Systemparameter CNC

Übersicht CNC Funktionalität der TwinCAT CNC, Stand Juni 2011

Erläuterung:

In der Spalte ISG stehen die Systemgrenzen bzw. die aktuell bei ISG zulässigen Werte. Sind dort z.B. allgemeine Angaben wie CPU oder Speicher gemacht, können die Einstellungen für die konkrete Steuerung (siehe Spalte TwinCAT CNC) aufgrund kundenspezifischer Anforderungen oder aufgrund von Beckhoff-Produktdefinitionen geändert werden.

1 | Bearbeitungstechnologien | ISG | TwinCAT CNC
1.1 | Drehen | √ | √
1.2 | Fräsen | √ | √
1.3 | Bohren | √ | √
1.4 | Schleifen | √ | √
1.5 | Handling | √ | √
1.6 | Sondermaschinen (Plasma-, Laser-, Brennschneiden, Biegen etc.) | √ | √

2 | Achssteuerung | ISG | TwinCAT CNC
2.1 | Maximale Achsanzahl | CPU, Speicher | 64
2.2 | Standardanzahl der Achsen |  | 8
2.3 | Maximale Anzahl der Achsen / Spindeln pro Kanal | 32 | 32
2.4 | Anzahl unabhängiger Kanäle | CPU, Speicher | 12
2.5 | Maximale Anzahl interpolierender Achsen pro Kanal | 32 | 32
2.6 | Maximale Anzahl geregelter Spindeln pro Kanal | CPU, Speicher | 6
2.7 | Maximale Anzahl unabhängiger Achsen im Kanal | 32 | 32
2.8 | SPS gesteuerte Spindeln pro Kanal | CPU, Speicher | 6
2.9 | Achsbezeichner im Kanal | Jeder String, der mit X, Y, Z, U, V, W, Q, A, B, C beginnt | Jeder String, der mit X, Y, Z, U, V, W, Q, A, B, C beginnt
2.10 | Maximale Anzahl der Synchronspindeln pro Kanal |  |
2.11 | Anzahl der definierbaren Koppelgruppen | Speicher | 7
2.12 | Anzahl der programmierbaren Achspaare innerhalb einer Koppelgruppe | Speicher | 15
2.13 | Maximale Anzahl der Gantry-Verbände | Speicher | 16 (16 Master, jeweils 1 Slave)
2.14 | Maximale Anzahl der Achsen innerhalb eines Gantry-verbandes | Speicher | 32 (1 Master, 31 Slave)
2.15 | Programmierbare Fahrbereichsbegrenzung (Softwareendschalter) | Ja | Ja
2.16 | Achsübergabe zwischen den Kanälen | CPU, Speicher | 32
2.17 | Programmierfeinheit | 0,0001 mm | 0,0001 mm
2.18 | Auflösung der Messignale | 0,0001 mm | 0,0001 mm
2.19 | Kleinstes programmierbares Inkrement | 0,0001 mm | 0,0001 mm
2.20 | Mehrfach Positionsmesssysteme |  |
2.21 | Umschaltung der Programmierung Inch/Metrisch | G70/G71 | G70/G71
2.22 | Umkehrspielkompensation | √ | √
2.23 | Achsfehlerkompensation richtungsabhängig (doppelseitige Spindelsteigungsfehlerkompensation) | Speicher | Je 1500 Punkte
2.24 | Kreuzkompensation Überhangkompensation | 1 Achse, Speicher | 1 Achse, 1000 Punkte
2.25 | Achsreferenzieren mit Endschalter und Nullimpuls | √ | √
2.26 | Geschwindigkeitsvorsteuerung | √ | √
2.27 | Beschleunigungsvorsteuerung | √ | √
2.28 | Messen | √ | √
2.29 | Achsposition zur SPS | √ | √
2.30 | Parametrierbare Achsfilter | √ | √
2.31 | Temperaturkompensation | √ | √
2.32 | Flächenkompensation | 2 Achsen, 100 Punkte | 2 Achsen, 100 Punkte
2.33 | Ruckvorsteuerung | √ | √
2.34 | Verfahrbereich Linearachse | -214m - +214m | -214m - +214m
2.35 | Verfahrbereich rotatorische Rundachse | -594 - +594 (Umdrehungen) | -594 - +594 (Umdrehungen)
2.36 | Verfahrbereich Rundachse Spindel | Unbegrenzt | Unbegrenzt
2.37 | Kreisradius | 0  106m | 0  106m
2.38 | Achsspezifische Transformation | Schubkurbel, E-Funktion | Schubkurbel, E-Funktion
2.39 | MAX_CROSSCOMP_CYC  Zyklenanzahl für die Kopplung der Kreuzkompensation (applikationsspezifisch) | 20 | 20

3 | Interpolationsfunktionen | ISG | TwinCAT CNC
3.1 | Kleinste Interpolationsgröße | 0,0001 mm | 0,0001 mm
3.2 | Eilgang | G0 | G0
3.3 | Linearinterpolation | G1 | G1
3.4 | Genauhalt | G60 | G60
3.5 | Zirkularinterpolation | G2/G3 | G2/G3
3.6 | Mittelpunktprogrammierung absolut / relativ | G161/G162 | G161/G162
3.7 | Radiusprogrammierung | √ | √
3.8 | Helikalinterpolation | G2/G3 | G2/G3
3.9 | Vorsteuerung /Schleppfehlerfreies Fahren | G135/G137 | G135/G137
3.10 | Prozentuale Gewichtung der Vorsteuerung | G136 | G136
3.11 | Verweilzeit | G4 | G4
3.12 | Stirnseitenbearbeitung | #FACE ON/OFF | #FACE ON/OFF
3.13 | Mantelflächenbearbeitung | #CYL ON/OFF | #CYL ON/OFF
3.14 | Gewindeschneiden | G33 | G33
3.15 | Mehrgängige Gewinde | G33 | G33
3.16 | Gewindebohren | G63 | G63
3.17 | Gewindebohren ohne Ausgleichsfutter | G63 | G63
3.18 | Schalttischklemmung (Clamping) | √ |
3.19 | NC-Satzvorausschau Look Ahead | 70 | 70
3.20 | Interpolationszykluszeit konfigurierbar | 0,5 bis 20 ms | 0,5 bis 20 ms
3.21 | Splineinterpolation | AKIMA/BSPLINE | AKIMA/BSPLINE
3.22 | Satzspezifische Parametrierung des Beschleunigungsprofiles | #SET SLOPE PROFIL | #SET SLOPE PROFIL
3.23 | Vorwärts-/Rückwärtsfahren auf der Bahn | √ | √

4 | Vorschubfunktionen | ISG | TwinCAT CNC
4.1 | Eilganggeschwindigkeit | 0,000001 - 3000 m/min | 0,000001 - 1000 m/min
4.2 | Eilgang-Override | √ | √
4.3 | Vorschubgeschwindigkeit | 0,000001 - 3000 m/min | 0,000001 - 1000 m/min
4.4 | Drehzahl | 0,00017  715828 U/min | 0,0002  100000 U/min
4.5 | Handeilgang | 0 - 3000 m/min | 0 - 1000 m/min
4.6 | Handvorschub | 0 - 3000 m/min | 0 - 1000 m/min
4.7 | Achsspezifischer Override | √ | √
4.8 | Vorschub pro Minute | G94 | G94
4.9 | Vorschub pro Umdrehung | G95 | G95
4.10 | Programmierung der Bearbeitungszeit | G93 | G93
4.11 | Satzübergangsverhalten | G8/G9 | G8/G9
4.12 | Vorschubhalt | √ | √
4.13 | Beschleunigungsrampe für Eilgang | √ | √
4.14 | Wichtungsfaktoren für die Beschleunigungsrampe | G132/G133 | G132/G133
4.15 | Konstante Schnittgeschwindigkeit | G96 | G96
4.16 | Vorschubanpassung bei aktiver Werkzeugradiuskompensation | G10/G11 | G10/G11
4.17 | Vorschubvorgabe durch PLC | √ | √
4.18 | Vorschubreduzierung durch PLC-Signal | √ | √

5 | 5-Achsfunktionen | ISG | TwinCAT CNC
5.1 | RTCP (rotation tool center point) | #RTCP ON/OFF | #RTCP ON/OFF
5.2 | TLC (tool length compensation) | #TLC ON/OFF | #TLC ON/OFF
5.3 | Ausrichtung des Werkzeuges | #TOOL ORI CS | #TOOL ORI CS
5.4 | Auswahl der Kinematik | #KIN ID | #KIN ID
5.5 | Definition eines Bearbeitungs-koordinatensystems | #CS ON/OFF | #CS ON/OFF
5.6 | Definition eines Koordinatensystems zur Aufspannlagenkorrektur | #ACS ON/OFF | #ACS ON/OFF
5.7 | Verkettung von Koordinatensystemen | Speicher | 10
5.8 | Effektorkoordinatensystem | #ECS ON/OFF | #ECS ON/OFF
5.9 | Temporärer Übergang in das Maschinenkoordinatensystem | #MCS ON/OFF | #MCS ON/OFF
5.10 | Kinematikbibliothek | √ | √
5.11 | Handbetrieb im Bearbeitungskoordinatensystem | √ | √

6 | Programmiereingaben | ISG | TwinCAT CNC
6.1 | Ausblendsatz | / | /
6.2 | Programmanzahl | Laden von Festplatte / Netzwerk | Laden von Festplatte / Netzwerk
6.3 | Beliebige Satznummerierung | √ | √
6.4 | Radius/Durchmesserprogrammierung | G51/G52 | G51/G52
6.5 | Interpolationsebenen | G17/G18/G19 | G17/G18/G19
6.6 | - |  |
6.7 | Rundachsbetrieb | √ | √
6.8 | Endlos drehende Rundachse | √ | √
6.9 | Frei definierbares Maschinenkoordinatensystem pro Kanal | G53 | G53
6.10 | Werkstückkoordinatensystem pro Kanal | #CS ON | #CS ON
6.11 | Werkstücknullpunkte pro Kanal | G54  G59 | G54  G59
6.12 | Erweiterte Werkstücknullpunkte | Speicher | 90
6.13 | Verdrehen des Koordinatensystems | √ | √
6.14 | Platzversätze | Speicher | 150 Gruppen
6.15 | Istwertsetzen | #PSET/#PRESET | #PSET/#PRESET
6.16 | Bezugspunktverschiebung | G92 | G92
6.17 | Anzahl additiver Koordinatensysteme | 5 | 10
6.18 | Fasen und Radien einfügen | G301/G302 | G301/G302
6.19 | Anzahl der P-Parameter pro Kanal | Speicher | 1000
6.20 | Dimension von Parameterarrays | Speicher | 4
6.21 | Globale Variablen V.P (nicht programmübergreifend) | Speicher | 1000
6.22 | Globale Variablen V.S (programmübergreifend) | Speicher | 400
6.23 | Lokale Variablen V.L (nicht programmübergreifend) | Speicher | 50
6.24 | Anzahl der Unterprogrammebenen | Speicher | 20
6.25 | Anzahl der Anwendermakros pro Kanal | Speicher | 100
6.26 | Spiegeln | G20/G21/G22/G23 | G20/G21/G22/G23
6.27 | Absolute/inkrementelle Angaben | G90/G91 | G90/G91
6.28 | Fertigungszeitberechnung | √ |
6.29 | Mathematische Funktionen | +, -, *, /, **, MOD, ABS, SQR, SQRT, EXP, LN, DEXP, &, |, ^, INV, LN, ==, !=, >=, <=, <, TRUE, FALSE, SIN, COS, TAN, ASIN, ACOS, ATAN, LOG, INT, FRACT, ROUND | +, -, *, /, **, MOD, ABS, SQR, SQRT, EXP, LN, DEXP, &, |, ^, INV, LN, ==, !=, >=, <=, <, TRUE, FALSE, SIN, COS, TAN, ASIN, ACOS, ATAN, LOG, INT, FRACT, ROUND
6.30 | Zeitmessungen | #TIMER | #TIMER
6.31 | Steuersatzanweisungen (Hochsprachenkonstrukte) | BREAK, CONTINUE, REPEAT, DO, FOR, GOTO, IF; ELSE; ENDIF, SWITCH, CASE, DEFAULT, ENDSWITCH, WHILE, ENDWHILE | BREAK, CONTINUE, REPEAT, DO, FOR, GOTO, IF; ELSE; ENDIF, SWITCH, CASE, DEFAULT, ENDSWITCH, WHILE, ENDWHILE
6.32 | Programmierung von Achsbezeichnungen | √ | √
6.33 | Meldungen aus dem NC-Programm | #MSG | #MSG
6.34 | Kanalübergreifende Synchronisation mit Parameterübergabe | #SIGNAL/WAIT | #SIGNAL/WAIT
6.35 | Aufspannlagenkompensation | #ACS ON/OFF | #ACS ON/OFF
6.36 | Definition und Aktivierung eines Bearbeitungskoordinatensystems | #CS ON/OFF | #CS ON/OFF
6.37 | Anwendermakros: Max. Stringlänge Makrosymbol | Speicher | 30
6.38 | Anwendermakros: Max. Stringlänge NC-Code | Speicher | 80
6.39 | Anwendermakros überschreibbar | √ | √
6.40 | Anwendermakros Schachtelungstiefe | Speicher | 14
6.41 | Anzahl Expressionlabel | Speicher | 200
6.42 | Anzahl Stringlabel | Speicher | 200
6.43 | Max. Stringlabellänge | Speicher | 30
6.44 | Nur P für Parameter | √ | √
6.45 | Max. Anzahl Übergabeparameter bei kanalübergreifender Synchronisation | Speicher | 12
6.46 | Max. Stringlänge von Achsnamen | Speicher | 16
6.47 | Arbeitsraumüberwachung | Speicher | 20 Räume, je 20 Punkte
6.48 | Wechsel absolut/inkrementell im NC-Satz | √ | √
6.49 | Achsunabhängige Zyklenprogrammierung | √ | √
6.50 | Anwendermakros: Initialisierung über Datei | √ | 50
6.51 | Einsatz Mehrfachwerkzeug (Fitting Zyklus) | √ | √

7 | Bedienen | ISG | TwinCAT CNC
7.1 | MDI-Betrieb pro Kanal | √ | √
7.2 | Satzvorlauf | √ | √
7.3 | Achsenreferenzieren | √ | √
7.4 | Einzelsatzbetrieb | √ | √
7.5 | Handbetrieb | √ | √
7.6 | Absolute Positionserfassung | √ | √
7.7 | Referenzpositionsverschiebung | √ | √
7.8 | Handradüberlagerung pro Kanal | √ | √
7.9 | Handradüberlagerung pro Achse | √ | √
7.10 | Handradempfindlichkeit | √ | √
7.11 | Handradunterbrechung | √ | √
7.12 | Joggbetrieb | √ | √
7.13 | Tippbetrieb | √ | √
7.14 | Programmierbarer Halt | M0 | M0
7.15 | Wahlweiser Halt | M1 | M1

8 | Spindel und Hilfsfunktionen | ISG | TwinCAT CNC
8.1 | Konfigurierbare M-Funktionen pro Kanal | Speicher | M0  M999
8.2 | Konfigurierbare H-Funktionen pro Kanal | Speicher | H0  H999
8.3 | Maximale Anzahl der M-/H-Funktionen pro NC-Satz | 15 | 20
8.4 | Konstante Schnittgeschwindigkeit pro Kanal | √ | √
8.5 | Werkzeugspezifische Grenzdrehzahl pro Spindel | √ | √
8.6 | Werkzeugspezifische Grenzbeschleunigung pro Spindel | √ | √
8.7 | Spindelsynchronisation | √ | √
8.8 | Mehrspindelansteuerung | Speicher | 6
8.9 | Spindelinterpolation (C-Achse) | √ | √
8.10 | Satzübergreifende Synchronisation von M-H-Funktion auf NC-Befehl | √ | √
8.11 | Satzübergreifende Synchronisation von M-H-Funktion auf G1 | √ | √
8.12 | Automatische Bestimmung der Getriebestufe | √ | M40  M45

9 | Werkzeugfunktionen | ISG | TwinCAT CNC
9.1 | Anzahl der internen Werkzeugplätze pro Kanal | Speicher | 200
9.2 | Anbindung externe Werkzeugverwaltung | √ | √
9.3 | Werkzeugnummer | T0 bis T2000000000 | T0 bis T2000000000
9.4 | Schwesterwerkzeuge und Varianten | √ | √
9.5 | Unterstützung Standzeitberechung | √ | √
9.6 | Programmierbare Werkzeugdaten | √ | √
9.7 | Freie werkzeugspezifische Parameter | Speicher | 60
9.8 | Werkzeugspezifische Minimal- und Maximaldrehzahl | √ | √
9.9 | Werkzeugspezfische Beschleunigung | √ | √
9.10 | Werkzeugspezifische Kinematik | √ | √
9.11 | Werkzeugoffsets in allen Achsen | √ | √
9.12 | Werkzeugspezifische Kinematikparameter | √ | √
9.13 | Werkzeuglängenkorrektur | D | D
9.14 | Werkzeugradiuskorrektur | G40/G41/G42 | G40/G41/G42
9.15 | Übergangselemente Radius / Fase | √ | √
9.16 | Direkte und indirekte Werkzeuganwahl | √ | √
9.17 | Schneidenradiuskorrektur | √ | √
9.18 | Anzahl Schwesterwerkzeuge und Varianten | 3 | 3
9.19 | Werkzeugverschleißkorrektur | √ | √
9.20 | Anwahlarten der Werkzeugradiuskorrektur | G05 G138/G138 G237/G238 | G05 G138/G138 G237/G238

10 | PLC-Funktionen | ISG | TwinCAT CNC
10.1 | Konfigurierbare CNC/PLC-Variablen und Variablenarrays | Speicher | 215 pro Kanal (Build 15xx: 225 pro Kanal)
10.2 | M-Funktionsvorausschau | Weg/Zeit | Weg/Zeit
10.3. | Strukturdefinition für CNC/PLC-Variablen | Speicher | 30 pro Kanal
10.4 | CNC/PLC-Variablen: Elemente pro Struktur | Speicher | 50 pro Kanal
10.5 | CNC/PLC-Variablen: Für Variablenstrukturen reservierte Strukturknoten | Speicher | 600 pro Kanal
10.6 | Erweiterte Stringlänge der CNC/PLC-Variablen | Speicher | 127 Zeichen

11 | Weitere Systemparameter | ISG | TwinCAT CNC
11.1 | Maximale Achsgeschwindigkeit | 1000 m/s | 1000 m/s
11.2 | Maximale Achsbeschleunigung | 1000 m/s2 | 1000 m/s2
11.3 | Minimale Rampenzeit | 0 s | 0 s
11.4 | Maximale Rampenzeit | 100 s | 100 s
11.5 | Maximaler Override | 2000  | 2000 

Conformity comparison between DIN-ISO programming and
TwinCAT CNC programming language syntax

The comparison is based on the DIN 66025 form sheets Part 1 (latest issue of Jan.1983) and Part 2 (latest issue of Sept.1988):

Table: Coding of preparatory functions G

N° | DIN/ISO Code | Description | TwinCAT Code | Conformity check
1 | G00 | Linear interpolation at high speed | G00 | in conformity
2 | G01 | Linear interpolation at programmed feed rate | G01 | in conformity
3 | G02 | Clockwise circular interpolation at programmed feed rate | G02 | in conformity
4 | G03 | Counterclockwise circular interpolation at programmed feed rate | G03 | in conformity
5 | G04 | Programmable dwell | G04 | in conformity
6 | G05 | free | G05 | Direct tangential selection/deselection of tool radius compensation
7 | G06 | Spline curve execution command | G151 | in conformity
8 | G07 | free | not assigned |
9 | G08 | Acceleration at the block beginning | G08 | in conformity
10 | G09 | Deceleration at the block end | G09 | in conformity
11 | G10 | free | G10 | Feedrate constant for tool radius compensation
12 | G11 | free | G11 | Feedrate adapted for tool radius compensation
13 | G12 | free | G12 | Deselection of corner deceleration
14 | G13 | free | G13 | Selection of corner deceleration
15 | G14 | free | not assigned |
16 | G15 | free | not assigned |
17 | G16 | free | not assigned |
18 | G17 | Selecting the working plane XY | G17 | in conformity
19 | G18 | Selecting the working plane ZX | G18 | in conformity
20 | G19 | Selecting the working plane YZ | G19 | in conformity
21 | G20 | free | G20 | Deselection of mirroring
22 | G21 | free | G21 | Mirroring of programmed path on the Y-axis
23 | G22 | free | G22 | Mirroring of programmed path on the X-axis
24 | G23 | free | G23 | Superimposing of G21 and G22
25 | G24 | free | not assigned |
26 | G25 | free | G25 | Linear transitions for WRK
27 | G26 | free | G26 | Circular transitions for WRK
28 | G27 | free | not assigned |
29 | G28 | free | not assigned |
30 | G29 | free | not assigned |
31 | G30 | free | not assigned |
32 | G31 | free | not assigned |
33 | G32 | free | not assigned |
34 | G33 | Thread cutting, uniform lead | G33 | in conformity
35 | G34 | Thread cutting, uniform increasing lead | not assigned | not realised
36 | G35 | Thread cutting, uniform decreasing lead | not assigned | not realised
37 | G36 | free | not assigned |
38 | G37 | free | not assigned |
39 | G38 | free | not assigned |
40 | G39 | free | not assigned |
41 | G40 | Deactive tool radius compensation | G40 | in conformity
42 | G41 | Activate tool radius compensation left of contour | G41 | in conformity
43 | G42 | Activate tool radius compensation right of contour | G42 | in conformity
44 | G43 | free | not assigned |
45 | G44 | free | not assigned |
46 | G45 | free | not assigned |
47 | G46 | free | not assigned |
48 | G47 | free | not assigned |
49 | G48 | free | not assigned |
50 | G49 | free | not assigned |
51 | G50 | free | not assigned |
52 | G51 | free | G51 | Selection of diameter programming
53 | G52 | free | G52 | Deselection of diameter programming
54 | G53 | Cancellation of zero offsets | G53 | in conformity
55 | G54 | Enabling zero offsets 1 | G54 | in conformity
56 | G55 | Enabling zero offsets 2 | G55 | in conformity
57 | G56 | Enabling zero offsets 3 | G56 | in conformity
58 | G57 | Enabling zero offsets 4 | G57 | in conformity
59 | G58 | Enabling zero offsets 5 | G58 | in conformity
60 | G59 | Enabling zero offsets 6 | G59 | in conformity
61 | G60 | free | G60 | Exact stop (Deceleration at end of block before continuation on next block)
62 | G61 | free | G61 | Selection of polynom contouring
63 | G62 | free | not assigned |
64 | G63 | Tapping | G63 | in conformity
65 | G64 | free | not assigned |
66 | G65 | free | not assigned |
67 | G66 | free | not assigned |
68 | G67 | free | not assigned |
69 | G68 | free | not assigned |
70 | G69 | free | not assigned |
71 | G70 | Inch data input | G70 | in conformity
72 | G71 | Metric data input | G71 | in conformity
73 | G72 | free | not assigned |
74 | G73 | free | not assigned |
75 | G74 | Homing | G74 | in conformity
76 | G75 | free | not assigned |
77 | G76 | free | not assigned |
78 | G77 | free | not assigned |
79 | G78 | free | not assigned |
80 | G79 | free | not assigned |
81 | G80 | Machining cycle cancel | G80 or not assigned | Implicit sub programm call (if name is configured)
82 | G81 | Center drilling cycle | G81 or not assigned | Implicit sub programm call (if name is configured)
83 | G82 | Counterboring cycle | G82 or not assigned | Implicit sub programm call (if name is configured)
84 | G83 | Peck drilling cycle | G83 or not assigned | Implicit sub programm call (if name is configured)
85 | G84 | (Rigid)Tapping cycle | G84 or not assigned | Implicit sub programm call (if name is configured)
86 | G85 | Boring cycle | G85 or not assigned | Implicit sub programm call (if name is configured)
87 | G86 | Boring canned cycle with spindle stop at drilling depth | G86 or not assigned | Implicit sub programm call (if name is configured)
88 | G87 | Drilling canned cycle with chip breaking | G87 or not assigned | Implicit sub programm call (if name is configured)
89 | G88 | Boring and traverse turning canned cycle | G88 or not assigned | Implicit sub programm call (if name is configured)
90 | G89 | Boring cycle with dwell in hole bottom | G89 or not assigned | Implicit sub programm call (if name is configured)
91 | G90 | Programming in absolute dimensions with respect to the program origin | G90 | in conformity
92 | G91 | Programming in incremental dimensions with respect to the start of the block. | G91 | in conformity
93 | G92 | Setting the part program origin | G92 | in conformity
94 | G93 | Inverse time feedrate in 1/min. | G93 | Machining time in sec.
95 | G94 | Feed rate expressed in mm/min, inch/min,deg /min | G94 | in conformity
96 | G95 | Feed rate expressed in mm/revolution, inc/revolution | G95 | in conformity
97 | G96 | Constant cutting speed in m/min | G96 | in conformity
98 | G97 | Spindle speed expressed in revolutions/min | G97 | in conformity
99 | G98 | free | G98 | Set negative software limit switch
100 | G99 | free | G99 | Set positive software limit switch
End of DIN/ISO-Definition

Table: Coding of miscellaneous functions M

N° | DIN/ISO Code | Description | TwinCAT Code | Conformity check
1 | M00 | Program stop | M00 | in conformity
2 | M01 | Optional stop | M01 | in conformity
3 | M02 | End of program | M02 | in conformity
4 | M03 | Clockwise spindle rotation (class1-3) or cutting on (class 4) | M03 | in conformity (method of operation is configurable)
5 | M04 | Counterclockwise spindle rotation (class1-3) or cutting off (class 4) | M04 | in conformity (method of operation is configurable)
6 | M05 | Spindle stop (class1-3) or free (class 4) | M05 | in conformity (method of operation is configurable)
7 | M06 | Tool change | M6 or not assigned | Implicit sub programm call (if name is configured)
8 | M10 | Clamp | M10 | in conformity
9 | M11 | Unclamp | M11 | in conformity
10 | M17 | free | M17 | End of subroutine
11 | M19 | Spindle positioning (class1-3) or free (class 4) | M19 | in conformity (method of operation is configurable)
12 | M29 | free | M29 | End of subroutine
13 | M30 | End of program | M30 | in conformity
14 | M40 | Automatic gear switching (class1-3) or free | M40 or not assigned | in conformity
15 | M41 | Gear step 1 (class1-3) or free | M41 or not assigned | in conformity
16 | M42 | Gear step 2 (class1-3) or free | M42 or not assigned | in conformity
17 | M43 | Gear step 3 (class1-3) or free | M43 or not assigned | in conformity
18 | M44 | Gear step 4 (class1-3) or free | M44 or not assigned | in conformity
19 | M45 | Gear step 5 (class1-3) or free | M45 or not assigned | in conformity
20 | M48 | Enable overrides | G166/G167 | Selection of path/spindle override 100% (Block local)
21 | M49 | Disable overrides | not assigned |
22 | M60 | Work piece change | not assigned |
The meanings of all further M-Functions are configurable corresponding to the class specific use defined in DIN/ISO code.

Table: Adress characters and special characters

N° | DIN/ISO Code | Description | TwinCAT Code | Conformity check
1 | A | Rotation around X | A | in conformity
2 | B | Rotation around Y | B | in conformity
3 | C | Rotation around Z | C | in conformity
4 | D | Tool data | D | in conformity (Time of activation of tool offsets is configurable)
5 | E | free | not assigned |
6 | F | Path feed | F | in conformity
7 | G | Path conditions | G | in conformity
8 | H | free | H | Additional technology functions (corr. to M-functions)
9 | I | Interpolation parameter for X | I | in conformity
10 | J | Interpolation parameter for Y | J | in conformity
11 | K | Interpolation parameter for Z | K | in conformity
12 | L | free | L/LL | Definition/Call of subroutines
13 | M | Additional technology functions | M | in conformity
14 | N | Block number | N | in conformity
15 | O | free | not assigned |
16 | P | free | P | Parameters
17 | Q | free | Q | Free configurable axis
18 | R | free | R | Circle radius or indirect parameter
19 | S | Spindel speed | S | in conformity
20 | T | Tool selection | T | in conformity
21 | U | Movement parallel to X-axis | U | in conformity
22 | V | Movement parallel to Y-axis | V | in conformity
23 | W | Movement parallel to Z-axis | W | in conformity
24 | X | Movement in direction of X-axis | X | in conformity
25 | Y | Movement in direction of Y-axis | Y | in conformity
26 | Z | Movement in direction of Z-axis | Z | in conformity
27 | % | Program beginning | % | in conformity
28 | ( | Comment start | ( | in conformity
29 | ) | Comment end | ) | in conformity
30 | + | Plus | + | in conformity
31 | - | Minus | - | in conformity
32 | . | Decimal point | . | in conformity
33 | / | Block skipping | / | in conformity
34 | : | Main block, conditional stopp of the program reset | : | Marker for definition of an expression label (block number)
35 | ; | Comment start | ; | Comment until block end