Begriffsdefinitionen

Allgemein:

ID Identifier; allg. Kennung

RT Rückwärtstransformation

TCP Tool-Center-Point; Mittelpunkt des Fräsers

VT Vorwärtstransformation

MK Maschinenkoordinaten

MKS Maschinenkoordinatensystem

WKS Werkstückkoordinatensystem

sonstige Abkürzungen

HDi: Kinematikversatzmaß


Einleitung

Bei den im folgenden aufgeführten Transformationen handelt es sich um 3, 4 ,5 und 6 achsige kinematische Transformationen die bei Maschinen mit nicht kartesischer Achsanordnung oder Maschinen mit rotatorischen Achsen zur Einstellung der Orientierung dann erforderlich sind, wenn im WKS programmiert werden soll. Im allgemeinen erhält man in diesem Fall nichtlineare Gleichungen die den Zusammenhang zwischen Werkstückkoordinaten und Maschinenkoordinaten wiederspiegeln.

Als Werkstückachsen werden Achsen bezeichnet die in der kinematischen Kette auf der Werkstückseite liegen. Als Werkzeugachsen werden Achsen auf der Werkzeugseite bezeichnet.

Es werden folgende Transformationstypen unterschieden:

− RTCP Transformation: Hierbei werden Raumpositionen im WKS programmiert, die Einstellung der Werkzeugrichtung erfolgt über die Programmierung der rotatorischen Maschinenachsen (z. B. B und C abhängig von Maschine). Hilfsfunktionen erlauben die automatische Werkzeugausrichtung auf gedrehte Koordinatensysteme im Raum.

Beispiel für NC Prg. Zeile: N10 X100 Y20 Z30 B0 C0

− Vollständige Transformation: Hierbei erfolgt die Programmierung von Raumkurven und der Bearbeitungsorientierung des Werkzeugs über Position und Orientierung (Punkt Vektor Folgen) also grundsätzlich unabhängig vom Maschinentyp mit 6 Koordinaten (*).

Beispiel für NC Prg. Zeile: N10 X100 Y20 Z30 A0 B0 C1

(*) Abhängig von den Freiheitsgraden einer Kinematik kann ggf. nur die Position über 3 Koordinaten programmiert werden (z. B. Tripod).

Die zur Verwendung einer bestimmten Kinematik notwendige ID ergibt sich aus dem angegebenen Kinematiktyp wie folgt:

KIN_TYP_1 1

KIN_TYP_2 2

.....usw.

Die HDi Versätze einer Kinematik korrespondieren zu den Kinematik-Offsets in den Kanalparametern (kinematik[ID].wz_kopf_versatz[i-1] Versionsstand 2.6.0. bzw. kinematik[ID].param[i-1] ab Versionsstand 2.6.3). Diese Offsets können auch alternativ im entsprechenden Wert der Werkzeugparameter eingetragen werden (P-TOOL-00009). Die Einheit der Versätze ist 0.1 μ m. Bei aktiver kinematischer Transformation werden achsspezifische Werkzeugversätze aus ax_versatz[ACHS_INDEX] nur in den Achsen berücksichtigt die nicht von der Transformationsfunktion beeinflusst werden. Abhängig vom Transformationstyp sind dies z.B. bei RTCP typischerweise alle Achsen oberhalb die ersten drei Achsen mit Index 0.. 2.

Die erforderliche kinematikspezifische Achskonfiguration ist in den Kanalparametern herzustellen. Dabei ist auf die korrekte Achsindexsequenz für die ausgewählte Transformation zu achten.

Mehr:

button Rotatorachsen und Drehrichtung

button Linearachsen und Bewegungsrichtung


Rotatorachsen und Drehrichtung

Im nachfolgenden Bild sind die positiven Drehrichtungen von rotatorischen Achsen dargestellt. Basis ist ein rechtsdrehendes kartesisches Koordinatensystem. Die Drehung ist dann positiv wenn mit Blick auf die Pfeilspitze der Koordinatensystemachse die Rotation gegen den Uhrzeigersinn erfolgt. Dreht sich die Rotatorachse um die X-Achse, wird diese als A-Achse bezeichnet, bei Drehung um Y-Achse als B-Achse usw.. Wenn nicht gesondert anders angeführt, liegen diese Drehrichtungen den kinematischen Transformationen mit Rotatorachsen zugrunde.

Abbildung 1-1: Koordinatensysteme und Bewegungsrichtungen


Linearachsen und Bewegungsrichtung

Die Bewegungsrichtung bei Linearachsen ist so einzustellen, das sich eine Relativbewegung zwischen Werkzeug und Werkstück wie bei 2.5 D Betrieb ergibt. Wenn also Linearachsen das Werkstück bewegen, so ist deren Bewegungsrichtung entgegengesetzt zu den Richtungen der Achsen des Werkstückkoordinatensystems.


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_1

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik dieser Maschine besteht aus zwei translatorischen Achsen und einer rotatorischen Achse im Werkstück sowie einer translatorischen und einer rotatorischen Achse im Werkzeug.

Achskonfiguration im NC-Kanal
Achsbezeichner | X,Y, Z, B, C
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | Z, B | X, Y, C

Abbildung 2-1: Kinematik der Einständerbettmaschine

Abbildung 2-2: Versätze im Werkzeugkopf

Abbildung 2-3: Versätze am Werkstückträger

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Versatz Werkzeugeinspannpunkt bis Drehpunkt B Achse
HD2 | 1 | Z-Versatz Drehpunkt B-Achse bis Bzpkt. WZ-Schlitten
HD3 | 2 | X-Versatz Bzpkt. WZ-Schlitten bis Drehpunkt B-Achse
HD4 | 3 | Y- Versatz Bzpkt. WZ-Schlitten bis Drehpunkt B-Achse
HD5 | 4 | X- Versatz Drehpunkt B Achse bis Werkzeugeinspannpunkt
HD6 | 5 | Y- Versatz Drehpunkt B Achse bis Werkzeugeinspannpunkt
HD7 | 6 | X- Versatz Maschinennullpunkt MNP zu Drehachse C
HD8 | 7 | Y- Versatz Maschinennullpunkt MNP zu Drehachse C
HD9 | 8 | Z- Versatz Maschinennullpunkt MNP zu Drehachse C
HD13 | 12 | Drehrichtung B-Achse (*), 0: negativ, 1 positiv
HD14 | 13 | Drehrichtung C-Achse, 0 positiv, 1 negativ

(*) Die Drehrichtung der B-Achse ist mathematisch negativ !


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_2

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik dieser Maschine besteht aus drei translatorischen Achsen und zwei rotatorischen Achsen im Werkzeug (Dreh-/Schwenkkopf).

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, A, B
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, A, B | -

Abbildung 2-4: Kinematik der fünfachsigen Fräsmaschine mit Dreh-Schwenkkopf

Zur Beschreibung des Dreh-/Schwenkkopfs der Maschine aus Abbildung 2-4 sind die Geometriekonstanten HD1, HD2 und HD3 notwendig und wie in Abbildung 2-5 gezeigt zu verwenden. Der Dreh-/Schwenkkopf ist dabei in der Draufsicht gezeichnet.

Abbildung 2-5: Die fünf Größen L, TX, HD1, HD2 und HD3 des Dreh-/Schwenkkopfes

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Versatz Werkzeugeinspannpunkt bis Drehpunkt B Achse
HD2 | 1 | Y Versatz von B Achse zu A Achse
HD3 | 2 | X Versatz von B Achse zu A Achse


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_3, 4

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik dieser Maschine besteht aus drei translatorischen Achsen und einer rotatorischen Achsen im Werkzeug (Doppelspindelkopf).

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, B
Achsindex | 0, 1, 2, 3,
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, B | -

Abbildung 2-6: Kinematik der 4-achsigen Fräsmaschine mit Doppelspindelkopf

Abbildung 2-7: Der Doppelspindelkopf in Seiten- und Vorderansicht

Der Aufbau des Fräskopfes ist in Abbildung 2-7 für die Nullstellung der B-Achse dargestellt. Er besitzt zwei Spindeln (im folgenden obere und untere Spindel genannt, unabhängig von der momentanen Position der B-Achse), so daß zwei Werkzeuge einspannbar sind, die um 180° gegeneinander verdreht sind.

Die Auswahl welche der beiden Spindeln bzw. welches der zwei Werkzeuge momentan aktiv ist soll durch einen Befehl im NC-Programm möglich sein.

Beim aktiver oberer Spindel muß der programmierte Wert für die B-Achse folgendermaßen verändert werden:

Ein Wechsel der Spindel bedeutet somit eine Drehung der B-Achse um 180° sowie bedingt durch die Geometriekonstanten bei aktivem RTCP translatorische Verschiebungen aller drei Linearachsen.

Spindelselektion:

KIN_TYP_3 = obere Spindel

KIN_TYP_4 = untere Spindel

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Versatz Werkzeugeinspannpunkt bis Drehpunkt B Achse
HD2 | 1 | Y Versatz Werkzeugkopf
HD3 | 2 | X Versatz von Werkzeugeinspannpunkt zu B Achse


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_5

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen Achsen und einer rotatorischen Achse im Werkzeug.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C
Achsindex | 0, 1, 2, 3,
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, C | -

Abbildung 2-8: Vierachsige Kinematik mit Kreuzkopf für 4 Werkzeuge

Abbildung 2-9: Werkzeugkreuzkopf

Die Angabe, welches Werkzeug momentan aktiv ist, erfolgt durch die Belegung des Werkzeugversatzes HD6 der C-Achse. HD6 wird von der Nullstellung der C-Achse (Y-Achse) zur Werkzeugposition hin positiv gerechnet.

Sind die vier Werkzeuge wie in Abbildung 2-9 gezeichnet rechtwinklig zueinander angeordnet, so ergibt sich beim Wechsel der Spindel eine Drehung der C-Achse um 90° bzw. 180° sowie bedingt durch die Geometriekonstanten bei aktivem RTCP translatorische Verschiebungen der X- und Y-Achse.

Abbildung 2-10: Werkzeugkreuzkopf mit Nullstellungen der Werkzeuge 1..4

Für jedes Werkzeug des Kopfes ist ein Datensatz mit Kopfparametern zu halten. Über den zugeordneten Werkzeugkopfdatensatz wird eines der Werkzeuge 1..4 selektiert.

Zur Vermaßung der Kopfversätze der einzelnen Werkzeuge wird das zugehörige Werkzeug über eine Drehung in die Nullstellung des Werkzeugs 1 gebracht (positive y-Richtung). Neben den einheitlichen Kopfparametern HD1, HD4, HD5 wird das Werkzeug 1 und 2 über den Kopfparameter HD2 parametriert, Werkzeug 3 und 4 über Kopfparameter HD3.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Versatz Werkzeugeinspannpunkt zu Bezugspunkt
HD2 | 1 | Versatz Bezugspunkt Drehmittelpunkt C Achse Werkzeug 1 und 2
HD3 | 2 | Versatz Bezugspunkt Drehmittelpunkt C Achse Werkzeug 3 und 4
HD4 | 3 | Z Achsversatz Werkzeugeinspannpunkt
HD5 | 4 | Rotatorischer Winkelversatz C Achsnullposition
HD7 | 6 | statischer Werkzeugversatz in X
HD8 | 7 | statischer Werkzeugversatz in Y


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_6

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen Achsen und einer rotatorischen Achse im Werkzeug. Als Besonderheit weist bei dieser Kinematik das Werkzeug in positive Z-Richtung.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C
Achsindex | 0, 1, 2, 3,
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, C | -

Abbildung 2-11: Vierachsige Kinematik mit Unterflur-Fräswerkzeug

Abbildung 2-12:Werkzeugkopf zum Unterflurfräsen (Ruhestellung mit HD4 = 0)

Die Achsen sind im Sinne eines Rechtssystems angeordnet. Die Nullstellung der C-Achse liegt in positiver Richtung der Y-Achse.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD2 | 1 | Z Achsversatz Werkzeugeinspannpunkt
HD3 | 2 | Y Achsversatz Drehachse C zu Werkzeugdrehachse
HD4 | 3 | Rotatorischer Winkelversatz C Achsnullposition
HD7 | 6 | statischer Werkzeugversatz in X
HD8 | 7 | statischer Werkzeugversatz in Y


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_7

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen NC-Achsen und einer rotatorischen NC-Achse im Werkzeug . Weiterhin steht eine manuell einstellbare rotatorische fünfte Achse zur Verfügung. Diese Achse ist also vom NC-Programm aus nicht ansprechbar.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C
Achsindex | 0, 1, 2, 3,
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, C | -
Hilfsachsen | A | -

Abbildung 2-13: Vierachsige Kinematik (Bohr und Fräswerkzeug mit manueller Hilfsachse A )

Abbildung 2-14: Vierachsiges Bohr-/Fräswerkzeug (Ruhestellung mit HD3 = 0, HD4 = 0, CM=0)

Die Achsen sind im Sinne eines Rechtssystems angeordnet. Die Nullstellung der A-Achse liegt in negativer Richtung der Z-Achse.

Bei dem 4 achsigen Werkzeugkopf mit manuell einstellbarer A-Achse ist die automatische Orientierungseinstellung von der Stellung der A-Achse abhängig. Stimmen physikalische Maschinenachsposition und Wert im HD-Parameter der A-Achse nicht überein, so ist keine korrekte automatische Ausrichtung möglich.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Achsversatz Werkzeugeinspannpunkt bis Drehpunkt A Achse (Schwenkachse)
HD2 | 1 | Z Achsversatz Drehpunkt A Achse zu Werkzeugkopfbezugspunkt
HD3 | 2 | Feste Winkeleinstellung von rotatorischer A Achse (Schwenkachse)
HD4 | 3 | Winkelversatz Werkzeug zu C Achsnullposition
HD5 | 4 | Y Achsversatz Drehpunkt A Achse zu Drehpunkt C Achse (Kröpfung)
HD6 | 5 | X Achsversatz Werkzeugkopfbezugspunkt bis Drehpunkt C Achse (Kröpfung)
HD7 | 6 | Statischer Werkzeugversatz in X
HD8 | 7 | Statischer Werkzeugversatz in Y


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_8

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen NC-Achsen und einer rotatorischen NC-Achse im Werkzeug. Weiterhin steht eine manuell einstellbare rotatorische fünfte Achse zur Verfügung. Diese Achse ist vom NC-Programm aus nicht ansprechbar.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C
Achsindex | 0, 1, 2, 3,
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, C | -
Hilfsachsen | A | -

Abbildung 2-15: Vierachsige Kinematik (Sägewerkzeug mit manueller Hilfsachse A)

Abbildung 2-16: Vierachsiges Sägewerkzeug (Ruhestellung mit HD5 = 0, HD4 = +90,CM=0)

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD2 | 1 | Y Achsversatz von Werkzeugeinspannpunkt bis Drehpunkt A Achse (Schwenkachse)
HD3 | 2 | Z Achsversatz von Drehpunkt A Achse zu Werkzeugbezugspunkt
HD4 | 3 | Feste Winkeleinstellung von rotatorischer A Achse (Schwenkachse)
HD5 | 4 | Rotatorischer Winkelversatz C Achse
HD7 | 6 | statischer Werkzeugversatz in X
HD8 | 7 | statischer Werkzeugversatz in Y


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_9

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen NC-Achsen und zwei rotatorischen NC-Achsen im Werkzeug .

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C, A
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, C, A | -

Abbildung 2-17: Fünfachsige Kinematik (Bohr- und Fräsaggregat)

Abbildung 2-18: Fünfachsiges Bohr-/Fräswerkzeug (Ruhestellung mit HD3 = 0, AM=0, HD4=0, CM=0)

Bei dem 4 achsigen Werkzeugkopf mit manuell einstellbarer A-Achse ist die automatische Orientierungseinstellung von der Stellung der A-Achse abhängig. Stimmen physikalische Maschinenachsposition und Wert im HD-Parameter der A-Achse nicht überein, so ist keine korrekte automatische Ausrichtung möglich.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Achsversatz von Werkzeugeinspannpunkt bis Drehpunkt A Achse (Schwenkachse)
HD2 | 1 | Z Achsversatz Drehachse A zu Werkzeugkopfbezugspunkt
HD3 | 2 | Rotatorischer Winkelversatz A Achse (Defaultwert 0)
HD4 | 3 | Rotatorischer Winkelversatz C Achse (Defaultwert 0)
HD5 | 4 | Y Achsversatz Drehpunkt C Achse
HD6 | 5 | X Achsversatz Drehpunkt C Achse
HD7 | 6 | statischer Kopfversatz in X (Defaultwert 0)
HD8 | 7 | statischer Kopfversatz in Y (Defaultwert 0)
HD9 | 8 | Y Achsversatz Fräserachse zu Drehpunkt A-Achse


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_10

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen NC-Achsen und zwei rotatorischen NC-Achsen im Werkzeug .

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C, A
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, C, A | -

Abbildung 2-19: Fünfachsige Kinematik (Sägewerkzeug)

Abbildung 2-20: Fünfachsiges Sägewerkzeug (Ruhestellung mit HD5 =0, CM=0, HD4 =0, AM =90)

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD2 | 1 | Y Achsversatz von Werkzeugeinspannpunkt bis Drehpunkt A Achse (Schwenkachse)
HD3 | 2 | Z Achsversatz von Drehpunkt A Achse (Schwenkachse) zu Werkzeugbezugspunkt
HD4 | 3 | Rotatorischer Winkelversatz A Achse
HD5 | 4 | Rotatorischer Winkelversatz C Achse
HD7 | 6 | statischer Werkzeugversatz in X
HD8 | 7 | statischer Werkzeugversatz in Y


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_11

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen kartesischen Achsen und zwei rotatorischen Achsen. Als Besonderheit weist die Maschine die schräg aufgesetzte B-Achse auf.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, A, B
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, B | Z, A

Abbildung 2-21: Achskonfiguration der fünfachsigen Maschine mit Schrägwinkelkopf

Abbildung 2-22: Winkel und Längen am Schrägwinkelkopf

Bei der Kinematik fällt besonders die Konstruktion der schiefwinkligen B-Achse auf: Wird die Werkzeuglänge so gewählt, daß der TCP (Tool Center Point) genau auf der Verlängerung der B-Achse zu liegen kommt (Werkzeugversatz HDZ), so sind bei Änderungen der Werkzeugorientierung über die B-Achse keine Ausgleichsbewegungen in den translatorischen Achsen notwendig (Ausgleichsbewegungen aufgrund von Orientierungsänderung in der A-Achse sind immer vorhanden). Ist die Werkzeuglänge nicht ideal gewählt, also der TCP nicht exakt auf der Verlängerung der B-Achse, so ergeben sich geringfügige zusätzliche Ausgleichsbewegungen auf den linearen Achsen, je nach Abweichung von der idealen Länge.

Durch die besondere Konstruktion der B-Achse können keine singulären Stellen bei der Rückwärtstransformation der Orientierungsachsen auftreten, jedoch können auch nicht alle beliebigen Werkzeugorientierungen eingestellt werden (s.u.).

Die Nullstellungen der Maschinenachsen XM, YM, ZM werden so gewählt, daß sich die gedachten Verlängerungen von AM und BM schneiden. Die Nullstellung von BM wird so gewählt, daß bei bM=0 das Werkzeug senkrecht und damit parallel zu Z0 steht (Abbildung 2-21 zeigt die Nullstellung von BM). Die Nullstellung von AM wird sinnvollerweise so festgelegt, daß die Y0 ,Z0 -Werkstückachsen parallel zu den Maschinenachsrichtungen verlaufen.

HDZ repräsentiert die ideale Werkzeuglänge als Geometrieparameter der Maschinenkinematik; HD1 repräsentiert den ersten Werkzeugkopfparameter sowie L die tatsächliche Werkzeuglänge (Fräserlänge).

Es ist zu beachten, daß l vorzeichenbehaftet ist, also auch negativ sein kann.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Achsversatz Werkzeugeinspannpunkt bis Werkzeugkopfbezugspunkt
HD2 | 1 | Ideale Werkzeuglänge
HD3 | 2 | Winkel zwischen B Achse und Z Achse (Schrägwinkel)


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_12

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die als Tripod bezeichnete Stabkinematik besteht aus drei nicht kartesisch angeordneten translatorischen Achsen. Jeweils zwei zueinander parallele Stäbe tragen die Werkzeugträgerplattform. Die Werkzeugorientierung ist konstant.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z (Z1, Z2, Z3)
Achsindex | 0, 1, 2
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z | -

Abbildung 2-23: Tripod Kinematik

Abbildung 2-24: Vektordarstellung der Stabkinematik

Abbildung 2-25: Versatzmaße der Stabkinematik

Mit dem Paramter HD8 läßt sich zwischen einem idealen (1) und nichtidealen(0) Tripod umschalten. Eine idealer Tripod hat zwischen allen Säulen eine Winkel von 120°. Der nichtideale Tripod muss durch die Winkel HD9 und HD10 definiert werden. Der dritte Winkel zwischen den Säulen berechnet sich aus:

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Werkzeugversatz
HD2 | 1 | Y Werkzeugversatz
HD3 | 2 | X Werkzeugversatz
HD4 | 3 | Z Achsversatz Maschinennullpunkt
HD5 | 4 | Radius zu Verbindungslinie Gelenkmittelpunkte Antriebssäulen(großer Kreis)
HD6 | 5 | Radius zu Verbindungslinie Gelenkmittelpunkte Stewardplattf (kleiner Kreis)
HD7 | 6 | Stablänge jeweils bis Gelenkmittelpunkt
HD8 | 7 | Schalter zum umschalten auf nichidealen Tripod (freischalten HD9 / HD 10)
HD9 | 8 | Winkel Säule / Gelenk 3 zu Säule / Gelenk 1
HD10 | 9 | Winkel Säule / Gelenk 3 Säule / Gelenk 2


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_16

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen und zwei rotatorischen NC-Achsen im Werkzeug .

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, B, A
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, B, A | -

Abbildung 2-26: Achskonfiguration der fünfachsigen Maschine

Abbildung 2-27: Parameter des Dreh-Schwenkkopfes

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Versatz bis Einspannpunkt WZ
HD2 | 1 | X Versatz
HD3 | 2 | Y Versatz
HD4 | 3 | Z Versatz
HD5 | 4 | X Versatz
HD6 | 5 | Y Achsversatz WZ
HD7 | 6 | Rotatorischer Versatz A Achse
HD8 | 7 | Rotatorischer Versatz B Achse
HD9 | 8 | Vorzeichen Drehrichtung A Achse
HD10 | 9 | Vorzeichen Drehrichtung B Achse


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_17

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen NC-Achsen. Weiterhin stehen zwei manuell einstellbare rotatorische Achsen zur Verfügung. Diese Achsen sind vom NC-Programm aus nicht ansprechbar.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z
Achsindex | 0, 1, 2
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z | -
Hilfsachsen | C, A | -

Abbildung 2-28: Dreiachsige Kinematik (Bohr und Fräswerkzeug mit manuellen Hilfsachsen C und A )

Abbildung 2-29: Bohr-/Fräswerkzeug (Ruhestellung mit HD3 = 0, HD4 = 0)

Die Achsen sind im Sinne eines Rechtssystems angeordnet. Die Nullstellung der A-Achse liegt in negativer Richtung der Z-Achse. Bei dem 2 achsigen Werkzeugkopf mit manuell einstellbarer C-Achse und A-Achse ist keine automatische Orientierungseinstellung möglich.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Achsversatz Werkzeugeinspannpunkt bis Drehpunkt A Achse (Schwenkachse)
HD2 | 1 | Z Achsversatz Drehpunkt A Achse zu Werkzeugkopfbezugspunkt
HD3 | 2 | Feste Winkeleinstellung von rotatorischer A Achse (Schwenkachse)
HD4 | 3 | Feste Winkeleinstellung von rotatorischer C -Achse
HD5 | 4 | Y Achsversatz Drehpunkt A Achse zu Drehpunkt C Achse (Kröpfung)
HD6 | 5 | X Achsversatz Werkzeugkopfbezugspunkt bis Drehpunkt C Achse (Kröpfung)
HD7 | 6 | Statischer Werkzeugversatz in X
HD8 | 7 | Statischer Werkzeugversatz in Y


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_18

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen NC-Achsen. Weiterhin stehen zwei manuell einstellbare rotatorische Achsen zur Verfügung. Diese Achsen sind vom NC-Programm aus nicht ansprechbar.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z
Achsindex | 0, 1, 2
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z | -
Hilfsachsen | C, A | -

Abbildung 2-30: Dreiachsige Kinematik (Sägewerkzeug mit manuellen Hilfsachsen C und A)

Abbildung 2-31: Sägewerkzeug (Ruhestellung mit HD5 = 0, HD4 = +90)

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD2 | 1 | Y Achsversatz von Werkzeugeinspannpunkt bis Drehpunkt A Achse (Schwenkachse)
HD3 | 2 | Z Achsversatz von Drehpunkt A Achse zu Werkzeugbezugspunkt
HD4 | 3 | Feste Winkeleinstellung von rotatorischer A Achse (Schwenkachse)
HD5 | 4 | Feste Winkeleinstellung von rotatorischer C Achse
HD7 | 6 | statischer Werkzeugversatz in X
HD8 | 7 | statischer Werkzeugversatz in Y


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_19

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Stabkinematik besteht aus drei nicht kartesisch angeordneten translatorischen Achsen und zwei kartesischen Achsen. Drei Stäbe mit Kugelgelenken tragen die Werkstückplattform. Dadurch kann die Z-Höhe und die Orientierung des Werkstücks beeinflußt werden.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, U, V, W (X,Y,Z1,Z2,Z3,W)
Achsindex | 0, 1, 2, 3, 4, 5
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y | Z1, Z2, Z3

Abbildung 2-32: Tripod Kinematik

Abbildung 2-33: Versätze der Kinematik

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Werkzeugversatz in Z
HD2 | 1 | Stablänge jeweils bis zu Gelenkmittelpunkt
HD3 | 2 | Radius zu Verbindungslinie Gelenkmittelpunkte Stewardplattform (kleiner Kreis)
HD4 | 3 | Radius zu Verbindungslinie Gelenkmittelpunkte Antriebssäulen (großer Kreis)
HD5 | 4 | Abstand Werkstückträgerplattform zu den Gelenkmittelpunkten auf der Stewardplattform


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_21

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus 3 translatorischen NC-Achsen und einer rotatorischen NC-Achse im Werkzeug.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C (X1, X2, Z, C)
Achsindex | 0, 1, 2, 3
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X,Y, Z, C | -

Abbildung 2- 34 : Lambda Kinematik

Die ebene XY Kinematik ist als eine der Varianten der Scherenkinematik bekannt. Auf zwei Linearschlitten XM1 und XM2 befinden sich an den Drehgelenken C und B die Stäbe (Länge l2, l1) die am Punkt D ebenfalls drehbar miteinander verbunden sind. Über den fixen Winkel β ist der Stab CA (Länge l3) an Stab CD befestigt. An der Spitze dieses Stabes befindet sich die C Achse. Der eigentliche werkzeugtragende Stab (Länge l4) beginnt im Drehpunkt der C-Achse und endet im TCP. Die C-Achse ist bezogen auf die kartesischen Achsen nicht mechanisch geführt d.h. sie muß abhängig von der Gelenkstellung kompensiert werden.

Abbildung 2- 35 : Lambda Kinematik, Variante 1

Abbildung 2- 36 : Lambda Kinematik, Variante 2

Versatzdaten der Kinematik:

Parameter | Bedeutung | HD-Versatz | param[i]
- | Z-Offset bis Einspannpunkt WZ | HD1 | 0
l1 | Stablänge 1 | HD2 | 1
l2 | Stablänge 2 | HD3 | 2
l3 | Stablänge 3 | HD4 | 3
g_s | Versatz Gelenkpunkte C zu B | HD5 | 4
β | Fixer Winkel zwischen Stab CD und Stab CA | HD6 | 5
m1_off | Y-Position von Antrieb 1, bezogen auf Y -Nullpunkt WKS | HD7 | 6
phi_min | Minimalwert für Winkel ϕ (0 ° ) | HD8 | 7
phi_max | Maximalwert für Winkel ϕ (90 ° ) | HD9 | 8
- | X Offset | HD10 | 9
L4 | Greiferoffset | HD11 | 10
- | Kinematikvariante | HD12 | 11


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_22

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus zwei translatorischen NC-Achsen im Werkstück, zwei rotatorischen NC-Achsen und eine translatorischen Achse im Werkzeug.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, A, B
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | Z, A, B | X, Y

Abbildung 2-37: Achskonfiguration der fünfachsigen Maschine

Abbildung 2-38: Versätze der Kinematik.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Achsversatz Werkzeugeinspannpunkt bis Drehpunkt A / B Achse
HD4 | 3 | Bewegungsrichtung Drehachse A
HD5 | 4 | Bewegungsrichtung Drehachse B


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_23

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus zwei translatorischen NC-Achsen im Werkstück, einer translatorischen Achse im Werkzeug und je einer rotatorische NC-Achse in Werkstück und Werkzeug.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, A, B
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | Z, A | X, Y, B

Abbildung 2-39: Achskonfiguration der fünfachsigen Maschine

Abbildung 2-40:: Versätze der Kinematik.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Achsversatz Werkzeugeinspannpunkt bis Drehpunkt A Achse
HD2 | 1 | Abstand Drehpunkt B Achse zu Werkstückplattform
HD4 | 3 | Bewegungsrichtung Drehachse A
HD5 | 4 | Bewegungsrichtung Drehachse B


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_28

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen NC-Achsen und zwei rotatorischen NC-Achsen im Werkzeug. Die physikalische Winkelstellung des Kopfes C, A wird über zwei Achsen mit Getriebekopplung eingestellt.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C(C1), A(C2)
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, C(C1), A(C2) | -

Abbildung 2- 41 : Fünfachsige Kinematik

Abbildung 2- 42 : Werkzeugkopf (Ruhestellung mit HD3 = 0 , A=0 , HD4=0 , C=0 )

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Achsversatz von Werkzeugeinspannpunkt bis Drehpunkt A Achse (Schwenkachse)
HD2 | 1 | Z Achsversatz Drehachse A zu Werkzeugkopfbezugspunkt
HD3 | 2 | Rotatorischer Winkelversatz A Achse (Defaultwert 0)
HD4 | 3 | Rotatorischer Winkelversatz C Achse (Defaultwert 0)
HD5 | 4 | Y Achsversatz Drehpunkt C Achse
HD6 | 5 | X Achsversatz Drehpunkt C Achse
HD7 | 6 | statischer Kopfversatz in X (Defaultwert 0)
HD8 | 7 | statischer Kopfversatz in Y (Defaultwert 0)
HD9 | 8 | Y Achsversatz Fräserachse zu Drehpunkt A-Achse
HD10 | 9 | n. v.
HD11 | 10 | Nullpunktoffset CA Getriebekopplung
HD12 | 11 | Getriebekopplungsfaktor Zähler
HD13 | 12 | Getriebekopplungsfaktor Nenner
HD14 | 13 | VZ Drehachse C
HD15 | 14 | VZ Drehachse A

Die Getriebekopplung zwischen C und A ist absolut und wird nach folgenden Gleichungen durchgeführt:

Die Drehachsen des Kopfes müssen entweder als Linearachsen oder als Rotatorachsen mit ausreichend großem Modulobereich eingestellt sein. Die SWE Überwachung im Kanal wirkt auf Antriebspositionen entsprechend den im MDS eingestellten Grenzen.


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_30

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen NC-Achsen und einer rotatorischen NC-Achse im Werkzeug .

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, A
Achsindex | 0, 1, 2, 3
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, A | -

Abbildung 2-43: Vierachsige Kinematik (Bohr- und Fräsaggregat)

Abbildung 2-44: Versätze der vierachsigen Kinematik

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z-Versatz WZ Einspannpunkt bis Drehpunkt A-Achse
HD2 | 1 | X-Versatz WZ Einspannpunkt bis Drehpunkt A-Achse
HD3 | 2 | Y- Versatz WZ Einspannpunkt bis Drehpunkt A-Achse
HD4 | 3 | VZ Drehrichtung A-Achse
HD5 | 4 | Rotatorischer Offset A-Achse
HD6 | 5 | X-Versatz Drehpunkt A-Achse bis Bzpkt. WZ-Schlitten
HD7 | 6 | Y-Versatz Drehpunkt A-Achse bis Bzpkt. WZ-Schlitten
HD8 | 7 | Z-Versatz Drehpunkt A-Achse bis Bzpkt. WZ-Schlitten


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_33

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen NC-Achsen und zwei rotatorischen NC-Achsen im Werkzeug. Als Besonderheit sind bei dieser Kinematik aufgrund des mechanischen Aufbaus bei Drehung der rotatorischen Achsen keine Ausgleichsbewegungen der translatorischen Achsen erforderlich.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C, A
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, C, A | -

Abbildung 2-45: Fünfachsiger Schrägwinkelkopf

Abbildung 2-46: Schrägwinkelkopf in Nullstellung, HD7=0

Abbildung 2-47: Schrägwinkelkopf mit 180 Grad Kopfoffset in Nullstellung, HD7=1

Abbildung 2-48: Statische Versätze in X, Y Ebene

Versatzdaten der kinematischen Struktur:

HD Versatz | param[i] | Bedeutung
HD3 | i = 2 | Kopfwinkel
HD4 | i = 3 | Statischer X- Versatz
HD5 | i = 4 | Statischer Y- Versatz
HD6 | i = 5 | Statischer Z-Versatz
HD7 | i = 6 | Orientierung C-Achs Kopf, erforderlich wenn Kopf 180 Grad Offset in Nullstellung hat


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_34

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus zwei translatorischen NC-Achsen im Werkzeug, jeweils einer rotatorischen und translatorischen NC-Achse im Werkstück.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C
Achsindex | 0, 1, 2, 3
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | Y, Z | X, C

Abbildung 2-49: Vierachsige C Achs-Kinematik

Abbildung 2-50: Nullpunktversätze am rotatorischen C Achs Werkstückträger

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD2 | 1 | MKS Versatz X
HD3 | 2 | MKS Versatz Y


KIN_TYP_36

Mehr:

button Kinematische Struktur

button Rechtshänder, Linkshänder


Kinematische Struktur

Die Roboterkinematik besteht aus drei rotatorischen und einer translatorischen NC-Achse im Werkzeug. In die Z-Achse erfolgt der Werkzeuglängenverrechnung. Alle Rotationachsen sind C Achsen.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C (C1, C2, Z, C3)
Achsindex | 0, 1, 2, 3
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X,Y, Z, C | -

Abbildung 2-51: SCARA Kinematik

Abbildung 2-52: SCARA Kinematik in Nullstellung (C1=0, C2=0, C3=0)

Abhängig von der Knickstellung des Robotergelenkes 2 (C2) arbeitet der SCARA als Links oder Rechtshänder. Die Maschinenachsstellung vor Anwahl der Transformation entscheidet also darüber ob der SCARA als Rechts- oder Linkshänder positioniert. Ein Wechsel zwischen Links- und Rechtshänder ist bei inaktiver kinematischer Transformation möglich.


Rechtshänder, Linkshänder

Abbildung 2-53: Rechtshänder C2 >=0, bzw. < 180Grad

Abbildung 2-54: Linkshänder C2 <=0 bzw. > 180 Grad

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | WZ Längenversatz in z-Richtung
HD2 | 1 | Längeversatz von Gelenk 1 bis Gelenk 2
HD3 | 2 | Längenversatz Gelenk 2 bis Drehachse C3
HD4 | 3 | x-Versatz Nullpunkt C1 Achse
HD5 | 4 | y-Versatz Nullpunkt C1 Achse
HD6 | 5 | rotatorischer Offset C1 Achse


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_52

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik dieser Maschine besteht aus drei translatorischen Achsen und zwei rotatorischen Achsen im Werkstück.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, A, B
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y | Z, A, B

Abbildung 2-55: Kinematik der 5-achsigen Fräsmaschine

Abbildung 2-56: Definition der Versatzparameter

In der obigen Abbildung ist die Kinematik für die Maschinenachspositionen Z = 0, Y = 0 und A = 0 dargestellt.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD0 | 0 | Versatz Drehachse A-Achse bis Werkzeug-einspannpunkt.
HD1 | 1 | Y Versatz Werkzeug
HD2 | 2 | Y Versatz von Nullpunkt Werkstückkoordinatensystem zu Drehachse A-Achse
HD3 | 3 | Vorzeichen Drehrichtung A-Achse
HD4 | 4 | Vorzeichen Drehrichtung B-Achse


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_57

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen Achsen im Werkzeug und zwei rotatorischen NC-Achsen im Werkstück.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, B, C
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z | B, C

Abbildung 2-57: Kinematische Struktur der fünfachsigen Maschine mit BC Werkstücktisch

Abbildung 2-58: Werkzeugversätze und Versätze zur B-Achse

Abbildung 2-59: X, Y Versätze zur B-Achse

Der Maschinennullpunkt kann über die Parameter HD7..HD9 verschoben werden. Abweichende Nullstellungen der rotatorischen Achsen B und C können über die Parameter HD10 HD11 so eingestellt werden, dass das interne kinematische Modell mit der realen Maschinenkinematik übereinstimmt. Ebenso können abweichende Drehrichtungen der Achsen B und C über die Parameter HD12, HD13 eingestellt werden. Im allgemeinen sind dann auch die Vorzeichen von Soll- und Istgrössen in den Achsparametern entsprechend anzupassen.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Werkzeugversatz Einspannpunkt zu Bezugspunkt Werkzeugschlitten SBP
HD2 | 1 | X Achsversatz Einspannpunkt zu Bezugspunkt Werkzeugschlitten SBP
HD3 | 2 | Y Achsversatz Einspannpunkt zu Bezugspunkt Werkzeugschlitten SBP
HD4 | 3 | X Achsversatz Drehachse B zu Drehachse C, NP WKS
HD5 | 4 | Y Achsversatz Drehachse B zu Drehachse C, NP WKS
HD6 | 5 | Z Achsversatz Drehachse B zu Drehachse C, NP WKS
HD7 | 6 | X Versatz Maschinennullpunkt MNP zu Drehachse B
HD8 | 7 | Y Versatz Maschinennullpunkt MNP zu Drehachse B
HD9 | 8 | Z Versatz Maschinennullpunkt MNP zu Drehachse B
HD10 | 9 | Rotatorischer Offset B Achse
HD11 | 10 | Rotatorischer Offset C Achse
HD12 | 11 | Drehrichtungsflag B-Achse
HD13 | 12 | Drehrichtungsflag C-Achse


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_58

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen Achsen im Werkzeug und zwei rotatorischen NC-Achsen im Werkstück.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, A, C
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z | A, C

Abbildung 2-60: Kinematische Struktur der fünfachsigen Maschine mit AC Werkstücktisch

Abbildung 2-61: Werkzeugversätze und Versätze zur A- Achse

Abbildung 2-62: X, Y Versätze zwischen A- und C-Achse

Den Maschinennullpunkt legt man typischerweise in die Drehachse A. Bei Bedarf kann er über die Parameter HD7..HD9 verschoben werden. Abweichende Nullstellungen der rotatorischen Achsen A und C können über die Parameter HD10 HD11 so eingestellt werden, dass das interne kinematische Modell mit der realen Maschinenkinematik übereinstimmt. Ebenso können abweichende Drehrichtungen der Achsen A und C über die Parameter HD12, HD13 eingestellt werden. Im allgemeinen sind dann auch die Vorzeichen von Soll- und Istgrössen in den Achsparametern entsprechend anzupassen.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Werkzeugversatz Einspannpunkt zu Bezugspunkt Werkzeugschlitten SBP
HD2 | 1 | X Achsversatz Einspannpunkt zu Bezugspunkt Werkzeugschlitten SBP
HD3 | 2 | Y Achsversatz Einspannpunkt zu Bezugspunkt Werkzeugschlitten SBP
HD4 | 3 | X Achsversatz Drehachse A zu Drehachse C, NP WKS
HD5 | 4 | Y Achsversatz Drehachse A zu Drehachse C, NP WKS
HD6 | 5 | Z Achsversatz Drehachse A zu Drehachse C, NP WKS
HD7 | 6 | X Versatz Maschinennullpunkt MNP zu Drehachse A
HD8 | 7 | Y Versatz Maschinennullpunkt MNP zu Drehachse A
HD9 | 8 | Z Versatz Maschinennullpunkt MNP zu Drehachse A
HD10 | 9 | Rotatorischer Offset A Achse
HD11 | 10 | Rotatorischer Offset C Achse
HD12 | 11 | Drehrichtungsflag A-Achse
HD13 | 12 | Drehrichtungsflag C-Achse


Kardankinematik

Mehr:

button KIN_TYP_59

button KIN_TYP_60


KIN_TYP_59

Die Kinematik besteht aus drei translatorischen und zwei rotatorischen NC-Achsen Achsen im Werkzeug. Die A-Achse ist um einen Winkel Winkel != 90 Grad um die Y-Achse gedreht angeordnet, typischerweise liegt der Winkel zwischen 30 und 60 Grad.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C, A
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z,C,A | -

Abbildung 2-63: Kardankinematik mit CA- Kopf

Abbildung 2-64: Versätze des kardanischen CA-Fünfachskopfes

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z- Versatz bis Einspannung WZ
HD2 | 1 | X- Versatz bis Einspannung WZ
HD3 | 2 | Y- Versatz bis Einspannung WZ
HD4 | 3 | X- Versatz Kompensationspunkt (SP) bis A-Achse
HD5 | 4 | Y- Versatz Kompensationspunkt (SP) bis A-Achse
HD6 | 5 | Z- Versatz Kompensationspunkt (SP) bis A-Achse
HD7 | 6 | Winkel zwischen A-Achse und Z Achse
HD8 | 7 | X- Versatz A-Achse bis C-Achse
HD9 | 8 | Y- Versatz A-Achse bis C-Achse
HD10 | 9 | Z- Versatz A-Achse bis C-Achse
HD11 | 10 | X- Versatz C-Achse bis Maschinenpunkt M
HD12 | 11 | Y- Versatz C-Achse bis Maschinenpunkt M
HD13 | 12 | Z- Versatz C-Achse bis Maschinenpunkt M
HD14 | 13 | Rotatorischer interner Offset C-Achse (*)
HD15 | 14 | Rotatorischer interner Offset A-Achse (*)
HD16 | 15 | Rotatorischer Offset C-Achse (*)
HD17 | 16 | Rotatorischer Offset A-Achse (*)
HD21 | 20 | Steuerflag: 0: Transformation der rotatorischen Achsen C und A , Default. 1: Die rotatorischen Achsen C und A sind Maschinenwinkel.

Im allgemeinen wandert der mit ARP bezeichnete Bezugspunkt in den Bezugspunkt SP d.h. der Vektor V3 ist 0 und der Punkt SP liegt in der Werkzeugachse die sich mit der C- Drehachse deckt. In diesem Fall sind dann nur die Parameter L, HD1, HD7 und HD10 erforderlich. Die Kinematik kann einen A-Raumwinkel von maximal 2*HD7 umsetzen.

(*) Die rotatorischen Offsets HD14 und HD15 wirken nur auf das interne Kinematikmodell d.h. diese Offsets werden nicht an die rotatorischen Achsen weitergereicht. Im Gegensatz dazu wirken die Offsets HD16, HD17 wie eine NPV bei aktiver kinematischer Transformation d.h. sie führen auch zu einer Neupositionierung des Kardankopfes mit rotatorischem Offset bei Programmierung einer Winkelposition.

Abbildung 2-65: Kardankopf bei idealer Kopfgeometrie (Schnittpunkt C-A Achse liegt in Werkzeugachse)

Abbildung 2-66: Kardankopf mit versetzter C-Achse (C- Achse liegt nicht in der Werkzeugachse)


KIN_TYP_60

Die Kinematik besteht aus drei translatorischen und zwei rotatorischen NC-Achsen Achsen im Werkzeug. Die B-Achse ist um einen Winkel != 90 Grad um die X-Achse gedreht angeordnet, typischerweise liegt der Winkel zwischen 30 und 60 Grad.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, C, B
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z,C,B | -

Abbildung 2-67: Kardankinematik mit CB- Kopf

Abbildung 2-68: Versätze des kardanischen CB-Fünfachskopfes

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z- Versatz bis Einspannung WZ
HD2 | 1 | X- Versatz bis Einspannung WZ
HD3 | 2 | Y- Versatz bis Einspannung WZ
HD4 | 3 | X- Versatz Kompensationspunkt (SP) bis B-Achse
HD5 | 4 | Y- Versatz Kompensationspunkt (SP) bis B-Achse
HD6 | 5 | Z- Versatz Kompensationspunkt (SP) bis B-Achse
HD7 | 6 | Winkel zwischen B-Achse und Z Achse
HD8 | 7 | X- Versatz B-Achse bis C-Achse
HD9 | 8 | Y- Versatz B-Achse bis C-Achse
HD10 | 9 | Z- Versatz B-Achse bis C-Achse
HD11 | 10 | X- Versatz C-Achse bis Maschinenpunkt M
HD12 | 11 | Y- Versatz C-Achse bis Maschinenpunkt M
HD13 | 12 | Z- Versatz C-Achse bis Maschinenpunkt M
HD14 | 13 | Rotatorischer Offset C-Achse
HD15 | 14 | Rotatorischer Offset B-Achse
HD21 | 20 | Steuerflag: 0: Transformation der rotatorischen Achsen C und B , Default. 1: Die rotatorischen Achsen C und B sind Maschinenwinkel.

Im allgemeinen wandert der mit BRP bezeichnete Bezugspunkt in den Bezugspunkt SP d.h. der Vektor V3 ist 0 und der Punkt SP liegt in der Werkzeugachse die sich mit der C- Drehachse deckt. In diesem Fall sind dann nur die Parameter L, HD1, HD7 und HD10 erforderlich.

Die Kinematik kann einen B-Raumwinkel von maximal 2*HD7 umsetzen.

(*) Die rotatorischen Offsets HD14 und HD15 wirken nur auf das interne Kinematikmodell d.h. diese Offsets führen nicht zu einer Neupositionierung des Kardankopfes wie bei einer rotatorischen NPV und Programmierung einer Winkelposition.

Abbildung 2- 69 : Kardankopf bei idealer Kopfgeometrie (Schnittpunkt C-B Achse liegt in Werkzeugachse)


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_61

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus je einer translatorischen und rotatorischen NC-Achse im Werkstück und zwei translatorischen und einer rotatorischen NC-Achse im Werkzeug.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, A, B
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Z, B | Y, A

Abbildung 2-70: Achskonfiguration der fünfachsigen Maschine

Abbildung 2-71: Versätze Werkzeugkopf

Abbildung 2-72: Versätze Werkstückträger

Abbildung 2-73: Ideale und reale z- Nullstellung

In der idealen Nullstellung der kinematischen Struktur schneiden sich die Drehachse A im Werkstück und Drehachse B im Werkzeug in einem Punkt. Die Maschinenachspositionen des Werkzeugschlittens sind dann in dieser Stellung 0. Real können diese Achspositionen bei einer Maschine nicht angefahren werden. Die bei der Werkzeugschlittenposition 0 vorhandenen Offsets zu dieser Stellung können über die Parameter HD7, HD8, HD9 berücksichtigt weden.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z-Versatz WZ Drehpunkt B-Achse bis Einspannpunkt
HD2 | 1 | X-Versatz WZ Drehpunkt B-Achse bis Einspannpunkt
HD3 | 2 | Y-Versatz WZ Drehpunkt B-Achse bis Einspannpunkt
HD4 | 3 | X-Versatz Drehpunkt B-Achse bis Bzpkt. WZ-Schlitten
HD5 | 4 | Y-Versatz Drehpunkt B-Achse bis Bzpkt. WZ-Schlitten
HD6 | 5 | Z-Versatz Drehpunkt B-Achse bis Bzpkt. WZ-Schlitten
HD7 | 6 | X-Versatz zu Maschinen-Nullpunkt
HD8 | 7 | Y-Versatz zu Maschinen-Nullpunkt
HD9 | 8 | Z-Versatz zu Maschinen-Nullpunkt
HD10 | 9 | X-Versatz A-Drehachse zu Nullpunkt WKS
HD11 | 10 | Y-Versatz A-Drehachse zu Nullpunkt WKS
HD12 | 11 | Z-Versatz A-Drehachse zu Nullpunkt WKS
HD13 | 12 | Rotatorischer Offset A-Achse
HD14 | 13 | Rotatorischer Offset B-Achse
HD15 | 14 | Drehrichtungs-Flag A-Achse
HD16 | 15 | Drehrichtungs-Flag B-Achse


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_63

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus je einer translatorischen und rotatorischen NC-Achse im Werkstück und zwei translatorischen und einer rotatorischen NC-Achse im Werkzeug. Die Transformation unterstützt zusätzliche Versatzparameter bei nicht symetrischem Aufbau und ersetzt die vorhandene Struktur unter KIN_TYP_23.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, A, B
Achsindex | 0, 1, 2, 3, 4
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | Z, A | X,Y, B

Abbildung 2-74: Achskonfiguration der fünfachsigen Maschine

Abbildung 2-75: Versätze Werkzeugkopf

Abbildung 2-76: Versätze Werkstückträger

Abbildung 2-77: Ideale und reale z- Nullstellung

In der idealen Nullstellung der kinematischen Struktur schneiden sich die Drehachse B im Werkstück und Drehachse A im Werkzeug in einem Punkt. Die Maschinenachspositionen des Werkzeugschlittens sind dann in dieser Stellung 0. Real können diese Achspositionen bei einer Maschine nicht angefahren werden. Die bei der Werkzeugschlittenposition 0 vorhandenen Offsets zu dieser Stellung können über die Parameter HD7, HD8, HD9 berücksichtigt weden.

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z-Versatz WZ Drehpunkt A-Achse bis Einspannpunkt
HD2 | 1 | X-Versatz WZ Drehpunkt A-Achse bis Einspannpunkt
HD3 | 2 | Y-Versatz WZ Drehpunkt A-Achse bis Einspannpunkt
HD4 | 3 | X-Versatz Drehpunkt A-Achse bis Bzpkt. WZ-Schlitten
HD5 | 4 | Y-Versatz Drehpunkt A-Achse bis Bzpkt. WZ-Schlitten
HD6 | 5 | Z-Versatz Drehpunkt A-Achse bis Bzpkt. WZ-Schlitten
HD7 | 6 | X-Versatz zu Maschinen-Nullpunkt
HD8 | 7 | Y-Versatz zu Maschinen-Nullpunkt
HD9 | 8 | Z-Versatz zu Maschinen-Nullpunkt
HD10 | 9 | X-Versatz B-Drehachse zu Nullpunkt WKS
HD11 | 10 | Y-Versatz B-Drehachse zu Nullpunkt WKS
HD12 | 11 | Z-Versatz B-Drehachse zu Nullpunkt WKS
HD13 | 12 | Rotatorischer Offset A-Achse
HD14 | 13 | Rotatorischer Offset B-Achse
HD15 | 14 | Drehrichtungs-Flag A-Achse
HD16 | 15 | Drehrichtungs-Flag B-Achse


TwinCAT CNC: Überblick

Kinematische Transformationen

KIN_TYP_70

Mehr:

button Kinematische Struktur


Kinematische Struktur

Die Kinematik besteht aus drei translatorischen und zwei rotatorischen NC-Achsen im Werkzeug. Bei dieser Kinematik kann die Werkzeugkopfrotation um z bei nicht achsparalleler Ausrichtung des B-A Drehkopfes eingestellt werden. Eine virtuelle Achse CV dient zur Beeinflussung der Werkzeugorientierung.

Achskonfiguration im NC-Kanal
Achsbezeichner | X, Y, Z, B, A, CV
Achsindex | 0, 1, 2, 3, 4, 5
Kinematische Struktur
 | Werkzeugachsen | Werkstückachsen
NC-Achsen | X, Y, Z, B, A, CV | -

Abbildung 2-78: Achskonfiguration der fünfachsigen Maschine

Abbildung 2-79: Parameter des Werkzeugkopfes

Versatzdaten der Kinematik:

HD-Versatz | param[i] | Bedeutung
HD1 | 0 | Z Versatz bis Einspannpunkt WZ
HD2 | 1 | X Versatz
HD3 | 2 | Y Versatz
HD4 | 3 | Z Versatz
HD5 | 4 | X Versatz
HD6 | 5 | Y Achsversatz WZ
HD7 | 6 | Rotatorischer Versatz A Achse
HD8 | 7 | Rotatorischer Versatz B Achse
HD9 | 8 | Vorzeichen Drehrichtung A Achse
HD10 | 9 | Vorzeichen Drehrichtung B Achse
HD14 | 13 | Rotatorischer Versatz um Z (Kopflage)

Abbildung 2- 80: Winkeloffset des Dreh-Schwenkkopfes

Die CV Achse ist keine physikalisch real vorhande Achse der kinematischen Struktur. Die CV- Achse führt eine Drehung des Werkzeugrichtungsvekors um z aus, d.h. die Winkel A und B werden abhängig von CV berechnet. Eine Anwendung kann z. B. die Normalausrichtung einer Komponente der XY Werkzeugrichtung zur programmierten Kontur sein. Dazu ist diese Achse als Simulationsachse einzustellen und kann dann wie gewohnt im NC-Programm angesprochen werden.

Der zulässige Winkelbereich der Achsen A und B liegt im Bereich +- 90 Grad.


TwinCAT CNC: Überblick

Kinematische Transformationen in Prototypen

KIN_TYP_24

Mehr:

button Kinematische Struktur


Kinematische Struktur

Dynamil Parallelkinematik mit 3 Plattformsäulen und 6 Maschinenachsen

Abbildung 3-1: Sechsachsige Parallelkinematikmaschine


TwinCAT CNC: Überblick

Kinematische Transformationen in Prototypen

KIN_TYP_45

Mehr:

button Kinematische Struktur


Kinematische Struktur

Gelenkarmroboter mit 6 Maschinenachsen.

Abbildung 3-2: Sechsachsiger Gelenkarmroboter


Klassifizierung der Transformationen

Abhängig von deren Eigenschaften lassen sich die in Kap. 2, 3 aufgeführten Transforma-tionen wie folgt einordnen:

Transformations ID | Transformationsart | Besonderheiten
1 | RTCP | 5 Maschinenachsen
2 | RTCP | 5 Maschinenachsen
3 | RTCP | 4 Maschinenachsen
4 | RTCP | 4 Maschinenachsen
5 | RTCP | 4 Maschinenachsen
6 | RTCP | 4 Maschinenachsen
7 | RTCP | 4 Maschinenachsen
8 | RTCP | 4 Maschinenachsen
9 | RTCP | 5 Maschinenachsen
10 | RTCP | 5 Maschinenachsen
11 | RTCP | 5 Maschinenachsen
12 | Vollständig | 3 achsige Parallelkinematik mit konstanter Orientierung, 3 Maschinenachsen
16 | RTCP | 5 Maschinenachsen
17 | RTCP | 3 Maschinenachsen, 2 Hilfsachsen
18 | RTCP | 3 Maschinenachsen, 2 Hilfsachsen
19 | Vollständig | 3 Säulen Parallelkinematik, 5 Maschinen-achsen
20 | Vollständig | wie 18 + Kalottentransformation, automatische Berechnung der Orientierung
21 | Vollständig | LAMBA Scherenkinematik mit Kompensation von rot. C Achse, konstante Orientierung, 4 Maschinenachsen
23 | RTCP | 5 Maschinenachsen
24 | Vollständig | 3 Säulen Parallelkinematik, 6 Maschinenachsen
30 | RTCP | 4 Maschinenachsen
33 | RTCP | 5 Maschinenachsen
34 | RTCP | 4 Maschinenachsen
36 | RTCP | 4 Maschinenachsen, SCARA
52 | RTCP | 5 Maschinenachsen
57 | RTCP | Dreh-/Schwenktisch, 5 Maschinenachsen
58 | RTCP | Dreh-/Schwenktisch, 5 Maschinenachsen
59 | RTCP | Kardankopf, 5 Maschinenachsen
60 | RTCP | Kardankopf, 5 Maschinenachsen
61 | RTCP | 5 Maschinenachsen
63 | RTCP | 5 Maschinenachsen