TwinCAT ADS-DLL .NET
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, und XTS® und XPlanar®, sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


TwinCAT ADS .NET API Documentation

TwinCAT ADS .NET API Documentation
TwinCAT ADS .NET API Documentation
The TwinCAT .NET API implements support for the TwinCAT Automation Device specification (ADS). It can be used within .NET Framework programming languages and support ADS Client implementations. The ADS API interface permits:
▪
The Implementation of ADS Clients
▪
Browsing of (ADS) server side symbolic information.
▪
Reading and writing ProcessImage information in Raw or in type safe manner.
▪
Receiving ADS Notifications as events.
Getting Started
For getting started please have a look at the following documents:
▪
Prerequisites
▪
Installation
▪
Concepts
▪
HowTo Samples
Background information about the TwinCAT ADS protocol can be found here:
▪
ADS Introduction
▪
TwinCAT ADS Device concept
for common ADS information.
From the conceptual standpoint within this ADS .NET API reference documentation, the most important starting points for reading are the following Classes/Methods:
Main documentation entry points
Description | Link
Addressing ADS Devices via AmsNetId Address information. | AmsNetId
Communicate to ADS Devices via the TcAdsClient class. | TcAdsClient
Browse target system symbolic information (new Version, V2). Creation of the SymbolLoader via Factory class. | SymbolLoaderFactory.Create(IConnection,ISymbolLoaderSettings)
Browse target system symbolic information (traditional Version, V1)) | TcAdsClient.CreateSymbolInfoLoader()
Session and Connection management on top of the ADS communication channel established by the TcAdsClient. | AdsSession, AdsConnection
Usage of Ads.Rx (Reactive extensions) to write reactive code. | AdsClientExtensions, AdsClientExtensions The ADS reactive extensions are only available for usage, when the corresponding Nuget package is downloaded from Nuget.org. Beckhoff.TwinCAT.Ads.Reactive package on Nuget
Other Resources
HowTo Samples
Version History
Weiterführende Informationen
•
Prerequisites
•
Installation


Prerequisites

TwinCAT ADS .NET API Documentation [image] Prerequisites
Prerequisites
Preconditions for installing the TwinCAT .NET ADS Communication API
▪
TwinCAT 2 or 3 Installation (XAR Runtime or full installation)
▪
Beckhoff.TwinCAT.Ads Nuget Package
.NET Framework 4.0 or later
▪
Beckhoff.TwinCAT.Ads.Reactive Nuget Package
.NET Framework 4.6 or later


Installation

TwinCAT ADS .NET API Documentation [image] Installation
Installation
The now preferred way to install the TwinCAT ADS .NET Communication API is to use the NuGet.org package manager. Alternatively, there is still the option to Add references manually via the "Add References..." Dialog in Visual Studio.
Beckhoff.TwinCAT.Ads package from Nuget.org repository.
This is the main package implementing the ADS client functionality. This is needed to establish ADS connections to local and remote devices.
Please follow the install instructions on the Nuget.org site.
Beckhoff.TwinCAT.Ads Nuget Package
Beckhoff.TwinCAT.Ads.Reactive package from Nuget.org repository.
This package installs Reactive extensions on top of the Beckhoff.TwinCAT.Ads Nuget Package and installs additional extensions to map ADSNotifications to observable events.
Please follow the install instructions on the Nuget.org site.
Beckhoff.TwinCAT.Ads.Reactive Nuget Package
Manually referencing the TwinCAT Ads .Net Communication Library (non-preferred, obsolete)
Add TwinCAT.Ads.dll manually in Visual Studio
1.
Create New project: Start Microsoft Visual Studio and create new project (e.g. Windows Forms Application).
2.
Adding reference: In order to select the TwinCAT.Ads class library you must choose the command Add Reference... under the Project menu . You will find the .Net Libraries per default in following TwinCAT folder:
C:\TwinCAT\AdsApi\.NET\
This opens the Add Reference dialog. In this dialog you have to press the Browse button and select the file TwinCAT.Ads.dll for your used .NET Framework runtime. In the Solution Explorer you can check, if the component has been added to the list of references.
3.
All accessible types (classes,structures ...) belong to the namespace TwinCAT.Ads. Therefore one has to insert the following line at the beginning of the source:C#
using System.IO; using TwinCAT.Ads;
This enables access to the types defined in TwinCAT.Ads without including the name of the namespace. The class TcAdsClient is the core of the TwinCAT.Ads class library and enables the user to communicate with an ads device. To begin with an instance of the class must be created. Then a connection to the ADS device is established by means of the Connect method.


Version History

Version History
Version History
The topics in this section describe the various changes made to the 'TwinCAT.Ads .NET API' over the life of the project.
Version History
Select a version below to see a description of its changes.
▪
Version 4.3.X.X
▪
Version 4.2.X.X
▪
Version 4.1.X.X
▪
Version 4.0.X.X
Other Resources
TwinCAT ADS .NET API Documentation
Weiterführende Informationen
•
Version 4.3.X.X
•
Version 4.2.X.X
•
Version 4.1.X.X
•
Version 4.0.X.X


Version 4.3.X.X

Version History [image] Version 4.3.X.X
Version 4.3.X.X
Feature milestones of the version 4.3.X.X Series
Milestones of Version 4.3.0.0
▪
Support of runtime sized Array Instances (AnySizeArrayInstance)
▪
Support of Nuget Semantic Versioning support:
Because now the Versioning of Nuget packages supports API Updates, it is not necessary anymore to update the TwinCAT.Ads.dll AssemblyVersion - which will force to recompile dependent assemblies. From Version 4.3.0.0 on the AssemblyVersion will change only on major updates, what means that minor Updates (within 4.3.X.X) will remain the same AssemblyVersion and remain backward compatible - only the AssemblyFileVersion will change.
Nuget package versioning
Semantic Versioning specification (Semver.org)
Other Resources
Version History


Version 4.2.X.X

Version History [image] Version 4.2.X.X
Version 4.2.X.X
Feature milestones of the version 4.2.X.X Series
Milestones of Version 4.2.172.0
▪
Release of TwincAT ADS Reactive (Ads.Rx) Nuget package Beckhoff.TwinCAT.Ads.Reactive package on Nuget The classes of the Reactive Extensions can be found in the namespace TwinCAT.Ads.Reactive.
Milestones of Version 4.2.171.0
▪
Release of Nuget package Beckhoff.TwinCAT.Ads package on Nuget
Milestones of Version < 4.2.170.0
▪
Dedicated AdsClientSettings object.
▪
Better Support of jagged arrays.
▪
Support of 64-Bit types ULINT, LINT, LTIME, LWORD, UXINT
▪
Enhanced support of ANYTypes (primitive .NET Arrays)
▪
Implementation of SymbolLoaderFactory to create SymbolLoader V2.
▪
Api for ADS Sum commands within the TwinCAT.Ads.SumCommand namespace.
▪
RPC Methods (Remote procedure calls) implementation.
▪
Support of custom symbol providers.
Other Resources
Version History


Version 4.1.X.X

Version History [image] Version 4.1.X.X
Version 4.1.X.X
Feature milestones of the version 4.1.X.X series
Milestones in this version series:
▪
Implementation of Symbol Loader V2
▪
Dynamic Language Runtime Support (DLR) for CLR4 Versions.
▪
Fail fast handler implementation on connection timeouts
▪
Session and Connection support.
▪
Extended support of DataTypes in Symbol loaders.
▪
Support of arrays with more than 3 dimensions.
▪
Recognition of WSTRING types in AdsSymbolParser corrected.
▪
Support of Pointer and Reference types.
▪
Support of of Symbol and DataType Attributes.
▪
ReferenceType Recursion recognition added.
▪
UINT64 Support for ReadAny.
▪
Enhanced Common Error handling.
▪
Extended support for PlcOpen DataTypes (TIME, DATE, TOD, DT)
Other Resources
Version History


Version 4.0.X.X

Version History [image] Version 4.0.X.X
Version 4.0.X.X
Feature milestones of the version 4.0.X.X series
Major Milestones:
▪
Support for .NET Framework 4.0
Other Resources
Version History


Concepts

Concepts
Concepts
Concepts introduction
Concepts
Concepts discussed
Name | Description
IndexGroup / IndexOffset | Read/Write values by IndexGroup / IndexOffset
Symbolic access | Read/Write values by symbolic instance path
Access via symbol handle | Read/Write values by symbol handles.
ADS Notifications | Concept of ADS Notifications
Symbol loader access | Access symbolic information by Symbol loader
Marshalling values via ANYTYPE concept | ANY Type blittable type marshalling
Dynamic automatic marshalling via Dynamic Language Runtime | Use of the .NET Framework Dynamic Language Runtime (DLR)
Access via reactive extensions | Observer value changes by ADS Reactive Extensions
Other Resources
TwinCAT ADS .NET API Documentation
Weiterführende Informationen
•
Access Data via IndexGroup/IndexOffset
•
Use of ADS Notifications
•
Access Data via Symbolic path
•
Access Data via Symbol handles
•
Value marshalling with ANYTYPE concept
•
Access Data via Symbol Loader
•
Automatic dynamic marshalling of values
•
Reactive Extensions and ADS


Access Data via IndexGroup/IndexOffset

Concepts [image] Access Data via IndexGroup/IndexOffset
Access Data via IndexGroup/IndexOffset
Reading/Writing values by Index/Group index offset are the most basic way to access data via ADS. This address combination directly link into the process image of virtual ADS Devices.
As long the process image is static this is unproblematic and a system near access, but if the content is more dynamic and the address changes over time the IndexGroup/IndexOffset can get invalid.
Examples about moving addresses could be:
▪
Changed Parametrization of IO (and Re-activation)
▪
The PLC Online change
▪
New Plc Downloads
In that case other access methods could be advantageous.
Another important point is that the data access is not type safe. The values are read or written to or from byte buffers and the proper marshalling/unmarshalling is the task of the application code.
Example
Access ProcessImage Data by IndexGroup/IndexOffset
using (TcAdsClient client = new TcAdsClient())
{
UInt32 valueToRead = 0;
UInt32 valueToWrite = 42;

client.Connect(AmsNetId.Local, 851);

// Write an UINT32 Value
AdsStream writeStream = new AdsStream(sizeof(uint));
AdsBinaryWriter writer = new AdsBinaryWriter(writeStream);
writer.Write(valueToWrite);
adsClient.Write(0x4020, 0x0, writeStream, 0, 4);

// Read an UINT32 Value
AdsStream readStream = new AdsStream(sizeof(uint));
adsClient.Read(0x4020, 0x0, readStream, 0, 4);
readStream.Position = 0;
AdsBinaryReader reader = new AdsBinaryReader(readStream);
valueToRead = reader.ReadUInt32();
}


Use of ADS Notifications

Concepts [image] Use of ADS Notifications
Use of ADS Notifications
If values from a PLC or NC are to be displayed continuously on a user interface, then it is very inefficient to use asynchronous read access, since this function must be called cyclically (polled triggered by a timer). Instead of using a pulling (read) model, ADS Notifications are implementing a push model. That means ADS Notifications are triggered by the sender and form a single or series of ADS messages/events. Together with these ADS Notifications, values can be transmitted. A distinction is drawn between whether the TwinCAT server is to transmit the values cyclically, or only when the values change.
In principle (raw mode) a notification is begun with the registration of the notification AddDeviceNotification. After this, events are automatically fired by TwinCAT. DeleteDeviceNotification is used to halt the notification again. Since the number of notifications is limited, you should ensure the notifications no longer required by your program are unregistered/deleted.
There exist several 'modes' for different type of ADS Notification triggers. For a complete list please consult AdsTransMode.
All the following examples demonstrate how to receive ADS Notifications. The .NET ADS API supports different information layers which different levels of ADS Notification support. All are using a PLC variable in the PLC and each time the value of the PLC variable changes, an ADS Notification message is sent and the registered callback method is invoked with event arguments that contain all the necessary information (value, time stamp, ...).
Hint: Don't use time intensive executions or ADS commands inside of your callback (not more than approx. 500). Remind to sync your callback in your main thread (typically the UI thread) if necessary, because the ADS Notifications appear on a background thread.
Using ADS Notifications with Symbolic information
C#
private void SymbolValueChanged()
{
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect("1.2.3.4.5.6", 851);
Symbol symbol = null;

try
{

ISymbolLoader loader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
// DINT Type (UINT32)
symbol = (Symbol)loader.Symbols["MAIN.nCounter"];

// Set the Notification Settings of the Symbol if NotificationSettings.Default is not appropriate
// Check for change every 500 ms
symbol.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 500, 0);

symbol.ValueChanged += Symbol_ValueChanged; // Registers the notification
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event and the underlying Handle
symbol.ValueChanged -= Symbol_ValueChanged; // Unregisters the notification
}
}
}

private void Symbol_ValueChanged(object sender, ValueChangedArgs e)
{
Symbol symbol = (Symbol)e.Symbol;

// Object Value can be cast to int automatically, because it is an Primitive Value (DINT --> Int32).
// The Symbol information is used internally to cast the value to its appropriate .NET Type.
int iVal = (int)e.Value;
}
Using ADS Notifications in 'ANYTYPE' style
C#
//AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event 'Ex' handler
client.AdsNotificationEx += Client_AdsNotification;

// Connect to target
client.Connect(AmsNetId.Local, 851);
int notificationHandle = 0;

try
{
// Notification to a ZDINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotificationEx("MAIN.nCounter",AdsTransMode.OnChange, 200, 0, null,typeof(uint));
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotificationEx -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationExEventArgs e)
{
// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = (uint)e.Value;
}
Using Raw ADS Notifications
C#
AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event handler
client.AdsNotification += Client_AdsNotification;

// Connect to target
client.Connect("1.2.3.4.5.6", 851);
int notificationHandle = 0;

try
{
// Notification to a DINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotification("MAIN.nCounter", readStream, AdsTransMode.OnChange, 200, 0, null);
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotification -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationEventArgs e)
{
int offset = (int)e.DataStream.Position;
int length = (int)e.DataStream.Length;

e.DataStream.Position = offset;
AdsBinaryReader reader = new AdsBinaryReader(e.DataStream);

// Read the Unmarshalled data
//byte[] data = reader.ReadBytes(length);

// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = reader.ReadUInt32();
}
Using reactive ADS Notifications
C#
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo[1].CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

cycleCount.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 500, 5000); // optional: Change NotificationSettings on Symbol

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = cycleCount.WhenValueChanged().Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}


Access Data via Symbolic path

Concepts [image] Access Data via Symbolic path
Access Data via Symbolic path
The Read/Write Access by symbol path solves the issue of directly accessing the process image. With specifying the access path to the symbol, the symbol address can be found by a binary search (internally) and reading / writing symbols is independent of the location within the process image.
This access method can only be used, when the ADS device is supporting symbolic information like the TwinCAT PLC.
Because its indirect access, the performance is slightly worse than the direct access via IndexGroup/IndexOffset. However there are internal optimizations to cache handles to the already used symbols to accelerate repeated access.
Example
Access symbolic data by instance/symbol path
using (TcAdsClient client = new TcAdsClient())
{
UInt32 valueToRead = 0;
UInt32 valueToWrite = 42;

client.Connect(AmsNetId.Local, 851);
adsClient.WriteSymbol("MAIN.nCounter", valueToWrite, false);
valueToRead = (uint)adsClient.ReadSymbol("MAIN.nCounter", typeof(UInt32),false);
}


Access Data via Symbol handles

Concepts [image] Access Data via Symbol handles
Access Data via Symbol handles
The Read/Write Access by handle solves the issue of directly accessing the process image like the symbol path access. Because the address is accessed indirectly by the symbol path creating a variable handle, the read/write works also when the data object has changed its position within the process image.
However the cost for this are two extra ADS communication roundtrips by the 'CreateVariableHandle' and 'DeleteVariableHandle' calls compared to the IndexGroup/IndexOffset access methods. It is the responsibility of the application code to optimize these accesses.
Example
Access symbolic values by handle
using (TcAdsClient client = new TcAdsClient())
{
int varHandle = 0;
client.Connect(AmsNetId.Local, 851);
try
{
UInt16 valueToRead = 0;
UInt16 valueToWrite = 42;

// Create the Variable Handle
varHandle = client.CreateVariableHandle("MAIN.testVar"); //Test Var is defined as PLC INT

// Write an UINT16 Value
AdsStream writeStream = new AdsStream(sizeof(UInt16));
AdsBinaryWriter writer = new AdsBinaryWriter(writeStream);
writer.Write(valueToWrite); // Marshal the Value
adsClient.Write(varHandle, writeStream,0,sizeof(uint));

// Read an UINT16 Value
AdsStream readStream = new AdsStream(sizeof(UInt16));
adsClient.Read(varHandle, readStream, 0, sizeof(UInt16));
readStream.Position = 0;
AdsBinaryReader reader = new AdsBinaryReader(readStream);
valueToRead = reader.ReadUInt16(); // Unmarshal the Value
}
finally
{
// Unregister VarHandle after Use
client.DeleteVariableHandle(varHandle);
}
}


Value marshalling with ANYTYPE concept

Concepts [image] Value marshalling with ANYTYPE concept
Value marshalling with ANYTYPE concept
This topic describes reading and writing variables/symbols of 'any' type with the help of the ReadAny and WriteAny (ReadSymbol, WriteSymbol) methods. The value will be marshalled / cast directly from/to its appropriate .NET type, what eases the value access.
'Any' types in this context are all types that are 'blittable' to the process image - what means that the memory layout is equal (e.g primitive types) or is marshallable by the default marshalling of .NET (see 'PlcStruct' in the example below).
The appropriate .NET type must be known during compile time and is passed to the methods as parameter. In case of a ReadAny call, the read data will be returned as a object. The type of the object is marshalled to the type specified as parameter type. Because the data size and the memory alignment is taken from this type specification, it is so important that this specification fits to the memory representation in the ADS device (e.g. the PLC).
Because some data types(arrays and strings) need additional information, an overload of the method ReadAny exists, that takes an additional parameter args. A Full list of supported types can be found in the documentation of the overloaded method.
Reading and writing of structures
To be able to read or write PLC structures the memory layout of the structure or class in .NET must be the same as in the PLC. The layout of a structure or class can be specified with the attribute StructLayoutAttribute. The LayoutKind must be set to LayoutKind.Sequential and the pack must be set to 1
If arrays, strings or boolean values are define the class, one has to specify how these fields should be marshalled. This is accomplished with help of the MarshalAs attribute. Because arrays and strings do not have a fixed length in .NET, the property SizeConst is necessary for arrays and strings.
Marshalling values with 'ANY_TYPES'
using (TcAdsClient client = new TcAdsClient())
{
client.Connect("1.2.3.4.5.6", 851);

// Bool value
bool boolValue = (bool)client.ReadSymbol("MAIN.bool1", typeof(bool), false);
adsClient.WriteSymbol("MAIN.bool1", boolValue,false);

// or
int handle1 = adsClient.CreateVariableHandle("MAIN.bool1"); // BOOL
boolValue = (bool)client.ReadAny(handle1, typeof(bool));
adsClient.WriteAny(handle1, boolValue);
adsClient.DeleteVariableHandle(handle1);

// RealValue
int handle2 = adsClient.CreateVariableHandle("MAIN.bool1"); // BOOL
float realValue = (float)client.ReadAny(handle2, typeof(float)); // REAL
client.WriteAny(handle2, realValue);
adsClient.DeleteVariableHandle(handle2);

// String
int handle3 = adsClient.CreateVariableHandle("MAIN.string1"); // STRING[80]
string stringValue = (string)client.ReadAny(handle3, typeof(string), new int[] { 80 }); // Needs additional para for strlen
adsClient.WriteAny(handle3, stringValue, new int[] { 80 });

// ushort[]
int handle4 = adsClient.CreateVariableHandle("MAIN.uint1Arr"); // ARRAY [0..9] OF UINT
ushort[] ushortArr = (ushort[])client.ReadAny(handle4, typeof(ushort[]), new int[] { 10 });
adsClient.WriteAny(handle4, ushortArr, new int[] { 10 });
adsClient.DeleteVariableHandle(handle4);

// Complex Struct Type
// Take care the the corresponding .NET Type is blittable / marshallable to the PLC type
int handle5 = adsClient.CreateVariableHandle("MAIN.struct");
PlcStruct structValue = (PlcStruct)adsClient.ReadAny(handle5, typeof(PlcStruct));
adsClient.WriteAny(handle5, typeof(PlcStruct));
adsClient.DeleteVariableHandle(handle5);

// ARRAY [0..9] OF STRING[80]
// args[0] --> Number of Characters
// args[1] --> Number of Array Elements
// Needs additional para for strlen and number of Elements in Array
int handle6 = adsClient.CreateVariableHandle("MAIN.stringArr"); // ARRAY [0..9] OF STRING[80]
string[] stringArr = (string[])client.ReadAny(handle6, typeof(string[]), new int[] { 80, 10 });
adsClient.WriteAny(handle6, stringValue, new int[] { 80 });
adsClient.DeleteVariableHandle(handle6);

}
Defining Memory layout of struct type.
[StructLayout(LayoutKind.Sequential, Pack = 1, CharSet = CharSet.Ansi)]
public struct PlcStruct
{
// Type must be 'blittable' to the corresponding PLC Struct Type
// See MSDN for MarshalAs and Default Marshalling.

[MarshalAs(UnmanagedType.I1)]
public bool boolVal; // BOOL
public byte byteVal; // BYTE
public ushort ushortVal; // UINT
public short shortVal; // INT
public uint uintVal; // UDINT
public int dintVal; // DINT
public uint udintVal; // UDINT
public float realVal; // REAL
public double lrealVal; // LREAL
[MarshalAs(UnmanagedType.ByValTStr, SizeConst = 81)]
public string stringVal; // STRING[80]

[MarshalAs(UnmanagedType.U4)]
public uint timeVal; // TIME
[MarshalAs(UnmanagedType.U4)]
public uint todVal; // TOD
[MarshalAs(UnmanagedType.U4)]
public uint dateval; // DATE
[MarshalAs(UnmanagedType.U4)]
public uint dtVal; // DT
}
ADS Notifications with Type marshalling (AdsNotificationEx)
The method AddDeviceNotificationEx is used to register notifications for a PLC variable. If the value of a variable changes the event AdsNotificationEx is fired. The difference to the event AdsNotification, is that the value of the variable is stored in an object instead of in an AdsStream. Therefore one has to pass the type of the object to the method AddDeviceNotificationEx
Notifications with 'ANY_TYPES'
using (TcAdsClient client = new TcAdsClient())
{
client.AdsNotificationEx += Client_AdsNotificationEx;
client.Connect("1.2.3.4.5.6", 851);

// Add UDINT
int notificationHandle = client.AddDeviceNotificationEx("MAIN.udint", AdsTransMode.OnChange, 200, 200, null, typeof(uint));
Thread.Sleep(5000); // ...
client.DeleteDeviceNotification(notificationHandle); // Unregister Event
}
Notifications with 'ANY_TYPES'
private void Client_AdsNotificationEx(object sender, AdsNotificationExEventArgs e)
{
uint value = (uint)e.Value; // Marshalled value as .NET Type
}


Access Data via Symbol Loader

Concepts [image] Access Data via Symbol Loader
Access Data via Symbol Loader
Some ADS Devices (e.g. the TwinCAT PLC) provide symbolic information for download. That means all visible Symbols and DataTypes can be retrieved from the target system. While this need an extra effort to upload and hold the data, this feature helps to remove the dependency of the code/configuration running on the target device.
E.g. because the symbolic information can now be browsed and determined during runtime, the application can be written without knowing what's running on the target system. Even more having the Symbol information cached, the access of the process image data will be easier because the datasize and access (instance path) is stored in the symbol.
Dependent how it is parametrized, the symbol loader can work with 'ANY_TYPES' (marshallable Primitive types, Value marshalling with ANYTYPE concept) or full dynamic symbols (Automatic dynamic marshalling of values).
Example
Accessing symbolic data by preloaded Symbolic information
using (TcAdsClient client = new TcAdsClient())
{
UInt32 valueToRead = 0;
UInt32 valueToWrite = 42;

client.Connect(AmsNetId.Local, 851);

// Load all Symbols + DataTypes
ISymbolLoader loader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
Symbol symbol = (Symbol)loader.Symbols["MAIN.nCounter"];

// Works for ALL Primitive 'ANY TYPES' Symbols
symbol.WriteValue(valueToWrite);
valueToRead = (UInt32)symbol.ReadValue();
}


Automatic dynamic marshalling of values

Concepts [image] Automatic dynamic marshalling of values
Automatic dynamic marshalling of values
The 'Dynamic Symbol Loader' of the .NET ADS Communication API makes use of the .NET dynamic language runtime (DLR).
The dynamic language runtime is a runtime environment that adds a set of services for dynamic languages to the common language runtime (CLR). The DLR makes it easier to develop dynamic languages to run on the .NET Framework and to add dynamic features to statically typed languages.
Dynamic languages can identify the type of an object at run time, whereas in statically typed languages (without using the 'dynamic' keyword, specify object types at design time.
The advantage here is - from the moment on the symbolic (and dataType) information is available from the ADS Device - Symbol/Variable values can be marshalled 'on-the-fly' during runtime in a type-safe manner.
This works not only with primitive types but also with complex types. This reduces the complexity of the written application code to access the values, because neither the type of the data must be known, nor how the value data must be marshalled from/to the process image.
The price to be paid is simply that the full symbolic information and data types must be downloaded from the ADS Device by the symbol loader.
Example
Automatic marshalling values with 'Dynamic Values'
using (TcAdsClient client = new TcAdsClient())
{
uint valueToRead = 0;
uint valueToWrite = 42;

client.Connect(AmsNetId.Local, 851);

// Load all Symbols + DataTypes
// Primitive Parts will be automatically resolved to .NET Primitive types.
IDynamicSymbolLoader loader = (IDynamicSymbolLoader)SymbolLoaderFactory.Create(client, SymbolLoaderSettings.DefaultDynamic);

dynamic symbols = loader.SymbolsDynamic;
dynamic main = symbols.Main;

// Use typed object to use InfoTips
DynamicSymbol nCounter = main.nCounter; // UDINT

// or to be fullDynamic
//dynamic nCounter = main.nCounter;

// Works for ALL sorts of types (not restricted to ANY_TYPE basing primitive types)
valueToRead = (uint)nCounter.ReadValue();
// or
var varValue = nCounter.ReadValue();
// or
dynamic dynValue = nCounter.ReadValue();

// Same for writing
nCounter.WriteValue(valueToWrite);

// Or Notifications / Events
nCounter.ValueChanged += NCounter_ValueChanged;

//Reading complexTypes e.g. Struct

DynamicSymbol myStructSymbol = main.plcStruct; // Dynamically created
dynamic myStructVal = myStructSymbol.ReadValue(); // Takes an ADS Snapshot of the value

dynamic int1Val = myStructVal.int1; // Value to an INT (short)
dynamic valueNestedStruct = myStructVal.nestedStruct; //value to another complex type (here a nested Struct)

myStructSymbol.ValueChanged += MyStructSymbol_ValueChanged;
}
Automatic marshalling values with 'Dynamic Values'
private void NCounter_ValueChanged(object sender, ValueChangedArgs e)
{
var uintVal = e.Value;
}

private void MyStructSymbol_ValueChanged(object sender, ValueChangedArgs e)
{
dynamic structValue = e.Value; // Snapshot of the whole Struct and all its contents
}
Calling 'ReadValue' or the 'ValueChanged' notification takes a full snapshot (with snapshot time) of the value. That means, when for example subelements of a struct value will be accessed, all subvalues will represent the value of that snapshot time consistently. Starting point is always the 'DynamicSymbol' object that called 'ReadValue'.
An update of the value can be done directly on the value with 'UpdateValue', or with reading a new Value on the 'DynamicSymbol' ('ReadValue').
The 'ValueChanged' event on the 'DynamicSymbol' assigns a Notification for just this symbol. The 'ValueChanged' Handler will contain the value completely marshalled as dynamic object.


Reactive Extensions and ADS

Concepts [image] Reactive Extensions and ADS
Reactive Extensions and ADS
The Reactive Extensions (Rx) is a .NET library for composing asynchronous and event-based programs using observable sequences and LINQ-style query operators. Using Rx, developers represent asynchronous data streams with Observables, query asynchronous data streams using LINQ operators, and parameterize the concurrency in the asynchronous data streams using Schedulers. Simply put, Rx = Observables + LINQ + Schedulers.
In ADS terms, not only the reading and writing data or symbol values can be put into reactive data streams, also ADS Notifications are a perfect fit for reactive code. This eases not only data binding to reactive frameworks (e.g. reactive UI) but also supports enhanced data manipulation via synchronous and asynchronous observers. Multithreaded and parallized code paths that support multiple CPU cores can be written very easily without the burden of deadlock and synchronization issues.
More about .NET reactive extensions can be read here: Reactive extensions project site.
The TwinCAT ADS Reactive extensions are available via a supplement Nuget Package: Beckhoff.TwinCAT.Ads.Reactive Nuget Package
Example
Observe for Notifications
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Reactive Notification Handler
var valueObserver = Observer.Create<ushort>(val =>
{
Console.WriteLine(string.Format("Value: {0}", val.ToString()));
}
);

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = client.WhenNotification<ushort>("TwinCAT_SystemInfoVarList._TaskInfo.CycleCount", NotificationSettings.Default).Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Observe for Symbol Notifications
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo[1].CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

cycleCount.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 500, 5000); // optional: Change NotificationSettings on Symbol

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = cycleCount.WhenValueChanged().Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Observer for dynamic Symbol Notifications
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = (IDynamicSymbolLoader)SymbolLoaderFactory.Create(client, SymbolLoaderSettings.DefaultDynamic);
dynamic symbols = symbolLoader.SymbolsDynamic;
dynamic cycleCount = symbols.TwinCAT_SystemInfoVarList._TaskInfo[1].CycleCount;

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
// Value objects can be dynamically (on the fly) created objects here (e.g. structs)
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

cycleCount.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 500, 5000); // optional: Change NotificationSettings on Symbol

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
// We have to give the 'hint' about IValueSymbol here, that the CLR finds the Extension Method 'WhenValueChanged' during runtime.
IDisposable subscription = ((IValueSymbol)cycleCount).WhenValueChanged().Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Polling observer
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo.CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

// Take 20 Values in an Interval of 500ms
IDisposable subscription = cycleCount.PollValues(TimeSpan.FromMilliseconds(500)).Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Writing values with observable subject
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information (Symbol 'i : INT' in PLC Global Variables list.
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol gvlIntSymbol = (IValueSymbol)symbolLoader.Symbols["GVL.i"];

// Produces object (short) Values 0,1,2,3 ... in seconds period
IObservable<object> timerObservable = Observable.Interval(TimeSpan.FromSeconds(1.0)).Select(i => (object)(short)i);

// Take 10 Values (0..9) and write them to GVL.i
IDisposable dispose = gvlIntSymbol.WriteValues(timerObservable.Take(10));

Console.ReadKey(); // Wait for Key press
dispose.Dispose(); // Dispose the Subscription
}


HowTo Samples

HowTo Samples
HowTo Samples
The topics in this section describe the various changes made to the 'TwinCAT.Ads .NET API' over the life of the project.
HowTo
How to use the .NET TwinCAT API
Sample | Description
Reading/writing (simple) values from/to ADS Servers. | Read/Write values
Reading/writing string values. | Read/Write string values
Event driven reading (ADS Notifications) | Event driven reading
Read/Write data from/to ADS Servers using reactive extensions | Reactive Read/Write
Other Resources
TwinCAT ADS .NET API Documentation
Weiterführende Informationen
•
Read/Write primitive values
•
Read/Write string types
•
Read/Write PlcOpen types (DATE, TIME ...)
•
Event driven read with ADS Notifications
•
Reactive Read/Write with Reactive Extensions


Read/Write primitive values

HowTo Samples [image] Read/Write primitive values
Read/Write primitive values
Reading writing Values from ADS Devices is the most essential part of the communication API. There are several options for communication with your application.
▪
Accessing by IndexGroup / IndexOffset
▪
Symbolic access by instance path and optionally use handles for the symbol
▪
Holding the overall Symbolic information in the SymbolLoader and use easy access via symbol objects.
▪
Usage the symbolic interface ITcAdsSymbol when complete SymbolLoading by SymbolLoaders is not appropriate.
▪
Reading / Writing values as .NET managed Types (primitive types or compound primitive types called ANY_TYPES), or complex dynamic types typesafe generated at runtime.
The following section shows the different scenarios as code snippets.
HowTo Read/Write Values
Read/Write AnyType by IndexGroup/IndexOffset
using (TcAdsClient client = new TcAdsClient())
{
UInt32 valueToRead = 0;
UInt32 valueToWrite = 42;

client.Connect(AmsNetId.Local, 851);
adsClient.WriteAny(0x4020, 0x0, valueToWrite);
valueToRead = (uint)adsClient.ReadAny(0x4020, 0x0, typeof(UInt32));
}
Read/Write AnyType by variable handle
using (TcAdsClient client = new TcAdsClient())
{
int varHandle = 0;
client.Connect(AmsNetId.Local, 851);
try
{
UInt32 valueToRead = 0;
UInt32 valueToWrite = 42;

varHandle = client.CreateVariableHandle("MAIN.nCounter");
adsClient.WriteAny(varHandle, valueToWrite);
valueToRead = (uint)adsClient.ReadAny(varHandle, typeof(UInt32));
}
finally
{
// Unregister VarHandle after Use
client.DeleteVariableHandle(varHandle);
}
}
Read/Write AnyType by instance/symbol path
using (TcAdsClient client = new TcAdsClient())
{
UInt32 valueToRead = 0;
UInt32 valueToWrite = 42;

client.Connect(AmsNetId.Local, 851);
adsClient.WriteSymbol("MAIN.nCounter", valueToWrite, false);
valueToRead = (uint)adsClient.ReadSymbol("MAIN.nCounter", typeof(UInt32),false);
}
Read/Write AnyType by IAdsSymbol
using (TcAdsClient client = new TcAdsClient())
{
UInt32 valueToRead = 0;
UInt32 valueToWrite = 42;

client.Connect(AmsNetId.Local, 851);

ITcAdsSymbol symbol = adsClient.ReadSymbolInfo("MAIN.nCounter");
adsClient.WriteSymbol(symbol, valueToWrite);
valueToRead = (uint)adsClient.ReadSymbol(symbol);
}
Read/Write AnyType by SymbolBrowser
using (TcAdsClient client = new TcAdsClient())
{
UInt32 valueToRead = 0;
UInt32 valueToWrite = 42;

client.Connect(AmsNetId.Local, 851);

// Load all Symbols + DataTypes
ISymbolLoader loader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
Symbol symbol = (Symbol)loader.Symbols["MAIN.nCounter"];

// Works for ALL Primitive 'ANY TYPES' Symbols
symbol.WriteValue(valueToWrite);
valueToRead = (UInt32)symbol.ReadValue();
}
Read/Write dynamic types by SymbolBrowser
using (TcAdsClient client = new TcAdsClient())
{
UInt32 valueToRead = 0;
UInt32 valueToWrite = 42;

client.Connect(AmsNetId.Local, 851);

// Load all Symbols + DataTypes
// Primitive Parts will be automatically resolved to .NET Primitive types.
IDynamicSymbolLoader loader = (IDynamicSymbolLoader)SymbolLoaderFactory.Create(client, SymbolLoaderSettings.DefaultDynamic);

dynamic symbols = loader.SymbolsDynamic;
dynamic main = symbols.Main;

// Use typed object to use InfoTips
DynamicSymbol nCounter = main.nCounter;

// or to be fullDynamic
//dynamic nCounter = main.nCounter;

// Works for ALL sorts of types (not restricted to ANY_TYPE basing primitive types)
nCounter.WriteValue(valueToWrite);
valueToRead = (uint)nCounter.ReadValue();
}


Read/Write string types

HowTo Samples [image] Read/Write string types
Read/Write string types
ADS Server usually support strings in 2 flavors. The Default (ANSI) and the Unicode encoding (STRING vs. WSTRING) The ANSI encoding reserves 1 byte per character. Unicode reserves 2.
The strings are of fixed size and therefore the length of the the reserved space within the process image is important.
HowTo Read/Write string values
Reading writing ANSI Streams:
Read/Write ANSI Strings
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local port 851 (PLC)

int handle = client.CreateVariableHandle("MAIN.string"); // Symbol "string" in MAIN defined as string

try
{
// Read ANSI String string[80]
int byteSize = 81; // Size of 80 ANSI chars + /0 (STRING[80])
AdsStream readStream = new AdsStream(byteSize); // Size of 80 ANSI chars + /0 (STRING[80])
AdsBinaryReader reader = new AdsBinaryReader(readStream);
client.Read(handle, readStream, 0, byteSize); // Read 81 bytes
string value = reader.ReadPlcString(byteSize,Encoding.Default);

// Write ANSI String string[80]
AdsStream writeStream = new AdsStream(byteSize);
AdsBinaryWriter writer = new AdsBinaryWriter(writeStream);
value = "Changed";
writer.WritePlcString(value, 80,Encoding.Default); // Max 80 characters!
client.Write(handle, writeStream, 0, byteSize);
}
finally
{
client.DeleteVariableHandle(handle);
}
}
Reading writing UNICODE Streams:
Read/Write Unicode Strings
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local port 851 (PLC)

int handle = client.CreateVariableHandle("MAIN.wstring"); // Symbol "wstring" defined in MAIN as WSTRING

try
{
// Read UNICODE String wstring[80]
int byteSize = 2 * 81; // Size of 80 UNICODE chars + /0 (WSTRING[80])
AdsStream readStream = new AdsStream(byteSize);
AdsBinaryReader reader = new AdsBinaryReader(readStream);
client.Read(handle, readStream, 0, byteSize); // Read 2*81 bytes
string value = reader.ReadPlcString(byteSize,Encoding.Unicode);

// Write ANSI String string[80]
AdsStream writeStream = new AdsStream(byteSize);
AdsBinaryWriter writer = new AdsBinaryWriter(writeStream);
value = "Changed";
writer.WritePlcString(value, 80,Encoding.Unicode);
client.Write(handle, writeStream, 0, byteSize);
}
finally
{
client.DeleteVariableHandle(handle);
}
}
Reading writing strings with ReadAny/WriteAny group of methods:
Read/Write Unicode Strings
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local port 851 (PLC)

int stringHandle = client.CreateVariableHandle("MAIN.string"); // Symbol "string" defined in MAIN as STRING
int wStringHandle = client.CreateVariableHandle("MAIN.wstring"); // Symbol "string" defined in MAIN as WSTRING

try
{
string str = client.ReadAnyString(stringHandle, 80, Encoding.Default);
string wStr = client.ReadAnyString(wStringHandle, 80, Encoding.Unicode);

string changedValue = "Changed";

// Attention, take care that the memory of the string in the process image is not exceeded!
client.WriteAnyString(stringHandle, changedValue, 80, Encoding.Default);
client.WriteAnyString(wStringHandle, changedValue, 80, Encoding.Unicode);
}
finally
{
client.DeleteVariableHandle(stringHandle);
client.DeleteVariableHandle(wStringHandle);
}
}


Read/Write PlcOpen types (DATE, TIME ...)

HowTo Samples [image] Read/Write PlcOpen types (DATE, TIME ...)
Read/Write PlcOpen types (DATE, TIME ...)
The following PLCOpen types have specific representations within the TwinCAT.Ads Communication Library: DT
▪
DT
▪
DATE
▪
TIME
▪
LTIME
▪
TOD
The following section shows the different scenarios as code snippets.
HowTo Read/Write PlcOpen values
Reading writing by streams:
Read/Write PlcOpen types (streamed)
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local plc

int handle1 = 0;
int handle2 = 0;

try
{
handle1 = client.CreateVariableHandle("MAIN.time"); // TIME
handle2 = client.CreateVariableHandle("MAIN.date"); // DATE

AdsStream readStream = new AdsStream(LTIME.MarshalSize); // Largest (8 Bytes)
AdsBinaryReader reader = new AdsBinaryReader(readStream);

client.Read(handle1, readStream, 0, TIME.MarshalSize);
TimeSpan time = reader.ReadPlcTIME();

client.Read(handle2, readStream, 0, DATE.MarshalSize);
DateTime dateTime = reader.ReadPlcDATE();
}
finally
{
client.DeleteVariableHandle(handle1);
client.DeleteVariableHandle(handle2);
}
}
Reading writing by ANY type concept:
Read/Write PlcOpen types (ANY)
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local plc

int handle1 = 0;
int handle2 = 0;
int handle3 = 0;

try
{
handle1 = client.CreateVariableHandle("MAIN.time"); // TIME
handle2 = client.CreateVariableHandle("MAIN.date"); // DATE
handle3 = client.CreateVariableHandle("MAIN.ltime"); // LTIME

TIME time = (TIME)client.ReadAny(handle1, typeof(TIME)); // TIME
TimeSpan timeSpan = time.Time;

DATE date = (DATE)client.ReadAny(handle2, typeof(DATE)); // DATE
DateTime dateTime = date.Date;

LTIME ltime = (LTIME)client.ReadAny(handle3, typeof(LTIME)); // LTIME
TimeSpan lTimeSpan = ltime.Time;
}
finally
{
client.DeleteVariableHandle(handle1);
client.DeleteVariableHandle(handle2);
client.DeleteVariableHandle(handle3);
}
}


Event driven read with ADS Notifications

HowTo Samples [image] Event driven read with ADS Notifications
Event driven read with ADS Notifications
Use of ADS Notifications
Trigger on changed values by ADS Notifications
AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event handler
client.AdsNotification += Client_AdsNotification;

// Connect to target
client.Connect("1.2.3.4.5.6", 851);
int notificationHandle = 0;

try
{
// Notification to a DINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotification("MAIN.nCounter", readStream, AdsTransMode.OnChange, 200, 0, null);
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotification -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationEventArgs e)
{
int offset = (int)e.DataStream.Position;
int length = (int)e.DataStream.Length;

e.DataStream.Position = offset;
AdsBinaryReader reader = new AdsBinaryReader(e.DataStream);

// Read the Unmarshalled data
//byte[] data = reader.ReadBytes(length);

// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = reader.ReadUInt32();
}


Reactive Read/Write with Reactive Extensions

HowTo Samples [image] Reactive Read/Write with Reactive Extensions
Reactive Read/Write with Reactive Extensions
Observation of Notifications
Notifications (address specified by InstancePath) will be received cyclically as defined in Default and put into the Observer pipeline for further processing. This example takes 20 Notification samples before returning.
Observe for Notifications
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Reactive Notification Handler
var valueObserver = Observer.Create<ushort>(val =>
{
Console.WriteLine(string.Format("Value: {0}", val.ToString()));
}
);

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = client.WhenNotification<ushort>("TwinCAT_SystemInfoVarList._TaskInfo.CycleCount", NotificationSettings.Default).Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Observation of Symbolic Notifications
This example determines a symbol via Symbolloader and samples its values by Notifications with customized NotificationSettings. Again 20 samples are taken before the Observation finishes.
Observe for Symbol Notifications
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo[1].CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

cycleCount.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 500, 5000); // optional: Change NotificationSettings on Symbol

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = cycleCount.WhenValueChanged().Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Observation of dynamic Symbol Notifications
Here, the symbol is determined via Symbolloader again, but now the Notifications will be processed as 'dynamic' values.
Observer for dynamic Symbol Notifications
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = (IDynamicSymbolLoader)SymbolLoaderFactory.Create(client, SymbolLoaderSettings.DefaultDynamic);
dynamic symbols = symbolLoader.SymbolsDynamic;
dynamic cycleCount = symbols.TwinCAT_SystemInfoVarList._TaskInfo[1].CycleCount;

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
// Value objects can be dynamically (on the fly) created objects here (e.g. structs)
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

cycleCount.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 500, 5000); // optional: Change NotificationSettings on Symbol

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
// We have to give the 'hint' about IValueSymbol here, that the CLR finds the Extension Method 'WhenValueChanged' during runtime.
IDisposable subscription = ((IValueSymbol)cycleCount).WhenValueChanged().Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Polling observer
A polling observer doesn't use ADS notifications, but instead the value read is triggered by a time interval (polling) or a customized trigger function (on request).
Polling observer
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo.CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

// Take 20 Values in an Interval of 500ms
IDisposable subscription = cycleCount.PollValues(TimeSpan.FromMilliseconds(500)).Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Writing values with observable subject
In this example, a symbolic value is written in a static time interval (1 second). The writing stops after 10 values. The WriteValues extension method can be used to seamlessly bind value writing into a reactive application.
Writing values with observable subject
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information (Symbol 'i : INT' in PLC Global Variables list.
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol gvlIntSymbol = (IValueSymbol)symbolLoader.Symbols["GVL.i"];

// Produces object (short) Values 0,1,2,3 ... in seconds period
IObservable<object> timerObservable = Observable.Interval(TimeSpan.FromSeconds(1.0)).Select(i => (object)(short)i);

// Take 10 Values (0..9) and write them to GVL.i
IDisposable dispose = gvlIntSymbol.WriteValues(timerObservable.Take(10));

Console.ReadKey(); // Wait for Key press
dispose.Dispose(); // Dispose the Subscription
}


TwinCAT.Ads Namespaces

TwinCAT.Ads Namespaces
TwinCAT.Ads Namespaces
TwinCAT ADS .NET API
Namespaces
Namespace | Description
TwinCAT | Common namespace for types that are not specific to ADS.
TwinCAT.Ads | ADS root namespace.
TwinCAT.Ads.Reactive | Reactive Extensions for the ADS Client. All types within are contained in the ADS companion package "Beckhoff.TwinCAT.Ads.Reactive" which must be referenced seperately. https://www.nuget.org/packages/Beckhoff.TwinCAT.Ads.Reactive/
TwinCAT.Ads.SumCommand | ADS offers powerful and fast communication to exchange any kind of information. It's possible to read single variables or complete arrays and structures with each one single ADS-API call. ADS Sum-Commands offer to read/write with one single ADS call multiple variables which are not structured within a linear memory, effectivly reducing roundtrips.
TwinCAT.Ads.TypeSystem | Root namespace for the ADS type system.
TwinCAT.Ads.ValueAccess | Root namespace for ADS value access.
TwinCAT.PlcOpen |
TwinCAT.TypeSystem | Namespace for the common (non ADS dependant) type system.
TwinCAT.TypeSystem.Generic | Namespace for the dynamic part of the common type system.
TwinCAT.ValueAccess | Namespace for the common (non ADS dependant) value access.
Weiterführende Informationen
•
TwinCAT Namespace
•
TwinCAT.Ads Namespace
•
TwinCAT.Ads.Reactive Namespace
•
TwinCAT.Ads.SumCommand Namespace
•
TwinCAT.Ads.TypeSystem Namespace
•
TwinCAT.Ads.ValueAccess Namespace
•
TwinCAT.PlcOpen Namespace
•
TwinCAT.TypeSystem Namespace
•
TwinCAT.TypeSystem.Generic Namespace
•
TwinCAT.ValueAccess Namespace


TwinCAT Namespace

TwinCAT.Ads Namespaces [image] TwinCAT Namespace
TwinCAT Namespace
Common namespace for types that are not specific to ADS.
Classes
Class | Description
CannotAccessVirtualSymbolException | Cannot access virtual Symbol
ClientNotConnectedException | Class ClientNotConnectedException
ConnectionStateChangedEventArgs | Event arguments for the Connection status changed event.
InsufficientAccessRights | Insufficient rights for access
Session | Abstract Session base class.
SessionConnectionStateChangedEventArgs | EventArguments for the ConnectionStatusChanged events.
SessionException | Session Exception
SessionNotConnectedException | Class SessionNotConnectedException.
SessionProvider.S, A, C. | Abstract base class for a Custom Session provider
Interfaces
Interface | Description
IConnection | Interface IConnection
IConnectionStateProvider | Interface IConnectionStateProvider
ISession | Interface ISession
ISessionSettings | Interface ISessionSettings
ISymbolLoaderSettings | Interface ISymbolLoaderSettings
Enumerations
Enumeration | Description
ConnectionState | Connection state enumeration
ConnectionStateChangedReason | Reason for the Connection status changed event.
SessionProviderCapabilities | Enum SessionProviderCapabilities
SymbolsLoadMode | Enum SymbolsLoadMode
Weiterführende Informationen
•
CannotAccessVirtualSymbolException Class
•
ClientNotConnectedException Class
•
ConnectionState Enumeration
•
ConnectionStateChangedEventArgs Class
•
ConnectionStateChangedReason Enumeration
•
IConnection Interface
•
IConnectionStateProvider Interface
•
InsufficientAccessRights Class
•
ISession Interface
•
ISessionSettings Interface
•
ISymbolLoaderSettings Interface
•
Session Class
•
SessionConnectionStateChangedEventArgs Class
•
SessionException Class
•
SessionNotConnectedException Class
•
SessionProvider.S, A, C. Class
•
SessionProviderCapabilities Enumeration
•
SymbolsLoadMode Enumeration


CannotAccessVirtualSymbolException Class

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] CannotAccessVirtualSymbolException Class
CannotAccessVirtualSymbolException Class
Cannot access virtual Symbol
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.Ads.SymbolException
TwinCAT.CannotAccessVirtualSymbolException
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class CannotAccessVirtualSymbolException : SymbolException
VB
<SerializableAttribute>
Public Class CannotAccessVirtualSymbolException
Inherits SymbolException
The CannotAccessVirtualSymbolException type exposes the following members.
Constructors
Name | Description
CannotAccessVirtualSymbolException | Initializes a new instance of the CannotAccessVirtualSymbolException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Fields
Name | Description
Symbol | Symbol that is bound to the SymbolException (Inherited from SymbolException.)
Reference
TwinCAT Namespace
Weiterführende Informationen
•
CannotAccessVirtualSymbolException Constructor
•
CannotAccessVirtualSymbolException Properties
•
CannotAccessVirtualSymbolException Methods
•
CannotAccessVirtualSymbolException Events
•
CannotAccessVirtualSymbolException Fields


CannotAccessVirtualSymbolException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] CannotAccessVirtualSymbolException Class [image] CannotAccessVirtualSymbolException Constructor
CannotAccessVirtualSymbolException Constructor
Initializes a new instance of the CannotAccessVirtualSymbolException class.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public CannotAccessVirtualSymbolException(
ISymbol symbol
)
VB
Public Sub New (
symbol As ISymbol
)
Parameters
symbol
Type: TwinCAT.TypeSystem.ISymbol
The symbol.
Reference
CannotAccessVirtualSymbolException Class
TwinCAT Namespace


CannotAccessVirtualSymbolException Properties

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] CannotAccessVirtualSymbolException Class [image] CannotAccessVirtualSymbolException Properties
CannotAccessVirtualSymbolException Properties
The CannotAccessVirtualSymbolException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
CannotAccessVirtualSymbolException Class
TwinCAT Namespace


CannotAccessVirtualSymbolException Methods

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] CannotAccessVirtualSymbolException Class [image] CannotAccessVirtualSymbolException Methods
CannotAccessVirtualSymbolException Methods
The CannotAccessVirtualSymbolException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
CannotAccessVirtualSymbolException Class
TwinCAT Namespace


CannotAccessVirtualSymbolException Events

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] CannotAccessVirtualSymbolException Class [image] CannotAccessVirtualSymbolException Events
CannotAccessVirtualSymbolException Events
The CannotAccessVirtualSymbolException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
CannotAccessVirtualSymbolException Class
TwinCAT Namespace


CannotAccessVirtualSymbolException Fields

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] CannotAccessVirtualSymbolException Class [image] CannotAccessVirtualSymbolException Fields
CannotAccessVirtualSymbolException Fields
The CannotAccessVirtualSymbolException type exposes the following members.
Fields
Name | Description
Symbol | Symbol that is bound to the SymbolException (Inherited from SymbolException.)
Reference
CannotAccessVirtualSymbolException Class
TwinCAT Namespace


ClientNotConnectedException Class

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ClientNotConnectedException Class
ClientNotConnectedException Class
Class ClientNotConnectedException
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.ClientNotConnectedException
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class ClientNotConnectedException : AdsException
VB
<SerializableAttribute>
Public Class ClientNotConnectedException
Inherits AdsException
The ClientNotConnectedException type exposes the following members.
Constructors
Name | Description
ClientNotConnectedException | Initializes a new instance of the ClientNotConnectedException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
TwinCAT Namespace
Weiterführende Informationen
•
ClientNotConnectedException Constructor
•
ClientNotConnectedException Properties
•
ClientNotConnectedException Methods
•
ClientNotConnectedException Events


ClientNotConnectedException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ClientNotConnectedException Class [image] ClientNotConnectedException Constructor
ClientNotConnectedException Constructor
Initializes a new instance of the ClientNotConnectedException class.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ClientNotConnectedException()
VB
Public Sub New
Reference
ClientNotConnectedException Class
TwinCAT Namespace


ClientNotConnectedException Properties

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ClientNotConnectedException Class [image] ClientNotConnectedException Properties
ClientNotConnectedException Properties
The ClientNotConnectedException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
ClientNotConnectedException Class
TwinCAT Namespace


ClientNotConnectedException Methods

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ClientNotConnectedException Class [image] ClientNotConnectedException Methods
ClientNotConnectedException Methods
The ClientNotConnectedException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
ClientNotConnectedException Class
TwinCAT Namespace


ClientNotConnectedException Events

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ClientNotConnectedException Class [image] ClientNotConnectedException Events
ClientNotConnectedException Events
The ClientNotConnectedException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
ClientNotConnectedException Class
TwinCAT Namespace


ConnectionState Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionState Enumeration
ConnectionState Enumeration
Connection state enumeration
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum ConnectionState
VB
Public Enumeration ConnectionState
Members
Member name | Value | Description
None | 0 | Unknown / Uninitialized
Unknown | 0 | Unknown / Uninitialized
Disconnected | 1 | Disconnected
Connected | 2 | Connected
Lost | 3 | Connection lost
Reference
TwinCAT Namespace


ConnectionStateChangedEventArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionStateChangedEventArgs Class
ConnectionStateChangedEventArgs Class
Event arguments for the Connection status changed event.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.ConnectionStateChangedEventArgs
TwinCAT.SessionConnectionStateChangedEventArgs
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ConnectionStateChangedEventArgs : EventArgs
VB
Public Class ConnectionStateChangedEventArgs
Inherits EventArgs
The ConnectionStateChangedEventArgs type exposes the following members.
Constructors
Name | Description
ConnectionStateChangedEventArgs(ConnectionStateChangedReason, ConnectionState, ConnectionState) | Constructs the ConnectionStateChangedEventArgs arguments.
ConnectionStateChangedEventArgs(ConnectionStateChangedReason, ConnectionState, ConnectionState, Exception) | Constructs the ConnectionStateChangedEventArgs arguments.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
Exception | Exception, (only for Error
NewState | New connection state
OldState | Old connection state
Reason | Reason for the event
Reference
TwinCAT Namespace
Weiterführende Informationen
•
ConnectionStateChangedEventArgs Constructor
•
ConnectionStateChangedEventArgs Methods
•
ConnectionStateChangedEventArgs Fields


ConnectionStateChangedEventArgs Constructor

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionStateChangedEventArgs Class [image] ConnectionStateChangedEventArgs Constructor
ConnectionStateChangedEventArgs Constructor
Overload List
Name | Description
ConnectionStateChangedEventArgs(ConnectionStateChangedReason, ConnectionState, ConnectionState) | Constructs the ConnectionStateChangedEventArgs arguments.
ConnectionStateChangedEventArgs(ConnectionStateChangedReason, ConnectionState, ConnectionState, Exception) | Constructs the ConnectionStateChangedEventArgs arguments.
Reference
ConnectionStateChangedEventArgs Class
TwinCAT Namespace
Weiterführende Informationen
•
ConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState)
•
ConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, Exception)


ConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState)

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionStateChangedEventArgs Class [image] ConnectionStateChangedEventArgs Constructor [image] ConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState)
ConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState)
Constructs the ConnectionStateChangedEventArgs arguments.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ConnectionStateChangedEventArgs(
ConnectionStateChangedReason reason,
ConnectionState newState,
ConnectionState oldState
)
VB
Public Sub New (
reason As ConnectionStateChangedReason,
newState As ConnectionState,
oldState As ConnectionState
)
Parameters
reason | Type: TwinCAT.ConnectionStateChangedReason The reason.
newState | Type: TwinCAT.ConnectionState The new state.
oldState | Type: TwinCAT.ConnectionState The old state.
Reference
ConnectionStateChangedEventArgs Class
ConnectionStateChangedEventArgs Overload
TwinCAT Namespace


ConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionStateChangedEventArgs Class [image] ConnectionStateChangedEventArgs Constructor [image] ConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, Exception)
ConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, Exception)
Constructs the ConnectionStateChangedEventArgs arguments.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ConnectionStateChangedEventArgs(
ConnectionStateChangedReason reason,
ConnectionState newState,
ConnectionState oldState,
Exception e
)
VB
Public Sub New (
reason As ConnectionStateChangedReason,
newState As ConnectionState,
oldState As ConnectionState,
e As Exception
)
Parameters
reason | Type: TwinCAT.ConnectionStateChangedReason The reason.
newState | Type: TwinCAT.ConnectionState The new state.
oldState | Type: TwinCAT.ConnectionState The old state.
e | Type: System.Exception The e.
Reference
ConnectionStateChangedEventArgs Class
ConnectionStateChangedEventArgs Overload
TwinCAT Namespace


ConnectionStateChangedEventArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionStateChangedEventArgs Class [image] ConnectionStateChangedEventArgs Methods
ConnectionStateChangedEventArgs Methods
The ConnectionStateChangedEventArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
ConnectionStateChangedEventArgs Class
TwinCAT Namespace


ConnectionStateChangedEventArgs Fields

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionStateChangedEventArgs Class [image] ConnectionStateChangedEventArgs Fields
ConnectionStateChangedEventArgs Fields
The ConnectionStateChangedEventArgs type exposes the following members.
Fields
Name | Description
Exception | Exception, (only for Error
NewState | New connection state
OldState | Old connection state
Reason | Reason for the event
Reference
ConnectionStateChangedEventArgs Class
TwinCAT Namespace
Weiterführende Informationen
•
ConnectionStateChangedEventArgs.Exception Field
•
ConnectionStateChangedEventArgs.NewState Field
•
ConnectionStateChangedEventArgs.OldState Field
•
ConnectionStateChangedEventArgs.Reason Field


ConnectionStateChangedEventArgs.Exception Field

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionStateChangedEventArgs Class [image] ConnectionStateChangedEventArgs Fields [image] ConnectionStateChangedEventArgs.Exception Field
ConnectionStateChangedEventArgs.Exception Field
Exception, (only for Error
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly Exception Exception
VB
Public ReadOnly Exception As Exception
Field Value
Type: Exception
Reference
ConnectionStateChangedEventArgs Class
TwinCAT Namespace


ConnectionStateChangedEventArgs.NewState Field

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionStateChangedEventArgs Class [image] ConnectionStateChangedEventArgs Fields [image] ConnectionStateChangedEventArgs.NewState Field
ConnectionStateChangedEventArgs.NewState Field
New connection state
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly ConnectionState NewState
VB
Public ReadOnly NewState As ConnectionState
Field Value
Type: ConnectionState
Reference
ConnectionStateChangedEventArgs Class
TwinCAT Namespace


ConnectionStateChangedEventArgs.OldState Field

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionStateChangedEventArgs Class [image] ConnectionStateChangedEventArgs Fields [image] ConnectionStateChangedEventArgs.OldState Field
ConnectionStateChangedEventArgs.OldState Field
Old connection state
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly ConnectionState OldState
VB
Public ReadOnly OldState As ConnectionState
Field Value
Type: ConnectionState
Reference
ConnectionStateChangedEventArgs Class
TwinCAT Namespace


ConnectionStateChangedEventArgs.Reason Field

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionStateChangedEventArgs Class [image] ConnectionStateChangedEventArgs Fields [image] ConnectionStateChangedEventArgs.Reason Field
ConnectionStateChangedEventArgs.Reason Field
Reason for the event
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly ConnectionStateChangedReason Reason
VB
Public ReadOnly Reason As ConnectionStateChangedReason
Field Value
Type: ConnectionStateChangedReason
Reference
ConnectionStateChangedEventArgs Class
TwinCAT Namespace


ConnectionStateChangedReason Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ConnectionStateChangedReason Enumeration
ConnectionStateChangedReason Enumeration
Reason for the Connection status changed event.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum ConnectionStateChangedReason
VB
Public Enumeration ConnectionStateChangedReason
Members
Member name | Value | Description
None | 0 | None / Uninitialized
Established | 1 | The connection to the target has been established
Closed | 2 | The Connection was closed
Lost | 3 | The connection to the target has been lost
Error | 4 | Communication error to the target (the connection is not shutting down)
Resurrected | 5 | Communication was resurrected (available again)
Reference
TwinCAT Namespace


IConnection Interface

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnection Interface
IConnection Interface
Interface IConnection
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IConnection : IConnectionStateProvider
VB
Public Interface IConnection
Inherits IConnectionStateProvider
The IConnection type exposes the following members.
Properties
Name | Description
ConnectionState | Gets the current Connection state of the IConnectionStateProvider (Inherited from IConnectionStateProvider.)
Id | Gets the Connection Identifier .
IsConnected | Gets a value indicating whether the local ADS port was opened successfully. It does not indicate if the target port is available. Use the method ReadState to determine if the target port is available.
Session | Gets the session that initiated this IConnection
Timeout | Gets the timeout (in milliseconds)
Methods
Name | Description
Close | Closes this IConnection
Connect | (Re)Connects the IConnection when disconnected.
Disconnect | Disconnects this IConnection.
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed. (Inherited from IConnectionStateProvider.)
Reference
TwinCAT Namespace
Weiterführende Informationen
•
IConnection Properties
•
IConnection Methods
•
IConnection Events


IConnection Properties

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnection Interface [image] IConnection Properties
IConnection Properties
The IConnection type exposes the following members.
Properties
Name | Description
ConnectionState | Gets the current Connection state of the IConnectionStateProvider (Inherited from IConnectionStateProvider.)
Id | Gets the Connection Identifier .
IsConnected | Gets a value indicating whether the local ADS port was opened successfully. It does not indicate if the target port is available. Use the method ReadState to determine if the target port is available.
Session | Gets the session that initiated this IConnection
Timeout | Gets the timeout (in milliseconds)
Reference
IConnection Interface
TwinCAT Namespace
Weiterführende Informationen
•
IConnection.Id Property
•
IConnection.IsConnected Property
•
IConnection.Session Property
•
IConnection.Timeout Property


IConnection.Id Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnection Interface [image] IConnection Properties [image] IConnection.Id Property
IConnection.Id Property
Gets the Connection Identifier .
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Id { get; }
VB
ReadOnly Property Id As Integer
Get
Property Value
Type: Int32
The identifier.
Reference
IConnection Interface
TwinCAT Namespace


IConnection.IsConnected Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnection Interface [image] IConnection Properties [image] IConnection.IsConnected Property
IConnection.IsConnected Property
Gets a value indicating whether the local ADS port was opened successfully. It does not indicate if the target port is available. Use the method ReadState to determine if the target port is available.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsConnected { get; }
VB
ReadOnly Property IsConnected As Boolean
Get
Property Value
Type: Boolean
Reference
IConnection Interface
TwinCAT Namespace


IConnection.Session Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnection Interface [image] IConnection Properties [image] IConnection.Session Property
IConnection.Session Property
Gets the session that initiated this IConnection
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ISession Session { get; }
VB
ReadOnly Property Session As ISession
Get
Property Value
Type: ISession
The session or NULL
Remarks
The Session can be null on standalone connections.
Reference
IConnection Interface
TwinCAT Namespace


IConnection.Timeout Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnection Interface [image] IConnection Properties [image] IConnection.Timeout Property
IConnection.Timeout Property
Gets the timeout (in milliseconds)
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Timeout { get; set; }
VB
Property Timeout As Integer
Get
Set
Property Value
Type: Int32
The timeout.
Reference
IConnection Interface
TwinCAT Namespace


IConnection Methods

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnection Interface [image] IConnection Methods
IConnection Methods
The IConnection type exposes the following members.
Methods
Name | Description
Close | Closes this IConnection
Connect | (Re)Connects the IConnection when disconnected.
Disconnect | Disconnects this IConnection.
Reference
IConnection Interface
TwinCAT Namespace
Weiterführende Informationen
•
IConnection.Close Method
•
IConnection.Connect Method
•
IConnection.Disconnect Method


IConnection.Close Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnection Interface [image] IConnection Methods [image] IConnection.Close Method
IConnection.Close Method
Closes this IConnection
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void Close()
VB
Sub Close
Remarks
Closed Connections cannot be reconnected (when disposable objects behind)
Reference
IConnection Interface
TwinCAT Namespace


IConnection.Connect Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnection Interface [image] IConnection Methods [image] IConnection.Connect Method
IConnection.Connect Method
(Re)Connects the IConnection when disconnected.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool Connect()
VB
Function Connect As Boolean
Return Value
Type: Boolean
Reference
IConnection Interface
TwinCAT Namespace


IConnection.Disconnect Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnection Interface [image] IConnection Methods [image] IConnection.Disconnect Method
IConnection.Disconnect Method
Disconnects this IConnection.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool Disconnect()
VB
Function Disconnect As Boolean
Return Value
Type: Boolean
Reference
IConnection Interface
TwinCAT Namespace


IConnection Events

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnection Interface [image] IConnection Events
IConnection Events
The IConnection type exposes the following members.
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed. (Inherited from IConnectionStateProvider.)
Reference
IConnection Interface
TwinCAT Namespace


IConnectionStateProvider Interface

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnectionStateProvider Interface
IConnectionStateProvider Interface
Interface IConnectionStateProvider
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IConnectionStateProvider
VB
Public Interface IConnectionStateProvider
The IConnectionStateProvider type exposes the following members.
Properties
Name | Description
ConnectionState | Gets the current Connection state of the IConnectionStateProvider
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed.
Reference
TwinCAT Namespace
Weiterführende Informationen
•
IConnectionStateProvider Properties
•
IConnectionStateProvider Events


IConnectionStateProvider Properties

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnectionStateProvider Interface [image] IConnectionStateProvider Properties
IConnectionStateProvider Properties
The IConnectionStateProvider type exposes the following members.
Properties
Name | Description
ConnectionState | Gets the current Connection state of the IConnectionStateProvider
Reference
IConnectionStateProvider Interface
TwinCAT Namespace
Weiterführende Informationen
•
IConnectionStateProvider.ConnectionState Property


IConnectionStateProvider.ConnectionState Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnectionStateProvider Interface [image] IConnectionStateProvider Properties [image] IConnectionStateProvider.ConnectionState Property
IConnectionStateProvider.ConnectionState Property
Gets the current Connection state of the IConnectionStateProvider
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ConnectionState ConnectionState { get; }
VB
ReadOnly Property ConnectionState As ConnectionState
Get
Property Value
Type: ConnectionState
The state of the connection.
Remarks
The Connection state changes only if the IConnection is established / shut down or active communication is triggered by the User of the IConnection object.
Examples
The following sample shows how to keep the ConnectionState updated by triggering ADS Communication.
Trigger ConnectionState changes in WPF Applications
private DispatcherTimer _timer = null;
private AdsSession _session = null;
//private AdsConnection _connection = null;

private void Window_Loaded(object sender, RoutedEventArgs e)
{
_session = new AdsSession(AmsNetId.Local, 10000);
IConnection connection = _session.Connect();
tbConnectionState.Text = connection.ConnectionState.ToString();
_session.ConnectionStateChanged += _session_ConnectionStateChanged;

_timer = new DispatcherTimer();
_timer.Interval = TimeSpan.FromMilliseconds(200);
_timer.Tick += TimerOnTick;

_timer.Start();
}

private void Window_Unloaded(object sender, RoutedEventArgs e)
{
_timer.Stop();
_session.Dispose();
}

private void _session_ConnectionStateChanged(object sender, TwinCAT.ConnectionStateChangedEventArgs e)
{
// ConnectionStateChanged will be triggered by communication Invokes
tbConnectionState.Text = e.NewState.ToString();
}

private void TimerOnTick(object sender, EventArgs eventArgs)
{
// The Timer Event will occur here in the UI thread because its an DispatcherTimer event!
// An active ADS request will trigger Connection State periodically!
StateInfo stateInfo;
if (_session.Connection.TryReadState(out stateInfo) == AdsErrorCode.NoError)
{
tbAdsState.Text = stateInfo.AdsState.ToString();
}
else
{
tbAdsState.Text = "Invalid";
}
}
Reference
IConnectionStateProvider Interface
TwinCAT Namespace
IConnectionStateProvider.ConnectionStateChanged


IConnectionStateProvider Events

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnectionStateProvider Interface [image] IConnectionStateProvider Events
IConnectionStateProvider Events
The IConnectionStateProvider type exposes the following members.
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed.
Reference
IConnectionStateProvider Interface
TwinCAT Namespace
Weiterführende Informationen
•
IConnectionStateProvider.ConnectionStateChanged Event


IConnectionStateProvider.ConnectionStateChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] IConnectionStateProvider Interface [image] IConnectionStateProvider Events [image] IConnectionStateProvider.ConnectionStateChanged Event
IConnectionStateProvider.ConnectionStateChanged Event
Occurs when connection status of the IConnectionStateProvider has been changed.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
event EventHandler<ConnectionStateChangedEventArgs> ConnectionStateChanged
VB
Event ConnectionStateChanged As EventHandler(Of ConnectionStateChangedEventArgs)
Value
Type: System.EventHandler.ConnectionStateChangedEventArgs.
Remarks
The Connection state changes only if the IConnection is established / shut down or active communication is triggered by the User of the IConnection object.
Examples
The following sample shows how to keep the ConnectionState updated by triggering ADS Communication.
Trigger ConnectionState changes in WPF Applications
private DispatcherTimer _timer = null;
private AdsSession _session = null;
//private AdsConnection _connection = null;

private void Window_Loaded(object sender, RoutedEventArgs e)
{
_session = new AdsSession(AmsNetId.Local, 10000);
IConnection connection = _session.Connect();
tbConnectionState.Text = connection.ConnectionState.ToString();
_session.ConnectionStateChanged += _session_ConnectionStateChanged;

_timer = new DispatcherTimer();
_timer.Interval = TimeSpan.FromMilliseconds(200);
_timer.Tick += TimerOnTick;

_timer.Start();
}

private void Window_Unloaded(object sender, RoutedEventArgs e)
{
_timer.Stop();
_session.Dispose();
}

private void _session_ConnectionStateChanged(object sender, TwinCAT.ConnectionStateChangedEventArgs e)
{
// ConnectionStateChanged will be triggered by communication Invokes
tbConnectionState.Text = e.NewState.ToString();
}

private void TimerOnTick(object sender, EventArgs eventArgs)
{
// The Timer Event will occur here in the UI thread because its an DispatcherTimer event!
// An active ADS request will trigger Connection State periodically!
StateInfo stateInfo;
if (_session.Connection.TryReadState(out stateInfo) == AdsErrorCode.NoError)
{
tbAdsState.Text = stateInfo.AdsState.ToString();
}
else
{
tbAdsState.Text = "Invalid";
}
}
Reference
IConnectionStateProvider Interface
TwinCAT Namespace
IConnectionStateProvider.ConnectionState


InsufficientAccessRights Class

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] InsufficientAccessRights Class
InsufficientAccessRights Class
Insufficient rights for access
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.Ads.SymbolException
TwinCAT.InsufficientAccessRights
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class InsufficientAccessRights : SymbolException
VB
<SerializableAttribute>
Public Class InsufficientAccessRights
Inherits SymbolException
The InsufficientAccessRights type exposes the following members.
Constructors
Name | Description
InsufficientAccessRights | Initializes a new instance of the InsufficientAccessRights class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Fields
Name | Description
Symbol | Symbol that is bound to the SymbolException (Inherited from SymbolException.)
Reference
TwinCAT Namespace
Weiterführende Informationen
•
InsufficientAccessRights Constructor
•
InsufficientAccessRights Properties
•
InsufficientAccessRights Methods
•
InsufficientAccessRights Events
•
InsufficientAccessRights Fields


InsufficientAccessRights Constructor

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] InsufficientAccessRights Class [image] InsufficientAccessRights Constructor
InsufficientAccessRights Constructor
Initializes a new instance of the InsufficientAccessRights class.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public InsufficientAccessRights(
IValueSymbol symbol,
SymbolAccessRights requested
)
VB
Public Sub New (
symbol As IValueSymbol,
requested As SymbolAccessRights
)
Parameters
symbol | Type: TwinCAT.TypeSystem.IValueSymbol The symbol.
requested | Type: TwinCAT.TypeSystem.SymbolAccessRights The requested.
Reference
InsufficientAccessRights Class
TwinCAT Namespace


InsufficientAccessRights Properties

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] InsufficientAccessRights Class [image] InsufficientAccessRights Properties
InsufficientAccessRights Properties
The InsufficientAccessRights type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
InsufficientAccessRights Class
TwinCAT Namespace


InsufficientAccessRights Methods

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] InsufficientAccessRights Class [image] InsufficientAccessRights Methods
InsufficientAccessRights Methods
The InsufficientAccessRights type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
InsufficientAccessRights Class
TwinCAT Namespace


InsufficientAccessRights Events

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] InsufficientAccessRights Class [image] InsufficientAccessRights Events
InsufficientAccessRights Events
The InsufficientAccessRights type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
InsufficientAccessRights Class
TwinCAT Namespace


InsufficientAccessRights Fields

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] InsufficientAccessRights Class [image] InsufficientAccessRights Fields
InsufficientAccessRights Fields
The InsufficientAccessRights type exposes the following members.
Fields
Name | Description
Symbol | Symbol that is bound to the SymbolException (Inherited from SymbolException.)
Reference
InsufficientAccessRights Class
TwinCAT Namespace


ISession Interface

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface
ISession Interface
Interface ISession
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISession : IConnectionStateProvider
VB
Public Interface ISession
Inherits IConnectionStateProvider
The ISession type exposes the following members.
Properties
Name | Description
AddressSpecifier | Gets the communication endpoint address string representation.
Connection | Gets the Connection object.
ConnectionState | Gets the current Connection state of the IConnectionStateProvider (Inherited from IConnectionStateProvider.)
EstablishedAt | Gets the UTC time when the session was established.
Id | Gets the Session Id
IsConnected | Gets a value indicating whether the session is connected.
Methods
Name | Description
Close | Closes this ISession
Connect | Connects the session and returns the established IConnection object.
Disconnect | Disconnects the ISession
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed. (Inherited from IConnectionStateProvider.)
Reference
TwinCAT Namespace
Weiterführende Informationen
•
ISession Properties
•
ISession Methods
•
ISession Events


ISession Properties

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface [image] ISession Properties
ISession Properties
The ISession type exposes the following members.
Properties
Name | Description
AddressSpecifier | Gets the communication endpoint address string representation.
Connection | Gets the Connection object.
ConnectionState | Gets the current Connection state of the IConnectionStateProvider (Inherited from IConnectionStateProvider.)
EstablishedAt | Gets the UTC time when the session was established.
Id | Gets the Session Id
IsConnected | Gets a value indicating whether the session is connected.
Reference
ISession Interface
TwinCAT Namespace
Weiterführende Informationen
•
ISession.AddressSpecifier Property
•
ISession.Connection Property
•
ISession.EstablishedAt Property
•
ISession.Id Property
•
ISession.IsConnected Property


ISession.AddressSpecifier Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface [image] ISession Properties [image] ISession.AddressSpecifier Property
ISession.AddressSpecifier Property
Gets the communication endpoint address string representation.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string AddressSpecifier { get; }
VB
ReadOnly Property AddressSpecifier As String
Get
Property Value
Type: String
The address.
Reference
ISession Interface
TwinCAT Namespace


ISession.Connection Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface [image] ISession Properties [image] ISession.Connection Property
ISession.Connection Property
Gets the Connection object.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IConnection Connection { get; }
VB
ReadOnly Property Connection As IConnection
Get
Property Value
Type: IConnection
The connection.
Remarks
The IConnection object is established by the ISession via Connect. and is valid until the Disconnect. method or the Dispose method is called. Any possible resurrections after communication losses will be done transparently under the hood of the IConnection so that the IConnection instance and ISession instance.
Reference
ISession Interface
TwinCAT Namespace


ISession.EstablishedAt Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface [image] ISession Properties [image] ISession.EstablishedAt Property
ISession.EstablishedAt Property
Gets the UTC time when the session was established.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
DateTime EstablishedAt { get; }
VB
ReadOnly Property EstablishedAt As DateTime
Get
Property Value
Type: DateTime
The session established at.
Reference
ISession Interface
TwinCAT Namespace


ISession.Id Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface [image] ISession Properties [image] ISession.Id Property
ISession.Id Property
Gets the Session Id
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Id { get; }
VB
ReadOnly Property Id As Integer
Get
Property Value
Type: Int32
The identifier.
Reference
ISession Interface
TwinCAT Namespace


ISession.IsConnected Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface [image] ISession Properties [image] ISession.IsConnected Property
ISession.IsConnected Property
Gets a value indicating whether the session is connected.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsConnected { get; }
VB
ReadOnly Property IsConnected As Boolean
Get
Property Value
Type: Boolean
true if session is connected; otherwise, false.
Reference
ISession Interface
TwinCAT Namespace


ISession Methods

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface [image] ISession Methods
ISession Methods
The ISession type exposes the following members.
Methods
Name | Description
Close | Closes this ISession
Connect | Connects the session and returns the established IConnection object.
Disconnect | Disconnects the ISession
Reference
ISession Interface
TwinCAT Namespace
Weiterführende Informationen
•
ISession.Close Method
•
ISession.Connect Method
•
ISession.Disconnect Method


ISession.Close Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface [image] ISession Methods [image] ISession.Close Method
ISession.Close Method
Closes this ISession
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void Close()
VB
Sub Close
Remarks
Closes also the IConnection.
Reference
ISession Interface
TwinCAT Namespace


ISession.Connect Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface [image] ISession Methods [image] ISession.Connect Method
ISession.Connect Method
Connects the session and returns the established IConnection object.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IConnection Connect()
VB
Function Connect As IConnection
Return Value
Type: IConnection
The IConnection object.
Remarks
The IConnection will be valid until the ISession is disconnected via the Disconnect. method or the Dispose method is called. Any possible resurrections after communication losses will be done transparently within the IConnection so that the IConnection instance and ISession instance remains.
Reference
ISession Interface
TwinCAT Namespace


ISession.Disconnect Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface [image] ISession Methods [image] ISession.Disconnect Method
ISession.Disconnect Method
Disconnects the ISession
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool Disconnect()
VB
Function Disconnect As Boolean
Return Value
Type: Boolean
true if Session was disconnected, false if the session was already closed.
Remarks
Disposes also the IConnection.
Reference
ISession Interface
TwinCAT Namespace


ISession Events

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISession Interface [image] ISession Events
ISession Events
The ISession type exposes the following members.
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed. (Inherited from IConnectionStateProvider.)
Reference
ISession Interface
TwinCAT Namespace


ISessionSettings Interface

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISessionSettings Interface
ISessionSettings Interface
Interface ISessionSettings
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISessionSettings
VB
Public Interface ISessionSettings
Reference
TwinCAT Namespace


ISymbolLoaderSettings Interface

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] ISymbolLoaderSettings Interface
ISymbolLoaderSettings Interface
Interface ISymbolLoaderSettings
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISymbolLoaderSettings
VB
Public Interface ISymbolLoaderSettings
Reference
TwinCAT Namespace


Session Class

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class
Session Class
Abstract Session base class.
Inheritance Hierarchy
System.Object
TwinCAT.Session
TwinCAT.Ads.AdsSession
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public abstract class Session : ISession,
IConnectionStateProvider, IDisposable
VB
Public MustInherit Class Session
Implements ISession, IConnectionStateProvider, IDisposable
The Session type exposes the following members.
Properties
Name | Description
AddressSpecifier | Gets the communication endpoint address string representation.
Connection | Gets the (established) connection.
ConnectionState | Gets the current Connection state of the Session
Disposed | Gets a value indicating whether this Session is disposed.
EstablishedAt | Gets the UTC time when the session was established.
Id | Gets the Session Identifier
IsConnected | Gets a value indicating whether this instance is connected.
Name | Gets the name of the session
SymbolServer | Gets the symbol server.
Methods
Name | Description
Close | Closes this ISession
Connect | Connects the session.
Disconnect | Disconnects the session from the target.
Dispose. | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetSessionName | Gets the name/string identifier of the session.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnConnect | Handler function connecting the Session.
OnCreateSymbolServer | Handler function creating the ISymbolServer
OnDisconnect | Handler function disconnecting the session.
OnGetAddress | Handler function getting the address of the session.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed.
Fields
Name | Description
connection | The (established) connection
Reference
TwinCAT Namespace
TwinCAT.ISession
System.IDisposable
Weiterführende Informationen
•
Session Properties
•
Session Methods
•
Session Events
•
Session Fields


Session Properties

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Properties
Session Properties
The Session type exposes the following members.
Properties
Name | Description
AddressSpecifier | Gets the communication endpoint address string representation.
Connection | Gets the (established) connection.
ConnectionState | Gets the current Connection state of the Session
Disposed | Gets a value indicating whether this Session is disposed.
EstablishedAt | Gets the UTC time when the session was established.
Id | Gets the Session Identifier
IsConnected | Gets a value indicating whether this instance is connected.
Name | Gets the name of the session
SymbolServer | Gets the symbol server.
Reference
Session Class
TwinCAT Namespace
Weiterführende Informationen
•
Session.AddressSpecifier Property
•
Session.Connection Property
•
Session.ConnectionState Property
•
Session.Disposed Property
•
Session.EstablishedAt Property
•
Session.Id Property
•
Session.IsConnected Property
•
Session.Name Property
•
Session.SymbolServer Property


Session.AddressSpecifier Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Properties [image] Session.AddressSpecifier Property
Session.AddressSpecifier Property
Gets the communication endpoint address string representation.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string AddressSpecifier { get; }
VB
Public ReadOnly Property AddressSpecifier As String
Get
Property Value
Type: String
The address.
Implements
ISession.AddressSpecifier
Reference
Session Class
TwinCAT Namespace


Session.Connection Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Properties [image] Session.Connection Property
Session.Connection Property
Gets the (established) connection.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IConnection Connection { get; }
VB
Public ReadOnly Property Connection As IConnection
Get
Property Value
Type: IConnection
The IConnection if connection established, or null if not connected.
Implements
ISession.Connection
Reference
Session Class
TwinCAT Namespace


Session.ConnectionState Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Properties [image] Session.ConnectionState Property
Session.ConnectionState Property
Gets the current Connection state of the Session
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ConnectionState ConnectionState { get; }
VB
Public ReadOnly Property ConnectionState As ConnectionState
Get
Property Value
Type: ConnectionState
The state of the connection.
Implements
IConnectionStateProvider.ConnectionState
Remarks
The Connection state changes only if the IConnection is established / shut down or active communication is triggered by the User of the IConnection object.
Examples
The following sample shows how to keep the ConnectionState updated by triggering ADS Communication.
Trigger ConnectionState changes in WPF Applications
private DispatcherTimer _timer = null;
private AdsSession _session = null;
//private AdsConnection _connection = null;

private void Window_Loaded(object sender, RoutedEventArgs e)
{
_session = new AdsSession(AmsNetId.Local, 10000);
IConnection connection = _session.Connect();
tbConnectionState.Text = connection.ConnectionState.ToString();
_session.ConnectionStateChanged += _session_ConnectionStateChanged;

_timer = new DispatcherTimer();
_timer.Interval = TimeSpan.FromMilliseconds(200);
_timer.Tick += TimerOnTick;

_timer.Start();
}

private void Window_Unloaded(object sender, RoutedEventArgs e)
{
_timer.Stop();
_session.Dispose();
}

private void _session_ConnectionStateChanged(object sender, TwinCAT.ConnectionStateChangedEventArgs e)
{
// ConnectionStateChanged will be triggered by communication Invokes
tbConnectionState.Text = e.NewState.ToString();
}

private void TimerOnTick(object sender, EventArgs eventArgs)
{
// The Timer Event will occur here in the UI thread because its an DispatcherTimer event!
// An active ADS request will trigger Connection State periodically!
StateInfo stateInfo;
if (_session.Connection.TryReadState(out stateInfo) == AdsErrorCode.NoError)
{
tbAdsState.Text = stateInfo.AdsState.ToString();
}
else
{
tbAdsState.Text = "Invalid";
}
}
Reference
Session Class
TwinCAT Namespace
Session.ConnectionStateChanged


Session.Disposed Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Properties [image] Session.Disposed Property
Session.Disposed Property
Gets a value indicating whether this Session is disposed.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Disposed { get; }
VB
Public ReadOnly Property Disposed As Boolean
Get
Property Value
Type: Boolean
true if disposed; otherwise, false.
Reference
Session Class
TwinCAT Namespace


Session.EstablishedAt Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Properties [image] Session.EstablishedAt Property
Session.EstablishedAt Property
Gets the UTC time when the session was established.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DateTime EstablishedAt { get; }
VB
Public ReadOnly Property EstablishedAt As DateTime
Get
Property Value
Type: DateTime
The session established at.
Implements
ISession.EstablishedAt
Reference
Session Class
TwinCAT Namespace


Session.Id Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Properties [image] Session.Id Property
Session.Id Property
Gets the Session Identifier
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Id { get; }
VB
Public ReadOnly Property Id As Integer
Get
Property Value
Type: Int32
The identifier.
Implements
ISession.Id
Reference
Session Class
TwinCAT Namespace


Session.IsConnected Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Properties [image] Session.IsConnected Property
Session.IsConnected Property
Gets a value indicating whether this instance is connected.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsConnected { get; }
VB
Public ReadOnly Property IsConnected As Boolean
Get
Property Value
Type: Boolean
true if this instance is connected; otherwise, false.
Implements
ISession.IsConnected
Reference
Session Class
TwinCAT Namespace


Session.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Properties [image] Session.Name Property
Session.Name Property
Gets the name of the session
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Name { get; }
VB
Public ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Reference
Session Class
TwinCAT Namespace


Session.SymbolServer Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Properties [image] Session.SymbolServer Property
Session.SymbolServer Property
Gets the symbol server.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ISymbolServer SymbolServer { get; }
VB
Public ReadOnly Property SymbolServer As ISymbolServer
Get
Property Value
Type: ISymbolServer
The symbol server.
Remarks
The Session object holds and caches the symbolic information. To initially create this information, the Connection must be established.
Reference
Session Class
TwinCAT Namespace


Session Methods

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods
Session Methods
The Session type exposes the following members.
Methods
Name | Description
Close | Closes this ISession
Connect | Connects the session.
Disconnect | Disconnects the session from the target.
Dispose. | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetSessionName | Gets the name/string identifier of the session.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnConnect | Handler function connecting the Session.
OnCreateSymbolServer | Handler function creating the ISymbolServer
OnDisconnect | Handler function disconnecting the session.
OnGetAddress | Handler function getting the address of the session.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
Session Class
TwinCAT Namespace
Weiterführende Informationen
•
Session.Close Method
•
Session.Connect Method
•
Session.Disconnect Method
•
Session.Dispose Method
•
Session.GetSessionName Method
•
Session.OnConnect Method
•
Session.OnCreateSymbolServer Method
•
Session.OnDisconnect Method
•
Session.OnGetAddress Method


Session.Close Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods [image] Session.Close Method
Session.Close Method
Closes this ISession
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Close()
VB
Public Sub Close
Implements
ISession.Close.
Remarks
Closes also the IConnection.
Reference
Session Class
TwinCAT Namespace


Session.Connect Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods [image] Session.Connect Method
Session.Connect Method
Connects the session.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IConnection Connect()
VB
Public Function Connect As IConnection
Return Value
Type: IConnection
true if XXXX, false otherwise.
Implements
ISession.Connect.
Exceptions
Exception | Condition
ObjectDisposedException |
ObjectDisposedException |
Remarks
The IConnection will be valid until the ISession is disconnected via the Disconnect. method or the Dispose method is called. Any possible resurrections after communication losses will be done transparently within the IConnection so that the IConnection instance and ISession instance remains.
Reference
Session Class
TwinCAT Namespace


Session.Disconnect Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods [image] Session.Disconnect Method
Session.Disconnect Method
Disconnects the session from the target.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Disconnect()
VB
Public Function Disconnect As Boolean
Return Value
Type: Boolean
true if XXXX, false otherwise.
Implements
ISession.Disconnect.
Exceptions
Exception | Condition
ObjectDisposedException |
Remarks
Closes (and disposes) the underlying IConnection The Session itself will not be Disposed and can be reconnected.
Reference
Session Class
TwinCAT Namespace


Session.Dispose Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods [image] Session.Dispose Method
Session.Dispose Method
Overload List
Name | Description
Dispose. | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Reference
Session Class
TwinCAT Namespace
Weiterführende Informationen
•
Session.Dispose Method
•
Session.Dispose Method (Boolean)


Session.Dispose Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods [image] Session.Dispose Method [image] Session.Dispose Method
Session.Dispose Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Dispose()
VB
Public Sub Dispose
Implements
IDisposable.Dispose.
Reference
Session Class
Dispose Overload
TwinCAT Namespace


Session.Dispose Method (Boolean)

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods [image] Session.Dispose Method [image] Session.Dispose Method (Boolean)
Session.Dispose Method (Boolean)
Releases unmanaged and - optionally - managed resources.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual void Dispose(
bool disposing
)
VB
Protected Overridable Sub Dispose (
disposing As Boolean
)
Parameters
disposing
Type: System.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Reference
Session Class
Dispose Overload
TwinCAT Namespace


Session.GetSessionName Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods [image] Session.GetSessionName Method
Session.GetSessionName Method
Gets the name/string identifier of the session.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected abstract string GetSessionName()
VB
Protected MustOverride Function GetSessionName As String
Return Value
Type: String
System.String.
Reference
Session Class
TwinCAT Namespace


Session.OnConnect Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods [image] Session.OnConnect Method
Session.OnConnect Method
Handler function connecting the Session.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual IConnection OnConnect(
bool reconnect
)
VB
Protected Overridable Function OnConnect (
reconnect As Boolean
) As IConnection
Parameters
reconnect
Type: System.Boolean
if set to true [reconnect].
Return Value
Type: IConnection
IConnection.
Reference
Session Class
TwinCAT Namespace


Session.OnCreateSymbolServer Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods [image] Session.OnCreateSymbolServer Method
Session.OnCreateSymbolServer Method
Handler function creating the ISymbolServer
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected abstract ISymbolServer OnCreateSymbolServer()
VB
Protected MustOverride Function OnCreateSymbolServer As ISymbolServer
Return Value
Type: ISymbolServer
ISymbolServer.
Exceptions
Exception | Condition
SessionNotConnectedException | The connection is not established!
Reference
Session Class
TwinCAT Namespace


Session.OnDisconnect Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods [image] Session.OnDisconnect Method
Session.OnDisconnect Method
Handler function disconnecting the session.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual bool OnDisconnect()
VB
Protected Overridable Function OnDisconnect As Boolean
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
Session Class
TwinCAT Namespace


Session.OnGetAddress Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Methods [image] Session.OnGetAddress Method
Session.OnGetAddress Method
Handler function getting the address of the session.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected abstract string OnGetAddress()
VB
Protected MustOverride Function OnGetAddress As String
Return Value
Type: String
System.String.
Reference
Session Class
TwinCAT Namespace


Session Events

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Events
Session Events
The Session type exposes the following members.
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed.
Reference
Session Class
TwinCAT Namespace
Weiterführende Informationen
•
Session.ConnectionStateChanged Event


Session.ConnectionStateChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Events [image] Session.ConnectionStateChanged Event
Session.ConnectionStateChanged Event
Occurs when connection status of the IConnectionStateProvider has been changed.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event EventHandler<ConnectionStateChangedEventArgs> ConnectionStateChanged
VB
Public Event ConnectionStateChanged As EventHandler(Of ConnectionStateChangedEventArgs)
Value
Type: System.EventHandler.ConnectionStateChangedEventArgs.
Implements
IConnectionStateProvider.ConnectionStateChanged
Remarks
The Connection state changes only if the IConnection is established / shut down or active communication is triggered by the User of the IConnection object.
Examples
The following sample shows how to keep the ConnectionState updated by triggering ADS Communication.
Trigger ConnectionState changes in WPF Applications
private DispatcherTimer _timer = null;
private AdsSession _session = null;
//private AdsConnection _connection = null;

private void Window_Loaded(object sender, RoutedEventArgs e)
{
_session = new AdsSession(AmsNetId.Local, 10000);
IConnection connection = _session.Connect();
tbConnectionState.Text = connection.ConnectionState.ToString();
_session.ConnectionStateChanged += _session_ConnectionStateChanged;

_timer = new DispatcherTimer();
_timer.Interval = TimeSpan.FromMilliseconds(200);
_timer.Tick += TimerOnTick;

_timer.Start();
}

private void Window_Unloaded(object sender, RoutedEventArgs e)
{
_timer.Stop();
_session.Dispose();
}

private void _session_ConnectionStateChanged(object sender, TwinCAT.ConnectionStateChangedEventArgs e)
{
// ConnectionStateChanged will be triggered by communication Invokes
tbConnectionState.Text = e.NewState.ToString();
}

private void TimerOnTick(object sender, EventArgs eventArgs)
{
// The Timer Event will occur here in the UI thread because its an DispatcherTimer event!
// An active ADS request will trigger Connection State periodically!
StateInfo stateInfo;
if (_session.Connection.TryReadState(out stateInfo) == AdsErrorCode.NoError)
{
tbAdsState.Text = stateInfo.AdsState.ToString();
}
else
{
tbAdsState.Text = "Invalid";
}
}
Reference
Session Class
TwinCAT Namespace
Session.ConnectionState


Session Fields

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Fields
Session Fields
The Session type exposes the following members.
Fields
Name | Description
connection | The (established) connection
Reference
Session Class
TwinCAT Namespace
Weiterführende Informationen
•
Session.connection Field


Session.connection Field

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] Session Class [image] Session Fields [image] Session.connection Field
Session.connection Field
The (established) connection
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected IConnection connection
VB
Protected connection As IConnection
Field Value
Type: IConnection
Reference
Session Class
TwinCAT Namespace


SessionConnectionStateChangedEventArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionConnectionStateChangedEventArgs Class
SessionConnectionStateChangedEventArgs Class
EventArguments for the ConnectionStatusChanged events.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.ConnectionStateChangedEventArgs
TwinCAT.SessionConnectionStateChangedEventArgs
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SessionConnectionStateChangedEventArgs : ConnectionStateChangedEventArgs
VB
Public Class SessionConnectionStateChangedEventArgs
Inherits ConnectionStateChangedEventArgs
The SessionConnectionStateChangedEventArgs type exposes the following members.
Constructors
Name | Description
SessionConnectionStateChangedEventArgs(ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection) | Initializes a new instance of the SessionConnectionStateChangedEventArgs class.
SessionConnectionStateChangedEventArgs(ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection, Exception) | Initializes a new instance of the SessionConnectionStateChangedEventArgs class.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
Connection | The connection
Exception | Exception, (only for Error (Inherited from ConnectionStateChangedEventArgs.)
NewState | New connection state (Inherited from ConnectionStateChangedEventArgs.)
OldState | Old connection state (Inherited from ConnectionStateChangedEventArgs.)
Reason | Reason for the event (Inherited from ConnectionStateChangedEventArgs.)
Session | The session
Reference
TwinCAT Namespace
TwinCAT.ConnectionStateChangedEventArgs
Weiterführende Informationen
•
SessionConnectionStateChangedEventArgs Constructor
•
SessionConnectionStateChangedEventArgs Methods
•
SessionConnectionStateChangedEventArgs Fields


SessionConnectionStateChangedEventArgs Constructor

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionConnectionStateChangedEventArgs Class [image] SessionConnectionStateChangedEventArgs Constructor
SessionConnectionStateChangedEventArgs Constructor
Overload List
Name | Description
SessionConnectionStateChangedEventArgs(ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection) | Initializes a new instance of the SessionConnectionStateChangedEventArgs class.
SessionConnectionStateChangedEventArgs(ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection, Exception) | Initializes a new instance of the SessionConnectionStateChangedEventArgs class.
Reference
SessionConnectionStateChangedEventArgs Class
TwinCAT Namespace
Weiterführende Informationen
•
SessionConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection)
•
SessionConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection, Exception)


SessionConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection)

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionConnectionStateChangedEventArgs Class [image] SessionConnectionStateChangedEventArgs Constructor [image] SessionConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection)
SessionConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection)
Initializes a new instance of the SessionConnectionStateChangedEventArgs class.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SessionConnectionStateChangedEventArgs(
ConnectionStateChangedReason reason,
ConnectionState newState,
ConnectionState oldState,
ISession session,
IConnection connection
)
VB
Public Sub New (
reason As ConnectionStateChangedReason,
newState As ConnectionState,
oldState As ConnectionState,
session As ISession,
connection As IConnection
)
Parameters
reason | Type: TwinCAT.ConnectionStateChangedReason The reason.
newState | Type: TwinCAT.ConnectionState The new state.
oldState | Type: TwinCAT.ConnectionState The old state.
session | Type: TwinCAT.ISession The session.
connection | Type: TwinCAT.IConnection The connection.
Reference
SessionConnectionStateChangedEventArgs Class
SessionConnectionStateChangedEventArgs Overload
TwinCAT Namespace


SessionConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionConnectionStateChangedEventArgs Class [image] SessionConnectionStateChangedEventArgs Constructor [image] SessionConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection, Exception)
SessionConnectionStateChangedEventArgs Constructor (ConnectionStateChangedReason, ConnectionState, ConnectionState, ISession, IConnection, Exception)
Initializes a new instance of the SessionConnectionStateChangedEventArgs class.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SessionConnectionStateChangedEventArgs(
ConnectionStateChangedReason reason,
ConnectionState newState,
ConnectionState oldState,
ISession session,
IConnection connection,
Exception e
)
VB
Public Sub New (
reason As ConnectionStateChangedReason,
newState As ConnectionState,
oldState As ConnectionState,
session As ISession,
connection As IConnection,
e As Exception
)
Parameters
reason | Type: TwinCAT.ConnectionStateChangedReason The reason.
newState | Type: TwinCAT.ConnectionState The new state.
oldState | Type: TwinCAT.ConnectionState The old state.
session | Type: TwinCAT.ISession The session.
connection | Type: TwinCAT.IConnection The connection.
e | Type: System.Exception The e.
Reference
SessionConnectionStateChangedEventArgs Class
SessionConnectionStateChangedEventArgs Overload
TwinCAT Namespace


SessionConnectionStateChangedEventArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionConnectionStateChangedEventArgs Class [image] SessionConnectionStateChangedEventArgs Methods
SessionConnectionStateChangedEventArgs Methods
The SessionConnectionStateChangedEventArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
SessionConnectionStateChangedEventArgs Class
TwinCAT Namespace


SessionConnectionStateChangedEventArgs Fields

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionConnectionStateChangedEventArgs Class [image] SessionConnectionStateChangedEventArgs Fields
SessionConnectionStateChangedEventArgs Fields
The SessionConnectionStateChangedEventArgs type exposes the following members.
Fields
Name | Description
Connection | The connection
Exception | Exception, (only for Error (Inherited from ConnectionStateChangedEventArgs.)
NewState | New connection state (Inherited from ConnectionStateChangedEventArgs.)
OldState | Old connection state (Inherited from ConnectionStateChangedEventArgs.)
Reason | Reason for the event (Inherited from ConnectionStateChangedEventArgs.)
Session | The session
Reference
SessionConnectionStateChangedEventArgs Class
TwinCAT Namespace
Weiterführende Informationen
•
SessionConnectionStateChangedEventArgs.Connection Field
•
SessionConnectionStateChangedEventArgs.Session Field


SessionConnectionStateChangedEventArgs.Connection Field

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionConnectionStateChangedEventArgs Class [image] SessionConnectionStateChangedEventArgs Fields [image] SessionConnectionStateChangedEventArgs.Connection Field
SessionConnectionStateChangedEventArgs.Connection Field
The connection
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly IConnection Connection
VB
Public ReadOnly Connection As IConnection
Field Value
Type: IConnection
Reference
SessionConnectionStateChangedEventArgs Class
TwinCAT Namespace


SessionConnectionStateChangedEventArgs.Session Field

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionConnectionStateChangedEventArgs Class [image] SessionConnectionStateChangedEventArgs Fields [image] SessionConnectionStateChangedEventArgs.Session Field
SessionConnectionStateChangedEventArgs.Session Field
The session
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly ISession Session
VB
Public ReadOnly Session As ISession
Field Value
Type: ISession
Reference
SessionConnectionStateChangedEventArgs Class
TwinCAT Namespace


SessionException Class

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionException Class
SessionException Class
Session Exception
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.SessionException
TwinCAT.SessionNotConnectedException
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class SessionException : AdsException
VB
<SerializableAttribute>
Public Class SessionException
Inherits AdsException
The SessionException type exposes the following members.
Constructors
Name | Description
SessionException(String, ISession) | Initializes a new instance of the SessionException class.
SessionException(String, ISession, Exception) | Initializes a new instance of the SessionException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Fields
Name | Description
Session | The session
Reference
TwinCAT Namespace
TwinCAT.Ads.AdsException
Weiterführende Informationen
•
SessionException Constructor
•
SessionException Properties
•
SessionException Methods
•
SessionException Events
•
SessionException Fields


SessionException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionException Class [image] SessionException Constructor
SessionException Constructor
Overload List
Name | Description
SessionException(String, ISession) | Initializes a new instance of the SessionException class.
SessionException(String, ISession, Exception) | Initializes a new instance of the SessionException class.
Reference
SessionException Class
TwinCAT Namespace
Weiterführende Informationen
•
SessionException Constructor (String, ISession)
•
SessionException Constructor (String, ISession, Exception)


SessionException Constructor (String, ISession)

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionException Class [image] SessionException Constructor [image] SessionException Constructor (String, ISession)
SessionException Constructor (String, ISession)
Initializes a new instance of the SessionException class.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SessionException(
string message,
ISession session
)
VB
Public Sub New (
message As String,
session As ISession
)
Parameters
message | Type: System.String The message.
session | Type: TwinCAT.ISession The session.
Reference
SessionException Class
SessionException Overload
TwinCAT Namespace


SessionException Constructor (String, ISession, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionException Class [image] SessionException Constructor [image] SessionException Constructor (String, ISession, Exception)
SessionException Constructor (String, ISession, Exception)
Initializes a new instance of the SessionException class.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SessionException(
string message,
ISession session,
Exception innerException
)
VB
Public Sub New (
message As String,
session As ISession,
innerException As Exception
)
Parameters
message | Type: System.String The message.
session | Type: TwinCAT.ISession The session.
innerException | Type: System.Exception The inner exception.
Reference
SessionException Class
SessionException Overload
TwinCAT Namespace


SessionException Properties

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionException Class [image] SessionException Properties
SessionException Properties
The SessionException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
SessionException Class
TwinCAT Namespace


SessionException Methods

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionException Class [image] SessionException Methods
SessionException Methods
The SessionException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
SessionException Class
TwinCAT Namespace
Weiterführende Informationen
•
SessionException.GetObjectData Method


SessionException.GetObjectData Method

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionException Class [image] SessionException Methods [image] SessionException.GetObjectData Method
SessionException.GetObjectData Method
When overridden in a derived class, sets the SerializationInfo with information about the exception.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
VB
Public Overrides Sub GetObjectData (
info As SerializationInfo,
context As StreamingContext
)
Parameters
info | Type: System.Runtime.Serialization.SerializationInfo The SerializationInfo that holds the serialized object data about the exception being thrown.
context | Type: System.Runtime.Serialization.StreamingContext The StreamingContext that contains contextual information about the source or destination.
Implements
ISerializable.GetObjectData(SerializationInfo, StreamingContext)
_Exception.GetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info
Reference
SessionException Class
TwinCAT Namespace


SessionException Events

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionException Class [image] SessionException Events
SessionException Events
The SessionException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
SessionException Class
TwinCAT Namespace


SessionException Fields

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionException Class [image] SessionException Fields
SessionException Fields
The SessionException type exposes the following members.
Fields
Name | Description
Session | The session
Reference
SessionException Class
TwinCAT Namespace
Weiterführende Informationen
•
SessionException.Session Field


SessionException.Session Field

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionException Class [image] SessionException Fields [image] SessionException.Session Field
SessionException.Session Field
The session
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[NonSerializedAttribute]
public readonly ISession Session
VB
<NonSerializedAttribute>
Public ReadOnly Session As ISession
Field Value
Type: ISession
Reference
SessionException Class
TwinCAT Namespace


SessionNotConnectedException Class

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionNotConnectedException Class
SessionNotConnectedException Class
Class SessionNotConnectedException.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.SessionException
TwinCAT.SessionNotConnectedException
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class SessionNotConnectedException : SessionException
VB
<SerializableAttribute>
Public Class SessionNotConnectedException
Inherits SessionException
The SessionNotConnectedException type exposes the following members.
Constructors
Name | Description
SessionNotConnectedException(ISession) | Initializes a new instance of the SessionNotConnectedException class.
SessionNotConnectedException(String, ISession) | Initializes a new instance of the SessionNotConnectedException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from SessionException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Fields
Name | Description
Session | The session (Inherited from SessionException.)
Reference
TwinCAT Namespace
TwinCAT.SessionException
Weiterführende Informationen
•
SessionNotConnectedException Constructor
•
SessionNotConnectedException Properties
•
SessionNotConnectedException Methods
•
SessionNotConnectedException Events
•
SessionNotConnectedException Fields


SessionNotConnectedException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionNotConnectedException Class [image] SessionNotConnectedException Constructor
SessionNotConnectedException Constructor
Overload List
Name | Description
SessionNotConnectedException(ISession) | Initializes a new instance of the SessionNotConnectedException class.
SessionNotConnectedException(String, ISession) | Initializes a new instance of the SessionNotConnectedException class.
Reference
SessionNotConnectedException Class
TwinCAT Namespace
Weiterführende Informationen
•
SessionNotConnectedException Constructor (ISession)
•
SessionNotConnectedException Constructor (String, ISession)


SessionNotConnectedException Constructor (ISession)

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionNotConnectedException Class [image] SessionNotConnectedException Constructor [image] SessionNotConnectedException Constructor (ISession)
SessionNotConnectedException Constructor (ISession)
Initializes a new instance of the SessionNotConnectedException class.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SessionNotConnectedException(
ISession session
)
VB
Public Sub New (
session As ISession
)
Parameters
session
Type: TwinCAT.ISession
The session.
Reference
SessionNotConnectedException Class
SessionNotConnectedException Overload
TwinCAT Namespace


SessionNotConnectedException Constructor (String, ISession)

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionNotConnectedException Class [image] SessionNotConnectedException Constructor [image] SessionNotConnectedException Constructor (String, ISession)
SessionNotConnectedException Constructor (String, ISession)
Initializes a new instance of the SessionNotConnectedException class.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SessionNotConnectedException(
string message,
ISession session
)
VB
Public Sub New (
message As String,
session As ISession
)
Parameters
message | Type: System.String The message.
session | Type: TwinCAT.ISession The session.
Reference
SessionNotConnectedException Class
SessionNotConnectedException Overload
TwinCAT Namespace


SessionNotConnectedException Properties

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionNotConnectedException Class [image] SessionNotConnectedException Properties
SessionNotConnectedException Properties
The SessionNotConnectedException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
SessionNotConnectedException Class
TwinCAT Namespace


SessionNotConnectedException Methods

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionNotConnectedException Class [image] SessionNotConnectedException Methods
SessionNotConnectedException Methods
The SessionNotConnectedException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from SessionException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
SessionNotConnectedException Class
TwinCAT Namespace


SessionNotConnectedException Events

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionNotConnectedException Class [image] SessionNotConnectedException Events
SessionNotConnectedException Events
The SessionNotConnectedException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
SessionNotConnectedException Class
TwinCAT Namespace


SessionNotConnectedException Fields

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionNotConnectedException Class [image] SessionNotConnectedException Fields
SessionNotConnectedException Fields
The SessionNotConnectedException type exposes the following members.
Fields
Name | Description
Session | The session (Inherited from SessionException.)
Reference
SessionNotConnectedException Class
TwinCAT Namespace


SessionProvider.S, A, C. Class

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionProvider.S, A, C. Class
SessionProvider.S, A, C. Class
Abstract base class for a Custom Session provider
Inheritance Hierarchy
System.Object
TwinCAT.SessionProvider.S, A, C.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public abstract class SessionProvider<S, A, C> : ISessionProvider<S, A, C>
where S : ISession
where C : class
VB
Public MustInherit Class SessionProvider(Of S As ISession, A, C As Class)
Implements ISessionProvider(Of S, A, C)
Type Parameters
S | SessionType
A | Address type
C | Communication settings type
The SessionProvider.S, A, C. type exposes the following members.
Constructors
Name | Description
SessionProvider.S, A, C.. | Initializes a new instance of the SessionProvider.S, A, C. class.
SessionProvider.S, A, C.(SessionProviderCapabilities) | Initializes a new instance of the SessionProvider.S, A, C. class.
Properties
Name | Description
Capabilities | Gets the capabilities.
Name | Gets the name of the SessionProvider
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
capabilities | The capabilities of the ISessionProvider
Reference
TwinCAT Namespace
ISessionProvider
Weiterführende Informationen
•
SessionProvider.S, A, C. Constructor
•
SessionProvider.S, A, C. Properties
•
SessionProvider.S, A, C. Methods
•
SessionProvider.S, A, C. Fields


SessionProvider.S, A, C. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionProvider.S, A, C. Class [image] SessionProvider.S, A, C. Constructor
SessionProvider.S, A, C. Constructor
Overload List
Name | Description
SessionProvider.S, A, C.. | Initializes a new instance of the SessionProvider.S, A, C. class.
SessionProvider.S, A, C.(SessionProviderCapabilities) | Initializes a new instance of the SessionProvider.S, A, C. class.
Reference
SessionProvider.S, A, C. Class
TwinCAT Namespace
Weiterführende Informationen
•
SessionProvider.S, A, C. Constructor
•
SessionProvider.S, A, C. Constructor (SessionProviderCapabilities)


SessionProvider.S, A, C. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionProvider.S, A, C. Class [image] SessionProvider.S, A, C. Constructor [image] SessionProvider.S, A, C. Constructor
SessionProvider.S, A, C. Constructor
Initializes a new instance of the SessionProvider.S, A, C. class.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected SessionProvider()
VB
Protected Sub New
Exceptions
Exception | Condition
Exception | Session provider already instantiated!
Reference
SessionProvider.S, A, C. Class
SessionProvider.S, A, C. Overload
TwinCAT Namespace


SessionProvider.S, A, C. Constructor (SessionProviderCapabilities)

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionProvider.S, A, C. Class [image] SessionProvider.S, A, C. Constructor [image] SessionProvider.S, A, C. Constructor (SessionProviderCapabilities)
SessionProvider.S, A, C. Constructor (SessionProviderCapabilities)
Initializes a new instance of the SessionProvider.S, A, C. class.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected SessionProvider(
SessionProviderCapabilities cap
)
VB
Protected Sub New (
cap As SessionProviderCapabilities
)
Parameters
cap
Type: TwinCAT.SessionProviderCapabilities
Exceptions
Exception | Condition
Exception | Session provider already instantiated!
Reference
SessionProvider.S, A, C. Class
SessionProvider.S, A, C. Overload
TwinCAT Namespace


SessionProvider.S, A, C. Properties

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionProvider.S, A, C. Class [image] SessionProvider.S, A, C. Properties
SessionProvider.S, A, C. Properties
The SessionProvider.S, A, C. generic type exposes the following members.
Properties
Name | Description
Capabilities | Gets the capabilities.
Name | Gets the name of the SessionProvider
Reference
SessionProvider.S, A, C. Class
TwinCAT Namespace
Weiterführende Informationen
•
SessionProvider.S, A, C..Capabilities Property
•
SessionProvider.S, A, C..Name Property


SessionProvider.S, A, C..Capabilities Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionProvider.S, A, C. Class [image] SessionProvider.S, A, C. Properties [image] SessionProvider.S, A, C..Capabilities Property
SessionProvider.S, A, C..Capabilities Property
Gets the capabilities.
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SessionProviderCapabilities Capabilities { get; }
VB
Public ReadOnly Property Capabilities As SessionProviderCapabilities
Get
Property Value
Type: SessionProviderCapabilities
The capabilities.
Reference
SessionProvider.S, A, C. Class
TwinCAT Namespace


SessionProvider.S, A, C..Name Property

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionProvider.S, A, C. Class [image] SessionProvider.S, A, C. Properties [image] SessionProvider.S, A, C..Name Property
SessionProvider.S, A, C..Name Property
Gets the name of the SessionProvider
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public abstract string Name { get; }
VB
Public MustOverride ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Reference
SessionProvider.S, A, C. Class
TwinCAT Namespace


SessionProvider.S, A, C. Methods

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionProvider.S, A, C. Class [image] SessionProvider.S, A, C. Methods
SessionProvider.S, A, C. Methods
The SessionProvider.S, A, C. generic type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
SessionProvider.S, A, C. Class
TwinCAT Namespace


SessionProvider.S, A, C. Fields

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionProvider.S, A, C. Class [image] SessionProvider.S, A, C. Fields
SessionProvider.S, A, C. Fields
The SessionProvider.S, A, C. generic type exposes the following members.
Fields
Name | Description
capabilities | The capabilities of the ISessionProvider
Reference
SessionProvider.S, A, C. Class
TwinCAT Namespace
Weiterführende Informationen
•
SessionProvider.S, A, C..capabilities Field


SessionProvider.S, A, C..capabilities Field

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionProvider.S, A, C. Class [image] SessionProvider.S, A, C. Fields [image] SessionProvider.S, A, C..capabilities Field
SessionProvider.S, A, C..capabilities Field
The capabilities of the ISessionProvider
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected SessionProviderCapabilities capabilities
VB
Protected capabilities As SessionProviderCapabilities
Field Value
Type: SessionProviderCapabilities
Reference
SessionProvider.S, A, C. Class
TwinCAT Namespace


SessionProviderCapabilities Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SessionProviderCapabilities Enumeration
SessionProviderCapabilities Enumeration
Enum SessionProviderCapabilities
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[FlagsAttribute]
public enum SessionProviderCapabilities
VB
<FlagsAttribute>
Public Enumeration SessionProviderCapabilities
Members
Member name | Value | Description
DataTypeSupport | 1 | Supports DataTypes
SymbolBrowsing | 2 | Supports Symbol Browsing
ValueRead | 4 | Supports VAlue Read
ValueWrite | 8 | Support Value Write
ValueNotifications | 16 | Supports Value changed Notifications
None | 0 | Uninitilialized / None
Mask_All | 31 | All Capabilities active
Reference
TwinCAT Namespace


SymbolsLoadMode Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT Namespace [image] SymbolsLoadMode Enumeration
SymbolsLoadMode Enumeration
Enum SymbolsLoadMode
Namespace: TwinCAT
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum SymbolsLoadMode
VB
Public Enumeration SymbolsLoadMode
Members
Member name | Value | Description
Flat | 0 | Loads the Symbols organized as Flat List
VirtualTree | 1 | Loads the Symbols organized as Virtual tree (Symbol Parent - Child relationships)
DynamicTree | 2 | Loads the Symbols as a Virtual tree with Dynamic Symbols (Only available within versions > 4.X of this ADS Api)
Reference
TwinCAT Namespace


TwinCAT.Ads Namespace

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace
TwinCAT.Ads Namespace
ADS root namespace.
Classes
Class | Description
AdsBinaryReader | Derives from BinaryReader and reads primitive as well as PLC data types as binary values.
AdsBinaryWriter | Derives from BinaryWriter and writes primitive and PLC data types in binary to a stream.
AdsClientSettings | Settings object for TcAdsClient.
AdsCommunicationStatistics | ADS Communication statistics
AdsConnection | ADS Connection class
AdsDatatypeArrayInfo | Array definition for a single dimension.
AdsDatatypeNotSupportedException | The exception that is thrown when a ADS datatype is not supported.
AdsErrorException | The exception that is thrown when an ADS error occurs.
AdsException | Base class for all exceptions thrown by this class.
AdsInitializeException | Initializing exception (TcAdsDllCe resp. TcAdsDll.dll not found)
AdsInvalidNotificationException | This AdsInvalidNotificationException is created if the length of the notification data is 0. This indicates that the notification handle is not valid any more. This exception is passed to the AdsNotificationErrorEvent.
AdsNotificationErrorEventArgs | Provides data for AdsNotificationErrorEvent of the class TcAdsClient.
AdsNotificationEventArgs | Provides data for AdsNotificationEvent of the class TcAdsClient.
AdsNotificationExEventArgs | Provides data for AdsNotificationExEvent of the class TcAdsClient.
AdsSession | AdsSession class
AdsStateChangedEventArgs | Provides data for AdsStateChangedEvent of the class TcAdsClient.
AdsStateChangedEventArgs2 | Event Arguments for AdsStateChanged events.
AdsStream | The class AdsStream is a stream class used for ADS communication.
AdsSumCommandException | The exception that is thrown when an ADS SumCommand error occurs.
AdsSymbolException | Symbol Exception
AdsSymbolVersionChangedEventArgs | Provides data for AdsSymbolVersionChangedEvent of the class TcAdsClient.
AmsAddress | Ams/Ads Address
AmsNetId | AMS/ADS Net ID
AmsRouterNotificationEventArgs | Provides data for AmsRouterNotificationEvent of the class TcAdsClient.
NotificationSettings | Notification communication settings
ReadOnlyTcAdsDataTypeCollection | Read only collection of ITcAdsDataType" types.
RpcMethodNotSupportedException | Symbol Exception
SessionSettings | Session settings class
SymbolException | Symbol bound exceptions
SymbolLoaderSettings | Settings object for the IAdsSymbolLoader initialization.
TcAdsClient | ADS Client / ADS Communication object.
TcAdsSymbolInfo | The class TcAdsSymbolInfo represents a symbol loaded by an instance of the TcAdsSymbolInfoLoader class.
TcAdsSymbolInfoCollection | Represents a collection of TcAdsSymbolInfo objects.
TcAdsSymbolInfoLoader | The class TcAdsSymbolInfoLoader is responsible for downloading the list of declared variables and the data types from an ADS Server.
Structures
Structure | Description
AdsVersion | The structure contains the version number, revision number and build number.
DeviceInfo | The structure contains the name and the version information of the device.
StateInfo | The structure contains the ADS state and device state.
Interfaces
Interface | Description
IAdsAnyAccess | Interface for accessing ADS 'Any' objects.
IAdsConnection | ADS Connection interface
IAdsHandleAccess | Interface for ads access via variable handle
IAdsNotifications | Interface for Notification management.
IAdsSession | Interface IAdsSession
IAdsSessionSettings | Interface for ADS Session Settings
IFailFastHandler | Interface for a fast failing (Circuit breaker) ads handler
ITcAdsDataType | Interface ITcAdsDataType
ITcAdsRpcInvoke | Interface ITcAdsRpcInvoke
ITcAdsSubItem | Interface ITcAdsSubItem
ITcAdsSymbol | Defines an Interface for reading the ADS symbol information.
ITcAdsSymbol2 | Interface ITcAdsSymbol2 (extends ITcAdsSymbol)
ITcAdsSymbol3 | Interface ITcAdsSymbol3 (extends ITcAdsSymbol ... ITcAdsSymbol3)
ITcAdsSymbol4 | Interface ITcAdsSymbol4 (extends ITcAdsSymbol ... ITcAdsSymbol3
ITcAdsSymbol5 | Interface ITcAdsSymbol5 (extends ITcAdsSymbol ... ITcAdsSymbol4
ITcAdsSymbolBrowser | Interface ITcAdsSubSymbolProvider
Delegates
Delegate | Description
AdsNotificationErrorEventHandler | Event handler for the AdsNotificationError event in the class TcAdsClient.
AdsNotificationEventHandler | Event handler for the AdsNotification event in the class TcAdsClient.
AdsNotificationExEventHandler | Event handler for the AdsNotification event in the class TcAdsClient.
AdsStateChangedEventHandler | Event handler for the AdsStateChanged event in the class TcAdsClient.
AmsRouterNotificationEventHandler | Event handler for the AmsRouterNotification event in the class TcAdsClient.
Enumerations
Enumeration | Description
AdsDatatypeId | ADS data types.
AdsErrorCode | Describes the ADS error that occured.
AdsState | Describes the AdsState.
AdsTransMode | ADS Transmission Mode for ADS Notifications.
AmsPort | AmsPorts
AmsRouterState | State of the AMS Router.
TransportProtocol | Enum ADS TransportProtocol
Weiterführende Informationen
•
AdsBinaryReader Class
•
AdsBinaryWriter Class
•
AdsClientSettings Class
•
AdsCommunicationStatistics Class
•
AdsConnection Class
•
AdsDatatypeArrayInfo Class
•
AdsDatatypeId Enumeration
•
AdsDatatypeNotSupportedException Class
•
AdsErrorCode Enumeration
•
AdsErrorException Class
•
AdsException Class
•
AdsInitializeException Class
•
AdsInvalidNotificationException Class
•
AdsNotificationErrorEventArgs Class
•
AdsNotificationErrorEventHandler Delegate
•
AdsNotificationEventArgs Class
•
AdsNotificationEventHandler Delegate
•
AdsNotificationExEventArgs Class
•
AdsNotificationExEventHandler Delegate
•
AdsSession Class
•
AdsState Enumeration
•
AdsStateChangedEventArgs Class
•
AdsStateChangedEventArgs2 Class
•
AdsStateChangedEventHandler Delegate
•
AdsStream Class
•
AdsSumCommandException Class
•
AdsSymbolException Class
•
AdsSymbolVersionChangedEventArgs Class
•
AdsTransMode Enumeration
•
AdsVersion Structure
•
AmsAddress Class
•
AmsNetId Class
•
AmsPort Enumeration
•
AmsRouterNotificationEventArgs Class
•
AmsRouterNotificationEventHandler Delegate
•
AmsRouterState Enumeration
•
DeviceInfo Structure
•
IAdsAnyAccess Interface
•
IAdsConnection Interface
•
IAdsHandleAccess Interface
•
IAdsNotifications Interface
•
IAdsSession Interface
•
IAdsSessionSettings Interface
•
IFailFastHandler Interface
•
ITcAdsDataType Interface
•
ITcAdsRpcInvoke Interface
•
ITcAdsSubItem Interface
•
ITcAdsSymbol Interface
•
ITcAdsSymbol2 Interface
•
ITcAdsSymbol3 Interface
•
ITcAdsSymbol4 Interface
•
ITcAdsSymbol5 Interface
•
ITcAdsSymbolBrowser Interface
•
NotificationSettings Class
•
ReadOnlyTcAdsDataTypeCollection Class
•
RpcMethodNotSupportedException Class
•
SessionSettings Class
•
StateInfo Structure
•
SymbolException Class
•
SymbolLoaderSettings Class
•
TcAdsClient Class
•
TcAdsSymbolInfo Class
•
TcAdsSymbolInfoCollection Class
•
TcAdsSymbolInfoLoader Class
•
TransportProtocol Enumeration


AdsBinaryReader Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryReader Class
AdsBinaryReader Class
Derives from BinaryReader and reads primitive as well as PLC data types as binary values.
Inheritance Hierarchy
System.Object
System.IO.BinaryReader
TwinCAT.Ads.AdsBinaryReader
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class AdsBinaryReader : BinaryReader
VB
Public Class AdsBinaryReader
Inherits BinaryReader
The AdsBinaryReader type exposes the following members.
Constructors
Name | Description
AdsBinaryReader | Initializes a new instance of the AdsBinaryReader class based on the supplied stream.
Properties
Name | Description
BaseStream | Exposes access to the underlying stream of the BinaryReader. (Inherited from BinaryReader.)
Methods
Name | Description
Close | Closes the current reader and the underlying stream. (Inherited from BinaryReader.)
Dispose. | Releases all resources used by the current instance of the BinaryReader class. (Inherited from BinaryReader.)
Dispose(Boolean) | Releases the unmanaged resources used by the BinaryReader class and optionally releases the managed resources. (Inherited from BinaryReader.)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
FillBuffer | Fills the internal buffer with the specified number of bytes read from the stream. (Inherited from BinaryReader.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PeekChar | Returns the next available character and does not advance the byte or character position. (Inherited from BinaryReader.)
Read. | Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Read(.Char., Int32, Int32) | Reads the specified number of characters from the stream, starting from a specified point in the character array. (Inherited from BinaryReader.)
Read(.Byte., Int32, Int32) | Reads the specified number of bytes from the stream, starting from a specified point in the byte array. (Inherited from BinaryReader.)
Read7BitEncodedInt | Reads in a 32-bit integer in compressed format. (Inherited from BinaryReader.)
ReadBoolean | Reads a Boolean value from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
ReadByte | Reads the next byte from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
ReadBytes | Reads the specified number of bytes from the current stream into a byte array and advances the current position by that number of bytes. (Inherited from BinaryReader.)
ReadChar | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
ReadChars | Reads the specified number of characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
ReadDecimal | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes. (Inherited from BinaryReader.)
ReadDouble | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
ReadGuid | Reads a Guid from the current stream.
ReadInt16 | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes. (Inherited from BinaryReader.)
ReadInt32 | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
ReadInt64 | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
ReadPlcAnsiString | Reads a PLC string from the current stream (Encoding.Default, ANSI Encoding)
ReadPlcDATE | Reads a PLC Date type from the current stream.
ReadPlcTIME | Reads a PLC 'TIME' data type from the current stream.
ReadPlcUnicodeString | Reads a PLC string from the current stream (Encoding.Unicode, Unicode Encoding)
ReadSByte | Reads a signed byte from this stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
ReadSingle | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
ReadString | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time. (Inherited from BinaryReader.)
ReadUInt16 | Reads a 2-byte unsigned integer from the current stream using little-endian encoding and advances the position of the stream by two bytes. (Inherited from BinaryReader.)
ReadUInt32 | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes. (Inherited from BinaryReader.)
ReadUInt64 | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes. (Inherited from BinaryReader.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Remarks
The AdsBinaryReader object is initialized with System.Text.Encoding.Default (ANSI Encoding).
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsBinaryReader Constructor
•
AdsBinaryReader Properties
•
AdsBinaryReader Methods


AdsBinaryReader Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryReader Class [image] AdsBinaryReader Constructor
AdsBinaryReader Constructor
Initializes a new instance of the AdsBinaryReader class based on the supplied stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsBinaryReader(
AdsStream stream
)
VB
Public Sub New (
stream As AdsStream
)
Parameters
stream
Type: TwinCAT.Ads.AdsStream
A stream.
Reference
AdsBinaryReader Class
TwinCAT.Ads Namespace


AdsBinaryReader Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryReader Class [image] AdsBinaryReader Properties
AdsBinaryReader Properties
The AdsBinaryReader type exposes the following members.
Properties
Name | Description
BaseStream | Exposes access to the underlying stream of the BinaryReader. (Inherited from BinaryReader.)
Reference
AdsBinaryReader Class
TwinCAT.Ads Namespace


AdsBinaryReader Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryReader Class [image] AdsBinaryReader Methods
AdsBinaryReader Methods
The AdsBinaryReader type exposes the following members.
Methods
Name | Description
Close | Closes the current reader and the underlying stream. (Inherited from BinaryReader.)
Dispose. | Releases all resources used by the current instance of the BinaryReader class. (Inherited from BinaryReader.)
Dispose(Boolean) | Releases the unmanaged resources used by the BinaryReader class and optionally releases the managed resources. (Inherited from BinaryReader.)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
FillBuffer | Fills the internal buffer with the specified number of bytes read from the stream. (Inherited from BinaryReader.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PeekChar | Returns the next available character and does not advance the byte or character position. (Inherited from BinaryReader.)
Read. | Reads characters from the underlying stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
Read(.Char., Int32, Int32) | Reads the specified number of characters from the stream, starting from a specified point in the character array. (Inherited from BinaryReader.)
Read(.Byte., Int32, Int32) | Reads the specified number of bytes from the stream, starting from a specified point in the byte array. (Inherited from BinaryReader.)
Read7BitEncodedInt | Reads in a 32-bit integer in compressed format. (Inherited from BinaryReader.)
ReadBoolean | Reads a Boolean value from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
ReadByte | Reads the next byte from the current stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
ReadBytes | Reads the specified number of bytes from the current stream into a byte array and advances the current position by that number of bytes. (Inherited from BinaryReader.)
ReadChar | Reads the next character from the current stream and advances the current position of the stream in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
ReadChars | Reads the specified number of characters from the current stream, returns the data in a character array, and advances the current position in accordance with the Encoding used and the specific character being read from the stream. (Inherited from BinaryReader.)
ReadDecimal | Reads a decimal value from the current stream and advances the current position of the stream by sixteen bytes. (Inherited from BinaryReader.)
ReadDouble | Reads an 8-byte floating point value from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
ReadGuid | Reads a Guid from the current stream.
ReadInt16 | Reads a 2-byte signed integer from the current stream and advances the current position of the stream by two bytes. (Inherited from BinaryReader.)
ReadInt32 | Reads a 4-byte signed integer from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
ReadInt64 | Reads an 8-byte signed integer from the current stream and advances the current position of the stream by eight bytes. (Inherited from BinaryReader.)
ReadPlcAnsiString | Reads a PLC string from the current stream (Encoding.Default, ANSI Encoding)
ReadPlcDATE | Reads a PLC Date type from the current stream.
ReadPlcTIME | Reads a PLC 'TIME' data type from the current stream.
ReadPlcUnicodeString | Reads a PLC string from the current stream (Encoding.Unicode, Unicode Encoding)
ReadSByte | Reads a signed byte from this stream and advances the current position of the stream by one byte. (Inherited from BinaryReader.)
ReadSingle | Reads a 4-byte floating point value from the current stream and advances the current position of the stream by four bytes. (Inherited from BinaryReader.)
ReadString | Reads a string from the current stream. The string is prefixed with the length, encoded as an integer seven bits at a time. (Inherited from BinaryReader.)
ReadUInt16 | Reads a 2-byte unsigned integer from the current stream using little-endian encoding and advances the position of the stream by two bytes. (Inherited from BinaryReader.)
ReadUInt32 | Reads a 4-byte unsigned integer from the current stream and advances the position of the stream by four bytes. (Inherited from BinaryReader.)
ReadUInt64 | Reads an 8-byte unsigned integer from the current stream and advances the position of the stream by eight bytes. (Inherited from BinaryReader.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AdsBinaryReader Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsBinaryReader.ReadGuid Method
•
AdsBinaryReader.ReadPlcAnsiString Method
•
AdsBinaryReader.ReadPlcDATE Method
•
AdsBinaryReader.ReadPlcTIME Method
•
AdsBinaryReader.ReadPlcUnicodeString Method


AdsBinaryReader.ReadGuid Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryReader Class [image] AdsBinaryReader Methods [image] AdsBinaryReader.ReadGuid Method
AdsBinaryReader.ReadGuid Method
Reads a Guid from the current stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Guid ReadGuid()
VB
Public Function ReadGuid As Guid
Return Value
Type: Guid
Guid.
Reference
AdsBinaryReader Class
TwinCAT.Ads Namespace


AdsBinaryReader.ReadPlcAnsiString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryReader Class [image] AdsBinaryReader Methods [image] AdsBinaryReader.ReadPlcAnsiString Method
AdsBinaryReader.ReadPlcAnsiString Method
Reads a PLC string from the current stream (Encoding.Default, ANSI Encoding)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ReadPlcAnsiString(
int byteLength
)
VB
Public Function ReadPlcAnsiString (
byteLength As Integer
) As String
Parameters
byteLength
Type: System.Int32
The length of the string in the PLC (byte length equals character count on PLC + '\0')
Return Value
Type: String
The string being read (until the first '\0' character)
Remarks
The byte length of a STRING[80] in the PLC is 81. The byte length of a WSTRING[80] in the PLC is 162. Because of ANSI Encoding the number of Chars could differ with the number of Bytes (e.g on Double Byte Codepages DBCS, Codepage 932, Japan)
Examples
The following code shows how to Read/Write ANSI string values..
Read/Write Strings
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local port 851 (PLC)

int handle = client.CreateVariableHandle("MAIN.string"); // Symbol "string" in MAIN defined as string

try
{
// Read ANSI String string[80]
int byteSize = 81; // Size of 80 ANSI chars + /0 (STRING[80])
AdsStream readStream = new AdsStream(byteSize); // Size of 80 ANSI chars + /0 (STRING[80])
AdsBinaryReader reader = new AdsBinaryReader(readStream);
client.Read(handle, readStream, 0, byteSize); // Read 81 bytes
string value = reader.ReadPlcString(byteSize,Encoding.Default);

// Write ANSI String string[80]
AdsStream writeStream = new AdsStream(byteSize);
AdsBinaryWriter writer = new AdsBinaryWriter(writeStream);
value = "Changed";
writer.WritePlcString(value, 80,Encoding.Default); // Max 80 characters!
client.Write(handle, writeStream, 0, byteSize);
}
finally
{
client.DeleteVariableHandle(handle);
}
}
Reference
AdsBinaryReader Class
TwinCAT.Ads Namespace


AdsBinaryReader.ReadPlcDATE Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryReader Class [image] AdsBinaryReader Methods [image] AdsBinaryReader.ReadPlcDATE Method
AdsBinaryReader.ReadPlcDATE Method
Reads a PLC Date type from the current stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DateTime ReadPlcDATE()
VB
Public Function ReadPlcDATE As DateTime
Return Value
Type: DateTime
The date being read.
Reference
AdsBinaryReader Class
TwinCAT.Ads Namespace


AdsBinaryReader.ReadPlcTIME Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryReader Class [image] AdsBinaryReader Methods [image] AdsBinaryReader.ReadPlcTIME Method
AdsBinaryReader.ReadPlcTIME Method
Reads a PLC 'TIME' data type from the current stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TimeSpan ReadPlcTIME()
VB
Public Function ReadPlcTIME As TimeSpan
Return Value
Type: TimeSpan
The time being read as TimeSpan.
Remarks
This method reads the 4 Byte Plc 'TIME' datatype.
Reference
AdsBinaryReader Class
TwinCAT.Ads Namespace


AdsBinaryReader.ReadPlcUnicodeString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryReader Class [image] AdsBinaryReader Methods [image] AdsBinaryReader.ReadPlcUnicodeString Method
AdsBinaryReader.ReadPlcUnicodeString Method
Reads a PLC string from the current stream (Encoding.Unicode, Unicode Encoding)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ReadPlcUnicodeString(
int byteLength
)
VB
Public Function ReadPlcUnicodeString (
byteLength As Integer
) As String
Parameters
byteLength
Type: System.Int32
The length of the string in the PLC (byte length equals character count on PLC + '\0')
Return Value
Type: String
The string being read (until the first '\0' character)
Remarks
The byte length of a STRING[80] in the PLC is 81. The byte length of a WSTRING[80] in the PLC is 162. Because of ANSI Encoding the number of Chars could differ with the number of Bytes (e.g on Double Byte Codepages DBCS, Codpage 932, Japan)
Examples
The following code shows how to Read/Write UNICODE string values..
Read/Write Unicode Strings
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local port 851 (PLC)

int handle = client.CreateVariableHandle("MAIN.wstring"); // Symbol "wstring" defined in MAIN as WSTRING

try
{
// Read UNICODE String wstring[80]
int byteSize = 2 * 81; // Size of 80 UNICODE chars + /0 (WSTRING[80])
AdsStream readStream = new AdsStream(byteSize);
AdsBinaryReader reader = new AdsBinaryReader(readStream);
client.Read(handle, readStream, 0, byteSize); // Read 2*81 bytes
string value = reader.ReadPlcString(byteSize,Encoding.Unicode);

// Write ANSI String string[80]
AdsStream writeStream = new AdsStream(byteSize);
AdsBinaryWriter writer = new AdsBinaryWriter(writeStream);
value = "Changed";
writer.WritePlcString(value, 80,Encoding.Unicode);
client.Write(handle, writeStream, 0, byteSize);
}
finally
{
client.DeleteVariableHandle(handle);
}
}
Reference
AdsBinaryReader Class
TwinCAT.Ads Namespace


AdsBinaryWriter Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class
AdsBinaryWriter Class
Derives from BinaryWriter and writes primitive and PLC data types in binary to a stream.
Inheritance Hierarchy
System.Object
System.IO.BinaryWriter
TwinCAT.Ads.AdsBinaryWriter
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class AdsBinaryWriter : BinaryWriter
VB
Public Class AdsBinaryWriter
Inherits BinaryWriter
The AdsBinaryWriter type exposes the following members.
Constructors
Name | Description
AdsBinaryWriter | Initializes a new instance of the AdsBinaryWriter class based on the supplied stream.
Properties
Name | Description
BaseStream | Gets the underlying stream of the BinaryWriter. (Inherited from BinaryWriter.)
Methods
Name | Description
Close | Closes the current BinaryWriter and the underlying stream. (Inherited from BinaryWriter.)
Dispose. | Releases all resources used by the current instance of the BinaryWriter class. (Inherited from BinaryWriter.)
Dispose(Boolean) | Releases the unmanaged resources used by the BinaryWriter and optionally releases the managed resources. (Inherited from BinaryWriter.)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from BinaryWriter.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Seek | Sets the position within the current stream. (Inherited from BinaryWriter.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Write(Boolean) | Writes a one-byte Boolean value to the current stream, with 0 representing false and 1 representing true. (Inherited from BinaryWriter.)
Write(Byte) | Writes an unsigned byte to the current stream and advances the stream position by one byte. (Inherited from BinaryWriter.)
Write(SByte) | Writes a signed byte to the current stream and advances the stream position by one byte. (Inherited from BinaryWriter.)
Write(.Byte.) | Writes a byte array to the underlying stream. (Inherited from BinaryWriter.)
Write(Char) | Writes a Unicode character to the current stream and advances the current position of the stream in accordance with the Encoding used and the specific characters being written to the stream. (Inherited from BinaryWriter.)
Write(.Char.) | Writes a character array to the current stream and advances the current position of the stream in accordance with the Encoding used and the specific characters being written to the stream. (Inherited from BinaryWriter.)
Write(Double) | Writes an eight-byte floating-point value to the current stream and advances the stream position by eight bytes. (Inherited from BinaryWriter.)
Write(Decimal) | Writes a decimal value to the current stream and advances the stream position by sixteen bytes. (Inherited from BinaryWriter.)
Write(Int16) | Writes a two-byte signed integer to the current stream and advances the stream position by two bytes. (Inherited from BinaryWriter.)
Write(UInt16) | Writes a two-byte unsigned integer to the current stream and advances the stream position by two bytes. (Inherited from BinaryWriter.)
Write(Int32) | Writes a four-byte signed integer to the current stream and advances the stream position by four bytes. (Inherited from BinaryWriter.)
Write(UInt32) | Writes a four-byte unsigned integer to the current stream and advances the stream position by four bytes. (Inherited from BinaryWriter.)
Write(Int64) | Writes an eight-byte signed integer to the current stream and advances the stream position by eight bytes. (Inherited from BinaryWriter.)
Write(UInt64) | Writes an eight-byte unsigned integer to the current stream and advances the stream position by eight bytes. (Inherited from BinaryWriter.)
Write(Single) | Writes a four-byte floating-point value to the current stream and advances the stream position by four bytes. (Inherited from BinaryWriter.)
Write(String) | Writes a length-prefixed string to this stream in the current encoding of the BinaryWriter, and advances the current position of the stream in accordance with the encoding used and the specific characters being written to the stream. (Inherited from BinaryWriter.)
Write(.Byte., Int32, Int32) | Writes a region of a byte array to the current stream. (Inherited from BinaryWriter.)
Write(.Char., Int32, Int32) | Writes a section of a character array to the current stream, and advances the current position of the stream in accordance with the Encoding used and perhaps the specific characters being written to the stream. (Inherited from BinaryWriter.)
Write7BitEncodedInt | Writes a 32-bit integer in a compressed format. (Inherited from BinaryWriter.)
WriteGuid | Writes the Guid (16 Bytes) to the current stream.
WritePlcAnsiString | Writes a string as a PLC string to the current stream.
WritePlcAnsiStringFixedLength | Writes the PLC ANSI string in a data block of the specified size.
WritePlcType(DateTime) | Writes a date as PLC date type to the current stream.
WritePlcType(TimeSpan) | Writes a time span as PLC time type to the current stream.
WritePlcUnicodeString | Writes a (unicode) string as a PLC string to the current stream.
WritePlcUnicodeStringFixedLength | Writes the PLC UNICODE string into a data block of the specified size.
Fields
Name | Description
OutStream | Holds the underlying stream. (Inherited from BinaryWriter.)
Remarks
The AdsBinaryWriter is fixed to use Default encoding (ANSI).
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsBinaryWriter Constructor
•
AdsBinaryWriter Properties
•
AdsBinaryWriter Methods
•
AdsBinaryWriter Fields


AdsBinaryWriter Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Constructor
AdsBinaryWriter Constructor
Initializes a new instance of the AdsBinaryWriter class based on the supplied stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsBinaryWriter(
AdsStream stream
)
VB
Public Sub New (
stream As AdsStream
)
Parameters
stream
Type: TwinCAT.Ads.AdsStream
The stream
Reference
AdsBinaryWriter Class
TwinCAT.Ads Namespace


AdsBinaryWriter Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Properties
AdsBinaryWriter Properties
The AdsBinaryWriter type exposes the following members.
Properties
Name | Description
BaseStream | Gets the underlying stream of the BinaryWriter. (Inherited from BinaryWriter.)
Reference
AdsBinaryWriter Class
TwinCAT.Ads Namespace


AdsBinaryWriter Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Methods
AdsBinaryWriter Methods
The AdsBinaryWriter type exposes the following members.
Methods
Name | Description
Close | Closes the current BinaryWriter and the underlying stream. (Inherited from BinaryWriter.)
Dispose. | Releases all resources used by the current instance of the BinaryWriter class. (Inherited from BinaryWriter.)
Dispose(Boolean) | Releases the unmanaged resources used by the BinaryWriter and optionally releases the managed resources. (Inherited from BinaryWriter.)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from BinaryWriter.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Seek | Sets the position within the current stream. (Inherited from BinaryWriter.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Write(Boolean) | Writes a one-byte Boolean value to the current stream, with 0 representing false and 1 representing true. (Inherited from BinaryWriter.)
Write(Byte) | Writes an unsigned byte to the current stream and advances the stream position by one byte. (Inherited from BinaryWriter.)
Write(SByte) | Writes a signed byte to the current stream and advances the stream position by one byte. (Inherited from BinaryWriter.)
Write(.Byte.) | Writes a byte array to the underlying stream. (Inherited from BinaryWriter.)
Write(Char) | Writes a Unicode character to the current stream and advances the current position of the stream in accordance with the Encoding used and the specific characters being written to the stream. (Inherited from BinaryWriter.)
Write(.Char.) | Writes a character array to the current stream and advances the current position of the stream in accordance with the Encoding used and the specific characters being written to the stream. (Inherited from BinaryWriter.)
Write(Double) | Writes an eight-byte floating-point value to the current stream and advances the stream position by eight bytes. (Inherited from BinaryWriter.)
Write(Decimal) | Writes a decimal value to the current stream and advances the stream position by sixteen bytes. (Inherited from BinaryWriter.)
Write(Int16) | Writes a two-byte signed integer to the current stream and advances the stream position by two bytes. (Inherited from BinaryWriter.)
Write(UInt16) | Writes a two-byte unsigned integer to the current stream and advances the stream position by two bytes. (Inherited from BinaryWriter.)
Write(Int32) | Writes a four-byte signed integer to the current stream and advances the stream position by four bytes. (Inherited from BinaryWriter.)
Write(UInt32) | Writes a four-byte unsigned integer to the current stream and advances the stream position by four bytes. (Inherited from BinaryWriter.)
Write(Int64) | Writes an eight-byte signed integer to the current stream and advances the stream position by eight bytes. (Inherited from BinaryWriter.)
Write(UInt64) | Writes an eight-byte unsigned integer to the current stream and advances the stream position by eight bytes. (Inherited from BinaryWriter.)
Write(Single) | Writes a four-byte floating-point value to the current stream and advances the stream position by four bytes. (Inherited from BinaryWriter.)
Write(String) | Writes a length-prefixed string to this stream in the current encoding of the BinaryWriter, and advances the current position of the stream in accordance with the encoding used and the specific characters being written to the stream. (Inherited from BinaryWriter.)
Write(.Byte., Int32, Int32) | Writes a region of a byte array to the current stream. (Inherited from BinaryWriter.)
Write(.Char., Int32, Int32) | Writes a section of a character array to the current stream, and advances the current position of the stream in accordance with the Encoding used and perhaps the specific characters being written to the stream. (Inherited from BinaryWriter.)
Write7BitEncodedInt | Writes a 32-bit integer in a compressed format. (Inherited from BinaryWriter.)
WriteGuid | Writes the Guid (16 Bytes) to the current stream.
WritePlcAnsiString | Writes a string as a PLC string to the current stream.
WritePlcAnsiStringFixedLength | Writes the PLC ANSI string in a data block of the specified size.
WritePlcType(DateTime) | Writes a date as PLC date type to the current stream.
WritePlcType(TimeSpan) | Writes a time span as PLC time type to the current stream.
WritePlcUnicodeString | Writes a (unicode) string as a PLC string to the current stream.
WritePlcUnicodeStringFixedLength | Writes the PLC UNICODE string into a data block of the specified size.
Reference
AdsBinaryWriter Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsBinaryWriter.WriteGuid Method
•
AdsBinaryWriter.WritePlcAnsiString Method
•
AdsBinaryWriter.WritePlcAnsiStringFixedLength Method
•
AdsBinaryWriter.WritePlcType Method
•
AdsBinaryWriter.WritePlcUnicodeString Method
•
AdsBinaryWriter.WritePlcUnicodeStringFixedLength Method


AdsBinaryWriter.WriteGuid Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Methods [image] AdsBinaryWriter.WriteGuid Method
AdsBinaryWriter.WriteGuid Method
Writes the Guid (16 Bytes) to the current stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteGuid(
Guid guid
)
VB
Public Sub WriteGuid (
guid As Guid
)
Parameters
guid
Type: System.Guid
The unique identifier.
Reference
AdsBinaryWriter Class
TwinCAT.Ads Namespace


AdsBinaryWriter.WritePlcAnsiString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Methods [image] AdsBinaryWriter.WritePlcAnsiString Method
AdsBinaryWriter.WritePlcAnsiString Method
Writes a string as a PLC string to the current stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WritePlcAnsiString(
string value,
int length
)
VB
Public Sub WritePlcAnsiString (
value As String,
length As Integer
)
Parameters
value | Type: System.String The string to write to the stream.
length | Type: System.Int32 The length of the string without '\0' terminator!
Remarks
This method is meant for writing single string variables defined in the PlcControl format. E.g. to write a 'STRING(80)' (byte size is 81) a length of '80' must be given to the 'length' parameter. If the string length is larger or equal than the length parameter, then only length characters are written to the AdsStream (without terminating character). If the string value character count is shorter than the specified length parameter, the string + a terminating \0 will be added to the AdsStream. This method cannot be used for marshalling purposes, for example several fields of a struct, because no filling bytes will be written to the stream. In that case use the WritePlcAnsiStringFixedLength(String, Int32) method.
Examples
The following code shows how to Read/Write ANSI string values..
Read/Write ANSI Strings
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local port 851 (PLC)

int handle = client.CreateVariableHandle("MAIN.string"); // Symbol "string" in MAIN defined as string

try
{
// Read ANSI String string[80]
int byteSize = 81; // Size of 80 ANSI chars + /0 (STRING[80])
AdsStream readStream = new AdsStream(byteSize); // Size of 80 ANSI chars + /0 (STRING[80])
AdsBinaryReader reader = new AdsBinaryReader(readStream);
client.Read(handle, readStream, 0, byteSize); // Read 81 bytes
string value = reader.ReadPlcString(byteSize,Encoding.Default);

// Write ANSI String string[80]
AdsStream writeStream = new AdsStream(byteSize);
AdsBinaryWriter writer = new AdsBinaryWriter(writeStream);
value = "Changed";
writer.WritePlcString(value, 80,Encoding.Default); // Max 80 characters!
client.Write(handle, writeStream, 0, byteSize);
}
finally
{
client.DeleteVariableHandle(handle);
}
}
Reference
AdsBinaryWriter Class
TwinCAT.Ads Namespace
AdsBinaryWriter.WritePlcAnsiStringFixedLength(String, Int32)
AdsBinaryWriter.WritePlcUnicodeString(String, Int32)
AdsBinaryWriter.WritePlcUnicodeStringFixedLength(String, Int32)


AdsBinaryWriter.WritePlcAnsiStringFixedLength Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Methods [image] AdsBinaryWriter.WritePlcAnsiStringFixedLength Method
AdsBinaryWriter.WritePlcAnsiStringFixedLength Method
Writes the PLC ANSI string in a data block of the specified size.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WritePlcAnsiStringFixedLength(
string value,
int byteSize
)
VB
Public Sub WritePlcAnsiStringFixedLength (
value As String,
byteSize As Integer
)
Parameters
value | Type: System.String The value.
byteSize | Type: System.Int32 Size of the String including the '\0' terminator.
Reference
AdsBinaryWriter Class
TwinCAT.Ads Namespace
AdsBinaryWriter.WritePlcAnsiString(String, Int32)
AdsBinaryWriter.WritePlcUnicodeString(String, Int32)
AdsBinaryWriter.WritePlcUnicodeStringFixedLength(String, Int32)


AdsBinaryWriter.WritePlcType Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Methods [image] AdsBinaryWriter.WritePlcType Method
AdsBinaryWriter.WritePlcType Method
Overload List
Name | Description
WritePlcType(DateTime) | Writes a date as PLC date type to the current stream.
WritePlcType(TimeSpan) | Writes a time span as PLC time type to the current stream.
Reference
AdsBinaryWriter Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsBinaryWriter.WritePlcType Method (DateTime)
•
AdsBinaryWriter.WritePlcType Method (TimeSpan)


AdsBinaryWriter.WritePlcType Method (DateTime)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Methods [image] AdsBinaryWriter.WritePlcType Method [image] AdsBinaryWriter.WritePlcType Method (DateTime)
AdsBinaryWriter.WritePlcType Method (DateTime)
Writes a date as PLC date type to the current stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WritePlcType(
DateTime value
)
VB
Public Sub WritePlcType (
value As DateTime
)
Parameters
value
Type: System.DateTime
The date to write to the stream.
Reference
AdsBinaryWriter Class
WritePlcType Overload
TwinCAT.Ads Namespace


AdsBinaryWriter.WritePlcType Method (TimeSpan)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Methods [image] AdsBinaryWriter.WritePlcType Method [image] AdsBinaryWriter.WritePlcType Method (TimeSpan)
AdsBinaryWriter.WritePlcType Method (TimeSpan)
Writes a time span as PLC time type to the current stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WritePlcType(
TimeSpan value
)
VB
Public Sub WritePlcType (
value As TimeSpan
)
Parameters
value
Type: System.TimeSpan
The time span to write to the stream.
Reference
AdsBinaryWriter Class
WritePlcType Overload
TwinCAT.Ads Namespace


AdsBinaryWriter.WritePlcUnicodeString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Methods [image] AdsBinaryWriter.WritePlcUnicodeString Method
AdsBinaryWriter.WritePlcUnicodeString Method
Writes a (unicode) string as a PLC string to the current stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WritePlcUnicodeString(
string value,
int length
)
VB
Public Sub WritePlcUnicodeString (
value As String,
length As Integer
)
Parameters
value | Type: System.String The string to write to the stream.
length | Type: System.Int32 The length of the string without '\0' terminator!
Remarks
This method is meant for writing single string variables defined in the PlcControl format. E.g. to write a 'WSTRING(80)' (byte size is 162) a length of '80' must be given to the 'length' parameter. If the string length is larger or equal than the length parameter, then only length characters are written to the AdsStream (without terminating character). If the string value character count is shorter than the specified length parameter, the string + a terminating \0 will be added to the AdsStream. This method cannot be used for marshalling purposes, for example several fields of a struct, because no filling bytes will be written to the stream. In that case use the WritePlcUnicodeStringFixedLength(String, Int32) method.
Examples
The following code shows how to Read/Write UNICODE string values..
Read/Write Unicode Strings
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local port 851 (PLC)

int handle = client.CreateVariableHandle("MAIN.wstring"); // Symbol "wstring" defined in MAIN as WSTRING

try
{
// Read UNICODE String wstring[80]
int byteSize = 2 * 81; // Size of 80 UNICODE chars + /0 (WSTRING[80])
AdsStream readStream = new AdsStream(byteSize);
AdsBinaryReader reader = new AdsBinaryReader(readStream);
client.Read(handle, readStream, 0, byteSize); // Read 2*81 bytes
string value = reader.ReadPlcString(byteSize,Encoding.Unicode);

// Write ANSI String string[80]
AdsStream writeStream = new AdsStream(byteSize);
AdsBinaryWriter writer = new AdsBinaryWriter(writeStream);
value = "Changed";
writer.WritePlcString(value, 80,Encoding.Unicode);
client.Write(handle, writeStream, 0, byteSize);
}
finally
{
client.DeleteVariableHandle(handle);
}
}
Reference
AdsBinaryWriter Class
TwinCAT.Ads Namespace
AdsBinaryWriter.WritePlcAnsiString(String, Int32)
AdsBinaryWriter.WritePlcAnsiStringFixedLength(String, Int32)
AdsBinaryWriter.WritePlcUnicodeStringFixedLength(String, Int32)


AdsBinaryWriter.WritePlcUnicodeStringFixedLength Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Methods [image] AdsBinaryWriter.WritePlcUnicodeStringFixedLength Method
AdsBinaryWriter.WritePlcUnicodeStringFixedLength Method
Writes the PLC UNICODE string into a data block of the specified size.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WritePlcUnicodeStringFixedLength(
string value,
int byteSize
)
VB
Public Sub WritePlcUnicodeStringFixedLength (
value As String,
byteSize As Integer
)
Parameters
value | Type: System.String The value.
byteSize | Type: System.Int32 Size of the String including the '\0' terminator.
Reference
AdsBinaryWriter Class
TwinCAT.Ads Namespace
AdsBinaryWriter.WritePlcAnsiStringFixedLength(String, Int32)
AdsBinaryWriter.WritePlcUnicodeString(String, Int32)
AdsBinaryWriter.WritePlcAnsiString(String, Int32)


AdsBinaryWriter Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsBinaryWriter Class [image] AdsBinaryWriter Fields
AdsBinaryWriter Fields
The AdsBinaryWriter type exposes the following members.
Fields
Name | Description
OutStream | Holds the underlying stream. (Inherited from BinaryWriter.)
Reference
AdsBinaryWriter Class
TwinCAT.Ads Namespace


AdsClientSettings Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsClientSettings Class
AdsClientSettings Class
Settings object for TcAdsClient.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.AdsClientSettings
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class AdsClientSettings
VB
Public Class AdsClientSettings
The AdsClientSettings type exposes the following members.
Constructors
Name | Description
AdsClientSettings | Creates a Default settings AdsClientSettings object with custom timeout.
Properties
Name | Description
CompatibilityDefault | Compatibility settings object
Default | Gets the default settings.
FastWriteThrough | Gets a Settings object that configures the TcAdsClient for FastWriteThrough
Protocol | Gets the protocol settings
Synchronize | Gets a value indicating whether the TwinCAT.Ads
Timeout | The communication Timeout of the TcAdsClient
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Remarks
This AdsClientSettings object is used to initalize the TcAdsClient with application appropriate settings.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsClientSettings Constructor
•
AdsClientSettings Properties
•
AdsClientSettings Methods


AdsClientSettings Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsClientSettings Class [image] AdsClientSettings Constructor
AdsClientSettings Constructor
Creates a Default settings AdsClientSettings object with custom timeout.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsClientSettings(
int timeout
)
VB
Public Sub New (
timeout As Integer
)
Parameters
timeout
Type: System.Int32
The timeout of the TcAdsClient in milliseconds.
Reference
AdsClientSettings Class
TwinCAT.Ads Namespace


AdsClientSettings Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsClientSettings Class [image] AdsClientSettings Properties
AdsClientSettings Properties
The AdsClientSettings type exposes the following members.
Properties
Name | Description
CompatibilityDefault | Compatibility settings object
Default | Gets the default settings.
FastWriteThrough | Gets a Settings object that configures the TcAdsClient for FastWriteThrough
Protocol | Gets the protocol settings
Synchronize | Gets a value indicating whether the TwinCAT.Ads
Timeout | The communication Timeout of the TcAdsClient
Reference
AdsClientSettings Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsClientSettings.CompatibilityDefault Property
•
AdsClientSettings.Default Property
•
AdsClientSettings.FastWriteThrough Property
•
AdsClientSettings.Protocol Property
•
AdsClientSettings.Synchronize Property
•
AdsClientSettings.Timeout Property


AdsClientSettings.CompatibilityDefault Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsClientSettings Class [image] AdsClientSettings Properties [image] AdsClientSettings.CompatibilityDefault Property
AdsClientSettings.CompatibilityDefault Property
Compatibility settings object
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static AdsClientSettings CompatibilityDefault { get; }
VB
Public Shared ReadOnly Property CompatibilityDefault As AdsClientSettings
Get
Property Value
Type: AdsClientSettings
The settings object.
Remarks
The compatibility settings intitialize the TcAdsClient the same way as it is done in earlier versions of the TwinCAT.Ads.dll (earlier than Version 4.2)
▪
All
▪
No FailFastHandler active.
▪
Default communicationtimeout 5000ms.
▪
Synchronized Notifications.
Reference
AdsClientSettings Class
TwinCAT.Ads Namespace


AdsClientSettings.Default Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsClientSettings Class [image] AdsClientSettings Properties [image] AdsClientSettings.Default Property
AdsClientSettings.Default Property
Gets the default settings.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static AdsClientSettings Default { get; }
VB
Public Shared ReadOnly Property Default As AdsClientSettings
Get
Property Value
Type: AdsClientSettings
The default.
Remarks
Creates an settings object, with specification for All and IFailFastHandler.
▪
All
▪
Fail fast handler is active.
▪
Default communication timeout 5000ms.
▪
Not synchronized Notifications.
Reference
AdsClientSettings Class
TwinCAT.Ads Namespace


AdsClientSettings.FastWriteThrough Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsClientSettings Class [image] AdsClientSettings Properties [image] AdsClientSettings.FastWriteThrough Property
AdsClientSettings.FastWriteThrough Property
Gets a Settings object that configures the TcAdsClient for FastWriteThrough
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static AdsClientSettings FastWriteThrough { get; }
VB
Public Shared ReadOnly Property FastWriteThrough As AdsClientSettings
Get
Property Value
Type: AdsClientSettings
Client settings for a fast write through (with 200 ms Timeout).
Remarks
The settings typically can be used for polling clients, where the "FailFast" feature will be bypassed. That means, that communication fails doesn't trigger the FailFast interceptor and every Request will go out via ADS. This has the Drawback that communication Timeouts are longer and subsequent timeouts block the ADS mailbox (with the danger of overflows). So use this setting with care for specific purposes and should not be used for standard communication.
▪
No FailFastHandler active.
▪
Default communicationtimeout 200ms.
▪
Not synchronized Notifications.
Reference
AdsClientSettings Class
TwinCAT.Ads Namespace


AdsClientSettings.Protocol Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsClientSettings Class [image] AdsClientSettings Properties [image] AdsClientSettings.Protocol Property
AdsClientSettings.Protocol Property
Gets the protocol settings
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TransportProtocol Protocol { get; }
VB
Public ReadOnly Property Protocol As TransportProtocol
Get
Property Value
Type: TransportProtocol
The protocol.
Reference
AdsClientSettings Class
TwinCAT.Ads Namespace


AdsClientSettings.Synchronize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsClientSettings Class [image] AdsClientSettings Properties [image] AdsClientSettings.Synchronize Property
AdsClientSettings.Synchronize Property
Gets a value indicating whether the TwinCAT.Ads
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Synchronize { get; }
VB
Public ReadOnly Property Synchronize As Boolean
Get
Property Value
Type: Boolean
true if synchronize; otherwise, false.
Reference
AdsClientSettings Class
TwinCAT.Ads Namespace


AdsClientSettings.Timeout Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsClientSettings Class [image] AdsClientSettings Properties [image] AdsClientSettings.Timeout Property
AdsClientSettings.Timeout Property
The communication Timeout of the TcAdsClient
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Timeout { get; }
VB
Public ReadOnly Property Timeout As Integer
Get
Property Value
Type: Int32
The timeout.
Reference
AdsClientSettings Class
TwinCAT.Ads Namespace


AdsClientSettings Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsClientSettings Class [image] AdsClientSettings Methods
AdsClientSettings Methods
The AdsClientSettings type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AdsClientSettings Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class
AdsCommunicationStatistics Class
ADS Communication statistics
Inheritance Hierarchy
System.Object
TwinCAT.Ads.AdsCommunicationStatistics
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class AdsCommunicationStatistics
VB
Public Class AdsCommunicationStatistics
The AdsCommunicationStatistics type exposes the following members.
Properties
Name | Description
AccessWaitTime | Gets the wait time for the next access (Resurrection time) if in Lost.
ConnectionActiveSince | Gets the UTC time of the last conenction activation.
ConnectionEstablishedAt | Gets the UTC time when the current connection was established.
ConnectionLostCount | Gets the connection lost count.
ConnectionLostTime | Gets the UTC connection lost time.
ConnectionResurrections | Gets the number of resurrections on the AdsConnection
ErrorsSinceLastSucceeded | Gets the error count since last access (UTC)
LastSucceededAccess | Gets the UTC time of the last succeeded access.
Resurrections | Gets the number of Resurrections of this Session.
SessionEstablishedAt | Gets the UTC time when the session was established.
TotalCycles | Gets the total cycles.
TotalErrors | Gets the total error count.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Remarks
These statistics can be used for communication diagnosis. They contain Error/Succeed counts as well as Resurrection infos.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsCommunicationStatistics Properties
•
AdsCommunicationStatistics Methods


AdsCommunicationStatistics Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties
AdsCommunicationStatistics Properties
The AdsCommunicationStatistics type exposes the following members.
Properties
Name | Description
AccessWaitTime | Gets the wait time for the next access (Resurrection time) if in Lost.
ConnectionActiveSince | Gets the UTC time of the last conenction activation.
ConnectionEstablishedAt | Gets the UTC time when the current connection was established.
ConnectionLostCount | Gets the connection lost count.
ConnectionLostTime | Gets the UTC connection lost time.
ConnectionResurrections | Gets the number of resurrections on the AdsConnection
ErrorsSinceLastSucceeded | Gets the error count since last access (UTC)
LastSucceededAccess | Gets the UTC time of the last succeeded access.
Resurrections | Gets the number of Resurrections of this Session.
SessionEstablishedAt | Gets the UTC time when the session was established.
TotalCycles | Gets the total cycles.
TotalErrors | Gets the total error count.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsCommunicationStatistics.AccessWaitTime Property
•
AdsCommunicationStatistics.ConnectionActiveSince Property
•
AdsCommunicationStatistics.ConnectionEstablishedAt Property
•
AdsCommunicationStatistics.ConnectionLostCount Property
•
AdsCommunicationStatistics.ConnectionLostTime Property
•
AdsCommunicationStatistics.ConnectionResurrections Property
•
AdsCommunicationStatistics.ErrorsSinceLastSucceeded Property
•
AdsCommunicationStatistics.LastSucceededAccess Property
•
AdsCommunicationStatistics.Resurrections Property
•
AdsCommunicationStatistics.SessionEstablishedAt Property
•
AdsCommunicationStatistics.TotalCycles Property
•
AdsCommunicationStatistics.TotalErrors Property


AdsCommunicationStatistics.AccessWaitTime Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.AccessWaitTime Property
AdsCommunicationStatistics.AccessWaitTime Property
Gets the wait time for the next access (Resurrection time) if in Lost.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TimeSpan AccessWaitTime { get; }
VB
Public ReadOnly Property AccessWaitTime As TimeSpan
Get
Property Value
Type: TimeSpan
The wait time if in Lost otherwise TimeSpan.Zero.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics.ConnectionActiveSince Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.ConnectionActiveSince Property
AdsCommunicationStatistics.ConnectionActiveSince Property
Gets the UTC time of the last conenction activation.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Nullable<DateTime> ConnectionActiveSince { get; }
VB
Public ReadOnly Property ConnectionActiveSince As Nullable(Of DateTime)
Get
Property Value
Type: Nullable.DateTime.
Connection active time.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics.ConnectionEstablishedAt Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.ConnectionEstablishedAt Property
AdsCommunicationStatistics.ConnectionEstablishedAt Property
Gets the UTC time when the current connection was established.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Nullable<DateTime> ConnectionEstablishedAt { get; }
VB
Public ReadOnly Property ConnectionEstablishedAt As Nullable(Of DateTime)
Get
Property Value
Type: Nullable.DateTime.
The connection established at.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics.ConnectionLostCount Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.ConnectionLostCount Property
AdsCommunicationStatistics.ConnectionLostCount Property
Gets the connection lost count.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ConnectionLostCount { get; }
VB
Public ReadOnly Property ConnectionLostCount As Integer
Get
Property Value
Type: Int32
The connection lost count.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics.ConnectionLostTime Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.ConnectionLostTime Property
AdsCommunicationStatistics.ConnectionLostTime Property
Gets the UTC connection lost time.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Nullable<DateTime> ConnectionLostTime { get; }
VB
Public ReadOnly Property ConnectionLostTime As Nullable(Of DateTime)
Get
Property Value
Type: Nullable.DateTime.
The connection lost time.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics.ConnectionResurrections Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.ConnectionResurrections Property
AdsCommunicationStatistics.ConnectionResurrections Property
Gets the number of resurrections on the AdsConnection
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ConnectionResurrections { get; }
VB
Public ReadOnly Property ConnectionResurrections As Integer
Get
Property Value
Type: Int32
The resurrections.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics.ErrorsSinceLastSucceeded Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.ErrorsSinceLastSucceeded Property
AdsCommunicationStatistics.ErrorsSinceLastSucceeded Property
Gets the error count since last access (UTC)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ErrorsSinceLastSucceeded { get; }
VB
Public ReadOnly Property ErrorsSinceLastSucceeded As Integer
Get
Property Value
Type: Int32
The error count since last access.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics.LastSucceededAccess Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.LastSucceededAccess Property
AdsCommunicationStatistics.LastSucceededAccess Property
Gets the UTC time of the last succeeded access.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Nullable<DateTime> LastSucceededAccess { get; }
VB
Public ReadOnly Property LastSucceededAccess As Nullable(Of DateTime)
Get
Property Value
Type: Nullable.DateTime.
The last succeeded access.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics.Resurrections Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.Resurrections Property
AdsCommunicationStatistics.Resurrections Property
Gets the number of Resurrections of this Session.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Resurrections { get; }
VB
Public ReadOnly Property Resurrections As Integer
Get
Property Value
Type: Int32
The resurrections.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics.SessionEstablishedAt Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.SessionEstablishedAt Property
AdsCommunicationStatistics.SessionEstablishedAt Property
Gets the UTC time when the session was established.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DateTime SessionEstablishedAt { get; }
VB
Public ReadOnly Property SessionEstablishedAt As DateTime
Get
Property Value
Type: DateTime
The session established at.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics.TotalCycles Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.TotalCycles Property
AdsCommunicationStatistics.TotalCycles Property
Gets the total cycles.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int TotalCycles { get; }
VB
Public ReadOnly Property TotalCycles As Integer
Get
Property Value
Type: Int32
The total cycles.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics.TotalErrors Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Properties [image] AdsCommunicationStatistics.TotalErrors Property
AdsCommunicationStatistics.TotalErrors Property
Gets the total error count.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int TotalErrors { get; }
VB
Public ReadOnly Property TotalErrors As Integer
Get
Property Value
Type: Int32
The total error count.
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsCommunicationStatistics Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsCommunicationStatistics Class [image] AdsCommunicationStatistics Methods
AdsCommunicationStatistics Methods
The AdsCommunicationStatistics type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AdsCommunicationStatistics Class
TwinCAT.Ads Namespace


AdsConnection Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class
AdsConnection Class
ADS Connection class
Inheritance Hierarchy
System.Object
TwinCAT.Ads.AdsConnection
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class AdsConnection : IAdsConnection,
IConnection, IConnectionStateProvider, IAdsNotifications, IAdsAnyAccess, IAdsHandleAccess,
ITcAdsRpcInvoke, IDisposable
VB
Public NotInheritable Class AdsConnection
Implements IAdsConnection, IConnection, IConnectionStateProvider, IAdsNotifications,
IAdsAnyAccess, IAdsHandleAccess, ITcAdsRpcInvoke, IDisposable
The AdsConnection type exposes the following members.
Properties
Name | Description
AccessWaitTime | Gets the access wait time.
ActiveSince | Gets the UTC time when tha last active/resurrected Connection was established
Address | Gets the AmsAddress of the ADS server.
ClientAddress | Get the AmsAddress of the ADS client.
ConnectionEstablishedAt | Gets the UTC time when the Connection was originally established.
ConnectionLostCount | Gets the connection lost count.
ConnectionLostTime | Gets the connection lost time.
ConnectionState | Gets the current Connection state of the AdsConnection
Disposed | Gets a value indicating whether this AdsConnection is disposed.
Id | Gets the AdsConnection identifier.
IsActive | Gets a value indicating whether communication is in active state
IsConnected | Gets a value indicating whether the local ADS port was opened successfully. It does not indicate if the target port is available. Use the method ReadState to determine if the target port is available.
IsLocal | Gets a value indicating whether the ADS client is connected to a ADS Server on the local computer.
IsLost | Gets a value indicating whether the communication is in lost / open state
IsReconnecting | Gets a value indicating whether communication is ready for reconnecting
Name | Gets the name.
ResurrectingTries | Gets the number of tries to resurrect the AdsConnection.
Resurrections | Gets the number of succeeded connection resurrections.
Session | Gets the Session object of the AdsConnection object.
State | Gets the current ConnectionState
Timeout | Gets the timeout (in milliseconds)
Methods
Name | Description
AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Adds the device notification.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Close | Closes the AdsConnection
Connect | (Re)Connects the IConnection when disconnected.
CreateSymbolLoader | Creates a new instance of the Symbol loader with the specified mode.
CreateVariableHandle | Generates a unique handle for an ADS variable.
DeleteDeviceNotification | Deletes an existing notification.
DeleteVariableHandle | Releases the handle of a ADS variable again.
Disconnect | Disconnects this IConnection.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeRpcMethod(String, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(String, String, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, String, .Object.) | Invokes the specified RPC Method.
Read(Int32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(Int32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, .Byte., Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, .Byte., Int32, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream, Int32, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
ReadAny(Int32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(Int32, Type, .Int32.) | Reads any.
ReadAny(UInt32, UInt32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object. If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
ReadAny(UInt32, UInt32, Type, .Int32., Int32) | Reads data synchronously from an ADS device and writes it to an object. If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
ReadAnyString(Int32, Int32, Encoding) | Reads the string.
ReadAnyString(UInt32, UInt32, Int32, Encoding) | Reads the string
ReadDeviceInfo | Reads the identification and version number of an ADS server.
ReadState. | Reads the ADS status and the device status from an ADS server.
ReadState(Int32) | Reads the ADS status and the device status from an ADS server.
ReadSymbol(ITcAdsSymbol) | Reads the value of a symbol and returns it as an object. Strings and all primitive datatypes(UInt32, Int32, Bool etc.) are supported. Arrays and structures cannot be read.
ReadSymbol(String, Type, Boolean) | Reads the value of a symbol and returns the value as object. The parameter type must have the same layout as the ADS symbol.
ReadSymbolInfo | Call this method to obtain information about the individual symbols (variables) in ADS devices.
ReadWrite(UInt32, UInt32, AdsStream, AdsStream) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, AdsStream, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device and then reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryAddDeviceNotification | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryAddDeviceNotificationEx | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryDeleteDeviceNotification | Deletes an existing notification.
TryInvokeRpcMethod(String, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(String, String, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.) | Invokes the specified RPC Method.
TryRead(Int32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, .Byte., Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, .Byte., Int32, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, AdsStream, Int32, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryReadState(StateInfo.) | Reads the ADS status and the device status from an ADS server. Unlike the ReadState method this method does not call an exception on failure. Instead an AdsErrorCode is returned. If the return value is equal to AdsErrorCode.NoError the call was successful.
TryReadState(Int32, StateInfo.) | Reads the ADS status and the device status from an ADS server. Unlike the ReadState method this method does not call an exception on failure. Instead an AdsErrorCode is returned. If the return value is equal to AdsErrorCode.NoError the call was successfull.
TryReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryWrite(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, .Byte., Int32, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, AdsStream, Int32, Int32, Int32) | Writes data synchronously to an ADS device.
TryWriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, Int32) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, AdsStream, Int32, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
Write(Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32) | Trigger Client Method/Command.
Write(UInt32, UInt32, Int32) | Trigger Client Method/Command.
Write(UInt32, UInt32, AdsStream) | Writes data synchronously to an ADS device.
Write(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, .Byte., Int32, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32, Int32, Int32) | Writes data synchronously to an ADS device.
WriteAny(Int32, Object) | Writes an object synchronously to an ADS device.
WriteAny(Int32, Object, .Int32.) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
WriteAny(UInt32, UInt32, Object) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object, .Int32.) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
WriteAny(UInt32, UInt32, Object, .Int32., Int32) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
WriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, Int32) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, AdsStream, Int32, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
WriteSymbol(ITcAdsSymbol, Object) | Writes a value to the symbol. Strings and all primitive data types(UInt32, Int32, Bool etc.) are supported. Array and structures are not supported. If a string is passed as parameter, the method attempts to parse the string according to the ADS data type of the symbol.
WriteSymbol(String, Object, Boolean) | Writes the passed object value to the specified ADS symbol.The parameter type must have the same layout as the ADS symbol.
Events
Name | Description
AdsNotification | Occurs when the ADS device sends a notification to the client.
AdsNotificationError | Occurs when a exception has occurred during notification management.
AdsNotificationEx | Occurs when the ADS devices sends a notification to the client.
AdsStateChanged | Occurs when ADS State has been changed.
AdsSymbolVersionChanged | Occurs when the symbol version has been changed.
AmsRouterNotification | Occurs when the Route sends an Notification.
ConnectionStateChanged | Occurs when connection status of the AdsConnection has been changed.
Extension Methods
Name | Description
PollAdsState(IObservable.Unit.) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollAdsState(TimeSpan) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollValues(String, Type, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
WhenNotification(ISymbol) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenNotification(ISymbol, NotificationSettings) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection, NotificationSettings) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenValueChanged | Observable sequence of Values driven by ADS Notifications on the specified symbol. (Defined by ValueSymbolExtensions.)
WriteValues.T.(String, IObservable.T.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
WriteValues.T.(String, IObservable.T., Action.Exception.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
Remarks
The ADS Connection class represents an ADS Point-to-Point Connection between client and server. It is established by using the Connect method of the AdsSession object. An ADS Connection can have different ConnectionStates, which represent the state of the logical ADS connection.
Reference
TwinCAT.Ads Namespace
TwinCAT.Ads.AdsSession
TwinCAT.Ads.IAdsConnection
System.IDisposable
Weiterführende Informationen
•
AdsConnection Properties
•
AdsConnection Methods
•
AdsConnection Events


AdsConnection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties
AdsConnection Properties
The AdsConnection type exposes the following members.
Properties
Name | Description
AccessWaitTime | Gets the access wait time.
ActiveSince | Gets the UTC time when tha last active/resurrected Connection was established
Address | Gets the AmsAddress of the ADS server.
ClientAddress | Get the AmsAddress of the ADS client.
ConnectionEstablishedAt | Gets the UTC time when the Connection was originally established.
ConnectionLostCount | Gets the connection lost count.
ConnectionLostTime | Gets the connection lost time.
ConnectionState | Gets the current Connection state of the AdsConnection
Disposed | Gets a value indicating whether this AdsConnection is disposed.
Id | Gets the AdsConnection identifier.
IsActive | Gets a value indicating whether communication is in active state
IsConnected | Gets a value indicating whether the local ADS port was opened successfully. It does not indicate if the target port is available. Use the method ReadState to determine if the target port is available.
IsLocal | Gets a value indicating whether the ADS client is connected to a ADS Server on the local computer.
IsLost | Gets a value indicating whether the communication is in lost / open state
IsReconnecting | Gets a value indicating whether communication is ready for reconnecting
Name | Gets the name.
ResurrectingTries | Gets the number of tries to resurrect the AdsConnection.
Resurrections | Gets the number of succeeded connection resurrections.
Session | Gets the Session object of the AdsConnection object.
State | Gets the current ConnectionState
Timeout | Gets the timeout (in milliseconds)
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.AccessWaitTime Property
•
AdsConnection.ActiveSince Property
•
AdsConnection.Address Property
•
AdsConnection.ClientAddress Property
•
AdsConnection.ConnectionEstablishedAt Property
•
AdsConnection.ConnectionLostCount Property
•
AdsConnection.ConnectionLostTime Property
•
AdsConnection.ConnectionState Property
•
AdsConnection.Disposed Property
•
AdsConnection.Id Property
•
AdsConnection.IsActive Property
•
AdsConnection.IsConnected Property
•
AdsConnection.IsLocal Property
•
AdsConnection.IsLost Property
•
AdsConnection.IsReconnecting Property
•
AdsConnection.Name Property
•
AdsConnection.ResurrectingTries Property
•
AdsConnection.Resurrections Property
•
AdsConnection.Session Property
•
AdsConnection.State Property
•
AdsConnection.Timeout Property


AdsConnection.AccessWaitTime Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.AccessWaitTime Property
AdsConnection.AccessWaitTime Property
Gets the access wait time.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TimeSpan AccessWaitTime { get; }
VB
Public ReadOnly Property AccessWaitTime As TimeSpan
Get
Property Value
Type: TimeSpan
The access wait time.
Remarks
Gets the Wait Time until the next communication try will be done. This time is calculated as follows: ResurrectionTime - (DateTime.Now - ConnectionLostTime)
Reference
AdsConnection Class
TwinCAT.Ads Namespace
AdsConnection.ConnectionLostTime
SessionSettings.ResurrectionTime


AdsConnection.ActiveSince Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.ActiveSince Property
AdsConnection.ActiveSince Property
Gets the UTC time when tha last active/resurrected Connection was established
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Nullable<DateTime> ActiveSince { get; }
VB
Public ReadOnly Property ActiveSince As Nullable(Of DateTime)
Get
Property Value
Type: Nullable.DateTime.
The active since.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.Address Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.Address Property
AdsConnection.Address Property
Gets the AmsAddress of the ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress Address { get; }
VB
Public ReadOnly Property Address As AmsAddress
Get
Property Value
Type: AmsAddress
The server address.
Implements
IAdsConnection.Address
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.ClientAddress Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.ClientAddress Property
AdsConnection.ClientAddress Property
Get the AmsAddress of the ADS client.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress ClientAddress { get; }
VB
Public ReadOnly Property ClientAddress As AmsAddress
Get
Property Value
Type: AmsAddress
The client address.
Implements
IAdsConnection.ClientAddress
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.ConnectionEstablishedAt Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.ConnectionEstablishedAt Property
AdsConnection.ConnectionEstablishedAt Property
Gets the UTC time when the Connection was originally established.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Nullable<DateTime> ConnectionEstablishedAt { get; }
VB
Public ReadOnly Property ConnectionEstablishedAt As Nullable(Of DateTime)
Get
Property Value
Type: Nullable.DateTime.
The connection established at.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.ConnectionLostCount Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.ConnectionLostCount Property
AdsConnection.ConnectionLostCount Property
Gets the connection lost count.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ConnectionLostCount { get; }
VB
Public ReadOnly Property ConnectionLostCount As Integer
Get
Property Value
Type: Int32
The connection lost count.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.ConnectionLostTime Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.ConnectionLostTime Property
AdsConnection.ConnectionLostTime Property
Gets the connection lost time.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Nullable<DateTime> ConnectionLostTime { get; }
VB
Public ReadOnly Property ConnectionLostTime As Nullable(Of DateTime)
Get
Property Value
Type: Nullable.DateTime.
The connection lost time.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.ConnectionState Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.ConnectionState Property
AdsConnection.ConnectionState Property
Gets the current Connection state of the AdsConnection
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ConnectionState ConnectionState { get; }
VB
Public ReadOnly Property ConnectionState As ConnectionState
Get
Property Value
Type: ConnectionState
The state of the connection.
Implements
IConnectionStateProvider.ConnectionState
Remarks
The Connection state changes only if the IConnection is established / shut down or active communication is triggered by the User of the IConnection object.
Examples
The following sample shows how to keep the ConnectionState updated by triggering ADS Communication.
Trigger ConnectionState changes in WPF Applications
private DispatcherTimer _timer = null;
private AdsSession _session = null;
//private AdsConnection _connection = null;

private void Window_Loaded(object sender, RoutedEventArgs e)
{
_session = new AdsSession(AmsNetId.Local, 10000);
IConnection connection = _session.Connect();
tbConnectionState.Text = connection.ConnectionState.ToString();
_session.ConnectionStateChanged += _session_ConnectionStateChanged;

_timer = new DispatcherTimer();
_timer.Interval = TimeSpan.FromMilliseconds(200);
_timer.Tick += TimerOnTick;

_timer.Start();
}

private void Window_Unloaded(object sender, RoutedEventArgs e)
{
_timer.Stop();
_session.Dispose();
}

private void _session_ConnectionStateChanged(object sender, TwinCAT.ConnectionStateChangedEventArgs e)
{
// ConnectionStateChanged will be triggered by communication Invokes
tbConnectionState.Text = e.NewState.ToString();
}

private void TimerOnTick(object sender, EventArgs eventArgs)
{
// The Timer Event will occur here in the UI thread because its an DispatcherTimer event!
// An active ADS request will trigger Connection State periodically!
StateInfo stateInfo;
if (_session.Connection.TryReadState(out stateInfo) == AdsErrorCode.NoError)
{
tbAdsState.Text = stateInfo.AdsState.ToString();
}
else
{
tbAdsState.Text = "Invalid";
}
}
Reference
AdsConnection Class
TwinCAT.Ads Namespace
AdsConnection.ConnectionStateChanged


AdsConnection.Disposed Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.Disposed Property
AdsConnection.Disposed Property
Gets a value indicating whether this AdsConnection is disposed.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Disposed { get; }
VB
Public ReadOnly Property Disposed As Boolean
Get
Property Value
Type: Boolean
true if disposed; otherwise, false.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.Id Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.Id Property
AdsConnection.Id Property
Gets the AdsConnection identifier.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Id { get; }
VB
Public ReadOnly Property Id As Integer
Get
Property Value
Type: Int32
The identifier.
Implements
IConnection.Id
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.IsActive Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.IsActive Property
AdsConnection.IsActive Property
Gets a value indicating whether communication is in active state
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsActive { get; }
VB
Public ReadOnly Property IsActive As Boolean
Get
Property Value
Type: Boolean
true if this instance is active; otherwise, false.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.IsConnected Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.IsConnected Property
AdsConnection.IsConnected Property
Gets a value indicating whether the local ADS port was opened successfully. It does not indicate if the target port is available. Use the method ReadState to determine if the target port is available.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsConnected { get; }
VB
Public ReadOnly Property IsConnected As Boolean
Get
Property Value
Type: Boolean
true if this instance is connected; otherwise, false.
Implements
IConnection.IsConnected
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.IsLocal Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.IsLocal Property
AdsConnection.IsLocal Property
Gets a value indicating whether the ADS client is connected to a ADS Server on the local computer.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsLocal { get; }
VB
Public ReadOnly Property IsLocal As Boolean
Get
Property Value
Type: Boolean
true if this instance is local; otherwise, false.
Implements
IAdsConnection.IsLocal
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.IsLost Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.IsLost Property
AdsConnection.IsLost Property
Gets a value indicating whether the communication is in lost / open state
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsLost { get; }
VB
Public ReadOnly Property IsLost As Boolean
Get
Property Value
Type: Boolean
true if this instance is lost; otherwise, false.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.IsReconnecting Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.IsReconnecting Property
AdsConnection.IsReconnecting Property
Gets a value indicating whether communication is ready for reconnecting
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReconnecting { get; }
VB
Public ReadOnly Property IsReconnecting As Boolean
Get
Property Value
Type: Boolean
true if this instance is reconnecting; otherwise, false.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.Name Property
AdsConnection.Name Property
Gets the name.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Name { get; }
VB
Public ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.ResurrectingTries Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.ResurrectingTries Property
AdsConnection.ResurrectingTries Property
Gets the number of tries to resurrect the AdsConnection.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ResurrectingTries { get; }
VB
Public ReadOnly Property ResurrectingTries As Integer
Get
Property Value
Type: Int32
The number of tried resurrections of the IConnection.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.Resurrections Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.Resurrections Property
AdsConnection.Resurrections Property
Gets the number of succeeded connection resurrections.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Resurrections { get; }
VB
Public ReadOnly Property Resurrections As Integer
Get
Property Value
Type: Int32
The resurrection count.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.Session Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.Session Property
AdsConnection.Session Property
Gets the Session object of the AdsConnection object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ISession Session { get; }
VB
Public ReadOnly Property Session As ISession
Get
Property Value
Type: ISession
The client.
Implements
IConnection.Session
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.State Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.State Property
AdsConnection.State Property
Gets the current ConnectionState
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ConnectionState State { get; }
VB
Public ReadOnly Property State As ConnectionState
Get
Property Value
Type: ConnectionState
The state.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.Timeout Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Properties [image] AdsConnection.Timeout Property
AdsConnection.Timeout Property
Gets the timeout (in milliseconds)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Timeout { get; set; }
VB
Public Property Timeout As Integer
Get
Set
Property Value
Type: Int32
The timeout.
Implements
IConnection.Timeout
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods
AdsConnection Methods
The AdsConnection type exposes the following members.
Methods
Name | Description
AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Adds the device notification.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Close | Closes the AdsConnection
Connect | (Re)Connects the IConnection when disconnected.
CreateSymbolLoader | Creates a new instance of the Symbol loader with the specified mode.
CreateVariableHandle | Generates a unique handle for an ADS variable.
DeleteDeviceNotification | Deletes an existing notification.
DeleteVariableHandle | Releases the handle of a ADS variable again.
Disconnect | Disconnects this IConnection.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeRpcMethod(String, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(String, String, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, String, .Object.) | Invokes the specified RPC Method.
Read(Int32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(Int32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, .Byte., Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, .Byte., Int32, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream, Int32, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
ReadAny(Int32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(Int32, Type, .Int32.) | Reads any.
ReadAny(UInt32, UInt32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object. If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
ReadAny(UInt32, UInt32, Type, .Int32., Int32) | Reads data synchronously from an ADS device and writes it to an object. If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
ReadAnyString(Int32, Int32, Encoding) | Reads the string.
ReadAnyString(UInt32, UInt32, Int32, Encoding) | Reads the string
ReadDeviceInfo | Reads the identification and version number of an ADS server.
ReadState. | Reads the ADS status and the device status from an ADS server.
ReadState(Int32) | Reads the ADS status and the device status from an ADS server.
ReadSymbol(ITcAdsSymbol) | Reads the value of a symbol and returns it as an object. Strings and all primitive datatypes(UInt32, Int32, Bool etc.) are supported. Arrays and structures cannot be read.
ReadSymbol(String, Type, Boolean) | Reads the value of a symbol and returns the value as object. The parameter type must have the same layout as the ADS symbol.
ReadSymbolInfo | Call this method to obtain information about the individual symbols (variables) in ADS devices.
ReadWrite(UInt32, UInt32, AdsStream, AdsStream) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, AdsStream, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device and then reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryAddDeviceNotification | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryAddDeviceNotificationEx | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryDeleteDeviceNotification | Deletes an existing notification.
TryInvokeRpcMethod(String, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(String, String, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.) | Invokes the specified RPC Method.
TryRead(Int32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, .Byte., Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, .Byte., Int32, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, AdsStream, Int32, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryReadState(StateInfo.) | Reads the ADS status and the device status from an ADS server. Unlike the ReadState method this method does not call an exception on failure. Instead an AdsErrorCode is returned. If the return value is equal to AdsErrorCode.NoError the call was successful.
TryReadState(Int32, StateInfo.) | Reads the ADS status and the device status from an ADS server. Unlike the ReadState method this method does not call an exception on failure. Instead an AdsErrorCode is returned. If the return value is equal to AdsErrorCode.NoError the call was successfull.
TryReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryWrite(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, .Byte., Int32, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, AdsStream, Int32, Int32, Int32) | Writes data synchronously to an ADS device.
TryWriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, Int32) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, AdsStream, Int32, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
Write(Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32) | Trigger Client Method/Command.
Write(UInt32, UInt32, Int32) | Trigger Client Method/Command.
Write(UInt32, UInt32, AdsStream) | Writes data synchronously to an ADS device.
Write(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, .Byte., Int32, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32, Int32, Int32) | Writes data synchronously to an ADS device.
WriteAny(Int32, Object) | Writes an object synchronously to an ADS device.
WriteAny(Int32, Object, .Int32.) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
WriteAny(UInt32, UInt32, Object) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object, .Int32.) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
WriteAny(UInt32, UInt32, Object, .Int32., Int32) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
WriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, Int32) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, AdsStream, Int32, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
WriteSymbol(ITcAdsSymbol, Object) | Writes a value to the symbol. Strings and all primitive data types(UInt32, Int32, Bool etc.) are supported. Array and structures are not supported. If a string is passed as parameter, the method attempts to parse the string according to the ADS data type of the symbol.
WriteSymbol(String, Object, Boolean) | Writes the passed object value to the specified ADS symbol.The parameter type must have the same layout as the ADS symbol.
Extension Methods
Name | Description
PollAdsState(IObservable.Unit.) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollAdsState(TimeSpan) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollValues(String, Type, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
WhenNotification(ISymbol) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenNotification(ISymbol, NotificationSettings) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection, NotificationSettings) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenValueChanged | Observable sequence of Values driven by ADS Notifications on the specified symbol. (Defined by ValueSymbolExtensions.)
WriteValues.T.(String, IObservable.T.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
WriteValues.T.(String, IObservable.T., Action.Exception.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.AddDeviceNotification Method
•
AdsConnection.AddDeviceNotificationEx Method
•
AdsConnection.Close Method
•
AdsConnection.Connect Method
•
AdsConnection.CreateSymbolLoader Method
•
AdsConnection.CreateVariableHandle Method
•
AdsConnection.DeleteDeviceNotification Method
•
AdsConnection.DeleteVariableHandle Method
•
AdsConnection.Disconnect Method
•
AdsConnection.Dispose Method
•
AdsConnection.InvokeRpcMethod Method
•
AdsConnection.Read Method
•
AdsConnection.ReadAny Method
•
AdsConnection.ReadAnyString Method
•
AdsConnection.ReadDeviceInfo Method
•
AdsConnection.ReadState Method
•
AdsConnection.ReadSymbol Method
•
AdsConnection.ReadSymbolInfo Method
•
AdsConnection.ReadWrite Method
•
AdsConnection.TryAddDeviceNotification Method
•
AdsConnection.TryAddDeviceNotificationEx Method
•
AdsConnection.TryDeleteDeviceNotification Method
•
AdsConnection.TryInvokeRpcMethod Method
•
AdsConnection.TryRead Method
•
AdsConnection.TryReadState Method
•
AdsConnection.TryReadWrite Method
•
AdsConnection.TryWrite Method
•
AdsConnection.TryWriteControl Method
•
AdsConnection.Write Method
•
AdsConnection.WriteAny Method
•
AdsConnection.WriteControl Method
•
AdsConnection.WriteSymbol Method


AdsConnection.AddDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.AddDeviceNotification Method
AdsConnection.AddDeviceNotification Method
Overload List
Name | Description
AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Adds the device notification.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)
•
AdsConnection.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)
•
AdsConnection.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
•
AdsConnection.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)


AdsConnection.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.AddDeviceNotification Method [image] AdsConnection.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)
AdsConnection.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
string variableName,
AdsStream dataStream,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
variableName As String,
dataStream As AdsStream,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object)
Reference
AdsConnection Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace


AdsConnection.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.AddDeviceNotification Method [image] AdsConnection.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)
AdsConnection.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)
Reference
AdsConnection Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace


AdsConnection.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.AddDeviceNotification Method [image] AdsConnection.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
AdsConnection.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
Adds the device notification.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
string variableName,
AdsStream dataStream,
int offset,
int length,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
variableName As String,
dataStream As AdsStream,
offset As Integer,
length As Integer,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
variableName | Type: System.String Name of the variable.
dataStream | Type: TwinCAT.Ads.AdsStream The data stream.
offset | Type: System.Int32 The offset.
length | Type: System.Int32 The length.
transMode | Type: TwinCAT.Ads.AdsTransMode The trans mode.
cycleTime | Type: System.Int32 The cycle time.
maxDelay | Type: System.Int32 The maximum delay.
userData | Type: System.Object The user data.
Return Value
Type: Int32
System.Int32.
Implements
IAdsNotifications.AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
Reference
AdsConnection Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace


AdsConnection.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.AddDeviceNotification Method [image] AdsConnection.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
AdsConnection.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
Reference
AdsConnection Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace


AdsConnection.AddDeviceNotificationEx Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.AddDeviceNotificationEx Method
AdsConnection.AddDeviceNotificationEx Method
Overload List
Name | Description
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)
•
AdsConnection.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
•
AdsConnection.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)
•
AdsConnection.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)


AdsConnection.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.AddDeviceNotificationEx Method [image] AdsConnection.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)
AdsConnection.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
string variableName,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type
)
VB
Public Function AddDeviceNotificationEx (
variableName As String,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type)
Reference
AdsConnection Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace


AdsConnection.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.AddDeviceNotificationEx Method [image] AdsConnection.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
AdsConnection.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
string variableName,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type,
int[] args
)
VB
Public Function AddDeviceNotificationEx (
variableName As String,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type,
args As Integer()
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
Reference
AdsConnection Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace


AdsConnection.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.AddDeviceNotificationEx Method [image] AdsConnection.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)
AdsConnection.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
uint indexGroup,
uint indexOffset,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type
)
VB
Public Function AddDeviceNotificationEx (
indexGroup As UInteger,
indexOffset As UInteger,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)
Reference
AdsConnection Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace


AdsConnection.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.AddDeviceNotificationEx Method [image] AdsConnection.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
AdsConnection.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
uint indexGroup,
uint indexOffset,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type,
int[] args
)
VB
Public Function AddDeviceNotificationEx (
indexGroup As UInteger,
indexOffset As UInteger,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type,
args As Integer()
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object s0000tored in the event argument.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
Reference
AdsConnection Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace


AdsConnection.Close Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Close Method
AdsConnection.Close Method
Closes the AdsConnection
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Close()
VB
Public Sub Close
Implements
IConnection.Close.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.Connect Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Connect Method
AdsConnection.Connect Method
(Re)Connects the IConnection when disconnected.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Connect()
VB
Public Function Connect As Boolean
Return Value
Type: Boolean
true if the AdsConnection is reconnected, false otherwise.
Implements
IConnection.Connect.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.CreateSymbolLoader Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.CreateSymbolLoader Method
AdsConnection.CreateSymbolLoader Method
Creates a new instance of the Symbol loader with the specified mode.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IAdsSymbolLoader CreateSymbolLoader(
ISession session,
SymbolLoaderSettings settings
)
VB
Public Function CreateSymbolLoader (
session As ISession,
settings As SymbolLoaderSettings
) As IAdsSymbolLoader
Parameters
session | Type: TwinCAT.ISession The session (for session orientated loades / symbols). Can be NULL if not present.
settings | Type: TwinCAT.Ads.SymbolLoaderSettings The settings.
Return Value
Type: IAdsSymbolLoader
The IAdsSymbolLoader interface of the Symbol loader.
Exceptions
Exception | Condition
ObjectDisposedException |
ObjectDisposedException |
Remarks
The Symbol Loader (V2) supports the following modes. FlatThe flat mode organizes the Symbols in a flat list. At the beginning this List caches only the root symbol objects, which can be enumerated. To access the sub elements like structure fields or array elements use the SubSymbols collection. The property get accessor generates the subsymbols lazy on the fly (performance optimized) and stores them internally as weak reference (memory optimized). This mode is available in all .NET versions.VirtualTreeOn top of the behaviour of the Flat, the virtual tree mode organizes the Symbols hierarchically with parent-child relationships. That eases the access to the hierarchical structure but needs slightly more preprocessing of the data. This mode is available in all .NET Versions. DynamicTreeThe Dynamic tree mode organizes the Symbols hierarchically and (dynamically) creates struct members, array elements and enum fields on the fly. 'Dynamically' means here not only lazy creation like in Flat, but furthermore real creation of type safe .NET complex types/instances as represetantives of the TwinCAT Symbol objects/types. This feature is only available on platforms that support the Dynamic Language Runtime (DLR); actually all .NET Framework Version larger than 4.0. Virtual instances means, that all Symbols are ordered within a tree structure. For that symbol nodes that are not located on a fixed address, a Virtual Symbol will be created. Setting the virtualInstance parameter to 'false' means, that the located symbols will be returned in a flattened list.
Examples
The following sample shows how to create a dynamic version of the SymbolLoader V2. The dynamic symbol loader makes use of the Dynamic Language Runtime (DLR) of the .NET Framework. That means Structures, Arrays and Enumeration types and instances are generated 'on-the-fly' during symbol Browsing. These created dynamic objects are a one to one representation of the Symbol Server target objects (e.g the IEC61131 types on the PLC). Dynamic language features are only available from .NET4 upwards.
Dynamic Tree Mode
namespace Sample
{
using System;
using System.Diagnostics;
using System.Threading;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.Ads.TypeSystem;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

class SymbolBrowserProgramV2DynamicTree
{

#region CODE_SAMPLE_SIMPLEDYNAMIC
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
// Get the AdsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect to the target device
client.Connect(address);

// Usage of "dynamic" Type and Symbols (>= .NET4 only)
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.DynamicTree);
IAdsSymbolLoader dynLoader = (IAdsSymbolLoader)SymbolLoaderFactory.Create(client, settings);

#endregion

// Set the Default setting for Notifications
dynLoader.DefaultNotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 200, 2000);

// Get the Symbols (Dynamic Symbols)
dynamic dynamicSymbols = ((IDynamicSymbolLoader)dynLoader).SymbolsDynamic;

dynamic adsPort = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.AdsPort;

#region CODE_SAMPLE_SIMPLEDYNAMIC

// Access Main Symbol with Dynamic Language Runtime support (DLR)
// Dynamically created property "Main"
//dynamic symMain = dynamicSymbols.Main;

// Main is an 'VirtualSymbol' / Organizational unit that doesn't have a value
// Calling ReadValue is not allowed
//bool test = symMain.HasValue;
//dynamic invalid = symMain.ReadValue();

//Reading TaskInfo Value
//With calling ReadValue() a 'snapshot' of the Symbols Instance is taken
dynamic vTaskInfoArray = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo.ReadValue();

// Getting the Snapshot time in UTC format
DateTime timeStamp1 = vTaskInfoArray.UtcTimeStamp;

// Getting TaskInfo Symbol for Task 1
dynamic symTaskInfo1 = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo[1];

// Getting CycleCount Symbol
dynamic symCycleCount = symTaskInfo1.CycleCount;

// Take Snapshot value of the ApplicationInfo struct
dynamic vAppInfo = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.ReadValue();
// Get the UTC Timestamp of the snapshot

DateTime timeStamp2 = vAppInfo.UtcTimeStamp;

// Access the ProjectName of the ApplicationInfo Snapshot (type-safe!)
string projectNameValue = vAppInfo.ProjectName;

// Reading the CycleCount Value
uint cycleCountValue = symTaskInfo1.CycleCount.ReadValue(); // Taking a Value Snapshot
#endregion

// Registering for dynamic "ValueChanged" events for the Values
// Using Default Notification settings
symCycleCount.ValueChanged += new EventHandler<ValueChangedArgs>(cycleCount_ValueChanged);

// Override default notification settings
symTaskInfo1.NotificationSettings = new NotificationSettings(AdsTransMode.Cyclic,500,0);

// Register for ValueChanged event.
symTaskInfo1.ValueChanged += new EventHandler<ValueChangedArgs>(taskInfo1Value_ValueChanged); // Struct Type

Thread.Sleep(10000); // Sleep main thread for 10 Seconds
}
Console.WriteLine("CycleCount Changed events received: {0}",_cycleCountEvents);
Console.WriteLine("taskInfo1 Changed events received: {0}", _taskInfo1Events);

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}

static object _notificationSynchronizer = new object();
static int _cycleCountEvents = 0;

/// <summary>
/// Handler function for the CycleCount ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void cycleCount_ValueChanged(object sender, ValueChangedArgs e)
{
lock(_notificationSynchronizer)
{
Interlocked.Increment(ref _cycleCountEvents);
// val is a type safe value of int!
dynamic val = e.Value;
uint intVal = val;

DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert UTC to local time
Console.WriteLine("CycleCount changed to: {0}, TimeStamp: {1}", intVal, changedTime.ToString("HH:mm:ss:fff"));
}
}

static int _taskInfo1Events = 0;

/// <summary>
/// Handler function for the TaskInfo ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void taskInfo1Value_ValueChanged(object sender, ValueChangedArgs e)
{
lock (_notificationSynchronizer)
{
Interlocked.Increment(ref _taskInfo1Events);
dynamic val = e.Value;
DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert to local time

// Val is a during Runtime created struct type and contains
// the same Properties as related PLC object.
int cycleTime = val.CycleTime;
Console.WriteLine("TaskInfo1Value changed TimeStamp: {0}", changedTime.ToString("HH:mm:ss:fff"));
}
}
}
}
The following sample shows how to create a static (non dynamic) version of the SymbolLoader V2. The static symbol loader in version 2 is a nearly code compatible version of the Dynamic Loader, only the dynamic creation of objects is not available. The reason for supporting this mode is that .NET Framework Versions lower than Version 4.0 (CLR2) doesn't support the Dynamic Language Runtime (DLR). The SymbolLoader V2 static object is supported from .NET 2.0 on.
Virtual Tree Mode
using System;
using System.Threading;
using System.Diagnostics;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.Ads.TypeSystem;

namespace Sample
{
class SymbolBrowserProgramV2VirtualTree
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
ConsoleLogger logger = new ConsoleLogger();

Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

//logger.Active = false;

Stopwatch stopper = new Stopwatch();

// Parse the command-line arguments
AmsAddress address = ArgParser.Parse(args);

stopper.Start();

using (TcAdsClient client = new TcAdsClient())
{
client.Synchronize = false;

// Connect the AdsClient to the device target.
client.Connect(address);

// Creates the Symbol Objects as hierarchical tree
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.VirtualTree, ValueAccessMode.IndexGroupOffsetPreferred);
ISymbolLoader symbolLoader = SymbolLoaderFactory.Create(client, settings);

// Dump Datatypes from Target Device
Console.WriteLine(string.Format("Dumping '{0}' DataTypes:", symbolLoader.DataTypes.Count));
foreach (IDataType type in symbolLoader.DataTypes)
{
logger.DumpType(type);
}
Console.WriteLine("");

// Dump Symbols from target device
Console.WriteLine("Dumping '{0}' Symbols:", symbolLoader.Symbols.Count);
foreach (ISymbol symbol in symbolLoader.Symbols)
{
logger.DumpSymbol(symbol,0);
}
}
stopper.Stop();
TimeSpan elapsed = stopper.Elapsed;

Console.WriteLine("");
Console.WriteLine("Browsing complete tree: {0},({1} DataTypes, {2} Symbols)",elapsed,logger.DataTypesCount,logger.DataTypesCount);
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Examples
The SymbolLoader V2 static object is supported from .NET 2.0 on.
Flat Mode
using System;
using System.Diagnostics;
using System.Threading;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.Ads.TypeSystem;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

namespace Sample
{
class SymbolBrowserProgramV2Flat
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
ConsoleLogger logger = new ConsoleLogger();

Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

//logger.Active = false;

Stopwatch stopper = new Stopwatch();

// Parse the command line arguments
AmsAddress address = ArgParser.Parse(args);

stopper.Start();

// Create the ADS Client
using (TcAdsClient client = new TcAdsClient())
{
client.Synchronize = false;

// Connect to Address
client.Timeout = 30000;
client.Connect(address);

// Creates the Symbol Objects in Flat Mode (Flat list)
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.Flat, ValueAccessMode.IndexGroupOffsetPreferred);
ISymbolLoader symbolLoader = SymbolLoaderFactory.Create(client, settings);

// Dump Datatypes from Target Device
Console.WriteLine(string.Format("Dumping '{0}' DataTypes:",symbolLoader.DataTypes.Count));
foreach (IDataType type in symbolLoader.DataTypes)
{
logger.DumpType(type);
}

Console.WriteLine("");

// Dump Symbols from target device
Console.WriteLine("Dumping '{0}' Symbols:",symbolLoader.Symbols.Count);
foreach (ISymbol symbol in symbolLoader.Symbols)
{
logger.DumpSymbol(symbol,0);
}
}
stopper.Stop();
TimeSpan elapsed = stopper.Elapsed;

Console.WriteLine("");
Console.WriteLine("Browsing complete tree: {0},({1} DataTypes, {2} Symbols)", elapsed, logger.DataTypesCount, logger.DataTypesCount);
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Examples
Argument Parser
public static class ArgParser
{
/// <summary>
/// Parses the arguments.
/// </summary>
/// <param name="args">The arguments.</param>
/// <returns>AmsAddress.</returns>
public static AmsAddress Parse(string[] args)
{
AmsNetId netId = AmsNetId.Local;
int port = 851;

if (args != null)
{
if (args.Length > 0 && args[0] != null)
netId = AmsNetId.Parse(args[0]);

if (args.Length > 1 && args[1] != null)
port = int.Parse(args[1]);
}
return new AmsAddress(netId, port);
}
}
Dumping Symbols
/// <summary>
/// Console logger
/// </summary>
public class ConsoleLogger
{
public ConsoleLogger()
{
}
bool _active = true;

/// <summary>
/// Gets or sets a value indicating whether this ConsoleLogger is active.
/// </summary>
/// <value><c>true</c> if active; otherwise, <c>false</c>.</value>
public bool Active
{
get { return _active; }
set
{
_active = value;
}
}

int _dataTypes = 0;

/// <summary>
/// Gets the number of dumped dataTypes.
/// </summary>
/// <value>The data types count.</value>
public int DataTypesCount
{
get { return _dataTypes; }
}

int _symbols = 0;

/// <summary>
/// Gets the number of dumped symbols
/// </summary>
/// <value>The symbols count.</value>
public int SymbolsCount
{
get { return _symbols; }
}

/// <summary>
/// Dumps the data type.
/// </summary>
/// <param name="dataType">Data Type.</param>
public void DumpType(IDataType dataType)
{
WriteLine(string.Format("DataType: {0}, Category: {1}, Size: {2}", dataType.Name, dataType.Category, dataType.Size));

switch (dataType.Category)
{
case DataTypeCategory.Alias:
IAliasType alias = (IAliasType)dataType;
WriteLine(GetPrefix(1) + string.Format("Alias BaseType: {0}", alias.BaseTypeName));
break;

case DataTypeCategory.Enum:

//IEnumType<ushort> enumType = (IEnumType<ushort>)dataType;
IEnumType enumType = (IEnumType)dataType;
WriteLine(GetPrefix(1) + string.Format("Enum BaseType: {0}", enumType.BaseTypeName));

foreach (IEnumValue enumValue in enumType.EnumValues)
{
WriteLine(GetPrefix(2) + string.Format("Name: {0}, Value: {1}", enumValue.Name, enumValue.Primitive));
}
break;
case DataTypeCategory.Array:

IArrayType arrayType = (IArrayType)dataType;
int i = 0;

foreach (IDimension dim in arrayType.Dimensions)
{
WriteLine(GetPrefix(2) + string.Format("{0}: LowerBound: {1}, Elements: {2}", i++, dim.LowerBound, dim.ElementCount));
}
break;
case DataTypeCategory.Struct:
IStructType structType = (IStructType)dataType;

foreach (IMember member in structType.Members)
{
WriteLine(GetPrefix(2) + string.Format("Offset {0}: Name: {1}, Type: {2}", member.Offset, member.InstanceName, member.TypeName));
}
break;
default:
break;
}

foreach (ITypeAttribute attribute in dataType.Attributes)
{
WriteLine(GetPrefix(1) + string.Format("{{ {0} : {1} }}", attribute.Name, attribute.Value));
}
if (!string.IsNullOrEmpty(dataType.Comment))
{
WriteLine(GetPrefix(1) + string.Format("Comment: {0}", dataType.Comment));
}

IRpcCallableType rpcCallable = dataType as IRpcCallableType;

if (rpcCallable != null)
{
foreach (IRpcMethod rpcMethod in rpcCallable.RpcMethods)
{
if (string.IsNullOrEmpty(rpcMethod.Comment))
WriteLine(GetPrefix(1) + string.Format("Method: {0}", rpcMethod));
else
WriteLine(GetPrefix(1) + string.Format("Method: {0}, Comment: {1}", rpcMethod, rpcMethod.Comment));
}
}
_dataTypes++;
}

/// <summary>
/// Dumps the Datatype to Console
/// </summary>
/// <param name="dataType">DataType.</param>
public void DumpType(ITcAdsDataType dataType)
{
// Dump the Attributes (PLC Metadata)
foreach (ITypeAttribute attribute in dataType.Attributes)
{
WriteLine(GetPrefix(1) + string.Format("{{ {0} : {1} }}", attribute.Name, attribute.Value));
}

WriteLine(string.Format("DataType: {0}, Category: {1}, Size: {2}", dataType.Name, dataType.Category, dataType.Size));

if (dataType.BaseType != null)
{
WriteLine(GetPrefix(1) + string.Format("BaseType: {0}", dataType.BaseType));
}

switch (dataType.Category)
{
case DataTypeCategory.Enum:
foreach (IEnumValue enumValue in dataType.EnumValues)
{
WriteLine(GetPrefix(2) + string.Format("Name: {0}, Value: {1}", enumValue.Name, enumValue.Primitive));
}
break;
case DataTypeCategory.Array:
int i = 0;
foreach (IDimension dim in dataType.Dimensions)
{
WriteLine(GetPrefix(2) + string.Format("{0}: LowerBound: {1}, Elements: {2}", i++, dim.LowerBound, dim.ElementCount));
}
break;
case DataTypeCategory.Struct:
foreach (ITcAdsSubItem subItem in dataType.SubItems)
{
WriteLine(GetPrefix(2) + string.Format("Offset {0}: Name: {1}, Type: {2}", subItem.Offset, subItem.SubItemName, subItem.Name));
}
break;
default:
break;
}
_dataTypes++;
}

/// <summary>
/// Dump Symbol
/// </summary>
/// <param name="symbol">The symbol.</param>
/// <param name="level">Output indentation level</param>
public void DumpSymbol(ISymbol symbol, int level)
{
IDataType type = symbol.DataType as IDataType;

foreach (ITypeAttribute attribute in symbol.Attributes)
{
WriteLine(GetPrefix(level) + string.Format("{{ {0} : {1} }}", attribute.Name, attribute.Value));
}

WriteLine(GetPrefix(level) + string.Format("{0} : {1} (IG: 0x{2} IO: 0x{3} size:{4})", symbol.InstanceName, symbol.TypeName, ((IAdsSymbol)symbol).IndexGroup.ToString("x"), ((IAdsSymbol)symbol).IndexOffset.ToString("x"), symbol.Size));

if (symbol.Category == DataTypeCategory.Array)
{
IArrayInstance arrInstance = (IArrayInstance)symbol;
IArrayType arrType = (IArrayType)symbol.DataType;

int count = 0;
level++;

foreach (ISymbol arrayElement in arrInstance.Elements)
{
DumpSymbol(arrayElement, level);
count++;

if (count > 20) // Write only the first 20 to limit output
break;
}
}
else if (symbol.Category == DataTypeCategory.Struct)
{
IStructInstance structInstance = (IStructInstance)symbol;
IStructType structType = (IStructType)symbol.DataType;

level++;

foreach (ISymbol member in structInstance.MemberInstances)
{
DumpSymbol(member, level);
}
}
_symbols++;
}

/// <summary>
/// Dumps the specified Symbol to the Console
/// </summary>
/// <param name="symbol">The symbol.</param>
/// <param name="level">The level.</param>
public void DumpSymbol(ITcAdsSymbol5 symbol, int level)
{
// Dump Attributes of the Symbol
foreach (ITypeAttribute attribute in symbol.Attributes)
{
WriteLine(GetPrefix(level) + string.Format("{{ {0} : {1} }}", attribute.Name, attribute.Value));
}

ITcAdsSymbolBrowser subSymbolProvider = (ITcAdsSymbolBrowser)symbol;

// Dump The Symbol
WriteLine(GetPrefix(level) + string.Format("{0} : {1} ({2}, IG: 0x{3} IO: 0x{4} size:{6} subCount:{5})", symbol.Name, symbol.TypeName, symbol.DataTypeId, symbol.IndexGroup.ToString("x"), symbol.IndexOffset.ToString("x"), subSymbolProvider.SubSymbols.Count, symbol.Size));
level++;

// Dump all SubSymbols with indentation
foreach (ITcAdsSymbol5 subSymbol in ((ITcAdsSymbolBrowser)symbol).SubSymbols)
{
DumpSymbol(subSymbol, level);
}
_symbols++;
}

/// <summary>
/// Dump namespace.
/// </summary>
/// <param name="ns">The namespace.</param>
public void DumpNamespace(INamespace<IDataType> ns)
{
WriteLine("Namespace: {0}, DataTypes: {1}", ns.Name, ns.DataTypes.Count);

foreach (IDataType type in ns.DataTypes)
{
DumpType(type);
}
}

/// <summary>
/// Get the indentation prefix
/// </summary>
/// <param name="level">The level.</param>
/// <returns>System.String.</returns>
public string GetPrefix(int level)
{
return "".PadLeft(level * 3);
}

/// <summary>
/// Writes a line to the Console
/// </summary>
/// <param name="message">The message.</param>
public void WriteLine(string message)
{
if (Active)
{
Console.WriteLine(message);
}
}

/// <summary>
/// Writes a line to the console
/// </summary>
/// <param name="format">The format.</param>
/// <param name="args">The arguments.</param>
public void WriteLine(string format, params object[] args)
{
if (Active)
{
Console.WriteLine(format,args);
}
}
}
Examples
The following sample shows how to call (Remote Procedures / Methods) with Virtual Symbols
RPC Call in Virtual Mode
class RpcCallVirtualProgram
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
// Get the AdsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
client.Synchronize = false;

// Connect to the target device
client.Connect(address);

SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.VirtualTree);
ISymbolLoader loader = SymbolLoaderFactory.Create(client, settings);

// Get the Symbols (Dynamic Symbols)

IRpcStructInstance main = (IRpcStructInstance)loader.Symbols["MAIN"]; // Gets the MAIN Instance of the PLC Program

// Call a Method that has the following signature (within MAIN Program)
/* {attribute 'TcRpcEnable'}
METHOD PUBLIC M_Add : INT
VAR_INPUT
i1 : INT := 0;
i2 : INT := 0;
END_VAR
*/

short result = (short)main.InvokeRpcMethod("M_Add", new object[] {(short) 3, (short) 4});

// Call a Method that has no parameter and returns VOID
main.InvokeRpcMethod("M_Method1", new object[] {});

//Browsing RpcMethods
foreach(IRpcMethod method in main.RpcMethods)
{
string methodName = method.Name;

foreach(IRpcMethodParameter parameter in method.Parameters)
{
string parameterName = parameter.Name;
string parameterType = parameter.TypeName;
}
}
}
}
}
Examples
The following sample shows how to call (Remote Procedures / Methods) with Dynamic Symbols.
RPC Call in Dynamic Mode
namespace Sample
{
using System;
using System.Diagnostics;
using System.Threading;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.Ads.TypeSystem;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

class RpcCallDynamicProgram
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
// Get the AdsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
client.Synchronize = false;

// Connect to the target device
client.Connect(address);

// Usage of "dynamic" Type and Symbols (>= .NET4 only)
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.DynamicTree);
ISymbolLoader dynLoader = SymbolLoaderFactory.Create(client, settings);

// Get the Symbols (Dynamic Symbols)
dynamic symbols = ((IDynamicSymbolLoader)dynLoader).SymbolsDynamic;
dynamic main = symbols.Main; // Gets the MAIN Instance of the PLC Program

// Call a Method that has the following signature (within MAIN Program)

/* {attribute 'TcRpcEnable'}
METHOD PUBLIC M_Add : INT
VAR_INPUT
i1 : INT := 0;
i2 : INT := 0;
END_VAR
*/

short result = main.M_Add(3,4);

// Call a Method that has no parameter and returns VOID
main.M_Method1();

//Browsing Rpc Methods
foreach (IRpcMethod method in main.RpcMethods)
{
string methodName = method.Name;

foreach (IRpcMethodParameter parameter in method.Parameters)
{
string parameterName = parameter.Name;
string parameterType = parameter.TypeName;
}
}
}
}
}
}
Reference
AdsConnection Class
TwinCAT.Ads Namespace
TwinCAT.Ads.TypeSystem.SymbolLoaderFactory


AdsConnection.CreateVariableHandle Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.CreateVariableHandle Method
AdsConnection.CreateVariableHandle Method
Generates a unique handle for an ADS variable.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int CreateVariableHandle(
string variableName
)
VB
Public Function CreateVariableHandle (
variableName As String
) As Integer
Parameters
variableName
Type: System.String
Name of the ADS variable
Return Value
Type: Int32
The handle of the ADS Variable.
Implements
IAdsHandleAccess.CreateVariableHandle(String)
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.DeleteDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.DeleteDeviceNotification Method
AdsConnection.DeleteDeviceNotification Method
Deletes an existing notification.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void DeleteDeviceNotification(
int notificationHandle
)
VB
Public Sub DeleteDeviceNotification (
notificationHandle As Integer
)
Parameters
notificationHandle
Type: System.Int32
Handle of the notification.
Implements
IAdsNotifications.DeleteDeviceNotification(Int32)
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.DeleteVariableHandle Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.DeleteVariableHandle Method
AdsConnection.DeleteVariableHandle Method
Releases the handle of a ADS variable again.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void DeleteVariableHandle(
int variableHandle
)
VB
Public Sub DeleteVariableHandle (
variableHandle As Integer
)
Parameters
variableHandle
Type: System.Int32
Handle of the ADS variable
Implements
IAdsHandleAccess.DeleteVariableHandle(Int32)
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.Disconnect Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Disconnect Method
AdsConnection.Disconnect Method
Disconnects this IConnection.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Disconnect()
VB
Public Function Disconnect As Boolean
Return Value
Type: Boolean
true if XXXX, false otherwise.
Implements
IConnection.Disconnect.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.Dispose Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Dispose Method
AdsConnection.Dispose Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Dispose()
VB
Public Sub Dispose
Implements
IDisposable.Dispose.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.InvokeRpcMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.InvokeRpcMethod Method
AdsConnection.InvokeRpcMethod Method
Overload List
Name | Description
InvokeRpcMethod(String, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(String, String, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, String, .Object.) | Invokes the specified RPC Method.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.InvokeRpcMethod Method (String, Int32, .Object.)
•
AdsConnection.InvokeRpcMethod Method (String, String, .Object.)
•
AdsConnection.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)
•
AdsConnection.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)


AdsConnection.InvokeRpcMethod Method (String, Int32, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.InvokeRpcMethod Method [image] AdsConnection.InvokeRpcMethod Method (String, Int32, .Object.)
AdsConnection.InvokeRpcMethod Method (String, Int32, .Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object InvokeRpcMethod(
string symbolPath,
int methodId,
Object[] parameters
)
VB
Public Function InvokeRpcMethod (
symbolPath As String,
methodId As Integer,
parameters As Object()
) As Object
Parameters
symbolPath | Type: System.String The symbol path.
methodId | Type: System.Int32 The method identifier.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
The return value of the Method (as object).
Implements
ITcAdsRpcInvoke.InvokeRpcMethod(String, Int32, .Object.)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


AdsConnection.InvokeRpcMethod Method (String, String, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.InvokeRpcMethod Method [image] AdsConnection.InvokeRpcMethod Method (String, String, .Object.)
AdsConnection.InvokeRpcMethod Method (String, String, .Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object InvokeRpcMethod(
string symbolPath,
string methodName,
Object[] parameters
)
VB
Public Function InvokeRpcMethod (
symbolPath As String,
methodName As String,
parameters As Object()
) As Object
Parameters
symbolPath | Type: System.String The symbol path.
methodName | Type: System.String The method name.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
The return value of the Method (as object).
Implements
ITcAdsRpcInvoke.InvokeRpcMethod(String, String, .Object.)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


AdsConnection.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.InvokeRpcMethod Method [image] AdsConnection.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)
AdsConnection.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object InvokeRpcMethod(
ITcAdsSymbol symbol,
int methodId,
Object[] parameters
)
VB
Public Function InvokeRpcMethod (
symbol As ITcAdsSymbol,
methodId As Integer,
parameters As Object()
) As Object
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodId | Type: System.Int32 The method identifier / Virtual Function table index.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
The return value of the Method (as object).
Implements
ITcAdsRpcInvoke.InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


AdsConnection.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.InvokeRpcMethod Method [image] AdsConnection.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)
AdsConnection.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)
Invokes the specified RPC Method.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object InvokeRpcMethod(
ITcAdsSymbol symbol,
string methodName,
Object[] parameters
)
VB
Public Function InvokeRpcMethod (
symbol As ITcAdsSymbol,
methodName As String,
parameters As Object()
) As Object
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodName | Type: System.String Name of the method.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
The return value of the Method (as object).
Implements
ITcAdsRpcInvoke.InvokeRpcMethod(ITcAdsSymbol, String, .Object.)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


AdsConnection.Read Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Read Method
AdsConnection.Read Method
Overload List
Name | Description
Read(Int32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(Int32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, .Byte., Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, .Byte., Int32, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream, Int32, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.Read Method (Int32, AdsStream)
•
AdsConnection.Read Method (UInt32, UInt32, AdsStream)
•
AdsConnection.Read Method (Int32, AdsStream, Int32, Int32)
•
AdsConnection.Read Method (UInt32, UInt32, .Byte., Int32, Int32)
•
AdsConnection.Read Method (UInt32, UInt32, AdsStream, Int32, Int32)
•
AdsConnection.Read Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)
•
AdsConnection.Read Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)


AdsConnection.Read Method (Int32, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Read Method [image] AdsConnection.Read Method (Int32, AdsStream)
AdsConnection.Read Method (Int32, AdsStream)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
int variableHandle,
AdsStream dataStream
)
VB
Public Function Read (
variableHandle As Integer,
dataStream As AdsStream
) As Integer
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
Return Value
Type: Int32
Number of successfully returned data bytes.
Implements
IAdsHandleAccess.Read(Int32, AdsStream)
Reference
AdsConnection Class
Read Overload
TwinCAT.Ads Namespace


AdsConnection.Read Method (UInt32, UInt32, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Read Method [image] AdsConnection.Read Method (UInt32, UInt32, AdsStream)
AdsConnection.Read Method (UInt32, UInt32, AdsStream)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
uint indexGroup,
uint indexOffset,
AdsStream dataStream
)
VB
Public Function Read (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
Return Value
Type: Int32
Number of successfully returned data bytes.
Reference
AdsConnection Class
Read Overload
TwinCAT.Ads Namespace


AdsConnection.Read Method (Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Read Method [image] AdsConnection.Read Method (Int32, AdsStream, Int32, Int32)
AdsConnection.Read Method (Int32, AdsStream, Int32, Int32)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
int variableHandle,
AdsStream dataStream,
int offset,
int length
)
VB
Public Function Read (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As Integer
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Implements
IAdsHandleAccess.Read(Int32, AdsStream, Int32, Int32)
Reference
AdsConnection Class
Read Overload
TwinCAT.Ads Namespace


AdsConnection.Read Method (UInt32, UInt32, .Byte., Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Read Method [image] AdsConnection.Read Method (UInt32, UInt32, .Byte., Int32, Int32)
AdsConnection.Read Method (UInt32, UInt32, .Byte., Int32, Int32)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
uint indexGroup,
uint indexOffset,
byte[] readBuffer,
int offset,
int length
)
VB
Public Function Read (
indexGroup As UInteger,
indexOffset As UInteger,
readBuffer As Byte(),
offset As Integer,
length As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
readBuffer | Type: .System.Byte. The read buffer.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
Read Overload
TwinCAT.Ads Namespace


AdsConnection.Read Method (UInt32, UInt32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Read Method [image] AdsConnection.Read Method (UInt32, UInt32, AdsStream, Int32, Int32)
AdsConnection.Read Method (UInt32, UInt32, AdsStream, Int32, Int32)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length
)
VB
Public Function Read (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Reference
AdsConnection Class
Read Overload
TwinCAT.Ads Namespace


AdsConnection.Read Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Read Method [image] AdsConnection.Read Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)
AdsConnection.Read Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
uint indexGroup,
uint indexOffset,
byte[] readBuffer,
int offset,
int length,
int timeout
)
VB
Public Function Read (
indexGroup As UInteger,
indexOffset As UInteger,
readBuffer As Byte(),
offset As Integer,
length As Integer,
timeout As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
readBuffer | Type: .System.Byte. The read buffer.
offset | Type: System.Int32 The offset.
length | Type: System.Int32 The length.
timeout | Type: System.Int32 The timeout.
Return Value
Type: Int32
Number of successfully returned data bytes.
Reference
AdsConnection Class
Read Overload
TwinCAT.Ads Namespace


AdsConnection.Read Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Read Method [image] AdsConnection.Read Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)
AdsConnection.Read Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length,
int timeout
)
VB
Public Function Read (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer,
timeout As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 The offset.
length | Type: System.Int32 The length.
timeout | Type: System.Int32 The timeout.
Return Value
Type: Int32
Number of successfully returned data bytes.
Reference
AdsConnection Class
Read Overload
TwinCAT.Ads Namespace


AdsConnection.ReadAny Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadAny Method
AdsConnection.ReadAny Method
Overload List
Name | Description
ReadAny(Int32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(Int32, Type, .Int32.) | Reads any.
ReadAny(UInt32, UInt32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object. If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
ReadAny(UInt32, UInt32, Type, .Int32., Int32) | Reads data synchronously from an ADS device and writes it to an object. If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.ReadAny Method (Int32, Type)
•
AdsConnection.ReadAny Method (Int32, Type, .Int32.)
•
AdsConnection.ReadAny Method (UInt32, UInt32, Type)
•
AdsConnection.ReadAny Method (UInt32, UInt32, Type, .Int32.)
•
AdsConnection.ReadAny Method (UInt32, UInt32, Type, .Int32., Int32)


AdsConnection.ReadAny Method (Int32, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadAny Method [image] AdsConnection.ReadAny Method (Int32, Type)
AdsConnection.ReadAny Method (Int32, Type)
Reads data synchronously from an ADS device and writes it to an object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAny(
int variableHandle,
Type type
)
VB
Public Function ReadAny (
variableHandle As Integer,
type As Type
) As Object
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable.
type | Type: System.Type Type of the object to be read.
Return Value
Type: Object
The object the read data is written to.
Implements
IAdsAnyAccess.ReadAny(Int32, Type)
Reference
AdsConnection Class
ReadAny Overload
TwinCAT.Ads Namespace


AdsConnection.ReadAny Method (Int32, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadAny Method [image] AdsConnection.ReadAny Method (Int32, Type, .Int32.)
AdsConnection.ReadAny Method (Int32, Type, .Int32.)
Reads any.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAny(
int variableHandle,
Type type,
int[] args
)
VB
Public Function ReadAny (
variableHandle As Integer,
type As Type,
args As Integer()
) As Object
Parameters
variableHandle | Type: System.Int32 The variable handle.
type | Type: System.Type The type.
args | Type: .System.Int32. The arguments.
Return Value
Type: Object
System.Object.
Implements
IAdsAnyAccess.ReadAny(Int32, Type, .Int32.)
Reference
AdsConnection Class
ReadAny Overload
TwinCAT.Ads Namespace


AdsConnection.ReadAny Method (UInt32, UInt32, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadAny Method [image] AdsConnection.ReadAny Method (UInt32, UInt32, Type)
AdsConnection.ReadAny Method (UInt32, UInt32, Type)
Reads data synchronously from an ADS device and writes it to an object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAny(
uint indexGroup,
uint indexOffset,
Type type
)
VB
Public Function ReadAny (
indexGroup As UInteger,
indexOffset As UInteger,
type As Type
) As Object
Parameters
indexGroup | Type: System.UInt32 Index group of the ADS variable.
indexOffset | Type: System.UInt32 Index offset of the ADS variable.
type | Type: System.Type Type of the object to be read.
Return Value
Type: Object
The object the read data is written to.
Implements
IAdsAnyAccess.ReadAny(UInt32, UInt32, Type)
Reference
AdsConnection Class
ReadAny Overload
TwinCAT.Ads Namespace


AdsConnection.ReadAny Method (UInt32, UInt32, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadAny Method [image] AdsConnection.ReadAny Method (UInt32, UInt32, Type, .Int32.)
AdsConnection.ReadAny Method (UInt32, UInt32, Type, .Int32.)
Reads data synchronously from an ADS device and writes it to an object. If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAny(
uint indexGroup,
uint indexOffset,
Type type,
int[] args
)
VB
Public Function ReadAny (
indexGroup As UInteger,
indexOffset As UInteger,
type As Type,
args As Integer()
) As Object
Parameters
indexGroup | Type: System.UInt32 Index group of the ADS variable.
indexOffset | Type: System.UInt32 Index offset of the ADS variable.
type | Type: System.Type Type of the object to be read.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Object
The object the read data is written to.
Implements
IAdsAnyAccess.ReadAny(UInt32, UInt32, Type, .Int32.)
Reference
AdsConnection Class
ReadAny Overload
TwinCAT.Ads Namespace


AdsConnection.ReadAny Method (UInt32, UInt32, Type, .Int32., Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadAny Method [image] AdsConnection.ReadAny Method (UInt32, UInt32, Type, .Int32., Int32)
AdsConnection.ReadAny Method (UInt32, UInt32, Type, .Int32., Int32)
Reads data synchronously from an ADS device and writes it to an object. If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAny(
uint indexGroup,
uint indexOffset,
Type type,
int[] args,
int timeout
)
VB
Public Function ReadAny (
indexGroup As UInteger,
indexOffset As UInteger,
type As Type,
args As Integer(),
timeout As Integer
) As Object
Parameters
indexGroup | Type: System.UInt32 Index group of the ADS variable.
indexOffset | Type: System.UInt32 Index offset of the ADS variable.
type | Type: System.Type Type of the object to be read.
args | Type: .System.Int32. Additional arguments.
timeout | Type: System.Int32 The timeout.
Return Value
Type: Object
The object the read data is written to.
Reference
AdsConnection Class
ReadAny Overload
TwinCAT.Ads Namespace


AdsConnection.ReadAnyString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadAnyString Method
AdsConnection.ReadAnyString Method
Overload List
Name | Description
ReadAnyString(Int32, Int32, Encoding) | Reads the string.
ReadAnyString(UInt32, UInt32, Int32, Encoding) | Reads the string
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.ReadAnyString Method (Int32, Int32, Encoding)
•
AdsConnection.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)


AdsConnection.ReadAnyString Method (Int32, Int32, Encoding)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadAnyString Method [image] AdsConnection.ReadAnyString Method (Int32, Int32, Encoding)
AdsConnection.ReadAnyString Method (Int32, Int32, Encoding)
Reads the string.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ReadAnyString(
int variableHandle,
int len,
Encoding encoding
)
VB
Public Function ReadAnyString (
variableHandle As Integer,
len As Integer,
encoding As Encoding
) As String
Parameters
variableHandle | Type: System.Int32 The variable handle.
len | Type: System.Int32 The length.
encoding | Type: System.Text.Encoding The encoding.
Return Value
Type: String
System.String.
Implements
IAdsAnyAccess.ReadAnyString(Int32, Int32, Encoding)
Exceptions
Exception | Condition
ObjectDisposedException |
ObjectDisposedException |
Remarks
ASCII Encoding expected
Reference
AdsConnection Class
ReadAnyString Overload
TwinCAT.Ads Namespace


AdsConnection.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadAnyString Method [image] AdsConnection.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)
AdsConnection.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)
Reads the string
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ReadAnyString(
uint indexGroup,
uint indexOffset,
int len,
Encoding encoding
)
VB
Public Function ReadAnyString (
indexGroup As UInteger,
indexOffset As UInteger,
len As Integer,
encoding As Encoding
) As String
Parameters
indexGroup | Type: System.UInt32 The index group.
indexOffset | Type: System.UInt32 The index offset.
len | Type: System.Int32 The length.
encoding | Type: System.Text.Encoding The encoding.
Return Value
Type: String
System.String.
Implements
IAdsAnyAccess.ReadAnyString(UInt32, UInt32, Int32, Encoding)
Exceptions
Exception | Condition
ObjectDisposedException |
ObjectDisposedException |
Remarks
ASCII Encoding expected
Reference
AdsConnection Class
ReadAnyString Overload
TwinCAT.Ads Namespace


AdsConnection.ReadDeviceInfo Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadDeviceInfo Method
AdsConnection.ReadDeviceInfo Method
Reads the identification and version number of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DeviceInfo ReadDeviceInfo()
VB
Public Function ReadDeviceInfo As DeviceInfo
Return Value
Type: DeviceInfo
DeviceInfo struct containing the name of the device and the version information.
Implements
IAdsConnection.ReadDeviceInfo.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.ReadState Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadState Method
AdsConnection.ReadState Method
Overload List
Name | Description
ReadState. | Reads the ADS status and the device status from an ADS server.
ReadState(Int32) | Reads the ADS status and the device status from an ADS server.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.ReadState Method
•
AdsConnection.ReadState Method (Int32)


AdsConnection.ReadState Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadState Method [image] AdsConnection.ReadState Method
AdsConnection.ReadState Method
Reads the ADS status and the device status from an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public StateInfo ReadState()
VB
Public Function ReadState As StateInfo
Return Value
Type: StateInfo
The ADS statue and device status.
Reference
AdsConnection Class
ReadState Overload
TwinCAT.Ads Namespace


AdsConnection.ReadState Method (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadState Method [image] AdsConnection.ReadState Method (Int32)
AdsConnection.ReadState Method (Int32)
Reads the ADS status and the device status from an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public StateInfo ReadState(
int timeout
)
VB
Public Function ReadState (
timeout As Integer
) As StateInfo
Parameters
timeout
Type: System.Int32
The timeout.
Return Value
Type: StateInfo
The ADS statue and device status.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
ReadState Overload
TwinCAT.Ads Namespace


AdsConnection.ReadSymbol Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadSymbol Method
AdsConnection.ReadSymbol Method
Overload List
Name | Description
ReadSymbol(ITcAdsSymbol) | Reads the value of a symbol and returns it as an object. Strings and all primitive datatypes(UInt32, Int32, Bool etc.) are supported. Arrays and structures cannot be read.
ReadSymbol(String, Type, Boolean) | Reads the value of a symbol and returns the value as object. The parameter type must have the same layout as the ADS symbol.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.ReadSymbol Method (ITcAdsSymbol)
•
AdsConnection.ReadSymbol Method (String, Type, Boolean)


AdsConnection.ReadSymbol Method (ITcAdsSymbol)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadSymbol Method [image] AdsConnection.ReadSymbol Method (ITcAdsSymbol)
AdsConnection.ReadSymbol Method (ITcAdsSymbol)
Reads the value of a symbol and returns it as an object. Strings and all primitive datatypes(UInt32, Int32, Bool etc.) are supported. Arrays and structures cannot be read.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadSymbol(
ITcAdsSymbol symbol
)
VB
Public Function ReadSymbol (
symbol As ITcAdsSymbol
) As Object
Parameters
symbol
Type: TwinCAT.Ads.ITcAdsSymbol
The symbol that should be read.
Return Value
Type: Object
The value of the symbol as an object.
Reference
AdsConnection Class
ReadSymbol Overload
TwinCAT.Ads Namespace


AdsConnection.ReadSymbol Method (String, Type, Boolean)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadSymbol Method [image] AdsConnection.ReadSymbol Method (String, Type, Boolean)
AdsConnection.ReadSymbol Method (String, Type, Boolean)
Reads the value of a symbol and returns the value as object. The parameter type must have the same layout as the ADS symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadSymbol(
string name,
Type type,
bool reloadSymbolInfo
)
VB
Public Function ReadSymbol (
name As String,
type As Type,
reloadSymbolInfo As Boolean
) As Object
Parameters
name | Type: System.String Name of the ADS symbol.
type | Type: System.Type Managed type of the ADS symbol.
reloadSymbolInfo | Type: System.Boolean If reload is true previously stored symbol information is cleared. As a consequence the symbol information must be obtained from the ADS server again.
Return Value
Type: Object
Value of the symbol
Reference
AdsConnection Class
ReadSymbol Overload
TwinCAT.Ads Namespace


AdsConnection.ReadSymbolInfo Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadSymbolInfo Method
AdsConnection.ReadSymbolInfo Method
Call this method to obtain information about the individual symbols (variables) in ADS devices.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ITcAdsSymbol ReadSymbolInfo(
string name
)
VB
Public Function ReadSymbolInfo (
name As String
) As ITcAdsSymbol
Parameters
name
Type: System.String
Name of the symbol.
Return Value
Type: ITcAdsSymbol
A ITcAdsSymbol containing the requested symbol information or null if symbol could not be found.
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.ReadWrite Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadWrite Method
AdsConnection.ReadWrite Method
Overload List
Name | Description
ReadWrite(UInt32, UInt32, AdsStream, AdsStream) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, AdsStream, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device and then reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream)
•
AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream, Int32)
•
AdsConnection.ReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
•
AdsConnection.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32)
•
AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
•
AdsConnection.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32)
•
AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32)


AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadWrite Method [image] AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream)
AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReadWrite(
uint indexGroup,
uint indexOffset,
AdsStream rdDataStream,
AdsStream wrDataStream
)
VB
Public Function ReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
rdDataStream As AdsStream,
wrDataStream As AdsStream
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
Return Value
Type: Int32
Number of successfully returned data bytes.
Reference
AdsConnection Class
ReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadWrite Method [image] AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream, Int32)
AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream, Int32)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReadWrite(
uint indexGroup,
uint indexOffset,
AdsStream rdDataStream,
AdsStream wrDataStream,
int timeout
)
VB
Public Function ReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
rdDataStream As AdsStream,
wrDataStream As AdsStream,
timeout As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
timeout | Type: System.Int32 The timeout.
Return Value
Type: Int32
Number of successfully returned data bytes.
Reference
AdsConnection Class
ReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.ReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadWrite Method [image] AdsConnection.ReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
AdsConnection.ReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReadWrite(
int variableHandle,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength
)
VB
Public Function ReadWrite (
variableHandle As Integer,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer
) As Integer
Parameters
variableHandle | Type: System.Int32 Variable handle.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Implements
IAdsHandleAccess.ReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
Reference
AdsConnection Class
ReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadWrite Method [image] AdsConnection.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32)
AdsConnection.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32)
Writes data synchronously to an ADS device and then reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReadWrite(
uint indexGroup,
uint indexOffset,
byte[] readBuffer,
int rdOffset,
int rdLength,
byte[] writeBuffer,
int wrOffset,
int wrLength
)
VB
Public Function ReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
readBuffer As Byte(),
rdOffset As Integer,
rdLength As Integer,
writeBuffer As Byte(),
wrOffset As Integer,
wrLength As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
readBuffer | Type: .System.Byte. The read buffer.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
writeBuffer | Type: .System.Byte. The write buffer.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
ReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadWrite Method [image] AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReadWrite(
uint indexGroup,
uint indexOffset,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength
)
VB
Public Function ReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Reference
AdsConnection Class
ReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadWrite Method [image] AdsConnection.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32)
AdsConnection.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReadWrite(
uint indexGroup,
uint indexOffset,
byte[] readBuffer,
int rdOffset,
int rdLength,
byte[] writeBuffer,
int wrOffset,
int wrLength,
int timeout
)
VB
Public Function ReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
readBuffer As Byte(),
rdOffset As Integer,
rdLength As Integer,
writeBuffer As Byte(),
wrOffset As Integer,
wrLength As Integer,
timeout As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
readBuffer | Type: .System.Byte. The read buffer.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
writeBuffer | Type: .System.Byte. The write buffer.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
timeout | Type: System.Int32 The timeout.
Return Value
Type: Int32
Number of successfully returned data bytes.
Reference
AdsConnection Class
ReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.ReadWrite Method [image] AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32)
AdsConnection.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReadWrite(
uint indexGroup,
uint indexOffset,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength,
int timeout
)
VB
Public Function ReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer,
timeout As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
timeout | Type: System.Int32 The timeout.
Return Value
Type: Int32
Number of successfully returned data bytes.
Reference
AdsConnection Class
ReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.TryAddDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryAddDeviceNotification Method
AdsConnection.TryAddDeviceNotification Method
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryAddDeviceNotification(
string variableName,
AdsStream dataStream,
int offset,
int length,
NotificationSettings settings,
Object userData,
out uint handle
)
VB
Public Function TryAddDeviceNotification (
variableName As String,
dataStream As AdsStream,
offset As Integer,
length As Integer,
settings As NotificationSettings,
userData As Object,
<OutAttribute> ByRef handle As UInteger
) As AdsErrorCode
Parameters
variableName | Type: System.String Name of the ADS variable.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
settings | Type: TwinCAT.Ads.NotificationSettings The settings.
userData | Type: System.Object This object can be used to store user specific data.
handle | Type: System.UInt32. The handle.
Return Value
Type: AdsErrorCode
The ADS ErrorCode.
Implements
IAdsNotifications.TryAddDeviceNotification(String, AdsStream, Int32, Int32, NotificationSettings, Object, UInt32.)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.TryAddDeviceNotificationEx Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryAddDeviceNotificationEx Method
AdsConnection.TryAddDeviceNotificationEx Method
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryAddDeviceNotificationEx(
string variableName,
NotificationSettings settings,
Object userData,
Type type,
int[] args,
out uint handle
)
VB
Public Function TryAddDeviceNotificationEx (
variableName As String,
settings As NotificationSettings,
userData As Object,
type As Type,
args As Integer(),
<OutAttribute> ByRef handle As UInteger
) As AdsErrorCode
Parameters
variableName | Type: System.String Name of the ADS variable.
settings | Type: TwinCAT.Ads.NotificationSettings The settings.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
args | Type: .System.Int32. Additional arguments.
handle | Type: System.UInt32. The handle.
Return Value
Type: AdsErrorCode
The handle of the notification.
Implements
IAdsNotifications.TryAddDeviceNotificationEx(String, NotificationSettings, Object, Type, .Int32., UInt32.)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.TryDeleteDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryDeleteDeviceNotification Method
AdsConnection.TryDeleteDeviceNotification Method
Deletes an existing notification.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryDeleteDeviceNotification(
uint notificationHandle
)
VB
Public Function TryDeleteDeviceNotification (
notificationHandle As UInteger
) As AdsErrorCode
Parameters
notificationHandle
Type: System.UInt32
Handle of the notification.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Implements
IAdsNotifications.TryDeleteDeviceNotification(UInt32)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.TryInvokeRpcMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryInvokeRpcMethod Method
AdsConnection.TryInvokeRpcMethod Method
Overload List
Name | Description
TryInvokeRpcMethod(String, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(String, String, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.) | Invokes the specified RPC Method.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)
•
AdsConnection.TryInvokeRpcMethod Method (String, String, .Object., Object.)
•
AdsConnection.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)
•
AdsConnection.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)


AdsConnection.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryInvokeRpcMethod Method [image] AdsConnection.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)
AdsConnection.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryInvokeRpcMethod(
string symbolPath,
int methodId,
Object[] parameters,
out Object retValue
)
VB
Public Function TryInvokeRpcMethod (
symbolPath As String,
methodId As Integer,
parameters As Object(),
<OutAttribute> ByRef retValue As Object
) As AdsErrorCode
Parameters
symbolPath | Type: System.String The symbol path.
methodId | Type: System.Int32 The method identifier.
parameters | Type: .System.Object. The parameters.
retValue | Type: System.Object. The return value of the RPC method as object.
Return Value
Type: AdsErrorCode
The ADS Error Code.
Implements
ITcAdsRpcInvoke.TryInvokeRpcMethod(String, Int32, .Object., Object.)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


AdsConnection.TryInvokeRpcMethod Method (String, String, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryInvokeRpcMethod Method [image] AdsConnection.TryInvokeRpcMethod Method (String, String, .Object., Object.)
AdsConnection.TryInvokeRpcMethod Method (String, String, .Object., Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryInvokeRpcMethod(
string symbolPath,
string methodName,
Object[] parameters,
out Object retValue
)
VB
Public Function TryInvokeRpcMethod (
symbolPath As String,
methodName As String,
parameters As Object(),
<OutAttribute> ByRef retValue As Object
) As AdsErrorCode
Parameters
symbolPath | Type: System.String The symbol path.
methodName | Type: System.String The method name.
parameters | Type: .System.Object. The parameters.
retValue | Type: System.Object. The return value of the RPC method as object.
Return Value
Type: AdsErrorCode
The ADS Error Code.
Implements
ITcAdsRpcInvoke.TryInvokeRpcMethod(String, String, .Object., Object.)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


AdsConnection.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryInvokeRpcMethod Method [image] AdsConnection.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)
AdsConnection.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryInvokeRpcMethod(
ITcAdsSymbol symbol,
int methodId,
Object[] parameters,
out Object retValue
)
VB
Public Function TryInvokeRpcMethod (
symbol As ITcAdsSymbol,
methodId As Integer,
parameters As Object(),
<OutAttribute> ByRef retValue As Object
) As AdsErrorCode
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodId | Type: System.Int32 The method identifier / Virtual Function table index.
parameters | Type: .System.Object. The parameters.
retValue | Type: System.Object. The return value of the RPC method as object.
Return Value
Type: AdsErrorCode
The ADS Error Code.
Implements
ITcAdsRpcInvoke.TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


AdsConnection.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryInvokeRpcMethod Method [image] AdsConnection.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)
AdsConnection.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)
Invokes the specified RPC Method.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryInvokeRpcMethod(
ITcAdsSymbol symbol,
string methodName,
Object[] parameters,
out Object retValue
)
VB
Public Function TryInvokeRpcMethod (
symbol As ITcAdsSymbol,
methodName As String,
parameters As Object(),
<OutAttribute> ByRef retValue As Object
) As AdsErrorCode
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodName | Type: System.String Name of the method.
parameters | Type: .System.Object. The parameters.
retValue | Type: System.Object. The return value of the RPC method as object.
Return Value
Type: AdsErrorCode
The ADS Error Code.
Implements
ITcAdsRpcInvoke.TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


AdsConnection.TryRead Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryRead Method
AdsConnection.TryRead Method
Overload List
Name | Description
TryRead(Int32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, .Byte., Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, .Byte., Int32, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, AdsStream, Int32, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.TryRead Method (Int32, AdsStream, Int32, Int32, Int32.)
•
AdsConnection.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32.)
•
AdsConnection.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32.)
•
AdsConnection.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32, Int32.)
•
AdsConnection.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32, Int32.)


AdsConnection.TryRead Method (Int32, AdsStream, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryRead Method [image] AdsConnection.TryRead Method (Int32, AdsStream, Int32, Int32, Int32.)
AdsConnection.TryRead Method (Int32, AdsStream, Int32, Int32, Int32.)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryRead(
int variableHandle,
AdsStream dataStream,
int offset,
int length,
out int readBytes
)
VB
Public Function TryRead (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
readBytes | Type: System.Int32. Number of successfully returned data bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode
Implements
IAdsHandleAccess.TryRead(Int32, AdsStream, Int32, Int32, Int32.)
Reference
AdsConnection Class
TryRead Overload
TwinCAT.Ads Namespace


AdsConnection.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryRead Method [image] AdsConnection.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32.)
AdsConnection.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32.)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryRead(
uint indexGroup,
uint indexOffset,
byte[] readBuffer,
int offset,
int length,
out int readBytes
)
VB
Public Function TryRead (
indexGroup As UInteger,
indexOffset As UInteger,
readBuffer As Byte(),
offset As Integer,
length As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
readBuffer | Type: .System.Byte. The read buffer.
offset | Type: System.Int32 The offset.
length | Type: System.Int32 The length.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ObjectDisposedException |
ObjectDisposedException |
Reference
AdsConnection Class
TryRead Overload
TwinCAT.Ads Namespace


AdsConnection.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryRead Method [image] AdsConnection.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32.)
AdsConnection.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32.)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryRead(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length,
out int readBytes
)
VB
Public Function TryRead (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 The offset.
length | Type: System.Int32 The length.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryRead Overload
TwinCAT.Ads Namespace


AdsConnection.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryRead Method [image] AdsConnection.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32, Int32.)
AdsConnection.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32, Int32.)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryRead(
uint indexGroup,
uint indexOffset,
byte[] readBuffer,
int offset,
int length,
int timeout,
out int readBytes
)
VB
Public Function TryRead (
indexGroup As UInteger,
indexOffset As UInteger,
readBuffer As Byte(),
offset As Integer,
length As Integer,
timeout As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
readBuffer | Type: .System.Byte. The read buffer.
offset | Type: System.Int32 The offset.
length | Type: System.Int32 The length.
timeout | Type: System.Int32 The timeout.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
AdsConnection Class
TryRead Overload
TwinCAT.Ads Namespace


AdsConnection.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryRead Method [image] AdsConnection.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32, Int32.)
AdsConnection.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32, Int32.)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryRead(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length,
int timeout,
out int readBytes
)
VB
Public Function TryRead (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer,
timeout As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 The offset.
length | Type: System.Int32 The length.
timeout | Type: System.Int32 The timeout.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
AdsConnection Class
TryRead Overload
TwinCAT.Ads Namespace


AdsConnection.TryReadState Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryReadState Method
AdsConnection.TryReadState Method
Overload List
Name | Description
TryReadState(StateInfo.) | Reads the ADS status and the device status from an ADS server. Unlike the ReadState method this method does not call an exception on failure. Instead an AdsErrorCode is returned. If the return value is equal to AdsErrorCode.NoError the call was successful.
TryReadState(Int32, StateInfo.) | Reads the ADS status and the device status from an ADS server. Unlike the ReadState method this method does not call an exception on failure. Instead an AdsErrorCode is returned. If the return value is equal to AdsErrorCode.NoError the call was successfull.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.TryReadState Method (StateInfo.)
•
AdsConnection.TryReadState Method (Int32, StateInfo.)


AdsConnection.TryReadState Method (StateInfo.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryReadState Method [image] AdsConnection.TryReadState Method (StateInfo.)
AdsConnection.TryReadState Method (StateInfo.)
Reads the ADS status and the device status from an ADS server. Unlike the ReadState method this method does not call an exception on failure. Instead an AdsErrorCode is returned. If the return value is equal to AdsErrorCode.NoError the call was successful.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadState(
out StateInfo stateInfo
)
VB
Public Function TryReadState (
<OutAttribute> ByRef stateInfo As StateInfo
) As AdsErrorCode
Parameters
stateInfo
Type: TwinCAT.Ads.StateInfo.
The ADS statue and device status.
Return Value
Type: AdsErrorCode
AdsErrorCode of the ads read state call. Check for AdsErrorCode.NoError to see if call was successfull.
Reference
AdsConnection Class
TryReadState Overload
TwinCAT.Ads Namespace


AdsConnection.TryReadState Method (Int32, StateInfo.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryReadState Method [image] AdsConnection.TryReadState Method (Int32, StateInfo.)
AdsConnection.TryReadState Method (Int32, StateInfo.)
Reads the ADS status and the device status from an ADS server. Unlike the ReadState method this method does not call an exception on failure. Instead an AdsErrorCode is returned. If the return value is equal to AdsErrorCode.NoError the call was successfull.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadState(
int timeout,
out StateInfo stateInfo
)
VB
Public Function TryReadState (
timeout As Integer,
<OutAttribute> ByRef stateInfo As StateInfo
) As AdsErrorCode
Parameters
timeout | Type: System.Int32 The timeout.
stateInfo | Type: TwinCAT.Ads.StateInfo. The ADS statue and device status.
Return Value
Type: AdsErrorCode
AdsErrorCode of the ads read state call. Check for AdsErrorCode.NoError to see if call was successfull.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryReadState Overload
TwinCAT.Ads Namespace


AdsConnection.TryReadWrite Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryReadWrite Method
AdsConnection.TryReadWrite Method
Overload List
Name | Description
TryReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.TryReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
•
AdsConnection.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)
•
AdsConnection.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
•
AdsConnection.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32, Int32.)
•
AdsConnection.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32, Int32.)


AdsConnection.TryReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryReadWrite Method [image] AdsConnection.TryReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
AdsConnection.TryReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadWrite(
int variableHandle,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength,
out int readBytes
)
VB
Public Function TryReadWrite (
variableHandle As Integer,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
variableHandle | Type: System.Int32 Variable handle.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Implements
IAdsHandleAccess.TryReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
Reference
AdsConnection Class
TryReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryReadWrite Method [image] AdsConnection.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)
AdsConnection.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadWrite(
uint indexGroup,
uint indexOffset,
byte[] readBuffer,
int rdOffset,
int rdLength,
byte[] writeBuffer,
int wrOffset,
int wrLength,
out int readBytes
)
VB
Public Function TryReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
readBuffer As Byte(),
rdOffset As Integer,
rdLength As Integer,
writeBuffer As Byte(),
wrOffset As Integer,
wrLength As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
readBuffer | Type: .System.Byte. The read buffer.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
writeBuffer | Type: .System.Byte. The write buffer.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ObjectDisposedException |
ObjectDisposedException |
Reference
AdsConnection Class
TryReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryReadWrite Method [image] AdsConnection.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
AdsConnection.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadWrite(
uint indexGroup,
uint indexOffset,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength,
out int readBytes
)
VB
Public Function TryReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryReadWrite Method [image] AdsConnection.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32, Int32.)
AdsConnection.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32, Int32.)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadWrite(
uint indexGroup,
uint indexOffset,
byte[] readBuffer,
int rdOffset,
int rdLength,
byte[] writeBuffer,
int wrOffset,
int wrLength,
int timeout,
out int readBytes
)
VB
Public Function TryReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
readBuffer As Byte(),
rdOffset As Integer,
rdLength As Integer,
writeBuffer As Byte(),
wrOffset As Integer,
wrLength As Integer,
timeout As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
readBuffer | Type: .System.Byte. The read buffer.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
writeBuffer | Type: .System.Byte. The write buffer.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
timeout | Type: System.Int32 The timeout.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
AdsConnection Class
TryReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryReadWrite Method [image] AdsConnection.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32, Int32.)
AdsConnection.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32, Int32.)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadWrite(
uint indexGroup,
uint indexOffset,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength,
int timeout,
out int readBytes
)
VB
Public Function TryReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer,
timeout As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
timeout | Type: System.Int32 The timeout.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
AdsConnection Class
TryReadWrite Overload
TwinCAT.Ads Namespace


AdsConnection.TryWrite Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryWrite Method
AdsConnection.TryWrite Method
Overload List
Name | Description
TryWrite(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, .Byte., Int32, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, AdsStream, Int32, Int32, Int32) | Writes data synchronously to an ADS device.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.TryWrite Method (Int32, AdsStream, Int32, Int32)
•
AdsConnection.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32)
•
AdsConnection.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32)
•
AdsConnection.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)
•
AdsConnection.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)


AdsConnection.TryWrite Method (Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryWrite Method [image] AdsConnection.TryWrite Method (Int32, AdsStream, Int32, Int32)
AdsConnection.TryWrite Method (Int32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWrite(
int variableHandle,
AdsStream dataStream,
int offset,
int length
)
VB
Public Function TryWrite (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As AdsErrorCode
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Implements
IAdsHandleAccess.TryWrite(Int32, AdsStream, Int32, Int32)
Reference
AdsConnection Class
TryWrite Overload
TwinCAT.Ads Namespace


AdsConnection.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryWrite Method [image] AdsConnection.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32)
AdsConnection.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWrite(
uint indexGroup,
uint indexOffset,
byte[] writeBuffer,
int offset,
int length
)
VB
Public Function TryWrite (
indexGroup As UInteger,
indexOffset As UInteger,
writeBuffer As Byte(),
offset As Integer,
length As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
writeBuffer | Type: .System.Byte. The write buffer.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ObjectDisposedException |
ObjectDisposedException |
Reference
AdsConnection Class
TryWrite Overload
TwinCAT.Ads Namespace


AdsConnection.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryWrite Method [image] AdsConnection.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32)
AdsConnection.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWrite(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length
)
VB
Public Function TryWrite (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryWrite Overload
TwinCAT.Ads Namespace


AdsConnection.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryWrite Method [image] AdsConnection.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)
AdsConnection.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWrite(
uint indexGroup,
uint indexOffset,
byte[] writeStream,
int offset,
int length,
int timeout
)
VB
Public Function TryWrite (
indexGroup As UInteger,
indexOffset As UInteger,
writeStream As Byte(),
offset As Integer,
length As Integer,
timeout As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
writeStream | Type: .System.Byte. The write stream.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
timeout | Type: System.Int32 The timeout.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
AdsConnection Class
TryWrite Overload
TwinCAT.Ads Namespace


AdsConnection.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryWrite Method [image] AdsConnection.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)
AdsConnection.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWrite(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length,
int timeout
)
VB
Public Function TryWrite (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer,
timeout As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
timeout | Type: System.Int32 The timeout.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
AdsConnection Class
TryWrite Overload
TwinCAT.Ads Namespace


AdsConnection.TryWriteControl Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryWriteControl Method
AdsConnection.TryWriteControl Method
Overload List
Name | Description
TryWriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, Int32) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, AdsStream, Int32, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.TryWriteControl Method (StateInfo)
•
AdsConnection.TryWriteControl Method (StateInfo, Int32)
•
AdsConnection.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32)
•
AdsConnection.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32, Int32)


AdsConnection.TryWriteControl Method (StateInfo)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryWriteControl Method [image] AdsConnection.TryWriteControl Method (StateInfo)
AdsConnection.TryWriteControl Method (StateInfo)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWriteControl(
StateInfo stateInfo
)
VB
Public Function TryWriteControl (
stateInfo As StateInfo
) As AdsErrorCode
Parameters
stateInfo
Type: TwinCAT.Ads.StateInfo
New ADS status and device status.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryWriteControl Overload
TwinCAT.Ads Namespace


AdsConnection.TryWriteControl Method (StateInfo, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryWriteControl Method [image] AdsConnection.TryWriteControl Method (StateInfo, Int32)
AdsConnection.TryWriteControl Method (StateInfo, Int32)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWriteControl(
StateInfo stateInfo,
int timeout
)
VB
Public Function TryWriteControl (
stateInfo As StateInfo,
timeout As Integer
) As AdsErrorCode
Parameters
stateInfo | Type: TwinCAT.Ads.StateInfo New ADS status and device status.
timeout | Type: System.Int32 The timeout.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryWriteControl Overload
TwinCAT.Ads Namespace


AdsConnection.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryWriteControl Method [image] AdsConnection.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32)
AdsConnection.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWriteControl(
StateInfo stateInfo,
AdsStream dataStream,
int offset,
int length
)
VB
Public Function TryWriteControl (
stateInfo As StateInfo,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As AdsErrorCode
Parameters
stateInfo | Type: TwinCAT.Ads.StateInfo New ADS status and device status.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be sent to the ADS device
offset | Type: System.Int32 Offset of the data in the stream.
length | Type: System.Int32 Length of the data in the stream.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryWriteControl Overload
TwinCAT.Ads Namespace


AdsConnection.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.TryWriteControl Method [image] AdsConnection.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32, Int32)
AdsConnection.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32, Int32)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWriteControl(
StateInfo stateInfo,
AdsStream dataStream,
int offset,
int length,
int timeout
)
VB
Public Function TryWriteControl (
stateInfo As StateInfo,
dataStream As AdsStream,
offset As Integer,
length As Integer,
timeout As Integer
) As AdsErrorCode
Parameters
stateInfo | Type: TwinCAT.Ads.StateInfo New ADS status and device status.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be sent to the ADS device
offset | Type: System.Int32 Offset of the data in the stream.
length | Type: System.Int32 Length of the data in the stream.
timeout | Type: System.Int32 The timeout.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
TryWriteControl Overload
TwinCAT.Ads Namespace


AdsConnection.Write Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Write Method
AdsConnection.Write Method
Overload List
Name | Description
Write(Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32) | Trigger Client Method/Command.
Write(UInt32, UInt32, Int32) | Trigger Client Method/Command.
Write(UInt32, UInt32, AdsStream) | Writes data synchronously to an ADS device.
Write(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, .Byte., Int32, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32, Int32, Int32) | Writes data synchronously to an ADS device.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.Write Method (Int32, AdsStream)
•
AdsConnection.Write Method (UInt32, UInt32)
•
AdsConnection.Write Method (UInt32, UInt32, Int32)
•
AdsConnection.Write Method (UInt32, UInt32, AdsStream)
•
AdsConnection.Write Method (Int32, AdsStream, Int32, Int32)
•
AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32)
•
AdsConnection.Write Method (UInt32, UInt32, .Byte., Int32, Int32)
•
AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32, Int32)
•
AdsConnection.Write Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)
•
AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)


AdsConnection.Write Method (Int32, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Write Method [image] AdsConnection.Write Method (Int32, AdsStream)
AdsConnection.Write Method (Int32, AdsStream)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
int variableHandle,
AdsStream dataStream
)
VB
Public Sub Write (
variableHandle As Integer,
dataStream As AdsStream
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
Implements
IAdsHandleAccess.Write(Int32, AdsStream)
Reference
AdsConnection Class
Write Overload
TwinCAT.Ads Namespace


AdsConnection.Write Method (UInt32, UInt32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Write Method [image] AdsConnection.Write Method (UInt32, UInt32)
AdsConnection.Write Method (UInt32, UInt32)
Trigger Client Method/Command.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
Remarks
This method is used to trigger Client Methods/Commands without parameters.
Reference
AdsConnection Class
Write Overload
TwinCAT.Ads Namespace


AdsConnection.Write Method (UInt32, UInt32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Write Method [image] AdsConnection.Write Method (UInt32, UInt32, Int32)
AdsConnection.Write Method (UInt32, UInt32, Int32)
Trigger Client Method/Command.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset,
int timeout
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger,
timeout As Integer
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
timeout | Type: System.Int32 The timeout.
Remarks
This method is used to trigger Client Methods/Commands without parameters.
Reference
AdsConnection Class
Write Overload
TwinCAT.Ads Namespace


AdsConnection.Write Method (UInt32, UInt32, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Write Method [image] AdsConnection.Write Method (UInt32, UInt32, AdsStream)
AdsConnection.Write Method (UInt32, UInt32, AdsStream)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset,
AdsStream dataStream
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
Reference
AdsConnection Class
Write Overload
TwinCAT.Ads Namespace


AdsConnection.Write Method (Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Write Method [image] AdsConnection.Write Method (Int32, AdsStream, Int32, Int32)
AdsConnection.Write Method (Int32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
int variableHandle,
AdsStream dataStream,
int offset,
int length
)
VB
Public Sub Write (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Implements
IAdsHandleAccess.Write(Int32, AdsStream, Int32, Int32)
Reference
AdsConnection Class
Write Overload
TwinCAT.Ads Namespace


AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Write Method [image] AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32)
AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int timeout
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
timeout As Integer
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
timeout | Type: System.Int32 The timeout.
Reference
AdsConnection Class
Write Overload
TwinCAT.Ads Namespace


AdsConnection.Write Method (UInt32, UInt32, .Byte., Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Write Method [image] AdsConnection.Write Method (UInt32, UInt32, .Byte., Int32, Int32)
AdsConnection.Write Method (UInt32, UInt32, .Byte., Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset,
byte[] writeBuffer,
int offset,
int length
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger,
writeBuffer As Byte(),
offset As Integer,
length As Integer
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
writeBuffer | Type: .System.Byte. The write buffer.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
Write Overload
TwinCAT.Ads Namespace


AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Write Method [image] AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32, Int32)
AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Reference
AdsConnection Class
Write Overload
TwinCAT.Ads Namespace


AdsConnection.Write Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Write Method [image] AdsConnection.Write Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)
AdsConnection.Write Method (UInt32, UInt32, .Byte., Int32, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset,
byte[] writeBuffer,
int offset,
int length,
int timeout
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger,
writeBuffer As Byte(),
offset As Integer,
length As Integer,
timeout As Integer
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
writeBuffer | Type: .System.Byte. The write buffer.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
timeout | Type: System.Int32 The timeout.
Reference
AdsConnection Class
Write Overload
TwinCAT.Ads Namespace


AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.Write Method [image] AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)
AdsConnection.Write Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length,
int timeout
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer,
timeout As Integer
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
timeout | Type: System.Int32 The timeout.
Reference
AdsConnection Class
Write Overload
TwinCAT.Ads Namespace


AdsConnection.WriteAny Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteAny Method
AdsConnection.WriteAny Method
Overload List
Name | Description
WriteAny(Int32, Object) | Writes an object synchronously to an ADS device.
WriteAny(Int32, Object, .Int32.) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
WriteAny(UInt32, UInt32, Object) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object, .Int32.) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
WriteAny(UInt32, UInt32, Object, .Int32., Int32) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.WriteAny Method (Int32, Object)
•
AdsConnection.WriteAny Method (Int32, Object, .Int32.)
•
AdsConnection.WriteAny Method (UInt32, UInt32, Object)
•
AdsConnection.WriteAny Method (UInt32, UInt32, Object, .Int32.)
•
AdsConnection.WriteAny Method (UInt32, UInt32, Object, .Int32., Int32)


AdsConnection.WriteAny Method (Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteAny Method [image] AdsConnection.WriteAny Method (Int32, Object)
AdsConnection.WriteAny Method (Int32, Object)
Writes an object synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAny(
int variableHandle,
Object value
)
VB
Public Sub WriteAny (
variableHandle As Integer,
value As Object
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable.
value | Type: System.Object Object to write to the ADS device.
Implements
IAdsAnyAccess.WriteAny(Int32, Object)
Reference
AdsConnection Class
WriteAny Overload
TwinCAT.Ads Namespace


AdsConnection.WriteAny Method (Int32, Object, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteAny Method [image] AdsConnection.WriteAny Method (Int32, Object, .Int32.)
AdsConnection.WriteAny Method (Int32, Object, .Int32.)
Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAny(
int variableHandle,
Object value,
int[] args
)
VB
Public Sub WriteAny (
variableHandle As Integer,
value As Object,
args As Integer()
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable.
value | Type: System.Object Object to write to the ADS device.
args | Type: .System.Int32. Additional arguments.
Implements
IAdsAnyAccess.WriteAny(Int32, Object, .Int32.)
Reference
AdsConnection Class
WriteAny Overload
TwinCAT.Ads Namespace


AdsConnection.WriteAny Method (UInt32, UInt32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteAny Method [image] AdsConnection.WriteAny Method (UInt32, UInt32, Object)
AdsConnection.WriteAny Method (UInt32, UInt32, Object)
Writes an object synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAny(
uint indexGroup,
uint indexOffset,
Object value
)
VB
Public Sub WriteAny (
indexGroup As UInteger,
indexOffset As UInteger,
value As Object
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
value | Type: System.Object Object to write to the ADS device.
Implements
IAdsAnyAccess.WriteAny(UInt32, UInt32, Object)
Reference
AdsConnection Class
WriteAny Overload
TwinCAT.Ads Namespace


AdsConnection.WriteAny Method (UInt32, UInt32, Object, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteAny Method [image] AdsConnection.WriteAny Method (UInt32, UInt32, Object, .Int32.)
AdsConnection.WriteAny Method (UInt32, UInt32, Object, .Int32.)
Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAny(
uint indexGroup,
uint indexOffset,
Object value,
int[] args
)
VB
Public Sub WriteAny (
indexGroup As UInteger,
indexOffset As UInteger,
value As Object,
args As Integer()
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
value | Type: System.Object Object to write to the ADS device.
args | Type: .System.Int32. Additional arguments.
Implements
IAdsAnyAccess.WriteAny(UInt32, UInt32, Object, .Int32.)
Reference
AdsConnection Class
WriteAny Overload
TwinCAT.Ads Namespace


AdsConnection.WriteAny Method (UInt32, UInt32, Object, .Int32., Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteAny Method [image] AdsConnection.WriteAny Method (UInt32, UInt32, Object, .Int32., Int32)
AdsConnection.WriteAny Method (UInt32, UInt32, Object, .Int32., Int32)
Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAny(
uint indexGroup,
uint indexOffset,
Object value,
int[] args,
int timeout
)
VB
Public Sub WriteAny (
indexGroup As UInteger,
indexOffset As UInteger,
value As Object,
args As Integer(),
timeout As Integer
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
value | Type: System.Object Object to write to the ADS device.
args | Type: .System.Int32. Additional arguments.
timeout | Type: System.Int32 The timeout.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
WriteAny Overload
TwinCAT.Ads Namespace


AdsConnection.WriteControl Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteControl Method
AdsConnection.WriteControl Method
Overload List
Name | Description
WriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, Int32) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, AdsStream, Int32, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.WriteControl Method (StateInfo)
•
AdsConnection.WriteControl Method (StateInfo, Int32)
•
AdsConnection.WriteControl Method (StateInfo, AdsStream, Int32, Int32)
•
AdsConnection.WriteControl Method (StateInfo, AdsStream, Int32, Int32, Int32)


AdsConnection.WriteControl Method (StateInfo)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteControl Method [image] AdsConnection.WriteControl Method (StateInfo)
AdsConnection.WriteControl Method (StateInfo)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteControl(
StateInfo stateInfo
)
VB
Public Sub WriteControl (
stateInfo As StateInfo
)
Parameters
stateInfo
Type: TwinCAT.Ads.StateInfo
New ADS status and device status.
Reference
AdsConnection Class
WriteControl Overload
TwinCAT.Ads Namespace


AdsConnection.WriteControl Method (StateInfo, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteControl Method [image] AdsConnection.WriteControl Method (StateInfo, Int32)
AdsConnection.WriteControl Method (StateInfo, Int32)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteControl(
StateInfo stateInfo,
int timeout
)
VB
Public Sub WriteControl (
stateInfo As StateInfo,
timeout As Integer
)
Parameters
stateInfo | Type: TwinCAT.Ads.StateInfo New ADS status and device status.
timeout | Type: System.Int32 The timeout.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
WriteControl Overload
TwinCAT.Ads Namespace


AdsConnection.WriteControl Method (StateInfo, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteControl Method [image] AdsConnection.WriteControl Method (StateInfo, AdsStream, Int32, Int32)
AdsConnection.WriteControl Method (StateInfo, AdsStream, Int32, Int32)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteControl(
StateInfo stateInfo,
AdsStream dataStream,
int offset,
int length
)
VB
Public Sub WriteControl (
stateInfo As StateInfo,
dataStream As AdsStream,
offset As Integer,
length As Integer
)
Parameters
stateInfo | Type: TwinCAT.Ads.StateInfo New ADS status and device status.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be sent to the ADS device
offset | Type: System.Int32 Offset of the data in the stream.
length | Type: System.Int32 Length of the data in the stream.
Reference
AdsConnection Class
WriteControl Overload
TwinCAT.Ads Namespace


AdsConnection.WriteControl Method (StateInfo, AdsStream, Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteControl Method [image] AdsConnection.WriteControl Method (StateInfo, AdsStream, Int32, Int32, Int32)
AdsConnection.WriteControl Method (StateInfo, AdsStream, Int32, Int32, Int32)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteControl(
StateInfo stateInfo,
AdsStream dataStream,
int offset,
int length,
int timeout
)
VB
Public Sub WriteControl (
stateInfo As StateInfo,
dataStream As AdsStream,
offset As Integer,
length As Integer,
timeout As Integer
)
Parameters
stateInfo | Type: TwinCAT.Ads.StateInfo New ADS status and device status.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be sent to the ADS device
offset | Type: System.Int32 Offset of the data in the stream.
length | Type: System.Int32 Length of the data in the stream.
timeout | Type: System.Int32 The timeout.
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
AdsConnection Class
WriteControl Overload
TwinCAT.Ads Namespace


AdsConnection.WriteSymbol Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteSymbol Method
AdsConnection.WriteSymbol Method
Overload List
Name | Description
WriteSymbol(ITcAdsSymbol, Object) | Writes a value to the symbol. Strings and all primitive data types(UInt32, Int32, Bool etc.) are supported. Array and structures are not supported. If a string is passed as parameter, the method attempts to parse the string according to the ADS data type of the symbol.
WriteSymbol(String, Object, Boolean) | Writes the passed object value to the specified ADS symbol.The parameter type must have the same layout as the ADS symbol.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.WriteSymbol Method (ITcAdsSymbol, Object)
•
AdsConnection.WriteSymbol Method (String, Object, Boolean)


AdsConnection.WriteSymbol Method (ITcAdsSymbol, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteSymbol Method [image] AdsConnection.WriteSymbol Method (ITcAdsSymbol, Object)
AdsConnection.WriteSymbol Method (ITcAdsSymbol, Object)
Writes a value to the symbol. Strings and all primitive data types(UInt32, Int32, Bool etc.) are supported. Array and structures are not supported. If a string is passed as parameter, the method attempts to parse the string according to the ADS data type of the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteSymbol(
ITcAdsSymbol symbol,
Object val
)
VB
Public Sub WriteSymbol (
symbol As ITcAdsSymbol,
val As Object
)
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol the value is written to.
val | Type: System.Object The value to write.
Reference
AdsConnection Class
WriteSymbol Overload
TwinCAT.Ads Namespace


AdsConnection.WriteSymbol Method (String, Object, Boolean)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Methods [image] AdsConnection.WriteSymbol Method [image] AdsConnection.WriteSymbol Method (String, Object, Boolean)
AdsConnection.WriteSymbol Method (String, Object, Boolean)
Writes the passed object value to the specified ADS symbol.The parameter type must have the same layout as the ADS symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteSymbol(
string name,
Object value,
bool reloadSymbolInfo
)
VB
Public Sub WriteSymbol (
name As String,
value As Object,
reloadSymbolInfo As Boolean
)
Parameters
name | Type: System.String Name of the ADS symbol.
value | Type: System.Object Object holding the value to be written to the ADS symbol
reloadSymbolInfo | Type: System.Boolean If reload is true previously stored symbol information is cleared. As a consequence the symbol information must be obtained from the ADS server again.
Reference
AdsConnection Class
WriteSymbol Overload
TwinCAT.Ads Namespace


AdsConnection Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Events
AdsConnection Events
The AdsConnection type exposes the following members.
Events
Name | Description
AdsNotification | Occurs when the ADS device sends a notification to the client.
AdsNotificationError | Occurs when a exception has occurred during notification management.
AdsNotificationEx | Occurs when the ADS devices sends a notification to the client.
AdsStateChanged | Occurs when ADS State has been changed.
AdsSymbolVersionChanged | Occurs when the symbol version has been changed.
AmsRouterNotification | Occurs when the Route sends an Notification.
ConnectionStateChanged | Occurs when connection status of the AdsConnection has been changed.
Reference
AdsConnection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsConnection.AdsNotification Event
•
AdsConnection.AdsNotificationError Event
•
AdsConnection.AdsNotificationEx Event
•
AdsConnection.AdsStateChanged Event
•
AdsConnection.AdsSymbolVersionChanged Event
•
AdsConnection.AmsRouterNotification Event
•
AdsConnection.ConnectionStateChanged Event


AdsConnection.AdsNotification Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Events [image] AdsConnection.AdsNotification Event
AdsConnection.AdsNotification Event
Occurs when the ADS device sends a notification to the client.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event AdsNotificationEventHandler AdsNotification
VB
Public Event AdsNotification As AdsNotificationEventHandler
Value
Type: TwinCAT.Ads.AdsNotificationEventHandler
Implements
IAdsNotifications.AdsNotification
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.AdsNotificationError Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Events [image] AdsConnection.AdsNotificationError Event
AdsConnection.AdsNotificationError Event
Occurs when a exception has occurred during notification management.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event AdsNotificationErrorEventHandler AdsNotificationError
VB
Public Event AdsNotificationError As AdsNotificationErrorEventHandler
Value
Type: TwinCAT.Ads.AdsNotificationErrorEventHandler
Implements
IAdsNotifications.AdsNotificationError
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.AdsNotificationEx Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Events [image] AdsConnection.AdsNotificationEx Event
AdsConnection.AdsNotificationEx Event
Occurs when the ADS devices sends a notification to the client.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event AdsNotificationExEventHandler AdsNotificationEx
VB
Public Event AdsNotificationEx As AdsNotificationExEventHandler
Value
Type: TwinCAT.Ads.AdsNotificationExEventHandler
Implements
IAdsNotifications.AdsNotificationEx
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.AdsStateChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Events [image] AdsConnection.AdsStateChanged Event
AdsConnection.AdsStateChanged Event
Occurs when ADS State has been changed.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event AdsStateChangedEventHandler AdsStateChanged
VB
Public Event AdsStateChanged As AdsStateChangedEventHandler
Value
Type: TwinCAT.Ads.AdsStateChangedEventHandler
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.AdsSymbolVersionChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Events [image] AdsConnection.AdsSymbolVersionChanged Event
AdsConnection.AdsSymbolVersionChanged Event
Occurs when the symbol version has been changed.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event EventHandler AdsSymbolVersionChanged
VB
Public Event AdsSymbolVersionChanged As EventHandler
Value
Type: System.EventHandler
Remarks
This is the case when the connected ADS server restarts. This invalidates all actual opened symbol handles. The SymbolVersion counter doesn't trigger, when an online change is made on the PLC (ports 801, ..., 851 ...)
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.AmsRouterNotification Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Events [image] AdsConnection.AmsRouterNotification Event
AdsConnection.AmsRouterNotification Event
Occurs when the Route sends an Notification.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event AmsRouterNotificationEventHandler AmsRouterNotification
VB
Public Event AmsRouterNotification As AmsRouterNotificationEventHandler
Value
Type: TwinCAT.Ads.AmsRouterNotificationEventHandler
Reference
AdsConnection Class
TwinCAT.Ads Namespace


AdsConnection.ConnectionStateChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsConnection Class [image] AdsConnection Events [image] AdsConnection.ConnectionStateChanged Event
AdsConnection.ConnectionStateChanged Event
Occurs when connection status of the AdsConnection has been changed.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event EventHandler<ConnectionStateChangedEventArgs> ConnectionStateChanged
VB
Public Event ConnectionStateChanged As EventHandler(Of ConnectionStateChangedEventArgs)
Value
Type: System.EventHandler.ConnectionStateChangedEventArgs.
Implements
IConnectionStateProvider.ConnectionStateChanged
Remarks
The Connection state changes only if the IConnection is established / shut down or active communication is triggered by the User of the IConnection object.
Examples
The following sample shows how to keep the ConnectionState updated by triggering ADS Communication.
Trigger ConnectionState changes in WPF Applications
private DispatcherTimer _timer = null;
private AdsSession _session = null;
//private AdsConnection _connection = null;

private void Window_Loaded(object sender, RoutedEventArgs e)
{
_session = new AdsSession(AmsNetId.Local, 10000);
IConnection connection = _session.Connect();
tbConnectionState.Text = connection.ConnectionState.ToString();
_session.ConnectionStateChanged += _session_ConnectionStateChanged;

_timer = new DispatcherTimer();
_timer.Interval = TimeSpan.FromMilliseconds(200);
_timer.Tick += TimerOnTick;

_timer.Start();
}

private void Window_Unloaded(object sender, RoutedEventArgs e)
{
_timer.Stop();
_session.Dispose();
}

private void _session_ConnectionStateChanged(object sender, TwinCAT.ConnectionStateChangedEventArgs e)
{
// ConnectionStateChanged will be triggered by communication Invokes
tbConnectionState.Text = e.NewState.ToString();
}

private void TimerOnTick(object sender, EventArgs eventArgs)
{
// The Timer Event will occur here in the UI thread because its an DispatcherTimer event!
// An active ADS request will trigger Connection State periodically!
StateInfo stateInfo;
if (_session.Connection.TryReadState(out stateInfo) == AdsErrorCode.NoError)
{
tbAdsState.Text = stateInfo.AdsState.ToString();
}
else
{
tbAdsState.Text = "Invalid";
}
}
Reference
AdsConnection Class
TwinCAT.Ads Namespace
AdsConnection.ConnectionState


AdsDatatypeArrayInfo Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeArrayInfo Class
AdsDatatypeArrayInfo Class
Array definition for a single dimension.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.AdsDatatypeArrayInfo
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class AdsDatatypeArrayInfo
VB
Public Class AdsDatatypeArrayInfo
The AdsDatatypeArrayInfo type exposes the following members.
Properties
Name | Description
Elements | Gets the number of elements.
LowerBound | Gets the lower bound.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsDatatypeArrayInfo Properties
•
AdsDatatypeArrayInfo Methods


AdsDatatypeArrayInfo Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeArrayInfo Class [image] AdsDatatypeArrayInfo Properties
AdsDatatypeArrayInfo Properties
The AdsDatatypeArrayInfo type exposes the following members.
Properties
Name | Description
Elements | Gets the number of elements.
LowerBound | Gets the lower bound.
Reference
AdsDatatypeArrayInfo Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsDatatypeArrayInfo.Elements Property
•
AdsDatatypeArrayInfo.LowerBound Property


AdsDatatypeArrayInfo.Elements Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeArrayInfo Class [image] AdsDatatypeArrayInfo Properties [image] AdsDatatypeArrayInfo.Elements Property
AdsDatatypeArrayInfo.Elements Property
Gets the number of elements.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Elements { get; }
VB
Public ReadOnly Property Elements As Integer
Get
Property Value
Type: Int32
Reference
AdsDatatypeArrayInfo Class
TwinCAT.Ads Namespace


AdsDatatypeArrayInfo.LowerBound Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeArrayInfo Class [image] AdsDatatypeArrayInfo Properties [image] AdsDatatypeArrayInfo.LowerBound Property
AdsDatatypeArrayInfo.LowerBound Property
Gets the lower bound.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int LowerBound { get; }
VB
Public ReadOnly Property LowerBound As Integer
Get
Property Value
Type: Int32
Reference
AdsDatatypeArrayInfo Class
TwinCAT.Ads Namespace


AdsDatatypeArrayInfo Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeArrayInfo Class [image] AdsDatatypeArrayInfo Methods
AdsDatatypeArrayInfo Methods
The AdsDatatypeArrayInfo type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AdsDatatypeArrayInfo Class
TwinCAT.Ads Namespace


AdsDatatypeId Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeId Enumeration
AdsDatatypeId Enumeration
ADS data types.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum AdsDatatypeId
VB
Public Enumeration AdsDatatypeId
Members
Member name | Value | Description
ADST_VOID | 0 | Empty Type
ADST_INT8 | 16 | Integer 8 Bit
ADST_UINT8 | 17 | Unsigned integer 8 Bit
ADST_INT16 | 2 | Integer 16 Bit
ADST_UINT16 | 18 | Unsigned integer 16 Bit
ADST_INT32 | 3 | Integer 32 Bit
ADST_UINT32 | 19 | Unsigned Integer 32 Bit
ADST_INT64 | 20 | LONG Integer 64 Bit
ADST_UINT64 | 21 | Unsigned Long integer 64 Bit
ADST_REAL32 | 4 | Real (32 Bit)
ADST_REAL64 | 5 | Real 64 Bit
ADST_BIGTYPE | 65 | Blob
ADST_STRING | 30 | STRING
ADST_WSTRING | 31 | WSTRING
ADST_REAL80 | 32 | ADS REAL80
ADST_BIT | 33 | ADS BIT
ADST_MAXTYPES | 34 | Internal Only
Reference
TwinCAT.Ads Namespace


AdsDatatypeNotSupportedException Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeNotSupportedException Class
AdsDatatypeNotSupportedException Class
The exception that is thrown when a ADS datatype is not supported.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.Ads.AdsDatatypeNotSupportedException
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class AdsDatatypeNotSupportedException : AdsException
VB
<SerializableAttribute>
Public Class AdsDatatypeNotSupportedException
Inherits AdsException
The AdsDatatypeNotSupportedException type exposes the following members.
Constructors
Name | Description
AdsDatatypeNotSupportedException. | Initializes a new Instance of the AdsDatatypeNotSupportedException class.
AdsDatatypeNotSupportedException(String) | Initializes a new Instance of the AdsDatatypeNotSupportedException class.
AdsDatatypeNotSupportedException(String, Exception) | Initializes a new Instance of the AdsDatatypeNotSupportedException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsDatatypeNotSupportedException Constructor
•
AdsDatatypeNotSupportedException Properties
•
AdsDatatypeNotSupportedException Methods
•
AdsDatatypeNotSupportedException Events


AdsDatatypeNotSupportedException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeNotSupportedException Class [image] AdsDatatypeNotSupportedException Constructor
AdsDatatypeNotSupportedException Constructor
Overload List
Name | Description
AdsDatatypeNotSupportedException. | Initializes a new Instance of the AdsDatatypeNotSupportedException class.
AdsDatatypeNotSupportedException(String) | Initializes a new Instance of the AdsDatatypeNotSupportedException class.
AdsDatatypeNotSupportedException(String, Exception) | Initializes a new Instance of the AdsDatatypeNotSupportedException class.
Reference
AdsDatatypeNotSupportedException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsDatatypeNotSupportedException Constructor
•
AdsDatatypeNotSupportedException Constructor (String)
•
AdsDatatypeNotSupportedException Constructor (String, Exception)


AdsDatatypeNotSupportedException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeNotSupportedException Class [image] AdsDatatypeNotSupportedException Constructor [image] AdsDatatypeNotSupportedException Constructor
AdsDatatypeNotSupportedException Constructor
Initializes a new Instance of the AdsDatatypeNotSupportedException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsDatatypeNotSupportedException()
VB
Public Sub New
Reference
AdsDatatypeNotSupportedException Class
AdsDatatypeNotSupportedException Overload
TwinCAT.Ads Namespace


AdsDatatypeNotSupportedException Constructor (String)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeNotSupportedException Class [image] AdsDatatypeNotSupportedException Constructor [image] AdsDatatypeNotSupportedException Constructor (String)
AdsDatatypeNotSupportedException Constructor (String)
Initializes a new Instance of the AdsDatatypeNotSupportedException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsDatatypeNotSupportedException(
string message
)
VB
Public Sub New (
message As String
)
Parameters
message
Type: System.String
The message.
Reference
AdsDatatypeNotSupportedException Class
AdsDatatypeNotSupportedException Overload
TwinCAT.Ads Namespace


AdsDatatypeNotSupportedException Constructor (String, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeNotSupportedException Class [image] AdsDatatypeNotSupportedException Constructor [image] AdsDatatypeNotSupportedException Constructor (String, Exception)
AdsDatatypeNotSupportedException Constructor (String, Exception)
Initializes a new Instance of the AdsDatatypeNotSupportedException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsDatatypeNotSupportedException(
string message,
Exception innerException
)
VB
Public Sub New (
message As String,
innerException As Exception
)
Parameters
message | Type: System.String The message.
innerException | Type: System.Exception The inner exception.
Reference
AdsDatatypeNotSupportedException Class
AdsDatatypeNotSupportedException Overload
TwinCAT.Ads Namespace


AdsDatatypeNotSupportedException Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeNotSupportedException Class [image] AdsDatatypeNotSupportedException Properties
AdsDatatypeNotSupportedException Properties
The AdsDatatypeNotSupportedException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
AdsDatatypeNotSupportedException Class
TwinCAT.Ads Namespace


AdsDatatypeNotSupportedException Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeNotSupportedException Class [image] AdsDatatypeNotSupportedException Methods
AdsDatatypeNotSupportedException Methods
The AdsDatatypeNotSupportedException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
AdsDatatypeNotSupportedException Class
TwinCAT.Ads Namespace


AdsDatatypeNotSupportedException Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsDatatypeNotSupportedException Class [image] AdsDatatypeNotSupportedException Events
AdsDatatypeNotSupportedException Events
The AdsDatatypeNotSupportedException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
AdsDatatypeNotSupportedException Class
TwinCAT.Ads Namespace


AdsErrorCode Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorCode Enumeration
AdsErrorCode Enumeration
Describes the ADS error that occured.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum AdsErrorCode
VB
Public Enumeration AdsErrorCode
Members
Member name | Value | Description
NoError | 0 | No Error. Error code: 0(0x000).
InternalError | 1 | Internal Error. Error code: 1(0x001).
NoRTime | 2 | No Rtime. Error code: 2(0x002).
LockedMemoryError | 3 | Allocation locked memory error. Error code: 3(0x003).
MailBoxError | 4 | Insert mailbox error. Error code: 4(0x004).
WrongHMsg | 5 | Wrong receive HMSG. Error code: 5(0x005).
TargetPortNotFound | 6 | Target port not found. Error code: 6(0x006).
TargetMachineNotFound | 7 | Target machine not found. Error code: 7(0x007).
UnknownCommandID | 8 | Unknown command ID. Error code: 8(0x008).
BadTaskID | 9 | Bad task ID. Error code: 9(0x009).
NoIO | 10 | No IO. Error code: 10(0x00A).
UnknwonAmsCommand | 11 | Unknown AMS command. Error code: 11(0x00B).
Win32Error | 12 | Win 32 error. Error code: 12(0x00C).
PortNotConnected | 13 | Port is not connected. Error code: 13(0x00D).
InvalidAmsLength | 14 | Invalid AMS length. Error code: 14(0x00E).
InvalidAmsNetID | 15 | Invalid AMS Net ID. Error code: 15(0x00F).
LowInstallLevel | 16 | Low Installation level. Error code: 16(0x010).
NoDebug | 17 | No debug available. Error code: 17(0x011).
PortDisabled | 18 | Port disabled. Error code: 18(0x012).
PortConnected | 19 | Port is already connected. Error code: 19(0x013).
AmsSyncWin32Error | 20 | AMS Sync Win32 error. Error code: 20(0x014).
SyncTimeOut | 21 | AMS Sync timeout. Error code: 21(0x015).
AmsSyncAmsError | 22 | AMS Sync AMS error Error code: 22(0x016).
AmsSyncNoIndexMap | 23 | AMS Sync no index map. Error code: 23(0x017).
InvalidAmsPort | 24 | Invalid AMS port. Error code: 24(0x018).
NoMemory | 25 | No memory. Error code: 25(0x019).
TCPSendError | 26 | TCP send error. Error code: 26(0x01A).
HostUnreachable | 27 | Host unreachable. Error code: 27(0x1B).
AmsInvalidFragment | 28 | Invalid AMS fragment. Error code: 28(0x1C).
NoLockedMemory | 1280 | Router: no locked memory. Error code: 1280(0x500).
ResizeMemory | 1281 | Router: The size of the router memory could not be changed. Error code: 1281(0x501).
MailboxFull | 1282 | Router: mailbox full. Error code: 1282(0x502).
DebugBoxFull | 1283 | Router: The mailbox has reached the maximum number of possible messages. Error code: 1283(0x503).
UnknownPortType | 1284 | Router: Unknown Port Type Error code: 1284(0x504).
RouterNotInitialized | 1285 | Router: Router is not initialized. Error code: 1285(0x505).
PortAlreadyInUse | 1286 | Router: The desired port number is already assigned. Error code: 1286(0x506).
PortNotRegistered | 1287 | Router: Port not registered. Error code: 1287(0x507).
NoMoreQueues | 1288 | Router: The maximum number of Ports reached. Error code: 1288(0x508).
InvalidPort | 1289 | Router: The port is invalid. Error code: 1289(0x509).
RouterNotActive | 1290 | Router: TwinCAT Router not active. Error code: 1290(0x50A).
DeviceError | 1792 | error class <device error"> Error code: 1792(0x700).
DeviceServiceNotSupported | 1793 | Service is not supported by server. Error code: 1793(0x701).
DeviceInvalidGroup | 1794 | Invalid index group. Error code: 1794(0x702).
DeviceInvalidOffset | 1795 | Invalid index offset. Error code: 1795(0x703).
DeviceInvalidAccess | 1796 | Reading/writing not permitted. Error code: 1796(0x704).
DeviceInvalidSize | 1797 | Parameter size not correct. Error code: 1797(0x705).
DeviceInvalidData | 1798 | Invalid parameter value(s). Error code: 1798(0x706).
DeviceNotReady | 1799 | Device is not in a ready state. Error code: 1799(0x707).
DeviceBusy | 1800 | Device is busy. Error code: 1800(0x708).
DeviceInvalidContext | 1801 | Invalid context (must be in Windows). Error code: 1801(0x709).
DeviceNoMemory | 1802 | Out of memory. Error code: 1802(0x70a).
DeviceInvalidParam | 1803 | Invalid parameter value(s). Error code: 1803(0x70b).
DeviceNotFound | 1804 | Not found(files, ...). Error code: 1804(0x70c).
DeviceSyntaxError | 1805 | Syntax error in command or file. Error code: 1805(0x70d).
DeviceIncompatible | 1806 | Objects do not match. Error code: 1806(0x70e).
DeviceExists | 1807 | Object already exists. Error code: 1807(0x70f).
DeviceSymbolNotFound | 1808 | Symbol not found. Error code: 1808(0x7010).
DeviceSymbolVersionInvalid | 1809 | Symbol version is invalid. Error code: 1809(0x711).
DeviceInvalidState | 1810 | Server is not i a valid state. Error code: 1810(0x712).
DeviceTransModeNotSupported | 1811 | ADS transmode is not supported. Error code: 1811(0x713).
DeviceNotifyHandleInvalid | 1812 | Notification handle is invalid. Error code: 1812(0x714).
DeviceClientUnknown | 1813 | Notification vlient not registered. Error code: 1813(0x715).
DeviceNoMoreHandles | 1814 | No more notification handles. Error code: 1814(0x716).
DeviceInvalidWatchsize | 1815 | Size for watch to big. Error code: 1815(0x717).
DeviceNotInitialized | 1816 | Device is not initialized. Errocr code: 1818(0x718).
DeviceTimeOut | 1817 | Devicee has a timeout. Error code: 1817(0x719).
DeviceNoInterface | 1818 | Query interface has failed. Error code: 1818(0x71A).
DeviceInvalidInterface | 1819 | Wrong interface required. Error code: 1819(0x71B).
DeviceInvalidCLSID | 1820 | Class ID is invalid. Error code: 1820(0x71C).
DeviceInvalidObjectID | 1821 | Object ID is invalid. Error code: 1821(0x71D).
DeviceRequestIsPending | 1822 | Device: Request is Pending. Error code: 1822(0x71E).
DeviceRequestIsAborted | 1823 | Device: Request is Aborted. Error code: 1823(0x71F).
DeviceSignalWarning | 1824 | Device: Signal warning. Error code: 1824(0x720).
DeviceInvalidArrayIndex | 1825 | Device: Invalid Array Index (ADSERR_DEVICE_INVALIDARRAYIDX) Error code: 1825(0x721).
DeviceSymbolNotActive | 1826 | Device: Symbol not Active Error code: 1826(0x722).
DeviceAccessDenied | 1827 | Device: Access denied. Error code: 1827(0x723).
DeviceLicenseNotFound | 1828 | Device: license not found Error code: 1828(0x724).
DeviceLicenseExpired | 1829 | Device: license expired Error code: 1829(0x725).
DeviceLicenseExceeded | 1830 | Device: license exceeded Error code: 1830(0x726).
DeviceLicenseInvalid | 1831 | Device: license invalid Error code: 1831(0x727).
DeviceLicenseSystemId | 1832 | Device: license invalid system id Error code: 1832(0x728).
DeviceLicenseNoTimeLimit | 1833 | Device: license not time limited Error code: 1833(0x729).
DeviceLicenseFutureIssue | 1834 | Device: license issue time in the future Error code: 1834(0x72A).
DeviceLicenseTimeToLong | 1835 | Device: license time period to long Error code: 1835(0x72B).
DeviceException | 1836 | Device: Exception in device specific code Error code: 1836(0x72C).
DeviceLicenseDuplicated | 1837 | Device: license file read twice Error code: 1837(0x72D).
DeviceSignatureInvalid | 1838 | Device: invalid signature Error code: 1838(0x72E).
DeviceCertificateInvalid | 1839 | Device: public key certificate Error code: 1839(0x72F).
DeviceLicenseOemNotFound | 1840 | Device: public key of OEM unknown Error code: 1840(0x730).
DeviceLicenseRestricted | 1841 | Device: license not valid for this system id type Error code: 1841(0x731).
DeviceLicenseDemoDenied | 1842 | Device: trial license denied Error code: 1842(0x732).
DeviceInvalidFncId | 1843 | Device: function id is invalid Error code: 1843(0x733).
DeviceOutOfRange | 1844 | Device: a parameter, an index, an iterator, ... is out of range Error code: 1844(0x734).
DeviceInvalidAlignment | 1845 | Device: invalid alignment Error code: 1845(0x735).
DeviceLicensePlatform | 1846 | Device: license invalid platform level Error code: 1846(0x736).
ClientError | 1856 | Error class <client error> Error code: 1856(0x740).
ClientInvalidParameter | 1857 | Parameter at service is invalid. Error code: 1857(0x741).
ClientListEmpty | 1858 | Polling list is empty. Error code: 1858(0x742).
ClientVariableInUse | 1859 | Variable connection is already in use. Error code: 1859(0x743).
ClientDuplicateInvokeID | 1860 | Invoke ID already in use. Error code: 1860(0x744).
ClientSyncTimeOut | 1861 | Timeout has elapsed. Error code: 1861(x745).
ClientW32OR | 1862 | Error in win32 subsystem. Error code: 1862(0x746).
ClientTimeoutInvalid | 1863 | Timeout value is invalid. Error code: 1863(0x747).
ClientPortNotOpen | 1864 | ADS port is not opened. Error code: 1864(0x748).
ClientNoAmsAddr | 1865 | No AMS Address. Error code: 1865(0x749).
ClientSyncInternal | 1872 | An internal in ADS sync has occurred. Error code: 1872(0x750).
ClientAddHash | 1873 | Hash table overflow. Error code: 1873(0x751).
ClientRemoveHash | 1874 | There are no more symbols in the hash table. Error code: 1874(0x752).
ClientNoMoreSymbols | 1875 | There are no more symbols in cache. Error code: 1875(0x753).
ClientSyncResInvalid | 1876 | An invalid response has been received. Error code: 1876(0x754).
ClientSyncPortLocked | 1877 | Sync port is locked. Error code: 1877(0x755).
ClientQueueFull | 32768 | Client queue is full
WSA_ConnRefused | 10061 | Windows sockets connection refused (0x274d, 10061)
Reference
TwinCAT.Ads Namespace


AdsErrorException Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class
AdsErrorException Class
The exception that is thrown when an ADS error occurs.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.Ads.AdsErrorException
TwinCAT.Ads.AdsSumCommandException
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class AdsErrorException : AdsException
VB
<SerializableAttribute>
Public Class AdsErrorException
Inherits AdsException
The AdsErrorException type exposes the following members.
Constructors
Name | Description
AdsErrorException. | Initializes a new Instance of the AdsErrorException class.
AdsErrorException(String, AdsErrorCode) | Initializes a new Instance of the AdsErrorException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets the error code of the Exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Create(AdsErrorCode) | Creates the AdsErrorException
Create(String, AdsErrorCode) | Creates the AdsErrorException
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsErrorException Constructor
•
AdsErrorException Properties
•
AdsErrorException Methods
•
AdsErrorException Events


AdsErrorException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class [image] AdsErrorException Constructor
AdsErrorException Constructor
Overload List
Name | Description
AdsErrorException. | Initializes a new Instance of the AdsErrorException class.
AdsErrorException(String, AdsErrorCode) | Initializes a new Instance of the AdsErrorException class.
Reference
AdsErrorException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsErrorException Constructor
•
AdsErrorException Constructor (String, AdsErrorCode)


AdsErrorException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class [image] AdsErrorException Constructor [image] AdsErrorException Constructor
AdsErrorException Constructor
Initializes a new Instance of the AdsErrorException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorException()
VB
Public Sub New
Reference
AdsErrorException Class
AdsErrorException Overload
TwinCAT.Ads Namespace


AdsErrorException Constructor (String, AdsErrorCode)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class [image] AdsErrorException Constructor [image] AdsErrorException Constructor (String, AdsErrorCode)
AdsErrorException Constructor (String, AdsErrorCode)
Initializes a new Instance of the AdsErrorException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorException(
string message,
AdsErrorCode errorCode
)
VB
Public Sub New (
message As String,
errorCode As AdsErrorCode
)
Parameters
message | Type: System.String The message.
errorCode | Type: TwinCAT.Ads.AdsErrorCode The error code.
Reference
AdsErrorException Class
AdsErrorException Overload
TwinCAT.Ads Namespace


AdsErrorException Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class [image] AdsErrorException Properties
AdsErrorException Properties
The AdsErrorException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets the error code of the Exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
AdsErrorException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsErrorException.ErrorCode Property


AdsErrorException.ErrorCode Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class [image] AdsErrorException Properties [image] AdsErrorException.ErrorCode Property
AdsErrorException.ErrorCode Property
Gets the error code of the Exception.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode ErrorCode { get; }
VB
Public ReadOnly Property ErrorCode As AdsErrorCode
Get
Property Value
Type: AdsErrorCode
The error code.
Reference
AdsErrorException Class
TwinCAT.Ads Namespace


AdsErrorException Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class [image] AdsErrorException Methods
AdsErrorException Methods
The AdsErrorException type exposes the following members.
Methods
Name | Description
Create(AdsErrorCode) | Creates the AdsErrorException
Create(String, AdsErrorCode) | Creates the AdsErrorException
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
AdsErrorException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsErrorException.Create Method
•
AdsErrorException.GetObjectData Method


AdsErrorException.Create Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class [image] AdsErrorException Methods [image] AdsErrorException.Create Method
AdsErrorException.Create Method
Overload List
Name | Description
Create(AdsErrorCode) | Creates the AdsErrorException
Create(String, AdsErrorCode) | Creates the AdsErrorException
Reference
AdsErrorException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsErrorException.Create Method (AdsErrorCode)
•
AdsErrorException.Create Method (String, AdsErrorCode)


AdsErrorException.Create Method (AdsErrorCode)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class [image] AdsErrorException Methods [image] AdsErrorException.Create Method [image] AdsErrorException.Create Method (AdsErrorCode)
AdsErrorException.Create Method (AdsErrorCode)
Creates the AdsErrorException
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static AdsErrorException Create(
AdsErrorCode adsErrorCode
)
VB
Public Shared Function Create (
adsErrorCode As AdsErrorCode
) As AdsErrorException
Parameters
adsErrorCode
Type: TwinCAT.Ads.AdsErrorCode
The ads error code.
Return Value
Type: AdsErrorException
AdsErrorException.
Reference
AdsErrorException Class
Create Overload
TwinCAT.Ads Namespace


AdsErrorException.Create Method (String, AdsErrorCode)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class [image] AdsErrorException Methods [image] AdsErrorException.Create Method [image] AdsErrorException.Create Method (String, AdsErrorCode)
AdsErrorException.Create Method (String, AdsErrorCode)
Creates the AdsErrorException
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static AdsErrorException Create(
string message,
AdsErrorCode adsErrorCode
)
VB
Public Shared Function Create (
message As String,
adsErrorCode As AdsErrorCode
) As AdsErrorException
Parameters
message | Type: System.String The message.
adsErrorCode | Type: TwinCAT.Ads.AdsErrorCode The ads error code.
Return Value
Type: AdsErrorException
AdsErrorException.
Reference
AdsErrorException Class
Create Overload
TwinCAT.Ads Namespace


AdsErrorException.GetObjectData Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class [image] AdsErrorException Methods [image] AdsErrorException.GetObjectData Method
AdsErrorException.GetObjectData Method
When overridden in a derived class, sets the SerializationInfo with information about the exception.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
VB
Public Overrides Sub GetObjectData (
info As SerializationInfo,
context As StreamingContext
)
Parameters
info | Type: System.Runtime.Serialization.SerializationInfo The SerializationInfo that holds the serialized object data about the exception being thrown.
context | Type: System.Runtime.Serialization.StreamingContext The StreamingContext that contains contextual information about the source or destination.
Implements
ISerializable.GetObjectData(SerializationInfo, StreamingContext)
_Exception.GetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info
Reference
AdsErrorException Class
TwinCAT.Ads Namespace


AdsErrorException Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsErrorException Class [image] AdsErrorException Events
AdsErrorException Events
The AdsErrorException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
AdsErrorException Class
TwinCAT.Ads Namespace


AdsException Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsException Class
AdsException Class
Base class for all exceptions thrown by this class.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
More...
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class AdsException : ApplicationException
VB
<SerializableAttribute>
Public Class AdsException
Inherits ApplicationException
The AdsException type exposes the following members.
Constructors
Name | Description
AdsException. | Initializes a new Instance of the AdsException class.
AdsException(String) | Initializes a new Instance of the AdsException class.
AdsException(String, Exception) | Initializes a new Instance of the AdsException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
TwinCAT.Ads Namespace
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.Ads.AdsDatatypeNotSupportedException
TwinCAT.Ads.AdsErrorException
TwinCAT.Ads.AdsInitializeException
TwinCAT.Ads.AdsInvalidNotificationException
TwinCAT.Ads.AdsSymbolException
TwinCAT.Ads.SymbolException
TwinCAT.ClientNotConnectedException
TwinCAT.SessionException
TwinCAT.TypeSystem.DataTypeException
TwinCAT.TypeSystem.MarshalException
Weiterführende Informationen
•
AdsException Constructor
•
AdsException Properties
•
AdsException Methods
•
AdsException Events


AdsException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsException Class [image] AdsException Constructor
AdsException Constructor
Overload List
Name | Description
AdsException. | Initializes a new Instance of the AdsException class.
AdsException(String) | Initializes a new Instance of the AdsException class.
AdsException(String, Exception) | Initializes a new Instance of the AdsException class.
Reference
AdsException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsException Constructor
•
AdsException Constructor (String)
•
AdsException Constructor (String, Exception)


AdsException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsException Class [image] AdsException Constructor [image] AdsException Constructor
AdsException Constructor
Initializes a new Instance of the AdsException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsException()
VB
Public Sub New
Reference
AdsException Class
AdsException Overload
TwinCAT.Ads Namespace


AdsException Constructor (String)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsException Class [image] AdsException Constructor [image] AdsException Constructor (String)
AdsException Constructor (String)
Initializes a new Instance of the AdsException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsException(
string message
)
VB
Public Sub New (
message As String
)
Parameters
message
Type: System.String
A message that describes the error.
Reference
AdsException Class
AdsException Overload
TwinCAT.Ads Namespace


AdsException Constructor (String, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsException Class [image] AdsException Constructor [image] AdsException Constructor (String, Exception)
AdsException Constructor (String, Exception)
Initializes a new Instance of the AdsException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsException(
string message,
Exception innerException
)
VB
Public Sub New (
message As String,
innerException As Exception
)
Parameters
message | Type: System.String The error message that explains the reason for the exception.
innerException | Type: System.Exception The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
Reference
AdsException Class
AdsException Overload
TwinCAT.Ads Namespace


AdsException Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsException Class [image] AdsException Properties
AdsException Properties
The AdsException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
AdsException Class
TwinCAT.Ads Namespace


AdsException Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsException Class [image] AdsException Methods
AdsException Methods
The AdsException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
AdsException Class
TwinCAT.Ads Namespace


AdsException Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsException Class [image] AdsException Events
AdsException Events
The AdsException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
AdsException Class
TwinCAT.Ads Namespace


AdsInitializeException Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInitializeException Class
AdsInitializeException Class
Initializing exception (TcAdsDllCe resp. TcAdsDll.dll not found)
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.Ads.AdsInitializeException
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class AdsInitializeException : AdsException
VB
<SerializableAttribute>
Public Class AdsInitializeException
Inherits AdsException
The AdsInitializeException type exposes the following members.
Constructors
Name | Description
AdsInitializeException(Exception) | Initializes a new instance of the AdsInitializeException class.
AdsInitializeException(String, Exception) | Initializes a new instance of the AdsInitializeException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsInitializeException Constructor
•
AdsInitializeException Properties
•
AdsInitializeException Methods
•
AdsInitializeException Events


AdsInitializeException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInitializeException Class [image] AdsInitializeException Constructor
AdsInitializeException Constructor
Overload List
Name | Description
AdsInitializeException(Exception) | Initializes a new instance of the AdsInitializeException class.
AdsInitializeException(String, Exception) | Initializes a new instance of the AdsInitializeException class.
Reference
AdsInitializeException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsInitializeException Constructor (Exception)
•
AdsInitializeException Constructor (String, Exception)


AdsInitializeException Constructor (Exception)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInitializeException Class [image] AdsInitializeException Constructor [image] AdsInitializeException Constructor (Exception)
AdsInitializeException Constructor (Exception)
Initializes a new instance of the AdsInitializeException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsInitializeException(
Exception inner
)
VB
Public Sub New (
inner As Exception
)
Parameters
inner
Type: System.Exception
The inner.
Reference
AdsInitializeException Class
AdsInitializeException Overload
TwinCAT.Ads Namespace


AdsInitializeException Constructor (String, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInitializeException Class [image] AdsInitializeException Constructor [image] AdsInitializeException Constructor (String, Exception)
AdsInitializeException Constructor (String, Exception)
Initializes a new instance of the AdsInitializeException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsInitializeException(
string message,
Exception inner
)
VB
Public Sub New (
message As String,
inner As Exception
)
Parameters
message | Type: System.String The message.
inner | Type: System.Exception The inner.
Reference
AdsInitializeException Class
AdsInitializeException Overload
TwinCAT.Ads Namespace


AdsInitializeException Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInitializeException Class [image] AdsInitializeException Properties
AdsInitializeException Properties
The AdsInitializeException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
AdsInitializeException Class
TwinCAT.Ads Namespace


AdsInitializeException Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInitializeException Class [image] AdsInitializeException Methods
AdsInitializeException Methods
The AdsInitializeException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
AdsInitializeException Class
TwinCAT.Ads Namespace


AdsInitializeException Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInitializeException Class [image] AdsInitializeException Events
AdsInitializeException Events
The AdsInitializeException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
AdsInitializeException Class
TwinCAT.Ads Namespace


AdsInvalidNotificationException Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInvalidNotificationException Class
AdsInvalidNotificationException Class
This AdsInvalidNotificationException is created if the length of the notification data is 0. This indicates that the notification handle is not valid any more. This exception is passed to the AdsNotificationErrorEvent.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.Ads.AdsInvalidNotificationException
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public sealed class AdsInvalidNotificationException : AdsException
VB
<SerializableAttribute>
Public NotInheritable Class AdsInvalidNotificationException
Inherits AdsException
The AdsInvalidNotificationException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Handle | Handle of the notification.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TimeStamp | Gets the Time stamp as long
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsInvalidNotificationException Properties
•
AdsInvalidNotificationException Methods


AdsInvalidNotificationException Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInvalidNotificationException Class [image] AdsInvalidNotificationException Properties
AdsInvalidNotificationException Properties
The AdsInvalidNotificationException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Handle | Handle of the notification.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TimeStamp | Gets the Time stamp as long
Reference
AdsInvalidNotificationException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsInvalidNotificationException.Handle Property
•
AdsInvalidNotificationException.TimeStamp Property


AdsInvalidNotificationException.Handle Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInvalidNotificationException Class [image] AdsInvalidNotificationException Properties [image] AdsInvalidNotificationException.Handle Property
AdsInvalidNotificationException.Handle Property
Handle of the notification.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Handle { get; }
VB
Public ReadOnly Property Handle As Integer
Get
Property Value
Type: Int32
The handle.
Reference
AdsInvalidNotificationException Class
TwinCAT.Ads Namespace


AdsInvalidNotificationException.TimeStamp Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInvalidNotificationException Class [image] AdsInvalidNotificationException Properties [image] AdsInvalidNotificationException.TimeStamp Property
AdsInvalidNotificationException.TimeStamp Property
Gets the Time stamp as long
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public long TimeStamp { get; }
VB
Public ReadOnly Property TimeStamp As Long
Get
Property Value
Type: Int64
The time stamp.
Reference
AdsInvalidNotificationException Class
TwinCAT.Ads Namespace


AdsInvalidNotificationException Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInvalidNotificationException Class [image] AdsInvalidNotificationException Methods
AdsInvalidNotificationException Methods
The AdsInvalidNotificationException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
AdsInvalidNotificationException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsInvalidNotificationException.GetObjectData Method


AdsInvalidNotificationException.GetObjectData Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsInvalidNotificationException Class [image] AdsInvalidNotificationException Methods [image] AdsInvalidNotificationException.GetObjectData Method
AdsInvalidNotificationException.GetObjectData Method
When overridden in a derived class, sets the SerializationInfo with information about the exception.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
VB
Public Overrides Sub GetObjectData (
info As SerializationInfo,
context As StreamingContext
)
Parameters
info | Type: System.Runtime.Serialization.SerializationInfo The SerializationInfo that holds the serialized object data about the exception being thrown.
context | Type: System.Runtime.Serialization.StreamingContext The StreamingContext that contains contextual information about the source or destination.
Implements
ISerializable.GetObjectData(SerializationInfo, StreamingContext)
_Exception.GetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info
Reference
AdsInvalidNotificationException Class
TwinCAT.Ads Namespace


AdsNotificationErrorEventArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationErrorEventArgs Class
AdsNotificationErrorEventArgs Class
Provides data for AdsNotificationErrorEvent of the class TcAdsClient.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.Ads.AdsNotificationErrorEventArgs
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class AdsNotificationErrorEventArgs : EventArgs
VB
Public NotInheritable Class AdsNotificationErrorEventArgs
Inherits EventArgs
The AdsNotificationErrorEventArgs type exposes the following members.
Constructors
Name | Description
AdsNotificationErrorEventArgs | Initializes a new instance of the AdsNotificationErrorEventArgs class.
Properties
Name | Description
Exception | Exception that was caught while handling notifications.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsNotificationErrorEventArgs Constructor
•
AdsNotificationErrorEventArgs Properties
•
AdsNotificationErrorEventArgs Methods


AdsNotificationErrorEventArgs Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationErrorEventArgs Class [image] AdsNotificationErrorEventArgs Constructor
AdsNotificationErrorEventArgs Constructor
Initializes a new instance of the AdsNotificationErrorEventArgs class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsNotificationErrorEventArgs(
Exception e
)
VB
Public Sub New (
e As Exception
)
Parameters
e
Type: System.Exception
Exception that was caught while handling notifications.
Reference
AdsNotificationErrorEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationErrorEventArgs Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationErrorEventArgs Class [image] AdsNotificationErrorEventArgs Properties
AdsNotificationErrorEventArgs Properties
The AdsNotificationErrorEventArgs type exposes the following members.
Properties
Name | Description
Exception | Exception that was caught while handling notifications.
Reference
AdsNotificationErrorEventArgs Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsNotificationErrorEventArgs.Exception Property


AdsNotificationErrorEventArgs.Exception Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationErrorEventArgs Class [image] AdsNotificationErrorEventArgs Properties [image] AdsNotificationErrorEventArgs.Exception Property
AdsNotificationErrorEventArgs.Exception Property
Exception that was caught while handling notifications.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Exception Exception { get; }
VB
Public ReadOnly Property Exception As Exception
Get
Property Value
Type: Exception
Reference
AdsNotificationErrorEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationErrorEventArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationErrorEventArgs Class [image] AdsNotificationErrorEventArgs Methods
AdsNotificationErrorEventArgs Methods
The AdsNotificationErrorEventArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AdsNotificationErrorEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationErrorEventHandler Delegate

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationErrorEventHandler Delegate
AdsNotificationErrorEventHandler Delegate
Event handler for the AdsNotificationError event in the class TcAdsClient.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public delegate void AdsNotificationErrorEventHandler(
Object sender,
AdsNotificationErrorEventArgs e
)
VB
Public Delegate Sub AdsNotificationErrorEventHandler (
sender As Object,
e As AdsNotificationErrorEventArgs
)
Parameters
sender | Type: System.Object
e | Type: TwinCAT.Ads.AdsNotificationErrorEventArgs
Reference
TwinCAT.Ads Namespace


AdsNotificationEventArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationEventArgs Class
AdsNotificationEventArgs Class
Provides data for AdsNotificationEvent of the class TcAdsClient.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.Ads.AdsNotificationEventArgs
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class AdsNotificationEventArgs : EventArgs
VB
Public NotInheritable Class AdsNotificationEventArgs
Inherits EventArgs
The AdsNotificationEventArgs type exposes the following members.
Constructors
Name | Description
AdsNotificationEventArgs | Initializes a new instance of the AdsStream class AdsSyncNotificationEventArgs.
Properties
Name | Description
DataStream | Streams that holds the notification data.
Length | Gets the Length of the data in the stream.
NotificationHandle | Gets the handle of the connection.
Offset | Gets the Offset of the data in the stream.
TimeStamp | Gets the timestamp of this Notification.
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsNotificationEventArgs Constructor
•
AdsNotificationEventArgs Properties
•
AdsNotificationEventArgs Methods


AdsNotificationEventArgs Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationEventArgs Class [image] AdsNotificationEventArgs Constructor
AdsNotificationEventArgs Constructor
Initializes a new instance of the AdsStream class AdsSyncNotificationEventArgs.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsNotificationEventArgs(
long timeStamp,
Object userData,
int notificationHandle,
int length,
int offset,
AdsStream dataStream
)
VB
Public Sub New (
timeStamp As Long,
userData As Object,
notificationHandle As Integer,
length As Integer,
offset As Integer,
dataStream As AdsStream
)
Parameters
timeStamp | Type: System.Int64 TwinCAT realtime timestamp.
userData | Type: System.Object An object, that is passed by AddDeviceNotification.
notificationHandle | Type: System.Int32 Handle of the connection.
length | Type: System.Int32 Length of the data in dataStream.
offset | Type: System.Int32 The offset of the data in dataStream .
dataStream | Type: TwinCAT.Ads.AdsStream Stream that is used to store the data.
Remarks
The TwinCAT realtime target system (even when working locally) has its own TimeSystem which is synchronized with the Desktop/User time at TwinCAT Start. From this moment on the Desktop/User time can drift from the local Realtime/Target time. can differ. The TimeStamp can be converted to a .NET DateTime Object with FromFileTimeUtc(Int64) or FromFileTime(Int64)
Reference
AdsNotificationEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationEventArgs Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationEventArgs Class [image] AdsNotificationEventArgs Properties
AdsNotificationEventArgs Properties
The AdsNotificationEventArgs type exposes the following members.
Properties
Name | Description
DataStream | Streams that holds the notification data.
Length | Gets the Length of the data in the stream.
NotificationHandle | Gets the handle of the connection.
Offset | Gets the Offset of the data in the stream.
TimeStamp | Gets the timestamp of this Notification.
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data.
Reference
AdsNotificationEventArgs Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsNotificationEventArgs.DataStream Property
•
AdsNotificationEventArgs.Length Property
•
AdsNotificationEventArgs.NotificationHandle Property
•
AdsNotificationEventArgs.Offset Property
•
AdsNotificationEventArgs.TimeStamp Property
•
AdsNotificationEventArgs.UserData Property


AdsNotificationEventArgs.DataStream Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationEventArgs Class [image] AdsNotificationEventArgs Properties [image] AdsNotificationEventArgs.DataStream Property
AdsNotificationEventArgs.DataStream Property
Streams that holds the notification data.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsStream DataStream { get; }
VB
Public ReadOnly Property DataStream As AdsStream
Get
Property Value
Type: AdsStream
Reference
AdsNotificationEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationEventArgs.Length Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationEventArgs Class [image] AdsNotificationEventArgs Properties [image] AdsNotificationEventArgs.Length Property
AdsNotificationEventArgs.Length Property
Gets the Length of the data in the stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Length { get; }
VB
Public ReadOnly Property Length As Integer
Get
Property Value
Type: Int32
Reference
AdsNotificationEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationEventArgs.NotificationHandle Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationEventArgs Class [image] AdsNotificationEventArgs Properties [image] AdsNotificationEventArgs.NotificationHandle Property
AdsNotificationEventArgs.NotificationHandle Property
Gets the handle of the connection.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int NotificationHandle { get; }
VB
Public ReadOnly Property NotificationHandle As Integer
Get
Property Value
Type: Int32
Reference
AdsNotificationEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationEventArgs.Offset Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationEventArgs Class [image] AdsNotificationEventArgs Properties [image] AdsNotificationEventArgs.Offset Property
AdsNotificationEventArgs.Offset Property
Gets the Offset of the data in the stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Offset { get; }
VB
Public ReadOnly Property Offset As Integer
Get
Property Value
Type: Int32
Reference
AdsNotificationEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationEventArgs.TimeStamp Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationEventArgs Class [image] AdsNotificationEventArgs Properties [image] AdsNotificationEventArgs.TimeStamp Property
AdsNotificationEventArgs.TimeStamp Property
Gets the timestamp of this Notification.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public long TimeStamp { get; }
VB
Public ReadOnly Property TimeStamp As Long
Get
Property Value
Type: Int64
Reference
AdsNotificationEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationEventArgs.UserData Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationEventArgs Class [image] AdsNotificationEventArgs Properties [image] AdsNotificationEventArgs.UserData Property
AdsNotificationEventArgs.UserData Property
Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object UserData { get; }
VB
Public ReadOnly Property UserData As Object
Get
Property Value
Type: Object
Reference
AdsNotificationEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationEventArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationEventArgs Class [image] AdsNotificationEventArgs Methods
AdsNotificationEventArgs Methods
The AdsNotificationEventArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AdsNotificationEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationEventHandler Delegate

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationEventHandler Delegate
AdsNotificationEventHandler Delegate
Event handler for the AdsNotification event in the class TcAdsClient.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public delegate void AdsNotificationEventHandler(
Object sender,
AdsNotificationEventArgs e
)
VB
Public Delegate Sub AdsNotificationEventHandler (
sender As Object,
e As AdsNotificationEventArgs
)
Parameters
sender | Type: System.Object
e | Type: TwinCAT.Ads.AdsNotificationEventArgs
Reference
TwinCAT.Ads Namespace


AdsNotificationExEventArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationExEventArgs Class
AdsNotificationExEventArgs Class
Provides data for AdsNotificationExEvent of the class TcAdsClient.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.Ads.AdsNotificationExEventArgs
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class AdsNotificationExEventArgs : EventArgs
VB
Public NotInheritable Class AdsNotificationExEventArgs
Inherits EventArgs
The AdsNotificationExEventArgs type exposes the following members.
Constructors
Name | Description
AdsNotificationExEventArgs | Initializes a new instance of the AdsStream class AdsSyncNotificationEventArgs.
Properties
Name | Description
NotificationHandle | Gets the handle of the connection.
TimeStamp | Gets the timestamp.
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data.
Value | Value of the ads variable.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsNotificationExEventArgs Constructor
•
AdsNotificationExEventArgs Properties
•
AdsNotificationExEventArgs Methods


AdsNotificationExEventArgs Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationExEventArgs Class [image] AdsNotificationExEventArgs Constructor
AdsNotificationExEventArgs Constructor
Initializes a new instance of the AdsStream class AdsSyncNotificationEventArgs.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsNotificationExEventArgs(
long timeStamp,
Object userData,
int notificationHandle,
Object value
)
VB
Public Sub New (
timeStamp As Long,
userData As Object,
notificationHandle As Integer,
value As Object
)
Parameters
timeStamp | Type: System.Int64 Timestamp.
userData | Type: System.Object An object, that is passed by AddDeviceNotificationEx.
notificationHandle | Type: System.Int32 Handle of the connection.
value | Type: System.Object Value of the ADS variable.
Reference
AdsNotificationExEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationExEventArgs Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationExEventArgs Class [image] AdsNotificationExEventArgs Properties
AdsNotificationExEventArgs Properties
The AdsNotificationExEventArgs type exposes the following members.
Properties
Name | Description
NotificationHandle | Gets the handle of the connection.
TimeStamp | Gets the timestamp.
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data.
Value | Value of the ads variable.
Reference
AdsNotificationExEventArgs Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsNotificationExEventArgs.NotificationHandle Property
•
AdsNotificationExEventArgs.TimeStamp Property
•
AdsNotificationExEventArgs.UserData Property
•
AdsNotificationExEventArgs.Value Property


AdsNotificationExEventArgs.NotificationHandle Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationExEventArgs Class [image] AdsNotificationExEventArgs Properties [image] AdsNotificationExEventArgs.NotificationHandle Property
AdsNotificationExEventArgs.NotificationHandle Property
Gets the handle of the connection.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int NotificationHandle { get; }
VB
Public ReadOnly Property NotificationHandle As Integer
Get
Property Value
Type: Int32
Reference
AdsNotificationExEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationExEventArgs.TimeStamp Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationExEventArgs Class [image] AdsNotificationExEventArgs Properties [image] AdsNotificationExEventArgs.TimeStamp Property
AdsNotificationExEventArgs.TimeStamp Property
Gets the timestamp.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public long TimeStamp { get; }
VB
Public ReadOnly Property TimeStamp As Long
Get
Property Value
Type: Int64
Reference
AdsNotificationExEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationExEventArgs.UserData Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationExEventArgs Class [image] AdsNotificationExEventArgs Properties [image] AdsNotificationExEventArgs.UserData Property
AdsNotificationExEventArgs.UserData Property
Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object UserData { get; }
VB
Public ReadOnly Property UserData As Object
Get
Property Value
Type: Object
Reference
AdsNotificationExEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationExEventArgs.Value Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationExEventArgs Class [image] AdsNotificationExEventArgs Properties [image] AdsNotificationExEventArgs.Value Property
AdsNotificationExEventArgs.Value Property
Value of the ads variable.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object Value { get; }
VB
Public ReadOnly Property Value As Object
Get
Property Value
Type: Object
Reference
AdsNotificationExEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationExEventArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationExEventArgs Class [image] AdsNotificationExEventArgs Methods
AdsNotificationExEventArgs Methods
The AdsNotificationExEventArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AdsNotificationExEventArgs Class
TwinCAT.Ads Namespace


AdsNotificationExEventHandler Delegate

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsNotificationExEventHandler Delegate
AdsNotificationExEventHandler Delegate
Event handler for the AdsNotification event in the class TcAdsClient.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public delegate void AdsNotificationExEventHandler(
Object sender,
AdsNotificationExEventArgs e
)
VB
Public Delegate Sub AdsNotificationExEventHandler (
sender As Object,
e As AdsNotificationExEventArgs
)
Parameters
sender | Type: System.Object
e | Type: TwinCAT.Ads.AdsNotificationExEventArgs
Reference
TwinCAT.Ads Namespace


AdsSession Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class
AdsSession Class
AdsSession class
Inheritance Hierarchy
System.Object
TwinCAT.Session
TwinCAT.Ads.AdsSession
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class AdsSession : Session, IAdsSession,
ISession, IConnectionStateProvider
VB
Public Class AdsSession
Inherits Session
Implements IAdsSession, ISession, IConnectionStateProvider
The AdsSession type exposes the following members.
Constructors
Name | Description
AdsSession(AmsAddress) | Initializes a new instance of the AdsSession class.
AdsSession(AmsAddress, SessionSettings) | Initializes a new instance of the AdsSession class.
AdsSession(AmsNetId, Int32) | Initializes a new instance of the AdsSession class.
AdsSession(AmsAddress, SessionSettings, Object) | Initializes a new instance of the AdsSession class.
AdsSession(AmsNetId, Int32, SessionSettings) | Initializes a new instance of the AdsSession class.
Properties
Name | Description
Address | Gets the target address of the AdsSession
AddressSpecifier | Gets the communication endpoint address string representation. (Inherited from Session.)
Connection | Gets the connection.
ConnectionState | Gets the current Connection state of the Session (Inherited from Session.)
Disposed | Gets a value indicating whether this Session is disposed. (Inherited from Session.)
EstablishedAt | Gets the UTC time when the session was established. (Inherited from Session.)
Id | Gets the Session Identifier (Inherited from Session.)
IsConnected | Gets a value indicating whether this instance is connected. (Inherited from Session.)
Name | Gets the name of the session (Inherited from Session.)
NetId | Gets the NetId of the Session
Owner | Gets the Session owner.
Port | Gets the Ams Port of the Session
Settings | Gets the settings of the connection.
Statistics | Gets the Communication / Session statistics.
SymbolServer | Gets the symbol server. (Inherited from Session.)
Methods
Name | Description
Close | Closes this ISession (Inherited from Session.)
Connect | Connects the session. (Inherited from Session.)
Disconnect | Disconnects the session from the target. (Inherited from Session.)
Dispose. | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Session.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Overrides Session.Dispose(Boolean).)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Finalizes an instance of the AdsSession class. (Overrides Object.Finalize..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetSessionName | Gets the name/string identifier of the session. (Overrides Session.GetSessionName..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnConnect | Handler function connecting the Session. (Overrides Session.OnConnect(Boolean).)
OnCreateSymbolServer | Handler function creating the symbol server object. (Overrides Session.OnCreateSymbolServer..)
OnDisconnect | Called when [disconnect]. (Overrides Session.OnDisconnect..)
OnGetAddress | Handler function getting the address of the session. (Overrides Session.OnGetAddress..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed. (Inherited from Session.)
Fields
Name | Description
connection | The (established) connection (Inherited from Session.)
Remarks
On top of the well known TcAdsClient class that is used traditionally for ADS communication, the AdsSession class provides the following additionally abilities out of the box: These are used to provide more stable connections to ADS Servers than the TcAdsClient can provide. The main issues are Resurrection / Self-Healing after communication timeouts, faster and less error prone reaction to communication errors (not necessarily waiting for communication timeouts) und enhanced communication diagnosis. These enhanced features are provided by the following additions to the TwinCAT.Ads API:
▪
AdsConnection class.
▪
Enhanced diagnosis in form of communication statistics Statistics
▪
(semi-automatic) Resurrectable client communication with AdsConnection objects.
▪
Symbol caching SymbolServer
▪
Fail fast handler for connection stabilization IFailFastHandler
The AdsConnection is established by calling the Connect. method. The returned AdsConnection can be used as long the AdsSession exists.
Examples
The following sample shows a simple use of the AdsSession object. The AdsSession object (and the dynamic SymbolLoader features) are only available from .NET 4 and upwards.
Use of the AdsSession object
using System;
using System.Diagnostics;
using System.Threading;

using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.Ads.TypeSystem;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

namespace Sample
{
class Session
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
AmsAddress address = ArgParser.Parse(args);
SessionSettings settings = SessionSettings.Default; // Default settings are Async access with Timeout 5 sec

// Async access is necessary for Console applications!

using (AdsSession session = new AdsSession(address, settings))
{
AdsConnection connection = (AdsConnection) session.Connect(); // Establish the connection
connection.ConnectionStateChanged += Connection_ConnectionStateChanged;

ConnectionState connectionState = connection.ConnectionState; // The actual connection state

// Read the identification and version number of the device
DeviceInfo deviceInfo = connection.ReadDeviceInfo();
Version version = deviceInfo.Version.ConvertToStandard();
Console.WriteLine(string.Format("DeviceName: {0}", deviceInfo.Name));
Console.WriteLine(string.Format("DeviceVersion: {0}", version.ToString(3)));

/// Read the state of the device
StateInfo stateInfo = connection.ReadState();
AdsState adsState = stateInfo.AdsState;

short deviceState = stateInfo.DeviceState;
Console.WriteLine(string.Format("DeviceState: {0}", deviceState));
Console.WriteLine(string.Format("AdsState : {0}", adsState));

// Other ADS methods (as formerly used on TcAdsClient) can be used also on connection object:

// connection.Read(...)
// connection.Write(...)
// connection.AddDeviceNotificationEx += ...

// Session communication Diagnostic:

int resurrectionTries = connection.ResurrectingTries;
int succeededResurrections = connection.Resurrections;

AdsCommunicationStatistics statistics = session.Statistics; // The communication statistics

// Symbol access:
// The Session holds and Caches the Symbolic data information
ReadOnlyDataTypeCollection types = session.SymbolServer.DataTypes;
ReadOnlySymbolCollection symbols = session.SymbolServer.Symbols;

dynamic projectNameSymbol = symbols["TwinCAT_SystemInfoVarList._AppInfo.ProjectName"];
string projectName = (string) projectNameSymbol.ReadValue();

// Or use dynamic objects
dynamic appInfo = symbols["TwinCAT_SystemInfoVarList._AppInfo"];
string projectName2 = appInfo.ProjectName.ReadValue();

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
}

private static void Connection_ConnectionStateChanged(object sender, ConnectionStateChangedEventArgs e)
{
Console.WriteLine("Connection State changed (NewState: {0}, OldState: {1}",e.NewState,e.OldState);
}
Reference
TwinCAT.Ads Namespace
TwinCAT.Session
TwinCAT.Ads.IAdsSession
IInterceptionFactory
Weiterführende Informationen
•
AdsSession Constructor
•
AdsSession Properties
•
AdsSession Methods
•
AdsSession Events
•
AdsSession Fields


AdsSession Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Constructor
AdsSession Constructor
Overload List
Name | Description
AdsSession(AmsAddress) | Initializes a new instance of the AdsSession class.
AdsSession(AmsAddress, SessionSettings) | Initializes a new instance of the AdsSession class.
AdsSession(AmsNetId, Int32) | Initializes a new instance of the AdsSession class.
AdsSession(AmsAddress, SessionSettings, Object) | Initializes a new instance of the AdsSession class.
AdsSession(AmsNetId, Int32, SessionSettings) | Initializes a new instance of the AdsSession class.
Reference
AdsSession Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSession Constructor (AmsAddress)
•
AdsSession Constructor (AmsAddress, SessionSettings)
•
AdsSession Constructor (AmsNetId, Int32)
•
AdsSession Constructor (AmsAddress, SessionSettings, Object)
•
AdsSession Constructor (AmsNetId, Int32, SessionSettings)


AdsSession Constructor (AmsAddress)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Constructor [image] AdsSession Constructor (AmsAddress)
AdsSession Constructor (AmsAddress)
Initializes a new instance of the AdsSession class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSession(
AmsAddress address
)
VB
Public Sub New (
address As AmsAddress
)
Parameters
address
Type: TwinCAT.Ads.AmsAddress
The address.
Reference
AdsSession Class
AdsSession Overload
TwinCAT.Ads Namespace


AdsSession Constructor (AmsAddress, SessionSettings)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Constructor [image] AdsSession Constructor (AmsAddress, SessionSettings)
AdsSession Constructor (AmsAddress, SessionSettings)
Initializes a new instance of the AdsSession class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSession(
AmsAddress address,
SessionSettings settings
)
VB
Public Sub New (
address As AmsAddress,
settings As SessionSettings
)
Parameters
address | Type: TwinCAT.Ads.AmsAddress The address.
settings | Type: TwinCAT.Ads.SessionSettings The settings.
Reference
AdsSession Class
AdsSession Overload
TwinCAT.Ads Namespace


AdsSession Constructor (AmsNetId, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Constructor [image] AdsSession Constructor (AmsNetId, Int32)
AdsSession Constructor (AmsNetId, Int32)
Initializes a new instance of the AdsSession class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSession(
AmsNetId netId,
int port
)
VB
Public Sub New (
netId As AmsNetId,
port As Integer
)
Parameters
netId | Type: TwinCAT.Ads.AmsNetId The net identifier.
port | Type: System.Int32 The port.
Reference
AdsSession Class
AdsSession Overload
TwinCAT.Ads Namespace


AdsSession Constructor (AmsAddress, SessionSettings, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Constructor [image] AdsSession Constructor (AmsAddress, SessionSettings, Object)
AdsSession Constructor (AmsAddress, SessionSettings, Object)
Initializes a new instance of the AdsSession class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSession(
AmsAddress address,
SessionSettings settings,
Object owner
)
VB
Public Sub New (
address As AmsAddress,
settings As SessionSettings,
owner As Object
)
Parameters
address | Type: TwinCAT.Ads.AmsAddress The address.
settings | Type: TwinCAT.Ads.SessionSettings The settings.
owner | Type: System.Object The session owner
Reference
AdsSession Class
AdsSession Overload
TwinCAT.Ads Namespace


AdsSession Constructor (AmsNetId, Int32, SessionSettings)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Constructor [image] AdsSession Constructor (AmsNetId, Int32, SessionSettings)
AdsSession Constructor (AmsNetId, Int32, SessionSettings)
Initializes a new instance of the AdsSession class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSession(
AmsNetId netId,
int port,
SessionSettings settings
)
VB
Public Sub New (
netId As AmsNetId,
port As Integer,
settings As SessionSettings
)
Parameters
netId | Type: TwinCAT.Ads.AmsNetId The net identifier.
port | Type: System.Int32 The port.
settings | Type: TwinCAT.Ads.SessionSettings The settings.
Reference
AdsSession Class
AdsSession Overload
TwinCAT.Ads Namespace


AdsSession Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Properties
AdsSession Properties
The AdsSession type exposes the following members.
Properties
Name | Description
Address | Gets the target address of the AdsSession
AddressSpecifier | Gets the communication endpoint address string representation. (Inherited from Session.)
Connection | Gets the connection.
ConnectionState | Gets the current Connection state of the Session (Inherited from Session.)
Disposed | Gets a value indicating whether this Session is disposed. (Inherited from Session.)
EstablishedAt | Gets the UTC time when the session was established. (Inherited from Session.)
Id | Gets the Session Identifier (Inherited from Session.)
IsConnected | Gets a value indicating whether this instance is connected. (Inherited from Session.)
Name | Gets the name of the session (Inherited from Session.)
NetId | Gets the NetId of the Session
Owner | Gets the Session owner.
Port | Gets the Ams Port of the Session
Settings | Gets the settings of the connection.
Statistics | Gets the Communication / Session statistics.
SymbolServer | Gets the symbol server. (Inherited from Session.)
Reference
AdsSession Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSession.Address Property
•
AdsSession.Connection Property
•
AdsSession.NetId Property
•
AdsSession.Owner Property
•
AdsSession.Port Property
•
AdsSession.Settings Property
•
AdsSession.Statistics Property


AdsSession.Address Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Properties [image] AdsSession.Address Property
AdsSession.Address Property
Gets the target address of the AdsSession
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress Address { get; }
VB
Public ReadOnly Property Address As AmsAddress
Get
Property Value
Type: AmsAddress
The address.
Implements
IAdsSession.Address
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession.Connection Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Properties [image] AdsSession.Connection Property
AdsSession.Connection Property
Gets the connection.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsConnection Connection { get; }
VB
Public ReadOnly Property Connection As AdsConnection
Get
Property Value
Type: AdsConnection
The connection.
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession.NetId Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Properties [image] AdsSession.NetId Property
AdsSession.NetId Property
Gets the NetId of the Session
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsNetId NetId { get; }
VB
Public ReadOnly Property NetId As AmsNetId
Get
Property Value
Type: AmsNetId
The net identifier.
Implements
IAdsSession.NetId
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession.Owner Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Properties [image] AdsSession.Owner Property
AdsSession.Owner Property
Gets the Session owner.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object Owner { get; }
VB
Public ReadOnly Property Owner As Object
Get
Property Value
Type: Object
The owner or NULL
Implements
IAdsSession.Owner
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession.Port Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Properties [image] AdsSession.Port Property
AdsSession.Port Property
Gets the Ams Port of the Session
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Port { get; }
VB
Public ReadOnly Property Port As Integer
Get
Property Value
Type: Int32
The port.
Implements
IAdsSession.Port
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession.Settings Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Properties [image] AdsSession.Settings Property
AdsSession.Settings Property
Gets the settings of the connection.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SessionSettings Settings { get; }
VB
Public ReadOnly Property Settings As SessionSettings
Get
Property Value
Type: SessionSettings
The settings.
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession.Statistics Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Properties [image] AdsSession.Statistics Property
AdsSession.Statistics Property
Gets the Communication / Session statistics.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsCommunicationStatistics Statistics { get; }
VB
Public ReadOnly Property Statistics As AdsCommunicationStatistics
Get
Property Value
Type: AdsCommunicationStatistics
The communication / Session statistics.
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Methods
AdsSession Methods
The AdsSession type exposes the following members.
Methods
Name | Description
Close | Closes this ISession (Inherited from Session.)
Connect | Connects the session. (Inherited from Session.)
Disconnect | Disconnects the session from the target. (Inherited from Session.)
Dispose. | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Session.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Overrides Session.Dispose(Boolean).)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Finalizes an instance of the AdsSession class. (Overrides Object.Finalize..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetSessionName | Gets the name/string identifier of the session. (Overrides Session.GetSessionName..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnConnect | Handler function connecting the Session. (Overrides Session.OnConnect(Boolean).)
OnCreateSymbolServer | Handler function creating the symbol server object. (Overrides Session.OnCreateSymbolServer..)
OnDisconnect | Called when [disconnect]. (Overrides Session.OnDisconnect..)
OnGetAddress | Handler function getting the address of the session. (Overrides Session.OnGetAddress..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AdsSession Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSession.Dispose Method
•
AdsSession.Finalize Method
•
AdsSession.GetSessionName Method
•
AdsSession.OnConnect Method
•
AdsSession.OnCreateSymbolServer Method
•
AdsSession.OnDisconnect Method
•
AdsSession.OnGetAddress Method


AdsSession.Dispose Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Methods [image] AdsSession.Dispose Method
AdsSession.Dispose Method
Overload List
Name | Description
Dispose. | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Session.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Overrides Session.Dispose(Boolean).)
Reference
AdsSession Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSession.Dispose Method (Boolean)


AdsSession.Dispose Method (Boolean)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Methods [image] AdsSession.Dispose Method [image] AdsSession.Dispose Method (Boolean)
AdsSession.Dispose Method (Boolean)
Releases unmanaged and - optionally - managed resources.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected override void Dispose(
bool disposing
)
VB
Protected Overrides Sub Dispose (
disposing As Boolean
)
Parameters
disposing
Type: System.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Reference
AdsSession Class
Dispose Overload
TwinCAT.Ads Namespace


AdsSession.Finalize Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Methods [image] AdsSession.Finalize Method
AdsSession.Finalize Method
Finalizes an instance of the AdsSession class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected override void Finalize()
VB
Protected Overrides Sub Finalize
Implements
Object.Finalize.
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession.GetSessionName Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Methods [image] AdsSession.GetSessionName Method
AdsSession.GetSessionName Method
Gets the name/string identifier of the session.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected override string GetSessionName()
VB
Protected Overrides Function GetSessionName As String
Return Value
Type: String
System.String.
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession.OnConnect Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Methods [image] AdsSession.OnConnect Method
AdsSession.OnConnect Method
Handler function connecting the Session.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected override IConnection OnConnect(
bool reconnect
)
VB
Protected Overrides Function OnConnect (
reconnect As Boolean
) As IConnection
Parameters
reconnect
Type: System.Boolean
Return Value
Type: IConnection
IConnection.
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession.OnCreateSymbolServer Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Methods [image] AdsSession.OnCreateSymbolServer Method
AdsSession.OnCreateSymbolServer Method
Handler function creating the symbol server object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected override ISymbolServer OnCreateSymbolServer()
VB
Protected Overrides Function OnCreateSymbolServer As ISymbolServer
Return Value
Type: ISymbolServer
ISymbolServer.
Exceptions
Exception | Condition
SessionNotConnectedException | The connection is not established!
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession.OnDisconnect Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Methods [image] AdsSession.OnDisconnect Method
AdsSession.OnDisconnect Method
Called when [disconnect].
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected override bool OnDisconnect()
VB
Protected Overrides Function OnDisconnect As Boolean
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession.OnGetAddress Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Methods [image] AdsSession.OnGetAddress Method
AdsSession.OnGetAddress Method
Handler function getting the address of the session.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected override string OnGetAddress()
VB
Protected Overrides Function OnGetAddress As String
Return Value
Type: String
System.String.
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Events
AdsSession Events
The AdsSession type exposes the following members.
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed. (Inherited from Session.)
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsSession Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSession Class [image] AdsSession Fields
AdsSession Fields
The AdsSession type exposes the following members.
Fields
Name | Description
connection | The (established) connection (Inherited from Session.)
Reference
AdsSession Class
TwinCAT.Ads Namespace


AdsState Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsState Enumeration
AdsState Enumeration
Describes the AdsState.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum AdsState
VB
Public Enumeration AdsState
Members
Member name | Value | Description
Invalid | 0 | Invalid
Idle | 1 | Idle
Reset | 2 | Reset
Init | 3 | Initialize
Start | 4 | Start
Run | 5 | Run
Stop | 6 | Stop
SaveConfig | 7 | Save Configuration
LoadConfig | 8 | Load Configuration
PowerFailure | 9 | Power failure
PowerGood | 10 | Power Good
Error | 11 | Error
Shutdown | 12 | Shutdown
Suspend | 13 | Suspend
Resume | 14 | Resume
Config | 15 | Config (System is in config mode)
Reconfig | 16 | Reconfig (System should restart in config mode)
Stopping | 17 | Stopping
Incompatible | 18 | Incompatible
Exception | 19 | Exception
Reference
TwinCAT.Ads Namespace


AdsStateChangedEventArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs Class
AdsStateChangedEventArgs Class
Provides data for AdsStateChangedEvent of the class TcAdsClient.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.Ads.AdsStateChangedEventArgs
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class AdsStateChangedEventArgs : EventArgs
VB
Public NotInheritable Class AdsStateChangedEventArgs
Inherits EventArgs
The AdsStateChangedEventArgs type exposes the following members.
Constructors
Name | Description
AdsStateChangedEventArgs(AdsStateChangedEventArgs) | Initializes a new instance of the AdsStateChangedEventArgs class.
AdsStateChangedEventArgs(StateInfo) | Initializes a new instance of the AdsStateChangedEventArgs class.
Properties
Name | Description
State | Current state of the ADS device.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsStateChangedEventArgs Constructor
•
AdsStateChangedEventArgs Properties
•
AdsStateChangedEventArgs Methods


AdsStateChangedEventArgs Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs Class [image] AdsStateChangedEventArgs Constructor
AdsStateChangedEventArgs Constructor
Overload List
Name | Description
AdsStateChangedEventArgs(AdsStateChangedEventArgs) | Initializes a new instance of the AdsStateChangedEventArgs class.
AdsStateChangedEventArgs(StateInfo) | Initializes a new instance of the AdsStateChangedEventArgs class.
Reference
AdsStateChangedEventArgs Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsStateChangedEventArgs Constructor (AdsStateChangedEventArgs)
•
AdsStateChangedEventArgs Constructor (StateInfo)


AdsStateChangedEventArgs Constructor (AdsStateChangedEventArgs)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs Class [image] AdsStateChangedEventArgs Constructor [image] AdsStateChangedEventArgs Constructor (AdsStateChangedEventArgs)
AdsStateChangedEventArgs Constructor (AdsStateChangedEventArgs)
Initializes a new instance of the AdsStateChangedEventArgs class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsStateChangedEventArgs(
AdsStateChangedEventArgs eventArgs
)
VB
Public Sub New (
eventArgs As AdsStateChangedEventArgs
)
Parameters
eventArgs
Type: TwinCAT.Ads.AdsStateChangedEventArgs
The AdsStateChangedEventArgs instance containing the event data.
Reference
AdsStateChangedEventArgs Class
AdsStateChangedEventArgs Overload
TwinCAT.Ads Namespace


AdsStateChangedEventArgs Constructor (StateInfo)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs Class [image] AdsStateChangedEventArgs Constructor [image] AdsStateChangedEventArgs Constructor (StateInfo)
AdsStateChangedEventArgs Constructor (StateInfo)
Initializes a new instance of the AdsStateChangedEventArgs class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsStateChangedEventArgs(
StateInfo state
)
VB
Public Sub New (
state As StateInfo
)
Parameters
state
Type: TwinCAT.Ads.StateInfo
Current state of the ADS device.
Reference
AdsStateChangedEventArgs Class
AdsStateChangedEventArgs Overload
TwinCAT.Ads Namespace


AdsStateChangedEventArgs Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs Class [image] AdsStateChangedEventArgs Properties
AdsStateChangedEventArgs Properties
The AdsStateChangedEventArgs type exposes the following members.
Properties
Name | Description
State | Current state of the ADS device.
Reference
AdsStateChangedEventArgs Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsStateChangedEventArgs.State Property


AdsStateChangedEventArgs.State Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs Class [image] AdsStateChangedEventArgs Properties [image] AdsStateChangedEventArgs.State Property
AdsStateChangedEventArgs.State Property
Current state of the ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public StateInfo State { get; }
VB
Public ReadOnly Property State As StateInfo
Get
Property Value
Type: StateInfo
The state.
Reference
AdsStateChangedEventArgs Class
TwinCAT.Ads Namespace


AdsStateChangedEventArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs Class [image] AdsStateChangedEventArgs Methods
AdsStateChangedEventArgs Methods
The AdsStateChangedEventArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AdsStateChangedEventArgs Class
TwinCAT.Ads Namespace


AdsStateChangedEventArgs2 Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs2 Class
AdsStateChangedEventArgs2 Class
Event Arguments for AdsStateChanged events.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.Ads.AdsStateChangedEventArgs2
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class AdsStateChangedEventArgs2 : EventArgs
VB
Public NotInheritable Class AdsStateChangedEventArgs2
Inherits EventArgs
The AdsStateChangedEventArgs2 type exposes the following members.
Constructors
Name | Description
AdsStateChangedEventArgs2 | Initializes a new instance of the AdsStateChangedEventArgs2 class.
Properties
Name | Description
Connection | Gets the connection.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
NewState | The new state
OldState | The old state
Session | The session
Reference
TwinCAT.Ads Namespace
System.EventArgs
Weiterführende Informationen
•
AdsStateChangedEventArgs2 Constructor
•
AdsStateChangedEventArgs2 Properties
•
AdsStateChangedEventArgs2 Methods
•
AdsStateChangedEventArgs2 Fields


AdsStateChangedEventArgs2 Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs2 Class [image] AdsStateChangedEventArgs2 Constructor
AdsStateChangedEventArgs2 Constructor
Initializes a new instance of the AdsStateChangedEventArgs2 class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsStateChangedEventArgs2(
StateInfo newState,
StateInfo oldState,
IAdsSession session
)
VB
Public Sub New (
newState As StateInfo,
oldState As StateInfo,
session As IAdsSession
)
Parameters
newState | Type: TwinCAT.Ads.StateInfo The new state.
oldState | Type: TwinCAT.Ads.StateInfo The old state.
session | Type: TwinCAT.Ads.IAdsSession The session.
Reference
AdsStateChangedEventArgs2 Class
TwinCAT.Ads Namespace


AdsStateChangedEventArgs2 Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs2 Class [image] AdsStateChangedEventArgs2 Properties
AdsStateChangedEventArgs2 Properties
The AdsStateChangedEventArgs2 type exposes the following members.
Properties
Name | Description
Connection | Gets the connection.
Reference
AdsStateChangedEventArgs2 Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsStateChangedEventArgs2.Connection Property


AdsStateChangedEventArgs2.Connection Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs2 Class [image] AdsStateChangedEventArgs2 Properties [image] AdsStateChangedEventArgs2.Connection Property
AdsStateChangedEventArgs2.Connection Property
Gets the connection.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IAdsConnection Connection { get; }
VB
Public ReadOnly Property Connection As IAdsConnection
Get
Property Value
Type: IAdsConnection
The connection.
Reference
AdsStateChangedEventArgs2 Class
TwinCAT.Ads Namespace


AdsStateChangedEventArgs2 Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs2 Class [image] AdsStateChangedEventArgs2 Methods
AdsStateChangedEventArgs2 Methods
The AdsStateChangedEventArgs2 type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AdsStateChangedEventArgs2 Class
TwinCAT.Ads Namespace


AdsStateChangedEventArgs2 Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs2 Class [image] AdsStateChangedEventArgs2 Fields
AdsStateChangedEventArgs2 Fields
The AdsStateChangedEventArgs2 type exposes the following members.
Fields
Name | Description
NewState | The new state
OldState | The old state
Session | The session
Reference
AdsStateChangedEventArgs2 Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsStateChangedEventArgs2.NewState Field
•
AdsStateChangedEventArgs2.OldState Field
•
AdsStateChangedEventArgs2.Session Field


AdsStateChangedEventArgs2.NewState Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs2 Class [image] AdsStateChangedEventArgs2 Fields [image] AdsStateChangedEventArgs2.NewState Field
AdsStateChangedEventArgs2.NewState Field
The new state
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly StateInfo NewState
VB
Public ReadOnly NewState As StateInfo
Field Value
Type: StateInfo
Reference
AdsStateChangedEventArgs2 Class
TwinCAT.Ads Namespace


AdsStateChangedEventArgs2.OldState Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs2 Class [image] AdsStateChangedEventArgs2 Fields [image] AdsStateChangedEventArgs2.OldState Field
AdsStateChangedEventArgs2.OldState Field
The old state
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly StateInfo OldState
VB
Public ReadOnly OldState As StateInfo
Field Value
Type: StateInfo
Reference
AdsStateChangedEventArgs2 Class
TwinCAT.Ads Namespace


AdsStateChangedEventArgs2.Session Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventArgs2 Class [image] AdsStateChangedEventArgs2 Fields [image] AdsStateChangedEventArgs2.Session Field
AdsStateChangedEventArgs2.Session Field
The session
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly IAdsSession Session
VB
Public ReadOnly Session As IAdsSession
Field Value
Type: IAdsSession
Reference
AdsStateChangedEventArgs2 Class
TwinCAT.Ads Namespace


AdsStateChangedEventHandler Delegate

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStateChangedEventHandler Delegate
AdsStateChangedEventHandler Delegate
Event handler for the AdsStateChanged event in the class TcAdsClient.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public delegate void AdsStateChangedEventHandler(
Object sender,
AdsStateChangedEventArgs e
)
VB
Public Delegate Sub AdsStateChangedEventHandler (
sender As Object,
e As AdsStateChangedEventArgs
)
Parameters
sender | Type: System.Object
e | Type: TwinCAT.Ads.AdsStateChangedEventArgs
Reference
TwinCAT.Ads Namespace


AdsStream Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStream Class
AdsStream Class
The class AdsStream is a stream class used for ADS communication.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.IO.Stream
System.IO.MemoryStream
TwinCAT.Ads.AdsStream
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class AdsStream : MemoryStream
VB
Public Class AdsStream
Inherits MemoryStream
The AdsStream type exposes the following members.
Constructors
Name | Description
AdsStream. | Initializes a new instance of the AdsStream class. The instance has an expandable capacity initialized to zero.
AdsStream(.Byte.) | Initializes a new instance of the AdsStream class, based on a byte array.
AdsStream(Int32) | Initializes a new instance of the AdsStream class.
AdsStream(.Byte., Int32, Int32) | Initializes a new instance of the AdsStream class, based on the specified region of a byte array.
Properties
Name | Description
CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from MemoryStream.)
CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from MemoryStream.)
CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from MemoryStream.)
Capacity | Gets or sets the number of bytes allocated for this stream. (Inherited from MemoryStream.)
Length | Gets the length of the stream in bytes. (Inherited from MemoryStream.)
Position | Gets or sets the current position within the stream. (Inherited from MemoryStream.)
ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Methods
Name | Description
BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(.Byte., Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(.Byte., Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads all the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from MemoryStream.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Dispose. | Releases all resources used by the Stream. (Inherited from Stream.)
Dispose(Boolean) | Releases the unmanaged resources used by the MemoryStream class and optionally releases the managed resources. (Inherited from MemoryStream.)
EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(.Byte., Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(.Byte., Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Flush | Overrides the Flush. method so that no action is performed. (Inherited from MemoryStream.)
FlushAsync. | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, and monitors cancellation requests. (Inherited from MemoryStream.)
GetBuffer | Returns the array of unsigned bytes from which this stream was created. (Inherited from MemoryStream.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone. | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Read | Reads a block of bytes from the current stream and writes the data to a buffer. (Inherited from MemoryStream.)
ReadAsync(.Byte., Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
ReadAsync(.Byte., Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from MemoryStream.)
ReadByte | Reads a byte from the current stream. (Inherited from MemoryStream.)
Seek | Sets the position within the current stream to the specified value. (Inherited from MemoryStream.)
SetLength | Sets the length of the current stream to the specified value. (Inherited from MemoryStream.)
ToArray | Writes the stream contents to a byte array, regardless of the Position property. (Inherited from MemoryStream.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetBuffer | Returns the array of unsigned bytes from which this stream was created. The return value indicates whether the conversion succeeded. (Inherited from MemoryStream.)
Write | Writes a block of bytes to the current stream using data read from a buffer. (Inherited from MemoryStream.)
WriteAsync(.Byte., Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
WriteAsync(.Byte., Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from MemoryStream.)
WriteByte | Writes a byte to the current stream at the current position. (Inherited from MemoryStream.)
WriteTo | Writes the entire contents of this memory stream to another stream. (Inherited from MemoryStream.)
Fields
Name | Description
origin | The origin of the stream.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsStream Constructor
•
AdsStream Properties
•
AdsStream Methods
•
AdsStream Fields


AdsStream Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStream Class [image] AdsStream Constructor
AdsStream Constructor
Overload List
Name | Description
AdsStream. | Initializes a new instance of the AdsStream class. The instance has an expandable capacity initialized to zero.
AdsStream(.Byte.) | Initializes a new instance of the AdsStream class, based on a byte array.
AdsStream(Int32) | Initializes a new instance of the AdsStream class.
AdsStream(.Byte., Int32, Int32) | Initializes a new instance of the AdsStream class, based on the specified region of a byte array.
Reference
AdsStream Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsStream Constructor
•
AdsStream Constructor (.Byte.)
•
AdsStream Constructor (Int32)
•
AdsStream Constructor (.Byte., Int32, Int32)


AdsStream Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStream Class [image] AdsStream Constructor [image] AdsStream Constructor
AdsStream Constructor
Initializes a new instance of the AdsStream class. The instance has an expandable capacity initialized to zero.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsStream()
VB
Public Sub New
Reference
AdsStream Class
AdsStream Overload
TwinCAT.Ads Namespace


AdsStream Constructor (.Byte.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStream Class [image] AdsStream Constructor [image] AdsStream Constructor (.Byte.)
AdsStream Constructor (.Byte.)
Initializes a new instance of the AdsStream class, based on a byte array.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsStream(
byte[] buffer
)
VB
Public Sub New (
buffer As Byte()
)
Parameters
buffer
Type: .System.Byte.
The array of bytes from which to create this stream.
Reference
AdsStream Class
AdsStream Overload
TwinCAT.Ads Namespace


AdsStream Constructor (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStream Class [image] AdsStream Constructor [image] AdsStream Constructor (Int32)
AdsStream Constructor (Int32)
Initializes a new instance of the AdsStream class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsStream(
int length
)
VB
Public Sub New (
length As Integer
)
Parameters
length
Type: System.Int32
Length of the stream in bytes.
Reference
AdsStream Class
AdsStream Overload
TwinCAT.Ads Namespace


AdsStream Constructor (.Byte., Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStream Class [image] AdsStream Constructor [image] AdsStream Constructor (.Byte., Int32, Int32)
AdsStream Constructor (.Byte., Int32, Int32)
Initializes a new instance of the AdsStream class, based on the specified region of a byte array.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsStream(
byte[] buffer,
int offset,
int length
)
VB
Public Sub New (
buffer As Byte(),
offset As Integer,
length As Integer
)
Parameters
buffer | Type: .System.Byte. The array of bytes from which to create this stream.
offset | Type: System.Int32 The offset in buffer at which the stream begins.
length | Type: System.Int32 The length of the stream in bytes.
Reference
AdsStream Class
AdsStream Overload
TwinCAT.Ads Namespace


AdsStream Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStream Class [image] AdsStream Properties
AdsStream Properties
The AdsStream type exposes the following members.
Properties
Name | Description
CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from MemoryStream.)
CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from MemoryStream.)
CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from MemoryStream.)
Capacity | Gets or sets the number of bytes allocated for this stream. (Inherited from MemoryStream.)
Length | Gets the length of the stream in bytes. (Inherited from MemoryStream.)
Position | Gets or sets the current position within the stream. (Inherited from MemoryStream.)
ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Reference
AdsStream Class
TwinCAT.Ads Namespace


AdsStream Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStream Class [image] AdsStream Methods
AdsStream Methods
The AdsStream type exposes the following members.
Methods
Name | Description
BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(.Byte., Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(.Byte., Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads all the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from MemoryStream.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Dispose. | Releases all resources used by the Stream. (Inherited from Stream.)
Dispose(Boolean) | Releases the unmanaged resources used by the MemoryStream class and optionally releases the managed resources. (Inherited from MemoryStream.)
EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(.Byte., Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(.Byte., Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Flush | Overrides the Flush. method so that no action is performed. (Inherited from MemoryStream.)
FlushAsync. | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, and monitors cancellation requests. (Inherited from MemoryStream.)
GetBuffer | Returns the array of unsigned bytes from which this stream was created. (Inherited from MemoryStream.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone. | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Read | Reads a block of bytes from the current stream and writes the data to a buffer. (Inherited from MemoryStream.)
ReadAsync(.Byte., Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
ReadAsync(.Byte., Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from MemoryStream.)
ReadByte | Reads a byte from the current stream. (Inherited from MemoryStream.)
Seek | Sets the position within the current stream to the specified value. (Inherited from MemoryStream.)
SetLength | Sets the length of the current stream to the specified value. (Inherited from MemoryStream.)
ToArray | Writes the stream contents to a byte array, regardless of the Position property. (Inherited from MemoryStream.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetBuffer | Returns the array of unsigned bytes from which this stream was created. The return value indicates whether the conversion succeeded. (Inherited from MemoryStream.)
Write | Writes a block of bytes to the current stream using data read from a buffer. (Inherited from MemoryStream.)
WriteAsync(.Byte., Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
WriteAsync(.Byte., Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from MemoryStream.)
WriteByte | Writes a byte to the current stream at the current position. (Inherited from MemoryStream.)
WriteTo | Writes the entire contents of this memory stream to another stream. (Inherited from MemoryStream.)
Reference
AdsStream Class
TwinCAT.Ads Namespace


AdsStream Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStream Class [image] AdsStream Fields
AdsStream Fields
The AdsStream type exposes the following members.
Fields
Name | Description
origin | The origin of the stream.
Reference
AdsStream Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsStream.origin Field


AdsStream.origin Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsStream Class [image] AdsStream Fields [image] AdsStream.origin Field
AdsStream.origin Field
The origin of the stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected int origin
VB
Protected origin As Integer
Field Value
Type: Int32
Reference
AdsStream Class
TwinCAT.Ads Namespace


AdsSumCommandException Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSumCommandException Class
AdsSumCommandException Class
The exception that is thrown when an ADS SumCommand error occurs.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.Ads.AdsErrorException
TwinCAT.Ads.AdsSumCommandException
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class AdsSumCommandException : AdsErrorException
VB
<SerializableAttribute>
Public Class AdsSumCommandException
Inherits AdsErrorException
The AdsSumCommandException type exposes the following members.
Constructors
Name | Description
AdsSumCommandException | Initializes a new Instance of the AdsErrorException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets the error code of the Exception. (Inherited from AdsErrorException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
SumCommand | Gets the sum command.
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides AdsErrorException.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSumCommandException Constructor
•
AdsSumCommandException Properties
•
AdsSumCommandException Methods
•
AdsSumCommandException Events


AdsSumCommandException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSumCommandException Class [image] AdsSumCommandException Constructor
AdsSumCommandException Constructor
Initializes a new Instance of the AdsErrorException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSumCommandException(
string message,
ISumCommand command
)
VB
Public Sub New (
message As String,
command As ISumCommand
)
Parameters
message | Type: System.String The message.
command | Type: TwinCAT.Ads.SumCommand.ISumCommand The command.
Reference
AdsSumCommandException Class
TwinCAT.Ads Namespace


AdsSumCommandException Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSumCommandException Class [image] AdsSumCommandException Properties
AdsSumCommandException Properties
The AdsSumCommandException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets the error code of the Exception. (Inherited from AdsErrorException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
SumCommand | Gets the sum command.
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
AdsSumCommandException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSumCommandException.SumCommand Property


AdsSumCommandException.SumCommand Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSumCommandException Class [image] AdsSumCommandException Properties [image] AdsSumCommandException.SumCommand Property
AdsSumCommandException.SumCommand Property
Gets the sum command.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ISumCommand SumCommand { get; }
VB
Public ReadOnly Property SumCommand As ISumCommand
Get
Property Value
Type: ISumCommand
The sum command.
Reference
AdsSumCommandException Class
TwinCAT.Ads Namespace


AdsSumCommandException Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSumCommandException Class [image] AdsSumCommandException Methods
AdsSumCommandException Methods
The AdsSumCommandException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides AdsErrorException.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
AdsSumCommandException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSumCommandException.GetObjectData Method


AdsSumCommandException.GetObjectData Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSumCommandException Class [image] AdsSumCommandException Methods [image] AdsSumCommandException.GetObjectData Method
AdsSumCommandException.GetObjectData Method
When overridden in a derived class, sets the SerializationInfo with information about the exception.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
VB
Public Overrides Sub GetObjectData (
info As SerializationInfo,
context As StreamingContext
)
Parameters
info | Type: System.Runtime.Serialization.SerializationInfo The SerializationInfo that holds the serialized object data about the exception being thrown.
context | Type: System.Runtime.Serialization.StreamingContext The StreamingContext that contains contextual information about the source or destination.
Implements
ISerializable.GetObjectData(SerializationInfo, StreamingContext)
_Exception.GetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info
Reference
AdsSumCommandException Class
TwinCAT.Ads Namespace


AdsSumCommandException Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSumCommandException Class [image] AdsSumCommandException Events
AdsSumCommandException Events
The AdsSumCommandException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
AdsSumCommandException Class
TwinCAT.Ads Namespace


AdsSymbolException Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class
AdsSymbolException Class
Symbol Exception
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.Ads.AdsSymbolException
TwinCAT.Ads.RpcMethodNotSupportedException
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class AdsSymbolException : AdsException
VB
<SerializableAttribute>
Public Class AdsSymbolException
Inherits AdsException
The AdsSymbolException type exposes the following members.
Constructors
Name | Description
AdsSymbolException(String, String) | Initializes a new instance of the AdsSymbolException class.
AdsSymbolException(String, ITcAdsSymbol) | Initializes a new instance of the AdsSymbolException class.
AdsSymbolException(String, String, Exception) | Initializes a new instance of the AdsSymbolException class.
AdsSymbolException(String, ITcAdsSymbol, Exception) | Initializes a new instance of the AdsSymbolException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Fields
Name | Description
Symbol | The symbol
SymbolName | The symbol
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSymbolException Constructor
•
AdsSymbolException Properties
•
AdsSymbolException Methods
•
AdsSymbolException Events
•
AdsSymbolException Fields


AdsSymbolException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class [image] AdsSymbolException Constructor
AdsSymbolException Constructor
Overload List
Name | Description
AdsSymbolException(String, String) | Initializes a new instance of the AdsSymbolException class.
AdsSymbolException(String, ITcAdsSymbol) | Initializes a new instance of the AdsSymbolException class.
AdsSymbolException(String, String, Exception) | Initializes a new instance of the AdsSymbolException class.
AdsSymbolException(String, ITcAdsSymbol, Exception) | Initializes a new instance of the AdsSymbolException class.
Reference
AdsSymbolException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSymbolException Constructor (String, String)
•
AdsSymbolException Constructor (String, ITcAdsSymbol)
•
AdsSymbolException Constructor (String, String, Exception)
•
AdsSymbolException Constructor (String, ITcAdsSymbol, Exception)


AdsSymbolException Constructor (String, String)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class [image] AdsSymbolException Constructor [image] AdsSymbolException Constructor (String, String)
AdsSymbolException Constructor (String, String)
Initializes a new instance of the AdsSymbolException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSymbolException(
string message,
string symbolName
)
VB
Public Sub New (
message As String,
symbolName As String
)
Parameters
message | Type: System.String The message.
symbolName | Type: System.String Symbol path.
Reference
AdsSymbolException Class
AdsSymbolException Overload
TwinCAT.Ads Namespace


AdsSymbolException Constructor (String, ITcAdsSymbol)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class [image] AdsSymbolException Constructor [image] AdsSymbolException Constructor (String, ITcAdsSymbol)
AdsSymbolException Constructor (String, ITcAdsSymbol)
Initializes a new instance of the AdsSymbolException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSymbolException(
string message,
ITcAdsSymbol symbol
)
VB
Public Sub New (
message As String,
symbol As ITcAdsSymbol
)
Parameters
message | Type: System.String The message.
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
Reference
AdsSymbolException Class
AdsSymbolException Overload
TwinCAT.Ads Namespace


AdsSymbolException Constructor (String, String, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class [image] AdsSymbolException Constructor [image] AdsSymbolException Constructor (String, String, Exception)
AdsSymbolException Constructor (String, String, Exception)
Initializes a new instance of the AdsSymbolException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSymbolException(
string message,
string symbolName,
Exception innerException
)
VB
Public Sub New (
message As String,
symbolName As String,
innerException As Exception
)
Parameters
message | Type: System.String The message.
symbolName | Type: System.String Symbol path.
innerException | Type: System.Exception The inner exception.
Reference
AdsSymbolException Class
AdsSymbolException Overload
TwinCAT.Ads Namespace


AdsSymbolException Constructor (String, ITcAdsSymbol, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class [image] AdsSymbolException Constructor [image] AdsSymbolException Constructor (String, ITcAdsSymbol, Exception)
AdsSymbolException Constructor (String, ITcAdsSymbol, Exception)
Initializes a new instance of the AdsSymbolException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSymbolException(
string message,
ITcAdsSymbol symbol,
Exception innerException
)
VB
Public Sub New (
message As String,
symbol As ITcAdsSymbol,
innerException As Exception
)
Parameters
message | Type: System.String The message.
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
innerException | Type: System.Exception The inner exception.
Reference
AdsSymbolException Class
AdsSymbolException Overload
TwinCAT.Ads Namespace


AdsSymbolException Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class [image] AdsSymbolException Properties
AdsSymbolException Properties
The AdsSymbolException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
AdsSymbolException Class
TwinCAT.Ads Namespace


AdsSymbolException Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class [image] AdsSymbolException Methods
AdsSymbolException Methods
The AdsSymbolException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
AdsSymbolException Class
TwinCAT.Ads Namespace


AdsSymbolException Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class [image] AdsSymbolException Events
AdsSymbolException Events
The AdsSymbolException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
AdsSymbolException Class
TwinCAT.Ads Namespace


AdsSymbolException Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class [image] AdsSymbolException Fields
AdsSymbolException Fields
The AdsSymbolException type exposes the following members.
Fields
Name | Description
Symbol | The symbol
SymbolName | The symbol
Reference
AdsSymbolException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSymbolException.Symbol Field
•
AdsSymbolException.SymbolName Field


AdsSymbolException.Symbol Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class [image] AdsSymbolException Fields [image] AdsSymbolException.Symbol Field
AdsSymbolException.Symbol Field
The symbol
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[NonSerializedAttribute]
public readonly ITcAdsSymbol Symbol
VB
<NonSerializedAttribute>
Public ReadOnly Symbol As ITcAdsSymbol
Field Value
Type: ITcAdsSymbol
Reference
AdsSymbolException Class
TwinCAT.Ads Namespace


AdsSymbolException.SymbolName Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolException Class [image] AdsSymbolException Fields [image] AdsSymbolException.SymbolName Field
AdsSymbolException.SymbolName Field
The symbol
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[NonSerializedAttribute]
public readonly string SymbolName
VB
<NonSerializedAttribute>
Public ReadOnly SymbolName As String
Field Value
Type: String
Reference
AdsSymbolException Class
TwinCAT.Ads Namespace


AdsSymbolVersionChangedEventArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolVersionChangedEventArgs Class
AdsSymbolVersionChangedEventArgs Class
Provides data for AdsSymbolVersionChangedEvent of the class TcAdsClient.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.Ads.AdsSymbolVersionChangedEventArgs
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class AdsSymbolVersionChangedEventArgs : EventArgs
VB
Public NotInheritable Class AdsSymbolVersionChangedEventArgs
Inherits EventArgs
The AdsSymbolVersionChangedEventArgs type exposes the following members.
Constructors
Name | Description
AdsSymbolVersionChangedEventArgs(Byte) | Initializes a new instance of the AdsSymbolVersionChangedEventArgs class.
AdsSymbolVersionChangedEventArgs(AdsSymbolVersionChangedEventArgs) | Initializes a new instance of the AdsSymbolVersionChangedEventArgs class.
Properties
Name | Description
SymbolVersion | Current symbol version device.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSymbolVersionChangedEventArgs Constructor
•
AdsSymbolVersionChangedEventArgs Properties
•
AdsSymbolVersionChangedEventArgs Methods


AdsSymbolVersionChangedEventArgs Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolVersionChangedEventArgs Class [image] AdsSymbolVersionChangedEventArgs Constructor
AdsSymbolVersionChangedEventArgs Constructor
Overload List
Name | Description
AdsSymbolVersionChangedEventArgs(Byte) | Initializes a new instance of the AdsSymbolVersionChangedEventArgs class.
AdsSymbolVersionChangedEventArgs(AdsSymbolVersionChangedEventArgs) | Initializes a new instance of the AdsSymbolVersionChangedEventArgs class.
Reference
AdsSymbolVersionChangedEventArgs Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSymbolVersionChangedEventArgs Constructor (Byte)
•
AdsSymbolVersionChangedEventArgs Constructor (AdsSymbolVersionChangedEventArgs)


AdsSymbolVersionChangedEventArgs Constructor (Byte)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolVersionChangedEventArgs Class [image] AdsSymbolVersionChangedEventArgs Constructor [image] AdsSymbolVersionChangedEventArgs Constructor (Byte)
AdsSymbolVersionChangedEventArgs Constructor (Byte)
Initializes a new instance of the AdsSymbolVersionChangedEventArgs class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSymbolVersionChangedEventArgs(
byte symbolVersion
)
VB
Public Sub New (
symbolVersion As Byte
)
Parameters
symbolVersion
Type: System.Byte
Current symbol version.
Reference
AdsSymbolVersionChangedEventArgs Class
AdsSymbolVersionChangedEventArgs Overload
TwinCAT.Ads Namespace


AdsSymbolVersionChangedEventArgs Constructor (AdsSymbolVersionChangedEventArgs)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolVersionChangedEventArgs Class [image] AdsSymbolVersionChangedEventArgs Constructor [image] AdsSymbolVersionChangedEventArgs Constructor (AdsSymbolVersionChangedEventArgs)
AdsSymbolVersionChangedEventArgs Constructor (AdsSymbolVersionChangedEventArgs)
Initializes a new instance of the AdsSymbolVersionChangedEventArgs class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsSymbolVersionChangedEventArgs(
AdsSymbolVersionChangedEventArgs eventArgs
)
VB
Public Sub New (
eventArgs As AdsSymbolVersionChangedEventArgs
)
Parameters
eventArgs
Type: TwinCAT.Ads.AdsSymbolVersionChangedEventArgs
The AdsSymbolVersionChangedEventArgs instance containing the event data.
Reference
AdsSymbolVersionChangedEventArgs Class
AdsSymbolVersionChangedEventArgs Overload
TwinCAT.Ads Namespace


AdsSymbolVersionChangedEventArgs Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolVersionChangedEventArgs Class [image] AdsSymbolVersionChangedEventArgs Properties
AdsSymbolVersionChangedEventArgs Properties
The AdsSymbolVersionChangedEventArgs type exposes the following members.
Properties
Name | Description
SymbolVersion | Current symbol version device.
Reference
AdsSymbolVersionChangedEventArgs Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsSymbolVersionChangedEventArgs.SymbolVersion Property


AdsSymbolVersionChangedEventArgs.SymbolVersion Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolVersionChangedEventArgs Class [image] AdsSymbolVersionChangedEventArgs Properties [image] AdsSymbolVersionChangedEventArgs.SymbolVersion Property
AdsSymbolVersionChangedEventArgs.SymbolVersion Property
Current symbol version device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public short SymbolVersion { get; }
VB
Public ReadOnly Property SymbolVersion As Short
Get
Property Value
Type: Int16
The symbol version.
Reference
AdsSymbolVersionChangedEventArgs Class
TwinCAT.Ads Namespace


AdsSymbolVersionChangedEventArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsSymbolVersionChangedEventArgs Class [image] AdsSymbolVersionChangedEventArgs Methods
AdsSymbolVersionChangedEventArgs Methods
The AdsSymbolVersionChangedEventArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AdsSymbolVersionChangedEventArgs Class
TwinCAT.Ads Namespace


AdsTransMode Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsTransMode Enumeration
AdsTransMode Enumeration
ADS Transmission Mode for ADS Notifications.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum AdsTransMode
VB
Public Enumeration AdsTransMode
Members
Member name
Value
Description
None
0
None / Uninitalized transport mode. No AdsNotification event is fired.
ClientCycle
1
Client triggered cyclic AdsNotification event. The AdsNotification event is fired cyclically triggered from the client side. Polling is used from the User Application to read values, before they are fired as Notifications.
Client side triggering has the following consequences:
▪
The realtime environment on the server side will be less stressed (expecially the mailbox queue).
▪
Value requests are serialized one after another and are handled slower (synchronouly, not asynchronously)
▪
Implicit synchronization of the events into the UI Thread.
ClientOnChange
2
The AdsNotification event is fired when data changes triggered by the client. The AdsNotification event is fired on-change triggered from the client side. Polling is used from the User Application to read values, before they are fired as Notifications. Client side triggering has the following consequences:
▪
The realtime environment on the server side will be less stressed (expecially the mailbox queue).
▪
Value requests are serialized one after another and are handled slower (synchronouly, not asynchronously)
▪
Implicit synchronization of the events into the UI Thread.
Cyclic
3
The AdsNotification event is fired cyclically.
The Notification will be registered on the ADS Server side for a cyclical trigger (dependant on time parameter) and is bound to the 'default' task of the addressed target. In case of the PLC target (e.g. Port 851) the default task is the first configured task.
Each time the 'default' task has finished its cycle the realtime system will check for the expired cycle time and sends the AdsNotification message on expiry.
The used ContextMask for the 'default' task is 0.
Please be aware, that server side 'Change' notifications stress the realtime system and should be handled with care. Therefore, dependent of the cycle time of the task and the capabilities of the system only a limited set of Cyclic Notifications should be used!
A system limit for server side notification registrations is 1024.
OnChange
4
On-Change AdsNotification event.
The Notification will be registered on the ADS Server side for an on-change and optional cyclical trigger (dependant on parameters) and is bound to the 'default' task of the addressed target. In case of the PLC target (e.g. Port 851) the default task is the first configured task.
Each time this task has finished its cycle the realtime system will check for the changed value and an optional expired cycle time and sends the AdsNotification message on change or expiry.
The used ContextMask for the 'default' task is 0.
Please be aware, that server side 'OnChange' notifications stress the realtime system / the default task with value comparisons. Therefore, dependent of the cycle time of the task and the capabilities of the system a higher amount of notification registrations should be handled with care !
A system limit for server side notification registrations is 1024.
CyclicInContext
5
The AdsNotification event is fired cyclically within the given task context.
A Value of parameter is interpreted as task context number ContextMask. This can be important, if the notifications have to be synchron with specific tasks, but should not be used in the default case.
The Notification will be registered on the ADS Server side for a cyclical trigger (dependant on time parameter) and is bound to the task specified by the ContextMask of the addressed target. In case of the PLC target (e.g. Port 851) the ContextMask is the Index of the global TASKINFOARRAY - 1.
Each time this task has finished its cycle the realtime system will check for the expired cycle time and sends the AdsNotification message on expiry.
OnChangeInContext
6
The AdsNotification event is fired when the data changes within the given task context.
A Value of parameter is interpreted as task context number ContextMask. This can be important, if the notifications have to be synchron with specific tasks, but should not be used in the default case.
The Notification will be registered on the ADS Server side for an on-change and optional cyclical trigger (dependant on parameters) and is bound to the task specified by the ContextMask of the addressed target. In case of the PLC target (e.g. Port 851) the ContextMask is the Index of the global TASKINFOARRAY - 1. Each time this task has finished its cycle the realtime system will check for the changed value and an optional expired cycle time and sends the AdsNotification message on change or expiry.
Please be aware, that server side 'OnChange' notifications stress the realtime system / the default task with value comparisons. Therefore, dependent of the cycle time of the task and the capabilities of the system only a limited set of OnChange Notifications should be used!
Remarks
The AdsTransMode configures the registration of the AdsNotification at the server system and how the parameters of the AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) are interpreted. The following general scenarios are addressed:
▪
Cyclic notifications.
▪
Notifications on value change.
▪
Server side and Client side notifications.
▪
Binding of notifications to specific tasks.
In the default case the OnChange or the Cyclic (Server cycle) should be used. All other modes are side cases for special purposes.
More about the AdsNotifications: ADS Notification concept.
Reference
TwinCAT.Ads Namespace
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx
AddDeviceNotification Overload
AddDeviceNotificationEx Overload


AdsVersion Structure

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsVersion Structure
AdsVersion Structure
The structure contains the version number, revision number and build number.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public struct AdsVersion
VB
Public Structure AdsVersion
The AdsVersion type exposes the following members.
Constructors
Name | Description
AdsVersion | Initializes a new instance of the AdsVersion struct.
Properties
Name | Description
Build | Gets or sets the build number.
IsEmpty | Gets a value indicating whether this instance is empty / uninitialized.
Revision | Gets or sets the revision number.
Version | Gets or sets the version number.
Methods
Name | Description
ConvertToStandard | Converts this AdsVersion to a .NET Framework Version object.
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsVersion Constructor
•
AdsVersion Properties
•
AdsVersion Methods


AdsVersion Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsVersion Structure [image] AdsVersion Constructor
AdsVersion Constructor
Initializes a new instance of the AdsVersion struct.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsVersion(
int version,
int revision,
int build
)
VB
Public Sub New (
version As Integer,
revision As Integer,
build As Integer
)
Parameters
version | Type: System.Int32 The version.
revision | Type: System.Int32 The revision.
build | Type: System.Int32 The build.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | version or revision
Reference
AdsVersion Structure
TwinCAT.Ads Namespace


AdsVersion Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsVersion Structure [image] AdsVersion Properties
AdsVersion Properties
The AdsVersion type exposes the following members.
Properties
Name | Description
Build | Gets or sets the build number.
IsEmpty | Gets a value indicating whether this instance is empty / uninitialized.
Revision | Gets or sets the revision number.
Version | Gets or sets the version number.
Reference
AdsVersion Structure
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsVersion.Build Property
•
AdsVersion.IsEmpty Property
•
AdsVersion.Revision Property
•
AdsVersion.Version Property


AdsVersion.Build Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsVersion Structure [image] AdsVersion Properties [image] AdsVersion.Build Property
AdsVersion.Build Property
Gets or sets the build number.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Build { get; set; }
VB
Public Property Build As Integer
Get
Set
Property Value
Type: Int32
Reference
AdsVersion Structure
TwinCAT.Ads Namespace


AdsVersion.IsEmpty Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsVersion Structure [image] AdsVersion Properties [image] AdsVersion.IsEmpty Property
AdsVersion.IsEmpty Property
Gets a value indicating whether this instance is empty / uninitialized.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsEmpty { get; }
VB
Public ReadOnly Property IsEmpty As Boolean
Get
Property Value
Type: Boolean
true if this instance is empty; otherwise, false.
Reference
AdsVersion Structure
TwinCAT.Ads Namespace


AdsVersion.Revision Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsVersion Structure [image] AdsVersion Properties [image] AdsVersion.Revision Property
AdsVersion.Revision Property
Gets or sets the revision number.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public byte Revision { get; set; }
VB
Public Property Revision As Byte
Get
Set
Property Value
Type: Byte
Reference
AdsVersion Structure
TwinCAT.Ads Namespace


AdsVersion.Version Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsVersion Structure [image] AdsVersion Properties [image] AdsVersion.Version Property
AdsVersion.Version Property
Gets or sets the version number.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public byte Version { get; set; }
VB
Public Property Version As Byte
Get
Set
Property Value
Type: Byte
Reference
AdsVersion Structure
TwinCAT.Ads Namespace


AdsVersion Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsVersion Structure [image] AdsVersion Methods
AdsVersion Methods
The AdsVersion type exposes the following members.
Methods
Name | Description
ConvertToStandard | Converts this AdsVersion to a .NET Framework Version object.
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Reference
AdsVersion Structure
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AdsVersion.ConvertToStandard Method


AdsVersion.ConvertToStandard Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AdsVersion Structure [image] AdsVersion Methods [image] AdsVersion.ConvertToStandard Method
AdsVersion.ConvertToStandard Method
Converts this AdsVersion to a .NET Framework Version object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Version ConvertToStandard()
VB
Public Function ConvertToStandard As Version
Return Value
Type: Version
Version.
Reference
AdsVersion Structure
TwinCAT.Ads Namespace


AmsAddress Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class
AmsAddress Class
Ams/Ads Address
Inheritance Hierarchy
System.Object
TwinCAT.Ads.AmsAddress
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class AmsAddress
VB
Public Class AmsAddress
The AmsAddress type exposes the following members.
Constructors
Name | Description
AmsAddress. | Protected constructor
AmsAddress(Int32) | Constructor
AmsAddress(String) | Initializes a new instance of the AmsAddress class.
AmsAddress(AmsAddress) | Copy constructor
AmsAddress(AmsPort) | Constructor
AmsAddress(.Byte., Int32) | Constructor
AmsAddress(.Byte., AmsPort) | Constructor
AmsAddress(String, Int32) | Constructor
AmsAddress(String, AmsPort) | Constructor
AmsAddress(AmsNetId, Int32) | Constructor
AmsAddress(AmsNetId, AmsPort) | Constructor
Properties
Name | Description
NetId | Gets the NetId
Port | Gets the Port number
Methods
Name | Description
Clone | Clones this instance.
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parses a string to an AmsAddress object.
ToString | Converts the Address to String 'NetId:Port' (Overrides Object.ToString..)
TryParse | Tries to parse the AmsAddress from string.
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Fields
Name | Description
netId | The net id
port | The port
RegularExpressionPattern | The regular expression pattern for AmsAddress
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsAddress Constructor
•
AmsAddress Properties
•
AmsAddress Methods
•
AmsAddress Operators
•
AmsAddress Fields


AmsAddress Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor
AmsAddress Constructor
Overload List
Name | Description
AmsAddress. | Protected constructor
AmsAddress(Int32) | Constructor
AmsAddress(String) | Initializes a new instance of the AmsAddress class.
AmsAddress(AmsAddress) | Copy constructor
AmsAddress(AmsPort) | Constructor
AmsAddress(.Byte., Int32) | Constructor
AmsAddress(.Byte., AmsPort) | Constructor
AmsAddress(String, Int32) | Constructor
AmsAddress(String, AmsPort) | Constructor
AmsAddress(AmsNetId, Int32) | Constructor
AmsAddress(AmsNetId, AmsPort) | Constructor
Reference
AmsAddress Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsAddress Constructor
•
AmsAddress Constructor (Int32)
•
AmsAddress Constructor (String)
•
AmsAddress Constructor (AmsAddress)
•
AmsAddress Constructor (AmsPort)
•
AmsAddress Constructor (.Byte., Int32)
•
AmsAddress Constructor (.Byte., AmsPort)
•
AmsAddress Constructor (String, Int32)
•
AmsAddress Constructor (String, AmsPort)
•
AmsAddress Constructor (AmsNetId, Int32)
•
AmsAddress Constructor (AmsNetId, AmsPort)


AmsAddress Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor [image] AmsAddress Constructor
AmsAddress Constructor
Protected constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected AmsAddress()
VB
Protected Sub New
Reference
AmsAddress Class
AmsAddress Overload
TwinCAT.Ads Namespace


AmsAddress Constructor (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor [image] AmsAddress Constructor (Int32)
AmsAddress Constructor (Int32)
Constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress(
int port
)
VB
Public Sub New (
port As Integer
)
Parameters
port
Type: System.Int32
The port.
Reference
AmsAddress Class
AmsAddress Overload
TwinCAT.Ads Namespace


AmsAddress Constructor (String)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor [image] AmsAddress Constructor (String)
AmsAddress Constructor (String)
Initializes a new instance of the AmsAddress class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress(
string str
)
VB
Public Sub New (
str As String
)
Parameters
str
Type: System.String
The address coded as string (Format NetId:Port, 1.2.3.4.5.6:Port)
Reference
AmsAddress Class
AmsAddress Overload
TwinCAT.Ads Namespace


AmsAddress Constructor (AmsAddress)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor [image] AmsAddress Constructor (AmsAddress)
AmsAddress Constructor (AmsAddress)
Copy constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress(
AmsAddress address
)
VB
Public Sub New (
address As AmsAddress
)
Parameters
address
Type: TwinCAT.Ads.AmsAddress
The address.
Reference
AmsAddress Class
AmsAddress Overload
TwinCAT.Ads Namespace


AmsAddress Constructor (AmsPort)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor [image] AmsAddress Constructor (AmsPort)
AmsAddress Constructor (AmsPort)
Constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress(
AmsPort port
)
VB
Public Sub New (
port As AmsPort
)
Parameters
port
Type: TwinCAT.Ads.AmsPort
The port.
Reference
AmsAddress Class
AmsAddress Overload
TwinCAT.Ads Namespace


AmsAddress Constructor (.Byte., Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor [image] AmsAddress Constructor (.Byte., Int32)
AmsAddress Constructor (.Byte., Int32)
Constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress(
byte[] netId,
int port
)
VB
Public Sub New (
netId As Byte(),
port As Integer
)
Parameters
netId | Type: .System.Byte. The net identifier.
port | Type: System.Int32 The port.
Reference
AmsAddress Class
AmsAddress Overload
TwinCAT.Ads Namespace


AmsAddress Constructor (.Byte., AmsPort)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor [image] AmsAddress Constructor (.Byte., AmsPort)
AmsAddress Constructor (.Byte., AmsPort)
Constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress(
byte[] netId,
AmsPort port
)
VB
Public Sub New (
netId As Byte(),
port As AmsPort
)
Parameters
netId | Type: .System.Byte. The net identifier.
port | Type: TwinCAT.Ads.AmsPort The port.
Reference
AmsAddress Class
AmsAddress Overload
TwinCAT.Ads Namespace


AmsAddress Constructor (String, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor [image] AmsAddress Constructor (String, Int32)
AmsAddress Constructor (String, Int32)
Constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress(
string netId,
int port
)
VB
Public Sub New (
netId As String,
port As Integer
)
Parameters
netId | Type: System.String The net identifier.
port | Type: System.Int32 The port.
Reference
AmsAddress Class
AmsAddress Overload
TwinCAT.Ads Namespace


AmsAddress Constructor (String, AmsPort)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor [image] AmsAddress Constructor (String, AmsPort)
AmsAddress Constructor (String, AmsPort)
Constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress(
string netId,
AmsPort port
)
VB
Public Sub New (
netId As String,
port As AmsPort
)
Parameters
netId | Type: System.String The net identifier.
port | Type: TwinCAT.Ads.AmsPort The port.
Reference
AmsAddress Class
AmsAddress Overload
TwinCAT.Ads Namespace


AmsAddress Constructor (AmsNetId, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor [image] AmsAddress Constructor (AmsNetId, Int32)
AmsAddress Constructor (AmsNetId, Int32)
Constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress(
AmsNetId netId,
int port
)
VB
Public Sub New (
netId As AmsNetId,
port As Integer
)
Parameters
netId | Type: TwinCAT.Ads.AmsNetId Net Id
port | Type: System.Int32 Port
Reference
AmsAddress Class
AmsAddress Overload
TwinCAT.Ads Namespace


AmsAddress Constructor (AmsNetId, AmsPort)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Constructor [image] AmsAddress Constructor (AmsNetId, AmsPort)
AmsAddress Constructor (AmsNetId, AmsPort)
Constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress(
AmsNetId netId,
AmsPort port
)
VB
Public Sub New (
netId As AmsNetId,
port As AmsPort
)
Parameters
netId | Type: TwinCAT.Ads.AmsNetId The net identifier.
port | Type: TwinCAT.Ads.AmsPort The port.
Reference
AmsAddress Class
AmsAddress Overload
TwinCAT.Ads Namespace


AmsAddress Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Properties
AmsAddress Properties
The AmsAddress type exposes the following members.
Properties
Name | Description
NetId | Gets the NetId
Port | Gets the Port number
Reference
AmsAddress Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsAddress.NetId Property
•
AmsAddress.Port Property


AmsAddress.NetId Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Properties [image] AmsAddress.NetId Property
AmsAddress.NetId Property
Gets the NetId
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsNetId NetId { get; set; }
VB
Public Property NetId As AmsNetId
Get
Set
Property Value
Type: AmsNetId
The net identifier.
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress.Port Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Properties [image] AmsAddress.Port Property
AmsAddress.Port Property
Gets the Port number
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Port { get; set; }
VB
Public Property Port As Integer
Get
Set
Property Value
Type: Int32
The port.
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Methods
AmsAddress Methods
The AmsAddress type exposes the following members.
Methods
Name | Description
Clone | Clones this instance.
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parses a string to an AmsAddress object.
ToString | Converts the Address to String 'NetId:Port' (Overrides Object.ToString..)
TryParse | Tries to parse the AmsAddress from string.
Reference
AmsAddress Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsAddress.Clone Method
•
AmsAddress.Equals Method
•
AmsAddress.GetHashCode Method
•
AmsAddress.Parse Method
•
AmsAddress.ToString Method
•
AmsAddress.TryParse Method


AmsAddress.Clone Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Methods [image] AmsAddress.Clone Method
AmsAddress.Clone Method
Clones this instance.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress Clone()
VB
Public Function Clone As AmsAddress
Return Value
Type: AmsAddress
AmsAddress.
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress.Equals Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Methods [image] AmsAddress.Equals Method
AmsAddress.Equals Method
Equals
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool Equals(
Object obj
)
VB
Public Overrides Function Equals (
obj As Object
) As Boolean
Parameters
obj
Type: System.Object
The object to compare with the current object.
Return Value
Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress.GetHashCode Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Methods [image] AmsAddress.GetHashCode Method
AmsAddress.GetHashCode Method
Gets the HashCode of the Address
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override int GetHashCode()
VB
Public Overrides Function GetHashCode As Integer
Return Value
Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress.Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Methods [image] AmsAddress.Parse Method
AmsAddress.Parse Method
Parses a string to an AmsAddress object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static AmsAddress Parse(
string str
)
VB
Public Shared Function Parse (
str As String
) As AmsAddress
Parameters
str
Type: System.String
The string.
Return Value
Type: AmsAddress
AmsAddress.
Exceptions
Exception | Condition
FormatException |
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Methods [image] AmsAddress.ToString Method
AmsAddress.ToString Method
Converts the Address to String 'NetId:Port'
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress.TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Methods [image] AmsAddress.TryParse Method
AmsAddress.TryParse Method
Tries to parse the AmsAddress from string.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool TryParse(
string str,
out AmsAddress address
)
VB
Public Shared Function TryParse (
str As String,
<OutAttribute> ByRef address As AmsAddress
) As Boolean
Parameters
str | Type: System.String The STR.
address | Type: TwinCAT.Ads.AmsAddress. The address.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress Operators

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Operators
AmsAddress Operators
The AmsAddress type exposes the following members.
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Reference
AmsAddress Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsAddress.Equality Operator
•
AmsAddress.Inequality Operator


AmsAddress.Equality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Operators [image] AmsAddress.Equality Operator
AmsAddress.Equality Operator
Operator==
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator ==(
AmsAddress o1,
AmsAddress o2
)
VB
Public Shared Operator = (
o1 As AmsAddress,
o2 As AmsAddress
) As Boolean
Parameters
o1 | Type: TwinCAT.Ads.AmsAddress The o1.
o2 | Type: TwinCAT.Ads.AmsAddress The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress.Inequality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Operators [image] AmsAddress.Inequality Operator
AmsAddress.Inequality Operator
Implements the != operator.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator !=(
AmsAddress o1,
AmsAddress o2
)
VB
Public Shared Operator <> (
o1 As AmsAddress,
o2 As AmsAddress
) As Boolean
Parameters
o1 | Type: TwinCAT.Ads.AmsAddress The o1.
o2 | Type: TwinCAT.Ads.AmsAddress The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Fields
AmsAddress Fields
The AmsAddress type exposes the following members.
Fields
Name | Description
netId | The net id
port | The port
RegularExpressionPattern | The regular expression pattern for AmsAddress
Reference
AmsAddress Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsAddress.netId Field
•
AmsAddress.port Field
•
AmsAddress.RegularExpressionPattern Field


AmsAddress.netId Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Fields [image] AmsAddress.netId Field
AmsAddress.netId Field
The net id
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected AmsNetId netId
VB
Protected netId As AmsNetId
Field Value
Type: AmsNetId
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress.port Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Fields [image] AmsAddress.port Field
AmsAddress.port Field
The port
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected int port
VB
Protected port As Integer
Field Value
Type: Int32
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsAddress.RegularExpressionPattern Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsAddress Class [image] AmsAddress Fields [image] AmsAddress.RegularExpressionPattern Field
AmsAddress.RegularExpressionPattern Field
The regular expression pattern for AmsAddress
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public const string RegularExpressionPattern = "^(?<AmsNetId>((?<First>\d{1,3})\.(?<Second>\d{1,3})\.(?<Third>\d{1,3})\.(?<Fourth>\d{1,3})\.(?<Fifth>\d{1,3})\.(?<Sixth>\d{1,3})) | Local | Empty | LocalHost)(:(?<AdsPort>\d+))?$"
VB
Public Const RegularExpressionPattern As String = "^(?<AmsNetId>((?<First>\d{1,3})\.(?<Second>\d{1,3})\.(?<Third>\d{1,3})\.(?<Fourth>\d{1,3})\.(?<Fifth>\d{1,3})\.(?<Sixth>\d{1,3})) | Local | Empty | LocalHost)(:(?<AdsPort>\d+))?$"
Field Value
Type: String
Reference
AmsAddress Class
TwinCAT.Ads Namespace


AmsNetId Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class
AmsNetId Class
AMS/ADS Net ID
Inheritance Hierarchy
System.Object
TwinCAT.Ads.AmsNetId
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class AmsNetId : IComparable<AmsNetId>,
IComparable
VB
<SerializableAttribute>
Public Class AmsNetId
Implements IComparable(Of AmsNetId), IComparable
The AmsNetId type exposes the following members.
Constructors
Name | Description
AmsNetId(.Byte.) | Constructor
AmsNetId(String) | Constructor
AmsNetId(AmsNetId) | Copy Constructor
Properties
Name | Description
Empty | Creates an empty NetId ("0.0.0.0.0.0")
IsLocal | Is the Address Local?
Local | Gets the Local Net ID (System service must be running)
LocalHost | Creates the local NetId ("127.0.0.1.1.1")
Methods
Name | Description
Clone | Clones the NetId
CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
CompareTo(AmsNetId) | Compares the current object with another object of the same type.
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FromBinHexString | Creates the AmsNetId from bin hex string.
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Determines whether the specified AmsNetIds are equal.
IsSameTarget | Determines whether the AmsNetIds refer to the same target.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NetIdsEqual(.Byte.) | Compares the netIds
NetIdsEqual(.Byte., .Byte.) | Compares the NetIds
Parse | Converts the string representation of the address to AmsNetId.
ToBinHex. | Converts the AmsNetId to a BinHex string.
ToBinHex(AmsNetId) | Converts the specified AmsNetId to a BinHex string.
ToBytes | Converts the NetId object to byte array
ToString. | Converts the netId to string (Overrides Object.ToString..)
ToString(String, IFormatProvider) | Returns a String that represents this instance.
TryParse | Converts the string representation of the address to AmsNetId.
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsNetId Constructor
•
AmsNetId Properties
•
AmsNetId Methods
•
AmsNetId Operators


AmsNetId Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Constructor
AmsNetId Constructor
Overload List
Name | Description
AmsNetId(.Byte.) | Constructor
AmsNetId(String) | Constructor
AmsNetId(AmsNetId) | Copy Constructor
Reference
AmsNetId Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsNetId Constructor (.Byte.)
•
AmsNetId Constructor (String)
•
AmsNetId Constructor (AmsNetId)


AmsNetId Constructor (.Byte.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Constructor [image] AmsNetId Constructor (.Byte.)
AmsNetId Constructor (.Byte.)
Constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsNetId(
byte[] netId
)
VB
Public Sub New (
netId As Byte()
)
Parameters
netId
Type: .System.Byte.
Net ID in bytes
Exceptions
Exception | Condition
ArgumentException | Not a valid NetId;netId
Reference
AmsNetId Class
AmsNetId Overload
TwinCAT.Ads Namespace


AmsNetId Constructor (String)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Constructor [image] AmsNetId Constructor (String)
AmsNetId Constructor (String)
Constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsNetId(
string netId
)
VB
Public Sub New (
netId As String
)
Parameters
netId
Type: System.String
NetID as string
Reference
AmsNetId Class
AmsNetId Overload
TwinCAT.Ads Namespace


AmsNetId Constructor (AmsNetId)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Constructor [image] AmsNetId Constructor (AmsNetId)
AmsNetId Constructor (AmsNetId)
Copy Constructor
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsNetId(
AmsNetId netId
)
VB
Public Sub New (
netId As AmsNetId
)
Parameters
netId
Type: TwinCAT.Ads.AmsNetId
Net Id.
Reference
AmsNetId Class
AmsNetId Overload
TwinCAT.Ads Namespace


AmsNetId Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Properties
AmsNetId Properties
The AmsNetId type exposes the following members.
Properties
Name | Description
Empty | Creates an empty NetId ("0.0.0.0.0.0")
IsLocal | Is the Address Local?
Local | Gets the Local Net ID (System service must be running)
LocalHost | Creates the local NetId ("127.0.0.1.1.1")
Reference
AmsNetId Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsNetId.Empty Property
•
AmsNetId.IsLocal Property
•
AmsNetId.Local Property
•
AmsNetId.LocalHost Property


AmsNetId.Empty Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Properties [image] AmsNetId.Empty Property
AmsNetId.Empty Property
Creates an empty NetId ("0.0.0.0.0.0")
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static AmsNetId Empty { get; }
VB
Public Shared ReadOnly Property Empty As AmsNetId
Get
Property Value
Type: AmsNetId
The empty.
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId.IsLocal Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Properties [image] AmsNetId.IsLocal Property
AmsNetId.IsLocal Property
Is the Address Local?
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsLocal { get; }
VB
Public ReadOnly Property IsLocal As Boolean
Get
Property Value
Type: Boolean
true if this instance is local; otherwise, false.
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId.Local Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Properties [image] AmsNetId.Local Property
AmsNetId.Local Property
Gets the Local Net ID (System service must be running)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static AmsNetId Local { get; }
VB
Public Shared ReadOnly Property Local As AmsNetId
Get
Property Value
Type: AmsNetId
The local.
Remarks
The system service must be running
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId.LocalHost Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Properties [image] AmsNetId.LocalHost Property
AmsNetId.LocalHost Property
Creates the local NetId ("127.0.0.1.1.1")
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static AmsNetId LocalHost { get; }
VB
Public Shared ReadOnly Property LocalHost As AmsNetId
Get
Property Value
Type: AmsNetId
The local host.
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods
AmsNetId Methods
The AmsNetId type exposes the following members.
Methods
Name | Description
Clone | Clones the NetId
CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
CompareTo(AmsNetId) | Compares the current object with another object of the same type.
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FromBinHexString | Creates the AmsNetId from bin hex string.
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Determines whether the specified AmsNetIds are equal.
IsSameTarget | Determines whether the AmsNetIds refer to the same target.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NetIdsEqual(.Byte.) | Compares the netIds
NetIdsEqual(.Byte., .Byte.) | Compares the NetIds
Parse | Converts the string representation of the address to AmsNetId.
ToBinHex. | Converts the AmsNetId to a BinHex string.
ToBinHex(AmsNetId) | Converts the specified AmsNetId to a BinHex string.
ToBytes | Converts the NetId object to byte array
ToString. | Converts the netId to string (Overrides Object.ToString..)
ToString(String, IFormatProvider) | Returns a String that represents this instance.
TryParse | Converts the string representation of the address to AmsNetId.
Reference
AmsNetId Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsNetId.Clone Method
•
AmsNetId.CompareTo Method
•
AmsNetId.Equals Method
•
AmsNetId.FromBinHexString Method
•
AmsNetId.GetHashCode Method
•
AmsNetId.IsEqual Method
•
AmsNetId.IsSameTarget Method
•
AmsNetId.NetIdsEqual Method
•
AmsNetId.Parse Method
•
AmsNetId.ToBinHex Method
•
AmsNetId.ToBytes Method
•
AmsNetId.ToString Method
•
AmsNetId.TryParse Method


AmsNetId.Clone Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.Clone Method
AmsNetId.Clone Method
Clones the NetId
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsNetId Clone()
VB
Public Function Clone As AmsNetId
Return Value
Type: AmsNetId
The cloned AmsNetId
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId.CompareTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.CompareTo Method
AmsNetId.CompareTo Method
Overload List
Name | Description
CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
CompareTo(AmsNetId) | Compares the current object with another object of the same type.
Reference
AmsNetId Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsNetId.CompareTo Method (Object)
•
AmsNetId.CompareTo Method (AmsNetId)


AmsNetId.CompareTo Method (Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.CompareTo Method [image] AmsNetId.CompareTo Method (Object)
AmsNetId.CompareTo Method (Object)
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int CompareTo(
Object obj
)
VB
Public Function CompareTo (
obj As Object
) As Integer
Parameters
obj
Type: System.Object
An object to compare with this instance.
Return Value
Type: Int32
A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance precedes obj in the sort order. Zero This instance occurs in the same position in the sort order as obj. Greater than zero This instance follows obj in the sort order.
Implements
IComparable.CompareTo(Object)
Reference
AmsNetId Class
CompareTo Overload
TwinCAT.Ads Namespace


AmsNetId.CompareTo Method (AmsNetId)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.CompareTo Method [image] AmsNetId.CompareTo Method (AmsNetId)
AmsNetId.CompareTo Method (AmsNetId)
Compares the current object with another object of the same type.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int CompareTo(
AmsNetId other
)
VB
Public Function CompareTo (
other As AmsNetId
) As Integer
Parameters
other
Type: TwinCAT.Ads.AmsNetId
An object to compare with this object.
Return Value
Type: Int32
A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.
Implements
IComparable.T..CompareTo(T)
Reference
AmsNetId Class
CompareTo Overload
TwinCAT.Ads Namespace


AmsNetId.Equals Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.Equals Method
AmsNetId.Equals Method
Equals
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool Equals(
Object obj
)
VB
Public Overrides Function Equals (
obj As Object
) As Boolean
Parameters
obj
Type: System.Object
The object to compare with the current object.
Return Value
Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId.FromBinHexString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.FromBinHexString Method
AmsNetId.FromBinHexString Method
Creates the AmsNetId from bin hex string.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static AmsNetId FromBinHexString(
string str
)
VB
Public Shared Function FromBinHexString (
str As String
) As AmsNetId
Parameters
str
Type: System.String
The BinHex string.
Return Value
Type: AmsNetId
AmsNetId.
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId.GetHashCode Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.GetHashCode Method
AmsNetId.GetHashCode Method
Gets the HashCode of the Address
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override int GetHashCode()
VB
Public Overrides Function GetHashCode As Integer
Return Value
Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId.IsEqual Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.IsEqual Method
AmsNetId.IsEqual Method
Determines whether the specified AmsNetIds are equal.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool IsEqual(
AmsNetId netIDA,
AmsNetId netIDB
)
VB
Public Shared Function IsEqual (
netIDA As AmsNetId,
netIDB As AmsNetId
) As Boolean
Parameters
netIDA | Type: TwinCAT.Ads.AmsNetId The net IDA.
netIDB | Type: TwinCAT.Ads.AmsNetId The net IDB.
Return Value
Type: Boolean
true if the specified net IDA is equal; otherwise, false.
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId.IsSameTarget Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.IsSameTarget Method
AmsNetId.IsSameTarget Method
Determines whether the AmsNetIds refer to the same target.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool IsSameTarget(
AmsNetId netIDA,
AmsNetId netIDB
)
VB
Public Shared Function IsSameTarget (
netIDA As AmsNetId,
netIDB As AmsNetId
) As Boolean
Parameters
netIDA | Type: TwinCAT.Ads.AmsNetId NetID of target system A
netIDB | Type: TwinCAT.Ads.AmsNetId NetID of target system B
Return Value
Type: Boolean
true if the target systems are the same, otherwise false.
Remarks
In comparison to the IsEqual(AmsNetId, AmsNetId) or Equals(Object) methods, this Method alse checks against the LocalHost ID, which means that LocalHost is the same target as Local
Reference
AmsNetId Class
TwinCAT.Ads Namespace
AmsNetId.IsEqual(AmsNetId, AmsNetId)


AmsNetId.NetIdsEqual Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.NetIdsEqual Method
AmsNetId.NetIdsEqual Method
Overload List
Name | Description
NetIdsEqual(.Byte.) | Compares the netIds
NetIdsEqual(.Byte., .Byte.) | Compares the NetIds
Reference
AmsNetId Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsNetId.NetIdsEqual Method (.Byte.)
•
AmsNetId.NetIdsEqual Method (.Byte., .Byte.)


AmsNetId.NetIdsEqual Method (.Byte.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.NetIdsEqual Method [image] AmsNetId.NetIdsEqual Method (.Byte.)
AmsNetId.NetIdsEqual Method (.Byte.)
Compares the netIds
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool NetIdsEqual(
byte[] netId
)
VB
Public Function NetIdsEqual (
netId As Byte()
) As Boolean
Parameters
netId
Type: .System.Byte.
NetId in bytes.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
AmsNetId Class
NetIdsEqual Overload
TwinCAT.Ads Namespace


AmsNetId.NetIdsEqual Method (.Byte., .Byte.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.NetIdsEqual Method [image] AmsNetId.NetIdsEqual Method (.Byte., .Byte.)
AmsNetId.NetIdsEqual Method (.Byte., .Byte.)
Compares the NetIds
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool NetIdsEqual(
byte[] netId1,
byte[] netId2
)
VB
Public Shared Function NetIdsEqual (
netId1 As Byte(),
netId2 As Byte()
) As Boolean
Parameters
netId1 | Type: .System.Byte. NetID1
netId2 | Type: .System.Byte. NetId2
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
AmsNetId Class
NetIdsEqual Overload
TwinCAT.Ads Namespace


AmsNetId.Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.Parse Method
AmsNetId.Parse Method
Converts the string representation of the address to AmsNetId.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static AmsNetId Parse(
string str
)
VB
Public Shared Function Parse (
str As String
) As AmsNetId
Parameters
str
Type: System.String
The string to parse.
Return Value
Type: AmsNetId
AmsNetId.
Exceptions
Exception | Condition
FormatException | Format of AmsNetId is not valid!
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId.ToBinHex Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.ToBinHex Method
AmsNetId.ToBinHex Method
Overload List
Name | Description
ToBinHex. | Converts the AmsNetId to a BinHex string.
ToBinHex(AmsNetId) | Converts the specified AmsNetId to a BinHex string.
Reference
AmsNetId Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsNetId.ToBinHex Method
•
AmsNetId.ToBinHex Method (AmsNetId)


AmsNetId.ToBinHex Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.ToBinHex Method [image] AmsNetId.ToBinHex Method
AmsNetId.ToBinHex Method
Converts the AmsNetId to a BinHex string.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ToBinHex()
VB
Public Function ToBinHex As String
Return Value
Type: String
System.String.
Reference
AmsNetId Class
ToBinHex Overload
TwinCAT.Ads Namespace


AmsNetId.ToBinHex Method (AmsNetId)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.ToBinHex Method [image] AmsNetId.ToBinHex Method (AmsNetId)
AmsNetId.ToBinHex Method (AmsNetId)
Converts the specified AmsNetId to a BinHex string.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static string ToBinHex(
AmsNetId netId
)
VB
Public Shared Function ToBinHex (
netId As AmsNetId
) As String
Parameters
netId
Type: TwinCAT.Ads.AmsNetId
NetId to convert
Return Value
Type: String
System.String.
Reference
AmsNetId Class
ToBinHex Overload
TwinCAT.Ads Namespace


AmsNetId.ToBytes Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.ToBytes Method
AmsNetId.ToBytes Method
Converts the NetId object to byte array
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public byte[] ToBytes()
VB
Public Function ToBytes As Byte()
Return Value
Type: .Byte.
System.Byte[].
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.ToString Method
AmsNetId.ToString Method
Overload List
Name | Description
ToString. | Converts the netId to string (Overrides Object.ToString..)
ToString(String, IFormatProvider) | Returns a String that represents this instance.
Reference
AmsNetId Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsNetId.ToString Method
•
AmsNetId.ToString Method (String, IFormatProvider)


AmsNetId.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.ToString Method [image] AmsNetId.ToString Method
AmsNetId.ToString Method
Converts the netId to string
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
AmsNetId Class
ToString Overload
TwinCAT.Ads Namespace


AmsNetId.ToString Method (String, IFormatProvider)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.ToString Method [image] AmsNetId.ToString Method (String, IFormatProvider)
AmsNetId.ToString Method (String, IFormatProvider)
Returns a String that represents this instance.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ToString(
string format,
IFormatProvider formatProvider
)
VB
Public Function ToString (
format As String,
formatProvider As IFormatProvider
) As String
Parameters
format | Type: System.String The format.
formatProvider | Type: System.IFormatProvider The format provider.
Return Value
Type: String
A String that represents this instance.
Exceptions
Exception | Condition
FormatException |
Remarks
Formatting | Description
g | Standard formatting
x | Formatting as Hexadecimal (small letters)
X | Formatting as Hexadecimal (big letters)
Reference
AmsNetId Class
ToString Overload
TwinCAT.Ads Namespace


AmsNetId.TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Methods [image] AmsNetId.TryParse Method
AmsNetId.TryParse Method
Converts the string representation of the address to AmsNetId.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool TryParse(
string str,
out AmsNetId netId
)
VB
Public Shared Function TryParse (
str As String,
<OutAttribute> ByRef netId As AmsNetId
) As Boolean
Parameters
str | Type: System.String The string to parse.
netId | Type: TwinCAT.Ads.AmsNetId. The parsed AmsNetId.
Return Value
Type: Boolean
true if parsed, false otherwise.
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId Operators

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Operators
AmsNetId Operators
The AmsNetId type exposes the following members.
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Reference
AmsNetId Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsNetId.Equality Operator
•
AmsNetId.Inequality Operator


AmsNetId.Equality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Operators [image] AmsNetId.Equality Operator
AmsNetId.Equality Operator
Operator==
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator ==(
AmsNetId o1,
AmsNetId o2
)
VB
Public Shared Operator = (
o1 As AmsNetId,
o2 As AmsNetId
) As Boolean
Parameters
o1 | Type: TwinCAT.Ads.AmsNetId The o1.
o2 | Type: TwinCAT.Ads.AmsNetId The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsNetId.Inequality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsNetId Class [image] AmsNetId Operators [image] AmsNetId.Inequality Operator
AmsNetId.Inequality Operator
Implements the != operator.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator !=(
AmsNetId o1,
AmsNetId o2
)
VB
Public Shared Operator <> (
o1 As AmsNetId,
o2 As AmsNetId
) As Boolean
Parameters
o1 | Type: TwinCAT.Ads.AmsNetId The o1.
o2 | Type: TwinCAT.Ads.AmsNetId The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
AmsNetId Class
TwinCAT.Ads Namespace


AmsPort Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsPort Enumeration
AmsPort Enumeration
AmsPorts
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum AmsPort
VB
Public Enumeration AmsPort
Members
Member name | Value | Description
Router | 1 | AMS Router (Port 1)
Debugger | 2 | AMS Debugger (Port 2)
R0_TComServer | 10 | The TCom Server. Dpc or passive level.
R0_TComServerTask | 11 | TCom Serve Task. RT context.
R0_TComServer_PL | 12 | TCom Serve Task. Passive level.
R0_TcDebugger | 20 | TwinCAT Debugger
R0_TcDebuggerTask | 21 | TwinCAT Debugger Task
R0_LicenseServer | 30 | The License Server (Port 30)
Logger | 100 | Logger (Port 100)
EventLog | 110 | Event Logger (Port 110)
DeviceApplication | 120 | application for coupler (EK), gateway (EL), etc.
EventLog_UM | 130 | Event Logger UM
EventLog_RT | 131 | Event Logger RT
EventLogPublisher | 132 | Event Logger Publisher
R0_Realtime | 200 | R0 Realtime (Port 200)
R0_Trace | 290 | R0 Trace (Port 290)
R0_IO | 300 | R0 IO (Port 300)
R0_NC | 500 | NC (R0) (Port 500)
R0_NCSAF | 501 | R0 Satzausführung (Port 501)
R0_NCSVB | 511 | R0 Satzvorbereitung (Port 511)
R0_NCINSTANCE | 520 | Preconfigured Nc2-Nc3-Instance
R0_ISG | 550 | R0 ISG (Port 550)
R0_CNC | 600 | R0 CNC (Port 600)
R0_LINE | 700 | R0 Line (Port 700)
R0_PLC | 800 | R0 PLC (Port 800)
Tc2_Plc1 | 801 | Tc2 PLC RuntimeSystem 1 (Port 801)
Tc2_Plc2 | 811 | Tc2 PLC RuntimeSystem 2 (Port 811)
Tc2_Plc3 | 821 | Tc2 PLC RuntimeSystem 3 (Port 821)
Tc2_Plc4 | 831 | Tc2 PLC RuntimeSystem 4 (Port 831)
R0_RTS | 850 | R0 RTS (Port 850)
CamshaftController | 900 | Camshaft Controller (R0) (Port 900)
R0_CAMTOOL | 950 | R0 CAM Tool (Port 950)
R0_USER | 2000 | R0 User (Port 2000)
SystemService | 10000 | System Service (AMSPORT_R3_SYSSERV, 10000)
R3_CTRLPROG | 10000 | (Port 10000)
R3_SYSCTRL | 10001 | (Port 10001)
R3_SYSSAMPLER | 10100 | Port 10100
R3_TCPRAWCONN | 10200 | Port 10200
R3_TCPIPSERVER | 10201 | Port 10201
R3_SYSMANAGER | 10300 | Port 10300
R3_SMSSERVER | 10400 | Port 10400
R3_MODBUSSERVER | 10500 | Port 10500
R3_AMSLOGGER | 10502 | Port 10502
R3_S7SERVER | 10600 | Obsolete. Port 10600
R3_XMLDATASERVER | 10600 | Port 10600
R3_AUTOCONFIG | 10700 | Port 10700
R3_PLCCONTROL | 10800 | Port 10800
R3_FTPCLIENT | 10900 | Port 10900
R3_NCCTRL | 11000 | Port 11000
R3_NCINTERPRETER | 11500 | Port 11500
R3_GSTINTERPRETER | 11600 | Port 11600
R3_STRECKECTRL | 12000 | Port 12000
R3_CAMCTRL | 13000 | Port 13000
R3_SCOPE | 14000 | Port 14000
R3_CONDITIONMON | 14100 | Port 14100
R3_SINECH1 | 15000 | Port 15000
R3_CONTROLNET | 16000 | Port 16000
R3_OPCSERVER | 17000 | Port 17000
R3_OPCCLIENT | 17500 | Port 17500
R3_MAILSERVER | 18000 | Port 18000
R3_EL60XX | 19000 | Port 19000
R3_MANAGEMENT | 19100 | Port 19100
R3_MIELEHOME | 19200 | Port 19200
R3_CPLINK3 | 19300 | Port 19300
R3_VNSERVICE | 19500 | Port 19500
USEDEFAULT | 65535 |
Reference
TwinCAT.Ads Namespace


AmsRouterNotificationEventArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsRouterNotificationEventArgs Class
AmsRouterNotificationEventArgs Class
Provides data for AmsRouterNotificationEvent of the class TcAdsClient.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.Ads.AmsRouterNotificationEventArgs
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class AmsRouterNotificationEventArgs : EventArgs
VB
Public NotInheritable Class AmsRouterNotificationEventArgs
Inherits EventArgs
The AmsRouterNotificationEventArgs type exposes the following members.
Constructors
Name | Description
AmsRouterNotificationEventArgs | Initializes a new instance of the AmsRouterNotificationEventArgs class.
Properties
Name | Description
State | Current state of the AMS Router.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsRouterNotificationEventArgs Constructor
•
AmsRouterNotificationEventArgs Properties
•
AmsRouterNotificationEventArgs Methods


AmsRouterNotificationEventArgs Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsRouterNotificationEventArgs Class [image] AmsRouterNotificationEventArgs Constructor
AmsRouterNotificationEventArgs Constructor
Initializes a new instance of the AmsRouterNotificationEventArgs class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsRouterNotificationEventArgs(
AmsRouterState state
)
VB
Public Sub New (
state As AmsRouterState
)
Parameters
state
Type: TwinCAT.Ads.AmsRouterState
The current state of the Router.
Reference
AmsRouterNotificationEventArgs Class
TwinCAT.Ads Namespace


AmsRouterNotificationEventArgs Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsRouterNotificationEventArgs Class [image] AmsRouterNotificationEventArgs Properties
AmsRouterNotificationEventArgs Properties
The AmsRouterNotificationEventArgs type exposes the following members.
Properties
Name | Description
State | Current state of the AMS Router.
Reference
AmsRouterNotificationEventArgs Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
AmsRouterNotificationEventArgs.State Property


AmsRouterNotificationEventArgs.State Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsRouterNotificationEventArgs Class [image] AmsRouterNotificationEventArgs Properties [image] AmsRouterNotificationEventArgs.State Property
AmsRouterNotificationEventArgs.State Property
Current state of the AMS Router.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsRouterState State { get; }
VB
Public ReadOnly Property State As AmsRouterState
Get
Property Value
Type: AmsRouterState
Reference
AmsRouterNotificationEventArgs Class
TwinCAT.Ads Namespace


AmsRouterNotificationEventArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsRouterNotificationEventArgs Class [image] AmsRouterNotificationEventArgs Methods
AmsRouterNotificationEventArgs Methods
The AmsRouterNotificationEventArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
AmsRouterNotificationEventArgs Class
TwinCAT.Ads Namespace


AmsRouterNotificationEventHandler Delegate

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsRouterNotificationEventHandler Delegate
AmsRouterNotificationEventHandler Delegate
Event handler for the AmsRouterNotification event in the class TcAdsClient.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public delegate void AmsRouterNotificationEventHandler(
Object sender,
AmsRouterNotificationEventArgs e
)
VB
Public Delegate Sub AmsRouterNotificationEventHandler (
sender As Object,
e As AmsRouterNotificationEventArgs
)
Parameters
sender | Type: System.Object
e | Type: TwinCAT.Ads.AmsRouterNotificationEventArgs
Reference
TwinCAT.Ads Namespace


AmsRouterState Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] AmsRouterState Enumeration
AmsRouterState Enumeration
State of the AMS Router.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum AmsRouterState
VB
Public Enumeration AmsRouterState
Members
Member name | Value | Description
Unknown | -1 | Unknown Router State
Stop | 0 | AMS Router is stopped.
Start | 1 | AMS Router is started.
Removed | 2 | AMS Router has been removed.
Reference
TwinCAT.Ads Namespace


DeviceInfo Structure

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] DeviceInfo Structure
DeviceInfo Structure
The structure contains the name and the version information of the device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public struct DeviceInfo
VB
Public Structure DeviceInfo
The DeviceInfo type exposes the following members.
Properties
Name | Description
IsEmpty | Gets a value indicating whether this instance is empty.
Name | Gets or sets the name of the device.
Version | Gets or sets the version information.
Methods
Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
DeviceInfo Properties
•
DeviceInfo Methods


DeviceInfo Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] DeviceInfo Structure [image] DeviceInfo Properties
DeviceInfo Properties
The DeviceInfo type exposes the following members.
Properties
Name | Description
IsEmpty | Gets a value indicating whether this instance is empty.
Name | Gets or sets the name of the device.
Version | Gets or sets the version information.
Reference
DeviceInfo Structure
TwinCAT.Ads Namespace
Weiterführende Informationen
•
DeviceInfo.IsEmpty Property
•
DeviceInfo.Name Property
•
DeviceInfo.Version Property


DeviceInfo.IsEmpty Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] DeviceInfo Structure [image] DeviceInfo Properties [image] DeviceInfo.IsEmpty Property
DeviceInfo.IsEmpty Property
Gets a value indicating whether this instance is empty.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsEmpty { get; }
VB
Public ReadOnly Property IsEmpty As Boolean
Get
Property Value
Type: Boolean
true if this instance is empty; otherwise, false.
Reference
DeviceInfo Structure
TwinCAT.Ads Namespace


DeviceInfo.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] DeviceInfo Structure [image] DeviceInfo Properties [image] DeviceInfo.Name Property
DeviceInfo.Name Property
Gets or sets the name of the device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Name { get; set; }
VB
Public Property Name As String
Get
Set
Property Value
Type: String
Reference
DeviceInfo Structure
TwinCAT.Ads Namespace


DeviceInfo.Version Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] DeviceInfo Structure [image] DeviceInfo Properties [image] DeviceInfo.Version Property
DeviceInfo.Version Property
Gets or sets the version information.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsVersion Version { get; set; }
VB
Public Property Version As AdsVersion
Get
Set
Property Value
Type: AdsVersion
Reference
DeviceInfo Structure
TwinCAT.Ads Namespace


DeviceInfo Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] DeviceInfo Structure [image] DeviceInfo Methods
DeviceInfo Methods
The DeviceInfo type exposes the following members.
Methods
Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Reference
DeviceInfo Structure
TwinCAT.Ads Namespace


IAdsAnyAccess Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface
IAdsAnyAccess Interface
Interface for accessing ADS 'Any' objects.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IAdsAnyAccess
VB
Public Interface IAdsAnyAccess
Methods
Name | Description
ReadAny(Int32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(Int32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
ReadAnyString(Int32, Int32, Encoding) | Reads the string.
ReadAnyString(UInt32, UInt32, Int32, Encoding) | Reads the string
WriteAny(Int32, Object) | Writes an object synchronously to an ADS device.
WriteAny(Int32, Object, .Int32.) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
WriteAny(UInt32, UInt32, Object) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object, .Int32.) | Writes an object synchronously to an ADS device.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsAnyAccess Methods


IAdsAnyAccess Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods
IAdsAnyAccess Methods
Methods
Name | Description
ReadAny(Int32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(Int32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
ReadAnyString(Int32, Int32, Encoding) | Reads the string.
ReadAnyString(UInt32, UInt32, Int32, Encoding) | Reads the string
WriteAny(Int32, Object) | Writes an object synchronously to an ADS device.
WriteAny(Int32, Object, .Int32.) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
WriteAny(UInt32, UInt32, Object) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object, .Int32.) | Writes an object synchronously to an ADS device.
Reference
IAdsAnyAccess Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsAnyAccess.ReadAny Method
•
IAdsAnyAccess.ReadAnyString Method
•
IAdsAnyAccess.WriteAny Method


IAdsAnyAccess.ReadAny Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.ReadAny Method
IAdsAnyAccess.ReadAny Method
Overload List
Name | Description
ReadAny(Int32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(Int32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
Reference
IAdsAnyAccess Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsAnyAccess.ReadAny Method (Int32, Type)
•
IAdsAnyAccess.ReadAny Method (Int32, Type, .Int32.)
•
IAdsAnyAccess.ReadAny Method (UInt32, UInt32, Type)
•
IAdsAnyAccess.ReadAny Method (UInt32, UInt32, Type, .Int32.)


IAdsAnyAccess.ReadAny Method (Int32, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.ReadAny Method [image] IAdsAnyAccess.ReadAny Method (Int32, Type)
IAdsAnyAccess.ReadAny Method (Int32, Type)
Reads data synchronously from an ADS device and writes it to an object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object ReadAny(
int variableHandle,
Type type
)
VB
Function ReadAny (
variableHandle As Integer,
type As Type
) As Object
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable.
type | Type: System.Type Type of the object to be read.
Return Value
Type: Object
The object the read data is written to.
Reference
IAdsAnyAccess Interface
ReadAny Overload
TwinCAT.Ads Namespace


IAdsAnyAccess.ReadAny Method (Int32, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.ReadAny Method [image] IAdsAnyAccess.ReadAny Method (Int32, Type, .Int32.)
IAdsAnyAccess.ReadAny Method (Int32, Type, .Int32.)
Reads data synchronously from an ADS device and writes it to an object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object ReadAny(
int variableHandle,
Type type,
int[] args
)
VB
Function ReadAny (
variableHandle As Integer,
type As Type,
args As Integer()
) As Object
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable.
type | Type: System.Type Type of the object to be read.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Object
The object the read data is written to.
Remarks
If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Reference
IAdsAnyAccess Interface
ReadAny Overload
TwinCAT.Ads Namespace


IAdsAnyAccess.ReadAny Method (UInt32, UInt32, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.ReadAny Method [image] IAdsAnyAccess.ReadAny Method (UInt32, UInt32, Type)
IAdsAnyAccess.ReadAny Method (UInt32, UInt32, Type)
Reads data synchronously from an ADS device and writes it to an object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object ReadAny(
uint indexGroup,
uint indexOffset,
Type type
)
VB
Function ReadAny (
indexGroup As UInteger,
indexOffset As UInteger,
type As Type
) As Object
Parameters
indexGroup | Type: System.UInt32 Index group of the ADS variable.
indexOffset | Type: System.UInt32 Index offset of the ADS variable.
type | Type: System.Type Type of the object to be read.
Return Value
Type: Object
The object the read data is written to.
Reference
IAdsAnyAccess Interface
ReadAny Overload
TwinCAT.Ads Namespace


IAdsAnyAccess.ReadAny Method (UInt32, UInt32, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.ReadAny Method [image] IAdsAnyAccess.ReadAny Method (UInt32, UInt32, Type, .Int32.)
IAdsAnyAccess.ReadAny Method (UInt32, UInt32, Type, .Int32.)
Reads data synchronously from an ADS device and writes it to an object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object ReadAny(
uint indexGroup,
uint indexOffset,
Type type,
int[] args
)
VB
Function ReadAny (
indexGroup As UInteger,
indexOffset As UInteger,
type As Type,
args As Integer()
) As Object
Parameters
indexGroup | Type: System.UInt32 Index group of the ADS variable.
indexOffset | Type: System.UInt32 Index offset of the ADS variable.
type | Type: System.Type Type of the object to be read.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Object
The object the read data is written to.
Remarks
If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Reference
IAdsAnyAccess Interface
ReadAny Overload
TwinCAT.Ads Namespace


IAdsAnyAccess.ReadAnyString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.ReadAnyString Method
IAdsAnyAccess.ReadAnyString Method
Overload List
Name | Description
ReadAnyString(Int32, Int32, Encoding) | Reads the string.
ReadAnyString(UInt32, UInt32, Int32, Encoding) | Reads the string
Reference
IAdsAnyAccess Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsAnyAccess.ReadAnyString Method (Int32, Int32, Encoding)
•
IAdsAnyAccess.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)


IAdsAnyAccess.ReadAnyString Method (Int32, Int32, Encoding)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.ReadAnyString Method [image] IAdsAnyAccess.ReadAnyString Method (Int32, Int32, Encoding)
IAdsAnyAccess.ReadAnyString Method (Int32, Int32, Encoding)
Reads the string.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string ReadAnyString(
int variableHandle,
int len,
Encoding encoding
)
VB
Function ReadAnyString (
variableHandle As Integer,
len As Integer,
encoding As Encoding
) As String
Parameters
variableHandle | Type: System.Int32 The variable handle.
len | Type: System.Int32 The length.
encoding | Type: System.Text.Encoding The encoding.
Return Value
Type: String
System.String.
Reference
IAdsAnyAccess Interface
ReadAnyString Overload
TwinCAT.Ads Namespace


IAdsAnyAccess.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.ReadAnyString Method [image] IAdsAnyAccess.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)
IAdsAnyAccess.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)
Reads the string
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string ReadAnyString(
uint indexGroup,
uint indexOffset,
int len,
Encoding encoding
)
VB
Function ReadAnyString (
indexGroup As UInteger,
indexOffset As UInteger,
len As Integer,
encoding As Encoding
) As String
Parameters
indexGroup | Type: System.UInt32 The index group.
indexOffset | Type: System.UInt32 The index offset.
len | Type: System.Int32 The length.
encoding | Type: System.Text.Encoding The encoding.
Return Value
Type: String
System.String.
Remarks
ASCII Encoding expected
Reference
IAdsAnyAccess Interface
ReadAnyString Overload
TwinCAT.Ads Namespace


IAdsAnyAccess.WriteAny Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.WriteAny Method
IAdsAnyAccess.WriteAny Method
Overload List
Name | Description
WriteAny(Int32, Object) | Writes an object synchronously to an ADS device.
WriteAny(Int32, Object, .Int32.) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
WriteAny(UInt32, UInt32, Object) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object, .Int32.) | Writes an object synchronously to an ADS device.
Reference
IAdsAnyAccess Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsAnyAccess.WriteAny Method (Int32, Object)
•
IAdsAnyAccess.WriteAny Method (Int32, Object, .Int32.)
•
IAdsAnyAccess.WriteAny Method (UInt32, UInt32, Object)
•
IAdsAnyAccess.WriteAny Method (UInt32, UInt32, Object, .Int32.)


IAdsAnyAccess.WriteAny Method (Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.WriteAny Method [image] IAdsAnyAccess.WriteAny Method (Int32, Object)
IAdsAnyAccess.WriteAny Method (Int32, Object)
Writes an object synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void WriteAny(
int variableHandle,
Object value
)
VB
Sub WriteAny (
variableHandle As Integer,
value As Object
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable.
value | Type: System.Object Object to write to the ADS device.
Reference
IAdsAnyAccess Interface
WriteAny Overload
TwinCAT.Ads Namespace


IAdsAnyAccess.WriteAny Method (Int32, Object, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.WriteAny Method [image] IAdsAnyAccess.WriteAny Method (Int32, Object, .Int32.)
IAdsAnyAccess.WriteAny Method (Int32, Object, .Int32.)
Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void WriteAny(
int variableHandle,
Object value,
int[] args
)
VB
Sub WriteAny (
variableHandle As Integer,
value As Object,
args As Integer()
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable.
value | Type: System.Object Object to write to the ADS device.
args | Type: .System.Int32. Additional arguments.
Reference
IAdsAnyAccess Interface
WriteAny Overload
TwinCAT.Ads Namespace


IAdsAnyAccess.WriteAny Method (UInt32, UInt32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.WriteAny Method [image] IAdsAnyAccess.WriteAny Method (UInt32, UInt32, Object)
IAdsAnyAccess.WriteAny Method (UInt32, UInt32, Object)
Writes an object synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void WriteAny(
uint indexGroup,
uint indexOffset,
Object value
)
VB
Sub WriteAny (
indexGroup As UInteger,
indexOffset As UInteger,
value As Object
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
value | Type: System.Object Object to write to the ADS device.
Reference
IAdsAnyAccess Interface
WriteAny Overload
TwinCAT.Ads Namespace


IAdsAnyAccess.WriteAny Method (UInt32, UInt32, Object, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsAnyAccess Interface [image] IAdsAnyAccess Methods [image] IAdsAnyAccess.WriteAny Method [image] IAdsAnyAccess.WriteAny Method (UInt32, UInt32, Object, .Int32.)
IAdsAnyAccess.WriteAny Method (UInt32, UInt32, Object, .Int32.)
Writes an object synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void WriteAny(
uint indexGroup,
uint indexOffset,
Object value,
int[] args
)
VB
Sub WriteAny (
indexGroup As UInteger,
indexOffset As UInteger,
value As Object,
args As Integer()
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
value | Type: System.Object Object to write to the ADS device.
args | Type: .System.Int32. Additional arguments.
Remarks
If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
Reference
IAdsAnyAccess Interface
WriteAny Overload
TwinCAT.Ads Namespace


IAdsConnection Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsConnection Interface
IAdsConnection Interface
ADS Connection interface
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IAdsConnection : IConnection,
IConnectionStateProvider, IAdsNotifications, IAdsAnyAccess, IAdsHandleAccess, ITcAdsRpcInvoke
VB
Public Interface IAdsConnection
Inherits IConnection, IConnectionStateProvider, IAdsNotifications, IAdsAnyAccess,
IAdsHandleAccess, ITcAdsRpcInvoke
The IAdsConnection type exposes the following members.
Properties
Name | Description
Address | Gets the AmsAddress of the ADS server.
ClientAddress | Get the AmsAddress of the ADS client.
ConnectionState | Gets the current Connection state of the IConnectionStateProvider (Inherited from IConnectionStateProvider.)
Id | Gets the Connection Identifier . (Inherited from IConnection.)
IsConnected | Gets a value indicating whether the local ADS port was opened successfully. It does not indicate if the target port is available. Use the method ReadState to determine if the target port is available. (Inherited from IConnection.)
IsLocal | Gets a value indicating whether the ADS client is connected to a ADS Server on the local computer.
Session | Gets the session that initiated this IConnection (Inherited from IConnection.)
Timeout | Gets the timeout (in milliseconds) (Inherited from IConnection.)
Methods
Name | Description
AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported. (Inherited from IAdsNotifications.)
Close | Closes this IConnection (Inherited from IConnection.)
Connect | (Re)Connects the IConnection when disconnected. (Inherited from IConnection.)
CreateVariableHandle | Generates a unique handle for an ADS variable. (Inherited from IAdsHandleAccess.)
DeleteDeviceNotification | Deletes an existing notification. (Inherited from IAdsNotifications.)
DeleteVariableHandle | Releases the handle of a ADS variable again. (Inherited from IAdsHandleAccess.)
Disconnect | Disconnects this IConnection. (Inherited from IConnection.)
InvokeRpcMethod(String, Int32, .Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
InvokeRpcMethod(String, String, .Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
InvokeRpcMethod(ITcAdsSymbol, String, .Object.) | Invokes the specified RPC Method. (Inherited from ITcAdsRpcInvoke.)
Read(Int32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream. (Inherited from IAdsHandleAccess.)
Read(Int32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream. (Inherited from IAdsHandleAccess.)
ReadAny(Int32, Type) | Reads data synchronously from an ADS device and writes it to an object. (Inherited from IAdsAnyAccess.)
ReadAny(Int32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object. (Inherited from IAdsAnyAccess.)
ReadAny(UInt32, UInt32, Type) | Reads data synchronously from an ADS device and writes it to an object. (Inherited from IAdsAnyAccess.)
ReadAny(UInt32, UInt32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object. (Inherited from IAdsAnyAccess.)
ReadAnyString(Int32, Int32, Encoding) | Reads the string. (Inherited from IAdsAnyAccess.)
ReadAnyString(UInt32, UInt32, Int32, Encoding) | Reads the string (Inherited from IAdsAnyAccess.)
ReadDeviceInfo | Reads the identification and version number of an ADS server.
ReadWrite | Writes data synchronously to an ADS device and then Reads data from this device. (Inherited from IAdsHandleAccess.)
TryAddDeviceNotification | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
TryAddDeviceNotificationEx | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
TryDeleteDeviceNotification | Deletes an existing notification. (Inherited from IAdsNotifications.)
TryInvokeRpcMethod(String, Int32, .Object., Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
TryInvokeRpcMethod(String, String, .Object., Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.) | Invokes the specified RPC Method. (Inherited from ITcAdsRpcInvoke.)
TryRead | Reads data synchronously from an ADS device and writes it to the given stream. (Inherited from IAdsHandleAccess.)
TryReadWrite | Writes data synchronously to an ADS device and then Reads data from this device. (Inherited from IAdsHandleAccess.)
TryWrite | Writes data synchronously to an ADS device. (Inherited from IAdsHandleAccess.)
Write(Int32, AdsStream) | Writes data synchronously to an ADS device. (Inherited from IAdsHandleAccess.)
Write(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device. (Inherited from IAdsHandleAccess.)
WriteAny(Int32, Object) | Writes an object synchronously to an ADS device. (Inherited from IAdsAnyAccess.)
WriteAny(Int32, Object, .Int32.) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string. (Inherited from IAdsAnyAccess.)
WriteAny(UInt32, UInt32, Object) | Writes an object synchronously to an ADS device. (Inherited from IAdsAnyAccess.)
WriteAny(UInt32, UInt32, Object, .Int32.) | Writes an object synchronously to an ADS device. (Inherited from IAdsAnyAccess.)
Events
Name | Description
AdsNotification | Occurs when the ADS device sends a notification to the client. (Inherited from IAdsNotifications.)
AdsNotificationError | Occurs when a exception has occurred during notification management. (Inherited from IAdsNotifications.)
AdsNotificationEx | Occurs when the ADS devices sends a notification to the client. (Inherited from IAdsNotifications.)
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed. (Inherited from IConnectionStateProvider.)
Extension Methods
Name | Description
PollAdsState(IObservable.Unit.) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollAdsState(TimeSpan) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollValues(String, Type, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
WhenNotification(ISymbol) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenNotification(ISymbol, NotificationSettings) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection, NotificationSettings) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenValueChanged | Observable sequence of Values driven by ADS Notifications on the specified symbol. (Defined by ValueSymbolExtensions.)
WriteValues.T.(String, IObservable.T.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
WriteValues.T.(String, IObservable.T., Action.Exception.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
Remarks
The ADS connection interface represents the the logical point-to-point exception between Client and Server within an ADS Session.
Reference
TwinCAT.Ads Namespace
TwinCAT.IConnection
TwinCAT.Ads.IAdsAnyAccess
TwinCAT.Ads.IAdsHandleAccess
Weiterführende Informationen
•
IAdsConnection Properties
•
IAdsConnection Methods
•
IAdsConnection Events


IAdsConnection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsConnection Interface [image] IAdsConnection Properties
IAdsConnection Properties
The IAdsConnection type exposes the following members.
Properties
Name | Description
Address | Gets the AmsAddress of the ADS server.
ClientAddress | Get the AmsAddress of the ADS client.
ConnectionState | Gets the current Connection state of the IConnectionStateProvider (Inherited from IConnectionStateProvider.)
Id | Gets the Connection Identifier . (Inherited from IConnection.)
IsConnected | Gets a value indicating whether the local ADS port was opened successfully. It does not indicate if the target port is available. Use the method ReadState to determine if the target port is available. (Inherited from IConnection.)
IsLocal | Gets a value indicating whether the ADS client is connected to a ADS Server on the local computer.
Session | Gets the session that initiated this IConnection (Inherited from IConnection.)
Timeout | Gets the timeout (in milliseconds) (Inherited from IConnection.)
Reference
IAdsConnection Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsConnection.Address Property
•
IAdsConnection.ClientAddress Property
•
IAdsConnection.IsLocal Property


IAdsConnection.Address Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsConnection Interface [image] IAdsConnection Properties [image] IAdsConnection.Address Property
IAdsConnection.Address Property
Gets the AmsAddress of the ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AmsAddress Address { get; }
VB
ReadOnly Property Address As AmsAddress
Get
Property Value
Type: AmsAddress
Reference
IAdsConnection Interface
TwinCAT.Ads Namespace


IAdsConnection.ClientAddress Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsConnection Interface [image] IAdsConnection Properties [image] IAdsConnection.ClientAddress Property
IAdsConnection.ClientAddress Property
Get the AmsAddress of the ADS client.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AmsAddress ClientAddress { get; }
VB
ReadOnly Property ClientAddress As AmsAddress
Get
Property Value
Type: AmsAddress
Reference
IAdsConnection Interface
TwinCAT.Ads Namespace


IAdsConnection.IsLocal Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsConnection Interface [image] IAdsConnection Properties [image] IAdsConnection.IsLocal Property
IAdsConnection.IsLocal Property
Gets a value indicating whether the ADS client is connected to a ADS Server on the local computer.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsLocal { get; }
VB
ReadOnly Property IsLocal As Boolean
Get
Property Value
Type: Boolean
Reference
IAdsConnection Interface
TwinCAT.Ads Namespace


IAdsConnection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsConnection Interface [image] IAdsConnection Methods
IAdsConnection Methods
The IAdsConnection type exposes the following members.
Methods
Name | Description
AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported. (Inherited from IAdsNotifications.)
Close | Closes this IConnection (Inherited from IConnection.)
Connect | (Re)Connects the IConnection when disconnected. (Inherited from IConnection.)
CreateVariableHandle | Generates a unique handle for an ADS variable. (Inherited from IAdsHandleAccess.)
DeleteDeviceNotification | Deletes an existing notification. (Inherited from IAdsNotifications.)
DeleteVariableHandle | Releases the handle of a ADS variable again. (Inherited from IAdsHandleAccess.)
Disconnect | Disconnects this IConnection. (Inherited from IConnection.)
InvokeRpcMethod(String, Int32, .Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
InvokeRpcMethod(String, String, .Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
InvokeRpcMethod(ITcAdsSymbol, String, .Object.) | Invokes the specified RPC Method. (Inherited from ITcAdsRpcInvoke.)
Read(Int32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream. (Inherited from IAdsHandleAccess.)
Read(Int32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream. (Inherited from IAdsHandleAccess.)
ReadAny(Int32, Type) | Reads data synchronously from an ADS device and writes it to an object. (Inherited from IAdsAnyAccess.)
ReadAny(Int32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object. (Inherited from IAdsAnyAccess.)
ReadAny(UInt32, UInt32, Type) | Reads data synchronously from an ADS device and writes it to an object. (Inherited from IAdsAnyAccess.)
ReadAny(UInt32, UInt32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object. (Inherited from IAdsAnyAccess.)
ReadAnyString(Int32, Int32, Encoding) | Reads the string. (Inherited from IAdsAnyAccess.)
ReadAnyString(UInt32, UInt32, Int32, Encoding) | Reads the string (Inherited from IAdsAnyAccess.)
ReadDeviceInfo | Reads the identification and version number of an ADS server.
ReadWrite | Writes data synchronously to an ADS device and then Reads data from this device. (Inherited from IAdsHandleAccess.)
TryAddDeviceNotification | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
TryAddDeviceNotificationEx | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. (Inherited from IAdsNotifications.)
TryDeleteDeviceNotification | Deletes an existing notification. (Inherited from IAdsNotifications.)
TryInvokeRpcMethod(String, Int32, .Object., Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
TryInvokeRpcMethod(String, String, .Object., Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.) | Invokes the specified RPC Method (Inherited from ITcAdsRpcInvoke.)
TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.) | Invokes the specified RPC Method. (Inherited from ITcAdsRpcInvoke.)
TryRead | Reads data synchronously from an ADS device and writes it to the given stream. (Inherited from IAdsHandleAccess.)
TryReadWrite | Writes data synchronously to an ADS device and then Reads data from this device. (Inherited from IAdsHandleAccess.)
TryWrite | Writes data synchronously to an ADS device. (Inherited from IAdsHandleAccess.)
Write(Int32, AdsStream) | Writes data synchronously to an ADS device. (Inherited from IAdsHandleAccess.)
Write(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device. (Inherited from IAdsHandleAccess.)
WriteAny(Int32, Object) | Writes an object synchronously to an ADS device. (Inherited from IAdsAnyAccess.)
WriteAny(Int32, Object, .Int32.) | Writes an object synchronously to an ADS device. If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string. (Inherited from IAdsAnyAccess.)
WriteAny(UInt32, UInt32, Object) | Writes an object synchronously to an ADS device. (Inherited from IAdsAnyAccess.)
WriteAny(UInt32, UInt32, Object, .Int32.) | Writes an object synchronously to an ADS device. (Inherited from IAdsAnyAccess.)
Extension Methods
Name | Description
PollAdsState(IObservable.Unit.) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollAdsState(TimeSpan) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollValues(String, Type, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
WhenNotification(ISymbol) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenNotification(ISymbol, NotificationSettings) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection, NotificationSettings) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenValueChanged | Observable sequence of Values driven by ADS Notifications on the specified symbol. (Defined by ValueSymbolExtensions.)
WriteValues.T.(String, IObservable.T.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
WriteValues.T.(String, IObservable.T., Action.Exception.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
Reference
IAdsConnection Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsConnection.ReadDeviceInfo Method


IAdsConnection.ReadDeviceInfo Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsConnection Interface [image] IAdsConnection Methods [image] IAdsConnection.ReadDeviceInfo Method
IAdsConnection.ReadDeviceInfo Method
Reads the identification and version number of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
DeviceInfo ReadDeviceInfo()
VB
Function ReadDeviceInfo As DeviceInfo
Return Value
Type: DeviceInfo
DeviceInfo struct containing the name of the device and the version information.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsConnection Interface
TwinCAT.Ads Namespace


IAdsConnection Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsConnection Interface [image] IAdsConnection Events
IAdsConnection Events
The IAdsConnection type exposes the following members.
Events
Name | Description
AdsNotification | Occurs when the ADS device sends a notification to the client. (Inherited from IAdsNotifications.)
AdsNotificationError | Occurs when a exception has occurred during notification management. (Inherited from IAdsNotifications.)
AdsNotificationEx | Occurs when the ADS devices sends a notification to the client. (Inherited from IAdsNotifications.)
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed. (Inherited from IConnectionStateProvider.)
Reference
IAdsConnection Interface
TwinCAT.Ads Namespace


IAdsHandleAccess Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface
IAdsHandleAccess Interface
Interface for ads access via variable handle
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IAdsHandleAccess
VB
Public Interface IAdsHandleAccess
The IAdsHandleAccess type exposes the following members.
Methods
Name | Description
CreateVariableHandle | Generates a unique handle for an ADS variable.
DeleteVariableHandle | Releases the handle of a ADS variable again.
Read(Int32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(Int32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
ReadWrite | Writes data synchronously to an ADS device and then Reads data from this device.
TryRead | Reads data synchronously from an ADS device and writes it to the given stream.
TryReadWrite | Writes data synchronously to an ADS device and then Reads data from this device.
TryWrite | Writes data synchronously to an ADS device.
Write(Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsHandleAccess Methods


IAdsHandleAccess Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods
IAdsHandleAccess Methods
The IAdsHandleAccess type exposes the following members.
Methods
Name | Description
CreateVariableHandle | Generates a unique handle for an ADS variable.
DeleteVariableHandle | Releases the handle of a ADS variable again.
Read(Int32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(Int32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
ReadWrite | Writes data synchronously to an ADS device and then Reads data from this device.
TryRead | Reads data synchronously from an ADS device and writes it to the given stream.
TryReadWrite | Writes data synchronously to an ADS device and then Reads data from this device.
TryWrite | Writes data synchronously to an ADS device.
Write(Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Reference
IAdsHandleAccess Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsHandleAccess.CreateVariableHandle Method
•
IAdsHandleAccess.DeleteVariableHandle Method
•
IAdsHandleAccess.Read Method
•
IAdsHandleAccess.ReadWrite Method
•
IAdsHandleAccess.TryRead Method
•
IAdsHandleAccess.TryReadWrite Method
•
IAdsHandleAccess.TryWrite Method
•
IAdsHandleAccess.Write Method


IAdsHandleAccess.CreateVariableHandle Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.CreateVariableHandle Method
IAdsHandleAccess.CreateVariableHandle Method
Generates a unique handle for an ADS variable.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int CreateVariableHandle(
string variableName
)
VB
Function CreateVariableHandle (
variableName As String
) As Integer
Parameters
variableName
Type: System.String
Name of the ADS variable
Return Value
Type: Int32
The handle of the ADS Variable.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsHandleAccess Interface
TwinCAT.Ads Namespace


IAdsHandleAccess.DeleteVariableHandle Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.DeleteVariableHandle Method
IAdsHandleAccess.DeleteVariableHandle Method
Releases the handle of a ADS variable again.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void DeleteVariableHandle(
int variableHandle
)
VB
Sub DeleteVariableHandle (
variableHandle As Integer
)
Parameters
variableHandle
Type: System.Int32
Handle of the ADS variable
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsHandleAccess Interface
TwinCAT.Ads Namespace


IAdsHandleAccess.Read Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.Read Method
IAdsHandleAccess.Read Method
Overload List
Name | Description
Read(Int32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(Int32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Reference
IAdsHandleAccess Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsHandleAccess.Read Method (Int32, AdsStream)
•
IAdsHandleAccess.Read Method (Int32, AdsStream, Int32, Int32)


IAdsHandleAccess.Read Method (Int32, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.Read Method [image] IAdsHandleAccess.Read Method (Int32, AdsStream)
IAdsHandleAccess.Read Method (Int32, AdsStream)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Read(
int variableHandle,
AdsStream dataStream
)
VB
Function Read (
variableHandle As Integer,
dataStream As AdsStream
) As Integer
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
Return Value
Type: Int32
Number of successfully returned data bytes.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsHandleAccess Interface
Read Overload
TwinCAT.Ads Namespace


IAdsHandleAccess.Read Method (Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.Read Method [image] IAdsHandleAccess.Read Method (Int32, AdsStream, Int32, Int32)
IAdsHandleAccess.Read Method (Int32, AdsStream, Int32, Int32)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Read(
int variableHandle,
AdsStream dataStream,
int offset,
int length
)
VB
Function Read (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As Integer
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsHandleAccess Interface
Read Overload
TwinCAT.Ads Namespace


IAdsHandleAccess.ReadWrite Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.ReadWrite Method
IAdsHandleAccess.ReadWrite Method
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int ReadWrite(
int variableHandle,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength
)
VB
Function ReadWrite (
variableHandle As Integer,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer
) As Integer
Parameters
variableHandle | Type: System.Int32 Variable handle.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsHandleAccess Interface
TwinCAT.Ads Namespace


IAdsHandleAccess.TryRead Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.TryRead Method
IAdsHandleAccess.TryRead Method
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode TryRead(
int variableHandle,
AdsStream dataStream,
int offset,
int length,
out int readBytes
)
VB
Function TryRead (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
readBytes | Type: System.Int32. Number of successfully returned data bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode
Exceptions
Exception | Condition
ArgumentException |
Reference
IAdsHandleAccess Interface
TwinCAT.Ads Namespace


IAdsHandleAccess.TryReadWrite Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.TryReadWrite Method
IAdsHandleAccess.TryReadWrite Method
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode TryReadWrite(
int variableHandle,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength,
out int readBytes
)
VB
Function TryReadWrite (
variableHandle As Integer,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
variableHandle | Type: System.Int32 Variable handle.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ArgumentException |
Reference
IAdsHandleAccess Interface
TwinCAT.Ads Namespace


IAdsHandleAccess.TryWrite Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.TryWrite Method
IAdsHandleAccess.TryWrite Method
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode TryWrite(
int variableHandle,
AdsStream dataStream,
int offset,
int length
)
VB
Function TryWrite (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As AdsErrorCode
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ArgumentException |
Reference
IAdsHandleAccess Interface
TwinCAT.Ads Namespace


IAdsHandleAccess.Write Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.Write Method
IAdsHandleAccess.Write Method
Overload List
Name | Description
Write(Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Reference
IAdsHandleAccess Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsHandleAccess.Write Method (Int32, AdsStream)
•
IAdsHandleAccess.Write Method (Int32, AdsStream, Int32, Int32)


IAdsHandleAccess.Write Method (Int32, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.Write Method [image] IAdsHandleAccess.Write Method (Int32, AdsStream)
IAdsHandleAccess.Write Method (Int32, AdsStream)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void Write(
int variableHandle,
AdsStream dataStream
)
VB
Sub Write (
variableHandle As Integer,
dataStream As AdsStream
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsHandleAccess Interface
Write Overload
TwinCAT.Ads Namespace


IAdsHandleAccess.Write Method (Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsHandleAccess Interface [image] IAdsHandleAccess Methods [image] IAdsHandleAccess.Write Method [image] IAdsHandleAccess.Write Method (Int32, AdsStream, Int32, Int32)
IAdsHandleAccess.Write Method (Int32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void Write(
int variableHandle,
AdsStream dataStream,
int offset,
int length
)
VB
Sub Write (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsHandleAccess Interface
Write Overload
TwinCAT.Ads Namespace


IAdsNotifications Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface
IAdsNotifications Interface
Interface for Notification management.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IAdsNotifications
VB
Public Interface IAdsNotifications
The IAdsNotifications type exposes the following members.
Methods
Name | Description
AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
DeleteDeviceNotification | Deletes an existing notification.
TryAddDeviceNotification | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryAddDeviceNotificationEx | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryDeleteDeviceNotification | Deletes an existing notification.
Events
Name | Description
AdsNotification | Occurs when the ADS device sends a notification to the client.
AdsNotificationError | Occurs when a exception has occurred during notification management.
AdsNotificationEx | Occurs when the ADS devices sends a notification to the client.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsNotifications Methods
•
IAdsNotifications Events


IAdsNotifications Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods
IAdsNotifications Methods
The IAdsNotifications type exposes the following members.
Methods
Name | Description
AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
DeleteDeviceNotification | Deletes an existing notification.
TryAddDeviceNotification | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryAddDeviceNotificationEx | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryDeleteDeviceNotification | Deletes an existing notification.
Reference
IAdsNotifications Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsNotifications.AddDeviceNotification Method
•
IAdsNotifications.AddDeviceNotificationEx Method
•
IAdsNotifications.DeleteDeviceNotification Method
•
IAdsNotifications.TryAddDeviceNotification Method
•
IAdsNotifications.TryAddDeviceNotificationEx Method
•
IAdsNotifications.TryDeleteDeviceNotification Method


IAdsNotifications.AddDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.AddDeviceNotification Method
IAdsNotifications.AddDeviceNotification Method
Overload List
Name | Description
AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Reference
IAdsNotifications Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsNotifications.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)
•
IAdsNotifications.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)
•
IAdsNotifications.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
•
IAdsNotifications.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)


IAdsNotifications.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.AddDeviceNotification Method [image] IAdsNotifications.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)
IAdsNotifications.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int AddDeviceNotification(
string variableName,
AdsStream dataStream,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Function AddDeviceNotification (
variableName As String,
dataStream As AdsStream,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsNotifications Interface
AddDeviceNotification Overload
TwinCAT.Ads Namespace


IAdsNotifications.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.AddDeviceNotification Method [image] IAdsNotifications.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)
IAdsNotifications.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int AddDeviceNotification(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Function AddDeviceNotification (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Reference
IAdsNotifications Interface
AddDeviceNotification Overload
TwinCAT.Ads Namespace


IAdsNotifications.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.AddDeviceNotification Method [image] IAdsNotifications.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
IAdsNotifications.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int AddDeviceNotification(
string variableName,
AdsStream dataStream,
int offset,
int length,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Function AddDeviceNotification (
variableName As String,
dataStream As AdsStream,
offset As Integer,
length As Integer,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Remarks
AdsTransMode | Parameter semantic
CyclicInContext | Value of parameter is interpreted as task context number ContextMask
OnChangeInContext | Value of parameter is interpreted as task context number ContextMask
Reference
IAdsNotifications Interface
AddDeviceNotification Overload
TwinCAT.Ads Namespace


IAdsNotifications.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.AddDeviceNotification Method [image] IAdsNotifications.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
IAdsNotifications.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int AddDeviceNotification(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Function AddDeviceNotification (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsNotifications Interface
AddDeviceNotification Overload
TwinCAT.Ads Namespace


IAdsNotifications.AddDeviceNotificationEx Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.AddDeviceNotificationEx Method
IAdsNotifications.AddDeviceNotificationEx Method
Overload List
Name | Description
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Reference
IAdsNotifications Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsNotifications.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)
•
IAdsNotifications.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
•
IAdsNotifications.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)
•
IAdsNotifications.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)


IAdsNotifications.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.AddDeviceNotificationEx Method [image] IAdsNotifications.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)
IAdsNotifications.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int AddDeviceNotificationEx(
string variableName,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type
)
VB
Function AddDeviceNotificationEx (
variableName As String,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsNotifications Interface
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace


IAdsNotifications.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.AddDeviceNotificationEx Method [image] IAdsNotifications.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
IAdsNotifications.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int AddDeviceNotificationEx(
string variableName,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type,
int[] args
)
VB
Function AddDeviceNotificationEx (
variableName As String,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type,
args As Integer()
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsNotifications Interface
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace


IAdsNotifications.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.AddDeviceNotificationEx Method [image] IAdsNotifications.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)
IAdsNotifications.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int AddDeviceNotificationEx(
uint indexGroup,
uint indexOffset,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type
)
VB
Function AddDeviceNotificationEx (
indexGroup As UInteger,
indexOffset As UInteger,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsNotifications Interface
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace


IAdsNotifications.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.AddDeviceNotificationEx Method [image] IAdsNotifications.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
IAdsNotifications.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int AddDeviceNotificationEx(
uint indexGroup,
uint indexOffset,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type,
int[] args
)
VB
Function AddDeviceNotificationEx (
indexGroup As UInteger,
indexOffset As UInteger,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type,
args As Integer()
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object s0000tored in the event argument.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsNotifications Interface
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace


IAdsNotifications.DeleteDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.DeleteDeviceNotification Method
IAdsNotifications.DeleteDeviceNotification Method
Deletes an existing notification.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void DeleteDeviceNotification(
int notificationHandle
)
VB
Sub DeleteDeviceNotification (
notificationHandle As Integer
)
Parameters
notificationHandle
Type: System.Int32
Handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsNotifications Interface
TwinCAT.Ads Namespace


IAdsNotifications.TryAddDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.TryAddDeviceNotification Method
IAdsNotifications.TryAddDeviceNotification Method
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode TryAddDeviceNotification(
string variableName,
AdsStream dataStream,
int offset,
int length,
NotificationSettings settings,
Object userData,
out uint handle
)
VB
Function TryAddDeviceNotification (
variableName As String,
dataStream As AdsStream,
offset As Integer,
length As Integer,
settings As NotificationSettings,
userData As Object,
<OutAttribute> ByRef handle As UInteger
) As AdsErrorCode
Parameters
variableName | Type: System.String Name of the ADS variable.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
settings | Type: TwinCAT.Ads.NotificationSettings The settings.
userData | Type: System.Object This object can be used to store user specific data.
handle | Type: System.UInt32. The handle.
Return Value
Type: AdsErrorCode
The ADS ErrorCode.
Reference
IAdsNotifications Interface
TwinCAT.Ads Namespace


IAdsNotifications.TryAddDeviceNotificationEx Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.TryAddDeviceNotificationEx Method
IAdsNotifications.TryAddDeviceNotificationEx Method
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode TryAddDeviceNotificationEx(
string variableName,
NotificationSettings settings,
Object userData,
Type type,
int[] args,
out uint handle
)
VB
Function TryAddDeviceNotificationEx (
variableName As String,
settings As NotificationSettings,
userData As Object,
type As Type,
args As Integer(),
<OutAttribute> ByRef handle As UInteger
) As AdsErrorCode
Parameters
variableName | Type: System.String Name of the ADS variable.
settings | Type: TwinCAT.Ads.NotificationSettings The settings.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
args | Type: .System.Int32. Additional arguments.
handle | Type: System.UInt32. The handle.
Return Value
Type: AdsErrorCode
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsNotifications Interface
TwinCAT.Ads Namespace


IAdsNotifications.TryDeleteDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Methods [image] IAdsNotifications.TryDeleteDeviceNotification Method
IAdsNotifications.TryDeleteDeviceNotification Method
Deletes an existing notification.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode TryDeleteDeviceNotification(
uint notificationHandle
)
VB
Function TryDeleteDeviceNotification (
notificationHandle As UInteger
) As AdsErrorCode
Parameters
notificationHandle
Type: System.UInt32
Handle of the notification.
Return Value
Type: AdsErrorCode
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
IAdsNotifications Interface
TwinCAT.Ads Namespace


IAdsNotifications Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Events
IAdsNotifications Events
The IAdsNotifications type exposes the following members.
Events
Name | Description
AdsNotification | Occurs when the ADS device sends a notification to the client.
AdsNotificationError | Occurs when a exception has occurred during notification management.
AdsNotificationEx | Occurs when the ADS devices sends a notification to the client.
Reference
IAdsNotifications Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsNotifications.AdsNotification Event
•
IAdsNotifications.AdsNotificationError Event
•
IAdsNotifications.AdsNotificationEx Event


IAdsNotifications.AdsNotification Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Events [image] IAdsNotifications.AdsNotification Event
IAdsNotifications.AdsNotification Event
Occurs when the ADS device sends a notification to the client.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
event AdsNotificationEventHandler AdsNotification
VB
Event AdsNotification As AdsNotificationEventHandler
Value
Type: TwinCAT.Ads.AdsNotificationEventHandler
Examples
The following sample shows how to register/unregister for AdsNotification
Receive AdsNotifications
AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event handler
client.AdsNotification += Client_AdsNotification;

// Connect to target
client.Connect("1.2.3.4.5.6", 851);
int notificationHandle = 0;

try
{
// Notification to a DINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotification("MAIN.nCounter", readStream, AdsTransMode.OnChange, 200, 0, null);
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotification -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationEventArgs e)
{
int offset = (int)e.DataStream.Position;
int length = (int)e.DataStream.Length;

e.DataStream.Position = offset;
AdsBinaryReader reader = new AdsBinaryReader(e.DataStream);

// Read the Unmarshalled data
//byte[] data = reader.ReadBytes(length);

// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = reader.ReadUInt32();
}
Reference
IAdsNotifications Interface
TwinCAT.Ads Namespace


IAdsNotifications.AdsNotificationError Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Events [image] IAdsNotifications.AdsNotificationError Event
IAdsNotifications.AdsNotificationError Event
Occurs when a exception has occurred during notification management.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
event AdsNotificationErrorEventHandler AdsNotificationError
VB
Event AdsNotificationError As AdsNotificationErrorEventHandler
Value
Type: TwinCAT.Ads.AdsNotificationErrorEventHandler
Reference
IAdsNotifications Interface
TwinCAT.Ads Namespace


IAdsNotifications.AdsNotificationEx Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsNotifications Interface [image] IAdsNotifications Events [image] IAdsNotifications.AdsNotificationEx Event
IAdsNotifications.AdsNotificationEx Event
Occurs when the ADS devices sends a notification to the client.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
event AdsNotificationExEventHandler AdsNotificationEx
VB
Event AdsNotificationEx As AdsNotificationExEventHandler
Value
Type: TwinCAT.Ads.AdsNotificationExEventHandler
Reference
IAdsNotifications Interface
TwinCAT.Ads Namespace


IAdsSession Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSession Interface
IAdsSession Interface
Interface IAdsSession
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IAdsSession : ISession,
IConnectionStateProvider
VB
Public Interface IAdsSession
Inherits ISession, IConnectionStateProvider
The IAdsSession type exposes the following members.
Properties
Name | Description
Address | Gets the Address specifier of the Session / connection
AddressSpecifier | Gets the communication endpoint address string representation. (Inherited from ISession.)
Connection | Gets the Connection object. (Inherited from ISession.)
ConnectionState | Gets the current Connection state of the IConnectionStateProvider (Inherited from IConnectionStateProvider.)
EstablishedAt | Gets the UTC time when the session was established. (Inherited from ISession.)
Id | Gets the Session Id (Inherited from ISession.)
IsConnected | Gets a value indicating whether the session is connected. (Inherited from ISession.)
NetId | Gets the NetId of the Session
Owner | Gets the Session owner.
Port | Gets the Ams Port of the Session
Methods
Name | Description
Close | Closes this ISession (Inherited from ISession.)
Connect | Connects the session and returns the established IConnection object. (Inherited from ISession.)
Disconnect | Disconnects the ISession (Inherited from ISession.)
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed. (Inherited from IConnectionStateProvider.)
Reference
TwinCAT.Ads Namespace
TwinCAT.ISession
Weiterführende Informationen
•
IAdsSession Properties
•
IAdsSession Methods
•
IAdsSession Events


IAdsSession Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSession Interface [image] IAdsSession Properties
IAdsSession Properties
The IAdsSession type exposes the following members.
Properties
Name | Description
Address | Gets the Address specifier of the Session / connection
AddressSpecifier | Gets the communication endpoint address string representation. (Inherited from ISession.)
Connection | Gets the Connection object. (Inherited from ISession.)
ConnectionState | Gets the current Connection state of the IConnectionStateProvider (Inherited from IConnectionStateProvider.)
EstablishedAt | Gets the UTC time when the session was established. (Inherited from ISession.)
Id | Gets the Session Id (Inherited from ISession.)
IsConnected | Gets a value indicating whether the session is connected. (Inherited from ISession.)
NetId | Gets the NetId of the Session
Owner | Gets the Session owner.
Port | Gets the Ams Port of the Session
Reference
IAdsSession Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsSession.Address Property
•
IAdsSession.NetId Property
•
IAdsSession.Owner Property
•
IAdsSession.Port Property


IAdsSession.Address Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSession Interface [image] IAdsSession Properties [image] IAdsSession.Address Property
IAdsSession.Address Property
Gets the Address specifier of the Session / connection
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AmsAddress Address { get; }
VB
ReadOnly Property Address As AmsAddress
Get
Property Value
Type: AmsAddress
The address.
Reference
IAdsSession Interface
TwinCAT.Ads Namespace


IAdsSession.NetId Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSession Interface [image] IAdsSession Properties [image] IAdsSession.NetId Property
IAdsSession.NetId Property
Gets the NetId of the Session
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AmsNetId NetId { get; }
VB
ReadOnly Property NetId As AmsNetId
Get
Property Value
Type: AmsNetId
The net identifier.
Reference
IAdsSession Interface
TwinCAT.Ads Namespace


IAdsSession.Owner Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSession Interface [image] IAdsSession Properties [image] IAdsSession.Owner Property
IAdsSession.Owner Property
Gets the Session owner.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object Owner { get; }
VB
ReadOnly Property Owner As Object
Get
Property Value
Type: Object
The owner or NULL
Reference
IAdsSession Interface
TwinCAT.Ads Namespace


IAdsSession.Port Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSession Interface [image] IAdsSession Properties [image] IAdsSession.Port Property
IAdsSession.Port Property
Gets the Ams Port of the Session
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Port { get; }
VB
ReadOnly Property Port As Integer
Get
Property Value
Type: Int32
The port.
Reference
IAdsSession Interface
TwinCAT.Ads Namespace


IAdsSession Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSession Interface [image] IAdsSession Methods
IAdsSession Methods
The IAdsSession type exposes the following members.
Methods
Name | Description
Close | Closes this ISession (Inherited from ISession.)
Connect | Connects the session and returns the established IConnection object. (Inherited from ISession.)
Disconnect | Disconnects the ISession (Inherited from ISession.)
Reference
IAdsSession Interface
TwinCAT.Ads Namespace


IAdsSession Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSession Interface [image] IAdsSession Events
IAdsSession Events
The IAdsSession type exposes the following members.
Events
Name | Description
ConnectionStateChanged | Occurs when connection status of the IConnectionStateProvider has been changed. (Inherited from IConnectionStateProvider.)
Reference
IAdsSession Interface
TwinCAT.Ads Namespace


IAdsSessionSettings Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSessionSettings Interface
IAdsSessionSettings Interface
Interface for ADS Session Settings
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IAdsSessionSettings : ISessionSettings
VB
Public Interface IAdsSessionSettings
Inherits ISessionSettings
The IAdsSessionSettings type exposes the following members.
Properties
Name | Description
ResurrectionTime | Gets or sets the resurrection time.
SymbolLoader | Gets or sets the symbol loader settings
Timeout | Gets the ADS timeout in milliseconds.
Reference
TwinCAT.Ads Namespace
TwinCAT.ISessionSettings
Weiterführende Informationen
•
IAdsSessionSettings Properties


IAdsSessionSettings Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSessionSettings Interface [image] IAdsSessionSettings Properties
IAdsSessionSettings Properties
The IAdsSessionSettings type exposes the following members.
Properties
Name | Description
ResurrectionTime | Gets or sets the resurrection time.
SymbolLoader | Gets or sets the symbol loader settings
Timeout | Gets the ADS timeout in milliseconds.
Reference
IAdsSessionSettings Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
IAdsSessionSettings.ResurrectionTime Property
•
IAdsSessionSettings.SymbolLoader Property
•
IAdsSessionSettings.Timeout Property


IAdsSessionSettings.ResurrectionTime Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSessionSettings Interface [image] IAdsSessionSettings Properties [image] IAdsSessionSettings.ResurrectionTime Property
IAdsSessionSettings.ResurrectionTime Property
Gets or sets the resurrection time.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
TimeSpan ResurrectionTime { get; set; }
VB
Property ResurrectionTime As TimeSpan
Get
Set
Property Value
Type: TimeSpan
The resurrection time.
Reference
IAdsSessionSettings Interface
TwinCAT.Ads Namespace


IAdsSessionSettings.SymbolLoader Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSessionSettings Interface [image] IAdsSessionSettings Properties [image] IAdsSessionSettings.SymbolLoader Property
IAdsSessionSettings.SymbolLoader Property
Gets or sets the symbol loader settings
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
SymbolLoaderSettings SymbolLoader { get; set; }
VB
Property SymbolLoader As SymbolLoaderSettings
Get
Set
Property Value
Type: SymbolLoaderSettings
The symbol loader.
Reference
IAdsSessionSettings Interface
TwinCAT.Ads Namespace


IAdsSessionSettings.Timeout Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IAdsSessionSettings Interface [image] IAdsSessionSettings Properties [image] IAdsSessionSettings.Timeout Property
IAdsSessionSettings.Timeout Property
Gets the ADS timeout in milliseconds.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Timeout { get; }
VB
ReadOnly Property Timeout As Integer
Get
Property Value
Type: Int32
The timeout.
Reference
IAdsSessionSettings Interface
TwinCAT.Ads Namespace


IFailFastHandler Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] IFailFastHandler Interface
IFailFastHandler Interface
Interface for a fast failing (Circuit breaker) ads handler
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IFailFastHandler
VB
Public Interface IFailFastHandler
Remarks
If a target is not available it will throw Timeout exceptions after a Default time of 5 seconds. To prevent hanging applications and bring more robustness into the communication (less consumption of ADS Mailbox memory), a second try to call the target should fail fast - not waiting for the Timeout. Only after a dedicated reconnection timeout timespan, real communication should be retried.
Reference
TwinCAT.Ads Namespace


ITcAdsDataType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface
ITcAdsDataType Interface
Interface ITcAdsDataType
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ITcAdsDataType : IDataType,
IBitSize
VB
Public Interface ITcAdsDataType
Inherits IDataType, IBitSize
The ITcAdsDataType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the Base Type of the Type (if enum, alias, array)
BaseTypeName | Gets the name of the base type (if enum, alias, array)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
DataTypeId | Gets the data type identifier.
Dimensions | Gets the dimensions of an array type
EnumValues | Enumeration specification (if enum)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
HasArrayInfo | Gets a value indicating whether this instance has dimension information.
HasEnumInfo | Gets a value indicating whether this instance has enum information.
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only)
HasSubItemInfo | Gets a value indicating whether this instance has sub items.
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsJaggedArray | Gets a value indicating whether this dataType is a jagged array.
IsOversamplingArray | Gets a value indicating whether this instance is an oversampling array.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
IsSubItem | Determines whether this object is an SubItem (DataType Member, true) or a native DataType (false)
ManagedType | Managed Type of the (simple,primitive) type.
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
RpcMethods | Gets the RPC method descriptions
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubItems | Get the SubElements of this ITcAdsDataType.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsDataType Properties


ITcAdsDataType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties
ITcAdsDataType Properties
The ITcAdsDataType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the Base Type of the Type (if enum, alias, array)
BaseTypeName | Gets the name of the base type (if enum, alias, array)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
DataTypeId | Gets the data type identifier.
Dimensions | Gets the dimensions of an array type
EnumValues | Enumeration specification (if enum)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
HasArrayInfo | Gets a value indicating whether this instance has dimension information.
HasEnumInfo | Gets a value indicating whether this instance has enum information.
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only)
HasSubItemInfo | Gets a value indicating whether this instance has sub items.
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsJaggedArray | Gets a value indicating whether this dataType is a jagged array.
IsOversamplingArray | Gets a value indicating whether this instance is an oversampling array.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
IsSubItem | Determines whether this object is an SubItem (DataType Member, true) or a native DataType (false)
ManagedType | Managed Type of the (simple,primitive) type.
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
RpcMethods | Gets the RPC method descriptions
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubItems | Get the SubElements of this ITcAdsDataType.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsDataType.BaseType Property
•
ITcAdsDataType.BaseTypeName Property
•
ITcAdsDataType.DataTypeId Property
•
ITcAdsDataType.Dimensions Property
•
ITcAdsDataType.EnumValues Property
•
ITcAdsDataType.HasArrayInfo Property
•
ITcAdsDataType.HasEnumInfo Property
•
ITcAdsDataType.HasRpcMethods Property
•
ITcAdsDataType.HasSubItemInfo Property
•
ITcAdsDataType.IsJaggedArray Property
•
ITcAdsDataType.IsOversamplingArray Property
•
ITcAdsDataType.IsSubItem Property
•
ITcAdsDataType.ManagedType Property
•
ITcAdsDataType.RpcMethods Property
•
ITcAdsDataType.SubItems Property


ITcAdsDataType.BaseType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.BaseType Property
ITcAdsDataType.BaseType Property
Gets the Base Type of the Type (if enum, alias, array)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ITcAdsDataType BaseType { get; }
VB
ReadOnly Property BaseType As ITcAdsDataType
Get
Property Value
Type: ITcAdsDataType
The type of the base.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.BaseTypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.BaseTypeName Property
ITcAdsDataType.BaseTypeName Property
Gets the name of the base type (if enum, alias, array)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string BaseTypeName { get; }
VB
ReadOnly Property BaseTypeName As String
Get
Property Value
Type: String
The name of the base type.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.DataTypeId Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.DataTypeId Property
ITcAdsDataType.DataTypeId Property
Gets the data type identifier.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsDatatypeId DataTypeId { get; }
VB
ReadOnly Property DataTypeId As AdsDatatypeId
Get
Property Value
Type: AdsDatatypeId
The data type identifier.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.Dimensions Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.Dimensions Property
ITcAdsDataType.Dimensions Property
Gets the dimensions of an array type
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyDimensionCollection Dimensions { get; }
VB
ReadOnly Property Dimensions As ReadOnlyDimensionCollection
Get
Property Value
Type: ReadOnlyDimensionCollection
The array infos.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.EnumValues Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.EnumValues Property
ITcAdsDataType.EnumValues Property
Enumeration specification (if enum)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyEnumValueCollection EnumValues { get; }
VB
ReadOnly Property EnumValues As ReadOnlyEnumValueCollection
Get
Property Value
Type: ReadOnlyEnumValueCollection
The enum infos.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.HasArrayInfo Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.HasArrayInfo Property
ITcAdsDataType.HasArrayInfo Property
Gets a value indicating whether this instance has dimension information.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool HasArrayInfo { get; }
VB
ReadOnly Property HasArrayInfo As Boolean
Get
Property Value
Type: Boolean
true if this instance has dimension information; otherwise, false.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.HasEnumInfo Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.HasEnumInfo Property
ITcAdsDataType.HasEnumInfo Property
Gets a value indicating whether this instance has enum information.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool HasEnumInfo { get; }
VB
ReadOnly Property HasEnumInfo As Boolean
Get
Property Value
Type: Boolean
true if this instance has enum information; otherwise, false.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.HasRpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.HasRpcMethods Property
ITcAdsDataType.HasRpcMethods Property
Gets a value indicating whether this instance has RPC methods (Struct types only)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool HasRpcMethods { get; }
VB
ReadOnly Property HasRpcMethods As Boolean
Get
Property Value
Type: Boolean
true if this instance has RPC methods; otherwise, false.
Remarks
The DataType (Structure) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods, otherwise RpcMethods are not passed through to the ADS symbolic information.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.HasSubItemInfo Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.HasSubItemInfo Property
ITcAdsDataType.HasSubItemInfo Property
Gets a value indicating whether this instance has sub items.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool HasSubItemInfo { get; }
VB
ReadOnly Property HasSubItemInfo As Boolean
Get
Property Value
Type: Boolean
true if this instance has sub items; otherwise, false.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.IsJaggedArray Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.IsJaggedArray Property
ITcAdsDataType.IsJaggedArray Property
Gets a value indicating whether this dataType is a jagged array.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsJaggedArray { get; }
VB
ReadOnly Property IsJaggedArray As Boolean
Get
Property Value
Type: Boolean
true if this instance is jagged array; otherwise, false.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.IsOversamplingArray Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.IsOversamplingArray Property
ITcAdsDataType.IsOversamplingArray Property
Gets a value indicating whether this instance is an oversampling array.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsOversamplingArray { get; }
VB
ReadOnly Property IsOversamplingArray As Boolean
Get
Property Value
Type: Boolean
true if this instance is oversampling array; otherwise, false.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.IsSubItem Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.IsSubItem Property
ITcAdsDataType.IsSubItem Property
Determines whether this object is an SubItem (DataType Member, true) or a native DataType (false)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsSubItem { get; }
VB
ReadOnly Property IsSubItem As Boolean
Get
Return Value
Type: Boolean
true if [is sub item]; otherwise, false.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.ManagedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.ManagedType Property
ITcAdsDataType.ManagedType Property
Managed Type of the (simple,primitive) type.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Type ManagedType { get; }
VB
ReadOnly Property ManagedType As Type
Get
Property Value
Type: Type
The managed type of the data type.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.RpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.RpcMethods Property
ITcAdsDataType.RpcMethods Property
Gets the RPC method descriptions
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyRpcMethodCollection RpcMethods { get; }
VB
ReadOnly Property RpcMethods As ReadOnlyRpcMethodCollection
Get
Property Value
Type: ReadOnlyRpcMethodCollection
A list of the rpc methods.
Remarks
The DataType (Structure) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods, otherwise RpcMethods are not passed through to the ADS symbolic information.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsDataType.SubItems Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsDataType Interface [image] ITcAdsDataType Properties [image] ITcAdsDataType.SubItems Property
ITcAdsDataType.SubItems Property
Get the SubElements of this ITcAdsDataType.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlySubItemCollection SubItems { get; }
VB
ReadOnly Property SubItems As ReadOnlySubItemCollection
Get
Property Value
Type: ReadOnlySubItemCollection
The subItems.
Reference
ITcAdsDataType Interface
TwinCAT.Ads Namespace


ITcAdsRpcInvoke Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface
ITcAdsRpcInvoke Interface
Interface ITcAdsRpcInvoke
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ITcAdsRpcInvoke
VB
Public Interface ITcAdsRpcInvoke
Methods
Name | Description
InvokeRpcMethod(String, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(String, String, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, String, .Object.) | Invokes the specified RPC Method.
TryInvokeRpcMethod(String, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(String, String, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.) | Invokes the specified RPC Method.
Remarks
This interface is used to invoke ADS RPC Method calls. This can be done 'symbolic' via the Method name or the MethodID of the method on the specified symbol. To activate the RPC Access within the PLC environment, its dataType (Structure, FB) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsRpcInvoke Methods


ITcAdsRpcInvoke Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface [image] ITcAdsRpcInvoke Methods
ITcAdsRpcInvoke Methods
Methods
Name | Description
InvokeRpcMethod(String, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(String, String, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, String, .Object.) | Invokes the specified RPC Method.
TryInvokeRpcMethod(String, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(String, String, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.) | Invokes the specified RPC Method.
Reference
ITcAdsRpcInvoke Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsRpcInvoke.InvokeRpcMethod Method
•
ITcAdsRpcInvoke.TryInvokeRpcMethod Method


ITcAdsRpcInvoke.InvokeRpcMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface [image] ITcAdsRpcInvoke Methods [image] ITcAdsRpcInvoke.InvokeRpcMethod Method
ITcAdsRpcInvoke.InvokeRpcMethod Method
Overload List
Name | Description
InvokeRpcMethod(String, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(String, String, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, String, .Object.) | Invokes the specified RPC Method.
Reference
ITcAdsRpcInvoke Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsRpcInvoke.InvokeRpcMethod Method (String, Int32, .Object.)
•
ITcAdsRpcInvoke.InvokeRpcMethod Method (String, String, .Object.)
•
ITcAdsRpcInvoke.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)
•
ITcAdsRpcInvoke.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)


ITcAdsRpcInvoke.InvokeRpcMethod Method (String, Int32, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface [image] ITcAdsRpcInvoke Methods [image] ITcAdsRpcInvoke.InvokeRpcMethod Method [image] ITcAdsRpcInvoke.InvokeRpcMethod Method (String, Int32, .Object.)
ITcAdsRpcInvoke.InvokeRpcMethod Method (String, Int32, .Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object InvokeRpcMethod(
string symbolPath,
int methodId,
Object[] parameters
)
VB
Function InvokeRpcMethod (
symbolPath As String,
methodId As Integer,
parameters As Object()
) As Object
Parameters
symbolPath | Type: System.String The symbol path.
methodId | Type: System.Int32 The method identifier.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
The return value of the Method (as object).
Reference
ITcAdsRpcInvoke Interface
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


ITcAdsRpcInvoke.InvokeRpcMethod Method (String, String, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface [image] ITcAdsRpcInvoke Methods [image] ITcAdsRpcInvoke.InvokeRpcMethod Method [image] ITcAdsRpcInvoke.InvokeRpcMethod Method (String, String, .Object.)
ITcAdsRpcInvoke.InvokeRpcMethod Method (String, String, .Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object InvokeRpcMethod(
string symbolPath,
string methodName,
Object[] parameters
)
VB
Function InvokeRpcMethod (
symbolPath As String,
methodName As String,
parameters As Object()
) As Object
Parameters
symbolPath | Type: System.String The symbol path.
methodName | Type: System.String The method name.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
The return value of the Method (as object).
Reference
ITcAdsRpcInvoke Interface
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


ITcAdsRpcInvoke.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface [image] ITcAdsRpcInvoke Methods [image] ITcAdsRpcInvoke.InvokeRpcMethod Method [image] ITcAdsRpcInvoke.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)
ITcAdsRpcInvoke.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object InvokeRpcMethod(
ITcAdsSymbol symbol,
int methodId,
Object[] parameters
)
VB
Function InvokeRpcMethod (
symbol As ITcAdsSymbol,
methodId As Integer,
parameters As Object()
) As Object
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodId | Type: System.Int32 The method identifier / Virtual Function table index.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
The return value of the Method (as object).
Reference
ITcAdsRpcInvoke Interface
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


ITcAdsRpcInvoke.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface [image] ITcAdsRpcInvoke Methods [image] ITcAdsRpcInvoke.InvokeRpcMethod Method [image] ITcAdsRpcInvoke.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)
ITcAdsRpcInvoke.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)
Invokes the specified RPC Method.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object InvokeRpcMethod(
ITcAdsSymbol symbol,
string methodName,
Object[] parameters
)
VB
Function InvokeRpcMethod (
symbol As ITcAdsSymbol,
methodName As String,
parameters As Object()
) As Object
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodName | Type: System.String Name of the method.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
The return value of the Method (as object).
Reference
ITcAdsRpcInvoke Interface
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


ITcAdsRpcInvoke.TryInvokeRpcMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface [image] ITcAdsRpcInvoke Methods [image] ITcAdsRpcInvoke.TryInvokeRpcMethod Method
ITcAdsRpcInvoke.TryInvokeRpcMethod Method
Overload List
Name | Description
TryInvokeRpcMethod(String, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(String, String, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.) | Invokes the specified RPC Method.
Reference
ITcAdsRpcInvoke Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsRpcInvoke.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)
•
ITcAdsRpcInvoke.TryInvokeRpcMethod Method (String, String, .Object., Object.)
•
ITcAdsRpcInvoke.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)
•
ITcAdsRpcInvoke.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)


ITcAdsRpcInvoke.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface [image] ITcAdsRpcInvoke Methods [image] ITcAdsRpcInvoke.TryInvokeRpcMethod Method [image] ITcAdsRpcInvoke.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)
ITcAdsRpcInvoke.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode TryInvokeRpcMethod(
string symbolPath,
int methodId,
Object[] parameters,
out Object retValue
)
VB
Function TryInvokeRpcMethod (
symbolPath As String,
methodId As Integer,
parameters As Object(),
<OutAttribute> ByRef retValue As Object
) As AdsErrorCode
Parameters
symbolPath | Type: System.String The symbol path.
methodId | Type: System.Int32 The method identifier.
parameters | Type: .System.Object. The parameters.
retValue | Type: System.Object. The return value of the RPC method as object.
Return Value
Type: AdsErrorCode
The ADS Error Code.
Reference
ITcAdsRpcInvoke Interface
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


ITcAdsRpcInvoke.TryInvokeRpcMethod Method (String, String, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface [image] ITcAdsRpcInvoke Methods [image] ITcAdsRpcInvoke.TryInvokeRpcMethod Method [image] ITcAdsRpcInvoke.TryInvokeRpcMethod Method (String, String, .Object., Object.)
ITcAdsRpcInvoke.TryInvokeRpcMethod Method (String, String, .Object., Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode TryInvokeRpcMethod(
string symbolPath,
string methodName,
Object[] parameters,
out Object retValue
)
VB
Function TryInvokeRpcMethod (
symbolPath As String,
methodName As String,
parameters As Object(),
<OutAttribute> ByRef retValue As Object
) As AdsErrorCode
Parameters
symbolPath | Type: System.String The symbol path.
methodName | Type: System.String The method name.
parameters | Type: .System.Object. The parameters.
retValue | Type: System.Object. The return value of the RPC method as object.
Return Value
Type: AdsErrorCode
The ADS Error Code.
Reference
ITcAdsRpcInvoke Interface
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


ITcAdsRpcInvoke.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface [image] ITcAdsRpcInvoke Methods [image] ITcAdsRpcInvoke.TryInvokeRpcMethod Method [image] ITcAdsRpcInvoke.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)
ITcAdsRpcInvoke.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode TryInvokeRpcMethod(
ITcAdsSymbol symbol,
int methodId,
Object[] parameters,
out Object retValue
)
VB
Function TryInvokeRpcMethod (
symbol As ITcAdsSymbol,
methodId As Integer,
parameters As Object(),
<OutAttribute> ByRef retValue As Object
) As AdsErrorCode
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodId | Type: System.Int32 The method identifier / Virtual Function table index.
parameters | Type: .System.Object. The parameters.
retValue | Type: System.Object. The return value of the RPC method as object.
Return Value
Type: AdsErrorCode
The ADS Error Code.
Reference
ITcAdsRpcInvoke Interface
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


ITcAdsRpcInvoke.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsRpcInvoke Interface [image] ITcAdsRpcInvoke Methods [image] ITcAdsRpcInvoke.TryInvokeRpcMethod Method [image] ITcAdsRpcInvoke.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)
ITcAdsRpcInvoke.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)
Invokes the specified RPC Method.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode TryInvokeRpcMethod(
ITcAdsSymbol symbol,
string methodName,
Object[] parameters,
out Object retValue
)
VB
Function TryInvokeRpcMethod (
symbol As ITcAdsSymbol,
methodName As String,
parameters As Object(),
<OutAttribute> ByRef retValue As Object
) As AdsErrorCode
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodName | Type: System.String Name of the method.
parameters | Type: .System.Object. The parameters.
retValue | Type: System.Object. The return value of the RPC method as object.
Return Value
Type: AdsErrorCode
The ADS Error Code.
Reference
ITcAdsRpcInvoke Interface
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


ITcAdsSubItem Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSubItem Interface
ITcAdsSubItem Interface
Interface ITcAdsSubItem
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ITcAdsSubItem : ITcAdsDataType,
IDataType, IBitSize
VB
Public Interface ITcAdsSubItem
Inherits ITcAdsDataType, IDataType, IBitSize
The ITcAdsSubItem type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the Base Type of the Type (if enum, alias, array) (Inherited from ITcAdsDataType.)
BaseTypeName | Gets the name of the base type (if enum, alias, array) (Inherited from ITcAdsDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
DataTypeId | Gets the data type identifier. (Inherited from ITcAdsDataType.)
Dimensions | Gets the dimensions of an array type (Inherited from ITcAdsDataType.)
EnumValues | Enumeration specification (if enum) (Inherited from ITcAdsDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
HasArrayInfo | Gets a value indicating whether this instance has dimension information. (Inherited from ITcAdsDataType.)
HasEnumInfo | Gets a value indicating whether this instance has enum information. (Inherited from ITcAdsDataType.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only) (Inherited from ITcAdsDataType.)
HasSubItemInfo | Gets a value indicating whether this instance has sub items. (Inherited from ITcAdsDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsJaggedArray | Gets a value indicating whether this dataType is a jagged array. (Inherited from ITcAdsDataType.)
IsOversamplingArray | Gets a value indicating whether this instance is an oversampling array. (Inherited from ITcAdsDataType.)
IsPersistent | Gets a value indicating whether this sub element is persistent.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
IsSubItem | Determines whether this object is an SubItem (DataType Member, true) or a native DataType (false) (Inherited from ITcAdsDataType.)
ManagedType | Managed Type of the (simple,primitive) type. (Inherited from ITcAdsDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Offset | Gets the offset of the SubItem (in Bytes or Bits)
RpcMethods | Gets the RPC method descriptions (Inherited from ITcAdsDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubItemName | Gets the name of the subitem / Sub element.
SubItems | Get the SubElements of this ITcAdsDataType. (Inherited from ITcAdsDataType.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsSubItem Properties


ITcAdsSubItem Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSubItem Interface [image] ITcAdsSubItem Properties
ITcAdsSubItem Properties
The ITcAdsSubItem type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the Base Type of the Type (if enum, alias, array) (Inherited from ITcAdsDataType.)
BaseTypeName | Gets the name of the base type (if enum, alias, array) (Inherited from ITcAdsDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
DataTypeId | Gets the data type identifier. (Inherited from ITcAdsDataType.)
Dimensions | Gets the dimensions of an array type (Inherited from ITcAdsDataType.)
EnumValues | Enumeration specification (if enum) (Inherited from ITcAdsDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
HasArrayInfo | Gets a value indicating whether this instance has dimension information. (Inherited from ITcAdsDataType.)
HasEnumInfo | Gets a value indicating whether this instance has enum information. (Inherited from ITcAdsDataType.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only) (Inherited from ITcAdsDataType.)
HasSubItemInfo | Gets a value indicating whether this instance has sub items. (Inherited from ITcAdsDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsJaggedArray | Gets a value indicating whether this dataType is a jagged array. (Inherited from ITcAdsDataType.)
IsOversamplingArray | Gets a value indicating whether this instance is an oversampling array. (Inherited from ITcAdsDataType.)
IsPersistent | Gets a value indicating whether this sub element is persistent.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
IsSubItem | Determines whether this object is an SubItem (DataType Member, true) or a native DataType (false) (Inherited from ITcAdsDataType.)
ManagedType | Managed Type of the (simple,primitive) type. (Inherited from ITcAdsDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Offset | Gets the offset of the SubItem (in Bytes or Bits)
RpcMethods | Gets the RPC method descriptions (Inherited from ITcAdsDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubItemName | Gets the name of the subitem / Sub element.
SubItems | Get the SubElements of this ITcAdsDataType. (Inherited from ITcAdsDataType.)
Reference
ITcAdsSubItem Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsSubItem.IsPersistent Property
•
ITcAdsSubItem.Offset Property
•
ITcAdsSubItem.SubItemName Property


ITcAdsSubItem.IsPersistent Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSubItem Interface [image] ITcAdsSubItem Properties [image] ITcAdsSubItem.IsPersistent Property
ITcAdsSubItem.IsPersistent Property
Gets a value indicating whether this sub element is persistent.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsPersistent { get; }
VB
ReadOnly Property IsPersistent As Boolean
Get
Property Value
Type: Boolean
true if this subelement is persistent; otherwise, false.
Reference
ITcAdsSubItem Interface
TwinCAT.Ads Namespace


ITcAdsSubItem.Offset Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSubItem Interface [image] ITcAdsSubItem Properties [image] ITcAdsSubItem.Offset Property
ITcAdsSubItem.Offset Property
Gets the offset of the SubItem (in Bytes or Bits)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Offset { get; }
VB
ReadOnly Property Offset As Integer
Get
Property Value
Type: Int32
The offset.
Remarks
If IsBitType indicates 'BitSize' then this value will be in Bits, otherwise Bytes.
Reference
ITcAdsSubItem Interface
TwinCAT.Ads Namespace


ITcAdsSubItem.SubItemName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSubItem Interface [image] ITcAdsSubItem Properties [image] ITcAdsSubItem.SubItemName Property
ITcAdsSubItem.SubItemName Property
Gets the name of the subitem / Sub element.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string SubItemName { get; }
VB
ReadOnly Property SubItemName As String
Get
Property Value
Type: String
The name of the sub item.
Reference
ITcAdsSubItem Interface
TwinCAT.Ads Namespace


ITcAdsSymbol Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol Interface
ITcAdsSymbol Interface
Defines an Interface for reading the ADS symbol information.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ITcAdsSymbol
VB
Public Interface ITcAdsSymbol
The ITcAdsSymbol type exposes the following members.
Properties
Name | Description
Comment | Gets the comment behind the variable declaration.
IndexGroup | Gets the index group of the symbol.
IndexOffset | Gets the index offset of the symbol.
Name | Gets the name of the symbol.
Size | Gets the size of the symbol (in Bytes or bits dependent on IsBitType).
Remarks
The most sophisticated implementation of this interface is ITcAdsSymbol"/>
Reference
TwinCAT.Ads Namespace
TwinCAT.Ads.ITcAdsSymbol5
Weiterführende Informationen
•
ITcAdsSymbol Properties


ITcAdsSymbol Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol Interface [image] ITcAdsSymbol Properties
ITcAdsSymbol Properties
The ITcAdsSymbol type exposes the following members.
Properties
Name | Description
Comment | Gets the comment behind the variable declaration.
IndexGroup | Gets the index group of the symbol.
IndexOffset | Gets the index offset of the symbol.
Name | Gets the name of the symbol.
Size | Gets the size of the symbol (in Bytes or bits dependent on IsBitType).
Reference
ITcAdsSymbol Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsSymbol.Comment Property
•
ITcAdsSymbol.IndexGroup Property
•
ITcAdsSymbol.IndexOffset Property
•
ITcAdsSymbol.Name Property
•
ITcAdsSymbol.Size Property


ITcAdsSymbol.Comment Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol Interface [image] ITcAdsSymbol Properties [image] ITcAdsSymbol.Comment Property
ITcAdsSymbol.Comment Property
Gets the comment behind the variable declaration.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Comment { get; }
VB
ReadOnly Property Comment As String
Get
Property Value
Type: String
Comment behind the variable declaration.
Reference
ITcAdsSymbol Interface
TwinCAT.Ads Namespace


ITcAdsSymbol.IndexGroup Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol Interface [image] ITcAdsSymbol Properties [image] ITcAdsSymbol.IndexGroup Property
ITcAdsSymbol.IndexGroup Property
Gets the index group of the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
long IndexGroup { get; }
VB
ReadOnly Property IndexGroup As Long
Get
Property Value
Type: Int64
Index group of the symbol.
Reference
ITcAdsSymbol Interface
TwinCAT.Ads Namespace


ITcAdsSymbol.IndexOffset Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol Interface [image] ITcAdsSymbol Properties [image] ITcAdsSymbol.IndexOffset Property
ITcAdsSymbol.IndexOffset Property
Gets the index offset of the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
long IndexOffset { get; }
VB
ReadOnly Property IndexOffset As Long
Get
Property Value
Type: Int64
Index offset of the symbol.
Reference
ITcAdsSymbol Interface
TwinCAT.Ads Namespace


ITcAdsSymbol.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol Interface [image] ITcAdsSymbol Properties [image] ITcAdsSymbol.Name Property
ITcAdsSymbol.Name Property
Gets the name of the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Name { get; }
VB
ReadOnly Property Name As String
Get
Property Value
Type: String
Name of the symbol.
Reference
ITcAdsSymbol Interface
TwinCAT.Ads Namespace


ITcAdsSymbol.Size Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol Interface [image] ITcAdsSymbol Properties [image] ITcAdsSymbol.Size Property
ITcAdsSymbol.Size Property
Gets the size of the symbol (in Bytes or bits dependent on IsBitType).
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Size { get; }
VB
ReadOnly Property Size As Integer
Get
Property Value
Type: Int32
Size of the symbol in Bytes / Bits
Reference
ITcAdsSymbol Interface
TwinCAT.Ads Namespace


ITcAdsSymbol2 Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol2 Interface
ITcAdsSymbol2 Interface
Interface ITcAdsSymbol2 (extends ITcAdsSymbol)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ITcAdsSymbol2 : ITcAdsSymbol
VB
Public Interface ITcAdsSymbol2
Inherits ITcAdsSymbol
The ITcAdsSymbol2 type exposes the following members.
Properties
Name | Description
Comment | Gets the comment behind the variable declaration. (Inherited from ITcAdsSymbol.)
ContextMask | Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications.
IndexGroup | Gets the index group of the symbol. (Inherited from ITcAdsSymbol.)
IndexOffset | Gets the index offset of the symbol. (Inherited from ITcAdsSymbol.)
IsBitType | Indicates if the BitValue flag is set for the symbol.
IsPersistent | Indicates if the Persistent flag is set for the symbol.
IsReadOnly | Indicates if the ReadOnly flag is set for the symbol.
IsTcComInterfacePointer | Indicates if the TcComInterfacePointer flag is set for the symbol.
IsTypeGuid | Indicates if the TypeGuid flag is set for the symbol.
Name | Gets the name of the symbol. (Inherited from ITcAdsSymbol.)
Size | Gets the size of the symbol (in Bytes or bits dependent on IsBitType). (Inherited from ITcAdsSymbol.)
Remarks
The most sophisticated implementation of this interface is ITcAdsSymbol"/>
Reference
TwinCAT.Ads Namespace
TwinCAT.Ads.ITcAdsSymbol5
Weiterführende Informationen
•
ITcAdsSymbol2 Properties


ITcAdsSymbol2 Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol2 Interface [image] ITcAdsSymbol2 Properties
ITcAdsSymbol2 Properties
The ITcAdsSymbol2 type exposes the following members.
Properties
Name | Description
Comment | Gets the comment behind the variable declaration. (Inherited from ITcAdsSymbol.)
ContextMask | Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications.
IndexGroup | Gets the index group of the symbol. (Inherited from ITcAdsSymbol.)
IndexOffset | Gets the index offset of the symbol. (Inherited from ITcAdsSymbol.)
IsBitType | Indicates if the BitValue flag is set for the symbol.
IsPersistent | Indicates if the Persistent flag is set for the symbol.
IsReadOnly | Indicates if the ReadOnly flag is set for the symbol.
IsTcComInterfacePointer | Indicates if the TcComInterfacePointer flag is set for the symbol.
IsTypeGuid | Indicates if the TypeGuid flag is set for the symbol.
Name | Gets the name of the symbol. (Inherited from ITcAdsSymbol.)
Size | Gets the size of the symbol (in Bytes or bits dependent on IsBitType). (Inherited from ITcAdsSymbol.)
Reference
ITcAdsSymbol2 Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsSymbol2.ContextMask Property
•
ITcAdsSymbol2.IsBitType Property
•
ITcAdsSymbol2.IsPersistent Property
•
ITcAdsSymbol2.IsReadOnly Property
•
ITcAdsSymbol2.IsTcComInterfacePointer Property
•
ITcAdsSymbol2.IsTypeGuid Property


ITcAdsSymbol2.ContextMask Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol2 Interface [image] ITcAdsSymbol2 Properties [image] ITcAdsSymbol2.ContextMask Property
ITcAdsSymbol2.ContextMask Property
Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int ContextMask { get; }
VB
ReadOnly Property ContextMask As Integer
Get
Property Value
Type: Int32
Reference
ITcAdsSymbol2 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol2.IsBitType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol2 Interface [image] ITcAdsSymbol2 Properties [image] ITcAdsSymbol2.IsBitType Property
ITcAdsSymbol2.IsBitType Property
Indicates if the BitValue flag is set for the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsBitType { get; }
VB
ReadOnly Property IsBitType As Boolean
Get
Property Value
Type: Boolean
true if is BitValue, otherwise false.
Reference
ITcAdsSymbol2 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol2.IsPersistent Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol2 Interface [image] ITcAdsSymbol2 Properties [image] ITcAdsSymbol2.IsPersistent Property
ITcAdsSymbol2.IsPersistent Property
Indicates if the Persistent flag is set for the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsPersistent { get; }
VB
ReadOnly Property IsPersistent As Boolean
Get
Property Value
Type: Boolean
true if persistent, otherwise false.
Reference
ITcAdsSymbol2 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol2.IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol2 Interface [image] ITcAdsSymbol2 Properties [image] ITcAdsSymbol2.IsReadOnly Property
ITcAdsSymbol2.IsReadOnly Property
Indicates if the ReadOnly flag is set for the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsReadOnly { get; }
VB
ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if ReadOnly, otherwise false.
Reference
ITcAdsSymbol2 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol2.IsTcComInterfacePointer Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol2 Interface [image] ITcAdsSymbol2 Properties [image] ITcAdsSymbol2.IsTcComInterfacePointer Property
ITcAdsSymbol2.IsTcComInterfacePointer Property
Indicates if the TcComInterfacePointer flag is set for the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsTcComInterfacePointer { get; }
VB
ReadOnly Property IsTcComInterfacePointer As Boolean
Get
Property Value
Type: Boolean
true if is TcComInterfacePointer, otherwise false.
Reference
ITcAdsSymbol2 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol2.IsTypeGuid Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol2 Interface [image] ITcAdsSymbol2 Properties [image] ITcAdsSymbol2.IsTypeGuid Property
ITcAdsSymbol2.IsTypeGuid Property
Indicates if the TypeGuid flag is set for the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsTypeGuid { get; }
VB
ReadOnly Property IsTypeGuid As Boolean
Get
Property Value
Type: Boolean
true if is TypeGuid, otherwise false.
Reference
ITcAdsSymbol2 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol3 Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol3 Interface
ITcAdsSymbol3 Interface
Interface ITcAdsSymbol3 (extends ITcAdsSymbol ... ITcAdsSymbol3)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ITcAdsSymbol3 : ITcAdsSymbol2,
ITcAdsSymbol
VB
Public Interface ITcAdsSymbol3
Inherits ITcAdsSymbol2, ITcAdsSymbol
The ITcAdsSymbol3 type exposes the following members.
Properties
Name | Description
ArrayDimensions | Gets the array dimensions.
ArrayInfos | Gets the collection of Array Infos.
Comment | Gets the comment behind the variable declaration. (Inherited from ITcAdsSymbol.)
ContextMask | Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications. (Inherited from ITcAdsSymbol2.)
IndexGroup | Gets the index group of the symbol. (Inherited from ITcAdsSymbol.)
IndexOffset | Gets the index offset of the symbol. (Inherited from ITcAdsSymbol.)
IsBitType | Indicates if the BitValue flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsPersistent | Indicates if the Persistent flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsReadOnly | Indicates if the ReadOnly flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsTcComInterfacePointer | Indicates if the TcComInterfacePointer flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsTypeGuid | Indicates if the TypeGuid flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
Name | Gets the name of the symbol. (Inherited from ITcAdsSymbol.)
Size | Gets the size of the symbol (in Bytes or bits dependent on IsBitType). (Inherited from ITcAdsSymbol.)
Remarks
The most sophisticated implementation of this interface is ITcAdsSymbol"/>
Reference
TwinCAT.Ads Namespace
TwinCAT.Ads.ITcAdsSymbol5
Weiterführende Informationen
•
ITcAdsSymbol3 Properties


ITcAdsSymbol3 Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol3 Interface [image] ITcAdsSymbol3 Properties
ITcAdsSymbol3 Properties
The ITcAdsSymbol3 type exposes the following members.
Properties
Name | Description
ArrayDimensions | Gets the array dimensions.
ArrayInfos | Gets the collection of Array Infos.
Comment | Gets the comment behind the variable declaration. (Inherited from ITcAdsSymbol.)
ContextMask | Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications. (Inherited from ITcAdsSymbol2.)
IndexGroup | Gets the index group of the symbol. (Inherited from ITcAdsSymbol.)
IndexOffset | Gets the index offset of the symbol. (Inherited from ITcAdsSymbol.)
IsBitType | Indicates if the BitValue flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsPersistent | Indicates if the Persistent flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsReadOnly | Indicates if the ReadOnly flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsTcComInterfacePointer | Indicates if the TcComInterfacePointer flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsTypeGuid | Indicates if the TypeGuid flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
Name | Gets the name of the symbol. (Inherited from ITcAdsSymbol.)
Size | Gets the size of the symbol (in Bytes or bits dependent on IsBitType). (Inherited from ITcAdsSymbol.)
Reference
ITcAdsSymbol3 Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsSymbol3.ArrayDimensions Property
•
ITcAdsSymbol3.ArrayInfos Property


ITcAdsSymbol3.ArrayDimensions Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol3 Interface [image] ITcAdsSymbol3 Properties [image] ITcAdsSymbol3.ArrayDimensions Property
ITcAdsSymbol3.ArrayDimensions Property
Gets the array dimensions.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int ArrayDimensions { get; }
VB
ReadOnly Property ArrayDimensions As Integer
Get
Property Value
Type: Int32
The array dimensions.
Reference
ITcAdsSymbol3 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol3.ArrayInfos Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol3 Interface [image] ITcAdsSymbol3 Properties [image] ITcAdsSymbol3.ArrayInfos Property
ITcAdsSymbol3.ArrayInfos Property
Gets the collection of Array Infos.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsDatatypeArrayInfo[] ArrayInfos { get; }
VB
ReadOnly Property ArrayInfos As AdsDatatypeArrayInfo()
Get
Property Value
Type: .AdsDatatypeArrayInfo.
The array infos.
Reference
ITcAdsSymbol3 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol4 Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol4 Interface
ITcAdsSymbol4 Interface
Interface ITcAdsSymbol4 (extends ITcAdsSymbol ... ITcAdsSymbol3
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ITcAdsSymbol4 : ITcAdsSymbol3,
ITcAdsSymbol2, ITcAdsSymbol
VB
Public Interface ITcAdsSymbol4
Inherits ITcAdsSymbol3, ITcAdsSymbol2, ITcAdsSymbol
The ITcAdsSymbol4 type exposes the following members.
Properties
Name | Description
ArrayDimensions | Gets the array dimensions. (Inherited from ITcAdsSymbol3.)
ArrayInfos | Gets the collection of Array Infos. (Inherited from ITcAdsSymbol3.)
Attributes | Gets the attribute count of the ITcAdsSymbol
BitSize | Gets the Bit Size of the Symbol
ByteSize | Gets the Byte Size of the Symbol
Category | Gets the Data Type Category
Comment | Gets the comment behind the variable declaration. (Inherited from ITcAdsSymbol.)
ContextMask | Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications. (Inherited from ITcAdsSymbol2.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only)
IndexGroup | Gets the index group of the symbol. (Inherited from ITcAdsSymbol.)
IndexOffset | Gets the index offset of the symbol. (Inherited from ITcAdsSymbol.)
IsBitType | Indicates if the BitValue flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsPersistent | Indicates if the Persistent flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsReadOnly | Indicates if the ReadOnly flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsTcComInterfacePointer | Indicates if the TcComInterfacePointer flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsTypeGuid | Indicates if the TypeGuid flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
Name | Gets the name of the symbol. (Inherited from ITcAdsSymbol.)
RpcMethods | Gets the RPC method descriptions
Size | Gets the size of the symbol (in Bytes or bits dependent on IsBitType). (Inherited from ITcAdsSymbol.)
Remarks
The most sophisticated implementation of this interface is ITcAdsSymbol"/>
Reference
TwinCAT.Ads Namespace
TwinCAT.Ads.ITcAdsSymbol5
Weiterführende Informationen
•
ITcAdsSymbol4 Properties


ITcAdsSymbol4 Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol4 Interface [image] ITcAdsSymbol4 Properties
ITcAdsSymbol4 Properties
The ITcAdsSymbol4 type exposes the following members.
Properties
Name | Description
ArrayDimensions | Gets the array dimensions. (Inherited from ITcAdsSymbol3.)
ArrayInfos | Gets the collection of Array Infos. (Inherited from ITcAdsSymbol3.)
Attributes | Gets the attribute count of the ITcAdsSymbol
BitSize | Gets the Bit Size of the Symbol
ByteSize | Gets the Byte Size of the Symbol
Category | Gets the Data Type Category
Comment | Gets the comment behind the variable declaration. (Inherited from ITcAdsSymbol.)
ContextMask | Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications. (Inherited from ITcAdsSymbol2.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only)
IndexGroup | Gets the index group of the symbol. (Inherited from ITcAdsSymbol.)
IndexOffset | Gets the index offset of the symbol. (Inherited from ITcAdsSymbol.)
IsBitType | Indicates if the BitValue flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsPersistent | Indicates if the Persistent flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsReadOnly | Indicates if the ReadOnly flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsTcComInterfacePointer | Indicates if the TcComInterfacePointer flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsTypeGuid | Indicates if the TypeGuid flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
Name | Gets the name of the symbol. (Inherited from ITcAdsSymbol.)
RpcMethods | Gets the RPC method descriptions
Size | Gets the size of the symbol (in Bytes or bits dependent on IsBitType). (Inherited from ITcAdsSymbol.)
Reference
ITcAdsSymbol4 Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsSymbol4.Attributes Property
•
ITcAdsSymbol4.BitSize Property
•
ITcAdsSymbol4.ByteSize Property
•
ITcAdsSymbol4.Category Property
•
ITcAdsSymbol4.HasRpcMethods Property
•
ITcAdsSymbol4.RpcMethods Property


ITcAdsSymbol4.Attributes Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol4 Interface [image] ITcAdsSymbol4 Properties [image] ITcAdsSymbol4.Attributes Property
ITcAdsSymbol4.Attributes Property
Gets the attribute count of the ITcAdsSymbol
Gets the attributes of the ITcAdsSymbol
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyTypeAttributeCollection Attributes { get; }
VB
ReadOnly Property Attributes As ReadOnlyTypeAttributeCollection
Get
Property Value
Type: ReadOnlyTypeAttributeCollection
The attribute count.
Property Value
Type: ReadOnlyTypeAttributeCollection
The attributes.
Reference
ITcAdsSymbol4 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol4.BitSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol4 Interface [image] ITcAdsSymbol4 Properties [image] ITcAdsSymbol4.BitSize Property
ITcAdsSymbol4.BitSize Property
Gets the Bit Size of the Symbol
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int BitSize { get; }
VB
ReadOnly Property BitSize As Integer
Get
Property Value
Type: Int32
The Bit Size of the underlying data type.
Reference
ITcAdsSymbol4 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol4.ByteSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol4 Interface [image] ITcAdsSymbol4 Properties [image] ITcAdsSymbol4.ByteSize Property
ITcAdsSymbol4.ByteSize Property
Gets the Byte Size of the Symbol
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int ByteSize { get; }
VB
ReadOnly Property ByteSize As Integer
Get
Property Value
Type: Int32
The Byte Size of the underlying data type.
Reference
ITcAdsSymbol4 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol4.Category Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol4 Interface [image] ITcAdsSymbol4 Properties [image] ITcAdsSymbol4.Category Property
ITcAdsSymbol4.Category Property
Gets the Data Type Category
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
DataTypeCategory Category { get; }
VB
ReadOnly Property Category As DataTypeCategory
Get
Property Value
Type: DataTypeCategory
The category.
Reference
ITcAdsSymbol4 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol4.HasRpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol4 Interface [image] ITcAdsSymbol4 Properties [image] ITcAdsSymbol4.HasRpcMethods Property
ITcAdsSymbol4.HasRpcMethods Property
Gets a value indicating whether this instance has RPC methods (Struct types only)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool HasRpcMethods { get; }
VB
ReadOnly Property HasRpcMethods As Boolean
Get
Property Value
Type: Boolean
true if this instance has RPC methods; otherwise, false.
Remarks
The DataType (Structure) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods, otherwise RpcMethods are not passed through to the ADS symbolic information.
Reference
ITcAdsSymbol4 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol4.RpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol4 Interface [image] ITcAdsSymbol4 Properties [image] ITcAdsSymbol4.RpcMethods Property
ITcAdsSymbol4.RpcMethods Property
Gets the RPC method descriptions
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyRpcMethodCollection RpcMethods { get; }
VB
ReadOnly Property RpcMethods As ReadOnlyRpcMethodCollection
Get
Property Value
Type: ReadOnlyRpcMethodCollection
The RPC methods.
Remarks
The DataType (Structure) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods, otherwise RpcMethods are not passed through to the ADS symbolic information.
Reference
ITcAdsSymbol4 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol5 Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol5 Interface
ITcAdsSymbol5 Interface
Interface ITcAdsSymbol5 (extends ITcAdsSymbol ... ITcAdsSymbol4
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ITcAdsSymbol5 : ITcAdsSymbol4,
ITcAdsSymbol3, ITcAdsSymbol2, ITcAdsSymbol
VB
Public Interface ITcAdsSymbol5
Inherits ITcAdsSymbol4, ITcAdsSymbol3, ITcAdsSymbol2, ITcAdsSymbol
The ITcAdsSymbol5 type exposes the following members.
Properties
Name | Description
ArrayDimensions | Gets the array dimensions. (Inherited from ITcAdsSymbol3.)
ArrayInfos | Gets the collection of Array Infos. (Inherited from ITcAdsSymbol3.)
Attributes | Gets the attribute count of the ITcAdsSymbol (Inherited from ITcAdsSymbol4.)
BitSize | Gets the Bit Size of the Symbol (Inherited from ITcAdsSymbol4.)
ByteSize | Gets the Byte Size of the Symbol (Inherited from ITcAdsSymbol4.)
Category | Gets the Data Type Category (Inherited from ITcAdsSymbol4.)
Comment | Gets the comment behind the variable declaration. (Inherited from ITcAdsSymbol.)
ContextMask | Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications. (Inherited from ITcAdsSymbol2.)
DataType | Gets the Data type object of the Symbol.
DataTypeId | DataType identifier of the Symbol AdsDatatypeId
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only) (Inherited from ITcAdsSymbol4.)
IndexGroup | Gets the index group of the symbol. (Inherited from ITcAdsSymbol.)
IndexOffset | Gets the index offset of the symbol. (Inherited from ITcAdsSymbol.)
IsBitType | Indicates if the BitValue flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsPersistent | Indicates if the Persistent flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsReadOnly | Indicates if the ReadOnly flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsStatic | Gets a value indicating whether the Symbol is static.
IsTcComInterfacePointer | Indicates if the TcComInterfacePointer flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsTypeGuid | Indicates if the TypeGuid flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
Name | Gets the name of the symbol. (Inherited from ITcAdsSymbol.)
RpcMethods | Gets the RPC method descriptions (Inherited from ITcAdsSymbol4.)
Size | Gets the size of the symbol (in Bytes or bits dependent on IsBitType). (Inherited from ITcAdsSymbol.)
TypeName | Gets the name of the symbol data type.
Methods
Name | Description
IsRecursive | Gets a value indicating whether this instance is recursive.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsSymbol5 Properties
•
ITcAdsSymbol5 Methods


ITcAdsSymbol5 Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol5 Interface [image] ITcAdsSymbol5 Properties
ITcAdsSymbol5 Properties
The ITcAdsSymbol5 type exposes the following members.
Properties
Name | Description
ArrayDimensions | Gets the array dimensions. (Inherited from ITcAdsSymbol3.)
ArrayInfos | Gets the collection of Array Infos. (Inherited from ITcAdsSymbol3.)
Attributes | Gets the attribute count of the ITcAdsSymbol (Inherited from ITcAdsSymbol4.)
BitSize | Gets the Bit Size of the Symbol (Inherited from ITcAdsSymbol4.)
ByteSize | Gets the Byte Size of the Symbol (Inherited from ITcAdsSymbol4.)
Category | Gets the Data Type Category (Inherited from ITcAdsSymbol4.)
Comment | Gets the comment behind the variable declaration. (Inherited from ITcAdsSymbol.)
ContextMask | Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications. (Inherited from ITcAdsSymbol2.)
DataType | Gets the Data type object of the Symbol.
DataTypeId | DataType identifier of the Symbol AdsDatatypeId
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only) (Inherited from ITcAdsSymbol4.)
IndexGroup | Gets the index group of the symbol. (Inherited from ITcAdsSymbol.)
IndexOffset | Gets the index offset of the symbol. (Inherited from ITcAdsSymbol.)
IsBitType | Indicates if the BitValue flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsPersistent | Indicates if the Persistent flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsReadOnly | Indicates if the ReadOnly flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsStatic | Gets a value indicating whether the Symbol is static.
IsTcComInterfacePointer | Indicates if the TcComInterfacePointer flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
IsTypeGuid | Indicates if the TypeGuid flag is set for the symbol. (Inherited from ITcAdsSymbol2.)
Name | Gets the name of the symbol. (Inherited from ITcAdsSymbol.)
RpcMethods | Gets the RPC method descriptions (Inherited from ITcAdsSymbol4.)
Size | Gets the size of the symbol (in Bytes or bits dependent on IsBitType). (Inherited from ITcAdsSymbol.)
TypeName | Gets the name of the symbol data type.
Reference
ITcAdsSymbol5 Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsSymbol5.DataType Property
•
ITcAdsSymbol5.DataTypeId Property
•
ITcAdsSymbol5.IsStatic Property
•
ITcAdsSymbol5.TypeName Property


ITcAdsSymbol5.DataType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol5 Interface [image] ITcAdsSymbol5 Properties [image] ITcAdsSymbol5.DataType Property
ITcAdsSymbol5.DataType Property
Gets the Data type object of the Symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ITcAdsDataType DataType { get; }
VB
ReadOnly Property DataType As ITcAdsDataType
Get
Property Value
Type: ITcAdsDataType
The data type object or NULL if not resolved.
Reference
ITcAdsSymbol5 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol5.DataTypeId Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol5 Interface [image] ITcAdsSymbol5 Properties [image] ITcAdsSymbol5.DataTypeId Property
ITcAdsSymbol5.DataTypeId Property
DataType identifier of the Symbol AdsDatatypeId
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsDatatypeId DataTypeId { get; }
VB
ReadOnly Property DataTypeId As AdsDatatypeId
Get
Property Value
Type: AdsDatatypeId
Data type of the symbol.
Reference
ITcAdsSymbol5 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol5.IsStatic Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol5 Interface [image] ITcAdsSymbol5 Properties [image] ITcAdsSymbol5.IsStatic Property
ITcAdsSymbol5.IsStatic Property
Gets a value indicating whether the Symbol is static.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsStatic { get; }
VB
ReadOnly Property IsStatic As Boolean
Get
Property Value
Type: Boolean
true if this instance is static; otherwise, false.
Reference
ITcAdsSymbol5 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol5.TypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol5 Interface [image] ITcAdsSymbol5 Properties [image] ITcAdsSymbol5.TypeName Property
ITcAdsSymbol5.TypeName Property
Gets the name of the symbol data type.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string TypeName { get; }
VB
ReadOnly Property TypeName As String
Get
Property Value
Type: String
Name of the symbol data type.
Reference
ITcAdsSymbol5 Interface
TwinCAT.Ads Namespace


ITcAdsSymbol5 Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol5 Interface [image] ITcAdsSymbol5 Methods
ITcAdsSymbol5 Methods
The ITcAdsSymbol5 type exposes the following members.
Methods
Name | Description
IsRecursive | Gets a value indicating whether this instance is recursive.
Reference
ITcAdsSymbol5 Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsSymbol5.IsRecursive Method


ITcAdsSymbol5.IsRecursive Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbol5 Interface [image] ITcAdsSymbol5 Methods [image] ITcAdsSymbol5.IsRecursive Method
ITcAdsSymbol5.IsRecursive Method
Gets a value indicating whether this instance is recursive.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsRecursive(
IEnumerable<ITcAdsSymbol5> parents
)
VB
Function IsRecursive (
parents As IEnumerable(Of ITcAdsSymbol5)
) As Boolean
Parameters
parents
Type: System.Collections.Generic.IEnumerable.ITcAdsSymbol5.
The parents.
Field Value
Type: Boolean
true if this instance is recursive; otherwise, false.
Return Value
Type: Boolean
true if the specified parents is recursive; otherwise, false.
Reference
ITcAdsSymbol5 Interface
TwinCAT.Ads Namespace


ITcAdsSymbolBrowser Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbolBrowser Interface
ITcAdsSymbolBrowser Interface
Interface ITcAdsSubSymbolProvider
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ITcAdsSymbolBrowser
VB
Public Interface ITcAdsSymbolBrowser
The ITcAdsSymbolBrowser type exposes the following members.
Properties
Name | Description
SubSymbols | GetSubSymbols of this symbol.
Remarks
Interface used for ITcAdsSymbol objects that support subsymbols (e.g. Arrays, References, Structs)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsSymbolBrowser Properties


ITcAdsSymbolBrowser Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbolBrowser Interface [image] ITcAdsSymbolBrowser Properties
ITcAdsSymbolBrowser Properties
The ITcAdsSymbolBrowser type exposes the following members.
Properties
Name | Description
SubSymbols | GetSubSymbols of this symbol.
Reference
ITcAdsSymbolBrowser Interface
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ITcAdsSymbolBrowser.SubSymbols Property


ITcAdsSymbolBrowser.SubSymbols Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ITcAdsSymbolBrowser Interface [image] ITcAdsSymbolBrowser Properties [image] ITcAdsSymbolBrowser.SubSymbols Property
ITcAdsSymbolBrowser.SubSymbols Property
GetSubSymbols of this symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
TcAdsSymbolInfoCollection SubSymbols { get; }
VB
ReadOnly Property SubSymbols As TcAdsSymbolInfoCollection
Get
Property Value
Type: TcAdsSymbolInfoCollection
The SubSymbols.
Reference
ITcAdsSymbolBrowser Interface
TwinCAT.Ads Namespace


NotificationSettings Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class
NotificationSettings Class
Notification communication settings
Inheritance Hierarchy
System.Object
TwinCAT.Ads.NotificationSettings
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class NotificationSettings : INotificationSettings,
IComparable<INotificationSettings>
VB
Public Class NotificationSettings
Implements INotificationSettings, IComparable(Of INotificationSettings)
The NotificationSettings type exposes the following members.
Constructors
Name | Description
NotificationSettings | Initializes a new instance of the NotificationSettings class.
Properties
Name | Description
CycleTime | Gets or sets the cycle time (in milliseconds) for AdsNotifications.
Default | Gets the default Settings (AdsTransMode.OnChange, CycleTime 200 ms, MaxDelay: off)
MaxDelay | Gets or sets the Maximum Delay Time (in milliseconds) for AdsNotifications.
NotificationMode | Gets or sets the ADS Transmission mode.
Methods
Name | Description
CompareTo | Compares this NotificationSettings in term of priorities to the other NotificationSettings.
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
NotificationSettings Constructor
•
NotificationSettings Properties
•
NotificationSettings Methods
•
NotificationSettings Operators


NotificationSettings Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Constructor
NotificationSettings Constructor
Initializes a new instance of the NotificationSettings class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public NotificationSettings(
AdsTransMode mode,
int cycleTime,
int maxDelay
)
VB
Public Sub New (
mode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer
)
Parameters
mode | Type: TwinCAT.Ads.AdsTransMode The ADS Transmission mode.
cycleTime | Type: System.Int32 The cycle time in ms.
maxDelay | Type: System.Int32 The maximum delay in ms
Reference
NotificationSettings Class
TwinCAT.Ads Namespace


NotificationSettings Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Properties
NotificationSettings Properties
The NotificationSettings type exposes the following members.
Properties
Name | Description
CycleTime | Gets or sets the cycle time (in milliseconds) for AdsNotifications.
Default | Gets the default Settings (AdsTransMode.OnChange, CycleTime 200 ms, MaxDelay: off)
MaxDelay | Gets or sets the Maximum Delay Time (in milliseconds) for AdsNotifications.
NotificationMode | Gets or sets the ADS Transmission mode.
Reference
NotificationSettings Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
NotificationSettings.CycleTime Property
•
NotificationSettings.Default Property
•
NotificationSettings.MaxDelay Property
•
NotificationSettings.NotificationMode Property


NotificationSettings.CycleTime Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Properties [image] NotificationSettings.CycleTime Property
NotificationSettings.CycleTime Property
Gets or sets the cycle time (in milliseconds) for AdsNotifications.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int CycleTime { get; }
VB
Public ReadOnly Property CycleTime As Integer
Get
Property Value
Type: Int32
The cycle time.
Remarks
The ADS server checks if the value changes in this time slice. The unit is 1ms
Reference
NotificationSettings Class
TwinCAT.Ads Namespace


NotificationSettings.Default Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Properties [image] NotificationSettings.Default Property
NotificationSettings.Default Property
Gets the default Settings (AdsTransMode.OnChange, CycleTime 200 ms, MaxDelay: off)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static NotificationSettings Default { get; }
VB
Public Shared ReadOnly Property Default As NotificationSettings
Get
Property Value
Type: NotificationSettings
The default.
Reference
NotificationSettings Class
TwinCAT.Ads Namespace


NotificationSettings.MaxDelay Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Properties [image] NotificationSettings.MaxDelay Property
NotificationSettings.MaxDelay Property
Gets or sets the Maximum Delay Time (in milliseconds) for AdsNotifications.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int MaxDelay { get; }
VB
Public ReadOnly Property MaxDelay As Integer
Get
Property Value
Type: Int32
The maximum Delay time for ADS Notifications.
Reference
NotificationSettings Class
TwinCAT.Ads Namespace


NotificationSettings.NotificationMode Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Properties [image] NotificationSettings.NotificationMode Property
NotificationSettings.NotificationMode Property
Gets or sets the ADS Transmission mode.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsTransMode NotificationMode { get; }
VB
Public ReadOnly Property NotificationMode As AdsTransMode
Get
Property Value
Type: AdsTransMode
The Transmission mode.
Reference
NotificationSettings Class
TwinCAT.Ads Namespace


NotificationSettings Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Methods
NotificationSettings Methods
The NotificationSettings type exposes the following members.
Methods
Name | Description
CompareTo | Compares this NotificationSettings in term of priorities to the other NotificationSettings.
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
NotificationSettings Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
NotificationSettings.CompareTo Method
•
NotificationSettings.Equals Method
•
NotificationSettings.GetHashCode Method


NotificationSettings.CompareTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Methods [image] NotificationSettings.CompareTo Method
NotificationSettings.CompareTo Method
Compares this NotificationSettings in term of priorities to the other NotificationSettings.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int CompareTo(
INotificationSettings other
)
VB
Public Function CompareTo (
other As INotificationSettings
) As Integer
Parameters
other
Type: TwinCAT.TypeSystem.INotificationSettings
The other.
Return Value
Type: Int32
1: this has higher priority (shorter times), 0: Equal, 1: Lower prioritiy
Implements
IComparable.T..CompareTo(T)
Reference
NotificationSettings Class
TwinCAT.Ads Namespace
NotificationSettingsPriorityComparer


NotificationSettings.Equals Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Methods [image] NotificationSettings.Equals Method
NotificationSettings.Equals Method
Equals
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool Equals(
Object obj
)
VB
Public Overrides Function Equals (
obj As Object
) As Boolean
Parameters
obj
Type: System.Object
The object to compare with the current object.
Return Value
Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Reference
NotificationSettings Class
TwinCAT.Ads Namespace


NotificationSettings.GetHashCode Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Methods [image] NotificationSettings.GetHashCode Method
NotificationSettings.GetHashCode Method
Gets the HashCode of the Address
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override int GetHashCode()
VB
Public Overrides Function GetHashCode As Integer
Return Value
Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
Reference
NotificationSettings Class
TwinCAT.Ads Namespace


NotificationSettings Operators

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Operators
NotificationSettings Operators
The NotificationSettings type exposes the following members.
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Reference
NotificationSettings Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
NotificationSettings.Equality Operator
•
NotificationSettings.Inequality Operator


NotificationSettings.Equality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Operators [image] NotificationSettings.Equality Operator
NotificationSettings.Equality Operator
Operator==
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator ==(
NotificationSettings o1,
NotificationSettings o2
)
VB
Public Shared Operator = (
o1 As NotificationSettings,
o2 As NotificationSettings
) As Boolean
Parameters
o1 | Type: TwinCAT.Ads.NotificationSettings The o1.
o2 | Type: TwinCAT.Ads.NotificationSettings The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
NotificationSettings Class
TwinCAT.Ads Namespace


NotificationSettings.Inequality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] NotificationSettings Class [image] NotificationSettings Operators [image] NotificationSettings.Inequality Operator
NotificationSettings.Inequality Operator
Implements the != operator.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator !=(
NotificationSettings o1,
NotificationSettings o2
)
VB
Public Shared Operator <> (
o1 As NotificationSettings,
o2 As NotificationSettings
) As Boolean
Parameters
o1 | Type: TwinCAT.Ads.NotificationSettings The o1.
o2 | Type: TwinCAT.Ads.NotificationSettings The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
NotificationSettings Class
TwinCAT.Ads Namespace


ReadOnlyTcAdsDataTypeCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ReadOnlyTcAdsDataTypeCollection Class
ReadOnlyTcAdsDataTypeCollection Class
Read only collection of ITcAdsDataType" types.
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.ITcAdsDataType.
TwinCAT.Ads.ReadOnlyTcAdsDataTypeCollection
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyTcAdsDataTypeCollection : ReadOnlyCollection<ITcAdsDataType>,
IEnumerable<IDataType>, IEnumerable
VB
Public Class ReadOnlyTcAdsDataTypeCollection
Inherits ReadOnlyCollection(Of ITcAdsDataType)
Implements IEnumerable(Of IDataType), IEnumerable
The ReadOnlyTcAdsDataTypeCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
Item.String. | Gets the ITcAdsDataType with the specified type name.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
Methods
Name | Description
Contains(String) | Determines whether this ReadOnlyTcAdsDataTypeCollection contains the specified type name.
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetDataType | Tries to get the specified type name.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ReadOnlyTcAdsDataTypeCollection Properties
•
ReadOnlyTcAdsDataTypeCollection Methods


ReadOnlyTcAdsDataTypeCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ReadOnlyTcAdsDataTypeCollection Class [image] ReadOnlyTcAdsDataTypeCollection Properties
ReadOnlyTcAdsDataTypeCollection Properties
The ReadOnlyTcAdsDataTypeCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
Item.String. | Gets the ITcAdsDataType with the specified type name.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
Reference
ReadOnlyTcAdsDataTypeCollection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ReadOnlyTcAdsDataTypeCollection.Item Property


ReadOnlyTcAdsDataTypeCollection.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ReadOnlyTcAdsDataTypeCollection Class [image] ReadOnlyTcAdsDataTypeCollection Properties [image] ReadOnlyTcAdsDataTypeCollection.Item Property
ReadOnlyTcAdsDataTypeCollection.Item Property
Overload List
Name | Description
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
Item.String. | Gets the ITcAdsDataType with the specified type name.
Reference
ReadOnlyTcAdsDataTypeCollection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ReadOnlyTcAdsDataTypeCollection.Item Property (String)


ReadOnlyTcAdsDataTypeCollection.Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ReadOnlyTcAdsDataTypeCollection Class [image] ReadOnlyTcAdsDataTypeCollection Properties [image] ReadOnlyTcAdsDataTypeCollection.Item Property [image] ReadOnlyTcAdsDataTypeCollection.Item Property (String)
ReadOnlyTcAdsDataTypeCollection.Item Property (String)
Gets the ITcAdsDataType with the specified type name.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ITcAdsDataType this[
string typeName
] { get; }
VB
Public ReadOnly Default Property Item (
typeName As String
) As ITcAdsDataType
Get
Parameters
typeName
Type: System.String
Name of the type.
Return Value
Type: ITcAdsDataType
ITcAdsDataType.
Reference
ReadOnlyTcAdsDataTypeCollection Class
Item Overload
TwinCAT.Ads Namespace


ReadOnlyTcAdsDataTypeCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ReadOnlyTcAdsDataTypeCollection Class [image] ReadOnlyTcAdsDataTypeCollection Methods
ReadOnlyTcAdsDataTypeCollection Methods
The ReadOnlyTcAdsDataTypeCollection type exposes the following members.
Methods
Name | Description
Contains(String) | Determines whether this ReadOnlyTcAdsDataTypeCollection contains the specified type name.
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetDataType | Tries to get the specified type name.
Reference
ReadOnlyTcAdsDataTypeCollection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ReadOnlyTcAdsDataTypeCollection.Contains Method
•
ReadOnlyTcAdsDataTypeCollection.TryGetDataType Method


ReadOnlyTcAdsDataTypeCollection.Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ReadOnlyTcAdsDataTypeCollection Class [image] ReadOnlyTcAdsDataTypeCollection Methods [image] ReadOnlyTcAdsDataTypeCollection.Contains Method
ReadOnlyTcAdsDataTypeCollection.Contains Method
Overload List
Name | Description
Contains(String) | Determines whether this ReadOnlyTcAdsDataTypeCollection contains the specified type name.
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsDataType..)
Reference
ReadOnlyTcAdsDataTypeCollection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
ReadOnlyTcAdsDataTypeCollection.Contains Method (String)


ReadOnlyTcAdsDataTypeCollection.Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ReadOnlyTcAdsDataTypeCollection Class [image] ReadOnlyTcAdsDataTypeCollection Methods [image] ReadOnlyTcAdsDataTypeCollection.Contains Method [image] ReadOnlyTcAdsDataTypeCollection.Contains Method (String)
ReadOnlyTcAdsDataTypeCollection.Contains Method (String)
Determines whether this ReadOnlyTcAdsDataTypeCollection contains the specified type name.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string typeName
)
VB
Public Function Contains (
typeName As String
) As Boolean
Parameters
typeName
Type: System.String
Name of the type.
Return Value
Type: Boolean
true if the specified name is contained; otherwise, false.
Reference
ReadOnlyTcAdsDataTypeCollection Class
Contains Overload
TwinCAT.Ads Namespace


ReadOnlyTcAdsDataTypeCollection.TryGetDataType Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] ReadOnlyTcAdsDataTypeCollection Class [image] ReadOnlyTcAdsDataTypeCollection Methods [image] ReadOnlyTcAdsDataTypeCollection.TryGetDataType Method
ReadOnlyTcAdsDataTypeCollection.TryGetDataType Method
Tries to get the specified type name.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetDataType(
string typeName,
out ITcAdsDataType type
)
VB
Public Function TryGetDataType (
typeName As String,
<OutAttribute> ByRef type As ITcAdsDataType
) As Boolean
Parameters
typeName | Type: System.String Name of the type.
type | Type: TwinCAT.Ads.ITcAdsDataType. The type.
Return Value
Type: Boolean
true if found, false otherwise.
Reference
ReadOnlyTcAdsDataTypeCollection Class
TwinCAT.Ads Namespace


RpcMethodNotSupportedException Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] RpcMethodNotSupportedException Class
RpcMethodNotSupportedException Class
Symbol Exception
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.Ads.AdsSymbolException
TwinCAT.Ads.RpcMethodNotSupportedException
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class RpcMethodNotSupportedException : AdsSymbolException
VB
<SerializableAttribute>
Public Class RpcMethodNotSupportedException
Inherits AdsSymbolException
The RpcMethodNotSupportedException type exposes the following members.
Constructors
Name | Description
RpcMethodNotSupportedException(Int32, ITcAdsSymbol) | Initializes a new instance of the RpcMethodNotSupportedException class.
RpcMethodNotSupportedException(String, ITcAdsSymbol) | Initializes a new instance of the RpcMethodNotSupportedException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Fields
Name | Description
Symbol | The symbol (Inherited from AdsSymbolException.)
SymbolName | The symbol (Inherited from AdsSymbolException.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
RpcMethodNotSupportedException Constructor
•
RpcMethodNotSupportedException Properties
•
RpcMethodNotSupportedException Methods
•
RpcMethodNotSupportedException Events
•
RpcMethodNotSupportedException Fields


RpcMethodNotSupportedException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] RpcMethodNotSupportedException Class [image] RpcMethodNotSupportedException Constructor
RpcMethodNotSupportedException Constructor
Overload List
Name | Description
RpcMethodNotSupportedException(Int32, ITcAdsSymbol) | Initializes a new instance of the RpcMethodNotSupportedException class.
RpcMethodNotSupportedException(String, ITcAdsSymbol) | Initializes a new instance of the RpcMethodNotSupportedException class.
Reference
RpcMethodNotSupportedException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
RpcMethodNotSupportedException Constructor (Int32, ITcAdsSymbol)
•
RpcMethodNotSupportedException Constructor (String, ITcAdsSymbol)


RpcMethodNotSupportedException Constructor (Int32, ITcAdsSymbol)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] RpcMethodNotSupportedException Class [image] RpcMethodNotSupportedException Constructor [image] RpcMethodNotSupportedException Constructor (Int32, ITcAdsSymbol)
RpcMethodNotSupportedException Constructor (Int32, ITcAdsSymbol)
Initializes a new instance of the RpcMethodNotSupportedException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public RpcMethodNotSupportedException(
int vTableIndex,
ITcAdsSymbol symbol
)
VB
Public Sub New (
vTableIndex As Integer,
symbol As ITcAdsSymbol
)
Parameters
vTableIndex | Type: System.Int32 Index of the v table.
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
Reference
RpcMethodNotSupportedException Class
RpcMethodNotSupportedException Overload
TwinCAT.Ads Namespace


RpcMethodNotSupportedException Constructor (String, ITcAdsSymbol)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] RpcMethodNotSupportedException Class [image] RpcMethodNotSupportedException Constructor [image] RpcMethodNotSupportedException Constructor (String, ITcAdsSymbol)
RpcMethodNotSupportedException Constructor (String, ITcAdsSymbol)
Initializes a new instance of the RpcMethodNotSupportedException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public RpcMethodNotSupportedException(
string methodName,
ITcAdsSymbol symbol
)
VB
Public Sub New (
methodName As String,
symbol As ITcAdsSymbol
)
Parameters
methodName | Type: System.String Name of the method.
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
Reference
RpcMethodNotSupportedException Class
RpcMethodNotSupportedException Overload
TwinCAT.Ads Namespace


RpcMethodNotSupportedException Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] RpcMethodNotSupportedException Class [image] RpcMethodNotSupportedException Properties
RpcMethodNotSupportedException Properties
The RpcMethodNotSupportedException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
RpcMethodNotSupportedException Class
TwinCAT.Ads Namespace


RpcMethodNotSupportedException Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] RpcMethodNotSupportedException Class [image] RpcMethodNotSupportedException Methods
RpcMethodNotSupportedException Methods
The RpcMethodNotSupportedException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
RpcMethodNotSupportedException Class
TwinCAT.Ads Namespace


RpcMethodNotSupportedException Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] RpcMethodNotSupportedException Class [image] RpcMethodNotSupportedException Events
RpcMethodNotSupportedException Events
The RpcMethodNotSupportedException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
RpcMethodNotSupportedException Class
TwinCAT.Ads Namespace


RpcMethodNotSupportedException Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] RpcMethodNotSupportedException Class [image] RpcMethodNotSupportedException Fields
RpcMethodNotSupportedException Fields
The RpcMethodNotSupportedException type exposes the following members.
Fields
Name | Description
Symbol | The symbol (Inherited from AdsSymbolException.)
SymbolName | The symbol (Inherited from AdsSymbolException.)
Reference
RpcMethodNotSupportedException Class
TwinCAT.Ads Namespace


SessionSettings Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SessionSettings Class
SessionSettings Class
Session settings class
Inheritance Hierarchy
System.Object
TwinCAT.Ads.SessionSettings
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SessionSettings : IAdsSessionSettings,
ISessionSettings
VB
Public Class SessionSettings
Implements IAdsSessionSettings, ISessionSettings
The SessionSettings type exposes the following members.
Properties
Name | Description
Default | Gets the default Settings (Synchronized).
FastWriteThrough | Gets a Settings object that configures the AdsSession for FastWriteThrough
ResurrectionTime | Gets or sets the resurrection time (Default: DefaultResurrectionTime)
SymbolLoader | Gets or sets the symbol loader settings
Timeout | Gets the ADS timeout in milliseconds.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
DefaultCommunicationTimeout | The default communication timeout (5 Seconds)
DefaultResurrectionTime | The default resurrection time (21 Seconds)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
SessionSettings Properties
•
SessionSettings Methods
•
SessionSettings Fields


SessionSettings Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SessionSettings Class [image] SessionSettings Properties
SessionSettings Properties
The SessionSettings type exposes the following members.
Properties
Name | Description
Default | Gets the default Settings (Synchronized).
FastWriteThrough | Gets a Settings object that configures the AdsSession for FastWriteThrough
ResurrectionTime | Gets or sets the resurrection time (Default: DefaultResurrectionTime)
SymbolLoader | Gets or sets the symbol loader settings
Timeout | Gets the ADS timeout in milliseconds.
Reference
SessionSettings Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
SessionSettings.Default Property
•
SessionSettings.FastWriteThrough Property
•
SessionSettings.ResurrectionTime Property
•
SessionSettings.SymbolLoader Property
•
SessionSettings.Timeout Property


SessionSettings.Default Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SessionSettings Class [image] SessionSettings Properties [image] SessionSettings.Default Property
SessionSettings.Default Property
Gets the default Settings (Synchronized).
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static SessionSettings Default { get; }
VB
Public Shared ReadOnly Property Default As SessionSettings
Get
Property Value
Type: SessionSettings
The default settings.
Remarks
The following defaults are set here:
Setting | Description
Communication Timeout (Timeout) | Default communication timeout (DefaultCommunicationTimeout, default 5s)
Resurrection Timeout (ResurrectionTime) | Default communication timeout (DefaultResurrectionTime, default 21s)
Dynamic SymbolLoader settings SymbolLoader | Synchronized mode activated (DefaultDynamic)
Reference
SessionSettings Class
TwinCAT.Ads Namespace


SessionSettings.FastWriteThrough Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SessionSettings Class [image] SessionSettings Properties [image] SessionSettings.FastWriteThrough Property
SessionSettings.FastWriteThrough Property
Gets a Settings object that configures the AdsSession for FastWriteThrough
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static SessionSettings FastWriteThrough { get; }
VB
Public Shared ReadOnly Property FastWriteThrough As SessionSettings
Get
Property Value
Type: SessionSettings
Session settings for a fast write through (with 200 ms Timeout).
Remarks
The settings typically can be used for polling clients, where the "FailFast" feature will be bypassed. That means, that communication fails doesn't trigger the FailFast interceptor and every Request will go out via ADS. This has the Drawback that communication Timeouts are longer and subsequent timeouts block the ADS mailbox (with the danger of overflows). So use this setting with care for specific purposes and should not be used for standard communication.
▪
No Resurrection time and therefore:
▪
No FailFastHandler active.
▪
Default communication timeout 200ms.
▪
Not synchronized Notifications.
Reference
SessionSettings Class
TwinCAT.Ads Namespace


SessionSettings.ResurrectionTime Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SessionSettings Class [image] SessionSettings Properties [image] SessionSettings.ResurrectionTime Property
SessionSettings.ResurrectionTime Property
Gets or sets the resurrection time (Default: DefaultResurrectionTime)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TimeSpan ResurrectionTime { get; set; }
VB
Public Property ResurrectionTime As TimeSpan
Get
Set
Property Value
Type: TimeSpan
The resurrection time.
Implements
IAdsSessionSettings.ResurrectionTime
Remarks
The resurrection time is the time after a lost connection Lost can be 'resurrected'. This time is set to 21 Seconds by default (a value greater than the standard Ethernet connection timeout of 20s). The reason for this timeout is not to flood the ADS mailbox with requests that cannot be handled by the ethernet infrastructure. As long this Timespan is not expired after a recognized Lost, no further data communication is done, and requests are immediately ('FailFast') answered by communication exceptions. Change this value only for edge cases.
Reference
SessionSettings Class
TwinCAT.Ads Namespace


SessionSettings.SymbolLoader Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SessionSettings Class [image] SessionSettings Properties [image] SessionSettings.SymbolLoader Property
SessionSettings.SymbolLoader Property
Gets or sets the symbol loader settings
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolLoaderSettings SymbolLoader { get; set; }
VB
Public Property SymbolLoader As SymbolLoaderSettings
Get
Set
Property Value
Type: SymbolLoaderSettings
The symbol loader.
Implements
IAdsSessionSettings.SymbolLoader
Reference
SessionSettings Class
TwinCAT.Ads Namespace


SessionSettings.Timeout Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SessionSettings Class [image] SessionSettings Properties [image] SessionSettings.Timeout Property
SessionSettings.Timeout Property
Gets the ADS timeout in milliseconds.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Timeout { get; }
VB
Public ReadOnly Property Timeout As Integer
Get
Property Value
Type: Int32
The timeout.
Implements
IAdsSessionSettings.Timeout
Reference
SessionSettings Class
TwinCAT.Ads Namespace


SessionSettings Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SessionSettings Class [image] SessionSettings Methods
SessionSettings Methods
The SessionSettings type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
SessionSettings Class
TwinCAT.Ads Namespace


SessionSettings Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SessionSettings Class [image] SessionSettings Fields
SessionSettings Fields
The SessionSettings type exposes the following members.
Fields
Name | Description
DefaultCommunicationTimeout | The default communication timeout (5 Seconds)
DefaultResurrectionTime | The default resurrection time (21 Seconds)
Reference
SessionSettings Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
SessionSettings.DefaultCommunicationTimeout Field
•
SessionSettings.DefaultResurrectionTime Field


SessionSettings.DefaultCommunicationTimeout Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SessionSettings Class [image] SessionSettings Fields [image] SessionSettings.DefaultCommunicationTimeout Field
SessionSettings.DefaultCommunicationTimeout Field
The default communication timeout (5 Seconds)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static TimeSpan DefaultCommunicationTimeout
VB
Public Shared DefaultCommunicationTimeout As TimeSpan
Field Value
Type: TimeSpan
Reference
SessionSettings Class
TwinCAT.Ads Namespace


SessionSettings.DefaultResurrectionTime Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SessionSettings Class [image] SessionSettings Fields [image] SessionSettings.DefaultResurrectionTime Field
SessionSettings.DefaultResurrectionTime Field
The default resurrection time (21 Seconds)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static TimeSpan DefaultResurrectionTime
VB
Public Shared DefaultResurrectionTime As TimeSpan
Field Value
Type: TimeSpan
Reference
SessionSettings Class
TwinCAT.Ads Namespace


StateInfo Structure

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure
StateInfo Structure
The structure contains the ADS state and device state.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public struct StateInfo
VB
Public Structure StateInfo
The StateInfo type exposes the following members.
Constructors
Name | Description
StateInfo | Initializes a new Instance of the StateInfo struct.
Properties
Name | Description
AdsState | Gets or sets the ADS state of this StateInfo object.
DeviceState | Gets or sets the device state of this StateInfo object.
Methods
Name | Description
Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueType.Equals(Object).)
Equals(StateInfo) | Determines whether the specified StateInfo is equal to this instance.
GetHashCode | Returns a hash code for this instance. (Overrides ValueType.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Operators
Name | Description
Equality | Implements the ==.
Inequality | Implements the !=.
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
StateInfo Constructor
•
StateInfo Properties
•
StateInfo Methods
•
StateInfo Operators


StateInfo Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Constructor
StateInfo Constructor
Initializes a new Instance of the StateInfo struct.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public StateInfo(
AdsState adsState,
short deviceState
)
VB
Public Sub New (
adsState As AdsState,
deviceState As Short
)
Parameters
adsState | Type: TwinCAT.Ads.AdsState Ads state.
deviceState | Type: System.Int16 Device state.
Reference
StateInfo Structure
TwinCAT.Ads Namespace


StateInfo Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Properties
StateInfo Properties
The StateInfo type exposes the following members.
Properties
Name | Description
AdsState | Gets or sets the ADS state of this StateInfo object.
DeviceState | Gets or sets the device state of this StateInfo object.
Reference
StateInfo Structure
TwinCAT.Ads Namespace
Weiterführende Informationen
•
StateInfo.AdsState Property
•
StateInfo.DeviceState Property


StateInfo.AdsState Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Properties [image] StateInfo.AdsState Property
StateInfo.AdsState Property
Gets or sets the ADS state of this StateInfo object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsState AdsState { get; set; }
VB
Public Property AdsState As AdsState
Get
Set
Property Value
Type: AdsState
Reference
StateInfo Structure
TwinCAT.Ads Namespace


StateInfo.DeviceState Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Properties [image] StateInfo.DeviceState Property
StateInfo.DeviceState Property
Gets or sets the device state of this StateInfo object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public short DeviceState { get; set; }
VB
Public Property DeviceState As Short
Get
Set
Property Value
Type: Int16
Reference
StateInfo Structure
TwinCAT.Ads Namespace


StateInfo Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Methods
StateInfo Methods
The StateInfo type exposes the following members.
Methods
Name | Description
Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueType.Equals(Object).)
Equals(StateInfo) | Determines whether the specified StateInfo is equal to this instance.
GetHashCode | Returns a hash code for this instance. (Overrides ValueType.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Reference
StateInfo Structure
TwinCAT.Ads Namespace
Weiterführende Informationen
•
StateInfo.Equals Method
•
StateInfo.GetHashCode Method


StateInfo.Equals Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Methods [image] StateInfo.Equals Method
StateInfo.Equals Method
Overload List
Name | Description
Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueType.Equals(Object).)
Equals(StateInfo) | Determines whether the specified StateInfo is equal to this instance.
Reference
StateInfo Structure
TwinCAT.Ads Namespace
Weiterführende Informationen
•
StateInfo.Equals Method (Object)
•
StateInfo.Equals Method (StateInfo)


StateInfo.Equals Method (Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Methods [image] StateInfo.Equals Method [image] StateInfo.Equals Method (Object)
StateInfo.Equals Method (Object)
Determines whether the specified Object is equal to this instance.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool Equals(
Object ob
)
VB
Public Overrides Function Equals (
ob As Object
) As Boolean
Parameters
ob
Type: System.Object
The Object to compare with this instance.
Return Value
Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Reference
StateInfo Structure
Equals Overload
TwinCAT.Ads Namespace


StateInfo.Equals Method (StateInfo)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Methods [image] StateInfo.Equals Method [image] StateInfo.Equals Method (StateInfo)
StateInfo.Equals Method (StateInfo)
Determines whether the specified StateInfo is equal to this instance.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Equals(
StateInfo info
)
VB
Public Function Equals (
info As StateInfo
) As Boolean
Parameters
info
Type: TwinCAT.Ads.StateInfo
The StateInfo to compare with this instance.
Return Value
Type: Boolean
true if the specified StateInfo is equal to this instance; otherwise, false.
Reference
StateInfo Structure
Equals Overload
TwinCAT.Ads Namespace


StateInfo.GetHashCode Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Methods [image] StateInfo.GetHashCode Method
StateInfo.GetHashCode Method
Returns a hash code for this instance.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override int GetHashCode()
VB
Public Overrides Function GetHashCode As Integer
Return Value
Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
Reference
StateInfo Structure
TwinCAT.Ads Namespace


StateInfo Operators

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Operators
StateInfo Operators
The StateInfo type exposes the following members.
Operators
Name | Description
Equality | Implements the ==.
Inequality | Implements the !=.
Reference
StateInfo Structure
TwinCAT.Ads Namespace
Weiterführende Informationen
•
StateInfo.Equality Operator
•
StateInfo.Inequality Operator


StateInfo.Equality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Operators [image] StateInfo.Equality Operator
StateInfo.Equality Operator
Implements the ==.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator ==(
StateInfo a,
StateInfo b
)
VB
Public Shared Operator = (
a As StateInfo,
b As StateInfo
) As Boolean
Parameters
a | Type: TwinCAT.Ads.StateInfo a.
b | Type: TwinCAT.Ads.StateInfo The b.
Return Value
Type: Boolean
The result of the operator.
Reference
StateInfo Structure
TwinCAT.Ads Namespace


StateInfo.Inequality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] StateInfo Structure [image] StateInfo Operators [image] StateInfo.Inequality Operator
StateInfo.Inequality Operator
Implements the !=.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator !=(
StateInfo a,
StateInfo b
)
VB
Public Shared Operator <> (
a As StateInfo,
b As StateInfo
) As Boolean
Parameters
a | Type: TwinCAT.Ads.StateInfo a.
b | Type: TwinCAT.Ads.StateInfo The b.
Return Value
Type: Boolean
The result of the operator.
Reference
StateInfo Structure
TwinCAT.Ads Namespace


SymbolException Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class
SymbolException Class
Symbol bound exceptions
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.Ads.SymbolException
TwinCAT.CannotAccessVirtualSymbolException
TwinCAT.InsufficientAccessRights
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class SymbolException : AdsException
VB
<SerializableAttribute>
Public Class SymbolException
Inherits AdsException
The SymbolException type exposes the following members.
Constructors
Name | Description
SymbolException(ISymbol) | Initializes a new instance of the SymbolException class.
SymbolException(String, ISymbol) | Initializes a new instance of the SymbolException class.
SymbolException(ISymbol, Exception) | Initializes a new instance of the SymbolException class.
SymbolException(ISymbol, Int32) | Initializes a new instance of the SymbolException class.
SymbolException(ISymbol, AdsErrorCode) | Initializes a new instance of the SymbolException class.
SymbolException(String, ISymbol, Exception) | Initializes a new instance of the SymbolException class.
SymbolException(ISymbol, AdsErrorCode, Exception) | Initializes a new instance of the SymbolException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Fields
Name | Description
Symbol | Symbol that is bound to the SymbolException
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
SymbolException Constructor
•
SymbolException Properties
•
SymbolException Methods
•
SymbolException Events
•
SymbolException Fields


SymbolException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Constructor
SymbolException Constructor
Overload List
Name | Description
SymbolException(ISymbol) | Initializes a new instance of the SymbolException class.
SymbolException(String, ISymbol) | Initializes a new instance of the SymbolException class.
SymbolException(ISymbol, Exception) | Initializes a new instance of the SymbolException class.
SymbolException(ISymbol, Int32) | Initializes a new instance of the SymbolException class.
SymbolException(ISymbol, AdsErrorCode) | Initializes a new instance of the SymbolException class.
SymbolException(String, ISymbol, Exception) | Initializes a new instance of the SymbolException class.
SymbolException(ISymbol, AdsErrorCode, Exception) | Initializes a new instance of the SymbolException class.
Reference
SymbolException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
SymbolException Constructor (ISymbol)
•
SymbolException Constructor (String, ISymbol)
•
SymbolException Constructor (ISymbol, Exception)
•
SymbolException Constructor (ISymbol, Int32)
•
SymbolException Constructor (ISymbol, AdsErrorCode)
•
SymbolException Constructor (String, ISymbol, Exception)
•
SymbolException Constructor (ISymbol, AdsErrorCode, Exception)


SymbolException Constructor (ISymbol)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Constructor [image] SymbolException Constructor (ISymbol)
SymbolException Constructor (ISymbol)
Initializes a new instance of the SymbolException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolException(
ISymbol symbol
)
VB
Public Sub New (
symbol As ISymbol
)
Parameters
symbol
Type: TwinCAT.TypeSystem.ISymbol
The symbol.
Reference
SymbolException Class
SymbolException Overload
TwinCAT.Ads Namespace


SymbolException Constructor (String, ISymbol)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Constructor [image] SymbolException Constructor (String, ISymbol)
SymbolException Constructor (String, ISymbol)
Initializes a new instance of the SymbolException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolException(
string message,
ISymbol symbol
)
VB
Public Sub New (
message As String,
symbol As ISymbol
)
Parameters
message | Type: System.String The message.
symbol | Type: TwinCAT.TypeSystem.ISymbol The symbol.
Reference
SymbolException Class
SymbolException Overload
TwinCAT.Ads Namespace


SymbolException Constructor (ISymbol, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Constructor [image] SymbolException Constructor (ISymbol, Exception)
SymbolException Constructor (ISymbol, Exception)
Initializes a new instance of the SymbolException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolException(
ISymbol symbol,
Exception innerException
)
VB
Public Sub New (
symbol As ISymbol,
innerException As Exception
)
Parameters
symbol | Type: TwinCAT.TypeSystem.ISymbol The symbol.
innerException | Type: System.Exception The inner exception.
Reference
SymbolException Class
SymbolException Overload
TwinCAT.Ads Namespace


SymbolException Constructor (ISymbol, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Constructor [image] SymbolException Constructor (ISymbol, Int32)
SymbolException Constructor (ISymbol, Int32)
Initializes a new instance of the SymbolException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolException(
ISymbol symbol,
int errorCode
)
VB
Public Sub New (
symbol As ISymbol,
errorCode As Integer
)
Parameters
symbol | Type: TwinCAT.TypeSystem.ISymbol The symbol.
errorCode | Type: System.Int32 The error code.
Reference
SymbolException Class
SymbolException Overload
TwinCAT.Ads Namespace


SymbolException Constructor (ISymbol, AdsErrorCode)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Constructor [image] SymbolException Constructor (ISymbol, AdsErrorCode)
SymbolException Constructor (ISymbol, AdsErrorCode)
Initializes a new instance of the SymbolException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolException(
ISymbol symbol,
AdsErrorCode errorCode
)
VB
Public Sub New (
symbol As ISymbol,
errorCode As AdsErrorCode
)
Parameters
symbol | Type: TwinCAT.TypeSystem.ISymbol The symbol.
errorCode | Type: TwinCAT.Ads.AdsErrorCode The error code.
Reference
SymbolException Class
SymbolException Overload
TwinCAT.Ads Namespace


SymbolException Constructor (String, ISymbol, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Constructor [image] SymbolException Constructor (String, ISymbol, Exception)
SymbolException Constructor (String, ISymbol, Exception)
Initializes a new instance of the SymbolException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolException(
string message,
ISymbol symbol,
Exception innerException
)
VB
Public Sub New (
message As String,
symbol As ISymbol,
innerException As Exception
)
Parameters
message | Type: System.String The message.
symbol | Type: TwinCAT.TypeSystem.ISymbol The symbol.
innerException | Type: System.Exception The inner exception.
Reference
SymbolException Class
SymbolException Overload
TwinCAT.Ads Namespace


SymbolException Constructor (ISymbol, AdsErrorCode, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Constructor [image] SymbolException Constructor (ISymbol, AdsErrorCode, Exception)
SymbolException Constructor (ISymbol, AdsErrorCode, Exception)
Initializes a new instance of the SymbolException class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolException(
ISymbol symbol,
AdsErrorCode errorCode,
Exception innerException
)
VB
Public Sub New (
symbol As ISymbol,
errorCode As AdsErrorCode,
innerException As Exception
)
Parameters
symbol | Type: TwinCAT.TypeSystem.ISymbol The symbol.
errorCode | Type: TwinCAT.Ads.AdsErrorCode The error code.
innerException | Type: System.Exception The inner exception.
Reference
SymbolException Class
SymbolException Overload
TwinCAT.Ads Namespace


SymbolException Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Properties
SymbolException Properties
The SymbolException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
SymbolException Class
TwinCAT.Ads Namespace


SymbolException Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Methods
SymbolException Methods
The SymbolException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
SymbolException Class
TwinCAT.Ads Namespace


SymbolException Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Events
SymbolException Events
The SymbolException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
SymbolException Class
TwinCAT.Ads Namespace


SymbolException Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Fields
SymbolException Fields
The SymbolException type exposes the following members.
Fields
Name | Description
Symbol | Symbol that is bound to the SymbolException
Reference
SymbolException Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
SymbolException.Symbol Field


SymbolException.Symbol Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolException Class [image] SymbolException Fields [image] SymbolException.Symbol Field
SymbolException.Symbol Field
Symbol that is bound to the SymbolException
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[NonSerializedAttribute]
public readonly ISymbol Symbol
VB
<NonSerializedAttribute>
Public ReadOnly Symbol As ISymbol
Field Value
Type: ISymbol
Reference
SymbolException Class
TwinCAT.Ads Namespace


SymbolLoaderSettings Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class
SymbolLoaderSettings Class
Settings object for the IAdsSymbolLoader initialization.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.SymbolLoaderSettings
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SymbolLoaderSettings : ISymbolLoaderSettings
VB
Public Class SymbolLoaderSettings
Implements ISymbolLoaderSettings
The SymbolLoaderSettings type exposes the following members.
Constructors
Name | Description
SymbolLoaderSettings(SymbolsLoadMode) | Initializes a new instance of the SymbolLoaderSettings class with IndexGroupOffsetPreferred.
SymbolLoaderSettings(SymbolsLoadMode, ValueAccessMode) | Initializes a new instance of the SymbolLoaderSettings class.
SymbolLoaderSettings(SymbolsLoadMode, ValueCreationMode, ValueAccessMode) | Initializes a new instance of the SymbolLoaderSettings class.
Properties
Name | Description
AutomaticReconnection | Gets or sets a value indicating whether Disconnect connections can be reconnected.
Default | Gets the default settings object (SymbolsLoadMode.VirtualTree + ValueAccessMode.IndexGroupOffsetPreferred)
DefaultDynamic | Gets the default settings object (SymbolsLoadMode.DynamicTree + ValueCreationMode.TranslateToPrimitives + ValueAccessMode.IndexGroupOffsetPreferred)
NonCachedArrayElements | Gets or sets the setting to create ArrayElements "On-The-Fly" (Default True)
SymbolsLoadMode | Gets or sets the symbols load mode.
ValueAccessMode | Gets or sets the value access mode.
ValueCreation | Gets or sets the value creation mode.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Remarks
This settings object is used for the initialization of the Symbol loader object.
Reference
TwinCAT.Ads Namespace
TwinCAT.ISymbolLoaderSettings
TwinCAT.Ads.TypeSystem.SymbolLoaderFactory
TwinCAT.Ads.TypeSystem.IAdsSymbolLoader
TwinCAT.SymbolsLoadMode
TwinCAT.Ads.ValueAccess.ValueAccessMode
Weiterführende Informationen
•
SymbolLoaderSettings Constructor
•
SymbolLoaderSettings Properties
•
SymbolLoaderSettings Methods


SymbolLoaderSettings Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Constructor
SymbolLoaderSettings Constructor
Overload List
Name | Description
SymbolLoaderSettings(SymbolsLoadMode) | Initializes a new instance of the SymbolLoaderSettings class with IndexGroupOffsetPreferred.
SymbolLoaderSettings(SymbolsLoadMode, ValueAccessMode) | Initializes a new instance of the SymbolLoaderSettings class.
SymbolLoaderSettings(SymbolsLoadMode, ValueCreationMode, ValueAccessMode) | Initializes a new instance of the SymbolLoaderSettings class.
Reference
SymbolLoaderSettings Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
SymbolLoaderSettings Constructor (SymbolsLoadMode)
•
SymbolLoaderSettings Constructor (SymbolsLoadMode, ValueAccessMode)
•
SymbolLoaderSettings Constructor (SymbolsLoadMode, ValueCreationMode, ValueAccessMode)


SymbolLoaderSettings Constructor (SymbolsLoadMode)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Constructor [image] SymbolLoaderSettings Constructor (SymbolsLoadMode)
SymbolLoaderSettings Constructor (SymbolsLoadMode)
Initializes a new instance of the SymbolLoaderSettings class with IndexGroupOffsetPreferred.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolLoaderSettings(
SymbolsLoadMode loadMode
)
VB
Public Sub New (
loadMode As SymbolsLoadMode
)
Parameters
loadMode
Type: TwinCAT.SymbolsLoadMode
The load mode.
Reference
SymbolLoaderSettings Class
SymbolLoaderSettings Overload
TwinCAT.Ads Namespace


SymbolLoaderSettings Constructor (SymbolsLoadMode, ValueAccessMode)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Constructor [image] SymbolLoaderSettings Constructor (SymbolsLoadMode, ValueAccessMode)
SymbolLoaderSettings Constructor (SymbolsLoadMode, ValueAccessMode)
Initializes a new instance of the SymbolLoaderSettings class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolLoaderSettings(
SymbolsLoadMode loadMode,
ValueAccessMode valueAccess
)
VB
Public Sub New (
loadMode As SymbolsLoadMode,
valueAccess As ValueAccessMode
)
Parameters
loadMode | Type: TwinCAT.SymbolsLoadMode The load mode.
valueAccess | Type: TwinCAT.Ads.ValueAccess.ValueAccessMode The value access.
Reference
SymbolLoaderSettings Class
SymbolLoaderSettings Overload
TwinCAT.Ads Namespace


SymbolLoaderSettings Constructor (SymbolsLoadMode, ValueCreationMode, ValueAccessMode)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Constructor [image] SymbolLoaderSettings Constructor (SymbolsLoadMode, ValueCreationMode, ValueAccessMode)
SymbolLoaderSettings Constructor (SymbolsLoadMode, ValueCreationMode, ValueAccessMode)
Initializes a new instance of the SymbolLoaderSettings class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolLoaderSettings(
SymbolsLoadMode loadMode,
ValueCreationMode valueCreation,
ValueAccessMode valueAccess
)
VB
Public Sub New (
loadMode As SymbolsLoadMode,
valueCreation As ValueCreationMode,
valueAccess As ValueAccessMode
)
Parameters
loadMode | Type: TwinCAT.SymbolsLoadMode The load mode.
valueCreation | Type: TwinCAT.ValueAccess.ValueCreationMode The dynamic value creation.
valueAccess | Type: TwinCAT.Ads.ValueAccess.ValueAccessMode The value access.
Reference
SymbolLoaderSettings Class
SymbolLoaderSettings Overload
TwinCAT.Ads Namespace


SymbolLoaderSettings Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Properties
SymbolLoaderSettings Properties
The SymbolLoaderSettings type exposes the following members.
Properties
Name | Description
AutomaticReconnection | Gets or sets a value indicating whether Disconnect connections can be reconnected.
Default | Gets the default settings object (SymbolsLoadMode.VirtualTree + ValueAccessMode.IndexGroupOffsetPreferred)
DefaultDynamic | Gets the default settings object (SymbolsLoadMode.DynamicTree + ValueCreationMode.TranslateToPrimitives + ValueAccessMode.IndexGroupOffsetPreferred)
NonCachedArrayElements | Gets or sets the setting to create ArrayElements "On-The-Fly" (Default True)
SymbolsLoadMode | Gets or sets the symbols load mode.
ValueAccessMode | Gets or sets the value access mode.
ValueCreation | Gets or sets the value creation mode.
Reference
SymbolLoaderSettings Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
SymbolLoaderSettings.AutomaticReconnection Property
•
SymbolLoaderSettings.Default Property
•
SymbolLoaderSettings.DefaultDynamic Property
•
SymbolLoaderSettings.NonCachedArrayElements Property
•
SymbolLoaderSettings.SymbolsLoadMode Property
•
SymbolLoaderSettings.ValueAccessMode Property
•
SymbolLoaderSettings.ValueCreation Property


SymbolLoaderSettings.AutomaticReconnection Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Properties [image] SymbolLoaderSettings.AutomaticReconnection Property
SymbolLoaderSettings.AutomaticReconnection Property
Gets or sets a value indicating whether Disconnect connections can be reconnected.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool AutomaticReconnection { get; set; }
VB
Public Property AutomaticReconnection As Boolean
Get
Set
Property Value
Type: Boolean
true if Disconnect connections can be reconnecte; otherwise, false.
Reference
SymbolLoaderSettings Class
TwinCAT.Ads Namespace


SymbolLoaderSettings.Default Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Properties [image] SymbolLoaderSettings.Default Property
SymbolLoaderSettings.Default Property
Gets the default settings object (SymbolsLoadMode.VirtualTree + ValueAccessMode.IndexGroupOffsetPreferred)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static SymbolLoaderSettings Default { get; }
VB
Public Shared ReadOnly Property Default As SymbolLoaderSettings
Get
Property Value
Type: SymbolLoaderSettings
The default settings object.
Remarks
The following defaults are set here:
Setting | Description
Symbols load mode (SymbolsLoadMode) | Create virtual tree (VirtualTree.
Value access mode (ValueAccessMode) | Prefer IndexGroup/IndexOffset communication if available (IndexGroupOffsetPreferred).
Value creation mode ValueCreation | Create primitives if possible (Default.
Reference
SymbolLoaderSettings Class
TwinCAT.Ads Namespace


SymbolLoaderSettings.DefaultDynamic Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Properties [image] SymbolLoaderSettings.DefaultDynamic Property
SymbolLoaderSettings.DefaultDynamic Property
Gets the default settings object (SymbolsLoadMode.DynamicTree + ValueCreationMode.TranslateToPrimitives + ValueAccessMode.IndexGroupOffsetPreferred)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static SymbolLoaderSettings DefaultDynamic { get; }
VB
Public Shared ReadOnly Property DefaultDynamic As SymbolLoaderSettings
Get
Property Value
Type: SymbolLoaderSettings
The dynamic default settings object.
Remarks
The following defaults are set here:
Setting | Description
Symbols load mode (SymbolsLoadMode) | Create dynamic tree (DynamicTree.
Value access mode (ValueAccessMode) | Prefer IndexGroup/IndexOffset communication if available (IndexGroupOffsetPreferred).
Value creation mode ValueCreation | Create primitives if possible (Default.
Reference
SymbolLoaderSettings Class
TwinCAT.Ads Namespace


SymbolLoaderSettings.NonCachedArrayElements Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Properties [image] SymbolLoaderSettings.NonCachedArrayElements Property
SymbolLoaderSettings.NonCachedArrayElements Property
Gets or sets the setting to create ArrayElements "On-The-Fly" (Default True)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool NonCachedArrayElements { get; set; }
VB
Public Property NonCachedArrayElements As Boolean
Get
Set
Property Value
Type: Boolean
The value access mode.
Reference
SymbolLoaderSettings Class
TwinCAT.Ads Namespace


SymbolLoaderSettings.SymbolsLoadMode Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Properties [image] SymbolLoaderSettings.SymbolsLoadMode Property
SymbolLoaderSettings.SymbolsLoadMode Property
Gets or sets the symbols load mode.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolsLoadMode SymbolsLoadMode { get; set; }
VB
Public Property SymbolsLoadMode As SymbolsLoadMode
Get
Set
Property Value
Type: SymbolsLoadMode
The symbols load mode.
Reference
SymbolLoaderSettings Class
TwinCAT.Ads Namespace


SymbolLoaderSettings.ValueAccessMode Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Properties [image] SymbolLoaderSettings.ValueAccessMode Property
SymbolLoaderSettings.ValueAccessMode Property
Gets or sets the value access mode.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ValueAccessMode ValueAccessMode { get; set; }
VB
Public Property ValueAccessMode As ValueAccessMode
Get
Set
Property Value
Type: ValueAccessMode
The value access mode.
Reference
SymbolLoaderSettings Class
TwinCAT.Ads Namespace


SymbolLoaderSettings.ValueCreation Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Properties [image] SymbolLoaderSettings.ValueCreation Property
SymbolLoaderSettings.ValueCreation Property
Gets or sets the value creation mode.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ValueCreationMode ValueCreation { get; set; }
VB
Public Property ValueCreation As ValueCreationMode
Get
Set
Property Value
Type: ValueCreationMode
The dynamic value mode.
Reference
SymbolLoaderSettings Class
TwinCAT.Ads Namespace


SymbolLoaderSettings Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] SymbolLoaderSettings Class [image] SymbolLoaderSettings Methods
SymbolLoaderSettings Methods
The SymbolLoaderSettings type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
SymbolLoaderSettings Class
TwinCAT.Ads Namespace


TcAdsClient Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class
TcAdsClient Class
ADS Client / ADS Communication object.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TcAdsClient
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class TcAdsClient : ITcAdsRpcInvoke,
IDisposable, IAdsConnection, IConnection, IConnectionStateProvider, IAdsNotifications,
IAdsAnyAccess, IAdsHandleAccess
VB
Public Class TcAdsClient
Implements ITcAdsRpcInvoke, IDisposable, IAdsConnection, IConnection,
IConnectionStateProvider, IAdsNotifications, IAdsAnyAccess, IAdsHandleAccess
The TcAdsClient type exposes the following members.
Constructors
Name | Description
TcAdsClient. | Initializes a new instance of the class TcAdsClient.
TcAdsClient(AdsClientSettings) | Initializes a new instance of the TcAdsClient class.
Properties
Name | Description
Address | Gets the AmsAddress of the ADS server (Target side)
ClientAddress | Get the AmsAddress of the ADS client (Source side)
Disposed | Determines, whether the TcAdsClient is disposed
Id | Gets the TcAdsClient Identifier.
IsConnected | Gets a value indicating whether the local ADS port was opened successfully. It does not indicate if the target port is available. Use the method ReadState to determine if the target port is available.
IsLocal | Gets a value indicating whether the ADS client is connected to a ADS Server on the local computer.
Protocol | Gets actual ADS Transport protocol
RouterState | Gets the current state of the local AMS Router.
Session | Gets the session that initiated this IConnection
Synchronize | Gets or sets a value indicating whether the TcAdsClient object synchronizes the incoming notifications (obsolete)
Timeout | Sets the timeout for the ads communication. Unit is in ms.
Methods
Name | Description
AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, TimeSpan, TimeSpan, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Close | Closes this IConnection
Connect(Int32) | Establishes a connection to a ADS device using the local netID.
Connect(AmsAddress) | Establishes a connection to a ADS device.
Connect(.Byte., Int32) | Establishes a connection to a ADS device.
Connect(String, Int32) | Establishes a connection to a ADS device.
Connect(AmsNetId, Int32) | Establishes a connection to a ADS device.
Connect(AmsNetId, AmsPort) | Establishes a connection to a ADS device.
CreateSymbolInfoLoader | Obsolete. Creates a new instance of the TcAdsSymbolInfoLoader class (Symbol Browser V1, obsolete).
CreateVariableHandle | Generates a unique handle for an ADS variable.
DeleteDeviceNotification | Deletes an existing notification.
DeleteVariableHandle | Releases the handle of a ADS variable again.
Disconnect | Disconnects the TcAdsClient
Dispose. | Releases the resources used by TcAdsClient.
Dispose(Boolean) | Disposes the TcAdsClient.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Finalizes an instance of the TcAdsClient class. (Overrides Object.Finalize..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeRpcMethod(String, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(String, String, .Object.) | Invokes the RPC method.
InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, String, .Object.) | Invokes the RPC method.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBeforeDisconnect | Called when before the TcAdsClient is disconnected.
OnConnectionStateChanged | Called when the ConnectionState of the TcAdsClient has changed.
Read(Int32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(Int32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, .Byte., Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
ReadAny(Int32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(Int32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
ReadAnyString(Int32, Int32, Encoding) | Reads the string.
ReadAnyString(UInt32, UInt32, Int32, Encoding) | Reads the string
ReadDeviceInfo | Reads the identification and version number of an ADS server.
ReadState | Reads the ADS status and the device status from an ADS server.
ReadSymbol(ITcAdsSymbol) | Reads the value of a symbol and returns it as an object. Strings and all primitive datatypes(UInt32, Int32, Bool etc.) are supported. Arrays and structures cannot be read.
ReadSymbol(String, Type, Boolean) | Reads the value of a symbol and returns the value as object. The parameter type must have the same layout as the ADS symbol.
ReadSymbolInfo | Call this method to obtain information about the individual symbols (variables) in ADS devices.
ReadWrite(UInt32, UInt32, AdsStream, AdsStream) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryAddDeviceNotification | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryAddDeviceNotificationEx | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryDeleteDeviceNotification | Deletes an existing notification.
TryInvokeRpcMethod(String, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(String, String, .Object., Object.) | Tries to invoke the RPC method.
TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.) | Tries to invoke a RPC method.
TryRead(UInt32, UInt32, AdsStream, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(Int32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, .Byte., Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryReadState | Reads the ADS status and the device status from an ADS server. Unlike the ReadState method this method does not call an exception on failure. Instead an AdsErrorCode is returned. If the return value is equal to AdsErrorCode.NoError the call was successfull.
TryReadWrite(Int32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryWrite(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
TryWriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
Write(Int32, Int32) | Trigger Client Method/Command.
Write(Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32) | Trigger Client Method/Command.
Write(Int32, Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream) | Writes data synchronously to an ADS device.
Write(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(Int32, Int32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
Write(Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
WriteAny(Int32, Object) | Writes an object synchronously to an ADS device.
WriteAny(Int32, Object, .Int32.) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object, .Int32.) | Writes an object synchronously to an ADS device.
WriteAnyString(Int32, String, Int32, Encoding) | Writes the string (Potentially unsafe!)
WriteAnyString(UInt32, UInt32, String, Int32, Encoding) | Writes the string (Potentially unsafe!)
WriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
WriteSymbol(ITcAdsSymbol, Object) | Writes a value to the symbol. Strings and all primitive data types(UInt32, Int32, Bool etc.) are supported. Array and structures are not supported. If a string is passed as parameter, the method attempts to parse the string according to the ADS data type of the symbol.
WriteSymbol(String, Object, Boolean) | Writes the passed object value to the specified ADS symbol.The parameter type must have the same layout as the ADS symbol.
Events
Name | Description
AdsNotification | Occurs when the ADS device sends a ADS Notification to the client.
AdsNotificationError | Occurs when a exception has occurred during notification management.
AdsNotificationEx | Occurs when the ADS devices sends an (extended) notification to the client.
AdsStateChanged | Occurs when the ADS state changes.
AdsSymbolVersionChanged | Occurs when the symbol version has been changed changes.
AmsRouterNotification | Occurs when the state of the local Router has changed.
ConnectionStateChanged | Occurs when the connection state has been changed.
Extension Methods
Name | Description
PollAdsState(IObservable.Unit.) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollAdsState(TimeSpan) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollValues(String, Type, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
WhenAdsStateChanges | Gets an observable sequence of AdsStates. (Defined by AdsClientExtensions.)
WhenNotification(ISymbol) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenNotification(ISymbol, NotificationSettings) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection, NotificationSettings) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenValueChanged | Observable sequence of Values driven by ADS Notifications on the specified symbol. (Defined by ValueSymbolExtensions.)
WriteValues.T.(String, IObservable.T.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
WriteValues.T.(String, IObservable.T., Action.Exception.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
Remarks
IMPORTANT: The Default setting of the Synchronize property has changed to 'false' from Version 4.2.XX on. This has the effect that - by default - the notifications events and are not synchronized into the UI thread anymore. To re enable the obsolete behavior set to 'true'. AdsNotification AdsNotificationEx Synchronize Use an instance of this object to create a point-to-point send/receive connection to an ADS Server/Device object. The class TcAdsClient is a wrapper for the TcAdsdll.dll and enables synchronous/asynchronous access to data of an ADS Device.
Examples
The following sample shows how to instantiate and use the TcAdsClient class.
TcAdsClient Demo
using System;
using System.Threading;

using TwinCAT.Ads;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

namespace Sample
{
class AdsClient
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Asynchronized access necessary for Console applications
client.Synchronize = false;

// Connect to Address
client.Connect(address.NetId,address.Port); // Connect to Port (851, first PLC by default)

// Read the identification and version number of the device
DeviceInfo deviceInfo = client.ReadDeviceInfo();
Version version = deviceInfo.Version.ConvertToStandard();
Console.WriteLine(string.Format("DeviceName: {0}", deviceInfo.Name));
Console.WriteLine(string.Format("DeviceVersion: {0}", version.ToString(3)));

// Read the state of the device
StateInfo stateInfo = client.ReadState();
AdsState state = stateInfo.AdsState;
short deviceState = stateInfo.DeviceState;
Console.WriteLine(string.Format("DeviceState: {0}", deviceState));
Console.WriteLine(string.Format("AdsState : {0}", state));

// Write ADS Commands (write state) to target
// Set PLC to Run

if (state == AdsState.Stop)
{
StateInfo setState = new StateInfo(AdsState.Run, 0);
client.WriteControl(setState);
}

//create variable handle for Plc Project Name (automatic generated symbol in PLC)
int handleProjectName = client.CreateVariableHandle("TwinCAT_SystemInfoVarList._AppInfo.ProjectName");
int handleNotification = 0; // Notification Handle for Task1 CycleCount changes

try
{
// Read value from target and Marshal data into string
using (AdsBinaryReader reader = new AdsBinaryReader(new AdsStream(256)))
{
int read = client.Read(handleProjectName, (AdsStream)reader.BaseStream);
string projectName = reader.ReadPlcAnsiString(256);
Console.WriteLine(string.Format("ProjectName : {0}", projectName));
}

_notificationStream = new AdsStream(4); // Sizeof UDINT
_notificationReader = new AdsBinaryReader(_notificationStream);

client.AdsNotification += client_NotificationEvent; // Register for Notification event

//Register Notification for Task1 CycleCount symbol (automatic generated symbol in PLC)
handleNotification = client.AddDeviceNotification("TwinCAT_SystemInfoVarList._TaskInfo[1].CycleCount", _notificationStream, AdsTransMode.OnChange, 500, 0, null);

// Sleep 10 Seconds to receive events
System.Threading.Thread.Sleep(10000);
}
finally
{
// Cleanup all handles
// Dispose all Streams

client.DeleteDeviceNotification(handleNotification);
_notificationReader.Close();
_notificationStream.Close();

// Always delete all variable handles.
client.DeleteVariableHandle(handleProjectName);
}
Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
}
Argument Parser
public static class ArgParser
{
/// <summary>
/// Parses the arguments.
/// </summary>
/// <param name="args">The arguments.</param>
/// <returns>AmsAddress.</returns>
public static AmsAddress Parse(string[] args)
{
AmsNetId netId = AmsNetId.Local;
int port = 851;

if (args != null)
{
if (args.Length > 0 && args[0] != null)
netId = AmsNetId.Parse(args[0]);

if (args.Length > 1 && args[1] != null)
port = int.Parse(args[1]);
}
return new AmsAddress(netId, port);
}
}
The following sample shows how to call (Remote Procedures / Methods) within the PLC directly from the TcAdsClient class.
RPC Call Example
namespace Sample
{
using System;
using System.Diagnostics;
using TwinCAT.Ads;
using TwinCAT.TypeSystem;

class RpcCallV1Program
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
//Parse the AmsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

// Create the ADS Client
using (TcAdsClient client = new TcAdsClient())
{
// Establish Connection
client.Connect(address);

// Call a Method that has the following signature (within MAIN Program)

/* {attribute 'TcRpcEnable'}
METHOD PUBLIC M_Add : INT
VAR_INPUT
i1 : INT := 0;
i2 : INT := 0;
END_VAR
*/

short result = (short)client.InvokeRpcMethod("MAIN", "M_Add", new object[] {(short)1, (short)4});

// Call a Method that has no parameter and returns VOID
client.InvokeRpcMethod("MAIN", "M_Method1", new object[] {});
}
}
}
}
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient Constructor
•
TcAdsClient Properties
•
TcAdsClient Methods
•
TcAdsClient Events


TcAdsClient Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Constructor
TcAdsClient Constructor
Overload List
Name | Description
TcAdsClient. | Initializes a new instance of the class TcAdsClient.
TcAdsClient(AdsClientSettings) | Initializes a new instance of the TcAdsClient class.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient Constructor
•
TcAdsClient Constructor (AdsClientSettings)


TcAdsClient Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Constructor [image] TcAdsClient Constructor
TcAdsClient Constructor
Initializes a new instance of the class TcAdsClient.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TcAdsClient()
VB
Public Sub New
Remarks
Default Interceptors (FailFastHandler) will be used.
Reference
TcAdsClient Class
TcAdsClient Overload
TwinCAT.Ads Namespace


TcAdsClient Constructor (AdsClientSettings)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Constructor [image] TcAdsClient Constructor (AdsClientSettings)
TcAdsClient Constructor (AdsClientSettings)
Initializes a new instance of the TcAdsClient class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TcAdsClient(
AdsClientSettings settings
)
VB
Public Sub New (
settings As AdsClientSettings
)
Parameters
settings
Type: TwinCAT.Ads.AdsClientSettings
The settings.
Reference
TcAdsClient Class
TcAdsClient Overload
TwinCAT.Ads Namespace


TcAdsClient Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties
TcAdsClient Properties
The TcAdsClient type exposes the following members.
Properties
Name | Description
Address | Gets the AmsAddress of the ADS server (Target side)
ClientAddress | Get the AmsAddress of the ADS client (Source side)
Disposed | Determines, whether the TcAdsClient is disposed
Id | Gets the TcAdsClient Identifier.
IsConnected | Gets a value indicating whether the local ADS port was opened successfully. It does not indicate if the target port is available. Use the method ReadState to determine if the target port is available.
IsLocal | Gets a value indicating whether the ADS client is connected to a ADS Server on the local computer.
Protocol | Gets actual ADS Transport protocol
RouterState | Gets the current state of the local AMS Router.
Session | Gets the session that initiated this IConnection
Synchronize | Gets or sets a value indicating whether the TcAdsClient object synchronizes the incoming notifications (obsolete)
Timeout | Sets the timeout for the ads communication. Unit is in ms.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.Address Property
•
TcAdsClient.ClientAddress Property
•
TcAdsClient.Disposed Property
•
TcAdsClient.Id Property
•
TcAdsClient.IsConnected Property
•
TcAdsClient.IsLocal Property
•
TcAdsClient.Protocol Property
•
TcAdsClient.RouterState Property
•
TcAdsClient.Session Property
•
TcAdsClient.Synchronize Property
•
TcAdsClient.Timeout Property


TcAdsClient.Address Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties [image] TcAdsClient.Address Property
TcAdsClient.Address Property
Gets the AmsAddress of the ADS server (Target side)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress Address { get; }
VB
Public ReadOnly Property Address As AmsAddress
Get
Property Value
Type: AmsAddress
Implements
IAdsConnection.Address
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.ClientAddress Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties [image] TcAdsClient.ClientAddress Property
TcAdsClient.ClientAddress Property
Get the AmsAddress of the ADS client (Source side)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress ClientAddress { get; }
VB
Public ReadOnly Property ClientAddress As AmsAddress
Get
Property Value
Type: AmsAddress
The client address if connection is up and running, otherwise NULL.
Implements
IAdsConnection.ClientAddress
Remarks
The ClientAddress is only available if the connection is up and running. For the different (possible) connection methods:
Port | Description
1 | Connection is using the TCP/IP protocol.
>=0x8000 (>=32768) | Ads communication via ADS Router (Default)
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.Disposed Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties [image] TcAdsClient.Disposed Property
TcAdsClient.Disposed Property
Determines, whether the TcAdsClient is disposed
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Disposed { get; }
VB
Public ReadOnly Property Disposed As Boolean
Get
Property Value
Type: Boolean
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.Id Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties [image] TcAdsClient.Id Property
TcAdsClient.Id Property
Gets the TcAdsClient Identifier.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Id { get; }
VB
Public ReadOnly Property Id As Integer
Get
Property Value
Type: Int32
The identifier.
Implements
IConnection.Id
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.IsConnected Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties [image] TcAdsClient.IsConnected Property
TcAdsClient.IsConnected Property
Gets a value indicating whether the local ADS port was opened successfully. It does not indicate if the target port is available. Use the method ReadState to determine if the target port is available.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsConnected { get; }
VB
Public ReadOnly Property IsConnected As Boolean
Get
Property Value
Type: Boolean
Implements
IConnection.IsConnected
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.IsLocal Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties [image] TcAdsClient.IsLocal Property
TcAdsClient.IsLocal Property
Gets a value indicating whether the ADS client is connected to a ADS Server on the local computer.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsLocal { get; }
VB
Public ReadOnly Property IsLocal As Boolean
Get
Property Value
Type: Boolean
Implements
IAdsConnection.IsLocal
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.Protocol Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties [image] TcAdsClient.Protocol Property
TcAdsClient.Protocol Property
Gets actual ADS Transport protocol
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TransportProtocol Protocol { get; }
VB
Public ReadOnly Property Protocol As TransportProtocol
Get
Property Value
Type: TransportProtocol
The protocol.
Remarks
Transport protocol | Description
TcpIp | Connection is using the TCP/IP protocol (Client port 1)
Router | Ads communication via local ADS Router (Default, Client Port >=0x8000 (32768))
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.RouterState Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties [image] TcAdsClient.RouterState Property
TcAdsClient.RouterState Property
Gets the current state of the local AMS Router.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsRouterState RouterState { get; }
VB
Public ReadOnly Property RouterState As AmsRouterState
Get
Property Value
Type: AmsRouterState
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.Session Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties [image] TcAdsClient.Session Property
TcAdsClient.Session Property
Gets the session that initiated this IConnection
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ISession Session { get; }
VB
Public ReadOnly Property Session As ISession
Get
Property Value
Type: ISession
The session or NULL
Implements
IConnection.Session
Remarks
The Session can be null on standalone connections.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.Synchronize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties [image] TcAdsClient.Synchronize Property
TcAdsClient.Synchronize Property
Gets or sets a value indicating whether the TcAdsClient object synchronizes the incoming notifications (obsolete)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Synchronize { get; set; }
VB
Public Property Synchronize As Boolean
Get
Set
Property Value
Type: Boolean
Remarks
IMPORTANT: Be aware that this setting could be removed in later version of this API. The default setting changed from 'true' to 'false' in newer versions, because synchronization should be done in the Application and not has helper functionality within this class / API. Please think about of using .NET SynchronizationContexts or Control.Invoke(...) calls for Application side synchronization. If Synchronize is set to true, the notifications are synchronized onto the Main thread. This is helpful for Windows Forms projects because this automatically synchronizes the notifications into the main UI thread and prevents any synchronization issues like deadlocks. In Console Applications it is necessary to set this flag to false if ADS notifications are used, because the Console Host doesn't trigger any message pumps, effectively blocking any Windows Messages and ADS Notifications.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.Timeout Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Properties [image] TcAdsClient.Timeout Property
TcAdsClient.Timeout Property
Sets the timeout for the ads communication. Unit is in ms.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Timeout { get; set; }
VB
Public Property Timeout As Integer
Get
Set
Property Value
Type: Int32
Implements
IConnection.Timeout
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods
TcAdsClient Methods
The TcAdsClient type exposes the following members.
Methods
Name | Description
AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, TimeSpan, TimeSpan, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Close | Closes this IConnection
Connect(Int32) | Establishes a connection to a ADS device using the local netID.
Connect(AmsAddress) | Establishes a connection to a ADS device.
Connect(.Byte., Int32) | Establishes a connection to a ADS device.
Connect(String, Int32) | Establishes a connection to a ADS device.
Connect(AmsNetId, Int32) | Establishes a connection to a ADS device.
Connect(AmsNetId, AmsPort) | Establishes a connection to a ADS device.
CreateSymbolInfoLoader | Obsolete. Creates a new instance of the TcAdsSymbolInfoLoader class (Symbol Browser V1, obsolete).
CreateVariableHandle | Generates a unique handle for an ADS variable.
DeleteDeviceNotification | Deletes an existing notification.
DeleteVariableHandle | Releases the handle of a ADS variable again.
Disconnect | Disconnects the TcAdsClient
Dispose. | Releases the resources used by TcAdsClient.
Dispose(Boolean) | Disposes the TcAdsClient.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Finalizes an instance of the TcAdsClient class. (Overrides Object.Finalize..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeRpcMethod(String, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(String, String, .Object.) | Invokes the RPC method.
InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, String, .Object.) | Invokes the RPC method.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBeforeDisconnect | Called when before the TcAdsClient is disconnected.
OnConnectionStateChanged | Called when the ConnectionState of the TcAdsClient has changed.
Read(Int32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(Int32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, .Byte., Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
ReadAny(Int32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(Int32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
ReadAnyString(Int32, Int32, Encoding) | Reads the string.
ReadAnyString(UInt32, UInt32, Int32, Encoding) | Reads the string
ReadDeviceInfo | Reads the identification and version number of an ADS server.
ReadState | Reads the ADS status and the device status from an ADS server.
ReadSymbol(ITcAdsSymbol) | Reads the value of a symbol and returns it as an object. Strings and all primitive datatypes(UInt32, Int32, Bool etc.) are supported. Arrays and structures cannot be read.
ReadSymbol(String, Type, Boolean) | Reads the value of a symbol and returns the value as object. The parameter type must have the same layout as the ADS symbol.
ReadSymbolInfo | Call this method to obtain information about the individual symbols (variables) in ADS devices.
ReadWrite(UInt32, UInt32, AdsStream, AdsStream) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryAddDeviceNotification | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryAddDeviceNotificationEx | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
TryDeleteDeviceNotification | Deletes an existing notification.
TryInvokeRpcMethod(String, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(String, String, .Object., Object.) | Tries to invoke the RPC method.
TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.) | Tries to invoke a RPC method.
TryRead(UInt32, UInt32, AdsStream, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(Int32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, .Byte., Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryReadState | Reads the ADS status and the device status from an ADS server. Unlike the ReadState method this method does not call an exception on failure. Instead an AdsErrorCode is returned. If the return value is equal to AdsErrorCode.NoError the call was successfull.
TryReadWrite(Int32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryWrite(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
TryWriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
Write(Int32, Int32) | Trigger Client Method/Command.
Write(Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32) | Trigger Client Method/Command.
Write(Int32, Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream) | Writes data synchronously to an ADS device.
Write(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(Int32, Int32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
Write(Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
WriteAny(Int32, Object) | Writes an object synchronously to an ADS device.
WriteAny(Int32, Object, .Int32.) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object, .Int32.) | Writes an object synchronously to an ADS device.
WriteAnyString(Int32, String, Int32, Encoding) | Writes the string (Potentially unsafe!)
WriteAnyString(UInt32, UInt32, String, Int32, Encoding) | Writes the string (Potentially unsafe!)
WriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
WriteSymbol(ITcAdsSymbol, Object) | Writes a value to the symbol. Strings and all primitive data types(UInt32, Int32, Bool etc.) are supported. Array and structures are not supported. If a string is passed as parameter, the method attempts to parse the string according to the ADS data type of the symbol.
WriteSymbol(String, Object, Boolean) | Writes the passed object value to the specified ADS symbol.The parameter type must have the same layout as the ADS symbol.
Extension Methods
Name | Description
PollAdsState(IObservable.Unit.) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollAdsState(TimeSpan) | Overloaded. Gets an observable sequence of AdsStates via Polling. (Defined by AdsClientExtensions.)
PollValues(String, Type, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., IObservable.Unit., Func.Exception, Object.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues(String, Type, .Int32., TimeSpan, Func.Exception, Object.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit.) | Overloaded. Polls the symbol values on time points where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., IObservable.Unit., Func.Exception, T.) | Overloaded. Polls the symbol values on timepoints where the polling observable streams data / triggers (Defined by AnyTypeExtensions.)
PollValues.T.(String, .Int32., TimeSpan, Func.Exception, T.) | Overloaded. Polls the symbol as value sequence of object values with a specified period time. (Defined by AnyTypeExtensions.)
WhenAdsStateChanges | Gets an observable sequence of AdsStates. (Defined by AdsClientExtensions.)
WhenNotification(ISymbol) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenNotification(ISymbol, NotificationSettings) | Overloaded. Gets an observable sequence of Notifications. (Defined by AdsClientExtensions.)
WhenNotification(ISymbolCollection, NotificationSettings) | Overloaded. Gets an observable sequence of Notification objects. (Defined by AdsClientExtensions.)
WhenValueChanged | Observable sequence of Values driven by ADS Notifications on the specified symbol. (Defined by ValueSymbolExtensions.)
WriteValues.T.(String, IObservable.T.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
WriteValues.T.(String, IObservable.T., Action.Exception.) | Overloaded. Writes the sequence of values to the symbol specified by the instance path. (Defined by AnyTypeExtensions.)
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.AddDeviceNotification Method
•
TcAdsClient.AddDeviceNotificationEx Method
•
TcAdsClient.Close Method
•
TcAdsClient.Connect Method
•
TcAdsClient.CreateSymbolInfoLoader Method
•
TcAdsClient.CreateVariableHandle Method
•
TcAdsClient.DeleteDeviceNotification Method
•
TcAdsClient.DeleteVariableHandle Method
•
TcAdsClient.Disconnect Method
•
TcAdsClient.Dispose Method
•
TcAdsClient.Finalize Method
•
TcAdsClient.InvokeRpcMethod Method
•
TcAdsClient.OnBeforeDisconnect Method
•
TcAdsClient.OnConnectionStateChanged Method
•
TcAdsClient.Read Method
•
TcAdsClient.ReadAny Method
•
TcAdsClient.ReadAnyString Method
•
TcAdsClient.ReadDeviceInfo Method
•
TcAdsClient.ReadState Method
•
TcAdsClient.ReadSymbol Method
•
TcAdsClient.ReadSymbolInfo Method
•
TcAdsClient.ReadWrite Method
•
TcAdsClient.TryAddDeviceNotification Method
•
TcAdsClient.TryAddDeviceNotificationEx Method
•
TcAdsClient.TryDeleteDeviceNotification Method
•
TcAdsClient.TryInvokeRpcMethod Method
•
TcAdsClient.TryRead Method
•
TcAdsClient.TryReadState Method
•
TcAdsClient.TryReadWrite Method
•
TcAdsClient.TryWrite Method
•
TcAdsClient.TryWriteControl Method
•
TcAdsClient.Write Method
•
TcAdsClient.WriteAny Method
•
TcAdsClient.WriteAnyString Method
•
TcAdsClient.WriteControl Method
•
TcAdsClient.WriteSymbol Method


TcAdsClient.AddDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotification Method
TcAdsClient.AddDeviceNotification Method
Overload List
Name | Description
AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)
•
TcAdsClient.AddDeviceNotification Method (String, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object)
•
TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)
•
TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object)
•
TcAdsClient.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
•
TcAdsClient.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object)
•
TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
•
TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object)


TcAdsClient.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotification Method [image] TcAdsClient.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)
TcAdsClient.AddDeviceNotification Method (String, AdsStream, AdsTransMode, Int32, Int32, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
string variableName,
AdsStream dataStream,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
variableName As String,
dataStream As AdsStream,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotification(String, AdsStream, AdsTransMode, Int32, Int32, Object)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotification Method (String, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotification Method [image] TcAdsClient.AddDeviceNotification Method (String, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object)
TcAdsClient.AddDeviceNotification Method (String, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
string variableName,
AdsStream dataStream,
AdsTransMode transMode,
TimeSpan cycleTime,
TimeSpan maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
variableName As String,
dataStream As AdsStream,
transMode As AdsTransMode,
cycleTime As TimeSpan,
maxDelay As TimeSpan,
userData As Object
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.TimeSpan The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.TimeSpan The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotification Method [image] TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)
TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the created ADS notification.
Implements
IAdsNotifications.AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to register/unregister for AdsNotifications (asynchronous change messages) via AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) and DeleteDeviceNotification(Int32)
Receive AdsNotifications
AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event handler
client.AdsNotification += Client_AdsNotification;

// Connect to target
client.Connect("1.2.3.4.5.6", 851);
int notificationHandle = 0;

try
{
// Notification to a DINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotification("MAIN.nCounter", readStream, AdsTransMode.OnChange, 200, 0, null);
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotification -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationEventArgs e)
{
int offset = (int)e.DataStream.Position;
int length = (int)e.DataStream.Length;

e.DataStream.Position = offset;
AdsBinaryReader reader = new AdsBinaryReader(e.DataStream);

// Read the Unmarshalled data
//byte[] data = reader.ReadBytes(length);

// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = reader.ReadUInt32();
}
Reference
TcAdsClient Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotification Method [image] TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object)
TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, AdsTransMode, TimeSpan, TimeSpan, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
AdsTransMode transMode,
TimeSpan cycleTime,
TimeSpan maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
transMode As AdsTransMode,
cycleTime As TimeSpan,
maxDelay As TimeSpan,
userData As Object
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.TimeSpan The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.TimeSpan The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to register/unregister for AdsNotifications (asynchronous change messages) via AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object) and DeleteDeviceNotification(Int32)
Receive AdsNotifications
AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event handler
client.AdsNotification += Client_AdsNotification;

// Connect to target
client.Connect("1.2.3.4.5.6", 851);
int notificationHandle = 0;

try
{
// Notification to a DINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotification("MAIN.nCounter", readStream, AdsTransMode.OnChange, 200, 0, null);
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotification -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationEventArgs e)
{
int offset = (int)e.DataStream.Position;
int length = (int)e.DataStream.Length;

e.DataStream.Position = offset;
AdsBinaryReader reader = new AdsBinaryReader(e.DataStream);

// Read the Unmarshalled data
//byte[] data = reader.ReadBytes(length);

// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = reader.ReadUInt32();
}
Reference
TcAdsClient Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotification Method [image] TcAdsClient.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
TcAdsClient.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
string variableName,
AdsStream dataStream,
int offset,
int length,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
variableName As String,
dataStream As AdsStream,
offset As Integer,
length As Integer,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
Exceptions
Exception | Condition
ObjectDisposedException |
AdsErrorException | Thrown when the ADS call fails.
Remarks
AdsTransMode | Parameter semantic
CyclicInContext | Value of parameter is interpreted as task context number ContextMask
OnChangeInContext | Value of parameter is interpreted as task context number ContextMask
Reference
TcAdsClient Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
AddDeviceNotificationEx Overload


TcAdsClient.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotification Method [image] TcAdsClient.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object)
TcAdsClient.AddDeviceNotification Method (String, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
string variableName,
AdsStream dataStream,
int offset,
int length,
AdsTransMode transMode,
TimeSpan cycleTime,
TimeSpan maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
variableName As String,
dataStream As AdsStream,
offset As Integer,
length As Integer,
transMode As AdsTransMode,
cycleTime As TimeSpan,
maxDelay As TimeSpan,
userData As Object
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.TimeSpan The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.TimeSpan The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Remarks
AdsTransMode | Parameter semantic
CyclicInContext | Value of parameter is interpreted as task context number ContextMask
OnChangeInContext | Value of parameter is interpreted as task context number ContextMask
Reference
TcAdsClient Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotification Method [image] TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
offset | Type: System.Int32 Byte Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream (in bytes)
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotification(UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, Int32, Int32, Object)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to register/unregister for AdsNotifications (asynchronous change messages) via AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) and DeleteDeviceNotification(Int32)
Receive AdsNotifications
AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event handler
client.AdsNotification += Client_AdsNotification;

// Connect to target
client.Connect("1.2.3.4.5.6", 851);
int notificationHandle = 0;

try
{
// Notification to a DINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotification("MAIN.nCounter", readStream, AdsTransMode.OnChange, 200, 0, null);
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotification -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationEventArgs e)
{
int offset = (int)e.DataStream.Position;
int length = (int)e.DataStream.Length;

e.DataStream.Position = offset;
AdsBinaryReader reader = new AdsBinaryReader(e.DataStream);

// Read the Unmarshalled data
//byte[] data = reader.ReadBytes(length);

// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = reader.ReadUInt32();
}
Reference
TcAdsClient Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotification Method [image] TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object)
TcAdsClient.AddDeviceNotification Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotification(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length,
AdsTransMode transMode,
TimeSpan cycleTime,
TimeSpan maxDelay,
Object userData
)
VB
Public Function AddDeviceNotification (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer,
transMode As AdsTransMode,
cycleTime As TimeSpan,
maxDelay As TimeSpan,
userData As Object
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.TimeSpan The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.TimeSpan The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to register/unregister for AdsNotifications (asynchronous change messages) via AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) and DeleteDeviceNotification(Int32)
Receive AdsNotifications
AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event handler
client.AdsNotification += Client_AdsNotification;

// Connect to target
client.Connect("1.2.3.4.5.6", 851);
int notificationHandle = 0;

try
{
// Notification to a DINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotification("MAIN.nCounter", readStream, AdsTransMode.OnChange, 200, 0, null);
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotification -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationEventArgs e)
{
int offset = (int)e.DataStream.Position;
int length = (int)e.DataStream.Length;

e.DataStream.Position = offset;
AdsBinaryReader reader = new AdsBinaryReader(e.DataStream);

// Read the Unmarshalled data
//byte[] data = reader.ReadBytes(length);

// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = reader.ReadUInt32();
}
Reference
TcAdsClient Class
AddDeviceNotification Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotificationEx Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotificationEx Method
TcAdsClient.AddDeviceNotificationEx Method
Overload List
Name | Description
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, TimeSpan, TimeSpan, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(String, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.) | Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)
•
TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, TimeSpan, TimeSpan, Object, Type)
•
TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
•
TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.)
•
TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)
•
TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type)
•
TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
•
TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.)


TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotificationEx Method [image] TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)
TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
string variableName,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type
)
VB
Public Function AddDeviceNotificationEx (
variableName As String,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to use AdsNotificationEx events.
Receive AdsNotifications
//AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event 'Ex' handler
client.AdsNotificationEx += Client_AdsNotification;

// Connect to target
client.Connect(AmsNetId.Local, 851);
int notificationHandle = 0;

try
{
// Notification to a ZDINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotificationEx("MAIN.nCounter",AdsTransMode.OnChange, 200, 0, null,typeof(uint));
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotificationEx -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationExEventArgs e)
{
// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = (uint)e.Value;
}
Reference
TcAdsClient Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, TimeSpan, TimeSpan, Object, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotificationEx Method [image] TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, TimeSpan, TimeSpan, Object, Type)
TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, TimeSpan, TimeSpan, Object, Type)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
string variableName,
AdsTransMode transMode,
TimeSpan cycleTime,
TimeSpan maxDelay,
Object userData,
Type type
)
VB
Public Function AddDeviceNotificationEx (
variableName As String,
transMode As AdsTransMode,
cycleTime As TimeSpan,
maxDelay As TimeSpan,
userData As Object,
type As Type
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.TimeSpan The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.TimeSpan The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to use AdsNotificationEx events.
Receive AdsNotifications
//AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event 'Ex' handler
client.AdsNotificationEx += Client_AdsNotification;

// Connect to target
client.Connect(AmsNetId.Local, 851);
int notificationHandle = 0;

try
{
// Notification to a ZDINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotificationEx("MAIN.nCounter",AdsTransMode.OnChange, 200, 0, null,typeof(uint));
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotificationEx -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationExEventArgs e)
{
// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = (uint)e.Value;
}
Reference
TcAdsClient Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotificationEx Method [image] TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
string variableName,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type,
int[] args
)
VB
Public Function AddDeviceNotificationEx (
variableName As String,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type,
args As Integer()
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotificationEx(String, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to use AdsNotificationEx events.
Receive AdsNotifications
//AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event 'Ex' handler
client.AdsNotificationEx += Client_AdsNotification;

// Connect to target
client.Connect(AmsNetId.Local, 851);
int notificationHandle = 0;

try
{
// Notification to a ZDINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotificationEx("MAIN.nCounter",AdsTransMode.OnChange, 200, 0, null,typeof(uint));
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotificationEx -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationExEventArgs e)
{
// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = (uint)e.Value;
}
Reference
TcAdsClient Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotificationEx Method [image] TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.)
TcAdsClient.AddDeviceNotificationEx Method (String, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
string variableName,
AdsTransMode transMode,
TimeSpan cycleTime,
TimeSpan maxDelay,
Object userData,
Type type,
int[] args
)
VB
Public Function AddDeviceNotificationEx (
variableName As String,
transMode As AdsTransMode,
cycleTime As TimeSpan,
maxDelay As TimeSpan,
userData As Object,
type As Type,
args As Integer()
) As Integer
Parameters
variableName | Type: System.String Name of the ADS variable.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.TimeSpan The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.TimeSpan The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to use AdsNotificationEx events.
Receive AdsNotifications
//AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event 'Ex' handler
client.AdsNotificationEx += Client_AdsNotification;

// Connect to target
client.Connect(AmsNetId.Local, 851);
int notificationHandle = 0;

try
{
// Notification to a ZDINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotificationEx("MAIN.nCounter",AdsTransMode.OnChange, 200, 0, null,typeof(uint));
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotificationEx -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationExEventArgs e)
{
// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = (uint)e.Value;
}
Reference
TcAdsClient Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotificationEx Method [image] TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)
TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
uint indexGroup,
uint indexOffset,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type
)
VB
Public Function AddDeviceNotificationEx (
indexGroup As UInteger,
indexOffset As UInteger,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to use AdsNotificationEx events.
Receive AdsNotifications
//AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event 'Ex' handler
client.AdsNotificationEx += Client_AdsNotification;

// Connect to target
client.Connect(AmsNetId.Local, 851);
int notificationHandle = 0;

try
{
// Notification to a ZDINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotificationEx("MAIN.nCounter",AdsTransMode.OnChange, 200, 0, null,typeof(uint));
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotificationEx -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationExEventArgs e)
{
// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = (uint)e.Value;
}
Reference
TcAdsClient Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification


TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotificationEx Method [image] TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type)
TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
uint indexGroup,
uint indexOffset,
AdsTransMode transMode,
TimeSpan cycleTime,
TimeSpan maxDelay,
Object userData,
Type type
)
VB
Public Function AddDeviceNotificationEx (
indexGroup As UInteger,
indexOffset As UInteger,
transMode As AdsTransMode,
cycleTime As TimeSpan,
maxDelay As TimeSpan,
userData As Object,
type As Type
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.TimeSpan The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.TimeSpan The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to use AdsNotificationEx events.
Receive AdsNotifications
//AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event 'Ex' handler
client.AdsNotificationEx += Client_AdsNotification;

// Connect to target
client.Connect(AmsNetId.Local, 851);
int notificationHandle = 0;

try
{
// Notification to a ZDINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotificationEx("MAIN.nCounter",AdsTransMode.OnChange, 200, 0, null,typeof(uint));
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotificationEx -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationExEventArgs e)
{
// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = (uint)e.Value;
}
Reference
TcAdsClient Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification


TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotificationEx Method [image] TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
uint indexGroup,
uint indexOffset,
AdsTransMode transMode,
int cycleTime,
int maxDelay,
Object userData,
Type type,
int[] args
)
VB
Public Function AddDeviceNotificationEx (
indexGroup As UInteger,
indexOffset As UInteger,
transMode As AdsTransMode,
cycleTime As Integer,
maxDelay As Integer,
userData As Object,
type As Type,
args As Integer()
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.Int32 The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.Int32 The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object s0000tored in the event argument.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Int32
The handle of the notification.
Implements
IAdsNotifications.AddDeviceNotificationEx(UInt32, UInt32, AdsTransMode, Int32, Int32, Object, Type, .Int32.)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to use AdsNotificationEx events.
Receive AdsNotifications
//AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event 'Ex' handler
client.AdsNotificationEx += Client_AdsNotification;

// Connect to target
client.Connect(AmsNetId.Local, 851);
int notificationHandle = 0;

try
{
// Notification to a ZDINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotificationEx("MAIN.nCounter",AdsTransMode.OnChange, 200, 0, null,typeof(uint));
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotificationEx -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationExEventArgs e)
{
// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = (uint)e.Value;
}
Reference
TcAdsClient Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.AddDeviceNotificationEx Method [image] TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.)
TcAdsClient.AddDeviceNotificationEx Method (UInt32, UInt32, AdsTransMode, TimeSpan, TimeSpan, Object, Type, .Int32.)
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event. If type is a string type, the first element of the parameter args specifies the number of characters of the string. If type is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AddDeviceNotificationEx(
uint indexGroup,
uint indexOffset,
AdsTransMode transMode,
TimeSpan cycleTime,
TimeSpan maxDelay,
Object userData,
Type type,
int[] args
)
VB
Public Function AddDeviceNotificationEx (
indexGroup As UInteger,
indexOffset As UInteger,
transMode As AdsTransMode,
cycleTime As TimeSpan,
maxDelay As TimeSpan,
userData As Object,
type As Type,
args As Integer()
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
transMode | Type: TwinCAT.Ads.AdsTransMode Specifies if the event should be fired cyclically or only if the variable has changed.
cycleTime | Type: System.TimeSpan The ADS server checks whether the variable has changed after this time interval. Unit is in ms.
maxDelay | Type: System.TimeSpan The AdsNotification event is fired at the latest when this time has elapsed. The unit is ms.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object s0000tored in the event argument.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Int32
The handle of the notification.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
AddDeviceNotificationEx Overload
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx
TcAdsClient.AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object)


TcAdsClient.Close Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Close Method
TcAdsClient.Close Method
Closes this IConnection
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Close()
VB
Public Sub Close
Implements
IConnection.Close.
Remarks
The TcAdsClient is disposed afterwards.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.Connect Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Connect Method
TcAdsClient.Connect Method
Overload List
Name | Description
Connect(Int32) | Establishes a connection to a ADS device using the local netID.
Connect(AmsAddress) | Establishes a connection to a ADS device.
Connect(.Byte., Int32) | Establishes a connection to a ADS device.
Connect(String, Int32) | Establishes a connection to a ADS device.
Connect(AmsNetId, Int32) | Establishes a connection to a ADS device.
Connect(AmsNetId, AmsPort) | Establishes a connection to a ADS device.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.Connect Method (Int32)
•
TcAdsClient.Connect Method (AmsAddress)
•
TcAdsClient.Connect Method (.Byte., Int32)
•
TcAdsClient.Connect Method (String, Int32)
•
TcAdsClient.Connect Method (AmsNetId, Int32)
•
TcAdsClient.Connect Method (AmsNetId, AmsPort)


TcAdsClient.Connect Method (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Connect Method [image] TcAdsClient.Connect Method (Int32)
TcAdsClient.Connect Method (Int32)
Establishes a connection to a ADS device using the local netID.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Connect(
int srvPort
)
VB
Public Sub Connect (
srvPort As Integer
)
Parameters
srvPort
Type: System.Int32
Port number of the ADS server.
Reference
TcAdsClient Class
Connect Overload
TwinCAT.Ads Namespace


TcAdsClient.Connect Method (AmsAddress)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Connect Method [image] TcAdsClient.Connect Method (AmsAddress)
TcAdsClient.Connect Method (AmsAddress)
Establishes a connection to a ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Connect(
AmsAddress address
)
VB
Public Sub Connect (
address As AmsAddress
)
Parameters
address
Type: TwinCAT.Ads.AmsAddress
The address.
Reference
TcAdsClient Class
Connect Overload
TwinCAT.Ads Namespace


TcAdsClient.Connect Method (.Byte., Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Connect Method [image] TcAdsClient.Connect Method (.Byte., Int32)
TcAdsClient.Connect Method (.Byte., Int32)
Establishes a connection to a ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Connect(
byte[] netID,
int srvPort
)
VB
Public Sub Connect (
netID As Byte(),
srvPort As Integer
)
Parameters
netID | Type: .System.Byte. NetId of the ADS server.
srvPort | Type: System.Int32 Port number of the ADS server.
Reference
TcAdsClient Class
Connect Overload
TwinCAT.Ads Namespace


TcAdsClient.Connect Method (String, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Connect Method [image] TcAdsClient.Connect Method (String, Int32)
TcAdsClient.Connect Method (String, Int32)
Establishes a connection to a ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Connect(
string netID,
int srvPort
)
VB
Public Sub Connect (
netID As String,
srvPort As Integer
)
Parameters
netID | Type: System.String NetId of the ADS server.
srvPort | Type: System.Int32 Port number of the ADS server.
Reference
TcAdsClient Class
Connect Overload
TwinCAT.Ads Namespace


TcAdsClient.Connect Method (AmsNetId, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Connect Method [image] TcAdsClient.Connect Method (AmsNetId, Int32)
TcAdsClient.Connect Method (AmsNetId, Int32)
Establishes a connection to a ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Connect(
AmsNetId netID,
int srvPort
)
VB
Public Sub Connect (
netID As AmsNetId,
srvPort As Integer
)
Parameters
netID | Type: TwinCAT.Ads.AmsNetId NetId of the ADS server.
srvPort | Type: System.Int32 Port number of the ADS server.
Reference
TcAdsClient Class
Connect Overload
TwinCAT.Ads Namespace


TcAdsClient.Connect Method (AmsNetId, AmsPort)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Connect Method [image] TcAdsClient.Connect Method (AmsNetId, AmsPort)
TcAdsClient.Connect Method (AmsNetId, AmsPort)
Establishes a connection to a ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Connect(
AmsNetId netID,
AmsPort srvPort
)
VB
Public Sub Connect (
netID As AmsNetId,
srvPort As AmsPort
)
Parameters
netID | Type: TwinCAT.Ads.AmsNetId NetId of the ADS server.
srvPort | Type: TwinCAT.Ads.AmsPort Port number of the ADS server.
Reference
TcAdsClient Class
Connect Overload
TwinCAT.Ads Namespace


TcAdsClient.CreateSymbolInfoLoader Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.CreateSymbolInfoLoader Method
TcAdsClient.CreateSymbolInfoLoader Method
Note: This API is now obsolete.
Creates a new instance of the TcAdsSymbolInfoLoader class (Symbol Browser V1, obsolete).
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[ObsoleteAttribute("For new code use the SymbolLoaderFactory.Create method instead!",
false)]
public TcAdsSymbolInfoLoader CreateSymbolInfoLoader()
VB
<ObsoleteAttribute("For new code use the SymbolLoaderFactory.Create method instead!",
false)>
Public Function CreateSymbolInfoLoader As TcAdsSymbolInfoLoader
Return Value
Type: TcAdsSymbolInfoLoader
Instance of the TcAdsSymbolInfoLoader class.
Remarks
This is the traditional way of accessing symbol information from the target device that is still supported here for backward compatibility. For new implementations please consider to use the new symbol browsing capabilities accessed by the SymbolLoaderFactory class (Create(IConnection, ISymbolLoaderSettings) method).
Examples
Create SymbolLoader V1 object
using System;
using System.Diagnostics;
using TwinCAT.Ads;
using TwinCAT.TypeSystem;

namespace Sample
{
class SymbolBrowserProgramV1
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
ConsoleLogger logger = new ConsoleLogger();
//logger.Active = false;

Console.WriteLine("");
Console.WriteLine("Press [Enter] for Start:");
Console.ReadLine();

Stopwatch stopper = new Stopwatch();

//Parse the AmsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);
stopper.Start();

// Create the ADS Client
using (TcAdsClient client = new TcAdsClient())
{
// Establish Connection
client.Connect(address);

// Create Symbol / DataType Loader
#pragma warning disable 0618
TcAdsSymbolInfoLoader loader = client.CreateSymbolInfoLoader();
#pragma warning restore 0618

// Determine List of used DataTypes.
ReadOnlyTcAdsDataTypeCollection dataTypes = loader.GetDataTypes(false);

// Determine List of contained symbols
TcAdsSymbolInfoCollection symbols = loader.GetSymbols(false);

// Dump Datatypes from Target Device
Console.WriteLine(string.Format("Dumping '{0}' DataTypes:", dataTypes.Count));

// Iterate through types and Dump Content
foreach (ITcAdsDataType dataType in dataTypes)
{
logger.DumpType(dataType);
}

// Dump Symbols from target device
Console.WriteLine("Dumping '{0}' Symbols:", symbols.Count);

// Iterates through symbols and Dump Content
foreach (ITcAdsSymbol5 symbol in symbols)
{
logger.DumpSymbol(symbol,0);
}

stopper.Stop();
TimeSpan elapsed = stopper.Elapsed;
Console.WriteLine("");
Console.WriteLine("Browsing complete tree: {0},({1} DataTypes, {2} Symbols)", elapsed, logger.DataTypesCount, logger.SymbolsCount);

Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
}
}
}
Examples
The following sample shows how to call (Remote Procedures / Methods) within the PLC directly from the TcAdsClient class.
RPC Call Example
namespace Sample
{
using System;
using System.Diagnostics;
using TwinCAT.Ads;
using TwinCAT.TypeSystem;

class RpcCallV1Program
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
//Parse the AmsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

// Create the ADS Client
using (TcAdsClient client = new TcAdsClient())
{
// Establish Connection
client.Connect(address);

// Call a Method that has the following signature (within MAIN Program)

/* {attribute 'TcRpcEnable'}
METHOD PUBLIC M_Add : INT
VAR_INPUT
i1 : INT := 0;
i2 : INT := 0;
END_VAR
*/

short result = (short)client.InvokeRpcMethod("MAIN", "M_Add", new object[] {(short)1, (short)4});

// Call a Method that has no parameter and returns VOID
client.InvokeRpcMethod("MAIN", "M_Method1", new object[] {});
}
}
}
}
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.CreateVariableHandle Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.CreateVariableHandle Method
TcAdsClient.CreateVariableHandle Method
Generates a unique handle for an ADS variable.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int CreateVariableHandle(
string variableName
)
VB
Public Function CreateVariableHandle (
variableName As String
) As Integer
Parameters
variableName
Type: System.String
Name of the ADS variable
Return Value
Type: Int32
The handle of the ADS Variable.
Implements
IAdsHandleAccess.CreateVariableHandle(String)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.DeleteDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.DeleteDeviceNotification Method
TcAdsClient.DeleteDeviceNotification Method
Deletes an existing notification.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void DeleteDeviceNotification(
int notificationHandle
)
VB
Public Sub DeleteDeviceNotification (
notificationHandle As Integer
)
Parameters
notificationHandle
Type: System.Int32
Handle of the notification.
Implements
IAdsNotifications.DeleteDeviceNotification(Int32)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Examples
The following sample shows how to register/unregister for AdsNotifications (asynchronous change messages) via AddDeviceNotification(String, AdsStream, Int32, Int32, AdsTransMode, TimeSpan, TimeSpan, Object) and DeleteDeviceNotification(Int32)
Receive AdsNotifications
AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event handler
client.AdsNotification += Client_AdsNotification;

// Connect to target
client.Connect("1.2.3.4.5.6", 851);
int notificationHandle = 0;

try
{
// Notification to a DINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotification("MAIN.nCounter", readStream, AdsTransMode.OnChange, 200, 0, null);
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotification -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationEventArgs e)
{
int offset = (int)e.DataStream.Position;
int length = (int)e.DataStream.Length;

e.DataStream.Position = offset;
AdsBinaryReader reader = new AdsBinaryReader(e.DataStream);

// Read the Unmarshalled data
//byte[] data = reader.ReadBytes(length);

// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = reader.ReadUInt32();
}
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.DeleteVariableHandle Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.DeleteVariableHandle Method
TcAdsClient.DeleteVariableHandle Method
Releases the handle of a ADS variable again.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void DeleteVariableHandle(
int variableHandle
)
VB
Public Sub DeleteVariableHandle (
variableHandle As Integer
)
Parameters
variableHandle
Type: System.Int32
Handle of the ADS variable
Implements
IAdsHandleAccess.DeleteVariableHandle(Int32)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.Disconnect Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Disconnect Method
TcAdsClient.Disconnect Method
Disconnects the TcAdsClient
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Disconnect()
VB
Public Function Disconnect As Boolean
Return Value
Type: Boolean
true if successfully disconnected, false if the TcAdsClient was already disconnected.
Implements
IConnection.Disconnect.
Remarks
The TcAdsClient can be connected again afterwards. Disconnection doesn't mean disposing / closing:
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.Dispose Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Dispose Method
TcAdsClient.Dispose Method
Overload List
Name | Description
Dispose. | Releases the resources used by TcAdsClient.
Dispose(Boolean) | Disposes the TcAdsClient.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.Dispose Method
•
TcAdsClient.Dispose Method (Boolean)


TcAdsClient.Dispose Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Dispose Method [image] TcAdsClient.Dispose Method
TcAdsClient.Dispose Method
Releases the resources used by TcAdsClient.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Dispose()
VB
Public Sub Dispose
Implements
IDisposable.Dispose.
Reference
TcAdsClient Class
Dispose Overload
TwinCAT.Ads Namespace


TcAdsClient.Dispose Method (Boolean)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Dispose Method [image] TcAdsClient.Dispose Method (Boolean)
TcAdsClient.Dispose Method (Boolean)
Disposes the TcAdsClient.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual void Dispose(
bool disposing
)
VB
Protected Overridable Sub Dispose (
disposing As Boolean
)
Parameters
disposing
Type: System.Boolean
Remarks
When overwritten don't forget to call the base class
Reference
TcAdsClient Class
Dispose Overload
TwinCAT.Ads Namespace


TcAdsClient.Finalize Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Finalize Method
TcAdsClient.Finalize Method
Finalizes an instance of the TcAdsClient class.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected override void Finalize()
VB
Protected Overrides Sub Finalize
Implements
Object.Finalize.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.InvokeRpcMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.InvokeRpcMethod Method
TcAdsClient.InvokeRpcMethod Method
Overload List
Name | Description
InvokeRpcMethod(String, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(String, String, .Object.) | Invokes the RPC method.
InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.) | Invokes the specified RPC Method
InvokeRpcMethod(ITcAdsSymbol, String, .Object.) | Invokes the RPC method.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.InvokeRpcMethod Method (String, Int32, .Object.)
•
TcAdsClient.InvokeRpcMethod Method (String, String, .Object.)
•
TcAdsClient.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)
•
TcAdsClient.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)


TcAdsClient.InvokeRpcMethod Method (String, Int32, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.InvokeRpcMethod Method [image] TcAdsClient.InvokeRpcMethod Method (String, Int32, .Object.)
TcAdsClient.InvokeRpcMethod Method (String, Int32, .Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object InvokeRpcMethod(
string symbolPath,
int methodId,
Object[] parameters
)
VB
Public Function InvokeRpcMethod (
symbolPath As String,
methodId As Integer,
parameters As Object()
) As Object
Parameters
symbolPath | Type: System.String The symbol path.
methodId | Type: System.Int32 The method identifier.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
System.Object.
Implements
ITcAdsRpcInvoke.InvokeRpcMethod(String, Int32, .Object.)
Examples
The following sample shows how to call (Remote Procedures / Methods) within the PLC.
Dynamic Tree Mode
namespace Sample
{
using System;
using System.Diagnostics;
using TwinCAT.Ads;
using TwinCAT.TypeSystem;

class RpcCallV1Program
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
//Parse the AmsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

// Create the ADS Client
using (TcAdsClient client = new TcAdsClient())
{
// Establish Connection
client.Connect(address);

// Call a Method that has the following signature (within MAIN Program)

/* {attribute 'TcRpcEnable'}
METHOD PUBLIC M_Add : INT
VAR_INPUT
i1 : INT := 0;
i2 : INT := 0;
END_VAR
*/

short result = (short)client.InvokeRpcMethod("MAIN", "M_Add", new object[] {(short)1, (short)4});

// Call a Method that has no parameter and returns VOID
client.InvokeRpcMethod("MAIN", "M_Method1", new object[] {});
}
}
}
}
Reference
TcAdsClient Class
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


TcAdsClient.InvokeRpcMethod Method (String, String, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.InvokeRpcMethod Method [image] TcAdsClient.InvokeRpcMethod Method (String, String, .Object.)
TcAdsClient.InvokeRpcMethod Method (String, String, .Object.)
Invokes the RPC method.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object InvokeRpcMethod(
string symbolPath,
string methodName,
Object[] parameters
)
VB
Public Function InvokeRpcMethod (
symbolPath As String,
methodName As String,
parameters As Object()
) As Object
Parameters
symbolPath | Type: System.String The symbol path.
methodName | Type: System.String Name of the method.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
System.Object.
Implements
ITcAdsRpcInvoke.InvokeRpcMethod(String, String, .Object.)
Exceptions
Exception | Condition
NotImplementedException |
Examples
The following sample shows how to call (Remote Procedures / Methods) within the PLC.
Dynamic Tree Mode
namespace Sample
{
using System;
using System.Diagnostics;
using TwinCAT.Ads;
using TwinCAT.TypeSystem;

class RpcCallV1Program
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
//Parse the AmsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

// Create the ADS Client
using (TcAdsClient client = new TcAdsClient())
{
// Establish Connection
client.Connect(address);

// Call a Method that has the following signature (within MAIN Program)

/* {attribute 'TcRpcEnable'}
METHOD PUBLIC M_Add : INT
VAR_INPUT
i1 : INT := 0;
i2 : INT := 0;
END_VAR
*/

short result = (short)client.InvokeRpcMethod("MAIN", "M_Add", new object[] {(short)1, (short)4});

// Call a Method that has no parameter and returns VOID
client.InvokeRpcMethod("MAIN", "M_Method1", new object[] {});
}
}
}
}
Reference
TcAdsClient Class
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


TcAdsClient.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.InvokeRpcMethod Method [image] TcAdsClient.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)
TcAdsClient.InvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object InvokeRpcMethod(
ITcAdsSymbol symbol,
int methodId,
Object[] parameters
)
VB
Public Function InvokeRpcMethod (
symbol As ITcAdsSymbol,
methodId As Integer,
parameters As Object()
) As Object
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodId | Type: System.Int32 The method identifier / Virtual Function table index.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
System.Object.
Implements
ITcAdsRpcInvoke.InvokeRpcMethod(ITcAdsSymbol, Int32, .Object.)
Examples
The following sample shows how to call (Remote Procedures / Methods) within the PLC.
Dynamic Tree Mode
namespace Sample
{
using System;
using System.Diagnostics;
using TwinCAT.Ads;
using TwinCAT.TypeSystem;

class RpcCallV1Program
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
//Parse the AmsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

// Create the ADS Client
using (TcAdsClient client = new TcAdsClient())
{
// Establish Connection
client.Connect(address);

// Call a Method that has the following signature (within MAIN Program)

/* {attribute 'TcRpcEnable'}
METHOD PUBLIC M_Add : INT
VAR_INPUT
i1 : INT := 0;
i2 : INT := 0;
END_VAR
*/

short result = (short)client.InvokeRpcMethod("MAIN", "M_Add", new object[] {(short)1, (short)4});

// Call a Method that has no parameter and returns VOID
client.InvokeRpcMethod("MAIN", "M_Method1", new object[] {});
}
}
}
}
Reference
TcAdsClient Class
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


TcAdsClient.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.InvokeRpcMethod Method [image] TcAdsClient.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)
TcAdsClient.InvokeRpcMethod Method (ITcAdsSymbol, String, .Object.)
Invokes the RPC method.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object InvokeRpcMethod(
ITcAdsSymbol symbol,
string methodName,
Object[] parameters
)
VB
Public Function InvokeRpcMethod (
symbol As ITcAdsSymbol,
methodName As String,
parameters As Object()
) As Object
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodName | Type: System.String Name of the method.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
System.Object.
Implements
ITcAdsRpcInvoke.InvokeRpcMethod(ITcAdsSymbol, String, .Object.)
Exceptions
Exception | Condition
NotImplementedException |
Reference
TcAdsClient Class
InvokeRpcMethod Overload
TwinCAT.Ads Namespace


TcAdsClient.OnBeforeDisconnect Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.OnBeforeDisconnect Method
TcAdsClient.OnBeforeDisconnect Method
Called when before the TcAdsClient is disconnected.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual void OnBeforeDisconnect()
VB
Protected Overridable Sub OnBeforeDisconnect
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.OnConnectionStateChanged Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.OnConnectionStateChanged Method
TcAdsClient.OnConnectionStateChanged Method
Called when the ConnectionState of the TcAdsClient has changed.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual void OnConnectionStateChanged(
ConnectionState newState,
ConnectionState oldState
)
VB
Protected Overridable Sub OnConnectionStateChanged (
newState As ConnectionState,
oldState As ConnectionState
)
Parameters
newState | Type: TwinCAT.ConnectionState The new state.
oldState | Type: TwinCAT.ConnectionState The old state.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.Read Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Read Method
TcAdsClient.Read Method
Overload List
Name | Description
Read(Int32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(Int32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, .Byte., Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Read(UInt32, UInt32, AdsStream, Int32, Int32) | Reads data synchronously from an ADS device and writes it to the given stream.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.Read Method (Int32, AdsStream)
•
TcAdsClient.Read Method (UInt32, UInt32, AdsStream)
•
TcAdsClient.Read Method (Int32, AdsStream, Int32, Int32)
•
TcAdsClient.Read Method (UInt32, UInt32, .Byte., Int32, Int32)
•
TcAdsClient.Read Method (UInt32, UInt32, AdsStream, Int32, Int32)


TcAdsClient.Read Method (Int32, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Read Method [image] TcAdsClient.Read Method (Int32, AdsStream)
TcAdsClient.Read Method (Int32, AdsStream)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
int variableHandle,
AdsStream dataStream
)
VB
Public Function Read (
variableHandle As Integer,
dataStream As AdsStream
) As Integer
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
Return Value
Type: Int32
Number of successfully returned data bytes.
Implements
IAdsHandleAccess.Read(Int32, AdsStream)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Read Overload
TwinCAT.Ads Namespace


TcAdsClient.Read Method (UInt32, UInt32, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Read Method [image] TcAdsClient.Read Method (UInt32, UInt32, AdsStream)
TcAdsClient.Read Method (UInt32, UInt32, AdsStream)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
uint indexGroup,
uint indexOffset,
AdsStream dataStream
)
VB
Public Function Read (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
Return Value
Type: Int32
Number of successfully returned data bytes.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Read Overload
TwinCAT.Ads Namespace


TcAdsClient.Read Method (Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Read Method [image] TcAdsClient.Read Method (Int32, AdsStream, Int32, Int32)
TcAdsClient.Read Method (Int32, AdsStream, Int32, Int32)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
int variableHandle,
AdsStream dataStream,
int offset,
int length
)
VB
Public Function Read (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As Integer
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Implements
IAdsHandleAccess.Read(Int32, AdsStream, Int32, Int32)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Read Overload
TwinCAT.Ads Namespace


TcAdsClient.Read Method (UInt32, UInt32, .Byte., Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Read Method [image] TcAdsClient.Read Method (UInt32, UInt32, .Byte., Int32, Int32)
TcAdsClient.Read Method (UInt32, UInt32, .Byte., Int32, Int32)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
uint indexGroup,
uint indexOffset,
byte[] dataStream,
int offset,
int length
)
VB
Public Function Read (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As Byte(),
offset As Integer,
length As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: .System.Byte. Stream that receives the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Read Overload
TwinCAT.Ads Namespace


TcAdsClient.Read Method (UInt32, UInt32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Read Method [image] TcAdsClient.Read Method (UInt32, UInt32, AdsStream, Int32, Int32)
TcAdsClient.Read Method (UInt32, UInt32, AdsStream, Int32, Int32)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Read(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length
)
VB
Public Function Read (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Read Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadAny Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadAny Method
TcAdsClient.ReadAny Method
Overload List
Name | Description
ReadAny(Int32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(Int32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type) | Reads data synchronously from an ADS device and writes it to an object.
ReadAny(UInt32, UInt32, Type, .Int32.) | Reads data synchronously from an ADS device and writes it to an object.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.ReadAny Method (Int32, Type)
•
TcAdsClient.ReadAny Method (Int32, Type, .Int32.)
•
TcAdsClient.ReadAny Method (UInt32, UInt32, Type)
•
TcAdsClient.ReadAny Method (UInt32, UInt32, Type, .Int32.)


TcAdsClient.ReadAny Method (Int32, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadAny Method [image] TcAdsClient.ReadAny Method (Int32, Type)
TcAdsClient.ReadAny Method (Int32, Type)
Reads data synchronously from an ADS device and writes it to an object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAny(
int variableHandle,
Type type
)
VB
Public Function ReadAny (
variableHandle As Integer,
type As Type
) As Object
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable.
type | Type: System.Type Type of the object to be read.
Return Value
Type: Object
The object the read data is written to.
Implements
IAdsAnyAccess.ReadAny(Int32, Type)
Reference
TcAdsClient Class
ReadAny Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadAny Method (Int32, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadAny Method [image] TcAdsClient.ReadAny Method (Int32, Type, .Int32.)
TcAdsClient.ReadAny Method (Int32, Type, .Int32.)
Reads data synchronously from an ADS device and writes it to an object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAny(
int variableHandle,
Type type,
int[] args
)
VB
Public Function ReadAny (
variableHandle As Integer,
type As Type,
args As Integer()
) As Object
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable.
type | Type: System.Type Type of the object to be read.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Object
The object the read data is written to.
Implements
IAdsAnyAccess.ReadAny(Int32, Type, .Int32.)
Remarks
If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Reference
TcAdsClient Class
ReadAny Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadAny Method (UInt32, UInt32, Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadAny Method [image] TcAdsClient.ReadAny Method (UInt32, UInt32, Type)
TcAdsClient.ReadAny Method (UInt32, UInt32, Type)
Reads data synchronously from an ADS device and writes it to an object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAny(
uint indexGroup,
uint indexOffset,
Type type
)
VB
Public Function ReadAny (
indexGroup As UInteger,
indexOffset As UInteger,
type As Type
) As Object
Parameters
indexGroup | Type: System.UInt32 Index group of the ADS variable.
indexOffset | Type: System.UInt32 Index offset of the ADS variable.
type | Type: System.Type Type of the object to be read.
Return Value
Type: Object
The object the read data is written to.
Implements
IAdsAnyAccess.ReadAny(UInt32, UInt32, Type)
Examples
Usage of ReadAny/WriteAny
using (TcAdsClient client = new TcAdsClient())
{
UInt32 valueToRead = 0;
UInt32 valueToWrite = 42;

client.Connect(AmsNetId.Local, 851);
adsClient.WriteAny(0x4020, 0x0, valueToWrite);
valueToRead = (uint)adsClient.ReadAny(0x4020, 0x0, typeof(UInt32));
}
Reference
TcAdsClient Class
ReadAny Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadAny Method (UInt32, UInt32, Type, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadAny Method [image] TcAdsClient.ReadAny Method (UInt32, UInt32, Type, .Int32.)
TcAdsClient.ReadAny Method (UInt32, UInt32, Type, .Int32.)
Reads data synchronously from an ADS device and writes it to an object.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAny(
uint indexGroup,
uint indexOffset,
Type type,
int[] args
)
VB
Public Function ReadAny (
indexGroup As UInteger,
indexOffset As UInteger,
type As Type,
args As Integer()
) As Object
Parameters
indexGroup | Type: System.UInt32 Index group of the ADS variable.
indexOffset | Type: System.UInt32 Index offset of the ADS variable.
type | Type: System.Type Type of the object to be read.
args | Type: .System.Int32. Additional arguments.
Return Value
Type: Object
The object the read data is written to.
Implements
IAdsAnyAccess.ReadAny(UInt32, UInt32, Type, .Int32.)
Remarks
If the Type of the object to be read is a string type, the first element of the parameter args specifies the number of characters of the string. If the Type of the object to be read is an array type, the number of elements for each dimension has to be specified in the parameter args. At the moment only 1 dimensional Arrays are supported.
Reference
TcAdsClient Class
ReadAny Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadAnyString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadAnyString Method
TcAdsClient.ReadAnyString Method
Overload List
Name | Description
ReadAnyString(Int32, Int32, Encoding) | Reads the string.
ReadAnyString(UInt32, UInt32, Int32, Encoding) | Reads the string
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.ReadAnyString Method (Int32, Int32, Encoding)
•
TcAdsClient.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)


TcAdsClient.ReadAnyString Method (Int32, Int32, Encoding)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadAnyString Method [image] TcAdsClient.ReadAnyString Method (Int32, Int32, Encoding)
TcAdsClient.ReadAnyString Method (Int32, Int32, Encoding)
Reads the string.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ReadAnyString(
int variableHandle,
int len,
Encoding encoding
)
VB
Public Function ReadAnyString (
variableHandle As Integer,
len As Integer,
encoding As Encoding
) As String
Parameters
variableHandle | Type: System.Int32 The variable handle.
len | Type: System.Int32 The length of the string (e.g. 80 for STRING[80] or WSTRING[80]
encoding | Type: System.Text.Encoding The encoding (Default or Unicode).
Return Value
Type: String
System.String.
Implements
IAdsAnyAccess.ReadAnyString(Int32, Int32, Encoding)
Examples
The following code shows how to Read/Write string values with the ANY concept.
Read/Write Any Strings
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local port 851 (PLC)

int stringHandle = client.CreateVariableHandle("MAIN.string"); // Symbol "string" defined in MAIN as STRING
int wStringHandle = client.CreateVariableHandle("MAIN.wstring"); // Symbol "string" defined in MAIN as WSTRING

try
{
string str = client.ReadAnyString(stringHandle, 80, Encoding.Default);
string wStr = client.ReadAnyString(wStringHandle, 80, Encoding.Unicode);

string changedValue = "Changed";

// Attention, take care that the memory of the string in the process image is not exceeded!
client.WriteAnyString(stringHandle, changedValue, 80, Encoding.Default);
client.WriteAnyString(wStringHandle, changedValue, 80, Encoding.Unicode);
}
finally
{
client.DeleteVariableHandle(stringHandle);
client.DeleteVariableHandle(wStringHandle);
}
}
Reference
TcAdsClient Class
ReadAnyString Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadAnyString Method [image] TcAdsClient.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)
TcAdsClient.ReadAnyString Method (UInt32, UInt32, Int32, Encoding)
Reads the string
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ReadAnyString(
uint indexGroup,
uint indexOffset,
int len,
Encoding encoding
)
VB
Public Function ReadAnyString (
indexGroup As UInteger,
indexOffset As UInteger,
len As Integer,
encoding As Encoding
) As String
Parameters
indexGroup | Type: System.UInt32 The index group.
indexOffset | Type: System.UInt32 The index offset.
len | Type: System.Int32 The length of the string.
encoding | Type: System.Text.Encoding The encoding (Default or Unicode).
Return Value
Type: String
System.String.
Implements
IAdsAnyAccess.ReadAnyString(UInt32, UInt32, Int32, Encoding)
Examples
The following code shows how to Read/Write string values with the ANY concept.
Read/Write Any Strings
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local port 851 (PLC)

int stringHandle = client.CreateVariableHandle("MAIN.string"); // Symbol "string" defined in MAIN as STRING
int wStringHandle = client.CreateVariableHandle("MAIN.wstring"); // Symbol "string" defined in MAIN as WSTRING

try
{
string str = client.ReadAnyString(stringHandle, 80, Encoding.Default);
string wStr = client.ReadAnyString(wStringHandle, 80, Encoding.Unicode);

string changedValue = "Changed";

// Attention, take care that the memory of the string in the process image is not exceeded!
client.WriteAnyString(stringHandle, changedValue, 80, Encoding.Default);
client.WriteAnyString(wStringHandle, changedValue, 80, Encoding.Unicode);
}
finally
{
client.DeleteVariableHandle(stringHandle);
client.DeleteVariableHandle(wStringHandle);
}
}
Reference
TcAdsClient Class
ReadAnyString Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadDeviceInfo Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadDeviceInfo Method
TcAdsClient.ReadDeviceInfo Method
Reads the identification and version number of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DeviceInfo ReadDeviceInfo()
VB
Public Function ReadDeviceInfo As DeviceInfo
Return Value
Type: DeviceInfo
DeviceInfo struct containing the name of the device and the version information.
Implements
IAdsConnection.ReadDeviceInfo.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.ReadState Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadState Method
TcAdsClient.ReadState Method
Reads the ADS status and the device status from an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public StateInfo ReadState()
VB
Public Function ReadState As StateInfo
Return Value
Type: StateInfo
The ADS statue and device status.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.ReadSymbol Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadSymbol Method
TcAdsClient.ReadSymbol Method
Overload List
Name | Description
ReadSymbol(ITcAdsSymbol) | Reads the value of a symbol and returns it as an object. Strings and all primitive datatypes(UInt32, Int32, Bool etc.) are supported. Arrays and structures cannot be read.
ReadSymbol(String, Type, Boolean) | Reads the value of a symbol and returns the value as object. The parameter type must have the same layout as the ADS symbol.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.ReadSymbol Method (ITcAdsSymbol)
•
TcAdsClient.ReadSymbol Method (String, Type, Boolean)


TcAdsClient.ReadSymbol Method (ITcAdsSymbol)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadSymbol Method [image] TcAdsClient.ReadSymbol Method (ITcAdsSymbol)
TcAdsClient.ReadSymbol Method (ITcAdsSymbol)
Reads the value of a symbol and returns it as an object. Strings and all primitive datatypes(UInt32, Int32, Bool etc.) are supported. Arrays and structures cannot be read.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadSymbol(
ITcAdsSymbol symbol
)
VB
Public Function ReadSymbol (
symbol As ITcAdsSymbol
) As Object
Parameters
symbol
Type: TwinCAT.Ads.ITcAdsSymbol
The symbol that should be read.
Return Value
Type: Object
The value of the symbol as an object.
Exceptions
Exception | Condition
AdsDatatypeNotSupportedException | Thrown when a ADS datatype is not supported.
AdsErrorException | Thrown when the Sync port is not open.
Reference
TcAdsClient Class
ReadSymbol Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadSymbol Method (String, Type, Boolean)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadSymbol Method [image] TcAdsClient.ReadSymbol Method (String, Type, Boolean)
TcAdsClient.ReadSymbol Method (String, Type, Boolean)
Reads the value of a symbol and returns the value as object. The parameter type must have the same layout as the ADS symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadSymbol(
string name,
Type type,
bool reloadSymbolInfo
)
VB
Public Function ReadSymbol (
name As String,
type As Type,
reloadSymbolInfo As Boolean
) As Object
Parameters
name | Type: System.String Name of the ADS symbol.
type | Type: System.Type Managed type of the ADS symbol.
reloadSymbolInfo | Type: System.Boolean If reload is true previously stored symbol information is cleared. As a consequence the symbol information must be obtained from the ADS server again.
Return Value
Type: Object
Value of the symbol
Reference
TcAdsClient Class
ReadSymbol Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadSymbolInfo Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadSymbolInfo Method
TcAdsClient.ReadSymbolInfo Method
Call this method to obtain information about the individual symbols (variables) in ADS devices.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ITcAdsSymbol ReadSymbolInfo(
string name
)
VB
Public Function ReadSymbolInfo (
name As String
) As ITcAdsSymbol
Parameters
name
Type: System.String
Name of the symbol.
Return Value
Type: ITcAdsSymbol
A ITcAdsSymbol containing the requested symbol information or null if symbol could not be found.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.ReadWrite Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadWrite Method
TcAdsClient.ReadWrite Method
Overload List
Name | Description
ReadWrite(UInt32, UInt32, AdsStream, AdsStream) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
ReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device and then Reads data from this device.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream)
•
TcAdsClient.ReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
•
TcAdsClient.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32)
•
TcAdsClient.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)


TcAdsClient.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadWrite Method [image] TcAdsClient.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream)
TcAdsClient.ReadWrite Method (UInt32, UInt32, AdsStream, AdsStream)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReadWrite(
uint indexGroup,
uint indexOffset,
AdsStream rdDataStream,
AdsStream wrDataStream
)
VB
Public Function ReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
rdDataStream As AdsStream,
wrDataStream As AdsStream
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
Return Value
Type: Int32
Number of successfully returned data bytes.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
ReadWrite Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadWrite Method [image] TcAdsClient.ReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
TcAdsClient.ReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReadWrite(
int variableHandle,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength
)
VB
Public Function ReadWrite (
variableHandle As Integer,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer
) As Integer
Parameters
variableHandle | Type: System.Int32 Variable handle.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Implements
IAdsHandleAccess.ReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
ReadWrite Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadWrite Method [image] TcAdsClient.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32)
TcAdsClient.ReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReadWrite(
uint indexGroup,
uint indexOffset,
byte[] rdDataStream,
int rdOffset,
int rdLength,
byte[] wrDataStream,
int wrOffset,
int wrLength
)
VB
Public Function ReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
rdDataStream As Byte(),
rdOffset As Integer,
rdLength As Integer,
wrDataStream As Byte(),
wrOffset As Integer,
wrLength As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
rdDataStream | Type: .System.Byte. Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: .System.Byte. Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
ReadWrite Overload
TwinCAT.Ads Namespace


TcAdsClient.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.ReadWrite Method [image] TcAdsClient.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
TcAdsClient.ReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReadWrite(
uint indexGroup,
uint indexOffset,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength
)
VB
Public Function ReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer
) As Integer
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
Return Value
Type: Int32
Number of successfully returned data bytes.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
ReadWrite Overload
TwinCAT.Ads Namespace


TcAdsClient.TryAddDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryAddDeviceNotification Method
TcAdsClient.TryAddDeviceNotification Method
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryAddDeviceNotification(
string variableName,
AdsStream dataStream,
int offset,
int length,
NotificationSettings settings,
Object userData,
out uint handle
)
VB
Public Function TryAddDeviceNotification (
variableName As String,
dataStream As AdsStream,
offset As Integer,
length As Integer,
settings As NotificationSettings,
userData As Object,
<OutAttribute> ByRef handle As UInteger
) As AdsErrorCode
Parameters
variableName | Type: System.String Name of the ADS variable.
dataStream | Type: TwinCAT.Ads.AdsStream The stream that should receive the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
settings | Type: TwinCAT.Ads.NotificationSettings The notification settings.
userData | Type: System.Object This object can be used to store user specific data.
handle | Type: System.UInt32. The handle.
Return Value
Type: AdsErrorCode
The handle of the notification.
Implements
IAdsNotifications.TryAddDeviceNotification(String, AdsStream, Int32, Int32, NotificationSettings, Object, UInt32.)
Exceptions
Exception | Condition
ObjectDisposedException |
AdsErrorException |
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
AddDeviceNotificationEx Overload


TcAdsClient.TryAddDeviceNotificationEx Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryAddDeviceNotificationEx Method
TcAdsClient.TryAddDeviceNotificationEx Method
Connects a variable to the ADS client. The ADS client will be notified by the AdsNotification event.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryAddDeviceNotificationEx(
string variableName,
NotificationSettings settings,
Object userData,
Type type,
int[] args,
out uint handle
)
VB
Public Function TryAddDeviceNotificationEx (
variableName As String,
settings As NotificationSettings,
userData As Object,
type As Type,
args As Integer(),
<OutAttribute> ByRef handle As UInteger
) As AdsErrorCode
Parameters
variableName | Type: System.String Name of the ADS variable.
settings | Type: TwinCAT.Ads.NotificationSettings The settings.
userData | Type: System.Object This object can be used to store user specific data.
type | Type: System.Type Type of the object stored in the event argument.
args | Type: .System.Int32. Additional arguments.
handle | Type: System.UInt32. The handle.
Return Value
Type: AdsErrorCode
The handle of the notification.
Implements
IAdsNotifications.TryAddDeviceNotificationEx(String, NotificationSettings, Object, Type, .Int32., UInt32.)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.TryDeleteDeviceNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryDeleteDeviceNotification Method
TcAdsClient.TryDeleteDeviceNotification Method
Deletes an existing notification.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryDeleteDeviceNotification(
uint notificationHandle
)
VB
Public Function TryDeleteDeviceNotification (
notificationHandle As UInteger
) As AdsErrorCode
Parameters
notificationHandle
Type: System.UInt32
Handle of the notification.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Implements
IAdsNotifications.TryDeleteDeviceNotification(UInt32)
Exceptions
Exception | Condition
ObjectDisposedException |
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.TryInvokeRpcMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryInvokeRpcMethod Method
TcAdsClient.TryInvokeRpcMethod Method
Overload List
Name | Description
TryInvokeRpcMethod(String, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(String, String, .Object., Object.) | Tries to invoke the RPC method.
TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.) | Invokes the specified RPC Method
TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.) | Tries to invoke a RPC method.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)
•
TcAdsClient.TryInvokeRpcMethod Method (String, String, .Object., Object.)
•
TcAdsClient.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)
•
TcAdsClient.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)


TcAdsClient.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryInvokeRpcMethod Method [image] TcAdsClient.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)
TcAdsClient.TryInvokeRpcMethod Method (String, Int32, .Object., Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryInvokeRpcMethod(
string symbolPath,
int methodId,
Object[] parameters,
out Object retValue
)
VB
Public Function TryInvokeRpcMethod (
symbolPath As String,
methodId As Integer,
parameters As Object(),
<OutAttribute> ByRef retValue As Object
) As AdsErrorCode
Parameters
symbolPath | Type: System.String The symbol path.
methodId | Type: System.Int32 The method identifier.
parameters | Type: .System.Object. The parameters.
retValue | Type: System.Object. The return value.
Return Value
Type: AdsErrorCode
true if succeeded, false otherwise.
Implements
ITcAdsRpcInvoke.TryInvokeRpcMethod(String, Int32, .Object., Object.)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | symbolPath or methodId
ArgumentNullException | parameters
RpcMethodNotSupportedException |
Reference
TcAdsClient Class
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


TcAdsClient.TryInvokeRpcMethod Method (String, String, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryInvokeRpcMethod Method [image] TcAdsClient.TryInvokeRpcMethod Method (String, String, .Object., Object.)
TcAdsClient.TryInvokeRpcMethod Method (String, String, .Object., Object.)
Tries to invoke the RPC method.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryInvokeRpcMethod(
string symbolPath,
string methodName,
Object[] parameters,
out Object returnValue
)
VB
Public Function TryInvokeRpcMethod (
symbolPath As String,
methodName As String,
parameters As Object(),
<OutAttribute> ByRef returnValue As Object
) As AdsErrorCode
Parameters
symbolPath | Type: System.String The symbol path.
methodName | Type: System.String Name of the method.
parameters | Type: .System.Object. The parameters.
returnValue | Type: System.Object. The return value.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Implements
ITcAdsRpcInvoke.TryInvokeRpcMethod(String, String, .Object., Object.)
Exceptions
Exception | Condition
NotImplementedException |
Reference
TcAdsClient Class
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


TcAdsClient.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryInvokeRpcMethod Method [image] TcAdsClient.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)
TcAdsClient.TryInvokeRpcMethod Method (ITcAdsSymbol, Int32, .Object., Object.)
Invokes the specified RPC Method
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryInvokeRpcMethod(
ITcAdsSymbol symbol,
int methodId,
Object[] parameters,
out Object retValue
)
VB
Public Function TryInvokeRpcMethod (
symbol As ITcAdsSymbol,
methodId As Integer,
parameters As Object(),
<OutAttribute> ByRef retValue As Object
) As AdsErrorCode
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodId | Type: System.Int32 The method identifier / Virtual Function table index.
parameters | Type: .System.Object. The parameters.
retValue | Type: System.Object. The return value.
Return Value
Type: AdsErrorCode
true if succeeded, false otherwise.
Implements
ITcAdsRpcInvoke.TryInvokeRpcMethod(ITcAdsSymbol, Int32, .Object., Object.)
Exceptions
Exception | Condition
ArgumentNullException | symbol or parameters
ArgumentOutOfRangeException | methodId
RpcMethodNotSupportedException |
Reference
TcAdsClient Class
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


TcAdsClient.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryInvokeRpcMethod Method [image] TcAdsClient.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)
TcAdsClient.TryInvokeRpcMethod Method (ITcAdsSymbol, String, .Object., Object.)
Tries to invoke a RPC method.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryInvokeRpcMethod(
ITcAdsSymbol symbol,
string methodName,
Object[] parameters,
out Object returnValue
)
VB
Public Function TryInvokeRpcMethod (
symbol As ITcAdsSymbol,
methodName As String,
parameters As Object(),
<OutAttribute> ByRef returnValue As Object
) As AdsErrorCode
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol.
methodName | Type: System.String Name of the method.
parameters | Type: .System.Object. The parameters.
returnValue | Type: System.Object. The return value.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Implements
ITcAdsRpcInvoke.TryInvokeRpcMethod(ITcAdsSymbol, String, .Object., Object.)
Exceptions
Exception | Condition
ArgumentNullException | symbol or parameters
ArgumentOutOfRangeException | methodName
AdsSymbolException |
Reference
TcAdsClient Class
TryInvokeRpcMethod Overload
TwinCAT.Ads Namespace


TcAdsClient.TryRead Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryRead Method
TcAdsClient.TryRead Method
Overload List
Name | Description
TryRead(UInt32, UInt32, AdsStream, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(Int32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, .Byte., Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
TryRead(UInt32, UInt32, AdsStream, Int32, Int32, Int32.) | Reads data synchronously from an ADS device and writes it to the given stream.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.TryRead Method (UInt32, UInt32, AdsStream, Int32.)
•
TcAdsClient.TryRead Method (Int32, AdsStream, Int32, Int32, Int32.)
•
TcAdsClient.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32.)
•
TcAdsClient.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32.)


TcAdsClient.TryRead Method (UInt32, UInt32, AdsStream, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryRead Method [image] TcAdsClient.TryRead Method (UInt32, UInt32, AdsStream, Int32.)
TcAdsClient.TryRead Method (UInt32, UInt32, AdsStream, Int32.)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryRead(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
out int readBytes
)
VB
Public Function TryRead (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
readBytes | Type: System.Int32. Number of successfully returned data bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
TcAdsClient Class
TryRead Overload
TwinCAT.Ads Namespace


TcAdsClient.TryRead Method (Int32, AdsStream, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryRead Method [image] TcAdsClient.TryRead Method (Int32, AdsStream, Int32, Int32, Int32.)
TcAdsClient.TryRead Method (Int32, AdsStream, Int32, Int32, Int32.)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryRead(
int variableHandle,
AdsStream dataStream,
int offset,
int length,
out int readBytes
)
VB
Public Function TryRead (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
readBytes | Type: System.Int32. Number of successfully returned data bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode
Implements
IAdsHandleAccess.TryRead(Int32, AdsStream, Int32, Int32, Int32.)
Exceptions
Exception | Condition
ArgumentException |
Reference
TcAdsClient Class
TryRead Overload
TwinCAT.Ads Namespace


TcAdsClient.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryRead Method [image] TcAdsClient.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32.)
TcAdsClient.TryRead Method (UInt32, UInt32, .Byte., Int32, Int32, Int32.)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryRead(
uint indexGroup,
uint indexOffset,
byte[] dataStream,
int offset,
int length,
out int readBytes
)
VB
Public Function TryRead (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As Byte(),
offset As Integer,
length As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: .System.Byte. Stream that receives the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
readBytes | Type: System.Int32. Number of successfully returned data bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
TcAdsClient Class
TryRead Overload
TwinCAT.Ads Namespace


TcAdsClient.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryRead Method [image] TcAdsClient.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32.)
TcAdsClient.TryRead Method (UInt32, UInt32, AdsStream, Int32, Int32, Int32.)
Reads data synchronously from an ADS device and writes it to the given stream.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryRead(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length,
out int readBytes
)
VB
Public Function TryRead (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
readBytes | Type: System.Int32. Number of successfully returned data bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
TcAdsClient Class
TryRead Overload
TwinCAT.Ads Namespace


TcAdsClient.TryReadState Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryReadState Method
TcAdsClient.TryReadState Method
Reads the ADS status and the device status from an ADS server. Unlike the ReadState method this method does not call an exception on failure. Instead an AdsErrorCode is returned. If the return value is equal to AdsErrorCode.NoError the call was successfull.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadState(
out StateInfo stateInfo
)
VB
Public Function TryReadState (
<OutAttribute> ByRef stateInfo As StateInfo
) As AdsErrorCode
Parameters
stateInfo
Type: TwinCAT.Ads.StateInfo.
The ADS statue and device status.
Return Value
Type: AdsErrorCode
AdsErrorCode of the ads read state call. Check for AdsErrorCode.NoError to see if call was successfull.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.TryReadWrite Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryReadWrite Method
TcAdsClient.TryReadWrite Method
Overload List
Name | Description
TryReadWrite(Int32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
TryReadWrite(UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.) | Writes data synchronously to an ADS device and then Reads data from this device.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.TryReadWrite Method (Int32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)
•
TcAdsClient.TryReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
•
TcAdsClient.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)
•
TcAdsClient.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)


TcAdsClient.TryReadWrite Method (Int32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryReadWrite Method [image] TcAdsClient.TryReadWrite Method (Int32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)
TcAdsClient.TryReadWrite Method (Int32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadWrite(
int variableHandle,
byte[] rdDataStream,
int rdOffset,
int rdLength,
byte[] wrDataStream,
int wrOffset,
int wrLength,
out int readBytes
)
VB
Public Function TryReadWrite (
variableHandle As Integer,
rdDataStream As Byte(),
rdOffset As Integer,
rdLength As Integer,
wrDataStream As Byte(),
wrOffset As Integer,
wrLength As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
variableHandle | Type: System.Int32 Variable handle.
rdDataStream | Type: .System.Byte. Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: .System.Byte. Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ArgumentException |
Reference
TcAdsClient Class
TryReadWrite Overload
TwinCAT.Ads Namespace


TcAdsClient.TryReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryReadWrite Method [image] TcAdsClient.TryReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
TcAdsClient.TryReadWrite Method (Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadWrite(
int variableHandle,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength,
out int readBytes
)
VB
Public Function TryReadWrite (
variableHandle As Integer,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
variableHandle | Type: System.Int32 Variable handle.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Implements
IAdsHandleAccess.TryReadWrite(Int32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
Exceptions
Exception | Condition
ArgumentException |
Reference
TcAdsClient Class
TryReadWrite Overload
TwinCAT.Ads Namespace


TcAdsClient.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryReadWrite Method [image] TcAdsClient.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)
TcAdsClient.TryReadWrite Method (UInt32, UInt32, .Byte., Int32, Int32, .Byte., Int32, Int32, Int32.)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadWrite(
uint indexGroup,
uint indexOffset,
byte[] rdDataStream,
int rdOffset,
int rdLength,
byte[] wrDataStream,
int wrOffset,
int wrLength,
out int readBytes
)
VB
Public Function TryReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
rdDataStream As Byte(),
rdOffset As Integer,
rdLength As Integer,
wrDataStream As Byte(),
wrOffset As Integer,
wrLength As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
rdDataStream | Type: .System.Byte. Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: .System.Byte. Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
TcAdsClient Class
TryReadWrite Overload
TwinCAT.Ads Namespace


TcAdsClient.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryReadWrite Method [image] TcAdsClient.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
TcAdsClient.TryReadWrite Method (UInt32, UInt32, AdsStream, Int32, Int32, AdsStream, Int32, Int32, Int32.)
Writes data synchronously to an ADS device and then Reads data from this device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReadWrite(
uint indexGroup,
uint indexOffset,
AdsStream rdDataStream,
int rdOffset,
int rdLength,
AdsStream wrDataStream,
int wrOffset,
int wrLength,
out int readBytes
)
VB
Public Function TryReadWrite (
indexGroup As UInteger,
indexOffset As UInteger,
rdDataStream As AdsStream,
rdOffset As Integer,
rdLength As Integer,
wrDataStream As AdsStream,
wrOffset As Integer,
wrLength As Integer,
<OutAttribute> ByRef readBytes As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
rdDataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data that has been read.
rdOffset | Type: System.Int32 Offset of the data in rdDataStream.
rdLength | Type: System.Int32 Length of the data in rdDataStream.
wrDataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be written.
wrOffset | Type: System.Int32 Offset of the data in wrDataStream.
wrLength | Type: System.Int32 Length of the data in wrDataStream.
readBytes | Type: System.Int32. The read bytes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
TcAdsClient Class
TryReadWrite Overload
TwinCAT.Ads Namespace


TcAdsClient.TryWrite Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryWrite Method
TcAdsClient.TryWrite Method
Overload List
Name | Description
TryWrite(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
TryWrite(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.TryWrite Method (Int32, AdsStream, Int32, Int32)
•
TcAdsClient.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32)
•
TcAdsClient.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32)


TcAdsClient.TryWrite Method (Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryWrite Method [image] TcAdsClient.TryWrite Method (Int32, AdsStream, Int32, Int32)
TcAdsClient.TryWrite Method (Int32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWrite(
int variableHandle,
AdsStream dataStream,
int offset,
int length
)
VB
Public Function TryWrite (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As AdsErrorCode
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Implements
IAdsHandleAccess.TryWrite(Int32, AdsStream, Int32, Int32)
Exceptions
Exception | Condition
ArgumentException |
Reference
TcAdsClient Class
TryWrite Overload
TwinCAT.Ads Namespace


TcAdsClient.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryWrite Method [image] TcAdsClient.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32)
TcAdsClient.TryWrite Method (UInt32, UInt32, .Byte., Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWrite(
uint indexGroup,
uint indexOffset,
byte[] writeBuffer,
int offset,
int length
)
VB
Public Function TryWrite (
indexGroup As UInteger,
indexOffset As UInteger,
writeBuffer As Byte(),
offset As Integer,
length As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
writeBuffer | Type: .System.Byte. The write buffer.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
TcAdsClient Class
TryWrite Overload
TwinCAT.Ads Namespace


TcAdsClient.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryWrite Method [image] TcAdsClient.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32)
TcAdsClient.TryWrite Method (UInt32, UInt32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWrite(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length
)
VB
Public Function TryWrite (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As AdsErrorCode
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
TcAdsClient Class
TryWrite Overload
TwinCAT.Ads Namespace


TcAdsClient.TryWriteControl Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryWriteControl Method
TcAdsClient.TryWriteControl Method
Overload List
Name | Description
TryWriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
TryWriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.TryWriteControl Method (StateInfo)
•
TcAdsClient.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32)


TcAdsClient.TryWriteControl Method (StateInfo)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryWriteControl Method [image] TcAdsClient.TryWriteControl Method (StateInfo)
TcAdsClient.TryWriteControl Method (StateInfo)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWriteControl(
StateInfo stateInfo
)
VB
Public Function TryWriteControl (
stateInfo As StateInfo
) As AdsErrorCode
Parameters
stateInfo
Type: TwinCAT.Ads.StateInfo
New ADS status and device status.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
TcAdsClient Class
TryWriteControl Overload
TwinCAT.Ads Namespace


TcAdsClient.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.TryWriteControl Method [image] TcAdsClient.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32)
TcAdsClient.TryWriteControl Method (StateInfo, AdsStream, Int32, Int32)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWriteControl(
StateInfo stateInfo,
AdsStream dataStream,
int offset,
int length
)
VB
Public Function TryWriteControl (
stateInfo As StateInfo,
dataStream As AdsStream,
offset As Integer,
length As Integer
) As AdsErrorCode
Parameters
stateInfo | Type: TwinCAT.Ads.StateInfo New ADS status and device status.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be sent to the ADS device
offset | Type: System.Int32 Offset of the data in the stream.
length | Type: System.Int32 Length of the data in the stream.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Exceptions
Exception | Condition
ArgumentException |
Reference
TcAdsClient Class
TryWriteControl Overload
TwinCAT.Ads Namespace


TcAdsClient.Write Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Write Method
TcAdsClient.Write Method
Overload List
Name | Description
Write(Int32, Int32) | Trigger Client Method/Command.
Write(Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32) | Trigger Client Method/Command.
Write(Int32, Int32, AdsStream) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream) | Writes data synchronously to an ADS device.
Write(Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(Int32, Int32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
Write(Int32, Int32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, .Byte., Int32, Int32) | Writes data synchronously to an ADS device.
Write(UInt32, UInt32, AdsStream, Int32, Int32) | Writes data synchronously to an ADS device.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.Write Method (Int32, Int32)
•
TcAdsClient.Write Method (Int32, AdsStream)
•
TcAdsClient.Write Method (UInt32, UInt32)
•
TcAdsClient.Write Method (Int32, Int32, AdsStream)
•
TcAdsClient.Write Method (UInt32, UInt32, AdsStream)
•
TcAdsClient.Write Method (Int32, AdsStream, Int32, Int32)
•
TcAdsClient.Write Method (Int32, Int32, .Byte., Int32, Int32)
•
TcAdsClient.Write Method (Int32, Int32, AdsStream, Int32, Int32)
•
TcAdsClient.Write Method (UInt32, UInt32, .Byte., Int32, Int32)
•
TcAdsClient.Write Method (UInt32, UInt32, AdsStream, Int32, Int32)


TcAdsClient.Write Method (Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Write Method [image] TcAdsClient.Write Method (Int32, Int32)
TcAdsClient.Write Method (Int32, Int32)
Trigger Client Method/Command.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
int indexGroup,
int indexOffset
)
VB
Public Sub Write (
indexGroup As Integer,
indexOffset As Integer
)
Parameters
indexGroup | Type: System.Int32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.Int32 Contains the index offset number of the requested ADS service.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Remarks
This method is used to trigger Client Methods/Commands without parameters.
Reference
TcAdsClient Class
Write Overload
TwinCAT.Ads Namespace


TcAdsClient.Write Method (Int32, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Write Method [image] TcAdsClient.Write Method (Int32, AdsStream)
TcAdsClient.Write Method (Int32, AdsStream)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
int variableHandle,
AdsStream dataStream
)
VB
Public Sub Write (
variableHandle As Integer,
dataStream As AdsStream
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
Implements
IAdsHandleAccess.Write(Int32, AdsStream)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Write Overload
TwinCAT.Ads Namespace


TcAdsClient.Write Method (UInt32, UInt32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Write Method [image] TcAdsClient.Write Method (UInt32, UInt32)
TcAdsClient.Write Method (UInt32, UInt32)
Trigger Client Method/Command.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Remarks
This method is used to trigger Client Methods/Commands without parameters.
Reference
TcAdsClient Class
Write Overload
TwinCAT.Ads Namespace


TcAdsClient.Write Method (Int32, Int32, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Write Method [image] TcAdsClient.Write Method (Int32, Int32, AdsStream)
TcAdsClient.Write Method (Int32, Int32, AdsStream)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
int indexGroup,
int indexOffset,
AdsStream dataStream
)
VB
Public Sub Write (
indexGroup As Integer,
indexOffset As Integer,
dataStream As AdsStream
)
Parameters
indexGroup | Type: System.Int32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.Int32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Write Overload
TwinCAT.Ads Namespace


TcAdsClient.Write Method (UInt32, UInt32, AdsStream)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Write Method [image] TcAdsClient.Write Method (UInt32, UInt32, AdsStream)
TcAdsClient.Write Method (UInt32, UInt32, AdsStream)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset,
AdsStream dataStream
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that receives the data.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Write Overload
TwinCAT.Ads Namespace


TcAdsClient.Write Method (Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Write Method [image] TcAdsClient.Write Method (Int32, AdsStream, Int32, Int32)
TcAdsClient.Write Method (Int32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
int variableHandle,
AdsStream dataStream,
int offset,
int length
)
VB
Public Sub Write (
variableHandle As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Implements
IAdsHandleAccess.Write(Int32, AdsStream, Int32, Int32)
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Write Overload
TwinCAT.Ads Namespace


TcAdsClient.Write Method (Int32, Int32, .Byte., Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Write Method [image] TcAdsClient.Write Method (Int32, Int32, .Byte., Int32, Int32)
TcAdsClient.Write Method (Int32, Int32, .Byte., Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
int indexGroup,
int indexOffset,
byte[] writeBuffer,
int offset,
int length
)
VB
Public Sub Write (
indexGroup As Integer,
indexOffset As Integer,
writeBuffer As Byte(),
offset As Integer,
length As Integer
)
Parameters
indexGroup | Type: System.Int32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.Int32 Contains the index offset number of the requested ADS service.
writeBuffer | Type: .System.Byte. The write buffer.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Write Overload
TwinCAT.Ads Namespace


TcAdsClient.Write Method (Int32, Int32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Write Method [image] TcAdsClient.Write Method (Int32, Int32, AdsStream, Int32, Int32)
TcAdsClient.Write Method (Int32, Int32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
int indexGroup,
int indexOffset,
AdsStream dataStream,
int offset,
int length
)
VB
Public Sub Write (
indexGroup As Integer,
indexOffset As Integer,
dataStream As AdsStream,
offset As Integer,
length As Integer
)
Parameters
indexGroup | Type: System.Int32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.Int32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Write Overload
TwinCAT.Ads Namespace


TcAdsClient.Write Method (UInt32, UInt32, .Byte., Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Write Method [image] TcAdsClient.Write Method (UInt32, UInt32, .Byte., Int32, Int32)
TcAdsClient.Write Method (UInt32, UInt32, .Byte., Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset,
byte[] dataStream,
int offset,
int length
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As Byte(),
offset As Integer,
length As Integer
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: .System.Byte. Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Write Overload
TwinCAT.Ads Namespace


TcAdsClient.Write Method (UInt32, UInt32, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.Write Method [image] TcAdsClient.Write Method (UInt32, UInt32, AdsStream, Int32, Int32)
TcAdsClient.Write Method (UInt32, UInt32, AdsStream, Int32, Int32)
Writes data synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
uint indexGroup,
uint indexOffset,
AdsStream dataStream,
int offset,
int length
)
VB
Public Sub Write (
indexGroup As UInteger,
indexOffset As UInteger,
dataStream As AdsStream,
offset As Integer,
length As Integer
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data.
offset | Type: System.Int32 Offset of the data in dataStream.
length | Type: System.Int32 Length of the data in dataStream.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
Write Overload
TwinCAT.Ads Namespace


TcAdsClient.WriteAny Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteAny Method
TcAdsClient.WriteAny Method
Overload List
Name | Description
WriteAny(Int32, Object) | Writes an object synchronously to an ADS device.
WriteAny(Int32, Object, .Int32.) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object) | Writes an object synchronously to an ADS device.
WriteAny(UInt32, UInt32, Object, .Int32.) | Writes an object synchronously to an ADS device.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.WriteAny Method (Int32, Object)
•
TcAdsClient.WriteAny Method (Int32, Object, .Int32.)
•
TcAdsClient.WriteAny Method (UInt32, UInt32, Object)
•
TcAdsClient.WriteAny Method (UInt32, UInt32, Object, .Int32.)


TcAdsClient.WriteAny Method (Int32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteAny Method [image] TcAdsClient.WriteAny Method (Int32, Object)
TcAdsClient.WriteAny Method (Int32, Object)
Writes an object synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAny(
int variableHandle,
Object value
)
VB
Public Sub WriteAny (
variableHandle As Integer,
value As Object
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable.
value | Type: System.Object Object to write to the ADS device.
Implements
IAdsAnyAccess.WriteAny(Int32, Object)
Reference
TcAdsClient Class
WriteAny Overload
TwinCAT.Ads Namespace


TcAdsClient.WriteAny Method (Int32, Object, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteAny Method [image] TcAdsClient.WriteAny Method (Int32, Object, .Int32.)
TcAdsClient.WriteAny Method (Int32, Object, .Int32.)
Writes an object synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAny(
int variableHandle,
Object value,
int[] args
)
VB
Public Sub WriteAny (
variableHandle As Integer,
value As Object,
args As Integer()
)
Parameters
variableHandle | Type: System.Int32 Handle of the ADS variable.
value | Type: System.Object Object to write to the ADS device.
args | Type: .System.Int32. Additional arguments.
Implements
IAdsAnyAccess.WriteAny(Int32, Object, .Int32.)
Remarks
If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
Reference
TcAdsClient Class
WriteAny Overload
TwinCAT.Ads Namespace


TcAdsClient.WriteAny Method (UInt32, UInt32, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteAny Method [image] TcAdsClient.WriteAny Method (UInt32, UInt32, Object)
TcAdsClient.WriteAny Method (UInt32, UInt32, Object)
Writes an object synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAny(
uint indexGroup,
uint indexOffset,
Object value
)
VB
Public Sub WriteAny (
indexGroup As UInteger,
indexOffset As UInteger,
value As Object
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
value | Type: System.Object Object to write to the ADS device.
Implements
IAdsAnyAccess.WriteAny(UInt32, UInt32, Object)
Examples
Usage of ReadAny/WriteAny
using (TcAdsClient client = new TcAdsClient())
{
UInt32 valueToRead = 0;
UInt32 valueToWrite = 42;

client.Connect(AmsNetId.Local, 851);
adsClient.WriteAny(0x4020, 0x0, valueToWrite);
valueToRead = (uint)adsClient.ReadAny(0x4020, 0x0, typeof(UInt32));
}
Reference
TcAdsClient Class
WriteAny Overload
TwinCAT.Ads Namespace


TcAdsClient.WriteAny Method (UInt32, UInt32, Object, .Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteAny Method [image] TcAdsClient.WriteAny Method (UInt32, UInt32, Object, .Int32.)
TcAdsClient.WriteAny Method (UInt32, UInt32, Object, .Int32.)
Writes an object synchronously to an ADS device.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAny(
uint indexGroup,
uint indexOffset,
Object value,
int[] args
)
VB
Public Sub WriteAny (
indexGroup As UInteger,
indexOffset As UInteger,
value As Object,
args As Integer()
)
Parameters
indexGroup | Type: System.UInt32 Contains the index group number of the requested ADS service.
indexOffset | Type: System.UInt32 Contains the index offset number of the requested ADS service.
value | Type: System.Object Object to write to the ADS device.
args | Type: .System.Int32. Additional arguments.
Implements
IAdsAnyAccess.WriteAny(UInt32, UInt32, Object, .Int32.)
Remarks
If the Type of the object to be written is a string type, the first element of parameter args specifies the number of characters of the string.
Reference
TcAdsClient Class
WriteAny Overload
TwinCAT.Ads Namespace


TcAdsClient.WriteAnyString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteAnyString Method
TcAdsClient.WriteAnyString Method
Overload List
Name | Description
WriteAnyString(Int32, String, Int32, Encoding) | Writes the string (Potentially unsafe!)
WriteAnyString(UInt32, UInt32, String, Int32, Encoding) | Writes the string (Potentially unsafe!)
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.WriteAnyString Method (Int32, String, Int32, Encoding)
•
TcAdsClient.WriteAnyString Method (UInt32, UInt32, String, Int32, Encoding)


TcAdsClient.WriteAnyString Method (Int32, String, Int32, Encoding)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteAnyString Method [image] TcAdsClient.WriteAnyString Method (Int32, String, Int32, Encoding)
TcAdsClient.WriteAnyString Method (Int32, String, Int32, Encoding)
Writes the string (Potentially unsafe!)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAnyString(
int variableHandle,
string value,
int length,
Encoding encoding
)
VB
Public Sub WriteAnyString (
variableHandle As Integer,
value As String,
length As Integer,
encoding As Encoding
)
Parameters
variableHandle | Type: System.Int32 The variable handle.
value | Type: System.String The value.
length | Type: System.Int32 The length of the string to write
encoding | Type: System.Text.Encoding The encoding.
Exceptions
Exception | Condition
NotImplementedException |
Remarks
ATTENTION: Potentially this method is unsafe because following data can be overwritten after the string symbol. Please be sure to specify the string length lower than the string size reserved within the process image!
Examples
The following code shows how to Read/Write string values with the ANY concept.
Read/Write Any Strings
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local port 851 (PLC)

int stringHandle = client.CreateVariableHandle("MAIN.string"); // Symbol "string" defined in MAIN as STRING
int wStringHandle = client.CreateVariableHandle("MAIN.wstring"); // Symbol "string" defined in MAIN as WSTRING

try
{
string str = client.ReadAnyString(stringHandle, 80, Encoding.Default);
string wStr = client.ReadAnyString(wStringHandle, 80, Encoding.Unicode);

string changedValue = "Changed";

// Attention, take care that the memory of the string in the process image is not exceeded!
client.WriteAnyString(stringHandle, changedValue, 80, Encoding.Default);
client.WriteAnyString(wStringHandle, changedValue, 80, Encoding.Unicode);
}
finally
{
client.DeleteVariableHandle(stringHandle);
client.DeleteVariableHandle(wStringHandle);
}
}
Reference
TcAdsClient Class
WriteAnyString Overload
TwinCAT.Ads Namespace


TcAdsClient.WriteAnyString Method (UInt32, UInt32, String, Int32, Encoding)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteAnyString Method [image] TcAdsClient.WriteAnyString Method (UInt32, UInt32, String, Int32, Encoding)
TcAdsClient.WriteAnyString Method (UInt32, UInt32, String, Int32, Encoding)
Writes the string (Potentially unsafe!)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAnyString(
uint indexGroup,
uint indexOffset,
string value,
int length,
Encoding encoding
)
VB
Public Sub WriteAnyString (
indexGroup As UInteger,
indexOffset As UInteger,
value As String,
length As Integer,
encoding As Encoding
)
Parameters
indexGroup | Type: System.UInt32 The index group.
indexOffset | Type: System.UInt32 The index offset.
value | Type: System.String The value.
length | Type: System.Int32 The length.
encoding | Type: System.Text.Encoding The encoding.
Exceptions
Exception | Condition
NotImplementedException |
Remarks
ATTENTION: Potentially this method is unsafe because following data can be overwritten after the string symbol. Please be sure to specify the string length lower than the string size reserved within the process image!
Examples
The following code shows how to Read/Write string values with the ANY concept.
Read/Write Any Strings
using (TcAdsClient client = new TcAdsClient())
{
client.Connect(851); // Connect to local port 851 (PLC)

int stringHandle = client.CreateVariableHandle("MAIN.string"); // Symbol "string" defined in MAIN as STRING
int wStringHandle = client.CreateVariableHandle("MAIN.wstring"); // Symbol "string" defined in MAIN as WSTRING

try
{
string str = client.ReadAnyString(stringHandle, 80, Encoding.Default);
string wStr = client.ReadAnyString(wStringHandle, 80, Encoding.Unicode);

string changedValue = "Changed";

// Attention, take care that the memory of the string in the process image is not exceeded!
client.WriteAnyString(stringHandle, changedValue, 80, Encoding.Default);
client.WriteAnyString(wStringHandle, changedValue, 80, Encoding.Unicode);
}
finally
{
client.DeleteVariableHandle(stringHandle);
client.DeleteVariableHandle(wStringHandle);
}
}
Reference
TcAdsClient Class
WriteAnyString Overload
TwinCAT.Ads Namespace


TcAdsClient.WriteControl Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteControl Method
TcAdsClient.WriteControl Method
Overload List
Name | Description
WriteControl(StateInfo) | Changes the ADS status and the device status of an ADS server.
WriteControl(StateInfo, AdsStream, Int32, Int32) | Changes the ADS status and the device status of an ADS server.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.WriteControl Method (StateInfo)
•
TcAdsClient.WriteControl Method (StateInfo, AdsStream, Int32, Int32)


TcAdsClient.WriteControl Method (StateInfo)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteControl Method [image] TcAdsClient.WriteControl Method (StateInfo)
TcAdsClient.WriteControl Method (StateInfo)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteControl(
StateInfo stateInfo
)
VB
Public Sub WriteControl (
stateInfo As StateInfo
)
Parameters
stateInfo
Type: TwinCAT.Ads.StateInfo
New ADS status and device status.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
WriteControl Overload
TwinCAT.Ads Namespace


TcAdsClient.WriteControl Method (StateInfo, AdsStream, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteControl Method [image] TcAdsClient.WriteControl Method (StateInfo, AdsStream, Int32, Int32)
TcAdsClient.WriteControl Method (StateInfo, AdsStream, Int32, Int32)
Changes the ADS status and the device status of an ADS server.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteControl(
StateInfo stateInfo,
AdsStream dataStream,
int offset,
int length
)
VB
Public Sub WriteControl (
stateInfo As StateInfo,
dataStream As AdsStream,
offset As Integer,
length As Integer
)
Parameters
stateInfo | Type: TwinCAT.Ads.StateInfo New ADS status and device status.
dataStream | Type: TwinCAT.Ads.AdsStream Stream that contains the data that should be sent to the ADS device
offset | Type: System.Int32 Offset of the data in the stream.
length | Type: System.Int32 Length of the data in the stream.
Exceptions
Exception | Condition
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
WriteControl Overload
TwinCAT.Ads Namespace


TcAdsClient.WriteSymbol Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteSymbol Method
TcAdsClient.WriteSymbol Method
Overload List
Name | Description
WriteSymbol(ITcAdsSymbol, Object) | Writes a value to the symbol. Strings and all primitive data types(UInt32, Int32, Bool etc.) are supported. Array and structures are not supported. If a string is passed as parameter, the method attempts to parse the string according to the ADS data type of the symbol.
WriteSymbol(String, Object, Boolean) | Writes the passed object value to the specified ADS symbol.The parameter type must have the same layout as the ADS symbol.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.WriteSymbol Method (ITcAdsSymbol, Object)
•
TcAdsClient.WriteSymbol Method (String, Object, Boolean)


TcAdsClient.WriteSymbol Method (ITcAdsSymbol, Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteSymbol Method [image] TcAdsClient.WriteSymbol Method (ITcAdsSymbol, Object)
TcAdsClient.WriteSymbol Method (ITcAdsSymbol, Object)
Writes a value to the symbol. Strings and all primitive data types(UInt32, Int32, Bool etc.) are supported. Array and structures are not supported. If a string is passed as parameter, the method attempts to parse the string according to the ADS data type of the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteSymbol(
ITcAdsSymbol symbol,
Object val
)
VB
Public Sub WriteSymbol (
symbol As ITcAdsSymbol,
val As Object
)
Parameters
symbol | Type: TwinCAT.Ads.ITcAdsSymbol The symbol the value is written to.
val | Type: System.Object The value to write.
Exceptions
Exception | Condition
AdsDatatypeNotSupportedException | Thrown when a ADS data type is not supported.
AdsErrorException | Thrown when the ADS call fails.
Reference
TcAdsClient Class
WriteSymbol Overload
TwinCAT.Ads Namespace


TcAdsClient.WriteSymbol Method (String, Object, Boolean)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Methods [image] TcAdsClient.WriteSymbol Method [image] TcAdsClient.WriteSymbol Method (String, Object, Boolean)
TcAdsClient.WriteSymbol Method (String, Object, Boolean)
Writes the passed object value to the specified ADS symbol.The parameter type must have the same layout as the ADS symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteSymbol(
string name,
Object value,
bool reloadSymbolInfo
)
VB
Public Sub WriteSymbol (
name As String,
value As Object,
reloadSymbolInfo As Boolean
)
Parameters
name | Type: System.String Name of the ADS symbol.
value | Type: System.Object Object holding the value to be written to the ADS symbol
reloadSymbolInfo | Type: System.Boolean If reload is true previously stored symbol information is cleared. As a consequence the symbol information must be obtained from the ADS server again.
Reference
TcAdsClient Class
WriteSymbol Overload
TwinCAT.Ads Namespace


TcAdsClient Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Events
TcAdsClient Events
The TcAdsClient type exposes the following members.
Events
Name | Description
AdsNotification | Occurs when the ADS device sends a ADS Notification to the client.
AdsNotificationError | Occurs when a exception has occurred during notification management.
AdsNotificationEx | Occurs when the ADS devices sends an (extended) notification to the client.
AdsStateChanged | Occurs when the ADS state changes.
AdsSymbolVersionChanged | Occurs when the symbol version has been changed changes.
AmsRouterNotification | Occurs when the state of the local Router has changed.
ConnectionStateChanged | Occurs when the connection state has been changed.
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsClient.AdsNotification Event
•
TcAdsClient.AdsNotificationError Event
•
TcAdsClient.AdsNotificationEx Event
•
TcAdsClient.AdsStateChanged Event
•
TcAdsClient.AdsSymbolVersionChanged Event
•
TcAdsClient.AmsRouterNotification Event
•
TcAdsClient.ConnectionStateChanged Event


TcAdsClient.AdsNotification Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Events [image] TcAdsClient.AdsNotification Event
TcAdsClient.AdsNotification Event
Occurs when the ADS device sends a ADS Notification to the client.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event AdsNotificationEventHandler AdsNotification
VB
Public Event AdsNotification As AdsNotificationEventHandler
Value
Type: TwinCAT.Ads.AdsNotificationEventHandler
Implements
IAdsNotifications.AdsNotification
Remarks
In most implementations, these notifications indicate changed values on the client target. These 'ADS notifications' will be received asynchronously from the target system and distributed via this AdsNotification event. IMPORTANT: The Default setting of the Synchronize property has changed to 'false' from Version 4.2.XX on. This has the effect that - by default - the notifications events AdsNotification and are not synchronized into the UI thread anymore. To re-enable the obsolete behavior for legacy applications set to 'true'.AdsNotificationExSynchronize
Examples
The following sample shows how to register/unregister for AdsNotifications (asynchronous change messages) via AddDeviceNotification(UInt32, UInt32, AdsStream, AdsTransMode, Int32, Int32, Object) and DeleteDeviceNotification(Int32)
Receive AdsNotifications
AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event handler
client.AdsNotification += Client_AdsNotification;

// Connect to target
client.Connect("1.2.3.4.5.6", 851);
int notificationHandle = 0;

try
{
// Notification to a DINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotification("MAIN.nCounter", readStream, AdsTransMode.OnChange, 200, 0, null);
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotification -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationEventArgs e)
{
int offset = (int)e.DataStream.Position;
int length = (int)e.DataStream.Length;

e.DataStream.Position = offset;
AdsBinaryReader reader = new AdsBinaryReader(e.DataStream);

// Read the Unmarshalled data
//byte[] data = reader.ReadBytes(length);

// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = reader.ReadUInt32();
}
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotificationEx
TcAdsClient.AdsNotificationError


TcAdsClient.AdsNotificationError Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Events [image] TcAdsClient.AdsNotificationError Event
TcAdsClient.AdsNotificationError Event
Occurs when a exception has occurred during notification management.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event AdsNotificationErrorEventHandler AdsNotificationError
VB
Public Event AdsNotificationError As AdsNotificationErrorEventHandler
Value
Type: TwinCAT.Ads.AdsNotificationErrorEventHandler
Implements
IAdsNotifications.AdsNotificationError
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationEx


TcAdsClient.AdsNotificationEx Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Events [image] TcAdsClient.AdsNotificationEx Event
TcAdsClient.AdsNotificationEx Event
Occurs when the ADS devices sends an (extended) notification to the client.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event AdsNotificationExEventHandler AdsNotificationEx
VB
Public Event AdsNotificationEx As AdsNotificationExEventHandler
Value
Type: TwinCAT.Ads.AdsNotificationExEventHandler
Implements
IAdsNotifications.AdsNotificationEx
Remarks
In most implementations, these notifications indicate changed values on the client target. These 'ADS notifications' will be received asynchronously from the target system and distributed via this AdsNotification event. IMPORTANT: The Default setting of the Synchronize property has changed to 'false' from Version 4.2.XX on. This has the effect that - by default - the notifications events and AdsNotificationEx are not synchronized into the UI thread anymore. To re-enable the obsolete behavior for legacy applications set to 'true'.AdsNotificationSynchronize
Examples
The following sample shows how to use AdsNotificationEx events.
Receive AdsNotifications
//AdsStream readStream = new AdsStream(sizeof(UInt32));

private void ReceiveNotifications()
{
using (TcAdsClient client = new TcAdsClient())
{
// Add the Notification event 'Ex' handler
client.AdsNotificationEx += Client_AdsNotification;

// Connect to target
client.Connect(AmsNetId.Local, 851);
int notificationHandle = 0;

try
{
// Notification to a ZDINT Type (UINT32)
// Check for change every 200 ms
notificationHandle = client.AddDeviceNotificationEx("MAIN.nCounter",AdsTransMode.OnChange, 200, 0, null,typeof(uint));
Thread.Sleep(5000); // Sleep the main thread to get some (asynchronous Notifications)
}
finally
{
// Unregister the Event / Handle
client.DeleteDeviceNotification(notificationHandle);
client.AdsNotificationEx -= Client_AdsNotification;
}
}
}

private void Client_AdsNotification(object sender, AdsNotificationExEventArgs e)
{
// Or here we know about UDINT type --> can be marshalled as UINT32
uint nCounter = (uint)e.Value;
}
Reference
TcAdsClient Class
TwinCAT.Ads Namespace
TcAdsClient.AddDeviceNotificationEx(Int64, Int64, AdsTransMode, Int32, Int32, Object, Type)
TcAdsClient.DeleteDeviceNotification(Int32)
TcAdsClient.AdsNotification
TcAdsClient.AdsNotificationError


TcAdsClient.AdsStateChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Events [image] TcAdsClient.AdsStateChanged Event
TcAdsClient.AdsStateChanged Event
Occurs when the ADS state changes.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event AdsStateChangedEventHandler AdsStateChanged
VB
Public Event AdsStateChanged As AdsStateChangedEventHandler
Value
Type: TwinCAT.Ads.AdsStateChangedEventHandler
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.AdsSymbolVersionChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Events [image] TcAdsClient.AdsSymbolVersionChanged Event
TcAdsClient.AdsSymbolVersionChanged Event
Occurs when the symbol version has been changed changes.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event EventHandler AdsSymbolVersionChanged
VB
Public Event AdsSymbolVersionChanged As EventHandler
Value
Type: System.EventHandler
Remarks
This is the case when the connected ADS server restarts. This invalidates all actual opened symbol handles. The SymbolVersion counter doesn't trigger, when an online change is made on the PLC (ports 801, ..., 851 ...)
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.AmsRouterNotification Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Events [image] TcAdsClient.AmsRouterNotification Event
TcAdsClient.AmsRouterNotification Event
Occurs when the state of the local Router has changed.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event AmsRouterNotificationEventHandler AmsRouterNotification
VB
Public Event AmsRouterNotification As AmsRouterNotificationEventHandler
Value
Type: TwinCAT.Ads.AmsRouterNotificationEventHandler
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsClient.ConnectionStateChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsClient Class [image] TcAdsClient Events [image] TcAdsClient.ConnectionStateChanged Event
TcAdsClient.ConnectionStateChanged Event
Occurs when the connection state has been changed.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event EventHandler<ConnectionStateChangedEventArgs> ConnectionStateChanged
VB
Public Event ConnectionStateChanged As EventHandler(Of ConnectionStateChangedEventArgs)
Value
Type: System.EventHandler.ConnectionStateChangedEventArgs.
Implements
IConnectionStateProvider.ConnectionStateChanged
Reference
TcAdsClient Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class
TcAdsSymbolInfo Class
The class TcAdsSymbolInfo represents a symbol loaded by an instance of the TcAdsSymbolInfoLoader class.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TcAdsSymbolInfo
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class TcAdsSymbolInfo : ITcAdsSymbol5,
ITcAdsSymbol4, ITcAdsSymbol3, ITcAdsSymbol2, ITcAdsSymbol, ITcAdsSymbolBrowser
VB
Public Class TcAdsSymbolInfo
Implements ITcAdsSymbol5, ITcAdsSymbol4, ITcAdsSymbol3, ITcAdsSymbol2,
ITcAdsSymbol, ITcAdsSymbolBrowser
The TcAdsSymbolInfo type exposes the following members.
Properties
Name | Description
ArrayDimensions | Gets the array dimensions.
ArrayInfos | Gets the collection of Array Infos.
Attributes | Gets the attributes of the ITcAdsSymbol
BitSize | Gets the size of this TcAdsSymbolInfo in bits.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes
Category | Gets the Data Type Category
Comment | Gets the comment behind the variable declaration.
ContextMask | Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications.
DataType | Gets the DataType object
DataTypeId | Data type of the symbol.
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only)
IndexGroup | Gets the index group of the symbol.
IndexOffset | Gets the index offset of the symbol.
IsBitType | Indicates if the BitValue flag is set for the symbol.
IsOversamplingArray | Gets a value indicating whether this instance is oversampling array.
IsPersistent | Indicates if the Persistent flag is set for the symbol.
IsReadOnly | Indicates if the ReadOnly flag is set for the symbol.
IsStatic | Indicates, that this symbol is a static symbol.
IsTcComInterfacePointer | Indicates if the TcComInterfacePointer flag is set for the symbol.
IsTypeGuid | Indicates if the TypeGuid flag is set for the symbol.
Name | Gets the name of the symbol.
Parent | Gets the parent of this symbol.
RpcMethods | Gets the RPC method descriptions
ShortName | Gets the name of the symbol (short form without prefixed names of the parents).
Size | Gets the size of the symbol.
SubSymbols | Gets the sub symbols of this symbol as a collection of TcAdsSymbolInfo objects.
TypeName | Gets the name of the symbol data type.
Methods
Name | Description
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsRecursive | Gets a value indicating whether this instance is recursive.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryGetPointerRef | Gets the Base data type of the pointer (the referenced type)
TryGetReference | Gets the referenced data type of the reference.
Operators
Name | Description
Equality | Implements the == operator.
Inequality | Implements the != operator.
Reference
TwinCAT.Ads Namespace
TwinCAT.Ads.ITcAdsSymbol5
TwinCAT.Ads.ITcAdsSymbolBrowser
Weiterführende Informationen
•
TcAdsSymbolInfo Properties
•
TcAdsSymbolInfo Methods
•
TcAdsSymbolInfo Operators


TcAdsSymbolInfo Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties
TcAdsSymbolInfo Properties
The TcAdsSymbolInfo type exposes the following members.
Properties
Name | Description
ArrayDimensions | Gets the array dimensions.
ArrayInfos | Gets the collection of Array Infos.
Attributes | Gets the attributes of the ITcAdsSymbol
BitSize | Gets the size of this TcAdsSymbolInfo in bits.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes
Category | Gets the Data Type Category
Comment | Gets the comment behind the variable declaration.
ContextMask | Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications.
DataType | Gets the DataType object
DataTypeId | Data type of the symbol.
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only)
IndexGroup | Gets the index group of the symbol.
IndexOffset | Gets the index offset of the symbol.
IsBitType | Indicates if the BitValue flag is set for the symbol.
IsOversamplingArray | Gets a value indicating whether this instance is oversampling array.
IsPersistent | Indicates if the Persistent flag is set for the symbol.
IsReadOnly | Indicates if the ReadOnly flag is set for the symbol.
IsStatic | Indicates, that this symbol is a static symbol.
IsTcComInterfacePointer | Indicates if the TcComInterfacePointer flag is set for the symbol.
IsTypeGuid | Indicates if the TypeGuid flag is set for the symbol.
Name | Gets the name of the symbol.
Parent | Gets the parent of this symbol.
RpcMethods | Gets the RPC method descriptions
ShortName | Gets the name of the symbol (short form without prefixed names of the parents).
Size | Gets the size of the symbol.
SubSymbols | Gets the sub symbols of this symbol as a collection of TcAdsSymbolInfo objects.
TypeName | Gets the name of the symbol data type.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsSymbolInfo.ArrayDimensions Property
•
TcAdsSymbolInfo.ArrayInfos Property
•
TcAdsSymbolInfo.Attributes Property
•
TcAdsSymbolInfo.BitSize Property
•
TcAdsSymbolInfo.ByteSize Property
•
TcAdsSymbolInfo.Category Property
•
TcAdsSymbolInfo.Comment Property
•
TcAdsSymbolInfo.ContextMask Property
•
TcAdsSymbolInfo.DataType Property
•
TcAdsSymbolInfo.DataTypeId Property
•
TcAdsSymbolInfo.HasRpcMethods Property
•
TcAdsSymbolInfo.IndexGroup Property
•
TcAdsSymbolInfo.IndexOffset Property
•
TcAdsSymbolInfo.IsBitType Property
•
TcAdsSymbolInfo.IsOversamplingArray Property
•
TcAdsSymbolInfo.IsPersistent Property
•
TcAdsSymbolInfo.IsReadOnly Property
•
TcAdsSymbolInfo.IsStatic Property
•
TcAdsSymbolInfo.IsTcComInterfacePointer Property
•
TcAdsSymbolInfo.IsTypeGuid Property
•
TcAdsSymbolInfo.Name Property
•
TcAdsSymbolInfo.Parent Property
•
TcAdsSymbolInfo.RpcMethods Property
•
TcAdsSymbolInfo.ShortName Property
•
TcAdsSymbolInfo.Size Property
•
TcAdsSymbolInfo.SubSymbols Property
•
TcAdsSymbolInfo.TypeName Property


TcAdsSymbolInfo.ArrayDimensions Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.ArrayDimensions Property
TcAdsSymbolInfo.ArrayDimensions Property
Gets the array dimensions.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ArrayDimensions { get; }
VB
Public ReadOnly Property ArrayDimensions As Integer
Get
Property Value
Type: Int32
The array dimensions.
Implements
ITcAdsSymbol3.ArrayDimensions
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.ArrayInfos Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.ArrayInfos Property
TcAdsSymbolInfo.ArrayInfos Property
Gets the collection of Array Infos.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsDatatypeArrayInfo[] ArrayInfos { get; }
VB
Public ReadOnly Property ArrayInfos As AdsDatatypeArrayInfo()
Get
Property Value
Type: .AdsDatatypeArrayInfo.
The array infos.
Implements
ITcAdsSymbol3.ArrayInfos
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.Attributes Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.Attributes Property
TcAdsSymbolInfo.Attributes Property
Gets the attributes of the ITcAdsSymbol
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyTypeAttributeCollection Attributes { get; }
VB
Public ReadOnly Property Attributes As ReadOnlyTypeAttributeCollection
Get
Property Value
Type: ReadOnlyTypeAttributeCollection
The attributes or NULL if no Attributes are defined.
Implements
ITcAdsSymbol4.Attributes
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.BitSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.BitSize Property
TcAdsSymbolInfo.BitSize Property
Gets the size of this TcAdsSymbolInfo in bits.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int BitSize { get; }
VB
Public ReadOnly Property BitSize As Integer
Get
Property Value
Type: Int32
The size of the bit.
Implements
ITcAdsSymbol4.BitSize
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.ByteSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.ByteSize Property
TcAdsSymbolInfo.ByteSize Property
Gets the (aligned) size of of the Type/Instance in Bytes
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ByteSize { get; }
VB
Public ReadOnly Property ByteSize As Integer
Get
Property Value
Type: Int32
The size of the byte.
Implements
ITcAdsSymbol4.ByteSize
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.Category Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.Category Property
TcAdsSymbolInfo.Category Property
Gets the Data Type Category
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeCategory Category { get; }
VB
Public ReadOnly Property Category As DataTypeCategory
Get
Property Value
Type: DataTypeCategory
The category.
Implements
ITcAdsSymbol4.Category
Exceptions
Exception | Condition
NotImplementedException |
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.Comment Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.Comment Property
TcAdsSymbolInfo.Comment Property
Gets the comment behind the variable declaration.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Comment { get; }
VB
Public ReadOnly Property Comment As String
Get
Property Value
Type: String
Comment behind the variable declaration.
Implements
ITcAdsSymbol.Comment
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.ContextMask Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.ContextMask Property
TcAdsSymbolInfo.ContextMask Property
Gets the ContextMask of the symbol, indicating the task the variable belongs to. If ContextMask is not zero use CyclicInContext or OnChangeInContext to add notifications.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ContextMask { get; }
VB
Public ReadOnly Property ContextMask As Integer
Get
Property Value
Type: Int32
The context mask.
Implements
ITcAdsSymbol2.ContextMask
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.DataType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.DataType Property
TcAdsSymbolInfo.DataType Property
Gets the DataType object
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ITcAdsDataType DataType { get; }
VB
Public ReadOnly Property DataType As ITcAdsDataType
Get
Property Value
Type: ITcAdsDataType
The dataType if available, or NULL.
Implements
ITcAdsSymbol5.DataType
Remarks
Tries to resolve the DataType if not cached.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.DataTypeId Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.DataTypeId Property
TcAdsSymbolInfo.DataTypeId Property
Data type of the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsDatatypeId DataTypeId { get; }
VB
Public ReadOnly Property DataTypeId As AdsDatatypeId
Get
Property Value
Type: AdsDatatypeId
Data type of the symbol.
Implements
ITcAdsSymbol5.DataTypeId
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.HasRpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.HasRpcMethods Property
TcAdsSymbolInfo.HasRpcMethods Property
Gets a value indicating whether this instance has RPC methods (Struct types only)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool HasRpcMethods { get; }
VB
Public ReadOnly Property HasRpcMethods As Boolean
Get
Property Value
Type: Boolean
true if this instance has RPC methods; otherwise, false.
Implements
ITcAdsSymbol4.HasRpcMethods
Remarks
The DataType (Structure) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods, otherwise RpcMethods are not passed through to the ADS symbolic information.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.IndexGroup Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.IndexGroup Property
TcAdsSymbolInfo.IndexGroup Property
Gets the index group of the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public long IndexGroup { get; }
VB
Public ReadOnly Property IndexGroup As Long
Get
Property Value
Type: Int64
Index group of the symbol.
Implements
ITcAdsSymbol.IndexGroup
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.IndexOffset Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.IndexOffset Property
TcAdsSymbolInfo.IndexOffset Property
Gets the index offset of the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public long IndexOffset { get; }
VB
Public ReadOnly Property IndexOffset As Long
Get
Property Value
Type: Int64
Index offset of the symbol.
Implements
ITcAdsSymbol.IndexOffset
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.IsBitType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.IsBitType Property
TcAdsSymbolInfo.IsBitType Property
Indicates if the BitValue flag is set for the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsBitType { get; }
VB
Public ReadOnly Property IsBitType As Boolean
Get
Property Value
Type: Boolean
true if is BitValue, otherwise false.
Implements
ITcAdsSymbol2.IsBitType
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.IsOversamplingArray Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.IsOversamplingArray Property
TcAdsSymbolInfo.IsOversamplingArray Property
Gets a value indicating whether this instance is oversampling array.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsOversamplingArray { get; }
VB
Public ReadOnly Property IsOversamplingArray As Boolean
Get
Property Value
Type: Boolean
true if this instance is oversampling array; otherwise, false.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.IsPersistent Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.IsPersistent Property
TcAdsSymbolInfo.IsPersistent Property
Indicates if the Persistent flag is set for the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsPersistent { get; }
VB
Public ReadOnly Property IsPersistent As Boolean
Get
Property Value
Type: Boolean
true if persistent, otherwise false.
Implements
ITcAdsSymbol2.IsPersistent
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.IsReadOnly Property
TcAdsSymbolInfo.IsReadOnly Property
Indicates if the ReadOnly flag is set for the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if ReadOnly, otherwise false.
Implements
ITcAdsSymbol2.IsReadOnly
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.IsStatic Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.IsStatic Property
TcAdsSymbolInfo.IsStatic Property
Indicates, that this symbol is a static symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsStatic { get; }
VB
Public ReadOnly Property IsStatic As Boolean
Get
Property Value
Type: Boolean
Static indicator.
Implements
ITcAdsSymbol5.IsStatic
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.IsTcComInterfacePointer Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.IsTcComInterfacePointer Property
TcAdsSymbolInfo.IsTcComInterfacePointer Property
Indicates if the TcComInterfacePointer flag is set for the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsTcComInterfacePointer { get; }
VB
Public ReadOnly Property IsTcComInterfacePointer As Boolean
Get
Property Value
Type: Boolean
treu if is TcComInterfacePointer, otherwise false.
Implements
ITcAdsSymbol2.IsTcComInterfacePointer
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.IsTypeGuid Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.IsTypeGuid Property
TcAdsSymbolInfo.IsTypeGuid Property
Indicates if the TypeGuid flag is set for the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsTypeGuid { get; }
VB
Public ReadOnly Property IsTypeGuid As Boolean
Get
Property Value
Type: Boolean
true if is TypeGuid, otherwise false.
Implements
ITcAdsSymbol2.IsTypeGuid
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.Name Property
TcAdsSymbolInfo.Name Property
Gets the name of the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Name { get; }
VB
Public ReadOnly Property Name As String
Get
Property Value
Type: String
Name of the symbol.
Implements
ITcAdsSymbol.Name
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.Parent Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.Parent Property
TcAdsSymbolInfo.Parent Property
Gets the parent of this symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TcAdsSymbolInfo Parent { get; }
VB
Public ReadOnly Property Parent As TcAdsSymbolInfo
Get
Property Value
Type: TcAdsSymbolInfo
Parent of this symbol
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.RpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.RpcMethods Property
TcAdsSymbolInfo.RpcMethods Property
Gets the RPC method descriptions
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyRpcMethodCollection RpcMethods { get; }
VB
Public ReadOnly Property RpcMethods As ReadOnlyRpcMethodCollection
Get
Property Value
Type: ReadOnlyRpcMethodCollection
The RPC methods.
Implements
ITcAdsSymbol4.RpcMethods
Remarks
The DataType (Structure) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods, otherwise RpcMethods are not passed through to the ADS symbolic information.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.ShortName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.ShortName Property
TcAdsSymbolInfo.ShortName Property
Gets the name of the symbol (short form without prefixed names of the parents).
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ShortName { get; }
VB
Public ReadOnly Property ShortName As String
Get
Property Value
Type: String
Full name of the symbol.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.Size Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.Size Property
TcAdsSymbolInfo.Size Property
Gets the size of the symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Size { get; }
VB
Public ReadOnly Property Size As Integer
Get
Property Value
Type: Int32
Size of the symbol.
Implements
ITcAdsSymbol.Size
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.SubSymbols Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.SubSymbols Property
TcAdsSymbolInfo.SubSymbols Property
Gets the sub symbols of this symbol as a collection of TcAdsSymbolInfo objects.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TcAdsSymbolInfoCollection SubSymbols { get; }
VB
Public ReadOnly Property SubSymbols As TcAdsSymbolInfoCollection
Get
Property Value
Type: TcAdsSymbolInfoCollection
The SubSymbol collection.
Implements
ITcAdsSymbolBrowser.SubSymbols
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.TypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Properties [image] TcAdsSymbolInfo.TypeName Property
TcAdsSymbolInfo.TypeName Property
Gets the name of the symbol data type.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string TypeName { get; }
VB
Public ReadOnly Property TypeName As String
Get
Property Value
Type: String
Name of the symbol data type.
Implements
ITcAdsSymbol5.TypeName
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Methods
TcAdsSymbolInfo Methods
The TcAdsSymbolInfo type exposes the following members.
Methods
Name | Description
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsRecursive | Gets a value indicating whether this instance is recursive.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryGetPointerRef | Gets the Base data type of the pointer (the referenced type)
TryGetReference | Gets the referenced data type of the reference.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsSymbolInfo.Equals Method
•
TcAdsSymbolInfo.GetHashCode Method
•
TcAdsSymbolInfo.IsRecursive Method
•
TcAdsSymbolInfo.ToString Method
•
TcAdsSymbolInfo.TryGetPointerRef Method
•
TcAdsSymbolInfo.TryGetReference Method


TcAdsSymbolInfo.Equals Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Methods [image] TcAdsSymbolInfo.Equals Method
TcAdsSymbolInfo.Equals Method
Equals
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool Equals(
Object obj
)
VB
Public Overrides Function Equals (
obj As Object
) As Boolean
Parameters
obj
Type: System.Object
The object to compare with the current object.
Return Value
Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.GetHashCode Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Methods [image] TcAdsSymbolInfo.GetHashCode Method
TcAdsSymbolInfo.GetHashCode Method
Gets the HashCode of the Address
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override int GetHashCode()
VB
Public Overrides Function GetHashCode As Integer
Return Value
Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.IsRecursive Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Methods [image] TcAdsSymbolInfo.IsRecursive Method
TcAdsSymbolInfo.IsRecursive Method
Gets a value indicating whether this instance is recursive.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsRecursive(
IEnumerable<ITcAdsSymbol5> parents
)
VB
Public Function IsRecursive (
parents As IEnumerable(Of ITcAdsSymbol5)
) As Boolean
Parameters
parents
Type: System.Collections.Generic.IEnumerable.ITcAdsSymbol5.
The parents.
Field Value
Type: Boolean
true if this instance is recursive; otherwise, false.
Return Value
Type: Boolean
true if the specified parents is recursive; otherwise, false.
Implements
ITcAdsSymbol5.IsRecursive(IEnumerable.ITcAdsSymbol5.)
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Methods [image] TcAdsSymbolInfo.ToString Method
TcAdsSymbolInfo.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.TryGetPointerRef Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Methods [image] TcAdsSymbolInfo.TryGetPointerRef Method
TcAdsSymbolInfo.TryGetPointerRef Method
Gets the Base data type of the pointer (the referenced type)
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetPointerRef(
out string referencedType
)
VB
Public Function TryGetPointerRef (
<OutAttribute> ByRef referencedType As String
) As Boolean
Parameters
referencedType
Type: System.String.
Type of the reference.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.TryGetReference Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Methods [image] TcAdsSymbolInfo.TryGetReference Method
TcAdsSymbolInfo.TryGetReference Method
Gets the referenced data type of the reference.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetReference(
out string referencedType
)
VB
Public Function TryGetReference (
<OutAttribute> ByRef referencedType As String
) As Boolean
Parameters
referencedType
Type: System.String.
Type of the referenced.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo Operators

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Operators
TcAdsSymbolInfo Operators
The TcAdsSymbolInfo type exposes the following members.
Operators
Name | Description
Equality | Implements the == operator.
Inequality | Implements the != operator.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsSymbolInfo.Equality Operator
•
TcAdsSymbolInfo.Inequality Operator


TcAdsSymbolInfo.Equality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Operators [image] TcAdsSymbolInfo.Equality Operator
TcAdsSymbolInfo.Equality Operator
Implements the == operator.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator ==(
TcAdsSymbolInfo s1,
TcAdsSymbolInfo s2
)
VB
Public Shared Operator = (
s1 As TcAdsSymbolInfo,
s2 As TcAdsSymbolInfo
) As Boolean
Parameters
s1 | Type: TwinCAT.Ads.TcAdsSymbolInfo Symbol 1.
s2 | Type: TwinCAT.Ads.TcAdsSymbolInfo Symbol 2.
Return Value
Type: Boolean
The result of the operator.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfo.Inequality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfo Class [image] TcAdsSymbolInfo Operators [image] TcAdsSymbolInfo.Inequality Operator
TcAdsSymbolInfo.Inequality Operator
Implements the != operator.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator !=(
TcAdsSymbolInfo s1,
TcAdsSymbolInfo s2
)
VB
Public Shared Operator <> (
s1 As TcAdsSymbolInfo,
s2 As TcAdsSymbolInfo
) As Boolean
Parameters
s1 | Type: TwinCAT.Ads.TcAdsSymbolInfo The symbol 1.
s2 | Type: TwinCAT.Ads.TcAdsSymbolInfo The symbol 2.
Return Value
Type: Boolean
The result of the operator.
Reference
TcAdsSymbolInfo Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class
TcAdsSymbolInfoCollection Class
Represents a collection of TcAdsSymbolInfo objects.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TcAdsSymbolInfoCollection
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class TcAdsSymbolInfoCollection : ICollection,
IEnumerable
VB
Public Class TcAdsSymbolInfoCollection
Implements ICollection, IEnumerable
The TcAdsSymbolInfoCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Methods
Name | Description
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that can iterate through the symbols (TcAdsSymbolInfo) in this collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetSymbol(Int32) | Gets the Symbol by index
GetSymbol(String) | Gets the symbol by name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsSymbolInfoCollection Properties
•
TcAdsSymbolInfoCollection Methods


TcAdsSymbolInfoCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class [image] TcAdsSymbolInfoCollection Properties
TcAdsSymbolInfoCollection Properties
The TcAdsSymbolInfoCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Reference
TcAdsSymbolInfoCollection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsSymbolInfoCollection.Count Property
•
TcAdsSymbolInfoCollection.IsSynchronized Property
•
TcAdsSymbolInfoCollection.Item Property
•
TcAdsSymbolInfoCollection.SyncRoot Property


TcAdsSymbolInfoCollection.Count Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class [image] TcAdsSymbolInfoCollection Properties [image] TcAdsSymbolInfoCollection.Count Property
TcAdsSymbolInfoCollection.Count Property
Gets the number of elements contained in the collection.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual int Count { get; }
VB
Public Overridable ReadOnly Property Count As Integer
Get
Property Value
Type: Int32
Implements
ICollection.Count
Reference
TcAdsSymbolInfoCollection Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoCollection.IsSynchronized Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class [image] TcAdsSymbolInfoCollection Properties [image] TcAdsSymbolInfoCollection.IsSynchronized Property
TcAdsSymbolInfoCollection.IsSynchronized Property
Gets a value indicating whether access to the collection is synchronized (thread-safe).
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual bool IsSynchronized { get; }
VB
Public Overridable ReadOnly Property IsSynchronized As Boolean
Get
Property Value
Type: Boolean
Implements
ICollection.IsSynchronized
Reference
TcAdsSymbolInfoCollection Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoCollection.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class [image] TcAdsSymbolInfoCollection Properties [image] TcAdsSymbolInfoCollection.Item Property
TcAdsSymbolInfoCollection.Item Property
Gets the element at the specified index.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TcAdsSymbolInfo this[
int index
] { get; }
VB
Public ReadOnly Default Property Item (
index As Integer
) As TcAdsSymbolInfo
Get
Parameters
index
Type: System.Int32
Property Value
Type: TcAdsSymbolInfo
Reference
TcAdsSymbolInfoCollection Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoCollection.SyncRoot Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class [image] TcAdsSymbolInfoCollection Properties [image] TcAdsSymbolInfoCollection.SyncRoot Property
TcAdsSymbolInfoCollection.SyncRoot Property
Gets an object that can be used to synchronize access to the collection.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual Object SyncRoot { get; }
VB
Public Overridable ReadOnly Property SyncRoot As Object
Get
Property Value
Type: Object
Implements
ICollection.SyncRoot
Reference
TcAdsSymbolInfoCollection Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class [image] TcAdsSymbolInfoCollection Methods
TcAdsSymbolInfoCollection Methods
The TcAdsSymbolInfoCollection type exposes the following members.
Methods
Name | Description
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that can iterate through the symbols (TcAdsSymbolInfo) in this collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetSymbol(Int32) | Gets the Symbol by index
GetSymbol(String) | Gets the symbol by name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TcAdsSymbolInfoCollection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsSymbolInfoCollection.CopyTo Method
•
TcAdsSymbolInfoCollection.GetEnumerator Method
•
TcAdsSymbolInfoCollection.GetSymbol Method


TcAdsSymbolInfoCollection.CopyTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class [image] TcAdsSymbolInfoCollection Methods [image] TcAdsSymbolInfoCollection.CopyTo Method
TcAdsSymbolInfoCollection.CopyTo Method
Copies the elements of the collection to an Array, starting at a particular Array index.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual void CopyTo(
Array array,
int index
)
VB
Public Overridable Sub CopyTo (
array As Array,
index As Integer
)
Parameters
array | Type: System.Array The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index | Type: System.Int32 The zero-based index in array at which copying begins.
Implements
ICollection.CopyTo(Array, Int32)
Reference
TcAdsSymbolInfoCollection Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoCollection.GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class [image] TcAdsSymbolInfoCollection Methods [image] TcAdsSymbolInfoCollection.GetEnumerator Method
TcAdsSymbolInfoCollection.GetEnumerator Method
Returns an enumerator that can iterate through the symbols (TcAdsSymbolInfo) in this collection.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual IEnumerator GetEnumerator()
VB
Public Overridable Function GetEnumerator As IEnumerator
Return Value
Type: IEnumerator
An IEnumerator that can be used to iterate through all symbols (TcAdsSymbolInfo) in this collection.
Implements
IEnumerable.GetEnumerator.
Reference
TcAdsSymbolInfoCollection Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoCollection.GetSymbol Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class [image] TcAdsSymbolInfoCollection Methods [image] TcAdsSymbolInfoCollection.GetSymbol Method
TcAdsSymbolInfoCollection.GetSymbol Method
Overload List
Name | Description
GetSymbol(Int32) | Gets the Symbol by index
GetSymbol(String) | Gets the symbol by name.
Reference
TcAdsSymbolInfoCollection Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsSymbolInfoCollection.GetSymbol Method (Int32)
•
TcAdsSymbolInfoCollection.GetSymbol Method (String)


TcAdsSymbolInfoCollection.GetSymbol Method (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class [image] TcAdsSymbolInfoCollection Methods [image] TcAdsSymbolInfoCollection.GetSymbol Method [image] TcAdsSymbolInfoCollection.GetSymbol Method (Int32)
TcAdsSymbolInfoCollection.GetSymbol Method (Int32)
Gets the Symbol by index
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TcAdsSymbolInfo GetSymbol(
int index
)
VB
Public Function GetSymbol (
index As Integer
) As TcAdsSymbolInfo
Parameters
index
Type: System.Int32
The index.
Return Value
Type: TcAdsSymbolInfo
TcAdsSymbolInfo if found, or NULL
Reference
TcAdsSymbolInfoCollection Class
GetSymbol Overload
TwinCAT.Ads Namespace


TcAdsSymbolInfoCollection.GetSymbol Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoCollection Class [image] TcAdsSymbolInfoCollection Methods [image] TcAdsSymbolInfoCollection.GetSymbol Method [image] TcAdsSymbolInfoCollection.GetSymbol Method (String)
TcAdsSymbolInfoCollection.GetSymbol Method (String)
Gets the symbol by name.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TcAdsSymbolInfo GetSymbol(
string name
)
VB
Public Function GetSymbol (
name As String
) As TcAdsSymbolInfo
Parameters
name
Type: System.String
The name.
Return Value
Type: TcAdsSymbolInfo
TcAdsSymbolInfo.
Remarks
Only located Symbols will be returned.
Reference
TcAdsSymbolInfoCollection Class
GetSymbol Overload
TwinCAT.Ads Namespace


TcAdsSymbolInfoLoader Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoLoader Class
TcAdsSymbolInfoLoader Class
The class TcAdsSymbolInfoLoader is responsible for downloading the list of declared variables and the data types from an ADS Server.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TcAdsSymbolInfoLoader
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class TcAdsSymbolInfoLoader : IEnumerable
VB
Public Class TcAdsSymbolInfoLoader
Implements IEnumerable
The TcAdsSymbolInfoLoader type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FindSymbol | Call this method to find a symbol in the list.
GetDataTypes | Gets the data types.
GetEnumerator | Returns an enumerator that can iterate through all symbols.
GetFirstSymbol | Call this method to get the first symbol.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetSymbolCount | Call this method to get the number of declared symbols.
GetSymbols | Loads the declared symbols from the ADS device and returns them as a collection of TcAdsSymbolInfo objects.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Events
Name | Description
TypeResolveError | Occurs when a typename cannot be resolved.
TypesGenerated | Occurs when new types are generated
Reference
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsSymbolInfoLoader Methods
•
TcAdsSymbolInfoLoader Events


TcAdsSymbolInfoLoader Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoLoader Class [image] TcAdsSymbolInfoLoader Methods
TcAdsSymbolInfoLoader Methods
The TcAdsSymbolInfoLoader type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FindSymbol | Call this method to find a symbol in the list.
GetDataTypes | Gets the data types.
GetEnumerator | Returns an enumerator that can iterate through all symbols.
GetFirstSymbol | Call this method to get the first symbol.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetSymbolCount | Call this method to get the number of declared symbols.
GetSymbols | Loads the declared symbols from the ADS device and returns them as a collection of TcAdsSymbolInfo objects.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TcAdsSymbolInfoLoader Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsSymbolInfoLoader.FindSymbol Method
•
TcAdsSymbolInfoLoader.GetDataTypes Method
•
TcAdsSymbolInfoLoader.GetEnumerator Method
•
TcAdsSymbolInfoLoader.GetFirstSymbol Method
•
TcAdsSymbolInfoLoader.GetSymbolCount Method
•
TcAdsSymbolInfoLoader.GetSymbols Method


TcAdsSymbolInfoLoader.FindSymbol Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoLoader Class [image] TcAdsSymbolInfoLoader Methods [image] TcAdsSymbolInfoLoader.FindSymbol Method
TcAdsSymbolInfoLoader.FindSymbol Method
Call this method to find a symbol in the list.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TcAdsSymbolInfo FindSymbol(
string name
)
VB
Public Function FindSymbol (
name As String
) As TcAdsSymbolInfo
Parameters
name
Type: System.String
Name of the symbol
Return Value
Type: TcAdsSymbolInfo
TcAdsSymbolInfo.
Remarks
If no symbols have been loaded before, the symbols are loaded from the server, regardless of the parameter forceReload.
Note about the PLC: Please attend to the PLC Control that the 'Symbol-Download' under Project / Options / TwinCAT is activated. For further information please see the manual TwinCAT PLC Control.
Note about NC: The Symbol download has to be activated at each axis. This can de done in the configuration dialog of the axis under ‚General'. The field ‚Create Symbols' has to be marked. See manual of the TwinCAT System Manager.
Reference
TcAdsSymbolInfoLoader Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoLoader.GetDataTypes Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoLoader Class [image] TcAdsSymbolInfoLoader Methods [image] TcAdsSymbolInfoLoader.GetDataTypes Method
TcAdsSymbolInfoLoader.GetDataTypes Method
Gets the data types.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyTcAdsDataTypeCollection GetDataTypes(
bool forceReload
)
VB
Public Function GetDataTypes (
forceReload As Boolean
) As ReadOnlyTcAdsDataTypeCollection
Parameters
forceReload
Type: System.Boolean
if set to true [force reload].
Return Value
Type: ReadOnlyTcAdsDataTypeCollection
ReadOnlyTcAdsDataTypeCollection.
Reference
TcAdsSymbolInfoLoader Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoLoader.GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoLoader Class [image] TcAdsSymbolInfoLoader Methods [image] TcAdsSymbolInfoLoader.GetEnumerator Method
TcAdsSymbolInfoLoader.GetEnumerator Method
Returns an enumerator that can iterate through all symbols.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual IEnumerator GetEnumerator()
VB
Public Overridable Function GetEnumerator As IEnumerator
Return Value
Type: IEnumerator
An IEnumerator that can be used to iterate through all symbols.
Implements
IEnumerable.GetEnumerator.
Reference
TcAdsSymbolInfoLoader Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoLoader.GetFirstSymbol Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoLoader Class [image] TcAdsSymbolInfoLoader Methods [image] TcAdsSymbolInfoLoader.GetFirstSymbol Method
TcAdsSymbolInfoLoader.GetFirstSymbol Method
Call this method to get the first symbol.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TcAdsSymbolInfo GetFirstSymbol(
bool forceReload
)
VB
Public Function GetFirstSymbol (
forceReload As Boolean
) As TcAdsSymbolInfo
Parameters
forceReload
Type: System.Boolean
True, if a (new) loading of the symbol information from the server is required.
Return Value
Type: TcAdsSymbolInfo
Returns the first symbol or null if no symbols are available.
Remarks
If no symbols have been loaded before, the symbols are loaded from the server, regardless of the parameter forceReload. Note about the PLC: Please attend to the PLC Control that the 'Symbol-Download' under Project / Options / TwinCAT is activated. For further information please see the manual TwinCAT PLC Control. Note about NC: The Symbol download has to be activated at each axis. This can de done in the configuration dialog of the axis under ‚General'. The field ‚Create Symbols' has to be marked. See manual of the TwinCAT System Manager.
Reference
TcAdsSymbolInfoLoader Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoLoader.GetSymbolCount Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoLoader Class [image] TcAdsSymbolInfoLoader Methods [image] TcAdsSymbolInfoLoader.GetSymbolCount Method
TcAdsSymbolInfoLoader.GetSymbolCount Method
Call this method to get the number of declared symbols.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int GetSymbolCount(
bool forceReload
)
VB
Public Function GetSymbolCount (
forceReload As Boolean
) As Integer
Parameters
forceReload
Type: System.Boolean
True, if a (new) loading of the symbol information from the server is required.
Return Value
Type: Int32
Returns the number of symbols.
Remarks
If no symbols have been loaded before, the symbols are loaded from the server, regardless of the parameter forceReload. Note about the PLC: Please attend to the PLC Control that the 'Symbol-Download' under Project / Options / TwinCAT is activated. For further information please see the manual TwinCAT PLC Control. Note about NC: The Symbol download has to be activated at each axis. This can de done in the configuration dialog of the axis under ‚General'. The field ‚Create Symbols' has to be marked. See manual of the TwinCAT System Manager.
Reference
TcAdsSymbolInfoLoader Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoLoader.GetSymbols Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoLoader Class [image] TcAdsSymbolInfoLoader Methods [image] TcAdsSymbolInfoLoader.GetSymbols Method
TcAdsSymbolInfoLoader.GetSymbols Method
Loads the declared symbols from the ADS device and returns them as a collection of TcAdsSymbolInfo objects.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TcAdsSymbolInfoCollection GetSymbols(
bool forceReload
)
VB
Public Function GetSymbols (
forceReload As Boolean
) As TcAdsSymbolInfoCollection
Parameters
forceReload
Type: System.Boolean
True, if a (new) loading of the symbol information from the server is required.
Return Value
Type: TcAdsSymbolInfoCollection
A collection of TcAdsSymbolInfo objects
Remarks
If no symbols have been loaded before, the symbols are loaded from the server, regardless of the parameter forceReload.
Note about the PLC: Please attend to the PLC Control that the 'Symbol-Download' under Project / Options / TwinCAT is activated. For further information please see the manual TwinCAT PLC Control.
Note about NC: The Symbol download has to be activated at each axis. This can de done in the configuration dialog of the axis under ‚General'. The field ‚Create Symbols' has to be marked. See manual of the TwinCAT System Manager.
Reference
TcAdsSymbolInfoLoader Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoLoader Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoLoader Class [image] TcAdsSymbolInfoLoader Events
TcAdsSymbolInfoLoader Events
The TcAdsSymbolInfoLoader type exposes the following members.
Events
Name | Description
TypeResolveError | Occurs when a typename cannot be resolved.
TypesGenerated | Occurs when new types are generated
Reference
TcAdsSymbolInfoLoader Class
TwinCAT.Ads Namespace
Weiterführende Informationen
•
TcAdsSymbolInfoLoader.TypeResolveError Event
•
TcAdsSymbolInfoLoader.TypesGenerated Event


TcAdsSymbolInfoLoader.TypeResolveError Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoLoader Class [image] TcAdsSymbolInfoLoader Events [image] TcAdsSymbolInfoLoader.TypeResolveError Event
TcAdsSymbolInfoLoader.TypeResolveError Event
Occurs when a typename cannot be resolved.
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event EventHandler<DataTypeNameEventArgs> TypeResolveError
VB
Public Event TypeResolveError As EventHandler(Of DataTypeNameEventArgs)
Value
Type: System.EventHandler.DataTypeNameEventArgs.
Reference
TcAdsSymbolInfoLoader Class
TwinCAT.Ads Namespace


TcAdsSymbolInfoLoader.TypesGenerated Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TcAdsSymbolInfoLoader Class [image] TcAdsSymbolInfoLoader Events [image] TcAdsSymbolInfoLoader.TypesGenerated Event
TcAdsSymbolInfoLoader.TypesGenerated Event
Occurs when new types are generated
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event EventHandler<DataTypeEventArgs> TypesGenerated
VB
Public Event TypesGenerated As EventHandler(Of DataTypeEventArgs)
Value
Type: System.EventHandler.DataTypeEventArgs.
Reference
TcAdsSymbolInfoLoader Class
TwinCAT.Ads Namespace


TransportProtocol Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.Ads Namespace [image] TransportProtocol Enumeration
TransportProtocol Enumeration
Enum ADS TransportProtocol
Namespace: TwinCAT.Ads
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[FlagsAttribute]
public enum TransportProtocol
VB
<FlagsAttribute>
Public Enumeration TransportProtocol
Members
Member name | Value | Description
None | 0 | None / Uninitialized
Router | 1 | ADS via Router
TcpIp | 2 | ADS via TCP/IP (without router)
All | 3 | Indicates that Router and TcpIp are appropriate (for establishing connections)
Reference
TwinCAT.Ads Namespace


TwinCAT.Ads.Reactive Namespace

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace
TwinCAT.Ads.Reactive Namespace
Reactive Extensions for the ADS Client. All types within are contained in the ADS companion package "Beckhoff.TwinCAT.Ads.Reactive" which must be referenced seperately. https://www.nuget.org/packages/Beckhoff.TwinCAT.Ads.Reactive/
Classes
Class | Description
AdsClientExtensions | Extension class for TcAdsClient respective IAdsConnection to provide reactive ADS extensions.
AnyTypeExtensions | Extension class for TcAdsClient respective IAdsConnection to provide reactive ADS extensions (accessing symbol value sequences with the ANY_TYPE concept)
Notification | Provides data for AdsNotificationEvent of the class
NotificationBase | Base class for Notifications
NotificationEx | Provides data for AdsNotificationExEvent of the class
SymbolNotification | Provides data for AdsNotificationEvent of the class
ValueSymbolExtensions | Extension class for TcAdsClient respective IAdsConnection to provide reactive ADS extensions for accessing symbols that are loaded by the IAdsSymbolLoaderFactory
Weiterführende Informationen
•
AdsClientExtensions Class
•
AnyTypeExtensions Class
•
Notification Class
•
NotificationBase Class
•
NotificationEx Class
•
SymbolNotification Class
•
ValueSymbolExtensions Class


AdsClientExtensions Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AdsClientExtensions Class
AdsClientExtensions Class
Extension class for TcAdsClient respective IAdsConnection to provide reactive ADS extensions.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.Reactive.AdsClientExtensions
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static class AdsClientExtensions
VB
<ExtensionAttribute>
Public NotInheritable Class AdsClientExtensions
The AdsClientExtensions type exposes the following members.
Methods
Name | Description
PollAdsState(IAdsConnection, IObservable.Unit.) | Gets an observable sequence of AdsStates via Polling.
PollAdsState(IAdsConnection, TimeSpan) | Gets an observable sequence of AdsStates via Polling.
WhenAdsStateChanges | Gets an observable sequence of AdsStates.
WhenNotification(IAdsConnection, ISymbol) | Gets an observable sequence of Notifications.
WhenNotification(IAdsConnection, ISymbolCollection) | Gets an observable sequence of Notification objects.
WhenNotification(IAdsConnection, ISymbol, NotificationSettings) | Gets an observable sequence of Notifications.
WhenNotification(IAdsConnection, ISymbolCollection, NotificationSettings) | Gets an observable sequence of Notification objects.
Remarks
Reactive Extensions (Rx) are a library for composing asynchronous and event-based programs using observable sequences and LINQ-style query operators. Using Rx, developers represent asynchronous data streams with Observables, query asynchronous data streams using LINQ operators, and parameterize the concurrency in the asynchronous data streams using Schedulers. Simply put, Rx = Observables + LINQ + Schedulers. The ADS reactive extensions are build on top of this library to enable ADS Symbol and State Observables, seamlessly bound to the reactive extensions. To use the ADS reactive extensions the TwinCAT.Ads.Reactive Nuget package (or the included TwinCAT.Ads.Reactive.dll) must be referenced. (Beckhoff.TwinCAT.Ads.Reactive package on Nuget).
Examples
The following sample shows how observe Value changed Notifications with the reactive AdsClientExtensions
Observe changing ADS Symbols with reactive extensions.
// To Test the Observer run a project on the local PLC System (Port 851)

using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);

int eventCount = 1;

// Reactive Notification Handler
var valueObserver = Observer.Create<SymbolNotification>(not =>
{
Console.WriteLine(string.Format("{0} {1:u} {2} = '{3}' ({4})", eventCount++, not.TimeStamp, not.Symbol.InstancePath, not.Value, not.Symbol.DataType));
}
);

// Collect the symbols that are registered as Notification sources for their changed values.

SymbolCollection notificationSymbols = new SymbolCollection();
IArrayInstance taskInfo = (IArrayInstance)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo"];

foreach(ISymbol element in taskInfo.Elements)
{
ISymbol cycleCount = element.SubSymbols["CycleCount"];
ISymbol lastExecTime = element.SubSymbols["LastExecTime"];

notificationSymbols.Add(cycleCount);
notificationSymbols.Add(lastExecTime);
}

// Create a subscription for the first 200 Notifications on Symbol Value changes.
IDisposable subscription = client.WhenNotification(notificationSymbols,NotificationSettings.Default).Take(200).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Examples
The following sample shows how observe AdsState changed Notifications with the reactive AdsClientExtensions
Observe changing ADS states with reactive extensions.
// To Test the observer, Start/Stop the local PLC

using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.DefaultDynamic);

// Reactive Notification Handler
var valueObserver = Observer.Create<IList<AdsState>>(not =>
{
AdsState oldValue = not[0];
AdsState newValue = not[1];

Console.WriteLine(string.Format("Changed ADSState from '{0}' --> '{1}!", oldValue, newValue));
}
);

// Create a subscription for the AdsState change and buffering 2 Values (for oldValue --> newValue output).
IDisposable subscription = client.WhenAdsStateChanges().Buffer(2,1).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Reference
TwinCAT.Ads.Reactive Namespace
TwinCAT.Ads.Reactive.AnyTypeExtensions
TwinCAT.Ads.Reactive.ValueSymbolExtensions
Weiterführende Informationen
•
AdsClientExtensions Methods


AdsClientExtensions Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AdsClientExtensions Class [image] AdsClientExtensions Methods
AdsClientExtensions Methods
The AdsClientExtensions type exposes the following members.
Methods
Name | Description
PollAdsState(IAdsConnection, IObservable.Unit.) | Gets an observable sequence of AdsStates via Polling.
PollAdsState(IAdsConnection, TimeSpan) | Gets an observable sequence of AdsStates via Polling.
WhenAdsStateChanges | Gets an observable sequence of AdsStates.
WhenNotification(IAdsConnection, ISymbol) | Gets an observable sequence of Notifications.
WhenNotification(IAdsConnection, ISymbolCollection) | Gets an observable sequence of Notification objects.
WhenNotification(IAdsConnection, ISymbol, NotificationSettings) | Gets an observable sequence of Notifications.
WhenNotification(IAdsConnection, ISymbolCollection, NotificationSettings) | Gets an observable sequence of Notification objects.
Reference
AdsClientExtensions Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
AdsClientExtensions.PollAdsState Method
•
AdsClientExtensions.WhenAdsStateChanges Method
•
AdsClientExtensions.WhenNotification Method


AdsClientExtensions.PollAdsState Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AdsClientExtensions Class [image] AdsClientExtensions Methods [image] AdsClientExtensions.PollAdsState Method
AdsClientExtensions.PollAdsState Method
Overload List
Name | Description
PollAdsState(IAdsConnection, IObservable.Unit.) | Gets an observable sequence of AdsStates via Polling.
PollAdsState(IAdsConnection, TimeSpan) | Gets an observable sequence of AdsStates via Polling.
Reference
AdsClientExtensions Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
AdsClientExtensions.PollAdsState Method (IAdsConnection, IObservable.Unit.)
•
AdsClientExtensions.PollAdsState Method (IAdsConnection, TimeSpan)


AdsClientExtensions.PollAdsState Method (IAdsConnection, IObservable.Unit.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AdsClientExtensions Class [image] AdsClientExtensions Methods [image] AdsClientExtensions.PollAdsState Method [image] AdsClientExtensions.PollAdsState Method (IAdsConnection, IObservable.Unit.)
AdsClientExtensions.PollAdsState Method (IAdsConnection, IObservable.Unit.)
Gets an observable sequence of AdsStates via Polling.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<AdsState> PollAdsState(
this IAdsConnection client,
IObservable<Unit> trigger
)
VB
<ExtensionAttribute>
Public Shared Function PollAdsState (
client As IAdsConnection,
trigger As IObservable(Of Unit)
) As IObservable(Of AdsState)
Parameters
client | Type: TwinCAT.Ads.IAdsConnection The client.
trigger | Type: System.IObservable.Unit. The polling trigger
Return Value
Type: IObservable.AdsState.
IObservable<AdsState>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
The following sample shows how observe AdsState via polling with the reactive AdsClientExtensions
Observe changing ADS States with reactive extensions.
// To Test the observer, Start/Stop the local PLC

using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.DefaultDynamic);

// Reactive Change Handler
var valueObserver = Observer.Create<IList<AdsState>>(not =>
{
AdsState oldValue = not[0];
AdsState newValue = not[1];

Console.WriteLine(string.Format("Changed ADSState from '{0}' --> '{1}!", oldValue, newValue));
}
);

// Create a subscription for the AdsState change and buffering 2 Values (for oldValue --> newValue output).
IDisposable subscription = client.PollAdsState(TimeSpan.FromMilliseconds(200)).Buffer(2, 1).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Reference
AdsClientExtensions Class
PollAdsState Overload
TwinCAT.Ads.Reactive Namespace
AdsClientExtensions.WhenAdsStateChanges(TcAdsClient)


AdsClientExtensions.PollAdsState Method (IAdsConnection, TimeSpan)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AdsClientExtensions Class [image] AdsClientExtensions Methods [image] AdsClientExtensions.PollAdsState Method [image] AdsClientExtensions.PollAdsState Method (IAdsConnection, TimeSpan)
AdsClientExtensions.PollAdsState Method (IAdsConnection, TimeSpan)
Gets an observable sequence of AdsStates via Polling.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<AdsState> PollAdsState(
this IAdsConnection client,
TimeSpan period
)
VB
<ExtensionAttribute>
Public Shared Function PollAdsState (
client As IAdsConnection,
period As TimeSpan
) As IObservable(Of AdsState)
Parameters
client | Type: TwinCAT.Ads.IAdsConnection The client.
period | Type: System.TimeSpan The period.
Return Value
Type: IObservable.AdsState.
IObservable<AdsState>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
The following sample shows how observe AdsState via polling with the reactive AdsClientExtensions
Observe changing ADS States with reactive extensions.
// To Test the observer, Start/Stop the local PLC

using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.DefaultDynamic);

// Reactive Change Handler
var valueObserver = Observer.Create<IList<AdsState>>(not =>
{
AdsState oldValue = not[0];
AdsState newValue = not[1];

Console.WriteLine(string.Format("Changed ADSState from '{0}' --> '{1}!", oldValue, newValue));
}
);

// Create a subscription for the AdsState change and buffering 2 Values (for oldValue --> newValue output).
IDisposable subscription = client.PollAdsState(TimeSpan.FromMilliseconds(200)).Buffer(2, 1).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Reference
AdsClientExtensions Class
PollAdsState Overload
TwinCAT.Ads.Reactive Namespace
AdsClientExtensions.WhenAdsStateChanges(TcAdsClient)


AdsClientExtensions.WhenAdsStateChanges Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AdsClientExtensions Class [image] AdsClientExtensions Methods [image] AdsClientExtensions.WhenAdsStateChanges Method
AdsClientExtensions.WhenAdsStateChanges Method
Gets an observable sequence of AdsStates.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<AdsState> WhenAdsStateChanges(
this TcAdsClient client
)
VB
<ExtensionAttribute>
Public Shared Function WhenAdsStateChanges (
client As TcAdsClient
) As IObservable(Of AdsState)
Parameters
client
Type: TwinCAT.Ads.TcAdsClient
The client.
Return Value
Type: IObservable.AdsState.
IObservable<AdsState>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type TcAdsClient. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
The following sample shows how observe AdsState changed Notifications with the reactive AdsClientExtensions
Observe changing ADS States with reactive extensions.
// To Test the observer, Start/Stop the local PLC

using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.DefaultDynamic);

// Reactive Notification Handler
var valueObserver = Observer.Create<IList<AdsState>>(not =>
{
AdsState oldValue = not[0];
AdsState newValue = not[1];

Console.WriteLine(string.Format("Changed ADSState from '{0}' --> '{1}!", oldValue, newValue));
}
);

// Create a subscription for the AdsState change and buffering 2 Values (for oldValue --> newValue output).
IDisposable subscription = client.WhenAdsStateChanges().Buffer(2,1).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Reference
AdsClientExtensions Class
TwinCAT.Ads.Reactive Namespace
AdsClientExtensions.PollAdsState(IAdsConnection, IObservable.Unit.)


AdsClientExtensions.WhenNotification Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AdsClientExtensions Class [image] AdsClientExtensions Methods [image] AdsClientExtensions.WhenNotification Method
AdsClientExtensions.WhenNotification Method
Overload List
Name | Description
WhenNotification(IAdsConnection, ISymbol) | Gets an observable sequence of Notifications.
WhenNotification(IAdsConnection, ISymbolCollection) | Gets an observable sequence of Notification objects.
WhenNotification(IAdsConnection, ISymbol, NotificationSettings) | Gets an observable sequence of Notifications.
WhenNotification(IAdsConnection, ISymbolCollection, NotificationSettings) | Gets an observable sequence of Notification objects.
Reference
AdsClientExtensions Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbol)
•
AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbolCollection)
•
AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbol, NotificationSettings)
•
AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbolCollection, NotificationSettings)


AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbol)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AdsClientExtensions Class [image] AdsClientExtensions Methods [image] AdsClientExtensions.WhenNotification Method [image] AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbol)
AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbol)
Gets an observable sequence of Notifications.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<Notification> WhenNotification(
this IAdsConnection client,
ISymbol symbol
)
VB
<ExtensionAttribute>
Public Shared Function WhenNotification (
client As IAdsConnection,
symbol As ISymbol
) As IObservable(Of Notification)
Parameters
client | Type: TwinCAT.Ads.IAdsConnection The client.
symbol | Type: TwinCAT.TypeSystem.ISymbol The symbol.
Return Value
Type: IObservable.Notification.
IObservable<NotificationValue>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AdsClientExtensions Class
WhenNotification Overload
TwinCAT.Ads.Reactive Namespace
AdsClientExtensions.WhenNotification(IAdsConnection, ISymbolCollection, NotificationSettings)
AdsClientExtensions.WhenNotification(IAdsConnection, ISymbol, NotificationSettings)


AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbolCollection)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AdsClientExtensions Class [image] AdsClientExtensions Methods [image] AdsClientExtensions.WhenNotification Method [image] AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbolCollection)
AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbolCollection)
Gets an observable sequence of Notification objects.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<SymbolNotification> WhenNotification(
this IAdsConnection client,
ISymbolCollection symbols
)
VB
<ExtensionAttribute>
Public Shared Function WhenNotification (
client As IAdsConnection,
symbols As ISymbolCollection
) As IObservable(Of SymbolNotification)
Parameters
client | Type: TwinCAT.Ads.IAdsConnection The client.
symbols | Type: TwinCAT.TypeSystem.ISymbolCollection The symbols.
Return Value
Type: IObservable.SymbolNotification.
IObservable<NotificationValue>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
The following sample shows how observe Value changed Notifications with the reactive AdsClientExtensions
Observe changing ADS Symbols with reactive extensions.
// To Test the Observer run a project on the local PLC System (Port 851)

using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);

int eventCount = 1;

// Reactive Notification Handler
var valueObserver = Observer.Create<SymbolNotification>(not =>
{
Console.WriteLine(string.Format("{0} {1:u} {2} = '{3}' ({4})", eventCount++, not.TimeStamp, not.Symbol.InstancePath, not.Value, not.Symbol.DataType));
}
);

// Collect the symbols that are registered as Notification sources for their changed values.

SymbolCollection notificationSymbols = new SymbolCollection();
IArrayInstance taskInfo = (IArrayInstance)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo"];

foreach(ISymbol element in taskInfo.Elements)
{
ISymbol cycleCount = element.SubSymbols["CycleCount"];
ISymbol lastExecTime = element.SubSymbols["LastExecTime"];

notificationSymbols.Add(cycleCount);
notificationSymbols.Add(lastExecTime);
}

// Create a subscription for the first 200 Notifications on Symbol Value changes.
IDisposable subscription = client.WhenNotification(notificationSymbols,NotificationSettings.Default).Take(200).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Reference
AdsClientExtensions Class
WhenNotification Overload
TwinCAT.Ads.Reactive Namespace
AdsClientExtensions.WhenNotification(IAdsConnection, ISymbol, NotificationSettings)


AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbol, NotificationSettings)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AdsClientExtensions Class [image] AdsClientExtensions Methods [image] AdsClientExtensions.WhenNotification Method [image] AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbol, NotificationSettings)
AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbol, NotificationSettings)
Gets an observable sequence of Notifications.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<SymbolNotification> WhenNotification(
this IAdsConnection client,
ISymbol symbol,
NotificationSettings settings
)
VB
<ExtensionAttribute>
Public Shared Function WhenNotification (
client As IAdsConnection,
symbol As ISymbol,
settings As NotificationSettings
) As IObservable(Of SymbolNotification)
Parameters
client | Type: TwinCAT.Ads.IAdsConnection The client.
symbol | Type: TwinCAT.TypeSystem.ISymbol The symbol to observe.
settings | Type: TwinCAT.Ads.NotificationSettings Notification settings.
Return Value
Type: IObservable.SymbolNotification.
IObservable<NotificationValue>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | symbol
ArgumentOutOfRangeException | Symbol is not an IValueSymbol - symbol
Reference
AdsClientExtensions Class
WhenNotification Overload
TwinCAT.Ads.Reactive Namespace
AdsClientExtensions.WhenNotification(IAdsConnection, ISymbolCollection, NotificationSettings)


AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbolCollection, NotificationSettings)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AdsClientExtensions Class [image] AdsClientExtensions Methods [image] AdsClientExtensions.WhenNotification Method [image] AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbolCollection, NotificationSettings)
AdsClientExtensions.WhenNotification Method (IAdsConnection, ISymbolCollection, NotificationSettings)
Gets an observable sequence of Notification objects.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<SymbolNotification> WhenNotification(
this IAdsConnection client,
ISymbolCollection symbols,
NotificationSettings settings
)
VB
<ExtensionAttribute>
Public Shared Function WhenNotification (
client As IAdsConnection,
symbols As ISymbolCollection,
settings As NotificationSettings
) As IObservable(Of SymbolNotification)
Parameters
client | Type: TwinCAT.Ads.IAdsConnection The client.
symbols | Type: TwinCAT.TypeSystem.ISymbolCollection The symbols to observe.
settings | Type: TwinCAT.Ads.NotificationSettings The Notification settings.
Return Value
Type: IObservable.SymbolNotification.
IObservable<NotificationValue>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
The following sample shows how observe Value changed Notifications with the reactive AdsClientExtensions
Observe changing ADS Symbols with reactive extensions.
// To Test the Observer run a project on the local PLC System (Port 851)

using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);

int eventCount = 1;

// Reactive Notification Handler
var valueObserver = Observer.Create<SymbolNotification>(not =>
{
Console.WriteLine(string.Format("{0} {1:u} {2} = '{3}' ({4})", eventCount++, not.TimeStamp, not.Symbol.InstancePath, not.Value, not.Symbol.DataType));
}
);

// Collect the symbols that are registered as Notification sources for their changed values.

SymbolCollection notificationSymbols = new SymbolCollection();
IArrayInstance taskInfo = (IArrayInstance)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo"];

foreach(ISymbol element in taskInfo.Elements)
{
ISymbol cycleCount = element.SubSymbols["CycleCount"];
ISymbol lastExecTime = element.SubSymbols["LastExecTime"];

notificationSymbols.Add(cycleCount);
notificationSymbols.Add(lastExecTime);
}

// Create a subscription for the first 200 Notifications on Symbol Value changes.
IDisposable subscription = client.WhenNotification(notificationSymbols,NotificationSettings.Default).Take(200).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Reference
AdsClientExtensions Class
WhenNotification Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class
AnyTypeExtensions Class
Extension class for TcAdsClient respective IAdsConnection to provide reactive ADS extensions (accessing symbol value sequences with the ANY_TYPE concept)
Inheritance Hierarchy
System.Object
TwinCAT.Ads.Reactive.AnyTypeExtensions
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static class AnyTypeExtensions
VB
<ExtensionAttribute>
Public NotInheritable Class AnyTypeExtensions
Methods
Name | Description
PollValues(IAdsConnection, String, Type, IObservable.Unit.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues(IAdsConnection, String, Type, TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues(IAdsConnection, String, Type, .Int32., TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues(IAdsConnection, String, Type, IObservable.Unit., Func.Exception, Object.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues(IAdsConnection, String, Type, TimeSpan, Func.Exception, Object.) | Polls the symbol as value sequence of object values with a specified period time.
PollValues(IAdsConnection, String, Type, .Int32., IObservable.Unit., Func.Exception, Object.) | Polls the symbol values on time points where the polling observable streams data / triggers
PollValues(IAdsConnection, String, Type, .Int32., TimeSpan, Func.Exception, Object.) | Polls the symbol as value sequence of object values with a specified period time.
PollValues.T.(IAdsConnection, String, IObservable.Unit.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues.T.(IAdsConnection, String, .Int32., IObservable.Unit.) | Polls the symbol values on time points where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, .Int32., TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues.T.(IAdsConnection, String, IObservable.Unit., Func.Exception, T.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, TimeSpan, Func.Exception, T.) | Polls the symbol as value sequence of object values with a specified period time.
PollValues.T.(IAdsConnection, String, .Int32., IObservable.Unit., Func.Exception, T.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, .Int32., TimeSpan, Func.Exception, T.) | Polls the symbol as value sequence of object values with a specified period time.
WriteValues.T.(IAdsConnection, String, IObservable.T.) | Writes the sequence of values to the symbol specified by the instance path.
WriteValues.T.(IAdsConnection, String, IObservable.T., Action.Exception.) | Writes the sequence of values to the symbol specified by the instance path.
Remarks
Reactive Extensions (Rx) are a library for composing asynchronous and event-based programs using observable sequences and LINQ-style query operators. Using Rx, developers represent asynchronous data streams with Observables, query asynchronous data streams using LINQ operators, and parameterize the concurrency in the asynchronous data streams using Schedulers. Simply put, Rx = Observables + LINQ + Schedulers. The ADS reactive extensions are build on top of this library to enable ADS Symbol and State Observables, seamlessly bound to the reactive extensions. To use the ADS reactive extensions the TwinCAT.Ads.Reactive Nuget package (or the included TwinCAT.Ads.Reactive.dll) must be referenced. (Beckhoff.TwinCAT.Ads.Reactive package on Nuget).
Examples
Example1: Observe Value changed Notifications with the reactive AnyTypeExtensions
Observe a single changing ADS Symbols (Extended AdsNotifications, ANY_TYPE)
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Reactive Notification Handler
var valueObserver = Observer.Create<ushort>(val =>
{
Console.WriteLine(string.Format("Value: {0}", val.ToString()));
}
);

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = client.WhenNotification<ushort>("TwinCAT_SystemInfoVarList._TaskInfo.CycleCount", NotificationSettings.Default).Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Examples
Example2: Polling ANY_TYPE values.
Observe changing ADS Symbols by polling (Read Polling) (ANY_TYPE)
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo.CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

// Take 20 Values in an Interval of 500ms
IDisposable subscription = cycleCount.PollValues(TimeSpan.FromMilliseconds(500)).Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Examples
Write values sequentially.
Write sequences of values to the target (ANY_TYPE)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information (Symbol 'i : INT' in PLC Global Variables list.
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol gvlIntSymbol = (IValueSymbol)symbolLoader.Symbols["GVL.i"];

// Produces object (short) Values 0,1,2,3 ... in seconds period
IObservable<object> timerObservable = Observable.Interval(TimeSpan.FromSeconds(1.0)).Select(i => (object)(short)i);

// Take 10 Values (0..9) and write them to GVL.i
IDisposable dispose = gvlIntSymbol.WriteValues(timerObservable.Take(10));

Console.ReadKey(); // Wait for Key press
dispose.Dispose(); // Dispose the Subscription
}
Reference
TwinCAT.Ads.Reactive Namespace
TwinCAT.Ads.Reactive.AdsClientExtensions
TwinCAT.Ads.Reactive.ValueSymbolExtensions
Weiterführende Informationen
•
AnyTypeExtensions Methods


AnyTypeExtensions Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods
AnyTypeExtensions Methods
Methods
Name | Description
PollValues(IAdsConnection, String, Type, IObservable.Unit.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues(IAdsConnection, String, Type, TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues(IAdsConnection, String, Type, .Int32., TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues(IAdsConnection, String, Type, IObservable.Unit., Func.Exception, Object.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues(IAdsConnection, String, Type, TimeSpan, Func.Exception, Object.) | Polls the symbol as value sequence of object values with a specified period time.
PollValues(IAdsConnection, String, Type, .Int32., IObservable.Unit., Func.Exception, Object.) | Polls the symbol values on time points where the polling observable streams data / triggers
PollValues(IAdsConnection, String, Type, .Int32., TimeSpan, Func.Exception, Object.) | Polls the symbol as value sequence of object values with a specified period time.
PollValues.T.(IAdsConnection, String, IObservable.Unit.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues.T.(IAdsConnection, String, .Int32., IObservable.Unit.) | Polls the symbol values on time points where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, .Int32., TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues.T.(IAdsConnection, String, IObservable.Unit., Func.Exception, T.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, TimeSpan, Func.Exception, T.) | Polls the symbol as value sequence of object values with a specified period time.
PollValues.T.(IAdsConnection, String, .Int32., IObservable.Unit., Func.Exception, T.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, .Int32., TimeSpan, Func.Exception, T.) | Polls the symbol as value sequence of object values with a specified period time.
WriteValues.T.(IAdsConnection, String, IObservable.T.) | Writes the sequence of values to the symbol specified by the instance path.
WriteValues.T.(IAdsConnection, String, IObservable.T., Action.Exception.) | Writes the sequence of values to the symbol specified by the instance path.
Reference
AnyTypeExtensions Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
AnyTypeExtensions.PollValues Method
•
AnyTypeExtensions.WriteValues Method


AnyTypeExtensions.PollValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method
AnyTypeExtensions.PollValues Method
Overload List
Name | Description
PollValues.T.(IAdsConnection, String, IObservable.Unit.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues.T.(IAdsConnection, String, .Int32., IObservable.Unit.) | Polls the symbol values on time points where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, .Int32., TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues.T.(IAdsConnection, String, IObservable.Unit., Func.Exception, T.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, TimeSpan, Func.Exception, T.) | Polls the symbol as value sequence of object values with a specified period time.
PollValues(IAdsConnection, String, Type, IObservable.Unit.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues(IAdsConnection, String, Type, TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues.T.(IAdsConnection, String, .Int32., IObservable.Unit., Func.Exception, T.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues.T.(IAdsConnection, String, .Int32., TimeSpan, Func.Exception, T.) | Polls the symbol as value sequence of object values with a specified period time.
PollValues(IAdsConnection, String, Type, .Int32., TimeSpan) | Polls the symbol as value sequence of object values with a specified period time.
PollValues(IAdsConnection, String, Type, IObservable.Unit., Func.Exception, Object.) | Polls the symbol values on timepoints where the polling observable streams data / triggers
PollValues(IAdsConnection, String, Type, TimeSpan, Func.Exception, Object.) | Polls the symbol as value sequence of object values with a specified period time.
PollValues(IAdsConnection, String, Type, .Int32., IObservable.Unit., Func.Exception, Object.) | Polls the symbol values on time points where the polling observable streams data / triggers
PollValues(IAdsConnection, String, Type, .Int32., TimeSpan, Func.Exception, Object.) | Polls the symbol as value sequence of object values with a specified period time.
Reference
AnyTypeExtensions Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, IObservable.Unit.)
•
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, TimeSpan)
•
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., IObservable.Unit.)
•
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., TimeSpan)
•
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, IObservable.Unit., Func.Exception, T.)
•
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, TimeSpan, Func.Exception, T.)
•
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, IObservable.Unit.)
•
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, TimeSpan)
•
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., IObservable.Unit., Func.Exception, T.)
•
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., TimeSpan, Func.Exception, T.)
•
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., TimeSpan)
•
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, IObservable.Unit., Func.Exception, Object.)
•
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, TimeSpan, Func.Exception, Object.)
•
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., IObservable.Unit., Func.Exception, Object.)
•
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., TimeSpan, Func.Exception, Object.)


AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, IObservable.Unit.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, IObservable.Unit.)
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, IObservable.Unit.)
Polls the symbol values on timepoints where the polling observable streams data / triggers
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<T> PollValues<T>(
this IAdsConnection connection,
string instancePath,
IObservable<Unit> trigger
)
VB
<ExtensionAttribute>
Public Shared Function PollValues(Of T) (
connection As IAdsConnection,
instancePath As String,
trigger As IObservable(Of Unit)
) As IObservable(Of T)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
trigger | Type: System.IObservable.Unit. The Polling trigger
Type Parameters
T
The ANY_TYPE compatible .NET Type.
Return Value
Type: IObservable.T.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, TimeSpan)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, TimeSpan)
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, TimeSpan)
Polls the symbol as value sequence of object values with a specified period time.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<T> PollValues<T>(
this IAdsConnection connection,
string instancePath,
TimeSpan period
)
VB
<ExtensionAttribute>
Public Shared Function PollValues(Of T) (
connection As IAdsConnection,
instancePath As String,
period As TimeSpan
) As IObservable(Of T)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
period | Type: System.TimeSpan The period.
Type Parameters
T
The ANY_TYPE compatible .NET Type.
Return Value
Type: IObservable.T.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., IObservable.Unit.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., IObservable.Unit.)
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., IObservable.Unit.)
Polls the symbol values on time points where the polling observable streams data / triggers
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<T> PollValues<T>(
this IAdsConnection connection,
string instancePath,
int[] args,
IObservable<Unit> trigger
)
VB
<ExtensionAttribute>
Public Shared Function PollValues(Of T) (
connection As IAdsConnection,
instancePath As String,
args As Integer(),
trigger As IObservable(Of Unit)
) As IObservable(Of T)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
args | Type: .System.Int32. ANY_TYPE arguments
trigger | Type: System.IObservable.Unit. The Polling trigger
Type Parameters
T
The ANY_TYPE compatible .NET Type.
Return Value
Type: IObservable.T.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., TimeSpan)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., TimeSpan)
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., TimeSpan)
Polls the symbol as value sequence of object values with a specified period time.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<T> PollValues<T>(
this IAdsConnection connection,
string instancePath,
int[] args,
TimeSpan period
)
VB
<ExtensionAttribute>
Public Shared Function PollValues(Of T) (
connection As IAdsConnection,
instancePath As String,
args As Integer(),
period As TimeSpan
) As IObservable(Of T)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
args | Type: .System.Int32. ANY_TYPE arguments.
period | Type: System.TimeSpan The period.
Type Parameters
T
The ANY_TYPE compatible .NET Type.
Return Value
Type: IObservable.T.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
Polling ANY_TYPE values.
Observe changing ADS Symbols by polling (Read Polling) (ANY_TYPE)
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo.CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

// Take 20 Values in an Interval of 500ms
IDisposable subscription = cycleCount.PollValues(TimeSpan.FromMilliseconds(500)).Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, IObservable.Unit., Func.Exception, T.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, IObservable.Unit., Func.Exception, T.)
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, IObservable.Unit., Func.Exception, T.)
Polls the symbol values on timepoints where the polling observable streams data / triggers
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<T> PollValues<T>(
this IAdsConnection connection,
string instancePath,
IObservable<Unit> trigger,
Func<Exception, T> errorHandler
)
VB
<ExtensionAttribute>
Public Shared Function PollValues(Of T) (
connection As IAdsConnection,
instancePath As String,
trigger As IObservable(Of Unit),
errorHandler As Func(Of Exception, T)
) As IObservable(Of T)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
trigger | Type: System.IObservable.Unit. The Polling trigger
errorHandler | Type: System.Func.Exception, T. The error handler.
Type Parameters
T
The ANY_TYPE compatible .NET Type.
Return Value
Type: IObservable.T.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, TimeSpan, Func.Exception, T.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, TimeSpan, Func.Exception, T.)
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, TimeSpan, Func.Exception, T.)
Polls the symbol as value sequence of object values with a specified period time.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<T> PollValues<T>(
this IAdsConnection connection,
string instancePath,
TimeSpan period,
Func<Exception, T> errorHandler
)
VB
<ExtensionAttribute>
Public Shared Function PollValues(Of T) (
connection As IAdsConnection,
instancePath As String,
period As TimeSpan,
errorHandler As Func(Of Exception, T)
) As IObservable(Of T)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
period | Type: System.TimeSpan The period.
errorHandler | Type: System.Func.Exception, T. The error handler.
Type Parameters
T
The ANY_TYPE compatible .NET Type.
Return Value
Type: IObservable.T.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, IObservable.Unit.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, IObservable.Unit.)
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, IObservable.Unit.)
Polls the symbol values on timepoints where the polling observable streams data / triggers
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<Object> PollValues(
this IAdsConnection connection,
string instancePath,
Type type,
IObservable<Unit> trigger
)
VB
<ExtensionAttribute>
Public Shared Function PollValues (
connection As IAdsConnection,
instancePath As String,
type As Type,
trigger As IObservable(Of Unit)
) As IObservable(Of Object)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
type | Type: System.Type The data type of the symbol (ANY_TYPE)
trigger | Type: System.IObservable.Unit. The Polling trigger
Return Value
Type: IObservable.Object.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, TimeSpan)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, TimeSpan)
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, TimeSpan)
Polls the symbol as value sequence of object values with a specified period time.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<Object> PollValues(
this IAdsConnection connection,
string instancePath,
Type type,
TimeSpan period
)
VB
<ExtensionAttribute>
Public Shared Function PollValues (
connection As IAdsConnection,
instancePath As String,
type As Type,
period As TimeSpan
) As IObservable(Of Object)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
type | Type: System.Type The data type of the symbol (ANY_TYPE)
period | Type: System.TimeSpan The period.
Return Value
Type: IObservable.Object.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., IObservable.Unit., Func.Exception, T.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., IObservable.Unit., Func.Exception, T.)
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., IObservable.Unit., Func.Exception, T.)
Polls the symbol values on timepoints where the polling observable streams data / triggers
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<T> PollValues<T>(
this IAdsConnection connection,
string instancePath,
int[] args,
IObservable<Unit> trigger,
Func<Exception, T> errorHandler
)
VB
<ExtensionAttribute>
Public Shared Function PollValues(Of T) (
connection As IAdsConnection,
instancePath As String,
args As Integer(),
trigger As IObservable(Of Unit),
errorHandler As Func(Of Exception, T)
) As IObservable(Of T)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
args | Type: .System.Int32. ANY_TYPE arguments
trigger | Type: System.IObservable.Unit. The Polling trigger
errorHandler | Type: System.Func.Exception, T. The error handler.
Type Parameters
T
The ANY_TYPE compatible .NET Type.
Return Value
Type: IObservable.T.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., TimeSpan, Func.Exception, T.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., TimeSpan, Func.Exception, T.)
AnyTypeExtensions.PollValues.T. Method (IAdsConnection, String, .Int32., TimeSpan, Func.Exception, T.)
Polls the symbol as value sequence of object values with a specified period time.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<T> PollValues<T>(
this IAdsConnection connection,
string instancePath,
int[] args,
TimeSpan period,
Func<Exception, T> errorHandler
)
VB
<ExtensionAttribute>
Public Shared Function PollValues(Of T) (
connection As IAdsConnection,
instancePath As String,
args As Integer(),
period As TimeSpan,
errorHandler As Func(Of Exception, T)
) As IObservable(Of T)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
args | Type: .System.Int32. ANY_TYPE arguments.
period | Type: System.TimeSpan The period.
errorHandler | Type: System.Func.Exception, T. The error handler.
Type Parameters
T
The ANY_TYPE compatible .NET Type.
Return Value
Type: IObservable.T.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
Polling ANY_TYPE values.
Observe changing ADS Symbols by polling (Read Polling) (ANY_TYPE)
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo.CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

// Take 20 Values in an Interval of 500ms
IDisposable subscription = cycleCount.PollValues(TimeSpan.FromMilliseconds(500)).Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., TimeSpan)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., TimeSpan)
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., TimeSpan)
Polls the symbol as value sequence of object values with a specified period time.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<Object> PollValues(
this IAdsConnection connection,
string instancePath,
Type type,
int[] args,
TimeSpan period
)
VB
<ExtensionAttribute>
Public Shared Function PollValues (
connection As IAdsConnection,
instancePath As String,
type As Type,
args As Integer(),
period As TimeSpan
) As IObservable(Of Object)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
type | Type: System.Type The data type of the symbol (ANY_TYPE)
args | Type: .System.Int32. The ANY_TYPE arguments.
period | Type: System.TimeSpan The period.
Return Value
Type: IObservable.Object.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, IObservable.Unit., Func.Exception, Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, IObservable.Unit., Func.Exception, Object.)
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, IObservable.Unit., Func.Exception, Object.)
Polls the symbol values on timepoints where the polling observable streams data / triggers
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<Object> PollValues(
this IAdsConnection connection,
string instancePath,
Type type,
IObservable<Unit> trigger,
Func<Exception, Object> errorHandler
)
VB
<ExtensionAttribute>
Public Shared Function PollValues (
connection As IAdsConnection,
instancePath As String,
type As Type,
trigger As IObservable(Of Unit),
errorHandler As Func(Of Exception, Object)
) As IObservable(Of Object)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
type | Type: System.Type The data type of the symbol (ANY_TYPE)
trigger | Type: System.IObservable.Unit. The Polling trigger
errorHandler | Type: System.Func.Exception, Object. The error handler.
Return Value
Type: IObservable.Object.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, TimeSpan, Func.Exception, Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, TimeSpan, Func.Exception, Object.)
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, TimeSpan, Func.Exception, Object.)
Polls the symbol as value sequence of object values with a specified period time.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<Object> PollValues(
this IAdsConnection connection,
string instancePath,
Type type,
TimeSpan period,
Func<Exception, Object> errorHandler
)
VB
<ExtensionAttribute>
Public Shared Function PollValues (
connection As IAdsConnection,
instancePath As String,
type As Type,
period As TimeSpan,
errorHandler As Func(Of Exception, Object)
) As IObservable(Of Object)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
type | Type: System.Type The data type of the symbol (ANY_TYPE)
period | Type: System.TimeSpan The period.
errorHandler | Type: System.Func.Exception, Object. The error handler.
Return Value
Type: IObservable.Object.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., IObservable.Unit., Func.Exception, Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., IObservable.Unit., Func.Exception, Object.)
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., IObservable.Unit., Func.Exception, Object.)
Polls the symbol values on time points where the polling observable streams data / triggers
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<Object> PollValues(
this IAdsConnection connection,
string instancePath,
Type type,
int[] args,
IObservable<Unit> trigger,
Func<Exception, Object> errorHandler
)
VB
<ExtensionAttribute>
Public Shared Function PollValues (
connection As IAdsConnection,
instancePath As String,
type As Type,
args As Integer(),
trigger As IObservable(Of Unit),
errorHandler As Func(Of Exception, Object)
) As IObservable(Of Object)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
type | Type: System.Type The data type of the symbol (ANY_TYPE)
args | Type: .System.Int32. The ANY_TYPE arguments.
trigger | Type: System.IObservable.Unit. The Polling trigger
errorHandler | Type: System.Func.Exception, Object. The error handler.
Return Value
Type: IObservable.Object.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., TimeSpan, Func.Exception, Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.PollValues Method [image] AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., TimeSpan, Func.Exception, Object.)
AnyTypeExtensions.PollValues Method (IAdsConnection, String, Type, .Int32., TimeSpan, Func.Exception, Object.)
Polls the symbol as value sequence of object values with a specified period time.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<Object> PollValues(
this IAdsConnection connection,
string instancePath,
Type type,
int[] args,
TimeSpan period,
Func<Exception, Object> errorHandler
)
VB
<ExtensionAttribute>
Public Shared Function PollValues (
connection As IAdsConnection,
instancePath As String,
type As Type,
args As Integer(),
period As TimeSpan,
errorHandler As Func(Of Exception, Object)
) As IObservable(Of Object)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
type | Type: System.Type The data type of the symbol (ANY_TYPE)
args | Type: .System.Int32. The ANY_TYPE arguments.
period | Type: System.TimeSpan The period.
errorHandler | Type: System.Func.Exception, Object. The error handler.
Return Value
Type: IObservable.Object.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
AnyTypeExtensions Class
PollValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.WriteValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.WriteValues Method
AnyTypeExtensions.WriteValues Method
Overload List
Name | Description
WriteValues.T.(IAdsConnection, String, IObservable.T.) | Writes the sequence of values to the symbol specified by the instance path.
WriteValues.T.(IAdsConnection, String, IObservable.T., Action.Exception.) | Writes the sequence of values to the symbol specified by the instance path.
Reference
AnyTypeExtensions Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
AnyTypeExtensions.WriteValues.T. Method (IAdsConnection, String, IObservable.T.)
•
AnyTypeExtensions.WriteValues.T. Method (IAdsConnection, String, IObservable.T., Action.Exception.)


AnyTypeExtensions.WriteValues.T. Method (IAdsConnection, String, IObservable.T.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.WriteValues Method [image] AnyTypeExtensions.WriteValues.T. Method (IAdsConnection, String, IObservable.T.)
AnyTypeExtensions.WriteValues.T. Method (IAdsConnection, String, IObservable.T.)
Writes the sequence of values to the symbol specified by the instance path.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IDisposable WriteValues<T>(
this IAdsConnection connection,
string instancePath,
IObservable<T> valueSequence
)
VB
<ExtensionAttribute>
Public Shared Function WriteValues(Of T) (
connection As IAdsConnection,
instancePath As String,
valueSequence As IObservable(Of T)
) As IDisposable
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
valueSequence | Type: System.IObservable.T. Value sequence (Any type).
Type Parameters
T
Return Value
Type: IDisposable
IDisposable.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
Write values sequentially.
Write sequences of values to the target (ANY_TYPE)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information (Symbol 'i : INT' in PLC Global Variables list.
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol gvlIntSymbol = (IValueSymbol)symbolLoader.Symbols["GVL.i"];

// Produces object (short) Values 0,1,2,3 ... in seconds period
IObservable<object> timerObservable = Observable.Interval(TimeSpan.FromSeconds(1.0)).Select(i => (object)(short)i);

// Take 10 Values (0..9) and write them to GVL.i
IDisposable dispose = gvlIntSymbol.WriteValues(timerObservable.Take(10));

Console.ReadKey(); // Wait for Key press
dispose.Dispose(); // Dispose the Subscription
}
Reference
AnyTypeExtensions Class
WriteValues Overload
TwinCAT.Ads.Reactive Namespace


AnyTypeExtensions.WriteValues.T. Method (IAdsConnection, String, IObservable.T., Action.Exception.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] AnyTypeExtensions Class [image] AnyTypeExtensions Methods [image] AnyTypeExtensions.WriteValues Method [image] AnyTypeExtensions.WriteValues.T. Method (IAdsConnection, String, IObservable.T., Action.Exception.)
AnyTypeExtensions.WriteValues.T. Method (IAdsConnection, String, IObservable.T., Action.Exception.)
Writes the sequence of values to the symbol specified by the instance path.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IDisposable WriteValues<T>(
this IAdsConnection connection,
string instancePath,
IObservable<T> valueSequence,
Action<Exception> errorHandler
)
VB
<ExtensionAttribute>
Public Shared Function WriteValues(Of T) (
connection As IAdsConnection,
instancePath As String,
valueSequence As IObservable(Of T),
errorHandler As Action(Of Exception)
) As IDisposable
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePath | Type: System.String The instance path.
valueSequence | Type: System.IObservable.T. Value sequence (Any type).
errorHandler | Type: System.Action.Exception. The error handler.
Type Parameters
T
Return Value
Type: IDisposable
IDisposable.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
Write values sequentially.
Write sequences of values to the target (ANY_TYPE)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information (Symbol 'i : INT' in PLC Global Variables list.
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol gvlIntSymbol = (IValueSymbol)symbolLoader.Symbols["GVL.i"];

// Produces object (short) Values 0,1,2,3 ... in seconds period
IObservable<object> timerObservable = Observable.Interval(TimeSpan.FromSeconds(1.0)).Select(i => (object)(short)i);

// Take 10 Values (0..9) and write them to GVL.i
IDisposable dispose = gvlIntSymbol.WriteValues(timerObservable.Take(10));

Console.ReadKey(); // Wait for Key press
dispose.Dispose(); // Dispose the Subscription
}
Reference
AnyTypeExtensions Class
WriteValues Overload
TwinCAT.Ads.Reactive Namespace


Notification Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] Notification Class
Notification Class
Provides data for AdsNotificationEvent of the class
Inheritance Hierarchy
System.Object
TwinCAT.Ads.Reactive.NotificationBase
TwinCAT.Ads.Reactive.Notification
TwinCAT.Ads.Reactive.SymbolNotification
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public class Notification : NotificationBase
VB
Public Class Notification
Inherits NotificationBase
The Notification type exposes the following members.
Properties
Name | Description
NotificationHandle | Gets the handle of the connection. (Inherited from NotificationBase.)
RawValue | Streams that holds the notification data.
TimeStamp | Gets the timestamp of this Notification. (Inherited from NotificationBase.)
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data. (Inherited from NotificationBase.)
Value | Gets the value of the Notification. (Inherited from NotificationBase.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
_bytes | Raw Data
notificationHandle | Notification Handle (Inherited from NotificationBase.)
timeStamp | Notification Time Stamp (Inherited from NotificationBase.)
userData | User Data (Inherited from NotificationBase.)
val | The unmarshalled value. (Inherited from NotificationBase.)
Reference
TwinCAT.Ads.Reactive Namespace
TwinCAT.Ads.TcAdsClient
Weiterführende Informationen
•
Notification Properties
•
Notification Methods
•
Notification Fields


Notification Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] Notification Class [image] Notification Properties
Notification Properties
The Notification type exposes the following members.
Properties
Name | Description
NotificationHandle | Gets the handle of the connection. (Inherited from NotificationBase.)
RawValue | Streams that holds the notification data.
TimeStamp | Gets the timestamp of this Notification. (Inherited from NotificationBase.)
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data. (Inherited from NotificationBase.)
Value | Gets the value of the Notification. (Inherited from NotificationBase.)
Reference
Notification Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
Notification.RawValue Property


Notification.RawValue Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] Notification Class [image] Notification Properties [image] Notification.RawValue Property
Notification.RawValue Property
Streams that holds the notification data.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public byte[] RawValue { get; }
VB
Public ReadOnly Property RawValue As Byte()
Get
Property Value
Type: .Byte.
Reference
Notification Class
TwinCAT.Ads.Reactive Namespace


Notification Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] Notification Class [image] Notification Methods
Notification Methods
The Notification type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
Notification Class
TwinCAT.Ads.Reactive Namespace


Notification Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] Notification Class [image] Notification Fields
Notification Fields
The Notification type exposes the following members.
Fields
Name | Description
_bytes | Raw Data
notificationHandle | Notification Handle (Inherited from NotificationBase.)
timeStamp | Notification Time Stamp (Inherited from NotificationBase.)
userData | User Data (Inherited from NotificationBase.)
val | The unmarshalled value. (Inherited from NotificationBase.)
Reference
Notification Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
Notification._bytes Field


Notification._bytes Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] Notification Class [image] Notification Fields [image] Notification._bytes Field
Notification._bytes Field
Raw Data
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
protected byte[] _bytes
VB
Protected _bytes As Byte()
Field Value
Type: .Byte.
Reference
Notification Class
TwinCAT.Ads.Reactive Namespace


NotificationBase Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class
NotificationBase Class
Base class for Notifications
Inheritance Hierarchy
System.Object
TwinCAT.Ads.Reactive.NotificationBase
TwinCAT.Ads.Reactive.Notification
TwinCAT.Ads.Reactive.NotificationEx
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public abstract class NotificationBase
VB
Public MustInherit Class NotificationBase
The NotificationBase type exposes the following members.
Constructors
Name | Description
NotificationBase |
Properties
Name | Description
NotificationHandle | Gets the handle of the connection.
TimeStamp | Gets the timestamp of this Notification.
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data.
Value | Gets the value of the Notification.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
notificationHandle | Notification Handle
timeStamp | Notification Time Stamp
userData | User Data
val | The unmarshalled value.
Reference
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
NotificationBase Constructor
•
NotificationBase Properties
•
NotificationBase Methods
•
NotificationBase Fields


NotificationBase Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Constructor
NotificationBase Constructor
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
protected NotificationBase()
VB
Protected Sub New
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace


NotificationBase Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Properties
NotificationBase Properties
The NotificationBase type exposes the following members.
Properties
Name | Description
NotificationHandle | Gets the handle of the connection.
TimeStamp | Gets the timestamp of this Notification.
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data.
Value | Gets the value of the Notification.
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
NotificationBase.NotificationHandle Property
•
NotificationBase.TimeStamp Property
•
NotificationBase.UserData Property
•
NotificationBase.Value Property


NotificationBase.NotificationHandle Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Properties [image] NotificationBase.NotificationHandle Property
NotificationBase.NotificationHandle Property
Gets the handle of the connection.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public uint NotificationHandle { get; }
VB
Public ReadOnly Property NotificationHandle As UInteger
Get
Property Value
Type: UInt32
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace


NotificationBase.TimeStamp Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Properties [image] NotificationBase.TimeStamp Property
NotificationBase.TimeStamp Property
Gets the timestamp of this Notification.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public DateTimeOffset TimeStamp { get; }
VB
Public ReadOnly Property TimeStamp As DateTimeOffset
Get
Property Value
Type: DateTimeOffset
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace


NotificationBase.UserData Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Properties [image] NotificationBase.UserData Property
NotificationBase.UserData Property
Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public Object UserData { get; }
VB
Public ReadOnly Property UserData As Object
Get
Property Value
Type: Object
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace


NotificationBase.Value Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Properties [image] NotificationBase.Value Property
NotificationBase.Value Property
Gets the value of the Notification.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public virtual Object Value { get; }
VB
Public Overridable ReadOnly Property Value As Object
Get
Property Value
Type: Object
The value.
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace


NotificationBase Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Methods
NotificationBase Methods
The NotificationBase type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace


NotificationBase Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Fields
NotificationBase Fields
The NotificationBase type exposes the following members.
Fields
Name | Description
notificationHandle | Notification Handle
timeStamp | Notification Time Stamp
userData | User Data
val | The unmarshalled value.
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
NotificationBase.notificationHandle Field
•
NotificationBase.timeStamp Field
•
NotificationBase.userData Field
•
NotificationBase.val Field


NotificationBase.notificationHandle Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Fields [image] NotificationBase.notificationHandle Field
NotificationBase.notificationHandle Field
Notification Handle
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
protected uint notificationHandle
VB
Protected notificationHandle As UInteger
Field Value
Type: UInt32
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace


NotificationBase.timeStamp Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Fields [image] NotificationBase.timeStamp Field
NotificationBase.timeStamp Field
Notification Time Stamp
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
protected DateTimeOffset timeStamp
VB
Protected timeStamp As DateTimeOffset
Field Value
Type: DateTimeOffset
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace


NotificationBase.userData Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Fields [image] NotificationBase.userData Field
NotificationBase.userData Field
User Data
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
protected Object userData
VB
Protected userData As Object
Field Value
Type: Object
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace


NotificationBase.val Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationBase Class [image] NotificationBase Fields [image] NotificationBase.val Field
NotificationBase.val Field
The unmarshalled value.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
protected Object val
VB
Protected val As Object
Field Value
Type: Object
Reference
NotificationBase Class
TwinCAT.Ads.Reactive Namespace


NotificationEx Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationEx Class
NotificationEx Class
Provides data for AdsNotificationExEvent of the class
Inheritance Hierarchy
System.Object
TwinCAT.Ads.Reactive.NotificationBase
TwinCAT.Ads.Reactive.NotificationEx
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public sealed class NotificationEx : NotificationBase
VB
Public NotInheritable Class NotificationEx
Inherits NotificationBase
The NotificationEx type exposes the following members.
Properties
Name | Description
NotificationHandle | Gets the handle of the connection. (Inherited from NotificationBase.)
TimeStamp | Gets the timestamp of this Notification. (Inherited from NotificationBase.)
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data. (Inherited from NotificationBase.)
Value | Gets the value of the Notification. (Inherited from NotificationBase.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.Ads.Reactive Namespace
TwinCAT.Ads.TcAdsClient
Weiterführende Informationen
•
NotificationEx Properties
•
NotificationEx Methods


NotificationEx Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationEx Class [image] NotificationEx Properties
NotificationEx Properties
The NotificationEx type exposes the following members.
Properties
Name | Description
NotificationHandle | Gets the handle of the connection. (Inherited from NotificationBase.)
TimeStamp | Gets the timestamp of this Notification. (Inherited from NotificationBase.)
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data. (Inherited from NotificationBase.)
Value | Gets the value of the Notification. (Inherited from NotificationBase.)
Reference
NotificationEx Class
TwinCAT.Ads.Reactive Namespace


NotificationEx Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] NotificationEx Class [image] NotificationEx Methods
NotificationEx Methods
The NotificationEx type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
NotificationEx Class
TwinCAT.Ads.Reactive Namespace


SymbolNotification Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] SymbolNotification Class
SymbolNotification Class
Provides data for AdsNotificationEvent of the class
Inheritance Hierarchy
System.Object
TwinCAT.Ads.Reactive.NotificationBase
TwinCAT.Ads.Reactive.Notification
TwinCAT.Ads.Reactive.SymbolNotification
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public sealed class SymbolNotification : Notification
VB
Public NotInheritable Class SymbolNotification
Inherits Notification
The SymbolNotification type exposes the following members.
Properties
Name | Description
NotificationHandle | Gets the handle of the connection. (Inherited from NotificationBase.)
RawValue | Streams that holds the notification data. (Inherited from Notification.)
Symbol | Gets the symbol of the SymbolNotification.
TimeStamp | Gets the timestamp of this Notification. (Inherited from NotificationBase.)
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data. (Inherited from NotificationBase.)
Value | Gets the value of the Notification. (Overrides NotificationBase.Value.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.Ads.Reactive Namespace
TwinCAT.Ads.TcAdsClient
Weiterführende Informationen
•
SymbolNotification Properties
•
SymbolNotification Methods


SymbolNotification Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] SymbolNotification Class [image] SymbolNotification Properties
SymbolNotification Properties
The SymbolNotification type exposes the following members.
Properties
Name | Description
NotificationHandle | Gets the handle of the connection. (Inherited from NotificationBase.)
RawValue | Streams that holds the notification data. (Inherited from Notification.)
Symbol | Gets the symbol of the SymbolNotification.
TimeStamp | Gets the timestamp of this Notification. (Inherited from NotificationBase.)
UserData | Gets the user object. This object is passed by to AddDeviceNotification and can be used to store data. (Inherited from NotificationBase.)
Value | Gets the value of the Notification. (Overrides NotificationBase.Value.)
Reference
SymbolNotification Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
SymbolNotification.Symbol Property
•
SymbolNotification.Value Property


SymbolNotification.Symbol Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] SymbolNotification Class [image] SymbolNotification Properties [image] SymbolNotification.Symbol Property
SymbolNotification.Symbol Property
Gets the symbol of the SymbolNotification.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public ISymbol Symbol { get; }
VB
Public ReadOnly Property Symbol As ISymbol
Get
Property Value
Type: ISymbol
The value symbol.
Reference
SymbolNotification Class
TwinCAT.Ads.Reactive Namespace


SymbolNotification.Value Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] SymbolNotification Class [image] SymbolNotification Properties [image] SymbolNotification.Value Property
SymbolNotification.Value Property
Gets the value of the Notification.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public override Object Value { get; }
VB
Public Overrides ReadOnly Property Value As Object
Get
Property Value
Type: Object
The value.
Reference
SymbolNotification Class
TwinCAT.Ads.Reactive Namespace


SymbolNotification Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] SymbolNotification Class [image] SymbolNotification Methods
SymbolNotification Methods
The SymbolNotification type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
SymbolNotification Class
TwinCAT.Ads.Reactive Namespace


ValueSymbolExtensions Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class
ValueSymbolExtensions Class
Extension class for TcAdsClient respective IAdsConnection to provide reactive ADS extensions for accessing symbols that are loaded by the IAdsSymbolLoaderFactory
Inheritance Hierarchy
System.Object
TwinCAT.Ads.Reactive.ValueSymbolExtensions
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static class ValueSymbolExtensions
VB
<ExtensionAttribute>
Public NotInheritable Class ValueSymbolExtensions
Methods
Name | Description
PollValuesAnnotated(IValueSymbol, IObservable.Unit.) | Polls the values as ValueChangedArgs sequence annotated value on trigger sequence
PollValuesAnnotated(IValueSymbol, TimeSpan) | Polls the values as ValueChangedArgs sequence with a specified period time.
WhenValueChanged(IValueSymbol) | Gets an observable sequence when the value of the IValueSymbol has changed.
WhenValueChanged(IAdsConnection, IEnumerable.ISymbol.) | Observable sequence of Values driven by ADS Notifications on the specified symbol.
WriteValues(IValueSymbol, IObservable.Object.) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
WriteValues(IValueSymbol, IObservable.Object., Action.Exception.) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
WriteValues(IValueSymbol, IObservable.Object., CancellationToken) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
WriteValues(IValueSymbol, IObservable.Object., Action.Exception., CancellationToken) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
Remarks
Reactive Extensions (Rx) are a library for composing asynchronous and event-based programs using observable sequences and LINQ-style query operators. Using Rx, developers represent asynchronous data streams with Observables, query asynchronous data streams using LINQ operators, and parameterize the concurrency in the asynchronous data streams using Schedulers. Simply put, Rx = Observables + LINQ + Schedulers. The ADS reactive extensions are build on top of this library to enable ADS Symbol and State Observables, seamlessly bound to the reactive extensions. To use the ADS reactive extensions the TwinCAT.Ads.Reactive Nuget package (or the included TwinCAT.Ads.Reactive.dll) must be referenced from All types within are contained in the ADS companion package "Beckhoff.TwinCAT.Ads.Reactive" which must be referenced separately. (Beckhoff.TwinCAT.Ads.Reactive package on Nuget).
Examples
The following sample shows how to observe Value changed Notifications with the reactive ValueSymbolExtensions from an IValueSymbol.
Observe a single changing ADS Symbol (ADS Notifications)
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo[1].CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

cycleCount.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 500, 5000); // optional: Change NotificationSettings on Symbol

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = cycleCount.WhenValueChanged().Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Examples
The following sample shows how to observe Value changed Notifications with the reactive ValueSymbolExtensions from an DynamicSymbol.
Observe a single changing ADS Symbol (ADS Notifications) with the dynamic language runtime (.NET DLR)
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo[1].CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

cycleCount.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 500, 5000); // optional: Change NotificationSettings on Symbol

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = cycleCount.WhenValueChanged().Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Examples
The same for more than one IValueSymbol.
Observe changing ADS Symbols (ADS Notifications)
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo.CycleCount"]; // UShort Type
IValueSymbol lastExecTime = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo.LastExecTime"]; // UInt Type

SymbolCollection symbols = new SymbolCollection();
symbols.Add(cycleCount);
symbols.Add(lastExecTime);

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

cycleCount.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange,500,5000); // optional: Change NotificationSettings on Symbol

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = client.WhenValueChanged(symbols).Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Examples
Here, the values are polled in a specific time period and sequential Reads are triggered (in opposite to ADS Notification in the latter example)
Observe changing ADS Symbols by polling (Read Polling)
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo[1].CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

// Take 20 Values in an Interval of 500ms
IDisposable subscription = cycleCount.PollValues(TimeSpan.FromMilliseconds(500)).Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Examples
In the following example it is demonstrated how to write Values sequentially to a IValueSymbol with the help of the reactive extensions.
Write sequences of values to the target
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information (Symbol 'i : INT' in PLC Global Variables list.
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["GVL.i"];

// Produces object Values 0,1,2,3 ... in seconds period
IObservable<object> timerObservable = Observable.Interval(TimeSpan.FromSeconds(1.0)).Select(i => (object)(short)i);

// Take 10 Values (0..9) and write them to GVL.i
IDisposable dispose = cycleCount.WriteValues(timerObservable.Take(10));

Console.ReadKey(); // Wait for Key press
dispose.Dispose(); // Dispose the Subscription
}
Reference
TwinCAT.Ads.Reactive Namespace
TwinCAT.Ads.Reactive.AdsClientExtensions
TwinCAT.Ads.Reactive.AnyTypeExtensions
Weiterführende Informationen
•
ValueSymbolExtensions Methods


ValueSymbolExtensions Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods
ValueSymbolExtensions Methods
Methods
Name | Description
PollValuesAnnotated(IValueSymbol, IObservable.Unit.) | Polls the values as ValueChangedArgs sequence annotated value on trigger sequence
PollValuesAnnotated(IValueSymbol, TimeSpan) | Polls the values as ValueChangedArgs sequence with a specified period time.
WhenValueChanged(IValueSymbol) | Gets an observable sequence when the value of the IValueSymbol has changed.
WhenValueChanged(IAdsConnection, IEnumerable.ISymbol.) | Observable sequence of Values driven by ADS Notifications on the specified symbol.
WriteValues(IValueSymbol, IObservable.Object.) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
WriteValues(IValueSymbol, IObservable.Object., Action.Exception.) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
WriteValues(IValueSymbol, IObservable.Object., CancellationToken) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
WriteValues(IValueSymbol, IObservable.Object., Action.Exception., CancellationToken) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
Reference
ValueSymbolExtensions Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
ValueSymbolExtensions.PollValuesAnnotated Method
•
ValueSymbolExtensions.WhenValueChanged Method
•
ValueSymbolExtensions.WriteValues Method


ValueSymbolExtensions.PollValuesAnnotated Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods [image] ValueSymbolExtensions.PollValuesAnnotated Method
ValueSymbolExtensions.PollValuesAnnotated Method
Overload List
Name | Description
PollValuesAnnotated(IValueSymbol, IObservable.Unit.) | Polls the values as ValueChangedArgs sequence annotated value on trigger sequence
PollValuesAnnotated(IValueSymbol, TimeSpan) | Polls the values as ValueChangedArgs sequence with a specified period time.
Reference
ValueSymbolExtensions Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
ValueSymbolExtensions.PollValuesAnnotated Method (IValueSymbol, IObservable.Unit.)
•
ValueSymbolExtensions.PollValuesAnnotated Method (IValueSymbol, TimeSpan)


ValueSymbolExtensions.PollValuesAnnotated Method (IValueSymbol, IObservable.Unit.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods [image] ValueSymbolExtensions.PollValuesAnnotated Method [image] ValueSymbolExtensions.PollValuesAnnotated Method (IValueSymbol, IObservable.Unit.)
ValueSymbolExtensions.PollValuesAnnotated Method (IValueSymbol, IObservable.Unit.)
Polls the values as ValueChangedArgs sequence annotated value on trigger sequence
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<ValueChangedArgs> PollValuesAnnotated(
this IValueSymbol symbol,
IObservable<Unit> trigger
)
VB
<ExtensionAttribute>
Public Shared Function PollValuesAnnotated (
symbol As IValueSymbol,
trigger As IObservable(Of Unit)
) As IObservable(Of ValueChangedArgs)
Parameters
symbol | Type: TwinCAT.TypeSystem.IValueSymbol The symbol.
trigger | Type: System.IObservable.Unit. The polling Trigger.
Return Value
Type: IObservable.ValueChangedArgs.
IObservable<ValueChangedArgs>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IValueSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
ValueSymbolExtensions Class
PollValuesAnnotated Overload
TwinCAT.Ads.Reactive Namespace


ValueSymbolExtensions.PollValuesAnnotated Method (IValueSymbol, TimeSpan)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods [image] ValueSymbolExtensions.PollValuesAnnotated Method [image] ValueSymbolExtensions.PollValuesAnnotated Method (IValueSymbol, TimeSpan)
ValueSymbolExtensions.PollValuesAnnotated Method (IValueSymbol, TimeSpan)
Polls the values as ValueChangedArgs sequence with a specified period time.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<ValueChangedArgs> PollValuesAnnotated(
this IValueSymbol symbol,
TimeSpan period
)
VB
<ExtensionAttribute>
Public Shared Function PollValuesAnnotated (
symbol As IValueSymbol,
period As TimeSpan
) As IObservable(Of ValueChangedArgs)
Parameters
symbol | Type: TwinCAT.TypeSystem.IValueSymbol The symbol.
period | Type: System.TimeSpan The polling period/interval.
Return Value
Type: IObservable.ValueChangedArgs.
IObservable<ValueChangedArgs>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IValueSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
ValueSymbolExtensions Class
PollValuesAnnotated Overload
TwinCAT.Ads.Reactive Namespace


ValueSymbolExtensions.WhenValueChanged Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods [image] ValueSymbolExtensions.WhenValueChanged Method
ValueSymbolExtensions.WhenValueChanged Method
Overload List
Name | Description
WhenValueChanged(IValueSymbol) | Gets an observable sequence when the value of the IValueSymbol has changed.
WhenValueChanged(IAdsConnection, IEnumerable.ISymbol.) | Observable sequence of Values driven by ADS Notifications on the specified symbol.
Reference
ValueSymbolExtensions Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
ValueSymbolExtensions.WhenValueChanged Method (IValueSymbol)
•
ValueSymbolExtensions.WhenValueChanged Method (IAdsConnection, IEnumerable.ISymbol.)


ValueSymbolExtensions.WhenValueChanged Method (IValueSymbol)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods [image] ValueSymbolExtensions.WhenValueChanged Method [image] ValueSymbolExtensions.WhenValueChanged Method (IValueSymbol)
ValueSymbolExtensions.WhenValueChanged Method (IValueSymbol)
Gets an observable sequence when the value of the IValueSymbol has changed.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<Object> WhenValueChanged(
this IValueSymbol symbol
)
VB
<ExtensionAttribute>
Public Shared Function WhenValueChanged (
symbol As IValueSymbol
) As IObservable(Of Object)
Parameters
symbol
Type: TwinCAT.TypeSystem.IValueSymbol
The symbol.
Return Value
Type: IObservable.Object.
IObservable<System.Object>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IValueSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
The following sample shows how to observe Value changed Notifications with the reactive ValueSymbolExtensions from an IValueSymbol.
Observe a single changing ADS Symbols (ADS Notifications)
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo[1].CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

cycleCount.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 500, 5000); // optional: Change NotificationSettings on Symbol

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = cycleCount.WhenValueChanged().Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Reference
ValueSymbolExtensions Class
WhenValueChanged Overload
TwinCAT.Ads.Reactive Namespace


ValueSymbolExtensions.WhenValueChanged Method (IAdsConnection, IEnumerable.ISymbol.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods [image] ValueSymbolExtensions.WhenValueChanged Method [image] ValueSymbolExtensions.WhenValueChanged Method (IAdsConnection, IEnumerable.ISymbol.)
ValueSymbolExtensions.WhenValueChanged Method (IAdsConnection, IEnumerable.ISymbol.)
Observable sequence of Values driven by ADS Notifications on the specified symbol.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IObservable<Object> WhenValueChanged(
this IAdsConnection connection,
IEnumerable<ISymbol> symbols
)
VB
<ExtensionAttribute>
Public Shared Function WhenValueChanged (
connection As IAdsConnection,
symbols As IEnumerable(Of ISymbol)
) As IObservable(Of Object)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The ADS connection / ADS Client
symbols | Type: System.Collections.Generic.IEnumerable.ISymbol. The symbols to observe.
Return Value
Type: IObservable.Object.
IObservable<ValueChangedArgs>.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAdsConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
The same for more than one IValueSymbol.
Observe changing ADS Symbols (ADS Notifications)
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo.CycleCount"]; // UShort Type
IValueSymbol lastExecTime = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo.LastExecTime"]; // UInt Type

SymbolCollection symbols = new SymbolCollection();
symbols.Add(cycleCount);
symbols.Add(lastExecTime);

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

cycleCount.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange,500,5000); // optional: Change NotificationSettings on Symbol

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = client.WhenValueChanged(symbols).Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Examples
The following sample shows how to observe Value changed Notifications with the reactive ValueSymbolExtensions from an DynamicSymbol.
Observe a single changing ADS Symbol (ADS Notifications) with the dynamic language runtime (.NET DLR)
// To Test the Observer run a project on the local PLC System (Port 851)
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["TwinCAT_SystemInfoVarList._TaskInfo[1].CycleCount"];

// Reactive Notification Handler
var valueObserver = Observer.Create<object>(val =>
{
Console.WriteLine(string.Format("Instance: {0}, Value: {1}", cycleCount.InstancePath, val.ToString()));
}
);

cycleCount.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 500, 5000); // optional: Change NotificationSettings on Symbol

// Turning ADS Notifications into sequences of Value Objects (Taking 20 Values)
// and subscribe to them.
IDisposable subscription = cycleCount.WhenValueChanged().Take(20).Subscribe(valueObserver);

Console.ReadKey(); // Wait for Key press
subscription.Dispose(); // Dispose the Subscription
}
Reference
ValueSymbolExtensions Class
WhenValueChanged Overload
TwinCAT.Ads.Reactive Namespace
Observable


ValueSymbolExtensions.WriteValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods [image] ValueSymbolExtensions.WriteValues Method
ValueSymbolExtensions.WriteValues Method
Overload List
Name | Description
WriteValues(IValueSymbol, IObservable.Object.) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
WriteValues(IValueSymbol, IObservable.Object., Action.Exception.) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
WriteValues(IValueSymbol, IObservable.Object., CancellationToken) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
WriteValues(IValueSymbol, IObservable.Object., Action.Exception., CancellationToken) | Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
Reference
ValueSymbolExtensions Class
TwinCAT.Ads.Reactive Namespace
Weiterführende Informationen
•
ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object.)
•
ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., Action.Exception.)
•
ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., CancellationToken)
•
ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., Action.Exception., CancellationToken)


ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods [image] ValueSymbolExtensions.WriteValues Method [image] ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object.)
ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object.)
Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IDisposable WriteValues(
this IValueSymbol symbol,
IObservable<Object> valueObservable
)
VB
<ExtensionAttribute>
Public Shared Function WriteValues (
symbol As IValueSymbol,
valueObservable As IObservable(Of Object)
) As IDisposable
Parameters
symbol | Type: TwinCAT.TypeSystem.IValueSymbol The symbol.
valueObservable | Type: System.IObservable.Object. Observable of Values.
Return Value
Type: IDisposable
IDisposable.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IValueSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
In the following example it is demonstrated how to write Values sequentially to a IValueSymbol with the help of the reactive extensions.
Write sequences of values to the target
using (TcAdsClient client = new TcAdsClient())
{
// Connect to target
client.Connect(new AmsAddress(AmsNetId.Local, 851));

// Create Symbol information (Symbol 'i : INT' in PLC Global Variables list.
var symbolLoader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
IValueSymbol cycleCount = (IValueSymbol)symbolLoader.Symbols["GVL.i"];

// Produces object Values 0,1,2,3 ... in seconds period
IObservable<object> timerObservable = Observable.Interval(TimeSpan.FromSeconds(1.0)).Select(i => (object)(short)i);

// Take 10 Values (0..9) and write them to GVL.i
IDisposable dispose = cycleCount.WriteValues(timerObservable.Take(10));

Console.ReadKey(); // Wait for Key press
dispose.Dispose(); // Dispose the Subscription
}
Reference
ValueSymbolExtensions Class
WriteValues Overload
TwinCAT.Ads.Reactive Namespace


ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., Action.Exception.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods [image] ValueSymbolExtensions.WriteValues Method [image] ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., Action.Exception.)
ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., Action.Exception.)
Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static IDisposable WriteValues(
this IValueSymbol symbol,
IObservable<Object> valueObservable,
Action<Exception> errorHandler
)
VB
<ExtensionAttribute>
Public Shared Function WriteValues (
symbol As IValueSymbol,
valueObservable As IObservable(Of Object),
errorHandler As Action(Of Exception)
) As IDisposable
Parameters
symbol | Type: TwinCAT.TypeSystem.IValueSymbol The symbol.
valueObservable | Type: System.IObservable.Object. Observable of Values.
errorHandler | Type: System.Action.Exception. The error handler or NULL.
Return Value
Type: IDisposable
IDisposable.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IValueSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
ValueSymbolExtensions Class
WriteValues Overload
TwinCAT.Ads.Reactive Namespace


ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., CancellationToken)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods [image] ValueSymbolExtensions.WriteValues Method [image] ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., CancellationToken)
ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., CancellationToken)
Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static void WriteValues(
this IValueSymbol symbol,
IObservable<Object> valueObservable,
CancellationToken cancel
)
VB
<ExtensionAttribute>
Public Shared Sub WriteValues (
symbol As IValueSymbol,
valueObservable As IObservable(Of Object),
cancel As CancellationToken
)
Parameters
symbol | Type: TwinCAT.TypeSystem.IValueSymbol The symbol.
valueObservable | Type: System.IObservable.Object. Observable of Values.
cancel | Type: System.Threading.CancellationToken The cancellation token.
Return Value
Type:
IDisposable.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IValueSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
ValueSymbolExtensions Class
WriteValues Overload
TwinCAT.Ads.Reactive Namespace


ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., Action.Exception., CancellationToken)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.Reactive Namespace [image] ValueSymbolExtensions Class [image] ValueSymbolExtensions Methods [image] ValueSymbolExtensions.WriteValues Method [image] ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., Action.Exception., CancellationToken)
ValueSymbolExtensions.WriteValues Method (IValueSymbol, IObservable.Object., Action.Exception., CancellationToken)
Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol.
Namespace: TwinCAT.Ads.Reactive
Assembly: TwinCAT.Ads.Reactive (in TwinCAT.Ads.Reactive.dll) Version: 4.3.0.0 (4.3.7.0)
Syntax
C#
public static void WriteValues(
this IValueSymbol symbol,
IObservable<Object> valueObservable,
Action<Exception> errorHandler,
CancellationToken cancel
)
VB
<ExtensionAttribute>
Public Shared Sub WriteValues (
symbol As IValueSymbol,
valueObservable As IObservable(Of Object),
errorHandler As Action(Of Exception),
cancel As CancellationToken
)
Parameters
symbol | Type: TwinCAT.TypeSystem.IValueSymbol The symbol.
valueObservable | Type: System.IObservable.Object. Observable of Values.
errorHandler | Type: System.Action.Exception. The error handler.
cancel | Type: System.Threading.CancellationToken The cancellation token.
Return Value
Type:
IDisposable.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IValueSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Reference
ValueSymbolExtensions Class
WriteValues Overload
TwinCAT.Ads.Reactive Namespace


TwinCAT.Ads.SumCommand Namespace

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace
TwinCAT.Ads.SumCommand Namespace
ADS offers powerful and fast communication to exchange any kind of information. It's possible to read single variables or complete arrays and structures with each one single ADS-API call. ADS Sum-Commands offer to read/write with one single ADS call multiple variables which are not structured within a linear memory, effectivly reducing roundtrips.
Classes
Class | Description
SumCreateHandles | SumCommand for getting variable handles by a set of InstancePaths
SumHandleRead | Read (primitive, Any) values by Handle SumCommand.
SumHandleWrite | Write any (primitive) values by Handle SumCommand.
SumReleaseHandles | Release Handles SumCommand.
SumSymbolRead | Symbolic ADS Sum read access
SumSymbolWrite | Class for ADS Sum symbolic Write Access.
Interfaces
Interface | Description
ISumCommand | Interface for SumCommands (Combined commands)
Weiterführende Informationen
•
ISumCommand Interface
•
SumCreateHandles Class
•
SumHandleRead Class
•
SumHandleWrite Class
•
SumReleaseHandles Class
•
SumSymbolRead Class
•
SumSymbolWrite Class


ISumCommand Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] ISumCommand Interface
ISumCommand Interface
Interface for SumCommands (Combined commands)
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISumCommand
VB
Public Interface ISumCommand
The ISumCommand type exposes the following members.
Properties
Name | Description
Executed | Gets a value indicating whether this ISumCommand was already executed.
Failed | Gets a value indicating whether this ISumCommand failed.
Result | Gets teh AdsErrorCode of the main SumCommand ADS Request
SubResults | Gets the sub results of the single Sub Requests.
Succeeded | Gets a value indicating whether this ISumCommand is succeeded.
Remarks
ADS offers powerful and fast communication to exchange any kind of information. It's possible to read single variables or complete arrays and structures with each one single ADS-API call. The ADS Sum Command command offers to read with one singale ADS call multiple variables which are not structured within a linear memory. As a result the ADS caller application (like scada Systems etc.) can extremly speed up cyclic polling : Sample :
▪
Until now : Polling 4000 single variables which are not in a linear area (like array / structure / fixed PLC address ) would cause 4000 single Ads-ReadReq with each 1-2 ms protocol time. As a result the scanning of these variables take 4000ms-8000ms.
▪
New Ads-Command allows to read multiple variables with one single ADS-ReadReq : 4000 single variables are handled with e.g. 8 single Ads-ReadReq (each call requesting 500 variables) with each 1-2 ms protocol time. As a result the scanning of these variables take just few 10ms.
REQUIREMENTS AND IMPORTANT LIMITATIONS: Note that ADS is just a transport layer, but there could be important side effects. So read this requirements and take care on limitations:
▪
Version of target ADS Device - - ADS itself is just the transport layer, but the requested ADS device has to support the ADS-Command.
▪
Bytes length of requested data - - Requesting a large list of values from variables is fine, but the requested data of the Ads-response (the data-byte-length) have to pass the AMS Router (size by default a 2048kb) So the caller has to limit the requested variables based on calculation of requested data-byte-length.
▪
Number of Sub-ADS calls : Highly recommended to max. 500 ! - - If the PLC is processing one ADS request, it will completely work on this single ADS request BEFORE starting neyt PLC cycle. As a result one single ADS request with 200.000 sub-Ads-requests would cause that PLC would collect and copy 200.000 variables into one single ADS response, before starting next PLC. So this large number of ads-sub-commands will jitter the PLC execution ! We highly recommend to not request more than 500 Ads-Sub commands
Reference
TwinCAT.Ads.SumCommand Namespace
Weiterführende Informationen
•
ISumCommand Properties


ISumCommand Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] ISumCommand Interface [image] ISumCommand Properties
ISumCommand Properties
The ISumCommand type exposes the following members.
Properties
Name | Description
Executed | Gets a value indicating whether this ISumCommand was already executed.
Failed | Gets a value indicating whether this ISumCommand failed.
Result | Gets teh AdsErrorCode of the main SumCommand ADS Request
SubResults | Gets the sub results of the single Sub Requests.
Succeeded | Gets a value indicating whether this ISumCommand is succeeded.
Reference
ISumCommand Interface
TwinCAT.Ads.SumCommand Namespace
Weiterführende Informationen
•
ISumCommand.Executed Property
•
ISumCommand.Failed Property
•
ISumCommand.Result Property
•
ISumCommand.SubResults Property
•
ISumCommand.Succeeded Property


ISumCommand.Executed Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] ISumCommand Interface [image] ISumCommand Properties [image] ISumCommand.Executed Property
ISumCommand.Executed Property
Gets a value indicating whether this ISumCommand was already executed.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool Executed { get; }
VB
ReadOnly Property Executed As Boolean
Get
Property Value
Type: Boolean
true if executed; otherwise, false.
Reference
ISumCommand Interface
TwinCAT.Ads.SumCommand Namespace


ISumCommand.Failed Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] ISumCommand Interface [image] ISumCommand Properties [image] ISumCommand.Failed Property
ISumCommand.Failed Property
Gets a value indicating whether this ISumCommand failed.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool Failed { get; }
VB
ReadOnly Property Failed As Boolean
Get
Property Value
Type: Boolean
true if failed; otherwise, false.
Reference
ISumCommand Interface
TwinCAT.Ads.SumCommand Namespace


ISumCommand.Result Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] ISumCommand Interface [image] ISumCommand Properties [image] ISumCommand.Result Property
ISumCommand.Result Property
Gets teh AdsErrorCode of the main SumCommand ADS Request
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode Result { get; }
VB
ReadOnly Property Result As AdsErrorCode
Get
Property Value
Type: AdsErrorCode
The result.
Reference
ISumCommand Interface
TwinCAT.Ads.SumCommand Namespace


ISumCommand.SubResults Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] ISumCommand Interface [image] ISumCommand Properties [image] ISumCommand.SubResults Property
ISumCommand.SubResults Property
Gets the sub results of the single Sub Requests.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AdsErrorCode[] SubResults { get; }
VB
ReadOnly Property SubResults As AdsErrorCode()
Get
Property Value
Type: .AdsErrorCode.
The sub results.
Reference
ISumCommand Interface
TwinCAT.Ads.SumCommand Namespace


ISumCommand.Succeeded Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] ISumCommand Interface [image] ISumCommand Properties [image] ISumCommand.Succeeded Property
ISumCommand.Succeeded Property
Gets a value indicating whether this ISumCommand is succeeded.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool Succeeded { get; }
VB
ReadOnly Property Succeeded As Boolean
Get
Property Value
Type: Boolean
true if succeeded; otherwise, false.
Reference
ISumCommand Interface
TwinCAT.Ads.SumCommand Namespace


SumCreateHandles Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumCreateHandles Class
SumCreateHandles Class
SumCommand for getting variable handles by a set of InstancePaths
Inheritance Hierarchy
System.Object
SumCommandWrapper.SumReadWrite.
TwinCAT.Ads.SumCommand.SumCreateHandles
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SumCreateHandles : SumCommandWrapper<SumReadWrite>
VB
Public Class SumCreateHandles
Inherits SumCommandWrapper(Of SumReadWrite)
The SumCreateHandles type exposes the following members.
Constructors
Name | Description
SumCreateHandles(IAdsConnection, IList.String.) | Initializes a new instance of the SumCreateHandles class.
SumCreateHandles(IAdsConnection, .String.) | Initializes a new instance of the SumCreateHandles class.
Methods
Name | Description
CreateHandles | Creates the ADS handles.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Examples
Usage of Sum commands with handles (CreateHandles, Read, Write, ReleaseHandles)
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

// Parse the command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect the AdsClient to the device target.
client.Connect(address);

string[] instancePathList = {"GVL.bVar", "GVL.iCount", "TwinCAT_SystemInfoVarList._AppInfo.ProjectName"};
SumCreateHandles createHandlesCommand = new SumCreateHandles(client,instancePathList);

uint[] handles = createHandlesCommand.CreateHandles();
Type[] valueTypes = new Type[] { typeof(bool), typeof(short), typeof(string)};

SumHandleRead readCommand = new SumHandleRead(client,handles,valueTypes);

object[] readValues = readCommand.Read();

for (int i = 0; i < instancePathList.Length; i++)
{
Console.WriteLine("Symbol: {0} (Value: {1}, Type: {2})",instancePathList[i],readValues[i].ToString(),valueTypes[i].Name);
}

// Sum Command Write
SumHandleWrite writeCommand = new SumHandleWrite(client,handles,valueTypes);
object[] writeValues = new object[] {true, (short) 42, "MyNewProjectName"};

writeCommand.Write(writeValues);

SumReleaseHandles releaseCommand = new SumReleaseHandles(client,handles);
releaseCommand.ReleaseHandles();
}

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Reference
TwinCAT.Ads.SumCommand Namespace
TwinCAT.Ads.SumCommand.ISumCommand
TwinCAT.Ads.SumCommand.SumReleaseHandles
TwinCAT.Ads.SumCommand.SumHandleRead
TwinCAT.Ads.SumCommand.SumHandleWrite
Weiterführende Informationen
•
SumCreateHandles Constructor
•
SumCreateHandles Methods


SumCreateHandles Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumCreateHandles Class [image] SumCreateHandles Constructor
SumCreateHandles Constructor
Overload List
Name | Description
SumCreateHandles(IAdsConnection, IList.String.) | Initializes a new instance of the SumCreateHandles class.
SumCreateHandles(IAdsConnection, .String.) | Initializes a new instance of the SumCreateHandles class.
Reference
SumCreateHandles Class
TwinCAT.Ads.SumCommand Namespace
Weiterführende Informationen
•
SumCreateHandles Constructor (IAdsConnection, IList.String.)
•
SumCreateHandles Constructor (IAdsConnection, .String.)


SumCreateHandles Constructor (IAdsConnection, IList.String.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumCreateHandles Class [image] SumCreateHandles Constructor [image] SumCreateHandles Constructor (IAdsConnection, IList.String.)
SumCreateHandles Constructor (IAdsConnection, IList.String.)
Initializes a new instance of the SumCreateHandles class.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SumCreateHandles(
IAdsConnection connection,
IList<string> instancePaths
)
VB
Public Sub New (
connection As IAdsConnection,
instancePaths As IList(Of String)
)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePaths | Type: System.Collections.Generic.IList.String. The instance paths.
Reference
SumCreateHandles Class
SumCreateHandles Overload
TwinCAT.Ads.SumCommand Namespace


SumCreateHandles Constructor (IAdsConnection, .String.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumCreateHandles Class [image] SumCreateHandles Constructor [image] SumCreateHandles Constructor (IAdsConnection, .String.)
SumCreateHandles Constructor (IAdsConnection, .String.)
Initializes a new instance of the SumCreateHandles class.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SumCreateHandles(
IAdsConnection connection,
string[] instancePaths
)
VB
Public Sub New (
connection As IAdsConnection,
instancePaths As String()
)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
instancePaths | Type: .System.String. The instance paths.
Reference
SumCreateHandles Class
SumCreateHandles Overload
TwinCAT.Ads.SumCommand Namespace


SumCreateHandles Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumCreateHandles Class [image] SumCreateHandles Methods
SumCreateHandles Methods
The SumCreateHandles type exposes the following members.
Methods
Name | Description
CreateHandles | Creates the ADS handles.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
SumCreateHandles Class
TwinCAT.Ads.SumCommand Namespace
Weiterführende Informationen
•
SumCreateHandles.CreateHandles Method


SumCreateHandles.CreateHandles Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumCreateHandles Class [image] SumCreateHandles Methods [image] SumCreateHandles.CreateHandles Method
SumCreateHandles.CreateHandles Method
Creates the ADS handles.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public uint[] CreateHandles()
VB
Public Function CreateHandles As UInteger()
Return Value
Type: .UInt32.
System.UInt32[].
Exceptions
Exception | Condition
AdsSumCommandException | SumGetHandlesCommand failed!
Reference
SumCreateHandles Class
TwinCAT.Ads.SumCommand Namespace


SumHandleRead Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumHandleRead Class
SumHandleRead Class
Read (primitive, Any) values by Handle SumCommand.
Inheritance Hierarchy
System.Object
SumCommand
SumRead
TwinCAT.Ads.SumCommand.SumHandleRead
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SumHandleRead : SumRead
VB
Public Class SumHandleRead
Inherits SumRead
The SumHandleRead type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads the values.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryRead | Tries to read the values of the .
Remarks
This is an ADS Sum Command to access values by handle information. It is always used in combination with and . By design (and in contrast to the symbolic access in SumSymbolRead, SumSymbolWrite) this access method can act only with ADS ANY Type (Primitive) values (disadvantage). The Advantage is, that no symbolic information must be loaded before accessing the values, see samples:
Examples
Usage of Sum commands with handles (CreateHandles, Read, Write, ReleaseHandles)
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

// Parse the command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect the AdsClient to the device target.
client.Connect(address);

string[] instancePathList = {"GVL.bVar", "GVL.iCount", "TwinCAT_SystemInfoVarList._AppInfo.ProjectName"};
SumCreateHandles createHandlesCommand = new SumCreateHandles(client,instancePathList);

uint[] handles = createHandlesCommand.CreateHandles();
Type[] valueTypes = new Type[] { typeof(bool), typeof(short), typeof(string)};

SumHandleRead readCommand = new SumHandleRead(client,handles,valueTypes);

object[] readValues = readCommand.Read();

for (int i = 0; i < instancePathList.Length; i++)
{
Console.WriteLine("Symbol: {0} (Value: {1}, Type: {2})",instancePathList[i],readValues[i].ToString(),valueTypes[i].Name);
}

// Sum Command Write
SumHandleWrite writeCommand = new SumHandleWrite(client,handles,valueTypes);
object[] writeValues = new object[] {true, (short) 42, "MyNewProjectName"};

writeCommand.Write(writeValues);

SumReleaseHandles releaseCommand = new SumReleaseHandles(client,handles);
releaseCommand.ReleaseHandles();
}

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Reference
TwinCAT.Ads.SumCommand Namespace
TwinCAT.Ads.SumCommand.SumCreateHandles
TwinCAT.Ads.SumCommand.SumReleaseHandles
TwinCAT.Ads.SumCommand.ISumCommand
TwinCAT.Ads.SumCommand.SumReleaseHandles
TwinCAT.Ads.SumCommand.SumReleaseHandles
TwinCAT.Ads.SumCommand.SumHandleWrite
Weiterführende Informationen
•
SumHandleRead Methods


SumHandleRead Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumHandleRead Class [image] SumHandleRead Methods
SumHandleRead Methods
The SumHandleRead type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads the values.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryRead | Tries to read the values of the .
Reference
SumHandleRead Class
TwinCAT.Ads.SumCommand Namespace
Weiterführende Informationen
•
SumHandleRead.Read Method
•
SumHandleRead.TryRead Method


SumHandleRead.Read Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumHandleRead Class [image] SumHandleRead Methods [image] SumHandleRead.Read Method
SumHandleRead.Read Method
Reads the values.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object[] Read()
VB
Public Function Read As Object()
Return Value
Type: .Object.
System.Object[].
Exceptions
Exception | Condition
AdsSumCommandException | SumAnyReadByHandleCommand failed!
Reference
SumHandleRead Class
TwinCAT.Ads.SumCommand Namespace


SumHandleRead.TryRead Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumHandleRead Class [image] SumHandleRead Methods [image] SumHandleRead.TryRead Method
SumHandleRead.TryRead Method
Tries to read the values of the .
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryRead(
out Object[] values,
out AdsErrorCode[] returnCodes
)
VB
Public Function TryRead (
<OutAttribute> ByRef values As Object(),
<OutAttribute> ByRef returnCodes As AdsErrorCode()
) As AdsErrorCode
Parameters
values | Type: .System.Object.. The values.
returnCodes | Type: .TwinCAT.Ads.AdsErrorCode.. The return codes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
SumHandleRead Class
TwinCAT.Ads.SumCommand Namespace
TwinCAT.Ads.SumCommand.SumHandleRead


SumHandleWrite Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumHandleWrite Class
SumHandleWrite Class
Write any (primitive) values by Handle SumCommand.
Inheritance Hierarchy
System.Object
SumCommand
SumWrite
TwinCAT.Ads.SumCommand.SumHandleWrite
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SumHandleWrite : SumWrite
VB
Public Class SumHandleWrite
Inherits SumWrite
The SumHandleWrite type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryWrite | Tries to write the values.
Write | Writes the values to the Symbols.
Remarks
This is an ADS Sum Command to access values by handle information. It is always used in combination with and . By design (and in contrast to the symbolic access in SumSymbolRead, SumSymbolWrite) this access method can act only with ADS ANY Type (Primitive) values (disadvantage). The Advantage is, that no symbolic information must be loaded before accessing the values, see samples:
Examples
Usage of Sum commands with handles (CreateHandles, Read, Write, ReleaseHandles)
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

// Parse the command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect the AdsClient to the device target.
client.Connect(address);

string[] instancePathList = {"GVL.bVar", "GVL.iCount", "TwinCAT_SystemInfoVarList._AppInfo.ProjectName"};
SumCreateHandles createHandlesCommand = new SumCreateHandles(client,instancePathList);

uint[] handles = createHandlesCommand.CreateHandles();
Type[] valueTypes = new Type[] { typeof(bool), typeof(short), typeof(string)};

SumHandleRead readCommand = new SumHandleRead(client,handles,valueTypes);

object[] readValues = readCommand.Read();

for (int i = 0; i < instancePathList.Length; i++)
{
Console.WriteLine("Symbol: {0} (Value: {1}, Type: {2})",instancePathList[i],readValues[i].ToString(),valueTypes[i].Name);
}

// Sum Command Write
SumHandleWrite writeCommand = new SumHandleWrite(client,handles,valueTypes);
object[] writeValues = new object[] {true, (short) 42, "MyNewProjectName"};

writeCommand.Write(writeValues);

SumReleaseHandles releaseCommand = new SumReleaseHandles(client,handles);
releaseCommand.ReleaseHandles();
}

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Reference
TwinCAT.Ads.SumCommand Namespace
TwinCAT.Ads.SumCommand.SumCreateHandles
TwinCAT.Ads.SumCommand.SumReleaseHandles
TwinCAT.Ads.SumCommand.ISumCommand
TwinCAT.Ads.SumCommand.SumReleaseHandles
TwinCAT.Ads.SumCommand.SumReleaseHandles
TwinCAT.Ads.SumCommand.SumHandleRead
Weiterführende Informationen
•
SumHandleWrite Methods


SumHandleWrite Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumHandleWrite Class [image] SumHandleWrite Methods
SumHandleWrite Methods
The SumHandleWrite type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryWrite | Tries to write the values.
Write | Writes the values to the Symbols.
Reference
SumHandleWrite Class
TwinCAT.Ads.SumCommand Namespace
Weiterführende Informationen
•
SumHandleWrite.TryWrite Method
•
SumHandleWrite.Write Method


SumHandleWrite.TryWrite Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumHandleWrite Class [image] SumHandleWrite Methods [image] SumHandleWrite.TryWrite Method
SumHandleWrite.TryWrite Method
Tries to write the values.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWrite(
Object[] values,
out AdsErrorCode[] returnCodes
)
VB
Public Function TryWrite (
values As Object(),
<OutAttribute> ByRef returnCodes As AdsErrorCode()
) As AdsErrorCode
Parameters
values | Type: .System.Object. The values (ANY/Primitive types only).
returnCodes | Type: .TwinCAT.Ads.AdsErrorCode.. The return codes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
SumHandleWrite Class
TwinCAT.Ads.SumCommand Namespace


SumHandleWrite.Write Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumHandleWrite Class [image] SumHandleWrite Methods [image] SumHandleWrite.Write Method
SumHandleWrite.Write Method
Writes the values to the Symbols.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
Object[] values
)
VB
Public Sub Write (
values As Object()
)
Parameters
values
Type: .System.Object.
The Values (Any primitive types only):
Exceptions
Exception | Condition
AdsSumCommandException | SumAnyWriteByHandleCommand failed!
Reference
SumHandleWrite Class
TwinCAT.Ads.SumCommand Namespace


SumReleaseHandles Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumReleaseHandles Class
SumReleaseHandles Class
Release Handles SumCommand.
Inheritance Hierarchy
System.Object
SumCommandWrapper.SumWrite.
TwinCAT.Ads.SumCommand.SumReleaseHandles
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SumReleaseHandles : SumCommandWrapper<SumWrite>
VB
Public Class SumReleaseHandles
Inherits SumCommandWrapper(Of SumWrite)
The SumReleaseHandles type exposes the following members.
Constructors
Name | Description
SumReleaseHandles | Initializes a new instance of the SumReleaseHandles class.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReleaseHandles | Releases the handles.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryReleaseHandles | Tries to Release the Handles
Remarks
Releases the specified ADS handles. Usually used in conjunction with the SumCreateHandles and the SumHandleRead / SumHandleWrite commands.
Examples
Usage of Sum commands with handles (CreateHandles, Read, Write, ReleaseHandles)
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

// Parse the command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect the AdsClient to the device target.
client.Connect(address);

string[] instancePathList = {"GVL.bVar", "GVL.iCount", "TwinCAT_SystemInfoVarList._AppInfo.ProjectName"};
SumCreateHandles createHandlesCommand = new SumCreateHandles(client,instancePathList);

uint[] handles = createHandlesCommand.CreateHandles();
Type[] valueTypes = new Type[] { typeof(bool), typeof(short), typeof(string)};

SumHandleRead readCommand = new SumHandleRead(client,handles,valueTypes);

object[] readValues = readCommand.Read();

for (int i = 0; i < instancePathList.Length; i++)
{
Console.WriteLine("Symbol: {0} (Value: {1}, Type: {2})",instancePathList[i],readValues[i].ToString(),valueTypes[i].Name);
}

// Sum Command Write
SumHandleWrite writeCommand = new SumHandleWrite(client,handles,valueTypes);
object[] writeValues = new object[] {true, (short) 42, "MyNewProjectName"};

writeCommand.Write(writeValues);

SumReleaseHandles releaseCommand = new SumReleaseHandles(client,handles);
releaseCommand.ReleaseHandles();
}

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Reference
TwinCAT.Ads.SumCommand Namespace
TwinCAT.Ads.SumCommand.ISumCommand
TwinCAT.Ads.SumCommand.SumCreateHandles
TwinCAT.Ads.SumCommand.SumHandleRead
TwinCAT.Ads.SumCommand.SumHandleWrite
Weiterführende Informationen
•
SumReleaseHandles Constructor
•
SumReleaseHandles Methods


SumReleaseHandles Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumReleaseHandles Class [image] SumReleaseHandles Constructor
SumReleaseHandles Constructor
Initializes a new instance of the SumReleaseHandles class.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SumReleaseHandles(
IAdsConnection connection,
uint[] serverHandles
)
VB
Public Sub New (
connection As IAdsConnection,
serverHandles As UInteger()
)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The connection.
serverHandles | Type: .System.UInt32. The handles.
Reference
SumReleaseHandles Class
TwinCAT.Ads.SumCommand Namespace


SumReleaseHandles Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumReleaseHandles Class [image] SumReleaseHandles Methods
SumReleaseHandles Methods
The SumReleaseHandles type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReleaseHandles | Releases the handles.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryReleaseHandles | Tries to Release the Handles
Reference
SumReleaseHandles Class
TwinCAT.Ads.SumCommand Namespace
Weiterführende Informationen
•
SumReleaseHandles.ReleaseHandles Method
•
SumReleaseHandles.TryReleaseHandles Method


SumReleaseHandles.ReleaseHandles Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumReleaseHandles Class [image] SumReleaseHandles Methods [image] SumReleaseHandles.ReleaseHandles Method
SumReleaseHandles.ReleaseHandles Method
Releases the handles.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void ReleaseHandles()
VB
Public Sub ReleaseHandles
Exceptions
Exception | Condition
AdsSumCommandException | SumReleaseHandlesCommand failed!
Reference
SumReleaseHandles Class
TwinCAT.Ads.SumCommand Namespace


SumReleaseHandles.TryReleaseHandles Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumReleaseHandles Class [image] SumReleaseHandles Methods [image] SumReleaseHandles.TryReleaseHandles Method
SumReleaseHandles.TryReleaseHandles Method
Tries to Release the Handles
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryReleaseHandles(
out AdsErrorCode[] returnCodes
)
VB
Public Function TryReleaseHandles (
<OutAttribute> ByRef returnCodes As AdsErrorCode()
) As AdsErrorCode
Parameters
returnCodes
Type: .TwinCAT.Ads.AdsErrorCode..
The return codes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Reference
SumReleaseHandles Class
TwinCAT.Ads.SumCommand Namespace


SumSymbolRead Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumSymbolRead Class
SumSymbolRead Class
Symbolic ADS Sum read access
Inheritance Hierarchy
System.Object
SumCommandWrapper.SumRead.
SumSymbolCommand.SumRead.
TwinCAT.Ads.SumCommand.SumSymbolRead
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SumSymbolRead : SumSymbolCommand<SumRead>
VB
Public Class SumSymbolRead
Inherits SumSymbolCommand(Of SumRead)
The SumSymbolRead type exposes the following members.
Constructors
Name | Description
SumSymbolRead | Initializes a new instance of the SumSymbolRead class.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads the Values.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryRead | Tries to read the specified symbols.
Remarks
The SumSymbolRead implements symbolic read access with automatic (dynamic) value marshalling. The advantage of the symbolic access is (in contrast to the handle access classes SumHandleRead,SumHandleWrite) that all type information is available when using this ADS Sum Command. The disadvantage is, that the Symbolic information must be loaded beforehand, see examples.
Examples
Usage of SumSymbolRead/SumSymbolWrite with AdsSession
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

// Parse the command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (AdsSession session = new AdsSession(address))
{
// Connect to the device target.
AdsConnection connection = (AdsConnection)session.Connect();

// Load symbolic information
ReadOnlySymbolCollection symbols = session.SymbolServer.Symbols;

ISymbol bVar1 = symbols["GVL.bVar1"];
ISymbol bVar2 = symbols["GVL.bVar2"];
ISymbol projectName = symbols["TwinCAT_SystemInfoVarList._AppInfo.ProjectName"];

SymbolCollection coll = new SymbolCollection() {bVar1, bVar2, projectName};

// Sum Command Read
SumSymbolRead readCommand = new SumSymbolRead(connection,coll);
object[] values = readCommand.Read();

for (int i = 0; i < coll.Count; i++)
{
Console.WriteLine("Symbol: {0} (Value: {1}, Type: {2})",coll[i].InstancePath,values[i].ToString(),values[i].GetType().Name);
}

// Sum Command Write
SumSymbolWrite writeCommand = new SumSymbolWrite(connection,coll);
object[] writeValues = new object[] {true, (short) 42, "MyNewProjectName"};

writeCommand.Write(writeValues);
}

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Examples
Usage of SumSymbolRead/SumSymbolWrite with TcAdsClient
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

// Parse the command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect the AdsClient to the device target.
client.Connect(address);

// Load symbolic information
ISymbolLoader loader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
ReadOnlySymbolCollection allSymbols = loader.Symbols;

ISymbol bVar1 = allSymbols["GVL.bVar1"];
ISymbol bVar2 = allSymbols["GVL.iCount"];
ISymbol projectName = allSymbols["TwinCAT_SystemInfoVarList._AppInfo.ProjectName"];

SymbolCollection symbols = new SymbolCollection() {bVar1, bVar2, projectName};

// Sum Command Read
SumSymbolRead readCommand = new SumSymbolRead(client,symbols);
object[] values = readCommand.Read();

for (int i = 0; i < symbols.Count; i++)
{
Console.WriteLine("Symbol: {0} (Value: {1}, Type: {2})",symbols[i].InstancePath,values[i].ToString(),values[i].GetType().Name);
}

// Sum Command Write
SumSymbolWrite writeCommand = new SumSymbolWrite(client,symbols);
object[] writeValues = new object[] {true, (short) 42, "MyNewProjectName"};

writeCommand.Write(writeValues);
}

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Reference
TwinCAT.Ads.SumCommand Namespace
TwinCAT.Ads.SumCommand.ISumCommand
TwinCAT.Ads.SumCommand.SumSymbolWrite
Weiterführende Informationen
•
SumSymbolRead Constructor
•
SumSymbolRead Methods


SumSymbolRead Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumSymbolRead Class [image] SumSymbolRead Constructor
SumSymbolRead Constructor
Initializes a new instance of the SumSymbolRead class.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SumSymbolRead(
IAdsConnection connection,
IList<ISymbol> symbols
)
VB
Public Sub New (
connection As IAdsConnection,
symbols As IList(Of ISymbol)
)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The TcAdsClient or ADS Connection object
symbols | Type: System.Collections.Generic.IList.ISymbol. The symbols to read
Reference
SumSymbolRead Class
TwinCAT.Ads.SumCommand Namespace


SumSymbolRead Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumSymbolRead Class [image] SumSymbolRead Methods
SumSymbolRead Methods
The SumSymbolRead type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads the Values.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryRead | Tries to read the specified symbols.
Reference
SumSymbolRead Class
TwinCAT.Ads.SumCommand Namespace
Weiterführende Informationen
•
SumSymbolRead.Read Method
•
SumSymbolRead.TryRead Method


SumSymbolRead.Read Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumSymbolRead Class [image] SumSymbolRead Methods [image] SumSymbolRead.Read Method
SumSymbolRead.Read Method
Reads the Values.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object[] Read()
VB
Public Function Read As Object()
Return Value
Type: .Object.
System.Object[].
Exceptions
Exception | Condition
AdsSumCommandException | SumSymbolRead failed!
Remarks
The return values are automatically marshalled to their appropriate .NET types.
Reference
SumSymbolRead Class
TwinCAT.Ads.SumCommand Namespace


SumSymbolRead.TryRead Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumSymbolRead Class [image] SumSymbolRead Methods [image] SumSymbolRead.TryRead Method
SumSymbolRead.TryRead Method
Tries to read the specified symbols.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryRead(
out Object[] values,
out AdsErrorCode[] returnCodes
)
VB
Public Function TryRead (
<OutAttribute> ByRef values As Object(),
<OutAttribute> ByRef returnCodes As AdsErrorCode()
) As AdsErrorCode
Parameters
values | Type: .System.Object.. The values.
returnCodes | Type: .TwinCAT.Ads.AdsErrorCode.. The return codes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Remarks
The returned values are automatically marshalled to their appropriate .NET types.
Reference
SumSymbolRead Class
TwinCAT.Ads.SumCommand Namespace


SumSymbolWrite Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumSymbolWrite Class
SumSymbolWrite Class
Class for ADS Sum symbolic Write Access.
Inheritance Hierarchy
System.Object
SumCommandWrapper.SumWrite.
SumSymbolCommand.SumWrite.
TwinCAT.Ads.SumCommand.SumSymbolWrite
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SumSymbolWrite : SumSymbolCommand<SumWrite>
VB
Public Class SumSymbolWrite
Inherits SumSymbolCommand(Of SumWrite)
The SumSymbolWrite type exposes the following members.
Constructors
Name | Description
SumSymbolWrite | Initializes a new instance of the SumSymbolWrite class.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryWrite | Tries the write.
Write | Writes the specified values.
Remarks
The SumSymbolWrite implements symbolic write access with automatic (dynamic) value marshalling. The advantage of the symbolic access is (in contrast to the handle access classes SumHandleRead,SumHandleWrite) that all type information is available when using this ADS Sum Command. The disadvantage is, that the Symbolic information must be loaded beforehand, see examples.
Examples
Usage of SumSymbolRead/SumSymbolWrite with AdsSession
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

// Parse the command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (AdsSession session = new AdsSession(address))
{
// Connect to the device target.
AdsConnection connection = (AdsConnection)session.Connect();

// Load symbolic information
ReadOnlySymbolCollection symbols = session.SymbolServer.Symbols;

ISymbol bVar1 = symbols["GVL.bVar1"];
ISymbol bVar2 = symbols["GVL.bVar2"];
ISymbol projectName = symbols["TwinCAT_SystemInfoVarList._AppInfo.ProjectName"];

SymbolCollection coll = new SymbolCollection() {bVar1, bVar2, projectName};

// Sum Command Read
SumSymbolRead readCommand = new SumSymbolRead(connection,coll);
object[] values = readCommand.Read();

for (int i = 0; i < coll.Count; i++)
{
Console.WriteLine("Symbol: {0} (Value: {1}, Type: {2})",coll[i].InstancePath,values[i].ToString(),values[i].GetType().Name);
}

// Sum Command Write
SumSymbolWrite writeCommand = new SumSymbolWrite(connection,coll);
object[] writeValues = new object[] {true, (short) 42, "MyNewProjectName"};

writeCommand.Write(writeValues);
}

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Examples
Usage of SumSymbolRead/SumSymbolWrite with TcAdsClient
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

// Parse the command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect the AdsClient to the device target.
client.Connect(address);

// Load symbolic information
ISymbolLoader loader = SymbolLoaderFactory.Create(client, SymbolLoaderSettings.Default);
ReadOnlySymbolCollection allSymbols = loader.Symbols;

ISymbol bVar1 = allSymbols["GVL.bVar1"];
ISymbol bVar2 = allSymbols["GVL.iCount"];
ISymbol projectName = allSymbols["TwinCAT_SystemInfoVarList._AppInfo.ProjectName"];

SymbolCollection symbols = new SymbolCollection() {bVar1, bVar2, projectName};

// Sum Command Read
SumSymbolRead readCommand = new SumSymbolRead(client,symbols);
object[] values = readCommand.Read();

for (int i = 0; i < symbols.Count; i++)
{
Console.WriteLine("Symbol: {0} (Value: {1}, Type: {2})",symbols[i].InstancePath,values[i].ToString(),values[i].GetType().Name);
}

// Sum Command Write
SumSymbolWrite writeCommand = new SumSymbolWrite(client,symbols);
object[] writeValues = new object[] {true, (short) 42, "MyNewProjectName"};

writeCommand.Write(writeValues);
}

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Reference
TwinCAT.Ads.SumCommand Namespace
TwinCAT.Ads.SumCommand.ISumCommand
TwinCAT.Ads.SumCommand.SumSymbolWrite
Weiterführende Informationen
•
SumSymbolWrite Constructor
•
SumSymbolWrite Methods


SumSymbolWrite Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumSymbolWrite Class [image] SumSymbolWrite Constructor
SumSymbolWrite Constructor
Initializes a new instance of the SumSymbolWrite class.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SumSymbolWrite(
IAdsConnection connection,
IList<ISymbol> symbols
)
VB
Public Sub New (
connection As IAdsConnection,
symbols As IList(Of ISymbol)
)
Parameters
connection | Type: TwinCAT.Ads.IAdsConnection The TcAdsClient or ADS Connection object
symbols | Type: System.Collections.Generic.IList.ISymbol. The symbols to read
Reference
SumSymbolWrite Class
TwinCAT.Ads.SumCommand Namespace


SumSymbolWrite Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumSymbolWrite Class [image] SumSymbolWrite Methods
SumSymbolWrite Methods
The SumSymbolWrite type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryWrite | Tries the write.
Write | Writes the specified values.
Reference
SumSymbolWrite Class
TwinCAT.Ads.SumCommand Namespace
Weiterführende Informationen
•
SumSymbolWrite.TryWrite Method
•
SumSymbolWrite.Write Method


SumSymbolWrite.TryWrite Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumSymbolWrite Class [image] SumSymbolWrite Methods [image] SumSymbolWrite.TryWrite Method
SumSymbolWrite.TryWrite Method
Tries the write.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AdsErrorCode TryWrite(
Object[] values,
out AdsErrorCode[] returnCodes
)
VB
Public Function TryWrite (
values As Object(),
<OutAttribute> ByRef returnCodes As AdsErrorCode()
) As AdsErrorCode
Parameters
values | Type: .System.Object. The values.
returnCodes | Type: .TwinCAT.Ads.AdsErrorCode.. The return codes.
Return Value
Type: AdsErrorCode
AdsErrorCode.
Remarks
The written values will be marshalled automatically to their appropriate ADS types.
Reference
SumSymbolWrite Class
TwinCAT.Ads.SumCommand Namespace


SumSymbolWrite.Write Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.SumCommand Namespace [image] SumSymbolWrite Class [image] SumSymbolWrite Methods [image] SumSymbolWrite.Write Method
SumSymbolWrite.Write Method
Writes the specified values.
Namespace: TwinCAT.Ads.SumCommand
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write(
Object[] values
)
VB
Public Sub Write (
values As Object()
)
Parameters
values
Type: .System.Object.
The values.
Exceptions
Exception | Condition
AdsSumCommandException | SumSymbolWrite failed!
Remarks
The values will be marshalled automatically to their appropriate ADS types.
Reference
SumSymbolWrite Class
TwinCAT.Ads.SumCommand Namespace


TwinCAT.Ads.TypeSystem Namespace

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace
TwinCAT.Ads.TypeSystem Namespace
Root namespace for the ADS type system.
Classes
Class | Description
AliasType | Alias DataType
ArrayType | Represents an Array DataType
BitMappingType | Helper Data Type to implement Bit mapping types.
DataType | DataType class
EnumType.T. | Enum DataType.
Field | Represents a field of an Struct/Alias/Union
Instance | Instance implementation
Member | Represents a member of an StructType
PointerType | Represents a pointer type.
PrimitiveType | Class PrimitiveType.
ReferenceType | Represents a reference type
RpcMethod | RPC Method Description
RpcMethodParameter | Class RpcMethodParameter.
RpcStructType | StructType which is callable by RPC Methods.
StringType | String DataType
StructType | Represents a struct type
SubRangeType.T. | Represents a SubRangType
Symbol | Symbol class
SymbolLoaderFactory | The class SymbolLoaderFactory is used to create a new instance of the AdsSymbolLoader initialized to the parametrized mode (SymbolBrowser V2, new Version)
UnionType | Represents a union type
WStringType | Represents an Unicode string (Wide string)
Interfaces
Interface | Description
IAdsSymbol | Interface IAdsSymbol
IAdsSymbolLoader | Symbol Loader interface
Weiterführende Informationen
•
AliasType Class
•
ArrayType Class
•
BitMappingType Class
•
DataType Class
•
EnumType.T. Class
•
Field Class
•
IAdsSymbol Interface
•
IAdsSymbolLoader Interface
•
Instance Class
•
Member Class
•
PointerType Class
•
PrimitiveType Class
•
ReferenceType Class
•
RpcMethod Class
•
RpcMethodParameter Class
•
RpcStructType Class
•
StringType Class
•
StructType Class
•
SubRangeType.T. Class
•
Symbol Class
•
SymbolLoaderFactory Class
•
UnionType Class
•
WStringType Class


AliasType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] AliasType Class
AliasType Class
Alias DataType
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.AliasType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class AliasType : DataType,
IAliasType, IDataType, IBitSize
VB
Public NotInheritable Class AliasType
Inherits DataType
Implements IAliasType, IDataType, IBitSize
The AliasType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BaseType | Gets the Base Type
BaseTypeName | Gets the BaseType name
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Overrides DataType.IsContainer.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Overrides DataType.IsPrimitive.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Overrides DataType.ManagedType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides DataType.ToString..)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
AliasType Properties
•
AliasType Methods


AliasType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] AliasType Class [image] AliasType Properties
AliasType Properties
The AliasType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BaseType | Gets the Base Type
BaseTypeName | Gets the BaseType name
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Overrides DataType.IsContainer.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Overrides DataType.IsPrimitive.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Overrides DataType.ManagedType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
AliasType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
AliasType.BaseType Property
•
AliasType.BaseTypeName Property
•
AliasType.IsContainer Property
•
AliasType.IsPrimitive Property
•
AliasType.ManagedType Property


AliasType.BaseType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] AliasType Class [image] AliasType Properties [image] AliasType.BaseType Property
AliasType.BaseType Property
Gets the Base Type
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType BaseType { get; }
VB
Public ReadOnly Property BaseType As IDataType
Get
Property Value
Type: IDataType
Implements
IAliasType.BaseType
Reference
AliasType Class
TwinCAT.Ads.TypeSystem Namespace


AliasType.BaseTypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] AliasType Class [image] AliasType Properties [image] AliasType.BaseTypeName Property
AliasType.BaseTypeName Property
Gets the BaseType name
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string BaseTypeName { get; }
VB
Public ReadOnly Property BaseTypeName As String
Get
Property Value
Type: String
Implements
IAliasType.BaseTypeName
Reference
AliasType Class
TwinCAT.Ads.TypeSystem Namespace


AliasType.IsContainer Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] AliasType Class [image] AliasType Properties [image] AliasType.IsContainer Property
AliasType.IsContainer Property
Gets a value indicating whether this IDataType is a container type
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool IsContainer { get; }
VB
Public Overrides ReadOnly Property IsContainer As Boolean
Get
Property Value
Type: Boolean
true if this instance is container type; otherwise, false.
Implements
IDataType.IsContainer
IDataType.IsContainer
Remarks
Container Types are all types that contain SubElements like
▪
Array
▪
Pointer
▪
Union
▪
Struct
▪
Function
▪
FunctionBlock
▪
Program
And the Alias types, if they have a container type as base type.
Reference
AliasType Class
TwinCAT.Ads.TypeSystem Namespace
IDataType.Category


AliasType.IsPrimitive Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] AliasType Class [image] AliasType Properties [image] AliasType.IsPrimitive Property
AliasType.IsPrimitive Property
Gets a value indicating whether this IDataType is primitive
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool IsPrimitive { get; }
VB
Public Overrides ReadOnly Property IsPrimitive As Boolean
Get
Property Value
Type: Boolean
true if this instance is primitive; otherwise, false.
Implements
IDataType.IsPrimitive
IDataType.IsPrimitive
Reference
AliasType Class
TwinCAT.Ads.TypeSystem Namespace


AliasType.ManagedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] AliasType Class [image] AliasType Properties [image] AliasType.ManagedType Property
AliasType.ManagedType Property
Gets the corresponding .NET Type if attached.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override Type ManagedType { get; }
VB
Public Overrides ReadOnly Property ManagedType As Type
Get
Property Value
Type: Type
Dot net type.
Reference
AliasType Class
TwinCAT.Ads.TypeSystem Namespace


AliasType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] AliasType Class [image] AliasType Methods
AliasType Methods
The AliasType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides DataType.ToString..)
Reference
AliasType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
AliasType.ToString Method


AliasType.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] AliasType Class [image] AliasType Methods [image] AliasType.ToString Method
AliasType.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
AliasType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class
ArrayType Class
Represents an Array DataType
DataType class
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.ArrayType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ArrayType : DataType, IArrayType,
IDataType, IBitSize
VB
Public Class ArrayType
Inherits DataType
Implements IArrayType, IDataType, IBitSize
The ArrayType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
DimensionCount | Gets the dimension count.
Dimensions | Gets the dimensions as read only collection.
ElementCount | Gets the element count.
ElementSize | Gets the byte-size of a single element of the array
ElementType | Gets the type of the contained elements.
ElementTypeName | Gets the name of the element type.
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsJagged | Gets a value indicating whether this instance is jagged.
IsOversampled | Gets a value indicating whether this array instance describes an oversampling type.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Overrides DataType.IsPrimitive.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
JaggedLevel | Gets the jagged level (Non-Jagged Array have level 1)
ManagedType | Gets the corresponding .NET Type if attached. (Overrides DataType.ManagedType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Fields
Name | Description
_dimensions | Dimension information (for arrays)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
ArrayType Properties
•
ArrayType Methods
•
ArrayType Fields


ArrayType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties
ArrayType Properties
The ArrayType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
DimensionCount | Gets the dimension count.
Dimensions | Gets the dimensions as read only collection.
ElementCount | Gets the element count.
ElementSize | Gets the byte-size of a single element of the array
ElementType | Gets the type of the contained elements.
ElementTypeName | Gets the name of the element type.
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsJagged | Gets a value indicating whether this instance is jagged.
IsOversampled | Gets a value indicating whether this array instance describes an oversampling type.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Overrides DataType.IsPrimitive.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
JaggedLevel | Gets the jagged level (Non-Jagged Array have level 1)
ManagedType | Gets the corresponding .NET Type if attached. (Overrides DataType.ManagedType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
ArrayType.DimensionCount Property
•
ArrayType.Dimensions Property
•
ArrayType.ElementCount Property
•
ArrayType.ElementSize Property
•
ArrayType.ElementType Property
•
ArrayType.ElementTypeName Property
•
ArrayType.IsJagged Property
•
ArrayType.IsOversampled Property
•
ArrayType.IsPrimitive Property
•
ArrayType.JaggedLevel Property
•
ArrayType.ManagedType Property


ArrayType.DimensionCount Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties [image] ArrayType.DimensionCount Property
ArrayType.DimensionCount Property
Gets the dimension count.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int DimensionCount { get; }
VB
Public ReadOnly Property DimensionCount As Integer
Get
Property Value
Type: Int32
The dimension count.
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType.Dimensions Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties [image] ArrayType.Dimensions Property
ArrayType.Dimensions Property
Gets the dimensions as read only collection.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyDimensionCollection Dimensions { get; }
VB
Public ReadOnly Property Dimensions As ReadOnlyDimensionCollection
Get
Property Value
Type: ReadOnlyDimensionCollection
The dimensions.
Implements
IArrayType.Dimensions
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType.ElementCount Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties [image] ArrayType.ElementCount Property
ArrayType.ElementCount Property
Gets the element count.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ElementCount { get; }
VB
Public ReadOnly Property ElementCount As Integer
Get
Property Value
Type: Int32
The element count.
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType.ElementSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties [image] ArrayType.ElementSize Property
ArrayType.ElementSize Property
Gets the byte-size of a single element of the array
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ElementSize { get; }
VB
Public ReadOnly Property ElementSize As Integer
Get
Property Value
Type: Int32
The size of the element.
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType.ElementType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties [image] ArrayType.ElementType Property
ArrayType.ElementType Property
Gets the type of the contained elements.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType ElementType { get; }
VB
Public ReadOnly Property ElementType As IDataType
Get
Property Value
Type: IDataType
The type of the element.
Implements
IArrayType.ElementType
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType.ElementTypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties [image] ArrayType.ElementTypeName Property
ArrayType.ElementTypeName Property
Gets the name of the element type.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ElementTypeName { get; }
VB
Public ReadOnly Property ElementTypeName As String
Get
Property Value
Type: String
The name of the element type.
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType.IsJagged Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties [image] ArrayType.IsJagged Property
ArrayType.IsJagged Property
Gets a value indicating whether this instance is jagged.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsJagged { get; }
VB
Public ReadOnly Property IsJagged As Boolean
Get
Property Value
Type: Boolean
true if this instance is jagged; otherwise, false.
Implements
IArrayType.IsJagged
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType.IsOversampled Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties [image] ArrayType.IsOversampled Property
ArrayType.IsOversampled Property
Gets a value indicating whether this array instance describes an oversampling type.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsOversampled { get; }
VB
Public ReadOnly Property IsOversampled As Boolean
Get
Property Value
Type: Boolean
true if this instance is oversampling; otherwise, false.
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType.IsPrimitive Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties [image] ArrayType.IsPrimitive Property
ArrayType.IsPrimitive Property
Gets a value indicating whether this IDataType is primitive
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool IsPrimitive { get; }
VB
Public Overrides ReadOnly Property IsPrimitive As Boolean
Get
Property Value
Type: Boolean
true if this instance is primitive; otherwise, false.
Implements
IDataType.IsPrimitive
IDataType.IsPrimitive
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType.JaggedLevel Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties [image] ArrayType.JaggedLevel Property
ArrayType.JaggedLevel Property
Gets the jagged level (Non-Jagged Array have level 1)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int JaggedLevel { get; }
VB
Public ReadOnly Property JaggedLevel As Integer
Get
Property Value
Type: Int32
The jagged level.
Implements
IArrayType.JaggedLevel
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType.ManagedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Properties [image] ArrayType.ManagedType Property
ArrayType.ManagedType Property
Gets the corresponding .NET Type if attached.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override Type ManagedType { get; }
VB
Public Overrides ReadOnly Property ManagedType As Type
Get
Property Value
Type: Type
Dot net type.
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Methods
ArrayType Methods
The ArrayType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


ArrayType Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Fields
ArrayType Fields
The ArrayType type exposes the following members.
Fields
Name | Description
_dimensions | Dimension information (for arrays)
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
ArrayType._dimensions Field


ArrayType._dimensions Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ArrayType Class [image] ArrayType Fields [image] ArrayType._dimensions Field
ArrayType._dimensions Field
Dimension information (for arrays)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected DimensionCollection _dimensions
VB
Protected _dimensions As DimensionCollection
Field Value
Type: DimensionCollection
Reference
ArrayType Class
TwinCAT.Ads.TypeSystem Namespace


BitMappingType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] BitMappingType Class
BitMappingType Class
Helper Data Type to implement Bit mapping types.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.BitMappingType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class BitMappingType : DataType
VB
Public NotInheritable Class BitMappingType
Inherits DataType
The BitMappingType type exposes the following members.
Constructors
Name | Description
BitMappingType | Initializes a new instance of the BitMappingType class.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
BitMappingType Constructor
•
BitMappingType Properties
•
BitMappingType Methods


BitMappingType Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] BitMappingType Class [image] BitMappingType Constructor
BitMappingType Constructor
Initializes a new instance of the BitMappingType class.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public BitMappingType(
string name,
int bitSize,
Type dotnetType
)
VB
Public Sub New (
name As String,
bitSize As Integer,
dotnetType As Type
)
Parameters
name | Type: System.String The name.
bitSize | Type: System.Int32 The size of the type in bits.
dotnetType | Type: System.Type Type of the dotnet.
Reference
BitMappingType Class
TwinCAT.Ads.TypeSystem Namespace


BitMappingType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] BitMappingType Class [image] BitMappingType Properties
BitMappingType Properties
The BitMappingType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
BitMappingType Class
TwinCAT.Ads.TypeSystem Namespace


BitMappingType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] BitMappingType Class [image] BitMappingType Methods
BitMappingType Methods
The BitMappingType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
BitMappingType Class
TwinCAT.Ads.TypeSystem Namespace


DataType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class
DataType Class
DataType class
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
More...
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DataType : IDataType, IBitSize
VB
Public Class DataType
Implements IDataType, IBitSize
The DataType type exposes the following members.
Constructors
Name | Description
DataType | Initializes a new instance of the DataType class (copy Constructor)
Properties
Name | Description
Attributes | Gets the attributes of the IDataType
BitSize | Gets the size of the DataType in bits.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes
Category | Gets the Data Type category
Comment | Gets the comment.
FullName | Gets the full name of the IDataType (Namespace + Name)
Id | Gets the ID of the DataType
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
IsContainer | Gets a value indicating whether this IDataType is a container type
IsPointer | Gets a value indicating whether this IDataType is a pointer type
IsPrimitive | Gets a value indicating whether this IDataType is primitive
IsReference | Gets a value indicating whether this IDataType is a reference type
ManagedType | Gets the corresponding .NET Type if attached.
Name | Gets the name of the Data Type (without namespace)
Namespace | Gets the namespace string within the IDataType exists.
Size | Gets the Size of the DataType in Bytes
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPointerType | Determines whether the specified category is a pointer type.
IsReferenceType | Determines whether the specified category is a reference type.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
Reference
TwinCAT.Ads.TypeSystem Namespace
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.AliasType
TwinCAT.Ads.TypeSystem.ArrayType
TwinCAT.Ads.TypeSystem.BitMappingType
TwinCAT.Ads.TypeSystem.EnumType.T.
TwinCAT.Ads.TypeSystem.PointerType
TwinCAT.Ads.TypeSystem.PrimitiveType
TwinCAT.Ads.TypeSystem.ReferenceType
TwinCAT.Ads.TypeSystem.StringType
TwinCAT.Ads.TypeSystem.StructType
TwinCAT.Ads.TypeSystem.SubRangeType.T.
TwinCAT.Ads.TypeSystem.UnionType
TwinCAT.Ads.TypeSystem.WStringType
Weiterführende Informationen
•
DataType Constructor
•
DataType Properties
•
DataType Methods


DataType Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Constructor
DataType Constructor
Initializes a new instance of the DataType class (copy Constructor)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected DataType(
DataType copy
)
VB
Protected Sub New (
copy As DataType
)
Parameters
copy
Type: TwinCAT.Ads.TypeSystem.DataType
The copy.
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties
DataType Properties
The DataType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType
BitSize | Gets the size of the DataType in bits.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes
Category | Gets the Data Type category
Comment | Gets the comment.
FullName | Gets the full name of the IDataType (Namespace + Name)
Id | Gets the ID of the DataType
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
IsContainer | Gets a value indicating whether this IDataType is a container type
IsPointer | Gets a value indicating whether this IDataType is a pointer type
IsPrimitive | Gets a value indicating whether this IDataType is primitive
IsReference | Gets a value indicating whether this IDataType is a reference type
ManagedType | Gets the corresponding .NET Type if attached.
Name | Gets the name of the Data Type (without namespace)
Namespace | Gets the namespace string within the IDataType exists.
Size | Gets the Size of the DataType in Bytes
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
DataType.Attributes Property
•
DataType.BitSize Property
•
DataType.ByteSize Property
•
DataType.Category Property
•
DataType.Comment Property
•
DataType.FullName Property
•
DataType.Id Property
•
DataType.IsBitType Property
•
DataType.IsByteAligned Property
•
DataType.IsContainer Property
•
DataType.IsPointer Property
•
DataType.IsPrimitive Property
•
DataType.IsReference Property
•
DataType.ManagedType Property
•
DataType.Name Property
•
DataType.Namespace Property
•
DataType.Size Property


DataType.Attributes Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.Attributes Property
DataType.Attributes Property
Gets the attributes of the IDataType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyTypeAttributeCollection Attributes { get; }
VB
Public ReadOnly Property Attributes As ReadOnlyTypeAttributeCollection
Get
Property Value
Type: ReadOnlyTypeAttributeCollection
The attributes.
Implements
IDataType.Attributes
Exceptions
Exception | Condition
NotImplementedException |
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.BitSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.BitSize Property
DataType.BitSize Property
Gets the size of the DataType in bits.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int BitSize { get; }
VB
Public ReadOnly Property BitSize As Integer
Get
Property Value
Type: Int32
The size of the bit.
Implements
IBitSize.BitSize
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.ByteSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.ByteSize Property
DataType.ByteSize Property
Gets the (aligned) size of of the Type/Instance in Bytes
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ByteSize { get; }
VB
Public ReadOnly Property ByteSize As Integer
Get
Property Value
Type: Int32
The size of the byte.
Implements
IBitSize.ByteSize
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.Category Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.Category Property
DataType.Category Property
Gets the Data Type category
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeCategory Category { get; }
VB
Public ReadOnly Property Category As DataTypeCategory
Get
Property Value
Type: DataTypeCategory
The category.
Implements
IDataType.Category
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.Comment Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.Comment Property
DataType.Comment Property
Gets the comment.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Comment { get; }
VB
Public ReadOnly Property Comment As String
Get
Property Value
Type: String
The comment.
Implements
IDataType.Comment
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.FullName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.FullName Property
DataType.FullName Property
Gets the full name of the IDataType (Namespace + Name)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string FullName { get; }
VB
Public ReadOnly Property FullName As String
Get
Property Value
Type: String
The full name.
Implements
IDataType.FullName
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.Id Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.Id Property
DataType.Id Property
Gets the ID of the DataType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Id { get; }
VB
Public ReadOnly Property Id As Integer
Get
Property Value
Type: Int32
The id.
Implements
IDataType.Id
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.IsBitType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.IsBitType Property
DataType.IsBitType Property
Gets a value indicating whether this IDataType is a bit mapping Type
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsBitType { get; }
VB
Public ReadOnly Property IsBitType As Boolean
Get
Property Value
Type: Boolean
true if this instance is bit mapping subtype; otherwise, false.
Implements
IBitSize.IsBitType
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.IsByteAligned Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.IsByteAligned Property
DataType.IsByteAligned Property
Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsByteAligned { get; }
VB
Public ReadOnly Property IsByteAligned As Boolean
Get
Property Value
Type: Boolean
true if this instance is byte aligned; otherwise, false.
Implements
IBitSize.IsByteAligned
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.IsContainer Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.IsContainer Property
DataType.IsContainer Property
Gets a value indicating whether this IDataType is a container type
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual bool IsContainer { get; }
VB
Public Overridable ReadOnly Property IsContainer As Boolean
Get
Property Value
Type: Boolean
true if this instance is container type; otherwise, false.
Implements
IDataType.IsContainer
Remarks
Container Types are all types that contain SubElements like
▪
Array
▪
Pointer
▪
Union
▪
Struct
▪
Function
▪
FunctionBlock
▪
Program
and the Alias and Reference types, if they have a container type as base type.
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace
IDataType.Category


DataType.IsPointer Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.IsPointer Property
DataType.IsPointer Property
Gets a value indicating whether this IDataType is a pointer type
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual bool IsPointer { get; }
VB
Public Overridable ReadOnly Property IsPointer As Boolean
Get
Property Value
Type: Boolean
true if this instance is pointer type; otherwise, false.
Implements
IDataType.IsPointer
Remarks
Pointer types can be dereferenced with the '^' operator.
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace
IDataType.Category


DataType.IsPrimitive Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.IsPrimitive Property
DataType.IsPrimitive Property
Gets a value indicating whether this IDataType is primitive
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual bool IsPrimitive { get; }
VB
Public Overridable ReadOnly Property IsPrimitive As Boolean
Get
Property Value
Type: Boolean
true if this instance is primitive; otherwise, false.
Implements
IDataType.IsPrimitive
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.IsReference Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.IsReference Property
DataType.IsReference Property
Gets a value indicating whether this IDataType is a reference type
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual bool IsReference { get; }
VB
Public Overridable ReadOnly Property IsReference As Boolean
Get
Property Value
Type: Boolean
true if this instance is container type; otherwise, false.
Implements
IDataType.IsReference
Remarks
Reference types can be dereferenced.
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace
IDataType.Category


DataType.ManagedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.ManagedType Property
DataType.ManagedType Property
Gets the corresponding .NET Type if attached.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual Type ManagedType { get; }
VB
Public Overridable ReadOnly Property ManagedType As Type
Get
Property Value
Type: Type
Dot net type.
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.Name Property
DataType.Name Property
Gets the name of the Data Type (without namespace)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Name { get; }
VB
Public ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Implements
IDataType.Name
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.Namespace Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.Namespace Property
DataType.Namespace Property
Gets the namespace string within the IDataType exists.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Namespace { get; }
VB
Public ReadOnly Property Namespace As String
Get
Property Value
Type: String
The namespace.
Implements
IDataType.Namespace
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.Size Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Properties [image] DataType.Size Property
DataType.Size Property
Gets the Size of the DataType in Bytes
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Size { get; }
VB
Public ReadOnly Property Size As Integer
Get
Property Value
Type: Int32
The size.
Implements
IBitSize.Size
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Methods
DataType Methods
The DataType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPointerType | Determines whether the specified category is a pointer type.
IsReferenceType | Determines whether the specified category is a reference type.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
DataType.IsPointerType Method
•
DataType.IsReferenceType Method
•
DataType.ToString Method


DataType.IsPointerType Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Methods [image] DataType.IsPointerType Method
DataType.IsPointerType Method
Determines whether the specified category is a pointer type.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool IsPointerType(
DataTypeCategory cat
)
VB
Public Shared Function IsPointerType (
cat As DataTypeCategory
) As Boolean
Parameters
cat
Type: TwinCAT.TypeSystem.DataTypeCategory
The data type category.
Return Value
Type: Boolean
true if [is pointer type] [the specified cat]; otherwise, false.
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.IsReferenceType Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Methods [image] DataType.IsReferenceType Method
DataType.IsReferenceType Method
Determines whether the specified category is a reference type.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool IsReferenceType(
DataTypeCategory cat
)
VB
Public Shared Function IsReferenceType (
cat As DataTypeCategory
) As Boolean
Parameters
cat
Type: TwinCAT.TypeSystem.DataTypeCategory
The data type category.
Return Value
Type: Boolean
true if [is reference type] [the specified cat]; otherwise, false.
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


DataType.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] DataType Class [image] DataType Methods [image] DataType.ToString Method
DataType.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
DataType Class
TwinCAT.Ads.TypeSystem Namespace


EnumType.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class
EnumType.T. Class
Enum DataType.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.EnumType.T.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class EnumType<T> : DataType,
IEnumType<T>, IAliasType, IDataType, IBitSize, IEnumType
where T : IConvertible
VB
Public NotInheritable Class EnumType(Of T As IConvertible)
Inherits DataType
Implements IEnumType(Of T), IAliasType, IDataType,
IBitSize, IEnumType
Type Parameters
T
The EnumType.T. type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BaseType | Gets the Base Type
BaseTypeName | Gets the BaseType name
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
EnumValues | Enumeration specification (if enum)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Contains | Determines whether the enum values contains the specified name
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetNames | Gets the filed names of the IEnumType.T.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Gets the values of the IEnumType.T.
Parse | Parses a name of the IEnumType.T. and returns the value (as base type)
ToString. | Returns a String that represents this instance. (Inherited from DataType.)
ToString(Object) | Returns a String that represents this instance.
ToString(T) | Returns a String that represents this instance.
TryParse | Tries to parse the Enum Value
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
EnumType.T. Properties
•
EnumType.T. Methods


EnumType.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Properties
EnumType.T. Properties
The EnumType.T. generic type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BaseType | Gets the Base Type
BaseTypeName | Gets the BaseType name
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
EnumValues | Enumeration specification (if enum)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
EnumType.T. Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
EnumType.T..BaseType Property
•
EnumType.T..BaseTypeName Property
•
EnumType.T..EnumValues Property


EnumType.T..BaseType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Properties [image] EnumType.T..BaseType Property
EnumType.T..BaseType Property
Gets the Base Type
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType BaseType { get; }
VB
Public ReadOnly Property BaseType As IDataType
Get
Property Value
Type: IDataType
The type of the base.
Implements
IAliasType.BaseType
Reference
EnumType.T. Class
TwinCAT.Ads.TypeSystem Namespace


EnumType.T..BaseTypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Properties [image] EnumType.T..BaseTypeName Property
EnumType.T..BaseTypeName Property
Gets the BaseType name
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string BaseTypeName { get; }
VB
Public ReadOnly Property BaseTypeName As String
Get
Property Value
Type: String
The name of the base type.
Implements
IAliasType.BaseTypeName
Reference
EnumType.T. Class
TwinCAT.Ads.TypeSystem Namespace


EnumType.T..EnumValues Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Properties [image] EnumType.T..EnumValues Property
EnumType.T..EnumValues Property
Enumeration specification (if enum)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyEnumValueCollection<T> EnumValues { get; }
VB
Public ReadOnly Property EnumValues As ReadOnlyEnumValueCollection(Of T)
Get
Property Value
Type: ReadOnlyEnumValueCollection.T.
The enum specification.
Implements
IEnumType.T..EnumValues
Reference
EnumType.T. Class
TwinCAT.Ads.TypeSystem Namespace


EnumType.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Methods
EnumType.T. Methods
The EnumType.T. generic type exposes the following members.
Methods
Name | Description
Contains | Determines whether the enum values contains the specified name
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetNames | Gets the filed names of the IEnumType.T.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Gets the values of the IEnumType.T.
Parse | Parses a name of the IEnumType.T. and returns the value (as base type)
ToString. | Returns a String that represents this instance. (Inherited from DataType.)
ToString(Object) | Returns a String that represents this instance.
ToString(T) | Returns a String that represents this instance.
TryParse | Tries to parse the Enum Value
Reference
EnumType.T. Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
EnumType.T..Contains Method
•
EnumType.T..GetNames Method
•
EnumType.T..GetValues Method
•
EnumType.T..Parse Method
•
EnumType.T..ToString Method
•
EnumType.T..TryParse Method


EnumType.T..Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Methods [image] EnumType.T..Contains Method
EnumType.T..Contains Method
Determines whether the enum values contains the specified name
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string name
)
VB
Public Function Contains (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if contains the value, otherwise, false.
Implements
IEnumType.T..Contains(String)
IEnumType.Contains(String)
Reference
EnumType.T. Class
TwinCAT.Ads.TypeSystem Namespace


EnumType.T..GetNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Methods [image] EnumType.T..GetNames Method
EnumType.T..GetNames Method
Gets the filed names of the IEnumType.T.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string[] GetNames()
VB
Public Function GetNames As String()
Return Value
Type: .String.
System.String[].
Implements
IEnumType.T..GetNames.
IEnumType.GetNames.
Reference
EnumType.T. Class
TwinCAT.Ads.TypeSystem Namespace


EnumType.T..GetValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Methods [image] EnumType.T..GetValues Method
EnumType.T..GetValues Method
Gets the values of the IEnumType.T.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T[] GetValues()
VB
Public Function GetValues As T()
Return Value
Type: .T.
T[].
Implements
IEnumType.T..GetValues.
Reference
EnumType.T. Class
TwinCAT.Ads.TypeSystem Namespace


EnumType.T..Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Methods [image] EnumType.T..Parse Method
EnumType.T..Parse Method
Parses a name of the IEnumType.T. and returns the value (as base type)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T Parse(
string strValue
)
VB
Public Function Parse (
strValue As String
) As T
Parameters
strValue
Type: System.String
Enum Value as string.
Return Value
Type: T
T.
Implements
IEnumType.T..Parse(String)
Reference
EnumType.T. Class
TwinCAT.Ads.TypeSystem Namespace


EnumType.T..ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Methods [image] EnumType.T..ToString Method
EnumType.T..ToString Method
Overload List
Name | Description
ToString. | Returns a String that represents this instance. (Inherited from DataType.)
ToString(Object) | Returns a String that represents this instance.
ToString(T) | Returns a String that represents this instance.
Reference
EnumType.T. Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
EnumType.T..ToString Method (Object)
•
EnumType.T..ToString Method (T)


EnumType.T..ToString Method (Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Methods [image] EnumType.T..ToString Method [image] EnumType.T..ToString Method (Object)
EnumType.T..ToString Method (Object)
Returns a String that represents this instance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ToString(
Object val
)
VB
Public Function ToString (
val As Object
) As String
Parameters
val
Type: System.Object
The value.
Return Value
Type: String
A String that represents this instance.
Implements
IEnumType.ToString(Object)
Reference
EnumType.T. Class
ToString Overload
TwinCAT.Ads.TypeSystem Namespace


EnumType.T..ToString Method (T)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Methods [image] EnumType.T..ToString Method [image] EnumType.T..ToString Method (T)
EnumType.T..ToString Method (T)
Returns a String that represents this instance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ToString(
T val
)
VB
Public Function ToString (
val As T
) As String
Parameters
val
Type: T
The value.
Return Value
Type: String
A String that represents this instance.
Implements
IEnumType.T..ToString(T)
Exceptions
Exception | Condition
ArgumentException | val
Reference
EnumType.T. Class
ToString Overload
TwinCAT.Ads.TypeSystem Namespace


EnumType.T..TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] EnumType.T. Class [image] EnumType.T. Methods [image] EnumType.T..TryParse Method
EnumType.T..TryParse Method
Tries to parse the Enum Value
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryParse(
string strValue,
out T value
)
VB
Public Function TryParse (
strValue As String,
<OutAttribute> ByRef value As T
) As Boolean
Parameters
strValue | Type: System.String Enum value (in string representation).
value | Type: T. The value.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Implements
IEnumType.T..TryParse(String, T.)
Reference
EnumType.T. Class
TwinCAT.Ads.TypeSystem Namespace


Field Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Field Class
Field Class
Represents a field of an Struct/Alias/Union
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.Instance
TwinCAT.Ads.TypeSystem.Field
TwinCAT.Ads.TypeSystem.Member
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class Field : Instance, IField,
IAttributedInstance, IInstance, IBitSize
VB
Public Class Field
Inherits Instance
Implements IField, IAttributedInstance, IInstance, IBitSize
The Field type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from Instance.)
BitSize | Gets the size of this Instance in bits. (Inherited from Instance.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from Instance.)
Category | Gets the the DataTypeCategory of the Instance. (Inherited from Instance.)
Comment | Gets the comment. (Inherited from Instance.)
ContextMask | Gets the context mask of this instance. (Inherited from Instance.)
DataType | Gets the IDataType of the IInstance. (Inherited from Instance.)
HasValue | Gets a value indicating whether this instance has a value. (Inherited from Instance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from Instance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from Instance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from Instance.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from Instance.)
IsPersistent | Indicates if this instance is persistent. (Inherited from Instance.)
IsPointer | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsReadOnly | Indicates if this instance is read only. (Inherited from Instance.)
IsReference | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from Instance.)
IsTcComInterfacePointer | Indicates if this instance is a TcComInterfacePointer. (Inherited from Instance.)
IsTypeGuid | Indicates if this instance has set TypeGuid flag. (Inherited from Instance.)
Namespace | Gets the namespace name. (Inherited from Instance.)
ParentType | Gets the Parent of this IField.
Size | Gets the size of the IDataType in bytes or Bits dependant on IsBitType (Inherited from Instance.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from Instance.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnGetSize | Handler function getting the size of the Instance (Inherited from Instance.)
OnSetInstanceName | Sets a new InstanceName InstancePath (Inherited from Instance.)
SetContextMask | Sets the context mask. (Inherited from Instance.)
ToString | Returns a String that represents this instance. (Inherited from Instance.)
Fields
Name | Description
attributes | The attributes (Inherited from Instance.)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Field Properties
•
Field Methods
•
Field Fields


Field Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Field Class [image] Field Properties
Field Properties
The Field type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from Instance.)
BitSize | Gets the size of this Instance in bits. (Inherited from Instance.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from Instance.)
Category | Gets the the DataTypeCategory of the Instance. (Inherited from Instance.)
Comment | Gets the comment. (Inherited from Instance.)
ContextMask | Gets the context mask of this instance. (Inherited from Instance.)
DataType | Gets the IDataType of the IInstance. (Inherited from Instance.)
HasValue | Gets a value indicating whether this instance has a value. (Inherited from Instance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from Instance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from Instance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from Instance.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from Instance.)
IsPersistent | Indicates if this instance is persistent. (Inherited from Instance.)
IsPointer | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsReadOnly | Indicates if this instance is read only. (Inherited from Instance.)
IsReference | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from Instance.)
IsTcComInterfacePointer | Indicates if this instance is a TcComInterfacePointer. (Inherited from Instance.)
IsTypeGuid | Indicates if this instance has set TypeGuid flag. (Inherited from Instance.)
Namespace | Gets the namespace name. (Inherited from Instance.)
ParentType | Gets the Parent of this IField.
Size | Gets the size of the IDataType in bytes or Bits dependant on IsBitType (Inherited from Instance.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from Instance.)
Reference
Field Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Field.ParentType Property


Field.ParentType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Field Class [image] Field Properties [image] Field.ParentType Property
Field.ParentType Property
Gets the Parent of this IField.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType ParentType { get; }
VB
Public ReadOnly Property ParentType As IDataType
Get
Property Value
Type: IDataType
The type of the parent (Alias, Union, Struct)
Implements
IField.ParentType
Reference
Field Class
TwinCAT.Ads.TypeSystem Namespace


Field Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Field Class [image] Field Methods
Field Methods
The Field type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnGetSize | Handler function getting the size of the Instance (Inherited from Instance.)
OnSetInstanceName | Sets a new InstanceName InstancePath (Inherited from Instance.)
SetContextMask | Sets the context mask. (Inherited from Instance.)
ToString | Returns a String that represents this instance. (Inherited from Instance.)
Reference
Field Class
TwinCAT.Ads.TypeSystem Namespace


Field Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Field Class [image] Field Fields
Field Fields
The Field type exposes the following members.
Fields
Name | Description
attributes | The attributes (Inherited from Instance.)
Reference
Field Class
TwinCAT.Ads.TypeSystem Namespace


IAdsSymbol Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] IAdsSymbol Interface
IAdsSymbol Interface
Interface IAdsSymbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IAdsSymbol : ISymbol,
IAttributedInstance, IInstance, IBitSize, IProcessImageAddress
VB
Public Interface IAdsSymbol
Inherits ISymbol, IAttributedInstance, IInstance, IBitSize,
IProcessImageAddress
The IAdsSymbol type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
ImageBaseAddress | Gets the AmsAddress of the Process Image
IndexGroup | Gets the index group of the Symbol (Inherited from IProcessImageAddress.)
IndexOffset | Gets the index offset of the Symbol (Inherited from IProcessImageAddress.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.Ads.TypeSystem Namespace
TwinCAT.TypeSystem.ISymbol
TwinCAT.TypeSystem.IProcessImageAddress
Weiterführende Informationen
•
IAdsSymbol Properties


IAdsSymbol Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] IAdsSymbol Interface [image] IAdsSymbol Properties
IAdsSymbol Properties
The IAdsSymbol type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
ImageBaseAddress | Gets the AmsAddress of the Process Image
IndexGroup | Gets the index group of the Symbol (Inherited from IProcessImageAddress.)
IndexOffset | Gets the index offset of the Symbol (Inherited from IProcessImageAddress.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IAdsSymbol Interface
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
IAdsSymbol.ImageBaseAddress Property


IAdsSymbol.ImageBaseAddress Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] IAdsSymbol Interface [image] IAdsSymbol Properties [image] IAdsSymbol.ImageBaseAddress Property
IAdsSymbol.ImageBaseAddress Property
Gets the AmsAddress of the Process Image
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AmsAddress ImageBaseAddress { get; }
VB
ReadOnly Property ImageBaseAddress As AmsAddress
Get
Property Value
Type: AmsAddress
The address.
Reference
IAdsSymbol Interface
TwinCAT.Ads.TypeSystem Namespace


IAdsSymbolLoader Interface

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] IAdsSymbolLoader Interface
IAdsSymbolLoader Interface
Symbol Loader interface
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IAdsSymbolLoader : ISymbolLoader,
ISymbolProvider
VB
Public Interface IAdsSymbolLoader
Inherits ISymbolLoader, ISymbolProvider
The IAdsSymbolLoader type exposes the following members.
Properties
Name | Description
BuildInTypes | Gets the build in types. (Inherited from ISymbolLoader.)
DataTypes | Gets all data types from all Namespaces (Inherited from ISymbolProvider.)
DefaultNotificationSettings | Gets/Sets the default notification settings for this SymbolLoader
ImageBaseAddress | Gets the image base address.
RootNamespaceName | Gets the name of the root namespace (Inherited from ISymbolProvider.)
Settings | Gets or sets the access Method (Inherited from ISymbolLoader.)
Symbols | Gets the (root) symbols of the Symbol provider. (Inherited from ISymbolProvider.)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
IAdsSymbolLoader Properties


IAdsSymbolLoader Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] IAdsSymbolLoader Interface [image] IAdsSymbolLoader Properties
IAdsSymbolLoader Properties
The IAdsSymbolLoader type exposes the following members.
Properties
Name | Description
BuildInTypes | Gets the build in types. (Inherited from ISymbolLoader.)
DataTypes | Gets all data types from all Namespaces (Inherited from ISymbolProvider.)
DefaultNotificationSettings | Gets/Sets the default notification settings for this SymbolLoader
ImageBaseAddress | Gets the image base address.
RootNamespaceName | Gets the name of the root namespace (Inherited from ISymbolProvider.)
Settings | Gets or sets the access Method (Inherited from ISymbolLoader.)
Symbols | Gets the (root) symbols of the Symbol provider. (Inherited from ISymbolProvider.)
Reference
IAdsSymbolLoader Interface
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
IAdsSymbolLoader.DefaultNotificationSettings Property
•
IAdsSymbolLoader.ImageBaseAddress Property


IAdsSymbolLoader.DefaultNotificationSettings Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] IAdsSymbolLoader Interface [image] IAdsSymbolLoader Properties [image] IAdsSymbolLoader.DefaultNotificationSettings Property
IAdsSymbolLoader.DefaultNotificationSettings Property
Gets/Sets the default notification settings for this SymbolLoader
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
INotificationSettings DefaultNotificationSettings { get; set; }
VB
Property DefaultNotificationSettings As INotificationSettings
Get
Set
Property Value
Type: INotificationSettings
The default notification settings.
Remarks
The Default notification Settings can be set on the SymbolLoader and is used as default on the different Symbols. On the symbol itself the NotificationSettings can be overridden.
Examples
Setting the DefaultNotificationSettings on the IAdsSymbolLoader object:
Set DefaultNotificationSettings
// Create AdsClient object
using (TcAdsClient client = new TcAdsClient())
{
// No automatic Synchronization (necessary for Console applications without message loop)
client.Synchronize = false;

// Connect to client
client.Connect(address);

// Usage of 'dynamic' type/symbol loader
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.DynamicTree, ValueAccessMode.IndexGroupOffsetPreferred);
IAdsSymbolLoader dynLoader = (IAdsSymbolLoader)SymbolLoaderFactory.Create(client, settings);

// Set the DefaultNotification Properties
dynLoader.DefaultNotificationSettings = new NotificationSettings(AdsTransMode.ClientOnChange, 200, 2000);

// Determine the symbols
dynamic dynamicSymbols = ((IDynamicSymbolLoader)dynLoader).SymbolsDynamic;

// Task 1 Symbol (build in symbol)
dynamic task1Symbol = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo[1];

// CycleCount Symbol
dynamic cycleCountSymbol = task1Symbol.CycleCount;

// Override Notification Setting for Cycle Count Symbol
cycleCountSymbol.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 250, 0);

// Register Dynamic Value Changed event.
cycleCountSymbol.ValueChanged += new EventHandler<ValueChangedArgs>(cycleCount_ValueChanged);
Reference
IAdsSymbolLoader Interface
TwinCAT.Ads.TypeSystem Namespace


IAdsSymbolLoader.ImageBaseAddress Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] IAdsSymbolLoader Interface [image] IAdsSymbolLoader Properties [image] IAdsSymbolLoader.ImageBaseAddress Property
IAdsSymbolLoader.ImageBaseAddress Property
Gets the image base address.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
AmsAddress ImageBaseAddress { get; }
VB
ReadOnly Property ImageBaseAddress As AmsAddress
Get
Property Value
Type: AmsAddress
The image base address.
Reference
IAdsSymbolLoader Interface
TwinCAT.Ads.TypeSystem Namespace


Instance Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class
Instance Class
Instance implementation
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.Instance
TwinCAT.Ads.TypeSystem.Field
TwinCAT.Ads.TypeSystem.Symbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class Instance : IInstance, IBitSize
VB
Public Class Instance
Implements IInstance, IBitSize
The Instance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes.
BitSize | Gets the size of this Instance in bits.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes
Category | Gets the the DataTypeCategory of the Instance.
Comment | Gets the comment.
ContextMask | Gets the context mask of this instance.
DataType | Gets the IDataType of the IInstance.
HasValue | Gets a value indicating whether this instance has a value.
InstanceName | Gets the name of the instance (without periods (.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.))
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
IsPersistent | Indicates if this instance is persistent.
IsPointer | Gets a value indicating whether this instance is reference.
IsReadOnly | Indicates if this instance is read only.
IsReference | Gets a value indicating whether this instance is reference.
IsStatic | Gets a value indicating whether this IInstance is static.
IsTcComInterfacePointer | Indicates if this instance is a TcComInterfacePointer.
IsTypeGuid | Indicates if this instance has set TypeGuid flag.
Namespace | Gets the namespace name.
Size | Gets the size of the IDataType in bytes or Bits dependant on IsBitType
TypeName | Gets the name of the DataType that is used for this IInstance.
Methods
Name | Description
AlignTypeName | Aligns the type name
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnGetSize | Handler function getting the size of the Instance
OnSetInstanceName | Sets a new InstanceName InstancePath
SetContextMask | Sets the context mask.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
Fields
Name | Description
attributes | The attributes
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Instance Properties
•
Instance Methods
•
Instance Fields


Instance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties
Instance Properties
The Instance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes.
BitSize | Gets the size of this Instance in bits.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes
Category | Gets the the DataTypeCategory of the Instance.
Comment | Gets the comment.
ContextMask | Gets the context mask of this instance.
DataType | Gets the IDataType of the IInstance.
HasValue | Gets a value indicating whether this instance has a value.
InstanceName | Gets the name of the instance (without periods (.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.))
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
IsPersistent | Indicates if this instance is persistent.
IsPointer | Gets a value indicating whether this instance is reference.
IsReadOnly | Indicates if this instance is read only.
IsReference | Gets a value indicating whether this instance is reference.
IsStatic | Gets a value indicating whether this IInstance is static.
IsTcComInterfacePointer | Indicates if this instance is a TcComInterfacePointer.
IsTypeGuid | Indicates if this instance has set TypeGuid flag.
Namespace | Gets the namespace name.
Size | Gets the size of the IDataType in bytes or Bits dependant on IsBitType
TypeName | Gets the name of the DataType that is used for this IInstance.
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Instance.Attributes Property
•
Instance.BitSize Property
•
Instance.ByteSize Property
•
Instance.Category Property
•
Instance.Comment Property
•
Instance.ContextMask Property
•
Instance.DataType Property
•
Instance.HasValue Property
•
Instance.InstanceName Property
•
Instance.InstancePath Property
•
Instance.IsBitType Property
•
Instance.IsByteAligned Property
•
Instance.IsPersistent Property
•
Instance.IsPointer Property
•
Instance.IsReadOnly Property
•
Instance.IsReference Property
•
Instance.IsStatic Property
•
Instance.IsTcComInterfacePointer Property
•
Instance.IsTypeGuid Property
•
Instance.Namespace Property
•
Instance.Size Property
•
Instance.TypeName Property


Instance.Attributes Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.Attributes Property
Instance.Attributes Property
Gets the Type Attributes.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyTypeAttributeCollection Attributes { get; }
VB
Public ReadOnly Property Attributes As ReadOnlyTypeAttributeCollection
Get
Property Value
Type: ReadOnlyTypeAttributeCollection
The attributes.
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.BitSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.BitSize Property
Instance.BitSize Property
Gets the size of this Instance in bits.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual int BitSize { get; }
VB
Public Overridable ReadOnly Property BitSize As Integer
Get
Property Value
Type: Int32
The size of the bit.
Implements
IBitSize.BitSize
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.ByteSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.ByteSize Property
Instance.ByteSize Property
Gets the (aligned) size of of the Type/Instance in Bytes
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ByteSize { get; }
VB
Public ReadOnly Property ByteSize As Integer
Get
Property Value
Type: Int32
The size of the byte.
Implements
IBitSize.ByteSize
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.Category Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.Category Property
Instance.Category Property
Gets the the DataTypeCategory of the Instance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeCategory Category { get; }
VB
Public ReadOnly Property Category As DataTypeCategory
Get
Property Value
Type: DataTypeCategory
The category.
Remarks
Corresponds to the Category
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.Comment Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.Comment Property
Instance.Comment Property
Gets the comment.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Comment { get; }
VB
Public ReadOnly Property Comment As String
Get
Property Value
Type: String
The comment.
Implements
IInstance.Comment
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.ContextMask Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.ContextMask Property
Instance.ContextMask Property
Gets the context mask of this instance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public byte ContextMask { get; }
VB
Public ReadOnly Property ContextMask As Byte
Get
Property Value
Type: Byte
Remarks
The Size of the internal data is 4-Bit
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.DataType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.DataType Property
Instance.DataType Property
Gets the IDataType of the IInstance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType DataType { get; }
VB
Public ReadOnly Property DataType As IDataType
Get
Property Value
Type: IDataType
The type of the data.
Implements
IInstance.DataType
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.HasValue Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.HasValue Property
Instance.HasValue Property
Gets a value indicating whether this instance has a value.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual bool HasValue { get; }
VB
Public Overridable ReadOnly Property HasValue As Boolean
Get
Property Value
Type: Boolean
true if this instance has value; otherwise, false.
Remarks
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.InstanceName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.InstanceName Property
Instance.InstanceName Property
Gets the name of the instance (without periods (.)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string InstanceName { get; }
VB
Public ReadOnly Property InstanceName As String
Get
Property Value
Type: String
The name of the instance.
Implements
IInstance.InstanceName
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.InstancePath Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.InstancePath Property
Instance.InstancePath Property
Gets the relative / absolute access path to the instance (with periods (.))
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual string InstancePath { get; }
VB
Public Overridable ReadOnly Property InstancePath As String
Get
Property Value
Type: String
The instance path.
Implements
IInstance.InstancePath
Remarks
If this path is relative or absolute depends on the context. IMember are using relative paths, ISymbols are using absolute ones.
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.IsBitType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.IsBitType Property
Instance.IsBitType Property
Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsBitType { get; }
VB
Public ReadOnly Property IsBitType As Boolean
Get
Property Value
Type: Boolean
true if this instance is bit mapping; otherwise, false.
Implements
IBitSize.IsBitType
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.IsByteAligned Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.IsByteAligned Property
Instance.IsByteAligned Property
Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsByteAligned { get; }
VB
Public ReadOnly Property IsByteAligned As Boolean
Get
Property Value
Type: Boolean
true if this instance is byte aligned; otherwise, false.
Implements
IBitSize.IsByteAligned
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.IsPersistent Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.IsPersistent Property
Instance.IsPersistent Property
Indicates if this instance is persistent.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsPersistent { get; }
VB
Public ReadOnly Property IsPersistent As Boolean
Get
Property Value
Type: Boolean
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.IsPointer Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.IsPointer Property
Instance.IsPointer Property
Gets a value indicating whether this instance is reference.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsPointer { get; }
VB
Public ReadOnly Property IsPointer As Boolean
Get
Property Value
Type: Boolean
true if this instance is reference; otherwise, false.
Implements
IInstance.IsPointer
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.IsReadOnly Property
Instance.IsReadOnly Property
Indicates if this instance is read only.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.IsReference Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.IsReference Property
Instance.IsReference Property
Gets a value indicating whether this instance is reference.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReference { get; }
VB
Public ReadOnly Property IsReference As Boolean
Get
Property Value
Type: Boolean
true if this instance is reference; otherwise, false.
Implements
IInstance.IsReference
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.IsStatic Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.IsStatic Property
Instance.IsStatic Property
Gets a value indicating whether this IInstance is static.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsStatic { get; }
VB
Public ReadOnly Property IsStatic As Boolean
Get
Property Value
Type: Boolean
true if this instance is static; otherwise, false.
Implements
IInstance.IsStatic
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.IsTcComInterfacePointer Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.IsTcComInterfacePointer Property
Instance.IsTcComInterfacePointer Property
Indicates if this instance is a TcComInterfacePointer.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsTcComInterfacePointer { get; }
VB
Public ReadOnly Property IsTcComInterfacePointer As Boolean
Get
Property Value
Type: Boolean
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.IsTypeGuid Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.IsTypeGuid Property
Instance.IsTypeGuid Property
Indicates if this instance has set TypeGuid flag.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsTypeGuid { get; }
VB
Public ReadOnly Property IsTypeGuid As Boolean
Get
Property Value
Type: Boolean
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.Namespace Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.Namespace Property
Instance.Namespace Property
Gets the namespace name.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Namespace { get; }
VB
Public ReadOnly Property Namespace As String
Get
Property Value
Type: String
The namespace.
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.Size Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.Size Property
Instance.Size Property
Gets the size of the IDataType in bytes or Bits dependant on IsBitType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Size { get; }
VB
Public ReadOnly Property Size As Integer
Get
Property Value
Type: Int32
The size of the bit.
Implements
IBitSize.Size
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.TypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Properties [image] Instance.TypeName Property
Instance.TypeName Property
Gets the name of the DataType that is used for this IInstance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string TypeName { get; }
VB
Public ReadOnly Property TypeName As String
Get
Property Value
Type: String
The name of the type.
Implements
IInstance.TypeName
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Methods
Instance Methods
The Instance type exposes the following members.
Methods
Name | Description
AlignTypeName | Aligns the type name
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnGetSize | Handler function getting the size of the Instance
OnSetInstanceName | Sets a new InstanceName InstancePath
SetContextMask | Sets the context mask.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Instance.AlignTypeName Method
•
Instance.OnGetSize Method
•
Instance.OnSetInstanceName Method
•
Instance.SetContextMask Method
•
Instance.ToString Method


Instance.AlignTypeName Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Methods [image] Instance.AlignTypeName Method
Instance.AlignTypeName Method
Aligns the type name
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected static string AlignTypeName(
string typeName
)
VB
Protected Shared Function AlignTypeName (
typeName As String
) As String
Parameters
typeName
Type: System.String
Name of the type.
Return Value
Type: String
System.String.
Exceptions
Exception | Condition
ArgumentException | Type name not valid!
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.OnGetSize Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Methods [image] Instance.OnGetSize Method
Instance.OnGetSize Method
Handler function getting the size of the Instance
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual int OnGetSize()
VB
Protected Overridable Function OnGetSize As Integer
Return Value
Type: Int32
System.Int32.
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.OnSetInstanceName Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Methods [image] Instance.OnSetInstanceName Method
Instance.OnSetInstanceName Method
Sets a new InstanceName InstancePath
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual void OnSetInstanceName(
string instanceName
)
VB
Protected Overridable Sub OnSetInstanceName (
instanceName As String
)
Parameters
instanceName
Type: System.String
Instance name.
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.SetContextMask Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Methods [image] Instance.SetContextMask Method
Instance.SetContextMask Method
Sets the context mask.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected void SetContextMask(
byte contextMask
)
VB
Protected Sub SetContextMask (
contextMask As Byte
)
Parameters
contextMask
Type: System.Byte
The context mask.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | contextMask
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Methods [image] Instance.ToString Method
Instance.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Instance Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Fields
Instance Fields
The Instance type exposes the following members.
Fields
Name | Description
attributes | The attributes
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Instance.attributes Field


Instance.attributes Field

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Instance Class [image] Instance Fields [image] Instance.attributes Field
Instance.attributes Field
The attributes
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected TypeAttributeCollection attributes
VB
Protected attributes As TypeAttributeCollection
Field Value
Type: TypeAttributeCollection
Reference
Instance Class
TwinCAT.Ads.TypeSystem Namespace


Member Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Member Class
Member Class
Represents a member of an StructType
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.Instance
TwinCAT.Ads.TypeSystem.Field
TwinCAT.Ads.TypeSystem.Member
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class Member : Field,
IMember, IField, IAttributedInstance, IInstance, IBitSize
VB
Public NotInheritable Class Member
Inherits Field
Implements IMember, IField, IAttributedInstance, IInstance,
IBitSize
The Member type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from Instance.)
BitOffset | Gets the bit offset.
BitSize | Gets the size of this Instance in bits. (Inherited from Instance.)
ByteOffset | Gets the byte offset.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from Instance.)
Category | Gets the the DataTypeCategory of the Instance. (Inherited from Instance.)
Comment | Gets the comment. (Inherited from Instance.)
ContextMask | Gets the context mask of this instance. (Inherited from Instance.)
DataType | Gets the IDataType of the IInstance. (Inherited from Instance.)
HasValue | Gets a value indicating whether this instance has a value. (Inherited from Instance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from Instance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from Instance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from Instance.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from Instance.)
IsPersistent | Indicates if this instance is persistent. (Inherited from Instance.)
IsPointer | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsReadOnly | Indicates if this instance is read only. (Inherited from Instance.)
IsReference | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from Instance.)
IsTcComInterfacePointer | Indicates if this instance is a TcComInterfacePointer. (Inherited from Instance.)
IsTypeGuid | Indicates if this instance has set TypeGuid flag. (Inherited from Instance.)
Namespace | Gets the namespace name. (Inherited from Instance.)
Offset | Gets the offset of the Member within the parent StructType in bits or bytes dependent on IsBitType
ParentType | Gets the Parent of this IField. (Inherited from Field.)
Size | Gets the size of the IDataType in bytes or Bits dependant on IsBitType (Inherited from Instance.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from Instance.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from Instance.)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Member Properties
•
Member Methods


Member Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Member Class [image] Member Properties
Member Properties
The Member type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from Instance.)
BitOffset | Gets the bit offset.
BitSize | Gets the size of this Instance in bits. (Inherited from Instance.)
ByteOffset | Gets the byte offset.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from Instance.)
Category | Gets the the DataTypeCategory of the Instance. (Inherited from Instance.)
Comment | Gets the comment. (Inherited from Instance.)
ContextMask | Gets the context mask of this instance. (Inherited from Instance.)
DataType | Gets the IDataType of the IInstance. (Inherited from Instance.)
HasValue | Gets a value indicating whether this instance has a value. (Inherited from Instance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from Instance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from Instance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from Instance.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from Instance.)
IsPersistent | Indicates if this instance is persistent. (Inherited from Instance.)
IsPointer | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsReadOnly | Indicates if this instance is read only. (Inherited from Instance.)
IsReference | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from Instance.)
IsTcComInterfacePointer | Indicates if this instance is a TcComInterfacePointer. (Inherited from Instance.)
IsTypeGuid | Indicates if this instance has set TypeGuid flag. (Inherited from Instance.)
Namespace | Gets the namespace name. (Inherited from Instance.)
Offset | Gets the offset of the Member within the parent StructType in bits or bytes dependent on IsBitType
ParentType | Gets the Parent of this IField. (Inherited from Field.)
Size | Gets the size of the IDataType in bytes or Bits dependant on IsBitType (Inherited from Instance.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from Instance.)
Reference
Member Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Member.BitOffset Property
•
Member.ByteOffset Property
•
Member.Offset Property


Member.BitOffset Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Member Class [image] Member Properties [image] Member.BitOffset Property
Member.BitOffset Property
Gets the bit offset.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int BitOffset { get; }
VB
Public ReadOnly Property BitOffset As Integer
Get
Property Value
Type: Int32
The bit offset.
Implements
IMember.BitOffset
Reference
Member Class
TwinCAT.Ads.TypeSystem Namespace


Member.ByteOffset Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Member Class [image] Member Properties [image] Member.ByteOffset Property
Member.ByteOffset Property
Gets the byte offset.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ByteOffset { get; }
VB
Public ReadOnly Property ByteOffset As Integer
Get
Property Value
Type: Int32
The byte offset.
Implements
IMember.ByteOffset
Reference
Member Class
TwinCAT.Ads.TypeSystem Namespace


Member.Offset Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Member Class [image] Member Properties [image] Member.Offset Property
Member.Offset Property
Gets the offset of the Member within the parent StructType in bits or bytes dependent on IsBitType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Offset { get; }
VB
Public ReadOnly Property Offset As Integer
Get
Property Value
Type: Int32
The offset.
Implements
IMember.Offset
Reference
Member Class
TwinCAT.Ads.TypeSystem Namespace


Member Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Member Class [image] Member Methods
Member Methods
The Member type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from Instance.)
Reference
Member Class
TwinCAT.Ads.TypeSystem Namespace


PointerType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] PointerType Class
PointerType Class
Represents a pointer type.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.PointerType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class PointerType : DataType,
IPointerType, IDataType, IBitSize
VB
Public NotInheritable Class PointerType
Inherits DataType
Implements IPointerType, IDataType, IBitSize
The PointerType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Overrides DataType.ManagedType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
ReferencedType | Gets the the referenced type.
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
PointerType Properties
•
PointerType Methods


PointerType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] PointerType Class [image] PointerType Properties
PointerType Properties
The PointerType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Overrides DataType.ManagedType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
ReferencedType | Gets the the referenced type.
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
PointerType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
PointerType.ManagedType Property
•
PointerType.ReferencedType Property


PointerType.ManagedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] PointerType Class [image] PointerType Properties [image] PointerType.ManagedType Property
PointerType.ManagedType Property
Gets the corresponding .NET Type if attached.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override Type ManagedType { get; }
VB
Public Overrides ReadOnly Property ManagedType As Type
Get
Property Value
Type: Type
Dot net type.
Reference
PointerType Class
TwinCAT.Ads.TypeSystem Namespace


PointerType.ReferencedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] PointerType Class [image] PointerType Properties [image] PointerType.ReferencedType Property
PointerType.ReferencedType Property
Gets the the referenced type.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType ReferencedType { get; }
VB
Public ReadOnly Property ReferencedType As IDataType
Get
Property Value
Type: IDataType
The type of the referenced.
Implements
IPointerType.ReferencedType
Reference
PointerType Class
TwinCAT.Ads.TypeSystem Namespace


PointerType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] PointerType Class [image] PointerType Methods
PointerType Methods
The PointerType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
PointerType Class
TwinCAT.Ads.TypeSystem Namespace


PrimitiveType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] PrimitiveType Class
PrimitiveType Class
Class PrimitiveType.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.PrimitiveType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class PrimitiveType : DataType,
IPrimitiveType, IDataType, IBitSize
VB
Public NotInheritable Class PrimitiveType
Inherits DataType
Implements IPrimitiveType, IDataType, IBitSize
The PrimitiveType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
PrimitiveFlags | Indicates types of different PrimitiveTypes with flags.
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
TwinCAT.Ads.TypeSystem Namespace
TwinCAT.Ads.TypeSystem.DataType
Weiterführende Informationen
•
PrimitiveType Properties
•
PrimitiveType Methods


PrimitiveType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] PrimitiveType Class [image] PrimitiveType Properties
PrimitiveType Properties
The PrimitiveType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
PrimitiveFlags | Indicates types of different PrimitiveTypes with flags.
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
PrimitiveType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
PrimitiveType.PrimitiveFlags Property


PrimitiveType.PrimitiveFlags Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] PrimitiveType Class [image] PrimitiveType Properties [image] PrimitiveType.PrimitiveFlags Property
PrimitiveType.PrimitiveFlags Property
Indicates types of different PrimitiveTypes with flags.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public PrimitiveTypeFlags PrimitiveFlags { get; }
VB
Public ReadOnly Property PrimitiveFlags As PrimitiveTypeFlags
Get
Property Value
Type: PrimitiveTypeFlags
The primitive flags.
Implements
IPrimitiveType.PrimitiveFlags
Reference
PrimitiveType Class
TwinCAT.Ads.TypeSystem Namespace


PrimitiveType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] PrimitiveType Class [image] PrimitiveType Methods
PrimitiveType Methods
The PrimitiveType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
PrimitiveType Class
TwinCAT.Ads.TypeSystem Namespace


ReferenceType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ReferenceType Class
ReferenceType Class
Represents a reference type
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.ReferenceType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class ReferenceType : DataType,
IReferenceType, IDataType, IBitSize
VB
Public NotInheritable Class ReferenceType
Inherits DataType
Implements IReferenceType, IDataType, IBitSize
The ReferenceType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Overrides DataType.IsContainer.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Overrides DataType.IsPrimitive.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Overrides DataType.ManagedType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
ReferencedType | Gets the the referenced type.
ResolvedByteSize | Get the ByteSize of the (completely) resolved Symbol
ResolvedCategory | Gets the Category of the (completely) resolved Symbol.
ResolvedType | Gets the (completely) resolved type
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
ReferenceType Properties
•
ReferenceType Methods


ReferenceType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ReferenceType Class [image] ReferenceType Properties
ReferenceType Properties
The ReferenceType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Overrides DataType.IsContainer.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Overrides DataType.IsPrimitive.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Overrides DataType.ManagedType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
ReferencedType | Gets the the referenced type.
ResolvedByteSize | Get the ByteSize of the (completely) resolved Symbol
ResolvedCategory | Gets the Category of the (completely) resolved Symbol.
ResolvedType | Gets the (completely) resolved type
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
ReferenceType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
ReferenceType.IsContainer Property
•
ReferenceType.IsPrimitive Property
•
ReferenceType.ManagedType Property
•
ReferenceType.ReferencedType Property
•
ReferenceType.ResolvedByteSize Property
•
ReferenceType.ResolvedCategory Property
•
ReferenceType.ResolvedType Property


ReferenceType.IsContainer Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ReferenceType Class [image] ReferenceType Properties [image] ReferenceType.IsContainer Property
ReferenceType.IsContainer Property
Gets a value indicating whether this IDataType is a container type
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool IsContainer { get; }
VB
Public Overrides ReadOnly Property IsContainer As Boolean
Get
Property Value
Type: Boolean
true if this instance is container type; otherwise, false.
Implements
IDataType.IsContainer
IDataType.IsContainer
Remarks
Container Types are all types that contain SubElements like
▪
Array
▪
Pointer
▪
Union
▪
Struct
▪
Function
▪
FunctionBlock
▪
Program
and the Alias and Reference types, if they have a container type as base type.
Reference
ReferenceType Class
TwinCAT.Ads.TypeSystem Namespace
IDataType.Category


ReferenceType.IsPrimitive Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ReferenceType Class [image] ReferenceType Properties [image] ReferenceType.IsPrimitive Property
ReferenceType.IsPrimitive Property
Gets a value indicating whether this IDataType is primitive
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool IsPrimitive { get; }
VB
Public Overrides ReadOnly Property IsPrimitive As Boolean
Get
Property Value
Type: Boolean
true if this instance is primitive; otherwise, false.
Implements
IDataType.IsPrimitive
IDataType.IsPrimitive
Reference
ReferenceType Class
TwinCAT.Ads.TypeSystem Namespace


ReferenceType.ManagedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ReferenceType Class [image] ReferenceType Properties [image] ReferenceType.ManagedType Property
ReferenceType.ManagedType Property
Gets the corresponding .NET Type if attached.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override Type ManagedType { get; }
VB
Public Overrides ReadOnly Property ManagedType As Type
Get
Property Value
Type: Type
Dot net type.
Reference
ReferenceType Class
TwinCAT.Ads.TypeSystem Namespace


ReferenceType.ReferencedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ReferenceType Class [image] ReferenceType Properties [image] ReferenceType.ReferencedType Property
ReferenceType.ReferencedType Property
Gets the the referenced type.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType ReferencedType { get; }
VB
Public ReadOnly Property ReferencedType As IDataType
Get
Property Value
Type: IDataType
The type of the referenced.
Implements
IReferenceType.ReferencedType
Reference
ReferenceType Class
TwinCAT.Ads.TypeSystem Namespace


ReferenceType.ResolvedByteSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ReferenceType Class [image] ReferenceType Properties [image] ReferenceType.ResolvedByteSize Property
ReferenceType.ResolvedByteSize Property
Get the ByteSize of the (completely) resolved Symbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ResolvedByteSize { get; }
VB
Public ReadOnly Property ResolvedByteSize As Integer
Get
Property Value
Type: Int32
The size of the resolved byte.
Implements
IReferenceType.ResolvedByteSize
Reference
ReferenceType Class
TwinCAT.Ads.TypeSystem Namespace


ReferenceType.ResolvedCategory Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ReferenceType Class [image] ReferenceType Properties [image] ReferenceType.ResolvedCategory Property
ReferenceType.ResolvedCategory Property
Gets the Category of the (completely) resolved Symbol.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeCategory ResolvedCategory { get; }
VB
Public ReadOnly Property ResolvedCategory As DataTypeCategory
Get
Property Value
Type: DataTypeCategory
The resolved category.
Implements
IReferenceType.ResolvedCategory
Reference
ReferenceType Class
TwinCAT.Ads.TypeSystem Namespace


ReferenceType.ResolvedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ReferenceType Class [image] ReferenceType Properties [image] ReferenceType.ResolvedType Property
ReferenceType.ResolvedType Property
Gets the (completely) resolved type
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType ResolvedType { get; }
VB
Public ReadOnly Property ResolvedType As IDataType
Get
Property Value
Type: IDataType
The type of the resolved symbol
Implements
IReferenceType.ResolvedType
Reference
ReferenceType Class
TwinCAT.Ads.TypeSystem Namespace


ReferenceType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] ReferenceType Class [image] ReferenceType Methods
ReferenceType Methods
The ReferenceType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
ReferenceType Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethod Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class
RpcMethod Class
RPC Method Description
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.RpcMethod
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class RpcMethod : IRpcMethod
VB
Public Class RpcMethod
Implements IRpcMethod
The RpcMethod type exposes the following members.
Properties
Name | Description
Comment | Gets the Method comment.
IsVoid | Gets a value indicating whether this IRpcMethod has no return parameter
Name | Gets the name of the method
Parameters | Gets the Method parameter descriptions.
ReturnAlignSize | Gets the size of the biggest element in bytes for Alignment
ReturnType | Gets the return type.
ReturnTypeSize | Gets the Byte size of the return type.
VTableIndex | Gets the V-table index of the method.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethod Properties
•
RpcMethod Methods


RpcMethod Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class [image] RpcMethod Properties
RpcMethod Properties
The RpcMethod type exposes the following members.
Properties
Name | Description
Comment | Gets the Method comment.
IsVoid | Gets a value indicating whether this IRpcMethod has no return parameter
Name | Gets the name of the method
Parameters | Gets the Method parameter descriptions.
ReturnAlignSize | Gets the size of the biggest element in bytes for Alignment
ReturnType | Gets the return type.
ReturnTypeSize | Gets the Byte size of the return type.
VTableIndex | Gets the V-table index of the method.
Reference
RpcMethod Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethod.Comment Property
•
RpcMethod.IsVoid Property
•
RpcMethod.Name Property
•
RpcMethod.Parameters Property
•
RpcMethod.ReturnAlignSize Property
•
RpcMethod.ReturnType Property
•
RpcMethod.ReturnTypeSize Property
•
RpcMethod.VTableIndex Property


RpcMethod.Comment Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class [image] RpcMethod Properties [image] RpcMethod.Comment Property
RpcMethod.Comment Property
Gets the Method comment.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Comment { get; }
VB
Public ReadOnly Property Comment As String
Get
Property Value
Type: String
The comment.
Implements
IRpcMethod.Comment
Reference
RpcMethod Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethod.IsVoid Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class [image] RpcMethod Properties [image] RpcMethod.IsVoid Property
RpcMethod.IsVoid Property
Gets a value indicating whether this IRpcMethod has no return parameter
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsVoid { get; }
VB
Public ReadOnly Property IsVoid As Boolean
Get
Property Value
Type: Boolean
true if this instance is void; otherwise, false.
Implements
IRpcMethod.IsVoid
Exceptions
Exception | Condition
NotImplementedException |
Reference
RpcMethod Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethod.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class [image] RpcMethod Properties [image] RpcMethod.Name Property
RpcMethod.Name Property
Gets the name of the method
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Name { get; }
VB
Public ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Implements
IRpcMethod.Name
Reference
RpcMethod Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethod.Parameters Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class [image] RpcMethod Properties [image] RpcMethod.Parameters Property
RpcMethod.Parameters Property
Gets the Method parameter descriptions.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyMethodParameterCollection Parameters { get; }
VB
Public ReadOnly Property Parameters As ReadOnlyMethodParameterCollection
Get
Property Value
Type: ReadOnlyMethodParameterCollection
The parameters.
Implements
IRpcMethod.Parameters
Reference
RpcMethod Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethod.ReturnAlignSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class [image] RpcMethod Properties [image] RpcMethod.ReturnAlignSize Property
RpcMethod.ReturnAlignSize Property
Gets the size of the biggest element in bytes for Alignment
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReturnAlignSize { get; }
VB
Public ReadOnly Property ReturnAlignSize As Integer
Get
Property Value
Type: Int32
The size of the return align.
Reference
RpcMethod Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethod.ReturnType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class [image] RpcMethod Properties [image] RpcMethod.ReturnType Property
RpcMethod.ReturnType Property
Gets the return type.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string ReturnType { get; }
VB
Public ReadOnly Property ReturnType As String
Get
Property Value
Type: String
Return type.
Implements
IRpcMethod.ReturnType
Reference
RpcMethod Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethod.ReturnTypeSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class [image] RpcMethod Properties [image] RpcMethod.ReturnTypeSize Property
RpcMethod.ReturnTypeSize Property
Gets the Byte size of the return type.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ReturnTypeSize { get; }
VB
Public ReadOnly Property ReturnTypeSize As Integer
Get
Property Value
Type: Int32
The size of the return type.
Implements
IRpcMethod.ReturnTypeSize
Reference
RpcMethod Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethod.VTableIndex Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class [image] RpcMethod Properties [image] RpcMethod.VTableIndex Property
RpcMethod.VTableIndex Property
Gets the V-table index of the method.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int VTableIndex { get; }
VB
Public ReadOnly Property VTableIndex As Integer
Get
Property Value
Type: Int32
The index of the v table.
Reference
RpcMethod Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethod Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class [image] RpcMethod Methods
RpcMethod Methods
The RpcMethod type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
Reference
RpcMethod Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethod.ToString Method


RpcMethod.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethod Class [image] RpcMethod Methods [image] RpcMethod.ToString Method
RpcMethod.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
RpcMethod Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethodParameter Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethodParameter Class
RpcMethodParameter Class
Class RpcMethodParameter.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.RpcMethodParameter
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class RpcMethodParameter : IRpcMethodParameter
VB
Public Class RpcMethodParameter
Implements IRpcMethodParameter
The RpcMethodParameter type exposes the following members.
Properties
Name | Description
AlignSize | Gets the size of biggest element for alignment
Comment | Gets the Parameter Comment.
Name | Gets the Parameter Name
ParameterFlags | Gets the parameter flags.
Size | Gets the size of the RpcMethodParameter
TypeGuid | Gets the Unique identifier of the parameters data type.
TypeName | Gets the Data type of the Parameter
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethodParameter Properties
•
RpcMethodParameter Methods


RpcMethodParameter Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethodParameter Class [image] RpcMethodParameter Properties
RpcMethodParameter Properties
The RpcMethodParameter type exposes the following members.
Properties
Name | Description
AlignSize | Gets the size of biggest element for alignment
Comment | Gets the Parameter Comment.
Name | Gets the Parameter Name
ParameterFlags | Gets the parameter flags.
Size | Gets the size of the RpcMethodParameter
TypeGuid | Gets the Unique identifier of the parameters data type.
TypeName | Gets the Data type of the Parameter
Reference
RpcMethodParameter Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethodParameter.AlignSize Property
•
RpcMethodParameter.Comment Property
•
RpcMethodParameter.Name Property
•
RpcMethodParameter.ParameterFlags Property
•
RpcMethodParameter.Size Property
•
RpcMethodParameter.TypeGuid Property
•
RpcMethodParameter.TypeName Property


RpcMethodParameter.AlignSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethodParameter Class [image] RpcMethodParameter Properties [image] RpcMethodParameter.AlignSize Property
RpcMethodParameter.AlignSize Property
Gets the size of biggest element for alignment
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int AlignSize { get; }
VB
Public ReadOnly Property AlignSize As Integer
Get
Property Value
Type: Int32
The size of the align.
Reference
RpcMethodParameter Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethodParameter.Comment Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethodParameter Class [image] RpcMethodParameter Properties [image] RpcMethodParameter.Comment Property
RpcMethodParameter.Comment Property
Gets the Parameter Comment.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Comment { get; }
VB
Public ReadOnly Property Comment As String
Get
Property Value
Type: String
The comment.
Reference
RpcMethodParameter Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethodParameter.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethodParameter Class [image] RpcMethodParameter Properties [image] RpcMethodParameter.Name Property
RpcMethodParameter.Name Property
Gets the Parameter Name
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Name { get; }
VB
Public ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Implements
IRpcMethodParameter.Name
Reference
RpcMethodParameter Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethodParameter.ParameterFlags Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethodParameter Class [image] RpcMethodParameter Properties [image] RpcMethodParameter.ParameterFlags Property
RpcMethodParameter.ParameterFlags Property
Gets the parameter flags.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public MethodParamFlags ParameterFlags { get; }
VB
Public ReadOnly Property ParameterFlags As MethodParamFlags
Get
Property Value
Type: MethodParamFlags
The parameter flags.
Implements
IRpcMethodParameter.ParameterFlags
Reference
RpcMethodParameter Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethodParameter.Size Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethodParameter Class [image] RpcMethodParameter Properties [image] RpcMethodParameter.Size Property
RpcMethodParameter.Size Property
Gets the size of the RpcMethodParameter
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Size { get; }
VB
Public ReadOnly Property Size As Integer
Get
Property Value
Type: Int32
The size.
Implements
IRpcMethodParameter.Size
Reference
RpcMethodParameter Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethodParameter.TypeGuid Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethodParameter Class [image] RpcMethodParameter Properties [image] RpcMethodParameter.TypeGuid Property
RpcMethodParameter.TypeGuid Property
Gets the Unique identifier of the parameters data type.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Guid TypeGuid { get; }
VB
Public ReadOnly Property TypeGuid As Guid
Get
Property Value
Type: Guid
The type unique identifier.
Reference
RpcMethodParameter Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethodParameter.TypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethodParameter Class [image] RpcMethodParameter Properties [image] RpcMethodParameter.TypeName Property
RpcMethodParameter.TypeName Property
Gets the Data type of the Parameter
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string TypeName { get; }
VB
Public ReadOnly Property TypeName As String
Get
Property Value
Type: String
The type.
Implements
IRpcMethodParameter.TypeName
Reference
RpcMethodParameter Class
TwinCAT.Ads.TypeSystem Namespace


RpcMethodParameter Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcMethodParameter Class [image] RpcMethodParameter Methods
RpcMethodParameter Methods
The RpcMethodParameter type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
RpcMethodParameter Class
TwinCAT.Ads.TypeSystem Namespace


RpcStructType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcStructType Class
RpcStructType Class
StructType which is callable by RPC Methods.
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.StructType
TwinCAT.Ads.TypeSystem.RpcStructType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class RpcStructType : StructType,
IRpcCallableType
VB
Public NotInheritable Class RpcStructType
Inherits StructType
Implements IRpcCallableType
The RpcStructType type exposes the following members.
Properties
Name | Description
AllMembers | Gets all members (down the derivation hierarchy) (Inherited from StructType.)
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BaseType | Gets the structs Base Type (Null if not derived). (Inherited from StructType.)
BaseTypeName | Gets the the Name of the Base class (if derived) (Inherited from StructType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
HasRpcMethods | Gets a value indicating whether this instance has RPC Methods. (Overrides StructType.HasRpcMethods.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsDerived | Gets a value indicating whether this instance is derived. (Inherited from StructType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Members | Gets a read only collection of the Members of the IStructType. (Inherited from StructType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
RpcMethods | Gets the Method descriptions for the IRpcCallableType
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
RpcStructType Properties
•
RpcStructType Methods


RpcStructType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcStructType Class [image] RpcStructType Properties
RpcStructType Properties
The RpcStructType type exposes the following members.
Properties
Name | Description
AllMembers | Gets all members (down the derivation hierarchy) (Inherited from StructType.)
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BaseType | Gets the structs Base Type (Null if not derived). (Inherited from StructType.)
BaseTypeName | Gets the the Name of the Base class (if derived) (Inherited from StructType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
HasRpcMethods | Gets a value indicating whether this instance has RPC Methods. (Overrides StructType.HasRpcMethods.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsDerived | Gets a value indicating whether this instance is derived. (Inherited from StructType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Members | Gets a read only collection of the Members of the IStructType. (Inherited from StructType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
RpcMethods | Gets the Method descriptions for the IRpcCallableType
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
RpcStructType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
RpcStructType.HasRpcMethods Property
•
RpcStructType.RpcMethods Property


RpcStructType.HasRpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcStructType Class [image] RpcStructType Properties [image] RpcStructType.HasRpcMethods Property
RpcStructType.HasRpcMethods Property
Gets a value indicating whether this instance has RPC Methods.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool HasRpcMethods { get; }
VB
Public Overrides ReadOnly Property HasRpcMethods As Boolean
Get
Property Value
Type: Boolean
true if this instance has methods; otherwise, false.
Implements
IStructType.HasRpcMethods
Remarks
The DataType (Structure) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods, otherwise RpcMethods are not passed through to the ADS symbolic information.
Reference
RpcStructType Class
TwinCAT.Ads.TypeSystem Namespace


RpcStructType.RpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcStructType Class [image] RpcStructType Properties [image] RpcStructType.RpcMethods Property
RpcStructType.RpcMethods Property
Gets the Method descriptions for the IRpcCallableType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyRpcMethodCollection RpcMethods { get; }
VB
Public ReadOnly Property RpcMethods As ReadOnlyRpcMethodCollection
Get
Property Value
Type: ReadOnlyRpcMethodCollection
The methods.
Implements
IRpcCallableType.RpcMethods
Remarks
The DataType (Structure) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods, otherwise RpcMethods are not passed through to the ADS symbolic information.
Reference
RpcStructType Class
TwinCAT.Ads.TypeSystem Namespace


RpcStructType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] RpcStructType Class [image] RpcStructType Methods
RpcStructType Methods
The RpcStructType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
RpcStructType Class
TwinCAT.Ads.TypeSystem Namespace


StringType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StringType Class
StringType Class
String DataType
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.StringType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class StringType : DataType,
IStringType, IDataType, IBitSize
VB
Public NotInheritable Class StringType
Inherits DataType
Implements IStringType, IDataType, IBitSize
The StringType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
Encoding | Gets the encoding of the String (Encoding.ASCII (STRING) or Encoding.UNICODE (WSTRING))
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsFixedLength | Gets a value indicating whether the string is of fixed length.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
Length | Gets the number of characters within the string.
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides DataType.ToString..)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
StringType Properties
•
StringType Methods


StringType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StringType Class [image] StringType Properties
StringType Properties
The StringType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
Encoding | Gets the encoding of the String (Encoding.ASCII (STRING) or Encoding.UNICODE (WSTRING))
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsFixedLength | Gets a value indicating whether the string is of fixed length.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
Length | Gets the number of characters within the string.
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
StringType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
StringType.Encoding Property
•
StringType.IsFixedLength Property
•
StringType.Length Property


StringType.Encoding Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StringType Class [image] StringType Properties [image] StringType.Encoding Property
StringType.Encoding Property
Gets the encoding of the String (Encoding.ASCII (STRING) or Encoding.UNICODE (WSTRING))
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Encoding Encoding { get; }
VB
Public ReadOnly Property Encoding As Encoding
Get
Property Value
Type: Encoding
The encoding.
Implements
IStringType.Encoding
Reference
StringType Class
TwinCAT.Ads.TypeSystem Namespace


StringType.IsFixedLength Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StringType Class [image] StringType Properties [image] StringType.IsFixedLength Property
StringType.IsFixedLength Property
Gets a value indicating whether the string is of fixed length.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsFixedLength { get; }
VB
Public ReadOnly Property IsFixedLength As Boolean
Get
Property Value
Type: Boolean
true if this instance is fixed length; otherwise, false.
Implements
IStringType.IsFixedLength
Exceptions
Exception | Condition
NotImplementedException |
Reference
StringType Class
TwinCAT.Ads.TypeSystem Namespace


StringType.Length Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StringType Class [image] StringType Properties [image] StringType.Length Property
StringType.Length Property
Gets the number of characters within the string.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Length { get; }
VB
Public ReadOnly Property Length As Integer
Get
Property Value
Type: Int32
The length.
Implements
IStringType.Length
Reference
StringType Class
TwinCAT.Ads.TypeSystem Namespace


StringType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StringType Class [image] StringType Methods
StringType Methods
The StringType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides DataType.ToString..)
Reference
StringType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
StringType.ToString Method


StringType.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StringType Class [image] StringType Methods [image] StringType.ToString Method
StringType.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
StringType Class
TwinCAT.Ads.TypeSystem Namespace


StructType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StructType Class
StructType Class
Represents a struct type
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.StructType
TwinCAT.Ads.TypeSystem.RpcStructType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class StructType : DataType, IStructType,
IDataType, IBitSize
VB
Public Class StructType
Inherits DataType
Implements IStructType, IDataType, IBitSize
The StructType type exposes the following members.
Properties
Name | Description
AllMembers | Gets all members (down the derivation hierarchy)
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BaseType | Gets the structs Base Type (Null if not derived).
BaseTypeName | Gets the the Name of the Base class (if derived)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
HasRpcMethods | Gets a value indicating whether this StructType has RPC Methods.
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsDerived | Gets a value indicating whether this instance is derived.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Members | Gets a read only collection of the Members of the IStructType.
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
StructType Properties
•
StructType Methods


StructType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StructType Class [image] StructType Properties
StructType Properties
The StructType type exposes the following members.
Properties
Name | Description
AllMembers | Gets all members (down the derivation hierarchy)
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BaseType | Gets the structs Base Type (Null if not derived).
BaseTypeName | Gets the the Name of the Base class (if derived)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
HasRpcMethods | Gets a value indicating whether this StructType has RPC Methods.
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsDerived | Gets a value indicating whether this instance is derived.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Members | Gets a read only collection of the Members of the IStructType.
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
StructType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
StructType.AllMembers Property
•
StructType.BaseType Property
•
StructType.BaseTypeName Property
•
StructType.HasRpcMethods Property
•
StructType.IsDerived Property
•
StructType.Members Property


StructType.AllMembers Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StructType Class [image] StructType Properties [image] StructType.AllMembers Property
StructType.AllMembers Property
Gets all members (down the derivation hierarchy)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyMemberCollection AllMembers { get; }
VB
Public ReadOnly Property AllMembers As ReadOnlyMemberCollection
Get
Property Value
Type: ReadOnlyMemberCollection
All members.
Implements
IStructType.AllMembers
Reference
StructType Class
TwinCAT.Ads.TypeSystem Namespace


StructType.BaseType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StructType Class [image] StructType Properties [image] StructType.BaseType Property
StructType.BaseType Property
Gets the structs Base Type (Null if not derived).
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType BaseType { get; }
VB
Public ReadOnly Property BaseType As IDataType
Get
Property Value
Type: IDataType
Implements
IStructType.BaseType
Reference
StructType Class
TwinCAT.Ads.TypeSystem Namespace


StructType.BaseTypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StructType Class [image] StructType Properties [image] StructType.BaseTypeName Property
StructType.BaseTypeName Property
Gets the the Name of the Base class (if derived)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string BaseTypeName { get; }
VB
Public ReadOnly Property BaseTypeName As String
Get
Property Value
Type: String
Empty if not derived.
Implements
IStructType.BaseTypeName
Reference
StructType Class
TwinCAT.Ads.TypeSystem Namespace


StructType.HasRpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StructType Class [image] StructType Properties [image] StructType.HasRpcMethods Property
StructType.HasRpcMethods Property
Gets a value indicating whether this StructType has RPC Methods.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual bool HasRpcMethods { get; }
VB
Public Overridable ReadOnly Property HasRpcMethods As Boolean
Get
Property Value
Type: Boolean
true if this type has methods; otherwise, false.
Implements
IStructType.HasRpcMethods
Remarks
The DataType (Structure) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods, otherwise RpcMethods are not passed through to the ADS symbolic information.
Reference
StructType Class
TwinCAT.Ads.TypeSystem Namespace


StructType.IsDerived Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StructType Class [image] StructType Properties [image] StructType.IsDerived Property
StructType.IsDerived Property
Gets a value indicating whether this instance is derived.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsDerived { get; }
VB
Public ReadOnly Property IsDerived As Boolean
Get
Property Value
Type: Boolean
true if this instance is derived; otherwise, false.
Reference
StructType Class
TwinCAT.Ads.TypeSystem Namespace


StructType.Members Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StructType Class [image] StructType Properties [image] StructType.Members Property
StructType.Members Property
Gets a read only collection of the Members of the IStructType.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyMemberCollection Members { get; }
VB
Public ReadOnly Property Members As ReadOnlyMemberCollection
Get
Property Value
Type: ReadOnlyMemberCollection
The members as read only collection.
Implements
IStructType.Members
Remarks
If the IStructType is derived, only the extended members are returned. To get all supported members down the inheritance chain, use the AllMembers property.
Reference
StructType Class
TwinCAT.Ads.TypeSystem Namespace


StructType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] StructType Class [image] StructType Methods
StructType Methods
The StructType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
StructType Class
TwinCAT.Ads.TypeSystem Namespace


SubRangeType.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] SubRangeType.T. Class
SubRangeType.T. Class
Represents a SubRangType
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.SubRangeType.T.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class SubRangeType<T> : DataType,
ISubRangeType<T>, ISubRangeType, IDataType, IBitSize
where T : struct, new()
VB
Public NotInheritable Class SubRangeType(Of T As {Structure, New})
Inherits DataType
Implements ISubRangeType(Of T), ISubRangeType, IDataType,
IBitSize
Type Parameters
T
The SubRangeType.T. type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BaseType | Gets the the base type.
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
LowerBound | Gets the lower bound.
ManagedType | Gets the corresponding .NET Type if attached. (Overrides DataType.ManagedType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
UpperBound | Gets the upper bound.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
SubRangeType.T. Properties
•
SubRangeType.T. Methods


SubRangeType.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] SubRangeType.T. Class [image] SubRangeType.T. Properties
SubRangeType.T. Properties
The SubRangeType.T. generic type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BaseType | Gets the the base type.
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
LowerBound | Gets the lower bound.
ManagedType | Gets the corresponding .NET Type if attached. (Overrides DataType.ManagedType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
UpperBound | Gets the upper bound.
Reference
SubRangeType.T. Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
SubRangeType.T..BaseType Property
•
SubRangeType.T..LowerBound Property
•
SubRangeType.T..ManagedType Property
•
SubRangeType.T..UpperBound Property


SubRangeType.T..BaseType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] SubRangeType.T. Class [image] SubRangeType.T. Properties [image] SubRangeType.T..BaseType Property
SubRangeType.T..BaseType Property
Gets the the base type.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType BaseType { get; }
VB
Public ReadOnly Property BaseType As IDataType
Get
Property Value
Type: IDataType
The type of the referenced.
Implements
ISubRangeType.BaseType
Reference
SubRangeType.T. Class
TwinCAT.Ads.TypeSystem Namespace


SubRangeType.T..LowerBound Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] SubRangeType.T. Class [image] SubRangeType.T. Properties [image] SubRangeType.T..LowerBound Property
SubRangeType.T..LowerBound Property
Gets the lower bound.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T LowerBound { get; }
VB
Public ReadOnly Property LowerBound As T
Get
Property Value
Type: T
The lower bound.
Implements
ISubRangeType.T..LowerBound
Reference
SubRangeType.T. Class
TwinCAT.Ads.TypeSystem Namespace


SubRangeType.T..ManagedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] SubRangeType.T. Class [image] SubRangeType.T. Properties [image] SubRangeType.T..ManagedType Property
SubRangeType.T..ManagedType Property
Gets the corresponding .NET Type if attached.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override Type ManagedType { get; }
VB
Public Overrides ReadOnly Property ManagedType As Type
Get
Property Value
Type: Type
Dot net type.
Reference
SubRangeType.T. Class
TwinCAT.Ads.TypeSystem Namespace


SubRangeType.T..UpperBound Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] SubRangeType.T. Class [image] SubRangeType.T. Properties [image] SubRangeType.T..UpperBound Property
SubRangeType.T..UpperBound Property
Gets the upper bound.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T UpperBound { get; }
VB
Public ReadOnly Property UpperBound As T
Get
Property Value
Type: T
The lower bound.
Implements
ISubRangeType.T..UpperBound
Reference
SubRangeType.T. Class
TwinCAT.Ads.TypeSystem Namespace


SubRangeType.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] SubRangeType.T. Class [image] SubRangeType.T. Methods
SubRangeType.T. Methods
The SubRangeType.T. generic type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
SubRangeType.T. Class
TwinCAT.Ads.TypeSystem Namespace


Symbol Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class
Symbol Class
Symbol class
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.Instance
TwinCAT.Ads.TypeSystem.Symbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class Symbol : Instance, IValueSymbol3,
IValueSymbol2, IValueSymbol, IValueRawSymbol, ISymbol, IAttributedInstance,
IInstance, IBitSize, IValueAnySymbol, IAdsSymbol, IProcessImageAddress
VB
Public Class Symbol
Inherits Instance
Implements IValueSymbol3, IValueSymbol2, IValueSymbol, IValueRawSymbol,
ISymbol, IAttributedInstance, IInstance, IBitSize, IValueAnySymbol,
IAdsSymbol, IProcessImageAddress
The Symbol type exposes the following members.
Properties
Name | Description
AccessRights | Gets the access rights.
Attributes | Gets the Type Attributes. (Inherited from Instance.)
BitSize | Gets the size of this Instance in bits. (Inherited from Instance.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from Instance.)
Category | Gets the the DataTypeCategory of the Instance. (Inherited from Instance.)
Comment | Gets the comment. (Inherited from Instance.)
Connection | Gets the connection that produces values for this IValueSymbol
ContextMask | Gets the context mask of this instance. (Inherited from Instance.)
DataType | Gets the IDataType of the IInstance. (Inherited from Instance.)
HasValue | Gets a value indicating whether this instance has a value. (Inherited from Instance.)
ImageBaseAddress | Gets the AmsAddress of the Process Image
IndexGroup | Gets the index group of the Symbol
IndexOffset | Gets the index offset of the Symbol
InstanceName | Gets the name of the instance (without periods (.) (Inherited from Instance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Overrides Instance.InstancePath.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from Instance.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from Instance.)
IsContainerType | Gets a value indicating whether the Symbols datatype is a Container type.
IsDereferencedPointer | Gets or sets a value indicating whether an ancestor is a dereferenced Pointer
IsDereferencedReference | Gets or sets a value indicating whether an ancestor is a dereferenced Reference
IsPersistent | Indicates if this instance is persistent. (Inherited from Instance.)
IsPointer | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsPrimitiveType | Gets a value indicating whether this instance is primitive.
IsReadOnly | Indicates if this instance is read only. (Inherited from Instance.)
IsRecursive | Gets a value indicating whether this instance is recursive.
IsReference | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from Instance.)
IsTcComInterfacePointer | Indicates if this instance is a TcComInterfacePointer. (Inherited from Instance.)
IsTypeGuid | Indicates if this instance has set TypeGuid flag. (Inherited from Instance.)
Namespace | Gets the namespace name. (Inherited from Instance.)
NotificationSettings | Gets or sets the notification settings.
Parent | Gets the parent Symbol
Size | Gets the size of the IDataType in bytes or Bits dependant on IsBitType (Inherited from Instance.)
SubSymbolCount | Gets the number of SubSymbols
SubSymbols | Gets the SubSymbols of the ISymbol
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from Instance.)
Methods
Name | Description
EnsureRights | Ensures that the AccessRights are matched.
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnGetSize | Handler function getting the size of the Instance (Inherited from Instance.)
OnReadRawValue | Handler function for reading the raw value
OnReadValue | Handler function for reading the dynamic value.
OnSetInstanceName | Sets a new InstanceName InstancePath (Overrides Instance.OnSetInstanceName(String).)
OnTryReadValue | Handler function for reading the dynamic value.
OnTryWriteValue | Handler function for writing the dynamic value
OnWriteRawValue | Handler function for writing the RawValue
OnWriteValue | Handler function for writing the dynamic value
ReadAnyValue(Type) | Reads the value of this Value into a new created instance of the managed type
ReadAnyValue(Type, Int32) | Reads the value of this Value into a new created instance of the managed type
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write)
ReadValue. | Reads the Value of the IValueSymbol
ReadValue(Int32) | Reads the Value of the IValueSymbol
SetContextMask | Sets the context mask. (Inherited from Instance.)
SetParent | Sets the parent symbol.
ToString | Returns a String that represents this instance. (Overrides Instance.ToString..)
TryReadValue | Reads the Value of the IValueSymbol
TryWriteValue | Writes the Value of the IValueSymbol
UpdateAnyValue(Object.) | Reads the value of this Value into the specified managed value.
UpdateAnyValue(Object., Int32) | Reads the value of this Value into the specified managed value.
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write)
WriteValue(Object) | Writes the Value of the IValueSymbol
WriteValue(Object, Int32) | Writes the Value of the IValueSymbol
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed.
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed.
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Fields
Name | Description
attributes | The attributes (Inherited from Instance.)
Extension Methods
Name | Description
PollValuesAnnotated(IObservable.Unit.) | Overloaded. Polls the values as ValueChangedArgs sequence annotated value on trigger sequence (Defined by ValueSymbolExtensions.)
PollValuesAnnotated(TimeSpan) | Overloaded. Polls the values as ValueChangedArgs sequence with a specified period time. (Defined by ValueSymbolExtensions.)
WhenValueChanged | Gets an observable sequence when the value of the IValueSymbol has changed. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
Remarks
A Symbol is a (named) memory object within the Process Image with a fixed address indicated by Index Group and Index Offset. Symbols can optionally be addressed by instance path and are bound to a specific DataType.
Reference
TwinCAT.Ads.TypeSystem Namespace
TwinCAT.Ads.TypeSystem.Instance
TwinCAT.TypeSystem.IValueSymbol
TwinCAT.TypeSystem.IValueAnySymbol
IValueAccessorProvider
ISymbolFactoryServicesProvider
IHierarchicalSymbol
ISymbolValueChangeNotify
IContextMaskProvider
IInstanceInternal
ISymbolInternal
TwinCAT.Ads.TypeSystem.IAdsSymbol
Weiterführende Informationen
•
Symbol Properties
•
Symbol Methods
•
Symbol Events
•
Symbol Operators
•
Symbol Fields


Symbol Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties
Symbol Properties
The Symbol type exposes the following members.
Properties
Name | Description
AccessRights | Gets the access rights.
Attributes | Gets the Type Attributes. (Inherited from Instance.)
BitSize | Gets the size of this Instance in bits. (Inherited from Instance.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from Instance.)
Category | Gets the the DataTypeCategory of the Instance. (Inherited from Instance.)
Comment | Gets the comment. (Inherited from Instance.)
Connection | Gets the connection that produces values for this IValueSymbol
ContextMask | Gets the context mask of this instance. (Inherited from Instance.)
DataType | Gets the IDataType of the IInstance. (Inherited from Instance.)
HasValue | Gets a value indicating whether this instance has a value. (Inherited from Instance.)
ImageBaseAddress | Gets the AmsAddress of the Process Image
IndexGroup | Gets the index group of the Symbol
IndexOffset | Gets the index offset of the Symbol
InstanceName | Gets the name of the instance (without periods (.) (Inherited from Instance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Overrides Instance.InstancePath.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from Instance.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from Instance.)
IsContainerType | Gets a value indicating whether the Symbols datatype is a Container type.
IsDereferencedPointer | Gets or sets a value indicating whether an ancestor is a dereferenced Pointer
IsDereferencedReference | Gets or sets a value indicating whether an ancestor is a dereferenced Reference
IsPersistent | Indicates if this instance is persistent. (Inherited from Instance.)
IsPointer | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsPrimitiveType | Gets a value indicating whether this instance is primitive.
IsReadOnly | Indicates if this instance is read only. (Inherited from Instance.)
IsRecursive | Gets a value indicating whether this instance is recursive.
IsReference | Gets a value indicating whether this instance is reference. (Inherited from Instance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from Instance.)
IsTcComInterfacePointer | Indicates if this instance is a TcComInterfacePointer. (Inherited from Instance.)
IsTypeGuid | Indicates if this instance has set TypeGuid flag. (Inherited from Instance.)
Namespace | Gets the namespace name. (Inherited from Instance.)
NotificationSettings | Gets or sets the notification settings.
Parent | Gets the parent Symbol
Size | Gets the size of the IDataType in bytes or Bits dependant on IsBitType (Inherited from Instance.)
SubSymbolCount | Gets the number of SubSymbols
SubSymbols | Gets the SubSymbols of the ISymbol
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from Instance.)
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Symbol.AccessRights Property
•
Symbol.Connection Property
•
Symbol.ImageBaseAddress Property
•
Symbol.IndexGroup Property
•
Symbol.IndexOffset Property
•
Symbol.InstancePath Property
•
Symbol.IsContainerType Property
•
Symbol.IsDereferencedPointer Property
•
Symbol.IsDereferencedReference Property
•
Symbol.IsPrimitiveType Property
•
Symbol.IsRecursive Property
•
Symbol.NotificationSettings Property
•
Symbol.Parent Property
•
Symbol.SubSymbolCount Property
•
Symbol.SubSymbols Property


Symbol.AccessRights Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.AccessRights Property
Symbol.AccessRights Property
Gets the access rights.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolAccessRights AccessRights { get; }
VB
Public ReadOnly Property AccessRights As SymbolAccessRights
Get
Property Value
Type: SymbolAccessRights
The access rights.
Implements
IValueSymbol.AccessRights
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.Connection Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.Connection Property
Symbol.Connection Property
Gets the connection that produces values for this IValueSymbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IConnection Connection { get; }
VB
Public ReadOnly Property Connection As IConnection
Get
Property Value
Type: IConnection
The connection object.
Implements
IValueSymbol2.Connection
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.ImageBaseAddress Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.ImageBaseAddress Property
Symbol.ImageBaseAddress Property
Gets the AmsAddress of the Process Image
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public AmsAddress ImageBaseAddress { get; }
VB
Public ReadOnly Property ImageBaseAddress As AmsAddress
Get
Property Value
Type: AmsAddress
The address.
Implements
IAdsSymbol.ImageBaseAddress
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.IndexGroup Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.IndexGroup Property
Symbol.IndexGroup Property
Gets the index group of the Symbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public uint IndexGroup { get; }
VB
Public ReadOnly Property IndexGroup As UInteger
Get
Property Value
Type: UInt32
The index group.
Implements
IProcessImageAddress.IndexGroup
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.IndexOffset Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.IndexOffset Property
Symbol.IndexOffset Property
Gets the index offset of the Symbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public uint IndexOffset { get; }
VB
Public ReadOnly Property IndexOffset As UInteger
Get
Property Value
Type: UInt32
The index offset.
Implements
IProcessImageAddress.IndexOffset
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.InstancePath Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.InstancePath Property
Symbol.InstancePath Property
Gets the relative / absolute access path to the instance (with periods (.))
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string InstancePath { get; }
VB
Public Overrides ReadOnly Property InstancePath As String
Get
Property Value
Type: String
The instance path.
Implements
IInstance.InstancePath
IInstance.InstancePath
Remarks
If this path is relative or absolute depends on the context. IMember are using relative paths, ISymbols are using absolute ones.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.IsContainerType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.IsContainerType Property
Symbol.IsContainerType Property
Gets a value indicating whether the Symbols datatype is a Container type.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual bool IsContainerType { get; }
VB
Public Overridable ReadOnly Property IsContainerType As Boolean
Get
Property Value
Type: Boolean
true if this instance is container type; otherwise, false.
Implements
ISymbol.IsContainerType
Remarks
Container Types are all types that contain SubElements like
▪
Array
▪
Pointer
▪
Union
▪
Struct
▪
Function
▪
FunctionBlock
▪
Program
and the Alias and Reference types, if they have a container type as base type.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace
IDataType.Category


Symbol.IsDereferencedPointer Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.IsDereferencedPointer Property
Symbol.IsDereferencedPointer Property
Gets or sets a value indicating whether an ancestor is a dereferenced Pointer
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsDereferencedPointer { get; }
VB
Public ReadOnly Property IsDereferencedPointer As Boolean
Get
Property Value
Type: Boolean
true if this instance is ancestor is pointer; otherwise, false.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.IsDereferencedReference Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.IsDereferencedReference Property
Symbol.IsDereferencedReference Property
Gets or sets a value indicating whether an ancestor is a dereferenced Reference
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsDereferencedReference { get; }
VB
Public ReadOnly Property IsDereferencedReference As Boolean
Get
Property Value
Type: Boolean
true if this instance is ancestor is reference; otherwise, false.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.IsPrimitiveType Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.IsPrimitiveType Property
Symbol.IsPrimitiveType Property
Gets a value indicating whether this instance is primitive.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual bool IsPrimitiveType { get; }
VB
Public Overridable ReadOnly Property IsPrimitiveType As Boolean
Get
Property Value
Type: Boolean
true if this instance is primitive; otherwise, false.
Implements
ISymbol.IsPrimitiveType
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.IsRecursive Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.IsRecursive Property
Symbol.IsRecursive Property
Gets a value indicating whether this instance is recursive.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsRecursive { get; }
VB
Public ReadOnly Property IsRecursive As Boolean
Get
Property Value
Type: Boolean
true if this instance is recursive; otherwise, false.
Implements
ISymbol.IsRecursive
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.NotificationSettings Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.NotificationSettings Property
Symbol.NotificationSettings Property
Gets or sets the notification settings.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public INotificationSettings NotificationSettings { get; set; }
VB
Public Property NotificationSettings As INotificationSettings
Get
Set
Property Value
Type: INotificationSettings
The notification settings.
Implements
IValueSymbol.NotificationSettings
Remarks
The NotificationSettings will be inherited from Parent if the setting is not overwritten. If the Root Symbol also doesn't contain the settings, then the DefaultNotificationSettings will be returned.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.Parent Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.Parent Property
Symbol.Parent Property
Gets the parent Symbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ISymbol Parent { get; }
VB
Public ReadOnly Property Parent As ISymbol
Get
Property Value
Type: ISymbol
The parent.
Implements
ISymbol.Parent
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.SubSymbolCount Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.SubSymbolCount Property
Symbol.SubSymbolCount Property
Gets the number of SubSymbols
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int SubSymbolCount { get; }
VB
Public ReadOnly Property SubSymbolCount As Integer
Get
Property Value
Type: Int32
The Number of SubSymbols.
Remarks
If the SubSymbols collection is not generated yet (WeakReference), then this method is less memory and cpu consuming to use for just determining the the number of child symbols (instead of using SubSymbols.Count)/>
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.SubSymbols Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Properties [image] Symbol.SubSymbols Property
Symbol.SubSymbols Property
Gets the SubSymbols of the ISymbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySymbolCollection SubSymbols { get; }
VB
Public ReadOnly Property SubSymbols As ReadOnlySymbolCollection
Get
Property Value
Type: ReadOnlySymbolCollection
Implements
ISymbol.SubSymbols
Remarks
Used for Array, Struct, Pointer and Reference instances. Otherwise empty
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods
Symbol Methods
The Symbol type exposes the following members.
Methods
Name | Description
EnsureRights | Ensures that the AccessRights are matched.
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnGetSize | Handler function getting the size of the Instance (Inherited from Instance.)
OnReadRawValue | Handler function for reading the raw value
OnReadValue | Handler function for reading the dynamic value.
OnSetInstanceName | Sets a new InstanceName InstancePath (Overrides Instance.OnSetInstanceName(String).)
OnTryReadValue | Handler function for reading the dynamic value.
OnTryWriteValue | Handler function for writing the dynamic value
OnWriteRawValue | Handler function for writing the RawValue
OnWriteValue | Handler function for writing the dynamic value
ReadAnyValue(Type) | Reads the value of this Value into a new created instance of the managed type
ReadAnyValue(Type, Int32) | Reads the value of this Value into a new created instance of the managed type
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write)
ReadValue. | Reads the Value of the IValueSymbol
ReadValue(Int32) | Reads the Value of the IValueSymbol
SetContextMask | Sets the context mask. (Inherited from Instance.)
SetParent | Sets the parent symbol.
ToString | Returns a String that represents this instance. (Overrides Instance.ToString..)
TryReadValue | Reads the Value of the IValueSymbol
TryWriteValue | Writes the Value of the IValueSymbol
UpdateAnyValue(Object.) | Reads the value of this Value into the specified managed value.
UpdateAnyValue(Object., Int32) | Reads the value of this Value into the specified managed value.
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write)
WriteValue(Object) | Writes the Value of the IValueSymbol
WriteValue(Object, Int32) | Writes the Value of the IValueSymbol
Extension Methods
Name | Description
PollValuesAnnotated(IObservable.Unit.) | Overloaded. Polls the values as ValueChangedArgs sequence annotated value on trigger sequence (Defined by ValueSymbolExtensions.)
PollValuesAnnotated(TimeSpan) | Overloaded. Polls the values as ValueChangedArgs sequence with a specified period time. (Defined by ValueSymbolExtensions.)
WhenValueChanged | Gets an observable sequence when the value of the IValueSymbol has changed. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Symbol.EnsureRights Method
•
Symbol.Equals Method
•
Symbol.GetHashCode Method
•
Symbol.OnReadRawValue Method
•
Symbol.OnReadValue Method
•
Symbol.OnSetInstanceName Method
•
Symbol.OnTryReadValue Method
•
Symbol.OnTryWriteValue Method
•
Symbol.OnWriteRawValue Method
•
Symbol.OnWriteValue Method
•
Symbol.ReadAnyValue Method
•
Symbol.ReadRawValue Method
•
Symbol.ReadValue Method
•
Symbol.SetParent Method
•
Symbol.ToString Method
•
Symbol.TryReadValue Method
•
Symbol.TryWriteValue Method
•
Symbol.UpdateAnyValue Method
•
Symbol.WriteRawValue Method
•
Symbol.WriteValue Method


Symbol.EnsureRights Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.EnsureRights Method
Symbol.EnsureRights Method
Ensures that the AccessRights are matched.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected void EnsureRights(
SymbolAccessRights requested
)
VB
Protected Sub EnsureRights (
requested As SymbolAccessRights
)
Parameters
requested
Type: TwinCAT.TypeSystem.SymbolAccessRights
The requested rights.
Exceptions
Exception | Condition
InsufficientAccessRights |
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.Equals Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.Equals Method
Symbol.Equals Method
Equals
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool Equals(
Object obj
)
VB
Public Overrides Function Equals (
obj As Object
) As Boolean
Parameters
obj
Type: System.Object
The object to compare with the current object.
Return Value
Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.GetHashCode Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.GetHashCode Method
Symbol.GetHashCode Method
Gets the HashCode of the Address
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override int GetHashCode()
VB
Public Overrides Function GetHashCode As Integer
Return Value
Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.OnReadRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.OnReadRawValue Method
Symbol.OnReadRawValue Method
Handler function for reading the raw value
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual byte[] OnReadRawValue(
int timeout
)
VB
Protected Overridable Function OnReadRawValue (
timeout As Integer
) As Byte()
Parameters
timeout
Type: System.Int32
Return Value
Type: .Byte.
System.Byte[].
Exceptions
Exception | Condition
AdsErrorException |
AdsErrorException |
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.OnReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.OnReadValue Method
Symbol.OnReadValue Method
Handler function for reading the dynamic value.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual Object OnReadValue(
int timeout
)
VB
Protected Overridable Function OnReadValue (
timeout As Integer
) As Object
Parameters
timeout
Type: System.Int32
Return Value
Type: Object
The Value
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.OnSetInstanceName Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.OnSetInstanceName Method
Symbol.OnSetInstanceName Method
Sets a new InstanceName InstancePath
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected override void OnSetInstanceName(
string instanceName
)
VB
Protected Overrides Sub OnSetInstanceName (
instanceName As String
)
Parameters
instanceName
Type: System.String
Instance name.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.OnTryReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.OnTryReadValue Method
Symbol.OnTryReadValue Method
Handler function for reading the dynamic value.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual int OnTryReadValue(
int timeout,
out Object value
)
VB
Protected Overridable Function OnTryReadValue (
timeout As Integer,
<OutAttribute> ByRef value As Object
) As Integer
Parameters
timeout | Type: System.Int32
value | Type: System.Object.
Return Value
Type: Int32
The Value
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.OnTryWriteValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.OnTryWriteValue Method
Symbol.OnTryWriteValue Method
Handler function for writing the dynamic value
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual int OnTryWriteValue(
Object value,
int timeout
)
VB
Protected Overridable Function OnTryWriteValue (
value As Object,
timeout As Integer
) As Integer
Parameters
value | Type: System.Object The value.
timeout | Type: System.Int32 The timeout.
Return Value
Type: Int32
Exceptions
Exception | Condition
CannotAccessVirtualSymbolException |
AdsSymbolException |
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.OnWriteRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.OnWriteRawValue Method
Symbol.OnWriteRawValue Method
Handler function for writing the RawValue
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual void OnWriteRawValue(
byte[] value,
int timeout
)
VB
Protected Overridable Sub OnWriteRawValue (
value As Byte(),
timeout As Integer
)
Parameters
value | Type: .System.Byte. The value.
timeout | Type: System.Int32 The timeout.
Exceptions
Exception | Condition
CannotAccessVirtualSymbolException |
SymbolException |
SymbolException |
AdsErrorException |
AdsSymbolException |
AdsErrorException |
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.OnWriteValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.OnWriteValue Method
Symbol.OnWriteValue Method
Handler function for writing the dynamic value
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual void OnWriteValue(
Object value,
int timeout
)
VB
Protected Overridable Sub OnWriteValue (
value As Object,
timeout As Integer
)
Parameters
value | Type: System.Object The value.
timeout | Type: System.Int32 The timeout.
Exceptions
Exception | Condition
CannotAccessVirtualSymbolException |
AdsSymbolException |
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.ReadAnyValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.ReadAnyValue Method
Symbol.ReadAnyValue Method
Overload List
Name | Description
ReadAnyValue(Type) | Reads the value of this Value into a new created instance of the managed type
ReadAnyValue(Type, Int32) | Reads the value of this Value into a new created instance of the managed type
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Symbol.ReadAnyValue Method (Type)
•
Symbol.ReadAnyValue Method (Type, Int32)


Symbol.ReadAnyValue Method (Type)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.ReadAnyValue Method [image] Symbol.ReadAnyValue Method (Type)
Symbol.ReadAnyValue Method (Type)
Reads the value of this Value into a new created instance of the managed type
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAnyValue(
Type managedType
)
VB
Public Function ReadAnyValue (
managedType As Type
) As Object
Parameters
managedType
Type: System.Type
The tp.
Return Value
Type: Object
Read value (System.Object).
Implements
IValueAnySymbol.ReadAnyValue(Type)
Reference
Symbol Class
ReadAnyValue Overload
TwinCAT.Ads.TypeSystem Namespace
IValueAnySymbol.WriteAnyValue(Object)
IValueAnySymbol.UpdateAnyValue(Object.)


Symbol.ReadAnyValue Method (Type, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.ReadAnyValue Method [image] Symbol.ReadAnyValue Method (Type, Int32)
Symbol.ReadAnyValue Method (Type, Int32)
Reads the value of this Value into a new created instance of the managed type
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAnyValue(
Type managedType,
int timeout
)
VB
Public Function ReadAnyValue (
managedType As Type,
timeout As Integer
) As Object
Parameters
managedType | Type: System.Type The tp.
timeout | Type: System.Int32 The timeout in ms.
Return Value
Type: Object
Read value (System.Object).
Implements
IValueAnySymbol.ReadAnyValue(Type, Int32)
Reference
Symbol Class
ReadAnyValue Overload
TwinCAT.Ads.TypeSystem Namespace
IValueAnySymbol.WriteAnyValue(Object)
IValueAnySymbol.UpdateAnyValue(Object.)


Symbol.ReadRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.ReadRawValue Method
Symbol.ReadRawValue Method
Overload List
Name | Description
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write)
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Symbol.ReadRawValue Method
•
Symbol.ReadRawValue Method (Int32)


Symbol.ReadRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.ReadRawValue Method [image] Symbol.ReadRawValue Method
Symbol.ReadRawValue Method
Reads the raw value of the IValueSymbol (Ads Read / Write)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public byte[] ReadRawValue()
VB
Public Function ReadRawValue As Byte()
Field Value
Type: .Byte.
The raw value.
Return Value
Type: .Byte.
System.Byte[].
Implements
IValueRawSymbol.ReadRawValue.
Reference
Symbol Class
ReadRawValue Overload
TwinCAT.Ads.TypeSystem Namespace


Symbol.ReadRawValue Method (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.ReadRawValue Method [image] Symbol.ReadRawValue Method (Int32)
Symbol.ReadRawValue Method (Int32)
Reads the raw value of the IValueSymbol (Ads Read / Write)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public byte[] ReadRawValue(
int timeout
)
VB
Public Function ReadRawValue (
timeout As Integer
) As Byte()
Parameters
timeout
Type: System.Int32
Field Value
Type: .Byte.
The raw value.
Return Value
Type: .Byte.
System.Byte[].
Implements
IValueRawSymbol.ReadRawValue(Int32)
Reference
Symbol Class
ReadRawValue Overload
TwinCAT.Ads.TypeSystem Namespace


Symbol.ReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.ReadValue Method
Symbol.ReadValue Method
Overload List
Name | Description
ReadValue. | Reads the Value of the IValueSymbol
ReadValue(Int32) | Reads the Value of the IValueSymbol
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Symbol.ReadValue Method
•
Symbol.ReadValue Method (Int32)


Symbol.ReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.ReadValue Method [image] Symbol.ReadValue Method
Symbol.ReadValue Method
Reads the Value of the IValueSymbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadValue()
VB
Public Function ReadValue As Object
Field Value
Type: Object
The value.
Return Value
Type: Object
System.Object.
Implements
IValueSymbol.ReadValue.
Remarks
Calling on primitive types, a call of this method will return the primitive value. On complex types (structures and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: the raw byte Array will be returned, in dynamic mode: A Value will be created on the fly.
Reference
Symbol Class
ReadValue Overload
TwinCAT.Ads.TypeSystem Namespace


Symbol.ReadValue Method (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.ReadValue Method [image] Symbol.ReadValue Method (Int32)
Symbol.ReadValue Method (Int32)
Reads the Value of the IValueSymbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadValue(
int timeout
)
VB
Public Function ReadValue (
timeout As Integer
) As Object
Parameters
timeout
Type: System.Int32
The timeout in ms.
Field Value
Type: Object
The value.
Return Value
Type: Object
System.Object.
Implements
IValueSymbol.ReadValue(Int32)
Remarks
Calling on primitive types, a call of this method will return the primitive value. On complex types (structures and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: the raw byte Array will be returned, in dynamic mode: A Value will be created on the fly. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
Symbol Class
ReadValue Overload
TwinCAT.Ads.TypeSystem Namespace


Symbol.SetParent Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.SetParent Method
Symbol.SetParent Method
Sets the parent symbol.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void SetParent(
ISymbol parent
)
VB
Public Sub SetParent (
parent As ISymbol
)
Parameters
parent
Type: TwinCAT.TypeSystem.ISymbol
The parent.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.ToString Method
Symbol.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.TryReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.TryReadValue Method
Symbol.TryReadValue Method
Reads the Value of the IValueSymbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int TryReadValue(
int timeout,
out Object value
)
VB
Public Function TryReadValue (
timeout As Integer,
<OutAttribute> ByRef value As Object
) As Integer
Parameters
timeout | Type: System.Int32 The timeout in ms.
value | Type: System.Object. The read value.
Return Value
Type: Int32
The error Code..
Implements
IValueSymbol3.TryReadValue(Int32, Object.)
Remarks
Calling on primitive types, a call of this method will return the primitive value. On complex types (structures and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: the raw byte Array will be returned, in dynamic mode: A Value will be created on the fly. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.TryWriteValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.TryWriteValue Method
Symbol.TryWriteValue Method
Writes the Value of the IValueSymbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int TryWriteValue(
Object value,
int timeout
)
VB
Public Function TryWriteValue (
value As Object,
timeout As Integer
) As Integer
Parameters
value | Type: System.Object The value.
timeout | Type: System.Int32 The timeout in ms.
Return Value
Type: Int32
The error code.
Implements
IValueSymbol3.TryWriteValue(Object, Int32)
Remarks
Calling on primitive types, a call of this method will directly write this Value. On complex types (structs and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: Only byte Arrays (of correct size) can be written) in dynamic mode: A Value that represents the value will be accepted also. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.UpdateAnyValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.UpdateAnyValue Method
Symbol.UpdateAnyValue Method
Overload List
Name | Description
UpdateAnyValue(Object.) | Reads the value of this Value into the specified managed value.
UpdateAnyValue(Object., Int32) | Reads the value of this Value into the specified managed value.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Symbol.UpdateAnyValue Method (Object.)
•
Symbol.UpdateAnyValue Method (Object., Int32)


Symbol.UpdateAnyValue Method (Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.UpdateAnyValue Method [image] Symbol.UpdateAnyValue Method (Object.)
Symbol.UpdateAnyValue Method (Object.)
Reads the value of this Value into the specified managed value.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void UpdateAnyValue(
ref Object managedObject
)
VB
Public Sub UpdateAnyValue (
ByRef managedObject As Object
)
Parameters
managedObject
Type: System.Object.
The managed object.
Return Value
Type:
Read value (System.Object).
Implements
IValueAnySymbol.UpdateAnyValue(Object.)
Reference
Symbol Class
UpdateAnyValue Overload
TwinCAT.Ads.TypeSystem Namespace
IValueAnySymbol.ReadAnyValue(Type)
IValueAnySymbol.WriteAnyValue(Object)


Symbol.UpdateAnyValue Method (Object., Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.UpdateAnyValue Method [image] Symbol.UpdateAnyValue Method (Object., Int32)
Symbol.UpdateAnyValue Method (Object., Int32)
Reads the value of this Value into the specified managed value.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void UpdateAnyValue(
ref Object managedObject,
int timeout
)
VB
Public Sub UpdateAnyValue (
ByRef managedObject As Object,
timeout As Integer
)
Parameters
managedObject | Type: System.Object. The managed object.
timeout | Type: System.Int32 The timeout.
Return Value
Type:
Read value (System.Object).
Implements
IValueAnySymbol.UpdateAnyValue(Object., Int32)
Reference
Symbol Class
UpdateAnyValue Overload
TwinCAT.Ads.TypeSystem Namespace
IValueAnySymbol.ReadAnyValue(Type)
IValueAnySymbol.WriteAnyValue(Object)


Symbol.WriteRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.WriteRawValue Method
Symbol.WriteRawValue Method
Overload List
Name | Description
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write)
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Symbol.WriteRawValue Method (.Byte.)
•
Symbol.WriteRawValue Method (.Byte., Int32)


Symbol.WriteRawValue Method (.Byte.)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.WriteRawValue Method [image] Symbol.WriteRawValue Method (.Byte.)
Symbol.WriteRawValue Method (.Byte.)
Writes the raw value of the IValueSymbol (Ads Read / Write)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteRawValue(
byte[] value
)
VB
Public Sub WriteRawValue (
value As Byte()
)
Parameters
value
Type: .System.Byte.
The value.
Field Value
Type:
The raw value.
Implements
IValueRawSymbol.WriteRawValue(.Byte.)
Reference
Symbol Class
WriteRawValue Overload
TwinCAT.Ads.TypeSystem Namespace


Symbol.WriteRawValue Method (.Byte., Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.WriteRawValue Method [image] Symbol.WriteRawValue Method (.Byte., Int32)
Symbol.WriteRawValue Method (.Byte., Int32)
Writes the raw value of the IValueSymbol (Ads Read / Write)
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteRawValue(
byte[] value,
int timeout
)
VB
Public Sub WriteRawValue (
value As Byte(),
timeout As Integer
)
Parameters
value | Type: .System.Byte. The value.
timeout | Type: System.Int32 The timeout.
Field Value
Type:
The raw value.
Implements
IValueRawSymbol.WriteRawValue(.Byte., Int32)
Remarks
A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
Symbol Class
WriteRawValue Overload
TwinCAT.Ads.TypeSystem Namespace


Symbol.WriteValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.WriteValue Method
Symbol.WriteValue Method
Overload List
Name | Description
WriteValue(Object) | Writes the Value of the IValueSymbol
WriteValue(Object, Int32) | Writes the Value of the IValueSymbol
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Symbol.WriteValue Method (Object)
•
Symbol.WriteValue Method (Object, Int32)


Symbol.WriteValue Method (Object)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.WriteValue Method [image] Symbol.WriteValue Method (Object)
Symbol.WriteValue Method (Object)
Writes the Value of the IValueSymbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteValue(
Object value
)
VB
Public Sub WriteValue (
value As Object
)
Parameters
value
Type: System.Object
The value.
Implements
IValueSymbol.WriteValue(Object)
Remarks
Calling on primitive types, a call of this method will directly write this Value. On complex types (structs and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: Only byte Arrays (of correct size) can be written) in dynamic mode: A Value that represents the value will be accepted also.
Reference
Symbol Class
WriteValue Overload
TwinCAT.Ads.TypeSystem Namespace


Symbol.WriteValue Method (Object, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Methods [image] Symbol.WriteValue Method [image] Symbol.WriteValue Method (Object, Int32)
Symbol.WriteValue Method (Object, Int32)
Writes the Value of the IValueSymbol
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteValue(
Object value,
int timeout
)
VB
Public Sub WriteValue (
value As Object,
timeout As Integer
)
Parameters
value | Type: System.Object The value.
timeout | Type: System.Int32 The timeout in ms.
Implements
IValueSymbol.WriteValue(Object, Int32)
Remarks
Calling on primitive types, a call of this method will directly write this Value. On complex types (structs and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: Only byte Arrays (of correct size) can be written) in dynamic mode: A Value that represents the value will be accepted also. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
Symbol Class
WriteValue Overload
TwinCAT.Ads.TypeSystem Namespace


Symbol Events

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Events
Symbol Events
The Symbol type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed.
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Symbol.RawValueChanged Event
•
Symbol.ValueChanged Event


Symbol.RawValueChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Events [image] Symbol.RawValueChanged Event
Symbol.RawValueChanged Event
Occurs when the RawValue of the IValueSymbol has changed.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event EventHandler<RawValueChangedArgs> RawValueChanged
VB
Public Event RawValueChanged As EventHandler(Of RawValueChangedArgs)
Value
Type: System.EventHandler.RawValueChangedArgs.
Implements
IValueRawSymbol.RawValueChanged
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.ValueChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Events [image] Symbol.ValueChanged Event
Symbol.ValueChanged Event
Occurs when the (Primitive) value of the IValueSymbol has changed.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event EventHandler<ValueChangedArgs> ValueChanged
VB
Public Event ValueChanged As EventHandler(Of ValueChangedArgs)
Value
Type: System.EventHandler.ValueChangedArgs.
Implements
IValueSymbol.ValueChanged
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol Operators

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Operators
Symbol Operators
The Symbol type exposes the following members.
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
Symbol.Equality Operator
•
Symbol.Inequality Operator


Symbol.Equality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Operators [image] Symbol.Equality Operator
Symbol.Equality Operator
Operator==
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator ==(
Symbol o1,
Symbol o2
)
VB
Public Shared Operator = (
o1 As Symbol,
o2 As Symbol
) As Boolean
Parameters
o1 | Type: TwinCAT.Ads.TypeSystem.Symbol The o1.
o2 | Type: TwinCAT.Ads.TypeSystem.Symbol The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol.Inequality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Operators [image] Symbol.Inequality Operator
Symbol.Inequality Operator
Implements the != operator.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator !=(
Symbol o1,
Symbol o2
)
VB
Public Shared Operator <> (
o1 As Symbol,
o2 As Symbol
) As Boolean
Parameters
o1 | Type: TwinCAT.Ads.TypeSystem.Symbol The o1.
o2 | Type: TwinCAT.Ads.TypeSystem.Symbol The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


Symbol Fields

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] Symbol Class [image] Symbol Fields
Symbol Fields
The Symbol type exposes the following members.
Fields
Name | Description
attributes | The attributes (Inherited from Instance.)
Reference
Symbol Class
TwinCAT.Ads.TypeSystem Namespace


SymbolLoaderFactory Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] SymbolLoaderFactory Class
SymbolLoaderFactory Class
The class SymbolLoaderFactory is used to create a new instance of the AdsSymbolLoader initialized to the parametrized mode (SymbolBrowser V2, new Version)
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.SymbolLoaderFactory
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SymbolLoaderFactory
VB
Public Class SymbolLoaderFactory
The SymbolLoaderFactory type exposes the following members.
Constructors
Name | Description
SymbolLoaderFactory |
Methods
Name | Description
Create | Creates the specified connection.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Remarks
The Symbol Loader (V2) supports the following modes. FlatThe flat mode organizes the Symbols in a flat list. This mode is available in all .NET versions. VirtualTreeThe virtual tree mode organizes the Symbols hierarchically with parent-child relationships. This mode is available in all .NET Versions. DynamicTreeThe Dynamic tree mode organizes the Symbols hierarchically and (dynamically) creates struct members, array elements and enum fields on the fly. This feature is only available on platforms that support the Dynamic Language Runtime (DLR), actually all .NET Framework Version larger than 4.0. Virtual instances means, that all Symbols are ordered within a tree structure. For that symbol nodes that are not located on a fixed address, a Virtual Symbol will be created. Setting the virtualInstance parameter to 'false' means, that the located symbols will be returned in a flattened list.
Reference
TwinCAT.Ads.TypeSystem Namespace
TwinCAT.Ads.SymbolLoaderSettings
Weiterführende Informationen
•
SymbolLoaderFactory Constructor
•
SymbolLoaderFactory Methods


SymbolLoaderFactory Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] SymbolLoaderFactory Class [image] SymbolLoaderFactory Constructor
SymbolLoaderFactory Constructor
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolLoaderFactory()
VB
Public Sub New
Reference
SymbolLoaderFactory Class
TwinCAT.Ads.TypeSystem Namespace


SymbolLoaderFactory Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] SymbolLoaderFactory Class [image] SymbolLoaderFactory Methods
SymbolLoaderFactory Methods
The SymbolLoaderFactory type exposes the following members.
Methods
Name | Description
Create | Creates the specified connection.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
SymbolLoaderFactory Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
SymbolLoaderFactory.Create Method


SymbolLoaderFactory.Create Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] SymbolLoaderFactory Class [image] SymbolLoaderFactory Methods [image] SymbolLoaderFactory.Create Method
SymbolLoaderFactory.Create Method
Creates the specified connection.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static ISymbolLoader Create(
IConnection connection,
ISymbolLoaderSettings settings
)
VB
Public Shared Function Create (
connection As IConnection,
settings As ISymbolLoaderSettings
) As ISymbolLoader
Parameters
connection | Type: TwinCAT.IConnection The connection.
settings | Type: TwinCAT.ISymbolLoaderSettings The settings.
Return Value
Type: ISymbolLoader
ISymbolLoader.
Examples
The following sample shows how to create a dynamic version of the SymbolLoader V2. The dynamic symbol loader makes use of the Dynamic Language Runtime (DLR) of the .NET Framework. That means Structures, Arrays and Enumeration types and instances are generated 'on-the-fly' during symbol Browsing. These created dynamic objects are a one to one representation of the Symbol Server target objects (e.g the IEC61131 types on the PLC). Dynamic language features are only available from .NET4 upwards.
Dynamic Tree Mode
namespace Sample
{
using System;
using System.Diagnostics;
using System.Threading;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.Ads.TypeSystem;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

class SymbolBrowserProgramV2DynamicTree
{

#region CODE_SAMPLE_SIMPLEDYNAMIC
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
// Get the AdsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect to the target device
client.Connect(address);

// Usage of "dynamic" Type and Symbols (>= .NET4 only)
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.DynamicTree);
IAdsSymbolLoader dynLoader = (IAdsSymbolLoader)SymbolLoaderFactory.Create(client, settings);

#endregion

// Set the Default setting for Notifications
dynLoader.DefaultNotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 200, 2000);

// Get the Symbols (Dynamic Symbols)
dynamic dynamicSymbols = ((IDynamicSymbolLoader)dynLoader).SymbolsDynamic;

dynamic adsPort = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.AdsPort;

#region CODE_SAMPLE_SIMPLEDYNAMIC

// Access Main Symbol with Dynamic Language Runtime support (DLR)
// Dynamically created property "Main"
//dynamic symMain = dynamicSymbols.Main;

// Main is an 'VirtualSymbol' / Organizational unit that doesn't have a value
// Calling ReadValue is not allowed
//bool test = symMain.HasValue;
//dynamic invalid = symMain.ReadValue();

//Reading TaskInfo Value
//With calling ReadValue() a 'snapshot' of the Symbols Instance is taken
dynamic vTaskInfoArray = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo.ReadValue();

// Getting the Snapshot time in UTC format
DateTime timeStamp1 = vTaskInfoArray.UtcTimeStamp;

// Getting TaskInfo Symbol for Task 1
dynamic symTaskInfo1 = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo[1];

// Getting CycleCount Symbol
dynamic symCycleCount = symTaskInfo1.CycleCount;

// Take Snapshot value of the ApplicationInfo struct
dynamic vAppInfo = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.ReadValue();
// Get the UTC Timestamp of the snapshot

DateTime timeStamp2 = vAppInfo.UtcTimeStamp;

// Access the ProjectName of the ApplicationInfo Snapshot (type-safe!)
string projectNameValue = vAppInfo.ProjectName;

// Reading the CycleCount Value
uint cycleCountValue = symTaskInfo1.CycleCount.ReadValue(); // Taking a Value Snapshot
#endregion

// Registering for dynamic "ValueChanged" events for the Values
// Using Default Notification settings
symCycleCount.ValueChanged += new EventHandler<ValueChangedArgs>(cycleCount_ValueChanged);

// Override default notification settings
symTaskInfo1.NotificationSettings = new NotificationSettings(AdsTransMode.Cyclic,500,0);

// Register for ValueChanged event.
symTaskInfo1.ValueChanged += new EventHandler<ValueChangedArgs>(taskInfo1Value_ValueChanged); // Struct Type

Thread.Sleep(10000); // Sleep main thread for 10 Seconds
}
Console.WriteLine("CycleCount Changed events received: {0}",_cycleCountEvents);
Console.WriteLine("taskInfo1 Changed events received: {0}", _taskInfo1Events);

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}

static object _notificationSynchronizer = new object();
static int _cycleCountEvents = 0;

/// <summary>
/// Handler function for the CycleCount ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void cycleCount_ValueChanged(object sender, ValueChangedArgs e)
{
lock(_notificationSynchronizer)
{
Interlocked.Increment(ref _cycleCountEvents);
// val is a type safe value of int!
dynamic val = e.Value;
uint intVal = val;

DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert UTC to local time
Console.WriteLine("CycleCount changed to: {0}, TimeStamp: {1}", intVal, changedTime.ToString("HH:mm:ss:fff"));
}
}

static int _taskInfo1Events = 0;

/// <summary>
/// Handler function for the TaskInfo ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void taskInfo1Value_ValueChanged(object sender, ValueChangedArgs e)
{
lock (_notificationSynchronizer)
{
Interlocked.Increment(ref _taskInfo1Events);
dynamic val = e.Value;
DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert to local time

// Val is a during Runtime created struct type and contains
// the same Properties as related PLC object.
int cycleTime = val.CycleTime;
Console.WriteLine("TaskInfo1Value changed TimeStamp: {0}", changedTime.ToString("HH:mm:ss:fff"));
}
}
}
}
The following sample shows how to create a static (non dynamic) version of the SymbolLoader V2. The static symbol loader in version 2 is a nearly code compatible version of the Dynamic Loader, only the dynamic creation of objects is not available. The reason for supporting this mode is that .NET Framework Versions lower than Version 4.0 (CLR2) doesn't support the Dynamic Language Runtime (DLR). The SymbolLoader V2 static object is supported from .NET 2.0 on.
Virtual Tree Mode
using System;
using System.Threading;
using System.Diagnostics;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.Ads.TypeSystem;

namespace Sample
{
class SymbolBrowserProgramV2VirtualTree
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
ConsoleLogger logger = new ConsoleLogger();

Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

//logger.Active = false;

Stopwatch stopper = new Stopwatch();

// Parse the command-line arguments
AmsAddress address = ArgParser.Parse(args);

stopper.Start();

using (TcAdsClient client = new TcAdsClient())
{
client.Synchronize = false;

// Connect the AdsClient to the device target.
client.Connect(address);

// Creates the Symbol Objects as hierarchical tree
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.VirtualTree, ValueAccessMode.IndexGroupOffsetPreferred);
ISymbolLoader symbolLoader = SymbolLoaderFactory.Create(client, settings);

// Dump Datatypes from Target Device
Console.WriteLine(string.Format("Dumping '{0}' DataTypes:", symbolLoader.DataTypes.Count));
foreach (IDataType type in symbolLoader.DataTypes)
{
logger.DumpType(type);
}
Console.WriteLine("");

// Dump Symbols from target device
Console.WriteLine("Dumping '{0}' Symbols:", symbolLoader.Symbols.Count);
foreach (ISymbol symbol in symbolLoader.Symbols)
{
logger.DumpSymbol(symbol,0);
}
}
stopper.Stop();
TimeSpan elapsed = stopper.Elapsed;

Console.WriteLine("");
Console.WriteLine("Browsing complete tree: {0},({1} DataTypes, {2} Symbols)",elapsed,logger.DataTypesCount,logger.DataTypesCount);
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Examples
The SymbolLoader V2 static object is supported from .NET 2.0 on.
Flat Mode
using System;
using System.Diagnostics;
using System.Threading;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.Ads.TypeSystem;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

namespace Sample
{
class SymbolBrowserProgramV2Flat
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
ConsoleLogger logger = new ConsoleLogger();

Console.WriteLine("");
Console.WriteLine("Press [Enter] for start:");
Console.ReadLine();

//logger.Active = false;

Stopwatch stopper = new Stopwatch();

// Parse the command line arguments
AmsAddress address = ArgParser.Parse(args);

stopper.Start();

// Create the ADS Client
using (TcAdsClient client = new TcAdsClient())
{
client.Synchronize = false;

// Connect to Address
client.Timeout = 30000;
client.Connect(address);

// Creates the Symbol Objects in Flat Mode (Flat list)
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.Flat, ValueAccessMode.IndexGroupOffsetPreferred);
ISymbolLoader symbolLoader = SymbolLoaderFactory.Create(client, settings);

// Dump Datatypes from Target Device
Console.WriteLine(string.Format("Dumping '{0}' DataTypes:",symbolLoader.DataTypes.Count));
foreach (IDataType type in symbolLoader.DataTypes)
{
logger.DumpType(type);
}

Console.WriteLine("");

// Dump Symbols from target device
Console.WriteLine("Dumping '{0}' Symbols:",symbolLoader.Symbols.Count);
foreach (ISymbol symbol in symbolLoader.Symbols)
{
logger.DumpSymbol(symbol,0);
}
}
stopper.Stop();
TimeSpan elapsed = stopper.Elapsed;

Console.WriteLine("");
Console.WriteLine("Browsing complete tree: {0},({1} DataTypes, {2} Symbols)", elapsed, logger.DataTypesCount, logger.DataTypesCount);
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}
Examples
Argument Parser
public static class ArgParser
{
/// <summary>
/// Parses the arguments.
/// </summary>
/// <param name="args">The arguments.</param>
/// <returns>AmsAddress.</returns>
public static AmsAddress Parse(string[] args)
{
AmsNetId netId = AmsNetId.Local;
int port = 851;

if (args != null)
{
if (args.Length > 0 && args[0] != null)
netId = AmsNetId.Parse(args[0]);

if (args.Length > 1 && args[1] != null)
port = int.Parse(args[1]);
}
return new AmsAddress(netId, port);
}
}
Dumping Symbols
/// <summary>
/// Console logger
/// </summary>
public class ConsoleLogger
{
public ConsoleLogger()
{
}
bool _active = true;

/// <summary>
/// Gets or sets a value indicating whether this ConsoleLogger is active.
/// </summary>
/// <value><c>true</c> if active; otherwise, <c>false</c>.</value>
public bool Active
{
get { return _active; }
set
{
_active = value;
}
}

int _dataTypes = 0;

/// <summary>
/// Gets the number of dumped dataTypes.
/// </summary>
/// <value>The data types count.</value>
public int DataTypesCount
{
get { return _dataTypes; }
}

int _symbols = 0;

/// <summary>
/// Gets the number of dumped symbols
/// </summary>
/// <value>The symbols count.</value>
public int SymbolsCount
{
get { return _symbols; }
}

/// <summary>
/// Dumps the data type.
/// </summary>
/// <param name="dataType">Data Type.</param>
public void DumpType(IDataType dataType)
{
WriteLine(string.Format("DataType: {0}, Category: {1}, Size: {2}", dataType.Name, dataType.Category, dataType.Size));

switch (dataType.Category)
{
case DataTypeCategory.Alias:
IAliasType alias = (IAliasType)dataType;
WriteLine(GetPrefix(1) + string.Format("Alias BaseType: {0}", alias.BaseTypeName));
break;

case DataTypeCategory.Enum:

//IEnumType<ushort> enumType = (IEnumType<ushort>)dataType;
IEnumType enumType = (IEnumType)dataType;
WriteLine(GetPrefix(1) + string.Format("Enum BaseType: {0}", enumType.BaseTypeName));

foreach (IEnumValue enumValue in enumType.EnumValues)
{
WriteLine(GetPrefix(2) + string.Format("Name: {0}, Value: {1}", enumValue.Name, enumValue.Primitive));
}
break;
case DataTypeCategory.Array:

IArrayType arrayType = (IArrayType)dataType;
int i = 0;

foreach (IDimension dim in arrayType.Dimensions)
{
WriteLine(GetPrefix(2) + string.Format("{0}: LowerBound: {1}, Elements: {2}", i++, dim.LowerBound, dim.ElementCount));
}
break;
case DataTypeCategory.Struct:
IStructType structType = (IStructType)dataType;

foreach (IMember member in structType.Members)
{
WriteLine(GetPrefix(2) + string.Format("Offset {0}: Name: {1}, Type: {2}", member.Offset, member.InstanceName, member.TypeName));
}
break;
default:
break;
}

foreach (ITypeAttribute attribute in dataType.Attributes)
{
WriteLine(GetPrefix(1) + string.Format("{{ {0} : {1} }}", attribute.Name, attribute.Value));
}
if (!string.IsNullOrEmpty(dataType.Comment))
{
WriteLine(GetPrefix(1) + string.Format("Comment: {0}", dataType.Comment));
}

IRpcCallableType rpcCallable = dataType as IRpcCallableType;

if (rpcCallable != null)
{
foreach (IRpcMethod rpcMethod in rpcCallable.RpcMethods)
{
if (string.IsNullOrEmpty(rpcMethod.Comment))
WriteLine(GetPrefix(1) + string.Format("Method: {0}", rpcMethod));
else
WriteLine(GetPrefix(1) + string.Format("Method: {0}, Comment: {1}", rpcMethod, rpcMethod.Comment));
}
}
_dataTypes++;
}

/// <summary>
/// Dumps the Datatype to Console
/// </summary>
/// <param name="dataType">DataType.</param>
public void DumpType(ITcAdsDataType dataType)
{
// Dump the Attributes (PLC Metadata)
foreach (ITypeAttribute attribute in dataType.Attributes)
{
WriteLine(GetPrefix(1) + string.Format("{{ {0} : {1} }}", attribute.Name, attribute.Value));
}

WriteLine(string.Format("DataType: {0}, Category: {1}, Size: {2}", dataType.Name, dataType.Category, dataType.Size));

if (dataType.BaseType != null)
{
WriteLine(GetPrefix(1) + string.Format("BaseType: {0}", dataType.BaseType));
}

switch (dataType.Category)
{
case DataTypeCategory.Enum:
foreach (IEnumValue enumValue in dataType.EnumValues)
{
WriteLine(GetPrefix(2) + string.Format("Name: {0}, Value: {1}", enumValue.Name, enumValue.Primitive));
}
break;
case DataTypeCategory.Array:
int i = 0;
foreach (IDimension dim in dataType.Dimensions)
{
WriteLine(GetPrefix(2) + string.Format("{0}: LowerBound: {1}, Elements: {2}", i++, dim.LowerBound, dim.ElementCount));
}
break;
case DataTypeCategory.Struct:
foreach (ITcAdsSubItem subItem in dataType.SubItems)
{
WriteLine(GetPrefix(2) + string.Format("Offset {0}: Name: {1}, Type: {2}", subItem.Offset, subItem.SubItemName, subItem.Name));
}
break;
default:
break;
}
_dataTypes++;
}

/// <summary>
/// Dump Symbol
/// </summary>
/// <param name="symbol">The symbol.</param>
/// <param name="level">Output indentation level</param>
public void DumpSymbol(ISymbol symbol, int level)
{
IDataType type = symbol.DataType as IDataType;

foreach (ITypeAttribute attribute in symbol.Attributes)
{
WriteLine(GetPrefix(level) + string.Format("{{ {0} : {1} }}", attribute.Name, attribute.Value));
}

WriteLine(GetPrefix(level) + string.Format("{0} : {1} (IG: 0x{2} IO: 0x{3} size:{4})", symbol.InstanceName, symbol.TypeName, ((IAdsSymbol)symbol).IndexGroup.ToString("x"), ((IAdsSymbol)symbol).IndexOffset.ToString("x"), symbol.Size));

if (symbol.Category == DataTypeCategory.Array)
{
IArrayInstance arrInstance = (IArrayInstance)symbol;
IArrayType arrType = (IArrayType)symbol.DataType;

int count = 0;
level++;

foreach (ISymbol arrayElement in arrInstance.Elements)
{
DumpSymbol(arrayElement, level);
count++;

if (count > 20) // Write only the first 20 to limit output
break;
}
}
else if (symbol.Category == DataTypeCategory.Struct)
{
IStructInstance structInstance = (IStructInstance)symbol;
IStructType structType = (IStructType)symbol.DataType;

level++;

foreach (ISymbol member in structInstance.MemberInstances)
{
DumpSymbol(member, level);
}
}
_symbols++;
}

/// <summary>
/// Dumps the specified Symbol to the Console
/// </summary>
/// <param name="symbol">The symbol.</param>
/// <param name="level">The level.</param>
public void DumpSymbol(ITcAdsSymbol5 symbol, int level)
{
// Dump Attributes of the Symbol
foreach (ITypeAttribute attribute in symbol.Attributes)
{
WriteLine(GetPrefix(level) + string.Format("{{ {0} : {1} }}", attribute.Name, attribute.Value));
}

ITcAdsSymbolBrowser subSymbolProvider = (ITcAdsSymbolBrowser)symbol;

// Dump The Symbol
WriteLine(GetPrefix(level) + string.Format("{0} : {1} ({2}, IG: 0x{3} IO: 0x{4} size:{6} subCount:{5})", symbol.Name, symbol.TypeName, symbol.DataTypeId, symbol.IndexGroup.ToString("x"), symbol.IndexOffset.ToString("x"), subSymbolProvider.SubSymbols.Count, symbol.Size));
level++;

// Dump all SubSymbols with indentation
foreach (ITcAdsSymbol5 subSymbol in ((ITcAdsSymbolBrowser)symbol).SubSymbols)
{
DumpSymbol(subSymbol, level);
}
_symbols++;
}

/// <summary>
/// Dump namespace.
/// </summary>
/// <param name="ns">The namespace.</param>
public void DumpNamespace(INamespace<IDataType> ns)
{
WriteLine("Namespace: {0}, DataTypes: {1}", ns.Name, ns.DataTypes.Count);

foreach (IDataType type in ns.DataTypes)
{
DumpType(type);
}
}

/// <summary>
/// Get the indentation prefix
/// </summary>
/// <param name="level">The level.</param>
/// <returns>System.String.</returns>
public string GetPrefix(int level)
{
return "".PadLeft(level * 3);
}

/// <summary>
/// Writes a line to the Console
/// </summary>
/// <param name="message">The message.</param>
public void WriteLine(string message)
{
if (Active)
{
Console.WriteLine(message);
}
}

/// <summary>
/// Writes a line to the console
/// </summary>
/// <param name="format">The format.</param>
/// <param name="args">The arguments.</param>
public void WriteLine(string format, params object[] args)
{
if (Active)
{
Console.WriteLine(format,args);
}
}
}
Reference
SymbolLoaderFactory Class
TwinCAT.Ads.TypeSystem Namespace


UnionType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] UnionType Class
UnionType Class
Represents a union type
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.UnionType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class UnionType : DataType,
IUnionType, IDataType, IBitSize
VB
Public NotInheritable Class UnionType
Inherits DataType
Implements IUnionType, IDataType, IBitSize
The UnionType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
Fields | Gets a read only collection of the Fields of the IUnionType.
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
UnionType Properties
•
UnionType Methods


UnionType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] UnionType Class [image] UnionType Properties
UnionType Properties
The UnionType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
Fields | Gets a read only collection of the Fields of the IUnionType.
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
UnionType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
UnionType.Fields Property


UnionType.Fields Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] UnionType Class [image] UnionType Properties [image] UnionType.Fields Property
UnionType.Fields Property
Gets a read only collection of the Fields of the IUnionType.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyFieldCollection Fields { get; }
VB
Public ReadOnly Property Fields As ReadOnlyFieldCollection
Get
Property Value
Type: ReadOnlyFieldCollection
The members as read only collection.
Implements
IUnionType.Fields
Reference
UnionType Class
TwinCAT.Ads.TypeSystem Namespace


UnionType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] UnionType Class [image] UnionType Methods
UnionType Methods
The UnionType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from DataType.)
Reference
UnionType Class
TwinCAT.Ads.TypeSystem Namespace


WStringType Class

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] WStringType Class
WStringType Class
Represents an Unicode string (Wide string)
Inheritance Hierarchy
System.Object
TwinCAT.Ads.TypeSystem.DataType
TwinCAT.Ads.TypeSystem.WStringType
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class WStringType : DataType,
IStringType, IDataType, IBitSize
VB
Public NotInheritable Class WStringType
Inherits DataType
Implements IStringType, IDataType, IBitSize
The WStringType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
Encoding | Gets the encoding of the String (Encoding.Default (STRING) or Encoding.UNICODE (WSTRING))
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsFixedLength | Gets a value indicating whether the string is of fixed length.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
Length | Gets the number of characters within the string.
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides DataType.ToString..)
Reference
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
WStringType Properties
•
WStringType Methods


WStringType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] WStringType Class [image] WStringType Properties
WStringType Properties
The WStringType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from DataType.)
BitSize | Gets the size of the DataType in bits. (Inherited from DataType.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DataType.)
Category | Gets the Data Type category (Inherited from DataType.)
Comment | Gets the comment. (Inherited from DataType.)
Encoding | Gets the encoding of the String (Encoding.Default (STRING) or Encoding.UNICODE (WSTRING))
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from DataType.)
Id | Gets the ID of the DataType (Inherited from DataType.)
IsBitType | Gets a value indicating whether this IDataType is a bit mapping Type (Inherited from DataType.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DataType.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from DataType.)
IsFixedLength | Gets a value indicating whether the string is of fixed length.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from DataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from DataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from DataType.)
Length | Gets the number of characters within the string.
ManagedType | Gets the corresponding .NET Type if attached. (Inherited from DataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from DataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from DataType.)
Size | Gets the Size of the DataType in Bytes (Inherited from DataType.)
Reference
WStringType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
WStringType.Encoding Property
•
WStringType.IsFixedLength Property
•
WStringType.Length Property


WStringType.Encoding Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] WStringType Class [image] WStringType Properties [image] WStringType.Encoding Property
WStringType.Encoding Property
Gets the encoding of the String (Encoding.Default (STRING) or Encoding.UNICODE (WSTRING))
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Encoding Encoding { get; }
VB
Public ReadOnly Property Encoding As Encoding
Get
Property Value
Type: Encoding
The encoding.
Implements
IStringType.Encoding
Reference
WStringType Class
TwinCAT.Ads.TypeSystem Namespace


WStringType.IsFixedLength Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] WStringType Class [image] WStringType Properties [image] WStringType.IsFixedLength Property
WStringType.IsFixedLength Property
Gets a value indicating whether the string is of fixed length.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsFixedLength { get; }
VB
Public ReadOnly Property IsFixedLength As Boolean
Get
Property Value
Type: Boolean
true if this instance is fixed length; otherwise, false.
Implements
IStringType.IsFixedLength
Exceptions
Exception | Condition
NotImplementedException |
Reference
WStringType Class
TwinCAT.Ads.TypeSystem Namespace


WStringType.Length Property

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] WStringType Class [image] WStringType Properties [image] WStringType.Length Property
WStringType.Length Property
Gets the number of characters within the string.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Length { get; }
VB
Public ReadOnly Property Length As Integer
Get
Property Value
Type: Int32
The length.
Implements
IStringType.Length
Reference
WStringType Class
TwinCAT.Ads.TypeSystem Namespace


WStringType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] WStringType Class [image] WStringType Methods
WStringType Methods
The WStringType type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides DataType.ToString..)
Reference
WStringType Class
TwinCAT.Ads.TypeSystem Namespace
Weiterführende Informationen
•
WStringType.ToString Method


WStringType.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.TypeSystem Namespace [image] WStringType Class [image] WStringType Methods [image] WStringType.ToString Method
WStringType.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.Ads.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
WStringType Class
TwinCAT.Ads.TypeSystem Namespace


TwinCAT.Ads.ValueAccess Namespace

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.ValueAccess Namespace
TwinCAT.Ads.ValueAccess Namespace
Root namespace for ADS value access.
Enumerations
Enumeration | Description
ValueAccessMode | Enum ValueAccessMethod
Weiterführende Informationen
•
ValueAccessMode Enumeration


ValueAccessMode Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.Ads.ValueAccess Namespace [image] ValueAccessMode Enumeration
ValueAccessMode Enumeration
Enum ValueAccessMethod
Namespace: TwinCAT.Ads.ValueAccess
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum ValueAccessMode
VB
Public Enumeration ValueAccessMode
Members
Member name | Value | Description
None | 0 | None / Uninitialized
IndexGroupOffset | 1 | Value access via Index Group and Offset Only
Symbolic | 2 | Symbolic access via Instance Path only.
IndexGroupOffsetPreferred | 3 | Uses IndexGroup IndexOffset Preferred (and Symbolic for Dereferenced Pointers / References)
Default | 3 | The Default access mode (IndexGroupOffsetPreferred)
Reference
TwinCAT.Ads.ValueAccess Namespace


TwinCAT.PlcOpen Namespace

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace
TwinCAT.PlcOpen Namespace
Classes
Class | Description
DATE | PlcOpen DATE class
DateBase | PlcOpen Date base class.
LTIME | PlcOpen TIME class
LTimeBase | Time base class
TIME | PlcOpen TIME class
TimeBase | Time base class
TOD | TimeOfDay class
Weiterführende Informationen
•
DATE Class
•
DateBase Class
•
LTIME Class
•
LTimeBase Class
•
TIME Class
•
TimeBase Class
•
TOD Class


DATE Class

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class
DATE Class
PlcOpen DATE class
Inheritance Hierarchy
System.Object
TwinCAT.PlcOpen.DateBase
TwinCAT.PlcOpen.DATE
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class DATE : DateBase
VB
Public NotInheritable Class DATE
Inherits DateBase
The DATE type exposes the following members.
Constructors
Name | Description
DATE. | Initializes a new instance of the DATE class.
DATE(DateTime) | Initializes a new instance of the DATE class.
DATE(Int64) | Initializes a new instance of the DATE class.
DATE(UInt32) | Initializes a new instance of the DATE class.
DATE(Int32, Int32, Int32) | Initializes a new instance of the DATE class.
Properties
Name | Description
Date | Gets or sthe date value. (Inherited from DateBase.)
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64). (Inherited from DateBase.)
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Inherited from DateBase.)
GetHashCode | Gets the HashCode of the Address (Inherited from DateBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Parse | Parses the specified string to a DATE object.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryParse | Tries to parse the specified string to a DATE object.
Reference
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
DATE Constructor
•
DATE Properties
•
DATE Methods


DATE Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class [image] DATE Constructor
DATE Constructor
Overload List
Name | Description
DATE. | Initializes a new instance of the DATE class.
DATE(DateTime) | Initializes a new instance of the DATE class.
DATE(Int64) | Initializes a new instance of the DATE class.
DATE(UInt32) | Initializes a new instance of the DATE class.
DATE(Int32, Int32, Int32) | Initializes a new instance of the DATE class.
Reference
DATE Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
DATE Constructor
•
DATE Constructor (DateTime)
•
DATE Constructor (Int64)
•
DATE Constructor (UInt32)
•
DATE Constructor (Int32, Int32, Int32)


DATE Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class [image] DATE Constructor [image] DATE Constructor
DATE Constructor
Initializes a new instance of the DATE class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DATE()
VB
Public Sub New
Reference
DATE Class
DATE Overload
TwinCAT.PlcOpen Namespace


DATE Constructor (DateTime)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class [image] DATE Constructor [image] DATE Constructor (DateTime)
DATE Constructor (DateTime)
Initializes a new instance of the DATE class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DATE(
DateTime date
)
VB
Public Sub New (
date As DateTime
)
Parameters
date
Type: System.DateTime
The date.
Reference
DATE Class
DATE Overload
TwinCAT.PlcOpen Namespace


DATE Constructor (Int64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class [image] DATE Constructor [image] DATE Constructor (Int64)
DATE Constructor (Int64)
Initializes a new instance of the DATE class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DATE(
long dateValue
)
VB
Public Sub New (
dateValue As Long
)
Parameters
dateValue
Type: System.Int64
The date value in PlcOpen Ticks.
Reference
DATE Class
DATE Overload
TwinCAT.PlcOpen Namespace


DATE Constructor (UInt32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class [image] DATE Constructor [image] DATE Constructor (UInt32)
DATE Constructor (UInt32)
Initializes a new instance of the DATE class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DATE(
uint dateValue
)
VB
Public Sub New (
dateValue As UInteger
)
Parameters
dateValue
Type: System.UInt32
The date value in PlcOpen Ticks.
Reference
DATE Class
DATE Overload
TwinCAT.PlcOpen Namespace


DATE Constructor (Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class [image] DATE Constructor [image] DATE Constructor (Int32, Int32, Int32)
DATE Constructor (Int32, Int32, Int32)
Initializes a new instance of the DATE class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DATE(
int year,
int month,
int day
)
VB
Public Sub New (
year As Integer,
month As Integer,
day As Integer
)
Parameters
year | Type: System.Int32 The year.
month | Type: System.Int32 The month.
day | Type: System.Int32 The day.
Reference
DATE Class
DATE Overload
TwinCAT.PlcOpen Namespace


DATE Properties

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class [image] DATE Properties
DATE Properties
The DATE type exposes the following members.
Properties
Name | Description
Date | Gets or sthe date value. (Inherited from DateBase.)
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64). (Inherited from DateBase.)
Reference
DATE Class
TwinCAT.PlcOpen Namespace


DATE Methods

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class [image] DATE Methods
DATE Methods
The DATE type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Inherited from DateBase.)
GetHashCode | Gets the HashCode of the Address (Inherited from DateBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Parse | Parses the specified string to a DATE object.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryParse | Tries to parse the specified string to a DATE object.
Reference
DATE Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
DATE.Parse Method
•
DATE.ToString Method
•
DATE.TryParse Method


DATE.Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class [image] DATE Methods [image] DATE.Parse Method
DATE.Parse Method
Parses the specified string to a DATE object.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static DATE Parse(
string s
)
VB
Public Shared Function Parse (
s As String
) As DATE
Parameters
s
Type: System.String
The s.
Return Value
Type: DATE
DATE.
Exceptions
Exception | Condition
FormatException | Cannot parse DATE object!
Reference
DATE Class
TwinCAT.PlcOpen Namespace


DATE.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class [image] DATE Methods [image] DATE.ToString Method
DATE.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
DATE Class
TwinCAT.PlcOpen Namespace


DATE.TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DATE Class [image] DATE Methods [image] DATE.TryParse Method
DATE.TryParse Method
Tries to parse the specified string to a DATE object.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool TryParse(
string s,
out DATE date
)
VB
Public Shared Function TryParse (
s As String,
<OutAttribute> ByRef date As DATE
) As Boolean
Parameters
s | Type: System.String The s.
date | Type: TwinCAT.PlcOpen.DATE. The date.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
DATE Class
TwinCAT.PlcOpen Namespace


DateBase Class

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class
DateBase Class
PlcOpen Date base class.
Inheritance Hierarchy
System.Object
TwinCAT.PlcOpen.DateBase
TwinCAT.PlcOpen.DATE
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public abstract class DateBase : IPlcOpenType<DateTime, uint>,
IPlcOpenType
VB
Public MustInherit Class DateBase
Implements IPlcOpenType(Of DateTime, UInteger),
IPlcOpenType
The DateBase type exposes the following members.
Constructors
Name | Description
DateBase. | Initializes a new instance of the DateBase class.
DateBase(DateTime) | Initializes a new instance of the DateBase class.
DateBase(Int64) | Initializes a new instance of the DateBase class.
DateBase(UInt32) | Initializes a new instance of the DateBase class.
Properties
Name | Description
Date | Gets or sthe date value.
MarshalSize | Gets the marshal size in bytes.
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64).
Methods
Name | Description
DateToValue | Converts the specified DateTime value to PlcOpen Ticks.
Equals | Determines whether the specified Object is equal to this instance. (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseToTicks | Parses the specified PlcOpen Date string to PlcOpen ticks.
ToString | Returns a string that represents the current object. (Inherited from Object.)
ValueToDate(Int64) | Converts the specified PlcOpen dateValue in ticks to a DateTime Object
ValueToDate(UInt32) | Converts the specified PlcOpen dateValue in ticks to a DateTime Object
Fields
Name | Description
internalDateValue | The internal date value
Reference
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
DateBase Constructor
•
DateBase Properties
•
DateBase Methods
•
DateBase Fields


DateBase Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Constructor
DateBase Constructor
Overload List
Name | Description
DateBase. | Initializes a new instance of the DateBase class.
DateBase(DateTime) | Initializes a new instance of the DateBase class.
DateBase(Int64) | Initializes a new instance of the DateBase class.
DateBase(UInt32) | Initializes a new instance of the DateBase class.
Reference
DateBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
DateBase Constructor
•
DateBase Constructor (DateTime)
•
DateBase Constructor (Int64)
•
DateBase Constructor (UInt32)


DateBase Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Constructor [image] DateBase Constructor
DateBase Constructor
Initializes a new instance of the DateBase class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected DateBase()
VB
Protected Sub New
Reference
DateBase Class
DateBase Overload
TwinCAT.PlcOpen Namespace


DateBase Constructor (DateTime)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Constructor [image] DateBase Constructor (DateTime)
DateBase Constructor (DateTime)
Initializes a new instance of the DateBase class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected DateBase(
DateTime date
)
VB
Protected Sub New (
date As DateTime
)
Parameters
date
Type: System.DateTime
The date.
Reference
DateBase Class
DateBase Overload
TwinCAT.PlcOpen Namespace


DateBase Constructor (Int64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Constructor [image] DateBase Constructor (Int64)
DateBase Constructor (Int64)
Initializes a new instance of the DateBase class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected DateBase(
long dateValue
)
VB
Protected Sub New (
dateValue As Long
)
Parameters
dateValue
Type: System.Int64
The date value in PlcOpen Ticks.
Exceptions
Exception | Condition
ArgumentOutOfRangeException |
Reference
DateBase Class
DateBase Overload
TwinCAT.PlcOpen Namespace


DateBase Constructor (UInt32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Constructor [image] DateBase Constructor (UInt32)
DateBase Constructor (UInt32)
Initializes a new instance of the DateBase class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected DateBase(
uint dateValue
)
VB
Protected Sub New (
dateValue As UInteger
)
Parameters
dateValue
Type: System.UInt32
The date value in PlcOpen Ticks.
Exceptions
Exception | Condition
ArgumentOutOfRangeException |
Reference
DateBase Class
DateBase Overload
TwinCAT.PlcOpen Namespace


DateBase Properties

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Properties
DateBase Properties
The DateBase type exposes the following members.
Properties
Name | Description
Date | Gets or sthe date value.
MarshalSize | Gets the marshal size in bytes.
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64).
Reference
DateBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
DateBase.Date Property
•
DateBase.MarshalSize Property
•
DateBase.Ticks Property


DateBase.Date Property

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Properties [image] DateBase.Date Property
DateBase.Date Property
Gets or sthe date value.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DateTime Date { get; }
VB
Public ReadOnly Property Date As DateTime
Get
Property Value
Type: DateTime
The date.
Reference
DateBase Class
TwinCAT.PlcOpen Namespace


DateBase.MarshalSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Properties [image] DateBase.MarshalSize Property
DateBase.MarshalSize Property
Gets the marshal size in bytes.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static int MarshalSize { get; }
VB
Public Shared ReadOnly Property MarshalSize As Integer
Get
Property Value
Type: Int32
Marshal size in bytes.
Reference
DateBase Class
TwinCAT.PlcOpen Namespace


DateBase.Ticks Property

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Properties [image] DateBase.Ticks Property
DateBase.Ticks Property
Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64).
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public uint Ticks { get; }
VB
Public ReadOnly Property Ticks As UInteger
Get
Property Value
Type: UInt32
The ticks.
Implements
IPlcOpenType.Ticks
Reference
DateBase Class
TwinCAT.PlcOpen Namespace


DateBase Methods

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Methods
DateBase Methods
The DateBase type exposes the following members.
Methods
Name | Description
DateToValue | Converts the specified DateTime value to PlcOpen Ticks.
Equals | Determines whether the specified Object is equal to this instance. (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseToTicks | Parses the specified PlcOpen Date string to PlcOpen ticks.
ToString | Returns a string that represents the current object. (Inherited from Object.)
ValueToDate(Int64) | Converts the specified PlcOpen dateValue in ticks to a DateTime Object
ValueToDate(UInt32) | Converts the specified PlcOpen dateValue in ticks to a DateTime Object
Reference
DateBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
DateBase.DateToValue Method
•
DateBase.Equals Method
•
DateBase.GetHashCode Method
•
DateBase.ParseToTicks Method
•
DateBase.ValueToDate Method


DateBase.DateToValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Methods [image] DateBase.DateToValue Method
DateBase.DateToValue Method
Converts the specified DateTime value to PlcOpen Ticks.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static long DateToValue(
DateTime date
)
VB
Public Shared Function DateToValue (
date As DateTime
) As Long
Parameters
date
Type: System.DateTime
The date.
Return Value
Type: Int64
Reference
DateBase Class
TwinCAT.PlcOpen Namespace


DateBase.Equals Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Methods [image] DateBase.Equals Method
DateBase.Equals Method
Determines whether the specified Object is equal to this instance.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool Equals(
Object obj
)
VB
Public Overrides Function Equals (
obj As Object
) As Boolean
Parameters
obj
Type: System.Object
The object to compare with the current object.
Return Value
Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Reference
DateBase Class
TwinCAT.PlcOpen Namespace


DateBase.GetHashCode Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Methods [image] DateBase.GetHashCode Method
DateBase.GetHashCode Method
Gets the HashCode of the Address
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override int GetHashCode()
VB
Public Overrides Function GetHashCode As Integer
Return Value
Type: Int32
Reference
DateBase Class
TwinCAT.PlcOpen Namespace


DateBase.ParseToTicks Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Methods [image] DateBase.ParseToTicks Method
DateBase.ParseToTicks Method
Parses the specified PlcOpen Date string to PlcOpen ticks.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected abstract long ParseToTicks(
string s
)
VB
Protected MustOverride Function ParseToTicks (
s As String
) As Long
Parameters
s
Type: System.String
The s.
Return Value
Type: Int64
Reference
DateBase Class
TwinCAT.PlcOpen Namespace


DateBase.ValueToDate Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Methods [image] DateBase.ValueToDate Method
DateBase.ValueToDate Method
Overload List
Name | Description
ValueToDate(Int64) | Converts the specified PlcOpen dateValue in ticks to a DateTime Object
ValueToDate(UInt32) | Converts the specified PlcOpen dateValue in ticks to a DateTime Object
Reference
DateBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
DateBase.ValueToDate Method (Int64)
•
DateBase.ValueToDate Method (UInt32)


DateBase.ValueToDate Method (Int64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Methods [image] DateBase.ValueToDate Method [image] DateBase.ValueToDate Method (Int64)
DateBase.ValueToDate Method (Int64)
Converts the specified PlcOpen dateValue in ticks to a DateTime Object
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static DateTime ValueToDate(
long dateValue
)
VB
Public Shared Function ValueToDate (
dateValue As Long
) As DateTime
Parameters
dateValue
Type: System.Int64
The date value.
Return Value
Type: DateTime
Reference
DateBase Class
ValueToDate Overload
TwinCAT.PlcOpen Namespace


DateBase.ValueToDate Method (UInt32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Methods [image] DateBase.ValueToDate Method [image] DateBase.ValueToDate Method (UInt32)
DateBase.ValueToDate Method (UInt32)
Converts the specified PlcOpen dateValue in ticks to a DateTime Object
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static DateTime ValueToDate(
uint dateValue
)
VB
Public Shared Function ValueToDate (
dateValue As UInteger
) As DateTime
Parameters
dateValue
Type: System.UInt32
The date value.
Return Value
Type: DateTime
Reference
DateBase Class
ValueToDate Overload
TwinCAT.PlcOpen Namespace


DateBase Fields

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Fields
DateBase Fields
The DateBase type exposes the following members.
Fields
Name | Description
internalDateValue | The internal date value
Reference
DateBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
DateBase.internalDateValue Field


DateBase.internalDateValue Field

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] DateBase Class [image] DateBase Fields [image] DateBase.internalDateValue Field
DateBase.internalDateValue Field
The internal date value
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected uint internalDateValue
VB
Protected internalDateValue As UInteger
Field Value
Type: UInt32
Reference
DateBase Class
TwinCAT.PlcOpen Namespace


LTIME Class

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class
LTIME Class
PlcOpen TIME class
Inheritance Hierarchy
System.Object
TwinCAT.PlcOpen.LTimeBase
TwinCAT.PlcOpen.LTIME
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class LTIME : LTimeBase
VB
Public NotInheritable Class LTIME
Inherits LTimeBase
The LTIME type exposes the following members.
Constructors
Name | Description
LTIME. | Initializes a new instance of the TIME class.
LTIME(Int64) | Initializes a new instance of the TIME class.
LTIME(TimeSpan) | Initializes a new instance of the TIME class.
LTIME(UInt64) | Initializes a new instance of the TIME class.
LTIME(Int32, Int32, Int32) | Initializes a new instance of the LTIME class.
LTIME(Int32, Int32, Int32, Int32) | Initializes a new instance of the LTIME class.
LTIME(Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the LTIME class.
Properties
Name | Description
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64). (Inherited from LTimeBase.)
Time | Gets or the time value. (Inherited from LTimeBase.)
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Inherited from LTimeBase.)
GetHashCode | Gets the HashCode of the Address (Inherited from LTimeBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Parse | Parses the specified string to a LTIME object.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryParse | Tries to parse the string to a LTIME object.
Reference
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
LTIME Constructor
•
LTIME Properties
•
LTIME Methods


LTIME Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Constructor
LTIME Constructor
Overload List
Name | Description
LTIME. | Initializes a new instance of the TIME class.
LTIME(Int64) | Initializes a new instance of the TIME class.
LTIME(TimeSpan) | Initializes a new instance of the TIME class.
LTIME(UInt64) | Initializes a new instance of the TIME class.
LTIME(Int32, Int32, Int32) | Initializes a new instance of the LTIME class.
LTIME(Int32, Int32, Int32, Int32) | Initializes a new instance of the LTIME class.
LTIME(Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the LTIME class.
Reference
LTIME Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
LTIME Constructor
•
LTIME Constructor (Int64)
•
LTIME Constructor (TimeSpan)
•
LTIME Constructor (UInt64)
•
LTIME Constructor (Int32, Int32, Int32)
•
LTIME Constructor (Int32, Int32, Int32, Int32)
•
LTIME Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Int32)


LTIME Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Constructor [image] LTIME Constructor
LTIME Constructor
Initializes a new instance of the TIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public LTIME()
VB
Public Sub New
Reference
LTIME Class
LTIME Overload
TwinCAT.PlcOpen Namespace


LTIME Constructor (Int64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Constructor [image] LTIME Constructor (Int64)
LTIME Constructor (Int64)
Initializes a new instance of the TIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public LTIME(
long timeValue
)
VB
Public Sub New (
timeValue As Long
)
Parameters
timeValue
Type: System.Int64
The time value.
Reference
LTIME Class
LTIME Overload
TwinCAT.PlcOpen Namespace


LTIME Constructor (TimeSpan)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Constructor [image] LTIME Constructor (TimeSpan)
LTIME Constructor (TimeSpan)
Initializes a new instance of the TIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public LTIME(
TimeSpan time
)
VB
Public Sub New (
time As TimeSpan
)
Parameters
time
Type: System.TimeSpan
The time.
Reference
LTIME Class
LTIME Overload
TwinCAT.PlcOpen Namespace


LTIME Constructor (UInt64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Constructor [image] LTIME Constructor (UInt64)
LTIME Constructor (UInt64)
Initializes a new instance of the TIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public LTIME(
ulong timeValue
)
VB
Public Sub New (
timeValue As ULong
)
Parameters
timeValue
Type: System.UInt64
The time value.
Reference
LTIME Class
LTIME Overload
TwinCAT.PlcOpen Namespace


LTIME Constructor (Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Constructor [image] LTIME Constructor (Int32, Int32, Int32)
LTIME Constructor (Int32, Int32, Int32)
Initializes a new instance of the LTIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public LTIME(
int seconds,
int milliseconds,
int microseconds
)
VB
Public Sub New (
seconds As Integer,
milliseconds As Integer,
microseconds As Integer
)
Parameters
seconds | Type: System.Int32 The seconds.
milliseconds | Type: System.Int32 The milliseconds.
microseconds | Type: System.Int32 The microseconds.
Reference
LTIME Class
LTIME Overload
TwinCAT.PlcOpen Namespace


LTIME Constructor (Int32, Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Constructor [image] LTIME Constructor (Int32, Int32, Int32, Int32)
LTIME Constructor (Int32, Int32, Int32, Int32)
Initializes a new instance of the LTIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public LTIME(
int seconds,
int milliseconds,
int microseconds,
int nanoseconds
)
VB
Public Sub New (
seconds As Integer,
milliseconds As Integer,
microseconds As Integer,
nanoseconds As Integer
)
Parameters
seconds | Type: System.Int32 The seconds.
milliseconds | Type: System.Int32 The milliseconds.
microseconds | Type: System.Int32 The microseconds.
nanoseconds | Type: System.Int32 The nanoseconds.
Reference
LTIME Class
LTIME Overload
TwinCAT.PlcOpen Namespace


LTIME Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Constructor [image] LTIME Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Int32)
LTIME Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Int32)
Initializes a new instance of the LTIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public LTIME(
int days,
int hours,
int minutes,
int seconds,
int milliseconds,
int microseconds,
int nanoseconds
)
VB
Public Sub New (
days As Integer,
hours As Integer,
minutes As Integer,
seconds As Integer,
milliseconds As Integer,
microseconds As Integer,
nanoseconds As Integer
)
Parameters
days | Type: System.Int32 The days.
hours | Type: System.Int32 The hours.
minutes | Type: System.Int32 The minutes.
seconds | Type: System.Int32 The seconds.
milliseconds | Type: System.Int32 The milliseconds.
microseconds | Type: System.Int32 The microseconds.
nanoseconds | Type: System.Int32 The nanoseconds.
Reference
LTIME Class
LTIME Overload
TwinCAT.PlcOpen Namespace


LTIME Properties

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Properties
LTIME Properties
The LTIME type exposes the following members.
Properties
Name | Description
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64). (Inherited from LTimeBase.)
Time | Gets or the time value. (Inherited from LTimeBase.)
Reference
LTIME Class
TwinCAT.PlcOpen Namespace


LTIME Methods

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Methods
LTIME Methods
The LTIME type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Inherited from LTimeBase.)
GetHashCode | Gets the HashCode of the Address (Inherited from LTimeBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Parse | Parses the specified string to a LTIME object.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryParse | Tries to parse the string to a LTIME object.
Reference
LTIME Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
LTIME.Parse Method
•
LTIME.ToString Method
•
LTIME.TryParse Method


LTIME.Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Methods [image] LTIME.Parse Method
LTIME.Parse Method
Parses the specified string to a LTIME object.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static LTIME Parse(
string str
)
VB
Public Shared Function Parse (
str As String
) As LTIME
Parameters
str
Type: System.String
The string.
Return Value
Type: LTIME
LTIME.
Exceptions
Exception | Condition
FormatException | Cannot create TIME DataType!
Reference
LTIME Class
TwinCAT.PlcOpen Namespace


LTIME.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Methods [image] LTIME.ToString Method
LTIME.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
LTIME Class
TwinCAT.PlcOpen Namespace


LTIME.TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTIME Class [image] LTIME Methods [image] LTIME.TryParse Method
LTIME.TryParse Method
Tries to parse the string to a LTIME object.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool TryParse(
string str,
out LTIME ret
)
VB
Public Shared Function TryParse (
str As String,
<OutAttribute> ByRef ret As LTIME
) As Boolean
Parameters
str | Type: System.String The string.
ret | Type: TwinCAT.PlcOpen.LTIME. The ret.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
LTIME Class
TwinCAT.PlcOpen Namespace


LTimeBase Class

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class
LTimeBase Class
Time base class
Inheritance Hierarchy
System.Object
TwinCAT.PlcOpen.LTimeBase
TwinCAT.PlcOpen.LTIME
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public abstract class LTimeBase : IPlcOpenType<TimeSpan, ulong>,
IPlcOpenType
VB
Public MustInherit Class LTimeBase
Implements IPlcOpenType(Of TimeSpan, ULong),
IPlcOpenType
The LTimeBase type exposes the following members.
Constructors
Name | Description
LTimeBase. | Initializes a new instance of the TimeBase class.
LTimeBase(UInt64) | Initializes a new instance of the TimeBase class.
Properties
Name | Description
MarshalSize | Gets the marshal size in bytes.
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64).
Time | Gets or the time value.
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
TimeToValue | Converts the Timespan to PlcOpen ticks.
ToString | Returns a string that represents the current object. (Inherited from Object.)
ValueToTime(Int64) | Converts the timeValue (PlcOpen ticks) to TimeSpan
ValueToTime(UInt64) | Converts the timeValue (PlcOpen ticks) to TimeSpan
Fields
Name | Description
internalTimeValue | The internal time value
Reference
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
LTimeBase Constructor
•
LTimeBase Properties
•
LTimeBase Methods
•
LTimeBase Fields


LTimeBase Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Constructor
LTimeBase Constructor
Overload List
Name | Description
LTimeBase. | Initializes a new instance of the TimeBase class.
LTimeBase(UInt64) | Initializes a new instance of the TimeBase class.
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
LTimeBase Constructor
•
LTimeBase Constructor (UInt64)


LTimeBase Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Constructor [image] LTimeBase Constructor
LTimeBase Constructor
Initializes a new instance of the TimeBase class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected LTimeBase()
VB
Protected Sub New
Reference
LTimeBase Class
LTimeBase Overload
TwinCAT.PlcOpen Namespace


LTimeBase Constructor (UInt64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Constructor [image] LTimeBase Constructor (UInt64)
LTimeBase Constructor (UInt64)
Initializes a new instance of the TimeBase class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected LTimeBase(
ulong timeValue
)
VB
Protected Sub New (
timeValue As ULong
)
Parameters
timeValue
Type: System.UInt64
The time value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException |
Reference
LTimeBase Class
LTimeBase Overload
TwinCAT.PlcOpen Namespace


LTimeBase Properties

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Properties
LTimeBase Properties
The LTimeBase type exposes the following members.
Properties
Name | Description
MarshalSize | Gets the marshal size in bytes.
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64).
Time | Gets or the time value.
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
LTimeBase.MarshalSize Property
•
LTimeBase.Ticks Property
•
LTimeBase.Time Property


LTimeBase.MarshalSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Properties [image] LTimeBase.MarshalSize Property
LTimeBase.MarshalSize Property
Gets the marshal size in bytes.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static int MarshalSize { get; }
VB
Public Shared ReadOnly Property MarshalSize As Integer
Get
Property Value
Type: Int32
Marshal size in bytes.
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace


LTimeBase.Ticks Property

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Properties [image] LTimeBase.Ticks Property
LTimeBase.Ticks Property
Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64).
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ulong Ticks { get; }
VB
Public ReadOnly Property Ticks As ULong
Get
Property Value
Type: UInt64
The ticks.
Implements
IPlcOpenType.Ticks
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace


LTimeBase.Time Property

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Properties [image] LTimeBase.Time Property
LTimeBase.Time Property
Gets or the time value.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TimeSpan Time { get; }
VB
Public ReadOnly Property Time As TimeSpan
Get
Property Value
Type: TimeSpan
The time.
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace


LTimeBase Methods

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Methods
LTimeBase Methods
The LTimeBase type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
TimeToValue | Converts the Timespan to PlcOpen ticks.
ToString | Returns a string that represents the current object. (Inherited from Object.)
ValueToTime(Int64) | Converts the timeValue (PlcOpen ticks) to TimeSpan
ValueToTime(UInt64) | Converts the timeValue (PlcOpen ticks) to TimeSpan
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
LTimeBase.Equals Method
•
LTimeBase.GetHashCode Method
•
LTimeBase.TimeToValue Method
•
LTimeBase.ValueToTime Method


LTimeBase.Equals Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Methods [image] LTimeBase.Equals Method
LTimeBase.Equals Method
Determines whether the specified Object is equal to this instance.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool Equals(
Object obj
)
VB
Public Overrides Function Equals (
obj As Object
) As Boolean
Parameters
obj
Type: System.Object
The object to compare with the current object.
Return Value
Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace


LTimeBase.GetHashCode Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Methods [image] LTimeBase.GetHashCode Method
LTimeBase.GetHashCode Method
Gets the HashCode of the Address
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override int GetHashCode()
VB
Public Overrides Function GetHashCode As Integer
Return Value
Type: Int32
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace


LTimeBase.TimeToValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Methods [image] LTimeBase.TimeToValue Method
LTimeBase.TimeToValue Method
Converts the Timespan to PlcOpen ticks.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static ulong TimeToValue(
TimeSpan time
)
VB
Public Shared Function TimeToValue (
time As TimeSpan
) As ULong
Parameters
time
Type: System.TimeSpan
The time.
Return Value
Type: UInt64
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace


LTimeBase.ValueToTime Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Methods [image] LTimeBase.ValueToTime Method
LTimeBase.ValueToTime Method
Overload List
Name | Description
ValueToTime(Int64) | Converts the timeValue (PlcOpen ticks) to TimeSpan
ValueToTime(UInt64) | Converts the timeValue (PlcOpen ticks) to TimeSpan
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
LTimeBase.ValueToTime Method (Int64)
•
LTimeBase.ValueToTime Method (UInt64)


LTimeBase.ValueToTime Method (Int64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Methods [image] LTimeBase.ValueToTime Method [image] LTimeBase.ValueToTime Method (Int64)
LTimeBase.ValueToTime Method (Int64)
Converts the timeValue (PlcOpen ticks) to TimeSpan
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static TimeSpan ValueToTime(
long nanoseconds
)
VB
Public Shared Function ValueToTime (
nanoseconds As Long
) As TimeSpan
Parameters
nanoseconds
Type: System.Int64
The time value.
Return Value
Type: TimeSpan
Reference
LTimeBase Class
ValueToTime Overload
TwinCAT.PlcOpen Namespace


LTimeBase.ValueToTime Method (UInt64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Methods [image] LTimeBase.ValueToTime Method [image] LTimeBase.ValueToTime Method (UInt64)
LTimeBase.ValueToTime Method (UInt64)
Converts the timeValue (PlcOpen ticks) to TimeSpan
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static TimeSpan ValueToTime(
ulong nanoseconds
)
VB
Public Shared Function ValueToTime (
nanoseconds As ULong
) As TimeSpan
Parameters
nanoseconds
Type: System.UInt64
The time value.
Return Value
Type: TimeSpan
Reference
LTimeBase Class
ValueToTime Overload
TwinCAT.PlcOpen Namespace


LTimeBase Fields

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Fields
LTimeBase Fields
The LTimeBase type exposes the following members.
Fields
Name | Description
internalTimeValue | The internal time value
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
LTimeBase.internalTimeValue Field


LTimeBase.internalTimeValue Field

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] LTimeBase Class [image] LTimeBase Fields [image] LTimeBase.internalTimeValue Field
LTimeBase.internalTimeValue Field
The internal time value
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected ulong internalTimeValue
VB
Protected internalTimeValue As ULong
Field Value
Type: UInt64
Reference
LTimeBase Class
TwinCAT.PlcOpen Namespace


TIME Class

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class
TIME Class
PlcOpen TIME class
Inheritance Hierarchy
System.Object
TwinCAT.PlcOpen.TimeBase
TwinCAT.PlcOpen.TIME
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class TIME : TimeBase
VB
Public NotInheritable Class TIME
Inherits TimeBase
The TIME type exposes the following members.
Constructors
Name | Description
TIME. | Initializes a new instance of the TIME class.
TIME(Int64) | Initializes a new instance of the TIME class.
TIME(TimeSpan) | Initializes a new instance of the TIME class.
TIME(UInt32) | Initializes a new instance of the TIME class.
TIME(Int32, Int32) | Initializes a new instance of the TIME class.
TIME(Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the TIME class.
Properties
Name | Description
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64). (Inherited from TimeBase.)
Time | Gets the time value. (Inherited from TimeBase.)
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Inherited from TimeBase.)
GetHashCode | Gets the HashCode of the Address (Inherited from TimeBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Parse | Parses the specified string to a TIME object.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryParse | Tries to parse the TIME object from string.
Reference
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TIME Constructor
•
TIME Properties
•
TIME Methods


TIME Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Constructor
TIME Constructor
Overload List
Name | Description
TIME. | Initializes a new instance of the TIME class.
TIME(Int64) | Initializes a new instance of the TIME class.
TIME(TimeSpan) | Initializes a new instance of the TIME class.
TIME(UInt32) | Initializes a new instance of the TIME class.
TIME(Int32, Int32) | Initializes a new instance of the TIME class.
TIME(Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the TIME class.
Reference
TIME Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TIME Constructor
•
TIME Constructor (Int64)
•
TIME Constructor (TimeSpan)
•
TIME Constructor (UInt32)
•
TIME Constructor (Int32, Int32)
•
TIME Constructor (Int32, Int32, Int32, Int32, Int32)


TIME Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Constructor [image] TIME Constructor
TIME Constructor
Initializes a new instance of the TIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TIME()
VB
Public Sub New
Reference
TIME Class
TIME Overload
TwinCAT.PlcOpen Namespace


TIME Constructor (Int64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Constructor [image] TIME Constructor (Int64)
TIME Constructor (Int64)
Initializes a new instance of the TIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TIME(
long timeValue
)
VB
Public Sub New (
timeValue As Long
)
Parameters
timeValue
Type: System.Int64
The time value.
Reference
TIME Class
TIME Overload
TwinCAT.PlcOpen Namespace


TIME Constructor (TimeSpan)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Constructor [image] TIME Constructor (TimeSpan)
TIME Constructor (TimeSpan)
Initializes a new instance of the TIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TIME(
TimeSpan time
)
VB
Public Sub New (
time As TimeSpan
)
Parameters
time
Type: System.TimeSpan
The time.
Reference
TIME Class
TIME Overload
TwinCAT.PlcOpen Namespace


TIME Constructor (UInt32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Constructor [image] TIME Constructor (UInt32)
TIME Constructor (UInt32)
Initializes a new instance of the TIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TIME(
uint timeValue
)
VB
Public Sub New (
timeValue As UInteger
)
Parameters
timeValue
Type: System.UInt32
The time value.
Reference
TIME Class
TIME Overload
TwinCAT.PlcOpen Namespace


TIME Constructor (Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Constructor [image] TIME Constructor (Int32, Int32)
TIME Constructor (Int32, Int32)
Initializes a new instance of the TIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TIME(
int seconds,
int milliseconds
)
VB
Public Sub New (
seconds As Integer,
milliseconds As Integer
)
Parameters
seconds | Type: System.Int32 The seconds.
milliseconds | Type: System.Int32 The milliseconds.
Reference
TIME Class
TIME Overload
TwinCAT.PlcOpen Namespace


TIME Constructor (Int32, Int32, Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Constructor [image] TIME Constructor (Int32, Int32, Int32, Int32, Int32)
TIME Constructor (Int32, Int32, Int32, Int32, Int32)
Initializes a new instance of the TIME class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TIME(
int days,
int hours,
int minutes,
int seconds,
int milliseconds
)
VB
Public Sub New (
days As Integer,
hours As Integer,
minutes As Integer,
seconds As Integer,
milliseconds As Integer
)
Parameters
days | Type: System.Int32 The days.
hours | Type: System.Int32 The hours.
minutes | Type: System.Int32 The minutes.
seconds | Type: System.Int32 The seconds.
milliseconds | Type: System.Int32 The milliseconds.
Reference
TIME Class
TIME Overload
TwinCAT.PlcOpen Namespace


TIME Properties

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Properties
TIME Properties
The TIME type exposes the following members.
Properties
Name | Description
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64). (Inherited from TimeBase.)
Time | Gets the time value. (Inherited from TimeBase.)
Reference
TIME Class
TwinCAT.PlcOpen Namespace


TIME Methods

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Methods
TIME Methods
The TIME type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Inherited from TimeBase.)
GetHashCode | Gets the HashCode of the Address (Inherited from TimeBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Parse | Parses the specified string to a TIME object.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryParse | Tries to parse the TIME object from string.
Reference
TIME Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TIME.Parse Method
•
TIME.ToString Method
•
TIME.TryParse Method


TIME.Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Methods [image] TIME.Parse Method
TIME.Parse Method
Parses the specified string to a TIME object.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static TIME Parse(
string str
)
VB
Public Shared Function Parse (
str As String
) As TIME
Parameters
str
Type: System.String
The string.
Return Value
Type: TIME
TIME.
Exceptions
Exception | Condition
FormatException | Cannot create TIME DataType!
Reference
TIME Class
TwinCAT.PlcOpen Namespace


TIME.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Methods [image] TIME.ToString Method
TIME.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
TIME Class
TwinCAT.PlcOpen Namespace


TIME.TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TIME Class [image] TIME Methods [image] TIME.TryParse Method
TIME.TryParse Method
Tries to parse the TIME object from string.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool TryParse(
string str,
out TIME ret
)
VB
Public Shared Function TryParse (
str As String,
<OutAttribute> ByRef ret As TIME
) As Boolean
Parameters
str | Type: System.String The string.
ret | Type: TwinCAT.PlcOpen.TIME. The ret.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
TIME Class
TwinCAT.PlcOpen Namespace


TimeBase Class

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class
TimeBase Class
Time base class
Inheritance Hierarchy
System.Object
TwinCAT.PlcOpen.TimeBase
TwinCAT.PlcOpen.TIME
TwinCAT.PlcOpen.TOD
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public abstract class TimeBase : IPlcOpenType<TimeSpan, uint>,
IPlcOpenType
VB
Public MustInherit Class TimeBase
Implements IPlcOpenType(Of TimeSpan, UInteger),
IPlcOpenType
The TimeBase type exposes the following members.
Constructors
Name | Description
TimeBase. | Initializes a new instance of the TimeBase class.
TimeBase(Int64) | Initializes a new instance of the TimeBase class.
TimeBase(UInt32) | Initializes a new instance of the TimeBase class.
Properties
Name | Description
MarshalSize | Gets the marshal size in bytes.
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64).
Time | Gets the time value.
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
TimeToValue | Converts the Timespan to PlcOpen ticks.
ToString | Returns a string that represents the current object. (Inherited from Object.)
ValueToTime(Int64) | Converts the timeValue (PlcOpen ticks) to TimeSpan
ValueToTime(UInt32) | Converts the timeValue (PlcOpen ticks) to TimeSpan
Fields
Name | Description
internalTimeValue | The internal time value
Reference
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TimeBase Constructor
•
TimeBase Properties
•
TimeBase Methods
•
TimeBase Fields


TimeBase Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Constructor
TimeBase Constructor
Overload List
Name | Description
TimeBase. | Initializes a new instance of the TimeBase class.
TimeBase(Int64) | Initializes a new instance of the TimeBase class.
TimeBase(UInt32) | Initializes a new instance of the TimeBase class.
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TimeBase Constructor
•
TimeBase Constructor (Int64)
•
TimeBase Constructor (UInt32)


TimeBase Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Constructor [image] TimeBase Constructor
TimeBase Constructor
Initializes a new instance of the TimeBase class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected TimeBase()
VB
Protected Sub New
Reference
TimeBase Class
TimeBase Overload
TwinCAT.PlcOpen Namespace


TimeBase Constructor (Int64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Constructor [image] TimeBase Constructor (Int64)
TimeBase Constructor (Int64)
Initializes a new instance of the TimeBase class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected TimeBase(
long timeValue
)
VB
Protected Sub New (
timeValue As Long
)
Parameters
timeValue
Type: System.Int64
The time value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException |
Reference
TimeBase Class
TimeBase Overload
TwinCAT.PlcOpen Namespace


TimeBase Constructor (UInt32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Constructor [image] TimeBase Constructor (UInt32)
TimeBase Constructor (UInt32)
Initializes a new instance of the TimeBase class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected TimeBase(
uint timeValue
)
VB
Protected Sub New (
timeValue As UInteger
)
Parameters
timeValue
Type: System.UInt32
The time value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException |
Reference
TimeBase Class
TimeBase Overload
TwinCAT.PlcOpen Namespace


TimeBase Properties

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Properties
TimeBase Properties
The TimeBase type exposes the following members.
Properties
Name | Description
MarshalSize | Gets the marshal size in bytes.
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64).
Time | Gets the time value.
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TimeBase.MarshalSize Property
•
TimeBase.Ticks Property
•
TimeBase.Time Property


TimeBase.MarshalSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Properties [image] TimeBase.MarshalSize Property
TimeBase.MarshalSize Property
Gets the marshal size in bytes.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static int MarshalSize { get; }
VB
Public Shared ReadOnly Property MarshalSize As Integer
Get
Property Value
Type: Int32
Marshal size in bytes.
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace


TimeBase.Ticks Property

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Properties [image] TimeBase.Ticks Property
TimeBase.Ticks Property
Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64).
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public uint Ticks { get; }
VB
Public ReadOnly Property Ticks As UInteger
Get
Property Value
Type: UInt32
The ticks.
Implements
IPlcOpenType.Ticks
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace


TimeBase.Time Property

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Properties [image] TimeBase.Time Property
TimeBase.Time Property
Gets the time value.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual TimeSpan Time { get; }
VB
Public Overridable ReadOnly Property Time As TimeSpan
Get
Property Value
Type: TimeSpan
The time.
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace


TimeBase Methods

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Methods
TimeBase Methods
The TimeBase type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
TimeToValue | Converts the Timespan to PlcOpen ticks.
ToString | Returns a string that represents the current object. (Inherited from Object.)
ValueToTime(Int64) | Converts the timeValue (PlcOpen ticks) to TimeSpan
ValueToTime(UInt32) | Converts the timeValue (PlcOpen ticks) to TimeSpan
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TimeBase.Equals Method
•
TimeBase.GetHashCode Method
•
TimeBase.TimeToValue Method
•
TimeBase.ValueToTime Method


TimeBase.Equals Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Methods [image] TimeBase.Equals Method
TimeBase.Equals Method
Determines whether the specified Object is equal to this instance.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool Equals(
Object obj
)
VB
Public Overrides Function Equals (
obj As Object
) As Boolean
Parameters
obj
Type: System.Object
The object to compare with the current object.
Return Value
Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace


TimeBase.GetHashCode Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Methods [image] TimeBase.GetHashCode Method
TimeBase.GetHashCode Method
Gets the HashCode of the Address
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override int GetHashCode()
VB
Public Overrides Function GetHashCode As Integer
Return Value
Type: Int32
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace


TimeBase.TimeToValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Methods [image] TimeBase.TimeToValue Method
TimeBase.TimeToValue Method
Converts the Timespan to PlcOpen ticks.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static long TimeToValue(
TimeSpan time
)
VB
Public Shared Function TimeToValue (
time As TimeSpan
) As Long
Parameters
time
Type: System.TimeSpan
The time.
Return Value
Type: Int64
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace


TimeBase.ValueToTime Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Methods [image] TimeBase.ValueToTime Method
TimeBase.ValueToTime Method
Overload List
Name | Description
ValueToTime(Int64) | Converts the timeValue (PlcOpen ticks) to TimeSpan
ValueToTime(UInt32) | Converts the timeValue (PlcOpen ticks) to TimeSpan
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TimeBase.ValueToTime Method (Int64)
•
TimeBase.ValueToTime Method (UInt32)


TimeBase.ValueToTime Method (Int64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Methods [image] TimeBase.ValueToTime Method [image] TimeBase.ValueToTime Method (Int64)
TimeBase.ValueToTime Method (Int64)
Converts the timeValue (PlcOpen ticks) to TimeSpan
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static TimeSpan ValueToTime(
long timeValue
)
VB
Public Shared Function ValueToTime (
timeValue As Long
) As TimeSpan
Parameters
timeValue
Type: System.Int64
The time value.
Return Value
Type: TimeSpan
Reference
TimeBase Class
ValueToTime Overload
TwinCAT.PlcOpen Namespace


TimeBase.ValueToTime Method (UInt32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Methods [image] TimeBase.ValueToTime Method [image] TimeBase.ValueToTime Method (UInt32)
TimeBase.ValueToTime Method (UInt32)
Converts the timeValue (PlcOpen ticks) to TimeSpan
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static TimeSpan ValueToTime(
uint timeValue
)
VB
Public Shared Function ValueToTime (
timeValue As UInteger
) As TimeSpan
Parameters
timeValue
Type: System.UInt32
The time value.
Return Value
Type: TimeSpan
Reference
TimeBase Class
ValueToTime Overload
TwinCAT.PlcOpen Namespace


TimeBase Fields

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Fields
TimeBase Fields
The TimeBase type exposes the following members.
Fields
Name | Description
internalTimeValue | The internal time value
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TimeBase.internalTimeValue Field


TimeBase.internalTimeValue Field

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TimeBase Class [image] TimeBase Fields [image] TimeBase.internalTimeValue Field
TimeBase.internalTimeValue Field
The internal time value
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected uint internalTimeValue
VB
Protected internalTimeValue As UInteger
Field Value
Type: UInt32
Reference
TimeBase Class
TwinCAT.PlcOpen Namespace


TOD Class

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class
TOD Class
TimeOfDay class
Inheritance Hierarchy
System.Object
TwinCAT.PlcOpen.TimeBase
TwinCAT.PlcOpen.TOD
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class TOD : TimeBase
VB
Public NotInheritable Class TOD
Inherits TimeBase
The TOD type exposes the following members.
Constructors
Name | Description
TOD. | Initializes a new instance of the TOD class.
TOD(Int64) | Initializes a new instance of the TOD class.
TOD(TimeSpan) | Initializes a new instance of the TOD class.
TOD(UInt32) | Initializes a new instance of the TOD class.
TOD(Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the TOD class.
Properties
Name | Description
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64). (Inherited from TimeBase.)
Time | Gets the time value. (Inherited from TimeBase.)
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Inherited from TimeBase.)
GetHashCode | Gets the HashCode of the Address (Inherited from TimeBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Parse | Parses the specified string to a TOD object.
ToString | Returns a string that represents the current object. (Overrides Object.ToString..)
TryParse | Tries to parse the string to a TOD object.
Reference
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TOD Constructor
•
TOD Properties
•
TOD Methods


TOD Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class [image] TOD Constructor
TOD Constructor
Overload List
Name | Description
TOD. | Initializes a new instance of the TOD class.
TOD(Int64) | Initializes a new instance of the TOD class.
TOD(TimeSpan) | Initializes a new instance of the TOD class.
TOD(UInt32) | Initializes a new instance of the TOD class.
TOD(Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the TOD class.
Reference
TOD Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TOD Constructor
•
TOD Constructor (Int64)
•
TOD Constructor (TimeSpan)
•
TOD Constructor (UInt32)
•
TOD Constructor (Int32, Int32, Int32, Int32, Int32)


TOD Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class [image] TOD Constructor [image] TOD Constructor
TOD Constructor
Initializes a new instance of the TOD class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TOD()
VB
Public Sub New
Reference
TOD Class
TOD Overload
TwinCAT.PlcOpen Namespace


TOD Constructor (Int64)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class [image] TOD Constructor [image] TOD Constructor (Int64)
TOD Constructor (Int64)
Initializes a new instance of the TOD class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TOD(
long time
)
VB
Public Sub New (
time As Long
)
Parameters
time
Type: System.Int64
The time.
Reference
TOD Class
TOD Overload
TwinCAT.PlcOpen Namespace


TOD Constructor (TimeSpan)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class [image] TOD Constructor [image] TOD Constructor (TimeSpan)
TOD Constructor (TimeSpan)
Initializes a new instance of the TOD class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TOD(
TimeSpan timeSpan
)
VB
Public Sub New (
timeSpan As TimeSpan
)
Parameters
timeSpan
Type: System.TimeSpan
The time span.
Reference
TOD Class
TOD Overload
TwinCAT.PlcOpen Namespace


TOD Constructor (UInt32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class [image] TOD Constructor [image] TOD Constructor (UInt32)
TOD Constructor (UInt32)
Initializes a new instance of the TOD class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TOD(
uint time
)
VB
Public Sub New (
time As UInteger
)
Parameters
time
Type: System.UInt32
The time.
Reference
TOD Class
TOD Overload
TwinCAT.PlcOpen Namespace


TOD Constructor (Int32, Int32, Int32, Int32, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class [image] TOD Constructor [image] TOD Constructor (Int32, Int32, Int32, Int32, Int32)
TOD Constructor (Int32, Int32, Int32, Int32, Int32)
Initializes a new instance of the TOD class.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TOD(
int days,
int hours,
int minutes,
int seconds,
int milliseconds
)
VB
Public Sub New (
days As Integer,
hours As Integer,
minutes As Integer,
seconds As Integer,
milliseconds As Integer
)
Parameters
days | Type: System.Int32 The days.
hours | Type: System.Int32 The hours.
minutes | Type: System.Int32 The minutes.
seconds | Type: System.Int32 The seconds.
milliseconds | Type: System.Int32 The milliseconds.
Reference
TOD Class
TOD Overload
TwinCAT.PlcOpen Namespace


TOD Properties

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class [image] TOD Properties
TOD Properties
The TOD type exposes the following members.
Properties
Name | Description
Ticks | Returns the number of ticks that represent the value of this IPlcOpenType (uint32 or uint64). (Inherited from TimeBase.)
Time | Gets the time value. (Inherited from TimeBase.)
Reference
TOD Class
TwinCAT.PlcOpen Namespace


TOD Methods

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class [image] TOD Methods
TOD Methods
The TOD type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified Object is equal to this instance. (Inherited from TimeBase.)
GetHashCode | Gets the HashCode of the Address (Inherited from TimeBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Parse | Parses the specified string to a TOD object.
ToString | Returns a string that represents the current object. (Overrides Object.ToString..)
TryParse | Tries to parse the string to a TOD object.
Reference
TOD Class
TwinCAT.PlcOpen Namespace
Weiterführende Informationen
•
TOD.Parse Method
•
TOD.ToString Method
•
TOD.TryParse Method


TOD.Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class [image] TOD Methods [image] TOD.Parse Method
TOD.Parse Method
Parses the specified string to a TOD object.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static TOD Parse(
string str
)
VB
Public Shared Function Parse (
str As String
) As TOD
Parameters
str
Type: System.String
The string.
Return Value
Type: TOD
TOD.
Exceptions
Exception | Condition
FormatException | Cannot parse TOD object!
Reference
TOD Class
TwinCAT.PlcOpen Namespace


TOD.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class [image] TOD Methods [image] TOD.ToString Method
TOD.ToString Method
Returns a string that represents the current object.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A string that represents the current object.
Reference
TOD Class
TwinCAT.PlcOpen Namespace


TOD.TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.PlcOpen Namespace [image] TOD Class [image] TOD Methods [image] TOD.TryParse Method
TOD.TryParse Method
Tries to parse the string to a TOD object.
Namespace: TwinCAT.PlcOpen
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool TryParse(
string str,
out TOD ret
)
VB
Public Shared Function TryParse (
str As String,
<OutAttribute> ByRef ret As TOD
) As Boolean
Parameters
str | Type: System.String The string.
ret | Type: TwinCAT.PlcOpen.TOD. The ret.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
TOD Class
TwinCAT.PlcOpen Namespace


TwinCAT.TypeSystem Namespace

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem Namespace
Namespace for the common (non ADS dependant) type system.
Classes
Class | Description
DataTypeCollection | Collection of DataTypes.
DataTypeEventArgs | Class DataTypeEventArgs.
DataTypeException | Data Type Exception
DataTypeNameEventArgs | Class DataTypeNameEventArgs.
Dimension | Represents a single dimension of an IArrayType
DimensionCollection | Collection class for Array Dimensions
DynamicAliasInstance | Class DynamicAliasInstance. This class cannot be inherited.
DynamicArrayInstance | Dynamic Array Instance
DynamicOversamplingArrayInstance | Dynamic Array Instance
DynamicPointerInstance | Dynamic Pointer Instance
DynamicPointerValue | Class DynamicPointerValue.
DynamicReferenceInstance | Dynamic Reference Instance
DynamicReferenceValue | Class DynamicReferenceValue.
DynamicRpcStructInstance | Dynamic struct instance with RPC Methods.
DynamicStructInstance | Dynamic struct instance
DynamicSymbol | Dynamic Symbol object.
DynamicSymbolsContainer | Dynamic (Expandable) Symbols collection.
DynamicUnionInstance | Dynamic union instance
DynamicValue | Dynamic value (uses RuntimeBinding for ISymbol value reading / writing).
DynamicVirtualStructInstance | Dynamic struct instance
EnumValue.T. | Enum Value
EnumValueCollection | Class EnumValueCollection.
EnumValueCollection.T. | Collection of EnumValues
FieldCollection | Collection of IField objects.
MarshalException | Common Marshalling Exception
MemberCollection | Collection of IMember objects.
RawValueChangedArgs | Event args for the RawValueChanged event.
ReadOnlyDataTypeCollection | ReadOnly Collection of IDataType objects.
ReadOnlyDimensionCollection | ReadOnly version of the DimensionCollection
ReadOnlyEnumValueCollection | Read only version of the EnumValueCollection.T.
ReadOnlyEnumValueCollection.T. | Read only version of the EnumValueCollection.T.
ReadOnlyFieldCollection | Read only collection of IField objects
ReadOnlyMemberCollection | Read only collection of IMember objects
ReadOnlyMethodParameterCollection | Read only RpcMethodParameterCollection.
ReadOnlyRpcMethodCollection | Read only RpcMethodCollection
ReadOnlySubItemCollection | Class ReadOnlySubItemCollection.
ReadOnlySymbolCollection | ReadOnly collection containing ISymbol objects.
ReadOnlyTypeAttributeCollection | Read only version of the TypeAttributeCollection
RpcMethodCollection | Collection of RpcMethods.
RpcMethodParameterCollection | Collection of RPC method parameters
SubItemCollection | Class SubItemCollection.
SymbolCollection | Interface represents a collection of ISymbol objects.
TypeAttribute | ADS Attribute
TypeAttributeCollection | Collection of AdsAttributes
ValueChangedArgs | Event args for the ValueChanged event.
ValueChangedBaseArgs | Event args for the RawValueChanged event.
Interfaces
Interface | Description
IAliasInstance | Interface representing an instance of an IAliasType.
IAliasType | Interface representing an Alias Type
IArrayInstance | Interface representing an array instance
IArrayType | Interface representing an array DataType.
IArrayValue | Interface IArrayValue
IAttributedInstance | Interface IAttributedInstance
IBitSize | Interface IBitSize
IDataType | Base interface for objects representing data types
IDimension | Interface representing a single Dimension of an ArrayType.
IDimensionCollection | Interface IDimensionCollection
IDynamicSymbol | Interface IDynamicSymbol
IDynamicSymbolLoader | Dynamic symbol loader interface
IEnumType | Common Enum type interface
IEnumType.T. | Interface representing an enum type
IEnumValue | Generic interface for EnumValues
IField | Specifies a single field/member of a Struct DataType.
IInstance | Interface specifying instance objects.
IMember | Specifies a single field/member of a Struct DataType.
INotificationSettings | Interface for Notification Settings
IOversamplingArrayInstance | Interface IOversamplingArrayInstance
IPointerInstance | Interface representing an instance of an IPointerType
IPointerType | Interface representing a pointer type
IPrimitiveType | Interface IPrimitiveType
IProcessImageAddress | Interface describing a Process Image Address
IReferenceInstance | Interface representing an instance of an IReferenceType
IReferenceType | Interface representing a reference/pointer type
IRpcCallableInstance | Interface for an RPC callable PLC Method (Remote procedure call)
IRpcCallableType | Interface representing an RPC callable IStructType
IRpcMethod | Interface describes an RPC Method
IRpcMethodParameter | Interface IRpcMethodParameter
IRpcStructInstance | Interface IRpcStructInstance
IStringInstance | Interface IStringInstance
IStringType | Interface representing a string IDataType
IStructInstance | Interface representing an instance of a IStructType
IStructType | Interface representing Struct data types
IStructValue | Interface IStructValue
ISubRangeType | Interface representing a SubRange type
ISubRangeType.T. | Interface representing a SubRange type
ISymbol | Interface specifying Symbols (
ISymbolCollection | Interface ISymbolCollection
ISymbolInfo | Interface ISymbolInfo
ISymbolLoader | Symbol Loader interface
ISymbolProvider | Symbol Provider interface.
ISymbolServer | Symbol Server Interface
ITypeAttribute | Interface for ADS attributes
IUnionInstance | Interface for an Instance of the IUnionType.
IUnionType | Interface for an union data type.
IValue | Symbol Value Interface
IValueAnySymbol | Interface IValueAnySymbol
IValueRawSymbol | Interface IValueRawSymbol
IValueSymbol | Interface for a ISymbol that supports values.
IValueSymbol2 | Interface for a ISymbol that supports values.
IValueSymbol3 | Interface IValueSymbol3 Implements the IValueSymbol2
IVirtualStructInstance | Virtual Struct instance interface.
Enumerations
Enumeration | Description
DataTypeCategory | Category of a DataType / Instance
MethodParamFlags | Flag set specifying the MethodParameter context
PrimitiveTypeFlags | Enum PrimitiveTypeFlags
SymbolAccessRights | Enum specifying Access Rights to symbols
Weiterführende Informationen
•
DataTypeCategory Enumeration
•
DataTypeCollection Class
•
DataTypeEventArgs Class
•
DataTypeException Class
•
DataTypeNameEventArgs Class
•
Dimension Class
•
DimensionCollection Class
•
DynamicAliasInstance Class
•
DynamicArrayInstance Class
•
DynamicOversamplingArrayInstance Class
•
DynamicPointerInstance Class
•
DynamicPointerValue Class
•
DynamicReferenceInstance Class
•
DynamicReferenceValue Class
•
DynamicRpcStructInstance Class
•
DynamicStructInstance Class
•
DynamicSymbol Class
•
DynamicSymbolsContainer Class
•
DynamicUnionInstance Class
•
DynamicValue Class
•
DynamicVirtualStructInstance Class
•
EnumValue.T. Class
•
EnumValueCollection Class
•
EnumValueCollection.T. Class
•
FieldCollection Class
•
IAliasInstance Interface
•
IAliasType Interface
•
IArrayInstance Interface
•
IArrayType Interface
•
IArrayValue Interface
•
IAttributedInstance Interface
•
IBitSize Interface
•
IDataType Interface
•
IDimension Interface
•
IDimensionCollection Interface
•
IDynamicSymbol Interface
•
IDynamicSymbolLoader Interface
•
IEnumType Interface
•
IEnumType.T. Interface
•
IEnumValue Interface
•
IField Interface
•
IInstance Interface
•
IMember Interface
•
INotificationSettings Interface
•
IOversamplingArrayInstance Interface
•
IPointerInstance Interface
•
IPointerType Interface
•
IPrimitiveType Interface
•
IProcessImageAddress Interface
•
IReferenceInstance Interface
•
IReferenceType Interface
•
IRpcCallableInstance Interface
•
IRpcCallableType Interface
•
IRpcMethod Interface
•
IRpcMethodParameter Interface
•
IRpcStructInstance Interface
•
IStringInstance Interface
•
IStringType Interface
•
IStructInstance Interface
•
IStructType Interface
•
IStructValue Interface
•
ISubRangeType Interface
•
ISubRangeType.T. Interface
•
ISymbol Interface
•
ISymbolCollection Interface
•
ISymbolInfo Interface
•
ISymbolLoader Interface
•
ISymbolProvider Interface
•
ISymbolServer Interface
•
ITypeAttribute Interface
•
IUnionInstance Interface
•
IUnionType Interface
•
IValue Interface
•
IValueAnySymbol Interface
•
IValueRawSymbol Interface
•
IValueSymbol Interface
•
IValueSymbol2 Interface
•
IValueSymbol3 Interface
•
IVirtualStructInstance Interface
•
MarshalException Class
•
MemberCollection Class
•
MethodParamFlags Enumeration
•
PrimitiveTypeFlags Enumeration
•
RawValueChangedArgs Class
•
ReadOnlyDataTypeCollection Class
•
ReadOnlyDimensionCollection Class
•
ReadOnlyEnumValueCollection Class
•
ReadOnlyEnumValueCollection.T. Class
•
ReadOnlyFieldCollection Class
•
ReadOnlyMemberCollection Class
•
ReadOnlyMethodParameterCollection Class
•
ReadOnlyRpcMethodCollection Class
•
ReadOnlySubItemCollection Class
•
ReadOnlySymbolCollection Class
•
ReadOnlyTypeAttributeCollection Class
•
RpcMethodCollection Class
•
RpcMethodParameterCollection Class
•
SubItemCollection Class
•
SymbolAccessRights Enumeration
•
SymbolCollection Class
•
TypeAttribute Class
•
TypeAttributeCollection Class
•
ValueChangedArgs Class
•
ValueChangedBaseArgs Class


DataTypeCategory Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeCategory Enumeration
DataTypeCategory Enumeration
Category of a DataType / Instance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum DataTypeCategory
VB
Public Enumeration DataTypeCategory
Members
Member name | Value | Description
Unknown | 0 | Uninitialized / NotProcessed (0)
None | 0 | Uninitialized / NotProcessed (0)
Primitive | 1 | Simple / Base Data Type (1)
Alias | 2 | Alias data type (2)
Enum | 3 | Enumeration data type (3)
Array | 4 | Array data type (4)
Struct | 5 | Structure data type (5)
FunctionBlock | 6 | Function block (POU) (6)
Program | 7 | Program (POU) (7)
Function | 8 | Function (POU) (8)
SubRange | 9 | SubRange (9)
String | 10 | Fixed length string (10)
Bitset | 12 | Bitset (12)
Pointer | 13 | Pointer type (13)
Union | 14 | Union type (14)
Reference | 15 | Reference type (15)
Interface | 16 | The interface
Reference
TwinCAT.TypeSystem Namespace


DataTypeCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeCollection Class
DataTypeCollection Class
Collection of DataTypes.
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.Generic.DataTypeCollection.IDataType.
TwinCAT.TypeSystem.DataTypeCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DataTypeCollection : DataTypeCollection<IDataType>
VB
Public Class DataTypeCollection
Inherits DataTypeCollection(Of IDataType)
The DataTypeCollection type exposes the following members.
Constructors
Name | Description
DataTypeCollection. | Initializes a new instance of the DataTypeCollection class.
DataTypeCollection(IEnumerable.IDataType.) | Initializes a new instance of the DataTypeCollection class (Copy constructor).
Properties
Name | Description
Count | Gets the count of contained IDataTypes. (Inherited from DataTypeCollection.T..)
IsReadOnly | Gets a value indicating whether this instance is read only. (Inherited from DataTypeCollection.T..)
Item.Int32. | Gets or sets the IDataType at the specified index. (Inherited from DataTypeCollection.T..)
Item.String. | Gets the IDataType with the specified name. (Inherited from DataTypeCollection.T..)
Methods
Name | Description
Add | Adds the specified item to the collection. (Inherited from DataTypeCollection.T..)
AddRange | Adds a range of types (Inherited from DataTypeCollection.T..)
AsReadOnly | Returns A ReadOnly-Version of the DataTypeCollection.
Clear | Clears the collection. (Inherited from DataTypeCollection.T..)
Clone | Clones this DataTypeCollection (Shallow Copy)
Contains | Determines whether this DataTypeCollection contains the specified IDataType. (Inherited from DataTypeCollection.T..)
ContainsType | Determines whether the container contains the specified IDataType. (Inherited from DataTypeCollection.T..)
CopyTo | Copies the data types to the specified array, starting at the array index. (Inherited from DataTypeCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator. (Inherited from DataTypeCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the Index of the specified IDataType. (Inherited from DataTypeCollection.T..)
Insert | Inserts an IDataType into the DataTypeCollection. (Inherited from DataTypeCollection.T..)
LookupType | Determines the specified IDataType (Inherited from DataTypeCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified IDataType. (Inherited from DataTypeCollection.T..)
RemoveAt | Removes the IDataType object at the specified index. (Inherited from DataTypeCollection.T..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetType | Tries to get the specified IDataType from the IDataTypeContainer.T.. (Inherited from DataTypeCollection.T..)
Fields
Name | Description
list | Internal list of data types (Inherited from DataTypeCollection.T..)
nameDict | Dictionary (Type Name --> DataType) (Inherited from DataTypeCollection.T..)
readOnly | Indicates that the DataTypeCollection.T. is readonly (Inherited from DataTypeCollection.T..)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DataTypeCollection Constructor
•
DataTypeCollection Properties
•
DataTypeCollection Methods
•
DataTypeCollection Fields


DataTypeCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeCollection Class [image] DataTypeCollection Constructor
DataTypeCollection Constructor
Overload List
Name | Description
DataTypeCollection. | Initializes a new instance of the DataTypeCollection class.
DataTypeCollection(IEnumerable.IDataType.) | Initializes a new instance of the DataTypeCollection class (Copy constructor).
Reference
DataTypeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DataTypeCollection Constructor
•
DataTypeCollection Constructor (IEnumerable.IDataType.)


DataTypeCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeCollection Class [image] DataTypeCollection Constructor [image] DataTypeCollection Constructor
DataTypeCollection Constructor
Initializes a new instance of the DataTypeCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeCollection()
VB
Public Sub New
Reference
DataTypeCollection Class
DataTypeCollection Overload
TwinCAT.TypeSystem Namespace


DataTypeCollection Constructor (IEnumerable.IDataType.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeCollection Class [image] DataTypeCollection Constructor [image] DataTypeCollection Constructor (IEnumerable.IDataType.)
DataTypeCollection Constructor (IEnumerable.IDataType.)
Initializes a new instance of the DataTypeCollection class (Copy constructor).
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeCollection(
IEnumerable<IDataType> coll
)
VB
Public Sub New (
coll As IEnumerable(Of IDataType)
)
Parameters
coll
Type: System.Collections.Generic.IEnumerable.IDataType.
The coll.
Reference
DataTypeCollection Class
DataTypeCollection Overload
TwinCAT.TypeSystem Namespace


DataTypeCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeCollection Class [image] DataTypeCollection Properties
DataTypeCollection Properties
The DataTypeCollection type exposes the following members.
Properties
Name | Description
Count | Gets the count of contained IDataTypes. (Inherited from DataTypeCollection.T..)
IsReadOnly | Gets a value indicating whether this instance is read only. (Inherited from DataTypeCollection.T..)
Item.Int32. | Gets or sets the IDataType at the specified index. (Inherited from DataTypeCollection.T..)
Item.String. | Gets the IDataType with the specified name. (Inherited from DataTypeCollection.T..)
Reference
DataTypeCollection Class
TwinCAT.TypeSystem Namespace


DataTypeCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeCollection Class [image] DataTypeCollection Methods
DataTypeCollection Methods
The DataTypeCollection type exposes the following members.
Methods
Name | Description
Add | Adds the specified item to the collection. (Inherited from DataTypeCollection.T..)
AddRange | Adds a range of types (Inherited from DataTypeCollection.T..)
AsReadOnly | Returns A ReadOnly-Version of the DataTypeCollection.
Clear | Clears the collection. (Inherited from DataTypeCollection.T..)
Clone | Clones this DataTypeCollection (Shallow Copy)
Contains | Determines whether this DataTypeCollection contains the specified IDataType. (Inherited from DataTypeCollection.T..)
ContainsType | Determines whether the container contains the specified IDataType. (Inherited from DataTypeCollection.T..)
CopyTo | Copies the data types to the specified array, starting at the array index. (Inherited from DataTypeCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator. (Inherited from DataTypeCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the Index of the specified IDataType. (Inherited from DataTypeCollection.T..)
Insert | Inserts an IDataType into the DataTypeCollection. (Inherited from DataTypeCollection.T..)
LookupType | Determines the specified IDataType (Inherited from DataTypeCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified IDataType. (Inherited from DataTypeCollection.T..)
RemoveAt | Removes the IDataType object at the specified index. (Inherited from DataTypeCollection.T..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetType | Tries to get the specified IDataType from the IDataTypeContainer.T.. (Inherited from DataTypeCollection.T..)
Reference
DataTypeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DataTypeCollection.AsReadOnly Method
•
DataTypeCollection.Clone Method


DataTypeCollection.AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeCollection Class [image] DataTypeCollection Methods [image] DataTypeCollection.AsReadOnly Method
DataTypeCollection.AsReadOnly Method
Returns A ReadOnly-Version of the DataTypeCollection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyDataTypeCollection AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlyDataTypeCollection
Return Value
Type: ReadOnlyDataTypeCollection
A read only version of this DataTypeCollection.
Reference
DataTypeCollection Class
TwinCAT.TypeSystem Namespace


DataTypeCollection.Clone Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeCollection Class [image] DataTypeCollection Methods [image] DataTypeCollection.Clone Method
DataTypeCollection.Clone Method
Clones this DataTypeCollection (Shallow Copy)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeCollection Clone()
VB
Public Function Clone As DataTypeCollection
Return Value
Type: DataTypeCollection
A clone of this DataTypeCollection.
Reference
DataTypeCollection Class
TwinCAT.TypeSystem Namespace


DataTypeCollection Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeCollection Class [image] DataTypeCollection Fields
DataTypeCollection Fields
The DataTypeCollection type exposes the following members.
Fields
Name | Description
list | Internal list of data types (Inherited from DataTypeCollection.T..)
nameDict | Dictionary (Type Name --> DataType) (Inherited from DataTypeCollection.T..)
readOnly | Indicates that the DataTypeCollection.T. is readonly (Inherited from DataTypeCollection.T..)
Reference
DataTypeCollection Class
TwinCAT.TypeSystem Namespace


DataTypeEventArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeEventArgs Class
DataTypeEventArgs Class
Class DataTypeEventArgs.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.TypeSystem.DataTypeEventArgs
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DataTypeEventArgs : EventArgs
VB
Public Class DataTypeEventArgs
Inherits EventArgs
The DataTypeEventArgs type exposes the following members.
Constructors
Name | Description
DataTypeEventArgs | Initializes a new instance of the DataTypeEventArgs class.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
DataTypes | The data types
Reference
TwinCAT.TypeSystem Namespace
System.EventArgs
Weiterführende Informationen
•
DataTypeEventArgs Constructor
•
DataTypeEventArgs Methods
•
DataTypeEventArgs Fields


DataTypeEventArgs Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeEventArgs Class [image] DataTypeEventArgs Constructor
DataTypeEventArgs Constructor
Initializes a new instance of the DataTypeEventArgs class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeEventArgs(
IEnumerable<IDataType> types
)
VB
Public Sub New (
types As IEnumerable(Of IDataType)
)
Parameters
types
Type: System.Collections.Generic.IEnumerable.IDataType.
The types.
Reference
DataTypeEventArgs Class
TwinCAT.TypeSystem Namespace


DataTypeEventArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeEventArgs Class [image] DataTypeEventArgs Methods
DataTypeEventArgs Methods
The DataTypeEventArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
DataTypeEventArgs Class
TwinCAT.TypeSystem Namespace


DataTypeEventArgs Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeEventArgs Class [image] DataTypeEventArgs Fields
DataTypeEventArgs Fields
The DataTypeEventArgs type exposes the following members.
Fields
Name | Description
DataTypes | The data types
Reference
DataTypeEventArgs Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DataTypeEventArgs.DataTypes Field


DataTypeEventArgs.DataTypes Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeEventArgs Class [image] DataTypeEventArgs Fields [image] DataTypeEventArgs.DataTypes Field
DataTypeEventArgs.DataTypes Field
The data types
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly IEnumerable<IDataType> DataTypes
VB
Public ReadOnly DataTypes As IEnumerable(Of IDataType)
Field Value
Type: IEnumerable.IDataType.
Reference
DataTypeEventArgs Class
TwinCAT.TypeSystem Namespace


DataTypeException Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeException Class
DataTypeException Class
Data Type Exception
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.TypeSystem.DataTypeException
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class DataTypeException : AdsException
VB
<SerializableAttribute>
Public Class DataTypeException
Inherits AdsException
The DataTypeException type exposes the following members.
Constructors
Name | Description
DataTypeException | Initializes a new instance of the DataTypeException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Fields
Name | Description
DataType | The data type
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DataTypeException Constructor
•
DataTypeException Properties
•
DataTypeException Methods
•
DataTypeException Events
•
DataTypeException Fields


DataTypeException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeException Class [image] DataTypeException Constructor
DataTypeException Constructor
Initializes a new instance of the DataTypeException class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeException(
string message,
IDataType type
)
VB
Public Sub New (
message As String,
type As IDataType
)
Parameters
message | Type: System.String The message.
type | Type: TwinCAT.TypeSystem.IDataType The type.
Reference
DataTypeException Class
TwinCAT.TypeSystem Namespace


DataTypeException Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeException Class [image] DataTypeException Properties
DataTypeException Properties
The DataTypeException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
DataTypeException Class
TwinCAT.TypeSystem Namespace


DataTypeException Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeException Class [image] DataTypeException Methods
DataTypeException Methods
The DataTypeException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
DataTypeException Class
TwinCAT.TypeSystem Namespace


DataTypeException Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeException Class [image] DataTypeException Events
DataTypeException Events
The DataTypeException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
DataTypeException Class
TwinCAT.TypeSystem Namespace


DataTypeException Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeException Class [image] DataTypeException Fields
DataTypeException Fields
The DataTypeException type exposes the following members.
Fields
Name | Description
DataType | The data type
Reference
DataTypeException Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DataTypeException.DataType Field


DataTypeException.DataType Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeException Class [image] DataTypeException Fields [image] DataTypeException.DataType Field
DataTypeException.DataType Field
The data type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[NonSerializedAttribute]
public readonly IDataType DataType
VB
<NonSerializedAttribute>
Public ReadOnly DataType As IDataType
Field Value
Type: IDataType
Reference
DataTypeException Class
TwinCAT.TypeSystem Namespace


DataTypeNameEventArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeNameEventArgs Class
DataTypeNameEventArgs Class
Class DataTypeNameEventArgs.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.TypeSystem.DataTypeNameEventArgs
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DataTypeNameEventArgs : EventArgs
VB
Public Class DataTypeNameEventArgs
Inherits EventArgs
The DataTypeNameEventArgs type exposes the following members.
Constructors
Name | Description
DataTypeNameEventArgs | Initializes a new instance of the DataTypeNameEventArgs class.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
TypeName | The type name
Reference
TwinCAT.TypeSystem Namespace
System.EventArgs
Weiterführende Informationen
•
DataTypeNameEventArgs Constructor
•
DataTypeNameEventArgs Methods
•
DataTypeNameEventArgs Fields


DataTypeNameEventArgs Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeNameEventArgs Class [image] DataTypeNameEventArgs Constructor
DataTypeNameEventArgs Constructor
Initializes a new instance of the DataTypeNameEventArgs class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeNameEventArgs(
string typeName
)
VB
Public Sub New (
typeName As String
)
Parameters
typeName
Type: System.String
Name of the type.
Reference
DataTypeNameEventArgs Class
TwinCAT.TypeSystem Namespace


DataTypeNameEventArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeNameEventArgs Class [image] DataTypeNameEventArgs Methods
DataTypeNameEventArgs Methods
The DataTypeNameEventArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
DataTypeNameEventArgs Class
TwinCAT.TypeSystem Namespace


DataTypeNameEventArgs Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeNameEventArgs Class [image] DataTypeNameEventArgs Fields
DataTypeNameEventArgs Fields
The DataTypeNameEventArgs type exposes the following members.
Fields
Name | Description
TypeName | The type name
Reference
DataTypeNameEventArgs Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DataTypeNameEventArgs.TypeName Field


DataTypeNameEventArgs.TypeName Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DataTypeNameEventArgs Class [image] DataTypeNameEventArgs Fields [image] DataTypeNameEventArgs.TypeName Field
DataTypeNameEventArgs.TypeName Field
The type name
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly string TypeName
VB
Public ReadOnly TypeName As String
Field Value
Type: String
Reference
DataTypeNameEventArgs Class
TwinCAT.TypeSystem Namespace


Dimension Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] Dimension Class
Dimension Class
Represents a single dimension of an IArrayType
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.Dimension
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class Dimension : IDimension
VB
Public Class Dimension
Implements IDimension
The Dimension type exposes the following members.
Properties
Name | Description
ElementCount | Gets the number of elements within that IDimension.
LowerBound | Gets the lower bound of elements within that IDimension.
UpperBound | Gets the upper bound of elements within this Dimension
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
Dimension Properties
•
Dimension Methods


Dimension Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] Dimension Class [image] Dimension Properties
Dimension Properties
The Dimension type exposes the following members.
Properties
Name | Description
ElementCount | Gets the number of elements within that IDimension.
LowerBound | Gets the lower bound of elements within that IDimension.
UpperBound | Gets the upper bound of elements within this Dimension
Reference
Dimension Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
Dimension.ElementCount Property
•
Dimension.LowerBound Property
•
Dimension.UpperBound Property


Dimension.ElementCount Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] Dimension Class [image] Dimension Properties [image] Dimension.ElementCount Property
Dimension.ElementCount Property
Gets the number of elements within that IDimension.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ElementCount { get; }
VB
Public ReadOnly Property ElementCount As Integer
Get
Property Value
Type: Int32
The element count.
Implements
IDimension.ElementCount
Reference
Dimension Class
TwinCAT.TypeSystem Namespace


Dimension.LowerBound Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] Dimension Class [image] Dimension Properties [image] Dimension.LowerBound Property
Dimension.LowerBound Property
Gets the lower bound of elements within that IDimension.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int LowerBound { get; }
VB
Public ReadOnly Property LowerBound As Integer
Get
Property Value
Type: Int32
The lower bound.
Implements
IDimension.LowerBound
Reference
Dimension Class
TwinCAT.TypeSystem Namespace


Dimension.UpperBound Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] Dimension Class [image] Dimension Properties [image] Dimension.UpperBound Property
Dimension.UpperBound Property
Gets the upper bound of elements within this Dimension
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int UpperBound { get; }
VB
Public ReadOnly Property UpperBound As Integer
Get
Property Value
Type: Int32
The upper bound.
Reference
Dimension Class
TwinCAT.TypeSystem Namespace


Dimension Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] Dimension Class [image] Dimension Methods
Dimension Methods
The Dimension type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
Dimension Class
TwinCAT.TypeSystem Namespace


DimensionCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class
DimensionCollection Class
Collection class for Array Dimensions
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.DimensionCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DimensionCollection : IDimensionCollection,
IList<IDimension>, ICollection<IDimension>, IEnumerable<IDimension>,
IEnumerable
VB
Public Class DimensionCollection
Implements IDimensionCollection, IList(Of IDimension),
ICollection(Of IDimension), IEnumerable(Of IDimension), IEnumerable
The DimensionCollection type exposes the following members.
Constructors
Name | Description
DimensionCollection. | Initializes a new instance of the DimensionCollection class.
DimensionCollection(Int32) | Initializes a new instance of an 1-Dimensional representing DimensionCollection class.
DimensionCollection(.Int32.) | Initializes a new instance of the DimensionCollection class.
DimensionCollection(IEnumerable.IDimension.) | Initializes a new instance of the DimensionCollection class.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
ElementCount | Gets the Number of elements in all Dimensions
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item | Gets or sets the element at the specified index.
LowerBounds | Gets the lower bounds.
UpperBounds | Gets the upper bounds.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Returns a read only version of this DimensionCollection.
Clear | Removes all items from the ICollection.T..
Contains | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDimensionLengths | Gets an array the specifies the Lengths of each Array Dimension
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DimensionCollection Constructor
•
DimensionCollection Properties
•
DimensionCollection Methods


DimensionCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Constructor
DimensionCollection Constructor
Overload List
Name | Description
DimensionCollection. | Initializes a new instance of the DimensionCollection class.
DimensionCollection(Int32) | Initializes a new instance of an 1-Dimensional representing DimensionCollection class.
DimensionCollection(.Int32.) | Initializes a new instance of the DimensionCollection class.
DimensionCollection(IEnumerable.IDimension.) | Initializes a new instance of the DimensionCollection class.
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DimensionCollection Constructor
•
DimensionCollection Constructor (Int32)
•
DimensionCollection Constructor (.Int32.)
•
DimensionCollection Constructor (IEnumerable.IDimension.)


DimensionCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Constructor [image] DimensionCollection Constructor
DimensionCollection Constructor
Initializes a new instance of the DimensionCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DimensionCollection()
VB
Public Sub New
Reference
DimensionCollection Class
DimensionCollection Overload
TwinCAT.TypeSystem Namespace


DimensionCollection Constructor (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Constructor [image] DimensionCollection Constructor (Int32)
DimensionCollection Constructor (Int32)
Initializes a new instance of an 1-Dimensional representing DimensionCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DimensionCollection(
int length
)
VB
Public Sub New (
length As Integer
)
Parameters
length
Type: System.Int32
The length.
Reference
DimensionCollection Class
DimensionCollection Overload
TwinCAT.TypeSystem Namespace


DimensionCollection Constructor (.Int32.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Constructor [image] DimensionCollection Constructor (.Int32.)
DimensionCollection Constructor (.Int32.)
Initializes a new instance of the DimensionCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DimensionCollection(
int[] dimLengths
)
VB
Public Sub New (
dimLengths As Integer()
)
Parameters
dimLengths
Type: .System.Int32.
The dim lengths.
Reference
DimensionCollection Class
DimensionCollection Overload
TwinCAT.TypeSystem Namespace


DimensionCollection Constructor (IEnumerable.IDimension.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Constructor [image] DimensionCollection Constructor (IEnumerable.IDimension.)
DimensionCollection Constructor (IEnumerable.IDimension.)
Initializes a new instance of the DimensionCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DimensionCollection(
IEnumerable<IDimension> coll
)
VB
Public Sub New (
coll As IEnumerable(Of IDimension)
)
Parameters
coll
Type: System.Collections.Generic.IEnumerable.IDimension.
The coll.
Reference
DimensionCollection Class
DimensionCollection Overload
TwinCAT.TypeSystem Namespace


DimensionCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Properties
DimensionCollection Properties
The DimensionCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
ElementCount | Gets the Number of elements in all Dimensions
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item | Gets or sets the element at the specified index.
LowerBounds | Gets the lower bounds.
UpperBounds | Gets the upper bounds.
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DimensionCollection.Count Property
•
DimensionCollection.ElementCount Property
•
DimensionCollection.IsReadOnly Property
•
DimensionCollection.Item Property
•
DimensionCollection.LowerBounds Property
•
DimensionCollection.UpperBounds Property


DimensionCollection.Count Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Properties [image] DimensionCollection.Count Property
DimensionCollection.Count Property
Gets the number of elements contained in the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Count { get; }
VB
Public ReadOnly Property Count As Integer
Get
Property Value
Type: Int32
The count.
Implements
ICollection.T..Count
Exceptions
Exception | Condition
NotImplementedException |
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.ElementCount Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Properties [image] DimensionCollection.ElementCount Property
DimensionCollection.ElementCount Property
Gets the Number of elements in all Dimensions
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ElementCount { get; }
VB
Public ReadOnly Property ElementCount As Integer
Get
Property Value
Type: Int32
Implements
IDimensionCollection.ElementCount
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Properties [image] DimensionCollection.IsReadOnly Property
DimensionCollection.IsReadOnly Property
Gets a value indicating whether the ICollection.T. is read-only.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if this instance is read only; otherwise, false.
Implements
ICollection.T..IsReadOnly
Exceptions
Exception | Condition
NotImplementedException |
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Properties [image] DimensionCollection.Item Property
DimensionCollection.Item Property
Gets or sets the element at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDimension this[
int index
] { get; set; }
VB
Public Default Property Item (
index As Integer
) As IDimension
Get
Set
Parameters
index
Type: System.Int32
The index.
Return Value
Type: IDimension
IDimension.
Implements
IList.T..Item.Int32.
Exceptions
Exception | Condition
NotImplementedException |
Remarks
Index = 0 is the lowest dimesion.
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.LowerBounds Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Properties [image] DimensionCollection.LowerBounds Property
DimensionCollection.LowerBounds Property
Gets the lower bounds.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int[] LowerBounds { get; }
VB
Public ReadOnly Property LowerBounds As Integer()
Get
Property Value
Type: .Int32.
The lower bounds.
Implements
IDimensionCollection.LowerBounds
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.UpperBounds Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Properties [image] DimensionCollection.UpperBounds Property
DimensionCollection.UpperBounds Property
Gets the upper bounds.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int[] UpperBounds { get; }
VB
Public ReadOnly Property UpperBounds As Integer()
Get
Property Value
Type: .Int32.
The upper bounds.
Implements
IDimensionCollection.UpperBounds
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods
DimensionCollection Methods
The DimensionCollection type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Returns a read only version of this DimensionCollection.
Clear | Removes all items from the ICollection.T..
Contains | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDimensionLengths | Gets an array the specifies the Lengths of each Array Dimension
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DimensionCollection.Add Method
•
DimensionCollection.AsReadOnly Method
•
DimensionCollection.Clear Method
•
DimensionCollection.Contains Method
•
DimensionCollection.CopyTo Method
•
DimensionCollection.GetDimensionLengths Method
•
DimensionCollection.GetEnumerator Method
•
DimensionCollection.IndexOf Method
•
DimensionCollection.Insert Method
•
DimensionCollection.Remove Method
•
DimensionCollection.RemoveAt Method


DimensionCollection.Add Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods [image] DimensionCollection.Add Method
DimensionCollection.Add Method
Adds an item to the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Add(
IDimension item
)
VB
Public Sub Add (
item As IDimension
)
Parameters
item
Type: TwinCAT.TypeSystem.IDimension
The object to add to the ICollection.T..
Implements
ICollection.T..Add(T)
Exceptions
Exception | Condition
NotImplementedException |
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods [image] DimensionCollection.AsReadOnly Method
DimensionCollection.AsReadOnly Method
Returns a read only version of this DimensionCollection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyDimensionCollection AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlyDimensionCollection
Field Value
Type: ReadOnlyDimensionCollection
As read only.
Return Value
Type: ReadOnlyDimensionCollection
ReadOnlyDimensionCollection.
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.Clear Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods [image] DimensionCollection.Clear Method
DimensionCollection.Clear Method
Removes all items from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Clear()
VB
Public Sub Clear
Implements
ICollection.T..Clear.
Exceptions
Exception | Condition
NotImplementedException |
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods [image] DimensionCollection.Contains Method
DimensionCollection.Contains Method
Determines whether the ICollection.T. contains a specific value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
IDimension item
)
VB
Public Function Contains (
item As IDimension
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.IDimension
The object to locate in the ICollection.T..
Return Value
Type: Boolean
true if item is found in the ICollection.T.; otherwise, false.
Implements
ICollection.T..Contains(T)
Exceptions
Exception | Condition
NotImplementedException |
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.CopyTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods [image] DimensionCollection.CopyTo Method
DimensionCollection.CopyTo Method
Copies to.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void CopyTo(
IDimension[] array,
int arrayIndex
)
VB
Public Sub CopyTo (
array As IDimension(),
arrayIndex As Integer
)
Parameters
array | Type: .TwinCAT.TypeSystem.IDimension. The array.
arrayIndex | Type: System.Int32 Index of the array.
Implements
ICollection.T..CopyTo(.T., Int32)
Exceptions
Exception | Condition
NotImplementedException |
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.GetDimensionLengths Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods [image] DimensionCollection.GetDimensionLengths Method
DimensionCollection.GetDimensionLengths Method
Gets an array the specifies the Lengths of each Array Dimension
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int[] GetDimensionLengths()
VB
Public Function GetDimensionLengths As Integer()
Return Value
Type: .Int32.
System.Int32[].
Implements
IDimensionCollection.GetDimensionLengths.
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods [image] DimensionCollection.GetEnumerator Method
DimensionCollection.GetEnumerator Method
Returns an enumerator that iterates through the collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<IDimension> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of IDimension)
Return Value
Type: IEnumerator.IDimension.
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Exceptions
Exception | Condition
NotImplementedException |
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.IndexOf Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods [image] DimensionCollection.IndexOf Method
DimensionCollection.IndexOf Method
Determines the index of a specific item in the IList.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int IndexOf(
IDimension item
)
VB
Public Function IndexOf (
item As IDimension
) As Integer
Parameters
item
Type: TwinCAT.TypeSystem.IDimension
The object to locate in the IList.T..
Return Value
Type: Int32
The index of item if found in the list; otherwise, -1.
Implements
IList.T..IndexOf(T)
Exceptions
Exception | Condition
NotImplementedException |
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.Insert Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods [image] DimensionCollection.Insert Method
DimensionCollection.Insert Method
Inserts an item to the IList.T. at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Insert(
int index,
IDimension item
)
VB
Public Sub Insert (
index As Integer,
item As IDimension
)
Parameters
index | Type: System.Int32 The zero-based index at which item should be inserted.
item | Type: TwinCAT.TypeSystem.IDimension The object to insert into the IList.T..
Implements
IList.T..Insert(Int32, T)
Exceptions
Exception | Condition
NotImplementedException |
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.Remove Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods [image] DimensionCollection.Remove Method
DimensionCollection.Remove Method
Removes the first occurrence of a specific object from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Remove(
IDimension item
)
VB
Public Function Remove (
item As IDimension
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.IDimension
The object to remove from the ICollection.T..
Return Value
Type: Boolean
true if item was successfully removed from the ICollection.T.; otherwise, false. This method also returns false if item is not found in the original ICollection.T..
Implements
ICollection.T..Remove(T)
Exceptions
Exception | Condition
NotImplementedException |
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DimensionCollection.RemoveAt Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DimensionCollection Class [image] DimensionCollection Methods [image] DimensionCollection.RemoveAt Method
DimensionCollection.RemoveAt Method
Removes the IList.T. item at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void RemoveAt(
int index
)
VB
Public Sub RemoveAt (
index As Integer
)
Parameters
index
Type: System.Int32
The zero-based index of the item to remove.
Implements
IList.T..RemoveAt(Int32)
Exceptions
Exception | Condition
NotImplementedException |
Reference
DimensionCollection Class
TwinCAT.TypeSystem Namespace


DynamicAliasInstance Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicAliasInstance Class
DynamicAliasInstance Class
Class DynamicAliasInstance. This class cannot be inherited.
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.DynamicAliasInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class DynamicAliasInstance : DynamicSymbol,
IAliasInstance, ISymbol, IAttributedInstance, IInstance, IBitSize
VB
Public NotInheritable Class DynamicAliasInstance
Inherits DynamicSymbol
Implements IAliasInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize
The DynamicAliasInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicSymbol.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Overrides DynamicObject.TryGetIndex(GetIndexBinder, .Object., Object.).)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicSymbol.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Overrides DynamicObject.TrySetIndex(SetIndexBinder, .Object., Object).)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicObject.TrySetMember(SetMemberBinder, Object).)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.IAliasInstance
Weiterführende Informationen
•
DynamicAliasInstance Properties
•
DynamicAliasInstance Methods
•
DynamicAliasInstance Events


DynamicAliasInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicAliasInstance Class [image] DynamicAliasInstance Properties
DynamicAliasInstance Properties
The DynamicAliasInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Reference
DynamicAliasInstance Class
TwinCAT.TypeSystem Namespace


DynamicAliasInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicAliasInstance Class [image] DynamicAliasInstance Methods
DynamicAliasInstance Methods
The DynamicAliasInstance type exposes the following members.
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicSymbol.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Overrides DynamicObject.TryGetIndex(GetIndexBinder, .Object., Object.).)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicSymbol.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Overrides DynamicObject.TrySetIndex(SetIndexBinder, .Object., Object).)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicObject.TrySetMember(SetMemberBinder, Object).)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Reference
DynamicAliasInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicAliasInstance.GetDynamicMemberNames Method
•
DynamicAliasInstance.TryGetIndex Method
•
DynamicAliasInstance.TryGetMember Method
•
DynamicAliasInstance.TrySetIndex Method
•
DynamicAliasInstance.TrySetMember Method


DynamicAliasInstance.GetDynamicMemberNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicAliasInstance Class [image] DynamicAliasInstance Methods [image] DynamicAliasInstance.GetDynamicMemberNames Method
DynamicAliasInstance.GetDynamicMemberNames Method
Returns the enumeration of all dynamic member names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override IEnumerable<string> GetDynamicMemberNames()
VB
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
Return Value
Type: IEnumerable.String.
A sequence that contains dynamic member names.
Reference
DynamicAliasInstance Class
TwinCAT.TypeSystem Namespace


DynamicAliasInstance.TryGetIndex Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicAliasInstance Class [image] DynamicAliasInstance Methods [image] DynamicAliasInstance.TryGetIndex Method
DynamicAliasInstance.TryGetIndex Method
Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetIndex(
GetIndexBinder binder,
Object[] indexes,
out Object result
)
VB
Public Overrides Function TryGetIndex (
binder As GetIndexBinder,
indexes As Object(),
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetIndexBinder Provides information about the operation.
indexes | Type: .System.Object. The indexes that are used in the operation. For example, for the sampleObject[3] operation in C# (sampleObject(3) in Visual Basic), where sampleObject is derived from the DynamicObject class, indexes[0] is equal to 3.
result | Type: System.Object. The result of the index operation.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicAliasInstance Class
TwinCAT.TypeSystem Namespace


DynamicAliasInstance.TryGetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicAliasInstance Class [image] DynamicAliasInstance Methods [image] DynamicAliasInstance.TryGetMember Method
DynamicAliasInstance.TryGetMember Method
Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetMember(
GetMemberBinder binder,
out Object result
)
VB
Public Overrides Function TryGetMember (
binder As GetMemberBinder,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member on which the dynamic operation is performed. For example, for the Console.WriteLine(sampleObject.SampleProperty) statement, where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
result | Type: System.Object. The result of the get operation. For example, if the method is called for a property, you can assign the property value to result.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicAliasInstance Class
TwinCAT.TypeSystem Namespace


DynamicAliasInstance.TrySetIndex Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicAliasInstance Class [image] DynamicAliasInstance Methods [image] DynamicAliasInstance.TrySetIndex Method
DynamicAliasInstance.TrySetIndex Method
Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TrySetIndex(
SetIndexBinder binder,
Object[] indexes,
Object value
)
VB
Public Overrides Function TrySetIndex (
binder As SetIndexBinder,
indexes As Object(),
value As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.SetIndexBinder Provides information about the operation.
indexes | Type: .System.Object. The indexes that are used in the operation. For example, for the sampleObject[3] = 10 operation in C# (sampleObject(3) = 10 in Visual Basic), where sampleObject is derived from the DynamicObject class, indexes[][] is equal to 3.
value | Type: System.Object The value to set to the object that has the specified index. For example, for the sampleObject[3] = 10 operation in C# (sampleObject(3) = 10 in Visual Basic), where sampleObject is derived from the DynamicObject class, value is equal to 10.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.
Reference
DynamicAliasInstance Class
TwinCAT.TypeSystem Namespace


DynamicAliasInstance.TrySetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicAliasInstance Class [image] DynamicAliasInstance Methods [image] DynamicAliasInstance.TrySetMember Method
DynamicAliasInstance.TrySetMember Method
Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TrySetMember(
SetMemberBinder binder,
Object value
)
VB
Public Overrides Function TrySetMember (
binder As SetMemberBinder,
value As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.SetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member to which the value is being assigned. For example, for the statement sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
value | Type: System.Object The value to set to the member. For example, for sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, the value is "Test".
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.)
Reference
DynamicAliasInstance Class
TwinCAT.TypeSystem Namespace


DynamicAliasInstance Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicAliasInstance Class [image] DynamicAliasInstance Events
DynamicAliasInstance Events
The DynamicAliasInstance type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
DynamicAliasInstance Class
TwinCAT.TypeSystem Namespace


DynamicArrayInstance Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class
DynamicArrayInstance Class
Dynamic Array Instance
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.DynamicArrayInstance
TwinCAT.TypeSystem.DynamicOversamplingArrayInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DynamicArrayInstance : DynamicSymbol,
IArrayInstance, ISymbol, IAttributedInstance, IInstance, IBitSize
VB
Public Class DynamicArrayInstance
Inherits DynamicSymbol
Implements IArrayInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize
The DynamicArrayInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
Dimensions | Gets the dimensions as read only collection.
Elements | Gets the contained Array Elements as read only collection.
ElementType | Gets the type of the contained elements.
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
Item | Gets the ISymbol with the specified indices.
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Inherited from DynamicSymbol.)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnReadAnyValue | Handler function for reading ADS 'Any' Values. (Inherited from DynamicSymbol.)
OnReadRawValue | Handler function for reading Raw symbol value. (Inherited from DynamicSymbol.)
OnReadValue | Handler function for the (Inherited from DynamicSymbol.)
OnSetInstanceName | Sets a new InstanceName InstancePath (Inherited from DynamicSymbol.)
OnTryReadValue | Handler function for the (Inherited from DynamicSymbol.)
OnTryWriteValue | Handler Function for writing value. (Inherited from DynamicSymbol.)
OnWriteRawValue | Handler function for reading symbols raw value. (Inherited from DynamicSymbol.)
OnWriteValue | Handler Function for writing value. (Inherited from DynamicSymbol.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetElement(IList..Int32.., ISymbol.) | Tries to get the array element with the specified indices (jagged array support).
TryGetElement(.Int32., ISymbol.) | Tries to get the array element
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Overrides DynamicObject.TryGetIndex(GetIndexBinder, .Object., Object.).)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Inherited from DynamicSymbol.)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Overrides DynamicObject.TrySetIndex(SetIndexBinder, .Object., Object).)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicObject.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Fields
Name | Description
normalizedName | The normalized name of this . (Inherited from DynamicSymbol.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicArrayInstance Properties
•
DynamicArrayInstance Methods
•
DynamicArrayInstance Events
•
DynamicArrayInstance Fields


DynamicArrayInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Properties
DynamicArrayInstance Properties
The DynamicArrayInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
Dimensions | Gets the dimensions as read only collection.
Elements | Gets the contained Array Elements as read only collection.
ElementType | Gets the type of the contained elements.
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
Item | Gets the ISymbol with the specified indices.
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Reference
DynamicArrayInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicArrayInstance.Dimensions Property
•
DynamicArrayInstance.Elements Property
•
DynamicArrayInstance.ElementType Property
•
DynamicArrayInstance.Item Property


DynamicArrayInstance.Dimensions Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Properties [image] DynamicArrayInstance.Dimensions Property
DynamicArrayInstance.Dimensions Property
Gets the dimensions as read only collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyDimensionCollection Dimensions { get; }
VB
Public ReadOnly Property Dimensions As ReadOnlyDimensionCollection
Get
Property Value
Type: ReadOnlyDimensionCollection
The dimensions.
Implements
IArrayInstance.Dimensions
Reference
DynamicArrayInstance Class
TwinCAT.TypeSystem Namespace


DynamicArrayInstance.Elements Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Properties [image] DynamicArrayInstance.Elements Property
DynamicArrayInstance.Elements Property
Gets the contained Array Elements as read only collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySymbolCollection Elements { get; }
VB
Public ReadOnly Property Elements As ReadOnlySymbolCollection
Get
Property Value
Type: ReadOnlySymbolCollection
The elements.
Implements
IArrayInstance.Elements
Reference
DynamicArrayInstance Class
TwinCAT.TypeSystem Namespace


DynamicArrayInstance.ElementType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Properties [image] DynamicArrayInstance.ElementType Property
DynamicArrayInstance.ElementType Property
Gets the type of the contained elements.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType ElementType { get; }
VB
Public ReadOnly Property ElementType As IDataType
Get
Property Value
Type: IDataType
The type of the element.
Implements
IArrayInstance.ElementType
Reference
DynamicArrayInstance Class
TwinCAT.TypeSystem Namespace


DynamicArrayInstance.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Properties [image] DynamicArrayInstance.Item Property
DynamicArrayInstance.Item Property
Gets the ISymbol with the specified indices.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ISymbol this[
int[] indices
] { get; }
VB
Public ReadOnly Default Property Item (
indices As Integer()
) As ISymbol
Get
Parameters
indices
Type: .System.Int32.
The indices.
Return Value
Type: ISymbol
ISymbol.
Implements
IArrayInstance.Item..Int32..
Exceptions
Exception | Condition
ArgumentOutOfRangeException | indices
Reference
DynamicArrayInstance Class
TwinCAT.TypeSystem Namespace


DynamicArrayInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Methods
DynamicArrayInstance Methods
The DynamicArrayInstance type exposes the following members.
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Inherited from DynamicSymbol.)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnReadAnyValue | Handler function for reading ADS 'Any' Values. (Inherited from DynamicSymbol.)
OnReadRawValue | Handler function for reading Raw symbol value. (Inherited from DynamicSymbol.)
OnReadValue | Handler function for the (Inherited from DynamicSymbol.)
OnSetInstanceName | Sets a new InstanceName InstancePath (Inherited from DynamicSymbol.)
OnTryReadValue | Handler function for the (Inherited from DynamicSymbol.)
OnTryWriteValue | Handler Function for writing value. (Inherited from DynamicSymbol.)
OnWriteRawValue | Handler function for reading symbols raw value. (Inherited from DynamicSymbol.)
OnWriteValue | Handler Function for writing value. (Inherited from DynamicSymbol.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetElement(IList..Int32.., ISymbol.) | Tries to get the array element with the specified indices (jagged array support).
TryGetElement(.Int32., ISymbol.) | Tries to get the array element
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Overrides DynamicObject.TryGetIndex(GetIndexBinder, .Object., Object.).)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Inherited from DynamicSymbol.)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Overrides DynamicObject.TrySetIndex(SetIndexBinder, .Object., Object).)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicObject.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Reference
DynamicArrayInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicArrayInstance.TryGetElement Method
•
DynamicArrayInstance.TryGetIndex Method
•
DynamicArrayInstance.TrySetIndex Method


DynamicArrayInstance.TryGetElement Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Methods [image] DynamicArrayInstance.TryGetElement Method
DynamicArrayInstance.TryGetElement Method
Overload List
Name | Description
TryGetElement(IList..Int32.., ISymbol.) | Tries to get the array element with the specified indices (jagged array support).
TryGetElement(.Int32., ISymbol.) | Tries to get the array element
Reference
DynamicArrayInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicArrayInstance.TryGetElement Method (IList..Int32.., ISymbol.)
•
DynamicArrayInstance.TryGetElement Method (.Int32., ISymbol.)


DynamicArrayInstance.TryGetElement Method (IList..Int32.., ISymbol.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Methods [image] DynamicArrayInstance.TryGetElement Method [image] DynamicArrayInstance.TryGetElement Method (IList..Int32.., ISymbol.)
DynamicArrayInstance.TryGetElement Method (IList..Int32.., ISymbol.)
Tries to get the array element with the specified indices (jagged array support).
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetElement(
IList<int[]> jaggedIndices,
out ISymbol symbol
)
VB
Public Function TryGetElement (
jaggedIndices As IList(Of Integer()),
<OutAttribute> ByRef symbol As ISymbol
) As Boolean
Parameters
jaggedIndices | Type: System.Collections.Generic.IList..Int32.. The jagged indices list.
symbol | Type: TwinCAT.TypeSystem.ISymbol. The symbol.
Return Value
Type: Boolean
true if found, false if the jagged indices specifiers is out-of-range.
Implements
IArrayInstance.TryGetElement(IList..Int32.., ISymbol.)
Exceptions
Exception | Condition
ArgumentNullException | jaggedIndices
ArgumentOutOfRangeException | jaggedIndices
Reference
DynamicArrayInstance Class
TryGetElement Overload
TwinCAT.TypeSystem Namespace


DynamicArrayInstance.TryGetElement Method (.Int32., ISymbol.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Methods [image] DynamicArrayInstance.TryGetElement Method [image] DynamicArrayInstance.TryGetElement Method (.Int32., ISymbol.)
DynamicArrayInstance.TryGetElement Method (.Int32., ISymbol.)
Tries to get the array element
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetElement(
int[] indices,
out ISymbol symbol
)
VB
Public Function TryGetElement (
indices As Integer(),
<OutAttribute> ByRef symbol As ISymbol
) As Boolean
Parameters
indices | Type: .System.Int32. The indices.
symbol | Type: TwinCAT.TypeSystem.ISymbol. The found Array element symbol (out-parameter).
Return Value
Type: Boolean
true if found, false if the indices specifiers is out-of-range.
Implements
IArrayInstance.TryGetElement(.Int32., ISymbol.)
Reference
DynamicArrayInstance Class
TryGetElement Overload
TwinCAT.TypeSystem Namespace


DynamicArrayInstance.TryGetIndex Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Methods [image] DynamicArrayInstance.TryGetIndex Method
DynamicArrayInstance.TryGetIndex Method
Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetIndex(
GetIndexBinder binder,
Object[] indexes,
out Object result
)
VB
Public Overrides Function TryGetIndex (
binder As GetIndexBinder,
indexes As Object(),
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetIndexBinder Provides information about the operation.
indexes | Type: .System.Object. The indexes that are used in the operation. For example, for the sampleObject[3] operation in C# (sampleObject(3) in Visual Basic), where sampleObject is derived from the DynamicObject class, indexes[0] is equal to 3.
result | Type: System.Object. The result of the index operation.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicArrayInstance Class
TwinCAT.TypeSystem Namespace


DynamicArrayInstance.TrySetIndex Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Methods [image] DynamicArrayInstance.TrySetIndex Method
DynamicArrayInstance.TrySetIndex Method
Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TrySetIndex(
SetIndexBinder binder,
Object[] indexes,
Object value
)
VB
Public Overrides Function TrySetIndex (
binder As SetIndexBinder,
indexes As Object(),
value As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.SetIndexBinder Provides information about the operation.
indexes | Type: .System.Object. The indexes that are used in the operation. For example, for the sampleObject[3] = 10 operation in C# (sampleObject(3) = 10 in Visual Basic), where sampleObject is derived from the DynamicObject class, indexes[][] is equal to 3.
value | Type: System.Object The value to set to the object that has the specified index. For example, for the sampleObject[3] = 10 operation in C# (sampleObject(3) = 10 in Visual Basic), where sampleObject is derived from the DynamicObject class, value is equal to 10.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.
Reference
DynamicArrayInstance Class
TwinCAT.TypeSystem Namespace


DynamicArrayInstance Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Events
DynamicArrayInstance Events
The DynamicArrayInstance type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
DynamicArrayInstance Class
TwinCAT.TypeSystem Namespace


DynamicArrayInstance Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicArrayInstance Class [image] DynamicArrayInstance Fields
DynamicArrayInstance Fields
The DynamicArrayInstance type exposes the following members.
Fields
Name | Description
normalizedName | The normalized name of this . (Inherited from DynamicSymbol.)
Reference
DynamicArrayInstance Class
TwinCAT.TypeSystem Namespace


DynamicOversamplingArrayInstance Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicOversamplingArrayInstance Class
DynamicOversamplingArrayInstance Class
Dynamic Array Instance
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.DynamicArrayInstance
TwinCAT.TypeSystem.DynamicOversamplingArrayInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class DynamicOversamplingArrayInstance : DynamicArrayInstance,
IOversamplingArrayInstance, IArrayInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize
VB
Public NotInheritable Class DynamicOversamplingArrayInstance
Inherits DynamicArrayInstance
Implements IOversamplingArrayInstance, IArrayInstance, ISymbol, IAttributedInstance,
IInstance, IBitSize
The DynamicOversamplingArrayInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
Dimensions | Gets the dimensions as read only collection. (Inherited from DynamicArrayInstance.)
Elements | Gets the contained Array Elements as read only collection. (Inherited from DynamicArrayInstance.)
ElementType | Gets the type of the contained elements. (Inherited from DynamicArrayInstance.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
Item | Gets the ISymbol with the specified indices. (Inherited from DynamicArrayInstance.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
OversamplingElement | Gets the oversampling element.
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Inherited from DynamicSymbol.)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetElement(IList..Int32.., ISymbol.) | Tries to get the array element with the specified indices (jagged array support). (Inherited from DynamicArrayInstance.)
TryGetElement(.Int32., ISymbol.) | Tries to get the array element (Inherited from DynamicArrayInstance.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicArrayInstance.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Inherited from DynamicSymbol.)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicArrayInstance.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicObject.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicOversamplingArrayInstance Properties
•
DynamicOversamplingArrayInstance Methods
•
DynamicOversamplingArrayInstance Events


DynamicOversamplingArrayInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicOversamplingArrayInstance Class [image] DynamicOversamplingArrayInstance Properties
DynamicOversamplingArrayInstance Properties
The DynamicOversamplingArrayInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
Dimensions | Gets the dimensions as read only collection. (Inherited from DynamicArrayInstance.)
Elements | Gets the contained Array Elements as read only collection. (Inherited from DynamicArrayInstance.)
ElementType | Gets the type of the contained elements. (Inherited from DynamicArrayInstance.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
Item | Gets the ISymbol with the specified indices. (Inherited from DynamicArrayInstance.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
OversamplingElement | Gets the oversampling element.
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Reference
DynamicOversamplingArrayInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicOversamplingArrayInstance.OversamplingElement Property


DynamicOversamplingArrayInstance.OversamplingElement Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicOversamplingArrayInstance Class [image] DynamicOversamplingArrayInstance Properties [image] DynamicOversamplingArrayInstance.OversamplingElement Property
DynamicOversamplingArrayInstance.OversamplingElement Property
Gets the oversampling element.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ISymbol OversamplingElement { get; }
VB
Public ReadOnly Property OversamplingElement As ISymbol
Get
Property Value
Type: ISymbol
The oversampling element.
Implements
IOversamplingArrayInstance.OversamplingElement
Exceptions
Exception | Condition
NotImplementedException |
Reference
DynamicOversamplingArrayInstance Class
TwinCAT.TypeSystem Namespace


DynamicOversamplingArrayInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicOversamplingArrayInstance Class [image] DynamicOversamplingArrayInstance Methods
DynamicOversamplingArrayInstance Methods
The DynamicOversamplingArrayInstance type exposes the following members.
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Inherited from DynamicSymbol.)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetElement(IList..Int32.., ISymbol.) | Tries to get the array element with the specified indices (jagged array support). (Inherited from DynamicArrayInstance.)
TryGetElement(.Int32., ISymbol.) | Tries to get the array element (Inherited from DynamicArrayInstance.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicArrayInstance.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Inherited from DynamicSymbol.)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicArrayInstance.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicObject.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Reference
DynamicOversamplingArrayInstance Class
TwinCAT.TypeSystem Namespace


DynamicOversamplingArrayInstance Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicOversamplingArrayInstance Class [image] DynamicOversamplingArrayInstance Events
DynamicOversamplingArrayInstance Events
The DynamicOversamplingArrayInstance type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
DynamicOversamplingArrayInstance Class
TwinCAT.TypeSystem Namespace


DynamicPointerInstance Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerInstance Class
DynamicPointerInstance Class
Dynamic Pointer Instance
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.DynamicPointerInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class DynamicPointerInstance : DynamicSymbol,
IPointerInstance, ISymbol, IAttributedInstance, IInstance, IBitSize
VB
Public NotInheritable Class DynamicPointerInstance
Inherits DynamicSymbol
Implements IPointerInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize
The DynamicPointerInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Reference | Gets the resolved reference of Pointer / Reference
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicSymbol.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicSymbol.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicObject.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicPointerInstance Properties
•
DynamicPointerInstance Methods
•
DynamicPointerInstance Events


DynamicPointerInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerInstance Class [image] DynamicPointerInstance Properties
DynamicPointerInstance Properties
The DynamicPointerInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Reference | Gets the resolved reference of Pointer / Reference
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Reference
DynamicPointerInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicPointerInstance.Reference Property


DynamicPointerInstance.Reference Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerInstance Class [image] DynamicPointerInstance Properties [image] DynamicPointerInstance.Reference Property
DynamicPointerInstance.Reference Property
Gets the resolved reference of Pointer / Reference
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ISymbol Reference { get; }
VB
Public ReadOnly Property Reference As ISymbol
Get
Property Value
Type: ISymbol
The reference.
Implements
IPointerInstance.Reference
Reference
DynamicPointerInstance Class
TwinCAT.TypeSystem Namespace


DynamicPointerInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerInstance Class [image] DynamicPointerInstance Methods
DynamicPointerInstance Methods
The DynamicPointerInstance type exposes the following members.
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicSymbol.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicSymbol.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicObject.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Reference
DynamicPointerInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicPointerInstance.GetDynamicMemberNames Method
•
DynamicPointerInstance.TryGetMember Method


DynamicPointerInstance.GetDynamicMemberNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerInstance Class [image] DynamicPointerInstance Methods [image] DynamicPointerInstance.GetDynamicMemberNames Method
DynamicPointerInstance.GetDynamicMemberNames Method
Returns the enumeration of all dynamic member names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override IEnumerable<string> GetDynamicMemberNames()
VB
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
Return Value
Type: IEnumerable.String.
A sequence that contains dynamic member names.
Reference
DynamicPointerInstance Class
TwinCAT.TypeSystem Namespace


DynamicPointerInstance.TryGetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerInstance Class [image] DynamicPointerInstance Methods [image] DynamicPointerInstance.TryGetMember Method
DynamicPointerInstance.TryGetMember Method
Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetMember(
GetMemberBinder binder,
out Object result
)
VB
Public Overrides Function TryGetMember (
binder As GetMemberBinder,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member on which the dynamic operation is performed. For example, for the Console.WriteLine(sampleObject.SampleProperty) statement, where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
result | Type: System.Object. The result of the get operation. For example, if the method is called for a property, you can assign the property value to result.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicPointerInstance Class
TwinCAT.TypeSystem Namespace


DynamicPointerInstance Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerInstance Class [image] DynamicPointerInstance Events
DynamicPointerInstance Events
The DynamicPointerInstance type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
DynamicPointerInstance Class
TwinCAT.TypeSystem Namespace


DynamicPointerValue Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerValue Class
DynamicPointerValue Class
Class DynamicPointerValue.
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicValue
TwinCAT.TypeSystem.DynamicPointerValue
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DynamicPointerValue : DynamicValue
VB
Public Class DynamicPointerValue
Inherits DynamicValue
The DynamicPointerValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value) (Inherited from DynamicValue.)
CachedRaw | Gets the cached Raw internal Data. (Inherited from DynamicValue.)
DataType | Gets the data type bound to this IValue (Inherited from DynamicValue.)
IsPrimitive | Gets a value indicating whether this IValue is a primitive value. (Inherited from DynamicValue.)
ResolvedType | Gets the resolved type. (Inherited from DynamicValue.)
Symbol | Gets the symbol that is bound to this value. (Inherited from DynamicValue.)
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value. (Inherited from DynamicValue.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicValue.GetDynamicMemberNames..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads the value (via ADS) (Inherited from DynamicValue.)
ReadMember | Reads the specified member element. (Inherited from DynamicValue.)
ResolveValue | Resolves the Value object to its primitive value. (Inherited from DynamicValue.)
ToString | Returns a String that represents this instance. (Inherited from DynamicValue.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicValue.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetArrayElementValues | Returns Array Element values. (Inherited from DynamicValue.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicValue.)
TryGetIndexValue(.Int32., Object.) | Reads the specified array element. (Inherited from DynamicValue.)
TryGetIndexValue(.Object., Object.) | Tries the get index value. (Inherited from DynamicValue.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Inherited from DynamicValue.)
TryGetMemberValue | Tries the get member value. (Overrides DynamicValue.TryGetMemberValue(String, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicValue.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicValue.)
TryResolveValue | Tries to resolves the Value object to its primitive value. (Inherited from DynamicValue.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicValue.)
TrySetIndexValue | Tries to set the indexed value on Arrays (Inherited from DynamicValue.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicValue.)
TrySetMemberValue | Tries to Set a Member/Property Value (Inherited from DynamicValue.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
Write | Writes the value (via ADS) (Inherited from DynamicValue.)
WriteMember | Writes the specified member element. (Inherited from DynamicValue.)
Fields
Name | Description
_symbol | Symbol that is bound to this value. (Inherited from DynamicValue.)
s_pointerDeref | Pointer Deref indicator
valueFactory | The value factory (Inherited from DynamicValue.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.DynamicValue
Weiterführende Informationen
•
DynamicPointerValue Properties
•
DynamicPointerValue Methods
•
DynamicPointerValue Fields


DynamicPointerValue Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerValue Class [image] DynamicPointerValue Properties
DynamicPointerValue Properties
The DynamicPointerValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value) (Inherited from DynamicValue.)
CachedRaw | Gets the cached Raw internal Data. (Inherited from DynamicValue.)
DataType | Gets the data type bound to this IValue (Inherited from DynamicValue.)
IsPrimitive | Gets a value indicating whether this IValue is a primitive value. (Inherited from DynamicValue.)
ResolvedType | Gets the resolved type. (Inherited from DynamicValue.)
Symbol | Gets the symbol that is bound to this value. (Inherited from DynamicValue.)
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value. (Inherited from DynamicValue.)
Reference
DynamicPointerValue Class
TwinCAT.TypeSystem Namespace


DynamicPointerValue Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerValue Class [image] DynamicPointerValue Methods
DynamicPointerValue Methods
The DynamicPointerValue type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicValue.GetDynamicMemberNames..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads the value (via ADS) (Inherited from DynamicValue.)
ReadMember | Reads the specified member element. (Inherited from DynamicValue.)
ResolveValue | Resolves the Value object to its primitive value. (Inherited from DynamicValue.)
ToString | Returns a String that represents this instance. (Inherited from DynamicValue.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicValue.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetArrayElementValues | Returns Array Element values. (Inherited from DynamicValue.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicValue.)
TryGetIndexValue(.Int32., Object.) | Reads the specified array element. (Inherited from DynamicValue.)
TryGetIndexValue(.Object., Object.) | Tries the get index value. (Inherited from DynamicValue.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Inherited from DynamicValue.)
TryGetMemberValue | Tries the get member value. (Overrides DynamicValue.TryGetMemberValue(String, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicValue.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicValue.)
TryResolveValue | Tries to resolves the Value object to its primitive value. (Inherited from DynamicValue.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicValue.)
TrySetIndexValue | Tries to set the indexed value on Arrays (Inherited from DynamicValue.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicValue.)
TrySetMemberValue | Tries to Set a Member/Property Value (Inherited from DynamicValue.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
Write | Writes the value (via ADS) (Inherited from DynamicValue.)
WriteMember | Writes the specified member element. (Inherited from DynamicValue.)
Reference
DynamicPointerValue Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicPointerValue.GetDynamicMemberNames Method
•
DynamicPointerValue.TryGetMemberValue Method


DynamicPointerValue.GetDynamicMemberNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerValue Class [image] DynamicPointerValue Methods [image] DynamicPointerValue.GetDynamicMemberNames Method
DynamicPointerValue.GetDynamicMemberNames Method
Returns the enumeration of all dynamic member names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override IEnumerable<string> GetDynamicMemberNames()
VB
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
Return Value
Type: IEnumerable.String.
A sequence that contains dynamic member names.
Reference
DynamicPointerValue Class
TwinCAT.TypeSystem Namespace


DynamicPointerValue.TryGetMemberValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerValue Class [image] DynamicPointerValue Methods [image] DynamicPointerValue.TryGetMemberValue Method
DynamicPointerValue.TryGetMemberValue Method
Tries the get member value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetMemberValue(
string name,
out Object result
)
VB
Public Overrides Function TryGetMemberValue (
name As String,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
name | Type: System.String The name.
result | Type: System.Object. The result.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Implements
IStructValue.TryGetMemberValue(String, Object.)
Exceptions
Exception | Condition
SymbolException |
Reference
DynamicPointerValue Class
TwinCAT.TypeSystem Namespace


DynamicPointerValue Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerValue Class [image] DynamicPointerValue Fields
DynamicPointerValue Fields
The DynamicPointerValue type exposes the following members.
Fields
Name | Description
_symbol | Symbol that is bound to this value. (Inherited from DynamicValue.)
s_pointerDeref | Pointer Deref indicator
valueFactory | The value factory (Inherited from DynamicValue.)
Reference
DynamicPointerValue Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicPointerValue.s_pointerDeref Field


DynamicPointerValue.s_pointerDeref Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicPointerValue Class [image] DynamicPointerValue Fields [image] DynamicPointerValue.s_pointerDeref Field
DynamicPointerValue.s_pointerDeref Field
Pointer Deref indicator
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static string s_pointerDeref
VB
Public Shared s_pointerDeref As String
Field Value
Type: String
Reference
DynamicPointerValue Class
TwinCAT.TypeSystem Namespace


DynamicReferenceInstance Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceInstance Class
DynamicReferenceInstance Class
Dynamic Reference Instance
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.DynamicReferenceInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class DynamicReferenceInstance : DynamicSymbol,
IReferenceInstance, ISymbol, IAttributedInstance, IInstance, IBitSize
VB
Public NotInheritable Class DynamicReferenceInstance
Inherits DynamicSymbol
Implements IReferenceInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize
The DynamicReferenceInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicSymbol.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Overrides DynamicObject.TryGetIndex(GetIndexBinder, .Object., Object.).)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicSymbol.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Overrides DynamicObject.TrySetIndex(SetIndexBinder, .Object., Object).)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicObject.TrySetMember(SetMemberBinder, Object).)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicReferenceInstance Properties
•
DynamicReferenceInstance Methods
•
DynamicReferenceInstance Events


DynamicReferenceInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceInstance Class [image] DynamicReferenceInstance Properties
DynamicReferenceInstance Properties
The DynamicReferenceInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Reference
DynamicReferenceInstance Class
TwinCAT.TypeSystem Namespace


DynamicReferenceInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceInstance Class [image] DynamicReferenceInstance Methods
DynamicReferenceInstance Methods
The DynamicReferenceInstance type exposes the following members.
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicSymbol.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Overrides DynamicObject.TryGetIndex(GetIndexBinder, .Object., Object.).)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicSymbol.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Overrides DynamicObject.TrySetIndex(SetIndexBinder, .Object., Object).)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicObject.TrySetMember(SetMemberBinder, Object).)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Reference
DynamicReferenceInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicReferenceInstance.GetDynamicMemberNames Method
•
DynamicReferenceInstance.TryGetIndex Method
•
DynamicReferenceInstance.TryGetMember Method
•
DynamicReferenceInstance.TrySetIndex Method
•
DynamicReferenceInstance.TrySetMember Method


DynamicReferenceInstance.GetDynamicMemberNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceInstance Class [image] DynamicReferenceInstance Methods [image] DynamicReferenceInstance.GetDynamicMemberNames Method
DynamicReferenceInstance.GetDynamicMemberNames Method
Returns the enumeration of all dynamic member names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override IEnumerable<string> GetDynamicMemberNames()
VB
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
Return Value
Type: IEnumerable.String.
A sequence that contains dynamic member names.
Reference
DynamicReferenceInstance Class
TwinCAT.TypeSystem Namespace


DynamicReferenceInstance.TryGetIndex Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceInstance Class [image] DynamicReferenceInstance Methods [image] DynamicReferenceInstance.TryGetIndex Method
DynamicReferenceInstance.TryGetIndex Method
Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetIndex(
GetIndexBinder binder,
Object[] indexes,
out Object result
)
VB
Public Overrides Function TryGetIndex (
binder As GetIndexBinder,
indexes As Object(),
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetIndexBinder Provides information about the operation.
indexes | Type: .System.Object. The indexes that are used in the operation. For example, for the sampleObject[3] operation in C# (sampleObject(3) in Visual Basic), where sampleObject is derived from the DynamicObject class, indexes[0] is equal to 3.
result | Type: System.Object. The result of the index operation.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicReferenceInstance Class
TwinCAT.TypeSystem Namespace


DynamicReferenceInstance.TryGetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceInstance Class [image] DynamicReferenceInstance Methods [image] DynamicReferenceInstance.TryGetMember Method
DynamicReferenceInstance.TryGetMember Method
Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetMember(
GetMemberBinder binder,
out Object result
)
VB
Public Overrides Function TryGetMember (
binder As GetMemberBinder,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member on which the dynamic operation is performed. For example, for the Console.WriteLine(sampleObject.SampleProperty) statement, where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
result | Type: System.Object. The result of the get operation. For example, if the method is called for a property, you can assign the property value to result.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicReferenceInstance Class
TwinCAT.TypeSystem Namespace


DynamicReferenceInstance.TrySetIndex Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceInstance Class [image] DynamicReferenceInstance Methods [image] DynamicReferenceInstance.TrySetIndex Method
DynamicReferenceInstance.TrySetIndex Method
Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TrySetIndex(
SetIndexBinder binder,
Object[] indexes,
Object value
)
VB
Public Overrides Function TrySetIndex (
binder As SetIndexBinder,
indexes As Object(),
value As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.SetIndexBinder Provides information about the operation.
indexes | Type: .System.Object. The indexes that are used in the operation. For example, for the sampleObject[3] = 10 operation in C# (sampleObject(3) = 10 in Visual Basic), where sampleObject is derived from the DynamicObject class, indexes[][] is equal to 3.
value | Type: System.Object The value to set to the object that has the specified index. For example, for the sampleObject[3] = 10 operation in C# (sampleObject(3) = 10 in Visual Basic), where sampleObject is derived from the DynamicObject class, value is equal to 10.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.
Reference
DynamicReferenceInstance Class
TwinCAT.TypeSystem Namespace


DynamicReferenceInstance.TrySetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceInstance Class [image] DynamicReferenceInstance Methods [image] DynamicReferenceInstance.TrySetMember Method
DynamicReferenceInstance.TrySetMember Method
Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TrySetMember(
SetMemberBinder binder,
Object value
)
VB
Public Overrides Function TrySetMember (
binder As SetMemberBinder,
value As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.SetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member to which the value is being assigned. For example, for the statement sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
value | Type: System.Object The value to set to the member. For example, for sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, the value is "Test".
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.)
Reference
DynamicReferenceInstance Class
TwinCAT.TypeSystem Namespace


DynamicReferenceInstance Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceInstance Class [image] DynamicReferenceInstance Events
DynamicReferenceInstance Events
The DynamicReferenceInstance type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
DynamicReferenceInstance Class
TwinCAT.TypeSystem Namespace


DynamicReferenceValue Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceValue Class
DynamicReferenceValue Class
Class DynamicReferenceValue.
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicValue
TwinCAT.TypeSystem.DynamicReferenceValue
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DynamicReferenceValue : DynamicValue
VB
Public Class DynamicReferenceValue
Inherits DynamicValue
The DynamicReferenceValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value) (Inherited from DynamicValue.)
CachedRaw | Gets the cached Raw internal Data. (Inherited from DynamicValue.)
DataType | Gets the data type bound to this IValue (Inherited from DynamicValue.)
IsPrimitive | Gets a value indicating whether this IValue is a primitive value. (Inherited from DynamicValue.)
ResolvedType | Gets the resolved type. (Inherited from DynamicValue.)
Symbol | Gets the symbol that is bound to this value. (Inherited from DynamicValue.)
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value. (Inherited from DynamicValue.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Inherited from DynamicValue.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads the value (via ADS) (Inherited from DynamicValue.)
ReadMember | Reads the specified member element. (Overrides DynamicValue.ReadMember(ISymbol).)
ResolveValue | Resolves the Value object to its primitive value. (Inherited from DynamicValue.)
ToString | Returns a String that represents this instance. (Inherited from DynamicValue.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicValue.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetArrayElementValues | Returns Array Element values. (Inherited from DynamicValue.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicValue.)
TryGetIndexValue(.Int32., Object.) | Reads the specified array element. (Inherited from DynamicValue.)
TryGetIndexValue(.Object., Object.) | Tries the get index value. (Inherited from DynamicValue.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Inherited from DynamicValue.)
TryGetMemberValue | Tries the get member value. (Inherited from DynamicValue.)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicValue.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicValue.)
TryResolveValue | Tries to resolves the Value object to its primitive value. (Inherited from DynamicValue.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicValue.)
TrySetIndexValue | Tries to set the indexed value on Arrays (Inherited from DynamicValue.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicValue.)
TrySetMemberValue | Tries to Set a Member/Property Value (Inherited from DynamicValue.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
Write | Writes the value (via ADS) (Inherited from DynamicValue.)
WriteMember | Writes the specified member element. (Inherited from DynamicValue.)
Fields
Name | Description
_symbol | Symbol that is bound to this value. (Inherited from DynamicValue.)
valueFactory | The value factory (Inherited from DynamicValue.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.DynamicValue
Weiterführende Informationen
•
DynamicReferenceValue Properties
•
DynamicReferenceValue Methods
•
DynamicReferenceValue Fields


DynamicReferenceValue Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceValue Class [image] DynamicReferenceValue Properties
DynamicReferenceValue Properties
The DynamicReferenceValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value) (Inherited from DynamicValue.)
CachedRaw | Gets the cached Raw internal Data. (Inherited from DynamicValue.)
DataType | Gets the data type bound to this IValue (Inherited from DynamicValue.)
IsPrimitive | Gets a value indicating whether this IValue is a primitive value. (Inherited from DynamicValue.)
ResolvedType | Gets the resolved type. (Inherited from DynamicValue.)
Symbol | Gets the symbol that is bound to this value. (Inherited from DynamicValue.)
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value. (Inherited from DynamicValue.)
Reference
DynamicReferenceValue Class
TwinCAT.TypeSystem Namespace


DynamicReferenceValue Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceValue Class [image] DynamicReferenceValue Methods
DynamicReferenceValue Methods
The DynamicReferenceValue type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Inherited from DynamicValue.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads the value (via ADS) (Inherited from DynamicValue.)
ReadMember | Reads the specified member element. (Overrides DynamicValue.ReadMember(ISymbol).)
ResolveValue | Resolves the Value object to its primitive value. (Inherited from DynamicValue.)
ToString | Returns a String that represents this instance. (Inherited from DynamicValue.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicValue.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetArrayElementValues | Returns Array Element values. (Inherited from DynamicValue.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicValue.)
TryGetIndexValue(.Int32., Object.) | Reads the specified array element. (Inherited from DynamicValue.)
TryGetIndexValue(.Object., Object.) | Tries the get index value. (Inherited from DynamicValue.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Inherited from DynamicValue.)
TryGetMemberValue | Tries the get member value. (Inherited from DynamicValue.)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicValue.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicValue.)
TryResolveValue | Tries to resolves the Value object to its primitive value. (Inherited from DynamicValue.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicValue.)
TrySetIndexValue | Tries to set the indexed value on Arrays (Inherited from DynamicValue.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicValue.)
TrySetMemberValue | Tries to Set a Member/Property Value (Inherited from DynamicValue.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
Write | Writes the value (via ADS) (Inherited from DynamicValue.)
WriteMember | Writes the specified member element. (Inherited from DynamicValue.)
Reference
DynamicReferenceValue Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicReferenceValue.ReadMember Method


DynamicReferenceValue.ReadMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceValue Class [image] DynamicReferenceValue Methods [image] DynamicReferenceValue.ReadMember Method
DynamicReferenceValue.ReadMember Method
Reads the specified member element.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected override Object ReadMember(
ISymbol memberInstance
)
VB
Protected Overrides Function ReadMember (
memberInstance As ISymbol
) As Object
Parameters
memberInstance
Type: TwinCAT.TypeSystem.ISymbol
The member instance.
Return Value
Type: Object
Reference
DynamicReferenceValue Class
TwinCAT.TypeSystem Namespace


DynamicReferenceValue Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicReferenceValue Class [image] DynamicReferenceValue Fields
DynamicReferenceValue Fields
The DynamicReferenceValue type exposes the following members.
Fields
Name | Description
_symbol | Symbol that is bound to this value. (Inherited from DynamicValue.)
valueFactory | The value factory (Inherited from DynamicValue.)
Reference
DynamicReferenceValue Class
TwinCAT.TypeSystem Namespace


DynamicRpcStructInstance Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class
DynamicRpcStructInstance Class
Dynamic struct instance with RPC Methods.
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.DynamicStructInstance
TwinCAT.TypeSystem.DynamicRpcStructInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class DynamicRpcStructInstance : DynamicStructInstance,
IRpcStructInstance, IStructInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize, IRpcCallableInstance
VB
Public NotInheritable Class DynamicRpcStructInstance
Inherits DynamicStructInstance
Implements IRpcStructInstance, IStructInstance, ISymbol, IAttributedInstance,
IInstance, IBitSize, IRpcCallableInstance
The DynamicRpcStructInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Inherited from DynamicStructInstance.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
MemberInstances | Gets the member instances of the Struct Instance. (Inherited from DynamicStructInstance.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
RpcMethods | Gets the Method descriptions for the IRpcCallableType
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Gets the dynamic member names. (Overrides DynamicStructInstance.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeRpcMethod | Invokes the specified method.
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicStructInstance.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Overrides DynamicObject.TryInvokeMember(InvokeMemberBinder, .Object., Object.).)
TryInvokeRpcMethod(String, .Object., Object.) | Tries to invoke the specified method.
TryInvokeRpcMethod(IRpcMethod, .Object., Object.) | Tries to invoke the specified method.
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicStructInstance.TrySetMember(SetMemberBinder, Object).)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.IStructInstance
TwinCAT.TypeSystem.IRpcStructInstance
TwinCAT.TypeSystem.IRpcCallableInstance
Weiterführende Informationen
•
DynamicRpcStructInstance Properties
•
DynamicRpcStructInstance Methods
•
DynamicRpcStructInstance Events


DynamicRpcStructInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Properties
DynamicRpcStructInstance Properties
The DynamicRpcStructInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Inherited from DynamicStructInstance.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
MemberInstances | Gets the member instances of the Struct Instance. (Inherited from DynamicStructInstance.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
RpcMethods | Gets the Method descriptions for the IRpcCallableType
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Reference
DynamicRpcStructInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicRpcStructInstance.RpcMethods Property


DynamicRpcStructInstance.RpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Properties [image] DynamicRpcStructInstance.RpcMethods Property
DynamicRpcStructInstance.RpcMethods Property
Gets the Method descriptions for the IRpcCallableType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyRpcMethodCollection RpcMethods { get; }
VB
Public ReadOnly Property RpcMethods As ReadOnlyRpcMethodCollection
Get
Property Value
Type: ReadOnlyRpcMethodCollection
The methods.
Implements
IRpcCallableInstance.RpcMethods
Reference
DynamicRpcStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicRpcStructInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Methods
DynamicRpcStructInstance Methods
The DynamicRpcStructInstance type exposes the following members.
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Gets the dynamic member names. (Overrides DynamicStructInstance.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeRpcMethod | Invokes the specified method.
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicStructInstance.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Overrides DynamicObject.TryInvokeMember(InvokeMemberBinder, .Object., Object.).)
TryInvokeRpcMethod(String, .Object., Object.) | Tries to invoke the specified method.
TryInvokeRpcMethod(IRpcMethod, .Object., Object.) | Tries to invoke the specified method.
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicStructInstance.TrySetMember(SetMemberBinder, Object).)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Reference
DynamicRpcStructInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicRpcStructInstance.GetDynamicMemberNames Method
•
DynamicRpcStructInstance.InvokeRpcMethod Method
•
DynamicRpcStructInstance.TryGetMember Method
•
DynamicRpcStructInstance.TryInvokeMember Method
•
DynamicRpcStructInstance.TryInvokeRpcMethod Method
•
DynamicRpcStructInstance.TrySetMember Method


DynamicRpcStructInstance.GetDynamicMemberNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Methods [image] DynamicRpcStructInstance.GetDynamicMemberNames Method
DynamicRpcStructInstance.GetDynamicMemberNames Method
Gets the dynamic member names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override IEnumerable<string> GetDynamicMemberNames()
VB
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
Return Value
Type: IEnumerable.String.
IEnumerable<System.String>.
Reference
DynamicRpcStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicRpcStructInstance.InvokeRpcMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Methods [image] DynamicRpcStructInstance.InvokeRpcMethod Method
DynamicRpcStructInstance.InvokeRpcMethod Method
Invokes the specified method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object InvokeRpcMethod(
string methodName,
Object[] parameters
)
VB
Public Function InvokeRpcMethod (
methodName As String,
parameters As Object()
) As Object
Parameters
methodName | Type: System.String Name of the method.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
The return value of the RPC Method
Implements
IRpcCallableInstance.InvokeRpcMethod(String, .Object.)
Remarks
To indicate a PLC Method for remote ads access, the attribute 'TcRpcEnable' must be declared on the method declaration (see example).
Examples
RPC Method definition and implementation
(* Declaration *)
{attribute 'TcRpcEnable'}
METHOD RpcMethod1 : INT
VAR_INPUT
i1 : INT;
END_VAR
(* Implementation *)
RpcMethod1 := i1 + 1;
Reference
DynamicRpcStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicRpcStructInstance.TryGetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Methods [image] DynamicRpcStructInstance.TryGetMember Method
DynamicRpcStructInstance.TryGetMember Method
Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetMember(
GetMemberBinder binder,
out Object result
)
VB
Public Overrides Function TryGetMember (
binder As GetMemberBinder,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member on which the dynamic operation is performed. For example, for the Console.WriteLine(sampleObject.SampleProperty) statement, where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
result | Type: System.Object. The result of the get operation. For example, if the method is called for a property, you can assign the property value to result.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicRpcStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicRpcStructInstance.TryInvokeMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Methods [image] DynamicRpcStructInstance.TryInvokeMember Method
DynamicRpcStructInstance.TryInvokeMember Method
Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryInvokeMember(
InvokeMemberBinder binder,
Object[] args,
out Object result
)
VB
Public Overrides Function TryInvokeMember (
binder As InvokeMemberBinder,
args As Object(),
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.InvokeMemberBinder Provides information about the dynamic operation. The binder.Name property provides the name of the member on which the dynamic operation is performed. For example, for the statement sampleObject.SampleMethod(100), where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleMethod". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
args | Type: .System.Object. The arguments that are passed to the object member during the invoke operation. For example, for the statement sampleObject.SampleMethod(100), where sampleObject is derived from the DynamicObject class, args[][] is equal to 100.
result | Type: System.Object. The result of the member invocation.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.)
Reference
DynamicRpcStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicRpcStructInstance.TryInvokeRpcMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Methods [image] DynamicRpcStructInstance.TryInvokeRpcMethod Method
DynamicRpcStructInstance.TryInvokeRpcMethod Method
Overload List
Name | Description
TryInvokeRpcMethod(String, .Object., Object.) | Tries to invoke the specified method.
TryInvokeRpcMethod(IRpcMethod, .Object., Object.) | Tries to invoke the specified method.
Reference
DynamicRpcStructInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicRpcStructInstance.TryInvokeRpcMethod Method (String, .Object., Object.)
•
DynamicRpcStructInstance.TryInvokeRpcMethod Method (IRpcMethod, .Object., Object.)


DynamicRpcStructInstance.TryInvokeRpcMethod Method (String, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Methods [image] DynamicRpcStructInstance.TryInvokeRpcMethod Method [image] DynamicRpcStructInstance.TryInvokeRpcMethod Method (String, .Object., Object.)
DynamicRpcStructInstance.TryInvokeRpcMethod Method (String, .Object., Object.)
Tries to invoke the specified method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int TryInvokeRpcMethod(
string methodName,
Object[] args,
out Object result
)
VB
Public Function TryInvokeRpcMethod (
methodName As String,
args As Object(),
<OutAttribute> ByRef result As Object
) As Integer
Parameters
methodName | Type: System.String Name of the method.
args | Type: .System.Object. The arguments.
result | Type: System.Object. The result.
Return Value
Type: Int32
true if the call succeeds, false otherwise.
Implements
IRpcCallableInstance.TryInvokeRpcMethod(String, .Object., Object.)
Exceptions
Exception | Condition
NotImplementedException |
Reference
DynamicRpcStructInstance Class
TryInvokeRpcMethod Overload
TwinCAT.TypeSystem Namespace


DynamicRpcStructInstance.TryInvokeRpcMethod Method (IRpcMethod, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Methods [image] DynamicRpcStructInstance.TryInvokeRpcMethod Method [image] DynamicRpcStructInstance.TryInvokeRpcMethod Method (IRpcMethod, .Object., Object.)
DynamicRpcStructInstance.TryInvokeRpcMethod Method (IRpcMethod, .Object., Object.)
Tries to invoke the specified method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int TryInvokeRpcMethod(
IRpcMethod method,
Object[] args,
out Object result
)
VB
Public Function TryInvokeRpcMethod (
method As IRpcMethod,
args As Object(),
<OutAttribute> ByRef result As Object
) As Integer
Parameters
method | Type: TwinCAT.TypeSystem.IRpcMethod The method.
args | Type: .System.Object. The arguments.
result | Type: System.Object. The result.
Return Value
Type: Int32
true if the call succeeds, false otherwise.
Implements
IRpcCallableInstance.TryInvokeRpcMethod(IRpcMethod, .Object., Object.)
Exceptions
Exception | Condition
NotImplementedException |
Reference
DynamicRpcStructInstance Class
TryInvokeRpcMethod Overload
TwinCAT.TypeSystem Namespace


DynamicRpcStructInstance.TrySetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Methods [image] DynamicRpcStructInstance.TrySetMember Method
DynamicRpcStructInstance.TrySetMember Method
Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TrySetMember(
SetMemberBinder binder,
Object value
)
VB
Public Overrides Function TrySetMember (
binder As SetMemberBinder,
value As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.SetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member to which the value is being assigned. For example, for the statement sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
value | Type: System.Object The value to set to the member. For example, for sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, the value is "Test".
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.)
Reference
DynamicRpcStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicRpcStructInstance Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicRpcStructInstance Class [image] DynamicRpcStructInstance Events
DynamicRpcStructInstance Events
The DynamicRpcStructInstance type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
DynamicRpcStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicStructInstance Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicStructInstance Class
DynamicStructInstance Class
Dynamic struct instance
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.DynamicStructInstance
TwinCAT.TypeSystem.DynamicRpcStructInstance
TwinCAT.TypeSystem.DynamicVirtualStructInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DynamicStructInstance : DynamicSymbol,
IStructInstance, ISymbol, IAttributedInstance, IInstance, IBitSize
VB
Public Class DynamicStructInstance
Inherits DynamicSymbol
Implements IStructInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize
The DynamicStructInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
MemberInstances | Gets the member instances of the Struct Instance.
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicSymbol.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnReadAnyValue | Handler function for reading ADS 'Any' Values. (Inherited from DynamicSymbol.)
OnReadRawValue | Handler function for reading Raw symbol value. (Inherited from DynamicSymbol.)
OnReadValue | Handler function for the (Inherited from DynamicSymbol.)
OnSetInstanceName | Sets a new InstanceName InstancePath (Inherited from DynamicSymbol.)
OnTryReadValue | Handler function for the (Inherited from DynamicSymbol.)
OnTryWriteValue | Handler Function for writing value. (Inherited from DynamicSymbol.)
OnWriteRawValue | Handler function for reading symbols raw value. (Inherited from DynamicSymbol.)
OnWriteValue | Handler Function for writing value. (Inherited from DynamicSymbol.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicSymbol.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicObject.TrySetMember(SetMemberBinder, Object).)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Fields
Name | Description
normalizedDict | Dictionary of normalized Instance Names
normalizedName | The normalized name of this . (Inherited from DynamicSymbol.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicStructInstance Properties
•
DynamicStructInstance Methods
•
DynamicStructInstance Events
•
DynamicStructInstance Fields


DynamicStructInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicStructInstance Class [image] DynamicStructInstance Properties
DynamicStructInstance Properties
The DynamicStructInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
MemberInstances | Gets the member instances of the Struct Instance.
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Reference
DynamicStructInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicStructInstance.HasRpcMethods Property
•
DynamicStructInstance.MemberInstances Property


DynamicStructInstance.HasRpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicStructInstance Class [image] DynamicStructInstance Properties [image] DynamicStructInstance.HasRpcMethods Property
DynamicStructInstance.HasRpcMethods Property
Gets a value indicating whether this instance has RPC methods
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool HasRpcMethods { get; }
VB
Public ReadOnly Property HasRpcMethods As Boolean
Get
Property Value
Type: Boolean
true if this instance has RPC methods; otherwise, false.
Implements
IStructInstance.HasRpcMethods
Remarks
If the struct instance supports RPC Methods, then the instance class is also supporting IRpcStructInstance
Reference
DynamicStructInstance Class
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IRpcStructInstance
TwinCAT.TypeSystem.IRpcMethod
TwinCAT.TypeSystem.IRpcMethodParameter


DynamicStructInstance.MemberInstances Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicStructInstance Class [image] DynamicStructInstance Properties [image] DynamicStructInstance.MemberInstances Property
DynamicStructInstance.MemberInstances Property
Gets the member instances of the Struct Instance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySymbolCollection MemberInstances { get; }
VB
Public ReadOnly Property MemberInstances As ReadOnlySymbolCollection
Get
Property Value
Type: ReadOnlySymbolCollection
The member instances.
Implements
IStructInstance.MemberInstances
Reference
DynamicStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicStructInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicStructInstance Class [image] DynamicStructInstance Methods
DynamicStructInstance Methods
The DynamicStructInstance type exposes the following members.
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicSymbol.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnReadAnyValue | Handler function for reading ADS 'Any' Values. (Inherited from DynamicSymbol.)
OnReadRawValue | Handler function for reading Raw symbol value. (Inherited from DynamicSymbol.)
OnReadValue | Handler function for the (Inherited from DynamicSymbol.)
OnSetInstanceName | Sets a new InstanceName InstancePath (Inherited from DynamicSymbol.)
OnTryReadValue | Handler function for the (Inherited from DynamicSymbol.)
OnTryWriteValue | Handler Function for writing value. (Inherited from DynamicSymbol.)
OnWriteRawValue | Handler function for reading symbols raw value. (Inherited from DynamicSymbol.)
OnWriteValue | Handler Function for writing value. (Inherited from DynamicSymbol.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicSymbol.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicObject.TrySetMember(SetMemberBinder, Object).)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Reference
DynamicStructInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicStructInstance.GetDynamicMemberNames Method
•
DynamicStructInstance.TryGetMember Method
•
DynamicStructInstance.TrySetMember Method


DynamicStructInstance.GetDynamicMemberNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicStructInstance Class [image] DynamicStructInstance Methods [image] DynamicStructInstance.GetDynamicMemberNames Method
DynamicStructInstance.GetDynamicMemberNames Method
Returns the enumeration of all dynamic member names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override IEnumerable<string> GetDynamicMemberNames()
VB
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
Return Value
Type: IEnumerable.String.
A sequence that contains dynamic member names.
Reference
DynamicStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicStructInstance.TryGetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicStructInstance Class [image] DynamicStructInstance Methods [image] DynamicStructInstance.TryGetMember Method
DynamicStructInstance.TryGetMember Method
Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetMember(
GetMemberBinder binder,
out Object result
)
VB
Public Overrides Function TryGetMember (
binder As GetMemberBinder,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member on which the dynamic operation is performed. For example, for the Console.WriteLine(sampleObject.SampleProperty) statement, where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
result | Type: System.Object. The result of the get operation. For example, if the method is called for a property, you can assign the property value to result.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicStructInstance.TrySetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicStructInstance Class [image] DynamicStructInstance Methods [image] DynamicStructInstance.TrySetMember Method
DynamicStructInstance.TrySetMember Method
Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TrySetMember(
SetMemberBinder binder,
Object value
)
VB
Public Overrides Function TrySetMember (
binder As SetMemberBinder,
value As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.SetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member to which the value is being assigned. For example, for the statement sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
value | Type: System.Object The value to set to the member. For example, for sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, the value is "Test".
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.)
Reference
DynamicStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicStructInstance Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicStructInstance Class [image] DynamicStructInstance Events
DynamicStructInstance Events
The DynamicStructInstance type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
DynamicStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicStructInstance Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicStructInstance Class [image] DynamicStructInstance Fields
DynamicStructInstance Fields
The DynamicStructInstance type exposes the following members.
Fields
Name | Description
normalizedDict | Dictionary of normalized Instance Names
normalizedName | The normalized name of this . (Inherited from DynamicSymbol.)
Reference
DynamicStructInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicStructInstance.normalizedDict Field


DynamicStructInstance.normalizedDict Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicStructInstance Class [image] DynamicStructInstance Fields [image] DynamicStructInstance.normalizedDict Field
DynamicStructInstance.normalizedDict Field
Dictionary of normalized Instance Names
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected Dictionary<string, ISymbol> normalizedDict
VB
Protected normalizedDict As Dictionary(Of String, ISymbol)
Field Value
Type: Dictionary.String, ISymbol.
Reference
DynamicStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicSymbol Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class
DynamicSymbol Class
Dynamic Symbol object.
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbol
More...
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DynamicSymbol : DynamicObject,
IDynamicSymbol, ISymbol, IAttributedInstance, IInstance, IBitSize,
IValueSymbol3, IValueSymbol2, IValueSymbol, IValueRawSymbol
VB
Public Class DynamicSymbol
Inherits DynamicObject
Implements IDynamicSymbol, ISymbol, IAttributedInstance, IInstance,
IBitSize, IValueSymbol3, IValueSymbol2, IValueSymbol, IValueRawSymbol
The DynamicSymbol type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol
AccessRights | Gets the access rights.
Attributes | Gets the Symbol Attributes
BitSize | Gets the size of the IDataType in bits.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes
Category | Gets the category.
Comment | Gets the comment of the IInstance
Connection | Gets the connection bound to this DynamicSymbol
ContextMask | Gets the context mask.
DataType | Gets the IDataType of the IInstance.
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations).
InstanceName | Gets the name of the instance (without periods (.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.))
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type.
IsPersistent | Gets a value indicating whether this ISymbol is persistent.
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type.
IsReadOnly | Gets a value indicating whether this ISymbol is read only.
IsRecursive | Gets a value indicating whether this instance is recursive.
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO)
IsStatic | Gets a value indicating whether this instance is static.
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters),
NotificationSettings | Gets the notification settings.
Parent | Gets the parent Symbol
Size | Gets the size of the IInstance in bytes.
SubSymbols | Gets the SubSymbols of the ISymbol
TypeName | Gets the name of the DataType that is used for this IInstance.
Methods
Name | Description
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicObject.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnReadAnyValue | Handler function for reading ADS 'Any' Values.
OnReadRawValue | Handler function for reading Raw symbol value.
OnReadValue | Handler function for the
OnSetInstanceName | Sets a new InstanceName InstancePath
OnTryReadValue | Handler function for the
OnTryWriteValue | Handler Function for writing value.
OnWriteRawValue | Handler function for reading symbols raw value.
OnWriteValue | Handler Function for writing value.
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type
ReadRawValue. | Reads the Symbols raw value
ReadRawValue(Int32) | Reads the Symbols raw value
ReadValue. | Reads the value of this DynamicSymbol.
ReadValue(Int32) | Reads the value of this DynamicSymbol.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicObject.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicObject.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol.
UpdateAnyValue | Reads the value of this Value into the specified managed value.
WriteAnyValue | Writes the value represented by the managed value to this Value
WriteRawValue(.Byte.) | Writes the Symbol raw Value
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value
WriteValue(Object) | Writes the specified value to the DynamicSymbol.
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed.
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed.
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Fields
Name | Description
normalizedName | The normalized name of this .
Extension Methods
Name | Description
PollValuesAnnotated(IObservable.Unit.) | Overloaded. Polls the values as ValueChangedArgs sequence annotated value on trigger sequence (Defined by ValueSymbolExtensions.)
PollValuesAnnotated(TimeSpan) | Overloaded. Polls the values as ValueChangedArgs sequence with a specified period time. (Defined by ValueSymbolExtensions.)
WhenValueChanged | Gets an observable sequence when the value of the IValueSymbol has changed. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
Remarks
The DynamicSymbol adds dynamic run time behaviour to the ISymbol/IValueSymbol. That means e.g. for StructSymbols that .NET Properties are defined and dispatched at runtime to the structs fields like they are defined in TwinCAT / ADS Types. Indexed access to Array Symbols is another example where the dynamic runtime support takes place.
Examples
Sample for the dynamic resolution of Symbols:
Dynamic Symbol access
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
// Get the AdsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect to the target device
client.Connect(address);

// Usage of "dynamic" Type and Symbols (>= .NET4 only)
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.DynamicTree);
IAdsSymbolLoader dynLoader = (IAdsSymbolLoader)SymbolLoaderFactory.Create(client, settings);
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IDynamicSymbol
TwinCAT.TypeSystem.IValueSymbol
TwinCAT.TypeSystem.ISymbol
System.Dynamic.DynamicObject
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.DynamicAliasInstance
TwinCAT.TypeSystem.DynamicArrayInstance
TwinCAT.TypeSystem.DynamicPointerInstance
TwinCAT.TypeSystem.DynamicReferenceInstance
TwinCAT.TypeSystem.DynamicStructInstance
TwinCAT.TypeSystem.DynamicUnionInstance
Weiterführende Informationen
•
DynamicSymbol Properties
•
DynamicSymbol Methods
•
DynamicSymbol Events
•
DynamicSymbol Operators
•
DynamicSymbol Fields


DynamicSymbol Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties
DynamicSymbol Properties
The DynamicSymbol type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol
AccessRights | Gets the access rights.
Attributes | Gets the Symbol Attributes
BitSize | Gets the size of the IDataType in bits.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes
Category | Gets the category.
Comment | Gets the comment of the IInstance
Connection | Gets the connection bound to this DynamicSymbol
ContextMask | Gets the context mask.
DataType | Gets the IDataType of the IInstance.
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations).
InstanceName | Gets the name of the instance (without periods (.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.))
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type.
IsPersistent | Gets a value indicating whether this ISymbol is persistent.
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type.
IsReadOnly | Gets a value indicating whether this ISymbol is read only.
IsRecursive | Gets a value indicating whether this instance is recursive.
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO)
IsStatic | Gets a value indicating whether this instance is static.
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters),
NotificationSettings | Gets the notification settings.
Parent | Gets the parent Symbol
Size | Gets the size of the IInstance in bytes.
SubSymbols | Gets the SubSymbols of the ISymbol
TypeName | Gets the name of the DataType that is used for this IInstance.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbol._InnerSymbol Property
•
DynamicSymbol.AccessRights Property
•
DynamicSymbol.Attributes Property
•
DynamicSymbol.BitSize Property
•
DynamicSymbol.ByteSize Property
•
DynamicSymbol.Category Property
•
DynamicSymbol.Comment Property
•
DynamicSymbol.Connection Property
•
DynamicSymbol.ContextMask Property
•
DynamicSymbol.DataType Property
•
DynamicSymbol.HasValue Property
•
DynamicSymbol.InstanceName Property
•
DynamicSymbol.InstancePath Property
•
DynamicSymbol.IsBitType Property
•
DynamicSymbol.IsByteAligned Property
•
DynamicSymbol.IsContainerType Property
•
DynamicSymbol.IsPersistent Property
•
DynamicSymbol.IsPointer Property
•
DynamicSymbol.IsPrimitiveType Property
•
DynamicSymbol.IsReadOnly Property
•
DynamicSymbol.IsRecursive Property
•
DynamicSymbol.IsReference Property
•
DynamicSymbol.IsStatic Property
•
DynamicSymbol.NormalizedName Property
•
DynamicSymbol.NotificationSettings Property
•
DynamicSymbol.Parent Property
•
DynamicSymbol.Size Property
•
DynamicSymbol.SubSymbols Property
•
DynamicSymbol.TypeName Property


DynamicSymbol._InnerSymbol Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol._InnerSymbol Property
DynamicSymbol._InnerSymbol Property
Inner symbol object wrapped by this DynamicSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IValueSymbol _InnerSymbol { get; }
VB
Public ReadOnly Property _InnerSymbol As IValueSymbol
Get
Property Value
Type: IValueSymbol
The inner symbol.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.AccessRights Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.AccessRights Property
DynamicSymbol.AccessRights Property
Gets the access rights.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolAccessRights AccessRights { get; }
VB
Public ReadOnly Property AccessRights As SymbolAccessRights
Get
Property Value
Type: SymbolAccessRights
The access rights.
Implements
IValueSymbol.AccessRights
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.Attributes Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.Attributes Property
DynamicSymbol.Attributes Property
Gets the Symbol Attributes
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyTypeAttributeCollection Attributes { get; }
VB
Public ReadOnly Property Attributes As ReadOnlyTypeAttributeCollection
Get
Property Value
Type: ReadOnlyTypeAttributeCollection
The attributes.
Implements
IAttributedInstance.Attributes
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.BitSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.BitSize Property
DynamicSymbol.BitSize Property
Gets the size of the IDataType in bits.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int BitSize { get; }
VB
Public ReadOnly Property BitSize As Integer
Get
Property Value
Type: Int32
The size of the bit.
Implements
IBitSize.BitSize
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.ByteSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.ByteSize Property
DynamicSymbol.ByteSize Property
Gets the (aligned) size of of the Type/Instance in Bytes
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ByteSize { get; }
VB
Public ReadOnly Property ByteSize As Integer
Get
Property Value
Type: Int32
The size of the byte.
Implements
IBitSize.ByteSize
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.Category Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.Category Property
DynamicSymbol.Category Property
Gets the category.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeCategory Category { get; }
VB
Public ReadOnly Property Category As DataTypeCategory
Get
Property Value
Type: DataTypeCategory
The category.
Implements
ISymbol.Category
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.Comment Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.Comment Property
DynamicSymbol.Comment Property
Gets the comment of the IInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Comment { get; }
VB
Public ReadOnly Property Comment As String
Get
Property Value
Type: String
The comment.
Implements
IInstance.Comment
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.Connection Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.Connection Property
DynamicSymbol.Connection Property
Gets the connection bound to this DynamicSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IConnection Connection { get; }
VB
Public ReadOnly Property Connection As IConnection
Get
Property Value
Type: IConnection
The connection.
Implements
IValueSymbol2.Connection
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.ContextMask Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.ContextMask Property
DynamicSymbol.ContextMask Property
Gets the context mask.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public byte ContextMask { get; }
VB
Public ReadOnly Property ContextMask As Byte
Get
Property Value
Type: Byte
The context mask.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.DataType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.DataType Property
DynamicSymbol.DataType Property
Gets the IDataType of the IInstance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType DataType { get; }
VB
Public ReadOnly Property DataType As IDataType
Get
Property Value
Type: IDataType
The type of the data.
Implements
IInstance.DataType
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.HasValue Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.HasValue Property
DynamicSymbol.HasValue Property
Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations).
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool HasValue { get; }
VB
Public ReadOnly Property HasValue As Boolean
Get
Property Value
Type: Boolean
true if this instance has value; otherwise, false.
Implements
IValueRawSymbol.HasValue
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.InstanceName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.InstanceName Property
DynamicSymbol.InstanceName Property
Gets the name of the instance (without periods (.)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string InstanceName { get; }
VB
Public ReadOnly Property InstanceName As String
Get
Property Value
Type: String
The name of the instance.
Implements
IInstance.InstanceName
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.InstancePath Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.InstancePath Property
DynamicSymbol.InstancePath Property
Gets the relative / absolute access path to the instance (with periods (.))
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string InstancePath { get; }
VB
Public ReadOnly Property InstancePath As String
Get
Property Value
Type: String
The instance path.
Implements
IInstance.InstancePath
Remarks
If this path is relative or absolute depends on the context. IMember are using relative paths, ISymbols are using absolute ones.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.IsBitType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.IsBitType Property
DynamicSymbol.IsBitType Property
Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsBitType { get; }
VB
Public ReadOnly Property IsBitType As Boolean
Get
Property Value
Type: Boolean
true if this instance is bit mapping; otherwise, false.
Implements
IBitSize.IsBitType
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.IsByteAligned Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.IsByteAligned Property
DynamicSymbol.IsByteAligned Property
Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsByteAligned { get; }
VB
Public ReadOnly Property IsByteAligned As Boolean
Get
Property Value
Type: Boolean
true if this instance is byte aligned; otherwise, false.
Implements
IBitSize.IsByteAligned
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.IsContainerType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.IsContainerType Property
DynamicSymbol.IsContainerType Property
Gets a value indicating whether this Symbol is acontainer type.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsContainerType { get; }
VB
Public ReadOnly Property IsContainerType As Boolean
Get
Property Value
Type: Boolean
true if this instance is container type; otherwise, false.
Implements
ISymbol.IsContainerType
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.IsPersistent Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.IsPersistent Property
DynamicSymbol.IsPersistent Property
Gets a value indicating whether this ISymbol is persistent.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsPersistent { get; }
VB
Public ReadOnly Property IsPersistent As Boolean
Get
Property Value
Type: Boolean
true if this instance is persistent; otherwise, false.
Implements
ISymbol.IsPersistent
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.IsPointer Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.IsPointer Property
DynamicSymbol.IsPointer Property
Indicates that the IInstance represents a Pointer type (Pointer TO)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsPointer { get; }
VB
Public ReadOnly Property IsPointer As Boolean
Get
Property Value
Type: Boolean
true if is ReferenceTo, otherwise false.
Implements
IInstance.IsPointer
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.IsPrimitiveType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.IsPrimitiveType Property
DynamicSymbol.IsPrimitiveType Property
Gets a value indicating whether this instance is a primitive type.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsPrimitiveType { get; }
VB
Public ReadOnly Property IsPrimitiveType As Boolean
Get
Property Value
Type: Boolean
true if this instance is primitive type; otherwise, false.
Implements
ISymbol.IsPrimitiveType
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.IsReadOnly Property
DynamicSymbol.IsReadOnly Property
Gets a value indicating whether this ISymbol is read only.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if this instance is read only; otherwise, false.
Implements
ISymbol.IsReadOnly
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.IsRecursive Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.IsRecursive Property
DynamicSymbol.IsRecursive Property
Gets a value indicating whether this instance is recursive.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsRecursive { get; }
VB
Public ReadOnly Property IsRecursive As Boolean
Get
Property Value
Type: Boolean
true if this instance is recursive; otherwise, false.
Implements
ISymbol.IsRecursive
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.IsReference Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.IsReference Property
DynamicSymbol.IsReference Property
Indicates that the IInstance represents a Reference type (REFERENCE TO)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReference { get; }
VB
Public ReadOnly Property IsReference As Boolean
Get
Property Value
Type: Boolean
true if is ReferenceTo, otherwise false.
Implements
IInstance.IsReference
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.IsStatic Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.IsStatic Property
DynamicSymbol.IsStatic Property
Gets a value indicating whether this instance is static.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsStatic { get; }
VB
Public ReadOnly Property IsStatic As Boolean
Get
Property Value
Type: Boolean
true if this instance is static; otherwise, false.
Implements
IInstance.IsStatic
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.NormalizedName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.NormalizedName Property
DynamicSymbol.NormalizedName Property
Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters),
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string NormalizedName { get; }
VB
Public ReadOnly Property NormalizedName As String
Get
Property Value
Type: String
The normalized instance name (can be the same like InstanceName
Implements
IDynamicSymbol.NormalizedName
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
IInstance.InstanceName


DynamicSymbol.NotificationSettings Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.NotificationSettings Property
DynamicSymbol.NotificationSettings Property
Gets the notification settings.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public INotificationSettings NotificationSettings { get; set; }
VB
Public Property NotificationSettings As INotificationSettings
Get
Set
Property Value
Type: INotificationSettings
The notification settings.
Implements
IValueSymbol.NotificationSettings
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.Parent Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.Parent Property
DynamicSymbol.Parent Property
Gets the parent Symbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ISymbol Parent { get; }
VB
Public ReadOnly Property Parent As ISymbol
Get
Property Value
Type: ISymbol
The parent.
Implements
ISymbol.Parent
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.Size Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.Size Property
DynamicSymbol.Size Property
Gets the size of the IInstance in bytes.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Size { get; }
VB
Public ReadOnly Property Size As Integer
Get
Property Value
Type: Int32
The size of the IInstance in bytes.
Implements
IBitSize.Size
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.SubSymbols Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.SubSymbols Property
DynamicSymbol.SubSymbols Property
Gets the SubSymbols of the ISymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySymbolCollection SubSymbols { get; }
VB
Public ReadOnly Property SubSymbols As ReadOnlySymbolCollection
Get
Property Value
Type: ReadOnlySymbolCollection
Implements
ISymbol.SubSymbols
Remarks
Only used for Array and Struct instances. Otherwise empty
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.TypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Properties [image] DynamicSymbol.TypeName Property
DynamicSymbol.TypeName Property
Gets the name of the DataType that is used for this IInstance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string TypeName { get; }
VB
Public ReadOnly Property TypeName As String
Get
Property Value
Type: String
The name of the type.
Implements
IInstance.TypeName
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods
DynamicSymbol Methods
The DynamicSymbol type exposes the following members.
Methods
Name | Description
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicObject.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnReadAnyValue | Handler function for reading ADS 'Any' Values.
OnReadRawValue | Handler function for reading Raw symbol value.
OnReadValue | Handler function for the
OnSetInstanceName | Sets a new InstanceName InstancePath
OnTryReadValue | Handler function for the
OnTryWriteValue | Handler Function for writing value.
OnWriteRawValue | Handler function for reading symbols raw value.
OnWriteValue | Handler Function for writing value.
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type
ReadRawValue. | Reads the Symbols raw value
ReadRawValue(Int32) | Reads the Symbols raw value
ReadValue. | Reads the value of this DynamicSymbol.
ReadValue(Int32) | Reads the value of this DynamicSymbol.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicObject.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicObject.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol.
UpdateAnyValue | Reads the value of this Value into the specified managed value.
WriteAnyValue | Writes the value represented by the managed value to this Value
WriteRawValue(.Byte.) | Writes the Symbol raw Value
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value
WriteValue(Object) | Writes the specified value to the DynamicSymbol.
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol.
Extension Methods
Name | Description
PollValuesAnnotated(IObservable.Unit.) | Overloaded. Polls the values as ValueChangedArgs sequence annotated value on trigger sequence (Defined by ValueSymbolExtensions.)
PollValuesAnnotated(TimeSpan) | Overloaded. Polls the values as ValueChangedArgs sequence with a specified period time. (Defined by ValueSymbolExtensions.)
WhenValueChanged | Gets an observable sequence when the value of the IValueSymbol has changed. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbol.Equals Method
•
DynamicSymbol.GetDynamicMemberNames Method
•
DynamicSymbol.GetHashCode Method
•
DynamicSymbol.OnReadAnyValue Method
•
DynamicSymbol.OnReadRawValue Method
•
DynamicSymbol.OnReadValue Method
•
DynamicSymbol.OnSetInstanceName Method
•
DynamicSymbol.OnTryReadValue Method
•
DynamicSymbol.OnTryWriteValue Method
•
DynamicSymbol.OnWriteRawValue Method
•
DynamicSymbol.OnWriteValue Method
•
DynamicSymbol.ReadAnyValue Method
•
DynamicSymbol.ReadRawValue Method
•
DynamicSymbol.ReadValue Method
•
DynamicSymbol.ToString Method
•
DynamicSymbol.TryGetMember Method
•
DynamicSymbol.TryReadValue Method
•
DynamicSymbol.TryWriteValue Method
•
DynamicSymbol.UpdateAnyValue Method
•
DynamicSymbol.WriteAnyValue Method
•
DynamicSymbol.WriteRawValue Method
•
DynamicSymbol.WriteValue Method


DynamicSymbol.Equals Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.Equals Method
DynamicSymbol.Equals Method
Equals
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool Equals(
Object obj
)
VB
Public Overrides Function Equals (
obj As Object
) As Boolean
Parameters
obj
Type: System.Object
The object to compare with the current object.
Return Value
Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.GetDynamicMemberNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.GetDynamicMemberNames Method
DynamicSymbol.GetDynamicMemberNames Method
Returns the enumeration of all dynamic member names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override IEnumerable<string> GetDynamicMemberNames()
VB
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
Return Value
Type: IEnumerable.String.
A sequence that contains dynamic member names.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.GetHashCode Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.GetHashCode Method
DynamicSymbol.GetHashCode Method
Gets the HashCode of the Address
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override int GetHashCode()
VB
Public Overrides Function GetHashCode As Integer
Return Value
Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.OnReadAnyValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.OnReadAnyValue Method
DynamicSymbol.OnReadAnyValue Method
Handler function for reading ADS 'Any' Values.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual Object OnReadAnyValue(
Type managedType
)
VB
Protected Overridable Function OnReadAnyValue (
managedType As Type
) As Object
Parameters
managedType
Type: System.Type
Managed type to read.
Return Value
Type: Object
System.Object.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.OnReadRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.OnReadRawValue Method
DynamicSymbol.OnReadRawValue Method
Handler function for reading Raw symbol value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual byte[] OnReadRawValue(
int timeout
)
VB
Protected Overridable Function OnReadRawValue (
timeout As Integer
) As Byte()
Parameters
timeout
Type: System.Int32
The timeout.
Return Value
Type: .Byte.
System.Byte[].
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.OnReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.OnReadValue Method
DynamicSymbol.OnReadValue Method
Handler function for the
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual Object OnReadValue(
int timeout
)
VB
Protected Overridable Function OnReadValue (
timeout As Integer
) As Object
Parameters
timeout
Type: System.Int32
The timeout.
Return Value
Type: Object
System.Object.
Exceptions
Exception | Condition
CannotAccessVirtualSymbolException |
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.OnSetInstanceName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.OnSetInstanceName Method
DynamicSymbol.OnSetInstanceName Method
Sets a new InstanceName InstancePath
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual void OnSetInstanceName(
string instanceName
)
VB
Protected Overridable Sub OnSetInstanceName (
instanceName As String
)
Parameters
instanceName
Type: System.String
Instance name.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.OnTryReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.OnTryReadValue Method
DynamicSymbol.OnTryReadValue Method
Handler function for the
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual int OnTryReadValue(
int timeout,
out Object value
)
VB
Protected Overridable Function OnTryReadValue (
timeout As Integer,
<OutAttribute> ByRef value As Object
) As Integer
Parameters
timeout | Type: System.Int32 The timeout.
value | Type: System.Object. The value.
Return Value
Type: Int32
The error Code.
Exceptions
Exception | Condition
CannotAccessVirtualSymbolException |
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.OnTryWriteValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.OnTryWriteValue Method
DynamicSymbol.OnTryWriteValue Method
Handler Function for writing value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual int OnTryWriteValue(
Object value,
int timeout
)
VB
Protected Overridable Function OnTryWriteValue (
value As Object,
timeout As Integer
) As Integer
Parameters
value | Type: System.Object The value.
timeout | Type: System.Int32 The timeout.
Return Value
Type: Int32
Exceptions
Exception | Condition
CannotAccessVirtualSymbolException |
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.OnWriteRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.OnWriteRawValue Method
DynamicSymbol.OnWriteRawValue Method
Handler function for reading symbols raw value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual void OnWriteRawValue(
byte[] rawValue,
int timeout
)
VB
Protected Overridable Sub OnWriteRawValue (
rawValue As Byte(),
timeout As Integer
)
Parameters
rawValue | Type: .System.Byte. The raw value.
timeout | Type: System.Int32 The timeout.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.OnWriteValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.OnWriteValue Method
DynamicSymbol.OnWriteValue Method
Handler Function for writing value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual void OnWriteValue(
Object value,
int timeout
)
VB
Protected Overridable Sub OnWriteValue (
value As Object,
timeout As Integer
)
Parameters
value | Type: System.Object The value.
timeout | Type: System.Int32 The timeout.
Exceptions
Exception | Condition
CannotAccessVirtualSymbolException |
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.ReadAnyValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.ReadAnyValue Method
DynamicSymbol.ReadAnyValue Method
Reads the value of this Value into a new created instance of the managed type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadAnyValue(
Type managedType
)
VB
Public Function ReadAnyValue (
managedType As Type
) As Object
Parameters
managedType
Type: System.Type
The tp.
Return Value
Type: Object
Read value (System.Object).
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
IValueAnySymbol.WriteAnyValue(Object)
IValueAnySymbol.UpdateAnyValue(Object.)


DynamicSymbol.ReadRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.ReadRawValue Method
DynamicSymbol.ReadRawValue Method
Overload List
Name | Description
ReadRawValue. | Reads the Symbols raw value
ReadRawValue(Int32) | Reads the Symbols raw value
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbol.ReadRawValue Method
•
DynamicSymbol.ReadRawValue Method (Int32)


DynamicSymbol.ReadRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.ReadRawValue Method [image] DynamicSymbol.ReadRawValue Method
DynamicSymbol.ReadRawValue Method
Reads the Symbols raw value
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public byte[] ReadRawValue()
VB
Public Function ReadRawValue As Byte()
Field Value
Type: .Byte.
The raw value in bytes.
Return Value
Type: .Byte.
System.Byte[].
Implements
IValueRawSymbol.ReadRawValue.
Reference
DynamicSymbol Class
ReadRawValue Overload
TwinCAT.TypeSystem Namespace


DynamicSymbol.ReadRawValue Method (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.ReadRawValue Method [image] DynamicSymbol.ReadRawValue Method (Int32)
DynamicSymbol.ReadRawValue Method (Int32)
Reads the Symbols raw value
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public byte[] ReadRawValue(
int timeout
)
VB
Public Function ReadRawValue (
timeout As Integer
) As Byte()
Parameters
timeout
Type: System.Int32
The timeout in ms.
Field Value
Type: .Byte.
The raw value in bytes.
Return Value
Type: .Byte.
System.Byte[].
Implements
IValueRawSymbol.ReadRawValue(Int32)
Remarks
A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
DynamicSymbol Class
ReadRawValue Overload
TwinCAT.TypeSystem Namespace


DynamicSymbol.ReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.ReadValue Method
DynamicSymbol.ReadValue Method
Overload List
Name | Description
ReadValue. | Reads the value of this DynamicSymbol.
ReadValue(Int32) | Reads the value of this DynamicSymbol.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbol.ReadValue Method
•
DynamicSymbol.ReadValue Method (Int32)


DynamicSymbol.ReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.ReadValue Method [image] DynamicSymbol.ReadValue Method
DynamicSymbol.ReadValue Method
Reads the value of this DynamicSymbol.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadValue()
VB
Public Function ReadValue As Object
Return Value
Type: Object
System.Object.
Implements
IValueSymbol.ReadValue.
Remarks
Examples
Dynamic Read access
namespace Sample
{
using System;
using System.Diagnostics;
using System.Threading;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.Ads.TypeSystem;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

class SymbolBrowserProgramV2DynamicTree
{

#region CODE_SAMPLE_SIMPLEDYNAMIC
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
// Get the AdsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect to the target device
client.Connect(address);

// Usage of "dynamic" Type and Symbols (>= .NET4 only)
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.DynamicTree);
IAdsSymbolLoader dynLoader = (IAdsSymbolLoader)SymbolLoaderFactory.Create(client, settings);

#endregion

// Set the Default setting for Notifications
dynLoader.DefaultNotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 200, 2000);

// Get the Symbols (Dynamic Symbols)
dynamic dynamicSymbols = ((IDynamicSymbolLoader)dynLoader).SymbolsDynamic;

dynamic adsPort = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.AdsPort;

#region CODE_SAMPLE_SIMPLEDYNAMIC

// Access Main Symbol with Dynamic Language Runtime support (DLR)
// Dynamically created property "Main"
//dynamic symMain = dynamicSymbols.Main;

// Main is an 'VirtualSymbol' / Organizational unit that doesn't have a value
// Calling ReadValue is not allowed
//bool test = symMain.HasValue;
//dynamic invalid = symMain.ReadValue();

//Reading TaskInfo Value
//With calling ReadValue() a 'snapshot' of the Symbols Instance is taken
dynamic vTaskInfoArray = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo.ReadValue();

// Getting the Snapshot time in UTC format
DateTime timeStamp1 = vTaskInfoArray.UtcTimeStamp;

// Getting TaskInfo Symbol for Task 1
dynamic symTaskInfo1 = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo[1];

// Getting CycleCount Symbol
dynamic symCycleCount = symTaskInfo1.CycleCount;

// Take Snapshot value of the ApplicationInfo struct
dynamic vAppInfo = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.ReadValue();
// Get the UTC Timestamp of the snapshot

DateTime timeStamp2 = vAppInfo.UtcTimeStamp;

// Access the ProjectName of the ApplicationInfo Snapshot (type-safe!)
string projectNameValue = vAppInfo.ProjectName;

// Reading the CycleCount Value
uint cycleCountValue = symTaskInfo1.CycleCount.ReadValue(); // Taking a Value Snapshot
#endregion

// Registering for dynamic "ValueChanged" events for the Values
// Using Default Notification settings
symCycleCount.ValueChanged += new EventHandler<ValueChangedArgs>(cycleCount_ValueChanged);

// Override default notification settings
symTaskInfo1.NotificationSettings = new NotificationSettings(AdsTransMode.Cyclic,500,0);

// Register for ValueChanged event.
symTaskInfo1.ValueChanged += new EventHandler<ValueChangedArgs>(taskInfo1Value_ValueChanged); // Struct Type

Thread.Sleep(10000); // Sleep main thread for 10 Seconds
}
Console.WriteLine("CycleCount Changed events received: {0}",_cycleCountEvents);
Console.WriteLine("taskInfo1 Changed events received: {0}", _taskInfo1Events);

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}

static object _notificationSynchronizer = new object();
static int _cycleCountEvents = 0;

/// <summary>
/// Handler function for the CycleCount ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void cycleCount_ValueChanged(object sender, ValueChangedArgs e)
{
lock(_notificationSynchronizer)
{
Interlocked.Increment(ref _cycleCountEvents);
// val is a type safe value of int!
dynamic val = e.Value;
uint intVal = val;

DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert UTC to local time
Console.WriteLine("CycleCount changed to: {0}, TimeStamp: {1}", intVal, changedTime.ToString("HH:mm:ss:fff"));
}
}

static int _taskInfo1Events = 0;

/// <summary>
/// Handler function for the TaskInfo ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void taskInfo1Value_ValueChanged(object sender, ValueChangedArgs e)
{
lock (_notificationSynchronizer)
{
Interlocked.Increment(ref _taskInfo1Events);
dynamic val = e.Value;
DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert to local time

// Val is a during Runtime created struct type and contains
// the same Properties as related PLC object.
int cycleTime = val.CycleTime;
Console.WriteLine("TaskInfo1Value changed TimeStamp: {0}", changedTime.ToString("HH:mm:ss:fff"));
}
}
}
}
Reference
DynamicSymbol Class
ReadValue Overload
TwinCAT.TypeSystem Namespace


DynamicSymbol.ReadValue Method (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.ReadValue Method [image] DynamicSymbol.ReadValue Method (Int32)
DynamicSymbol.ReadValue Method (Int32)
Reads the value of this DynamicSymbol.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ReadValue(
int timeout
)
VB
Public Function ReadValue (
timeout As Integer
) As Object
Parameters
timeout
Type: System.Int32
The timeout in ms.
Field Value
Type: Object
The value.
Return Value
Type: Object
System.Object.
Implements
IValueSymbol.ReadValue(Int32)
Remarks
Calling on primitive types, a call of this method will return the primitive value. On complex types (structures and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: the raw byte Array will be returned, in dynamic mode: A Value will be created on the fly. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
DynamicSymbol Class
ReadValue Overload
TwinCAT.TypeSystem Namespace


DynamicSymbol.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.ToString Method
DynamicSymbol.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.TryGetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.TryGetMember Method
DynamicSymbol.TryGetMember Method
Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetMember(
GetMemberBinder binder,
out Object result
)
VB
Public Overrides Function TryGetMember (
binder As GetMemberBinder,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member on which the dynamic operation is performed. For example, for the Console.WriteLine(sampleObject.SampleProperty) statement, where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
result | Type: System.Object. The result of the get operation. For example, if the method is called for a property, you can assign the property value to result.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.TryReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.TryReadValue Method
DynamicSymbol.TryReadValue Method
Reads the Value of the IValueSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int TryReadValue(
int timeout,
out Object value
)
VB
Public Function TryReadValue (
timeout As Integer,
<OutAttribute> ByRef value As Object
) As Integer
Parameters
timeout | Type: System.Int32 The timeout in ms.
value | Type: System.Object. The symbol value.
Return Value
Type: Int32
The error code.
Implements
IValueSymbol3.TryReadValue(Int32, Object.)
Remarks
Calling on primitive types, a call of this method will return the primitive value. On complex types (structures and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: the raw byte Array will be returned, in dynamic mode: A Value will be created on the fly. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.TryWriteValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.TryWriteValue Method
DynamicSymbol.TryWriteValue Method
Writes the specified value to the DynamicSymbol.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int TryWriteValue(
Object value,
int timeout
)
VB
Public Function TryWriteValue (
value As Object,
timeout As Integer
) As Integer
Parameters
value | Type: System.Object The value.
timeout | Type: System.Int32 The timeout in ms.
Return Value
Type: Int32
The error code.
Implements
IValueSymbol3.TryWriteValue(Object, Int32)
Remarks
Calling on primitive types, a call of this method will directly write this Value. On complex types (structs and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: Only byte Arrays (of correct size) can be written) in dynamic mode: A Value that represents the value will be accepted also. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Examples
Dynamic Write access
namespace Sample
{
using System;
using System.Diagnostics;
using System.Threading;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.Ads.TypeSystem;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

class SymbolBrowserProgramV2DynamicTree
{

#region CODE_SAMPLE_SIMPLEDYNAMIC
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
// Get the AdsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect to the target device
client.Connect(address);

// Usage of "dynamic" Type and Symbols (>= .NET4 only)
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.DynamicTree);
IAdsSymbolLoader dynLoader = (IAdsSymbolLoader)SymbolLoaderFactory.Create(client, settings);

#endregion

// Set the Default setting for Notifications
dynLoader.DefaultNotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 200, 2000);

// Get the Symbols (Dynamic Symbols)
dynamic dynamicSymbols = ((IDynamicSymbolLoader)dynLoader).SymbolsDynamic;

dynamic adsPort = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.AdsPort;

#region CODE_SAMPLE_SIMPLEDYNAMIC

// Access Main Symbol with Dynamic Language Runtime support (DLR)
// Dynamically created property "Main"
//dynamic symMain = dynamicSymbols.Main;

// Main is an 'VirtualSymbol' / Organizational unit that doesn't have a value
// Calling ReadValue is not allowed
//bool test = symMain.HasValue;
//dynamic invalid = symMain.ReadValue();

//Reading TaskInfo Value
//With calling ReadValue() a 'snapshot' of the Symbols Instance is taken
dynamic vTaskInfoArray = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo.ReadValue();

// Getting the Snapshot time in UTC format
DateTime timeStamp1 = vTaskInfoArray.UtcTimeStamp;

// Getting TaskInfo Symbol for Task 1
dynamic symTaskInfo1 = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo[1];

// Getting CycleCount Symbol
dynamic symCycleCount = symTaskInfo1.CycleCount;

// Take Snapshot value of the ApplicationInfo struct
dynamic vAppInfo = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.ReadValue();
// Get the UTC Timestamp of the snapshot

DateTime timeStamp2 = vAppInfo.UtcTimeStamp;

// Access the ProjectName of the ApplicationInfo Snapshot (type-safe!)
string projectNameValue = vAppInfo.ProjectName;

// Reading the CycleCount Value
uint cycleCountValue = symTaskInfo1.CycleCount.ReadValue(); // Taking a Value Snapshot
#endregion

// Registering for dynamic "ValueChanged" events for the Values
// Using Default Notification settings
symCycleCount.ValueChanged += new EventHandler<ValueChangedArgs>(cycleCount_ValueChanged);

// Override default notification settings
symTaskInfo1.NotificationSettings = new NotificationSettings(AdsTransMode.Cyclic,500,0);

// Register for ValueChanged event.
symTaskInfo1.ValueChanged += new EventHandler<ValueChangedArgs>(taskInfo1Value_ValueChanged); // Struct Type

Thread.Sleep(10000); // Sleep main thread for 10 Seconds
}
Console.WriteLine("CycleCount Changed events received: {0}",_cycleCountEvents);
Console.WriteLine("taskInfo1 Changed events received: {0}", _taskInfo1Events);

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}

static object _notificationSynchronizer = new object();
static int _cycleCountEvents = 0;

/// <summary>
/// Handler function for the CycleCount ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void cycleCount_ValueChanged(object sender, ValueChangedArgs e)
{
lock(_notificationSynchronizer)
{
Interlocked.Increment(ref _cycleCountEvents);
// val is a type safe value of int!
dynamic val = e.Value;
uint intVal = val;

DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert UTC to local time
Console.WriteLine("CycleCount changed to: {0}, TimeStamp: {1}", intVal, changedTime.ToString("HH:mm:ss:fff"));
}
}

static int _taskInfo1Events = 0;

/// <summary>
/// Handler function for the TaskInfo ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void taskInfo1Value_ValueChanged(object sender, ValueChangedArgs e)
{
lock (_notificationSynchronizer)
{
Interlocked.Increment(ref _taskInfo1Events);
dynamic val = e.Value;
DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert to local time

// Val is a during Runtime created struct type and contains
// the same Properties as related PLC object.
int cycleTime = val.CycleTime;
Console.WriteLine("TaskInfo1Value changed TimeStamp: {0}", changedTime.ToString("HH:mm:ss:fff"));
}
}
}
}
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.UpdateAnyValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.UpdateAnyValue Method
DynamicSymbol.UpdateAnyValue Method
Reads the value of this Value into the specified managed value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void UpdateAnyValue(
ref Object valueObject
)
VB
Public Sub UpdateAnyValue (
ByRef valueObject As Object
)
Parameters
valueObject
Type: System.Object.
The managed object.
Return Value
Type:
Read value (System.Object).
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
IValueAnySymbol.ReadAnyValue(Type)
IValueAnySymbol.WriteAnyValue(Object)


DynamicSymbol.WriteAnyValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.WriteAnyValue Method
DynamicSymbol.WriteAnyValue Method
Writes the value represented by the managed value to this Value
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteAnyValue(
Object managedValue
)
VB
Public Sub WriteAnyValue (
managedValue As Object
)
Parameters
managedValue
Type: System.Object
The managed value.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
DynamicSymbol.ReadAnyValue(Type)
DynamicSymbol.UpdateAnyValue(Object.)


DynamicSymbol.WriteRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.WriteRawValue Method
DynamicSymbol.WriteRawValue Method
Overload List
Name | Description
WriteRawValue(.Byte.) | Writes the Symbol raw Value
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbol.WriteRawValue Method (.Byte.)
•
DynamicSymbol.WriteRawValue Method (.Byte., Int32)


DynamicSymbol.WriteRawValue Method (.Byte.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.WriteRawValue Method [image] DynamicSymbol.WriteRawValue Method (.Byte.)
DynamicSymbol.WriteRawValue Method (.Byte.)
Writes the Symbol raw Value
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteRawValue(
byte[] rawValue
)
VB
Public Sub WriteRawValue (
rawValue As Byte()
)
Parameters
rawValue
Type: .System.Byte.
The raw value.
Implements
IValueRawSymbol.WriteRawValue(.Byte.)
Reference
DynamicSymbol Class
WriteRawValue Overload
TwinCAT.TypeSystem Namespace


DynamicSymbol.WriteRawValue Method (.Byte., Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.WriteRawValue Method [image] DynamicSymbol.WriteRawValue Method (.Byte., Int32)
DynamicSymbol.WriteRawValue Method (.Byte., Int32)
Writes the Symbol raw Value
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteRawValue(
byte[] rawValue,
int timeout
)
VB
Public Sub WriteRawValue (
rawValue As Byte(),
timeout As Integer
)
Parameters
rawValue | Type: .System.Byte. The raw value.
timeout | Type: System.Int32 The timeout.
Implements
IValueRawSymbol.WriteRawValue(.Byte., Int32)
Reference
DynamicSymbol Class
WriteRawValue Overload
TwinCAT.TypeSystem Namespace


DynamicSymbol.WriteValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.WriteValue Method
DynamicSymbol.WriteValue Method
Overload List
Name | Description
WriteValue(Object) | Writes the specified value to the DynamicSymbol.
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbol.WriteValue Method (Object)
•
DynamicSymbol.WriteValue Method (Object, Int32)


DynamicSymbol.WriteValue Method (Object)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.WriteValue Method [image] DynamicSymbol.WriteValue Method (Object)
DynamicSymbol.WriteValue Method (Object)
Writes the specified value to the DynamicSymbol.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteValue(
Object value
)
VB
Public Sub WriteValue (
value As Object
)
Parameters
value
Type: System.Object
The value.
Implements
IValueSymbol.WriteValue(Object)
Remarks
Examples
Dynamic Write access
namespace Sample
{
using System;
using System.Diagnostics;
using System.Threading;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.Ads.TypeSystem;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

class SymbolBrowserProgramV2DynamicTree
{

#region CODE_SAMPLE_SIMPLEDYNAMIC
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
// Get the AdsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect to the target device
client.Connect(address);

// Usage of "dynamic" Type and Symbols (>= .NET4 only)
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.DynamicTree);
IAdsSymbolLoader dynLoader = (IAdsSymbolLoader)SymbolLoaderFactory.Create(client, settings);

#endregion

// Set the Default setting for Notifications
dynLoader.DefaultNotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 200, 2000);

// Get the Symbols (Dynamic Symbols)
dynamic dynamicSymbols = ((IDynamicSymbolLoader)dynLoader).SymbolsDynamic;

dynamic adsPort = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.AdsPort;

#region CODE_SAMPLE_SIMPLEDYNAMIC

// Access Main Symbol with Dynamic Language Runtime support (DLR)
// Dynamically created property "Main"
//dynamic symMain = dynamicSymbols.Main;

// Main is an 'VirtualSymbol' / Organizational unit that doesn't have a value
// Calling ReadValue is not allowed
//bool test = symMain.HasValue;
//dynamic invalid = symMain.ReadValue();

//Reading TaskInfo Value
//With calling ReadValue() a 'snapshot' of the Symbols Instance is taken
dynamic vTaskInfoArray = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo.ReadValue();

// Getting the Snapshot time in UTC format
DateTime timeStamp1 = vTaskInfoArray.UtcTimeStamp;

// Getting TaskInfo Symbol for Task 1
dynamic symTaskInfo1 = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo[1];

// Getting CycleCount Symbol
dynamic symCycleCount = symTaskInfo1.CycleCount;

// Take Snapshot value of the ApplicationInfo struct
dynamic vAppInfo = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.ReadValue();
// Get the UTC Timestamp of the snapshot

DateTime timeStamp2 = vAppInfo.UtcTimeStamp;

// Access the ProjectName of the ApplicationInfo Snapshot (type-safe!)
string projectNameValue = vAppInfo.ProjectName;

// Reading the CycleCount Value
uint cycleCountValue = symTaskInfo1.CycleCount.ReadValue(); // Taking a Value Snapshot
#endregion

// Registering for dynamic "ValueChanged" events for the Values
// Using Default Notification settings
symCycleCount.ValueChanged += new EventHandler<ValueChangedArgs>(cycleCount_ValueChanged);

// Override default notification settings
symTaskInfo1.NotificationSettings = new NotificationSettings(AdsTransMode.Cyclic,500,0);

// Register for ValueChanged event.
symTaskInfo1.ValueChanged += new EventHandler<ValueChangedArgs>(taskInfo1Value_ValueChanged); // Struct Type

Thread.Sleep(10000); // Sleep main thread for 10 Seconds
}
Console.WriteLine("CycleCount Changed events received: {0}",_cycleCountEvents);
Console.WriteLine("taskInfo1 Changed events received: {0}", _taskInfo1Events);

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}

static object _notificationSynchronizer = new object();
static int _cycleCountEvents = 0;

/// <summary>
/// Handler function for the CycleCount ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void cycleCount_ValueChanged(object sender, ValueChangedArgs e)
{
lock(_notificationSynchronizer)
{
Interlocked.Increment(ref _cycleCountEvents);
// val is a type safe value of int!
dynamic val = e.Value;
uint intVal = val;

DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert UTC to local time
Console.WriteLine("CycleCount changed to: {0}, TimeStamp: {1}", intVal, changedTime.ToString("HH:mm:ss:fff"));
}
}

static int _taskInfo1Events = 0;

/// <summary>
/// Handler function for the TaskInfo ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void taskInfo1Value_ValueChanged(object sender, ValueChangedArgs e)
{
lock (_notificationSynchronizer)
{
Interlocked.Increment(ref _taskInfo1Events);
dynamic val = e.Value;
DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert to local time

// Val is a during Runtime created struct type and contains
// the same Properties as related PLC object.
int cycleTime = val.CycleTime;
Console.WriteLine("TaskInfo1Value changed TimeStamp: {0}", changedTime.ToString("HH:mm:ss:fff"));
}
}
}
}
Reference
DynamicSymbol Class
WriteValue Overload
TwinCAT.TypeSystem Namespace


DynamicSymbol.WriteValue Method (Object, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Methods [image] DynamicSymbol.WriteValue Method [image] DynamicSymbol.WriteValue Method (Object, Int32)
DynamicSymbol.WriteValue Method (Object, Int32)
Writes the specified value to the DynamicSymbol.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void WriteValue(
Object value,
int timeout
)
VB
Public Sub WriteValue (
value As Object,
timeout As Integer
)
Parameters
value | Type: System.Object The value.
timeout | Type: System.Int32 The timeout in ms.
Implements
IValueSymbol.WriteValue(Object, Int32)
Remarks
Calling on primitive types, a call of this method will directly write this Value. On complex types (structs and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: Only byte Arrays (of correct size) can be written) in dynamic mode: A Value that represents the value will be accepted also. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Examples
Dynamic Write access
namespace Sample
{
using System;
using System.Diagnostics;
using System.Threading;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.Ads.TypeSystem;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

class SymbolBrowserProgramV2DynamicTree
{

#region CODE_SAMPLE_SIMPLEDYNAMIC
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
// Get the AdsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect to the target device
client.Connect(address);

// Usage of "dynamic" Type and Symbols (>= .NET4 only)
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.DynamicTree);
IAdsSymbolLoader dynLoader = (IAdsSymbolLoader)SymbolLoaderFactory.Create(client, settings);

#endregion

// Set the Default setting for Notifications
dynLoader.DefaultNotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 200, 2000);

// Get the Symbols (Dynamic Symbols)
dynamic dynamicSymbols = ((IDynamicSymbolLoader)dynLoader).SymbolsDynamic;

dynamic adsPort = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.AdsPort;

#region CODE_SAMPLE_SIMPLEDYNAMIC

// Access Main Symbol with Dynamic Language Runtime support (DLR)
// Dynamically created property "Main"
//dynamic symMain = dynamicSymbols.Main;

// Main is an 'VirtualSymbol' / Organizational unit that doesn't have a value
// Calling ReadValue is not allowed
//bool test = symMain.HasValue;
//dynamic invalid = symMain.ReadValue();

//Reading TaskInfo Value
//With calling ReadValue() a 'snapshot' of the Symbols Instance is taken
dynamic vTaskInfoArray = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo.ReadValue();

// Getting the Snapshot time in UTC format
DateTime timeStamp1 = vTaskInfoArray.UtcTimeStamp;

// Getting TaskInfo Symbol for Task 1
dynamic symTaskInfo1 = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo[1];

// Getting CycleCount Symbol
dynamic symCycleCount = symTaskInfo1.CycleCount;

// Take Snapshot value of the ApplicationInfo struct
dynamic vAppInfo = dynamicSymbols.TwinCAT_SystemInfoVarList._AppInfo.ReadValue();
// Get the UTC Timestamp of the snapshot

DateTime timeStamp2 = vAppInfo.UtcTimeStamp;

// Access the ProjectName of the ApplicationInfo Snapshot (type-safe!)
string projectNameValue = vAppInfo.ProjectName;

// Reading the CycleCount Value
uint cycleCountValue = symTaskInfo1.CycleCount.ReadValue(); // Taking a Value Snapshot
#endregion

// Registering for dynamic "ValueChanged" events for the Values
// Using Default Notification settings
symCycleCount.ValueChanged += new EventHandler<ValueChangedArgs>(cycleCount_ValueChanged);

// Override default notification settings
symTaskInfo1.NotificationSettings = new NotificationSettings(AdsTransMode.Cyclic,500,0);

// Register for ValueChanged event.
symTaskInfo1.ValueChanged += new EventHandler<ValueChangedArgs>(taskInfo1Value_ValueChanged); // Struct Type

Thread.Sleep(10000); // Sleep main thread for 10 Seconds
}
Console.WriteLine("CycleCount Changed events received: {0}",_cycleCountEvents);
Console.WriteLine("taskInfo1 Changed events received: {0}", _taskInfo1Events);

Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}

static object _notificationSynchronizer = new object();
static int _cycleCountEvents = 0;

/// <summary>
/// Handler function for the CycleCount ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void cycleCount_ValueChanged(object sender, ValueChangedArgs e)
{
lock(_notificationSynchronizer)
{
Interlocked.Increment(ref _cycleCountEvents);
// val is a type safe value of int!
dynamic val = e.Value;
uint intVal = val;

DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert UTC to local time
Console.WriteLine("CycleCount changed to: {0}, TimeStamp: {1}", intVal, changedTime.ToString("HH:mm:ss:fff"));
}
}

static int _taskInfo1Events = 0;

/// <summary>
/// Handler function for the TaskInfo ValueChanged event.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
static void taskInfo1Value_ValueChanged(object sender, ValueChangedArgs e)
{
lock (_notificationSynchronizer)
{
Interlocked.Increment(ref _taskInfo1Events);
dynamic val = e.Value;
DateTime changedTime = e.UtcRtime.ToLocalTime(); // Convert to local time

// Val is a during Runtime created struct type and contains
// the same Properties as related PLC object.
int cycleTime = val.CycleTime;
Console.WriteLine("TaskInfo1Value changed TimeStamp: {0}", changedTime.ToString("HH:mm:ss:fff"));
}
}
}
}
Reference
DynamicSymbol Class
WriteValue Overload
TwinCAT.TypeSystem Namespace


DynamicSymbol Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Events
DynamicSymbol Events
The DynamicSymbol type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed.
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbol.RawValueChanged Event
•
DynamicSymbol.ValueChanged Event


DynamicSymbol.RawValueChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Events [image] DynamicSymbol.RawValueChanged Event
DynamicSymbol.RawValueChanged Event
Occurs when the RawValue of the IValueSymbol has changed.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event EventHandler<RawValueChangedArgs> RawValueChanged
VB
Public Event RawValueChanged As EventHandler(Of RawValueChangedArgs)
Value
Type: System.EventHandler.RawValueChangedArgs.
Implements
IValueRawSymbol.RawValueChanged
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.ValueChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Events [image] DynamicSymbol.ValueChanged Event
DynamicSymbol.ValueChanged Event
Occurs when the (Primitive) value of the IValueSymbol has changed.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public event EventHandler<ValueChangedArgs> ValueChanged
VB
Public Event ValueChanged As EventHandler(Of ValueChangedArgs)
Value
Type: System.EventHandler.ValueChangedArgs.
Implements
IValueSymbol.ValueChanged
Remarks
Examples
Use Dynamic Notifications
using System;
using System.Diagnostics;
using System.Threading;
using TwinCAT;
using TwinCAT.Ads;
using TwinCAT.Ads.TypeSystem;
using TwinCAT.Ads.ValueAccess;
using TwinCAT.TypeSystem;
using TwinCAT.TypeSystem.Generic;

namespace Sample
{
class SymbolBrowserV2Notifications
{
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
// Parse the Command Line Parameters.
AmsAddress address = ArgParser.Parse(args);

#region DEFAULTNOTIFICATON_SAMPLE

// Create AdsClient object
using (TcAdsClient client = new TcAdsClient())
{
// No automatic Synchronization (necessary for Console applications without message loop)
client.Synchronize = false;

// Connect to client
client.Connect(address);

// Usage of 'dynamic' type/symbol loader
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.DynamicTree, ValueAccessMode.IndexGroupOffsetPreferred);
IAdsSymbolLoader dynLoader = (IAdsSymbolLoader)SymbolLoaderFactory.Create(client, settings);

// Set the DefaultNotification Properties
dynLoader.DefaultNotificationSettings = new NotificationSettings(AdsTransMode.ClientOnChange, 200, 2000);

// Determine the symbols
dynamic dynamicSymbols = ((IDynamicSymbolLoader)dynLoader).SymbolsDynamic;

// Task 1 Symbol (build in symbol)
dynamic task1Symbol = dynamicSymbols.TwinCAT_SystemInfoVarList._TaskInfo[1];

// CycleCount Symbol
dynamic cycleCountSymbol = task1Symbol.CycleCount;

// Override Notification Setting for Cycle Count Symbol
cycleCountSymbol.NotificationSettings = new NotificationSettings(AdsTransMode.OnChange, 250, 0);

// Register Dynamic Value Changed event.
cycleCountSymbol.ValueChanged += new EventHandler<ValueChangedArgs>(cycleCount_ValueChanged);
#endregion
// Sleep main thread to receive notifications
Thread.Sleep(10000);
#region DEFAULTNOTIFICATON_SAMPLE
}
#endregion
Console.WriteLine("CycleCount Changed events received: {0}", _cycleCountEvents);
Console.WriteLine("");
Console.WriteLine("Press [Enter] for leave:");
Console.ReadLine();
}

/// <summary>
/// The cycle count event counter
/// </summary>
static int _cycleCountEvents = 0;

/// <summary>
/// Handler function for CycleCount changed events.
/// </summary>
/// <param name="sender">Event sender.</param>
/// <param name="args">Event arguments.</param>
static void cycleCount_ValueChanged(object sender, ValueChangedArgs args)
{
Interlocked.Increment(ref _cycleCountEvents);

// Use Value as dynamic (type safe: UINT) object.
dynamic val = args.Value;
uint intVal = val;

DateTime changedTime = args.UtcRtime.ToLocalTime(); // Convert UTC to local time
Console.WriteLine("CycleCount changed to: {0}, TimeStamp: {1}", intVal, changedTime.ToString("HH:mm:ss:fff"));
}
}
}
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol Operators

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Operators
DynamicSymbol Operators
The DynamicSymbol type exposes the following members.
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbol.Equality Operator
•
DynamicSymbol.Inequality Operator


DynamicSymbol.Equality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Operators [image] DynamicSymbol.Equality Operator
DynamicSymbol.Equality Operator
Operator==
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator ==(
DynamicSymbol o1,
DynamicSymbol o2
)
VB
Public Shared Operator = (
o1 As DynamicSymbol,
o2 As DynamicSymbol
) As Boolean
Parameters
o1 | Type: TwinCAT.TypeSystem.DynamicSymbol The o1.
o2 | Type: TwinCAT.TypeSystem.DynamicSymbol The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol.Inequality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Operators [image] DynamicSymbol.Inequality Operator
DynamicSymbol.Inequality Operator
Implements the != operator.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator !=(
DynamicSymbol o1,
DynamicSymbol o2
)
VB
Public Shared Operator <> (
o1 As DynamicSymbol,
o2 As DynamicSymbol
) As Boolean
Parameters
o1 | Type: TwinCAT.TypeSystem.DynamicSymbol The o1.
o2 | Type: TwinCAT.TypeSystem.DynamicSymbol The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace


DynamicSymbol Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Fields
DynamicSymbol Fields
The DynamicSymbol type exposes the following members.
Fields
Name | Description
normalizedName | The normalized name of this .
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbol.normalizedName Field


DynamicSymbol.normalizedName Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbol Class [image] DynamicSymbol Fields [image] DynamicSymbol.normalizedName Field
DynamicSymbol.normalizedName Field
The normalized name of this .
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected string normalizedName
VB
Protected normalizedName As String
Field Value
Type: String
Reference
DynamicSymbol Class
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.DynamicSymbol


DynamicSymbolsContainer Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbolsContainer Class
DynamicSymbolsContainer Class
Dynamic (Expandable) Symbols collection.
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbolsContainer
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class DynamicSymbolsContainer : DynamicObject,
IEnumerable<ISymbol>, IEnumerable
VB
Public NotInheritable Class DynamicSymbolsContainer
Inherits DynamicObject
Implements IEnumerable(Of ISymbol), IEnumerable
The DynamicSymbolsContainer type exposes the following members.
Constructors
Name | Description
DynamicSymbolsContainer | Initializes a new instance of the DynamicSymbolsContainer class (for internal use only)
Properties
Name | Description
Item | Gets the DynamicSymbol with the specified name.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicObject.GetDynamicMemberNames..)
GetEnumerator | Gets the enumerator.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetInstance | Tries to get the IInstance. of the specified path.
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicObject.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicObject.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
Remarks
The DynamicSymbolsContainer collection adds dynamically its child Symbols as Members (for access like "Main.Symbol")
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbolsContainer Constructor
•
DynamicSymbolsContainer Properties
•
DynamicSymbolsContainer Methods


DynamicSymbolsContainer Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbolsContainer Class [image] DynamicSymbolsContainer Constructor
DynamicSymbolsContainer Constructor
Initializes a new instance of the DynamicSymbolsContainer class (for internal use only)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DynamicSymbolsContainer(
SymbolCollection<ISymbol> symbols
)
VB
Public Sub New (
symbols As SymbolCollection(Of ISymbol)
)
Parameters
symbols
Type: TwinCAT.TypeSystem.Generic.SymbolCollection.ISymbol.
The symbols.
Exceptions
Exception | Condition
ArgumentNullException | symbols
Reference
DynamicSymbolsContainer Class
TwinCAT.TypeSystem Namespace


DynamicSymbolsContainer Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbolsContainer Class [image] DynamicSymbolsContainer Properties
DynamicSymbolsContainer Properties
The DynamicSymbolsContainer type exposes the following members.
Properties
Name | Description
Item | Gets the DynamicSymbol with the specified name.
Reference
DynamicSymbolsContainer Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbolsContainer.Item Property


DynamicSymbolsContainer.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbolsContainer Class [image] DynamicSymbolsContainer Properties [image] DynamicSymbolsContainer.Item Property
DynamicSymbolsContainer.Item Property
Gets the DynamicSymbol with the specified name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DynamicSymbol this[
string name
] { get; }
VB
Public ReadOnly Default Property Item (
name As String
) As DynamicSymbol
Get
Parameters
name
Type: System.String
The name.
Return Value
Type: DynamicSymbol
DynamicSymbol.
Exceptions
Exception | Condition
KeyNotFoundException | Symbol name not found in DynamicSymbols collection!
Reference
DynamicSymbolsContainer Class
TwinCAT.TypeSystem Namespace


DynamicSymbolsContainer Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbolsContainer Class [image] DynamicSymbolsContainer Methods
DynamicSymbolsContainer Methods
The DynamicSymbolsContainer type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicObject.GetDynamicMemberNames..)
GetEnumerator | Gets the enumerator.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetInstance | Tries to get the IInstance. of the specified path.
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicObject.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicObject.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
Reference
DynamicSymbolsContainer Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicSymbolsContainer.GetDynamicMemberNames Method
•
DynamicSymbolsContainer.GetEnumerator Method
•
DynamicSymbolsContainer.TryGetInstance Method
•
DynamicSymbolsContainer.TryGetMember Method


DynamicSymbolsContainer.GetDynamicMemberNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbolsContainer Class [image] DynamicSymbolsContainer Methods [image] DynamicSymbolsContainer.GetDynamicMemberNames Method
DynamicSymbolsContainer.GetDynamicMemberNames Method
Returns the enumeration of all dynamic member names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override IEnumerable<string> GetDynamicMemberNames()
VB
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
Return Value
Type: IEnumerable.String.
A sequence that contains dynamic member names.
Reference
DynamicSymbolsContainer Class
TwinCAT.TypeSystem Namespace


DynamicSymbolsContainer.GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbolsContainer Class [image] DynamicSymbolsContainer Methods [image] DynamicSymbolsContainer.GetEnumerator Method
DynamicSymbolsContainer.GetEnumerator Method
Gets the enumerator.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<ISymbol> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of ISymbol)
Return Value
Type: IEnumerator.ISymbol.
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Reference
DynamicSymbolsContainer Class
TwinCAT.TypeSystem Namespace


DynamicSymbolsContainer.TryGetInstance Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbolsContainer Class [image] DynamicSymbolsContainer Methods [image] DynamicSymbolsContainer.TryGetInstance Method
DynamicSymbolsContainer.TryGetInstance Method
Tries to get the IInstance. of the specified path.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetInstance(
string instanceSpecifier,
out ISymbol symbol
)
VB
Public Function TryGetInstance (
instanceSpecifier As String,
<OutAttribute> ByRef symbol As ISymbol
) As Boolean
Parameters
instanceSpecifier | Type: System.String The instance path or Instance Name (dependent of Mode setting)
symbol | Type: TwinCAT.TypeSystem.ISymbol. The symbol.
Return Value
Type: Boolean
true if the IInstance is found; otherwise, false
Exceptions
Exception | Condition
ArgumentNullException | instancePath
ArgumentException |
Reference
DynamicSymbolsContainer Class
TwinCAT.TypeSystem Namespace


DynamicSymbolsContainer.TryGetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicSymbolsContainer Class [image] DynamicSymbolsContainer Methods [image] DynamicSymbolsContainer.TryGetMember Method
DynamicSymbolsContainer.TryGetMember Method
Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetMember(
GetMemberBinder binder,
out Object result
)
VB
Public Overrides Function TryGetMember (
binder As GetMemberBinder,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member on which the dynamic operation is performed. For example, for the Console.WriteLine(sampleObject.SampleProperty) statement, where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
result | Type: System.Object. The result of the get operation. For example, if the method is called for a property, you can assign the property value to result.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicSymbolsContainer Class
TwinCAT.TypeSystem Namespace


DynamicUnionInstance Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicUnionInstance Class
DynamicUnionInstance Class
Dynamic union instance
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.DynamicUnionInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class DynamicUnionInstance : DynamicSymbol,
IUnionInstance, ISymbol, IAttributedInstance, IInstance, IBitSize
VB
Public NotInheritable Class DynamicUnionInstance
Inherits DynamicSymbol
Implements IUnionInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize
The DynamicUnionInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
FieldInstances | Gets the member instances of the Struct Instance.
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicSymbol.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicSymbol.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicObject.TrySetMember(SetMemberBinder, Object).)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicUnionInstance Properties
•
DynamicUnionInstance Methods
•
DynamicUnionInstance Events


DynamicUnionInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicUnionInstance Class [image] DynamicUnionInstance Properties
DynamicUnionInstance Properties
The DynamicUnionInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
FieldInstances | Gets the member instances of the Struct Instance.
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Reference
DynamicUnionInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicUnionInstance.FieldInstances Property


DynamicUnionInstance.FieldInstances Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicUnionInstance Class [image] DynamicUnionInstance Properties [image] DynamicUnionInstance.FieldInstances Property
DynamicUnionInstance.FieldInstances Property
Gets the member instances of the Struct Instance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySymbolCollection FieldInstances { get; }
VB
Public ReadOnly Property FieldInstances As ReadOnlySymbolCollection
Get
Property Value
Type: ReadOnlySymbolCollection
The member instances.
Implements
IUnionInstance.FieldInstances
Reference
DynamicUnionInstance Class
TwinCAT.TypeSystem Namespace


DynamicUnionInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicUnionInstance Class [image] DynamicUnionInstance Methods
DynamicUnionInstance Methods
The DynamicUnionInstance type exposes the following members.
Methods
Name | Description
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicSymbol.GetDynamicMemberNames..)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicSymbol.TryGetMember(GetMemberBinder, Object.).)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicObject.TrySetMember(SetMemberBinder, Object).)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Reference
DynamicUnionInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicUnionInstance.GetDynamicMemberNames Method
•
DynamicUnionInstance.TryGetMember Method
•
DynamicUnionInstance.TrySetMember Method


DynamicUnionInstance.GetDynamicMemberNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicUnionInstance Class [image] DynamicUnionInstance Methods [image] DynamicUnionInstance.GetDynamicMemberNames Method
DynamicUnionInstance.GetDynamicMemberNames Method
Returns the enumeration of all dynamic member names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override IEnumerable<string> GetDynamicMemberNames()
VB
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
Return Value
Type: IEnumerable.String.
A sequence that contains dynamic member names.
Reference
DynamicUnionInstance Class
TwinCAT.TypeSystem Namespace


DynamicUnionInstance.TryGetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicUnionInstance Class [image] DynamicUnionInstance Methods [image] DynamicUnionInstance.TryGetMember Method
DynamicUnionInstance.TryGetMember Method
Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetMember(
GetMemberBinder binder,
out Object result
)
VB
Public Overrides Function TryGetMember (
binder As GetMemberBinder,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member on which the dynamic operation is performed. For example, for the Console.WriteLine(sampleObject.SampleProperty) statement, where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
result | Type: System.Object. The result of the get operation. For example, if the method is called for a property, you can assign the property value to result.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicUnionInstance Class
TwinCAT.TypeSystem Namespace


DynamicUnionInstance.TrySetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicUnionInstance Class [image] DynamicUnionInstance Methods [image] DynamicUnionInstance.TrySetMember Method
DynamicUnionInstance.TrySetMember Method
Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TrySetMember(
SetMemberBinder binder,
Object value
)
VB
Public Overrides Function TrySetMember (
binder As SetMemberBinder,
value As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.SetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member to which the value is being assigned. For example, for the statement sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
value | Type: System.Object The value to set to the member. For example, for sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, the value is "Test".
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.)
Reference
DynamicUnionInstance Class
TwinCAT.TypeSystem Namespace


DynamicUnionInstance Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicUnionInstance Class [image] DynamicUnionInstance Events
DynamicUnionInstance Events
The DynamicUnionInstance type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
DynamicUnionInstance Class
TwinCAT.TypeSystem Namespace


DynamicValue Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class
DynamicValue Class
Dynamic value (uses RuntimeBinding for ISymbol value reading / writing).
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicValue
TwinCAT.TypeSystem.DynamicPointerValue
TwinCAT.TypeSystem.DynamicReferenceValue
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DynamicValue : DynamicObject,
IValue, IStructValue, IArrayValue
VB
Public Class DynamicValue
Inherits DynamicObject
Implements IValue, IStructValue, IArrayValue
The DynamicValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value)
CachedRaw | Gets the cached Raw internal Data.
DataType | Gets the data type bound to this IValue
IsPrimitive | Gets a value indicating whether this IValue is a primitive value.
ResolvedType | Gets the resolved type.
Symbol | Gets the symbol that is bound to this value.
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicObject.GetDynamicMemberNames..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads the value (via ADS)
ReadMember | Reads the specified member element.
ResolveValue | Resolves the Value object to its primitive value.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Overrides DynamicObject.TryConvert(ConvertBinder, Object.).)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetArrayElementValues | Returns Array Element values.
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Overrides DynamicObject.TryGetIndex(GetIndexBinder, .Object., Object.).)
TryGetIndexValue(.Int32., Object.) | Reads the specified array element.
TryGetIndexValue(.Object., Object.) | Tries the get index value.
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicObject.TryGetMember(GetMemberBinder, Object.).)
TryGetMemberValue | Tries the get member value.
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Overrides DynamicObject.TryInvoke(InvokeBinder, .Object., Object.).)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Overrides DynamicObject.TryInvokeMember(InvokeMemberBinder, .Object., Object.).)
TryResolveValue | Tries to resolves the Value object to its primitive value.
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Overrides DynamicObject.TrySetIndex(SetIndexBinder, .Object., Object).)
TrySetIndexValue | Tries to set the indexed value on Arrays
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicObject.TrySetMember(SetMemberBinder, Object).)
TrySetMemberValue | Tries to Set a Member/Property Value
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
Write | Writes the value (via ADS)
WriteMember | Writes the specified member element.
Fields
Name | Description
_symbol | Symbol that is bound to this value.
valueFactory | The value factory
Remarks
The DynamicValue adds dynamic run time behaviour to the IValueValue/IValue. That means e.g. for struct values that .NET Properties are on-the-fly defined and dispatched at runtime just like defined in the structs structs data type definition. Another example is the access of Array Element values through indexes.
Examples
Sample for the dynamic resolution of Symbols and reading values:
Dynamic Symbol access
/// <summary>
/// Defines the entry point of the application.
/// </summary>
/// <param name="args">The arguments.</param>
static void Main(string[] args)
{
// Get the AdsAddress from command-line arguments
AmsAddress address = ArgParser.Parse(args);

using (TcAdsClient client = new TcAdsClient())
{
// Connect to the target device
client.Connect(address);

// Usage of "dynamic" Type and Symbols (>= .NET4 only)
SymbolLoaderSettings settings = new SymbolLoaderSettings(SymbolsLoadMode.DynamicTree);
IAdsSymbolLoader dynLoader = (IAdsSymbolLoader)SymbolLoaderFactory.Create(client, settings);
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.DynamicSymbol
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.IValue
Weiterführende Informationen
•
DynamicValue Properties
•
DynamicValue Methods
•
DynamicValue Fields


DynamicValue Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Properties
DynamicValue Properties
The DynamicValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value)
CachedRaw | Gets the cached Raw internal Data.
DataType | Gets the data type bound to this IValue
IsPrimitive | Gets a value indicating whether this IValue is a primitive value.
ResolvedType | Gets the resolved type.
Symbol | Gets the symbol that is bound to this value.
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value.
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicValue.Age Property
•
DynamicValue.CachedRaw Property
•
DynamicValue.DataType Property
•
DynamicValue.IsPrimitive Property
•
DynamicValue.ResolvedType Property
•
DynamicValue.Symbol Property
•
DynamicValue.UtcTimeStamp Property


DynamicValue.Age Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Properties [image] DynamicValue.Age Property
DynamicValue.Age Property
Gets the age of the value (last successful read of the value)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TimeSpan Age { get; }
VB
Public ReadOnly Property Age As TimeSpan
Get
Property Value
Type: TimeSpan
The age.
Implements
IValue.Age
Exceptions
Exception | Condition
NotImplementedException |
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace
DynamicValue.UtcTimeStamp


DynamicValue.CachedRaw Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Properties [image] DynamicValue.CachedRaw Property
DynamicValue.CachedRaw Property
Gets the cached Raw internal Data.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public byte[] CachedRaw { get; }
VB
Public ReadOnly Property CachedRaw As Byte()
Get
Property Value
Type: .Byte.
The raw cached data.
Implements
IValue.CachedRaw
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.DataType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Properties [image] DynamicValue.DataType Property
DynamicValue.DataType Property
Gets the data type bound to this IValue
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IDataType DataType { get; }
VB
Public ReadOnly Property DataType As IDataType
Get
Property Value
Type: IDataType
The type of the data.
Implements
IValue.DataType
Exceptions
Exception | Condition
NotImplementedException |
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.IsPrimitive Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Properties [image] DynamicValue.IsPrimitive Property
DynamicValue.IsPrimitive Property
Gets a value indicating whether this IValue is a primitive value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsPrimitive { get; }
VB
Public ReadOnly Property IsPrimitive As Boolean
Get
Property Value
Type: Boolean
true if this instance is primitive; otherwise, false.
Implements
IValue.IsPrimitive
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.ResolvedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Properties [image] DynamicValue.ResolvedType Property
DynamicValue.ResolvedType Property
Gets the resolved type.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected IDataType ResolvedType { get; }
VB
Protected ReadOnly Property ResolvedType As IDataType
Get
Property Value
Type: IDataType
Resolved type.
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.Symbol Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Properties [image] DynamicValue.Symbol Property
DynamicValue.Symbol Property
Gets the symbol that is bound to this value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ISymbol Symbol { get; }
VB
Public ReadOnly Property Symbol As ISymbol
Get
Property Value
Type: ISymbol
The symbol.
Implements
IValue.Symbol
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.UtcTimeStamp Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Properties [image] DynamicValue.UtcTimeStamp Property
DynamicValue.UtcTimeStamp Property
Gets the Time stamp of the last successful read of the Value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DateTime UtcTimeStamp { get; }
VB
Public ReadOnly Property UtcTimeStamp As DateTime
Get
Property Value
Type: DateTime
The read time stamp.
Implements
IValue.UtcTimeStamp
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods
DynamicValue Methods
The DynamicValue type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Overrides DynamicObject.GetDynamicMemberNames..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads the value (via ADS)
ReadMember | Reads the specified member element.
ResolveValue | Resolves the Value object to its primitive value.
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Overrides DynamicObject.TryConvert(ConvertBinder, Object.).)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetArrayElementValues | Returns Array Element values.
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Overrides DynamicObject.TryGetIndex(GetIndexBinder, .Object., Object.).)
TryGetIndexValue(.Int32., Object.) | Reads the specified array element.
TryGetIndexValue(.Object., Object.) | Tries the get index value.
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Overrides DynamicObject.TryGetMember(GetMemberBinder, Object.).)
TryGetMemberValue | Tries the get member value.
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Overrides DynamicObject.TryInvoke(InvokeBinder, .Object., Object.).)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Overrides DynamicObject.TryInvokeMember(InvokeMemberBinder, .Object., Object.).)
TryResolveValue | Tries to resolves the Value object to its primitive value.
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Overrides DynamicObject.TrySetIndex(SetIndexBinder, .Object., Object).)
TrySetIndexValue | Tries to set the indexed value on Arrays
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Overrides DynamicObject.TrySetMember(SetMemberBinder, Object).)
TrySetMemberValue | Tries to Set a Member/Property Value
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
Write | Writes the value (via ADS)
WriteMember | Writes the specified member element.
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicValue.GetDynamicMemberNames Method
•
DynamicValue.Read Method
•
DynamicValue.ReadMember Method
•
DynamicValue.ResolveValue Method
•
DynamicValue.ToString Method
•
DynamicValue.TryConvert Method
•
DynamicValue.TryGetArrayElementValues Method
•
DynamicValue.TryGetIndex Method
•
DynamicValue.TryGetIndexValue Method
•
DynamicValue.TryGetMember Method
•
DynamicValue.TryGetMemberValue Method
•
DynamicValue.TryInvoke Method
•
DynamicValue.TryInvokeMember Method
•
DynamicValue.TryResolveValue Method
•
DynamicValue.TrySetIndex Method
•
DynamicValue.TrySetIndexValue Method
•
DynamicValue.TrySetMember Method
•
DynamicValue.TrySetMemberValue Method
•
DynamicValue.Write Method
•
DynamicValue.WriteMember Method


DynamicValue.GetDynamicMemberNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.GetDynamicMemberNames Method
DynamicValue.GetDynamicMemberNames Method
Returns the enumeration of all dynamic member names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override IEnumerable<string> GetDynamicMemberNames()
VB
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
Return Value
Type: IEnumerable.String.
A sequence that contains dynamic member names.
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.Read Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.Read Method
DynamicValue.Read Method
Reads the value (via ADS)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Read()
VB
Public Sub Read
Implements
IValue.Read.
Exceptions
Exception | Condition
SymbolException |
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.ReadMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.ReadMember Method
DynamicValue.ReadMember Method
Reads the specified member element.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual Object ReadMember(
ISymbol memberInstance
)
VB
Protected Overridable Function ReadMember (
memberInstance As ISymbol
) As Object
Parameters
memberInstance
Type: TwinCAT.TypeSystem.ISymbol
The member instance.
Return Value
Type: Object
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.ResolveValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.ResolveValue Method
DynamicValue.ResolveValue Method
Resolves the Value object to its primitive value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object ResolveValue(
bool resolveEnumToPrimitive
)
VB
Public Function ResolveValue (
resolveEnumToPrimitive As Boolean
) As Object
Parameters
resolveEnumToPrimitive
Type: System.Boolean
if set to trueIEnumValues are resolved to their primitives also.
Return Value
Type: Object
System.Object.
Implements
IValue.ResolveValue(Boolean)
Remarks
If the value is not primitive, this method returns the IValue itself.
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.ToString Method
DynamicValue.ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TryConvert Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TryConvert Method
DynamicValue.TryConvert Method
Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryConvert(
ConvertBinder binder,
out Object result
)
VB
Public Overrides Function TryConvert (
binder As ConvertBinder,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.ConvertBinder Provides information about the conversion operation. The binder.Type property provides the type to which the object must be converted. For example, for the statement (String)sampleObject in C# (CType(sampleObject, Type) in Visual Basic), where sampleObject is an instance of the class derived from the DynamicObject class, binder.Type returns the String type. The binder.Explicit property provides information about the kind of conversion that occurs. It returns true for explicit conversion and false for implicit conversion.
result | Type: System.Object. The result of the type conversion operation.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.)
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TryGetArrayElementValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TryGetArrayElementValues Method
DynamicValue.TryGetArrayElementValues Method
Returns Array Element values.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetArrayElementValues(
out IEnumerable<Object> elementValues
)
VB
Public Function TryGetArrayElementValues (
<OutAttribute> ByRef elementValues As IEnumerable(Of Object)
) As Boolean
Parameters
elementValues
Type: System.Collections.Generic.IEnumerable.Object..
The element values.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Implements
IArrayValue.TryGetArrayElementValues(IEnumerable.Object..)
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TryGetIndex Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TryGetIndex Method
DynamicValue.TryGetIndex Method
Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetIndex(
GetIndexBinder binder,
Object[] indexes,
out Object result
)
VB
Public Overrides Function TryGetIndex (
binder As GetIndexBinder,
indexes As Object(),
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetIndexBinder Provides information about the operation.
indexes | Type: .System.Object. The indexes that are used in the operation. For example, for the sampleObject[3] operation in C# (sampleObject(3) in Visual Basic), where sampleObject is derived from the DynamicObject class, indexes[0] is equal to 3.
result | Type: System.Object. The result of the index operation.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TryGetIndexValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TryGetIndexValue Method
DynamicValue.TryGetIndexValue Method
Overload List
Name | Description
TryGetIndexValue(.Int32., Object.) | Reads the specified array element.
TryGetIndexValue(.Object., Object.) | Tries the get index value.
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicValue.TryGetIndexValue Method (.Int32., Object.)
•
DynamicValue.TryGetIndexValue Method (.Object., Object.)


DynamicValue.TryGetIndexValue Method (.Int32., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TryGetIndexValue Method [image] DynamicValue.TryGetIndexValue Method (.Int32., Object.)
DynamicValue.TryGetIndexValue Method (.Int32., Object.)
Reads the specified array element.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetIndexValue(
int[] indices,
out Object value
)
VB
Public Function TryGetIndexValue (
indices As Integer(),
<OutAttribute> ByRef value As Object
) As Boolean
Parameters
indices | Type: .System.Int32. The indices.
value | Type: System.Object. The value.
Return Value
Type: Boolean
System.Object.
Implements
IArrayValue.TryGetIndexValue(.Int32., Object.)
Reference
DynamicValue Class
TryGetIndexValue Overload
TwinCAT.TypeSystem Namespace


DynamicValue.TryGetIndexValue Method (.Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TryGetIndexValue Method [image] DynamicValue.TryGetIndexValue Method (.Object., Object.)
DynamicValue.TryGetIndexValue Method (.Object., Object.)
Tries the get index value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetIndexValue(
Object[] indexes,
out Object result
)
VB
Public Function TryGetIndexValue (
indexes As Object(),
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
indexes | Type: .System.Object. The indexes.
result | Type: System.Object. The result.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
DynamicValue Class
TryGetIndexValue Overload
TwinCAT.TypeSystem Namespace


DynamicValue.TryGetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TryGetMember Method
DynamicValue.TryGetMember Method
Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryGetMember(
GetMemberBinder binder,
out Object result
)
VB
Public Overrides Function TryGetMember (
binder As GetMemberBinder,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.GetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member on which the dynamic operation is performed. For example, for the Console.WriteLine(sampleObject.SampleProperty) statement, where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
result | Type: System.Object. The result of the get operation. For example, if the method is called for a property, you can assign the property value to result.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a run-time exception is thrown.)
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TryGetMemberValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TryGetMemberValue Method
DynamicValue.TryGetMemberValue Method
Tries the get member value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual bool TryGetMemberValue(
string name,
out Object result
)
VB
Public Overridable Function TryGetMemberValue (
name As String,
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
name | Type: System.String The name.
result | Type: System.Object. The result.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Implements
IStructValue.TryGetMemberValue(String, Object.)
Exceptions
Exception | Condition
SymbolException |
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TryInvoke Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TryInvoke Method
DynamicValue.TryInvoke Method
Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryInvoke(
InvokeBinder binder,
Object[] args,
out Object result
)
VB
Public Overrides Function TryInvoke (
binder As InvokeBinder,
args As Object(),
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.InvokeBinder Provides information about the invoke operation.
args | Type: .System.Object. The arguments that are passed to the object during the invoke operation. For example, for the sampleObject(100) operation, where sampleObject is derived from the DynamicObject class, args is equal to 100.
result | Type: System.Object. The result of the object invocation.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TryInvokeMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TryInvokeMember Method
DynamicValue.TryInvokeMember Method
Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TryInvokeMember(
InvokeMemberBinder binder,
Object[] args,
out Object result
)
VB
Public Overrides Function TryInvokeMember (
binder As InvokeMemberBinder,
args As Object(),
<OutAttribute> ByRef result As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.InvokeMemberBinder Provides information about the dynamic operation. The binder.Name property provides the name of the member on which the dynamic operation is performed. For example, for the statement sampleObject.SampleMethod(100), where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleMethod". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
args | Type: .System.Object. The arguments that are passed to the object member during the invoke operation. For example, for the statement sampleObject.SampleMethod(100), where sampleObject is derived from the DynamicObject class, args[0] is equal to 100.
result | Type: System.Object. The result of the member invocation.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.)
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TryResolveValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TryResolveValue Method
DynamicValue.TryResolveValue Method
Tries to resolves the Value object to its primitive value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryResolveValue(
bool resolveEnumToPrimitive,
out Object value
)
VB
Public Function TryResolveValue (
resolveEnumToPrimitive As Boolean,
<OutAttribute> ByRef value As Object
) As Boolean
Parameters
resolveEnumToPrimitive | Type: System.Boolean if set to trueIEnumValues are resolved to their primitives also.
value | Type: System.Object. The value.
Return Value
Type: Boolean
true if value can be resolved, false otherwise.
Implements
IValue.TryResolveValue(Boolean, Object.)
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TrySetIndex Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TrySetIndex Method
DynamicValue.TrySetIndex Method
Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TrySetIndex(
SetIndexBinder binder,
Object[] indexes,
Object value
)
VB
Public Overrides Function TrySetIndex (
binder As SetIndexBinder,
indexes As Object(),
value As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.SetIndexBinder Provides information about the operation.
indexes | Type: .System.Object. The indexes that are used in the operation. For example, for the sampleObject[3] = 10 operation in C# (sampleObject(3) = 10 in Visual Basic), where sampleObject is derived from the DynamicObject class, indexes[0] is equal to 3.
value | Type: System.Object The value to set to the object that has the specified index. For example, for the sampleObject[3] = 10 operation in C# (sampleObject(3) = 10 in Visual Basic), where sampleObject is derived from the DynamicObject class, value is equal to 10.
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TrySetIndexValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TrySetIndexValue Method
DynamicValue.TrySetIndexValue Method
Tries to set the indexed value on Arrays
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TrySetIndexValue(
Object[] indexes,
Object value
)
VB
Public Function TrySetIndexValue (
indexes As Object(),
value As Object
) As Boolean
Parameters
indexes | Type: .System.Object. The indexes.
value | Type: System.Object The value.
Return Value
Type: Boolean
true if succeeded, false otherwise.
Implements
IArrayValue.TrySetIndexValue(.Object., Object)
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TrySetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TrySetMember Method
DynamicValue.TrySetMember Method
Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool TrySetMember(
SetMemberBinder binder,
Object value
)
VB
Public Overrides Function TrySetMember (
binder As SetMemberBinder,
value As Object
) As Boolean
Parameters
binder | Type: System.Dynamic.SetMemberBinder Provides information about the object that called the dynamic operation. The binder.Name property provides the name of the member to which the value is being assigned. For example, for the statement sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, binder.Name returns "SampleProperty". The binder.IgnoreCase property specifies whether the member name is case-sensitive.
value | Type: System.Object The value to set to the member. For example, for sampleObject.SampleProperty = "Test", where sampleObject is an instance of the class derived from the DynamicObject class, the value is "Test".
Return Value
Type: Boolean
true if the operation is successful; otherwise, false. If this method returns false, the run-time binder of the language determines the behavior. (In most cases, a language-specific run-time exception is thrown.)
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.TrySetMemberValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.TrySetMemberValue Method
DynamicValue.TrySetMemberValue Method
Tries to Set a Member/Property Value
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TrySetMemberValue(
string name,
Object value
)
VB
Public Function TrySetMemberValue (
name As String,
value As Object
) As Boolean
Parameters
name | Type: System.String The name of the member
value | Type: System.Object The value.
Return Value
Type: Boolean
true if succeeded, otherwise false otherwise.
Implements
IStructValue.TrySetMemberValue(String, Object)
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.Write Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.Write Method
DynamicValue.Write Method
Writes the value (via ADS)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Write()
VB
Public Sub Write
Implements
IValue.Write.
Exceptions
Exception | Condition
SymbolException |
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.WriteMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Methods [image] DynamicValue.WriteMember Method
DynamicValue.WriteMember Method
Writes the specified member element.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected virtual void WriteMember(
ISymbol memberInstance,
Object value
)
VB
Protected Overridable Sub WriteMember (
memberInstance As ISymbol,
value As Object
)
Parameters
memberInstance | Type: TwinCAT.TypeSystem.ISymbol The member instance.
value | Type: System.Object The value.
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Fields
DynamicValue Fields
The DynamicValue type exposes the following members.
Fields
Name | Description
_symbol | Symbol that is bound to this value.
valueFactory | The value factory
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicValue._symbol Field
•
DynamicValue.valueFactory Field


DynamicValue._symbol Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Fields [image] DynamicValue._symbol Field
DynamicValue._symbol Field
Symbol that is bound to this value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected ISymbol _symbol
VB
Protected _symbol As ISymbol
Field Value
Type: ISymbol
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicValue.valueFactory Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicValue Class [image] DynamicValue Fields [image] DynamicValue.valueFactory Field
DynamicValue.valueFactory Field
The value factory
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected IAccessorValueFactory valueFactory
VB
Protected valueFactory As IAccessorValueFactory
Field Value
Type: IAccessorValueFactory
Reference
DynamicValue Class
TwinCAT.TypeSystem Namespace


DynamicVirtualStructInstance Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicVirtualStructInstance Class
DynamicVirtualStructInstance Class
Dynamic struct instance
Inheritance Hierarchy
System.Object
System.Dynamic.DynamicObject
TwinCAT.TypeSystem.DynamicSymbol
TwinCAT.TypeSystem.DynamicStructInstance
TwinCAT.TypeSystem.DynamicVirtualStructInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public sealed class DynamicVirtualStructInstance : DynamicStructInstance,
IVirtualStructInstance, IStructInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize
VB
Public NotInheritable Class DynamicVirtualStructInstance
Inherits DynamicStructInstance
Implements IVirtualStructInstance, IStructInstance, ISymbol, IAttributedInstance,
IInstance, IBitSize
The DynamicVirtualStructInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Inherited from DynamicStructInstance.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
MemberInstances | Gets the member instances of the Struct Instance. (Inherited from DynamicStructInstance.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Methods
Name | Description
AddMember | Adds an member instance.
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Inherited from DynamicStructInstance.)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Inherited from DynamicStructInstance.)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicStructInstance.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicVirtualStructInstance Properties
•
DynamicVirtualStructInstance Methods
•
DynamicVirtualStructInstance Events


DynamicVirtualStructInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicVirtualStructInstance Class [image] DynamicVirtualStructInstance Properties
DynamicVirtualStructInstance Properties
The DynamicVirtualStructInstance type exposes the following members.
Properties
Name | Description
_InnerSymbol | Inner symbol object wrapped by this DynamicSymbol (Inherited from DynamicSymbol.)
AccessRights | Gets the access rights. (Inherited from DynamicSymbol.)
Attributes | Gets the Symbol Attributes (Inherited from DynamicSymbol.)
BitSize | Gets the size of the IDataType in bits. (Inherited from DynamicSymbol.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from DynamicSymbol.)
Category | Gets the category. (Inherited from DynamicSymbol.)
Comment | Gets the comment of the IInstance (Inherited from DynamicSymbol.)
Connection | Gets the connection bound to this DynamicSymbol (Inherited from DynamicSymbol.)
ContextMask | Gets the context mask. (Inherited from DynamicSymbol.)
DataType | Gets the IDataType of the IInstance. (Inherited from DynamicSymbol.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Inherited from DynamicStructInstance.)
HasValue | Gets a value indicating whether this instance has value (only the non VirtualInstances, what means the Symbols with locations). (Inherited from DynamicSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from DynamicSymbol.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from DynamicSymbol.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from DynamicSymbol.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from DynamicSymbol.)
IsContainerType | Gets a value indicating whether this Symbol is acontainer type. (Inherited from DynamicSymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from DynamicSymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from DynamicSymbol.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from DynamicSymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from DynamicSymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from DynamicSymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from DynamicSymbol.)
IsStatic | Gets a value indicating whether this instance is static. (Inherited from DynamicSymbol.)
MemberInstances | Gets the member instances of the Struct Instance. (Inherited from DynamicStructInstance.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access that doesn't contain invalid characters), (Inherited from DynamicSymbol.)
NotificationSettings | Gets the notification settings. (Inherited from DynamicSymbol.)
Parent | Gets the parent Symbol (Inherited from DynamicSymbol.)
Size | Gets the size of the IInstance in bytes. (Inherited from DynamicSymbol.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from DynamicSymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from DynamicSymbol.)
Reference
DynamicVirtualStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicVirtualStructInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicVirtualStructInstance Class [image] DynamicVirtualStructInstance Methods
DynamicVirtualStructInstance Methods
The DynamicVirtualStructInstance type exposes the following members.
Methods
Name | Description
AddMember | Adds an member instance.
Equals | Equals (Inherited from DynamicSymbol.)
GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Inherited from DynamicStructInstance.)
GetHashCode | Gets the HashCode of the Address (Inherited from DynamicSymbol.)
GetMetaObject | Provides a DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from DynamicObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReadAnyValue | Reads the value of this Value into a new created instance of the managed type (Inherited from DynamicSymbol.)
ReadRawValue. | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadRawValue(Int32) | Reads the Symbols raw value (Inherited from DynamicSymbol.)
ReadValue. | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ReadValue(Int32) | Reads the value of this DynamicSymbol. (Inherited from DynamicSymbol.)
ToString | Returns a String that represents this instance. (Inherited from DynamicSymbol.)
TryBinaryOperation | Provides implementation for binary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from DynamicObject.)
TryConvert | Provides implementation for type conversion operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that convert an object from one type to another. (Inherited from DynamicObject.)
TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from DynamicObject.)
TryGetIndex | Provides the implementation for operations that get a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for indexing operations. (Inherited from DynamicObject.)
TryGetMember | Provides the implementation for operations that get member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as getting a value for a property. (Inherited from DynamicStructInstance.)
TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from DynamicObject.)
TryInvokeMember | Provides the implementation for operations that invoke a member. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as calling a method. (Inherited from DynamicObject.)
TryReadValue | Reads the Value of the IValueSymbol (Inherited from DynamicSymbol.)
TrySetIndex | Provides the implementation for operations that set a value by index. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations that access objects by a specified index. (Inherited from DynamicObject.)
TrySetMember | Provides the implementation for operations that set member values. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as setting a value for a property. (Inherited from DynamicStructInstance.)
TryUnaryOperation | Provides implementation for unary operations. Classes derived from the DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from DynamicObject.)
TryWriteValue | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
UpdateAnyValue | Reads the value of this Value into the specified managed value. (Inherited from DynamicSymbol.)
WriteAnyValue | Writes the value represented by the managed value to this Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte.) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteRawValue(.Byte., Int32) | Writes the Symbol raw Value (Inherited from DynamicSymbol.)
WriteValue(Object) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
WriteValue(Object, Int32) | Writes the specified value to the DynamicSymbol. (Inherited from DynamicSymbol.)
Reference
DynamicVirtualStructInstance Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
DynamicVirtualStructInstance.AddMember Method


DynamicVirtualStructInstance.AddMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicVirtualStructInstance Class [image] DynamicVirtualStructInstance Methods [image] DynamicVirtualStructInstance.AddMember Method
DynamicVirtualStructInstance.AddMember Method
Adds an member instance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool AddMember(
ISymbol memberInstance,
IVirtualStructInstance parent
)
VB
Public Function AddMember (
memberInstance As ISymbol,
parent As IVirtualStructInstance
) As Boolean
Parameters
memberInstance | Type: TwinCAT.TypeSystem.ISymbol The member instance.
parent | Type: TwinCAT.TypeSystem.IVirtualStructInstance The parent struct instance. Usually the this pointer.
Return Value
Type: Boolean
Implements
IVirtualStructInstance.AddMember(ISymbol, IVirtualStructInstance)
Reference
DynamicVirtualStructInstance Class
TwinCAT.TypeSystem Namespace


DynamicVirtualStructInstance Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] DynamicVirtualStructInstance Class [image] DynamicVirtualStructInstance Events
DynamicVirtualStructInstance Events
The DynamicVirtualStructInstance type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from DynamicSymbol.)
Reference
DynamicVirtualStructInstance Class
TwinCAT.TypeSystem Namespace


EnumValue.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValue.T. Class
EnumValue.T. Class
Enum Value
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.EnumValue.T.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class EnumValue<T> : IEnumValue
where T : IConvertible
VB
Public Class EnumValue(Of T As IConvertible)
Implements IEnumValue
Type Parameters
T
Enum base type (byte,sbyte,short,ushort,int,uint,long or ulong)
The EnumValue.T. type exposes the following members.
Properties
Name | Description
ManagedBaseType | Gets the enumeration base type (sint,byte,short,ushort,int,uint,Int64,UInt64 supported)
Name | Gets the name of the Enum Value
Primitive | Gets the value.
RawValue | Gets the raw value of the enumeration (as byte array)
Size | Gets the size of the Enum value (in bytes)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parse Enum Type string
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryParse | Parse EnumType string
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValue.T. Properties
•
EnumValue.T. Methods


EnumValue.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValue.T. Class [image] EnumValue.T. Properties
EnumValue.T. Properties
The EnumValue.T. generic type exposes the following members.
Properties
Name | Description
ManagedBaseType | Gets the enumeration base type (sint,byte,short,ushort,int,uint,Int64,UInt64 supported)
Name | Gets the name of the Enum Value
Primitive | Gets the value.
RawValue | Gets the raw value of the enumeration (as byte array)
Size | Gets the size of the Enum value (in bytes)
Reference
EnumValue.T. Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValue.T..ManagedBaseType Property
•
EnumValue.T..Name Property
•
EnumValue.T..Primitive Property
•
EnumValue.T..RawValue Property
•
EnumValue.T..Size Property


EnumValue.T..ManagedBaseType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValue.T. Class [image] EnumValue.T. Properties [image] EnumValue.T..ManagedBaseType Property
EnumValue.T..ManagedBaseType Property
Gets the enumeration base type (sint,byte,short,ushort,int,uint,Int64,UInt64 supported)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Type ManagedBaseType { get; }
VB
Public ReadOnly Property ManagedBaseType As Type
Get
Property Value
Type: Type
The type of the base.
Implements
IEnumValue.ManagedBaseType
Reference
EnumValue.T. Class
TwinCAT.TypeSystem Namespace


EnumValue.T..Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValue.T. Class [image] EnumValue.T. Properties [image] EnumValue.T..Name Property
EnumValue.T..Name Property
Gets the name of the Enum Value
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Name { get; }
VB
Public ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Implements
IEnumValue.Name
Reference
EnumValue.T. Class
TwinCAT.TypeSystem Namespace


EnumValue.T..Primitive Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValue.T. Class [image] EnumValue.T. Properties [image] EnumValue.T..Primitive Property
EnumValue.T..Primitive Property
Gets the value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T Primitive { get; }
VB
Public ReadOnly Property Primitive As T
Get
Property Value
Type: T
The value.
Reference
EnumValue.T. Class
TwinCAT.TypeSystem Namespace


EnumValue.T..RawValue Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValue.T. Class [image] EnumValue.T. Properties [image] EnumValue.T..RawValue Property
EnumValue.T..RawValue Property
Gets the raw value of the enumeration (as byte array)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public byte[] RawValue { get; }
VB
Public ReadOnly Property RawValue As Byte()
Get
Property Value
Type: .Byte.
The raw value.
Implements
IEnumValue.RawValue
Exceptions
Exception | Condition
NotSupportedException | Base type of enum is not allowed!
Reference
EnumValue.T. Class
TwinCAT.TypeSystem Namespace


EnumValue.T..Size Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValue.T. Class [image] EnumValue.T. Properties [image] EnumValue.T..Size Property
EnumValue.T..Size Property
Gets the size of the Enum value (in bytes)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Size { get; }
VB
Public ReadOnly Property Size As Integer
Get
Property Value
Type: Int32
The size.
Implements
IEnumValue.Size
Reference
EnumValue.T. Class
TwinCAT.TypeSystem Namespace


EnumValue.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValue.T. Class [image] EnumValue.T. Methods
EnumValue.T. Methods
The EnumValue.T. generic type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parse Enum Type string
ToString | Returns a String that represents this instance. (Overrides Object.ToString..)
TryParse | Parse EnumType string
Reference
EnumValue.T. Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValue.T..Parse Method
•
EnumValue.T..ToString Method
•
EnumValue.T..TryParse Method


EnumValue.T..Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValue.T. Class [image] EnumValue.T. Methods [image] EnumValue.T..Parse Method
EnumValue.T..Parse Method
Parse Enum Type string
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static EnumValue<T> Parse(
IEnumType<T> type,
string str
)
VB
Public Shared Function Parse (
type As IEnumType(Of T),
str As String
) As EnumValue(Of T)
Parameters
type | Type: TwinCAT.TypeSystem.IEnumType.T. The type.
str | Type: System.String The string.
Return Value
Type: EnumValue.T.
EnumValue<T>.
Exceptions
Exception | Condition
FormatException |
Reference
EnumValue.T. Class
TwinCAT.TypeSystem Namespace


EnumValue.T..ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValue.T. Class [image] EnumValue.T. Methods [image] EnumValue.T..ToString Method
EnumValue.T..ToString Method
Returns a String that represents this instance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override string ToString()
VB
Public Overrides Function ToString As String
Return Value
Type: String
A String that represents this instance.
Reference
EnumValue.T. Class
TwinCAT.TypeSystem Namespace


EnumValue.T..TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValue.T. Class [image] EnumValue.T. Methods [image] EnumValue.T..TryParse Method
EnumValue.T..TryParse Method
Parse EnumType string
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool TryParse(
IEnumType<T> type,
string str,
out EnumValue<T> value
)
VB
Public Shared Function TryParse (
type As IEnumType(Of T),
str As String,
<OutAttribute> ByRef value As EnumValue(Of T)
) As Boolean
Parameters
type | Type: TwinCAT.TypeSystem.IEnumType.T. The type.
str | Type: System.String The string.
value | Type: TwinCAT.TypeSystem.EnumValue.T.. The value.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
EnumValue.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class
EnumValueCollection Class
Class EnumValueCollection.
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.EnumValueCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class EnumValueCollection : IList<IEnumValue>,
ICollection<IEnumValue>, IEnumerable<IEnumValue>, IEnumerable
VB
Public Class EnumValueCollection
Implements IList(Of IEnumValue), ICollection(Of IEnumValue),
IEnumerable(Of IEnumValue), IEnumerable
The EnumValueCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets or sets the element at the specified index.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Gets as read only.
Clear | Removes all items from the ICollection.T..
Contains(Object) | Determines whether [contains] [the specified value].
Contains(String) | Determines whether [contains] [the specified name].
Contains(IEnumValue) | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies the entire list.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetNames | Gets the names.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Gets the values.
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parses the specified string to the Enum value.
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInfo | Tries the get information.
TryParse | Parse the specified string to the enum value.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValueCollection Properties
•
EnumValueCollection Methods


EnumValueCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Properties
EnumValueCollection Properties
The EnumValueCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets or sets the element at the specified index.
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValueCollection.Count Property
•
EnumValueCollection.IsReadOnly Property
•
EnumValueCollection.Item Property


EnumValueCollection.Count Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Properties [image] EnumValueCollection.Count Property
EnumValueCollection.Count Property
Gets the number of elements contained in the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Count { get; }
VB
Public ReadOnly Property Count As Integer
Get
Property Value
Type: Int32
The count.
Implements
ICollection.T..Count
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Properties [image] EnumValueCollection.IsReadOnly Property
EnumValueCollection.IsReadOnly Property
Gets a value indicating whether the ICollection.T. is read-only.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if this instance is read only; otherwise, false.
Implements
ICollection.T..IsReadOnly
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Properties [image] EnumValueCollection.Item Property
EnumValueCollection.Item Property
Overload List
Name | Description
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets or sets the element at the specified index.
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValueCollection.Item Property (Int32)
•
EnumValueCollection.Item Property (String)


EnumValueCollection.Item Property (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Properties [image] EnumValueCollection.Item Property [image] EnumValueCollection.Item Property (Int32)
EnumValueCollection.Item Property (Int32)
Gets or sets the element at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumValue this[
int index
] { get; set; }
VB
Public Default Property Item (
index As Integer
) As IEnumValue
Get
Set
Parameters
index
Type: System.Int32
The index.
Return Value
Type: IEnumValue
EnumValue<T>.
Implements
IList.T..Item.Int32.
Exceptions
Exception | Condition
NotImplementedException |
Reference
EnumValueCollection Class
Item Overload
TwinCAT.TypeSystem Namespace


EnumValueCollection.Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Properties [image] EnumValueCollection.Item Property [image] EnumValueCollection.Item Property (String)
EnumValueCollection.Item Property (String)
Gets or sets the element at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumValue this[
string name
] { get; }
VB
Public ReadOnly Default Property Item (
name As String
) As IEnumValue
Get
Parameters
name
Type: System.String
The name of the value
Return Value
Type: IEnumValue
EnumValue<T>.
Exceptions
Exception | Condition
NotImplementedException |
NotImplementedException |
Reference
EnumValueCollection Class
Item Overload
TwinCAT.TypeSystem Namespace


EnumValueCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods
EnumValueCollection Methods
The EnumValueCollection type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Gets as read only.
Clear | Removes all items from the ICollection.T..
Contains(Object) | Determines whether [contains] [the specified value].
Contains(String) | Determines whether [contains] [the specified name].
Contains(IEnumValue) | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies the entire list.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetNames | Gets the names.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Gets the values.
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parses the specified string to the Enum value.
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInfo | Tries the get information.
TryParse | Parse the specified string to the enum value.
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValueCollection.Add Method
•
EnumValueCollection.AsReadOnly Method
•
EnumValueCollection.Clear Method
•
EnumValueCollection.Contains Method
•
EnumValueCollection.CopyTo Method
•
EnumValueCollection.GetEnumerator Method
•
EnumValueCollection.GetNames Method
•
EnumValueCollection.GetValues Method
•
EnumValueCollection.IndexOf Method
•
EnumValueCollection.Insert Method
•
EnumValueCollection.Parse Method
•
EnumValueCollection.Remove Method
•
EnumValueCollection.RemoveAt Method
•
EnumValueCollection.TryGetInfo Method
•
EnumValueCollection.TryParse Method


EnumValueCollection.Add Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.Add Method
EnumValueCollection.Add Method
Adds an item to the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Add(
IEnumValue item
)
VB
Public Sub Add (
item As IEnumValue
)
Parameters
item
Type: TwinCAT.TypeSystem.IEnumValue
The object to add to the ICollection.T..
Implements
ICollection.T..Add(T)
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.AsReadOnly Method
EnumValueCollection.AsReadOnly Method
Gets as read only.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyEnumValueCollection AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlyEnumValueCollection
Field Value
Type: ReadOnlyEnumValueCollection
As read only.
Return Value
Type: ReadOnlyEnumValueCollection
ReadOnlyEnumValueCollection.
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.Clear Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.Clear Method
EnumValueCollection.Clear Method
Removes all items from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Clear()
VB
Public Sub Clear
Implements
ICollection.T..Clear.
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.Contains Method
EnumValueCollection.Contains Method
Overload List
Name | Description
Contains(Object) | Determines whether [contains] [the specified value].
Contains(String) | Determines whether [contains] [the specified name].
Contains(IEnumValue) | Determines whether the ICollection.T. contains a specific value.
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValueCollection.Contains Method (Object)
•
EnumValueCollection.Contains Method (String)
•
EnumValueCollection.Contains Method (IEnumValue)


EnumValueCollection.Contains Method (Object)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.Contains Method [image] EnumValueCollection.Contains Method (Object)
EnumValueCollection.Contains Method (Object)
Determines whether [contains] [the specified value].
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
Object value
)
VB
Public Function Contains (
value As Object
) As Boolean
Parameters
value
Type: System.Object
The value.
Return Value
Type: Boolean
true if [contains] [the specified value]; otherwise, false.
Reference
EnumValueCollection Class
Contains Overload
TwinCAT.TypeSystem Namespace


EnumValueCollection.Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.Contains Method [image] EnumValueCollection.Contains Method (String)
EnumValueCollection.Contains Method (String)
Determines whether [contains] [the specified name].
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string name
)
VB
Public Function Contains (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if [contains] [the specified name]; otherwise, false.
Reference
EnumValueCollection Class
Contains Overload
TwinCAT.TypeSystem Namespace


EnumValueCollection.Contains Method (IEnumValue)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.Contains Method [image] EnumValueCollection.Contains Method (IEnumValue)
EnumValueCollection.Contains Method (IEnumValue)
Determines whether the ICollection.T. contains a specific value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
IEnumValue item
)
VB
Public Function Contains (
item As IEnumValue
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.IEnumValue
The object to locate in the ICollection.T..
Return Value
Type: Boolean
true if item is found in the ICollection.T.; otherwise, false.
Implements
ICollection.T..Contains(T)
Reference
EnumValueCollection Class
Contains Overload
TwinCAT.TypeSystem Namespace


EnumValueCollection.CopyTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.CopyTo Method
EnumValueCollection.CopyTo Method
Copies the entire list.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void CopyTo(
IEnumValue[] array,
int arrayIndex
)
VB
Public Sub CopyTo (
array As IEnumValue(),
arrayIndex As Integer
)
Parameters
array | Type: .TwinCAT.TypeSystem.IEnumValue. The array.
arrayIndex | Type: System.Int32 Index of the array.
Implements
ICollection.T..CopyTo(.T., Int32)
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.GetEnumerator Method
EnumValueCollection.GetEnumerator Method
Returns an enumerator that iterates through the collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<IEnumValue> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of IEnumValue)
Return Value
Type: IEnumerator.IEnumValue.
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.GetNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.GetNames Method
EnumValueCollection.GetNames Method
Gets the names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string[] GetNames()
VB
Public Function GetNames As String()
Return Value
Type: .String.
System.String[].
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.GetValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.GetValues Method
EnumValueCollection.GetValues Method
Gets the values.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object[] GetValues()
VB
Public Function GetValues As Object()
Return Value
Type: .Object.
T[].
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.IndexOf Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.IndexOf Method
EnumValueCollection.IndexOf Method
Determines the index of a specific item in the IList.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int IndexOf(
IEnumValue item
)
VB
Public Function IndexOf (
item As IEnumValue
) As Integer
Parameters
item
Type: TwinCAT.TypeSystem.IEnumValue
The object to locate in the IList.T..
Return Value
Type: Int32
The index of item if found in the list; otherwise, -1.
Implements
IList.T..IndexOf(T)
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.Insert Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.Insert Method
EnumValueCollection.Insert Method
Inserts an item to the IList.T. at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Insert(
int index,
IEnumValue item
)
VB
Public Sub Insert (
index As Integer,
item As IEnumValue
)
Parameters
index | Type: System.Int32 The zero-based index at which item should be inserted.
item | Type: TwinCAT.TypeSystem.IEnumValue The object to insert into the IList.T..
Implements
IList.T..Insert(Int32, T)
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.Parse Method
EnumValueCollection.Parse Method
Parses the specified string to the Enum value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object Parse(
string name
)
VB
Public Function Parse (
name As String
) As Object
Parameters
name
Type: System.String
The name.
Return Value
Type: Object
T.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | name
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.Remove Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.Remove Method
EnumValueCollection.Remove Method
Removes the first occurrence of a specific object from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Remove(
IEnumValue item
)
VB
Public Function Remove (
item As IEnumValue
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.IEnumValue
The object to remove from the ICollection.T..
Return Value
Type: Boolean
true if item was successfully removed from the ICollection.T.; otherwise, false. This method also returns false if item is not found in the original ICollection.T..
Implements
ICollection.T..Remove(T)
Exceptions
Exception | Condition
NotImplementedException |
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.RemoveAt Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.RemoveAt Method
EnumValueCollection.RemoveAt Method
Removes the IList.T. item at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void RemoveAt(
int index
)
VB
Public Sub RemoveAt (
index As Integer
)
Parameters
index
Type: System.Int32
The zero-based index of the item to remove.
Implements
IList.T..RemoveAt(Int32)
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.TryGetInfo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.TryGetInfo Method
EnumValueCollection.TryGetInfo Method
Tries the get information.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetInfo(
Object val,
out IEnumValue ei
)
VB
Public Function TryGetInfo (
val As Object,
<OutAttribute> ByRef ei As IEnumValue
) As Boolean
Parameters
val | Type: System.Object The value.
ei | Type: TwinCAT.TypeSystem.IEnumValue. The ei.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection Class [image] EnumValueCollection Methods [image] EnumValueCollection.TryParse Method
EnumValueCollection.TryParse Method
Parse the specified string to the enum value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryParse(
string name,
out Object value
)
VB
Public Function TryParse (
name As String,
<OutAttribute> ByRef value As Object
) As Boolean
Parameters
name | Type: System.String The name.
value | Type: System.Object. The value.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
EnumValueCollection Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class
EnumValueCollection.T. Class
Collection of EnumValues
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.EnumValueCollection.T.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class EnumValueCollection<T> : IList<EnumValue<T>>,
ICollection<EnumValue<T>>, IEnumerable<EnumValue<T>>, IEnumerable
where T : IConvertible
VB
Public Class EnumValueCollection(Of T As IConvertible)
Implements IList(Of EnumValue(Of T)), ICollection(Of EnumValue(Of T)),
IEnumerable(Of EnumValue(Of T)), IEnumerable
Type Parameters
T
Base type of enum
The EnumValueCollection.T. type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item | Gets or sets the element at the specified index.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Gets as read only.
Clear | Removes all items from the ICollection.T..
Contains(String) | Determines whether [contains] [the specified name].
Contains(T) | Determines whether [contains] [the specified value].
Contains(EnumValue.T.) | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies the entire list.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetNames | Gets the names.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Gets the values.
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parses the specified string to the Enum value.
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInfo | Tries the get information.
TryParse | Parse the specified string to the enum value.
Operators
Name | Description
.(EnumValueCollection.T. to EnumValueCollection) | Performs an explicit conversion from EnumValueCollection.T. to EnumValueCollection.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValueCollection.T. Properties
•
EnumValueCollection.T. Methods
•
EnumValueCollection.T. Type Conversions


EnumValueCollection.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Properties
EnumValueCollection.T. Properties
The EnumValueCollection.T. generic type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item | Gets or sets the element at the specified index.
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValueCollection.T..Count Property
•
EnumValueCollection.T..IsReadOnly Property
•
EnumValueCollection.T..Item Property


EnumValueCollection.T..Count Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Properties [image] EnumValueCollection.T..Count Property
EnumValueCollection.T..Count Property
Gets the number of elements contained in the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Count { get; }
VB
Public ReadOnly Property Count As Integer
Get
Property Value
Type: Int32
The count.
Implements
ICollection.T..Count
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Properties [image] EnumValueCollection.T..IsReadOnly Property
EnumValueCollection.T..IsReadOnly Property
Gets a value indicating whether the ICollection.T. is read-only.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if this instance is read only; otherwise, false.
Implements
ICollection.T..IsReadOnly
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Properties [image] EnumValueCollection.T..Item Property
EnumValueCollection.T..Item Property
Gets or sets the element at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public EnumValue<T> this[
int index
] { get; set; }
VB
Public Default Property Item (
index As Integer
) As EnumValue(Of T)
Get
Set
Parameters
index
Type: System.Int32
The index.
Return Value
Type: EnumValue.T.
EnumValue<T>.
Implements
IList.T..Item.Int32.
Exceptions
Exception | Condition
NotImplementedException |
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods
EnumValueCollection.T. Methods
The EnumValueCollection.T. generic type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Gets as read only.
Clear | Removes all items from the ICollection.T..
Contains(String) | Determines whether [contains] [the specified name].
Contains(T) | Determines whether [contains] [the specified value].
Contains(EnumValue.T.) | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies the entire list.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetNames | Gets the names.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Gets the values.
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parses the specified string to the Enum value.
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInfo | Tries the get information.
TryParse | Parse the specified string to the enum value.
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValueCollection.T..Add Method
•
EnumValueCollection.T..AsReadOnly Method
•
EnumValueCollection.T..Clear Method
•
EnumValueCollection.T..Contains Method
•
EnumValueCollection.T..CopyTo Method
•
EnumValueCollection.T..GetEnumerator Method
•
EnumValueCollection.T..GetNames Method
•
EnumValueCollection.T..GetValues Method
•
EnumValueCollection.T..IndexOf Method
•
EnumValueCollection.T..Insert Method
•
EnumValueCollection.T..Parse Method
•
EnumValueCollection.T..Remove Method
•
EnumValueCollection.T..RemoveAt Method
•
EnumValueCollection.T..TryGetInfo Method
•
EnumValueCollection.T..TryParse Method


EnumValueCollection.T..Add Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..Add Method
EnumValueCollection.T..Add Method
Adds an item to the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Add(
EnumValue<T> item
)
VB
Public Sub Add (
item As EnumValue(Of T)
)
Parameters
item
Type: TwinCAT.TypeSystem.EnumValue.T.
The object to add to the ICollection.T..
Implements
ICollection.T..Add(T)
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..AsReadOnly Method
EnumValueCollection.T..AsReadOnly Method
Gets as read only.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyEnumValueCollection<T> AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlyEnumValueCollection(Of T)
Field Value
Type: ReadOnlyEnumValueCollection.T.
As read only.
Return Value
Type: ReadOnlyEnumValueCollection.T.
ReadOnlyEnumValueCollection<T>.
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..Clear Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..Clear Method
EnumValueCollection.T..Clear Method
Removes all items from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Clear()
VB
Public Sub Clear
Implements
ICollection.T..Clear.
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..Contains Method
EnumValueCollection.T..Contains Method
Overload List
Name | Description
Contains(String) | Determines whether [contains] [the specified name].
Contains(T) | Determines whether [contains] [the specified value].
Contains(EnumValue.T.) | Determines whether the ICollection.T. contains a specific value.
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValueCollection.T..Contains Method (String)
•
EnumValueCollection.T..Contains Method (T)
•
EnumValueCollection.T..Contains Method (EnumValue.T.)


EnumValueCollection.T..Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..Contains Method [image] EnumValueCollection.T..Contains Method (String)
EnumValueCollection.T..Contains Method (String)
Determines whether [contains] [the specified name].
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string name
)
VB
Public Function Contains (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if [contains] [the specified name]; otherwise, false.
Reference
EnumValueCollection.T. Class
Contains Overload
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..Contains Method (T)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..Contains Method [image] EnumValueCollection.T..Contains Method (T)
EnumValueCollection.T..Contains Method (T)
Determines whether [contains] [the specified value].
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
T value
)
VB
Public Function Contains (
value As T
) As Boolean
Parameters
value
Type: T
The value.
Return Value
Type: Boolean
true if [contains] [the specified value]; otherwise, false.
Reference
EnumValueCollection.T. Class
Contains Overload
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..Contains Method (EnumValue.T.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..Contains Method [image] EnumValueCollection.T..Contains Method (EnumValue.T.)
EnumValueCollection.T..Contains Method (EnumValue.T.)
Determines whether the ICollection.T. contains a specific value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
EnumValue<T> item
)
VB
Public Function Contains (
item As EnumValue(Of T)
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.EnumValue.T.
The object to locate in the ICollection.T..
Return Value
Type: Boolean
true if item is found in the ICollection.T.; otherwise, false.
Implements
ICollection.T..Contains(T)
Reference
EnumValueCollection.T. Class
Contains Overload
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..CopyTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..CopyTo Method
EnumValueCollection.T..CopyTo Method
Copies the entire list.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void CopyTo(
EnumValue<T>[] array,
int arrayIndex
)
VB
Public Sub CopyTo (
array As EnumValue(Of T)(),
arrayIndex As Integer
)
Parameters
array | Type: .TwinCAT.TypeSystem.EnumValue.T.. The array.
arrayIndex | Type: System.Int32 Index of the array.
Implements
ICollection.T..CopyTo(.T., Int32)
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..GetEnumerator Method
EnumValueCollection.T..GetEnumerator Method
Returns an enumerator that iterates through the collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<EnumValue<T>> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of EnumValue(Of T))
Return Value
Type: IEnumerator.EnumValue.T..
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..GetNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..GetNames Method
EnumValueCollection.T..GetNames Method
Gets the names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string[] GetNames()
VB
Public Function GetNames As String()
Return Value
Type: .String.
System.String[].
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..GetValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..GetValues Method
EnumValueCollection.T..GetValues Method
Gets the values.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T[] GetValues()
VB
Public Function GetValues As T()
Return Value
Type: .T.
T[].
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..IndexOf Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..IndexOf Method
EnumValueCollection.T..IndexOf Method
Determines the index of a specific item in the IList.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int IndexOf(
EnumValue<T> item
)
VB
Public Function IndexOf (
item As EnumValue(Of T)
) As Integer
Parameters
item
Type: TwinCAT.TypeSystem.EnumValue.T.
The object to locate in the IList.T..
Return Value
Type: Int32
The index of item if found in the list; otherwise, -1.
Implements
IList.T..IndexOf(T)
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..Insert Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..Insert Method
EnumValueCollection.T..Insert Method
Inserts an item to the IList.T. at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Insert(
int index,
EnumValue<T> item
)
VB
Public Sub Insert (
index As Integer,
item As EnumValue(Of T)
)
Parameters
index | Type: System.Int32 The zero-based index at which item should be inserted.
item | Type: TwinCAT.TypeSystem.EnumValue.T. The object to insert into the IList.T..
Implements
IList.T..Insert(Int32, T)
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..Parse Method
EnumValueCollection.T..Parse Method
Parses the specified string to the Enum value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T Parse(
string name
)
VB
Public Function Parse (
name As String
) As T
Parameters
name
Type: System.String
The name.
Return Value
Type: T
T.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | name
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..Remove Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..Remove Method
EnumValueCollection.T..Remove Method
Removes the first occurrence of a specific object from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Remove(
EnumValue<T> item
)
VB
Public Function Remove (
item As EnumValue(Of T)
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.EnumValue.T.
The object to remove from the ICollection.T..
Return Value
Type: Boolean
true if item was successfully removed from the ICollection.T.; otherwise, false. This method also returns false if item is not found in the original ICollection.T..
Implements
ICollection.T..Remove(T)
Exceptions
Exception | Condition
NotImplementedException |
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..RemoveAt Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..RemoveAt Method
EnumValueCollection.T..RemoveAt Method
Removes the IList.T. item at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void RemoveAt(
int index
)
VB
Public Sub RemoveAt (
index As Integer
)
Parameters
index
Type: System.Int32
The zero-based index of the item to remove.
Implements
IList.T..RemoveAt(Int32)
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..TryGetInfo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..TryGetInfo Method
EnumValueCollection.T..TryGetInfo Method
Tries the get information.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetInfo(
T val,
out EnumValue<T> ei
)
VB
Public Function TryGetInfo (
val As T,
<OutAttribute> ByRef ei As EnumValue(Of T)
) As Boolean
Parameters
val | Type: T The value.
ei | Type: TwinCAT.TypeSystem.EnumValue.T.. The ei.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T..TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Methods [image] EnumValueCollection.T..TryParse Method
EnumValueCollection.T..TryParse Method
Parse the specified string to the enum value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryParse(
string name,
out T value
)
VB
Public Function TryParse (
name As String,
<OutAttribute> ByRef value As T
) As Boolean
Parameters
name | Type: System.String The name.
value | Type: T. The value.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


EnumValueCollection.T. Type Conversions

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Type Conversions
EnumValueCollection.T. Type Conversions
The EnumValueCollection.T. generic type exposes the following members.
Operators
Name | Description
.(EnumValueCollection.T. to EnumValueCollection) | Performs an explicit conversion from EnumValueCollection.T. to EnumValueCollection.
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
EnumValueCollection.T. . Conversion (EnumValueCollection.T. to EnumValueCollection)


EnumValueCollection.T. . Conversion (EnumValueCollection.T. to EnumValueCollection)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] EnumValueCollection.T. Class [image] EnumValueCollection.T. Type Conversions [image] EnumValueCollection.T. . Conversion (EnumValueCollection.T. to EnumValueCollection)
EnumValueCollection.T. . Conversion (EnumValueCollection.T. to EnumValueCollection)
Performs an explicit conversion from EnumValueCollection.T. to EnumValueCollection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static explicit operator EnumValueCollection (
EnumValueCollection<T> coll
)
VB
Public Shared Narrowing Operator CType (
coll As EnumValueCollection(Of T)
) As EnumValueCollection
Parameters
coll
Type: TwinCAT.TypeSystem.EnumValueCollection.T.
The coll.
Return Value
Type: EnumValueCollection
The result of the conversion.
Reference
EnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


FieldCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] FieldCollection Class
FieldCollection Class
Collection of IField objects.
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.Generic.InstanceCollection.IField.
TwinCAT.TypeSystem.FieldCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class FieldCollection : InstanceCollection<IField>
VB
Public Class FieldCollection
Inherits InstanceCollection(Of IField)
The FieldCollection type exposes the following members.
Constructors
Name | Description
FieldCollection. | Initializes a new instance of the FieldCollection class.
FieldCollection(IEnumerable.IField.) | Initializes a new instance of the FieldCollection class (copy constructor)
Properties
Name | Description
Count | Gets the collection count. (Inherited from InstanceCollection.T..)
IsReadOnly | Gets a value indicating whether this instance is read only. (Inherited from InstanceCollection.T..)
Item.Int32. | Gets or sets the IInstance at the specified index. (Inherited from InstanceCollection.T..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from InstanceCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from InstanceCollection.T..)
Methods
Name | Description
Add | Adds the specified item. (Inherited from InstanceCollection.T..)
AddRange | Adds the specified items to this collection. (Inherited from InstanceCollection.T..)
AsReadOnly | Returns a read only copy of this collection (shallow copy)
Clear | Clears this instance. (Inherited from InstanceCollection.T..)
Clone | Clones this FieldCollection.
Contains(String) | Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath (Inherited from InstanceCollection.T..)
Contains(T) | Determines whether this collection contains the specified IInstance (Inherited from InstanceCollection.T..)
ContainsName | Determines whether the specified instance name contains name. (Inherited from InstanceCollection.T..)
CopyTo | Copies this InstanceCollection.T. to the specified array. (Inherited from InstanceCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator. (Inherited from InstanceCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from InstanceCollection.T..)
GetInstanceByName | Gets the name of the instance by. (Inherited from InstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of the specified IInstance. (Inherited from InstanceCollection.T..)
Insert | Inserts the specified IInstance at the specified index. (Inherited from InstanceCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified item. (Inherited from InstanceCollection.T..)
RemoveAt | Removes the IInstance at the specified index. (Inherited from InstanceCollection.T..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the IInstance. of the specified path. (Inherited from InstanceCollection.T..)
TryGetInstanceByName | Tries to get Instnaces by name. (Inherited from InstanceCollection.T..)
Fields
Name | Description
_list | The _list (Inherited from InstanceCollection.T..)
_pathDict | The _path dictionary (Inherited from InstanceCollection.T..)
mode | The mode this InstanceCollection.T. is working in. (Inherited from InstanceCollection.T..)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
FieldCollection Constructor
•
FieldCollection Properties
•
FieldCollection Methods
•
FieldCollection Fields


FieldCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] FieldCollection Class [image] FieldCollection Constructor
FieldCollection Constructor
Overload List
Name | Description
FieldCollection. | Initializes a new instance of the FieldCollection class.
FieldCollection(IEnumerable.IField.) | Initializes a new instance of the FieldCollection class (copy constructor)
Reference
FieldCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
FieldCollection Constructor
•
FieldCollection Constructor (IEnumerable.IField.)


FieldCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] FieldCollection Class [image] FieldCollection Constructor [image] FieldCollection Constructor
FieldCollection Constructor
Initializes a new instance of the FieldCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public FieldCollection()
VB
Public Sub New
Reference
FieldCollection Class
FieldCollection Overload
TwinCAT.TypeSystem Namespace


FieldCollection Constructor (IEnumerable.IField.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] FieldCollection Class [image] FieldCollection Constructor [image] FieldCollection Constructor (IEnumerable.IField.)
FieldCollection Constructor (IEnumerable.IField.)
Initializes a new instance of the FieldCollection class (copy constructor)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public FieldCollection(
IEnumerable<IField> coll
)
VB
Public Sub New (
coll As IEnumerable(Of IField)
)
Parameters
coll
Type: System.Collections.Generic.IEnumerable.IField.
The coll.
Reference
FieldCollection Class
FieldCollection Overload
TwinCAT.TypeSystem Namespace


FieldCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] FieldCollection Class [image] FieldCollection Properties
FieldCollection Properties
The FieldCollection type exposes the following members.
Properties
Name | Description
Count | Gets the collection count. (Inherited from InstanceCollection.T..)
IsReadOnly | Gets a value indicating whether this instance is read only. (Inherited from InstanceCollection.T..)
Item.Int32. | Gets or sets the IInstance at the specified index. (Inherited from InstanceCollection.T..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from InstanceCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from InstanceCollection.T..)
Reference
FieldCollection Class
TwinCAT.TypeSystem Namespace


FieldCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] FieldCollection Class [image] FieldCollection Methods
FieldCollection Methods
The FieldCollection type exposes the following members.
Methods
Name | Description
Add | Adds the specified item. (Inherited from InstanceCollection.T..)
AddRange | Adds the specified items to this collection. (Inherited from InstanceCollection.T..)
AsReadOnly | Returns a read only copy of this collection (shallow copy)
Clear | Clears this instance. (Inherited from InstanceCollection.T..)
Clone | Clones this FieldCollection.
Contains(String) | Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath (Inherited from InstanceCollection.T..)
Contains(T) | Determines whether this collection contains the specified IInstance (Inherited from InstanceCollection.T..)
ContainsName | Determines whether the specified instance name contains name. (Inherited from InstanceCollection.T..)
CopyTo | Copies this InstanceCollection.T. to the specified array. (Inherited from InstanceCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator. (Inherited from InstanceCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from InstanceCollection.T..)
GetInstanceByName | Gets the name of the instance by. (Inherited from InstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of the specified IInstance. (Inherited from InstanceCollection.T..)
Insert | Inserts the specified IInstance at the specified index. (Inherited from InstanceCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified item. (Inherited from InstanceCollection.T..)
RemoveAt | Removes the IInstance at the specified index. (Inherited from InstanceCollection.T..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the IInstance. of the specified path. (Inherited from InstanceCollection.T..)
TryGetInstanceByName | Tries to get Instnaces by name. (Inherited from InstanceCollection.T..)
Reference
FieldCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
FieldCollection.AsReadOnly Method
•
FieldCollection.Clone Method


FieldCollection.AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] FieldCollection Class [image] FieldCollection Methods [image] FieldCollection.AsReadOnly Method
FieldCollection.AsReadOnly Method
Returns a read only copy of this collection (shallow copy)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyFieldCollection AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlyFieldCollection
Return Value
Type: ReadOnlyFieldCollection
The readonly copy.
Reference
FieldCollection Class
TwinCAT.TypeSystem Namespace


FieldCollection.Clone Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] FieldCollection Class [image] FieldCollection Methods [image] FieldCollection.Clone Method
FieldCollection.Clone Method
Clones this FieldCollection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public FieldCollection Clone()
VB
Public Function Clone As FieldCollection
Return Value
Type: FieldCollection
A cloned FieldCollection.
Reference
FieldCollection Class
TwinCAT.TypeSystem Namespace


FieldCollection Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] FieldCollection Class [image] FieldCollection Fields
FieldCollection Fields
The FieldCollection type exposes the following members.
Fields
Name | Description
_list | The _list (Inherited from InstanceCollection.T..)
_pathDict | The _path dictionary (Inherited from InstanceCollection.T..)
mode | The mode this InstanceCollection.T. is working in. (Inherited from InstanceCollection.T..)
Reference
FieldCollection Class
TwinCAT.TypeSystem Namespace


IAliasInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IAliasInstance Interface
IAliasInstance Interface
Interface representing an instance of an IAliasType.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IAliasInstance : ISymbol,
IAttributedInstance, IInstance, IBitSize
VB
Public Interface IAliasInstance
Inherits ISymbol, IAttributedInstance, IInstance, IBitSize
The IAliasInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.ISymbol
Weiterführende Informationen
•
IAliasInstance Properties


IAliasInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IAliasInstance Interface [image] IAliasInstance Properties
IAliasInstance Properties
The IAliasInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IAliasInstance Interface
TwinCAT.TypeSystem Namespace


IAliasType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IAliasType Interface
IAliasType Interface
Interface representing an Alias Type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IAliasType : IDataType,
IBitSize
VB
Public Interface IAliasType
Inherits IDataType, IBitSize
The IAliasType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the Base Type
BaseTypeName | Gets the BaseType name
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IAliasType Properties


IAliasType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IAliasType Interface [image] IAliasType Properties
IAliasType Properties
The IAliasType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the Base Type
BaseTypeName | Gets the BaseType name
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IAliasType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IAliasType.BaseType Property
•
IAliasType.BaseTypeName Property


IAliasType.BaseType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IAliasType Interface [image] IAliasType Properties [image] IAliasType.BaseType Property
IAliasType.BaseType Property
Gets the Base Type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType BaseType { get; }
VB
ReadOnly Property BaseType As IDataType
Get
Property Value
Type: IDataType
Reference
IAliasType Interface
TwinCAT.TypeSystem Namespace


IAliasType.BaseTypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IAliasType Interface [image] IAliasType Properties [image] IAliasType.BaseTypeName Property
IAliasType.BaseTypeName Property
Gets the BaseType name
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string BaseTypeName { get; }
VB
ReadOnly Property BaseTypeName As String
Get
Property Value
Type: String
Reference
IAliasType Interface
TwinCAT.TypeSystem Namespace


IArrayInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayInstance Interface
IArrayInstance Interface
Interface representing an array instance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IArrayInstance : ISymbol,
IAttributedInstance, IInstance, IBitSize
VB
Public Interface IArrayInstance
Inherits ISymbol, IAttributedInstance, IInstance, IBitSize
The IArrayInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
Dimensions | Gets the dimensions as read only collection.
Elements | Gets the contained Array Elements as read only collection.
ElementType | Gets the type of the contained elements.
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Item | Gets the ISymbol with the specified indices.
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Methods
Name | Description
TryGetElement(IList..Int32.., ISymbol.) | Tries to get the array element with the specified indices (jagged array support).
TryGetElement(.Int32., ISymbol.) | Tries to get the array element with specified indices (only first level on jagged arrays)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IArrayInstance Properties
•
IArrayInstance Methods


IArrayInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayInstance Interface [image] IArrayInstance Properties
IArrayInstance Properties
The IArrayInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
Dimensions | Gets the dimensions as read only collection.
Elements | Gets the contained Array Elements as read only collection.
ElementType | Gets the type of the contained elements.
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Item | Gets the ISymbol with the specified indices.
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IArrayInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IArrayInstance.Dimensions Property
•
IArrayInstance.Elements Property
•
IArrayInstance.ElementType Property
•
IArrayInstance.Item Property


IArrayInstance.Dimensions Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayInstance Interface [image] IArrayInstance Properties [image] IArrayInstance.Dimensions Property
IArrayInstance.Dimensions Property
Gets the dimensions as read only collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyDimensionCollection Dimensions { get; }
VB
ReadOnly Property Dimensions As ReadOnlyDimensionCollection
Get
Property Value
Type: ReadOnlyDimensionCollection
The dimensions.
Reference
IArrayInstance Interface
TwinCAT.TypeSystem Namespace


IArrayInstance.Elements Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayInstance Interface [image] IArrayInstance Properties [image] IArrayInstance.Elements Property
IArrayInstance.Elements Property
Gets the contained Array Elements as read only collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlySymbolCollection Elements { get; }
VB
ReadOnly Property Elements As ReadOnlySymbolCollection
Get
Property Value
Type: ReadOnlySymbolCollection
The elements.
Reference
IArrayInstance Interface
TwinCAT.TypeSystem Namespace


IArrayInstance.ElementType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayInstance Interface [image] IArrayInstance Properties [image] IArrayInstance.ElementType Property
IArrayInstance.ElementType Property
Gets the type of the contained elements.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType ElementType { get; }
VB
ReadOnly Property ElementType As IDataType
Get
Property Value
Type: IDataType
The type of the element.
Reference
IArrayInstance Interface
TwinCAT.TypeSystem Namespace


IArrayInstance.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayInstance Interface [image] IArrayInstance Properties [image] IArrayInstance.Item Property
IArrayInstance.Item Property
Gets the ISymbol with the specified indices.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ISymbol this[
int[] indices
] { get; }
VB
ReadOnly Default Property Item (
indices As Integer()
) As ISymbol
Get
Parameters
indices
Type: .System.Int32.
The indices.
Property Value
Type: ISymbol
The ISymbol.
Return Value
Type: ISymbol
Reference
IArrayInstance Interface
TwinCAT.TypeSystem Namespace


IArrayInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayInstance Interface [image] IArrayInstance Methods
IArrayInstance Methods
Methods
Name | Description
TryGetElement(IList..Int32.., ISymbol.) | Tries to get the array element with the specified indices (jagged array support).
TryGetElement(.Int32., ISymbol.) | Tries to get the array element with specified indices (only first level on jagged arrays)
Reference
IArrayInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IArrayInstance.TryGetElement Method


IArrayInstance.TryGetElement Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayInstance Interface [image] IArrayInstance Methods [image] IArrayInstance.TryGetElement Method
IArrayInstance.TryGetElement Method
Overload List
Name | Description
TryGetElement(IList..Int32.., ISymbol.) | Tries to get the array element with the specified indices (jagged array support).
TryGetElement(.Int32., ISymbol.) | Tries to get the array element with specified indices (only first level on jagged arrays)
Reference
IArrayInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IArrayInstance.TryGetElement Method (IList..Int32.., ISymbol.)
•
IArrayInstance.TryGetElement Method (.Int32., ISymbol.)


IArrayInstance.TryGetElement Method (IList..Int32.., ISymbol.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayInstance Interface [image] IArrayInstance Methods [image] IArrayInstance.TryGetElement Method [image] IArrayInstance.TryGetElement Method (IList..Int32.., ISymbol.)
IArrayInstance.TryGetElement Method (IList..Int32.., ISymbol.)
Tries to get the array element with the specified indices (jagged array support).
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TryGetElement(
IList<int[]> jaggedIndices,
out ISymbol symbol
)
VB
Function TryGetElement (
jaggedIndices As IList(Of Integer()),
<OutAttribute> ByRef symbol As ISymbol
) As Boolean
Parameters
jaggedIndices | Type: System.Collections.Generic.IList..Int32.. The jagged indices list.
symbol | Type: TwinCAT.TypeSystem.ISymbol. The symbol.
Return Value
Type: Boolean
true if found, false if the jagged indices specifiers is out-of-range.
Reference
IArrayInstance Interface
TryGetElement Overload
TwinCAT.TypeSystem Namespace


IArrayInstance.TryGetElement Method (.Int32., ISymbol.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayInstance Interface [image] IArrayInstance Methods [image] IArrayInstance.TryGetElement Method [image] IArrayInstance.TryGetElement Method (.Int32., ISymbol.)
IArrayInstance.TryGetElement Method (.Int32., ISymbol.)
Tries to get the array element with specified indices (only first level on jagged arrays)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TryGetElement(
int[] indices,
out ISymbol symbol
)
VB
Function TryGetElement (
indices As Integer(),
<OutAttribute> ByRef symbol As ISymbol
) As Boolean
Parameters
indices | Type: .System.Int32. The indices.
symbol | Type: TwinCAT.TypeSystem.ISymbol. The found Array element symbol (out-parameter).
Return Value
Type: Boolean
true if found, false if the indices specifiers is out-of-range.
Reference
IArrayInstance Interface
TryGetElement Overload
TwinCAT.TypeSystem Namespace


IArrayType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayType Interface
IArrayType Interface
Interface representing an array DataType.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IArrayType : IDataType,
IBitSize
VB
Public Interface IArrayType
Inherits IDataType, IBitSize
The IArrayType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
Dimensions | Gets the dimensions as read only collection.
ElementType | Gets the type of the contained elements.
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsJagged | Gets a value indicating whether this instance is jagged.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
JaggedLevel | Gets the jagged level (Non-Jagged Array have level 1)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IArrayType Properties


IArrayType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayType Interface [image] IArrayType Properties
IArrayType Properties
The IArrayType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
Dimensions | Gets the dimensions as read only collection.
ElementType | Gets the type of the contained elements.
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsJagged | Gets a value indicating whether this instance is jagged.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
JaggedLevel | Gets the jagged level (Non-Jagged Array have level 1)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IArrayType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IArrayType.Dimensions Property
•
IArrayType.ElementType Property
•
IArrayType.IsJagged Property
•
IArrayType.JaggedLevel Property


IArrayType.Dimensions Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayType Interface [image] IArrayType Properties [image] IArrayType.Dimensions Property
IArrayType.Dimensions Property
Gets the dimensions as read only collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyDimensionCollection Dimensions { get; }
VB
ReadOnly Property Dimensions As ReadOnlyDimensionCollection
Get
Property Value
Type: ReadOnlyDimensionCollection
The dimensions.
Reference
IArrayType Interface
TwinCAT.TypeSystem Namespace


IArrayType.ElementType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayType Interface [image] IArrayType Properties [image] IArrayType.ElementType Property
IArrayType.ElementType Property
Gets the type of the contained elements.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType ElementType { get; }
VB
ReadOnly Property ElementType As IDataType
Get
Property Value
Type: IDataType
The type of the element.
Reference
IArrayType Interface
TwinCAT.TypeSystem Namespace


IArrayType.IsJagged Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayType Interface [image] IArrayType Properties [image] IArrayType.IsJagged Property
IArrayType.IsJagged Property
Gets a value indicating whether this instance is jagged.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsJagged { get; }
VB
ReadOnly Property IsJagged As Boolean
Get
Property Value
Type: Boolean
true if this instance is jagged; otherwise, false.
Reference
IArrayType Interface
TwinCAT.TypeSystem Namespace


IArrayType.JaggedLevel Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayType Interface [image] IArrayType Properties [image] IArrayType.JaggedLevel Property
IArrayType.JaggedLevel Property
Gets the jagged level (Non-Jagged Array have level 1)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int JaggedLevel { get; }
VB
ReadOnly Property JaggedLevel As Integer
Get
Property Value
Type: Int32
The jagged level.
Reference
IArrayType Interface
TwinCAT.TypeSystem Namespace


IArrayValue Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayValue Interface
IArrayValue Interface
Interface IArrayValue
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IArrayValue : IValue
VB
Public Interface IArrayValue
Inherits IValue
The IArrayValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value) (Inherited from IValue.)
CachedRaw | Gets the cached Raw internal Data. (Inherited from IValue.)
DataType | Gets the data type bound to this IValue (Inherited from IValue.)
IsPrimitive | Gets a value indicating whether this IValue is a primitive value. (Inherited from IValue.)
Symbol | Gets the symbol bound to this IValue. (Inherited from IValue.)
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value (local user time, UTC) (Inherited from IValue.)
Methods
Name | Description
Read | Reads the value (via ADS) (Inherited from IValue.)
ResolveValue | Resolves the Value object to its primitive value. (Inherited from IValue.)
TryGetArrayElementValues | Returns Array Element values.
TryGetIndexValue | Tries to get the specified Array Element
TryResolveValue | Tries to resolves the Value object to its primitive value. (Inherited from IValue.)
TrySetIndexValue | Tries to set the indexed value on Arrays
Write | Writes the value (via ADS) (Inherited from IValue.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IValue
Weiterführende Informationen
•
IArrayValue Properties
•
IArrayValue Methods


IArrayValue Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayValue Interface [image] IArrayValue Properties
IArrayValue Properties
The IArrayValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value) (Inherited from IValue.)
CachedRaw | Gets the cached Raw internal Data. (Inherited from IValue.)
DataType | Gets the data type bound to this IValue (Inherited from IValue.)
IsPrimitive | Gets a value indicating whether this IValue is a primitive value. (Inherited from IValue.)
Symbol | Gets the symbol bound to this IValue. (Inherited from IValue.)
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value (local user time, UTC) (Inherited from IValue.)
Reference
IArrayValue Interface
TwinCAT.TypeSystem Namespace


IArrayValue Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayValue Interface [image] IArrayValue Methods
IArrayValue Methods
The IArrayValue type exposes the following members.
Methods
Name | Description
Read | Reads the value (via ADS) (Inherited from IValue.)
ResolveValue | Resolves the Value object to its primitive value. (Inherited from IValue.)
TryGetArrayElementValues | Returns Array Element values.
TryGetIndexValue | Tries to get the specified Array Element
TryResolveValue | Tries to resolves the Value object to its primitive value. (Inherited from IValue.)
TrySetIndexValue | Tries to set the indexed value on Arrays
Write | Writes the value (via ADS) (Inherited from IValue.)
Reference
IArrayValue Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IArrayValue.TryGetArrayElementValues Method
•
IArrayValue.TryGetIndexValue Method
•
IArrayValue.TrySetIndexValue Method


IArrayValue.TryGetArrayElementValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayValue Interface [image] IArrayValue Methods [image] IArrayValue.TryGetArrayElementValues Method
IArrayValue.TryGetArrayElementValues Method
Returns Array Element values.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TryGetArrayElementValues(
out IEnumerable<Object> elementValues
)
VB
Function TryGetArrayElementValues (
<OutAttribute> ByRef elementValues As IEnumerable(Of Object)
) As Boolean
Parameters
elementValues
Type: System.Collections.Generic.IEnumerable.Object..
The element values.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
IArrayValue Interface
TwinCAT.TypeSystem Namespace


IArrayValue.TryGetIndexValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayValue Interface [image] IArrayValue Methods [image] IArrayValue.TryGetIndexValue Method
IArrayValue.TryGetIndexValue Method
Tries to get the specified Array Element
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TryGetIndexValue(
int[] indices,
out Object value
)
VB
Function TryGetIndexValue (
indices As Integer(),
<OutAttribute> ByRef value As Object
) As Boolean
Parameters
indices | Type: .System.Int32. The indices.
value | Type: System.Object. The value.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
IArrayValue Interface
TwinCAT.TypeSystem Namespace


IArrayValue.TrySetIndexValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IArrayValue Interface [image] IArrayValue Methods [image] IArrayValue.TrySetIndexValue Method
IArrayValue.TrySetIndexValue Method
Tries to set the indexed value on Arrays
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TrySetIndexValue(
Object[] indexes,
Object value
)
VB
Function TrySetIndexValue (
indexes As Object(),
value As Object
) As Boolean
Parameters
indexes | Type: .System.Object. The indexes.
value | Type: System.Object The value.
Return Value
Type: Boolean
true if succeeded, false otherwise.
Reference
IArrayValue Interface
TwinCAT.TypeSystem Namespace


IAttributedInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IAttributedInstance Interface
IAttributedInstance Interface
Interface IAttributedInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IAttributedInstance : IInstance,
IBitSize
VB
Public Interface IAttributedInstance
Inherits IInstance, IBitSize
The IAttributedInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes.
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IInstance
Weiterführende Informationen
•
IAttributedInstance Properties


IAttributedInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IAttributedInstance Interface [image] IAttributedInstance Properties
IAttributedInstance Properties
The IAttributedInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes.
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IAttributedInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IAttributedInstance.Attributes Property


IAttributedInstance.Attributes Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IAttributedInstance Interface [image] IAttributedInstance Properties [image] IAttributedInstance.Attributes Property
IAttributedInstance.Attributes Property
Gets the Type Attributes.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyTypeAttributeCollection Attributes { get; }
VB
ReadOnly Property Attributes As ReadOnlyTypeAttributeCollection
Get
Property Value
Type: ReadOnlyTypeAttributeCollection
The attributes.
Reference
IAttributedInstance Interface
TwinCAT.TypeSystem Namespace


IBitSize Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IBitSize Interface
IBitSize Interface
Interface IBitSize
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IBitSize
VB
Public Interface IBitSize
The IBitSize type exposes the following members.
Properties
Name | Description
BitSize | Gets the size of the IDataType in bits.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType
Remarks
Specifies the Bitness of the the object and the bit resp. byte sizes.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IBitSize Properties


IBitSize Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IBitSize Interface [image] IBitSize Properties
IBitSize Properties
The IBitSize type exposes the following members.
Properties
Name | Description
BitSize | Gets the size of the IDataType in bits.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType
Reference
IBitSize Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IBitSize.BitSize Property
•
IBitSize.ByteSize Property
•
IBitSize.IsBitType Property
•
IBitSize.IsByteAligned Property
•
IBitSize.Size Property


IBitSize.BitSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IBitSize Interface [image] IBitSize Properties [image] IBitSize.BitSize Property
IBitSize.BitSize Property
Gets the size of the IDataType in bits.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int BitSize { get; }
VB
ReadOnly Property BitSize As Integer
Get
Property Value
Type: Int32
The size of IDataType in bits.
Reference
IBitSize Interface
TwinCAT.TypeSystem Namespace


IBitSize.ByteSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IBitSize Interface [image] IBitSize Properties [image] IBitSize.ByteSize Property
IBitSize.ByteSize Property
Gets the (aligned) size of of the Type/Instance in Bytes
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int ByteSize { get; }
VB
ReadOnly Property ByteSize As Integer
Get
Property Value
Type: Int32
The size of the byte.
Reference
IBitSize Interface
TwinCAT.TypeSystem Namespace


IBitSize.IsBitType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IBitSize Interface [image] IBitSize Properties [image] IBitSize.IsBitType Property
IBitSize.IsBitType Property
Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsBitType { get; }
VB
ReadOnly Property IsBitType As Boolean
Get
Property Value
Type: Boolean
true if this instance is bit mapping; otherwise, false.
Reference
IBitSize Interface
TwinCAT.TypeSystem Namespace


IBitSize.IsByteAligned Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IBitSize Interface [image] IBitSize Properties [image] IBitSize.IsByteAligned Property
IBitSize.IsByteAligned Property
Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsByteAligned { get; }
VB
ReadOnly Property IsByteAligned As Boolean
Get
Property Value
Type: Boolean
true if this instance is byte aligned; otherwise, false.
Reference
IBitSize Interface
TwinCAT.TypeSystem Namespace


IBitSize.Size Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IBitSize Interface [image] IBitSize Properties [image] IBitSize.Size Property
IBitSize.Size Property
Gets the size of the object in bytes or Bits dependant on IsBitType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Size { get; }
VB
ReadOnly Property Size As Integer
Get
Property Value
Type: Int32
The size of the bit.
Reference
IBitSize Interface
TwinCAT.TypeSystem Namespace


IDataType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface
IDataType Interface
Base interface for objects representing data types
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IDataType : IBitSize
VB
Public Interface IDataType
Inherits IBitSize
The IDataType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category
Comment | Gets the comment behind the variable declaration.
FullName | Gets the full name of the IDataType (Namespace + Name)
Id | Gets the ID of the DataType
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type
IsPointer | Gets a value indicating whether this IDataType is a pointer type
IsPrimitive | Gets a value indicating whether this IDataType is primitive
IsReference | Gets a value indicating whether this IDataType is a reference type
Name | Gets the name of the Data Type (without namespace)
Namespace | Gets the namespace string within the IDataType exists.
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IDataType Properties


IDataType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties
IDataType Properties
The IDataType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category
Comment | Gets the comment behind the variable declaration.
FullName | Gets the full name of the IDataType (Namespace + Name)
Id | Gets the ID of the DataType
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type
IsPointer | Gets a value indicating whether this IDataType is a pointer type
IsPrimitive | Gets a value indicating whether this IDataType is primitive
IsReference | Gets a value indicating whether this IDataType is a reference type
Name | Gets the name of the Data Type (without namespace)
Namespace | Gets the namespace string within the IDataType exists.
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IDataType.Attributes Property
•
IDataType.Category Property
•
IDataType.Comment Property
•
IDataType.FullName Property
•
IDataType.Id Property
•
IDataType.IsContainer Property
•
IDataType.IsPointer Property
•
IDataType.IsPrimitive Property
•
IDataType.IsReference Property
•
IDataType.Name Property
•
IDataType.Namespace Property


IDataType.Attributes Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties [image] IDataType.Attributes Property
IDataType.Attributes Property
Gets the attributes of the IDataType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyTypeAttributeCollection Attributes { get; }
VB
ReadOnly Property Attributes As ReadOnlyTypeAttributeCollection
Get
Property Value
Type: ReadOnlyTypeAttributeCollection
The attributes.
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace


IDataType.Category Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties [image] IDataType.Category Property
IDataType.Category Property
Gets the Data Type category
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
DataTypeCategory Category { get; }
VB
ReadOnly Property Category As DataTypeCategory
Get
Property Value
Type: DataTypeCategory
The category.
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace


IDataType.Comment Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties [image] IDataType.Comment Property
IDataType.Comment Property
Gets the comment behind the variable declaration.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Comment { get; }
VB
ReadOnly Property Comment As String
Get
Property Value
Type: String
Comment behind the variable declaration.
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace


IDataType.FullName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties [image] IDataType.FullName Property
IDataType.FullName Property
Gets the full name of the IDataType (Namespace + Name)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string FullName { get; }
VB
ReadOnly Property FullName As String
Get
Property Value
Type: String
The full name.
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace


IDataType.Id Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties [image] IDataType.Id Property
IDataType.Id Property
Gets the ID of the DataType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Id { get; }
VB
ReadOnly Property Id As Integer
Get
Property Value
Type: Int32
The id.
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace


IDataType.IsContainer Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties [image] IDataType.IsContainer Property
IDataType.IsContainer Property
Gets a value indicating whether this IDataType is a container type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsContainer { get; }
VB
ReadOnly Property IsContainer As Boolean
Get
Property Value
Type: Boolean
true if this instance is container type; otherwise, false.
Remarks
Container Types are all types that contain SubElements like
▪
Array
▪
Pointer
▪
Union
▪
Struct
▪
Function
▪
FunctionBlock
▪
Program
and the Alias and Reference types, if they have a container type as base type.
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace
IDataType.Category


IDataType.IsPointer Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties [image] IDataType.IsPointer Property
IDataType.IsPointer Property
Gets a value indicating whether this IDataType is a pointer type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsPointer { get; }
VB
ReadOnly Property IsPointer As Boolean
Get
Property Value
Type: Boolean
true if this instance is pointer type; otherwise, false.
Remarks
Pointer types can be dereferenced with the '^' operator.
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace
IDataType.Category


IDataType.IsPrimitive Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties [image] IDataType.IsPrimitive Property
IDataType.IsPrimitive Property
Gets a value indicating whether this IDataType is primitive
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsPrimitive { get; }
VB
ReadOnly Property IsPrimitive As Boolean
Get
Property Value
Type: Boolean
true if this instance is primitive; otherwise, false.
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace


IDataType.IsReference Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties [image] IDataType.IsReference Property
IDataType.IsReference Property
Gets a value indicating whether this IDataType is a reference type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsReference { get; }
VB
ReadOnly Property IsReference As Boolean
Get
Property Value
Type: Boolean
true if this instance is container type; otherwise, false.
Remarks
Reference types can be dereferenced.
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace
IDataType.Category


IDataType.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties [image] IDataType.Name Property
IDataType.Name Property
Gets the name of the Data Type (without namespace)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Name { get; }
VB
ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace


IDataType.Namespace Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDataType Interface [image] IDataType Properties [image] IDataType.Namespace Property
IDataType.Namespace Property
Gets the namespace string within the IDataType exists.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Namespace { get; }
VB
ReadOnly Property Namespace As String
Get
Property Value
Type: String
The namespace.
Reference
IDataType Interface
TwinCAT.TypeSystem Namespace


IDimension Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDimension Interface
IDimension Interface
Interface representing a single Dimension of an ArrayType.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IDimension
VB
Public Interface IDimension
The IDimension type exposes the following members.
Properties
Name | Description
ElementCount | Gets the number of elements within that IDimension.
LowerBound | Gets the lower bound of elements within that IDimension.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IDimension Properties


IDimension Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDimension Interface [image] IDimension Properties
IDimension Properties
The IDimension type exposes the following members.
Properties
Name | Description
ElementCount | Gets the number of elements within that IDimension.
LowerBound | Gets the lower bound of elements within that IDimension.
Reference
IDimension Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IDimension.ElementCount Property
•
IDimension.LowerBound Property


IDimension.ElementCount Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDimension Interface [image] IDimension Properties [image] IDimension.ElementCount Property
IDimension.ElementCount Property
Gets the number of elements within that IDimension.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int ElementCount { get; }
VB
ReadOnly Property ElementCount As Integer
Get
Property Value
Type: Int32
The element count.
Reference
IDimension Interface
TwinCAT.TypeSystem Namespace


IDimension.LowerBound Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDimension Interface [image] IDimension Properties [image] IDimension.LowerBound Property
IDimension.LowerBound Property
Gets the lower bound of elements within that IDimension.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int LowerBound { get; }
VB
ReadOnly Property LowerBound As Integer
Get
Property Value
Type: Int32
The lower bound.
Reference
IDimension Interface
TwinCAT.TypeSystem Namespace


IDimensionCollection Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDimensionCollection Interface
IDimensionCollection Interface
Interface IDimensionCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IDimensionCollection : IList<IDimension>,
ICollection<IDimension>, IEnumerable<IDimension>, IEnumerable
VB
Public Interface IDimensionCollection
Inherits IList(Of IDimension), ICollection(Of IDimension),
IEnumerable(Of IDimension), IEnumerable
The IDimensionCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T.. (Inherited from ICollection.IDimension..)
ElementCount | Gets the Number of elements in all Dimensions
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only. (Inherited from ICollection.IDimension..)
Item | Gets or sets the element at the specified index. (Inherited from IList.IDimension..)
LowerBounds | Gets the lower bounds.
UpperBounds | Gets the lower bounds.
Methods
Name | Description
Add | Adds an item to the ICollection.T.. (Inherited from ICollection.IDimension..)
Clear | Removes all items from the ICollection.T.. (Inherited from ICollection.IDimension..)
Contains | Determines whether the ICollection.T. contains a specific value. (Inherited from ICollection.IDimension..)
CopyTo | Copies the elements of the ICollection.T. to an Array, starting at a particular Array index. (Inherited from ICollection.IDimension..)
GetDimensionLengths | Gets an array the specifies the Lengths of each Array Dimension
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable.IDimension..)
IndexOf | Determines the index of a specific item in the IList.T.. (Inherited from IList.IDimension..)
Insert | Inserts an item to the IList.T. at the specified index. (Inherited from IList.IDimension..)
Remove | Removes the first occurrence of a specific object from the ICollection.T.. (Inherited from ICollection.IDimension..)
RemoveAt | Removes the IList.T. item at the specified index. (Inherited from IList.IDimension..)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IDimension
Weiterführende Informationen
•
IDimensionCollection Properties
•
IDimensionCollection Methods


IDimensionCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDimensionCollection Interface [image] IDimensionCollection Properties
IDimensionCollection Properties
The IDimensionCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T.. (Inherited from ICollection.IDimension..)
ElementCount | Gets the Number of elements in all Dimensions
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only. (Inherited from ICollection.IDimension..)
Item | Gets or sets the element at the specified index. (Inherited from IList.IDimension..)
LowerBounds | Gets the lower bounds.
UpperBounds | Gets the lower bounds.
Reference
IDimensionCollection Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IDimensionCollection.ElementCount Property
•
IDimensionCollection.LowerBounds Property
•
IDimensionCollection.UpperBounds Property


IDimensionCollection.ElementCount Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDimensionCollection Interface [image] IDimensionCollection Properties [image] IDimensionCollection.ElementCount Property
IDimensionCollection.ElementCount Property
Gets the Number of elements in all Dimensions
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int ElementCount { get; }
VB
ReadOnly Property ElementCount As Integer
Get
Property Value
Type: Int32
Reference
IDimensionCollection Interface
TwinCAT.TypeSystem Namespace


IDimensionCollection.LowerBounds Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDimensionCollection Interface [image] IDimensionCollection Properties [image] IDimensionCollection.LowerBounds Property
IDimensionCollection.LowerBounds Property
Gets the lower bounds.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int[] LowerBounds { get; }
VB
ReadOnly Property LowerBounds As Integer()
Get
Property Value
Type: .Int32.
The lower bounds.
Reference
IDimensionCollection Interface
TwinCAT.TypeSystem Namespace


IDimensionCollection.UpperBounds Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDimensionCollection Interface [image] IDimensionCollection Properties [image] IDimensionCollection.UpperBounds Property
IDimensionCollection.UpperBounds Property
Gets the lower bounds.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int[] UpperBounds { get; }
VB
ReadOnly Property UpperBounds As Integer()
Get
Property Value
Type: .Int32.
The lower bounds.
Reference
IDimensionCollection Interface
TwinCAT.TypeSystem Namespace


IDimensionCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDimensionCollection Interface [image] IDimensionCollection Methods
IDimensionCollection Methods
The IDimensionCollection type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T.. (Inherited from ICollection.IDimension..)
Clear | Removes all items from the ICollection.T.. (Inherited from ICollection.IDimension..)
Contains | Determines whether the ICollection.T. contains a specific value. (Inherited from ICollection.IDimension..)
CopyTo | Copies the elements of the ICollection.T. to an Array, starting at a particular Array index. (Inherited from ICollection.IDimension..)
GetDimensionLengths | Gets an array the specifies the Lengths of each Array Dimension
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable.IDimension..)
IndexOf | Determines the index of a specific item in the IList.T.. (Inherited from IList.IDimension..)
Insert | Inserts an item to the IList.T. at the specified index. (Inherited from IList.IDimension..)
Remove | Removes the first occurrence of a specific object from the ICollection.T.. (Inherited from ICollection.IDimension..)
RemoveAt | Removes the IList.T. item at the specified index. (Inherited from IList.IDimension..)
Reference
IDimensionCollection Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IDimensionCollection.GetDimensionLengths Method


IDimensionCollection.GetDimensionLengths Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDimensionCollection Interface [image] IDimensionCollection Methods [image] IDimensionCollection.GetDimensionLengths Method
IDimensionCollection.GetDimensionLengths Method
Gets an array the specifies the Lengths of each Array Dimension
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int[] GetDimensionLengths()
VB
Function GetDimensionLengths As Integer()
Return Value
Type: .Int32.
System.Int32[].
Reference
IDimensionCollection Interface
TwinCAT.TypeSystem Namespace


IDynamicSymbol Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDynamicSymbol Interface
IDynamicSymbol Interface
Interface IDynamicSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IDynamicSymbol : ISymbol,
IAttributedInstance, IInstance, IBitSize
VB
Public Interface IDynamicSymbol
Inherits ISymbol, IAttributedInstance, IInstance, IBitSize
The IDynamicSymbol type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IDynamicSymbol Properties


IDynamicSymbol Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDynamicSymbol Interface [image] IDynamicSymbol Properties
IDynamicSymbol Properties
The IDynamicSymbol type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
NormalizedName | Gets the normalized instance name (fixed name for dynamic property access)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IDynamicSymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IDynamicSymbol.NormalizedName Property


IDynamicSymbol.NormalizedName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDynamicSymbol Interface [image] IDynamicSymbol Properties [image] IDynamicSymbol.NormalizedName Property
IDynamicSymbol.NormalizedName Property
Gets the normalized instance name (fixed name for dynamic property access)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string NormalizedName { get; }
VB
ReadOnly Property NormalizedName As String
Get
Property Value
Type: String
The normalized instance name (can be the same like InstanceName
Reference
IDynamicSymbol Interface
TwinCAT.TypeSystem Namespace
IInstance.InstanceName
ISymbolFactory.InvalidCharacters


IDynamicSymbolLoader Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDynamicSymbolLoader Interface
IDynamicSymbolLoader Interface
Dynamic symbol loader interface
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IDynamicSymbolLoader : ISymbolLoader,
ISymbolProvider
VB
Public Interface IDynamicSymbolLoader
Inherits ISymbolLoader, ISymbolProvider
The IDynamicSymbolLoader type exposes the following members.
Properties
Name | Description
BuildInTypes | Gets the build in types. (Inherited from ISymbolLoader.)
DataTypes | Gets all data types from all Namespaces (Inherited from ISymbolProvider.)
RootNamespaceName | Gets the name of the root namespace (Inherited from ISymbolProvider.)
Settings | Gets or sets the access Method (Inherited from ISymbolLoader.)
Symbols | Gets the (root) symbols of the Symbol provider. (Inherited from ISymbolProvider.)
SymbolsDynamic | Gets the symbols (late bound as dynamic objects)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IDynamicSymbolLoader Properties


IDynamicSymbolLoader Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDynamicSymbolLoader Interface [image] IDynamicSymbolLoader Properties
IDynamicSymbolLoader Properties
The IDynamicSymbolLoader type exposes the following members.
Properties
Name | Description
BuildInTypes | Gets the build in types. (Inherited from ISymbolLoader.)
DataTypes | Gets all data types from all Namespaces (Inherited from ISymbolProvider.)
RootNamespaceName | Gets the name of the root namespace (Inherited from ISymbolProvider.)
Settings | Gets or sets the access Method (Inherited from ISymbolLoader.)
Symbols | Gets the (root) symbols of the Symbol provider. (Inherited from ISymbolProvider.)
SymbolsDynamic | Gets the symbols (late bound as dynamic objects)
Reference
IDynamicSymbolLoader Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IDynamicSymbolLoader.SymbolsDynamic Property


IDynamicSymbolLoader.SymbolsDynamic Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IDynamicSymbolLoader Interface [image] IDynamicSymbolLoader Properties [image] IDynamicSymbolLoader.SymbolsDynamic Property
IDynamicSymbolLoader.SymbolsDynamic Property
Gets the symbols (late bound as dynamic objects)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
DynamicSymbolsContainer SymbolsDynamic { get; }
VB
ReadOnly Property SymbolsDynamic As DynamicSymbolsContainer
Get
Property Value
Type: DynamicSymbolsContainer
The dynamic symbols.
Reference
IDynamicSymbolLoader Interface
TwinCAT.TypeSystem Namespace


IEnumType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType Interface
IEnumType Interface
Common Enum type interface
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IEnumType : IAliasType,
IDataType, IBitSize
VB
Public Interface IEnumType
Inherits IAliasType, IDataType, IBitSize
The IEnumType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the Base Type (Inherited from IAliasType.)
BaseTypeName | Gets the BaseType name (Inherited from IAliasType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
EnumValues | Enumeration specification (if enum)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Methods
Name | Description
Contains | Determines whether the enum values contains the specified name
GetNames | Gets the filed names of the IEnumType.T.
GetValues | Gets the values of the IEnumType.T.
Parse | Parses a value name of the IEnumType.T. and returns the value (as base type)
ToString | Returns a String that represents the specified value.
TryParse | Parses the value from value name.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IEnumType Properties
•
IEnumType Methods


IEnumType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType Interface [image] IEnumType Properties
IEnumType Properties
The IEnumType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the Base Type (Inherited from IAliasType.)
BaseTypeName | Gets the BaseType name (Inherited from IAliasType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
EnumValues | Enumeration specification (if enum)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IEnumType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IEnumType.EnumValues Property


IEnumType.EnumValues Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType Interface [image] IEnumType Properties [image] IEnumType.EnumValues Property
IEnumType.EnumValues Property
Enumeration specification (if enum)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyEnumValueCollection EnumValues { get; }
VB
ReadOnly Property EnumValues As ReadOnlyEnumValueCollection
Get
Property Value
Type: ReadOnlyEnumValueCollection
The enum specification.
Reference
IEnumType Interface
TwinCAT.TypeSystem Namespace


IEnumType Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType Interface [image] IEnumType Methods
IEnumType Methods
The IEnumType type exposes the following members.
Methods
Name | Description
Contains | Determines whether the enum values contains the specified name
GetNames | Gets the filed names of the IEnumType.T.
GetValues | Gets the values of the IEnumType.T.
Parse | Parses a value name of the IEnumType.T. and returns the value (as base type)
ToString | Returns a String that represents the specified value.
TryParse | Parses the value from value name.
Reference
IEnumType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IEnumType.Contains Method
•
IEnumType.GetNames Method
•
IEnumType.GetValues Method
•
IEnumType.Parse Method
•
IEnumType.ToString Method
•
IEnumType.TryParse Method


IEnumType.Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType Interface [image] IEnumType Methods [image] IEnumType.Contains Method
IEnumType.Contains Method
Determines whether the enum values contains the specified name
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool Contains(
string name
)
VB
Function Contains (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if contains the value, otherwise, false.
Reference
IEnumType Interface
TwinCAT.TypeSystem Namespace


IEnumType.GetNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType Interface [image] IEnumType Methods [image] IEnumType.GetNames Method
IEnumType.GetNames Method
Gets the filed names of the IEnumType.T.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string[] GetNames()
VB
Function GetNames As String()
Return Value
Type: .String.
System.String[].
Reference
IEnumType Interface
TwinCAT.TypeSystem Namespace


IEnumType.GetValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType Interface [image] IEnumType Methods [image] IEnumType.GetValues Method
IEnumType.GetValues Method
Gets the values of the IEnumType.T.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object[] GetValues()
VB
Function GetValues As Object()
Return Value
Type: .Object.
T[].
Reference
IEnumType Interface
TwinCAT.TypeSystem Namespace


IEnumType.Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType Interface [image] IEnumType Methods [image] IEnumType.Parse Method
IEnumType.Parse Method
Parses a value name of the IEnumType.T. and returns the value (as base type)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object Parse(
string name
)
VB
Function Parse (
name As String
) As Object
Parameters
name
Type: System.String
The value name.
Return Value
Type: Object
T.
Reference
IEnumType Interface
TwinCAT.TypeSystem Namespace


IEnumType.ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType Interface [image] IEnumType Methods [image] IEnumType.ToString Method
IEnumType.ToString Method
Returns a String that represents the specified value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string ToString(
Object val
)
VB
Function ToString (
val As Object
) As String
Parameters
val
Type: System.Object
The value.
Return Value
Type: String
A String that represents this value.
Reference
IEnumType Interface
TwinCAT.TypeSystem Namespace


IEnumType.TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType Interface [image] IEnumType Methods [image] IEnumType.TryParse Method
IEnumType.TryParse Method
Parses the value from value name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TryParse(
string name,
out Object value
)
VB
Function TryParse (
name As String,
<OutAttribute> ByRef value As Object
) As Boolean
Parameters
name | Type: System.String The value name.
value | Type: System.Object. The value.
Return Value
Type: Boolean
true if value name was found, false otherwise.
Reference
IEnumType Interface
TwinCAT.TypeSystem Namespace


IEnumType.T. Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType.T. Interface
IEnumType.T. Interface
Interface representing an enum type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IEnumType<T> : IAliasType,
IDataType, IBitSize
where T : IConvertible
VB
Public Interface IEnumType(Of T As IConvertible)
Inherits IAliasType, IDataType, IBitSize
Type Parameters
T
Base type of the Enum
The IEnumType.T. type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the Base Type (Inherited from IAliasType.)
BaseTypeName | Gets the BaseType name (Inherited from IAliasType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
EnumValues | Enumeration specification (if enum)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Methods
Name | Description
Contains | Determines whether the enum values contains the specified name
GetNames | Gets the filed names of the IEnumType.T.
GetValues | Gets the values of the IEnumType.T.
Parse | Parses a name of the IEnumType.T. and returns the value (as base type)
ToString | Returns a String that represents the specified value.
TryParse | Parses the value from value name.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IEnumType.T. Properties
•
IEnumType.T. Methods


IEnumType.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType.T. Interface [image] IEnumType.T. Properties
IEnumType.T. Properties
The IEnumType.T. generic type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the Base Type (Inherited from IAliasType.)
BaseTypeName | Gets the BaseType name (Inherited from IAliasType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
EnumValues | Enumeration specification (if enum)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IEnumType.T. Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IEnumType.T..EnumValues Property


IEnumType.T..EnumValues Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType.T. Interface [image] IEnumType.T. Properties [image] IEnumType.T..EnumValues Property
IEnumType.T..EnumValues Property
Enumeration specification (if enum)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyEnumValueCollection<T> EnumValues { get; }
VB
ReadOnly Property EnumValues As ReadOnlyEnumValueCollection(Of T)
Get
Property Value
Type: ReadOnlyEnumValueCollection.T.
The enum specification.
Reference
IEnumType.T. Interface
TwinCAT.TypeSystem Namespace


IEnumType.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType.T. Interface [image] IEnumType.T. Methods
IEnumType.T. Methods
The IEnumType.T. generic type exposes the following members.
Methods
Name | Description
Contains | Determines whether the enum values contains the specified name
GetNames | Gets the filed names of the IEnumType.T.
GetValues | Gets the values of the IEnumType.T.
Parse | Parses a name of the IEnumType.T. and returns the value (as base type)
ToString | Returns a String that represents the specified value.
TryParse | Parses the value from value name.
Reference
IEnumType.T. Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IEnumType.T..Contains Method
•
IEnumType.T..GetNames Method
•
IEnumType.T..GetValues Method
•
IEnumType.T..Parse Method
•
IEnumType.T..ToString Method
•
IEnumType.T..TryParse Method


IEnumType.T..Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType.T. Interface [image] IEnumType.T. Methods [image] IEnumType.T..Contains Method
IEnumType.T..Contains Method
Determines whether the enum values contains the specified name
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool Contains(
string name
)
VB
Function Contains (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if contains the value, otherwise, false.
Reference
IEnumType.T. Interface
TwinCAT.TypeSystem Namespace


IEnumType.T..GetNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType.T. Interface [image] IEnumType.T. Methods [image] IEnumType.T..GetNames Method
IEnumType.T..GetNames Method
Gets the filed names of the IEnumType.T.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string[] GetNames()
VB
Function GetNames As String()
Return Value
Type: .String.
System.String[].
Reference
IEnumType.T. Interface
TwinCAT.TypeSystem Namespace


IEnumType.T..GetValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType.T. Interface [image] IEnumType.T. Methods [image] IEnumType.T..GetValues Method
IEnumType.T..GetValues Method
Gets the values of the IEnumType.T.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
T[] GetValues()
VB
Function GetValues As T()
Return Value
Type: .T.
T[].
Reference
IEnumType.T. Interface
TwinCAT.TypeSystem Namespace


IEnumType.T..Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType.T. Interface [image] IEnumType.T. Methods [image] IEnumType.T..Parse Method
IEnumType.T..Parse Method
Parses a name of the IEnumType.T. and returns the value (as base type)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
T Parse(
string name
)
VB
Function Parse (
name As String
) As T
Parameters
name
Type: System.String
The name.
Return Value
Type: T
T.
Reference
IEnumType.T. Interface
TwinCAT.TypeSystem Namespace


IEnumType.T..ToString Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType.T. Interface [image] IEnumType.T. Methods [image] IEnumType.T..ToString Method
IEnumType.T..ToString Method
Returns a String that represents the specified value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string ToString(
T val
)
VB
Function ToString (
val As T
) As String
Parameters
val
Type: T
The value.
Return Value
Type: String
A String that represents this value.
Reference
IEnumType.T. Interface
TwinCAT.TypeSystem Namespace


IEnumType.T..TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumType.T. Interface [image] IEnumType.T. Methods [image] IEnumType.T..TryParse Method
IEnumType.T..TryParse Method
Parses the value from value name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TryParse(
string name,
out T value
)
VB
Function TryParse (
name As String,
<OutAttribute> ByRef value As T
) As Boolean
Parameters
name | Type: System.String The value name.
value | Type: T. The value.
Return Value
Type: Boolean
true if value name was found, false otherwise.
Reference
IEnumType.T. Interface
TwinCAT.TypeSystem Namespace


IEnumValue Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumValue Interface
IEnumValue Interface
Generic interface for EnumValues
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IEnumValue
VB
Public Interface IEnumValue
The IEnumValue type exposes the following members.
Properties
Name | Description
ManagedBaseType | Gets the enumeration base type (sint,byte,short,ushort,int,uint,Int64,UInt64 supported)
Name | Gets the name of the Enumeration Value (value as string)
Primitive | Gets the (Primitive, BaseType) Value of the enumeration as object
RawValue | Gets the raw value of the enumeration (as byte array)
Size | Gets the size of the Enum value (in bytes)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IEnumValue Properties


IEnumValue Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumValue Interface [image] IEnumValue Properties
IEnumValue Properties
The IEnumValue type exposes the following members.
Properties
Name | Description
ManagedBaseType | Gets the enumeration base type (sint,byte,short,ushort,int,uint,Int64,UInt64 supported)
Name | Gets the name of the Enumeration Value (value as string)
Primitive | Gets the (Primitive, BaseType) Value of the enumeration as object
RawValue | Gets the raw value of the enumeration (as byte array)
Size | Gets the size of the Enum value (in bytes)
Reference
IEnumValue Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IEnumValue.ManagedBaseType Property
•
IEnumValue.Name Property
•
IEnumValue.Primitive Property
•
IEnumValue.RawValue Property
•
IEnumValue.Size Property


IEnumValue.ManagedBaseType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumValue Interface [image] IEnumValue Properties [image] IEnumValue.ManagedBaseType Property
IEnumValue.ManagedBaseType Property
Gets the enumeration base type (sint,byte,short,ushort,int,uint,Int64,UInt64 supported)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Type ManagedBaseType { get; }
VB
ReadOnly Property ManagedBaseType As Type
Get
Property Value
Type: Type
The type of the base.
Reference
IEnumValue Interface
TwinCAT.TypeSystem Namespace


IEnumValue.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumValue Interface [image] IEnumValue Properties [image] IEnumValue.Name Property
IEnumValue.Name Property
Gets the name of the Enumeration Value (value as string)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Name { get; }
VB
ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Reference
IEnumValue Interface
TwinCAT.TypeSystem Namespace


IEnumValue.Primitive Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumValue Interface [image] IEnumValue Properties [image] IEnumValue.Primitive Property
IEnumValue.Primitive Property
Gets the (Primitive, BaseType) Value of the enumeration as object
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object Primitive { get; }
VB
ReadOnly Property Primitive As Object
Get
Property Value
Type: Object
The object value.
Reference
IEnumValue Interface
TwinCAT.TypeSystem Namespace


IEnumValue.RawValue Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumValue Interface [image] IEnumValue Properties [image] IEnumValue.RawValue Property
IEnumValue.RawValue Property
Gets the raw value of the enumeration (as byte array)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
byte[] RawValue { get; }
VB
ReadOnly Property RawValue As Byte()
Get
Property Value
Type: .Byte.
The raw value.
Reference
IEnumValue Interface
TwinCAT.TypeSystem Namespace


IEnumValue.Size Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IEnumValue Interface [image] IEnumValue Properties [image] IEnumValue.Size Property
IEnumValue.Size Property
Gets the size of the Enum value (in bytes)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Size { get; }
VB
ReadOnly Property Size As Integer
Get
Property Value
Type: Int32
The size.
Reference
IEnumValue Interface
TwinCAT.TypeSystem Namespace


IField Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IField Interface
IField Interface
Specifies a single field/member of a Struct DataType.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IField : IAttributedInstance, IInstance,
IBitSize
VB
Public Interface IField
Inherits IAttributedInstance, IInstance, IBitSize
The IField type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
ParentType | Gets the Parent Struct/Union of this IField.
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IField Properties


IField Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IField Interface [image] IField Properties
IField Properties
The IField type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
ParentType | Gets the Parent Struct/Union of this IField.
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IField Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IField.ParentType Property


IField.ParentType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IField Interface [image] IField Properties [image] IField.ParentType Property
IField.ParentType Property
Gets the Parent Struct/Union of this IField.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType ParentType { get; }
VB
ReadOnly Property ParentType As IDataType
Get
Property Value
Type: IDataType
The type of the parent.
Reference
IField Interface
TwinCAT.TypeSystem Namespace


IInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IInstance Interface
IInstance Interface
Interface specifying instance objects.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IInstance : IBitSize
VB
Public Interface IInstance
Inherits IBitSize
The IInstance type exposes the following members.
Properties
Name | Description
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Comment | Gets the comment of the IInstance
DataType | Gets the IDataType of the IInstance.
InstanceName | Gets the name of the instance (without periods (.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.))
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO)
IsStatic | Gets a value indicating whether this IInstance is static.
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
TypeName | Gets the name of the DataType that is used for this IInstance.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IInstance Properties


IInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IInstance Interface [image] IInstance Properties
IInstance Properties
The IInstance type exposes the following members.
Properties
Name | Description
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Comment | Gets the comment of the IInstance
DataType | Gets the IDataType of the IInstance.
InstanceName | Gets the name of the instance (without periods (.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.))
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO)
IsStatic | Gets a value indicating whether this IInstance is static.
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
TypeName | Gets the name of the DataType that is used for this IInstance.
Reference
IInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IInstance.Comment Property
•
IInstance.DataType Property
•
IInstance.InstanceName Property
•
IInstance.InstancePath Property
•
IInstance.IsPointer Property
•
IInstance.IsReference Property
•
IInstance.IsStatic Property
•
IInstance.TypeName Property


IInstance.Comment Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IInstance Interface [image] IInstance Properties [image] IInstance.Comment Property
IInstance.Comment Property
Gets the comment of the IInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Comment { get; }
VB
ReadOnly Property Comment As String
Get
Property Value
Type: String
The comment.
Reference
IInstance Interface
TwinCAT.TypeSystem Namespace


IInstance.DataType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IInstance Interface [image] IInstance Properties [image] IInstance.DataType Property
IInstance.DataType Property
Gets the IDataType of the IInstance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType DataType { get; }
VB
ReadOnly Property DataType As IDataType
Get
Property Value
Type: IDataType
The type of the data.
Reference
IInstance Interface
TwinCAT.TypeSystem Namespace


IInstance.InstanceName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IInstance Interface [image] IInstance Properties [image] IInstance.InstanceName Property
IInstance.InstanceName Property
Gets the name of the instance (without periods (.)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string InstanceName { get; }
VB
ReadOnly Property InstanceName As String
Get
Property Value
Type: String
The name of the instance.
Reference
IInstance Interface
TwinCAT.TypeSystem Namespace


IInstance.InstancePath Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IInstance Interface [image] IInstance Properties [image] IInstance.InstancePath Property
IInstance.InstancePath Property
Gets the relative / absolute access path to the instance (with periods (.))
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string InstancePath { get; }
VB
ReadOnly Property InstancePath As String
Get
Property Value
Type: String
The instance path.
Remarks
If this path is relative or absolute depends on the context. IMember are using relative paths, ISymbols are using absolute ones.
Reference
IInstance Interface
TwinCAT.TypeSystem Namespace


IInstance.IsPointer Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IInstance Interface [image] IInstance Properties [image] IInstance.IsPointer Property
IInstance.IsPointer Property
Indicates that the IInstance represents a Pointer type (Pointer TO)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsPointer { get; }
VB
ReadOnly Property IsPointer As Boolean
Get
Property Value
Type: Boolean
true if is ReferenceTo, otherwise false.
Reference
IInstance Interface
TwinCAT.TypeSystem Namespace


IInstance.IsReference Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IInstance Interface [image] IInstance Properties [image] IInstance.IsReference Property
IInstance.IsReference Property
Indicates that the IInstance represents a Reference type (REFERENCE TO)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsReference { get; }
VB
ReadOnly Property IsReference As Boolean
Get
Property Value
Type: Boolean
true if is ReferenceTo, otherwise false.
Reference
IInstance Interface
TwinCAT.TypeSystem Namespace


IInstance.IsStatic Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IInstance Interface [image] IInstance Properties [image] IInstance.IsStatic Property
IInstance.IsStatic Property
Gets a value indicating whether this IInstance is static.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsStatic { get; }
VB
ReadOnly Property IsStatic As Boolean
Get
Property Value
Type: Boolean
true if this instance is static; otherwise, false.
Reference
IInstance Interface
TwinCAT.TypeSystem Namespace


IInstance.TypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IInstance Interface [image] IInstance Properties [image] IInstance.TypeName Property
IInstance.TypeName Property
Gets the name of the DataType that is used for this IInstance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string TypeName { get; }
VB
ReadOnly Property TypeName As String
Get
Property Value
Type: String
The name of the type.
Reference
IInstance Interface
TwinCAT.TypeSystem Namespace


IMember Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IMember Interface
IMember Interface
Specifies a single field/member of a Struct DataType.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IMember : IField,
IAttributedInstance, IInstance, IBitSize
VB
Public Interface IMember
Inherits IField, IAttributedInstance, IInstance, IBitSize
The IMember type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitOffset | Gets the bit offset.
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteOffset | Gets the byte offset.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Offset | Gets the offset of the IMember within the parent IStructType in bits or bytes dependent on IsBitType.
ParentType | Gets the Parent Struct/Union of this IField. (Inherited from IField.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IMember Properties


IMember Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IMember Interface [image] IMember Properties
IMember Properties
The IMember type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitOffset | Gets the bit offset.
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteOffset | Gets the byte offset.
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Offset | Gets the offset of the IMember within the parent IStructType in bits or bytes dependent on IsBitType.
ParentType | Gets the Parent Struct/Union of this IField. (Inherited from IField.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IMember Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IMember.BitOffset Property
•
IMember.ByteOffset Property
•
IMember.Offset Property


IMember.BitOffset Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IMember Interface [image] IMember Properties [image] IMember.BitOffset Property
IMember.BitOffset Property
Gets the bit offset.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int BitOffset { get; }
VB
ReadOnly Property BitOffset As Integer
Get
Property Value
Type: Int32
The bit offset.
Reference
IMember Interface
TwinCAT.TypeSystem Namespace


IMember.ByteOffset Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IMember Interface [image] IMember Properties [image] IMember.ByteOffset Property
IMember.ByteOffset Property
Gets the byte offset.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int ByteOffset { get; }
VB
ReadOnly Property ByteOffset As Integer
Get
Property Value
Type: Int32
The byte offset.
Reference
IMember Interface
TwinCAT.TypeSystem Namespace


IMember.Offset Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IMember Interface [image] IMember Properties [image] IMember.Offset Property
IMember.Offset Property
Gets the offset of the IMember within the parent IStructType in bits or bytes dependent on IsBitType.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Offset { get; }
VB
ReadOnly Property Offset As Integer
Get
Property Value
Type: Int32
The bit offset.
Reference
IMember Interface
TwinCAT.TypeSystem Namespace


INotificationSettings Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] INotificationSettings Interface
INotificationSettings Interface
Interface for Notification Settings
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface INotificationSettings : IComparable<INotificationSettings>
VB
Public Interface INotificationSettings
Inherits IComparable(Of INotificationSettings)
The INotificationSettings type exposes the following members.
Methods
Name | Description
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.INotificationSettings..)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
INotificationSettings Methods


INotificationSettings Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] INotificationSettings Interface [image] INotificationSettings Methods
INotificationSettings Methods
The INotificationSettings type exposes the following members.
Methods
Name | Description
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.INotificationSettings..)
Reference
INotificationSettings Interface
TwinCAT.TypeSystem Namespace


IOversamplingArrayInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IOversamplingArrayInstance Interface
IOversamplingArrayInstance Interface
Interface IOversamplingArrayInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IOversamplingArrayInstance : IArrayInstance,
ISymbol, IAttributedInstance, IInstance, IBitSize
VB
Public Interface IOversamplingArrayInstance
Inherits IArrayInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize
The IOversamplingArrayInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
Dimensions | Gets the dimensions as read only collection. (Inherited from IArrayInstance.)
Elements | Gets the contained Array Elements as read only collection. (Inherited from IArrayInstance.)
ElementType | Gets the type of the contained elements. (Inherited from IArrayInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Item | Gets the ISymbol with the specified indices. (Inherited from IArrayInstance.)
OversamplingElement | Gets the oversampling element.
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Methods
Name | Description
TryGetElement(IList..Int32.., ISymbol.) | Tries to get the array element with the specified indices (jagged array support). (Inherited from IArrayInstance.)
TryGetElement(.Int32., ISymbol.) | Tries to get the array element with specified indices (only first level on jagged arrays) (Inherited from IArrayInstance.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IArrayInstance
Weiterführende Informationen
•
IOversamplingArrayInstance Properties
•
IOversamplingArrayInstance Methods


IOversamplingArrayInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IOversamplingArrayInstance Interface [image] IOversamplingArrayInstance Properties
IOversamplingArrayInstance Properties
The IOversamplingArrayInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
Dimensions | Gets the dimensions as read only collection. (Inherited from IArrayInstance.)
Elements | Gets the contained Array Elements as read only collection. (Inherited from IArrayInstance.)
ElementType | Gets the type of the contained elements. (Inherited from IArrayInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Item | Gets the ISymbol with the specified indices. (Inherited from IArrayInstance.)
OversamplingElement | Gets the oversampling element.
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IOversamplingArrayInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IOversamplingArrayInstance.OversamplingElement Property


IOversamplingArrayInstance.OversamplingElement Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IOversamplingArrayInstance Interface [image] IOversamplingArrayInstance Properties [image] IOversamplingArrayInstance.OversamplingElement Property
IOversamplingArrayInstance.OversamplingElement Property
Gets the oversampling element.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ISymbol OversamplingElement { get; }
VB
ReadOnly Property OversamplingElement As ISymbol
Get
Property Value
Type: ISymbol
The oversampling element.
Reference
IOversamplingArrayInstance Interface
TwinCAT.TypeSystem Namespace


IOversamplingArrayInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IOversamplingArrayInstance Interface [image] IOversamplingArrayInstance Methods
IOversamplingArrayInstance Methods
Methods
Name | Description
TryGetElement(IList..Int32.., ISymbol.) | Tries to get the array element with the specified indices (jagged array support). (Inherited from IArrayInstance.)
TryGetElement(.Int32., ISymbol.) | Tries to get the array element with specified indices (only first level on jagged arrays) (Inherited from IArrayInstance.)
Reference
IOversamplingArrayInstance Interface
TwinCAT.TypeSystem Namespace


IPointerInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IPointerInstance Interface
IPointerInstance Interface
Interface representing an instance of an IPointerType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IPointerInstance : ISymbol,
IAttributedInstance, IInstance, IBitSize
VB
Public Interface IPointerInstance
Inherits ISymbol, IAttributedInstance, IInstance, IBitSize
The IPointerInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Reference | Gets the resolved reference of Pointer / Reference
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IPointerInstance Properties


IPointerInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IPointerInstance Interface [image] IPointerInstance Properties
IPointerInstance Properties
The IPointerInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Reference | Gets the resolved reference of Pointer / Reference
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IPointerInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IPointerInstance.Reference Property


IPointerInstance.Reference Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IPointerInstance Interface [image] IPointerInstance Properties [image] IPointerInstance.Reference Property
IPointerInstance.Reference Property
Gets the resolved reference of Pointer / Reference
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ISymbol Reference { get; }
VB
ReadOnly Property Reference As ISymbol
Get
Property Value
Type: ISymbol
The reference.
Reference
IPointerInstance Interface
TwinCAT.TypeSystem Namespace


IPointerType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IPointerType Interface
IPointerType Interface
Interface representing a pointer type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IPointerType : IDataType,
IBitSize
VB
Public Interface IPointerType
Inherits IDataType, IBitSize
The IPointerType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
ReferencedType | Gets the the referenced type.
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IPointerType Properties


IPointerType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IPointerType Interface [image] IPointerType Properties
IPointerType Properties
The IPointerType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
ReferencedType | Gets the the referenced type.
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IPointerType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IPointerType.ReferencedType Property


IPointerType.ReferencedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IPointerType Interface [image] IPointerType Properties [image] IPointerType.ReferencedType Property
IPointerType.ReferencedType Property
Gets the the referenced type.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType ReferencedType { get; }
VB
ReadOnly Property ReferencedType As IDataType
Get
Property Value
Type: IDataType
The type of the referenced.
Reference
IPointerType Interface
TwinCAT.TypeSystem Namespace


IPrimitiveType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IPrimitiveType Interface
IPrimitiveType Interface
Interface IPrimitiveType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IPrimitiveType : IDataType,
IBitSize
VB
Public Interface IPrimitiveType
Inherits IDataType, IBitSize
The IPrimitiveType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
PrimitiveFlags | Indicates types of different PrimitiveTypes with flags.
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IDataType
Weiterführende Informationen
•
IPrimitiveType Properties


IPrimitiveType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IPrimitiveType Interface [image] IPrimitiveType Properties
IPrimitiveType Properties
The IPrimitiveType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
PrimitiveFlags | Indicates types of different PrimitiveTypes with flags.
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IPrimitiveType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IPrimitiveType.PrimitiveFlags Property


IPrimitiveType.PrimitiveFlags Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IPrimitiveType Interface [image] IPrimitiveType Properties [image] IPrimitiveType.PrimitiveFlags Property
IPrimitiveType.PrimitiveFlags Property
Indicates types of different PrimitiveTypes with flags.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
PrimitiveTypeFlags PrimitiveFlags { get; }
VB
ReadOnly Property PrimitiveFlags As PrimitiveTypeFlags
Get
Property Value
Type: PrimitiveTypeFlags
Reference
IPrimitiveType Interface
TwinCAT.TypeSystem Namespace


IProcessImageAddress Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IProcessImageAddress Interface
IProcessImageAddress Interface
Interface describing a Process Image Address
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IProcessImageAddress : IBitSize
VB
Public Interface IProcessImageAddress
Inherits IBitSize
The IProcessImageAddress type exposes the following members.
Properties
Name | Description
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
IndexGroup | Gets the index group of the Symbol
IndexOffset | Gets the index offset of the Symbol
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IProcessImageAddress Properties


IProcessImageAddress Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IProcessImageAddress Interface [image] IProcessImageAddress Properties
IProcessImageAddress Properties
The IProcessImageAddress type exposes the following members.
Properties
Name | Description
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
IndexGroup | Gets the index group of the Symbol
IndexOffset | Gets the index offset of the Symbol
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IProcessImageAddress Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IProcessImageAddress.IndexGroup Property
•
IProcessImageAddress.IndexOffset Property


IProcessImageAddress.IndexGroup Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IProcessImageAddress Interface [image] IProcessImageAddress Properties [image] IProcessImageAddress.IndexGroup Property
IProcessImageAddress.IndexGroup Property
Gets the index group of the Symbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
uint IndexGroup { get; }
VB
ReadOnly Property IndexGroup As UInteger
Get
Property Value
Type: UInt32
The index group.
Reference
IProcessImageAddress Interface
TwinCAT.TypeSystem Namespace


IProcessImageAddress.IndexOffset Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IProcessImageAddress Interface [image] IProcessImageAddress Properties [image] IProcessImageAddress.IndexOffset Property
IProcessImageAddress.IndexOffset Property
Gets the index offset of the Symbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
uint IndexOffset { get; }
VB
ReadOnly Property IndexOffset As UInteger
Get
Property Value
Type: UInt32
The index offset.
Reference
IProcessImageAddress Interface
TwinCAT.TypeSystem Namespace


IReferenceInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceInstance Interface
IReferenceInstance Interface
Interface representing an instance of an IReferenceType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IReferenceInstance : ISymbol,
IAttributedInstance, IInstance, IBitSize
VB
Public Interface IReferenceInstance
Inherits ISymbol, IAttributedInstance, IInstance, IBitSize
The IReferenceInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
ReferencedType | Gets the referenced type
ResolvedByteSize | Get the ByteSize of the (completely) resolved Symbol
ResolvedCategory | Gets the Category of the Referenced Symbol.
ResolvedType | Gets the (completely) resolved type
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IReferenceInstance Properties


IReferenceInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceInstance Interface [image] IReferenceInstance Properties
IReferenceInstance Properties
The IReferenceInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
ReferencedType | Gets the referenced type
ResolvedByteSize | Get the ByteSize of the (completely) resolved Symbol
ResolvedCategory | Gets the Category of the Referenced Symbol.
ResolvedType | Gets the (completely) resolved type
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IReferenceInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IReferenceInstance.ReferencedType Property
•
IReferenceInstance.ResolvedByteSize Property
•
IReferenceInstance.ResolvedCategory Property
•
IReferenceInstance.ResolvedType Property


IReferenceInstance.ReferencedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceInstance Interface [image] IReferenceInstance Properties [image] IReferenceInstance.ReferencedType Property
IReferenceInstance.ReferencedType Property
Gets the referenced type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType ReferencedType { get; }
VB
ReadOnly Property ReferencedType As IDataType
Get
Property Value
Type: IDataType
The type of the referenced type
Remarks
This is no complete resolvement, only the next level. The referenced type can be a reference again.
Reference
IReferenceInstance Interface
TwinCAT.TypeSystem Namespace


IReferenceInstance.ResolvedByteSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceInstance Interface [image] IReferenceInstance Properties [image] IReferenceInstance.ResolvedByteSize Property
IReferenceInstance.ResolvedByteSize Property
Get the ByteSize of the (completely) resolved Symbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int ResolvedByteSize { get; }
VB
ReadOnly Property ResolvedByteSize As Integer
Get
Property Value
Type: Int32
The size of the resolved byte.
Reference
IReferenceInstance Interface
TwinCAT.TypeSystem Namespace


IReferenceInstance.ResolvedCategory Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceInstance Interface [image] IReferenceInstance Properties [image] IReferenceInstance.ResolvedCategory Property
IReferenceInstance.ResolvedCategory Property
Gets the Category of the Referenced Symbol.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
DataTypeCategory ResolvedCategory { get; }
VB
ReadOnly Property ResolvedCategory As DataTypeCategory
Get
Property Value
Type: DataTypeCategory
The resolved category.
Reference
IReferenceInstance Interface
TwinCAT.TypeSystem Namespace


IReferenceInstance.ResolvedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceInstance Interface [image] IReferenceInstance Properties [image] IReferenceInstance.ResolvedType Property
IReferenceInstance.ResolvedType Property
Gets the (completely) resolved type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType ResolvedType { get; }
VB
ReadOnly Property ResolvedType As IDataType
Get
Property Value
Type: IDataType
The type of the resolved symbol
Reference
IReferenceInstance Interface
TwinCAT.TypeSystem Namespace


IReferenceType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceType Interface
IReferenceType Interface
Interface representing a reference/pointer type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IReferenceType : IDataType,
IBitSize
VB
Public Interface IReferenceType
Inherits IDataType, IBitSize
The IReferenceType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
ReferencedType | Gets the the referenced type.
ResolvedByteSize | Get the ByteSize of the (completely) resolved Symbol
ResolvedCategory | Gets the Category of the (completely) resolved Symbol.
ResolvedType | Gets the (completely) resolved type
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IReferenceType Properties


IReferenceType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceType Interface [image] IReferenceType Properties
IReferenceType Properties
The IReferenceType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
ReferencedType | Gets the the referenced type.
ResolvedByteSize | Get the ByteSize of the (completely) resolved Symbol
ResolvedCategory | Gets the Category of the (completely) resolved Symbol.
ResolvedType | Gets the (completely) resolved type
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IReferenceType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IReferenceType.ReferencedType Property
•
IReferenceType.ResolvedByteSize Property
•
IReferenceType.ResolvedCategory Property
•
IReferenceType.ResolvedType Property


IReferenceType.ReferencedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceType Interface [image] IReferenceType Properties [image] IReferenceType.ReferencedType Property
IReferenceType.ReferencedType Property
Gets the the referenced type.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType ReferencedType { get; }
VB
ReadOnly Property ReferencedType As IDataType
Get
Property Value
Type: IDataType
The type of the referenced.
Reference
IReferenceType Interface
TwinCAT.TypeSystem Namespace


IReferenceType.ResolvedByteSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceType Interface [image] IReferenceType Properties [image] IReferenceType.ResolvedByteSize Property
IReferenceType.ResolvedByteSize Property
Get the ByteSize of the (completely) resolved Symbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int ResolvedByteSize { get; }
VB
ReadOnly Property ResolvedByteSize As Integer
Get
Property Value
Type: Int32
The size of the resolved byte.
Reference
IReferenceType Interface
TwinCAT.TypeSystem Namespace


IReferenceType.ResolvedCategory Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceType Interface [image] IReferenceType Properties [image] IReferenceType.ResolvedCategory Property
IReferenceType.ResolvedCategory Property
Gets the Category of the (completely) resolved Symbol.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
DataTypeCategory ResolvedCategory { get; }
VB
ReadOnly Property ResolvedCategory As DataTypeCategory
Get
Property Value
Type: DataTypeCategory
The resolved category.
Reference
IReferenceType Interface
TwinCAT.TypeSystem Namespace


IReferenceType.ResolvedType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IReferenceType Interface [image] IReferenceType Properties [image] IReferenceType.ResolvedType Property
IReferenceType.ResolvedType Property
Gets the (completely) resolved type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType ResolvedType { get; }
VB
ReadOnly Property ResolvedType As IDataType
Get
Property Value
Type: IDataType
The type of the resolved symbol
Reference
IReferenceType Interface
TwinCAT.TypeSystem Namespace


IRpcCallableInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcCallableInstance Interface
IRpcCallableInstance Interface
Interface for an RPC callable PLC Method (Remote procedure call)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IRpcCallableInstance
VB
Public Interface IRpcCallableInstance
The IRpcCallableInstance type exposes the following members.
Properties
Name | Description
RpcMethods | Gets the Method descriptions for the IRpcCallableType
Methods
Name | Description
InvokeRpcMethod | Invokes the specified method.
TryInvokeRpcMethod(String, .Object., Object.) | Tries to invoke the specified method.
TryInvokeRpcMethod(IRpcMethod, .Object., Object.) | Tries to invoke the specified method.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IRpcCallableInstance Properties
•
IRpcCallableInstance Methods


IRpcCallableInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcCallableInstance Interface [image] IRpcCallableInstance Properties
IRpcCallableInstance Properties
The IRpcCallableInstance type exposes the following members.
Properties
Name | Description
RpcMethods | Gets the Method descriptions for the IRpcCallableType
Reference
IRpcCallableInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IRpcCallableInstance.RpcMethods Property


IRpcCallableInstance.RpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcCallableInstance Interface [image] IRpcCallableInstance Properties [image] IRpcCallableInstance.RpcMethods Property
IRpcCallableInstance.RpcMethods Property
Gets the Method descriptions for the IRpcCallableType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyRpcMethodCollection RpcMethods { get; }
VB
ReadOnly Property RpcMethods As ReadOnlyRpcMethodCollection
Get
Property Value
Type: ReadOnlyRpcMethodCollection
The methods.
Reference
IRpcCallableInstance Interface
TwinCAT.TypeSystem Namespace


IRpcCallableInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcCallableInstance Interface [image] IRpcCallableInstance Methods
IRpcCallableInstance Methods
The IRpcCallableInstance type exposes the following members.
Methods
Name | Description
InvokeRpcMethod | Invokes the specified method.
TryInvokeRpcMethod(String, .Object., Object.) | Tries to invoke the specified method.
TryInvokeRpcMethod(IRpcMethod, .Object., Object.) | Tries to invoke the specified method.
Reference
IRpcCallableInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IRpcCallableInstance.InvokeRpcMethod Method
•
IRpcCallableInstance.TryInvokeRpcMethod Method


IRpcCallableInstance.InvokeRpcMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcCallableInstance Interface [image] IRpcCallableInstance Methods [image] IRpcCallableInstance.InvokeRpcMethod Method
IRpcCallableInstance.InvokeRpcMethod Method
Invokes the specified method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object InvokeRpcMethod(
string methodName,
Object[] parameters
)
VB
Function InvokeRpcMethod (
methodName As String,
parameters As Object()
) As Object
Parameters
methodName | Type: System.String Name of the method.
parameters | Type: .System.Object. The parameters.
Return Value
Type: Object
The return value of the RPC Method
Remarks
To indicate a PLC Method for remote ads access, the attribute 'TcRpcEnable' must be declared on the method declaration (see example).
Examples
RPC Method definition and implementation
(* Declaration *)
{attribute 'TcRpcEnable'}
METHOD RpcMethod1 : INT
VAR_INPUT
i1 : INT;
END_VAR

(* Implementation *)
RpcMethod1 := i1 + 1;
Reference
IRpcCallableInstance Interface
TwinCAT.TypeSystem Namespace


IRpcCallableInstance.TryInvokeRpcMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcCallableInstance Interface [image] IRpcCallableInstance Methods [image] IRpcCallableInstance.TryInvokeRpcMethod Method
IRpcCallableInstance.TryInvokeRpcMethod Method
Overload List
Name | Description
TryInvokeRpcMethod(String, .Object., Object.) | Tries to invoke the specified method.
TryInvokeRpcMethod(IRpcMethod, .Object., Object.) | Tries to invoke the specified method.
Reference
IRpcCallableInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IRpcCallableInstance.TryInvokeRpcMethod Method (String, .Object., Object.)
•
IRpcCallableInstance.TryInvokeRpcMethod Method (IRpcMethod, .Object., Object.)


IRpcCallableInstance.TryInvokeRpcMethod Method (String, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcCallableInstance Interface [image] IRpcCallableInstance Methods [image] IRpcCallableInstance.TryInvokeRpcMethod Method [image] IRpcCallableInstance.TryInvokeRpcMethod Method (String, .Object., Object.)
IRpcCallableInstance.TryInvokeRpcMethod Method (String, .Object., Object.)
Tries to invoke the specified method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int TryInvokeRpcMethod(
string methodName,
Object[] args,
out Object result
)
VB
Function TryInvokeRpcMethod (
methodName As String,
args As Object(),
<OutAttribute> ByRef result As Object
) As Integer
Parameters
methodName | Type: System.String Name of the method.
args | Type: .System.Object. The arguments.
result | Type: System.Object. The result.
Return Value
Type: Int32
true if the call succeeds, false otherwise.
Reference
IRpcCallableInstance Interface
TryInvokeRpcMethod Overload
TwinCAT.TypeSystem Namespace


IRpcCallableInstance.TryInvokeRpcMethod Method (IRpcMethod, .Object., Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcCallableInstance Interface [image] IRpcCallableInstance Methods [image] IRpcCallableInstance.TryInvokeRpcMethod Method [image] IRpcCallableInstance.TryInvokeRpcMethod Method (IRpcMethod, .Object., Object.)
IRpcCallableInstance.TryInvokeRpcMethod Method (IRpcMethod, .Object., Object.)
Tries to invoke the specified method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int TryInvokeRpcMethod(
IRpcMethod method,
Object[] args,
out Object result
)
VB
Function TryInvokeRpcMethod (
method As IRpcMethod,
args As Object(),
<OutAttribute> ByRef result As Object
) As Integer
Parameters
method | Type: TwinCAT.TypeSystem.IRpcMethod The method.
args | Type: .System.Object. The arguments.
result | Type: System.Object. The result.
Return Value
Type: Int32
true if the call succeeds, false otherwise.
Reference
IRpcCallableInstance Interface
TryInvokeRpcMethod Overload
TwinCAT.TypeSystem Namespace


IRpcCallableType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcCallableType Interface
IRpcCallableType Interface
Interface representing an RPC callable IStructType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IRpcCallableType
VB
Public Interface IRpcCallableType
The IRpcCallableType type exposes the following members.
Properties
Name | Description
RpcMethods | Gets the Method descriptions for the IRpcCallableType
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IRpcCallableType Properties


IRpcCallableType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcCallableType Interface [image] IRpcCallableType Properties
IRpcCallableType Properties
The IRpcCallableType type exposes the following members.
Properties
Name | Description
RpcMethods | Gets the Method descriptions for the IRpcCallableType
Reference
IRpcCallableType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IRpcCallableType.RpcMethods Property


IRpcCallableType.RpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcCallableType Interface [image] IRpcCallableType Properties [image] IRpcCallableType.RpcMethods Property
IRpcCallableType.RpcMethods Property
Gets the Method descriptions for the IRpcCallableType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyRpcMethodCollection RpcMethods { get; }
VB
ReadOnly Property RpcMethods As ReadOnlyRpcMethodCollection
Get
Property Value
Type: ReadOnlyRpcMethodCollection
The RPC methods.
Remarks
The DataType (Structure) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods, otherwise RpcMethods are not passed through to the ADS symbolic information.
Reference
IRpcCallableType Interface
TwinCAT.TypeSystem Namespace


IRpcMethod Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethod Interface
IRpcMethod Interface
Interface describes an RPC Method
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IRpcMethod
VB
Public Interface IRpcMethod
The IRpcMethod type exposes the following members.
Properties
Name | Description
Comment | Gets the Method comment.
IsVoid | Gets a value indicating whether this IRpcMethod has no return parameter
Name | Gets the name of the method
Parameters | Gets the Method parameter descriptions.
ReturnType | Gets the return type.
ReturnTypeSize | Gets the size of the return type in bytes.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IRpcMethod Properties


IRpcMethod Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethod Interface [image] IRpcMethod Properties
IRpcMethod Properties
The IRpcMethod type exposes the following members.
Properties
Name | Description
Comment | Gets the Method comment.
IsVoid | Gets a value indicating whether this IRpcMethod has no return parameter
Name | Gets the name of the method
Parameters | Gets the Method parameter descriptions.
ReturnType | Gets the return type.
ReturnTypeSize | Gets the size of the return type in bytes.
Reference
IRpcMethod Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IRpcMethod.Comment Property
•
IRpcMethod.IsVoid Property
•
IRpcMethod.Name Property
•
IRpcMethod.Parameters Property
•
IRpcMethod.ReturnType Property
•
IRpcMethod.ReturnTypeSize Property


IRpcMethod.Comment Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethod Interface [image] IRpcMethod Properties [image] IRpcMethod.Comment Property
IRpcMethod.Comment Property
Gets the Method comment.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Comment { get; }
VB
ReadOnly Property Comment As String
Get
Property Value
Type: String
The comment.
Reference
IRpcMethod Interface
TwinCAT.TypeSystem Namespace


IRpcMethod.IsVoid Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethod Interface [image] IRpcMethod Properties [image] IRpcMethod.IsVoid Property
IRpcMethod.IsVoid Property
Gets a value indicating whether this IRpcMethod has no return parameter
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsVoid { get; }
VB
ReadOnly Property IsVoid As Boolean
Get
Property Value
Type: Boolean
true if this instance is void; otherwise, false.
Reference
IRpcMethod Interface
TwinCAT.TypeSystem Namespace


IRpcMethod.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethod Interface [image] IRpcMethod Properties [image] IRpcMethod.Name Property
IRpcMethod.Name Property
Gets the name of the method
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Name { get; }
VB
ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Reference
IRpcMethod Interface
TwinCAT.TypeSystem Namespace


IRpcMethod.Parameters Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethod Interface [image] IRpcMethod Properties [image] IRpcMethod.Parameters Property
IRpcMethod.Parameters Property
Gets the Method parameter descriptions.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyMethodParameterCollection Parameters { get; }
VB
ReadOnly Property Parameters As ReadOnlyMethodParameterCollection
Get
Property Value
Type: ReadOnlyMethodParameterCollection
The parameters.
Reference
IRpcMethod Interface
TwinCAT.TypeSystem Namespace


IRpcMethod.ReturnType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethod Interface [image] IRpcMethod Properties [image] IRpcMethod.ReturnType Property
IRpcMethod.ReturnType Property
Gets the return type.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string ReturnType { get; }
VB
ReadOnly Property ReturnType As String
Get
Property Value
Type: String
Return type.
Reference
IRpcMethod Interface
TwinCAT.TypeSystem Namespace


IRpcMethod.ReturnTypeSize Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethod Interface [image] IRpcMethod Properties [image] IRpcMethod.ReturnTypeSize Property
IRpcMethod.ReturnTypeSize Property
Gets the size of the return type in bytes.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int ReturnTypeSize { get; }
VB
ReadOnly Property ReturnTypeSize As Integer
Get
Property Value
Type: Int32
The size of the return type.
Reference
IRpcMethod Interface
TwinCAT.TypeSystem Namespace


IRpcMethodParameter Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethodParameter Interface
IRpcMethodParameter Interface
Interface IRpcMethodParameter
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IRpcMethodParameter
VB
Public Interface IRpcMethodParameter
The IRpcMethodParameter type exposes the following members.
Properties
Name | Description
Name | Gets the Parameter Name
ParameterFlags | Gets the parameter flags.
Size | Gets the size of the IRpcMethodParameter
TypeName | Gets the Data type of the Parameter
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IRpcMethodParameter Properties


IRpcMethodParameter Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethodParameter Interface [image] IRpcMethodParameter Properties
IRpcMethodParameter Properties
The IRpcMethodParameter type exposes the following members.
Properties
Name | Description
Name | Gets the Parameter Name
ParameterFlags | Gets the parameter flags.
Size | Gets the size of the IRpcMethodParameter
TypeName | Gets the Data type of the Parameter
Reference
IRpcMethodParameter Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IRpcMethodParameter.Name Property
•
IRpcMethodParameter.ParameterFlags Property
•
IRpcMethodParameter.Size Property
•
IRpcMethodParameter.TypeName Property


IRpcMethodParameter.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethodParameter Interface [image] IRpcMethodParameter Properties [image] IRpcMethodParameter.Name Property
IRpcMethodParameter.Name Property
Gets the Parameter Name
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Name { get; }
VB
ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Reference
IRpcMethodParameter Interface
TwinCAT.TypeSystem Namespace


IRpcMethodParameter.ParameterFlags Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethodParameter Interface [image] IRpcMethodParameter Properties [image] IRpcMethodParameter.ParameterFlags Property
IRpcMethodParameter.ParameterFlags Property
Gets the parameter flags.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
MethodParamFlags ParameterFlags { get; }
VB
ReadOnly Property ParameterFlags As MethodParamFlags
Get
Property Value
Type: MethodParamFlags
The parameter flags.
Reference
IRpcMethodParameter Interface
TwinCAT.TypeSystem Namespace


IRpcMethodParameter.Size Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethodParameter Interface [image] IRpcMethodParameter Properties [image] IRpcMethodParameter.Size Property
IRpcMethodParameter.Size Property
Gets the size of the IRpcMethodParameter
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Size { get; }
VB
ReadOnly Property Size As Integer
Get
Property Value
Type: Int32
The size.
Reference
IRpcMethodParameter Interface
TwinCAT.TypeSystem Namespace


IRpcMethodParameter.TypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcMethodParameter Interface [image] IRpcMethodParameter Properties [image] IRpcMethodParameter.TypeName Property
IRpcMethodParameter.TypeName Property
Gets the Data type of the Parameter
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string TypeName { get; }
VB
ReadOnly Property TypeName As String
Get
Property Value
Type: String
The type.
Reference
IRpcMethodParameter Interface
TwinCAT.TypeSystem Namespace


IRpcStructInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcStructInstance Interface
IRpcStructInstance Interface
Interface IRpcStructInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IRpcStructInstance : IStructInstance,
ISymbol, IAttributedInstance, IInstance, IBitSize, IRpcCallableInstance
VB
Public Interface IRpcStructInstance
Inherits IStructInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize, IRpcCallableInstance
The IRpcStructInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Inherited from IStructInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
MemberInstances | Gets the member instances of the Struct Instance. (Inherited from IStructInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
RpcMethods | Gets the Method descriptions for the IRpcCallableType (Inherited from IRpcCallableInstance.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Methods
Name | Description
InvokeRpcMethod | Invokes the specified method. (Inherited from IRpcCallableInstance.)
TryInvokeRpcMethod(String, .Object., Object.) | Tries to invoke the specified method. (Inherited from IRpcCallableInstance.)
TryInvokeRpcMethod(IRpcMethod, .Object., Object.) | Tries to invoke the specified method. (Inherited from IRpcCallableInstance.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IStructInstance
TwinCAT.TypeSystem.IRpcCallableInstance
Weiterführende Informationen
•
IRpcStructInstance Properties
•
IRpcStructInstance Methods


IRpcStructInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcStructInstance Interface [image] IRpcStructInstance Properties
IRpcStructInstance Properties
The IRpcStructInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Inherited from IStructInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
MemberInstances | Gets the member instances of the Struct Instance. (Inherited from IStructInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
RpcMethods | Gets the Method descriptions for the IRpcCallableType (Inherited from IRpcCallableInstance.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IRpcStructInstance Interface
TwinCAT.TypeSystem Namespace


IRpcStructInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IRpcStructInstance Interface [image] IRpcStructInstance Methods
IRpcStructInstance Methods
The IRpcStructInstance type exposes the following members.
Methods
Name | Description
InvokeRpcMethod | Invokes the specified method. (Inherited from IRpcCallableInstance.)
TryInvokeRpcMethod(String, .Object., Object.) | Tries to invoke the specified method. (Inherited from IRpcCallableInstance.)
TryInvokeRpcMethod(IRpcMethod, .Object., Object.) | Tries to invoke the specified method. (Inherited from IRpcCallableInstance.)
Reference
IRpcStructInstance Interface
TwinCAT.TypeSystem Namespace


IStringInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStringInstance Interface
IStringInstance Interface
Interface IStringInstance
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IStringInstance : ISymbol,
IAttributedInstance, IInstance, IBitSize
VB
Public Interface IStringInstance
Inherits ISymbol, IAttributedInstance, IInstance, IBitSize
The IStringInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
Encoding | Gets the encoding of the String (Encoding.Default (STRING) or Encoding.UNICODE (WSTRING))
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsFixedLength | Gets a value indicating whether this instance is a string of static length
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.ISymbol
TwinCAT.TypeSystem.IStringType
Weiterführende Informationen
•
IStringInstance Properties


IStringInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStringInstance Interface [image] IStringInstance Properties
IStringInstance Properties
The IStringInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
Encoding | Gets the encoding of the String (Encoding.Default (STRING) or Encoding.UNICODE (WSTRING))
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsFixedLength | Gets a value indicating whether this instance is a string of static length
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IStringInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IStringInstance.Encoding Property
•
IStringInstance.IsFixedLength Property


IStringInstance.Encoding Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStringInstance Interface [image] IStringInstance Properties [image] IStringInstance.Encoding Property
IStringInstance.Encoding Property
Gets the encoding of the String (Encoding.Default (STRING) or Encoding.UNICODE (WSTRING))
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Encoding Encoding { get; }
VB
ReadOnly Property Encoding As Encoding
Get
Property Value
Type: Encoding
The encoding.
Reference
IStringInstance Interface
TwinCAT.TypeSystem Namespace


IStringInstance.IsFixedLength Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStringInstance Interface [image] IStringInstance Properties [image] IStringInstance.IsFixedLength Property
IStringInstance.IsFixedLength Property
Gets a value indicating whether this instance is a string of static length
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsFixedLength { get; }
VB
ReadOnly Property IsFixedLength As Boolean
Get
Property Value
Type: Boolean
true if this instance is of static length; otherwise, false.
Reference
IStringInstance Interface
TwinCAT.TypeSystem Namespace


IStringType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStringType Interface
IStringType Interface
Interface representing a string IDataType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IStringType : IDataType,
IBitSize
VB
Public Interface IStringType
Inherits IDataType, IBitSize
The IStringType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
Encoding | Gets the encoding of the String (Encoding.Default (STRING) or Encoding.UNICODE (WSTRING))
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsFixedLength | Gets a value indicating whether the string is of fixed length.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Length | Gets the number of characters within the string (when fixed length).
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IStringType Properties


IStringType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStringType Interface [image] IStringType Properties
IStringType Properties
The IStringType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
Encoding | Gets the encoding of the String (Encoding.Default (STRING) or Encoding.UNICODE (WSTRING))
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsFixedLength | Gets a value indicating whether the string is of fixed length.
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Length | Gets the number of characters within the string (when fixed length).
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IStringType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IStringType.Encoding Property
•
IStringType.IsFixedLength Property
•
IStringType.Length Property


IStringType.Encoding Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStringType Interface [image] IStringType Properties [image] IStringType.Encoding Property
IStringType.Encoding Property
Gets the encoding of the String (Encoding.Default (STRING) or Encoding.UNICODE (WSTRING))
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Encoding Encoding { get; }
VB
ReadOnly Property Encoding As Encoding
Get
Property Value
Type: Encoding
The encoding.
Reference
IStringType Interface
TwinCAT.TypeSystem Namespace


IStringType.IsFixedLength Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStringType Interface [image] IStringType Properties [image] IStringType.IsFixedLength Property
IStringType.IsFixedLength Property
Gets a value indicating whether the string is of fixed length.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsFixedLength { get; }
VB
ReadOnly Property IsFixedLength As Boolean
Get
Property Value
Type: Boolean
true if this instance is fixed length; otherwise, false.
Reference
IStringType Interface
TwinCAT.TypeSystem Namespace


IStringType.Length Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStringType Interface [image] IStringType Properties [image] IStringType.Length Property
IStringType.Length Property
Gets the number of characters within the string (when fixed length).
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int Length { get; }
VB
ReadOnly Property Length As Integer
Get
Property Value
Type: Int32
The length if fixed length, otherwise -1
Reference
IStringType Interface
TwinCAT.TypeSystem Namespace


IStructInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructInstance Interface
IStructInstance Interface
Interface representing an instance of a IStructType
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IStructInstance : ISymbol,
IAttributedInstance, IInstance, IBitSize
VB
Public Interface IStructInstance
Inherits ISymbol, IAttributedInstance, IInstance, IBitSize
The IStructInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
MemberInstances | Gets the member instances of the Struct Instance.
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IStructInstance Properties


IStructInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructInstance Interface [image] IStructInstance Properties
IStructInstance Properties
The IStructInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
MemberInstances | Gets the member instances of the Struct Instance.
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IStructInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IStructInstance.HasRpcMethods Property
•
IStructInstance.MemberInstances Property


IStructInstance.HasRpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructInstance Interface [image] IStructInstance Properties [image] IStructInstance.HasRpcMethods Property
IStructInstance.HasRpcMethods Property
Gets a value indicating whether this instance has RPC methods
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool HasRpcMethods { get; }
VB
ReadOnly Property HasRpcMethods As Boolean
Get
Property Value
Type: Boolean
true if this instance has RPC methods; otherwise, false.
Remarks
If the struct instance supports RPC Methods, then the instance class is also supporting IRpcStructInstance:
Reference
IStructInstance Interface
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IRpcStructInstance
TwinCAT.TypeSystem.IRpcMethod
TwinCAT.TypeSystem.IRpcMethodParameter


IStructInstance.MemberInstances Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructInstance Interface [image] IStructInstance Properties [image] IStructInstance.MemberInstances Property
IStructInstance.MemberInstances Property
Gets the member instances of the Struct Instance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlySymbolCollection MemberInstances { get; }
VB
ReadOnly Property MemberInstances As ReadOnlySymbolCollection
Get
Property Value
Type: ReadOnlySymbolCollection
The member instances.
Reference
IStructInstance Interface
TwinCAT.TypeSystem Namespace


IStructType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructType Interface
IStructType Interface
Interface representing Struct data types
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IStructType : IDataType,
IBitSize
VB
Public Interface IStructType
Inherits IDataType, IBitSize
The IStructType type exposes the following members.
Properties
Name | Description
AllMembers | Gets all members (down the derivation hierarchy)
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the structs Base Type (Null if not derived).
BaseTypeName | Gets the the Name of the Base class (if derived)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Members | Gets a readonly collection of the Members of the IStructType.
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IStructType Properties


IStructType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructType Interface [image] IStructType Properties
IStructType Properties
The IStructType type exposes the following members.
Properties
Name | Description
AllMembers | Gets all members (down the derivation hierarchy)
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the structs Base Type (Null if not derived).
BaseTypeName | Gets the the Name of the Base class (if derived)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Struct types only)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Members | Gets a readonly collection of the Members of the IStructType.
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IStructType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IStructType.AllMembers Property
•
IStructType.BaseType Property
•
IStructType.BaseTypeName Property
•
IStructType.HasRpcMethods Property
•
IStructType.Members Property


IStructType.AllMembers Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructType Interface [image] IStructType Properties [image] IStructType.AllMembers Property
IStructType.AllMembers Property
Gets all members (down the derivation hierarchy)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyMemberCollection AllMembers { get; }
VB
ReadOnly Property AllMembers As ReadOnlyMemberCollection
Get
Property Value
Type: ReadOnlyMemberCollection
All members.
Reference
IStructType Interface
TwinCAT.TypeSystem Namespace


IStructType.BaseType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructType Interface [image] IStructType Properties [image] IStructType.BaseType Property
IStructType.BaseType Property
Gets the structs Base Type (Null if not derived).
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType BaseType { get; }
VB
ReadOnly Property BaseType As IDataType
Get
Property Value
Type: IDataType
Reference
IStructType Interface
TwinCAT.TypeSystem Namespace


IStructType.BaseTypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructType Interface [image] IStructType Properties [image] IStructType.BaseTypeName Property
IStructType.BaseTypeName Property
Gets the the Name of the Base class (if derived)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string BaseTypeName { get; }
VB
ReadOnly Property BaseTypeName As String
Get
Property Value
Type: String
Empty if not derived.
Reference
IStructType Interface
TwinCAT.TypeSystem Namespace


IStructType.HasRpcMethods Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructType Interface [image] IStructType Properties [image] IStructType.HasRpcMethods Property
IStructType.HasRpcMethods Property
Gets a value indicating whether this instance has RPC methods (Struct types only)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool HasRpcMethods { get; }
VB
ReadOnly Property HasRpcMethods As Boolean
Get
Property Value
Type: Boolean
true if this instance has RPC methods; otherwise, false.
Remarks
The DataType (Structure) must be marked with the PlcAttribute 'TcRpcEnable' to enable RpcMethods, otherwise RpcMethods are not passed through to the ADS symbolic information.
Reference
IStructType Interface
TwinCAT.TypeSystem Namespace


IStructType.Members Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructType Interface [image] IStructType Properties [image] IStructType.Members Property
IStructType.Members Property
Gets a readonly collection of the Members of the IStructType.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyMemberCollection Members { get; }
VB
ReadOnly Property Members As ReadOnlyMemberCollection
Get
Property Value
Type: ReadOnlyMemberCollection
The members as readonly collection.
Remarks
If the IStructType is derived, only the extended members are returned. To get all supported members down the inheritance chain, use the AllMembers property.
Reference
IStructType Interface
TwinCAT.TypeSystem Namespace


IStructValue Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructValue Interface
IStructValue Interface
Interface IStructValue
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IStructValue : IValue
VB
Public Interface IStructValue
Inherits IValue
The IStructValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value) (Inherited from IValue.)
CachedRaw | Gets the cached Raw internal Data. (Inherited from IValue.)
DataType | Gets the data type bound to this IValue (Inherited from IValue.)
IsPrimitive | Gets a value indicating whether this IValue is a primitive value. (Inherited from IValue.)
Symbol | Gets the symbol bound to this IValue. (Inherited from IValue.)
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value (local user time, UTC) (Inherited from IValue.)
Methods
Name | Description
Read | Reads the value (via ADS) (Inherited from IValue.)
ResolveValue | Resolves the Value object to its primitive value. (Inherited from IValue.)
TryGetMemberValue | Tries to get a property/Member value.
TryResolveValue | Tries to resolves the Value object to its primitive value. (Inherited from IValue.)
TrySetMemberValue | Tries to Set a Member/Property Value
Write | Writes the value (via ADS) (Inherited from IValue.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IValue
Weiterführende Informationen
•
IStructValue Properties
•
IStructValue Methods


IStructValue Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructValue Interface [image] IStructValue Properties
IStructValue Properties
The IStructValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value) (Inherited from IValue.)
CachedRaw | Gets the cached Raw internal Data. (Inherited from IValue.)
DataType | Gets the data type bound to this IValue (Inherited from IValue.)
IsPrimitive | Gets a value indicating whether this IValue is a primitive value. (Inherited from IValue.)
Symbol | Gets the symbol bound to this IValue. (Inherited from IValue.)
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value (local user time, UTC) (Inherited from IValue.)
Reference
IStructValue Interface
TwinCAT.TypeSystem Namespace


IStructValue Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructValue Interface [image] IStructValue Methods
IStructValue Methods
The IStructValue type exposes the following members.
Methods
Name | Description
Read | Reads the value (via ADS) (Inherited from IValue.)
ResolveValue | Resolves the Value object to its primitive value. (Inherited from IValue.)
TryGetMemberValue | Tries to get a property/Member value.
TryResolveValue | Tries to resolves the Value object to its primitive value. (Inherited from IValue.)
TrySetMemberValue | Tries to Set a Member/Property Value
Write | Writes the value (via ADS) (Inherited from IValue.)
Reference
IStructValue Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IStructValue.TryGetMemberValue Method
•
IStructValue.TrySetMemberValue Method


IStructValue.TryGetMemberValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructValue Interface [image] IStructValue Methods [image] IStructValue.TryGetMemberValue Method
IStructValue.TryGetMemberValue Method
Tries to get a property/Member value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TryGetMemberValue(
string name,
out Object value
)
VB
Function TryGetMemberValue (
name As String,
<OutAttribute> ByRef value As Object
) As Boolean
Parameters
name | Type: System.String The name of the member
value | Type: System.Object. The value.
Return Value
Type: Boolean
true if succeeded, otherwise false otherwise.
Reference
IStructValue Interface
TwinCAT.TypeSystem Namespace


IStructValue.TrySetMemberValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IStructValue Interface [image] IStructValue Methods [image] IStructValue.TrySetMemberValue Method
IStructValue.TrySetMemberValue Method
Tries to Set a Member/Property Value
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TrySetMemberValue(
string name,
Object value
)
VB
Function TrySetMemberValue (
name As String,
value As Object
) As Boolean
Parameters
name | Type: System.String The name of the member
value | Type: System.Object The value.
Return Value
Type: Boolean
true if succeeded, otherwise false otherwise.
Reference
IStructValue Interface
TwinCAT.TypeSystem Namespace


ISubRangeType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISubRangeType Interface
ISubRangeType Interface
Interface representing a SubRange type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISubRangeType : IDataType,
IBitSize
VB
Public Interface ISubRangeType
Inherits IDataType, IBitSize
The ISubRangeType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the the base type.
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISubRangeType Properties


ISubRangeType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISubRangeType Interface [image] ISubRangeType Properties
ISubRangeType Properties
The ISubRangeType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the the base type.
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
ISubRangeType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISubRangeType.BaseType Property


ISubRangeType.BaseType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISubRangeType Interface [image] ISubRangeType Properties [image] ISubRangeType.BaseType Property
ISubRangeType.BaseType Property
Gets the the base type.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType BaseType { get; }
VB
ReadOnly Property BaseType As IDataType
Get
Property Value
Type: IDataType
The type of the referenced.
Reference
ISubRangeType Interface
TwinCAT.TypeSystem Namespace


ISubRangeType.T. Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISubRangeType.T. Interface
ISubRangeType.T. Interface
Interface representing a SubRange type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISubRangeType<T> : ISubRangeType,
IDataType, IBitSize
where T : struct, new()
VB
Public Interface ISubRangeType(Of T As {Structure, New})
Inherits ISubRangeType, IDataType, IBitSize
Type Parameters
T
The ISubRangeType.T. type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the the base type. (Inherited from ISubRangeType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
LowerBound | Gets the lower bound.
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
UpperBound | Gets the upper bound.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISubRangeType.T. Properties


ISubRangeType.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISubRangeType.T. Interface [image] ISubRangeType.T. Properties
ISubRangeType.T. Properties
The ISubRangeType.T. generic type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BaseType | Gets the the base type. (Inherited from ISubRangeType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
LowerBound | Gets the lower bound.
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
UpperBound | Gets the upper bound.
Reference
ISubRangeType.T. Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISubRangeType.T..LowerBound Property
•
ISubRangeType.T..UpperBound Property


ISubRangeType.T..LowerBound Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISubRangeType.T. Interface [image] ISubRangeType.T. Properties [image] ISubRangeType.T..LowerBound Property
ISubRangeType.T..LowerBound Property
Gets the lower bound.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
T LowerBound { get; }
VB
ReadOnly Property LowerBound As T
Get
Property Value
Type: T
The lower bound.
Reference
ISubRangeType.T. Interface
TwinCAT.TypeSystem Namespace


ISubRangeType.T..UpperBound Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISubRangeType.T. Interface [image] ISubRangeType.T. Properties [image] ISubRangeType.T..UpperBound Property
ISubRangeType.T..UpperBound Property
Gets the upper bound.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
T UpperBound { get; }
VB
ReadOnly Property UpperBound As T
Get
Property Value
Type: T
The upper bound.
Reference
ISubRangeType.T. Interface
TwinCAT.TypeSystem Namespace


ISymbol Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbol Interface
ISymbol Interface
Interface specifying Symbols (
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISymbol : IAttributedInstance,
IInstance, IBitSize
VB
Public Interface ISymbol
Inherits IAttributedInstance, IInstance, IBitSize
The ISymbol type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type.
IsPersistent | Gets a value indicating whether this ISymbol is persistent.
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type.
IsReadOnly | Gets a value indicating whether this ISymbol is read only.
IsRecursive | Gets a value indicating whether this instance is recursive.
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISymbol Properties


ISymbol Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbol Interface [image] ISymbol Properties
ISymbol Properties
The ISymbol type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type.
IsPersistent | Gets a value indicating whether this ISymbol is persistent.
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type.
IsReadOnly | Gets a value indicating whether this ISymbol is read only.
IsRecursive | Gets a value indicating whether this instance is recursive.
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
ISymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISymbol.Category Property
•
ISymbol.IsContainerType Property
•
ISymbol.IsPersistent Property
•
ISymbol.IsPrimitiveType Property
•
ISymbol.IsReadOnly Property
•
ISymbol.IsRecursive Property
•
ISymbol.Parent Property
•
ISymbol.SubSymbols Property


ISymbol.Category Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbol Interface [image] ISymbol Properties [image] ISymbol.Category Property
ISymbol.Category Property
Gets the Symbol/Datatype Category
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
DataTypeCategory Category { get; }
VB
ReadOnly Property Category As DataTypeCategory
Get
Property Value
Type: DataTypeCategory
The category.
Reference
ISymbol Interface
TwinCAT.TypeSystem Namespace


ISymbol.IsContainerType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbol Interface [image] ISymbol Properties [image] ISymbol.IsContainerType Property
ISymbol.IsContainerType Property
Gets a value indicating whether this Symbol is a container type.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsContainerType { get; }
VB
ReadOnly Property IsContainerType As Boolean
Get
Property Value
Type: Boolean
true if this instance is container type; otherwise, false.
Reference
ISymbol Interface
TwinCAT.TypeSystem Namespace


ISymbol.IsPersistent Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbol Interface [image] ISymbol Properties [image] ISymbol.IsPersistent Property
ISymbol.IsPersistent Property
Gets a value indicating whether this ISymbol is persistent.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsPersistent { get; }
VB
ReadOnly Property IsPersistent As Boolean
Get
Property Value
Type: Boolean
true if this instance is persistent; otherwise, false.
Reference
ISymbol Interface
TwinCAT.TypeSystem Namespace


ISymbol.IsPrimitiveType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbol Interface [image] ISymbol Properties [image] ISymbol.IsPrimitiveType Property
ISymbol.IsPrimitiveType Property
Gets a value indicating whether this instance is a primitive type.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsPrimitiveType { get; }
VB
ReadOnly Property IsPrimitiveType As Boolean
Get
Property Value
Type: Boolean
true if this instance is primitive type; otherwise, false.
Reference
ISymbol Interface
TwinCAT.TypeSystem Namespace


ISymbol.IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbol Interface [image] ISymbol Properties [image] ISymbol.IsReadOnly Property
ISymbol.IsReadOnly Property
Gets a value indicating whether this ISymbol is read only.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsReadOnly { get; }
VB
ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if this instance is read only; otherwise, false.
Reference
ISymbol Interface
TwinCAT.TypeSystem Namespace


ISymbol.IsRecursive Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbol Interface [image] ISymbol Properties [image] ISymbol.IsRecursive Property
ISymbol.IsRecursive Property
Gets a value indicating whether this instance is recursive.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsRecursive { get; }
VB
ReadOnly Property IsRecursive As Boolean
Get
Property Value
Type: Boolean
true if this instance is recursive; otherwise, false.
Reference
ISymbol Interface
TwinCAT.TypeSystem Namespace


ISymbol.Parent Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbol Interface [image] ISymbol Properties [image] ISymbol.Parent Property
ISymbol.Parent Property
Gets the parent Symbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ISymbol Parent { get; }
VB
ReadOnly Property Parent As ISymbol
Get
Property Value
Type: ISymbol
The parent.
Reference
ISymbol Interface
TwinCAT.TypeSystem Namespace


ISymbol.SubSymbols Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbol Interface [image] ISymbol Properties [image] ISymbol.SubSymbols Property
ISymbol.SubSymbols Property
Gets the SubSymbols of the ISymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlySymbolCollection SubSymbols { get; }
VB
ReadOnly Property SubSymbols As ReadOnlySymbolCollection
Get
Property Value
Type: ReadOnlySymbolCollection
Remarks
Used for Array, Struct, Pointer and Reference instances. Otherwise empty
Reference
ISymbol Interface
TwinCAT.TypeSystem Namespace


ISymbolCollection Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolCollection Interface
ISymbolCollection Interface
Interface ISymbolCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISymbolCollection : ISymbolCollection<ISymbol>,
IInstanceCollection<ISymbol>, IList<ISymbol>, ICollection<ISymbol>,
IEnumerable<ISymbol>, IEnumerable
VB
Public Interface ISymbolCollection
Inherits ISymbolCollection(Of ISymbol), IInstanceCollection(Of ISymbol),
IList(Of ISymbol), ICollection(Of ISymbol), IEnumerable(Of ISymbol),
IEnumerable
The ISymbolCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T.. (Inherited from ICollection.ISymbol..)
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only. (Inherited from ICollection.ISymbol..)
Item.Int32. | Gets or sets the element at the specified index. (Inherited from IList.ISymbol..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from IInstanceCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from IInstanceCollection.T..)
Methods
Name | Description
Add | Adds an item to the ICollection.T.. (Inherited from ICollection.ISymbol..)
Clear | Removes all items from the ICollection.T.. (Inherited from ICollection.ISymbol..)
Contains(String) | Determines whether this collection contains an instance with the specified instance path. (Inherited from IInstanceCollection.T..)
Contains(T) | Determines whether the ICollection.T. contains a specific value. (Inherited from ICollection.ISymbol..)
ContainsName | Determines whether this collection contains an instance with the specified instance name. (Inherited from IInstanceCollection.T..)
CopyTo | Copies the elements of the ICollection.T. to an Array, starting at a particular Array index. (Inherited from ICollection.ISymbol..)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable.ISymbol..)
GetInstance | Gets the IInstanceby instance path. (Inherited from IInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from IInstanceCollection.T..)
IndexOf | Determines the index of a specific item in the IList.T.. (Inherited from IList.ISymbol..)
Insert | Inserts an item to the IList.T. at the specified index. (Inherited from IList.ISymbol..)
Remove | Removes the first occurrence of a specific object from the ICollection.T.. (Inherited from ICollection.ISymbol..)
RemoveAt | Removes the IList.T. item at the specified index. (Inherited from IList.ISymbol..)
TryGetInstance | Tries to get the specified instance. (Inherited from IInstanceCollection.T..)
TryGetInstanceByName | Tries to get the specified instance by name. (Inherited from IInstanceCollection.T..)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISymbolCollection Properties
•
ISymbolCollection Methods


ISymbolCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolCollection Interface [image] ISymbolCollection Properties
ISymbolCollection Properties
The ISymbolCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T.. (Inherited from ICollection.ISymbol..)
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only. (Inherited from ICollection.ISymbol..)
Item.Int32. | Gets or sets the element at the specified index. (Inherited from IList.ISymbol..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from IInstanceCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from IInstanceCollection.T..)
Reference
ISymbolCollection Interface
TwinCAT.TypeSystem Namespace


ISymbolCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolCollection Interface [image] ISymbolCollection Methods
ISymbolCollection Methods
The ISymbolCollection type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T.. (Inherited from ICollection.ISymbol..)
Clear | Removes all items from the ICollection.T.. (Inherited from ICollection.ISymbol..)
Contains(String) | Determines whether this collection contains an instance with the specified instance path. (Inherited from IInstanceCollection.T..)
Contains(T) | Determines whether the ICollection.T. contains a specific value. (Inherited from ICollection.ISymbol..)
ContainsName | Determines whether this collection contains an instance with the specified instance name. (Inherited from IInstanceCollection.T..)
CopyTo | Copies the elements of the ICollection.T. to an Array, starting at a particular Array index. (Inherited from ICollection.ISymbol..)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable.ISymbol..)
GetInstance | Gets the IInstanceby instance path. (Inherited from IInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from IInstanceCollection.T..)
IndexOf | Determines the index of a specific item in the IList.T.. (Inherited from IList.ISymbol..)
Insert | Inserts an item to the IList.T. at the specified index. (Inherited from IList.ISymbol..)
Remove | Removes the first occurrence of a specific object from the ICollection.T.. (Inherited from ICollection.ISymbol..)
RemoveAt | Removes the IList.T. item at the specified index. (Inherited from IList.ISymbol..)
TryGetInstance | Tries to get the specified instance. (Inherited from IInstanceCollection.T..)
TryGetInstanceByName | Tries to get the specified instance by name. (Inherited from IInstanceCollection.T..)
Reference
ISymbolCollection Interface
TwinCAT.TypeSystem Namespace


ISymbolInfo Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolInfo Interface
ISymbolInfo Interface
Interface ISymbolInfo
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISymbolInfo
VB
Public Interface ISymbolInfo
The ISymbolInfo type exposes the following members.
Properties
Name | Description
InstancePath | Gets the Symbol Path
TypeName | Gets the data type Name
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISymbolInfo Properties


ISymbolInfo Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolInfo Interface [image] ISymbolInfo Properties
ISymbolInfo Properties
The ISymbolInfo type exposes the following members.
Properties
Name | Description
InstancePath | Gets the Symbol Path
TypeName | Gets the data type Name
Reference
ISymbolInfo Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISymbolInfo.InstancePath Property
•
ISymbolInfo.TypeName Property


ISymbolInfo.InstancePath Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolInfo Interface [image] ISymbolInfo Properties [image] ISymbolInfo.InstancePath Property
ISymbolInfo.InstancePath Property
Gets the Symbol Path
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string InstancePath { get; }
VB
ReadOnly Property InstancePath As String
Get
Property Value
Type: String
The path.
Reference
ISymbolInfo Interface
TwinCAT.TypeSystem Namespace


ISymbolInfo.TypeName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolInfo Interface [image] ISymbolInfo Properties [image] ISymbolInfo.TypeName Property
ISymbolInfo.TypeName Property
Gets the data type Name
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string TypeName { get; }
VB
ReadOnly Property TypeName As String
Get
Property Value
Type: String
The type of the data.
Reference
ISymbolInfo Interface
TwinCAT.TypeSystem Namespace


ISymbolLoader Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolLoader Interface
ISymbolLoader Interface
Symbol Loader interface
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISymbolLoader : ISymbolProvider
VB
Public Interface ISymbolLoader
Inherits ISymbolProvider
The ISymbolLoader type exposes the following members.
Properties
Name | Description
BuildInTypes | Gets the build in types.
DataTypes | Gets all data types from all Namespaces (Inherited from ISymbolProvider.)
RootNamespaceName | Gets the name of the root namespace (Inherited from ISymbolProvider.)
Settings | Gets or sets the access Method
Symbols | Gets the (root) symbols of the Symbol provider. (Inherited from ISymbolProvider.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISymbolLoader Properties


ISymbolLoader Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolLoader Interface [image] ISymbolLoader Properties
ISymbolLoader Properties
The ISymbolLoader type exposes the following members.
Properties
Name | Description
BuildInTypes | Gets the build in types.
DataTypes | Gets all data types from all Namespaces (Inherited from ISymbolProvider.)
RootNamespaceName | Gets the name of the root namespace (Inherited from ISymbolProvider.)
Settings | Gets or sets the access Method
Symbols | Gets the (root) symbols of the Symbol provider. (Inherited from ISymbolProvider.)
Reference
ISymbolLoader Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISymbolLoader.BuildInTypes Property
•
ISymbolLoader.Settings Property


ISymbolLoader.BuildInTypes Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolLoader Interface [image] ISymbolLoader Properties [image] ISymbolLoader.BuildInTypes Property
ISymbolLoader.BuildInTypes Property
Gets the build in types.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyDataTypeCollection<IDataType> BuildInTypes { get; }
VB
ReadOnly Property BuildInTypes As ReadOnlyDataTypeCollection(Of IDataType)
Get
Property Value
Type: ReadOnlyDataTypeCollection.IDataType.
The build in types.
Reference
ISymbolLoader Interface
TwinCAT.TypeSystem Namespace


ISymbolLoader.Settings Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolLoader Interface [image] ISymbolLoader Properties [image] ISymbolLoader.Settings Property
ISymbolLoader.Settings Property
Gets or sets the access Method
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ISymbolLoaderSettings Settings { get; }
VB
ReadOnly Property Settings As ISymbolLoaderSettings
Get
Property Value
Type: ISymbolLoaderSettings
The access method.
Reference
ISymbolLoader Interface
TwinCAT.TypeSystem Namespace


ISymbolProvider Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolProvider Interface
ISymbolProvider Interface
Symbol Provider interface.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISymbolProvider
VB
Public Interface ISymbolProvider
The ISymbolProvider type exposes the following members.
Properties
Name | Description
DataTypes | Gets all data types from all Namespaces
RootNamespaceName | Gets the name of the root namespace
Symbols | Gets the (root) symbols of the Symbol provider.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISymbolProvider Properties


ISymbolProvider Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolProvider Interface [image] ISymbolProvider Properties
ISymbolProvider Properties
The ISymbolProvider type exposes the following members.
Properties
Name | Description
DataTypes | Gets all data types from all Namespaces
RootNamespaceName | Gets the name of the root namespace
Symbols | Gets the (root) symbols of the Symbol provider.
Reference
ISymbolProvider Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISymbolProvider.DataTypes Property
•
ISymbolProvider.RootNamespaceName Property
•
ISymbolProvider.Symbols Property


ISymbolProvider.DataTypes Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolProvider Interface [image] ISymbolProvider Properties [image] ISymbolProvider.DataTypes Property
ISymbolProvider.DataTypes Property
Gets all data types from all Namespaces
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyDataTypeCollection DataTypes { get; }
VB
ReadOnly Property DataTypes As ReadOnlyDataTypeCollection
Get
Property Value
Type: ReadOnlyDataTypeCollection
The data types.
Reference
ISymbolProvider Interface
TwinCAT.TypeSystem Namespace


ISymbolProvider.RootNamespaceName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolProvider Interface [image] ISymbolProvider Properties [image] ISymbolProvider.RootNamespaceName Property
ISymbolProvider.RootNamespaceName Property
Gets the name of the root namespace
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string RootNamespaceName { get; }
VB
ReadOnly Property RootNamespaceName As String
Get
Property Value
Type: String
The namespace.
Reference
ISymbolProvider Interface
TwinCAT.TypeSystem Namespace


ISymbolProvider.Symbols Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolProvider Interface [image] ISymbolProvider Properties [image] ISymbolProvider.Symbols Property
ISymbolProvider.Symbols Property
Gets the (root) symbols of the Symbol provider.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlySymbolCollection Symbols { get; }
VB
ReadOnly Property Symbols As ReadOnlySymbolCollection
Get
Property Value
Type: ReadOnlySymbolCollection
Read only collection of the Symbols
Reference
ISymbolProvider Interface
TwinCAT.TypeSystem Namespace


ISymbolServer Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolServer Interface
ISymbolServer Interface
Symbol Server Interface
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISymbolServer
VB
Public Interface ISymbolServer
The ISymbolServer type exposes the following members.
Properties
Name | Description
DataTypes | Gets the data types.
Symbols | Gets the symbols.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISymbolServer Properties


ISymbolServer Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolServer Interface [image] ISymbolServer Properties
ISymbolServer Properties
The ISymbolServer type exposes the following members.
Properties
Name | Description
DataTypes | Gets the data types.
Symbols | Gets the symbols.
Reference
ISymbolServer Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ISymbolServer.DataTypes Property
•
ISymbolServer.Symbols Property


ISymbolServer.DataTypes Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolServer Interface [image] ISymbolServer Properties [image] ISymbolServer.DataTypes Property
ISymbolServer.DataTypes Property
Gets the data types.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyDataTypeCollection DataTypes { get; }
VB
ReadOnly Property DataTypes As ReadOnlyDataTypeCollection
Get
Property Value
Type: ReadOnlyDataTypeCollection
The data types.
Reference
ISymbolServer Interface
TwinCAT.TypeSystem Namespace


ISymbolServer.Symbols Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ISymbolServer Interface [image] ISymbolServer Properties [image] ISymbolServer.Symbols Property
ISymbolServer.Symbols Property
Gets the symbols.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlySymbolCollection Symbols { get; }
VB
ReadOnly Property Symbols As ReadOnlySymbolCollection
Get
Property Value
Type: ReadOnlySymbolCollection
The symbols.
Reference
ISymbolServer Interface
TwinCAT.TypeSystem Namespace


ITypeAttribute Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ITypeAttribute Interface
ITypeAttribute Interface
Interface for ADS attributes
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ITypeAttribute
VB
Public Interface ITypeAttribute
The ITypeAttribute type exposes the following members.
Properties
Name | Description
Name | Name of the Attribute
Value | Gets the value of the attribute
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ITypeAttribute Properties


ITypeAttribute Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ITypeAttribute Interface [image] ITypeAttribute Properties
ITypeAttribute Properties
The ITypeAttribute type exposes the following members.
Properties
Name | Description
Name | Name of the Attribute
Value | Gets the value of the attribute
Reference
ITypeAttribute Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ITypeAttribute.Name Property
•
ITypeAttribute.Value Property


ITypeAttribute.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ITypeAttribute Interface [image] ITypeAttribute Properties [image] ITypeAttribute.Name Property
ITypeAttribute.Name Property
Name of the Attribute
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Name { get; }
VB
ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Reference
ITypeAttribute Interface
TwinCAT.TypeSystem Namespace


ITypeAttribute.Value Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ITypeAttribute Interface [image] ITypeAttribute Properties [image] ITypeAttribute.Value Property
ITypeAttribute.Value Property
Gets the value of the attribute
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Value { get; }
VB
ReadOnly Property Value As String
Get
Property Value
Type: String
The value.
Reference
ITypeAttribute Interface
TwinCAT.TypeSystem Namespace


IUnionInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IUnionInstance Interface
IUnionInstance Interface
Interface for an Instance of the IUnionType.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IUnionInstance : ISymbol,
IAttributedInstance, IInstance, IBitSize
VB
Public Interface IUnionInstance
Inherits ISymbol, IAttributedInstance, IInstance, IBitSize
The IUnionInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
FieldInstances | Gets the field instances of the Union
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.ISymbol
Weiterführende Informationen
•
IUnionInstance Properties


IUnionInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IUnionInstance Interface [image] IUnionInstance Properties
IUnionInstance Properties
The IUnionInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
FieldInstances | Gets the field instances of the Union
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IUnionInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IUnionInstance.FieldInstances Property


IUnionInstance.FieldInstances Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IUnionInstance Interface [image] IUnionInstance Properties [image] IUnionInstance.FieldInstances Property
IUnionInstance.FieldInstances Property
Gets the field instances of the Union
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlySymbolCollection FieldInstances { get; }
VB
ReadOnly Property FieldInstances As ReadOnlySymbolCollection
Get
Property Value
Type: ReadOnlySymbolCollection
The field instances.
Reference
IUnionInstance Interface
TwinCAT.TypeSystem Namespace


IUnionType Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IUnionType Interface
IUnionType Interface
Interface for an union data type.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IUnionType : IDataType,
IBitSize
VB
Public Interface IUnionType
Inherits IDataType, IBitSize
The IUnionType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
Fields | Gets a readonly collection of the Members of the IUnionType.
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IDataType
Weiterführende Informationen
•
IUnionType Properties


IUnionType Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IUnionType Interface [image] IUnionType Properties
IUnionType Properties
The IUnionType type exposes the following members.
Properties
Name | Description
Attributes | Gets the attributes of the IDataType (Inherited from IDataType.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Data Type category (Inherited from IDataType.)
Comment | Gets the comment behind the variable declaration. (Inherited from IDataType.)
Fields | Gets a readonly collection of the Members of the IUnionType.
FullName | Gets the full name of the IDataType (Namespace + Name) (Inherited from IDataType.)
Id | Gets the ID of the DataType (Inherited from IDataType.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainer | Gets a value indicating whether this IDataType is a container type (Inherited from IDataType.)
IsPointer | Gets a value indicating whether this IDataType is a pointer type (Inherited from IDataType.)
IsPrimitive | Gets a value indicating whether this IDataType is primitive (Inherited from IDataType.)
IsReference | Gets a value indicating whether this IDataType is a reference type (Inherited from IDataType.)
Name | Gets the name of the Data Type (without namespace) (Inherited from IDataType.)
Namespace | Gets the namespace string within the IDataType exists. (Inherited from IDataType.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
Reference
IUnionType Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IUnionType.Fields Property


IUnionType.Fields Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IUnionType Interface [image] IUnionType Properties [image] IUnionType.Fields Property
IUnionType.Fields Property
Gets a readonly collection of the Members of the IUnionType.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyFieldCollection Fields { get; }
VB
ReadOnly Property Fields As ReadOnlyFieldCollection
Get
Property Value
Type: ReadOnlyFieldCollection
The members as readonly collection.
Remarks
If the IStructType is derived, only the extended members are returned. To get all supported members down the inheritance chain, use the AllMembers property.
Reference
IUnionType Interface
TwinCAT.TypeSystem Namespace


IValue Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface
IValue Interface
Symbol Value Interface
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IValue
VB
Public Interface IValue
The IValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value)
CachedRaw | Gets the cached Raw internal Data.
DataType | Gets the data type bound to this IValue
IsPrimitive | Gets a value indicating whether this IValue is a primitive value.
Symbol | Gets the symbol bound to this IValue.
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value (local user time, UTC)
Methods
Name | Description
Read | Reads the value (via ADS)
ResolveValue | Resolves the Value object to its primitive value.
TryResolveValue | Tries to resolves the Value object to its primitive value.
Write | Writes the value (via ADS)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValue Properties
•
IValue Methods


IValue Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Properties
IValue Properties
The IValue type exposes the following members.
Properties
Name | Description
Age | Gets the age of the value (last successful read of the value)
CachedRaw | Gets the cached Raw internal Data.
DataType | Gets the data type bound to this IValue
IsPrimitive | Gets a value indicating whether this IValue is a primitive value.
Symbol | Gets the symbol bound to this IValue.
UtcTimeStamp | Gets the Time stamp of the last successful read of the Value (local user time, UTC)
Reference
IValue Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValue.Age Property
•
IValue.CachedRaw Property
•
IValue.DataType Property
•
IValue.IsPrimitive Property
•
IValue.Symbol Property
•
IValue.UtcTimeStamp Property


IValue.Age Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Properties [image] IValue.Age Property
IValue.Age Property
Gets the age of the value (last successful read of the value)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
TimeSpan Age { get; }
VB
ReadOnly Property Age As TimeSpan
Get
Property Value
Type: TimeSpan
The age.
Reference
IValue Interface
TwinCAT.TypeSystem Namespace
IValue.UtcTimeStamp


IValue.CachedRaw Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Properties [image] IValue.CachedRaw Property
IValue.CachedRaw Property
Gets the cached Raw internal Data.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
byte[] CachedRaw { get; }
VB
ReadOnly Property CachedRaw As Byte()
Get
Property Value
Type: .Byte.
The raw cached data.
Reference
IValue Interface
TwinCAT.TypeSystem Namespace


IValue.DataType Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Properties [image] IValue.DataType Property
IValue.DataType Property
Gets the data type bound to this IValue
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IDataType DataType { get; }
VB
ReadOnly Property DataType As IDataType
Get
Property Value
Type: IDataType
The type of the data.
Reference
IValue Interface
TwinCAT.TypeSystem Namespace


IValue.IsPrimitive Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Properties [image] IValue.IsPrimitive Property
IValue.IsPrimitive Property
Gets a value indicating whether this IValue is a primitive value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool IsPrimitive { get; }
VB
ReadOnly Property IsPrimitive As Boolean
Get
Property Value
Type: Boolean
true if this instance is primitive; otherwise, false.
Reference
IValue Interface
TwinCAT.TypeSystem Namespace


IValue.Symbol Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Properties [image] IValue.Symbol Property
IValue.Symbol Property
Gets the symbol bound to this IValue.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ISymbol Symbol { get; }
VB
ReadOnly Property Symbol As ISymbol
Get
Property Value
Type: ISymbol
The symbol.
Reference
IValue Interface
TwinCAT.TypeSystem Namespace


IValue.UtcTimeStamp Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Properties [image] IValue.UtcTimeStamp Property
IValue.UtcTimeStamp Property
Gets the Time stamp of the last successful read of the Value (local user time, UTC)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
DateTime UtcTimeStamp { get; }
VB
ReadOnly Property UtcTimeStamp As DateTime
Get
Property Value
Type: DateTime
The read time stamp.
Reference
IValue Interface
TwinCAT.TypeSystem Namespace


IValue Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Methods
IValue Methods
The IValue type exposes the following members.
Methods
Name | Description
Read | Reads the value (via ADS)
ResolveValue | Resolves the Value object to its primitive value.
TryResolveValue | Tries to resolves the Value object to its primitive value.
Write | Writes the value (via ADS)
Reference
IValue Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValue.Read Method
•
IValue.ResolveValue Method
•
IValue.TryResolveValue Method
•
IValue.Write Method


IValue.Read Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Methods [image] IValue.Read Method
IValue.Read Method
Reads the value (via ADS)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void Read()
VB
Sub Read
Reference
IValue Interface
TwinCAT.TypeSystem Namespace


IValue.ResolveValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Methods [image] IValue.ResolveValue Method
IValue.ResolveValue Method
Resolves the Value object to its primitive value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object ResolveValue(
bool resolveEnumToPrimitive
)
VB
Function ResolveValue (
resolveEnumToPrimitive As Boolean
) As Object
Parameters
resolveEnumToPrimitive
Type: System.Boolean
if set to trueIEnumValues are resolved to their primitives also.
Return Value
Type: Object
System.Object.
Remarks
If the value is not primitive, this method returns the IValue itself.
Reference
IValue Interface
TwinCAT.TypeSystem Namespace


IValue.TryResolveValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Methods [image] IValue.TryResolveValue Method
IValue.TryResolveValue Method
Tries to resolves the Value object to its primitive value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TryResolveValue(
bool resolveEnumToPrimitive,
out Object value
)
VB
Function TryResolveValue (
resolveEnumToPrimitive As Boolean,
<OutAttribute> ByRef value As Object
) As Boolean
Parameters
resolveEnumToPrimitive | Type: System.Boolean if set to trueIEnumValues are resolved to their primitives also.
value | Type: System.Object. The value.
Return Value
Type: Boolean
true if value can be resolved, false otherwise.
Reference
IValue Interface
TwinCAT.TypeSystem Namespace


IValue.Write Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValue Interface [image] IValue Methods [image] IValue.Write Method
IValue.Write Method
Writes the value (via ADS)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void Write()
VB
Sub Write
Reference
IValue Interface
TwinCAT.TypeSystem Namespace


IValueAnySymbol Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface
IValueAnySymbol Interface
Interface IValueAnySymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IValueAnySymbol : ISymbol,
IAttributedInstance, IInstance, IBitSize
VB
Public Interface IValueAnySymbol
Inherits ISymbol, IAttributedInstance, IInstance, IBitSize
The IValueAnySymbol type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Methods
Name | Description
ReadAnyValue(Type) | Reads the value of this Value into a new created instance of the managed type
ReadAnyValue(Type, Int32) | Reads the value of this Value into a new created instance of the managed type
UpdateAnyValue(Object.) | Reads the value of this Value into the specified managed value.
UpdateAnyValue(Object., Int32) | Reads the value of this Value into the specified managed value.
WriteAnyValue(Object) | Writes the value represented by the managed value to this Value
WriteAnyValue(Object, Int32) | Writes the value represented by the managed value to this Value
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.ISymbol
Weiterführende Informationen
•
IValueAnySymbol Properties
•
IValueAnySymbol Methods


IValueAnySymbol Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface [image] IValueAnySymbol Properties
IValueAnySymbol Properties
The IValueAnySymbol type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IValueAnySymbol Interface
TwinCAT.TypeSystem Namespace


IValueAnySymbol Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface [image] IValueAnySymbol Methods
IValueAnySymbol Methods
Methods
Name | Description
ReadAnyValue(Type) | Reads the value of this Value into a new created instance of the managed type
ReadAnyValue(Type, Int32) | Reads the value of this Value into a new created instance of the managed type
UpdateAnyValue(Object.) | Reads the value of this Value into the specified managed value.
UpdateAnyValue(Object., Int32) | Reads the value of this Value into the specified managed value.
WriteAnyValue(Object) | Writes the value represented by the managed value to this Value
WriteAnyValue(Object, Int32) | Writes the value represented by the managed value to this Value
Reference
IValueAnySymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueAnySymbol.ReadAnyValue Method
•
IValueAnySymbol.UpdateAnyValue Method
•
IValueAnySymbol.WriteAnyValue Method


IValueAnySymbol.ReadAnyValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface [image] IValueAnySymbol Methods [image] IValueAnySymbol.ReadAnyValue Method
IValueAnySymbol.ReadAnyValue Method
Overload List
Name | Description
ReadAnyValue(Type) | Reads the value of this Value into a new created instance of the managed type
ReadAnyValue(Type, Int32) | Reads the value of this Value into a new created instance of the managed type
Reference
IValueAnySymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueAnySymbol.ReadAnyValue Method (Type)
•
IValueAnySymbol.ReadAnyValue Method (Type, Int32)


IValueAnySymbol.ReadAnyValue Method (Type)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface [image] IValueAnySymbol Methods [image] IValueAnySymbol.ReadAnyValue Method [image] IValueAnySymbol.ReadAnyValue Method (Type)
IValueAnySymbol.ReadAnyValue Method (Type)
Reads the value of this Value into a new created instance of the managed type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object ReadAnyValue(
Type managedType
)
VB
Function ReadAnyValue (
managedType As Type
) As Object
Parameters
managedType
Type: System.Type
The tp.
Return Value
Type: Object
Read value (System.Object).
Reference
IValueAnySymbol Interface
ReadAnyValue Overload
TwinCAT.TypeSystem Namespace
IValueAnySymbol.WriteAnyValue(Object)
IValueAnySymbol.UpdateAnyValue(Object.)


IValueAnySymbol.ReadAnyValue Method (Type, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface [image] IValueAnySymbol Methods [image] IValueAnySymbol.ReadAnyValue Method [image] IValueAnySymbol.ReadAnyValue Method (Type, Int32)
IValueAnySymbol.ReadAnyValue Method (Type, Int32)
Reads the value of this Value into a new created instance of the managed type
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object ReadAnyValue(
Type managedType,
int timeout
)
VB
Function ReadAnyValue (
managedType As Type,
timeout As Integer
) As Object
Parameters
managedType | Type: System.Type The tp.
timeout | Type: System.Int32 The timeout in ms.
Return Value
Type: Object
Read value (System.Object).
Reference
IValueAnySymbol Interface
ReadAnyValue Overload
TwinCAT.TypeSystem Namespace
IValueAnySymbol.WriteAnyValue(Object)
IValueAnySymbol.UpdateAnyValue(Object.)


IValueAnySymbol.UpdateAnyValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface [image] IValueAnySymbol Methods [image] IValueAnySymbol.UpdateAnyValue Method
IValueAnySymbol.UpdateAnyValue Method
Overload List
Name | Description
UpdateAnyValue(Object.) | Reads the value of this Value into the specified managed value.
UpdateAnyValue(Object., Int32) | Reads the value of this Value into the specified managed value.
Reference
IValueAnySymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueAnySymbol.UpdateAnyValue Method (Object.)
•
IValueAnySymbol.UpdateAnyValue Method (Object., Int32)


IValueAnySymbol.UpdateAnyValue Method (Object.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface [image] IValueAnySymbol Methods [image] IValueAnySymbol.UpdateAnyValue Method [image] IValueAnySymbol.UpdateAnyValue Method (Object.)
IValueAnySymbol.UpdateAnyValue Method (Object.)
Reads the value of this Value into the specified managed value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void UpdateAnyValue(
ref Object managedObject
)
VB
Sub UpdateAnyValue (
ByRef managedObject As Object
)
Parameters
managedObject
Type: System.Object.
The managed object.
Return Value
Type:
Read value (System.Object).
Reference
IValueAnySymbol Interface
UpdateAnyValue Overload
TwinCAT.TypeSystem Namespace
IValueAnySymbol.ReadAnyValue(Type)
IValueAnySymbol.WriteAnyValue(Object)


IValueAnySymbol.UpdateAnyValue Method (Object., Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface [image] IValueAnySymbol Methods [image] IValueAnySymbol.UpdateAnyValue Method [image] IValueAnySymbol.UpdateAnyValue Method (Object., Int32)
IValueAnySymbol.UpdateAnyValue Method (Object., Int32)
Reads the value of this Value into the specified managed value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void UpdateAnyValue(
ref Object managedObject,
int timeout
)
VB
Sub UpdateAnyValue (
ByRef managedObject As Object,
timeout As Integer
)
Parameters
managedObject | Type: System.Object. The managed object.
timeout | Type: System.Int32 The timeout.
Return Value
Type:
Read value (System.Object).
Reference
IValueAnySymbol Interface
UpdateAnyValue Overload
TwinCAT.TypeSystem Namespace
IValueAnySymbol.ReadAnyValue(Type)
IValueAnySymbol.WriteAnyValue(Object)


IValueAnySymbol.WriteAnyValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface [image] IValueAnySymbol Methods [image] IValueAnySymbol.WriteAnyValue Method
IValueAnySymbol.WriteAnyValue Method
Overload List
Name | Description
WriteAnyValue(Object) | Writes the value represented by the managed value to this Value
WriteAnyValue(Object, Int32) | Writes the value represented by the managed value to this Value
Reference
IValueAnySymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueAnySymbol.WriteAnyValue Method (Object)
•
IValueAnySymbol.WriteAnyValue Method (Object, Int32)


IValueAnySymbol.WriteAnyValue Method (Object)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface [image] IValueAnySymbol Methods [image] IValueAnySymbol.WriteAnyValue Method [image] IValueAnySymbol.WriteAnyValue Method (Object)
IValueAnySymbol.WriteAnyValue Method (Object)
Writes the value represented by the managed value to this Value
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void WriteAnyValue(
Object managedValue
)
VB
Sub WriteAnyValue (
managedValue As Object
)
Parameters
managedValue
Type: System.Object
The managed value.
Reference
IValueAnySymbol Interface
WriteAnyValue Overload
TwinCAT.TypeSystem Namespace
IValueAnySymbol.ReadAnyValue(Type)
IValueAnySymbol.UpdateAnyValue(Object.)


IValueAnySymbol.WriteAnyValue Method (Object, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueAnySymbol Interface [image] IValueAnySymbol Methods [image] IValueAnySymbol.WriteAnyValue Method [image] IValueAnySymbol.WriteAnyValue Method (Object, Int32)
IValueAnySymbol.WriteAnyValue Method (Object, Int32)
Writes the value represented by the managed value to this Value
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void WriteAnyValue(
Object managedValue,
int timeout
)
VB
Sub WriteAnyValue (
managedValue As Object,
timeout As Integer
)
Parameters
managedValue | Type: System.Object The managed value.
timeout | Type: System.Int32 The timeout in ms.
Reference
IValueAnySymbol Interface
WriteAnyValue Overload
TwinCAT.TypeSystem Namespace
IValueAnySymbol.ReadAnyValue(Type)
IValueAnySymbol.UpdateAnyValue(Object.)


IValueRawSymbol Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface
IValueRawSymbol Interface
Interface IValueRawSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IValueRawSymbol : ISymbol,
IAttributedInstance, IInstance, IBitSize
VB
Public Interface IValueRawSymbol
Inherits ISymbol, IAttributedInstance, IInstance, IBitSize
The IValueRawSymbol type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasValue | Gets a value indicating whether this IValueSymbol has a value.
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Methods
Name | Description
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write)
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueRawSymbol Properties
•
IValueRawSymbol Methods
•
IValueRawSymbol Events


IValueRawSymbol Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface [image] IValueRawSymbol Properties
IValueRawSymbol Properties
The IValueRawSymbol type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasValue | Gets a value indicating whether this IValueSymbol has a value.
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IValueRawSymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueRawSymbol.HasValue Property


IValueRawSymbol.HasValue Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface [image] IValueRawSymbol Properties [image] IValueRawSymbol.HasValue Property
IValueRawSymbol.HasValue Property
Gets a value indicating whether this IValueSymbol has a value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool HasValue { get; }
VB
ReadOnly Property HasValue As Boolean
Get
Property Value
Type: Boolean
true if this instance has value; otherwise, false.
Remarks
A VirtualSymbol does not support values, but in terms of the IValueSymbol definition, is a IValueSymbol
Reference
IValueRawSymbol Interface
TwinCAT.TypeSystem Namespace


IValueRawSymbol Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface [image] IValueRawSymbol Methods
IValueRawSymbol Methods
Methods
Name | Description
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write)
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write)
Reference
IValueRawSymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueRawSymbol.ReadRawValue Method
•
IValueRawSymbol.WriteRawValue Method


IValueRawSymbol.ReadRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface [image] IValueRawSymbol Methods [image] IValueRawSymbol.ReadRawValue Method
IValueRawSymbol.ReadRawValue Method
Overload List
Name | Description
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write)
Reference
IValueRawSymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueRawSymbol.ReadRawValue Method
•
IValueRawSymbol.ReadRawValue Method (Int32)


IValueRawSymbol.ReadRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface [image] IValueRawSymbol Methods [image] IValueRawSymbol.ReadRawValue Method [image] IValueRawSymbol.ReadRawValue Method
IValueRawSymbol.ReadRawValue Method
Reads the raw value of the IValueSymbol (Ads Read / Write)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
byte[] ReadRawValue()
VB
Function ReadRawValue As Byte()
Field Value
Type: .Byte.
The raw value.
Return Value
Type: .Byte.
System.Byte[].
Reference
IValueRawSymbol Interface
ReadRawValue Overload
TwinCAT.TypeSystem Namespace


IValueRawSymbol.ReadRawValue Method (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface [image] IValueRawSymbol Methods [image] IValueRawSymbol.ReadRawValue Method [image] IValueRawSymbol.ReadRawValue Method (Int32)
IValueRawSymbol.ReadRawValue Method (Int32)
Reads the raw value of the IValueSymbol (Ads Read / Write)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
byte[] ReadRawValue(
int timeout
)
VB
Function ReadRawValue (
timeout As Integer
) As Byte()
Parameters
timeout
Type: System.Int32
The timeout in ms.
Field Value
Type: .Byte.
The raw value.
Return Value
Type: .Byte.
System.Byte[].
Remarks
A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
IValueRawSymbol Interface
ReadRawValue Overload
TwinCAT.TypeSystem Namespace


IValueRawSymbol.WriteRawValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface [image] IValueRawSymbol Methods [image] IValueRawSymbol.WriteRawValue Method
IValueRawSymbol.WriteRawValue Method
Overload List
Name | Description
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write)
Reference
IValueRawSymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueRawSymbol.WriteRawValue Method (.Byte.)
•
IValueRawSymbol.WriteRawValue Method (.Byte., Int32)


IValueRawSymbol.WriteRawValue Method (.Byte.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface [image] IValueRawSymbol Methods [image] IValueRawSymbol.WriteRawValue Method [image] IValueRawSymbol.WriteRawValue Method (.Byte.)
IValueRawSymbol.WriteRawValue Method (.Byte.)
Writes the raw value of the IValueSymbol (Ads Read / Write)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void WriteRawValue(
byte[] value
)
VB
Sub WriteRawValue (
value As Byte()
)
Parameters
value
Type: .System.Byte.
The value as byte array.
Field Value
Type:
The value.
Reference
IValueRawSymbol Interface
WriteRawValue Overload
TwinCAT.TypeSystem Namespace


IValueRawSymbol.WriteRawValue Method (.Byte., Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface [image] IValueRawSymbol Methods [image] IValueRawSymbol.WriteRawValue Method [image] IValueRawSymbol.WriteRawValue Method (.Byte., Int32)
IValueRawSymbol.WriteRawValue Method (.Byte., Int32)
Writes the raw value of the IValueSymbol (Ads Read / Write)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void WriteRawValue(
byte[] value,
int timeout
)
VB
Sub WriteRawValue (
value As Byte(),
timeout As Integer
)
Parameters
value | Type: .System.Byte. The value as byte array.
timeout | Type: System.Int32 The timeout.
Field Value
Type:
The value.
Remarks
A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
IValueRawSymbol Interface
WriteRawValue Overload
TwinCAT.TypeSystem Namespace


IValueRawSymbol Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface [image] IValueRawSymbol Events
IValueRawSymbol Events
The IValueRawSymbol type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed.
Reference
IValueRawSymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueRawSymbol.RawValueChanged Event


IValueRawSymbol.RawValueChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueRawSymbol Interface [image] IValueRawSymbol Events [image] IValueRawSymbol.RawValueChanged Event
IValueRawSymbol.RawValueChanged Event
Occurs when the RawValue of the IValueSymbol has changed.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
event EventHandler<RawValueChangedArgs> RawValueChanged
VB
Event RawValueChanged As EventHandler(Of RawValueChangedArgs)
Value
Type: System.EventHandler.RawValueChangedArgs.
Reference
IValueRawSymbol Interface
TwinCAT.TypeSystem Namespace


IValueSymbol Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface
IValueSymbol Interface
Interface for a ISymbol that supports values.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IValueSymbol : IValueRawSymbol,
ISymbol, IAttributedInstance, IInstance, IBitSize
VB
Public Interface IValueSymbol
Inherits IValueRawSymbol, ISymbol, IAttributedInstance, IInstance,
IBitSize
The IValueSymbol type exposes the following members.
Properties
Name | Description
AccessRights | Gets the access rights.
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasValue | Gets a value indicating whether this IValueSymbol has a value. (Inherited from IValueRawSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
NotificationSettings | Gets or sets the notification settings.
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Methods
Name | Description
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadValue. | Reads the Value of the IValueSymbol
ReadValue(Int32) | Reads the Value of the IValueSymbol
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteValue(Object) | Writes the Value of the IValueSymbol
WriteValue(Object, Int32) | Writes the Value of the IValueSymbol
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from IValueRawSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed.
Extension Methods
Name | Description
PollValuesAnnotated(IObservable.Unit.) | Overloaded. Polls the values as ValueChangedArgs sequence annotated value on trigger sequence (Defined by ValueSymbolExtensions.)
PollValuesAnnotated(TimeSpan) | Overloaded. Polls the values as ValueChangedArgs sequence with a specified period time. (Defined by ValueSymbolExtensions.)
WhenValueChanged | Gets an observable sequence when the value of the IValueSymbol has changed. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IValueRawSymbol
Weiterführende Informationen
•
IValueSymbol Properties
•
IValueSymbol Methods
•
IValueSymbol Events


IValueSymbol Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Properties
IValueSymbol Properties
The IValueSymbol type exposes the following members.
Properties
Name | Description
AccessRights | Gets the access rights.
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasValue | Gets a value indicating whether this IValueSymbol has a value. (Inherited from IValueRawSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
NotificationSettings | Gets or sets the notification settings.
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IValueSymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueSymbol.AccessRights Property
•
IValueSymbol.NotificationSettings Property


IValueSymbol.AccessRights Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Properties [image] IValueSymbol.AccessRights Property
IValueSymbol.AccessRights Property
Gets the access rights.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
SymbolAccessRights AccessRights { get; }
VB
ReadOnly Property AccessRights As SymbolAccessRights
Get
Property Value
Type: SymbolAccessRights
The access rights.
Reference
IValueSymbol Interface
TwinCAT.TypeSystem Namespace


IValueSymbol.NotificationSettings Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Properties [image] IValueSymbol.NotificationSettings Property
IValueSymbol.NotificationSettings Property
Gets or sets the notification settings.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
INotificationSettings NotificationSettings { get; set; }
VB
Property NotificationSettings As INotificationSettings
Get
Set
Property Value
Type: INotificationSettings
The notification settings.
Remarks
The NotificationSettings will be inherited from Parent if the setting is not overwritten.
Reference
IValueSymbol Interface
TwinCAT.TypeSystem Namespace


IValueSymbol Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Methods
IValueSymbol Methods
The IValueSymbol type exposes the following members.
Methods
Name | Description
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadValue. | Reads the Value of the IValueSymbol
ReadValue(Int32) | Reads the Value of the IValueSymbol
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteValue(Object) | Writes the Value of the IValueSymbol
WriteValue(Object, Int32) | Writes the Value of the IValueSymbol
Extension Methods
Name | Description
PollValuesAnnotated(IObservable.Unit.) | Overloaded. Polls the values as ValueChangedArgs sequence annotated value on trigger sequence (Defined by ValueSymbolExtensions.)
PollValuesAnnotated(TimeSpan) | Overloaded. Polls the values as ValueChangedArgs sequence with a specified period time. (Defined by ValueSymbolExtensions.)
WhenValueChanged | Gets an observable sequence when the value of the IValueSymbol has changed. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
Reference
IValueSymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueSymbol.ReadValue Method
•
IValueSymbol.WriteValue Method


IValueSymbol.ReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Methods [image] IValueSymbol.ReadValue Method
IValueSymbol.ReadValue Method
Overload List
Name | Description
ReadValue. | Reads the Value of the IValueSymbol
ReadValue(Int32) | Reads the Value of the IValueSymbol
Reference
IValueSymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueSymbol.ReadValue Method
•
IValueSymbol.ReadValue Method (Int32)


IValueSymbol.ReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Methods [image] IValueSymbol.ReadValue Method [image] IValueSymbol.ReadValue Method
IValueSymbol.ReadValue Method
Reads the Value of the IValueSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object ReadValue()
VB
Function ReadValue As Object
Field Value
Type: Object
The value.
Return Value
Type: Object
System.Object.
Remarks
Calling on primitive types, a call of this method will return the primitive value. On complex types (structures and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: the raw byte Array will be returned, in dynamic mode: A Value will be created on the fly.
Reference
IValueSymbol Interface
ReadValue Overload
TwinCAT.TypeSystem Namespace


IValueSymbol.ReadValue Method (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Methods [image] IValueSymbol.ReadValue Method [image] IValueSymbol.ReadValue Method (Int32)
IValueSymbol.ReadValue Method (Int32)
Reads the Value of the IValueSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
Object ReadValue(
int timeout
)
VB
Function ReadValue (
timeout As Integer
) As Object
Parameters
timeout
Type: System.Int32
The timeout in ms.
Field Value
Type: Object
The value.
Return Value
Type: Object
System.Object.
Remarks
Calling on primitive types, a call of this method will return the primitive value. On complex types (structures and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: the raw byte Array will be returned, in dynamic mode: A Value will be created on the fly. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
IValueSymbol Interface
ReadValue Overload
TwinCAT.TypeSystem Namespace


IValueSymbol.WriteValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Methods [image] IValueSymbol.WriteValue Method
IValueSymbol.WriteValue Method
Overload List
Name | Description
WriteValue(Object) | Writes the Value of the IValueSymbol
WriteValue(Object, Int32) | Writes the Value of the IValueSymbol
Reference
IValueSymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueSymbol.WriteValue Method (Object)
•
IValueSymbol.WriteValue Method (Object, Int32)


IValueSymbol.WriteValue Method (Object)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Methods [image] IValueSymbol.WriteValue Method [image] IValueSymbol.WriteValue Method (Object)
IValueSymbol.WriteValue Method (Object)
Writes the Value of the IValueSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void WriteValue(
Object value
)
VB
Sub WriteValue (
value As Object
)
Parameters
value
Type: System.Object
The value.
Remarks
Calling on primitive types, a call of this method will directly write this Value. On complex types (structs and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: Only byte Arrays (of correct size) can be written) in dynamic mode: A Value that represents the value will be accepted also.
Reference
IValueSymbol Interface
WriteValue Overload
TwinCAT.TypeSystem Namespace


IValueSymbol.WriteValue Method (Object, Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Methods [image] IValueSymbol.WriteValue Method [image] IValueSymbol.WriteValue Method (Object, Int32)
IValueSymbol.WriteValue Method (Object, Int32)
Writes the Value of the IValueSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
void WriteValue(
Object value,
int timeout
)
VB
Sub WriteValue (
value As Object,
timeout As Integer
)
Parameters
value | Type: System.Object The value.
timeout | Type: System.Int32 The timeout in ms.
Remarks
Calling on primitive types, a call of this method will directly write this Value. On complex types (structs and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: Only byte Arrays (of correct size) can be written) in dynamic mode: A Value that represents the value will be accepted also. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
IValueSymbol Interface
WriteValue Overload
TwinCAT.TypeSystem Namespace


IValueSymbol Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Events
IValueSymbol Events
The IValueSymbol type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from IValueRawSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed.
Reference
IValueSymbol Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueSymbol.ValueChanged Event


IValueSymbol.ValueChanged Event

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol Interface [image] IValueSymbol Events [image] IValueSymbol.ValueChanged Event
IValueSymbol.ValueChanged Event
Occurs when the (Primitive) value of the IValueSymbol has changed.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
event EventHandler<ValueChangedArgs> ValueChanged
VB
Event ValueChanged As EventHandler(Of ValueChangedArgs)
Value
Type: System.EventHandler.ValueChangedArgs.
Reference
IValueSymbol Interface
TwinCAT.TypeSystem Namespace


IValueSymbol2 Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol2 Interface
IValueSymbol2 Interface
Interface for a ISymbol that supports values.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IValueSymbol2 : IValueSymbol,
IValueRawSymbol, ISymbol, IAttributedInstance, IInstance, IBitSize
VB
Public Interface IValueSymbol2
Inherits IValueSymbol, IValueRawSymbol, ISymbol, IAttributedInstance,
IInstance, IBitSize
The IValueSymbol2 type exposes the following members.
Properties
Name | Description
AccessRights | Gets the access rights. (Inherited from IValueSymbol.)
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
Connection | Gets the connection that produces values for this IValueSymbol
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasValue | Gets a value indicating whether this IValueSymbol has a value. (Inherited from IValueRawSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
NotificationSettings | Gets or sets the notification settings. (Inherited from IValueSymbol.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Methods
Name | Description
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadValue. | Reads the Value of the IValueSymbol (Inherited from IValueSymbol.)
ReadValue(Int32) | Reads the Value of the IValueSymbol (Inherited from IValueSymbol.)
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteValue(Object) | Writes the Value of the IValueSymbol (Inherited from IValueSymbol.)
WriteValue(Object, Int32) | Writes the Value of the IValueSymbol (Inherited from IValueSymbol.)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from IValueRawSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from IValueSymbol.)
Extension Methods
Name | Description
PollValuesAnnotated(IObservable.Unit.) | Overloaded. Polls the values as ValueChangedArgs sequence annotated value on trigger sequence (Defined by ValueSymbolExtensions.)
PollValuesAnnotated(TimeSpan) | Overloaded. Polls the values as ValueChangedArgs sequence with a specified period time. (Defined by ValueSymbolExtensions.)
WhenValueChanged | Gets an observable sequence when the value of the IValueSymbol has changed. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IValueSymbol
Weiterführende Informationen
•
IValueSymbol2 Properties
•
IValueSymbol2 Methods
•
IValueSymbol2 Events


IValueSymbol2 Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol2 Interface [image] IValueSymbol2 Properties
IValueSymbol2 Properties
The IValueSymbol2 type exposes the following members.
Properties
Name | Description
AccessRights | Gets the access rights. (Inherited from IValueSymbol.)
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
Connection | Gets the connection that produces values for this IValueSymbol
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasValue | Gets a value indicating whether this IValueSymbol has a value. (Inherited from IValueRawSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
NotificationSettings | Gets or sets the notification settings. (Inherited from IValueSymbol.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IValueSymbol2 Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueSymbol2.Connection Property


IValueSymbol2.Connection Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol2 Interface [image] IValueSymbol2 Properties [image] IValueSymbol2.Connection Property
IValueSymbol2.Connection Property
Gets the connection that produces values for this IValueSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IConnection Connection { get; }
VB
ReadOnly Property Connection As IConnection
Get
Property Value
Type: IConnection
The connection object.
Reference
IValueSymbol2 Interface
TwinCAT.TypeSystem Namespace


IValueSymbol2 Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol2 Interface [image] IValueSymbol2 Methods
IValueSymbol2 Methods
The IValueSymbol2 type exposes the following members.
Methods
Name | Description
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadValue. | Reads the Value of the IValueSymbol (Inherited from IValueSymbol.)
ReadValue(Int32) | Reads the Value of the IValueSymbol (Inherited from IValueSymbol.)
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteValue(Object) | Writes the Value of the IValueSymbol (Inherited from IValueSymbol.)
WriteValue(Object, Int32) | Writes the Value of the IValueSymbol (Inherited from IValueSymbol.)
Extension Methods
Name | Description
PollValuesAnnotated(IObservable.Unit.) | Overloaded. Polls the values as ValueChangedArgs sequence annotated value on trigger sequence (Defined by ValueSymbolExtensions.)
PollValuesAnnotated(TimeSpan) | Overloaded. Polls the values as ValueChangedArgs sequence with a specified period time. (Defined by ValueSymbolExtensions.)
WhenValueChanged | Gets an observable sequence when the value of the IValueSymbol has changed. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
Reference
IValueSymbol2 Interface
TwinCAT.TypeSystem Namespace


IValueSymbol2 Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol2 Interface [image] IValueSymbol2 Events
IValueSymbol2 Events
The IValueSymbol2 type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from IValueRawSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from IValueSymbol.)
Reference
IValueSymbol2 Interface
TwinCAT.TypeSystem Namespace


IValueSymbol3 Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol3 Interface
IValueSymbol3 Interface
Interface IValueSymbol3 Implements the IValueSymbol2
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IValueSymbol3 : IValueSymbol2,
IValueSymbol, IValueRawSymbol, ISymbol, IAttributedInstance, IInstance,
IBitSize
VB
Public Interface IValueSymbol3
Inherits IValueSymbol2, IValueSymbol, IValueRawSymbol, ISymbol,
IAttributedInstance, IInstance, IBitSize
The IValueSymbol3 type exposes the following members.
Properties
Name | Description
AccessRights | Gets the access rights. (Inherited from IValueSymbol.)
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
Connection | Gets the connection that produces values for this IValueSymbol (Inherited from IValueSymbol2.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasValue | Gets a value indicating whether this IValueSymbol has a value. (Inherited from IValueRawSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
NotificationSettings | Gets or sets the notification settings. (Inherited from IValueSymbol.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Methods
Name | Description
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadValue. | Reads the Value of the IValueSymbol (Inherited from IValueSymbol.)
ReadValue(Int32) | Reads the Value of the IValueSymbol (Inherited from IValueSymbol.)
TryReadValue | Reads the Value of the IValueSymbol
TryWriteValue | Writes the Value of the IValueSymbol
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteValue(Object) | Writes the Value of the IValueSymbol (Inherited from IValueSymbol.)
WriteValue(Object, Int32) | Writes the Value of the IValueSymbol (Inherited from IValueSymbol.)
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from IValueRawSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from IValueSymbol.)
Extension Methods
Name | Description
PollValuesAnnotated(IObservable.Unit.) | Overloaded. Polls the values as ValueChangedArgs sequence annotated value on trigger sequence (Defined by ValueSymbolExtensions.)
PollValuesAnnotated(TimeSpan) | Overloaded. Polls the values as ValueChangedArgs sequence with a specified period time. (Defined by ValueSymbolExtensions.)
WhenValueChanged | Gets an observable sequence when the value of the IValueSymbol has changed. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IValueSymbol2
Weiterführende Informationen
•
IValueSymbol3 Properties
•
IValueSymbol3 Methods
•
IValueSymbol3 Events


IValueSymbol3 Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol3 Interface [image] IValueSymbol3 Properties
IValueSymbol3 Properties
The IValueSymbol3 type exposes the following members.
Properties
Name | Description
AccessRights | Gets the access rights. (Inherited from IValueSymbol.)
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
Connection | Gets the connection that produces values for this IValueSymbol (Inherited from IValueSymbol2.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasValue | Gets a value indicating whether this IValueSymbol has a value. (Inherited from IValueRawSymbol.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
NotificationSettings | Gets or sets the notification settings. (Inherited from IValueSymbol.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IValueSymbol3 Interface
TwinCAT.TypeSystem Namespace


IValueSymbol3 Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol3 Interface [image] IValueSymbol3 Methods
IValueSymbol3 Methods
The IValueSymbol3 type exposes the following members.
Methods
Name | Description
ReadRawValue. | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadRawValue(Int32) | Reads the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
ReadValue. | Reads the Value of the IValueSymbol (Inherited from IValueSymbol.)
ReadValue(Int32) | Reads the Value of the IValueSymbol (Inherited from IValueSymbol.)
TryReadValue | Reads the Value of the IValueSymbol
TryWriteValue | Writes the Value of the IValueSymbol
WriteRawValue(.Byte.) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteRawValue(.Byte., Int32) | Writes the raw value of the IValueSymbol (Ads Read / Write) (Inherited from IValueRawSymbol.)
WriteValue(Object) | Writes the Value of the IValueSymbol (Inherited from IValueSymbol.)
WriteValue(Object, Int32) | Writes the Value of the IValueSymbol (Inherited from IValueSymbol.)
Extension Methods
Name | Description
PollValuesAnnotated(IObservable.Unit.) | Overloaded. Polls the values as ValueChangedArgs sequence annotated value on trigger sequence (Defined by ValueSymbolExtensions.)
PollValuesAnnotated(TimeSpan) | Overloaded. Polls the values as ValueChangedArgs sequence with a specified period time. (Defined by ValueSymbolExtensions.)
WhenValueChanged | Gets an observable sequence when the value of the IValueSymbol has changed. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception.) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
WriteValues(IObservable.Object., Action.Exception., CancellationToken) | Overloaded. Subscribes the IValueSymbol to an observable sequence of values and writes them to the IValueSymbol. (Defined by ValueSymbolExtensions.)
Reference
IValueSymbol3 Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IValueSymbol3.TryReadValue Method
•
IValueSymbol3.TryWriteValue Method


IValueSymbol3.TryReadValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol3 Interface [image] IValueSymbol3 Methods [image] IValueSymbol3.TryReadValue Method
IValueSymbol3.TryReadValue Method
Reads the Value of the IValueSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int TryReadValue(
int timeout,
out Object value
)
VB
Function TryReadValue (
timeout As Integer,
<OutAttribute> ByRef value As Object
) As Integer
Parameters
timeout | Type: System.Int32 The timeout in ms.
value | Type: System.Object. The symbol value.
Return Value
Type: Int32
The error code.
Remarks
Calling on primitive types, a call of this method will return the primitive value. On complex types (structures and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: the raw byte Array will be returned, in dynamic mode: A Value will be created on the fly. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
IValueSymbol3 Interface
TwinCAT.TypeSystem Namespace


IValueSymbol3.TryWriteValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol3 Interface [image] IValueSymbol3 Methods [image] IValueSymbol3.TryWriteValue Method
IValueSymbol3.TryWriteValue Method
Writes the Value of the IValueSymbol
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
int TryWriteValue(
Object value,
int timeout
)
VB
Function TryWriteValue (
value As Object,
timeout As Integer
) As Integer
Parameters
value | Type: System.Object The value.
timeout | Type: System.Int32 The timeout in ms.
Return Value
Type: Int32
The error code.
Remarks
Calling on primitive types, a call of this method will directly write this Value. On complex types (structs and arrays) it depends on the ISymbolLoader settings what will happen. In non dynamic modes: Only byte Arrays (of correct size) can be written) in dynamic mode: A Value that represents the value will be accepted also. A negative timeout indicates that the Default Timeout for the communication will be used. 0 means timeout is switched off.
Reference
IValueSymbol3 Interface
TwinCAT.TypeSystem Namespace


IValueSymbol3 Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IValueSymbol3 Interface [image] IValueSymbol3 Events
IValueSymbol3 Events
The IValueSymbol3 type exposes the following members.
Events
Name | Description
RawValueChanged | Occurs when the RawValue of the IValueSymbol has changed. (Inherited from IValueRawSymbol.)
ValueChanged | Occurs when the (Primitive) value of the IValueSymbol has changed. (Inherited from IValueSymbol.)
Reference
IValueSymbol3 Interface
TwinCAT.TypeSystem Namespace


IVirtualStructInstance Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IVirtualStructInstance Interface
IVirtualStructInstance Interface
Virtual Struct instance interface.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IVirtualStructInstance : IStructInstance,
ISymbol, IAttributedInstance, IInstance, IBitSize
VB
Public Interface IVirtualStructInstance
Inherits IStructInstance, ISymbol, IAttributedInstance, IInstance,
IBitSize
The IVirtualStructInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Inherited from IStructInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
MemberInstances | Gets the member instances of the Struct Instance. (Inherited from IStructInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Methods
Name | Description
AddMember | Adds the member.
Remarks
Virtual struct instance are used to create a TreeView from the flat list of symbols.
Reference
TwinCAT.TypeSystem Namespace
TwinCAT.TypeSystem.IStructInstance
Weiterführende Informationen
•
IVirtualStructInstance Properties
•
IVirtualStructInstance Methods


IVirtualStructInstance Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IVirtualStructInstance Interface [image] IVirtualStructInstance Properties
IVirtualStructInstance Properties
The IVirtualStructInstance type exposes the following members.
Properties
Name | Description
Attributes | Gets the Type Attributes. (Inherited from IAttributedInstance.)
BitSize | Gets the size of the IDataType in bits. (Inherited from IBitSize.)
ByteSize | Gets the (aligned) size of of the Type/Instance in Bytes (Inherited from IBitSize.)
Category | Gets the Symbol/Datatype Category (Inherited from ISymbol.)
Comment | Gets the comment of the IInstance (Inherited from IInstance.)
DataType | Gets the IDataType of the IInstance. (Inherited from IInstance.)
HasRpcMethods | Gets a value indicating whether this instance has RPC methods (Inherited from IStructInstance.)
InstanceName | Gets the name of the instance (without periods (.) (Inherited from IInstance.)
InstancePath | Gets the relative / absolute access path to the instance (with periods (.)) (Inherited from IInstance.)
IsBitType | Gets a value indicating whether this instance is not basing on a full DataType but instead of some sort of bit mapping (Inherited from IBitSize.)
IsByteAligned | Indicates that the Size of the Object is Byte aligned (BitSize % 8 == 0) (Inherited from IBitSize.)
IsContainerType | Gets a value indicating whether this Symbol is a container type. (Inherited from ISymbol.)
IsPersistent | Gets a value indicating whether this ISymbol is persistent. (Inherited from ISymbol.)
IsPointer | Indicates that the IInstance represents a Pointer type (Pointer TO) (Inherited from IInstance.)
IsPrimitiveType | Gets a value indicating whether this instance is a primitive type. (Inherited from ISymbol.)
IsReadOnly | Gets a value indicating whether this ISymbol is read only. (Inherited from ISymbol.)
IsRecursive | Gets a value indicating whether this instance is recursive. (Inherited from ISymbol.)
IsReference | Indicates that the IInstance represents a Reference type (REFERENCE TO) (Inherited from IInstance.)
IsStatic | Gets a value indicating whether this IInstance is static. (Inherited from IInstance.)
MemberInstances | Gets the member instances of the Struct Instance. (Inherited from IStructInstance.)
Parent | Gets the parent Symbol (Inherited from ISymbol.)
Size | Gets the size of the object in bytes or Bits dependant on IsBitType (Inherited from IBitSize.)
SubSymbols | Gets the SubSymbols of the ISymbol (Inherited from ISymbol.)
TypeName | Gets the name of the DataType that is used for this IInstance. (Inherited from IInstance.)
Reference
IVirtualStructInstance Interface
TwinCAT.TypeSystem Namespace


IVirtualStructInstance Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IVirtualStructInstance Interface [image] IVirtualStructInstance Methods
IVirtualStructInstance Methods
The IVirtualStructInstance type exposes the following members.
Methods
Name | Description
AddMember | Adds the member.
Reference
IVirtualStructInstance Interface
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
IVirtualStructInstance.AddMember Method


IVirtualStructInstance.AddMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] IVirtualStructInstance Interface [image] IVirtualStructInstance Methods [image] IVirtualStructInstance.AddMember Method
IVirtualStructInstance.AddMember Method
Adds the member.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool AddMember(
ISymbol memberInstance,
IVirtualStructInstance parent
)
VB
Function AddMember (
memberInstance As ISymbol,
parent As IVirtualStructInstance
) As Boolean
Parameters
memberInstance | Type: TwinCAT.TypeSystem.ISymbol The member instance.
parent | Type: TwinCAT.TypeSystem.IVirtualStructInstance The parent struct instance. Usually the this pointer.
Return Value
Type: Boolean
Reference
IVirtualStructInstance Interface
TwinCAT.TypeSystem Namespace


MarshalException Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MarshalException Class
MarshalException Class
Common Marshalling Exception
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
TwinCAT.Ads.AdsException
TwinCAT.TypeSystem.MarshalException
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[SerializableAttribute]
public class MarshalException : AdsException
VB
<SerializableAttribute>
Public Class MarshalException
Inherits AdsException
The MarshalException type exposes the following members.
Constructors
Name | Description
MarshalException. | Initializes a new instance of the MarshalException class.
MarshalException(String) | Initializes a new instance of the MarshalException class.
MarshalException(String, Exception) | Initializes a new Instance of the AdsException class.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
MarshalException Constructor
•
MarshalException Properties
•
MarshalException Methods
•
MarshalException Events


MarshalException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MarshalException Class [image] MarshalException Constructor
MarshalException Constructor
Overload List
Name | Description
MarshalException. | Initializes a new instance of the MarshalException class.
MarshalException(String) | Initializes a new instance of the MarshalException class.
MarshalException(String, Exception) | Initializes a new Instance of the AdsException class.
Reference
MarshalException Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
MarshalException Constructor
•
MarshalException Constructor (String)
•
MarshalException Constructor (String, Exception)


MarshalException Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MarshalException Class [image] MarshalException Constructor [image] MarshalException Constructor
MarshalException Constructor
Initializes a new instance of the MarshalException class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public MarshalException()
VB
Public Sub New
Reference
MarshalException Class
MarshalException Overload
TwinCAT.TypeSystem Namespace


MarshalException Constructor (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MarshalException Class [image] MarshalException Constructor [image] MarshalException Constructor (String)
MarshalException Constructor (String)
Initializes a new instance of the MarshalException class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public MarshalException(
string message
)
VB
Public Sub New (
message As String
)
Parameters
message
Type: System.String
The message.
Reference
MarshalException Class
MarshalException Overload
TwinCAT.TypeSystem Namespace


MarshalException Constructor (String, Exception)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MarshalException Class [image] MarshalException Constructor [image] MarshalException Constructor (String, Exception)
MarshalException Constructor (String, Exception)
Initializes a new Instance of the AdsException class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public MarshalException(
string message,
Exception innerException
)
VB
Public Sub New (
message As String,
innerException As Exception
)
Parameters
message | Type: System.String The message.
innerException | Type: System.Exception The inner exception.
Reference
MarshalException Class
MarshalException Overload
TwinCAT.TypeSystem Namespace


MarshalException Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MarshalException Class [image] MarshalException Properties
MarshalException Properties
The MarshalException type exposes the following members.
Properties
Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Reference
MarshalException Class
TwinCAT.TypeSystem Namespace


MarshalException Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MarshalException Class [image] MarshalException Methods
MarshalException Methods
The MarshalException type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Reference
MarshalException Class
TwinCAT.TypeSystem Namespace


MarshalException Events

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MarshalException Class [image] MarshalException Events
MarshalException Events
The MarshalException type exposes the following members.
Events
Name | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Reference
MarshalException Class
TwinCAT.TypeSystem Namespace


MemberCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MemberCollection Class
MemberCollection Class
Collection of IMember objects.
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.Generic.InstanceCollection.IMember.
TwinCAT.TypeSystem.MemberCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class MemberCollection : InstanceCollection<IMember>
VB
Public Class MemberCollection
Inherits InstanceCollection(Of IMember)
The MemberCollection type exposes the following members.
Constructors
Name | Description
MemberCollection. | Initializes a new instance of the MemberCollection class.
MemberCollection(IEnumerable.IMember.) | Initializes a new instance of the MemberCollection class (copy constructor)
Properties
Name | Description
Count | Gets the collection count. (Inherited from InstanceCollection.T..)
IsReadOnly | Gets a value indicating whether this instance is read only. (Inherited from InstanceCollection.T..)
Item.Int32. | Gets or sets the IInstance at the specified index. (Inherited from InstanceCollection.T..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from InstanceCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from InstanceCollection.T..)
Methods
Name | Description
Add | Adds the specified item. (Inherited from InstanceCollection.T..)
AddRange | Adds the specified items to this collection. (Inherited from InstanceCollection.T..)
AsReadOnly | Returns a read only copy of this collection (shallow copy)
Clear | Clears this instance. (Inherited from InstanceCollection.T..)
Clone | Clones this MemberCollection.
Contains(String) | Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath (Inherited from InstanceCollection.T..)
Contains(T) | Determines whether this collection contains the specified IInstance (Inherited from InstanceCollection.T..)
ContainsName | Determines whether the specified instance name contains name. (Inherited from InstanceCollection.T..)
CopyTo | Copies this InstanceCollection.T. to the specified array. (Inherited from InstanceCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator. (Inherited from InstanceCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from InstanceCollection.T..)
GetInstanceByName | Gets the name of the instance by. (Inherited from InstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of the specified IInstance. (Inherited from InstanceCollection.T..)
Insert | Inserts the specified IInstance at the specified index. (Inherited from InstanceCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified item. (Inherited from InstanceCollection.T..)
RemoveAt | Removes the IInstance at the specified index. (Inherited from InstanceCollection.T..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the IInstance. of the specified path. (Inherited from InstanceCollection.T..)
TryGetInstanceByName | Tries to get Instnaces by name. (Inherited from InstanceCollection.T..)
Fields
Name | Description
_list | The _list (Inherited from InstanceCollection.T..)
_pathDict | The _path dictionary (Inherited from InstanceCollection.T..)
mode | The mode this InstanceCollection.T. is working in. (Inherited from InstanceCollection.T..)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
MemberCollection Constructor
•
MemberCollection Properties
•
MemberCollection Methods
•
MemberCollection Fields


MemberCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MemberCollection Class [image] MemberCollection Constructor
MemberCollection Constructor
Overload List
Name | Description
MemberCollection. | Initializes a new instance of the MemberCollection class.
MemberCollection(IEnumerable.IMember.) | Initializes a new instance of the MemberCollection class (copy constructor)
Reference
MemberCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
MemberCollection Constructor
•
MemberCollection Constructor (IEnumerable.IMember.)


MemberCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MemberCollection Class [image] MemberCollection Constructor [image] MemberCollection Constructor
MemberCollection Constructor
Initializes a new instance of the MemberCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public MemberCollection()
VB
Public Sub New
Reference
MemberCollection Class
MemberCollection Overload
TwinCAT.TypeSystem Namespace


MemberCollection Constructor (IEnumerable.IMember.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MemberCollection Class [image] MemberCollection Constructor [image] MemberCollection Constructor (IEnumerable.IMember.)
MemberCollection Constructor (IEnumerable.IMember.)
Initializes a new instance of the MemberCollection class (copy constructor)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public MemberCollection(
IEnumerable<IMember> coll
)
VB
Public Sub New (
coll As IEnumerable(Of IMember)
)
Parameters
coll
Type: System.Collections.Generic.IEnumerable.IMember.
The coll.
Reference
MemberCollection Class
MemberCollection Overload
TwinCAT.TypeSystem Namespace


MemberCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MemberCollection Class [image] MemberCollection Properties
MemberCollection Properties
The MemberCollection type exposes the following members.
Properties
Name | Description
Count | Gets the collection count. (Inherited from InstanceCollection.T..)
IsReadOnly | Gets a value indicating whether this instance is read only. (Inherited from InstanceCollection.T..)
Item.Int32. | Gets or sets the IInstance at the specified index. (Inherited from InstanceCollection.T..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from InstanceCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from InstanceCollection.T..)
Reference
MemberCollection Class
TwinCAT.TypeSystem Namespace


MemberCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MemberCollection Class [image] MemberCollection Methods
MemberCollection Methods
The MemberCollection type exposes the following members.
Methods
Name | Description
Add | Adds the specified item. (Inherited from InstanceCollection.T..)
AddRange | Adds the specified items to this collection. (Inherited from InstanceCollection.T..)
AsReadOnly | Returns a read only copy of this collection (shallow copy)
Clear | Clears this instance. (Inherited from InstanceCollection.T..)
Clone | Clones this MemberCollection.
Contains(String) | Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath (Inherited from InstanceCollection.T..)
Contains(T) | Determines whether this collection contains the specified IInstance (Inherited from InstanceCollection.T..)
ContainsName | Determines whether the specified instance name contains name. (Inherited from InstanceCollection.T..)
CopyTo | Copies this InstanceCollection.T. to the specified array. (Inherited from InstanceCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator. (Inherited from InstanceCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from InstanceCollection.T..)
GetInstanceByName | Gets the name of the instance by. (Inherited from InstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of the specified IInstance. (Inherited from InstanceCollection.T..)
Insert | Inserts the specified IInstance at the specified index. (Inherited from InstanceCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified item. (Inherited from InstanceCollection.T..)
RemoveAt | Removes the IInstance at the specified index. (Inherited from InstanceCollection.T..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the IInstance. of the specified path. (Inherited from InstanceCollection.T..)
TryGetInstanceByName | Tries to get Instnaces by name. (Inherited from InstanceCollection.T..)
Reference
MemberCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
MemberCollection.AsReadOnly Method
•
MemberCollection.Clone Method


MemberCollection.AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MemberCollection Class [image] MemberCollection Methods [image] MemberCollection.AsReadOnly Method
MemberCollection.AsReadOnly Method
Returns a read only copy of this collection (shallow copy)
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyMemberCollection AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlyMemberCollection
Return Value
Type: ReadOnlyMemberCollection
The readonly copy.
Reference
MemberCollection Class
TwinCAT.TypeSystem Namespace


MemberCollection.Clone Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MemberCollection Class [image] MemberCollection Methods [image] MemberCollection.Clone Method
MemberCollection.Clone Method
Clones this MemberCollection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public MemberCollection Clone()
VB
Public Function Clone As MemberCollection
Return Value
Type: MemberCollection
A cloned MemberCollection.
Reference
MemberCollection Class
TwinCAT.TypeSystem Namespace


MemberCollection Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MemberCollection Class [image] MemberCollection Fields
MemberCollection Fields
The MemberCollection type exposes the following members.
Fields
Name | Description
_list | The _list (Inherited from InstanceCollection.T..)
_pathDict | The _path dictionary (Inherited from InstanceCollection.T..)
mode | The mode this InstanceCollection.T. is working in. (Inherited from InstanceCollection.T..)
Reference
MemberCollection Class
TwinCAT.TypeSystem Namespace


MethodParamFlags Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] MethodParamFlags Enumeration
MethodParamFlags Enumeration
Flag set specifying the MethodParameter context
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[FlagsAttribute]
public enum MethodParamFlags
VB
<FlagsAttribute>
Public Enumeration MethodParamFlags
Members
Member name | Value | Description
In | 1 | Input Parameter (ADSMETHODPARAFLAG_IN)
Out | 2 | Output Parameter (ADSMETHODPARAFLAG_OUT)
ByReference | 4 | By reference Parameter (ADSMETHODPARAFLAG_BYREFERENCE)
MaskIn | 5 | Mask for In parameters.
MaskOut | 6 | Mask for Out parameters.
Reference
TwinCAT.TypeSystem Namespace


PrimitiveTypeFlags Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] PrimitiveTypeFlags Enumeration
PrimitiveTypeFlags Enumeration
Enum PrimitiveTypeFlags
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[FlagsAttribute]
public enum PrimitiveTypeFlags
VB
<FlagsAttribute>
Public Enumeration PrimitiveTypeFlags
Members
Member name | Value | Description
None | 0 | None / Uninitialized
System | 1 | System Type like Byte / Word / DWORD
Unsigned | 2 | Primitive Type is Unsigned
Bool | 4 | Boolean Value (maps to true and false)
Float | 8 | Floating Point
Date | 16 | Type represents a Date
Time | 32 | Type represents a Time
Numeric | 64 | Numeric value
Bitset | 128 | Bitset
MaskNumericUnsigned | 66 | Numeric / Unsigned Mask
MaskDateTime | 48 | Date / Time Mask
Reference
TwinCAT.TypeSystem Namespace


RawValueChangedArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RawValueChangedArgs Class
RawValueChangedArgs Class
Event args for the RawValueChanged event.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.TypeSystem.ValueChangedBaseArgs
TwinCAT.TypeSystem.RawValueChangedArgs
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class RawValueChangedArgs : ValueChangedBaseArgs
VB
Public Class RawValueChangedArgs
Inherits ValueChangedBaseArgs
The RawValueChangedArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
Symbol | Symbol that caused the event. (Inherited from ValueChangedBaseArgs.)
UtcLocalSystemTime | Notification Time stamp of the local system (user/desktop time) in UTC (Inherited from ValueChangedBaseArgs.)
UtcRtime | Notification Time stamp of the Real time System in UTC (Inherited from ValueChangedBaseArgs.)
Value | New Value (byte[])
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
RawValueChangedArgs Methods
•
RawValueChangedArgs Fields


RawValueChangedArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RawValueChangedArgs Class [image] RawValueChangedArgs Methods
RawValueChangedArgs Methods
The RawValueChangedArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
RawValueChangedArgs Class
TwinCAT.TypeSystem Namespace


RawValueChangedArgs Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RawValueChangedArgs Class [image] RawValueChangedArgs Fields
RawValueChangedArgs Fields
The RawValueChangedArgs type exposes the following members.
Fields
Name | Description
Symbol | Symbol that caused the event. (Inherited from ValueChangedBaseArgs.)
UtcLocalSystemTime | Notification Time stamp of the local system (user/desktop time) in UTC (Inherited from ValueChangedBaseArgs.)
UtcRtime | Notification Time stamp of the Real time System in UTC (Inherited from ValueChangedBaseArgs.)
Value | New Value (byte[])
Reference
RawValueChangedArgs Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
RawValueChangedArgs.Value Field


RawValueChangedArgs.Value Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RawValueChangedArgs Class [image] RawValueChangedArgs Fields [image] RawValueChangedArgs.Value Field
RawValueChangedArgs.Value Field
New Value (byte[])
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly byte[] Value
VB
Public ReadOnly Value As Byte()
Field Value
Type: .Byte.
Reference
RawValueChangedArgs Class
TwinCAT.TypeSystem Namespace


ReadOnlyDataTypeCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyDataTypeCollection Class
ReadOnlyDataTypeCollection Class
ReadOnly Collection of IDataType objects.
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.IDataType.
TwinCAT.TypeSystem.Generic.ReadOnlyDataTypeCollection.IDataType.
TwinCAT.TypeSystem.ReadOnlyDataTypeCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyDataTypeCollection : ReadOnlyDataTypeCollection<IDataType>
VB
Public Class ReadOnlyDataTypeCollection
Inherits ReadOnlyDataTypeCollection(Of IDataType)
The ReadOnlyDataTypeCollection type exposes the following members.
Constructors
Name | Description
ReadOnlyDataTypeCollection | Initializes a new instance of the ReadOnlyDataTypeCollection class.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IDataType..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IDataType..)
Item.String. | Gets the element with the specified type name. (Inherited from ReadOnlyDataTypeCollection.T..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IDataType..)
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDataType..)
ContainsType | Determines whether the specified name contains type. (Inherited from ReadOnlyDataTypeCollection.T..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IDataType..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDataType..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDataType..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetType | Tries to get the Type with the specified name out of the collection. (Inherited from ReadOnlyDataTypeCollection.T..)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyDataTypeCollection Constructor
•
ReadOnlyDataTypeCollection Properties
•
ReadOnlyDataTypeCollection Methods


ReadOnlyDataTypeCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyDataTypeCollection Class [image] ReadOnlyDataTypeCollection Constructor
ReadOnlyDataTypeCollection Constructor
Initializes a new instance of the ReadOnlyDataTypeCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyDataTypeCollection(
DataTypeCollection<IDataType> coll
)
VB
Public Sub New (
coll As DataTypeCollection(Of IDataType)
)
Parameters
coll
Type: TwinCAT.TypeSystem.Generic.DataTypeCollection.IDataType.
Collection of types.
Reference
ReadOnlyDataTypeCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyDataTypeCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyDataTypeCollection Class [image] ReadOnlyDataTypeCollection Properties
ReadOnlyDataTypeCollection Properties
The ReadOnlyDataTypeCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IDataType..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IDataType..)
Item.String. | Gets the element with the specified type name. (Inherited from ReadOnlyDataTypeCollection.T..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IDataType..)
Reference
ReadOnlyDataTypeCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyDataTypeCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyDataTypeCollection Class [image] ReadOnlyDataTypeCollection Methods
ReadOnlyDataTypeCollection Methods
The ReadOnlyDataTypeCollection type exposes the following members.
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDataType..)
ContainsType | Determines whether the specified name contains type. (Inherited from ReadOnlyDataTypeCollection.T..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IDataType..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDataType..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDataType..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetType | Tries to get the Type with the specified name out of the collection. (Inherited from ReadOnlyDataTypeCollection.T..)
Reference
ReadOnlyDataTypeCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyDimensionCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyDimensionCollection Class
ReadOnlyDimensionCollection Class
ReadOnly version of the DimensionCollection
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.IDimension.
TwinCAT.TypeSystem.ReadOnlyDimensionCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyDimensionCollection : ReadOnlyCollection<IDimension>,
IDimensionCollection, IList<IDimension>, ICollection<IDimension>,
IEnumerable<IDimension>, IEnumerable
VB
Public Class ReadOnlyDimensionCollection
Inherits ReadOnlyCollection(Of IDimension)
Implements IDimensionCollection, IList(Of IDimension),
ICollection(Of IDimension), IEnumerable(Of IDimension), IEnumerable
The ReadOnlyDimensionCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IDimension..)
ElementCount | Gets the Number of elements in all Dimensions
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IDimension..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IDimension..)
LowerBounds | Gets the lower bounds.
UpperBounds | Gets the upper bounds.
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDimension..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IDimension..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDimensionLengths | Gets an array the specifies the Lengths of each Array Dimension
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDimension..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDimension..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyDimensionCollection Properties
•
ReadOnlyDimensionCollection Methods


ReadOnlyDimensionCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyDimensionCollection Class [image] ReadOnlyDimensionCollection Properties
ReadOnlyDimensionCollection Properties
The ReadOnlyDimensionCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IDimension..)
ElementCount | Gets the Number of elements in all Dimensions
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IDimension..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IDimension..)
LowerBounds | Gets the lower bounds.
UpperBounds | Gets the upper bounds.
Reference
ReadOnlyDimensionCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyDimensionCollection.ElementCount Property
•
ReadOnlyDimensionCollection.LowerBounds Property
•
ReadOnlyDimensionCollection.UpperBounds Property


ReadOnlyDimensionCollection.ElementCount Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyDimensionCollection Class [image] ReadOnlyDimensionCollection Properties [image] ReadOnlyDimensionCollection.ElementCount Property
ReadOnlyDimensionCollection.ElementCount Property
Gets the Number of elements in all Dimensions
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int ElementCount { get; }
VB
Public ReadOnly Property ElementCount As Integer
Get
Property Value
Type: Int32
Implements
IDimensionCollection.ElementCount
Reference
ReadOnlyDimensionCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyDimensionCollection.LowerBounds Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyDimensionCollection Class [image] ReadOnlyDimensionCollection Properties [image] ReadOnlyDimensionCollection.LowerBounds Property
ReadOnlyDimensionCollection.LowerBounds Property
Gets the lower bounds.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int[] LowerBounds { get; }
VB
Public ReadOnly Property LowerBounds As Integer()
Get
Property Value
Type: .Int32.
The lower bounds.
Implements
IDimensionCollection.LowerBounds
Reference
ReadOnlyDimensionCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyDimensionCollection.UpperBounds Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyDimensionCollection Class [image] ReadOnlyDimensionCollection Properties [image] ReadOnlyDimensionCollection.UpperBounds Property
ReadOnlyDimensionCollection.UpperBounds Property
Gets the upper bounds.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int[] UpperBounds { get; }
VB
Public ReadOnly Property UpperBounds As Integer()
Get
Property Value
Type: .Int32.
The upper bounds.
Implements
IDimensionCollection.UpperBounds
Reference
ReadOnlyDimensionCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyDimensionCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyDimensionCollection Class [image] ReadOnlyDimensionCollection Methods
ReadOnlyDimensionCollection Methods
The ReadOnlyDimensionCollection type exposes the following members.
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDimension..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IDimension..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDimensionLengths | Gets an array the specifies the Lengths of each Array Dimension
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDimension..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IDimension..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
ReadOnlyDimensionCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyDimensionCollection.GetDimensionLengths Method


ReadOnlyDimensionCollection.GetDimensionLengths Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyDimensionCollection Class [image] ReadOnlyDimensionCollection Methods [image] ReadOnlyDimensionCollection.GetDimensionLengths Method
ReadOnlyDimensionCollection.GetDimensionLengths Method
Gets an array the specifies the Lengths of each Array Dimension
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int[] GetDimensionLengths()
VB
Public Function GetDimensionLengths As Integer()
Return Value
Type: .Int32.
System.Int32[].
Implements
IDimensionCollection.GetDimensionLengths.
Reference
ReadOnlyDimensionCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class
ReadOnlyEnumValueCollection Class
Read only version of the EnumValueCollection.T.
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.IEnumValue.
TwinCAT.TypeSystem.ReadOnlyEnumValueCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyEnumValueCollection : ReadOnlyCollection<IEnumValue>
VB
Public Class ReadOnlyEnumValueCollection
Inherits ReadOnlyCollection(Of IEnumValue)
The ReadOnlyEnumValueCollection type exposes the following members.
Constructors
Name | Description
ReadOnlyEnumValueCollection | Initializes a new instance of the ReadOnlyEnumValueCollection.T. class.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IEnumValue..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IEnumValue..)
Item.String. | Gets or sets the element at the specified index.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IEnumValue..)
Methods
Name | Description
Contains(String) | Determines whether [contains] [the specified name].
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IEnumValue..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IEnumValue..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IEnumValue..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetNames | Gets the Value Names.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Gets the values.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IEnumValue..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parses the specified name.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryParse | Tries to pars the string value of the Enum.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyEnumValueCollection Constructor
•
ReadOnlyEnumValueCollection Properties
•
ReadOnlyEnumValueCollection Methods


ReadOnlyEnumValueCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class [image] ReadOnlyEnumValueCollection Constructor
ReadOnlyEnumValueCollection Constructor
Initializes a new instance of the ReadOnlyEnumValueCollection.T. class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyEnumValueCollection(
EnumValueCollection coll
)
VB
Public Sub New (
coll As EnumValueCollection
)
Parameters
coll
Type: TwinCAT.TypeSystem.EnumValueCollection
The coll.
Reference
ReadOnlyEnumValueCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class [image] ReadOnlyEnumValueCollection Properties
ReadOnlyEnumValueCollection Properties
The ReadOnlyEnumValueCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IEnumValue..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IEnumValue..)
Item.String. | Gets or sets the element at the specified index.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IEnumValue..)
Reference
ReadOnlyEnumValueCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyEnumValueCollection.Item Property


ReadOnlyEnumValueCollection.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class [image] ReadOnlyEnumValueCollection Properties [image] ReadOnlyEnumValueCollection.Item Property
ReadOnlyEnumValueCollection.Item Property
Overload List
Name | Description
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IEnumValue..)
Item.String. | Gets or sets the element at the specified index.
Reference
ReadOnlyEnumValueCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyEnumValueCollection.Item Property (String)


ReadOnlyEnumValueCollection.Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class [image] ReadOnlyEnumValueCollection Properties [image] ReadOnlyEnumValueCollection.Item Property [image] ReadOnlyEnumValueCollection.Item Property (String)
ReadOnlyEnumValueCollection.Item Property (String)
Gets or sets the element at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumValue this[
string name
] { get; }
VB
Public ReadOnly Default Property Item (
name As String
) As IEnumValue
Get
Parameters
name
Type: System.String
The name of the value
Return Value
Type: IEnumValue
EnumValue<T>.
Exceptions
Exception | Condition
NotImplementedException |
NotImplementedException |
Reference
ReadOnlyEnumValueCollection Class
Item Overload
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class [image] ReadOnlyEnumValueCollection Methods
ReadOnlyEnumValueCollection Methods
The ReadOnlyEnumValueCollection type exposes the following members.
Methods
Name | Description
Contains(String) | Determines whether [contains] [the specified name].
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IEnumValue..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IEnumValue..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IEnumValue..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetNames | Gets the Value Names.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Gets the values.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IEnumValue..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parses the specified name.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryParse | Tries to pars the string value of the Enum.
Reference
ReadOnlyEnumValueCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyEnumValueCollection.Contains Method
•
ReadOnlyEnumValueCollection.GetNames Method
•
ReadOnlyEnumValueCollection.GetValues Method
•
ReadOnlyEnumValueCollection.Parse Method
•
ReadOnlyEnumValueCollection.TryParse Method


ReadOnlyEnumValueCollection.Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class [image] ReadOnlyEnumValueCollection Methods [image] ReadOnlyEnumValueCollection.Contains Method
ReadOnlyEnumValueCollection.Contains Method
Overload List
Name | Description
Contains(String) | Determines whether [contains] [the specified name].
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IEnumValue..)
Reference
ReadOnlyEnumValueCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyEnumValueCollection.Contains Method (String)


ReadOnlyEnumValueCollection.Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class [image] ReadOnlyEnumValueCollection Methods [image] ReadOnlyEnumValueCollection.Contains Method [image] ReadOnlyEnumValueCollection.Contains Method (String)
ReadOnlyEnumValueCollection.Contains Method (String)
Determines whether [contains] [the specified name].
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string value
)
VB
Public Function Contains (
value As String
) As Boolean
Parameters
value
Type: System.String
Value
Return Value
Type: Boolean
true if [contains] [the specified name]; otherwise, false.
Reference
ReadOnlyEnumValueCollection Class
Contains Overload
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection.GetNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class [image] ReadOnlyEnumValueCollection Methods [image] ReadOnlyEnumValueCollection.GetNames Method
ReadOnlyEnumValueCollection.GetNames Method
Gets the Value Names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string[] GetNames()
VB
Public Function GetNames As String()
Return Value
Type: .String.
System.String[].
Reference
ReadOnlyEnumValueCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection.GetValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class [image] ReadOnlyEnumValueCollection Methods [image] ReadOnlyEnumValueCollection.GetValues Method
ReadOnlyEnumValueCollection.GetValues Method
Gets the values.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object[] GetValues()
VB
Public Function GetValues As Object()
Return Value
Type: .Object.
T[].
Reference
ReadOnlyEnumValueCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection.Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class [image] ReadOnlyEnumValueCollection Methods [image] ReadOnlyEnumValueCollection.Parse Method
ReadOnlyEnumValueCollection.Parse Method
Parses the specified name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public Object Parse(
string name
)
VB
Public Function Parse (
name As String
) As Object
Parameters
name
Type: System.String
The name.
Return Value
Type: Object
T.
Reference
ReadOnlyEnumValueCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection.TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection Class [image] ReadOnlyEnumValueCollection Methods [image] ReadOnlyEnumValueCollection.TryParse Method
ReadOnlyEnumValueCollection.TryParse Method
Tries to pars the string value of the Enum.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryParse(
string strValue,
Object value
)
VB
Public Function TryParse (
strValue As String,
value As Object
) As Boolean
Parameters
strValue | Type: System.String The Value in string represention.
value | Type: System.Object The value.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
ReadOnlyEnumValueCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection.T. Class
ReadOnlyEnumValueCollection.T. Class
Read only version of the EnumValueCollection.T.
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.EnumValue.T..
TwinCAT.TypeSystem.ReadOnlyEnumValueCollection.T.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyEnumValueCollection<T> : ReadOnlyCollection<EnumValue<T>>
where T : IConvertible
VB
Public Class ReadOnlyEnumValueCollection(Of T As IConvertible)
Inherits ReadOnlyCollection(Of EnumValue(Of T))
Type Parameters
T
The ReadOnlyEnumValueCollection.T. type exposes the following members.
Constructors
Name | Description
ReadOnlyEnumValueCollection.T. | Initializes a new instance of the ReadOnlyEnumValueCollection.T. class.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.EnumValue.T...)
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection.EnumValue.T...)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.EnumValue.T...)
Methods
Name | Description
Contains(String) | Determines whether [contains] [the specified name].
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.EnumValue.T...)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.EnumValue.T...)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.EnumValue.T...)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetNames | Gets the Value Names.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Gets the values.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.EnumValue.T...)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parses the specified name.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryParse | Tries to parse the string value of the Enum.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyEnumValueCollection.T. Constructor
•
ReadOnlyEnumValueCollection.T. Properties
•
ReadOnlyEnumValueCollection.T. Methods


ReadOnlyEnumValueCollection.T. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection.T. Class [image] ReadOnlyEnumValueCollection.T. Constructor
ReadOnlyEnumValueCollection.T. Constructor
Initializes a new instance of the ReadOnlyEnumValueCollection.T. class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyEnumValueCollection(
EnumValueCollection<T> coll
)
VB
Public Sub New (
coll As EnumValueCollection(Of T)
)
Parameters
coll
Type: TwinCAT.TypeSystem.EnumValueCollection.T.
The coll.
Reference
ReadOnlyEnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection.T. Class [image] ReadOnlyEnumValueCollection.T. Properties
ReadOnlyEnumValueCollection.T. Properties
The ReadOnlyEnumValueCollection.T. generic type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.EnumValue.T...)
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection.EnumValue.T...)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.EnumValue.T...)
Reference
ReadOnlyEnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection.T. Class [image] ReadOnlyEnumValueCollection.T. Methods
ReadOnlyEnumValueCollection.T. Methods
The ReadOnlyEnumValueCollection.T. generic type exposes the following members.
Methods
Name | Description
Contains(String) | Determines whether [contains] [the specified name].
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.EnumValue.T...)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.EnumValue.T...)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.EnumValue.T...)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetNames | Gets the Value Names.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Gets the values.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.EnumValue.T...)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Parses the specified name.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryParse | Tries to parse the string value of the Enum.
Reference
ReadOnlyEnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyEnumValueCollection.T..Contains Method
•
ReadOnlyEnumValueCollection.T..GetNames Method
•
ReadOnlyEnumValueCollection.T..GetValues Method
•
ReadOnlyEnumValueCollection.T..Parse Method
•
ReadOnlyEnumValueCollection.T..TryParse Method


ReadOnlyEnumValueCollection.T..Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection.T. Class [image] ReadOnlyEnumValueCollection.T. Methods [image] ReadOnlyEnumValueCollection.T..Contains Method
ReadOnlyEnumValueCollection.T..Contains Method
Overload List
Name | Description
Contains(String) | Determines whether [contains] [the specified name].
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.EnumValue.T...)
Reference
ReadOnlyEnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyEnumValueCollection.T..Contains Method (String)


ReadOnlyEnumValueCollection.T..Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection.T. Class [image] ReadOnlyEnumValueCollection.T. Methods [image] ReadOnlyEnumValueCollection.T..Contains Method [image] ReadOnlyEnumValueCollection.T..Contains Method (String)
ReadOnlyEnumValueCollection.T..Contains Method (String)
Determines whether [contains] [the specified name].
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string value
)
VB
Public Function Contains (
value As String
) As Boolean
Parameters
value
Type: System.String
Value
Return Value
Type: Boolean
true if [contains] [the specified name]; otherwise, false.
Reference
ReadOnlyEnumValueCollection.T. Class
Contains Overload
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection.T..GetNames Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection.T. Class [image] ReadOnlyEnumValueCollection.T. Methods [image] ReadOnlyEnumValueCollection.T..GetNames Method
ReadOnlyEnumValueCollection.T..GetNames Method
Gets the Value Names.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string[] GetNames()
VB
Public Function GetNames As String()
Return Value
Type: .String.
System.String[].
Reference
ReadOnlyEnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection.T..GetValues Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection.T. Class [image] ReadOnlyEnumValueCollection.T. Methods [image] ReadOnlyEnumValueCollection.T..GetValues Method
ReadOnlyEnumValueCollection.T..GetValues Method
Gets the values.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T[] GetValues()
VB
Public Function GetValues As T()
Return Value
Type: .T.
T[].
Reference
ReadOnlyEnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection.T..Parse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection.T. Class [image] ReadOnlyEnumValueCollection.T. Methods [image] ReadOnlyEnumValueCollection.T..Parse Method
ReadOnlyEnumValueCollection.T..Parse Method
Parses the specified name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T Parse(
string name
)
VB
Public Function Parse (
name As String
) As T
Parameters
name
Type: System.String
The name.
Return Value
Type: T
T.
Reference
ReadOnlyEnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


ReadOnlyEnumValueCollection.T..TryParse Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyEnumValueCollection.T. Class [image] ReadOnlyEnumValueCollection.T. Methods [image] ReadOnlyEnumValueCollection.T..TryParse Method
ReadOnlyEnumValueCollection.T..TryParse Method
Tries to parse the string value of the Enum.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryParse(
string strValue,
out T value
)
VB
Public Function TryParse (
strValue As String,
<OutAttribute> ByRef value As T
) As Boolean
Parameters
strValue | Type: System.String The Value in string represention.
value | Type: T. The value.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
ReadOnlyEnumValueCollection.T. Class
TwinCAT.TypeSystem Namespace


ReadOnlyFieldCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyFieldCollection Class
ReadOnlyFieldCollection Class
Read only collection of IField objects
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.IField.
TwinCAT.TypeSystem.Generic.ReadOnlyInstanceCollection.IField.
TwinCAT.TypeSystem.ReadOnlyFieldCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyFieldCollection : ReadOnlyInstanceCollection<IField>
VB
Public Class ReadOnlyFieldCollection
Inherits ReadOnlyInstanceCollection(Of IField)
The ReadOnlyFieldCollection type exposes the following members.
Constructors
Name | Description
ReadOnlyFieldCollection | Initializes a new instance of the ReadOnlyMemberCollection class.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IField..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IField..)
Item.String. | Gets the element with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IField..)
Mode | Gets the InstanceCollectionMode. (Inherited from ReadOnlyInstanceCollection.T..)
Methods
Name | Description
Contains(String) | Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IField..)
ContainsName | Determines whether the specified instance is contained. (Inherited from ReadOnlyInstanceCollection.T..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IField..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IField..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from ReadOnlyInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from ReadOnlyInstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IField..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetInstanceByName | Tries to get the instance by name. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetMember | Tries to get the specified member
Fields
Name | Description
mode | Mode of the IInstanceCollection.T. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyFieldCollection Constructor
•
ReadOnlyFieldCollection Properties
•
ReadOnlyFieldCollection Methods
•
ReadOnlyFieldCollection Fields


ReadOnlyFieldCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyFieldCollection Class [image] ReadOnlyFieldCollection Constructor
ReadOnlyFieldCollection Constructor
Initializes a new instance of the ReadOnlyMemberCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyFieldCollection(
FieldCollection members
)
VB
Public Sub New (
members As FieldCollection
)
Parameters
members
Type: TwinCAT.TypeSystem.FieldCollection
The members.
Reference
ReadOnlyFieldCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyFieldCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyFieldCollection Class [image] ReadOnlyFieldCollection Properties
ReadOnlyFieldCollection Properties
The ReadOnlyFieldCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IField..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IField..)
Item.String. | Gets the element with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IField..)
Mode | Gets the InstanceCollectionMode. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
ReadOnlyFieldCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyFieldCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyFieldCollection Class [image] ReadOnlyFieldCollection Methods
ReadOnlyFieldCollection Methods
The ReadOnlyFieldCollection type exposes the following members.
Methods
Name | Description
Contains(String) | Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IField..)
ContainsName | Determines whether the specified instance is contained. (Inherited from ReadOnlyInstanceCollection.T..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IField..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IField..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from ReadOnlyInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from ReadOnlyInstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IField..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetInstanceByName | Tries to get the instance by name. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetMember | Tries to get the specified member
Reference
ReadOnlyFieldCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyFieldCollection.TryGetMember Method


ReadOnlyFieldCollection.TryGetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyFieldCollection Class [image] ReadOnlyFieldCollection Methods [image] ReadOnlyFieldCollection.TryGetMember Method
ReadOnlyFieldCollection.TryGetMember Method
Tries to get the specified member
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetMember(
string fieldName,
out IField symbol
)
VB
Public Function TryGetMember (
fieldName As String,
<OutAttribute> ByRef symbol As IField
) As Boolean
Parameters
fieldName | Type: System.String Name of the member.
symbol | Type: TwinCAT.TypeSystem.IField. The symbol.
Return Value
Type: Boolean
true if found, false otherwise.
Reference
ReadOnlyFieldCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyFieldCollection Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyFieldCollection Class [image] ReadOnlyFieldCollection Fields
ReadOnlyFieldCollection Fields
The ReadOnlyFieldCollection type exposes the following members.
Fields
Name | Description
mode | Mode of the IInstanceCollection.T. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
ReadOnlyFieldCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyMemberCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyMemberCollection Class
ReadOnlyMemberCollection Class
Read only collection of IMember objects
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.IMember.
TwinCAT.TypeSystem.Generic.ReadOnlyInstanceCollection.IMember.
TwinCAT.TypeSystem.ReadOnlyMemberCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyMemberCollection : ReadOnlyInstanceCollection<IMember>
VB
Public Class ReadOnlyMemberCollection
Inherits ReadOnlyInstanceCollection(Of IMember)
The ReadOnlyMemberCollection type exposes the following members.
Constructors
Name | Description
ReadOnlyMemberCollection | Initializes a new instance of the ReadOnlyMemberCollection class.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IMember..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IMember..)
Item.String. | Gets the element with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IMember..)
Mode | Gets the InstanceCollectionMode. (Inherited from ReadOnlyInstanceCollection.T..)
Methods
Name | Description
Contains(String) | Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IMember..)
ContainsName | Determines whether the specified instance is contained. (Inherited from ReadOnlyInstanceCollection.T..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IMember..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IMember..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from ReadOnlyInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from ReadOnlyInstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IMember..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetInstanceByName | Tries to get the instance by name. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetMember | Tries to get the specified member
Fields
Name | Description
mode | Mode of the IInstanceCollection.T. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyMemberCollection Constructor
•
ReadOnlyMemberCollection Properties
•
ReadOnlyMemberCollection Methods
•
ReadOnlyMemberCollection Fields


ReadOnlyMemberCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyMemberCollection Class [image] ReadOnlyMemberCollection Constructor
ReadOnlyMemberCollection Constructor
Initializes a new instance of the ReadOnlyMemberCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyMemberCollection(
MemberCollection members
)
VB
Public Sub New (
members As MemberCollection
)
Parameters
members
Type: TwinCAT.TypeSystem.MemberCollection
The members.
Reference
ReadOnlyMemberCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyMemberCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyMemberCollection Class [image] ReadOnlyMemberCollection Properties
ReadOnlyMemberCollection Properties
The ReadOnlyMemberCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IMember..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IMember..)
Item.String. | Gets the element with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IMember..)
Mode | Gets the InstanceCollectionMode. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
ReadOnlyMemberCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyMemberCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyMemberCollection Class [image] ReadOnlyMemberCollection Methods
ReadOnlyMemberCollection Methods
The ReadOnlyMemberCollection type exposes the following members.
Methods
Name | Description
Contains(String) | Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IMember..)
ContainsName | Determines whether the specified instance is contained. (Inherited from ReadOnlyInstanceCollection.T..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IMember..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IMember..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from ReadOnlyInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from ReadOnlyInstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IMember..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetInstanceByName | Tries to get the instance by name. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetMember | Tries to get the specified member
Reference
ReadOnlyMemberCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyMemberCollection.TryGetMember Method


ReadOnlyMemberCollection.TryGetMember Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyMemberCollection Class [image] ReadOnlyMemberCollection Methods [image] ReadOnlyMemberCollection.TryGetMember Method
ReadOnlyMemberCollection.TryGetMember Method
Tries to get the specified member
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetMember(
string memberName,
out IMember symbol
)
VB
Public Function TryGetMember (
memberName As String,
<OutAttribute> ByRef symbol As IMember
) As Boolean
Parameters
memberName | Type: System.String Name of the member.
symbol | Type: TwinCAT.TypeSystem.IMember. The symbol.
Return Value
Type: Boolean
true if found, false otherwise.
Reference
ReadOnlyMemberCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyMemberCollection Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyMemberCollection Class [image] ReadOnlyMemberCollection Fields
ReadOnlyMemberCollection Fields
The ReadOnlyMemberCollection type exposes the following members.
Fields
Name | Description
mode | Mode of the IInstanceCollection.T. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
ReadOnlyMemberCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyMethodParameterCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyMethodParameterCollection Class
ReadOnlyMethodParameterCollection Class
Read only RpcMethodParameterCollection.
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.IRpcMethodParameter.
TwinCAT.TypeSystem.ReadOnlyMethodParameterCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyMethodParameterCollection : ReadOnlyCollection<IRpcMethodParameter>
VB
Public Class ReadOnlyMethodParameterCollection
Inherits ReadOnlyCollection(Of IRpcMethodParameter)
The ReadOnlyMethodParameterCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyMethodParameterCollection Properties
•
ReadOnlyMethodParameterCollection Methods


ReadOnlyMethodParameterCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyMethodParameterCollection Class [image] ReadOnlyMethodParameterCollection Properties
ReadOnlyMethodParameterCollection Properties
The ReadOnlyMethodParameterCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
Reference
ReadOnlyMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyMethodParameterCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyMethodParameterCollection Class [image] ReadOnlyMethodParameterCollection Methods
ReadOnlyMethodParameterCollection Methods
The ReadOnlyMethodParameterCollection type exposes the following members.
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethodParameter..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
ReadOnlyMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyRpcMethodCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyRpcMethodCollection Class
ReadOnlyRpcMethodCollection Class
Read only RpcMethodCollection
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.IRpcMethod.
TwinCAT.TypeSystem.ReadOnlyRpcMethodCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyRpcMethodCollection : ReadOnlyCollection<IRpcMethod>
VB
Public Class ReadOnlyRpcMethodCollection
Inherits ReadOnlyCollection(Of IRpcMethod)
The ReadOnlyRpcMethodCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IRpcMethod..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IRpcMethod..)
Item.String. | Gets the IRpcMethod with the specified method name.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IRpcMethod..)
Methods
Name | Description
Contains(String) | Determines whether this collection contains the specified method name.
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethod..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IRpcMethod..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethod..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethod..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetMethod(Int32, IRpcMethod.) | Tries to get the specified method.
TryGetMethod(String, IRpcMethod.) | Tries to get the specified method.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyRpcMethodCollection Properties
•
ReadOnlyRpcMethodCollection Methods


ReadOnlyRpcMethodCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyRpcMethodCollection Class [image] ReadOnlyRpcMethodCollection Properties
ReadOnlyRpcMethodCollection Properties
The ReadOnlyRpcMethodCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.IRpcMethod..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IRpcMethod..)
Item.String. | Gets the IRpcMethod with the specified method name.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.IRpcMethod..)
Reference
ReadOnlyRpcMethodCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyRpcMethodCollection.Item Property


ReadOnlyRpcMethodCollection.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyRpcMethodCollection Class [image] ReadOnlyRpcMethodCollection Properties [image] ReadOnlyRpcMethodCollection.Item Property
ReadOnlyRpcMethodCollection.Item Property
Overload List
Name | Description
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.IRpcMethod..)
Item.String. | Gets the IRpcMethod with the specified method name.
Reference
ReadOnlyRpcMethodCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyRpcMethodCollection.Item Property (String)


ReadOnlyRpcMethodCollection.Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyRpcMethodCollection Class [image] ReadOnlyRpcMethodCollection Properties [image] ReadOnlyRpcMethodCollection.Item Property [image] ReadOnlyRpcMethodCollection.Item Property (String)
ReadOnlyRpcMethodCollection.Item Property (String)
Gets the IRpcMethod with the specified method name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IRpcMethod this[
string methodName
] { get; }
VB
Public ReadOnly Default Property Item (
methodName As String
) As IRpcMethod
Get
Parameters
methodName
Type: System.String
Name of the method.
Return Value
Type: IRpcMethod
RpcMethod.
Exceptions
Exception | Condition
KeyNotFoundException |
Reference
ReadOnlyRpcMethodCollection Class
Item Overload
TwinCAT.TypeSystem Namespace


ReadOnlyRpcMethodCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyRpcMethodCollection Class [image] ReadOnlyRpcMethodCollection Methods
ReadOnlyRpcMethodCollection Methods
The ReadOnlyRpcMethodCollection type exposes the following members.
Methods
Name | Description
Contains(String) | Determines whether this collection contains the specified method name.
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethod..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.IRpcMethod..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethod..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethod..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetMethod(Int32, IRpcMethod.) | Tries to get the specified method.
TryGetMethod(String, IRpcMethod.) | Tries to get the specified method.
Reference
ReadOnlyRpcMethodCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyRpcMethodCollection.Contains Method
•
ReadOnlyRpcMethodCollection.TryGetMethod Method


ReadOnlyRpcMethodCollection.Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyRpcMethodCollection Class [image] ReadOnlyRpcMethodCollection Methods [image] ReadOnlyRpcMethodCollection.Contains Method
ReadOnlyRpcMethodCollection.Contains Method
Overload List
Name | Description
Contains(String) | Determines whether this collection contains the specified method name.
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.IRpcMethod..)
Reference
ReadOnlyRpcMethodCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyRpcMethodCollection.Contains Method (String)


ReadOnlyRpcMethodCollection.Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyRpcMethodCollection Class [image] ReadOnlyRpcMethodCollection Methods [image] ReadOnlyRpcMethodCollection.Contains Method [image] ReadOnlyRpcMethodCollection.Contains Method (String)
ReadOnlyRpcMethodCollection.Contains Method (String)
Determines whether this collection contains the specified method name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string methodName
)
VB
Public Function Contains (
methodName As String
) As Boolean
Parameters
methodName
Type: System.String
Name of the method.
Return Value
Type: Boolean
true if contained.; otherwise, false.
Reference
ReadOnlyRpcMethodCollection Class
Contains Overload
TwinCAT.TypeSystem Namespace


ReadOnlyRpcMethodCollection.TryGetMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyRpcMethodCollection Class [image] ReadOnlyRpcMethodCollection Methods [image] ReadOnlyRpcMethodCollection.TryGetMethod Method
ReadOnlyRpcMethodCollection.TryGetMethod Method
Overload List
Name | Description
TryGetMethod(Int32, IRpcMethod.) | Tries to get the specified method.
TryGetMethod(String, IRpcMethod.) | Tries to get the specified method.
Reference
ReadOnlyRpcMethodCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyRpcMethodCollection.TryGetMethod Method (Int32, IRpcMethod.)
•
ReadOnlyRpcMethodCollection.TryGetMethod Method (String, IRpcMethod.)


ReadOnlyRpcMethodCollection.TryGetMethod Method (Int32, IRpcMethod.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyRpcMethodCollection Class [image] ReadOnlyRpcMethodCollection Methods [image] ReadOnlyRpcMethodCollection.TryGetMethod Method [image] ReadOnlyRpcMethodCollection.TryGetMethod Method (Int32, IRpcMethod.)
ReadOnlyRpcMethodCollection.TryGetMethod Method (Int32, IRpcMethod.)
Tries to get the specified method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetMethod(
int vTableIndex,
out IRpcMethod method
)
VB
Public Function TryGetMethod (
vTableIndex As Integer,
<OutAttribute> ByRef method As IRpcMethod
) As Boolean
Parameters
vTableIndex | Type: System.Int32 vTableIndex.
method | Type: TwinCAT.TypeSystem.IRpcMethod. The method if fund, NULL otherwise.
Return Value
Type: Boolean
true if found, false otherwise.
Reference
ReadOnlyRpcMethodCollection Class
TryGetMethod Overload
TwinCAT.TypeSystem Namespace


ReadOnlyRpcMethodCollection.TryGetMethod Method (String, IRpcMethod.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyRpcMethodCollection Class [image] ReadOnlyRpcMethodCollection Methods [image] ReadOnlyRpcMethodCollection.TryGetMethod Method [image] ReadOnlyRpcMethodCollection.TryGetMethod Method (String, IRpcMethod.)
ReadOnlyRpcMethodCollection.TryGetMethod Method (String, IRpcMethod.)
Tries to get the specified method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetMethod(
string methodName,
out IRpcMethod method
)
VB
Public Function TryGetMethod (
methodName As String,
<OutAttribute> ByRef method As IRpcMethod
) As Boolean
Parameters
methodName | Type: System.String Name of the method.
method | Type: TwinCAT.TypeSystem.IRpcMethod. The method if fund, NULL otherwise.
Return Value
Type: Boolean
true if found, false otherwise.
Reference
ReadOnlyRpcMethodCollection Class
TryGetMethod Overload
TwinCAT.TypeSystem Namespace


ReadOnlySubItemCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlySubItemCollection Class
ReadOnlySubItemCollection Class
Class ReadOnlySubItemCollection.
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.ITcAdsSubItem.
TwinCAT.TypeSystem.ReadOnlySubItemCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlySubItemCollection : ReadOnlyCollection<ITcAdsSubItem>
VB
Public Class ReadOnlySubItemCollection
Inherits ReadOnlyCollection(Of ITcAdsSubItem)
The ReadOnlySubItemCollection type exposes the following members.
Constructors
Name | Description
ReadOnlySubItemCollection. | Initializes a new instance of the ReadOnlySubItemCollection class.
ReadOnlySubItemCollection(IList.ITcAdsSubItem.) | Initializes a new instance of the ReadOnlySubItemCollection class.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlySubItemCollection Constructor
•
ReadOnlySubItemCollection Properties
•
ReadOnlySubItemCollection Methods


ReadOnlySubItemCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlySubItemCollection Class [image] ReadOnlySubItemCollection Constructor
ReadOnlySubItemCollection Constructor
Overload List
Name | Description
ReadOnlySubItemCollection. | Initializes a new instance of the ReadOnlySubItemCollection class.
ReadOnlySubItemCollection(IList.ITcAdsSubItem.) | Initializes a new instance of the ReadOnlySubItemCollection class.
Reference
ReadOnlySubItemCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlySubItemCollection Constructor
•
ReadOnlySubItemCollection Constructor (IList.ITcAdsSubItem.)


ReadOnlySubItemCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlySubItemCollection Class [image] ReadOnlySubItemCollection Constructor [image] ReadOnlySubItemCollection Constructor
ReadOnlySubItemCollection Constructor
Initializes a new instance of the ReadOnlySubItemCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySubItemCollection()
VB
Public Sub New
Reference
ReadOnlySubItemCollection Class
ReadOnlySubItemCollection Overload
TwinCAT.TypeSystem Namespace


ReadOnlySubItemCollection Constructor (IList.ITcAdsSubItem.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlySubItemCollection Class [image] ReadOnlySubItemCollection Constructor [image] ReadOnlySubItemCollection Constructor (IList.ITcAdsSubItem.)
ReadOnlySubItemCollection Constructor (IList.ITcAdsSubItem.)
Initializes a new instance of the ReadOnlySubItemCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySubItemCollection(
IList<ITcAdsSubItem> coll
)
VB
Public Sub New (
coll As IList(Of ITcAdsSubItem)
)
Parameters
coll
Type: System.Collections.Generic.IList.ITcAdsSubItem.
The coll.
Reference
ReadOnlySubItemCollection Class
ReadOnlySubItemCollection Overload
TwinCAT.TypeSystem Namespace


ReadOnlySubItemCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlySubItemCollection Class [image] ReadOnlySubItemCollection Properties
ReadOnlySubItemCollection Properties
The ReadOnlySubItemCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
Reference
ReadOnlySubItemCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlySubItemCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlySubItemCollection Class [image] ReadOnlySubItemCollection Methods
ReadOnlySubItemCollection Methods
The ReadOnlySubItemCollection type exposes the following members.
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITcAdsSubItem..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
ReadOnlySubItemCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlySymbolCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlySymbolCollection Class
ReadOnlySymbolCollection Class
ReadOnly collection containing ISymbol objects.
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.ISymbol.
TwinCAT.TypeSystem.Generic.ReadOnlyInstanceCollection.ISymbol.
TwinCAT.TypeSystem.Generic.ReadOnlySymbolCollection.ISymbol.
TwinCAT.TypeSystem.ReadOnlySymbolCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlySymbolCollection : ReadOnlySymbolCollection<ISymbol>,
ISymbolCollection, ISymbolCollection<ISymbol>, IInstanceCollection<ISymbol>,
IList<ISymbol>, ICollection<ISymbol>, IEnumerable<ISymbol>,
IEnumerable
VB
Public Class ReadOnlySymbolCollection
Inherits ReadOnlySymbolCollection(Of ISymbol)
Implements ISymbolCollection, ISymbolCollection(Of ISymbol),
IInstanceCollection(Of ISymbol), IList(Of ISymbol), ICollection(Of ISymbol),
IEnumerable(Of ISymbol), IEnumerable
The ReadOnlySymbolCollection type exposes the following members.
Constructors
Name | Description
ReadOnlySymbolCollection | Initializes a new instance of the ReadOnlySymbolCollection class.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.ISymbol..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.ISymbol..)
Item.String. | Gets the element with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.ISymbol..)
Mode | Gets the InstanceCollectionMode. (Inherited from ReadOnlyInstanceCollection.T..)
Methods
Name | Description
Contains(String) | Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ISymbol..)
ContainsName | Determines whether the specified instance is contained. (Inherited from ReadOnlyInstanceCollection.T..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.ISymbol..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ISymbol..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from ReadOnlyInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from ReadOnlyInstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ISymbol..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetInstanceByName | Tries to get the instance by name. (Inherited from ReadOnlyInstanceCollection.T..)
Fields
Name | Description
mode | Mode of the IInstanceCollection.T. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlySymbolCollection Constructor
•
ReadOnlySymbolCollection Properties
•
ReadOnlySymbolCollection Methods
•
ReadOnlySymbolCollection Fields


ReadOnlySymbolCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlySymbolCollection Class [image] ReadOnlySymbolCollection Constructor
ReadOnlySymbolCollection Constructor
Initializes a new instance of the ReadOnlySymbolCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySymbolCollection(
IInstanceCollection<ISymbol> symbols
)
VB
Public Sub New (
symbols As IInstanceCollection(Of ISymbol)
)
Parameters
symbols
Type: TwinCAT.TypeSystem.Generic.IInstanceCollection.ISymbol.
The symbols.
Reference
ReadOnlySymbolCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlySymbolCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlySymbolCollection Class [image] ReadOnlySymbolCollection Properties
ReadOnlySymbolCollection Properties
The ReadOnlySymbolCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.ISymbol..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.ISymbol..)
Item.String. | Gets the element with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.ISymbol..)
Mode | Gets the InstanceCollectionMode. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
ReadOnlySymbolCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlySymbolCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlySymbolCollection Class [image] ReadOnlySymbolCollection Methods
ReadOnlySymbolCollection Methods
The ReadOnlySymbolCollection type exposes the following members.
Methods
Name | Description
Contains(String) | Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ISymbol..)
ContainsName | Determines whether the specified instance is contained. (Inherited from ReadOnlyInstanceCollection.T..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.ISymbol..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ISymbol..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from ReadOnlyInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from ReadOnlyInstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ISymbol..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetInstanceByName | Tries to get the instance by name. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
ReadOnlySymbolCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlySymbolCollection Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlySymbolCollection Class [image] ReadOnlySymbolCollection Fields
ReadOnlySymbolCollection Fields
The ReadOnlySymbolCollection type exposes the following members.
Fields
Name | Description
mode | Mode of the IInstanceCollection.T. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
ReadOnlySymbolCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyTypeAttributeCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyTypeAttributeCollection Class
ReadOnlyTypeAttributeCollection Class
Read only version of the TypeAttributeCollection
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.ITypeAttribute.
TwinCAT.TypeSystem.ReadOnlyTypeAttributeCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyTypeAttributeCollection : ReadOnlyCollection<ITypeAttribute>
VB
Public Class ReadOnlyTypeAttributeCollection
Inherits ReadOnlyCollection(Of ITypeAttribute)
The ReadOnlyTypeAttributeCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.ITypeAttribute..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.ITypeAttribute..)
Item.String. | Gets the String with the specified name.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.ITypeAttribute..)
Methods
Name | Description
Contains(String) | Determines whether this ReadOnlyTypeAttributeCollection contains the specified attribute.
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITypeAttribute..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.ITypeAttribute..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITypeAttribute..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITypeAttribute..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetAttribute | Tries to get the specified ITypeAttribute
TryGetValue | Tries to get the specified Attribute value.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyTypeAttributeCollection Properties
•
ReadOnlyTypeAttributeCollection Methods


ReadOnlyTypeAttributeCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyTypeAttributeCollection Class [image] ReadOnlyTypeAttributeCollection Properties
ReadOnlyTypeAttributeCollection Properties
The ReadOnlyTypeAttributeCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.ITypeAttribute..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.ITypeAttribute..)
Item.String. | Gets the String with the specified name.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.ITypeAttribute..)
Reference
ReadOnlyTypeAttributeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyTypeAttributeCollection.Item Property


ReadOnlyTypeAttributeCollection.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyTypeAttributeCollection Class [image] ReadOnlyTypeAttributeCollection Properties [image] ReadOnlyTypeAttributeCollection.Item Property
ReadOnlyTypeAttributeCollection.Item Property
Overload List
Name | Description
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.ITypeAttribute..)
Item.String. | Gets the String with the specified name.
Reference
ReadOnlyTypeAttributeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyTypeAttributeCollection.Item Property (String)


ReadOnlyTypeAttributeCollection.Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyTypeAttributeCollection Class [image] ReadOnlyTypeAttributeCollection Properties [image] ReadOnlyTypeAttributeCollection.Item Property [image] ReadOnlyTypeAttributeCollection.Item Property (String)
ReadOnlyTypeAttributeCollection.Item Property (String)
Gets the String with the specified name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string this[
string name
] { get; }
VB
Public ReadOnly Default Property Item (
name As String
) As String
Get
Parameters
name
Type: System.String
The name.
Return Value
Type: String
System.String.
Reference
ReadOnlyTypeAttributeCollection Class
Item Overload
TwinCAT.TypeSystem Namespace


ReadOnlyTypeAttributeCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyTypeAttributeCollection Class [image] ReadOnlyTypeAttributeCollection Methods
ReadOnlyTypeAttributeCollection Methods
The ReadOnlyTypeAttributeCollection type exposes the following members.
Methods
Name | Description
Contains(String) | Determines whether this ReadOnlyTypeAttributeCollection contains the specified attribute.
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITypeAttribute..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.ITypeAttribute..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITypeAttribute..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITypeAttribute..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetAttribute | Tries to get the specified ITypeAttribute
TryGetValue | Tries to get the specified Attribute value.
Reference
ReadOnlyTypeAttributeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyTypeAttributeCollection.Contains Method
•
ReadOnlyTypeAttributeCollection.TryGetAttribute Method
•
ReadOnlyTypeAttributeCollection.TryGetValue Method


ReadOnlyTypeAttributeCollection.Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyTypeAttributeCollection Class [image] ReadOnlyTypeAttributeCollection Methods [image] ReadOnlyTypeAttributeCollection.Contains Method
ReadOnlyTypeAttributeCollection.Contains Method
Overload List
Name | Description
Contains(String) | Determines whether this ReadOnlyTypeAttributeCollection contains the specified attribute.
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.ITypeAttribute..)
Reference
ReadOnlyTypeAttributeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ReadOnlyTypeAttributeCollection.Contains Method (String)


ReadOnlyTypeAttributeCollection.Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyTypeAttributeCollection Class [image] ReadOnlyTypeAttributeCollection Methods [image] ReadOnlyTypeAttributeCollection.Contains Method [image] ReadOnlyTypeAttributeCollection.Contains Method (String)
ReadOnlyTypeAttributeCollection.Contains Method (String)
Determines whether this ReadOnlyTypeAttributeCollection contains the specified attribute.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string name
)
VB
Public Function Contains (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if [contains] [the specified name]; otherwise, false.
Reference
ReadOnlyTypeAttributeCollection Class
Contains Overload
TwinCAT.TypeSystem Namespace


ReadOnlyTypeAttributeCollection.TryGetAttribute Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyTypeAttributeCollection Class [image] ReadOnlyTypeAttributeCollection Methods [image] ReadOnlyTypeAttributeCollection.TryGetAttribute Method
ReadOnlyTypeAttributeCollection.TryGetAttribute Method
Tries to get the specified ITypeAttribute
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetAttribute(
string name,
out ITypeAttribute attribute
)
VB
Public Function TryGetAttribute (
name As String,
<OutAttribute> ByRef attribute As ITypeAttribute
) As Boolean
Parameters
name | Type: System.String The name of the ITypeAttribute.
attribute | Type: TwinCAT.TypeSystem.ITypeAttribute. The attribute.
Return Value
Type: Boolean
true if found, false otherwise.
Reference
ReadOnlyTypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


ReadOnlyTypeAttributeCollection.TryGetValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ReadOnlyTypeAttributeCollection Class [image] ReadOnlyTypeAttributeCollection Methods [image] ReadOnlyTypeAttributeCollection.TryGetValue Method
ReadOnlyTypeAttributeCollection.TryGetValue Method
Tries to get the specified Attribute value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetValue(
string name,
out string value
)
VB
Public Function TryGetValue (
name As String,
<OutAttribute> ByRef value As String
) As Boolean
Parameters
name | Type: System.String The name.
value | Type: System.String. The value.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
ReadOnlyTypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class
RpcMethodCollection Class
Collection of RpcMethods.
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.RpcMethodCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class RpcMethodCollection : IList<IRpcMethod>,
ICollection<IRpcMethod>, IEnumerable<IRpcMethod>, IEnumerable
VB
Public Class RpcMethodCollection
Implements IList(Of IRpcMethod), ICollection(Of IRpcMethod),
IEnumerable(Of IRpcMethod), IEnumerable
The RpcMethodCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets the IRpcMethod with the specified method name.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Gets a read only collection of this RpcMethodCollection
Clear | Removes all items from the ICollection.T..
Contains(String) | Determines whether this collection contains the specified method name.
Contains(IRpcMethod) | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetMethod(Int32, IRpcMethod.) | Tries to get the specified method.
TryGetMethod(String, IRpcMethod.) | Tries to get the specified method.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethodCollection Properties
•
RpcMethodCollection Methods


RpcMethodCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Properties
RpcMethodCollection Properties
The RpcMethodCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets the IRpcMethod with the specified method name.
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethodCollection.Count Property
•
RpcMethodCollection.IsReadOnly Property
•
RpcMethodCollection.Item Property


RpcMethodCollection.Count Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Properties [image] RpcMethodCollection.Count Property
RpcMethodCollection.Count Property
Gets the number of elements contained in the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Count { get; }
VB
Public ReadOnly Property Count As Integer
Get
Property Value
Type: Int32
The count.
Implements
ICollection.T..Count
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection.IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Properties [image] RpcMethodCollection.IsReadOnly Property
RpcMethodCollection.IsReadOnly Property
Gets a value indicating whether the ICollection.T. is read-only.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if this instance is read only; otherwise, false.
Implements
ICollection.T..IsReadOnly
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Properties [image] RpcMethodCollection.Item Property
RpcMethodCollection.Item Property
Overload List
Name | Description
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets the IRpcMethod with the specified method name.
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethodCollection.Item Property (Int32)
•
RpcMethodCollection.Item Property (String)


RpcMethodCollection.Item Property (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Properties [image] RpcMethodCollection.Item Property [image] RpcMethodCollection.Item Property (Int32)
RpcMethodCollection.Item Property (Int32)
Gets or sets the element at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IRpcMethod this[
int index
] { get; set; }
VB
Public Default Property Item (
index As Integer
) As IRpcMethod
Get
Set
Parameters
index
Type: System.Int32
The index.
Return Value
Type: IRpcMethod
RpcMethod.
Implements
IList.T..Item.Int32.
Exceptions
Exception | Condition
NotImplementedException |
Reference
RpcMethodCollection Class
Item Overload
TwinCAT.TypeSystem Namespace


RpcMethodCollection.Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Properties [image] RpcMethodCollection.Item Property [image] RpcMethodCollection.Item Property (String)
RpcMethodCollection.Item Property (String)
Gets the IRpcMethod with the specified method name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IRpcMethod this[
string methodName
] { get; }
VB
Public ReadOnly Default Property Item (
methodName As String
) As IRpcMethod
Get
Parameters
methodName
Type: System.String
Name of the method.
Return Value
Type: IRpcMethod
RpcMethod.
Exceptions
Exception | Condition
KeyNotFoundException |
Reference
RpcMethodCollection Class
Item Overload
TwinCAT.TypeSystem Namespace


RpcMethodCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods
RpcMethodCollection Methods
The RpcMethodCollection type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Gets a read only collection of this RpcMethodCollection
Clear | Removes all items from the ICollection.T..
Contains(String) | Determines whether this collection contains the specified method name.
Contains(IRpcMethod) | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetMethod(Int32, IRpcMethod.) | Tries to get the specified method.
TryGetMethod(String, IRpcMethod.) | Tries to get the specified method.
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethodCollection.Add Method
•
RpcMethodCollection.AsReadOnly Method
•
RpcMethodCollection.Clear Method
•
RpcMethodCollection.Contains Method
•
RpcMethodCollection.CopyTo Method
•
RpcMethodCollection.GetEnumerator Method
•
RpcMethodCollection.IndexOf Method
•
RpcMethodCollection.Insert Method
•
RpcMethodCollection.Remove Method
•
RpcMethodCollection.RemoveAt Method
•
RpcMethodCollection.TryGetMethod Method


RpcMethodCollection.Add Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.Add Method
RpcMethodCollection.Add Method
Adds an item to the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Add(
IRpcMethod item
)
VB
Public Sub Add (
item As IRpcMethod
)
Parameters
item
Type: TwinCAT.TypeSystem.IRpcMethod
The object to add to the ICollection.T..
Implements
ICollection.T..Add(T)
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection.AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.AsReadOnly Method
RpcMethodCollection.AsReadOnly Method
Gets a read only collection of this RpcMethodCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyRpcMethodCollection AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlyRpcMethodCollection
Field Value
Type: ReadOnlyRpcMethodCollection
Returns a read only version of this RpcMethodCollection
Return Value
Type: ReadOnlyRpcMethodCollection
ReadOnlyRpcMethodCollection.
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection.Clear Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.Clear Method
RpcMethodCollection.Clear Method
Removes all items from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Clear()
VB
Public Sub Clear
Implements
ICollection.T..Clear.
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection.Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.Contains Method
RpcMethodCollection.Contains Method
Overload List
Name | Description
Contains(String) | Determines whether this collection contains the specified method name.
Contains(IRpcMethod) | Determines whether the ICollection.T. contains a specific value.
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethodCollection.Contains Method (String)
•
RpcMethodCollection.Contains Method (IRpcMethod)


RpcMethodCollection.Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.Contains Method [image] RpcMethodCollection.Contains Method (String)
RpcMethodCollection.Contains Method (String)
Determines whether this collection contains the specified method name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string methodName
)
VB
Public Function Contains (
methodName As String
) As Boolean
Parameters
methodName
Type: System.String
Name of the method.
Return Value
Type: Boolean
true if contained.; otherwise, false.
Reference
RpcMethodCollection Class
Contains Overload
TwinCAT.TypeSystem Namespace


RpcMethodCollection.Contains Method (IRpcMethod)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.Contains Method [image] RpcMethodCollection.Contains Method (IRpcMethod)
RpcMethodCollection.Contains Method (IRpcMethod)
Determines whether the ICollection.T. contains a specific value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
IRpcMethod item
)
VB
Public Function Contains (
item As IRpcMethod
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.IRpcMethod
The object to locate in the ICollection.T..
Return Value
Type: Boolean
true if item is found in the ICollection.T.; otherwise, false.
Implements
ICollection.T..Contains(T)
Reference
RpcMethodCollection Class
Contains Overload
TwinCAT.TypeSystem Namespace


RpcMethodCollection.CopyTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.CopyTo Method
RpcMethodCollection.CopyTo Method
Copies to.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void CopyTo(
IRpcMethod[] array,
int arrayIndex
)
VB
Public Sub CopyTo (
array As IRpcMethod(),
arrayIndex As Integer
)
Parameters
array | Type: .TwinCAT.TypeSystem.IRpcMethod. The array.
arrayIndex | Type: System.Int32 Index of the array.
Implements
ICollection.T..CopyTo(.T., Int32)
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection.GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.GetEnumerator Method
RpcMethodCollection.GetEnumerator Method
Returns an enumerator that iterates through the collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<IRpcMethod> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of IRpcMethod)
Return Value
Type: IEnumerator.IRpcMethod.
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection.IndexOf Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.IndexOf Method
RpcMethodCollection.IndexOf Method
Determines the index of a specific item in the IList.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int IndexOf(
IRpcMethod item
)
VB
Public Function IndexOf (
item As IRpcMethod
) As Integer
Parameters
item
Type: TwinCAT.TypeSystem.IRpcMethod
The object to locate in the IList.T..
Return Value
Type: Int32
The index of item if found in the list; otherwise, -1.
Implements
IList.T..IndexOf(T)
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection.Insert Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.Insert Method
RpcMethodCollection.Insert Method
Inserts an item to the IList.T. at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Insert(
int index,
IRpcMethod item
)
VB
Public Sub Insert (
index As Integer,
item As IRpcMethod
)
Parameters
index | Type: System.Int32 The zero-based index at which item should be inserted.
item | Type: TwinCAT.TypeSystem.IRpcMethod The object to insert into the IList.T..
Implements
IList.T..Insert(Int32, T)
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection.Remove Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.Remove Method
RpcMethodCollection.Remove Method
Removes the first occurrence of a specific object from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Remove(
IRpcMethod item
)
VB
Public Function Remove (
item As IRpcMethod
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.IRpcMethod
The object to remove from the ICollection.T..
Return Value
Type: Boolean
true if item was successfully removed from the ICollection.T.; otherwise, false. This method also returns false if item is not found in the original ICollection.T..
Implements
ICollection.T..Remove(T)
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection.RemoveAt Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.RemoveAt Method
RpcMethodCollection.RemoveAt Method
Removes the IList.T. item at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void RemoveAt(
int index
)
VB
Public Sub RemoveAt (
index As Integer
)
Parameters
index
Type: System.Int32
The zero-based index of the item to remove.
Implements
IList.T..RemoveAt(Int32)
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodCollection.TryGetMethod Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.TryGetMethod Method
RpcMethodCollection.TryGetMethod Method
Overload List
Name | Description
TryGetMethod(Int32, IRpcMethod.) | Tries to get the specified method.
TryGetMethod(String, IRpcMethod.) | Tries to get the specified method.
Reference
RpcMethodCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethodCollection.TryGetMethod Method (Int32, IRpcMethod.)
•
RpcMethodCollection.TryGetMethod Method (String, IRpcMethod.)


RpcMethodCollection.TryGetMethod Method (Int32, IRpcMethod.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.TryGetMethod Method [image] RpcMethodCollection.TryGetMethod Method (Int32, IRpcMethod.)
RpcMethodCollection.TryGetMethod Method (Int32, IRpcMethod.)
Tries to get the specified method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetMethod(
int vTableIndex,
out IRpcMethod method
)
VB
Public Function TryGetMethod (
vTableIndex As Integer,
<OutAttribute> ByRef method As IRpcMethod
) As Boolean
Parameters
vTableIndex | Type: System.Int32 VTable index.
method | Type: TwinCAT.TypeSystem.IRpcMethod. The method if fund, NULL otherwise.
Return Value
Type: Boolean
true if found, false otherwise.
Reference
RpcMethodCollection Class
TryGetMethod Overload
TwinCAT.TypeSystem Namespace


RpcMethodCollection.TryGetMethod Method (String, IRpcMethod.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodCollection Class [image] RpcMethodCollection Methods [image] RpcMethodCollection.TryGetMethod Method [image] RpcMethodCollection.TryGetMethod Method (String, IRpcMethod.)
RpcMethodCollection.TryGetMethod Method (String, IRpcMethod.)
Tries to get the specified method.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetMethod(
string methodName,
out IRpcMethod method
)
VB
Public Function TryGetMethod (
methodName As String,
<OutAttribute> ByRef method As IRpcMethod
) As Boolean
Parameters
methodName | Type: System.String Name of the method.
method | Type: TwinCAT.TypeSystem.IRpcMethod. The method if fund, NULL otherwise.
Return Value
Type: Boolean
true if found, false otherwise.
Reference
RpcMethodCollection Class
TryGetMethod Overload
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class
RpcMethodParameterCollection Class
Collection of RPC method parameters
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.RpcMethodParameterCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class RpcMethodParameterCollection : IList<IRpcMethodParameter>,
ICollection<IRpcMethodParameter>, IEnumerable<IRpcMethodParameter>, IEnumerable
VB
Public Class RpcMethodParameterCollection
Implements IList(Of IRpcMethodParameter), ICollection(Of IRpcMethodParameter),
IEnumerable(Of IRpcMethodParameter), IEnumerable
The RpcMethodParameterCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item | Gets or sets the element at the specified index.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Returns a read only version of this RpcMethodParameterCollection
Clear | Removes all items from the ICollection.T..
Contains | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethodParameterCollection Properties
•
RpcMethodParameterCollection Methods


RpcMethodParameterCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Properties
RpcMethodParameterCollection Properties
The RpcMethodParameterCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item | Gets or sets the element at the specified index.
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethodParameterCollection.Count Property
•
RpcMethodParameterCollection.IsReadOnly Property
•
RpcMethodParameterCollection.Item Property


RpcMethodParameterCollection.Count Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Properties [image] RpcMethodParameterCollection.Count Property
RpcMethodParameterCollection.Count Property
Gets the number of elements contained in the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Count { get; }
VB
Public ReadOnly Property Count As Integer
Get
Property Value
Type: Int32
The count.
Implements
ICollection.T..Count
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection.IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Properties [image] RpcMethodParameterCollection.IsReadOnly Property
RpcMethodParameterCollection.IsReadOnly Property
Gets a value indicating whether the ICollection.T. is read-only.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if this instance is read only; otherwise, false.
Implements
ICollection.T..IsReadOnly
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Properties [image] RpcMethodParameterCollection.Item Property
RpcMethodParameterCollection.Item Property
Gets or sets the element at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IRpcMethodParameter this[
int index
] { get; set; }
VB
Public Default Property Item (
index As Integer
) As IRpcMethodParameter
Get
Set
Parameters
index
Type: System.Int32
The index.
Return Value
Type: IRpcMethodParameter
RpcMethodParameter.
Implements
IList.T..Item.Int32.
Exceptions
Exception | Condition
NotImplementedException |
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Methods
RpcMethodParameterCollection Methods
The RpcMethodParameterCollection type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Returns a read only version of this RpcMethodParameterCollection
Clear | Removes all items from the ICollection.T..
Contains | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
RpcMethodParameterCollection.Add Method
•
RpcMethodParameterCollection.AsReadOnly Method
•
RpcMethodParameterCollection.Clear Method
•
RpcMethodParameterCollection.Contains Method
•
RpcMethodParameterCollection.CopyTo Method
•
RpcMethodParameterCollection.GetEnumerator Method
•
RpcMethodParameterCollection.IndexOf Method
•
RpcMethodParameterCollection.Insert Method
•
RpcMethodParameterCollection.Remove Method
•
RpcMethodParameterCollection.RemoveAt Method


RpcMethodParameterCollection.Add Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Methods [image] RpcMethodParameterCollection.Add Method
RpcMethodParameterCollection.Add Method
Adds an item to the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Add(
IRpcMethodParameter item
)
VB
Public Sub Add (
item As IRpcMethodParameter
)
Parameters
item
Type: TwinCAT.TypeSystem.IRpcMethodParameter
The object to add to the ICollection.T..
Implements
ICollection.T..Add(T)
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection.AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Methods [image] RpcMethodParameterCollection.AsReadOnly Method
RpcMethodParameterCollection.AsReadOnly Method
Returns a read only version of this RpcMethodParameterCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyMethodParameterCollection AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlyMethodParameterCollection
Field Value
Type: ReadOnlyMethodParameterCollection
Collection as read only version.
Return Value
Type: ReadOnlyMethodParameterCollection
ReadOnlyMethodParameterCollection.
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection.Clear Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Methods [image] RpcMethodParameterCollection.Clear Method
RpcMethodParameterCollection.Clear Method
Removes all items from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Clear()
VB
Public Sub Clear
Implements
ICollection.T..Clear.
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection.Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Methods [image] RpcMethodParameterCollection.Contains Method
RpcMethodParameterCollection.Contains Method
Determines whether the ICollection.T. contains a specific value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
IRpcMethodParameter item
)
VB
Public Function Contains (
item As IRpcMethodParameter
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.IRpcMethodParameter
The object to locate in the ICollection.T..
Return Value
Type: Boolean
true if item is found in the ICollection.T.; otherwise, false.
Implements
ICollection.T..Contains(T)
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection.CopyTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Methods [image] RpcMethodParameterCollection.CopyTo Method
RpcMethodParameterCollection.CopyTo Method
Copies to.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void CopyTo(
IRpcMethodParameter[] array,
int arrayIndex
)
VB
Public Sub CopyTo (
array As IRpcMethodParameter(),
arrayIndex As Integer
)
Parameters
array | Type: .TwinCAT.TypeSystem.IRpcMethodParameter. The array.
arrayIndex | Type: System.Int32 Index of the array.
Implements
ICollection.T..CopyTo(.T., Int32)
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection.GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Methods [image] RpcMethodParameterCollection.GetEnumerator Method
RpcMethodParameterCollection.GetEnumerator Method
Returns an enumerator that iterates through the collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<IRpcMethodParameter> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of IRpcMethodParameter)
Return Value
Type: IEnumerator.IRpcMethodParameter.
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection.IndexOf Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Methods [image] RpcMethodParameterCollection.IndexOf Method
RpcMethodParameterCollection.IndexOf Method
Determines the index of a specific item in the IList.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int IndexOf(
IRpcMethodParameter item
)
VB
Public Function IndexOf (
item As IRpcMethodParameter
) As Integer
Parameters
item
Type: TwinCAT.TypeSystem.IRpcMethodParameter
The object to locate in the IList.T..
Return Value
Type: Int32
The index of item if found in the list; otherwise, -1.
Implements
IList.T..IndexOf(T)
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection.Insert Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Methods [image] RpcMethodParameterCollection.Insert Method
RpcMethodParameterCollection.Insert Method
Inserts an item to the IList.T. at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Insert(
int index,
IRpcMethodParameter item
)
VB
Public Sub Insert (
index As Integer,
item As IRpcMethodParameter
)
Parameters
index | Type: System.Int32 The zero-based index at which item should be inserted.
item | Type: TwinCAT.TypeSystem.IRpcMethodParameter The object to insert into the IList.T..
Implements
IList.T..Insert(Int32, T)
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection.Remove Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Methods [image] RpcMethodParameterCollection.Remove Method
RpcMethodParameterCollection.Remove Method
Removes the first occurrence of a specific object from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Remove(
IRpcMethodParameter item
)
VB
Public Function Remove (
item As IRpcMethodParameter
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.IRpcMethodParameter
The object to remove from the ICollection.T..
Return Value
Type: Boolean
true if item was successfully removed from the ICollection.T.; otherwise, false. This method also returns false if item is not found in the original ICollection.T..
Implements
ICollection.T..Remove(T)
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


RpcMethodParameterCollection.RemoveAt Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] RpcMethodParameterCollection Class [image] RpcMethodParameterCollection Methods [image] RpcMethodParameterCollection.RemoveAt Method
RpcMethodParameterCollection.RemoveAt Method
Removes the IList.T. item at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void RemoveAt(
int index
)
VB
Public Sub RemoveAt (
index As Integer
)
Parameters
index
Type: System.Int32
The zero-based index of the item to remove.
Implements
IList.T..RemoveAt(Int32)
Reference
RpcMethodParameterCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class
SubItemCollection Class
Class SubItemCollection.
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.SubItemCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SubItemCollection : IList<ITcAdsSubItem>,
ICollection<ITcAdsSubItem>, IEnumerable<ITcAdsSubItem>, IEnumerable
VB
Public Class SubItemCollection
Implements IList(Of ITcAdsSubItem), ICollection(Of ITcAdsSubItem),
IEnumerable(Of ITcAdsSubItem), IEnumerable
The SubItemCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item | Gets or sets the element at the specified index.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Gets a read only version of this SubItemCollection.
Clear | Removes all items from the ICollection.T..
Contains | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
SubItemCollection Properties
•
SubItemCollection Methods


SubItemCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Properties
SubItemCollection Properties
The SubItemCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item | Gets or sets the element at the specified index.
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
SubItemCollection.Count Property
•
SubItemCollection.IsReadOnly Property
•
SubItemCollection.Item Property


SubItemCollection.Count Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Properties [image] SubItemCollection.Count Property
SubItemCollection.Count Property
Gets the number of elements contained in the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Count { get; }
VB
Public ReadOnly Property Count As Integer
Get
Property Value
Type: Int32
The count.
Implements
ICollection.T..Count
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection.IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Properties [image] SubItemCollection.IsReadOnly Property
SubItemCollection.IsReadOnly Property
Gets a value indicating whether the ICollection.T. is read-only.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if this instance is read only; otherwise, false.
Implements
ICollection.T..IsReadOnly
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Properties [image] SubItemCollection.Item Property
SubItemCollection.Item Property
Gets or sets the element at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ITcAdsSubItem this[
int index
] { get; set; }
VB
Public Default Property Item (
index As Integer
) As ITcAdsSubItem
Get
Set
Parameters
index
Type: System.Int32
The index.
Return Value
Type: ITcAdsSubItem
ITcAdsSubItem.
Implements
IList.T..Item.Int32.
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Methods
SubItemCollection Methods
The SubItemCollection type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Gets a read only version of this SubItemCollection.
Clear | Removes all items from the ICollection.T..
Contains | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
SubItemCollection.Add Method
•
SubItemCollection.AsReadOnly Method
•
SubItemCollection.Clear Method
•
SubItemCollection.Contains Method
•
SubItemCollection.CopyTo Method
•
SubItemCollection.GetEnumerator Method
•
SubItemCollection.IndexOf Method
•
SubItemCollection.Insert Method
•
SubItemCollection.Remove Method
•
SubItemCollection.RemoveAt Method


SubItemCollection.Add Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Methods [image] SubItemCollection.Add Method
SubItemCollection.Add Method
Adds an item to the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Add(
ITcAdsSubItem item
)
VB
Public Sub Add (
item As ITcAdsSubItem
)
Parameters
item
Type: TwinCAT.Ads.ITcAdsSubItem
The object to add to the ICollection.T..
Implements
ICollection.T..Add(T)
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection.AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Methods [image] SubItemCollection.AsReadOnly Method
SubItemCollection.AsReadOnly Method
Gets a read only version of this SubItemCollection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySubItemCollection AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlySubItemCollection
Field Value
Type: ReadOnlySubItemCollection
As read only.
Return Value
Type: ReadOnlySubItemCollection
ReadOnlySubItemCollection.
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection.Clear Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Methods [image] SubItemCollection.Clear Method
SubItemCollection.Clear Method
Removes all items from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Clear()
VB
Public Sub Clear
Implements
ICollection.T..Clear.
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection.Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Methods [image] SubItemCollection.Contains Method
SubItemCollection.Contains Method
Determines whether the ICollection.T. contains a specific value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
ITcAdsSubItem item
)
VB
Public Function Contains (
item As ITcAdsSubItem
) As Boolean
Parameters
item
Type: TwinCAT.Ads.ITcAdsSubItem
The object to locate in the ICollection.T..
Return Value
Type: Boolean
true if item is found in the ICollection.T.; otherwise, false.
Implements
ICollection.T..Contains(T)
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection.CopyTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Methods [image] SubItemCollection.CopyTo Method
SubItemCollection.CopyTo Method
Copies to.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void CopyTo(
ITcAdsSubItem[] array,
int arrayIndex
)
VB
Public Sub CopyTo (
array As ITcAdsSubItem(),
arrayIndex As Integer
)
Parameters
array | Type: .TwinCAT.Ads.ITcAdsSubItem. The array.
arrayIndex | Type: System.Int32 Index of the array.
Implements
ICollection.T..CopyTo(.T., Int32)
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection.GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Methods [image] SubItemCollection.GetEnumerator Method
SubItemCollection.GetEnumerator Method
Returns an enumerator that iterates through the collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<ITcAdsSubItem> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of ITcAdsSubItem)
Return Value
Type: IEnumerator.ITcAdsSubItem.
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection.IndexOf Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Methods [image] SubItemCollection.IndexOf Method
SubItemCollection.IndexOf Method
Determines the index of a specific item in the IList.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int IndexOf(
ITcAdsSubItem item
)
VB
Public Function IndexOf (
item As ITcAdsSubItem
) As Integer
Parameters
item
Type: TwinCAT.Ads.ITcAdsSubItem
The object to locate in the IList.T..
Return Value
Type: Int32
The index of item if found in the list; otherwise, -1.
Implements
IList.T..IndexOf(T)
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection.Insert Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Methods [image] SubItemCollection.Insert Method
SubItemCollection.Insert Method
Inserts an item to the IList.T. at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Insert(
int index,
ITcAdsSubItem item
)
VB
Public Sub Insert (
index As Integer,
item As ITcAdsSubItem
)
Parameters
index | Type: System.Int32 The zero-based index at which item should be inserted.
item | Type: TwinCAT.Ads.ITcAdsSubItem The object to insert into the IList.T..
Implements
IList.T..Insert(Int32, T)
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection.Remove Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Methods [image] SubItemCollection.Remove Method
SubItemCollection.Remove Method
Removes the first occurrence of a specific object from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Remove(
ITcAdsSubItem item
)
VB
Public Function Remove (
item As ITcAdsSubItem
) As Boolean
Parameters
item
Type: TwinCAT.Ads.ITcAdsSubItem
The object to remove from the ICollection.T..
Return Value
Type: Boolean
true if item was successfully removed from the ICollection.T.; otherwise, false. This method also returns false if item is not found in the original ICollection.T..
Implements
ICollection.T..Remove(T)
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SubItemCollection.RemoveAt Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SubItemCollection Class [image] SubItemCollection Methods [image] SubItemCollection.RemoveAt Method
SubItemCollection.RemoveAt Method
Removes the IList.T. item at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void RemoveAt(
int index
)
VB
Public Sub RemoveAt (
index As Integer
)
Parameters
index
Type: System.Int32
The zero-based index of the item to remove.
Implements
IList.T..RemoveAt(Int32)
Reference
SubItemCollection Class
TwinCAT.TypeSystem Namespace


SymbolAccessRights Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SymbolAccessRights Enumeration
SymbolAccessRights Enumeration
Enum specifying Access Rights to symbols
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[FlagsAttribute]
public enum SymbolAccessRights
VB
<FlagsAttribute>
Public Enumeration SymbolAccessRights
Members
Member name | Value | Description
None | 0 | None / Uninitialized
Read | 1 | Read-Access
Write | 2 | Write-Access
MethodInvoke | 4 | Right to Invoke Methods / RPC Invoke
ReadWrite | 3 | Read / Write Access
All | 7 | Full Access
Reference
TwinCAT.TypeSystem Namespace


SymbolCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SymbolCollection Class
SymbolCollection Class
Interface represents a collection of ISymbol objects.
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.Generic.InstanceCollection.ISymbol.
TwinCAT.TypeSystem.Generic.SymbolCollection.ISymbol.
TwinCAT.TypeSystem.SymbolCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SymbolCollection : SymbolCollection<ISymbol>,
ISymbolCollection, ISymbolCollection<ISymbol>, IInstanceCollection<ISymbol>,
IList<ISymbol>, ICollection<ISymbol>, IEnumerable<ISymbol>,
IEnumerable
VB
Public Class SymbolCollection
Inherits SymbolCollection(Of ISymbol)
Implements ISymbolCollection, ISymbolCollection(Of ISymbol),
IInstanceCollection(Of ISymbol), IList(Of ISymbol), ICollection(Of ISymbol),
IEnumerable(Of ISymbol), IEnumerable
The SymbolCollection type exposes the following members.
Properties
Name | Description
Count | Gets the collection count. (Inherited from InstanceCollection.T..)
IsReadOnly | Gets a value indicating whether this instance is read only. (Inherited from InstanceCollection.T..)
Item.Int32. | Gets or sets the IInstance at the specified index. (Inherited from InstanceCollection.T..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from InstanceCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from InstanceCollection.T..)
Methods
Name | Description
Add | Adds the specified item. (Inherited from InstanceCollection.T..)
AddRange | Adds the specified items to this collection. (Inherited from InstanceCollection.T..)
AsReadOnly | Returns a Read only version of this collection (shallow copy).
Clear | Clears this instance. (Inherited from InstanceCollection.T..)
Clone | Clones this instance.
Contains(String) | Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath (Inherited from InstanceCollection.T..)
Contains(T) | Determines whether this collection contains the specified IInstance (Inherited from InstanceCollection.T..)
ContainsName | Determines whether the specified instance name contains name. (Inherited from InstanceCollection.T..)
CopyTo | Copies this InstanceCollection.T. to the specified array. (Inherited from InstanceCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator. (Inherited from InstanceCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from InstanceCollection.T..)
GetInstanceByName | Gets the name of the instance by. (Inherited from InstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of the specified IInstance. (Inherited from InstanceCollection.T..)
Insert | Inserts the specified IInstance at the specified index. (Inherited from InstanceCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified item. (Inherited from InstanceCollection.T..)
RemoveAt | Removes the IInstance at the specified index. (Inherited from InstanceCollection.T..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the IInstance. of the specified path. (Inherited from InstanceCollection.T..)
TryGetInstanceByName | Tries to get Instnaces by name. (Inherited from InstanceCollection.T..)
TryGetInstances | Try to get instances with predicate function (Inherited from SymbolCollection.T..)
Fields
Name | Description
_list | The _list (Inherited from InstanceCollection.T..)
_pathDict | The _path dictionary (Inherited from InstanceCollection.T..)
mode | The mode this InstanceCollection.T. is working in. (Inherited from InstanceCollection.T..)
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
SymbolCollection Properties
•
SymbolCollection Methods
•
SymbolCollection Fields


SymbolCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SymbolCollection Class [image] SymbolCollection Properties
SymbolCollection Properties
The SymbolCollection type exposes the following members.
Properties
Name | Description
Count | Gets the collection count. (Inherited from InstanceCollection.T..)
IsReadOnly | Gets a value indicating whether this instance is read only. (Inherited from InstanceCollection.T..)
Item.Int32. | Gets or sets the IInstance at the specified index. (Inherited from InstanceCollection.T..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from InstanceCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from InstanceCollection.T..)
Reference
SymbolCollection Class
TwinCAT.TypeSystem Namespace


SymbolCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SymbolCollection Class [image] SymbolCollection Methods
SymbolCollection Methods
The SymbolCollection type exposes the following members.
Methods
Name | Description
Add | Adds the specified item. (Inherited from InstanceCollection.T..)
AddRange | Adds the specified items to this collection. (Inherited from InstanceCollection.T..)
AsReadOnly | Returns a Read only version of this collection (shallow copy).
Clear | Clears this instance. (Inherited from InstanceCollection.T..)
Clone | Clones this instance.
Contains(String) | Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath (Inherited from InstanceCollection.T..)
Contains(T) | Determines whether this collection contains the specified IInstance (Inherited from InstanceCollection.T..)
ContainsName | Determines whether the specified instance name contains name. (Inherited from InstanceCollection.T..)
CopyTo | Copies this InstanceCollection.T. to the specified array. (Inherited from InstanceCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator. (Inherited from InstanceCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from InstanceCollection.T..)
GetInstanceByName | Gets the name of the instance by. (Inherited from InstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of the specified IInstance. (Inherited from InstanceCollection.T..)
Insert | Inserts the specified IInstance at the specified index. (Inherited from InstanceCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified item. (Inherited from InstanceCollection.T..)
RemoveAt | Removes the IInstance at the specified index. (Inherited from InstanceCollection.T..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the IInstance. of the specified path. (Inherited from InstanceCollection.T..)
TryGetInstanceByName | Tries to get Instnaces by name. (Inherited from InstanceCollection.T..)
TryGetInstances | Try to get instances with predicate function (Inherited from SymbolCollection.T..)
Reference
SymbolCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
SymbolCollection.AsReadOnly Method
•
SymbolCollection.Clone Method


SymbolCollection.AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SymbolCollection Class [image] SymbolCollection Methods [image] SymbolCollection.AsReadOnly Method
SymbolCollection.AsReadOnly Method
Returns a Read only version of this collection (shallow copy).
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySymbolCollection AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlySymbolCollection
Return Value
Type: ReadOnlySymbolCollection
Read only collection.
Reference
SymbolCollection Class
TwinCAT.TypeSystem Namespace


SymbolCollection.Clone Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SymbolCollection Class [image] SymbolCollection Methods [image] SymbolCollection.Clone Method
SymbolCollection.Clone Method
Clones this instance.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolCollection Clone()
VB
Public Function Clone As SymbolCollection
Return Value
Type: SymbolCollection
Cloned SymbolCollection.
Reference
SymbolCollection Class
TwinCAT.TypeSystem Namespace


SymbolCollection Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] SymbolCollection Class [image] SymbolCollection Fields
SymbolCollection Fields
The SymbolCollection type exposes the following members.
Fields
Name | Description
_list | The _list (Inherited from InstanceCollection.T..)
_pathDict | The _path dictionary (Inherited from InstanceCollection.T..)
mode | The mode this InstanceCollection.T. is working in. (Inherited from InstanceCollection.T..)
Reference
SymbolCollection Class
TwinCAT.TypeSystem Namespace


TypeAttribute Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttribute Class
TypeAttribute Class
ADS Attribute
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.TypeAttribute
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class TypeAttribute : ITypeAttribute
VB
Public Class TypeAttribute
Implements ITypeAttribute
The TypeAttribute type exposes the following members.
Properties
Name | Description
Name | Name of the Attribute
Value | Gets the value of the attribute
Methods
Name | Description
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttribute Properties
•
TypeAttribute Methods
•
TypeAttribute Operators


TypeAttribute Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttribute Class [image] TypeAttribute Properties
TypeAttribute Properties
The TypeAttribute type exposes the following members.
Properties
Name | Description
Name | Name of the Attribute
Value | Gets the value of the attribute
Reference
TypeAttribute Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttribute.Name Property
•
TypeAttribute.Value Property


TypeAttribute.Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttribute Class [image] TypeAttribute Properties [image] TypeAttribute.Name Property
TypeAttribute.Name Property
Name of the Attribute
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Name { get; }
VB
Public ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Implements
ITypeAttribute.Name
Reference
TypeAttribute Class
TwinCAT.TypeSystem Namespace


TypeAttribute.Value Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttribute Class [image] TypeAttribute Properties [image] TypeAttribute.Value Property
TypeAttribute.Value Property
Gets the value of the attribute
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string Value { get; }
VB
Public ReadOnly Property Value As String
Get
Property Value
Type: String
The value.
Implements
ITypeAttribute.Value
Reference
TypeAttribute Class
TwinCAT.TypeSystem Namespace


TypeAttribute Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttribute Class [image] TypeAttribute Methods
TypeAttribute Methods
The TypeAttribute type exposes the following members.
Methods
Name | Description
Equals | Equals (Overrides Object.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the HashCode of the Address (Overrides Object.GetHashCode..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
TypeAttribute Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttribute.Equals Method
•
TypeAttribute.GetHashCode Method


TypeAttribute.Equals Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttribute Class [image] TypeAttribute Methods [image] TypeAttribute.Equals Method
TypeAttribute.Equals Method
Equals
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override bool Equals(
Object obj
)
VB
Public Overrides Function Equals (
obj As Object
) As Boolean
Parameters
obj
Type: System.Object
The object to compare with the current object.
Return Value
Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Reference
TypeAttribute Class
TwinCAT.TypeSystem Namespace


TypeAttribute.GetHashCode Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttribute Class [image] TypeAttribute Methods [image] TypeAttribute.GetHashCode Method
TypeAttribute.GetHashCode Method
Gets the HashCode of the Address
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public override int GetHashCode()
VB
Public Overrides Function GetHashCode As Integer
Return Value
Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
Reference
TypeAttribute Class
TwinCAT.TypeSystem Namespace


TypeAttribute Operators

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttribute Class [image] TypeAttribute Operators
TypeAttribute Operators
The TypeAttribute type exposes the following members.
Operators
Name | Description
Equality | Operator==
Inequality | Implements the != operator.
Reference
TypeAttribute Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttribute.Equality Operator
•
TypeAttribute.Inequality Operator


TypeAttribute.Equality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttribute Class [image] TypeAttribute Operators [image] TypeAttribute.Equality Operator
TypeAttribute.Equality Operator
Operator==
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator ==(
TypeAttribute o1,
TypeAttribute o2
)
VB
Public Shared Operator = (
o1 As TypeAttribute,
o2 As TypeAttribute
) As Boolean
Parameters
o1 | Type: TwinCAT.TypeSystem.TypeAttribute The o1.
o2 | Type: TwinCAT.TypeSystem.TypeAttribute The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
TypeAttribute Class
TwinCAT.TypeSystem Namespace


TypeAttribute.Inequality Operator

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttribute Class [image] TypeAttribute Operators [image] TypeAttribute.Inequality Operator
TypeAttribute.Inequality Operator
Implements the != operator.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public static bool operator !=(
TypeAttribute o1,
TypeAttribute o2
)
VB
Public Shared Operator <> (
o1 As TypeAttribute,
o2 As TypeAttribute
) As Boolean
Parameters
o1 | Type: TwinCAT.TypeSystem.TypeAttribute The o1.
o2 | Type: TwinCAT.TypeSystem.TypeAttribute The o2.
Return Value
Type: Boolean
The result of the operator.
Reference
TypeAttribute Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class
TypeAttributeCollection Class
Collection of AdsAttributes
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.TypeAttributeCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class TypeAttributeCollection : IList<ITypeAttribute>,
ICollection<ITypeAttribute>, IEnumerable<ITypeAttribute>, IEnumerable
VB
Public Class TypeAttributeCollection
Implements IList(Of ITypeAttribute), ICollection(Of ITypeAttribute),
IEnumerable(Of ITypeAttribute), IEnumerable
The TypeAttributeCollection type exposes the following members.
Constructors
Name | Description
TypeAttributeCollection. | Initializes a new instance of the TypeAttributeCollection class.
TypeAttributeCollection(IEnumerable.ITypeAttribute.) | Initializes a new instance of the TypeAttributeCollection class.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets the String with the specified name.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Gets a read only version of this TypeAttributeCollection
Clear | Removes all items from the ICollection.T..
Contains(String) | Determines whether this TypeAttributeCollection contains the ITypeAttribute with the specified name.
Contains(ITypeAttribute) | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove(String) | Removes the specified ITypeAttribute from the TypeAttributeCollection
Remove(ITypeAttribute) | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetAttribute | Tries to get the specified ITypeAttribute
TryGetValue | Tries to get the specified Attribute value.
Fields
Name | Description
list | List of Attributes
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttributeCollection Constructor
•
TypeAttributeCollection Properties
•
TypeAttributeCollection Methods
•
TypeAttributeCollection Fields


TypeAttributeCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Constructor
TypeAttributeCollection Constructor
Overload List
Name | Description
TypeAttributeCollection. | Initializes a new instance of the TypeAttributeCollection class.
TypeAttributeCollection(IEnumerable.ITypeAttribute.) | Initializes a new instance of the TypeAttributeCollection class.
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttributeCollection Constructor
•
TypeAttributeCollection Constructor (IEnumerable.ITypeAttribute.)


TypeAttributeCollection Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Constructor [image] TypeAttributeCollection Constructor
TypeAttributeCollection Constructor
Initializes a new instance of the TypeAttributeCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TypeAttributeCollection()
VB
Public Sub New
Reference
TypeAttributeCollection Class
TypeAttributeCollection Overload
TwinCAT.TypeSystem Namespace


TypeAttributeCollection Constructor (IEnumerable.ITypeAttribute.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Constructor [image] TypeAttributeCollection Constructor (IEnumerable.ITypeAttribute.)
TypeAttributeCollection Constructor (IEnumerable.ITypeAttribute.)
Initializes a new instance of the TypeAttributeCollection class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public TypeAttributeCollection(
IEnumerable<ITypeAttribute> coll
)
VB
Public Sub New (
coll As IEnumerable(Of ITypeAttribute)
)
Parameters
coll
Type: System.Collections.Generic.IEnumerable.ITypeAttribute.
The coll.
Reference
TypeAttributeCollection Class
TypeAttributeCollection Overload
TwinCAT.TypeSystem Namespace


TypeAttributeCollection Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Properties
TypeAttributeCollection Properties
The TypeAttributeCollection type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets the String with the specified name.
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttributeCollection.Count Property
•
TypeAttributeCollection.IsReadOnly Property
•
TypeAttributeCollection.Item Property


TypeAttributeCollection.Count Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Properties [image] TypeAttributeCollection.Count Property
TypeAttributeCollection.Count Property
Gets the number of elements contained in the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Count { get; }
VB
Public ReadOnly Property Count As Integer
Get
Property Value
Type: Int32
The count.
Implements
ICollection.T..Count
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Properties [image] TypeAttributeCollection.IsReadOnly Property
TypeAttributeCollection.IsReadOnly Property
Gets a value indicating whether the ICollection.T. is read-only.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if this instance is read only; otherwise, false.
Implements
ICollection.T..IsReadOnly
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Properties [image] TypeAttributeCollection.Item Property
TypeAttributeCollection.Item Property
Overload List
Name | Description
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets the String with the specified name.
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttributeCollection.Item Property (Int32)
•
TypeAttributeCollection.Item Property (String)


TypeAttributeCollection.Item Property (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Properties [image] TypeAttributeCollection.Item Property [image] TypeAttributeCollection.Item Property (Int32)
TypeAttributeCollection.Item Property (Int32)
Gets or sets the element at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ITypeAttribute this[
int index
] { get; set; }
VB
Public Default Property Item (
index As Integer
) As ITypeAttribute
Get
Set
Parameters
index
Type: System.Int32
The index.
Return Value
Type: ITypeAttribute
AdsAttribute.
Implements
IList.T..Item.Int32.
Reference
TypeAttributeCollection Class
Item Overload
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Properties [image] TypeAttributeCollection.Item Property [image] TypeAttributeCollection.Item Property (String)
TypeAttributeCollection.Item Property (String)
Gets the String with the specified name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public string this[
string name
] { get; }
VB
Public ReadOnly Default Property Item (
name As String
) As String
Get
Parameters
name
Type: System.String
The name.
Return Value
Type: String
System.String.
Exceptions
Exception | Condition
KeyNotFoundException |
Reference
TypeAttributeCollection Class
Item Overload
TwinCAT.TypeSystem Namespace


TypeAttributeCollection Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods
TypeAttributeCollection Methods
The TypeAttributeCollection type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
AsReadOnly | Gets a read only version of this TypeAttributeCollection
Clear | Removes all items from the ICollection.T..
Contains(String) | Determines whether this TypeAttributeCollection contains the ITypeAttribute with the specified name.
Contains(ITypeAttribute) | Determines whether the ICollection.T. contains a specific value.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove(String) | Removes the specified ITypeAttribute from the TypeAttributeCollection
Remove(ITypeAttribute) | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetAttribute | Tries to get the specified ITypeAttribute
TryGetValue | Tries to get the specified Attribute value.
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttributeCollection.Add Method
•
TypeAttributeCollection.AsReadOnly Method
•
TypeAttributeCollection.Clear Method
•
TypeAttributeCollection.Contains Method
•
TypeAttributeCollection.CopyTo Method
•
TypeAttributeCollection.GetEnumerator Method
•
TypeAttributeCollection.IndexOf Method
•
TypeAttributeCollection.Insert Method
•
TypeAttributeCollection.Remove Method
•
TypeAttributeCollection.RemoveAt Method
•
TypeAttributeCollection.TryGetAttribute Method
•
TypeAttributeCollection.TryGetValue Method


TypeAttributeCollection.Add Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.Add Method
TypeAttributeCollection.Add Method
Adds an item to the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Add(
ITypeAttribute item
)
VB
Public Sub Add (
item As ITypeAttribute
)
Parameters
item
Type: TwinCAT.TypeSystem.ITypeAttribute
The object to add to the ICollection.T..
Implements
ICollection.T..Add(T)
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.AsReadOnly Method
TypeAttributeCollection.AsReadOnly Method
Gets a read only version of this TypeAttributeCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyTypeAttributeCollection AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlyTypeAttributeCollection
Field Value
Type: ReadOnlyTypeAttributeCollection
As read only.
Return Value
Type: ReadOnlyTypeAttributeCollection
ReadOnlyAttributeCollection.
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.Clear Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.Clear Method
TypeAttributeCollection.Clear Method
Removes all items from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Clear()
VB
Public Sub Clear
Implements
ICollection.T..Clear.
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.Contains Method
TypeAttributeCollection.Contains Method
Overload List
Name | Description
Contains(String) | Determines whether this TypeAttributeCollection contains the ITypeAttribute with the specified name.
Contains(ITypeAttribute) | Determines whether the ICollection.T. contains a specific value.
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttributeCollection.Contains Method (String)
•
TypeAttributeCollection.Contains Method (ITypeAttribute)


TypeAttributeCollection.Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.Contains Method [image] TypeAttributeCollection.Contains Method (String)
TypeAttributeCollection.Contains Method (String)
Determines whether this TypeAttributeCollection contains the ITypeAttribute with the specified name.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string name
)
VB
Public Function Contains (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if [contains] [the specified name]; otherwise, false.
Reference
TypeAttributeCollection Class
Contains Overload
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.Contains Method (ITypeAttribute)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.Contains Method [image] TypeAttributeCollection.Contains Method (ITypeAttribute)
TypeAttributeCollection.Contains Method (ITypeAttribute)
Determines whether the ICollection.T. contains a specific value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
ITypeAttribute item
)
VB
Public Function Contains (
item As ITypeAttribute
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.ITypeAttribute
The object to locate in the ICollection.T..
Return Value
Type: Boolean
true if item is found in the ICollection.T.; otherwise, false.
Implements
ICollection.T..Contains(T)
Reference
TypeAttributeCollection Class
Contains Overload
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.CopyTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.CopyTo Method
TypeAttributeCollection.CopyTo Method
Copies to.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void CopyTo(
ITypeAttribute[] array,
int arrayIndex
)
VB
Public Sub CopyTo (
array As ITypeAttribute(),
arrayIndex As Integer
)
Parameters
array | Type: .TwinCAT.TypeSystem.ITypeAttribute. The array.
arrayIndex | Type: System.Int32 Index of the array.
Implements
ICollection.T..CopyTo(.T., Int32)
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.GetEnumerator Method
TypeAttributeCollection.GetEnumerator Method
Returns an enumerator that iterates through the collection.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<ITypeAttribute> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of ITypeAttribute)
Return Value
Type: IEnumerator.ITypeAttribute.
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.IndexOf Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.IndexOf Method
TypeAttributeCollection.IndexOf Method
Determines the index of a specific item in the IList.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int IndexOf(
ITypeAttribute item
)
VB
Public Function IndexOf (
item As ITypeAttribute
) As Integer
Parameters
item
Type: TwinCAT.TypeSystem.ITypeAttribute
The object to locate in the IList.T..
Return Value
Type: Int32
The index of item if found in the list; otherwise, -1.
Implements
IList.T..IndexOf(T)
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.Insert Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.Insert Method
TypeAttributeCollection.Insert Method
Inserts an item to the IList.T. at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Insert(
int index,
ITypeAttribute item
)
VB
Public Sub Insert (
index As Integer,
item As ITypeAttribute
)
Parameters
index | Type: System.Int32 The zero-based index at which item should be inserted.
item | Type: TwinCAT.TypeSystem.ITypeAttribute The object to insert into the IList.T..
Implements
IList.T..Insert(Int32, T)
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.Remove Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.Remove Method
TypeAttributeCollection.Remove Method
Overload List
Name | Description
Remove(String) | Removes the specified ITypeAttribute from the TypeAttributeCollection
Remove(ITypeAttribute) | Removes the first occurrence of a specific object from the ICollection.T..
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttributeCollection.Remove Method (String)
•
TypeAttributeCollection.Remove Method (ITypeAttribute)


TypeAttributeCollection.Remove Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.Remove Method [image] TypeAttributeCollection.Remove Method (String)
TypeAttributeCollection.Remove Method (String)
Removes the specified ITypeAttribute from the TypeAttributeCollection
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Remove(
string name
)
VB
Public Function Remove (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
TypeAttributeCollection Class
Remove Overload
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.Remove Method (ITypeAttribute)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.Remove Method [image] TypeAttributeCollection.Remove Method (ITypeAttribute)
TypeAttributeCollection.Remove Method (ITypeAttribute)
Removes the first occurrence of a specific object from the ICollection.T..
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Remove(
ITypeAttribute item
)
VB
Public Function Remove (
item As ITypeAttribute
) As Boolean
Parameters
item
Type: TwinCAT.TypeSystem.ITypeAttribute
The object to remove from the ICollection.T..
Return Value
Type: Boolean
true if item was successfully removed from the ICollection.T.; otherwise, false. This method also returns false if item is not found in the original ICollection.T..
Implements
ICollection.T..Remove(T)
Reference
TypeAttributeCollection Class
Remove Overload
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.RemoveAt Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.RemoveAt Method
TypeAttributeCollection.RemoveAt Method
Removes the IList.T. item at the specified index.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void RemoveAt(
int index
)
VB
Public Sub RemoveAt (
index As Integer
)
Parameters
index
Type: System.Int32
The zero-based index of the item to remove.
Implements
IList.T..RemoveAt(Int32)
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.TryGetAttribute Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.TryGetAttribute Method
TypeAttributeCollection.TryGetAttribute Method
Tries to get the specified ITypeAttribute
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetAttribute(
string name,
out ITypeAttribute att
)
VB
Public Function TryGetAttribute (
name As String,
<OutAttribute> ByRef att As ITypeAttribute
) As Boolean
Parameters
name | Type: System.String The name of the ITypeAttribute.
att | Type: TwinCAT.TypeSystem.ITypeAttribute. The att.
Return Value
Type: Boolean
true if found, false otherwise.
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection.TryGetValue Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Methods [image] TypeAttributeCollection.TryGetValue Method
TypeAttributeCollection.TryGetValue Method
Tries to get the specified Attribute value.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetValue(
string name,
out string value
)
VB
Public Function TryGetValue (
name As String,
<OutAttribute> ByRef value As String
) As Boolean
Parameters
name | Type: System.String The name.
value | Type: System.String. The value.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


TypeAttributeCollection Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Fields
TypeAttributeCollection Fields
The TypeAttributeCollection type exposes the following members.
Fields
Name | Description
list | List of Attributes
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
TypeAttributeCollection.list Field


TypeAttributeCollection.list Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] TypeAttributeCollection Class [image] TypeAttributeCollection Fields [image] TypeAttributeCollection.list Field
TypeAttributeCollection.list Field
List of Attributes
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected List<ITypeAttribute> list
VB
Protected list As List(Of ITypeAttribute)
Field Value
Type: List.ITypeAttribute.
Reference
TypeAttributeCollection Class
TwinCAT.TypeSystem Namespace


ValueChangedArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ValueChangedArgs Class
ValueChangedArgs Class
Event args for the ValueChanged event.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.TypeSystem.ValueChangedBaseArgs
TwinCAT.TypeSystem.ValueChangedArgs
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ValueChangedArgs : ValueChangedBaseArgs
VB
Public Class ValueChangedArgs
Inherits ValueChangedBaseArgs
The ValueChangedArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
Symbol | Symbol that caused the event. (Inherited from ValueChangedBaseArgs.)
UtcLocalSystemTime | Notification Time stamp of the local system (user/desktop time) in UTC (Inherited from ValueChangedBaseArgs.)
UtcRtime | Notification Time stamp of the Real time System in UTC (Inherited from ValueChangedBaseArgs.)
Value | The new received Value
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ValueChangedArgs Methods
•
ValueChangedArgs Fields


ValueChangedArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ValueChangedArgs Class [image] ValueChangedArgs Methods
ValueChangedArgs Methods
The ValueChangedArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
ValueChangedArgs Class
TwinCAT.TypeSystem Namespace


ValueChangedArgs Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ValueChangedArgs Class [image] ValueChangedArgs Fields
ValueChangedArgs Fields
The ValueChangedArgs type exposes the following members.
Fields
Name | Description
Symbol | Symbol that caused the event. (Inherited from ValueChangedBaseArgs.)
UtcLocalSystemTime | Notification Time stamp of the local system (user/desktop time) in UTC (Inherited from ValueChangedBaseArgs.)
UtcRtime | Notification Time stamp of the Real time System in UTC (Inherited from ValueChangedBaseArgs.)
Value | The new received Value
Reference
ValueChangedArgs Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ValueChangedArgs.Value Field


ValueChangedArgs.Value Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ValueChangedArgs Class [image] ValueChangedArgs Fields [image] ValueChangedArgs.Value Field
ValueChangedArgs.Value Field
The new received Value
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly Object Value
VB
Public ReadOnly Value As Object
Field Value
Type: Object
Reference
ValueChangedArgs Class
TwinCAT.TypeSystem Namespace


ValueChangedBaseArgs Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ValueChangedBaseArgs Class
ValueChangedBaseArgs Class
Event args for the RawValueChanged event.
Inheritance Hierarchy
System.Object
System.EventArgs
TwinCAT.TypeSystem.ValueChangedBaseArgs
TwinCAT.TypeSystem.RawValueChangedArgs
TwinCAT.TypeSystem.ValueChangedArgs
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ValueChangedBaseArgs : EventArgs
VB
Public Class ValueChangedBaseArgs
Inherits EventArgs
The ValueChangedBaseArgs type exposes the following members.
Constructors
Name | Description
ValueChangedBaseArgs | Initializes a new instance of the RawValueChangedArgs class.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Fields
Name | Description
Symbol | Symbol that caused the event.
UtcLocalSystemTime | Notification Time stamp of the local system (user/desktop time) in UTC
UtcRtime | Notification Time stamp of the Real time System in UTC
Reference
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ValueChangedBaseArgs Constructor
•
ValueChangedBaseArgs Methods
•
ValueChangedBaseArgs Fields


ValueChangedBaseArgs Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ValueChangedBaseArgs Class [image] ValueChangedBaseArgs Constructor
ValueChangedBaseArgs Constructor
Initializes a new instance of the RawValueChangedArgs class.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected ValueChangedBaseArgs(
ISymbol symbol,
DateTime rtUtcTimeStamp,
DateTime localUtcTimeStamp
)
VB
Protected Sub New (
symbol As ISymbol,
rtUtcTimeStamp As DateTime,
localUtcTimeStamp As DateTime
)
Parameters
symbol | Type: TwinCAT.TypeSystem.ISymbol The symbol.
rtUtcTimeStamp | Type: System.DateTime The TwinCAT Real time time stamp (UTC)
localUtcTimeStamp | Type: System.DateTime The local user mode time stamp (UTC)
Reference
ValueChangedBaseArgs Class
TwinCAT.TypeSystem Namespace


ValueChangedBaseArgs Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ValueChangedBaseArgs Class [image] ValueChangedBaseArgs Methods
ValueChangedBaseArgs Methods
The ValueChangedBaseArgs type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
ValueChangedBaseArgs Class
TwinCAT.TypeSystem Namespace


ValueChangedBaseArgs Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ValueChangedBaseArgs Class [image] ValueChangedBaseArgs Fields
ValueChangedBaseArgs Fields
The ValueChangedBaseArgs type exposes the following members.
Fields
Name | Description
Symbol | Symbol that caused the event.
UtcLocalSystemTime | Notification Time stamp of the local system (user/desktop time) in UTC
UtcRtime | Notification Time stamp of the Real time System in UTC
Reference
ValueChangedBaseArgs Class
TwinCAT.TypeSystem Namespace
Weiterführende Informationen
•
ValueChangedBaseArgs.Symbol Field
•
ValueChangedBaseArgs.UtcLocalSystemTime Field
•
ValueChangedBaseArgs.UtcRtime Field


ValueChangedBaseArgs.Symbol Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ValueChangedBaseArgs Class [image] ValueChangedBaseArgs Fields [image] ValueChangedBaseArgs.Symbol Field
ValueChangedBaseArgs.Symbol Field
Symbol that caused the event.
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly ISymbol Symbol
VB
Public ReadOnly Symbol As ISymbol
Field Value
Type: ISymbol
Reference
ValueChangedBaseArgs Class
TwinCAT.TypeSystem Namespace


ValueChangedBaseArgs.UtcLocalSystemTime Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ValueChangedBaseArgs Class [image] ValueChangedBaseArgs Fields [image] ValueChangedBaseArgs.UtcLocalSystemTime Field
ValueChangedBaseArgs.UtcLocalSystemTime Field
Notification Time stamp of the local system (user/desktop time) in UTC
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly DateTime UtcLocalSystemTime
VB
Public ReadOnly UtcLocalSystemTime As DateTime
Field Value
Type: DateTime
Reference
ValueChangedBaseArgs Class
TwinCAT.TypeSystem Namespace


ValueChangedBaseArgs.UtcRtime Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem Namespace [image] ValueChangedBaseArgs Class [image] ValueChangedBaseArgs Fields [image] ValueChangedBaseArgs.UtcRtime Field
ValueChangedBaseArgs.UtcRtime Field
Notification Time stamp of the Real time System in UTC
Namespace: TwinCAT.TypeSystem
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public readonly DateTime UtcRtime
VB
Public ReadOnly UtcRtime As DateTime
Field Value
Type: DateTime
Reference
ValueChangedBaseArgs Class
TwinCAT.TypeSystem Namespace


TwinCAT.TypeSystem.Generic Namespace

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace
TwinCAT.TypeSystem.Generic Namespace
Namespace for the dynamic part of the common type system.
Classes
Class | Description
DataTypeCollection.T. | Data type collection
InstanceCollection.T. | Base class for IInstance object collections (abstract).
NamespaceCollection.N, T. | Generic class for Namespace collections
ReadOnlyDataTypeCollection.T. | ReadOnly DataType collection
ReadOnlyInstanceCollection.T. | ReadOnly Instance collection
ReadOnlyNamespaceCollection.N, T. | Read Only namespace collection
ReadOnlySymbolCollection.T. | Read only symbol collection.
SymbolCollection.T. | Interface represents a collection of ISymbol objects.
SymbolIterator.T. | Symbol iterator object
Interfaces
Interface | Description
IDataTypeContainer.T. | Data Type container interface
IInstanceCollection.T. | Generic InstanceColleciton interface.
INamespace.T. | Namespace interface
ISymbolCollection.T. | Interface ISymbolCollection
ISymbolProvider.N, T, S. | Symbol provider interface
Enumerations
Enumeration | Description
InstanceCollectionMode | Enum InstanceCollectionMode
SymbolIterationMask | Mask Flagset to specify filters for SymbolIterator.T..
Weiterführende Informationen
•
DataTypeCollection.T. Class
•
IDataTypeContainer.T. Interface
•
IInstanceCollection.T. Interface
•
INamespace.T. Interface
•
InstanceCollection.T. Class
•
InstanceCollectionMode Enumeration
•
ISymbolCollection.T. Interface
•
ISymbolProvider.N, T, S. Interface
•
NamespaceCollection.N, T. Class
•
ReadOnlyDataTypeCollection.T. Class
•
ReadOnlyInstanceCollection.T. Class
•
ReadOnlyNamespaceCollection.N, T. Class
•
ReadOnlySymbolCollection.T. Class
•
SymbolCollection.T. Class
•
SymbolIterationMask Enumeration
•
SymbolIterator.T. Class


DataTypeCollection.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class
DataTypeCollection.T. Class
Data type collection
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.Generic.DataTypeCollection.T.
TwinCAT.TypeSystem.DataTypeCollection
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class DataTypeCollection<T> : IList<T>,
ICollection<T>, IEnumerable<T>, IEnumerable, IDataTypeContainer<T>
where T : IDataType
VB
Public Class DataTypeCollection(Of T As IDataType)
Implements IList(Of T), ICollection(Of T),
IEnumerable(Of T), IEnumerable, IDataTypeContainer(Of T)
Type Parameters
T
The DataTypeCollection.T. type exposes the following members.
Constructors
Name | Description
DataTypeCollection.T.. | Initializes a new instance of the DataTypeCollection class.
DataTypeCollection.T.(IEnumerable.T.) | Initializes a new instance of the DataTypeCollection.T. class.
Properties
Name | Description
Count | Gets the count of contained IDataTypes.
IsReadOnly | Gets a value indicating whether this instance is read only.
Item.Int32. | Gets or sets the IDataType at the specified index.
Item.String. | Gets the IDataType with the specified name.
Methods
Name | Description
Add | Adds the specified item to the collection.
AddRange | Adds a range of types
AsReadOnly | Converts the DataTypeCollection.T. into a ReadOnlyCollection.T.
Clear | Clears the collection.
Clone | Clones this instance.
Contains | Determines whether this DataTypeCollection contains the specified IDataType.
ContainsType | Determines whether the container contains the specified IDataType.
CopyTo | Copies the data types to the specified array, starting at the array index.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the Index of the specified IDataType.
Insert | Inserts an IDataType into the DataTypeCollection.
LookupType | Determines the specified IDataType
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified IDataType.
RemoveAt | Removes the IDataType object at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetType | Tries to get the specified IDataType from the IDataTypeContainer.T..
Fields
Name | Description
list | Internal list of data types
nameDict | Dictionary (Type Name --> DataType)
readOnly | Indicates that the DataTypeCollection.T. is readonly
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
DataTypeCollection.T. Constructor
•
DataTypeCollection.T. Properties
•
DataTypeCollection.T. Methods
•
DataTypeCollection.T. Fields


DataTypeCollection.T. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Constructor
DataTypeCollection.T. Constructor
Overload List
Name | Description
DataTypeCollection.T.. | Initializes a new instance of the DataTypeCollection class.
DataTypeCollection.T.(IEnumerable.T.) | Initializes a new instance of the DataTypeCollection.T. class.
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
DataTypeCollection.T. Constructor
•
DataTypeCollection.T. Constructor (IEnumerable.T.)


DataTypeCollection.T. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Constructor [image] DataTypeCollection.T. Constructor
DataTypeCollection.T. Constructor
Initializes a new instance of the DataTypeCollection class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeCollection()
VB
Public Sub New
Reference
DataTypeCollection.T. Class
DataTypeCollection.T. Overload
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T. Constructor (IEnumerable.T.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Constructor [image] DataTypeCollection.T. Constructor (IEnumerable.T.)
DataTypeCollection.T. Constructor (IEnumerable.T.)
Initializes a new instance of the DataTypeCollection.T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeCollection(
IEnumerable<T> types
)
VB
Public Sub New (
types As IEnumerable(Of T)
)
Parameters
types
Type: System.Collections.Generic.IEnumerable.T.
The types.
Reference
DataTypeCollection.T. Class
DataTypeCollection.T. Overload
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Properties
DataTypeCollection.T. Properties
The DataTypeCollection.T. generic type exposes the following members.
Properties
Name | Description
Count | Gets the count of contained IDataTypes.
IsReadOnly | Gets a value indicating whether this instance is read only.
Item.Int32. | Gets or sets the IDataType at the specified index.
Item.String. | Gets the IDataType with the specified name.
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
DataTypeCollection.T..Count Property
•
DataTypeCollection.T..IsReadOnly Property
•
DataTypeCollection.T..Item Property


DataTypeCollection.T..Count Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Properties [image] DataTypeCollection.T..Count Property
DataTypeCollection.T..Count Property
Gets the count of contained IDataTypes.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Count { get; }
VB
Public ReadOnly Property Count As Integer
Get
Property Value
Type: Int32
The count.
Implements
ICollection.T..Count
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Properties [image] DataTypeCollection.T..IsReadOnly Property
DataTypeCollection.T..IsReadOnly Property
Gets a value indicating whether this instance is read only.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if this instance is read only; otherwise, false.
Implements
ICollection.T..IsReadOnly
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Properties [image] DataTypeCollection.T..Item Property
DataTypeCollection.T..Item Property
Overload List
Name | Description
Item.Int32. | Gets or sets the IDataType at the specified index.
Item.String. | Gets the IDataType with the specified name.
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
DataTypeCollection.T..Item Property (Int32)
•
DataTypeCollection.T..Item Property (String)


DataTypeCollection.T..Item Property (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Properties [image] DataTypeCollection.T..Item Property [image] DataTypeCollection.T..Item Property (Int32)
DataTypeCollection.T..Item Property (Int32)
Gets or sets the IDataType at the specified index.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T this[
int index
] { get; set; }
VB
Public Default Property Item (
index As Integer
) As T
Get
Set
Parameters
index
Type: System.Int32
The index.
Return Value
Type: T
T.
Implements
IList.T..Item.Int32.
Exceptions
Exception | Condition
NotImplementedException |
Reference
DataTypeCollection.T. Class
Item Overload
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Properties [image] DataTypeCollection.T..Item Property [image] DataTypeCollection.T..Item Property (String)
DataTypeCollection.T..Item Property (String)
Gets the IDataType with the specified name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T this[
string name
] { get; }
VB
Public ReadOnly Default Property Item (
name As String
) As T
Get
Parameters
name
Type: System.String
The name.
Return Value
Type: T
T.
Implements
IDataTypeContainer.T..Item.String.
Reference
DataTypeCollection.T. Class
Item Overload
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods
DataTypeCollection.T. Methods
The DataTypeCollection.T. generic type exposes the following members.
Methods
Name | Description
Add | Adds the specified item to the collection.
AddRange | Adds a range of types
AsReadOnly | Converts the DataTypeCollection.T. into a ReadOnlyCollection.T.
Clear | Clears the collection.
Clone | Clones this instance.
Contains | Determines whether this DataTypeCollection contains the specified IDataType.
ContainsType | Determines whether the container contains the specified IDataType.
CopyTo | Copies the data types to the specified array, starting at the array index.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the Index of the specified IDataType.
Insert | Inserts an IDataType into the DataTypeCollection.
LookupType | Determines the specified IDataType
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified IDataType.
RemoveAt | Removes the IDataType object at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetType | Tries to get the specified IDataType from the IDataTypeContainer.T..
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
DataTypeCollection.T..Add Method
•
DataTypeCollection.T..AddRange Method
•
DataTypeCollection.T..AsReadOnly Method
•
DataTypeCollection.T..Clear Method
•
DataTypeCollection.T..Clone Method
•
DataTypeCollection.T..Contains Method
•
DataTypeCollection.T..ContainsType Method
•
DataTypeCollection.T..CopyTo Method
•
DataTypeCollection.T..GetEnumerator Method
•
DataTypeCollection.T..IndexOf Method
•
DataTypeCollection.T..Insert Method
•
DataTypeCollection.T..LookupType Method
•
DataTypeCollection.T..Remove Method
•
DataTypeCollection.T..RemoveAt Method
•
DataTypeCollection.T..TryGetType Method


DataTypeCollection.T..Add Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..Add Method
DataTypeCollection.T..Add Method
Adds the specified item to the collection.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Add(
T item
)
VB
Public Sub Add (
item As T
)
Parameters
item
Type: T
The item.
Implements
ICollection.T..Add(T)
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..AddRange Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..AddRange Method
DataTypeCollection.T..AddRange Method
Adds a range of types
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void AddRange(
IEnumerable<T> types
)
VB
Public Sub AddRange (
types As IEnumerable(Of T)
)
Parameters
types
Type: System.Collections.Generic.IEnumerable.T.
The types.
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..AsReadOnly Method
DataTypeCollection.T..AsReadOnly Method
Converts the DataTypeCollection.T. into a ReadOnlyCollection.T.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyDataTypeCollection<T> AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlyDataTypeCollection(Of T)
Return Value
Type: ReadOnlyDataTypeCollection.T.
ReadOnlyDataTypeCollection<T>.
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..Clear Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..Clear Method
DataTypeCollection.T..Clear Method
Clears the collection.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Clear()
VB
Public Sub Clear
Implements
ICollection.T..Clear.
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..Clone Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..Clone Method
DataTypeCollection.T..Clone Method
Clones this instance.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public DataTypeCollection<T> Clone()
VB
Public Function Clone As DataTypeCollection(Of T)
Return Value
Type: DataTypeCollection.T.
DataTypeCollection<T>.
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..Contains Method
DataTypeCollection.T..Contains Method
Determines whether this DataTypeCollection contains the specified IDataType.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
T item
)
VB
Public Function Contains (
item As T
) As Boolean
Parameters
item
Type: T
The item.
Return Value
Type: Boolean
true if [contains] [the specified item]; otherwise, false.
Implements
ICollection.T..Contains(T)
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..ContainsType Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..ContainsType Method
DataTypeCollection.T..ContainsType Method
Determines whether the container contains the specified IDataType.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool ContainsType(
string name
)
VB
Public Function ContainsType (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if contained; otherwise, false.
Implements
IDataTypeContainer.T..ContainsType(String)
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..CopyTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..CopyTo Method
DataTypeCollection.T..CopyTo Method
Copies the data types to the specified array, starting at the array index.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void CopyTo(
T[] array,
int arrayIndex
)
VB
Public Sub CopyTo (
array As T(),
arrayIndex As Integer
)
Parameters
array | Type: .T. The array.
arrayIndex | Type: System.Int32 Index of the array.
Implements
ICollection.T..CopyTo(.T., Int32)
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..GetEnumerator Method
DataTypeCollection.T..GetEnumerator Method
Gets the enumerator.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<T> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of T)
Return Value
Type: IEnumerator.T.
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..IndexOf Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..IndexOf Method
DataTypeCollection.T..IndexOf Method
Determines the Index of the specified IDataType.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int IndexOf(
T item
)
VB
Public Function IndexOf (
item As T
) As Integer
Parameters
item
Type: T
The item.
Return Value
Type: Int32
The index of item if found in the list; otherwise, -1.
Implements
IList.T..IndexOf(T)
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..Insert Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..Insert Method
DataTypeCollection.T..Insert Method
Inserts an IDataType into the DataTypeCollection.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Insert(
int index,
T item
)
VB
Public Sub Insert (
index As Integer,
item As T
)
Parameters
index | Type: System.Int32 The index.
item | Type: T The item.
Implements
IList.T..Insert(Int32, T)
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..LookupType Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..LookupType Method
DataTypeCollection.T..LookupType Method
Determines the specified IDataType
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T LookupType(
string name
)
VB
Public Function LookupType (
name As String
) As T
Parameters
name
Type: System.String
The name.
Return Value
Type: T
The IDataType if found, otherwise NULL
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..Remove Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..Remove Method
DataTypeCollection.T..Remove Method
Removes the specified IDataType.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Remove(
T item
)
VB
Public Function Remove (
item As T
) As Boolean
Parameters
item
Type: T
The item.
Return Value
Type: Boolean
true if item was successfully removed from the ICollection.T.; otherwise, false. This method also returns false if item is not found in the original ICollection.T..
Implements
ICollection.T..Remove(T)
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..RemoveAt Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..RemoveAt Method
DataTypeCollection.T..RemoveAt Method
Removes the IDataType object at the specified index.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void RemoveAt(
int index
)
VB
Public Sub RemoveAt (
index As Integer
)
Parameters
index
Type: System.Int32
The index.
Implements
IList.T..RemoveAt(Int32)
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..TryGetType Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Methods [image] DataTypeCollection.T..TryGetType Method
DataTypeCollection.T..TryGetType Method
Tries to get the specified IDataType from the IDataTypeContainer.T..
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetType(
string name,
out T type
)
VB
Public Function TryGetType (
name As String,
<OutAttribute> ByRef type As T
) As Boolean
Parameters
name | Type: System.String The name.
type | Type: T. The type (Out parameter)
Return Value
Type: Boolean
true if found
Implements
IDataTypeContainer.T..TryGetType(String, T.)
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T. Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Fields
DataTypeCollection.T. Fields
The DataTypeCollection.T. generic type exposes the following members.
Fields
Name | Description
list | Internal list of data types
nameDict | Dictionary (Type Name --> DataType)
readOnly | Indicates that the DataTypeCollection.T. is readonly
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
DataTypeCollection.T..list Field
•
DataTypeCollection.T..nameDict Field
•
DataTypeCollection.T..readOnly Field


DataTypeCollection.T..list Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Fields [image] DataTypeCollection.T..list Field
DataTypeCollection.T..list Field
Internal list of data types
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected List<T> list
VB
Protected list As List(Of T)
Field Value
Type: List.T.
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..nameDict Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Fields [image] DataTypeCollection.T..nameDict Field
DataTypeCollection.T..nameDict Field
Dictionary (Type Name --> DataType)
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected Dictionary<string, T> nameDict
VB
Protected nameDict As Dictionary(Of String, T)
Field Value
Type: Dictionary.String, T.
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


DataTypeCollection.T..readOnly Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] DataTypeCollection.T. Class [image] DataTypeCollection.T. Fields [image] DataTypeCollection.T..readOnly Field
DataTypeCollection.T..readOnly Field
Indicates that the DataTypeCollection.T. is readonly
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected bool readOnly
VB
Protected readOnly As Boolean
Field Value
Type: Boolean
Reference
DataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


IDataTypeContainer.T. Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IDataTypeContainer.T. Interface
IDataTypeContainer.T. Interface
Data Type container interface
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IDataTypeContainer<T>
where T : IDataType
VB
Public Interface IDataTypeContainer(Of T As IDataType)
Type Parameters
T
Data Type type.
The IDataTypeContainer.T. type exposes the following members.
Properties
Name | Description
Item | Gets the IDataType with the specified name.
Methods
Name | Description
ContainsType | Determines whether the container contains the specified IDataType.
TryGetType | Tries to get the specified IDataType from the IDataTypeContainer.T..
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
IDataTypeContainer.T. Properties
•
IDataTypeContainer.T. Methods


IDataTypeContainer.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IDataTypeContainer.T. Interface [image] IDataTypeContainer.T. Properties
IDataTypeContainer.T. Properties
The IDataTypeContainer.T. generic type exposes the following members.
Properties
Name | Description
Item | Gets the IDataType with the specified name.
Reference
IDataTypeContainer.T. Interface
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
IDataTypeContainer.T..Item Property


IDataTypeContainer.T..Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IDataTypeContainer.T. Interface [image] IDataTypeContainer.T. Properties [image] IDataTypeContainer.T..Item Property
IDataTypeContainer.T..Item Property
Gets the IDataType with the specified name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
T this[
string name
] { get; }
VB
ReadOnly Default Property Item (
name As String
) As T
Get
Parameters
name
Type: System.String
The name.
Return Value
Type: T
T.
Reference
IDataTypeContainer.T. Interface
TwinCAT.TypeSystem.Generic Namespace


IDataTypeContainer.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IDataTypeContainer.T. Interface [image] IDataTypeContainer.T. Methods
IDataTypeContainer.T. Methods
The IDataTypeContainer.T. generic type exposes the following members.
Methods
Name | Description
ContainsType | Determines whether the container contains the specified IDataType.
TryGetType | Tries to get the specified IDataType from the IDataTypeContainer.T..
Reference
IDataTypeContainer.T. Interface
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
IDataTypeContainer.T..ContainsType Method
•
IDataTypeContainer.T..TryGetType Method


IDataTypeContainer.T..ContainsType Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IDataTypeContainer.T. Interface [image] IDataTypeContainer.T. Methods [image] IDataTypeContainer.T..ContainsType Method
IDataTypeContainer.T..ContainsType Method
Determines whether the container contains the specified IDataType.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool ContainsType(
string name
)
VB
Function ContainsType (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if contained; otherwise, false.
Reference
IDataTypeContainer.T. Interface
TwinCAT.TypeSystem.Generic Namespace


IDataTypeContainer.T..TryGetType Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IDataTypeContainer.T. Interface [image] IDataTypeContainer.T. Methods [image] IDataTypeContainer.T..TryGetType Method
IDataTypeContainer.T..TryGetType Method
Tries to get the specified IDataType from the IDataTypeContainer.T..
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TryGetType(
string name,
out T type
)
VB
Function TryGetType (
name As String,
<OutAttribute> ByRef type As T
) As Boolean
Parameters
name | Type: System.String The name.
type | Type: T. The type (Out parameter)
Return Value
Type: Boolean
true if found
Reference
IDataTypeContainer.T. Interface
TwinCAT.TypeSystem.Generic Namespace


IInstanceCollection.T. Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface
IInstanceCollection.T. Interface
Generic InstanceColleciton interface.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface IInstanceCollection<T> : IList<T>,
ICollection<T>, IEnumerable<T>, IEnumerable
where T : IInstance
VB
Public Interface IInstanceCollection(Of T As IInstance)
Inherits IList(Of T), ICollection(Of T), IEnumerable(Of T),
IEnumerable
Type Parameters
T
The IInstanceCollection.T. type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T.. (Inherited from ICollection.T..)
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only. (Inherited from ICollection.T..)
Item.Int32. | Gets or sets the element at the specified index. (Inherited from IList.T..)
Item.String. | Gets the IInstance with the specified instance path.
Mode | Gets the InstanceCollectionMode.
Methods
Name | Description
Add | Adds an item to the ICollection.T.. (Inherited from ICollection.T..)
Clear | Removes all items from the ICollection.T.. (Inherited from ICollection.T..)
Contains(T) | Determines whether the ICollection.T. contains a specific value. (Inherited from ICollection.T..)
Contains(String) | Determines whether this collection contains an instance with the specified instance path.
ContainsName | Determines whether this collection contains an instance with the specified instance name.
CopyTo | Copies the elements of the ICollection.T. to an Array, starting at a particular Array index. (Inherited from ICollection.T..)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable.T..)
GetInstance | Gets the IInstanceby instance path.
GetInstanceByName | Gets the IInstance by instance name.
IndexOf | Determines the index of a specific item in the IList.T.. (Inherited from IList.T..)
Insert | Inserts an item to the IList.T. at the specified index. (Inherited from IList.T..)
Remove | Removes the first occurrence of a specific object from the ICollection.T.. (Inherited from ICollection.T..)
RemoveAt | Removes the IList.T. item at the specified index. (Inherited from IList.T..)
TryGetInstance | Tries to get the specified instance.
TryGetInstanceByName | Tries to get the specified instance by name.
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
IInstanceCollection.T. Properties
•
IInstanceCollection.T. Methods


IInstanceCollection.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Properties
IInstanceCollection.T. Properties
The IInstanceCollection.T. generic type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T.. (Inherited from ICollection.T..)
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only. (Inherited from ICollection.T..)
Item.Int32. | Gets or sets the element at the specified index. (Inherited from IList.T..)
Item.String. | Gets the IInstance with the specified instance path.
Mode | Gets the InstanceCollectionMode.
Reference
IInstanceCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
IInstanceCollection.T..Item Property
•
IInstanceCollection.T..Mode Property


IInstanceCollection.T..Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Properties [image] IInstanceCollection.T..Item Property
IInstanceCollection.T..Item Property
Overload List
Name | Description
Item.Int32. | Gets or sets the element at the specified index. (Inherited from IList.T..)
Item.String. | Gets the IInstance with the specified instance path.
Reference
IInstanceCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
IInstanceCollection.T..Item Property (String)


IInstanceCollection.T..Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Properties [image] IInstanceCollection.T..Item Property [image] IInstanceCollection.T..Item Property (String)
IInstanceCollection.T..Item Property (String)
Gets the IInstance with the specified instance path.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
T this[
string instancePath
] { get; }
VB
ReadOnly Default Property Item (
instancePath As String
) As T
Get
Parameters
instancePath
Type: System.String
Property Value
Type: T
Reference
IInstanceCollection.T. Interface
Item Overload
TwinCAT.TypeSystem.Generic Namespace


IInstanceCollection.T..Mode Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Properties [image] IInstanceCollection.T..Mode Property
IInstanceCollection.T..Mode Property
Gets the InstanceCollectionMode.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
InstanceCollectionMode Mode { get; }
VB
ReadOnly Property Mode As InstanceCollectionMode
Get
Property Value
Type: InstanceCollectionMode
The mode.
Reference
IInstanceCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace


IInstanceCollection.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Methods
IInstanceCollection.T. Methods
The IInstanceCollection.T. generic type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T.. (Inherited from ICollection.T..)
Clear | Removes all items from the ICollection.T.. (Inherited from ICollection.T..)
Contains(T) | Determines whether the ICollection.T. contains a specific value. (Inherited from ICollection.T..)
Contains(String) | Determines whether this collection contains an instance with the specified instance path.
ContainsName | Determines whether this collection contains an instance with the specified instance name.
CopyTo | Copies the elements of the ICollection.T. to an Array, starting at a particular Array index. (Inherited from ICollection.T..)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable.T..)
GetInstance | Gets the IInstanceby instance path.
GetInstanceByName | Gets the IInstance by instance name.
IndexOf | Determines the index of a specific item in the IList.T.. (Inherited from IList.T..)
Insert | Inserts an item to the IList.T. at the specified index. (Inherited from IList.T..)
Remove | Removes the first occurrence of a specific object from the ICollection.T.. (Inherited from ICollection.T..)
RemoveAt | Removes the IList.T. item at the specified index. (Inherited from IList.T..)
TryGetInstance | Tries to get the specified instance.
TryGetInstanceByName | Tries to get the specified instance by name.
Reference
IInstanceCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
IInstanceCollection.T..Contains Method
•
IInstanceCollection.T..ContainsName Method
•
IInstanceCollection.T..GetInstance Method
•
IInstanceCollection.T..GetInstanceByName Method
•
IInstanceCollection.T..TryGetInstance Method
•
IInstanceCollection.T..TryGetInstanceByName Method


IInstanceCollection.T..Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Methods [image] IInstanceCollection.T..Contains Method
IInstanceCollection.T..Contains Method
Overload List
Name | Description
Contains(T) | Determines whether the ICollection.T. contains a specific value. (Inherited from ICollection.T..)
Contains(String) | Determines whether this collection contains an instance with the specified instance path.
Reference
IInstanceCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
IInstanceCollection.T..Contains Method (String)


IInstanceCollection.T..Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Methods [image] IInstanceCollection.T..Contains Method [image] IInstanceCollection.T..Contains Method (String)
IInstanceCollection.T..Contains Method (String)
Determines whether this collection contains an instance with the specified instance path.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool Contains(
string instancePath
)
VB
Function Contains (
instancePath As String
) As Boolean
Parameters
instancePath
Type: System.String
The instance path.
Return Value
Type: Boolean
true if this collection contains the specified instance path; otherwise, false.
Reference
IInstanceCollection.T. Interface
Contains Overload
TwinCAT.TypeSystem.Generic Namespace


IInstanceCollection.T..ContainsName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Methods [image] IInstanceCollection.T..ContainsName Method
IInstanceCollection.T..ContainsName Method
Determines whether this collection contains an instance with the specified instance name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool ContainsName(
string instanceName
)
VB
Function ContainsName (
instanceName As String
) As Boolean
Parameters
instanceName
Type: System.String
Name of the instance.
Return Value
Type: Boolean
true if this collection contains the specified instance path; otherwise, false.
Reference
IInstanceCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace


IInstanceCollection.T..GetInstance Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Methods [image] IInstanceCollection.T..GetInstance Method
IInstanceCollection.T..GetInstance Method
Gets the IInstanceby instance path.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
T GetInstance(
string instancePath
)
VB
Function GetInstance (
instancePath As String
) As T
Parameters
instancePath
Type: System.String
The instance path.
Return Value
Type: T
T.
Reference
IInstanceCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace


IInstanceCollection.T..GetInstanceByName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Methods [image] IInstanceCollection.T..GetInstanceByName Method
IInstanceCollection.T..GetInstanceByName Method
Gets the IInstance by instance name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
IList<T> GetInstanceByName(
string instanceName
)
VB
Function GetInstanceByName (
instanceName As String
) As IList(Of T)
Parameters
instanceName
Type: System.String
Name of the instance.
Return Value
Type: IList.T.
IList<T>.
Reference
IInstanceCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace


IInstanceCollection.T..TryGetInstance Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Methods [image] IInstanceCollection.T..TryGetInstance Method
IInstanceCollection.T..TryGetInstance Method
Tries to get the specified instance.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TryGetInstance(
string instancePath,
out T symbol
)
VB
Function TryGetInstance (
instancePath As String,
<OutAttribute> ByRef symbol As T
) As Boolean
Parameters
instancePath | Type: System.String The instance path.
symbol | Type: T. The symbol.
Return Value
Type: Boolean
true if the IInstance is found; otherwise, false
Reference
IInstanceCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace


IInstanceCollection.T..TryGetInstanceByName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] IInstanceCollection.T. Interface [image] IInstanceCollection.T. Methods [image] IInstanceCollection.T..TryGetInstanceByName Method
IInstanceCollection.T..TryGetInstanceByName Method
Tries to get the specified instance by name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
bool TryGetInstanceByName(
string instanceName,
out IList<T> symbols
)
VB
Function TryGetInstanceByName (
instanceName As String,
<OutAttribute> ByRef symbols As IList(Of T)
) As Boolean
Parameters
instanceName | Type: System.String Name of the instance.
symbols | Type: System.Collections.Generic.IList.T.. The found symbols.
Return Value
Type: Boolean
true if the IInstance is found; otherwise, false
Reference
IInstanceCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace


INamespace.T. Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] INamespace.T. Interface
INamespace.T. Interface
Namespace interface
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface INamespace<T>
where T : IDataType
VB
Public Interface INamespace(Of T As IDataType)
Type Parameters
T
DataType class used within this Namespace interface
The INamespace.T. type exposes the following members.
Properties
Name | Description
DataTypes | Data types organized by the INamespace.T.
Name | Gets the name/ identifier of the Namespace
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
INamespace.T. Properties


INamespace.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] INamespace.T. Interface [image] INamespace.T. Properties
INamespace.T. Properties
The INamespace.T. generic type exposes the following members.
Properties
Name | Description
DataTypes | Data types organized by the INamespace.T.
Name | Gets the name/ identifier of the Namespace
Reference
INamespace.T. Interface
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
INamespace.T..DataTypes Property
•
INamespace.T..Name Property


INamespace.T..DataTypes Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] INamespace.T. Interface [image] INamespace.T. Properties [image] INamespace.T..DataTypes Property
INamespace.T..DataTypes Property
Data types organized by the INamespace.T.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyDataTypeCollection<T> DataTypes { get; }
VB
ReadOnly Property DataTypes As ReadOnlyDataTypeCollection(Of T)
Get
Property Value
Type: ReadOnlyDataTypeCollection.T.
The data types.
Reference
INamespace.T. Interface
TwinCAT.TypeSystem.Generic Namespace


INamespace.T..Name Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] INamespace.T. Interface [image] INamespace.T. Properties [image] INamespace.T..Name Property
INamespace.T..Name Property
Gets the name/ identifier of the Namespace
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string Name { get; }
VB
ReadOnly Property Name As String
Get
Property Value
Type: String
The name.
Reference
INamespace.T. Interface
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class
InstanceCollection.T. Class
Base class for IInstance object collections (abstract).
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.Generic.InstanceCollection.T.
TwinCAT.TypeSystem.FieldCollection
TwinCAT.TypeSystem.Generic.SymbolCollection.T.
TwinCAT.TypeSystem.MemberCollection
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public abstract class InstanceCollection<T> : IList<T>,
ICollection<T>, IEnumerable<T>, IEnumerable, IInstanceCollection<T>
where T : class, IInstance
VB
Public MustInherit Class InstanceCollection(Of T As {Class, IInstance})
Implements IList(Of T), ICollection(Of T),
IEnumerable(Of T), IEnumerable, IInstanceCollection(Of T)
Type Parameters
T
The InstanceCollection.T. type exposes the following members.
Constructors
Name | Description
InstanceCollection.T.(InstanceCollectionMode) | Initializes a new instance of the InstanceCollection.T. class.
InstanceCollection.T.(IEnumerable.T., InstanceCollectionMode) | Initializes a new instance of the InstanceCollection.T. class.
Properties
Name | Description
Count | Gets the collection count.
IsReadOnly | Gets a value indicating whether this instance is read only.
Item.Int32. | Gets or sets the IInstance at the specified index.
Item.String. | Gets the IInstance with the specified instance path.
Mode | Gets the InstanceCollectionMode.
Methods
Name | Description
Add | Adds the specified item.
AddRange | Adds the specified items to this collection.
AsReadOnly | Converts the InstanceCollection.T. to an ReadOnlyInstanceCollection.T.
Clear | Clears this instance.
Contains(String) | Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath
Contains(T) | Determines whether this collection contains the specified IInstance
ContainsName | Determines whether the specified instance name contains name.
CopyTo | Copies this InstanceCollection.T. to the specified array.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path.
GetInstanceByName | Gets the name of the instance by.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of the specified IInstance.
Insert | Inserts the specified IInstance at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified item.
RemoveAt | Removes the IInstance at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the IInstance. of the specified path.
TryGetInstanceByName | Tries to get Instnaces by name.
Fields
Name | Description
_list | The _list
_pathDict | The _path dictionary
mode | The mode this InstanceCollection.T. is working in.
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
InstanceCollection.T. Constructor
•
InstanceCollection.T. Properties
•
InstanceCollection.T. Methods
•
InstanceCollection.T. Fields


InstanceCollection.T. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Constructor
InstanceCollection.T. Constructor
Overload List
Name | Description
InstanceCollection.T.(InstanceCollectionMode) | Initializes a new instance of the InstanceCollection.T. class.
InstanceCollection.T.(IEnumerable.T., InstanceCollectionMode) | Initializes a new instance of the InstanceCollection.T. class.
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
InstanceCollection.T. Constructor (InstanceCollectionMode)
•
InstanceCollection.T. Constructor (IEnumerable.T., InstanceCollectionMode)


InstanceCollection.T. Constructor (InstanceCollectionMode)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Constructor [image] InstanceCollection.T. Constructor (InstanceCollectionMode)
InstanceCollection.T. Constructor (InstanceCollectionMode)
Initializes a new instance of the InstanceCollection.T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected InstanceCollection(
InstanceCollectionMode mode
)
VB
Protected Sub New (
mode As InstanceCollectionMode
)
Parameters
mode
Type: TwinCAT.TypeSystem.Generic.InstanceCollectionMode
The mode.
Reference
InstanceCollection.T. Class
InstanceCollection.T. Overload
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T. Constructor (IEnumerable.T., InstanceCollectionMode)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Constructor [image] InstanceCollection.T. Constructor (IEnumerable.T., InstanceCollectionMode)
InstanceCollection.T. Constructor (IEnumerable.T., InstanceCollectionMode)
Initializes a new instance of the InstanceCollection.T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected InstanceCollection(
IEnumerable<T> coll,
InstanceCollectionMode mode
)
VB
Protected Sub New (
coll As IEnumerable(Of T),
mode As InstanceCollectionMode
)
Parameters
coll | Type: System.Collections.Generic.IEnumerable.T. The copy collection
mode | Type: TwinCAT.TypeSystem.Generic.InstanceCollectionMode The mode.
Reference
InstanceCollection.T. Class
InstanceCollection.T. Overload
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Properties
InstanceCollection.T. Properties
The InstanceCollection.T. generic type exposes the following members.
Properties
Name | Description
Count | Gets the collection count.
IsReadOnly | Gets a value indicating whether this instance is read only.
Item.Int32. | Gets or sets the IInstance at the specified index.
Item.String. | Gets the IInstance with the specified instance path.
Mode | Gets the InstanceCollectionMode.
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
InstanceCollection.T..Count Property
•
InstanceCollection.T..IsReadOnly Property
•
InstanceCollection.T..Item Property
•
InstanceCollection.T..Mode Property


InstanceCollection.T..Count Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Properties [image] InstanceCollection.T..Count Property
InstanceCollection.T..Count Property
Gets the collection count.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Count { get; }
VB
Public ReadOnly Property Count As Integer
Get
Property Value
Type: Int32
The count.
Implements
ICollection.T..Count
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Properties [image] InstanceCollection.T..IsReadOnly Property
InstanceCollection.T..IsReadOnly Property
Gets a value indicating whether this instance is read only.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Property Value
Type: Boolean
true if this instance is read only; otherwise, false.
Implements
ICollection.T..IsReadOnly
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Properties [image] InstanceCollection.T..Item Property
InstanceCollection.T..Item Property
Overload List
Name | Description
Item.Int32. | Gets or sets the IInstance at the specified index.
Item.String. | Gets the IInstance with the specified instance path.
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
InstanceCollection.T..Item Property (Int32)
•
InstanceCollection.T..Item Property (String)


InstanceCollection.T..Item Property (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Properties [image] InstanceCollection.T..Item Property [image] InstanceCollection.T..Item Property (Int32)
InstanceCollection.T..Item Property (Int32)
Gets or sets the IInstance at the specified index.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T this[
int index
] { get; set; }
VB
Public Default Property Item (
index As Integer
) As T
Get
Set
Parameters
index
Type: System.Int32
The index.
Return Value
Type: T
T.
Implements
IList.T..Item.Int32.
Exceptions
Exception | Condition
NotImplementedException |
Reference
InstanceCollection.T. Class
Item Overload
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Properties [image] InstanceCollection.T..Item Property [image] InstanceCollection.T..Item Property (String)
InstanceCollection.T..Item Property (String)
Gets the IInstance with the specified instance path.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T this[
string instanceSpecifier
] { get; }
VB
Public ReadOnly Default Property Item (
instanceSpecifier As String
) As T
Get
Parameters
instanceSpecifier
Type: System.String
The instance path or Instance Name (dependent of Mode setting)
Return Value
Type: T
T.
Implements
IInstanceCollection.T..Item.String.
Exceptions
Exception | Condition
ArgumentNullException |
ArgumentException |
Remarks
Dependent what this InstanceCollection.T. contains configured by the InstanceCollectionMode the instance specifier should be the InstanceName or the InstancePath.
Reference
InstanceCollection.T. Class
Item Overload
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..Mode Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Properties [image] InstanceCollection.T..Mode Property
InstanceCollection.T..Mode Property
Gets the InstanceCollectionMode.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public InstanceCollectionMode Mode { get; }
VB
Public ReadOnly Property Mode As InstanceCollectionMode
Get
Property Value
Type: InstanceCollectionMode
The mode.
Implements
IInstanceCollection.T..Mode
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods
InstanceCollection.T. Methods
The InstanceCollection.T. generic type exposes the following members.
Methods
Name | Description
Add | Adds the specified item.
AddRange | Adds the specified items to this collection.
AsReadOnly | Converts the InstanceCollection.T. to an ReadOnlyInstanceCollection.T.
Clear | Clears this instance.
Contains(String) | Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath
Contains(T) | Determines whether this collection contains the specified IInstance
ContainsName | Determines whether the specified instance name contains name.
CopyTo | Copies this InstanceCollection.T. to the specified array.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path.
GetInstanceByName | Gets the name of the instance by.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of the specified IInstance.
Insert | Inserts the specified IInstance at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified item.
RemoveAt | Removes the IInstance at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the IInstance. of the specified path.
TryGetInstanceByName | Tries to get Instnaces by name.
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
InstanceCollection.T..Add Method
•
InstanceCollection.T..AddRange Method
•
InstanceCollection.T..AsReadOnly Method
•
InstanceCollection.T..Clear Method
•
InstanceCollection.T..Contains Method
•
InstanceCollection.T..ContainsName Method
•
InstanceCollection.T..CopyTo Method
•
InstanceCollection.T..GetEnumerator Method
•
InstanceCollection.T..GetInstance Method
•
InstanceCollection.T..GetInstanceByName Method
•
InstanceCollection.T..IndexOf Method
•
InstanceCollection.T..Insert Method
•
InstanceCollection.T..Remove Method
•
InstanceCollection.T..RemoveAt Method
•
InstanceCollection.T..TryGetInstance Method
•
InstanceCollection.T..TryGetInstanceByName Method


InstanceCollection.T..Add Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..Add Method
InstanceCollection.T..Add Method
Adds the specified item.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Add(
T item
)
VB
Public Sub Add (
item As T
)
Parameters
item
Type: T
The item.
Implements
ICollection.T..Add(T)
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..AddRange Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..AddRange Method
InstanceCollection.T..AddRange Method
Adds the specified items to this collection.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void AddRange(
IEnumerable<T> items
)
VB
Public Sub AddRange (
items As IEnumerable(Of T)
)
Parameters
items
Type: System.Collections.Generic.IEnumerable.T.
The items.
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..AsReadOnly Method
InstanceCollection.T..AsReadOnly Method
Converts the InstanceCollection.T. to an ReadOnlyInstanceCollection.T.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyInstanceCollection<T> AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlyInstanceCollection(Of T)
Return Value
Type: ReadOnlyInstanceCollection.T.
ReadOnlyInstanceCollection<T>.
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..Clear Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..Clear Method
InstanceCollection.T..Clear Method
Clears this instance.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Clear()
VB
Public Sub Clear
Implements
ICollection.T..Clear.
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..Contains Method
InstanceCollection.T..Contains Method
Overload List
Name | Description
Contains(String) | Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath
Contains(T) | Determines whether this collection contains the specified IInstance
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
InstanceCollection.T..Contains Method (String)
•
InstanceCollection.T..Contains Method (T)


InstanceCollection.T..Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..Contains Method [image] InstanceCollection.T..Contains Method (String)
InstanceCollection.T..Contains Method (String)
Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string instanceSpecifier
)
VB
Public Function Contains (
instanceSpecifier As String
) As Boolean
Parameters
instanceSpecifier
Type: System.String
The instance path or Instance Name (dependent of Mode setting)
Return Value
Type: Boolean
true if [contains] [the specified instance path]; otherwise, false.
Implements
IInstanceCollection.T..Contains(String)
Exceptions
Exception | Condition
ArgumentNullException | instancePath
ArgumentException |
Reference
InstanceCollection.T. Class
Contains Overload
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..Contains Method (T)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..Contains Method [image] InstanceCollection.T..Contains Method (T)
InstanceCollection.T..Contains Method (T)
Determines whether this collection contains the specified IInstance
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
T item
)
VB
Public Function Contains (
item As T
) As Boolean
Parameters
item
Type: T
The item.
Return Value
Type: Boolean
true if [contains] [the specified item]; otherwise, false.
Implements
ICollection.T..Contains(T)
Reference
InstanceCollection.T. Class
Contains Overload
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..ContainsName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..ContainsName Method
InstanceCollection.T..ContainsName Method
Determines whether the specified instance name contains name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool ContainsName(
string instanceName
)
VB
Public Function ContainsName (
instanceName As String
) As Boolean
Parameters
instanceName
Type: System.String
Name of the instance.
Return Value
Type: Boolean
true if the specified instance name contains name; otherwise, false.
Implements
IInstanceCollection.T..ContainsName(String)
Exceptions
Exception | Condition
NotImplementedException |
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..CopyTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..CopyTo Method
InstanceCollection.T..CopyTo Method
Copies this InstanceCollection.T. to the specified array.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void CopyTo(
T[] array,
int arrayIndex
)
VB
Public Sub CopyTo (
array As T(),
arrayIndex As Integer
)
Parameters
array | Type: .T. The array.
arrayIndex | Type: System.Int32 Index of the array.
Implements
ICollection.T..CopyTo(.T., Int32)
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..GetEnumerator Method
InstanceCollection.T..GetEnumerator Method
Gets the enumerator.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<T> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of T)
Return Value
Type: IEnumerator.T.
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..GetInstance Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..GetInstance Method
InstanceCollection.T..GetInstance Method
Gets the IInstanceby instance path.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T GetInstance(
string instanceSpecifier
)
VB
Public Function GetInstance (
instanceSpecifier As String
) As T
Parameters
instanceSpecifier
Type: System.String
The instance path or Instance Name (dependent of Mode setting)
Return Value
Type: T
T.
Implements
IInstanceCollection.T..GetInstance(String)
Exceptions
Exception | Condition
ArgumentException | Path not found!;instancePath
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..GetInstanceByName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..GetInstanceByName Method
InstanceCollection.T..GetInstanceByName Method
Gets the name of the instance by.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IList<T> GetInstanceByName(
string instanceName
)
VB
Public Function GetInstanceByName (
instanceName As String
) As IList(Of T)
Parameters
instanceName
Type: System.String
Name of the instance.
Return Value
Type: IList.T.
IList<T>.
Implements
IInstanceCollection.T..GetInstanceByName(String)
Exceptions
Exception | Condition
ArgumentException | Name not found!;instanceName
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..IndexOf Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..IndexOf Method
InstanceCollection.T..IndexOf Method
Determines the index of the specified IInstance.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int IndexOf(
T item
)
VB
Public Function IndexOf (
item As T
) As Integer
Parameters
item
Type: T
The item.
Return Value
Type: Int32
The index of item if found in the list; otherwise, -1.
Implements
IList.T..IndexOf(T)
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..Insert Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..Insert Method
InstanceCollection.T..Insert Method
Inserts the specified IInstance at the specified index.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Insert(
int index,
T instance
)
VB
Public Sub Insert (
index As Integer,
instance As T
)
Parameters
index | Type: System.Int32 The instance.
instance | Type: T The item.
Implements
IList.T..Insert(Int32, T)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index or index
ArgumentNullException |
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..Remove Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..Remove Method
InstanceCollection.T..Remove Method
Removes the specified item.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Remove(
T item
)
VB
Public Function Remove (
item As T
) As Boolean
Parameters
item
Type: T
The item.
Return Value
Type: Boolean
true if item was successfully removed from the ICollection.T.; otherwise, false. This method also returns false if item is not found in the original ICollection.T..
Implements
ICollection.T..Remove(T)
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..RemoveAt Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..RemoveAt Method
InstanceCollection.T..RemoveAt Method
Removes the IInstance at the specified index.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void RemoveAt(
int index
)
VB
Public Sub RemoveAt (
index As Integer
)
Parameters
index
Type: System.Int32
The index.
Implements
IList.T..RemoveAt(Int32)
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..TryGetInstance Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..TryGetInstance Method
InstanceCollection.T..TryGetInstance Method
Tries to get the IInstance. of the specified path.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetInstance(
string instanceSpecifier,
out T symbol
)
VB
Public Function TryGetInstance (
instanceSpecifier As String,
<OutAttribute> ByRef symbol As T
) As Boolean
Parameters
instanceSpecifier | Type: System.String The instance path or Instance Name (dependent of Mode setting)
symbol | Type: T. The symbol.
Return Value
Type: Boolean
true if the IInstance is found; otherwise, false
Implements
IInstanceCollection.T..TryGetInstance(String, T.)
Exceptions
Exception | Condition
ArgumentNullException | instancePath
ArgumentException |
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..TryGetInstanceByName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Methods [image] InstanceCollection.T..TryGetInstanceByName Method
InstanceCollection.T..TryGetInstanceByName Method
Tries to get Instnaces by name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public virtual bool TryGetInstanceByName(
string instanceName,
out IList<T> instances
)
VB
Public Overridable Function TryGetInstanceByName (
instanceName As String,
<OutAttribute> ByRef instances As IList(Of T)
) As Boolean
Parameters
instanceName | Type: System.String Name of the instance.
instances | Type: System.Collections.Generic.IList.T.. The instances found.
Return Value
Type: Boolean
true if the IInstance is found; otherwise, false
Implements
IInstanceCollection.T..TryGetInstanceByName(String, IList.T..)
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T. Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Fields
InstanceCollection.T. Fields
The InstanceCollection.T. generic type exposes the following members.
Fields
Name | Description
_list | The _list
_pathDict | The _path dictionary
mode | The mode this InstanceCollection.T. is working in.
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
InstanceCollection.T.._list Field
•
InstanceCollection.T.._pathDict Field
•
InstanceCollection.T..mode Field


InstanceCollection.T.._list Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Fields [image] InstanceCollection.T.._list Field
InstanceCollection.T.._list Field
The _list
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected List<T> _list
VB
Protected _list As List(Of T)
Field Value
Type: List.T.
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T.._pathDict Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Fields [image] InstanceCollection.T.._pathDict Field
InstanceCollection.T.._pathDict Field
The _path dictionary
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected Dictionary<string, T> _pathDict
VB
Protected _pathDict As Dictionary(Of String, T)
Field Value
Type: Dictionary.String, T.
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollection.T..mode Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollection.T. Class [image] InstanceCollection.T. Fields [image] InstanceCollection.T..mode Field
InstanceCollection.T..mode Field
The mode this InstanceCollection.T. is working in.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected InstanceCollectionMode mode
VB
Protected mode As InstanceCollectionMode
Field Value
Type: InstanceCollectionMode
Reference
InstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


InstanceCollectionMode Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] InstanceCollectionMode Enumeration
InstanceCollectionMode Enumeration
Enum InstanceCollectionMode
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public enum InstanceCollectionMode
VB
Public Enumeration InstanceCollectionMode
Members
Member name | Value | Description
Names | 0 | InstanceCollection{T} is organized with InstanceNames instead of Instance Paths
Path | 1 | InstanceCollection{T} is organized with InstancePaths in a flat list
PathHierarchy | 2 | InstanceCollection{T} is organized with InstancePaths in a Hierarchy (Only Root objects appearing)
Reference
TwinCAT.TypeSystem.Generic Namespace


ISymbolCollection.T. Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ISymbolCollection.T. Interface
ISymbolCollection.T. Interface
Interface ISymbolCollection
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISymbolCollection<T> : IInstanceCollection<T>,
IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
where T : ISymbol
VB
Public Interface ISymbolCollection(Of T As ISymbol)
Inherits IInstanceCollection(Of T), IList(Of T), ICollection(Of T),
IEnumerable(Of T), IEnumerable
Type Parameters
T
The ISymbolCollection.T. type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T.. (Inherited from ICollection.T..)
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only. (Inherited from ICollection.T..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from IInstanceCollection.T..)
Item.Int32. | Gets or sets the element at the specified index. (Inherited from IList.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from IInstanceCollection.T..)
Methods
Name | Description
Add | Adds an item to the ICollection.T.. (Inherited from ICollection.T..)
Clear | Removes all items from the ICollection.T.. (Inherited from ICollection.T..)
Contains(String) | Determines whether this collection contains an instance with the specified instance path. (Inherited from IInstanceCollection.T..)
Contains(T) | Determines whether the ICollection.T. contains a specific value. (Inherited from ICollection.T..)
ContainsName | Determines whether this collection contains an instance with the specified instance name. (Inherited from IInstanceCollection.T..)
CopyTo | Copies the elements of the ICollection.T. to an Array, starting at a particular Array index. (Inherited from ICollection.T..)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable.T..)
GetInstance | Gets the IInstanceby instance path. (Inherited from IInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from IInstanceCollection.T..)
IndexOf | Determines the index of a specific item in the IList.T.. (Inherited from IList.T..)
Insert | Inserts an item to the IList.T. at the specified index. (Inherited from IList.T..)
Remove | Removes the first occurrence of a specific object from the ICollection.T.. (Inherited from ICollection.T..)
RemoveAt | Removes the IList.T. item at the specified index. (Inherited from IList.T..)
TryGetInstance | Tries to get the specified instance. (Inherited from IInstanceCollection.T..)
TryGetInstanceByName | Tries to get the specified instance by name. (Inherited from IInstanceCollection.T..)
Reference
TwinCAT.TypeSystem.Generic Namespace
TwinCAT.TypeSystem.Generic.IInstanceCollection.T.
Weiterführende Informationen
•
ISymbolCollection.T. Properties
•
ISymbolCollection.T. Methods


ISymbolCollection.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ISymbolCollection.T. Interface [image] ISymbolCollection.T. Properties
ISymbolCollection.T. Properties
The ISymbolCollection.T. generic type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ICollection.T.. (Inherited from ICollection.T..)
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only. (Inherited from ICollection.T..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from IInstanceCollection.T..)
Item.Int32. | Gets or sets the element at the specified index. (Inherited from IList.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from IInstanceCollection.T..)
Reference
ISymbolCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace


ISymbolCollection.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ISymbolCollection.T. Interface [image] ISymbolCollection.T. Methods
ISymbolCollection.T. Methods
The ISymbolCollection.T. generic type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T.. (Inherited from ICollection.T..)
Clear | Removes all items from the ICollection.T.. (Inherited from ICollection.T..)
Contains(String) | Determines whether this collection contains an instance with the specified instance path. (Inherited from IInstanceCollection.T..)
Contains(T) | Determines whether the ICollection.T. contains a specific value. (Inherited from ICollection.T..)
ContainsName | Determines whether this collection contains an instance with the specified instance name. (Inherited from IInstanceCollection.T..)
CopyTo | Copies the elements of the ICollection.T. to an Array, starting at a particular Array index. (Inherited from ICollection.T..)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable.T..)
GetInstance | Gets the IInstanceby instance path. (Inherited from IInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from IInstanceCollection.T..)
IndexOf | Determines the index of a specific item in the IList.T.. (Inherited from IList.T..)
Insert | Inserts an item to the IList.T. at the specified index. (Inherited from IList.T..)
Remove | Removes the first occurrence of a specific object from the ICollection.T.. (Inherited from ICollection.T..)
RemoveAt | Removes the IList.T. item at the specified index. (Inherited from IList.T..)
TryGetInstance | Tries to get the specified instance. (Inherited from IInstanceCollection.T..)
TryGetInstanceByName | Tries to get the specified instance by name. (Inherited from IInstanceCollection.T..)
Reference
ISymbolCollection.T. Interface
TwinCAT.TypeSystem.Generic Namespace


ISymbolProvider.N, T, S. Interface

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ISymbolProvider.N, T, S. Interface
ISymbolProvider.N, T, S. Interface
Symbol provider interface
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public interface ISymbolProvider<N, T, S>
where N : Object, INamespace<T>
where T : IDataType
where S : ISymbol
VB
Public Interface ISymbolProvider(Of N As {Object, INamespace(Of T)}, T As IDataType, S As ISymbol)
Type Parameters
N | Namespace type
T | DataType type
S | Symbol type
The ISymbolProvider.N, T, S. type exposes the following members.
Properties
Name | Description
DataTypes | Gets all data types from all Namespaces
Namespaces | Get the Namespaces of DataTypes for this Symbol provider
RootNamespace | Gets the root (main) namespace of the Symbol provider.
RootNamespaceName | Gets the name of the root namespace
Symbols | Gets the (root) symbols of the Symbol provider.
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ISymbolProvider.N, T, S. Properties


ISymbolProvider.N, T, S. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ISymbolProvider.N, T, S. Interface [image] ISymbolProvider.N, T, S. Properties
ISymbolProvider.N, T, S. Properties
The ISymbolProvider.N, T, S. generic type exposes the following members.
Properties
Name | Description
DataTypes | Gets all data types from all Namespaces
Namespaces | Get the Namespaces of DataTypes for this Symbol provider
RootNamespace | Gets the root (main) namespace of the Symbol provider.
RootNamespaceName | Gets the name of the root namespace
Symbols | Gets the (root) symbols of the Symbol provider.
Reference
ISymbolProvider.N, T, S. Interface
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ISymbolProvider.N, T, S..DataTypes Property
•
ISymbolProvider.N, T, S..Namespaces Property
•
ISymbolProvider.N, T, S..RootNamespace Property
•
ISymbolProvider.N, T, S..RootNamespaceName Property
•
ISymbolProvider.N, T, S..Symbols Property


ISymbolProvider.N, T, S..DataTypes Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ISymbolProvider.N, T, S. Interface [image] ISymbolProvider.N, T, S. Properties [image] ISymbolProvider.N, T, S..DataTypes Property
ISymbolProvider.N, T, S..DataTypes Property
Gets all data types from all Namespaces
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyDataTypeCollection<T> DataTypes { get; }
VB
ReadOnly Property DataTypes As ReadOnlyDataTypeCollection(Of T)
Get
Property Value
Type: ReadOnlyDataTypeCollection.T.
The data types.
Reference
ISymbolProvider.N, T, S. Interface
TwinCAT.TypeSystem.Generic Namespace


ISymbolProvider.N, T, S..Namespaces Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ISymbolProvider.N, T, S. Interface [image] ISymbolProvider.N, T, S. Properties [image] ISymbolProvider.N, T, S..Namespaces Property
ISymbolProvider.N, T, S..Namespaces Property
Get the Namespaces of DataTypes for this Symbol provider
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlyNamespaceCollection<N, T> Namespaces { get; }
VB
ReadOnly Property Namespaces As ReadOnlyNamespaceCollection(Of N, T)
Get
Property Value
Type: ReadOnlyNamespaceCollection.N, T.
ReadOnly collection of the namespaces.
Reference
ISymbolProvider.N, T, S. Interface
TwinCAT.TypeSystem.Generic Namespace


ISymbolProvider.N, T, S..RootNamespace Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ISymbolProvider.N, T, S. Interface [image] ISymbolProvider.N, T, S. Properties [image] ISymbolProvider.N, T, S..RootNamespace Property
ISymbolProvider.N, T, S..RootNamespace Property
Gets the root (main) namespace of the Symbol provider.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
N RootNamespace { get; }
VB
ReadOnly Property RootNamespace As N
Get
Property Value
Type: N
The root namespace.
Reference
ISymbolProvider.N, T, S. Interface
TwinCAT.TypeSystem.Generic Namespace


ISymbolProvider.N, T, S..RootNamespaceName Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ISymbolProvider.N, T, S. Interface [image] ISymbolProvider.N, T, S. Properties [image] ISymbolProvider.N, T, S..RootNamespaceName Property
ISymbolProvider.N, T, S..RootNamespaceName Property
Gets the name of the root namespace
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
string RootNamespaceName { get; }
VB
ReadOnly Property RootNamespaceName As String
Get
Property Value
Type: String
The namespace.
Reference
ISymbolProvider.N, T, S. Interface
TwinCAT.TypeSystem.Generic Namespace


ISymbolProvider.N, T, S..Symbols Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ISymbolProvider.N, T, S. Interface [image] ISymbolProvider.N, T, S. Properties [image] ISymbolProvider.N, T, S..Symbols Property
ISymbolProvider.N, T, S..Symbols Property
Gets the (root) symbols of the Symbol provider.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
ReadOnlySymbolCollection<S> Symbols { get; }
VB
ReadOnly Property Symbols As ReadOnlySymbolCollection(Of S)
Get
Property Value
Type: ReadOnlySymbolCollection.S.
Read only collection of the Symbols
Reference
ISymbolProvider.N, T, S. Interface
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class
NamespaceCollection.N, T. Class
Generic class for Namespace collections
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.Generic.NamespaceCollection.N, T.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class NamespaceCollection<N, T> : IList<N>,
ICollection<N>, IEnumerable<N>, IEnumerable, INamespaceCollection<N, T>
where N : Object, INamespace<T>
where T : IDataType
VB
Public Class NamespaceCollection(Of N As {Object, INamespace(Of T)}, T As IDataType)
Implements IList(Of N), ICollection(Of N),
IEnumerable(Of N), IEnumerable, INamespaceCollection(Of N, T)
Type Parameters
N
T
The NamespaceCollection.N, T. type exposes the following members.
Constructors
Name | Description
NamespaceCollection.N, T. | Initializes a new instance of the NamespaceCollection.N, T. class.
Properties
Name | Description
AllTypes | Gets all types included in all namespaces.
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets or sets the element at the specified index.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
Clear | Removes all items from the ICollection.T..
Contains | Determines whether the ICollection.T. contains a specific value.
ContainsNamespace | Determines whether the specified name contains namespace.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetNamespace | Tries to get the namespace object
TryGetType | Tries to get the specified type.
TryGetTypeByFullName | Tries to get the data type by full name.
Fields
Name | Description
allTypes | Dictionary FullPath -> IDataType
list | List of Namespaces
namespaceDict | Dictionary NamespaceName --> INamespace
readOnly | Read only indicator
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
NamespaceCollection.N, T. Constructor
•
NamespaceCollection.N, T. Properties
•
NamespaceCollection.N, T. Methods
•
NamespaceCollection.N, T. Fields


NamespaceCollection.N, T. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Constructor
NamespaceCollection.N, T. Constructor
Initializes a new instance of the NamespaceCollection.N, T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public NamespaceCollection()
VB
Public Sub New
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Properties
NamespaceCollection.N, T. Properties
The NamespaceCollection.N, T. generic type exposes the following members.
Properties
Name | Description
AllTypes | Gets all types included in all namespaces.
Count | Gets the number of elements contained in the ICollection.T..
IsReadOnly | Gets a value indicating whether the ICollection.T. is read-only.
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets or sets the element at the specified index.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
NamespaceCollection.N, T..AllTypes Property
•
NamespaceCollection.N, T..Count Property
•
NamespaceCollection.N, T..IsReadOnly Property
•
NamespaceCollection.N, T..Item Property


NamespaceCollection.N, T..AllTypes Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Properties [image] NamespaceCollection.N, T..AllTypes Property
NamespaceCollection.N, T..AllTypes Property
Gets all types included in all namespaces.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyDataTypeCollection<T> AllTypes { get; }
VB
Public ReadOnly Property AllTypes As ReadOnlyDataTypeCollection(Of T)
Get
Property Value
Type: ReadOnlyDataTypeCollection.T.
All types.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..Count Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Properties [image] NamespaceCollection.N, T..Count Property
NamespaceCollection.N, T..Count Property
Gets the number of elements contained in the ICollection.T..
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int Count { get; }
VB
Public ReadOnly Property Count As Integer
Get
Return Value
Type: Int32
The number of elements contained in the ICollection.T..
Implements
ICollection.T..Count
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..IsReadOnly Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Properties [image] NamespaceCollection.N, T..IsReadOnly Property
NamespaceCollection.N, T..IsReadOnly Property
Gets a value indicating whether the ICollection.T. is read-only.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool IsReadOnly { get; }
VB
Public ReadOnly Property IsReadOnly As Boolean
Get
Return Value
Type: Boolean
true if the ICollection.T. is read-only; otherwise, false.
Implements
ICollection.T..IsReadOnly
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Properties [image] NamespaceCollection.N, T..Item Property
NamespaceCollection.N, T..Item Property
Overload List
Name | Description
Item.Int32. | Gets or sets the element at the specified index.
Item.String. | Gets or sets the element at the specified index.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
NamespaceCollection.N, T..Item Property (Int32)
•
NamespaceCollection.N, T..Item Property (String)


NamespaceCollection.N, T..Item Property (Int32)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Properties [image] NamespaceCollection.N, T..Item Property [image] NamespaceCollection.N, T..Item Property (Int32)
NamespaceCollection.N, T..Item Property (Int32)
Gets or sets the element at the specified index.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public N this[
int index
] { get; set; }
VB
Public Default Property Item (
index As Integer
) As N
Get
Set
Parameters
index
Type: System.Int32
The index.
Return Value
Type: N
Implements
IList.T..Item.Int32.
Exceptions
Exception | Condition
NotImplementedException |
Reference
NamespaceCollection.N, T. Class
Item Overload
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Properties [image] NamespaceCollection.N, T..Item Property [image] NamespaceCollection.N, T..Item Property (String)
NamespaceCollection.N, T..Item Property (String)
Gets or sets the element at the specified index.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public N this[
string str
] { get; }
VB
Public ReadOnly Default Property Item (
str As String
) As N
Get
Parameters
str
Type: System.String
The STR.
Return Value
Type: N
Reference
NamespaceCollection.N, T. Class
Item Overload
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods
NamespaceCollection.N, T. Methods
The NamespaceCollection.N, T. generic type exposes the following members.
Methods
Name | Description
Add | Adds an item to the ICollection.T..
Clear | Removes all items from the ICollection.T..
Contains | Determines whether the ICollection.T. contains a specific value.
ContainsNamespace | Determines whether the specified name contains namespace.
CopyTo | Copies to.
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the IList.T..
Insert | Inserts an item to the IList.T. at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the ICollection.T..
RemoveAt | Removes the IList.T. item at the specified index.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetNamespace | Tries to get the namespace object
TryGetType | Tries to get the specified type.
TryGetTypeByFullName | Tries to get the data type by full name.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
NamespaceCollection.N, T..Add Method
•
NamespaceCollection.N, T..Clear Method
•
NamespaceCollection.N, T..Contains Method
•
NamespaceCollection.N, T..ContainsNamespace Method
•
NamespaceCollection.N, T..CopyTo Method
•
NamespaceCollection.N, T..GetEnumerator Method
•
NamespaceCollection.N, T..IndexOf Method
•
NamespaceCollection.N, T..Insert Method
•
NamespaceCollection.N, T..Remove Method
•
NamespaceCollection.N, T..RemoveAt Method
•
NamespaceCollection.N, T..TryGetNamespace Method
•
NamespaceCollection.N, T..TryGetType Method
•
NamespaceCollection.N, T..TryGetTypeByFullName Method


NamespaceCollection.N, T..Add Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..Add Method
NamespaceCollection.N, T..Add Method
Adds an item to the ICollection.T..
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Add(
N item
)
VB
Public Sub Add (
item As N
)
Parameters
item
Type: N
The object to add to the ICollection.T..
Implements
ICollection.T..Add(T)
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..Clear Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..Clear Method
NamespaceCollection.N, T..Clear Method
Removes all items from the ICollection.T..
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Clear()
VB
Public Sub Clear
Implements
ICollection.T..Clear.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..Contains Method
NamespaceCollection.N, T..Contains Method
Determines whether the ICollection.T. contains a specific value.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
N item
)
VB
Public Function Contains (
item As N
) As Boolean
Parameters
item
Type: N
The object to locate in the ICollection.T..
Return Value
Type: Boolean
true if item is found in the ICollection.T.; otherwise, false.
Implements
ICollection.T..Contains(T)
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..ContainsNamespace Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..ContainsNamespace Method
NamespaceCollection.N, T..ContainsNamespace Method
Determines whether the specified name contains namespace.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool ContainsNamespace(
string name
)
VB
Public Function ContainsNamespace (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if the specified name contains namespace; otherwise, false.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..CopyTo Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..CopyTo Method
NamespaceCollection.N, T..CopyTo Method
Copies to.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void CopyTo(
N[] array,
int arrayIndex
)
VB
Public Sub CopyTo (
array As N(),
arrayIndex As Integer
)
Parameters
array | Type: .N. The array.
arrayIndex | Type: System.Int32 Index of the array.
Implements
ICollection.T..CopyTo(.T., Int32)
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..GetEnumerator Method
NamespaceCollection.N, T..GetEnumerator Method
Returns an enumerator that iterates through the collection.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<N> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of N)
Return Value
Type: IEnumerator.N.
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..IndexOf Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..IndexOf Method
NamespaceCollection.N, T..IndexOf Method
Determines the index of a specific item in the IList.T..
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public int IndexOf(
N item
)
VB
Public Function IndexOf (
item As N
) As Integer
Parameters
item
Type: N
The object to locate in the IList.T..
Return Value
Type: Int32
The index of item if found in the list; otherwise, -1.
Implements
IList.T..IndexOf(T)
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..Insert Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..Insert Method
NamespaceCollection.N, T..Insert Method
Inserts an item to the IList.T. at the specified index.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void Insert(
int index,
N item
)
VB
Public Sub Insert (
index As Integer,
item As N
)
Parameters
index | Type: System.Int32 The zero-based index at which item should be inserted.
item | Type: N The object to insert into the IList.T..
Implements
IList.T..Insert(Int32, T)
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..Remove Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..Remove Method
NamespaceCollection.N, T..Remove Method
Removes the first occurrence of a specific object from the ICollection.T..
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Remove(
N item
)
VB
Public Function Remove (
item As N
) As Boolean
Parameters
item
Type: N
The object to remove from the ICollection.T..
Return Value
Type: Boolean
true if item was successfully removed from the ICollection.T.; otherwise, false. This method also returns false if item is not found in the original ICollection.T..
Implements
ICollection.T..Remove(T)
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..RemoveAt Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..RemoveAt Method
NamespaceCollection.N, T..RemoveAt Method
Removes the IList.T. item at the specified index.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public void RemoveAt(
int index
)
VB
Public Sub RemoveAt (
index As Integer
)
Parameters
index
Type: System.Int32
The zero-based index of the item to remove.
Implements
IList.T..RemoveAt(Int32)
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..TryGetNamespace Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..TryGetNamespace Method
NamespaceCollection.N, T..TryGetNamespace Method
Tries to get the namespace object
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetNamespace(
string name,
out N nspace
)
VB
Public Function TryGetNamespace (
name As String,
<OutAttribute> ByRef nspace As N
) As Boolean
Parameters
name | Type: System.String The name.
nspace | Type: N. The namespace object (out-parameter)
Return Value
Type: Boolean
true if found, false if not contained.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..TryGetType Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..TryGetType Method
NamespaceCollection.N, T..TryGetType Method
Tries to get the specified type.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetType(
string typeName,
out T dataType
)
VB
Public Function TryGetType (
typeName As String,
<OutAttribute> ByRef dataType As T
) As Boolean
Parameters
typeName | Type: System.String Data type name
dataType | Type: T. The found data type (out-parameter).
Return Value
Type: Boolean
true if found, false if not contained.
Exceptions
Exception | Condition
ArgumentNullException | typeName
ArgumentException |
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..TryGetTypeByFullName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Methods [image] NamespaceCollection.N, T..TryGetTypeByFullName Method
NamespaceCollection.N, T..TryGetTypeByFullName Method
Tries to get the data type by full name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetTypeByFullName(
string fullname,
out T dataType
)
VB
Public Function TryGetTypeByFullName (
fullname As String,
<OutAttribute> ByRef dataType As T
) As Boolean
Parameters
fullname | Type: System.String DataTypes full name.
dataType | Type: T. Found data type (out-parameter).
Return Value
Type: Boolean
true if found, false if not contained.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T. Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Fields
NamespaceCollection.N, T. Fields
The NamespaceCollection.N, T. generic type exposes the following members.
Fields
Name | Description
allTypes | Dictionary FullPath -> IDataType
list | List of Namespaces
namespaceDict | Dictionary NamespaceName --> INamespace
readOnly | Read only indicator
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
NamespaceCollection.N, T..allTypes Field
•
NamespaceCollection.N, T..list Field
•
NamespaceCollection.N, T..namespaceDict Field
•
NamespaceCollection.N, T..readOnly Field


NamespaceCollection.N, T..allTypes Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Fields [image] NamespaceCollection.N, T..allTypes Field
NamespaceCollection.N, T..allTypes Field
Dictionary FullPath -> IDataType
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected Dictionary<string, T> allTypes
VB
Protected allTypes As Dictionary(Of String, T)
Field Value
Type: Dictionary.String, T.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..list Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Fields [image] NamespaceCollection.N, T..list Field
NamespaceCollection.N, T..list Field
List of Namespaces
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected List<N> list
VB
Protected list As List(Of N)
Field Value
Type: List.N.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..namespaceDict Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Fields [image] NamespaceCollection.N, T..namespaceDict Field
NamespaceCollection.N, T..namespaceDict Field
Dictionary NamespaceName --> INamespace
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected Dictionary<string, N> namespaceDict
VB
Protected namespaceDict As Dictionary(Of String, N)
Field Value
Type: Dictionary.String, N.
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


NamespaceCollection.N, T..readOnly Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] NamespaceCollection.N, T. Class [image] NamespaceCollection.N, T. Fields [image] NamespaceCollection.N, T..readOnly Field
NamespaceCollection.N, T..readOnly Field
Read only indicator
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected bool readOnly
VB
Protected readOnly As Boolean
Field Value
Type: Boolean
Reference
NamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyDataTypeCollection.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyDataTypeCollection.T. Class
ReadOnlyDataTypeCollection.T. Class
ReadOnly DataType collection
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.T.
TwinCAT.TypeSystem.Generic.ReadOnlyDataTypeCollection.T.
TwinCAT.TypeSystem.ReadOnlyDataTypeCollection
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyDataTypeCollection<T> : ReadOnlyCollection<T>,
IDataTypeContainer<T>
where T : IDataType
VB
Public Class ReadOnlyDataTypeCollection(Of T As IDataType)
Inherits ReadOnlyCollection(Of T)
Implements IDataTypeContainer(Of T)
Type Parameters
T
The ReadOnlyDataTypeCollection.T. type exposes the following members.
Constructors
Name | Description
ReadOnlyDataTypeCollection.T.(DataTypeCollection.T.) | Initializes a new instance of the ReadOnlyDataTypeCollection.T. class.
ReadOnlyDataTypeCollection.T.(ReadOnlyDataTypeCollection.T.) | Initializes a new instance of the ReadOnlyDataTypeCollection.T. class.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.T..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.T..)
Item.String. | Gets the element with the specified type name.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.T..)
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
ContainsType | Determines whether the specified name contains type.
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetType | Tries to get the Type with the specified name out of the collection.
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyDataTypeCollection.T. Constructor
•
ReadOnlyDataTypeCollection.T. Properties
•
ReadOnlyDataTypeCollection.T. Methods


ReadOnlyDataTypeCollection.T. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyDataTypeCollection.T. Class [image] ReadOnlyDataTypeCollection.T. Constructor
ReadOnlyDataTypeCollection.T. Constructor
Overload List
Name | Description
ReadOnlyDataTypeCollection.T.(DataTypeCollection.T.) | Initializes a new instance of the ReadOnlyDataTypeCollection.T. class.
ReadOnlyDataTypeCollection.T.(ReadOnlyDataTypeCollection.T.) | Initializes a new instance of the ReadOnlyDataTypeCollection.T. class.
Reference
ReadOnlyDataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyDataTypeCollection.T. Constructor (DataTypeCollection.T.)
•
ReadOnlyDataTypeCollection.T. Constructor (ReadOnlyDataTypeCollection.T.)


ReadOnlyDataTypeCollection.T. Constructor (DataTypeCollection.T.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyDataTypeCollection.T. Class [image] ReadOnlyDataTypeCollection.T. Constructor [image] ReadOnlyDataTypeCollection.T. Constructor (DataTypeCollection.T.)
ReadOnlyDataTypeCollection.T. Constructor (DataTypeCollection.T.)
Initializes a new instance of the ReadOnlyDataTypeCollection.T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyDataTypeCollection(
DataTypeCollection<T> coll
)
VB
Public Sub New (
coll As DataTypeCollection(Of T)
)
Parameters
coll
Type: TwinCAT.TypeSystem.Generic.DataTypeCollection.T.
The collection.
Reference
ReadOnlyDataTypeCollection.T. Class
ReadOnlyDataTypeCollection.T. Overload
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyDataTypeCollection.T. Constructor (ReadOnlyDataTypeCollection.T.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyDataTypeCollection.T. Class [image] ReadOnlyDataTypeCollection.T. Constructor [image] ReadOnlyDataTypeCollection.T. Constructor (ReadOnlyDataTypeCollection.T.)
ReadOnlyDataTypeCollection.T. Constructor (ReadOnlyDataTypeCollection.T.)
Initializes a new instance of the ReadOnlyDataTypeCollection.T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyDataTypeCollection(
ReadOnlyDataTypeCollection<T> coll
)
VB
Public Sub New (
coll As ReadOnlyDataTypeCollection(Of T)
)
Parameters
coll
Type: TwinCAT.TypeSystem.Generic.ReadOnlyDataTypeCollection.T.
The coll.
Reference
ReadOnlyDataTypeCollection.T. Class
ReadOnlyDataTypeCollection.T. Overload
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyDataTypeCollection.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyDataTypeCollection.T. Class [image] ReadOnlyDataTypeCollection.T. Properties
ReadOnlyDataTypeCollection.T. Properties
The ReadOnlyDataTypeCollection.T. generic type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.T..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.T..)
Item.String. | Gets the element with the specified type name.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.T..)
Reference
ReadOnlyDataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyDataTypeCollection.T..Item Property


ReadOnlyDataTypeCollection.T..Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyDataTypeCollection.T. Class [image] ReadOnlyDataTypeCollection.T. Properties [image] ReadOnlyDataTypeCollection.T..Item Property
ReadOnlyDataTypeCollection.T..Item Property
Overload List
Name | Description
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.T..)
Item.String. | Gets the element with the specified type name.
Reference
ReadOnlyDataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyDataTypeCollection.T..Item Property (String)


ReadOnlyDataTypeCollection.T..Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyDataTypeCollection.T. Class [image] ReadOnlyDataTypeCollection.T. Properties [image] ReadOnlyDataTypeCollection.T..Item Property [image] ReadOnlyDataTypeCollection.T..Item Property (String)
ReadOnlyDataTypeCollection.T..Item Property (String)
Gets the element with the specified type name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T this[
string name
] { get; }
VB
Public ReadOnly Default Property Item (
name As String
) As T
Get
Parameters
name
Type: System.String
The name.
Return Value
Type: T
T.
Implements
IDataTypeContainer.T..Item.String.
Reference
ReadOnlyDataTypeCollection.T. Class
Item Overload
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyDataTypeCollection.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyDataTypeCollection.T. Class [image] ReadOnlyDataTypeCollection.T. Methods
ReadOnlyDataTypeCollection.T. Methods
The ReadOnlyDataTypeCollection.T. generic type exposes the following members.
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
ContainsType | Determines whether the specified name contains type.
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetType | Tries to get the Type with the specified name out of the collection.
Reference
ReadOnlyDataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyDataTypeCollection.T..ContainsType Method
•
ReadOnlyDataTypeCollection.T..TryGetType Method


ReadOnlyDataTypeCollection.T..ContainsType Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyDataTypeCollection.T. Class [image] ReadOnlyDataTypeCollection.T. Methods [image] ReadOnlyDataTypeCollection.T..ContainsType Method
ReadOnlyDataTypeCollection.T..ContainsType Method
Determines whether the specified name contains type.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool ContainsType(
string name
)
VB
Public Function ContainsType (
name As String
) As Boolean
Parameters
name
Type: System.String
The name.
Return Value
Type: Boolean
true if the specified name contains type; otherwise, false.
Implements
IDataTypeContainer.T..ContainsType(String)
Reference
ReadOnlyDataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyDataTypeCollection.T..TryGetType Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyDataTypeCollection.T. Class [image] ReadOnlyDataTypeCollection.T. Methods [image] ReadOnlyDataTypeCollection.T..TryGetType Method
ReadOnlyDataTypeCollection.T..TryGetType Method
Tries to get the Type with the specified name out of the collection.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetType(
string name,
out T type
)
VB
Public Function TryGetType (
name As String,
<OutAttribute> ByRef type As T
) As Boolean
Parameters
name | Type: System.String The name.
type | Type: T. The type.
Return Value
Type: Boolean
true if found
Implements
IDataTypeContainer.T..TryGetType(String, T.)
Reference
ReadOnlyDataTypeCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyInstanceCollection.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class
ReadOnlyInstanceCollection.T. Class
ReadOnly Instance collection
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.T.
TwinCAT.TypeSystem.Generic.ReadOnlyInstanceCollection.T.
TwinCAT.TypeSystem.Generic.ReadOnlySymbolCollection.T.
TwinCAT.TypeSystem.ReadOnlyFieldCollection
TwinCAT.TypeSystem.ReadOnlyMemberCollection
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyInstanceCollection<T> : ReadOnlyCollection<T>,
IInstanceCollection<T>, IList<T>, ICollection<T>, IEnumerable<T>,
IEnumerable
where T : IInstance
VB
Public Class ReadOnlyInstanceCollection(Of T As IInstance)
Inherits ReadOnlyCollection(Of T)
Implements IInstanceCollection(Of T), IList(Of T),
ICollection(Of T), IEnumerable(Of T), IEnumerable
Type Parameters
T
The ReadOnlyInstanceCollection.T. type exposes the following members.
Constructors
Name | Description
ReadOnlyInstanceCollection.T. | Initializes a new instance of the ReadOnlyInstanceCollection.T. class.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.T..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.T..)
Item.String. | Gets the element with the specified instance path.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.T..)
Mode | Gets the InstanceCollectionMode.
Methods
Name | Description
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
Contains(String) | Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path.
ContainsName | Determines whether the specified instance is contained.
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path.
GetInstanceByName | Gets the IInstance by instance name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the instance with the specified instance path.
TryGetInstanceByName | Tries to get the instance by name.
Fields
Name | Description
mode | Mode of the IInstanceCollection.T.
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyInstanceCollection.T. Constructor
•
ReadOnlyInstanceCollection.T. Properties
•
ReadOnlyInstanceCollection.T. Methods
•
ReadOnlyInstanceCollection.T. Fields


ReadOnlyInstanceCollection.T. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Constructor
ReadOnlyInstanceCollection.T. Constructor
Initializes a new instance of the ReadOnlyInstanceCollection.T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyInstanceCollection(
IInstanceCollection<T> coll
)
VB
Public Sub New (
coll As IInstanceCollection(Of T)
)
Parameters
coll
Type: TwinCAT.TypeSystem.Generic.IInstanceCollection.T.
The coll.
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyInstanceCollection.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Properties
ReadOnlyInstanceCollection.T. Properties
The ReadOnlyInstanceCollection.T. generic type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.T..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.T..)
Item.String. | Gets the element with the specified instance path.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.T..)
Mode | Gets the InstanceCollectionMode.
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyInstanceCollection.T..Item Property
•
ReadOnlyInstanceCollection.T..Mode Property


ReadOnlyInstanceCollection.T..Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Properties [image] ReadOnlyInstanceCollection.T..Item Property
ReadOnlyInstanceCollection.T..Item Property
Overload List
Name | Description
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.T..)
Item.String. | Gets the element with the specified instance path.
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyInstanceCollection.T..Item Property (String)


ReadOnlyInstanceCollection.T..Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Properties [image] ReadOnlyInstanceCollection.T..Item Property [image] ReadOnlyInstanceCollection.T..Item Property (String)
ReadOnlyInstanceCollection.T..Item Property (String)
Gets the element with the specified instance path.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T this[
string instancePath
] { get; }
VB
Public ReadOnly Default Property Item (
instancePath As String
) As T
Get
Parameters
instancePath
Type: System.String
The instance path.
Return Value
Type: T
The instance if contained.
Implements
IInstanceCollection.T..Item.String.
Reference
ReadOnlyInstanceCollection.T. Class
Item Overload
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyInstanceCollection.T..Mode Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Properties [image] ReadOnlyInstanceCollection.T..Mode Property
ReadOnlyInstanceCollection.T..Mode Property
Gets the InstanceCollectionMode.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public InstanceCollectionMode Mode { get; }
VB
Public ReadOnly Property Mode As InstanceCollectionMode
Get
Property Value
Type: InstanceCollectionMode
The mode.
Implements
IInstanceCollection.T..Mode
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyInstanceCollection.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Methods
ReadOnlyInstanceCollection.T. Methods
The ReadOnlyInstanceCollection.T. generic type exposes the following members.
Methods
Name | Description
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
Contains(String) | Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path.
ContainsName | Determines whether the specified instance is contained.
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path.
GetInstanceByName | Gets the IInstance by instance name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the instance with the specified instance path.
TryGetInstanceByName | Tries to get the instance by name.
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyInstanceCollection.T..Contains Method
•
ReadOnlyInstanceCollection.T..ContainsName Method
•
ReadOnlyInstanceCollection.T..GetInstance Method
•
ReadOnlyInstanceCollection.T..GetInstanceByName Method
•
ReadOnlyInstanceCollection.T..TryGetInstance Method
•
ReadOnlyInstanceCollection.T..TryGetInstanceByName Method


ReadOnlyInstanceCollection.T..Contains Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Methods [image] ReadOnlyInstanceCollection.T..Contains Method
ReadOnlyInstanceCollection.T..Contains Method
Overload List
Name | Description
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
Contains(String) | Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path.
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyInstanceCollection.T..Contains Method (String)


ReadOnlyInstanceCollection.T..Contains Method (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Methods [image] ReadOnlyInstanceCollection.T..Contains Method [image] ReadOnlyInstanceCollection.T..Contains Method (String)
ReadOnlyInstanceCollection.T..Contains Method (String)
Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool Contains(
string instancePath
)
VB
Public Function Contains (
instancePath As String
) As Boolean
Parameters
instancePath
Type: System.String
The instance path.
Return Value
Type: Boolean
true if contains the specified instance path; otherwise, false.
Implements
IInstanceCollection.T..Contains(String)
Reference
ReadOnlyInstanceCollection.T. Class
Contains Overload
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyInstanceCollection.T..ContainsName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Methods [image] ReadOnlyInstanceCollection.T..ContainsName Method
ReadOnlyInstanceCollection.T..ContainsName Method
Determines whether the specified instance is contained.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool ContainsName(
string instanceName
)
VB
Public Function ContainsName (
instanceName As String
) As Boolean
Parameters
instanceName
Type: System.String
Name of the instance.
Return Value
Type: Boolean
true, if instance name is found.
Implements
IInstanceCollection.T..ContainsName(String)
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyInstanceCollection.T..GetInstance Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Methods [image] ReadOnlyInstanceCollection.T..GetInstance Method
ReadOnlyInstanceCollection.T..GetInstance Method
Gets the IInstanceby instance path.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public T GetInstance(
string instancePath
)
VB
Public Function GetInstance (
instancePath As String
) As T
Parameters
instancePath
Type: System.String
The instance path.
Return Value
Type: T
T.
Implements
IInstanceCollection.T..GetInstance(String)
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyInstanceCollection.T..GetInstanceByName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Methods [image] ReadOnlyInstanceCollection.T..GetInstanceByName Method
ReadOnlyInstanceCollection.T..GetInstanceByName Method
Gets the IInstance by instance name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IList<T> GetInstanceByName(
string instanceName
)
VB
Public Function GetInstanceByName (
instanceName As String
) As IList(Of T)
Parameters
instanceName
Type: System.String
Name of the instance.
Return Value
Type: IList.T.
IList<T>.
Implements
IInstanceCollection.T..GetInstanceByName(String)
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyInstanceCollection.T..TryGetInstance Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Methods [image] ReadOnlyInstanceCollection.T..TryGetInstance Method
ReadOnlyInstanceCollection.T..TryGetInstance Method
Tries to get the instance with the specified instance path.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetInstance(
string instancePath,
out T instance
)
VB
Public Function TryGetInstance (
instancePath As String,
<OutAttribute> ByRef instance As T
) As Boolean
Parameters
instancePath | Type: System.String The instance path.
instance | Type: T. The instance.
Return Value
Type: Boolean
true, if found, false if not contained.
Implements
IInstanceCollection.T..TryGetInstance(String, T.)
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyInstanceCollection.T..TryGetInstanceByName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Methods [image] ReadOnlyInstanceCollection.T..TryGetInstanceByName Method
ReadOnlyInstanceCollection.T..TryGetInstanceByName Method
Tries to get the instance by name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetInstanceByName(
string instanceName,
out IList<T> symbols
)
VB
Public Function TryGetInstanceByName (
instanceName As String,
<OutAttribute> ByRef symbols As IList(Of T)
) As Boolean
Parameters
instanceName | Type: System.String Name of the instance.
symbols | Type: System.Collections.Generic.IList.T.. The found symbols (out-parameter)
Return Value
Type: Boolean
true, if found; false if not contained.
Implements
IInstanceCollection.T..TryGetInstanceByName(String, IList.T..)
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyInstanceCollection.T. Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Fields
ReadOnlyInstanceCollection.T. Fields
The ReadOnlyInstanceCollection.T. generic type exposes the following members.
Fields
Name | Description
mode | Mode of the IInstanceCollection.T.
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyInstanceCollection.T..mode Field


ReadOnlyInstanceCollection.T..mode Field

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyInstanceCollection.T. Class [image] ReadOnlyInstanceCollection.T. Fields [image] ReadOnlyInstanceCollection.T..mode Field
ReadOnlyInstanceCollection.T..mode Field
Mode of the IInstanceCollection.T.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
protected InstanceCollectionMode mode
VB
Protected mode As InstanceCollectionMode
Field Value
Type: InstanceCollectionMode
Reference
ReadOnlyInstanceCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyNamespaceCollection.N, T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyNamespaceCollection.N, T. Class
ReadOnlyNamespaceCollection.N, T. Class
Read Only namespace collection
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.N.
TwinCAT.TypeSystem.Generic.ReadOnlyNamespaceCollection.N, T.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlyNamespaceCollection<N, T> : ReadOnlyCollection<N>,
INamespaceCollection<N, T>
where N : Object, INamespace<T>
where T : IDataType
VB
Public Class ReadOnlyNamespaceCollection(Of N As {Object, INamespace(Of T)}, T As IDataType)
Inherits ReadOnlyCollection(Of N)
Implements INamespaceCollection(Of N, T)
Type Parameters
N
T
The ReadOnlyNamespaceCollection.N, T. type exposes the following members.
Constructors
Name | Description
ReadOnlyNamespaceCollection.N, T. | Initializes a new instance of the ReadOnlyNamespaceCollection.N, T. class.
Properties
Name | Description
AllTypes | Gets all types included in all namespaces.
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.N..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.N..)
Item.String. | Gets the element at the specified index.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.N..)
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.N..)
ContainsNamespace | Determines whether this collection contains a namespace with the specified name.
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.N..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.N..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.N..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetNamespace | Tries to get the namespace with the specified name.
TryGetType | Tries to get the specified data type.
TryGetTypeByFullName | Tries to get the specified type (by fullName)
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyNamespaceCollection.N, T. Constructor
•
ReadOnlyNamespaceCollection.N, T. Properties
•
ReadOnlyNamespaceCollection.N, T. Methods


ReadOnlyNamespaceCollection.N, T. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyNamespaceCollection.N, T. Class [image] ReadOnlyNamespaceCollection.N, T. Constructor
ReadOnlyNamespaceCollection.N, T. Constructor
Initializes a new instance of the ReadOnlyNamespaceCollection.N, T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyNamespaceCollection(
NamespaceCollection<N, T> coll
)
VB
Public Sub New (
coll As NamespaceCollection(Of N, T)
)
Parameters
coll
Type: TwinCAT.TypeSystem.Generic.NamespaceCollection.N, T.
The coll.
Reference
ReadOnlyNamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyNamespaceCollection.N, T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyNamespaceCollection.N, T. Class [image] ReadOnlyNamespaceCollection.N, T. Properties
ReadOnlyNamespaceCollection.N, T. Properties
The ReadOnlyNamespaceCollection.N, T. generic type exposes the following members.
Properties
Name | Description
AllTypes | Gets all types included in all namespaces.
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.N..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.N..)
Item.String. | Gets the element at the specified index.
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.N..)
Reference
ReadOnlyNamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyNamespaceCollection.N, T..AllTypes Property
•
ReadOnlyNamespaceCollection.N, T..Item Property


ReadOnlyNamespaceCollection.N, T..AllTypes Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyNamespaceCollection.N, T. Class [image] ReadOnlyNamespaceCollection.N, T. Properties [image] ReadOnlyNamespaceCollection.N, T..AllTypes Property
ReadOnlyNamespaceCollection.N, T..AllTypes Property
Gets all types included in all namespaces.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlyDataTypeCollection<T> AllTypes { get; }
VB
Public ReadOnly Property AllTypes As ReadOnlyDataTypeCollection(Of T)
Get
Property Value
Type: ReadOnlyDataTypeCollection.T.
All types.
Reference
ReadOnlyNamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyNamespaceCollection.N, T..Item Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyNamespaceCollection.N, T. Class [image] ReadOnlyNamespaceCollection.N, T. Properties [image] ReadOnlyNamespaceCollection.N, T..Item Property
ReadOnlyNamespaceCollection.N, T..Item Property
Overload List
Name | Description
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.N..)
Item.String. | Gets the element at the specified index.
Reference
ReadOnlyNamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyNamespaceCollection.N, T..Item Property (String)


ReadOnlyNamespaceCollection.N, T..Item Property (String)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyNamespaceCollection.N, T. Class [image] ReadOnlyNamespaceCollection.N, T. Properties [image] ReadOnlyNamespaceCollection.N, T..Item Property [image] ReadOnlyNamespaceCollection.N, T..Item Property (String)
ReadOnlyNamespaceCollection.N, T..Item Property (String)
Gets the element at the specified index.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public N this[
string name
] { get; }
VB
Public ReadOnly Default Property Item (
name As String
) As N
Get
Parameters
name
Type: System.String
The name.
Return Value
Type: N
Reference
ReadOnlyNamespaceCollection.N, T. Class
Item Overload
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyNamespaceCollection.N, T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyNamespaceCollection.N, T. Class [image] ReadOnlyNamespaceCollection.N, T. Methods
ReadOnlyNamespaceCollection.N, T. Methods
The ReadOnlyNamespaceCollection.N, T. generic type exposes the following members.
Methods
Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.N..)
ContainsNamespace | Determines whether this collection contains a namespace with the specified name.
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.N..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.N..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.N..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetNamespace | Tries to get the namespace with the specified name.
TryGetType | Tries to get the specified data type.
TryGetTypeByFullName | Tries to get the specified type (by fullName)
Reference
ReadOnlyNamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlyNamespaceCollection.N, T..ContainsNamespace Method
•
ReadOnlyNamespaceCollection.N, T..TryGetNamespace Method
•
ReadOnlyNamespaceCollection.N, T..TryGetType Method
•
ReadOnlyNamespaceCollection.N, T..TryGetTypeByFullName Method


ReadOnlyNamespaceCollection.N, T..ContainsNamespace Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyNamespaceCollection.N, T. Class [image] ReadOnlyNamespaceCollection.N, T. Methods [image] ReadOnlyNamespaceCollection.N, T..ContainsNamespace Method
ReadOnlyNamespaceCollection.N, T..ContainsNamespace Method
Determines whether this collection contains a namespace with the specified name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool ContainsNamespace(
string name
)
VB
Public Function ContainsNamespace (
name As String
) As Boolean
Parameters
name
Type: System.String
The name of the namespace
Return Value
Type: Boolean
true if the namespace is contained; otherwise, false.
Reference
ReadOnlyNamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyNamespaceCollection.N, T..TryGetNamespace Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyNamespaceCollection.N, T. Class [image] ReadOnlyNamespaceCollection.N, T. Methods [image] ReadOnlyNamespaceCollection.N, T..TryGetNamespace Method
ReadOnlyNamespaceCollection.N, T..TryGetNamespace Method
Tries to get the namespace with the specified name.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetNamespace(
string name,
out N nspace
)
VB
Public Function TryGetNamespace (
name As String,
<OutAttribute> ByRef nspace As N
) As Boolean
Parameters
name | Type: System.String Namespace name.
nspace | Type: N. The found namespace (out-parameter).
Return Value
Type: Boolean
true if found, false if not contained.
Reference
ReadOnlyNamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyNamespaceCollection.N, T..TryGetType Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyNamespaceCollection.N, T. Class [image] ReadOnlyNamespaceCollection.N, T. Methods [image] ReadOnlyNamespaceCollection.N, T..TryGetType Method
ReadOnlyNamespaceCollection.N, T..TryGetType Method
Tries to get the specified data type.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetType(
string typeName,
out T dataType
)
VB
Public Function TryGetType (
typeName As String,
<OutAttribute> ByRef dataType As T
) As Boolean
Parameters
typeName | Type: System.String Name of the type.
dataType | Type: T. Data Type (out-parameter).
Return Value
Type: Boolean
true if found, false if not contained.
Reference
ReadOnlyNamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlyNamespaceCollection.N, T..TryGetTypeByFullName Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlyNamespaceCollection.N, T. Class [image] ReadOnlyNamespaceCollection.N, T. Methods [image] ReadOnlyNamespaceCollection.N, T..TryGetTypeByFullName Method
ReadOnlyNamespaceCollection.N, T..TryGetTypeByFullName Method
Tries to get the specified type (by fullName)
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetTypeByFullName(
string fullname,
out T dataType
)
VB
Public Function TryGetTypeByFullName (
fullname As String,
<OutAttribute> ByRef dataType As T
) As Boolean
Parameters
fullname | Type: System.String FullName of the data type.
dataType | Type: T. Found Data type (out-parameter).
Return Value
Type: Boolean
true if found, false if not contained.
Reference
ReadOnlyNamespaceCollection.N, T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlySymbolCollection.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlySymbolCollection.T. Class
ReadOnlySymbolCollection.T. Class
Read only symbol collection.
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection.T.
TwinCAT.TypeSystem.Generic.ReadOnlyInstanceCollection.T.
TwinCAT.TypeSystem.Generic.ReadOnlySymbolCollection.T.
TwinCAT.TypeSystem.ReadOnlySymbolCollection
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class ReadOnlySymbolCollection<T> : ReadOnlyInstanceCollection<T>
where T : ISymbol
VB
Public Class ReadOnlySymbolCollection(Of T As ISymbol)
Inherits ReadOnlyInstanceCollection(Of T)
Type Parameters
T
The ReadOnlySymbolCollection.T. type exposes the following members.
Constructors
Name | Description
ReadOnlySymbolCollection.T. | Initializes a new instance of the ReadOnlySymbolCollection.T. class.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.T..)
Item.String. | Gets the element with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.T..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from ReadOnlyInstanceCollection.T..)
Methods
Name | Description
Contains(String) | Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
ContainsName | Determines whether the specified instance is contained. (Inherited from ReadOnlyInstanceCollection.T..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from ReadOnlyInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from ReadOnlyInstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetInstanceByName | Tries to get the instance by name. (Inherited from ReadOnlyInstanceCollection.T..)
Fields
Name | Description
mode | Mode of the IInstanceCollection.T. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
ReadOnlySymbolCollection.T. Constructor
•
ReadOnlySymbolCollection.T. Properties
•
ReadOnlySymbolCollection.T. Methods
•
ReadOnlySymbolCollection.T. Fields


ReadOnlySymbolCollection.T. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlySymbolCollection.T. Class [image] ReadOnlySymbolCollection.T. Constructor
ReadOnlySymbolCollection.T. Constructor
Initializes a new instance of the ReadOnlySymbolCollection.T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySymbolCollection(
IInstanceCollection<T> coll
)
VB
Public Sub New (
coll As IInstanceCollection(Of T)
)
Parameters
coll
Type: TwinCAT.TypeSystem.Generic.IInstanceCollection.T.
The coll.
Reference
ReadOnlySymbolCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlySymbolCollection.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlySymbolCollection.T. Class [image] ReadOnlySymbolCollection.T. Properties
ReadOnlySymbolCollection.T. Properties
The ReadOnlySymbolCollection.T. generic type exposes the following members.
Properties
Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection.T. instance. (Inherited from ReadOnlyCollection.T..)
Item.String. | Gets the element with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Item.Int32. | Gets the element at the specified index. (Inherited from ReadOnlyCollection.T..)
Items | Returns the IList.T. that the ReadOnlyCollection.T. wraps. (Inherited from ReadOnlyCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
ReadOnlySymbolCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlySymbolCollection.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlySymbolCollection.T. Class [image] ReadOnlySymbolCollection.T. Methods
ReadOnlySymbolCollection.T. Methods
The ReadOnlySymbolCollection.T. generic type exposes the following members.
Methods
Name | Description
Contains(String) | Determines whether the ReadOnlyInstanceCollection.T. contains an instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
Contains(T) | Determines whether an element is in the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
ContainsName | Determines whether the specified instance is contained. (Inherited from ReadOnlyInstanceCollection.T..)
CopyTo | Copies the entire ReadOnlyCollection.T. to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from ReadOnlyInstanceCollection.T..)
GetInstanceByName | Gets the IInstance by instance name. (Inherited from ReadOnlyInstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection.T.. (Inherited from ReadOnlyCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the instance with the specified instance path. (Inherited from ReadOnlyInstanceCollection.T..)
TryGetInstanceByName | Tries to get the instance by name. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
ReadOnlySymbolCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


ReadOnlySymbolCollection.T. Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] ReadOnlySymbolCollection.T. Class [image] ReadOnlySymbolCollection.T. Fields
ReadOnlySymbolCollection.T. Fields
The ReadOnlySymbolCollection.T. generic type exposes the following members.
Fields
Name | Description
mode | Mode of the IInstanceCollection.T. (Inherited from ReadOnlyInstanceCollection.T..)
Reference
ReadOnlySymbolCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


SymbolCollection.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolCollection.T. Class
SymbolCollection.T. Class
Interface represents a collection of ISymbol objects.
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.Generic.InstanceCollection.T.
TwinCAT.TypeSystem.Generic.SymbolCollection.T.
TwinCAT.TypeSystem.SymbolCollection
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SymbolCollection<T> : InstanceCollection<T>,
ISymbolCollection<T>, IInstanceCollection<T>, IList<T>, ICollection<T>,
IEnumerable<T>, IEnumerable
where T : class, ISymbol
VB
Public Class SymbolCollection(Of T As {Class, ISymbol})
Inherits InstanceCollection(Of T)
Implements ISymbolCollection(Of T), IInstanceCollection(Of T),
IList(Of T), ICollection(Of T), IEnumerable(Of T),
IEnumerable
Type Parameters
T
The SymbolCollection.T. type exposes the following members.
Properties
Name | Description
Count | Gets the collection count. (Inherited from InstanceCollection.T..)
IsReadOnly | Gets a value indicating whether this instance is read only. (Inherited from InstanceCollection.T..)
Item.Int32. | Gets or sets the IInstance at the specified index. (Inherited from InstanceCollection.T..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from InstanceCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from InstanceCollection.T..)
Methods
Name | Description
Add | Adds the specified item. (Inherited from InstanceCollection.T..)
AddRange | Adds the specified items to this collection. (Inherited from InstanceCollection.T..)
AsReadOnly | Returns a Read only version of this collection (shallow copy).
Clear | Clears this instance. (Inherited from InstanceCollection.T..)
Clone | Clones this instance.
Contains(String) | Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath (Inherited from InstanceCollection.T..)
Contains(T) | Determines whether this collection contains the specified IInstance (Inherited from InstanceCollection.T..)
ContainsName | Determines whether the specified instance name contains name. (Inherited from InstanceCollection.T..)
CopyTo | Copies this InstanceCollection.T. to the specified array. (Inherited from InstanceCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator. (Inherited from InstanceCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from InstanceCollection.T..)
GetInstanceByName | Gets the name of the instance by. (Inherited from InstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of the specified IInstance. (Inherited from InstanceCollection.T..)
Insert | Inserts the specified IInstance at the specified index. (Inherited from InstanceCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified item. (Inherited from InstanceCollection.T..)
RemoveAt | Removes the IInstance at the specified index. (Inherited from InstanceCollection.T..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the IInstance. of the specified path. (Inherited from InstanceCollection.T..)
TryGetInstanceByName | Tries to get Instnaces by name. (Inherited from InstanceCollection.T..)
TryGetInstances | Try to get instances with predicate function
Fields
Name | Description
_list | The _list (Inherited from InstanceCollection.T..)
_pathDict | The _path dictionary (Inherited from InstanceCollection.T..)
mode | The mode this InstanceCollection.T. is working in. (Inherited from InstanceCollection.T..)
Reference
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
SymbolCollection.T. Properties
•
SymbolCollection.T. Methods
•
SymbolCollection.T. Fields


SymbolCollection.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolCollection.T. Class [image] SymbolCollection.T. Properties
SymbolCollection.T. Properties
The SymbolCollection.T. generic type exposes the following members.
Properties
Name | Description
Count | Gets the collection count. (Inherited from InstanceCollection.T..)
IsReadOnly | Gets a value indicating whether this instance is read only. (Inherited from InstanceCollection.T..)
Item.Int32. | Gets or sets the IInstance at the specified index. (Inherited from InstanceCollection.T..)
Item.String. | Gets the IInstance with the specified instance path. (Inherited from InstanceCollection.T..)
Mode | Gets the InstanceCollectionMode. (Inherited from InstanceCollection.T..)
Reference
SymbolCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


SymbolCollection.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolCollection.T. Class [image] SymbolCollection.T. Methods
SymbolCollection.T. Methods
The SymbolCollection.T. generic type exposes the following members.
Methods
Name | Description
Add | Adds the specified item. (Inherited from InstanceCollection.T..)
AddRange | Adds the specified items to this collection. (Inherited from InstanceCollection.T..)
AsReadOnly | Returns a Read only version of this collection (shallow copy).
Clear | Clears this instance. (Inherited from InstanceCollection.T..)
Clone | Clones this instance.
Contains(String) | Determines whether this collection contains an IInstance with the specified InstanceName / InstancePath (Inherited from InstanceCollection.T..)
Contains(T) | Determines whether this collection contains the specified IInstance (Inherited from InstanceCollection.T..)
ContainsName | Determines whether the specified instance name contains name. (Inherited from InstanceCollection.T..)
CopyTo | Copies this InstanceCollection.T. to the specified array. (Inherited from InstanceCollection.T..)
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator. (Inherited from InstanceCollection.T..)
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetInstance | Gets the IInstanceby instance path. (Inherited from InstanceCollection.T..)
GetInstanceByName | Gets the name of the instance by. (Inherited from InstanceCollection.T..)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of the specified IInstance. (Inherited from InstanceCollection.T..)
Insert | Inserts the specified IInstance at the specified index. (Inherited from InstanceCollection.T..)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified item. (Inherited from InstanceCollection.T..)
RemoveAt | Removes the IInstance at the specified index. (Inherited from InstanceCollection.T..)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryGetInstance | Tries to get the IInstance. of the specified path. (Inherited from InstanceCollection.T..)
TryGetInstanceByName | Tries to get Instnaces by name. (Inherited from InstanceCollection.T..)
TryGetInstances | Try to get instances with predicate function
Reference
SymbolCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
SymbolCollection.T..AsReadOnly Method
•
SymbolCollection.T..Clone Method
•
SymbolCollection.T..TryGetInstances Method


SymbolCollection.T..AsReadOnly Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolCollection.T. Class [image] SymbolCollection.T. Methods [image] SymbolCollection.T..AsReadOnly Method
SymbolCollection.T..AsReadOnly Method
Returns a Read only version of this collection (shallow copy).
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public ReadOnlySymbolCollection<T> AsReadOnly()
VB
Public Function AsReadOnly As ReadOnlySymbolCollection(Of T)
Return Value
Type: ReadOnlySymbolCollection.T.
ReadOnlySymbolCollection<T>.
Reference
SymbolCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


SymbolCollection.T..Clone Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolCollection.T. Class [image] SymbolCollection.T. Methods [image] SymbolCollection.T..Clone Method
SymbolCollection.T..Clone Method
Clones this instance.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolCollection<T> Clone()
VB
Public Function Clone As SymbolCollection(Of T)
Return Value
Type: SymbolCollection.T.
SymbolCollection<T>.
Reference
SymbolCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


SymbolCollection.T..TryGetInstances Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolCollection.T. Class [image] SymbolCollection.T. Methods [image] SymbolCollection.T..TryGetInstances Method
SymbolCollection.T..TryGetInstances Method
Try to get instances with predicate function
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool TryGetInstances(
Func<T, bool> predicate,
bool recurse,
out IList<T> instances
)
VB
Public Function TryGetInstances (
predicate As Func(Of T, Boolean),
recurse As Boolean,
<OutAttribute> ByRef instances As IList(Of T)
) As Boolean
Parameters
predicate | Type: System.Func.T, Boolean. The predicate function
recurse | Type: System.Boolean if set to true the symbol hierarchy will be searched recursively.
instances | Type: System.Collections.Generic.IList.T.. The instances.
Return Value
Type: Boolean
true if XXXX, false otherwise.
Reference
SymbolCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


SymbolCollection.T. Fields

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolCollection.T. Class [image] SymbolCollection.T. Fields
SymbolCollection.T. Fields
The SymbolCollection.T. generic type exposes the following members.
Fields
Name | Description
_list | The _list (Inherited from InstanceCollection.T..)
_pathDict | The _path dictionary (Inherited from InstanceCollection.T..)
mode | The mode this InstanceCollection.T. is working in. (Inherited from InstanceCollection.T..)
Reference
SymbolCollection.T. Class
TwinCAT.TypeSystem.Generic Namespace


SymbolIterationMask Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterationMask Enumeration
SymbolIterationMask Enumeration
Mask Flagset to specify filters for SymbolIterator.T..
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[FlagsAttribute]
public enum SymbolIterationMask
VB
<FlagsAttribute>
Public Enumeration SymbolIterationMask
Members
Member name | Value | Description
None | 0 | Uninitialized / None
Structures | 1 | Iterates over Subelements of Structs
Arrays | 2 | Iterates over Elements of Arrays
Unions | 4 | Iterates over Subelements of Unions
Pointer | 8 | Iterates over Pointer SubElements
References | 16 | Iterates over References
All | 31 | Iterates over All Complex/Combined types
Reference
TwinCAT.TypeSystem.Generic Namespace


SymbolIterator.T. Class

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterator.T. Class
SymbolIterator.T. Class
Symbol iterator object
Inheritance Hierarchy
System.Object
TwinCAT.TypeSystem.Generic.SymbolIterator.T.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public class SymbolIterator<T> : IEnumerable<T>,
IEnumerable
where T : ISymbol
VB
Public Class SymbolIterator(Of T As ISymbol)
Implements IEnumerable(Of T), IEnumerable
Type Parameters
T
Concrete ISymbol type.
The SymbolIterator.T. type exposes the following members.
Constructors
Name | Description
SymbolIterator.T.(IInstanceCollection.T.) | Initializes a new instance of the SymbolIterator.T. class.
SymbolIterator.T.(IEnumerable.T., Boolean) | Initializes a new instance of the SymbolIterator.T. class.
SymbolIterator.T.(IInstanceCollection.T., Func.T, Boolean.) | Initializes a new instance of the SymbolIterator.T. class.
SymbolIterator.T.(IEnumerable.T., Boolean, Func.T, Boolean.) | Initializes a new instance of the SymbolIterator.T. class.
Properties
Name | Description
Mask | Gets or sets the SymbolIterationMask
SymbolRecursionDetection | Gets or sets a value indicating whether the iterator checks for Symbol recursions (true by default).
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator that enumerates through a collection
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Remarks
Iterates over all root symbols and its sub symbols.
Reference
TwinCAT.TypeSystem.Generic Namespace
System.Collections.Generic.IEnumerable.T.
Weiterführende Informationen
•
SymbolIterator.T. Constructor
•
SymbolIterator.T. Properties
•
SymbolIterator.T. Methods


SymbolIterator.T. Constructor

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterator.T. Class [image] SymbolIterator.T. Constructor
SymbolIterator.T. Constructor
Overload List
Name | Description
SymbolIterator.T.(IInstanceCollection.T.) | Initializes a new instance of the SymbolIterator.T. class.
SymbolIterator.T.(IEnumerable.T., Boolean) | Initializes a new instance of the SymbolIterator.T. class.
SymbolIterator.T.(IInstanceCollection.T., Func.T, Boolean.) | Initializes a new instance of the SymbolIterator.T. class.
SymbolIterator.T.(IEnumerable.T., Boolean, Func.T, Boolean.) | Initializes a new instance of the SymbolIterator.T. class.
Reference
SymbolIterator.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
SymbolIterator.T. Constructor (IInstanceCollection.T.)
•
SymbolIterator.T. Constructor (IEnumerable.T., Boolean)
•
SymbolIterator.T. Constructor (IInstanceCollection.T., Func.T, Boolean.)
•
SymbolIterator.T. Constructor (IEnumerable.T., Boolean, Func.T, Boolean.)


SymbolIterator.T. Constructor (IInstanceCollection.T.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterator.T. Class [image] SymbolIterator.T. Constructor [image] SymbolIterator.T. Constructor (IInstanceCollection.T.)
SymbolIterator.T. Constructor (IInstanceCollection.T.)
Initializes a new instance of the SymbolIterator.T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolIterator(
IInstanceCollection<T> coll
)
VB
Public Sub New (
coll As IInstanceCollection(Of T)
)
Parameters
coll
Type: TwinCAT.TypeSystem.Generic.IInstanceCollection.T.
The root symbols.
Reference
SymbolIterator.T. Class
SymbolIterator.T. Overload
TwinCAT.TypeSystem.Generic Namespace


SymbolIterator.T. Constructor (IEnumerable.T., Boolean)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterator.T. Class [image] SymbolIterator.T. Constructor [image] SymbolIterator.T. Constructor (IEnumerable.T., Boolean)
SymbolIterator.T. Constructor (IEnumerable.T., Boolean)
Initializes a new instance of the SymbolIterator.T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolIterator(
IEnumerable<T> coll,
bool recurse
)
VB
Public Sub New (
coll As IEnumerable(Of T),
recurse As Boolean
)
Parameters
coll | Type: System.Collections.Generic.IEnumerable.T. The root collection
recurse | Type: System.Boolean if set to true the iterator will iterate recursively.
Reference
SymbolIterator.T. Class
SymbolIterator.T. Overload
TwinCAT.TypeSystem.Generic Namespace


SymbolIterator.T. Constructor (IInstanceCollection.T., Func.T, Boolean.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterator.T. Class [image] SymbolIterator.T. Constructor [image] SymbolIterator.T. Constructor (IInstanceCollection.T., Func.T, Boolean.)
SymbolIterator.T. Constructor (IInstanceCollection.T., Func.T, Boolean.)
Initializes a new instance of the SymbolIterator.T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolIterator(
IInstanceCollection<T> coll,
Func<T, bool> predicate
)
VB
Public Sub New (
coll As IInstanceCollection(Of T),
predicate As Func(Of T, Boolean)
)
Parameters
coll | Type: TwinCAT.TypeSystem.Generic.IInstanceCollection.T. The root symbols.
predicate | Type: System.Func.T, Boolean. The predicate.
Exceptions
Exception | Condition
NotSupportedException |
Reference
SymbolIterator.T. Class
SymbolIterator.T. Overload
TwinCAT.TypeSystem.Generic Namespace


SymbolIterator.T. Constructor (IEnumerable.T., Boolean, Func.T, Boolean.)

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterator.T. Class [image] SymbolIterator.T. Constructor [image] SymbolIterator.T. Constructor (IEnumerable.T., Boolean, Func.T, Boolean.)
SymbolIterator.T. Constructor (IEnumerable.T., Boolean, Func.T, Boolean.)
Initializes a new instance of the SymbolIterator.T. class.
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolIterator(
IEnumerable<T> coll,
bool recurse,
Func<T, bool> predicate
)
VB
Public Sub New (
coll As IEnumerable(Of T),
recurse As Boolean,
predicate As Func(Of T, Boolean)
)
Parameters
coll | Type: System.Collections.Generic.IEnumerable.T. Input collection (root objects).
recurse | Type: System.Boolean if set to true the iterator will iterate recursively.
predicate | Type: System.Func.T, Boolean. The predicate.
Reference
SymbolIterator.T. Class
SymbolIterator.T. Overload
TwinCAT.TypeSystem.Generic Namespace


SymbolIterator.T. Properties

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterator.T. Class [image] SymbolIterator.T. Properties
SymbolIterator.T. Properties
The SymbolIterator.T. generic type exposes the following members.
Properties
Name | Description
Mask | Gets or sets the SymbolIterationMask
SymbolRecursionDetection | Gets or sets a value indicating whether the iterator checks for Symbol recursions (true by default).
Reference
SymbolIterator.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
SymbolIterator.T..Mask Property
•
SymbolIterator.T..SymbolRecursionDetection Property


SymbolIterator.T..Mask Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterator.T. Class [image] SymbolIterator.T. Properties [image] SymbolIterator.T..Mask Property
SymbolIterator.T..Mask Property
Gets or sets the SymbolIterationMask
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public SymbolIterationMask Mask { get; set; }
VB
Public Property Mask As SymbolIterationMask
Get
Set
Property Value
Type: SymbolIterationMask
The mask.
Remarks
This property can be used for prefiltering the iterator without using a predicate function.
Reference
SymbolIterator.T. Class
TwinCAT.TypeSystem.Generic Namespace


SymbolIterator.T..SymbolRecursionDetection Property

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterator.T. Class [image] SymbolIterator.T. Properties [image] SymbolIterator.T..SymbolRecursionDetection Property
SymbolIterator.T..SymbolRecursionDetection Property
Gets or sets a value indicating whether the iterator checks for Symbol recursions (true by default).
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public bool SymbolRecursionDetection { get; set; }
VB
Public Property SymbolRecursionDetection As Boolean
Get
Set
Property Value
Type: Boolean
true if recursion checking, false switched off check.
Reference
SymbolIterator.T. Class
TwinCAT.TypeSystem.Generic Namespace


SymbolIterator.T. Methods

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterator.T. Class [image] SymbolIterator.T. Methods
SymbolIterator.T. Methods
The SymbolIterator.T. generic type exposes the following members.
Methods
Name | Description
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets the enumerator that enumerates through a collection
GetHashCode | Serves as the default hash function. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Reference
SymbolIterator.T. Class
TwinCAT.TypeSystem.Generic Namespace
Weiterführende Informationen
•
SymbolIterator.T..GetEnumerator Method


SymbolIterator.T..GetEnumerator Method

TwinCAT.Ads Namespaces [image] TwinCAT.TypeSystem.Generic Namespace [image] SymbolIterator.T. Class [image] SymbolIterator.T. Methods [image] SymbolIterator.T..GetEnumerator Method
SymbolIterator.T..GetEnumerator Method
Gets the enumerator that enumerates through a collection
Namespace: TwinCAT.TypeSystem.Generic
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
public IEnumerator<T> GetEnumerator()
VB
Public Function GetEnumerator As IEnumerator(Of T)
Return Value
Type: IEnumerator.T.
A IEnumerator.T. that can be used to iterate through the collection.
Implements
IEnumerable.T..GetEnumerator.
Reference
SymbolIterator.T. Class
TwinCAT.TypeSystem.Generic Namespace


TwinCAT.ValueAccess Namespace

TwinCAT.Ads Namespaces [image] TwinCAT.ValueAccess Namespace
TwinCAT.ValueAccess Namespace
Namespace for the common (non ADS dependant) value access.
Enumerations
Enumeration | Description
SymbolNotificationType | Specifies the Notification type of ADS Notifications
ValueCreationMode | Creation mode for Values
Weiterführende Informationen
•
SymbolNotificationType Enumeration
•
ValueCreationMode Enumeration


SymbolNotificationType Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.ValueAccess Namespace [image] SymbolNotificationType Enumeration
SymbolNotificationType Enumeration
Specifies the Notification type of ADS Notifications
Namespace: TwinCAT.ValueAccess
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[FlagsAttribute]
public enum SymbolNotificationType
VB
<FlagsAttribute>
Public Enumeration SymbolNotificationType
Members
Member name | Value | Description
None | 0 | None / Uninitialized
Value | 1 | ValueChanged notifications
RawValue | 2 | RawValueChanged notifications
Both | 3 | ValueChanged + RawValueChanged notifications
Reference
TwinCAT.ValueAccess Namespace


ValueCreationMode Enumeration

TwinCAT.Ads Namespaces [image] TwinCAT.ValueAccess Namespace [image] ValueCreationMode Enumeration
ValueCreationMode Enumeration
Creation mode for Values
Namespace: TwinCAT.ValueAccess
Assembly: TwinCAT.Ads (in TwinCAT.Ads.dll) Version: 4.3.0.0
Syntax
C#
[FlagsAttribute]
public enum ValueCreationMode
VB
<FlagsAttribute>
Public Enumeration ValueCreationMode
Members
Member name | Value | Description
None | 0 | None / Uninitialized Mask
Primitives | 1 | Convert to .NET Primitives, wherever possible.
Enums | 2 | Use IEnumValue on EnumTypes instead of .NET Primitives
FullDynamics | 4 | Wraps all Primitives also in IValue Objects
PlcOpenTypes | 8 | Use PlcOpen Times (TIME, LTIME, DT, TOD, DATETIME) instead of .NET Primitives DateTime and TimeSpan
Default | 1 | Default settings for the value creation mode (Translate to Primitives)
Remarks
This setting is used by the ValueFactory/ to create Read values. In default primitive mode all values will be transferred to Primitive .NET Symbols if possible. E.g PlcOpen.TIME --> TimeSpan, IEnumValue --> .NET Primitives. They won't be wrapped into
Reference
TwinCAT.ValueAccess Namespace