SW OS - Betriebssystem für CX1000/CX10x0/CX90x0/Ethernet Panels/IPC...

Betriebssysteme

Dokumentation zu

SW OS

Betriebssystem für CX1000/CX10x0/CX90x0/Ethernet Panels/IPC...

Version: 1.1
Datum:


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr |
DangerNV | Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung |
AttentionNV | Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis |
NoteNV | Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Version Änderungen

1.1

  • Adaption to customer needs
  • Scada Solutions


Übersicht

Betriebssysteme

Betriebssysteme für CX1000/CX10x0/CX90x0/Ethernet Panels/IPC...

Für den CX10xx ( CX Geräte des Typs CX1000 oder CX1020) sind zwei Betriebssysteme verfügbar, Windows CE.NET und Windows XP Embedded.

Für den CX9000 ist nur das Windows CE.NET Betriebssystem verfügbar.

Remote Programmierung über Ethernet

Dies ist der Fall, wenn die Basiseinheit mit Windows CE.NET ausgestattet wird. Dann erfolgt die Programmierung über ein Laptop oder einen Desktop-PC, der über Ethernet (Netzwerk oder Crossover-Cable) mit dem CX10xx verbunden ist. Die Programme werden mit einer Standard TwinCAT Softwarelizenz auf dem Laptop entwickelt und dann in das Zielgerät geladen.

Die Entscheidung, welche Betriebssystemvariante und welche TwinCAT Version mit dem CX10xx System gewählt werden sollte, ist stark applikationsspezifisch.

Nachfolgend finden Sie eine Übersicht der Basis Betriebssystem Images.


CE Device: Welcome

Betriebssysteme

Willkommen

Willkommen in der Welt der Beckhoff CE Geräte. In diesem Kapitel finden Sie Informationen zu

  • Start-/Bootphase der Geräte
  • User Shell
    • Wie die User Shell passwortgeschützt werden kann, oder wie das Wallpaper geändert werden kann.
  • Konfigurationswerkzeuge
    • "CxConfig" ermöglicht die Konfiguration lokal auf dem Gerät
      Wählen Sie "Start --> Control Panel --> CxConfig"
    • "Remote Display" bietet ähnliche Funktionalitäten wie "RDP" oder "VNC" durch eine Remote Anzeige des CE Shells am Host PC
      Siehe "Remote Display"
    • "TwinCAT System Manager" erlaubt die Konfiguration der Basisfunktionalitäten
      Siehe "System Manager"
    • "Web based configuration" : Alle CE Geräte bieten Webseiten zur einfachen Remote Konfiguration
      Siehe "Web based configuration"

      HINWEIS: Achten Sie darauf, die Sicherheit zu aktivierten, wenn die Web aktivierte Konfiguration nicht verfügbar sein soll.
  • Implementation der Software mit Visual Studio 20xx
    • Artikel über die Implementation von Applikationen und Remote debugging auf BECKHOFF CE Geräten.
  • Verfügbarkeit der Scada Software
    • Übersicht der Scadapakte mit integriertem TwinCAT Treiber
  • Update Firmware / CE-Images
    • Beschreibung des Imageupdates für die verschiedenen BECKHOFF CE Geräte

Erste Eindrücke

Nach dem Start des BECKHOFF CE Geräts, sieht die Shell (user shell) folgendermaßen aus, abhängig von der Version des Betriebssystems:

  • CE6 :
    • In der Standardeinstellung bootet das CE Gerät mit einer modifizierten Microsoft CE Shell, die so aussieht:

  • CE4 / CE5 :
    • In der Standardeinstellung bootet das CE Gerät mit der Microsoft Standard Shell mit diesem Wallpaper (möglicherweise mit einem anderen CE Logo):
    • Um die Wallpaper oder die Shell zu ändern, lesen Sie bitte diesen Artikel.


User Shell

In der Standardeinstellung starten die CE Geräte mit einem modifizierten Microsoft CE Shell wie diesem hier (CE6 ++)

Dieses modifizierte Shell schützt das CE Gerät, so dass Sie als Anwender folgendes tun können:

  • Optional: Ein Gerätepasswort ("Admin password") einmalig konfigurieren. Damit können Sie verhindern, dass (andere) Benutzer in der Microsoft Shell eigene Konfigurationen vornehmen.
  • Optional: Applikationen so konfigurieren, dass sie automatisch starten, siehe Artikel

Optional: Konfiguration des Admin-Geräte Passwort

  • Wählen Sie "Start --> Control Panel --> Password"
  • Geben Sie im Feld "Password" ein Passwort ein und bestätigen Sie mit "Confirm password"
  • Beenden Sie die Konfiguration mit "OK"

Nach einem Reboot kann der Benutzer keine Dialogeinstellungen zur Rekonfiguration vornehmen, ohne das Passwort einzugeben.

Starten des Windows Explorer

Wenn Sie den Windows Explorer während der Startphase öffnen wollen::

  • Wählen Sie "Start --> Run..." geben Sie im Feld "Open" "explorer" an und beenden Sie den Dialog mit "OK"


Wallpaper

Nutzer können ein eigenes Wallpaper als Hintergrundbild auswählen.

Allgemein:

Das CE-Gerät startet standardgemäß mit der Microsoft CE Standardshell mit folgendem Wallpaper:

Um das Wallpaper zu ändern, benötigen Sie eine Bitmap-Datei *.BMP vom CE-Gerät. Dann erstellen Sie einen Registry-Eintrag, der auf das Wallpaper-Bitmap verweist.

BEISPIEL

  • Verwenden Sie ein Bitmap (mit entsprechender Bildschirmauflösung) vom CE-Gerät, z.B.: "\hard disk\MyProject\WishToBeHere.bmp"
  • Geben Sie den Registry-Key ein, um das Bitmap als Standardwallpaper zu verwenden
[HKEY_CURRENT_USER\ControlPanel\Desktop]
"wallpaper"="\hard
disk\MyProject\WishToBeHere.bmp"

Weitere Information siehe einfache Imageanpassung durch den Kunden.

Das geänderte Wallpaper könnte so aussehen:


Remote Display

Diese Seite beschreibt die Schritte um ein CE-Gerät mit CE Betriebssystem von einem weiteren PC per "Remote Display" fernzusteuern.

1. Voraussetzungen:

Erforderliche Software auf dem Host-PC:

  • Windows NT/2000/XP
  • Microsoft Remote Display (lizenzfrei bei Microsoft erhältlich)
    RemoteDisplay für den CX1000

Erforderliche Hardware:

  • Eine TCP/IP Verbindung zwischen dem CE-Gerät und dem Host-PC

2. Verbindungsaufbau:

1. Auf dem PC wird das Tool "Remote Display" gestartet. Unter dem Menüpunkt "File -> Connect" kann nun die Adresse des CE-Gerätes eingetragen werden, dabei kann sowohl die TCP-IP Adresse oder falls vorhanden auch der Name des CE-Gerätes eingetragen werden.

Ist das CE Gerät mit einem Passwortschutz versehen, so muss auch das Passwort entsprechend eingetragen werden.

2. Nach Eintrag der Zieladresse steht die Oberfläche des CE-Gerätes zur Remote-Bedienung auf dem PC zur Verfügung.


Web basierende Diagnose / Konfigurationsoberfl che

Betriebssysteme

Beckhoff Device Manager:
Web-basierende Diagnose- und Konfigurations-Schnittstelle

Für Windows CE-basierende Geräte steht ab dem Image 2.16 eine Web-basierende Konfigurations- und Diagnoseschnittstelle zur Verfügung. Hier können die wichtigsten Geräteeinstellungen vorgenommen werden.

Mehr Informationen zum Beckhoff Device Manager finden Sie hier: Beckhoff Device Manager

Security:
- Ab Image 2.16: Der Zugriff kann ber den Dialog "Security" eingeschränkt werden.
- Ab Image 3.08: Der Zugriff ist per Default mit einem Passwort versehen.

-> Dieses Passwort sollte bei der Inbetriebnahme des Gerätes vom Anwender auf ein eigenes Passwort umgestellt werden!

Der Aufruf erfolgt im IE Browser (oder anderen Browsern) mit folgenden Angaben

- Ab Image 2.16
http://<ip-oder-Gerätename>:5120/upnpdevice/index.htm

Beispiele :
http://192.168.0.123:5120/upnpdevice/index.htm
http://CX_123456:5120/upnpdevice/index.htm

- Ab Image 3.08
http://<ip-oder-Gerätename/config

Beispiele:
http://192.168.0.123/config
http://CX_123456/config


Modifikation das Standardimages

Betriebssysteme

Modifikation des Standardimages

Einleitung

Die CE Geräte werden mit einem Standard CE Image ausgeliefert, welches allgemeine Einstellungen wie Bildschirmauflösung, DHCP, usw., enthält.

Nachfolgend wird beschrieben, wie die Basiseinstellungen bzw. das Basisverhalten eines Standard CE Images verändert werden können.

Prinzipiell können die Einstellungen am CE Gerät durch Dialoge vorgenommen werden. Wenn das modifizierte Image jedoch auf mehreren CE Geräten angewendet werden soll ist es sinnvoll, die Einstellungen direkt in der Registry vorzunehmen, und danach das Image auf die Geräte zu verteilen. So wird die Konfiguration eines jeden einzelnen Geräts vermieden.

Die Modifikation ist nur einmal notwendig und erlaubt ein einfaches Handling bei Anwendung auf mehreren CE Geräten, besonders beim Update von Image Versionen.

In der Beispielliste finden Sie Hinweise, wie die Einstellungen für FTP, RAS, Regional settings, Taskbar, Timebase, Gerätename, Bildschirmauflösung, Wallpaper vorgenommen werden können.

HINWEIS :
Einige Reg-Files sind Hardware-Plattform unabhängig und können somit auf CX1020 oder C69xx Geräte eingespielt werden (Betriebssystem Einstellungen, Wallpaper, FTP etc.)
Andere Einstellungen (wie IP Adresse, Bildschirmauflösung etc.) können sich auf den Geräten unterscheiden.

Beispiele hier

Alle möglichen Modifikationen, die hier aufgelistet sind, können bei jedem Start des CE Gerätes vorgenommen werden, oder einmalig bei der Erstellung einer Standard Registry:

  • Beispiele für Registry Einstellungen :
    • Einstellung spezifischer Bildschirmauflösungen
    • Netzwerkinformationen wie TCP/IP Adresse
    • Gerätename
    • Standard Shell ausblenden
    • Starten von kundenspezifischen Applikationen
    • Starten des RDP Clients (Remote Desktop Client zur automatischen Verbindung mit der XP Station)
    • Konfiguration des SNTP (Simple network time protocol)
    • RAS Server
    • FTP Server
    • Eigenes Wallpaper definieren
    • TwinCAT spezifische Einstellungen wie ADS Routes
    • Unterstützung der Audio Module
    • ....
  • Alle Arten der User Management Verwaltung, die zur NTLM Benutzerauthentifikation erforderlich sind

    • Benutzer hinzufügen/entfernen, Passwort für RAS Server
    • Benutzer hinzufügen/entfernen, Passwort für FTP-Server und SMB-Server (öffentliche Ordner) Zugriff

Startup / Booten von CE Geräten

Die Vorgehensweise ist wie folgt:

Schritt 1 : Power an CE Hardware

Nach dem Einschalten des CE Geräts versucht der CE Loader/BIOS die CF Karte mit der NK.BIN Datei zu finden. Die NK.BIN Datei enthält das komplette CE Betriebssystem und TwinCAT.

Wenn die Datei NK.BIN verfügbar ist, wird sie in das RAM geladen und ausgeführt. Falls einer dieser Schritte fehlschlägt, sendet das Gerät Zeichen, wie z.B. eine Meldung auf dem Display oder eine blinkende LED, usw.

Schritt 2 : Prüfung : Standard Registry verfügbar oder nicht?

Während des Bootens wird die NK.BIN Datei von der CF Karte geladen und ausgeführt. Dazu sucht das CE Gerät auf der CF Karte nach dem Ordner "Dokumente und Einstellungen". Dieser Ordner enthält die Registry mit allen Einstellungen. Falls dieser Ordner eine Registry enthält, die der Version der gestarteten NK.BIN Datei entspricht, werden alle Einstellungen aus dieser Registry gelesen.

Die Registry kann von der NK.BIN Datei abweichen, wenn die Datei mit CE 4.2 erstellt wurde, und nicht mit einer NK.BIN Datei CE5 gehandelt werden kann. Möglicherweise werden ältere Registrys nicht von unterschiedliche Image Versionen des gleichen CE Levels unterstützt.

Jedenfalls gilt: Wenn die Registry Version nicht der Version der NK.BIN Datei entspricht, oder wenn der Order "Dokumente und Einstellungen" nicht zu finden ist, erstellt das CE System eine neue Standard Registry und speichert diese zurück in den Ordner "Dokumente und Einstellungen" der CF Karte.

Step 3 : Standard Registry verfügbar

Nach diesen beiden Schritten ist die Standard Registry verfügbar, so dass wir davon ausgehen können, dass wir über ein CE Gerät mit einer Standard Registry verfügen.

Unter "HKLM\Init" enthält die Registry Informationen über Applikationen.

Die Registry kann folgendermaßen aussehen:

[HKEY_LOCAL_MACHINE\init]
"Launch20"="device.exe"
"Launch30"="gwes.exe"
"Depend30"=hex:14,00
"Launch60"="services.exe"
"Depend60"=hex:14,00
"Launch50"="explorer.exe"
"Depend50"=hex:14,00,1e,00
"Launch90"="CeRDisp.exe"
"Depend90"=hex:14,00,1e,00,32,00,50,00
"Launch80"="TcSysSrvW32.exe"
"Depend80"=hex:14,00,1e,00,32,00
"Launch96"="\\hard
disk\\system\\Startup.exe"
"Depend96"=hex:14,00,1e,00,32,00,50,00,5a,00

Zum Starten von “device.exe”, “gwes.exe”, “service.exe” muss CE OS laufen. Die anderen Anwendungen sind optional.

  • explorer .exe startet Default-Shell (siehe Nutzung einer alternativen Shell)
  • CeRdisp.exe startet den CE-RemoteDisplay Server (zugänglich vom Host-PC über CeRHost.exe)
  • TcSysSrvW32.exe startet TwinCAT
  • \hard disk\system\Startup.exe startet verschiedene Tools (falls vorhanden), z.B.
    • \hard disk\system\CxRunOnce.cmd (läuft nur einmal nach der Erstellung der ersten Registry)
    • \hard disk\system\autoexec.cmd (bei jedem Start des CE-Geräts)
    • \hard disk2\system\autoexec.cmd (bei jedem Start des CE-Geräts, Laufwerk 2 könnte ein externer MemoryStick sein, der beim Booten verfügbar ist)
    • \hard disk\system\CeRdpAutoClient.exe (Anwendung ähnlich RDP-Client starten. Anschluss muss vorkonfiguriert sein)
    • verschiedene Scada-Pakete anderer Hersteller

Optionen, nur einmal bei Inbetriebnahme auszuführen

Beim ersten Booten– sofort nach Aufbau der Standard-Registry – führt auch die Anwendung “Startup” einiges nur einmal aus (nicht bei jedem Booten des Systems)

a. Option : Registry-Einstellungen importieren (falls vorhanden)

Beim ersten Booten– sofort nach Aufbau der Standard-Registry – importiert auch “Startup” alle Registry-Dateien aus dem Ordner “hard disk\RegFiles”.
Nach dem Import der Registry und deren Speicherung auf der CF-Karte bootet das Gerät automatisch neu.
Mit dieser Funktion kann man spezifische Einstellungen des Geräts kopieren, indem man nur den Order “RegFiles” auf eine CF-Karte kopiert.

In der Beispielliste finden Sie Hinweise, wie Einstellungen für FTP, RAS, Regional settings, Taskbar, Timebase, Gerätename, Bildschirmauflösung, Wallpaper verändert werden können.
HINWEIS: Die Beispiele sind für CX100x Geräte mit CE. Die Registry-Einstellungen können sich von denen für andere Geräte z. B. CX1020, CX9000 oder Ethernetpanels unterscheiden.

b. Option : Batch Datei CxRunOnce ausführen (falls vorhanden)

Beim ersten Booten– sofort nach Aufbau der ersten Registry – ruft “Startup” "\hard disk\System\CxRunOnce.cmd" auf (wenn vorhanden) Hier können kundenspezifische Änderungen vorgenommen werden..

Für Verbindung zu RAS oder zum Schutz des Zugangs zu FTP oder SMB (öffentlicher Ordner) wird u.U. “NTLM Users” benötigt, um Berechtigungsnachweise für User vergeben zu können .

Mit dem Befehlszeilen Tool “CxAddUser” im Ordner “\hard disk\system” können Berechtigungsnachweise vergeben werden; die Batch-Einträge sollten in CxRunOnce.cmd erfolgen.

Siehe ausführliche Informationen zum Hinzufügen von Usern.

Optionen, die bei jedem Booten ausgeführt werden

a. Option : AutoExec.cmd ausführen (falls vorhanden)

Bei jedem Booten ruft “Startup” auch “hard disk\System\autoexec.cmd” auf (falls vorhanden). Kundenspezifische Einstellungen/Aufrufe hier eintragen..

b. Option : CeRdpAutoClient.exe ausführen (falls vorhanden)

Bei jedem Booten ruft “Startup” auch "\hard disk\System\CeRdpAutoClient.exe" auf (falls vorhanden). RDP-Client ermöglicht die Verbindung und Anzeige von RDP-Servern (Standard : Ein CE-System zeigt eine XP/SPE-Maschine an)


Name / TCP-IP / AdsNetId / Bildschirmauflösung

Allgemein:

Name und AdsNetID des CE-Geräts werden standardmäßig von der eindeutigen MAC ID des Geräts abgeleitet.

Sie finden die MAC ID auf dem Etikett am CE-Gerät.

Der IP-Port wird standardmäßig auf DHCP gesetzt.

Beispiel:

  • Name des CE-Geräts:
    Der Name des Geräts ist standardmäßig eine Kombination aus einem Präfix (z.B. “CX” für CX-Geräte oder “CP” für Control Panels) und den letzten drei Bytes der eindeutigen MAC ID des Geräts.

    Beispiel: Die MAC ID 00-01-05-00-27-84 ergibt:

    • den Gerätenamen CX_002784 (für CE-Geräte wie CX1000 / CX1020 / CX9000 ...)
    • den Gerätenamen CP_002784 (für CE-Geräte wie EthernetPanel...)
  • AdsNetId des CE-Geräts:
    Diese AmsNetId besteht standardmäßig aus einer Kombination der letzten vier Stellen der eindeutigen Mac ID des CE-Gerätes mit der Erweiterung “1.1”.

    Beispiel: Die MAC ID 00-01-05-00-27-84 ergibt die AmsNetID 5.0.39.132.1.1

Änderung der Grundeinstellungen

Sie können Ihre eigenen Einstellungen unterschiedlich auswählen und zuweisen:

  • Option 1:
    Die Änderungen können einfach vom TwinCAT System Manager durchgeführt werden:
    Er schreibt die neuen Einstellungen an die richtige Adresse in der Registry des CE-Geräts, speichert die geänderte Registry auf die Compact-Flash-Karte und fordert gegebenenfalls einen automatischen Neustart des Geräts.

  • Option 2:
    Die Änderung kann lokal am CE-Gerät erfolgen:
    • Gerätename: Wählen Sie “Start” --> “Settings” --> “Control Panel” --> “System” --> “Device Name” und ändern Sie das Feld “Device name”
    • IP-Einstellungen: Wählen Sie “Start” --> “Settings” --> “Control Panel” --> “Network and Dial-up Connections” --> “PCI-T...” und ändern Sie die IP-Einstellungen
  • Option 3:
    Bereiten Sie eine oder mehrere Registry-Dateien vor und legen diese im CE-Gerät unter “\hard disk\RegFiles” ab
    Auf dem CE-Gerät können Sie sie dann mit einem Doppelklick auf regfile in die Registry importieren.

    HINWEIS: Wird die Registry gelöscht, werden die Registry-Dateien automatisch importiert und das Gerät neu gestartet.
    Weitere Information siehe einfache Imageanpassung durch den Kunden.

Note:

Die ersten drei Buchstaben des Gerätenamens sind per default vorbelegt (z.B. "CX_" or "CP_" )

  • Eine Umbenennung zu "Machine1" ist möglich
  • Eine Umbenennung zu "CX_Machine1" ist nicht erlaubt und nicht möglich: Mit dem nächsten Reboot wird der ursprüngliche Name "CX_.." wieder hergestellt.
    Grund ist, dass diese Funktion ermöglicht eine Master-CF Karte vorzubereiten um diese Master-CF dann auf diverse Geräte zu vervielfältigen.
    Auf den neuen Geräten wird der neue Name automatisch angepasst - wenn die ersten drei Buchstaben die vorbelegten Buchstaben sind.

Hinweis:

Das CE-Gerät muss nach jeder Änderung neu gestartet werden, damit die neuen Einstellungen wirksam werden.
Die Registry wird auf die CF-Karte gespeichert, wenn der Neustart über “Start” --> “Suspend” erfolgt


FTP Server

Der CX1001-xxxx kann mit verschiedenen CE-Images betrieben werden, diese beinhalten unterschiedliche Komponenten. Der FTP-Server ist Bestandteil aller CE-Images.

Das "FTP-root" - Verzeichnis befindet sich auf der Compact Flash im Verzeichnis "\FTP" und steht im CX1000 somit unter "\hard disk\FTP" zur Verfügung.

Für Konfigurationen nutzen Sie das Tool "START - Settings - Control Panel - CX Configuration" und wählen den Bereich FTP.

Um den Zugang als "Anonymous" frei zu schalten, aktivieren Sie "Server active". Der CX1000-FTP-Server ist somit vom Host-PC über z.B. den Microsoft Explorer erreichbar über ftp://<CX1000-Ip-Adresse> bzw. ftp://<CX1000-host-name> und hat im CX1000-FTP-root Verzeichnis volle Zugriffsrechte (Schreiben / Lesen).

Security :

Wenn kein "Anonymous" Zugang erwünscht ist muss ein NTLM User konfiguriert werden: Details hier


RAS Dienst

Jedes Windows CE Gerät enthält einen eingebauten RAS Server, um eine Remoteeinwahl entweder über ein angeschlossenes Modem (COM-Port), oder über eine vorhandene Netzwerkverbindung (VPN) herzustellen. Das folgende Kapitel gibt Ihnen einen Überblick über die allgemeinen Einstellmöglichkeiten des Windows CE RAS Diensts. Zum Abschluss finden Sie dann detaillierte Informationen, wie Sie eine Modemeinwahl, oder eine VPN-Einwahl konfigurieren können.

Allgemeine Informationen über den RAS Server

Jedes Beckhoff CE Gerät wird mit einem integrierten RAS Server ausgeliefert. Dieser Hintergrunddienst verwaltet alle eingehenden Einwahlverbindungen, welche entweder über ein abgeschlossenes Modem, oder auch über das Netzwerk hergestellt werden können. Das folgende Bild zeigt ein typisches Beispiel für einen RAS-Aufbau.

Der CE RAS Server unterstützt zwei Szenarios: Sie können entweder ein Modem zur Einwahl über eine Telefonleitung verwenden, oder Sie können das Firmennetzwerk benutzen, um eine Einwahlverbindung über VPN herzustellen. Diese Flexibilität ermöglich es Ihnen, mit wenig Aufwand eine Einwahlverbindung zu Ihrem CE-Gerät zu erzeugen und diesen Aufbau in Ihre bestehende IT-Umgebung zu integrieren. Sie können den RAS Server über das "CX Configuration" Tool konfigurieren, welches Sie in der "Systemsteuerung" auf Ihrem CE-Gerät finden:

  • Öffnen Sie das "Startmenü" und dann die "Systemsteuerung"
  • Starten Sie das Tool "CX Configuration"
  • Navigieren Sie zur Registerkarte "RAS Control"

Standardmäßig ist das RAS Server deaktiviert. Um ihn zu aktivieren müssen Sie die folgenden Schritte durchführen:

  • Aktivieren Sie die Checkbox "Enable RAS Server"
  • Selektieren Sie einen oder mehrere Verbindungskanäle (Lines) und klicken Sie jeweils auf "Enable Line". Mit Hilfe dieser Kanäle unterscheiden Sie, ob sie ein Modem- oder eine VPN-Einwahl ermöglichen möchten. Beide Einstellmöglichkeiten werden später noch detailiert erläutert werden.
  • Fügen Sie einen Benutzeraccount hinzu, welcher über die Kanäle eine Verbindung herstellen darf. Bitte beachten Sie, dass dieses Benutzerkonto nicht mit den Konten verwechselt werden darf, welche z.B. für den SMB Server konfiguriert werden können, denn beides sind verschiedene Konten!
  • Sie können optional auch andere IP-Einstellungen wählen. Mit Hilfe dieser Einstellungen können Sie ändern, wie Clients eine IP-Adresse erhalten. Die zur Verfügung stehenden Möglichkeiten sind: DHCP, AutoIP (default), Static. Diese werden weiter unten noch ausführlich erklärt.

Sobald Sie die Konfiguration abgeschlossen haben, klicken Sie auf "OK" und starten Sie Ihr Gerät neu. Sie sollten immer die soeben besprochene grafische Oberfläche zur Konfiguration benutzen. Möchten Sie jedoch die Konfiguration des RAS Servers zusätzlich anpassen, so stehen Ihnen diverse Möglichkeiten über die Windows Registry auf Ihrem CE-Gerät zur Verfügung:

  • Öffnen Sie das "Startmenü" und klicken Sie auf "Ausführen"
  • Geben Sie "regedit" ein und bestätigen Sie mit "OK". Es öffnet sich der Registry Editor.
  • Navigieren Sie zum Schlüssel "HKEY_LOCAL_MACHINE\Comm\ppp\Server\Parms". Hier können Sie weitere Parameter für den RAS Server vornehmen. Bitte beachten Sie, dass der Schlüssel "ppp" nur existiert, nachdem der RAS Server aktiviert wurde!

Die folgende Tabelle zeigt Ihnen die verschiedenen Parameter in diesem Schlüssel:

Attribute | Type | Standardwert | Erläuterung
Enable | DWORD | 0x00000000 | Deaktiviert (0) oder aktiviert (1) den RAS Server
StartupDelaySeconds | DWORD | 0x00000000 | Gibt die Zeit an, die nach dem Booten gewartet werden soll, bis der RAS Server gestartet wird.
UseDHCPAddresses | DWORD | 0x00000000 | Deaktiviert (0) oder aktiviert (1) die Benutzung von DHCP-Adressen durch Clients. Kann verwendet werden, wenn das CE-Gerät einen internen DHCP-Server enthält.
UseAutoIpAddresses | DWORD | 0x00000000 | See explaination above
AutoIpSubnet | DWORD | 0xC0A80000 | Subnetz-IP für AutoIP Konfiguration. Die Berechnung des hier anzugebenden Hexadezimalwert wird weiter unten erklärt.
AutoIpSubnetMask | DWORD | 0xFFFF0000 | Subnetzmaske für AutoIP Konfiguration.Die Berechnung des hier anzugebenden Hexadezimalwert wird weiter unten erklärt.
StaticIpAddrStart | DWORD | 0xC0A8FE01 | Erste IP-Adresse für Static Konfiguration. Die Berechnung des hier anzugebenden Hexadezimalwert wird weiter unten erklärt.
StaticIpAddrCount | DWORD | 0x000000FE | Anzahl der zu vergebenden IP-Adressen für Static Konfiguration.
AuthenticationMethods | DWORD | 0x00400000 | Weiter unten ausführlich erklärt.
Flags | DWORD | 0x00000000 | Weiter unten ausführlich erklärt.

Der Wert jedes IP-Parameters kann durch die Binär- und Hexadezimal-Darstellung einer IP-Adresse leicht ermittelt werden. Eine IP-Adresse besteht aus 4 Werten, wobei jeder Wert einem Byte entspricht (oder auch 8 bit). Die Hexadezimaldarstellung einer IP-Adresse kann also direkt aus der binären Darstellung abgeleitet werden, indem man jede 4 bits direkt in eine Hex-Zahl umwandelt, zum Beispiel:

IP address: | 192.168.0.1
Binary: | 11000000.10101000.00000000.00000001
Hexadecimal: | C0.A8.00.01 à 0xC0A80001

Die folgende Tabelle zeigt einige Beispiele für Subnetz-IP's, wie sie z.B. beim Parameter "AutoIpSubnet" angegeben werden können:

Subnet IP | Subnet Mask | Value IP (Hex) | Value Mask (Hex)
192.168.0.0 | 255.255.255.0 | 0xC0A80000 | 0xFFFFFF00
192.168.1.0 | 255.255.255.0 | 0xC0A80100 | 0xFFFFFF00
192.168.2.0 | 255.255.255.0 | 0xC0A80200 | 0xFFFFFF00
172.16.0.0 | 255.255.0.0 | 0xAC100000 | 0xFFFF0000

Der Parameter "AuthenticationMethods" konfiguriert den RAS Server für die Benutzung verschiedener Protokolle zur Client-Authentifizierung. Bitte beachten Sie, dass hier die Protokolle konfiguriert werden, welche vom Server verweigert werden! Das bedeutet, dass, wenn ein Client versucht eine Verbindung zum RAS Server über ein verweigertes Protokoll herzustellen, der Verbindungsversuch vom Server angewiesen wird.

Protocol | Value (Hex) | Information
PAP | 0x00040000 | Das Password wird zur Authentifizierung im Klartext übermittelt. Unsicher!
CHAP | 0x00080000 | Benutzt einen Zufallswert zusammen mit dem Password, um einen one-way Hashwert zu erzeugen, welcher zur Authentifizierung übermittelt wird.
MS-CHAP | 0x00100000 | Microsoft's Implementierung von CHAP. Enthält einige Verbesserungen zum Standard-CHAP.
MS-CHAP v2 | 0x00200000 | Version 2 von MS-CHAP. Unterstützt erstmalig eine gegenseitige Authentifizierung der Kommunikationsteilnehmer.
EAP | 0x00400000 | Entwickelt vom IETF. Unterstützt diverse Authentifizierungsmechanismen, wie zum Beispiel RADIUS, Zertifikate, ... . Dies bedeutet jedoch auch, dass, je nach Authentifizierungsmethode, noch zusätzliche Software auf dem CE-Gerät benötigt wird.

Um mehr als ein Protokoll serverseitig zu sperren, müssen die in obiger Tabelle zur Verfügung gestellten Werte als eine Bitmaske interpretiert werden, in der die Werte bitweise aufaddiert werden. Zum Beispiel:

Zu verweigernde Protokolle: | PAP, CHAP, MS-CHAP
Binärdarstellung PAP-Wert: | 0000 0000 0000 0100 0000 0000 0000 0000
Binärdarstellung CHAP-Wert: | 0000 0000 0000 1000 0000 0000 0000 0000
Binärdarstellung MS-CHAP-Wert: | 0000 0000 0001 0000 0000 0000 0000 0000
Aufaddiert: | 0000 0000 0001 1100 0000 0000 0000 0000
Zu konfigurierender Hex-Wert: | 0x001C0000

Der "Flags" Parameter spezifiziert die Nutzung diverser weiterer RAS Features, welche in der folgenden Tabelle gelistet werden. Diese Features können durch obige bitweise Aufaddierung beliebig miteinander kombiniert werden.

Feature | Value (Hex) | Information
Data Encryption | 0x01 | Requires data encryption, if set
Unauthenticated Access | 0x02 | Allows unauthenticated access, if set
Use of VJ header compression | 0x04 | Prevents the use, if set
Use data compression | 0x08 | Prevents the use, if set

Konfiguration einer Modemeinwahl

Sie können ein an das CE-Gerät angeschlossenes Modem verwenden, um eine Einwahlverbindung herzustellen. Die resultierende Verbindung ist somit eine Punkt-zu-Punkt Verbindung über das Telefonnetz.

Diese Konfigurationsvariante können Sie über das "CX Configuration" Tool einstellen:

  • Öffnen Sie das "Startmenü" und dann die "Systemsteuerung"

  • Starten Sie die "CX Configuration"

  • Navigieren Sie zur Registerkarte "RAS Control"

  • Wählen Sie eine der dort gelisteten Modem-Lines aus, zum Beispiel "Hayes Compatible" und klicken Sie auf "Enable Line"

  • Bitte stellen Sie sicher, dass sie auch alle weiteren notwendigen Einstellungen getroffen haben, zum Beispiel das Setzen eines Benutzeraccounts oder IP-Einstellung. Diese Einstellungen werden weiter oben in diesem Dokument ausführlich beschrieben. ("Allgemeine Informationen...")

  • Starten Sie Ihr Gerät neu

Jede Windows Version besitzt einen integrierten Einwahl-Client, welcher die Remoteeinwahl über ein Modem unterstützt. Am Beispiel von Windows 7 können Sie solch eine Verbindung auf Ihrem Client wie folgt konfigurieren:

  • Öffnen Sie das "Startmenü" und dann die "Systemsteuerung"

  • Öffnen Sie "Netzwerk und Internet" und wechseln Sie dort zum "Netzwerkfreigabe Center"

  • Klicken Sie auf "Eine neue Verbindung herstellen"

  • Wählen Sie "Verbindung mit dem Arbeitsplatz herstellen"

  • Selektieren Sie dann "Nein, eine neue Verbindung herstellen". Bitte beachten Sie: Dieser Bildschirm wird nur gezeigt, wenn es bereits konfigurierte Einwahlverbindung auf Ihrem System gibt

  • Wählen Sie "Direkt wählen"

  • Wählen Sie im nächsten Schritt das Modem aus, welches Sie für die ausgehende Verbindung benutzen möchten und klicken Sie auf "Next"

  • Geben Sie die Telefonnummer Ihres CE-Geräts ein. Dies ist die Rufnummer des Modems an dem Gerät!

  • Geben Sie einen Benutzernamen und ein Kennwort ein. Dies sind die Zugangsdaten, welche Sie in der "CX Configuration" für den RAS Server eingestellt haben.

  • Zum Abschluss klicken Sie auf "Connect". Dies speichert das Verbindungsprofil und startet die Verbindung zu Ihrem Gerät

Konfiguration einer VPN-Verbindung

VPN ist die Abkürzung für "Virtual Private Network". In Windows CE ist VPN ein Teil des RAS Servers und ermöglicht es Ihnen, eine bestehende Netzwerkverbindung zur Einwahl in Ihr CE-Gerät über einen sicheren Kanal zu benutzen. Die resultierende Verbindung basiert hierbei auf IP. Standardmäßig verwendet der in Windows CE integrierte RAS Server das PPTP Protokoll (Point-to-Point Tunneling Protocol) für eingehende VPN-Verbindung. Um eine Verbindungsherstellung von außerhalb Ihres Unternehmensnetzwerks zu ermöglichen, müssen Sie somit auch die PPTP-spezifischen Ports auf Ihrer Firewall öffnen. Dies sind 1723/TCP für den initialen Verbindungsaufbau und GRE für die Datenflusssteuerung. Diese Ports müssen von Ihrer Firewall an das CE-Gerät weitergeleitet werden ("Port Forwarding"). Bitte konsultieren Sie hierzu das Handbuch Ihres Routers/Firewall.

Um den RAS Server für eingehende VPN-Verbindungen zu konfigurieren, führen Sie bitte die folgenden Schritte durch:

  • Öffnen Sie das "Startmenü" und dann die "Systemsteuerung"

  • Starten Sie die "CX Configuration"

  • Navigieren Sie zur Registerkarte "RAS Control"

  • Wählen Sie eine der dort gelisteten Modem-Lines aus, zum Beispiel "Hayes Compatible" und klicken Sie auf "Enable Line"

  • Bitte stellen Sie sicher, dass sie auch alle weiteren notwendigen Einstellungen getroffen haben, zum Beispiel das Setzen eines Benutzeraccounts oder IP-Einstellung. Diese Einstellungen werden weiter oben in diesem Dokument ausführlich beschrieben. ("Allgemeine Informationen...")

  • Starten Sie Ihr Gerät neu

Seit Windows XP enthält jede Windows Version einen integrierten VPN-Client, welcher auch das PPTP-Protokoll unterstützt. Am Beispiel von Windows 7 können Sie folgendermaßen eine solche VPN-Verbindung zu Ihrem CE-Gerät herstellen:

  • Öffnen Sie das "Startmenü" und dann die "Systemsteuerung"

  • Öffnen Sie "Netzwerk und Internet" und wechseln Sie dort zum "Netzwerkfreigabe Center"

  • Klicken Sie auf "Eine neue Verbindung herstellen"

  • Wählen Sie "Verbindung mit dem Arbeitsplatz herstellen"

  • Selektieren Sie dann "Nein, eine neue Verbindung herstellen". Bitte beachten Sie: Dieser Bildschirm wird nur gezeigt, wenn es bereits konfigurierte Einwahlverbindung auf Ihrem System gibt

  • Wählen Sie "Meine Internetverbindung benutzen (VPN)"

  • Geben Sie die Internetadresse Ihres CE-Geräts ein. Bitte beachten Sie: Wenn Sie diese VPN-Verbindung von außerhalb Ihres Unternehmensnetzwerk verwenden möchten, müssen Sie hier die IP-Adresse Ihres Routers/Firewall eintragen, welche Sie für das "Port Forwarding" konfiguriert haben, siehe oben.

  • Klicken Sie auf "Next"

  • Geben Sie einen Benutzernamen und ein Kennwort ein. Dies sind die Zugangsdaten, welche Sie in der "CX Configuration" für den RAS Server eingestellt haben.

  • Zum Abschluss klicken Sie auf "Connect". Dies speichert das Verbindungsprofil und startet die Verbindung zu Ihrem Gerät


SNTP: Simple Network Time Protocol

Hinweis:

Diese Funktion wird beim CX1000 ab der CE Imageversion 1.60 (basierend auf CE4.2) unterstützt.

SNTP :Simple Network Time Protocol
Protokoll, das die Systemzeit eines Computers mit der eines Servers synchronisiert, der bereits von einer Referenzquelle wie zum Beispiel einem Radio, Satellitenreceiver oder einem Modem synchronisiert wurde.

Die erforderliche Zeitkonfiguration kann mit der Beckhoff Software unter "START - Settings - Control Panel - CxConfiguration" auf dem CE-Gerät vorgenommen werden.
Auf dem Karteireiter "Miscellaneous" sind die Einstellungen für das SNTP Protokoll zu finden.

Hinweis:

Standardmäßig benutzt das SNTP Protokoll den UDP Port 123. Dieser Port darf keinesfalls durch die Firewall belegt werden.

Einstellungen:

SNTP Server : Geben Sie die IP Adresse oder den Namen des Rechners ein, der als Zeit-Server agiert.

Refresh rate : Wählen Sie den Zeitintervall, in dem die Zeitsynchronisation zyklisch erfolgen soll.

Hinweis:

Nachdem die Einstellungen für "Time zone" oder "Automatically adjust clock for daylight saving" vorgenommen wurden kann es bis zu 40 Sekunden dauern, bis die Uhrzeit durch den SNTP server synchronisiert wird.

Veränderungen an "Automatically adjust clock for daylight saving" erfordern einen Reboot des CE-Geräts, damit ein einwandfreies Arbeiten ermöglicht wird.

Die Vorgehensweise lautet wie folgt: Öffnen der Shell-Umgebung ("START --> Ausführen...", geben Sie "cmd" ein und bestätigen Sie mit "OK" ) und Eingabe der Zeile:

services refresh ntp0:

Diese Zeile kann auch in die Datei "\hard disk\system\autoexec.cmd" eingegeben werden, damit sie bei jedem Gerätestart ausgeführt wird.

Konfiguration des PCs, um als Zeit-Server zu agieren:

Wenn Sie einen Rechner so einrichten wollen, dass dieser als Zeit-Server auftritt, unterstützen dies einige Systeme wie der Windows2000-Server und der XP-Server.

Bei anderen Systemen, wie z.B. Windows2000 Professional oder XP Professional kann dieses Feature durch folgende Registry Einstellungen aktiviert werden:

REGEDIT4
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]

"TimeSource"=dword:00000001

Nach einem Reboot agiert der Rechner wie ein Zeit-Server.


NTLM User Authentifizierung

Durch Hinzufügen von “NTLM User” kann der Zugang zum FTP-Server und/oder SMB-Server (öffentliche Ordner) mit einem Berechtigungsnachweis versehen werden.

NTLM-User können folgendermaßen hinzugefügt werden:

  • Option 1:
    User mit Zugang zum geschützten FTP- oder SMB-Server (öffentliche Ordner) anlegen

    Die nötige einmalige Konfigurierung erfolgt bequem am CE-Gerät über die Beckhoff-Software “START - Settings - Control Panel - CX Configuration”.
    Kartenreiter “FTP” aufrufen. Nach einem Doppelklick mit der linken Maustaste (oder einem einfachen Klick mit der rechten) im Feld “NTLM User” erscheint ein Dialogfenster. Wählen Sie “Add User” und geben Sie Usernamen und Passwort ein.

    Danach wird der neue User in die Liste aufgenommen. Mit einem Doppelklick (oder einem einfachen Klick rechts) können Sie den User aktivieren/deaktivieren oder löschen.

  • Option 2:
    User mit RAS-Zugang anlegen

    Die nötige einmalige Konfigurierung erfolgt bequem am CE-Gerät über die Beckhoff-Software “START - Settings - Control Panel - CX Configuration”.
    Kartenreiter “RAS” aufrufen. Nach “Enable RAS server” und “Enable Line” kann mit “Add User” ein User hinzugefügt werden. Füllen Sie alle Felder aus und beenden mit “OK”.

  • Option 3:
    Nutzen Sie das Befehlszeilen Tool “CxAddUser” im Ordner “\hard disk\system”

    Starten Sie eine Shell mit “START --> Run. ..”, geben “cmd” ein und beenden Sie mit “OK”. In der Shell können Sie das Tool mit “CxAddUser” aufrufen.

    Syntax:
    CxAddUser <User name> <password> [n]

    [n] ist optional und kann sein:
    0 : AddUser für RAS und FTP
    1 : AddUser für RAS
    2 : AddUser für FTP

Hinweis:

Das Befehlszeilen Tool CxAddUser kann in eine Batchdatei zum Setup eines CE-Geräts integriert werden:
Erzeugen Sie die Batch-Datei “CxRunOnce.cmd” im Ordner “\hard disk\system” und geben Sie die Zeilen zum Hinzuzufügen eines Users ein.


Internet Explorer (IE) im Kioskmode (kein Menü)

Betriebssysteme

Microsoft IE im "Kiosk-mode" : Internet Explorer ohne Menü im "Full Screen"

Dieser Artikel beschreibt die Konfiguration eines CE Gerätes um den Internet Explorer (IE) im Vollbildmodus (ohne Menüs etc.) zu starten :

1. Voraussetzungen

Erforderliche Software auf dem CE Gerät

  • IEsimple (Simple Internet Explorer)
    IESimple für die Plattformen X86 (CX10x0) und ARM (CX9000)

2. Einmalige Konfiguration

  • Stellen Sie die Datei "IEsimple.exe" auf dem CE-Gerät im Verzeichnis "\hard disk\system" zur Verfügung.
  • Die Software IEsimple.exe entnimmt aus der Registry die Information aus der zu startenden Seite (die Startseite)
[HKEY_CURRENT_USER\Software\Microsoft\Internet
Explorer\Main]
"Start Page"="http://localhost/index.htm"

3. Optionale Hinweise

  • Hier Hinweise, falls IEsimple.exe automatisch beim Booten gestartet werden soll : weitere Informationen
  • Hier Hinweise, falls das CE-Gerät ohne die Microsoft Standardshell starten soll : weitere Informationen


Starten von CE Applikationen

Das automatische Starten von Applikationen auf Beckhoff CE Geräten kann in drei verschiedenen Varianten erfolgen :

  1. Start per "Start Manager" (ab CE6 verfügbar)
  2. Eintrag in der CE-Registry
  3. Eintrag in einer anzulegenden Batchdatei "autoexec.cmd"

1. Start per "Start Manager" (ab CE6 verfügbar)

Ab CE Image 3.0x basierend auf CE6 steht der Start-Manager zur Verfügung - hier können eine oder mehrere Applikationen eingetragen werden, die beim Starten des CE-Gerätes auch mit gestartet werden sollen

Um eine Applikation hinzuzufügen muss der Button "New" ausgewählt werden und die Basis Informationen eingetragen werden.

"Type" auswählen - zwei Optionen sind verfügbar: RDP-Session und ShellCommand:

  • RDP Session: Ermöglicht eine Konfiguration der RDP-Session mit einem Remote PC.

  • Wenn die RDP-Verbindung nach jedem Reboot gestartet werden soll, muss die Option "Autostart" ausgewählt werden.
  • Im Falle von mehreren RDP-Verbindungen muss die Option "Start Focused" angewählt werden, um eine Verbindung herzustellen. Alle anderen RDP-Verbindungen sollten die Option "Start Focused" nicht haben.

  • Den Reiter "Logon" auswählen um die Applikation einzugeben, die gestartet werden soll

  • Die Parameter für "Server" (der Server der über RDP verbunden werden soll), User, Passwort und Domain eingeben. Mit OK bestätigen.

  • ShellCommand: Ermöglicht die Konfiguration einer lokalen Applikation - genauso wie ein Start von der Shell.
    Die Option "Autostart" anwählen, wenn die Applikation nach jedem Reboot gestartet werden soll.

  • Den Reiter "Shell command" auswählen, um die zu startende Applikation einzugeben

Nun zeigt der Startup Manager die Applikation "notepadce" an, um diese bei jedem Gerätestart zu starten.

Um eine Konfiguration zu überarbeiten muss ein Element in der Startup Manager Liste ausgewählt werden - die ausgewählte Linie wird für diese optionalen Aktionen hervorgehoben:

Configure: Ein Element wird neu konfiguriert

Autostart: Ermöglicht das Feststellen der Option "Auto" für die ausgewählten Elemente. Die Option "True" startet eine Applikation, die Option "False" startet keine Applikation

Start: Startet sofort die ausgewählten Elemente

Delete: Löscht die ausgewählten Elemente

Save: Speichert die Startup Manager Konfiguration

Exit: Verlässt den Startup Manager

Alle Einstellungen werden lokal auf einem CE-Gerät unter "\hard disk\TwinCAT\StartManCOnfig.xml" abgespeichert.

Für das Duplizieren der Start Manager-Einstellungen auf weitere CE-Geräte reicht das Kopieren dieser Datei auf die neuen Geräte aus.

2. Eintrag in der CE-Registry

Die Registry der CE-Geräte enthält unter HKEY_LOCAL_MACHINE \ INIT eine Liste von Applikationen und deren Startreihenfolge während der Hochlaufphase des CE-Gerätes.

Diese Liste kann erweitert werden, mit eigenen Applikationen.

Hinweis :
Wenn die Registry gelöscht wird (manuell oder durch ein Update einer NK.BIN Datei) sind ihre Einträge zunächst verloren.
Um dies zu verhindern nutzen Sie den Mechanismus zum Importieren von Registrydateien "RegFiles".

3. Eintrag in einer der Batchdatei "autoexec.cmd"

Falls im Verzeichnis \hard disk\system eine Datei autoexec.cmd vorhanden ist, so wird diese in der Hochlaufphase des CE-Gerätes zur Ausführung gebracht.

Durch Eintrag von Applikationen können diese somit automatisch gestartet werden.

Beispiel:

REM DEMO autexec.cmd
REM
start "\hard disk\MyAppFolder\MyApp.exe"


Installation zusätzlicher Fonts

Benötigen Applikationen zusätzliche Fonts (Beispiel : Symbol oder Wingding) so müssen diese einfach in einem Verzeichnis auf den Windows CE Gerät zur Verfügung gestellt werden.

Zielverzeichnis auf dem Windows CE Gerät : "\Hard Disk\System\Fonts"

1. Ändern des Standard Fonts

Um die Standard-Schriftart zu ändern, muss der folgende Registry Key gesetzt werden :

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\FontPath]
"FontPath"="\Hard Disk\System\Fonts"

Anmerkung : In diesem Ordner sollte sich nur eine Schriftart befinden.

2. Zusätzliche Fonts

Um mehrere Fonts zur Verfügung zu stellen, muss der unten genannten Registry-Keys in der jeweiligen Windows CE Version geändert werden.

2.1 Fonts Pfad in der Windows CE 4.20 Registry

Der Pfad für die Fonts muss in der Windows CE Registry auf die folgende Einstellung geändert werden :

[HKEY_LOCAL_MACHINE\Explorer\Shell Folders]
"Fonts"="\Hard Disk\System\Fonts"

2.2 Fonts Pfad in der Windows CE 5.00 Registry

Der Pfad für die Fonts muss in der Windows CE Registry auf die folgende Einstellung geändert werden :

[HKEY_LOCAL_MACHINE\System\Explorer\Shell Folders]
"Fonts"="\Hard Disk\System\Fonts"


IIS Web Server

Der CX1001-xxxx kann mit verschiedenen CE-Images betrieben werden, diese Images enthalten auch den Microsoft Internet Information Server (IIS-Web-Server).

Dieser Web-Server unterstützt HTML / DHTML, SSL, die ISAPI Erweiterungen. JavaApplets werden nicht unterstützt, da die aktuellen CX1000-CE-Images keine Java VM enthalten.

CGI wird nicht unterstützt, in der Windows CE.NET Dokumentation gibt es Hinweise zur Konvertierung der CGI in ISAPI.

Mit der TwinCAT-Ads-Script-DLL (CE) kann die Anbindung an die TwinCAT CE Umgebung realisiert werden.

ASP und Java Script werden ausschließlich vom Image CX1800-0101 HMI unterstützt.

www-root

Das "www-root" - Verzeichnis befindet sich auf der Compact Flash im Verzeichnis "\www" und steht im CE-Gerät somit unter "\hard disk\www" zur Verfügung.
Nach der Bereitstellung von weiteren HTML / ASP Seiten stehen diese über das HTTP Protokoll auch externen Benutzern zur Verfügung.

Protokolle

Die Protokolle HTTP und FTP werden von allen CE-Gerät Modulen unterstützt, das SMTP Protokoll nur von den CE-Gerät Modulen mit großem Speicherausbau.

Das POP3 Protokoll wird von keinem CE-Gerät Modul unterstützt.


File Server

Betriebssysteme

Shared Folder (File Server)

Achtung: Diese Funktionalität wird ab der CE Imageversion 1.60 (basierend auf CE4.2) unterstützt.

Jedes Beckhoff CE Image wird mit einer SMB Server Installation ausgeliefert. Der Begriff SMB steht hierbei für ein Netzwerkprotokoll, welches primär für den Zugriff auf freigegebene Ressourcen auf einem Windows-Betriebssystem benutzt wird. Das CE-Gerät (ab Version 5.0) kann hierbei für zwei verschiedene Zugriffsarten konfiguriert werden, welche im Folgenden erläutert werden sollen. Anschließend erfolgt eine Anleitung zur Erstellung neuer Verzeichnisfreigaben. Zum Abschluß finden Sie noch eine wichtige Information zu Client-Systemen, welche unter Windows Vista / 7 laufen.

Authentifizierung von Netzwerkzugriffen über NTLM

Jede Standard CE-Installation auf einem Beckhoff Controller nutzt NTLM (NT LAN Manager), um Netzwerkzugriffe auf den SMB Server zu authentifizieren. Das bedeutet, daß Sie sich bei dem Zugriff auf eine Verzeichnisfreigabe Ihres CE-Geräts zunächst an diesem Authentifizieren müssen, bevor Ihnen der Zugriff gestattet wird. Im Regelfall erfolgt hierbei die Aufforderung zur Eingabe eines Benutzernamens und eines Kennworts, vgl. auch die folgende Abbildung:

Standardmäßig wird ein CE-Gerät mit den folgenden Benutzerdaten ausgeliefert:

  • Benutzername: guest
  • Password: 1

Sie können jedoch auch eigene Benutzerkonten einrichten und diese für den Zugriff auf die Freigaben verwenden. Um ein neues Benutzerkonto einzurichten müssen Sie die folgenden Schritte auf Ihrem CE-Gerät durchführen:

  • Öffnen Sie das "Startmenü" und wechseln Sie dann zur "Systemsteuerung"
  • Starten Sie das Tool "CX Configuration" und wechseln Sie dort zur Registerkarte "FTP"

  • Die Tabelle zeigt alle momentan konfigurierten Benutzerkonten auf dem CE-Gerät. Um ein neues Benutzerkonto einzurichten, klicken Sie mit der rechten Maustaste auf eine freie Fläche in dieser Liste und wählen Sie "Add user"
  • Geben Sie einen "Benutzernamen" und ein "Password" Ihrer Wahl ein und bestätigen Sie dies mit einem Klick auf "OK"
  • Starten Sie Ihr CE-Gerät neu, damit die Änderungen wirksam werden

Nachdem das CE-Gerät neu hochgefahren ist, können Sie das soeben hinzugefügte Benutzerkonto verwenden, um sich über das Netzwerk an dem Gerät anzumelden.

Hinweis: Alternativ können Sie für das Anlegen von NTLM Usern auch das Tool CxAddUser benutzen, zusätzliche Hinweise finden Sie hier.

Keine Authentifizierung von Netzwerkzugriffen

Möchten Sie die Authentifizierung von Benutzern am SMB Server komplett deaktivieren, so müssen Sie hierfür die Windows Registry verändern. Hierzu führen Sie bitte die folgenden Schritte durch:

  • Öffnen Sie das "Startmenü" und klicken Sie auf "Run..."
  • Geben Sie im Textfeld "regedit" ein und klicken Sie danach auf "OK". Daraufhin öffnet sich der "Registry Editor"
  • Navigieren Sie zum Schlüssel " HKEY_LOCAL_MACHINE\Services\SMBServer\Shares"
  • Editieren Sie das Attribut "UseAuthentication" und setzen Sie dessen Wert auf "0"
  • Starten Sie Ihr CE-Gerät neu, damit die Änderungen wirksam werden

Nachdem das CE-Gerät neu hochgefahren ist, brauchen Sie für einen Zugriff auf das Gerät über das Netzwerk nun keine Anmeldeinformationen mehr einzugeben.

Eine neue Verzeichnisfreigabe erstellen

Die Erstellung von neuen Verzeichnisfreigaben auf dem CE-Gerät ist für die beiden obigen Szenarien identisch. Um eine neue Freigabe zu erstellen, müssen Sie Änderungen in der Windows Registry vornehmen. Hierzu führen Sie bitte die folgenden Schritte durch:

  • Öffnen Sie das "Startmenü" und klicken Sie auf "Run..."
  • Geben Sie im Textfeld "regedit" ein und klicken Sie danach auf "OK". Daraufhin öffnet sich der "Registry Editor"
  • Navigieren Sie zum Schlüssel "HKEY_LOCAL_MACHINE\Services\SMBServer\Shares". Alle hierunter gelisteten Schlüssel repräsentieren Freigaben auf dem CE-System. Standardmäßig existiert bereits eine Freigabe, nach deren Konfiguration Sie sich richten können. Falls Sie diese Freigabe löschen möchten, selektieren Sie sie und klicken Sie auf das rote Kreuz in der oberen Menüleiste.

  • Jede Freigabe besitzt 3 Attribute: Path (String), Type (DWORD), UserList (String)
  • Das Attribut "Path" beinhaltet den absoluten Pfad zum freizugebenden Verzeichnis, z.B. "\Public"
  • Das Attribut "Type" beinhaltet die Art der Freigabe. Für eine Verzeichnisfreigabe tragen Sie hier bitte ein "0" ein und für eine Druckerfreigabe eine "1".
  • Das Attribute "UserList" beinhaltet eine Liste mit lokalen Benutzerkonten, welche auf die Freigabe zugreifen dürfen. Die Benutzerkonten werden hierbei durch ein Semikolon voneinander getrennt

Bitte beachten Sie: Benutzerkonten, welche nicht in dem Attribut "UserList" vermerkt sind, bekommen die Freigabe auch nicht angezeigt!

Das Anlegen einer neuen Freigabe erfordert also zusammengefasst die folgenden Schritte:

  • Erstellung des freizugebenden Verzeichnisses
  • Erstellung eines neuen Schlüssels unterhalb von "HKEY_LOCAL_MACHINE\Services\SMBServer\Shares " in der Windows Registry
  • Erstellung der 3 obigen Attribute für diesen neuen Schlüssel
  • Neustart des CE-Geräts, damit die Änderungen wirksam werden

Wichtiger Hinweis zu Client-Systemen unter Windows Vista / 7

Bei Windows Vista und Windows 7 Systemen muss einmalig die Konfiguration der Sicherheitseinstellungen angepasst werden, um auf SMB Ordner von CE Geräten zugreifen zu können.
Standardmäßig sind diese Systeme so konfiguriert, dass diese ausschließlich NTLM Version 2 akzeptieren, ältere Versionen dieses Protokolls werden abgelehnt. Da der SMB Server von Windows CE jedoch NTLM Version 0.12 benutzt, schlägt die Anmeldung an solch einem System fehl.

Um dieses Problem zu umgehen führen Sie bitte auf dem Windows Vista/7 System die folgenden Schritte durch:

  • Öffnen Sie das "Startmenü" und gehen Sie dann in die "Systemsteuerung"
  • Öffnen Sie hier die "Verwaltung" und starten Sie "Lokale Sicherheitsrichtlinien"
  • Navigieren Sie zum Pfad "Lokale Richtlinien\Sicherheitsoptionen"
  • Doppelklicken Sie auf den Eintrag "Netzwerksicherheit: LAN Manager Authentifizierungslevel" und wählen Sie "LM & NTLM Antworten senden"
  • Starten Sie das System neu, damit die Änderungen wirksam werden


Microsoft Shell (ausblenden)

Allgemein:

Standardmäßig bootet das CE Gerät mit der Standard Microsoft CE Shell, welche wie folgt aussehen kann:

Es sind zwei Optionen zur Änderung der Ansicht möglich:

1. Option : Auswechseln des Hintergrundbildes (wallpaper)

In diesem Fall wird nur das Hintergrundbild ausgetauscht, die Funktionalität bleibt vollständig erhalten ( Icons, usw.)

Weitere Informationen zum Auswechseln des Hintergrundbildes

2. Option : Modifikation der Registry Einstellungen

Der Registry Key "HKLM\Init\Lauch50" enthält als Standardeinstellung den Eintrag "explorer.exe". Dies ist die Standard Microsoft CE Shell

Wenn Sie den Eintrag "explorer.exe" durch "TaskMan.exe" ersetzen, startet das System ohne die Standard Microsoft CE Shell.

HINWEIS:

Diese Option führt zu Veränderungen der Funktionalität: der Startbutton , die Icons u.a. wird nicht mehr angezeigt. (Das Hintergrundbild besteht weiterhin unverändert)

Hier kann der Benutzer eigene Applikationen starten und die Standard Shell ausblenden. Applikationen wie Notepad etc können über den Taskmanager gestartet werden. Hinweis: Die Standard-Shell explorer.exe kann nicht nachträglich gestartet werden.

Die veränderte Shell sieht wie folgt aus:


Weitere Software / Treiber installieren

Bitte beachten Sie bei der Installation weiterer Software auf einem Beckhoff CE Ger t folgendes:

  • Normalerweise ist der Standard-Installationspfad "\Windows", aber dieser Ordner ist nicht persistent auf dem Beckhoff CE Ger t vorhanden.
  • Um die Dateien persistent zu halten, benutzen Sie bitte den Ordner \hard disk\system.

Erforderliche Registry Einstellungen:

Falls die Software weitere Registry Keys ben tigt, empfehlen wir, eine Registry Datei mit den Einstellungen im Ordner \hard disk\RegFiles zu platzieren.

Mit einem Doppelklick werden die Registry Dateien in die Ger te Registry importiert.


Tastatur Layout

Auf den CE basierenden CX Geräten kann die "Input Language" (gemeint ist die Tastaturbelegung bei unterschiedlichen landessprachlichen Tastaturen) angepasst werden.

1. Laden Sie die benötigten Dateien vom FTP-Server http://download.beckhoff.com/download/Software/embPC-Control/CE/Solutions/KeyBoardLayout/

Beachten Sie, dass für CE5 und CE6 unterschiedliche Dateien vorhanden sind.

2. Das Verzeichnis X86 enthält Komponenten für X86 basierende CE Geräte : CX1000 / CX1020 / CP62xx / C69xx ...
Das Verzeichnis ARMV4i enthält Komponenten für ARM basierende CE Geräte : CX9000 / CP6608 / ...

3. Für jede Sprache stehen dazu zwei Dateien zur Verfügung, eine Resource-DLL (*.dll) und eine Registrydatei(*.reg).

Das Verzeichnis USB enthält die Dateien für USB basierende Tastaturen.
Das Verzeichnis PS2 enthält die Dateien für eine PS2 und/oder eine USB basierende Tastatur.

4. Die Registrydatei kopieren Sie in den Ordner \hard disk\RegFiles Ihres CE Gerätes.

5. Die Resource-DLL kopieren Sie in den Ordner \hard disk\system Ihres CE Gerätes.

Voraussetzungen :

  • CE Gerät mit Windows CE5 oder CE6
  • Die gewünschten Keyboard Layouts müssen im Image vorhanden sein.

    Aktuell werden im Standardimage unterstützt:

    0x0804 Chinese PRC
    0x0413 Dutch Netherlands
    0x0405 Czech Czech Republic
    0x0406 Danish Denmark
    0x0409 English United States
    0x040b Finnish Finland
    0x040c French France
    0x0407 German Germany
    0x040e Hungarian Hungary
    0x0410 Italian Italy
    0x0411 Japanese Japan
    0x0412 Korean Korea
    0x0415 Polish Poland
    0x0419 Russian Russia
    0x040a Spanish Spain
    0x041d Swedish Sweden


CE SDK

Betriebssysteme

SDK (Software Development Kit)

Diese Seite enthält Informationen um mit Microsoft embVC++ 4 oder Microsoft Visual Studio 2003/ 2005 native C++ CE Applikationen für CE Geräte zu implementieren.

Installation BECKHOFF-SDK:

Die Beckhoff SDK sind lizenzfrei bei Beckhoff erhältlich:

Download vom Pfad : http://download.beckhoff.com/download/Software/embPC-Control/CE/Solutions/SDK/

  • HMI_500_Vx.x_SDK.msi (65 MB) : Beckhoff -SDK für Beckhoff-CE5 Geräte (wie CX1010 / CX1020 / CX9000 / Ethernetpanel / CP62xx / C69xx...)
  • HMI_600_Vx.x_SDK.msi (15 MB) : Beckhoff -SDK für Beckhoff-CE6 Geräte (wie CX1010 / CX1020 / CX9000 / Ethernetpanel / CP62xx / C69xx...)

    Historie: Die früheren SDK Versionen stehen im folgenden FTP-Verzeichnis zur Verfügung
    http://download.beckhoff.com/download/Software/embPC-Control/CE/Solutions/SDK/History

VS2003/2005 : Projekt Migration auf das aktuelle SDK

Wenn ältere Visual Studio C++ - Projekte gegen frühere SDK Versionen kompiliert wurden so muss einmalig eine Anpassung erfolgen.
Für neuere Versionen des Beckhoff-SDK muss diese Anpassung nicht mehr erfolgen.

  • Öffnen Sie mit einem Texteditor (Notepad etc.) die Projektdatei <projektname>.vcproj
  • Suchen Sie nach allen alten SDK Einträgen und ersetzen diese durch die neuen Einträge

    Suchen nach
    "     HMI_500_V1.1 (x86)" und "HMI_500_V1.2 (x86)"

    Ersetzen durch
    "Beckhoff_HMI_500 (x86)"

     Suchen nach
    "     HMI_500_V1.1 (ARMV4I)" und "HMI_500_V1.2 (ARMV4I)"

    Ersetzen durch
    "Beckhoff_HMI_500 (ARMV4I)"

Beispiel:

Altes SDK:

        <Platforms>

    <Platform

        Name="HMI_500_V1.1 (x86)"

    />

</Platforms>

<ToolFiles>

</ToolFiles>

<Configurations>

<Configuration

    Name="Debug|HMI_500_V1.1 (x86)"

OutputDirectory="$(PlatformName)\$(ConfigurationName)"

IntermediateDirectory="$(PlatformName)\$(ConfigurationName)"

    ...

Neues SDK:

        <Platforms>

    <Platform

        Name="Beckhoff_HMI_500
(x86)"

    />

</Platforms>

<ToolFiles>

</ToolFiles>

<Configurations>

<Configuration

    Name="Debug|Beckhoff_HMI_500
(x86)"

OutputDirectory="$(PlatformName)\$(ConfigurationName)"

IntermediateDirectory="$(PlatformName)\$(ConfigurationName)"

    ...


Einrichtung einer ActiveSync Verbindung

Diese Seite beschreibt die Schritte zur Erstellung einer ActiveSync Verbindung zwischen dem CX Gerät und dem Host-PC. Eine ActiveSync Verbindung wird empfohlen zur Implementation und vor allem zum Test (Debuggen) von Applikationen unter MS embVC++4 oder MS Visual Studio .NET 2003. Teilweise ist eine ActiveSync Verbindung sinnvoll bei der Erstellung von HMI-Scada-Lösungen.

Eine Notwendigkeit zur Einrichtung einer ActiveSync Verbindung besteht nicht: So können Applikationen auch mit Hilfe von CF-Adaptern direkt auf die CF-Karten kopiert werden.

1. Voraussetzungen:

Erforderliche Software auf dem Host-PC:

  • Windows NT/2000/XP
  • Microsoft ActiveSync 3.x (lizenzfrei bei Microsoft erhältlich)

Erforderliche Hardware:

  • Nullmodemkabel zur Verbindung zwischen dem CX Gerät und dem Host-PC.
    Anschlussbelegung NullModem Kabel
  • Optional: Eine TCP/IP Verbindung zwischen CX Gerät und Host-PC

2. Verbindungsaufbau:

1. Nach der Installation der Software Microsoft ActiveSync auf dem Host-PC muss Active ync gestartet werden. Die verfügbaren Kommunikationsschnittstellen werden mit "Get Connected" eingerichtet.

Bei der Erstinbetriebnahme eines CX1000/CX1020/CX9000 muss hier die serielle Schnittstelle verwendet werden.

2. Auf der CX Plattform ist keine gesonderte Einstellung notwendig. Zum Initiierung der Verbindung zum Host-PC klicken Sie auf dem CX Gerät auf >den "Start" Button, wählen "Ausführen" und geben Sie "Repllog" ein.

3. Nach Bestätigung mit "OK" wird der CX1000/CX1020/CX9000 den Host-PC aufrufen, mit dem er per Nullmodemkabel verbunden ist, und versucht eine Verbindung zu diesem PC aufzunehmen. Wurde die Verbindung erfolgreich hergestellt werden Sie aufgefordert eine sogenannte "Partnerschaft" (Partnership) zwischen Host-PC und CX Gerät zu bestätigen. Nach dieser Bestätigung ist die einmalige Einrichtung des ActiveSync Verbindung abgeschlossen.

Hinweis für ActiveSync via Ethernet-Schnittstelle:

Die erstmalige Verbindung des Host-PC mit dem CX1000/CX1020/CX9000 ist nur mit einer seriellen Schnittstelle möglich. Danach kann eine schnellere Verbindung über Ethernet hergestellt werden. Diese ermöglicht eine deutlich schnellere ActiveSync Verbindung zwischen Host-PC und CX Gerät. Beachten Sie, dass teilweise auch bei Nutzung der Ethernet-Schnittstelle weiterhin das serielle Kabel gleichzeitig vorhanden sein muss.

Zum Start einer ActiveSync-Verbindung über Ethernet geben Sie auf dem CX1000/CX1020/CX9000 nach dem "Start" Button, "Ausführen" "Repllog/remote" ein, wählen Sie ihren Host-PC in der Liste aus und starten die Verbindung durch "Verbinden".

Einstellungen in der Compact Flash Karte speichern:

Damit diese Einstellungen auf die CF Karte übernommen werden, muss der CX1000/CX1020/CX9000 mit "Start"-Button und "Suspend" herunter gefahren werden. Nur per "Suspend" wird die Registry des CE-Betriebssystems auf die Compact Flash des CX Geräts zurück gesichert.


Establish a TCP connection for Remote Tools

Betriebssysteme

Erstellung einer TCP Verbindung für Remote Tools

Diese Seite beschreibt, wie eine TCP Verbindung mit CE Geräten hergestellt wird, um Remote Tools wie Remote Debugging, Remote Registry Editor, Remote File Explorer usw. verwenden zu können.

1. Voraussetzungen:

Erforderliche Software auf dem Host-PC:

  • Microsoft embedded Visual C++4 (frei bei Microsoft verfügbar)

Erforderliche Hardware

  • TCP/IP Kabel zwischen Host-PC und CE Gerät.

2. Konfiguration auf dem Host-PC:

Folgende Schritte sind notwendig, um eine Verbindung zum Zielgerät zu erstellen:

  1. Wählen Sie Im Tools Menü "Configure Platform Manager..."
  2. Öffnen Sie den Windows CE Default Platform Knoten

    Wählen Sie den Eintrag für Ihr Gerät (Beispiel "HMI_500_V1.1 Device") und gehen Sie danach auf "Properties".

  3. Wählen Sie in der Transport Box, eine Übertragungsart aus und gehen Sie danach auf Configure.

  4. An dieser Stelle müssen Sie TCP/IP Transport for Windows CE wählen.
    Wählen Sie hier "Configure".

  5. Konfigurieren Sie die Einstellungen für den Transport. Geben Sie hier die IP Adresse Ihres Host-PC ein.
    Wählen Sie danach OK.
  6. Zurück im vorhergehenden Dialog, können Sie die Verbindung testen wenn Sie "Test" wählen.
    Der folgende Dialog öffnet sich :

  7. Folgen Sie den Anweisungen "Launch CEMGRC.exe" mit der Kommandozeile auf dem CE Gerät.

  8. Wählen SIe auf dem CE Gerät "Start->Run" und geben Sie "CEMGRC.exe /t:...." ein
    Beenden Sie den Dialog mit "OK"

    Wenn Sie auch auf dem Host-PC mit "OK" bestätigt haben wird die Verbindung aufgebaut und der Host-PC und das CE Gerät sind miteinander verbunden.
    Nun können die Remote Tools verwendet werden.


Implementation unter Microsoft embedded VC++ 4

Diese Seite enthält Informationen um mit Microsoft embVC++ 4 CE Applikationen für die CX1000/CX1020/CX9000 CE Plattform zu implementieren.

1. Voraussetzungen:

Erforderliche Software auf dem Host-PC:

  • Windows NT/2000/XP
  • Microsoft Embedded VC4 (lizenzfrei bei Microsoft erhältlich)
  • Beckhoff CX1000 SDK (lizenzfrei bei Beckhoff erhältlich)

Optional:

  • Microsoft ActiveSync 3.x (lizenzfrei bei Microsoft erhältlich)
    Eine ActiveSync Verbindung erleichtert die Implementation und das Testen von Software auf CE Geräten.
    Anleitung zur Einrichtung der Microsoft ActiveSync Verbindung

2. Installation CX1000-SDKs:

Sehen Sie den Artikel "BECKHOFF SDK"

3. Implementation unter embVC++ 4:

Nach der Installation der SDKs stehen diese in der embVC++ 4 Entwicklungsumgebung zur Verfügung. Für ein CE Projekt auf dem CX Gerät wählen Sie bitte als unterstützte Plattform "Win32 (WCEx86)" an. Mit Auswahl der Plattform "Win32 (WCE emulator)" kann die CE Applikation auch ohne CE Hardware zunächst im Emulator getestet werden.

In der Entwicklungsumgebung stehen Ihnen nun die installierten Beckhoff CX1000 SDKs zur Verfügung.

Sie können nun ihre C++ Applikation erstellen. Zur Anbindung an TwinCAT stehen CE Applikationsbeispiele im Beckhoff Information System im Bereich "Connectivity -> TcAdsDll" zur Verfügung.

Wurde eine ActiveSync Verbindung erfolgreich eingerichtet, so kann die Applikation direkt auf den CX Gerät geladen und zur Ausführung gebracht werden. Auch das Debuggen der CX1000-Applikation ist so aus der embVC4++ Umgebung möglich.

Hinweis zu :

embVC++3 : Applikationen, die unter embVC++3 erstellt wurden sind auf der CX Plattform lauffähig. Allerdings ist es nicht möglich, aus der embVC++ 3 Umgebung Applikationen auf das CX Gerät zu laden oder zu debuggen.

embVB3: Applikationen, die unter embVB3 erstellt wurden sind auf der CX Plattform lauffähig. Allerdings ist es nicht möglich, aus der embVB 3 Umgebung Applikationen auf das CX Gerät zu laden oder zu debuggen. Beckhoff bietet keine ADS-Anbindung für die embVB3 Umgebung an.


CX Emulator für MS Visual Studio .NET

Diese Seite beschreibt die Schritte zur Einrichtung eines CX Emulators mit integrierten TwinCAT Komponenten.
Der Emulator dient dazu, HMI Applikationen unter Microsoft Visual Studio .NET ohne CX1000/CX1020/CX9000 Hardware zu implementieren und zu testen.

Erforderliche Software auf dem Host-PC:

  • Windows NT/2000/XP
  • Microsoft Visual Studio .NET

Beckhoff CX Emulator für Visual Studio .NET

Der Beckhoff CX Emulator ist eine erweiterte Version des Standard SDK Emulator. Diese erweiterte Version enthält TwinCAT Komponenten. Nach dem Start wird der Emulator als virtuelles CE Gerät im Netzwerk erkannt.
Der TwinCAT System Manager auf dem Host-PC kann das virtuelle CE Gerät im Emulator per Broadcast-Suche erkennen. Das TwinCAT PLC Control kann das SPS Projekt in das SPS-Laufzeitsystem im Emulator herunterladen.

Alle weiteren TwinCAT CE Produkte wie TwinACT OPC-XML Server CE, TwinCAT Modbus Server CE etc. können im Emulator installiert werden.

Hauptzweck bleibt, eine HMI-Applikation im CE Emulator zu implementieren und zu testen ohne dafür CX Hardware zu benötigen.

Einrichtung des Emulators:

1. Download der Datei vom Beckhoff-FTP-Server
http://download.beckhoff.com/download/Software/embPC-Control/CE/Solutions/CX_Emulator/emulator.zip (18 MB)

2. Die zip Datei enthält eine Installation, die Installation lädt zusätzlich Komponenten aus dem Microsoft Web.

3. Die Batchdatei "StartEmulator" enthält weitere Angaben zur Einstellung an ihr lokales System, bitte nehmen Sie hier die Einstellungen vor.

Anschließend kann der Emulator mit der Batchdatei gestartet werden.

Hinweise :

- Getestet wurde mit Microsoft Visual Studio .NET 2003 und 2005.

- Eine virtuelle Netzwerkverbindung zwischen Host-PC und Emulator kann nur hergestellt werden, wenn der Host-PC eine Netzwerkverbindung hat. (Linksignal hat)

Der Microsoft Standard- Emulator ist in der Beckhoff-Variante mit TwinCAT Komponenten erweitert:


Implementation .NET Applikation unter Microsoft Visual Studio .NET 20xx

Diese Seite enthält Informationen um mit Microsoft Visual Studio .NET 20xx eine .NET-CE Applikationen für die CE Plattform zu implementieren.

1. Voraussetzungen:

Erforderliche Software auf dem Host-PC:

  • Windows NT/2000/XP
  • Microsoft Visual Studio .NET 200x

Optional:

  • Verbindungsaufnahme zwischen Host PC und CE Gerät siehe Artikel "Remote Debugging VS2003" und "Remote Debugging VS20xx"

Erforderliche Software auf dem CE Gerät:

  • Das CE-Zielgerät muss das .NET Compact Framework enthalten !
    Per Default enthalten fast BECKHOFF CE Geräte das .NET-CF - Ausnahme sind die Geräte mit sehr kleinem Speicherausbau auf denen kein .NET CF verfügbar ist und die somit keine .NET Applikationen ablaufen lassen können.
    Geräte OHNE .NET CF: CX9000 / CX1000

Übersicht .NET-CF Versionen in den CE-Images:

  • CE4.1 bis Image V1.59 : Enthält .NET CF Framework 1
  • CE4.2 : Enthält .NET CF Framework 1
  • CE5 : Enthält .NET CF Framework 1 und 2
  • CE6: Enthält .NET CF Framework 1 und 2, es kann durch hinzukopieren von Dateien auch .NET CF 3.5 verwendet werden

2. Implementation unter VS .NET 20xx

Erstellen Sie ein neues Projekt, wählen Sie dabei als Projektvorlage "Smart Device Application". Dieser Projekttyp ermöglicht das Erstellen von CE Applikationen die auf dem Compact-Framework von Microsoft basieren.

Im nächsten Schritt wählen Sie bitte als Zielplattform "Windows CE" aus.

Sie können nun ihre CE Applikation implementieren und diese sowohl im "Windows CE.NET Emulator" testen aber auch auf das "Windows CE.NET Device" (das BECKHOFF-CE-Gerät) laden und debuggen.

Beachten Sie, dass für NET Applikationen auf dem CX unter CE das Microsoft Compact Framework enthalten sein muss !


Implementation unter Microsoft Visual STudio .NET 2003

Betriebssysteme

Remote Debugging unter Microsoft Visual Studio .NET 2003

Diese Seite enthält Informationen um mit Microsoft VS .NET 2003 CE Applikationen auf dem HOST-Entwicklungs-PC zu erstellen und durch den Quellcode zu debuggen wobei die Applikation selbst auf dem eigentlichen CE Zielgerät läuft.

Remote Debugging ist Bestandteil der Microsoft Entwicklungsumgebung. Über die ActiveSync Verbindung kann effizient und performant über Ethernet das Remote-Debugging erfolgen. Der Nachteil der ActiveSync Verbindung liegt in der häufig aufwendigeren Erstellung der ActiveSync Verbindung : So muss zunächst mit einem seriellen Nullmodemkabel eine serielle Verbindung zwischen dem CE-Gerät und dem HOST-PC erstellt werden, erst anschließend kann die performantere Ethernet Schnittstelle gewählt werden.

Die hier beschriebene Variante "Smart Device Utility" basiert auf dem Add-On-Paket für die Windows CE-Dienstprogramme für Visual Studio .NET 2003.

1. Voraussetzungen:

Erforderliche Software auf dem Host-PC:

  • Microsoft Visual Studio .NET 2003

  • Für die Erstellung der Verbindung zum Remote-Debugging mittels Smart Device Utility wird die frei im Internet verfügbare Microsoft Software Windows CE .NET Utilities for Visual Studio .NET 2003.EXE benötigt.

Erforderliche Software auf dem Beckhoff-CE Gerät:

  • Im Verzeichnis \hard disk\system müssen die Dateien SDAuthUtilDevice.exe und toolhelp.dll enthalten sein.
    Diese Dateien können vom Beckhoff FTP-Server hier geladen werden.
  • Laden Sie die Datei CE5_DbgHlp.zip vom Link http://download.beckhoff.com/download/Software/embPC-Control/CE/Solutions/VS_NET20xx_DbgHelp/
    Falls der FTP Server ein Zugangspasswort erfordert, kontaktieren Sie bitten den Beckhoff Support.

    Nach dem Entpacken stellen Sie die Dateien bitte auf dem CE-Gerät im Verzeichnis \hard disk\system zur Verfügung.

2. Herstellung der Verbindung:

  • Auf dem CE Gerät : Starten Sie das Tool \hard disk\system\SDAuthUtilDevice.exe und klicken Sie "Start". Die IP Adresse des CE Gerätes wird nun angezeigt, das CE Gerät ist bereit zur Erwiderung der Kommunikation.
  • Auf dem HOST-PC im Visual Studio 2003 : Im Menü "Extra" wählen Sie "Smart Device Authentication Utility", tragen die IP Adresse des CE-Gerätes ein und schließen mit "Set up device" ab.
    Bei erfolgreicher Verbindungsaufnahme zum CE-Gerät erscheint ein Dialog "Device has been prepared and ConmanClient.exe has been successfully launched".
    Mit Bestätigung "OK" und "Close" wird das Utility geschlossen und die Verbindung zum CE-Gerät besteht.
  • Im Visual Studio 2003 muss nun nur bei der Auswahl des Zielgerätes das Gerät "Windows CE.NET Gerät" ausgewählt werden. Hier ist unter Transport "TCP-Transportverbindung" per Auswahl von "Konfigurieren..." die IP-Adresse vom CE-Gerät in das Feld "Spezielle IP-Adresse verwenden" einzutragen.


Remote Debugging of CE apps under Microsoft Visual Studio .NET 20xx

Betriebssysteme

Remote Debugging von CE Apps unter Microsoft Visual Studio .NET 20xx

Debugging auf CE Geräten ohne ActiveSync

Ohne Hilfe von ActiveSync kopiert VS20xx nicht automatisch die Verbindungsausführungsdateien und demzufolge wird das Debuggen problematisch.

Beachten Sie Folgendes, um den Debugger auf Windows CE Geräten ohne ActiveSync nutzen zu können:

HINWEIS:
Implementierung von native C++ Code unter VS20xx erfordert die Installation des Beckhoff-SDK für CE
Siehe Artikel "BECKHOFF SDK"

Schritt 1. Manuelles Kopieren einiger Dateien auf das CE Gerät

  • Um ein Remote Debugging durchführen zu können, müssen Sie zunächst einige erforderliche Dateien auf das ausgewählte CE Gerät übertragen.
    Unglücklicherweise besitzt jede Version des Visual Studio .NET (und der installierten Service Packs) verschiedene Versionen der für das Remote Debugging erforderlichen Dateien.
    Beispielsweise ist es nicht möglich, eine Remote Debugging Verbindung zwischen einem Host -PC mit VS2005-SP1 und einem CE Gerät mit Dateien von VS2005 (ohne SP) aufzubauen.

    Die erforderlichen Dateien befinden sich auf Ihrem Host-PC mit Visual Studio .NET:

    "C:\Program Files\Common Files\Microsoft Shared\CoreCon\<yyyy>\Target\wce400" (Beachten Sie, dass <yyyy> variieren kann.)

    Kopieren Sie alle Dateien Ihres korrekten Unterordners in Ihr CE-Gerät:

    BEKCHOFF-CE-X86 Geräte: Kopieren Sie alle Komponenten des Unterordners \wce400\x86
    BECKHOFF-CE-ARM Geräte: Kopieren Sie alle Komponenten des Unterordners \wce400\ARMV4i

Step 2. Manuelles Starten der Dateien auf dem CE Gerät

  • Auf der Seite des CE Geräts: Öffnen Sie die Kommandozeile und geben Sie "Conmanclient2.exe" ein.

Step 3. Setzen der korrekten IP Adresse

  • Auf Ihrem Host-PC: Öffnen Sie Visual Studio 20xx.
  • Gehen Sie zu "Tools-->options-->device tools-->devices"
  • Wählen Sie Windows CE Geräte, klicken Sie auf “properties”.
  • Im Dialog “Windows CE device properties” , gehen Sie auf “configure”.
  • Im Transportdialog “Configure TCP/IP” , wählen Sie “use specific IP address” und geben die IP Adresse Ihres Windows CE Geräts ein.
  • Klicken Sie auf OK

Step 4. Verbindung aktivieren

  • Auf dem CE-Gerät: Öffnen Sie die Kommandozeile und geben Sie "cMaccept.exe" ein.
  • Stellen Sie innerhalb von drei Minuten eine Verbindung zum Gerät her. (Die 3 Minuten sind beim ersten Verbindungsaufbau erforderlich. So lange Sie die erste Verbindung innerhalb dieser drei Minuten aufbauen, sind weitere Verbindungsaufbauten unter Verwendung des gleichen VS nicht durch diese Zeit begrenzt.)
  • Falls Sie die Verbindung mit anderen Instances von VS aufbauen möchten, wiederholen Sie Schritt 4.
  • Nun ist der Debugger bereit. Sie sollten nun Programme debuggen können, die auf Windows CE Geräten laufen.


Embedded-PC: Allgemeine Software Erstellung

Betriebssysteme

Nachinstallation der CE .NET CF 3.5 Komponenten auf X86 Geräten

CE6 Images beinhalten das .NET CF 1 und 2. Auf X86 Geräten kann zudem das .NET CF 3.5 nachinstalliert werden. Dazu können Sie vom Beckhoff FTP Server die .NET CF 3.5 Komponenten herunterladen.

http://download.beckhoff.com/download/Software/embPC-Control/CE/Solutions/NET35/

Anschließend die DLLs ins Systemverzeichnis kopieren und netcfv35.reg nach RegFiles kopieren und ausführen. Nach einem Neustart des Gerätes ist die Installation abgeschlossen.


CE basierende Supplementprodukte installieren

Übersicht

Supplementprodukte sind für CE basierte Images, die auf den verschiedenen Plattformen wie CX1000, CX1020, CX9000, Ethernetpanels, IPCs, etc. laufen, verfügbar.

Liste der Supplements :

Supplementprodukt | Dokumentation | Verfügbare Plattform
TwinCAT OPC Server CE | additional info | OPC-DA Server verfügbar für X86 / ARM PPC / ARM HPC / MIPS OPC-XMLDA Server verfügbar für X86 / ARM
TwinCAT ADS CE | additional info | X86 / ARM PPC / ARM HPC / MIPS /
TwinCAT XML Data Server CE | additional info |
TwinCAT TCP Server CE | additional info | X86 / ARM
TwinCAT Modbus Server CE | additional info | X86 / ARM
TwinCAT PLC HMI CE | additional info | X86 / ARM
TwinCAT-Virtual-Serial-COM-Driver | additional info | Windows CE 6.0, X86 / ARM

Installation

Wenn die Supplementprodukte bereits zusammen mit Beckhoff Hardware Komponenten bestellt werden, wird die Software werksseitig in die CE Images installiert.

Der Kunde kann somit das Gerät starten, ohne weitere Installationen vornehmen zu müssen.

Falls die Supplement Produkte nicht zusammen mit Beckhoff Hardware bestellt worden sind, oder die Supplementprodukte auf Hardwareprodukten laufen, die nicht von Beckhoff sind ( wie z.B. der OPC Server auf einer MIPS Plattform) müssen 2 Schritte in der Installation eingehalten werden:

  • Schritt 1:
     Installieren Sie die Supplement Software auf dem Host PC. Mit Eingabe des erforderlichen Lizenzkeys und der Zustimmung zu den Lizenzvereinbarungen wird die Supplement Software in den Unterordner ..\TwinCAT\CE auf Ihren PC installiert.

Beispiel: Installation des TwinCAT OPC Server CE
Die Installation der Software auf dem Host PC erzeugt einen Ordner "..\TwinCAT\CE\OPC", der die CE*.cab Installationsdateien enthält (z.B.TcOpcXmlSvrCe.I586.CAB)

  • Schritt 2 :
     Transfer der CE-Cab Installationsdateien auf das CE Gerät (per memory stick/FTP/Public Folder/CF-Adapter...)
  • Während das CE Geräte läuft, machen Sie einen Doppelklick auf die Cab Datei und folgen Sie der Dokumentation. Nach Ende der Installation zerstört sich die Cab Datei von selbst.


Übersicht

Generell

Für embedded Produkte basierend auf dem Betriebssystem CE stehen verschiedene CE basierende SCADA-Lösungen zur Verfügung.

Diese SCADA CE-Runtime-Versionen sind auf Beckhoff embedded CE Plattformen (mit ausreichend RAM) lauffähig und verfügen über eine Treiberanbindung zum TwinCAT System:

  • Die SCADA CE-Runtime-Module können vorinstalliert auf der BECKHOFF CE Plattform bei Beckhoff bestellt werden - die Lizenz muss vom Kunden beim jeweiligen SCADA-Anbieter bezogen werden.
    BECKHOFF bietet somit "nur" die Dienstleistung, CE-SCADA-Systeme auf BECKHOFF-Geräten vorinstalliert auszuliefern.
  • Notwendige Editoren zur Erstellung der HMI-Lösungen müssen vom jeweiligen Anbieter erworben werden.

Für diese SCADA-Anwendungen muss ein CE basierendes System mit großem Speicherausbau verwendet werden.

SCADA editor / Support / Trainig | Produkt Beschreibung
Vom SCADA Hersteller : BECKHOFF | TwinCAT PLC HMI CE Produkt der Fa. BECKHOFF Automation, Verl, Deutschland
Vom SCADA Hersteller : CopaData | zenOn CE NET Runtime zenon ist ein Produkt der Fa. Copa-Data, Salzburg, Österreich
Vom SCADA Hersteller : Hilscher Swiss | QVis CE NET Runtime QVis ist ein Produkt der Fa. Hilscher Swiss, Solothurn, Schweiz
Vom SCADA Hersteller : Progea | MovXCE NET Runtime MovXCe ist ein Produkt der Fa. Progea, Modena, Italien
Vom SCADA Hersteller : InduSoft | InduSoft CE NET Runtime InduSoft ist ein Produkt der Fa. InduSoft, USA


Audio Modul CX1000-N003 (CX1000) bzw. CX1020-N020 (CX1020)

Betriebssysteme

Verwendung des W&T USB-Com-Adapters unter WinCE 5.0

Um den USB-COM-Adapter von W&T (Siehe www.wut.de, Serielle Interfaces, 38001USB <> RS232 Interface Cable mit USB-Versorgung, V2.0.1.) oder kompatible Adapter verwenden zu können, muss das WinCE 5.0 Image dafür eingerichtet werden.

Kopieren der Treiber-DLL:

Die Treiber-DLL ftdi_ser.dll unterstützt nur FTDI-Chips mit der Produkt-ID PID_6001, PID_6010, PID_6011und PID_6012 unter WinCE 5.0. Die ftdi_ser.dll muß per USB-Stick oder Netzwerk auf die Compact Flash in das Verzeichnis "\Hard Disk\System" kopiert werden. Findet das Kopieren mit einem CF-Card-Adapter außerhalb des CX statt, dann muss die ftdi_ser.dll in das Verzeichnis "X:\System" kopiert werden, wobei das "X" für den Laufwerksbuchstaben steht. Ein Zip-File mit der DLL liegt hier: ftdi_ser.zip.

Einrichten der Registrierdatenbank:

Zum Einrichten der USB-COM-Schnittstelle als COM5: muss die Reg-Datei "FTDI_USB2COM_COM5.reg" in das Verzeichnis "\Hard Disk\RegFiles" kopiert werden. Ein Zip-File mit der Reg-Datei liegt hier: FTDI_USB2COM_COM5.zip.

;-------------------------------------------------------------------------------

; FDTI USB 2 COM Adapter Settings (PID_6001) for COM5:
;
; for PID_6010 change 24577 -> 24592
; for PID_6011 change 24577 -> 24593
; for PID_6012 change 24577 -> 24594
;-------------------------------------------------------------------------------
[HKEY_LOCAL_MACHINE\Drivers\USB\ClientDrivers\FTDI_DEVICE]
[HKEY_LOCAL_MACHINE\Drivers\USB\FTDI_DEVICE]
"InitialIndex"=dword:5
"ActiveSyncSetting"=dword:0003e880
"LatencyTimer"=dword:00000010
"Index"=dword:0
"DeviceArrayIndex"=dword:0
"Version"="1.0.2.9"
"Prefix"="COM"
"Dll"="ftdi_ser.dll"
[HKEY_LOCAL_MACHINE\Drivers\USB\FTDI_DEVICE\Unimodem]
"DevConfig"=hex:\
10,00,00,00,05,00,00,00,10,01,00,00,00,4b,00,00,00,00,08,00,00,00,00,00,00

"FriendlyName"="Serial Cable on COM Port"
"DeviceType"=dword:00000000
"Tsp"="Unimodem.dll"
[HKEY_LOCAL_MACHINE\Drivers\USB\LoadClients\1027_24577\Default\Default\FTDI_DEVICE]

"DLL"="ftdi_ser.dll"
[HKEY_LOCAL_MACHINE\Drivers\USB\LoadClients\1027_24592\Default\Default\FTDI_DEVICE]

"DLL"="ftdi_ser.dll"
[HKEY_LOCAL_MACHINE\Drivers\USB\LoadClients\1027_24593\Default\Default\FTDI_DEVICE]

"DLL"="ftdi_ser.dll"
[HKEY_LOCAL_MACHINE\Drivers\USB\LoadClients\1027_24594\Default\Default\FTDI_DEVICE]

"DLL"="ftdi_ser.dll"

Zum Einrichten eines hayeskompatiblen Modems an der USB-COM-Schnittstelle als COM5: muss die Reg-Datei "FTDI_USB2COM_COM5_Modem.reg" in das Verzeichnis "\Hard Disk\RegFiles" kopiert werden. Ein Zip-File mit der Reg-Datei liegt hier: FTDI_USB2COM_COM5_Modem.zip.

;-------------------------------------------------------------------------------

; FDTI USB 2 COM Adapter Settings (PID_6001) for COM5:
;
; for PID_6010 change 24577 -> 24592
; for PID_6011 change 24577 -> 24593
; for PID_6012 change 24577 -> 24594
;-------------------------------------------------------------------------------
[HKEY_LOCAL_MACHINE\Drivers\USB\ClientDrivers\FTDI_DEVICE]
[HKEY_LOCAL_MACHINE\Drivers\USB\FTDI_DEVICE]
"InitialIndex"=dword:5
"ActiveSyncSetting"=dword:0003e880
"LatencyTimer"=dword:00000010
"Index"=dword:0
"DeviceArrayIndex"=dword:0
"Version"="1.0.2.9"
"Prefix"="COM"
"Dll"="ftdi_ser.dll"
[HKEY_LOCAL_MACHINE\Drivers\USB\FTDI_DEVICE\Unimodem]
"DevConfig"=hex:\
10,00,00,00,05,00,00,00,10,01,00,00,00,4b,00,00,00,00,08,00,00,00,00,00,00

"FriendlyName"="Serial Cable on COM Port"
"DeviceType"=dword:00000000
"Tsp"="Unimodem.dll"
[HKEY_LOCAL_MACHINE\Drivers\USB\LoadClients\1027_24577\Default\Default\FTDI_DEVICE]

"DLL"="ftdi_ser.dll"
[HKEY_LOCAL_MACHINE\Drivers\USB\LoadClients\1027_24592\Default\Default\FTDI_DEVICE]

"DLL"="ftdi_ser.dll"
[HKEY_LOCAL_MACHINE\Drivers\USB\LoadClients\1027_24593\Default\Default\FTDI_DEVICE]

"DLL"="ftdi_ser.dll"
[HKEY_LOCAL_MACHINE\Drivers\USB\LoadClients\1027_24594\Default\Default\FTDI_DEVICE]

"DLL"="ftdi_ser.dll"
;
-----------------------------------------------------------------------

; set USB-COM5-Modem
;
-----------------------------------------------------------------------

[HKEY_LOCAL_MACHINE\Comm\ppp\Server\Line\Hayes Compatible on
COM1:]
"DisconnectIdleSeconds"=dword:00000000
"Flags"=dword:00000000
"DeviceType"="modem"
"Enable"=dword:00000000
[HKEY_LOCAL_MACHINE\Comm\ppp\Server\Line\Hayes Compatible on
COM5:]
"DisconnectIdleSeconds"=dword:00000000
"Flags"=dword:00000000
"DeviceType"="modem"
"Enable"=dword:00000001
[HKEY_LOCAL_MACHINE\ExtModems\HayesCompat]
"FriendlyName"="Hayes Compatible on
COM5:"
"Port"="COM5:"
"CmdSendDelay"=dword:000001F4
"DeviceType"=dword:00000001
;
-----------------------------------------------------------------------

; enable ras
;
-----------------------------------------------------------------------

[HKEY_LOCAL_MACHINE\Comm\ppp\Server\Parms]
"Enable"=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\RasServer]
[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\RasServer\User]
"guest"="guest"

Die Reg-Dateien aus dem Verzeichnis "\Hard Disk\RegFiles" werden automatisch beim Erzeugen der Registry importiert werden. Das Erzeugen der Registry erfolgt beim ersten Hochlauf des CX10xx bzw. wenn kein Verzeichnis "\Hard disk\Documents and Settings" mehr vorhanden ist bzw. nach einem Update der NK.bin. Wenn bereits eine Registry besteht (z.B. beim Nachrüsten auf einem laufenden CX10xx), muss die Datei noch manuell durch Doppelklick aktiviert werden.

Per CxRunOnce.CMD wird ein RAS/FTP-Nutzer guest mit Passwort 1 angelegt. Die Datei muss in das Verzeichnis "\Hard Disk\System" kopiert werden bzw. die dort vorhandene Datei angepasst werden. Wie bei den Reg-Dateien wir die CxRunOnce.CMD beim ersten Hochlauf des CX10xx automatisch ausgeführt. Beim nachträglichen Einrichten genügt ein Doppelklick auf die Datei zum Ausführen. Ein Zip-File mit der CMD-Datei liegt hier: CxRunOnce.zip.

CxAddUser guest 1 0

Verwenden eines anderen COM-Ports als COM5:

Die Reg-Dateien sind für COM5: vorbereitet, da die Ports COM1: ... COM4: für lokale COM-Ports (Systemschnittstellen CX10x0-N03x bzw. CX10x0-N04x) am CX10xx reserviert sind. Wird ein höherer COM-Port gewünscht, muss in der RegDatei der InitialIndex für das FTDI-Device entsprechend eingestellt werden (z.B. 8 für COM8:).

[HKEY_LOCAL_MACHINE\Drivers\USB\FTDI_DEVICE]
"InitialIndex"=dword:5

Anschluss des Adapters und Neustart:

Anschließend kann der Adapter an den USB-Port angeschlossen und muss der CX10xx neu gebootet werden.

Achtung:

Diese Funktionalität wird nur für CE Imageversionen basierend auf WinCE5.0 für CX10xx unterstützt.

Es werden nur USB-COM-Adapter mit der Produkt-ID PID_6001, PID_6010, PID_6011und PID_6012 unterstützt.


Audio Modul CX1000-N003 (CX1000) bzw. CX1020-N020 (CX1020)

Betriebssysteme

Audio Modul CX1000-N003 (für CX1000) bzw. CX1020-N020 (für CX1020)

Die notwendige einmalige Konfiguration erfolgt benutzerfreundlich durch die Beckhoff-Software "START - Settings - Control Panel - CX Configuration" auf dem CX1000/CX1020.

Aktivierung Audio-Modul CX1000-N003/ CX1020-N020 :

- Aktivierung von "Enable Audio Device"

Deaktivierung Audio-Modul CX1000-N003/CX1020-N020 :

- Deaktivierung von "Enable Audio Device"

Achtung:

Diese Funktionalität wird ab CX1000 CE Imageversion 1.60 (basierend auf CE4.2) unterstützt.


Touch-Panel: Kalibrierung

Um den Touch zu kalibrieren gehen Sie so vor :

Auf dem CE Gerät wählen Sie "Start" --> "Settings" --> Control Panel" --> "CxConfiguration" --> "Display Settings".

Mit Klick auf "Calibrate TouchScreen" wird der Touch neu kalibriert.


CE Image update

Um ein Image Update eines BECKHOFF CE Geräts durchzuführen, gibt es zwei Möglichkeiten, abhängig vom Gerätetyp:

Wichtig:

  • Achten Sie darauf, dass Sie das "richtige" CE Image updaten, das auch zu Ihrer Zielplattform passt. !!
  • Lizenz

    Achten Sie auf den korrekten Level Ihrer Microsoft CE Lizenz!

    Beispiel:
    Wenn das CE Gerät mit einem CE5 Lizenzaufkleber ausgeliefert wurde, können Sie alle CE5 Versionen und alle vorherigen Versionen ( wie CE4.1 und CE4.2) benutzen.
    Es ist jedoch nicht erlaubt, ein CE6 Image zu benutzen. Dafür ist ein kostenpflichtiges Lizenzupdate erforderlich. Bitte wenden Sie sich dazu an Beckhoff.

Inhalt

  • X86 basierend CX1000 / CX1001 / CX1010 / CX1020 / CX1030
  • ARM basierend CX9000
  • ARM basierend CX9001 / CX9010 / CP6608
  • X86 basierend CP62xx / C60xx

x86 basierend : CX1000 / CX1001 / CX1010 / CX1020 / CX1030

  • Diese Geräte werden mit einer CF Karte ausgeliefert.
  • Löschen Sie den alten Inhalt der CF Karte
  • Kopieren Sie den neuen Inhalt auf die leere CF Karte
  • OPTIONAL:
    Für spezielle Voreinstellungen kopieren Sie die erforderlichen Dateien von \hard disk\RegFiles\Samples\Common nach \hard disk\RegFiles\
  • Fügen Sie die CF Karte in das Gerät ein und fahren Sie das Gerät hoch.
  • Das Gerät wird booten und seine eigene Standard Registry erzeugen (\hard disk\Documents and Settings).
    Wenn verfügbar, werden alle Registry Dateien (\hard disk\RegFiles\*.reg) importiert und das Gerät bootet noch einmal.

    Siehe Artikel

ARM basierend : CX9000

  • Diese Geräte werden nur mit einem internen Speicher ausgeliefert.
  • Sehen Sie dazu auch den Artikel wie ein Imageupdate durchgeführt werden kann.
  • HINWEIS:
    • Das Updaten eines CX9000 Geräts ist eine "2-Schritt-Prozedur":
      Wenn der zweite Schritt nicht durchgeführt wird, hat das Gerät nur eine extrem begrenzte Funktionalität, z.B. keine "Standard-NTLM-Benutzer", keine "Public Ordner", keine "UPnP WebKonfigurationsseite" etc.
    • Erster Schritt:

      Das CX9000 Gerät basiert auf einem einzigen 16 MB Flash Modul. Durch ein Update dieses einzigen Flash Moduls mit einem neuen Image wird das Flash Modul formatiert und alle Benutzerdaten und Geräteeinstellungen gehen verloren.

      Nach dem Update des neuen Image ist der Ordner \hard disk nahezu leer !
    • Zweiter Schritt:

      Packen Sie alle Ordner und Dateien in \hard disk of device (wie \hard disk\system and \hard disk\UPnP ...)
      Benennen Sie den Ordner "\hard disk\Documents and settings" um (z.B. in "oldreg") und starten Sie das Gerät erneut.
      Nach dem Reboot erzeugt das Gerät eine neue Standard Registry (\hard disk\Documents and Settings). Löschen Sie nun den alten umbenannten Ordner (Beispiel hier "oldreg")

  • OPTIONAL:
    Für spezielle Voreinstellungen kopieren Sie die erforderlichen Dateien von \hard disk\RegFiles\Samples\Common nach \hard disk\RegFiles\
  • Fügen Sie die CF Karte in das Gerät ein und fahren Sie das Gerät hoch.
  • Das Gerät wird booten und seine eigene Standard Registry erzeugen (\hard disk\Documents and Settings).
    Wenn verfügbar, werden alle Registry Dateien (\hard disk\RegFiles\*.reg) importiert und das Gerät bootet noch einmal.

    Siehe Artikel

ARM basierend: CX9001 / CX9010 / CP6608

  • Diese Geräte werden mit zwei internen Speichermodulen ausgeliefert.
  • Sehen Sie dazu auch den Artikel wie ein Imageupdate durchgeführt werden kann.
  • NOTE:
    • Das Updaten eines CX9001/CX9010/CP6608 Geräts ist eine "2-Schritt-Prozedur":
      Wenn der zweite Schritt nicht durchgeführt wird, hat das Gerät nur eine extrem begrenzte Funktionalität, z.B. keine "Standard-NTLM-Benutzer", keine "Public Ordner", keine "UPnP WebKonfigurationsseite" etc.
    • Erster Schritt:

      Das Gerät basiert auf zwei 16 MB Modulen. Durch ein Update einer neuen Image Version wird das erste Flash Modul formatiert. Alle Anwenderdaten und Geräteeinstellungen befinden sich weiterhin auf (\hard disk) ! (Dies ist der Unterschied zum CX9000, der nur ein einziges Flash Modul besitzt.)
    • Zweiter Schritt:

      Der persistente Ordner \hard disk\ befindet sich auf dem zweiten Flash Modul.

      Wir empfehlen dringend ein update der Ordner \hard disk\ folders (wie system und UPnP) um ein einheitliches Flashed Image und die korrekte Dateie für das spezifische Image zu besitzen.

      Bitte beachten Sie, dass sich die Inhalte von \system und \UpnP in den Images CE5 und CE6 unterscheiden:

      Noch einmal: Führen Sie immer ein komplettes Update durch. 1.) FlashIimage and 2.) Update \hard disk\components

      Packen Sie alle Ordner und Dateien in \hard disk of device (wie \hard disk\system and \hard disk\UPnP ...)
      Benennen Sie den Ordner "\hard disk\Documents and settings" um (z.B. in "oldreg") und starten Sie das Gerät erneut.
      Nach dem Reboot erzeugt das Gerät eine neue Standard Registry (\hard disk\Documents and Settings). Löschen Sie nun den alten umbenannten Ordner (Beispiel hier "oldreg")
  • OPTIONAL:
    Für spezielle Voreinstellungen kopieren Sie die erforderlichen Dateien von \hard disk\RegFiles\Samples\Common nach \hard disk\RegFiles\
  • Fügen Sie die CF Karte in das Gerät ein und fahren Sie das Gerät hoch.
  • Das Gerät wird booten und seine eigene Standard Registry erzeugen (\hard disk\Documents and Settings).
    Wenn verfügbar, werden alle Registry Dateien (\hard disk\RegFiles\*.reg) importiert und das Gerät bootet noch einmal.

    Siehe Artikel

x86 basierend : CP62xx / C69xx

  • Diese Geräte werden mit einer CF Karte ausgeliefert.
  • Löschen Sie den alten Inhalt der CF Karte
  • Kopieren Sie den neuen Inhalt auf die leere CF Karte
  • WICHTIG:
    Abhängig von Ihrem Gerät (CP62xx oder C60xx) und der Bildschirmauflösung kopieren Sie eine Datei in den Ordner \hard disk\Regfiles !

    Wenn dieser Schritt nicht vorgenommen wird, wird Ihr Gerät zyklisch booten oder das Gerät wird eine fehlerhafte Usershell anzeigen.

    Beispiel:

    CP62xx mit einer Bildschirmauflösung von 800*600:
    Kopieren von: \hard disk\RegFiles\Samples\CP62xx\CP62xx_Resolution_800_600.reg
    Kopieren nach: \hard disk\RegFiles\CP62xx_Resolution_800_600.reg

    CP69xx mit einer Bildschirmauflösung von 1024*768:
    Kopieren von: \hard disk\RegFiles\Samples\C69xx\C69xx_Resolution_1024_768.reg
    Kopieren nach: \hard disk\RegFiles\C69xx_Resolution_1024_768.reg

  • Fügen Sie die CF Karte in das Gerät ein und fahren Sie das Gerät hoch.
  • Das Gerät wird booten und seine eigene Standard Registry erzeugen (\hard disk\Documents and Settings).
    Wenn verfügbar, werden alle Registry Dateien (\hard disk\RegFiles\*.reg) importiert und das Gerät bootet noch einmal.

    Siehe Artikel


Übersicht

Übersicht der Basis Images für CX1000, CX1020 und CX9000 mit CE 5.0 Betriebssystem (ab CX1000 CE Image 2.10 und ab CX1020 CE Image 2.04)

--> Zur Übersicht der Komponenten in den CE-Images

Produktnummer | Beschreibung | Benötigtes CX Modell | Verfügbarer Speicher RAM | Benötigter Speicher auf CF*
CX1800-0100-000x | LF Image (Low Footprint) mit Windows CE.NET - Die Plattform mit geringem Arbeitsspeicherbedarf - Default Image, wenn kein spezielles CX Image bei Bestellung angegeben wird | - |  |
CX1800-0100 | Basisbetriebssystem-Image für CX1000 | CX1000-xxxx (Speicherausbau 32 MB) | 8 MB | ca. 8,8 MB
CX1800-0100-0002 | Basisbetriebssystem-Image für CX1020 | - | 8 MB | ca. 8,8 MB
CX1800-0100-0003 | Basisbetriebssystem-Image für CX9000 | CX9000 |  |
CX1800-0101-000x | HMI Image mit Windows CE.NET - Die Plattform für Visualisierungspakete und Internet Explorer - Default Image für CX mit großem Speicherausbau - Default Basis-Image, wenn CX mit einer Runtime Lizenz eines SCADA Pakets bestellt wird | - |  |
CX1800-0101 | Basisbetriebssystem-Image für CX1000 | CX1001-xxxx (Speicherausbau 128 MB) | 100 MB | ca.12,0 MB
CX1800-0101-0002 | Basisbetriebssystem-Image für CX1020 | - | 100 MB | ca.12,0 MB
CX1800-0101-0003 | Basisbetriebssystem-Image für CX9000 | CX9001 |  |

Übersicht der Basis Images für CX1000 mit CE 4.2 Betriebssystem (ab CX1000 CE Image 1.60)

--> Zur Übersicht der Komponenten in den CE-Images

Produktnummer | Beschreibung | Benötigtes CX Modell | Verfügbarer Speicher RAM | Benötigter Speicher auf CF*
CX1800-0100 | LF Image (Low Footprint) mit Windows CE.NET - Die Plattform mit geringem Arbeitsspeicherbedarf - Default Image für CX1000-xxxx (Speicherausbau 32 MB) | CX1000-xxxx (Speicherausbau 32 MB) | 8 MB | ca. 8,8 MB
CX1800-0101 | HMI Image mit Windows CE.NET - Die Plattform mit den meisten Komponenten (z.B. Internet Explorer, ASP Unterstützung und mit .NET Compact Framework, die Plattform für .NET) - Default Image für CX1001-xxxx (Speicherausbau 128 MB) - Default Basis-Image, wenn CX1000 mit einer Runtime Lizenz eines SCADA Pakets bestellt wird | CX1001-xxxx (Speicherausbau 128 MB) | 100 MB | ca.12,0 MB

Übersicht der Basis Images für CX1000 mit CE 4.1 Betriebssystem (bis CX1000 CE Image 1.59)

--> Zur Übersicht der Komponenten in den CE-Images

Produktnummer | Beschreibung | Benötigtes CX1000 Modell | Verfügbarer Speicher RAM | Benötigter Speicher auf CF*
CX1800-0100 | LF Image (Low Footprint) mit Windows CE.NET - Die Plattform mit geringem Arbeitsspeicherbedarf - Default Image für CX1000-xxxx (Speicherausbau 32 MB) | CX1000-xxxx (Speicherausbau 32 MB) | 8 MB | ca. 8,8 MB
CX1800-0101 | HMI Image mit Windows CE.NET - Die Plattform mit den meisten Komponenten (z.B. Internet Explorer und ASP Unterstützung) - Default Image für CX1001-xxxx (Speicherausbau 128 MB) - Default Basis-Image, wenn CX1000 mit einer Runtime Lizenz eines SCADA Pakets bestellt wird | CX1001-xxxx (Speicherausbau 128 MB) | 100 MB | ca.12,0 MB
CX1800-0102 | .NET Image mit Windows CE.NET - Windows CE.NET Image mit .NET Compact Framework, die Plattform für .NET Anwendungen - Image für die Erstellung von .NET Anwendungen auf CX1000 - Image benötigt CX1001-xxxx (Speicherausbau 128 MB) | CX1001-xxxx (Speicherausbau 128 MB) | 100 MB | ca. 9,0 MB

CF*: Compact Flash card


Bestandteile

Betriebssysteme

Bestandteile der CX Images ab Version 2.00

Übersicht der Komponenten der Basis CE Images ab Version 2.xx (CE 5.0 basierend)

Feature / Platform | CX1800-0100-000x LF | CX1800-0101-000x HMI
ATL, MFC | X | X
XML DOM | X | X
COM | X | X
COM Storage | X | X
Winsock | X | X
TCP/IP | X | X
UPnP |  |
Control Point | - | X
Device Host | - | X
SOAP |  |
Client | - | X
Server | - | X
DCOM | - | X
OBEX | - | X
MSMQ | - | X
Server |  |
HTTP / ASP / FTP / SNTP -Server | X | X
RAS Server | - | X
HTML / DHTML, SSL, ISAPI Erweiterungen | X | X
IE 6.x, Java Script | - | X
Java Applets | auf Anfrage
.NET Compact Framework | - | X
RDP Client (Remote Desktop protocol) | - | X
TwinCAT (Option) | X | X
USB support | X | X
Printer, Storage auf z.B. Compact Flash | X | X
HID (Human interface devices) | X | X
Touch | X | X
S-Keys | X | X
Media Player, Print Server | - | X


Bestandteile

Übersicht der Komponenten der Basis CE Images ab Version 1.60 (CE 4.2 basierend)

Hinweis 1:
Ab V1.60 basieren die Images auf CE4.2
Ab V2.00 basieren die Images auf CE5.0

Hinweis 2:
Die CE Images ab V1.60 wurden reorganisiert : Die bisherigen Images CX1800-0101HMI und CX1800-0102 NET wurden im CX1800-0101HMI zusammengefasst.
Somit sind nun Anwendungen möglich, die sowohl volle IIS-Funktionalitäten (z.B. ASP Technologie) und gleichzeitig auch das Microsoft NET Compact-Framework nutzen.

Feature / Platform | CX1800-0100 LF | CX1800-0101 HMI
ATL, MFC | X | X
XML DOM | X | X
COM | X | X
COM Storage | X | X
Winsock | X | X
TCP/IP | X | X
Shared Folder | X | X
SNTP : Simple network time protocol | X | X
Microsoft Media Player 9 | - | X
UPnP |  |
Control Point | - | X
Device Host | - | X
SOAP |  |
Client | - | X
Server | - | X
DCOM | - | X
OBEX |  |
MSMQ |  |
Server |  |
RAS | - | X
HTTP / FTP -Server | X | X
HTML / DHTML, SSL, ISAPI Erweiterungen | X | X
Support ASP, Java Script | - | X
Java Applets | - | -
.NET Compact Framework | - | X
Internet Explorer IE 6.0 | - | X
RDP Client (Remote Desktop protocol) | - | X
TwinCAT (Option, alle Images auch ohne TwinCAT verfügbar) | X | X
Standard SDK | - | X
USB support | X | X
Storage auf z.B. CompactFlash | X | X
HID (Human interface devices) | X | X
Touch | X | X
S-Keys | X | X


Bestandteile

Übersicht der Komponenten der Basis CE Images bis Version 1.59 (CE 4.1 basierend)

Hinweis: Die CE Images ab V1.60 wurden reorganisiert

Feature / Platform | CX1800-0100 LF | CX1800-0101 HMI | CX1800-0102 .NET
ATL, MFC | X | X | X
XML DOM | X | X | X
COM | X | X | X
COM Storage | X | X | X
Winsock | X | X | X
TCP/IP | X | X | X
UPnP |  |  |
Control Point | - | X | X
Device Host | - | X | X
SOAP |  |  |
Client | - | X | X
Server | - | X | X
DCOM | - | X | -
OBEX |  |  |
MSMQ |  |  |
Server |  |  |
RAS / HTTP / FTP -Server | X | X | X
HTML / DHTML, SSL, ISAPI Erweiterungen | X | X | X
Support ASP, Java Script | - | X | -
Java Applets | - | - | -
.NET Compact Framework | - | - | X
Internet Explorer IE 5.5 | - | X | -
RDP Client (Remote Desktop protocol) | - | X | -
TwinCAT (Option, alle Images auch ohne TwinCAT verfügbar) | X | X | X
Standard SDK | - | X | -
USB support | X | X | X
Storage auf z.B. Compact Flash | X | X | X
HID (Human interface devices) | X | X | X
Touch | X | X | X
S-Keys | X | X | X


Übersicht

Aktuelle Windows Embedded Standard Basis Betriebssystem Images für Beckhoff Embedded-PC Plattformen

Produktnummer Beschreibung Version
CBxx5x
  • Microsoft .NET Framework 3.0
  • Microsoft DirectX 11
  • Microsoft Silverlight 4.0
  • Enhanced Write Filter (EWF)
  • File Based Write Filter (FBWF)
  • IPC Diagnose (Modular Device Profile)

Detaillierte Übersicht von den installierten Komponenten

3.0


Windows Embedded Standard - Eigenschaften der Images

Betriebssysteme

Eigenschaften der Basis Windows Embedded Images für Beckhoff Embedded-PC Plattformen

Hinweis: Windows Embedded Standard ist nur für bestimmte Embedded-PC Plattformen verfügbar. Nähere Informationen hierzu finden sie in der WES7 Kompatibilitätsliste.

Übersicht der plattformspezifischen Eigenschaften der Windows Embedded Images für Beckhoff Embedded-PCs

Allgemeine Daten |
Image Version | 3.0
Plattform | Beckhoff IPC
Speicherbedarf | ca. 2900 MB

Übersicht der gemeinsamen Komponenten der Windows Embedded Images für Beckhoff Embedded-PCs

  • Allgemeine Daten

  • Entwicklung / Laufzeitumgebungen / Schnittstellen

  • Applikationen

  • Netzwerk

  • Systemverwaltung / Systemwerkzeuge

  • Geräteunterstützung

  • Dienste

Allgemeine Daten
Grafische Oberfläche: Explorer Shell
Sprache (MUI): Englisch

Entwicklung / Laufzeitumgebungen / Schnittstellen
Microsoft .NET Framework 2.0 (+ Client Profile)
Microsoft .NET Framework 3.0 (+ Client Profile)
Microsoft .NET Framework 3.5 (+ Client Profile)
COM OLE Application Support
COM+ Application Support
Win32 Application Runtimes and Libraries
EWF Anwendungsprogrammierungsschnittstelle (API)
FBWF Anwendungsprogrammierungsschnittstelle (API)
Microsoft Visual C++ 2005 Redistributable (v.8.0.56336)
Microsoft Visual C++ 2008 Redistributable (v.9.0.30729)
Microsoft Visual C++ 2010 Redistributable (v.10.0.30319)
Silverlight 4.0 (v.4.0.50826.0)
DirectX 11

Applikationen
Eingabeaufforderung / Konsole
Internet Explorer 8
Editor
On-Screen Keyboard
Paint
Rechner
Windows Explorer
Wordpad
Zeichentabelle
CXD-Tool
Beckhoff EWF Manager
Beckhoff FBWF Manager

Netzwerk
Netzwerk Unterstützung (TCP/IP, EtherCAT)
Dateifreigabe
Datenfernübertragung (DFÜ)
Direkte Verbindung (Nullmodem)
DHCP Client
DNS Client
Net Shell
Netzwerkdrucken
Netzwerk Setup Wizard
Remote Desktop
Windows Firewall (ICS)

Systemverwaltung / Systemwerkzeuge
Verwaltung (Event Log, Service Control Manager, Computer Management,...)
Enhanced Write Filter (EWF)
File Based Write Filter (FBWF)
Registry Filter
Kompatibilitätsmodus (Windows 95, Windows 98, Windows NT 4, Windows 2000, Windows XP, Windows Vista)
Registry Editor
Installierte Tastatur Layouts: Englisch
Systemsteuerung
Disk Management
Windows Firewall Control Panel

Geräteunterstützung
Audio Unterstützung (wave, midi, mp3)
Drahtloses / Funk- Netzwerk
(lokale) USB Drucker-Unterstützung
Elo Touch
Modem-Unterstützung
Microsoft Bluetooth Unterstützung
USB Audio Unterstützung
USB Speichermedien / USB Massenspeicher

Dienste
Automatic Updates
Indexing Service
Internet Information Service (IIS Web-Server)
Message Queuing (MSMQ)
Simple Network Management Protocol (SNMP)
IPC-Diagnose (Modular Device Profile)


Allgemeine Informationen

Windows Embedded Standard: Default User und Passwort

Per Default ist in allen Windows Embedded Images ein Benutzer und ein Passwort eingetragen. Dies ist notwendig, um z.B. per "Remote Desktop" mit dem Embedded-PC zu arbeiten.

  • Default User : Administrator (mit Administrator-Rechten)
  • Default Passwort : 1


Lokalisierte Windows XP embedded Images für Beckhoff Embedded-PCs

Betriebssysteme

Sprachpakete für Windows Embedded Standard 7 Images

Die Windows Embedded Standard 7 Images für die embedded PCs werden in englischer Sprache ausgeliefert. Es besteht jedoch die Möglichkeit, lokalisierte Fassungen von den Windows Embedded Standard 7 Images zu erhalten. Diese können problemlos nachinstalliert werden. Eine Lokalisierung eines Windows Embedded Images benötigt mehr Platz auf dem Speichermedium. Der Speicherbedarf bei einer Lokalisierung kann um ca. 30 - 300 MB ansteigen. Die Speicherplatzänderung hängt von der gewählten Sprache ab.

Die Lokalisierung der Images geschieht durch sogenannte Cabinet Files (.cab). Um diese Pakete zu installieren empfehlen wir die Verwendung des Beckhoff IPC-FeatureManager.

Verfügbare Sprachen::

Arabic (Saudi Arabia)
Bulgarian
Chinese (Hong Kong S.A.R.)
Croatian
Czech
Danish
Dutch
Estonian
Finnish
French
German
Greek
Hebrew (Israel)
Hungarian
Italian
Japanese
Korean
Latvian
Lithuanian
Norwegian
Polish
Portugese (Brazil)
Portugese (Portugal)
Romanian
Russian
Serbian (Latin)
Simplified (PRC) Chinese
Slovak
Slovenian
Spanish
Swedish
Thai
Traditional (Taiwan) Chinese
Turkish
Ukrainian


Configuration of WES 7 Images

Betriebssysteme

Einfaches duplizieren eines Windows Embedded Standard 7 Images

Ein Windows Embedded Standard 7 Betriebssystem wird oft an einem Entwicklungs-PC erstellt und konfiguriert. Um es anschließend auf mehreren identischen Zielsystemen verwenden zu können wird ein Image (Master-Image) dieses Betriebssystems erzeugt. Dieses Image wird dann auf anderen Zielsystemen wiederhergestellt. Dieser Artikel ist die einfache Art ein Image zu duplizieren.

Vorgehensweise:

Um den Aufwand bei der Konfiguration des Windows Embedded Images zu minimieren, können Sie mit dem CXID diese Computername, AmsNetId und UPnP- registrierungen ändern bzw. beim erstellen des Images die Änderungen beim nächsten Start des Betriebsystems vornehmen lassen.

Im folgenden Text wird beschrieben, wie Sie basierend auf einem Beckhoff Standard Embedded Image für Embedded-PCs ein Master-Image erstellen, welches dann auf anderen Embedded-PCs wiederhergestellt werden kann, ohne dass Konflikte entstehen, wie z.B. gleicher Computername, AmsNetId,usw... .

Schritt 1: Die Ausgangssituation

Für die Erstellung eines Master-Images wird ein Windows Embedded Standard 7 Image, Version 3.84 oder höher verwendet, dieses Image sollte über das CXID in der Version 4.2.1.2 verfügen.

Schritt 2: Zusätzliche Einstellungen

Hinweis : Bevor Sie Einstellungen am Betriebssystem vornehmen vergewissern Sie sich, dass die Write-Filter ( EWF, FBWF) ausgeschaltet sind. Ansonsten werden die Änderungen am Betriebssystem nicht übernommen.

Wenn beabsichtigt ist, weitere Software zu installieren oder Registry Einstellungen vorzunehmen, kann dies nach dem erfolgreichen SysPrep Vorgang getätigt werden.

Wenn die gewünschten Einstellungen auf dem Entwicklungsgerät (Master-Image), getätigt wurden das Gerät einfach herrunterfahren.

Schritt 3: Erstellen des (Master-) Images und Wiederherstellen des Images auf dem Zielsystem

Nach dem herrunterfahren wird ein Image von dem Entwicklungsgerät erzeugt. Beckhoff empfiehlt hierzu das Beckhoff Service Tool.

Nachdem das Master Image nun auf die Zielplatform portiert wurde, wird das CXID Tool beim nächsten Neustart Computername, AmsNetId und die UPnP- registrierung automatisch ändern.

HINT :Dies ist eine einfache Methode seine Geräte zu duplizieren. Wenn sie z.B. Filter wie den EWF, FBWF oder Security Identifier (SID) nutzen, wird ihnen die Benutzung von Microsoft SysPrep empfohlen.


Bildschirmtastatur

Betriebssysteme

Schritt 1:

Bitte wählen sie: "Start" -> "Systemsteuerung" -> "Center für erleichterte Bedienung" -> "Computer ohne Maus oder Tastatur bedienen"

Schritt 2:

Wählen sie das "Bildschirmtastatur verwenden" Kästchen aus.

Schritt 3:

Navigieren sie von der "Center für erleichterte Bedienung" Seite zu "Administratoreinstellungen ändern".

Schritt 4:

"Alle Einstellungen auf den Anmeldedialog anwenden" auswählen.

Von nun an sollte bei jedem Start des Gerätes die Bildschirmtastatur schon während des Logon-Bildschirms angezeigt werden.


Configuration of WES 7 Images

Betriebssysteme

Benutzerdefinierte Bildschirmschoner unter Windows Embedded Standard 7 einrichten.

Um einen Bildschirmschoner mit eigenen Bildern zu erstellen, halten sie sich bitte an die folgenden Schritte.

Schritt 1:

Verwenden sie ein Windows Embedded Standard 7 P-Image. Dieses ist notwendig, da die in "Schritt 2:" beschriebene Komponente eine P-Lizens erforderlich macht.

Schritt 2:

Installieren sie mittels IPC-Feature Manager die „Photoviewer“ Komponente welche sie hier auf dem Beckhoff-FTP finden.

Schritt 3:

Nach der erfolgreichen Installation der Komponente mittels IPC-FeatureManager, das Gerät bitte neu starten.

Schritt 4:

Um den Bildschirmschoner nun zu konfigurieren, navigieren sie per Rechtsklick auf dem Desktop -> „Personalize“ -> „Screensaver“ -> „Photos“ und nehmen die von ihnen gewünschten Einstellungen am Bildschirmschoner vor.


Embedded PC - WES7 - Tools

Betriebssysteme

  • Beckhoff EWF Manager
  • Beckhoff FBWF Manager
  • Beckhoff IPC-FeatureManager


Beckhoff FBWF Manager

Der Beckhoff FBWF Manager ist ein Tool, mit dem sich der FBWF (File Based Write Filter) sehr einfach mit einer grafischen Oberfläche bedienen lässt. Die bisherige Methode des Einstellens über die Eingabekonsole ist damit hinfällig. Mehr zum Thema File Based Write Filter finden Sie hier.

Übersicht über die Oberfläche “General Settings“ des Beckhoff File Based Write Filter Managers:

Abbildung 1: Beckhoff File Based Write Filter Manager - General Settings

Die Funktionen der Oberfläche sind der untenstehenden Tabelle zu entnehmen.

Current State | Zeigt den aktuellen Status des FBWF an.
Next State | Zeigt den Status des FBWF nach einem Neustart des Systems an.
Change State | Schaltet den FBWF ein bzw. aus.
Compression | Zeigt ob die Komprimierung des FBWF Overlays aktiv ist.
Next Compression | Zeigt ob die Komprimierung des FBWF Overlays nach einem Neustart ein- bzw. ausgeschaltet wird/ist.
Change Compression | Schaltet die Komprimierung ein bzw. aus.
PreAllocation | Zeigt ob die PreAllocation aktiviert bzw. deaktiviert ist.
Next Pre Allocation | Zeigt ob die PreAllocation beim nächsten Start aktiv bzw. nicht aktiv ist.
Change PreAllocation | Schaltet die PreAllocation ein bzw. aus.

Übersicht über die Oberfläche “Exclusions“ des Beckhoff File Based Write Filter Managers:

Abbildung 2: Beckhoff File Based Write Filter Manager - Exclusions

Die Funktionen der Oberfläche sind der untenstehenden Tabelle zu entnehmen.

Add Folder | Fügt den ausgewählten Ordner der Exclusionlist nach einem Neustart hinzu.
Add File | Fügt eine ausgewählte Datei der Exclusionlist nach einem Neustart hinzu.
Remove Exclusion | Entfernt die im Fenster Exclusionlist per Haken ausgewählte Datei oder das ausgewählte Verzeichnis von der aktuellen Exclusionlist.
Exclusionlist | Zeigt Verzeichnisse und Dateien die sich aktuell in der Exclusionlist befinden.
Changes | Zeigt Änderungen an der Exclusionlist, die mit einem Neustart übernommen werden.

Hinweis:

Der Beckhoff FBWF Manager ist standardmäßig in allen Beckhoff Windows Embedded Standard 7 Images enthalten. Falls es sich um ein Kundenspezifisches Image handelt, stellen Sie bitte sicher, dass die File Based Write Filter Komponente in Ihrem Image enthalten ist.


Beckhoff EWF Manager

Der Beckhoff EWF Manager ist ein Tool, mit dem sich der EWF (Enhanced Write Filter) sehr einfach mit einer grafischen Oberfläche bedienen lässt.

Die bisherige Methode des Einstellens über die Eingabekonsole ist damit hinfällig.

Mehr zum Thema Enhanced Write Filter finden Sie hier.

In Abbildung 1.0 ist der EWF Manager abgebildet. Er zeigt den Type, Status, Boot command, Volume name und Volume ID an.

Abbildung 1.0

In der Tabelle 1 werden die "EWF overlay store configuration" EWF Information/Konfiguration beschrieben

Tabelle 2 beschreibt die "Action" Kommandos zur Handhabung des EWF

Tabelle 1

Type: | Zeigt an, welche Art von EWF Volumen genutzt wird. In den neuen Versionen (ab 1.14) wird das EWF Volumen im RAM ausgeführt. D.h. es wird keine zusätzliche EWF Partition benötigt
State: | Zeigt den aktuellen Status des Enhanced Write Filters an, d.h. ob er Eingeschaltet (Enabled) oder Ausgeschaltet (Disabled) ist.
Boot command: | Zeigt an was beim nächsten Booten ausgeführt wird. Es gibt folgende "Boot commands": 1. "EWF NO CMD": es wird nichts geändert. 2. "EWF ENABLE": der EWF wird beim nächsten Booten Eingeschaltet "Enabled". 3. "EWF DISABLE": der EWF wird beim nächsten Booten Ausgeschaltet "Disabled". 4. "EWF COMMIT": Daten werden beim Herunterfahren auf die HD geschrieben, obwohl der EWF Enabled ist.
Volume ID: | Zeigt die ID (Hexadezimal) der Partition der Compact-Flash.
Volume name: | Zeigt den Namen der Partition der Compact-Flash

Tabelle 2

Enable | Mit dem "Enable" Button können Sie Ihren Enhanced Write Filter einschalten. Dieses bestätigen Sie dann mit OK
Disable | Mit dem "Disable" Button können Sie den Enhanced Write Filter ausschalten. Dieses bestätigen Sie dann mit OK
Commit changes | Mit "Commit" können Sie, bei eingeschaltetem Enhanced Write Filter, Daten zur Laufzeit übernehmen. Dieses bestätigen Sie dann mit OK
Commitanddisable -live | Mit "Commitanddisable -live" k nnen Sie den Enhanced Write Filter ohne einen Neustart des Systems ausschalten. Dieses bestätigen Sie dann bitte mit OK.
Clear command | Mit "Clear command" können Sie den "Boot command" wieder auf "EWF_NO_CMD" setzen, somit wird beim nächsten Neustart der "EWF" eingeschaltet (Enabled) bzw. ausgeschaltet (Disabled). Dieses bestätigen Sie dann bitte mit OK.
Exit | Mit "Exit" können Sie den EWF Manager beenden.
Reboot | Mit dem "Reboot" Button können Sie Ihr System Neustarten.

Hinweis:

Der Beckhoff FBWF Manager ist standardmäßig in allen Beckhoff Windows Embedded Standard 7 Images enthalten. Falls es sich um ein Kundenspezifisches Image handelt, stellen Sie bitte sicher, dass die Enhanced Write Filter Komponente in Ihrem Image enthalten ist.

Hinweis:

Der EWF Manager kann auch nachinstalliert werden, so lange die Konfiguration aus einem EWF volume besteht.


Beckhoff IPC-FeatureManager

Betriebssysteme

Übersicht

Der Beckhoff IPC-FeatureManager dient zur Installation von Sprach- und Komponentenpaketen.
Zur Inbetriebnahme der Komponente ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Der Beckhoff IPC-FeatureManager ist nur für den Einsatz unter Windows Embedded System ausgelegt und biete keine Kompatibilität zu anderen Betriebssystemen.

Achtung

Durch das Deinstallieren von Sprach- oder Komponentenpaketen kann es zu schweren Schäden am System kommen. Bitte Beachten Sie die Informationshinweise oder wenden Sie sich an Ihrem Systemadministrator um Schäden am System zu vermeiden.


Beckhoff IPC-FeatureManager

Betriebssysteme

Install Packages

Unter dem Reiter Install Packages können Sie neue von Beckhoff vorgefertigte Komponentenpakete installieren.

Eine Auswahl der verfügbaren Sprachpakete finden sie hier:

  • Sprachpakete für x86-Systeme
  • Sprachpakete für x64-Systeme
.

Package Directory | Auswahl des Verzeichnisses, in welchem sich die .HTML-Datei des zu installierenden Komponentenpaketes befindet. Das Verzeichnis kann mittels der Schaltfläche "Change" geändert werden. Die entsprechenden Komponentenpakete werden von Beckhoff bereit gestellt.
Available packages | Nachdem das entsprechende Verzeichnis ausgewählt wurde, werden in einer Liste alle verfügbaren Komponentenpakete aufgelistet. Sie können mehrere Pakete gleichzeitig auswählen und ber die Schaltfläche "Install" den Installationsvorgang starten.

Hinweis: Sollte das ausgewählte Komponentenpaket bereits auf dem System installiert sein, so wird die vorhandene Installation überschrieben.

Hinweis: Manche Komponenten benötigen mehrere Pakete um funktionsfähig zu sein.


Beckhoff IPC-FeatureManager

Betriebssysteme

Remove Packages

Unter dem Reiter Remove Packages können Sie die derzeit installierten Komponentenpakete einsehen und entfernen.

Zur Auswahl stehen Ihnen alle auf dem System installierten Komponentenpakete.

Wählen Sie die gewünschten Komponenten auf der linken Seite aus und deinstallieren Sie diese über die Schaltfläche Remove.

Wichtiger Hinweis

  • Das Entfernen gewisser Komponenten kann Ihr gesamtes System instabil und sogar unbrauchbar machen.
  • Manche Komponenten können aus mehr als einem einzelnen Komponentenpaket bestehen.
  • Ein Komponentenpaket kann von mehreren Komponenten benötigt werden.

  • Wenden Sie sich an Ihren Systemadministrator wenn Sie sich nicht sicher sind, was das Entfernen der Komponente zur Folge hat.


Beckhoff IPC-FeatureManager

Betriebssysteme

Systemsprache ändern

Um eine bereits installierte Systemsprache in einem Windows Embedded Standard 7 P-Image zu aktivieren, gehen Sie bitte wie folgt vor:

  1. Klicken Sie mit der linken Maustaste auf Start und anschließend auf Systemsteuerung.

  2. Wählen Sie mit der linken Maustaste den Menüpunkt Region und Sprache.

  3. In dem sich öffnenden Fenster wählen Sie bitte den Reiter Tastaturen und Sprachen aus.

  4. Anschließend können Sie im unteren Bereich Ihre Systemsprache auswählen.


Übersicht

Aktuelle Basis Betriebssystem Images für Beckhoff Embedded-PC Plattformen

Produktnummer Beschreibung Version
CX1800-0202-0002
CX1800-0202-0005 		Basis Betriebssystemimage für die Beckhoff CX1020 / CX1030 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0 SP2
  • Enhanced Write Filter (EWF)
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.11 R3 Build 2223 NC-I Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 2.26a
CX1800-0202-0004 Basis Betriebssystemimage für die Beckhoff CX1010 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0 SP2
  • Enhanced Write Filter (EWF)
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.11 R3 Build 2223 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 2.26a
CX1800-0202-0007 Basis Betriebssystemimage für die Beckhoff CX50x0 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0 SP2
  • Enhanced Write Filter (EWF)
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.11 R3 Build 2223 NC-I Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 2.26a
CX1800-0212-0007 Basis Betriebssystemimage für die Beckhoff CX50x0 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0 SP2
  • Enhanced Write Filter (EWF)
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 3 Build 3102 XAR

Detaillierte Übersicht von den installierten Komponenten

 2.26a

Frühere Basis Betriebssystem Images für Beckhoff Embedded-PC Plattformen

Produktnummer Beschreibung Version
CX1800-0202-0002
CX1800-0202-0005 		Basis Betriebssystemimage für die Beckhoff CX1020 / CX1030 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0 SP1
  • Enhanced Write Filter (EWF)
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.11 R2 Build 2032 NC-I Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 2.22a
CX1800-0202-0004 Basis Betriebssystemimage für die Beckhoff CX1010 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0 SP1
  • Enhanced Write Filter (EWF)
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.11 R2 Build 2032 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 2.22a
CX1800-0202-0007 Basis Betriebssystemimage für die Beckhoff CX50x0 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0 SP1
  • Enhanced Write Filter (EWF)
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.11 R2 Build 2032 NC-I Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 2.22a
CX1800-0202-0002

CX1800-0202-0005

 Basis Betriebssystemimage für die Beckhoff CX1020 / CX1030 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0 SP1
  • Enhanced Write Filter (EWF)
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.10 Build 1340 NC-I Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 2.2
CX1800-0202-0004 Basis Betriebssystemimage für die Beckhoff CX1010 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0 SP1
  • Enhanced Write Filter (EWF)
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.10 Build 1340 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 2.2
CX1800-0202 Basis Betriebssystemimage für die Beckhoff CX1001 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0
  • Enhanced Write Filter (EWF)
  • Microsoft Feature Pack 2007
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.10 Build 1323 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.37
CX1800-0202-0002

CX1800-0202-0005

 Basis Betriebssystemimage für die Beckhoff CX1020 / CX1030 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0
  • Enhanced Write Filter (EWF)
  • Microsoft Feature Pack 2007
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.10 Build 1323 NC-I Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.37
CX1800-0202-0004 Basis Betriebssystemimage für die Beckhoff CX1010 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0
  • Enhanced Write Filter (EWF)
  • Microsoft Feature Pack 2007
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.10 Build 1323 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.37
CX1800-0202 Basis Betriebssystemimage für die Beckhoff CX1001 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0
  • Enhanced Write Filter (EWF)
  • Microsoft Feature Pack 2007
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.10 Build 1307 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.35
CX1800-0202-0002 Basis Betriebssystemimage für die Beckhoff CX1020 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0
  • Enhanced Write Filter (EWF)
  • Microsoft Feature Pack 2007
  • File Based Write Filter (FBWF)
  • Registry Filter
  • Microsoft DirectX 9.0c
  • TwinCAT 2.10 Build 1307 NC-I Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.35
CX1800-0202-0002 Basis Betriebssystemimage für die Beckhoff CX1020 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft Service Pack 2
  • Enhanced Write Filter (EWF)
  • Microsoft .NET Framework 2.0
  • Microsoft DirectX 9.0c
  • TwinCAT 2.10 Build 1203 NC-I Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.33
CX1800-0201-0002 Basis Betriebssystemimage für die Beckhoff CX1020 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Enhanced Write Filter (EWF)
  • Microsoft Service Pack 2
  • Microsoft DirectX 9.0c
  • TwinCAT 2.10 Build 1203 NC-I Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.33
CX1800-0202 Basis Betriebssystemimage für die Beckhoff CX1001 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 2.0
  • Enhanced Write Filter (EWF)
  • Microsoft Service Pack 2
  • Microsoft DirectX 9.0c
  • TwinCAT 2.9 Build 1030 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.33
CX1800-0201 Basis Betriebssystemimage für die Beckhoff CX1001 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Enhanced Write Filter (EWF)
  • Microsoft Service Pack 2
  • Microsoft DirectX 9.0c
  • TwinCAT 2.9 Build 1030 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.33
CX1800-0202-0002 Basis Betriebssystemimage für die Beckhoff CX1020 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 1.1
  • Enhanced Write Filter (EWF)
  • Microsoft Service Pack 2
  • TwinCAT 2.9 Build 1030 NC-I Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.30
CX1800-0201-0002 Basis Betriebssystemimage für die Beckhoff CX1020 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Enhanced Write Filter (EWF)
  • Microsoft Service Pack 2
  • TwinCAT 2.9 Build 1030 NC-I Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.30
CX1800-0202 Basis Betriebssystemimage für die Beckhoff CX1001 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 1.1
  • Enhanced Write Filter (EWF)
  • Microsoft Service Pack 2
  • TwinCAT 2.9 Build 1030 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.20
CX1800-0201 Basis Betriebssystemimage für die Beckhoff CX1001 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Enhanced Write Filter (EWF)
  • Microsoft Service Pack 2
  • TwinCAT 2.9 Build 1030 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.20
CX1800-0202 Basis Betriebssystemimage für die Beckhoff CX1001 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Microsoft .NET Framework 1.1
  • Enhanced Write Filter (EWF)
  • Microsoft Service Pack 1
  • TwinCAT 2.9 Build 1004 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.14
CX1800-0201 Basis Betriebssystemimage für die Beckhoff CX1001 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Enhanced Write Filter (EWF)
  • Microsoft Service Pack 1
  • TwinCAT 2.9 Build 1004 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.14
CX1800-0200 Basis Betriebssystemimage für die Beckhoff CX1001 Embedded-PC Plattform

Dieses Image enthält folgende charakteristische Merkmale:

  • Enhanced Write Filter (EWF)
  • Microsoft Service Pack 1
  • TwinCAT 2.9 Build 1004 NC-PTP Laufzeitumgebung

Detaillierte Übersicht von den installierten Komponenten

 1.14


Gemeinsame Eigenschaften der CX Images

Betriebssysteme

Eigenschaften der Basis Windows Embedded Images für Beckhoff Embedded-PC Plattformen

Hinweis: Ab den Windows Embedded Standard (WES) Images gibt es kein CX1001 Image mehr.

Übersicht der plattformspezifischen Eigenschaften der Windows Embedded Images für Beckhoff Embedded-PCs

Platform / Feature | Image Version | TwinCAT2 Laufzeitumgebungs-Version / Build / Level | TwinCAT3 Laufzeitumgebungs-Version / Build / Level | Plattform | Speicherbedarf
CX1800-0202-0002 CX1800-0202-0005 | 2.26a | 2.11 R3 / 2223 / NC I |  | CX1020 CX1030 | ca. 990MB
CX1800-0202-0004 | 2.26a | 2.11 R3 / 2223 / NC PTP |  | CX1010 | ca. 990MB
CX1800-0202-0007 | 2.26a | 2.11 R3 / 2223 / NC I |  | CX50x0 | ca. 990MB
CX1800-0212-0007 | 2.26a |  | 3.0 / 3102 / NC I | CX50x0 | ca. 1020MB

Übersicht der gemeinsamen Komponenten der Windows Embedded Images für Beckhoff Embedded-PCs

  • Allgemeine Daten

  • Entwicklung / Laufzeitumgebungen / Schnittstellen

  • Applikationen

  • Netzwerk

  • Systemverwaltung / Systemwerkzeuge

  • Geräteunterstützung

  • Dienste

Komponente / Image

Allgemeine Daten
Energieverwaltung: Standard PC
Grafische Oberfläche: Explorer Shell
Sprache (MUI): Englisch/Deutsch (als Standardsprache ist Englisch eingestellt)

Entwicklung / Laufzeitumgebungen / Schnittstellen
Microsoft .NET Framework 2.0 Service Pack 2 (v.2.2.30729)
ADS .NET Unterstützung
ASP .NET Unterstützung
DirectX 9.0c Laufzeitumgebung
C Laufzeit Bibliothek
COM+ (DCOM, MSDTC, ...)
EWF Anwendungsprogrammierungsschnittstelle (API)
FBWF Anwendungsprogrammierungsschnittstelle (API)
Jet Datenbank Schnittstellen (ODBC, OLEDB, DAO)
ODBC Schnittstellen
TwinCAT Laufzeitumgebung (ADS, COM,...)
Visual Basic 6.0 Laufzeit Bibliothek
Visual C++ Laufzeitumgebung
Windows Installer 4.5
Microsoft Visual C++ 2005 Redistributable (v. 8.0.56336)
Microsoft Visual C++ 2008 Redistributable (v. 9.0.30729.4148)
Microsoft Visual C++ 2010 Redistributable (v. 10.0.30319)
Silverlight 5 (v. 5.0.61118.0)

Applikationen
Eingabeaufforderung / Konsole
HyperTerminal
Internet Explorer 7
Netmeeting
Notepad
On-Screen Keyboard
Paint
Rechner
Windows Explorer
Windows Media Player 6.4
Wordpad
Zeichentabelle
CXD-Tool
Beckhoff EWF Manager
Beckhoff FBWF Manager
Beckhoff On-Screen-Keyboard (BkOSK)

Netzwerk
Netzwerk Unterstützung (TCP/IP, EtherCAT)
Dateifreigabe
Datenfernübertragung (DFÜ)
Direkte Verbindung (Nullmodem)
DHCP Client
DNS Client
Net Shell
Netzwerkdrucken
Netzwerk Setup Wizard
Remote Desktop
PPPoE Protokoll
Windows Firewall (ICS)

Systemverwaltung / Systemwerkzeuge
Verwaltung (Event Log, Service Control Manager, Computer Management,...)
CheckDisk (mit autocheck Funktion)
Enhanced Write Filter (EWF)
File Based Write Filter (FBWF)
Registry Filter
Kompatibilitätsmodus (Windows 95, Windows 98, Windows NT 4, Windows 2000)
Registry Editor
Installierte Tastatur Layouts: Englisch, Deutsch
Systemsteuerung
Task Scheduler
Disk Management
Windows Firewall Control Panel

Geräteunterstützung
ATM Unterstützung
Audio Unterstützung (wave, midi, mp3)
Drahtloses / Funk- Netzwerk
(lokale) USB Drucker-Unterstützung
Elo Touch
Modem-Unterstützung
Microsoft Bluetooth Unterstützung
USB Audio Unterstützung
USB Speichermedien / USB Massenspeicher
IrDA Unterstützung
Virtuelle-SCSI Unterstützung (NDAS)
CU88xx Unterstützung

Dienste
Automatic Updates
Distributed Transaction Coordinator (MSDTC)
Indexing Service
Messenger (net send)
Internet Information Service (IIS Web-Server)
Message Queuing (MSMQ)
Simple Network Management Protocol (SNMP)
RunAs Service
Time Service
Unterbrechungsfreie Strom-Versorgung (USV)
Beckhoff IPC Diagnostics (v.1.6.74)


Gemeinsame Eigenschaften der CX Images

Betriebssysteme

Eigenschaften der Basis Windows Embedded Images für Beckhoff Embedded-PC Plattformen

Hinweis: Ab den Windows Embedded Standard (WES) Images gibt es kein CX1001 Image mehr.

Übersicht der plattformspezifischen Eigenschaften der Windows Embedded Images für Beckhoff Embedded-PCs

Feature / Plattform | CX1800-0202-0002 | CX1800-0202-0004 | CX1800-0202-0007
 | CX1800-0202-0005
Allgemeine Daten |  |  |
Image Version | 2.22a | 2.22a | 2.22a
TwinCAT Laufzeitumgebungs-Version / Build / Level | 2.11 R2 / 2032 / NC I | 2.11 R2 / 2032 / NC PTP | 2.11 R2 / 2032 / NC I
Plattform | CX1020 / CX1030 | CX1010 | CX50x0
Speicherbedarf | ca. 950 MB | ca. 950 MB | ca. 950 MB

Übersicht der gemeinsamen Komponenten der Windows Embedded Images für Beckhoff Embedded-PCs

  • Allgemeine Daten

  • Entwicklung / Laufzeitumgebungen / Schnittstellen

  • Applikationen

  • Netzwerk

  • Systemverwaltung / Systemwerkzeuge

  • Geräteunterstützung

  • Dienste

Komponente / Image

Allgemeine Daten
Energieverwaltung: Standard PC
Grafische Oberfläche: Explorer Shell
Sprache (MUI): Englisch/Deutsch (als Standardsprache ist Englisch eingestellt)

Entwicklung / Laufzeitumgebungen / Schnittstellen
Microsoft .NET Framework 2.0 Service Pack 1 (v.2.1.21022)
ADS .NET Unterstützung
ASP .NET Unterstützung
DirectX 9.0c Laufzeitumgebung
C Laufzeit Bibliothek
COM+ (DCOM, MSDTC, ...)
EWF Anwendungsprogrammierungsschnittstelle (API)
FBWF Anwendungsprogrammierungsschnittstelle (API)
Jet Datenbank Schnittstellen (ODBC, OLEDB, DAO)
ODBC Schnittstellen
TwinCAT Laufzeitumgebung (ADS, COM,...)
Visual Basic 6.0 Laufzeit Bibliothek
Visual C++ Laufzeitumgebung
Windows Installer 4.5
Microsoft Visual C++ 2005 Redistributable (v.8.0.56336)
Microsoft Visual C++ 2008 Redistributable (v.9.0.30729.17)
Microsoft Visual C++ 2008 Redistributable (v.9.0.30729.4148)
Microsoft Visual C++ 2010 Redistributable (v.10.0.30319)
Silverlight 4.0 (v.4.0.50826.0)

Applikationen
Eingabeaufforderung / Konsole
HyperTerminal
Internet Explorer 7
Netmeeting
Notepad
On-Screen Keyboard
Paint
Rechner
Windows Explorer
Windows Media Player 6.4
Wordpad
Zeichentabelle
CXD-Tool
Beckhoff EWF Manager
Beckhoff FBWF Manager
Beckhoff On-Screen-Keyboard (BkOSK)

Netzwerk
Netzwerk Unterstützung (TCP/IP, EtherCAT)
Dateifreigabe
Datenfernübertragung (DFÜ)
Direkte Verbindung (Nullmodem)
DHCP Client
DNS Client
Net Shell
Netzwerkdrucken
Netzwerk Setup Wizard
Remote Desktop
PPPoE Protokoll
Windows Firewall (ICS)

Systemverwaltung / Systemwerkzeuge
Verwaltung (Event Log, Service Control Manager, Computer Management,...)
CheckDisk (mit autocheck Funktion)
Enhanced Write Filter (EWF)
File Based Write Filter (FBWF)
Registry Filter
Kompatibilitätsmodus (Windows 95, Windows 98, Windows NT 4, Windows 2000)
Registry Editor
Installierte Tastatur Layouts: Englisch, Deutsch
Systemsteuerung
Task Scheduler
Disk Management
Windows Firewall Control Panel

Geräteunterstützung
ATM Unterstützung
Audio Unterstützung (wave, midi, mp3)
Drahtloses / Funk- Netzwerk
(lokale) USB Drucker-Unterstützung
Elo Touch
Modem-Unterstützung
Microsoft Bluetooth Unterstützung
USB Audio Unterstützung
USB Speichermedien / USB Massenspeicher
IrDA Unterstützung
Virtuelle-SCSI Unterstützung (NDAS)
CU88xx Unterstützung

Dienste
Automatic Updates
Distributed Transaction Coordinator (MSDTC)
Indexing Service
Messenger (net send)
Internet Information Service (IIS Web-Server)
Message Queuing (MSMQ)
Simple Network Management Protocol (SNMP)
RunAs Service
Time Service
Unterbrechungsfreie Strom-Versorgung (USV)
Beckhoff IPC Diagnostics (v.1.5.5713)


Gemeinsame Eigenschaften der CX Images

Betriebssysteme

Eigenschaften der Basis Windows Embedded Images für Beckhoff Embedded-PC Plattformen

Hinweis: Ab den Windows Embedded Standard (WES) Images gibt es kein CX1001 Image mehr.

Übersicht der plattformspezifischen Eigenschaften der Windows Embedded Images für Beckhoff Embedded-PCs

Feature / Plattform | CX1800-0202-0002 | CX1800-0202-0004
 | CX1800-0202-0005
Allgemeine Daten |  |
Image Version | 2.2 | 2.2
TwinCAT Laufzeitumgebungs-Version / Build / Level | 2.10 / 1340 / NC I | 2.10 / 1340 / NC PTP
Plattform | CX1020 / CX1030 | CX1010
Speicherbedarf | ca. 850 MB | ca. 850 MB

Übersicht der gemeinsamen Komponenten der Windows Embedded Images für Beckhoff Embedded-PCs

  • Allgemeine Daten

  • Entwicklung / Laufzeitumgebungen / Schnittstellen

  • Applikationen

  • Netzwerk

  • Systemverwaltung / Systemwerkzeuge

  • Geräteunterstützung

  • Dienste

Komponente / Image

Allgemeine Daten
Energieverwaltung: Standard PC
Grafische Oberfläche: Explorer Shell
Sprache (MUI): Englisch/Deutsch (als Standardsprache ist Englisch eingestellt)

Entwicklung / Laufzeitumgebungen / Schnittstellen
Microsoft .NET Framework 2.0 SP1
ADS .NET Unterstützung
ASP .NET Unterstützung
DirectX 9.0c Laufzeitumgebung
C Laufzeit Bibliothek
COM+ (DCOM, MSDTC, ...)
EWF Anwendungsprogrammierungsschnittstelle (API)
FBWF Anwendungsprogrammierungsschnittstelle (API)
Jet Datenbank Schnittstellen (ODBC, OLEDB, DAO)
ODBC Schnittstellen
TwinCAT Laufzeitumgebung (ADS, COM,...)
Visual Basic 6.0 Laufzeit Bibliothek
Visual C++ Laufzeitumgebung
Windows Installer 3.1
Microsoft Visual C++ 2005 Redistributable (v.8.0.56336)
Microsoft Visual C++ 2008 Redistributable (v.9.0.30729)
Silverlight 2.0 (v.2.0.40115.0)

Applikationen
Eingabeaufforderung / Konsole
HyperTerminal
Internet Explorer 7
Netmeeting
Notepad
On-Screen Keyboard
Paint
Rechner
Windows Explorer
Windows Media Player 6.4
Wordpad
Zeichentabelle
CXD-Tool
Beckhoff EWF Manager
Beckhoff FBWF Manager
Beckhoff On-Screen-Keyboard (BkOSK)

Netzwerk
Netzwerk Unterstützung (TCP/IP, EtherCAT)
Dateifreigabe
Datenfernübertragung (DFÜ)
Direkte Verbindung (Nullmodem)
DHCP Client
DNS Client
Net Shell
Netzwerkdrucken
Netzwerk Setup Wizard
Remote Desktop
PPPoE Protokoll
Windows Firewall (ICS)

Systemverwaltung / Systemwerkzeuge
Verwaltung (Event Log, Service Control Manager, Computer Management,...)
CheckDisk (mit autocheck Funktion)
Enhanced Write Filter (EWF)
File Based Write Filter (FBWF)
Registry Filter
Kompatibilitätsmodus (Windows 95, Windows 98, Windows NT 4, Windows 2000)
Registry Editor
Installierte Tastatur Layouts: Englisch, Deutsch
Systemsteuerung
Task Scheduler
Disk Management
Windows Firewall Control Panel

Geräteunterstützung
ATM Unterstützung
Audio Unterstützung (wave, midi, mp3)
Drahtloses / Funk- Netzwerk
(lokale) USB Drucker-Unterstützung
Elo Touch
Modem-Unterstützung
Microsoft Bluetooth Unterstützung
USB Audio Unterstützung
USB Speichermedien / USB Massenspeicher
IrDA Unterstützung
Virtuelle-SCSI Unterstützung (NDAS)
CU88xx Unterstützung

Dienste
Automatic Updates
Distributed Transaction Coordinator (MSDTC)
Indexing Service
Messenger (net send)
Internet Information Service (IIS Web-Server)
Message Queuing (MSMQ)
Simple Network Management Protocol (SNMP)
RunAs Service
Time Service
Unterbrechungsfreie Strom-Versorgung (USV)
Modular Device Profile (MDP)


Gemeinsame Eigenschaften der CX Images

Betriebssysteme

Eigenschaften der Basis windows XP embedded Images für Beckhoff Embedded-PC Plattformen

Hinweis: Die Windows XP embedded Images ab Version 1.35 wurden reorganisiert : Die bisherigen Images CX1800-0201 HMI und CX1800-0202 .NET wurden im CX1800-0202 zusammengefasst.

Übersicht der plattformspezifischen Eigenschaften der Windows XP embedded Images für Beckhoff Embedded-PCs

Feature / Plattform | CX1800-0202 | CX1800-0202-0002 | CX1800-0202-0004
 |  | CX1800-0202-0005
Allgemeine Daten |  |  |
Image Version | 1.37 | 1.37 | 1.37
TwinCAT Laufzeitumgebungs-Version / Build / Level | 2.10 / 1323 / NC PTP | 2.10 / 1323 / NC I | 2.10 / 1323 / NC PTP
Plattform | CX1000 | CX1020 / CX1030 | CX1010
Speicherbedarf | ca. 600 MB | ca. 600 MB | ca. 600 MB

Übersicht der gemeinsamen Komponenten der Windows XP embedded Images für Beckhoff Embedded-PCs

  • Allgemeine Daten

  • Entwicklung / Laufzeitumgebungen / Schnittstellen

  • Applikationen

  • Netzwerk

  • Systemverwaltung / Systemwerkzeuge

  • Geräteunterstützung

  • Dienste

Komponente / Image

Allgemeine Daten
Energieverwaltung: Standard PC
Grafische Oberfläche: Explorer Shell
Sprache: Englisch

Entwicklung / Laufzeitumgebungen / Schnittstellen
Microsoft .NET Framework 2.0
ADS .NET Unterstützung
ASP .NET Unterstützung
DirectX 9.0c Laufzeitumgebung
C Laufzeit Bibliothek
COM+ (DCOM, MSDTC, ...)
EWF Anwendungsprogrammierungsschnittstelle (API)
FBWF Anwendungsprogrammierungsschnittstelle (API)
Jet Datenbank Schnittstellen (ODBC, OLEDB, DAO)
ODBC Schnittstellen
TwinCAT Laufzeitumgebung (ADS, COM,...)
Visual Basic 6.0 Laufzeit Bibliothek
Visual C++ Laufzeitumgebung
Windows Installer 3.1
Microsoft Visual C++ 2005 Redistributable (v.8.0.56336)

Applikationen
Eingabeaufforderung / Konsole
HyperTerminal
Internet Explorer 7
Netmeeting
Notepad
On-Screen Keyboard
Paint
Rechner
Windows Explorer
Windows Media Player 6.4
Wordpad
Zeichentabelle
CXD-Tool
Beckhoff EWF Manager
Beckhoff FBWF Manager

Netzwerk
Netzwerk Unterstützung (TCP/IP, EtherCAT)
Dateifreigabe
Datenfernübertragung (DFÜ)
Direkte Verbindung (Nullmodem)
DHCP Client
DNS Client
Net Shell
Netzwerkdrucken
Netzwerk Setup Wizard
Remote Desktop
PPPoE Protokoll
Windows Firewall (ICS)

Systemverwaltung / Systemwerkzeuge
Verwaltung (Event Log, Service Control Manager, Computer Management,...)
CheckDisk (mit autocheck Funktion)
Enhanced Write Filter (EWF)
File Based Write Filter (FBWF)
Registry Filter
Kompatibilitätsmodus (Windows 95, Windows 98, Windows NT 4, Windows 2000)
Registry Editor
Installierte Tastatur Layouts: Englisch, Deutsch
Systemsteuerung
Task Scheduler
Disk Management
Windows Firewall Control Panel

Geräteunterstützung
ATM Unterstützung
Audio Unterstützung (wave, midi, mp3)
Drahtloses / Funk- Netzwerk
(lokale) USB Drucker-Unterstützung
Elo Touch
Modem-Unterstützung
Microsoft Bluetooth Unterstützung
USB Audio Unterstützung
USB Speichermedien / USB Massenspeicher
IrDA Unterstützung
Virtuelle-SCSI Unterstützung (NDAS)

Dienste
Automatic Updates
Distributed Transaction Coordinator (MSDTC)
Indexing Service
Messenger (net send)
Internet Information Service (IIS Web-Server)
Message Queuing (MSMQ)
Simple Network Management Protocol (SNMP)
RunAs Service
Time Service
Unterbrechungsfreie Strom-Versorgung (USV)


Gemeinsame Eigenschaften der CX Images

Betriebssysteme

Eigenschaften der Basis windows XP embedded Images für Beckhoff Embedded-PC Plattformen

Hinweis: Die Windows XPembedded Images ab Version 1.35 wurden reorganisiert : Die bisherigen Images CX1800-0201 HMI und CX1800-0202 .NET wurden im CX1800-0202 .NET zusammengefasst.

Übersicht der plattformspezifischen Eigenschaften der Windows XP embedded Images für Beckhoff Embedded-PCs

Feature / Plattform | CX1800-0202 | CX1800-0202-0002
Allgemeine Daten | .NET | .NET
Image Version | 1.35 | 1.35
TwinCAT Laufzeitumgebungs-Version / Build / Level | 2.10 / 1307 / NC PTP | 2.10 / 1307 / NC I
Plattform | CX1000 | CX1020
Speicherbedarf | ca. 600 MB | ca. 600 MB

Übersicht der gemeinsamen Komponenten der Windows XP embedded Images für Beckhoff Embedded-PCs

  • Allgemeine Daten

  • Entwicklung / Laufzeitumgebungen / Schnittstellen

  • Applikationen

  • Netzwerk

  • Systemverwaltung / Systemwerkzeuge

  • Geräteunterstützung

  • Dienste

Komponente / Image | .NET
Allgemeine Daten | .NET
Energieverwaltung | Standard PC
Grafische Oberfläche | Explorer Shell
Sprache | Englisch
Entwicklung / Laufzeitumgebungen / Schnittstellen | .NET
Microsoft .NET Framework 2.0 | X
ADS .NET Unterstützung | X
ASP .NET Unterstützung | X
DirectX 9.0c Laufzeitumgebung | X
C Laufzeit Bibliothek | X
COM+ (DCOM, MSDTC, ...) | X
EWF Anwendungsprogrammierungsschnittstelle (API) | X
FBWF Anwendungsprogrammierungsschnittstelle (API) | X
Jet Datenbank Schnittstellen (ODBC, OLEDB, DAO) | X
ODBC Schnittstellen | X
TwinCAT Laufzeitumgebung (ADS, COM,...) | X
Visual Basic 6.0 Laufzeit Bibliothek | X
Visual C++ Laufzeitumgebung | X
Windows Installer | X
Microsoft Visual C++ 2005 Redistributable | X
Applikationen | .NET
Eingabeaufforderung / Konsole | X
HyperTerminal | X
Internet Explorer 6 | X
Netmeeting | X
Notepad | X
On-Screen Keyboard | X
Paint | X
Rechner | X
Windows Explorer | X
Windows Media Player 6.4 | X
Wordpad | X
Zeichentabelle | X
CXD-Tool | X
Beckhoff EWF Manager | X
Netzwerk | .NET
Netzwerk Unterstützung (TCP/IP, EtherCAT) | X
Dateifreigabe | X
Datenfernübertragung (DFÜ) | X
Direkte Verbindung (Nullmodem) | X
DHCP Client | X
DNS Client | X
Net Shell | X
Netzwerkdrucken | X
Netzwerk Setup Wizard | X
Remote Desktop | X
PPPoE Protokoll | X
Windows Firewall (ICS) | X
Systemverwaltung / Systemwerkzeuge | .NET
Verwaltung (Event Log, Service Control Manager, Computer Management,...) | X
CheckDisk (mit autocheck Funktion) | X
Enhanced Write Filter (EWF) | X
File Based Write Filter (FBWF) | X
Registry Filter | X
Kompatibilitätsmodus (DOS, Windows 95, Windows 98, Windows 2000) | X
Registry Editor | X
Installierte Tastatur Layouts | Englisch, Deutsch
Systemsteuerung | X
Task Scheduler | X
Disk Management | X
Windows Firewall Control Panel | X
Geräteunterstützung | .NET
ATM Unterstützung (dsl fähig) | X
Audio Unterstützung (wave, midi, mp3) | X
Drahtloses / Funk- Netzwerk | X
(lokale) USB Drucker-Unterstützung | X
Elo Touch | X
Modem-Unterstützung | X
Microsoft Bluetooth Unterstützung | X
USB Audio Unterstützung | X
USB Speichermedien / USB Massenspeicher | X
IrDA Unterstützung | X
Virtuelle-SCSI Unterstützung (NDAS) | X
Dienste | .NET
Distributed Transaction Coordinator (MSDTC) | X
Indexing Service | X
Messenger (net send) | X
Internet Information Service (IIS Web-Server) | X
Message Queuing (MSMQ) | X
Simple Network Management Protocol (SNMP) | X
RunAs Service | X
Time Service | X
Unterbrechungsfreie Strom-Versorgung (USV) | X


Bestandteile XPE Image 1.33

Betriebssysteme

Bestandteile

Übersicht der plattformspezifischen Eigenschaften der Windows XP embedded Images für Beckhoff Embedded-PCs

Feature / Plattform | CX1800-0201 | CX1800-0202
Allgemeine Daten | HMI | .NET
Image Version | 1.33 | 1.33
TwinCAT Laufzeitumgebungs-Version / Build / Level | 2.9 / 1030 / NC PTP | 2.9 / 1030 / NC PTP
Plattform | CX1000 | CX1000
Speicherbedarf (Dateisystem komprimiert) | 280 MB | 400 MB

Feature / Plattform | CX1800-0201-0002 | CX1800-0202-0002
Allgemeine Daten | HMI | .NET
Image Version | 1.33 | 1.33
TwinCAT Laufzeitumgebungs-Version / Build / Level | 2.9 / 1030 / NC PTP | 2.9 / 1030 / NC PTP
Plattform | CX1020 | CX1020
Speicherbedarf (Dateisystem komprimiert) | 346 MB | 455 MB

Übersicht der gemeinsamen Komponenten der Windows XP embedded Images für Beckhoff Embedded-PCs

Die folgende Tabelle stellt die gemeinsamen Komponenten der Basis Images Version 1.20 für CX1000 Embedded PCs bzw.

die Komponenten Basis Images Version 1.30 für CX1020 Embedded PCs dar.

  • Allgemeine Daten

  • Entwicklung / Laufzeitumgebungen / Schnittstellen

  • Applikationen

  • Netzwerk

  • Systemverwaltung / Systemwerkzeuge

  • Geräteunterstützung

  • Dienste

Komponente / Image | CX1800-0201 HMI | CX1800-0202 .NET
Allgemeine Daten | HMI | .NET
Energieverwaltung | Standard PC | Standard PC
Service Pack | Service Pack 2 | Service Pack 2
Grafische Oberfläche | Explorer Shell | Explorer Shell
Sprache | Englisch | Englisch
Entwicklung / Laufzeitumgebungen / Schnittstellen | HMI | .NET
.NET Framework 2.0 |  | X
ADS .NET Unterstützung |  | X
ASP .NET Unterstützung |  | X
C Laufzeit Bibliothek | X | X
COM+ (DCOM, MSDTC, ...) | X | X
DirectX 9.0c runtime | X | X
EWF Anwendungsprogrammierungsschnittstelle (API) | X | X
Jet Datenbank Schnittstellen (ODBC, OLEDB, DAO) | X | X
ODBC Schnittstellen | X | X
TwinCAT Laufzeitumgebung (ADS, COM,...) | X | X
Visual Basic 6.0 Laufzeit Bibliothek | X | X
Visual C++ Laufzeitumgebung | X | X
Windows Installer |  | X
Applikationen | HMI | .NET
Eingabeaufforderung / Konsole | X | X
HyperTerminal | X | X
Internet Explorer 6 | X | X
Netmeeting |  | X
Notepad | X | X
On-Screen Keyboard | X | X
Paint | X | X
Rechner | X | X
Windows Explorer | X | X
Windows Media Player 6.4 | X | X
Wordpad | X | X
Zeichentabelle | X | X
Beckhoff EWF Manager | X | X
Netzwerk | HMI | .NET
Netzwerk Unterstützung (TCP/IP, EtherCAT) | X | X
Dateifreigabe | X | X
Datenfernübertragung (DFÜ) | X | X
Direkte Verbindung (Nullmodem) | X | X
DHCP Client | X | X
DNS Client | X | X
Net Shell | X | X
Netzwerkdrucken | X | X
Netzwerk Setup Wizard | X | X
Remote Desktop | X | X
PPPoE Protokoll | X | X
Windows Firewall (ICS) | X | X
Systemverwaltung / Systemwerkzeuge | HMI | .NET
Verwaltung (Event Log, Service Control Manager, Computer Management,...) | X | X
CheckDisk (mit autocheck Funktion) | X | X
Enhanced Write Filter (EWF) | X | X
Kompatibilitätsmodus (DOS, Windows 95, Windows 98, Windows 2000) |  | X
Registry Editor | X | X
System Locals / Tastatur Layout | Englisch, Deutsch | Englisch, Deutsch
Systemsteuerung | X | X
Systemwiederherstellung |  | X
Task Scheduler | X | X
Disk Management |  | X
Windows Firewall Control Panel |  | X
Geräteunterstützung | HMI | .NET
ATM Unterstützung (dsl fähig) | X | X
Audio Unterstützung (wave, midi, mp3) | X | X
Drahtloses / Funk- Netzwerk | X | X
(lokale) USB Drucker-Unterstützung | X | X
Elo Touch | X | X
Modem-Unterstützung | X | X
Microsoft Bluetooth Unterstützung |  | X
USB Audio Unterstützung |  | X
USB Speichermedien / USB Massenspeicher | X | X
IrDA Unterstützung |  | X
Dienste | HMI | .NET
Distributed Transaction Coordinator (MSDTC) | X | X
Indexing Service |  | X
Messenger (net send) | X | X
Internet Information Service (IIS Web-Server) |  | X
Message Queuing (MSMQ) | X | X
Simple Network Management Protocol (SNMP) | X | X
RunAs Service | X | X
Time Service | X | X
Unterbrechungsfreie Strom-Versorgung (USV) |  | X


Bestandteile XPE Image 1.20

Betriebssysteme

Bestandteile

Übersicht der plattformspezifischen Eigenschaften der Windows XP embedded Images für Beckhoff Embedded-PCs

Hinweis: Die Windows XPembedded Images ab Version 1.20 wurden reorganisiert : Die bisherigen Images CX1800-0200 LF und CX1800-0201 HMI wurden im CX1800-0201 HMI zusammengefasst.

Plattformspezifische Infomationen zum Basis Image Version 1.20

Feature / Plattform | CX1800-0201 | CX1800-0202
Allgemeine Daten | HMI | .NET
Image Version | 1.20 | 1.20
TwinCAT Laufzeitumgebungs-Version / Build / Level | 2.9 / 1030 / NC PTP | 2.9 / 1030 / NC PTP
Plattform | CX1000 | CX1000
Speicherbedarf (Dateisystem komprimiert) | 210 MB | 290 MB

Plattformspezifische Infomationen zum Basis Image Version 1.30

Feature / Plattform | CX1800-0201-0002 | CX1800-0202-0002
Allgemeine Daten | HMI | .NET
Image Version | 1.30 | 1.30
TwinCAT Laufzeitumgebungs-Version / Build / Level | 2.9 / 1030 / NC PTP | 2.9 / 1030 / NC PTP
Plattform | CX1020 | CX1020
Speicherbedarf (Dateisystem komprimiert) | 244 MB | 316 MB

Übersicht der gemeinsamen Komponenten der Windows XP embedded Images für Beckhoff Embedded-PCs

Die folgende Tabelle stellt die gemeinsamen Komponenten der Basis Images Version 1.20 für CX1000 Embedded PCs bzw.

die Komponenten Basis Images Version 1.30 für CX1020 Embedded PCs dar.

  • Allgemeine Daten

  • Entwicklung / Laufzeitumgebungen / Schnittstellen

  • Applikationen

  • Netzwerk

  • Systemverwaltung / Systemwerkzeuge

  • Geräteunterstützung

  • Dienste

Komponente / Image | HMI | .NET
Allgemeine Daten | HMI | .NET
Energieverwaltung | Standard PC | Standard PC
Service Pack | Service Pack 2 | Service Pack 2
Grafische Oberfläche | Explorer Shell | Explorer Shell
Sprache | Englisch | Englisch
Entwicklung / Laufzeitumgebungen / Schnittstellen | HMI | .NET
.NET Framework 1.1 |  | X
ADS .NET Unterstützung |  | X
ASP .NET Unterstützung |  | X
C Laufzeit Bibliothek | X | X
COM+ (DCOM, MSDTC, ...) | X | X
EWF Anwendungsprogrammierungsschnittstelle (API) | X | X
Jet Datenbank Schnittstellen (ODBC, OLEDB, DAO) | X | X
ODBC Schnittstellen | X | X
TwinCAT Laufzeitumgebung (ADS, COM,...) | X | X
Visual Basic 6.0 Laufzeit Bibliothek | X | X
Visual C++ Laufzeitumgebung | X | X
Windows Installer |  | X
Applikationen | HMI | .NET
Eingabeaufforderung / Konsole | X | X
HyperTerminal | X | X
Internet Explorer 6 | X | X
Netmeeting |  | X
Notepad | X | X
On-Screen Keyboard | X | X
Paint | X | X
Rechner | X | X
Windows Explorer | X | X
Windows Media Player 6.4 | X | X
Wordpad | X | X
Zeichentabelle | X | X
Netzwerk | HMI | .NET
Netzwerk Unterstützung (TCP/IP, EtherCAT) | X | X
Dateifreigabe | X | X
Datenfernübertragung (DFÜ) | X | X
Direkte Verbindung (Nullmodem) | X | X
DHCP Client | X | X
DNS Client | X | X
Net Shell | X | X
Netzwerkdrucken | X | X
Netzwerk Setup Wizard | X | X
Remote Desktop | X | X
PPPoE Protokoll | X | X
Windows Firewall (ICS) | X | X
Systemverwaltung / Systemwerkzeuge | HMI | .NET
Verwaltung (Event Log, Service Control Manager, Computer Management,...) | X | X
CheckDisk (mit autocheck Funktion) | X | X
Enhanced Write Filter (EWF) | X | X
Kompatibilitätsmodus (DOS, Windows 95, Windows 98, Windows 2000) |  | X
Registry Editor | X | X
System Locals / Tastatur Layout | Englisch, Deutsch | Englisch, Deutsch
Systemsteuerung | X | X
Systemwiederherstellung |  | X
Task Scheduler | X | X
Disk Management |  | X
Windows Firewall Control Panel |  | X
Geräteunterstützung | HMI | .NET
ATM Unterstützung (dsl fähig) | X | X
Audio Unterstützung (wave, midi, mp3) | X | X
Drahtloses / Funk- Netzwerk | X | X
(lokale) USB Drucker-Unterstützung | X | X
Elo Touch | X | X
Modem-Unterstützung | X | X
Microsoft Bluetooth Unterstützung |  | X
USB Audio Unterstützung |  | X
USB Speichermedien / USB Massenspeicher | X | X
IrDA Unterstützung |  | X
Dienste | HMI | .NET
Distributed Transaction Coordinator (MSDTC) | X | X
Indexing Service |  | X
Messenger (net send) | X | X
Internet Information Service (IIS Web-Server) |  | X
Message Queuing (MSMQ) | X | X
Simple Network Management Protocol (SNMP) | X | X
RunAs Service | X | X
Time Service | X | X
Unterbrechungsfreie Strom-Versorgung (USV) |  | X


Bestandteile XPE Image 1.14

Betriebssysteme

Bestandteile

Hinweis: Die Windows XP embedded Images ab Version 1.20 wurden reorganisiert

Übersicht der Komponenten der XPe Images

Feature / Platform | CX1800-0200 LF | CX1800-0201 HMI | CX1800-0202 .NET
Allgemeine Daten | LF | HMI | .NET
Aktuelle Image Version | 1.14 | 1.14 | 1.14
Installierte Updates | Service Pack 1 | Service Pack 1 | Service Pack 1
Speicherbedarf (Dateisystem komprimiert) | ca. 105 MB | ca. 201 MB | ca. 250 MB
Grafische Oberfläche | Explorer Shell | Explorer Shell | Explorer Shell
Sprache | Englisch | Englisch | Englisch
Entwicklung / Laufzeitumgebungen / Schnittstellen | LF | HMI | .NET
.NET Framework 1.1 |  |  | X
ADS .NET Unterstützung |  |  | X
ASP .NET Unterstützung |  |  | X
C Laufzeit Bibliothek | X | X | X
COM+ (DCOM, MSDTC, ...) |  | X | X
EWF Anwendungsprogrammierungs-schnittstelle (API) | X | X | X
Jet Datenbank Schnittstellen (ODBC, OLEDB, DAO) |  | X | X
ODBC Schnittstellen |  | X | X
TwinCAT Laufzeitumgebung | X | X | X
Visual Basic 6.0 Laufzeit Bibliothek | X | X | X
Visual C++ Laufzeitumgebung | X | X | X
Windows Installer |  |  | X
Applikationen | LF | HMI | .NET
Eingabeaufforderung / Konsole | X | X | X
HyperTerminal |  | X | X
Internet Explorer 6 |  | X | X
Netmeeting |  |  | X
Notepad | X | X | X
On-Screen Keyboard |  | X | X
Paint | X | X | X
Rechner |  | X | X
Windows Explorer | X | X | X
Windows Media Player 6.4 |  | X | X
Wordpad |  | X | X
Zeichentabelle |  | X | X
Netzwerk | LF | HMI | .NET
Netzwerk Unterstützung (TCP/IP, EtherCAT) | X | X | X
Dateifreigabe | X | X | X
Datenfernübertragung (DFÜ) |  | X | X
Direkte Verbindung (Nullmodem) |  | X | X
DHCP Client | X | X | X
DNS Client | X | X | X
Internet Connection Firewall (ICF) |  |  | X
Net Shell | X | X | X
Netzwerkdrucken |  | X | X
Netzwerk Setup Wizard |  | X | X
Remote Desktop | X | X | X
Systemverwaltung / Systemwerkzeuge | LF | HMI | .NET
Verwaltung (Event Log, Service Control Manager, Computer Management,...) |  | X | X
CheckDisk (mit autocheck Funktion) | X | X | X
Enhanced Write Filter (EWF) | X | X | X
Kompatibilitätsmodus (DOS, Windows 95, Windows 98, Windows 2000) |  |  | X
Registry Editor | X | X | X
System Locals / Keyboard Layout | Englisch, Deutsch | Englisch, Deutsch | Englisch, Deutsch
Systemsteuerung |  | X | X
Task Scheduler | X | X | X
Geräteunterstützung | LF | HMI | .NET
Audio Unterstützung (wave, midi, mp3) |  | X | X
Drahtloses / Funk- Netzwerk |  | X | X
(lokale) USB Drucker-Unterstützung |  | X | X
Elo Touch | X | X | X
Modem-Unterstützung |  | X | X
USB Speichermedien / USB Massenspeicher | X | X | X
Dienste | LF | HMI | .NET
Distributed Transaction Coordinator (MSDTC) |  | X | X
Indexing Service |  |  | X
Messenger (net send) |  | X | X
Internet Information Service (IIS Web-Server) |  |  | X
Message Queuing (MSMQ) |  | X | X
Simple Network Management Protocol (SNMP) |  | X | X
Time Service | X | X | X
Unterbrechungsfreie Strom-Versorgung (USV) |  |  | X


Lokalisierte Windows XP embedded Images für Beckhoff Embedded-PCs

Betriebssysteme

Lokalisierte Windows Embedded Images für Beckhoff Embedded-PC Plattformen

Die Windows Embedded Standard Images für die embedded PCs werden in englischer Sprache ausgeliefert. Es besteht jedoch die Möglichkeit, lokalisierte Fassungen von den Windows Embedded Standard Images zu erhalten. Diese werden ab Werk geliefert. Eine Lokalisierung eines Windows Embedded Images benötigt mehr Platz auf dem Speichermedium. Der Speicherbedarf bei einer Lokalisierung kann um ca. 30 - 200 MB ansteigen. Die Speicherplatzänderung hängt von der gewählten Sprache ab.

Die Lokalisierung der Images geschieht durch die Multilingual User Interface Pakete (MUI). Dieses Lokalisierungskonzept wird verstärkt auch bei anderen (aktuellen) Windows Betriebssystemen angewendet.

Die Lokalisierung durch die MUI Pakete ist nahezu identisch mit den lokalisierten Versionen der Windows Betriebssysteme.

Bei der Verwendung dieser MUI Pakete werden jedoch einzelne Menüelemente nicht in die gewünschte Sprache übersetzt und bleiben in englischer Sprache.

Meistens werden folgende Teile des Betriebssystems nicht vollständig übersetzt:

  • Einzelne Elemente im Startmenü, z. B: die Elemente der Netzwerkeinstellungen
  • Einzelne Elemente in der Systemsteuerung, z.B.: Systemverwaltung / ODBC Schnittstellen.

Weitere Informationen zu den MUI Paketen von Microsoft finden Sie hier

Hier eine Liste der Standard Images für die CX-Images:

Artikelnummer | CX-Type
CX18xx-0202 | CX1000
CX18xx-0202-0002 | CX1020
CX18xx-0202-0004 | CX1010
CX18xx-0202-0005 | CX1030
CX18xx-0202-0007 | CX50x0

Entsprechende Sprachcodes:

Lokalisierte Images | Lokalisierungs Name
25 | Arabic
26 | Bulgarian
28 | Traditional Chinese
2 9 | Czech
30 | Danish
31 | German
32 | Greek
35 | Finnish
36 | French
37 | Hebrew
38 | Hungarian
40 | Italian
41 | Japanese
42 | Korean
43 | Dutch
44 | Norwegian (Bokmål)
45 | Polish
46 | Portuguese (Brazil)
48 | Romanian
49 | Russian
50 | Croatian
51 | Slovak
52 | Simplified Chinese
53 | Swedish
54 | Thai
55 | Turkish
60 | Slovenian
61 | Estonian
62 | Latvian
62 | Lithuanian
70 | Portuguese (Portugal)
83 | Spanish


Allgemeine Informationen

TwinCAT Lizenzierung unter Windows Embedded auf CX-Hardware

Die Lizenzierung von TwinCAT auf der CX Hardware (CX1000/CX1020/CX9000/Ethernetpanel...) verhält sich anders als die bisher gewohnte Registrierung von TwinCAT auf einem Industrie-PC.

  • Industrie-PC:
    Nach der TwinCAT Installation steht TwinCAT als 30-Tages Version zur Verfügung. Eine zeitlich unlimitierte Freischaltung erfolgt, wenn zu der TwinCAT-Software-Schlüssel "System-ID" ein passender "Registration-Key" eingetragen wird.
  • CX-Hardware (CX1000/CX1020/CX9000/Ethernetpanel...):
     Die TwinCAT Lizenzierung ist im Werk für den bestellten TwinCAT-Level bereits in der CX-Hardware vorgenommen worden. Eine weitere Freischaltung mit "System-ID" und "Registration-Key" ist somit -benutzerfreundlich- nicht erforderlich.

    TwinCAT-Update (Build-update):
    Ein TwinCAT-Update d.h. eine neuere TwinCAT Version, kann jederzeit installiert werden. Die Registrierung in der CX-Hardware bleibt hierbei bestehen, das CX Gerät startet mit dem gleichen TwinCAT-Level.

    TwinCAT-Level Änderung:
    Ein bestehender TwinCAT-Level kann geändert werden, dazu kann der TwinCAT-Registrierungsmechanismus vom PC genutzt werden. Durch Eintrag eines zur "System-ID" passenden "Registration-Key" startet TwinCAT im gewünschten neuen TwinCAT-Level.

Windows Embedded : Default User und Passwort

Per Default ist in allen Windows Embedded Images ein Benutzer und ein Passwort eingetragen. Dies ist notwendig, um z.B. per "Remote Desktop" mit dem CX Gerät mit Windows Embedded zu arbeiten.

  • Default User : Administrator (mit Administrator-Rechten)
  • Default Passwort : 1


Update des XPe Images

Betriebssysteme

Update des Windows Embedded Images

Die Embedded PCs werden in einem lauffähigen Grundzustand ausgeliefert, trotzdem kann es z.B. für die Unterstützung neuer Treiber notwendig sein, ein aktuelleres Windows Embedded Image zu verwenden. Hier wird beschrieben, wie ein Update des Windows Embedded Images durchgeführt wird.

Voraussetzung:

  • Die Windows Embedded Images sind auf dem Beckhoff-FTP-Server zum Download als Zip-Datei verfügbar. Aus Lizenzgründen ist diese Zip-Datei passwortgeschützt, es wird damit sichergestellt, dass dieses Image nur für bereits lizensierte Windows Embedded Geräte verwendet wird. Das notwendige Passwort erhalten Sie von der für Sie zuständigen Technischen Support Niederlassung nach Identifizierung als Kunde und Nennung der Geräteseriennummer und der MACID.
  • Auf der Compact Flash des CX Geräts war bereits ein Windows Embedded Betriebssystem installiert, es liegt somit ein bootfähiges Medium vor.
  • Beckhoff Service Tool (BST) zum wiederherstellen des entpackten Tib-Images auf die CompactFlash (CF).

Um das heruntergeladene Image vom Beckhoff FTP-Server wiederherzustellen, müssen Sie zuerst den Beckhoff Service Tool (BST)-Stick booten. Wenn das BST geladen ist, können Sie einfach das Image wiederherstellen via der Image wiederherstellen Schaltfläche.

Hinweis | Information:
Note | Eine ausführliche Anleitung finden Sie in der Beckhoff Service Tool Dokumentation. Mit dem Beckhoff Service Tool können Sie außerdem Images erstellen und verwalten.


Konfiguration eines XPe Images

Betriebssysteme

Konfiguration eines Embedded Images

Ein Windows Embedded Betriebssystem wird oft an einem Entwicklungs-PC erstellt und konfiguriert. Um es anschließend auf mehreren identischen Zielsystemen verwenden zu können wird ein Image (Master-Image) dieses Betriebssystems erzeugt. Dieses Image wird dann auf anderen Zielsystemen wiederhergestellt.

Problem:

Jedes so erstellte Zielsystem erhält denselben Computernamen, AMSNetId und Computer Security Identifier (SID). Sollen diese Rechner in einem Netzwerk betrieben werden, müsste an jedem Gerät der Name, die AmsNetId und die SID manuell geändert werden. Das manuelle ändern dieser Daten ist zeitintensiv.

Vorgehensweise jetzt:

Um den Aufwand bei der Konfiguration des embedded Images zu minimieren, können Sie mit dem CxCloningTool diese Daten ändern, oder beim Erstellen des Images die Änderungen beim nächsten Start des Betriebsystems vornehmen lassen.

Im folgenden Text wird beschrieben wie Sie basierend auf einem Beckhoff Standard Embedded Image für Embedded-PCs ein Master-Image erstellen, das dann auf anderen Embedded-PCs wiederherstellt werden kann ohne dass Konflikte entstehen, wie z.B. gleicher Computername, AmsNetId,usw.... .

Schritt 1: Die Ausgangssituation

Für die Erstellung eines Master-Images wird ein Windows XP embedded Standard Image, Version 1.35 oder höher, für Beckhoff Embedded-PC verwendet, sowie ein Beckhoff Embedded-PC. Das Image muss auf dem Medium des Embedded-PCs installiert sein.

Falls eine nachträgliche Aktualisierung des Images erforderlich ist, dann verwenden Sie dafür diese Anleitung

Schritt 2: Zusätzliche Einstellungen

HINWEIS: Bevor Sie Einstellungen am Betriebssystem vornehmen vergewissern Sie sich, dass die Write-Filter (EWF, FBWF) ausgeschaltet sind. Ansonsten werden die Änderungen am Betriebssystem nicht übernommen.

HINWEIS: Wenn der Computername auch automatisch (vom CxCloningTool) geändert werden soll, dann muss er auf dem Entwicklungssystem (Master-Image) BK_IPC heißen.

Es besteht die Möglichkeit weitere Einstellungen und Installationen auf dem System automatisch vornehmen zu lassen:

Auf dem Medium befindet sich das Verzeichnis "C:\Data". Hier können Sie nun die "run.cmd" erstellen und in dieser Datei weitere Aktionen definieren. Mit dem im Image enthaltenem Werkzeug CX-Cloning-Tool können Sie nun die Ausführung dieser Befehle bestimmen. Beim Erstellen des Master-Images ist es sinnvoll diese Einstellungen beim ersten Start des embedded Betriebssystems auf dem Zielsystem durchzuführen, damit das Zielsystem unterschiedlich zu den anderen Systemen ist. Dies geschieht mit dem CX-Cloning-Tool:

Der Aufruf des CX-Cloning-Tools geschieht über die Eingabeaufforderung: start --> run... --> cmd Enter.

In der Eingabeaufforderung wird mit dem unten stehenden Befehl die Änderung des Computernamens, AmsNet-Id und SID, sowie das Ausführen der vorhandenen "run.cmd" beim nächsten Start des Betriebssystems vorgemerkt.

Mit diesem CX-Cloning-Tool Funktionsaufruf werden die Änderungen der Merkmale beim nächsten Start des Betriebssystems ausgeführt:

cxcloningtool -ro

Schritt 3: Erstellen des (Master -) Images und Wiederherstellen des Images auf dem Zielsystem

Nachdem die gewünschten Einstellungen am Betriebssystem vorgenommen wurden können Sie das (Master -) Image erstellen. Dabei ist es nicht relevant welche Image-erstellungsart verwendet wird. Die Änderungen werden beim nächsten Start des Betriebssystem durchgeführt.

HINWEIS: Das CX-Cloning-Tool führt diese Änderungen nicht aus wenn ein Write-Filter aktiv ist!.

HINWEIS: Bitte beachten Sie die Information aus dem Kapitel "Verhalten des CX-Cloning-Tools mit Write-Filtern" aus der CX-Cloning-Tool Funktionsbeschreibung


Bluetooth support

Betriebssysteme

Bluetooth Support in Beckhoff .NET Images für Beckhoff Embedded PCs

Integrierte Bluetooth Funktionen basierend auf dem Microsoft Bluetooth Stack

Hier sind die Microsoft Bluetooth Funktionen beschrieben, die im Image enthalten sind:

Diese Funktionen sind vom verwendeten Bluetooth-Adapter abhängig.

Bluetooth Funktion / Protokoll | Getestete Szenarien
Bluetooth Human Interface Device Support
  • Verwendung einer Bluetooth Maus an dem CX1000.
Bluetooth Modem Device Support
  • Verwendung eines Mobiltelefons als Modem
  • Einbinden eines Bluetooth Modems
Bluetooth Personal Area Networking Support
  • TCP/IP Verbindung zwischen zwei Computern via Bluetooth zwecks Dateiaustausch
  • TCP/IP Verbindung zwischen zwei Computern via Bluetooth zwecks Verwendung des Remote Desktop (Terminal Services)
  • TCP/IP Verbindung zwischen zwei Computern via Bluetooth zwecks TwinCAT Kommunikation
Bluetooth Serial Device Support
  • Verwendung als virtuelles Null-Modem Kabel
  • Verwendung als virtuelle serielle Verbindung
  • Verbindung zweier TwinCAT Systeme über eine serielle Bluetooth Verbindung
Bluetooth Printing Support | --- noch nicht getestet ---

Installation der Treiber

Hinweis: Der verwendete Bluetooth-Adapter sollte kompatibel mit dem Microsoft Bluetooth Stack sein.

Beim Anschließen des Gerätes wird ein neues Gerät gefunden. Falls die Treiber nicht im Image enthalten sind, müssen sie nachinstalliert werden.
Bei der Installation ist der Treiberpfad anzugeben.
Die Datei bthusb.sys befindet sich im "c:\windows\system32\drivers" Verzeichnis

Verwendung einer Bluetooth Maus

Voraussetzung:

Der Bluetooth Adapter sollte installiert sein und das Eingabegerät (z.B.: Maus) in einem betriebsbereitem Zustand sein.

Mit dem Bluetooth Symbol in der Traybar (Abbildung 1) kann man ein Bluetooth Gerät hinzufügen.

 | Add a Bluetooth Device: | Hinzufügen eines Bluetooth-Gerätes
 | Show Bluetooth Devices: | Auflisten der gefundenen Bluetooth-Geräte
 | Join a Personal Area Network: | Zeigt Bluetooth-Geräte mit PAN-Eigenschaften an
 | Open Bluetooth Settings: | Zeigt die Eigenschaften der angeschlossenen und verbundenen Bluetooth Geräte an
Abbildung 1: Funktionen des Microsoft Bluetooth Stacks, einstellbar über das Tray - Symbol

Mit dem Befehl "Add a Bluetooth Device" wird die Umgebung nach Bluetooth Geräten abgesucht. Die gefundenen Geräte werden dann angezeigt.

 | HINWEIS: Einige Bluetooth Geräte (z.B.: Maus, Tastatur) haben einen Knopf (Connect, Synch) bzw. Funktion (z.B.: Mobiltelefon, Computer (make visible)) die dann das Gerät für andere Geräte sichtbar machen. Diese Funktion sollte verwendet werden, um die Bluetooth Geräte miteinander zu verbinden. Wenn der Knopf bzw. die Funktion an dem Bluetooth Gerät verwendet wurde kann man mit dem Button "Search Again" eine erneute Suche nach benachbarten Bluetooth Geräten starten.
Abbildung 2: Dialog des Microsoft Bluetooth Stacks, der gefundene Bluetooth Geräte anzeigt |

Nach dem Auswählen des Gerätes folgt die Authentifizierung der Verbindung zwischen dem Betriebssystem und dem gefundenem Bluetooth Gerät:

 | Choose a passkey for me | Das Betriebssystem erstellt einen 8-stelligen Schlüssel
 | Use the passkey found in the documentation | Einige Geräte (Modem) haben voreingestellte Schlüssel. Dieser Schlüssel muss dann verwendet werden, um das Gerät zu nutzen
 | Let me choose my own passkey | Hier kann ein eigener Schlüssel verwendet werden
 | Don`t use a passkey | Einige Geräte (Maus) benötigen keinen Schlüssel zur Authentifizierung.
Abbildung 3: Authentifizierungsdialog von einem gefundenem Bluetooth Gerät, das zum System hinzugefügt wird.

Nach der erfolgreichen Authentifizierung wird das Gerät installiert.

TCP/IP Verbindung zwischen zwei Computern via Bluetooth

Nach der Installation des Bluetooth-Adapters ist eine weitere Netzwerkverbindung vorhanden:

  • Die Darstellung der installierten TCP/IP netzwerkfähigen Bluetooth Geräte in den Netzwerkeinstellungen von Windows. Im Bereich Personal Area Network werden die installierten Bluetooth Netzwerkgeräte dargestellt.
  • Die "Bluetooth Network Connection" stellt einen "virtuellen" Netzwerkanschluss dar. Diese Verbindung verhält sich wie eine LAN Verbindung. Die Einstellungen für die IP-Adressen, DNS-Adressen und die Firewall sind genauso vorzunehmen wie bei einer gewöhnlichen Netzwerkverbindung.
  • Durch den Befehl "View Bluetooth Network Devices" werden Bluetooth Geräte angezeigt, die in der Lage sind eine PAN-Verbindung aufzubauen.
Abbildung 4: Darstellung der installierten Bluetooth TCP/IP Netzwerkadapter im Dialog der Netzwerkverbindungen von Windows XP

Verfügbare (PAN fähige) Bluetooth-Geräte mit der Personal Area Network(PAN) Funktionalität:

In diesem Dialog können PAN-Verbindungen zu anderen Geräten
  • aufgebaut werden: "Connect"
  • getrennt werden: "Remove"

Beim Verbinden wird eine vollständig funktionierende TCP/IP Netzwerkverbindung aufgebaut.
Somit sind in der Regel alle netzwerkfähigen Programme und Funktionen mit dieser Netzwerkverbindung kompatibel.

HINWEIS: Die Übertragungsgeschwindigkeit dieser Verbindung ist durch die Geschwindigkeit des Bluetooth Gerätes beschränkt.
Abbildung 5: Dialog des Microsoft Bluetooth Stacks, der benachbarte und sichtbare PAN Geräte angezeigt


HOWTO enable Automatic Update

Betriebssysteme

Automatic Update

Um die Automatische Update Funktion nutzen zu können muss der Dienst eingeschaltet werden. Der Dienst ist ab Werk auf Manuell gestellt.

Um den Dienst einzuschalten gehen Sie über das "Control Panel" in die "Administrative Tools" und wählen dort "Services" aus. In dem nun geöffneten Fenster wählen Sie den "Automatic Updates"-Dienst (Abbildung 1) heraus und rechtsklicken Sie auf den Dienst und wählen "Properties".

Abbildung 1

Dort können Sie den Dienst auf Automatisch umstellen, oder Sie belassen Ihn auf Manuell und starten Ihn einfach nur. Nachdem der Dienst aktiviert wurde, muss im "Control Panel" "Automatic Update" noch konfiguriert werden. Hier ist ab Werk das automatische herunterladen bzw. das automatische installieren von Updates ausgeschaltet (Abbildung 2).

Abbildung 2

Die Konfiguration des "Automatic Update" kann genauso vorgenommen werden, wie es bei einem Windows XP Professional erfolgt.

Beim Nutzen der Automatischen Update Funktion muss darauf geachtet werden das genug freier Speicher zur Verfügung steht. Außerdem wird von den "Uninstall-Files" noch zusätzlich Speicher belegt, der aber wieder freigegeben werden kann.


Benutzerverwaltung mit der Windows Eingabeaufforderung

Betriebssysteme

Benutzerverwaltung mit der Windows Eingabeaufforderung : Erstellen von Benutzern und Gruppen

Es ist möglich mit der Eingabeeinforderung "cmd" von Windows und dem net Befehl Benutzerkonten zu verwalten.

Da aus Platzgründen im LF-Image die herkömmliche Benutzerverwaltung nicht zur Verfügung steht, müssen Benutzer und Gruppen über die Konsole verwaltet werden.

Beispiele:

Erstellen eines Benutzers:

net user TcatUser Password /add

Erstellen einer Gruppe:

net localgroup TwinCAT /add

Benutzer einer Gruppe zuweisen:

net localgroup TwinCAT TcatUser /add

Weitere Informationen zum Net-Befehl finden Sie in der Windows-Hilfe oder im Microsoft Technet.


Bildschirmauflösung auf 640x480 einstellen

Unter den Windows XP Anzeigeeigenschaften können nur Auflösungen ab 800x600 Pixel aufwärts eingestellt werden. Bei den Beckhoff Standard Images für embedded PCs kann man die Bildschirmauflösung wie folgt einstellen:

  • Einstellen der Bildschirmauflösung mit den Grafikkarten-Optionen des Betriebssystems
  • Einstellen der Bildschirmauflösung mit dem CXD Utility

Einstellen der Bildschirmauflösung mit den Grafikkarten-Optionen des Betriebssystems

Um die Auflösung auf 640x480 Pixel einzustellen, müssen folgende Schritte durchgeführt werden:

Schritt 1:

In den Display Properties unter dem Reiter "Settings" auf den Button "Advanced" klicken.

Schritt 2:

Unter dem Reiter "Adapter" nun den Button "List All Modes..." anklicken.

Schritt 3:

In diesem Fenster ist es möglich, die gewünschte Auflösung 640x480 Pixel zu wählen.

Einstellen der Bildschirmauflösung mit dem CXD Utility

Die Windows Embedded Standard Images für Beckhoff embedded PCs haben das CXD Utilitiy damit ist es möglich schnell die Auflösung zu ändern. Um die Bildschirmauflösung auf 640x480 zu stellen muss man cxd Utility mit cxd 1 aufrufen.

Weitere Informationen zum CX Utility


HOWTO ELO

Betriebssysteme

Fehler: Com Port in Benutzung

Bei den CX18xx-0202 Version 1.35 Images kann es sein, das der COM-Port1 nicht genutzt werden kann. Das liegt daran, das der COM-Port1 von dem ELO-TouchScreen Treiber verwendet. Um den COM-Port1 wieder nutzen zu können muss einfach nur der ELO-Treiber deinstalliert werden. Deinstallieren kann man den ELO-TouchScreen Treiber über "Add or Remove Programs". Danach kann der ELO-Treiber wieder installiert werden - dabei ist darauf zu achten, das nur der USB-Treiber für den ELO-TouchScreen installiert wird.


Nachinstallation .NET Framework 3.5 auf XP embedded Systemen

Bei der Installation des .NET Framework 3.5 kann es auf Standard XP embedded Systemen, kleiner der Version 2.2, zu einem Abbruch der Installation kommen. Das liegt an der Installationsweise des .NET Framework 2 auf den XP embedded Systemen.

Damit das .NET Framework 3.5 auf einem XP embedded installiert werden kann, muss folgender Registry Key gelöscht werden.

[HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\ NET Framework Setup\ NDP\ v2.0.50727]

OCM=1

Das Löschen des Registry Keys kann auch einfach per Batch Datei erfolgen, welche es hier zum Download gibt.

Nach dem Löschen des Registry Keys kann die normale .NET Framework 3.5 Installation ausgeführt werden.


"Write Filter" Konzepte

Der Schutz der Laufwerke ist besonders beim System empfehlenswert, wenn das System sich auf einer Compact Flash Karte (oder einem anderen Flash Medium) befindet. Flash Medien (Compact Flash Karten, USB Sticks, etc.) haben den Nachteil, dass man sie nur begrenzt wiederbeschreiben kann. Schreibt man zyklisch Daten aus einer SPS oder aus einer Visualisierung, wird die Lebensdauer eines solchen Mediums drastisch verkürzt und kann somit zum Ausfall des CX / IPCs führen.
Microsoft bietet im Embedded Bereich zwei "Write Filter". Diese "Write Filter" sind der EWF (Enhanced Write Filter) und der FBWF (File Based Write Filter). Zusätzlich gibt es noch den Registry Filter, dieser erlaubt es Daten trotz aktiviertem Schreibfilters in die Registry zu schreiben. Diese "Write Filter" verfolgen unterschiedliche Konzepte um ein Laufwerk vor Schreibzugriffen zu schützen. In den folgenden Punkten werden diese kurz beschrieben.

EWF (Enhanced Write Filter)

Der EWF schützt die gesamte Partition vor Schreibzugriffen (ohne Ausnahmen). Diese Schreibzugriffe werden in den RAM umgeleitet um so das Flash Medium zu schützen.
Weitere Informationen zu dem EWF und der Bedienung finden Sie hier.

FBWF (File Based Write Filter)

Der FBWF schützt die gesamte Partition, allerdings kann man Ausnahmen (sogenannte "exclusions") definieren. Die Schreibzugriffe werden wie bei dem EWF in den RAM umgeleitet.
Weitere Informationen zu dem FBWF und der Bedienung finden Sie hier.

Registry Filter

Der Registry Filter ermöglicht es, bei eingeschaltetem "Write Filter" Dateien in bestimmte Keys der Registry zu schreiben ohne das System zu "commiten" (übernehmen der Änderungen ohne das Ausschalten des "Write Filters").
Weitere Informationen zu dem Registry Filter und der Bedienung finden Sie hier.


Embedded PC: Write Filter

Betriebssysteme

Schreibfilter und Sommer- Winterzeitumstellung (DST, Daylight Saving Time)

Bei Verwendung eines Schreibfilters (EWF bzw. FBWF) ist es nicht möglich die automatische Sommer- Winterzeitumschaltung zu nutzen.

Dieses liegt daran, dass bei aktiviertem Schreibfilter Windows keine Möglichkeit hat, sich die Information, dass ein Zeitwechsel vorgenommen wurde, zu speichern.

Dadurch wird nach jedem Neustart, nach der Zeitänderung, die Zeit wieder um den entsprechenden Zeitversatz zwischen Winter- und Sommerzeit geändert.

Das heißt wenn der Schreibfilter in der Sommerzeit aktiviert wurde, wird in der Winterzeit nach jedem Neustart die Uhrzeit um eine Stunde erhöht.

Mit dem CXID-Service gibt es die Möglichkeit diesem Verhalten entgegenzuwirken. In einer früheren Version konnte dies mittels Einträgen in der Registry und einem "Commit" des jeweiligen Write Filters mit anschließendem Neustart des Systems erfolgen.

Ab der Version 3.1.4.0 des CXID-Tools wurde der DST-Patch überarbeitet und dessen Nutzung vereinfacht. Hier können die Einstellungen durch Aufrufe des CXID über die Kommandozeile oder per Skript erfolgen. Es müssen keine Einträge in der Registry verändert und Neustarts durchgeführt werden.

Um den DST Patch jeweils ein- bzw. auszuschalten wird das CXID mit folgenden Parametern aufgerufen:

Einschalten des DST Patches:

cxid -enabledst

Ausschalten des DST Patches:

cxid -disabledst

Die neue Version des CXID-Tools kann vom Beckhoff Server heruntergeladen werden. Eine Update-Anweisung ist in der ZIP-Datei enthalten.

AttentionNV ACHTUNG:

  • Die neue Version des CXID-Tools (Version 3.1.4.0) ist in den Standard WES Images ab der Version 2.2 enthalten.
  • Der CXID-Service kann auf älteren Systemen aktualisiert bzw. nachinstalliert werden. Die Mindestvoraussetzung ist die Microsoft VCRedist2005 Runtime.
    • Beim Aktualisieren muss der CXID-Service im Windows\System32 Ordner ersetzt werden. Hierzu muss sichergestellt sein, dass der CXID-Service gestoppt ist!
    • Wird der CXID-Service neu Installiert muss dieser in das Windows\System32 kopiert und über die Konsole mit "cxid -service" registriert werden.


EWF : Enhanced Write Filter

Der Enhanced Write Filter im RAM Overlay Modus unter Windows Embedded bietet die Möglichkeit, eine Partition vor Schreibzugriffen zu schützen. Dabei werden die zu schreibenden Daten in den Arbeitsspeicher umgeleitet. Nach einem Neustart befindet sich das System wieder im Urzustand.

Der Einsatz des EWF ist sinnvoll bei Flash basierten Speichermedien (Compact Flash Card,...). Die Betriebszeit des Flashspeichers ist umgekehrt proportional abhängig von der Anzahl und der Größe der stattgefunden Schreibzugriffe auf den Flashspeicher. Je weniger Schreibzugriffe stattfinden und je kleiner die zu schreibende Menge ist, desto länger ist der Flashspeicher nutzbar.

Obwohl man bewusst keine Schreibzugriffe, z.B. mit dem Explorer vornimmt, werden vom Betriebssystem kontinuierlich Daten auf das Speichermedium geschrieben (Log Dateien,...). Beim eingeschalteten EWF im RAM Overlay Modus werden alle Schreibzugriffe in den Arbeitsspeicher (RAM) umgeleitet, damit finden keine realen Schreibzugriffe auf dem Medium statt.

Der Enhanced Write Filter ist Bestandteil aller Beckhoff Standard Images für embedded PCs.

Konfiguration und Steuerung des EWF mit der Windows Konsole / Eingabeaufforderung (cmd)

Es gibt zwei Möglichkeiten den Enhanced Write Filter im RAM Overlay Modus zu verwenden:

  • Enhanced Write Filter im RAM Overlay Modus
  • Enhanced Write Filter im RAM Overlay Modus mit der ram reg Option: Dieser Modus wird in den aktuellen Beckhoff Standard Images für embedded PCs verwendet.

Steuerung des EWF mit dem Beckhoff EWF Manager

Die Enhanced Write Filter lässt sich mit dem Werkzeug "Beckhoff EWF Manger" mittels Zeigegeräten (z.B.: Maus, Touchscreen) steuern. Der Beckhoff EWF Manager ist in den Standard Images installiert. Die Benutzerdokumentation und die Downloadquelle für den Beckhoff EWF Manager finden Sie hier.


EWF : Enhanced Write Filter

Betriebssysteme

Konfiguration des EWF im RAM Overlay Modus

Der Enhanced Write Filter unter Embedded Systemen bietet die Möglichkeit, Partitionen vor Schreibzugriffen zu schützen. Dabei werden die zu schreibenden Daten in den Arbeitsspeicher umgeleitet.
Nach einem Neustart befindet sich das System wieder im Urzustand.

Die Benutzung des EWF im "reinen" RAM Overlay Modus benötigt circa 5 MB unpartionierten Festplattenspeicher, um die EWF Einstellungen zu speichern.

Konfiguration des Enhanced Write Filter

Über die Konsolen-Application "ewfmgr" kann der Enhanced Write Filter konfiguriert werden.

Aktivierung des Enhanced Write Filters

ewfmgr c: -enable

Deaktivierung des Enhanced Write Filters

ewfmgr c: -disable

Anzeigen des aktuellen Status

ewfmgr -all

Klonen eines Images

Da der Enhanced Write Filter eine versteckte Partitionen auf der Festplatte anlegt, die von den meisten System-Backup-Programmen nicht erkannt und bearbeitet werden kann, muss diese Partition vor einem Backup entfernt und nach dem Wiederherstellen des Images neu hergestellt werden.

Löschen der EWF-Partition

etprep /delete

Wiederherstellen der EWF-Partition

syspropchange.exe


EWF : Enhanced Write Filter

Betriebssysteme

Konfiguration des EWF im RAM Overlay Modus mit ram (reg) Option

Für die Inbetriebnahme und Konfiguration des Enhanced Write Filters wird nun keine versteckte Partition auf dem Medium benötigt. Dadurch wird das Klonen bzw. das Erstellen von Backups vereinfacht.

Konfiguration des Enhanced Write Filters

Über die Konsolen-Applikation "ewfmgr" kann der Enhanced Write Filter konfiguriert werden.

Aktivierung des Enhanced Write Filters

ewfmgr c: -enable

Deaktivierung des Enhanced Write Filters

ewfmgr c: -commitanddisable

Daten auf geschütztes Medium schreiben bei aktiviertem Enhanced Write Filter

Dabei werden beim Herunterfahren des Systems die Daten auf das Medium geschrieben

ewfmgr c: -commit

Anzeigen des aktuellen EWF Status

ewfmgr -all

Klonen eines Images

Das System-Backup kann mit den gängigen Backup Programmen durchgeführt werden.

Beim Wiederherstellen des Backups sollte der Status des Enhanced Write Filters überprüft werden:

Re-Konfiguration des Enhanced Write Filters nach einem Systemwechsel / Wiederherstellung des System-Backups

Beim ersten Start des Betriebssystems nach der Betriebssystemaktualisierung konfiguriert sich das System automatisch. Dabei wird auch der EWF an das System angepasst und deaktiviert.

Wenn der Enhanced Write Filter beim Deaktivieren den Fehler 87 ausgibt, dann können Sie ihn mit folgendem Befehl rekonfigurieren:

rundll32 c:\windows\system32\ewfdll.dll ConfigureEwf Start

AttentionNV ACHTUNG:

Beachten Sie die exakte Schreibweise!


EWF : Einstellung der Systempartition

Betriebssysteme

Optimale Einstellung der EWF geschützten Partition

Der Enhanced Write Filter im RAM Overlay Modus unter Windows Embedded funktioniert wie eine dynamische RAM Disk (virtuelles Laufwerk, erzeugt im Arbeitsspeicher des Computersystems). Die beim Betrieb entstehenden (Schreib-) Daten (Anwendungen bzw. Prozesse) werden in diese RAM-Disk umgeleitet und dort gespeichert. Die Obergrenze dieser dynamischen RAM Disk ist die physikalische RAM Kapazität des CX 1000/CX1020/Ethernetpanel/... Computers. Damit nicht unnötig viele Daten in den Arbeitsspeicher geschrieben werden sollte man die Größe der vom EWF zu schützenden Partition so anlegen, dass der freie Festplattenspeicher auch der Größe des verfügbaren Arbeitsspeichers entspricht.

Dabei gilt folgender Zusammenhang:

  • Optimale EWF Partition: ePARTi
  • minimale EWF Partition: ePARTmin
  • freier physikalischer Arbeitsspeicher: phRAMfree

ePARTi= ePARTmin + phRAMfree

Beispiel am CX1800-0202 (.NET) Image Version 1.14

Größe des Betriebssystems: (ePARTmin) = 257 MB

Freier physikalischer Arbeitsspeicher (phRAMfree) = 43 MB

Optimale EWF Partition (ePARTi) = aPARTmin + phRAMfree = 257 MB + 43 MB = 300 MB


File-Based Write Filter

Betriebssysteme

File-Based Write Filter (FBWF)

Mit dem "Windows XP Embedded SP2 Feature Pack 2007" hat Microsoft den "File-Based Write Filter" eingeführt.

Der "File-Based-Write Filter" unterscheidet sich zu dem "Enhanced Write Filter" dadurch, dass er im Gegensatz zum EWF nicht auf Partitionsebene arbeitet, sondern die Datei auf Dateiebene vor Schreibzugriffen schützt. Dadurch ist es möglich Ausnahmen zu definieren, d.h. man kann einzelnen Datei oder Ordnern einen direkten Schreibzugriff auf das Speichermedium erlauben. In den Beckhoff-XPe-Images (ab v.135) sind standardmäßig die Ordner "C:\Data" und "C:\TwinCAT\Boot" für direkten Schreibzugriff freigegeben. Der Ordner "Data" steht dem Benutzer zum Schreiben von permanenten Daten zur Verfügung. Durch die Freigabe des Ordners "TwinCAT\Boot" kann ein neues TwinCAT-Boot-Projekt auf dem Rechner geladen werden, ohne dass der FBWF vorher deaktiviert werden muss oder die Dateien nachher "commited" werden müssen.

EWF vs. FBWF

In dem meisten Fällen ist der FBWF die bessere Wahl, da er einfacher zu bedienen ist und direkte Schreibzugriffe erlaubt. Jedoch gibt es Szenarien in denen der EWF unverzichtbar ist, z.B. wird HORM (Hibernate Once/Resume Many) vom FBWF nicht unterstützt. Außerdem ist beim FBWF die Verwendung von komprimiertem NTFS-Volumen nicht möglich.

Verhalten des aktivierten FBWFs

Bei eingeschaltetem FBWF wird im Explorer eine andere Partitionsgröße angezeigt, als die vorhandene. Dieser neue Wert berechnet sich aus dem belegten Speicher auf der Partition + dem vom FBWF freigegebenen Speicher (Threshold). Der Threshold spezifiziert die maximale Größe des Overlays. D.h. wenn die maximale Größe des Overlays erreicht ist, kommt eine Meldung, dass die Partition voll ist.

AttentionNV ACHTUNG:

In den Beckhoff-Embedded-Images sind seit der Imageversionen 1.35 zwar der EWF und der FBWF parallel installiert, jedoch sollten nicht beide Write Filter zur selben Zeit aktiviert werden. Falls doch beide Write Filter aktiviert sein solten, werden die direkten Schreibzugriffe vom FBWF durch den EWF abgefangen und sind nach einem Neustart des Rechners verloren.

Konfiguration des FBWF über den FBWF Manager

Der FBWF kann über das Konsolenprogramm "fbwfmgr" konfiguriert werden. Es ermöglicht die Anzeige des Status, Ein/Ausschalten des Filters, das Durchschreiben geschützter Dateien (commit) und das Hinzufügen bzw. Entfernen von Ausnahmen (Exclusions).
Weitere Informationen und Funktionen finden Sie hier: http://msdn2.microsoft.com/en-us/library/aa940817.aspx

Beispiele zur Verwendung des FBWF Managers

Anzeigen des Status

fbwfmgr

Aktivieren des FBWF

fbwfmgr /enable

Deaktivieren des FBWF

fbwfmgr /disable

Durchschreiben geschützter Dateien

fbwfmgr /commit c: \Beispiel.txt

Wichtig:

  • Richtige Schreibweise beachten: Erst den Buchstaben der Partition, Leerzeichen, dann relativer Pfad der Datei angefangen mit '\'.
  • Es können nur einzelne Dateien "commited" werden, kein Verzeichnisse.
  • Neu erstellte Dateien können bisher noch nicht "commited" werden, d.h. die Datei muss existieren bevor der FBWF aktiviert wird.
  • Dateien können nicht gelöscht werden.

Hinzufügen/Entfernen von Ausnahmen

fbwfmgr /addexclusion    c: \Beispiel.txt        //Datei hinzufügen
fbwfmgr /addexclusion   c: \BeispielOrdner      //Ordner hinzufügen
fbwfmgr /removeexclusion        c: \Beispiel.txt        //Datei entfernen
fbwfmgr /removeexclusion        c: \BeispielOrdner      //Ordner entfernen

Wichtig:

  • Richtige Schreibweise beachten: Erst den Buchstaben der Partition, Leerzeichen, dann relativer Pfad der Datei angefangen mit '\'.
  • Die Änderungen für den direkten Schreibzugriff werden erst nach Neustart aktiv.
  • Beim Hinzufügen von Ausnahmen für Dateien/Ordner die noch nicht existieren, ist folgende Reihenfolge einzuhalten
    • Ausnahme hinzufügen
    • Neustart
    • Datei/Ordner anlegen

Steuerung des FBWF mit dem Beckhoff FBWF Manager

Der File Based Write Filter lässt sich mit dem Werkzeug "Beckhoff FBWF Manger" mittels Zeigegeräten (z.B.: Maus, Touchscreen) steuern. Der Beckhoff FBWF Manager ist in den Standard Images installiert. Die Benutzerdokumentation und die Downloadquelle für den Beckhoff FBWF Manager finden Sie hier.


FBWF Seiteneffekte

Betriebssysteme

File Based Write Filter (FBWF) Seiteneffekte

Bei dem FBWF kann es unter Umständen zu Seiteneffekten kommen, die den Schutz des jeweiligen Mediums nicht mehr gewährleisten.

Die Default Konfiguration des FBWF sieht vor, das Systemmedium zu schützen, welches auf dem HardDiskVolume1 liegt. Damit ein Volumen als HardDiskVolume1 erkannt wird, muss das jeweilige Medium entweder allein am primären IDE-Bus angeschlossen, oder als "Primary Master" am System angeschlossen sein. Ist keine dieser Voraussetzungen erfüllt, muss der FBWF neu konfiguriert werden!!

Beispiel Konfiguration:

Ein C69xx mit Festplatte und Compact Flash Karte, wobei sich das System auf der Compact Flash Karte befindet.

Startet der Rechner ohne angeschlossene Festplatte ist das System auf HardDiskVolume1. Wird der Rechner aber mit einer angeschlossenen Festplatte hochgefahren, wird das System HardDiskVolume2 sein. Das liegt daran, dass die Festplatte als "Primary Master" erkannt wird und die Compact Flash Karte als "Secondary Master".

Um diesen Seiteneffekt zu beheben muss der FBWF neu konfiguriert werden.

Konfiguration:

  • mit "fbwfmgr /removevolume C: 1" wird das Volumen aus der Konfiguration entfernt
  • als nächstes kann man das neue Laufwerk (System) in die Konfiguration einpflegen "fbwfmgr /addvolume D:"
    • nach einem Neustart sollte man die Standardfreigaben wieder in die Konfiguration einpflegen ("C:\Data" und "C:\TwinCAT\Boot")

Zusammenfassung:

- Standard C69xx:
Die CF Karte ist „\Device\HarddisVolume1" mit dem Laufwerksbuchstabe C:

- Erweiterung mit einer Festplatte:
Die CF Karte ist „\Device\HarddiskVolume2" mit dem Laufwerksbuchstaben C:
Die Festplatte ist „\Device\HarddiskVolume1" mit dem Laufwerksbuchstaben D:

(Der Enhanced Write Filter (EWF) ist von diesem Seiteneffekt nicht betroffen.)


File-Based Write Filter

Betriebssysteme

Registry Filter

Neben "File-Based Write Filter" wurde im "Windows XP Embedded SP2 Feature Pack 2007" auch der "Registry Filter" eingeführt. Durch ihn ist es möglich, unter Verwendung eines Schreibfilters (FBWF oder EWF), einzelne Registry-Keys permanent zu schreiben, ohne die gesamten Registry Dateien nach jeder Änderung zu "commiten".

Standardmäßig ist der Registry-Keys [HKLM\SOFTWARE\Beckhoff] freigegeben, damit TwinCAT Einstellungen in der Registry speichern kann. Unter dem zweiten Key können eigene "Schreibfreigaben" angelegt werden. Dafür muss ein Subkey mit laufender Nummer angelegt werden.

z.B.:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Regfilter\Parameters\MonitoredKeys\2]
"ClassKey"="HKLM"
"RelativeKeyName"="SOFTWARE\\Beckhoff"
"FileNameForSaving"="Beckhoff.rgf"

ClassKey = Übergeordneter Regkey

RelativeKeyName= Relativer Key der für Schreibzugriffe freigegeben werden soll.

FileNameForSaving= Datei in der der Key gesichert wird.

Deaktivieren des Registry Filters:

Momentan ist es nur möglich den Regfilter über die Registry zu deaktivieren.

  1. Öffnen Sie den "Registry Editor" (Start-> Run...->"regedit" eingeben).
  2. Nun navigieren Sie im Baum auf der linken Seite zu dem Registrykey "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Regfilter".
  3. Ändern Sie nun dem Wert des Parameters "Start" von "1" auf "4".

Aktivieren des Registry Filters:

Zum Aktivieren führen Sie wieder die Schritte 1 & 2 aus.

Danach ändern Sie der Wert des Parameters "Start" wieder auf 1.


Regfilter Seiteneffekte

Betriebssysteme

Seiteneffekte des Registry Filters

Unter Verwendung des Registry Filters ist es nicht möglich, CHKDSK beim Start des Betriebssystems durchlaufen zu lassen.

Ist der Regfilter aktiv, gibt CHKDSK folgende Fehlermeldung aus: "Cannot open volume for direct access".

Um CHKDSK verwenden zu können, müssen Sie zuvor den Regfilter deaktivieren.

Nachdem CHKDSK erfolgreich durchgelaufen ist, können Sie den Regfilter wieder aktivieren.

Hinweise zur Aktivierung und Deaktivierung des Regfilters.


Audio Modul CX1000-N003

Die Treiber für das CX1000-N003 Audiomodul sind (ab Version 1.00) in den Images LF (CX1800-0200)* , HMI (CX1800-0201)* und .NET (CX1800-0202) enthalten.

Die Treiber wurden in der Systemsteuerung deaktiviert und müssen bei Nutzung des CX1000-N003 Audiomoduls wieder eingeschaltet werden.

Im Gerätemanager (Start-->Control Panel-->System-->Hardware-->Device Manager) kann der Treiber ein- bzw. ausgeschaltet werden.

Der Audiotreiber ist unter "Sound, video and game controllers" installiert. Er heißt "Geode - Native Mode Audio Driver (Windows XP/2000)". Das rote Kreuz am Lautsprechersymbol / Audio Treiber zeigt den deaktivierten Zustand des Gerätes an. Durch einen Klick mit der rechten Maustaste auf den Treiber kann man ihn einschalten (enable). Alternativ kann man im Action Menu des Gerätemanagers bzw. des Device Managers den Treiber einschalten.

Hinweis:

Der "Geode - Native Mode Audio Driver (WindowsXP/2000)" Treiber Version 1.0.10.0 wird in den CX1000 Images LF (CX1800-0200), HMI (CX1800-0201) und .NET (CX1800-0202) ab Version 1.00 - 1.10 verwendet. Dieser Treiber sollte nur bei angeschlossenem CX1000-N003 Audiomodul aktiviert werden. Bei aktiviertem Soundtreiber und nicht angeschlossenem Audiomodul startet Windows XP embedded nicht.

Ab der Version 1.1.50.0 des "Geode - Native Mode Audio Driver (Windows XP/2000)" Treibers ist es nicht mehr erforderlich den Treiber im Gerätemanager zu deaktivieren, wenn der CX1000 über kein angeschlossenes CX1000-N003 Audio Modul verfügt. Dieser Treiber wird in den Images LF (CX1800-0200), HMI (CX1800-0201) und .NET (CX1800-0202) ab Version 1.12 verwendet.

* wird nicht mehr unterstützt.


CX-Cloning-Tool

Beschreibung der Funktionen

Verhalten des CX-Cloning-Tools mit Write Filtern

Das CX-Cloning-Tool wird eingesetzt, um die charakteristischen Merkmale des Betriebssystems ändern zu können. Merkmale wie Computername, AmsNet-Id und SID sind auf jedem Windows XP embedded einzigartig. Wenn allerdings der Distributionsweg eines Images über den Klonprozess stattfindet, sind diese Werte die gleichen wie beim Master-Image. Das führt dazu, dass die Systeme mit den geklonten XPe Images nicht im gleichen Netzwerk betrieben werden können, weil eben der Computername, AmsNet-Id und die SID gleich sind.

Um die zeitraubende und fehleranfällige Prozedur der Merkmaländerungen zu vereinfachen kann man das CX-Cloning-Tool für diese Art der Aufgaben einsetzen.

Mit dem CX-Cloning-Tool ist es auch möglich diese Daten automatisch zu ändern. Somit werden die geklonten Systeme wieder unterscheidbar und können zusammen in einem Netzwerk betrieben werden.

Das CX-Cloning-Tool ist ein konsolenbasiertes Werkzeug und kann im Windows XPe embedded Standard Betriebssystem für Beckhoff Embedded-PCs mit der Eingabeaufforderung (Command Prompt) verwendet werden. (start --> run... --> "cmd" Enter) . Dadurch lässt es sich in Skripte integrieren.

Das CX-Cloning-Tool wird mit der Eingabeaufforderung aufgerufen. Über die verschiedenen Parameter können die Funktionen einzeln oder alle nacheinander mit den Combo-Parametern aufgerufen werden:

Beschreibung der Funktionen:

Hier werden im einzelnen die Parameter des CX-Cloning-Tools erklärt:

HINWEIS: Die hier beschriebenen Funktionen des CX-Cloning-Tools sind in Version 3.1.0.14 enthalten.

Diese Version des CX-Cloning-Tools ist in den XPe Betriebsystemen Version 1.35 bzw. 135a, oder höher, für Beckhoff Embedded-PCs enthalten!

Combo-Parameter des CX-Cloning-Tools:

  • Alle Funktionen des CX-Cloning-Tools aufrufen:
    Für eine schnelle Konfiguration des Betriebssystems kann man das CX-Cloning-Tool mit allen Funktionsparametern aufrufen. Dann werden die grundlegenden Parameter und die optionalen Parameter zur Laufzeit ausgeführt.

    AttentionNV HINWEIS: Danach wird auch ein Neustart initiiert. Alle nicht gespeicherten Daten gehen verloren!

  • cxcloningtool -all

  • Alle Funktionen des CX-Cloning-Tools beim nächsten Start des Betriebssystems aufrufen:
    Dieser Parameter schreibt in die Registry einen "runonce"-Eintrag dadurch wird das CX-Cloning-Tool mit dem Parameter "-all" beim nächsten Start des Betriebssystems aufgerufen.
    Schlüssel in der Registry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
    String-Wert im Schlüssel: SysPropChange
    Datum des Wertes: c:\windows\system32\cxcloningtool.exe -all

    Ausgabe nach erfolgreichem Schreiben des runonce Eintrags: "CXCloningTool runs after reboot"

    HINWEIS: Diese Option eignet sich besonders für das Erstellen von Master-Images, weil die individuellen Daten (Computername, AmsNetId, SID) nach dem Wiederherstellen des Images auf dem Zielsystem automatisch beim nächsten Start des Betriebssystems geändert werden.

    cxcloningtool -ro

Grundlegende CX-Cloning-Tool Parameter:

  • Setzen des Computernamens
    Der Computername wird auf Eindeutigkeit geprüft und gegebenenfalls geändert.
    Der erzeugte Computername ist 'CX_' gefolgt von den letzten sechs Ziffern der MAC-Id. Die MAC-Id können Sie dem Aufkleber am CX Gerät entnehmen.
    HINWEIS: Der Computername wird nur dann geändert, wenn er auf dem Entwicklungssystem (Master-Image) BK_IPC heißt.

    AttentionNV HINWEIS: Nach der Änderung des Computernamens ist ein Neustart des Systems erforderlich. Ungespeicherte Daten gehen dabei verloren !

    cxcloningtool -n

  • Setzen der AmsNetId
    Falls keine AmsNetId vorhanden ist, wird eine neue AmsNet-Id erzeugt. Diese wird auf die letzten acht Ziffern der MAC-Id und der Erweiterung '01 01' gesetzt.
    HINWEIS: Das Cloning-Tool stellt die AmsNetId als hexadezimale Zahl dar.
    HINWEIS: Die neue AmsNetId wird erst nach einem Neustart des Systems übernommen.
    cxcloningtool -a

  • Setzen der SID
    Die SID ist bei einem manuell installierten Betriebssystem einzigartig. Beim Klonen wird die SID des Entwicklungs-PCs (Master-Image) verwendet. Die Verwendung von gleichen SIDs im selben Netzwerk kann die Netzwerksicherheit gefährden.

    AttentionNV HINWEIS: Nach der Änderung der SID ist ein Neustart des Systems erforderlich. Ungesicherte Daten gehen dabei verloren!

    cxcloningtool -s

Optionale CX-Cloning-Tool Parameter:

  • Löschen der Benutzereingaben
    Beim Konfigurieren des Betriebssystems werden Benutzereingaben gespeichert, zum Beispiel in der Adressleiste und im temporären Verzeichnis. Diese Eingaben lassen sich entfernen:
    cxcloningtool -c

  • Gerät Neustarten
    Das CX-Cloning-Tool kann einen Neustart des Gerätes initiieren:

    AttentionNV HINWEIS: Es wird ein Neustart initiiert. Alle nicht gespeicherten Daten gehen verloren!

  • cxcloningtool -rb

  • Benutzerdefinierte Batch-Dateien ausführen:
    Das CX-Cloning-Tool führt benutzerdefinierte Scripte (Batch-Dateien) aus.
    HINWEIS: Die Batch-Datei wird im Ordner "C:\Data" gespeichert und sie muss "run.cmd" heißen. Das CX-Cloning-Tool führt die Datei "C:\Data\run.cmd" aus.
    cxcloningtool -rc
  • Ausführen von Reg-Dateien:

  • Reg-Dateien (.reg) können mit Hilfe der "run.cmd" importiert werden. Reg-Dateien werden mit dem Schlüsselwort "REG IMPORT" und den Dateinamen der Reg-Datei importiert.
    REG IMPORT registryDatei.reg

Verhalten des CX-Cloning-Tools mit Write Filtern:

Das CX-Cloning-Tool erkennt ob ein Write Filter aktiviert ist. Wenn ein Write-Filter aktiviert ist, wird keine CX-Cloning-Tool Funktion durchgeführt. Write-Filter (EWF, FBWF) kontrollieren die Schreibzugriffe auf das Medium. Somit sind die gemachten Änderungen am System nur zur Laufzeit des Betriebsystems vorhanden.
Mehr zum Thema Write Filter, und zur Steuerung der Write Filter finden Sie hier.

Das CX-Cloning-Tool gibt dann folgende Fehlermeldung aus: "A WriteFilter is active. Please disable the Filter and restart the program!"

AttentionNV ACHTUNG: Folgende Reihenfolge sollte beachtet werden, um Seiteneffekte zu vermeiden:

1. Write Filter deaktivieren

2. CX-Cloning-Tool Operation durchführen

3. Write Filter aktiveren

Wenn man das CX-Cloning-Tool mit dem Parameter "-ro" aufruft und dann einen Schreibfilter aktiviert. Dann wird bei jedem Start des Gerätes ein Aufruf des CX-Cloning-Tools stattfinden. Das CX-Cloning-Tool stellt fest, dass ein Write Filter aktiv ist und beendet sich. Da aber die Änderungen nicht gesichert werden, bleibt der CX-Cloning-Tool Eintrag in der Registry erhalten. Somit wiederholt sich dieses Verhalten beim nächsten Start des Gerätes.

Verwandte Artikel:

Konfiguration eines XPE Images | Dieser Artikel beschreibt, den Einsatz des CX-Cloning-Tools zum Erstellen von Master-Images
Write Filter Konzepte | Funktionsweise und Unterschiede der Write Filter in Windows XP embedded Standard Images für Beckhoff Embedded-PC Plattformen.


Beckhoff EWF Manager Version 1.0

Betriebssysteme

Beckhoff EWF Manager Version 1.2

Der Beckhoff EWF Manager ist ein Tool, mit dem sich der EWF (Enhanced Write Filter) sehr einfach mit einer grafischen Oberfl che bedienen l sst.

Die bisherige Methode des Einstellens über die Eingabekonsole ist damit hinfällig.

Mehr zum Thema Enhanced Write Filter finden Sie hier.

Hinweis: Der EWF Manager kann bei Bedarf auch nachinstalliert werden.

In Abbildung 1.0 ist der EWF Manager abgebildet. Er zeigt den Type, Status, Boot command, Volume name und Volume ID an.

Abbildung 1.0

In der Tabelle 1 werden die "EWF overlay store configuration" EWF Information/Konfiguration beschrieben

Tabelle 2 beschreibt die "Action" Kommandos zur Handhabung des EWF

Tabelle 1

Type: | Zeigt an, welche Art von EWF Volumen genutzt wird. In den neuen Versionen (ab 1.14) wird das EWF Volumen im RAM ausgeführt. D.h. es wird keine zus tzliche EWF Partition benötigt
State: | Zeigt den aktuellen Status des Enhanced Write Filters an, d.h. ob er Eingeschaltet (Enabled) oder Ausgeschaltet (Disabled) ist.
Boot command: | Zeigt an was beim nächsten Booten ausgeführt wird. Es gibt folgende "Boot commands": 1. "EWF NO CMD": es wird nichts geändert. 2. "EWF ENABLE": der EWF wird beim nächsten Booten Eingeschaltet "Enabled". 3. "EWF DISABLE": der EWF wird beim nächsten Booten Ausgeschaltet "Disabled". 4. "EWF COMMIT": Daten werden beim Herunterfahren auf die HD geschrieben, obwohl der EWF Enabled ist.
Volume ID: | Zeigt die ID (Hexadezimal) der Partition der Compact-Flash.
Volume name: | Zeigt den Namen der Partition der Compact-Flash

Tabelle 2

Enable | Mit dem "Enable" Button können Sie Ihren Enhanced Write Filter einschalten. Dieses bestätigen Sie dann mit OK
Disable | Mit dem "Disable" Button können Sie den Enhanced Write Filter ausschalten. Dieses bestätigen Sie dann mit OK
Commit changes | Mit "Commit" können Sie, bei eingeschaltetem Enhanced Write Filter, Daten zur Laufzeit übernehmen. Dieses bestätigen Sie dann mit OK
Commitanddisable -live | Mit "Commitanddisable -live" k nnen Sie den Enhanced Write Filter ohne einen Neustart des Systems ausschalten. Dieses best tigen Sie dann bitte mit OK.
Clear command | Mit "Clear command" k nnen Sie den "Boot command" wieder auf "EWF_NO_CMD" setzen, somit wird beim n chsten Neustart der "EWF" eingeschaltet (Enabled) bzw. ausgeschaltet (Disabled). Dieses best tigen Sie dann bitte mit OK.
Exit | Mit "Exit" können Sie den EWF Manager beenden.
Reboot | Mit dem "Reboot" Button k nnen Sie Ihr System Neustarten.

Informationen zur Installation des EWF (Enhanced Write Filter) Managers:

Der EWF Manager l sst sich auf einem CX (mit Windows Embedded) ab der Version 1.11 installieren.

Bei PCs (mit Windows Embedded System) kann der EWF Manager ohne Probleme nachinstalliert werden, sofern das System ber ein EWF Volumen verf gt.

Verhalten des EWF Managers im Service Pack 1:

Im Service Pack 1 ist der Button "Commitanddisable -live" gesperrt, da diese Funktion erst ab dem Service Pack 2 integriert ist.

Verhalten des EWF Managers auf einem CX Image:

Bei einem CX Image (auch mit Service Pack 2) ist der Button "Commitanddisable -live" deaktiviert, da beim bernehmen und sofortigen Ausschaltens des EWF nicht gen gend freier Arbeitsspeicher zur Verf gung steht und dieses dann zu einem Bluescreen f hrt.


Beckhoff FBWF Manager Version 1.0

Der Beckhoff FBWF Manager ist ein Tool, mit dem sich der FBWF (File Based Write Filter) sehr einfach mit einer grafischen Oberfl che bedienen l sst. Die bisherige Methode des Einstellens ber die Eingabekonsole ist damit hinf llig. Mehr zum Thema File Based Write Filter finden Sie hier.

bersicht ber die Oberfl che “General Settings“ des Beckhoff File Based Write Filter Managers:

Abbildung 1: Beckhoff File Based Write Filter Manager - General Settings

Die Funktionen der Oberfl che sind der untenstehenden Tabelle zu entnehmen.

a1 | Zeigt den aktuellen Status des FBWF an.
a2 | Zeigt den Status des FBWF nach einem Neustart des Systems an.
a3 | Schaltet den FBWF ein bzw. aus.
a4 | Zeigt ob die Komprimierung des FBWF Overlays aktiv ist.
a5 | Zeigt ob die Komprimierung des FBWF Overlays nach einem Neustart ein- bzw. ausgeschaltet wird/ist.
a6 | Schaltet die Komprimierung ein bzw. aus.
a7 | Zeigt ob die PreAllocation aktiviert bzw. deaktiviert ist.
a8 | Zeigt ob die PreAllocation beim n chsten Start aktiv bzw. nicht aktiv ist.
a9 | Schaltet die PreAllocation ein bzw. aus.

bersicht ber die Oberfl che “Exclusions“ des Beckhoff File Based Write Filter Managers:

Abbildung 2: Beckhoff File Based Write Filter Manager - Exclusions

Die Funktionen der Oberfl che sind der untenstehenden Tabelle zu entnehmen.

b1 | F gt den ausgew hlten Ordner der Exclusionlist nach einem Neustart hinzu.
b2 | F gt eine ausgew hlte Datei der Exclusionlist nach einem Neustart hinzu.
b3 | Entfernt die im Fenster b4 per Haken ausgew hlte Datei oder das ausgew hlte Verzeichnis von der aktuellen Exclusionlist.
b4 | Zeigt Verzeichnisse und Dateien die sich aktuell in der Exclusionlist befinden.
b5 | Zeigt nderungen an der Exclusionlist, die mit einem Neustart bernommen werden.

Informationen zur Installation des FBWF Managers (File Based Write Filter Managers):

Der Beckhoff FBWF Manager l sst sich auf einem CX (mit Windows Embedded) ab der Version 1.35 installieren. Ab Image Version 1.37 ist dieser jedoch standardm ig enthalten. Die Datei zur Installation des Beckhoff FBWF Managers finden Sie hier.

Um den Beckhoff FBWF Manager zu installieren, ben tigen Sie das "Microsoft Visual C++ 2005 Redistributable Package" in der Version 2.0.50727.762 oder h her. Dieses ist jedoch nicht standardm ig in der Imageversion 1.35 enthalten. Es kann allerdings problemlos nachinstalliert werden. Die Installation des "Microsoft Visual C++ 2005 Redistributable Packages" finden Sie hier.

Hinweis:

Falls Sie ein Kundespezifisches Image verwenden stellen Sie bitte sicher, dass der File Based Write Filter installiert ist.


Windows Visual Styles

AttentionNV ACHTUNG:

  • Die Nachinstallation der Windows Visual Styles ist nicht für den CX1000 empfohlen! Es entfällt die Gewährleistung.
  • Die Windows Visual Styles können auf den Embedded Standard Images ab der Version 1.35 nachinstalliert werden. Frühere Versionen werden nicht unterstützt!

Installation der Windows Visual Styles auf den Beckhoff Standard Images

Hinweis: Die Installationsdateien können hier heruntergeladen werden.

Wichtig: Bevor Sie mit der Installation beginnen, vergewissern Sie sich das kein "Write Filter" (EWF, FBWF) aktiviert ist. Sollte einer der beiden "Write Filter" aktiviert sein, schalten Sie diesen aus.

Nach dem Herunterladen des ZIP-Archives und dem Entpacken müssen Sie die "install.cmd" ausführen. Wenn das Skript erfolgreich durchgelaufen ist, müssen Sie den Rechner Neustarten.

Jetzt können Sie in den Display Properties das Windows XP Theme auswählen (siehe Abbildung 1).

Abbildung 1

Bitte bestätigen Sie mit OK.


Keyboard Layout Setup

  • Vom "Keyboard Layout Setup" unterstützte Sprachen

  • Download des "Keyboard Layout Setup"

  • Installation von zusätzlichen Keyboard Layouts auf den Beckhoff Standard Images

  • Verwendung der Keyboard Layouts im Betriebssystem

  • Verwandte Themen

Vom "Keyboard Layout Setup" unterstützte Sprachen:

Auf den Windows XP embedded Images für Beckhoff Embedded-PCs sind bereits Keyboard Layout und Sprachunterstützung für die Sprachen Englisch und Deutsch installiert. Weitere Sprachen lassen sich mit dem hier beschriebenen "Keyboard Layout Setup" nachinstallieren.

Das Kapitel " Verwandte Themen" enthält einen Eintrag über die Dokumentation zu lokalisierten Windows XP embedded Standard Images für Beckhoff Embedded-PCs, die bei Beckhoff erhältlich sind.

Mit den zusätzlichen Keyboard Layouts ist es möglich in den jeweiligen Sprachen zu schreiben (z.B. in Notepad) bzw. die Zeichen / Symbole der jeweiligen Sprache darzustellen (z.B. On Screen Keyboard, Internet Explorer). Bei fehlenden Keyboard Layouts wird ein Standard Ersatzsymbol gewählt (z.B. leeres weißes Rechteck, Fragezeichen).

Das "Keyboard Layout Setup" enthält noch nicht alle Sprachen und Keyboard Layouts, die auch in einem Windows XP Professional enthalten sind.

Die folgende Tabelle zeigt die im "Keyboard Layout Setup" enthaltenen und die im Windows XP Professional verfügbaren Keyboard Layouts an.

Die im "Keyboard Layout Setup" enthaltenen Keyboard Layouts sind mit einem " X " markiert.

Sprache / Keyboard Layout | im "Keyboard Layout Setup" enthalten
Albanian | X
Azeri (Latin) |
Armenian |
Azeri (Cyrillic) |
Arabic Saudi Arabia |
Belarussian |
Bengali |
Bosnian | X
Bulgarian | X
Chinese (Hong Kong S.A.R.) |
Chinese (Taiwan) |
Chinese (PRC) |
Czech | X
Canadian French | X
Belgian French | X
Belgian (Period) | X
Danish | X
Divehi |
Dutch | X
Estonian | X
Farsi |
Finnish | X
French | X
Faeroese | X
FYRO Macedonian | X
German | X
Greek | X
Georgian |
Gujarati |
Hebrew |
Hindi |
Hungarian | X
Icelandic | X
Italian | X
Japanese |
Kazakh |
Kannada |
Korean |
Kyrgyz (Cyrillic) | X
Latvian | X
Lithuanian | X
Irish | X
Malayalam |
Maltese 47 Key | X
Maori | X
Marathi |
Mongolian |
Northern Sami Norway |
Norwegian | X
Polish (Programmers) | X
Portugese (Brazilian ABNT) | X
Portugese | X
Punjabi |
Romanian | X
Russian | X
Serbian | X
Spanish | X
Slovak | X
Swedish | X
Syriac |
Latin America | X
Serbian (Latin) | X
Slovenian | X
Turkish Q | X
Ukrainian | X
Swedish with Sami | X
Swiss German | X
Swiss French | X
Thai Kedmanee |
Telugu |
Tatar |
Tamil |
United Kingdom | X
United Kingdom Extended | X
Urdu |
Uzbek (Cyrillic) |
Vietnamese | X

Download des "Keyboard Layout Setup" und installationsvorbereitende Hinweise

Download: Das "Keyboard Layout Setup" kann vom Beckhoff FTP-Server heruntergeladen werden. Die Größe des ZIP-Archivs beträgt ca. 6 MB. Download des "Keyboard Layout Setups"

Wichtig : Bevor Sie mit der Installation beginnen, vergewissern Sie sich das kein "Write Filter" ( EWF, FBWF) aktiviert ist. Sollte einer der beiden "Write Filter" aktiviert sein, schalten Sie diesen vor dem Download aus.

Installation von zusätzlichen Keyboard Layouts auf den Beckhoff Standard Images

Nach dem Herunterladen und Entpacken des ZIP-Archives müssen Sie die "KeyboardLayout.exe" ausführen. In der Installation kann man nun die gewünschten Sprachen auswählen.

Abbildung 1: Darstellung der im Setup auswählbaren Sprachen

Eigenschaften des "Keyboard Layout Setups"
  • Die Sprachen sind alphabetisch sortiert. Die Auswahl einer Sprache geschieht durch aktivieren der Checkbox.
  • Die Sprachen sind in Gruppen zusammengefasst
  • Die im System bereits installierte Sprachen werden durch eine aktivierte Checkbox der jeweiligen Sprache dargestellt.
  • Nach Abschluss der Installation ist ein Neustart des Systems erforderlich.

Verwendung der Keyboard Layouts im Betriebssystem

Für die Verwendung der installierten Keyboard Layouts müssen diese zuerst in der Systemsteuerung des Betriebssystems ausgewählt werden. Mit start / Control Panel / Regional and Language Options gelangt man zum Lokalisierungs-Konfigurationsdialog des Windows XP embedded Standard Images für Beckhoff Embedded-PCs:

Abbildung 2: Darstellung des Sprachenkonfigurationsdialogs

Regional and Language Options / Languages:

  1. Im Dialog "Regional and Language Options" gibt es drei Reiter (Tabs). Durch Klicken auf den mittleren Reiter [1] "Languages" gelangt man in den Sprach-Optionsdialog des Systems

  2. Durch Drücken der Schaltfläche "Details..." [2] gelangt man zum Konfigurationsdialog für installierte (Input-) Sprachen.

Der Konfigurationsdialog für installierte (Input-) Sprachen:

Abbildung 3: Konfigurationsdialog für installierte (Input-) Sprachen

Text Services and Input Languages / Settings:

  • Anzeige der Standard Eingabe-Sprache (Rahmen: Default input language). Das ist die Sprache die bei Anwendungen (Notepad, on Screen Keyboard, Internet Explorer, ...) als erstes verwendet wird um den Text anzuzeigen.
  • Auflistung der im System verwendeten Sprachen und Keyboard Layouts: (Rahmen: Installed services) Hier werden die installierten und vom System anwendbaren Sprachen dargestellt. Es wird zunächst eine kurze Bezeichnung der Sprache dargestellt (hier: DE), gefolgt vom Namen der Sprache sowie das Land (hier: German (Germany)) . Unter der Sprache werden die Keyboard Layouts angezeigt, die mit dieser Sprache verwendet werden (hier: German)
  • Zu jeder Sprache können die im System installierten Keyboard Layouts hinzugefügt werden.
  • Mit der Schaltfläche "Add..." (Siehe: Roter Rahmen) kann man nun weitere verfügbare Sprachen und / oder Keyboard Layouts zum verwenden auswählen. (Siehe: Abbildung 4)
  • Mit der Schaltfläche "Remove" kann man eine Sprache / Keyboard Layout von der Verwendung ausschließen. Dabei wird das ausgewählte Element im "Installed services" Rahmen entfernt. Im System ist diese Ressource weiterhin vorhanden.
  • Unter "Preferences" kann man die Einstellungen für die Language Bar (Siehe Abbildung 5) vornehmen.

Das Auswahlmenü für Sprachen und Keyboard Layouts:

Abbildung 4: Auswahldialog für installierte (Input-) Sprachen und Keyboard Layouts.

 Add Input language:

  • Die Auswahl der Eingabe Sprache (Input language) wird mit der Auswahlbox "Input language" [1] vorgenommen. Nach Auswahl der Sprache erscheint sie dann im Dialog (Abbildung 3) Text Services and Input Languages / Settings im Installed services Rahmen.
  • Die Auswahl des Keyboard Layouts wird mit der Auswahlbox "Keyboard layout / IME" [2] vorgenommen. Nach Auswahl des Keyboard Layouts erscheint es dann im Dialog (Abbildung 3) Text Services and Input Languages / Settings im Installed services Rahmen unter der Sprache, von der aus das Keyboard Layout ausgewählt wurde. Bei Verwendung mehrer Keyboard Layouts mit einer Sprache wählt man zuerst die Sprache aus und fügt zu dieser dann das gewünschte Keyboard Layout hinzu.
  • Beim "Keyboard Layout Setup" werden Eingabesprache und das dazugehörende Keyboard Layout installiert.

Verwendung der Language Bar bei mehreren Eingabe-Sprachen:

Abbildung 5: Verwendung der Language Bar.

 Language Bar:
  • Mit der "Language Bar" kann man schnell die Sprachen / Keyboard Layouts mit Maus / Tastatur (TastenkÃ¼rzel) umschalten.
  • Die "Language Bar" kann man in der Task Leiste verwenden (Abbildung 5) oder als sichtbares Element auf dem Desktop
  • Die Konfiguration der "Language Bar" erfolgt im Text Services and Input Languages / Settings: Dialog (Abblidung 3)

Verwandte Themen

Der Artikel Lokalisierte Windows XP embedded Images für Beckhoff Embedded-PC Plattformen beschreibt das Konzept der Lokalisierung von Windows XP embedded Images mit der Multilingual User Interface (MUI) Installation. Er enthält außerdem eine Liste mit den aktuell verfügbaren lokalisierten Windows XP embedded Standard Images für Beckhoff Embedded-PCs


Lizensierung

Betriebssysteme

Lizenzierung

Betriebssystem

Geräte der CX-Serie werden je nach Bestelloption ab Werk mit einem vorinstalliertem Betriebsystem ausgeliefert. Die möglichen Optionen umfassen Microsoft Windows XP Embedded oder Windows CE.NET .

Die Lizenznummer des Betriebssystems eines CX1000/CX1020/CX9000/Ethernetpanel ist am Windows Lizenz Aufkleber erkennbar, der außen am Gerät angebracht ist. Dieser Original-Aufkleber der Firma Microsoft stellt das so genannte COA (Certificate of Authenticity) dar und darf nicht vom Gerät entfernt oder auf andere Geräte übertragen werden. Der Aufkleber dokumentiert das Vorhandensein einer legalen Version des Betriebssystems.

TwinCAT Software Lizenz

Die im CX1000/CX1020/CX9000/Ethernetpanel enthaltene TwinCAT Software Lizenz ist an der Bestellbezeichnung auf der Front des Geräts ablesbar und wird vorinstalliert ab Werk geliefert.

Die letzte Ziffer der CPU-Baugruppe gibt Auskunft über den ab Werk freigeschalteten TwinCAT Level. Geräte mit der Bezeichnung CX10xx-0xx1 sind mit einer TwinCAT PLC Lizenz ausgestattet, Geräte mit der Bezeichnung CX10xx-0xx2 sind mit einer TwinCAT PLC und NC PTP Lizenz ausgestattet, Geräte mit der Bezeichnung CX10xx-0xx3 sind mit einer TwinCAT NCI Lizenz ausgestattet. Falls es sich bei der letzten Ziffer um eine Null handelt besitzt das Gerät keine TwinCAT Lizenz.

Hinweis:

Die TwinCAT Lizenz ist in der Gerätehardware einprogrammiert und kann vom Benutzer nicht verändert werden. Ein Veränderung des TwinCAT Levels (z.B. von PLC auf PTP oder umgekehrt) ist nur werkseitig möglich.


Änderung von Parametern : AmsNetId / TCP-IP / Bildschirmauflösung

Der TwinCAT ADS Message Router auf dem CX1000 ist durch eine eindeutige AdsAmsNetID im TwinCAT Netzwerk identifizierbar. Bei dem ersten Start des CX1000 wird vom TwinCAT System Service eine solche eindeutige AmsNetID gebildet.

Eine Änderung der AmsNetID ist für den Betrieb des CX1000 somit nicht notwendig.

Per Default setzt sich diese AmsNetId aus den letzten 4 Stellen der eindeutigen Ethernet-MACID des CX1000 mit der Erweiterung "1.1" zusammen.
Die MACID können Sie dem Aufkleber am CX1000 entnehmen.

Beispiel:

MACID = 00-01-05-00-27-84 ergibt die AmsNetID 5.0.39.132.1.1

Änderung der voreingestellten AmsNetID

Die Möglichkeit zur Vergabe und Wahl von eigenen AmsNetIDs ist gegeben, so kann z.B. die AmsNetID an die IP-Adresse des CX1000 angepasst werden.
Zwei Wege sind zur Änderung der AmsNetID möglich:

  • Die Änderung der AmsNetID kann bequem durch den TwinCAT System Manager vorgenommen werden:
    Dieser schreibt die neue AMsNetID an die vorgegebene Stelle in der Registry des CX1000 und sichert die modifizierte Registry auf die Compact Flash Karte zurück.
  • Als Alternative kann die AmsNetID auch direkt mit dem Registry Editor modifiziert werden.

Hinweis:

Bei beiden Varianten muss der CX1000 nach der Änderung neu gestartet werden, um die neue Einstellung wirksam werden zu lassen.

1. Änderung mit dem TwinCAT System Manager

Wenn Sie mit dem System Manager den CX1000 als Zielsystem gewählt haben und somit "per remote" mit dem CX1000 verbunden sind, steht ein Dialog zur Verfügung, in dem die wichtigsten Einstellungen im CX1000 vorgenommen werden können.

Diese möglichen Änderungen beinhalten:

  • AmsNetId
  • Host Name (des CX1000)
  • TCP/IP Einstellungen
  • Bildschirmauflösungen / Bildwiederholfrequenzen

Nach einer Änderung von Einstellungen folgt ein Dialog, der nach Bestätigung mit "OK" einen Reboot auf dem CX1000 auslöst. Dabei werden zunächst alle Einstellungen zurück auf die Compact Flash Karte gesichert, erst beim Neustart sind dann die neuen Einstellungen wirksam.

Anmerkung:
Bei Änderung der TCP/IP Adresse des CX1000 ist es notwendig, die Verbindungsprozedur zwischen dem Host-PC (mit System Manager) und dem CX1000 erneut durchzuführen.

2. Änderung mit dem Registry Editor

1. Wählen Sie über den "Start" Button "Ausführen" aus.

2. Geben Sie "RegEdit.exe" ein, um den Registry Editor zu öffnen.

3. Navigieren Sie zu HKLM ->Software-> Beckhoff-> TwinCAT -> System

Der Key "AmsNetId" enthält die aktuellen Einstellungen. Hier kann die Adresse geändert werden, z.B. auf 172.16.10.7.1.1

4. Damit die Änderung der Einstellungen wirksam wird, muss der Registry-Editor geschlossen werden. Dabei wird die Registry wieder auf die Compact Flash Karte geschrieben. Nach einem Neustart des CX1000 ist die neue AmsNetId wirksam.


Verbindungsaufbau

Hier werden die Schritte zur Inbetriebnahme eines CX Gerätes (mit CE) mit TwinCAT beschrieben.

1. Voraussetzungen:

Erforderliche Software auf dem Host-PC:

  • Windows NT/2000/XP
  • TwinCAT 2.9 ab Build 941

Erforderliche Software auf dem CX Gerät:

  • Windows CE.NET 4.10 mit Software Version ab V1.29
  • TwinCAT CE

Erforderliche Hardware:

  • TCP/IP Netzwerkverbindung zwischen dem CX Gerät und dem Host-PC direkt mittels Cross-Over-Cable oder per Netzwerkkabel zu einem Netzwerk-Hub/Switch
  • Optional: Monitor mit DVI-A Anschluss (bzw. VGA-DVI-A-Adapter für VGA-Monitor-Anschluss)
  • Optional: USB-Tastatur und USB-Maus.

2. Verbindungsaufbau zu einem CX Gerät mit Windows CE.NET

2.1 Ermitteln des Namen des CX Gerätes

Um eine ADS Verbindung zwischen dem Host-PC und einem CX Gerät mit Windows CE.NET herstellen zu können, ist es notwendig, den Computer-Namen des CX Geräts zu ermitteln.

Dieser Name leitet sich aus den letzten 3 Bytes der MAC-ID des CX Geräts ab. Die MACID ist dem Aufkleber am CX Gerät zu entnehmen.
Ein Beispiel:
Die MACID = 00-01-05-00-23-1E ergibt den Namen CX_00231E

Der Name (hier im Beispiel "CX_00231E") wird beim Starten des CX Gerätes im Display in der zweiten Zeile angezeigt.

2.1 TwinCAT im Konfig Modus auf dem Host PC

Hierzu wird auf dem Host PC der TwinCAT System Manager gestartet (über das Windows-Start-Menü oder das TwinCAT-Icon in der Windows-Statuszeile).

Das TwinCAT auf dem Host PC muss in den Konfig-Mode versetzt werden. Wenn TwinCAT im Konfig-Modus ist, wird das in der Windows-Statuszeile durch ein grün-blaues TwinCAT-Symbol angezeigt.

TwinCAT kann über das Aktionen-Menü (Starten/Restarten von TwinCAT im Konfig-Modus) bzw. durch Klicken auf das grün-blaue TwinCAT Symbol in der Toolbox des System Managers in den Konfig-Mode versetzt werden.

TwinCAT im Konfig-Modus:

2.2 Suchen nach dem CX10xx im Netzwerk

Das Suchen des CX Gerätes im Netzwerk erfolgt auf dem Host PC im System Manager. Über den Aktionen-Menü-Punkt "Auswahl des Zielsystems..." oder alternativ über die Schaltfläche "Zielsystem wählen" auf dem Allgemein-Tab der SYSTEM-Konfiguration.

Es öffnet sich der Dialog zur Auswahl des Zielsystems.

Der Eintrag "<Suchen>" in der Liste muss markiert und mit Okay bestätigt werden. Es öffnet sich der Dialog zum Hinzufügen einer Verbindung. Über die Schaltfläche "Broadcast Suche" werden alle verfügbaren Zielsysteme im Netzwerk gefunden und in der Liste angezeigt.

Der Eintrag mit dem Namen des CX Gerätes muss nun in der Liste ausgewählt und mittels "Add Route" zu den aktuellen Verbindungen des Host PCs zugefügt werden.

Es erscheint ein Dialog in dem zur Angabe eines gültigen Benutzernamens und Kennwortes für das Zielsystem aufgefordert wird. Für das CX Gerät mit Windows CE.NET müssen beide Felder leer bleiben und der Dialog mit "Okay" beendet werden.

In der Spalte "Verbunden" erscheint für das CX Gerät ein 'X'. Der Dialog kann jetzt über die Schaltfläche "Schließen" beendet werden.

Im Zielwahl-Dialog ist das gerade zugefügte CX Gerät mit aufgelistet und kann als Zielsystem ausgewählt werden. Nach dem Schließen dieses Dialogs mit Okay wird in der Statuszeile des TwinCAT System Managers der Name des CX Gerätes mit der AmsNetID in Klammern und der aktuelle Status des TwinCAT auf dem CX Gerät angezeigt.


SPS Programmierung mit TwinCAT PLC Control

Das Handling der CX Geräte SPS (CX Gerät vom Typ CX10x0 oder CX9000) mit dem TwinCAT PLC Control unterscheidet sich nicht von anderer Hardware und ist bereits im Beckhoff Information System beschrieben. Zur Einführung wird an dieser Stelle darauf verwiesen.

Kurzanleitung:

  • Die Programmiersprachen zur Erstellung von Programmen im TwinCAT PLC Control entsprechen der Norm IEC61131-3.
  • Mit jedem Kompilieren werden die Projektinformationen in eine <Projektname>.tpy Datei geschrieben. Diese Datei ist XML-basierend und kann mit dem Internet Explorer geöffnet werden. Der unterste Abschnitt "Symbols" enthält eine Auflistung der SPS Variablen mit detaillierter Information über Datentypen und ADS Parameter für den Zugriff auf die SPS Symbole (wie Index Group, Index Offset, Length).
  • Nach dem Kompilieren müssen Sie die Datei <Projektname>.tpy in den TwinCAT System Manager einlesen.
  • Mappen Sie im TwinCAT System Manager die SPS Variablen mit den E/A Punkten.
  • Wählen Sie das Zielsystem aus, in welches das SPS Projekt geladen werden soll. Geben Sie dazu in der Dialogbox "Auswahl des Zielsystems" unter Zielsystem (Port) "Runtime 1 (Port 801)" ein, und unter Zielsystem (Maschine) z.B. "CX1000" ein
  • Danach loggen Sie sich ein und erzeugen ein Bootprojekt.


Hardware Setup mit dem TwinCAT System Manager

Die Konfiguration und der Test der CX Hardware (z.B. CX Geräte des Typs CX10xx oder CX9000) erfolgt per Remote (Remote-Konfiguration) mit dem TwinCAT System Manager vom Host-PC aus.

Konfiguration der CX Geräte:

1. Setzen Sie den TwinCAT System Manager in den "Konfig-Modus" (am blauen Icon in der Taskbar zu erkennen).

2. Öffnen Sie den System Manager.

3. Gehen Sie mit einem Doppelklick auf die Statuszeile in das Feld der AmsNetId (linkes Feld) und wählen Sie im Fenster, dass sich daraufhin öffnet, das Zielsystem CXxxxx aus.

In diesem Beispiel besitzt der CX10xx die AmsNetId 5.0.34.251.1.1. Bestätigen Sie ihre Eingabe mit "OK".

Ab diesem Zeitpunkt wird per Remote auf den CX10xx zugegriffen. Das angewählte Gerät und der Status wird in der Statuszeile angegeben.

4. Wechseln Sie mit einem Klick auf das blaue Icon in der Toolbar des System Managers in den Konfig-Mode.

Das CX10xx Gerät befindet sich nun im Konfig-Mode, angezeigt wird dies in der Statuszeile des TwinCAT System Managers.

Zur Konfiguration der Hardware:

Durch rechten Mausklick auf E/A-Geräte öffnet sich folgendes Kontextmenü:

Geräte Suchen:

Scannt die CX1 Hardware nach bekannten Geräten ab. Gefundene Geräte werden dann unter E/A-Geräte aufgelistet.

Nachdem Sie 'Geräte suchen' angewählt haben öffnet sich folgende Messagebox:

Das Finden eines neuen Geräts zeigt anschließend dieses Fenster an:

Zum Scannen der Untergeräte müssen Sie die auftretende Messagebox bestätigen:

Damit ist die Gerätesuche beendet und alle am CX Gerät angefügten Busklemmen sind nun eingescannt.

Zur Aktivierung des Freilauf Modus muss die folgende Messagebox bestätigt werden.

Freilauf Modus (Free Run)

Dieses Konfig-Mode Feature erlaubt das direkte Testen der IO Hardware, indem Ausgänge geschrieben werden können, ohne erst ein lauffähiges SPS Programm erstellen zu müssen.

Dazu navigieren Sie auf E/A Konfiguration ->E/A Geräte -> CX10xx... -> Busklemmen -> Busklemme -> Kanal-> Ausgang. Wählen Sie "Schreiben" auf dem Karteireiter "Online". Danach öffnet sich folgender Dialog:

Jetzt können Sie die Hardware durch das Schreiben von Werten testen.

Hinweis:

Zur Sicherung der Konfiguration speichern Sie die Datei bitte im TwinCAT System Manager ( "Datei" -> "Speichern unter").


CX1000-HMI-Emulator

Diese Seite enthält Informationen darüber wie Sie eine CE-HMI Applikation ohne vorhandene CX1000/CX1020/CX9000-Hardware testen können. Dabei wird beschrieben, wie aus dem CX1000-Emulator eine reale ADS Kommunikation zur TwinCAT SPS auf dem Host-PC erstellt wird. Der CX1000-Emulator ist von der Performance nicht mit einem realen CX Gerät zu vergleichen, der Ablauf auf dem Emulator ist deutlich langsamer.

1. Voraussetzungen:

Erforderliche Software auf dem Host-PC:

  • Windows NT/2000/XP
  • TwinCAT 2.9
  • Beckhoff Erweiterung des Microsoft Standard CE-Device-Emulators

    Informationen zur Installation unter Microsoft Embedded VC4
    Informationen zur Installation unter Microsoft Visual Studio .NET 2003
  • Entwicklungsumgebung

    Microsoft Embedded VC4 (lizenzfrei bei Microsoft erhältlich)
    oder
    Microsoft Visual Studio .NET 2003

2. Konfiguration des CX1000-Emulators als "Remote Computer" auf dem Host-PC:

Unter "TwinCAT System Service->Eigenschaften" öffnet sich ein Dialog, auf dem dritten Reiter "AMS Router" können dem TwinCAT System mit "Hinzufügen" zusätzliche ADS Computer bekannt gegeben werden.

In dem sich öffnenden Dialog müssen nun die Parameter "Name", "AMS Net Id" und "Adresse" eingetragen werden.

  • Als frei wählbarer Name wurde in diesem Beispiel "CX1000_EMULATOR" gewählt.
  • Als "AMS Net Id" muss "1.1.1.1.1.1" eingetragen werden.
  • Als "Adresse" muss die TCP-IP Adresse des HOST-PC eingetragen werden (hier im Beispiel 172.16.10.5).
    NOTE:
    Die lokale AMS-Net-Id des HOST-PC muss sich aus der lokalen IP-Adresse mit der Erweiterung "1.1" zusammen setzen (hier im Beispiel 172.16.10.5.1.1).

Nach dem Eintrag eines neuen "Remote Computers" muss auf dem HOST-PC ein TwinCAT Restart durchgeführt werden um die neuen Einstellungen zu übernehmen.

3. CE-HMI Applikation kommuniziert ADS mit Remote SPS auf HOST-PC :

Sie können nun ihre CE Applikation erstellen. Zur ADS-Anbindung an TwinCAT stehen CE-Applikationsbeispiele im Beckhoff Information System im Bereich "Connectivity ->TcAdsDll" zur Verfügung.
Die Wahl des ADS Kommunikationspartners erfolgt mit den beiden Kennungen "AmsNetID" und "ADS-Port". Als ADS-Port ist hier das erste SPS-Laufzeitsystem PLC1 mit Port 801 ausgewählt.

  • Kommunikation zwischen CE-HMI und lokaler SPS auf dem CX Gerät:
    AMSNetID : 127.0.0.1.1.1
  • Kommunikation zwischen CE-HMI und Remote SPS auf dem HOST-PC:
    AMSNetID : AmsNetID des HOST-PC , in diesem Beispiel 172.16.10.5.1.1

C++ Quellcode

// Choose one of following AmsNetID
// AmsNetId ServerNetId = { 127,0,0,1,1,1 }; // target local-CX-plc
AmsNetId ServerNetId = {172,16,10,5,1,1}; // target host-plc

m_ServerAddr.netId = ServerNetId;
// ADS to PLC 1
m_ServerAddr.port = 801;
// open ADS channel
m_nClientPort = AdsPortOpen();
// optional: specify ADS-timeout
long err = AdsSyncSetTimeout(2000);

embedded Visual Studio C++ 4 Umgebung :

In der Entwicklungsumgebung stehen Ihnen der CX1000 Emulator zur Verfügung wenn als SDK "STANDARDSDK" gewählt wird.


CX1000 Emulator für embVC++ 4

Für die Implementation von C++ Applikationen steht ein CX1000 Emulator mit integrierten TwinCAT Komponenten zur Verfügung. Der Emulator dient dazu, HMI Applikationen unter Microsoft embedded Visual C++4 ohne CX1000/CX1020/CX9000 Hardware zu implementieren und zu testen.

Generell kann gegen das Microsoft Standard SDK kompiliert werden, und der Microsoft-Standard-SDK-Emulator genutzt werden.

Erforderliche Software auf dem Host-PC:

  • Windows NT/2000/XP
  • Microsoft Embedded VC4 (lizenzfrei bei Microsoft erhältlich)
  • Microsoft Windows CE.NET Emulation Edition (lizenzfrei bei Microsoft erhältlich)

Microsoft Windows CE.NET Emulation Edition (480 MB) :

Der Emulator ermöglicht die Implementierung von C++ Applikationen mit eVC4++ für verschiedene Hardware Plattformen.

Die Emulator Edition unterstützt:

  • embedded x86 Plattformen
  • das Starten / Debuggen einer CE Applikation in der CE Emulationsumgebung
  • die Auswahl verschiedener grafischer Auflösungen
  • TCP/IP zur Verbindung mit anderen PCs (wie z.B. der Hostrechner, der den Emulator enthält)

Beckhoff CX1000 Emulator für embVC++4 (7 MB)

Der Beckhoff CX1000 Emulator ist eine erweiterte Version des Standard SDK Emulator. Diese erweiterte Version enthält TwinCAT Komponenten. Es ist somit möglich, eine HMI-Applikation im CE Emulator zu starten und von dort eine ADS Kommunikation via virtuellem Netzwerk zu einer laufenden TwinCAT-SPS Applikation >auf dem Host-PC herzustellen.

Der Emulator ermöglicht somit die Implementation und den Test einer CX1000 embVC4 Applikation ohne CX1000/CX1020/CX9000 Hardware.

Einrichtung des Emulators:

1. Download der Datei NK.CEM (12.5 MB) vom Beckhoff-FTP-Server
ftp://ftp.beckhoff.com/Software/embPC-Control/CE/Solutions/embVC4/nk.cem

2. Erstellen Sie eine Sicherungskopie des Standard Microsoft Emulators und ersetzen Sie diesen anschließend durch den Beckhoff CX1000 Emulator. Der Emulator befindet sich im Ordner "..\wce400\STANDARDSDK\Emulation"

In der Entwicklungsumgebung embVC++ 4 ermöglicht die Auswahl der Microsoft Standard-SDKs die Implementation von Applikation ohne CE Hardware im Emulator:

Der Microsoft Standard- Emulator ist in der Beckhoff-Variante mit TwinCAT-Komponenten erweitert:

Hinweis:

Microsoft embedded VB 3 wird nicht unterstützt

Microsoft embedded VC3 wird nicht unterstützt


TwinCAT OPC Server CE

Der TwinCAT OPC Server CE ist auf den verschiedenen CE Images der CE Geräte lauffähig.

Die Konfiguration des Namesspace muss einmalig durchgeführt werden, detaillierte Informationen stehen in der Dokumentation TwinCAT-OPC-Server4 zur Verfügung: "Konfiguration TwinCAT OPC Server CE"


CX1800-0001 zenOn HMI CE Runtime

1. Generell

  • Die zenOn HMI CE-Runtime kann vorinstalliert mit dem CE Gerät bei Beckhoff bestellt werden.
  • Der notwendige zenOn-Editor zur Erstellung der zenOn-HMI-Lösung wird nicht von der Firma Beckhoff geliefert, sondern muss von der Firma Copa-Data erworben werden.

Das Produkt zenOn der Copa-Data GmbH aus Österreich ist ein Visualisierungspaket auch für das Beckhoff Embedded-System der CX Serie. Ab der Version 5.50 SP4 ermöglicht der zenOn Editor den komfortablen Import von TwinCAT SPS Projekten. Die so erstellten zenOn Projekte sind lauffähig unter Windows NT/2000/XP und CE. Erstellte zenOn-Projekte können per TCP/IP auf die Zielplattform geladen werden, eine Änderung der Dialoge kann sogar zur Laufzeit erfolgen. Der Zugriff auf TwinCAT SPS Variablen erfolgt über optimiertes ADS. Die zenOn Dialoge werden auflösungsunabhängig erstellt und passen sich an die eingestellte Monitorauflösung an.

Für Geräte mit Windows CE.NET Betriebssystem wurde die zenOn CE.NET Runtime (Copa-Data: ZRT5-CENET) integriert und wird bei BECKHOFF unter der Produktbezeichnung CX1800-0001 angeboten. Der zenOn Editor ist ausschließlich über Copa-Data zu beziehen.

1.1 Kontakt

Informationen zur lokalen Copa-Data Niederlassung oder zum Copa-Data-Partner entnehmen Sie bitte dem Web:

Österreich
A-5020 SALZBURG · Karolingerstrasse 7 b
Tel: +43/(0)662/431002-0 · Fax: DW 23
http://www.copadata.at e-mail: sales@copadata.at

Deutschland
D-85521 Ottobrunn · Haidgraben 2
Tel: +49/(0)89/660298-90 Fax DW 99
http://www.copadata.de e-mail: sales@copadata.de

2. zenOn Produktbeschreibung

(Auszug aus der Copa-Data Produktbeschreibung)

Für das Design wird die Standard PC Entwicklungsumgebung verwendet oder der begrenzte Editor für CE Projekte. Die zenOn CE Runtime ist auf CE Hardware Plattformen (hier BECKHOFF CX Plattform) lauffähig. PC Connect und Downloadfunktionen wird von der Entwicklungsumgebung unterstützt.

2.1 zenOn CE Netzwerkkopplung

Die zenOn CE Netzwerkkopplung ermöglicht die Einbindung von zenOn CE Bedienterminals in ein zenOn Netzwerk. Ein zenOn Netzwerk unterstützt somit in einem Verbund sowohl PC als auch CE Stationen.
Mögliche Anbindungsarten:

  • CE Terminal ist Server
  • CE Terminal ist Client
  • PC ist Server / CE Terminal ist Prozessdatenserver
    (Mischung zwischen Client und Server. Optimiert für die vor Ort Bedienung mit Datenspeicherung im Netzwerk auf einem separaten PC System.)

Grundsätzlich bietet zenOn CE die selben Funktionalitäten wie zenOn mit einigen Begrenzungen, die sich durch die geringeren Hardwareressourcen ergeben.
zenOn CE bietet :

  • Schablonen / Mehrfenstertechnik
  • Alarmsystem (Ringspeicher)
  • chronologische Ereignisliste (Ringspeicher)
  • Statusverarbeitung
  • Benutzerverwaltung
  • Zeitsteuerung
  • Rezeptverwaltung
  • online Sprachumschaltung
  • Mathematik
  • flexible Anschaltung an verschiedene SPS - Systeme
  • Soundunterstützung
  • usw.

3. Voraussetzung

Die CX1800-0001 zenOn CE Runtime benötigt ein CE Gerät mit hohem Speicherausbau ( z.B. CX1001-xx1x).

4. zenOn CE Runtime auf CE Gerät / zenOn Lizenz

4.1 zenOn CE Runtime vorinstalliert auf CE Gerät / zenOn Lizenz

Bei entsprechender Bestellung ist die CX1800-0001 zenOn CE Runtime bereits vorinstalliert auf dem CE Gerät verfügbar. Nach Einschalten des CE Geräts wird der zenOn-System-Service automatisch gestartet, vom Host-PC kann somit aus dem zenOn Editor direkt eine HMI Lösung per TCP-IP auf das CE Gerät geladen werden. Der notwendige zenOn-CE Lizenzschlüssel ist dem zenOn- Aufkleber auf dem CE Gerät zu entnehmen.

4.2 Installation der zenOn CE Runtime / Evaluierungslizenz

Eine CE-Installation der zenOn-CE-Runtime kann kostenlos vom BECKHOFF Web geladen und per Compact-Flash Adapter oder über den CX1000-FTP Server auf das CE Gerät kopiert werden.
Dabei sollte als CX-CE-Basisimage die Variante "CX1800-0101-000x HMI" verwendet werden.

Die Installationsdatei "CX1800-0001_HMI_Zenon.I586.CAB" wird per Doppelklick zur Ausführung gebracht.

ACHTUNG:

  • Als Zielverzeichnis muss das vorgewählte Verzeichnis "\hard disk\zenOn_RT" mit "OK" bestätigt werden !
  • Nach der Installation der Komponenten in das korrekte Zielverzeichnis "\hard disk\zenOn_RT" löscht sich die Installationsdatei CX1800-0001_HMI_Zenon.I586.CAB selber.

Nach Bestätigung mit "OK" wird die Installation in das korrekte Zielverzeichnis "\hard disk\zenOn_RT" durchgeführt.

  • Beenden Sie das CE Gerät einmalig nach der Installation per "Start-> Suspend". Erst dann werden die Einstellungen in der Registry auf die Compact Flash des CE Geräts gesichert.
  • Nach einem Neustart wird der zenOn-CE System Service gestartet, vom Host-PC kann somit aus dem zenOn Editor direkt eine HMI Lösung per TCP/IP auf das CE Gerät geladen werden.
  • Für die Evaluierungsphase steht die kostenlose Evaluierungs-Lizenz ( SN: 00000.1410.0.0 ) zur Verfügung, diese beschränkt die zenOn-CE Runtime auf einen 30 minütigen Betrieb.


CX1800-0002 TwinCAT HMI Target Visu CE

1. Allgemein

  • Die TwinCAT HMI Target Visu CE kann vorinstalliert auf den CE Geräten bei Beckhoff bestellt werden.
  • Die TwinCAT HMI Target Visu CE, ein Produkt von BECKHOFF , ist ein Visualisierungspaket für das Beckhoff Embedded System, basierend auf dem Betriebssystem CE.

2. TwinCAT HMI Target Visu CE Produktbeschreibung

Eine ausführliche Beschreibung der Funktionalität finden Sie unter TwinCAT PLC Control, "Target-Visualisierung"

3. Voraussetzung

Die CX1800-0002 TwinCAT HMI Target Visu CE benötigt ein CE Gerät mit mindestens 128 MB RAM.

Die CX1800-0002 TwinCAT HMI Target Visu CE benötigt ein CE basierendes HMI Image ab Version 1.90.

Um Benutzer Interfaces zu erstellen ist TwinCAT V2.10 Build 1242 (oder höher) auf dem Host-PC erforderlich.

4. TwinCAT HMI Target Visu CE Lizenz

4.1 TwinCAT HMI Target Visu CE vorinstalliert auf dem CE Gerät / TwinCAT HMI Target Visu CE Lizenz

Bei entsprechender Bestellung ist die CX1800-0002 TwinCAT HMI Taget Visu bereits vorinstalliert auf dem CE Gerät verfügbar.

4.2 Installation der TwinCAT HMI Target Visu CE

Nach Installation der Software auf Ihrem Host-PC müssen Sie die ..\TwinCAT\CE\TargetVisu\X86\*.cab Datei per Compact Flash Adapter , FTP-Server oder per Public Folder auf das CE Gerät kopieren.

Wenn sich die Installationsdatei "CX1800-0002_HMI_TcTargetVisuCE.I586.CAB" auf dem CE Gerät befindet, kann sie mit einem Doppelklick ausgeführt werden.

HINWEIS:

  • Als Zielpfad muss der vorgewählte (default) Pfad "\hard disk\system" mit "OK" bestätigt werden!
  • Nach der Installation der Komponente in den korrekten Zielordner "\hard disk\system" wird die Installationsdatei CX1800-0002_HMI_TcTargetVisuCe.I586.CAB automatisch entfernt.

Nach Bestätigung mit "OK" wird die Installation im Zielordner "\hard disk\system" ausgeführt.

  • Beenden Sie das CE Gerät einmalig nach der Installation per "Start-> Suspend". Erst dann werden die Einstellungen in der Registry auf die Compact Flash des CE Geräts gesichert.
  • Die Konfiguration der Targt Visu kann in TwinCAT PLC Control vorgenommen werden.

5. Konfiguration

Die Konfiguration der Target Visu erfolgt in TwinCAT PLC Control.

Nach der Erstellung der User Interface Bildschirme im PLC Control muss der Download zum Geräte einmalig aktiviert werden.
Die Aktivierung erfolgt im TwinCAT PLC Control: Wählen Sie Menü "Projekt" , "Optionen..." die Kategorie "TwinCAT" und "Enable CE Target Visualization".

HINWEIS:: Die Target Visualisierung ist nicht kostenlos. Es wird eine Lizenz pro CPU benötigt.

Die Bildschirmauflösung in in folgender Datei definiert: "C:\TwinCAT\PLC\TwinCAT PLC Control.ini"

[TwinCAT PLC Control]
VisuWidth=640
VisuHeight=480


CX1800-0003 QVis HMI CE Runtime

1. Generell

  • Die QVis HMI CE-Runtime kann vorinstalliert mit dem CE Gerät ( z.B.CX1001-xxxx) bei Beckhoff bestellt werden.
  • Der notwendige QVis-Editor zur Erstellung der QVis-HMI-Lösung wird nicht von Fa. Beckhoff geliefert sondern muss von Fa. Hilscher Swiss erworben werden.

Das Produkt QVis der Firma Hilscher Swiss aus der Schweiz ist ein Visualisierungspaket auch für die Beckhoff Embedded Geräte. Ab der Version 1.30 ermöglicht der QVis Editor den komfortablen Import von TwinCAT SPS Projekten. Die so erstellten Qvis Projekte sind lauffähig unter Windows NT/2000/XP und CE. Erstellte QVis-Projekte können per ActiveSync oder per FTP auf die Zielplattform geladen werden. Der Zugriff auf TwinCAT SPS Variablen erfolgt über optimiertes ADS. Die QVis Dialoge können in der Entwicklungsphase an die Bildschirmauflösung de CE Geräts angepasst werden.

Für Geräte mit Windows CE.NET Betriebssystem wurde die QVis CE Runtime integriert und wird bei BECKHOFF unter der Produktbezeichnung CX1800-0003 angeboten. Der QVis Editor ist ausschließlich über Fa. Hilscher Swiss zu beziehen.

1.1 Kontakt

Weitere Informationen zum Produkt entnehmen Sie bitte dem Web:

Hilscher Swiss GmbH

Embedded Technology
Hubelmattstrasse 29
CH-4500 Solothurn
Tel +41 32 623 6633
Fax +41 32 623 6632

www.hilscher.com e-mail: info@hilscher.com

2. QVis Produktbeschreibung

(Auszug aus der QVis Produktbeschreibung)

Für das Design wird die Standard PC Entwicklungsumgebung verwendet. Die QVis CE Runtime ist auf CE Hardware Plattformen (hier BECKHOFF CX Plattform) lauffähig.

QVis CE bietet :

  • Vollgraphische Bedienerführung
  • Trenddarstellung
  • Alarmsystem
  • chronologische Ereignisliste
  • Passwort Handling
  • Rezeptverwaltung
  • online Sprachumschaltung (Unicode-Zeichensatz)
  • online Einheitenumschaltung mit Wertumrechnung
  • flexible Anschaltung an verschiedene SPS - Systeme
  • Simulation auf Entwicklungsrechner
  • uvm.

3. Voraussetzung

Die CX1800-0003 QVis CE Runtime benötigt ein CE Gerät mit hohem Speicherausbau (z.B. CX1001-xxxx).

4. QVis CE Runtime auf CE Gerät / QVis Lizenz

4.1 Installation der QVis CE Runtime / Evaluierungslizenz

Eine Evaluierungsversion der QVis-CE-Runtime ist aktuell noch nicht verfügbar, bitte kontaktieren Sie Fa. Hilscher Swiss für Evaluierungsversionen.

4.2 QVis CE Runtime vorinstalliert auf CE Gerät / QVis Lizenz

Bei entsprechender Bestellung ist die CX1800-0003 QVis CE Runtime bereits vorinstalliert auf dem CE Gerät verfügbar. Nach Einschalten des CE Geräts wird der QVis-QLoader automatisch gestartet. Vom Host-PC kann via Compact Flash Adapter oder FTP eine HMI Lösung auf das CE Gerät geladen werden.

Die notwendige QVis-CE Lizenz ist im Preis CX1800-0003 enthalten.

ACHTUNG:

  • Als Zielverzeichnis muss das vorgewählte Verzeichnis "\hard disk\QVisRT" mit "OK" bestätigt werden !
  • Nach der Installation der Komponenten in das korrekte Zielverzeichnis "\hard disk\QVisRT" löscht sich die Installationsdatei CX1800-0003_HMI_QVis.I586.CAB selber.

Nach Bestätigung mit "OK" wird die Installation in das korrekte Zielverzeichnis "\hard disk\QVisRT" durchgeführt.

  • Beenden Sie das CE Gerät einmalig nach der Installation per "Start-> Suspend". Erst dann werden die Einstellungen in der Registry auf die Compact Flash des CE Geräts gesichert.
  • Nach einem Neustart wird der QVis-CE Dienst "QLoader" gestartet, weitere Informationen dazu sind in der Dokumentation der Fa. Hilscher Swiss enthalten.


CX1800-0004 Movicon HMI CE Runtime

1. Generell

  • Die Movicon HMI CE-Runtime kann vorinstalliert mit dem CE Gerät bei Beckhoff bestellt werden.
  • Der notwendige Movicon-Editor zur Erstellung der Movicon-HMI-Lösung wird nicht von Fa. Beckhoff geliefert sondern muss von Fa. Progea erworben werden.

Das Produkt Movicon der Firma Progea aus Italien ist ein Visualisierungspaket auch für das Beckhoff Embedded-System. Ab der Version 9.1 Build 605 ermöglicht der Movicon Editor den komfortablen Import von TwinCAT SPS Projekten. Die so erstellten Movicon Projekte sind lauffähig unter Windows NT/2000/XP und CE. Erstellte Movicon-Projekte können per ActiveSync oder per FTP auf die Zielplattform geladen werden. Der Zugriff auf TwinCAT SPS Variablen erfolgt über ADS. Die Movicon Dialoge werden unabhängig von der Bildschirmauflösung des CE Geräts erstellt.

Für Geräte mit Windows CE.NET Betriebssystem wurde die Movicon CE Runtime (Progea: RTCE01) integriert und wird bei BECKHOFF unter der Produktbezeichnung CX1800-0004 angeboten.
Der Movicon Editor ist ausschließlich über Fa. Progea zu beziehen.

1.1 Kontakt

Informationen zur Progea Niederlassung entnehmen Sie bitte dem Web:

Deutschland

Pankstr. 8-10
D-13127 Berlin
Deutschland
Tel. +49 30 48627991
Fax. +49 30 48627993
Email:info@progea.de
http://www.progea.de

Italien (Headquater)

Progea Srl
Via S. Anna 88/E
I-41100 Modena
Italien
Tel. +39 059 451060 (6 linee r.a.)
Fax. +39 059 451061
Email:info@progea.com
http://www.progea.com

2. Movicon Produktbeschreibung

(Auszug aus der Progea Produktbeschreibung)

Movicon ermöglicht die Erstellung von HMI Lösungen für die Plattform 98/Me/NT/2000/XP/CE 3.0/CE.NET. Die Movicon CE Runtime ist auf CE Hardware Plattformen (hier BECKHOFF CX Plattform) lauffähig.

Movicon CE bietet :

  • 3D Graphic interface
  • Rezept Manager
  • Alarm Management
  • Data Logger Management
  • Trend Interface
  • Netzwerk Management

3. Voraussetzung

Die CX1800-0004 Movicon CE Runtime benötigt ein CE Gerät mit hohem Speicherausbau (z.B. CX1001-xxxx).

4. Movicon CE Runtime auf CE Gerät / Movicon Lizenz

4.1 Movicon CE Runtime vorinstalliert auf CE Gerät / Movicon Lizenz

Bei entsprechender Bestellung ist die CX1800-0004 Movicon CE Runtime bereits vorinstalliert auf dem CE Gerät verfügbar. Nach Einschalten des CE Geräts wird die HMI Lösung Movce.exe automatisch mit einem Demoprojekt gestartet.

Der notwendige Movicon-CE Lizenzschlüssel ist dem Movicon-Aufkleber auf dem CE Gerät zu entnehmen.

4.2 Installation der Movicon CE Runtime / Evaluierungslizenz

Eine CE-Installation der Movicon-CE-Runtime kann kostenlos vom BECKHOFF Web geladen und per Compact-Flash Adapter oder über den CX1000-FTP Server auf das CE Gerät kopiert werden.
Dabei sollte als CX-CE-Basisimage die Variante "CX1800-0101-000x HMI" verwendet werden.

Die Installationsdatei "CX1800-0004_HMI_Movicon.I586.CAB" wird per Doppelklick zur Ausführung gebracht.

ACHTUNG:

  • Als Zielverzeichnis muss das vorgewählte Verzeichnis "\hard disk\MovXCe" mit "OK" bestätigt werden !
  • Nach der Installation der Komponenten in das korrekte Zielverzeichnis "\hard disk\MovXCe" löscht sich die Installationsdatei CX1800-0004_HMI_Movicon.I586.CAB selbst.

Nach Bestätigung mit "OK" wird die Installation in das korrekte Zielverzeichnis "\hard disk\MovXCe" durchgeführt.

  • Beenden Sie das CE Gerät einmalig nach der Installation per "Start-> Suspend". Erst dann werden die Einstellungen in der Registry auf die Compact Flash des CE Geräts gesichert.
  • Nach einem Neustart wird MovXCE.exe mit dem Demoprojekt gestartet. Dieses Demo ist als Startprojekt in der Batchdatei "\hard disk\MovXCe\autoexec.cmd" enthalten.
    Zum automatischen Starten eines anderen Projektes verändern Sie die Batchdatei "\hard disk\MovXCe\autoexec.cmd".
  • Für die Evaluierungsphase ist keine Lizenz notwendig, die Dokumentation der Fa. Progea gibt Auskunft über den Evaluierungsmodus.


CX1800-0005 InduSoft HMI CE Runtime

1. Generell

  • Die InduSoft Web Studio HMI CE-Runtime kann vorinstalliert mit dem CE Gerät Beckhoff bestellt werden.
  • Der notwendige InduSoft Web Studio-Editor zur Erstellung der InduSoft-HMI-Lösung wird nicht von Fa. Beckhoff geliefert sondern muss von Fa. InduSoft erworben werden.

Das Produkt WebStudio der Firma InduSoft aus den USA ist ein Visualisierungspaket auch für das Beckhoff Embedded-System. Der InduSoft-Editor bietet neben vielen Treibern eine OPC Client Schnittstelle und ermöglicht durch Browsen in den Namespace des TwinCAT-OPC-Server somit eine komfortable Erstellung von HMI Lösungen. Die so erstellten InduSoft Web Studio Projekte sind lauffähig unter Windows NT/2000/XP und CE. Erstellte InduSoft Web Studio-Projekte können per TCP/IP, per Compact-Flash Adapter oder per FTP auf die Zielplattform CE geladen werden. Der Zugriff auf TwinCAT Variablen erfolgt über den performance optimierten TwinCAT OPC Server CE, dieser ist bereits vorinstalliert auf dem CE Gerät. Die InduSoft Web Studio Dialoge werden auflösungsunabhängig erstellt und passen sich an die eingestellte Monitorauflösung an.

Für Geräte mit Windows CE.NET Betriebssystem wurde die InduSoft Web Studio CE Runtime integriert und wird bei BECKHOFF unter der Produktbezeichnung CX1800-0005 angeboten.

Der InduSoft Web Studio Editor ist ausschließlich über Fa. InduSoft zu beziehen.

1.1 Kontakt

Informationen zu InduSoft Niederlassungen entnehmen Sie bitte dem Web:

SALES (EUROPE)

Rheintalbahnstr. 45
D-68753 Waghaeusel
Deutschland
Direct: +49 7254-952841
Fax: +49 7254-952843
germany@indusoft.com
http://Indusoft.com

SALES AND TECHNICAL SUPPORT
(UNITED STATES)

3445 Executive Center Drive, Suite 212
Austin, TX 78731
info@indusoft.com or support@indusoft.com
Toll Free: 877-INDUSOFT (877-463-8763)
Direct: 512-349-0334
Fax: 512-349-0375
http://Indusoft.com

SALES AND TECHNICAL SUPPORT
(SOUTH AMERICA)

Av. Eng. Luis Carlos Berrini, 962 – 8° andar
São Paulo, SP Brazil 04571-906
sales@indusoft.com.br
Direct: +55 11 5505-5676
Fax: +55 11 5505-5676 ext. 13
http://Indusoft.com

2. InduSoft Produktbeschreibung

(Auszug aus der InduSoft Produktbeschreibung)

InduSoft Web Studio ermöglicht die Erstellung von HMI Lösungen für die Plattform Windows NT/ 2000 / XP /CE 3.0 / CE.NET. Die InduSoft Web Studio CE Runtime ist auf CE Hardware Plattformen (hier BECKHOFF CX Plattform) lauffähig.

InduSoft Web Studio CE bietet :

  • Rezept Manager
  • Alarm Management
  • Data Logger Management
  • Trend Interface
  • Netzwerk Management
  • Scriptsprache
  • Testwerkzeuge auf der CE Zielplattform

3. Voraussetzung

Die CX1800-0005 InduSoft CE Runtime benötigt ein CE Gerät mit hohem Speicherausbau (z.B. CX1001-xxxx).

4. InduSoft CE Runtime auf CE Gerät / InduSoft Lizenz

4.1 InduSoft CE Runtime vorinstalliert auf CE Gerät / InduSoft Lizenz

Bei entsprechender Bestellung ist die CX1800-0005 InduSoft CE Runtime bereits vorinstalliert auf dem CE Gerät verfügbar. Nach Einschalten des CE Geräts wird der InduSoft System Service CEServer.exe automatisch gestartet.

Der notwendige InduSoft-CE Lizenzschlüssel ist bereits auf dem CE Gerät eingetragen.

4.2 Installation der InduSoft CE Runtime / Evaluierungslizenz

Eine CE-Installation der InduSoft-CE-Runtime kann kostenlos vom BECKHOFF Web geladen und per Compact-Flash Adapter oder über den CX1000-FTP Server auf das CE Gerät kopiert werden.
Dabei sollte als CX-CE-Basisimage die Variante "CX1800-0101-000x HMI" verwendet werden.

Die Installationsdatei "CX1800-0005_HMI_InduSoft.I586.CAB" wird auf dem CE Gerät per Doppelklick zur Ausführung gebracht.

ACHTUNG:

  • Als Zielverzeichnis muss das vorgewählte Verzeichnis "\hard disk\InduSoft" mit "OK" bestätigt werden !
  • Nach der Installation der Komponenten in das korrekte Zielverzeichnis "\hard disk\InduSoft" löscht sich die Installationsdatei CX1800-0005_HMI_InduSoft.I586.CAB selber.

Nach Bestätigung mit "OK" wird die Installation in das korrekte Zielverzeichnis "\hard disk\InduSoft" durchgeführt.

  • Beenden Sie das CE Gerät einmalig nach der Installation per "Start-> Suspend". Erst dann werden die Einstellungen in der Registry auf die Compact Flash des CE Geräts gesichert.
  • Nach einem Neustart wird der InduSoft-Remote Agent ( \hard disk\InduSoft\CEServer.exe) gestartet. Sie können nun ihre InduSoft Applikation zum CE Gerät via TCP-IP laden.

  • Für die Evaluierungsphase ist keine Lizenz notwendig, die Dokumentation der Fa. InduSoft gibt Auskunft über den Evaluierungsmodus.


CX 1000 Hardwarekompatibilität - Hinweise

ACHTUNG: Nur in Verbindung mit seriellen Zeigegeräten benutzen !

zurück zur Hardwarekompatibilitätsliste


Hardware Installation on CX 1000 computer with Windows XP embedded

CAUTION:

The device needs more electricity! For this reason the device should be connected with the CX1000 computer or an USB hub with own current supply (active hub).

Otherwise malfunctions of the device are possible.

back to hardware compatibility list


Hardware-Kompatibilitätsliste

Kompatible Hardware zu Beckhoff embedded PCs mit dem Microsoft Windows XP embedded Betriebssystem

In der folgenden Tabelle sind die Geräte aufgeführt, die mit einem Beckhoff embedded PC verwendet und auf ihre Funktionalität getestet wurden.
Getestet wurde die Installation und die Funktion dieser Geräte auf dem CX 1000 Computer mit einem Windows XP embedded Beckhoff Standard Image für embedded PCs.

USB Massenspeicher | Adapter: IDE | Adapter: Wired LAN
Optische Laufwerke | Adapter: Bluetooth | Adapter: Wirelles LAN
Diskettenlaufwerke | Adapter: Card Reader | Adapter: ISDN
Modems | Adapter: Serial Port | Mouse und Zeigegeräte
Drucker (lokal) | Adapter: Parallel Port | Tastaturen

ACHTUNG:

USB Floppy Laufwerke, Festplatten, Bluetooth Adapter, usw. besitzen einen erhöhten Strombedarf. Aus diesem Grund sollte man diese Geräte direkt an dem CX 1000 Computer anschließen oder an einem "aktiven" USB Hub (d.h. ein Hub mit eigener Stromversorgung) betreiben, wenn eine externe Stromversorgung an dem Gerät nicht vorhanden ist.
Anderenfalls funktioniert das angeschlossene Gerät nicht ordnungsgemäß.

Gerät | Beschreibung | Schnittstelle | Image-Kompatibilität | Information | Installation
USB Massenspeicher
CnMemory Red Pearl 1.1 | Hot-Plug fähiger USB Flash-Speicher der mit einer USB 1.1 Schnittstelle verwendet werden kann | USB | ab CX 1800-0202 Version 1.13 |  |
Jamba U100 | Hot-Plug fähiger USB Flash-Speicher der mit einer USB 1.1 Schnittstelle verwendet werden kann | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
Medion USB Stick (3SYSTEM USB FLASH) | Hot-Plug fähiger USB Flash-Speicher der mit einer USB 1.1 Schnittstelle verwendet werden kann | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
OTi Flash Disk (6808) | Hot-Plug fähiger USB Flash-Speicher der mit einer USB 1.1 Schnittstelle verwendet werden kann | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
Sony Micro Vault | Hot-Plug fähiger USB Flash-Speicher der mit einer USB 2.0 Schnittstelle (abwärtskompatibel) verwendet werden kann | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
Transcend JetFlash | Hot-Plug fähiger USB Flash-Speicher der mit einer USB 1.1 Schnittstelle verwendet werden kann | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
TrekStor USB-Stick 2.0 CS | Hot-Plug fähiger USB Flash-Speicher der mit einer USB 2.0 Schnittstelle (abwärtskompatibel) verwendet werden kann | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
TwinMOS Mobile Disk III TTI-MSA USB Disk | Hot-Plug fähiger USB-Flash-Speicher der mit einer USB 1.1 Schnittstelle verwendet werden kann | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
Western Digital Series II USB 2.0 External Hard Drive | Hot-Plug fähige USB Festplatte die mit einer USB 2.0 Schnittstelle (abwärtskompatibel) verwendet werden kann | USB | ab CX 1800-0202 Version 1.13 |  |
Optische Laufwerke
FREECOM Traveller II | Hot-Plug fähiges CD-RW / DVD Combo Laufwerk (RW / DVD Combo 24x10x24x8) | USB | ab CX1800-0202 Version 1.11 |  |
Diskettenlaufwerke
TEAC FD-05PUB | Externes, hot-plug fähiges USB Diskettenlaufwerk für 1.44MB Disketten | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
DELL USB Floppy (NEC USB Floppy ) | Hot-Plug fähiges USB Diskettenlaufwerk für 1.44MB Disketten | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
Modems
Elsa MicoLink 56k basic (www.devolo.de) | Plug&Play fähiges Modem mit seriellem Anschluss. | seriell (RS 232) | ab CX1800-0201 Version 1.01 |  |
U.S. Robotics 56k Faxmodem | Plug&Play fähiges Modem mit seriellem Anschluss. | seriell (RS 232) | ab CX1800-0201 Version 1.01 |  |
Drucker (lokal)
Canon i350 | Plug&Play Farb Tintenstrahldrucker | USB | ab CX1800-0202 Version 1.14 |  |
Canon i865 | Plug&Play Farb Tintenstrahldrucker | USB | ab CX1800-0202 Version 1.20 |  |
Canon BJC 6200 | Plug&Play Farb Tintenstrahldrucker | USB | ab CX1800-0202 Version 1.20 |  |
EPSON AcuLaser C900 | Plug&Play Farb Laser Drucker | USB | ab CX1800-0201 Version 1.13 |  |
EPSON EPL-6200 | Plug&Play Schwarz/Weiß Laser Drucker | USB | ab CX1800-0201 Version 1.14 |  |
Adapter: IDE
Beckhoff C9900 A156 0 USB 2.0 to ATA / ATAPI connector | Hot-Plug fähiger Adapter, mit dem IDE-Geräte (HDD, CD-ROM) mit einer USB 2.0 (abwärtskompatibel) Schnittstelle benutzt werden können | USB / IDE | ab CX1800-0202 Version 1.14 |  |
EZ Linker USB to IDE connector (KW-592) | Hot-Plug fähiger Adapter, mit dem IDE-Geräte (HDD, CD-ROM) mit einer USB 1.1 Schnittstelle benutzt werden können | USB / IDE | ab CX1800-0202 Version 1.11 |  |
Adapter: Bluetooth
MSI MS-6967 (PC2PC) USB Bluetooth Adapter | stellt eine Bluetooth Funktionalität (drahtlose Verbindung) nach dem IEEE 802.15.1 Standard an dem Computer her | USB / Bluetooth | ab CX1800-0202 Version 1.11 mit Widcomm Bluetooth Stack ab CX1800-0202 Version 1.20 mit Microsoft Bluetooth Stack |  |
ALLNET ALL1575 USB Bluetooth Adapter | stellt eine Bluetooth Funktionalität (drahtlose Verbindung) nach dem IEEE 802.15.1 Standard an dem Computer her | USB / Bluetooth | ab CX1800-0202 Version 1.11 mit Widcomm Bluetooth Stack |  |
Adapter: Card Reader
Medion MD 5313 Card Reader/Writer | Hot-Plug fähiger Adapter, mit dem Flashkartenspeicher (Compact Flash Typ I+II, SD-, MM- Card... ) am CX1000 Gerät benutzt werden können | USB / CFI+II, MS, SD, SM | alle CX 1000 Standard Images ab Version 1.00 |  |
(ANUBIS 81035) TYPHOON USB 2.0 8-in-1 CARD READER | Hot-Plug fähiger USB 2.0 Adapter, mit dem Flashspeicher (Compact Flash Typ I+II, SD-, MM- Card... ) am CX1000 Gerät benutzt werden können | USB / CFI+II, MD, MS / -PRO, SM, SD, MMC | ab CX1800-0202 Version 1.13 |  |
Adapter: Serial Port
Prolific PL-2303 USB to Serial Comm Port | erstellt einen (virtuellen) seriellen Port (RS232) | USB / RS 232 | ab CX1800-0201 Version 1.13 |  |
HP High Speed Converter (FTDI) | erstellt einen (virtuellen) seriellen Port (RS232) | USB / RS 232 | ab CX1800-0201 Version 1.13 |  |
Adapter: Parallel Port
Belkin F5U002 USB Parallel Printer Adapter | stellt die parallele Druckerfunktionalität her (nach IEEE 1284 Standard) | USB / parallel (centronics) | ab CX1800-0201 Version 1.13 |  |
Adapter: Wired LAN
Prolific PL-2302 USB to USB Network Bridge | stellt eine Netzwerkfunktionalität her auf Basis der TCP/IP Protokolle und der USB-Schnittstellen | USB / USB | ab CX1800-0201 Version 1.13 |  |
UTE-200 (ASIX AX88172) USB 2.0 to Fast Ethernet Adapter | stellt eine Ethernet Schnittstelle zur Verfügung nach dem IEEE 802.3 / IEEE 802.3u LAN Standard | USB / RJ-45 (Ethernet) | ab CX1800-0202 Version 1.13 |  |
Adapter: Wireless LAN
D-Link DWL-122 | stellt eine drahtlose LAN Funktionalität nach dem IEEE 802.11b Standard an dem Computer her | USB / WLAN | abCX1800-0201 Version 1.14 |  |
Netgear MA111 Wireless LAN Adapter | stellt eine drahtlose LAN Funktionalität nach dem IEEE 802.11b Standard an dem Computer her | USB / WLAN | ab CX1800-0201 Version 1.13 |  |
ZyXEL ZyAIR B-400 Wireless LAN Ethernet Adapter | stellt eine Verbindung über Ethernet zu W-LAN her | RJ-45 (Ethernet) / W-LAN | ab CX1800-0200 Version 1.13, sofern ein Browser zur Konfigu-ration zur Verfügung steht |  |
Adapter: ISDN
AVM Fritz!Card USB Ver2.1 | stellt eine Netzwerkfunktionalität her auf Basis von ISDN. Ermöglicht die Nutzung von ISDN Diensten. | USB / ISDN | ab CX1800-0201 Version 1.13 |  |
Mouse und Zeigegeräte
Microsoft IntelliMouse Explorer | Zeigegerät | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
Microsoft IntelliMouse USB | Zeigegerät | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
Microsoft Serial Mouse | Zeigegerät | seriell (RS 232) | alle CX 1000 Standard Images ab Version 1.00 |  |
Logitech MX500 Optical Mouse | Zeigegerät | USB | ab CX1800-0202 Version 1.20 |  |
Logitech USB Wheel Mouse | Zeigegerät | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
Elo TouchScreen | druckempfindliches Anzeigefeld | USB | alle CX 1000 Standard Images ab Version 1.00 |  |
Tastaturen
Cherry USB Tastatur | Tastatur | USB | alle CX 1000 Standard Images ab Version 1.00 |  |


Hardware-Installaton auf dem CX 1000 Computer mit Windows XP embedded

Hardware-Installation auf dem CX 1000 Computer mit Windows XP embedded

Die Hardware-Installation auf dem CX 1000 mit Windows XP embedded ist abhängig von zwei Faktoren:

1. Das eingesetzte Betriebssystem

Windows XP embedded ist auf die jeweilige Hardware angepasst und abweichend von Windows XP professional oder der Windows XP home Edition, verfügen die Windows XP embedded Betriebssysteme über keine Treiberdatenbank. Es sind in der Regel nur Treiber für die verwendeten Hardware Geräte vorhanden. Die BECKHOFF Standard Images für CX 1000 Computer sind in der Lage die häufig verwendeten Plug & Play Geräte zu erkennen und in das System automatisch mit einzubinden. Dies gilt insbesondere für USB Massenspeicher (USB-Stick), USB-Diskettenlaufwerke,... etc. Die CX1800-0202 (.NET) und CX1800-0201 Images haben den größten Treiberumfang.

2. Die verwendete Hardware

Bei der Installation zusätzlicher Hardware ist es notwendig, die benötigten Treiber bereitzustellen. Sollten die benötigten Treiber nicht im CX1000 Standard Image enthalten sein, dann wird ein externes Treiber Archiv nötig sein.

Das Bereitstellen des externen Treiber Archives kann durch das Ablegen der Daten auf einem USB Massenspeicher (USB-Stick, USB-Festplatte,...) geschehen. Sie können auch das externe Treiberarchiv auf einem anderen im Netzwerk befindenden Computer ablegen und dann über das Netzwerk darauf zugreifen. Manche Installationen erfordern ein Laufwerk daher sollten Sie zuvor ein Netzlaufwerk erstellen und dann darauf zugreifen.

Im Grunde gibt es drei verschiedene Verfahren bei der Hardwareinstallation an einem CX 1000 Computer mit Windows XP embedded:

1. Das angeschlossene Gerät wird vom Betriebssystem durch Plug&Play erkannt und die benötigten Treiber sind im Windows XP embedded Image enthalten.

2. Das angeschlossene Gerät wird vom Betriebsystem durch Plug&Play erkannt. Allerdings benötigt das Betriebsystem zusätzliche Treiber um das Gerät ordnungsgemäß nutzen zu können.

3. Das angeschlossene Gerät wird vom Betriebssystem durch Plug&Play erkannt. Die Installation des Gerätes benötigt neben den Geräte-Treibern auch noch Treiber aus dem Windows Treiber-Archiv.

zurück zur Hardwarekompatibilitätsliste

Embedded PC


Hardware Installation auf dem CX 1000 Computer mit dem Windows XP embedded Betriebssystem

Das Gerät wird beim Anschluss an den CX 1000 Computer automatisch erkannt und in das Windows XP embedded System eingebunden.

Eine Treiberinstallation für dieses Gerät ist nicht erforderlich

zurück zur Hardwarekopatibilitätsliste


Hardware Installation auf dem CX 1000 Computer mit dem Windows XP embedded Betriebssystem

Das Gerät wird durch die Plug&play Funktion gefunden. Anschließend müssen Sie den Treiber-Pfad für den Gerätetreiber angeben.

Die Treiber für das Gerät können sich auf folgenden Ressourcen befinden:

  • Wechselmedien (USB-Stick, Diskette, CD-ROM)

  • Netzwerkfreigaben

zurück zur Hardwarekompatibilitätsliste


Hardware Installation auf dem CX 1000 Computer mit dem Windows XP embedded Betriebssystem

Das Gerät wird durch die Plug&Play Funktion gefunden. Anschließend müssen Sie den Treiber-Pfad angeben. Es werden noch einige Dateien aus dem Windows XP Treiberarchiv benötigt. Den Pfad zu den Dateien muss ebenfalls angegeben werden.

Siehe Installation von Fremdgeräten.

zurück zur Hardwarekompatibilitätsliste