KM6551-0000 - Klemmenmodul für Funkübertragung

BECKHOFF Feldbuskomponenten

Dokumentation zu

KM6551-0000

Klemmenmodul für Funkübertragung

Version: 1.2.0
Datum: 22.10.2009


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


KM6551-0000 - Ausgabestände der Dokumentation

BECKHOFF KM6551-0000: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
1.2.0
  • Enthaltene TwinCAT-Bibliothek auf Version 1.7.0 aktualisiert
  • Beschreibung der Konfigurations-Software KS2000 aktualisiert
1.1.0
  • Registerbeschreibung erweitert
  • Hinweise zu Störungen durch andere Funksysteme erweitert
  • Hinweise zur Montage erweitert
  • Antenne ZS6201-0500 hinzugefügt
  • Beschreibungen der Antennen aktualisiert
1.0.0 | erste Veröffentlichung

Firm- und Hardware-Stände

Dokumentation, Version | Firmware-Version | Hardware-Version
1.2.0 | 1E | 01
1.1.0 | 1E | 00
1.0.0 | 1B | 00

Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite des Klemmenmoduls aufgedruckten Seriennummer entnehmen.

Syntax der Seriennummer

Aufbau der Seriennummer: WW YY FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 35 05 00 01:

35 - Produktionswoche 35
05 - Produktionsjahr 2005
00 - Firmware-Stand 00
01 - Hardware-Stand 01


KM6551-0000 - Einführung

BECKHOFF KM6551-0000: Produktübersicht

Einführung

Wireless Datenaustausch Klemme

Das Klemmenmodul KM6551-0000 ist eine Datenaustauscheinheit basierend auf Funktechnik. Es nutzt den Standard IEEE 802.15.4. Unabhängig vom überlagerten Feldbus werden Daten ausgetauscht oder zwischen zwei eigenständigen Steuerungen Daten über Funk übertragen. Im freien Feld können bis zu 300 m zwischen zwei KM6551-0000 liegen.

Das Klemmenmodul KM6551-0000 besitzt einen reversen SMA-Stecker (Straight Medium Adapter), an den verschiedene, von Beckhoff zu beziehende Funkantennen angeschlossen werden können. Durch die gezielte Wahl der Antenne können Sie die Richtcharakteristik der Umgebung anpassen. Der Status und der Datenaustausch werden über LEDs angezeigt und bieten damit eine schnelle und einfache Diagnose. Für den Einsatz des Klemmenmodul KM6551-0000 mit TwinCAT steht eine TwinCAT-Bibliothek zur Verfügung.


KM6551-0000 - Technische Daten

BECKHOFF KM6551-0000: Produktübersicht

Technische Daten

Technische Daten | KM6551-0000
Frequenzband | 2,4 GHz
Übertragungsraten | 250 kBit
Ausgangsleistung | 0 dBm (1 mW)
Empfangsempfindlichkeit | -87 dBm
Protokoll | IEEE 802.15.4
Antennenanschluss | reverser SMA-Stecker (RP_SMA)
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 135 mA
Breite eines Busklemmenblocks | maximal 64 Standard-Busklemmen oder 80 cm (ein KM6551-0000 entspricht hierbei 2 Standard-Busklemmen)
Datenbreite im Eingangsprozessabbild | 12 Byte
Datenbreite im Ausgangsprozessabbild | 12 Byte
Abmessungen ohne Antennen (B x H x T) | ca. 26,5 mm x 100 mm x 55 mm (Breite angereiht: 24 mm)
Gewicht | ca. 100 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene (z.B. Hutschiene TH 35-7.5 nach EN 60715)
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4, EN 300-440-02
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE


KM6551-0000 - Grundlagen zur Funktion

BECKHOFF KM6551-0000: Produktübersicht

Grundlagen zur Funktion

Das Datenaustauschmodul KM6551-0000 ermöglicht drahtlosen Datenaustausch zwischen zwei oder mehreren Steuerungen. Es verwendet als Grundlage den Standard IEEE 802.15.4 mit einem Beckhoff -spezifischem Protokoll. Pro Datenpaket werden 10 Byte Nutzdaten übertragen. Über den DIP-Schalter können Sie den Betriebsmodus des KM6551-0000 einstellen, d.h. ob das Modul als Master oder Slave arbeitet und ist und welcher Kommunikationsmodus verwendet wird.

Die Daten werden beim Peer-to-Peer- und beim Master-Slave-Modus im Polling-Verfahren ausgetauscht. Beim Broadcast-Modus ist eine Modul der Broadcast-Master der die Daten sendet und alle anderen Module sind Broadcast-Slaves die diese Daten empfangen aber selbst keine Daten an den Broadcast-Master verschicken können. Sie hören also nur auf die Daten des Broadcast-Masters.

Im Master-Slave Modus können Sie per Software entscheiden, mit welchem Slave Daten ausgetauscht werden sollen. Es sind bis zu 7Slaves ansprechbar.

Das Datenaustauschmodul KM6551-0000 unterstützt 16 Kanäle, aus denen Sie frei wählen können um zum Beispiel mehrere Funknetzwerke aufzubauen oder um sich außerhalb von W-LANs oder anderen Funksystemen, die auch 2,4 GHz verwenden zu platzieren.

Das KM6551-0000 kann die 16 möglichen Kanäle scannen. Hier wird die Energie in dem Frequenzbereich gemessen, um vorab zu sehen ob und auf welchen Frequenzen sich etwas andere Systeme aktiv sind. Weiterhin wird bei jedem Datentelegramm der sogenannte LQI (Link of Quality Index) übertragen. Damit ist es möglich, die Güte des Signals zu bestimmen. Ein hoher LQI-Wert steht für eine gute Verbindung, ein niedriger Wert für eine schlechte Verbindung. Um den LQI-Wert zu verbessern, kann eine größere Antenne oder eine Antenne mit entsprechende größeren Übertragungsfaktor verwendet werden.

Kommunikationsmodus

Das Datenaustauschmodul KM6551-0000 unterstützt 3 verschiedene Kommunikationsmodi.

Modus 1: Peer to Peer - Datenaustausch zwischen zwei Modulen

Erlaubt den Datenaustausch zwischen zwei KM6551-0000. Es können pro Zyklus maximal 10 Byte Daten übertragen werden. In einem Zyklus (typisch < 20ms) schickt Modul 1 Daten zu Modul 2 und Modul 2 schickt Daten zu Modul 1 zurück.

Modus 2: Master-Slave - Datenaustausch eines Masters mit bis zu 7 Slaves

Im Master-Slave-Modus kann der Master im Polling-Verfahren mit bis zu sieben KM6551-0000 kommunizieren. Stellen Sie dazu mit den DIP-Schalter die entsprechenden Slave-Adressen ein. Aus der SPS können Sie dem Master mitteilen, mit welchem Slave wird wie oft und wie lange kommuniziert werden soll. Pro Slave werden ca. 20 ms benötigt. Bei sieben Slaves ergibt sich so ein minimalen Zykluszeit von gut 140 ms, die der Master benötigt um alle 7 Slaves jeweils einmal anzusprechen.

Modus 3: Broadcast an beliebig viele Slaves

Im Broadcast-Modus nur sendet nur der Broadcast-Master. Alle anderen Module (Broadcast-Slaves) können nur empfangen und selbst keine Daten verschicken. Es können beliebig viele (x) Broadcast-Slaves mithören.

Hinweis 		Unterstützung des KM6551-0000 durch Buskoppler, Busklemmen-Controller und TwinCAT
Das KM6551-0000 wird ab TwinCAT 2.10 Build 1326 unterstützt.

Es werden die Buskoppler BK1120, BK1250, BK2020, BK3120, BK3150, BK9000, BK9050 unterstütz (weitere Buskoppler auf Anfrage).
Es werden alle Busklemmen-Controller der Serien BCxxxx, BXxxxx und BXxxxx unterstützt.

Achtung 		CE-Konformität
Die CE-Konformität des KM6551-0000 ist nur beim Betrieb mit original Beckhoff-Zubehör (Antennen, Koaxialleitung) gewährleistet!


KM6551-0000 - LED-Anzeigen

BECKHOFF KM6551-0000: Produktübersicht

LED-Anzeigen

KM6551-0000

LED | Anzeige
Run (grün) | aus | Datenübertragung auf dem K-Bus nicht aktiv
 | an | Datenübertragung auf dem K-Bus aktiv
Rx (Grün) | an | Daten werden über Funk empfangen
Tx (Grün) | an | Daten werden über Funk gesendet
Link (grün, orange, rot) | an | Grün - gute Signal Qualität Orange - mäßige Signalqualität Rot - Schlechte Signalqualität oder Watchdog hat ausgelöst


KM6551-0000 - DIP-Schalter

BECKHOFF KM6551-0000: Produktübersicht

DIP-Schalter

Mit dem DIP-Schalter können Sie die verschiedenen Modi des KM6551-0000 aktivieren. Dies ermöglicht einen einfachen Austausch der Module ohne zusätzliche Konfigurations-Software.

  • DIP-Schalter in Stellung Rechts: ON
  • DIP-Schalter in Stellung Links: OFF

Im Bild ist die Einstellung Slave 5 dargestellt.

DIP-Schalter | A | B | C | D
Master-Mode | OFF | OFF | OFF | OFF
Slave 1 | ON | OFF | OFF | OFF
Slave 2 | OFF | ON | OFF | OFF
Slave 3 | ON | ON | OFF | OFF
Slave 4 | OFF | OFF | ON | OFF
Slave 5 | ON | OFF | ON | OFF
Slave 6 | OFF | ON | ON | OFF
Slave 7 | ON | ON | ON | OFF
Broadcast-Slave | OFF | OFF | OFF | ON


KM6551-0000 - IEEE802.15.4 - Einführung

BECKHOFF KM6551-0000: IEEE 802.15.4

IEEE 802.15.4

Einführung

Die Begriffe IEEE 802.15.4 und ZigBee werden vielerorts als Synonyme verwendet, obwohl zwischen ihnen eine klare Abgrenzung besteht, die an dieser Stelle kurz verdeutlicht werden soll.

Der vom Institute of Electrical and Electronics Engineers (IEEE) erarbeitete Standard 802.15.4 spezifiziert die Radioeinheit (physical Layer, PHY) und den Medienzugriff (Medium Access Control, MAC), was den untersten beiden Ebenen des OSI-Schichtenmodells entspricht. Anfang Mai 2004 wurde der Standard IEEE 802.15.4 ratifiziert [1]. Abgesehen von einigen zu erwartenden Berichtigungen und Verdeutlichungen gelten die Arbeiten daran nun also als abgeschlossen.

Die ZigBee Alliance [2] wurde von einigen großen Firmen aus der Halbleiterbranche ins Leben gerufen mit dem Ziel, auf der Basis von IEEE 802.15.4 eine komplette Protokollsuite für drahtlose Kommunikation bis hinauf zu der Applikationsschnittstelle zu entwickeln. Erwähnenswert ist in diesem Zusammenhang noch, dass der Standard IEEE 802.15.4 in keiner Weise an die ZigBee Alliance gebunden ist.

Hinweis 		Kein ZigBee!
Das Datenübertragungsmodul KM6551-0000 basiert auf IEEE 802.15.4 ist aber kein ZigBee-Produkt und auch nicht ZigBee-kompatibel!
Technische Daten | KM6551
Datenübertragungsband | 2,4 GHz
Kanäle | 16
Kanalabstand | 5 MHz
Kanalweite | 2 MHz
Verfügbar | Weltweit
Übertragungsrate | 250 kBit
Protokoll | IEEE 802.15.4

Im weltweit verfügbaren Band mit 2,4 GHz stehen 16 Kanäle mit einer Bruttodatenrate von jeweils 250 kB/s zur Verfügung.

[1] Institute of Electrical and Electronics Engineers (Ed.): IEEE Standard for Information technology -- Telecommunication and information exchange between systems -- Local and metropolitan area networks -- Specific requirements. Part 15.4: Wireless Medium Access Control (MAC) and Physical Layer (PHY) Specifications for Low-Rate Wireless Personal Area Networks (LR-WPANs).IEEE Computer Society, New York, NY, USA, October 2003

[2] ZigBee Alliance, http://www.zigbee.org


KM6551-0000 - Störungen durch andere Funksysteme

BECKHOFF KM6551-0000: IEEE 802.15.4

Störungen durch andere Funksysteme

Hinweis 		Frequenzbereiche überprüfen
Falls in einem Gebäude parallel zum KM6551-0000 (IEEE 802.15.4) auch andere Funksysteme (z.B. W-LAN) verwendet werden, prüfen Sie welche Frequenzbereiche diese Nutzen!
Mögliche Störer sind:
  • W-LAN-Netze auf angrenzenden oder gleichen Kanälen
  • Mikrowellenherde

W-LAN

Wenn sich der von den KM6551-0000 benutzte IEEE 802.15.4-Kanal mit dem Frequenzbereich eines benachbarten W-LAN-Netzes überschneiden, kann dies zu Störungen der KM6551-0000-Kommunikation führen.

Wählen Sie für die KM6551-0000 einen IEEE 802.15.4-Kanal, der wie im Bild unten dargestellt die Lücken zwischen benachbarten W-LAN-Netzen ausnutzt.

Selbst wenn benachbart die maximal möglichen drei überlappungsfreien W-LAN-Kanäle genutzt werden, bleiben für KM6551-0000 vier IEEE 802.15.4-Kanäle übrig, die Sie störungsfrei nutzen können.

  1. Drei nichtüberlappende W-LAN-Netze in den für Nordamerika zugelassenen W-LAN-Kanälen (IEEE 802.11b)
  2. Drei nichtüberlappende W-LAN-Netze in den für Europa zugelassenen W-LAN-Kanälen (IEEE 802.11b)
  3. Platzierung von EEE802.15.4-Kanälen (2400 MHz PHY) in den Lücken zwischen den W-LAN-Netzen

Mikrowellenherde

Da Mikrowellenherde typischer Weise mit einer Frequenz von 2,455 GHz arbeiten können benachbart aufgestellte, schlecht abgeschirmte Herde die Übertragung zwischen den KM6551-0000 stören.

Entfernen Sie in diesem Falle die störenden Geräte oder verwenden Sie in direkter Nachbarschaft der KM6551-0000 nur gut abgeschirmte Mikrowellenherde.


Klemmenmodule - Empfohlene Tragschienen

BECKHOFF Klemmenmodule: Montage und Verdrahtung

Empfohlene Tragschienen

Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx können Sie auf folgende Tragschienen aufrasten:

  • Hutschiene TH 35-7.5 mit 1 mm Materialstärke (nach EN 60715)
  • Hutschiene TH 35-15 mit 1,5 mm Materialstärke

Hinweis 		Materialstärke der Hutschiene beachten
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx passen nicht auf die Hutschiene TH 35-15 mit 2,2 bis 2,5 mm Materialstärke (nach EN 60715)!


Klemmenmodule - Montage und Demontage

BECKHOFF Klemmenmodule: Montage und Verdrahtung

Montage und Demontage

Die Klemmenmodule werden mit Hilfe einer 35 mm Tragschiene (z.B. Hutschiene TH 35-7.5 nach EN 60715) auf der Montagefläche befestigt.

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
  • Montieren Sie die Tragschiene an der vorgesehenen Montagestelle

    und drücken Sie (1) das Klemmenmodul gegen die Tragschiene, bis es auf der Tragschiene Einrastet (2).
  • Schließen Sie die Leitungen an.
Demontage
  • Entfernen Sie alle Leitungen. Dank der KM/EM-Steckverbinder müssen Sie hierzu nicht alle Leitungen einzeln entfernen, sondern pro KM/EM-Steckverbinder nur 2 Schrauben lösen um diese abziehen zu können (stehende Verdrahtung)!
  • Hebeln Sie auf der linken Seite des Klemmenmoduls mit einem Schraubendreher (3) den Entriegelungshaken nach oben. Dabei
    • ziehen sich über einen internen Mechanismus die beiden Rastnasen (3a) an der Hutschiene ins Klemmenmodul zurück,
    • bewegt sich der Entriegelungshaken nach vorne (3b) und rastet ein

  • Bei 32- und 64-kanaligen Klemmenmodulen (KMxxx4 und KMxxx8 bzw. EMxxx4 und EMxxx8) hebeln Sie nun den zweiten Entriegelungshaken auf der rechten Seite des Klemmenmoduls auf die gleiche Weise nach oben.
  • Ziehen Sie (5) das Klemmenmodul von der Montagefläche weg.


KM6551-0000 - Abmessungen

BECKHOFF KM6551-0000: Montage und Vertrahtung

Abmessungen


KM6551-0000 - Anschluss

BECKHOFF KM6551-0000: Montage und Verdrahtung

Anschluss

Der Anschluss der Antennen erfolgt über eine reverse SMA-Steckverschraubung. Schrauben Sie das Kabel die Koaxialleitung oder die Antenne bitte handfest an dieser Steckverschraubung an.

Koaxialleitung
Bezeichnung | Beschreibung
ZK6000-0102-0020 | Koaxialleitung, 50 Ω Wellenwiderstand, vorkonfektionierte Steckverbinder (SMA-Stecker u. rev. SMA-Buchse), schwarz, 2 m
ZK6000-0102-0040 | Koaxialleitung, 50 Ω Wellenwiderstand, vorkonfektionierte Steckverbinder (SMA-Stecker u. rev. SMA-Buchse), schwarz, 4 m


KM6551-0000 - Ausrichtung der Antennen

BECKHOFF KM6551-0000: Montage und Verdrahtung

Ausrichtung der Antennen

Beachten Sie bitte die Richtcharakteristik und Polarisation der Antennen, um sie optimal zu montieren und aufeinander auszurichten!

Richtcharakteristik

Rundstrahler

ZS6201-0410, ZS6201-0500

Bauform | Seitenansicht (vertikale Richtcharakteristik) | Draufsicht (horizontale Richtcharakteristik)

ZS6200-0400

Prädestiniert für die Montage unter der Decke.

Bauform | Seitenansicht (vertikale Richtcharakteristik) | Draufsicht (horizontale Richtcharakteristik)

Richtantennen

ZS6100-0900

Bauform | Seitenansicht (vertikale Richtcharakteristik) | Draufsicht (horizontale Richtcharakteristik)

ZS6100-1800

Bauform | Seitenansicht (vertikale Richtcharakteristik)
 | Draufsicht (horizontale Richtcharakteristik)

Ausrichtungsbeispiele

Richten Sie die Antennen so aus, das sich die Gegenseiten in den Strahlungskegeln der Antennen befinden.

Rundstrahler

Zwei ZS6201-0410 oder ZS6201-0500

Richtantennen

Zwei ZS6100-0900 oder ZS6100-1800

Gemischter Betrieb

z.B. eine ZS6201-0410 und zwei ZS6100-1800

Polarisation

Für eine optimale Übertragung müssen die Antennen aller verwendeten KM6551-0000 die gleiche Polarisation aufweisen.

Rundstrahler

Achten Sie auch bei der Verwendung von rundstrahlenden Antennen darauf, dass die Antennen aller verwendeten KM6551-0000 die gleiche Polarisation aufweisen.

Rundstrahler wie ZS6201-0410, ZS6201-0500 oder ZS6200-0400 werden meistens für vertikale Polarisation montiert.

Richtantennen

Die Richtantenne ZS6100-0900 trägt auf der Gehäuserückseite mit den Buchstaben H und V gekennzeichnete Pfeile um die Polarisation zu kennzeichnen (ZS6100-1800 in Vorbereitung).

Montieren Sie die Richtantennen so, dass diese gekennzeichnete Pfeile aller verwendeten Antennen korrespondieren.

Platzierung der Antennen

Montieren Sie die Antennen so, das diese frei abstrahlen können!

In direkter Umgebung der Antenne dürfen sich keine Hindernisse befinden, welche die Ausbildung der Fresnel-Zone behindern. Insbesondere Hindernisse aus Metall wie Schaltschränke, Maschinenteile, Rohrleitungen, Eisenträger usw. behindern die Ausbildung der Fresnel-Zone besonders!

Der Anschluss der Antennen an das KM6551-0000 über den RSMA-Stecker und Koaxialkabel ermöglicht eine abgesetzte Montage der Antenne, so dass Sie die Antenne optimal platzieren können.


KM6551-0000 - Dämpfung und Reichweite

BECKHOFF KM6551-0000: Montage und Verdrahtung

Dämpfung und Reichweite

Fresnel-Zone

Bei einer Funkübertragung bezeichnet man den Raum zwischen Sende- und Empfangsantenne als Fresnel-Zone. Die Fresnel-Zone ist ein gedachter Rotationsellipsoid zwischen den Antennen.

Im Bereich der Fresnel-Zone wird der Hauptteil der Energie übertragen.

Diese Zone sollte frei von Hindernissen (z.B. Gegenständen, Häuser, Bäume, usw.) sein. Insbesondere Hindernisse aus Metall wie Schaltschränke, Maschinenteile, Rohrleitungen, Eisenträger usw. behindern die Ausbildung der Fresnel-Zone besonders!

Jede Behinderung der Fresnel-Zone, dämpft die Übertragung. Ist die Fresnel-Zone z.B. zur Hälfte verdeckt, so beträgt die Zusatzdämpfung 6 dB, die Feldstärke sinkt also auf die Hälfte des Freiraumwertes. Unter Umständen ist der Empfang dann gestört oder komplett unterbrochen.

Ist die Fresnel-Zone frei von Hindernissen, wird die sich ausbreitende Funkwelle nur durch die Freiraumdämpfung gedämpft.

Radius r der Fresnel-Zone in Abhängigkeit der Entfernung s

Dämpfung in der Praxis

Bei einer Dämpfung von 6 dB verringert sich die Reichweite im Vergleich zu einer Freisicht-Verbindung auf die Hälfte, bei 12dB auf ein Viertel.

Material | Dämpfung | Reichweite ca. | Beispiel bei 280 m Freisicht-Reichweite
Dünne Wand | 2-5 dB | (Freiluft Reichweite)/1,5 ... (Freiluft Reichweite)/2 | 180 m - 140 m
Holzwand | 5 dB | (Freiluft Reichweite)/2 | 140 m
Ziegelmauer | 6-12 dB | (Freiluft Reichweite)/2 ... (Freiluft Reichweite)/4 | 140 m - 70 m
Beton Mauer | 10-20 dB | (Freiluft Reichweite)/4 ... (Freiluft Reichweite)/8 | 70 m - 5 m
Beton Decke | 20 dB | (Freiluft Reichweite)/8 | < 35 m

Reichweite bei Auswahl folgender Antennenkombination

Die Angegebenen Reichweiten beziehen sich auf die Bedingung freie Sicht und Einhaltung der Fresnel-Zone.

Zwei Rundstrahlantennen

Rundstrahlantennen kombiniert mit Richtantenne

Zwei Richtantennen


KM6551-0000 - Antennen

BECKHOFF KM6551-0000: Antennen

Antennen

Übersicht

Bezeichnung | Beschreibung
ZS6100-0900 | Richtantenne (9 dBi Gewinn), ohne Leitung
ZS6100-1800 | Richtantenne (18 dBi Gewinn), ohne Leitung
ZS6200-0400 | Rundstrahlantenne (4 dBi Gewinn), ohne Leitung
ZS6201-0410 | Stabantenne (4 dBi Gewinn), mit Leitung (1 m)
ZS6201-0500 | Stabantenne (5 dBi Gewinn), ohne Leitung

Achtung 		CE-Konformität
Die CE-Konformität des KM6551-0000 ist nur beim Betrieb mit original Beckhoff-Zubehör (Antennen, Koaxialleitung) gewährleistet!


ZS6100-0900

Technische Daten

Technische Daten | ZS6100-0900
Frequenzbereich | 2400...2485 MHz
Übertragungsfaktor | 9 dBi
3 dB Bandbreite, horizontal | 65°
3 dB Bandbreite, vertikal | 65°
Anschluss | SMA-Buchse
Abmessungen (B x H x T) | 93 mm x 93 mm x 25 mm
Gewicht (mit Zubehör und Verpackung) | ca. 190 g
zulässiger Umgebungstemperaturbereich im Betrieb | -40°C ... + 80°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE
Befestigung | Winkelmontage, im Lieferumfang enthalten
Passende Koaxialleitung | ZS6000-0102-0020, ZS6000-0102-0040


ZS6100-1800

Technische Daten

Technische Daten | ZS6100-1800
Frequenzbereich | 2400...2485 MHz
Übertragungsfaktor | 18 dBi
3 dB Bandbreite, horizontal | 20°
3 dB Bandbreite, vertikal | 20°
Anschluss | SMA-Buchse
Abmessungen (B x H x T) | 360 mm x 360 mm x 30 mm
Gewicht (mit Zubehör und Verpackung) | ca. 3640 g
zulässiger Umgebungstemperaturbereich im Betrieb | -40°C ... + 80°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE
Befestigung | Winkelmontage, im Lieferumfang enthalten
Passende Koaxialleitung | ZS6000-0102-0020, ZS6000-0102-0040


ZS6200-0400

Technische Daten

Technische Daten | ZS6200-0400
Frequenzbereich | 2400...2485 MHz
Übertragungsfaktor | 4 dBi
3 dB Bandbreite, horizontal | 360°
3 dB Bandbreite, vertikal | 70°
Anschluss | SMA-Buchse
Abmessungen | Durchmesser 110 mm, Höhe 45 mm
Gewicht (mit Zubehör und Verpackung) | ca. 210 g
zulässiger Umgebungstemperaturbereich im Betrieb | -40°C ... + 80°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Schutzart | IP20
Einbaulage | beliebig, prädestiniert für die Montage unter der Decke.
Zulassung | CE
Passende Koaxialleitung | ZS6000-0102-0020, ZS6000-0102-0040


ZS6201-0410

Technische Daten

Technische Daten | ZS6201-0410
Frequenzbereich | 2400...2485 MHz
Übertragungsfaktor | 4 dBi
3 dB Bandbreite, horizontal | 360°
3 dB Bandbreite, vertikal | 70°
Anschluss | reverse SMA-Buchse (mit 1 m Kabel, fest angeschlossen an Antenne)
Abmessungen | Höhe 202 mm, Fußdurchmesser 35 mm
Gewicht (mit Zuleitung, Zubehör und Verpackung) | ca. 220 g
zulässiger Umgebungstemperaturbereich im Betrieb | -40°C ... + 80°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Befestigung | Überwurfmutter M14
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE
Koaxialleitung | 1 m, im Lieferumfang enthalten


ZS6201-0500

Technische Daten

Technische Daten | ZS6201-0500
Frequenzbereich | 2400...2485 MHz
Übertragungsfaktor | 5 dBi
3 dB Bandbreite, horizontal | 360°
3 dB Bandbreite, vertikal | 70°
Anschluss | reverse SMA-Buchse
Abmessungen | Höhe 195 mm, Fußdurchmesser 12 mm
Gewicht (mit Verpackung) | ca. 40 g
zulässiger Umgebungstemperaturbereich im Betrieb | -40°C ... + 80°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Befestigung | direkter Anschluss mit Winkelgelenk
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE
Passende Koaxialleitung | entfällt, direkter Anschluss


KM6551-0000 - Anwendungsbeispiele - Übersicht

BECKHOFF KM6551-0000: Anwendungsbeispiele

Anwendungsbeispiele - Übersicht

  • Peer-to-Peer-Modus
  • Master-Slave-Modus
  • Broadcast-Modus
  • Energy-Scan


KM6551-0000 - Peer-to-Peer-Modus

BECKHOFF KM6551-0000: Anwendungsbeispiele

Peer-to-Peer-Modus

Anwendung

Die einfachste Art der Kommunikation zwischen zwei KM6551-0000 ist der Peer-to-Peer-Modus. Stellen Sie hierzu die DIP-Schalter

  • des Master-Moduls auf den Master-Mode und
  • des zweiten Moduls auf die Slave-Adresse 1.

Nun müssen Sie im Control-Byte CB1 beider Module das Bit 0 (Start-Bit) auf TRUE setzen. Die Module quittieren dieses Bit durch setzen des Bit 0 Ihrer Status-Bytes SB1. Der Kommunikationsaufbau und die Kommunikation beginnt dann automatisch.

Jetzt werden immer 10 Byte zwischen den Modulen ausgetauscht. Dieses läuft solange, bis ein Start-Bit auf FALSE gesetzt wird. Hierbei spielt es keine Rolle welche Seite das Start-Bit zurücksetzt.

Ist die Verbindung gestört oder auf der Gegenseite das Start-Bit nicht gesetzt so meldet das Modul im Status-Byte SB1 mit Bit 6 das ein Fehler vorliegt. Der Fehler-Code wird dazu im Status-Byte SB2 ausgegeben (siehe ErrorID).


KM6551-0000 - Master-Slave-Modus

BECKHOFF KM6551-0000: Anwendungsbeispiele

Master-Slave-Modus

Anwendung

Eine weiter Möglichkeit ist der Datenaustausch von einem Master mit bis zu 7 Slaves. Die Adresse der Slaves wird mit dem DIP-Schalter auf die entsprechende Adresse gestellt. Die Adresse darf nur einmal pro Kanal benutzt werden. Auch hier muss das Control Byte 1 CB1 as Bit 0 "Start BIT" auf TRUE gesetzt werden. Mit den Bits 3..5 wird die Slave Adresse des Zielgerätes eingestellt. Die Klemme sendet darauf hin Telegramme zu dem entsprechenden Slave. bekommt die Klemme eine Antwort so wird diese im Status angezeigt.

Beispiel: Aufgabe Sie wollen mit Slave 2 sprechen.

Setzen Sie das Bit 0 auf True um in den Datenaustausch zu gehen. Um mit Slave 2 zu reden muss dann das Bit 3 gesetzt werden. Sobald die Antwort vom Slave 2 eingetroffen ist (nach ca. 20ms) bestätigt das die Master Klemme im Status Byte in dem Sie Bit das Bit 4 Setzt. Im Status Byte wird die Adresse immer +1 gezählt (siehe Tabelle).

CB1

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reserve | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Wert | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 1

SB1

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Wert | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 1
Adresse | Control Byte Bit 3..5 |  | Status Byte Bit 3..5
Slave 1 | 0dez | 000bin | 1dez | 001bin
Slave 2 | 1dez | 001bin | 2dez | 010bin
Slave 3 | 2dez | 010bin | 3dez | 011bin
Slave 4 | 3dez | 011bin | 4dez | 100bin
Slave 5 | 4dez | 100bin | 5dez | 101bin
Slave 6 | 5dez | 101bin | 6dez | 110bin
Slave 7 | 6dez | 110bin | 7dez | 111bin

Damit können Sie die Klemmen jetzt pollen in beliebiger Schnelligkeit und in einem beliebigen Rhythmus. Achten Sie darauf, wenn Sie Daten nur sehr selten zu einem Slave schicken, dass der Watchdog in der Slave Klemmen zuschlagen kann. Die Watchdog Zeit im Slave beträgt ca. 400 ms und kann im Register R38 eingestellt werden. Der Default Wert ist 20 und muss mit 20 ms multipliziert werden.

Sollte eine Slave Klemme nicht Antworten, die Funkverbindung gestört sein oder auf der Slave Seite das Bit 0 im Control-Byte nicht gesetzt sein, setzt die Master Klemme das Bit 6 Error. Der Fehlercode ist im SB2 im High-Nibbel enthalten.

Achten Sie darauf, wenn sie einen neuen Slave ansprechen wollen das Gleichzeitig die Daten Bytes 0...9 auf den neuen Slave zu aktualisieren. Bei der Antwort des Slaves sollten Sie die Daten nur dann von dem neuen Slave übernehmen wenn im Status die neue Slave Adresse steht und das Error Bit nicht gesetzt ist.


KM6551-0000 - Broadcast-Modus

BECKHOFF KM6551-0000: Anwendungsbeispiele

Broadcast-Modus

Anwendung

Der Broadcast-Modus ermöglicht das versenden von Daten von einem Master zu einer beliebigen Anzahl von Slaves. Dabei werden Daten zu den Slaves geschickt. Die Slaves erhalten die Daten der Master bekommt aber keine Rückmeldung von den Slaves.

Für den Broadcast-Modus muss der Master auf Master Betrieb mit Hilfe der DIP-Schalter gestellt werden und es muss vor den setzen der Datenkommunikation das Register 39 auf den Broadcast-Modus gestellt werden. Beim Slave reicht die Einstellung per DIP-Schalter auf Broadcast-Slave-Modus.

Folgender Ablauf zum Einstellen des Broadcast-Master Modus bei dem Master Modul

  1. Aufheben des Schreibschutzes R31
  2. Beschreiben des R39 mit dem Broadcast-Master-Modus
  3. Auslesen des R39 das der Master-Modus auch gesetzt wurde
  4. Setzen des Start Bits im CB1
Beispiel: Aufgabe starten Sie den Datenaustausch (bei Master und Slave gleich)

Setzen Sie das Bit 0 auf TRUE um in den Datenaustausch zu gehen.

CB1

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reserve | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Wert | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1

SB1

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Wert | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1


KM6551-0000 - Energie Scan

BECKHOFF KM6551-0000: Anwendungsbeispiele

Energy-Scan

Anwendung

Der Energy- Scan ermöglicht das abhören der 16 IEEE 802.15.4 Kanäle um andere Funksysteme zu detektieren. Es wird die Energie in einem Frequenzband bestimmt und angezeigt. Jeder Kanal wird ca. 5 sec gemessen und dann wir zum nächsten Kanal gesprungen. Man muss darauf achten das in den 5 Sec eventuell ein Kanal grade keine Kommunikation macht. Daher macht es Sinn das Scannen der Kanäle ein paar mal zu wiederholen um eine bessere Aussage zu treffen ob ein Kanal belegt ist oder nicht. Die Energie wird von 0...0xF angezeigt, wobei "0" keine Energie bedeutet und "0xF" oder 16dez viel Energie entspricht.

Setzen Sie im CB1 das Bit 1 auf TRUE. Das KM6551-0000 bestätigt das im Status mit Bit 1 was dann auch auf TRUE gesetzt wird. Der Scan ist fertig wenn das SB1 Bit 1 auf FALSE fällt. Das Ergebnis steht dann in den Eingangsdaten Byte 0 bis 7. Jeder Kanal entspricht dann einem Nibble, also einem halbes Byte.

Beispiel

Byte-Nummer | Beschreibung | Wert (hex) | Bedeutung
1 | SB1 | - | Status Byte 1
2 | SB2 | - | Status Byte 2
3 | Data IN[0] | 0x3F | 3 - Kanal 1 wenig Energie, F - Kanal 2 sehr viel Energie
4 | Data IN[1] | 0x01 | 0 - Kanal 3 keine Energie, 1 - Kanal 4 sehr wenig Energie
5 | Data IN[2] | 0x7F | 7 - Kanal 5 mittel mäßig Energie, F - Kanal 5 sehr viel Energie
6...9 | ... | ... | ... (wird der einfacher halber nicht berücksichtigt in diesem Beispiel)
10 | Data IN[8] | 0x10 | 1 - Kanal 15 wenig Energie, 0 - Kanal 16 - keine Energie
11...12 | Data IN[8...9] | - | wird nicht benötigt

Das Ergebnis ist wie folgt zu interpretieren. Die Kanäle 2 und 5 sind auf jeden Fall zu meiden, sehr gut sieht es bei den Kanälen 3 und 16 aus. Hier konnte keine Energie gemessen werden. Beachten Sie das es sich hier um einen Augenblickswert handelt. Kanäle mit viel Energie können sie für ihrer weitere suche nach freien Kanälen ausschließen, aber Kanäle mit keiner oder nur mäßiger Energie Ermittlung können unter umständen zu einem anderen Zeitpunkt zu ganz anderen Ergebnissen führen.

Beispiel: Aktivieren des Energy-Scan

Setzen Sie das Bit 1 auf TRUE um in den Datenaustausch zu gehen.

CB1

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reserve | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Wert | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 0

Die Klemme setzt im Status Byte SB1 das Bit 1 auf TRUE solange der Scan aktiv ist.

SB1

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Wert | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 0

Ist der Scan abgeschlossen setzt die Klemme im Status Byte SB1 das Bit 1 auf FALSE. Nun können sie die Eingangsdatenbytes 0..7 auswerten (Byte 8-9 haben keine Bedeutung und sollten nicht ausgewertet werden).

Der Scan dauert ca. 80 Sekunden.

SB1

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Wert | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0


TwinCAT

SPS und Motion Control auf dem PC

TwinCAT - The Windows Control and Automation Technology

Die Automatisierungs-Software TwinCAT verwandelt jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS, NC-Achsregelung, Programmierumgebung und Bedienstation. TwinCAT substituiert herkömmliche SPS- und NC/CNC-Steuerungen sowie Bediengeräte:

  • offene, kompatible PC-Hardware
  • Einbettung von IEC 61131-3-Software-SPS, Software-NC und Software-CNC in Windows NT/2000/XP, NT/XP Embedded, CE
  • Programmiersystem und Laufzeit wahlweise auf einem PC oder getrennt
  • Anbindung an alle gängigen Feldbuss-Systeme
  • PC-Schnittstellen werden unterstützt
  • Datenanbindung an Bedienoberflächen und andere Programme mittels offener Standards (OPC, OCX, DLL etc.)

TwinCAT-Architektur

TwinCAT besteht aus Laufzeitsystemen zur Echtzeitausführung von Steuerungsprogrammen und den Entwicklungsumgebungen zur Programmierung, Diagnose und Konfiguration. Alle Windows-Programme, beispielsweise Visualisierungen oder Office-Produkte, können über Microsoft-Schnittstellen auf TwinCAT-Daten zugreifen oder Kommandos ausführen.

Praxisorientierte Softwarelösung

TwinCAT bietet eine genaue Zeitbasis, die mit höchster Deterministik Programme unabhängig von anderen Prozessoraufgaben ausführt. Die Echtzeitlast auf einem PC wird mit TwinCAT eingestellt: Auf diese Weise wird ein definiertes Betriebsverhalten erreicht. TwinCAT zeigt die Systemlast für laufende Programme an. Eine Lastgrenze kann eingestellt werden, um für die Bedienprogramme und Windows NT/2000/XP eine definierte Rechenkapazität zur Verfügung zu stellen. Bei Überschreiten dieser Grenze wird eine Systemmeldung generiert.

TwinCAT unterstützt die Systemdiagnose

Die freie Verwendung von Hardware oder Software aus der offenen PC-Welt erfordert ihre Prüfung: Ungeeignete Komponenten können das PC-System außer Tritt bringen. Beckhoff integriert eine praktische Anzeige des Jitters der Echtzeit, um einem Administrator ein einfaches Mittel zur Evaluierung von Hardware und Software an die Hand zu geben. Im Betrieb kann eine Systemmeldung auf Fehlerzustände aufmerksam machen.

Start-/Stoppverhalten

TwinCAT startet und stoppt, je nach Einstellung, durch manuellen Eingriff oder automatisch. Da TwinCAT als Service in Windows NT/2000/XP integriert ist, wird zum Systemstart kein Bediener benötigt: Strom einschalten genügt.

Wiederanlauf und Datensicherung

TwinCAT lädt beim Start oder Wiederanlauf Programme und remanente Daten. Zur Datensicherung und zum korrekten Beenden von Windows NT/2000/XP empfiehlt sich eine USV (unterbrechungsfreie Stromversorgung).

TwinCAT und „Blue Screen“

Das TwinCAT-System kann so konfiguriert werden, dass die Echtzeit im Falle eines Betriebssystemabsturzes BSOD (Blue-Screen-of-Death) funktionell erhalten bleibt. Echtzeittasks, wie z. B. die SPS und NC, können somit weiterlaufen und den gesteuerten Prozess in einen sicheren Zustand bringen. Letztlich liegt es in der Entscheidung des Programmierers, diese Eigenschaft zu nutzen in Anbetracht dessen, dass Daten oder Programme durch den BSOD bereits zerstört sein können.

Weltweite Verbindung per Message-Routing – Remote-Verbindung ist systemimmanent

Die Softwaregeräte von TwinCAT können, je nach Anforderung, auf Betriebsmittel verteilt werden: TwinCAT-SPS-Programme können auf PCs und auf Beckhoff Busklemmen Controllern ablaufen. Ein „Message-Router“ verwaltet und verteilt alle Nachrichten im System und über TCP/IP-Verbindungen. PC-Systeme können per TCP/IP miteinander verbunden werden; Busklemmen Controller werden über serielle Schnittstellen und über Feldbuss-Systeme (EtherCAT, Lightbus, PROFIBUS DP, PROFINET, Interbus, CANopen, DeviceNet, RS232, RS485, Ethernet TCP/IP, Ethernet/IP) angebunden.

Weltweiter Zugriff

Da Standard-TCP/IP-Dienste von Windows NT/2000/XP genutzt werden, kann dieser Datenaustausch weltweit erfolgen. Das System bietet skalierbare Kommunikationsleistung und Time-out-Zeiten zur Überwachung von Kommunikationen. Mittels OPC kann auf einem standardisierten Weg auf viele unterschiedliche SCADA-Pakete zugegriffen werden. Mit dem SOAP (Simple-Object-Access-Protocol) kann über eine Internetverbindung via Standard-HTTP eine Verbindung zwischen zwei Rechnern hergestellt werden. Auch hierzu bietet TwinCAT eine Komponente an.

Beckhoff-Information-System

Weitere Informationen über die Automatisierungs-Software TwinCAT finden Sie im Beckhoff-Information-System.

Das Setup zur Installation des Beckhoff-Information-Systems steht Ihnen auf der Beckhoff-DVD Products & Solutions und auf unseren Internetseiten zum download zur Verfügung.

Außerdem finden Sie unter http://infosys.beckhoff.com die Online-Version des Beckhoff-Information-System.


KM6551-0000 - TwinCAT-Bibliotheken

BECKHOFF KM6551-0000: Programmierung

TwinCAT-Bibliotheken

Zum Betrieb der KM6551-0000 unter TwinCAT steht für alle Beckhoff-Steuerungsfamilien (BC, BX, CX und IPC) eine TwinCAT-Bibliothek zur Verfügung. Diese Bibliothek übernimmt die Kommunikation mit der Klemme. Sie setzt Parameter bzw. liest Parameter aus der Klemme raus. Für den Anwender vereinfacht die Verwendung der Bibliothek die Kommunikation mit der Klemme.

ZIP-Datei TC_KM6551.zip:

Kopieren Sie die Bibliotheken in das Verzeichnis TwinCAT\PLC\Lib.

Weitere Notwendige Bibliotheken:

Für Busklemmen-Controller der Serie BCxx00

  • Standard.lb6
  • PlcHelper.lb6

Für Busklemmen-Controller der Serien BCxx20 und BCxx50

  • Standard.lbx
  • TcBaseBCxx50.lbx
  • TcSystemBCxx50.lbx

Für Busklemmen-Controller der Serie BXxxxx

  • Standard.lbx
  • TcBaseBX.lbx
  • TcSystemBX.lbx

Für 386er Systeme wie Industrie PCs, Embedded PCs (CX)

  • Standard.lib
  • TcBase.lib
  • TcSystem.lib

Zum Betrieb der KM6551-0000 unter anderen Steuerungen kann sich der Anwender eigene Funktionsbausteine schreiben.


KM6551-0000 - TwinCAT-Beispiele

BECKHOFF KM6551-0000: Programmierung

TwinCAT-Beispiele

Für die Beispiel brauchen Sie einen CX9000 mit K-Bus, einen BC9050, zwei KM6551-0000 , zwei KL9010 Endklemme und eine KL2xx4 (optional).

Beispiel Master/Slave-Kommunikation [image] (ZIP Datei rechte Maustaste Speicher unter...)

Am CX9000 ist ein KM6551-0000 als Master-Modul gesteckt und optional die Busklemme KL2xx4. Am BC9050 ist ein KM6551-0000 als Slave-Modul gesteckt.

Beispiel Broadcast-Kommunikation [image] (ZIP Datei rechte Maustaste Speicher unter...)

Am CX9000 ist ein KM6551-0000 als Master-Modul gesteckt und optional die Busklemme KL2xx4. Am BC9050 ist ein KM6551-0000 als Broadcast-Slave-Modul gesteckt.

Beispiel Energie Scan [image] (rechte Maustaste Speicher unter...)

Es sind ein BX9000, ein KL6551-0000 und eine KL9010 erforderlich.


KM6551-0000 - Funktionsbaustein FB_KM6551_MAIN

BECKHOFF KM6551-0000: Funktionsbausteine

Funktionsbaustein FB_KM6551_MAIN

Dieser Funktionsbaustein übernimmt die Kommunikation zum KM6651-0000 und übernimmt und setzt per Registerkommunikation Einstellungen im Modul. Es ist pro KM6551-0000 immer nur ein FB_KM6551_MAIN Baustein zulässig.

VAR_INPUT

bActivate            :BOOL;
bBroadcast           :BOOL;
iChannel_Set         :INT;
uiSlaveTM
:UINT;
KM6551_IN
:ARRAY[1..12] of BYTE;
KM6551_OUT
:ARRAY[1..12] of BYTE;

Legende

bActivate: Positive Flanke aktiviert den Baustein und schreibt Parameter zum KM6551-0000.
bBroadcast: nur im Master Mode aktivierbar. TRUE - stellt das KM6651-0000 auf den Broadcast Master Mode um (siehe Register 39).
iChannel_Set: Hier wird der IEEE 802.15.4 Kanal eingestellt. Erlaubte Werte 0..15 (siehe Register 32/33).
uiSlaveTM: nur im Slave Mode nutzbar, Einstellung des Watchdogs für den Slave Mode (siehe Register 38).
KM6551_IN: Wird mit den INPUT-Daten des KM6551-0000 verbunden.
KM6551_OUT: Wird mit den OUTPUT-Daten des KM6551-0000 verbunden.

VAR_OUTPUT

bActive :BOOL;
bError :BOOL;
iErrorID :E_KM6551_ERRORID;
bBusy :BOOL;
strLinkData :KM6551_Data;

Legende

b Active: Der Baustein hat die Parameter erfolgreich zum KM6551-0000 übertragen und kann jetzt mit den anderen KM6551-0000-Bausteinen die Datenkommunikation beginnen.
b Error: Der Baustein hat einen Fehler.
iErrorID: Enthält den Fehler-Code.
bBusy: Solange bBusy gesetzt ist, also TRUE ist, ist der Baustein noch am Arbeiten, warten Sie bis bBusy auf FALSE wechselt.
strLinkData: Daten, die die überlagerten Funktionsbausteine benötigen. Verbinden Sie diese Daten mit den weiteren Funktionsbausteinen die sie Aufrufen.


KM6551-0000 - Funktionsbaustein FB_KM6551_MASTER_10BYTE

BECKHOFF KM6551-0000: Funktionsbausteine

Funktionsbaustein FB_KM6551_MASTER_10BYTE

Dieser Funktionsbaustein übernimmt die Kommunikation zu den einzelnen Slaves. Es darf nur ein Baustein pro Slave aufgerufen werden. Es sind maximal 7 Slaves erlaubt, daher dürfen maximal 7 Bausteinen dieses Typs pro Master Klemme aufgerufen werden. Eine positive Flanke von bStart aktiviert die Kommunikation zu dem Slave der in der Variable iSlaveAddr hinterlegt ist. Das bBusy geht auf TRUE solange der Baustein aktive ist. Ist das bBusy wieder FALSE ist der Baustein fertig. Sollte bError FALSE sein ist die Kommunikation erfolgreich gewesen und die Input Daten sind gültig. Ist das bError Bit TRUE liegt ein Fehler vor. Eine genauere Fehlerursache kann man in iErrorID auslesen. ptData_IN ist eine Pointeradresse für die Eingangsdaten (ADR Befehl zur Ermittlung der Pointeradresse) und iLenData_IN die Länge der Daten. Die Länge kann man mit SIZEOF bestimmen und darf nicht größer als 10 Byte sein. Das Gleiche gilt auch für die Output Daten. Die Variable strLinkData wird mit dem Baustein FB_KM6551_MAIN verbunden (die Variable heiß genauso). Bevor der Baustein FB_KM6551_MASTER_10BYTE aufgerufen wird sollte der FB_KM6551_MAIN fertig sein (siehe bActive in diesem Baustein).

VAR_INPUT

bStart :BOOL;
iSlaveAddr :INT;
strLinkData :KM6551_Data;
ptData_IN :DWORD;
iLenData_IN :INT;
ptData_OUT :DWORD;
iLenData_OUT :INT;

Legende

bStart: Positive Flanke aktiviert den Baustein.
iSlaveAddr: Hier wird die Slave Adresse des Slaves eingetragen (siehe DIP Schalter auf Ihrem Slave Modul)
strLinkData: Wird mit strLinkData vom FB_KM6551_MAIN verbunden.
ptData_IN: Pointer auf die Variable, in die die Daten des Teilnehmers kopiert werden sollen (Pointer Adresse wird mit ADR(Variablen_Name) ermittelt).
iLenData_IN: Länge der Variable (ermitteln kann man die Länge mit SIZEOF(Variablen_Name))
ptData_OUT: Pointer auf die Variable, in die die Master Klemme zum Slave übertagen soll (Pointer Adresse wird mit ADR(Variablen_Name) ermittelt).
iLenData_OUT: Länge der Variable (ermitteln kann man die Länge mit SIZEOF(Variablen_Name))

VAR_OUTPUT

bError :BOOL;
bBusy :BOOL;
iErrorID :E_KM6551_ERRORID;
iSignalQuality :INT;
E_Addr :E_KM6551_DIP;

Legende

b Error: Der Baustein hat einen Fehler.
bBusy: Solange bBusy gesetzt ist, also TRUE ist, ist der Baustein noch am Arbeiten, warten Sie bis bBusy auf FALSE wechselt.
iErrorID: Enthält den Fehler-Code.
iSignalQuality: LQI Wert, Güte des empfangenden Signals, 100 sehr gute Übertragung 0 sehr schlechte Übertragung - der LQI Wert sollte möglichst hoch sein und minimal eine Wert von 10-20 haben. Sie können den LQI Wert durch bessere Antennen oder kürzere Kabel oder bessere Ausrichtung der Antennen verbessern.
E_Addr: Ließt die DIP Schalterstellung des Moduls KM6551-0000 aus und zeigt diese an.


KM6551-0000 - Funktionsbaustein FB_KM6551_SLAVE_10BYTE

BECKHOFF KM6551-0000: Funktionsbausteine

Funktionsbaustein FB_KM6551_SLAVE_10BYTE

Dieser Funktionsbaustein übernimmt die Kommunikation zum Slave Modul. Es darf nur ein Baustein pro Slave aufgerufen werden. Eine positive Flanke von bStart aktiviert die Kommunikation zu dem Slave. Sollte bError FALSE sein ist die Kommunikation erfolgreich gewesen und die Input Daten sind gültig. Ist das bError Bit TRUE liegt ein Fehler vor. Eine genauere Fehlerursache kann man in iErrorID auslesen. ptData_IN ist eine Pointeradresse für die Eingangsdaten (ADR Befehl zur Ermittlung der Pointeradresse) und iLenData_IN die Länge der Daten. Die Länge kann man mit SIZEOF bestimmen und darf nicht größer als 10 Byte sein. Das Gleiche gilt auch für die Output Daten. Die Variable strLinkData wird mit dem Baustein FB_KM6551_MAIN verbunden (die Variable heißt genauso). Bevor der Baustein FB_KM6551_SLAVE_10BYTE aufgerufen wird sollte der FB_KM6551_MAIN fertig sein (siehe bActive in diesem Baustein).

VAR_INPUT

bStart :BOOL;
strLinkData :KM6551_Data;
ptData_IN :DWORD;
iLenData_IN :INT;
ptData_OUT :DWORD;
iLenData_OUT :INT;

Legende

bStart: Positive Flanke aktiviert den Baustein.
strLinkData: Wird mit strLinkData vom FB_KM6551_MAIN verbunden.
ptData_IN: Pointer auf die Variable, in die die Daten des Teilnehmers kopiert werden sollen (Pointer Adresse wird mit ADR(Variablen_Name) ermittelt).
iLenData_IN: Länge der Variable (ermitteln kann man die Länge mit SIZEOF(Variablen_Name))
ptData_OUT: Pointer auf die Variable, in die die Master Klemme zum Slave übertagen soll (Pointer Adresse wird mit ADR(Variablen_Name) ermittelt).
iLenData_OUT: Länge der Variable (ermitteln kann man die Länge mit SIZEOF(Variablen_Name))

VAR_OUTPUT

bError :BOOL;
bBusy :BOOL;
iErrorID :E_KM6551_ERRORID;
iSignalQuality :INT;
E_Addr :E_KM6551_DIP;

Legende

b Error: Der Baustein hat einen Fehler.
bBusy: Solange bBusy gesetzt ist, also TRUE ist, ist der Baustein noch am Arbeiten, warten Sie bis bBusy auf FALSE wechselt.
iErrorID: Enthält den Fehler-Code.
iSignalQuality: LQI Wert, Güte des empfangenden Signals, 100 sehr gute Übertragung 0 sehr schlechte Übertragung - der LQI Wert sollte möglichst hoch sein und minimal eine Wert von 10-20 haben. Sie können den LQI Wert durch bessere Antennen oder kürzere Kabel oder bessere Ausrichtung der Antennen verbessern.
E_Addr: Ließt die DIP Schalterstellung des Moduls KM6651-0000 aus und zeigt diese an.


KM6551-0000 - Funktionsbaustein FB_KM6551_MASTERBROADCAST_10BYTE

BECKHOFF KM6551-0000: Funktionsbausteine

Funktionsbaustein FB_KM6551_MASTERBROADCAST_10BYTE

Dieser Funktionsbaustein übernimmt die Kommunikation zu den einzelnen Slaves im Broadcast-Modus. Mit der Zeit tPolling kann man die Anzahl der Datentelegramme reduzieren. Es werden dann immer nur Daten in der Zeit tPolling gesendet. Achten sie darauf das sie bei einer hohen tPolling-Zeit bei den Broadcast-Slaves auch eine höhere Watchdog-Zeit eintragen, da sonst der Slave einen Watchdog-Fehler anzeigt. Eine positive Flanke von bStart aktiviert die Kommunikation. Ist das bError Bit TRUE liegt ein Fehler vor. Eine genauere Fehlerursache kann man in iErrorID auslesen. ptData_OUT ist eine Pointeradresse für die Eingangsdaten (ADR Befehl zur Ermittlung der Pointeradresse) und iLenData_OUT die Länge der Daten. Die Länge kann man mit SIZEOF bestimmen und darf nicht größer als 10 Byte sein. Die Variable strLinkData wird mit dem Baustein FB_KM6551_MAIN verbunden (die Variable heißt genauso). Bevor der Baustein FB_KM6551_MASTER_10BYTE aufgerufen wird sollte der FB_KM6551_MAIN fertig sein (siehe bActive in diesem Baustein).

VAR_INPUT

bStart :BOOL;
iSlaveAddr :INT;
strLinkData :KM6551_Data;
ptData_OUT :DWORD;
iLenData_OUT :INT;
tPolling :TIME;

Legende

bStart: Positive Flanke aktiviert den Baustein.
iSlaveAddr: Hier wird die Slave Adresse des Slaves eingetragen (siehe DIP-Schalter auf Ihrem Slave-Modul)
strLinkData: Wird mit strLinkData vom FB_KM6551_MAIN verbunden.
ptData_OUT: Pointer auf die Variable, in die die Master Klemme zum Slave übertragen soll (Pointer Adresse wird mit ADR(Variablen_Name) ermittelt).
iLenData_OUT: Länge der Variable (ermitteln kann man die Länge mit SIZEOF(Variablen_Name))
tPolling: Zeitzyklus in dem die Daten zu den Slaves geschickt werden sollen.

VAR_OUTPUT

bError :BOOL;
bActive :BOOL;
iErrorID :E_KM6551_ERRORID;
E_Addr :E_KM6551_DIP;

Legende

b Error: Der Baustein hat einen Fehler.
b Active: Zeigt an ob der Baustein arbeitet.
iErrorID: Enthält den Fehler-Code.
E_Addr: Liest die DIP-Schalterstellung des KM6551-0000 aus und zeigt diese an.


KM6551-0000 - FB_KM6551_SLAVEBROADCAST_10BYTE

BECKHOFF KM6551-0000: Funktionsbausteine

Funktionsbaustein FB_KM6551_SLAVEBROADCAST_10BYTE

Dieser Funktionsbaustein übernimmt die Kommunikation zum Broadcast Slave Modul. Es darf nur ein Baustein pro Slave aufgerufen werden. Eine positive Flanke von bStart aktiviert die Kommunikation zu dem Slave. Sollte bError FALSE sein ist die Kommunikation erfolgreich gewesen und die Input Daten sind gültig. Ist das bError Bit TRUE liegt ein Fehler vor. Eine genauere Fehlerursache kann man in iErrorID auslesen. ptData_IN ist eine Pointeradresse für die Eingangsdaten (ADR Befehl zur Ermittlung der Pointeradresse) und iLenData_IN die Länge der Daten. Die Länge kann man mit SIZEOF bestimmen und darf nicht größer als 10 Byte sein. Das Gleiche gilt auch für die Output Daten. Die Variable strLinkData wird mit dem Baustein FB_KM6551_MAIN verbunden (die Variable heißt genauso). Bevor der Baustein FB_KM6551_MASTER_10BYTE aufgerufen wird sollte der FB_KM6551_MAIN fertig sein (siehe bActive in diesem Baustein).

VAR_INPUT

bStart :BOOL;
strLinkData :KM6551_Data;
ptData_IN :DWORD;
iLenData_IN :INT;

Legende

bStart: Positive Flanke aktiviert den Baustein.
strLinkData: Wird mit strLinkData vom FB_KM6551_MAIN verbunden.
ptData_IN: Pointer auf die Variable, in die die Daten des Teilnehmers kopiert werden sollen (Pointer Adresse wird mit ADR(Variablen_Name) ermittelt)).
iLenData_IN: Länge der Variable (ermitteln kann man die Länge mit SIZEOF(Variablen_Name))

VAR_OUTPUT

bError :BOOL;
bActive :BOOL;
iErrorID :E_KM6551_ERRORID;
iSignalQuality :INT;
E_Addr :E_KM6551_DIP;

Legende

b Error: Der Baustein hat einen Fehler.
b Active: Zeigt an ob der Baustein arbeitet.
iErrorID: Enthält den Fehler-Code.
iSignalQuality: LQI Wert, Güte des empfangenden Signals, 100 sehr gute Übertragung 0 sehr schlechte Übertragung - der LQI Wert sollte möglichst hoch sein und minimal eine Wert von 10-20 haben. Sie können den LQI Wert durch bessere Antennen oder kürzere Kabel oder bessere Ausrichtung der Antennen verbessern.
E_Addr: Ließt die DIP Schalterstellung des Moduls KM6651-0000 aus und zeigt diese an.


Konfigurations-Software KS2000

Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler/Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.

Projektierung

Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, d. h. vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.

Parametrierung

KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.

Inbetriebnahme

KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.

KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:

  • Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
  • Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.

Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


KM6551-0000 - Parametrierung mit KS2000

BECKHOFF KM6551-0000: Konfigurationssoftware KS2000

Parametrierung mit KS2000

Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.

Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
  • ein Buskoppler für Ethernet BK9000
  • eine Eingangsklemme KL1002
  • eine Datenaustauschklemme KM6551-0000
  • eine Bus-Endklemme KL9010

Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.

Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor dem Modul, dessen Parameter sie verändern möchten (Im Beispiel Position 2).

Für das KM6551-0000 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:

  • Register erlaubt den direkten Zugriff auf die Register des KM6551-0000.
  • Unter Einstellungen finden Sie Dialogmasken zur Parametrierung des KM6551-0000.
  • Prozessdaten zeigt die Prozessdaten des KM6551-0000.


KM6551 - KS2000-Einstellungen

BECKHOFF KM6551: Konfigurations-Software KS2000

Einstellungen

Dialogmaske zur Parametrierung der KM6551.

Einstellungen

Funkkanal für KM6551 (R33)

Hier können Sie den Funkkanal festlegen. (Default: 5, zulässige Werte: 0 bis 15).

Scan-Einstellungen

Gefundene Slaves

Zeigt die Anzahl der gefundenen Slaves an (R40).

Slaves (R40)

Zeigt die Slave-Nummern der gefundenen Slaves an.


KM6551-0000 - KS2000 - Register

BECKHOFF KM6551-0000: Konfigurations-Software KS2000

Register

Unter Register können Sie direkt auf die Register des Klemmenmoduls KM6551-0000 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.


KS2000 - Prozessdaten

BECKHOFF Feldbuskomponenten: Konfigurations-Software KS2000

Prozessdaten

Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.

Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.

Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.

Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.

VORSICHT 		Gefahr für Personen, Umwelt oder Geräte!
Beachten Sie, das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann.
Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, das Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!

Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.


KM6551-0000 - Prozessabbild

BECKHOFF KM6551-0000: Zugriff aus dem Anwenderprogramm

Prozessabbild

Das Klemmenmodul KM6551-0000 stellt sich im Prozessabbild mit maximal 12 Byte Ein- und 12 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:

Format | Eingangsdaten | Ausgangsdaten
Byte | SB1 | CB1
Byte | SB2 | CB2
Array of Byte (0...9) | DataIN | DataOUT
Legende

SBn: Status-Byte n
CBn: Control-Byte n

DataIN: Array von 10 Eingangs-Bytes (0...9)
DataOUT: Array von 10 Eingangs-Bytes (0...9)

Die Bedeutung der Control- und Status-Bytes entnehmen Sie bitte der Seite Control- und Status-Bytes.

Im Prozessdatenbetrieb werden die Eingangsdaten im Array DataIN und die Ausgangsdaten im Array DataOUT übertragen.

Hinweis 		Verwendung der Daten-Arrays
Eingangsdaten- und das Ausgangsdaten-Array können frei verwenden um beliebige Daten zu übertragen. Sie können
  • damit z.B. die Prozessdaten von analogen Ein- oder Ausgangskanälen übertragen.
  • die 10 Byte aber auch Nutzen um unter Verwendung eines selbstdefinierten Protokolls (z.B. 2 Byte Header, 8 Byte Nutzdaten) in mehreren Zyklen größere Datenmengen zu übertragen.


KM6551-0000 - Control- und Status-Bytes

BECKHOFF KM6551-0000: Zugriff aus dem Anwenderprogramm

Control- und Status-Bytes

Prozessdatenbetrieb

Control-Bytes (bei Prozessdatenbetrieb)

Die Control-Bytes befinden sich im Ausgangsabbild und werden von der Steuerung zum Klemmenmodul übertragen.

CB1: Low Byte

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | Address |  |  | Scan | EnergyScan | Start

CB2: High Byte

Bit | CB2.7 | CB2.6 | CB2.5 | CB2.4 | CB2.3 | CB2.2 | CB2.1 | CB2.0
Name | - | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
CB2.0 bis CB2.7 | Reserve | 0bin | reserviert
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 | Reserve | 0bin | reserviert
CB1.3 bis CB1.5 | Address | 0..7dez | Im Master Mode, mit welchem Teilnehmer die Verbindung läuft 0 - Slave 1 1 - Slave 2 ... 6 - Slave 7
CB1.2 | Scan | 1bin | Aktiviert das Scannen der angeschlossenen Slaves (nur im Master Mode möglich). Die gescannten Slaves finden Sie in Register R38.
CB1.1 | EnergyScan | 1bin | Aktiviert die Energie Messung für die 16 Kanäle des 2,4 GHz Bandes. EnergyScan darf nicht im Datenaustausch oder im Scan-Mode aktiviert werden.
CB1.0 | Start | 1bin | Aktiviert die Kommunikation

Status-Bytes (bei Prozessdatenbetrieb)

Die Status-Bytes befinden sich im Eingangsabbild und werden vom Klemmenmodul zur Steuerung übertragen.

SB1: Low Byte:

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Address |  |  | Scan | EnergyScan | Start

SB2: High Byte:

Bit | SB2.7 | SB2.6 | SB2.5 | SB2.4 | SB2.3 | SB2.2 | SB2.1 | SB2.0
Name | ErrorID |  |  |  | LQI
Legende
Bit | Name | Beschreibung
SB2.7 bis SB2.4 | ErrorID | 0..Fhex | Fehlermeldung 1 - ungültige oder nicht erlaubte DIP Schalter Stellung 2 - Watchdog Fehler 3..F unbenutzt
SB2.3 bis SB2.0 | LQI | 0..Fhex | Güte des Funksignals
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 | Error | 1bin | ein interner Fehler ist aufgetreten (aktuelle Prozessdaten sind nicht mehr gültig)
SB1.5 bis SB1.3 | Address | 1..7dez | Slave-Adresse 1: Slave 1 2: Slave 2 ... 7: Slave 7
SB1.2 | Scan | 1bin |
SB1.1 | EnergyScan | 1bin | TRUE das Energie-Scannen ist aktive, wird wieder auf FALSE gesetzt wenn die Klemme fertig ist.
SB1.0 | Start | 1bin |

Registerkommunikation

Control-Byte 2 und Status-Byte 2 haben bei Register-Kommunikation keine Funktion.

Control-Byte 1 (bei Registerkommunikation)

Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zum Klemmenmodul übertragen.

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIn lesen oder - mit dem Ausgangsdatenwort DataOut beschreiben wollen.

Status-Byte 1 (bei Registerkommunikation)

Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird vom Klemmenmodul zur Steuerung übertragen.

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.


KM6551-0000 - Registerübersicht

BECKHOFF KM6551-0000: Zugriff aus dem Anwenderprogramm

Registerübersicht

Die Register dienen zur Parametrierung der Klemmenmodule. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.

Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | reserviert | 0x0000 | 0dez | - | -
... | ... | ... | ... | ... | ...
R7 | reserviert | 0x0000 | 0dez | - | -
R8 | Klemmentyp | 0x1997 | 6551dez | R | ROM
R9 | Firmware-Stand | z.B. 0x3144 | z.B. 1DASCI | R | ROM
R10 | Multiplex-Schieberegister | 0x0118 | 280dez | R | ROM
R11 | Signalkanäle | 0x0218 | 280dez | R | ROM
R12 | minimale Datenlänge eines Kanals | 0x0098 | 152dez | R | ROM
R13 | Datenstruktur | 0x0000 | 0dez | R | ROM
R14 | reserviert | 0x0000 | 0dez | - | -
R15 | Alignment-Register | typisch 0x7F80 | typisch 32640dez | R/W | RAM
R16 | DIP-Schalter Stellung | z.B. 0x0000 | z.B. 0dez | R | RAM
R17 | interne Verwendung | typisch 0x0000 | typisch 0dez | R | EEPROM
R18 | reserviert | 0x0000 | 0dez | R | EEPROM
R19 | reserviert | 0x0000 | 0dez | R | EEPROM
R20 | reserviert für interne Verwendung | 0x0001 | 1dez | R | EEPROM
R21 | reserviert für interne Verwendung | 0x0500 | 1280dez | R | EEPROM
R22 | reserviert für interne Verwendung | 0x0000 | 0dez | R | EEPROM
R23 | reserviert für interne Verwendung | 0x00FF | 255dez | R | EEPROM
R24 | reserviert | 0x0000 | 0dez | - | -
... | ... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | 0dez | - | -
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | EEPROM
R32 | IEEE 802.15.4 Kanal | 0x0005 | 5dez | R/W | EEPROM
R33 | Kontrollregister für R32 | 0x0000 | 0dez | R | RAM
R34 | reserviert | 0x0000 | 0dez | R/W | EEPROM
R35 | reserviert | 0x0000 | 0dez | R/W | EEPROM
R36 | reserviert | 0x0000 | 0dez | R/W | EEPROM
R37 | reserviert | 0x0000 | 0dez | R/W | EEPROM
R38 | Watchdog für den Slave-Modus | 0x0014 | 20dez | R/W | EEPROM
R39 | Broadcast-Modus | 0x0000 | 0dez | R/W | EEPROM
R40 | Scan Register | - | - | R | RAM
R41 | Netzwerk-ID | 0x0000 | 0dez | R/W | RAM
R42 | Wrong Channel (intern) | - | - | R | EEPROM
R43 | reserviert | 0x0000 | 0dez | R | EEPROM
R44 | Reset-Counter (intern) | - | - | R | EEPROM
R45 | reserviert | 0x0000 | 0dez | R | EEPROM
R46 | Dämpfung der Sendeleistung | 0x0000 | 0dez | R/W | EEPROM
R47 | reserviert | 0x0000 | 0dez | R | EEPROM
... | ... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | 0dez | R | EEPROM


KM6551-0000 - Registerbeschreibung

BECKHOFF KM6551-0000: Zugriff aus dem Anwenderprogramm

Registerbeschreibung

Die Register dienen zur Parametrierung der Klemmenmodule. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.

R8: Modulbezeichnung

Im Register R8 steht die Bezeichnung des Klemmenmoduls.
KM6551-0000: 0x1997 (6551dez)

R9: Firmware-Stand

Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z.B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.

R12: Minimale Datenlänge eines Kanals

Bit 0 bis 6 des höherwertigen Bytes geben die minimale Anzahl der Ausgangsdaten in Bit an: 000.0000bin = 0dez so 0 Byte.

Bit 0 bis 6 des niederwertigen Bytes geben die minimale Anzahl der Eingangsdaten in Bit an: 001.1000bin = 24dez so 3 Byte.
Das Bit 7 gesetzt ist zeigt, das Control- und Status-Byte für die Funktion der Klemme nicht zwingend erforderlich sind und im kompakten Modus nicht übertragen werden.

R16: DIP-Schalter-Stellung

Im Register R16 ist die Stellung des DIP-Schalters hinterlegt.

Wert (hex) | String (ASCII) | Betriebs-Modus
0x414D | MA | Master
0x4253 | SB | Slave für Broadcast-Empfang
0x3153 | S1 | Slave mit Adresse 1
0x3253 | S2 | Slave mit Adresse 2
0x3353 | S3 | Slave mit Adresse 3
0x3453 | S4 | Slave mit Adresse 4
0x3553 | S5 | Slave mit Adresse 5
0x3653 | S6 | Slave mit Adresse 6
0x3753 | S7 | Slave mit Adresse 7
0xFFFF | - | Unknown DIP-Switch

R31: Kodewort-Register

  • Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
  • Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.

Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.

R32: Kanal-Register (read/write)

Die IEEE 802.15.4 erlaubt es, einen von 16 verfügbaren Kanäle zu nutzen. Diese Frequenzbereiche arbeiten ohne sich zu beeinflussen. Die Bandbreite des Signals umfasst 2 MHz und der Kanalabstand beträgt 5 MHz. Der Kanal sollte so gewählt werden das er mit anderen Funksystemen nicht kollidiert wie W-LAN oder andere Systeme die auf dem 2,4 GHz Bereich senden. Erlaubte Einstellungen im Register 0..15.
Es ist erlaubt während des Betriebes den Kanal zu wechseln. Die Klemme zeigt den Wechsel des Kanals in R33 an. Sind R32 und R33 gleich ist der Fequenzkanal übernommen worden.

R33: Kanal-Register (read only)

Im diesem Kanal wird von der Klemme die Übernahme des Kanals quittiert. Bei Übernahme des neues Kanals in R32 bestätigt dies die Klemme im dem Sie den Kanal in R33 einträgt.

R38: Watchdog (nur im Slave Modus aktiviert)

In Register R38 wird der Watchdog für den Slave eingestellt. Bei dem Wert Null ist der Watchdog deaktiviert. Es wird also bei Kommunikationsabbruch kein Fehlerbit gesetzt. Der Default-Wert beträgt 20dez. Der Wert aus R38 muss mit ca. 20ms multipliziert werden.
Beispiel: R38 = 100 (100 x 20 ms = 2000 ms oder 2 sec).

R39: Broadcast-Modus

In Register R39 wird der Broadcast-Modus für den Broadcast-Master aktiviert. Das Register wird von den Broadcast-Slaves nicht augewertet. Die Slaves werden über den DIP-Schalter zu Broadcast-Slaves "gemacht".
0x0000: Master-Slave- oder Peer to Peer-Modus (Default)
0x4342: Broadcast-Modus (Master)

R40: Scan (nur im Master-Mode möglich)

Hier werden die gefundenen Slaves eingetragen wenn der Scan mit dem Bit CB1.2 aktiviert wurde. Jedes Bit steht für eine gefundene Slave-Adresse.

R41: Netzwerk-ID

Mit der Netzwerk-ID können Sie bis zu 255 Funknetze unterscheiden. Die KM6551-0000 akzeptieren nur Telegramme von Modulen, die die gleiche Netzwerk-ID haben.
Zulässiger Wertebereich: 0...255dez. Der Default-Wert ist 0dez.

Hinweis 		Betrieb mehrerer Funknetze
Wenn Sie innerhalb der Reichweit (z.B. innerhalb einer Fabrikhalle) verschiedene Funknetze betreiben möchten, gewährleistet die Unterscheidung der Netzwerke über verschiedene Kanalnummern einen störungsfreieren Betrieb, als wenn Sie Netzwerke mit verschiedenen Netzwerk-IDs auf dem selben Kanal betreiben!

Verwenden Sie die Unterscheidung verschiedener Funknetze über die Netzwerk-ID erst, wenn Sie keine freien Kanäle mehr zur Verfügung haben!

R46: Dämpfung der Sendeleistung

Mit Bit 0 bis 7 des Register R46 können Sie die Sendeleistung des KM6551-000 dämpfen. Die Einstellung wir erst mit neu start des Moduls wirksam.

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8
Name | - | - | - | - | - | - | - | -
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Large Scale |  | Small Scale |  |  | - | - | -
Legende
Bit | Name | Beschreibung |  | default
15...8 | - | reserviert |  | 00bin
7...6 | Large Scale | 11bin | minus 30 dB | 00bin
 |  | 10bin | minus 20 dB
 |  | 01bin | minus 10 dB
 |  | 00bin | minus 0,0 dB
5...3 | Small Scale | 111bin | minus 6,3 dB | 000bin
 |  | 110bin | minus 4,9 dB
 |  | 101bin | minus 3,7 dB
 |  | 100bin | minus 2,8 dB
 |  | 011bin | minus 1,9 dB
 |  | 010bin | minus 1,2 dB
 |  | 001bin | minus 0,5 dB
 |  | 000bin | minus 0,0 dB
2...0 | - | reserviert |  | 000bin


Beispiele für die Register-Kommunikation

Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.

Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
    - ASCII-Code 0x33 steht für die Ziffer 3
    - ASCII-Code 0x41 steht für den Buchstaben A
    Die Firmwareversion lautet also 3A.

Beispiel 2: Beschreiben eines Anwender-Registers

Hinweis 		Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt.
Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder.
Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.

I. Schreiben des Code-Worts (0x1235) in Register 31

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!

II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.

III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.

    VORSICHT     		Beachten Sie die Registerbeschreibung!
    Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
    Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!

IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.

V. Schreiben des Register 31 (Code-Wort zurücksetzen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


KM6551-0000 - Allgemeine Betriebsbedingungen

BECKHOFF KM6551-0000: Anhang

Allgemeine Betriebsbedingungen

Zulassung und Einsatz

Das Modul KM6551-0000 erfüllt die Anforderungen der EN 300-440-02 V1.1.2.

Der Betrieb des Moduls KM6551-0000 ist in allen Ländern der EU sowie in der Schweiz und in Lichtenstein zulässig. Weitere Länder auf Anfrage.

Der Einsatz des KM6551-0000 ist mit folgenden Antennen gestattet:

Bezeichnung | Beschreibung
ZS6100-0900 | Richtantenne (9 dBi Gewinn), ohne Leitung
ZS6100-1800 | Richtantenne (18 dBi Gewinn), ohne Leitung
ZS6200-0400 | Rundstrahlantenne (4 dBi Gewinn), ohne Leitung
ZS6201-0410 | Stabantenne (4 dBi Gewinn), mit Leitung (1 m)
ZS6201-0500 | Stabantenne (5 dBi Gewinn), ohne Leitung

Achtung 		CE-Konformität
Die CE-Konformität des KM6551-0000 ist nur beim Betrieb mit original Beckhoff-Zubehör (Antennen, Koaxialleitung) gewährleistet!

Bedingungen an die Umgebung

Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden.

Betrieb

An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:

  • unter erschwerten Betriebsbedingungen, wie z.B. ätzende Dämpfe oder Gase, Staubbildung
  • bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur im Betrieb | 0°C ...+55°C
zulässige Umgebungstemperatur im Betrieb | -25°C ... +85°C
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4, EN 300-440-02 V1.1.2
Sicherheit von Personen in elektromagnetischen Feldern | gemäß EN 50371:2002

Transport und Lagerung

Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur bei Lagerung | -25°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m

Schutzklasse und Schutzart

Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 ( Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz


KM6551-0000 - EG-Konformitätserklärung

BECKHOFF KM6551-0000: Anhang

EG-Konformitätserklärung


Rechnen mit Dezibel

Leistungen werden in der Kommunikationstechnik in Dezibel (dB) angegeben, dem Zehntel der Einheit Bel. Sie ist das logarithmische Verhältnis zweier dimensionsgleicher Größen.

Es wird eine Bezugsgröße (P1), z. B. ein Milliwatt (mW), mit der Messgröße (P2) verglichen. Den logarithmischen Zusammenhang stellte Alexander Graham Bell fest, Ihm zu Ehren heißt die Einheit Bel.

Da die Zahlenwerte beim Benutzen des Bel zu unhandlich wurden, einigte man sich auf 1/10 der Werte, das Dezibel.

Definition der Pegeldifferenz: Pegeldifferenz [dB] = 10 log ([P1] / [P2]).

Definition eines Leistungsverhältnisses: Leistungsverhältnis = 10Pegeldifferenz/10

Wenn man die Leistungen und Verluste (Dämpfungen) in dB ausdrückt, hat dies den Vorteil, dass man die Rechenart bei Leistungsverhältnissen durch eine niedrigere Rechenart bei der dB-Rechnung ersetzen kann:

Leistungsverhältnis | dB-Rechnung
Multiplikation oder Division | Addition oder Subtraktion
Exponent | Faktor
Beispiele für Leistungsverhältnisse
Faktor | Verstärkung [db]
x 1 | +0 dB
x 1,25 | +1 dB
x 2 | +3 dB
x 4 | +6 dB
x 10 | +10 dB
x 16 | +12 dB
x 100 | +20 dB
x 1000 | +30 dB

Faktor | Dämpfung [dB]
x 1 | -0 dB
x 0,8 | -1 dB
x 0,5 | -3 dB
x 0,25 | -6 dB
x 0,1 | -10 dB
x 0,6 | -12 dB
x 0,01 | -20 dB
x 0,001 | -30 dB
Beispiele für das Rechnen mit Dezibel
Änderung | in dB
10 / 2 = 5 | 10 - 3 = 7
2 x 2 x 2 = 8 | 3 + 3 + 3 = 9
2 x 100 = 200 | 3 + 20 = 23
1000 / 2 = 500 | 30 - 3 = 27


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


KM6551-0000 - FB_KM6551_ENERGIE_SCAN

BECKHOFF KM6551-0000: Funktionsbausteine

Funktionsbaustein FB_KM6551_ENERGY_SCAN

Dieser Funktionsbaustein scannt die 16 Kanäle des 2,5 Ghz Bandes. Eine positive Flanke von bStart aktiviert den Scan. Mit iMode können zwei Scan Methoden ausgewählt werden. Mit iMode = 0 wird ein einfacher Scan der 16 Kanäle durchgeführt. Dieser Scan benötigt ca. 90 Sec. Mit iMode = 1 wird der Scan 10 mal wiederholt. Beim einfachen Scan wird der einzelne Kanal ca. 5 Sekunden beobachtet. Bitte beachten Sie das es vorkommen kann das ein W-LAN zum Beispiel in dieser Zeit grade nicht sendet und damit der Scan einen sehr niedrigen Wert erhält. Die Werte der gescannten Kanäle liegen im Array arEnergie von 0..15. Die Werte sind 0 - 100%. Je niedriger der Wert, desto kleiner die Ernergiedichte bei einer Frequenz. Sonlange der Baustein arbeitet ist das bBusy auf TRUE. Wechselt das bBusy auf FALSE ist der Baustein Fertig oder er hat einen Fehler, der mit bError angezeigt wird. Die Fehlerart kann dann mit iErrorID ausgelesen werden..

VAR_INPUT

bStart :BOOL;
iMode :INT;
strLinkData :KM6551_Data;

Legende

bStart: Positive Flanke aktiviert den Baustein.
i Mode: Einfacher Scan iMode = 0, 10 facher Scan iMode = 1
strLinkData: Wird mit strLinkData vom FB_KM6551_MAIN verbunden.

VAR_OUTPUT

bBusy             :BOOL;
arEnergie         :ARRAY [0..15] OF
UDINT;
bError            :BOOL;
iErrorID          :E_KM6551_ERRORID;

Legende

bBusy: Solange bBusy gesetzt ist, also TRUE ist, ist der Baustein noch am Arbeiten, warten Sie bis bBusy auf FALSE wechselt.
arEnergie: Enthält den Energiewert für die einzelnen Kanäle. "0%" wenig Energie, "100%" viel Energie.
b Error: Der Baustein hat einen Fehler.
iErrorID: Fehler Code