KM4602 - Zweikanaliges analoges Ausgangsmodul mit Hand- und Automatikbetrieb
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.2.0
▪
Technische Daten korrigiert
▪
Strukturupdate
2.1.0
▪
Beschreibung des Control-Bytes korrigiert
2.0.0
▪
Migration
1.0.0
▪
erste Veröffentlichung
Firm- und Hardware-Stände
Dokumentation, Version | Firmware-Version | Hardware-Version
2.2.0 | 1C | 03
2.1.0 | 1C | 03
2.0.0 | 1C | 02
1.0.0 | 1C | 01
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite des Klemmenmoduls aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 35 05 00 01:
35 - Produktionswoche 35
05 - Produktionsjahr 2005
00 - Firmware-Stand 00
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten


Einführung

Produktübersicht [image] Einführung
Einführung
KM4602
Die analoge Ausgangsklemme KM4602 besitzt zwei potenzialfreie analoge Ausgänge (0 bis 10 VDC). Beide Ausgänge sind intern mit einer gemeinsamen Masse verbunden.
Für jeden Kanal ermöglicht ein Schalter die Auswahl zwischen Automatik- und Handbetrieb:
▪
Im Automatikbetrieb wird ein analoger Wert in Abhängigkeit von den Prozessdaten ausgegeben.
▪
Im Handbetrieb wird der über das Potentiometer eingestellte Wert auf den Ausgang gelegt.
Auch für Handbetrieb ist die Versorgungsspannung des Buskopplers mit 24 VDC (UL) erforderlich.
Der Zustand der Schalter kann von der Steuerung ausgelesen werden (Bit 0 der Status-Bytes).


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | KM4602-0000
Anzahl Ausgänge | 2
Anschlusstechnik | Single ended
Ausgangsspannung | 0 bis 10 VDC
Bürde | > 5 kΩ (kurzschlussfest)
Auflösung | 12 Bit
Ausgabefehler | < ±0,1% (bezogen auf den Endwert)
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 175 mA
Breite eines Busklemmenblocks | maximal 64 Standard-Busklemmen oder 80 cm (ein KM4602-0000 entspricht hierbei 2 Standard-Busklemmen)
Datenbreite im Eingangsprozessabbild | 8 Bit Status, 16 Bit Daten
Datenbreite im Ausgangsprozessabbild | 8 Bit Control, 16 Bit Daten
Konfiguration | keine Adress- oder Konfigurationseinstellung
Betriebsarten | Hand- oder Automatikbetrieb
Potenzialtrennung | 500 V (K-Bus/Signalspannung)
Abmessungen ohne Antennen (B x H x T) | ca. 26,5 mm x 100 mm x 55 mm (Breite angereiht: 24 mm)
Gewicht | ca. 85 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene (z. B. Hutschiene TH 35-7.5 nach EN 60715)
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4, EN 300-440-02
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Empfohlene Tragschienen
•
Montage und Demontage - Frontentriegelung oben
•
Abmessungen
•
Anschluss


Empfohlene Tragschienen

Montage und Verdrahtung [image] Empfohlene Tragschienen
Empfohlene Tragschienen
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx können Sie auf folgende Tragschienen aufrasten:
▪
Tragschiene TH 35-7.5 mit 1 mm Materialstärke (nach EN 60715)
▪
Tragschiene TH 35-15 mit 1,5 mm Materialstärke
Materialstärke der Tragschiene beachten
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx passen nicht auf die Tragschiene TH 35-15 mit 2,2 bis 2,5 mm Materialstärke (nach EN 60715)!


Montage und Demontage - Frontentriegelung oben

Montage und Verdrahtung [image] Montage und Demontage - Frontentriegelung oben
Montage und Demontage - Frontentriegelung oben
Die Klemmenmodule werden mit Hilfe einer 35 mm Tragschiene (z.B. Hutschiene TH 35-15) auf der Montagefläche befestigt.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung der empfohlenen Tragschienen unter den Klemmen flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle

und drücken Sie (1) das Klemmenmodul gegen die Tragschiene, bis es auf der Tragschiene einrastet (2).
▪
Schließen Sie die Leitungen an.
Demontage
▪
Entfernen Sie alle Leitungen.
▪
Ziehen Sie mit Daumen und Zeigefinger die orange Entriegelungslasche (3) zurück. Dabei ziehen sich über einen internen Mechanismus die beiden Rastnasen (3a) an der Hutschiene ins Klemmenmodul zurück.

▪
Ziehen Sie (4) das Klemmenmodul von der Montagefläche weg. Vermeiden Sie ein Verkanten; stabilisieren Sie das Modul ggf. mit der freien Hand


Abmessungen

Montage und Verdrahtung [image] Abmessungen
Abmessungen
Abmessungen KM4602


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Anschluss KM4602
Klemmstelle | Beschreibung
Channel 1 | Signalanschluss für Kanal 1
Ground | Masseanschluss für Kanal 1
Shield | Schirmanschluss für Kanal 1
Channel 2 | Signalanschluss für Kanal 2
Ground | Masseanschluss für Kanal 3
Shield | Schirmanschluss für Kanal 2
Interne Beschaltung des KM4602
Interne Beschaltung des KM4602


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Mapping
•
Control- und Status-Byte
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Das Klemmenmodul KM4602 stellt sich im Prozessabbild mit maximal 6 Byte Ein- und 6 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Format | Eingangsdaten | Ausgangsdaten
Byte | SB1 | CB1
Wort | DataIN1 | DataOUT1
Byte | SB2 | CB2
Wort | DataIN2 | DataOUT2
Legende
SB n: Status-Byte für Kanal n
CB n: Control-Byte für Kanal n
DataIN n: Eingangsdatenwort Kanal n
DataOUT n: Ausgangsdatenwort Kanal n
▪
Die Zuordnung der Bytes und Worte zu den Adressen der Steuerung entnehmen Sie bitte der Seite Mapping.
▪
Die Bedeutung der Control- und Status-Bytes entnehmen Sie bitte der Seite Control- und Status-Bytes.
▪
Im Prozessdatenbetrieb werden in den Ausgangsdatenworten DataOUT1 und DataOUT4 die Analogwerte übertragen und die Eingangsdatenworte DataIN1 und DataIN4 nicht benutzt.
Datenformat
Prozessdatum |  | Ausgangsspannung
hexadezimal | dezimal
0x0000 | 0 | 0 V
0x3FFF | 16383 | 5 V
0x7FFF | 32767 | 10 V


Mapping

Zugriff aus dem Anwenderprogramm [image] Mapping
Mapping
Die Busklemmen belegen Adressen im Prozessabbild der Steuerung. Die Zuordnung der Prozessdaten (Ein- und Ausgangsdaten) und Parametrierungsdaten (Control- und Status-Bytes) zu den Steuerungsadressen wird als Mapping bezeichnet. Die Art des Mappings ist abhängig von:
▪
dem verwendeten Feldbus-System
▪
dem Klemmentyp
▪
der Parametrierung des Buskopplers (Bedingungen) wie
–
kompakte oder komplette Auswertung.
–
Intel- oder Motorola-Format.
–
Word-Alignment ein- oder ausgeschaltet.
Die Buskoppler (BKxxxx, LCxxxx) und Busklemmen Controller (BCxxxx, BXxxxx) werden mit bestimmten Voreinstellungen (Default-Einstellungen) ausgeliefert. Mit der Konfigurationssoftware KS2000 oder mit einer Master-Konfigurationssoftware (z. B. TwinCAT System Manager oder ComProfibus) können Sie diese Default-Einstellungen verändern.
Die folgenden Tabellen zeigen das Mapping in Abhängigkeit der verschiedenen Bedingungen. Die Inhalte der einzelnen Bytes entnehmen Sie bitte den Seiten Prozessabbild sowie Control- und Status-Bytes.
Kompakte Auswertung
Bei kompakter Auswertung belegen die analogen Ausgangsklemmen nur Adressen im Ausgangsprozessabbild. Der Zugriff auf Control- und Status-Bytes ist nicht möglich.
Kompakte Auswertung im Intel-Format
Default-Mapping für CANopen-, CANCAL-, DeviceNet-, ControlNet-, Modbus-, RS232- und RS485-Koppler
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | - | - | Ch1 D1 | Ch1 D0
 | 1 | - | - | Ch2 D1 | Ch2 D0
Kompakte Auswertung im Motorola-Format
Default-Mapping für PROFIBUS- und Interbus-Koppler
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | - | - | Ch1 D0 | Ch1 D1
 | 1 | - | - | Ch2 D0 | Ch2 D1
Komplette Auswertung
Bei kompletter Auswertung belegen die analogen Ausgangsklemmen Adressen im Ein- und im Ausgangsprozessabbild. Der Zugriff auf Control- und Status-Bytes ist möglich.
Komplette Auswertung im Intel-Format
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
Komplette Auswertung im Motorola-Format
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
Komplette Auswertung im Intel-Format bei Word-Alignment
Default-Mapping für Lightbus-, Ethernet-, und EtherCAT-Koppler sowie Busklemmen Controller (BCxxxx, BXxxxx)
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
Komplette Auswertung im Motorola-Format bei Word-Alignment
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
Legende
Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.
SB n: Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)
Ch n D0: Kanal n, niederwertiges Daten-Byte
Ch n D1: Kanal n, höherwertiges Daten-Byte
Reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Klemme/Modul nicht belegt oder benutzt.


Control- und Status-Byte

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Byte
Control- und Status-Byte
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 (bei Prozessdatenbetrieb)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zum Klemmenmodul übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 bis CB1.1 | - | 0bin | reserviert
... | ... | ... | ...
CB1.0 | - | 0bin | reserviert
Status-Byte 1 (bei Prozessdatenbetrieb)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird vom Klemmenmodul zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | - | - | - | - | - | - | OperationMode
Legende
Bit | Name | Beschreibung
SB1.6 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 | - |  | reserviert
... | ... | ... | ...
SB1.1 | - | 0bin | Reserviert
SB1.0 | OperationMode | 0bin | Für diesen Kanal ist der Handbetrieb aktiviert.
 |  | 1bin | Für diesen Kanal ist der Automatikbetrieb aktiviert.
Registerkommunikation
Control-Byte 1 (bei Registerkommunikation)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zum Klemmenmodul übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIn lesen oder - mit dem Ausgangsdatenwort DataOut beschreiben wollen.
Status-Byte 1 (bei Registerkommunikation)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird vom Klemmenmodul zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2
Control- und Status-Byte des Kanals 2 (CB2 und SB2) sind wie Control- und Status-Byte des Kanals 1 aufgebaut.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die folgenden Register dienen zur Parametrierung der KM4602. Sind für jeden Signalkanal der Analogklemme einmal vorhanden und können mit Hilfe von Control-, Status- und Daten-Bytes über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | Prozessdaten für D/A-C | - | - | R | RAM
R1 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R5 | reserviert | - | - | - | -
R6 | Diagnose-Register (nicht benutzt) | - | - | R | RAM
R7 | Kommando-Register (nicht benutzt) | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | 0x11FA | 4602dez | R | ROM
R9 | Firmware-Stand | z. B. 0x3141 | z.B. 1AASCI | R | ROM
R10 | Datenlänge (Multiplex-Schieberegister) | 0x0218 | 536dez | R | ROM
R11 | Signalkanäle | 0x0218 | 536dez | R | ROM
R12 | minimale Datenlänge | 0x9800 | 38912dez | R | ROM
R13 | Datenstruktur (Datentyp-Register) | 0x0000 | 0dez | R | ROM
R14 | reserviert | - | - | - | -
R15 | Alignment-Register | z. B. 0x7F80 | z. B. 32640dez | R/W | RAM
R16 | Hardware-Versionsnummer | z. B. 0x0000 | z. B. 0dez | R/W | SEEPROM
R17 | Hardware-Abgleich: Offset (Ba) | 0x0001 | 1dez | R/W | SEEPROM
R18 | Hardware-Abgleich: Gain (Aa) | typ. 0x0E99 | typ. 3737dez | R/W | SEEPROM
R19 | Hersteller-Skalierung: Offset (Bh) | 0x0000 | 0dez | R/W | SEEPROM
R20 | Hersteller-Skalierung: Gain (Ah) | typ. 0x0020 | typ. 32dez | R/W | SEEPROM
R21 | Hersteller-Einschaltwert | 0x0000 | 0dez | R/W | SEEPROM
R22 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R30 | reserviert | - | - | - | -
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register | 0x0006 | 6dez | R/W | SEEPROM
R33 | Anwender-Skalierung: Offset (Bw) | 0x0000 | 0dez | R/W | SEEPROM
R34 | Anwender-Skalierung: Gain (Aw) | 0x0100 | 256dez | R/W | SEEPROM
R35 | Anwender-Einschaltwert (Y2) | 0x0000 | 0dez | R/W | SEEPROM
R36 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R63 | reserviert | - | - | - | -


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die folgenden Register dienen zur Parametrierung des KM4602. Sie sind für jeden Signalkanal der Analogklemme einmal vorhanden und können mit Hilfe von Control-, Status- und Daten-Bytes über die Registerkommunikation ausgelesen oder beschrieben werden.
R0: Prozessdaten für D/A-C
Prozessdaten, die dem D/A-Wandlers übergeben werden.
R6: Diagnose-Register
Das Diagnose-Register des KM4602 wird zur Zeit nicht benutzt.
R7: Kommando-Register
Das Kommando-Register des KM4602 wird zur Zeit nicht benutzt.
R8: Klemmenbezeichnung
Im Register R8 steht die Bezeichnung der Klemme.
KM4602: 0x11FA (4602dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 (1AASCII). Hierbei entspricht '0x31' dem ASCII-Zeichen '1' und '0x41' dem ASCII-Zeichen 'A'. Dieser Wert kann nicht verändert werden.
R10: Datenlänge (Multiplex-Schieberegister)
R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit.
R11: Signalkanäle
Im Gegensatz zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z. B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.
R12: Minimale Datenlänge
Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control- und Status-Byte nicht zwingend notwendig für die Funktion der Klemme und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen.
R13: Datenstruktur (Datentyp-Register)
Datentypregister | Bedeutung
0x00 | Klemme ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur: 1 Byte, n Bytes
0x03 | Wort-Array
0x04 | Struktur: 1 Byte, n Worte
0x05 | Doppelwort-Array
0x06 | Struktur: 1 Byte, n Doppelworte
0x07 | Struktur: 1 Byte, 1 Doppelwort
0x08 | Struktur: 1 Byte, 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur: 1 Byte, n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur: 1 Byte, n Worte mit variabler logischer Kanallänge
0x15x | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur: 1 Byte, n Doppelworte mit variabler logischer Kanallänge
R15: Alignment-Register
Mit Hilfe der Bits des Alignment-Register legt der Buskoppler den Adressbereich einer Analogklemme so, dass er auf einer auf Byte-Grenze beginnt.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme, dieser Wert kann nicht verändert werden.
R17: Hardware-Abgleich - Offset (Ba)
Über dieses Register erfolgt der Offset-Abgleich der Klemme (siehe Gleichung 1.1). Registerwert (16 Bit signed Integer). Default: 0x0001 (1dez)
R18: Hardware-Abgleich - Gain (Aa)
Über dieses Register erfolgt der Gain-Abgleich der Klemme (siehe Gleichung 1.1). Registerwert (16 Bit unsigned Integer x 2-12). Default: typisch 0x0E99 (3737dez)
R19: Hersteller-Skalierung - Offset (Bh)
Dieses Register beinhaltet den Offset der Hersteller-Skalierung (siehe Gleichung 1.3). Registerwert (16 Bit signed Integer). Default: 0x0000 (0dez)
Die Hersteller-Skalierung kann durch Bit R32.1 des Feature-Registers aktiviert werden.
R20: Hersteller-Skalierung - Gain (Ah)
Dieses Register beinhaltet den Gain der Hersteller-Skalierung (siehe Gleichung 1.3). Registerwert (16 Bit un signed Integer x 2-8). Default: typisch 0x0020 (32dez)
Die Hersteller-Skalierung kann durch Bit R32.1 des Feature-Registers aktiviert werden.
R21: Hersteller-Einschaltwert
Die Klemme legt den Hersteller-Einschaltwert nach einem System-Reset oder einem Watchdog-timer-Overflow (Klemme hat 100 ms lang keine Prozessdaten erhalten) an ihren Ausgang. Registerwert (16 Bit signed Integer).
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei jedem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Konfiguration der Klemme fest. Default: 0x0006 (6dez)
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | - | - | - | enUserActValue
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | enSignRepr | - | enSignAmRepr | enWdTimer | enManScal | enUsrScal
Legende
Bit | Name | Beschreibung |  | default
R32.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.9 | - | reserviert |  | 0bin
R32.8 | enUserActValue | 0bin | Hersteller-Einschaltwert aktiv | 0bin
 |  | 1bin | Anwender-Einschaltwert aktiv
R32.7 | - | reserviert |  | 0bin
R32.6 | - | reserviert |  | 0bin
R32.5 | enSignRepr | 0bin | Betragsbildung nicht aktiv | 0bin
 |  | 1bin | Betragsbildung aktiv
R32.4 | - | reserviert |  | 0bin
R32.3 | enSignAmRepr | 0bin | Zweierkomplementdarstellung aktiv | 0bin
 |  | 1bin | Betragsvorzeichendarstellung aktiv (-1dez = 0x8001)
R32.2 | enWdTimer | 0bin | Watchdog-Timer nicht aktiv | 1bin
 |  | 1bin | Watchdog-Timer aktiv (werden 100 ms keine Prozessdaten empfangen, löst der Watchdog aus)
R32.1 | enManScal | 0bin | Hersteller-Skalierung aktiv | 1bin
 |  | 1bin | Hersteller-Skalierung nicht aktiv
R32.0 | enUsrScal | 0bin | Anwender-Skalierung nicht aktiv | 0bin
 |  | 1bin | Anwender-Skalierung aktiv
R33: Anwender-Skalierung - Offset (Bw)
Dieses Register beinhaltet den Offset der Anwender-Skalierung.
Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden.
R34: Anwender-Skalierung - Gain (Aw)
Dieses Register beinhaltet das Gain der Anwender-Skalierung. Default: 0x0100 (256dez)
Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden.
R35: Anwender-Einschaltwert
Wenn der Anwender-Einschaltwert mit Bit R32.8 des Feature-Registers aktiviert wurde, legt die Klemme anstelle des Hersteller-Einschaltwerts den Anwender-Einschaltwert an ihren Ausgang wenn ein System-Reset oder ein Watchdog-timer-Overflow (Klemme hat 100 ms lang keine Prozessdaten erhalten) auftritt.


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.