KM37xx - Druckmessmodule
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0.0
▪
Korrekturen
▪
Erste Veröffentlichung als PDF
1.2.0
▪
Technische Daten aktualisiert
▪
Montage und Verdrahtung erweitert
▪
Prozessdaten korrigiert
▪
KM3701-0340 hinzugefügt
1.1.1
Applikationsbeispiele aktualisiert
1.1.0
Technische Daten aktualisiert
1.0.0
erste Veröffentlichung
Firm- und Hardware-Stände
Dokumentation Version | KM3701-0000, KM3701-0340 |  | KM3702-0000 |  | KM3712-0000
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
2.0.0 | 1G | 09 | 1D | 07 | 1E | 09
1.2.0 | 1C | 01 | 1B | 01 | 1B | 01
1.1.1 | 1C | 00 | 1B | 00 | 1B | 00
1.1.0 | 1B | 00 | 1A | 00 | 1A | 00
1.0.0 | 1B | 00 | 1A | 00 | 1A | 00
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite des Klemmenmoduls aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 35 05 00 01:
35 - Produktionswoche 35
05 - Produktionsjahr 2005
00 - Firmware-Stand 00
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KM3701 - Einführung
•
KM3702 - Einführung
•
KM3712 - Einführung
•
Technische Daten
•
Grundlagen zur Funktion
•
LED-Anzeigen


KM3701 - Einführung

Produktübersicht [image] KM3701 - Einführung
KM3701 - Einführung
KM3701
Einkanaliges Differenzdruckmessmodul
Das Differenzdruckmessmodul KM3701 ermöglicht die direkte Messung von Druckunterschieden zwischen zwei Schlauchanschlüssen. Die Druckdifferenz steht im Feldbus mit 16 Bit Auflösung zur Verfügung. Der Messbereich liegt zwischen -100 hPa und +100 hPa (-100 mbar bis +100 mbar). Die Status-LEDs zeigen die ordnungsgemäße Funktion bzw. Fehler, wie Bereichsüberschreitung, an.
Es stehen zwei Varianten zur Verfügung:
▪
KM3701-0000: Messbereich -100 bis +100 hPa (-100 bis +100 mbar)
▪
KM3701-0340: Messbereich -340 bis +340 hPa (-340 bis +340 mbar)
Quick-Links
▪
Montage und Verdrahtung
▪
Zugriff aus dem Anwenderprogramm
▪
Anwendungsbeispiele


KM3702 - Einführung

Produktübersicht [image] KM3702 - Einführung
KM3702 - Einführung
KM3702
Zweikanaliges Relativdruckmessmodul für 0 bis 7500 hPa (0 bis 7,5 bar)
Das Relativdruckmessmodul KM3702 ermöglicht die direkte Messung von zwei Druckwerten an den Schlauchanschlüssen. Der Druck wird als Differenz zur Umgebung des KM3702 ermittelt und steht im Feldbus mit 16 Bit Auflösung zur Verfügung. Die Status-LEDs zeigen die ordnungsgemäße Funktion bzw. Fehler, wie Bereichsüberschreitung, an.


KM3712 - Einführung

Produktübersicht [image] KM3712 - Einführung
KM3712 - Einführung
KM3712
Zweikanaliges Relativdruckmessmodul für -1.000 hPa bis +1.000 hPa (-1 bar bis +1 bar)
Das Relativdruckmessmodul KM3712 ermöglicht die direkte Messung von zwei negativen Druckwerten an den Schlauchanschlüssen. Der Druck wird als Differenz zur Umgebung des KM3712 ermittelt und steht im Feldbus mit 16 Bit Auflösung zur Verfügung. Die Status-LEDs zeigen die ordnungsgemäße Funktion bzw. Fehler, wie Bereichsüberschreitung, an.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | KM3701-0000 | KM3701-0340 | KM3702-0000 | KM3712-0000
Anzahl der Eingänge | 1 (Differenzdruck) |  | 2 | 2
Messbereich | -100 bis +100 hPa (-100 bis +100 mbar) | -340 bis +340 hPa (-340 bis +340 mbar) | 0 bis 7500 hPa (0 bis 7,5 bar) | -1000 bis +1000 hPa (-1 bis +1 bar)
Zulässiger Überdruck | max. ±500 hPa differentiell, max. +5000 hPa zur Umgebung |  | +10000 hPa | +5000 hPa
zulässige Medien | nicht aggressive Gase
Auflösung | 0,1 hPa (0,1 mbar) pro Digit |  | 1 hPa (1 mbar) pro Digit | 1 hPa (1 mbar) pro Digit
Messgenauigkeit | 3% (vom Messbereichsendwert)
Messgeschwindigkeit | typisch 5 ms
Druckanschlüsse | Steckverschraubung, M12 x 1
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 15 mA
Breite eines Busklemmenblocks | maximal 64 Standard-Busklemmen oder 80 cm (ein KM37xx entspricht hierbei 2 Standard-Busklemmen)
Potenzialtrennung | 500 V (K-Bus/Signalspannung)
Bitbreite im Eingangsprozessabbild | 3 Byte | 3 Byte | 6 Byte | 6 Byte
Bitbreite im Ausgangsprozessabbild | 3 Byte | 3 Byte | 6 Byte | 6 Byte
Abmessungen ohne Luftschläuche (B x H x T) | ca. 26,5 mm x 100 mm x 69 mm (Breite angereiht: 24 mm)
Gewicht | ca. 100 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene (z. B. Hutschiene TH 35-7.5 nach EN 60715)
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Busklemmenblock mit Druckmessmodulen
Die Druckmessmodule KM3701 und KM3712 erfassen direkt Differenz- und Relativdrücke in nicht aggressiven Gasen. Die Druckmessung erfolgt wie bei der elektronischen Signalerfassung über ein Klemmenmodul. Die Druckmessmodule wandeln den gemessenen Druck in ein elektrisches Signal um und stellen mit 16 Bit Auflösung der übergeordneten Steuerung zur Verfügung. Das Messprinzip beruht auf aktuellster chipintegrierter Sensorik. Neben der reinen Messung führt der Halbleiter auch weitere Funktionen, wie die Temperaturkompensation und Vermeidung von Langzeitdrift, durch. Die Status-LEDs zeigen die ordnungsgemäße Funktion bzw. Fehler, wie Bereichsüberschreitung an.
KM3701 - Einkanaliges Differenzdruckmessmodul
KM3701 - Einkanalige Differenzdruckmessung
Das Klemmenmodul KM3701 misst Druckunterschiede von 0 bis 100 hPa (0 bis 100 mbar) zwischen zwei Schlauchanschlüssen. Der Differenzdruck kann bis zu einem Umgebungsdruck von 7500 hPa (7 bar) zwischen beliebigen Punkten gemessen werden.
KM3702 - Zweikanaliges Relativdruckmessmodul (0 hPa bis 7500 hPa)
KM3702 - Zweikanalige Relativdruckmessung
Das Klemmenmodul KM3702 misst Druckwerte von 0 bis 7000 hPa (0 bis 7 bar) an jedem Schlauchanschluss. Die Druckmessung erfolgt relativ gegenüber dem realen, momentanen Umgebungsdruck.
KM3712 - Zweikanaliges Relativdruckmessmodul (-1000 hPa bis +1000 hPa)
KM3712 - Zweikanalige Relativdruckmessung
Das Klemmenmodul KM3712 misst Druckwerte von -1000 hPa bis +1000 hPa (-1 bar bis +1 bar) an jedem Schlauchanschluss. Die Druckmessung erfolgt relativ gegenüber dem realen, momentanen Umgebungsdruck.
Einbau und Anschlusstechnik
Die Drücke werden direkt von der Druckmessklemme erfasst. Zusätzliche Messgeräte entfallen. Das spart Anschlusstechnik und Bauraum gegenüber dem Einsatz herkömmlicher Messgeräte. Der Einbau der Druckmessklemmen ist einfach und schnell und erfolgt ohne zusätzliche Montagewerkzeuge. Die Messschläuche werden direkt an die Schnellverschlüsse der Druckmessklemme angebracht. Als Messschlauch können handelsübliche Kunststoffschläuche eingesetzt werden. Die Druckmessklemmen sind bezüglich Anschlusstechnik und Bauraum wie eine übliche 24-mm-Busklemme ausgeführt und können platzsparend direkt in das Busklemmensystem eingebaut werden.


LED-Anzeigen

Produktübersicht [image] LED-Anzeigen
LED-Anzeigen
KM3701
KM3701 - LEDs
LED | Anzeige
Run (grün) | aus | Datenübertragung auf dem K-Bus nicht aktiv
 | an | Datenübertragung auf dem K-Bus aktiv
Overrange (rot) | an | der Differenzdruck liegt oberhalb des zulässigen Messbereichs
Underrange (rot) | an | der Differenzdruck liegt unterhalb des zulässigen Messbereichs
KM3702, KM3712
KM3702, KM3712 - LEDs
LED | Anzeige
Run (grün) | aus | Datenübertragung auf dem K-Bus nicht aktiv
 | an | Datenübertragung auf dem K-Bus aktiv
Error X1 (rot) | an | der Druck an Anschluss X1 liegt unterhalb (underrange) oder oberhalb (overrange) des zulässigen Messbereichs
Error X2 (rot) | an | der Druck an Anschluss X2 liegt unterhalb (underrange) oder oberhalb (overrange) des zulässigen Messbereichs


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Empfohlene Tragschienen
•
Montage und Demontage - Frontentriegelung oben
•
Anschluss


Empfohlene Tragschienen

Montage und Verdrahtung [image] Empfohlene Tragschienen
Empfohlene Tragschienen
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx können Sie auf folgende Tragschienen aufrasten:
▪
Hutschiene TH 35-7.5 mit 1 mm Materialstärke (nach EN 60715)
▪
Hutschiene TH 35-15 mit 1,5 mm Materialstärke
Hinweis
Materialstärke der Hutschiene beachten
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx passen nicht auf die Hutschiene TH 35-15 mit 2,2 mm bis 2,5 mm Materialstärke (nach EN 60715)!


Montage und Demontage - Frontentriegelung oben

Montage und Verdrahtung [image] Montage und Demontage - Frontentriegelung oben
Montage und Demontage - Frontentriegelung oben
Die Klemmenmodule werden mit Hilfe einer 35 mm Tragschiene (z.B. Hutschiene TH 35-15) auf der Montagefläche befestigt.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung der empfohlenen Tragschienen unter den Klemmen flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle

und drücken Sie (1) das Klemmenmodul gegen die Tragschiene, bis es auf der Tragschiene einrastet (2).
▪
Schließen Sie die Leitungen an.
Demontage
▪
Entfernen Sie alle Leitungen.
▪
Ziehen Sie mit Daumen und Zeigefinger die orange Entriegelungslasche (3) zurück. Dabei ziehen sich über einen internen Mechanismus die beiden Rastnasen (3a) an der Hutschiene ins Klemmenmodul zurück.

▪
Ziehen Sie (4) das Klemmenmodul von der Montagefläche weg. Vermeiden Sie ein Verkanten; stabilisieren Sie das Modul ggf. mit der freien Hand


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Der Anschluss der Luftschläuche erfolgt auf Steckverschraubungen.
Technische Daten | Steckverschraubung
Typ | QSS-4-F
Schlauchaußendurchmesser | 4 mm
Nennweite | 2,6 mm
Gewinde | M12 x 1
Schlüsselweite | 14 mm


Anwendungsbeispiele

Anwendungsbeispiele
Anwendungsbeispiele
Die Druckmessmodule können überall dort eingesetzt werden, wo es um das Erfassen und Kontrollieren von Differenz- und Staudrücken in nicht aggressiven Gasen geht, z. B. in Druckbehältern, Druckkabinen, Pneumatik-, Filter-, Ansaug-, Verpackungs- und Positionieranlagen.
Sie messen Betriebsdrücke, überwachen Filter und Siebe, prüfen die Dichtheit von Behältern und unterstützen bei der Lageprüfung von Bauteilen oder der Niveaukontrolle von Flüssigkeiten. Werden aus den gemessenen Drücken Strömungsgeschwindigkeiten berechnet, können die Druckmessklemmen auch zur Strömungsmessung eingesetzt werden. So finden sie Anwendung in Bereichen wie beispielsweise der Prozess-, Verfahrens-, Haus-, Gebäude- und Klimatechnik sowie der Heizungs- und Lüftungstechnik.
▪
Anwendungsbeispiele für KM3701
▪
Anwendungsbeispiel für KM3702
▪
Anwendungsbeispiel für KM3712
Weiterführende Informationen
•
KM3701 - Anwendungsbeispiele
•
KM3702 - Anwendungsbeispiel
•
KM3712 - Anwendungsbeispiel


KM3701 - Anwendungsbeispiele

Anwendungsbeispiele [image] KM3701 - Anwendungsbeispiele
KM3701 - Anwendungsbeispiele
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Tankanlagen
KM3701 - Anwendungsbeispiel für die Füllstandsmenge von Tanks
▪
kontrolliert Füllstandsmenge von Tanks und aktiviert bei Unterschreiten eines definierten Füllstands das Nachfüllen
▪
Druckdifferenz ist Indikator für Füllhöhe
▪
zusätzliche Manometer, Schalter und zugehörige Anschlusstechnik sind nicht notwendig
Filteranlagen, Rohrverengungen
KM3701 - Anwendungsbeispiel für Filteranlagen, Rohrverengungen
▪
überwacht den Betriebszustand von Filtern und Sieben
▪
Druckdifferenz zeigt Verschmutzungsgrad an


KM3702 - Anwendungsbeispiel

Anwendungsbeispiele [image] KM3702 - Anwendungsbeispiel
KM3702 - Anwendungsbeispiel
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Pneumatikanlagen
KM3702 Anwendungsbeispiel für Pneumatikanlagen
▪
Kontrolle des Füllstand von Speichern
▪
Überwachung des Betriebsdrucks von Anlagen
▪
ermöglicht die Überwachung und Vermeidung von Überdruck


KM3712 - Anwendungsbeispiel

Anwendungsbeispiele [image] KM3712 - Anwendungsbeispiel
KM3712 - Anwendungsbeispiel
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Verpackungsanlage für Eier
EM3712 - Anwendungsbeispiel Verpackungsanlage für Eier
▪
kontrolliert die Ansaugung
▪
Druckabweichungen signalisieren Leckagen oder Positionierungenauigkeiten


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Register
•
Prozessdaten


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Buskoppler für Ethernet BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine Differenzdruckmessmodul KM3701
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor dem Modul, dessen Parameter sie verändern möchten (Im Beispiel Position 2).
KS2000 Baumzweig für Kanal 1 der KM3701
Für das KM3701 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register des KM3701.
▪
ProcData zeigt die Prozessdaten des KM3701.


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register des Klemmenmoduls (hier im Beispiel das KM3701) zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Registeransicht in KS2000


Prozessdaten

Konfigurations-Software KS2000 [image] Prozessdaten
Prozessdaten
Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.
Feld Prozessdaten
Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.
Feld Verlauf
Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.
Feld Wert
Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.
Feld Wert
VORSICHT
Gefahr für Personen, Umwelt oder Geräte!
Beachten Sie, das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann. Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, das Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.
Einstellung der Darstellung


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
KM3701 - Prozessabbild
•
KM3702, KM3712 - Prozessabbild
•
Control- und Status-Byte
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


KM3701 - Prozessabbild

Zugriff aus dem Anwenderprogramm [image] KM3701 - Prozessabbild
KM3701 - Prozessabbild
Das Klemmenmodul KM3701stelt sich im Prozessabbild mit maximal 3 Byte Ein- und 3 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Format | Eingangsdaten | Ausgangsdaten
Byte | SB | CB
Wort | DataIN | DataOUT
Legende
SB: Status-Byte
CB: Control-Byte
DataIN: Eingangsdatenwort
DataOUT: Ausgangsdatenwort
▪
Die Bedeutung der Control- und Status-Bytes entnehmen Sie bitte der Seite Control- und Status-Bytes.
▪
Im Prozessdatenbetrieb wird im Eingangsdatenwort DataIN der Analogwert übertragen und das Ausgangsdatenwort DataOUT nicht benutzt.
Darstellung der Analogwerte
Die analogen Eingangswerte werden vom Klemmenmodul wie folgt dargestellt:
KM3701-0000
Differenzdruck | Dezimal | Hexadezimal
-100 hPa | -1000 | 0xFC18
0 hPa | 0 | 0x0000
+100 hPa | +1000 | 0x03E8
KM3701-0340
Differenzdruck | Dezimal | Hexadezimal
-340 hPa | -3400 | 0xF2B8
0 hPa | 0 | 0x0000
+340 hPa | +3400 | 0x0D48


KM3702, KM3712 - Prozessabbild

Zugriff aus dem Anwenderprogramm [image] KM3702, KM3712 - Prozessabbild
KM3702, KM3712 - Prozessabbild
Die Klemmenmodule KM3702 und KM3712 stellten sich im Prozessabbild mit maximal 6 Byte Ein- und 6 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Format | Eingangsdaten | Ausgangsdaten
Byte | SB1 | CB1
Wort | DataIN1 | DataOUT1
Byte | SB2 | CB2
Wort | DataIN2 | DataOUT2
Legende
SB n: Status-Byte für Kanal n
CB n: Control-Byte für Kanal n
DataIN n: Eingangsdatenwort Kanal n
DataOUT n: Ausgangsdatenwort Kanal n
▪
Die Bedeutung der Control- und Status-Bytes entnehmen Sie bitte der Seite Control- und Status-Bytes.
▪
Im Prozessdatenbetrieb werden in den Eingangsdatenworten DataIN1 und DataIN2 die Analogwerte übertragen und die Ausgangsdatenworte DataOUT1 und DataOUT2 nicht benutzt.
Darstellung der Analogwerte
Die analogen Eingangswerte werden von den Klemmenmodulen wie folgt dargestellt:
KM3702-0000
Druck | Dezimal | Hexadezimal
0 hPa | 0 | 0x0000
7500 hPa | 7500 | 0x1D4C
KM3712-0000
Druck | Dezimal | Hexadezimal
-1000 hPa | -1000 | 0xFC18
0 hPa | 0 | 0x0000
+1000 hPa | +1000 | 0x03E8


Control- und Status-Byte

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Byte
Control- und Status-Byte
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 (bei Prozessdatenbetrieb)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zum Klemmenmodul übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | -
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 bis CB1.1 | - | 0bin | reserviert
... | ... | ... | ...
CB1.0 | - | 0bin | reserviert
Status-Byte 1 (bei Prozessdatenbetrieb)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird vom Klemmenmodul zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | StateThreshold2 |  | StateThreshold1 |  | Overload | Underload
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 | Error | 1bin | ein interner Fehler ist aufgetreten (aktuelle Prozessdaten sind nicht mehr gültig)
SB1.5 / SB1.4 | StateThreshold2 | 00bin | Grenzwert 2 ist nicht über Bit R32.10 des Feature-Registers aktiviert
 |  | 01bin | Prozessdatum ist größer als Grenzwert 2
 |  | 10bin | Prozessdatum ist kleiner als Grenzwert 2
 |  | 11bin | Prozessdatum ist gleich Grenzwert 2
SB1.3 / SB1.2 | StateThreshold1 | 00bin | Grenzwert 1 ist nicht über Bit R32.9 des Feature-Registers aktiviert
 |  | 01bin | Prozessdatum ist größer als Grenzwert 1
 |  | 10bin | Prozessdatum ist kleiner als Grenzwert 1
 |  | 11bin | Prozessdatum ist gleich Grenzwert 1
SB1.1 | Overload | 1bin | Prozessdatum ist größer als in Register R21 vorgegeben. Die rote Error-LED dieses Kanals leuchtet.
SB1.0 | Underload | 1bin | Prozessdatum sind kleiner als in Register R22 vorgegeben. Die rote Error-LED dieses Kanals leuchtet (die Kalibrierung ist aktiv, wenn SB1.0 und SB1.1 gleichzeitig gesetzt sind).
Registerkommunikation
Control-Byte 1 (bei Registerkommunikation)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zum Klemmenmodul übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIn lesen oder - mit dem Ausgangsdatenwort DataOut beschreiben wollen.
Status-Byte 1 (bei Registerkommunikation)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird vom Klemmenmodul zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2 (nur KM3702 und KM3712)
Control- und Status-Byte des Kanals 2 (CB2 und SB2) sind wie Control- und Status-Byte des Kanals 1 aufgebaut.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | ADC-Rohwert |  | variabel | variabel | R | RAM
R1 | reserviert |  | 0x0000 | 0dez | - | -
... | ... |  | ... | ... | ... | ...
R5 | reserviert |  | 0x0000 | 0dez | - | -
R6 | Diagnose-Register |  | 0x0000 | 0dez | R | RAM
R7 | Kommando-Register |  | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | KM3701: | 0x0E75 | 3701dez | R | ROM
 |  | KM3702: | 0x0E76 | 3702dez
 |  | KM3712: | 0x0E80 | 3712dez
R9 | Firmware-Stand |  | z. B. 0x3141 | z. B. 1AASCI | R | ROM
R10 | Multiplex-Schieberegister |  | 0x0118 | 280dez | R | ROM
R11 | Signalkanäle |  | 0x0218 | 280dez | R | ROM
R12 | minimale Datenlänge eines Kanals |  | 0x0098 | 152dez | R | ROM
R13 | Datenstruktur |  | 0x0000 | 0dez | R | ROM
R14 | reserviert |  | 0x0000 | 0dez | - | -
R15 | Alignment-Register |  | typisch 0x7F80 | typisch 32640dez | R/W | RAM
R16 | Hardware-Versionsnummer |  | z. B. 0x0000 | z. B. 0dez | R/W | EEPROM
R17 | Hersteller-Abgleich: Offset | KM3701, KM3712: | typisch 0xF800 | typisch 63488dez | R/W | EEPROM
 |  | KM3702: | typisch 0xFE66 | typisch 65126dez
R18 | Hersteller-Abgleich: Gain |  | 0x0000 | 0dez | R/W | EEPROM
R19 | Hersteller-Skalierung: Offset |  | 0x0000 | 0dez | R/W | EEPROM
R20 | Hersteller-Skalierung: Gain | KM3701, KM3712: | 0x00A2 | 162dez | R/W | EEPROM
 |  | KM3702: | 0x021B | 539dez
R21 | Overrange-Limit | KM3701, KM3712: | 0x03E8 | 1000dez | R/W | EEPROM
 |  | KM3702: | 0x1D4C | 7500dez
R22 | Underrange-Limit | KM3701, KM3712: | 0xFC18 | -1000dez | R/W | EEPROM
 |  | KM3702: | 0xFF9C | -100dez
R23 | interne Verwendung |  | 0x0000 | 0dez | R/W | EEPROM
R24 | interne Verwendung |  | 0x1004 | 4100dez | R/W | EEPROM
R25 | reserviert |  | 0x0000 | 0dez | - | -
... | reserviert |  | - | - | - | -
R30 | reserviert |  | 0x0000 | 0dez | - | -
R31 | Kodewort-Register |  | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register |  | 0x0202 | 514dez | R/W | EEPROM
R33 | Anwender-Offset |  | 0x0000 | 0dez | R/W | EEPROM
R34 | Anwender-Gain |  | 0x0100 | 256dez | R/W | EEPROM
R35 | Grenzwert 1 |  | 0x0000 | 0dez | R/W | EEPROM
R36 | Grenzwert 2 |  | 0x0000 | 0dez | R/W | EEPROM
R37 | reserviert |  | - | - | - | -
... | reserviert |  | - | - | - | -
R63 | reserviert |  | - | - | - | -


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
R0: ADC-Rohwert
Im Register R0 steht der Rohwert des Analog/Digital-Wandlers. Dies ist der unveränderte Analogwert vor allen Skalierungen.
R6: Diagnose-Register
In Register R6 wird das Status-Byte SB eingeblendet.
R7: Kommando-Register
Hinweis
Anwender-Kodewort
Um die folgenden Kommandos auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein!
Kommando 0x7000: Restore Factory Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register beider Kanäle die Werte des Auslieferungszustands wiederhergestellt:
KM3701, KM3712:
R21: 0x03E8 (1000dez)
R22: 0xFC18 (-1000dez)
R32: 0x0202 (514dez)
R33: 0x0000 (0dez)
R34: 0x0100 (256dez)
R35: 0x0000 (0dez)
R36: 0x0000 (0dez)
KM3702:
R21: 0x1D4C (7500dez)
R22: 0xFF9C (-100dez)
R32: 0x0202 (514dez)
R33: 0x0000 (0dez)
R34: 0x0100 (256dez)
R35: 0x0000 (0dez)
R36: 0x0000 (0dez)
Hinweis
Auslieferungszustand für alle Kanäle
Das Kommando Restore Factory Settings setzt alle Kanäle des Moduls gleichzeitig zurück auf Auslieferungszustand, egal aus welchem Registersatz heraus es aufgerufen wird!
R8: Modulbezeichnung
Im Register R8 steht die Bezeichnung des Klemmenmoduls.
KM3701: 0x0C64 (3701dez)
KM3702: 0x0C6E (3702dez)
KM3712: 0xC3C (3712dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R12: Minimale Datenlänge eines Kanals
Bit 0 bis 6 des höherwertigen Bytes geben die minimale Anzahl der Ausgangsdaten in Bit an: 000.0000bin = 0dez so 0 Byte.
Bit 0 bis 6 des niederwertigen Bytes geben die minimale Anzahl der Eingangsdaten in Bit an: 001.1000bin = 24dez so 3 Byte.
Dass Bit 7 gesetzt ist zeigt, dass Control- und Status-Byte für die Funktion der Klemme nicht zwingend erforderlich sind und im kompakten Modus nicht übertragen werden.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R17: Hersteller-Abgleich - Offset
Dieses Register beinhaltet den Offset des Hersteller-Abgleichs (16 Bit signed Integer).
R18: Hersteller-Abgleich - Gain
Dieses Register beinhaltet den Gain des Hersteller-Abgleichs (16 Bit unsigned Integer x 2-16 + 1). Beispiele:
0x0000 bedeutet Faktor 1
0xFFFF bedeutet Faktor 2
R19: Hersteller-Skalierung - Offset
Dieses Register beinhaltet den Offset der Hersteller-Skalierung. Kann durch R32.1 im Feature-Register aktiviert werden (16 Bit signed Integer).
R20: Hersteller-Skalierung - Gain
Dieses Register beinhaltet den Gain der Hersteller-Skalierung. Kann durch R32.1 im Feature-Register aktiviert werden (16 Bit unsigned Integer x 2-8 + 1). Beispiele:
0x0100 bedeutet Faktor 1.
0x0080 bedeutet Factor 0,5
R21: Obere Begrenzung Messbereich
Dieses Register beinhaltet die obere Begrenzung Messbereichs. Kann durch R32.8 im Feature-Register aktiviert werden.
R22: Untere Begrenzung Messbereich
Dieses Register beinhaltet die untere Begrenzung Messbereichs. Kann durch R32.8 im Feature-Register aktiviert werden.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Konfiguration des Moduls fest.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | enTh2 | enTh1 | enOverProt | -
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | enSiemens Format | enAverage Format | disWdTimer | enManScal | enUsrScal
Bit | Name | Beschreibung |  | default
R32.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.12 | - | reserviert |  | 0bin
R32.11 | enTh2 | 0bin | Grenzwert 2 nicht aktiv | 0bin
 |  | 1bin | Grenzwert 2 aktiv
R32.10 | enTh1 | 0bin | Grenzwert 1 nicht aktiv | 0bin
 |  | 1bin | Grenzwert 1 aktiv
R32.9 | enOverProt | 0bin | Begrenzung des Messbereichs nicht aktiv | 1bin
 |  | 1bin | Begrenzung des Messbereichs aktiv
R32.8 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.5 | - | reserviert |  | 0bin
R32.4 | enSiemensFormat | 0bin | Siemensausgabeformat nicht aktiv | 0bin
 |  | 1bin | Siemensausgabeformat aktiv
R32.3 | enAverageFormat | 0bin | Betragsvorzeichendarstellung nicht aktiv | 0bin
 |  | 1bin | Betragsvorzeichendarstellung aktiv
R32.2 | disWdTimer | 0bin | Watchdog-Timer aktiv (werden 100 ms keine Prozessdaten empfangen, löst der Watchdog aus) | 0bin
 |  | 1bin | Watchdog-Timer nicht aktiv
R32.1 | enManScal | 0bin | Hersteller-Skalierung nicht aktiv | 1bin
 |  | 1bin | Hersteller-Skalierung aktiv
R32.0 | enUsrScal | 0bin | Anwender-Skalierung nicht aktiv | 0bin
 |  | 1bin | Anwender-Skalierung aktiv
R33: Anwender-Skalierung - Offset
Dieses Register beinhaltet den Offset der Anwender-Skalierung. Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden (16 Bit signed Integer).
R34: Anwender-Skalierung - Gain
Dieses Register beinhaltet den Gain der Anwender-Skalierung. Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden (16 Bit unsigned Integer x 2-8 + 1, eine 1dez entspricht hierbei 0x0100).
R35: Grenzwert 1
In Register R35 wird der Grenzwert 1 eingetragen. Der Grenzwert kann im Feature-Register durch Bit R32.10 aktiviert werden.
R36: Grenzwert 2
In Register R36 wird der Grenzwert 2 eingetragen. Der Grenzwert kann im Feature-Register durch Bit R32.11 aktiviert werden.


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Hinweis
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.