KM2774-0000 - Klemmenmodul für Jalousie-Motoren

BECKHOFF Feldbuskomponenten

Dokumentation zu

KM2774-0000

Klemmenmodul für Jalousie-Motoren

Version: 1.0.0
Datum: 18.08.2010


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


KM2774-0000 - Ausgabestände der Dokumentation

BECKHOFF KM2774-0000: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
1.0.0 | Erste Veröffentlichung

Firm- und Hardware-Stände

Dokumentation Version | Firmware-Version | Hardware-Version
1.0.0 | 1E | 04

Den Firm- und Hardware-Stand können Sie der Seriennummer auf dem Aufkleber an der Unterseite des Klemmenmoduls entnehmen.

Syntax der Seriennummer

Aufbau der Seriennummer: WW YY FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 12 10 1E 04:

12 - Produktionswoche 12
10 - Produktionsjahr 2010
1E - Firmware-Stand 1E
04 - Hardware-Stand 04


KM2774-0000 - Einführung

BECKHOFF KM2774-0000: Produktübersicht

Einführung

Das Klemmenmodul KM2774-0000 dient zur Ansteuerung von vier Jalousie-Motoren und zum Anschluss der dazugehörigen Taster.

Je Motor stehen drei gegeneinander verriegelte Triac-Ausgänge (230 V, 1,5 A), drei digitale Eingänge (24 V) und eine masseschaltender Ausgang (24 V, 20 mA) z.B. zum Anschluss einer Taster-LED zur Verfügung. Die Ausgänge sind überlastgeschützt. Eine einstellbare Überstrombegrenzung schützt den Motor vor Beschädigungen.

Leuchtdioden zeigen die Stati der Eingänge und Ausgänge an. Zudem gibt es LEDs für laufenden Datenverkehr auf dem K-Bus (RUN), das Anliegen der Versorgungsspannungen (24 VDC, 230 VAC) und für die Anzeige von Übertemperatur (Error) im Klemmenmodul.

Bei fehlender Versorgungsspannung (230 V) oder bei Übertemperatur werden die Triac-Ausgänge, die LED-Ausgänge und deren Status-LEDs nicht angesteuert.


KM2774-0000 - Technische Daten

BECKHOFF KM2774-0000: Produktübersicht

Technische Daten

Technische Daten | KM2774-0000
Anzahl der Leistungsausgänge | 4 x 3 Schließer
Nennspannung der Leistungsausgänge | 80 ... 230 VAC
Überspannungsschutz an den Leistungsausgängen | > 275 V
Ausgangsstrom der Leistungsausgänge | 1,5 A (0,6 mA Leerlaufstrom)
Stoß-Strom | 40 A (16 ms), 3 A (30s)
Überstrombegrenzung | Einstellbar
Einschaltzeit | 0,1 ... 10 ms, Nulldurchgang
Ausschaltzeit | T/2
Restspannung | maximal 1,5 V (60 mA ... 1 A), 150 Ω (< 60 mA)
Anzahl der digitalen Ausgänge | 4 (1 pro Kanal), masseschaltend
Nennspannung | 24 VDC
Ausgangsstrom | maximal 20 mA, kurzschlussfest
Signalspannung "0" | -3 V ... 5 V
Signalspannung "1" | -15 V ... 30 V
Anzahl der digitalen Eingänge | 12 (4 x 3)
Nennspannung | 24 VDC (-15%/+20%)
Signalspannung "0" | -3 V ... 5 V (IEC 61132-2, Typ 1)
Signalspannung "1" | -15 V ... 30 V (IEC 61132-2, Typ 1)
Eingangsfilter | 3,0 ms
Eingangsstrom | typisch 3 mA (IEC 61132-2, Typ 1)
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 30 mA
Potenzialtrennung | 500 Veff (K-Bus/Feldspannung), 3750 VAC (1 Minute)
Bitbreite im Eingangsprozessabbild | 24 Bit
Abmessungen mit Klemmen (B x H x T) | ca. 135mm x 100mm x 40mm Breite angereiht: 132mm), siehe Maßbild
Gewicht | ca. 270 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
zulässiger Verschmutzungsgrad | 1
Montage | auf 35 mm Tragschiene nach EN 50022
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


Klemmenmodule - Montage und Demontage

BECKHOFF Klemmenmodule: Montage und Verdrahtung

Montage und Demontage

Die Klemmenmodule werden mit Hilfe einer 35 mm Tragschiene (z.B. Hutschiene TH 35-7.5 nach EN 60715) auf der Montagefläche befestigt.

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
  • Montieren Sie die Tragschiene an der vorgesehenen Montagestelle

    und drücken Sie (1) das Klemmenmodul gegen die Tragschiene, bis es auf der Tragschiene Einrastet (2).
  • Schließen Sie die Leitungen an.
Demontage
  • Entfernen Sie alle Leitungen. Dank der KM/EM-Steckverbinder müssen Sie hierzu nicht alle Leitungen einzeln entfernen, sondern pro KM/EM-Steckverbinder nur 2 Schrauben lösen um diese abziehen zu können (stehende Verdrahtung)!
  • Hebeln Sie auf der linken Seite des Klemmenmoduls mit einem Schraubendreher (3) den Entriegelungshaken nach oben. Dabei
    • ziehen sich über einen internen Mechanismus die beiden Rastnasen (3a) an der Hutschiene ins Klemmenmodul zurück,
    • bewegt sich der Entriegelungshaken nach vorne (3b) und rastet ein

  • Bei 32- und 64-kanaligen Klemmenmodulen (KMxxx4 und KMxxx8 bzw. EMxxx4 und EMxxx8) hebeln Sie nun den zweiten Entriegelungshaken auf der rechten Seite des Klemmenmoduls auf die gleiche Weise nach oben.
  • Ziehen Sie (5) das Klemmenmodul von der Montagefläche weg.


Klemmenmodule - Empfohlene Tragschienen

BECKHOFF Klemmenmodule: Montage und Verdrahtung

Empfohlene Tragschienen

Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx können Sie auf folgende Tragschienen aufrasten:

  • Hutschiene TH 35-7.5 mit 1 mm Materialstärke (nach EN 60715)
  • Hutschiene TH 35-15 mit 1,5 mm Materialstärke

Hinweis 		Materialstärke der Hutschiene beachten
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx passen nicht auf die Hutschiene TH 35-15 mit 2,2 bis 2,5 mm Materialstärke (nach EN 60715)!


KM2774 - Verdrahtung

BECKHOFF KM2774: Montage und Verdrahtung

Verdrahtung

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Anschluss für Versorgungsspannung (24 V)

VORSICHT 		Erden Sie die 0 V Potentiale der 24 V Versorgungsspannung!
Verbinden Sie
  • das 0 V Potential der Versorgungsspannung (Us) des Buskopplers der das KM2774-1001 ansteuert und
  • das 0 V Potential der Versorgungsspannung des KM2774-1001 (X0, Klemmstelle 3, 4 oder 5)

mit der Schutzerde!

Klemmleiste | Klemmstelle | Bezeichnung | Funktion
X0: 24V | 0 | 24 V | Einspeisung 24 V für Modulelektronik
 | 1 | 24 V | Einspeisung 24 V für Modulelektronik
 | 2 | 0 V | Einspeisung 0 V für Modulelektronik
 | 3 | 0 V | Einspeisung 0 V für Modulelektronik
 | 4 | 0 V | Einspeisung 0 V für Modulelektronik

Anschluss der Taster für Kanal 1 bis 4

Klemmleiste | Klemmstelle | Bezeichnung | Funktion
X1: Ch1 | 0 | 24 V | Kanal 1: 24 V für Taster
 | 1 | IN1 | Kanal 1: Eingang für Taster 1
 | 2 | IN2 | Kanal 1: Eingang für Taster 2
 | 3 | IN3 | Kanal 1: Eingang für Taster 3
 | 4 | LED | Kanal 1: geschaltete Masse für Taster-LED
X2: Ch2 | 0 | 24 V | Kanal 2: 24 V für Taster
 | 1 | IN1 | Kanal 2: Eingang für Taster 1
 | 2 | IN2 | Kanal 2: Eingang für Taster 2
 | 3 | IN3 | Kanal 2: Eingang für Taster 3
 | 4 | LED | Kanal 2: geschaltete Masse für Taster-LED
X3: Ch3 | 0 | 24 V | Kanal 3: 24 V für Taster
 | 1 | IN1 | Kanal 3: Eingang für Taster 1
 | 2 | IN2 | Kanal 3: Eingang für Taster 2
 | 3 | IN3 | Kanal 3: Eingang für Taster 3
 | 4 | LED | Kanal 3: geschaltete Masse für Taster-LED
X4: Ch4 | 0 | 24 V | Kanal 4: 24 V für Taster
 | 1 | IN1 | Kanal 4: Eingang für Taster 1
 | 2 | IN2 | Kanal 4: Eingang für Taster 2
 | 3 | IN3 | Kanal 4: Eingang für Taster 3
 | 4 | LED | Kanal 4: geschaltete Masse für LED

Anschluss der Motoren für Kanal 1 bis 4

Klemmleiste | Klemmstelle | Bezeichnung | Funktion
X11: Ch1 | 0 | L1 | Kanal 1: Phase L1 für Motor 1
 | 1 | L2 | Kanal 1: Phase L2 für Motor 1
 | 2 | L3 | Kanal 1: Phase L3 für Motor 1
 | 3 | N | Kanal 1: Neutralleiter für Motor 1 (intern verbunden mit den Neutralleiter-Klemmstellen der andern Kanäle)
 | 4 | PE | Kanal 1: Schutzerde für Motor 1
X12: Ch2 | 0 | L1 | Kanal 2: Phase L1 für Motor 2
 | 1 | L2 | Kanal 2: Phase L2 für Motor 2
 | 2 | L3 | Kanal 2: Phase L3 für Motor 2
 | 3 | N | Kanal 2: Neutralleiter für Motor 2 (intern verbunden mit den Neutralleiter-Klemmstellen der andern Kanäle)
 | 4 | PE | Kanal 2: Schutzerde für Motor 2
X13: Ch3 | 0 | L1 | Kanal 3: Phase L1 für Motor 3
 | 1 | L2 | Kanal 3: Phase L2 für Motor 3
 | 2 | L3 | Kanal 3: Phase L3 für Motor 3
 | 3 | N | Kanal 3: Neutralleiter für Motor 3 (intern verbunden mit den Neutralleiter-Klemmstellen der andern Kanäle)
 | 4 | PE | Kanal 3: Schutzerde für Motor 3
X14: Ch4 | 0 | L1 | Kanal 4: Phase L1 für Motor 4
 | 1 | L2 | Kanal 4: Phase L2 für Motor 4
 | 2 | L3 | Kanal 4: Phase L3 für Motor 4
 | 3 | N | Kanal 4: Neutralleiter für Motor 4 (intern verbunden mit den Neutralleiter-Klemmstellen der andern Kanäle)
 | 4 | PE | Kanal 4: Schutzerde für Motor 4

Anschluss für Versorgungsspannung (230 V)

Klemmleiste | Klemmstelle | Bezeichnung | Funktion
X10: 230V | 0 | L | Einspeisung Lastspannung (230 V)
 | 1 | L | Weiterführung Lastspannung (230 V)
 | 2 | N | Einspeisung Lastspannung (0 V)
 | 3 | N | Weiterführung Lastspannung (0 V)
 | 4 | PE | Schutzerde
 | 4 | PE | Schutzerde


KM2774 - Abmessungen

BECKHOFF KM2774: Montage und Vertrahtung

Abmessungen


Konfigurations-Software KS2000

Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler/Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.

Projektierung

Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, d. h. vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.

Parametrierung

KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.

Inbetriebnahme

KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.

KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:

  • Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
  • Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.

Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


KM2774-1001 - Parametrierung mit KS2000

BECKHOFF KM2774-0000: Konfigurationssoftware KS2000

Parametrierung mit KS2000

Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.

Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
  • ein Buskoppler für Ethernet BK9000
  • eine digitale Eingangsklemme KL1xx2
  • eine Klemmenmodul für Jalousie-Motoren KM2774-0000
  • eine Bus-Endklemme KL9010

Das linken Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.

Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor dem Modul, dessen Parameter sie verändern möchten (Im Beispiel Position 2).

Für das KM2774-0000 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:

  • Register erlaubt den direkten Zugriff auf die Register des KM2774-0000.
  • Unter Einstellungen finden Sie die Dialogmaske zur Parametrierung des KM2774-0000.
  • ProcData zeigt die Prozessdaten des KM2774-0000.


KM2774-0000 - KS2000-Einstellungen

BECKHOFF KM2774-0000: Konfigurations-Software KS2000

Einstellungen

Einstellungen zur Parametrierung der KM2774-0000.

Stromlimit

Kanal 1 (R34)

Hier können Sie das Stromlimit für Kanal 1 festlegen (Default: 1500 mA).
Zulässiger Wertebereich: 50 bis 1500 mA.

Kanal 2 (R35)

Hier können Sie das Stromlimit für Kanal 1 festlegen (Default: 1500 mA).
Zulässiger Wertebereich: 50 bis 1500 mA.

Kanal 3 (R36)

Hier können Sie das Stromlimit für Kanal 1 festlegen (Default: 1500 mA).
Zulässiger Wertebereich: 50 bis 1500 mA.

Kanal 4 (R37)

Hier können Sie das Stromlimit für Kanal 1 festlegen (Default: 1500 mA).
Zulässiger Wertebereich: 50 bis 1500 mA.

Totzeit

Totzeit für Kanal 1 (R38)

Hier können Sie die Totzeit bis zur Überstromabschaltung für Kanal 1 festlegen (Default: 400 ms).
Zulässiger Wertebereich: 100 bis 2560 ms in Schritten von 10 ms.
Wenn Sie 0 ms eingeben, wird die Totzeit abgeschaltet. Der Ausgang schaltet bei überschreiten des Stromlimits sofort ab.

Totzeit für Kanal 2 (R39)

Hier können Sie die Totzeit bis zur Überstromabschaltung für Kanal 2 festlegen (Default: 400 ms).
Zulässiger Wertebereich: 100 bis 2560 ms in Schritten von 10 ms.
Wenn Sie 0 ms eingeben, wird die Totzeit abgeschaltet. Der Ausgang schaltet bei überschreiten des Stromlimits sofort ab.

Totzeit für Kanal 3 (R40)

Hier können Sie die Totzeit bis zur Überstromabschaltung für Kanal 3 festlegen (Default: 400 ms).
Zulässiger Wertebereich: 100 bis 2560 ms in Schritten von 10 ms.
Wenn Sie 0 ms eingeben, wird die Totzeit abgeschaltet. Der Ausgang schaltet bei überschreiten des Stromlimits sofort ab.

Totzeit für Kanal 4 (R41)

Hier können Sie die Totzeit bis zur Überstromabschaltung für Kanal 4 festlegen (Default: 400 ms).
Zulässiger Wertebereich: 100 bis 2560 ms in Schritten von 10 ms.
Wenn Sie 0 ms eingeben, wird die Totzeit abgeschaltet. Der Ausgang schaltet bei überschreiten des Stromlimits sofort ab.


KM2774 - Prozessabbild

BECKHOFF KM2774: Zugriff aus dem Anwenderprogramm

Prozessabbild

Das Klemmenmodul KM2774 stellt sich im Prozessabbild mit 2 oder 3 Byte Eingangs- und 2 oder 3 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:

Format | Eingangsdaten | Ausgangsdaten
Byte | SB | CB
Wort | DataIN | DataOUT

*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen

Legende

SB: Status-Byte (entfällt bei kompakter Auswertung)
CB: Control-Byte (entfällt bei kompakter Auswertung)

DataIN: Prozesseingangsdaten
DataOUT: Prozessausgangsdaten

  • Die Zuordnung der Bytes und Worte zu den Adressen der Steuerung entnehmen Sie bitte der Seite Mapping.
  • Die Bedeutung des Control- und Status-Bytes entnehmen Sie bitte der Seite Control- und Status-Byte.
  • Die Beschreibung der Prozessdatenworte entnehmen Sie bitte den Seiten Prozesseingangsdaten (DataIN) und Prozessausgangsdaten (DataOUT).


KM2774 - Mapping

BECKHOFF KM2774: Zugriff aus dem Anwenderprogramm

Mapping

Die Klemmenmodul KM2774 belegt Eingangs- und Ausgangsadressen im Prozessabbild der Steuerung. Die Zuordnung der Prozessdaten (Ein- und Ausgangsdaten) und Parametrierungsdaten (Control- und Status-Bytes) zu den Steuerungsadressen wird als Mapping bezeichnet. Die Art des Mappings ist abhängig von:

  • dem verwendeten Feldbus-System

  • dem Klemmentyp

  • der Parametrierung des Buskopplers (Bedingungen) wie
    - kompakte oder Komplexe Auswertung
    - Intel- oder Motorola-Format
    - Word-Alignment ein- oder ausgeschaltet

Die Buskoppler (BKxxxx, LCxxxx) und Busklemmen Controller (BCxxxx, BXxxxx) werden mit bestimmten Voreinstellungen (Default-Einstellungen) ausgeliefert. Mit der Konfigurationssoftware KS2000 oder mit einer Master-Konfigurationssoftware (z.B. TwinCAT System Manager oder ComProfibus) können Sie diese Default-Einstellungen verändern.

Die folgenden Tabellen zeigen das Mapping in Abhängigkeit der verschiedenen Bedingungen. Die Inhalte der einzelnen Bytes entnehmen Sie bitte den Seiten Prozessabbild sowie Control- und Status-Bytes.

Kompakte Auswertung

Bei kompakter Auswertung belegt das KM2774 Adressen im Ein- und Ausgangsprozessabbild. Der Zugriff auf Control- und Status-Byte ist nicht möglich.

Kompakte Auswertung im Intel-Format

Default-Mapping für CANopen-, CANCAL-, DeviceNet-, ControlNet-, Modbus-, RS232- und RS485-Koppler

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | D1 | D0 | D1 | D0

Kompakte Auswertung im Motorola-Format

Default-Mapping für PROFIBUS- und Interbus-Koppler

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | D0 | D1 | D0 | D1

Komplexe Auswertung

Bei kompakter Auswertung belegt das KM2774 Adressen im Ein- und Ausgangsprozessabbild. Der Zugriff auf Control- und Status-Byte ist möglich.

Komplexe Auswertung im Intel-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | D0 | SB | D0 | CB
 | 1 | - | D1 | - | D1

Komplexe Auswertung im Motorola-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | D1 | SB | D1 | CB
 | 1 | - | D0 | - | D0

Komplexe Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus-, Ethernet- und EtherCAT-Koppler (BK1120) sowie Busklemmen Controller (BCxxxx, BXxxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB | reserviert | CB
 | 1 | D1 | D0 | D1 | D0

Komplexe Auswertung im Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB | reserviert | CB
 | 1 | D0 | D1 | D0 | D1
Legende

Komplexe Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB Status-Byte (erscheint im Eingangsprozessabbild)
CB: Control-Byte (erscheint im Ausgangsprozessabbild)

D0: niederwertiges Byte des Datenworts
D1: höherwertiges Byte des Datenworts

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird vom Modul nicht belegt oder benutzt.


KM2774 - Control- und Status-Byte

BECKHOFF KM2774: Zugriff aus dem Anwenderprogramm

Control- und Status-Byte

Prozessdatenbetrieb

Control-Byte (bei Prozessdatenbetrieb)

Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | Reset | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB.6 | Reset | 1bin | alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke)
CB.5 bis CB.3 | - | 000bin | reserviert
CB.2 bis CB.0 | - | 000bin | reserviert

Status-Byte (bei Prozessdatenbetrieb)

Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | - | - | - | OverTemp | Err230V | Err24V
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB.6 | Error | 0bin | kein Fehler
 |  | 1bin | ein Fehler ist aufgetreten
SB.5 bis SB.3 | - | 000bin | reserviert
SB.2 | OverTemp | 1bin | die Innentemperatur der Klemme liegt über 80°C
SB.1 | Err230V | 1bin | Versorgungsspannung 230 V nicht vorhanden
SB.0 | Err24V | 1bin | Versorgungsspannung 24 V nicht vorhanden

Registerkommunikation

Control-Byte (bei Registerkommunikation)

Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB.5 bis CB.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIn lesen oder - mit dem Ausgangsdatenwort DataOut beschreiben wollen.

Status-Byte (bei Registerkommunikation)

Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB.6 | R | 0bin | Lesezugriff
SB.5 bis SB.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.


KM2774 - Prozesseingangsdaten (DataIN)

BECKHOFF KM2774: Zugriff aus dem Anwenderprogramm

Prozesseingangsdaten (DataIN)

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Kanal | Ch4 |  |  |  | Ch3 |  |  |  | Ch2 |  |  |  | Ch1
Name | curr | IN3 | IN2 | IN1 | curr | IN3 | IN2 | IN1 | curr | IN3 | IN2 | IN1 | curr | IN3 | IN2 | IN1
Legende
Bit | Kanal/Name | Beschreibung
15 | Ch4 curr | 0bin | Strom ist kleiner als für Kanal 4 spezifizierte Schaltschwelle
 |  | 1bin | Strom ist größer als für Kanal 4 spezifizierte Schaltschwelle
14 | Ch4 IN3 | Kanal 4, Eingang 3
13 | Ch4 IN2 | Kanal 4, Eingang 2
12 | Ch4 IN1 | Kanal 4, Eingang 1
11 | Ch3 curr | 0bin | Strom ist kleiner als für Kanal 3 spezifizierte Schaltschwelle
 |  | 1bin | Strom ist größer als für Kanal 3 spezifizierte Schaltschwelle
10 | Ch3 IN3 | Kanal 3, Eingang 3
9 | Ch3 IN2 | Kanal 3, Eingang 2
8 | Ch3 IN1 | Kanal 3, Eingang 1
7 | Ch2 curr | 0bin | Strom ist kleiner als für Kanal 2 spezifizierte Schaltschwelle
 |  | 1bin | Strom ist größer als für Kanal 2 spezifizierte Schaltschwelle
6 | Ch2 IN3 | Kanal 2, Eingang 3
5 | Ch2 IN2 | Kanal 2, Eingang 2
4 | Ch2 IN1 | Kanal 2, Eingang 1
3 | Ch1 curr | 0bin | Strom ist kleiner als für Kanal 1 spezifizierte Schaltschwelle
 |  | 1bin | Strom ist größer als für Kanal 1 spezifizierte Schaltschwelle
2 | Ch1 IN3 | Kanal 1, Eingang 3
1 | Ch1 IN2 | Kanal 1, Eingang 2
0 | Ch1 IN1 | Kanal 1, Eingang 1


KM2774 - Prozessausgangsdaten (DataOUT)

BECKHOFF KM2774: Zugriff aus dem Anwenderprogramm

Prozessausgangsdaten (DataOUT)

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Kanal | Ch4 |  |  |  | Ch3 |  |  |  | Ch2 |  |  |  | Ch1
Name | LED | L3 | L2 | L1 | LED | L3 | L2 | L1 | LED | L3 | L2 | L1 | LED | L3 | L2 | L1
Legende
Bit | Kanal/Name | Beschreibung
15 | Ch4 LED | 0bin | Masse für Taster-LED ist nicht geschaltet
 |  | 1bin | Masse für Taster-LED ist geschaltet
14 | Ch4 L3 | Kanal 4, Ausgang L3
13 | Ch4 L2 | Kanal 4, Ausgang L2
12 | Ch4 L1 | Kanal 4, Ausgang L1
11 | Ch3 LED | 0bin | Masse für Taster-LED ist nicht geschaltet
 |  | 1bin | Masse für Taster-LED ist geschaltet
10 | Ch3 L3 | Kanal 3, Ausgang L3
9 | Ch3 L2 | Kanal 3, Ausgang L2
8 | Ch3 L1 | Kanal 3, Ausgang L1
7 | Ch2 LED | 0bin | Masse für Taster-LED ist nicht geschaltet
 |  | 1bin | Masse für Taster-LED ist geschaltet
6 | Ch2 L3 | Kanal 2, Ausgang L3
5 | Ch2 L2 | Kanal 2, Ausgang L2
4 | Ch2 L1 | Kanal 2, Ausgang L1
3 | Ch1 LED | 0bin | Masse für Taster-LED ist nicht geschaltet
 |  | 1bin | Masse für Taster-LED ist geschaltet
2 | Ch1 L3 | Kanal 1, Ausgang L3
1 | Ch1 L2 | Kanal 1, Ausgang L2
0 | Ch1 L1 | Kanal 1, Ausgang L1


KM2774-0000 - Registerübersicht

BECKHOFF KM2774-0000: Zugriff aus dem Anwenderprogramm

Registerübersicht

Die Register dienen zur Parametrierung der Klemmenmodule. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.

Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | Analogwert Kanal 1 | - | - | R | RAM
R1 | Analogwert Kanal 2 | - | - | R | RAM
R2 | Analogwert Kanal 3 | - | - | R | RAM
R3 | Analogwert Kanal 4 | - | - | R | RAM
R4 | reserviert | 0x001A | 26dez | R | RAM
R5 | reserviert | 0x0000 | 0dez | R/W | RAM
R6 | reserviert | 0x0000 | 0dez | R/W | RAM
R7 | Kommando-Register (ohne Funktion) | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | 0x0AD6 | 2774dez | R | ROM
R9 | Firmware-Stand | z.B. 0x3144 | z.B. 1DASCII | R | ROM
R10 | Multiplex-Schieberegister | 0x0118 | 280dez | R | ROM
R11 | Signalkanäle | 0x0118 | 280dez | R | ROM
R12 | minimale Datenlänge | 0x9898 | 39064dez | R | ROM
R13 | Datenstruktur | 0x0004 | 4dez | R | ROM
R14 | reserviert | - | - | - | -
R15 | Alignment-Register | 0x7F80 | 32640 | R/W | RAM
R16 | Hardware-Versionsnummer | z.B. 0x0000 | z.B. 0dez | R/W | EEPROM
R17 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R28 | reserviert | - | - | - | -
R29 | Klemmentyp - Sonderkennung | 0x0000 | 0000 | R | EEPROM
R30 | reserviert | - | - | - | -
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | reserviert | 0x0000 | 0dez | R/W | RAM
R33 | Minimales Stromlimit | 0x0005 | 5dez | R/W | EEPROM
R34 | Stromlimit, Kanal 1 | 0x0096 | 150dez | R/W | EEPROM
R35 | Stromlimit, Kanal 2 | 0x0096 | 150dez | R/W | EEPROM
R36 | Stromlimit, Kanal 3 | 0x0096 | 150dez | R/W | EEPROM
R37 | Stromlimit, Kanal 4 | 0x0096 | 150dez | R/W | EEPROM
R38 | Totzeit für die Überstromabschaltung, Kanal 1 | 0x0004 | 4dez | R/W | EEPROM
R39 | Totzeit für die Überstromabschaltung, Kanal 2 | 0x0004 | 4dez | R/W | EEPROM
R40 | Totzeit für die Überstromabschaltung, Kanal 3 | 0x0004 | 4dez | R/W | EEPROM
R41 | Totzeit für die Überstromabschaltung, Kanal 4 | 0x0004 | 4dez | R/W | EEPROM
R42 | reserviert | 0x0000 | 0dez | R/W | RAM
... | ... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | 0dez | R/W | RAM


KM2774-0000 - Registerbeschreibung

BECKHOFF KM2774-0000: Zugriff aus dem Anwenderprogramm

Registerbeschreibung

Die Register dienen zur Parametrierung der Klemmenmodule. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.

R0: Analogwert von Kanal 1

Beinhaltet den momentanen Analogwert von Kanal 1.

R1: Analogwert von Kanal 2

Beinhaltet den momentanen Analogwert von Kanal 2.

R2: Analogwert von Kanal 3

Beinhaltet den momentanen Analogwert von Kanal 3.

R3: Analogwert von Kanal 4

Beinhaltet den momentanen Analogwert von Kanal 4.

R7: Kommando-Register

Das Kommando-Register des KM2774-0000 hat keine Funktion.

R8: Klemmentyp

Im Register R8 steht die Bezeichnung der Klemme: 0x0AD6 (2774dez)

R9: Firmware-Stand

Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z.B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.

R16: Hardware-Versionsnummer

Im Register R16 steht der Hardware-Stand der Klemme.

R29: Klemmentyp - Sonderkennung

Im Register R29 steht die Sonderkennung der Klemme: 0x0000 (0dez)

R31: Kodewort-Register

  • Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
  • Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die EEPROM-Register geschrieben und bleiben somit bei einem Neustart der Klemme erhalten.

Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.

R34: Stromlimit, Kanal 1

Hier können Sie das Stromlimit für Kanal 1 festlegen (Default: 150dez).
Skalierung: 150dez entspricht 1500 mA.
Zulässiger Wertebereich: 5 bis 150dez

R35: Stromlimit, Kanal 2

Hier können Sie das Stromlimit für Kanal 2 festlegen (Default: 150dez).
Skalierung: 150dez entspricht 1500 mA.
Zulässiger Wertebereich: 5 bis 150dez

R36: Stromlimit, Kanal 3

Hier können Sie das Stromlimit für Kanal 3 festlegen (Default: 150dez).
Skalierung: 150dez entspricht 1500 mA.
Zulässiger Wertebereich: 5 bis 150dez

R37: Stromlimit, Kanal 4

Hier können Sie das Stromlimit für Kanal 4 festlegen (Default: 150dez).
Skalierung: 150dez entspricht 1500 mA.
Zulässiger Wertebereich: 5 bis 150dez

R38: Totzeit für die Überstromabschaltung, Kanal 1

Hier können Sie die Totzeit bis zur Überstromabschaltung für Kanal 1 festlegen (Default: 40dez).
Skalierung: 40dez entspricht 400 ms.
Zulässiger Wertebereich: 10 bis 256dez
Wenn Sie 0 eingeben, wird die Totzeit abgeschaltet. Der Ausgang schaltet bei überschreiten des Stromlimits sofort ab.

R39: Totzeit für die Überstromabschaltung, Kanal 2

Hier können Sie die Totzeit bis zur Überstromabschaltung für Kanal 2 festlegen (Default: 40dez).
Skalierung: 40dez entspricht 400 ms.
Zulässiger Wertebereich: 10 bis 256dez
Wenn Sie 0 eingeben, wird die Totzeit abgeschaltet. Der Ausgang schaltet bei überschreiten des Stromlimits sofort ab.

R40: Totzeit für die Überstromabschaltung, Kanal 3

Hier können Sie die Totzeit bis zur Überstromabschaltung für Kanal 3 festlegen (Default: 40dez).
Skalierung: 40dez entspricht 400 ms.
Zulässiger Wertebereich: 10 bis 256dez
Wenn Sie 0 eingeben, wird die Totzeit abgeschaltet. Der Ausgang schaltet bei überschreiten des Stromlimits sofort ab.

R41: Totzeit für die Überstromabschaltung, Kanal 4

Hier können Sie die Totzeit bis zur Überstromabschaltung für Kanal 4 festlegen (Default: 40dez).
Skalierung: 40dez entspricht 400 ms.
Zulässiger Wertebereich: 10 bis 256dez
Wenn Sie 0 eingeben, wird die Totzeit abgeschaltet. Der Ausgang schaltet bei überschreiten des Stromlimits sofort ab.


Beispiele für die Register-Kommunikation

Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.

Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
    - ASCII-Code 0x33 steht für die Ziffer 3
    - ASCII-Code 0x41 steht für den Buchstaben A
    Die Firmwareversion lautet also 3A.

Beispiel 2: Beschreiben eines Anwender-Registers

Hinweis 		Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt.
Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder.
Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.

I. Schreiben des Code-Worts (0x1235) in Register 31

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!

II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.

III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.

    VORSICHT     		Beachten Sie die Registerbeschreibung!
    Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
    Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!

IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.

V. Schreiben des Register 31 (Code-Wort zurücksetzen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.