KL85xx - Handbedienmodule (K-Bus)
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.1.0
▪
Kapitel Technische Daten für KL8548 aktualisiert
2.0.0
▪
Migration
▪
Kapitel Funktionsbausteine erweitert
▪
Kapitel Anpassung der LED-Anzeigen hinzugefügt
1.5.0
▪
Beschreibung zur Deaktivierung der manuellen Bedienung durch das PLC-Programm hinzugefügt
▪
Beschreibung Control- und Status-Byte für KL8524 aktualisiert
▪
Beschreibung Control- und Status-Byte für KL8528 aktualisiert
▪
Beschreibung Control- und Status-Byte für KL8548 aktualisiert
1.4.0
▪
Beschriftung für Spannungsversorgung (Us) der KL85xx korrigiert
1.3.0
▪
Vorwort aktualisiert
▪
Beschreibung der Programmierung aktualisiert
▪
Registerbeschreibung für KL8519 aktualisiert
▪
Registerbeschreibung für KL8524 aktualisiert
▪
Technische Daten der KL9020 und KL9309 aktualisiert
1.2.0
▪
Einführung für Handbedienmodule aktualisiert
▪
Beschreibung des Status-Bytes korrigiert
▪
Kapitel Anschluss erweitert
▪
Bibliotheken aktualisiert
1.1.0
▪
Registerbeschreibungen aktualisiert
▪
Technische Daten aktualisiert
1.0.0
Erste Veröffentlichung
Firm- und Hardware-Stände
Dokumentation Version | KL8500 |  | KL8519 |  | KL8524 |  | KL8528 |  | KL8548 |  | KL9309
 | Firmw. | Hardw. | Firmw. | Hard. | Firmw. | Hardw. | Firmw. | Hardw. | Firmw. | Hardw. | Firmw. | Hardw.
2.0.0 | - | 00 | 1C | 03 | 1B | 01 | 1B | 03 | 1F | 03 | 00 | 00
1.5.0 | - | 00 | 1C | 03 | 1B | 01 | 1B | 03 | 1F | 03 | 00 | 00
1.4.0 | - | 00 | 1C | 03 | 1A | 01 | 1A | 03 | 1E | 03 | 00 | 00
1.3.0 | - | 00 | 1C | 03 | 1A | 01 | 1A | 02 | 1E | 03 | 00 | 00
1.2.0 | - | 00 | 1C | 03 | 1A | 01 | 1A | 02 | 1D | 03 | 00 | 00
1.1.0 | - | 00 | 1C | 00 | 1A | 00 | 1A | 00 | 1C | 01 | 00 | 00
1.0.0 | - | 00 | 1C | 00 | 1A | 00 | 1A | 00 | 1C | 01 | 00 | 00
Den Firm- und Hardware-Stand (Auslieferungszustand) der KL85xx können Sie der auf der Rückseite aufgedruckten Seriennummer entnehmen.
Den Firm- und Hardware-Stand (Auslieferungszustand) der KL9309 können Sie der auf der Seite aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 33 06 B1 00:
33 - Produktionswoche 33
06 - Produktionsjahr 2006
B1 - Firmware-Stand B1
00 - Hardware-Stand 00


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
KL8500
•
KL8519
•
KL8524
•
KL8528
•
KL8548
•
KL9020
•
KL9309
•
Diagnose-LEDs


Einführung

Produktübersicht [image] Einführung
Einführung
Handbedienmodul mit K-Bus-Interface
Handbedienmodule mit K-Bus-Interface
Für das Schalten, Steuern und Beobachten von digitalen und analogen Signalen wurden die Handbedienmodule entwickelt.
Sie ermöglichen das Setzen und Lesen von Daten und Werten bei Ausfall einer Steuerung.
Die Handbedienmodule erfüllen die Funktionalität einer lokalen Vorrang-Bedienung-/Anzeigeeinheit (LVB) nach EN ISO 16484-2:2004, Kapitel 5.4.3.
Der Anlagenbauer muss den Zugriffsschutz gegen unautorisierte Bedienung durch Installation geeigneter Komponenten sicher stellen (siehe EN ISO 16484-2:2004, Kapitel 5.4.3.3. - Zugriffsschutz für LVB).
Durch das Anwenderprogramm ist das Deaktivieren der manuellen Bedienung möglich. Siehe Kapitel Control- und Status-Bytes des jeweiligen Moduls.
Die Handbedienmodule lassen sich durch Snap-in-Technik in die Schaltschranktür einsetzen; ihre Verdrahtung erfolgt im Schaltschrank.
Über das K-Bus-Interface mit K-Bus-Verlängerung können bis zu 31 Module eingesetzt werden. So können die Handbedienmodule einfach in das universelle Busklemmensystem integriert werden.
Der Anschluss an die signalunabhängige Übergabeklemme KL9309 erfolgt über ein Flachbandkabel. Die Signale sind galvanisch getrennt. Power- und Error-LEDs zeigen den Status der Module an.
Durch den Einsatz in die Schaltschranktür können die Module bedient werden, ohne dass der Schaltschrank geöffnet werden muss.
Insgesamt sind fünf verschiedene Module verfügbar:
▪
KL8500 | Platzhaltermodul
▪
KL8519 | Meldemodul, 16-Kanal-Digital-Eingang
▪
KL8524 | Ausgangsmodul, 4x2-Kanal-Digital-Ausgang
▪
KL8528 | Ausgangsmodul, 8-Kanal-Digital-Ausgang
▪
KL8548 | Analogmodul, 8-Kanal-Analog-Ausgang
Hinweis
TwinCAT-Version
Die Handbedienmodule werden ab TwinCAT 2.11 R3 (Build 2221) unterstützt.
Auch ältere TwinCAT-Versionen können die Handbedienmodule unterstützen, wenn eine aktuelle Busklemmen-Konfigurationsdatei (TcTerminals) verwendet wird.
Die aktuelle Busklemmen-Konfigurationsdatei steht Ihnen auf der Beckhoff Homepage im Bereich Download/Konfigurationsdateien/Busklemmen zur Verfügung.


KL8500

Produktübersicht [image] KL8500
KL8500
Weiterführende Informationen
•
KL8500 - Einführung
•
Technische Daten


KL8500 - Einführung

Produktübersicht [image] KL8500 [image] KL8500 - Einführung
KL8500 - Einführung
KL8500
Platzhaltermodul (ohne Funktion)
Das Platzhaltermodul KL8500 können Sie in Ihren Schaltschrank einbauen um zukünftige Erweiterungen vorzubereiten.
Sie können es dann später einfach gegen ein anderes Handbedienmodul austauschen, ohne das wiederum Blecharbeiten erforderlich sind.


Technische Daten

Produktübersicht [image] KL8500 [image] Technische Daten
Technische Daten
Technische Daten | KL8500
Anzahl der Eingänge/Ausgänge | 0
Businterface | -
I/O-Anschluss | -
Diagnose LEDs | keine
Potenzialtrennung | -
Stromaufnahme Us | -
Ausgangs-Prozessabbild | -
Eingangs -Prozessabbild | -
Gewicht | ca. 90 g
Abmessungen (B x H x T) | 71mm x 127,5 mm x 75mm (Außenmaße, Einbaumaße siehe Montage)
Montage | Einbau in die Schaltschranktür
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


KL8519

Produktübersicht [image] KL8519
KL8519
Weiterführende Informationen
•
KL8519 - Einführung
•
Technische Daten


KL8519 - Einführung

Produktübersicht [image] KL8519 [image] KL8519 - Einführung
KL8519 - Einführung
KL8519
16-Kanal-Digital-Eingangs-Meldemodul
Die KL8519 ist ein 16-Kanal-Digital-Eingangs-Meldemodul. Es können 16 digitale Eingänge angeschlossen werden, die ihren Status über LEDs anzeigen und die Daten in die Steuerung übertragen. Die LEDs sind Bicolor-LEDs in den Farben Rot und Grün und können individuell auf die Bedürfnisse der Anlage parametriert werden. Die LEDs lassen sich auch von der Steuerung ansprechen.


Technische Daten

Produktübersicht [image] KL8519 [image] Technische Daten
Technische Daten
Technische Daten | KL8519
Anzahl der Eingänge | 16
Eingangsfilter | 3,0 ms
Nennspannung | 24 VDC (-15 %/+20 %)
Businterface | K-Bus-Anschluss IN/OUT
I/O-Anschluss | Flachbandkabelanschluss, 20-polig
Diagnose LEDs | zweifarbige LEDs grün/rot
Potenzialtrennung | 500 V (K-Bus)
Stromaufnahme Us | typisch 50 mA
Ausgangs-Prozessabbild | 6 Byte Daten, 1 Control-Byte
Eingangs -Prozessabbild | 6 Byte Daten, 1 Status-Byte
Gewicht | ca. 150 g
Abmessungen (B x H x T) | 71 mm x 127 mm x 69 mm (Außenmaße, Einbaumaße siehe Montage)
Montage | Einbau in die Schaltschrank Tür
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


KL8524

Produktübersicht [image] KL8524
KL8524
Weiterführende Informationen
•
KL8524 - Einführung
•
Technische Daten


KL8524 - Einführung

Produktübersicht [image] KL8524 [image] KL8524 - Einführung
KL8524 - Einführung
KL8524
4 x 2-Kanal-Digital-Ausgangsmodul
Die KL8524 ist ein 4 x 2-Kanal-Digital-Ausgangmodul, ausgestattet mit zwei Schaltern. Der eine dient der Umschaltung zwischen Hand- und Automatikbetrieb, mit dem anderen wird ein 2-Stufen-Ausgang gesetzt. Dabei kann man festlegen, wann und wie die beiden Ausgänge geschaltet werden. Der Status wird über eine Bicolor-LED in Grün und Gelb angezeigt. Die Schalterstellungen sind über die SPS auslesbar.


Technische Daten

Produktübersicht [image] KL8524 [image] Technische Daten
Technische Daten
Technische Daten | KL8524
Anzahl der Ausgänge | 2 x 4
Ausgangsstrom | 0,5 A (Summenstrom 2 A)
Nennspannung | 24 VDC (-15 %/+20 %)
Businterface | K-Bus-Anschluss IN/OUT
I/O-Anschluss | Flachbandkabelanschluss, 20-polig
Diagnose LEDs | zweifarbige LEDs grün/gelb
Schalterstellung | 4 x auto/manuell; 4 x Mode 0/1/2
Potenzialtrennung | 500 V (K-Bus)
Stromaufnahme Us | typisch 40 mA
Ausgangs-Prozessabbild | 6 Byte Daten, 1 Control-Byte
Eingangs -Prozessabbild | 6 Byte Daten, 1 Status-Byte
Gewicht | ca. 160 g
Abmessungen (B x H x T) | 71 mm x 127 mm x 69 mm (Außenmaße, Einbaumaße siehe Montage)
Montage | Einbau in die Schaltschrank Tür
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


KL8528

Produktübersicht [image] KL8528
KL8528
Weiterführende Informationen
•
KL8528 - Einführung
•
Technische Daten


KL8528 - Einführung

Produktübersicht [image] KL8528 [image] KL8528 - Einführung
KL8528 - Einführung
KL8528
8-Kanal-Digital-Ausgangsmodul
Die KL8528 ist ein 8-Kanal-Digital-Ausgangsmodul. Die Ausgänge können über einen Schalter geschaltet oder von der Steuerung vorgegeben werden. Der Status wird über eine Bicolor-LED in Grün und Gelb angezeigt. Die Schalterstellungen sind über die SPS auslesbar.


Technische Daten

Produktübersicht [image] KL8528 [image] Technische Daten
Technische Daten
Technische Daten | KL8528
Anzahl der Ausgänge | 8
Ausgangsstrom | 0,5 A (Summenstrom 2 A)
Nennspannung | 24 VDC (-15 %/+20 %)
Businterface | K-Bus-Anschluss IN/OUT
I/O-Anschluss | Flachbandkabelanschluss, 20-polig
Diagnose LEDs | zweifarbige LEDs grün/gelb
Schalterstellung | 8 x auto/off/on
Potenzialtrennung | 500 V (K-Bus)
Stromaufnahme Us | typisch 40 mA
Ausgangs-Prozessabbild | 6 Byte Daten, 1 Control-Byte
Eingangs -Prozessabbild | 6 Byte Daten, 1 Status-Byte
Gewicht | ca. 160 g
Abmessungen (B x H x T) | 71 mm x 127 mm x 69 mm (Außenmaße, Einbaumaße siehe Montage)
Montage | Einbau in die Schaltschrank Tür
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


KL8548

Produktübersicht [image] KL8548
KL8548
Weiterführende Informationen
•
KL8548 - Einführung
•
Technische Daten


KL8548 - Einführung

Produktübersicht [image] KL8548 [image] KL8548 - Einführung
KL8548 - Einführung
KL8548
8-Kanal-Analog-Ausgangsmodul 0…10 V
Die KL8548 ist ein 8-Kanal-Analog-Ausgangsmodul für 0…10 V. Die analogen Werte sind über die Steuerung oder über ein Potentiometer für jeden Kanal einzeln vorzugeben. Der tatsächliche Ausgabewert wird über einen Bargraph angezeigt. Die Stellung des Potentiometers ist in jeder Betriebsart von der Steuerung lesbar.


Technische Daten

Produktübersicht [image] KL8548 [image] Technische Daten
Technische Daten
Technische Daten | KL8548
Anzahl der Eingänge | 8 (Potentiometer)
Anzahl der Ausgänge | 8
Signalspannung | 0...10 V
Bürde | > 5 kΩ (kurzschlussfest)
Genauigkeit | ± 0,5 LSB Linearitätsfehler, ± 0,5 LSB Offsetfehler
Ausgabefehler | < ± 0,1 % (bezogen auf den Messbereichsendwert)
A/D-Wandler | 12 Bit
Nennspannung | 24 VDC (-15 %/+20 %)
Businterface | K-Bus-Anschluss IN/OUT
I/O-Anschluss | Flachbandkabelanschluss, 20-polig
Diagnose LEDs | gelb
Schalterstellung | auto/mauell, Potentiometer
Besondere Eigenschaften | Poti und Schalter über die SPS lesbar, Anzeige Analogwert über Bargraphen
Potenzialtrennung | 500 V (K-Bus)
Stromaufnahme Us | typisch 50 mA in ECO Mode, 95 mA im Full-Scale-Mode
Ausgangs-Prozessabbild | 16 Byte Daten, 8 Control-Bytes
Eingangs-Prozessabbild | 16 Byte Daten, 8 Status-Bytes
Gewicht | ca. 215 g
Abmessungen (B x H x T) | 71 mm x 127 mm x 69 mm (Außenmaße, Einbaumaße siehe Montage)
Montage | Einbau in die Schaltschrank Tür
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


KL9020

Produktübersicht [image] KL9020
KL9020
Weiterführende Informationen
•
KL9020: Endklemme mit K-Bus-Verlängerung
•
Technische Daten


KL9020: Endklemme mit K-Bus-Verlängerung

Produktübersicht [image] KL9020 [image] KL9020: Endklemme mit K-Bus-Verlängerung
KL9020: Endklemme mit K-Bus-Verlängerung
KL9020
Die Endklemme mit K-Bus-Verlängerung KL9020 wird, wie eine Standardendklemme KL9010, an das Ende des Busklemmenblocks gesteckt und schließt ihn ab.
Die KL9020 bietet die Möglichkeit, ein Ethernet-Kabel mit RJ-45-Stecker anzuschließen. Die K-Bus-Signale werden auf RS485 umgesetzt; die Versorgung erfolgt über den K-Bus.
Neben der Versorgungsspannung von 24 V und dem Einstecken des Ethernet-Kabels sind keine weiteren Parametrier- und Konfigurierarbeiten notwendig.
Alle Diagnose- und Inbetriebnahmeaufgaben übernimmt der Buskoppler.
Hinweis
Dokumentation zur K-Bus-Verlängerung
Weitere Informationen finden Sie in der Dokumentation zur K-Bus-Verlängerung (KL9020/KL9050), die Ihnen auf der Beckhoff-Homepage im Bereich Download zur Verfügung steht.


Technische Daten

Produktübersicht [image] KL9020 [image] Technische Daten
Technische Daten
Technische Daten | KL9020
Feldbus | unabhängig
Anzahl der KL9020 pro Feldbuskoppler | 1
Anschluss für K-Bus-Verlängerung | RJ-45 Buchse
Stromaufnahme aus dem K-Bus | typisch 70 mA
Konfiguration | automatisch
Spannungsfestigkeit | 500 V (Abschirmung, Grundplatte / K-Bus)
Gewicht | ca. 45 g
Abmessungen (B x H x T) | ca. 26 mm x 100 mm x 70 mm
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassungen | CE, cULus, ATEX, GL


KL9309

Produktübersicht [image] KL9309
KL9309
Weiterführende Informationen
•
KL9309 - Einführung
•
Technische Daten


KL9309 - Einführung

Produktübersicht [image] KL9309 [image] KL9309 - Einführung
KL9309 - Einführung
KL9309
Adapterklemme für Handbedienmodule
Die Adapterklemme KL9309 besitzt 16 Klemmstellen, die die I/Os der Handbedienmodule KL85xx bereitstellen. Zusätzlich wird Versorgungsspannung (24 VDC) über zwei Klemmstellen (24 V, 0 V) eingespeist. Über eine 20-polige Stiftleiste mit Verriegelung kann die Klemme über ein Systemkabel mit den Handbedienmodulen verbunden werden.
Die KL9309 ist modular aufgebaut und lässt sich nahtlos auf der Hutschiene einreihen. Die K-Bus-Kommunikation wird von der Klemme weitergeleitet, sie selbst ist allerdings für den K-Bus nicht sichtbar und wird dementsprechend auch nicht vom Buskoppler erkannt.
Die eingespeiste Versorgungsspannung wird über zwei Powerkontakte (24 V, 0 V) zu darauf folgenden Klemmen weitergeleitet und über vier Kontakte (2 x 24 V, 2 x 0 V) der 20-poligen Stiftleiste zur Spannungsversorgung der Handbedienmodule bereitgestellt.


Technische Daten

Produktübersicht [image] KL9309 [image] Technische Daten
Technische Daten
Technische Daten | KL9309
Spannungsversorgung | 24 VDC
Powerkontakte | max. 24 VDC / max. 10 A
Nennspannung Up | 24 VDC, Summenstrom max. 2 A
Businterface | K-Bus-passiv (kein Prozessabbild im K-Bus), zählt aber wie zwei K-Bus Klemmen
I/O-Anschluss | Flachbandkabelanschluss, 20-polig, 16-fach HD-Anschluss
Diagnose-LEDs | grün für Up
Besondere Eigenschaften | passive Busklemme zum Anschluss der Handbedienmodule KL85xx
Potenzialtrennung | 500 V (K-Bus)
Ausgangs-Prozessabbild | -
Eingangs -Prozessabbild | -
Gewicht | ca. 85 g
Abmessungen (B x H x T) Außenmaße | doppelte K-Bus Klemme 24 mm x 100 mm x 68 mm (ohne Stecker)
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


Diagnose-LEDs

Produktübersicht [image] Diagnose-LEDs
Diagnose-LEDs
Vorderseite
LEDs
Bedeutung der LED-Anzeigen
LED | Farbe | Zustand und Bedeutung
 |  | Ein
Us/K-Bus | grün | K-Bus-Kommunikation OK
 | rot | Us vorhanden, keine K-Bus Kommunikation
 | aus | Us nicht vorhanden, keine Spannung angelegt
Up | grün | Up angeschlossen
 | aus | Up nicht vorhanden, keine Spannung angelegt (kontrollieren Sie die Spannung an der KL9309 oder den Anschluss des 20-poligen Steckers)
Rückseite
LEDs
Bedeutung der LED-Anzeigen
LED | Farbe | Zustand und Bedeutung
 |  | Ein | aus
RUN | grün | Leuchtet schwach bis stark: K-Bus-Kommunikation OK | keine K-Bus-Kommunikation
ERR | rot | keine K-Bus-Kommunikation | kein Fehler


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Abmessungen
•
Montageausschnitt
•
Tragschienenmontage
•
Anschluss der Handbedienmodule
•
Spannungsversorgung
•
Anschlussbilder der 20-poligen Steckverbinder
•
Beschriftung
•
Bestellinformationen


Abmessungen

Montage und Verdrahtung [image] Abmessungen
Abmessungen
Abmessungen
Hinweis
Montageausschnitt und Steckverbinder
Der Montageausschnitt sollte eine Größe von 67 mm x 116,2 mm haben. Beachten Sie, dass hinter dem Modul genügend Platz für die Steckverbinder ist.


Montageausschnitt

Montage und Verdrahtung [image] Montageausschnitt
Montageausschnitt
Der Montageausschnitt sollte eine Größe von 67 mm x 116,2 mm haben.
Montageausschnitt
Hinweis
Positionierung ist abhängig von der Wandstärke der Montagefläche
Die Grafik zeigt, dass sich beim Einbau in die Montagefläche in Abhängigkeit der Wandstärke unterschiedliche Montagehöhen ergeben.


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschluss der Handbedienmodule

Montage und Verdrahtung [image] Anschluss der Handbedienmodule
Anschluss der Handbedienmodule
Anschluss der Handbedienmodule über K-Bus-Verlängerung und Flachbandkabel
Montage
Beachten Sie bei der Montage die Hinweise im Kapitel Tragschienenmontage.
1.
Vergewissern Sie sich, dass sich das System in einem sicheren, spannungslosen Zustand befindet.
2.
Montieren Sie den ersten Busklemmenblock, bestehend aus dem Feldbuskoppler und den gewünschten Busklemmen auf einer Tragschiene.
Montieren Sie anstelle einer Standardendklemme (KL9010) eine Endklemme mit RJ45-Buchse (KL9020) als letzte Klemme am Ende des ersten Busklemmenblocks.
3.
Montieren Sie das erste Handbedienmodul.
4.
Stecken Sie einen RJ45-Stecker eines Ethernet-Kabels bis er hörbar einrastet in die RJ45-Buchse der KL85xx.
Stecken Sie den anderen RJ45-Stecker des Ethernet-Kabels bis er hörbar einrastet in die mit IN beschriftetet RJ45-Buchse der KL85xx.
5.
Montieren Sie das nächste Handbedienmodul.
6.
Stecken Sie einen RJ45-Stecker eines Ethernet-Kabels bis er hörbar einrastet in die mit OUT beschriftete RJ45-Buchse der KL85xx des vorherigen Handbedienmoduls.
Stecken Sie den anderen RJ45-Stecker des Ethernet-Kabels bis er hörbar einrastet in die mit IN beschriftetet RJ45-Buchse der KL85xx des hinzugefügten Handbedienmodul.
7.
Wiederholen Sie die Schritte 5 und 6 um weitere Erweiterungsklemmenblöcke anzuschließen. Es lassen sich maximal 31 Erweiterungsklemmenblöcke anschließen.
8.
Stellen Sie auf allen Kopplerklemmen (KL85xx/KL9050) den Schalter Function Switch korrekt ein.
Function Switch
Aktivieren Sie den Endwiderstand am letzten Erweiterungsklemmenblock Ihres K-Bus-Verlängerungs-Systems, indem Sie den auf der letzten Kopplerklemme (KL85xx/KL9050) befindlichen Schalter Function Switch in Stellung Last stellen.
WARNUNG
Korrekte Einstellung des Schalters Function Switch
Stellen Sie unbedingt die korrekte Einstellung des Schalters Function Switch aller Kopplerklemmen (KL9050) eines K-Bus-Verlängerungssystems sicher:
Auf jeder Kopplerklemme (KL85xx/KL9050) an der ein weiterführendes Ethernet-Kabel angeschlossen ist, muss der Schalter Function Switch in Stellung Next stehen! (Siehe folgendes Bild)
Nur an der letzten Kopplerklemme (KL85xx/KL9050) des K-Bus-Verlängerungssystems darf der Schalter Function Switch in Stellung Last stehen! (Siehe folgendes Bild)
Alle Erweiterungsklemmenblöcke, die hinter einer Kopplerklemme (KL85xx/KL9050) angeschlossen sind, deren Schalter Function Switch in Stellung Last steht, gehen nicht regulär in das Prozessabbild ein:
- Die Eingänge dieser Klemmen sind im Prozessabbild nicht sichtbar!
- Die Ausgänge dieser Klemmen werden nicht von dem Prozessabbild kontrolliert!
Sorgen Sie auch beim Austausch von Kopplerklemmen (KL85xx/KL9050) für die korrekte Stellung der Schalter Function Switch!
Function Switch
Demontage
Beachten Sie bei der Demontage die Hinweise im Kapitel Tragschienenmontage.
1.
Vergewissern Sie sich, dass sich das System in einem sicheren, spannungslosen Zustand befindet.
2.
Drücken Sie die Kunststoffverriegelung des RJ45-Steckers und ziehen Sie ihn aus der Buchse heraus.
3.
Ziehen Sie vorsichtig die orangefarbige Lasche ca. 1 cm aus der zu demontierenden Klemme heraus, bis die Lasche locker hervorsteht. Jetzt ist für diese Klemme die Verriegelung mit der Tragschiene gelöst und die Klemme kann ohne großen Kraftaufwand von der Tragschiene gezogen werden.
4.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen Sie die Klemme von der Tragschiene weg.


Spannungsversorgung

Montage und Verdrahtung [image] Spannungsversorgung
Spannungsversorgung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Achtung
Verbinden Sie die Massen der Spannungsversorgungen des Buskopplers und aller Handbedienmodule niederohmig miteinander
Für den störsicheren Betrieb der K-Bus-Verlängerung muss die Masse der K-Bus-Spannungsversorgung des übergeordneten Feldbuskopplers niederohmig mit der Masse der Spannungsversorgungen aller Handbedienmodule verbunden werden (siehe Bild)!
Spannungsversorgung mit niederohmig verbundenen Massen


Anschlussbilder der 20-poligen Steckverbinder

Montage und Verdrahtung [image] Anschlussbilder der 20-poligen Steckverbinder
Anschlussbilder der 20-poligen Steckverbinder
KL8519
Anschlussbild des 20-poligen Steckverbinders auf der Rückseite des KL8519.
KL8519 - Anschluss des 20-poligen Steckverbinders
KL8524
Anschlussbild des 20-poligen Steckverbinders auf der Rückseite des KL8524.
KL8524 - Anschluss des 20-poligen Steckverbinders
KL8528
Anschlussbild des 20-poligen Steckverbinders auf der Rückseite des KL8528.
KL8528 - Anschluss des 20-poligen Steckverbinders
KL8548
Anschlussbild des 20-poligen Steckverbinders auf der Rückseite des KL8548.
KL8548 - Anschluss des 20-poligen Steckverbinders
KL9309
Anschlussbild des 20-poligen Steckverbinders auf der Vorderseite der KL9309.
KL9309 - Anschluss des 20-poligen Steckverbinders


Beschriftung

Montage und Verdrahtung [image] Beschriftung
Beschriftung
Diese Dokumentation enthält eine Word-Datei mit Vorlagen zur Beschriftung der Schaltschrankmodule:
Achten Sie beim Ausdruck darauf, dass Ihr Drucker die Seitengröße nicht skaliert, damit die Beschriftungsstreifen ihre originale Größe beibehalten.


Bestellinformationen

Montage und Verdrahtung [image] Bestellinformationen
Bestellinformationen
K-Bus-Verlängerung
Bestellbezeichnung | Beschreibung
KL9020 | Endklemme mit RJ45-Buchse zur K-Bus-Verlängerung
ZK1090-0101-1005 | K-Bus-Verlängerungskabel mit zwei vorkonfektionierten Steckern, doppelt geschirmt, grau, 50 cm
ZK1090-0101-1010 | K-Bus-Verlängerungskabel mit zwei vorkonfektionierten Steckern, doppelt geschirmt, grau, 100 cm
ZK1090-0101-1020 | K-Bus-Verlängerungskabel mit zwei vorkonfektionierten Steckern, doppelt geschirmt, grau, 200 cm
ZK1090-0101-1030 | K-Bus-Verlängerungskabel mit zwei vorkonfektionierten Steckern, doppelt geschirmt, grau, 300 cm
ZK1090-0101-1050 | K-Bus-Verlängerungskabel mit zwei vorkonfektionierten Steckern, doppelt geschirmt, grau, 500 cm
Sensor-/Aktor-Kabel von KL85xx zu KL9303
Bestellbezeichnung | Beschreibung
ZK8500-8282-7030 | PVC-Kabel, 20 x 0,14 mm², Steckverbinder beidseitig für KL85xx, KL9309 und Klemmen mit Flachbandkabel Anschluss, Länge 3 m, geschirmt
ZK8500-8282-7040 | PVC-Kabel, 20 x 0,14 mm², Steckverbinder beidseitig für KL85xx, KL9309 und Klemmen mit Flachbandkabel Anschluss, Länge 4 m, geschirmt
ZK8500-8282-7050 | PVC-Kabel, 20 x 0,14 mm², Steckverbinder beidseitig für KL85xx, KL9309 und Klemmen mit Flachbandkabel Anschluss, Länge 5 m, geschirmt


Programmierung in TwinCAT

Programmierung in TwinCAT
Programmierung in TwinCAT
Weiterführende Informationen
•
Erforderliche Bibliotheken
•
Funktionsbausteine
•
Datentypen
•
Fehler-Codes
•
Anpassung der LED-Anzeigen


Erforderliche Bibliotheken

Programmierung in TwinCAT [image] Erforderliche Bibliotheken
Erforderliche Bibliotheken
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Programmierung in TwinCAT [image] Erforderliche Bibliotheken [image] TwinCAT 2
TwinCAT 2
Hinweis
Installation
Ab TwinCAT 2.11 Build 2251 (R3 und x64 Engineering) werden die Bibliotheken "TcKL85xx.lib/.lb6/.lbx" standardmäßig mitinstalliert.
Weitere erforderliche Bibliotheken
Für PC-Systeme (x86) und Embedded-PCs (CXxxxx):
▪
Standard.lib
Für Busklemmen-Controller der Serie BCxx00:
▪
Standard.lb6
Für Busklemmen-Controller der Serie BCxx50, BCxx20 und BC9191:
▪
Standard.lbx
Für Busklemmen-Controller der Serie BXxx00:
▪
Standard.lbx
Hinweis
Speicherauslastung
Durch Einbinden der Bibliothek wird bereits SPS-Programmspeicher verbraucht. Abhängig vom Applikationsprogramm kann daher der verbleibende Speicher nicht ausreichend sein.
Download für CX9000 ( )
benötigte Bibliotheken:
▪
Standard.lib
▪
TcKL85xx.lib
Download für BX9000 (seriell) ( )
benötigte Bibliotheken:
▪
Standard.lbx
▪
TcKL85xx.lbx
Download für BC9000 (seriell) ( )
benötigte Bibliotheken:
▪
Standard.lb6
▪
TcKL85xx.lb6
Download für BC9050 (seriell) ( )
benötigte Bibliotheken:
▪
Standard.lbx
▪
TcKL85xx.lbx


TwinCAT 3

Programmierung in TwinCAT [image] Erforderliche Bibliotheken [image] TwinCAT 3
TwinCAT 3
Hinweis
Installation
Ab TwinCAT 3.1.4020.14 wird die Bibliotheken „Tc2_KL85xx“ standardmäßig mitinstalliert.


Funktionsbausteine

Programmierung in TwinCAT [image] Funktionsbausteine
Funktionsbausteine
Übersicht
Funktionsbaustein | Beschreibung
FB_KL8519 | Baustein zum Konfigurieren der KL8519, zum Auslesen der digitalen Signale und zum Setzen der LEDs.
FB_KL8524 | Baustein zum Konfigurieren der KL8524, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/LEDs.
FB_KL8524Ex | Baustein zum Konfigurieren der KL8524, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/LEDs.
FB_KL8528 | Baustein zum Konfigurieren der KL8528, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/LEDs.
FB_KL8528Ex | Baustein zum Konfigurieren der KL8528, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/LEDs.
FB_KL8548 | Baustein zum Konfigurieren der KL8548, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/LEDs.
FB_KL8548Ex | Baustein zum Konfigurieren der KL8548, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/LEDs.
FB_KL85xx16BitToWord | Umwandlung von 16 Bit in 1 Word
FB_KL85xx8BitToByte | Umwandlung von 8 Bit in 1 Byte
FB_KL85xxByteTo8Bit | Umwandlung von einem Byte in 8 Bit.
FB_KL85xxWordTo16Bit | Umwandlung von einem Word in 16 Bit.
Weiterführende Informationen
•
KL8519
•
KL8524
•
KL8528
•
KL8548
•
KL85xx - Helper


KL8519

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL8519
KL8519
Bausteine | Beschreibung
FB_KL8519 | Baustein zum Konfigurieren der KL8519, zum Auslesen der digitalen Signale und zum Setzen der LEDs.
Weiterführende Informationen
•
FB_KL8519


FB_KL8519

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL8519 [image] FB_KL8519
FB_KL8519
Funktionsbaustein FB_KL8519
Anwendung
Dieser Baustein dient zum Konfigurieren der KL8519, zum Auslesen der digitalen Signale und zum Setzen der LEDs.
Der Baustein muss einmal pro Zyklus aufgerufen werden.
Mit einer positiven Flanke von bExecCfg werden die Parameter zur Klemme übertragen.
Die Variable wDisCh schaltet die Standardfunktion der LEDs aus. Die LEDs können jetzt unabhängig vom digitalen Eingangssignal über die PLC geschaltet werden, mit den Variablen wLEDGn oder wLEDRd. Hier kann jede LED einzeln verändert werden.
Die Variable wSetCol legt fest, wie die LED leuchten soll, wenn der Eingang belegt ist. Bei "0" wird die LED grün, bei "1" wird die LED rot. Ist der Eingang nicht belegt bleibt die LED aus.
Die Variable wInv invertiert das Verhalten der LED. Ist der Eingang "FALSE" geht die LED an, bei "TRUE" geht die LED aus.
Mit der Variablen wBiCol kann zwischen grün und rot umgeschaltet werden. Bei "1" und dem Eingang "FALSE" wird die LED rot und bei TRUE grün. Mit der Variablen wInv kann man das ganze umkehren.
Die Variable eKBusOff legt fest, wie sich die LEDs bei K-Bus Fehler (oder PLC gestoppt) verhalten sollen, wenn diese von der PLC angesteuert werden. Bei "0" (eKL8519_WatchdogOff) bleiben die LEDs aus, bei "1" (eKL8519_Watchdog500ms) wird der letzte Zustand der LED mit 500 ms getoggelt und bei "2" (Watchdog1000ms) mit einer Sekunde.
VAR_INPUT
bEn : BOOL;
bExecCfg : BOOL;
wDisCh : WORD;
wSetCol : WORD;
wInv : WORD;
wBiCol : WORD;
eKBusOff : E_KL8519_KBusOffReact;
dwOpt : DWORD;
wLEDGn : WORD;
wLEDRd : WORD;
bEn: Mit bEn = TRUE wird der Baustein vom PLC-Programm freigegeben. Mit bEn = FALSE wird die Abarbeitung des Bausteins gestoppt und alle Ausgänge werden zurückgesetzt.
bExecCfg: Die Konfigurationen wDisCh, wSetCol, wInv, wBiCol und eKBusOff werden auf positiver Flanke in die Klemmen geschrieben. bBusy wird TRUE. Es ist zu beachten, dass in dieser Zeit die Eingänge nicht aktualisiert werden.
wDisCh: Konfiguration: Abwahl der Standardfunktion der LEDs. Die LEDs können von der PLC gesetzt werden. Bit 0 = LED 1, ... , Bit 15 = LED 16. Mit 65535dez (FFFFhex) wird bei allen LEDs die Standardfunktion deaktiviert. Diese können dann über wLEDGn oder wLEDRd von der PLC aus gesetzt werden.
wSetCol: Konfiguration: Mit dieser Variablen können Sie für die Status-LEDs der einzelnen Kanäle die Farbe festlegen (0=grün oder 1=rot). Mit 65535dez (FFFFhex) werden alle LEDs rot, wenn der Eingang belegt ist.
wInv: Konfiguration: Mit dieser Variablen können Sie die Anzeige der Status-LEDs der einzelnen Kanäle invertieren. Die zur SPS übertragenen Prozessdaten (Eingangssignale) werden dadurch nicht beeinflusst.
wBiCol: Konfiguration: Mit dieser Variablen können Sie die Anzeige der Status-LEDs der einzelnen Kanäle zweifarbig schalten. Eingang unbelegt - LED ist rot, Eingang belegt - LED ist grün oder umgekehrt, wenn wInv aktiv.
eKBusOff: Konfiguration: Bei K-Bus Fehler gehen alle LEDs, die über die PLC gesetzt worden sind aus, es sei denn in hier steht ein anderer Wert als 00bin. Die Standardfunktion der LEDs muss dazu mit wDisCh abgewählt worden sein.
dwOpt: Für zukünftige Optionen.
wLEDGn: Bit 0 = TRUE, ... , Bit 15 = TRUE setzt die grünen LEDs, vorausgesetzt, die Standardfunktion der LED wurde mit wDisCh abgewählt. Mit 65535dez (FFFFhex) werden alle grünen LEDs gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx16BitToWord zum Aufbereiten der Signale zur Verfügung.
wLEDRd: Bit 0 = TRUE, ... , Bit 15 = TRUE setzt die roten LEDs, vorausgesetzt, die Standardfunktion der LED wurde mit wDisCh abgewählt. Mit 65535dez (FFFFhex) werden alle roten LEDs gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx16BitToWord zum Aufbereiten der Signale zur Verfügung.
VAR_OUTPUT
bBusy : BOOL;
wStaIn : WORD;
bErr : BOOL;
udiErrID : UDINT;
bBusy: bBusy ist TRUE, solange die Konfiguration geschrieben wird (Start mit bExecCfg). Es ist zu beachten, dass in dieser Zeit die Eingänge nicht aktualisiert werden.
wStaIn: Status der digitalen Eingangssignale. Bit 0 = Eingang 1, ... , Bit 15 Eingang 16. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xxWordTo16Bit zum Aufbereiten der Signale zur Verfügung.
bErr: Der bErr Ausgang wird TRUE sobald ein Fehler auftritt. Dieser Fehler wird über die Variable udiErrID beschrieben.
udiErrID: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe Fehlercodes). Gleichzeitig wird bError TRUE.
VAR_IN_OUT
stInData : ST_KL8519InData;
stOutData : ST_KL8519OutData;
stInData: Prozessabbild der Eingänge (siehe ST_KL8519InData).
stOutData: Prozessabbild der Ausgänge (siehe ST_KL8519OutData).


KL8524

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL8524
KL8524
Bausteine | Beschreibung
FB_KL8524 | Baustein zum Konfigurieren der KL8524, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/LEDs.
Weiterführende Informationen
•
FB_KL8524
•
FB_KL8524Ex


FB_KL8524

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL8524 [image] FB_KL8524
FB_KL8524
Funktionsbaustein FB_KL8524
Anwendung
Dieser Baustein dient zum Konfigurieren der KL8524, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/ LEDs.
Der Baustein muss einmal pro Zyklus aufgerufen werden.
Mit einer positiven Flanke von bExecCfg werden die Parameter zur Klemme übertragen.
Die Variable byDisCh schaltet die Standardfunktion der LEDs aus. Die LEDs können jetzt unabhängig vom digitalen Eingangssignal über die PLC geschaltet werden, mit den Variablen byLEDGn oder byLEDYe. Hier kann jede LED einzeln verändert werden.
Mit byKBusOff kann bei K-Bus Fehler (oder PLC gestoppt) und Schalterstellung "auto" der jeweilige Ausgang auf "TRUE" gesetzt werden. Bit 0..7 für die Ausgänge 1..8. Ist das Flag in byKBusOff nicht gesetzt geht der Ausgang bei K-Bus Fehler (oder PLC gestoppt) auf "FALSE".
VAR_INPUT
bEn : BOOL;
bExecCfg : BOOL;
byDisCh : BYTE := 0;
byKBusOff : BYTE := 0;
byOutMode : BYTE;
byTurnOnDelayCh1 : BYTE;
byTurnOnDelayCh2 : BYTE;
byTurnOnDelayCh3 : BYTE;
byTurnOnDelayCh4 : BYTE;
byOut : BYTE;
byLEDGn : BYTE;
byLEDYe : BYTE;
dwOpt : DWORD := 0;
bEn: Mit bEn = TRUE wird der Baustein vom SPS-Programm freigegeben. Mit bEn = FALSE wird die Abarbeitung des Bausteins gestoppt und alle Ausgänge werden zurückgesetzt.
bExecCfg: Die Konfigurationen byDisCh, byKBusOff, byOutMode, byTurnOnDelayCh1, byTurnOnDelayCh2, byTurnOnDelayCh3 und byTurnOnDelayCh4 werden in die Klemmen geschrieben. bBusy wird TRUE. Es ist zu beachten, dass in dieser Zeit die Ein-/Ausgänge nicht aktualisiert werden.
byDisCh: Konfiguration: Abwahl der Standardfunktion der LEDs. Die LEDs können von der PLC gesetzt werden. Bit 0 = LED 1, ... , Bit 7 = LED 8. Mit 255dez (FFhex) wird bei allen LEDs die Standardfunktion deaktiviert. Diese können dann über byLEDGn oder byLEDYe von der PLC aus gesetzt werden.
byKBusOff: Konfiguration: Reaktion der Ausgänge bei K-Bus Fehler. Mit Bit 0 = Ausgang 1, ... , Bit 7 = Ausgang 8 wird im K-Bus Fehlerfall (oder PLC gestoppt) der jeweilige Ausgang gesetzt, vorausgesetzt, der Schalter steht auf "auto". Hinweis: einem Kanal sind 2 Ausgänge zugeordnet und pro Kanal darf immer nur ein Ausgang angesteuert werden. Wird z. B. der Wert 255dez (FFhex) übergeben, wird bei Stopp der PLC kein Ausgang gesetzt.
byOutMode: Konfiguration: Die einem Kanal zugeordneten Ausgänge können in 2 Varianten gesetzt werden. Bit 0 = FALSE = Kanal 1 Ausgangsmodus 1, Bit 0 = TRUE = Kanal 1 Ausgangsmodus 2, ... , Bit 3 = FALSE = Kanal 4 Ausgangsmodus 1, Bit 3 = TRUE = Kanal 4 Ausgangsmodus 2.
Ausgangsmodus 1: Ausgang 1 wird geschaltet, wenn Dreistufenschalter in Stellung 1, Ausgang 2 wird geschaltet, wenn Dreistufenschalter in Stellung 2
Ausgangsmodus 2: Ausgang 1 wird geschaltet, wenn Dreistufenschalter in Stellung 1 oder Stellung 2, Ausgang 2 wird geschaltet, wenn Dreistufenschalter in Stellung 2, nach einer Verzögerung, einstellbar mit byTurnOnDelayChx.
byTurnOnDelayCh1: Konfiguration: Umschaltzeit für Kanal 1 Ausgangsmodus 2. 1 Bit = 10 ms -> bei Vorgabe 255dez, FFhex wird der 2.Ausgang nach 2550ms zugeschaltet, wenn der Dreistufenschalter in Stellung 2 steht.
byTurnOnDelayCh2: Konfiguration: Umschaltzeit für Kanal 2 Ausgangsmodus 2. 1 Bit = 10 ms -> bei Vorgabe 255dez, FFhex wird der 2.Ausgang nach 2550ms zugeschaltet, wenn der Dreistufenschalter in Stellung 2 steht.
byTurnOnDelayCh3: Konfiguration: Umschaltzeit für Kanal 3 Ausgangsmodus 2. 1 Bit = 10 ms -> bei Vorgabe 255dez, FFhex wird der 2.Ausgang nach 2550ms zugeschaltet, wenn der Dreistufenschalter in Stellung 2 steht.
byTurnOnDelayCh4: Konfiguration: Umschaltzeit für Kanal 4 Ausgangsmodus 2. 1 Bit = 10 ms -> bei Vorgabe 255dez, FFhex wird der 2.Ausgang nach 2550ms zugeschaltet, wenn der Dreistufenschalter in Stellung 2 steht.
byOut: Bit 0 = TRUE, ... , Bit 7 = TRUE setzt den jeweiligen Ausgang, vorausgesetzt, der Schalter steht auf "auto". Mit 255dez (FFhex) werden alle Ausgänge gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
byLEDGn: Bit 0 = TRUE, ... , Bit 7 = TRUE setzt die grünen LEDs, vorausgesetzt, die Standardfunktion der LEDs wurde mit byDisCh abgewählt. Mit 255dez (FFhex) werden alle grünen LEDs gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
byLEDYe: Bit 0 = TRUE, ... , Bit 7 = TRUE setzt die gelben LEDs, vorausgesetzt, die Standardfunktion der LEDs wurde mit byDisCh abgewählt. Mit 255dez (FFhex) werden alle gelben LEDs gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
dwOpt: Für zukünftige Optionen.
VAR_OUTPUT
bBusy : BOOL;
byStatSwiAuto : BYTE;
byStatSwi : BYTE;
byStatOut : BYTE;
bErr : BOOL;
udiErrID : UDINT;
bBusy: bBusy ist TRUE, solange die Konfiguration geschrieben wird (Start mit bExecCfg). Es ist zu beachten, dass in dieser Zeit die Eingänge nicht aktualisiert werden.
byStatSwiAuto: Status des Schalters "auto". Bit 0 = Kanal 1, ... , Bit 3 Kanal 4. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xxByteTo8Bit zum Aufbereiten der Signale zur Verfügung.
byStatSwi: Status der Dreistufenschalter. Bit 0 = Kanal 1 Stellung 1, Bit 1 = Kanal 1 Stellung 2 ... , Bit 7 = Kanal 4 Stellung 2. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xxByteTo8Bit zum Aufbereiten der Signale zur Verfügung.
byStatOut: Status der digitalen Ausgangssignale. Bit 0 = Kanal 1 Ausgang 1, Bit 1 = Kanal 1 Ausgang 2, ... , Bit 7 = Kanal 4 Ausgang 2,. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xxByteTo8Bit zum Aufbereiten der Signale zur Verfügung.
bErr: Der bErr Ausgang wird TRUE sobald ein Fehler auftritt. Dieser Fehler wird über die Variable udiErrID beschrieben.
udiErrID: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe Fehlercodes). Gleichzeitig wird bError TRUE.
VAR_IN_OUT
stInData : ST_KL8524InData;
stOutData : ST_KL8524OutData;
stInData: Prozessabbild der Eingänge (siehe ST_KL8524InData).
stOutData: Prozessabbild der Ausgänge (siehe ST_KL8524OutData).


FB_KL8524Ex

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL8524 [image] FB_KL8524Ex
FB_KL8524Ex
Funktionsbaustein FB_KL8524Ex
Anwendung
Dieser Baustein dient zum Konfigurieren der KL8524, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/ LEDs.
Der Baustein muss einmal pro Zyklus aufgerufen werden.
Mit einer positiven Flanke von bExecCfg werden die Parameter zur Klemme übertragen.
Die Variable byDisCh schaltet die Standardfunktion der LEDs aus. Die LEDs können jetzt unabhängig vom digitalen Eingangssignal über die PLC geschaltet werden, mit den Variablen byLEDGn oder byLEDYe. Hier kann jede LED einzeln verändert werden.
Mit byKBusOff kann bei K-Bus Fehler (oder PLC gestoppt) und Schalterstellung "auto" der jeweilige Ausgang auf "TRUE" gesetzt werden. Bit 0..7 für die Ausgänge 1..8. Ist das Flag in byKBusOff nicht gesetzt geht der Ausgang bei K-Bus Fehler (oder PLC gestoppt) auf "FALSE".
VAR_INPUT
bEn : BOOL;
bExecCfg : BOOL;
byDisCh : BYTE := 0;
byKBusOff : BYTE := 0;
byOutMode : BYTE;
byTurnOnDelayCh1 : BYTE;
byTurnOnDelayCh2 : BYTE;
byTurnOnDelayCh3 : BYTE;
byTurnOnDelayCh4 : BYTE;
byOut : BYTE;
byLEDGn : BYTE;
byLEDYe : BYTE;
bDisManMode : BOOL;
dwOpt : DWORD := 0;
bEn: Mit bEn = TRUE wird der Baustein vom SPS-Programm freigegeben. Mit bEn = FALSE wird die Abarbeitung des Bausteins gestoppt und alle Ausgänge werden zurückgesetzt.
bExecCfg: Die Konfigurationen byDisCh, byKBusOff, byOutMode, byTurnOnDelayCh1, byTurnOnDelayCh2, byTurnOnDelayCh3 und byTurnOnDelayCh4 werden in die Klemmen geschrieben. bBusy wird TRUE. Es ist zu beachten, dass in dieser Zeit die Ein-/Ausgänge nicht aktualisiert werden.
byDisCh: Konfiguration: Abwahl der Standardfunktion der LEDs. Die LEDs können von der PLC gesetzt werden. Bit 0 = LED 1, ... , Bit 7 = LED 8. Mit 255dez (FFhex) wird bei allen LEDs die Standardfunktion deaktiviert. Diese können dann über byLEDGn oder byLEDYe von der PLC aus gesetzt werden.
byKBusOff: Konfiguration: Reaktion der Ausgänge bei K-Bus Fehler. Mit Bit 0 = Ausgang 1, ... , Bit 7 =Ausgang 8 wird im K-Bus Fehlerfall (oder PLC gestoppt) der jeweilige Ausgang gesetzt, vorausgesetzt, der Schalter steht auf "auto". Hinweis: einem Kanal sind 2 Ausgänge zugeordnet und pro Kanal darf immer nur ein Ausgang angesteuert werden. Wird z. B. der Wert 255dez (FFhex) übergeben, wird bei Stopp der PLC kein Ausgang gesetzt.
byOutMode: Konfiguration: Die einem Kanal zugeordneten Ausgänge können in 2 Varianten gesetzt werden. Bit 0 = False = Kanal 1 Ausgangsmodus 1, Bit 0 = True = Kanal 1 Ausgangsmodus 2, ... , Bit 3 = False = Kanal 4 Ausgangsmodus 1, Bit 3 = True = Kanal 4 Ausgangsmodus 2.
Ausgangsmodus 1: Ausgang 1 wird geschaltet, wenn Dreistufenschalter in Stellung 1, Ausgang 2 wird geschaltet, wenn Dreistufenschalter in Stellung 2.
Ausgangsmodus 2: Ausgang 1 wird geschaltet, wenn Dreistufenschalter in Stellung 1 oder Stellung 2, Ausgang 2 wird geschaltet, wenn Dreistufenschalter in Stellung 2, nach einer Verzögerung, einstellbar mit byTurnOnDelayChx.
byTurnOnDelayCh1: Konfiguration: Umschaltzeit für Kanal 1 Ausgangsmodus 2. 1 Bit = 10 ms -> bei Vorgabe 255dez, FFhex wird der 2. Ausgang nach 2550 ms zugeschaltet, wenn der Dreistufenschalter in Stellung 2 steht.
byTurnOnDelayCh2: Konfiguration: Umschaltzeit für Kanal 2 Ausgangsmodus 2. 1 Bit = 10 ms -> bei Vorgabe 255dez, FFhex wird der 2. Ausgang nach 2550 ms zugeschaltet, wenn der Dreistufenschalter in Stellung 2 steht.
byTurnOnDelayCh3: Konfiguration: Umschaltzeit für Kanal 3 Ausgangsmodus 2. 1 Bit = 10 ms -> bei Vorgabe 255dez, FFhex wird der 2. Ausgang nach 2550 ms zugeschaltet, wenn der Dreistufenschalter in Stellung 2 steht.
byTurnOnDelayCh4: Konfiguration: Umschaltzeit für Kanal 4 Ausgangsmodus 2. 1 Bit = 10 ms -> bei Vorgabe 255dez, FFhex wird der 2. Ausgang nach 2550 ms zugeschaltet, wenn der Dreistufenschalter in Stellung 2 steht.
byOut: Bit 0 = true, ... , Bit 7 =true setzt den jeweiligen Ausgang, vorausgesetzt, der Schalter steht auf "auto". Mit 255dez (FFhex) werden alle Ausgänge gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
byLEDGn: Bit 0 = true, ... , Bit 7 =true setzt die grünen LEDs, vorausgesetzt, die Standardfunktion der LEDs wurde mit byDisCh abgewählt. Mit 255dez (FFhex) werden alle grünen LEDs gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
byLEDYe: Bit 0 = true, ... , Bit 7 =true setzt die gelben LEDs, vorausgesetzt, die Standardfunktion der LEDs wurde mit byDisCh abgewählt. Mit 255dez (FFhex) werden alle gelben LEDs gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
bDisManMode: Sperren des Handbedienmodus.
dwOpt: Für zukünftige Optionen.
VAR_OUPUT
bBusy : BOOL;
byStatSwiAuto : BYTE;
byStatSwi : BYTE;
byStatOut : BYTE;
bManModelsDis : BOOL;
wFirmVer : WORD;
bErr : BOOL;
udiErrID : UDINT;
bBusy: bBusy ist TRUE, solange die Konfiguration geschrieben wird (Start mit bExecCfg). Es ist zu beachten, dass in dieser Zeit die Eingänge nicht aktualisiert werden.
byStatSwiAuto: Status des Schalters "auto". Bit 0 = Kanal 1, ... , Bit 3 Kanal 4. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xxByteTo8Bit zum Aufbereiten der Signale zur Verfügung.
byStatSwi: Status der Dreistufenschalter. Bit 0 = Kanal 1 Stellung 1, Bit 1 = Kanal 1 Stellung 2 ... , Bit 7 = Kanal 4 Stellung 2. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xxByteTo8Bit zum Aufbereiten der Signale zur Verfügung.
byStatOut: Status der digitalen Ausgangssignale. Bit 0 = Kanal 1 Ausgang 1, Bit 1 = Kanal 1 Ausgang 2, ... , Bit 7 = Kanal 4 Ausgang 2,. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xxByteTo8Bit zum Aufbereiten der Signale zur Verfügung.
bManModelsDis: Handbedienmodus gesperrt.
wFirmVer: Gibt die Firmware Version aus.
bErr: Der bErr Ausgang wird TRUE sobald ein Fehler auftritt. Dieser Fehler wird über die Variable udiErrID beschrieben.
udiErrID: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe Fehlercodes). Gleichzeitig wird bError TRUE.
VAR_IN_OUT
stInData : ST_KL8524InData;
stOutData : ST_KL8524OutData;
stInData: Prozessabbild der Eingänge (siehe ST_KL8524InData).
stOutData: Prozessabbild der Ausgänge (siehe ST_KL8524OutData).


KL8528

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL8528
KL8528
Bausteine | Beschreibung
FB_KL8528 | Baustein zum Konfigurieren der KL8528, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/LEDs.
Weiterführende Informationen
•
FB_KL8528
•
FB_KL8528Ex


FB_KL8528

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL8528 [image] FB_KL8528
FB_KL8528
Funktionsbaustein FB_KL8528
Anwendung
Dieser Baustein dient zum Konfigurieren der KL8528, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/ LEDs.
Der Baustein muss einmal pro Zyklus aufgerufen werden.
Mit einer positiven Flanke von bExecCfg werden die Parameter zur Klemme übertragen.
Die Variable byDisCh schaltet die Standardfunktion der LEDs aus. Die LEDs können jetzt unabhängig vom digitalen Eingangssignal über die PLC geschaltet werden, mit den Variablen byLEDGn oder byLEDYe. Hier kann jede LED einzeln verändert werden.
Mit byKBusOff kann bei K-Bus Fehler (oder PLC gestoppt) und Schalterstellung "auto" der jeweilige Ausgang auf "TRUE" gesetzt werden. Bit 0..7 für die Ausgänge 1..8. Ist das Flag in byKBusOff nicht gesetzt geht der Ausgang bei K-Bus Fehler (oder PLC gestoppt) auf "FALSE".
VAR_INPUT
bEn : BOOL;
bExecCfg : BOOL;
byDisCh : BYTE;
byKBusOff : BYTE;
byOut : BYTE;
byLEDGn : BYTE;
byLEDYe : BYTE;
dwOpt : DWORD;
bEn: Mit bEn = TRUE wird der Baustein vom SPS-Programm freigegeben. Mit bEn = FALSE wird die Abarbeitung des Bausteins gestoppt und alle Ausgänge werden zurückgesetzt.
bExecCfg: Die Konfigurationen byDisCh und byKBusOff werden auf positiver Flanke in die Klemmen geschrieben. bBusy wird TRUE. Es ist zu beachten, dass in dieser Zeit die Ein-/Ausgänge nicht aktualisiert werden.
byDisCh: Konfiguration: Abwahl der Standardfunktion der LEDs. Die LEDs können von der PLC gesetzt werden. Bit 0 = LED 1, ... , Bit 7 = LED 8. Mit 255dez (FFhex) wird bei allen LEDs die Standardfunktion deaktiviert. Diese können dann über byLEDGn oder byLEDYe von der PLC aus gesetzt werden.
byKBusOff: Konfiguration: Reaktion der Ausgänge bei K-Bus Fehler. Mit Bit 0 = Ausgang 1, ... , Bit 7 = Ausgang 8 wird im K-Bus Fehlerfall (oder PLC gestoppt) der jeweilige Ausgang gesetzt, vorausgesetzt, der Schalter steht auf "auto".
byOut: Bit 0 = TRUE, ... , Bit 7 = TRUE setzt den jeweiligen Ausgang, vorausgesetzt, der Schalter steht auf "auto". Mit 255dez (FFhex) werden alle Ausgänge gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
byLEDGn: Bit 0 = TRUE, ... , Bit 7 = TRUE setzt die grünen LEDs, vorausgesetzt, die Standardfunktion der LEDs wurde mit byDisCh abgewählt. Mit 255dez (FFhex) werden alle grünen LEDs gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
byLEDYe: Bit 0 = TRUE, ... , Bit 7 = TRUE setzt die gelben LEDs, vorausgesetzt, die Standardfunktion der LEDs wurde mit byDisCh abgewählt. Mit 255dez (FFhex) werden alle gelben LEDs gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
dwOpt: Für zukünftige Optionen.
VAR_OUTPUT
bBusy : BOOL;
byStaSwiAuto : BYTE;
byStatOut : BYTE;
bErr : BOOL;
udiErrID : UDINT;
bBusy: bBusy ist TRUE, solange die Konfiguration geschrieben wird (Start mit bExecCfg). Es ist zu beachten, dass in dieser Zeit die Eingänge nicht aktualisiert werden.
byStaSwiAuto: Status der Schalter "auto". Bit 0 = Schalter 1, ... , Bit 7 Schalter 8. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xxByteTo8Bit zum Aufbereiten der Signale zur Verfügung.
byStatOut: Status der digitalen Ausgangssignale. Bit 0 = Ausgang 1, ... , Bit 7 Ausgang 8. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xxByteTo8Bit zum Aufbereiten der Signale zur Verfügung.
bErr: Der bErr Ausgang wird TRUE sobald ein Fehler auftritt. Dieser Fehler wird über die Variable udiErrID beschrieben.
udiErrID: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe Fehlercodes). Gleichzeitig wird bError TRUE.
VAR_IN_OUT
stInData : ST_KL8528InData;
stOutData : ST_KL8528OutData;
ST_KL8528OutData ST_KL8528InData
stInData: Prozessabbild der Eingänge (siehe ST_KL8528InData).
stOutData: Prozessabbild der Ausgänge (siehe ST_KL8528OutData).


FB_KL8528Ex

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL8528 [image] FB_KL8528Ex
FB_KL8528Ex
Funktionsbaustein FB_KL8528Ex
Anwendung
Dieser Baustein dient zum Konfigurieren der KL8528, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/ LEDs.
Der Baustein muss einmal pro Zyklus aufgerufen werden.
Mit einer positiven Flanke von bExecCfg werden die Parameter zur Klemme übertragen.
Die Variable byDisCh schaltet die Standardfunktion der LEDs aus. Die LEDs können jetzt unabhängig vom digitalen Eingangssignal über die PLC geschaltet werden, mit den Variablen byLEDGn oder byLEDYe. Hier kann jede LED einzeln verändert werden.
Mit byKBusOff kann bei K-Bus Fehler (oder Plc gestoppt) und Schalterstellung "auto" der jeweilige Ausgang auf "TRUE" gesetzt werden. Bit 0..7 für die Ausgänge 1..8. Ist das Flag in byKBusOff nicht gesetzt geht der Ausgang bei K-Bus Fehler (oder PLC gestoppt) auf "FALSE".
VAR_INPUT
bEn : BOOL;
bExecCfg : BOOL;
byDisCh : BYTE;
byKBusOff : BYTE;
byOut : BYTE;
byLEDGn : BYTE;
byLEDYe : BYTE;
bDisManMode : BOOL;
dwOpt : DWORD;
bEn: Mit bEn = TRUE wird der Baustein vom SPS-Programm freigegeben. Mit bEn = FALSE wird die Abarbeitung des Bausteins gestoppt und alle Ausgänge werden zurückgesetzt.
bExecCfg: Die Konfigurationen byDisCh und byKBusOff werden auf positiver Flanke in die Klemmen geschrieben. bBusy wird TRUE. Es ist zu beachten, dass in dieser Zeit die Ein-/Ausgänge nicht aktualisiert werden.
byDisCh: Konfiguration: Abwahl der Standardfunktion der LEDs. Die LEDs können von der Plc gesetzt werden. Bit 0 = LED 1, ... , Bit 7 = LED 8. Mit 255dez (FFhex) wird bei allen LEDs die Standardfunktion deaktiviert. Diese können dann über byLEDGn oder byLEDYe von der Plc aus gesetzt werden.
byKBusOff: Konfiguration: Reaktion der Ausgänge bei K-Bus Fehler. Mit Bit 0 = Ausgang 1, ... , Bit 7 =Ausgang 8 wird im K-Bus Fehlerfall (oder PLC gestoppt) der jeweilige Ausgang gesetzt, vorausgesetzt, der Schalter steht auf "auto".
byOut: Bit 0 = true, ... , Bit 7 = true setzt den jeweiligen Ausgang, vorausgesetzt, der Schalter steht auf "auto". Mit 255dez (FFhex) werden alle Ausgänge gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
byLEDGn: Bit 0 = true, ... , Bit 7 = true setzt die grünen LEDs, vorausgesetzt, die Standardfunktion der LEDs wurde mit byDisCh abgewählt. Mit 255dez (FFhex) werden alle grünen LEDs gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
byLEDYe: Bit 0 = true, ... , Bit 7 = true setzt die gelben LEDs, vorausgesetzt, die Standardfunktion der LEDs wurde mit byDisCh abgewählt. Mit 255dez (FFhex) werden alle gelben LEDs gesetzt. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xx8BitToByte zum Aufbereiten der Signale zur Verfügung.
bDisManMode: Sperren des Handbedienmodus.
dwOpt: Für zukünftige Optionen.
VAR_OUPUT
bBusy : BOOL;
byStaSwiAuto : BYTE;
byStatOut : BYTE;
bManModelsDis : BOOL;
wFirmVer : WORD;
bErr : BOOL;
udiErrID : UDINT;
bBusy: bBusy ist TRUE, solange die Konfiguration geschrieben wird (Start mit bExecCfg). Es ist zu beachten, dass in dieser Zeit die Eingänge nicht aktualisiert werden.
byStaSwiAuto: Status der Schalter "auto". Bit 0 = Schalter 1, ... , Bit 7 Schalter 8. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xxByteTo8Bit zum Aufbereiten der Signale zur Verfügung.
byStatOut: Status der digitalen Ausgangssignale. Bit 0 = Ausgang 1, ... , Bit 7 Ausgang 8. Für die grafischen Programmiersprachen steht der Baustein FB_KL85xxByteTo8Bit zum Aufbereiten der Signale zur Verfügung.
bManModelsDis: Handbedienmodus gesperrt.
wFirmVer: Gibt die Firmware Version aus.
bErr: Der bErr Ausgang wird TRUE sobald ein Fehler auftritt. Dieser Fehler wird über die Variable udiErrID beschrieben.
udiErrID: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe Fehlercodes). Gleichzeitig wird bError TRUE.
VAR_IN_OUT
stInData : ST_KL8528InData;
stOutData : ST_KL8528OutData;
stInData: Prozessabbild der Eingänge (siehe ST_KL8528InData).
stOutData: Prozessabbild der Ausgänge (siehe ST_KL8528OutData).


KL8548

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL8548
KL8548
Bausteine | Beschreibung
FB_KL8548 | Baustein zum Konfigurieren der KL8548, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/LEDs.
Weiterführende Informationen
•
FB_KL8548
•
FB_KL8548Ex


FB_KL8548

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL8548 [image] FB_KL8548
FB_KL8548
Funktionsbaustein FB_KL8548
Anwendung
Dieser Baustein dient zum Konfigurieren der KL8548, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge / LEDs.
Der Baustein muss einmal pro Zyklus aufgerufen werden.
Mit einer positiven Flanke von bExecCfg werden die Parameter zur Klemme übertragen.
Die Standardfunktion der LEDs kann nicht deaktiviert werden.
VAR_INPUT
bEn : BOOL;
bExecCfg : BOOL;
bDisWatchdog : BOOL;
bEnEcoMode : BOOL;
bEnPwrOnVal : BOOL;
wPwrOnVal : WORD;
wOut : WORD;
dwOpt : DWORD;
bEn: Mit bEn = TRUE wird der Baustein vom SPS-Programm freigegeben. Mit bEn = FALSE wird die Abarbeitung des Bausteins gestoppt und alle Ausgänge werden zurückgesetzt.
bExecCfg: Die Konfigurationen bDisWatchdog, bEnEcoMode, bEnPwrOnVal und wPwrOnVal werden auf positiver Flanke in die Klemmen geschrieben. bBusy wird TRUE. Es ist zu beachten, dass in dieser Zeit die Eingänge nicht aktualisiert werden.
bDisWatchdog: Konfiguration: Bei FALSE bleibt der letzte Wert von wStaOut bei K-Bus Fehler stehen (wenn PLC gestoppt, wird der Wert auf 0 gesetzt). Bei TRUE und bEnPwrOnVal = FALSE wird bei K-Bus Fehler (oder PLC gestoppt) der Ausgang 0. Bei TRUE und bEnPwrOnVal = TRUE wird bei K-Bus Fehler (oder PLC gestoppt) der Ausgang auf den Wert von wPwrOnVal gesetzt.
bEnEcoMode: Konfiguration: Fullscale-Mode oder ECO-Mode. TRUE: ECO-Mode. FALSE: Fullscale-Mode.
bEnPwrOnVal: Konfiguration: TRUE: Bei K-Bus Fehler (oder PLC gestoppt), wird der analoge Ausgang auf den Wert von wPowerOnValue gesetzt, wenn bDisWatchdog = TRUE,
wPwrOnVal: Konfiguration: Wert, den der Ausgang bei K-Bus Fehler (oder PLC gestoppt) annehmen soll.
wOut: Wert des analogen Ausgangssignals, vorausgesetzt der Schalter steht auf "auto". 0 V = 0000hex = 0dez , 10 V = 7FFFhex = 32767dez. Steht der Schalter auf "man" wird der Wert des Potentiometers ausgegeben.
dwOpt: Für zukünftige Optionen.
VAR_OUTPUT
bBusy : BOOL;
bStaSwiAuto : BOOL;
wStaPoti : WORD;
wStaOut : WORD;
bErr : BOOL;
udiErrID : UDINT;
bBusy: bBusy ist TRUE, solange die Konfiguration geschrieben wird (Start mit bExecCfg). Es ist zu beachten, dass in dieser Zeit die Eingänge nicht aktualisiert werden.
bStaSwiAuto: Status des Schalters. TRUE = "auto" FALSE = "man".
wStaPoti: Status des Potentiometers. Linksanschlag = 0000hex = 0dez = 0V , Rechtsanschlag = 7FFFhex = 32767dez = 10V.
wStaOut: Status des analogen Ausgangssignals. Linksanschlag = 0000hex = 0dez = 0V , Rechtsanschlag = 7FFFhex = 32767dez = 10V.
bErr: Der bErr Ausgang wird TRUE sobald ein Fehler auftritt. Dieser Fehler wird über die Variable udiErrID beschrieben.
udiErrID: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe Fehlercodes). Gleichzeitig wird bError TRUE.
VAR_IN_OUT
stInData : ST_KL8548InData;
stOutData : ST_KL8548OutData;
stInData: Prozessabbild der Eingänge (siehe ST_KL8548InData).
stOutData: Prozessabbild der Ausgänge (siehe ST_KL8548OutData).


FB_KL8548Ex

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL8548 [image] FB_KL8548Ex
FB_KL8548Ex
Funktionsbaustein FB_KL8548Ex
Anwendung
Dieser Baustein dient zum Konfigurieren der KL8548, zum Auslesen der digitalen Signale und zum Setzen der Ausgänge/ LEDs.
Der Baustein muss einmal pro Zyklus aufgerufen werden.
Mit einer positiven Flanke von bExecCfg werden die Parameter zur Klemme übertragen.
Die Standardfunktion der LEDs kann nicht deaktiviert werden.
VAR_INPUT
bEn : BOOL;
bExecCfg : BOOL;
bDisWatchdog : BOOL;
bEnEcoMode : BOOL;
bEnPwrOnVal : BOOL;
wPwrOnVal : WORD;
wOut : WORD;
bDisManMode : BOOL;
dwOpt : DWORD;
bEn: Mit bEn = TRUE wird der Baustein vom SPS-Programm freigegeben. Mit bEn = FALSE wird die Abarbeitung des Bausteins gestoppt und alle Ausgänge werden zurückgesetzt.
bExecCfg: Die Konfigurationen bDisWatchdog, bEnEcoMode, bEnPwrOnVal und wPwrOnVal werden auf positiver Flanke in die Klemmen geschrieben. bBusy wird TRUE. Es ist zu beachten, dass in dieser Zeit die Eingänge nicht aktualisiert werden.
bDisWatchdog: Konfiguration: Bei False bleibt der letzte Wert von wStaOut bei K-Bus Fehler stehen (wenn PLC gestoppt, wird der Wert auf 0 gesetzt). Bei True und bEnPwrOnVal =False wird bei K-Bus Fehler (oder Plc gestoppt) der Ausgang 0. Bei True und bEnPwrOnVal =True wird bei K-Bus Fehler (oder PLC gestoppt) der Ausgang auf den Wert von wPwrOnVal gesetzt.
bEnEcoMode: Konfiguration: Fullscale-Mode oder ECO-Mode. TRUE: ECO-Mode. FALSE: Fullscale-Mode.
bEnPwrOnVal: Konfiguration: TRUE: Bei K-Bus Fehler (oder PLC gestoppt), wird der analoge Ausgang auf den Wert von wPowerOnValue gesetzt, wenn bDisWatchdog = True,
wPwrOnVal: Konfiguration: Wert, den der Ausgang bei K-Bus Fehler (oder PLC gestoppt) annehmen soll.
wOut: Wert des analogen Ausgangssignals, vorausgesetzt der Schalter steht auf "auto". 0V = 0000hex = 0dez , 10V = 7FFFhex = 32767dez. Steht der Schalter auf "man" wird der Wert des Potentiometers ausgegeben.
bDisManMode: Sperren des Handbedienmodus .
dwOpt: Für zukünftige Optionen.
VAR_OUPUT
bBusy : BOOL;
bStaSwiAuto : BOOL;
wStaPoti : WORD;
wStaOut : WORD;
bManModelsDis : BOOL;
wFirmVer : WORD;
bErr : BOOL;
udiErrID : UDINT;
bBusy: bBusy ist TRUE, solange die Konfiguration geschrieben wird (Start mit bExecCfg). Es ist zu beachten, dass in dieser Zeit die Eingänge nicht aktualisiert werden.
bStaSwiAuto: Status des Schalters. True ="auto" False = "man".
wStaPoti: Status des Potentiometers. Linksanschlag = 0000hex = 0dez = 0 V , Rechtsanschlag = 7FFFhex = 32767dez = 10 V
wStaOut: Status des analogen Ausgangssignals. Linksanschlag = 0000hex = 0dez = 0 V , Rechtsanschlag = 7FFFhex = 32767dez = 10 V
bManModelsDis: Handbedienmodus gesperrt.
wFirmVer: Gibt die Firmware Version aus.
bErr: Der bErr Ausgang wird TRUE sobald ein Fehler auftritt. Dieser Fehler wird über die Variable udiErrID beschrieben.
udiErrID: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe Fehlercodes). Gleichzeitig wird bError TRUE.
VAR_IN_OUT
stInData : ST_KL8548InData;
stOutData : ST_KL8548OutData;
stInData: Prozessabbild der Eingänge (siehe ST_KL8548InData).
stOutData: Prozessabbild der Ausgänge (siehe ST_KL8548OutData).


KL85xx - Helper

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL85xx - Helper
KL85xx - Helper
Bausteine | Beschreibung
FB_KL85xx16BitToWord | Umwandlung von 16 Bit in 1 Word
FB_KL85xx8BitToByte | Umwandlung von 8 Bit in 1 Byte
FB_KL85xxByteTo8Bit | Umwandlung von einem Byte in 8 Bit.
FB_KL85xxWordTo16Bit | Umwandlung von einem Word in 16 Bit.
Weiterführende Informationen
•
FB_KL85xx16BitToWord
•
FB_KL85xx8BitToByte
•
FB_KL85xxByteTo8Bit
•
FB_KL85xxWordTo16Bit


FB_KL85xx16BitToWord

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL85xx - Helper [image] FB_KL85xx16BitToWord
FB_KL85xx16BitToWord
Funktionsbaustein FB_KL85xx16BitToWord
Anwendung
Dieser Baustein wandelt 16 Bit in 1 Word.
VAR_INPUT
b01 : BOOL;
b02 : BOOL;
b03 : BOOL;
b04 : BOOL;
b05 : BOOL;
b06 : BOOL;
b07 : BOOL;
b08 : BOOL;
b09 : BOOL;
b10 : BOOL;
b11 : BOOL;
b12 : BOOL;
b13 : BOOL;
b14 : BOOL;
b15 : BOOL;
b16 : BOOL;
b01: Bit 0
b02: Bit 1
b03: Bit 2
b04: Bit 3
b05: Bit 4
b06: Bit 5
b07: Bit 6
b08: Bit 7
b09: Bit 8
b10: Bit 9
b11: Bit 10
b12: Bit 11
b13: Bit 12
b14: Bit 13
b15: Bit 14
b16: Bit 15
VAR_OUTPUT
wOut : WORD;
wOut: Aus den 16 Bits zusammengesetztes Word.


FB_KL85xx8BitToByte

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL85xx - Helper [image] FB_KL85xx8BitToByte
FB_KL85xx8BitToByte
Funktionsbaustein FB_KL85xx8BitToByte
Anwendung
Dieser Baustein wandelt 8 Bit in 1 Byte.
VAR_INPUT
b01 : BOOL;
b02 : BOOL;
b03 : BOOL;
b04 : BOOL;
b05 : BOOL;
b06 : BOOL;
b07 : BOOL;
b08 : BOOL;
b01: Bit 0
b02: Bit 1
b03: Bit 2
b04: Bit 3
b05: Bit 4
b06: Bit 5
b07: Bit 6
b08: Bit 7
VAR_OUTPUT
byOut : BYTE;
byOut: Aus den 8 Bits zusammengesetzte Byte.


FB_KL85xxByteTo8Bit

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL85xx - Helper [image] FB_KL85xxByteTo8Bit
FB_KL85xxByteTo8Bit
Funktionsbaustein FB_KL85xxByteTo8Bit
Anwendung
Dieser Baustein wandelt 1 Byte in 8 Bit.
VAR_INPUT
byIn : BYTE;
byIn: Byte das in 8 Bits aufgelöst werden soll.
VAR_OUTPUT
b01 : BOOL;
b02 : BOOL;
b03 : BOOL;
b04 : BOOL;
b05 : BOOL;
b06 : BOOL;
b07 : BOOL;
b08 : BOOL;
b01: Bit 0
b02: Bit 1
b03: Bit 2
b04: Bit 3
b05: Bit 4
b06: Bit 5
b07: Bit 6
b08: Bit 7


FB_KL85xxWordTo16Bit

Programmierung in TwinCAT [image] Funktionsbausteine [image] KL85xx - Helper [image] FB_KL85xxWordTo16Bit
FB_KL85xxWordTo16Bit
Funktionsbaustein FB_KL85xxWordTo16Bit
Anwendung
Dieser Baustein wandelt 1 Word in 16 Bit.
VAR_INPUT
wIn : WORD;
wIn: Word das in 16 Bits aufgelöst werden soll.
VAR_OUTPUT
b01 : BOOL;
b02 : BOOL;
b03 : BOOL;
b04 : BOOL;
b05 : BOOL;
b06 : BOOL;
b07 : BOOL;
b08 : BOOL;
b09 : BOOL;
b10 : BOOL;
b11 : BOOL;
b12 : BOOL;
b13 : BOOL;
b14 : BOOL;
b15 : BOOL;
b16 : BOOL;
b01: Bit 0
b02: Bit 1
b03: Bit 2
b04: Bit 3
b05: Bit 4
b06: Bit 5
b07: Bit 6
b08: Bit 7
b09: Bit 8
b10: Bit 9
b11: Bit 10
b12: Bit 11
b13: Bit 12
b14: Bit 13
b15: Bit 14
b16: Bit 15


Datentypen

Programmierung in TwinCAT [image] Datentypen
Datentypen
Hardware Types
Datentyp | Beschreibung
ST_KL8519InData | Prozessabbild der Eingänge für die KL8519
ST_KL8519OutData | Prozessabbild der Ausgänge für die KL8519
ST_KL8524InData | Prozessabbild der Eingänge für die KL8524
ST_KL8524OutData | Prozessabbild der Ausgänge für die KL8524
ST_KL8528InData | Prozessabbild der Eingänge für die KL8528
ST_KL8528OutData | Prozessabbild der Ausgänge für die KL8528
ST_KL8548InData | Prozessabbild der Eingänge für die KL8548
ST_KL8548OutData | Prozessabbild der Ausgänge für die KL8548
Datentyp | Beschreibung
E_KL8519_KBusOffReact | Reaktion der LEDs der KL8519 bei K-Bus Fehler
Weiterführende Informationen
•
E_KL8519_KBusOffReact
•
ST_KL8519InData
•
ST_KL8519OutData
•
ST_KL8524InData
•
ST_KL8524OutData
•
ST_KL8528InData
•
ST_KL8528OutData
•
ST_KL8548InData
•
ST_KL8548OutData


E_KL8519_KBusOffReact

Programmierung in TwinCAT [image] Datentypen [image] E_KL8519_KBusOffReact
E_KL8519_KBusOffReact
Reaktion der LEDs der KL8519 bei K-Bus Fehler. Diese LEDs müssen über "wDisCh" aktiviert worden sein.
TYPE E_KL8519_KBusOffReact :
(
eKL8519_WatchdogOff := 0,
eKL8519_Watchdog500ms := 1,
eKL8519_Watchdog1000ms := 2
)
END_TYPE
eKL8519_WatchdogOff: Bei K-Bus Fehler gehen alle LEDs, die über die SPS gesetzt worden sind, aus.
eKL8519_Watchdog500ms: Der letzte Zustand der LED toggelt mit 500 ms. War der letzte Zustand AUS bleibt die LED aus.
eKL8519_Watchdog1000ms: Der letzte Zustand der LED toggelt mit 1000 ms. War der letzte Zustand AUS bleibt die LED aus.


ST_KL8519InData

Programmierung in TwinCAT [image] Datentypen [image] ST_KL8519InData
ST_KL8519InData
Prozessabbild der Eingänge für die KL8519
Wird im System Manager mit der Klemmen verknüpft.
TYPE ST_KL8519InData :
STRUCT
byState : BYTE;
byDataIN_1 : BYTE;
byDataIN_2 : BYTE;
END_STRUCT
END_TYPE
byState: Status-Byte
byDataIN_1: Daten-Byte 1: Eingang 1 bis 8
byDataIN_2: Daten-Byte 2: Eingang 9 bis 16


ST_KL8519OutData

Programmierung in TwinCAT [image] Datentypen [image] ST_KL8519OutData
ST_KL8519OutData
Prozessabbild der Ausgänge für die KL8519
Wird im System Manager mit der Klemmen verknüpft.
TYPE ST_KL8519OutData :
STRUCT
byCtrl : BYTE;
byLEDoutGreen_1 : BYTE;
byLEDoutGreen_2 : BYTE;
byLEDoutRed_1 : BYTE;
byLEDoutRed_2 : BYTE;
END_STRUCT
END_TYPE
byCtrl: Control-Byte
byLEDoutGreen_1: Daten-Byte 1: Grüne LED 1 bis 8 (muss über wDisCh freigegeben werden)
byLEDoutGreen_2: Daten-Byte 2: Grüne LED 9 bis 16 (muss über wDisCh freigegeben werden)
byLEDoutRed_1: Daten-Byte 3: rote LED 1 bis 8 (muss über wDisCh freigegeben werden)
byLEDoutRed_2: Daten-Byte 4: rote LED 9 bis 16 (muss über wDisCh freigegeben werden)


ST_KL8524InData

Programmierung in TwinCAT [image] Datentypen [image] ST_KL8524InData
ST_KL8524InData
Prozessabbild der Eingänge für die KL8524
Wird im System Manager mit der Klemmen verknüpft.
TYPE ST_KL8524InData :
STRUCT
byState : BYTE;
byAutoManual : BYTE;
bySwitchMode : BYTE;
byOnOff : BYTE;
END_STRUCT
END_TYPE
byState: Status-Byte
byAutoManual: Daten-Byte 1: Stellung der auto/man-Schalter (Bit 0 = Kanal 1, Bit 3 Kanal 4)
bySwitchMode: Daten-Byte 2: Stellung der Dreistufenschalter (Bit 0 = Kanal 1 Stellung 1, Bit 1 Kanal 1 Stellung 2 .. , Bit 6 = Kanal 1 Stellung 1, Bit 7 Kanal 4 Stellung 2)
byOnOff: Daten-Byte 3: Zustand der physikalischen Ausgänge (Bit 0 = Kanal 1 Ausgang 1, Bit 1 Kanal 1 Ausgang 2 .. , Bit 6 = Kanal 1 Ausgang 1, Bit 7 Kanal 4 Ausgang 2)


ST_KL8524OutData

Programmierung in TwinCAT [image] Datentypen [image] ST_KL8524OutData
ST_KL8524OutData
Prozessabbild der Ausgänge für die KL8524
Wird im System Manager mit der Klemmen verknüpft.
TYPE ST_KL8524OutData :
STRUCT
byCtrl : BYTE;
bySwitchModeOut : BYTE;
byData : BYTE;
byLEDGreen : BYTE;
byLEDYellow : BYTE;
END_STRUCT
END_TYPE
byCtrl: Control-Byte
bySwitchModeOut: Daten-Byte 1: setzt die Ausgänge des Dreistufenschalters durch die PLC, wenn Automatikschalter auf "auto" steht
byData: Daten-Byte 2: reserviert für Register-Kommunikation
byLEDGreen: Daten-Byte 3: setzt LEDs der Ausgänge grün (muss über byDisCh freigegeben werden)
byLEDYellow: Daten-Byte 4: setzt LEDs der Ausgänge gelb (muss über byDisCh freigegeben werden)


ST_KL8528InData

Programmierung in TwinCAT [image] Datentypen [image] ST_KL8528InData
ST_KL8528InData
Prozessabbild der Eingänge für die KL8528
Wird im System Manager mit der Klemmen verknüpft.
TYPE ST_KL8528InData :
STRUCT
byState : BYTE;
byAutoManual : BYTE;
byOnOff : BYTE;
END_STRUCT
END_TYPE
byState: Status-Byte
byAutoManual: Daten-Byte 1: Schalterstellung "auto" für Ausgang 1 bis 8 (Der Ausgang wird über die PLC gesetzt)
byOnOff: Daten-Byte 2: Schalterstellung "on" für Ausgang 1 bis 8 (Der Ausgang wird unabhängig von der PLC gesetzt)


ST_KL8528OutData

Programmierung in TwinCAT [image] Datentypen [image] ST_KL8528OutData
ST_KL8528OutData
Prozessabbild der Ausgänge für die KL8528
Wird im System Manager mit der Klemmen verknüpft.
TYPE ST_KL8528OutData :
STRUCT
byCtrl : BYTE;
byOut : BYTE;
byData : BYTE;
byLEDOutGreen : BYTE;
byLEDOutYellow : BYTE;
END_STRUCT
END_TYPE
byCtrl: Control-Byte
byOut: Daten-Byte 1: setzt Ausgang 1 bis 8 durch die PLC, wenn der jeweilige Schalter auf "auto" steht.
byData: Daten-Byte 2: reserviert für Register-Kommunikation
byLEDOutGreen: Daten-Byte 3: setzt LED 1 bis 8 grün (muss über byDisCh freigegeben werden)
byLEDOutYellow: Daten-Byte 4: setzt LED 1 bis 8 gelb (muss über byDisCh freigegeben werden)


ST_KL8548InData

Programmierung in TwinCAT [image] Datentypen [image] ST_KL8548InData
ST_KL8548InData
Prozessabbild der Eingänge für die KL8548
Wird im System Manager mit der Klemmen verknüpft.
TYPE ST_KL8548InData :
STRUCT
byState : BYTE;
byDummy : BYTE;
wDataIn : WORD;
END_STRUCT
END_TYPE
byState: Status-Byte: Bit 0 ist TRUE, wenn der Automatikschalter auf "man" steht (Status-Byte=1).
byDummy: Dummy Byte.
wDataIn: Daten-Word 1: Stellung der Potentiometer (0x0000=0V, 0x3FFF=+5V, 0x7FFF=+10V)


ST_KL8548OutData

Programmierung in TwinCAT [image] Datentypen [image] ST_KL8548OutData
ST_KL8548OutData
Prozessabbild der Ausgänge für die KL8548
Wird im System Manager mit der Klemmen verknüpft.
TYPE ST_KL8548OutData :
STRUCT
byCtrl : BYTE;
byDummy : BYTE;
wDataOut : WORD;
END_STRUCT
END_TYPE
byCtrl: Control-Byte
byDummy: Dummy Byte.
wDataOut: Daten-Word 1: setzt den Ausgangswert durch die PLC, wenn der jeweilige Schalter auf "auto" steht. (0x0000=0V, 0x3FFF=+5V, 0x7FFF=+10V)


Fehler-Codes

Programmierung in TwinCAT [image] Fehler-Codes
Fehler-Codes
Wert (hex)
Wert (dez)
Beschreibung
0x0000
0
Kein Fehler
0x8001
32769
Watchdog Error. Die Klemme antwortet nicht. Üblicherweise gibt es bei dieser Meldung keine Verbindung zur Klemme.
▪
Klemme im TwinCAT System Manager mit den Variablen verknüpft?
▪
Klemme falsch gesteckt?
▪
Alles bereinigen, alles Übersetzen und im TwinCAT System Manager neu eingelesen?
0x8002
32770
falsche Klemme angeschlossenen. Der Klemmentyp kann im Onlinemodus kontrolliert werden (uiTerm -interne Variable des Bausteins).
0x8003
32771
Die Eingangsvariable wOut des Bausteins FB_KL8548() ist zu groß. Maximal 32767 ist erlaubt. Intern (im Baustein) wird mit 32767 (entspricht 10 V) weitergearbeitet.
0x8004
32772
Der Baustein FB_KL8524() versucht auf dem Kanal 1 die Ausgänge 1 und 2 gleichzeitig zu setzen. Das ist nicht erlaubt. Es wird kein Ausgang gesetzt.
0x8005
32773
Der Baustein FB_KL8524() versucht auf dem Kanal 2 die Ausgänge 1 und 2 gleichzeitig zu setzen. Das ist nicht erlaubt. Es wird kein Ausgang gesetzt.
0x8006
32774
Der Baustein FB_KL8524() versucht auf dem Kanal 3 die Ausgänge 1 und 2 gleichzeitig zu setzen. Das ist nicht erlaubt. Es wird kein Ausgang gesetzt.
0x8007
32775
Der Baustein FB_KL8524() versucht auf dem Kanal 4 die Ausgänge 1 und 2 gleichzeitig zu setzen. Das ist nicht erlaubt. Es wird kein Ausgang gesetzt.


Anpassung der LED-Anzeigen

Programmierung in TwinCAT [image] Anpassung der LED-Anzeigen
Anpassung der LED-Anzeigen
Weiterführende Informationen
•
Standardfunktion LED KL8519
•
Standardfunktion LED KL8524
•
Standardfunktion LED KL8528
•
Standardfunktion LED KL8548
•
Bargraph-Anzeige-Mode - KL8548


Standardfunktion LED KL8519

Programmierung in TwinCAT [image] Anpassung der LED-Anzeigen [image] Standardfunktion LED KL8519
Standardfunktion LED KL8519
Im Auslieferungszustand leuchten die LEDs grün, wenn der jeweilige Eingang belegt wird und sind aus, wenn der Eingang nicht belegt ist.
Mit der Variablen wSetCol kann festgelegt werden, dass die jeweilige LED rot leuchtet.
Mit der Variablen wInv kann der Kanal invertiert werden. Das heißt, die LEDs leuchten, wenn der Eingang nicht belegt ist und sind aus, wenn der Eingang belegt ist.
Mit der Variablen wBiCol können die LEDs zweifarbig angesteuert werden. Das heißt, Die LEDs leuchten grün, wenn der Eingang belegt ist und rot, wenn der Eingang nicht belegt ist. Wurden die Kanäle mit wInv invertiert, ist es umgekehrt.
Diese Funktionalität kann mit der Variable wDisCh abgewählt werden. Die LEDs können dann von der PLC aus gesetzt werden.


Standardfunktion LED KL8524

Programmierung in TwinCAT [image] Anpassung der LED-Anzeigen [image] Standardfunktion LED KL8524
Standardfunktion LED KL8524
Die LEDs leuchten dauerhaft gelb, wenn der Automatikschalter auf auto steht und der jeweilige Ausgang FALSE ist.
Die LEDs leuchten dauerhaft grün, wenn der Automatikschalter auf auto steht und der jeweilige Ausgang TRUE (von der PLC gesetzt) ist.
Die LEDs blinken gelb, wenn der Automatikschalter auf "man" steht und der jeweilige Ausgang FALSE ist.
Die LEDs blinken grün, wenn der Automatikschalter auf "man" steht und der jeweilige Ausgang TRUE (vom Dreistufenschalter gesetzt) ist.
Diese Funktionalität kann mit der Variable byDisCh abgewählt werden. Die LEDs können dann von der PLC aus gesetzt werden.


Standardfunktion LED KL8528

Programmierung in TwinCAT [image] Anpassung der LED-Anzeigen [image] Standardfunktion LED KL8528
Standardfunktion LED KL8528
Die LEDs leuchten dauerhaft gelb, wenn der Schalter auf auto steht und der Ausgang FALSE ist.
Die LEDs leuchten dauerhaft grün, wenn der Schalter auf auto steht und der Ausgang TRUE (von der PLC gesetzt) ist.
Die LEDs blinken gelb, wenn der Automatikschalter auf off steht. Der jeweilige Ausgang ist dann FALSE (auch wenn er von der PLC gesetzt wird).
Die LEDs blinken grün, wenn der Automatikschalter auf man steht. Der jeweilige Ausgang ist dann TRUE.
Diese Funktionalität kann mit der Variable byDisCh abgewählt werden. Die LEDs können dann von der PLC aus gesetzt werden.


Standardfunktion LED KL8548

Programmierung in TwinCAT [image] Anpassung der LED-Anzeigen [image] Standardfunktion LED KL8548
Standardfunktion LED KL8548
Die LEDs sind aus, wenn der Schalter auf auto steht. Der Bargraph zeigt den Wert der PLC an.
Die LEDs leuchten dauerhaft gelb, wenn der Schalter auf man steht. Der Bargraph zeigt den Wert des Potentiometers an.
Diese Funktionalität kann nicht abgewählt werden.


Bargraph-Anzeige-Mode - KL8548

Programmierung in TwinCAT [image] Anpassung der LED-Anzeigen [image] Bargraph-Anzeige-Mode - KL8548
Bargraph-Anzeige-Mode - KL8548
KL8548 - Bargraph-Anzeige-Mode
Die Bargraph-Anzeige (Balkenanzeige) der Analogwerte können beim KL8548 in zwei Betriebsarten geschaltet werden.
Im Fullscale-Mode wird der aktuelle analogwert als voller Balken dargestellt.
Im ECO-Mode wird der Analogwert mit einer nur LED angezeigt.
Durch beschreiben der Registers R32.4 oder mit den Funktionsbausteinen FB_KL8548 oder FB_KL8548Ex kann der gewünschte Anzeige-Mode für jeden Analogwert getrennt ausgewählt werden.


Datenstrukturen der Module

Datenstrukturen der Module
Datenstrukturen der Module
Weiterführende Informationen
•
KL8519
•
KL8524
•
KL8528
•
KL8548
•
Beispiele für die Register-Kommunikation


KL8519

Datenstrukturen der Module [image] KL8519
KL8519
Weiterführende Informationen
•
KL8519 - Prozessabbild
•
KL8519 - Control- und Status-Bytes
•
KL8519 - Registerübersicht
•
KL8519 - Registerbeschreibung


KL8519 - Prozessabbild

Datenstrukturen der Module [image] KL8519 [image] KL8519 - Prozessabbild
KL8519 - Prozessabbild
Die KL8519 stellt sich im Prozessabbild mit jeweils 6 Byte Eingangs- und Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset | Format | Eingangsdaten | Ausgangsdaten
0 | Byte | Status-Byte (SB) | Control-Byte (CB)
1 | Byte | Daten-Byte 0 (Eingang 1 bis 8) | Daten-Byte 0 (Grüne LED 1 bis 8)
2 | Byte | Daten-Byte 1 (Eingang 9 bis 16) | Daten-Byte 1 (Grüne LED 9 bis 16)
3 | Byte | reserviert | Daten-Byte 2 (rote LED 1 bis 8)
4 | Byte | reserviert | Daten-Byte 3 (rote LED 9 bis 16)
5 | Byte | reserviert | reserviert


KL8519 - Control- und Status-Bytes

Datenstrukturen der Module [image] KL8519 [image] KL8519 - Control- und Status-Bytes
KL8519 - Control- und Status-Bytes
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 im Prozessdatenbetrieb
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 - CB1.0 | - | 0bin | reserviert
Status-Byte 1 im Prozessdatenbetrieb
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 - SB1.0 | - | 0bin | reserviert
Registerkommunikation
Control-Byte 1 bei Registerkommunikation
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIN1 lesen oder - mit dem Ausgangsdatenwort DataOUT1 beschreiben wollen.
Status-Byte 1 bei Registerkommunikation
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2 bis 8
Die Control- und Status-Bytes der Kanäle 2 bis 8 sind jeweils wie das Control- und Status-Byte des Kanals 1 aufgebaut.


KL8519 - Registerübersicht

Datenstrukturen der Module [image] KL8519 [image] KL8519 - Registerübersicht
KL8519 - Registerübersicht
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R6 | reserviert | - | - | - | -
R7 | Kommando-Register | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | 0x2147 | 8519dez | R | ROM
R9 | Firmware-Stand (ASCI) | z. B. 0x3141 | z. B. 12609dez | R | ROM
R10 | Multiplex-Schieberegister |  |  | R | ROM
R11 | Signalkanäle |  |  | R | ROM
R12 | minimale Datenlänge eines Kanals |  |  | R | ROM
R13 | Datenstruktur |  |  | R | ROM
R14 | reserviert | - | - | - | -
R15 | Alignment-Register |  |  | R/W | RAM
R16 | Hardware-Versionsnummer | z. B. 0x0000 | z. B. 0dez | R/W | SEEPROM
R17 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R30 | reserviert | - | - | - | -
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | Disable Channel LED | 0x0000 | 0dez | R/W | SEEPROM
R33 | LED Color | 0x0000 | 0dez | R/W | SEEPROM
R34 | Inv LED | 0x0000 | 0dez | R/W | SEEPROM
R35 | LED BiColor | 0x0000 | 0dez | R/W | SEEPROM
R36 | K-Bus off Reaction | 0x0000 | 0dez | R/W | SEEPROM
R37 | reserviert | - | - | - | -
... | reserviert | - | - | - | -
R63 | reserviert | - | - | - | -


KL8519 - Registerbeschreibung

Datenstrukturen der Module [image] KL8519 [image] KL8519 - Registerbeschreibung
KL8519 - Registerbeschreibung
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
R7: Kommando-Register
Um ein Standardkommando auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein.
Kommando 0x7000: Restore Factory Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register die Werte des Auslieferungszustands wiederhergestellt:
▪
Register R32: 0x0000
▪
Register R33: 0x0000
▪
Register R34: 0x0000
▪
Register R35: 0x0000
▪
Register R36: 0x0000
bis
▪
Register R63: 0x0000
R8: Klemmenbezeichnung
Im Register R8 steht die Bezeichnung der Klemme.
KL8519: 0x2147 (8519dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z.B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R12: Minimale Datenlänge eines Kanals
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Disable Channel LED
Mit diesem Register können Sie die Status-LEDs der einzelnen Kanäle deaktivieren.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | disLED_Ch16 | disLED_Ch15 | disLED_Ch14 | disLED_Ch13 | disLED_Ch12 | disLED_Ch11 | disLED_Ch10 | disLED_Ch9
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | disLED_Ch8 | disLED_Ch7 | disLED_Ch6 | disLED_Ch5 | disLED_Ch4 | disLED_Ch3 | disLED_Ch2 | disLED_Ch1
Legende
Bit | Name | Beschreibung |  | default
R32.15 | disLED_Ch16 | 0bin | Die LED zeigt den Zustand des Eingangs 16 an. Weitere Eigenschaften können mit R33, R34 und R35 eingestellt werden. | 0bin
 |  | 1bin | Die LED zeigt den Zustand des Eingangs 16 nicht an. Der Zustand des Eingangs 16 wird aber weiterhin zur SPS übertragen. Außerdem kann die SPS nun die LED wahlweise grün oder rot schalten.
R32.14 | disLED_Ch15 | 0bin | Die LED zeigt den Zustand des Eingangs 15 an. Weitere Eigenschaften können mit R33, R34 und R35 eingestellt werden. | 0bin
 |  | 1bin | Die LED zeigt den Zustand des Eingangs 15 nicht an. Der Zustand des Eingangs 15 wird aber weiterhin zur SPS übertragen. Außerdem kann die SPS nun die LED wahlweise grün oder rot schalten.
... | ... | ... |  | ...
R32.0 | disLED_Ch1 | 0bin | Die LED zeigt den Zustand des Eingangs 1 an. Weitere Eigenschaften können mit R33, R34 und R35 eingestellt werden. | 0bin
 |  | 1bin | Die LED zeigt den Zustand des Eingangs 1 nicht an. Der Zustand des Eingangs 1 wird aber weiterhin zur SPS übertragen. Außerdem kann die SPS nun die LED wahlweise grün oder rot schalten.
R33: LED Set Color
Mit diesem Register können Sie für die Status-LEDs der einzelnen Kanäle die Farbe festlegen (grün oder rot).
Bit | R33.15 | R33.14 | R33.13 | R33.12 | R33.11 | R33.10 | R33.9 | R33.8
Name | colLED_Ch16 | colLED_Ch15 | colLED_Ch14 | colLED_Ch13 | colLED_Ch12 | colLED_Ch11 | colLED_Ch10 | colLED_Ch9
Bit | R33.7 | R33.6 | R33.5 | R33.4 | R33.3 | R33.2 | R33.1 | R33.0
Name | colLED_Ch8 | colLED_Ch7 | colLED_Ch6 | colLED_Ch5 | colLED_Ch4 | colLED_Ch3 | colLED_Ch2 | colLED_Ch1
Legende
Bit | Name | Beschreibung |  | default
R33.15 | colLED_Ch16 | 0bin | Die LED des Eingangs 16 leuchtet grün. | 0bin
 |  | 1bin | Die LED des Eingangs 16 leuchtet rot.
R33.14 | colLED_Ch15 | 0bin | Die LED des Eingangs 15 leuchtet grün. | 0bin
 |  | 1bin | Die LED des Eingangs 15 leuchtet rot.
... | ... | ... |  | ...
R33.0 | colLED_Ch1 | 0bin | Die LED des Eingangs 1 leuchtet grün. | 0bin
 |  | 1bin | Die LED des Eingangs 1 leuchtet rot.
R34: Inv LED
Mit diesem Register können Sie die Anzeige der Status-LEDs der einzelnen Kanäle invertieren. Die zur SPS übertragenen Prozessdaten werden dadurch nicht beeinflusst.
Bit | R34.15 | R34.14 | R34.13 | R34.12 | R34.11 | R34.10 | R34.9 | R34.8
Name | invLED_Ch16 | invLED_Ch15 | invLED_Ch14 | invLED_Ch13 | invLED_Ch12 | invLED_Ch11 | invLED_Ch10 | invLED_Ch9
Bit | R34.7 | R34.6 | R34.5 | R34.4 | R34.3 | R34.2 | R34.1 | R34.0
Name | invLED_Ch8 | invLED_Ch7 | invLED_Ch6 | invLED_Ch5 | invLED_Ch4 | invLED_Ch3 | invLED_Ch2 | invLED_Ch1
Legende
Bit | Name | Beschreibung |  | default
R34.15 | invLED_Ch16 | 0bin | Die LED des Eingangs 16 leuchtet wenn der Eingang aktiv (1bin) ist. | 0bin
 |  | 1bin | Die LED des Eingangs 16 leuchtet wenn der Eingang inaktiv (0bin) ist.
R34.14 | invLED_Ch15 | 0bin | Die LED des Eingangs 15 leuchtet wenn der Eingang aktiv (1bin) ist. | 0bin
 |  | 1bin | Die LED des Eingangs 15 leuchtet wenn der Eingang inaktiv (0bin) ist.
... | ... | ... |  | ...
R34.0 | invLED_Ch1 | 0bin | Die LED des Eingangs 1 leuchtet wenn der Eingang aktiv (1bin) ist. | 0bin
 |  | 1bin | Die LED des Eingangs 1 leuchtet wenn der Eingang inaktiv (0bin) ist.
R35: LED BiColor
Mit diesem Register können Sie die Anzeige der Status-LEDs der einzelnen Kanäle zweifarbig schalten.
Bit | R35.15 | R35.14 | R35.13 | R35.12 | R35.11 | R35.10 | R35.9 | R35.8
Name | invLED_Ch16 | invLED_Ch15 | invLED_Ch14 | invLED_Ch13 | invLED_Ch12 | invLED_Ch11 | invLED_Ch10 | invLED_Ch9
Bit | R35.7 | R35.6 | R35.5 | R35.4 | R35.3 | R35.2 | R35.1 | R35.0
Name | invLED_Ch8 | invLED_Ch7 | invLED_Ch6 | invLED_Ch5 | invLED_Ch4 | invLED_Ch3 | invLED_Ch2 | invLED_Ch1
Legende
Bit | Name | Beschreibung |  | default
R35.15 | invLED_Ch16 | 0bin | Die LED des Eingangs 16 leuchtet grün wenn der Eingang inaktiv (0bin) ist. | 0bin
 |  | 1bin | Die LED des Eingangs 16 leuchtet rot wenn der Eingang aktiv (1bin) ist.
R35.14 | invLED_Ch15 | 0bin | Die LED des Eingangs 15 leuchtet grün wenn der Eingang inaktiv (0bin) ist. | 0bin
 |  | 1bin | Die LED des Eingangs 15 leuchtet rot wenn der Eingang aktiv (1bin) ist.
... | ... | ... |  | ...
R35.0 | invLED_Ch1 | 0bin | Die LED des Eingangs 1 leuchtet grün wenn der Eingang inaktiv (0bin) ist. | 0bin
 |  | 1bin | Die LED des Eingangs 1 leuchtet rot wenn der Eingang aktiv (1bin) ist.
Mit Register 34 können Sie auch diese Anzeigen invertieren.
R36: Reaktion auf K-Bus-Fehler
Bei K-Bus Fehler gehen alle LEDs, die über die SPS (R32) gesetzt worden sind aus. Es sei denn in R36 steht ein Wert anderer Wert als 00bin.
Bit | R36.15 | R36.14 | R36.13 | R36.12 | R36.11 | R36.10 | R36.9 | R36.8
Name | - | - | - | - | - | - | - | -
Bit | R36.7 | R36.6 | R36.5 | R36.4 | R36.3 | R36.2 | R36.1 | R36.0
Name | - | - | - | - | - | - | K-Bus-OFF-Reaction
Legende
Bit | Name | Beschreibung |  | default
R36.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R36.2 | - | reserviert |  | 0bin
R36.1, R36.0 | K-Bus-OFF-Reaction | 00bin | Bei K-Bus Fehler bleiben alle LEDs, die über die SPS (R32) gesetzt worden sind an. | 00bin
 |  | 01bin | Der letzte Zustand der LED toggelt mit 500 ms. War der Letzte Zustand AUS bleibt die LED AUS.
 |  | 10bin | Der letzte Zustand der LED toggelt mit 1000 ms. War der Letzte Zustand AUS bleibt die LED AUS.


KL8524

Datenstrukturen der Module [image] KL8524
KL8524
Weiterführende Informationen
•
KL8524 - Prozessabbild
•
KL8524 - Control- und Status-Bytes
•
KL8524 - Registerübersicht
•
KL8524 - Registerbeschreibung


KL8524 - Prozessabbild

Datenstrukturen der Module [image] KL8524 [image] KL8524 - Prozessabbild
KL8524 - Prozessabbild
Die KL8524 stellt sich im Prozessabbild mit jeweils 6 Byte Eingangs- und Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset | Format | Eingangsdaten | Ausgangsdaten
0 | Byte | Status-Byte (SB) | Control-Byte (CB)
1 | Byte | Daten-Byte 1: Stellung der auto/man-Schalter | Daten-Byte 1: überschreibt im Automatikbetrieb die Stellung der Dreistufenschalter
2 | Byte | Daten-Byte 2: Stellung der Dreistufenschalter | Daten-Byte 2: reserviert für Register-Kommunikation
3 | Byte | Daten-Byte 3: Zustand der physikalischen Ausgänge | Daten-Byte 3: setzt LEDs der Ausgänge grün
4 | Byte | Daten-Byte 4: reserviert | Daten-Byte 4: setzt LEDs der Ausgänge gelb
5 | Byte | Daten-Byte 5: reserviert | Daten-Byte 5: reserviert
Control- und Status-Byte
Siehe Kapitel Control- und Status-Byte
Prozessdaten
Eingangsdaten
Daten-Byte 1
Das Daten-Byte 1 zeigt die Stellungen der auto/man-Schalter.
Bit | Name | Beschreibung
0 | enAutoC1 | 0bin | auto/man-Schalter des Kanals 1 steht auf man: der Dreistufenschalter kontrolliert diesen Kanal.
 |  | 1bin | auto/man-Schalter des Kanals 1 steht auf auto: die SPS kontrolliert diesen Kanal.
1 | enAutoC2 | 0bin | auto/man-Schalter des Kanals 2 steht auf man: der Dreistufenschalter kontrolliert diesen Kanal.
 |  | 1bin | auto/man-Schalter des Kanals 2 steht auf auto: die SPS kontrolliert diesen Kanal.
2 | enAutoC3 | 0bin | auto/man-Schalter des Kanals 3 steht auf man: der Dreistufenschalter kontrolliert diesen Kanal.
 |  | 1bin | auto/man-Schalter des Kanals 3 steht auf auto: die SPS kontrolliert diesen Kanal.
3 | enAutoC4 | 0bin | auto/man-Schalter des Kanals 4 steht auf man: der Dreistufenschalter kontrolliert diesen Kanal.
 |  | 1bin | auto/man-Schalter des Kanals 4 steht auf auto: die SPS kontrolliert diesen Kanal.
4 | - | reserviert
... | ... | ...
7 | - | reserviert
Daten-Byte 2
Das Daten-Byte 2 zeigt die Stellungen der Dreistufenschalter.
Bit | Kanal | Beschreibung
1 und 0 | Kanal 1 | Bits | Dreistufenschalter
 |  | 00bin | Stellung 0
 |  | 01bin | Stellung 1
 |  | 10bin | Stellung 2
 |  | 11bin | - (nicht möglich)
3 und 2 | Kanal 2 | siehe Kanal 1
5 und 4 | Kanal 3 | siehe Kanal 1
7 und 6 | Kanal 4 | siehe Kanal 1
Daten-Byte 3
Das Daten-Byte 3 zeigt die Zustände der physikalischen Ausgänge des KL8524.
Bit | Name | Beschreibung
0 | stateC1.1 | 0bin | Ausgang C1.1 ist nicht gesetzt
 |  | 1bin | Ausgang C1.1 ist gesetzt
1 | stateC1.2 | 0bin | Ausgang C1.2 ist nicht gesetzt
 |  | 1bin | Ausgang C1.2 ist gesetzt
... | ... | ...
6 | stateC4.2 | 0bin | Ausgang C4.1 ist nicht gesetzt
 |  | 1bin | Ausgang C4.1 ist gesetzt
7 | stateC4.2 | 0bin | Ausgang C4.2 ist nicht gesetzt
 |  | 1bin | Ausgang C4.2 ist gesetzt
Ausgangsdaten
Daten-Byte 1
Das Daten-Byte 1 überschreibt im Automatikbetrieb die Stellung der Dreistufenschalter.
Bit | Kanal | Beschreibung
1 und 0 | Kanal 1 | Bits | Dreistufenschalter
 |  | 00bin | Stellung 0
 |  | 01bin | Stellung 1
 |  | 10bin | Stellung 2
 |  | 11bin | Stellung 0*
3 und 2 | Kanal 2 | siehe Kanal 1
5 und 4 | Kanal 3 | siehe Kanal 1
7 und 6 | Kanal 4 | siehe Kanal 1
*) Da es die Schalterstellung 3 nicht gibt, verhält sich der Kanal beim Setzen beider Bits als wenn kein Bit gesetzt wäre, was Schalterstellung 0 entspricht.
Daten-Byte 2
Hat im Prozessdatenbetrieb keine Funktion (reserviert), wird aber zur Register-Kommunikation verwendet.
Daten-Byte 3
Das Daten-Byte 3 setzt die LEDs der Kanäle grün.
Bit | Name | Beschreibung
0 | LED C1.1 green | 1bin | LED K1.1 leuchte grün
1 | LED C1.2 green | 1bin | LED K1.2 leuchte grün
... | ... | ...
6 | LED C4.1 green | 1bin | LED K4.1 leuchte grün
7 | LED C4.2 green | 1bin | LED K4.2 leuchte grün
Daten-Byte 4
Das Daten-Byte 4 setzt die LEDs der Kanäle gelb.
Bit | Name | Beschreibung
0 | LED C1.1 yellow | 1bin | LED K1.1 leuchte gelb
1 | LED C1.2 yellow | 1bin | LED K1.2 leuchte gelb
... | ... | ...
6 | LED C4.1 yellow | 1bin | LED K4.1 leuchte gelb
7 | LED C4.2 yellow | 1bin | LED K4.2 leuchte gelb


KL8524 - Control- und Status-Bytes

Datenstrukturen der Module [image] KL8524 [image] KL8524 - Control- und Status-Bytes
KL8524 - Control- und Status-Bytes
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 im Prozessdatenbetrieb
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 - CB1.0 | - | 0bin | reserviert
Status-Byte 1 im Prozessdatenbetrieb
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 - SB1.0 | - | 0bin | reserviert
Registerkommunikation
Control-Byte 1 bei Registerkommunikation
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIN1 lesen oder - mit dem Ausgangsdatenwort DataOUT1 beschreiben wollen.
Status-Byte 1 bei Registerkommunikation
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2 bis 8
Die Control- und Status-Bytes der Kanäle 2 bis 8 sind jeweils wie das Control- und Status-Byte des Kanals 1 aufgebaut.


KL8524 - Registerübersicht

Datenstrukturen der Module [image] KL8524 [image] KL8524 - Registerübersicht
KL8524 - Registerübersicht
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R6 | reserviert | - | - | - | -
R7 | Kommando-Register | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | 0x214C | 8524dez | R | ROM
R9 | Firmware-Stand (ASCI) | z. B. 0x3141 | z. B. 12609dez | R | ROM
R10 | Multiplex-Schieberegister |  |  | R | ROM
R11 | Signalkanäle |  |  | R | ROM
R12 | minimale Datenlänge eines Kanals |  |  | R | ROM
R13 | Datenstruktur |  |  | R | ROM
R14 | reserviert | - | - | - | -
R15 | Alignment-Register |  |  | R/W | RAM
R16 | Hardware-Versionsnummer | z. B. 0x0000 | z. B. 0dez | R/W | SEEPROM
R17 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R30 | reserviert | - | - | - | -
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | Enable PLC Set LED | 0x0000 | 0dez | R/W | SEEPROM
R33 | K-Bus off Reaction | 0x0000 | 0dez | R/W | SEEPROM
R34 | reserviert | - | - | - | -
... | reserviert | - | - | - | -
R36 | reserviert | - | - | - | -
R37 | Kanal 1: Ausgangsmodus / Einschaltverzögerung | 0x0000 | 0dez | R/W | SEEPROM
R38 | Kanal 2: Ausgangsmodus / Einschaltverzögerung | 0x0000 | 0dez | R/W | SEEPROM
R39 | Kanal 3: Ausgangsmodus / Einschaltverzögerung | 0x0000 | 0dez | R/W | SEEPROM
R40 | Kanal 4: Ausgangsmodus / Einschaltverzögerung | 0x0000 | 0dez | R/W | SEEPROM
R41 | reserviert | - | - | - | -
... | reserviert | - | - | - | -
R63 | reserviert | - | - | - | -


KL8524 - Registerbeschreibung

Datenstrukturen der Module [image] KL8524 [image] KL8524 - Registerbeschreibung
KL8524 - Registerbeschreibung
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
R7: Kommando-Register
Um ein Standardkommando auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein.
Kommando 0x7000: Restore Factory Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register die Werte des Auslieferungszustands wiederhergestellt:
▪
Register R32: 0x0000
▪
Register R33: 0x0000
▪
Register R34: 0x0000
▪
Register R35: 0x0000
▪
Register R36: 0x0000
▪
Register R37: 0x0000
▪
Register R38: 0x0000
▪
Register R39: 0x0000
▪
Register R40: 0x0000
bis
▪
Register R63: 0x0000
R8: Klemmenbezeichnung
Im Register R8 steht die Bezeichnung der Klemme.
KL8524: 0x214C (8524dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R12: Minimale Datenlänge eines Kanals
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Enable PLC Set LED
Mit diesem Register können Sie der SPS erlauben die Status-LEDs der einzelnen Kanäle zu setzen.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | - | - | - | -
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | - | enSetLED_Ch4 | enSetLED_Ch3 | enSetLED_Ch2 | enSetLED_Ch1
Legende
Bit | Name | Beschreibung |  | default
R32.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.4 | - | reserviert |  | 0bin
R32.3 | enSetLED_Ch4 | 0bin | LEDs des Kanals 4 können nicht von der SPS gesetzt werden | 0bin
 |  | 1bin | LEDs des Kanals 4 können von der SPS gesetzt werden
... | ... | ... |  | ...
R32.0 | enSetLED_Ch1 | 0bin | LEDs des Kanals 1 können nicht von der SPS gesetzt werden | 0bin
 |  | 1bin | LEDs des Kanals 1 können von der SPS gesetzt werden
R33: Reaktion auf K-Bus-Fehler
Bei K-Bus Fehler gehen alle Ausgänge, die über die SPS gesetzt worden sind aus. Es sei denn in R33 sind andere Vorgaben gemacht.
Bit | R33.15 | R33.14 | R33.13 | R33.12 | R33.11 | R33.10 | R33.9 | R33.8
Name | - | - | - | - | - | - | - | -
Bit | R33.7 | R33.6 | R33.5 | R33.4 | R33.3 | R33.2 | R33.1 | R33.0
Name | KBOR_Ch8 | KBOR_Ch7 | KBOR_Ch6 | KBOR_Ch5 | KBOR_Ch4 | KBOR_Ch3 | KBOR_Ch2 | KBOR_Ch1
Legende
Bit | Name | Beschreibung |  | default
R33.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R33.8 | - | reserviert |  | 0bin
R33.7 | K-Bus-OFF-Reaction_Ch4.2 | 0bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 4.2 zurückgesetzt (0bin). | 0bin
 |  | 1bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 4.2 gesetzt (1bin).
R33.6 | K-Bus-OFF-Reaction_Ch4.1 | 0bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 4.1 zurückgesetzt (0bin). | 0bin
 |  | 1bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 4.1 gesetzt (1bin).
... | ... | ... |  | ...
R33.1 | K-Bus-OFF-Reaction_Ch1.2 | 0bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 1.2 zurückgesetzt (0bin). | 0bin
 |  | 1bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 1.2 gesetzt (1bin).
R33.0 | K-Bus-OFF-Reaction_Ch1.1 | 0bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 1.1 zurückgesetzt (0bin). | 0bin
 |  | 1bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 1.1 gesetzt (1bin).
R37: Ausgangsmodus / Einschaltverzögerung für Kanal 1
Im Register 37 können Sie für Kanal 1 den Ausgangsmodus und die Einschaltverzögerung festlegen.
Bit | R37.15 | R37.14 | R37.13 | R37.12 | R37.11 | R37.10 | R37.9 | R37.8
Name | - | - | - | - | - | - | - | OutputMode
Bit | R37.7 | R37.6 | R37.5 | R37.4 | R37.3 | R37.2 | R37.1 | R37.0
Name | TurnOnDelay
Legende
Bit | Name | Beschreibung |  | default
R37.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R37.9 | - | reserviert |  | 0bin
R37.8 | OutputMode1 (arMode) | 0bin | Kanal 1 wird im Ausgangsmodus 1 betrieben | 0bin
 |  | 1bin | Kanal 1 wird im Ausgangsmodus 2 betrieben
R37.7-R37.0 | TurnOnDelay2 | 0dez | Keine Einschaltverzögerung | 0dez
 |  | 1dez | 10 ms Einschaltverzögerung
 |  | 2dez | 20 ms Einschaltverzögerung
 |  | ... | ...
 |  | 255dez | 2550 ms Einschaltverzögerung
1) OutputMode (arMode):
Ausgangsmodus 1:
Schalterstellung | Ausgang C 1.2 | Ausgang C 1.1
0 | 0 | 0
1 | 0 | 1
2 | 1 | 0
Ausgangsmodus 2:
Schalterstellung | Ausgang C 1.2 | Ausgang C 1.1
0 | 0 | 0
1 | 0 | 1
2 | 1 | 1
2) Umschaltverzögerung: Für das Wirksam werden der Schalterstellung kann eine Verzögerungszeit vorgegeben werden.
Verzögerungszeit im Ausgabemodus 1
Der Ausgabemodus 1 kann verwendet werden, wenn die beiden Ausgänge nicht Zeitgleich eingeschaltet werden dürfen (z. B. Lüftermotor mit Stern-Dreieck-Umschaltung).
Die Verzögerungszeit startet im Ausgabemodus 1 beim Wechsel von
▪
Schalterstellung 1 nach Schalterstellung 2
▪
Schalterstellung 2 nach Schalterstellung 1
▪
Ein schnelles Umschalten von 0 nach 2 oder 2 nach 0 geht dabei immer über Schalterstellung 1 und startet damit ebenfalls die Verzögerungszeit.
Beispiele:
▪
Beim Umschalten des Dreistufenschalters von 0 auf 1 schaltet Ausgang 1 sofort ein.
▪
Beim Umschalten des Dreistufenschalters von 1 auf 2 startet die Verzögerungszeit. Während die Verzögerungszeit läuft ist kein Ausgang geschaltet. Nach Ablauf der Verzögerungszeit wird Ausgang 2 eingeschaltet.
▪
Beim Zurückschalten des Dreistufenschalters von 2 auf 1 startet die Verzögerungszeit. Während die Verzögerungszeit läuft ist kein Ausgang geschaltet. Nach Ablauf der Verzögerungszeit wird Ausgang 1 eingeschaltet.
▪
Das Umschalten von 1 oder 2 auf 0 erfolgt sofort. Beide Ausgänge sind sofort ausgeschaltet.
▪
Wird während die Verzögerungszeit läuft wieder auf die vorhergehende Schalterstellung zurückgeschaltet, so wir auch der vorhergehende Ausgang sofort wieder aktiv.
Verzögerungszeit im Ausgabemodus 2
Der Ausgabemodus 2 kann verwendet werden, wenn vor dem Zuschalten des Ausgangs 2 eine Mindestzeit liegen muss (z. B. Verbraucher mit zwei Stufen, die einen zu hohen Einschaltstrom hätten, wenn sie direkt in Stufe 2 eingeschaltet werden).
Die Verzögerungszeit startet Ausgabemodus 2 beim Wechsel von
▪
Schalterstellung 1 nach Schalterstellung 2
▪
Ein schnelles Umschalten von 0 nach 2 geht immer über Schalterstellung 1 und startet damit ebenfalls die Verzögerungszeit.
Beispiele:
▪
Beim Umschalten des Dreistufenschalters von 0 auf 1 schaltet Ausgang 1 sofort ein.
▪
Beim Umschalten des Dreistufenschalters von 1 auf 2 startet die Verzögerungszeit. Während die Verzögerungszeit läuft bleibt Ausgang 1 eingeschaltet. Nach Ablauf der Verzögerungszeit wird Ausgang 2 zusätzlich eingeschaltet.
▪
Das Zurückschalten des Dreistufenschalters von 2 auf 1 erfolgt sofort. Ausgang 2 geht aus, Ausgang 1 bleibt eingeschaltet.
▪
Das Umschalten von 1 oder 2 auf 0 erfolgt sofort. Beide Ausgänge sind sofort ausgeschaltet.
▪
Beim Umschalten von 1 auf 2 während die Verzögerungszeit läuft, startet die Verzögerungszeit erneut.
R38: Ausgangsmodus / Einschaltverzögerung für Kanal 2
Siehe Register 37.
R39: Ausgangsmodus / Einschaltverzögerung für Kanal 3
Siehe Register 37.
R40: Ausgangsmodus / Einschaltverzögerung für Kanal 4
Siehe Register 37.


KL8528

Datenstrukturen der Module [image] KL8528
KL8528
Weiterführende Informationen
•
KL8528 - Prozessabbild
•
KL8528 - Control- und Status-Bytes
•
KL8528 - Registerübersicht
•
KL8528 - Registerbeschreibung


KL8528 - Prozessabbild

Datenstrukturen der Module [image] KL8528 [image] KL8528 - Prozessabbild
KL8528 - Prozessabbild
Die KL8528 stellt sich im Prozessabbild mit jeweils 6 Byte Eingangs- und Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset | Format | Eingangsdaten | Ausgangsdaten
0 | Byte | Status-Byte (SB), nur für Registerkommunikation | Control-Byte (CB), nur für Registerkommunikation
1 | Byte | Daten-Byte 1 (auto/manuell für Ausgang 1 bis 8) | Daten-Byte 1 (setzt Ausgang 1 bis 8)*
2 | Byte | Daten-Byte 2 (Schalterstellung für Ausgang 1 bis 8) | Daten-Byte 2 (reserviert)
3 | Byte | reserviert | Daten-Byte 3 (setzt LED 1 bis 8 grün)
4 | Byte | reserviert | Daten-Byte 4 (setzt LED 1 bis 8 gelb)
5 | Byte | reserviert | reserviert
*) Wenn der jeweilige Schalter auf Auto steht.
Control- und Status-Byte
Siehe Kapitel Control- und Status-Byte
Prozessdaten
Eingangsdaten
Daten-Byte 1
Das Daten-Byte 1 zeigt die Stellungen der Schalter (auto/man).
Bit | Name | Beschreibung
0 | enAutoCh1 | 1bin | Schalter des Kanals 1 steht auf auto: die SPS kontrolliert diesen Kanal.
1 | enAutoCh2 | 1bin | Schalter des Kanals 2 steht auf auto: die SPS kontrolliert diesen Kanal.
... | ... | ...
7 | enAutoCh8 | 1bin | Schalter des Kanals 8 steht auf auto: die SPS kontrolliert diesen Kanal.
Daten-Byte 2
Das Daten-Byte 2 zeigt die Stellungen der Schalter (off/on).
Bit | Name | Beschreibung
0 | Switch1 | 0bin | Schalter des Kanals 1 steht auf off
 |  | 1bin | Schalter des Kanals 1 steht auf on
1 | Switch1 | 0bin | Schalter des Kanals 2 steht auf off
 |  | 1bin | Schalter des Kanals 2 steht auf on
... | ... | ...
7 | Switch1 | 0bin | Schalter des Kanals 8 steht auf off
 |  | 1bin | Schalter des Kanals 8 steht auf on
Ausgangsdaten
Daten-Byte 1
Das Daten-Byte 1 setzt im Automatikbetrieb die Ausgänge.
Bit | Name | Beschreibung
0 | setCh1 | 1bin | Ausgang 1 ist gesetzt.
1 | setCh2 | 1bin | Ausgang 2 ist gesetzt.
... | ... | ...
7 | setCh8 | 1bin | Ausgang 8 ist gesetzt.
Daten-Byte 2
Hat im Prozessdatenbetrieb keine Funktion (reserviert), wird aber zur Register-Kommunikation verwendet.
Daten-Byte 3
Das Daten-Byte 3 setzt die LEDs der Kanäle grün.
Bit | Name | Beschreibung
0 | LED 1 green | 1bin | LED 1 leuchte grün
1 | LED 2 green | 1bin | LED 2 leuchte grün
... | ... | ...
7 | LED 8 green | 1bin | LED 8 leuchte grün
Daten-Byte 4
Das Daten-Byte 4 setzt die LEDs der Kanäle gelb.
Bit | Name | Beschreibung
0 | LED 1 green | 1bin | LED 1 leuchte gelb
1 | LED 2 green | 1bin | LED 2 leuchte gelb
... | ... | ...
7 | LED 8 green | 1bin | LED 8 leuchte gelb


KL8528 - Control- und Status-Bytes

Datenstrukturen der Module [image] KL8528 [image] KL8528 - Control- und Status-Bytes
KL8528 - Control- und Status-Bytes
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 im Prozessdatenbetrieb
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 - CB1.0 | - | 0bin | reserviert
Status-Byte 1 im Prozessdatenbetrieb
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 - SB1.0 | - | 0bin | reserviert
Registerkommunikation
Control-Byte 1 bei Registerkommunikation
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIN1 lesen oder - mit dem Ausgangsdatenwort DataOUT1 beschreiben wollen.
Status-Byte 1 bei Registerkommunikation
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2 bis 8
Die Control- und Status-Bytes der Kanäle 2 bis 8 sind jeweils wie das Control- und Status-Byte des Kanals 1 aufgebaut.


KL8528 - Registerübersicht

Datenstrukturen der Module [image] KL8528 [image] KL8528 - Registerübersicht
KL8528 - Registerübersicht
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R6 | reserviert | - | - | - | -
R7 | Kommando-Register | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | 0x2150 | 8528dez | R | ROM
R9 | Firmware-Stand (ASCI) | z. B. 0x2150 | z. B. 12609dez | R | ROM
R10 | Multiplex-Schieberegister |  |  | R | ROM
R11 | Signalkanäle |  |  | R | ROM
R12 | minimale Datenlänge eines Kanals |  |  | R | ROM
R13 | Datenstruktur |  |  | R | ROM
R14 | reserviert | - | - | - | -
R15 | Alignment-Register |  |  | R/W | RAM
R16 | Hardware-Versionsnummer | z. B. 0x0000 | z. B. 0dez | R/W | SEEPROM
R17 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R30 | reserviert | - | - | - | -
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | Disable Channel LED | 0x0000 | 0dez | R/W | SEEPROM
R33 | K-Bus off Reaction | 0x0000 | 0dez | R/W | SEEPROM
R34 | reserviert | - | - | - | -
... | reserviert | - | - | - | -
R63 | reserviert | - | - | - | -


KL8528 - Registerbeschreibung

Datenstrukturen der Module [image] KL8528 [image] KL8528 - Registerbeschreibung
KL8528 - Registerbeschreibung
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
R7: Kommando-Register
Um ein Standardkommando auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein.
Kommando 0x7000: Restore Factory Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register die Werte des Auslieferungszustands wiederhergestellt:
▪
Register R32: 0x0000
▪
Register R33: 0x0000
bis
▪
Register R63: 0x0000
R8: Klemmenbezeichnung
Im Register R8 steht die Bezeichnung der Klemme.
KL8528: 0x2150 (8528dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R12: Minimale Datenlänge eines Kanals
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Disable Channel LED
Mit diesem Register können Sie die Status-LEDs der einzelnen Kanäle deaktivieren.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | - | - | - | -
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | disLED_Ch8 | disLED_Ch7 | disLED_Ch6 | disLED_Ch5 | disLED_Ch4 | disLED_Ch3 | disLED_Ch2 | disLED_Ch1
Legende
Bit | Name | Beschreibung |  | default
R32.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.8 | - | reserviert |  | 0bin
R32.7 | disLED_Ch8 | 0bin | Die LED zeigt den Zustand des Ausgangs 8 an. Im Fall eines K-Bus-Fehlers blinkt die LED. | 0bin
 |  | 1bin | Die LED zeigt den Zustand des Ausgangs 8 nicht an. Die SPS kann die LED nun wahlweise grün oder rot schalten. Im Fall eines K-Bus-Fehlers erlischt die LED.
R32.6 | disLED_Ch7 | 0bin | Die LED zeigt den Zustand des Ausgangs 7 an. Im Fall eines K-Bus-Fehlers blinkt die LED. | 0bin
 |  | 1bin | Die LED zeigt den Zustand des Ausgangs 7 nicht an. Die SPS kann die LED nun wahlweise grün oder rot schalten. Im Fall eines K-Bus-Fehlers erlischt die LED.
... | ... | ... |  | ...
R32.0 | disLED_Ch1 | 0bin | Die LED zeigt den Zustand des Ausgangs 1 an. Im Fall eines K-Bus-Fehlers blinkt die LED. | 0bin
 |  | 1bin | Die LED zeigt den Zustand des Ausgangs 1 nicht an. Die SPS kann die LED nun wahlweise grün oder rot schalten. Im Fall eines K-Bus-Fehlers erlischt die LED.
R33: Reaktion auf K-Bus-Fehler
Bei K-Bus Fehler gehen alle Ausgänge, die über die SPS gesetzt worden sind aus. Es sei denn in R33 sind andere Vorgaben gemacht.
Bit | R33.15 | R33.14 | R33.13 | R33.12 | R33.11 | R33.10 | R33.9 | R33.8
Name | - | - | - | - | - | - | - | -
Bit | R33.7 | R33.6 | R33.5 | R33.4 | R33.3 | R33.2 | R33.1 | R33.0
Name | KBOR_Ch8 | KBOR_Ch7 | KBOR_Ch6 | KBOR_Ch5 | KBOR_Ch4 | KBOR_Ch3 | KBOR_Ch2 | KBOR_Ch1
Legende
Bit | Name | Beschreibung |  | default
R33.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R33.8 | - | reserviert |  | 0bin
R33.7 | K-Bus-OFF-Reaction_Ch8 | 0bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 8 zurückgesetzt (0bin). | 0bin
 |  | 1bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 8 gesetzt (1bin).
R33.6 | K-Bus-OFF-Reaction_Ch7 | 0bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 7 zurückgesetzt (0bin). | 0bin
 |  | 1bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 7 gesetzt (1bin).
... | ... | ... |  | ...
R33.0 | K-Bus-OFF-Reaction_Ch1 | 0bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 1 zurückgesetzt (0bin). | 0bin
 |  | 1bin | Im Fall eines K-Bus-Fehlers wird der Ausgang 1 gesetzt (1bin).


KL8548

Datenstrukturen der Module [image] KL8548
KL8548
Weiterführende Informationen
•
KL8548 - Prozessabbild
•
KL8548 - Control- und Status-Bytes
•
KL8548 - Registerübersicht
•
KL8548 - Registerbeschreibung


KL8548 - Prozessabbild

Datenstrukturen der Module [image] KL8548 [image] KL8548 - Prozessabbild
KL8548 - Prozessabbild
Die KL8548 stellt sich im Prozessabbild mit jeweils 24 Byte Eingangs- und 24 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | SB1 | CB1
1 | 2 | Wort | DataIN1 | DataOUT1
3 | 4 | Byte | SB2 | CB2
4 | 6 | Wort | DataIN2 | DataOUT2
6 | 8 | Byte | SB3 | CB3
7 | 10 | Wort | DataIN3 | DataOUT3
9 | 12 | Byte | SB4 | CB5
10 | 14 | Wort | DataIN4 | DataOUT4
12 | 16 | Byte | SB1 | CB1
13 | 18 | Wort | DataIN5 | DataOUT5
15 | 20 | Byte | SB2 | CB2
16 | 22 | Wort | DataIN6 | DataOUT6
18 | 24 | Byte | SB3 | CB3
19 | 26 | Wort | DataIN7 | DataOUT7
21 | 28 | Byte | SB4 | CB5
22 | 30 | Wort | DataIN8 | DataOUT8
*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen
Legende
SB1 bis SB8: Status-Bytes der Kanäle 1 bis 8
CB1 bis CB8: Control-Bytes der Kanäle 1 bis 8
DataIN1 bis DataIN8: Eingangsworte der Kanäle 1 bis 8
DataOUT1 bis DataOUT8: Ausgangsworte der Kanäle 1 bis 8
Control- und Status-Byte
Siehe Kapitel Control- und Status-Byte
Prozessdaten
Eingangsdaten (DataIN1 bis DataIN8)
Stellung der Potentiometer bei ausgeschalteter Anwender-Skalierung (R32.0 = 0)
Potentiometer- stellung | Eingangswert in der SPS
 | hexadezimal | dezimal
Linksanschlag | 0x0000 | 0
Mitte | 0x3FFF | 16383
Rechtsanschlag | 0x7FFF | 32767
Ausgangsdaten (DataOUT1 bis DataOUT8)
Vorgabe der Ausgangswerte durch die Steuerung.
Ausgabewert |  | Ausgangsspannung
hexadezimal | dezimal
0x0000 | 0 | 0 V
0x3FFF | 16383 | +5 V
0x7FFF | 32767 | +10 V


KL8548 - Control- und Status-Bytes

Datenstrukturen der Module [image] KL8548 [image] KL8548 - Control- und Status-Bytes
KL8548 - Control- und Status-Bytes
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 im Prozessdatenbetrieb
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 - CB1.0 | - | 0bin | reserviert
Status-Byte 1 im Prozessdatenbetrieb
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | - | - | - | - | - | - | auto/man
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 - SB1.1 | - | 0bin | reserviert
SB1.0 | auto/man | 0bin | Der auto/man-Schalter des Kanals 1 steht auf auto. Die SPS steuert den Ausgang.
 |  | 1bin | Der auto/man-Schalter des Kanals 1 steht auf manuell. Das Potentiometer steuert den Ausgang.
Registerkommunikation
Control-Byte 1 bei Registerkommunikation
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIN1 lesen oder - mit dem Ausgangsdatenwort DataOUT1 beschreiben wollen.
Status-Byte 1 bei Registerkommunikation
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2 bis 8
Die Control- und Status-Bytes der Kanäle 2 bis 8 sind jeweils wie das Control- und Status-Byte des Kanals 1 aufgebaut.


KL8548 - Registerübersicht

Datenstrukturen der Module [image] KL8548 [image] KL8548 - Registerübersicht
KL8548 - Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R6 | reserviert | - | - | - | -
R7 | Kommando-Register | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | 0x2164 | 8548dez | R | ROM
R9 | Firmware-Stand (ASCI) | z. B. 0x3141 | z. B. 12609dez | R | ROM
R10 | Multiplex-Schieberegister |  |  | R | ROM
R11 | Signalkanäle |  |  | R | ROM
R12 | minimale Datenlänge eines Kanals |  |  | R | ROM
R13 | Datenstruktur |  |  | R | ROM
R14 | reserviert | - | - | - | -
R15 | Alignment-Register |  |  | R/W | RAM
R16 | Hardware-Versionsnummer | z. B. 0x0000 | z. B. 0dez | R/W | SEEPROM
R17 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R30 | reserviert | - | - | - | -
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register | 0x0004 | 4dez | R/W | SEEPROM
R33 | Anwender-Skalierung: offset | 0x0000 | 0dez | R/W | SEEPROM
R34 | Anwender-Skalierung: gain | 0x0100 | 256dez | R/W | SEEPROM
R35 | Anwender-Einschaltwert | 0x0000 | 0dez | R/W | SEEPROM
R36 | reserviert | - | - | - | -
... | reserviert | - | - | - | -
R63 | reserviert | - | - | - | -


KL8548 - Registerbeschreibung

Datenstrukturen der Module [image] KL8548 [image] KL8548 - Registerbeschreibung
KL8548 - Registerbeschreibung
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
R7: Kommando-Register
Nicht benutzt.
R8: Klemmenbezeichnung
Im Register R8 steht die Bezeichnung der Klemme.
KL8548: 0x2164 (KL8548dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R12: Minimale Datenlänge eines Kanals
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Mit diesem Register für diesen Kanal verschiedene Features ein- oder ausschalten.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | - | - | - | enUserValue
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | enEcoMode | - | enWatchdog | - | -
Legende
Bit | Name | Beschreibung |  | default
R32.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.9 | - | reserviert |  | 0bin
R32.8 | enUserValue | 0bin | Anwender-Einschaltwert aktiviert | 0bin
 |  | 1bin | Anwender-Einschaltwert deaktiviert
R32.7 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.5 | - | reserviert |  | 0bin
R32.4 | enEcoMode | 0bin | Bargraph aktiviert | 0bin
 |  | 1bin | Eco-Mode aktiviert
R32.3 | ... | reserviert |  | ...
R32.2 | enWatchdog | 0bin | Watchdog deaktiviert | 1bin
 |  | 1bin | Watchdog aktiviert
R32.1 | - | reserviert |  | 0bin
R32.0 | - | reserviert |  | 0bin
R33: Anwender-Einschaltwert
Wenn der Anwender-Einschaltwert mit Bit R32.8 des Feature-Registers aktiviert wurde, legt die Klemme anstelle des Hersteller-Einschaltwerts den Anwender-Einschaltwert an ihren Ausgang wenn ein System-Reset oder ein Watchdog-timer-Overflow (Klemme hat 100 ms lang keine Prozessdaten erhalten) auftritt.


Beispiele für die Register-Kommunikation

Datenstrukturen der Module [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Datenstrukturen der Module [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Datenstrukturen der Module [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Hinweis
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.