KL6811, KS6811 - DALI/DSI-Masterklemmen mit integriertem Netzteil

BECKHOFF Feldbuskomponenten

Dokumentation zu

KL6811 / KS6811

DALI/DSI-Masterklemmen mit integriertem Netzteil

Version 1.4.0
Datum: 29.09.2015


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


KL6811 - Ausgabestände der Dokumentation

BECKHOFF KL6811: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
1.4.0
  • Registerbeschreibung korrigiert
  • Technische Daten aktualisiert
  • Vorwort und Anhang aktualisiert
1.3.0
  • Screen-Shots der KS2000 aktualisiert
  • Technische Daten aktualisiert
1.2.2
  • Tragschienenmontage aktualisiert
  • Grundlagen zur Funktion aktualisiert
1.2.1
  • Beschreibung der LEDs aktualisiert
  • Produktübersicht neu gegliedert
1.2
  • Beschreibung der Parametrierung von KL6811 und DALI-Geräten mit der KS2000-Software erweitert
  • Beschreibung des Status-Bytes erweitert
  • technische Daten aktualisiert
  • Registerbeschreibung korrigiert
1.1
  • Beschreibung der Parametrierung von KL6811 und DALI-Geräten mit der KS2000-Software hinzugefügt
  • Beschreibung der DALI-Befehle erweitert
  • Beispiele für Registerkommunikation hinzugefügt
1.0
  • Beschreibung der LEDs und der Kontaktbelegung erweitert
  • Angaben zu Literatur und zur Norm hinzugefügt
  • Übersetzung in englisch verfügbar
0.2 | technische Daten aktualisiert
0.1 | erste Vorabversion

Firm- und Hardware-Stände

Dokumentation Version | KL6811
 | Firmware | Hardware
1.4.0 | 2H | 10
1.3.0 | 2F | 07
1.2.2 | 1J | 04
1.2.1 | 1J | 04
1.2 | 1J | 03
1.1 | 1G | 03
1.0 |  | 01
0.2 |  | 01
0.1 |  | 01

Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.

Syntax der Seriennummer

Aufbau der Seriennummer: WW YY FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 35 04 1B 01:

35 - Produktionswoche 35
04 - Produktionsjahr 2004
1B - Firmware-Stand 1B
01 - Hardware-Stand 01


KL6811 - Einführung

BECKHOFF KL6811: Produktübersicht

Einführung

Die KL6811 erlaubt den Anschluss von bis zu 64 DALI-Slaves. Mit der Konfigurationssoftware KS2000 lässt sich die Parametrierung einfach über einen PC durchführen. Der PC wird über RS232-Schnittstelle oder über den Feldbus direkt an den Buskoppler angekoppelt. Die KL6811 enthält ein integriertes Netzteil (24 VDC) mit galvanisch getrennter Ausgangsspannung. Für den Betrieb der DALI-Slaves sind keine weiteren Komponenten notwendig. Die KL6811 arbeitet feldbusunabhängig.


KL6811 - Technische Daten

BECKHOFF KL6811, KS6811: Produktübersicht

Technische Daten

Technische Daten | KL6811, KS6811
Übertragungskanäle | 1
DALI-Slaves / Gruppen | maximal 64 / maximal 16
Bitbreite im K-Bus E/A | 2 x 8 Bit Nutzdaten, 1 x 8 Bit Control/Status
Bitbreite im Eingangsprozessabbild | 1 Datenwort, 1 Status-Byte
Bitbreite im Ausgangsprozessabbild | 1 Datenwort, 1 Control-Byte
Konfiguration | mit Konfigurations-Software KS2000 über - Buskoppler und Konfigurationskabel - Feldbus
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 55 mA
Stromaufnahme aus den Power-Kontakten | typisch 30 mA + Last
Kurzschlussfestigkeit | ja, automatischer Wiederanlauf
Eingangsspannung | 24 VDC (-15%/+ 20%)
Isolationsspannung | DALI-Bus / K-Bus: dauerhaft 1500 VAC DALI-Bus / Powerkontakte: dauerhaft 1500 VAC K-Bus / Powerkontakte: dauerhaft 500 VAC
DALI / DSI | normkonform, Leerlaufspannung 11,5 ... 15 VDC
Max. High / Low-Pegel | Strom 130 mA / 250 mA
Steckbare Verdrahtung | bei allen KSxxxx-Klemmen
Gewicht | ca. 80 g
Abmessungen (B x H x T) | ca. 15mm x 100mm x 70mm
Montage | auf 35 mm Tragschiene nach EN 60715
Verlustleistung | 0,5 W + Verlustleistung verursacht durch die angeschlossenen DALI-Slaves
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus, ATEX


KL6811 - Grundlagen zur Funktion

BECKHOFF KL6811: Produktübersicht

Grundlagen zur Funktion

Die Ankopplung preissensitiver Aktorik an ein Steuerungssystem ist eine Herausforderung an ein universelles Gateway. Die Beleuchtung in einem Gebäude wird typischerweise durch eine große Anzahl an Geräten realisiert. Der Preis einer Leuchte und damit auch die Anschaltung an ein Steuerungssystem ist daher von großer Bedeutung.

DALI

Das Digital Adressable Lighting Interface (DALI) ist ein einfaches Bussystem für die Gebäudeautomation, das die Signale zur digitalen Ansteuerung von Betriebsgeräten der Lichttechnik überträgt. Hierzu werden Licht-, Sensor-, Taster- und Schaltelemente parallel verdrahtet und über die Steuerung miteinander verknüpft. Auch andere Aktoren, wie Heizventile oder Jalousieantriebe werden zunehmend digital gesteuert.

DALI bietet folgende Vorteile:

  • eine preiswerte Schnittstelle mit einfacher Installation
  • die volldigitale Anschaltung von Leuchten und vergleichbaren Geräten
  • alle namhaften EVG-Hersteller unterstützen DALI

Die DALI-Masterklemme KL6811 von Beckhoff schließt die Lücke zwischen Beleuchtungssteuerung und Leuchte und erlaubt den Anschluss von bis zu 64 DALI-Betriebsgeräten (DALI-Slaves). Die KL6811 wird als ganz normale Busklemme in das Beckhoff Busklemmensystem integriert und ist somit feldbusunabhängig. Der übergeordnete Buskoppler leitet die Daten der DALI-Masterklemme an die Steuerung weiter. Das in der KL6811 integrierte DALI-Netzteil versorgt den DALI-Bus mit Spannung. Darüber hinaus sind keine weiteren Komponenten für den Betrieb des DALI-Stranges notwendig.

In der Hochlaufphase sucht die KL6811 nach angeschlossenen DALI-Slaves und unterstützt den Anwender bei der Inbetriebnahme der Anlage. Mit der Konfigurationssoftware KS2000 können Sie die Parametrierung der DALI-Masterklemme von einen PC aus durchführen. Die Parametrierung erfolgt über den Feldbus oder über eine RS232-Schnittstelle, die mit Konfigurationsschnittstelle des übergeordneten Buskopplers verbunden wird.

DSI

Außerdem können Sie die KL6811 auch als DSI-Master betreiben. Das Digital Serial Interface (DSI) ist ein noch einfacheres Bussystem zur Beleuchtungssteuerung. Der DSI-Master sendet digitale Helligkeitswerte seriell an die DSI-Slaves. Die Helligkeit der Slaves ist von 1% bis 100% einstellbar. Die Zuordnung der Helligkeit zu den Stellwerten ist logarithmisch, so dass bei linearem hochfahren der Stellwerte, die Helligkeit für den menschlichen Betrachter gleichmäßig zunimmt. Die Slaves können durch Vorgabe des Stellwerts 0 dunkel geschaltet werden, ohne deren Netzspannung abschalten zu müssen.


KL6811 - LED-Anzeigen

BECKHOFF KL6811: Produktübersicht

LED-Anzeigen

LED | Nr. | Bedeutung
RUN | A | on | Datenübertragung auf dem K-Bus
Bus | B | blinkt | Activity: Datenübertragung auf dem DALI/DSI-Bus
 |  | an | Keine Spannungsversorgung (24 VDC) für die Power-Kontakte
DALI / DSI | C | an | Betriebsart: DALI-Mode
 |  | aus | Betriebsart: DSI-Mode
Error | D | an | im DALI-Mode: Überlast des internen DALI-Netzteils im DSI-Mode: DSI-Rückmeldung


ELxxxx, KLxxxx - Tragschienenmontage

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Tragschienenmontage

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Montage

Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:

  1. Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
  2. Auf der rechten Seite des Feldbuskoppler werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
    Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.

Hinweis 		Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein.
Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät.
Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.

Demontage

Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:

  1. Ziehen Sie die Klemme an ihren orangefarbige Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
  2. Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.

Verbindungen innerhalb eines Busklemmenblocks

Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:

  • Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
  • Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.

Hinweis 		Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen.
Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.

PE-Powerkontakt

Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.

Achtung 		Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbraucher mit 230 V Nennspannung).

Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.

WARNUNG 		Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Anschlusstechnik

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Anschlusstechnik

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Übersicht

Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:

  • Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
  • Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
  • Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.

Standardverdrahtung

Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und
integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.

Steckbare Verdrahtung

Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt.
Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.

Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.

Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.

Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.

Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.

High-Density-Klemmen (HD-Klemmen)

Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.

Hinweis 		Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.

Ultraschall-litzenverdichtete Leiter

Hinweis 		Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschall verschweißte) Leiter angeschlossen werden.
Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!

Verdrahtung

Klemmen für Standardverdrahtung ELxxxx / KLxxxx und Klemmen für stehende Verdrahtung ESxxxx / KSxxxx

Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:

  1. Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
  2. Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
  3. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.

Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm

High-Density-Klemmen ELx8xx, KLx8xx (HD)

Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässige Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.

Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm

Schirmung

Hinweis 		Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


KL6811 - Anschluss

BECKHOFF KL6811: Montage und Verdrahtung

Anschluss

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Kontaktbelegung
Klemmstelle | Nr. | Anschluss für
DALI + | 1 | DALI/DSI-Steuerleitung (intern verbunden mit Klemmstelle Nr. 4)
+24 V | 2 | Powerkontakt +24 V
0 V | 3 | Powerkontakt 0 V
DALI + | 4 | DALI/DSI-Steuerleitung (intern verbunden mit Klemmstelle Nr. 1)
DALI - | 5 | DALI/DSI-Steuerleitung (intern verbunden mit Klemmstelle Nr. 8)
+24 V | 6 | Powerkontakt +24 V
0 V | 7 | Powerkontakt 0 V
DALI - | 8 | DALI/DSI-Steuerleitung (intern verbunden mit Klemmstelle Nr. 5)

Achtung 		Keine Netzspannung an die Powerkontakte
Die Klemmstellen für die Powerkontakte (+24 V, 0 V) dürfen auf keinen Fall mit 230 V Netzspannung belegt werden, weil die KL6811 dabei zerstört wird.

Hinweis 		Kontakte für die DALI-Steuerleitung (DALI+, DALI-) und Netzspannung
Falls Sie aus versehen die Kontakte für die DALI-Steuerleitung (DALI+, DALI-) mit 230 V Netzspannung belegen, wird die KL6811 nicht zerstört, sondern schaltet sich ab.

Leitungslängen im DALI-Betrieb

Der DALI-Bus kann in Linien-, Stern-Topologie oder einer Mischung aus beidem ausgeführt werden. Die maximale Leitungslänge darf 300 m nicht überschreiten!

Leitungslänge | Leitungsquerschnitt
bis 100 m | mindestens 0,5 mm2
bis 150 m | mindestens 0,75 mm2
bis 300 m | mindestens 1,5 mm2

Weitere wichtige Randbedingungen, die sich aus der IEC 62386 ableiten:

  • Die DALI-Leitungen müssen nicht mit Widerständen abgeschlossen werden.
  • Der maximale Spannungsabfall zwischen Sender und Empfänger darf 2 V nicht überschreiten.
  • Bei Ausnutzung der maximalen Leitungslänge ist es nicht ratsam DALI in Kombination mit der Netzleitung zu verlegen.


ATEX - Besondere Bedingungen

WARNUNG 		Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von
Beckhoff-Feldbuskomponenten in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
  • Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu Berücksichtigungen!
  • Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
  • Beachten Sie beim Einsatz von Beckhoff-Feldbuskomponenten in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
  • Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
  • Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Die Sicherung der Einspeiseklemmen KL92xx dürfen nur gewechselt werden,
    wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Adresswahlschalter und ID-Switche dürfen nur eingestellt werden,
    wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!

Normen

Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:

  • EN 60079-0: 2006
  • EN 60079-15: 2005

Kennzeichnung

Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten tragen eine der folgenden Kennzeichnungen:

II 3 G Ex nA II T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

oder

II 3 G Ex nA nC IIC T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

Seriennummer

Die Beckhoff-Feldbuskomponenten tragen eine Seriennummer, die wie folgt aufgebaut ist:

WW YY FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 35 04 1B 01:

35 - Produktionswoche 35
04 - Produktionsjahr 2004
1B - Firmware-Stand 1B
01 - Hardware-Stand 01


Feldbuskomponenten - ATEX-Dokumentation

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

ATEX-Dokumentation

Hinweis 		Hinweise zum Einsatz des Busklemmensystems in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz des Busklemmen-Systems in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler/Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.

Projektierung

Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, d. h. vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.

Parametrierung

KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.

Inbetriebnahme

KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.

KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:

  • Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
  • Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.

Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Konfiguration der KL6811

Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.

Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
  • ein Buskoppler für Ethernet BK9000
  • eine digitale Eingangsklemme KL1xx2
  • eine DALI-Masterklemme KL6811
  • eine Bus-Endklemme KL9010

Das linken Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.

Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).

Für die KL6811 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:

  • Register erlaubt den direkten Zugriff auf die Register der KL6811.
  • Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL6811.
  • ProcData zeigt die Prozessdaten der KL6811 graphisch.


KS2000 - Register

BECKHOFF KL6811: Konfigurations-Software KS2000

Register

Unter Register können Sie direkt auf die Register der KL6811 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.


KS2000 - Einstellungen

BECKHOFF KL6811: Konfigurations-Software KS2000

Einstellungen

Unter Einstellungen finden Sie die Dialogmasken zur Parametrierung der KL6811 und der daran angeschlossenen DALI/DSI-Geräte.

Geräteeinstellungen

Unter diesem Karteireiter können Sie die Einstellungen der DALI/DSI-Geräte verändern.

Adressierung

Unter diesem Karteireiter können Sie die Adressierung der DALI-Geräte vornehmen.

Optionen

Unter diesem Karteireiter können Sie verschiedene Optionen der KL6811 festlegen.


Einstellungen der DALI/DSI-Geräte

Drücken Sie auf die Schaltfläche Geräte suchen, damit die KL6811 die angeschlossenen DALI/DSI-Geräte einließt. Im Beispiel werden hier 6 DALI-Geräte angezeigt.

Senden von DALI-Befehlen

Klicken Sie auf Geräte.

Befehle an mehrere DALI-Geräte

Adress-Typ

Im DALI-Betrieb können Sie mit dieser Maske einen Befehl zu

  • allen angeschlossenen DALI-Geräten schicken (Sammelruf/Broadcast),
  • einer Gruppe von DALI-Geräten schicken (Gruppe), oder
  • zu einem bestimmten DALI-Gerät schicken (Kurzadresse).

Befehl und Daten

Direkte Steuerung der Lampenleistung

Der erste Befehl des Menüs wird durch einen Intensitätsschieber unterstützt:

  • stellen Sie den Intensitätsschieber auf den gewünschten Wert oder
  • geben Sie einen Wert in das Feld Daten ein

und drücken Sie die Schaltfläche Sende DALI-Befehl. Die KL6811 sendet diesen Wert als direkten DALI-Befehl für die Lampenleistung an alle ausgewählten DALI-Geräte.

Weitere Befehle

Zu allen weiteren Befehlen wird die Befehlsnummer in dezimaler Darstellung angezeigt. Sie sind unter dieser Nummer im Kapitel indirekte DALI-Befehle für die Lampenleistung beschrieben.

Einstellungen für die einzelnen DALI-Geräte

Für die Steuerung jedes erkannten DALI-Gerätes stehen ihnen jeweils 4 Dialogmasken zur Verfügung:

  • Lichtsteuerung/Abfrage (klicken Sie hierzu direkt auf Gerät #xx)
  • Variablen
  • Gruppen
  • Szenen

Optische Auswahlrückmeldung

Wenn die Option optische Auswahlrückmeldung aktiviert ist, setzt das setzt das ausgewählte Gerät (im Beispiel Gerät #04) seinen aktuellen Lampenleistungswert auf den parametrierten Maximalwert.

Senden von DSI-Befehlen

Im DSI-Betrieb können Sie mit dieser Maske die gleiche Lichtstärke zu allen angeschlossenen DSI-Geräten schicken:

  • stellen Sie den Intensitätsschieber auf den gewünschten Wert oder
  • geben Sie einen Wert in das Feld Daten ein

und drücken Sie die Schaltfläche Sende DSI-Befehl. Die KL6811 sendet diesen Wert an alle angeschlossenen DSI-Geräte.


Einstellungen der DALI-Geräte - Lichtsteuerung, Abfragen

BECKHOFF KL6811: Konfigurations-Software KS2000

Lichtsteuerung / Abfragen

Klicken Sie auf die Gerätenummer (im Beispiel Gerät #00). Es erscheint die Dialogmaske mit den Bereichen direkte Lichtsteuerung, indirekte Lichtsteuerung und Abfrage.

Direkte Lichtsteuerung (Steuerung über direkte DALI-Befehle für die Lampenleistung)

Setzt die Lichtstärke auf den vorgegebenen Wert.

Indirekte Lichtsteuerung (Steuerung über indirekte DALI-Befehle für die Lampenleistung)

Für die wichtigsten Funktionen stehen hier Schaltflächen zur Verfügung, die einen entsprechenden DALI-Befehl zum ausgewählten Gerät senden.

Ausschalten

Schaltet die am DALI-Gerät angeschlossenen Lampe ohne Fading aus (sendet den DALI-Befehl 0 dez).

Dunkler

Stellt die am DALI-Gerät angeschlossenen Lampe 200 ms lang mit mit ausgewählter Stufengeschwindigkeit dunkler (sendet den DALI-Befehl 2 dez)

Heller

Stellt die am DALI-Gerät angeschlossenen Lampe 200 ms lang mit mit ausgewählter Stufengeschwindigkeit heller (sendet den DALI-Befehl 1 dez)

Eine Stufe dunkler

Setzt den aktuellen Lampenleistungswert ohne Fading eine Stufe niederiger (sendet den DALI-Befehl 4 dez), falls die Lampe nicht bereits bereits ihrem parametrierten Minimalwert (MIN-Wert) hat. Falls die Lampe bereits ihrem MIN-Wert hat, wird sie nicht verändert und bleibt eingeschaltet. Den Minimalwert können Sie im unter dem Karteireiter Variablen parametrieren.

Eine Stufe heller

Setzt den aktuellen Lampenleistungswert ohne Fading eine Stufe höher (sendet den DALI-Befehl 3 dez), falls sie bereits eingeschaltet ist. Falls die Lampe ausgeschaltet ist, wird sie nicht eingeschaltet.

Eine Stufe dunkler und ausschalten

Setzt den aktuellen Lampenleistungswert ohne Fading eine Stufe niederiger (sendet den DALI-Befehl 7 dez). Falls die Lampe bereits ihren parametrierten Minimalwert (MIN-Wert) hat, wird sie ausgeschaltet. Den MIN-Wert können Sie unter dem Karteireiter Variablen parametrieren.

Einschalten und eine Stufe Heller

Setzt den aktuellen Lampenleistungswert ohne Fading eine Stufe höher (DALI-Befehl 8 dez). Falls die Lampe ausgeschaltet ist, wird sie eingeschaltet und auf ihren parametrierten Minimalwert (MIN-Wert) gestellt. Den MIN-Wert können Sie im unter dem Karteireiter Variablen parametrieren.

Abruf von MIN-Wert

Setzt den Lampenleistungswert auf den parametrierten Minimalwert (sendet DALI-Befehl 6 dez). Falls die Lampe ausgeschaltet war, wird sie eingeschaltet.

Abruf von MAX-Wert

Setzt den Lampenleistungswert auf den parametrierten Maximalwert (sendet DALI-Befehl 5 dez). Falls die Lampe ausgeschaltet war, wird sie eingeschaltet.

Gehe zu Szene
  • Wählen Sie eine Szene aus.
  • Drücken Sie die Schaltfläche gehe zu Szene.

Setzt den Lampenleistungswert des DALI-Geräts auf den für die ausgewählten Szene parametrierten Wert (sendet einen DALI-Befehl von 16 bis 31 dez). Diesen Wert können Sie im unter dem Karteireiter Szenen parametrieren.

Abfragen

Mit diesem Dialog können Sie Informationen über den Status des DALI-Geräts abfragen:

  • Wählen Sie die gewünschte Abfrage aus.
  • Drücken Sie die Schaltfläche Sende Abfrage.
Abfrage Vorschaltgerät

Fragt, ob das DALI-Gerät für den Datenaustausch bereit ist (DALI-Befehl 145dez).

Abfrage Lampenausfall

Fragt ab, ob das DALI-Gerät ein Lampenproblem hat (DALI-Befehl 146 dez).

Abfrage Stromversorgung Lampe eingeschaltet

Fragt ab, ob die Stromversorgung des DALI-Geräts eingeschaltet ist (DALI-Befehl 147 dez).

Abfrage Grenzwertfehler

Fragt ab, ob auf dem DALI-Gerät ein Grenzwertfehler aufgetreten ist (DALI-Befehl 148 dez).

Abfrage Rücksetzzustand

Fragt ab, ob sich das DALI-Gerät im Rücksetzzustand befindet (DALI-Befehl 149 dez).

Abfrage Kurzadresse fehlt

Fragt ab, ob dem DALI-Gerät die Kurzadresse fehlt (DALI-Befehl 150 dez).

Abfrage Inhalt DTR

Liest aus dem DALI-Gerät den Inhalt des Data-Transfer-Registers (DTR) aus (DALI-Befehl 152 dez).

Abfrage Gerätetyp

Liest den Typ des DALI-Geräts aus (DALI-Befehl 153 dez). Es gibt folgende Gerätetypen:
0: Standardgerät
1: Gerät für Notbeleuchtung
2: Gerät für HID-Lampen
3: Gerät zum dimmen von Glühlampen
5 bis 255 sind für zukünftige Gerätetypen reserviert. Weitere Informationen entnehmen Sie bitte der Norm DIN EN 60929.

Abfrage Störung der Stromversorgung

Fragt ab, ob am DALI-Gerät eine Störung der Stromversorgung aufgetreten ist (DALI-Befehl 155 dez).


Einstellungen der DALI-Geräte - Variablen

BECKHOFF KL6811: Konfigurations-Software KS2000

Variablen

Bei DALI wurde die Intelligenz nicht zu 100% zentralisiert. Das bedeutet, dass viele Einstellungen und Lichtwerte in Form von Variablen in den Vorschaltgeräten gespeichert sind.
Klicken Sie auf Variablen. Es erscheint eine Dialogmaske, mit der Sie die Variablen des ausgewählten DALI-Geräts überprüfen und editieren können.

Aktueller Dimmwert

Diese Variable beinhaltet den aktuellen Lampenleistungswert der Lampe.

Stromversorgung-EIN-Wert

Diese Variable legt fest, welchem Lampenleistungswert das DALI-Gerät nach dem Einschalten der Stromversorgung stellt , wenn der DALI-Bus dabei schon mit Spannung versorgt wird und im Ruhepegel ist.

Systemfehler-Wert

Diese Variable legt fest, welchem Lampenleistungswert das DALI-Gerät im Fall eines Systemfehlers stellt.

MIN-Wert

Legen Sie hier den minimalen Lampenleistungswert fest, den das DALI-Gerät stellen soll, damit die Beleuchtungsstärke eine von Ihnen gewünschte Helligkeit nicht unterschreitet. Der MIN-Wert kann den vom Hersteller des DALI-Geräts vorgegebenen physikalisch kleinstmöglichen Wert nicht unterschreiten.

MAX-Wert

Legen Sie hier den maximalen Lampenleistungswert fest, den das DALI-Gerät stellen soll, damit die Beleuchtungsstärke eine von Ihnen gewünschte Helligkeit nicht überschreitet.

Stufengeschwindigkeit

Geben Sie hier die Geschwindigkeit in Schritte pro Sekunde (Steps/s) an, mit der das DALI-Gerät bei den Befehlen Heller (DALI-Befehl 1 dez) oder Dunkler (DALI-Befehl 2 dez) für 200 ms dimmt. Die absolute Stufengeschwindigkeit wird nicht direkt angegeben, sondern nach folgender Formel berechnet:

T = absolute Stufengeschwindigkeit
n = Wert, der in der Variablen Stufengeschwindigkeit abgelegt wurde

Es ergeben sich folgende Werte:

n | absolute Stufengeschwindigkeit
0 | nicht erlaubt
1 | 357,796 Stufen/s
2 | 253,000 Stufen/s
3 | 178,898 Stufen/s
4 | 126,500 Stufen/s
5 | 89,449 Stufen/s
6 | 63,250 Stufen/s
7 | 44,725 Stufen/s
8 | 31,625 Stufen/s
9 | 22,362 Stufen/s
10 | 15,813 Stufen/s
11 | 11,181 Stufen/s
12 | 7,906 Stufen/s
13 | 5,591 Stufen/s
14 | 3,953 Stufen/s
15 | 2,795 Stufen/s
Stufenzeit

Geben Sie hier die Zeit in Sekunden an, die das DALI-Gerät z.B. bei Szenenwechsel oder der Ausführung von direkten DALI-Befehlen für die Lampenleistung für die Helligkeitsänderung benötigt. Diese Zeit ist unabhängig von der Größe der Änderung, damit alle Lampen zur gleichen Zeit die Änderung abgeschlossen haben. Im Falle einer ausgeschalteten Lampe ist die Vorheiz- und Zündzeit nicht in der Stufenzeit enthalten.
Die absolute Stufenzeit wird nicht direkt angegeben, sondern nach folgender Formel berechnet:

T = absolute Stufenzeit
n = Wert, der in der Variablen Stufenzeit abgelegt wurde

Es ergeben sich folgende Werte:

n | absolute Stufenzeit
0 | < 0,707 s
1 | 0,707 s
2 | 1,000 s
3 | 1,414 s
4 | 2,000 s
5 | 2,828 s
6 | 4,000 s
7 | 5,657 s
8 | 8,000 s
9 | 11,314 s
10 | 16,000 s
11 | 22,627 s
12 | 32,000 s
13 | 45,255 s
14 | 64,000 s
15 | 90,510 s
Direktadresse

Diese Variable beinhaltet die Kurzadresse des DALI-Geräts fest. Eine gültige Kurzadresse liegt im Wertebereich von 0dez bis 63dez. Wenn Sie 255dez in die Variable schreiben, so wird die Kurzadresse gelöscht.

Statusinformationen

Diese Variable kann nur gelesen werden! Sie enthält das Statusbyte des DALI-Geräts. Die Bits des Statusbytes haben folgende Bedeutung:

Bit | Name |  | Bedeutung
7 | Störung der Stromversorgung | 0bin | Nein
6 | Kurzadresse fehlt | 0bin | Nein
5 | Rücksetzzustand | 0bin | Nein
4 | Stufung fertig | 0bin | Stufung ist beendet
 |  | 1bin | Stufung läuft
3 | Grenzwertfehler | 0bin | Der letzte angeforderte Lampenleistungswert lag zwischen MIN-Wert und MAX-Wert oder war AUS.
2 | Lampenleistung | 0bin | AUS
 |  | 1bin | EIN
1 | Lampenausfall | 0bin | O.K.
0 | Status des DALI-Geräts | 0bin | O.K.
Versionsnummer

Zeigt die Versionsnummer des DALI-Geräts an. Diese Variable wurde vom Gerätehersteller hinterlegt und kann nur gelesen werden!

Physikalisch kleinstmöglicher Wert

Zeigt den physikalisch kleinstmöglichen Lampenleistungswert an, den das DALI-Gerät annehmen kann. Diese Variable wurde vom Gerätehersteller hinterlegt und kann nur gelesen werden!


Einstellungen der DALI-Geräte - Gruppen

BECKHOFF KL6811: Konfigurations-Software KS2000

Gruppen

Klicken Sie auf Gruppen. Es erscheint die Dialogmaske zur Zuordnung des DALI-Geräts zu einer Gruppe.

Mit diese Maske können Sie jedes DALI-Geräte zu bis zu 16 Gruppen hinzufügen. Wenn ein DALI-Gerät einen Befehl in Verbindung mit einer für sich parametrierten Gruppen-Nummer empfängt, wird es diesen Befehl ausführen.


Einstellungen der DALI-Geräte - Szenen

BECKHOFF KL6811: Konfigurations-Software KS2000

Szenen

Mit dieser Maske können Sie auf jedem DALI-Gerät die Lichtstärken für 16 verschiedene Szenen hinterlegen. Wenn ein DALI-Gerät eine für sich parametrierte Szenen-Nummer empfängt (z.B. im Rahmen einer Broadcast), wird es die für diese Szene festgelegte Lichtstärke stellen. Falls für diese Szene der Wert 255 (Maske) hinterlegt ist, wird das DALI-Gerät den vorherigen Wert beibehalten.


Adressierung der DALI-Geräte

Physikalische Auswahl

Hinweis 		Adressierungsvorgang nicht unterbrechen
Der Adressierungsvorgang darf nicht durch andere DALI-Befehle unterbrochen werden. Stellen Sie dies sicher indem Sie z.B. vor Beginn der Adressierung Ihr SPS-Programm oder den K-Bus-Zyklus unterbrechen.
Handlungsabfolge für die physikalische Adressierung
  1. Drücken Sie auf die Schaltfläche Start um das Adressierungsvorgang zu Starten.

    Hinweis     		Adressen
    Wenn Sie komplette Neuinstallation angewählt haben, werden alle bisherigen Adressen gelöscht. Andernfalls können Sie zur bisherigen Adressierung weitere Geräte hinzufügen.
    Wenn Sie alle Gruppenzuordnungen löschen nicht angewählt haben, bleibt die Zuordnung der Adressen zu den Gruppen erhalten. Beachten Sie dies bei der Neuvergabe der Adressen!
  2. In der Statuszeile erscheint nun folgende Aufforderung:
    Warte auf Auswahl eines Geräts. Entfernen Sie das Leuchtmittel!
  3. Nach entfernen des Leuchtmittel erscheint in der Statuszeile folgende Aufforderung:
    Das Gerät wurde adressiert. Fügen Sie das Leuchtmittel wieder ein!
    Nach wiedereinfügen des Leuchtmittels leuchtet dieses dreimal auf, um die erfolgreiche Adressvergabe anzuzeigen.
    Das neuadressierte Gerät wird nun in der Liste der Kurzadressen angezeigt.
  4. Führen Sie Punkt 2 und Punkt 3 bei jedem neu zu Adressierenden DALI-Gerät durch.
  5. Wenn Sie alle Adressen vergeben haben, beenden Sie den Adressierungsvorgang mit der Schaltfläche Abbrechen.

Die neuadressierten Geräte werden in der Liste der Kurzadressen angezeigt:

Zufällige Adressierung

Bei dieser Methode werden die Adressen per Zufall vergeben.

Der Bediener hat keinen Einfluss auf die Reihenfolge der Adressvergabe. Er kann sie aber im nachhinein mit der Registerlasche Adressen ändern anpassen.

Einzelzuweisung

Bei dieser Methode bekommen alle an der KL6811 angeschlossenen DALI-Slaves die gleiche neue Adresse zugeteilt. In der Praxis werden Sie also nur den einen DALI-Slave anschließen, der diese Adresse erhalten soll bevor Sie die Schaltfläche Start drücken.

Adressen ändern

Markieren Sie in der rechten Liste das Gerät, dessen Adresse Sie ändern möchten. Über die Auswahlbox neue Adresse können Sie für das markierte Gerät eine neue Adresse auswählen.
Nachdem Sie alle neuen Adressen ausgewählt haben, klicken Sie auf die Schaltfläche Start um diese Adressen den Geräten zuzuweisen.

Optische Auswahlrückmeldung

Wenn die Option optische Auswahlrückmeldung aktiviert ist, setzt das ausgewählte Gerät (im Beispiel Gerät #04) seinen aktuellen Lampenleistungswert auf den parametrierten Maximalwert.


KL6811 - KS2000-Optionen

BECKHOFF KL6811: Konfigurations-Software KS2000

Optionen der KL6811

Mit dieser Maske können Sie verschiedene Optionen für die KL6811 festlegen.

Betriebsart (R32.12-15)

Hier können Sie die Betriebsart der KL6811 festlegen:
  • DALI: Die KL6811 arbeitet als DALI-Master
  • DSI: Die KL6811 arbeitet als DSI-Master

Netzteil (R32.3)

Hier können Sie das DALI/DSI-Netzteil abschalten.

DALI-Geräte zählen (R32.4)

Hier können Sie das zählen der DALI-Geräte nach dem Hochlaufen der KL6811 abschalten.

Firmware-Version (R9)

Zeigt die Firmware-Version der KL6811 an.


Archiv

Mit diesen Masken können Sie in übersichtlichen Tabellen für die an der KL6811 angeschlossenen DALI-Slaves

  • die Lichtwerte für 16 Szenen vorgeben.
  • die Zugehörigkeit zu 16 Gruppen vorgeben.

Szenen

Hier können Sie für bis zu 64 DALI-Slaves (vertikal aufgelistet) die Lichtwerte für bis zu 16 Szenen (horizontal aufgelistet) vorgeben.

Zulässig sind folgende Einträge:

  • 0 bis 254: Lichtwerte (0: aus, 254: maximale Helligkeit)
  • 255: Maske (Der Slave behält beim Wechsel auf die neue Szene seinen bisherigen Wert).

Im dargestellten Beispiel wird für

  • DALI-Slave 1 für Szene 3 der Lichtwert 50, für Szene 5 der Lichtwert 100 und für Szene 10 der Lichtwert 250 projektiert.
  • DALI-Slave 8 für Szene 4 der Lichtwert 200, für Szene 6 der Lichtwert 150 und für Szene 12 der Lichtwert 20 projektiert.
  • DALI-Slave 18 für die Szenen 3, 4,5, 6, 10 und 12 der Lichtwert 254 projektiert.
Optische Auswahlrückmeldung

Falls die Option optische Auswahlrückmeldung aktiviert ist und Sie in eine Szenenspalte klicken, nehmen alle DALI-Slaves dieser Szene die in dieser Spalte eingetragenen Lichtwerte an.
Hierzu muss außerdem in KS2000 unter Optionen Online Monitoring aktiviert sein und auf dem Buskoppler die LED I/O Run leuchten!

Gruppen

Hier können Sie für bis zu 64 DALI-Slaves (vertikal aufgelistet) die Zugehörigkeit für bis zu 16 Gruppen (horizontal aufgelistet) vorgeben.

Zulässig sind folgende Einträge:

  • 1: DALI-Slave gehört zur Gruppe
  • 0: DALI-Slave gehört nicht zur Gruppe

Im dargestellten Beispiel wird

  • DALI-Slave 1 den Gruppen 7, 9 und 11 zugeordnet.
  • DALI-Slave 8 den Gruppen 2, 8 und 10 zugeordnet.
  • DALI-Slave 18 den Gruppen 2, 7, 8, 9, 10 und 11 zugeordnet.
Optische Auswahlrückmeldung

Falls die Option optische Auswahlrückmeldung aktiviert ist und Sie auf eine Gruppennummer klicken, leuchten alle DALI-Slaves dieser Gruppe mit maximaler Helligkeit.
Hierzu muss außerdem in KS2000 unter Optionen Online Monitoring aktiviert sein und auf dem Buskoppler die LED I/O Run leuchten!

Optionen

Öffnen

Öffnet eine auf Festplatte des PCs abgespeicherte Konfiguration (*.xml).

Speichern

Speichert die Konfiguration in einer Datei (*.xml) auf der Festplatte des PCs.

Download

Speichert die Konfiguration in den angeschlossenen DALI-Slaves.

Upload

Lädt die Konfiguration aus den angeschlossenen DALI-Slaves.


KS2000 - Prozessdaten

BECKHOFF KL6811: Konfigurations-Software KS2000

Prozessdaten

Unter ProcData werden die Prozessdaten graphisch dargestellt.


Prozessabbild

Die KL6811 stellt sich im Prozessabbild mit jeweils 3 Byte Ein- und Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:

Byte-0ffset (ohne Word-Alignment*) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | Status-Byte (SB) | Control-Byte (CB)
1 | 2 | Wort | DataIN | DataOUT

*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen

Prozessdatenworte im DALI-Betrieb

Prozessausgangswort (DataOUT)

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Y | Adressbits (A) |  |  |  |  |  | S | Befehl (X)
Legende
Bit | Name | Beschreibung
15 | Y | 0bin | Die Adressbits 9 bis 14 enthalten eine DALI-Kurzadresse.
 |  | 1bin | Die Adressbits 9 bis 14 enthalten eine DALI-Gruppenadresse oder einen DALI-Sammelruf.
14 bis 9 | Adressbits (A) | 0bin | DALI-Kurzadresse, DALI-Gruppenadresse oder DALI-Sammelruf
8 | Auswahlbit (S) | 0bin | Die Bits 0 bis 7 enthalten einen Lampenleistungswert.
 |  | 1bin | Die Bits 0 bis 7 enthalten einen DALI-Befehl.
7 bis 0 | Befehl (X) | Lampenleistungswert oder DALI-Befehl*

*) Eine Liste der DALI-Befehle finden Sie im Kapitel DALI-Befehle.

Hinweis 		Befehlesempfang der DALI-Slaves
Beachten Sie, dass DALI-Slaves erst dann Befehle empfangen können, wenn ihre Lastseite mit Spannung (230 V) versorgt wird, weil der PIC (Ein-Chip-Mikrocontroller) eines DALI-Slaves typischerweise über die Lastspannung versorgt wird.

Prozesseingangswort (DataIN)

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | reserviert |  |  |  |  |  |  | O.K. | Parameter
Legende
Bit | Name | Beschreibung
15 bis 9 | - | reserviert
8 | O.K. | 0bin | Bit 0 bis 7 enthalten keine gültigen Daten
 |  | 1bin | Bit 0 bis 7 enthalten die gültige Antwort eines DALI-Slaves
7 bis 0 | Parameter | Antwort eines DALI-Slaves

Prozessdatenworte im DSI-Betrieb

Prozessausgangswort (DataOUT)

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | reserviert |  |  |  |  |  |  |  | DSI-Dimmwert
Legende
Bit | Name | Beschreibung
15 bis 8 | - | reserviert
7 bis 0 | DSI-Dimmwert | Geben Sie hier den 8-Bit Dimmwert für alle DSI-Slaves vor.

Prozesseingangswort (DataIN)

Das Prozesseingangswort ist im DSI-Betrieb ohne Funktion.

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | reserviert


Control- und Status-Bytes

BECKHOFF KL6811: Zugriff aus dem Anwenderprogramm

Control- und Status-Byte

Prozessdatenbetrieb

Control-Byte im Prozessdatenbetrieb

Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur KL6811 übertragen.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess |  | - | - | - | - | RepeatASC | Toggle
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB.6 | R/W | 0bin | Lesezugriff
CB.5 bis CB.2 | - | reserviert
CB.1 | RepeatASC | 0bin | Die KL6811 wiederholt die anwendungsbezogenen Erweiterungsbefehle (224dez-255dez) nicht.
 |  | 1bin | Die KL6811 wiederholt auch die anwendungsbezogenen Erweiterungsbefehle (224dez-255dez).
CB.0 | Toggle | Mit jedem Flankenwechsel des Toggle-Bits sendet die KL6811 ein DALI- oder DSI-Telegramm. Die Telegramme können im Abstand von 25 ms gesendet werden, d.h. innerhalb von 100 ms kann die KL6811 maximal 4 Telegramme senden. Ein DALI-Telegrammzyklus dauert je nach Inhalt (mit oder ohne Rückkanal) zwischen 25 und 43,34 ms. Der Abschluss eines DALI-Telegrammzyklusses wird durch eine Flanke des Toggle-Bits im Status-Byte (SB.0) angezeigt.

Status-Byte im Prozessdatenbetrieb

Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der KL6811 zur Steuerung übertragen.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | - | - | - | BC Collision | FC Collision | Toggle
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB.6 | Error | 0bin | kein Fehler
1bin Fehler:
  • Im DALI-Betrieb bei Nutzung des internen DALI-Netzteils der KL6811: Überlastung des internen DALI-Netzteils der KL6811 (Busunterspannung)
  • Im DSI-Betrieb: Fehlermeldung von einem (oder mehreren) der DSI-Teilnehmer
SB.5 bis SB.3 - reserviert
SB.2 BC Collision (nur im DALI-
Betrieb) 		0bin keine Kollision
1bin | DALI-Kollision auf dem Rückkanal (Backward Channel) erkannt: während der Übertragung eines DALI-Telegramms wurde eine Kollision mit den Sendedaten eines anderen DALI-Slaves erkannt. Mit der nächsten Flanke des Bits SB.0 wird das Bit SB.2 zurückgesetzt, wenn nicht erneut eine DALI-Kollision aufgetreten ist.
SB.1 FC Collision (nur im DALI-
Betrieb) 		0bin keine Kollision
1bin | DALI-Kollision auf dem Hinkanal (Foreward Channel) erkannt: während der Übertragung eines DALI-Telegramms wurde eine Kollision mit den Sendedaten eines anderen DALI-Masters erkannt. Mit der nächsten Flanke des Bits SB.0 wird das Bit SB.1 zurückgesetzt, wenn nicht erneut eine DALI-Kollision aufgetreten ist.
SB.0 | Toggle | Eine Flanke des SB.0 ist die Quittung für den Abschluss des mit dem Toggle-Bit des Control-Bytes (CB.0) ausgelösten Telegrammzyklusses. Das Telegramm wurden über den DALI/DSI-Bus versandt. Im DALI-Betrieb gibt das Collision-Bit (SB.1) Aufschluss über gegebenenfalls erfolgte Kollisionen.

Registerkommunikation

Control-Byte bei Registerkommunikation

Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur KL6811 übertragen.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB.5 bis CB.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort 0 lesen oder - mit dem Ausgangsdatenwort 0 beschreiben wollen.

VORSICHT 		Ungültige Prozessdaten während der Registerkommunikation!
Während der Registerkommunikation kann nicht auf Datenregister zugegriffen werden! Prozessdaten, die eventuell noch angezeigt werden, sind nicht gültig!

Status-Byte bei Registerkommunikation

Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der KL6811 zur Steuerung übertragen.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB.6 | R | 0bin | Lesezugriff
SB.5 bis SB.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht

Register | Kommentar | Defaultwert |  | R/W | Speicher
R0 | reserviert | - | - | - | -
R1 | DALI-Slave-Counter | - | - | R | RAM
R2 bis R5 | reserviert | - | - | - | -
R6 | Diagnose-Register | - | - | R | RAM
R7 | Kommando-Register | 0x0000 | 0dez | R/W | RAM
R8 | Klemmenbezeichnung | 0x1A9B | 6811dez | R | ROM
R9 | Firmware-Stand | z.B. 0x3143 | z.B. 12611dez | R | ROM
R10 | Multiplex-Schieberegister | 0x0118 | 280dez | R | ROM
R11 | Signalkanäle | 0x0118 | 280dez | R | ROM
R12 | minimale Datenlänge | 0x1818 | 6168dez | R | ROM
R13 | Datenstruktur | 0x0000 | 0dez | R | ROM
R14 | reserviert | - | - | - | -
R15 | Alignment-Register | - | - | R/W | RAM
R16 | Hardware Version | z.B. 0x0000 | z.B. 0dez | R/W | SEEROM/RAM
R17 bis R30 | reserviert | - | - | - | -
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register | 0x0000 | 0dez | R/W | SEEROM/RAM
R33 bis R63 | reserviert | - | - | - | -


KL6811 - Registerbeschreibung

BECKHOFF KL6811: Zugriff aus dem Anwenderprogramm

Registerbeschreibung

R1: DALI-Slave-Counter

Nach dem Hochlaufen der KL6811 wird hier die Anzahl der gefundenen DALI-Slaves hinterlegt. Diese Funktion kann mit Bit 4 des Feature-Registers (R32.4) abgeschaltet werden.

R6: Diagnoseregister

Im Diagnoseregister werden ab einer späteren Firmware-Version Diagnose-Informationen über den Zustand der DALI-Masterklemme zur Verfügung gestellt.

R7: Kommandoregister

Mit diesem Register können Sie Kommandos zur DALI-Masterklemme übertragen.

R8: Klemmenbezeichnung

Im Register R8 steht in hexadezimaler Codierung die Bezeichnung der Klemme: 0x1A9B (6811dez)

R9: Firmware-Stand

Im Register R9 steht in hexadezimaler Codierung der Firmware-Stand der Klemme, z.B. 0x3144 (12612dez).

R10: Schieberegisterlänge

0x0118

R11: Anzahl der Signalkanäle

0x0118

R12: Minimale Datenlänge

0x1818

R13: Datentyp

Im Register R13 steht der Datentyp der Busklemme. 0x0004 steht für Sonderfunktion.

R15: Alignment-Register

R16: Hardware Versionsnummer

Im Register R16 steht in hexadezimaler Codierung der Hardware-Stand der Klemme, z.B. 0x0000 (0dez).

Anwender-Register

Die Anwender-Register der Klemme können vom Anwenderprogramm beschrieben werden um die Eigenschaften der Klemme zur Laufzeit zu verändern.

R31: Kodewort-Register

  • Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte nur in die RAM-Register, nicht aber in die EPROM-Register gespeichert und gehen somit bei einem Neustart der Klemme verloren.
  • Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die EPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.

Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.

R32: Feature-Register

Das Feature-Register legt die Betriebsart der Klemme fest.

Bit | Feature | Wert | Erläuterung | Default
R32.15 R32.14 R32.13 R32.12 | Betriebsart | 0000bin | DALI | 0000bin
 |  | 0001bin | DSI
 |  | weitere | reserviert
R32.11 | - | - | reserviert | 0bin
... | ... | ... | ... | ...
R32.5 | - | - | reserviert | 0bin
R32.4 | Abschalten des Zählens der DALI-Geräte | 0bin | Die DALI-Geräte werden nach dem Hochlaufen der KL6811 nicht gezählt. | 0bin
 |  | 1bin | Nach dem Hochlaufen der KL6811 werden die DALI-Geräte gezählt und das Ergebnis in Register 1 (R1) abgelegt.
R32.3 | Deaktivierung des internen DALI-Netzteils | 0bin | Versorgung des DALI-Busses erfolgt aus dem internen Netzteil der KL6811. | 0bin
 |  | 1bin | Internes DALI-Netzteil deaktiviert: Es ist ein externes DALI-Netzteil erforderlich.
R32.2 | - | - | reserviert | 0bin
R32.1 | - | - | reserviert | 0bin
R32.0 | - | - | reserviert | 0bin


Beispiele für die Register-Kommunikation

Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.

Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
    - ASCII-Code 0x33 steht für die Ziffer 3
    - ASCII-Code 0x41 steht für den Buchstaben A
    Die Firmwareversion lautet also 3A.

Beispiel 2: Beschreiben eines Anwender-Registers

Hinweis 		Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt.
Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder.
Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.

I. Schreiben des Code-Worts (0x1235) in Register 31

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!

II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.

III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.

    VORSICHT     		Beachten Sie die Registerbeschreibung!
    Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
    Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!

IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.

V. Schreiben des Register 31 (Code-Wort zurücksetzen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


KL6811 - Programmierung

BECKHOFF KL6811: Programmierung

TwinCAT-Bibliotheken

Siehe Software-Dokumentation im Beckhoff-Information-System.

TwinCAT 2: TwinCAT 2 PLC Lib: DALI

TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_DALI


DALI-Befehle

Nach der Norm DIN EN 60929 werden Adressen und Befehle als Zahl von 2 Byte Länge übertragen.

Diese Befehle sind von der form Form YAAA AAAS xxxx xxxx. Dabei steht jeder Buchstabe für ein Bit.

Y: Art der Adresse
0bin: Kurzadresse
1bin: Gruppenadresse oder Sammelruf

A: signifikantes Adressbit

S: Auswahlbit (legt die Bedeutung der folgenden 8 Bit fest):
0bin: Die 8 Bit xxxx xxxx enthalten einen Wert zur direkten Steuerung der Lampenleistung
1bin: Die 8 Bit xxxx xxxx enthalten eine Befehls-Nr.

x: Bit der Lampenleistung oder der Befehls-Nr.

Direkte DALI-Befehle für die Lampenleistung

Diese Befehle sind von der Form YAAA AAA0 xxxx xxxx.

xxxx xxxx: Mit diesen 8 Bits wird der Wert für die Lampenleistung übertragen. Sie Berechnet sich nach der Formel:

Für die Übertragung nach dieser Formel stehen 253 Werte von 1dez bis 254dez zur Verfügung.

Außerdem gibt es zwei 2 direkte DALI-Befehle mit besonderer Bedeutung:

Befehl | Befehls-Nr. | Beschreibung | Antwort
00hex | 0dez | Das DALI-Gerät dimmt mit der aktuellen Stufenzeit bis zum parametrierten MIN-Wert und schaltet dann aus. | -
FFhex | 254dez | Maske (keine Veränderung): dieser Wert wird im weiteren ignoriert und deshalb nicht in den Speicher geladen. | -

Indirekte DALI-Befehle für die Lampenleistung

Diese Befehle sind von der Form YAAA AAA1 xxxx xxxx.

xxxx xxxx: Mit diesen 8 Bits wird die Befehlsnummer übertragen. Die möglichen Befehlsnummern sind in den folgenden Tabellen in hexadezimaler und dezimaler Schreibweise aufgelistet und erläutert.

Befehl | Befehls-Nr. | Beschreibung | Antwort
00hex | 0dez | Lampe sofort ausschalten (ohne Fading). | -
01hex | 1dez | 200 ms lang mit mit ausgewählter Stufengeschwindigkeit heller stellen. | -
02hex | 2dez | 200 ms lang mit mit ausgewählter Stufengeschwindigkeit dunkler stellen. | -
03hex | 3dez | Setze den aktuellen Lampenleistungswert eine Stufe höher (ohne Fading). Falls die Lampe ausgeschaltet ist, wird sie nicht eingeschaltet. | -
04hex | 4dez | Setze den aktuellen Lampenleistungswert eine Stufe niedriger (ohne Fading) falls die Lampe nicht bereits bereits ihrem parametrierten Minimalwert hat. Falls die Lampe bereits ihrem Minimalwert hat, wird sie nicht verändert und bleibt eingeschaltet. | -
05hex | 5dez | Setze den aktuellen Lampenleistungswert auf den parametrierten Maximalwert. Falls die Lampe ausgeschaltet ist, wird sie eingeschaltet. | -
06hex | 6dez | Setze den aktuellen Lampenleistungswert auf den parametrierten Minimalwert. Falls die Lampe ausgeschaltet war, wird sie eingeschaltet. | -
07hex | 7dez | Setze den aktuellen Lampenleistungswert eine Stufe niedriger (ohne Fading). Falls die Lampe bereits bereits ihrem Minimalwert hat, wird sie ausgeschaltet. | -
08hex | 8dez | Setze den aktuellen Lampenleistungswert eine Stufe höher (ohne Fading). Falls die Lampe ausgeschaltet war, wird sie eingeschaltet und auf ihren parametrierten Minimalwert. gestellt. | -
09hex ... 0Fhex | 9dez ... 15dez | reserviert | -
1nhex (n: 0hex ... Fhex) | 16dez ... 31dez | Setze den Lampenleistungswert auf den für die angegebene Szene (n) gespeicherten Wert. | -

Konfigurationsbefehle

Befehl | Befehls-Nr. | Beschreibung | Antwort
20hex | 32dez | Setze alle Parameter in den Auslieferungszustand zurück. | -
21hex | 33dez | Speichere den aktuellen Helligkeitswert im DTR (Data-Transfer- Register). | -
22hex ... 29hex | 34dez ... 41dez | reserviert | -
2Ahex | 42dez | Speichere den aktuell im DTR befindlichen Wert als Maximal-Lampenleistungswert. | -
2Bhex | 43dez | Speichere den aktuell im DTR befindlichen Wert als Minimal-Lampenleistungswert. | -
2Chex | 44dez | Speichere den aktuell im DTR befindlichen Wert als Fehlerfall-Lampenleistungswert. | -
2Dhex | 45dez | Speichere den aktuell im DTR befindlichen Wert als Einschalt-Lampenleistungswert. | -
2Ehex | 46dez | Speichere den aktuell im DTR befindlichen Wert als Stufenzeit. | -
2Fhex | 47dez | Speichere den aktuell im DTR befindlichen Wert als Stufengeschwindigkeit. | -
30hex ... 3Fhex | 48dez ... 63dez | reserviert | -
4nhex (n: 0hex ... Fhex) | 64dez ... 79dez | Speichere den aktuell im DTR befindlichen Wert als ausgewählte Szene (n). | -
5nhex (n: 0hex ... Fhex) | 80dez ... 95dez | Lösche die ausgewählte Szene (n) vom DALI-Slave. | -
6nhex (n: 0hex ... Fhex) | 96dez ... 111dez | Füge den DALI-Slave zur ausgewählten Gruppe (n) hinzu. | -
7nhex (n: 0hex ... Fhex) | 112dez ... 127dez | Lösche den DALI-Slave aus der ausgewählten Gruppe (n). | -
80hex | 128dez | Speichere den aktuell im DTR befindlichen Wert als Kurzadresse. | -
81hex ... 8Fhex | 129dez ... 143dez | reserviert | -
90hex | 144dez | Gib den Zustand (XX) des DALI-Slaves zurück. | XX
91hex | 145dez | Überprüfe ob der DALI-Slave arbeitet. | ja/nein
92hex | 146dez | Überprüfe ob ein Lampenausfall vorliegt. | ja/nein
93hex | 147dez | Überprüfe ob die Stromversorgung der Lampe eingeschaltet ist. | ja/nein
94hex | 148dez | Überprüfe ob der Slave einen Wert unzulässigen Wert empfangen hat. | ja/nein
95hex | 149dez | Überprüfe ob der DALI-Slave im Reset-Zustand ist. | ja/nein
96hex | 150dez | Überprüfe ob dem DALI-Slave eine Kurzadresse fehlt. | ja/nein
97hex | 151dez | Gib die Versionsnummer (XX) zurück. | XX
98hex | 152dez | Gib den Inhalt (XX) des DTR zurück. | XX
99hex | 153dez | Gib den Geräte-Typ (XX) zurück. | XX
9Ahex | 154dez | Gib das physikalische Minimum (XX) zurück. | XX
9Bhex | 155dez | Überprüfe ob am DALI-Slave ein Versorgungsfehler vorliegt. | ja/nein
9Chex ... 9Fhex | 156dez ... 159dez | reserviert | -
A0hex | 160dez | Gib den aktuellen Lampenleistungswert (XX) zurück. | XX
A1hex | 161dez | Gibt den maximal zulässigen Lampenleistungswert (XX) zurück. | XX
A2hex | 162dez | Gibt den minimal zulässigen Lampenleistungswert (XX) zurück. | XX
A3hex | 163dez | Gibt Einschalt-Lampenleistungswert (XX) zurück. | XX
A4hex | 164dez | Gibt Fehlerfall-Lampenleistungswert (XX) zurück. | XX
A5hex | 165dez | Gibt die Stufengeschwindigkeit (X) und die Stufengeschwindigkeit (Y) zurück. | XY
A6hex ... AFhex | 166dez ... 175dez | reserviert | -
Bnhex (n: 0hex ... Fhex) | 176dez ... 191dez | Gibt den Lampenleistungswert (XX) der angegebenen Szene (n) zurück. | XX
C0hex | 192dez | Gibt ein Bit-Muster zurück, das anzeigt zu welcher Gruppe (0-7) der DALI-Slave gehört. | XX
C1hex | 193dez | Gibt ein Bit-Muster zurück, das anzeigt zu welcher Gruppe (8-15) der DALI-Slave gehört. | XX
C2hex | 194dez | Gibt die oberen Bits der wahlfreien Adresse (HH) zurück. | HH
C3hex | 195dez | Gibt die mittleren Bits der wahlfreien Adresse (MM) zurück. | MM
C4hex | 196dez | Gibt die niedrigen Bits der wahlfreien Adresse (LL) zurück. | LL
C5hex ... DFhex | 197dez ... 223dez | reserviert | -
E0hex ... FFhex | 224dez ... 255dez | Abfrage der anwendungsbezogenen Erweiterungsbefehle. |

Hinweis 		Wiederholung von DALI-Befehlen
Entsprechend der IEC 60929 muss ein DALI-Master einige Befehle innerhalb von 100 ms wiederholen, damit sie von den DALI-Slaves ausgeführt werden.
  • Die DALI-Masterklemme KL6811 wiederholt die Befehle 32dez bis 128dez, 258dez und 259dez (fett markiert) automatisch um Ihnen den doppelten Aufruf im Anwenderprogramm zu ersparen.
  • Die DALI-Masterklemme KL6811 wiederholt auch die Befehle 224dez bis 255dez, wenn Sie dies zuvor mit Bit 1 des Control-Bytes (CB.1) freigeschaltet haben.

Sonderbefehle

Die Sonderbefehle und weitere Informationen entnehmen Sie bitte der Norm DIN EN 60929.


Literaturverzeichnis

Bücher

  • DALI-Handbuch der DALI AG (DALI Activity Group, siehe http://www.dali-ag.org).

Normen

  • DIN EN 60929: Norm für Wechselstromversorgte elektronische Vorschaltgeräte für röhrenförmige Leuchtstofflampen (IEC 60929), Anhang E.


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.