KL6781 - M-Bus-Masterklemme
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0.0
▪
Migration
1.4.0
▪
Beschreibung der Programmierung ausgegliedert in das TwinCAT-Information-System.
▪
Library auf Version Version 2.0.1 aktualisiert
▪
Technische Daten aktualisiert
1.3.0
▪
Funktionsbaustein FB_MBUS_SBC_ALD1 hinzugefügt
▪
Library auf Version Version 1.2.0 aktualisiert
1.2.0
▪
Kapitel Programmierung aktualisiert
1.1.0
▪
Vorwort aktualisiert
▪
Montagehinweise erweitert
▪
Beschreibung von Control- und Status-Wort erweitert
▪
Registerbeschreibung erweitert
▪
Kapitel M-Bus hinzugefügt
▪
Kapitel Programmierung erweitert
1.0.0
▪
erste Veröffentlichung
Firm- und Hardware-Stände
Dokumentation Version | KL6781
 | Firmware | Hardware
2.0.0 | 1C | 03
1.4.0 | 1B | 01
1.3.0 | 1B | 01
1.2.0 | 1B | 01
1.1.0 | 1B | 01
1.0.0 | 1A | 00
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 50 11 1A 00:
50 - Produktionswoche 50
11- Produktionsjahr 2011
1A - Firmware-Stand 1A
00 - Hardware-Stand 00


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten der KL6781
•
LED-Anzeigen


Einführung

Produktübersicht [image] Einführung
Einführung
KL6781
Die M-Bus-Masterklemme KL6781 ermöglicht den direkten Anschluss von M-Bus-Geräten. Der M-Bus (Meter-Bus) ist ein Feldbus zur Verbrauchsdatenerfassung von Strom-, Wasser-, Gas- oder Energiezählern.
Die KL6781 enthält nicht das M-Bus-Protokoll, sondern setzt die Daten des K-Bus auf M-Bus-konforme Physik um. Hierfür stehen pro M-Bus-Masterklemme 24 Byte auf dem K-Bus zur Verfügung.
Die TwinCAT-M-Bus-Bibliothek ermöglicht das Arbeiten ohne externen M-Bus-Gateway, d. h. die M-Bus-Geräte können direkt an die KL6781 angeschlossen werden.
Bei einer Gesamtleitungslänge von 300 m können an einer KL6781 bis zu 40 M-Bus-Geräte betrieben werden.


Technische Daten der KL6781

Produktübersicht [image] Technische Daten der KL6781
Technische Daten der KL6781
Technische Daten | KL6781
Übertragungskanäle | 1
M-Bus-Teilnehmer | max. 40
Übertragungsstandard | M-Bus-Physik
Übertragungsrate | 300...9600 Baud (Default 2.400 Baud)
Buszugriff | Master-Slave-Verfahren (Polling)
Leitungslänge | max. 300 m
Stromaufnahme aus dem K-Bus | typisch 65 mA
Stromaufnahme aus den Powerkontakten | max. 250 mA
Kurzschlussfestigkeit | ja
Potenzialtrennung | 500 V (K-Bus / M-Bus)
Breite im Prozessabbild | Input/Output: 24 Byte
Konfiguration | TwinCAT PLC (Funktionsbausteine M-Bus)
Nennspannung | 24 VDC (-15% / +20%)
Eingangsspannung | 24 VDC (-15% / +20%)
Gewicht | ca. 60 g
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0 °C ... +55 °C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25 °C ... +85 °C
zulässige relative Feuchte | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27 siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, UL


LED-Anzeigen

Produktübersicht [image] LED-Anzeigen
LED-Anzeigen
LEDs
LED | Farbe | Bedeutung
Run | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | an | normaler Betrieb
 |  | aus | Werden vom Buskoppler 100 ms keine Prozessdaten zur Klemme übertragen, so erlischt die LED RUN.
Error | rot | Allgemeiner Fehler wird signalisiert
Send | grün | Datenübertragung auf dem M-Bus
Receive | grün | Datenübertragung auf dem M-Bus


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Tragschienenverriegelungen ober- und unterhalb des Klemmenmoduls bis zu deren Einrastpunkt heraus. Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Anschlussbelegung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Hinweis
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Hinweis
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Anschlussbelegung

Montage und Verdrahtung [image] Anschluss [image] Anschlussbelegung
Anschlussbelegung
Anschlussbelegung
Klemmstelle | Name | Signal
1 | reserviert | -
2 | M-Bus+ | M-Bus plus, intern verbunden mit Klemmstelle 6
3 | M-Bus- | M-Bus minus, intern verbunden mit Klemmstelle 7
4 | Schirm | Schirmanschluss, intern verbunden mit Klemmstelle 8
5 | reserviert | -
6 | M-Bus+ | M-Bus plus, intern verbunden mit Klemmstelle 2
7 | M-Bus- | M-Bus minus, intern verbunden mit Klemmstelle 3
8 | Schirm | Schirmanschluss, intern verbunden mit Klemmstelle 4


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Registerübersicht
•
Control- und Status-Wort
•
Prozessabbild
•
Mapping
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der M-Bus-Masterklemme. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | Anzahl Datenbytes im Sende-Buffer | variabel | variabel | R | RAM
R1 | Anzahl Datenbytes im Empfangs-Buffer | variabel | variabel | R | RAM
R2 | Anzahl der Parityfehler | 0x0000 | 0dez | R | -
R3 | Anzahl der Framing Errors | 0x0000 | 0dez | R | -
R4 | reserviert | 0x0000 | 0dez | R | -
R5 | reserviert | 0x0000 | 0dez | R | -
R6 | Diagnose-Register | variabel | variabel | R | RAM
R7 | Komando-Register | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | 0x1A7D | 6781dez | R | ROM
R9 | Firmware-Stand | variabel | variabel | R | ROM
R10 | reserviert | 0x0000 | 0dez | - | -
... | ... | ... | ... | ... | ...
R15 | reserviert | 0x0000 | 0dez | - | -
R16 | Hardware-Version | z. B. 0x0000 | z. B.: 0dez | ... | EEPROM
R17 | reserviert | 0x0000 | 0dez | - | -
... | ... | ... | ... | ... | ...
R18 | reserviert | 0x0000 | 0dez | - | -
R29 | Klemmentyp - Sonderkennung | 0x0000 | 0dez | R | EEPROM
R30 | reserviert | 0x0000 | 0dez | R/W | RAM
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | Baudrate-Register | 0x0004 | 4dez | R/W | EEPROM
R33 | reserviert | 0x0000 | 0dez | R/W | -
... | ... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | 0dez | R/W | -


Control- und Status-Wort

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Wort
Control- und Status-Wort
Prozessdatenbetrieb
Control-Wort (bei Prozessdatenbetrieb)
Das Control-Wort (CW) befindet sich im Ausgangsprozessabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CW.15 | CW.14 | CW.13 | CW.12 | CW.11 | CW.10 | CW.9 | CW.8 | CW.7 | CW.6 | CW.5 | CW.4 | CW.3 | CW.2 | CW.1 | CW.0
Name | OL7 | OL6 | OL5 | OL4 | OL3 | OL2 | OL1 | OL0 | Reg | - | - | - | - | IR | RA | TR
Legende
Bit | Name | Beschreibung
CW.15 ... CW.8 | OL7 ... OL0 (OutLenght) | 1dez... 22dez | Anzahl der Ausgangs-Bytes (), die für die Übertragung von der Steuerung zur Klemme bereit stehen.
CW.7 | Reg (RegAccess) | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CW.6 ... CW.3 | - | 0bin | reserviert
CW.2 | IR (InitRequest) | 0bin | Die Steuerung fordert von der Klemme wieder die Bereitschaft für den seriellen Datenaustausch.
 |  | 1bin | Die Steuerung fordert die Klemme zur Initialisierung auf. Die Sende- und Empfangsfunktionen werden gesperrt, die FIFO-Zeiger werden zurückgesetzt und die Schnittstelle wird mit den Werten der zuständigen Register initialisiert. Die Ausführung der Initialisierung wird von der Klemme mit dem Bit SW.2 (IA) quittiert.
CW.1 | RA (ReceiveAccepted) | toggle | Die Steuerung quittiert die Entgegennahme von Daten mit Zustandsänderung dieses Bits. Erst daraufhin werden neue Daten von der Klemme zur Steuerung übertragen.
CW.0 | TR (TransmitRequest) | toggle | Über eine Zustandsänderung dieses Bits teilt die Steuerung der Klemme mit, dass sich die in mit den OL-Bits angezeigte Anzahl von Bytes in den DataOut-Bytes befinden. Die Klemme quittiert die Entgegennahme der Daten im Status-Byte mit Zustandsänderung des Bits SW.0 (TA). Erst daraufhin werden neue Daten von der Steuerung zur Klemme übertragen.
Status-Wort (bei Prozessdatenbetrieb)
Das Status-Wort (SW) befindet sich im Eingangsprozessabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8 | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | IL7 | IL6 | IL5 | IL4 | IL3 | IL2 | IL1 | IL0 | Reg | - | - | - | BUF_F | IA | RR | TA
Legende
Bit | Name | Beschreibung
SW.15 ... SW8 | IL7 ... IL0 (InLenght) | 1dez ... 22dez | Anzahl der Eingangs-Bytes, die für die Übertragung von der Klemme zur Steuerung bereit stehen.
SW.7 | Reg (RegAccess) | 0bin | Quittung für Prozessdatenbetrieb
SW.6 ... SW.4 | - | 0 | reserviert
SW.3 | BUF_F | 1bin | Das Empfangs-FIFO ist voll. Alle ab jetzt eingehenden Daten gehen verloren!
SW.2 | IA (InitAccepted-Bit) | 1bin | Die Initialisierung wurde von der Klemme ausgeführt.
 |  | 0bin | Die Klemme ist wieder für den seriellen Datenaustausch bereit.
SW.1 | RR (ReceiveRequest) | toggle | Über eine Zustandsänderung dieses Bits teilt die Klemme der Steuerung mit, dass sich die in IL-Bits angezeigte Anzahl von Bytes in den DataIn-Bytes befinden. Die Steuerung muss die Entgegennahme der Daten im Control-Byte mit Zustandsänderung des Bits CW.1 (RA) quittieren. Erst daraufhin werden neue Daten von der Klemme zur Steuerung übertragen.
SW.0 | TA (TransmitAccepted) | toggle | Die Klemme quittiert die Entgegennahme von Daten mit Zustandsänderung dieses Bits. Erst daraufhin werden neue Daten von der Steuerung zur Klemme übertragen
Registerkommunikation
Control-Wort (bei Registerkommunikation)
Das Control-Wort (CW) befindet sich im Ausgangprozesssabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CW.15 | CW.14 | CW.13 | CW.12 | CW.11 | CW.10 | CW.9 | CW.8 | CW.7 | CW.6 | CW.5 | CW.4 | CW.3 | CW.2 | CW.1 | CW.0
Name | RegData |  |  |  |  |  |  |  | Reg | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CW.15 ... CW.8 | RegData | Ein Byte der in das Register zu schreibenden Daten. Das andere Byte wird im benachbarten Prozessdatenbyte übertragen.
CW.7 | Reg | 1bin | Registerkommunikation eingeschaltet
CW.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CW.5 bis CW.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, dass Sie - mit dem Eingangsdatenwort DataIN und dem HighByte des Status-Bytes (RegData) lesen oder - mit dem Ausgangsdatenwort DataOUT und dem HighByte des Control-Worts (RegData) beschreiben wollen.
Status-Byte (bei Registerkommunikation)
Das Status-Wort (SW) befindet sich im Eingangsprozessabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8 | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | RegData |  |  |  |  |  |  |  | Reg | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SW.15 ... SW.8 | RegData | Ein Byte der aus dem Register gelesenen Daten. Das andere Byte wird im benachbarten Prozessdatenbyte übertragen.
SW.7 | RegAccess | 1bin | Quittung für Registerzugriff
SW.6 | R | 0bin | Lesezugriff
SW.5 bis SW.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Hinweis
Kein kompaktes Prozessabbild
Ein Betrieb der KL6781 mit kompaktem Prozessabbild (ohne Control- und Status-Wort) ist nicht möglich, da Control- und Status-Wort für einen sinnvollen Prozessdatenbetrieb der Klemme erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen, wird die KL6781 mit ihrem komplexen Prozessabbild dargestellt!
Die KL6781 stellt sich im Prozessabbild mit bis zu 24 Byte Ein- und 24 Byte Ausgangsdaten dar.
Format | Eingangsdaten | Ausgangsdaten
Wort | SW | CW
Byte | DataIn0 | DataOut0
Byte | DataIn1 | DataOut1
... | ... | ...
Byte | DataIn21 | DataOut21
Legende
SW: Status-Byte
CW: Control-Byte
DataIN 0 bis DataIN 21: 22 Bytes für die Eingangsdaten des M-Bus
DataOUT 0 bis DataOUT 21: 22 Bytes für die Ausgangsdaten des M-Bus
▪
Die Bedeutung des Control- und Status-Worts entnehmen Sie bitte der Seite Control- und Status-Wort.
▪
Die Zuordnung der Bytes und Worte zu den Adressen der Steuerung entnehmen Sie bitte der Seite Mapping.


Mapping

Zugriff aus dem Anwenderprogramm [image] Mapping
Mapping
Die Busklemmen belegen Adressen im Prozessabbild der Steuerung. Die Zuordnung der Prozessdaten (Ein- und Ausgangsdaten) und Parametrierungsdaten (Control- und Status-Wort) zu den Steuerungsadressen wird als Mapping bezeichnet. Die Art des Mappings ist abhängig von:
▪
dem verwendeten Feldbus-System
▪
dem Klemmentyp
▪
der Parametrierung des Buskopplers (Bedingungen) wie
–
kompakte oder komplexe Auswertung
–
Intel- oder Motorola-Format
–
Word-Alignment ein- oder ausgeschaltet
Die folgenden Tabellen zeigen das Mapping in Abhängigkeit der verschiedenen Bedingungen. Die Inhalte der einzelnen Bytes entnehmen Sie bitte den Seiten Prozessabbild sowie Control- und Status-Wort.
Kompakte Auswertung
Hinweis
Kein kompaktes Prozessabbild
Ein Betrieb der KL6781 mit kompaktem Prozessabbild (ohne Control- und Status-Wort) ist nicht möglich, da Control- und Status-Wort für einen sinnvollen Prozessdatenbetrieb der Klemme erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen, wird die KL6781 mit ihrem kompletten Prozessabbild dargestellt!
Komplette Auswertung
Komplette Auswertung im Intel-Format
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: egal | 0 | SW |  | CW
 | 1 | DataIN 1 | DataIN 0 | DataOUT 1 | DataOUT 0
 | 2 | DataIN 3 | DataIN 2 | DataOUT 3 | DataOUT 2
 | 3 | DataIN 5 | DataIN 4 | DataOUT 5 | DataOUT 4
 | 4 | DataIN 7 | DataIN 6 | DataOUT 7 | DataOUT 6
 | 5 | DataIN 9 | DataIN 8 | DataOUT 9 | DataOUT 8
 | 6 | DataIN 11 | DataIN 10 | DataOUT 11 | DataOUT 10
 | 7 | DataIN 13 | DataIN 12 | DataOUT 13 | DataOUT 12
 | 8 | DataIN 15 | DataIN 14 | DataOUT 15 | DataOUT 14
 | 9 | DataIN 17 | DataIN 16 | DataOUT 17 | DataOUT 16
 | 10 | DataIN 19 | DataIN 18 | DataOUT 19 | DataOUT 18
 | 11 | DataIN 21 | DataIN 20 | DataOUT 21 | DataOUT 20
Komplexe Auswertung im Motorola-Format
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: egal | 0 | SW |  | CW
 | 1 | DataIN 0 | DataIN 1 | DataOUT 0 | DataOUT 1
 | 2 | DataIN 2 | DataIN 3 | DataOUT 2 | DataOUT 3
 | 3 | DataIN 4 | DataIN 5 | DataOUT 4 | DataOUT 5
 | 4 | DataIN 6 | DataIN 7 | DataOUT 6 | DataOUT 7
 | 5 | DataIN 8 | DataIN 9 | DataOUT 8 | DataOUT 9
 | 6 | DataIN 10 | DataIN 11 | DataOUT 10 | DataOUT 11
 | 7 | DataIN 12 | DataIN 13 | DataOUT 12 | DataOUT 13
 | 8 | DataIN 14 | DataIN 15 | DataOUT 14 | DataOUT 15
 | 9 | DataIN 16 | DataIN 17 | DataOUT 16 | DataOUT 17
 | 10 | DataIN 18 | DataIN 19 | DataOUT 18 | DataOUT 19
 | 11 | DataIN 20 | DataIN 21 | DataOUT 20 | DataOUT 21


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die Register dienen zur Parametrierung der M-Bus-Masterklemme. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
R0: Anzahl Datenbytes im Sende-Buffer
Im Register R0 steht die Anzahl der Daten im Sende-FIFO.
R1: Anzahl Datenbytes im Empfangs-Buffer
Im Register R1 steht die Anzahl der Daten im Empfangs-FIFO.
R6: Diagnose-Register
Bit | R6.15 | R6.14 | R6.13 | R6.12 | R6.11 | R6.10 | R6.9 | R6.8
Name | - | - | - | - | - | - | - | -
Bit | R6.7 | R6.6 | R65 | R6.4 | R6.3 | R6.2 | R6.1 | R6.0
Name | - | - | - | BufferOverflow | Overrun | Framing Error | Parity Error | RxBufferOverflow
Legende
Bit | Name | Beschreibung |  | default
R6.15…5 | - | - | reserviert | -
R6.4 | BufferOverflow | 1bin | Buffer ist voll | 0bin
R6.3 | Overrun | 1bin | Overrun Error ist aufgetreten | 0bin
R6.2 | Framing Error | 1bin | Framing Error ist aufgetreten | 0bin
R6.1 | Parity Error | 1bin | Parity Error ist aufgetreten | 0bin
R6.0 | RxBufferOverflow | 1bin | Der Empfangsbuffer ist übergelaufen, ankommende Daten gehen verloren. | 0bin
R7: Kommando-Register
Das Kommandoregister der KL6781 wird nicht benutzt.
R8: Klemmentyp
Im Register R8 steht die Bezeichnung der Klemme:
KL6781: 0x1A7D (6781dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R16: Hardware-Stand
Im Register R16 steht der Hardware-Stand der Klemme.
R29: Klemmentyp - Sonderkennung
Im Register R29 steht die Bezeichnung des Sondertyps der Klemme. KL6781-0000: 0x0000 (0000dez)
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Baudrate-Register
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | - | - | - | -
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | - | - | BaudRate
Legende
Bit | Name | Beschreibung |  | default
R32.15 - R32.3 | - | reserviert |  | 0bin
R32.2 - R32.0 | BaudRate | 110bin | 9600 Baud | 100bin
 |  | 101bin | 4800 Baud
 |  | 100bin | 2400 Baud (default)
 |  | 011bin | 1200 Baud
 |  | 010bin | 600 Baud
 |  | 001bin | 300 Baud


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Hinweis
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


M-Bus

M-Bus
M-Bus
Weiterführende Informationen
•
Einführung
•
Übersicht
•
Topologie


Einführung

M-Bus [image] Einführung
Einführung
M-Bus = Metering Bus
Der M-Bus ist ein Feldbus für die Erfassung von Verbrauchsdaten (z. B. Energiezählern). Nähere Details zum M-Bus findet man unter www.m-bus.com. Der M-Bus ist europäischer Standard und wird beschrieben in der Norm EN1434. Die Daten werden seriell von einem Slave (Messgerät) an einen Master (Pegelwandler mit PC) gesendet. Master und Slave werden verpolungssicher über eine Zweidrahtleitung verbunden. Bei Primäradressierung können bis zu 250 Slaves in den Topologien Stern, Strang oder Baum angeschlossen werden. Ringstruktur ist nicht erlaubt. Dabei ist es möglich, Geräte verschiedener Hersteller an einem Bus zu betreiben.
Der Master steuert die Kommunikation auf dem Bus, indem er Daten von den Slaves anfordert. Die Slaves können mit einer festen oder variablen Datenstruktur antworten. Die M-Bus Bibliothek wertet nur Daten mit variabler Datenstruktur, Lowbyte zuerst, aus. Die Slaves kommunizieren untereinander nicht. Die Daten können von den Slaves nur nacheinander angefordert werden.


Übersicht

M-Bus [image] Übersicht
Übersicht
KL6781 als M-Bus-Master


Topologie

M-Bus [image] Topologie
Topologie
Stern-, Linien- und Baumtopologie
Stern-, Linien- und Baumtopologie
Ringtopologie
Ringtopologie
Hinweis
Ringtopologie wird nicht unterstützt
Ringtopologie ist beim M-Bus zwar möglich, wird jedoch nicht empfohlen und daher von Beckhoff auch nicht unterstützt.


Programmierung

Programmierung
Programmierung
Weiterführende Informationen
•
TwinCAT-Bibliotheken


TwinCAT-Bibliotheken

Programmierung [image] TwinCAT-Bibliotheken
TwinCAT-Bibliotheken
Software Dokumentation im Beckhoff Information System:
TwinCAT 2: TwinCAT 2 PLC Lib: M-Bus
TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_MBus


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.