KL6581, KL6583 - EnOcean-Busklemme und -Tranceiver
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Übersetzung


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0.0
▪
Migration
▪
Technische Daten aktualisiert
▪
Verdrahtung aktualisiert
1.2.0
▪
Produktübersicht aktualisiert
▪
Technische Daten aktualisiert
▪
Beschreibung der LED-Anzeigen aktualisiert
▪
KL6583-0100 Transceiver für 315 MHz hinzugefügt
1.1.0
Hinweise zur Zulässigkeit von EnOcean-Funk-Technologie hinzugefügt
1.0.0
Erste Veröffentlichung
Firm- und Hardware-Stände
Dokumentation Version | KL6581-0000 |  | KL6583-0000 |  | KL6583-0100
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
2.0.0 | B3 | 01 | B2 | 02 | B2 | 02
1.2.0 | B3 | 00 | B2 | 02 | B2 | 02
1.1.0 | B2 | 00 | B1 | 01 | - | -
1.0.0 | B1 | 00 | B1 | 00 | - | -
Den Firm- und Hardware-Stand (Auslieferungszustand) der Klemme können Sie der auf der Seite aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Jahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 35 04 B1 00:
35 - Produktionswoche 35
04 - Produktionsjahr 2004
B1 - Firmware-Stand B1
00 - Hardware-Stand 00


Übersetzung

Vorwort [image] Übersetzung
Übersetzung
Übersetzung
Diese Dokumentation wurde in deutscher Sprache erstellt. Alle Dokumente in anderen Landessprachen werden daraus abgeleitet. Sollten Sie eine Übersetzung in eine bestimmte Landessprache benötigen, wenden Sie sich bitte an den Beckhoff Support.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KL6581-0000 - Einführung
•
KL6581-0000 - Technische Daten
•
KL6581-0000 - Diagnose-LEDs
•
KL6583 - Einführung
•
KL6583 - Technische Daten
•
KL6583 Diagnose-LEDs


KL6581-0000 - Einführung

Produktübersicht [image] KL6581-0000 - Einführung
KL6581-0000 - Einführung
KL6581-0000 - EnOcean-Masterklemme
Die bidirektionale EnOcean-Technologie empfängt Signale von batterielosen Sensoren oder sendet Daten an Aktoren. Mit einer Reichweite der Funksignale von minimal 30 Meter kann die Verdrahtung in einem Gebäude erheblich vereinfacht werden. Die EnOcean-Masterklemme KL6581-0000 ist das Bindeglied zwischen den EnOcean-Transceivern KL6583 und der Applikation. Es dürfen bis zu acht EnOcean-Transceiver KL6583 an eine EnOcean-Masterklemme KL6581-0000 angeschlossen werden. Die EnOcean-Daten werden an das entsprechende Feldbussystem oder die Steuerung übertragen. Der Anschluss der EnOcean-Tranceiver KL6583 an die KL6581-0000 erfolgt über zwei Drähte für die Spannungsversorgung und zwei Drähte für den Datenbus, der die EnOcean-Telegramme überträgt. Die Gesamtlänge des Datenbusses beträgt maximal 500 Meter.
EnOcean GmbH
Weitere Informationen zu EnOcean erhalten Sie unter .


KL6581-0000 - Technische Daten

Produktübersicht [image] KL6581-0000 - Technische Daten
KL6581-0000 - Technische Daten
Technische Daten | KL6581-0000
Anzahl der Ausgänge | 1
Anzahl der Anschließbaren KL6583 | 8
Übertragungsstandard | CAN
CAN-Verbindungskabel | Beckhoff ZB5100 (Meterware)
Zulässige Kabellänge von der KL6581 bis zur letzten KL6583 | maximal 500 Meter (nur Linientopologie)
Übertragungsrate | 125 kByte
Potenzialtrennung | 500 V (K-Bus/CAN)
Spannungsversorgung für Elektronik | über den K-Bus und über die Powerkontakte
Stromaufnahme aus dem K-Bus | typisch 60 mA
Bitbreite im Prozessabbild | Output: 12 Byte Daten, Input: 12 Byte Daten
Gewicht | ca. 85 g
Abmessungen (B x H x T) | ca. 15mm x 100mm x 70mm
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus


KL6581-0000 - Diagnose-LEDs

Produktübersicht [image] KL6581-0000 - Diagnose-LEDs
KL6581-0000 - Diagnose-LEDs
Die LEDs zeigen den Betriebszustand der KL6581-0000 an.
KL6581-0000 - Diagnose-LEDs
Bedeutung der LED-Anzeigen
LED | Farbe | Zustand und Bedeutung
 |  | Ein | aus | blinkt kurz auf | blink 1 s Takt
K-Bus Run | grün | Leuchtet schwach bis stark: K-Buskommunikation OK | keine K-Bus Kommunikation | K-Bus Kommunikation | -
Error | rot | Fehler aufgetreten: siehe Status-Byte SB.1 bis SB.6 für Fehlerbeschreibung | kein Fehler | - | -
Send | grün | Wenn die LEDs Send und Receive dauerhaft leuchten funktioniert die Kommunikation zu den KL6583 Ordnungsgemäß. | - | Es werden Daten zu einer KL6583 gesendet. | Wenn die LEDs Send und Receive im 1 s Takt blinken ist die Kommunikation zu den KL6583 gestört.
Receive | grün |  | - | Es werden Daten von einer KL6583 empfangen.
Verdrahtungskontrolle mittels LEDs
Die Verdrahtung zwischen der KL6581-0000 und den KL6583 ist korrekt, wenn
•
die LEDs Receive und Send der KL6581-0000 dauerhaft leuchten und
•
auf allen angeschlossenen KL6583 die LED 3 dauerhaft leuchtet.


KL6583 - Einführung

Produktübersicht [image] KL6583 - Einführung
KL6583 - Einführung
KL6583 - EnOcean-Transceiver
Die EnOcean-Transceiver ermöglicht das Senden und Empfangen von EnOcean-Daten. Die Antenne ist in den Transceivern integriert.
Zwei Versionen sind erhältlich:
▪
KL6583-0000 (868,35 MHz) mit Zulassung für die Europäische Union und die Schweiz
▪
KL6583-0100 (315 MHz) mit Zulassung für die USA und Kanada
Hinweis
Überprüfen Sie die Zulässigkeit des Betriebs in Ihrem Land
Die Erlaubnis für den Einsatz in anderen Ländern ist explizit zu klären!
Die EnOcean Transceiver KL6583 sind in folgenden Ländern anmelde- und gebührenfrei zu betreiben:
•
KL6583-0000: Europäische Union und Schweiz
•
KL6583-0100: USA und Kanada (siehe KL6583-0100 für USA und Kanada)
Die Transceiver werden über einen Busanschluss mit der EnOcean-Masterklemme KL6581-0000 verbunden und von ihr mit 24 V versorgt.
Betrieb von bis zu acht KL6583 an einer KL6581
Der Datenbus darf maximal 500 Meter lang sein. Die Adressierung der Transceiver wird über einen Adresswahlschalter vorgenommen.
Es können bis zu acht Transceiver an eine KL6581-0000 angeschlossen werden.
Die Daten werden von den Transceivern mittels CAN-Protokoll zur KL6581-0000 übertragen und stehen somit der übergeordneten Steuerung zur Verfügung.
EnOcean GmbH
Weitere Informationen zu EnOcean erhalten Sie unter .


KL6583 - Technische Daten

Produktübersicht [image] KL6583 - Technische Daten
KL6583 - Technische Daten
Technische Daten | KL6583-0000 | KL6583-0100
Anschluss | 2 x 2-Leiter direkt an Busklemme KL6581-0000
Übertragungsstandard | CAN
CAN-Verbindungskabel | Beckhoff ZB5100 (Meterware)
Zulässige Kabellänge von der KL6581 bis zur letzten KL6583 | maximal 500 Meter (nur Linientopologie)
Übertragungsrate | 125 kByte
Potenzialtrennung | keine
Spannungsversorgung für Elektronik | aus den Powerkotakten der KL6581 (24 VDC)
Stromaufnahme aus den Powerkotakten der KL6581-0000 | typisch 20 mA (24 VDC)
Mittenfrequenz | 868,3 MHz | 315 MHz
Belegtes Frequenzband | 868,0 … 868,6 MHz (600 kHz) | -
maximale Sendeleistung (zulässig) | 25 mW e.r.p. | -
Sendeleistung | 2 mW (3 dBm) | -
Empfänger-Kategorie | 2 | -
Übertragungsreichweite | 300 m im Freifeld, 30 m im Gebäude
Funktelegramm | abhängig vom Sensortyp (32 Bit Sensor-Identnummer, Anzahl der Nutzbytes unbegrenzt), senden und empfangen
Antenne | im Gehäuse integriert
Gewicht | ca. 90 g
Gehäuse | rundes Oberteil für Montage (Decke/Wand) mit Flanschanschluss für Hauptgehäuse, Oberteil mit Kabeldurchbruch; Farbe: grauweiß (RAL 9002)
Abmessungen (B x H x T) | Höhe: 57 mm, Durchmesser: 72 mm (rundes Oberteil für Montage); Durchmesser: 110 mm (Hauptgehäuse mit Flanschanschluss)
Montage | beliebig
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP40
Einbaulage | beliebig
Zulassung | CE | FCC
Erlaubnis für den Einsatz in | Europäischer Union und Schweiz | USA und Kanada


KL6583 Diagnose-LEDs

Produktübersicht [image] KL6583 Diagnose-LEDs
KL6583 Diagnose-LEDs
Die LEDs zeigen den Betriebszustand der KL6583 an.
KL6583 - Diagnose-LEDs
Bedeutung der LED-Anzeigen
LED
Farbe
Zustand und Bedeutung
Ein
aus
blinkt
LED 1
grün
24 V liegen an
Spannungsversorgung nicht angeschlossen
-
LED 2
grün
-
kein Fehler (es werden keine EnOcean Telegramme gesendet)
Geht bei jedem gesendeten EnOcean Frame kurz an
LED 3
grün
kein Fehler
-
▪
200 ms falsche Node-Adresse (gültige Adressen: 1 bis 8)
▪
1 sec keine Kommunikation zur KL6581
▪
geht kurz aus, EnOcean Daten werden empfangen oder gesendet
Verdrahtungskontrolle mittels LEDs
Die Verdrahtung zwischen der KL6581 und den KL6583 ist korrekt, wenn
•
die LEDs Receive und Send der KL6581 dauerhaft leuchten und
•
die LED 3 aller angeschlossenen KL6583 dauerhaft leuchten.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Anschluss


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Anschlussbelegung
•
Verkabelung zwischen KL6581-0000 und KL6583


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Anschlussbelegung

Montage und Verdrahtung [image] Anschluss [image] Anschlussbelegung
Anschlussbelegung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL6581-0000 - Anschlussbelegung
Klemmstelle | Nr. | Anschluss für
CAN + (A) | 1 | A (CAN +)
+ 24 VDC | 2 | 24 V Powerkontakte
GND | 3 | GND Powerkontakte
Shield | 4 | Schirm, intern verbunden mit Klemmstelle 6
CAN - (B) | 5 | B (CAN -)
+ 24 VDC | 6 | 24 V Powerkontakte
GND | 7 | GND Powerkontakte
Shield | 8 | Schirm, intern verbunden mit Klemmstelle 4


Verkabelung zwischen KL6581-0000 und KL6583

Montage und Verdrahtung [image] Anschluss [image] Verkabelung zwischen KL6581-0000 und KL6583
Verkabelung zwischen KL6581-0000 und KL6583
Hinweis
Verkabelungsanweisungen:
•
Die KL6583 müssen immer aus der KL6581-0000 versorgt werden. Der Betrieb mit anderer Spannungsversorgung ist nicht zulässig!
•
Beim letzten Teilnehmer muss der Abschlusswiderstand eingeschaltet werden, S1 und S2 auf ON stellen.
•
Verwenden ausschließlich das Beckhoff CAN-Kabel mit der Bestellbezeichnung ZB5100. Bestellmenge: Angaben in Meter.
•
Die gesamte Leitungslänge (von der KL6581-0000 bis zur letzten KL6583) darf 500 Meter nicht überschreiten.
•
Die Topologie ist Linie; es dürfen keine Stichleitungen verwendet werden!
•
Die Linie muss immer mit einer KL6581-0000 beginnen. Die KL6581-0000 darf nicht innerhalb der Linie installiert sein!
•
Maximal acht KL6583 dürfen an einer KL6581-0000 betrieben werden.
Klemmstellen der KL6583
Bedeutung | KL6581-0000 | KL6583 X1 oder X2
CAN + | 1 | CAN +
CAN - | 5 | CAN -
24 V DC | 2 oder 6 | 24 V
GND | 3 oder 7 | GND
Knoten Adresse KL6583
Einstellen der Knotenadresse mit Schalter S3
S3 ist zum Einstellen der Knotenadresse (Node Address). Es darf in der Linie immer nur eine Adresse verwendet werden (gültige Adressen: 1...8).
Abschlusswiderstand
Beim letzten Modul muss der Abschlusswiderstand aktiviert werden!
Dafür sind beide DIP-Schalter S1 und S2 auf ON zu setzen.
Abschlusswiderstand ON
Abschlusswiderstand OFF
Verwechselungsgefahr
Die Ziffer "1" auf dem DIP Schalter ist nur eine Nummerierung:
Die "1" bedeutet nicht ON.
Steht ein Schalter auf "1" so ist er OFF!
Verkabelungsbeispiel
KL6581-0000, KL6583 - Verkabelungsbeispiel


EnOcean

EnOcean
EnOcean
Weiterführende Informationen
•
EnOcean - Übersicht
•
Reichweitenplanung
•
Zulassung von EnOcean-Funk-Technologie


EnOcean - Übersicht

EnOcean [image] EnOcean - Übersicht
EnOcean - Übersicht
Technik
Die EnOcean-Funktechnik ermöglicht ein weit reichendes Signal mit geringen Mengen Umgebungsenergie. Mit 50 µWs kann ein serienmäßig EnOcean-Funkmodul ohne weiteres ein Signal über eine Distanz von 300 m (im Freifeld) übertragen. Die Signaldauer für ein EnOcean-Telegramm beträgt ca. 1 tausendstel Sekunde.
▪
Lizenzfreies 868 MHz Frequenzband mit 1% duty cycle
▪
Mehrfach-Telegrammaussendung mit Checksumme
▪
Kurze Telegramme (ca. 1 ms) führen zu geringer Kollisionswahrscheinlichkeit
▪
Hohe Reichweite: 30 m im Gebäude oder 300 m im Freifeld
▪
Repeater verfügbar für Erweiterungen
▪
Uni- und bidirektionale Kommunikation
▪
Hohe Datenübertragungsraten von 125 kbit/s
▪
Geringer "Daten-Overhead"
▪
ASK-Modulation
▪
Funkprotokoll ist definiert und in Modulen integriert
▪
Sensorprofile festgelegt und von Nutzern eingehalten
▪
Eindeutige Sende-ID (32 Bit)
▪
Keine Interferenz mit DECT-, WLAN-, PMR-Systemen etc.
▪
Systemdesign verifiziert in Industrieller Umgebung
Protokollaufbau
Protokoll | Beschreibung | Länge
ORG | Telegramm Typ | 1 Byte
DB_3 | Daten Byte 3 | 1 Byte
DB_2 | Daten Byte 2 | 1 Byte
DB_1 | Daten Byte 1 | 1 Byte
DB_0 | Daten Byte 0 | 1 Byte
ID_3 | Transmitter ID Byte 3 | 1 Byte
ID_2 | Transmitter ID Byte 2 | 1 Byte
ID_1 | Transmitter ID Byte 1 | 1 Byte
ID_0 | Transmitter ID Byte 0 | 1 Byte
STATUS | Informationsstatus | 1 Byte


Reichweitenplanung

EnOcean [image] Reichweitenplanung
Reichweitenplanung
Beachten Sie bei der Platzierung der EnOcean Geräte die Empfehlungen der EnOcean Allianz (siehe www.enocean.de). Das Einhalten der Empfehlungen unterstützt eine optimale Reichweite und Störunanfälligkeit.
Dämpfung von verschiedenen Materialien
Material | Dämpfung
Holz, Gips, Glas unbeschichtet (ohne Metall) | 0...10 %
Backstein, Pressspanplatten | 5...35 %
Beton mit Armierung aus Eisen | 10...90 %
Metall, Aluminiumkaschierung | 90..100 %
Reichweite
Material | Reichweite
Sichtverbindung | Typ 30 m in Gängen, bis zu 100 m in Hallen
Rigipswände/Holz | Typ 30 m, durch maximal 5 Wände
Ziegelwände/Gasbeton | Typ 20 m, durch maximal 3 Wände
Stahlbetonwände/-Decken | Typ 10 m, durch maximal 1 Wand/Decke
Platzierung des KL6583-Moduls
Das KL6583-Modul beinhaltet Sender, Empfänger sowie die Antenne.
Abstände
Der Abstand zu einer Stahlbetondecke sollte mindestens 50 cm betragen, der zu einer Wand 10 cm.
Das KL6583 Modul nicht auf einer Metall Platte verschrauben oder anbringen!
Umweltbedingungen
Des Weiteren sind die Umweltbedingungen einzuhalten:
▪
Luftfeuchtigkeit maximal 95% ohne Betauung
▪
Umgebungstemperatur 0...55°C


Zulassung von EnOcean-Funk-Technologie

EnOcean [image] Zulassung von EnOcean-Funk-Technologie
Zulassung von EnOcean-Funk-Technologie
Hinweis
Überprüfen Sie die Zulässigkeit des Betriebs in Ihrem Land
Die Erlaubnis für den Einsatz in anderen Ländern ist explizit zu klären!
Die EnOcean Transceiver KL6583 sind in folgenden Ländern anmelde- und gebührenfrei zu betreiben:
•
KL6583-0000: Europäische Union und Schweiz
•
KL6583-0100: USA und Kanada
KL6583-0100 for USA and Canada
Contains IC: 5731A-TCM320C
Contains FCC ID: SZV-TCM320C
The enclosed device complies with part15 of the FCC Rules.
Operation is subject to the following conditions:
▪
( i.) this device may not cause harmful interference and
▪
(ii.) this device must accept any interference received,
including interference that may cause undesired operation.


Programmierung

Programmierung
Programmierung
Weiterführende Informationen
•
TwinCAT-Bibliotheken
•
Betrieb an anderen Steuerungen


TwinCAT-Bibliotheken

Programmierung [image] TwinCAT-Bibliotheken
TwinCAT-Bibliotheken
Software Dokumentation im Beckhoff Information System:
TwinCAT 2: TwinCAT 2 PLC Lib: EIB
TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_EIB


Betrieb an anderen Steuerungen

Programmierung [image] Betrieb an anderen Steuerungen
Betrieb an anderen Steuerungen
Weiterführende Informationen
•
Prozessabbild
•
Mapping
•
KL6581-0000 - Control- und Status-Byte
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Programmierung [image] Betrieb an anderen Steuerungen [image] Prozessabbild
Prozessabbild
Die KL6581 stellt sich im Prozessabbild mit 12 Byte Ein- und 12 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Format | Eingangsdaten | Ausgangsdaten
0 | Byte | Status-Byte (SB1) | Control-Byte (CB1)
1 | Byte | CNODE | CNODE
2 | Byte | ORG | ORG
3 | Byte | DB0 | DB0
4 | Byte | DB1 | DB1
5 | Byte | DB2 | DB2
6 | Byte | DB3 | DB3
7 | Byte | ID0 | ID0
8 | Byte | ID1 | ID1
9 | Byte | ID2 | ID2
10 | Byte | ID3 | ID3
11 | Byte | STATUS | STATUS
CNODE
Bit | CNODE.7 | CNODE.6 | CNODE.5 | CNODE.4 | CNODE.3 | CNODE.2 | CNODE.1 | CNODE.0
Name | Message Type | Reserve | Reserve | Reserve | Modul Addr. 3 | Modul Addr. 2 | Modul Addr. 1 | Modul Addr. 0
Message Type:
▪
FALSE Radio Message
▪
TRUE Modul Massage
▪
Siehe Dokumentation TCM120 die auf www.enocean.de zum Download zur Verfügung steht.
Modul Adresse 1-8 Knotennummer (Node) der KL6583


Mapping

Programmierung [image] Betrieb an anderen Steuerungen [image] Mapping
Mapping
Die Busklemmen belegen Adressen im Prozessabbild der Steuerung. Die Zuordnung der Prozessdaten (Ein- und Ausgangsdaten) und Parametrierungsdaten (Control- und Status-Bytes) zu den Steuerungsadressen wird als Mapping bezeichnet. Die Art des Mappings ist abhängig von:
▪
dem verwendeten Feldbus-System
▪
dem Klemmentyp
▪
der Parametrierung des Buskopplers (Bedingungen) wie
–
Intel- oder Motorola-Format
–
Word-Alignment ein- oder ausgeschaltet
Die Buskoppler (BKxxxx, LCxxxx) und Busklemmen Controller (BCxxxx, BXxxxx) werden mit bestimmten Voreinstellungen (Default-Einstellungen) ausgeliefert. Mit der Konfigurationssoftware KS2000 oder mit einer Master-Konfigurationssoftware (z. B. TwinCAT System Manager oder ComProfibus) können Sie diese Default-Einstellungen verändern.
Die folgenden Tabellen zeigen das Mapping in Abhängigkeit der verschiedenen Bedingungen. Die Inhalte der einzelnen Bytes entnehmen Sie bitte den Seiten Prozessabbild sowie Control- und Status-Bytes.
Komplette Auswertung
Bei kompletter Auswertung belegen die analogen Eingangsklemmen Adressen im Ein- und im Ausgangsprozessabbild. Der Zugriff auf Control- und Status-Bytes ist möglich. Die Klemme belegt immer 12 Byte Ein- und 12 Byte Ausgangsdaten. Die KL6583 belegt selbst keine K-Bus Daten, da sie über die Prozessdaten der KL6581 angesprochen wird.
Komplette Auswertung
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: egal Word-Alignment: egal | 0 | CNODE | SB | CNODE | CB
 | 1 | DB0 | ORG | DB0 | ORG
 | 2 | DB2 | DB1 | DB2 | DB1
 | 3 | ID0 | DB3 | ID0 | DB3
 | 4 | ID2 | ID1 | ID2 | ID1
 | 5 | STATUS | ID3 | STATUS | ID3
Legende
Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Worte immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.
SB : Status-Byte (erscheint im Eingangsprozessabbild)
CB : Control-Byte (erscheint im Ausgangsprozessabbild)


KL6581-0000 - Control- und Status-Byte

Programmierung [image] Betrieb an anderen Steuerungen [image] KL6581-0000 - Control- und Status-Byte
KL6581-0000 - Control- und Status-Byte
Prozessdatenbetrieb
Control-Byte im Prozessdatenbetrieb
Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen. Es hat im Prozessdatenbetrieb keine Funktion.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | - | - | Addr Conflict | - | Buffer Full | RxC | TxC
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB.6 | Error | 0bin | allgemeines Fehlerbit
CB.5 | - | 1bin | Reserve
CB.4 | Addr Conflict | 1bin | Adresse einer KL6583 doppelt vergeben
CB.3 | - | 1bin | Reserve
CB.2 | Buffer Full | 1bin | Der interne Datenpuffer ist übergelaufen
CB.1 | RxC | 1bin | Toggle mit zum Empfangen von Daten ist RxS <> RxC dann liegen neu Daten vor, Toggelt man das Bit wird damit der Klemme signalisiert, dass die Daten abgeholt worden sind.
CB.0 | TxC | 1bin | Toggel zum Senden von Daten, ist TxC <> TxS werden Daten von der KL6851 zur KL6853 übertragen.
Status-Byte im Prozessdatenbetrieb
Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | Config Missmatch | Addr Conflict | Communication Error | Buffer Full | RxS | TxS
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB.6 | Error | 1bin | allgemeines Fehlerbit
SB.5 | Config Missmatch | 1bin | Konfigurationsfehler: Überprüfen Sie die Anzahl der projektierten und angeschlossenen KL6583 und deren Adressen. (siehe folgenden Hinweis)
Anzeige von ConfigMissmatch freischalten
Das Status-Bit SB.5 zeigt Konfigurationsfehler erst an, wenn Sie diese Anzeige zuvor durchsetzen des Bits R34.15 im Feature-Register freigeschaltet haben.
Bit | Name | Beschreibung
SB.4 | AddrConflict | 1bin | Adresse einer KL6583 doppelt vergeben
SB.3 | Communication Error | 0bin | Kommunikation OK
 |  | 1bin | Die KL6581 hat keine betriebsbereite KL6583 gefunden. Überprüfen Sie die Verkabelung und die Adressen.
SB.2 | Buffer Full | 1bin | Der interne Datenpuffer ist übergelaufen,
SB.1 | RxS | 1bin | Toggle mit zum Empfangen von Daten ist RxS <> RxC dann liegen neu Daten vor, Toggelt man das Bit wird damit der Klemme signalisiert, dass die Daten abgeholt worden sind.
SB.0 | TxS | 1bin | Toggel zum Senden von Daten, ist TxC <> TxS werden Daten von der KL6851 zur KL6853 übertragen.
Registerkommunikation
Control-Byte bei Registerkommunikation
Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB.5 bis CB.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIN1 lesen oder - mit dem Ausgangsdatenwort DataOUT1 beschreiben wollen.
Status-Byte bei Registerkommunikation
Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB.6 | R | 0bin | Lesezugriff
SB.5 bis SB.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht

Programmierung [image] Betrieb an anderen Steuerungen [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der Klemme. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | reserviert | 0x0000 | 0dez | - | -
... | ... | ... | ... | ... | ...
R3 | reserviert | 0x0000 | 0dez | - | -
R4 | Auswahl der Register-Page | 0x0000 | 0dez | R/W | ROM
R5 | reserviert | 0x0000 | 0dez | - | -
... | ... | ... | ... | ... | ...
R7 | reserviert | 0x0000 | 0dez | - | -
R8 | Klemmentyp | 0x19B5 | 6581dez | R | ROM
R9 | Firmware-Stand | z. B. 0xB100 |  | R | ROM
R10 | Multiplex-Schieberegister | 0x0160 | 352dez | R | ROM
R11 | Signalkanäle | 0x0160 | 352dez | R | ROM
R12 | minimale Datenlänge eines Kanals | 0x6060 | 24672dez | R | ROM
R13 | Datenstruktur | 0x0000 | 0dez | R | ROM
R14 | reserviert | 0x0000 | 0dez | - | -
R15 | Alignment-Register | typisch 0x7F80 | typisch 32640dez | R/W | RAM
R16 | reserviert | 0x0000 | 0dez | - | -
R17 | interne Verwendung | typisch 0x0000 | typisch 0dez | R | EEPROM
R18 | reserviert | 0x0000 | 0dez | R | EEPROM
R19 | reserviert | 0x0000 | 0dez | R | EEPROM
R20 | reserviert für interne Verwendung | 0x0001 | 1dez | R | EEPROM
R21 | reserviert für interne Verwendung | 0x0500 | 1280dez | R | EEPROM
R22 | reserviert für interne Verwendung | 0x0000 | 0dez | R | EEPROM
R23 | reserviert für interne Verwendung | 0x00FF | 255dez | R | EEPROM
R24 | reserviert | 0x0000 | 0dez | - | -
... | ... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | 0dez | - | -
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | EEPROM
R32 | Register zum einblenden der Register-Pages (siehe Register 4) | variabel | variabel | R | RAM
... | ... | ... | ... | ... | ...
R63 | Register zum einblenden der Register-Pages (siehe Register 4) | variabel | variabel | R | RAM
Register-Page 1
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R32 | KL6583 Gefundene Module | variabel | variabel | R | RAM
R33 | Anzahl gefundener Module | variabel | variabel | - | RAM
R34 | Feature-Register | 0x0000 | 0dez | R/W | RAM
R35 | reserviert | 0x0000 | 0dez | - | -
... | ... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | 0dez | - | -
Register-Page 2
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R32/33 | EnOcean-ID der KL6583 mit der CAN-Adresse 1 | variabel | variabel | R | RAM
... | ... | ... | ... | ... | ...
R36/47 | EnOcean-ID der KL6583 mit der CAN-Adresse 8 | variabel | variabel | R | RAM
R48 | Firmware-Version der KL6583 mit der CAN-Adresse 1 | variabel | variabel | R | RAM
... | ... | ... | ... | ... | ...
R55 | Firmware-Version der KL6583 mit der CAN-Adresse 8 | variabel | variabel | R | RAM
R56 | Status der KL6583 mit der CAN-Adresse 1 | variabel | variabel | - | RAM
... | ... | ... | ... | ... | ...
R63 | Status der KL6583 mit der CAN-Adresse 8 | variabel | variabel | - | RAM


Registerbeschreibung

Programmierung [image] Betrieb an anderen Steuerungen [image] Registerbeschreibung
Registerbeschreibung
Die Register dienen zur Parametrierung der Klemme. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
R4: Auswahl der Registerpage (read/write)
Die KL6581-0000 hat zwei Register-Pages über die Register 32 bis 63 angesprochen werden können.
Mir Register 4 wählen Sie aus, welche Register-Page 32 bis 63 eingeblendet wird. Gültige Werte:
0: Registerpage 1
1: Registerpage 2
R8: Klemmentyp
Im Register R8 steht die Bezeichnung des Klemmenmoduls.
KL6581-0000: 0x19B5 (6581dez)
R9: Firmware-Stand
Im Register R9 steht der Firmware-Stand der Klemme, z. B. 0xB100 = 'B1'.
Dieser Wert kann nicht verändert werden.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
Register-Page 1
R32: KL6583 Gefundene Module (read only)
Bei gesetztem Bit ist ein entsprechendes Modul gefunden worden.
Beispiel:
0x0001 nur ein Modul mit der CAN Adresse 1 gefunden.
0x0005 zwei Modul mit der CAN Adresse 1 und 3 gefunden.
0x00FF acht KL6583 gefunden von Adresse 1 bis 8
R33: Anzahl der KL6583 Module (read only)
Anzahl der gefundenen KL6853 Module. Maximal 8.
R34: Feature Register
Das Feature-Register legt verschiedene Eigenschaften der Klemme fest.
Bit | Feature | Wert | Erläuterung | Default
R34.15 | EnableDisplay ConfigMissmatch | 0bin | Das Statusbit SB5 zeigt Konfigurationsfehler nicht an. | 0bin
 |  | 1bin | Das Statusbit SB5 zeigt Konfigurationsfehler an.
R34.14 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R34.0 | - | reserviert |  | 0bin
Register-Page 2
R32/R33 bis R46/R47: EnOcean-IDs der angeschlossenen KL6583
R32/R33: EnOcean-ID der KL6583 mit der CAN-Adresse 1 (read only)
R34/R35: EnOcean-ID der KL6583 mit der CAN-Adresse 2 (read only)
R36/R37: EnOcean-ID der KL6583 mit der CAN-Adresse 3 (read only)
R38/R39: EnOcean-ID der KL6583 mit der CAN-Adresse 4 (read only)
R40/R41: EnOcean-ID der KL6583 mit der CAN-Adresse 5 (read only)
R42/R43: EnOcean-ID der KL6583 mit der CAN-Adresse 6 (read only)
R44/R45: EnOcean-ID der KL6583 mit der CAN-Adresse 7 (read only)
R46/R47: EnOcean-ID der KL6583 mit der CAN-Adresse 8 (read only)
R48 bis R55: Firmware-Versionen der angeschlossenen KL6583
R48: Firmware-Version der KL6583 mit der CAN-Adresse 1 (read only)
R49: Firmware-Version der KL6583 mit der CAN-Adresse 2 (read only)
R50: Firmware-Version der KL6583 mit der CAN-Adresse 3 (read only)
R51: Firmware-Version der KL6583 mit der CAN-Adresse 4 (read only)
R52: Firmware-Version der KL6583 mit der CAN-Adresse 5 (read only)
R53: Firmware-Version der KL6583 mit der CAN-Adresse 6 (read only)
R54: Firmware-Version der KL6583 mit der CAN-Adresse 7 (read only)
R55: Firmware-Version der KL6583 mit der CAN-Adresse 8 (read only)
R56: Zustand der KL6583 mit der CAN-Adresse 1 (read only)
0: nicht existent
8: KL6583 ist im Zustand Operational (im Datenaustausch)
R57: Zustand der KL6583 mit der CAN-Adresse 2 (read only)
0: nicht existent
8: KL6583 ist im Zustand Operational (im Datenaustausch)
R58: Zustand der KL6583 mit der CAN-Adresse 3 (read only)
0: nicht existent
8: KL6583 ist im Zustand Operational (im Datenaustausch)
R59: Zustand der KL6583 mit der CAN-Adresse 4 (read only)
0: nicht existent
8: KL6583 ist im Zustand Operational (im Datenaustausch)
R60: Zustand der KL6583 mit der CAN-Adresse 5 (read only)
0: nicht existent
8: KL6583 ist im Zustand Operational (im Datenaustausch)
R61: Zustand der KL6583 mit der CAN-Adresse 6 (read only)
0: nicht existent
8: KL6583 ist im Zustand Operational (im Datenaustausch)
R62: Zustand der KL6583 mit der CAN-Adresse 7 (read only)
0: nicht existent
8: KL6583 ist im Zustand Operational (im Datenaustausch)
R63: Zustand der KL6583 mit der CAN-Adresse 8 (read only)
0: nicht existent
8: KL6583 ist im Zustand Operational (im Datenaustausch)


Beispiele für die Register-Kommunikation

Programmierung [image] Betrieb an anderen Steuerungen [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Programmierung [image] Betrieb an anderen Steuerungen [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Programmierung [image] Betrieb an anderen Steuerungen [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.