KL6224 - IO-Link-Klemme
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0.0
▪
Migration
1.0.0
▪
Produktübersicht aktualisiert
▪
Technische Daten aktualisiert
▪
Beschreibung der Konfigurations-Software KS2000 erweitert
▪
Registerbeschreibung aktualisiert
0.5
▪
Vorläufige Version
Firm- und Hardware-Stände
Dokumentation Version | KL6224
 | Firmware | Hardware
1.0.0 | 03 | 02
0.5 | 00 | 01
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Die IO-Link-Spezifikation 1.1 wird von der KL6224 ab Firmware-Version 02 unterstützt.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 02 13 00 01:
02 - Produktionswoche 02
13 - Produktionsjahr 2013
00 - Firmware-Stand 00
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
IO-Link - Grundlagen


Einführung

Produktübersicht [image] Einführung
Einführung
KL6224
Die IO-Link-Klemme KL6224 ermöglicht den Anschluss von bis zu vier IO-Link-Teilnehmern, den sogenannten IO-Link-Geräten. Dies können Aktoren, Sensoren oder Kombinationen aus beiden sein. Die Verbindung zwischen der Klemme und dem Teilnehmer erfolgt als Punkt-zu-Punkt-Verbindung.
IO-Link ist als intelligentes Bindeglied zwischen der Feldbusebene und dem Sensor angelegt, wobei Parametrierungsinformationen über die IO-Link-Verbindung bidirektional ausgetauscht werden können. Die Parametrierung der IO-Link-Geräte kann mittels der Konfigurations-Software KS2000 oder aus der SPS heraus über Registerkommunikation erfolgen.
In der Standardeinstellung arbeitet die KL6224 als vierkanalige Eingangsklemme (24 VDC), die bei Bedarf mit angeschlossenen IO-Link-Geräten kommuniziert, sie parametriert und ggf. in der Betriebsart umstellt.
Die Integration der KL6224 in das HD-Gehäuse mit 16 Anschlusspunkten ermöglicht, dass jedes IO-Link-Gerät in 3-Leiteranschlusstechnik betrieben werden kann. Die Direktstecktechnik ermöglicht einen werkzeuglosen Aufbau.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | KL6224
Technik | IO-Link
Anzahl Kanäle | 4
IO-Link-Schnittstellen | 4
Feldspannung | 24 VDC (über Powerkontakte)
Anschluss | 3-Leiter, HD-Klemme
Übertragungsraten | 4,8 kBaud, 38,4 kBaud und 230,4 kBaud
Leitungslänge | maximal 20 m
Spannungsversorgung | über K-Bus und Powerkontakte
Versorgungsstrom für Teilnehmer | 500 mA je Teilnehmer
Stromaufnahme vom K-Bus | typisch 85 mA
Stromaufnahme aus den Powerkontakten | k. A.
Nennspannung | 24 VDC (-15 %/+20 %)
Potenzialtrennung | 500 V (IO-Link / K-Bus)
Gewicht | ca. 60 g
Bitbreite im K-Bus | je nach Prozessabbild
Konfiguration | über Feldbus Parameterinterface, DP-V1 oder Buskoppler durch Konfigurations-Software KS2000
zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
zulässige relative Feuchte | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27 siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus


IO-Link - Grundlagen

Produktübersicht [image] IO-Link - Grundlagen
IO-Link - Grundlagen
IO-Link stellt ein Kommunikationssystem zur Anbindung intelligenter Sensoren und Aktoren an ein Automatisierungssystem in der Norm IEC 61131-9 unter der Bezeichnung "Single-drop digital communication interface for small sensors and actuators" (SDCI) dar.
Sowohl die elektrischen Anschlussdaten als auch das Kommunikationsprotokoll sind standardisiert und in der IO-Link Spec zusammengefasst.
Hinweis
Spezifikation IO-Link
Die Entwicklung der KL6224 unterlag der IO-Link-Spezifikation 1.1. Zum Zeitpunkt der Erstellung dieser Dokumentation geht die IO-Link-Spezifikation in die IEC-Normung ein und wird als IEC 61131-9 in erweiterter Form übernommen. Dabei wird auch die neue Bezeichnung SDCI eingeführt.
Beckhoff unterstützt als Teilnehmer in den entsprechenden Gremien die Entwicklung von IO-Link und bildet Spezifikationsänderungen in seinen Produkten ab.
Ein IO-Link-System besteht aus einem IO-Link-Master und einem oder mehreren IO-Link-Geräten, also Sensoren oder Aktoren. Der IO-Link-Master stellt die Schnittstelle zur überlagerten Steuerung zur Verfügung und steuert die Kommunikation mit den angeschlossenen IO-Link-Geräten. Die Beckhoff IO-Link-Masterklemme KL6224 besitzt vier IO-Link-Ports, an dem je ein IO-Link-Gerät angeschlossen werden kann. IO-Link stellt daher keinen Feldbus dar, sondern ist eine Peer-to-Peer Verbindung (siehe Abb. Peer-to-Peer Kommunikation IO-Link).
Peer-to-Peer Kommunikation IO-Link
Die angeschlossenen IO-Link-Geräte besitzen individuelle Parameterinformationen in Form einer IO Device Description (IODD), die mit der Konfigurations-Software KS2000 eingestellt werden (siehe Kapitel KS2000 - Einstellungen).
Parameter-Datenaustausch
Ein intelligentes IO-Link-Gerät kann eine Parametrierung durch SPDU (Service Protocol Data Units) unterstützen. Diese azyklischen Servicedaten müssen von der SPS explizit angefragt oder, als solche gekennzeichnet, gesendet werden.
Hinweis
SPDU-Zugang
TwinCAT unterstützt aktuell nur den Zugriff über ADS.
Über den sogenannten SPDU-Index wird der entsprechende Parameter adressiert, verfügbar sind die folgenden Bereiche.
Index-Bereich | Bezeichnung
0x00...0x0F | System
0x10...0x1F | Identification
0x20...0x2F | Diagnostic
0x30...0x3F | Communication
0x40...0xFE | Prefered Idnex
0x0100...0x3FFF | Extended Index
0x4000...0xFFFF | n.n. (reserviert)
Die Nutzung und Implementierung dieser Bereiche obliegt dem Sensor/Aktor-Hersteller.
Zur Verdeutlichung seien hier nur einige mögliche Indexe mit Bezeichnung aufgeführt, siehe dazu die Dokumentation des verwendeten IO-Link-Geräts.
Index | Name
0x0010 | Vendor Name
0x0011 | Vendor Text
0x0012 | Product Name
0x0013 | Product ID
0x0015 | Serial Number
0x0016 | Hardware Revision
0x0017 | Firmware Revision
... | ...


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschlusstechnik
•
Anschlussbelegung
•
LED-Anzeigen


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Hinweis
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Hinweis
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Hinweis
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Anschlussbelegung

Montage und Verdrahtung [image] Anschlussbelegung
Anschlussbelegung
Anschlussbelegung KL6224
Anschlussbelegung
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Input 1 | 1 | Eingang 1
+ 24 V | 2 | + 24 V
Input 2 | 3 | Eingang 2
+ 24 V | 4 | + 24 V
Input 3 | 5 | Eingang 3
+ 24 V | 6 | + 24 V
Input 4 | 7 | Eingang 4
+ 24 V | 8 | + 24 V
+ 24 V | 9 | + 24 V
0 V | 10 | 0 V
+ 24 V | 11 | + 24 V
0 V | 12 | 0 V
+ 24 V | 13 | + 24 V
0 V | 14 | 0 V
+ 24 V | 15 | + 24 V
0 V | 16 | 0 V


LED-Anzeigen

Montage und Verdrahtung [image] LED-Anzeigen
LED-Anzeigen
LEDs
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LEDs geben den Betriebszustand der Klemme wieder:
 |  | aus | keine Datenübertragung auf dem K-Bus
 |  | blinkt | Datenübertragung auf dem K-Bus
Status Ch. 1 - 4 | grün | an / aus | Zustand der Signalleitung (bei Konfiguration als STD in / out)
 |  | 2 x kurz blinken | IO-Link Kommunikation wird aufgebaut
 |  | dauerhaft blinkend | IO-Link Kommunikation aufgebaut und in Funktion


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Konfiguration der KL6224
•
Register
•
Einstellungen


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Konfiguration der KL6224

Konfigurations-Software KS2000 [image] Konfiguration der KL6224
Konfiguration der KL6224
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Ethernet-Koppler BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine IO-Link-Klemme KL6224
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 1).
KS2000-Baumzweige für Kanal 1 der KL6224
Für die KL6224 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL6224.
▪
Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL6224.
▪
ProcData zeigt die Prozessdaten der KL6224.


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register der KL6224 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Register Ansicht in KS2000
Der Screenshot zeigt die Register der KL6224.


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Starten Sie die Konfigurations-Software KS2000.
KS2000 - Start der Konfigurations-Software
Kommunikationskanal
Die Kommunikation zwischen KS2000 und der KL6224 kenn entweder über den Feldbus (via ADS) oder über ein serielles Kabel (via COM-Schnittstelle) erfolgen.
Klicken Sie auf Optionen/Kommunikationskanal um den Kommunikationskanal zu wählen.
KS2000 - Auswahl des Kommunikationskanals
Einloggen
Klicken Sie auf die Schaltfläche Login.
Die Feldbusstation wird als Baumstruktur angezeigt.
KS2000 - Anzeige der Feldbusstation
Einfügen der IO-Link-Geräte
Es gibt drei Möglichkeiten ein IO-Link-Gerät einzufügen:
1.
Automatisches Scannen der IO-Link-Ports, Schaltfläche [Scan devices]
2.
Manuelles Einfügen über Katalog, Schaltfläche [Catalog]
3.
Importieren der Gerätebeschreibung, Schaltfläche [Import Device Description]
Einfügen der IO-Link-Geräte
Automatisches Scannen der IO-Link-Ports
Schließen Sie den IO-Link-Sensor an die KL6224 an.
Schalten Sie den Buskoppler mit der KL6224 ein.
Klicken Sie auf die Schaltfläche Login [image] um sich mit der Feldbusstation zu verbinden und das geänderte Prozessabbild der KL6224 einzulesen.
Klicken Sie im Dialog General auf die Schaltfläche [Scan devices].
Automatisches Scannen der IO-Link-Ports
Hinweis
Communication Mode
Zum Scannen darf der Communication Mode nicht auf Communication stehen (Port1/Settings)!
Anzeige der erkannten IO-Link-Geräte
Die erkannten IO-Link-Geräte werden angezeigt und ihre Prozessdaten angelegt.
Manuelles Einfügen über Katalog
Klicken Sie im Dialog General auf die Schaltfläche [Catalog].
Manuelles Einfügen über Katalog
Hier können Sie nun
Aufruf des Dialogs create Device
mit dem Dialog create Device manuell ein IO-Link-Gerät
Der Dialog create Device
mit den wichtigsten Kommunikationsparametern anlegen.
Importieren der Gerätebeschreibung
Klicken Sie im Dialog General auf die Schaltfläche [Import Device Description].
Importieren der Gerätebeschreibung
Die XML-Dateien der IO-Link-Geräte liegen im IO-Link-Ordner von KS2000 (z. B. unter Windows 7 im Ordner C:\Program Files (x86)\KS2000_V4\IOLink)
Auswahl der XML-Datei
Wählen Sie die XML-Datei des gewünschten Sensors aus und öffnen Sie diese.
Fahren Sie nun mit dem Scannen der IO-Link Ports fort (siehe oben).
Die erkannten IO-Link-Geräte werden angezeigt und ihre Prozessdaten angelegt.
Hinweis
IODD immer Importieren
Auch beim Scannen oder manuellen anlegen von IO-Link-Geräte sollten Sie vorhandene IODD zusätzlich einlesen, um weitere sensorspezifische Informationen zu bekommen.
K-Bus-Interface
Beachten Sie: Beim Wechseln der IO-Link-Geräte kann folgende Meldung auftreten.
Das K-Bus-Interface der KL6224 hat sich geändert
Diese Meldung zeigt an, dass sich das K-Bus-Interface der KL6224 geändert hat, weil der Anschluss eines weiteren IO-Link-Geräts das Prozessabbild der KL6224 verändert hat.
Diese Meldung hat aber keine weiteren Auswirkungen auf die Einbindung der IO-Link-Geräte.
Einstellungen der IO-Link-Ports
Klicken Sie im Dialog General auf Settings des gewünschten Ports.
Einstellungen der IO-Link-Ports?
StartUpChecks
Hier kann ausgewählt werden, ob beim Anlauf des IO-Link Gerätes die Vendor-ID und die Device-ID geprüft werden sollen.
CycleTime
Hier wird die Zykluszeit des IO-Link-Masters angegeben
Communication mode
Hier kann ein IO-Link-Gerät in verschieden Modi betrieben werden. Default-Modus für IO-Link Geräte ist Communication.
Error reaction
Ist diese Checkbox gesetzt, werden im Fehlerfall die Eingangsdaten auf 0 gesetzt.
Advanced
Klicken Sie auf die Schaltfläche [Advanced] um in den Dialog für die erweiterten Einstellungen zu gelangen.
Erweiterten Einstellungen
Data Storage
Beachten Sie die Version der Sensoren:
▪
V1.0: Data Storage wird nicht unterstützt
▪
V1.1: Data Storage wird unterstützt: Im Auslieferungszustand (default) werden Daten (Sensorparameter) gespeichert.
Process Data Format
Hier können Sie das Prozessdatenformat anpassen.
Ist die Checkbox only Octet String gesetzt, werden komplexe Datentypen (Prozessdaten) zur Vereinfachung als Octet String angelegt.


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Byte
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation
•
Register-Pages für IO-Link-Parameter
•
Zugriff auf IO-Link Parameter
•
Firmware-Stand der Buskoppler


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Das Prozessabbild der KL6224 besteht aus einem 6 Byte großen Parameterdatenblock und einem 6, 8, 18, 30 oder 42 Byte großen Prozessdatenblock.
Es ergibt sich somit ein 12, 14, 24, 36 oder 48 Byte großes Prozessabbild.
Die Größe des Prozessabbilds kann mit der Konfigurations-Software KS2000 oder feldbusspezifisch über den Buskoppler eingestellt werden. Sie wird im Register R27 der KL6224 gespeichert.
Nach Änderung des Prozessabbilds müssen Sie den Buskoppler neu starten, damit er das geänderte Prozessabbild übernimmt.
Beachten Sie das Kapitel Firmeware-Stand der Buskoppler um zu erfahren, welche Prozessabbilder Ihr Buskoppler unterstützt.
Beschreibung der Prozessabbilder
Hinweis
Auswahl des Prozessabbilds
Wählen Sie das Prozessabbild nicht größer, als zum Betrieb Ihrer IO-Link-Geräte erforderlich ist!
Diese Auswahl spart sowohl auf dem übergeordneten Feldbus als auch auf dem K-Bus Bandbreite. Da nur 12 Byte in einem K-Bus Zyklus zur KL6224 übertragen werden können, ist mit minimaler Auswahl auch die Update-Rate der anderen Klemmen optimal schnell.
12 Byte Prozessabbild
Das 12 Byte Prozessabbild besteht aus einem 6 Byte großen Parameterdatenblock und einem 6 Byte großen Prozessdatenblock.
Ausgangsdaten (SPS -> KL6224)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (6 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3 | DataOut0 | DataOut1 | DataOut2 | DataOut3 | DataOut4 | DataOut5
Eingangsdaten (KL6224 -> SPS)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (6 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3 | StatusCh1 | StatusCh2 | StatusCh3 | StatusCh4 | DataIn0 | DataIn1
Legende
CB n: Control-Byte n der KL6224
SB n: Status-Byte n der KL6224
Para Out n: Ausgangsparameter, Byte n
Para In n: Eingangsparameter, Byte n
StatusCH n: Statusinformationen des IO-Link-Geräts n
DataOut n: Ausgangsdaten-Byte n
DataIn n: Eingangsdaten-Byte n
12 Byte Prozessabbild, komprimierter Modus
Der komprimierte Modus verdichtet die Daten, um Platz zu sparen (z. B. für CANopen-Buskoppler). Er kann über den Parameter Master Control (Register R41 auf Register-Page 4) eingeschaltet werden.
Wenn der komprimierte Modus eingeschaltet ist, gilt er für alle IO-Link-Ports!
Der komprimierte Modus steht auch für die größeren Prozessabbilder (14, 24, 36 und 48 Byte) zur Verfügung.
Für die größeren Prozessabbilder ist der gemischte Datenblock genau wie hier dargestellt aufgebaut und der Prozessdatenblock beinhaltet dann die weiteren Daten-Bytes ab DataOut2/DataIn2.
Ausgangsdaten (SPS -> KL6224)
gemischter Datenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (6 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut21 oder DataOut02 | ParaOut31 oder DataOut12 | DataOut2 | DataOut3 | DataOut4 | DataOut5 | DataOut6 | DataOut7
Eingangsdaten (KL6224 -> SPS)
gemischter Datenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (6 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
SB01 oder StatusCh1/22 | SB11 oder StatusCh3/42 | ParaIn0 | ParaIn1 | ParaIn31 oder DataIn02 | ParaIn41 oder DataIn12 | DataIn2 | DataIn3 | DataIn4 | DataIn5 | DataIn6 | DataIn7
1) bei Registerkommunikation (siehe Kapitel Control- und Status-Byte)
2) bei Prozessdatenbetrieb
Legende
CB n: Control-Byte n der KL6224
SB n: Status-Byte n der KL6224
Para Out n: Ausgangsparameter, Byte n
Para In n: Eingangsparameter, Byte n
StatusCh1/2: Statusinformationen des IO-Link-Geräts n (4-Bit low = Port 1 / 4Bit high = Port 2)
StatusCh3/4: Statusinformationen des IO-Link-Geräts n (4-Bit low = Port 3 / 4Bit high = Port 4)
DataOut n: Ausgangsdaten-Byte n
DataIn n: Eingangsdaten-Byte n
14 Byte Prozessabbild
Das 14 Byte Prozessabbild besteht aus einem 6 Byte großen Parameterdatenblock und einem 8 Byte großen Prozessdatenblock.
Ausgangsdaten (SPS -> KL6224)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (8 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11 | Byte 12 | Byte 13
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3 | DataOut0 | DataOut1 | DataOut2 | DataOut3 | DataOut4 | DataOut5 | DataOut6 | DataOut7
Eingangsdaten (KL6224 -> SPS)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (8 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11 | Byte 12 | Byte 13
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3 | StatusCh1 | StatusCh2 | StatusCh3 | StatusCh4 | DataIn0 | DataIn1 | DataIn2 | DataIn3
Legende
Siehe 12 Byte Prozessabbild.
24 Byte Prozessabbild (default)
Das 24 Byte Prozessabbild besteht aus einem 6 Byte großen Parameterdatenblock und einem 18 Byte großen Prozessdatenblock. Diese Einstellung ist im Auslieferungszustand der KL6224 aktiviert.
Ausgangsdaten (SPS -> KL6224)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (18 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3 | DataOut0 | DataOut1 | DataOut2 | DataOut3 | DataOut4 | DataOut5
Prozessdatenblock (18 Byte, Fortsetzung)
Byte 12 | Byte 13 | Byte 14 | Byte 15 | Byte 16 | Byte 17 | Byte 18 | Byte 19 | Byte 20 | Byte 21 | Byte 22 | Byte 23
DataOut6 | DataOut7 | DataOut8 | DataOut9 | DataOut10 | DataOut11 | DataOut12 | DataOut13 | DataOut14 | DataOut15 | DataOut16 | DataOut17
Eingangsdaten (KL6224 -> SPS)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (18 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3 | StatusCh1 | StatusCh2 | StatusCh3 | StatusCh4 | DataIn0 | DataIn1
Prozessdatenblock (18 Byte, Fortsetzung)
Byte 12 | Byte 13 | Byte 14 | Byte 15 | Byte 16 | Byte 17 | Byte 18 | Byte 19 | Byte 20 | Byte 21 | Byte 22 | Byte 23
DataIn2 | DataIn3 | DataIn4 | DataIn5 | DataIn6 | DataIn7 | DataIn8 | DataIn9 | DataIn10 | DataIn11 | DataIn12 | DataIn13
Legende
Siehe 12 Byte Prozessabbild.
36 Byte Prozessabbild
Das 36 Byte Prozessabbild besteht aus einem 6 Byte großen Parameterdatenblock und einem 30 Byte großen Prozessdatenblock.
Ausgangsdaten (SPS -> KL6224)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (30 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3 | DataOut0 | DataOut1 | DataOut2 | DataOut3 | DataOut4 | DataOut25
Prozessdatenblock (30 Byte, Fortsetzung)
Byte 12 | Byte 13 | Byte 14 | Byte 15 | Byte 16 | Byte 17 | Byte 18 | Byte 19 | Byte 20 | Byte 21 | ... | Byte 35
DataOut6 | DataOut7 | DataOut8 | DataOut9 | DataOut10 | DataOut11 | DataOut12 | DataOut13 | DataOut14 | DataOut15 | ... | DataOut29
Eingangsdaten (KL6224 -> SPS)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (30 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3 | StatusCh1 | StatusCh2 | StatusCh3 | StatusCh4 | DataIn0 | DataIn1
Prozessdatenblock (30 Byte, Fortsetzung)
Byte 12 | Byte 13 | Byte 14 | Byte 15 | Byte 16 | Byte 17 | Byte 18 | Byte 19 | Byte 20 | Byte 21 | ... | Byte 35
DataIn2 | DataIn3 | DataIn4 | DataIn5 | DataIn6 | DataIn7 | DataIn8 | DataIn9 | DataIn10 | DataIn11 | ... | DataIn13
Legende
Siehe 12 Byte Prozessabbild.
48 Byte Prozessabbild
Das 48 Byte Prozessabbild besteht aus einem 6 Byte großen Parameterdatenblock und einem 42 Byte großen Prozessdatenblock.
Ausgangsdaten (SPS -> KL6224)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (42 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3 | DataOut0 | DataOut1 | DataOut2 | DataOut3 | DataOut4 | DataOut25
Prozessdatenblock (42 Byte, Fortsetzung)
Byte 12 | Byte 13 | Byte 14 | Byte 15 | Byte 16 | Byte 17 | Byte 18 | Byte 19 | Byte 20 | Byte 21 | ... | Byte 48
DataOut6 | DataOut7 | DataOut8 | DataOut9 | DataOut10 | DataOut11 | DataOut12 | DataOut13 | DataOut14 | DataOut15 | ... | DataOut41
Eingangsdaten (KL6224 -> SPS)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (42 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3 | StatusCh1 | StatusCh2 | StatusCh3 | StatusCh4 | DataIn0 | DataIn1
Prozessdatenblock (42 Byte, Fortsetzung)
Byte 12 | Byte 13 | Byte 14 | Byte 15 | Byte 16 | Byte 17 | Byte 18 | Byte 19 | Byte 20 | Byte 21 | ... | Byte 48
DataIn2 | DataIn3 | DataIn4 | DataIn5 | DataIn6 | DataIn7 | DataIn8 | DataIn9 | DataIn10 | DataIn11 | ... | DataIn37
Legende
Siehe 12 Byte Prozessabbild.


Control- und Status-Byte

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Byte
Control- und Status-Byte
Registerkommunikation
Control-Byte (bei Registerkommunikation)
Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB.5 bis CB.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie lesen oder beschreiben wollen.
Status-Byte (bei Registerkommunikation)
Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB.6 | R | 0bin | Lesezugriff
SB.5 bis SB.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Prozessdatenbetrieb
Hinweis
Control- und Status-Byte im Prozessdatenbetrieb
Zurzeit haben Control- und Status-Byte der KL6224 im Prozessdatenbetrieb keine weitere Funktion.
Control-Byte (im Prozessdatenbetrieb)
Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB.6 bis CB.0 | - | 0bin | reserviert
Status-Byte (im Prozessdatenbetrieb)
Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB.6 to SB.0 | Error | 0bin | reserviert


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der Klemme und können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register | Kommentar | Defaultwert |  | R/W | Speicher
R0 bis R3 | reserviert | 0x0000 | 0dez | - | -
R4 | Registerpage | 0x0004 | 4dez | R/W |
R5 bis R7 | reserviert | 0x0000 | 0dez | - | -
R8 | Klemmenbezeichnung | 0x1850 | 6224dez | R | ROM
R9 | Firmware-Stand | z. B. 0x0100 | z. B. 256dez | R | ROM
R10 | Multiplex-Schieberegister | 0x0160 | 352dez | R | ROM
R11 | Signalkanäle | 0x0160 | 352dez | R | ROM
R12 | minimale Datenlänge | 0x6060 | 24672dez | R | ROM
R13 | Datenstruktur der Busklemme | 0x0001 | 1dez | R | ROM
R14 | reserviert | - | - | - | -
R15 | Alignment-Register | - | - | R/W | RAM
R16 bis R26 | reserviert | 0x0000 | 0dez | - | -
R27 | reserviert | 0x0001 | 1dez | R/W | SEEROM/RAM
R28 bis R30 | reserviert | 0x0000 | 0dez | - | -
R31 | Kodewort-Register (nicht benutzt) | 0x0000 | 0dez | R/W | RAM
R32 bis R63 | Register zum Einblenden der Registerpages | - | - | - | -


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die Register dienen zur Parametrierung der Klemme und können über die Registerkommunikation ausgelesen oder beschrieben werden.
Die Register 0 bis 31 haben immer die gleiche Bedeutung. Der Inhalt der Register 32 bis 63 wird über das Register-Page-Auswahlregister (R4) festgelegt.
R4: Registerpage-Auswahlregister
Mit diesem Register legen Sie fest, welche Registerpage in die Register R32 bis R63 der KL6224 eingeblendet wird (default: 0x0000).
Über die Registerpages haben Sie Zugriff auf die IO-Link-Konfiguration, -Diagnose und Parametrierung der KL6224.
R8: Klemmenbezeichnung
Im Register R8 steht in hexadezimaler Codierung die Bezeichnung der Klemme: 0x1850 (6224dez)
R9: Firmware-Stand
Im Register R9 steht in hexadezimaler Codierung der Firmware-Stand der Klemme, z.B. 0x0100 (256dez).
R10: Schieberegisterlänge
0x0160
R11: Anzahl der Signalkanäle
0x0160
R12: Minimale Datenlänge
0x6060
R13: Datenstruktur der Busklemme
Im Register R13 steht die Datenstruktur der Busklemme.
R15: Alignment-Register
R31: Kodewort-Register
Das Kodewort-Register der KL6224 ist für den Anwender ohne Funktion, da alle Einstellungen die er über die Register R32 bis R63 (Register-Pages) vorgibt sofort von der KL6224 ausgeführt werden.
Register-Pages
In die Register R32 bis R64 blendet die KL6224 die IO-Link-Konfiguration, -Diagnose und Parametrierung der mit Register R4 ausgewählten Registerpage ein.
Register-Page 2 (RP2)
Schreiben Sie eine 2 in das Registerpage-Auswahlregister R4, um auf das Register RP2.R32 zugreifen zu können.
RP2.R32
Dieses Register legt die Größe des Prozessabbilds der KL6224 fest.
Wert | Prozessabbilds | Default
0002hex | 12 Byte Prozessabbild (6 Byte Parameter-Interface und 6 Byte IO-Link-Prozessdaten) | 0004hex
0004hex | 24 Byte Prozessabbild
0005hex | 36 Byte Prozessabbild
0006hex | 48 Byte Prozessabbild
weitere | reserviert
Nach Änderung des Prozessabbilds müssen Sie den Buskoppler neu starten, damit er das geänderte Prozessabbild übernimmt.
Register-Page 4 bis 9
Siehe Kapitel Register-Pages für IO-Link-Parameter.


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme
Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Hinweis
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Register-Pages für IO-Link-Parameter

Zugriff aus dem Anwenderprogramm [image] Register-Pages für IO-Link-Parameter
Register-Pages für IO-Link-Parameter
Auf die Parameter der KL6224 kann über Registerkommunikation oder die Konfigurationssoftware KS2000 zugegriffen werden. Als Basis dient das Registermodell der Klemmen. Die KL6224 verfügt über 64 Register (Worte). Die Register 0 bis 31 haben immer die gleiche Bedeutung. Der Inhalt der Register 32 bis 63 wird über das Register-Page-Auswahlregister (R4) festgelegt.
Eine Register-Page ist 32 Register (64 Byte) groß. Folgende Register-Pages werden genutzt:
▪
Register-Page 4: Parameter für Kanal 1 (IO-Link-Gerät 1)
▪
Register-Page 5: Parameter für Kanal 2 (IO-Link-Gerät 2)
▪
Register-Page 6: Parameter für Kanal 3 (IO-Link-Gerät 4)
▪
Register-Page 7: Parameter für Kanal 4 (IO-Link-Gerät 4)
▪
Register-Page 8: CMD/Status-Interface und azyklische Daten für IO-Link-Geräte
▪
Register-Page 9: azyklische Daten
Zuordnung der IO-Link-Parameter zu Registerpage und Klemmenregister
Register-Page 4 (RP4): Parameter für Kanal 1 (IO-Link-Gerät 1)
Register der KL6224 | Beschreibung | Name |  | Kommentar
RP4.R32 | IO-Link-Master-Konfiguration: Hier werden die Masterparameter zum Betrieb eines IO-Link-Gerätes eingetragen (wie Objekt 0x8000 der EL6224). | IO-Link DeviceID LowWord |  | Geräte-ID des IO-Link-Gerätes
RP4.R33 |  | IO-Link DeviceID HighWord
RP4.R34 |  | IO-Link VendorID LowWord |  | Hersteller-ID des IO-Link-Gerätes
RP4.R35 |  | IO-Link VendorID HighWord
RP4.R36 |  | LowByte | IO-Link Revision: Bit 0...3: MinorRev Bit 4...7: MajorRev | Kennzeichnung der Version der Spezifikation, nach der das IO-Link Gerät kommuniziert.
 |  | HighByte | FrameCapability: Bit 0: SPDU Bit 1: Type1 Bit 7: PHY1 | Der Frame Capability kennzeichnet bestimmte Funktionalitäten des IO-Link Gerätes (wie z.B.: SPDU supported).
RP4.R37 |  | LowByte | minCycleTime: Bit 6, 7: Time Base Bit 0...5: Multiplier | Siehe folgende Tabelle (Time Base)
 |  | HighByte | OffsetTime | reserviert
RP4.R38 |  | LowByte | ProcDataLenght Input (im IO-Link-Format) | Bit 7 | Byte | 0bin | Length wird in Bit gezählt
 |  |  |  |  |  | 1bin | Length wird in Byte gezählt
 |  |  |  | Bit 6 | SIO | 1bin | das Gerät unterstützt den Standard-IO-Modus
 |  |  |  | Bit 0...4 | Length |  | Länge der Prozessdaten
 |  | HighByte | ProcDataLenght Output (im IO-Link-Format) | siehe LowByte
RP4.R39 |  | CompatibleId |  | zur Zeit nicht genutzt
RP4.R40 |  | - |  | reserviert
RP4.R41 |  | MasterControl |  | 0 | Kanal 1 ist inaktiv
 |  |  |  | 1 | Kanal 1 ist digitaler Eingang
 |  |  |  | 2 | Kanal 1 ist digitaler Ausgang
 |  |  |  | 3 | Kanal 1 ist IO-Link Port und kommuniziert über das IO-Link-Protokoll
 |  |  |  | 4 | reserviert
 |  |  |  | 5 | Kanal 1 ist IO-Link Port und kommuniziert über das IO-Link-Protokoll mit komprimiertem Modus. Hinweis: Wenn der komprimierte Modus für Kanal 1 eingeschaltet ist, ist er für alle Kanäle, die als IO-Link Ports arbeiten eingeschaltet!
Time Base
Time Base | Bedeutung Time base | Berechnung | Min. Cycle Time
00bin | 0,1 ms | Multiplier x Time Base | 0,0...6,3 ms
01bin | 0,4 ms | 6,4 ms + Multiplier x Time Base | 6,4...31,6 ms
10bin | 1,6 ms | 32,0 ms + Multiplier x Time Base | 32,0...132,8 ms
11bin | 6,4 ms | 134,4 ms + Multiplier x Time Base | 134,4...537,6 ms
Register der KL6224 | Beschreibung | Name |  | Kommentar
RP4.R42 | IO-Link IstDaten: Hier werden die tatsächlichen Daten des IO-Link-Gerätes angezeigt das angeschlossen ist. Dies dient zum Vergleich mit den oben beschriebenen Masterparameter (wie Objekt 0x9000 der EL6224). | IO-Link DeviceID LowWord |  | Geräte-ID des IO-Link-Gerätes
RP4.R43 |  | IO-Link DeviceID HiWord
RP4.R44 |  | IO-Link VendorID LowWord |  | Hersteller-ID des IO-Link-Gerätes
RP4.R45 |  | IO-Link VendorID HiWord
RP4.R46 |  | LowByte | IO-Link Revision Bit 0...3: MinorRev Bit 4...7: MajorRev | Kennzeichnung der Version der Spezifikation, nach der das IO-Link Gerät kommuniziert.
 |  | HighByte | FrameCapability: Bit 0: SPDU Bit 1: Type1 Bit 7: PHY1 | Der Frame Capability kennzeichnet bestimmte Funktionalitäten des IO-Link Gerätes (wie z. B.: SPDU supported).
RP4.R47 |  | LowByte | minCycleTime: Bit 6, 7: Time Base Bit 0...5: Multiplier | Siehe folgende Tabelle (Time Base)
 |  | HighByte | OffsetTime | reserviert
RP4.R48 |  | LowByte | ProcDataLenght Input (im IO-Link-Format) | Bit 7 | Byte | 0bin | Length wird in Bit gezählt
 |  |  |  |  |  | 1bin | Length wird in Byte gezählt
 |  |  |  | Bit 6 | SIO | 1bin | das Gerät unterstützt den Standard-IO-Modus
 |  |  |  | Bit 0...4 | Length |  | Länge der Prozessdaten
 |  | HighByte | ProcDataLenght Output (im IO-Link-Format) | siehe LowByte
RP4.R49 |  | - |  | reserviert
RP4.R50 |  | - |  | reserviert
RP4.R51 |  | - |  | reserviert
Time Base | Bedeutung Time base | Berechnung | Min. Cycle Time
00bin | 0,1 ms | Multiplier x Time Base | 0,0...6,3 ms
01bin | 0,4 ms | 6,4 ms + Multiplier x Time Base | 6,4...31,6 ms
10bin | 1,6 ms | 32,0 ms + Multiplier x Time Base | 32,0...132,8 ms
11bin | 6,4 ms | 134,4 ms + Multiplier x Time Base | 134,4...537,6 ms
Register der KL6224 | Beschreibung | Name |  | Kommentar
RP4.R52 | IO-Link Diagnose | LowByte | IO-Link-State Der Wert des IO-Link State entspricht einem State aus der IO-Link Master Statemachine ( wie Objekt 0xA000 der EL6224). | 0 | Inactive
 |  |  |  | 1 | DigInput
 |  |  |  | 2 | DigOutput
 |  |  |  | 3 | EstablishComm
 |  |  |  | 4 | InitMaster
 |  |  |  | 5 | InitDevice
 |  |  |  | 6 | reserviert
 |  |  |  | 7 | reserviert
 |  |  |  | 8 | Operate
 |  |  |  | 9 | Stop
 |  | HighByte | LostFrames | Hier werden die Anzahl der verloren gegangenen IO-Link Telegramme mitgezählt. Dieser Wert wird bei jedem Hochlauf von IO-Link gelöscht, ansonsten immer weiter gezählt.
Register-Page 5 (RP5): Parameter für Kanal 2 (IO-Link-Gerät 2)
Aufbau wie Register-Page 4
Register-Page 6 (RP6): Parameter für Kanal 3 (IO-Link-Gerät 3)
Aufbau wie Register-Page 4
Register-Page 7 (RP7): Parameter für Kanal 4 (IO-Link-Gerät 4)
Aufbau wie Register-Page 4
Register-Page 8 (RP8): CMD/Status-Interface und azyklische Daten für IO-Link-Gerät
Register der KL6224 | Beschreibung | Name |  | Kommentar
RP8.R32 | Cmd | TACYCLICKBUSCMD_CMD_START |  | 0x00000001
 |  | TACYCLICKBUSCMD_CMD_ACK |  | 0x00000002
 |  | TACYCLICKBUSCMD_CMD_READ_CH1 |  | 0x00000010
 |  | TACYCLICKBUSCMD_CMD_READ_CH2 |  | 0x00000020
 |  | TACYCLICKBUSCMD_CMD_READ_CH3 |  | 0x00000030
 |  | TACYCLICKBUSCMD_CMD_READ_CH4 |  | 0x00000040
 |  | TACYCLICKBUSCMD_CMD_WRITE_CH1 |  | 0x00000100
 |  | TACYCLICKBUSCMD_CMD_WRITE_CH2 |  | 0x00000200
 |  | TACYCLICKBUSCMD_CMD_WRITE_CH3 |  | 0x00000300
 |  | TACYCLICKBUSCMD_CMD_WRITE_CH4 |  | 0x00000400
 |  | TACYCLICKBUSCMD_CMD_SCAN_CH1 |  | 0x00001000
 |  | TACYCLICKBUSCMD_CMD_SCAN_CH2 |  | 0x00002000
 |  | TACYCLICKBUSCMD_CMD_SCAN_CH3 |  | 0x00003000
 |  | TACYCLICKBUSCMD_CMD_SCAN_CH4 |  | 0x00004000
RP8.R33 | Status | TACYCLICKBUSCMD_STATUS_IDLE |  | 0x00000000
 |  | TACYCLICKBUSCMD_STATUS_BUSY |  | 0x00000001
 |  | TACYCLICKBUSCMD_STATUS_DATAREADY |  | 0x00000002
 |  | TACYCLICKBUSCMD_STATUS_DATAERROR |  | 0x00000003
RP8.R34 |  | SPDU / ISDU SubIdx |  | Index der SPDU / ISDU
RP8.R35 |  | LowByte | Length | Länge der Daten
 |  | HighByte | SPDU / ISDU SubIdx | Subindex der SPDU / ISDU
RP8.R36 | azyklische Daten für das IO-Link-Gerät |  |  |
... |  |  |  |
RP8.R61 |  |  |  |
Register-Page 9 (RP9): Weitere azyklische Daten für IO-Link-Gerät
Register der KL6224 | Beschreibung | Wert | Kommentar
RP9.R0 | Weitere azyklische Daten für das IO-Link-Gerät |  |
... |  |  |
RP9.R61 |  |  |
Ablauf für eine azyklische Anfrage
Der Ablauf für eine azyklische Anfrage zu einem IO-Link-Gerät ist wie folgt:
1.
Auslesen von Register-Page 8 R33 (Status) ob Status = Idle ist
2.
Wenn Status = Idle ist, dann TACYCLICKBUSCMD_CMD_START in Register-Page 8 R32 (Cmd) schreiben
3.
Bei Bedarf azyklische Daten in den Puffer ab Register-Page 8, R36 schreiben
4.
Dienst starten mit schreiben des entsprechenden Dienstes in Register-Page 8 R32 (Cmd)
5.
Register-Page 8 R33 (Status) auslesen bis nicht mehr Busy
6.
Bei Bedarf azyklische Daten aus dem Puffer ab Register-Page 8, R36 lesen
7.
Abschließen des Dienstes durch schreiben von TACYCLICKBUSCMD_CMD_ACK in Register-Page 8 R32 (Cmd)


Zugriff auf IO-Link Parameter

Zugriff aus dem Anwenderprogramm [image] Zugriff auf IO-Link Parameter
Zugriff auf IO-Link Parameter
Über den Parameterdaten-Block erfolgt der Zugriff auf die Parameter der KL6224 IO-Link Master Klemme. In Folgenden sind der Schreibzugriff und der Lesezugriff mit Beispielen dokumentiert.
Schreiben eines Parameters
Um einen Parameter zu schreiben ist folgende Sequenz einzuhalten:
Überprüfen Sie Zunächst, ob der vorherige Zugriff vollständig abgeschlossen wurde. Werten Sie hierzu Status-Byte 1 aus: Bits 4 bis 7 müssen 0bin sein. Falls nicht, sind Control-Byte 0 und Control-Byte 1 auf 0 zu setzen bis die Bits 4 bis 7 im Status-Byte 1 auf 0bin gesetzt sind.
Schreibzugriff (SPS->KL6224): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 01binA5A4 A3A2A1A0 | 0100bin A9A8A7A6 | P0...P7 | P8...P15 | P16...P23 | P24...P31
A0 bis A9: Bits der Parameteradresse
P0 bis P31: Bits des Parameter-Werts
Antwort auf Schreibzugriff (KL6224->SPS): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status-Byte 0 | Status-Byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Wert | xxxx xxxxbin | 01F1 xxx1bin | Error-Code | Error-Code | Error-Code | Error-Code
x: Bits können beliebige Werte annehmen
F: Fehler-Bit.
F=0bin: Schreibzugriff war erfolgreich.
F=1bin: Schreibzugriff war nicht erfolgreich. Die Bytes 2 bis 5 enthalten einen Error-Code, der Aufschluss über die Fehlerursache gibt.
Die Schreib-Sequenz wird durch Nullsetzen der Control-Bytes abgeschlossen:
Abschluss Schreibzugriff (SPS->KL6224): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 0000 0000bin | 0000 0000bin | x | x | x | x
x: Die Parameterwerte werden nicht ausgewertet wenn die Control-Bytes 0x00 sind.
Beispiel
Die Liste der projektierten Slaves (LPS) soll beschrieben werden. Der IO-Link Master soll gezielt mit den IO-Link Slaves mit den Knoten-Nummern 1, 2, 3, 4, 12, 16, 17 und 30 kommunizieren. Es soll also der Wert 0x4003101E (0100 0000 0000 0011 0001 0000 0001 1110bin) auf den Parameter 0xA8 (1010 1000bin) geschrieben werden.
Schreibzugriff (SPS->KL6224): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 0110 1000bin (0x68) | 0100 0010bin (0x42) | 0x1E | 0x10 | 0x03 | 0x40
Im Parameterdaten-Block zur KL6224 muss also die Bytefolge 0x68 42 1E 10 03 40 geschrieben werden.
Die Klemme antwortet mit folgenden Daten:
Antwort auf Schreibzugriff (KL6224->SPS): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status-Byte 0 | Status-Byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Wert | xxxx xxxxbin | 0101 xxx1bin | 0 | 0 | 0 | 0
Die Schreib-Sequenz wird mit dieser Bytefolge abgeschlossen: 0x00 00 00 00 00 00
Lesen eines Parameters
Um einen Parameter zu lesen ist folgende Sequenz einzuhalten:
Zunächst überprüfen, ob vorheriger Zugriff vollständig abgeschlossen wurde. Hierzu muss Status1 ausgewertet werden, Bits 4 bis 7 müssen 0 sein. Falls nicht, sind Control-Byte 0 und Control-Byte 1 auf 0 zu setzen bis die Bits 4 bis 7 im Status1 auf 0 gesetzt sind.
Lesezugriff (SPS->KL6224): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 00bin A5A4 A3A2A1A0 | 0100bin A9A8A7A6 | x | x | x | x
A0 bis A9: Bits der Parameteradresse
x: Die Parameterwerte werden nicht ausgewertet
Antwort auf Lesezugriff (KL6224->SPS): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status-Byte 0 | Status-Byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Wert | xxxx xxxxbin | 01F1 xxx0bin | P0...P7 | P8...P15 | P16...P23 | P24...P31
x: Bits können beliebige Werte annehmen
F: Fehler-Bit.
F=0bin: Lesezugriff war erfolgreich. Die Bytes 2 bis 5 enthalten den Parameterwert.
F=1bin: Lesezugriff war nicht erfolgreich. Die Bytes 2 bis 5 enthalten einen Error-Code, der Aufschluss über die Fehlerursache gibt.
P0 bis P31: Bits des Parameter-Werts oder Error-Codes
Die Lese-Sequenz wird durch Null-setzen der Control-Bytes abgeschlossen:
Abschluss Lesezugriff (SPS->KL6224): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 0000 0000bin | 0000 0000bin | x | x | x | x
x: Die Parameterwerte werden nicht ausgewertet wenn die Control-Bytes 0x00 sind.
Beispiel
Die Liste der erkannten Slaves (LES) soll ermittelt werden. Hierfür muss der Parameter 0xB0 (1011 0000bin) gelesen werden.
Lesezugriff (SPS->KL6224): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 0011 0000bin (0x30) | 0100 0010bin (0x42) | 0x00 | 0x00 | 0x00 | 0x00
Im Parameterdaten-Block zur KL6224 muss also die Bytefolge 0x30 42 00 00 00 00 geschrieben werden. Die Klemme antwortet mit folgenden Daten:
Antwort auf Schreibzugriff (KL6224->SPS): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status-Byte 0 | Status-Byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Wert | xxxx xxxxbin | 0101 xxx0bin | 0x4C | 0x02 | 0x80 | 0x83
Der IO-Link Master soll in diesem Beispiel die Slaves mit den Knoten-Nummern 2, 3, 6, 9, 23, 24, 25 und 31 erkannt haben. Er antwortet also mit den Parameterdaten 0x8380024C (1000 0011 1000 0000 0000 0010 0100 1100bin)
Die Lese-Sequenz wird mit der Bytefolge 0x00 00 00 00 00 00 abgeschlossen.


Firmware-Stand der Buskoppler

Zugriff aus dem Anwenderprogramm [image] Firmware-Stand der Buskoppler
Firmware-Stand der Buskoppler
Hinweis
Erforderliche Firmware
Zum Betrieb der IO-Link-Klemme KL6224 kann auf dem Buskoppler / Busklemmen Controller ein bestimmter Firmware-Stand erforderlich sein (siehe untenstehende Tabelle!)
Im Auslieferungszustand ist die KL6224 auf ein Prozessabbild von 24 Byte eingestellt.
Die meisten in der Tabelle aufgeführten Buskoppler und Busklemmen Controller unterstützen das Prozessabbild von 12 Byte.
Nicht aufgeführte Buskoppler / Busklemmen Controller sind noch nicht für den Betrieb des 24 Byte und oder größerer Prozessabbilder vorbereitet.
Der ausgelieferte Firmware-Stand ist auf der Rückseite des Buskopplers angegeben (siehe untenstehendes Beispiel für CANopen).
Angabe des Firmware-Standes auf einem Buskoppler
Bei Bedarf kann ein Firmware-Update über die serielle Schnittstelle (KS2000-Kabel erforderlich) oder - je nach Bussystem - auch über den Feldbus erfolgen. Die aktuellen Firmware-Stände und das Programm für das Firmware-Update finden Sie auf unserer Homepage http://www.beckhoff.de.
Unterstützung der verschiedenen Prozessabbilder durch die Firmware-Versionen der Buskoppler / Busklemmen Controller
Feldbus- System | Buskoppler / Busklemmen Controller | Auf dem Buskoppler / Busklemmen Controller erforderlicher Firmware-Stand zum Betrieb des
 |  | 12 Byte Prozessabbild | 24 Byte Prozessabbild | 36 Byte Prozessabbild | 48 Byte Prozessabbild
EtherCAT | BK1120 | Diese Buskoppler und Busklemmen Controller unterstützen das 12 Byte Prozessabbild der KL6204. | ab 08 (B8) | ab 08 (B8) | ab 08 (B8)
 | BK1250 |  | alle | alle | alle
Lightbus | BK2020 |  | ab B1 | in Vorbereitung | in Vorbereitung
PROFIBUS | BK3120 |  | ab B9 | ab BB | ab BB
 | BK3150 |  | alle | alle | alle
 | BK3500 |  | ab B9 | ab BB | -
 | BK3520 |  | ab B9 | ab BB | -
 | BC3100 |  | ab C3 | ab C4 | -
 | BC3150 |  | alle | alle | alle
 | BX3100 |  | alle | alle | alle
Interbus | BK4020 |  | ab B0 | in Vorbereitung | in Vorbereitung
 | BC4000 |  | ab B3 | in Vorbereitung | in Vorbereitung
CANopen | BK5120 |  | ab C4 | ab C5 | -
 | BK5150 |  | alle | alle | -
 | BC5150 |  | alle | alle | alle
 | BX5100 |  | alle | alle | alle
DeviceNet | BK5220 |  | (ab B3)* | in Vorbereitung | -
 | BC5250 |  | alle | alle | alle
 | BX5200 |  | alle | alle | alle
ControlNet | BK7000 |  | ab BC | ab BC | -
Modbus | BK7300 |  | ab B2 | ab B4 | -
Fip IO | BK7420 |  | ab B1 | ab B1 | -
RS485 | BK8000 |  | ab C2 | in Vorbereitung | in Vorbereitung
RS232 | BK8100 |  | ab C2 | in Vorbereitung | in Vorbereitung
 | BC8150 |  | alle | alle | alle
 | BX8000 |  | alle | alle | alle
Ethernet | BK9000 |  | ab B7 | ab BA | ab BA
 | BK9100 |  | ab B1 | ab B1 | ab B1
 | BC9000 |  | ab B9 | ab BB | ab BB
 | BC9100 |  | ab B1 | ab B1 | ab B1
 | BC9050 |  | alle | alle | alle
 | BX9000 |  | alle | alle | alle
PROFINET | BK9103 | in Vorbereitung | in Vorbereitung | in Vorbereitung | in Vorbereitung
EtherNet/IP | BK9105 | alle | alle | alle | alle
USB | BK9500 | Dieser Buskoppler unterstützt das 12 Byte Prozessabbild der KL6204. | (ab B1)* | in Vorbereitung | in Vorbereitung
*) Nur wenn der Buskoppler (z. B. mit der Konfigurationssoftware KS2000) auf komplettes Mapping der Busklemmen eingestellt wird. Im Auslieferungszustand sind diese Buskoppler auf kompaktes Mapping der Busklemmen eingestellt.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.