KL62x1, KL952x - AS-i Klemmen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0.0
▪
Migration
1.5.0
▪
Kapitel Tragschienenmontage aktualisiert
▪
Hinweise zum Firmware-Stand der Buskoppler aktualisiert
▪
Beschreibung der AS-i String-Parameter hinzugefügt (die AS-i String-Parameter werden ab Firmware-Version BA unterstützt)
▪
Beschreibung des AS-i Kommando-Interfaces aktualisiert
▪
Beschreibung der AS-i Einstellungen mittels KS2000 aktualisiert
▪
Montagehinweise aktualisiert
1.4
▪
Beschreibung der AS-i Masterklemme mit Powerkontakten KL6211 hinzugefügt
▪
Beschreibung der AS-i Potenzialeinspeiseklemme mit Filter KL9520 hinzugefügt
▪
Montagehinweise zu AS-i Masterklemmen hinzugefügt
▪
kleinere Routinekorrekturen (Tippfehler, Rechtschreibung usw.)
1.3
▪
Beschreibung der Quittung zur AS-i Kommandoschnittstelle (AS-i Parameter 0x100) erweitert
▪
Beschreibung des Prozessabbilds aktualisiert und 6 Byte Prozessabbild hinzugefügt
▪
Beschreibung des Betriebs der KL6201 unter PROFIBUS aktualisiert
▪
Beschreibung des Betriebs der KL6201 unter CANopen aktualisiert
▪
Hinweise zum Firmware-Stand der Buskoppler aktualisiert
1.2
▪
bis zu 62 AS-i Slaves werden nun direkt im Prozessabbild unterstützt
▪
analoge AS-i Slaves werden unterstützt
▪
Beschreibung der Parametrierung der KL6201 mit der KS2000-Software hinzugefügt
▪
Beschreibung der AS-i Parameter überarbeitet
▪
Beschreibung des Betriebs der KL6201 unter PROFIBUS überarbeitet
▪
Beschreibung des Betriebs der KL6201 unter CANopen überarbeitet
▪
Beschreibung der AS-i Netzteilklemme KL9528 hinzugefügt
1.1
▪
bis zu 62 AS-i Slaves werden unterstützt (32 direkt im Prozessabbild, weitere 32 über Parameterzugriff)
▪
ID-Code 1 und ID-Code 2 werden nun beim Aufstarten ausgelesen
▪
beim Kurzschließen der SET-Eingänge werden die ID-Codes 1 und 2 mit abgespeichert
1.0
▪
komplette Überarbeitung
▪
Beschreibung des Betriebs der KL6201 unter CANopen hinzugefügt
0.9
▪
erste Vorabversion: Beschreibung des Betriebs der KL6201 unter PROFIBUS
Firm- und Hardware-Stände
Dokumentation Version | KL6201 |  | KL6211
 | Firmware | Hardware | Firmware | Hardware
2.0.0 | D0 | 0I | D6 | 0J
1.5.0 | BA | 0D | BA | 0D
1.4 | B9 | 09 | B9 | 09
1.3 | B7 | 09 | - | -
1.2 | B4 | 09 | - | -
1.1 | B1-FE | 05 | - | -
1.0 | B0 | 04 | - | -
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 06 B9 09:
12 - Produktionswoche 12
06 - Produktionsjahr 2006
B9 - Firmware-Stand B9
09 - Hardware-Stand 09


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Funktionalität des AS-i Masters
•
Inbetriebnahmehinweise
•
KL9528: AS-i Netzteilklemme
•
KL9520: AS-i Potenzialeinspeiseklemme mit Filter


Einführung

Produktübersicht [image] Einführung
Einführung
KL6201, KL6211
Die AS-Interface Masterklemme ermöglicht den direkten Anschluss von AS-i Slaves. Die AS-i konforme Schnittstelle unterstützt digitale und analoge Slaves der Version 2.0 und 2.1. Der Prozessdatenaustausch, die Parametrierung und die Diagnose sind feldbusunabhängig. Die KL6201 stellt zusammen mit den verschiedenen von BECKHOFF erhältlichen Buskopplern ein universelles Feldbus/AS-i Gateway dar.
Die Größe des Prozessabbilds kann nach Bedarf auf 6 Byte, 12 Byte (Default), 22 Byte oder 38 Byte eingestellt werden.
Da das übliche Register-Interface (mit 64 Registern pro Klemme bzw. Kanal) nicht ausreicht, um sämtliche Informationen der AS-i Master-Klemme (Klemmenregister und AS-i Parameter) zu übertragen, wurde stattdessen ein Parameter-Interface definiert, auf das zyklisch (über das Prozessabbild) oder azyklisch (mit feldbusspezifischen azyklischen Diensten) zugegriffen werden kann.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | KL6201 | KL6211
AS-i Kanäle | 1
AS-i Versionen | Automatische Unterstützung von Version 2.0 und Version 2.1 (Master-Profil M3)
Anzahl der AS-i Slaves | Version 2.0: 31 Version 2.1: 62
AS-i Slave-Typen | digital und analog (Wandlung der Analogdaten in der KL6201)
Diagnosen | Spannungsausfall, Slave-Ausfall, Parametrierfehler
AS-i Adressvergabe | über Konfiguration oder automatisch
Zykluszeit | max. 5 ms (31 Teilnehmer), 10 ms (62 Teilnehmer)
Anschluss | 2 Stränge über Federkrafttechnik
Potenzialtrennung | 500 V (AS-Interface / K-Bus)
Stromaufnahme vom K-Bus | typisch 55 mA
Stromaufnahme vom AS-Interface | typisch 60 mA
Bitbreite im K-Bus | wählbar: 12 Byte, 22 Byte, 38 Byte, davon 6 Byte Parameter-Interface, Rest Prozessdaten-Interface
Konfiguration | über Feldbus Parameterinterface, DP-V1 oder Buskoppler durch Konfigurations-Software KS2000
Gewicht | ca. 55 g
zulässige Umgebungstemperatur, Betrieb | 0°C ... +55°C (siehe Kapitel Einbaulagen!) 0°C ... +55°C (ATEX) | 0°C ... +55°C (siehe Kapitel Einbaulagen!)
zulässige Umgebungstemperatur, Lagerung | -25°C ... +85°C
zulässige relative Feuchte | 95% ohne Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27 siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | optimale Einbaulage (siehe Kapitel Einbaulagen!)
Zulassung | CE, cULus, ATEX | CE, cULus


Funktionalität des AS-i Masters

Produktübersicht [image] Funktionalität des AS-i Masters
Funktionalität des AS-i Masters
Weiterführende Informationen
•
AS-i Statusmaschine
•
Listen
•
Betriebsmodi
•
Details der Betriebsphasen
•
Adressvergabe der AS-i Slaves
•
Automatische Projektierung


AS-i Statusmaschine

Produktübersicht [image] Funktionalität des AS-i Masters [image] AS-i Statusmaschine
AS-i Statusmaschine
Zunächst wird die Statusmaschine im Überblick beschrieben. Details zu den einzelnen Betriebsphasen finden sich weiter unten.
Überblick Statusmaschine
Initialisierung
Offline Phase: Während der Initialisierung findet kein AS-i Datenverkehr statt.
Aufstarten
Erkennungsphase
In dieser Phase sucht der AS-i Master zunächst nach vorhandenen Slaves - unabhängig, ob diese projektiert sind oder nicht. Diese Phase wird erst verlassen, wenn mindestens ein Slave gefunden wurde.
Aktivierungsphase
In dieser Phase werden die gefundenen Slaves in Abhängigkeit des Betriebsmodi aktiviert:
▪
protected mode: alle erkannten und projektierten Slaves werden aktiviert, falls E/A-Kennung und ID-Code der erkannten Slaves mit den projektierten Daten übereinstimmt.
▪
configuration mode: alle erkannten Slaves werden vom Master aktiviert.
Normalbetrieb
Datenaustauschphase
Der AS-i Master befindet sich im zyklischen Datenaustausch mit den aktivierten Slaves.
Managementphase
Am Ende eines Zyklus geht der AS-i Master in die Managementphase, in der der Master ein Kommando zu einem spezifischen Slave schicken kann (falls gewünscht).
Aufnahmephase
Danach geht der AS-i Master in die Aufnahmephase, in der er ein Kommando an eine freie Slave-Adresse schickt um neue Slaves zu erkennen. Falls keine Antwort kommt, startet der Master unverzüglich mit der nächsten Datenaustauschphase.


Listen

Produktübersicht [image] Funktionalität des AS-i Masters [image] Listen
Listen
Listen der AS-i Slaves im configuration und protected mode
LES - Liste der erkannten Slaves
Hier sind alle Slaves aufgeführt, die physikalisch am Netz vorhanden sind, eine gültige Adresse aufweisen und vom Master erkannt wurden.
LPS - Liste der projektierten Slaves
Diese Liste umfasst alle Slaves, die der Master am Netz erwartet. Im Protected Mode kommuniziert der Master nur mit diesen Slaves und gibt eine Meldung aus, wenn zusätzliche Slaves erkannt werden oder wenn Slaves aus dieser Liste fehlen.
LAS - Liste der aktivierten Slaves
Alle Slaves, mit denen der Master kommuniziert. Im Protected Mode entspricht diese Liste der LPS, im Configuration Mode entspricht diese Liste der LES.


Betriebsmodi

Produktübersicht [image] Funktionalität des AS-i Masters [image] Betriebsmodi
Betriebsmodi
Geschützter Modus (Protected Mode)
Im geschützten Modus werden nur die AS-i Slaves aktiviert, die in der LPS eingetragen sind. Außerdem muss deren Konfiguration (E/A-Kennung und ID-Codes) mit der projektierten Konfiguration aus den Parametern
- 0x40 bis 0x47 (projektierte E/A-Kennungen) bzw.
- 0x48 bis 0x4F (projektierte ID-Codes)
- 0xE0 bis 0xE7 (projektierte Extended ID-Codes 1) und
- 0xE8 bis 0xEF (projektierte Extended ID-Codes 2) übereinstimmen,
falls die Überprüfung der EA-Kennung bzw. ID-Codes in den Parametern 0x60 bis 0x61 bzw. 0x68 bis 0x69, 0x70 bis 0x71 und 0x78 bis 0x79 freigeschaltet ist.
Die automatische Adressierung ist möglich, wenn bei allen in der LPS eingetragenen AS-i Slaves auch die Überprüfung von E/A-Kennung sowie ID-Code freigeschaltet ist und genau ein projektierter AS-i Slave fehlt.
Konfigurationsmodus (Configuration Mode)
Im Konfigurationsmodus werden alle AS-i Slaves aktiviert, die gefunden werden. Die automatische Adressierung ist möglich, dabei wird einem gefundenen Slave mit der Adresse 0 die nächste freie Adresse zugeordnet. Eine AS-i Adresse kann aber über den Parameter 0x100 (AS-i Kommando-Schnittstelle) manuell eingestellt werden. Durch Setzen des Set-Eingangs oder über den Parameter 0x108 (allgemeine Kommandoschnittstelle) könne alle gefundenen AS-i Slaves projektiert werden. In diesem Fall werden auch
▪
die entsprechenden E/A-Kennungen und ID-Codes in die Parameter 0x40 bis 0x47 (Projektierte E/A-Kennungen) bzw. 0x48 bis 0x4F, 0xE0 bis 0xE7 und 0xE8 bis 0xEF (projektierte ID-Codes) eingetragen und
▪
die Überprüfung in den Parametern 0x60 bis 0x61 (E/A-Kennungen) bzw. 0x68 bis 0x69, 0x70 bis 0x71 und 0x78 bis 0x79 (ID-Codes) freigeschaltet.


Details der Betriebsphasen

Produktübersicht [image] Funktionalität des AS-i Masters [image] Details der Betriebsphasen
Details der Betriebsphasen
Offline
Nach Power-On geht der AS-i Master in den Offline-Zustand, d.h. mit den AS-i Slaves wird noch keine Kommunikation durchgeführt.
Über die Prozessdaten kann der AS-i Master im Normalbetrieb dazu veranlasst werden, in den Offline-Zustand zu gehen (OFFLINE-Flag ist gesetzt). Dabei werden die Output-Daten aller aktivierten AS-i Slaves auf den Defaultwert 1bin und die Input-Daten aller aktivierten AS-i Slaves auf den Defaultwert 0bin gesetzt. Danach ist der AS-i Master im Zustand Offline und sendet keine weiteren AS-i Kommandos.
Sobald das OFFLINE-Flag nicht mehr gesetzt ist, kopiert der AS-i Master die neue Liste der projektierten Slaves aus dem Parameter 0x58 bis 0x59 in den Parameter 0xA8 bis 0xA9 (LPS) und geht automatisch in die Erkennungsphase über. Wenn ein AS-i Slave in der Liste der projektierten Slaves (LPS) aktiviert ist, arbeitet der AS-i Master im Protected Mode (PRJ_ACTIVE-Flag wird in den Prozessdaten gesetzt), andernfalls im Configuration Mode (PRJ_ACTIVE-Flag wird in den Prozessdaten zurückgesetzt).
Start-Up
Erkennungsphase
In der Erkennungsphase werden E/A-Kennung und ID-Codes von allen AS-i Slaves abgefragt und in die Parameter
- 0x90 bis 0x97 (Gelesene E/A-Kennungen) bzw.
- 0x98 bis 0x9F (Gelesener ID-Codes),
- 0xD0 bis 0xD7 (Gelesene Extended ID-Codes 1) und
- 0xD8 bis 0xDF (Gelesene Extended ID-Codes 2) eingetragen.
Alle gefunden AS-i Slaves werden in die Liste der erkannten AS-i Slaves (LES, Parameter 0xB0 bis 0xB1) eingetragen. Der AS-i Master geht erst in die Aktivierungsphase über wenn er mindestens einen Slave erkannt bzw. gefunden hat.
Aktivierungsphase
Im Protected Mode aktiviert der AS-i Master nur die projektierten AS-i Slaves aus der Liste der projektierten Slaves (LPS, Parameter 0xA8 bis 0xA9).
Im Configuration Mode werden alle in der Erkennungsphase gefundenen AS-i Slaves aktiviert. Dazu sendet der AS-i Master ein Parametrieraufruf (Aktivierungs-Parameter, Parametern 0x50 bis 0x57) und ein Datenaufruf (mit den Defaultwerten 1bin als Outputs). Alle aktivierten Slaves werden in die Liste der aktivierten Slaves (LAS, Parameter 0xB8 bis 0xB9) eingetragen. Wenn alle AS-i Slaves durchlaufen sind, geht der AS-i Master automatisch in die Datenaustauschphase über.
Normalbetrieb
Datenaustauschphase
In der Datenaustauschphase führt der AS-i Master mit jedem aktivierten AS-i Slave Datenaustausch durch. Wenn ein AS-i Slave in drei aufeinander folgenden Datenaustauschphasen nicht antwortet, wird er aus der LAS und der LES ausgetragen und seine Inputs auf den Defaultwert 0bin gesetzt. Wenn mit allen aktivierten AS-i Slaves ein Datenzyklus durchgeführt wurde, geht der AS-i Master in die Managementphase über.
Managementphase
In der Managementphase wird ein AS-i Kommando gesendet, falls mit der automatischen Adressprogrammierung eine Betriebsadresse zu setzen ist oder über die AS-i Kommando-Schnittstelle (Parameter 0x100) ein AS-i Kommando angefordert wurde. Ansonsten geht der AS-i Master in die Aufnahmephase über, ohne ein AS-i Kommando zu senden.
Aufnahmephase
In der Aufnahmephase wird immer nur genau ein Kommando gesendet. Dabei wird versucht, neue AS-i Slaves zu finden und zu aktivieren, der jeweilige Status wird entsprechend aktualisiert. Die Schritte sind dabei die gleichen wie in der Erkennungs- bzw. Aktivierungsphase, nur dass die Schritte jetzt auf bis zu sieben Zyklen verteilt werden.


Adressvergabe der AS-i Slaves

Produktübersicht [image] Funktionalität des AS-i Masters [image] Adressvergabe der AS-i Slaves
Adressvergabe der AS-i Slaves
Die Adressvergabe kann durch den AS-i Master oder durch ein Adressiergerät erfolgen. AS-i Slaves werden in der Regel mit Adresse 0 ausgeliefert. Neu hinzugefügte Slaves werden unter dieser Adresse gesucht, anschließend wird eine Adresse zugeteilt. Die Adresse 0 ist in der Datenaustauschphase nicht zulässig.
Slaves der AS-i Spezifikation 2.1 können auch Adressen von 33 bis 63 bekommen (die AS-i Slave-Adresse 32 ist nicht erlaubt).
Normale Adressvergabe
Neue AS-i Slaves haben in der Regel die Adresse 0. Über den Parameter 0x100 (AS-i Kommandoschnittstelle) kann ein Adressieraufruf-Kommando angestoßen werden. Das Adressieraufruf-Kommando funktioniert aber nur, wenn genau ein AS-i Slave mit der Adresse 0 am Bus angeschlossen ist.
Automatische Adressvergabe
Die automatische Adressvergabe muss mit Bit 6.1, der Ausgangsdaten freigeschaltet werden.
Configuration Mode
Im Configuration Mode bekommt ein gefundener Slave mit Adresse 0 automatisch die nächste freie Adresse.
Protected Mode
Im Protected Mode wird ein AS-i Slave mit der Adresse 0 automatisch mit seiner neuen Adresse programmiert, falls genau ein projektierter AS-i Slave fehlt, und kein anderer nicht projektierter AS-i Slave am Bus ist. Damit kann während des Betriebs ein AS-i Slave (der nicht mehr funktioniert), ausgetauscht werden.


Automatische Projektierung

Produktübersicht [image] Funktionalität des AS-i Masters [image] Automatische Projektierung
Automatische Projektierung
Über den SET- oder über den Parameter 0x108 (Allgemeine Kommandoschnittstelle) können die aktuell erkannten Slaves (aus der LES) automatisch projektiert werden.


Inbetriebnahmehinweise

Produktübersicht [image] Inbetriebnahmehinweise
Inbetriebnahmehinweise
Um schnell ein AS-i Netz mit der AS-i Master-Klemme KL6201/KL6211 in Betrieb zu nehmen sind lediglich die folgenden Schritte durchzuführen:
1.
Adressieren Sie die AS-i Slaves.
2.
Schließen Sie die AS-i Slaves an die KL6201/KL6211 an.
3.
Im Auslieferungszustand ist die KL6201/KL6211 auf das 12 Byte Prozessabbild eingestellt, das direkten Zugriff auf die Prozessdaten der AS-i Slaves 1 bis 11 unterstützt. Wenn Sie direkt auf weitere AS-i Adressen zugreifen möchten, müssen Sie ein größeres Prozessabbild verwenden.
4.
Hinweis
Freigabe der Prozessdaten-Kommunikation
Setzen Sie zur Freigabe der Prozessdaten-Kommunikation im AS-i Comand-Nibble (ASI CN in Byte 6) das Bit 3 auf 1bin.
Beispiel für das 12 Byte Prozessabbild:
Parameterdatenblock |  |  |  |  |  | Prozessdatenblock
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
CB0 | CB1 | ParaOut 0 | ParaOut1 | ParaOut2 | ParaOut3 | ASI CN + ASI Out Slave 1 | ASI Out Slave 2+3 | ASI Out Slave 4+5 | ASI Out Slave 6+7 | ASI Out Slave 8+9 | ASI Out Slave 10+11
0x00 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00 | 0x8p | 0xpp | 0xpp | 0xpp | 0xpp | 0xpp
Legende
ASI CN: AS-i Command-Nibble
p: Prozessdaten-Nibbles (Ausgänge) für die jeweiligen AS-i Slaves
CB n: Control-Byte n
Para Out n: Ausgangsparameter, Byte n
5. Die KL6201/KL6211 antwortet dann nach Ausführung des AS-i Zyklus mit den Eingangsdaten (je nach übergeordnetem Feldbus-System um ein oder mehrere Zyklen verzögert).
Hinweis
Kurzschließen der beiden Set-Eingänge zum Betrieb nicht notwendig
Das Kurzschließen der beiden Set-Eingänge ist zum Betrieb nicht notwendig. In der Inbetriebnahme-Phase ist dies auch eher hinderlich, da die KL6201/KL6211 dann nur diejenigen AS-i Slaves in den Datenaustausch aufnimmt, die sie beim Kurzschließen der Set-Eingänge gefunden hat.


KL9528: AS-i Netzteilklemme

Produktübersicht [image] KL9528: AS-i Netzteilklemme
KL9528: AS-i Netzteilklemme
KL9528
Die Netzteilklemme KL9528 erzeugt aus der Steuerspannung 24 VDC eine 30 VDC Ausgangsspannung für den Betrieb eines AS-i Netzwerkes. Die Ausgangsspannung ist hochfrequenzentkoppelt, kurzschlussfest und auf einen Strom von 1,3 A begrenzt. Es besteht keine galvanische Trennung zwischen der Eingangsspannung und der Ausgangsspannung.
Die Verbindung zur AS-i Masterklemme KL6211 wird beim Nebeneinanderstecken durch die Powerkontakte hergestellt.
Die AS-i Masterklemme KL6201 muss über Kabelbrücken angeschlossen werden.
LED-Anzeigen
LED | Bedeutung
AS-i Power (grün) | aus | Die AS-i Spannung ist abgeschaltet.
 | an | Die AS-i Spannung ist eingeschaltet.
Error (rot) | aus | KL9528 O.K.
 | an | Es ist ein Fehler (z.B. Unterspannung, Überlast) aufgetreten.
Technische Daten
Technische Daten |  | KL9528
Kurzschlussfestigkeit |  | ja, Wiederanlauf nach Freigabe über positive Flanke des Ausgangsbits 0
Eingangsspannung |  | 21 bis 28,8 VDC
Ausgangsspannung |  | 30 VDC (±5%)
Ausgangsstrom |  | max. 1,25 A
Kurzschluss-Strombegrenzung |  | max. 1,3 A
Wirkungsgrad |  | ca. 95% (bei Nennlast)
Bitbreite im Prozessabbild |  | 2 Eingangsbits, 2 Ausgangsbits (siehe Prozessabbild der KL9528)
Stromaufnahme vom K-Bus |  | typisch 10 mA
Stromaufnahme AS-Interface |  | ca. 60 mA
Isolations–spannung | Eingangs- / Ausgangsspannung | keine
 | AS i / K-Bus | 1500 VAC (dauerhaft)
Gewicht |  | ca. 150 g
zulässige Umgebungstemperatur im Betrieb |  | 0°C... +55°C
zulässige Umgebungstemperatur bei Lagerung |  | -25°C ... +85°C
zulässige relative Feuchte |  | 95%, keine Betauung
Montage |  | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit |  | gemäß EN 60068-2-6 / EN 60068-2-27 siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung |  | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart |  | IP20
Einbaulage |  | beliebig
Zulassung |  | CE
Hinweis
Mapping der KL6201 und KL9528
Beachten Sie bei der Adressierung (Mapping) der KL6201 und KL9528 folgendes:
- Die AS-i Masterklemme KL6201 ist eine Byte-orientierter Klemme!
- Die AS-i Netzteilklemme KL9528 ist eine Byte-orientierte Klemme!
Das Mapping von Busklemmen erfolgt im Buskoppler grundsätzlich in folgender Reihenfolge:
- Zuerst erscheinen im Prozessabbild alle Byte-orientierten Busklemmen, in der Reihenfolge wie diese gesteckt sind.
- Danach erscheinen im Prozessabbild alle Bit-orientierten Busklemmen, in der Reihenfolge wie diese gesteckt sind.
Dies bedeutet, dass KL6201 und KL9528, wenn sie nebeneinander gesteckt sind, nicht zwangsläufig auch im Prozessabbild aufeinander folgen müssen!
Prozessabbild der KL9528
Eingangsdaten
Bit | Wert | Name | Bedeutung
1 und 0 | 00bin | O.K. | kein Fehler
 | 01bin | Überlast | Die KL9528 hat Aufgrund einer Überlastung die AS-i Spannung abgeschaltet. Sie kann mit einer positiven Flanke des Ausgangsbits 0 wieder eingeschaltet werden. Falls die Überlast weiterhin besteht, wird die KL9528 wieder abschalten.
 | 10bin | reserviert | -
 | 11bin | Unter- spannung | Die KL9528 hat die AS-i Spannung abgeschaltet, weil die Eingangsspannung unter 21 V gefallen war. Sobald die Eingangsspannung wieder höher als 21 V ist, schaltet die KL9528 die AS-i Spannung automatisch wieder ein.
Ausgangsdaten
Bit | Bedeutung
0 | Nach Abschalten wegen Überlast, schaltet eine positive Flanke dieses Bits die AS-i Spannung wieder ein.
1 | reserviert


KL9520: AS-i Potenzialeinspeiseklemme mit Filter

Produktübersicht [image] KL9520: AS-i Potenzialeinspeiseklemme mit Filter
KL9520: AS-i Potenzialeinspeiseklemme mit Filter
KL9520
Die KL9520 ermöglicht die Versorgung von AS-i Netzwerken aus Standardnetzteilen oder einem anderen AS interface-Netzwerk. Die Kombination von KL9520 und AS-i Masterklemme ist in einem Busklemmenblock mehrfach möglich und spart so mehrere AS-i Netzteile ein.
Die Potenzialeinspeiseklemme KL9520 entkoppelt Ein- und Ausgangsspannung durch einen integrierten Filter. Es besteht kein Kurzschlussschutz und keine galvanische Trennung zwischen der Eingangsspannung und der Ausgangsspannung!
Die Verbindung zur AS-i Masterklemme KL6211 wird beim Nebeneinanderstecken durch die Powerkontakte hergestellt.
Eine AS-i Masterklemme KL6201 muss über Kabelbrücken angeschlossen werden.
LEDs
LED | Bedeutung
Power (grün) | aus | AS-i Spannung ist abgeschaltet.
 | an | AS-i Spannung ist eingeschaltet.
Technische Daten
Technische Daten |  | KL9520
Eingangsspannung |  | bis 35 VDC
Ausgangsspannung |  | bis 35 VDC
Eingangsstrom |  | max. 2 A
Ausgangsstrom |  | max. 2 A (nicht kurzschlussfest)
Stromaufnahme vom K-Bus |  | 0 mA
Isolations- spannung | AS-i / K-Bus | 1500 VAC (Dauerbelastung)
 | Eingangs- / Ausgangsspannung | keine
Konfiguration |  | keine Adress- oder Konfigurationseinstellung erforderlich
Bitbreite im Prozessabbild |  | 0 Eingangsbits, 0 Ausgangsbits
Gewicht |  | ca. 90 g
zulässige Umgebungstemperatur im Betrieb |  | 0°C ... +55°C
zulässige Umgebungstemperatur bei Lagerung |  | -25°C ... +85°C
zulässige relative Feuchte |  | 95%, keine Betauung
Vibrations- / Schockfestigkeit |  | gemäß EN 60068-2-6 / EN 60068-2-27 siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung |  | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart |  | IP20
Einbaulage |  | beliebig
Zulassung |  | CE


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Einbaulagen
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
AS-i Installation
•
Anschlusstechnik
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX-Dokumentation


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Achtung
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


AS-i Installation

Montage und Verdrahtung [image] AS-i Installation
AS-i Installation
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschluss des AS-interfaces
Anschluss des AS-interface
Klemme | Verwendung
Mode 1, Mode 2 | Für zukünftige Funktionserweiterungen reserviert.
ASi+ | Anschluss ASi+ (braun). Beide mit ASi+ bezeichneten Klemmstellen sind intern verbunden.
ASi- | Anschluss ASi- (blau). Beide mit ASi- bezeichneten Klemmstellen sind intern verbunden.
Set 1, Set 2 | Durch Kurzschließen der beiden Set-Eingänge können die erkannten Slaves aus der Liste der erkannten Slaves (LES) für den Protected Mode projektiert werden. Dies Entspricht der Funktionalität von Parameter 0x108 (Kommando-Interface), wenn dort der Wert 0x0210 eingetragen wird.
Verdrahtung des AS-interface
Verdrahtung des AS-interface
Da die Nutzdaten bei AS-interface auf die Stromversorgungsleitung aufmoduliert werden, wird ein spezielles AS-i Netzteil (30,5 VDC) benötigt. Sie können
▪
die AS-i Netzteilklemme KL9528 mit integrierter Datenentkopplung oder
▪
die AS-i Potenzialeinspeiseklemme KL9520 in Verbindung mit einem Standardnetzteil verwenden.


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Hinweis
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Hinweis
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Hinweis
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweis
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Konfiguration der KL6201/KL6211
•
Register
•
KS2000 - Einstellungen
•
KS2000 - AS-i Einstellungen
•
KS2000 - AS-i Systemübersicht
•
KS2000 - AS-i Slave Parameter
•
Prozessdaten


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Konfiguration der KL6201/KL6211

Konfigurations-Software KS2000 [image] Konfiguration der KL6201/KL6211
Konfiguration der KL6201/KL6211
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Ethernet-Koppler BK9000
▪
eine AS-i Netzteilklemme KL9528 (doppelte Baubreite)
▪
eine AS-i Masterklemme KL6201
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 1).
KS2000-Baumzweige für Kanal 1 der KL6201
Für die KL6201/KL6211 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL6201/KL6211.
▪
Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL6201/KL6211.
▪
ProcData zeigt die Prozessdaten der KL6201/KL6211.


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register der KL6201/KL6211 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Register-Ansicht in KS2000
Der Screenshot zeigt die Register der KL6201.


KS2000 - Einstellungen

Konfigurations-Software KS2000 [image] KS2000 - Einstellungen
KS2000 - Einstellungen
Unter Einstellungen finden Sie die Dialogmasken zur Parametrierung der KL6201/KL6211 und der daran angeschlossenen AS-i Slaves.
Einstellungen der KL6201 in der Konfigurations-Software KS2000
Einstellungen
Unter diesem Karteireiter können Sie die Einstellungen der KL6201/KL6211 und der angeschlossenen AS-i Slaves verändern.
Systemübersicht
Unter diesem Karteireiter können Sie den Projektierungszustand der angeschlossenen AS-i Slaves überprüfen.
Slave Parameter
Unter diesem Karteireiter können Sie Parameter der angeschlossenen AS-i Slaves verändern.


KS2000 - AS-i Einstellungen

Konfigurations-Software KS2000 [image] KS2000 - AS-i Einstellungen
KS2000 - AS-i Einstellungen
Auf diesem Karteireiter können Sie die Einstellungen der KL6201/KL6211 und der angeschlossenen AS-i Slaves verändern.
KS2000 - AS-i Einstellungen
Prozessabbild
Wählen Sie hier die Größe des Prozessabbilds der KL6201/KL6211 aus. Sie wird im Register R27 der KL6201/KL6211 gespeichert.
▪
6 Byte AS-i Parameter Interface = 6 Byte Prozessabbild:
kein direkter Zugriff auf die Prozessdaten der AS-i Slaves! Der Prozessdatenzugriff muss über die AS-i Parameter 0x80 bis 0x87 (digitale Slaves) oder 0x204 bis 0x27F (analoge Slaves) erfolgen.
▪
6 Byte AS-i Parameter Interface + 6 Byte AS-i Prozessdaten (11 Slaves) = 12 Byte Prozessabbild:
unterstützt direkten Zugriff auf die Prozessdaten der AS-i Slaves 1 bis 11 (default).
▪
6 Byte AS-i Parameter Interface + 16 Byte AS-i Prozessdaten (32 Slaves) = 22 Byte Prozessabbild:
unterstützt direkten Zugriff auf die Prozessdaten der AS-i Slaves 1 bis 21.
▪
6 Byte AS-i Parameter Interface + 32 Byte AS-i Prozessdaten (64 Slaves) = 38 Byte Prozessabbild:
unterstützt direkten Zugriff auf die Prozessdaten der AS-i Slaves 1 bis 31 und 33 (1B) bis 63 (31B)
Nach Änderung des Prozessabbilds müssen Sie den Buskoppler neu starten, damit er das geänderte Prozessabbild übernimmt.
Informieren Sie sich im Kapitel Firmware-Stand der Buskoppler ob ihr Buskoppler/Busklemmen-Controller das gewünschte KL6201/KL6211-Prozessabbild unterstützt.
Offline Phase
Mit dieser Check-Box können Sie die KL6201/KL6211 in die in die Offline-Phase schalten. Die Schaltung wird mit Bit 2 des AS-i Command Nibbles übertragen.
Aktionen
erkannte Slaves projektieren:
Beim Drücken dieser Schaltfläche projektiert die KL6201/KL6211 alle erkannten AS-i Slaves neu.
Herstellereinstellungen setzen:
Durch Drücken dieser Schaltfläche setzen Sie die KL6201/KL6211 in den Auslieferungszustand zurück. Dabei werden die zuvor vorhandenen Projektierungen gelöscht.
Slave-Adressen
Automatische Adressierung aktiviert
Mit dieser Check-Box können Sie die automatische Adressierung aktivieren. Die Freigabe wird mit Bit 1 des AS-i Command Nibbles übertragen.
Adresse ändern
Hier können Sie die Adressen der AS-i Slaves ändern. Geben Sie dazu in das linke Feld die alte Adresse, in das rechte Feld die neue Adresse des AS-i Slaves ein, dessen Adresse Sie ändern möchten und drücken Sie auf Adresse ändern. Die Änderung der Adresse können Sie mit dem Karteireiter Systemübersicht überprüfen.
AS-i Slaves deren Adresse sie geändert haben müssen danach neu projektiert werden (siehe Aktionen: Schaltfläche erkannte Slaves projektieren).
Hinweis
AS-i Slaves
Die AS-i Slaves 1 bis 31 werden auch mit 1A bis 31A bezeichnet (A-Adressen).
Die AS-i Slave-Adresse 32 ist nicht zulässig.
Die AS-i Slaves 33 bis 63 werden auch mit 1B bis 31B bezeichnet (B-Adressen).
Die AS-i Slaves 33 bis 63 (B-Adressen) werden nur von digitalen AS-i Slaves unterstützt (A/B-Slaves). Analoge AS-i Slaves z. B. unterstützen die B-Adressen nicht!
Die KS2000 Software benutzt zur Adressierung die AS-i Kommandoschnittstelle (AS-i Parameter 0x100).
Ergebnis
▪
Bei erfolgreicher Adressänderung wird O.K. angezeigt.
▪
Falls die Adresse nicht geändert werden konnte, wird ein Fehler-Code angezeigt.
Code | Bedeutung
O.K. (0x00) | Die Adressänderung wurde erfolgreich durchgeführt.
0x11 | Es ist kein Slave mit der im linken Feld (alte Adresse) eingegebenen Adresse vorhanden.
0x22 | Die Adresse 0 wird zurzeit von einem anderen Slave belegt. Zum Ändern der Adresse eines AS-i Slaves, muss die KL6201/KL6211 diesem zuerst die Adresse 0 zuweisen, um ihn danach von dort aus neu zu Adressieren.
0x36 | Es ist bereits ein Slave mit der im rechten Feld angegebenen Adresse (neue Adresse) vorhanden.
0x47 | Nach dem Löschen der alten Adresse ist kein Slave mit der Adresse 0 vorhanden.
0x58 | Nach dem Löschen der alten Adresse kommt beim Lesen des Extended ID-Code 1 von Slave 0 ein Fehler. Bei A/B-Slaves wird zur Adressänderung auch der Extended ID-Code 1 benötigt.
0x69 | Nach dem Schreiben des Extended ID-Code 1 ist kein Slave mit Adresse 0 vorhanden.
0x6B | Nach dem Schreiben der neuen Adresse ist der Slave mit der neuen Adresse beim Lesen des ID-Codes nicht vorhanden.
0x6C | Nach dem Schreiben der neuen Adresse ist der Slave mit der neuen Adresse beim Lesen des Status nicht vorhanden.
0x7D | Die Adresse konnte nicht dauerhaft (non-volantile) gespeichert werden.
0x7E | Der Extended ID-Code eines A/B-Slaves konnte nicht dauerhaft (non-volantile) gespeichert werden.
0x7F | ID-Code 1 ist falsch bei A/B-Slaves
0x83 | Die neue Adresse ist eine B-Adresse. Wenn Sie im Adressbereich A und Adressbereich B auf zwei parallelen Adressen (z. B. 10A (10) und 10B (42)) Slaves betreiben wollen, müssen beide Slaves die B-Adressierung unterstützen. In diesem Fall, ist auf der parallelen A-Adresse bereits ein Slave vorhanden, der die B-Adressierung nicht unterstützt!
0x84 | Die neue Adresse ist eine B-Adresse. Der mit der alten Adresse ausgewählte Slave ist aber kein A/B-Slave, d.h. er unterstützt die B-Adressen (33 bis 63) nicht.
0x85 | Die neue Adresse ist eine A-Adresse. Slave ist kein A/B-Slave: zugehöriger B-Slave für neue Adresse ist vorhanden.


KS2000 - AS-i Systemübersicht

Konfigurations-Software KS2000 [image] KS2000 - AS-i Systemübersicht
KS2000 - AS-i Systemübersicht
Auf diesem Karteireiter können Sie den Projektierungszustand der angeschlossenen AS-i Slaves überprüfen.
KS2000 - AS-i Systemübersicht
Der aktuelle Projektierungszustand entspricht der angezeigten Farbe.
Hinweis
AS-i Slaves
Die AS-i Slaves 1 bis 31 werden auch mit 1A bis 31A bezeichnet.
Die AS-i Slave-Adresse 32 ist nicht zulässig.
Die AS-i Slaves 33 bis 63 werden auch mit 1B bis 31B bezeichnet.


KS2000 - AS-i Slave Parameter

Konfigurations-Software KS2000 [image] KS2000 - AS-i Slave Parameter
KS2000 - AS-i Slave Parameter
Dieser Karteireiter zeigt Informationen zur angeschlossenen AS-i Konfiguration an.
KS2000 - AS-i Slave Parameter
aktuelle Konfiguration
Hier können Sie Parameter der angeschlossenen AS-i Slaves überprüfen.
Parameter
Wählen Sie im Auswahlfeld den gewünschten Parameter aus. Er wird dann für alle AS-i Slaves im Feld aktuelle Konfiguration angezeigt.
E/A-Code
Zeigt die gelesene E/A-Kennungen der AS-i Slaves (Parameter 0x90 bis 0x97) an.
ID-Code
Zeigt die gelesenen Standard-ID-Codes der AS-i Slaves (Parameter 0x48 bis 0x4F) an.
Parameter
Zeigt die Aktivierungs-Parameter der AS-i Slaves (Parameter 0x50 bis 0x57) an.
Status
Zeigt die gelesenen Stati der AS-i Slaves (Parameter 0xA0 bis 0xA7) an.
Timeout
Zeigt die TimeOut-Zähler der AS-i Slaves (Parameter 0x160 bis 0x17F) an.
LeaveDataExch
Zeigt die LeaveDataExch-Zähler der AS-i Slaves (Parameter 0x1A0 bis 0x1BF) an.
Physical Fault
Zeigt die PhysicalFault-Zähler der AS-i Slaves (Parameter 0x140 bis 0x15F) an.
Repeat 1 bis Repeat 5
Zeigen jeweils einen der 5 Repeat-Counter der AS-i Slaves (Parameter 0x340 bis 0x35F) an.
Info
Hier werden weitere Informationen zur angeschlossenen AS-i Konfiguration angezeigt.
Software
Zeigt die Firmware-Version der KL6201/KL6211 an.
Zykluszeit
Zeigt die Zykluszeit des AS-i Busses an:
▪
aktuell: aktuelle AS-i Zykluszeit
▪
max.: maximale Zykluszeit, die bisher aufgetreten ist
Timeouts/Zyklus
Zeigt die Timeouts auf dem AS-i Bus an:
▪
max.: maximale Anzahl von Timeouts, die bisher während eines Zyklus aufgetreten sind
▪
1/Sek.: Timeouts in Bezug auf die Anzahl der AS-i Telegramme


Prozessdaten

Konfigurations-Software KS2000 [image] Prozessdaten
Prozessdaten
Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.
KS2000 - Prozessdaten
Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.
KS2000 - Grafischer Verlauf eines Prozessdatums
Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.
KS2000 - aktueller Wert eines Prozessdatums
Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.
KS2000 - Ausgangswerte
VORSICHT
Gefahr für Personen, Umwelt oder Geräte!
Beachten Sie, das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann. Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, das Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.
KS2000 - Auswahl der Darstellungsform eines Prozessdatums


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation
•
Registerpages
•
AS-i Parameter - Übersicht
•
AS-i Parameter - Beschreibung
•
Zugriff auf AS-i Parameter
•
Mapping analoger AS-i Slaves


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Das Prozessabbild der AS-i Master-Klemme besteht aus einem 6 Byte großen Parameterdatenblock und einem 0, 6, 16 oder 30 Byte großen Prozessdatenblock. Es ergibt sich somit ein 6, 12, 22 oder 38 Byte großes Prozessabbild. Die Größe des Prozessabbilds kann mit der Konfigurations-Software KS2000 oder feldbusspezifisch über den Buskoppler eingestellt werden.
Bei Verwendung der KL6201/KL6211 unter Buskopplern bzw. Busklemmen Controllern für PROFIBUS und CANopen sind einige Besonderheiten zu beachten, die in den Kapiteln KL6201/KL6211 anPROFIBUS-Kopplern und KL6201/KL6211 an CANopen-Kopplern erläutert sind.
Beschreibung der Prozessabbilder
Hinweis
Dummy-Nibbles
Nicht benutzte AS-i Slave-Adressen werden ausgangsseitig im Prozessabbild als Dummy-Nibble aufgefasst und nicht ausgewertet. In den Eingangsdaten sind die entsprechenden Stellen genullt.
6 Byte Prozessabbild
Das 6 Byte Prozessabbild besteht nur aus dem Parameterdatenblock. Es unterstützt im Gegensatz zu den anderen Prozessabbildern keinen direkten Zugriff auf die Prozessdaten der AS-i Slaves! Der Prozessdatenzugriff muss über die AS-i Parameter 0x80 bis 0x87 (digitale Slaves) oder 0x204 bis 0x27F (analoge Slaves) erfolgen.
Eingangsdaten (KL6201/KL6211 -> SPS)
Parameterdatenblock (6 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Ausgangsdaten (SPS -> KL6201/KL6211)
Parameterdatenblock (6 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Legende
Siehe 12 Byte Prozessabbild.
12 Byte Prozessabbild
Falls nur AS-i Slave-Adressen kleiner 12 verwendet werden, so genügt das 12 Byte große Prozessabbild. Diese Auswahl spart sowohl auf dem Feldbus als auch auf dem K-Bus Bandbreite. Da die 12 Byte zur AS-i Klemme in einem K-Bus Zyklus übertragen werden können, ist mit dieser Auswahl auch die Update-Rate der anderen Klemmen optimal schnell. Diese Einstellung ist im Auslieferungszustand der KL6201/KL6211 aktiviert.
Eingangsdaten (KL6201/KL6211 -> SPS)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (6 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3 | ASiSN + ASiIn Slave 1 | ASiIn Slave 2+3 | ASiIn Slave 4+5 | ASiIn Slave 6+7 | ASiIn Slave 8+9 | ASiIn Slave 10+11
Ausgangsdaten (SPS -> KL6201/KL6211)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (6 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3 | ASiCN + ASiOut Slave 1 | ASiOut Slave 2+3 | ASiOut Slave 4+5 | ASiOut Slave 6+7 | ASiOut Slave 8+9 | ASiOut Slave 10+11
Legende
CB n: Control-Byte n
SB n: Status-Byte n
Para In n: Eingangsparameter, Byte n
Para Out n: Ausgangsparameter, Byte n
ASiSN: AS-i Status-Nibble
ASiCN: AS-i Command-Nibble
ASiIn Slave x+y: Eingangsdaten der AS-i Slaves x und y (ein Nibble pro Slave)
ASiOut Slave x+y: Ausgangsdaten der AS-i Slaves x und y (ein Nibble pro Slave)
22 Byte Prozessabbild
Für AS-i Netze, in denen auch Slave-Adressen von 12 bis 31 eingesetzt werden, benötigen Sie das 22 Byte große Prozessabbild um direkt auf die Prozessdaten dieser AS-i Slaves zugreifen zu können.
Eingangsdaten (KL6201/KL6211 -> SPS)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (16 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | ... | Byte 21
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3 | ASiSN + ASiIn Slave 1 | ASiIn Slaves 2+3 | ASiIn Slaves 4+5 | ... | ASiIn Slaves 30+31
Ausgangsdaten (SPS -> KL6201/KL6211)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (16 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | ... | Byte 21
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3 | ASiCN + ASiOut Slave 1 | ASiOut Slaves 2+3 | ASiOut Slaves 4+5 | ... | ASiOut Slaves 30+31
Legende
Siehe 12 Byte Prozessabbild.
38 Byte Prozessabbild
Für AS-i Netze, in denen auch Slave-Adressen größer 32 eingesetzt werden, benötigen Sie das 38 Byte große Prozessabbild um direkt auf die Prozessdaten dieser AS-i Slaves zugreifen zu können.
Eingangsdaten (KL6201/KL6211 -> SPS)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (32 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | ... | Byte 37
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3 | ASiSN + ASiIn Slave 1 | ASiIn Slaves 2+3 | ASiIn Slaves 4+5 | ... | ASiIn Slaves 62+63
Ausgangsdaten (SPS -> KL6201/KL6211)
Parameterdatenblock (6 Byte) |  |  |  |  |  | Prozessdatenblock (32 Byte)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | ... | Byte 37
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3 | ASiCN + ASI Out Slave 1 | ASiOut Slaves 2+3 | ASiOut Slaves 4+5 | ... | ASiOut Slaves 62+63
Legende
Siehe 12 Byte Prozessabbild.
Beschreibung der Datenblöcke
Parameterdatenblock (Byte 0 bis 5 des Prozessabbildes)
Über die Bytes 0 bis 5 des Prozessabbild-Interfaces kann auf alle AS-i Parameter der KL6201/KL6211 zugegriffen werden. Die Ausgangs- und Eingangsdaten haben dann die folgende Bedeutung:
Ausgangsparameter (SPS -> KL6201/KL6211)
Ein neuer Auftrag wird erkannt, wenn sich irgendein Bit im 6 Bytes Parameterdaten-Block geändert hat.
Byte | Bit | Beschreibung
0 (CB0) | 0 bis 5 | Parameternummer Bit 0 bis 5
 | 6 | 0bin: Read 1bin: Write
 | 7 | immer 0 (wegen Kompatibilität zur Registerkommunikation)
1 (CB1) | 0 bis 3 | Parameternummer Bit 6 bis 9
 | 4 | Nur bei Write mit maskiertem Zugriff relevant: 0bin: Low-Word (Bit 0 bis 15) ist adressiert 1bin: High-Word (Bit 16 bis 31) ist adressiert
 | 5 | Nur bei Write relevant: 0bin: normaler 32-Bit-Zugriff 1bin: maskierter 16-Bit-Zugriff mit 16-Bit-Maske (es werden nur die Bits verändert, deren Maske auf "1" steht)
 | 6 | 0bin: der Parameterzugriff ist gesperrt 1bin: Parameter-Zugriff:
 | 7 | immer 0
2 (ParaOut0) | 0 bis 7 | Read: frei Write (normal): Parameterwert Bit 0 bis 7 Write (maskiert): Parameterwert Bit 0 bis 7
3 (ParaOut1) | 0 bis 7 | Read: frei Write (normal): Parameterwert Bit 8 bis 15 Write (maskiert): Parameterwert Bit 8 bis 15
4 (ParaOut2) | 0 bis 7 | Read: frei Write (normal): Parameterwert Bit 16 bis 23 Write (maskiert): Maske Bit 0 bis 7
5 (ParaOut3) | 0 bis 7 | Read: frei Write (normal): Parameterwert Bit 24 bis 31 Write (maskiert): Maske Bit 8 bis 15
Eingangsparameter (KL6201/KL6211 -> SPS)
Byte
Bit
Beschreibung
0 (SB0)
0
nur im geschützten Betriebsmodus relevant:
1bin: die Soll-Konfiguration und die Ist-Konfiguration stimmen überein
1
1bin: ein Spannungseinbruch (Power-Fail) hat stattgefunden
2
1bin: die automatische Adressierung ist freigegeben (der geschützte Betriebsmodus muss aktiv sein)
0bin: die automatische Adressierung ist gesperrt:
▪
ein AS-i Slave mit der Adresse 0 wurde gefunden, es fehlt aber kein projektierter AS-i Slave oder
▪
ein nicht projektierter AS-i Slave wurde gefunden
3
1bin: die automatische Adressierung ist verfügbar (der geschützte Betriebsmodus muss aktiv sein und es muss genau ein projektierter AS-i Slave fehlen)
4
1bin: ein AS-i Slave mit der Adresse "0" wurde gefunden
5
reserviert für Erweiterungen
6
Diagnose-Bit, 1bin:
▪
ein Spannungseinbruch hat stattgefunden
▪
im geschützten Betriebsmodus ist Soll-Konfiguration ungleich Ist-Konfiguration oder
▪
ein AS-i Slave mit der Adresse 0 wurde gefunden oder
▪
die automatische Adressprogrammierung in den Outputdaten (Byte 1, Bit 5) wurde von der Steuerung freigegeben, ist beim AS-i Master aber gesperrt (Inputdaten Byte 0, Bit 2) oder
7
immer 0 (aus Kompatibilität zur Registerkommunikation)
1 (SB1)
0
0bin: der AS-i Master antwortet auf einen Lese-Befehl
1bin: der AS-i Master quittiert einen Schreib-Befehl
1
0bin: der AS-i Master arbeitet im Projektierungsmodus
1bin: der AS-i Master arbeitet im geschützten Betriebsmodus
2
AS-i Master ist in Offline-Phase (die Outputs der aktivierten AS-i Slaves wurden auf den Defaultwert (1bin) gesetzt, die Inputs der aktivierten AS-i Slaves in der Steuerung wurden ebenfalls auf den Default wert (0bin) gesetzt
3
1bin: der AS-i Master arbeitet im Normalbetrieb (Datenaustauschphase wurde erreicht, AS-i Outputs und AS-i Inputs haben die aktuellen Werte)
4
Toggle-Bit, dieses Bit toggelt nach jedem ausgeführten Auftrag
5
0bin: der Parameterzugriff wurde erfolgreich abgeschlossen
1bin: beim Parameterzugriff trat ein Fehler auf
6
Quittiert Bit 6 des CB1:
0bin: Prozessdatenbetrieb
1bin: Parameterzugriff
7
immer 0bin
2 (ParaIn0)
0 bis 7
Read (ohne Fehler): Parameterwert Bit 0 bis 7
Write (ohne Fehler): gelesener Parameterwert Bit 0 bis 7
Read oder Write (mit Fehler): Fehler-Code Bit 0 bis 7
3 (ParaIn1)
0 bis 7
Read (ohne Fehler): Parameterwert Bit 8 bis 15
Write (ohne Fehler): gelesener Parameterwert Bit 8 bis 15
Read oder Write (mit Fehler): Fehler-Code Bit 8 bis 15
4 (ParaIn2)
0 bis 7
Read (ohne Fehler): Parameterwert Bit 16 bis 23
Write (ohne Fehler): gelesener Parameterwert Bit 16 bis 23
Read oder Write (mit Fehler): Fehler-Code Bit 16 bis 23
5 (ParaIn3)
0 bis 7
Read (ohne Fehler): Parameterwert Bit 24 bis 31
Write (ohne Fehler): gelesener Parameterwert Bit 24 bis 31
Read oder Write (mit Fehler): Fehler-Code Bit 24 bis 31
Prozessdatenblock (Byte 6 bis 33 des K-Bus-Interfaces)
Die Ausgangs- und Eingangsdaten der KL6201/KL6211 haben im Auslieferungszustand die folgende Bedeutung:
Eingangsdaten (KL6201/KL6211 -> SPS)
Byte | Bit | Beschreibung
6 | 0 | AS-i SN (AS-i Status Nibble) | nur im geschützten Betriebsmodus relevant: 1bin: Soll-Konfiguration und Ist-Konfiguration stimmen überein
 | 1 |  | 1bin: ein Spannungseinbruch (Power-Fail) hat stattgefunden
 | 2 |  | AS-i Master ist in Offline-Phase (die Outputs der aktivierten AS-i Slaves wurden auf den Defaultwert (1bin) gesetzt, die Inputs der aktivierten AS-i Slaves in der Steuerung wurden ebenfalls auf den Defaultwert (0bin) gesetzt
 | 3 |  | 1bin: der AS-i Master arbeitet im Normalbetrieb (die Datenaustauschphase wurde erreicht, AS-i Outputs und AS-i Inputs haben die aktuellen Werte)
 | 4 bis 7 | AS-i Slave 1 (1A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
7 | 0 bis 3 | AS-i Slave 2 (2A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 3 (3A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
8 | 0 bis 3 | AS-i Slave 4 (4A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 5 (5A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
9 | 0 bis 3 | AS-i Slave 6 (6A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 7 (7A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
10 | 0 bis 3 | AS-i Slave 8 (8A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 9 (9A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
11 | 0 bis 3 | AS-i Slave 10 (10A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 11 (11A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
12 | 0 bis 3 | AS-i Slave 12 (12A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 13 (13A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
13 | 0 bis 3 | AS-i Slave 14 (14A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 15 (15A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
14 | 0 bis 3 | AS-i Slave 16 (16A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 17 (17A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
15 | 0 bis 3 | AS-i Slave 18 (18A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 19 (19A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
16 | 0 bis 3 | AS-i Slave 20 (20A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 21 (21A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
17 | 0 bis 3 | AS-i Slave 22 (22A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 23 (23A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
18 | 0 bis 3 | AS-i Slave 24 (24A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 25 (25A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
19 | 0 bis 3 | AS-i Slave 26 (26A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 27 (27A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
20 | 0 bis 3 | AS-i Slave 28 (28A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 29 (29A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
21 | 0 bis 3 | AS-i Slave 30 (30A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
 | 4 bis 7 | AS-i Slave 31 (31A): digitale Eingänge, Valid-Flags* oder Safety-Flags**
22 | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | AS-i Slave 33 (1B): digitale Eingänge
23 | 0 bis 3 | AS-i Slave 34 (2B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 35 (3B): digitale Eingänge
Byte | Bit | Beschreibung
24 | 0 bis 3 | AS-i Slave 36 (4B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 37 (5B): digitale Eingänge
25 | 0 bis 3 | AS-i Slave 38 (6B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 39 (7B): digitale Eingänge
26 | 0 bis 3 | AS-i Slave 40 (8B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 41 (9B): digitale Eingänge
27 | 0 bis 3 | AS-i Slave 42 (10B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 43 (11B): digitale Eingänge
28 | 0 bis 3 | AS-i Slave 44 (12B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 45 (13B): digitale Eingänge
29 | 0 bis 3 | AS-i Slave 46 (14B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 47 (15B): digitale Eingänge
30 | 0 bis 3 | AS-i Slave 48 (16B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 49 (17B): digitale Eingänge
31 | 0 bis 3 | AS-i Slave 50 (18B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 51 (19B): digitale Eingänge
32 | 0 bis 3 | AS-i Slave 52 (20B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 53 (21B): digitale Eingänge
33 | 0 bis 3 | AS-i Slave 54 (22B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 55 (23B): digitale Eingänge
34 | 0 bis 3 | AS-i Slave 56 (24B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 57 (25B): digitale Eingänge
35 | 0 bis 3 | AS-i Slave 58 (26B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 59 (27B): digitale Eingänge
36 | 0 bis 3 | AS-i Slave 60 (28B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 61 (29B): digitale Eingänge
37 | 0 bis 3 | AS-i Slave 62 (30B): digitale Eingänge
 | 4 bis 7 | AS-i Slave 63 (31B): digitale Eingänge
Legende
Digitale Eingänge: 4 Eingangsbits des digitalen AS-i Slaves
*) Valid-Flags: 4 Eingangsflags, der Wert 1bin zeigt an, dass der analogen Werte des jeweiligen Kanals gültig (1bin) ist.
Bit 0 oder Bit 4: Gültigkeit des Kanals 1
Bit 1 oder Bit 5: Gültigkeit des Kanals 2
Bit 2 oder Bit 6: Gültigkeit des Kanals 3
Bit 3 oder Bit 7: Gültigkeit des Kanals 4
**) Safety-Flags: Informationen über den Zustand eines AS-i Safety-Slaves:
hex | binär |  |  |  | Zustand
 | Bit 3 | Bit 2 | Bit 1 | Bit 0
0x7 | 0 | 1 | 1 | 1 | Sensor im ordnungsgemäßen Ein-Zustand
0xC | 1 | 1 | 0 | 0 | Sensor im Aus-Zustand, aber nur Kontakt 2 offen
0xA | 1 | 0 | 1 | 0 | Sensor im Aus-Zustand, aber nur Kontakt 1 offen
0x8 | 1 | 0 | 0 | 0 | Sensor im ordnungsgemäßen Aus-Zustand
GEFAHR
Auswertung der Safety-Flags nicht zulässig!
Die Auswertung der im Prozessabbild der KL6201/KL6211 angezeigten Safety-Flags ist zur Steuerung sicherheitsrelevanter Funktionen nicht zulässig! Sie dürfen nicht für Schutzfunktionen wie z. B. Not-Aus, Zugangsschutz, Schutzraumüberwachung, Roboter-Bereichsüberwachung, Pressen-Sicherheitsventil usw. verwendet werden!
Ausgangsdaten (SPS -> KL6201/KL6211)
Byte | Bit | Beschreibung
6 | 0 | AS-i CN (AS-i Command Nibble) | reserviert
 | 1 |  | 0bin: automatische Adressierung gesperrt. 1bin: automatische Adressierung freigegeben
 | 2 |  | 1bin: der AS-i Master geht in die Offline-Phase 0bin: der AS-i Master verlässt die Offline-Phase. Dieses Bit wird in den Input-Prozessdaten (Byte 0, Bit 2) sowie in den Input-Parameterinterfacedaten (Byte 1, Bit 2) quittiert.
 | 3 |  | Freigabe AS-i Datenaustausch: 1bin: die aktuellen AS-i Outputs werden an die AS-i Slaves gesendet und die empfangenen AS-i Inputs werden an die Steuerung übergeben. 0bin: die Defaultwerte (1bin) werden an die AS-i Slaves gesendet, die empfangenen AS-i Inputs werden verworfen und die Defaultwerte (0bin) an die Steuerung übergeben. Dieses Bit wird in den Input-Prozessdaten (Byte 0, Bit 3) sowie in den Input-Parameterinterfacedaten (Byte 1, Bit 3) quittiert.
 | 4 bis 7 | AS-i Slave 1 (1A): digitale Ausgänge
7 | 0 bis 3 | AS-i Slave 2 (2A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 3 (3A): digitale Ausgänge
8 | 0 bis 3 | AS-i Slave 4 (4A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 5 (5A): digitale Ausgänge
9 | 0 bis 3 | AS-i Slave 6 (6A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 7 (7A): digitale Ausgänge
10 | 0 bis 3 | AS-i Slave 8 (8A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 9 (9A): digitale Ausgänge
11 | 0 bis 3 | AS-i Slave 10 (10A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 11 (11A): digitale Ausgänge
12 | 0 bis 3 | AS-i Slave 12 (12A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 13 (13A): digitale Ausgänge
13 | 0 bis 3 | AS-i Slave 14 (14A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 15 (15A): digitale Ausgänge
14 | 0 bis 3 | AS-i Slave 16 (16A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 17 (17A): digitale Ausgänge
15 | 0 bis 3 | AS-i Slave 18 (18A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 19 (19A): digitale Ausgänge
16 | 0 bis 3 | AS-i Slave 20 (20A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 21 (21A): digitale Ausgänge
17 | 0 bis 3 | AS-i Slave 22 (22A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 23 (23A): digitale Ausgänge
18 | 0 bis 3 | AS-i Slave 24 (24A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 25 (25A): digitale Ausgänge
19 | 0 bis 3 | AS-i Slave 26 (26A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 27 (27A): digitale Ausgänge
20 | 0 bis 3 | AS-i Slave 28 (28A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 29 (29A): digitale Ausgänge
21 | 0 bis 3 | AS-i Slave 30 (30A): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 31 (31A): digitale Ausgänge
22 | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | AS-i Slave 33 (1B): digitale Ausgänge
Byte | Bit | Beschreibung
23 | 0 bis 3 | AS-i Slave 34 (2B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 35 (3B): digitale Ausgänge
24 | 0 bis 3 | AS-i Slave 36 (4B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 37 (5B): digitale Ausgänge
25 | 0 bis 3 | AS-i Slave 38 (6B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 39 (7B): digitale Ausgänge
26 | 0 bis 3 | AS-i Slave 40 (8B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 41 (9B): digitale Ausgänge
27 | 0 bis 3 | AS-i Slave 42 (10B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 43 (11B): digitale Ausgänge
28 | 0 bis 3 | AS-i Slave 44 (12B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 45 (13B): digitale Ausgänge
29 | 0 bis 3 | AS-i Slave 46 (14B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 47 (15B): digitale Ausgänge
30 | 0 bis 3 | AS-i Slave 48 (16B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 49 (17B): digitale Ausgänge
31 | 0 bis 3 | AS-i Slave 50 (18B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 51 (19B): digitale Ausgänge
32 | 0 bis 3 | AS-i Slave 52 (20B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 53 (21B): digitale Ausgänge
33 | 0 bis 3 | AS-i Slave 54 (22B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 55 (23B): digitale Ausgänge
34 | 0 bis 3 | AS-i Slave 56 (24B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 57 (25B): digitale Ausgänge
35 | 0 bis 3 | AS-i Slave 58 (26B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 59 (27B): digitale Ausgänge
36 | 0 bis 3 | AS-i Slave 60 (28B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 61 (29B): digitale Ausgänge
37 | 0 bis 3 | AS-i Slave 62 (30B): digitale Ausgänge
 | 4 bis 7 | AS-i Slave 63 (31B): digitale Ausgänge


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der Klemme und können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register | Kommentar |  | Defaultwert |  | R/W | Speicher
R0 bis R3 | reserviert |  | 0x0000 | 0dez | - | -
R4 | Registerpage-Auswahlregister |  | 0x0000 | 0dez | R/W |
R5 bis R7 | reserviert |  | 0x0000 | 0dez | - | -
R8 | Klemmenbezeichnung | KL6201 | 0x1839 | 6201dez | R | ROM
 |  | KL6211 | 0x1843 | 6211dez
R9 | Firmware-Stand |  | z. B. 0x0100 | z. B. 256dez | R | ROM
R10 | Multiplex-Schieberegister |  | 0x0160 | 352dez | R | ROM
R11 | Signalkanäle |  | 0x0160 | 352dez | R | ROM
R12 | minimale Datenlänge |  | 0x6060 | 24672dez | R | ROM
R13 | Datenstruktur der Busklemme |  | 0x0001 | 1dez | R | ROM
R14 | reserviert |  | - | - | - | -
R15 | Alignment-Register |  | - | - | R/W | RAM
R16 bis R26 | reserviert |  | 0x0000 | 0dez | - | -
R27 | Größe des Prozessabbilds |  | 0x0001 | 1dez | R/W | SEEROM/RAM
R28 bis R30 | reserviert |  | 0x0000 | 0dez | - | -
R31 | Kodewort-Register |  | 0x0000 | 0dez | R/W | RAM
R32 bis R63 | Register zum Einblenden der Registerpages |  | - | - | - | -


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die Register dienen zur Parametrierung der Klemme und können über die Registerkommunikation ausgelesen oder beschrieben werden.
R4: Registerpage-Auswahlregister
Mit diesem Register legen Sie fest, welche Registerpage in die Register R32 bis R63 der KL6201/KL6211 eingeblendet wird (default: 0x0000). Über die Registerpages haben Sie Zugriff auf die AS-i Parameter der KL6201/KL6211.
R8: Klemmenbezeichnung
Im Register R8 steht in hexadezimaler Codierung die Bezeichnung der Klemme: 0x1839 (6201dez)
R9: Firmware-Stand
Im Register R9 steht in hexadezimaler Codierung der Firmware-Stand der Klemme, z. B. 0x0100 (256dez).
R10: Schieberegisterlänge
0x0160
R11: Anzahl der Signalkanäle
0x0160
R12: Minimale Datenlänge
0x6060
R13: Datenstruktur der Busklemme
Im Register R13 steht die Datenstruktur der Busklemme.
R15: Alignment-Register
R27: Größe des Prozessabbilds
Dieses Register legt die Größe des Prozessabbilds der KL6201/KL6211 fest.
Wert | Prozessabbilds | Default
0000hex | 6 Byte Prozessabbild | 0001hex
0001hex | 12 Byte Prozessabbild
0002hex | 22 Byte Prozessabbild
0003hex | 38 Byte Prozessabbild
weitere | reserviert
Nach Änderung des Prozessabbilds müssen Sie den Buskoppler neu starten, damit er das geänderte Prozessabbild übernimmt.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte nur in die RAM-Register, nicht aber in die EPROM-Register gespeichert und gehen somit bei einem Neustart der Klemme verloren.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die EPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32 bis R63
In diese Register blendet die KL6201/KL6211 die AS-i Parameter der mit Register R4 ausgewählten Registerpage ein.


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme
Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Hinweis
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Registerpages

Zugriff aus dem Anwenderprogramm [image] Registerpages
Registerpages
Auf die AS-i Parameter der KL6201/KL6211 kann über Registerkommunikation oder die Konfigurationssoftware KS2000 zugegriffen werden. Als Basis dient das Registermodell der Klemmen. Die KL6201/KL6211 verfügt über 64 Register (Worte). Die Register 0 bis 31 haben immer die gleiche Bedeutung. Der Inhalt der Register 32 bis 63 wird über das Registerpage-Auswahlregister (R4) festgelegt.
Eine Registerpage ist 32 Register (64 Byte) groß und kann also 16 AS-i Parameter ansprechen.
- Page 0 adressiert in den Klemmenregistern 32 bis 63 die AS-i Parameter 0 bis 15
- Page 1 adressiert in den Klemmenregistern 32 bis 63 die AS-i Parameter 16 bis 31
- usw.
Zuordnung der AS-i Parameter zu Registerpage und Klemmenregister
Reg.- Page | Register der KL6201/KL6211 | AS-i Parameter | Länge | Beschreibung
0x02 | 48 bis 49 | 0x28 | 4 Byte | Allgemeine Information (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x28)
0x04 | 32 bis 47 | 0x40 bis 0x47 | 32 Byte | Projektierte E/A-Kennungen aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x40)
 | 48 bis 63 | 0x48 bis 0x4F | 32 Byte | Projektierte ID-Codes aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x48)
0x05 | 32 bis 47 | 0x50 bis 0x57 | 32 Byte | Aktivierungs-Parameter der AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x50)
 | 48 bis 51 | 0x58 bis 0x59 | 8 Byte | Liste der beim nächsten Start projektierten AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x58)
0x06 | 32 bis 35 | 0x60 bis 0x61 | 8 Byte | Liste der zu überprüfenden E/A-Kennungen aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x60)
 | 48 bis 51 | 0x68 bis 0x69 | 8 Byte | Liste der zu überprüfenden ID-Codes aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x68)
0x07 | 32 bis 35 | 0x70 bis 0x71 | 8 Byte | Liste der zu überprüfenden Extended ID-Codes 1 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x70)
 | 48 bis 51 | 0x78 bis 0x79 | 8 Byte | Liste der zu überprüfenden Extended ID-Codes 2 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x78)
0x08 | 32 bis 47 | 0x80 bis 0x87 | 32 Byte | Digitale Inputs aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x80)
0x09 | 32 bis 47 | 0x90 bis 0x97 | 32 Byte | Gelesene E/A-Kennungen aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x90)
 | 48 bis 63 | 0x98 bis 0x9F | 32 Byte | Gelesene ID-Codes aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x98)
0x0A | 32 bis 47 | 0xA0 bis 0xA7 | 32 Byte | Gelesener Status aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xA0)
 | 48 bis 51 | 0xA8 bis 0xA9 | 8 Byte | Liste der aktuell projektierten AS-i Slaves (LPS) (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xA8)
0x0B | 32 bis 35 | 0xB0 bis 0xB1 | 8 Byte | Liste der erkannten AS-i Slaves (LES) (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xB0)
 | 48 bis 51 | 0xB8 bis 0xB9 | 8 Byte | Liste der aktivierten AS-i Slaves (LAS) (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xB8)
0x0C | 32 bis 35 | 0xC0 bis 0xC1 | 8 Byte | Liste der Slaves, die die erweiterten ID-Codes (ID-Code 1 und ID-Code 2) unterstützen (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xC0)
 | 48 bis 49 | 0xC8 | 4 Byte | Liste der Slaves, die die erweiterte Adressierung (als B-Slaves mit AS-i Adressen größer als 32) unterstützen (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xC8)
Reg.- Page | Register der KL6201/KL6211 | AS-i Parameter | Länge | Beschreibung
0x0D | 32 bis 47 | 0xD0 bis 0xD7 | 32 Byte | Gelesene Extended ID-Codes 1 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xD0)
 | 48 bis 63 | 0xD8 bis 0xDF | 32 Byte | Gelesene Extended ID-Codes 2 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xD8)
0x0E | 32 bis 47 | 0xE0 bis 0xE7 | 32 Byte | Projektierte Extended ID-Codes 1 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xE0)
 | 48 bis 63 | 0xE8 bis 0xEF | 32 Byte | Projektierte Extended ID-Codes 2 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xE8)
0x0F | 32 bis 33 | 0xF0 | 4 Byte | Liste der Analog-Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xF0)
 | 34 bis 35 | 0xF8 | 4 Byte | Liste der Safety-Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xF8)
0x12 | 32 bis 47 | 0x120 bis 0x127 | 32 Byte | Status-Register 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x120)
 | 48 bis 63 | 0x128 bis 0x12F | 32 Byte | Status-Register 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x128)
0x14 | 32 bis 47 | 0x140 bis 0x147 | 32 Byte | PhysicalFault-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x140)
 | 48 bis 63 | 0x148 bis 0x14F | 32 Byte | PhysicalFault-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x148)
0x15 | 33 bis 47 | 0x150 bis 0x157 | 32 Byte | PhysicalFault-Zähler, AS-i Slave 33 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x150)
 | 48 bis 63 | 0x158 bis 0x15F | 32 Byte | PhysicalFault-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x158)
0x16 | 32 bis 47 | 0x160 bis 0x167 | 32 Byte | Timeout-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x160)
 | 48 bis 63 | 0x168 bis 0x16F | 32 Byte | Timeout-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x168)
0x17 | 33 bis 47 | 0x170 bis 0x177 | 32 Byte | Timeout-Zähler, AS-i Slave 33 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x170)
 | 48 bis 63 | 0x178 bis 0x17F | 32 Byte | Timeout-Zähler AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x178)
0x18 | 32 bis 47 | 0x180 bis 0x187 | 32 Byte | Response-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x180)
 | 48 bis 63 | 0x188 bis 0x18F | 32 Byte | Response-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x188)
0x19 | 33 bis 47 | 0x190 bis 0x197 | 32 Byte | Response-Zähler, AS-i Slave 33 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x190)
 | 48 bis 63 | 0x198 bis 0x19F | 32 Byte | Response-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x198)
Reg.- Page | Register der KL6201/KL6211 | AS-i Parameter | Länge | Beschreibung
0x1A | 32 bis 47 | 0x1A0 bis 0x1A7 | 32 Byte | Leave-Data-Exchange-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1A0)
 | 48 bis 63 | 0x1A8 bis 0x1AF | 32 Byte | Leave-Data-Exchange-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1A8)
0x1B | 33 bis 47 | 0x1B0 bis 0x1B7 | 32 Byte | Leave-Data-Exchange-Zähler, AS-i Slave 33 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1B0)
 | 48 bis 63 | 0x1B8 bis 0x1BF | 32 Byte | Leave-Data-Exchange-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1B8)
0x1C | 32 bis 47 | 0x1C0 bis 0x1C7 | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1C0)
 | 48 bis 63 | 0x1C8 bis 0x1CF | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1C8)
0x1D | 33 bis 47 | 0x1D0 bis 0x1D7 | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 33 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1D0)
 | 48 bis 63 | 0x1D8 bis 0x1DF | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1D8)
0x20 | 40 bis 63 | 0x200 bis 0x20F | 64 Byte | Daten der analogen Slaves 1 bis 3 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x204) | siehe Mapping- Tabelle
0x21 | 32 bis 63 | 0x210 bis 0x21F | 64 Byte | Daten der analogen Slaves 4 bis 7 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x210)
... | ... | ... | ... | ...
0x27 | 32 bis 63 | 0x270 bis 0x27F | 64 Byte | Daten der analogen Slaves 30 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x270)
0x30 | 32 bis 33 | 0x300 | 4 Byte | Zykluszeiten (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x300)
0x31 | 32 bis 33 | 0x310 | 4 Byte | Statistik (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x310)
0x32 | 32 bis 63 | 0x320 bis 0x32F | 64 Byte | Timeout-Statistiken je AS-i Slave (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x320)
0x34 | 32 bis 63 | 0x340 bis 0x35F | 64 Byte | Data-Exchange-Repeat-Counter je AS-i Slave (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x340)


AS-i Parameter - Übersicht

Zugriff aus dem Anwenderprogramm [image] AS-i Parameter - Übersicht
AS-i Parameter - Übersicht
Sämtliche Informationen des AS-i Masters und der AS-i Slaves sind in den folgenden Parametern beschrieben, auf die über das zyklische Parameterinterface (Prozessdatenbetrieb), über azyklische Dienste (z. B. PROFIBUS DPV1) oder mit der Konfigurationssoftware KS2000 zugegriffen werden kann.
Übersicht der Parameter
Parameternummern | Zugriff | im Flash gespeichert | Beschreibung
0x20 | R/W | ja | Breite des Prozessabbild-Interfaces
0x28 | R | ja | Allgemeine Informationen
0x30 | R/W | ja | AS-i String-Parameter
0x40 bis 0x47 | R/W | ja | Projektierte E/A-Kennungen aller AS-i Slaves
0x48 bis 0x4F | R/W | ja | Projektierte ID-Codes aller AS-i Slaves
0x50 bis 0x57 | R/W | ja | Aktivierungs-Parameter der AS-i Slaves
0x58 bis 0x59 | R/W | ja | Liste der beim nächsten Start projektierten AS-i Slaves
0x60 bis 0x61 | R/W | ja | Liste der zu überprüfenden E/A-Kennungen aller AS-i Slaves
0x68 bis 0x69 | R/W | ja | Liste der zu überprüfenden ID-Codes aller AS-i Slaves
0x70 bis 0x71 | R/W | ja | Liste der zu überprüfenden Extended ID-Codes 1 aller AS-i Slaves
0x78 bis 0x79 | R/W | ja | Liste der zu überprüfenden Extended ID-Codes 2 aller AS-i Slaves
0x80 bis 0x87 | R | nein | Daten digitaler AS-i Slaves
0x90 bis 0x97 | R | nein | Gelesene E/A-Kennungen aller AS-i Slaves
0x98 bis 0x9F | R | nein | Gelesene ID-Codes aller AS-i Slaves
0xA0 bis 0xA7 | R | nein | Gelesener Status aller AS-i Slaves
0xA8 und 0xA9 | R | nein | Liste der aktuell projektierten AS-i Slaves (LPS)
0xB0 und 0xB1 | R | nein | Liste der erkannten AS-i Slaves (LES)
0xB8 und 0xB9 | R | nein | Liste der aktivierten AS-i Slaves (LAS)
0xC0 und 0xC1 |  |  | Liste der Slaves, die die erweiterten ID-Codes (ID-Code 1 und ID-Code 2) unterstützen
0xC8 |  |  | Liste der Slaves, die die erweiterte Adressierung (als B-Slaves mit Adressen größer als 32) unterstützen
0xD0 bis 0xD7 | R | nein | Gelesene Extended ID-Codes 1 aller AS-i Slaves
0xD8 bis 0xDF | R | nein | Gelesene Extended ID-Codes 2 aller AS-i Slaves
0xE0 bis 0xE7 | R/W | ja | Projektierte Extended ID-Codes 1 aller AS-i Slaves
0xE8 bis 0xEF | R/W | ja | Projektierte Extended ID-Codes 2 aller AS-i Slaves
0xF0 |  |  | Liste der Analog-Slaves
0xF8 |  |  | Liste der Safety-Slaves
0x100 | W | - | AS-i Kommandoschnittstelle
0x108 | W | - | Allgemeine Kommandoschnittstelle
0x120 bis 0x12F | R | nein | Status-Register
0x140 bis 0x15F | R/W | nein | Physical Fault-Zähler
0x160 bis 0x17F | R/W | nein | Timeout-Zähler
0x180 bis 0x19F | R/W | nein | Response-Zähler
0x1A0 bis 0x1BF | R/W | nein | Leave-DataExch-Zähler
0x1C0 bis 0x1DF | R/W | nein | DataExch-Failed-Zähler
0x200 bis 0x27F | R/W | nein | Daten analoger AS-i Slaves
0x300 |  |  | Zykluszeiten
0x310 |  |  | Statistik
0x320 bis 0x32F |  |  | Timeout-Statistiken je AS-i Slave
0x340 bis 0x35F |  |  | Data-Exchange-Repeat-Counter je AS-i Slave


AS-i Parameter - Beschreibung

Zugriff aus dem Anwenderprogramm [image] AS-i Parameter - Beschreibung
AS-i Parameter - Beschreibung
Parameter 0x20: Größe des Prozessabbilds
Im Parameter 0x20 steht die Größe des Prozessabbilds. Dieser Parameter kann gelesen oder beschrieben werden und wird im Flash der KL6201/KL6211 gespeichert (d.h. ist nach Power Off/On noch vorhanden).
Parameter | Bit | Beschreibung | default
0x20 | 0 bis 15 | 0dez: 6 Byte Interface 1dez: 12 Byte Interface 2dez: 22 Byte Interface 3dez: 38 Byte Interface | 1dez
 | 16 bis 31 | reserviert | -
Nach Änderung des Prozessabbilds müssen Sie den Buskoppler neu starten, damit er das geänderte Prozessabbild übernimmt.
Parameter 0x28: Allgemeine Informationen
In dem Parameter 0x28 stehen die Nummer der Klemme (6201) und die Firmware-Version (dieser Parameter ist Read-Only):
Parameter | Bit | Beschreibung
0x28 | 0 bis 15 | Bezeichnung der Klemme: 0x1839 (6201dez)
 | 16 bis 31 | Firmware-Version der Klemme
Parameter 0x30: AS-i String-Parameter
Mit dem Parameter 0x30 können AS-i Strings gelesen bzw. geschrieben werden. Der gesamte AS-i String wird in Tripeln übertragen. Parameter 0x30 wird ab Firmware-Version BA unterstützt.
Parameter | Bit | Beschreibung | Wert
0x30 | 0 bis 7 | Byte 0 von Datentripel m (Byte m) | 0 bis 255
 | 8 bis 15 | Byte 1 von Datentripel m (Byte m + 1) | 0 bis 255
 | 16 bis 23 | Byte 2 von Datentripel m (Byte m + 2) | 0 bis 255
 | 24 bis 31 | Byte-Offset (m = vielfaches von 3) | m
Hinweis
Stringtransfer
Mit einem Stringtransfer sind maximal Maximal 219 Byte String-Daten übertragbar.
Ein String-Transfer besteht aus mehreren Parameterzugriffen, wobei jeweils 4 Byte übergeben werden. Dies 4 Byte bestehen aus drei Byte (1 Tripel) String-Daten und einem 1 Byte für den Byte-Offset.
Parameter 0x40 bis 0x47: Projektierte E/A-Kennung (Soll-Konfiguration)
Im geschützten Betriebsmodus wird die E/A-Kennung der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit-E/A-Kennungen der AS-i Slaves befinden sich in den Parametern 0x40 bis 0x47 (diese Parameter sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)):
Parameter | Bit | Beschreibung
0x40 | 0 bis 3 | reserviert
 | 4 bis 7 | projektierte E/A-Kennung, AS-i Slave 1 (1A)
 | 8 bis 11 | projektierte E/A-Kennung, AS-i Slave 2 (2A)
 | 12 bis 15 | projektierte E/A-Kennung, AS-i Slave 3 (3A)
 | 16 bis 19 | projektierte E/A-Kennung, AS-i Slave 4 (4A)
 | 20 bis 23 | projektierte E/A-Kennung, AS-i Slave 5 (5A)
 | 24 bis 27 | projektierte E/A-Kennung, AS-i Slave 6 (6A)
 | 28 bis 31 | projektierte E/A-Kennung, AS-i Slave 7 (7A)
Parameter | Bit | Beschreibung
0x41 | 0 bis 3 | projektierte E/A-Kennung, AS-i Slave 8 (8A)
 | 4 bis 7 | projektierte E/A-Kennung, AS-i Slave 9 (9A)
 | 8 bis 11 | projektierte E/A-Kennung, AS-i Slave 10 (10A)
 | 12 bis 15 | projektierte E/A-Kennung, AS-i Slave 11 (11A)
 | 16 bis 19 | projektierte E/A-Kennung, AS-i Slave 12 (12A)
 | 20 bis 23 | projektierte E/A-Kennung, AS-i Slave 13 (13A)
 | 24 bis 27 | projektierte E/A-Kennung, AS-i Slave 14 (14A)
 | 28 bis 31 | projektierte E/A-Kennung, AS-i Slave 15 (15A)
0x42 | 0 bis 3 | projektierte E/A-Kennung, AS-i Slave 16 (16A)
 | 4 bis 7 | projektierte E/A-Kennung, AS-i Slave 17 (17A)
 | 8 bis 11 | projektierte E/A-Kennung, AS-i Slave 18 (18A)
 | 12 bis 15 | projektierte E/A-Kennung, AS-i Slave 19 (19A)
 | 16 bis 19 | projektierte E/A-Kennung, AS-i Slave 20 (20A)
 | 20 bis 23 | projektierte E/A-Kennung, AS-i Slave 21 (21A)
 | 24 bis 27 | projektierte E/A-Kennung, AS-i Slave 22 (22A)
 | 28 bis 31 | projektierte E/A-Kennung, AS-i Slave 23 (23A)
0x43 | 0 bis 3 | projektierte E/A-Kennung, AS-i Slave 24 (24A)
 | 4 bis 7 | projektierte E/A-Kennung, AS-i Slave 25 (25A)
 | 8 bis 11 | projektierte E/A-Kennung, AS-i Slave 26 (26A)
 | 12 bis 15 | projektierte E/A-Kennung, AS-i Slave 27 (27A)
 | 16 bis 19 | projektierte E/A-Kennung, AS-i Slave 28 (28A)
 | 20 bis 23 | projektierte E/A-Kennung, AS-i Slave 29 (29A)
 | 24 bis 27 | projektierte E/A-Kennung, AS-i Slave 30 (30A)
 | 28 bis 31 | projektierte E/A-Kennung, AS-i Slave 31 (31A)
0x44 | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | projektierte E/A-Kennung, AS-i Slave 33 (1B)
 | 8 bis 11 | projektierte E/A-Kennung, AS-i Slave 34 (2B)
 | 12 bis 15 | projektierte E/A-Kennung, AS-i Slave 35 (3B)
 | 16 bis 19 | projektierte E/A-Kennung, AS-i Slave 36 (4B)
 | 20 bis 23 | projektierte E/A-Kennung, AS-i Slave 37 (5B)
 | 24 bis 27 | projektierte E/A-Kennung, AS-i Slave 38 (6B)
 | 28 bis 31 | projektierte E/A-Kennung, AS-i Slave 39 (7B)
0x45 | 0 bis 3 | projektierte E/A-Kennung, AS-i Slave 40 (8B)
 | 4 bis 7 | projektierte E/A-Kennung, AS-i Slave 41 (9B)
 | 8 bis 11 | projektierte E/A-Kennung, AS-i Slave 42 (10B)
 | 12 bis 15 | projektierte E/A-Kennung, AS-i Slave 43 (11B)
 | 16 bis 19 | projektierte E/A-Kennung, AS-i Slave 44 (12B)
 | 20 bis 23 | projektierte E/A-Kennung, AS-i Slave 45 (13B)
 | 24 bis 27 | projektierte E/A-Kennung, AS-i Slave 46 (14B)
 | 28 bis 31 | projektierte E/A-Kennung, AS-i Slave 47 (15B)
0x46 | 0 bis 3 | projektierte E/A-Kennung, AS-i Slave 48 (16B)
 | 4 bis 7 | projektierte E/A-Kennung, AS-i Slave 49 (17B)
 | 8 bis 11 | projektierte E/A-Kennung, AS-i Slave 50 (18B)
 | 12 bis 15 | projektierte E/A-Kennung, AS-i Slave 51 (19B)
 | 16 bis 19 | projektierte E/A-Kennung, AS-i Slave 52 (20B)
 | 20 bis 23 | projektierte E/A-Kennung, AS-i Slave 53 (21B)
 | 24 bis 27 | projektierte E/A-Kennung, AS-i Slave 54 (22B)
 | 28 bis 31 | projektierte E/A-Kennung, AS-i Slave 55 (23B)
0x47 | 0 bis 3 | projektierte E/A-Kennung, AS-i Slave 56 (24B)
 | 4 bis 7 | projektierte E/A-Kennung, AS-i Slave 57 (25B)
 | 8 bis 11 | projektierte E/A-Kennung, AS-i Slave 58 (26B)
 | 12 bis 15 | projektierte E/A-Kennung, AS-i Slave 59 (27B)
 | 16 bis 19 | projektierte E/A-Kennung, AS-i Slave 60 (28B)
 | 20 bis 23 | projektierte E/A-Kennung, AS-i Slave 61 (29B)
 | 24 bis 27 | projektierte E/A-Kennung, AS-i Slave 62 (30B)
 | 28 bis 31 | projektierte E/A-Kennung, AS-i Slave 63 (31B)
Parameter 0x48 bis 0x4F: Projektierter ID-Code (Soll-Konfiguration)
Im geschützten Betriebsmodus wird der ID-Code der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit-ID-Codes der AS-i Slaves befinden sich in den Parametern 0x48 bis 0x4F (diese Parameter sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)):
Parameter | Bit | Beschreibung
0x48 | 0 bis 3 | reserviert
 | 4 bis 7 | projektierter ID-Code, AS-i Slave 1 (1A)
 | 8 bis 11 | projektierter ID-Code, AS-i Slave 2 (2A)
 | 12 bis 15 | projektierter ID-Code, AS-i Slave 3 (3A)
 | 16 bis 19 | projektierter ID-Code, AS-i Slave 4 (4A)
 | 20 bis 23 | projektierter ID-Code, AS-i Slave 5 (5A)
 | 24 bis 27 | projektierter ID-Code, AS-i Slave 6 (6A)
 | 28 bis 31 | projektierter ID-Code, AS-i Slave 7 (7A)
0x49 | 0 bis 3 | projektierter ID-Code, AS-i Slave 8 (8A)
 | 4 bis 7 | projektierter ID-Code, AS-i Slave 9 (9A)
 | 8 bis 11 | projektierter ID-Code, AS-i Slave 10 (10A)
 | 12 bis 15 | projektierter ID-Code, AS-i Slave 11 (11A)
 | 16 bis 19 | projektierter ID-Code, AS-i Slave 12 (12A)
 | 20 bis 23 | projektierter ID-Code, AS-i Slave 13 (13A)
 | 24 bis 27 | projektierter ID-Code, AS-i Slave 14 (14A) (14A)
 | 28 bis 31 | projektierter ID-Code, AS-i Slave 15 (15A)
0x4A | 0 bis 3 | projektierter ID-Code, AS-i Slave 16 (16A)
 | 4 bis 7 | projektierter ID-Code, AS-i Slave 17 (17A)
 | 8 bis 11 | projektierter ID-Code, AS-i Slave 18 (18A)
 | 12 bis 15 | projektierter ID-Code, AS-i Slave 19 (19A)
 | 16 bis 19 | projektierter ID-Code, AS-i Slave 20 (20A)
 | 20 bis 23 | projektierter ID-Code, AS-i Slave 21 (21A)
 | 24 bis 27 | projektierter ID-Code, AS-i Slave 22 (22A)
 | 28 bis 31 | projektierter ID-Code, AS-i Slave 23 (23A)
0x4B | 0 bis 3 | projektierter ID-Code, AS-i Slave 24 (24A)
 | 4 bis 7 | projektierter ID-Code, AS-i Slave 25 (25A)
 | 8 bis 11 | projektierter ID-Code, AS-i Slave 26 (26A)
 | 12 bis 15 | projektierter ID-Code, AS-i Slave 27 (27A)
 | 16 bis 19 | projektierter ID-Code, AS-i Slave 28 (28A)
 | 20 bis 23 | projektierter ID-Code, AS-i Slave 29 (29A)
 | 24 bis 27 | projektierter ID-Code, AS-i Slave 30 (30A)
 | 28 bis 31 | projektierter ID-Code, AS-i Slave 31 (31A)
0x4C | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | projektierter ID-Code, AS-i Slave 33 (1B)
 | 8 bis 11 | projektierter ID-Code, AS-i Slave 34 (2B)
 | 12 bis 15 | projektierter ID-Code, AS-i Slave 35 (3B)
 | 16 bis 19 | projektierter ID-Code, AS-i Slave 36 (4B)
 | 20 bis 23 | projektierter ID-Code, AS-i Slave 37 (5B)
 | 24 bis 27 | projektierter ID-Code, AS-i Slave 38 (6B)
 | 28 bis 31 | projektierter ID-Code, AS-i Slave 39 (7B)
0x4D | 0 bis 3 | projektierter ID-Code, AS-i Slave 40 (8B)
 | 4 bis 7 | projektierter ID-Code, AS-i Slave 41 (9B)
 | 8 bis 11 | projektierter ID-Code, AS-i Slave 42 (10B)
 | 12 bis 15 | projektierter ID-Code, AS-i Slave 43 (11B)
 | 16 bis 19 | projektierter ID-Code, AS-i Slave 44 (12B)
 | 20 bis 23 | projektierter ID-Code, AS-i Slave 45 (13B)
 | 24 bis 27 | projektierter ID-Code, AS-i Slave 46 (14B)
 | 28 bis 31 | projektierter ID-Code, AS-i Slave 47 (15B)
Parameter | Bit | Beschreibung
0x4E | 0 bis 3 | projektierter ID-Code, AS-i Slave 48 (16B)
 | 4 bis 7 | projektierter ID-Code, AS-i Slave 49 (17B)
 | 8 bis 11 | projektierter ID-Code, AS-i Slave 50 (18B)
 | 12 bis 15 | projektierter ID-Code, AS-i Slave 51 (19B)
 | 16 bis 19 | projektierter ID-Code, AS-i Slave 52 (20B)
 | 20 bis 23 | projektierter ID-Code, AS-i Slave 53 (21B)
 | 24 bis 27 | projektierter ID-Code, AS-i Slave 54 (22B)
 | 28 bis 31 | projektierter ID-Code, AS-i Slave 55 (23B)
0x4F | 0 bis 3 | projektierter ID-Code, AS-i Slave 56 (24B)
 | 4 bis 7 | projektierter ID-Code, AS-i Slave 57 (25B)
 | 8 bis 11 | projektierter ID-Code, AS-i Slave 58 (26B)
 | 12 bis 15 | projektierter ID-Code, AS-i Slave 59 (27B)
 | 16 bis 19 | projektierter ID-Code, AS-i Slave 60 (28B)
 | 20 bis 23 | projektierter ID-Code, AS-i Slave 61 (29B)
 | 24 bis 27 | projektierter ID-Code, AS-i Slave 62 (30B)
 | 28 bis 31 | projektierter ID-Code, AS-i Slave 63 (31B)
Parameter 0x50 bis 0x57: Aktivierungs-Parameter der AS-i Slaves
In der Aktivierungsphase (oder in der Aufnahmephase - bei später hinzugefügten AS-i Slaves) werden, bevor das erste Mal ein Datenaustausch durchgeführt wird, einmal 4 Bit Parameterdaten zu jedem AS-i Slave gesendet. Über die Parameter 0x50 bis 0x57 können diese Aktivierungs-Parameter für jeden AS-i Slave vorgegeben werden. Die genaue Bedeutung der Aktivierungs-Parameter jedes einzelnen AS-i Slaves entnehmen Sie bitte der zum Slave zugehörigen Dokumentation.
Die Parameter 0x50 bis 0x57 können gelesen oder beschrieben werden und sind im Flash des AS-i Masters gespeichert, d.h. sind nach Power Off/On der AS-i Masters noch vorhanden.
Parameter | Bit | Beschreibung | default
0x50 | 0 bis 3 | reserviert | -
 | 4 bis 7 | Aktivierungs-Parameter, AS-i Slave 1 (1A) | 0x0F
 | 8 bis 11 | Aktivierungs-Parameter, AS-i Slave 2 (2A) | 0x0F
 | 12 bis 15 | Aktivierungs-Parameter, AS-i Slave 3 (3A) | 0x0F
 | 16 bis 19 | Aktivierungs-Parameter, AS-i Slave 4 (4A) | 0x0F
 | 20 bis 23 | Aktivierungs-Parameter, AS-i Slave 5 (5A) | 0x0F
 | 24 bis 27 | Aktivierungs-Parameter, AS-i Slave 6 (6A) | 0x0F
 | 28 bis 31 | Aktivierungs-Parameter, AS-i Slave 7 (7A) | 0x0F
0x51 | 0 bis 3 | Aktivierungs-Parameter, AS-i Slave 8 (8A) | 0x0F
 | 4 bis 7 | Aktivierungs-Parameter, AS-i Slave 9 (9A) | 0x0F
 | 8 bis 11 | Aktivierungs-Parameter, AS-i Slave 10 (10A) | 0x0F
 | 12 bis 15 | Aktivierungs-Parameter, AS-i Slave 11 (11A) | 0x0F
 | 16 bis 19 | Aktivierungs-Parameter, AS-i Slave 12 (12A) | 0x0F
 | 20 bis 23 | Aktivierungs-Parameter, AS-i Slave 13 (13A) | 0x0F
 | 24 bis 27 | Aktivierungs-Parameter, AS-i Slave 14 (14A) | 0x0F
 | 28 bis 31 | Aktivierungs-Parameter, AS-i Slave 15 (15A) | 0x0F
0x52 | 0 bis 3 | Aktivierungs-Parameter, AS-i Slave 16 (16A) | 0x0F
 | 4 bis 7 | Aktivierungs-Parameter, AS-i Slave 17 (17A) | 0x0F
 | 8 bis 11 | Aktivierungs-Parameter, AS-i Slave 18 (18A) | 0x0F
 | 12 bis 15 | Aktivierungs-Parameter, AS-i Slave 19 (19A) | 0x0F
 | 16 bis 19 | Aktivierungs-Parameter, AS-i Slave 20 (20A) | 0x0F
 | 20 bis 23 | Aktivierungs-Parameter, AS-i Slave 21 (21A) | 0x0F
 | 24 bis 27 | Aktivierungs-Parameter, AS-i Slave 22 (22A) | 0x0F
 | 28 bis 31 | Aktivierungs-Parameter, AS-i Slave 23 (23A) | 0x0F
Parameter | Bit | Beschreibung | default
0x53 | 0 bis 3 | Aktivierungs-Parameter, AS-i Slave 24 (24A) | 0x0F
 | 4 bis 7 | Aktivierungs-Parameter, AS-i Slave 25 (25A) | 0x0F
 | 8 bis 11 | Aktivierungs-Parameter, AS-i Slave 26 (26A) | 0x0F
 | 12 bis 15 | Aktivierungs-Parameter, AS-i Slave 27 (27A) | 0x0F
 | 16 bis 19 | Aktivierungs-Parameter, AS-i Slave 28 (28A) | 0x0F
 | 20 bis 23 | Aktivierungs-Parameter, AS-i Slave 29 (29A) | 0x0F
 | 24 bis 27 | Aktivierungs-Parameter, AS-i Slave 30 (30A) | 0x0F
 | 28 bis 31 | Aktivierungs-Parameter, AS-i Slave 31 (31A) | 0x0F
0x54 | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig) | -
 | 4 bis 7 | Aktivierungs-Parameter, AS-i Slave 33 (1B) | 0x0F
 | 8 bis 11 | Aktivierungs-Parameter, AS-i Slave 34 (2B) | 0x0F
 | 12 bis 15 | Aktivierungs-Parameter, AS-i Slave 35 (3B) | 0x0F
 | 16 bis 19 | Aktivierungs-Parameter, AS-i Slave 36 (4B) | 0x0F
 | 20 bis 23 | Aktivierungs-Parameter, AS-i Slave 37 (5B) | 0x0F
 | 24 bis 27 | Aktivierungs-Parameter, AS-i Slave 38 (6B) | 0x0F
 | 28 bis 31 | Aktivierungs-Parameter, AS-i Slave 39 (7B) | 0x0F
0x55 | 0 bis 3 | Aktivierungs-Parameter, AS-i Slave 40 (8B) | 0x0F
 | 4 bis 7 | Aktivierungs-Parameter, AS-i Slave 41 (9B) | 0x0F
 | 8 bis 11 | Aktivierungs-Parameter, AS-i Slave 42 (10B) | 0x0F
 | 12 bis 15 | Aktivierungs-Parameter, AS-i Slave 43 (11B) | 0x0F
 | 16 bis 19 | Aktivierungs-Parameter, AS-i Slave 44 (12B) | 0x0F
 | 20 bis 23 | Aktivierungs-Parameter, AS-i Slave 45 (13B) | 0x0F
 | 24 bis 27 | Aktivierungs-Parameter, AS-i Slave 46 (14B) | 0x0F
 | 28 bis 31 | Aktivierungs-Parameter, AS-i Slave 47 (15B) | 0x0F
0x56 | 0 bis 3 | Aktivierungs-Parameter, AS-i Slave 48 (16B) | 0x0F
 | 4 bis 7 | Aktivierungs-Parameter, AS-i Slave 49 (17B) | 0x0F
 | 8 bis 11 | Aktivierungs-Parameter, AS-i Slave 50 (18B) | 0x0F
 | 12 bis 15 | Aktivierungs-Parameter, AS-i Slave 51 (19B) | 0x0F
 | 16 bis 19 | Aktivierungs-Parameter, AS-i Slave 52 (20B) | 0x0F
 | 20 bis 23 | Aktivierungs-Parameter, AS-i Slave 53 (21B) | 0x0F
 | 24 bis 27 | Aktivierungs-Parameter, AS-i Slave 54 (22B) | 0x0F
 | 28 bis 31 | Aktivierungs-Parameter, AS-i Slave 55 (23B) | 0x0F
0x57 | 0 bis 3 | Aktivierungs-Parameter, AS-i Slave 56 (24B) | 0x0F
 | 4 bis 7 | Aktivierungs-Parameter, AS-i Slave 57 (25B) | 0x0F
 | 8 bis 11 | Aktivierungs-Parameter, AS-i Slave 58 (26B) | 0x0F
 | 12 bis 15 | Aktivierungs-Parameter, AS-i Slave 59 (27B) | 0x0F
 | 16-19 | Aktivierungs-Parameter, AS-i Slave 60 (28B) | 0x0F
 | 20 bis 23 | Aktivierungs-Parameter, AS-i Slave 61 (29B) | 0x0F
 | 24 bis 27 | Aktivierungs-Parameter, AS-i Slave 62 (30B) | 0x0F
 | 28 bis 31 | Aktivierungs-Parameter, AS-i Slave 63 (31B) | 0x0F
Parameter 0x58 und 0x59: Liste der beim nächsten Start projektierten AS-i Slaves
In dieser Liste befinden sich die beim nächsten Start (Übergang von der Offline-Phase in die Erkennungsphase) projektierten AS-i Slaves. Je AS-i Slave gibt es in den Parametern 0x58 bis 0x59 ein Bit, das anzeigt, ob der entsprechende AS-i Slave projektiert ist (dieser Parameter ist Read-Write und wird im Flash des AS-i Masters gespeichert (d.h. ist nach Power Off/On noch vorhanden)):
Parameter | Bit | Beschreibung
0x58 | 0 | reserviert
 | 1 | 0bin: AS-i Slave 1 (1A) ist nicht projektiert 1bin: AS-i Slave 1 (1A) ist projektiert
 | ... | ...
 | 31 | 0bin: AS-i Slave 3 1 (31A) ist nicht projektiert 1bin: AS-i Slave 3 1 (31A) ist projektiert
0x59 | 0 | reserviert
 | 1 | 0bin: AS-i Slave 33 (1B) ist nicht projektiert 1bin: AS-i Slave 33 (1B) ist projektiert
 | ... | ...
 | 31 | 0bin: AS-i Slave 63 (31B) ist nicht projektiert 1bin: AS-i Slave 63 (31B) ist projektiert
Parameter 0x60 und 0x61: Überprüfung der E/A-Kennungen der AS-i Slaves
In dieser Liste wird festgelegt, ob im geschützten Betriebsmodus (Projektierung aktiv) die E/A-Kennungen geprüft werden sollen. Je AS-i Slave gibt es in den Parametern 0x60 bis 0x61 ein Bit, das anzeigt, ob die E/A-Kennung des entsprechende AS-i Slaves überprüft werden soll (dieser Parameter ist Read-Write und wird im Flash des AS-i Masters gespeichert (d.h: ist nach Power Off/On noch vorhanden)):
Parameter | Bit | Beschreibung
0x60 | 0 | reserviert
 | 1 | 0bin: E/A-Kennung von AS-i Slave 1 (1A) wird im geschützten Betriebsmodus nicht überprüft (0) 1bin: E/A-Kennung von AS-i Slave 1 (1A) wird im geschützten Betriebsmodus überprüft (1)
 | ... | ...
 | 31 | 0bin: E/A-Kennung von AS-i Slave 31 (31A) wird im geschützten Betriebsmodus nicht überprüft (0) 1bin: E/A-Kennung von AS-i Slave 31 (31A) wird im geschützten Betriebsmodus überprüft (1)
0x61 | 0 | reserviert
 | 1 | 0bin: E/A-Kennung von AS-i Slave 33 (1B) wird im geschützten Betriebsmodus nicht überprüft (0) 1bin: E/A-Kennung von AS-i Slave 33 (1B) wird im geschützten Betriebsmodus überprüft (1)
 | ... | ...
 | 31 | 0bin: E/A-Kennung von AS-i Slave 63 (31B) wird im geschützten Betriebsmodus nicht überprüft (0) 1bin: E/A-Kennung von AS-i Slave 63 (31B) wird im geschützten Betriebsmodus überprüft (1)
Parameter 0x68 und 0x69: Überprüfung der ID-Codes der AS-i Slaves
In dieser Liste wird festgelegt, ob im geschützten Betriebsmodus (Projektierung aktiv) die ID-Codes geprüft werden sollen. Je AS-i Slave gibt es in den Parametern 0x68 bis 0x69 ein Bit, das anzeigt, ob der ID-Code des entsprechenden AS-i Slaves überprüft werden soll (dieser Parameter ist Read-Write und wird im Flash des AS-i Masters gespeichert (d.h. ist nach Power Off/On noch vorhanden)):
Parameter | Bit | Beschreibung
0x68 | 0 | reserviert
 | 1 | 0bin: ID-Code von AS-i Slave 1 (1A) wird im geschützten Betriebsmodus nicht überprüft 1bin: ID-Code von AS-i Slave 1 (1A) wird im geschützten Betriebsmodus überprüft
 | ... | ...
 | 31 | 0bin: ID-Code von AS-i Slave 31 (31A) wird im geschützten Betriebsmodus nicht überprüft 1bin: ID-Code von AS-i Slave 31 (31A) wird im geschützten Betriebsmodus überprüft
0x69 | 0 | reserviert
 | 1 | 0bin: ID-Code von AS-i Slave 33 (1B) wird im geschützten Betriebsmodus nicht überprüft 1bin: ID-Code von AS-i Slave 33 (1B) wird im geschützten Betriebsmodus überprüft
 | ... | ...
 | 31 | 0bin: ID-Code von AS-i Slave 63 (31B) wird im geschützten Betriebsmodus nicht überprüft 1bin: ID-Code von AS-i Slave 63 (31B) wird im geschützten Betriebsmodus überprüft
Parameter 0x70 und 0x71: Überprüfung der Extended ID-Codes 1 der AS-i Slaves
In dieser Liste wird festgelegt, ob im geschützten Betriebsmodus (Projektierung aktiv) die Extended ID-Codes 1 geprüft werden sollen. Je AS-i Slave gibt es in den Parametern 0x70 bis 0x71 ein Bit, das anzeigt, ob der Extended ID-Code 2 des entsprechenden AS-i Slaves überprüft werden soll (dieser Parameter ist Read-Write und wird im Flash des AS-i Masters gespeichert (d.h. ist nach Power Off/On noch vorhanden)):
Parameter | Bit | Beschreibung
0x70 | 0 | reserviert
 | 1 | 0bin: Extended ID-Code 1 von AS-i Slave 1 (1A) wird im geschützten Betriebsmodus nicht überprüft 1bin: Extended ID-Code 1 von AS-i Slave 1 (1A) wird im geschützten Betriebsmodus überprüft
 | ... | ...
 | 31 | 0bin: Extended ID-Code 1 von AS-i Slave 31 (31A) wird im geschützten Betriebsmodus nicht überprüft 1bin: Extended ID-Code 1 von AS-i Slave 31 (31A) wird im geschützten Betriebsmodus überprüft
0x71 | 0 | reserviert
 | 1 | 0bin: Extended ID-Code 1 von AS-i Slave 33 (1B) wird im geschützten Betriebsmodus nicht überprüft 1bin: Extended ID-Code 1 von AS-i Slave 33 (1B) wird im geschützten Betriebsmodus überprüft
 | ... | ...
 | 31 | 0bin: Extended ID-Code 1 von AS-i Slave 63 (31B) wird im geschützten Betriebsmodus nicht überprüft 1bin: Extended ID-Code 1 von AS-i Slave 63 (31B) wird im geschützten Betriebsmodus überprüft
Parameter 0x78 und 0x79: Überprüfung der Extended ID-Codes 2 der AS-i Slaves
In dieser Liste wird festgelegt, ob im geschützten Betriebsmodus (Projektierung aktiv) die ID-Codes geprüft werden sollen. Je AS-i Slave gibt es in den Parametern 0x78 bis 0x79 ein Bit, das anzeigt, ob der Extended ID-Code 2 des entsprechenden AS-i Slaves überprüft werden soll (dieser Parameter ist Read-Write und wird im Flash des AS-i Masters gespeichert (d.h. ist nach Power Off/On noch vorhanden)):
Parameter | Bit | Beschreibung
0x78 | 0 | reserviert
 | 1 | 0bin: Extended ID-Code 2 von AS-i Slave 1 (1A) wird im geschützten Betriebsmodus nicht überprüft 1bin: Extended ID-Code 2 von AS-i Slave 1 (1A) wird im geschützten Betriebsmodus überprüft
 | ... | ...
 | 31 | 0bin: Extended ID-Code 2 von AS-i Slave 3 1 (31A) wird im geschützten Betriebsmodus nicht überprüft 1bin: Extended ID-Code 2 von AS-i Slave 3 1 (31A) wird im geschützten Betriebsmodus überprüft
0x79 | 0 | reserviert
 | 1 | 0bin: Extended ID-Code 2 von AS-i Slave 33 (1B) wird im geschützten Betriebsmodus nicht überprüft 1bin: Extended ID-Code 2 von AS-i Slave 33 (1B) wird im geschützten Betriebsmodus überprüft
 | ... | ...
 | 31 | 0bin: Extended ID-Code 2 von AS-i Slave 63 (31B) wird im geschützten Betriebsmodus nicht überprüft 1bin: Extended ID-Code 2 von AS-i Slave 63 (31B) wird im geschützten Betriebsmodus überprüft
Parameter 0x80 bis 0x87: Digitale In- und Outputs
Die digitalen Prozessdaten der AS-i Slaves können auch über die Parameter gelesen bzw. beschrieben werden. Das Schreiben der digitalen Outputs funktioniert beim 12-BYTE-KBus-Interface nur für die AS-i Slaves ab Adresse 12 (die digitalen Outputs der AS-i Slaves 1-11 werden durch die Prozessdaten überschrieben), beim 22-BYTE-KBus-Interface ab Adresse 33 (die digitalen Outputs der AS-i Slaves 1-31 werden durch die Prozessdaten überschrieben) und beim 30-BYTE-KBus-Interface ab Adresse 48 (die digitalen Outputs der AS-i Slaves 1-47 werden durch die Prozessdaten überschrieben). In den Parametern 0x80 bis 0x87 sind die digitalen Inputs (Readzugriff) bzw. digitalen Outputs (Write-Zugriff) aller AS-i Slaves abgelegt (diese Parameter sind Read-Write (Read für Inputs, Write für Outputs)):
Parameter | Bit | Beschreibung
0x80 | 0 bis 3 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 0
 | 4 bis 7 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 1 (1A)
 | 8 bis 11 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 2 (2A)
 | 12 bis 15 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 3 (3A)
 | 16-19 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 4 (4A)
 | 20 bis 23 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 5 (5A)
 | 24 bis 27 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 6 (6A)
 | 28 bis 31 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 7 (7A)
Parameter | Bit | Beschreibung
0x81 | 0 bis 3 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 8 (8A)
 | 4 bis 7 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 9 (9A)
 | 8 bis 11 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 10 (10A)
 | 12 bis 15 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 11 (11A)
 | 16-19 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 12 (12A)
 | 20 bis 23 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 13 (13A)
 | 24 bis 27 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 14 (14A)
 | 28 bis 31 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 15 (15A)
0x82 | 0 bis 3 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 16 (16A)
 | 4 bis 7 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 17 (17A)
 | 8 bis 11 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 18 (18A)
 | 12 bis 15 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 19 (19A)
 | 16-19 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 20 (20A)
 | 20 bis 23 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 21 (21A)
 | 24 bis 27 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 22 (22A)
 | 28 bis 31 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 23 (23A)
0x83 | 0 bis 3 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 24 (24A)
 | 4 bis 7 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 25 (25A)
 | 8 bis 11 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 26 (26A)
 | 12 bis 15 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 27 (27A)
 | 16-19 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 28 (28A)
 | 20 bis 23 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 29 (29A)
 | 24 bis 27 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 30 (30A)
 | 28 bis 31 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 31 (31A)
0x84 | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 33 (1B)
 | 8 bis 11 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 34 (2B)
 | 12 bis 15 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 35 (3B)
 | 16 bis 19 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 36 (4B)
 | 20 bis 23 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 37 (5B)
 | 24 bis 27 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 38 (6B)
 | 28 bis 31 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 39 (7B)
0x85 | 0 bis 3 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 40 (8B)
 | 4 bis 7 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 41 (9B)
 | 8 bis 11 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 42 (10B)
 | 12 bis 15 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 43 (11B)
 | 16 bis 19 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 44 (12B)
 | 20 bis 23 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 45 (13B)
 | 24 bis 27 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 46 (14B)
 | 28 bis 31 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 47 (15B)
0x86 | 0 bis 3 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 48 (16B)
 | 4 bis 7 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 49 (17B)
 | 8 bis 11 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 50 (18B)
 | 12 bis 15 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 51 (19B)
 | 16 bis 19 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 52 (20B)
 | 20 bis 23 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 53 (21B)
 | 24 bis 27 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 54 (22B)
 | 28 bis 31 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 55 (23B)
0x87 | 0 bis 3 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 56 (24B)
 | 4 bis 7 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 57 (25B)
 | 8 bis 11 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 58 (26B)
 | 12 bis 15 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 59 (27B)
 | 16 bis 19 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 60 (28B)
 | 20 bis 23 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 61 (29B)
 | 24 bis 27 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 62 (30B)
 | 28 bis 31 | Digitale Inputs (Read) bzw. digitale Outputs (Write), AS-i Slave 63 (31B)
Parameter 0x90 bis 0x97: Gelesene E/A-Kennung (Ist-Konfiguration)
Jeder AS-i Slave verfügt über eine 4-Bit-E/A-Kennung, die in den Parametern 0x90 bis 0x97 abgelegt sind (diese Parameter sind Read-Only):
Parameter | Bit | Beschreibung
0x90 | 0 bis 3 | gelesene E/A-Kennung, AS-i Slave 0
 | 4 bis 7 | gelesene E/A-Kennung, AS-i Slave 1 (1A)
 | 8 bis 11 | gelesene E/A-Kennung, AS-i Slave 2 (2A)
 | 12 bis 15 | gelesene E/A-Kennung, AS-i Slave 3 (3A)
 | 16 bis 19 | gelesene E/A-Kennung, AS-i Slave 4 (4A)
 | 20 bis 23 | gelesene E/A-Kennung, AS-i Slave 5 (5A)
 | 24 bis 27 | gelesene E/A-Kennung, AS-i Slave 6 (6A)
 | 28 bis 31 | gelesene E/A-Kennung, AS-i Slave 7 (7A)
0x91 | 0 bis 3 | gelesene E/A-Kennung, AS-i Slave 8 (8A)
 | 4 bis 7 | gelesene E/A-Kennung, AS-i Slave 9 (9A)
 | 8 bis 11 | gelesene E/A-Kennung, AS-i Slave 10 (10A)
 | 12 bis 15 | gelesene E/A-Kennung, AS-i Slave 11 (11A)
 | 16 bis 19 | gelesene E/A-Kennung, AS-i Slave 12 (12A)
 | 20 bis 23 | gelesene E/A-Kennung, AS-i Slave 13 (13A)
 | 24 bis 27 | gelesene E/A-Kennung, AS-i Slave 14 (14A)
 | 28 bis 31 | gelesene E/A-Kennung, AS-i Slave 15 (15A)
0x92 | 0 bis 3 | gelesene E/A-Kennung, AS-i Slave 16 (16A)
 | 4 bis 7 | gelesene E/A-Kennung, AS-i Slave 17 (17A)
 | 8 bis 11 | gelesene E/A-Kennung, AS-i Slave 18 (18A)
 | 12 bis 15 | gelesene E/A-Kennung, AS-i Slave 19 (19A)
 | 16 bis 19 | gelesene E/A-Kennung, AS-i Slave 20 (20A)
 | 20 bis 23 | gelesene E/A-Kennung, AS-i Slave 21 (21A)
 | 24 bis 27 | gelesene E/A-Kennung, AS-i Slave 22 (22A)
 | 28 bis 31 | gelesene E/A-Kennung, AS-i Slave 23 (23A)
0x93 | 0 bis 3 | gelesene E/A-Kennung, AS-i Slave 24 (24A)
 | 4 bis 7 | gelesene E/A-Kennung, AS-i Slave 25 (25A)
 | 8 bis 11 | gelesene E/A-Kennung, AS-i Slave 26 (26A)
 | 12 bis 15 | gelesene E/A-Kennung, AS-i Slave 27 (27A)
 | 16 bis 19 | gelesene E/A-Kennung, AS-i Slave 28 (28A)
 | 20 bis 23 | gelesene E/A-Kennung, AS-i Slave 29 (29A)
 | 24 bis 27 | gelesene E/A-Kennung, AS-i Slave 30 (30A)
 | 28 bis 31 | gelesene E/A-Kennung, AS-i Slave 31 (31A)
0x94 | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | gelesene E/A-Kennung, AS-i Slave 33 (1B)
 | 8 bis 11 | gelesene E/A-Kennung, AS-i Slave 34 (2B)
 | 12 bis 15 | gelesene E/A-Kennung, AS-i Slave 35 (3B)
 | 16 bis 19 | gelesene E/A-Kennung, AS-i Slave 36 (4B)
 | 20 bis 23 | gelesene E/A-Kennung, AS-i Slave 37 (5B)
 | 24 bis 27 | gelesene E/A-Kennung, AS-i Slave 38 (6B)
 | 28 bis 31 | gelesene E/A-Kennung, AS-i Slave 39 (7B)
0x95 | 0 bis 3 | gelesene E/A-Kennung, AS-i Slave 40 (8B)
 | 4 bis 7 | gelesene E/A-Kennung, AS-i Slave 41 (9B)
 | 8 bis 11 | gelesene E/A-Kennung, AS-i Slave 42 (10B)
 | 12 bis 15 | gelesene E/A-Kennung, AS-i Slave 43 (11B)
 | 16 bis 19 | gelesene E/A-Kennung, AS-i Slave 44 (12B)
 | 20 bis 23 | gelesene E/A-Kennung, AS-i Slave 45 (13B)
 | 24 bis 27 | gelesene E/A-Kennung, AS-i Slave 46 (14B)
 | 28 bis 31 | gelesene E/A-Kennung, AS-i Slave 47 (15B)
Parameter | Bit | Beschreibung
0x96 | 0 bis 3 | gelesene E/A-Kennung, AS-i Slave 48 (16B)
 | 4 bis 7 | gelesene E/A-Kennung, AS-i Slave 49 (17B)
 | 8 bis 11 | gelesene E/A-Kennung, AS-i Slave 50 (18B)
 | 12 bis 15 | gelesene E/A-Kennung, AS-i Slave 51 (19B)
 | 16 bis 19 | gelesene E/A-Kennung, AS-i Slave 52 (20B)
 | 20 bis 23 | gelesene E/A-Kennung, AS-i Slave 53 (21B)
 | 24 bis 27 | gelesene E/A-Kennung, AS-i Slave 54 (22B)
 | 28 bis 31 | gelesene E/A-Kennung, AS-i Slave 55 (23B)
0x97 | 0 bis 3 | gelesene E/A-Kennung, AS-i Slave 56 (24B)
 | 4 bis 7 | gelesene E/A-Kennung, AS-i Slave 57 (25B)
 | 8 bis 11 | gelesene E/A-Kennung, AS-i Slave 58 (26B)
 | 12 bis 15 | gelesene E/A-Kennung, AS-i Slave 59 (27B)
 | 16 bis 19 | gelesene E/A-Kennung, AS-i Slave 60 (28B)
 | 20 bis 23 | gelesene E/A-Kennung, AS-i Slave 61 (29B)
 | 24 bis 27 | gelesene E/A-Kennung, AS-i Slave 62 (30B)
 | 28 bis 31 | gelesene E/A-Kennung, AS-i Slave 63 (31B)
Parameter 0x98 bis 0x9F: Gelesener Standard-ID-Code (Ist-Konfiguration)
Jeder AS-i Slave verfügt über einen 4-Bit Standard-ID-Code, die in den Parametern 0x98 bis 0x9F abgelegt sind (diese Parameter sind Read-Only):
Parameter | Bit | Beschreibung
0x98 | 0 bis 3 | gelesener ID-Code, AS-i Slave 0
 | 4 bis 7 | gelesener ID-Code, AS-i Slave 1 (1A)
 | 8 bis 11 | gelesener ID-Code, AS-i Slave 2 (2A)
 | 12 bis 15 | gelesener ID-Code, AS-i Slave 3 (3A)
 | 16 bis 19 | gelesener ID-Code, AS-i Slave 4 (4A)
 | 20 bis 23 | gelesener ID-Code, AS-i Slave 5 (5A)
 | 24 bis 27 | gelesener ID-Code, AS-i Slave 6 (6A)
 | 28 bis 31 | gelesener ID-Code, AS-i Slave 7 (7A)
0x99 | 0 bis 3 | gelesener ID-Code, AS-i Slave 8 (8A)
 | 4 bis 7 | gelesener ID-Code, AS-i Slave 9 (9A)
 | 8 bis 11 | gelesener ID-Code, AS-i Slave 10 (10A)
 | 12 bis 15 | gelesener ID-Code, AS-i Slave 11 (11A)
 | 16 bis 19 | gelesener ID-Code, AS-i Slave 12 (12A)
 | 20 bis 23 | gelesener ID-Code, AS-i Slave 13 (13A)
 | 24 bis 27 | gelesener ID-Code, AS-i Slave 14 (14A)
 | 28 bis 31 | gelesener ID-Code, AS-i Slave 15 (15A)
0x9A | 0 bis 3 | gelesener ID-Code, AS-i Slave 16 (16A)
 | 4 bis 7 | gelesener ID-Code, AS-i Slave 17 (17A)
 | 8 bis 11 | gelesener ID-Code, AS-i Slave 18 (18A)
 | 12 bis 15 | gelesener ID-Code, AS-i Slave 19 (19A)
 | 16 bis 19 | gelesener ID-Code, AS-i Slave 20 (20A)
 | 20 bis 23 | gelesener ID-Code, AS-i Slave 21 (21A)
 | 24 bis 27 | gelesener ID-Code, AS-i Slave 22 (22A)
 | 28 bis 31 | gelesener ID-Code, AS-i Slave 23 (23A)
0x9B | 0 bis 3 | gelesener ID-Code, AS-i Slave 24 (24A)
 | 4 bis 7 | gelesener ID-Code, AS-i Slave 25 (25A)
 | 8 bis 11 | gelesener ID-Code, AS-i Slave 26 (26A)
 | 12 bis 15 | gelesener ID-Code, AS-i Slave 27 (27A)
 | 16 bis 19 | gelesener ID-Code, AS-i Slave 28 (28A)
 | 20 bis 23 | gelesener ID-Code, AS-i Slave 29 (29A)
 | 24 bis 27 | gelesener ID-Code, AS-i Slave 30 (30A)
 | 28 bis 31 | gelesener ID-Code, AS-i Slave 31 (31A)
Parameter | Bit | Beschreibung
0x9C | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | gelesener ID-Code, AS-i Slave 33 (1B)
 | 8 bis 11 | gelesener ID-Code, AS-i Slave 34 (2B)
 | 12 bis 15 | gelesener ID-Code, AS-i Slave 35 (3B)
 | 16 bis 19 | gelesener ID-Code, AS-i Slave 36 (4B)
 | 20 bis 23 | gelesener ID-Code, AS-i Slave 37 (5B)
 | 24 bis 27 | gelesener ID-Code, AS-i Slave 38 (6B)
 | 28 bis 31 | gelesener ID-Code, AS-i Slave 39 (7B)
0x9D | 0 bis 3 | gelesener ID-Code, AS-i Slave 40 (8B)
 | 4 bis 7 | gelesener ID-Code, AS-i Slave 41 (9B)
 | 8 bis 11 | gelesener ID-Code, AS-i Slave 42 (10B)
 | 12 bis 15 | gelesener ID-Code, AS-i Slave 43 (11B)
 | 16 bis 19 | gelesener ID-Code, AS-i Slave 44 (12B)
 | 20 bis 23 | gelesener ID-Code, AS-i Slave 45 (13B)
 | 24 bis 27 | gelesener ID-Code, AS-i Slave 46 (14B)
 | 28 bis 31 | gelesener ID-Code, AS-i Slave 47 (15B)
0x9E | 0 bis 3 | gelesener ID-Code, AS-i Slave 48 (16B)
 | 4 bis 7 | gelesener ID-Code, AS-i Slave 49 (17B)
 | 8 bis 11 | gelesener ID-Code, AS-i Slave 50 (18B)
 | 12 bis 15 | gelesener ID-Code, AS-i Slave 51 (19B)
 | 16 bis 19 | gelesener ID-Code, AS-i Slave 52 (20B)
 | 20 bis 23 | gelesener ID-Code, AS-i Slave 53 (21B)
 | 24 bis 27 | gelesener ID-Code, AS-i Slave 54 (22B)
 | 28 bis 31 | gelesener ID-Code, AS-i Slave 55 (23B)
0x9F | 0 bis 3 | gelesener ID-Code, AS-i Slave 56 (24B)
 | 4 bis 7 | gelesener ID-Code, AS-i Slave 57 (25B)
 | 8 bis 11 | gelesener ID-Code, AS-i Slave 58 (26B)
 | 12 bis 15 | gelesener ID-Code, AS-i Slave 59 (27B)
 | 16 bis 19 | gelesener ID-Code, AS-i Slave 60 (28B)
 | 20 bis 23 | gelesener ID-Code, AS-i Slave 61 (29B)
 | 24 bis 27 | gelesener ID-Code, AS-i Slave 62 (30B)
 | 28 bis 31 | gelesener ID-Code, AS-i Slave 63 (31B)
Parameter 0xA0 bis 0xA7: Gelesener Status
Jeder AS-i Slave verfügt über einen 4-Bit-Status, die in den Parametern 0xA0 bis 0xA7 abgelegt sind (diese Parameter sind Read-Only):
Parameter | Bit | Beschreibung
0xA0 | 0 bis 3 | Status, AS-i Slave 0
 | 4 bis 7 | Status, AS-i Slave 1 (1A)
 | 8 bis 11 | Status, AS-i Slave 2 (2A)
 | 12 bis 15 | Status, AS-i Slave 3 (3A)
 | 16 bis 19 | Status, AS-i Slave 4 (4A)
 | 20 bis 23 | Status, AS-i Slave 5 (5A)
 | 24 bis 27 | Status, AS-i Slave 6 (6A)
 | 28 bis 31 | Status, AS-i Slave 7 (7A)
0xA1 | 0 bis 3 | Status, AS-i Slave 8 (8A)
 | 4 bis 7 | Status, AS-i Slave 9 (9A)
 | 8 bis 11 | Status, AS-i Slave 10 (10A)
 | 12 bis 15 | Status, AS-i Slave 11 (11A)
 | 16 bis 19 | Status, AS-i Slave 12 (12A)
 | 20 bis 23 | Status, AS-i Slave 13 (13A)
 | 24 bis 27 | Status, AS-i Slave 14 (14A)
 | 28 bis 31 | Status, AS-i Slave 15 (15A)
Parameter | Bit | Beschreibung
0xA2 | 0 bis 3 | Status, AS-i Slave 16 (16A)
 | 4 bis 7 | Status, AS-i Slave 17 (17A)
 | 8 bis 11 | Status, AS-i Slave 18 (18A)
 | 12 bis 15 | Status, AS-i Slave 19 (19A)
 | 16 bis 19 | Status, AS-i Slave 20 (20A)
 | 20 bis 23 | Status, AS-i Slave 21 (21A)
 | 24 bis 27 | Status, AS-i Slave 22 (22A)
 | 28 bis 31 | Status, AS-i Slave 23 (23A)
0xA3 | 0 bis 3 | Status, AS-i Slave 24 (24A)
 | 4 bis 7 | Status, AS-i Slave 25 (25A)
 | 8 bis 11 | Status, AS-i Slave 26 (26A)
 | 12 bis 15 | Status, AS-i Slave 27 (27A)
 | 16 bis 19 | Status, AS-i Slave 28 (28A)
 | 20 bis 23 | Status, AS-i Slave 29 (29A)
 | 24 bis 27 | Status, AS-i Slave 30 (30A)
 | 28 bis 31 | Status, AS-i Slave 31 (31A)
0xA4 | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | Status, AS-i Slave 33 (1B)
 | 8 bis 11 | Status, AS-i Slave 34 (2B)
 | 12 bis 15 | Status, AS-i Slave 35 (3B)
 | 16 bis 19 | Status, AS-i Slave 36 (4B)
 | 20 bis 23 | Status, AS-i Slave 37 (5B)
 | 24 bis 27 | Status, AS-i Slave 38 (6B)
 | 28 bis 31 | Status, AS-i Slave 39 (7B)
0xA5 | 0 bis 3 | Status, AS-i Slave 40 (8B)
 | 4 bis 7 | Status, AS-i Slave 41 (9B)
 | 8 bis 11 | Status, AS-i Slave 42 (10B)
 | 12 bis 15 | Status, AS-i Slave 43 (11B)
 | 16 bis 19 | Status, AS-i Slave 44 (12B)
 | 20 bis 23 | Status, AS-i Slave 45 (13B)
 | 24 bis 27 | Status, AS-i Slave 46 (14B)
 | 28 bis 31 | Status, AS-i Slave 47 (15B)
0xA6 | 0 bis 3 | Status, AS-i Slave 48 (16B)
 | 4 bis 7 | Status, AS-i Slave 49 (17B)
 | 8 bis 11 | Status, AS-i Slave 50 (18B)
 | 12 bis 15 | Status, AS-i Slave 51 (19B)
 | 16 bis 19 | Status, AS-i Slave 52 (20B)
 | 20 bis 23 | Status, AS-i Slave 53 (21B)
 | 24 bis 27 | Status, AS-i Slave 54 (22B)
 | 28 bis 31 | Status, AS-i Slave 55 (23B)
0xA7 | 0 bis 3 | Status, AS-i Slave 56 (24B)
 | 4 bis 7 | Status, AS-i Slave 57 (25B)
 | 8 bis 11 | Status, AS-i Slave 58 (26B)
 | 12 bis 15 | Status, AS-i Slave 59 (27B)
 | 16 bis 19 | Status, AS-i Slave 60 (28B)
 | 20 bis 23 | Status, AS-i Slave 61 (29B)
 | 24 bis 27 | Status, AS-i Slave 62 (30B)
 | 28 bis 31 | Status, AS-i Slave 63 (31B)
Parameter 0xA8 und 0xA9: Liste der aktuell projektierten AS-i Slaves (LPS)
In dieser Liste befinden sich die aktuell projektierten AS-i Slaves. Sobald mindestens ein AS-i Slave in dieser Liste projektiert ist, befindet sich der AS-i Master im geschützten Betriebsmodus. Diese Liste wird nur beim Übergang von der Offline- Phase in die Erkennungsphase aktualisiert, wobei dann die Liste der beim nächsten Start projektierten AS-i Slaves übernommen wird. Je AS-i Slave gibt es in den Parametern 0xA8 bis 0xA9 ein Bit, das anzeigt, ob der entsprechende AS-i Slave projektiert ist (dieser Parameter ist Read-Only):
Parameter | Bit | Beschreibung
0xA8 | 0 | reserviert
 | 1 | 0bin: AS-i Slave 1 (1A) ist nicht projektiert 1bin: AS-i Slave 1 (1A) ist projektiert
 | ... | ...
 | 31 | 0bin: AS-i Slave 31 (31A) ist nicht projektiert 1bin: AS-i Slave 31 (31A) ist projektiert
0xA9 | 0 | reserviert
 | 1 | 0bin: AS-i Slave 33 (1B) ist nicht projektiert 1bin: AS-i Slave 33 (1B) ist projektiert
 | ... | ...
 | 31 | 0bin: AS-i Slave 63 (31B) ist nicht projektiert 1bin: AS-i Slave 63 (31B) ist projektiert
Parameter 0xB0 und 0xB1: Liste der aktuell erkannten AS-i Slaves (LES)
In dieser Liste befinden sich die aktuell am Bus erkannten AS-i Slaves. Je AS-i Slave gibt es in den Parametern 0xB0 bis 0xB1 ein Bit, das anzeigt, ob der entsprechende AS-i Slave erkannt wurde (dieser Parameter ist Read-Only):
Parameter | Bit | Beschreibung
0xB0 | 0 | reserviert
 | 1 | 0bin: AS-i Slave 1 (1A) wurde nicht erkannt 1bin: AS-i Slave 1 (1A) wurde erkannt
 | ... | ...
 | 31 | 0bin: AS-i Slave 31 (31A) wurde nicht erkannt 1bin: AS-i Slave 31 (31A) wurde erkannt
0xB1 | 0 | reserviert
 | 1 | 0bin: AS-i Slave 33 (1B) wurde nicht erkannt 1bin: AS-i Slave 33 (1B) wurde erkannt
 | ... | ...
 | 31 | 0bin: AS-i Slave 63 (31B) wurde nicht erkannt 1bin: AS-i Slave 63 (31B) wurde erkannt
Parameter 0xC0 und 0xC1: Liste der Slaves, die die erweiterten ID-Codes (ID-Code 1 und ID-Code 2) unterstützen
Parameter | Bit | Beschreibung
0xC0 | 0 | Slave 0 unterstützt erweiterte ID-Codes
 | 1 | Slave 1 (1A) unterstützt erweiterte ID-Codes
 | ... | ...
 | 31 | Slave 31 (31A) unterstützt erweiterte ID-Codes
0xC1 | 0 | frei
 | 1 | Slave 1 (1B) unterstützt erweiterte ID-Codes
 | ... | ...
 | 31 | Slave 31 (31B) unterstützt erweiterte ID-Codes
Parameter 0xC8: Liste der Slaves, die die erweiterte Adressierung (als B-Slaves mit Adressen größer als 32) unterstützen
Parameter | Bit | Beschreibung
0xC8 | 0 | Slave 0 unterstützt erweiterte Adressierung
 | 1 | Slave 1 (1A) unterstützt erweiterte Adressierung
 | ... | ...
 | 31 | Slave 31 (31A) unterstützt erweiterte Adressierung
Parameter 0xB8 und 0xB9: Liste der aktivierten AS-i Slaves (LAS)
In dieser Liste befinden sich die aktuell am Bus aktivierten AS-i Slaves. Im Projektierungsmodus werden alle erkannten AS-i Slaves aktiviert, im geschützten Betriebsmodus werden nur die projektierten AS-i Slaves, bei denen ID-Code und E/A-Kennung in der Ist- und Soll-Konfiguration übereinstimmen, aktiviert. Je AS-i Slave gibt es in den Parametern 0xB8 bis 0xB9 ein Bit, das anzeigt, ob der entsprechende AS-i Slave aktiviert wurde (dieser Parameter ist Read-Only):
Parameter | Bit | Beschreibung
0xB8 | 0 | reserviert
 | 1 | 0bin: AS-i Slave 1 (1A) wurde nicht aktiviert 1bin: AS-i Slave 1 (1A) wurde aktiviert
 | ... | ...
 | 31 | 0bin: AS-i Slave 31 (31A) wurde nicht aktiviert 1bin: AS-i Slave 31 (31A) wurde aktiviert
0xB9 | 0 | reserviert
 | 1 | 0bin: AS-i Slave 33 (1B) wurde nicht aktiviert 1bin: AS-i Slave 33 (1B) wurde aktiviert
 | ... | ...
 | 31 | 0bin: AS-i Slave 63 (31B) wurde nicht aktiviert 1bin: AS-i Slave 63 (31B) wurde aktiviert
Parameter 0xD0 bis 0xD7: Gelesener Extended ID-Code 1 (Ist-Konfiguration)
AS-i Slaves verfügen optional über einen 4-Bit Extended ID-Code 1, der in den Parametern 0xD0 bis 0xD7 abgelegt sind (diese Parameter sind Read-Only):
Parameter | Bit | Beschreibung
0xD0 | 0 bis 3 | gelesener Extended ID-Code 1, AS-i Slave 0
 | 4 bis 7 | gelesener Extended ID-Code 1, AS-i Slave 1 (1A)
 | 8 bis 11 | gelesener Extended ID-Code 1, AS-i Slave 2 (2A)
 | 12 bis 15 | gelesener Extended ID-Code 1, AS-i Slave 3 (3A)
 | 16 bis 19 | gelesener Extended ID-Code 1, AS-i Slave 4 (4A)
 | 20 bis 23 | gelesener Extended ID-Code 1, AS-i Slave 5 (5A)
 | 24 bis 27 | gelesener Extended ID-Code 1, AS-i Slave 6 (6A)
 | 28 bis 31 | gelesener Extended ID-Code 1, AS-i Slave 7 (7A)
0xD1 | 0 bis 3 | gelesener Extended ID-Code 1, AS-i Slave 8 (8A)
 | 4 bis 7 | gelesener Extended ID-Code 1, AS-i Slave 9 (9A)
 | 8 bis 11 | gelesener Extended ID-Code 1, AS-i Slave 10 (10A)
 | 12 bis 15 | gelesener Extended ID-Code 1, AS-i Slave 11 (11A)
 | 16 bis 19 | gelesener Extended ID-Code 1, AS-i Slave 12 (12A)
 | 20 bis 23 | gelesener Extended ID-Code 1, AS-i Slave 13 (13A)
 | 24 bis 27 | gelesener Extended ID-Code 1, AS-i Slave 14 (14A)
 | 28 bis 31 | gelesener Extended ID-Code 1, AS-i Slave 15 (15A)
0xD2 | 0 bis 3 | gelesener Extended ID-Code 1, AS-i Slave 16 (16A)
 | 4 bis 7 | gelesener Extended ID-Code 1, AS-i Slave 17 (17A)
 | 8 bis 11 | gelesener Extended ID-Code 1, AS-i Slave 18 (18A)
 | 12 bis 15 | gelesener Extended ID-Code 1, AS-i Slave 19 (19A)
 | 16 bis 19 | gelesener Extended ID-Code 1, AS-i Slave 20 (20A)
 | 20 bis 23 | gelesener Extended ID-Code 1, AS-i Slave 21 (21A)
 | 24 bis 27 | gelesener Extended ID-Code 1, AS-i Slave 22 (22A)
 | 28 bis 31 | gelesener Extended ID-Code 1, AS-i Slave 23 (23A)
Parameter | Bit | Beschreibung
0xD3 | 0 bis 3 | gelesener Extended ID-Code 1, AS-i Slave 24 (24A)
 | 4 bis 7 | gelesener Extended ID-Code 1, AS-i Slave 25 (25A)
 | 8 bis 11 | gelesener Extended ID-Code 1, AS-i Slave 26 (26A)
 | 12 bis 15 | gelesener Extended ID-Code 1, AS-i Slave 27 (27A)
 | 16 bis 19 | gelesener Extended ID-Code 1, AS-i Slave 28 (28A)
 | 20 bis 23 | gelesener Extended ID-Code 1, AS-i Slave 29 (29A)
 | 24 bis 27 | gelesener Extended ID-Code 1, AS-i Slave 30 (30A)
 | 28 bis 31 | gelesener Extended ID-Code 1, AS-i Slave 31 (31A)
0xD4 | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | gelesener Extended ID-Code 1, AS-i Slave 33 (1B)
 | 8 bis 11 | gelesener Extended ID-Code 1, AS-i Slave 34 (2B)
 | 12 bis 15 | gelesener Extended ID-Code 1, AS-i Slave 35 (3B)
 | 16 bis 19 | gelesener Extended ID-Code 1, AS-i Slave 36 (4B)
 | 20 bis 23 | gelesener Extended ID-Code 1, AS-i Slave 37 (5B)
 | 24 bis 27 | gelesener Extended ID-Code 1, AS-i Slave 38 (6B)
 | 28 bis 31 | gelesener Extended ID-Code 1, AS-i Slave 39 (7B)
0xD5 | 0 bis 3 | gelesener Extended ID-Code 1, AS-i Slave 40 (8B)
 | 4 bis 7 | gelesener Extended ID-Code 1, AS-i Slave 41 (9B)
 | 8 bis 11 | gelesener Extended ID-Code 1, AS-i Slave 42 (10B)
 | 12 bis 15 | gelesener Extended ID-Code 1, AS-i Slave 43 (11B)
 | 16 bis 19 | gelesener Extended ID-Code 1, AS-i Slave 44 (12B)
 | 20 bis 23 | gelesener Extended ID-Code 1, AS-i Slave 45 (13B)
 | 24 bis 27 | gelesener Extended ID-Code 1, AS-i Slave 46 (14B)
 | 28 bis 31 | gelesener Extended ID-Code 1, AS-i Slave 47 (15B)
0xD6 | 0 bis 3 | gelesener Extended ID-Code 1, AS-i Slave 48 (16B)
 | 4 bis 7 | gelesener Extended ID-Code 1, AS-i Slave 49 (17B)
 | 8 bis 11 | gelesener Extended ID-Code 1, AS-i Slave 50 (18B)
 | 12 bis 15 | gelesener Extended ID-Code 1, AS-i Slave 51 (19B)
 | 16 bis 19 | gelesener Extended ID-Code 1, AS-i Slave 52 (20B)
 | 20 bis 23 | gelesener Extended ID-Code 1, AS-i Slave 53 (21B)
 | 24 bis 27 | gelesener Extended ID-Code 1, AS-i Slave 54 (22B)
 | 28 bis 31 | gelesener Extended ID-Code 1, AS-i Slave 55 (23B)
0xD7 | 0 bis 3 | gelesener Extended ID-Code 1, AS-i Slave 56 (24B)
 | 4 bis 7 | gelesener Extended ID-Code 1, AS-i Slave 57 (25B)
 | 8 bis 11 | gelesener Extended ID-Code 1, AS-i Slave 58 (26B)
 | 12 bis 15 | gelesener Extended ID-Code 1, AS-i Slave 59 (27B)
 | 16 bis 19 | gelesener Extended ID-Code 1, AS-i Slave 60 (28B)
 | 20 bis 23 | gelesener Extended ID-Code 1, AS-i Slave 61 (29B)
 | 24 bis 27 | gelesener Extended ID-Code 1, AS-i Slave 62 (30B)
 | 28 bis 31 | gelesener Extended ID-Code 1, AS-i Slave 63 (31B)
Parameter 0xD8 bis 0xDF: Gelesener Extended ID-Code 2 (Ist-Konfiguration)
AS-i Slaves verfügen optional über einen 4-Bit Extended ID-Code 2, der in den Parametern 0xD8 bis 0xDF abgelegt sind (diese Parameter sind Read-Only):
Parameter | Bit | Beschreibung
0xD8 | 0 bis 3 | gelesener Extended ID-Code 2, AS-i Slave 0
 | 4 bis 7 | gelesener Extended ID-Code 2, AS-i Slave 1 (1A)
 | 8 bis 11 | gelesener Extended ID-Code 2, AS-i Slave 2 (2A)
 | 12 bis 15 | gelesener Extended ID-Code 2, AS-i Slave 3 (3A)
 | 16 bis 19 | gelesener Extended ID-Code 2, AS-i Slave 4 (4A)
 | 20 bis 23 | gelesener Extended ID-Code 2, AS-i Slave 5 (5A)
 | 24 bis 27 | gelesener Extended ID-Code 2, AS-i Slave 6 (6A)
 | 28 bis 31 | gelesener Extended ID-Code 2, AS-i Slave 7 (7A)
Parameter | Bit | Beschreibung
0xD9 | 0 bis 3 | gelesener Extended ID-Code 2, AS-i Slave 8 (8A)
 | 4 bis 7 | gelesener Extended ID-Code 2, AS-i Slave 9 (9A)
 | 8 bis 11 | gelesener Extended ID-Code 2, AS-i Slave 10 (10A)
 | 12 bis 15 | gelesener Extended ID-Code 2, AS-i Slave 11 (11A)
 | 16 bis 19 | gelesener Extended ID-Code 2, AS-i Slave 12 (12A)
 | 20 bis 23 | gelesener Extended ID-Code 2, AS-i Slave 13 (13A)
 | 24 bis 27 | gelesener Extended ID-Code 2, AS-i Slave 14 (14A)
 | 28 bis 31 | gelesener Extended ID-Code 2, AS-i Slave 15 (15A)
0xDA | 0 bis 3 | gelesener Extended ID-Code 2, AS-i Slave 16 (16A)
 | 4 bis 7 | gelesener Extended ID-Code 2, AS-i Slave 17 (17A)
 | 8 bis 11 | gelesener Extended ID-Code 2, AS-i Slave 18 (18A)
 | 12 bis 15 | gelesener Extended ID-Code 2, AS-i Slave 19 (19A)
 | 16 bis 19 | gelesener Extended ID-Code 2, AS-i Slave 20 (20A)
 | 20 bis 23 | gelesener Extended ID-Code 2, AS-i Slave 21 (21A)
 | 24 bis 27 | gelesener Extended ID-Code 2, AS-i Slave 22 (22A)
 | 28 bis 31 | gelesener Extended ID-Code 2, AS-i Slave 23 (23A)
0xDB | 0 bis 3 | gelesener Extended ID-Code 2, AS-i Slave 24 (24A)
 | 4 bis 7 | gelesener Extended ID-Code 2, AS-i Slave 25 (25A)
 | 8 bis 11 | gelesener Extended ID-Code 2, AS-i Slave 26 (26A)
 | 12 bis 15 | gelesener Extended ID-Code 2, AS-i Slave 27 (27A)
 | 16 bis 19 | gelesener Extended ID-Code 2, AS-i Slave 28 (28A)
 | 20 bis 23 | gelesener Extended ID-Code 2, AS-i Slave 29 (29A)
 | 24 bis 27 | gelesener Extended ID-Code 2, AS-i Slave 30 (30A)
 | 28 bis 31 | gelesener Extended ID-Code 2, AS-i Slave 31 (31A)
0xDC | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | gelesener Extended ID-Code 2, AS-i Slave 33 (1B)
 | 8 bis 11 | gelesener Extended ID-Code 2, AS-i Slave 34 (2B)
 | 12 bis 15 | gelesener Extended ID-Code 2, AS-i Slave 35 (3B)
 | 16 bis 19 | gelesener Extended ID-Code 2, AS-i Slave 36 (4B)
 | 20 bis 23 | gelesener Extended ID-Code 2, AS-i Slave 37 (5B)
 | 24 bis 27 | gelesener Extended ID-Code 2, AS-i Slave 38 (6B)
 | 28 bis 31 | gelesener Extended ID-Code 2, AS-i Slave 39 (7B)
0xDD | 0 bis 3 | gelesener Extended ID-Code 2, AS-i Slave 40 (8B)
 | 4 bis 7 | gelesener Extended ID-Code 2, AS-i Slave 41 (9B)
 | 8 bis 11 | gelesener Extended ID-Code 2, AS-i Slave 42 (10B)
 | 12 bis 15 | gelesener Extended ID-Code 2, AS-i Slave 43 (11B)
 | 16 bis 19 | gelesener Extended ID-Code 2, AS-i Slave 44 (12B)
 | 20 bis 23 | gelesener Extended ID-Code 2, AS-i Slave 45 (13B)
 | 24 bis 27 | gelesener Extended ID-Code 2, AS-i Slave 46 (14B)
 | 28 bis 31 | gelesener Extended ID-Code 2, AS-i Slave 47 (15B)
0xDE | 0 bis 3 | gelesener Extended ID-Code 2, AS-i Slave 48 (16B)
 | 4 bis 7 | gelesener Extended ID-Code 2, AS-i Slave 49 (17B)
 | 8 bis 11 | gelesener Extended ID-Code 2, AS-i Slave 50 (18B)
 | 12 bis 15 | gelesener Extended ID-Code 2, AS-i Slave 51 (19B)
 | 16 bis 19 | gelesener Extended ID-Code 2, AS-i Slave 52 (20B)
 | 20 bis 23 | gelesener Extended ID-Code 2, AS-i Slave 53 (21B)
 | 24 bis 27 | gelesener Extended ID-Code 2, AS-i Slave 54 (22B)
 | 28 bis 31 | gelesener Extended ID-Code 2, AS-i Slave 55 (23B)
0xDF | 0 bis 3 | gelesener Extended ID-Code 2, AS-i Slave 56 (24B)
 | 4 bis 7 | gelesener Extended ID-Code 2, AS-i Slave 57 (25B)
 | 8 bis 11 | gelesener Extended ID-Code 2, AS-i Slave 58 (26B)
 | 12 bis 15 | gelesener Extended ID-Code 2, AS-i Slave 59 (27B)
 | 16 bis 19 | gelesener Extended ID-Code 2, AS-i Slave 60 (28B)
 | 20 bis 23 | gelesener Extended ID-Code 2, AS-i Slave 61 (29B)
 | 24 bis 27 | gelesener Extended ID-Code 2, AS-i Slave 62 (30B)
 | 28 bis 31 | gelesener Extended ID-Code 2, AS-i Slave 63 (31B)
Parameter 0xE0 bis 0xE7: Projektierter Extended ID-Code 1 (Soll-Konfiguration)
Im geschützten Betriebsmodus wird der Extended ID-Code 1 der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit Extended ID-Codes 1 der AS-i Slaves befinden sich in den Parametern 0xE0 bis 0xE7 (diese Parameter sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)):
Parameter | Bit | Beschreibung
0xE0 | 0 bis 3 | reserviert
 | 4 bis 7 | projektierter Extended ID-Code 1, AS-i Slave 1 (1A)
 | 8 bis 11 | projektierter Extended ID-Code 1, AS-i Slave 2 (2A)
 | 12 bis 15 | projektierter Extended ID-Code 1, AS-i Slave 3 (3A)
 | 16 bis 19 | projektierter Extended ID-Code 1, AS-i Slave 4 (4A)
 | 20 bis 23 | projektierter Extended ID-Code 1, AS-i Slave 5 (5A)
 | 24 bis 27 | projektierter Extended ID-Code 1, AS-i Slave 6 (6A)
 | 28 bis 31 | projektierter Extended ID-Code 1, AS-i Slave 7 (7A)
0xE1 | 0 bis 3 | projektierter Extended ID-Code 1, AS-i Slave 8 (8A)
 | 4 bis 7 | projektierter Extended ID-Code 1, AS-i Slave 9 (9A)
 | 8 bis 11 | projektierter Extended ID-Code 1, AS-i Slave 10 (10A)
 | 12 bis 15 | projektierter Extended ID-Code 1, AS-i Slave 11 (11A)
 | 16 bis 19 | projektierter Extended ID-Code 1, AS-i Slave 12 (12A)
 | 20 bis 23 | projektierter Extended ID-Code 1, AS-i Slave 13 (13A)
 | 24 bis 27 | projektierter Extended ID-Code 1, AS-i Slave 14 (14A)
 | 28 bis 31 | projektierter Extended ID-Code 1, AS-i Slave 15 (15A)
0xE2 | 0 bis 3 | projektierter Extended ID-Code 1, AS-i Slave 16 (16A)
 | 4 bis 7 | projektierter Extended ID-Code 1, AS-i Slave 17 (17A)
 | 8 bis 11 | projektierter Extended ID-Code 1, AS-i Slave 18 (18A)
 | 12 bis 15 | projektierter Extended ID-Code 1, AS-i Slave 19 (19A)
 | 16 bis 19 | projektierter Extended ID-Code 1, AS-i Slave 20 (20A)
 | 20 bis 23 | projektierter Extended ID-Code 1, AS-i Slave 21 (21A)
 | 24 bis 27 | projektierter Extended ID-Code 1, AS-i Slave 22 (22A)
 | 28 bis 31 | projektierter Extended ID-Code 1, AS-i Slave 23 (23A)
0xE3 | 0 bis 3 | projektierter Extended ID-Code 1, AS-i Slave 24 (24A)
 | 4 bis 7 | projektierter Extended ID-Code 1, AS-i Slave 25 (25A)
 | 8 bis 11 | projektierter Extended ID-Code 1, AS-i Slave 26 (26A)
 | 12 bis 15 | projektierter Extended ID-Code 1, AS-i Slave 27 (27A)
 | 16 bis 19 | projektierter Extended ID-Code 1, AS-i Slave 28 (28A)
 | 20 bis 23 | projektierter Extended ID-Code 1, AS-i Slave 29 (29A)
 | 24 bis 27 | projektierter Extended ID-Code 1, AS-i Slave 30 (30A)
 | 28 bis 31 | projektierter Extended ID-Code 1, AS-i Slave 31 (31A)
0xE4 | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | projektierter Extended ID-Code 1, AS-i Slave 33 (1B)
 | 8 bis 11 | projektierter Extended ID-Code 1, AS-i Slave 34 (2B)
 | 12 bis 15 | projektierter Extended ID-Code 1, AS-i Slave 35 (3B)
 | 16 bis 19 | projektierter Extended ID-Code 1, AS-i Slave 36 (4B)
 | 20 bis 23 | projektierter Extended ID-Code 1, AS-i Slave 37 (5B)
 | 24 bis 27 | projektierter Extended ID-Code 1, AS-i Slave 38 (6B)
 | 28 bis 31 | projektierter Extended ID-Code 1, AS-i Slave 39 (7B)
0xE5 | 0 bis 3 | projektierter Extended ID-Code 1, AS-i Slave 40 (8B)
 | 4 bis 7 | projektierter Extended ID-Code 1, AS-i Slave 41 (9B)
 | 8 bis 11 | projektierter Extended ID-Code 1, AS-i Slave 42 (10B)
 | 12 bis 15 | projektierter Extended ID-Code 1, AS-i Slave 43 (11B)
 | 16 bis 19 | projektierter Extended ID-Code 1, AS-i Slave 44 (12B)
 | 20 bis 23 | projektierter Extended ID-Code 1, AS-i Slave 45 (13B)
 | 24 bis 27 | projektierter Extended ID-Code 1, AS-i Slave 46 (14B)
 | 28 bis 31 | projektierter Extended ID-Code 1, AS-i Slave 47 (15B)
Parameter | Bit | Beschreibung
0xE6 | 0 bis 3 | projektierter Extended ID-Code 1, AS-i Slave 48 (16B)
 | 4 bis 7 | projektierter Extended ID-Code 1, AS-i Slave 49 (17B)
 | 8 bis 11 | projektierter Extended ID-Code 1, AS-i Slave 50 (18B)
 | 12 bis 15 | projektierter Extended ID-Code 1, AS-i Slave 51 (19B)
 | 16 bis 19 | projektierter Extended ID-Code 1, AS-i Slave 52 (20B)
 | 20 bis 23 | projektierter Extended ID-Code 1, AS-i Slave 53 (21B)
 | 24 bis 27 | projektierter Extended ID-Code 1, AS-i Slave 54 (22B)
 | 28 bis 31 | projektierter Extended ID-Code 1, AS-i Slave 55 (23B)
0xE7 | 0 bis 3 | projektierter Extended ID-Code 1, AS-i Slave 56 (24B)
 | 4 bis 7 | projektierter Extended ID-Code 1, AS-i Slave 57 (25B)
 | 8 bis 11 | projektierter Extended ID-Code 1, AS-i Slave 58 (26B)
 | 12 bis 15 | projektierter Extended ID-Code 1, AS-i Slave 59 (27B)
 | 16 bis 19 | projektierter Extended ID-Code 1, AS-i Slave 60 (28B)
 | 20 bis 23 | projektierter Extended ID-Code 1, AS-i Slave 61 (29B)
 | 24 bis 27 | projektierter Extended ID-Code 1, AS-i Slave 62 (30B)
 | 28 bis 31 | projektierter Extended ID-Code 1, AS-i Slave 63 (31B)
Parameter 0xE8 bis 0xEF: Projektierter Extended ID-Code 2 (Soll-Konfiguration)
Im geschützten Betriebsmodus wird der Extended ID-Code 2 der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit Extended-ID-Codes 2 der AS-i Slaves befinden sich in den Parametern 0xE8 bis 0xEF (diese Parameter sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)):
Parameter | Bit | Beschreibung
0xE8 | 0 bis 3 | reserviert
 | 4 bis 7 | projektierter Extended ID-Code 2, AS-i Slave 1 (1A)
 | 8 bis 11 | projektierter Extended ID-Code 2, AS-i Slave 2 (2A)
 | 12 bis 15 | projektierter Extended ID-Code 2, AS-i Slave 3 (3A)
 | 16 bis 19 | projektierter Extended ID-Code 2, AS-i Slave 4 (4A)
 | 20 bis 23 | projektierter Extended ID-Code 2, AS-i Slave 5 (5A)
 | 24 bis 27 | projektierter Extended ID-Code 2, AS-i Slave 6 (6A)
 | 28 bis 31 | projektierter Extended ID-Code 2, AS-i Slave 7 (7A)
0xE9 | 0 bis 3 | projektierter Extended ID-Code 2, AS-i Slave 8 (8A)
 | 4 bis 7 | projektierter Extended ID-Code 2, AS-i Slave 9 (9A)
 | 8 bis 11 | projektierter Extended ID-Code 2, AS-i Slave 10 (10A)
 | 12 bis 15 | projektierter Extended ID-Code 2, AS-i Slave 11 (11A)
 | 16 bis 19 | projektierter Extended ID-Code 2, AS-i Slave 12 (12A)
 | 20 bis 23 | projektierter Extended ID-Code 2, AS-i Slave 13 (13A)
 | 24 bis 27 | projektierter Extended ID-Code 2, AS-i Slave 14 (14A)
 | 28 bis 31 | projektierter Extended ID-Code 2, AS-i Slave 15 (15A)
0xE/A | 0 bis 3 | projektierter Extended ID-Code 2, AS-i Slave 16 (16A)
 | 4 bis 7 | projektierter Extended ID-Code 2, AS-i Slave 17 (17A)
 | 8 bis 11 | projektierter Extended ID-Code 2, AS-i Slave 18 (18A)
 | 12 bis 15 | projektierter Extended ID-Code 2, AS-i Slave 19 (19A)
 | 16 bis 19 | projektierter Extended ID-Code 2, AS-i Slave 20 (20A)
 | 20 bis 23 | projektierter Extended ID-Code 2, AS-i Slave 21 (21A)
 | 24 bis 27 | projektierter Extended ID-Code 2, AS-i Slave 22 (22A)
 | 28 bis 31 | projektierter Extended ID-Code 2, AS-i Slave 23 (23A)
0xEB | 0 bis 3 | projektierter Extended ID-Code 2, AS-i Slave 24 (24A)
 | 4 bis 7 | projektierter Extended ID-Code 2, AS-i Slave 25 (25A)
 | 8 bis 11 | projektierter Extended ID-Code 2, AS-i Slave 26 (26A)
 | 12 bis 15 | projektierter Extended ID-Code 2, AS-i Slave 27 (27A)
 | 16 bis 19 | projektierter Extended ID-Code 2, AS-i Slave 28 (28A)
 | 20 bis 23 | projektierter Extended ID-Code 2, AS-i Slave 29 (29A)
 | 24 bis 27 | projektierter Extended ID-Code 2, AS-i Slave 30 (30A)
 | 28 bis 31 | projektierter Extended ID-Code 2, AS-i Slave 31 (31A)
Parameter | Bit | Beschreibung
0xEC | 0 bis 3 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 4 bis 7 | projektierter Extended ID-Code 2, AS-i Slave 33 (1B)
 | 8 bis 11 | projektierter Extended ID-Code 2, AS-i Slave 34 (2B)
 | 12 bis 15 | projektierter Extended ID-Code 2, AS-i Slave 35 (3B)
 | 16 bis 19 | projektierter Extended ID-Code 2, AS-i Slave 36 (4B)
 | 20 bis 23 | projektierter Extended ID-Code 2, AS-i Slave 37 (5B)
 | 24 bis 27 | projektierter Extended ID-Code 2, AS-i Slave 38 (6B)
 | 28 bis 31 | projektierter Extended ID-Code 2, AS-i Slave 39 (7B)
0xED | 0 bis 3 | projektierter Extended ID-Code 2, AS-i Slave 40 (8B)
 | 4 bis 7 | projektierter Extended ID-Code 2, AS-i Slave 41 (9B)
 | 8 bis 11 | projektierter Extended ID-Code 2, AS-i Slave 42 (10B)
 | 12 bis 15 | projektierter Extended ID-Code 2, AS-i Slave 43 (11B)
 | 16 bis 19 | projektierter Extended ID-Code 2, AS-i Slave 44 (12B)
 | 20 bis 23 | projektierter Extended ID-Code 2, AS-i Slave 45 (13B)
 | 24 bis 27 | projektierter Extended ID-Code 2, AS-i Slave 46 (14B)
 | 28 bis 31 | projektierter Extended ID-Code 2, AS-i Slave 47 (15B)
0xEE | 0 bis 3 | projektierter Extended ID-Code 2, AS-i Slave 48 (16B)
 | 4 bis 7 | projektierter Extended ID-Code 2, AS-i Slave 49 (17B)
 | 8 bis 11 | projektierter Extended ID-Code 2, AS-i Slave 50 (18B)
 | 12 bis 15 | projektierter Extended ID-Code 2, AS-i Slave 51 (19B)
 | 16 bis 19 | projektierter Extended ID-Code 2, AS-i Slave 52 (20B)
 | 20 bis 23 | projektierter Extended ID-Code 2, AS-i Slave 53 (21B)
 | 24 bis 27 | projektierter Extended ID-Code 2, AS-i Slave 54 (22B)
 | 28 bis 31 | projektierter Extended ID-Code 2, AS-i Slave 55 (23B)
0xEF | 0 bis 3 | projektierter Extended ID-Code 2, AS-i Slave 56 (24B)
 | 4 bis 7 | projektierter Extended ID-Code 2, AS-i Slave 57 (25B)
 | 8 bis 11 | projektierter Extended ID-Code 2, AS-i Slave 58 (26B)
 | 12 bis 15 | projektierter Extended ID-Code 2, AS-i Slave 59 (27B)
 | 16 bis 19 | projektierter Extended ID-Code 2, AS-i Slave 60 (28B)
 | 20 bis 23 | projektierter Extended ID-Code 2, AS-i Slave 61 (29B)
 | 24 bis 27 | projektierter Extended ID-Code 2, AS-i Slave 62 (30B)
 | 28 bis 31 | projektierter Extended ID-Code 2, AS-i Slave 63 (31B)
Parameter 0xF0: Liste der Analog-Slaves
(nur bis Adresse 31, denn Analog-Slaves unterstützen die erweiterte Adressierung nicht)
Parameter | Bit | Beschreibung
0xF0 | 0 | Slave 0 ist ein Analog-Slave
 | 1 | Slave 1 ist ein Analog-Slave
 | ... | ...
 | 31 | Slave 31 ist ein Analog-Slave
Parameter 0xF8: Liste der Safety-Slaves
(nur bis Adresse 31, denn Safety-Slaves unterstützen die erweiterte Adressierung nicht)
Parameter | Bit | Beschreibung
0xF8 | 0 | Slave 0 ist ein Safety-Slave
 | 1 | Slave 1 ist ein Safety-Slave
 | ... | ...
 | 31 | Slave 31 ist ein Safety-Slave
Parameter 0x100: AS-i Kommandoschnittstelle
Mit dem Parameter 0x100 können Sie Kommandos zu den AS-i Slaves senden. Dies ist sowohl in der Offline-Phase (keine anderen Kommandos auf dem AS-i Bus) als auch in der Management-Phase möglich. In der Managementphase können Sie aber nur nicht aktivierte AS-i Slaves ansprechen (dieser Parameter ist Write-Only).
Parameter
Bit
Wert
Beschreibung
0x100
0 bis 7
0 bis 255
muss ungleich 0 sein, damit das Kommando gesendet wird
8 bis 15
1
ASI-Kommando ID-Code lesen
2
ASI-Kommando EA-Kennung lesen
3
ASI-Kommando Status lesen
4
AS-i Kommando Parameter schreiben
5
ASI-Kommando Datenaustausch
6
ASI-Kommando Reset ASI-Slave
7
AS-i Kommando Adressieraufruf
Wenn in Bit 16 bis 23 eine Adresse ungleich 0 angegeben wird, wird zuerst das AS-i Kommando "Betriebsadresse löschen" aufgerufen, da die Adresse nur eingestellt werden kann, wenn sie vorher auf 0 war.
8
AS-i Kommando Betriebsadresse löschen
16 bis 23
0 bis 31
Adresse des AS-i Slaves, an den das Kommando gehen soll
24 bis 31
0 bis 31
Daten des AS-i Kommandos:
▪
bei AS-i Kommando Parameter schreiben: Parameterdaten
▪
bei AS-i Kommando Adressieraufruf: neue Adresse
Quittung
Wenn Sie den AS-i Parameter 0x100 über Registerkommunikation zur KL6201/KL6211 schreiben, erhalten Sie als Quittung folgende Informationen:
Parameter | Bit | Beschreibung
Quittung zu 0x100 | 7 bis 0 | immer 0
 | 14 bis 8 | Entsprechen den Bits 0 bis 14 des Kommando-Aufrufs.
 | 15 | Error-Bit: Falls Bit 15 gesetzt ist, ist bei der Ausführung des Kommandos ein Fehler passiert und in Bit 31 bis 24 wird ein Fehler-Code ausgegeben!
 | 23 bis 16 | Adresse des AS-i Slaves, an den das Kommando gesendet wurde.
 | 31 bis 24 | Für Quittung zum AS-i Kommando Parameter schreiben (Bit 4 des AS-i Kommandos war gesetzt): Bit 31 bis 24 geben die im Aufruf des AS-i Kommandos übergebenen Daten (Bit 31 bis 24 des AS-i Kommandos) zurück.Für Quittung zum AS-i Kommando Adressieraufruf (Bit 7 des AS-i Kommandos war gesetzt):Adressieraufruf Falls das Error-Bit (Bit 15) nicht gesetzt ist, enthalten Bit 31 bis 24 den Wert 00hex. Falls das Error-Bit (Bit 15) gesetzt ist, enthalten Bit 31 bis 24 einen Fehler-Code. Dieser Fehler-Code wird auch bei Änderung von AS-i Adressen mit der Konfigurationssoftware KS2000 ausgegeben.
 |  | 0x00 | Die Adressänderung wurde erfolgreich durchgeführt.
 |  | 0x11 | Es ist kein Slave mit der als alte Adresse angegebenen Adresse vorhanden.
 |  | 0x22 | Die Adresse 0 wird zurzeit von einem anderen Slave belegt. Zum Ändern der Adresse eines AS-i Slaves, muss die KL6201/KL6211 diesem zuerst die Adresse 0 zuweisen, um ihn danach von dort aus neu zu Adressieren.
 |  | 0x36 | Es ist bereits ein Slave mit der als neue Adresse angegebenen Adresse vorhanden.
 |  | 0x47 | Nach dem Löschen der alten Adresse ist kein Slave mit der Adresse 0 vorhanden.
 |  | 0x58 | Nach dem Löschen der alten Adresse kommt beim Lesen des Extended ID-Code 1 von Slave 0 ein Fehler. Bei A/B-Slaves wird zur Adressänderung auch der Extended ID-Code 1 benötigt.
 |  | 0x69 | Nach dem Schreiben des Extended ID-Code 1 ist kein Slave mit Adresse 0 vorhanden.
 |  | 0x6B | Nach dem Schreiben der neuen Adresse ist der Slave mit der neuen Adresse beim Lesen des ID-Codes nicht vorhanden.
 |  | 0x6C | Nach dem Schreiben der neuen Adresse ist der Slave mit der neuen Adresse beim Lesen des Status nicht vorhanden.
 |  | 0x7D | Die Adresse konnte nicht dauerhaft (non-volatile) gespeichert werden.
 |  | 0x7E | Der Extended ID-Code eines A/B-Slaves konnte nicht dauerhaft (non-volatile) gespeichert werden.
 |  | 0x7F | ID-Code 1 ist falsch bei A/B-Slaves
 |  | 0x83 | Die neue Adresse ist eine B-Adresse. Wenn Sie auf zwei parallelen Adressen im Adressbereich A und Adressbereich B, z. B. 10A (10) und 10B (42), Slaves betreiben wollen, müssen beide Slaves die B-Adressierung unterstützen. In diesem Fall, ist auf der parallelen A-Adresse ein Slave vorhanden, der die B-Adressierung nicht unterstützt!
 |  | 0x84 | Die neue Adresse ist eine B-Adresse. Der mit der alten Adresse ausgewählte Slave ist aber kein A/B-Slave, d.h. er unterstützt die B-Adressen (33 bis 63) nicht.
 |  | 0x85 | Die neue Adresse ist eine A-Adresse. Slave ist kein A/B-Slave: zugehöriger B-Slave für neue Adresse ist vorhanden.
Parameter 0x108: Allgemeine Kommandoschnittstelle
Mit dem Parameter 0x108 können allgemeine Kommandos ausgeführt werden (dieser Parameter ist Write-Only):
Parameter | Bit | Wert | Beschreibung
0x108 | 0 bis 15 | 0x0210 | Die erkannten AS-i Slaves werden automatisch projektiert (alle AS-i Slaves werden von der LES in die LPS eingetragen, die gelesenen ID-Codes und E/A-Kennungen werden ebenfalls übernommen)
 | 16 bis 31 | 0 | reserviert
0x108 | 0 bis 15 | 0x0301 | Legt fest, welcher Data-Exchange-Repeat-Zähler über die Parameter 0x340 bis 0x35F adressiert wird.
 | 16 bis 24 | 0x01 | Repeat-Zähler für einmalige Wiederholung des Data-Exchange-Telegramms
 |  | 0x02 | Repeat-Zähler für zweimalige Wiederholung des Data-Exchange-Telegramms
 |  | 0x03 | Repeat-Zähler für dreimalige Wiederholung des Data-Exchange-Telegramms
 |  | 0x04 | Repeat-Zähler für viermalige Wiederholung des Data-Exchange-Telegramms
 |  | 0x05 | Repeat-Zähler für fünfmalige Wiederholung des Data-Exchange-Telegramms
 | 25 bis 31 | 0 | reserviert
0x108 | 0 bis 15 | 0x0C00 | Initialisierung der Stringübertragung nach Slaveprofil 7.4
 |  | 0x0C10 | Kommando Read_ID_String
 |  | 0x0C20 | Kommando Read_Diagnosis_String
 |  | 0x0C30 | Kommando Read_Parameter_String
 |  | 0x0C40 | Kommando Write_Parameter_String
 | 16 bis 23 | 0...62 | Slave-Adresse
 | 24 bis 31 | 0 | reserviert
Parameter 0x120 bis 0x12F: Allgemeine Status-Informationen
Im Parameter 0x120 ff findet sich allgemeine Status-Information zur KL6201/KL6211 und zum angeschlossenen AS-i Netz.
Parameter | Bit | Beschreibung
0x120 | 0 bis 15 | StartUp-Status (0: kein Fehler)
 | 16 bis 31 | Status automatische Projektierung (0: kein Fehler)
0x121 bis 0x127 | je 0 bis 31 | reserviert
0x128 bis 0x12F | je 0 bis 31 | reserviert
Parameter 0x140 bis 0x15F: PhysicalFault-Zähler
Je AS-i Slave gibt es einen Zähler, der inkrementiert, wenn eine Antwort dem entsprechenden AS-i Slave einen Start-Bit-, Stop-Bit- oder Parity-Bit-Fehler hatte (dieser Parameter ist Read-Write):
Parameter | Bit | Beschreibung
0x140 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 0
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 1 (1A)
0x141 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 2 (2A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 3 (3A)
0x142 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 4 (4A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 5 (5A)
0x143 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 6 (6A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 7 (7A)
0x144 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 8 (8A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 9 (9A)
0x145 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 10 (10A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 11 (11A)
0x146 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 12 (12A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 13 (13A)
0x147 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 14 (14A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 15 (15A)
0x148 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 16 (16A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 17 (17A)
Parameter | Bit | Beschreibung
0x149 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 18 (18A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 19 (19A)
0x14A | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 20 (20A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 21 (21A)
0x14B | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 22 (22A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 23 (23A)
0x14C | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 24 (24A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 25 (25A)
0x14D | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 26 (26A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 27 (27A)
0x14E | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 28 (28A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 29 (29A)
0x14F | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 30 (30A)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 31 (31A)
0x150 | 0 bis 15 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 33 (1B)
0x151 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 34 (2B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 35 (3B)
0x152 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 36 (4B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 37 (5B)
0x153 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 38 (6B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 39 (7B)
0x154 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 40 (8B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 41 (9B)
0x155 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 42 (10B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 43 (11B)
0x156 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 44 (12B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 45 (13B)
0x157 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 46 (14B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 47 (15B)
0x158 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 48 (16B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 49 (17B)
0x159 | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 50 (18B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 51 (19B)
0x15A | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 52 (20B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 53 (21B)
0x15B | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 54 (22B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 55 (23B)
0x15C | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 56 (24B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 57 (25B)
0x15D | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 58 (26B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 59 (27B)
0x15E | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 60 (28B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 61 (29B)
0x15F | 0 bis 15 | Physical-Fault-Zähler, AS-i Slave 62 (30B)
 | 16 bis 31 | Physical-Fault-Zähler, AS-i Slave 63 (31B)
Parameter 0x160 bis 0x17F: Timeout-Zähler
Je AS-i Slave gibt es einen Zähler, der inkrementiert, wenn der entsprechende AS-i Slave nicht geantwortet hat (dieser Parameter ist Read-Write):
Parameter | Bit | Beschreibung
0x160 | 0 bis 15 | Timeout-Zähler, AS-i Slave 0
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 1 (1A)
0x161 | 0 bis 15 | Timeout-Zähler, AS-i Slave 2 (2A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 3 (3A)
0x162 | 0 bis 15 | Timeout-Zähler, AS-i Slave 4 (4A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 5 (5A)
0x163 | 0 bis 15 | Timeout-Zähler, AS-i Slave 6 (6A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 7 (7A)
0x164 | 0 bis 15 | Timeout-Zähler, AS-i Slave 8 (8A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 9 (9A)
0x165 | 0 bis 15 | Timeout-Zähler, AS-i Slave 10 (10A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 11 (11A)
0x166 | 0 bis 15 | Timeout-Zähler, AS-i Slave 12 (12A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 13 (13A)
0x167 | 0 bis 15 | Timeout-Zähler, AS-i Slave 14 (14A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 15 (15A)
0x168 | 0 bis 15 | Timeout-Zähler, AS-i Slave 16 (16A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 17 (17A)
0x169 | 0 bis 15 | Timeout-Zähler, AS-i Slave 18 (18A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 19 (19A)
0x16A | 0 bis 15 | Timeout-Zähler, AS-i Slave 20 (20A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 21 (21A)
0x16B | 0 bis 15 | Timeout-Zähler, AS-i Slave 22 (22A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 23 (23A)
0x16C | 0 bis 15 | Timeout-Zähler, AS-i Slave 24 (24A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 25 (25A)
0x16D | 0 bis 15 | Timeout-Zähler, AS-i Slave 26 (26A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 27 (27A)
0x16E | 0 bis 15 | Timeout-Zähler, AS-i Slave 28 (28A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 29 (29A)
0x16F | 0 bis 15 | Timeout-Zähler, AS-i Slave 30 (30A)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 31 (31A)
0x170 | 0 bis 15 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 33 (1B)
0x171 | 0 bis 15 | Timeout-Zähler, AS-i Slave 34 (2B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 35 (3B)
0x172 | 0 bis 15 | Timeout-Zähler, AS-i Slave 36 (4B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 37 (5B)
0x173 | 0 bis 15 | Timeout-Zähler, AS-i Slave 38 (6B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 39 (7B)
0x174 | 0 bis 15 | Timeout-Zähler, AS-i Slave 40 (8B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 41 (9B)
0x175 | 0 bis 15 | Timeout-Zähler, AS-i Slave 42 (10B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 43 (11B)
0x176 | 0 bis 15 | Timeout-Zähler, AS-i Slave 44 (12B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 45 (13B)
0x177 | 0 bis 15 | Timeout-Zähler, AS-i Slave 46 (14B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 47 (15B)
0x178 | 0 bis 15 | Timeout-Zähler, AS-i Slave 48 (16B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 49 (17B)
0x179 | 0 bis 15 | Timeout-Zähler, AS-i Slave 50 (18B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 51 (19B)
Parameter | Bit | Beschreibung
0x17A | 0 bis 15 | Timeout-Zähler, AS-i Slave 52 (20B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 53 (21B)
0x17B | 0 bis 15 | Timeout-Zähler, AS-i Slave 54 (22B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 55 (23B)
0x17C | 0 bis 15 | Timeout-Zähler, AS-i Slave 56 (24B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 57 (25B)
0x17D | 0 bis 15 | Timeout-Zähler, AS-i Slave 58 (26B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 59 (27B)
0x17E | 0 bis 15 | Timeout-Zähler, AS-i Slave 60 (28B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 61 (29B)
0x17F | 0 bis 15 | Timeout-Zähler, AS-i Slave 62 (30B)
 | 16 bis 31 | Timeout-Zähler, AS-i Slave 63 (31B)
Parameter 0x180 bis 0x19F: Response-Zähler
Je AS-i Slave gibt es einen Zähler, der inkrementiert, wenn der entsprechende AS-i Slave korrekt geantwortet hat (dieser Parameter ist Read-Write):
Parameter | Bit | Beschreibung
0x180 | 0 bis 15 | Response-Zähler, AS-i Slave 0
 | 16 bis 31 | Response-Zähler, AS-i Slave 1 (1A)
0x181 | 0 bis 15 | Response-Zähler, AS-i Slave 2 (2A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 3 (3A)
0x182 | 0 bis 15 | Response-Zähler, AS-i Slave 4 (4A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 5 (5A)
0x183 | 0 bis 15 | Response-Zähler, AS-i Slave 6 (6A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 7 (7A)
0x184 | 0 bis 15 | Response-Zähler, AS-i Slave 8 (8A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 9 (9A)
0x185 | 0 bis 15 | Response-Zähler, AS-i Slave 10 (10A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 11 (11A)
0x186 | 0 bis 15 | Response-Zähler, AS-i Slave 12 (12A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 13 (13A)
0x187 | 0 bis 15 | Response-Zähler, AS-i Slave 14 (14A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 15 (15A)
0x188 | 0 bis 15 | Response-Zähler, AS-i Slave 16 (16A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 17 (17A)
0x189 | 0 bis 15 | Response-Zähler, AS-i Slave 18 (18A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 19 (19A)
0x18A | 0 bis 15 | Response-Zähler, AS-i Slave 20 (20A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 21 (21A)
0x18B | 0 bis 15 | Response-Zähler, AS-i Slave 22 (22A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 23 (23A)
0x18C | 0 bis 15 | Response-Zähler, AS-i Slave 24 (24A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 25 (25A)
0x18D | 0 bis 15 | Response-Zähler, AS-i Slave 26 (26A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 27 (27A)
0x18E | 0 bis 15 | Response-Zähler, AS-i Slave 28 (28A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 29 (29A)
0x18F | 0 bis 15 | Response-Zähler, AS-i Slave 30 (30A)
 | 16 bis 31 | Response-Zähler, AS-i Slave 31 (31A)
0x190 | 0 bis 15 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 16 bis 31 | Response-Zähler, AS-i Slave 33 (1B)
0x191 | 0 bis 15 | Response-Zähler, AS-i Slave 34 (2B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 35 (3B)
0x192 | 0 bis 15 | Response-Zähler, AS-i Slave 36 (4B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 37 (5B)
Parameter | Bit | Beschreibung
0x193 | 0 bis 15 | Response-Zähler, AS-i Slave 38 (6B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 39 (7B)
0x194 | 0 bis 15 | Response-Zähler, AS-i Slave 40 (8B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 41 (9B)
0x195 | 0 bis 15 | Response-Zähler, AS-i Slave 42 (10B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 43 (11B)
0x196 | 0 bis 15 | Response-Zähler, AS-i Slave 44 (12B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 45 (13B)
0x197 | 0 bis 15 | Response-Zähler, AS-i Slave 46 (14B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 47 (15B)
0x198 | 0 bis 15 | Response-Zähler, AS-i Slave 48 (16B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 49 (17B)
0x199 | 0 bis 15 | Response-Zähler, AS-i Slave 50 (18B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 51 (19B)
0x19A | 0 bis 15 | Response-Zähler, AS-i Slave 52 (20B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 53 (21B)
0x19B | 0 bis 15 | Response-Zähler, AS-i Slave 54 (22B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 55 (23B)
0x19C | 0 bis 15 | Response-Zähler, AS-i Slave 56 (24B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 57 (25B)
0x19D | 0 bis 15 | Response-Zähler, AS-i Slave 58 (26B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 59 (27B)
0x19E | 0 bis 15 | Response-Zähler, AS-i Slave 60 (28B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 61 (29B)
0x19F | 0 bis 15 | Response-Zähler, AS-i Slave 62 (30B)
 | 16 bis 31 | Response-Zähler, AS-i Slave 63 (31B)
Parameter 0x1A0 bis 0x1BF: Leave-Data-Exchange-Zähler
Je AS-i Slave gibt es einen Zähler, der inkrementiert, wenn der entsprechende AS-i Slave aus der LAS ausgetragen wurde, d.h. dreimal hintereinander nicht (oder nicht korrekt) geantwortet hat (dieser Parameter ist Read-Write):
Parameter | Bit | Beschreibung
0x1A0 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 0
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 1 (1A)
0x1A1 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 2 (2A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 3 (3A)
0x1A2 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 4 (4A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 5 (5A)
0x1A3 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 6 (6A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 7 (7A)
0x1A4 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 8 (8A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 9 (9A)
0x1A5 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 10 (10A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 11 (11A)
0x1A6 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 12 (12A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 13 (13A)
0x1A7 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 14 (14A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 15 (15A)
0x1A8 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 16 (16A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 17 (17A)
0x1A9 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 18 (18A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 19 (19A)
0x1AA | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 20 (20A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 21 (21A)
0x1AB | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 22 (22A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 23 (23A)
Parameter | Bit | Beschreibung
0x1AC | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 24 (24A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 25 (25A)
0x1AD | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 26 (26A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 27 (27A)
0x1AE | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 28 (28A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 29 (29A)
0x1AF | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 30 (30A)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 31 (31A)
0x1B0 | 0 bis 15 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 33 (1B)
0x1B1 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 34 (2B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 35 (3B)
0x1B2 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 36 (4B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 37 (5B)
0x1B3 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 38 (6B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 39 (7B)
0x1B4 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 40 (8B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 41 (9B)
0x1B5 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 42 (10B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 43 (11B)
0x1B6 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 44 (12B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 45 (13B)
0x1B7 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 46 (14B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 47 (15B)
0x1B8 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 48 (16B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 49 (17B)
0x1B9 | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 50 (18B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 51 (19B)
0x1BA | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 52 (20B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 53 (21B)
0x1BB | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 54 (22B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 55 (23B)
0x1BC | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 56 (24B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 57 (25B)
0x1BD | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 58 (26B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 59 (27B)
0x1BE | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 60 (28B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 61 (29B)
0x1BF | 0 bis 15 | Leave-Data-Exchange-Zähler, AS-i Slave 62 (30B)
 | 16 bis 31 | Leave-Data-Exchange-Zähler, AS-i Slave 63 (31B)
Parameter 0x1C0 bis 0x1DF: DataExch-Failed-Zähler
Je AS-i Slave gibt es einen Zähler, der inkrementiert, wenn der entsprechende AS-i Slave auf ein DataExchange-Telegramm nicht (oder nicht korrekt) geantwortet hat (dieser Parameter ist Read-Write):
Parameter | Bit | Beschreibung
0x1C0 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 0
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 1 (1A)
0x1C1 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 2 (2A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 3 (3A)
0x1C2 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 4 (4A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 5 (5A)
0x1C3 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 6 (6A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 7 (7A)
0x1C4 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 8 (8A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 9 (9A)
Parameter | Bit | Beschreibung
0x1C5 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 10 (10A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 11 (11A)
0x1C6 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 12 (12A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 13 (13A)
0x1C7 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 14 (14A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 15 (15A)
0x1C8 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 16 (16A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 17 (17A)
0x1C9 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 18 (18A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 19 (19A)
0x1CA | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 20 (20A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 21 (21A)
0x1CB | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 22 (22A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 23 (23A)
0x1CC | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 24 (24A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 25 (25A)
0x1CD | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 26 (26A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 27 (27A)
0x1CE | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 28 (28A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 29 (29A)
0x1CF | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 30 (30A)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 31 (31A)
0x1C0 | 0 bis 15 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 33 (1B)
0x1D1 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 34 (2B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 35 (3B)
0x1D2 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 36 (4B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 37 (5B)
0x1D3 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 38 (6B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 39 (7B)
0x1D4 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 40 (8B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 41 (9B)
0x1D5 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 42 (10B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 43 (11B)
0x1D6 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 44 (12B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 45 (13B)
0x1D7 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 46 (14B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 47 (15B)
0x1D8 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 48 (16B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 49 (17B)
0x1D9 | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 50 (18B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 51 (19B)
0x1DA | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 52 (20B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 53 (21B)
0x1DB | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 54 (22B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 55 (23B)
0x1DC | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 56 (24B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 57 (25B)
0x1DD | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 58 (26B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 59 (27B)
0x1DE | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 60 (28B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 61 (29B)
0x1DF | 0 bis 15 | DataExch-Failed-Zähler, AS-i Slave 62 (30B)
 | 16 bis 31 | DataExch-Failed-Zähler, AS-i Slave 63 (31B)
Parameter 0x200 bis 0x27F: Daten analoger Slaves
Parameter | Bit | Beschreibung
 |  | Kanal | wenn analoger Output |  |  | wenn analoger Input
 |  |  | Write |  | Read | Read |  | Write
0x200 | Bit 0 bis 31 | (Slave 0) | Da die Slave-Nr. 0 für analoge AS-i Slaves nicht vorgesehen ist, werden hier Nullen ins Prozessabbild übertragen.
0x201 | Bit 0 bis 31
0x202 | Bit 0 bis 31
0x203 | Bit 0 bis 31
0x204 | Bit 0 bis 15 | Slave 1, Kanal 1 | Analogwert | - |  |  | Analogwert | nicht möglich
 | Bit 16 |  | V-Flag** (Valid) | V-Flag (Valid) |  |  | V-Flag (Valid)
 | Bit 17 |  | - | - |  |  | O-Flag (Overflow)
 | Bit 21 |  | - | No Response |  |  | No Response
 | Bit 22 |  | - | Toggle-Timeout |  |  | Toggle-Timeout,
 | Bit 23 |  | - | Data-Exchange disabled* |  |  | Data-Exchange disabled*
0x205 | Bit 0 bis 15 | Slave 1, Kanal 2 | Analogwert | - |  |  | Analogwert | nicht möglich
 | Bit 16 |  | V-Flag** (Valid) | V-Flag (Valid) |  |  | V-Flag (Valid)
 | Bit 17 |  | - | - |  |  | O-Flag (Overflow)
 | Bit 21 |  | - | No Response |  |  | No Response
 | Bit 22 |  | - | Toggle-Timeout |  |  | Toggle-Timeout,
 | Bit 23 |  | - | Data-Exchange disabled* |  |  | Data-Exchange disabled*
0x206 | Bit 0 bis 15 | Slave 1, Kanal 3 | Analogwert | - |  |  | Analogwert | nicht möglich
 | Bit 16 |  | V-Flag** (Valid) | V-Flag (Valid) |  |  | V-Flag (Valid)
 | Bit 17 |  | - | - |  |  | O-Flag (Overflow)
 | Bit 21 |  | - | No Response |  |  | No Response
 | Bit 22 |  | - | Toggle-Timeout |  |  | Toggle-Timeout,
 | Bit 23 |  | - | Data-Exchange disabled* |  |  | Data-Exchange disabled*
0x207 | Bit 0 bis 15 | Slave 1, Kanal 4 | Analogwert | - |  |  | Analogwert | nicht möglich
 | Bit 16 |  | V-Flag** (Valid) | V-Flag (Valid) |  |  | V-Flag (Valid)
 | Bit 17 |  | - | - |  |  | O-Flag (Overflow)
 | Bit 21 |  | - | No Response |  |  | No Response
 | Bit 22 |  | - | Toggle-Timeout |  |  | Toggle-Timeout,
 | Bit 23 |  | - | Data-Exchange disabled* |  |  | Data-Exchange disabled*
... | ... | ... | ... | ... |  |  | ... | ...
0x27C | ... | Slave 31, Kanal 1 | ... | ... |  |  | ... | ...
0x27D | ... | Slave 31, Kanal 2 | ... | ... (siehe Mapping-Tabelle) ... |  |  | ... | ...
0x27E | ... | Slave 31, Kanal 3 | ... |  |  |  | ... | ...
0x27F | ... | Slave 31, Kanal 4 | ... | ... |  |  | ... | ...
*) wenn ASI-Control Bit 3 = 0bin
**) Das V-Flag (Valid) muss von der Steuerung gesetzt werden, damit der AS-i Slave seine Ausgänge schaltet.
Parameter 0x300: Zykluszeiten
Parameter | Bit | Beschreibung
0x300 | Bit 0-15 | aktuelle Zykluszeit in µs
 | Bit 16-31 | maximale Zykluszeit in µs
Parameter 0x310: Statistik
Parameter | Bit | Beschreibung
0x310 | Bit 0-7 | max. Anzahl Data-Exchange-Fehler je ASI-Zyklus
 | Bit 8-15 | Timeouts/Data-Exchange-Telegramme in %
 | Bit 16-31 | reserviert
Parameter 0x320 bis 0x32F: Timeout-Statistiken je AS-i Slave
Parameter | Bit | Beschreibung
0x320 | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 0
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 1 (1A)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 2 (2A)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 3 (3A)
0x321 | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 4 (4A)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 5 (5A)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 6 (6A)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 7 (7A)
0x322 | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 8 (8A)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 9 (9A)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 10 (10A)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 11 (11A)
0x323 | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 12 (12A)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 13 (13A)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 14 (14A)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 15 (15A)
0x324 | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 16 (16A)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 17 (17A)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 18 (18A)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 19 (19A)
0x325 | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 20 (20A)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 21 (21A)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 22 (22A)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 23 (23A)
0x326 | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 24 (24A)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 25 (25A)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 26 (26A)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 27 (27A)
0x327 | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 28 (28A)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 29 (29A)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 30 (30A)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 31 (31A)
0x328 | Bit 0 bis 7 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 33 (1B)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 34 (2B)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 35 (3B)
0x329 | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 36 (4B)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 37 (5B)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 38 (6B)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 39 (7B)
0x32A | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 40 (8B)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 41 (9B)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 42 (10B)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 43 (11B)
0x32B | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 44 (12B)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 45 (13B)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 46 (14B)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 47 (15B)
0x32C | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 48 (16B)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 49 (17B)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 50 (18B)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 51 (19B)
0x32D | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 52 (20B)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 53 (21B)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 54 (22B)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 55 (23B)
Parameter | Bit | Beschreibung
0x32E | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 56 (24B)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 57 (25B)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 58 (26B)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 59 (27B)
0x32F | Bit 0 bis 7 | Timeouts/Telegramm in Prozent, AS-i Slave 60 (28B)
 | Bit 8 bis 15 | Timeouts/Telegramm in Prozent, AS-i Slave 61 (29B)
 | Bit 16 bis 23 | Timeouts/Telegramm in Prozent, AS-i Slave 62 (30B)
 | Bit 24 bis 31 | Timeouts/Telegramm in Prozent, AS-i Slave 63 (31B)
Parameter 0x340 bis 0x35F: Data-Exchange-Repeat-Zähler je AS-i Slave
Es gibt 5 Repeat-Zähler, da das Data-Exchange-Telegramm bis zu sechsmal gesendet wird, bevor der Slave aus der LAS ausgetragen wird - es wird also maximal fünfmal wiederholt). Die Zähler geben an, wie oft einmal, zweimal, dreimal, viermal oder fünfmal wiederholt werden musste:
▪
Wenn z. B. der Slave bei der 4. Wiederholung wieder antwortet, wurde der Repeat-Zähler nur dreimal inkrementiert.
▪
Wenn der Slave sechsmal nicht antwortet, wird er aus der LAS ausgetragen und kein Repeat-Zähler inkrementiert.
Die Umschaltung von x, also welcher der 5 Repeat-Zähler über die Parameter 0x340 bis 0x35F adressiert wird, erfolgt über die allgemeine Kommandoschnittstelle (Parameter 0x108).
Parameter | Bit | Beschreibung
0x340 | 0 bis 15 | reserviert
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 1 (1A)
0x341 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 2 (2A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 3 (3A)
0x342 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 4 (4A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 5 (5A)
0x343 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 6 (6A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 7 (7A)
0x344 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 8 (8A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 9 (9A)
0x345 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 10 (10A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 11 (11A)
0x346 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 12 (12A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 13 (13A)
0x347 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 14 (14A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 15 (15A)
0x348 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 16 (16A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 17 (17A)
0x349 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 18 (18A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 19 (19A)
0x34A | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 20 (20A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 21 (21A)
0x34B | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 22 (22A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 23 (23A)
0x34C | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 24 (24A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 25 (25A)
0x34D | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 26 (26A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 27 (27A)
0x34E | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 28 (28A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 29 (29A)
0x34F | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 30 (30A)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 31 (31A)
0x340 | 0 bis 15 | reserviert (AS-i Slave-Adresse 32 ist nicht zulässig)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 33 (1B)
0x351 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 34 (2B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 35 (3B)
Parameter | Bit | Beschreibung
0x352 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 36 (4B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 37 (5B)
0x353 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 38 (6B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 39 (7B)
0x354 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 40 (8B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 41 (9B)
0x355 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 42 (10B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 43 (11B)
0x356 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 44 (12B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 45 (13B)
0x357 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 46 (14B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 47 (15B)
0x358 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 48 (16B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 49 (17B)
0x359 | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 50 (18B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 51 (19B)
0x35A | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 52 (20B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 53 (21B)
0x35B | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 54 (22B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 55 (23B)
0x35C | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 56 (24B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 57 (25B)
0x35D | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 58 (26B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 59 (27B)
0x35E | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 60 (28B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 61 (29B)
0x35F | 0 bis 15 | Data-Exchange-Repeat-Zähler x, AS-i Slave 62 (30B)
 | 16 bis 31 | Data-Exchange-Repeat-Zähler x, AS-i Slave 63 (31B)


Zugriff auf AS-i Parameter

Zugriff aus dem Anwenderprogramm [image] Zugriff auf AS-i Parameter
Zugriff auf AS-i Parameter
Über den Parameterdaten-Block erfolgt der Zugriff auf die Parameter der KL6201/KL6211 AS-i Master Klemme. In Folgenden sind der Schreibzugriff und der Lesezugriff mit Beispielen dokumentiert.
Schreiben eines Parameters
Um einen Parameter zu schreiben ist folgende Sequenz einzuhalten:
Überprüfen Sie Zunächst, ob der vorherige Zugriff vollständig abgeschlossen wurde. Werten Sie hierzu Status-Byte 1 aus: Bits 4 bis 7 müssen 0bin sein. Falls nicht, sind Control-Byte 0 und Control-Byte 1 auf 0 zu setzen bis die Bits 4 bis 7 im Status-Byte 1 auf 0bin gesetzt sind.
Schreibzugriff (SPS->KL6201/KL6211): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 01binA5A4 A3A2A1A0 | 0100bin A9A8A7A6 | P0...P7 | P8...P15 | P16...P23 | P24...P31
A0 bis A9: Bits der Parameteradresse
P0 bis P31: Bits des Parameter-Werts
Antwort auf Schreibzugriff (KL6201/KL6211->SPS): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status-Byte 0 | Status-Byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Wert | xxxx xxxxbin | 01F1 xxx1bin | Error-Code | Error-Code | Error-Code | Error-Code
x: Bits können beliebige Werte annehmen
F: Fehler-Bit.
F=0bin: Schreibzugriff war erfolgreich.
F=1bin: Schreibzugriff war nicht erfolgreich. Die Bytes 2 bis 5 enthalten einen Error-Code, der Aufschluss über die Fehlerursache gibt.
Die Schreib-Sequenz wird durch Nullsetzen der Control-Bytes abgeschlossen:
Abschluss Schreibzugriff (SPS->KL6201/KL6211): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 0000 0000bin | 0000 0000bin | x | x | x | x
x: Die Parameterwerte werden nicht ausgewertet wenn die Control-Bytes 0x00 sind.
Beispiel
Die Liste der projektierten Slaves (LPS) soll beschrieben werden. Der AS-i Master soll gezielt mit den AS-i Slaves mit den Knoten-Nummern 1, 2, 3, 4, 12, 16, 17 und 30 kommunizieren. Es soll also der Wert 0x4003101E (0100 0000 0000 0011 0001 0000 0001 1110bin) auf den Parameter 0xA8 (1010 1000bin) geschrieben werden.
Schreibzugriff (SPS->KL6201/KL6211): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 0110 1000bin (0x68) | 0100 0010bin (0x42) | 0x1E | 0x10 | 0x03 | 0x40
Im Parameterdaten-Block zur KL6201/KL6211 muss also die Bytefolge 0x68 42 1E 10 03 40 geschrieben werden.
Die Klemme antwortet mit folgenden Daten:
Antwort auf Schreibzugriff (KL6201/KL6211->SPS): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status-Byte 0 | Status-Byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Wert | xxxx xxxxbin | 0101 xxx1bin | 0 | 0 | 0 | 0
Die Schreib-Sequenz wird mit dieser Bytefolge abgeschlossen: 0x00 00 00 00 00 00
Lesen eines Parameters
Um einen Parameter zu lesen ist folgende Sequenz einzuhalten:
Zunächst überprüfen, ob vorheriger Zugriff vollständig abgeschlossen wurde. Hierzu muss Status1 ausgewertet werden, Bits 4 bis 7 müssen 0 sein. Falls nicht, sind Control-Byte 0 und Control-Byte 1 auf 0 zu setzen bis die Bits 4 bis 7 im Status1 auf 0 gesetzt sind.
Lesezugriff (SPS->KL6201/KL6211): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 00bin A5A4 A3A2A1A0 | 0100bin A9A8A7A6 | x | x | x | x
A0 bis A9: Bits der Parameteradresse
x: Die Parameterwerte werden nicht ausgewertet
Antwort auf Lesezugriff (KL6201/KL6211->SPS): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status-Byte 0 | Status-Byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Wert | xxxx xxxxbin | 01F1 xxx0bin | P0...P7 | P8...P15 | P16...P23 | P24...P31
x: Bits können beliebige Werte annehmen
F: Fehler-Bit.
F=0bin: Lesezugriff war erfolgreich. Die Bytes 2 bis 5 enthalten den Parameterwert.
F=1bin: Lesezugriff war nicht erfolgreich. Die Bytes 2 bis 5 enthalten einen Error-Code, der Aufschluss über die Fehlerursache gibt.
P0 bis P31: Bits des Parameter-Werts oder Error-Codes
Die Lese-Sequenz wird durch Null-setzen der Control-Bytes abgeschlossen:
Abschluss Lesezugriff (SPS->KL6201/KL6211): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 0000 0000bin | 0000 0000bin | x | x | x | x
x: Die Parameterwerte werden nicht ausgewertet wenn die Control-Bytes 0x00 sind.
Beispiel
Die Liste der erkannten Slaves (LES) soll ermittelt werden. Hierfür muss der Parameter 0xB0 (1011 0000bin) gelesen werden.
Lesezugriff (SPS->KL6201/KL6211): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control-Byte 0 | Control-Byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Wert | 0011 0000bin (0x30) | 0100 0010bin (0x42) | 0x00 | 0x00 | 0x00 | 0x00
Im Parameterdaten-Block zur KL6201/KL6211 muss also die Bytefolge 0x30 42 00 00 00 00 geschrieben werden. Die Klemme antwortet mit folgenden Daten:
Antwort auf Schreibzugriff (KL6201/KL6211->SPS): Parameterdaten-Block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status-Byte 0 | Status-Byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Wert | xxxx xxxxbin | 0101 xxx0bin | 0x4C | 0x02 | 0x80 | 0x83
Der AS-i Master soll in diesem Beispiel die Slaves mit den Knoten-Nummern 2, 3, 6, 9, 23, 24, 25 und 31 erkannt haben. Er antwortet also mit den Parameterdaten 0x8380024C (1000 0011 1000 0000 0000 0010 0100 1100bin)
Die Lese-Sequenz wird mit der Bytefolge 0x00 00 00 00 00 00 abgeschlossen.


Mapping analoger AS-i Slaves

Zugriff aus dem Anwenderprogramm [image] Mapping analoger AS-i Slaves
Mapping analoger AS-i Slaves
Die folgende Tabelle zeigt die Zuordnung der Adressbereiche zu analogen AS-i Slaves,
▪
bei Registerzugriff (über Registerkommunikation oder die Konfigurationssoftware KS2000)
▪
für PROFIBUS (Zugriff per DPV1)
Hinweis
Adressen
Analoge AS-i Slaves unterstützen nur die Adressen 1 bis 31!
Die Adressen 33 (1B) bis 63 (31B) werden von analoge AS-i Slaves nicht unterstützt!
*) Da die AS-i Adresse 0 für analoge AS-i Slaves nicht vorgesehen ist, werden für die mit einem Stern gekennzeichneten Bereiche Nullen ins Prozessabbild übertragen.
Registerzugriff |  | PROFIBUS |  | AS-i Parameter | AS-i Slave |  | Daten
Registerpage | Register | DPV1-Index | Byte |  | AS-i Adresse | Kanal
0x20 | 32 und 33 * | 0x40 | 0 bis 3 * | 0x200 | (0)* | alles Null* | 4 Byte
 | 34 und 35 * |  | 4 bis 7 * | 0x201 |  |  | 4 Byte
 | 36 und 37 * |  | 8 bis 11 * | 0x202 |  |  | 4 Byte
 | 38 und 39 * |  | 12 bis 15 * | 0x203 |  |  | 4 Byte
 | 40 und 41 |  | 16 bis 19 | 0x204 | 1 | Ch1 | 4 Byte
 | 42 und 43 |  | 20 bis 23 | 0x205 |  | Ch2 | 4 Byte
 | 44 und 45 |  | 24 bis 27 | 0x206 |  | Ch3 | 4 Byte
 | 46 und 47 |  | 28 bis 31 | 0x207 |  | Ch4 | 4 Byte
 | 48 und 49 | 0x41 | 0 bis 3 | 0x208 | 2 | Ch1 | 4 Byte
 | 50 und 51 |  | 4 bis 7 | 0x209 |  | Ch2 | 4 Byte
 | 52 und 53 |  | 8 bis 11 | 0x20A |  | Ch3 | 4 Byte
 | 54 und 55 |  | 12 bis 15 | 0x20B |  | Ch4 | 4 Byte
 | 56 und 57 |  | 16 bis 19 | 0x20C | 3 | Ch1 | 4 Byte
 | 58 und 59 |  | 20 bis 23 | 0x20D |  | Ch2 | 4 Byte
 | 60 und 61 |  | 24 bis 27 | 0x20E |  | Ch3 | 4 Byte
 | 62 und 63 |  | 28 bis 31 | 0x20F |  | Ch4 | 4 Byte
Registerzugriff |  | PROFIBUS |  | AS-i Parameter | AS-i Slave |  | Daten
Registerpage | Register | DPV1-Index | Byte |  | AS-i Adresse | Kanal
0x21 | 32 und 33 | 0x42 | 0 bis 3 | 0x210 | 4 | Ch1 | 4 Byte
 | 34 und 35 |  | 4 bis 7 | 0x211 |  | Ch2 | 4 Byte
 | 36 und 37 |  | 8 bis 11 | 0x212 |  | Ch3 | 4 Byte
 | 38 und 39 |  | 12 bis 15 | 0x213 |  | Ch4 | 4 Byte
 | 40 und 41 |  | 16 bis 19 | 0x214 | 5 | Ch1 | 4 Byte
 | 42 und 43 |  | 20 bis 23 | 0x215 |  | Ch2 | 4 Byte
 | 44 und 45 |  | 24 bis 27 | 0x216 |  | Ch3 | 4 Byte
 | 46 und 47 |  | 28 bis 31 | 0x217 |  | Ch4 | 4 Byte
 | 48 und 49 | 0x43 | 0 bis 3 | 0x218 | 6 | Ch1 | 4 Byte
 | 50 und 51 |  | 4 bis 7 | 0x219 |  | Ch2 | 4 Byte
 | 52 und 53 |  | 8 bis 11 | 0x21A |  | Ch3 | 4 Byte
 | 54 und 55 |  | 12 bis 15 | 0x21B |  | Ch4 | 4 Byte
 | 56 und 57 |  | 16 bis 19 | 0x21C | 7 | Ch1 | 4 Byte
 | 58 und 59 |  | 20 bis 23 | 0x21D |  | Ch2 | 4 Byte
 | 60 und 61 |  | 24 bis 27 | 0x21E |  | Ch3 | 4 Byte
 | 62 und 63 |  | 28 bis 31 | 0x21F |  | Ch4 | 4 Byte
0x22 | 32 und 33 | 0x44 | 0 bis 3 | 0x220 | 8 | Ch1 | 4 Byte
 | 34 und 35 |  | 4 bis 7 | 0x221 |  | Ch2 | 4 Byte
 | 36 und 37 |  | 8 bis 11 | 0x222 |  | Ch3 | 4 Byte
 | 38 und 39 |  | 12 bis 15 | 0x223 |  | Ch4 | 4 Byte
 | 40 und 41 |  | 16 bis 19 | 0x224 | 9 | Ch1 | 4 Byte
 | 42 und 43 |  | 20 bis 23 | 0x225 |  | Ch2 | 4 Byte
 | 44 und 45 |  | 24 bis 27 | 0x226 |  | Ch3 | 4 Byte
 | 46 und 47 |  | 28 bis 31 | 0x227 |  | Ch4 | 4 Byte
 | 48 und 49 | 0x45 | 0 bis 3 | 0x228 | 10 | Ch1 | 4 Byte
 | 50 und 51 |  | 4 bis 7 | 0x229 |  | Ch2 | 4 Byte
 | 52 und 53 |  | 8 bis 11 | 0x22A |  | Ch3 | 4 Byte
 | 54 und 55 |  | 12 bis 15 | 0x22B |  | Ch4 | 4 Byte
 | 56 und 57 |  | 16 bis 19 | 0x22C | 11 | Ch1 | 4 Byte
 | 58 und 59 |  | 20 bis 23 | 0x22D |  | Ch2 | 4 Byte
 | 60 und 61 |  | 24 bis 27 | 0x22E |  | Ch3 | 4 Byte
 | 62 und 63 |  | 28 bis 31 | 0x22F |  | Ch4 | 4 Byte
0x23 | 32 und 33 | 0x46 | 0 bis 3 | 0x230 | 12 | Ch1 | 4 Byte
 | 34 und 35 |  | 4 bis 7 | 0x231 |  | Ch2 | 4 Byte
 | 36 und 37 |  | 8 bis 11 | 0x232 |  | Ch3 | 4 Byte
 | 38 und 39 |  | 12 bis 15 | 0x233 |  | Ch4 | 4 Byte
 | 40 und 41 |  | 16 bis 19 | 0x234 | 13 | Ch1 | 4 Byte
 | 42 und 43 |  | 20 bis 23 | 0x235 |  | Ch2 | 4 Byte
 | 44 und 45 |  | 24 bis 27 | 0x236 |  | Ch3 | 4 Byte
 | 46 und 47 |  | 28 bis 31 | 0x237 |  | Ch4 | 4 Byte
 | 48 und 49 | 0x47 | 0 bis 3 | 0x238 | 14 | Ch1 | 4 Byte
 | 50 und 51 |  | 4 bis 7 | 0x239 |  | Ch2 | 4 Byte
 | 52 und 53 |  | 8 bis 11 | 0x23A |  | Ch3 | 4 Byte
 | 54 und 55 |  | 12 bis 15 | 0x23B |  | Ch4 | 4 Byte
 | 56 und 57 |  | 16 bis 19 | 0x23C | 15 | Ch1 | 4 Byte
 | 58 und 59 |  | 20 bis 23 | 0x23D |  | Ch2 | 4 Byte
 | 60 und 61 |  | 24 bis 27 | 0x23E |  | Ch3 | 4 Byte
 | 62 und 63 |  | 28 bis 31 | 0x23F |  | Ch4 | 4 Byte
Registerzugriff |  | PROFIBUS |  | AS-i Parameter | AS-i Slave |  | Daten
Registerpage | Register | DPV1-Index | Byte |  | AS-i Adresse | Kanal
0x24 | 32 und 33 | 0x48 | 0 bis 3 | 0x240 | 16 | Ch1 | 4 Byte
 | 34 und 35 |  | 4 bis 7 | 0x241 |  | Ch2 | 4 Byte
 | 36 und 37 |  | 8 bis 11 | 0x242 |  | Ch3 | 4 Byte
 | 38 und 39 |  | 12 bis 15 | 0x243 |  | Ch4 | 4 Byte
 | 40 und 41 |  | 16 bis 19 | 0x244 | 17 | Ch1 | 4 Byte
 | 42 und 43 |  | 20 bis 23 | 0x245 |  | Ch2 | 4 Byte
 | 44 und 45 |  | 24 bis 27 | 0x246 |  | Ch3 | 4 Byte
 | 46 und 47 |  | 28 bis 31 | 0x247 |  | Ch4 | 4 Byte
 | 48 und 49 | 0x49 | 0 bis 3 | 0x248 | 18 | Ch1 | 4 Byte
 | 50 und 51 |  | 4 bis 7 | 0x249 |  | Ch2 | 4 Byte
 | 52 und 53 |  | 8 bis 11 | 0x24A |  | Ch3 | 4 Byte
 | 54 und 55 |  | 12 bis 15 | 0x24B |  | Ch4 | 4 Byte
 | 56 und 57 |  | 16 bis 19 | 0x24C | 19 | Ch1 | 4 Byte
 | 58 und 59 |  | 20 bis 23 | 0x24D |  | Ch2 | 4 Byte
 | 60 und 61 |  | 24 bis 27 | 0x24E |  | Ch3 | 4 Byte
 | 62 und 63 |  | 28 bis 31 | 0x24F |  | Ch4 | 4 Byte
0x25 | 32 und 33 | 0x4A | 0 bis 3 | 0x250 | 20 | Ch1 | 4 Byte
 | 34 und 35 |  | 4 bis 7 | 0x251 |  | Ch2 | 4 Byte
 | 36 und 37 |  | 8 bis 11 | 0x252 |  | Ch3 | 4 Byte
 | 38 und 39 |  | 12 bis 15 | 0x253 |  | Ch4 | 4 Byte
 | 40 und 41 |  | 16 bis 19 | 0x254 | 21 | Ch1 | 4 Byte
 | 42 und 43 |  | 20 bis 23 | 0x255 |  | Ch2 | 4 Byte
 | 44 und 45 |  | 24 bis 27 | 0x256 |  | Ch3 | 4 Byte
 | 46 und 47 |  | 28 bis 31 | 0x257 |  | Ch4 | 4 Byte
 | 48 und 49 | 0x4B | 0 bis 3 | 0x258 | 22 | Ch1 | 4 Byte
 | 50 und 51 |  | 4 bis 7 | 0x259 |  | Ch2 | 4 Byte
 | 52 und 53 |  | 8 bis 11 | 0x25A |  | Ch3 | 4 Byte
 | 54 und 55 |  | 12 bis 15 | 0x25B |  | Ch4 | 4 Byte
 | 56 und 57 |  | 16 bis 19 | 0x25C | 23 | Ch1 | 4 Byte
 | 58 und 59 |  | 20 bis 23 | 0x25D |  | Ch2 | 4 Byte
 | 60 und 61 |  | 24 bis 27 | 0x25E |  | Ch3 | 4 Byte
 | 62 und 63 |  | 28 bis 31 | 0x25F |  | Ch4 | 4 Byte
0x26 | 32 und 33 | 0x4C | 0 bis 3 | 0x260 | 24 | Ch1 | 4 Byte
 | 34 und 35 |  | 4 bis 7 | 0x261 |  | Ch2 | 4 Byte
 | 36 und 37 |  | 8 bis 11 | 0x262 |  | Ch3 | 4 Byte
 | 38 und 39 |  | 12 bis 15 | 0x263 |  | Ch4 | 4 Byte
 | 40 und 41 |  | 16 bis 19 | 0x264 | 25 | Ch1 | 4 Byte
 | 42 und 43 |  | 20 bis 23 | 0x265 |  | Ch2 | 4 Byte
 | 44 und 45 |  | 24 bis 27 | 0x266 |  | Ch3 | 4 Byte
 | 46 und 47 |  | 28 bis 31 | 0x267 |  | Ch4 | 4 Byte
 | 48 und 49 | 0x4D | 0 bis 3 | 0x268 | 26 | Ch1 | 4 Byte
 | 50 und 51 |  | 4 bis 7 | 0x269 |  | Ch2 | 4 Byte
 | 52 und 53 |  | 8 bis 11 | 0x26A |  | Ch3 | 4 Byte
 | 54 und 55 |  | 12 bis 15 | 0x26B |  | Ch4 | 4 Byte
 | 56 und 57 |  | 16 bis 19 | 0x26C | 27 | Ch1 | 4 Byte
 | 58 und 59 |  | 20 bis 23 | 0x26D |  | Ch2 | 4 Byte
 | 60 und 61 |  | 24 bis 27 | 0x26E |  | Ch3 | 4 Byte
 | 62 und 63 |  | 28 bis 31 | 0x26F |  | Ch4 | 4 Byte
Registerzugriff |  | PROFIBUS |  | AS-i Parameter | AS-i Slave |  | Daten
Registerpage | Register | DPV1-Index | Byte |  | AS-i Adresse | Kanal
0x27 | 32 und 33 | 0x4E | 0 bis 3 | 0x270 | 28 | Ch1 | 4 Byte
 | 34 und 35 |  | 4 bis 7 | 0x271 |  | Ch2 | 4 Byte
 | 36 und 37 |  | 8 bis 11 | 0x272 |  | Ch3 | 4 Byte
 | 38 und 39 |  | 12 bis 15 | 0x273 |  | Ch4 | 4 Byte
 | 40 und 41 |  | 16 bis 19 | 0x274 | 29 | Ch1 | 4 Byte
 | 42 und 43 |  | 20 bis 23 | 0x275 |  | Ch2 | 4 Byte
 | 44 und 45 |  | 24 bis 27 | 0x276 |  | Ch3 | 4 Byte
 | 46 und 47 |  | 28 bis 31 | 0x277 |  | Ch4 | 4 Byte
 | 48 und 49 | 0x4F | 0 bis 3 | 0x278 | 30 | Ch1 | 4 Byte
 | 50 und 51 |  | 4 bis 7 | 0x279 |  | Ch2 | 4 Byte
 | 52 und 53 |  | 8 bis 11 | 0x27A |  | Ch3 | 4 Byte
 | 54 und 55 |  | 12 bis 15 | 0x27B |  | Ch4 | 4 Byte
 | 56 und 57 |  | 16 bis 19 | 0x27C | 31 | Ch1 | 4 Byte
 | 58 und 59 |  | 20 bis 23 | 0x27D |  | Ch2 | 4 Byte
 | 60 und 61 |  | 24 bis 27 | 0x27E |  | Ch3 | 4 Byte
 | 62 und 63 |  | 28 bis 31 | 0x27F |  | Ch4 | 4 Byte


Betrieb am Feldbus, Übersicht

Betrieb am Feldbus, Übersicht
Betrieb am Feldbus, Übersicht
Weiterführende Informationen
•
KL6201/KL6211 an PROFIBUS-Kopplern
•
KL6201/KL6211 an CANopen-Kopplern
•
Firmware-Stand der Buskoppler


KL6201/KL6211 an PROFIBUS-Kopplern

Betrieb am Feldbus, Übersicht [image] KL6201/KL6211 an PROFIBUS-Kopplern
KL6201/KL6211 an PROFIBUS-Kopplern
Kapitelübersicht
Dieses Kapitel besteht aus den Unterkapiteln:
▪
Auswahl der Größe des Prozessabbilds
▪
Mapping der Prozessdaten
▪
Zugriff auf Parameter per DPV1-Dienste
–
DPV1-Read
–
DPV1-Write (normales Schreiben)
Auswahl der Größe des Prozessabbilds
Die Größe des Prozessabbilds der AS-i Master-Klemme kann auf 6, 12, 22 oder 38 Bytes eingestellt werden. Bei den PROFIBUS-Kopplern (BK3120, BK3150, BK3500, BK3520) erfolgt die Wahl des Prozessabbilds durch Auswahl der entsprechenden Module in der DP-Konfiguration. Die Einstellung wird dabei automatisch vom Buskoppler durchgeführt.
Hinweis
Prozessabbilder
Für die Verwendung des 22 Byte oder des 38 Byte Prozessabbilds unter PROFIBUS kann auf dem Buskoppler ein bestimmter Firmware-Stand erforderlich sein (siehe Kapitel Firmware-Stand der Buskoppler). Der ausgelieferte Firmware-Stand ist auf der Rückseite des Buskopplers angegeben (siehe untenstehendes Beispiel). Bei Bedarf kann ein Firmware-Update über die serielle Schnittstelle (KS2000-Kabel erforderlich) oder über den PROFIBUS (mit der Feldbuskarte FC3101, wenn auf dem Buskoppler bereits die Firmware B8 vorhanden ist) erfolgen.
Die aktuellen Firmware-Stände und das Programm für den Firmware-Update finden Sie unter http://www.beckhoff.de. BK3120 mit KL6201/KL6211 werden in TwinCAT ab Version 2.8 (Build 739) unterstützt.
Angabe des Firmware-Standes auf dem PROFIBUS-Koppler BK3120
6 Byte Prozessabbild
Die Bytes 0 bis 5 enthalten den Parameterdaten-Block, die Bytes 6 bis 11 den Prozessdaten-Block. Die folgenden DP-Module sind möglich:
DP-Modul | Hex-Code | Beschreibung
KL6201 - PRM PAB 6 | 0xF2, 0x35 | Nur die 6 Byte des Parameterdaten-Block werden per DP übertragen.
12 Byte Prozessabbild
Die Bytes 0 bis 5 enthalten den Parameterdaten-Block, die Bytes 6 bis 11 den Prozessdaten-Block. Die folgenden DP-Module sind möglich:
DP-Modul | Hex-Code | Beschreibung
KL6201 - PRM PAB 6 | 0xF2, 0x35 | Die kompletten 12 Bytes werden per DP übertragen (Parameterdaten-Block und Prozessdaten-Block).
KL6201 - PAB 6 | 0x35 | Nur die 6 Bytes Prozessdaten-Block werden übertragen. Zugriff auf die Parameter nur per DPV1.
22 Byte Prozessabbild
Die Bytes 0 bis 5 enthalten den Parameterdaten-Block, die Bytes 6 bis 21 den Prozessdaten-Block. Die folgenden DP-Module sind möglich:
DP-Modul | Hex-Code | Beschreibung
KL6201 - PRM PAB 16 | 0xF2, 0x3F | Der Parameterdaten-Block und der Prozessdaten-Block werden übertragen.
KL6201 - PAB 16 | 0x3F | Nur der Prozessdaten-Blocks wird übertragen. Zugriff auf die Parameter nur per DPV1.
38 Byte Prozessabbild
Die Bytes 0 bis 5 enthalten den Parameterdaten-Block, die Bytes 6 bis 37 den Prozessdaten-Block. Die folgenden DP-Module sind möglich:
DP-Modul | Hex-Code | Beschreibung
KL6201 - PRM PAB 32 | 0xF2, 0xC0, 0x1F | Der Parameterdaten-Block und der Prozessdaten-Block werden übertragen.
KL6201 - PAB 32 | 0xC0, 0x1F | Nur der Prozessdaten-Blocks wird übertragen. Zugriff auf die Parameter nur per DPV1.
Mapping der Prozessdaten
Bei PROFIBUS werden die Prozessdaten linear ins Prozessabbild gemappt, d.h. das Prozessabbild-Interface der KL6201/KL6211 findet sich in der beschriebenen Reihenfolge im Prozessabbild des PROFIBUS-Masters.
Zugriff auf Parameter per DPV1
Auf die Parameter der AS-i Master-Klemme kann per DPV1 zugegriffen werden. Als Slot-Number ist dabei die Position der Klemme im Klemmenbus anzugeben, die erste Nicht-Digitale Klemme hinter dem Buskoppler erhält dabei die Slot-Number 1, die zweite Nicht-Digitale Klemme die Slot-Number 2, etc.
Mit dem Index werden die Parameter adressiert. Dabei werden bis zu 8 Parameter zusammengefasst, d.h. der Index berechnet sich aus der Parameternummer geteilt durch 8. Beim Lesen (DPV1-Read) der Parameter kann eine beliebige Länge angegeben werden, beim Schreiben (DPV1-Write) muss Doppelwort-weise (Länge muss durch 4 teilbar) bzw. beim maskierten Schreiben 8-Byte-weise (Länge muss durch 8 teilbar sein) geschrieben werden.
DPV1-Read
Die folgenden Parameter können per DPV1 gelesen werden:
Index | AS-i Parameter | Länge | Beschreibung
0x05 | 0x28 | 4 Byte | Allgemeine Informationen (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x28)
0x08 | 0x40 bis 0x47 | 32 Byte | Projektierte EA-Kennungen aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x40)
0x09 | 0x48 bis 0x4F | 32 Byte | Projektierte ID-Codes aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x48)
0x0A | 0x50 bis 0x57 | 32 Byte | Aktivierungs-Parameter der AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x50)
0x0B | 0x58 bis 0x59 | 8 Byte | Liste der beim nächsten Start projektierten AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x58)
0x0C | 0x60 bis 0x61 | 8 Byte | Liste der zu überprüfenden EA-Kennungen aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x60)
0x0D | 0x68 bis 0x69 | 8 Byte | Liste der zu überprüfenden ID-Codes aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x68)
0x0E | 0x70 bis 0x71 | 8 Byte | Liste der zu überprüfenden Extended ID-Codes 1 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x70)
0x0F | 0x78 bis 0x79 | 8 Byte | Liste der zu überprüfenden Extended ID-Codes 2 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x78)
0x10 | 0x80 bis 0x87 | 32 Byte | Digitale Inputs aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x80)
0x12 | 0x90 bis 0x97 | 32 Byte | Gelesene EA-Kennungen aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x90)
0x13 | 0x98 bis 0x9F | 32 Byte | Gelesene ID-Codes aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x98)
0x14 | 0xA0 bis 0xA7 | 32 Byte | Gelesener Status aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xA0)
0x15 | 0xA8 bis 0xA9 | 8 Byte | Liste der aktuell projektierten AS-i Slaves (LPS) (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xA8)
0x16 | 0xB0 bis 0xB1 | 8 Byte | Liste der erkannten AS-i Slaves (LES) (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xB0)
0x17 | 0xB8 bis 0xB9 | 8 Byte | Liste der aktivierten AS-i Slaves (LAS) (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xB8)
0x18 | 0xC0 bis 0xC1 | 8 Byte | Liste der Slaves, die die erweiterten ID-Codes (ID-Code 1 und ID-Code 2) unterstützen (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xC0)
0x19 | 0xC8 | 4 Byte | Liste der Slaves, die die erweiterte Adressierung (als B-Slaves mit Adressen größer als 32) unterstützen (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xC8)
0x1A | 0xD0 bis 0xD7 | 32 Byte | Gelesene Extended ID-Codes 1 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xD0)
0x1B | 0xD8 bis 0xDF | 32 Byte | Gelesene Extended ID-Codes 2 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xD8)
0x1C | 0xE0 bis 0xE7 | 32 Byte | Projektierte Extended ID-Codes 1 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xE0)
0x1D | 0xE8 bis 0xEF | 32 Byte | Projektierte Extended ID-Codes 2 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xE8)
0x1E | 0xF0 | 4 Byte | Liste der Analog-Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xF0)
0x1F | 0xF8 | 4 Byte | Liste der Safety-Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xF8)
0x20 | 0x100 | 8 Byte | AS-i Kommandoschnittstelle, Response (Byte 0 entspricht der Antwort bei Parameter 0x100)
0x24 | 0x120 bis 0x12F | 2 Byte | StartUp-Status (0: kein Fehler)
 |  | 2 Byte | Status automatische Projektierung (0: kein Fehler)
 | 0x121 bis 0x127 | 28 Byte | reserviert
0x25 | 0x128 bis 0x12F | 32 Byte | reserviert
0x28 | 0x140 bis 0x147 | 32 Byte | PhysicalFault-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x140)
0x29 | 0x148 bis 0x14F | 32 Byte | PhysicalFault-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x148)
0x2A | 0x150 bis 0x157 | 32 Byte | PhysicalFault-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x150)
Index | AS-i Parameter | Länge | Beschreibung
0x2B | 0x158 bis 0x15F | 32 Byte | PhysicalFault-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x158)
0x2C | 0x160 bis 0x167 | 32 Byte | Timeout-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x160)
0x2D | 0x168 bis 0x16F | 32 Byte | Timeout-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x168)
0x2E | 0x170 bis 0x177 | 32 Byte | Timeout-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x170)
0x2F | 0x178 bis 0x17F | 32 Byte | Timeout-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x178)
0x30 | 0x180 bis 0x187 | 32 Byte | Response-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x180)
0x31 | 0x188 bis 0x18F | 32 Byte | Response-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x188)
0x32 | 0x190 bis 0x197 | 32 Byte | Response-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x190)
0x33 | 0x198 bis 0x19F | 32 Byte | Response-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x198)
0x34 | 0x1A0 bis 0x1A7 | 32 Byte | Leave-DataExch-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1A0)
0x35 | 0x1A8 bis 0x1AF | 32 Byte | Leave-DataExch-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1A8)
0x36 | 0x1B0 bis 0x1B7 | 32 Byte | Leave-DataExch-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1B0)
0x37 | 0x1B8 bis 0x1BF | 32 Byte | Leave-DataExch-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1B8)
0x38 | 0x1C0 bis 0x1C7 | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1C0)
0x39 | 0x1C8 bis 0x1CF | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1C8)
0x3A | 0x1D0 bis 0x1D7 | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1D0)
0x3B | 0x1D8 bis 0x1DF | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1D8)
0x40 | 0x200 bis 0x207 | 32 Byte | 16 Leer-Bytes und Eingangsdaten AS-i Analog-Slave 1 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x200) | siehe Mapping- Tabelle
0x41 | 0x208 bis 0x20F | 32 Byte | Eingangsdaten, AS-i Analog-Slave 1 und 2 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x208)
... | ... | ... | ...
0x4F | 0x278 bis 0x27F | 32 Byte | Eingangsdaten, AS-i Analog-Slave 30 und 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x278)
0x60 | 0x300 | 4 Byte | Zykluszeiten (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x300)
0x62 | 0x310 | 8 Byte | Statistik (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x310)
0x64 | 0x320 bis 0x327 | 32 Byte | Timeout-Statistiken, AS-i Slave 0 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x320)
0x65 | 0x328 bis 0x32F | 32 Byte | Timeout-Statistiken, AS-i Slave 32 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x328)
0x68 | 0x340 bis 0x347 | 32 Byte | Data-Exchange-Repeat-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x340)
0x69 | 0x348 bis 0x34F | 32 Byte | Data-Exchange-Repeat-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x348)
0x6A | 0x350 bis 0x357 | 32 Byte | Data-Exchange-Repeat-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x350)
0x6B | 0x358 bis 0x35F | 32 Byte | Data-Exchange-Repeat-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x358)
DPV1-Write (normales Schreiben)
Die folgenden Parameter können per DPV1 geschrieben werden:
Index | AS-i Parameter | Länge | Beschreibung
0x08 | 0x40 bis 0x47 | 32 Byte | Projektierte E/A-Kennungen aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x40)
0x09 | 0x48 bis 0x4F | 32 Byte | Projektierte ID-Codes aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x48)
0x0A | 0x50 bis 0x57 | 32 Byte | Aktivierungs-Parameter der AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x50)
0x0B | 0x58 bis 0x59 | 8 Byte | Liste der beim nächsten Start projektierten AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x58)
0x0C | 0x60 bis 0x61 | 8 Byte | Liste der zu überprüfenden EA-Kennungen aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x60)
0x0D | 0x68 bis 0x69 | 8 Byte | Liste der zu überprüfenden ID-Codes aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x68)
0x0E | 0x70 bis 0x71 | 8 Byte | Liste der zu überprüfenden Extended ID-Codes 1 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x70)
0x0F | 0x78 bis 0x79 | 8 Byte | Liste der zu überprüfenden Extended ID-Codes 2 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x78)
0x10 | 0x80 bis 0x87 | 32 Byte | Digitale Outputs aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x80)
0x1C | 0xE0 bis 0xE7 | 32 Byte | Liste der zu überprüfenden Extended ID-Codes 1 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xE0)
0x1D | 0xE8 bis 0xEF | 32 Byte | Liste der zu überprüfenden Extended ID-Codes 2 aller AS-i Slaves (Byte 0 entspricht Bit 0 bis 7 des Parameters 0xE8)
0x20 | 0x100 | 4 Byte | AS-i Kommandoschnittstelle, Request (Byte 0 entspricht dem Auftrag bei Parameter 0x100)
0x21 | 0x108 | 4 Byte | Allgemeine Kommandoschnittstelle (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x108)
0x28 | 0x140 bis 0x147 | 32 Byte | PhysicalFault-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x140)
0x29 | 0x148 bis 0x14F | 32 Byte | PhysicalFault-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x148)
0x2A | 0x150 bis 0x157 | 32 Byte | PhysicalFault-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x150)
0x2B | 0x158 bis 0x15F | 32 Byte | PhysicalFault-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x158)
0x2C | 0x160 bis 0x167 | 32 Byte | Timeout-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x160)
0x2D | 0x168 bis 0x16F | 32 Byte | Timeout-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x168)
0x2E | 0x170 bis 0x177 | 32 Byte | Timeout-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x170)
0x2F | 0x178 bis 0x17F | 32 Byte | Timeout-Zähler, AS-i Slave 48 bis 4F (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x178)
0x30 | 0x180 bis 0x187 | 32 Byte | Response-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x180)
0x31 | 0x188 bis 0x18F | 32 Byte | Response-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x188)
0x32 | 0x190 bis 0x197 | 32 Byte | Response-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x190)
0x33 | 0x198 bis 0x19F | 32 Byte | Response-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x198)
0x34 | 0x1A0 bis 0x1A7 | 32 Byte | Leave-DataExch-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1A0)
0x35 | 0x1A8 bis 0x1AF | 32 Byte | Leave-DataExch-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1A8)
0x36 | 0x1B0 bis 0x1B7 | 32 Byte | Leave-DataExch-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1B0)
0x37 | 0x1B8 bis 0x1BF | 32 Byte | Leave-DataExch-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1B8)
0x38 | 0x1C0 bis 0x1C7 | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1C0)
0x39 | 0x1C8 bis 0x1CF | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1C8)
Index | AS-i Parameter | Länge | Beschreibung
0x3A | 0x1D0 bis 0x1D7 | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1D0)
0x3B | 0x1D8 bis 0x1DF | 32 Byte | DataExch-Failed-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x1D8)
0x40 | 0x200 bis 0x207 | 32 Byte | 16 Leer-Bytes und Ausgangsdaten AS-i Analog-Slave 1 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x200) | siehe Mapping- Tabelle
0x41 | 0x208 bis 0x20F | 32 Byte | Ausgangsdaten, AS-i Analog-Slave 1 und 2 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x208)
... | ... | ... | ...
0x4F | 0x278 bis 0x27F | 32 Byte | Ausgangsdaten, AS-i Analog-Slave 30 und 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x278)
0x60 | 0x300 | 4 Byte | Zykluszeiten (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x300)
0x62 | 0x310 | 8 Byte | Statistik (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x310)
0x64 | 0x320 bis 0x327 | 32 Byte | Timeout-Statistiken, AS-i Slave 0 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x320)
0x65 | 0x328 bis 0x32F | 32 Byte | Timeout-Statistiken, AS-i Slave 32 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x328)
0x68 | 0x340 bis 0x347 | 32 Byte | Data-Exchange-Repeat-Zähler, AS-i Slave 0 bis 15 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x340)
0x69 | 0x348 bis 0x34F | 32 Byte | Data-Exchange-Repeat-Zähler, AS-i Slave 16 bis 31 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x348)
0x6A | 0x350 bis 0x357 | 32 Byte | Data-Exchange-Repeat-Zähler, AS-i Slave 32 bis 47 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x350)
0x6B | 0x358 bis 0x35F | 32 Byte | Data-Exchange-Repeat-Zähler, AS-i Slave 48 bis 63 (Byte 0 entspricht Bit 0 bis 7 des Parameters 0x358)


KL6201/KL6211 an CANopen-Kopplern

Betrieb am Feldbus, Übersicht [image] KL6201/KL6211 an CANopen-Kopplern
KL6201/KL6211 an CANopen-Kopplern
Kapitelübersicht
Dieses Kapitel besteht aus den Unterkapiteln:
▪
Auswahl der Größe des Prozessabbilds
▪
Mapping der Prozessdaten
–
6 Byte Prozessabbild
–
12 Byte Prozessabbild
–
22 Byte Prozessabbild
–
38 Byte Prozessabbild
▪
Zugriff auf Parameter
Auswahl der Größe des Prozessabbilds
Die Größe des Prozessabbilds der AS-i Master-Klemme kann auf 6, 12, 22 oder 38 Byte eingestellt werden. Dies kann mit Hilfe der Konfigurations-Software KS2000 oder über den Feldbus erfolgen. Hierzu muss der Parameter 0x20 über den Parameterdatenblock verändert werden (siehe AS-i Parameter 0x20). Anschließend muss ein Reset des Buskopplers erfolgen - der Koppler startet dann mit der zuletzt gewählten Prozessabbildgröße auf.
Hinweis
Prozessabbilder
Für die Verwendung des 22 Byte oder des 38 Byte Prozessabbilds unter CANopen kann auf dem Buskoppler ein bestimmter Firmware-Stand erforderlich sein (siehe Kapitel Firmware-Stand der Buskoppler). Der ausgelieferte Firmware-Stand ist auf der Rückseite des Buskopplers angegeben (siehe untenstehendes Beispiel). Bei Bedarf kann ein Firmware-Update über die serielle Schnittstelle (KS2000-Kabel erforderlich) oder über CANopen (mit der Feldbuskarte FC5101, wenn auf dem Buskoppler bereits die Firmware C2 vorhanden ist) erfolgen.
Die aktuellen Firmware-Stände und das Programm für das Firmware-Update finden Sie unter http://www.beckhoff.de. BK5120 mit KL6201/KL6211 werden in TwinCAT ab Version 2.8 (Build 739) unterstützt.
Angabe des Firmware-Standes auf dem CANopen-Koppler BK5120
Mapping der Prozessdaten
Das Prozessabbild der KL6201/KL6211 wird bei den CANopen Buskopplern auf mehrere 8-Byte Datenobjekte abgebildet. Die 8-Byte Datenobjekte finden sich im CANopen Objektverzeichnis bei Index 0x3000 (Eingangsdaten) bzw. Index 0x3100 (Ausgangsdaten). Der Koppler mappt diese Objekte beim Aufstarten automatisch in das jeweils erste freie PDO (ab PDO3).
6 Byte Prozessabbild
Parameterdatenblock
Das 6 Byte Prozessabbild besteht nur aus dem Parameterdatenblock ergänzt um 2 Dummy-Bytes. Dieser Block findet sich bei Index 0x3000 und wird komplett in ein PDO gemappt.
Das 6 Byte Prozessabbild unterstützt im Gegensatz zu den anderen Prozessabbildern keinen direkten Zugriff auf die Prozessdaten der AS-i Slaves! Der Prozessdatenzugriff muss über die AS-i Parameter 0x80 bis 0x87 (digitale Slaves) oder 0x204 bis 0x27F (analoge Slaves) erfolgen.
Das TxPDO (KL6201/KL6211 -> SPS) mit den Eingangsdaten (Index 0x3000) hat folgende Struktur:
Parameterdatenblock |  |  |  |  |  | Dummy-Bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
SB0 | SB1 | Para In 0 | Para In 1 | Para In 2 | Para In 3 | reserviert | reserviert
Das RxPDO (SPS -> KL6201/KL6211) mit den Ausgangsdaten (Index 0x3100) hat folgende Struktur:
Parameterdatenblock |  |  |  |  |  | Dummy-Bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
CB0 | CB1 | Para Out 0 | Para Out 1 | Para Out 2 | Para Out 3 | reserviert | reserviert
Legende
SB n: Status-Byte n
CB n: Control-Byte n
Para Out n: Ausgangsparameter, Byte n
Para In n: Eingangsparameter, Byte n
12 Byte Prozessabbild
Parameterdatenblock
Im ersten 8-Byte Objekt findet sich der Parameterdatenblock, ergänzt um 2 Dummy-Bytes. Dieser Block findet sich bei Index 0x3000 und wird komplett in ein PDO gemappt.
Das TxPDO (KL6201/KL6211 -> SPS) mit den Eingangsdaten (Index 0x3000) hat folgende Struktur:
Parameterdatenblock |  |  |  |  |  | Dummy-Bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
SB0 | SB1 | Para In 0 | Para In 1 | Para In 2 | Para In 3 | reserviert | reserviert
Das RxPDO (SPS -> KL6201/KL6211) mit den Ausgangsdaten (Index 0x3100) hat folgende Struktur:
Parameterdatenblock |  |  |  |  |  | Dummy-Bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
CB0 | CB1 | Para Out 0 | Para Out 1 | Para Out 2 | Para Out 3 | reserviert | reserviert
Legende
SB n: Status-Byte n
CB n: Control-Byte n
Para Out n: Ausgangsparameter, Byte n
Para In n: Eingangsparameter, Byte n
Prozessdaten-Block
Das nächste 8-Byte Objekt enthält den Prozessdatenblock mit AS-i Status-Nibble (ASI SN)sowie die AS-i Eingangsdaten. Das nächste TxPDO (KL6201/KL6211 -> SPS) hat also folgende Belegung:
Prozessdatenblock |  |  |  |  |  | Dummy-Bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
ASiSN + ASiIn Slave 1 | ASiIn Slave 2+3 | ASiIn Slave 4+5 | ASiIn Slave 6+7 | ASiIn Slave 8+9 | ASiIn Slave 10+11 | reserviert | reserviert
Das nächste RxPDO (SPS -> KL6201/KL6211) enthält das AS-i Command-Nibble (ASI CN) und die AS-i Ausgangsdaten:
Prozessdatenblock |  |  |  |  |  | Dummy-Bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
ASiCN + ASiOut Slave 1 | ASiOut Slave 2+3 | ASiOut Slave 4+5 | ASiOut Slave 6+7 | ASiOut Slave 8+9 | ASiOut Slave 10+11 | reserviert | reserviert
Legende
ASiSN: AS-i Status-Nibble
ASi CN: AS-i Command-Nibble
ASiIn Slave x+y: Eingangsdaten der AS-i Slaves x und y (ein Nibble pro Slave)
ASiOut Slave x+y: Ausgangsdaten der AS-i Slaves x und y (ein Nibble pro Slave)
Die Abbildung der AS-i Daten auf die CANopen-Prosessdatenobjekte (PDO) sieht also beim12 Byte Prozessabbild wie folgt aus:
Abbildung der AS-i Daten auf die CANopen-Prosessdatenobjekte beim12 Byte Prozessabbild
22 Byte Prozessabbild
Parameterdatenblock
Siehe 12 Byte Prozessabbild.
Prozessdatenblock
Falls das 22 Byte Prozessabbild angewählt wurde (AS-i-Slave Adressen > 11 in Benutzung), so werden die Dummy Bytes für weitere Prozessdaten genutzt (Slave-Adressen 12 bis 31). Außerdem wird jeweils ein weiteres 8 Byte Objekt mit Prozessdaten für die Slaves 16 bis 31 in Index 0x3000 bzw. 0x3100 angelegt und in das nächste freie PDO gemappt.
Prozessdatenblock
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | ... | Byte 15
ASiSN + ASiIn Slave 1 | ASiIn Slave 2+3 | ASiIn Slave 4+5 | ASiIn Slave 6+7 | ASiIn Slave 8+9 | ASiIn Slave 10+11 | ... | ASiIn Slave 30+31
Das nächste RxPDO (SPS -> KL6201/KL6211) enthält das AS-i Command-Nibble (ASI CN) und die AS-i Ausgangsdaten:
Prozessdatenblock
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | ... | Byte 15
ASiCN + ASI Out Slave 1 | ASiOut Slave 2+3 | ASiOut Slave 4+5 | ASiOut Slave 6+7 | ASiOut Slave 8+9 | ASiOut Slave 10+11 | ... | ASiOut Slave 30+31
Legende
Siehe 12 Byte Prozessabbild.
Entsprechend stellt sich die Abbildung der AS-i Daten auf die CANopen-Prosessdatenobjekte (PDO) beim 22 Byte Prozessabbild dar:
Abbildung der AS-i Daten auf die CANopen-Prosessdatenobjekte beim 22 Byte Prozessabbild
38 Byte Prozessabbild
Parameterdatenblock
Siehe 12 Byte Prozessabbild.
Prozessdatenblock
Falls das 38 Byte Prozessabbild angewählt wurde (AS-i Slave-Adressen > 32 in Benutzung), so wird jeweils ein weiteres 8 Byte Objekt mit Prozessdaten für die AS-i Slaves 33 bis 63 in Index 0x3000 bzw. 0x3100 angelegt und in das nächste freie PDO gemappt.
Entsprechend sieht die Abbildung der AS-i Daten für Slave-Adressen oberhalb von 32 auf das zusätzliche CANopen PDO beim 38 Byte Prozessabbild aus (PDO n, PDO n+1, PDO n+2 wie beim 22 Byte Prozessabbild):
Abbildung der AS-i Daten auf die CANopen-Prosessdatenobjekte beim 38 Byte Prozessabbild
Mapping Beispiel
Ein BK5120 (Buskoppler für CANopen) hat
▪
78 digitale Ein- und 48 digitale Ausgänge
▪
6 analoge Eingänge und 4 analoge Ausgänge
▪
eine KL5001 (SSI-Geber Interface: per default 4 Byte Eingänge)
▪
eine KL6001 (serielle Schnittstelle: per default 4 Byte Eingänge und 4 Byte Ausgänge)
▪
eine KL5111 (Inkrementalenkoder-Interface) (6 Byte Eingänge und 6 Byte Ausgänge)
▪
eine KL6201/KL6211 AS-i Masterklemme mit Default-Einstellung (22 Byte Prozessabbild)
PDO | Dateninhalt (Mapping) | Objektver- zeichnis | PDO | Dateninhalt (Mapping) | Objektver- zeichnis
RxPDO1 | 5 Bytes digitale Ausgänge 1..48 | 0x6200, SI 1...5 | TxPDO1 | 8 Bytes digitale Eingänge 1...64 | 0x6000, SI 1...8
RxPDO2 | 8 Bytes analoge Ausgänge 1..4 | 0x6411, SI 1...4 | TxPDO2 | 4 Bytes analoge Eingänge 1...4 | 0x6401, SI 1...4
RxPDO3 | 4 Bytes serielle Schnittstelle | 0x2900, SI 1 | TxPDO3 | 2 Bytes digitale Eingänge 65...78 | 0x6000, SI 9...10
RxPDO4 | 6 Byte Encoder Ausgänge | 0x2D00, SI 1 | TxPDO4 | analoge Eingänge 5 und 6 | 0x6401, SI 5..6
RxPDO5 | 8 Byte AS-i Master 1: Parameterdaten-Block | 0x3100, SI 1 | TxPDO5 | 8 Bytes: 4 Bytes SSI und 4 Bytes serielle Schnittstelle | 0x2800, SI 1...2
RxPDO6 | 8 Byte AS-i Master 1: Prozessdaten-Block Outputs AS-i Slave 1...15 | 0x3100, SI 2 | TxPDO6 | 6 Byte Encoder Ein | 0x2C00, SI 1
RxPDO7 | 8 Byte AS-i Master 1: Prozessdaten-Block Outputs AS-i Slave 16...31 | 0x3100, SI 3 | TxPDO7 | 8 Byte AS-i Master 1: Parameterdaten-Block | 0x3000, SI 1
 |  |  | TxPDO8 | 8 Byte AS-i Master 1: Prozessdaten-Block Inputs AS-i Slave 1...15 | 0x3000, SI 2
 |  |  | TxPDO9 | 8 Byte AS-i Master 1: Prozessdaten-Block Inputs AS-i Slave 16...31 | 0x3000, SI 3
Zugriff auf Parameter der KL6201/KL6211
Die Parameter der KL6201/KL6211 sind über den Parameterdaten-Block im jeweils ersten Receive-Prozessdatenobjekt (RxPDO) und Transmit-Prozessdatenobjekt (TxPDO) erreichbar.
Allgemeine Beispiele für den Zugriff auf die Parameter finden Sie im Kapitel Zugriff auf AS-i Parameter.


Firmware-Stand der Buskoppler

Betrieb am Feldbus, Übersicht [image] Firmware-Stand der Buskoppler
Firmware-Stand der Buskoppler
Hinweis
Erforderliche Firmware
Zum Betrieb der AS-i Masterklemmen KL6201/KL6211 kann auf dem Buskoppler / Busklemmen Controller ein bestimmter Firmware-Stand erforderlich sein (siehe untenstehende Tabelle)!
Im Auslieferungszustand ist die KL6201/KL6211 auf ein Prozessabbild von 12 Byte eingestellt. Die meisten in der Tabelle aufgeführten Buskoppler und Busklemmen Controller unterstützen Prozessabbilder von 6 und 12 Byte.
Nicht aufgeführte Buskoppler / Busklemmen Controller
▪
benötigen zum Betrieb des 6 Byte und des 12 Byte Prozessabbilds auf der KL6201/KL6211 eine Klemmen-Firmware-Version ab B7.
▪
sind noch nicht für den Betrieb der 22 Byte und des 38 Byte Prozessabbilds vorbereitet.
Der ausgelieferte Firmware-Stand ist auf der Rückseite des Buskopplers angegeben (siehe untenstehendes Beispiel für CANopen).
Angabe des Firmware-Standes auf einem Buskoppler
Bei Bedarf kann ein Firmware-Update über die serielle Schnittstelle (KS2000-Kabel erforderlich) oder - je nach Bussystem - auch über den Feldbus erfolgen. Die aktuellen Firmware-Stände und das Programm für das Firmware-Update finden Sie auf unserer Homepage http://www.beckhoff.de.
Unterstützung der verschiedenen Prozessabbilder durch die Firmware-Versionen der Buskoppler / Busklemmen Controller
Feldbus- System | Buskoppler / Busklemmen Controller | Auf dem Buskoppler / Busklemmen Controller erforderlicher Firmware-Stand zum Betrieb des
 |  | 6 Byte Prozessabbild (kein direkter Zugriff auf AS-i Slaves) | 12 Byte Prozessabbild (AS-i Slave Adressen 1 bis 11) | 22 Byte Prozessabbild (AS-i Slave Adressen 1 bis 31) | 38 Byte Prozessabbild (AS-i Slave Adressen 1 bis 62)
EtherCAT | BK1120 | Diese Buskoppler und Busklemmen Controller unterstützen das 6 und das 12 Byte Prozessabbild der KL6201/KL6211. |  | ab 08 (B8) | ab 08 (B8)
 | BK1250 |  |  | alle | alle
Lightbus | BK2020 |  |  | ab B1 | in Vorbereitung
PROFIBUS | BK3120 |  |  | ab B9 | ab BB
 | BK3150 |  |  | alle | alle
 | BK3500 |  |  | ab B9 | ab BB
 | BK3520 |  |  | ab B9 | ab BB
 | BC3100 |  |  | ab C3 | ab C4
 | BC3150 |  |  | alle | alle
 | BX3100 |  |  | alle | alle
Interbus | BK4020 |  |  | ab B0 | in Vorbereitung
 | BC4000 |  |  | ab B3 | in Vorbereitung
CANopen | BK5120 |  |  | ab C4 | ab C5
 | BK5150 |  |  | alle | alle
 | BC5150 |  |  | alle | alle
 | BX5100 |  |  | alle | alle
DeviceNet | BK5220 |  |  | (ab B3)* | in Vorbereitung
 | BC5250 |  |  | alle | alle
 | BX5200 |  |  | alle | alle
ControlNet | BK7000 |  |  | ab BC | ab BC
Modbus | BK7300 |  |  | ab B2 | ab B4
Fip IO | BK7420 |  |  | ab B1 | ab B1
RS485 | BK8000 |  |  | ab C2 | in Vorbereitung
RS232 | BK8100 |  |  | ab C2 | in Vorbereitung
 | BC8150 |  |  | alle | alle
 | BX8000 |  |  | alle | alle
Ethernet | BK9000 |  |  | ab B7 | ab BA
 | BK9100 |  |  | ab B1 | ab B1
 | BC9000 |  |  | ab B9 | ab BB
 | BC9100 |  |  | ab B1 | ab B1
 | BC9050 |  |  | alle | alle
 | BX9000 |  |  | alle | alle
PROFINET | BK9103 | in Vorbereitung |  | in Vorbereitung | in Vorbereitung
EtherNet/IP | BK9105 | alle |  | alle | alle
USB | BK9500 | Dieser Buskoppler unterstützt das 6 und das 12 Byte Prozessabbild der KL6201/KL6211. |  | (ab B1)* | in Vorbereitung
*) Nur wenn der Buskoppler (z. B. mit der Konfigurationssoftware KS2000) auf komplettes Mapping der Busklemmen eingestellt wird. Im Auslieferungszustand sind diese Buskoppler auf kompaktes Mapping der Busklemmen eingestellt.


Diagnose

Diagnose
Diagnose
Weiterführende Informationen
•
LEDs


LEDs

Diagnose [image] LEDs
LEDs
LEDs
Bedeutung der LEDs
LED
Position
Farbe
Bedeutung
K-Bus Diag
1. LED links
grün
Diese LED leuchtet bei jedem K-Bus-Zyklus auf. Im regulären Betrieb flackert sie also.
AS-i Diag
2. LED links
grün
Diese LED leuchtet während der AS-i Datenaustauschphase. Im regulären Betrieb flackert sie also.
-
3. LED links
grün
reserviert
Set
4. LED links
grün
Diese LED leuchtet solange die beiden Set-Eingänge kurzgeschlossen sind.
AS-i Power
1. LED rechts
grün
Diese LED leuchtet solange die AS-i Spannungsversorgung anliegt und mindestens ein AS-i Slave gefunden wurde.
AS-i Error
2. LED rechts
rot
Diese LED blinkt im geschützten Betriebsmodus (Protected Mode), wenn die Soll- und die Ist-Konfiguration nicht übereinstimmen.
Mögliche Ursachen:
▪
AS-i ID-Code eines oder mehrerer Slaves stimmt nicht mit den projektierten Werten überein.
▪
AS-i E/A Kennung eines oder mehrerer Slaves stimmt nicht mit den projektierten Werten überein.
▪
Projektierter AS-i Slave wurde nicht gefunden.
-
3. LED rechts
grün
reserviert
Mode
4. LED rechts
grün
Diese LED leuchtet solange die beiden Mode-Eingänge kurzgeschlossen sind.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.