KL6031, KL6041 - Serielle Schnittstellenklemmen

BECKHOFF Feldbuskomponenten

Dokumentation zu

KL6031 und KL6041

Serielle Schnittstellenklemmen

Version: 1.2.0
Datum: 2015-03-05


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


KL6031, KL6041 - Ausgabestände der Dokumentation

BECKHOFF KL6031, KL6041: Vorwort

Ausgabestände der Dokumentation

Version Kommentar
1.2.0
  • Technische Daten aktualisiert
  • Erweiterter Temperaturbereich
  • ATEX-Hinweise hinzugefügt
1.1
  • Korrektur C/S - Wort
1.0
  • Ergänzung zur Beschreibung zum Betrieb mit TwinCAT zugefügt
0.2
  • Beschreibung zum Betrieb mit TwinCAT SPS-Software hinzugefügt
0.1
  • erste vorläufige Dokumentation für KL6031 und KL6041

Firm- und Hardware-Stände

Dokumentation Version | KL6031-0000 |  | KL6041-0000
 | Firmware | Hardware | Firmware | Hardware
1.2.0 | 2A | 00 | 2A | 00
1.1 | 2A | 00 | 2A | 00
1.0 | 2A | 00 | 2A | 00
0.2 | 2A | 00 | 2A | 00
0.1 | 2A | 00 | 2A | 00

Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.

Syntax der Seriennummer

Aufbau der Seriennummer: KK YY FF HH

KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 12 06 3A 02:

12 - Produktionswoche 12
06 - Produktionsjahr 2006
3A - Firmware-Stand 3A
02 - Hardware-Stand 02


KL6031 - Einführung

BECKHOFF KL6031: Produktübersicht

Einführung

Die serielle Schnittstelle KL6031 ermöglicht den Anschluss von Geräten mit einer RS232-Schnittstelle. Sie arbeitet normkonform nach CCITT V.28/DIN 66 259-1. Das an die Klemme KL6031 angeschlossene Gerät kommuniziert über den Buskoppler mit dem Automatisierungsgerät. Der aktive Kommunikationskanal arbeitet unabhängig vom überlagerten Bussystem im Vollduplexbetrieb mit bis zu 115,2 kBaud. Die RS232-Schnittstelle garantiert hohe Störsicherheit durch galvanisch getrennte Signale.

LEDs

LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | an | normaler Betrieb
 |  | aus | Es ist ein Watchdog-Timer Overflow aufgetreten. Werden vom Buskoppler 100 ms keine Prozessdaten zur Klemme übertragen, so erlischt die LED RUN.
TxD | grün | Zustand der Sende-Signalleitung
RxD | grün | Zustand der Empfangs Signalleitung

Anschlüsse

Klemmstelle | Name | Signal
1 | TxD | Signalleitung (Transmit Data)
5 | RxD | Signalleitung (Receive Data)
2 | RTS | Steuerleitung (Request To Send)
6 | CTS | Steuerleitung (Clear To Send)
3 | GND | Masseanschluss (intern gebrückt mit Klemme 7)
7 | GND | Masseanschluss (intern gebrückt mit Klemme 3)
4 | Shield | Schirmanschluss (intern gebrückt mit Klemme 8)
8 | Shield | Schirmanschluss (intern gebrückt mit Klemme 4)


KL6031 - Technische Daten

BECKHOFF KL6031: Produktübersicht

Technische Daten der KL6031

Technische Daten | KL6031-0000, KS6031-0000
Übertragungskanäle | 2 (1/1), TxD und RxD, vollduplex
Übertragungsrate | 9600 Baud, 8 Datenbits, keine Parity und ein Stopp-Bit sind voreingestellt (max. 115200 Baud)
Bitverzerrung | < 3%
RS232-Leitungslänge | max. 15 m
Signalspannung "low" | -18 V ... -3 V
Signalspannung "high" | 3 V ... 18 V
Spannungsversorgung | über den K-Bus
Potenzialtrennung | 500 V (K-Bus/Signalspannung)
Datenbuffer | 1024-Byte-Empfangsbuffer, 128-Byte-Sendebuffer
Bitbreite im Prozessabbild | Input/Output: 22 x 8-Bit-Nutzdaten, 2 x 8-Bit-Control/Status (bis 22-Byte-Nutzdaten möglich)
Konfiguration | keine Adresseinstellung, Konfiguration über den Buskoppler oder die Steuerung
Stromaufnahme vom K-Bus | 55 mA
Gewicht | ca. 50 g
Zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich) 0°C ... +55°C (gemäß cULus für Canada und USA) 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen)
Zulässiger Umgebungstemperaturbereich bei Lagerung | -45 °C ... +85 °C
Zulässige relative Feuchte | 95% ohne Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Steckbare Verdrahtung | bei allen KSxxxx-Klemmen
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus, ATEX


KL6031 - Grundlagen zur Funktion

BECKHOFF KL6031: Produktübersicht

Grundlagen zur Funktion

Die serielle Schnittstellenklemme KL6031 ermöglicht den Anschluss von Geräten mit einer RS232-Schnittstelle (z.B. bei Bar Code Scannern). Unabhängig vom überlagerten Bussystem können Daten im Vollduplexbetrieb mit der Steuerung ausgetauscht werden . Der Empfangsbuffer ist 1024 Byte, der Sendebuffer 128 Byte groß. Der Datentransfer zwischen Klemme und Steuerung wird über einen Handshake im Status und Control-Byte abgewickelt. Die Werkseinstellung der Klemme ist 9600 Baud, 8 Datenbits, 1 Stopp-Bit, no Parity, RTS/CTS-Kontrolle aktiv.

LED-Anzeige

Die Run-LED gibt den Betriebszustand der Klemme wieder.
Ein – normaler Betrieb
Aus – Watchdog-Timer Overflow ist aufgetreten. Werden vom Buskoppler 100 ms keine Prozeßdaten übertragen, so erlöscht die grüne LED.

Die TxD und RxD-LEDs geben die Zustände der Signalleitungen wieder.

Prozessdaten - Standard Ausgabeformat

Beim Standard Ausgabeformat werden 22 Byte Nutzdaten und 1 Control/Status-Wort im Buskoppler gemappt. Durch Umparametrieren der KL6031 können bis zu 3 bzw. 5 Byte Nutzdaten übertragen werden.

Verweis

Im Kapitel "Zugriff aus dem Anwenderprogramm" befindet sich eine Übersicht über die möglichen Mappingkonfigurationen in Abhängigkeit der einstellbaren Parameter.


KL6041 - Einführung

BECKHOFF KL6041: Produktübersicht

Einführung

Die serielle Schnittstelle KL6041 ermöglicht den Anschluss von Geräten mit einer RS422- oder RS485-Schnittstelle. Das an die Klemme KL6041 angeschlossene Gerät kommuniziert über den Buskoppler mit dem Automatisierungsgerät. Der aktive Kommunikationskanal arbeitet unabhängig vom überlagerten Bussystem im Voll- oder Halbduplexbetrieb mit bis zu 115,2 kBaud. Die Differenzsignalübertragung nach RS422 garantiert hohe Störsicherheit durch galvanisch getrennte Signale.

LEDs

LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | an | normaler Betrieb
 |  | aus | Es ist ein Watchdog-Timer Overflow aufgetreten. Werden vom Buskoppler 100 ms keine Prozessdaten zur Klemme übertragen, so erlischt die LED RUN.
TxD | grün | Zustand der Sende-Signalleitung
RxD | grün | Zustand der Empfangs Signalleitung

Anschlüsse

Klemmstelle | Name | Signal
1 | TxD+ | Signalleitung + (Transmit Data)
5 | TxD- | Signalleitung - (Transmit Data)
2 | RxD+ | Signalleitung + (Receive Data)
6 | RxD- | Signalleitung - (Receive Data)
3 | GND | Masseanschluss (intern gebrückt mit Klemme 7)
7 | GND | Masseanschluss (intern gebrückt mit Klemme 3)
4 | Shield | Schirmanschluss (intern gebrückt mit Klemme 8)
8 | Shield | Schirmanschluss (intern gebrückt mit Klemme 4)


KL6041 - Technische Daten

BECKHOFF KL6041: Produktübersicht

Technische Daten der KL6041

Technische Daten | KL6041-0000, KS6041-0000
Übertragungskanäle | TxD und RxD, voll-/halbduplex
Übertragungsrate | 9600 Baud, 8 Datenbits, keine Parity und ein Stopp-Bit sind voreingestellt (max. 115200 Baud)
Bitübertragung | mit Differenzsignal
Leitungsimpedanz | 120 Ω
Übertragungsstrecke | ca. 1000 m Twisted-Pair
Spannungsversorgung | über den K-Bus
Stromaufnahme vom K-Bus | 65 mA typ.
Potenzialtrennung | 500 V (K-Bus/Signalspannung)
Datenbuffer | 1024-Byte-Empfangsbuffer, 128-Byte-Sendebuffer
Bitbreite im Prozessabbild | Input/Output: 22 x 8-Bit-Nutzdaten, 2 x 8-Bit-Control/Status (bis 22-Byte-Nutzdaten möglich)
Konfiguration | keine Adresseinstellung, Konfiguration über den Buskoppler oder die Steuerung
Gewicht | ca. 50 g
Zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich) 0°C ... +55°C (gemäß cULus für Canada und USA) 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen)
Zulässiger Umgebungstemperaturbereich bei Lagerung | -45 °C ... +85 °C
Zulässige relative Feuchte | 95% ohne Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Steckbare Verdrahtung | bei allen KSxxxx-Klemmen
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus, ATEX


KL6041 - Grundlagen zur Funktion

BECKHOFF KL6041: Produktübersicht

Grundlagen zur Funktion

Die serielle Schnittstellenklemme KL6041 ermöglicht den Anschluss von Geräten mit einer RS485-Schnittstelle. Unabhängig vom überlagerten Bussystem können Daten im Voll-/Halbduplexbetrieb mit der Steuerung ausgetauscht werden. Der Empfangsbuffer ist 1024 Byte, der Sendebuffer 128 Byte groß. Der Datentransfer zwischen Klemme und Steuerung wird über einen Handshake im Status und Control-Byte abgewickelt. Die Werkseinstellung der Klemme ist 9600 Baud, 8 Datenbits, 1 Stopp-Bit, no Parity, Voll-Duplex-Modus.

LED-Anzeige

Die Run-LED gibt den Betriebszustand der Klemme wieder.
Ein – normaler Betrieb
Aus – Watchdog-Timer Overflow ist aufgetreten. Werden vom Buskoppler 100 ms keine Prozeßdaten übertragen, so erlöscht die grüne LED.

Die TxD und RxD-LEDs geben die Zustände der Signalleitungen wieder.

Prozessdaten - Standard Ausgabeformat

Beim Standard Ausgabeformat werden 22 Byte Nutzdaten und 1 Control/Status-Wort im Buskoppler gemappt. Durch Umparametrieren der KL6041 können bis zu 3 bzw. 5 Byte Nutzdaten übertragen werden.

Anschluss bei RS485 Übertragung

Bei der RS485 Betriebsart werden die Daten in halbduplex Übertragung ausgetauscht. In dieser Betriebsart kann eine Busstruktur aufgebaut werden.

Anschluss bei RS422 Übertragung

Bei der RS422 Betriebsart werden die Daten vollduplex übertragen. Es können nur peer to peer Verbindungen hergestellt werden.

Verweis

Im "Zugriff aus dem Anwenderprogramm" befindet sich eine Übersicht über die möglichen Mappingkonfigurationen in Abhängigkeit der einstellbaren Parameter.


ELxxxx, KLxxxx - Tragschienenmontage

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Tragschienenmontage

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Montage

Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:

  1. Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
  2. Auf der rechten Seite des Feldbuskoppler werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
    Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.

Hinweis 		Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein.
Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät.
Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.

Demontage

Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:

  1. Ziehen Sie die Klemme an ihren orangefarbige Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
  2. Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.

Verbindungen innerhalb eines Busklemmenblocks

Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:

  • Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
  • Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.

Hinweis 		Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen.
Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.

PE-Powerkontakt

Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.

Achtung 		Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbraucher mit 230 V Nennspannung).

Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.

WARNUNG 		Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Anschlusstechnik

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Anschlusstechnik

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Übersicht

Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:

  • Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
  • Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
  • Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.

Standardverdrahtung

Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und
integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.

Steckbare Verdrahtung

Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt.
Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.

Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.

Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.

Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.

Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.

High-Density-Klemmen (HD-Klemmen)

Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.

Hinweis 		Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.

Ultraschall-litzenverdichtete Leiter

Hinweis 		Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschall verschweißte) Leiter angeschlossen werden.
Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!

Verdrahtung

Klemmen für Standardverdrahtung ELxxxx / KLxxxx und Klemmen für stehende Verdrahtung ESxxxx / KSxxxx

Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:

  1. Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
  2. Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
  3. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.

Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm

High-Density-Klemmen ELx8xx, KLx8xx (HD)

Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässige Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.

Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm

Schirmung

Hinweis 		Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


ATEX - Besondere Bedingungen

WARNUNG 		Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von
Beckhoff-Feldbuskomponenten in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
  • Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu Berücksichtigungen!
  • Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
  • Beachten Sie beim Einsatz von Beckhoff-Feldbuskomponenten in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
  • Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
  • Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Die Sicherung der Einspeiseklemmen KL92xx dürfen nur gewechselt werden,
    wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Adresswahlschalter und ID-Switche dürfen nur eingestellt werden,
    wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!

Normen

Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:

  • EN 60079-0: 2006
  • EN 60079-15: 2005

Kennzeichnung

Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten tragen eine der folgenden Kennzeichnungen:

II 3 G Ex nA II T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

oder

II 3 G Ex nA nC IIC T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

Seriennummer

Die Beckhoff-Feldbuskomponenten tragen eine Seriennummer, die wie folgt aufgebaut ist:

WW YY FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 35 04 1B 01:

35 - Produktionswoche 35
04 - Produktionsjahr 2004
1B - Firmware-Stand 1B
01 - Hardware-Stand 01


Feldbuskomponenten - ATEX-Dokumentation

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

ATEX-Dokumentation

Hinweis 		Hinweise zum Einsatz des Busklemmensystems in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz des Busklemmen-Systems in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler/Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.

Projektierung

Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, d. h. vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.

Parametrierung

KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.

Inbetriebnahme

KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.

KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:

  • Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
  • Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.

Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


KL6031, KL6041 - Parametrierung mit KS2000

BECKHOFF KL6031, KL6041: Konfigurationssoftware KS2000

Parametrierung mit KS2000

Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.

Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
  • ein Buskoppler für Ethernet BK9000
  • eine digitale Eingangsklemme KL1xx2
  • eine einkanalige serielle Schnittstellenklemme KL6041
  • eine einkanalige serielle Schnittstellenklemme KL6031
  • eine Bus-Endklemme KL9010

Das linken Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.

Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).

Für die KL6031 oder KL6041 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:

  • Register erlaubt den direkten Zugriff auf die Register der KL6031/KL6041.
  • Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL6031/KL6041.
  • ProcData zeigt die Prozessdaten der KL6031/KL6041.


KL6031, KL6041 - KS2000 - Register

BECKHOFF KL6031, KL6041: Konfigurations-Software KS2000

Register

Unter Register können Sie direkt auf die Register der KL6031/KL6041 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.


KL6031- KS2000 Allgemeine Einstellungen

BECKHOFF KL6031: Konfigurations-Software KS2000

Allgemeine Einstellungen

Karteireiter Common Settings (Allgemeine Einstellungen) zur Parametrierung der KL6031.

Allgemein

Take Settings for all channels of this terminal (Einstellungen für alle Kanäle dieser Klemme übernehmen)

Die vorgenommenen Einstellungen werden für alle Kanäle der Klemme übernommen (Default: deaktiviert).

Process Data Length (Prozessdatenlänge) (R34.7)

Hier können Sie Nutzdatenlänge (3, 5 oder 22 Byte) des Prozessdatenabbildes einstellen (Default: 22 Byte).

Set Factory Settings (Hersteller Einstellungen zurücksetzen) (R7)

Hier können Sie die Werkseinstellungen der Klemme zurücksetzen und mit "Apply" ("Übernehmen") abspeichern.

Communication Parameters (Kommunikationsparameter)
  • RTS/CTS activated (R34.0),
    RTS/CTS aktiviert (default: aktiviert)
  • Alternativ output format (R34.1),
    Alternatives Ausgabeformat (default: deaktiviert)
  • Status Byte one cycle later (R34.2),
    Status Byte einen Zyklus später (default: deaktiviert)
  • XON/XOFF supported sending data (R34.3),
    XON/XOFF beim Senden der Daten (default: deaktiviert)
  • XON/XOFF supported receiving data (R34.4),
    XON/XOFF beim Empfang der Daten (default: deaktiviert)
  • Send FIFO data continous (R34.6),
    Kontinuierliches Senden der FIFO Daten (default: deaktiviert)
  • Extended process data interface (R34.7),
    Erweitertes Prozessdateninterface (wird automatisch gesetzt)
  • Transfer rate optimization (R34.8),
    Transferratenoptimierung (default: aktiviert)


KL6041- KS2000 Allgemeine Einstellungen

BECKHOFF KL6041: Konfigurations-Software KS2000

Allgemeine Einstellungen

Karteireiter Common Settings (Allgemeine Einstellungen) zur Parametrierung der KL6041.

Allgemein

Take Settings for all channels of this terminal (Einstellungen für alle Kanäle dieser Klemme übernehmen)

Die vorgenommenen Einstellungen werden für alle Kanäle der Klemme übernommen (Default: deaktiviert).

Process Data Length (Prozessdatenlänge) (R34.7)

Hier können Sie Nutzdatenlänge (3, 5 oder 22 Byte) des Prozessdatenabbildes einstellen (Default: 22 Byte).

Set Factory Settings (Hersteller Einstellungen zurücksetzen) (R7)

Hier können Sie die Werkseinstellungen der Klemme zurücksetzen und mit "Apply" ("Übernehmen") abspeichern.

Communication Parameters (Kommunikationsparameter)
  • Half duplex (R34.0),
    Halbduplex (default: deaktiviert)
  • Alternativ output format (R34.1),
    Alternatives Ausgabeformat (default: deaktiviert)
  • Status Byte one cycle later (R34.2),
    Status Byte einen Zyklus später (default: deaktiviert)
  • XON/XOFF supported sending data (R34.3),
    XON/XOFF beim Senden der Daten (default: deaktiviert)
  • XON/XOFF supported receiving data (R34.4),
    XON/XOFF beim Empfang der Daten (default: deaktiviert)
  • Point to point connection (R34.5),
    Punkt zu Punkt Verbindung (default: deaktiviert)
  • Send FIFO data continous (R34.6),
    Kontinuierliches Senden der FIFO Daten (default: deaktiviert)
  • Extended process data interface (R34.7),
    Erweitertes Prozessdateninterface (wird automatisch gesetzt)
  • Transfer rate optimization (R34.8),
    Transferratenoptimierung (default: aktiviert)


KL6031, Kl6041 - KS2000 Allgemeine Einstellungen

BECKHOFF KL6031, KL6041: Konfigurations-Software KS2000

RS232(485)-Schnittstellenparameter

Karteireiter RS232(485) Interface Parameters (RS232/485 -Schnittstellenparameter) zur Parametrierung der KL6031/KL6041.
(Das untere Beispiel zeigt den Karteireiter der KL6031).

Baud rate (Baudrate) (R32)

Hier können Sie die Baudrate der Klemme einstellen (Default: 9600 Baud).

Data format (Datenrahmen) (R33)

Einstellung des Datenrahmens (Default: 8 Datenbits, keine Parität).

Stop Bits (R33.3)

Einstellung 1 oder 2 Stop-Bits über Register R33, Bit3 (Default: 1 Stop Bit).


KS2000 - Prozessdaten

BECKHOFF Feldbuskomponenten: Konfigurations-Software KS2000

Prozessdaten

Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.

Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.

Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.

Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.

VORSICHT 		Gefahr für Personen, Umwelt oder Geräte!
Beachten Sie, das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann.
Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, das Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!

Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.


KL6031, KL6041 - Control- und Status-Wort

BECKHOFF KL6031, KL6041: Konfiguration

Control- und Status-Wort

Control-Wort

Das Control-Wort (CW) befindet sich im Ausgangsprozessabbild und wird von der Steuerung zur Klemme übertragen.

Bit | CW.15 | CW.14 | CW.13 | CW.12 | CW.11 | CW.10 | CW.9 | CW.8 | CW.7 | CW.6 | CW.5 | CW.4 | CW.3 | CW.2 | CW.1 | CW.0
Name | OL7 | OL6 | OL5 | OL4 | OL3 | OL2 | OL1 | OL0 | - | OL2* | OL1* | OL0* | SC | IR | RA | TR

Die Bits CW.15 bis CW.8 werden nur bei Verwendung des großen Prozessabbilds dargestellt.
Bei Verwendung des kleinen oder mittleren Prozessabbilds erscheinen dort nur die Bits CW.7 bis CW.0 als Control-Byte! Die Anzahl der Ausgangs-Bytes, die für die Übertragung von der Steuerung zur Klemme bereit stehen werden dann von den Bits OL2* ... OL0* angezeigt.

Legende
Bit | Name | Beschreibung
CW.15 ... CW8 | OL7 ... OL0 (OutLenght) | 1dez... 22dez | Bei Verwendung des großen Prozessabbilds: Anzahl der Ausgangs-Bytes (), die für die Übertragung von der Steuerung zur Klemme bereit stehen.
 |  | - | Bei Verwendung des kleinen/mittleren Prozessabbilds: nicht dargestellt
CW.7 | - | 0bin | reserviert
CW.6 ... CW.4 | OL2* ... OL0* (OutLenght*) | 0 | Bei Verwendung des großen Prozessabbilds: reserviert
 |  | 1 ... 6 | Bei Verwendung des mittleren Prozessabbilds: Anzahl der Ausgangs-Bytes, die für die Übertragung von der Steuerung zur Klemme bereit stehen.
 |  | 1 ... 4 | Bei Verwendung des kleinen Prozessabbilds: Anzahl der Ausgangs-Bytes, die für die Übertragung von der Steuerung zur Klemme bereit stehen.
CW.3 | SC (SendContinious) | rise | Kontinuierliches Senden der Daten aus dem FIFO. Über die Steuerung wird der Sendebuffer gefüllt (bis zu 128 Byte). Mit steigender Flanke des Bits SC wird der gefüllte Buffer-Inhalt gesendet. Sind die Daten übertragen, so wird dies durch das Setzen des Bits SW.2 von der Klemme an die Steuerung quittiert. SW.2 wird mit CW.3 zurückgenommen.
CW.2 | IR (InitRequest) | 1bin | Die Steuerung fordert die Klemme zur Initialisierung auf. Die Sende- und Empfangsfunktionen werden gesperrt, die FIFO-Zeiger werden zurückgesetzt und die Schnittstelle wird mit den Werten der zuständigen Register (R32-R35, R18) initialisiert. Die Ausführung der Initialisierung wird von der Klemme mit dem Bit SW.2 (IA) quittiert.
 |  | 0bin | Die Steuerung fordert von der Klemme wieder die Bereitschaft für den seriellen Datenaustausch.
CW.1 | RA (ReceiveAccepted) | toggle | Die Steuerung quittiert die Entgegennahme von Daten mit Zustandsänderung dieses Bits. Erst daraufhin werden neue Daten von der Klemme zur Steuerung übertragen.
CW.0 | TR (TransmitRequest) | toggle | Über eine Zustandsänderung dieses Bits teilt die Steuerung der Klemme mit, dass sich die in mit den OL-Bits angezeigte Anzahl von Bytes in den DataOut-Bytes befinden. Die Klemme quittiert die Entgegennahme der Daten im Status-Byte mit Zustandsänderung des Bits SW.0 (TA). Erst daraufhin werden neue Daten von der Steuerung zur Klemme übertragen.

Status-Wort

Das Status-Wort (SW) befindet sich im Eingangsprozessabbild und wird von der Klemme zur Steuerung übertragen.

Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8 | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | IL7 | IL6 | IL5 | IL4 | IL3 | IL2 | IL1 | IL0 | - | IL2* | IL1* | IL0* | BUF_F | IA | RR | TA

Die Bits SW.15 bis SW.8 werden nur bei Verwendung des großen Prozessabbilds dargestellt.
Bei Verwendung des kleinen oder mittleren Prozessabbilds erscheinen dort nur die Bits SW.7 bis SW.0 als Status-Byte! Die Anzahl der Eingangs-Bytes, die für die Übertragung von der Klemme zur Steuerung bereit stehen werden dann von den Bits IL2* ... IL0* angezeigt.

Legende
Bit | Name | Beschreibung
SW.15 ... SW8 | IL7 ... IL0 (InLenght*) | 1dez ... 22dez | Bei Verwendung des großen Prozessabbilds: Anzahl der Eingangs-Bytes, die für die Übertragung von der Klemme zur Steuerung bereit stehen.
 |  | - | Bei Verwendung des kleinen/mittleren Prozessabbilds: nicht dargestellt
SW.7 | - | 0bin | reserviert
SW.6 ... SW.4 | IL2* ... IL0* (InLenght*) | 0 | Bei Verwendung des großen Prozessabbilds: reserviert
 |  | 1 ... 6 | Bei Verwendung des mittleren Prozessabbilds: Anzahl der Eingangs-Bytes, die für die Übertragung von der Klemme zur Steuerung bereit stehen.
 |  | 1 ... 4 | Bei Verwendung des kleinen Prozessabbilds: Anzahl der Eingangs-Bytes, die für die Übertragung von der Klemme zur Steuerung bereit stehen.
SW.3 | BUF_F | 1bin | Das Empfangs-FIFO ist voll. Alle ab jetzt eingehenden Daten gehen verloren!
SW.2 | IA (InitAccepted-Bit) | 1bin | Die Initialisierung wurde von der Klemme ausgeführt.
 |  | 0bin | Die Klemme ist wieder für den seriellen Datenaustausch bereit.
SW.1 | RR (ReceiveRequest) | toggle | Über eine Zustandsänderung dieses Bits teilt die Klemme der Steuerung mit, dass sich die in IL-Bits angezeigte Anzahl von Bytes in den DataIn-Bytes befinden. Die Steuerung muss die Entgegennahme der Daten im Control-Byte mit Zustandsänderung des Bits CW.1 (RA) quittieren. Erst daraufhin werden neue Daten von der Klemme zur Steuerung übertragen.
SW.0 | TA (TransmitAccepted) | toggle | Die Klemme quittiert die Entgegennahme von Daten mit Zustandsänderung dieses Bits. Erst daraufhin werden neue Daten von der Steuerung zur Klemme übertragen.

Beispiele für die Datenübertragung

Die Beispiele verwenden das große Prozessabbild.

Datenübertragung von der Steuerung zur Klemme

Control-Wort |  | Status-Wort |  | Kommentar
CW.15 ... CW.8 | CW.7 ... CW.1 | SW.15 ... SW.8 | SW.7 ... SW.1
0000 0000bin | 0000 0000bin | xxxx xxxxbin | 0000 x0x0bin | Start der Datenübertragung
0000 0010bin | 0000 0001bin | xxxx xxxxbin | 0000 x0x0bin | Steuerung fordert von der Klemme 2 Bytes zu senden
0000 0010bin | 0000 0001bin | xxxx xxxxbin | 0000 x0x1bin | Befehl ist ausgeführt: Klemme hat 2 Bytes in Sende-FIFO geladen
0001 0000bin | 0000 0000bin | xxxx xxxxbin | 0000 x0x1bin | Steuerung fordert von der Klemme 16 Bytes zu senden
0001 0000bin | 0000 0000bin | xxxx xxxxbin | 0000 x0x0bin | Befehl ist ausgeführt: Klemme hat 16 Bytes in Sende-FIFO geladen

Datenübertragung von der Klemme zur Steuerung

Control-Wort |  | Status-Wort |  | Kommentar
CW.15 ... CW.8 | CW.7 ... CW.1 | SW.15 ... SW.8 | SW.7 ... SW.1
xxxx xxxxbin | 0000 000xbin | 0000 0000bin | 0000 000xbin | Start der Datenübertragung
xxxx xxxxbin | 0000 000xbin | 0000 0011bin | 0000 001xbin | Klemme fordert von der Steuerung 3 Bytes zu übernehmen
xxxx xxxxbin | 0000 001xbin | 0000 0011bin | 0000 001xbin | Sie quittieren die Anforderung: Steuerung hat 3 Bytes aus Empfangs-FIFO übernommen
xxxx xxxxbin | 0000 001xbin | 0001 0110bin | 0000 000xbin | Klemme fordert von der Steuerung 22 Bytes zu übernehmen
xxxx xxxxbin | 0000 000xbin | 0001 0110bin | 0000 000xbin | Sie quittieren die Anforderung: Steuerung hat 22 Bytes aus Empfangs-FIFO übernommen

Initialisierung

Control-Wort |  | Status-Wort |  | Kommentar
CW.15 ... CW.8 | CW.7 ... CW.1 | SW.15 ... SW.8 | SW.7 ... SW.1
xxxx xxxxbin | xxxx xxxxbin | xxxx xxxxbin | xxxx xxxxbin | Start der Datenübertragung
0000 0000bin | 0000 0100bin | 0000 0000bin | 0000 0000bin | Steuerung fordert von der Klemme die Initialisierung
0000 0000bin | 0000 0100bin | 0000 0000bin | 0000 0100bin | Befehl ist ausgeführt: Klemme hat die Initialisierung vollzogen
0000 0000bin | 0000 0000bin | 0000 0000bin | 0000 0100bin | Steuerung fordert von der Klemme die Bereitschaft zum seriellen Datenaustausch
0000 0000bin | 0000 0000bin | 0000 0000bin | 0000 0000bin | Befehl ist ausgeführt: Klemme ist für seriellen Datenaustausch bereit


KL6031, KL6041 - Registerübersicht

BECKHOFF KL6031, KL6041: Zugriff aus dem Anwenderprogramm

Registerübersicht

Die Register dienen zur Parametrierung der Schnittstellenklemmen. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.

Register-Nr. | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | Anzahl Datenbytes im Sende-Buffer |  | variabel | - | R | RAM
R1 | Anzahl Datenbytes im Empfangs-Buffer |  | variabel | - | R | RAM
R2 | reserviert |  | 0x0000 | 0dez | R | -
R3 | reserviert |  | 0x0000 | 0dez | R | -
R4 | reserviert |  | 0x0000 | 0dez | R | -
R5 | reserviert |  | 0x0000 | 0dez | R | -
R6 | Diagnose-Register |  | variabel | - | R | RAM
R7 | Kommando-Register |  | 0x0000 | 0dez | R | -
R8 | Klemmentyp | KL6031: | 0x178F | 6031dez | R | ROM
 |  | KL6041: | 0x1799 | 6041dez
R9 | Firmware-Stand |  | z.B. 0x3143 | z.B. 1CASCII | R | ROM
R10 | Multiplex-Schieberegister |  | variabel | - | R | ROM
R11 | Signalkanäle |  | variabel | - | R | ROM
R12 | minimale Datenlänge |  | variabel | - | R | ROM
R13 | Datenstruktur |  | 0x0000 | 0dez | R | ROM
R14 | reserviert |  | - | - | R | -
R15 | Alignment-Register |  | variabel | - | R/W | RAM
R16 | Hardware-Versionsnummer |  | z.B. 0x0000 | z.B. 0dez | R/W | EEPROM
R17 | reserviert |  | - | - | - | -
R18 | Buffer voll - Meldung |  | 0x0400 | 1024dez | R/W | EEPROM
... | ... |  | ... | ... | ... | ...
R30 | reserviert |  | - | - | - | -
R31 | Kodewort-Register |  | variabel | - | R/W | RAM
R32 | Baudrate | 0x0006 | 6dez | R/W | EEPROM
R33 | Datenrahmen | 0x0003 | 3dez | R/W | EEPROM
R34 | Feature-Register | 0x0181 | 385dez | R/W | EEPROM
R35 | Anzahl der Datenbytes zum Buskoppler | 0x0017 | 23dez | R/W | EEPROM
R36 | reserviert | 0x0000 | 0dez | R/W | EEPROM
... | ... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | 0dez | R/W | EEPROM


KL6031, KL6041 - Registerbeschreibung

BECKHOFF KL6031, KL6041: Zugriff aus dem Anwenderprogramm

Registerbeschreibung

Alle Register können über die Registerkommunikation ausgelesen oder beschrieben werden. Sie dienen zur Parametrierung der Klemmen.

R0: Anzahl Datenbytes im Sende-Buffer

Im R0 steht die Anzahl der Daten im Sende-FIFO.

R1: Anzahl Datenbytes im Empfangs-Buffer

Im R0 steht die Anzahl der Daten im Empfangs-FIFO.

R6: Diagnose-Register

Bit | Beschreibung |  | default
R6.5-15 | - | reserviert | -
R6.4 | 1bin | Buffer ist voll | 0bin
R6.3 | 1bin | Overrun Error ist aufgetreten | 0bin
R6.2 | 1bin | Framing Error ist aufgetreten | 0bin
R6.1 | 1bin | Parity Error ist aufgetreten | 0bin
R6.0 | 1bin | Der Empfangsbuffer ist übergelaufen, ankommende Daten gehen verloren | 0bin

R7: Kommando-Register

Hinweis 		Anwender-Kodewort
Um die folgenden Kommandos auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein!
Kommando 0x7000: Restore Factory Settings

Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register die Werte des Auslieferungszustands wiederhergestellt:

R18: 0x0400
R32: 0x0006
R33: 0x0003
R34: 0x0181
R35: 0x0017

R8: Klemmentyp

Im Register R8 steht die Bezeichnung der Klemme:
KL6031: 0x178F (6031dez)
KL6041: 0x1799 (6041dez)

R9: Firmware-Stand

Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z.B. 0x3143 = '1C'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x43' dem ASCII-Zeichen 'C'.
Dieser Wert kann nicht verändert werden.

R16: Hardware-Versionsnummer

Im Register R16 steht der Hardware-Stand der Klemme.

R18: Buffer voll

Das Register R18 legt die Anzahl der Daten im Eingangs-FIFO fest, ab der das BUF_F-Bit im Status-Wort gesetzt wird

R31-R35: Anwenderregister

R31: Kodewort-Register

  • Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
  • Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die EEPROM-Register geschrieben und bleiben somit bei einem Neustart der Klemme erhalten.

Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.

R32: Baudrate

Das R32 legt die Baudrate der Klemme fest. Der Auslieferungszustand ist 9600 Baud.

Bit 4-15 | Bit 3 | Bit 2 | Bit 1 | Bit 0 | Baudrate
reserviert | 1 | 0 | 1 | 0 | 115200 Baud
reserviert | 1 | 0 | 0 | 1 | 57600 Baud
reserviert | 1 | 0 | 0 | 0 | 38400 Baud
reserviert | 0 | 1 | 1 | 1 | 19200 Baud
reserviert | 0 | 1 | 1 | 0 | 9600 Baud (default)
reserviert | 0 | 1 | 0 | 1 | 4800 Baud

R33: Datenrahmen

Das R33 legt die Einstellung des Datenrahmens fest. Der Auslieferungszustand ist 8 Datenbits, no Parity.

Bit 4-15 | Bit 3 | Bit 2 | Bit 1 | Bit 0 | Bedeutung
reserviert | 0bin: 1 Stop-Bit; 1bin: 2 Stop-Bits | 1 | 0 | 1 | 8 Datenbits, ungerade Parität
reserviert | 0bin: 1 Stop-Bit; 1bin: 2 Stop-Bits | 1 | 0 | 0 | 8 Datenbits, gerade Parität
reserviert | 0bin: 1 Stop-Bit; 1bin: 2 Stop-Bits | 0 | 1 | 1 | 8 Datenbits, keine Parität (default)
reserviert | 0bin: 1 Stop-Bit; 1bin: 2 Stop-Bits | 0 | 1 | 0 | 7 Datenbits, ungerade Parität
reserviert | 0bin: 1 Stop-Bit; 1bin: 2 Stop-Bits | 0 | 0 | 1 | 7 Datenbits, gerade Parität

R34: Feature-Register

Das R34 legt die Betriebsarten der Klemme fest.

Bit | Beschreibung der Betriebsart |  |  | default
R34.9-15 | - | reserviert |  | -
R34.8 | 0bin | Keine Transferratenoptimierung Die Daten werden sofort auf den Bus gelegt. |  | 1bin
 | 1bin | Transferratenoptimierung Nach Empfang eines Bytes wird für max. 4 ms auf ein weiteres Byte gewartet. Ist der Empfangspuffer komplett belegt, werden die Daten sofort auf den Bus gelegt.
R34.7 | 0bin | Kleines- und mittleres Prozessdatenabbild Es können 3 oder 5 Byte Nutzdaten (Einstellung in R35 ) übertragen werden. |  | 1bin
 | 1bin | Erweitertes Prozessdatenabbild Es können bis zu 22 Byte Nutzdaten (Einstellung in R35 ) übertragen werden. (Kompatible Koppler: BCxx50, BXxxxx, CXxxxx, BKxx20, BKxx50, BKxx50)
R34.6 | 0bin | Direktes Senden aus dem FIFO Der Buffer-Inhalt wird sofort gesendet. |  | 0bin
 | 1bin | Kontinuierliches Senden aus dem FIFO Über die Steuerung wird der Sendebuffer gefüllt (bis zu 128 Byte). Mit steigender Flanke des Bits "Control-Byte(Wort), Bit 3" (CB.3, CW.3) wird der gefüllte Buffer-Inhalt gesendet. Sind die Daten übertragen, so wird dies durch das Setzen des Bits "Status-Byte(Wort), Bit 2" (SB.2, SW.2) von der Klemme an die Steuerung quittiert. SB.2 (SW.2) wird mit CB3 (CW.3) zurückgenommen.
R34.5 | 0bin | KL6031: | reserviert | -
 |  | KL6041: | Punkt zu Punkt Verbindung deaktiviert | 0bin
 | 1bin | KL6031: | reserviert | -
 |  | KL6041: | Punkt zu Punkt Verbindung aktiviert | -
R34.4 | 0bin | Keine Unterstützung des XON/XOFF-Protokoll beim Daten-Empfang |  | 0bin
 | 1bin | Unterstützung des XON/XOFF-Protokoll beim Daten-Empfang Die Klemme sendet das Steuerzeichen XOFF, wenn 1014 Zeichen im Buffer der Klemme stehen, XON wird gesendet, wenn vorher XOFF gesendet wurde und die Buffer-Grenze von 18 Byte unterschritten wurde .
R34.3 | 0bin | Keine Unterstützung des XON/XOFF-Protokoll beim Senden von Daten |  | 0bin
 | 1bin | Unterstützung des XON/XOFF-Protokoll beim Senden von Daten Die Klemme sendet die von der Steuerung übergebenen Daten, bis sie von der Steuerung das Zeichen XOFF (DC3ASCII == 0x13) vom Partner empfängt. Das Senden wird daraufhin solange unterbunden, bis das Zeichen (DC1ASCII == 0x11) empfangen wird.
R34.2 | 0bin | Kein verzögertes Status-Byte |  | 0bin
 | 1bin | Verzögertes Status-Byte Das Status-Byte wird von der Klemme einen Zyklus später als die höherwertigen Daten-Bytes in die Schieberegister des K-Busses kopiert. Dadurch verringert sich die Datenübertragungsrate zur Steuerung.
R34.1 | 0bin | Standard Ausgabeformat (R35 beachten!) |  | 0bin
 | 1bin | Alternatives Ausgabeformat Im Alternativ Ausgabeformat werden 4 bzw. 5 Byte (3 Byte Daten und 1 Byte bzw. 2 Byte Control/Status) im Buskoppler gemappt.
R34.0 | 0bin | KL6031: | RTS, CTS deaktiviert | -
 |  | KL6041: | Vollduplex | 0bin
 | 1bin | KL6031: | RTS, CTS aktiviert | 1bin
 |  | KL6041: | Halbduplex | -

R35: Anzahl der im Buskoppler gemappten Datenbytes

Das R35 legt die Anzahl der im Buskoppler gemappten Datenbytes fest.

Bit 5-15 | Bit 4 | Bit 3 | Bit 2 | Bit 1 | Bit 0 | Datenbytes
reserviert | 1 | 0 | 1 | 1 | 1 | 22 Byte + 1 Control-/Status-Word im erweiterten Prozessdatenabbild (siehe R34.7)
reserviert | 0 | 0 | 1 | 1 | 0 | 5 Byte + 1 Control-/Status-Byte
reserviert | 0 | 0 | 0 | 1 | 1 | 3 Byte + 1 Control-/Status-Byte

R36 - 63: reserviert


KL6031, KL6041 - Mapping

BECKHOFF KL6031 und KL6041: Zugriff aus dem Anwenderprogramm

Mapping

Die Busklemmen belegen Adressen im Prozessabbild der Steuerung. Die Zuordnung der Prozessdaten (Ein- und Ausgangsdaten) und Parametrierungsdaten (Control- und Status-Bytes) zu den Steuerungsadressen wird als Mapping bezeichnet. Die Art des Mappings ist abhängig von:

  • dem verwendeten Feldbus-System

  • dem Klemmentyp

  • der Parametrierung des Buskopplers (Bedingungen) wie
    - kompakte oder komplexe Auswertung
    - Intel- oder Motorola-Format
    - Word-Alignment ein- oder ausgeschaltet

Die Buskoppler (BKxxxx, LCxxxx) und Busklemmen Controller (BCxxxx, BXxxxx) werden mit bestimmten Voreinstellungen (Default-Einstellungen) ausgeliefert. Mit der Konfigurationssoftware KS2000 oder mit einer Master-Konfigurationssoftware (z.B. TwinCAT System Manager oder ComProfibus) können Sie diese Default-Einstellungen verändern.

Die folgenden Tabellen zeigen das Mapping in Abhängigkeit der verschiedenen Bedingungen.

Komplexe Auswertung

Bei komplexer Auswertung belegen die seriellen Schnittstellenklemmen Adressen im Ein- und im Ausgangsprozessabbild. Der Zugriff auf Control- und Status-Wort ist möglich.

22-Byte Prozessabbild

Komplexe Auswertung im Intel-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: nein Word-Alignment: egal | 0 | SW |  | CW
 | 1 | DataIn 1 | DataIn 0 | DataOut 1 | DataOut 0
 | 2 | DataIn 3 | DataIn 2 | DataOut 3 | DataOut 2
 | 3 | DataIn 5 | DataIn 4 | DataOut 5 | DataOut 4
 | 4 | DataIn 7 | DataIn 6 | DataOut 7 | DataOut 6
 | 5 | DataIn 9 | DataIn 8 | DataOut 9 | DataOut 8
 | 6 | DataIn 11 | DataIn 10 | DataOut 11 | DataOut 10
 | 7 | DataIn 13 | DataIn 12 | DataOut 13 | DataOut 12
 | 8 | DataIn 15 | DataIn 14 | DataOut 15 | DataOut 14
 | 9 | DataIn 17 | DataIn 16 | DataOut 17 | DataOut 16
 | 10 | DataIn 19 | DataIn 18 | DataOut 19 | DataOut 18
 | 11 | DataIn 21 | DataIn 20 | DataOut 21 | DataOut 20

Komplexe Auswertung im Motorola-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: ja Word-Alignment: egal | 0 | SW |  | CW
 | 1 | DataIn 0 | DataIn 1 | DataOut 0 | DataOut 1
 | 2 | DataIn 2 | DataIn 3 | DataOut 2 | DataOut 3
 | 3 | DataIn 4 | DataIn 5 | DataOut 4 | DataOut 5
 | 4 | DataIn 6 | DataIn 7 | DataOut 6 | DataOut 7
 | 5 | DataIn 8 | DataIn 9 | DataOut 8 | DataOut 9
 | 6 | DataIn 10 | DataIn 11 | DataOut 10 | DataOut 11
 | 7 | DataIn 12 | DataIn 13 | DataOut 12 | DataOut 13
 | 8 | DataIn 14 | DataIn 15 | DataOut 14 | DataOut 15
 | 9 | DataIn 16 | DataIn 17 | DataOut 16 | DataOut 17
 | 10 | DataIn 18 | DataIn 19 | DataOut 18 | DataOut 19
 | 11 | DataIn 20 | DataIn 21 | DataOut 20 | DataOut 21

5-Byte Prozessabbild

Komplexe Auswertung im Intel-Format, ohne Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | DataIn 0 | SB | DataOut 0 | CB
 | 1 | DataIn 2 | DataIn 1 | DataOut 2 | DataOut 1
 | 2 | DataIn 4 | DataIn 3 | DataOut 4 | DataOut 3
 | 3 | reserviert | DataIn 5 | reserviert | DataOut 5

Komplexe Auswertung im Intel-Format, mit Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB | reserviert | CB
 | 1 | DataIn 1 | DataIn 0 | DataOut 1 | DataOut 0
 | 2 | DataIn 3 | DataIn 2 | DataOut 3 | DataOut 2
 | 3 | DataIn 5 | DataIn 4 | reserviert | DataOut 4

Komplexe Auswertung im Motorola-Format, ohne Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | DataIn 1 | SB | DataOut 1 | CB
 | 1 | DataIn 3 | DataIn 0 | DataOut 3 | DataOut 0
 | 2 | DataIn 5 | DataIn 2 | DataOut 5 | DataOut 2
 | 3 | reserviert | DataIn 4 | reserviert | DataOut 4

Komplexe Auswertung im Motorola-Format, mit Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB | reserviert | CB
 | 1 | DataIn 0 | DataIn 1 | DataOut 0 | DataOut 1
 | 2 | DataIn 2 | DataIn 3 | DataOut 2 | DataOut 3
 | 3 | DataIn 4 | DataIn 5 | DataOut 4 | DataOut 5

3-Byte Prozessabbild

Komplexe Auswertung im Intel-Format, ohne Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | DataIn 0 | SB | DataOut 0 | CB
 | 1 | DataIn 2 | DataIn 1 | DataOut 2 | DataOut 1

Komplexe Auswertung im Intel-Format, mit Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB | reserviert | CB
 | 1 | DataIn 1 | DataIn 0 | DataOut 1 | DataOut 0
 | 2 | reserviert | DataIn 2 | reserviert | DataOut 2

Komplexe Auswertung im Motorola-Format, ohne Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | DataIn 1 | SB | DataOut 1 | CB
 | 1 | DataIn 2 | DataIn 0 | DataOut 2 | DataOut 0

Komplexe Auswertung im Motorola-Format, mit Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplexe Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB | reserviert | CB
 | 1 | DataIn 0 | DataIn 1 | DataOut 0 | DataOut 1
 | 2 | DataIn 2 | reserviert | DataOut 2 | reserviert

Kompakte Auswertung

Hinweis Ein Betrieb der KL6031 / KL6041 mit kompaktem Prozessabbild (ohne Control- und Status-Bytes) ist nicht möglich, da Control- und Status-Bytes für einen sinnvollen Prozessdatenbetrieb der KL6031 / KL6041 erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen wird die KL6031 / KL6041 mit komplettem Prozessabbild dargestellt!

Legende

Komplexe Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB / SW: Status-Byte /Status-Wort für Kanal n (erscheint im Eingangsprozessabbild)
CB / CW: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.


Beispiele für die Register-Kommunikation

Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.

Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
    - ASCII-Code 0x33 steht für die Ziffer 3
    - ASCII-Code 0x41 steht für den Buchstaben A
    Die Firmwareversion lautet also 3A.

Beispiel 2: Beschreiben eines Anwender-Registers

Hinweis 		Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt.
Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder.
Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.

I. Schreiben des Code-Worts (0x1235) in Register 31

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!

II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.

III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.

    VORSICHT     		Beachten Sie die Registerbeschreibung!
    Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
    Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!

IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
  • Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.

V. Schreiben des Register 31 (Code-Wort zurücksetzen)

Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00

Erläuterung:

  • Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
  • Bit 0.6 gesetzt bedeutet: schreiben des Registers.
  • Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
  • Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Erläuterung:

  • Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
  • Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


KL6031, KL6041 - Betrieb mit der TwinCAT SPS-Software

BECKHOFF KL6031, KL6041: Zugriff aus dem Anwenderprogramm

Betrieb mit der TwinCAT SPS-Software

KL6031 und KL6041 im 22-Byte Modus

Die seriellen Beckhoff Busklemmen KL6031 und KL6041 werden in der ausgelieferten Standardausführung mit einem 24 Byte großen Prozessabbild betrieben (22 Byte Nutzdaten + 1 Control-/Status Wort), so dass jeweils 22 Datenbytes von und zur Klemme übertragen werden können.
Hierfür sind 3 SPS-Zyklen für den Datenaustausch zwischen SPS und Busklemme notwendig. Die maximale effektive Datenübertragungsrate (Bps) ist abhängig von der Zykluszeit T der SPS und der Anzahl der Bits, die erforderlich sind, um ein Datenbyte zu übertragen (LB):

Bps = (LB x PA / 3) / T
LB = 1 Startbit + n Datenbits + p Paritätsbits + m Stoppbits
PA = Anzahl Nutzdaten im Prozessabbild

Die maximale effektive Datenübertragungsrate wird nach oben durch die in der Busklemme konfigurierte physikalische Baudrate begrenzt.

Bps = (10 Bits x 22/3) / 0,010 s ≈ 7333 Bps

Hinweis 		TwinCAT Version
Diese Busklemme wird erst ab TwinCAT Version 2.0 der seriellen Kommunikationsbibliothek (ComLibV2) unterstützt. Bei der Wahl der Zykluszeit muss bei Busklemmen die K-Bus-Update-Zeit des Buskopplers berücksichtigt werden. Weitere Informationen zur Konfiguration und Betrieb mit TwinCAT finden Sie im Beckhoff-Infosys unter http://infosys.beckhoff.com/.

KL6031 und KL6041 im 5-Byte Modus

Die serielle Busklemme kann auch so umkonfiguriert werden, dass im 5-Byte Modus (6 Byte Prozessabbild) jeweils 5 Datenbyte von und zur Klemme übertragen werden können. Dabei sind ebenfalls 3 SPS-Zyklen für einen Austausch notwendig. Die effektive Datenrate liegt bei gleicher Zykluszeit der SPS um 5/3 höher als im 3-Byte Modus.

Bps = (10 Bits x 5/3) / 0,010 s ≈ 1666 Bps

Die Umprogrammierung der Busklemmen kann nicht zur Laufzeit der SPS erfolgen, da sich der 3-Byte und der 5-Byte Modus im Register-Mapping und in der Konfiguration im TwinCAT System Manager unterscheiden.

Hinweis 		TwinCAT Version
Diese Busklemme wird erst ab TwinCAT Version 2.0 der seriellen Kommunikationsbibliothek (ComLibV2) unterstützt. Bei der Wahl der Zykluszeit muss bei Busklemmen die K-Bus-Update-Zeit des Buskopplers berücksichtigt werden. Weitere Informationen zur Konfiguration und Betrieb mit TwinCAT finden Sie im Beckhoff-Infosys unter http://infosys.beckhoff.com/.

KL6031 und KL6041 im 3-Byte Modus

Beim Betrieb der KL6031 + KL6041 im 3-Byte Modus können in einem Bustelegramm 3 Datenbytes (4 Byte Prozessabbild) zur Klemme übertragen und von ihr empfangen werden. Da für jeden Datenaustausch zwischen SPS und Busklemme 3 SPS-Zyklen notwendig sind, kann effektiv in jedem Zyklus ein Byte übertragen werden.

Bps = (10 Bits x 3/3) / 0,010 s ≈ 1000 Bps

Hinweis 		TwinCAT Version
Diese Busklemme wird erst ab TwinCAT Version 2.0 der seriellen Kommunikationsbibliothek (ComLibV2) unterstützt. Bei der Wahl der Zykluszeit muss bei Busklemmen die K-Bus-Update-Zeit des Buskopplers berücksichtigt werden. Weitere Informationen zur Konfiguration und Betrieb mit TwinCAT finden Sie im Beckhoff-Infosys unter http://infosys.beckhoff.com/.

Serielle PC-Schnittstelle

Die serielle PC-Schnittstelle (COM1, COM2 etc.) wird durch das TwinCAT System analog zur seriellen Busklemme bedient und benutzt größere Datenübertragungspuffer als die serielle Busklemme. Die COMlib nutzt einen 64-Byte Puffer, so dass gleichzeitig bis zu 64 Datenbyte zwischen SPS und Schnittstellentreiber übertragen werden. Auch bei der seriellen PC-Schnittstelle werden 3 SPS-Zyklen für den Austausch eines Datenblocks benötigt.

Bps = (LB x 64/3) / T


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


KL6031, KL6041 - Prozessabbild

BECKHOFF KL6031, KL6041: Zugriff aus dem Anwenderprogramm

Prozessabbild

Die KL6031 und KL6041 stellen sich im Prozessabbild mit mindestens 5 Byte Ein- und 5 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:

Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | SB | CB
1 | 2 | Wort | DataIN | DataOUT
3 | 4 | Wort | SW | CW

*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen

Legende

SB: Status-Byte
CB: Control-Byte

DataIN: Eingangsdatenwort (Ist-Position)
DataOUT: Ausgangsdatenwort (z.B. Soll-Geschwindigkeit, siehe Prozessdaten)

SW: zusätzliches Status-Wort
CW: zusätzliches Control-Wort

Hinweis Ein Betrieb der KL2531 und KL2541 mit kompaktem Prozessabbild (ohne Control- und Status-Byte) ist nicht möglich, da Control- und Status-Byte für einen sinnvollen Prozessdatenbetrieb der Klemmen erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen, werden KL2531 und KL2541 mit ihrem kompletten Prozessabbild dargestellt!

Prozessdaten

Die