KL6021-0023 - EnOcean
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0
▪
Migration
1.1
▪
Montagebeschreibung erweitert
▪
Grundlagen zur Funktion erweitert
▪
Einführung der KL6023 hinzugefügt
1.0
▪
Beschreibung der KL6023 (Wireless-Adapter für EnOcean-Funktechnik) hinzugefügt
▪
Verdrahtungshinweise hinzugefügt
▪
Beschreibung der Konfigurations-Software KS2000 hinzugefügt
▪
Technische Daten ergänzt
0.1
erste Vorabversion
Firm- und Hardware-Stände
Dokumentation Version | KL6021-0023 |  | KL6023
 | Firmware | Hardware | Firmware | Hardware
2.0 | 5D | 03 | 1A | 02
1.1 | 5D | 01 | 1A | 01
1.0 | 5A | 00 | 1A | 00
0.1 | 5A | 00 | - | -
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 06 3A 02:
12 - Produktionswoche 12
06 - Produktionsjahr 2006
3A - Firmware-Stand 3A
02 - Hardware-Stand 02


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KL6021-0023 - Einführung
•
KL6021-0023 - Technische Daten
•
KL6023 - Einführung
•
KL6023 - Technische Daten
•
Grundlagen zur Funktion


KL6021-0023 - Einführung

Produktübersicht [image] KL6021-0023 - Einführung
KL6021-0023 - Einführung
KL6021-0023 - serielle Schnittstellenklemme zum Anschluss des Wireless-Adapters KL6023
Die serielle Schnittstelle KL6021-0023 verbindet den Wireless-Adapter über ein RS485 Signal. Der Wireless-Adapter KL6023 arbeitet als EnOcean-Funkempfänger und empfängt die Funksignale von EnOcean Sensoren.
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | an | normaler Betrieb
 |  | aus | Es ist ein Watchdog-Timer Overflow aufgetreten. Werden vom Buskoppler 100 ms keine Prozessdaten zur Klemme übertragen, so erlischt die LED RUN.
TxD | grün | Zustand der Sende-Signalleitung
RxD | grün | Zustand der Empfangs Signalleitung
Anschlussbelegung
Klemmstelle | Name | Signal
1 | TxD+ | Signalleitung (Transmit Data)
5 | TxD- | Signalleitung (Transmit Data)
2 | RxD+ | Signalleitung (Receive Data)
6 | RxD- | Signalleitung (Receive Data)
3 | GND | Masse für KL6023 (intern gebrückt mit Klemmstelle 7)
7 | GND | Masse für KL6023 (intern gebrückt mit Klemmstelle 3)
4 | +5V | Versorgungsspannung für KL6023 (intern gebrückt mit Klemmstelle 8)
8 | +5V | Versorgungsspannung für KL6023 (intern gebrückt mit Klemmstelle 4)


KL6021-0023 - Technische Daten

Produktübersicht [image] KL6021-0023 - Technische Daten
KL6021-0023 - Technische Daten
Technische Daten | KL6021-0023
Anzahl der Eingänge | 1, für Wireless-Adapter (EnOcean-Funktechnik)
Leitungsimpendanz | ca. 120 Ω
Verbindungskabel zum Wireless-Adapter KL6023 | 2 mal Zweileiter, Twisted Pair
Verbindungslänge zum Wireless-Adapter KL6023 | maximal 300 m
Bitbreite im Prozessabbild | 11 x 8 Bit Nutzdaten, 1 x 8 Bit Control/Status
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 65 mA
Gewicht | ca. 60 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus, ATEX


KL6023 - Einführung

Produktübersicht [image] KL6023 - Einführung
KL6023 - Einführung
KL6023 - Wireless-Adapter für EnOcean-Funktechnik
Der Wireless-Adapter KL6023 empfängt die Signale der batterielosen Sensoren mit EnOcean-Technologie. Dieses Signal wird vom Wireless-Adapter auf ein RS485-Signal umgesetzt und von der seriellen Busklemme KL6021-0023 direkt weiterverarbeitet. Mit einer Reichweite der Funksignale von ca. 30 m kann die Verdrahtung in einem Gebäude erheblich vereinfacht werden.
Applikationsbeispiel
Während der Inbetriebnahme sind die Status-LEDs des Wireless-Adapters hilfreich. Die LEDs zeigen jedes empfangene Telegramm, klassifiziert nach fehlerhaft oder fehlerfrei, an. Mit einer Distanz von max. 300 m zwischen dem Empfänger und der Busklemmenstation ist die Platzierung der Empfänger an jedem funktechnisch günstigen Ort innerhalb eines Gebäudes möglich. Die maximale Anzahl von Sendern pro Empfangseinheit ist vom System nicht vorgegeben. In der Praxis werden zwischen 25 und 100 Sender pro Empfänger eingesetzt.


KL6023 - Technische Daten

Produktübersicht [image] KL6023 - Technische Daten
KL6023 - Technische Daten
Technische Daten | KL6023 (Wireless-Adapter für EnOcean-Funktechnik)
Anschluss | 2 mal Zweileiter, direkt an Busklemme KL6021-0023
Spannungsversorgung | durch Busklemme KL6021-0023 (mit galvanischer Trennung)
Verbindungskabellänge zur KL6021-0023 | maximal 300 m
Konfiguration | nicht erforderlich
Frequenzband | 868,35 MHz
Übertragungsreichweite | Freifeld: ca. 300 m Im Gebäude: ca. 30 m
Funktelegramm | abhängig vom Sensortyp: - 32 Bit Sensor-Identnummer - Anzahl der Nutz-Bytes ist nicht begrenzt
Empfangsantenne | im Gehäuse integriert
Gehäuse | Kasten: Polystyrol (grau) mit PG-Verschraubung M16 für Kabelanschluss Deckel: Polycarbonat (transparent)
Gewicht | ca. 55 g
Abmessungen (B x H x T) | ca. 52 mm x 50mm x 35,5 mm (ohne PG-Verschraubung)
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP66
Einbaulage | beliebig
Zulassung | CE


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Die serielle Kommunikationsklemme KL6021-0023 verbindet das EnOcean-Empfängermodul KL6023 mit dem Beckhoff Busklemmensystem. EnOcean (http://www.enocean.de) ermöglicht eine Funkübertragung ohne Batterien oder externe Stromzufuhr im Sender.
KL6021-0023 mit KL6023 und drei EnOcean-Sendern
Zulassung von EnOcean-Funk-Technologie
Hinweis
Art und Quelle der Gefahr
Das EnOcean-Empfängermodul KL6032 ist in folgenden Ländern anmelde- und gebührenfrei zu betreiben.
Die Erlaubnis für den Einsatz in anderen Ländern ist explizit zu klären!
•
Europäische Union
•
Schweiz
Auslesen empfangener Telegramme
Wenn die KL6021-0023 neue Telegramme empfangen hat, signalisiert sie dies dadurch, dass sie im Status-Byte das Bit SB.2 auf 1 setzt. Das Auslesen empfangener Telegramme wird dadurch gestartet, dass im Control-Byte das Bit CB.0 von der übergeordneten Steuerung invertiert wird. Bei dem Wechsel von 0 nach 1 bzw. von 1 nach 0 wird immer das nächste im Speicher befindliche Telegramm in den Prozessdaten angezeigt. Zur Quittierung wird in SB.0 der Wert des Bits CB.0 übernommen.
Die KL6021-0023 filtert die im EnOcean Standard führenden Synchronisations-Bytes und die abschließende Check-Summe heraus, d.h. die angezeigten Daten beginnen mit dem Telegramm-Header und enden mit dem Statusfeld.
Längere Telegramme
Falls das Telegramm eines EnOcean-Senders aus mehr als 4 Datenbytes besteht, kann es nicht mit einem K-Bus-Zyklus übertragen werden. Die KL6021-0023 setzt in diesem Fall, beim nächsten Auslesezyklus im Status-Byte das Bit SB.1 und legt den nächsten Datenblock dieses Telegramms in den Prozessdaten ab.
Fehlerhafte Telegramme
Die KL6021-0023 berechnet für jedes empfangene EnOcean-Telegramm die Check-Summe. Falls diese nicht mit der übertragenen Check-Summe übereinstimmt, setzt die Klemme im Status-Byte das Bit SB.6. Das Telegramm wird nicht in den Datenspeicher übernommen und geht verloren.
Überlauf des Datenspeichers
Wenn die von der KL6021-0023 empfangen Telegramme nicht von der übergeordneten Steuerung ausgelesen werden, läuft der Empfangsspeicher der Klemme über und sie setzt im Status-Byte das Bit SB.3. Es kann auch vorkommen, dass ein Telegramm nur teilweise in den Speicher geschrieben wird. Hierbei entsteht automatisch ein Fehler in der Check-Summe, der genauso angezeigt und verarbeitet wird.
Protokoll
Die folgende Tabelle zeigt den allgemeinen Aufbau eines EnOcean-Telegramms:
Bit 7
Bit 0
Beschreibung
Sync_Byte1 (0xA5)
Synchronisations-Bytes
Sync_Byte0 (0x5A)
H_Seq
Length
Header-Identifikation
H_Seq (3 Bit)
▪
0 unbekannte Sender-ID empfangen
▪
1 bekannte Sender-ID empfangen
▪
2 neuer Sender angelernt
Length (5 Bit)
▪
Anzahl der nach dem Header folgenden Bytes (hier: 11)
ORG
Telegrammtyp
Data Byte 3
Daten-Bytes
Data Byte 2
Data Byte 1
Data Byte 0
ID Byte 3
32 Bit Sender-ID
ID Byte 2
ID Byte 1
ID Byte 0
Status
Statusfeld
Check Sum
Check-Summe (LSB der Addition aller Bytes ohne Synchronisations-Bytes, ohne Check-Summe)


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Anschluss des Wireless-Adapters


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschluss des Wireless-Adapters

Montage und Verdrahtung [image] Anschluss des Wireless-Adapters
Anschluss des Wireless-Adapters
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschluss des Wireless-Adapters
KL6021-0023 |  | KL6023 - Wireless-Adapter
Signal | Klemmstelle Nr. | Signal | Klemmstelle Nr.
RxD+ | 2 | RxD+ | 1
RxD- | 6 | RxD- | 2
GND | 3 oder 7 | GND | 3
5 V | 4 oder 8 | 5 V | 4


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Register
•
Einstellungen
•
Prozessdaten


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Lightbus-Koppler BK2020
▪
eine digitale Eingangsklemme KL1xx2
▪
eine serielle Schnittstellenklemme KL6021-0023 (RS485 für EnOcean-Empfänger KL6023)
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).
KS2000 Baumzweig für Kanal 1 der KL6021-0023
Für die KL6021-0023 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL6021-0023.
▪
Unter Einstellungen finden Sie keine Dialogmasken zur Parametrierung der KL6021-0023, da keine klemmenspezifischen Einstellungen erforderlich sind.
▪
ProcData zeigt die Prozessdaten der KL6021-0023 an.


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register der KL6021-0023 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Registeransicht in KS2000


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Für die KL6021-0023 und die KL6023 sind keine klemmenspezifischen Einstellungen erforderlich.


Prozessdaten

Konfigurations-Software KS2000 [image] Prozessdaten
Prozessdaten
Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.
ProcData
Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.
Feld Verlauf
Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.
Feld Wert
Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.
Feld Wert
SmallWarningYellow WARNUNG
Verändern von Ausgangswerten (Forcen)
Beachten Sie, das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann.
Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, dass Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Menschen besteht!
Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.
Einstellungen


Programmierung

Programmierung
Programmierung
Weiterführende Informationen
•
TwinCAT-Bibliotheken


TwinCAT-Bibliotheken

Programmierung [image] TwinCAT-Bibliotheken
TwinCAT-Bibliotheken
Software Dokumentation im Beckhoff Information System:
TwinCAT 2: TwinCAT 2 PLC Lib: EnOcean
TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_EnOcean


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Byte
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Die KL6021-0023 stellt sich im Prozessabbild mit 12 Byte Ein- und 12 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset | Format | Eingangsdaten | Ausgangsdaten
0 | Byte | Status-Byte (SB) | Control-Byte (CB)
1 | Byte | DataIn0 | DataOut0
2 | Byte | DataIn1 | DataOut1
3 | Byte | DataIn2 | DataOut2
4 | Byte | DataIn3 | DataOut3
5 | Byte | DataIn4 | DataOut4
6 | Byte | DataIn5 | DataOut5
7 | Byte | DataIn6 | DataOut6
8 | Byte | DataIn7 | DataOut7
9 | Byte | DataIn8 | DataOut8
10 | Byte | DataIn9 | DataOut9
11 | Byte | DataIn10 | DataOut10


Control- und Status-Byte

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Byte
Control- und Status-Byte
Registerkommunikation
Control-Byte (bei Registerkommunikation)
Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB.5 bis CB.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie lesen oder beschreiben wollen.
Status-Byte (bei Registerkommunikation)
Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB.6 | R | 0bin | Lesezugriff
SB.5 bis SB.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Prozessdaten während der Registerkommunikation
Die angezeigten Prozessdaten werden während der Registerkommunikation auf den Wert Null gesetzt!
Prozessdatenbetrieb
Control-Byte (im Prozessdatenbetrieb)
Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | - | - | - | - | - | - | NextTelegramReq
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB.6 bis CB.1 | - | 0bin | reserviert
CB.0 | NextTelegramReq | 0/1bin | Durch invertieren dieses Bits wird das nächste im Eingangsspeicher der KL6021-0023 liegende EnOcean- Telegramm in die Prozessdaten kopiert.
Status-Byte (im Prozessdatenbetrieb)
Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | - | - | BufferFull | NewTelegram | SameTelegram | NextTelegramAck
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB.6 | Error | 1bin | Das zurzeit in den Prozessdaten der KL6021-0023 angezeigte EnOcean-Telegramm hat eine falsche Check-Summe.
SB.5 | - | 0bin | reserviert
SB.4 | - | 0bin | reserviert
SB.3 | BufferFull | 1bin | Der Empfangsspeicher der KL6021-0023 ist voll.
SB.2 | NewTelegram | 1bin | Es liegt mindestens ein neues EnOcean- Telegramm im Empfangsspeicher der KL6021-0023.
SB.1 | SameTelegram | 1bin | Die aktuell angezeigten Daten gehören zum selben EnOcean- Telegramm wie die zuvor angezeigten Daten, da dieses Telegram mehr als 4 Daten-Bytes enthält.
SB.0 | NextTelegramAck | 0/1bin | Quittung für das Kopieren des EnOcean-Telegramms in die Prozessdaten. Das Bit übernimmt den Wert des Control-Bits CB.0, wenn das Telegram in die Prozessdaten kopiert wurde.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Diese Register dienen zur Parametrierung der KL6021. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R5 | reserviert | - | - | - | -
R6 | Diagnose-Register | 0x0000 | 0dez | R | RAM
R7 | Kommando-Register | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | 0x1785 | 6021dez | R | ROM
R9 | Firmware-Stand | z. B. 0x3541 | z. B. 13633dez | R | ROM
R10 | Multiplex-Schieberegister | 0x0230 | 560dez | R | ROM
R11 | Signalkanäle | 0x0160 | 352dez | R | ROM
R12 | minimale Datenlänge | 0x6060 | 24672dez | R | ROM
R13 | Datenstruktur | 0x0002 | 2dez | R | ROM
R14 | reserviert | - | - | - | -
R15 | Alignment-Register | typisch 0x7F80 | typisch 32640dez | R/W | RAM
R16 | Hardware-Versionsnummer | z. B. 0x0000 | z. B. 0dez | R/W | SEEPROM
R17 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R28 | reserviert | - | - | - | -
R29 | Klemmentyp - Sonderkennung | 0x0017 | 23dez | R | ROM
R30 | reserviert | - | - | - | -
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register | 0x0000 | 0dez | R/W | SEEPROM
R33 | reserviert | - | - | - | -
R34 | reserviert | - | - | - | -
R35 | Anzahl Datenbytes zum Buskoppler | 0x000B | 11dez | R | ROM
R36 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R63 | reserviert | - | - | - | -


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die Register dienen zur Parametrierung der Klemme. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
R6: Diagnose-Register
In Register R6 wird das Status-Byte SB eingeblendet.
R7: Kommando-Register
In dieser Klemme sind keine Kommandos implementiert.
R8: Klemmenbezeichnung
Im Register R8 steht die Bezeichnung der Klemme. KL6021: 0x1785 (6021dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3541 = '5A'. Hierbei entspricht die '0x35' dem ASCII-Zeichen '5' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme, dieser Wert kann nicht verändert werden.
R29: Klemmentyp - Sonderkennung
Im Register R29 steht die Bezeichnung des Sondertyps der Klemme. KL6021-0023: 0x0017 (0023dez)
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Konfiguration der Klemme fest. Bei dieser Klemme gibt es keine Konfigurationsmöglichkeiten.
R35: Anzahl Datenbytes zum Buskoppler
In Register R35 wird die Anzahl der Datenbytes, die zum Buskoppler übertragen werden angezeigt. Dieser Wert ist nicht veränderbar.


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.