KL5151, KL5152 - Inkremental-Encoder-Interface
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.2.0
▪
Hinweise zum Betreib der KL5151-000 (KL5151-0050) als einkanaliger Vorwärts-/Rückwärtszähler erweitert
2.1.0
▪
Produktübersicht aktualisiert
▪
Technische Daten aktualisiert
▪
KS2000-Einstellungen aktualisiert
▪
Verdrahtung und Anschlussbelegung erweitert
2.0.0
▪
Migration
▪
Revisionsstand aktualisiert
1.3.0
▪
Technische Daten aktualisiert
▪
ATEX-Hinweise hinzugefügt
▪
Erweiterter Temperaturbereich für KL5151-0000
▪
Beschreibung von Control- und Status-Byte der KL5151-0021 korrigiert
1.2.0
▪
Einführung aktualisiert
▪
Beschreibung der Parametrierung der KL5151 mittels Konfigurationssoftware KS2000 aktualisiert
▪
Registerbeschreibung aktualisiert
▪
Montagebeschreibung erweitert
▪
KL5151-0021 hinzugefügt
▪
KL5151-0050 umbenannt und nun als KL5152-0000 erhältlich
1.1.0
▪
Beschreibung der Prozessabbilder erweitert
▪
Mapping-Tabellen hinzugefügt
1.0
▪
KL5151-0050 hinzugefügt
▪
Beschreibung der Parametrierung der KL5151 mit der Konfigurationssoftware KS2000 hinzugefügt.
0.1
Vorabversion (nur KL5151-0000)
Firm- und Hardware-Stände
Dokumentation Version | KL5151-0000 |  | KL5151-0021 |  | KL5152-0000 (KL5151-0050)
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
2.2.0 | 4E | 09 | 14 | 09 | 4E | 09
2.1.0 | 4E | 09 | 14 | 09 | 4E | 09
2.0.0 | 4E | 09 | 14 | 09 | 4E | 09
1.3.0 | 4C | 07 | 13 | 07 | 4C | 07
1.2.0 | 4C | 07 | 13 | 07 | 4C | 07
1.1.0 | 3A | 02 | - | - | 3A | 02
1.0 | 3A | 02 |  |  | 3A | 02
0.1 | 3A | 00 |  |  | - | -
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 35 04 3A 02:
35 - Produktionswoche 35
04 - Produktionsjahr 2004
3A - Firmware-Stand 3A
02 - Hardware-Stand 02


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KL5151-0000 - Einführung
•
KL5151-0021 - Einführung
•
KL5152-0000 (KL5151-0050) - Einführung
•
Technische Daten


KL5151-0000 - Einführung

Produktübersicht [image] KL5151-0000 - Einführung
KL5151-0000 - Einführung
KL5151-0000
Die Busklemme KL5151-0000 ist ein Interface mit 24 V Eingängen zum direkten Anschluss von Inkremental-Encodern. Ein 32 Bit Zähler mit Quadraturdecoder sowie ein 32 Bit Latch für den Nullimpuls können gelesen, gesetzt oder aktiviert werden.
Die Busklemme KL5151-0000 kann auch als Vorwärts/Rückwärts-Zähler (32 Bit) verwendet werden. Dabei dient Eingang A als Zählereingang. Über Eingang B wird die Zählrichtung vorgegeben. Eingang C muss auf HIGH liegen, damit die Zählfunktion aktiviert wird.
LED-Anzeigen
LED | Funktion
Ch. A | Leuchtet wenn am Eingang A ein Signal anliegt.
Ch. B | Leuchtet wenn am Eingang B ein Signal anliegt.
Ch. C | Leuchtet wenn am Eingang C (Nulleingang) ein Signal anliegt.
Gate / Latch | Leuchtet wenn am Gate-/Latch-Eingang ein Signal anliegt.


KL5151-0021 - Einführung

Produktübersicht [image] KL5151-0021 - Einführung
KL5151-0021 - Einführung
KL5151-0021
Die Busklemme KL5151-0021 ist ein Interface mit 24 V Eingängen zum direkten Anschluss von Inkremental-Encodern. Ein 32 Bit Zähler mit Quadraturdecoder sowie ein 32 Bit Latch für den Nullimpuls können gelesen, gesetzt oder aktiviert werden.
Die Busklemme KL5151-0021 besitzt einen zusätzlichen Komparatorausgang.
LED-Anzeigen
LED | Funktion
Ch. A | Leuchtet wenn am Eingang A ein Signal anliegt.
Output | Leuchtet wenn der Komparatorausgang eingeschaltet ist
Ch. B | Leuchtet wenn am Eingang B ein Signal anliegt.
Ch. C | Leuchtet wenn am Eingang C (Nulleingang) ein Signal anliegt.
Gate / Latch | Leuchtet wenn am Gate-/Latch-Eingang ein Signal anliegt.
Betrieb
Referenzieren
Geben Sie zum Referenzieren über das Ausgangsdoppelwort DataOUT1 den Referenzwert vor und setzen Sie im Control-Byte die Bits CB1.0 (EnLatchC) und CB1.2 (SetCnt). Bei einer steigenden Flanke am Eingang C wird nun der Referenzwert vom Zähler übernommen.
Werkstück messen
Zu Beginn der Messung wird der Filterwert im Filter-Register R0 vorgegeben.
Setzen Sie anschließend im Control-Byte das Freigabe Bit CB1.1 (EnMeas). Wurde eine Platte erfolgreich gemessen, so setzt die Klemme im Status-Byte das Bit SB1.1 (MeasDone).
Der Messung beginnt bei einer entsprechenden Flanke. Falls der Pegel schon vorhanden ist, wird nur die Position des Brettendes festgestellt. Als Brettanfang wird dann der Start der Messung angenommen.
Postforming-Sägen
Der Ausgang hat 10 µs Anstiegszeit und 40 µS Verzögerung durch den Optokoppler.


KL5152-0000 (KL5151-0050) - Einführung

Produktübersicht [image] KL5152-0000 (KL5151-0050) - Einführung
KL5152-0000 (KL5151-0050) - Einführung
KL5152-0000 (KL5151-0050)
Die Busklemme KL5152-0000 (KL5151-0050) ist ein Interface mit 24 V Eingängen zum direkten Anschluss von zwei Inkremental-Encodern. Die Klemme kann wahlweise ein- oder zweikanalig genutzt werden.
Hinweis
Betrieb als einkanaliger Vorwärts/Rückwärts-Zähler
Die Busklemme KL5152-0000 (KL5151-0050) kann auch als einkanaliger Vorwärts/Rückwärts-Zähler (32 Bit) verwendet werden. Dabei dient Eingang A1 als Zählereingang. Über Eingang B1 wird die Zählrichtung vorgegeben. Eingang A2 muss auf HIGH liegen, damit die Zählfunktion aktiviert wird.
Ein Betrieb als zweikanaliger Zähler ist nicht möglich!
LED-Anzeigen
Signal LED | Funktion | Encoder
Ch. A1 | Leuchtet wenn am Eingang A1 ein Signal anliegt. | 1
Ch. B1 | Leuchtet wenn am Eingang B1 ein Signal anliegt.
Ch. A2 | Leuchtet wenn am Eingang A2 ein Signal anliegt. | 2
Ch. B2 | Leuchtet wenn am Eingang B2 ein Signal anliegt.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | KL5151-0000 | KL5151-0021 |  | KL5152-0000 (KL5151-0050)
Sensoreingänge (Kanäle) | 1 |  |  | 2 (als Encoder-Interface) 1 (als Zähler)
Geber Anschluss | A, B, C, Gate, 24 V |  |  | Kanal 1: A1, B1 Kanal 2: A2, B2
Geber Betriebsspannung | 24 VDC
Betrieb als Encoder-Interface | 1 x 32 Bit binär |  |  | 2 x 32 Bit binär
Betrieb als Zähler | 1 x 32 Bit binär | - |  | 1 x 32 Bit binär
Grenzfrequenz | 100 kHz
Quadraturdecoder | 4-fach Auswertung
Befehle | Lesen, Setzen, Latchen, Compare-Funktion zum Setzen des Ausgangs (nur KL5151-0021)
Versorgungsspannung | 24 VDC (-15% / +20%)
Komparator Ausgang | 0 | 1 |  | 0
Stromaufnahme aus den Powerkontakten | typisch 100 mA (ohne Geber)
Bitbreite im K-Bus E/A | 4 x 16 Bit Nutzdaten, 1 x 8 Bit Control/Status
Bitbreite im Eingangsprozessabbild | 2 Datenworte, 1 Status-Byte |  |  | kompakt | komplett
 |  |  |  | 4 Datenworte | 4 Datenworte, 2 Status-Bytes
Bitbreite im Ausgangsprozessabbild | 2 Datenworte, 1 Control-Byte |  |  | 2 Datenworte, 2 Control-Bytes, 2 Füll-Bytes | 4 Datenworte, 2 Control-Bytes
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 50 mA
Gewicht | ca. 50 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm
Montage | auf 35 mm Tragschiene nach EN 60715
Steckbare Verdrahtung | bei allen Klemmen der Bauform KSxxxx
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus, ATEX |  | CE, cULus, ATEX


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Anschluss
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung
•
KL5151-0000 - Anschlussbelegung
•
KL5151-0021 - Anschlussbelegung
•
KL5152-0000 (KL5151-0050) - Anschlussbelegung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Hinweis
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Hinweis
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Hinweis
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


KL5151-0000 - Anschlussbelegung

Montage und Verdrahtung [image] Anschluss [image] KL5151-0000 - Anschlussbelegung
KL5151-0000 - Anschlussbelegung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL5151-0000
Anschlussbelegung
Klemmstelle
Nr.
In Betriebsart* Encoder-Interface
Anschluss für
In Betriebsart* Counter
Anschluss für
A
1
Eingang A
Zählereingang
+24 V
2
Powerkontakt +24 V (intern verbunden mit Klemmstelle 6)
0 V
3
Powerkontakt 0 V (intern verbunden mit Klemmstelle 7)
C
4
Eingang C oder
Nulleingang (Falls im Control-Byte das Bit 0 (EnLatchC) gesetzt ist, veranlasst eine steigende Flanke an diesem Eingang, das der aktuelle Counter-Wert als Referenzmarke im Latch-Register gespeichert wird.)
Counter enable (Gate-Eingang für die Betriebsart Counter)
B
5
Eingang B
Zählrichtung:
high = rückwärts
low = vorwärts)
+24 V
6
Powerkontakt +24 V (intern verbunden mit Klemmstelle 2)
0 V
7
Powerkontakt 0 V (intern verbunden mit Klemmstelle 3)
Gate/Latch
8
Gate-Eingang oder
Latch-Eingang: Falls im Control-Byte
▪
das Bit 3 (EnLatchRise) gesetzt ist, veranlasst eine steigende Flanke
▪
das Bit 4 (EnLatchFall) gesetzt ist, veranlasst eine fallende Flanke
an diesem Eingang, das der aktuelle Counter-Wert als Referenzmarke im Latch-Register gespeichert wird.
keine Funktion
*) Die Betriebsart wird mit Bit R32.15 des Feature-Registers festgelegt.


KL5151-0021 - Anschlussbelegung

Montage und Verdrahtung [image] Anschluss [image] KL5151-0021 - Anschlussbelegung
KL5151-0021 - Anschlussbelegung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL5151-0021
Anschlussbelegung
Klemmstelle
Nr.
Anschluss für
A
1
Eingang A
Output
2
Komparator Ausgang
0 V
3
Powerkontakt 0 V (intern verbunden mit Klemmstelle 7)
C
4
Eingang C oder
Nulleingang (Falls im Control-Byte das Bit 0 (EnLatchC) gesetzt ist, veranlasst eine steigende Flanke an diesem Eingang, das der aktuelle Counter-Wert als Referenzmarke im Latch-Register gespeichert wird.)
B
5
Eingang B
+24 V
6
Powerkontakt +24 V
0 V
7
Powerkontakt 0 V (intern verbunden mit Klemmstelle 3)
Gate/Latch
8
Gate-Eingang oder
Latch-Eingang: Falls im Control-Byte
▪
das Bit 3 (EnLatchRise) gesetzt ist, veranlasst eine steigende Flanke
▪
das Bit 4 (EnLatchFall) gesetzt ist, veranlasst eine fallende Flanke
an diesem Eingang, das der aktuelle Counter-Wert als Referenzmarke im Latch-Register gespeichert wird.


KL5152-0000 (KL5151-0050) - Anschlussbelegung

Montage und Verdrahtung [image] Anschluss [image] KL5152-0000 (KL5151-0050) - Anschlussbelegung
KL5152-0000 (KL5151-0050) - Anschlussbelegung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL5152-0000 (KL5151-0050)
Anschlussbelegung
Klemmstelle | Nr. | In Betriebsart* Encoder-Interface Anschluss für | In Betriebsart* Counter Anschluss für
A1 | 1 | Eingang A für Encoder 1 | Zählereingang
+24 V | 2 | Powerkontakt +24 V (intern verbunden mit Klemmstelle 6)
0 V | 3 | Powerkontakt 0 V (intern verbunden mit Klemmstelle 7)
A2 | 4 | Eingang A für Encoder 2 | Counter enable (Gate-Eingang für die Betriebsart Counter)
B1 | 5 | Eingang B für Encoder 1 | Zählrichtung: high = rückwärts, low = vorwärts
+24 V | 6 | Powerkontakt +24 V (intern verbunden mit Klemmstelle 2)
0 V | 7 | Powerkontakt 0 V (intern verbunden mit Klemmstelle 3)
B2 | 8 | Eingang B für Encoder 2 | keine Funktion
*) Die Betriebsart wird mit Bit R32.15 des Feature-Registers festgelegt.


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweis
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Einstellungen


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Ethernet-Koppler BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine Inkremental-Encoder-Klemme KL5151-0000
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).
KS2000-Baumzweige für Kanal 1 der KL5151
Für die KL5151 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL5151.
▪
Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL5151.
▪
ProcData zeigt die Prozessdaten der KL5151.


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Unter Einstellungen finden Sie die Dialogmaske zur Parametrierung der KL5151-0000 oder KL5152-0000 (KL5151-0050).
Einstellungen über KS2000
Betriebsmodus
Counter Mode aktiv (R32.15)
Hier können Sie für KL5151-0000 und KL5152-0000 (KL5151-0050) den Counter Mode aktivieren (Default: deaktiviert). Bei aktiviertem Counter Mode arbeiten die Klemmen als 32 Bit Vorwärts/Rückwärts-Zähler. Die Zählrichtung (auf-/abwärts) wird über den Pegel an Kanal B vorgegeben.
Hinweis
Betrieb der KL5152-0000 (KL5151-0050) als einkanaliger Zähler
Da im Betrieb der KL5152-0000 (KL5151-0050) als Zähler der Anschluss A2 für die Freigabe (Gate) des Zählers benutzt wird, ist ein Betrieb als zweikanaliger Zähler nicht möglich.
Gesamtes Prozessabbild anzeigen (R32.6)
Ein sinnvoller Betrieb der KL5151-0000 ist nur mit gesamten Prozessabbild möglich (Default: aktiviert)!
Die KL5152-0000 (KL5151-0050) ist im Auslieferungszustand auf das verkleinerte (kompakte) Prozessabbild eingestellt. Hier können Sie für die KL5152-0000 (KL5151-0050) die Auswertung des gesamten (kompletten) Prozessabbilds aktivieren.
Positiver Pegel am Gate sperrt den Zähler (R32.5)
Hier können Sie das Sperren des Zählers durch einen positiven Pegel am Gate-Eingang aktivieren (Default: deaktiviert).
Negativer Pegel am Gate sperrt den Zähler (R32.4)
Hier können Sie das Sperren des Zählers durch einen negativen Pegel am Gate-Eingang aktivieren (Default: deaktiviert).


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
KL5151-0000
•
KL5151-0021
•
KL5152-0000 (KL5150-0050)
•
Register


KL5151-0000

Zugriff aus dem Anwenderprogramm [image] KL5151-0000
KL5151-0000
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Bytes
•
Mapping


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] KL5151-0000 [image] Prozessabbild
Prozessabbild
Die KL5151-0000 stellt sich im Prozessabbild mit jeweils 5 Byte Ein- und Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Format | Eingangsdaten | Ausgangsdaten
Byte | SB | CB
Doppel-Wort | DataIN | DataOUT
Legende
SB: Status-Byte
CB: Control-Byte
DataIN: aktueller oder im Latch gespeicherter Wert des 32-Bit-Zählers (die Auswahl erfolgt mit Bit CB1.1 des Control-Bytes)
DataOUT: Vorgabewert für den 32-Bit-Zähler
▪
Die Zuordnung der Bytes und Worte zu den Adressen der Steuerung entnehmen Sie bitte der Seite Mapping.
▪
Die Bedeutung des Control- und Status-Bytes entnehmen Sie bitte der Seite Control- und Status-Bytes.
Hinweis
Kein kompaktes Prozessabbild
Ein Betrieb der KL5151-0000 mit kompaktem Prozessabbild (ohne Control- und Status-Byte) ist nicht möglich, da Control- und Status-Byte für einen sinnvollen Prozessdatenbetrieb der Klemme erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen, wird die KL5151-0000 mit ihrem kompletten Prozessabbild dargestellt!


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] KL5151-0000 [image] Control- und Status-Bytes
Control- und Status-Bytes
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 im Prozessdatenbetrieb
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | RS_CNT_LAT | EnLatchFall | EnLatchRise | SetCnt | ReadLatch | EnLatchC
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 | - | reserviert
CB1.5 | RS_CNT_LAT* | 1bin | Der Zähler wir mit der aktiven Flanke des Latch-Eingangs auf Null gesetzt. Welche Latch-Flanke aktiv ist, bestimmen Sie mit den Bits CB1.4, CB1.3 und CB1.0.
CB1.4 | EnLatchFall* | 1bin | Die fallende Flanke des Latch-Eingangs wird aktiviert. Beim ersten externen Latch-Impuls nach Gültigkeit des Bits EnLatchFall wird der Counter-Wert im Latch-Register gespeichert. Die folgenden Impulse haben keinen Einfluss auf das Latch-Register.
CB1.3 | EnLatchRise* | 1bin | Die steigende Flanke des Latch-Eingangs wird aktiviert. Beim ersten externen Latch-Impuls nach Gültigkeit des Bits EnLatchRise wird der Counter-Wert im Latch-Register gespeichert (hat Vorrang vor EnLatchFall). Die folgenden Impulse haben keinen Einfluss auf das Latch-Register.
CB1.2 | SetCnt | Der Zähler wird mit steigender Flanke von SetCnt auf den 32-Bit-Vorgabewert gesetzt, der von der Steuerung in die Prozessausgangsdaten geschrieben wird.
CB1.1 | ReadLatch | 0bin | Der aktuelle Wert des 32-Bit Zähler wird in die Prozesseingangsdaten eingeblendet.
 |  | 1bin | Der im Latch gespeicherte 32-Bit-Wert wird in die Prozesseingangsdaten eingeblendet.
CB1.0 | EnLatchC* | 1bin | Die steigende Flanke des Nulleingangs (Eingang C) wird aktiviert. Beim ersten externen Latch-Impuls nach Gültigkeit des Bits EnLatchC wird der Counter-Wert im Latch-Register gespeichert. Die folgenden Impulse haben keinen Einfluss auf das Latch-Register. (siehe folgenden Hinweis)
*) Gilt nicht für KL5152-0000 (KL5151-0050), da hier Latch-Eingang und Nulleingang nicht zur Verfügung stehen. Setzen Sie die Bits CB1.5, CB1.4, CB1.3 und CB1.0 der KL5152-0000 (KL5151-0050) immer auf 0bin!
Hinweis
EnLatchC oder EnLatchRise und EnLatchFall?
Wenn Bit CB1.0 (EnLatchC) gesetzt ist, dürfen Bit CB1.3 (EnLatchRise) und Bit CB1.4 (EnLatchFall) nicht gesetzt sein, weil Sie sonst nicht wissen, welches Ereignis das Speichern eines Zählerwerts im Latch veranlasst hat.
Status-Byte 1 im Prozessdatenbetrieb
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | - | - | StGate | StLatchC | SetCnt | ReadLatch | ValLatchC
Legende
Bit
Name
Beschreibung
SB1.7
RegAccess
0bin
Quittung für Prozessdatenbetrieb
SB1.6
-
reserviert
SB1.5
-
reserviert
SB1.4
StGate
KL5151-0000: Status des externen Gate/Latch-Eingangs
KL5152-0000 (KL5151-0050): reserviert
SB1.3
StLatchC
KL5151-0000: Status des Nulleingangs (Eingang C)
KL5152-0000 (KL5151-0050): reserviert
SB1.2
SetCnt
Quittung, das die Daten zum Setzen des Zählers von der Klemme übernommen wurden.
SB1.1
ReadLatch
0bin
Der aktuelle Wert des 32-Bit Zählers wurde in die Prozessdaten eingeblendet.
1bin
Der im Latch gespeicherte 32-Bit-Wert wurde in die Prozessdaten eingeblendet.
SB1.0
ValLatchC*
1bin
Ein Nullpunkt-Latch ist aufgetreten: Eine steigende Flanke am Nulleingang (Eingang C) hat veranlasst, das der aktuelle Counter-Wert als Referenzmarke im Latch-Register gespeichert wurde.
Weitere Impulse haben keinen Einfluss mehr auf das Latch-Register. Um den Gate/Latch-Eingang erneut zu aktivieren müssen Sie:
▪
im Control-Byte das Bit 0 (EnLatchC) auf 0bin setzen.
▪
warten bis diese Änderung durch rücksetzen des Bit 0 (ValLatchC) im Status-Bytes quittiert wird.
▪
im Control-Byte das Bit 0 (EnLatchC) wieder auf 1bin setzen.
*) Gilt nicht für KL5152-0000 (KL5151-0050), da hier Latch-Eingang und Nulleingang nicht zur Verfügung stehen.
Registerkommunikation
Control-Byte 1 bei Registerkommunikation
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort 0 lesen oder - mit dem Ausgangsdatenwort 0 beschreiben wollen.
VORSICHT
Keine gültigen Prozessdaten währen der Registerkommunikation!
Während der Registerkommunikation kann nicht auf Datenregister zugegriffen werden! Prozessdaten, die eventuell noch angezeigt werden, sind nicht gültig!
Status-Byte 1 bei Registerkommunikation
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2 (nur KL5152-0000 und KL5151-0050)
Control- und Status-Byte des Kanals 2 (CB2 und SB2) sind wie Control- und Status-Byte des Kanals 1 aufgebaut.


Mapping

Zugriff aus dem Anwenderprogramm [image] KL5151-0000 [image] Mapping
Mapping
Die Busklemmen belegen Adressen im Prozessabbild der Steuerung. Die Zuordnung der Prozessdaten (Ein- und Ausgangsdaten) und Parametrierungsdaten (Control- und Status-Bytes) zu den Steuerungsadressen wird als Mapping bezeichnet. Die Art des Mappings ist abhängig von:
▪
dem verwendeten Feldbus-System
▪
dem Klemmentyp
▪
der Parametrierung des Buskopplers wie
- Intel- oder Motorola-Format
- Word-Alignment ein- oder ausgeschaltet
Die Buskoppler (BKxxxx, LCxxxx) und Busklemmen Controller (BCxxxx, BXxxxx) werden mit bestimmten Voreinstellungen (Default-Einstellungen) ausgeliefert. Mit der Konfigurationssoftware KS2000 oder mit einer Master-Konfigurationssoftware (z. B. TwinCAT System Manager oder ComProfibus) können Sie diese Default-Einstellungen verändern.
Die folgenden Tabellen zeigen das Mapping in Abhängigkeit der verschiedenen Bedingungen. Die Inhalte der einzelnen Bytes entnehmen Sie bitte den Seiten Prozessabbild sowie Control- und Status-Bytes.
Komplette Auswertung
Der Zugriff auf Control- und Status-Bytes ist möglich.
Komplette Auswertung im Intel-Format
Default-Mapping für CANopen-, CANCAL-, DeviceNet-, ControlNet-, Modbus-, RS232- und RS485-Koppler.
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: nein | 0 | DataIN D0 | SB | DataOUT D0 | CB
 | 1 | DataIN D2 | DataIN D1 | DataOUT D2 | DataOUT D1
 | 2 | reserviert | DataIN D3 | reserviert | DataOUT D3
Komplette Auswertung im Motorola-Format
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: nein | 0 | DataIN D3 | SB | DataOUT D3 | CB
 | 1 | DataIN D1 | DataIN D2 | DataOUT D1 | DataOUT D2
 | 2 | reserviert | DataIN D0 | reserviert | DataOUT D0
Komplette Auswertung im Intel-Format bei Word-Alignment
Default-Mapping für EtherCAT-, Lightbus- und Ethernet-Koppler sowie Busklemmen Controller (BCxxxx, BXxxxx).
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB | reserviert | CB
 | 1 | DataIN D1 | DataIN D0 | DataOUT D1 | DataOUT D0
 | 2 | DataIN D3 | DataIN D2 | DataOUT D3 | DataOUT D2
Komplette Auswertung im Motorola-Format bei Word-Alignment
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | DataIN D2 | DataIN D3 | DataOUT D2 | DataOUT D3
 | 2 | DataIN D0 | DataIN D1 | DataOUT D0 | DataOUT D1
Legende
Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Worte immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.
SB: Status-Byte (erscheint im Eingangsprozessabbild)
CB: Control-Byte (erscheint im Ausgangsprozessabbild)
DataIN D0: Eingangsdoppelwort, niederwertigste Daten-Byte
DataIN D1: Eingangsdoppelwort, ...
DataIN D2: Eingangsdoppelwort, ...
DataIN D3: Eingangsdoppelwort, höchstwertigste Daten-Byte
DataOUT D0: Ausgangsdoppelwort, niederwertigste Daten-Byte
DataOUT D1: Ausgangsdoppelwort, ...
DataOUT D2: Ausgangsdoppelwort, ...
DataOUT D3: Ausgangsdoppelwort, höchstwertigste Daten-Byte
reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
Kompakte Auswertung
Hinweis
Kein kompaktes Prozessabbild
Ein Betrieb der KL5151-0000 mit kompaktem Prozessabbild (ohne Control- und Status-Byte) ist nicht möglich, da Control- und Status-Byte für einen sinnvollen Prozessdatenbetrieb der Klemme erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen wird die KL5151-0000 mit komplettem Prozessabbild dargestellt!


KL5151-0021

Zugriff aus dem Anwenderprogramm [image] KL5151-0021
KL5151-0021
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Bytes


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] KL5151-0021 [image] Prozessabbild
Prozessabbild
Die KL5151-0021 stellt sich im Prozessabbild mit jeweils 5 Byte Ein- und Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Format | Eingangsdaten | Ausgangsdaten
Byte | SB1 | CB1
Doppel-Wort | DataIN1 | DataOUT1
Byte | SB2 | CB2
Doppel-Wort | DataIN2 | DataOUT2
Legende
SB1: Status-Byte 1
CB1: Control-Byte 1
SB1: Status-Byte 2 (nicht benutzt)
CB1: Control-Byte 2 (nicht benutzt)
DataIN1: aktueller oder im Latch gespeicherter Wert des 32-Bit-Zählers (die Auswahl erfolgt mit Bit CB1.1 des Control-Bytes)
DataOUT1: Compare-Wert zum Setzen des Komparator-Ausgangs (die Freigabe erfolgt mit Bit CB1.6 des Control-Bytes)
DataIN2: 32 Bit Latch
DataOUT2: Compare-Wert zum Rücksetzen des Komparator-Ausgangs
▪
Die Bedeutung des Control- und Status-Bytes entnehmen Sie bitte der Seite Control- und Status-Bytes.
Hinweis
Kein kompaktes Prozessabbild
Ein Betrieb der KL5151-0021 mit kompaktem Prozessabbild (ohne Control- und Status-Byte) ist nicht möglich, da Control- und Status-Byte für einen sinnvollen Prozessdatenbetrieb der Klemme erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen, wird die KL5151-0021 mit ihrem kompletten Prozessabbild dargestellt!


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] KL5151-0021 [image] Control- und Status-Bytes
Control- und Status-Bytes
Control-Byte 1 und Status-Byte 1
Prozessdatenbetrieb
Control-Byte 1 im Prozessdatenbetrieb
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | EnComp | SetOut | ReadLatchN | ReadLatchP | SetCnt | EnMeas | EnLatchC
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 | EnComp | 0bin | Kompare-Funktion zum Setzen und Rücksetzen des Ausgangs nicht freigegeben
 |  | 1bin | Kompare-Funktion zum Setzen und Rücksetzen des Ausgangs freigegeben
CB1.5 | SetOut | 0bin | setzt Ausgang manuell auf 0 V | SetOut funktioniert nur, wenn EnComp = 0bin
 |  | 1bin | setzt Ausgang manuell auf 24 V
CB1.4 | ReadLatchN | 1bin | Lesen der negativen Kante
CB1.3 | ReadLatchP | 1bin | Lesen der positiven Kante
CB1.2 | SetCnt | Der Zähler wird mit steigender Flanke von SetCnt auf den 32-Bit-Vorgabewert gesetzt, der von der Steuerung in die Prozessausgangsdaten geschrieben wird.
CB1.1 | EnMeas | 0bin | Werkstückmessung freigegeben | Ist die Werkstückmessung freigegeben, wird sie über CB1.3 und CB1.4 gelesen und in zwei Latch-Werten gespeichert.
 |  | 1bin | Werkstückmessung nicht freigegeben
CB1.0 | EnLatchC | 1bin | Die steigende Flanke des Nulleingangs (Eingang C) wird aktiviert. Beim ersten externen Latch-Impuls nach Gültigkeit des Bits EnLatchC wird der Counter-Wert im Latch-Register gespeichert. Die folgenden Impulse haben keinen Einfluss auf das Latch-Register. (Siehe folgenden Hinweis)
Hinweis
EnLatchC oder EnLatchRise und EnLatchFall?
Wenn Bit CB1.0 (EnLatchC) gesetzt ist, dürfen Bit CB1.3 (EnLatchRise) und Bit CB1.4 (EnLatchFall) nicht gesetzt sein, weil Sie sonst nicht wissen, welches Ereignis das Speichern eines Zählerwerts im Latch veranlasst hat.
Status-Byte 1 im Prozessdatenbetrieb
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | - | StOut | StGate | StLatchC | SetCnt | MeasDone | ValLatchC
Legende
Bit
Name
Beschreibung
SB1.7
RegAccess
0bin
Quittung für Prozessdatenbetrieb
SB1.6
-
reserviert
SB1.5
StOut
0bin
Status des Ausgangs ist 0 V
1bin
Status des Ausgangs ist 24 V
SB1.4
StGate
Status des externen Gate/Latch-Eingangs
SB1.3
StLatchC
Status des Nulleingangs (Eingang C)
SB1.2
SetCnt
Quittung, das die Daten zum Setzen des Zählers von der Klemme übernommen wurden.
SB1.1
MeasDone
1bin
Messung beendet
SB1.0
ValLatchC
1bin
Ein Nullpunkt-Latch ist aufgetreten: Eine steigende Flanke am Nulleingang (Eingang C) hat veranlasst, das der aktuelle Counter-Wert als Referenzmarke im Latch-Register gespeichert wurde.
Weitere Impulse haben keinen Einfluss mehr auf das Latch-Register. Um den Gate/Latch-Eingang erneut zu aktivieren müssen Sie:
▪
im Control-Byte das Bit 0 (EnLatchC) auf 0bin setzen.
▪
warten bis diese Änderung durch rücksetzen des Bit 0 (ValLatchC) im Status-Bytes quittiert wird.
▪
im Control-Byte das Bit 0 (EnLatchC) wieder auf 1bin setzen.
Registerkommunikation
Control-Byte 1 bei Registerkommunikation
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort 0 lesen oder - mit dem Ausgangsdatenwort 0 beschreiben wollen.
VORSICHT
Keine gültigen Prozessdaten währen der Registerkommunikation!
Während der Registerkommunikation kann nicht auf Datenregister zugegriffen werden! Prozessdaten, die eventuell noch angezeigt werden, sind nicht gültig!
Status-Byte 1 bei Registerkommunikation
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Control-Byte 2 und Status-Byte 2
Control-Byte 2 und Status-Byte 2 (CB2 und SB2) werden nicht benutzt.


KL5152-0000 (KL5150-0050)

Zugriff aus dem Anwenderprogramm [image] KL5152-0000 (KL5150-0050)
KL5152-0000 (KL5150-0050)
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Bytes
•
Mapping


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] KL5152-0000 (KL5150-0050) [image] Prozessabbild
Prozessabbild
Die Klemme kann mit verschieden großen Prozessabbildern betrieben werden:
▪
kompaktes Prozessabbild
▪
kompaktes Prozessabbild an Buskoppler, der auf komplettes Prozessabbild eingestellt ist (z.B. Lightbus)
▪
komplettes Prozessabbild
Im Auslieferungszustand der KL5151-0050 ist das kompakte Prozessabbild eingeschaltet. Mit Bit R32.6 des Feature-Registers können Sie die Größe des Prozessabbilds bestimmen.
Control-, Status-Byte und Mapping
▪
Die Bedeutung des Control- und Status-Bytes entnehmen Sie bitte der Seite Control- und Status-Bytes.
▪
Die Zuordnung der Bytes und Worte zu den Adressen der Steuerung entnehmen Sie bitte der Seite Mapping.
Kompaktes Prozessabbild
Zum Betrieb mit kompaktem Prozessabbild müssen Sie ihren Buskoppler auf kompaktes Mapping konfigurieren und Bit R32.6 des Feature-Registers der KL5151-0050 muss 1bin sein.
Die KL5151-0050 stellt sich im kompakten Prozessabbild mit 8 Byte Ein- und 8 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Eingangsdaten |  | Ausgangsdaten
Format | Inhalt | Format | Inhalt
Doppel-Wort | DataIN1 | Byte | CB1PD
 |  | Byte | reserviert
 |  | Byte | CB2PD
 |  | Byte | reserviert
Doppel-Wort | DataIN2 | Doppel-Wort | DataOUT
Legende
CB1PD: Control-Byte für Prozessdatenbetrieb des Kanals 1
CB2PD: Control-Byte für Prozessdatenbetrieb des Kanals 2
DataIN1: aktueller oder im Latch gespeicherter 32-Bit-Wert des Zählers 1 (die Auswahl erfolgt mit Bit CB1.1 des Control-Byte 1)
DataIN2: aktueller oder im Latch gespeicherter 32-Bit-Wert des Zählers 2 (die Auswahl erfolgt mit Bit CB2.1 des Control-Byte 2)
DataOUT: 32-Bit-Vorgabewert für Zähler 1 und Zähler 2
Hinweis
Keine Registerkommunikation möglich
In dieser Konfiguration eignen sich die Control-Bytes nur für den Prozessdatenbetrieb. Registerkommunikation ist nicht möglich!
Komplettes Prozessabbild
Zum Betrieb mit komplettem Prozessabbild müssen Sie ihren Buskoppler auf komplettes Mapping konfigurieren und Bit R32.6 des Feature-Registers der KL5151-0050 muss 0bin sein.
Die KL5151-0050 stellt sich im kompletten Prozessabbild mit 10 Byte Ein- und 10 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Eingangsdaten |  | Ausgangsdaten
Format | Inhalt | Format | Inhalt
Byte | SB1 | Byte | CB1
Doppel-Wort | DataIN1 | Doppel-Wort | DataOUT1
Byte | SB2 | Byte | CB2
Doppel-Wort | DataIN2 | Doppel-Wort | DataOUT2
Legende
SB1: Status-Byte für Kanal 1
SB2: Status-Byte für Kanal 2
CB1: Control-Byte für Kanal 1
CB2: Control-Byte für Kanal 2
DataIN1: aktueller oder im Latch gespeicherter 32-Bit-Wert des Zählers 1 (die Auswahl erfolgt mit Bit CB1.1 des Control-Byte 1)
DataIN2: aktueller oder im Latch gespeicherter 32-Bit-Wert des Zählers 2 (die Auswahl erfolgt mit Bit CB2.1 des Control-Byte 2)
DataOUT1: 32-Bit-Vorgabewert für Zähler 1
DataOUT2: 32-Bit-Vorgabewert für Zähler 2
Hinweis
Registerkommunikation möglich
In dieser Konfiguration können Sie die Control- und Status-Bytes wahlweise für Register-Kommunikation oder Prozessdatenbetrieb verwenden.
Kompaktes Prozessabbild an Buskoppler, der auf komplettes Prozessabbild eingestellt ist
Wenn Sie die KL5151-0050 an einem Buskoppler betreiben der per Default auf komplettes Prozessabbild eingestellt ist (z. B. Lightbus), Bit R32.6 des Feature-Registers der Klemme aber 1bin ist, ergibt sich folgendes Prozessabbild:
Eingangsdaten |  | Ausgangsdaten
Format | Inhalt | Format | Inhalt
Byte | SB1RC | Byte | CB1RC
Doppel-Wort | DataIN1 | Byte | CB1PD
 |  | Byte | reserviert
 |  | Byte | CB2PD
 |  | Byte | reserviert
Byte | SB2RC | Byte | CB2RC
Doppel-Wort | DataIN2 | Doppel-Wort | DataOUT
Legende
SB1RC: Status-Byte für Registerkommunikation mit Kanal 1
SB2RC: Status-Byte für Registerkommunikation mit Kanal 2
CB1RC: Control-Byte für Registerkommunikation mit Kanal 1
CB2RC: Control-Byte für Registerkommunikation mit Kanal 2
CB1PD: Control-Byte für Prozessdatenbetrieb des Kanals 1
CB2PD: Control-Byte für Prozessdatenbetrieb des Kanals 2
DataIN1: aktueller oder im Latch gespeicherter 32-Bit-Wert des Zählers 1 (die Auswahl erfolgt mit Bit CB1.1 des Control-Byte 1)
DataIN2: aktueller oder im Latch gespeicherter 32-Bit-Wert des Zählers 2 (die Auswahl erfolgt mit Bit CB2.1 des Control-Byte 2)
DataOUT: 32-Bit-Vorgabewert für Zähler 1 und Zähler 2
Hinweis
Registerkommunikation möglich
In dieser Konfiguration haben Sie für Register-Kommunikation und Prozessdatenbetrieb unterschiedliche Control- und Status-Bytes. Diese eignen sich nur für den jeweils angegebenen Zweck!
Mit Bit 7 der Control-Bytes für Registerkommunikation können Sie vom Prozessdatenbetrieb auf Registerkommunikation umschalten.
Bit 7 der Control-Bytes für Prozessdatenbetrieb wird nicht ausgewertet.


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] KL5152-0000 (KL5150-0050) [image] Control- und Status-Bytes
Control- und Status-Bytes
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 im Prozessdatenbetrieb
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | RS_CNT_LAT | EnLatchFall | EnLatchRise | SetCnt | ReadLatch | EnLatchC
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 | - | reserviert
CB1.5 | RS_CNT_LAT* | 1bin | Der Zähler wir mit der aktiven Flanke des Latch-Eingangs auf Null gesetzt. Welche Latch-Flanke aktiv ist, bestimmen Sie mit den Bits CB1.4, CB1.3 und CB1.0.
CB1.4 | EnLatchFall* | 1bin | Die fallende Flanke des Latch-Eingangs wird aktiviert. Beim ersten externen Latch-Impuls nach Gültigkeit des Bits EnLatchFall wird der Counter-Wert im Latch-Register gespeichert. Die folgenden Impulse haben keinen Einfluss auf das Latch-Register.
CB1.3 | EnLatchRise* | 1bin | Die steigende Flanke des Latch-Eingangs wird aktiviert. Beim ersten externen Latch-Impuls nach Gültigkeit des Bits EnLatchRise wird der Counter-Wert im Latch-Register gespeichert (hat Vorrang vor EnLatchFall). Die folgenden Impulse haben keinen Einfluss auf das Latch-Register.
CB1.2 | SetCnt | Der Zähler wird mit steigender Flanke von SetCnt auf den 32-Bit-Vorgabewert gesetzt, der von der Steuerung in die Prozessausgangsdaten geschrieben wird.
CB1.1 | ReadLatch | 0bin | Der aktuelle Wert des 32-Bit Zähler wird in die Prozesseingangsdaten eingeblendet.
 |  | 1bin | Der im Latch gespeicherte 32-Bit-Wert wird in die Prozesseingangsdaten eingeblendet.
CB1.0 | EnLatchC* | 1bin | Die steigende Flanke des Nulleingangs (Eingang C) wird aktiviert. Beim ersten externen Latch-Impuls nach Gültigkeit des Bits EnLatchC wird der Counter-Wert im Latch-Register gespeichert. Die folgenden Impulse haben keinen Einfluss auf das Latch-Register. (siehe folgenden Hinweis)
*) Gilt nicht für KL5152-0000 (KL5151-0050), da hier Latch-Eingang und Nulleingang nicht zur Verfügung stehen. Setzen Sie die Bits CB1.5, CB1.4, CB1.3 und CB1.0 der KL5152-0000 (KL5151-0050) immer auf 0bin!
Hinweis
EnLatchC oder EnLatchRise und EnLatchFall?
Wenn Bit CB1.0 (EnLatchC) gesetzt ist, dürfen Bit CB1.3 (EnLatchRise) und Bit CB1.4 (EnLatchFall) nicht gesetzt sein, weil Sie sonst nicht wissen, welches Ereignis das Speichern eines Zählerwerts im Latch veranlasst hat.
Status-Byte 1 im Prozessdatenbetrieb
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | - | - | StGate | StLatchC | SetCnt | ReadLatch | ValLatchC
Legende
Bit
Name
Beschreibung
SB1.7
RegAccess
0bin
Quittung für Prozessdatenbetrieb
SB1.6
-
reserviert
SB1.5
-
reserviert
SB1.4
StGate
KL5151-0000: Status des externen Gate/Latch-Eingangs
KL5152-0000 (KL5151-0050): reserviert
SB1.3
StLatchC
KL5151-0000: Status des Nulleingangs (Eingang C)
KL5152-0000 (KL5151-0050): reserviert
SB1.2
SetCnt
Quittung, das die Daten zum Setzen des Zählers von der Klemme übernommen wurden.
SB1.1
ReadLatch
0bin
Der aktuelle Wert des 32-Bit Zählers wurde in die Prozessdaten eingeblendet.
1bin
Der im Latch gespeicherte 32-Bit-Wert wurde in die Prozessdaten eingeblendet.
SB1.0
ValLatchC*
1bin
Ein Nullpunkt-Latch ist aufgetreten: Eine steigende Flanke am Nulleingang (Eingang C) hat veranlasst, das der aktuelle Counter-Wert als Referenzmarke im Latch-Register gespeichert wurde.
Weitere Impulse haben keinen Einfluss mehr auf das Latch-Register. Um den Gate/Latch-Eingang erneut zu aktivieren müssen Sie:
▪
im Control-Byte das Bit 0 (EnLatchC) auf 0bin setzen.
▪
warten bis diese Änderung durch rücksetzen des Bit 0 (ValLatchC) im Status-Bytes quittiert wird.
▪
im Control-Byte das Bit 0 (EnLatchC) wieder auf 1bin setzen.
*) Gilt nicht für KL5152-0000 (KL5151-0050), da hier Latch-Eingang und Nulleingang nicht zur Verfügung stehen.
Registerkommunikation
Control-Byte 1 bei Registerkommunikation
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort 0 lesen oder - mit dem Ausgangsdatenwort 0 beschreiben wollen.
VORSICHT
Keine gültigen Prozessdaten währen der Registerkommunikation!
Während der Registerkommunikation kann nicht auf Datenregister zugegriffen werden! Prozessdaten, die eventuell noch angezeigt werden, sind nicht gültig!
Status-Byte 1 bei Registerkommunikation
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2 (nur KL5152-0000 und KL5151-0050)
Control- und Status-Byte des Kanals 2 (CB2 und SB2) sind wie Control- und Status-Byte des Kanals 1 aufgebaut.


Mapping

Zugriff aus dem Anwenderprogramm [image] KL5152-0000 (KL5150-0050) [image] Mapping
Mapping
Die Busklemmen belegen Adressen im Prozessabbild der Steuerung. Die Zuordnung der Prozessdaten (Ein- und Ausgangsdaten) und Parametrierungsdaten (Control- und Status-Bytes) zu den Steuerungsadressen wird als Mapping bezeichnet. Die Art des Mappings ist abhängig von:
▪
dem verwendeten Feldbus-System
▪
dem Klemmentyp
▪
der Parametrierung des Buskopplers wie
- kompakte oder komplette Auswertung
- Intel- oder Motorola-Format
- Word-Alignment ein- oder ausgeschaltet
▪
der Parametrierung der KL5152-0000 (KL5151-0050) auf kompakte oder komplette Auswertung (Bit R32.6 des Feature-Registers)
Die Buskoppler (BKxxxx, LCxxxx) und Busklemmen Controller (BCxxxx, BXxxxx) werden mit bestimmten Voreinstellungen (Default-Einstellungen) ausgeliefert. Mit der Konfigurationssoftware KS2000 oder mit einer Master-Konfigurationssoftware (z. B. TwinCAT System Manager oder ComProfibus) können Sie diese Default-Einstellungen verändern.
Die folgenden Tabellen zeigen das Mapping in Abhängigkeit der verschiedenen Bedingungen. Die Inhalte der einzelnen Bytes entnehmen Sie bitte den Seiten Prozessabbild sowie Control- und Status-Bytes.
Kompakte Auswertung
Zum Betrieb mit kompaktem Prozessabbild müssen Sie ihren Buskoppler auf kompaktes Mapping konfigurieren und Bit R32.6 des Feature-Registers der KL5152-0000 (KL5151-0050) muss 1bin sein.
In dieser Konfiguration eignen sich die Control-Bytes nur für den Prozessdatenbetrieb. Registerkommunikation ist nicht möglich!
Kompakte Auswertung im Intel-Format
Default-Mapping für CANopen-, CANCAL-, DeviceNet-, ControlNet-, Modbus-, RS232- und RS485-Koppler
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | DataIN1 D1 | DataIN1 D0 | reserviert | CB1PD
 | 1 | DataIN1 D3 | DataIN1 D2 | reserviert | CB2PD
 | 2 | DataIN2 D1 | DataIN2 D0 | DataOUT D1 | DataOUT D0
 | 3 | DataIN2 D3 | DataIN2 D2 | DataOUT D3 | DataOUT D2
Kompakte Auswertung im Motorola-Format
Default-Mapping für PROFIBUS- und Interbus-Koppler
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | DataIN1 D2 | DataIN1 D3 | CB2PD | reserviert
 | 1 | DataIN1 D0 | DataIN1 D1 | CB1PD | reserviert
 | 2 | DataIN2 D2 | DataIN2 D3 | DataOUT D2 | DataOUT D3
 | 3 | DataIN2 D0 | DataIN2 D1 | DataOUT D0 | DataOUT D1
Komplette Auswertung
Zum Betrieb mit komplettem Prozessabbild müssen Sie ihren Buskoppler auf komplettes Mapping konfigurieren und Bit R32.6 des Feature-Registers der KL5151-0050 muss 0bin sein.
In dieser Konfiguration können Sie die Control- und Status-Bytes wahlweise für Register-Kommunikation oder Prozessdatenbetrieb verwenden.
Komplette Auswertung im Intel-Format
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | DataIN1 D0 | SB1 | DataOUT1 D0 | CB1
 | 1 | DataIN1 D2 | DataIN1 D1 | DataOUT1 D2 | DataOUT1 D1
 | 2 | SB2 | DataIN1 D3 | CB2 | DataOUT1 D3
 | 3 | DataIN2 D1 | DataIN2 D0 | DataOUT2 D1 | DataOUT2 D0
 | 4 | DataIN2 D3 | DataIN2 D2 | DataOUT2 D3 | DataOUT2 D2
Komplette Auswertung im Motorola-Format
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | DataIN1 D3 | SB1 | DataOUT1 D3 | CB1
 | 1 | DataIN1 D1 | DataIN1 D2 | DataOUT1 D1 | DataOUT1 D2
 | 2 | SB2 | DataIN1 D0 | CB2 | DataOUT1 D0
 | 3 | DataIN2 D2 | DataIN2 D3 | DataOUT2 D2 | DataOUT2 D3
 | 4 | DataIN2 D0 | DataIN2 D1 | DataOUT2 D0 | DataOUT2 D1
Komplette Auswertung im Intel-Format bei Word-Alignment
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | DataIN1 D1 | DataIN1 D0 | DataOUT1 D1 | DataOUT1 D0
 | 2 | DataIN1 D3 | DataIN1 D2 | DataOUT1 D3 | DataOUT1 D2
 | 3 | reserviert | SB2 | reserviert | CB2
 | 4 | DataIN2 D1 | DataIN2 D0 | DataOUT2 D1 | DataOUT2 D0
 | 5 | DataIN2 D3 | DataIN2 D2 | DataOUT2 D3 | DataOUT2 D2
Komplette Auswertung im Motorola-Format bei Word-Alignment
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | DataIN1 D2 | DataIN1 D3 | DataOUT1 D2 | DataOUT1 D3
 | 2 | DataIN1 D0 | DataIN1 D1 | DataOUT1 D0 | DataOUT1 D1
 | 3 | reserviert | SB2 | reserviert | CB2
 | 4 | DataIN2 D2 | DataIN2 D3 | DataOUT2 D2 | DataOUT2 D3
 | 5 | DataIN2 D0 | DataIN2 D1 | DataOUT2 D0 | DataOUT2 D1
Kompaktes Prozessabbild an Buskoppler, der auf komplettes Prozessabbild eingestellt ist
Wenn Sie die KL5152-0000 (KL5151-0050) an einem Buskoppler betreiben der per Default auf komplettes Prozessabbild eingestellt ist (z. B. Lightbus), Bit R32.6 des Feature-Registers der Klemme aber 1bin ist (Default-Einstellung), ergibt sich folgendes Prozessabbild.
In dieser Konfiguration haben Sie für Register-Kommunikation und Prozessdatenbetrieb unterschiedliche Control- und Status-Bytes. Diese eignen sich nur für den jeweils angegebenen Zweck!
Intel-Format
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | DataIN1 D0 | SB1RC | CB1PD | CB1RC
 | 1 | DataIN1 D2 | DataIN1 D1 | CB2PD | reserviert
 | 2 | SB2RC | DataIN1 D3 | CB2RC | reserviert
 | 3 | DataIN2 D1 | DataIN2 D0 | DataOUT D1 | DataOUT D0
 | 4 | DataIN2 D3 | DataIN2 D2 | DataOUT D3 | DataOUT D2
Motorola-Format
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | DataIN1 D3 | SB1RC | reserviert | CB1RC
 | 1 | DataIN1 D1 | DataIN1 D2 | reserviert | CB2PD
 | 2 | SB2RC | DataIN1 D0 | CB2RC | CB1PD
 | 3 | DataIN2 D2 | DataIN2 D3 | DataOUT D2 | DataOUT D3
 | 4 | DataIN2 D0 | DataIN2 D1 | DataOUT D0 | DataOUT D1
Intel-Format bei Word-Alignment
Default-Mapping für EtherCAT-, Lightbus- und Ethernet-Koppler sowie Busklemmen Controller (BCxxxx, BXxxxx)
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1RC | reserviert | CB1RC
 | 1 | DataIN1 D1 | DataIN1 D0 | reserviert | CB1PD
 | 2 | DataIN1 D3 | DataIN1 D2 | reserviert | CB2PD
 | 3 | reserviert | SB2RC | reserviert | CB2RC
 | 4 | DataIN2 D1 | DataIN2 D0 | DataOUT D1 | DataOUT D0
 | 5 | DataIN2 D3 | DataIN2 D2 | DataOUT D3 | DataOUT D2
Motorola-Format bei Word-Alignment
Parametrierung des Buskopplers | Adresse | Eingangsdaten |  | Ausgangsdaten
 | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1RC | reserviert | CB1RC
 | 1 | DataIN1 D2 | DataIN1 D3 | CB2PD | reserviert
 | 2 | DataIN1 D0 | DataIN1 D1 | CB1PD | reserviert
 | 3 | reserviert | SB2RC | reserviert | CB2RC
 | 4 | DataIN2 D2 | DataIN2 D3 | DataOUT D2 | DataOUT D3
 | 5 | DataIN2 D0 | DataIN2 D1 | DataOUT D0 | DataOUT D1
Legende
Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.
SB n: Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)
SB n PD: Status-Byte für Kanal n, nur für Prozessdatenbetrieb zu nutzen (erscheint im Eingangsprozessabbild)
CB n PD: Control-Byte für Kanal n, nur für Prozessdatenbetrieb zu nutzen (erscheint im Ausgangsprozessabbild)
SB n RC: Status-Byte für Kanal n, nur für Registerkommunikation zu nutzen (erscheint im Eingangsprozessabbild)
CB n RC: Control-Byte für Kanal n, nur für Registerkommunikation zu nutzen (erscheint im Ausgangsprozessabbild)
DataIN n D0: Kanal n, Eingangsdoppelwort, niederwertigste Daten-Byte
DataIN n D1: Kanal n, Eingangsdoppelwort, ...
DataIN n D2: Kanal n, Eingangsdoppelwort, ...
DataIN n D3: Kanal n, Eingangsdoppelwort, höchstwertigste Daten-Byte
DataOUT n D0: Kanal n, Ausgangsdoppelwort, niederwertigste Daten-Byte
DataOUT n D1: Kanal n, Ausgangsdoppelwort, ...
DataOUT n D2: Kanal n, Ausgangsdoppelwort, ...
DataOUT n D3: Kanal n, Ausgangsdoppelwort, höchstwertigste Daten-Byte
reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.


Register

Zugriff aus dem Anwenderprogramm [image] Register
Register
Weiterführende Informationen
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Register [image] Registerübersicht
Registerübersicht
Register | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | KL5151-0021: | Filter-Register | 0x0000 | 0dez | R/W | RAM
 | andere Typen: | reserviert | - | - | - | -
R1 bis R5 | reserviert |  | - | - | - | -
R6 | Diagnose-Register (nicht benutzt) |  | 0x0000 | 0dez | R | RAM
R7 | Kommando-Register (nicht benutzt) |  | 0x0000 | 0dez | R/W | RAM
R8 | Klemmenbezeichnung | KL5151-0000: | 0x141F | 5151dez | R | ROM
 |  | KL5151-0023:
 |  | KL5151-0050:
 |  | KL5152-0000: | 0x1420 | 5152dec
R9 | Firmware-Stand |  | z.B. 0x3341 | z. B. 3AASCII | R | ROM
R10 | Multiplex-Schieberegister |  | 0x0228 | 552dez | R | ROM
R11 | Signalkanäle | KL5151-0000: | 0x0128 | 296dez | R | ROM
 |  | KL5151-0023: | 0x0150 | 336dez
 |  | KL5151-0050: | 0x0228 | 552dez
 |  | KL5152-0000:
R12 | minimale Datenlänge | KL5151-0000: | 0x2828 | 10280dez | R | ROM
 |  | KL5151-0023: | 0x5050 | 20560dez
 |  | KL5151-0050: | 0xA8A8 | 43176dez
 |  | KL5152-0000:
R13 | Datentyp |  | 0x0006 | 6dez | R | ROM
R14 | reserviert |  | - | - | - | -
R15 | Alignment-Register |  | variabel | variabel | R/W | RAM
R16 | Hardware Version |  | z.B. 0x0000 | z.B. 0dez | R/W | SEEROM/RAM
R17 bis R30 | reserviert |  | - | - | - | -
R29 | Klemmentyp Sonderkennung | KL5151-0000: | 0x0000 | 0dez | R | ROM
 |  | KL5151-0023: | 0x0017 | 23dez
 |  | KL5151-0050: | 0x0032 | 50dez
 |  | KL5152-0000: | 0x0000 | 0dez
R31 | Codewort-Register |  | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register | KL5151-0000: | 0x0000 | 0dez | R/W | SEEROM/RAM
 |  | KL5151-0023: | 0x0000 | 0dez
 |  | KL5151-0050: | 0x00C0 | 192dez
 |  | KL5152-0000:
R33 bis R34 | reserviert |  | - | - | - | -
R35 | KL5151-0021 | Filter-Default | 0x0000 | 0dez | R/W | SEEROM/RAM
 | andere Typen | reserviert | - | - | - | -
R36 bis R63 | reserviert |  | - | - | - | -


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Register [image] Registerbeschreibung
Registerbeschreibung
R0: Filter-Register (nur KL5151-0021)
Es sind nur Werkstücklängen gültig, die größer als die hier angegebene Länge sind (Angaben in Inkrementen).
R6: Diagnoseregister
Wird nicht benutzt.
R7: Kommandoregister
Wird nicht benutzt.
R8: Klemmenbezeichnung
Im Register R8 steht in hexadezimaler Codierung die Bezeichnung der Klemme.
KL5151-0000: 0x141F (5151dez)
KL5151-0023: 0x141F (5151dez)
KL5151-0050: 0x141F (5151dez)
KL5152-0000: 0x1420 (5152dez)
R9: Firmware-Stand
Im Register R9 steht in hexadezimaler Codierung der Firmware-Stand der Klemme, z. B. 0x3341. Dies ist als ASCII-Code zu interpretieren:
- ASCII-Code 0x33 steht für die Ziffer 3
- ASCII-Code 0x41steht für den Buchstaben A
Die Firmwareversion lautet in diesem Beispiel also 3A.
R10: Schieberegisterlänge
0x0228
R11: Anzahl der Signalkanäle
KL5151-0000: 0x0128 (296dez)
KL5151-0023: 0x0150 (336dez)
KL5151-0050: 0x0228 (552dez)
KL5152-0000: 0x0228 (552dez)
R12: Minimale Datenlänge
KL5151-0000: 0x2828 (10280dez)
KL5151-0023: 0x5050 (20560dez)
KL5151-0050: 0xA8A8 (43176dez)
KL5152-0000: 0xA8A8 (43176dez)
R13: Datentyp
Im Register R13 steht der Datentyp der Busklemme. 0x0006 steht für Sonderfunktion.
R15: Alignment-Register
Mit den Bits des Alignment-Registers wird die Klemme im Buskoppler auf eine Bytegrenze gelegt.
R16: Hardware Versionsnummer
Im Register R16 steht in hexadezimaler Codierung der Hardware-Stand der Klemme, z. B. 0x0000 (0dez).
R29: Klemmentyp Sonderkennung
KL5151-0000: 0x0000 (0dez)
KL5151-0023: 0x0017 (23dez)
KL5151-0050: 0x0032 (50dez)
KL5152-0000: 0x0000 (0dez)
Anwender-Register
Die Anwender-Register der Klemme können vom Anwenderprogramm beschrieben werden um die Eigenschaften der Klemme zur Laufzeit zu verändern.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte nur in die RAM-Register, nicht aber in die EPROM-Register gespeichert und gehen somit bei einem Neustart der Klemme verloren.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die EPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Feature-Register (KL5151-0000, KL5151-0050, KL5152-0000)
Das Feature-Register legt verschiedene Eigenschaften der Klemme fest.
Bit | Feature | Wert | Erläuterung | Default
R32.15 | OperationMode | 0bin | Encoder Interface | 0bin
 |  | 1bin | Einkanaliger Zähler (32 Bit Vorwärts/Rückwärts)
R32.14 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.8 | - | reserviert |  | 0bin
R32.7 | - | reserviert |  | KL5151-0000: 0bin KL5151-0021: 0bin KL5151-0050: 1bin KL5152-0000: 1bin
R32.6 | enCompact ProcessImage | 0bin | KL5151-0050, KL5152-0000: komplettes Prozessabbild mit Status- und Control-Bytes KL5151-0000: komplettes Prozessabbild mit Status- und Control-Byte | KL5151-0000: 0bin KL5151-0021: 0bin KL5151-0050: 1bin KL5152-0000: 1bin
 |  | 1bin | KL5151-0050, KL5152-0000: kompaktes Prozessabbild ohne Status- aber mit Control-Byte KL5151-0000: kompaktes Prozessabbild ohne Status- und ohne Control-Byte Ein sinnvoller Betrieb der KL5151-0000 ist kompaktem Prozessabbild nicht möglich, da das Control-Byte zur Steuerung des Zählers und des Latches benötigt wird!
R32.5 | enPosGateLock | 0bin | Positiver Pegel am Gate-Eingang sperrt den Zähler nicht. | 0bin
 |  | 1bin | Positiver Pegel am Gate-Eingang sperrt den Zähler.
R32.4 | enNegGateLock | 0bin | Negativer Pegel am Gate-Eingang sperrt den Zähler nicht. | 0bin
 |  | 1bin | Negativer Pegel am Gate-Eingang sperrt den Zähler.
R32.3 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.0 | - | reserviert |  | 0bin
Hinweis
Betrieb der KL5152-0000 (KL5151-0050) als einkanaliger Zähler
Da im Betrieb der KL5152-0000 (KL5151-0050) als Zähler der Anschluss A2 für die Freigabe (Gate) des Zählers benutzt wird, ist ein Betrieb als zweikanaliger Zähler nicht möglich.
R32: Feature-Register (KL5151-0021)
Das Feature-Register legt verschiedene Eigenschaften der Klemme fest.
Bit | Feature | Wert |  | Erläuterung | Default
R32.15 | - | reserviert |  |  | 0bin
R32.14 | B_MES_INV | 0bin | zuerst die positive, dann die negative Flanke ermitteln |  | 0bin
 |  | 1bin | invertierte Messung durchführen: d.h. zuerst die negative, dann die positive Flanke ermitteln
R32.13 | - | reserviert |  |  | 0bin
... | ... | ... |  |  | ...
R32.0 | - | reserviert |  |  | 0bin
R35: Filter-Default (nur KL5151-0021)
Der hier hinterlegte Wert wird nach einem Reset der Klemme in Register R0 eingetragen (Angaben in Inkrementen).


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Register [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Register [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Register [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Hinweis
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.