KL4494 - Analogklemme mit zwei Eingangs-, und zwei Ausgangskanälen, -10 V...+10V
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Beckhoff Identification Code (BIC)


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.1.0
▪
Update Kapitel „Hinweise zum ESD-Schutz“
▪
Kapitel „Beckhoff Identification Code (BIC)“ eingefügt
2.0.0
▪
Migration
▪
Strukturupdate
▪
Update Kapitel Technische Daten
▪
Revisionsstand aktualisiert
▪
Kapitel Hinweise zum ESD-Schutz eingefügt
▪
Kapitel Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit eingefügt
▪
Kapitel ATEX - Besondere Bedingungen (Standardtemperaturbereich) und ATEX-Dokumentation eingefügt
▪
Update Kapitel Anschlusstechnik -> Anschluss
1.1.0
▪
Beschreibung der Konfigurations-Software KS2000 erweitert
▪
Beschreibung der Grundlagen zur Funktion hinzugefügt
▪
Technische Daten aktualisiert
▪
Registerübersicht und Registerbeschreibung aktualisiert
▪
Firm- und Hardware-Stände aktualisiert
1.0
▪
Beschreibung der Anschlussbelegung aktualisiert
▪
Technische Daten aktualisiert
▪
Englische Version verfügbar
0.1
▪
Vorabversion (nur in deutscher Sprache verfügbar)
Firm- und Hardware-Stände
Dokumentation Version | Firmware | Hardware
2.0.0 | 1C | 04
1.1.0 | 1B | 02
1.0 | 1B | 01
0.1 | 1A | 00
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 31 05 1B 01:
31 - Produktionswoche 31
05 - Produktionsjahr 2005
1B - Firmware-Stand 1B
01 - Hardware-Stand 01


Beckhoff Identification Code (BIC)

Vorwort [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Diagnose-LEDs
•
Grundlagen zur Funktion


Einführung

Produktübersicht [image] Einführung
Einführung
KL4494
Analogklemme mit zwei Eingangs- und zwei Ausgangskanälen, -10 V bis 10 V
Die Busklemme KL4494 kombiniert zwei analoge Eingänge und zwei analoge Ausgänge in einem Gehäuse und verarbeitet Signale im Bereich von -10 V bis +10 V. Die Spannung wird mit einer Auflösung von 12 Bit digitalisiert und galvanisch getrennt zum übergeordneten Automatisierungsgerät bzw. zur Prozessebene transportiert. Die Ein- und Ausgangskanäle der Busklemme besitzen ein gemeinsames Massepotenzial, das vom 0 V Powerkontakt galvanisch getrennt ist. Die RUN-LEDs zeigen den Datenaustausch mit dem Buskoppler an.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | KL4494
Anzahl der Ausgänge | 2
Anzahl der Eingänge | 2 (single-ended)
Signalspannung | -10 V bis +10 V
Bürde je Ausgang | > 5 kΩ
Innenwiderstand je Eingang | > 130 kΩ
Auflösung | 12 Bit
Messfehler (gesamter Messbereich) | ±0,3% vom Messbereichsendwert
Wandlungszeit | < 2 ms
Bitbreite im Eingangsprozessabbild | 2 Datenworte, 2 Status-Bytes
Bitbreite im Ausgangsprozessabbild | 2 Datenworte, 2 Control-Bytes
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 70 mA
Potenzialtrennung | 500 V (Signalspannung / K-Bus)
Anschluss | Federkrafttechnik
Gewicht | ca. 55 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, UL, ATEX


Diagnose-LEDs

Produktübersicht [image] Diagnose-LEDs
Diagnose-LEDs
Die vier grünen RUN-LEDs zeigen den Betriebszustand der Klemmenkanäle an.
KL4494 - LEDs
Bedeutung der LED-Anzeigen
LED | Farbe | Kanal | Zustand
 |  |  | Ein | aus
Run IN 1 | grün | Eingang 1 | normaler Betrieb | Ein Watchdog-Timer Overflow ist aufgetreten. Wenn zwischen Steuerung und Buskoppler innerhalb von 100 ms keine Prozessdaten übertragen werden, so erlöschen die grünen LEDs.
Run IN 2 |  | Eingang 2
Run OUT 1 |  | Ausgang 1
Run OUT 2 |  | Ausgang 2


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Analoge Eingangskanäle
Die analogen Eingangskanäle der KL4494 verarbeiten Signale im Bereich von -10 V bis +10 V mit einer Auflösung von 12-Bit (4095 Schritte). Bei den Eingängen handelt es sich um Single-Ended-Eingänge mit einem gemeinsamen Massepotential.
Format der Eingangswerte
Die Prozessdaten werden im Auslieferungszustand im Zweierkomplement dargestellt (-1integer entspricht 0xFFFF). Über das Feature-Register R32 ist das Siemens-Ausgabeformat als Alternative anwählbar.
Messwert | Eingangsdaten
 | dezimal | hexadezimal
-10 V | -32768 | 0x8000
-5 V | -16383 | 0xC001
0 V | 0 | 0x0000
+5 V | 16383 | 0x3FFF
+10 V | 32767 | 0x7FFF
Gleichungen für die Prozessdaten
Die Prozessdaten, die zum Buskoppler übertragen werden, berechnen sich aus den folgenden Gleichungen:
Weder Anwender noch Herstellerskalierung aktiv
Ya = (Ba + XADC) x Aa | (1.0)
Yaus = Ya |
Herstellerskalierung aktiv (Default- Einstellung)
Y1 = Bh + Ah x Ya | (1.1)
Yaus = Y1 |
Anwenderskalierung aktiv
Y2 = Bw + Aw x Ya | (1.2)
Yaus = Y2 |
Hersteller- und Anwenderskalierung aktiv
Y1 = Bh + Ah x Ya | (1.3)
Y2 = Bw + Aw x Y1 | (1.4)
Yaus = Y2 |
Legende
Xadc: | Ausgabewerte des A/D-Wandlers |
Yaus: | Prozessdaten zur SPS |
Ba , Aa: | Hersteller Gain- und Offsetabgleich | (R17, R18)
Bh , Ah: | Hersteller-Skalierung | (nicht implementiert)
Bw, Aw: | Anwender-Skalierung | (R33, R34)
Die Geradengleichungen werden über Register R32 aktiviert.
Analoge Ausgangskanäle
Die analogen Ausgangskanäle der KL4494 erzeugen Signale im Bereich von -10 V bis +10 V mit einer Auflösung von 12-Bit (4095 Schritte). Bei den Ausgängen handelt es sich um Single-Ended-Ausgänge mit einem gemeinsamen Massepotential.
Format der Ausgabewerte
Die Prozessdaten werden im Auslieferungszustand im Zweierkomplement dargestellt (-1integer entspricht 0xFFFF). Über das Feature-Register R32 ist das Siemens-Ausgabeformat als Alternative anwählbar.
Ausgabewert |  | Ausgangsspannung
hexadezimal | dezimal
0x8000 | -32768 | -10 V
0xC001 | -16383 | -5 V
0x0000 | 0 | 0 V
0x3FFF | 16383 | +5 V
0x7FFF | 32767 | +10 V
Gleichungen für die Prozessdaten
Die Prozessdaten, die zur Busklemme übertragen werden, berechnen sich aus den folgenden Gleichungen:
Weder Anwender noch Herstellerskalierung aktiv
Ydac = X x Aa + Ba
(1.0)
Herstellerskalierung aktiv (Default- Einstellung)
Y1 = Bh + Ah x X | (1.1)
Ydac = Y1 x Aa + Ba |
Anwenderskalierung aktiv
Y2 = Bw + Aw x X | (1.2)
Ydac = Y2 x Aa + Ba |
Hersteller- und Anwenderskalierung aktiv
Y1 = Bh + Ah x X | (1.3)
Y2 = Bw + Aw x Y1 | (1.4)
Ydac = Y2 x Aa + Ba |
Legende
X: | Prozessdaten der Steuerung |
Ydac: | Prozessdaten zum D/A-Wandler |
Ba , Aa: | Hersteller Gain- und Offsetabgleich | (R19, R20)
Bh , Ah: | Hersteller-Skalierung | (nicht implementiert)
Bw, Aw: | Anwender-Skalierung | (R36, R37)
Die Geradengleichungen werden über Register R32 aktiviert.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss
•
Anschluss
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX-Dokumentation


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endklemme KL9010 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
KL4494
Klemmstelle | Nr. | Anschluss für
Input 1 | 1 | Eingang 1, Signal
GND | 2 | Masse*
Output 2 | 3 | Ausgang 1, Signal
GND | 4 | Masse*
Input 2 | 5 | Eingang 2, Signal
GND | 6 | Masse*
Output 2 | 7 | Ausgang 2, Signal
GND | 8 | Masse*
*) Die Ein- und Ausgangskanäle der Busklemme besitzen ein gemeinsames Massepotenzial, das vom 0 V Powerkontakt galvanisch getrennt ist.


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Register
•
Einstellungen
•
Prozessdaten


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies:
▪
ein Buskoppler für Ethernet BK9000,
▪
eine digitale Eingangsklemme KL1xx2,
▪
eine Analogklemme mit 2 Eingangs- und 2 Ausgangskanälen KL4494,
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).
KS2000 Baumzweige für Kanal 1 der KL4494
Für die KL4494 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL4494.
▪
Unter Einstellungen finden Sie Dialogmaske zur Parametrierung der KL4494.
▪
ProcData zeigt die Prozessdaten der KL4494.


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register der KL4494 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Registeransicht in KS2000


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Unter Einstellungen finden Sie die Dialogmaske zur Parametrierung der KL4494.
Einstellungen über KS2000
Betriebsart (Analog-Eingang)
▪
Anwender-Skalierung aktiv (R32.0)
Hier können Sie die Anwender-Skalierung aktivieren (Default: deaktiviert).
▪
Hersteller-Skalierung aktiv (R32.1)
Hier können Sie die Hersteller-Skalierung deaktivieren (Default: aktiviert).
▪
Watchdog-Timer aktiv (R32.2)
Hier können Sie den Watchdog Timer deaktivieren (Default: aktiviert).
▪
Siemens-Ausgabeformat aktiv (R32.3)
Hier können Sie das Siemens-Ausgabeformat aktivieren (Default: deaktiviert).
Betriebsart (Analog-Ausgang)
▪
Anwender-Skalierung aktiv (R32.8)
Hier können Sie die Anwender-Skalierung aktivieren (Default: deaktiviert).
▪
Hersteller-Skalierung aktiv (R32.9)
Hier können Sie die Hersteller-Skalierung deaktivieren (Default: aktiviert).
▪
Watchdog-Timer aktiv (R32.10)
Hier können Sie den Watchdog Timer deaktivieren (Default: aktiviert).
▪
Siemens-Ausgabeformat aktiv (R32.11)
Hier können Sie das Siemens-Ausgabeformat aktivieren (Default: deaktiviert).
▪
Anwender-Einschaltwert aktiv (R32.12)
Hier können Sie den Anwender-Einschaltwert aktivieren (Default: deaktiviert).
▪
Anwender-Einschaltwert (R35)
Hier können Sie den Anwender-Einschaltwert vorgeben (Default: 0).
Anwender-Skalierung (Analog-Eingang)
▪
Offset (R33)
Hier können Sie den Offset für die Anwender-Skalierung des analogen Eingangs vorgeben (Default: 0).
▪
Gain (R34)
Hier können Sie den Verstärkungsfaktor (Gain) für die Anwender-Skalierung des analogen Eingangs vorgeben (Default: 256dez, entspricht einem Verstärkungsfaktor von 1).
Anwender-Skalierung (Analog-Ausgang)
▪
Offset (R36)
Hier können Sie den Offset für die Anwender-Skalierung des analogen Ausgangs vorgeben (Default: 0).
▪
Gain (R37)
Hier können Sie den Verstärkungsfaktor (Gain) für die Anwender-Skalierung des analogen Ausgangs vorgeben (Default: 256dez, entspricht einem Verstärkungsfaktor von 1).


Prozessdaten

Konfigurations-Software KS2000 [image] Prozessdaten
Prozessdaten
Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.
Feld Prozessdaten
Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.
Feld Verlauf
Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.
Feld Wert - Darstellung des Eingangswerts
Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.
Feld Wert - Eingabe der Ausgangswerte
SmallWarningYellow GEFAHR
Gefahr für Personen, Umwelt oder Geräte
Beachten Sie, das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann.
Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, das Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.
Einstellung der Darstellung


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Bytes
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Die KL4494 stellt sich im Prozessabbild mit 6 Byte Ein- und 6 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | Status-Byte (SB1) | Control-Byte (CB1)
1 | 2 | Wort | DataIN1 | DataOUT1
3 | 4 | Byte | Status-Byte (SB2) | Control-Byte (CB2)
4 | 6 | Wort | DataIN2 | DataOUT2
*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Bytes
Control- und Status-Bytes
Kanal 1: Im Folgenden werden die Control- und Status-Bytes für Kanal 1 dargestellt.
Kanal 2: Control- und Status-Bytes des Kanals 2 sind wie Control- und Status-Byte des Kanals 1 aufgebaut.
Prozessdatenbetrieb
Control-Byte 1 (CB1) im Prozessdatenbetrieb
Das Control-Byte 1 befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen. Es hat im Prozessdatenbetrieb keine Funktion.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 - CB1.0 | - | 0bin | reserviert
Status-Byte 1 (SB1) im Prozessdatenbetrieb
Das Status-Byte 1 befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | LimitValue 2 State |  | LimitValue 1 State |  | Overrange | Underrange
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 | Error | 1bin | allgemeines Fehlerbit
SB1.5 - SB1.4 | LimitValue 2 State | 00bin | Grenzwert 2 nicht aktiviert
 |  | 01bin | Prozessdaten kleiner Grenzwert 2
 |  | 10bin | Prozessdaten größer Grenzwert 2
 |  | 11bin | Prozessdaten gleich Grenzwert 2
SB1.3 - SB1.2 | LimitValue 1 State | 00bin | Grenzwert 1 nicht aktiviert
 |  | 01bin | Prozessdaten kleiner Grenzwert 1
 |  | 10bin | Prozessdaten größer Grenzwert 1
 |  | 11bin | Prozessdaten gleich Grenzwert 1
SB1.1 | Overrange | 1bin | zulässiger Messbereich überschritten
SB1.0 | Underrange | 1bin | zulässiger Messbereich unterschritten
Registerkommunikation
Control-Byte 1 (CB1) bei Registerkommunikation
Das Control-Byte 1 befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit
Name
Beschreibung
CB1.7
RegAccess
1bin
Registerkommunikation eingeschaltet
CB1.6
R/W
0bin
Lesezugriff
1bin
Schreibzugriff
CB1.5 bis CB1.0
Reg-Nr.
Registernummer:
Tragen Sie hier die Nummer des Registers ein, dass Sie
▪
mit dem Eingangsdatenwort DataIN1 lesen oder
▪
mit dem Ausgangsdatenwort DataOUT1
Status-Byte 1 (SB1) bei Registerkommunikation
Das Status-Byte 1 befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die folgenden Register dienen zur Parametrierung der KL4494. Sind für jeden Signalkanal der Analogklemme einmal vorhanden und können mit Hilfe von Control-, Status- und Daten-Bytes über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | Rohwert des A/D-Wandlers (XR) | - | - | R | RAM
R1 | reserviert | - |  | - | -
... | ... | ... | ... | ... | ...
R5 | reserviert | - | - | - | -
R6 | Diagnose-Register | - | - | R | RAM
R7 | Kommando-Register | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | 0x118E | 4494dez | R | ROM
R9 | Firmware-Stand | z.B. 0x3141 | z.B. 1AASCI | R | ROM
R10 | Datenlänge (Multiplex-Schieberegister) | 0x0130 | 304dez | R | ROM
R11 | Signalkanäle | 0x0218 | 536dez | R | ROM
R12 | minimale Datenlänge | 0x9898 | 39064dez | R | ROM
R13 | Datenstruktur (Datentyp-Register) | 0x0004 | 4dez | R | ROM
R14 | reserviert | - | - | - | -
R15 | Alignment-Register | z.B. 0x7F80 | z.B. 32640dez | R/W | RAM
R16 | Hardware-Versionsnummer | z.B. 0x0000 | z.B. 0dez | R/W | SEEPROM
R17 | Hersteller-Skalierung, Analogeingang: Offset (Ba) | variabel | variabel | R/W | SEEPROM
R18 | Hersteller-Skalierung, Analogeingang: Gain (Aa) | typ. 0x1080 | typ. 4224dez | R/W | SEEPROM
R19 | Hersteller-Skalierung, Analogausgang: Offset (Ba) | 0x0800 | 2048dez | R/W | SEEPROM
R20 | Hersteller-Skalierung, Analogausgang: Gain (Aa) | typ. 0x7D00 | typ. 32000dez | R/W | SEEPROM
R21 | Overrange-Limit | 0x0000 | 0dez | R/W | SEEPROM
R22 | Underrange-Limit | 0x0000 | 0dez | R/W | SEEPROM
R23 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R30 | reserviert | - | - | - | -
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register | 0x0404 | 1028dez | R/W | SEEPROM
R33 | Anwender-Skalierung, Analogeingang: Offset (Bw) | 0x0000 | 0dez | R/W | SEEPROM
R34 | Anwender-Skalierung, Analogeingang: Gain (Aw) | 0x0100 | 256dez | R/W | SEEPROM
R35 | Anwender-Default-Wert für Analogausgang | 0x0000 | 0dez | R/W | SEEPROM
R36 | Anwender-Skalierung, Analogausgang: Offset (Bw) | 0x0000 | 0dez | R/W | SEEPROM
R37 | Anwender-Skalierung, Analogausgang: Gain (Aw) | 0x0100 | 256dez | R/W | SEEPROM
R38 | reserviert | - | - | - | -
... | reserviert | ... | ... | ... | ...
R63 | reserviert | - | - | - | -


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Alle Register können über die Registerkommunikation ausgelesen oder beschrieben werden.
R0: Rohwert A/D-C
Rohwert des A/D-Wandlers (XR)
R6: Diagnose-Register
In das niederwertige Byte (Bit 7 bis Bit 0) des Register R6 wird das Status-Byte eingeblendet.
Das höherwertige Byte (Bit 15 bis Bit 8) des Register R6 ist reserviert.
R7: Kommando-Register
Das Kommandoregister der KL4494 wird zur Zeit nicht benutzt.
R8: Klemmenbezeichnung
Im Register R8 steht die Bezeichnung der Klemme: 0x118E (4494dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z.B. 0x3141 (1A)ASCII. Hierbei entspricht '0x31' dem ASCII-Zeichen '1' und '0x41' dem ASCII-Zeichen 'A'. Dieser Wert kann nicht verändert werden.
R10: Datenlänge (Multiplex-Schieberegister)
R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit.
R11: Signalkanäle
Im Gegensatz zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z. B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.
R12: Minimale Datenlänge
Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control- und Status-Byte nicht zwingend notwendig für die Funktion der Klemme und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen.
R13: Datenstruktur (Datentyp-Register)
Datentypregister | Bedeutung
0x00 | Klemme ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur: 1 Byte, n Bytes
0x03 | Wort-Array
0x04 | Struktur: 1 Byte, n Worte
0x05 | Doppelwort-Array
0x06 | Struktur: 1 Byte, n Doppelworte
0x07 | Struktur: 1 Byte, 1 Doppelwort
0x08 | Struktur: 1 Byte, 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur: 1 Byte, n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur: 1 Byte, n Worte mit variabler logischer Kanallänge
0x15x | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur: 1 Byte, n Doppelworte mit variabler logischer Kanallänge
R15: Alignment-Register
Mit Hilfe der Bits des Alignment-Registers legt der Buskoppler den Adressbereich einer Analogklemme so, dass er auf einer auf Byte-Grenze beginnt.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme, dieser Wert kann nicht verändert werden.
R17: Hardware-Abgleich für Analogeingang - Offset (Ba)
Über dieses Register erfolgt der Offset-Abgleich des Analogeingangs (siehe Gleichung 1.1).
R18: Hardware-Abgleich für Analogeingang - Gain (Aa)
Über dieses Register erfolgt der Gain-Abgleich des Analogeingangs.
Skalierung: Verstärkungsfaktor = R18 x 2-12 (siehe Gleichung 1.1)
Beispiel: 4096dez (0x1000), entspricht einem Verstärkungsfaktor von 1
R19: Hardware-Abgleich für Analogausgang - Offset (Ba)
Über dieses Register erfolgt der Offset-Abgleich des Analogausgangs (siehe Gleichung 1.1).
R20: Hardware-Abgleich für Analogausgang - Gain (Aa)
Über dieses Register erfolgt der Gain-Abgleich des Analogausgangs.
Skalierung: Verstärkungsfaktor = R20 x 2-15 (siehe Gleichung 1.1)
Beispiel: 32768dez (0x8000), entspricht einem Verstärkungsfaktor von 1
R21 Overrange-Limit - OvRL (Ya)
Dieser Grenzwert beschränkt den maximalen Messbereich der Eingangsklemme (siehe Gleichung 1.0). Wird er überschritten, so wird das entsprechende Statusbit gesetzt und der Maximalwert ausgegeben.
R22 Underrange-Limit - UnRL (Ya)
Wird dieser Grenzwert unterschritten, so wird das entsprechende Statusbit gesetzt und der Minimalwert ausgegeben (siehe Gleichung 1.0).
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei jedem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Konfiguration der Klemme fest. Default: 0x0404 (1028dez)
High-Byte: Konfiguration des Analogausgangs
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | enUsrDefault | enSiemens | enWDT | enManScal | enUsrScal
Low-Byte: Konfiguration des Analogeingangs
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | - | enSiemens | enWDT | enManScal | enUsrScal
Legende
Bit | Name | Beschreibung |  | default
R32.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.13 | - | reserviert |  | 0bin
R32.12 | enUsrDefault | 1bin | Mit Register R35 vorgegebener Anwender-Default-Wert aktiv | 0bin
R32.11 | enSiemens Analog Output | 0bin | Standard-Ausgabeformat | 0bin
 |  | 1bin | Siemens-Ausgabeformat
R32.10 | enWDT | 1bin | Watchdog timer aktiv | 1bin
R32.9 | enManScal Analog Output | 0bin | Hersteller-Skalierung aktiv | 0bin
 |  | 1bin | Hersteller-Skalierung nicht aktiv
R32.8 | enUsrScal Analog Output | 0bin | Anwender-Skalierung nicht aktiv | 0bin
 |  | 1bin | Anwender-Skalierung aktiv
R32.7 | - | reserviert |  | 0bin
R32.6 | - | reserviert |  | 0bin
R32.5 | - | reserviert |  | 0bin
R32.4 | - | reserviert |  | 0bin
R32.3 | enSiemens Analog Input | 0bin | Standard-Ausgabeformat | 0bin
 |  | 1bin | Siemens-Ausgabeformat: Auf den niederwertigsten 3 Bits des Prozessdatums werden Statusanzeigen eingeblendet (siehe unten).
R32.2 | enWDT | 1bin | Watchdog timer aktiv | 1bin
R32.1 | enManScal Analog Input | 0bin | Hersteller-Skalierung aktiv | 0bin
 |  | 1bin | Hersteller-Skalierung nicht aktiv
R32.0 | enUsrScal Analog Input | 0bin | Anwender-Skalierung nicht aktiv | 0bin
 |  | 1bin | Anwender-Skalierung aktiv
Siemens-Ausgabeformat
Wenn das Siemens-Ausgabeformat ausgewählt wird, werden die niederwertigsten drei Bits zur Statusauswertung genutzt. Das Prozessdatum wird in Bit 15 bis 3 abgebildet, wobei das Bit 15 das Vorzeichenbit ist. Die Skalierung des Messwertes entsprechend dem Siemensstandard muss über die Anwender-Skalierung erfolgen (R33, R34).
Messwert | Bit 15 ... 3 | Bit 2 X | Bit 1 Error | Bit 0 Überlauf
Messwert < -10 V |  | 0 | 0 | 1
-10 V < Messwert < 10 V | Prozessdatum | 0 | 0 | 0
Messwert > +10 V |  | 0 | 0 | 1
R33: Anwender-Skalierung für Analogeingang - Offset (Bw)
Dieses Register beinhaltet den Offset der Anwender-Skalierung für den Analogeingang (Default: 0).
Die Anwender-Skalierung für den Analogeingang kann im Feature-Register durch Bit R32.0 aktiviert werden.
R34: Anwender-Skalierung für Analogeingang - Gain (Aw)
Dieses Register beinhaltet den Verstärkungsfaktor (Gain) der Anwender-Skalierung für den Analogeingang (Default: 256dez, entspricht einem Verstärkungsfaktor von 1).
Skalierung: Verstärkungsfaktor = R34 x 2-8
Die Anwender-Skalierung für den Analogeingang kann im Feature-Register durch Bit R32.0 aktiviert werden.
R35: Anwender-Default-Wert für Analogausgang
Hier können Sie den Anwender-Default-Wert vorgeben.
R36: Anwender-Skalierung für Analogausgang - Offset (Bw)
Dieses Register beinhaltet den Offset der Anwender-Skalierung für den Analogausgang (Default: 0).
Die Anwender-Skalierung für den Analogausgang kann im Feature-Register durch Bit R32.8 aktiviert werden.
R37: Anwender-Skalierung für Analogausgang - Gain (Aw)
Dieses Register beinhaltet den Verstärkungsfaktor (Gain) der Anwender-Skalierung für den Analogausgang (Default: 256dez, entspricht einem Verstärkungsfaktor von 1).
Skalierung: Verstärkungsfaktor = R37 x 2-8
Die Anwender-Skalierung für den Analogausgang kann im Feature-Register durch Bit R32.8 aktiviert werden.


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.