KL440x, Kl443x - Vier- und achtkanalige, analoge Ausgangsklemmen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Beckhoff Identification Code (BIC)


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.1.0
▪
Kapitel „Beckhoff Identification Code (BIC)“ eingefügt
▪
Update Kapitel „Hinweise zum ESD-Schutz“ geändert
3.0.0
▪
Migration
▪
Strukturupdate
▪
Update Kapitel Technische Daten
▪
Revisionsstand aktualisiert
▪
Kapitel Hinweise zum ESD-Schutz eingefügt
▪
Kapitel Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit eingefügt
▪
Kapitel ATEX - Besondere Bedingungen (Standardtemperaturbereich) und ATEX-Dokumentation eingefügt
▪
Update Kapitel Anschlusstechnik -> Anschluss
2.0.2
▪
Anschlussbelegung korrigiert
2.0.1
▪
Registerbeschreibung aktualisiert
▪
Firm- und Hardware-Stände aktualisiert
2.0.0
▪
Achtkanalige Busklemmen hinzugefügt: KL4408 und KL4438
1.0.1
▪
Format der Ausgabewerte auf den Seiten Grundlagen zur Funktion korrigiert.
1.0
▪
erste Veröffentlichung
0.1
▪
interne Version
Firm- und Hardware-Version
Dokumentation Version | KL4404 |  | KL4408 |  | KL4434 |  | KL4438
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
3.0.0 | 1E | 06 | 2B | 06 | 1E | 05 | 2B | 05
2.0.2 | 1D | 01 | 1F | 01 | 1D | 01 | 1F | 01
2.0.1 | 1D | 01 | 1F | 01 | 1D | 01 | 1F | 01
2.0.0 | 1C | 00 | 1C | 00 | 1C | 00 | 1C | 00
1.0.1 | 1A | 00 | - | - | 1A | 00 | - | -
1.0 | 1A | 00 | - | - | 1A | 00 | - | -
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 35 04 1B 01:
35 - Produktionswoche 35
04 - Produktionsjahr 2004
1B - Firmware-Stand 1B
01 - Hardware-Stand 01


Beckhoff Identification Code (BIC)

Vorwort [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


KL4404, KL4434 - Produktübersicht

KL4404, KL4434 - Produktübersicht
KL4404, KL4434 - Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Diagnose-LEDs


Einführung

KL4404, KL4434 - Produktübersicht [image] Einführung
Einführung
KL4404
KL4434
Die analoge Ausgangsklemme KL4404 erzeugt Signale im Bereich von 0 V bis 10 V.
Die analoge Ausgangsklemme KL4434 erzeugt Signale im Bereich von -10 V bis +10 V.
Die Spannungen werden mit einer Auflösung von 12 Bit galvanisch getrennt zur Prozessebene transportiert. Die vier Ausgänge der Busklemmen sind in Zweileitertechnik ausgeführt und besitzen ein gemeinsames Massepotenzial. Die Powerkontakte sind durchverbunden; die Bezugsmasse der Ausgänge ist der Powerkontakt 0 V. Die Leuchtdioden zeigen den Datenaustausch mit dem Buskoppler an.


Technische Daten

KL4404, KL4434 - Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | KL4404 | KL4434
Anzahl der Ausgänge | 4
Signalspannung | 0 V...+10 V | -10 V...+10 V
Bürde | > 5 kΩ (kurzschlussfest)
Auflösung | 12 Bit
Genauigkeit | 0,1%
Wandlungszeit | ca. 4 ms
Potenzialtrennung | 500 V (K-Bus/Signalspannung)
Spannungsversorgung für Elektronik | über den K-Bus und über die Powerkontakte
Stromaufnahme aus dem K-Bus | typisch 20 mA (5 V)
Stromaufnahme aus den Powerkontakten | typisch 15 mA (24 V)
Bitbreite im Prozessabbild | Output: 4 x 16 Bit Nutzdaten, 4 x 8 Bit Control/Status (optional)
Gewicht | ca. 85 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, UL, ATEX, GL


Diagnose-LEDs

KL4404, KL4434 - Produktübersicht [image] Diagnose-LEDs
Diagnose-LEDs
Die vier grünen RUN-LEDs zeigen den Betriebszustand der Klemmenkanäle an.
KL4404, KL4434 - LEDs
Bedeutung der LED-Anzeigen
LED | Farbe | Kanal | Zustand
 |  |  | Ein | aus
Run1 | grün | 1 | normaler Betrieb | Ein Watchdog-Timer Overflow ist aufgetreten. Wenn zwischen Steuerung und Buskoppler innerhalb von 100 ms keine Prozessdaten übertragen werden, so erlöschen die grünen LEDs.
Run2 |  | 2
Run3 |  | 3
Run4 |  | 4


KL4408, KL4438 - Produktübersicht

KL4408, KL4438 - Produktübersicht
KL4408, KL4438 - Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Diagnose-LEDs


Einführung

KL4408, KL4438 - Produktübersicht [image] Einführung
Einführung
KL4408
KL4438
Die analoge Ausgangsklemme KL4408 erzeugt Signale im Bereich von 0 V bis 10 V.
Die analoge Ausgangsklemme KL4438 erzeugt Signale im Bereich von -10 V bis +10 V.
Die Spannung wird mit einer Auflösung von 12 Bit galvanisch getrennt zur Prozessebene transportiert. Die Klemmen vereinen 8 Kanäle in einem Gehäuse und sind besonders für den platzsparenden Einsatz im Schaltschrank geeignet. Durch den Einsatz der Einleiteranschlusstechnik kann auf kleinstem Raum eine mehrkanalige Aktorik angeschlossen werden. Die Busklemme besitzt ein gemeinsames Massepotenzial. Die Powerkontakte sind durchverbunden; die Bezugsmasse der Ausgänge ist der Powerkontakt 0 V. Die Leuchtdioden zeigen den Datenaustausch mit dem Buskoppler an.


Technische Daten

KL4408, KL4438 - Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | KL4408 | KL4438
Anzahl der Ausgänge | 8
Signalspannung | 0 V...+10 V | -10 V...+10 V
Bürde | > 5 kΩ (kurzschlussfest)
Auflösung | 12 Bit
Genauigkeit | 0,3%
Wandlungszeit | ca. 8 ms
Potenzialtrennung | 500 V (K-Bus/Signalspannung)
Spannungsversorgung für Elektronik | über den K-Bus und über die Powerkontakte
Stromaufnahme aus dem K-Bus | typisch 20 mA (5 V)
Stromaufnahme aus den Powerkontakten | typisch 20 mA (24 V)
Bitbreite im Prozessabbild | Output: 8 x 16 Bit Nutzdaten, 8 x 8 Bit Control/Status (optional)
Gewicht | ca. 85 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, UL, ATEX, GL


Diagnose-LEDs

KL4408, KL4438 - Produktübersicht [image] Diagnose-LEDs
Diagnose-LEDs
Die acht grünen RUN-LEDs zeigen den Betriebszustand der Klemmenkanäle an.
KL4408, KL4438 - LEDs
Bedeutung der LED-Anzeigen
LED | Farbe | Kanal | Zustand
 |  |  | Ein | aus
Run 1 | grün | 1 | normaler Betrieb | Ein Watchdog-Timer Overflow ist aufgetreten. Wenn zwischen Steuerung und Buskoppler innerhalb von 100 ms keine Prozessdaten übertragen werden, so erlöschen die grünen LEDs.
Run 2 |  | 2
Run 3 |  | 3
Run 4 |  | 4
Run 5 |  | 5
Run 6 |  | 6
Run 7 |  | 7
Run 8 |  | 8


Grundlagen zur Funktion

Grundlagen zur Funktion
Grundlagen zur Funktion
Weiterführende Informationen
•
KL4404 und KL4408 - Grundlagen zur Funktion
•
KL4434 und KL4438 - Grundlagen zur Funktion


KL4404 und KL4408 - Grundlagen zur Funktion

Grundlagen zur Funktion [image] KL4404 und KL4408 - Grundlagen zur Funktion
KL4404 und KL4408 - Grundlagen zur Funktion
Die analogen Ausgangsklemmen KL4404 und KL4408 erzeugen Signale im Bereich von 0 V bis +10 V mit einer Auflösung von 12-Bit (4095 Schritte). Bei den Ausgängen handelt es sich um Single-Ended-Ausgänge mit einem gemeinsamen Massepotential.
Format der Ausgabewerte
Die Prozessdaten werden im Auslieferungszustand im Zweierkomplement dargestellt ( -1integer entspricht 0xFFFF). Über das Feature-Register R32 sind andere Darstellungsarten anwählbar (z. B. Betrags-Vorzeichendarstellung, Siemens-Format).
Ausgabewert |  | Ausgangsspannung
hexadezimal | dezimal
0x0000 | 0 | 0 V
0x3FFF | 16383 | +5 V
0x7FFF | 32767 | +10 V
Gleichungen für die Prozessdaten
Die Prozessdaten, die zur Busklemme übertragen werden, berechnen sich aus den folgenden Gleichungen:
Weder Anwender noch Herstellerskalierung aktiv
Ydac = X x Aa + Ba
(1.0)
Herstellerskalierung aktiv (Default- Einstellung)
Y1 = Bh + Ah x X | (1.1)
Ydac = Y1 x Aa + Ba |
Anwenderskalierung aktiv
Y2 = Bw + Aw x X | (1.2)
Ydac = Y2 x Aa + Ba |
Hersteller- und Anwenderskalierung aktiv
Y1 = Bh + Ah x X | (1.3)
Y2 = Bw + Aw x Y1 | (1.4)
Ydac = Y2 x Aa + Ba |
Legende
X: | Prozessdaten der Steuerung |
Ydac: | Prozessdaten zum D/A-Wandler |
Ba , Aa: | Hersteller Gain- und Offsetabgleich | (R17, R18)
Bh , Ah: | Hersteller-Skalierung | (R19, R20)
Bw, Aw: | Anwender-Skalierung | (R33, R34)
Die Geradengleichungen werden über Register R32 aktiviert.


KL4434 und KL4438 - Grundlagen zur Funktion

Grundlagen zur Funktion [image] KL4434 und KL4438 - Grundlagen zur Funktion
KL4434 und KL4438 - Grundlagen zur Funktion
Die analoge Ausgangsklemmen KL4434 und KL4438 erzeugen Signale im Bereich von -10 V bis +10 V mit einer Auflösung von 12-Bit (4095 Schritte). Bei den Ausgängen handelt es sich um Single-Ended-Ausgänge mit einem gemeinsamen Massepotential.
Format der Ausgabewerte
Die Prozessdaten werden im Auslieferungszustand im Zweierkomplement dargestellt ( -1integer entspricht 0xFFFF). Über das Feature-Register sind andere Darstellungsarten anwählbar (z. B. Betrags-Vorzeichendarstellung, Siemens-Format).
Ausgabewert |  | Ausgangsspannung
hexadezimal | dezimal
0x8000 | -32768 | -10 V
0xC001 | -16383 | -5 V
0x0000 | 0 | 0 V
0x3FFF | 16383 | +5 V
0x7FFF | 32767 | +10 V
Gleichungen für die Prozessdaten
Die Prozessdaten, die zur Busklemme übertragen werden, berechnen sich aus den folgenden Gleichungen:
Weder Anwender noch Herstellerskalierung aktiv
Ydac = X x Aa + Ba
(1.0)
Herstellerskalierung aktiv (Default- Einstellung)
Y1 = Bh + Ah x X | (1.1)
Ydac = Y1 x Aa + Ba |
Anwenderskalierung aktiv
Y2 = Bw + Aw x X | (1.2)
Ydac = Y2 x Aa + Ba |
Hersteller- und Anwenderskalierung aktiv
Y1 = Bh + Ah x X | (1.3)
Y2 = Bw + Aw x Y1 | (1.4)
Ydac = Y2 x Aa + Ba |
Legende
X: | Prozessdaten der Steuerung |
Ydac: | Prozessdaten zum D/A-Wandler |
Ba , Aa: | Hersteller Gain- und Offsetabgleich | (R17, R18)
Bh , Ah: | Hersteller-Skalierung | (R19, R20)
Bw, Aw: | Anwender-Skalierung | (R33, R34)
Die Geradengleichungen werden über Register R32 aktiviert.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss
•
KL4404, KL4434 - Anschluss
•
KL4408, KL4438 - Anschluss
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX-Dokumentation


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endklemme KL9010 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


KL4404, KL4434 - Anschluss

Montage und Verdrahtung [image] KL4404, KL4434 - Anschluss
KL4404, KL4434 - Anschluss
KL4404 - Anschluss
KL4434 - Anschluss
Klemmstelle Nr. | Kanal | Name | Anschluss für
1 | 1 | Output 1 | Ausgang 1, Signal
2 |  | 0 V | Ausgang 1, Masse
3 | 3 | Output 3 | Ausgang 3, Signal
4 |  | 0 V | Ausgang 3, Masse
5 | 2 | Output 2 | Ausgang 2, Signal
6 |  | 0 V | Ausgang 2, Masse
7 | 4 | Output 4 | Ausgang 4, Signal
8 |  | 0 V | Ausgang 4, Masse


KL4408, KL4438 - Anschluss

Montage und Verdrahtung [image] KL4408, KL4438 - Anschluss
KL4408, KL4438 - Anschluss
KL4408 - Anschluss
KL4438 - Anschluss
Klemmstelle Nr. | Kanal | Name | Anschluss für
1 | 1 | Output 1 | Ausgang 1, Signal
2 | 3 | Output 3 | Ausgang 3, Signal
3 | 5 | Output 5 | Ausgang 5, Signal
4 | 7 | Output 7 | Ausgang 7, Signal
5 | 2 | Output 2 | Ausgang 2, Signal
6 | 4 | Output 4 | Ausgang 4, Signal
7 | 6 | Output 6 | Ausgang 6, Signal
8 | 8 | Output 8 | Ausgang 8, Signal


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Einstellungen
•
Register
•
Prozessdaten


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Ethernet-Koppler BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine analoge Ausgangsklemme KL4404
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).
KS2000 Baumzweige für Kanal1 der KL4404
Für die KL4404 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL4404.
▪
Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL4404.
▪
ProcData zeigt die Prozessdaten der KL4404.


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Unter Einstellungen finden Sie die Dialogmaske zur Parametrierung der Klemmen
Einstellungen über KS2000
Betriebsmodus
▪
Anwender-Skalierung aktiv (R32.0)
Hier können Sie die Anwender-Skalierung aktivieren (Default: deaktiviert).
▪
Hersteller-Skalierung aktiv (R32.1)
Hier können Sie die Hersteller-Skalierung deaktivieren (Default: aktiviert).
▪
Watchdog-Timer aktiv (R32.2)
Hier können Sie den Watchdog Timer deaktivieren (Default: aktiviert).
▪
Betragsvorzeichen-Darstellung (R32.3)
Hier können Sie die Betragsvorzeichen-Darstellung aktivieren (Default: deaktiviert).
▪
Betragsbildung aktiv (R32.5)
Hier können Sie die Betragsbildung aktivieren (Default: deaktiviert).
▪
Anwender-Einschaltwert aktiv (R32.8)
Hier können Sie den Anwender-Einschaltwert aktivieren (Default: deaktiviert).
Registerwerte
▪
Anwender-Offset (R33)
Hier können Sie den Anwender-Offset vorgeben (Default: 0).
▪
Anwender-Gain (R34)
Hier können Sie den Anwender-Gain vorgeben (Default: 256).
▪
Anwender-Einschaltwert (R35)
Hier können Sie den Anwender-Einschaltwert vorgeben (Default: 0).


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register der Klemmen zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Register-Ansicht in KS2000


Prozessdaten

Konfigurations-Software KS2000 [image] Prozessdaten
Prozessdaten
Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.
ProcData
Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.
Feld Verlauf
Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.
Feld Wert (Eingangswert)
Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.
Feld Wert (Ausgangswerte)
SmallWarningYellow GEFAHR
Gefahr für Personen, Umwelt oder Geräte
Beachten Sie, dass das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann. Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, dass Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.
Dialog Einstellungen


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Mapping
•
Control- und Status-Bytes
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Prozessabbild der Klemmen: KL4404, KL4434, KL4414 und KL4424
KL4404 und KL4434 sowie KL4414 und KL4424 stellen sich im Prozessabbild mit bis zu 12 Byte Ein- und 12 Byte Ausgangsdaten dar.
Format | Eingangsdaten | Ausgangsdaten
Byte | SB1 | CB1
Wort | DataIN1 | DataOUT1
Byte | SB2 | CB2
Wort | DataIN2 | DataOUT2
Byte | SB3 | CB3
Wort | DataIN3 | DataOUT3
Byte | SB4 | CB4
Wort | DataIN4 | DataOUT4
Legende
SB n: Status-Byte für Kanal n
CB n: Control-Byte für Kanal n
DataIN n: Eingangsdatenwort Kanal n
DataOUT n: Ausgangsdatenwort Kanal n
▪
Die Zuordnung der Bytes und Worte zu den Adressen der Steuerung entnehmen Sie bitte der Seite Mapping.
▪
Die Bedeutung der Control- und Status-Bytes entnehmen Sie bitte der Seite Control- und Status-Bytes.
▪
Im Prozessdatenbetrieb werden in den Ausgangsdatenworten DataOUT1 bis DataOUT4 die Analogwerte übertragen und die Eingangsdatenworte DataIN1bis DataIN4 nicht benutzt.
Prozessabbild der Klemmen: KL4408, KL4438, KL4418 und KL4428
KL4408 und KL4438 sowie KL4418 und KL4428 stellen vom Prozessabbild her einen Sonderfall dar:
Hier sind praktisch zwei vierkanalige Klemmen in einem Klemmengehäuse untergebracht, die sich für den K-Bus auch wie zwei Klemmen verhalten!
Jede dieser achtkanaligen Analogklemmen hat also das gleiche Prozessabbild, wie zwei nebeneinander gesteckte Vierkanalklemmen gleichen Signaltyps. Sie werden von der Konfigurations-Software KS2000 und vom TwinCAT System-Manager auch wie zwei separate vierkanalige Analogklemmen angezeigt!
Hinweis zur K-Bus-Diagnose bei KL4408, KL4438, KL4418, KL4428
Beachten Sie bei der K-Bus-Diagnose Ihres Buskopplers (z. B. bei Blink-Codes, Fehler-Code und Fehler-Argument), dass sich diese achtkanaligen Analogklemmen für den Buskoppler wie zwei vierkanalige Klemmen darstellen. Wenn der Buskoppler im Fehlerfall den Fehlerort darstellt, müssen Sie jede achtkanaligen Analogklemmen wie zwei Klemmen zählen!


Mapping

Zugriff aus dem Anwenderprogramm [image] Mapping
Mapping
Die Busklemmen belegen Adressen im Prozessabbild der Steuerung. Die Zuordnung der Prozessdaten (Ein- und Ausgangsdaten) und Parametrierungsdaten (Control- und Status-Bytes) zu den Steuerungsadressen wird als Mapping bezeichnet. Die Art des Mappings ist abhängig von:
▪
dem verwendeten Feldbus-System
▪
dem Klemmentyp
▪
der Parametrierung des Buskopplers (Bedingungen) wie
–
kompakte oder komplette Auswertung
–
Intel- oder Motorola-Format
–
Word-Alignment ein- oder ausgeschaltet
Die Buskoppler (BKxxxx, LCxxxx) und Busklemmen Controller (BCxxxx, BXxxxx) werden mit bestimmten Voreinstellungen (Default-Einstellungen) ausgeliefert. Mit der Konfigurationssoftware KS2000 oder mit einer Master-Konfigurationssoftware (z. B. TwinCAT System Manager oder ComProfibus) können Sie diese Default-Einstellungen verändern.
Die folgenden Tabellen zeigen das Mapping in Abhängigkeit der verschiedenen Bedingungen. Die Inhalte der einzelnen Bytes entnehmen Sie bitte den Seiten Prozessabbild sowie Control- und Status-Bytes.
Kompakte Auswertung
Bei kompakter Auswertung belegen die analogen Ausgangsklemmen nur Adressen im Ausgangsprozessabbild. Der Zugriff auf Control- und Status-Bytes ist nicht möglich.
Kompakte Auswertung im Intel-Format
Default-Mapping für CANopen-, CANCAL-, DeviceNet-, ControlNet-, Modbus-, RS232- und RS485-Koppler
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | - | - | Ch1 D1 | Ch1 D0
 | 1 | - | - | Ch2 D1 | Ch2 D0
 | 2 | - | - | Ch3 D1 | Ch3 D0
 | 3 | - | - | Ch4 D1 | Ch4 D0
Kompakte Auswertung im Motorola-Format
Default-Mapping für Profibus- und Interbus-Koppler
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | - | - | Ch1 D0 | Ch1 D1
 | 1 | - | - | Ch2 D0 | Ch2 D1
 | 2 | - | - | Ch3 D0 | Ch3 D1
 | 3 | - | - | Ch4 D0 | Ch4 D1
Legende
Komplette Auswertung: | Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: | Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: | Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.
Ch n D0: | Kanal n, niederwertiges Daten-Byte
Ch n D1: | Kanal n, höherwertiges Daten-Byte
"-": | Diese Byte wird von der Klemme/Modul nicht belegt oder benutzt.
Komplette Auswertung
Bei kompletter Auswertung belegen die analogen Ausgangsklemmen Adressen im Ein- und im Ausgangsprozessabbild. Der Zugriff auf Control- und Status-Bytes ist möglich.
Komplette Auswertung im Intel-Format
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0
Komplette Auswertung im Motorola-Format
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Komplette Auswertung im Intel-Format bei Word-Alignment
Default-Mapping für Lightbus- und Ethernet-Koppler sowie Busklemmen Controller (BCxxxx, BXxxxx)
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0
Komplette Auswertung im Motorola-Format bei Word-Alignment
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Legende
Komplette Auswertung: | Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: | Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: | Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.
SB n: | Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: | Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)
Ch n D0: | Kanal n, niederwertiges Daten-Byte
Ch n D1: | Kanal n, höherwertiges Daten-Byte
reserviert: | Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Bytes
Control- und Status-Bytes
Kanal 1
Im Folgenden werden die Control- und Status-Bytes für Kanal 1 dargestellt.
Kanal 2, Kanal 3 und Kanal 4
Die Control- und Status-Bytes der Kanäle 2, 3 und 4 sind jeweils wie das Control- und Status-Byte des Kanals 1 aufgebaut.
Prozessdatenbetrieb
Control-Byte 1 im Prozessdatenbetrieb
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen. Es hat im Prozessdatenbetrieb keine Funktion.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 - CB1.0 | - | 0bin | reserviert
Status-Byte 1 im Prozessdatenbetrieb
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen. Es hat im Prozessdatenbetrieb keine Funktion.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 - SB1.0 | Error | 0bin | reserviert
Registerkommunikation
Control-Byte 1 bei Registerkommunikation
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit
Name
Beschreibung
CB1.7
RegAccess
1bin
Registerkommunikation eingeschaltet
CB1.6
R/W
0bin
Lesezugriff
1bin
Schreibzugriff
CB1.5 bis CB1.0
Reg-Nr.
Registernummer:
Tragen Sie hier die Nummer des Registers ein, das Sie
▪
mit dem Eingangsdatenwort DataIN1 lesen oder
▪
mit dem Ausgangsdatenwort DataOUT1 beschreiben wollen.
Status-Byte 1 bei Registerkommunikation
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die folgenden Register dienen zur Parametrierung der KL4404, KL4408, KL4434 und KL4438. Sind für jeden Signalkanal der Analogklemme einmal vorhanden und können mit Hilfe von Control-, Status- und Daten-Bytes über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | Prozessdaten für D/A-C |  | - | - | R | RAM
R1 | reserviert |  | - |  | - | -
... | ... |  | ... | ... | ... | ...
R5 | reserviert |  | - | - | - | -
R6 | Diagnose-Register (nicht benutzt) |  | - | - | R | RAM
R7 | Kommando-Register (nicht benutzt) |  | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | KL4404: | 0x1134 | 4404dez | R | ROM
 |  | KL4408: | 0x1138 | 4408dez
 |  | KL4434: | 0x1152 | 4434dez
 |  | KL4438: | 0x1156 | 4438dez
R9 | Firmware-Stand |  | z. B. 0x3141 | z. B. 1AASCI | R | ROM
R10 | Datenlänge (Multiplex-Schieberegister) |  | 0x0230 | 560dez | R | ROM
R11 | Signalkanäle |  | 0x0418 | 1048dez | R | ROM
R12 | minimale Datenlänge |  | 0x9800 | 38912dez | R | ROM
R13 | Datenstruktur (Datentyp-Register) |  | 0x0004 | 4dez | R | ROM
R14 | reserviert |  | - | - | - | -
R15 | Alignment-Register |  | z. B. 0x7F80 | z. B. 32640dez | R/W | RAM
R16 | Hardware-Versionsnummer |  | z. B. 0x0000 | z. B. 0dez | R/W | SEEPROM
R17 | Hardware-Abgleich: Offset (Ba) |  | 0x0001 | 1dez | R/W | SEEPROM
R18 | Hardware-Abgleich: Gain (Aa) |  | typ. 0x0E99 | typ. 3737dez | R/W | SEEPROM
R19 | Hersteller-Skalierung: Offset (Bh) |  | 0x0000 | 0dez | R/W | SEEPROM
R20 | Hersteller-Skalierung: Gain (Ah) |  | typ. 0x0020 | typ. 32dez | R/W | SEEPROM
R21 | Hersteller-Einschaltwert |  | 0x0000 | 0dez | R/W | SEEPROM
R22 | KL4404: | reserviert | - | - | - | -
 | KL4408:
 | KL4434: | Hardware-Abgleich: Gain (Aa) für negative Werte | typ.0x0E99 | typ. 3737dez | R/W | SEEPROM
 | KL4438:
R23 | reserviert |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R30 | reserviert |  | - | - | - | -
R31 | Kodewort-Register |  | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register |  | 0x0006 | 6dez | R/W | SEEPROM
R33 | Anwender-Skalierung: Offset (Bw) |  | 0x0000 | 0dez | R/W | SEEPROM
R34 | Anwender-Skalierung: Gain (Aw) |  | 0x0100 | 256dez | R/W | SEEPROM
R35 | Anwender-Einschaltwert |  | 0x0000 | 0dez | R/W | SEEPROM
R36 | reserviert |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R63 | reserviert |  | - | - | - | -


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die folgenden Register dienen zur Parametrierung der KL4404, KL4408, KL4434 und KL4438. Sind für jeden Signalkanal der Analogklemme einmal vorhanden und können mit Hilfe von Control-, Status- und Daten-Bytes über die Registerkommunikation ausgelesen oder beschrieben werden.
R0: Prozessdaten für D/A-C
Prozessdaten, die dem D/A-Wandlers übergeben werden.
R6: Diagnose-Register
Das Diagnose-Register der KL4404 und KL4434 wird zurzeit nicht benutzt.
R7: Kommando-Register
Das Kommando-Register der KL4404 und KL4434 wird zurzeit nicht benutzt.
R8: Klemmenbezeichnung
Im Register R8 steht die Bezeichnung der Klemme, z. B.:
- KL4404: 0x1134 (4404dez) oder
- KL4434: 0x1152 (4434dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z.B. 0x3141 (1A)ASCII. Hierbei entspricht '0x31' dem ASCII-Zeichen '1' und '0x41' dem ASCII-Zeichen 'A'. Dieser Wert kann nicht verändert werden.
R10: Datenlänge (Multiplex-Schieberegister)
R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit.
R11: Signalkanäle
Im Gegensatz zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z. B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.
R12: Minimale Datenlänge
Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control- und Status-Byte nicht zwingend notwendig für die Funktion der Klemme und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen.
R13: Datenstruktur (Datentyp-Register)
Datentypregister | Bedeutung
0x00 | Klemme ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur: 1 Byte, n Bytes
0x03 | Wort-Array
0x04 | Struktur: 1 Byte, n Worte
0x05 | Doppelwort-Array
0x06 | Struktur: 1 Byte, n Doppelworte
0x07 | Struktur: 1 Byte, 1 Doppelwort
0x08 | Struktur: 1 Byte, 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur: 1 Byte, n Bytes mit variabler logischer Kanallänge (z. B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur: 1 Byte, n Worte mit variabler logischer Kanallänge
0x15x | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur: 1 Byte, n Doppelworte mit variabler logischer Kanallänge
R15: Alignment-Register
Mit Hilfe der Bits des Alignment-Registers legt der Buskoppler den Adressbereich einer Analogklemme so, dass er auf einer auf Byte-Grenze beginnt.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme, dieser Wert kann nicht verändert werden.
R17: Hardware-Abgleich - Offset (Ba)
Über dieses Register erfolgt der Offset-Abgleich der Klemme (siehe Gleichung 1.1). Registerwert (16 Bit signed Integer). Default: 0x0001 (1dez)
R18: Hardware-Abgleich - Gain (Aa)
Über dieses Register erfolgt der Gain-Abgleich der Klemme (siehe Gleichung 1.1). Registerwert (16 Bit unsigned Integer x 2-12). Default: typisch 0x0E99 (3737dez)
R19: Hersteller-Skalierung - Offset (Bh)
Dieses Register beinhaltet den Offset der Hersteller-Skalierung (siehe Gleichung 1.3). Registerwert (16 Bit signed Integer). Default: 0x0000 (0dez)
Die Hersteller-Skalierung kann durch Bit R32.1 des Feature-Registers aktiviert werden.
R20: Hersteller-Skalierung - Gain (Ah)
Dieses Register beinhaltet den Gain der Hersteller-Skalierung (siehe Gleichung 1.3). Registerwert (16 Bit unsigned Integer x 2-8). Default: typisch 0x0020 (32dez)
Die Hersteller-Skalierung kann durch Bit R32.1 des Feature-Registers aktiviert werden.
R21: Hersteller-Einschaltwert
Die Klemme legt den Hersteller-Einschaltwert nach einem System-Reset oder einem Watchdog-timer-Overflow (Klemme hat 100 ms lang keine Prozessdaten erhalten) an ihren Ausgang. Registerwert (16 Bit signed Integer).
R22: Hardware-Abgleich - Gain (Aa) für negative Werte
(nur KL4434 und KL4438)
Über dieses Register erfolgt der Gain-Abgleich der Klemme für negative Werte (0x1000 entspricht Faktor 1). Default: typisch 0x0E99 (3737dez)
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei jedem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Konfiguration der Klemme fest. Default: 0x0006 (6dez)
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | - | - | - | enUserActValue
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | enSignRepr | - | enSignAmRepr | enWdTimer | enManScal | enUsrScal
Legende
Bit | Name | Beschreibung |  | default
R32.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.9 | - | reserviert |  | 0bin
R32.8 | enUserActValue | 0bin | Hersteller-Einschaltwert aktiv | 0bin
 |  | 1bin | Anwender-Einschaltwert aktiv
R32.7 | - | reserviert |  | 0bin
R32.6 | - | reserviert |  | 0bin
R32.5 | enSignRepr | 0bin | Betragsbildung nicht aktiv | 0bin
 |  | 1bin | Betragsbildung aktiv
R32.4 | - | reserviert |  | 0bin
R32.3 | enSignAmRepr | 0bin | Zweierkomplementdarstellung aktiv | 0bin
 |  | 1bin | Betragsvorzeichendarstellung aktiv (-1dez = 0x8001)
R32.2 | enWdTimer | 0bin | Watchdog-Timer nicht aktiv | 1bin
 |  | 1bin | Watchdog-Timer aktiv (werden 100 ms keine Prozessdaten empfangen, löst der Watchdog aus)
R32.1 | enManScal | 0bin | Hersteller-Skalierung aktiv | 1bin
 |  | 1bin | Hersteller-Skalierung nicht aktiv
R32.0 | enUsrScal | 0bin | Anwender-Skalierung nicht aktiv | 0bin
 |  | 1bin | Anwender-Skalierung aktiv
R33: Anwender-Skalierung - Offset (Bw)
Dieses Register beinhaltet den Offset der Anwender-Skalierung.
Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden.
R34: Anwender-Skalierung - Gain (Aw)
Dieses Register beinhaltet das Gain der Anwender-Skalierung. Default: 0x0100 (256dez)
Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden.
R35: Anwender-Einschaltwert
Wenn der Anwender-Einschaltwert mit Bit R32.8 des Feature-Registers aktiviert wurde, legt die Klemme anstelle des Hersteller-Einschaltwerts den Anwender-Einschaltwert an ihren Ausgang wenn ein System-Reset oder ein Watchdog-timer-Overflow (Klemme hat 100 ms lang keine Prozessdaten erhalten) auftritt.


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.