KL3403 - 3-Phasen Leistungsmessklemmen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Beckhoff Identification Code (BIC)


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.1.0
▪
Sicherheitshinweise neues Layout
▪
Beispielprogramm zum Kapitel “Konfigurations-Software KS2000“ hinzugefügt
▪
Beschreibung von KL3403-0333 hinzugefügt
▪
KL3403-0021 entfernt
▪
Technische Daten aktualisiert
▪
Kapitel Hinweise zum ESD-Schutz eingefügt
3.0.0
▪
Migration
2.1.0
▪
Registerbeschreibung aktualisiert
▪
Kapitel KS2000 Einstellungen aktualisiert
▪
Kapitel Control- und Status-Byte aktualisiert
▪
Technische Daten aktualisiert
2.0.1
▪
Firmware-Stände aktualisiert
▪
Zahlenwerte bei der KL3403-0022 korrigiert
2.0.0
▪
zulässiger Umgebungstemperaturbereich für KL3403-0000 und KL3403-0010 erweitert
▪
Technische Daten aktualisiert
▪
Kapitel Grundlagen zur Funktion erweitert
Version
Kommentar
1.9.0
▪
UL-Hinweise aktualisiert
▪
Technische Daten aktualisiert
1.8.0
▪
UL-Hinweise hinzugefügt
▪
Technische Daten aktualisiert
1.7.0
▪
Anwendungsbeispiel mit Frequenzumrichter aktualisiert
▪
Technische Daten aktualisiert
1.6.0
▪
Beschreibung von KL3403-0014 hinzugefügt
▪
Montagebeschreibung erweitert
1.5.0
▪
Beschreibung von KL3403-0021, KL3403-0022, KL3403-0025 und KL3403-0026 hinzugefügt
▪
Beschreibung des flexiblen Prozessabbilds hinzugefügt
▪
Energiezähler kann invertiert werden (für generatorischen Betrieb)
▪
min. Werte von Strom, Spannung und Leistung
▪
automatisches Löschen der min. und max. Werte
1.4.1
▪
Feature-Register erweitert
1.4
▪
KL3403-0020 (20 mA) hinzugefügt
▪
Kapitel Messfehler durch Eingangsübersteuerung hinzugefügt
▪
Kapitel Messfehler bei Gleichspannungsmessung hinzugefügt
1.3
▪
Angaben zur Auflösung bei der Messung von Strom, Leistung und Energie für die Klemmenvariante KL3403-0010 korrigiert.
1.2
▪
Beschreibung von Control- und Status-Bytes erweitert: Prozessdatenindex für Frequenzmessung ergänzt
▪
Beschreibung der Parametrierung der KL3403 mit der KS2000-Software aktualisiert
▪
Nummerierung der Kanäle in den Beschreibungen an Darstellung in TwinCAT und KS2000 angepasst
▪
Defaultwert für Messzykluszeit auf 50 ms korrigiert
▪
Anwendungsbeispiel mit Frequenzumrichter hinzugefügt
1.1
▪
technische Daten aktualisiert
▪
Beschreibung der KL3403-0010 (5A Version) hinzugefügt
▪
Anwendungsbeispiel für Gleichstrom hinzugefügt
1.0
▪
Beschreibung der Parametrierung der KL3403 mit der KS2000-Software hinzugefügt
▪
Registerbeschreibung ergänzt
- Kommandos ergänzt
- Beschreibung des Feature-Registers hinzugefügt
- Beschreibung des Unterspannungs-Schwellen-Registers hinzugefügt
▪
Beispiele für Registerkommunikation hinzugefügt
▪
Beschreibung von Control- und Status-Bytes erweitert
- weitere Prozessdatenindices ergänzt
▪
technische Daten aktualisiert
0.4
▪
technische Daten ergänzt
▪
Anwendungsbeispiele überarbeitet
▪
Beschreibung von Control- und Status-Bytes erweitert
▪
Englische Version verfügbar
0.3
▪
Hinweise zum Messintervall überarbeitet
0.2
▪
weiteres Anwendungsbeispiel hinzugefügt
▪
Beschreibung der Anschlüsse hinzugefügt
▪
Registerbeschreibung ergänzt
0.1
▪
erste Vorabversion
Firmware (FW)- und Hardware-Stände (HW)
Dokumen- tation, Version | KL3403-0000 |  | KL3403-0010 |  | KL3403-0014 |  | KL3403-0020 |  | KL3403-0022 |  | KL3403-0025, KL3403-0026 |  | KL3403-0333
 | FW | HW | FW | HW | FW | HW | FW | HW | FW | HW | FW | HW | FW | HW
3.1.0 | 3L | 17 | 3L | 17 | 4K | 17 | 4K | 17 | 4K | 15 | 3L | 17 | 4K | 17
3.0.0 | 3L | 17 | 3L | 17 | 4K | 17 | 4K | 17 | 4K | 15 | 3L | 17 | - | -
2.1.0 | 3L | 15 | 3L | 15 | 4K | 16 | 4K | 15 | 4K | 15 | 3L | 15
2.0.1 | 3L | 15 | 3L | 15 | 4K | 15 | 4K | 15 | 4K | 15 | 3L | 15
2.0.0 | 3K | 15 | 3K | 15 | 4J | 15 | 4J | 15 | 4J | 15 | 3K | 15
1.9.0 | 3K | 15 | 3K | 15 | 4J | 15 | 4J | 15 | 4J | 15 | 3K | 15
1.8.0 | 3K | 15 | 3K | 15 | 4J | 15 | 4J | 15 | 4J | 15 | 3K | 15
1.7.0 | 3J | 15 | 3J | 14 | 4i | 15 | 4i | 15 | 4i | 15 | 3J | 15
1.6.0 | 3H | 10 | 3H | 10 | 3H | 10 | 4G | 10 | 3H | 10 | 3H | 10
1.5.0 | 3G | 10 | 3G | 10 | - | - | 4F | 10 | 4F | 10 | 3G | 10
1.4.1 | 3F | 10 | 3F | 10 |  |  | 4E | 10 | - | - | - | -
1.4 | 3E | 10 | 3E | 10 |  |  | 4D | 10
1.3 | 3E | 10 | 3E | 04 |  |  | - | -
1.2 | 3D | 09 | 3D | 03
1.1 | 3B | 06 | 3B | 00
1.0 | 2E | 03 | - | -
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Der aktuelle Firmware-Stand wird auch von der Konfigurations-Software KS2000 angezeigt.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Jahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 35 04 2E 03:
35 - Produktionswoche 35
04 - Produktionsjahr 2004
2E - Firmware-Stand 2E
03 - Hardware-Stand 03


Beckhoff Identification Code (BIC)

Vorwort [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
LED-Anzeigen
•
Grundlagen zur Funktion
•
Technische Daten
•
Stromwandler


Einführung

Produktübersicht [image] Einführung
Einführung
KL3403
Die 3-Phasen Leistungsmessklemme KL3403 ermöglicht die Messung der elektrischen Daten eines dreiphasigen Versorgungsnetzes:
▪
Die Spannung wird über den Anschluss des Netzes an die Klemmstellen L1, L2, L3 und N gemessen.
▪
Der Strom der drei Phasen wird über Stromwandler an den Klemmstellen IL1, IL2, IL3 und IN eingespeist.
Auch nicht sinusförmige Spannungs- und Stromverläufe können je nach Kurvenform mit einer praxistauglichen Genauigkeit von 1 % bis 5 % eingelesen werden. Die Grenzfrequenz der Berechnung beträgt 2 kHz. Durch die Einstellbarkeit des Zeitintervalls für die Berechnung der Werte ist eine Optimierung auf unterschiedlichste Einsatzfälle möglich.
Die Vorverarbeitung der KL3403 stellt Effektivwerte im Prozessabbild zur Verfügung, ohne dafür hohe Rechenleistung auf der Steuerung vorauszusetzen. Aus den Effektivwerten für Spannungen (U) und Ströme (I) berechnet die KL3403 für jede Phase die Wirkleistung (P), den Energieverbrauch (W) und den Leistungsfaktor (cos φ). Aus diesen Werten können z. B. die Scheinleistung (S) und der Phasenverschiebungswinkel (φ) leicht abgeleitet werden.
Die KL3403 ermöglicht Ihnen somit über den Feldbus eine umfangreiche Netzanalyse durchzuführen. Anhand der Werte für Spannung, Strom, Wirk- und Scheinleistungsaufnahme sowie Belastungszustand ist der Anlagenbediener in der Lage, die Versorgung eines Antriebs oder einer Maschine optimiert zu regeln und die Anlage vor Schäden und Ausfällen zu bewahren.
Varianten
Es stehen mehrere Varianten der KL3403 zur Verfügung.
Bezeichnung | Kommentar | Nennwert
KL3403-0000 KS3403-0000 | Standardvariante | 1 A
KL3403-0026 | Wie KL3403-0000, aber ohne EMV-Ableitkondensator zwischen den Klemmstellen 4/8 und dem Erdungskontakt zur Tragschiene. | 1 A
KL3403-0010 KS3403-0010 | Leistungsmessklemme mit höher belastbaren Strompfaden. | 5 A
KL3403-0014 | Leistungsmessklemme mit 3 zusätzlichen Spannungspfaden anstelle der Strompfade. Zum Anschluss externer Shunts. | 60 mV
KL3403-0020 | Leistungsmessklemme mit empfindlicheren Strompfaden. | 20 mA
KL3403-0022 | Leistungsmessklemme mit 6 Strompfaden, sonst wie KL3403-0020. | 20 mA
KL3403-0025 | Leistungsmessklemme mit empfindlicheren Strompfaden. | 250 mA
KL3403-0333 | Leistungsmessklemme konzipiert für den Betrieb mit 333 mV Aufsteckwandler | max. 333 mV (AC), über Messwandler xA / 333 mV
Weitere Details entnehmen Sie bitte dem Kapitel Technischen Daten.


LED-Anzeigen

Produktübersicht [image] LED-Anzeigen
LED-Anzeigen
LEDs
LED | Nr. | Anzeige
K-Bus-Run (grün) | A | K-Bus Datenübertragung
ERR L1 (rot) | B | Spannung zwischen L1 und N unter 10 V (default*) | *) Für jeden Kanal kann der Unterspannungs-Schwellwert mit seinem Register R36 verändert werden.
ERR L2 (rot) | C | Spannung zwischen L2 und N unter 10 V (default*)
ERR L3 (rot) | D | Spannung zwischen L3 und N unter 10 V (default*)
Kontaktbelegung siehe Anschluss der KL3403.


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Messprinzip
Die KL3403 arbeitet mit 6 Analog/Digitalwandern zur Erfassung der Strom und Spannungsgrößen aller 3 Phasen. Die Werte werden in einem Zeitraster von ca. 16 µs abgetastet.
Die Erfassung und Verarbeitung der 3 Phasen findet zeitsynchron in exakt gleicher Form statt. Im Folgenden wird die Signalverarbeitung für eine Phase beschrieben. Die Beschreibung gilt sinngemäß für alle 3 Phasen. Die Gesamtleistung und der Gesamtenergieverbrauch sind die Summe, der mittlere Strom ist der Durchschnitt der 3 Phasen.
Verlauf von Spannung u und Strom i
Verlauf von Spannung u und Strom i
Effektivwertberechnung
Über ein Messintervall, hier Periodendauer T, wird der Effektivwert für Spannung und Strom berechnet. Die Berechnungen erfolgen nach den Formeln:
u(t): Momentanwert der Spannung
i(t): Momentanwert des Stromes
n: Anzahl der gemessenen Werte
Für eine Messung in einem 50 Hz Netz (Periodendauer T = 20 ms) werden 1280 Messwerte in eine Berechnung einbezogen.
Messintervall
Die Wahl des richtigen Messintervalls ist für die Qualität der Messung von Bedeutung. Das Messintervall muss minimal ¼ T betragen. Sinnvoll sind ¼ T, ½ T, T und vielfache von ½ T. Wenn Sie ein beliebiges Intervall wählen, das keinem Vielfachen von ½ T entspricht und deutlich kleiner als 5 T ist schwankt der Messwert deutlich.
Die Defaulteinstellung für das Messintervall ist 50 ms, was im 50 Hz Netz 2,5 T und im 60 Hz Netz 3 T entspricht. Dies ist erfahrungsgemäß ein guter Kompromiss zwischen Messgeschwindigkeit und Stabilität. Weichen Sie von diesem Wert nur ab, wenn besondere Messanforderungen (z. B. hohe Messgeschwindigkeit, niedrige Signalfrequenzen oder besondere Stromverläufe) gegeben sind.
Leistungsmessung
Wirkleistungsmessung
Die KL3403 misst die Wirkleistung P nach der Gesetzmäßigkeit
P: Wirkleistung
n: Anzahl der Abtastungen (64000 Samples / s)
u(t): Augenblickswert der Spannung
i(t): Augenblickswert des Stromes
Verlauf der Leistung s(t)
Verlauf der Leistung s(t)
Im ersten Schritt wird zu jedem Abtastzeitpunkt die Leistung s(t) berechnet:
Über das Messintervall wird der Mittelwert gebildet. Hier spielt die richtige Wahl des Intervalls die gleiche Rolle wie im Abschnitt Effektivwertmessung beschrieben (das Intervall kann nur gemeinsam für U, I und P verändert werden).
Die Frequenz der Leistung ist doppelt so hoch wie die der entsprechenden Spannungen und Ströme.
Scheinleistungsmessung
In realen Netzen sind nicht alle Verbraucher rein ohmsch. Es kommt zu einer Phasenverschiebung zwischen Strom und Spannung. Die oben beschriebene Methodik zur Ermittlung der Effektivwerte von Spannung und Strom wird dadurch nicht beeinflusst.
Anders ist das bei der Wirkleistung: Das Produkt aus Effektivspannung und Effektivstrom ergibt hier die Scheinleistung.
Die Wirkleistung ist kleiner als die Scheinleistung.
S: Scheinleistung
P: Wirkleistung
Q: Blindleistung
φ: Phasenverschiebungswinkel
Verlauf u(t), i(t), p(t) mit Phasenverschiebungswinkel φ
Verlauf u(t), i(t), p(t) mit Phasenverschiebungswinkel φ
In diesem Umfeld sind weiter Informationen über das Netz und seine Verbraucher von Bedeutung:
▪
Scheinleistung S
▪
Blindleistung Q
▪
Leistungsfaktor cos φ
Die KL3403 ermittelt die Werte:
▪
Wirkleistung P
▪
Effektivspannung U
▪
Effektivstrom I
Daraus lassen sich die gesuchten Größen berechnen:
▪
Scheinleistung:
▪
Blindleistung:
▪
Leistungsfaktor:
Vorzeichen bei Leistungsmessung
Das Vorzeichen der Wirkleistung P und des Leistungsfaktors cos φ gibt Auskunft über die Richtung des Energieflusses. Ein positives Vorzeichen signalisiert den motorischen Betrieb, das negative Vorzeichen einen generatorischen Betrieb.
Weiterhin gibt das Vorzeichen der Blindleistung Q eine Auskunft über Richtung der Phasenverschiebung zwischen Strom und Spannung. In der Abb. Vier Quadranten der Wirkleistung/Blindleistung bei motorischen und generatorischen Betrieb wird dies in der Vier-Quadranten-Darstellung veranschaulicht. Im motorischen Betrieb (Quadrant I + IV) deutet eine positive Blindleistung auf eine induktive Belastung hin, eine negative Blindleistung entsprechend auf eine kapazitive Belastung. Im generatorischen Betrieb (Quadrant II + III) wird ein induktiv wirkender Generator durch eine positive Blindleistung dargestellt, ein kapazitiv wirkender Generator durch eine negative Blindleistung.
Vier Quadranten der Wirkleistung/Blindleistung bei motorischen und generatorischen Betrieb
Spitzenstrommessung
Hier muss zwischen Spitzenwert des Momentanwertes und dem Spitzenwert des Effektivwertes unterschieden werden. Der Spitzenwert des Effektivwertes bezieht sich immer nur auf den Spitzenwert innerhalb des eingestellten Messintervalls.
Frequenzmessung
Die KL3403 kann die Frequenz der an den Spannungspfaden (L1, L2, L3) anliegenden Eingangssignale messen. Die Messung dauert 5 Sekunden (Messintervall).
Messfehler
Frequenz | < 70 Hz | ≥ 70 Hz | ≥ 75 Hz | ≥ 80 Hz | ≥ 90 Hz | ≥ 100 Hz
Messfehler | < 0,0 % | < 0,2 % | < 0,5 % | < 1,5 % | < 2,0 % | < 3,0 %


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten |  |  | KL3403-... KS3403-...
 |  |  | 0000 | 0010 | 0014 |  | 0020 | 0022 | 0025 | 0026 | 0333
Messgrößen |  |  | U, I | U, I | U1) |  | U, I | I2) | U, I | U, I | U, I
Berechnetet Größen |  |  | Wirkleistung, Energie, Leistungsfaktor (cosj)
Messspannung |  |  | maximal 500 VAC 3~ |  |  |  |  | - | maximal 500 VAC 3~
Messspannung gemäß UL-Vorgaben (siehe UL-Konformität |  |  | maximal 300 VAC 3~ |  |  |  |  | - | maximal 300 VAC 3~
Messstrom (Dauerbetrieb) | direkt (maximal) |  | 1 A | 5 A | 60 mV1) |  | 20 mA | 20 mA | 250 mA | 1 A | 333 mV (AC)
 | über Stromwandler mit Übersetzungs- verhältnis Ü (maximal) |  | Ü x 1 A | Ü x 5 A | - |  | Ü x 20 mA | Ü x 20 mA | Ü x 250 mA | Ü x 1 A | Ü x 333 mV
Eingangswiderstand Spannungspfad (typisch) |  |  | 500 kΩ | 500 kΩ | 500 kΩ |  | 500 kΩ | 10 Ω2) | 500 kΩ | 500 kΩ | 500 kΩ
Eingangswiderstand Strompfad (typisch) |  |  | 33 mΩ | 6,8 mΩ | ca. 10 kΩ1) |  | 10 Ω | 10 Ω | 100 mΩ | 33 mΩ | 40 kΩ
Auflösung |  |  | 16 Bit (intern 21 Bit)
Frequenzbereich |  |  | 10 Hz bis 500 Hz
 |  |  | 0 Hz bis 500 Hz (bei deaktiviertem DC-Filter und mit Stromwandlern, die diesen Frequenzbereich unterstützen)
Grenzfrequenz |  |  | ca. 2 kHz
Signalform |  |  | beliebig (unter Berücksichtigung des Frequenzbereichs und der Grenzfrequenz)
Messgenauigkeit bei sinusförmigem Strom/Spannung (gesamter Messbereich, bezogen auf den Messbereichsendwert) |  | Spannung | 0,5% | 0,5% | 0,5% |  | 0,5% | - | 0,5%
 |  | Strom | 0,5% 3,0%3) | 1,0% 3,0%3) | - |  | 0,5% | 0,5% | 0,5%
 |  | Leistung (berechnet) | 1,0% 4,0%3) | 1,5% 4,0%3) | - |  | 1,0% | - | 1,0%
Messverfahren |  |  | True RMS, Echt-Effektivwertberechnung mit 64000 Samples / s
Messzykluszeit |  |  | frei konfigurierbar (50 ms pro Messwert voreingestellt)
Spannungsfestigkeit |  |  | 1500 V (Anschlussklemme/K-Bus)
Bitbreite im Eingangsprozessabbild |  |  | 72 Bit Eingänge (3 x 8 Bit Status, 3 x 16 Bit Daten)
Bitbreite im Ausgangsprozessabbild |  |  | 72 Bit Ausgänge (3 x 8 Bit Control, 3 x 16 Bit Daten)
Spannungsversorgung für Elektronik |  |  | über den K-Bus
Stromaufnahme aus dem K-Bus |  |  | typisch 115 mA
Steckbare Verdrahtung |  |  | bei allen Klemmen der Bauform KSxxxx
zulässiger Umgebungstemperaturbereich im Betrieb |  |  | -25°C ... + 60°C |  |  | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung |  |  | -40°C ... + 85°C |  |  | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit |  |  | 95%, keine Betauung
Vibrations- / Schockfestigkeit |  |  | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung |  |  | gemäß EN 61000-6-2 / EN 61000-6-4
Gewicht |  |  | ca. 75 g
Abmessungen (B x H x T) |  |  | ca. 15 mm x 100 mm x 70 mm (Breite angereiht 12 mm)
Montage |  |  | auf 35 mm Tragschiene nach EN 60715
Einbaulage |  |  | beliebig
Schutzart |  |  | IP20
Zulassungen |  |  | CE, cULus |  |  | CE
1) bei KL3403-0014: drei zusätzliche Spannungspfade anstelle der Strompfade: 60 mV zum Anschluss von externen Shunts
2) bei KL3403-0022: drei zusätzliche Strompfade anstelle der Spannungspfade: ebenfalls 20 mA
3) beim Einsatz im erweiterten Temperaturbereich (-25°C ... + 60°C) verringert sich die Messgenauigkeit


Stromwandler

Produktübersicht [image] Stromwandler
Stromwandler
Grundsätzlich ist die Auswahl der Stromwandler für die KL3403 nicht kritisch. Der Innenwiderstand im Strompfad der KL3403 ist so klein, dass er bei der Betrachtung der gesamten Widerstände der Stromschleife vernachlässigt werden kann. Die Wandler müssen einen Sekundär-Nennstrom von 1 A liefern können. Der Primär-Nennstrom Ipn kann beliebig gewählt werden. Die übliche zulässige Überlastung von 1.2 x Ipn ist für die KL3403 unproblematisch, kann aber zu geringen Mess-Ungenauigkeiten führen.
Genauigkeit
Beachten Sie, dass die Gesamtgenauigkeit des Aufbaues aus KL3403 und Stromwandlern, wesentlich von der Genauigkeitsklasse der Wandler abhängt.
Zulassung und Beglaubigung
Die Anordnung mit einem Stromwandler der Klasse 0,5 ist nicht zulassungs- und beglaubigungsfähig. Die KL3403 ist kein zugelassener Verrechungszähler im Sinne der Norm für Elektrizitätszähler (DIN 43 856).
Stromarten
Die KL3403 kann beliebige Stromformen bis zu einem Grenzanteil von 2 kHz messen. Da derartige Ströme häufig durch Wechselrichter erzeugt werden und Frequenzen von weniger als 50 Hz oder sogar einen DC-Anteil enthalten können, sollte in diesen Anwendungen ein elektronischer Wandler eingesetzt werden. Die KL3403 ist auch als Sonderausführung mit einem Interface für ±20 mA verfügbar.
Überstrombegrenzungsfaktor FS
Der Überstrombegrenzungsfaktor FS Stromwandler gibt an, bei welchem Vielfachen seines des primären Nennstrom der Stromwandler in die Sättigung geht, um die angeschlossenen Messgeräte zu schützen.
Hinweis
Beachten Sie den Nennstrom!
Die KL3403 darf nicht dauerhaft mit mehr als 5 A belastet werden! Setzen in Anlagen, in denen die Überstrombegrenzungsfaktoren der Wandler höhere Sekundärströme als 5 A erlauben, zusätzliche Zwischenwandler mit einem Übersetzungsverhältnis von 5A/1A oder 1A/5A ein!
Schutz vor gefährlichen Berührungsspannungen
Im bestimmungsgemäßen Betrieb der KL3403 mit entsprechenden Stromwandlern kommt es zu keinen gefährlichen Spannungen. Die Sekundärspannung liegt im Bereich von einigen Volt. Folgende Fehlerfälle können jedoch zu hohen Spannungen führen:
▪
Offener Strompfad eines oder mehrerer Wandler
▪
Durchtrennter Nullleiter auf der Seite der Spannungsmessung der KL3403
▪
Allgemeine Isolationsfehler
SmallWarningYellow WARNUNG
Berührungsgeschützt herstellen!
Die gesamte Verdrahtung der KL3403 muss berührungsgeschützt ausgeführt und mit den entsprechenden Warnhinweisen versehen werden! Legen Sie die Isolierung für die maximale Leiterspannung des zu messenden Netzes aus!
Die KL3403 lässt eine maximale Spannung von 500 V für normale Betriebsbedingen zu. Die Leiterspannung auf der Stromseite darf 500 V nicht überschreiten! Verwenden Sie für höhere Spannungen eine Zwischenwandlerstufe!
Ein KL3403 ist auf der Seite der Spannungsmessung mit einer Schutzimpedanz von 500 kΩ ausgestattet. Wenn der Nullleiter nicht angeschlossen ist und nur ein Anschluss auf der Seite der Spannungsmessung unter Spannung steht, ergibt sich in einem 3-Phasen-Netz mit einer Außenleiterspannung von 400 VAC eine Spannung von 230 VAC gegen Erde. Diese ist mit einem Multimeter mit 10 MΩ Innenwiderstand auch auf der Seite der Strommessung zu messen, was keinen Isolationsfehler darstellt.
Zusätzliche Messgeräte im Strompfad
Beachten Sie, dass sich durch das Hinzufügen zusätzlicher Messgeräte (z. B. Amperemeter) in den Strompfad die Gesamtscheinleistung deutlich erhöhen kann.
Außerdem ist muss der Anschluss IN der KL3403 einen Sternpunkt für die drei Sekundärwicklungen darstellen. Zusätzliche Messgeräte müssen deshalb potentialfrei sein und entsprechend verdrahtet werden.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Anschluss
•
Anwendungsbeispiele


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endklemme KL9010 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Anschlussbelegung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Anschlussbelegung

Montage und Verdrahtung [image] Anschluss [image] Anschlussbelegung
Anschlussbelegung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschlussbelegung
Klemmstelle | Nr. | Anschluss für | Kommentar
L1 | 1 | Phase L1 | Anschlüsse für die Spannungsmessung. (Siehe folgenden Hinweis Klemmstelle N nullen oder erden!)
L2 | 2 | Phase L2
L3 | 3 | Phase L3
N | 4 | Null-Leiter N (intern verbunden mit Klemmstelle IN, kapazitiv verbunden* mit dem Erdungskontakt zur Tragschiene)
IL1 | 5 | Stromwandler an L1 | Anschlüsse für die Stromwandler. (Siehe folgenden Hinweis Stromwandler bestimmungsgemäß betreiben!)
IL2 | 6 | Stromwandler an L2
IL3 | 7 | Stromwandler an L3
IN | 8 | Sternpunkt der Stromwandler (intern verbunden mit Klemmstelle N, kapazitiv verbunden* mit dem Erdungskontakt zur Tragschiene)
*) Bei der KL3403-0026 entfällt die kapazitive Verbindung mit dem Erdungskontakt zur Tragschiene!
SmallWarningYellow VORSICHT
Klemmstelle N nullen oder erden!
Wenn Sie die Klemmstelle N nicht mit dem Nulleiter Ihres Versorgungsnetzes verbinden (z. B. bei Verwendung der KL3403 zur reinen Strommessung), müssen Sie die Klemmstelle N erden, damit im Fehlerfall eines Stromwandlers gefährliche Überspannungen vermieden werden!
SmallWarningYellow VORSICHT
Stromwandler bestimmungsgemäß betreiben!
Beachten Sie, dass die Stromwandler vieler Hersteller nicht im Leerlauf betrieben werden dürfen! Schließen Sie die KL3403 an die Sekundärwicklung der Stromwandler an, bevor Sie die Stromwandler in Betrieb nehmen!
UL-Konformität
Beachten Sie bitte folgende Hinweise, um die Vorgaben der Underwriters Laboratories zu erfüllen.
culus-logo
Bestimmungsgemäße Verwendung
Die Klemmen sind ausschließlich für die Verwendung mit dem von UL aufgelisteten E/A-System der Serien BKxxxx, BCxxxx, BXxxxx, LCxxxx, CXxxxx, KLxxxx, KSxxxx oder KMxxxx von Beckhoff vorgesehen.
culus-logo
cULus Überprüfung
Für die cULus Überprüfung, wurde das Beckhoff E/A-System nur auf das Risiko für Feuer oder elektrischen Schlag untersucht (in Übereinstimmung mit UL508 and CSA C22.2 No. 142).
culus-logo
Strangspannung gemäß UL-Vorgaben maximal 300 V
Die von in den technischen Daten beschriebene maximale Strangspannung von 500 V ist für Anwendungsfälle mit notwendiger UL-Zulassung auf 300 V zu beschränken.
culus-logo
Stromwandler
Strommesseingänge mit den Bezeichnungen IL1, IL2, IL3, N dürfen nur mit isolierenden Stromwandlern verbunden werden, die den verfügbaren Strom auf maximal 5 A, maximal 20 V begrenzen.
culus-logo
Kein erweiterter Temperaturbereich
Auch für die KL3403-0000 / KS3403-0000 gilt beim Einsatz gemäß UL-Bedingungen der eingeschränkte Temperaturbereich (siehe Technische Daten).


Anwendungsbeispiele

Montage und Verdrahtung [image] Anwendungsbeispiele
Anwendungsbeispiele
Übersicht
▪
Anwendungsbeispiel für Wechselstrom
▪
Anwendungsbeispiel für Gleichstrom
▪
Anwendungsbeispiel mit Frequenzumrichter
▪
Anwendungsbeispiel für KL3403-0014 (ohne interne Shunts zur Strommessung)
Weiterführende Informationen
•
Anwendungsbeispiele für Wechselstrom
•
Anwendungsbeispiel für Gleichstrom
•
Anwendungsbeispiel mit Frequenzumrichter
•
Anwendungsbeispiel für KL3403-0014


Anwendungsbeispiele für Wechselstrom

Montage und Verdrahtung [image] Anwendungsbeispiele [image] Anwendungsbeispiele für Wechselstrom
Anwendungsbeispiele für Wechselstrom
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
SmallWarningYellow VORSICHT
Stromwandler bestimmungsgemäß betreiben!
Beachten Sie, dass die Stromwandler vieler Hersteller nicht im Leerlauf betrieben werden dürfen! Schließen Sie die KL3403 an die Sekundärwicklung der Stromwandler an, bevor Sie die Stromwandler in Betrieb nehmen!
Leistungsmessung an einer Maschine
▪
Die Spannungsmessung erfolgt über die Anschlüsse L1, L2, L3 und N.
▪
Die Strommessung erfolgt mittels dreier Stromwandler über die Anschlüsse IL1, IL2, IL3 und IN (Sternpunkt der Stromwandler).
Hinweis
Strom und Spannungspfad nicht verwechseln!
Achten Sie beim Anschluss darauf, Strom und Spannungspfad nicht zu verwechseln, da der direkte Anschluss von Netzspannung an die Klemmstellen für die Stromwandler (Eingangswiderstand typisch 33 mΩ) die Leistungsmessklemme zerstört!
Anwendungsbeispiel - Leistungsmessung an einer Maschine
Polarität der Stromwandler
Falls Sie in einem Pfad negative Leistungswerte messen, überprüfen Sie bitte, ob Sie den zugehörigen Stromwandlerpfad richtig herum angeschlossen haben.
Strommessung an einem Motor
SmallWarningYellow VORSICHT
Klemmstelle N nullen oder erden!
Wenn Sie die Klemmstelle N nicht mit dem Nulleiter Ihres Versorgungsnetzes verbinden (z. B. bei Verwendung der KL3403 zur reinen Strommessung), müssen Sie die Klemmstelle N erden, damit im Fehlerfall eines Stromwandlers gefährliche Überspannungen vermieden werden!
Anwendungsbeispiel - Strommessung an einem Motor


Anwendungsbeispiel für Gleichstrom

Montage und Verdrahtung [image] Anwendungsbeispiele [image] Anwendungsbeispiel für Gleichstrom
Anwendungsbeispiel für Gleichstrom
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zur Geichstrommessung DC-Filter ausschalten
Schalten Sie die DC-Filter der KL3403 (unter Verwendung der Konfigurationssoftware KS2000 oder der Registerkommunikation (Register R32.4) ab) um Gleichspannung und Gleichstrom messen zu können.
Leistungsmessung an einer Feldbusstation
Das Beispiel zeigt die Leistungsmessung an drei Stromkreisen der Feldbusstation. Die Klemme misst die:
▪
Leistungsaufnahme von Buskoppler und K-Bus-Versorgung
▪
Leistungsaufnahme der Powerkontakte
▪
Leistungsaufnahme der AS-i Netzteilklemme (KL9528)
Hinweis
Nennstrom beachten!
Im Beispiel wird der Sondertyp KL3403-0010 mit einem erweiterten Strom-Messbereich (maximal 5 A) verwendet. Der Standardtyp KL3403 ist für dieses Anwendungsbeispiel aufgrund des zu kleinen Strom-Messbereichs (1A) nicht geeignet!
Anwendungsbeispiel - Leistungsmessung an einer Feldbusstation


Anwendungsbeispiel mit Frequenzumrichter

Montage und Verdrahtung [image] Anwendungsbeispiele [image] Anwendungsbeispiel mit Frequenzumrichter
Anwendungsbeispiel mit Frequenzumrichter
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Das Beispiel zeigt die Leistungsmessung an mehreren von einem Frequenzumrichter (Wechselstromumrichter) gesteuerten Drehstrommotoren, z. B. an einer Förderanlage. Jeder Motor wird von einer KL3403 überwacht.
Anwendungsbeispiel mit Frequenzumrichter
Die galvanische Trennung des vor den Spannungspfad der Leistungsmessklemmen geschalteten Dreiphasen-Transformators (Yy0) ermöglicht die Messung hinter dem Frequenzumrichter.
Messfehler im unteren Frequenzbereich
Bei der Leistungsmessung hinter Frequenzumrichtern ist im unteren Frequenzbereich besonders bei der Spannungsmessung ein größerer Messfehler möglich. Dieser Fehler geht auch in die Leistungsberechnung ein.
Der Dreiphasen-Transformator sollte ein Übersetzungsverhältnis von 1:1 haben und darf keine Phasenverschiebung des Signals verursachen! Da hochfrequente Anteile auf die Motoren nur wenig Einfluss haben sind die durch den Dreiphasen-Transformator bedingten Verzerrungen bei der Übertragung der durch den Frequenzumrichter erzeugten Oberwellen ohne große Auswirkung auf die praktische Messung.
Durch die Verwendung von je einer Leistungsmessklemme pro Motor wird die Aufteilung der Leistung sehr gut abgebildet. Eine überhöhte Stromaufnahme eines einzelnen Motors kann rechtzeitig erkannt werden.
Die Messung von Gleichspannung/Gleichstrom (z. B. Halteströme von Synchronmotoren) ist auf diese Art nicht möglich! Praktische Ergebnisse ergeben sich je nach verwendeten Dreiphasen-Transformator und Stromwandlern für Spannungen/Ströme mit einer Frequenz oberhalb von 5 Hz.
SmallWarningYellow VORSICHT
Klemmstellen N erden!
Aufgrund der galvanischen Trennung durch den Dreiphasen-Transformator, müssen Sie die Klemmstellen N der Leistungsmessklemmen erden, damit im Fehlerfall eines Stromwandlers gefährliche Überspannungen vermieden werden!


Anwendungsbeispiel für KL3403-0014

Montage und Verdrahtung [image] Anwendungsbeispiele [image] Anwendungsbeispiel für KL3403-0014
Anwendungsbeispiel für KL3403-0014
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Die KL3403-0014 hat keine internen Shunts zur Strommessung. Sie ermöglicht die Verwendung von externen Shunts. Dafür stehen anstelle der drei Strompfade die zusätzlichen Spannungspfade UI1, UI2 und UI3 zur Verfügung.
Anschluss
Mit Verbindungsleitungen wird die an den externen Shunts abfallende Spannung zu den Klemmstellen UI1, UI2 und UI3 der KL3403-0014 geführt.
Anwendungsbeispiel für KL3403-0014
Das Beispiel zeigt die Leistungsmessung an drei Glühbirnen. Dabei erfolgt die Strommessung über drei externe Shunts.
Spannungsabfall auf den Leitungen zwischen den Shunts
Beachten Sie, dass der Spannungsabfall auf den Leitungen zwischen den Shunts (im Bild rot dargestellt) die Messung verfälscht. Diese Verbindungen müssen also mit kurzen Leitungen hohen Querschnitts möglichst niederohmig ausgeführt werden, um diesen Messfehler gering zu halten. Andernfalls kommt es zu erheblichen Messfehlern, da der Spannungsabfall auf diesen Leitungen vergleichsweise hoch ist bei der Leistungsberechnung einen großen Fehler erzeugt.
Bemessung der Shunts
Für die Shunts wird typischerweise ein Spannungsabfall von 60 mV / x A angegeben.
Beispiele
Nennwert des Shunts | 60 mV / 1 A | 60 mV / 25 A | 60 mV / 100 A
Beispielstrom | 1 A | 25 A | 100 A
Ausgabewert der Klemme für den Strom | 25000dez (0x61A8) | 25000dez (0x61A8) | 25000dez (0x61A8)


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Einstellungen
•
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Ethernet-Koppler BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine Leistungsmessklemme KL3403
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).
KS2000 Baumzweig für Kanal 1 der KL3403
Für jeden der drei Kanäle werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register des Kanals.
▪
Unter Einstellungen finden Sie die Dialogmaske zur Parametrierung der KL3403.
▪
ProcData zeigt die Prozessdaten der KL3403.


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Unter Einstellungen finden Sie die Dialogmaske zur Parametrierung der KL3403.
Einstellungen über KS2000
Kopfzeile
Pos.: Position der Klemme im Busklemmenblock.
Typ: Klemmentyp
Firmware: Auf der Klemme installierte Firmware-Version.
Betriebsmodus
Anwender-Skalierung aktiv (R32.0)
Hier können Sie die Anwender-Skalierung aktivieren (Default: deaktiviert).
Watchdog Timer aktiv (R32.2)
Hier können Sie den Watchdog Timer deaktivieren (Default: aktiviert).
DC-Filter aktiv (R32.4)
Hier können Sie den DC-Filter deaktivieren (Default: aktiviert).
CosPhi mit Vorzeichen (R32.5)
Hier können Sie für den CosPhi die Vorzeichendarstellung deaktivieren (Default: aktiviert).
Energiemessung invertiert (R32.6)
Hier können Sie die Invertierung des Vorzeichens der Energiemessung aktivieren (Default: deaktiviert).
Flexibles Prozessabbild aktiv (R32.3)
Hier können Sie das flexible Prozessabbild aktivieren/deaktivieren (Default:
▪
deaktiviert bei KL3403-0000, KL3403-0010, KL3403-0025, KL3403-0026, KL3403-0333,
▪
aktiviert bei KL3403-0020, KL3403-0022)
Min- und Max-Werte automatisch löschen (R32.7)
Hier können Sie das automatische Löschen der minimalen und maximalen Strom-, Spannungs- und Leistungswerte aktivieren (Default: deaktiviert).
Registerwerte
Skalierung Energieverbrauch (R35)
Hier können Sie die Skalierung der Messung des Energieverbrauch verändern (Default: KL3403-0000: 0,01 kWh, KL3403-0010: 0,05 kWh).
Minimale Eingangsspannung - Unterspannungs-Schwelle (R36)
Hier können Sie die Unterspannungs-Schwelle (Auflösung: 0,1 V) verändern.
Unterschreitet die Netzspannung die vorgegebene Unterspannungs-Schwelle (default: 10 V), wird die rote Fehler-LED aktiviert und im Status-Byte 0 das Error-Bit (SB1.6) gesetzt.
Übersetzung Stromwandler (R37)
Die KL3403 kann das Übersetzungsverhältnis eines angeschlossenen Stromwandlers bei der Messwertausgabe gleich berücksichtigen.
Wählen sie hier das Übersetzungsverhältnis eines angeschlossenen Stromwandlers aus und aktivieren Sie diese Skalierung mit dem Optionsfeld Anwender-Skalierung (R32.0).
Beachten Sie den zulässigen Wertebereich der Messwertausgabe
Die Berücksichtigung des Wandler-Verhältnisses durch die KL3403 darf nur benutzt werden, wenn der berechnete resultierende Strom den Wert von 65535 nicht überschreitet!
Falls die Berechnung den Wert 65535 doch überschreitet, müssen Sie die Berücksichtigung des Wandler-Verhältnisses in der PLC durchführen.
Messzykluszeit (R39)
Hier können Sie die Messzykluszeit (Auflösung: 1 ms) verändern (Default: 200 ms).
Löschzeit (R38)
Hier können Sie die Zeitkonstante (Auflösung: 10 ms) zum automatischen Löschen der minimalen und maximalen Strom, Spannungs- und Leistungswerte verändern (Default: 2000 ms).
Passwort
Hier können das Passwort der KL3403 (Default: 4661dez) ändern, um unbefugtes Löschen des Energieverbrauchs zu verhindern:
▪
Geben Sie das alte Passwort in das obere Feld ein!
▪
Geben Sie das neue Passwort in das mittlere Feld ein!
▪
Wiederholen Sie das neue Passwort im unteren Feld und drücken Sie die Schaltfläche Passwort ändern
Passwort
In diesem Dialog müssen sie die Passworte in dezimaler Form eingeben! Sie können das Passwort auch über das Passwortänderungsregister (R5) verändern.
Energieverbrauch
Hier können Sie den gespeicherten Energieverbrauch löschen. Geben Sie dazu das Passwort ein und drücken Sie die Schaltfläche Löschen.
Löschen des Energieverbrauchs
Nach löschen des Energieverbrauchs kann dieser Wert nicht wiederhergestellt werden!


Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314

Konfigurations-Software KS2000 [image] Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Anwenders zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Programmbeschreibung/ Funktion
Dieses Beispielprogramm (TwinCAT 3) erlaubt per AoE die Änderung einzelner Registerwerte der KL3314 wie die Auswahl des Element-Typs und charakteristische Einstellungen des Feature‑Registers R32 sowie die Anwenderskalierung Offset und Gain (R33/ R34) ähnlich wie per KS2000.
Einstellungen der KL3314 über die Visualisierung von TwinCAT 3
Es sollte mindestens die folgende Konfiguration vorhanden sein:
[Koppler (z.B. BK1120) oder embedded PC] + KL3314 + KL9010.
Download:
Vorbereitungen zum Starten des Beispielprogramms (tnzip - Datei/ TwinCAT 3)
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.tnzip -Archivdatei in einem temporären Ordner.
Öffnen des *. tnzip - Archives
▪
Wählen Sie die zuvor entpackte .tnzip Datei (Beispielprogramm) aus.
▪
Ein weiteres Auswahlfenster öffnet sich: wählen nun Sie das Zielverzeichnis, wo das Projekt gespeichert werden soll.
▪
Die generelle Vorgehensweise für die Inbetriebnahme der PLC bzw. dem Start des Programms kann u.a. den Klemmen‑Dokumentationen oder der EtherCAT‑Systemdokumentation entnommen werden.
▪
Das EtherCAT Gerät im Beispiel ist i.d.R. zuvor ihrem vorliegenden System bekannt zu machen. Verwenden Sie nach Auswahl des EtherCAT Gerätes im „Projektmappen-Explorer“ rechtsseitig den Karteireiter „Adapter“ und Klicken „Suchen...“:
Suche der bestehenden HW-Konfiguration zur bestehenden EtherCAT-Konfiguration
▪
Überprüfen der NetId: der Karteireiter „EtherCAT“ des EtherCAT Gerätes zeigt die konfigurierte NetId: .
Diese muss mit den ersten vier Zahlenwerten mit der Projekt‑NetId des Zielsystems übereinstimmen. Die NetId des Projektes kann oben in einem Textfeld der TwinCAT-Umgebung eingesehen werden. Ein pull-down Menü kann durch einen Klick rechts im Textfeld geöffnet werden; dort ist zu jeden Rechnernamen eines Zielsystems die NetId in Klammern angegeben.
▪
Ändern der NetId: mit einem Rechtsklick auf „Gerät EtherCAT“ im Projektmappen-Explorer öffnet sich das Kontextmenü, in dem „Ändern der NetId“ auszuwählen ist. Die ersten vier Zahlen der NetId des Projektes sind einzutragen. die beiden letzten Werte sind i.d.R. 4.1.
Beispiel:
–
NetId des Projektes: myComputer (123.45.67.89.1.1)
–
Eintrag per „Change NetId...“: 123.45.67.89.4.1


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Bytes
•
Auslesen der Prozessdaten
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Die KL3403 stellt sich im Prozessabbild mit mindestens 9 Byte Ein- und Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment*) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | Status-Byte 1 (SB1) | Control-Byte 1 (CB1)
1 | 2 | Wort | DataIN1 | DataOUT1
3 | 4 | Byte | Status-Byte 2 (SB2) | Control-Byte 2 (CB2)
4 | 6 | Wort | DataIN2 | DataOUT2
6 | 8 | Byte | Status-Byte 3 (SB3) | Control-Byte 3 (CB3)
7 | 10 | Wort | DataIN3 | DataOUT3
*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen
Kein kompaktes Prozessabbild
Ein Betrieb der KL3403 mit kompaktem Prozessabbild (ohne Control- und Status-Bytes) ist nicht möglich, da Control- und Status-Bytes für einen sinnvollen Prozessdatenbetrieb der KL3403 erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen wird die KL3403 mit ihrem kompletten Prozessabbild dargestellt!
Ausgabewerte
Klemmen-Typ | Nennwert (effektiv) | Ausgabe für Nennwert
KL3403-0000 | 1,0 A | 1000dez
KL3403-0010 | 5,0 A | 1000dez
KL3403-0014 | 60 mV | 25000dez
KL3403-0020 | 20 mA | 1000dez
KL3403-0022 | 20 mA | 4000dez
KL3403-0025 | 250 mA | 1000dez
KL3403-0026 | 1,0 A | 1000dez
KL3403-0333 | 333 mV | 1000dez


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Bytes
Control- und Status-Bytes
Control- uns Status-Byte des ersten Kanals (L1)
Prozessdatenbetrieb
Control-Byte 1 im Prozessdatenbetrieb
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur KL3403 übertragen. Beachten Sie die Zuordnung der Control-Bytes zu den Prozesseingangsdatenworten.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | ChannelIdx |  | ProcDatIdx
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 | R/W | 0bin | Lesezugriff
 |  | (1bin) | Da die Prozessdatenregister der KL3403 nur gelesen werden können, ist ein Schreibzugriff nicht sinnvoll.
CB1.5 bis CB1.4 | ChannelIdx5 | Geben Sie hier den Kanal-Index des Kanals an, von dem Sie mit dem Eingangsdatenwort 1 (DataIN1) einen Messwert auslesen wollen.
 |  | 00bin | Kanal 1
 |  | 01bin | Kanal 2
 |  | 10bin | Kanal 3
 |  | 11bin | reserviert
CB1.3 bis CB1.0 | ProcDatIdx | Geben Sie hier den Prozessdaten-Index des Messwerts an, den Sie mit dem Eingangsdatenwort 1 (DataIN1) auslesen wollen. Es werden folgende Prozessdaten-Indices unterstützt:
 |  | Index |  | Symbol | Messwert | Auflösung
 |  | 0000bin | 0x0 | Ieff | Strom (Effektivwert) | 0,001 A (KL3403-0000, KL3403-0026) 0,005 A (KL3403-0010) 20 µA (KL3403-0020) 5 µA (KL3403-0022) 250 µA (KL3403-0025) 333 µV (KL3403-0333)
 |  | 0001bin | 0x1 | Ueff | Spannung (Effektivwert) | 0,1 V
 |  | 0010bin | 0x2 | P | Wirkleistung | 0,1 W (KL3403-0000, KL3403-0026) 0,5 W (KL3403-0010) 2 mW (KL3403-0020) flexibel, max. 16000 Digit (KL3403-0022)6 25 mW (KL3403-0025) flexibel, max. 16000 Digit (KL3403-0333) 6
 |  | 0011bin | 0x3 | cos φ | Leistungsfaktor 4 | 0,01
 |  | 0100bin | 0x4 | W | Energieverbrauch1 | default3: 0,01 kWh (KL3403-0000, KL3403-0026) default3: 0,05 kWh (KL3403-0010) default3: 0,2 Wh (KL3403-0020) flexibel (KL3403-0022)6 default3: 2,5 Wh (KL3403-0025) flexibel (KL3403-0333) 6
 |  | 0101bin | 0x5 | Imax | Spitzenwert des Stroms2 | siehe Index 0dez
 |  | 0110bin | 0x6 | Umax | Spitzenwert der Spannung2 | siehe Index 1dez
 |  | 0111bin | 0x7 | Pmax | Spitzenwert der Wirkleistung2 | siehe Index 2dez
 |  | 1000bin | 0x8 | f | Frequenz | 0,1 Hz (Messintervall: 5 s)
 |  | 1001bin | 0x9 | Imin | Minimalwert des Stroms2 | siehe Index 0dez
 |  | 1010bin | 0xA | Umin | Minimalwert der Spannung2 | siehe Index 1dez
 |  | 1011bin | 0xB | Pmin | Minimalwert der Wirkleistung2 | siehe Index 2dez
 |  | weitere |  | reserviert
1) | Der Energieverbrauch wird im RAM gezählt und zyklisch alle 15 Minuten in das EEPROM gespeichert. Dort bleibt er auch beim Abschalten der KL3403 erhalten. Mit Hilfe des Kommando-Registers (R7) kann der Energiewert gelöscht werden oder manuell vor Ablauf der 15 Minuten gespeichert werden.
2) | Die Minimal- und Spitzenwerte werden beim Abschalten der KL3403 gelöscht. Es wird empfohlen die Minimal- und Spitzenwerte nach dem Hochfahren der Klemme einmal aus dem Anwenderprogramm heraus zu löschen, da hier beim Hochfahren der Klemme, also bevor die Klemme stabil misst, falsche Werte hinterlegt worden sein könnten.
3) | Die Auflösung des Energieverbrauchs kann für jeden Kanal mit seinem Register R35 skaliert werden.
4) | Der Leistungsfaktor (cos φ) kann mit oder ohne Vorzeichen angezeigt werden (siehe Bit R32.5 des Feature Registers).
5) | Das flexible Prozessabbild muss aktiviert sein (R32.3 = 1) um mit dem Eingangsdatenwort 1 (DataIN1) von jedem Kanal Messwerte auslesen zu können! Mit dem einfachen Prozessabbild (R32.3 = 0) kann das Eingangsdatenwort 1 (DataIN1) nur den ersten Kanal auslesen (die Bits CB1.5, CB1.4 bzw. SB1.5 und SB1.4 sind dann nicht aktiv).
6) | Die ausgelesenen Werte sind abhängig von den an den Stromwandlern angeschlossenen Spannungen und Strömen. Sie müssen von der Applikation umgerechnet werden.
Lebensdauer des EEPROMS
Der Energieverbrauch wird in einem EEPROM gespeichert. Der Hersteller des EEPROMS spezifiziert für diesen Baustein mindestens 100000 und typisch 1 Million mögliche Schreibvorgänge. Daraus ergibt sich bei Dauerbetrieb, wenn alle 15 Minuten der Energieverbrauch in das EEPROM geschrieben wird, für den Energieverbrauchsspeicher
•
eine Mindestlebensdauer von 2,85 Jahren
•
eine typische Lebensdauer von 28,5 Jahren
Status-Byte 1 im Prozessdatenbetrieb
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der KL3403 zur Steuerung übertragen. Beachten Sie im Prozessdatenbetrieb die Zuordnung der Control-Bytes zu den Prozesseingangsdatenworten.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | ERR L1 | ChannelIdx |  | ProcDatIdx
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 | ERR L1 | 0bin | Spannung zwischen L1 und N größer als Unterspannungs-Schwelle (R36).
 |  | 1bin | Spannung zwischen L1 und N kleiner als Unterspannungs-Schwelle (R36). Die Leuchtdiode ERR L1 leuchtet.
SB1.5 bis SB1.4 | ChannelIdx | 00bin | Mit dem Eingangsdatenwort 1 (DataIN1) wurde ein Messwert von Kanal 1 ausgelesen.
 |  | 01bin | Mit dem Eingangsdatenwort 1 (DataIN1) wurde ein Messwert von Kanal 2 ausgelesen.
 |  | 10bin | Mit dem Eingangsdatenwort 1 (DataIN1) wurde ein Messwert von Kanal 3 ausgelesen.
 |  | 11bin | reserviert
SB1.3 bis SB1.0 | ProcDatIdx | Index des Messwerts, der mit Eingangsdatenwort 1 (DataIN1) ausgelesen wurde.
Registerkommunikation
Control-Byte 1 bei Registerkommunikation
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur KL3403 übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort 1 lesen oder - mit dem Ausgangsdatenwort 1 beschreiben wollen.
SmallWarningYellow VORSICHT
Kein Prozessdatenzugriff während der Registerkommunikation!
Während der Registerkommunikation kann nicht auf Datenregister zugegriffen werden! Prozessdaten, die eventuell noch angezeigt werden, sind nicht gültig!
Status-Byte 1 bei Registerkommunikation
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der KL3403 zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Control- und Status-Byte des zweiten Kanals (L2)
Das Control-Byte 2 (CB2) befindet sich im Ausgangsabbild und wird von der Steuerung zur KL3403 übertragen (Aufbau und Verwendung siehe Control-Byte 0). Beachten Sie im Prozessdatenbetrieb die Zuordnung der Control-Bytes zu den Prozesseingangsdatenworten.
Das Status-Byte 2 (SB2) befindet sich im Eingangsabbild und wird von der KL3403 zur Steuerung übertragen (Aufbau und Verwendung siehe Status-Byte 0).
Control- und Status-Byte des dritten Kanals (L3)
Das Control-Byte 3 (CB3) befindet sich im Ausgangsabbild und wird von der Steuerung zur KL3403 übertragen (Aufbau und Verwendung siehe Control-Byte 0). Beachten Sie im Prozessdatenbetrieb die Zuordnung der Control-Bytes zu den Prozesseingangsdatenworten.
Das Status-Byte 3 (SB3) befindet sich im Eingangsabbild und wird von der KL3403 zur Steuerung übertragen (Aufbau und Verwendung siehe Status-Byte 0).


Auslesen der Prozessdaten

Zugriff aus dem Anwenderprogramm [image] Auslesen der Prozessdaten
Auslesen der Prozessdaten
Einfaches Prozessabbild (Kompatibilitäts-Modus)
Wird von allen Firmware-Versionen unterstützt.
Beim einfachen Prozessabbild ist jedes Prozessdatenwort seinem Kanal fest zugeordnet und kann nur Messwerte dieses Kanals auslesen!
Kanal | Kontroll-Byte | zugehöriges Prozessdatenwort
1 | Control-Byte 1 | DataIN1
2 | Control-Byte 2 | DataIN2
3 | Control-Byte 3 | DataIN3
Wenn Sie im Prozessdatenbetrieb einen Prozessdatenindex in ein Control-Byte eintragen, wird das Prozessdatum im zugehörigen Prozessdatenwort zurückgegeben.
Die Prozessdaten-Indices sind im Kapitel Control- und Status-Bytes aufgelistet.
Beispiele für das einfache Prozessabbild
Spannung (Effektivwert) der Phasen L1, L2 und L3 auslesen
▪
Tragen Sie Prozessdatenindex 0x1 in Control-Byte 1 ein.
Die Spannung (Effektivwert) der Phase L1 wird im Prozessdatenwort DataIN1 zurückgegeben.
▪
Tragen Sie Prozessdatenindex 0x1 in Control-Byte 2 ein.
Die Spannung (Effektivwert) der Phase L2 wird im Prozessdatenwort DataIN2 zurückgegeben.
▪
Tragen Sie Prozessdatenindex 0x1 in Control-Byte 3 ein.
Die Spannung (Effektivwert) der Phase L3 wird im Prozessdatenwort DataIN3 zurückgegeben.
Spannung (Effektivwert) der Phase L1 auslesen, Wirkleistung der Phase L2 auslesen und Leistungsfaktor der Phase L3 auslesen
▪
Tragen Sie Prozessdatenindex 0x1 in Control-Byte 1 ein.
Die Spannung (Effektivwert) der Phase L1 wird im Prozessdatenwort DataIN1 zurückgegeben.
▪
Tragen Sie Prozessdatenindex 0x2 in Control-Byte 2 ein.
Die Wirkleistung der Phase L2 wird im Prozessdatenwort DataIN2 zurückgegeben.
▪
Tragen Sie Prozessdatenindex 0x3 in Control-Byte 3 ein.
Der Leistungsfaktor der Phase L3 wird im Prozessdatenwort DataIN3 zurückgegeben.
Flexibles Prozessabbild
Wird ab Firmware-Version 3G von der KL3403-0000, KL3403-0010, KL3403-0025 und KL3403-0026 unterstützt.
Wird ab Firmware-Version 4F von der KL3403-0020 und KL3403-0022 unterstützt.
Wird ab Firmware-Version 4K von der KL3403-0333 unterstützt.
Beim flexiblen Prozessabbild kann ein Prozessdatenwort Messwerte von jedem beliebigen Kanal auslesen.
Das flexible Prozessabbild wird mit KS2000 oder Bit R32.3 des Feature-Registers aktiviert/deaktiviert.
Beispiele für das flexible Prozessabbild
Strom (Effektivwert), Spannung (Effektivwert) und Wirkleistung der Phase L2 auslesen
▪
Tragen Sie 0x10 in Control-Byte 1 ein (Kanalindex 01bin, Prozessdatenindex 0000bin).
Der Strom (Effektivwert) der Phase L2 wird im Prozessdatenwort DataIN1 zurückgegeben.
▪
Tragen Sie 0x11 in Control-Byte 2 ein (Kanalindex 01bin, Prozessdatenindex 0001bin).
Die Spannung (Effektivwert) der Phase L2 wird im Prozessdatenwort DataIN2 zurückgegeben.
▪
Tragen Sie 0x12 in Control-Byte 3 ein (Kanalindex 01bin, Prozessdatenindex 0010bin).
Die Wirkleistung der Phase L2 wird im Prozessdatenwort DataIN3 zurückgegeben.
Strom (Effektivwert), Spannung (Effektivwert) der Phase L1 und Spannung der Phase L2 auslesen
▪
Tragen Sie 0x00 in Control-Byte 1 ein (Kanalindex 00bin, Prozessdatenindex 0000bin).
Der Strom (Effektivwert) der Phase L1 wird im Prozessdatenwort DataIN1 zurückgegeben.
▪
Tragen Sie 0x01 in Control-Byte 2 ein (Kanalindex 00bin, Prozessdatenindex 0001bin).
Die Spannung (Effektivwert) der Phase L1 wird im Prozessdatenwort DataIN2 zurückgegeben.
▪
Tragen Sie 0x11 in Control-Byte 3 ein (Kanalindex 01bin, Prozessdatenindex 0001bin).
Der Spannung (Effektivwert) der Phase L2 wird im Prozessdatenwort DataIN3 zurückgegeben.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Diese Register dienen zur Parametrierung der Leistungsmessklemme und sind für jeden Kanal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | Überlauf-Register für den Energieverbrauch |  | 0x0000 | 0dez | R/W | Flash
R1 | reserviert |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R4 | reserviert |  | - | - | - | -
R5 | Passwortänderungs-Register |  | - | - | - | -
R6 | Diagnose-Register |  | - | - | R | RAM
R7 | Kommando-Register |  | - | - | - | -
R8 | Klemmentyp |  | 0x0D4B | 3403dez | R | ROM
R9 | Firmware-Stand |  | z. B. 0x3143 | 12611dez | R | ROM
R10 | Multiplex-Schieberegister |  | 0x0230 / 0x0318 | 560dez / 792dez | R | ROM
R11 | Signalkanäle |  | 0x0318 | 792dez | R | ROM
R12 | minimale Datenlänge |  | 0x1818 | 6168dez | R | ROM
R13 | Datenstruktur |  | 0x0007 | 7dez | R | ROM
R14 | reserviert |  | - | - | - | -
R15 | Alignment-Register |  | - | - | R/W | RAM
R16 | Hardware Version |  | z. B. 0x0000 | z. B. 0dez | R/W | Flash
R17 | Abgleich Gain Spannung |  | z. B. 0x0400 | z. B. 1024dez | R/W | Flash
R18 | Abgleich Gain Strom |  | z. B. 0x0400 | z. B. 1024dez | R/W | Flash
R19 | reserviert |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R29 | Klemmentyp, Sonderkennung |  | z. B. 0x000 | z. B. 0dez |  |
R30 | reserviert |  | - | - | - | -
R31 | Kodewort-Register |  | 0x0000 | 0dec | R/W | RAM
R32 | Feature-Register | KL3403-0000, KL3403-0010, KL3403-0025, KL3403-0026, KL3403-0333 | 0x0020 | 32dez | R/W | Flash
 |  | KL3403-0014, KL3403-0020, KL3403-0022 | 0x0030 | 48dez
R33 | reserviert |  | - | - | - | -
R34 | reserviert |  | - | - | - | -
R35 | Skalierungsfaktor für die Energiemessung |  | 0x0004 | 4dez | R/W | Flash
R36 | Unterspannungs-Schwellwert |  | 0x0064 | 100dez | R/W | Flash
R37 | Divisor des Stromwandlerverhältnisses |  | 0x0001 | 1dez | R/W | Flash
R38 | Zeitkonstante zum automatischen Löschen der minimalen und maximalen Werte |  | 0x00C8 | 200dez | R/W | Flash
R39 | Messzykluszeit |  | 0x0032 | 50dez | R/W | Flash
R40 | reserviert |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R63 | reserviert |  | - | - | - | -


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Diese Register dienen zur Parametrierung der Leistungsmessklemme und sind für jeden Kanal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
R0: Überlauf-Register für den Energieverbrauch
Wenn das Register für den Energieverbrauch (auszulesen über Prozessdatenindex 0x4) überläuft, wird dieses Überlauf-Register inkrementiert. So stehen Ihnen für die Speicherung des Energieverbrauchs 32 Bit zur Verfügung. Das Überlaufregister für den Energieverbrauch muss über die Registerkommunikation ausgelesen werden.
R5: Passwortänderungs-Register
Sie können das Passwort der KL3403 (Default: 1235hex) ändern, um unbefugtes Löschen des Energieverbrauchs zu verhindern.
Zur Änderung des Passwortes gehen Sie folgendermaßen vor:
1.
Tragen Sie das alte Passwort (Default: 1235hex) in das Passwort-Register (R31) ein.
2.
Tragen Sie das neue Passwort ein in das Passwortänderungs-Register (R5) ein.
3.
Wiederholen Sie das neue Passwort im Kommando-Register (R7).
Das neue Passwort ist nun ohne Reset der Klemme gültig!
R7: Kommando-Register
Kommando 0x1004: Energieverbrauch löschen (Anwender-Passwort muss gesetzt sein)
Schreiben Sie den Wert 0x1004 in das Kommandoregister um den in den Prozessdaten gespeicherten Energieverbrauch (Prozessdatenindex 0x4) und das Überlauf-Register für den Energieverbrauch (R0) zu löschen.
Kommando 0x1005: Maximalstrom löschen
Schreiben Sie den Wert 0x1005 in das Kommandoregister um den in den Prozessdaten gespeicherten Maximalstrom (Prozessdatenindex 0x5) zu löschen.
Kommando 0x1006: maximale Spannung löschen
Schreiben Sie den Wert 0x1006 in das Kommandoregister um die in den Prozessdaten gespeicherte maximale Spannung (Prozessdatenindex 0x6) zu löschen.
Kommando 0x1007: maximale Wirkleistung löschen
Schreiben Sie den Wert 0x1007 in das Kommandoregister um die in den Prozessdaten gespeicherte maximale Wirkleistung (Prozessdatenindex 0x7) zu löschen.
Kommando 0x1009: minimalen Strom löschen
Schreiben Sie den Wert 0x1009 in das Kommandoregister um den in den Prozessdaten gespeicherten minimalen Strom (Prozessdatenindex 0x9) zu löschen.
Kommando 0x100A: minimale Spannung löschen
Schreiben Sie den Wert 0x100A in das Kommandoregister um die in den Prozessdaten gespeicherte minimale Spannung (Prozessdatenindex 0xA) zu löschen.
Kommando 0x100B: minimale Wirkleistung löschen
Schreiben Sie den Wert 0x100B in das Kommandoregister um die in den Prozessdaten gespeicherte minimale Wirkleistung (Prozessdatenindex 0xB) zu löschen.
Kommando 0x1014: Energieverbrauch vorzeitig speichern
Die KL3403 zählt den Energieverbrauch im RAM und speichert die Werte nur alle 15 Minuten zyklisch im EEPROM. Wenn sie die KL3403 abschalten wollen, ohne den seit der letzten zyklischen Speicherung gemessenen Energieverbrauch zu verlieren, können sie mit diesem Befehl den aktuellen Wert manuell in das EEPROM speichern.
Kommando 0x1020: alle minimalen und maximalen Werte löschen
Schreiben Sie den Wert 0x1020 in das Kommandoregister um alle minimalen und maximalen Werte zu löschen.
Kommando 0x7000: Restore Factory Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register die Werte des Auslieferungszustands wiederhergestellt:
R32:
▪
0x0020 bei KL3403-0000, KL3403-0010, KL3403-0025, KL3403-0026, KL3403-0333 bzw.
▪
0x0030 bei KL3403-0014, KL3403-0020, KL3403-0022
R35: 4
R36: 100dez
R37: 1
R38: 200dez
R39: 50dez
Wiederholung des neuen Passworts
Wiederholen Sie bei der Änderung des Passwortes im Kommandoregister das neue Passwort (siehe Beschreibung zum Passwortänderungs-Register R5).
R8: Klemmenbezeichnung
Im Register R8 steht in hexadezimaler Codierung die Bezeichnung der Klemme. KL3403: 0x0D4B (3403dez)
R9: Firmware-Stand
Im Register R9 steht in hexadezimaler Codierung der Firmware-Stand der Klemme, z. B. 0x3143 (12611dez).
R17: Abgleich Gain Spannung
Dieses Register beinhaltet bei der Produktion ermittelte Abgleichwerte, die nicht verändert werden können.
R18: Abgleich Gain Strom
Dieses Register beinhaltet bei der Produktion ermittelte Abgleichwerte, die nicht verändert werden können.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte nur in die RAM-Register, nicht aber in die EEPROM-Register gespeichert und gehen somit bei einem Neustart der Klemme verloren.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die EEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Betriebsart der Klemme fest.
Bit | Feature | Wert | Erläuterung | Default
R32.15 bis R32.8 | - | - | reserviert | 0bin
R32.7 | enClrMinMaxValues | 1bin | automatisches Löschen der minimalen und maximalen Strom-, Spannungs- und Leistungswerte (Prozessdatenindex 0x5, 0x6, 0x7, 0x9, 0xA und 0xB) aktiviert | 0bin
R32.6 | invEnergySign | 1bin | die Energieverbrauchsmessung wird invertiert (generatorischer Betrieb) | 0bin
R32.5 | signCosPhi | 0bin | CosPhi (cos φ) wird immer positiv angezeigt | 1bin
 |  | 1bin | CosPhi (cos φ) wird mit Vorzeichen angezeigt: - induktive Last: cos φ hat positives Vorzeichen - kapazitive Last: cos φ hat negatives Vorzeichen
R32.4 | skipDcFilter | 0bin | DC-Filter aktiv | 0bin
 |  | 1bin | DC-Filter wird umgangen
R32.3 | enFlexProcImage | 0bin | einfaches Prozessabbild (Kompatibilitäts-Modus) | 0bin/1bin*
 |  | 1bin | flexibles Prozessabbild
R32.2 | disWdTimer | 0bin | Watchdog Timer aktiv: werden 100 ms keine Prozessdaten empfangen, löst der Watchdog aus | 0bin
 |  | 1bin | Watchdog Timer nicht aktiv
R32.1 | - | - | reserviert | 0bin
R32.0 | enUserScaling | 0bin | Anwenderskalierung ist ausgeschaltet (Übersetzungsverhältnis ist 1:1) | 0bin
 |  | 1bin | Anwenderskalierung ist eingeschaltet (Übersetzungsverhältnis ist 1/R37)
*) 0bin (KL3403-0000, KL3403-0010, KL3403-0025, KL3403-0026 KL3403-0333)
1bin (KL3403-0020, KL3403-0022)
R35: Skalierungsfaktor für die Energiemessung
Mit diesem Register können Sie die Messung der Energie skalieren. Default: 4dez (KL3403-0000 / -002x /-0333: 0,01 kWh, KL3403-0010: 0,05 kWh). Zum Ändern des Skalierungsfaktors müssen Sie zuvor in Register R31 das Anwender-Kodewort setzen!
Eintrag |  | 0dez | 1dez | 2dez | 3dez | 4dez | 5dez | 6dez | ...
Skalierungs- faktor | KL3403-0000, KL3403-002x, KL3403-0333 | 1 mWh | 0,01 Wh | 0,1 Wh | 1 Wh | 0,01 kWh | 0,1 kWh | 1 kWh | reserviert
 | KL3403-0010 | 5 mWh | 0,05 Wh | 0,5 Wh | 5 Wh | 0,05 kWh | 0,5 kWh | 5 kWh | reserviert
R36: Unterspannungs-Schwelle
Unterschreitet die Netzspannung die im Register R36 gespeicherte Unterspannungs-Schwelle (Auflösung: 0,1 V, Default: 100dez=10 V), wird im Status-Byte 0 das Error-Bit (SB1.6) gesetzt und die rote Fehler-LED aktiviert.
R37: Divisor des Stromwandlerverhältnisses
Die KL3403 kann das Übersetzungsverhältnis eines angeschlossenen Stromwandlers bei der Messwertausgabe gleich berücksichtigen. Geben sie hier den Divisor des Übersetzungsverhältnisses eines angeschlossenen Stromwandlers ein und schalten Sie diese Skalierung mit Bit R32.0 des Feature-Registers frei.
Beachten Sie den zulässigen Wertebereich der Messwertausgabe
Die Berücksichtigung des Wandler-Verhältnisses durch die KL3403 darf nur benutzt werden, wenn der berechnete resultierende Strom den Wert von 65535 nicht überschreitet!
Falls die Berechnung den Wert 65535 doch überschreitet, müssen Sie die Berücksichtigung des Wandler-Verhältnisses in der PLC durchführen.
R38: Zeitkonstante zum automatischen Löschen der minimalen und maximalen Werte
Bei aktiviertem Bit R32.7 werden die minimalen und maximalen Strom, Spannungs- und Leistungswerte der jeweiligen Phase nach der eingestellten Zeit gelöscht.
▪
Defaultwert: 2000 ms (R38 = 200)
▪
Auflösung: 10 ms
▪
Wertebereich: 10 ms bis 655350 ms
R39: Messzykluszeit
Mit diesem Register wird die Messzykluszeit des A/D-Wandlers eingestellt:
▪
Defaultwert: 50 ms
▪
Auflösung: 1 ms
▪
Wertebereich: 1 ms bis 65535 ms
Die richtige Einstellung des Messintervalls ist unter anderem von der Netzfrequenz abhängig (siehe Kapitel Grundlagen zur Funktion).


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Fehlerbehebung
•
Messfehler durch Eingangsübersteuerung
•
Messfehler bei Gleichspannungsmessung
•
Support und Service


Fehlerbehebung

Anhang [image] Fehlerbehebung
Fehlerbehebung
Die folgende Tabelle zeigt typische Fehler und ihre Behebung.
Fehler
Ursache
Abhilfe
Die KL3403 zeigt negative Leistungsaufnahme an obwohl ein Verbraucher angeschlossen ist.
▪
Ein oder mehrere Strompfade sind verkehrt herum angeschlossen.
▪
Strom und Spannungspfade sind nicht korrespondierend angeschlossen. Beispiel: die Phase L1 ist am Spannungspfad für L1 (Klemmstelle 1) angeschlossen, der an der Phase L1 angeschlossenen Stromwandler aber an IL2 (Klemmstelle 6).
Überprüfen Sie die Verdrahtung!
Ein vorgeschalteter Fehlerstromschutzschalter löst aus.
Eine Phase ist auf den Nulleiter geschaltet.
Überprüfen Sie die Verdrahtung!
Sie möchten Gleichstrom messen, die KL3403 zeigt aber keine sinnvollen Werte an.
Die DC-Filter der KL3403 sind eingeschaltet (Auslieferungszustand).
Schalten Sie die DC-Filter der KL3403 (unter Verwendung der Konfigurationssoftware KS2000 oder der Registerkommunikation (Register R32.4) ab) um Gleichspannung und Gleichstrom messen zu können.
Bei großen Strömen treten Mess-Ungenauigkeiten auf.
Die Stromeingänge der Klemme werden übersteuert (siehe Kapitel Messfehler durch Eingangsübersteuerung).
▪
Verwenden Sie einen Klemmentyp mit höherem Nennstrom (z. B. KL3403-0010)
▪
Verwenden Sie Stromwandler mit einem größeren Übersetzungsverhältnis.
Bei Messung von kleinen Gleichspannungen treten Mess-Ungenauigkeiten auf.
Die Spannungseingänge der KL3403 weisen im Bereich von 10 bis 20 V eine kleine Nichtlinearität auf (siehe Kapitel Messfehler bei Gleichspannungsmessung).


Messfehler durch Eingangsübersteuerung

Anhang [image] Messfehler durch Eingangsübersteuerung
Messfehler durch Eingangsübersteuerung
Die verschiedenen Varianten der KL3403 unterscheiden sich nur in der Eingangsbeschaltung. Der Ausgabewert beim Nennwert (Vollaussteuerung) ist für die meisten Varianten gleich (siehe Prozessdaten).
Klemmen-Typ | KL3403-...
 | 0000 | 0010 | 0014* | 0020 | 0022** | 0025 | 0026 | 0333
Nennwert | 1 A | 5 A | 60 mV | 20 mA | 20 mA | 250 mA | 1 A | 333 mV
Ausgabe für Effektivwert bei Nennwert | 1000dez | 1000dez | 25000dez | 1000dez | 4000dez | 1000dez | 1000dez | 1000dez
*) bei KL3403-0014: drei zusätzliche Spannungspfade anstelle der Strompfade: 60 mV zum Anschluss von externen Shunts
**) bei KL3403-0022: drei zusätzliche Strompfade anstelle der Spannungspfade: ebenfalls 20 mA
Verlauf von Strom und Abtastung bei Eingangssignalen innerhalb des zulässigen Messbereichs
Liegen die Eingangswerte für den Strom innerhalb des zulässigen Bereichs, also nicht oberhalb des Nennstroms der Klemme, so wird für jede Stützstelle ein gültiger Messwert (≤ 1414dez) eingelesen.
Verlauf von Strom und Abtastung bei Eingangssignalen innerhalb des zulässigen Messbereichs
Für den Effektivwert des Stromes gibt die Klemme im dargestellten Beispiel (Vollaussteuerung) den Wert 1000dez aus.
Verlauf von Strom und Abtastung bei 20% Übersteuerung
Wenn der Eingangsstrom den Nennstrom der Klemme überschreitet, so gibt die Klemme auch für die Spitzenwerte (die größer sind als Nennstrom mal Wurzel 2) den Wert 1414dez aus. Für diese Stützstellen entsteht ein Messfehler durch Eingangsübersteuerung.
Verlauf von Strom und Abtastung bei 20% Übersteuerung
Für den Effektivwert des Stromes gibt die Klemme im dargestellten Beispiel einen Wert von ca. 1150dez aus. Dieser Wert ist bereits mit einem kleinen Fehler behaftet.
Verlauf von Strom und Abtastung bei 50% Übersteuerung
Je weiter der Eingang übersteuert wird, umso mehr Stützstellen sind mit einem immer größeren Messfehler durch Eingangsübersteuerung behaftet.
Verlauf von Strom und Abtastung bei 50% Übersteuerung
Für den Effektivwert des Stromes gibt die Klemme im dargestellten Beispiel einen Wert von ca. 1250dez aus. Dieser Wert ist mit einem relevanten Fehler behaftet.
Der Messfehler steigt mit dem Grad der Übersteuerung
Mit zunehmender Übersteuerung steigt der aus den Stützstellen berechnete Effektivwert "I" zwar weiterhin mit der Eingangsspannung "î" an, steigt aber nicht mehr linear zum Eingangssignal - der Messfehler "∆" wird schnell größer!
Anstieg des Messfehlers "∆" bei zunehmender Übersteuerung
Die für die Eingangsübersteuerungen von 20% und 50% angegebenen Ausgangswerte sind typische Angaben. Sie können verursacht durch Bauteil-Toleranzen von Klemme zu Klemme differieren.


Messfehler bei Gleichspannungsmessung

Anhang [image] Messfehler bei Gleichspannungsmessung
Messfehler bei Gleichspannungsmessung
Bei der Messung von kleinen Gleichspannungen kann es zu geringen Mess-Ungenauigkeiten kommen, da die Spannungseingänge eine kleine Nichtlinearität aufweisen.
Messfehler bei Gleichspannungsmessung
Dieser stufenartige Einbruch ist ca. 1 bis 2 V groß und tritt typisch zwischen 10 und 20 V auf.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.