KL336x - Oszilloskopklemmen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Beckhoff Identification Code (BIC)


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.2.0
▪
Update Kapitel „Hinweise zum ESD-Schutz“
▪
Kapitel „Beckhoff Identification Code (BIC)“ eingefügt
2.1.0
▪
Sicherheitshinweise neues Layout
▪
Update Technische Daten
▪
Kapitel Hinweise zum ESD Schutz eingefügt
▪
Update Kapitel Anschlusstechnik -> Anschluss
▪
Kapitel Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit eingefügt
▪
Beispielprogramm zum Kapitel Konfigurations-Software KS2000 hinzugefügt
▪
Korrektur im Kapitel Registerübersicht
▪
Update Struktur
2.0.0
▪
Migration
1.1.0
▪
Technische Daten aktualisiert
▪
Montage und Verdrahtung überarbeitet
1.0
▪
Beschreibung der Parametrierung der KL336x mittels KS2000-Software korrigiert (Triggerlogik im Detail)
0.6
▪
Beschreibung der Parametrierung der KL336x mittels KS2000-Software aktualisiert (Triggerlogik im Detail)
0.5
▪
Beschreibung des Prozessabbilds überarbeitet
0.4
▪
Beschreibung von Control- und Status-Byte erweitert
▪
Registerbeschreibung aktualisiert
▪
Englische Version erhältlich
0.3
▪
Anschlusshinweise erweitert
▪
Beschreibung der Parametrierung der KL336x mittels KS2000-Software aktualisiert
▪
Registerbeschreibung aktualisiert
▪
Beschreibung von Control- und Status-Byte überarbeitet
0.2
▪
Anschlusshinweise hinzugefügt
▪
Beschreibung der Parametrierung der KL336x mittels KS2000-Software erweitert
▪
Registerbeschreibung überarbeitet
0.1
▪
erste vorläufige Vorabversion
Firm- und Hardware-Stände
Dokumentation Version | KL3361 |  | KL3362
 | Firmware | Hardware | Firmware | Hardware
2.1.0 | 1D | 05 | 1J | 05
2.0.0 | 1D | 04 | 1J | 04
1.1.0 | 1D | 01 | 1I | 01
1.0 | 1D | 01 | 1F | 01
0.6 09.05.2003 | 1D | 01 | 1D | 01
0.5 11.11.2002 | 1D | 01 | 1D | 01
0.4 18.10.2002 | 1D | 01 | 1D | 01
0.3 23.09.2002 | 1D | 01 | 1D | 01
0.2 09.09.2002 | 1D | 01 | 1D | 01
0.1 23.08.2002 | 1B | 00 | 1D | 01
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: KK YY FF HH | Beispiel mit Ser. Nr.: 35 04 1F 01:
KK - Produktionswoche (Kalenderwoche) | 35 - Produktionswoche 35
YY - Produktionsjahr | 04 - Produktionsjahr 2004
FF - Firmware-Stand | 1F - Firmware-Stand 1F
HH - Hardware-Stand | 01 - Hardware-Stand 01


Beckhoff Identification Code (BIC)

Vorwort [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Allgemein
•
KL3361 - einkanalige Oszilloskop-Klemme
•
Technische Daten der KL3361
•
KL3362 - zweikanalige Oszilloskop-Klemme
•
Technische Daten der KL3362
•
Triggermodule


Allgemein

Produktübersicht [image] Allgemein
Allgemein
Die Oszilloskop-Klemmen KL3361 und KL3362 ermöglichen die dezentrale Vorverarbeitung von Analogen Eingangswerten. Die Eingangswerte werden mit einer Auflösung von 14 Bit digitalisiert und in einen internen Speicher geschrieben. Ein leistungsfähiger Prozessor für die Vorverarbeitung kann die z. B. folgende Werte ermitteln oder überwachen:
▪
Maximalwert einer Aufzeichnung
▪
Minimalwert einer Aufzeichnung
▪
Effektivwert einer Aufzeichnung
▪
arithmetischer Mittelwert einer Aufzeichnung
▪
Spitze-Spitze Wert einer Aufzeichnung
▪
Hüllkurvenüberwachung
▪
Periodendauer
▪
Am häufigsten aufgetretener Wert einer Aufzeichnung
▪
usw.
Das Ergebnis oder die gesamten Messwerte werden zum übergeordneten Automatisierungsgerät transportiert.
Unterstützte Buskoppler
Die Oszilloskop-Klemmen KL3361 und KL3362 werden nicht von allen Buskopplern unterstützt. Zu diesen gehören der BK2000, BK3000, BK3100, BK4000, BK4500, BK5000, BK7500.
KL3361
Einkanalige Oszilloskopklemme für einen Eingangsspannungsbereich von -16 mV bis +16 mV.
Typische Anwendung:
Erfassen und Vorverarbeiten des Differenzsignals von Dehnungsmessstreifen (DMS) in Brückenschaltung.
KL3362
Zweikanalige Oszilloskopklemme für einen Eingangsspannungsbereich von -10 V bis +10 V.
Typische Anwendung:
Erfassen und Vorverarbeiten von Standard-Analogsignalen.


KL3361 - einkanalige Oszilloskop-Klemme

Produktübersicht [image] KL3361 - einkanalige Oszilloskop-Klemme
KL3361 - einkanalige Oszilloskop-Klemme
KL3361
Die analoge Eingangsklemme KL3361 ermöglicht das dezentrale Vorverarbeiten von Analogwerten. Die Eingangswerte werden mit einer Auflösung von 14 Bit digitalisiert und in einen internen Speicher geschrieben. Ein leistungsfähiger Prozessor kann die Werte vorverarbeiten. Grenzwerte, Maximal- und Minimalwerte werden ermittelt oder überwacht. Die KL3361 kann auch eine Hüllkurvenüberwachung durchführen. Ein Trigger startet die zyklischen Vorgänge. Das Ergebnis bzw. die gesamten Messwerte werden zum übergeordneten Automatisierungsgerät transportiert.
Die Versorgungsspannung Uv kann an der Klemme abgegriffen oder extern eingespeist werden. Die Klemme liefert 5 V. Die maximale Eingangsspannung U ist auf 10 V begrenzt.
Bedeutung der LEDs
LED | Nr. | Anzeige
No wire (rot) | A | Diese LED leuchtet, bei Drahtbruch am Triggereingang.
Output (grün) | B | Diese LED leuchtet, wenn der digitale Ausgang gesetzt ist.
Error (rot) | C | In Vorbereitung
Trigger (grün) | D | Diese LED leuchtet, wenn ein Signal am Triggereingang anliegt.
Kontaktbelegung siehe Anschluss der KL3361.


Technische Daten der KL3361

Produktübersicht [image] Technische Daten der KL3361
Technische Daten der KL3361
Einkanalige Oszilloskopklemme, -20 mV bis +20 mV
Technische Daten | KL3361
Anzahl der Eingänge | 1 Analog, 1 Trigger
Signalspannung UIN | -20 mV bis +20 mV
Eingangswiderstand | > 1 MOhm (UIN)
Versorgungsspannung für die Messbrücke UV | 5 VDC, maximal 20 mA
Auflösung | 14 Bit (plus 1 Vorzeichenbit)
Abtastrate (konfigurierbar) | minimal 100 µs, (minimal 10 µs bei Fast-Sampling)
Messfehler (gesamter Messbereich) | ±1% vom Messbereichsendwert
Interner Speicher | 32 kByte
Bitbreite im Eingangsprozessabbild | 2 Datenworte, 1 Control-Byte
Bitbreite im Ausgangsprozessabbild | 2 Datenworte, 1 Status-Byte
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus bei externer Versorgung der Messbrücke | typisch 120 mA
Stromaufnahme aus dem K-Bus bei Versorgung der Messbrücke (4 x 350 Ohm) durch KL3361 | typisch 140 mA
Spannungsfestigkeit | 500 V (Abschirmung, Grundplatte / K-Bus)
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Gewicht | ca. 55 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm
Montage | auf 35 mm Tragschiene nach EN 60715
Einbaulage | beliebig
Schutzart | IP20
Zulassungen | CE, ATEX, cULus


KL3362 - zweikanalige Oszilloskop-Klemme

Produktübersicht [image] KL3362 - zweikanalige Oszilloskop-Klemme
KL3362 - zweikanalige Oszilloskop-Klemme
KL3362
Die analoge Eingangsklemme KL3362 ermöglicht das dezentrale Vorverarbeiten von Analogwerten. Die Eingangswerte werden mit einer Auflösung von 14 Bit digitalisiert und in einen internen Speicher geschrieben. Ein leistungsfähiger Prozessor kann die Werte vorverarbeiten. Grenzwerte, Maximal- und Minimalwerte werden ermittelt oder überwacht. Die KL3362 kann auch eine Hüllkurvenüberwachung durchführen. Ein Trigger startet die zyklischen Vorgänge. Das Ergebnis bzw. die gesamten Messwerte werden zum übergeordneten Automatisierungsgerät transportiert.
Bedeutung der LEDs
LED | Nr. | Anzeige
Error 1 (rot) | A | in Vorbereitung
Output (grün) | B | Diese LED leuchtet, wenn der digitale Ausgang gesetzt ist.
Error 2 (rot) | C | in Vorbereitung
Trigger (grün) | D | Diese LED leuchtet, wenn ein Signal am Triggereingang anliegt.
Kontaktbelegung siehe Anschluss der KL3362.


Technische Daten der KL3362

Produktübersicht [image] Technische Daten der KL3362
Technische Daten der KL3362
Zweikanalige Oszilloskopklemme, -10 V bis +10 V
Technische Daten | KL3362
Anzahl der Eingänge | 2 Analog, 1 Trigger
Signalspannung UIN | -10 V bis +10 V
Eingangswiderstand (IN1-GND, IN2-GND) | > 500 kOhm
Auflösung | 14 Bit (plus 1 Vorzeichenbit)
Abtastrate (konfigurierbar) | minimal 100 µs, (minimal 10 µs bei Fast-Sampling)
Messfehler (gesamter Messbereich) | ±0,5% vom Messbereichsendwert
Interner Speicher | 32 kByte
Bitbreite im Eingangsprozessabbild | je Kanal: 2 Datenworte, 1 Control-Byte
Bitbreite im Ausgangsprozessabbild | je Kanal: 2 Datenworte, 1 Status-Byte
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 120 mA
Spannungsfestigkeit | 500 V (Abschirmung, Grundplatte / K-Bus)
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Gewicht | ca. 55 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm
Montage | auf 35 mm Tragschiene nach EN 60715
Einbaulage | beliebig
Schutzart | IP20
Zulassungen | CE, ATEX, cULus


Triggermodule

Produktübersicht [image] Triggermodule
Triggermodule
Die Oszilloskop-Klemmen haben pro Signalkanal zwei Triggermodule, die über Registersätze konfiguriert werden. Die erste Triggereinheit wird mit den Registern R40 bis R45, die zweite mit den Registern R46 bis R51 konfiguriert.
Als Triggerquelle dienen wahlweise:
▪
ein Ausgangswort der Feldbusse
▪
ein Zeitgeber
▪
die Analogeingänge
▪
der digitale Eingang
▪
bei Triggermodul 2 der Ausgang von Triggermodul 1
Als Triggerereignis kann ausgewählt werden:
▪
steigende oder fallende Flanke (Edge)
▪
ein positiver oder negativer Puls, der größer oder kleiner als eine festgelegte Pulsbreite ist (Glitch)
Die Triggerfreigabe kann erfolgen:
▪
immer, das bedeutet jedes Trigger-Ereignis wird sofort freigegeben
▪
über das Signal an den Analogeingängen oder dem digitalen Eingang (jeweils mit positiver bzw. negativer Logik und entsprechenden Schaltschwellen).
Bei Freigabe des Trigger-Ereignisses können verschiedene Aktionen veranlasst werden:
▪
start der Aufzeichnung
▪
start eines ein Timers (Chronometer)
▪
setzen des digitalen Ausgangs
▪
speichern des aktuellen Timer-Wertes
▪
rücksetzen des Timers
▪
starten eines weiteren Timers, der dem Register Valid Trigger Time zugeordnet ist
Die Triggermodule können kaskadiert werden. Dadurch ist ein äußerst flexibles Triggern auf den Ablauf von Ereignissen möglich. Bei kaskadierten Triggermodulen legt das Register Valid Trigger Time ein Zeitfenster fest, in dem das folgende Triggerereignis eintreffen muss. Passiert dies nicht, so wird alles zurückgesetzt und erneut auf das erste Triggerereignis gewartet.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss
•
Anschluss der KL3361
•
Anschluss der KL3362
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX-Dokumentation


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endklemme KL9010 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Anschluss der KL3361

Montage und Verdrahtung [image] Anschluss der KL3361
Anschluss der KL3361
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschluss der KL3361
Dargestellt ist der Anschluss von vier Dehnungsmessstreifen (DMS) in Brückenschaltung, bei Versorgung der Messbrücke
▪
durch die Oszilloskopklemme (links) oder
▪
aus einer externen Spannungsquelle Uext (rechts).
Klemmstelle | Nr. | Anschluss
+ 24 V | 1 | Versorgungsspannung für digitalen Ausgang
OUT 24 V | 2 | Digitaler Ausgang
UB+ | 3 | Eingang für Differenzspannung der Messbrücke
UV+ | 4 | 5 V Versorgungsspannung für die Dehnungsmessstreifen (DMS) in Brückenschaltung oder Referenzeingang für die externe Versorgungsspannung der Messbrücke
24 V Trigger | 5 | Triggereingang
0V | 6 | Masse für Triggereingang
UB- | 7 | Eingang für Differenzspannung der Messbrücke
UV- | 8 | 0 V Versorgungsspannung für die Dehnungsmessstreifen (DMS) in Brückenschaltung oder Referenzeingang für die externe Versorgungsspannung der Messbrücke
Versorgung der Messbrücke durch KL3361
Dimensionieren Sie den Gesamtwiderstand der Messbrücke so, dass der Strom, den die Oszilloskopklemme an den Klemmen UV+ und UV- zur Verfügung stellen muss in allen Betriebsfällen 20 mA nicht überschreitet.
Versorgung der Messbrücke aus externer Spannungsquelle
Beachten Sie bei Versorgung der Messbrücke aus einer externen Spannungsquelle folgendes:
Die externe Versorgungsspannung
▪
muss zur Referenz auch an die Anschlüsse UV+ und UV- angelegt werden.
▪
darf nur im Bereich von +5 V bis +10 V liegen.
▪
darf im Betrieb maximal um ±5% schwanken.
Schwankungen der externen Versorgungsspannung vergrößern den Messfehler!
Nach Änderung der externen Versorgungsspannung muss die Oszilloskopklemme zum Neuabgleich neu gestartet werden!
Die interne Spannungsquelle schaltet automatisch ab, sobald von außen eine Spannung von über 5 V an die Klemmen UV+ und UV- der Oszilloskopklemme angelegt wird.


Anschluss der KL3362

Montage und Verdrahtung [image] Anschluss der KL3362
Anschluss der KL3362
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschluss der KL3362
Dargestellt ist der Anschluss von zwei Funktionsgeneratoren (FG1, FG2) an den Kanälen der Oszilloskopklemme KL3362.
Klemmstelle | Nr. | Anschluss
+ 24V | 1 | Versorgungsspannung für digitalen Ausgang
OUT 24V | 2 | Digitaler Ausgang
IN 1 | 3 | Oszilloskopeingang Kanal 1 ( -10 V bis +10 V)
GND | 4 | Masse für Oszilloskopeingang Kanal 1(intern verbunden mit Klemme Nr. 8)
24V Trigger | 5 | Triggereingang
0V | 6 | Masse für Triggereingang
IN 2 | 7 | Oszilloskopeingang Kanal 2 ( -10 V bis +10 V)
GND | 8 | Masse für Oszilloskopeingang Kanal 2 (intern verbunden mit Klemme Nr. 4)


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Masken für KL3361
•
Masken für KL3362
•
Einstellungen im Detail
•
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Buskoppler für Ethernet BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine Oszilloskopklemme KL3661
▪
eine Busendklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).
KS2000-Baumzweig für Kanal 1 der KL3681
Klicken Sie auf Einstellungen. Nun können Sie die Einstellungen der Oszilloskopklemme verändern.
KL3361:
▪
Triggerlogik
▪
Betriebsart und Triggerwerte
▪
Prozessdaten
KL3362:
▪
Triggerlogik
▪
Triggerwerte
▪
Betriebsart
▪
Prozessdaten


Masken für KL3361

Konfigurations-Software KS2000 [image] Masken für KL3361
Masken für KL3361
Weiterführende Informationen
•
Triggerlogik für KL3361
•
Triggerwerte für KL3361
•
Prozessdaten für KL3361


Triggerlogik für KL3361

Konfigurations-Software KS2000 [image] Masken für KL3361 [image] Triggerlogik für KL3361
Triggerlogik für KL3361
In der Registerlasche Triggerlogik können Sie das Trigger-Verhalten der Oszilloskopklemme KL3361 einstellen.
Triggerlogik für KL3361
▪
Quelle
Hier können Sie die Triggerquelle auswählen (siehe Triggerlogik im Detail).
▪
Ereignis
Hier können Sie das Triggerereignis festlegen (siehe Triggerlogik im Detail).
▪
Freigabe
Verbinden Sie den unteren Eingang des Und-Gatters mit der gewünschten Funktion um festzulegen, wann das Und-Gatter einen Triggerimpuls durchschalten soll (siehe Triggerlogik im Detail).
▪
Aktion
Verbinden Sie den Ausgang des Und-Gatters mit der gewünschten Funktion um festzulegen, welche Aktion im Triggerfall ausgelöst werden soll (siehe Triggerlogik im Detail).


Triggerwerte für KL3361

Konfigurations-Software KS2000 [image] Masken für KL3361 [image] Triggerwerte für KL3361
Triggerwerte für KL3361
In der Registerlasche Triggerwerte können Sie die Betriebsart, die Skalierung sowie die Schaltschwellen, die Pulsbreite und die gültige Triggerzeit für die beiden Triggermodule der Oszilloskopklemme KL3361 einstellen.
Triggerwerte für KL3361
▪
Betriebsart
Legen Sie hier die Triggerart fest (siehe allgemeine Einstellungen im Detail).
▪
Allgemein
Legen Sie hier die allgemeinen Triggereinstellungen fest (siehe allgemeine Einstellungen im Detail).
▪
Skalierung
Legen Sie hier die Skalierung fest (siehe allgemeine Einstellungen im Detail).
▪
Triggermodul 1
Legen Sie hier die Triggerwerte für Triggermodul 1 fest (siehe Triggerwerte im Detail).
▪
Triggermodul 2
Legen Sie hier die Triggerwerte für Triggermodul 2 fest (siehe Triggerwerte im Detail).


Prozessdaten für KL3361

Konfigurations-Software KS2000 [image] Masken für KL3361 [image] Prozessdaten für KL3361
Prozessdaten für KL3361
In der Registerlasche Prozessdaten können Sie Einstellen, welche Daten in das Prozessabbild der Oszilloskopklemme KL3361 eingeblendet werden.
Prozessdaten für KL3361
Ausgangsprozessabbild
▪
Datenwort 0
Wählen Sie hier für das Triggermodul 1 aus, welchen Trigger-Parameter Sie mit dem Datenwort 0 (DataOUT0) der KL3361 vorgeben wollen (siehe Ausgangsprozessdaten im Detail).
▪
Datenwort 1
Wählen Sie hier für das Triggermodul 2 aus, welchen Trigger-Parameter Sie mit dem Datenwort 1 (DataOUT1) der KL3361 vorgeben wollen (siehe Ausgangsprozessdaten im Detail).
Eingangsprozessabbild
▪
Datenwort 0
Wählen Sie hier aus, welcher Eingangswert mit dem Datenwort 0 (DataIN0) von der KL3361 zur Steuerung übertragen wird (siehe Eingangsprozessdaten im Detail).
▪
Datenwort 1
Wählen Sie hier aus, welcher Eingangswert mit dem Datenwort 1 (DataIN1) von der KL3361 zur Steuerung übertragen wird (siehe Eingangsprozessdaten im Detail).


Masken für KL3362

Konfigurations-Software KS2000 [image] Masken für KL3362
Masken für KL3362
Weiterführende Informationen
•
Triggerlogik für KL3362
•
Allgemeine Einstellungen für KL3362
•
Triggerwerte für KL3362
•
Prozessdaten für KL3362


Triggerlogik für KL3362

Konfigurations-Software KS2000 [image] Masken für KL3362 [image] Triggerlogik für KL3362
Triggerlogik für KL3362
In der Registerlasche Triggerlogik können Sie das Trigger-Verhalten der Oszilloskopklemme KL3362 einstellen.
Triggerlogik für KL3362
▪
Quelle
Hier können Sie die Triggerquelle auswählen (siehe Triggerlogik im Detail).
▪
Ereignis
Hier können Sie das Triggerereignis festlegen (siehe Triggerlogik im Detail).
▪
Freigabe
Verbinden Sie den unteren Eingang des Und-Gatters mit der gewünschten Funktion um festzulegen, wann das Und-Gatter einen Triggerimpuls durchschalten soll (siehe Triggerlogik im Detail).
▪
Aktion
Verbinden Sie den Ausgang des Und-Gatters mit der gewünschten Funktion um festzulegen, welche Aktion im Triggerfall ausgelöst werden soll (siehe Triggerlogik im Detail).


Allgemeine Einstellungen für KL3362

Konfigurations-Software KS2000 [image] Masken für KL3362 [image] Allgemeine Einstellungen für KL3362
Allgemeine Einstellungen für KL3362
In der Registerlasche allgemeine Einstellungen können Sie die Betriebsart, allgemeine Einstellungen und die die Skalierung beider Kanäle der Oszilloskopklemme KL3362 einstellen.
Allgemeine Einstellungen für KL3362
▪
Betriebsart
Legen Sie hier die Triggerart fest (siehe allgemeine Einstellungen im Detail).
▪
Allgemein
Legen Sie hier die allgemeinen Triggereinstellungen fest (siehe allgemeine Einstellungen im Detail).
▪
Skalierung Kanal 1
Legen Sie hier die Skalierung für Kanal 1 fest (siehe allgemeine Einstellungen im Detail).
▪
Skalierung Kanal 2
Legen Sie hier die Skalierung für Kanal 2 fest (siehe allgemeine Einstellungen im Detail).


Triggerwerte für KL3362

Konfigurations-Software KS2000 [image] Masken für KL3362 [image] Triggerwerte für KL3362
Triggerwerte für KL3362
In der Registerlasche Triggerwerte können Sie die Schaltschwellen, die Pulsbreite und die gültige Triggerzeit für die vier Triggermodule der Oszilloskopklemme KL3362 einstellen.
Triggerwerte für KL3362
▪
Triggermodul 1
Legen Sie hier die Triggerwerte für Triggermodul 1 fest (siehe Triggerwerte im Detail).
▪
Triggermodul 2
Legen Sie hier die Triggerwerte für Triggermodul 2 fest (siehe Triggerwerte im Detail).
▪
Triggermodul 3
Legen Sie hier die Triggerwerte für Triggermodul 3 fest (siehe Triggerwerte im Detail).
▪
Triggermodul 4
Legen Sie hier die Triggerwerte für Triggermodul 4 fest (siehe Triggerwerte im Detail).


Prozessdaten für KL3362

Konfigurations-Software KS2000 [image] Masken für KL3362 [image] Prozessdaten für KL3362
Prozessdaten für KL3362
In der Registerlasche Prozessdaten können Sie Einstellen, welche Daten in das Prozessabbild der Oszilloskopklemme KL3362 eingeblendet werden.
Prozessdaten für KL3362
Ausgangsprozessabbild
▪
Datenwort 0
Wählen Sie hier für das Triggermodul 1 aus, welchen Trigger-Parameter Sie mit dem Datenwort 0 (DataOUT0, Kanal 1) der KL3362 vorgeben wollen (siehe Ausgangsprozessdaten im Detail).
▪
Datenwort 1
Wählen Sie hier für das Triggermodul 2 aus, welchen Trigger-Parameter Sie mit dem Datenwort 1 (DataOUT1, Kanal 1) der KL3362 vorgeben wollen (siehe Ausgangsprozessdaten im Detail).
▪
Datenwort 2
Wählen Sie hier für das Triggermodul 3 aus, welchen Trigger-Parameter Sie mit dem Datenwort 2 (DataOUT0, Kanal 2) der KL3362 vorgeben wollen (siehe Ausgangsprozessdaten im Detail).
▪
Datenwort 3
Wählen Sie hier für das Triggermodul 4 aus, welchen Trigger-Parameter Sie mit dem Datenwort 3 (DataOUT1, Kanal 2) der KL3362 vorgeben wollen (siehe Ausgangsprozessdaten im Detail).
Eingangsprozessabbild
▪
Datenwort 0
Wählen Sie hier aus, welcher Eingangswert mit dem Datenwort 0 (DataIN0, channel 1) von der KL3362 zur Steuerung übertragen wird (siehe Eingangsprozessdaten im Detail).
▪
Datenwort 1
Wählen Sie hier aus, welcher Eingangswert mit dem Datenwort 1 (DataIN1, channel 1) von der KL3362 zur Steuerung übertragen wird (siehe Eingangsprozessdaten im Detail).
▪
Datenwort 2
Wählen Sie hier aus, welcher Eingangswert mit dem Datenwort 2 (DataIN0, channel 2) von der KL3362 zur Steuerung übertragen wird (siehe Eingangsprozessdaten im Detail).
▪
Datenwort 3
Wählen Sie hier aus, welcher Eingangswert mit dem Datenwort 3 (DataIN1, channel 2) von der KL3362 zur Steuerung übertragen wird (siehe Eingangsprozessdaten im Detail).


Einstellungen im Detail

Konfigurations-Software KS2000 [image] Einstellungen im Detail
Einstellungen im Detail
Weiterführende Informationen
•
Triggerlogik
•
Allgemeine Einstellungen
•
Triggerwerte
•
Ausgangsprozessdaten
•
Eingangsprozessdaten


Triggerlogik

Konfigurations-Software KS2000 [image] Einstellungen im Detail [image] Triggerlogik
Triggerlogik
Quelle
Sie können hier eine der folgenden Triggerquellen (R40) auswählen:
 | Shot | Der Triggerimpuls wird über ein Kontrollwort vom Feldbus ausgelöst.
 | Zeitgeber | Der Triggerimpuls wird in gleichmäßigen Abständen von einem Zeitgeber ausgelöst. Die Frequenz des Zeitgebers können Sie unter allgemeine Triggereinstellungen vorgeben.
 | Digitaler Eingang | Der Triggerimpuls wird vom Triggereingang (24 V Trigger) ausgelöst.
 | Analoger Eingang 1 | Der Triggerimpuls wird vom analogen Eingang 1 ausgelöst.
(nur KL3362) | Analoger Eingang 2 | Der Triggerimpuls wird vom analogen Eingang 2 ausgelöst.
Ereignis
Sie können hier das Ereignis (R40) festlegen, das den Trigger auslöst.
Steigende Flanke (default) | Das Triggermodul triggert auf die steigende Flanke des Eingangssignals. Die zugehörige Schaltschwelle können Sie auf der Registerlache Triggerwerte festlegen.
Fallende Flanke | Das Triggermodul triggert auf die fallende Flanke des Eingangssignals. Die zugehörige Schaltschwelle können Sie auf der Registerlache Triggerwerte festlegen.
positiver Puls länger als eingestellte Pulsbreite | Das Triggermodul triggert wenn die positive Pulsbreite länger als die konfigurierte Pulsbreite ist, die Sie auf der Registerlasche Triggerwerte festlegen können.
positiver Puls kürzer als eingestellte Pulsbreite | Die Trigger Unit triggert, wenn die positive Pulsbreite kürzer als die konfigurierte Pulsbreite ist, die Sie auf der Registerlasche Triggerwerte festlegen können.
negativer Puls länger als eingestellte Pulsbreite | Das Triggermodul triggert, wenn die negative Pulsbreite länger als die konfigurierte Pulsbreite ist, die Sie auf der Registerlasche Triggerwerte festlegen können.
negativer Puls kürzer als eingestellte Pulsbreite | Das Triggermodul triggert, wenn die negative Pulsbreite kürzer als die konfigurierte Pulsbreite ist, die Sie auf der Registerlasche Triggerwerte festlegen können.
Freigabe
Verbinden Sie den unteren Eingang des Und-Gatters mit der gewünschten Funktion um festzulegen, wann das Und-Gatter einen Triggerimpuls durchschalten soll (R40).
 | immer freigegeben | Der Triggerimpuls wird immer durchgeschaltet.
 | digitaler Eingang High | Der Triggerimpuls wird durchgeschaltet, falls der Triggereingang (24 V Trigger) der Oszilloskopklemme auf High-Potential liegt.
 | analoger Eingang 1 über Schaltschwelle | Der Triggerimpuls wird durchgeschaltet, falls das Signal am analogen Eingang 1 der Oszilloskopklemme über die festgelegte Schaltschwelle 2 steigt. Die Schaltschwelle können sie auf der Registerlasche Triggerwerte festlegen.
(nur KL3362) | analoger Eingang 2 über Schaltschwelle | Der Triggerimpuls wird durchgeschaltet, falls das Signal am analogen Eingang 2 der Oszilloskopklemme über die festgelegte Schaltschwelle 2 steigt. Die Schaltschwelle können sie auf der Registerlasche Triggerwerte festlegen.
 | digitaler Eingang Low | Der Triggerimpuls wird durchgeschaltet, falls der Triggereingang (24 V Trigger) der Oszilloskopklemme auf Low-Potential liegt.
 | analoger Eingang 1 unter Schaltschwelle | Der Triggerimpuls wird durchgeschaltet, falls das Signal am analogen Eingang 1 der Oszilloskopklemme unter die festgelegte Schaltschwelle 2 fällt. Die Schaltschwelle können sie auf der Registerlasche Triggerwerte festlegen.
(nur KL3362) | analoger Eingang 2 unter Schaltschwelle | Der Triggerimpuls wird durchgeschaltet, falls das Signal am analogen Eingang 2 der Oszilloskopklemme unter die festgelegte Schaltschwelle 2 fällt. Die Schaltschwelle können sie auf der Registerlasche Triggerwerte festlegen.
Aktion
Verbinden Sie den Ausgang des Und-Gatters mit der gewünschten Funktion um festzulegen, welche Aktion im Triggerfall ausgelöst werden soll.
 | Timer (Chronometer) auf Null setzen (R40.2) | Setzt den Timer auf Null zurück. Der Timer läuft daraufhin sofort automatisch wieder los.
 | Timer (Chronometer) speichern (R40.3) | Speichert den zum Triggerzeitpunkt aktuellen Wert des laufenden Timers.
 | Digitalen Ausgang Setzen (R40.4) | Setzt den digitalen Ausgang, z. B. zu den synchronen Triggern des zweiten Oszilloskop-Kanals einer KL3362. Diese Funktion muss mit Bit 2 des Control-Bytes 1 (CB1.2) freigegeben werden.
 | Aufzeichnung starten (R40.5) | Starten der Aufzeichnung
 | Triggermodul 2 freischalten (R40.5) | Wenn sie den Ausgang des Und-Gatters in Triggermodul 1 mit der Funktion Enable Trigger 2 verbinden, wird das Triggersignal an das Triggermodul 2 weitergegeben, das Sie zur Parametrierung über die Schaltfläche Modul 2 im Feld Auswahl erreichen können.
(nur KL3362) | Triggermodul 3 freischalten (R40.5) | Wenn sie den Ausgang des Und-Gatters in Triggermodul 2 mit der Funktion Enable Trigger 3 verbinden, wird das Triggersignal an das Triggermodul 3 weitergegeben, das Sie zur Parametrierung über die Schaltfläche Modul 3 im Feld Auswahl erreichen können.
(nur KL3362) | Triggermodul 4 freischalten (R40.5) | Wenn sie den Ausgang des Und-Gatters in Triggermodul 3 mit der Funktion Enable Trigger 4 verbinden, wird das Triggersignal an das Triggermodul 4 weitergegeben, das Sie zur Parametrierung über die Schaltfläche Modul 4 im Feld Auswahl erreichen können.


Allgemeine Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen im Detail [image] Allgemeine Einstellungen
Allgemeine Einstellungen
Betriebsart
Pre-Trigger (R32.8-10)
Es wird bis zum Eintreten des Triggerereignisses aufgezeichnet.
Mid-Trigger (R32.8-10)
Das Triggerereignis ist das Zentrum der Aufzeichnung.
Post-Trigger (R32.8-10)
default
Es wird ab dem Eintreten des Triggerereignisses aufgezeichnet.
Fast-Sampling (R32.8-10)
Betrieb mit erhöhter Abtastrate von bis zu 10 µs:
▪
Die Aufzeichnung kann nur über den Triggereingang gestartet werden.
▪
Die Einstellungen der Triggermodule werden nicht berücksichtigt.
▪
Auch bei KL3362 wird nur der erste Kanal aufgezeichnet.
Triggerverzögerung aktiv (R32.4)
default: nicht aktiviert
Schaltet die Triggerverzögerung ein.
Triggerverzögerung (R52)
default: 0
Hier können Sie eine Triggerverzögerung (tTD) festlegen. Als Parameter wird die Anzahl der übergangenen Samples (nSTD) eingetragen. Die Triggerverzögerung ist somit abhängig von der Sample Rate! Beispiel:
- Sample Rate: Ts = 200 µs
- übergangene Samples: nSTD=100
tTD = Ts x nSTD = 200 µs x 100 = 20 ms
Testmodus aktiv (R32.5)
default: nicht aktiviert
Schaltet den Testmodus ein. Im Testmodus wird anstelle von gewandelten analogwerten eine Rampe ausgegeben, die von 0 bis 0x3FFF und wieder auf zurück läuft.
Autotrigger aktiv (R32.6)
default: nicht aktiviert
Schaltet die Funktion Autotrigger ein. Bei eingeschaltetem Autotrigger wird die Triggereinheit automatisch nach der Auswertung des vorhergehenden Ereignisses aktiviert. Dazu wird mit jeder neuen Auswertung im Statusregister 1 (SR1) das Bit 0 getoggelt.
Allgemein
Sample-Rate (R35)
default: 200 µs
Abstand (Ts) zweier Samples (Abtastungen) in Mikrosekunden.
Die Abtastgeschwindigkeit ist durch die Auswertung der Trigger-Detektoren auf Ts =100 µs (10 kHz) beschränkt.
Nur im Modus kann mit Ts=10 µs (100 kHz) abgetastet werden.
Sample-Amount ( )
default: 100
Anzahl der aufzuzeichnenden Abtastwerte. Es können maximal 4000 Werte aufgezeichnet werden.
Triggerfrequenz (R56)
default: 0
Hier können Sie die Triggerfrequenz des Zeitgebers vorgeben.
Skalierung Kanal 1
Anwender-Offset (R33) default: 0 | Hier können Sie einen Offset eingeben. Skalierung: Offset = Messbereichsendwert x Parameter / Auflösung Beispiel für KL3361: 16 mV x 100 / 32767 = 0,049 mV
Anwender-Gain (R34) default: 256 | Hier können Sie den Verstärkungsfaktor eingeben um den Eingangswert um diesen Faktor zu skalieren.
Skalierung Kanal 2 (nur KL3362)
Anwender-Offset (R33) default: 0 | Hier können Sie einen Offset eingeben. Skalierung: Offset = Messbereichsendwert x Parameter / Auflösung Beispiel für KL3361: 16 mV x 100 / 32767 = 0,049 mV
Anwender-Gain (R34) default: 256 | Hier können Sie den Verstärkungsfaktor eingeben um den Eingangswert um diesen Faktor zu skalieren.


Triggerwerte

Konfigurations-Software KS2000 [image] Einstellungen im Detail [image] Triggerwerte
Triggerwerte
Triggermodul 1
Schaltschwelle 1 (R41) default: 1000 | Legen Sie hier die Schaltschwelle für die Triggerquelle des Triggermoduls 1 fest. Skalierung: Schwellwert = Messbereichsendwert x Parameter / Auflösung Beispiel für KL3361: 16 mV x 1000 / 32767 = 0,488 mV
Schaltschwelle 2 (R42) default: 1000 | Legen Sie hier die Schaltschwelle für die Triggerfreigabe des Triggermoduls 1 fest. Skalierung: siehe Schaltschwelle 1.
Pulsbreite (R43) default: 100 | Legen Sie hier die Pulsbreite (tP) des Triggermoduls 1 für den Glitch-Mode fest. Als Parameter wird die Anzahl der Samples (nSP) eingetragen. Die Pulsbreite ist somit abhängig von der Sample Rate! Beispiel: - Sample Rate: Ts = 200 µs - Samples: nSP = 100 Pulsbreite : tP = Ts x nSP = 200 µs x 100 = 20 ms
gültige Triggerzeit (R44) default: 100 | Legen Sie hier die gültige Triggerzeit (tVT) für das Triggermodul 1 fest. Als Parameter wird die Anzahl der gültigen Samples (nVS) eingetragen. Die gültige Triggerzeit ist somit abhängig von der Sample Rate! Beispiel: - Sample Rate: Ts = 200 µs - gültige Samples: nVS=100 gütige Triggerzeit: tVT = Ts x nVS =200 µs x 100 = 20 ms
Zeitfenster aktiv (R40.6) default: nicht aktiviert | Hier können Sie das Zeitfenster für das Triggermodul 1 einschalten.
Triggermodul 2
Schaltschwelle 1 (R47) default: 1000 | Legen Sie hier die Schaltschwelle für die Triggerquelle des Triggermoduls 2 fest. Skalierung: siehe Triggermodul 1
Schaltschwelle 2 (R48) default: 1000 | Legen Sie hier die Schaltschwelle für die Triggerfreigabe des Triggermoduls 2 fest. Skalierung: siehe Triggermodul 1
Pulsbreite (R49) default: 100 | Legen Sie hier die Pulsbreite für das Triggermodul 2 fest. Skalierung: siehe Triggermodul 1
gültige Triggerzeit (R50) default: 100 | Legen Sie hier die gültige Triggerzeit für das Triggermodul 2 fest. Skalierung: siehe Triggermodul 1
Zeitfenster aktiv (R46) default: nicht aktiviert | Hier können Sie das Zeitfenster für das Triggermodul 2 einschalten.
Triggermodul 3 (nur KL3362)
Siehe Triggermodul 1.
Triggermodul 4 (nur KL3362)
Siehe Triggermodul 2.


Ausgangsprozessdaten

Konfigurations-Software KS2000 [image] Einstellungen im Detail [image] Ausgangsprozessdaten
Ausgangsprozessdaten
Ausgangsprozessdaten im Detail
Datenwort 0
Wählen Sie hier für das Triggermodul 1 aus, welchen Trigger-Parameter Sie mit Datenwort 0 der Oszilloskopklemme vorgeben wollen.
Schaltschwelle 1 | Schaltschwelle 1 des Triggermoduls 1
Schaltschwelle 2 | Schaltschwelle 2 des Triggermoduls 1
Pulsbreite | Pulsbreite des Triggermoduls 1
gütige Triggerzeit | Gültige Triggerzeit des Triggermoduls 1
keine Vorgabe | Keine Vorgabe von Parametern.
Datenwort 1
Wählen Sie hier für das Triggermodul 2 aus, welchen Trigger-Parameter Sie mit Datenwort 1 der Oszilloskopklemme vorgeben wollen.
Schaltschwelle 1 | Schaltschwelle 1 des Triggermoduls 2
Schaltschwelle 2 | Schaltschwelle 2 des Triggermoduls 2
Pulsbreite | Pulsbreite des Triggermoduls 2
gütige Triggerzeit | Gültige Triggerzeit des Triggermoduls 2
keine Vorgabe | Keine Vorgabe von Parametern.
Datenwort 2 (nur KL3362)
Wählen Sie hier für das Triggermodul 3 aus, welchen Trigger-Parameter Sie mit Datenwort 2 der Oszilloskopklemme vorgeben wollen (Trigger-Parameter siehe Datenwort 0).
Datenwort 3 (nur KL3362)
Wählen Sie hier für das Triggermodul 4 aus, welchen Trigger-Parameter Sie mit Datenwort 3 der Oszilloskopklemme vorgeben wollen (Trigger-Parameter siehe Datenwort 1).


Eingangsprozessdaten

Konfigurations-Software KS2000 [image] Einstellungen im Detail [image] Eingangsprozessdaten
Eingangsprozessdaten
Eingangsprozessdaten im Detail
Datenwort 0
Wählen Sie hier aus, welcher Eingangswert mit dem Datenwort 0 von der Oszilloskopklemme zur Steuerung übertragen wird.
Auswahl des Eingangswertes für Datenwort 0
Eingangswert
Kommentar
aktueller Messwert
aktueller Analogwert
Maximalwert
Maximalwert einer Aufzeichnung
Minimalwert
Minimalwert einer Aufzeichnung
Effektivwert
Effektivwert einer Aufzeichnung: Sqrt((Summe(xn2))/n
Mittelwert
arithmetischer Mittelwert einer Aufzeichnung: (Summe (xn))/n
Spitze-Spitze Wert
Spitze-Spitze Wert einer Aufzeichnung
Periodendauer
Periodendauer einer Aufzeichnung
Pulsbreite HIGH
▪
zum Start müssen vier aufeinanderfolgende Werte über der Schaltschwelle liegen
▪
zum Stop müssen vier aufeinanderfolgende Werte unter der Schaltschwelle liegen
Pulsbreite LOW
▪
zum Start müssen vier aufeinanderfolgende Werte über der Schaltschwelle liegen
▪
zum Stop müssen vier aufeinanderfolgende Werte unter der Schaltschwelle liegen
Tastverhältnis
Tastverhältnis
Jitter Tmax
reserviert
Jitter Tmin
reserviert
Jitter Tmittel
reserviert
Histogramm Max
Am häufigsten aufgetretener Wert einer Aufzeichnung
eingelesener Wert Timer 1
gespeichert Wert des Timers (Chronometer) aus Triggermodul 1*
*) bei KL3362 auch Triggermodul 3 (über Datenwort 2 oder 3)
aktueller Wert Timer 1
aktueller Wert des des Timers (Chronometer) aus Triggermodul 1*
eingelesener Wert Timer 2
gespeichert Wert des Timers (Chronometer) aus Triggermodul 2**
**) bei KL3362 auch Triggermodul 4 (über Datenwort 2 oder 3)
aktueller Wert Timer 2
aktueller Wert des Timers (Chronometer) aus Triggermodul 2**
Fehlerzähler innere Hüllkurve
Fehlerzähler der inneren Hüllkurve
Fehlerzähler äußere Hüllkurve
Fehlerzähler der äußeren Hüllkurve
Anzahl Samples bis Analogwert größer als Schaltschwelle
Anzahl zu dem Zeitpunkt aufgenommenen Messpunkte, als der Analogwert die Schaltschwelle überschritt.
Anzahl Samples bis Analogwert kleiner als Schaltschwelle
Anzahl zu dem Zeitpunkt aufgenommenen Messpunkte, als der Analogwert die Schaltschwelle unterschritt.
Datenwort 1
Wählen Sie hier aus, welcher Eingangswert mit dem Datenwort 1 von der Oszilloskopklemme zur Steuerung übertragen wird.
Auswahl des Eingangswertes für Datenwort 1
(Eingangswerte siehe Datenwort 0).
Datenwort 2 (nur KL3362)
Wählen Sie hier aus, welcher Eingangswert mit dem Datenwort 2 von der Oszilloskopklemme zur Steuerung übertragen wird.
Auswahl des Eingangswertes für Datenwort 2 (nur KL3362)
(Eingangswerte siehe Datenwort 0).
Datenwort 3 (nur KL3362)
Wählen Sie hier aus, welcher Eingangswert mit dem Datenwort 3 von der Oszilloskopklemme zur Steuerung übertragen wird.
Auswahl des Eingangswertes für Datenwort 3 (nur KL3362)
(Eingangswerte siehe Datenwort 0).


Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314

Konfigurations-Software KS2000 [image] Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Anwenders zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Programmbeschreibung/ Funktion
Dieses Beispielprogramm (TwinCAT 3) erlaubt per AoE die Änderung einzelner Registerwerte der KL3314 wie die Auswahl des Element-Typs und charakteristische Einstellungen des Feature‑Registers R32 sowie die Anwenderskalierung Offset und Gain (R33/ R34) ähnlich wie per KS2000.
Einstellungen der KL3314 über die Visualisierung von TwinCAT 3
Es sollte mindestens die folgende Konfiguration vorhanden sein:
[Koppler (z.B. BK1120) oder embedded PC] + KL3314 + KL9010.
Download:
Vorbereitungen zum Starten des Beispielprogramms (tnzip - Datei/ TwinCAT 3)
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.tnzip -Archivdatei in einem temporären Ordner.
Öffnen des *. tnzip - Archives
▪
Wählen Sie die zuvor entpackte .tnzip Datei (Beispielprogramm) aus.
▪
Ein weiteres Auswahlfenster öffnet sich: wählen nun Sie das Zielverzeichnis, wo das Projekt gespeichert werden soll.
▪
Die generelle Vorgehensweise für die Inbetriebnahme der PLC bzw. dem Start des Programms kann u.a. den Klemmen‑Dokumentationen oder der EtherCAT‑Systemdokumentation entnommen werden.
▪
Das EtherCAT Gerät im Beispiel ist i.d.R. zuvor ihrem vorliegenden System bekannt zu machen. Verwenden Sie nach Auswahl des EtherCAT Gerätes im „Projektmappen-Explorer“ rechtsseitig den Karteireiter „Adapter“ und Klicken „Suchen...“:
Suche der bestehenden HW-Konfiguration zur bestehenden EtherCAT-Konfiguration
▪
Überprüfen der NetId: der Karteireiter „EtherCAT“ des EtherCAT Gerätes zeigt die konfigurierte NetId: .
Diese muss mit den ersten vier Zahlenwerten mit der Projekt‑NetId des Zielsystems übereinstimmen. Die NetId des Projektes kann oben in einem Textfeld der TwinCAT-Umgebung eingesehen werden. Ein pull-down Menü kann durch einen Klick rechts im Textfeld geöffnet werden; dort ist zu jeden Rechnernamen eines Zielsystems die NetId in Klammern angegeben.
▪
Ändern der NetId: mit einem Rechtsklick auf „Gerät EtherCAT“ im Projektmappen-Explorer öffnet sich das Kontextmenü, in dem „Ändern der NetId“ auszuwählen ist. Die ersten vier Zahlen der NetId des Projektes sind einzutragen. die beiden letzten Werte sind i.d.R. 4.1.
Beispiel:
–
NetId des Projektes: myComputer (123.45.67.89.1.1)
–
Eintrag per „Change NetId...“: 123.45.67.89.4.1


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Über die beiden Index-Register R38 und R39 können Sie festlegen, welche Prozessdaten der Oszilloskopklemme
▪
KL3361 mit den Registern DataIN11 und DataIN12
▪
KL3362 mit den Registern DataIN11 und DataIN12 (Kanal 1) oder DataIN21 und DataIN22 (Kanal 2)
zyklisch zur Steuerung übertragen werden. So können wahlweise Maximalwerte, Minimalwerte, Effektivwerte, Mittelwerte, einzelne Abtastwerte (Sample n nach Triggerereignis), Anstiegszeiten, Pulsbreiten usw. direkt in den Prozessdaten dargestellt werden.
Über das Index-Register R37 können Sie festlegen, welche Parameter der Oszilloskopklemme
▪
KL3361 mit den Registern DataOUT11 und DataOUT12
▪
KL3362 mit den Registern DataOUT11 und DataOUT12 (Kanal 1) oder DataOUT21 und DataOUT22 (Kanal 2)
zyklisch übertragen werden. So können Sie wahlweise Schaltschwellen, Pulsbreiten usw. über den Prozessdatenkanal vorgeben.
Auswertung einer Aufzeichnung
Eine Aufzeichnung wird mit dem Bit bEnableTrigger angefordert. Aktuelle Werte sind im Speicher vorhanden wenn das Bit bTriggerDone im Status-Byte der Klemme erscheint. Soll der Speicher gelesen oder ausgewertet werden muss das Bit bEnableTrigger gesetzt bleiben, ansonsten wird der Speicher fortlaufend überschrieben.
Mit dem Bit bEvalBuffer wird die Auswertung des Speichers aktiviert. Aktuelle Werte sind in den Prozessdaten vorhanden, sobald das Bit bEvalBufferDone erscheint. Es ist so eine Mehrfachauswertung des Speichers möglich. So können nacheinander z. B. Mittelwert, Maximalwert, Minnimalwert, Effektivwert der Aufzeichnung gelesen werden.
Lesen des Trace-Speichers
Über die Trace Data Register (R60 und R61) können die Samples gelesen werden. Dazu legen Sie mit dem Trace Index Register (R62) der Offset innerhalb des Speichers fest.
Mit dem Zoom Register (R63) kann eine Anzahl nS Samples festgelegt werden, über die der Maxwert, Minwert, Mittelwert gebildet wird, oder der Abstand nS in Samples in dem die Werte ausgegeben werden. Nach jedem Lesezugriff auf R60 oder R61 wird das Trace Index Register (R62) um nS inkrementiert.
Beispiel:
Tragen Sie um alle Werte aus dem Speicher abzurufen in R62 den Wert 0x0000 und in R63 den Wert 0x0001 ein. Und lesen Sie dann abwechselnd R60 und R61 aus. Falls nur jeder zweite Wert gelesen werden so setzen Sie R63 auf den Wert 0x0002.
Hüllkurvenüberwachung
Für jede Aufzeichnung kann eine Überwachung mit einem engen und einem weiten Abstand erfolgen. Der enge Abstand wird im Folgenden als innere Hüllkurve, der weite Abstand als äußere Hüllkurve bezeichnet.
Anwendungsbeispiel:
▪
Überwachung eines Alterungsprozesses mit der inneren Hüllkurve
▪
Überwachung von Fehlfunktionen mit der äußeren Hüllkurve
Sie können im Flash-Speicher der Klemme eine Referenzkurve ablegen, die nach einem Reset der Klemme ins RAM kopiert wird.
Wenn die Auswertung des inneren bzw. äußeren Fehlerzählers aktiviert ist, d.h. im Indexregister für Prozessdaten (R38 oder R39) der Wert 18 oder 19 steht, so wird der Abstand zwischen dem jeweiligen Istwert und Sollwert mit Parameter x der Hüllkurve (R53, R54) verglichen. Falls der Abstand größer, wird der jeweilige Zähler inkrementiert.
Der RAM-Bereich kann über das Kommandoregister (R7) mit dem Befehl WriteEnvCurvToRAM (0x0201) mit aktuellen Trace-Daten überschrieben (Teach In) oder ab Offset 0x8000 direkt beschrieben und gelesen werden. Mit dem Kommando WriteEnvCurvToFLASH (0x0202) können Sie die Daten dann spannungsausfallsicher im Flash-Speicher ablegen.
Weiterführende Informationen
•
Prozessabbild
•
RAM- und ROM-Register


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Weiterführende Informationen
•
Prozessabbild der KL3361
•
Prozessabbild der KL3362
•
Control- und Status-Bytes


Prozessabbild der KL3361

Zugriff aus dem Anwenderprogramm [image] Prozessabbild [image] Prozessabbild der KL3361
Prozessabbild der KL3361
Die folgenden 5 Byte werden bidirektional zwischen KL3361 und Steuerung übertragen:
Oszilloskop - kanal | Byte-0ffset (ohne Word-Alignment*) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
1 | 0 | 0 | Byte | Status-Byte 1 (SB1) | Control-Byte 1 (CB1)
 | 1 | 2 | Wort | DataIN0 | DataOUT0
 | 3 | 4 | Wort | DataIN1 | DataOUT1
*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen
Analoge Spannungen werden von der Oszilloskopklemme KL3361 wie folgt dargestellt:
Spannung | Dezimal | Hexadezimal
+20 mV | 32767 | 0x7FFF
0 mV | 0 | 0x0000
-20 mV | -32767 | 0x8001


Prozessabbild der KL3362

Zugriff aus dem Anwenderprogramm [image] Prozessabbild [image] Prozessabbild der KL3362
Prozessabbild der KL3362
Die folgenden 10 Byte werden bidirektional zwischen KL3362 und Steuerung übertragen:
Oszilloskop- kanal | Byte-0ffset (ohne Word-Alignment*) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
1 | 0 | 0 | Byte | Status-Byte 1 (SB1) | Control-Byte 1 (CB1)
 | 1 | 2 | Wort | DataIN0 (Kanal 1) | DataOUT0 (Kanal 1)
 | 3 | 4 | Wort | DataIN1 (Kanal 1) | DataOUT1 (Kanal 1)
2 | 5 | 8 | Byte | Status-Byte 2 (SB2) | Control-Byte 2 (CB2)
 | 6 | 10 | Wort | DataIN0 (Kanal 2) | DataOUT0 (Kanal 2)
 | 8 | 12 | Wort | DataIN1 (Kanal 2) | DataOUT1 (Kanal 2)
*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen
Analoge Spannungen werden von der Oszilloskopklemme KL3362 wie folgt dargestellt:
Spannung | Dezimal | Hexadezimal
+10 V | 32767 | 0x7FFF
0 V | 0 | 0x0000
-10 V | -32767 | 0x8001


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] Prozessabbild [image] Control- und Status-Bytes
Control- und Status-Bytes
Weiterführende Informationen
•
Erster Kanal
•
Zweiter Kanal (nur KL3362)


Erster Kanal

Zugriff aus dem Anwenderprogramm [image] Prozessabbild [image] Control- und Status-Bytes [image] Erster Kanal
Erster Kanal
Weiterführende Informationen
•
Prozessdatenbetrieb
•
Registerkommunikation


Prozessdatenbetrieb

Zugriff aus dem Anwenderprogramm [image] Prozessabbild [image] Control- und Status-Bytes [image] Erster Kanal [image] Prozessdatenbetrieb
Prozessdatenbetrieb
Control-Byte 1 (CB1) im Prozessdatenbetrieb
Das Control-Byte des ersten Kanals befindet sich im Ausgangsabbild der Oszilloskopklemme und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | bRegAccess | - | - | - | bSetDigitalOut | bEnabIntFkt | bEvalBuffer | bEnableTrigger
Legende
Bit
Name
Beschreibung
CB1.7
bRegAccess
0bin
Registerkommunikation ausgeschaltet (Prozessdatenbetrieb):
▪
Mit dem Prozessdatenwort DataIN0 wird das mit dem Index-Register 1 für Eingangsdaten (R38)* spezifizierte Datum von der Klemme zur Steuerung übertragen.
▪
Mit dem Prozessdatenwort DataIN1 wird das mit dem Index-Register 2 für Eingangsdaten (R39)* spezifizierte Datum von der Klemme zur Steuerung übertragen.
▪
Mit dem Prozessdatenwort DataOUT0 wird der mit dem Low-Byte des Index-Registers für Ausgangsdaten (R37)* spezifizierte Parameter von der Steuerung zur Klemme übertragen.
▪
Mit dem Prozessdatenwort DataOUT1 wird der mit dem High-Byte des Index-Registers für Ausgangsdaten (R37)* spezifizierte Parameter von der Steuerung zur Klemme übertragen.
*) Diese Register können Sie über die Registerkommunikation oder mit der Konfigurationssoftware KS2000 setzen.
CB1.6 - CB1.4
-
reserviert
CB1.3
bSetDigitalOut
Setzen des digitalen Ausgangs.
CB1.2
bEnabIntFkt
Freigabe für das direkte Setzen des digitalen Ausgangs durch die Triggereinheit:
0bin
Das Triggermodul darf den digitalen Ausgang im Triggerfall nicht setzen (default).
1bin
Das Triggermodul darf den digitalen Ausgang im Triggerfall direkt setzen (SET DOUT)
CB1.1
bEvalBuffer
Der Aufgezeichnete Speicher soll ausgewertet werden.
CB1.0
bEnableTrigger
Die Positive Flanke dieses Bits löst im Triggermode Shot den Trigger aus.
Status-Byte 1 (SB1) im Prozessdatenbetrieb
Das Status-Byte des ersten Kanals befindet sich im Eingangsabbild der Oszilloskopklemme und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | bRegAccessQ | bError | - | - | bDigitalOutputStatus | bExtTriggerInput | bEvalBufferDone | bTriggerDone
Legende
Bit | Name | Beschreibung
SB1.7 | bRegAccessQ | 0bin | Quittung Prozessdatenbetrieb
SB1.6 | bError | 0bin | Kein Fehler
 |  | 1bin | Ein Fehler ist aufgetreten
SB1.5 | - | reserviert
SB1.4 | - | reserviert
SB1.3 | bDigitalOutputStatus | Zustand des digitalen Ausgangs
SB1.2 | bExtTriggerInput | Zustand des Triggereingangs
SB1.1 | bEvalBufferDone | Die Auswertung des Speichers ist abgeschlossen. Es sind gültige aktuelle Prozessdaten vorhanden.
SB1.0 | bTriggerDone | Quittung für Triggerereignis, Werte wurden aufgezeichnet.


Registerkommunikation

Zugriff aus dem Anwenderprogramm [image] Prozessabbild [image] Control- und Status-Bytes [image] Erster Kanal [image] Registerkommunikation
Registerkommunikation
Control-Byte 1 (CB1) bei Registerkommunikation
Das Control-Byte des ersten Kanals befindet sich im Ausgangsabbild der Oszilloskopklemme und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | bRegAccess | R/W | Registernummer
Legende
Bit
Name
Beschreibung
CB1.7
bRegAccess
1bin
Registerkommunikation eingeschaltet.
CB1.6
R/W
0bin
Lesezugriff:
▪
Mit dem Prozessdatenwort DataIN0 wird das mit der Registernummer (CB1.5-CB1.0) spezifizierte Register gelesen.
▪
Das Prozessdatenwort DataIN1 wird nicht für die Registerkommunikation verwendet, steht aber während der Registerkommunikation auch nicht für Prozessdaten zur Verfügung! Siehe folgenden Hinweis!
1bin
Schreibzugriff:
▪
Mit dem Prozessdatenwort DataOUT0 wird das mit der Registernummer (CB1.5-CB1.0) spezifizierte Register beschrieben.
▪
Das Prozessdatenwort DataOUT1 wird nicht für die Registerkommunikation verwendet, steht aber während der Registerkommunikation auch nicht für Prozessdaten zur Verfügung!
CB1.5-CB1.0
Registernummer
Nummer des Registers, das gelesen oder beschrieben werden soll.
SmallWarningYellow VORSICHT
Ungültige Prozessdaten!
Prozessdaten, die eventuell noch angezeigt werden, sind nicht gültig!
Status-Byte 1 (SB1) bei Registerkommunikation
Das Status-Byte des ersten Kanals befindet sich im Eingangsabbild der Oszilloskopklemme und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | bRegAccessQ | R | Registernummer
Legende
Bit | Name | Beschreibung
SB1.7 | bRegAccessQ | 1bin | Quittung Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5-SB1.0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Zweiter Kanal (nur KL3362)

Zugriff aus dem Anwenderprogramm [image] Prozessabbild [image] Control- und Status-Bytes [image] Zweiter Kanal (nur KL3362)
Zweiter Kanal (nur KL3362)
Weiterführende Informationen
•
Prozessdatenbetrieb
•
Registerkommunikation


Prozessdatenbetrieb

Zugriff aus dem Anwenderprogramm [image] Prozessabbild [image] Control- und Status-Bytes [image] Zweiter Kanal (nur KL3362) [image] Prozessdatenbetrieb
Prozessdatenbetrieb
Control-Byte 2 (CB2) im Prozessdatenbetrieb
Das Control-Byte des zweiten Kanals ist im Prozessdatenbetrieb zurzeit ohne Funktion.
Bit | SB2.7 | SB2.6 | SB2.5 | SB2.4 | SB2.3 | SB2.2 | SB2.1 | SB2.0
Name | bRegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
SB2.7 | bRegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
SB2.6-SB2.0 | - | reserviert
Status-Byte 2 (SB2) im Prozessdatenbetrieb
Das Status-Byte des zweiten Kanals ist im Prozessdatenbetrieb zurzeit ohne Funktion.
Bit | SB2.7 | SB2.6 | SB2.5 | SB2.4 | SB2.3 | SB2.2 | SB2.1 | SB2.0
Name | bRegAccessQ | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
SB2.7 | bRegAccessQ | 0bin | Quittung Prozessdatenbetrieb
SB2.6-SB2.0 | - | reserviert


Registerkommunikation

Zugriff aus dem Anwenderprogramm [image] Prozessabbild [image] Control- und Status-Bytes [image] Zweiter Kanal (nur KL3362) [image] Registerkommunikation
Registerkommunikation
Control-Byte 2 (CB2) bei Registerkommunikation
Das Control-Byte des zweiten Kanals befindet sich im Ausgangsabbild der Oszilloskopklemme und wird von der Steuerung zur Klemme übertragen.
Bit | CB2.7 | CB2.6 | CB2.5 | CB2.4 | CB2.3 | CB2.2 | CB2.1 | CB2.0
Name | bRegAccess | R/W | Registernummer
Legende
Bit
Name
Beschreibung
CB2.7
bRegAccess
1bin
Registerkommunikation eingeschaltet.
CB2.6
R/W
0bin
Lesezugriff:
▪
Mit dem Prozessdatenwort DataIN2 wird das mit der Registernummer (CB2.5-CB2.0) spezifizierte Register gelesen.
▪
Das Prozessdatenwort DataIN3 wird nicht für die Registerkommunikation verwendet, steht aber während der Registerkommunikation auch nicht für Prozessdaten zur Verfügung! Siehe Hinweis!
1bin
Schreibzugriff:
▪
Mit dem Prozessdatenwort DataOUT2 wird das mit der Registernummer (CB2.5-CB2.0) spezifizierte Register beschrieben.
▪
Das Prozessdatenwort DataOUT3 wird nicht für die Registerkommunikation verwendet, steht aber während der Registerkommunikation auch nicht für Prozessdaten zur Verfügung!
CB2.5-CB2.0
Registernummer
Nummer des Registers, das gelesen oder beschrieben werden soll.
SmallWarningYellow VORSICHT
Ungültige Prozessdaten!
Prozessdaten, die eventuell noch angezeigt werden, sind nicht gültig!
Status-Byte 2 (SB2) bei Registerkommunikation
Das Status-Byte des zweiten Kanals befindet sich im Eingangsabbild der Oszilloskopklemme und wird von der Klemme zur Steuerung übertragen.
Bit | SB2.7 | SB2.6 | SB2.5 | SB2.4 | SB2.3 | SB2.2 | SB2.1 | SB2.0
Name | bRegAccessQ | R | Registernummer
Legende
Bit | Name | Beschreibung
SB2.7 | bRegAccessQ | 1bin | Quittung Registerzugriff
SB2.6 | R | 0bin | Lesezugriff
SB2.5-SB2.0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


RAM- und ROM-Register

Zugriff aus dem Anwenderprogramm [image] RAM- und ROM-Register
RAM- und ROM-Register
Weiterführende Informationen
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] RAM- und ROM-Register [image] Registerübersicht
Registerübersicht
Die folgenden Register sind für jeden Signalkanal der Oszilloskopklemme vorhanden. Das bedeutet diese Register sind
▪
auf der KL3661 einmal vorhanden.
▪
auf der KL3662 zweimal vorhanden.
Register | Kommentar | Defaultwert |  | R/W | Speicher
R0 | Rohwert des A/D-Wandlers | - | - | R | RAM
R1 - R5 | reserviert | 0x0000 | 0dez | R | RAM
R6 | Diagnose-Register | - | - | R | RAM
R7 | Kommando-Register | 0x0000 | 0dez | R/W | RAM
R8 | Klemmenbezeichnung | KL3361: 0x0D21 KL3362: 0x0D22 | KL3361: 3361dez KL3362: 3362dez | R | ROM
R9 | Firmware-Stand | z. B. 0x3143 | z. B. 12611dez | R | ROM
R10 | Multiplex-Schieberegister | KL3361: 0x0128 KL3362: 0x0228 | KL3361: 296dez KL3362: 552dez | R | ROM
R11 | Signalkanäle | KL3362: 0x0128 KL3362: 0x0228 | KL3361: 296dez KL3362: 552dez | R | ROM
R12 | minimale Datenlänge | 0x2828 | 10280dez | R | ROM
R13 | Datenstruktur | 0x0004 | 4dez | R | ROM
R14 | reserviert | 0x0000 | 0dez | R | ROM
R15 | Alignment-Register | - | - | R/W | RAM
R16 | Hardware Versionsnummer | z. B. 0x0000 | z. B. 0dez | R/W | SEEROM/RAM
R17 | Hardware-Abgleich: Offset | typisch 0x1FFF | typisch 8191dez | R/W | SEEROM/RAM
R18 | Hardware-Abgleich: Gain | typisch 0x1000 | typisch 4096dez | R/W | SEEROM/RAM
R19 | Hersteller Skalierung: Offset | typisch 0x0000 | typisch 0dez | R/W | SEEROM/RAM
R20 | Hersteller Skalierung: Gain | typisch 0x0100 | typisch 256dez | R/W | SEEROM/RAM
R21 - R30 | reserviert | - | - | R/W | SEEROM/RAM
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register | 0x0000 | 0dez | R/W | SEEROM/RAM
R33 | Anwender-Offset | 0x0000 | 0dez | R/W | SEEROM/RAM
R34 | Anwender-Gain | 0x0100 | 256dez | R/W | SEEROM/RAM
R35 | Sample-Rate | 0x00C8 | 200dez | R/W | SEEROM/RAM
R36 | Sample-Amount | 0x0064 | 100dez | R/W | SEEROM/RAM
R37 | Index-Register für Ausgangsdaten | 0x0000 | 0dez | R/W | SEEROM/RAM
R38 | Index-Register 1 für Eingangsdaten | 0x0000 | 0dez | R/W | SEEROM/RAM
R39 | Index-Register 2 für Eingangsdaten | 0x8010 | 32784dez | R/W | SEEROM/RAM
R40 | Triggermodul 1, Triggerlogik | 0x0D21 | 3361dez | R/W | SEEROM/RAM
R41 | Triggermodul 1, Schwellwert 1 | 0x03E8 | 1000dez | R/W | SEEROM/RAM
R42 | Triggermodul 1, Schwellwert 2 | 0x03E8 | 1000dez | R/W | SEEROM/RAM
R43 | Triggermodul 1, Pulsbreite | 0x0064 | 100dez | R/W | SEEROM/RAM
R44 | Triggermodul 1, gültige Triggerzeit | 0x0064 | 100dez | R/W | SEEROM/RAM
R45 | reserviert | - | - | R/W | SEEROM/RAM
R46 | Triggermodul 2, Triggerlogik | 0x0D21 | 3361dez | R/W | SEEROM/RAM
R47 | Triggermodul 2, Schwellwert 1 | 0x03E8 | 1000dez | R/W | SEEROM/RAM
R48 | Triggermodul 2, Schwellwert 2 | 0x03E8 | 1000dez | R/W | SEEROM/RAM
R49 | Triggermodul 2, Pulsbreite | 0x0064 | 100dez | R/W | SEEROM/RAM
R50 | Triggermodul 2, gültige Triggerzeit | 0x0064 | 100dez | R/W | SEEROM/RAM
R51 | reserviert | - | - | R/W | SEEROM/RAM
R52 | Triggerverzögerung | 0x0000 | 0dez | R/W | SEEROM/RAM
R53 | Parameter 1 Hüllkurve | 0x0000 | 0dez | R/W | SEEROM/RAM
Register | Kommentar | Defaultwert |  | R/W | Speicher
R54 | Parameter 2 Hüllkurve | 0x0000 | 0dez | R/W | SEEROM/RAM
R55 | Samples Hüllkurve | 0x0000 | 0dez | R/W | SEEROM/RAM
R56 | Trigger-Frequenz | 0x0000 | 0dez | R/W | SEEROM/RAM
R57 - R59 | reserviert | - | - | R/W | SEEROM/RAM
R60 | Trace Data Register 1 | 0x0000 | 0dez | R/W | RAM
R61 | Trace Data Register 2 | 0x0000 | 0dez | R/W | RAM
R62 | Trace Index Register | 0x0000 | 0dez | R/W | RAM
R63 | Zoom Register | 0x0000 | 0dez | R/W | RAM


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] RAM- und ROM-Register [image] Registerbeschreibung
Registerbeschreibung
Die folgenden Register sind für jeden Signalkanal der Oszilloskopklemme vorhanden. Das bedeutet, diese Register sind
▪
auf der einkanaligen KL3361 einmal vorhanden.
▪
auf der zweikanaligen KL3362 zweimal vorhanden.
R0: ADC-Rohwert
Rohwert des Analog/Digital-Wandlers.
R6: Diagnoseregister
Im Diagnoseregister werden ab einer späteren Firmware-Version Diagnose-Informationen über den Zustand der Oszilloskopklemme zur Verfügung gestellt.
R7: Kommandoregister
Mit diesem Register können Sie Kommandos zur Oszilloskopklemme übertragen.
Kommandos
Kommando 0x0201: WriteEnvCurvToRAM
Schreiben der Abtastwerte in die RAM-Hüllkurve (Teach In Methode).
Rückgabewert: 0x201
Kommando 0x0202: WriteEnvCurvToFLASH
Schreiben der Abtastwerte in RAM-Hüllkurve und Flash-Hüllkurve (Teach In Methode).
Rückgabewert: 0x202
ROM-Register
Die Klemme belegt zwei Kanäle mit einer Byte/Wort/Wort Datenstruktur. Diese Struktur wird von Kopplern die das Umschalten des BK200 nicht besitzen nicht unterstützt. Es kann hier nicht lesend auf den zweiten Registersatz zugegriffen werden.
Die Klemme meldet sich immer mit einer Schieberegisterlänge von 5-Byte (siehe allgemeine Klemmendokumentation).
R8: Klemmenbezeichnung
Im Register R8 steht in hexadezimaler Codierung die Bezeichnung der Klemme:
KL3361: 0x0D21 (3361dez)
KL3362: 0x0D22 (3362dez)
R9: Firmware-Stand
Im Register R9 steht in hexadezimaler Codierung der Firmware-Stand der Klemme, z. B. 0x3144 (12612dez).
R10: Schieberegisterlänge
KL3361: 0x0128
KL3362: 0x0228
R11: Anzahl der Signalkanäle
KL3361: 0x0128
KL3362: 0x0228
R12: Minimale Datenlänge
KL3361: 0x2828
KL3362: 0x2828
R13: Datentyp
Im Register R13 steht der Datentyp der Busklemme. 0x0004 steht für Analogeingang.
R15: Alignment-Register
R16: Hardware Versionsnummer
Im Register R16 steht in hexadezimaler Codierung der Hardware-Stand der Klemme, z. B. 0x0000 (0dez).
Anwender-Register
Die Anwender-Register der Oszilloskopklemme können vom Anwenderprogramm beschrieben werden um die Eigenschaften der Oszilloskopklemme zur Laufzeit zu verändern.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte nur in die RAM-Register, nicht aber in die EPROM-Register gespeichert und gehen somit bei einem Neustart der Klemme verloren.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die EPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Betriebsart der Klemme fest.
Bit
Betriebsart
Wert
Erläuterung
Default
R32.15
-
-
reserviert
0bin
...
-
-
reserviert
0bin
R32.11
-
-
reserviert
0bin
R32.10
R32.9
R32.8
Triggerart
000bin
Posttrigger: Es wird ab dem Eintreten des Triggerereignisses aufgezeichnet.
000bin
001bin
Pretrigger: Es wird bis zum Eintreten des Triggerereignisses aufgezeichnet.
010bin
Midtrigger: Das Triggerereignisses ist das Zentrum der Aufzeichnung.
011bin
FastSampling (ab Firmware-Version 1B'): Betrieb mit erhöhter Abtastrate von bis zu 10 µs.
▪
Die Aufzeichnung kann nur über den Triggereingang gestartet werden.
▪
Die Einstellungen der Triggermodule werden nicht berücksichtigt.
▪
Auch bei KL3362 wird nur der erste Kanal aufgezeichnet.
R32.7
-
-
reserviert
0bin
R32.6
Autotrigger
0bin
nicht aktiv
0bin
1bin
aktiv: Die Triggereinheit wird automatisch nach der Auswertung des vorhergehenden Ereignisses aktiviert. Dazu wird mit jeder neuen Auswertung im Status-Byte 1 (SB1) das Bit 0 getoggelt.
R32.5
Testmodus
0bin
nicht aktiv
0bin
1bin
aktiv: Die Oszilloskopklemme simuliert eine Rampe von Abtastwerten. Dabei wird der Abtastwert nach jedem Auslesen inkrementiert. Die Rampe läuft so von 0x0000 bis 0x3FFF. Ab 0x3FFF wird der Abtastwert nach jedem Auslesen dekrementiert so dass die Rampe wieder auf 0x0000 zurück läuft. Der Vorgang wird zyklisch wiederholt.
R32.4
Triggerverzögerung
0bin
nicht aktiv
0bin
1bin
aktiv: Nach dem Trigger-Ereignis Samples übergangen. Die Anzahl der Samples die übergangen werden wird im Register Trigger Delay (R52) festgelegt.
R32.3
-
-
reserviert
0bin
...
-
-
reserviert
0bin
R32.0
-
-
reserviert
0bin
R33: Anwender-Offset
Vom Anwender veränderbarer Offset. Skalierung:
Offset = Messbereichsendwert x Parameter / Auflösung
Beispiel für KL3361: 16 mV x 100 / 32767 = 0,049 mV
R34: Anwender-Gain
Vom Anwender veränderbarer Verstärkungsfaktor.
R35: Sample-Rate
Abstand (Ts) zweier Samples (Abtastungen) in Mikrosekunden.
Die Abtastgeschwindigkeit ist durch die Auswertung der Trigger-Detektoren auf Ts =100 µs (10 kHz) beschränkt.
Nur im Modus Fast-Sampling kann mit Ts=10 µs (100 kHz) abgetastet werden.
Übertragungsgeschwindigkeit auf dem K-Bus
Die Sample-Rate beeinflusst die Übertragungsgeschwindigkeit, mit der die Oszilloskopklemme vom K-Bus angesprochen werden kann.
Beachten Sie dies in Bezug auf Ihre SPS-Zykluszeit:
•
Bei einer Sample-Rate von 100 µs können nur K-Bus-Zyklen, die mindestens 3 ms dauern gefahren werden!
•
Bei einer Sample-Rate von 150 µs können nur K-Bus-Zyklen, die mindestens 2 ms dauern gefahren werden!
•
Im Modus Fast-Sampling können nur K-Bus-Zyklen, die mindestens 2 ms dauern gefahren werden!
R36: Sample-Amount
Anzahl der aufzuzeichnenden Abtastwerte. Es können maximal 4000 Werte aufgezeichnet werden (Default 100).
R37: Index-Register für Ausgangsdaten (Klemmenparameter)
▪
Low Byte:
Der Inhalt des Low Bytes dieses Registers legt fest, welcher Parameter der Oszilloskopklemme
–
KL3361 mit dem Prozessdaten-Register DataOUT0
–
KL3362 mit dem Prozessdaten-Register DataOUT0 (Kanal 1) oder Prozessdaten-Register DataOUT0 (Kanal 2)
beschrieben wird.
Dabei entspricht der dezimale Wert der Indexe der Registernummer des zu beschreibenden Parameters.
Folgende Indizes werden unterstützt:
Index | Dezimal | Parameter
0x00 | 00 | Default-Wert
0x29 | 41 | Triggermodul 1, Schaltschwelle 1
0x2A | 42 | Triggermodul 1, Schaltschwelle 2
0x2B | 43 | Triggermodul 1, Pulsbreite
0x2C | 44 | Triggermodul 1, gültige Triggerzeit
0x2F | 47 | Triggermodul 2, Schaltschwelle 1
0x30 | 48 | Triggermodul 2, Schaltschwelle 2
0x31 | 49 | Triggermodul 2, Pulsbreite
0x32 | 50 | Triggermodul 2, gültige Triggerzeit
▪
High Byte:
Der Inhalt des High Bytes dieses Registers legt fest, welcher Parameter der Oszilloskopklemme
–
KL3361 mit dem Prozessdaten-Register DataOUT1
–
KL3362 mit den Prozessdaten-Registern DataOUT1 (Kanal 1) oder DataOUT1 (Kanal 2)
beschrieben wird (Indizes siehe Low Byte).
R38: Index-Register 1 für Eingangsdaten
Der Inhalt dieses Registers (Default-Wert: 0x0000) legt fest, welches Datum in das Prozessdaten-Register
▪
DataIN0 der Oszilloskopklemme KL3361
▪
DataIN0 (Kanal 1) oder DataIN0 (Kanal 2) der Oszilloskopklemme KL3362
eingeblendet wird.
Folgende Indizes werden unterstützt:
Index
Dezimal
Datum
0x0000
0
Aktueller Analogwert
0x0001
1
Maximalwert einer Aufzeichnung
0x0002
2
Minimalwert einer Aufzeichnung
0x0003
3
Effektivwert der Aufzeichnung: Sqrt((Summe(xn2))/n
0x0004
4
Mittelwert der Aufzeichnung: (Summe (xn))/n
0x0005
5
Spitze-Spitze der Aufzeichnung
0x0006
6
Periodendauer
0x0007
7
Pulsbreite-High: Schaltschwelle ist Triggerlevel 1
▪
Trigger startet, sobald vier aufeinanderfolgende Werte über der Schaltschwelle liegen
▪
Trigger wird beendet, sobald vier aufeinanderfolgende Werte unter der Schaltschwelle liegen
0x0008
8
Pulsbreite-Low: Schaltschwelle ist Triggerlevel 1
▪
Trigger startet, sobald vier aufeinanderfolgende Werte unter der Schaltschwelle liegen
▪
Trigger wird beendet, sobald vier aufeinanderfolgende Werte über der Schaltschwelle liegen
0x0009
9
Tastverhältnis
0x000A
10
reserviert für Jitter Tmax
0x000B
11
reserviert für Jitter Tmin
0x000C
12
reserviert für Jitter Tmittel
0x000D
13
Histogramm Max d.h. welcher Wert ist am häufigsten aufgetreten.
0x000E
14
Timer1LatchValue
0x000F
15
Timer1Run (read/write)
0x0010
16
Timer2LatchValue
0x0011
17
Timer2Run (read/write)
0x0012
18
Fehlerzähler innere Hüllkurve
0x0013
19
Fehlerzähler äußere Hüllkurve
0x0014
20
Anzahl Samples bis Analogwert größer als Schaltschwelle 1
0x0015
21
Anzahl Samples bis Analogwert kleiner als Schaltschwelle 1
0x8000
Erster Abtastwert.
Ab hier stehen die aufgezeichneten Abtastwerte zur Verfügung. Um den Trace-Offset zu bestimmen muss das MSB gelöscht werden.
0x8001
Zweiter Abtastwert.
0x8002
Dritter Abtastwert.
...
...
...
0x8063
Hundertster Abtastwert (im Auslieferungszustand werden 100 Werte gespeichert).
...
...
...
0x8F9F
Viertausendster Abtastwert (es können maximal 4000 Werte gespeichert werden).
R39: Index-Register 2 für Eingangsdaten
Der Inhalt dieses Registers (Default-Wert: 0x8010) legt fest, welches Datum in das Prozessdaten-Register
▪
DataIN1 der Oszilloskopklemme KL3361
▪
DataIN1 (Kanal 1) oder DataIN1 (Kanal 2) der Oszilloskopklemme KL3362
eingeblendet wird (Indizes siehe Index-Register 1 für Prozesseingangsdaten).
R40: Triggermodul 1, Triggerlogik
Bit
Betriebsart
Wert
Erläuterung
Default
R40.15
-
-
reserviert
0bin
R40.14,
R40.13,
R40.12
enableSource
000bin
Trigger immer freigegeben
000bin
001bin
Trigger freigegeben, wenn Signal am Analogeingang 1 über Schaltschwelle 2
Analogeingang 1 ist bei
▪
KL3361 der Eingang für Differenzspannung der Messbrücke (UB+/UB-)
▪
KL3362 der Oszilloskopeingang Kanal 1 (IN 1)
010bin
Trigger freigegeben, wenn Signal am Analogeingang 1 unter Schaltschwelle 2
011bin
Trigger freigegeben, wenn Signal am Analogeingang 2 über Schaltschwelle 2
Analogeingang 2 ist bei
▪
KL3361 nicht vorhanden
▪
KL3362 der Oszilloskopeingang Kanal 2 (IN 2)
100bin
Trigger freigegeben, wenn Signal am Analogeingang 1 unter Schaltschwelle 2
101bin
Trigger freigegeben wenn Triggereingang (24 V Trigger) auf High-Potential liegt.
110bin
Trigger freigegeben wenn Triggereingang (24 V Trigger) auf Low-Potential liegt.
R40.11,
R40.10
TriggerSource
00bin
Zeitgeber mit Schaltschwelle 1
11bin
01bin
erster analoger Eingang (IN1), mit Schaltschwelle 1
10bin
zweiter analoger Eingang (IN2), mit Schaltschwelle 1 (nur KL3362)
11bin
digitaler Eingang
R40.9,
R40.8
TriggerMode
00bin
Shot: Der Trigger wird mit einer Flanke des Bits bEnableTrigger des Control-Bytes 1 (CB1.0) ausgelöst, wenn die über enableSource eingestellte Freigabe vorhanden ist.
01bin
01bin
Edge: Der Trigger wird mit der über TriggerSource und bLogic ausgesuchten Flanke ausgelöst, wenn die über enableSource eingestellte Freigabe vorhanden ist.
10bin
Glitch: Trigger wird mit dem über TriggerSource, bLogic und bLarger ausgesuchtem Puls ausgelöst, wenn die über enableSource eingestellte Freigabe vorhanden ist.
R40.7
-
-
reserviert
0bin
R40.6
bTriggerWinEn
1bin
Innerhalb der gültigen Triggerzeit für Triggermodul 1 muss die Triggerbedingung für das folgenden Triggermodul eintreffen. Ansonsten wird alles zurückgesetzt
0bin
R40.5
bStartScopeRec
0bin
mit Triggerereignis wird das nachgeschaltete Triggermodul aktiv geschaltet
0bin
1bin
mit Triggerereignis wird die Aufzeichnung gestartet
R40.4
bTriggerOutEn
1bin
mit Triggerereignis wird der digitale Ausgang gesetzt, wenn dies durch Bit 2 des Control-Bytes 1 (CB1.2) freigegeben ist.
0bin
R40.3
bLatchtimer
1bin
bei Triggerereignis wird der aktuelle Wert des laufenden Timers gespeichert.
0bin
R40.2
bResetTimer
1bin
bei Triggerereignis wird der Timer auf Null zurückgesetzt. Der Timer läuft daraufhin sofort automatisch wieder los.
0bin
R40.1
bLarger
0bin
im Glitch-Mode: Pulsbreite kleiner als die für das Triggermodul 1 festgelegtePulsbreite
0bin
1bin
im Glitch-Mode: Pulsbreite größer als die für das Triggermodul 1 festgelegtePulsbreite
R40.0
bLogic
0bin
im Edge Mode (Flankentriggerung): negative Flanke
im Glitch-Mode: negativer Puls
1bin
1bin
im Edge Mode (Flankentriggerung): positive Flanke
im Glitch-Mode: positiver Puls
R41: Triggermodul 1, Schaltschwelle 1
Schaltschwelle für die Triggerquelle (TriggerSource) des Triggermoduls 1
R42: Triggermodul 1, Schaltschwelle 2
Schaltschwelle für die Triggerfreigabe (EnableSource) des Triggermoduls 1
R43: Triggermodul 1, Pulsbreite
Legen Sie hier die Pulsbreite (tP) des Triggermoduls 1 für den Glitch-Mode fest. Als Parameter wird die Anzahl der Samples (nSP) eingetragen. Die Pulsbreite ist somit abhängig von der Sample Rate! Beispiel:
▪
Sample Rate: Ts = 200 µs
▪
Samples: nSP = 100
Pulsbreite: tP = Ts x nSP = 200 µs x 100 = 20 ms
R44: Triggermodul 1, gültige Triggerzeit
Legen Sie hier die gültige Triggerzeit (tVT) für das Triggermodul 1 fest. Als Parameter wird die Anzahl der gültigen Samples (nVS) eingetragen. Die gültige Triggerzeit ist somit abhängig von der Sample Rate! Beispiel:
▪
Sample Rate: Ts = 200 µs
▪
gültige Samples: nVS=100
Valid Trigger Time: tVT = Ts x nVS =200 µs x 100 = 20 ms
R46: Triggermodul 2, Triggerlogik
siehe Trigger Detektor 1
R47: Triggermodul 2, Schaltschwelle 1
Schaltschwelle für die Triggerquelle (TriggerSource) des Triggermoduls 2
R48: Triggermodul 2, Schaltschwelle 2
Schaltschwelle für die Triggerfreigabe (EnableSource) des Triggermoduls 2
R49: Triggermodul 2, Pulsbreite
Legen Sie hier die Pulsbreite (tP) des Triggermoduls 2 für den Glitch-Mode fest (siehe Triggermodul 1, Pulsbreite).
R50: Triggermodul 2, gültige Triggerzeit
siehe Triggermodul 1, gültige Triggerzeit
R52: Triggerverzögerung
Hier können Sie eine Triggerverzögerung (tTD) festlegen. Als Parameter wird die Anzahl der übergangenen Samples (nSTD) eingetragen. Die Triggerverzögerung ist somit abhängig von der Sample Rate! Beispiel: Sample Rate: Ts = 200 µs, Übergangene Samples: nSTD=100
tTD = Ts x nSTD = 200 µs x 100 = 20 ms
R53: Parameter 1 Hüllkurve
z. B. Abstand der inneren Hüllkurve
Im Anschluss an die Trace-Aufzeichnung wird die Hüllkurve ausgewertet.
R54: Parameter 2 Hüllkurve
z. B. Abstand der äußeren Hüllkurve
Im Anschluss an die Trace-Aufzeichnung wird die Hüllkurve ausgewertet.
R55: Samples Hüllkurve
Anzahl der Samples die Auszuwerten sind (max. 512).
R56: Triggerfrequenz
Frequenz des Zeitgebers, der zur Triggerung verwendet werden kann.
R60: Trace Data Register 1
Enthält den Abtastwert aus dem im Trace Index Register (R62) angegebenen Register.
Nach Ende des Lesezugriffs (Wechsel der Registeradresse) wird der Trace-Index (R62) um den Zoom-Abstand nZ (siehe R63) inkrementiert.
R61: Trace Data Register 2
Enthält den Abtastwert aus dem auf das im Trace Index Register (R62) angegebenen Register folgende Register.
Nach Ende des Lesezugriffs (Wechsel der Registeradresse) wird der Trace-Index (R62) um den Zoom-Abstand nZ (siehe R63) inkrementiert.
R62: Trace Index Register
Schreiben: setzen des Trace-Indices auf Offset
Lesen: aktueller Wert des Trace-Indices.
Beim Start einer Aufzeichnung wird der Index auf Null gesetzt.
Von Offset Null bis 0x3FFF stehen die Trace Daten.
Ab 0x8000 wird die Hüllkurve ausgegeben
R63: Zoom Register
Mit dem Zoom Register können Sie festlegen, das
▪
nur bestimmte Werte oder
▪
vorverarbeitete Werte (Maximalwert , Minimalwert oder arithmetischer Mittelwert)
zur Steuerung übertragen werden.
Bit | Name | Wert | Erläuterung | Default
R63.15 R63.14 | Zoom-Modus | 00bin | Sample Zoom - Das Trace Index Register wird nach jedem Auslesen automatisch um den Zoom-Abstand nZ erhöht. Somit wird nur jeder nZ-te Wert ausgelesen. | -
 |  | 01bin | Max Zoom - Es wird der Maximalwert der ausgelesenen Werte ausgeben
 |  | 10bin | Min Zoom - Es wird der Minimalwert der ausgelesenen Werte ausgeben
 |  | 11bin | Mittelwert Zoom - Es wird der arithmetische Mittelwert der ausgelesenen Werte ausgeben
R63.13 R63.12 | - | - | reserviert | -
R63.11 ... R63.0 | Zoom-Abstand nZ | Anzahl nZ der Abtastwerte, um die das Trace Index Register (R62) im Zoom-Modus Sample Zoom nach jedem Auslesen automatisch erhöht wird. Beispiele: |  | -
 |  | 0x000 | Es wird immer der gleiche Wert ausgelesen.
 |  | 0x001 | Es wird jeder Wert ausgelesen.
 |  | 0x002 | Es wird nur jeder zweite Wert ausgelesen.
 |  | 0x00A | Es wird nur jeder zehnte Wert ausgelesen.


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] RAM- und ROM-Register [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] RAM- und ROM-Register [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] RAM- und ROM-Register [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.