KL3356 - Präzise Widerstandsbrückenklemme
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.3.0
▪
Beispielprogramm zum Kapitel “Konfigurations-Software KS2000“ hinzugefügt
▪
Sicherheitshinweise neues Layout
2.2.0
▪
Kapitel „Grundlagen zur Funktion“ aktualisiert
2.1.0
▪
Technische Daten aktualisiert
2.0.0
▪
Migration
1.5.0
▪
Beschreibung von Prozessabbild und Mapping aktualisiert
▪
Registerbeschreibung aktualisiert und korrigiert
1.4
▪
Registerbeschreibung aktualisiert
▪
Montageanleitung überarbeitet
1.3
▪
LED-Beschreibung an Re-Design mit neuem LED-Prisma angepasst (8 LEDs in Funktion)
▪
Registerbeschreibung korrigiert und erweitert
▪
Firm- und Hardware-Stände aktualisiert
1.2
▪
Bilder an Re-Design mit LED-Prisma angepasst (4 LEDs in Funktion)
▪
technische Daten aktualisiert
1.1
▪
Beschreibung von Prozessdaten, Control- und Status-Bytes überarbeitet
▪
Kalibrierungsstabilisierung ergänzt
▪
Verdrahtungsbeschreibung (Powerkontakte) aktualisiert und Beispiel hinzugefügt
▪
Anwender-Kalibrierung hinzugefügt
▪
Beschreibung der Parametrierung der KL3356 mit der KS2000-Software aktualisiert
1.0
▪
technische Daten aktualisiert
▪
Grundlagen zur Funktion überarbeitet
▪
Übersetzung in Englisch verfügbar
0.4
▪
Beschreibung der Register erweitert
0.3
▪
technische Daten aktualisiert
▪
Beschreibung der Parametrierung der KL3356 mit der KS2000-Software hinzugefügt
▪
Registerbeschreibung erweitert
0.2
▪
technische Daten hinzugefügt
▪
Beispiele für Registerkommunikation hinzugefügt
▪
Informationen zu Montage und Anschluss hinzugefügt
0.1
erste Vorabversion
Firm- und Hardware-Stände
Dokumentation Version | KL3356, KS3356
 | Firmware | Hardware
2.3.0 | 2D | 06
2.2.0 | 2D | 06
2.1.0 | 2D | 06
2.0.0 | 2D | 06
1.5.0 | 2D | 05
1.4 | 2B | 03
1.3 | 2B | 02
1.2 | 2A | 01
1.1 | 1F | 00
1.0 | 1A | 00
0.4 | 1A | 00
0.3 | 1A | 00
0.2 | 1A | 00
0.1 | 1A | 00
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Jahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 35 04 1A 00:
35 - Produktionswoche 35
04 - Produktionsjahr 2004
1A - Firmware-Stand 1A
00 - Hardware-Stand 00


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Grundlagen zur Funktion
•
LEDs


Einführung

Produktübersicht [image] Einführung
Einführung
KL3356
Die analoge Eingangsklemme KL3356 ermöglicht den direkten Anschluss einer Widerstandsbrücke. Durch eine verbesserte Eingangsschaltung ist die KL3356 deutlich genauer als die KL3351. Das Verhältnis der Brückenspannung UD zur Versorgungsspannung Uref wird in der Eingangsschaltung ermittelt. Um eine sehr gute Langzeitstabilität zu erreichen, wird die gesamte Schaltung mindestens alle 3 Minuten neu kalibriert. Dieser Vorgang kann von der Steuerung synchronisiert werden um zu verhindern, dass die Kalibrierung zu einer Verzögerung im Produktionsablauf führt.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | KL3356/KS3356
Eingänge | 2, für eine Brückenschaltung
Signalspannung UD | -20 mV ... +20 mV
Eingangswiderstand (UD) | > 1 MΩ
Versorgungsspannung für die Messbrücke (UV) | 5 V ... 12 V (empfohlen)
Referenzspannung URef | maximal 12 V
Eingangswiderstand (URef) | > 200 kΩ
Auflösung | 16 Bit
Wandlungszeit | < 250 ms, konfigurierbar
Messfehler (gesamter Messbereich) | ±0,01% vom Messbereichsendwert, Selbstkalibrierung
Bitbreite im K-Bus E /A | 2 x 16 Bit Nutzdaten, 2 x 8 Bit Control/Status
Bitbreite im Eingangsprozessabbild | 2 Datenworte, 2 Status-Bytes
Bitbreite im Ausgangsprozessabbild | 2 Datenworte, 2 Control-Bytes
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 85 mA
Gewicht | ca. 75 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm
Montage | auf 35 mm Tragschiene nach EN 60715
Steckbare Verdrahtung | bei allen Klemmen der Bauform KSxxxx
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus, ATEX


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Mit der Analogeingangsklemme KL3356 wird die Versorgungsspannung einer Wägezelle als Referenzspannung und gleichzeitig auch die der Krafteinwirkung proportionalen Differenzspannung erfasst. Die Messung der Referenz- und Differenzspannung erfolgt alternierend mit demselben Wandler. Der Quotient aus Differenz- und Referenzspannung entspricht der Krafteinwirkung auf die Wägezelle. Abweichungen der verwendeten Analogeingangsstufen (Temperatur-, Langzeitdrift usw.) werden durch regelmäßige Kalibrierungen überprüft und innerhalb des zulässigen Toleranzbereiches ausgeglichen.
DMS-Messsignal
Das DMS-Messsignal wird mit einer Auflösung von 16 Bit (+Vorzeichen) in festen Intervallen erfasst. Dieser Wert wird als Datenwort ohne Vorzeichen auch im Register R2 abgelegt. Das Vorzeichen wird im Bit SW.0 des Status-Worts eingeblendet.
Die Größe des Abtastintervalls wird direkt durch die Filterkonstante in Register R37 bestimmt.
DMS-Referenzsignal
Das DMS-Referenzsignal wird ebenfalls mit einer Auflösung von 16 Bit (+Vorzeichen) in größeren Intervallen erfasst. Dieser Wert wird als Datenwort ohne Vorzeichen auch im Register R3 abgelegt. Das Vorzeichen wird im Bit SW.1 des Status-Wort eingeblendet.
Die Größe des Abtastintervalls wird in Register R39, in Vielfachen von 100 ms definiert.
Gewichtsberechnung
Nach jeder Erfassung eines Analogsignals erfolgt die Berechnung des resultierenden Gewichts, welche sich aus dem Verhältnis des Messsignals zum Referenzsignal und aus mehreren Kalibrierungen zusammensetzt:
YR = (UDiff / URef) x (Emax / Cn) x 1000 / 500 | (1.0) | Berechnung des Rohwertes des Gewichtes
YS = YR x AS | (1.1) | Skalierfaktor
YH = YS x AH + BH | (1.2) | Hersteller-Skalierung
YAUS = YH x AA + BA | (1.3.0) | Anwender-Skalierung (wenn R32.10=0bin)
YAUS = (YH + BA) x AA | (1.3.1) | Anwender-Kalibrierung (wenn R32.10=1bin)
Legende
Name | Bezeichnung | Einheit | Register
UDiff | Messsignal der Wägezelle | [1] | R2
URef | Referenzsignal der Wägezelle | [1] | R3
Emax | Nennlast der Wägezelle | [1 kg] | R35
Cn | Nennkennwert der Wägezelle | [1 mV / V] | R36
AS | Skalierfaktor (aktivierbar über Bit R32.8 des Feature-Registers) | [1] | R38
BH | Offset der Hersteller-Skalierung (aktivierbar über Bit R32.1 des Feature-Registers) | [1] | R19
AH | Gain der Hersteller-Skalierung (aktivierbar über Bit R32.1 des Feature-Registers) | [1] | R20
BA | Offset der Anwender-Skalierung (aktivierbar über Bit R32.0 des Feature-Registers) | [1] | R33
AA | Gain der Anwender-Skalierung (aktivierbar über Bit R32.0 des Feature-Registers) | [1] | R34
Der Faktor 1000 in Formel 1.0 ergibt sich durch die Einheitennormierung der Nennlast [kg] und dem Nennkennwert [mV/V]. Der Faktor 1/500 wird durch einen Spannungsteiler vorgegeben. Das Ergebnis wird mit einer Auflösung von 16 Bit (+Vorzeichen) in das Prozessabbild der Klemme geschrieben. Dieser Wert wird als Datenwort ohne Vorzeichen auch im Register R1 abgelegt. Das Vorzeichen wird im Bit SB1.0 des Status-Bytes dargestellt.
Betriebsarten
Die KL3356 stellt verschiedene Betriebsarten zur Verfügung:
Betriebsart | Kommentar
Normalbetrieb | Messen der Krafteinwirkung auf die Lastmessdose
Null-Kalibrierung | Das Gleichspannungspotential der Operationsverstärker-Eingänge entspricht jenem des Normalbetriebs. Die Differenzspannung an beiden Operationsverstärker-Eingängen ist 0 mV (Feststellung der Nullpunkte).
End-Kalibrierung | Das Gleichspannungspotential der Operationsverstärker-Eingänge entspricht jenem des Normalbetriebs. Die heruntergeteilte Dosenversorgungsspannung (R114, R115, R151) wird an beide Operationsverstärker-Eingänge als Differenzsignal angelegt (Feststellung der Verstärkungen).
Null-Prüfen (0 V) | Das Gleichspannungspotential der Operationsverstärker-Eingänge wird auf 0 V gelegt. Die Differenzspannung an beiden Operationsverstärker-Eingängen ist 0 mV (1. Phase zur Feststellung der Common Mode Rejection der Operationsverstärker).
Null-Prüfen (2,5 V) | Das Gleichspannungspotential der Operationsverstärker-Eingänge wird auf 2,5 V gelegt. Die Differenzspannung an beiden Operationsverstärker-Eingängen ist 0 mV (2. Phase zur Feststellung der Common Mode Rejection der Operationsverstärker).
Referenz-Prüfen | Das Gleichspannungspotential der Operationsverstärker-Eingänge entspricht der halben Referenzspannung. Die heruntergeteilte Referenzspannung (R114, R115, R151) wird an beide Operationsverstärker-Eingänge als Differenzsignal angelegt (Messung der Referenzspannung).
Schalterstellungen
Die verschiedenen Betriebsarten werden über interne Schalter ausgewählt:
▪
Der Schalter SW1 wird durch das Bit R32.7 des Feature-Registers geschaltet ist für alle Kalibriervorgänge zu schließen:
- R32.7 = 0: SW1 offen
- R32.7 = 1: SW1 geschlossen
▪
Wenn im Kommandoregister R7 der manuelle Kalibriermodus aktiviert ist, können Sie die Schalter SW2 bis SW8 über das Ausgangsdatenwort RegOUT steuern.
Betriebsart | RegOUT | Schalterstellungen
 |  | SW1 | SW2 | SW3 | SW4 | SW5 | SW6 | SW7 | SW8
Normalbetrieb | 0dez | 0 / 1 | 1 | 1 | 0 | 1 | 0 | 1 | 0
Null-Kalibrierung | 1dez | 0 / 1 | 0 | 1 | 1 | 0 | 0 | 0 | 0
End-Kalibrierung | 2dez | 0 / 1 | 0 | 0 | 1 | 1 | 0 | 1 | 0
Null-Prüfen (0 V) | 3dez | 0 / 1 | 0 | 0 | 1 | 0 | 0 | 0 | 1
Null-Prüfen (2,5 V) | 4dez | 0 / 1 | 0 | 0 | 1 | 0 | 1 | 0 | 0
Referenz-Prüfen | 5dez | 0 / 1 | 0 | 0 | 1 | 0 | 1 | 0 | 1
Legende
0: Schalter nicht geschaltet
1: Schalter geschaltet
Kalibrierung der Messverstärker
Die Messverstärker werden periodisch einer Überprüfung und Kalibrierung unterzogen. Dafür sind insgesamt acht Analogschalter vorgesehen, um die verschiedenen Kalibriersignale aufschalten zu können. Wichtig dabei ist, dass in jeder Phase der Kalibrierung immer der gesamte Signalpfad (inklusive aller passiven Bauteile) überprüft wird. Lediglich die Entstörglieder (L/C-Kombination) und die Analogschalter selber können nicht erfasst werden.
Das Kalibrierintervall wird in 100 ms Schritten mit Register R40 eingestellt. Das Prüfintervall wird mit Register R41 als Vielfaches vom Kalibrierintervall vorgegeben.
▪
In der ersten Kalibrierphase werden beide Analogeingänge mit einer Eingangsspannung von 0 mV (Null-Kalibrierung) beaufschlagt. Somit können die Nullpunkte beider Analogeingangsstufen ermittelt werden. Hierbei wird eine System-Offset-Kalibrierung des A/D-Wandlers durchgeführt. Bei dieser Messung sind einerseits der jeweilige Absolutwert, sowie auch die gegenseitige Abweichung der Kanäle von Interesse.
▪
In der zweiten Kalibrierphase werden beide Analogeingänge mit einer Eingangsspannung von ca. 24 mV (End-Kalibrierung) beaufschlagt, die aus der Spannungsversorgung der Lastmessdose abgeleitet wird. Hier interessiert nicht mehr der Absolutwert der Messergebnisse, sondern nur noch die eventuelle Abweichung der Werte beider Analogeingänge. Hierbei wird der Gain des 1. Kanals an den des 2. Kanals angepasst. Entscheidend ist, dass die Kalibrierungen auf demselben Gleichspannungspotential der Operationsverstärkereingänge erfolgen wie im normalen Messbetrieb.
Durch die Kalibrierung der Eingangsstufen in den beiden Arbeitspunkten (Nullpunkt und Endwert) werden die Geraden beider Messkanäle aufeinander abgeglichen (Soll-Kennlinie), so dass sie deckungsgleich sind.
Kennlinien zur Kalibrierung
Während die Klemme eine Kalibrierung durchführt, ist im Register 0 (Status-Wort) das Bit R0.2 gesetzt.
Prüfung der Messverstärker
Um zusätzlich eine Funktionsprüfung der Analogeingangskreise und der Referenzspannungsquelle vornehmen zu können, besteht zusätzlich zur beschriebenen Kalibrierung die Möglichkeit, das interne Referenzspannungssignal von 2,5 V als Eingangssignal aufzuschalten. Zu diesem Zweck wird vor der eigentlichen Referenzspannungsmessung ein Differenzspannungssignal von 0 V bei einem Gleichspannungspotential von 0 V angelegt. Anschließend erfolgt die Messung des Differenzsignals 0 V bei einem Gleichspannungspotential von 2,5 V. Mit Hilfe der daraus resultierenden Messwerte kann der CommonMode-Einfluss der beiden Eingangsstufen bei der Eingangsspannung von 1,25 V berechnet und bei der abschließenden Referenzspannungsmessung berücksichtigt werden. Bei der Messung der Referenzspannungsquelle müssen beide Operationsverstärker dasselbe Messsignal liefern, das darüber hinaus auch mit einer sehr geringen Toleranz vorhergesagt werden kann. Überschreitungen dieser Toleranz werden als Hardwaredefekt eingestuft werden und in Bit SW.8 im Status-Wort angezeigt.
Wenn die Klemme eine Prüfung durchführt, ist im Register 0 (Status-Wort) das Bit R0.2 gesetzt.
Einleitung der Kalibrierung bzw. Prüfung
Der Kalibrier- bzw. Prüf-Vorgang wird von der Klemme automatisch nach den, in den Registern R39 bis R41, eingestellten Zeiten durchgeführt. Mit Bit CB1.1 des Control-Bytes können Sie die automatische Kalibrierung sperren (wird in Bit SB1.1 des Status-Bytes quittiert), um zu verhindern, dass während eines zeitkritischen Messvorganges kalibriert wird. Damit die Kalibrierung auf diese Art nicht vollständig unterdrückt wird, überwacht die KL3356 den Kalibrierzyklus und startet bei zu langer Sperre eigenständig eine Zwangskalibrierung. Die Zeit nach der die Klemme diese Zwangskalibrierung durchführt, wird im Register R44 als Vielfaches von Register R40 vorgegeben. Die Referenzspannung wird bei jeder Messung mit Register R45 (Einheit 1 mV) verglichen. Liegt sie unterhalb dieses Grenzwertes, wird Bit R0.14 gesetzt.
Sollte es notwendig sein eine manuelle Prüfung durchzuführen, wird diese durch Bit CB1.0 des Control-Bytes gestartet. Den Abschluss einer Prüfung wird mit Bit R0.4 im Register R0 (Status-Wort) signalisiert. Das Ergebnis der letzten Prüfung wird als Differenz der beiden Analogeingänge dargestellt und kann durch Bit CB1.2 des Control-Bytes in die Register R1 bis R3 und R5 eingeblendet werden. Es liegen gültige Kalibrierdaten vor, wenn Bit R0.5 im Register 0 (Status-Wort) auf 1bin gesetzt ist. Um einer Veränderung der Kalibrierdaten vorzubeugen, kann durch Bit CB1.3 ein Registerschreibschutz gesetzt werden (wird in Bit SB1.3 quittiert)
Manueller Betrieb
▪
Gegebenenfalls kann es notwendig sein, die direkten Werte des A/D-Wandlers zu betrachten. Die Klemme kann zu diesem Zweck in den manuellen Betrieb geschaltet werden. Tragen Sie hierzu zuerst das Anwender-Kodewort (1235hex) in das Kodewort-Register R31 ein, um den Schreibschutz der Anwender-Register aufzuheben.
▪
Anschließend tragen Sie den Wert 0401hex in das Kommando-Register (R7) ein um auf manuellen Betrieb Umzuschalten. Wenn Sie den Wert 0 in das Register R7 schreiben wird der manuelle Betrieb wieder beendet.
Im manuellen Betrieb gibt der Wert im Ausgangswort RegOUT die Stellung der Eingangs-Schalter vor (siehe Tabelle Schalterstellungen). Sie können mit Bit CB1.1 des Control-Bytes zwischen OP1 und OP2 umschalten (CB1.1=0bin: OP1; CB1.1 =1bin: OP2).
Sobald Sie die Klemme wieder in den normalen Betrieb schalten, wird automatisch eine Zwangskalibrierung durchgeführt.
Fehlerdiagnose
Die KL3356 besitzt eine interne Fehlerdiagnose. Die oberen 8 Bit des Registers R0 (Status-Wort) geben aufgetretene Fehler wieder.
Damit der Anwender nicht laufend das Register R0 auslesen muss, wird eine Änderung der Fehler-Bits (wenn z. B. ein neuer Fehler aufgetreten ist oder ein vorhandener Fehler beseitigt wurde) im Bit SB1.6 des Status-Bytes 1 angezeigt. Alle auftretenden Fehler werden temporär gespeichert und von der Klemme selbstständig nicht gelöscht. Durch Setzen des Bits CB1.6 im Control-Byte 1 können Sie das Fehler-Bit SB1.6 zurücksetzen.
Messwert Stabilisierung
Bei der Selbstkalibrierung werden wie oben beschrieben diverse Signale intern geschaltet. Nach Ablauf der Selbstkalibrierung gibt es je nach Einstellung von R32.9 (Stabilisierung der Kalibrierung) folgendes Verhalten:
▪
Stabilisierung aktiv (R32.9 = 1): die Klemme wartet, bis sich das Signal nach Vorgabe in Register R47/R48 eingeschwungen hat und gibt erst dann wieder Messwerte an den Bus aus – das verlängert die Pause bis die Klemme wieder misst und kann bei einem unruhigen Eingangssignal dazu führen, dass die Klemme bis zur Messung lang wartet.
▪
Stabilisierung inaktiv (R32.9 = 0): die Klemme schaltet umgehend das Messsignal wieder auf den Bus – das kann dazu führen, dass in dem Messwert ein Einschwingvorgang über mehrere Zyklen zu beobachten ist.


LEDs

Produktübersicht [image] LEDs
LEDs
LEDs
LED
Anzeige
Power
(grün)
EIN
Spannungsversorgung (5 V) auf dem K-Bus vorhanden
AUS
keine Spannungsversorgung (5 V) auf dem K-Bus vorhanden
K-Bus
(grün)
EIN
Datenübertragung auf dem K-Bus aktiv
AUS
Datenübertragung auf dem K-Bus nicht aktiv
Calibr.
(grün)
EIN
Kalibrierung aktiv
AUS
▪
Prüfung aktiv (wenn LED Measure nicht leuchtet) oder
▪
Messung aktiv (wenn LED Measure leuchtet)
Measure
(grün)
EIN
Messung aktiv (Prozessdaten sind gültig)
AUS
▪
Kalibrierung aktiv (wenn LED Calibr. leuchtet) oder
▪
Prüfung aktiv (wenn LED Calibr. nicht leuchtet)
Diff.
(grün)
EIN
▪
Differenzsignal wird kalibriert (wenn LED Calibr. leuchtet) oder
▪
Differenzsignal wird geprüft (wenn LED Calibr. nicht leuchtet)
Ref.
(grün)
EIN
▪
Referenzsignal wird kalibriert (wenn LED Calibr. leuchtet) oder
▪
Referenzsignal wird geprüft (wenn LED Calibr. nicht leuchtet)
Err. Diff.
(rot)
EIN
▪
Kanal 1 (DMS-Differenzsignal) ist oberhalb des gültigen Wertebereiches (max. 0xFFFF)
▪
interne Referenzspannung von Kanal 1 fehlt
Err. Ref
(rot)
EIN
▪
Kanal 2 (DMS-Referenzsignal) oberhalb des gültigen Wertebereiches (max. 0xFFFF)
▪
interne Referenzspannung von Kanal 2 fehlt
▪
Kanal 2 ist kleiner als ca. 1V
▪
keine Kommunikation mit dem A/D-Wandler
▪
Istwert der Prüfung liegt außerhalb der vorgegebenen Toleranz


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss
•
Applikationsbeispiel
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX-Dokumentation


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung
•
Anschlussbelegung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Anschlussbelegung

Montage und Verdrahtung [image] Anschluss [image] Anschlussbelegung
Anschlussbelegung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschlussbelegung
Klemmstelle | Nr. | Anschluss für
+UD | 1 | Messsignal
-UD | 2 | Messsignal
-UV | 3 | Versorgungsspannung, 0 V (von Powerkontakt)
Shield | 4 | PE-Kontakt
+Uref | 5 | Referenzsignal
-Uref | 6 | Referenzsignal
+UV | 7 | Versorgungsspannung, 5 bis 12 V (von Powerkontakt)
Shield | 8 | PE-Kontakt
Die Versorgungsspannung (UV) für die Messbrücke kann von einer Netzteilklemme (z. B. KL9510) in die Powerkontakte eingespeist werden und steht dann auch an den Klemmenstellen 7 (+UV) und 3 (-UV) der KL3356 zur Verfügung um an den Klemmestellen 5 und 6 referenziert zu werden.


Applikationsbeispiel

Montage und Verdrahtung [image] Applikationsbeispiel
Applikationsbeispiel
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschluss einer Wägezelle (z. B. 4 x 350 Ω) an die KL3356.
KL3356 - Applikationsbeispiel
Im dargestellten Beispiel wird zur Versorgung der Wägezelle die Netzteilklemme KL9510 (10 V) verwendet.
Beckhoff bietet verschiedene Netzteilklemmen zur Versorgung der Wägezellen einer KL3356 an:
Netzteilklemme | Eingangsspannung | Ausgangsspannung | Ausgangsstrom
KL9505 | 24 VDC | 5 VDC ±1% | 1,0 A
KL9510 | 24 VDC | 10 VDC ±1% | 0,5 A
KL9512 | 24 VDC | 12 VDC ±1% | 0,5 A


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Einstellungen
•
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Ethernet-Koppler BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine präzise Widerstandsbrückenklemme KL3356
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).
KS2000 Baumzweig für Kanal 1 de KL3356
Für die KL3356 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL3356.
▪
Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL3356.
▪
ProcData zeigt die Prozessdaten der KL3356.


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Unter Einstellungen finden Sie die Dialogmasken zur Parametrierung der KL3356.
Einstellungen über KS2000
Betriebsmodus
Anwender-Skalierung aktiv (R32.0)
Hier können Sie die Anwender-Skalierung aktivieren (default: deaktiviert). Es sind zwei Varianten (R32.10) wählbar:
▪
Skalierung (siehe Formel 1.3.0)
▪
Kalibrierung (siehe Formel 1.3.1)
Hersteller-Skalierung aktiv (R32.1)
Hier können Sie die Hersteller-Skalierung aktivieren (default: deaktiviert).
Skalierungsfaktor aktiv (R32.8)
Hier können Sie den Skalierungsfaktor deaktivieren (default: aktiviert).
Watchdog Timer aktiv (R32.2)
Hier können Sie den Watchdog Timer deaktivieren (default: aktiviert).
Zyklische Kalibrierung aktiv (R32.4)
Hier können Sie die zyklische Kalibrierung deaktivieren (default: aktiviert).
Zyklische Referenzmessung aktiv (R32.6)
Hier können Sie die zyklische Referenzmessung deaktivieren (default: aktiviert).
Zyklische Prüfung aktiv (R32.5)
Hier können Sie die zyklische Prüfung deaktivieren (default: aktiviert).
Symmetrisches Bezugspotential (R32.7)
Hier können Sie das symmetrisches Bezugspotential deaktivieren (default: aktiviert).
Stabilisierung der Kalibrierung aktiv (R32.9)
Hier können Sie die Stabilisierung der Kalibrierung deaktivieren (default: aktiviert). Die Stabilisierung der Kalibrierung kann über die Parameter Anzahl der stabilen Messwerte und Toleranz für Messwert-Stabilität parametriert werden.
Nennkennwertauflösung 0,01 mV/V (R32.11)
Hier können Sie eine Nennkennwertauflösung von 0,01 mV/V anstelle der Nennkennwertauflösung von 1 mV/V aktivieren (default: deaktiviert).
Warte nach Kalibrierung auf stabilen Messwert (R32.12)
Hier können Sie aktivieren, dass die KL3365 nach einer Kalibrierung oder Messung der Referenzspannung mit der Messwertausgabe wartet, bis der ausgegebene Gewichtswert stabil ist (default: deaktiviert).
Registerwerte
Nennlast (R35)
Hier können Sie die Nennlast der angeschlossenen Wägezelle in kg vorgeben (default: 5 kg).
Nennkennwert (R36)
Hier können Sie den Nennkennwert der angeschlossenen Wägezelle vorgeben (default: 2 mV / V).
Skalierungsfaktor (R38)
Hier können Sie den Skalierfaktor vorgeben (default: 1000).
Messintervall für Referenzsignal (R39)
Hier können Sie in Stufen von 100 ms das Messintervall für das Referenzsignal vorgeben (default: 360 s).
Kalibrierintervall (R40)
Hier können Sie in Stufen von 100 ms das Kalibrierintervall für das Referenzsignal vorgeben (default: 180 s).
Intervall für Zwangskalibrierung (R44)
Hier können Sie das Intervall für Zwangskalibrierung vorgeben. Dieses Intervall ist immer ein Vielfaches (default: 3dez) des Kalibrierintervalls. Somit ergibt sich im Auslieferungszustand ein Intervall für Zwangskalibrierung von 3 x 180 s = 540 s.
Prüfintervall (R41)
Hier können Sie das Prüfintervall vorgeben. Dieses Intervall ist immer ein Vielfaches (default: 10dez) des Kalibrierintervalls. Somit ergibt sich im Auslieferungszustand ein Prüfintervall von 10 x 180 s = 1800 s.
Prüfsollwert (R42)
Hier können Sie den Prüfsollwert der Klemme vorgeben (z. B. 332Chex = 13100dez).
Prüftoleranz (R43)
Hier können Sie den die Prüftoleranz der Klemme vorgeben (default: 50dez).
Grenzwert Referenzspannung (R45)
Hier können Sie in Stufen von 1 mV den Grenzwert für die Referenzspannungsprüfung vorgeben (default: 5000 mV). Liegt die Referenzspannung unterhalb dieses Grenzwertes, wird im Statuswort das Bit R0.14 gesetzt.
Grenzwert Korrekturfaktor (R46)
Hier können Sie den Grenzwert für den Korrekturfaktor (für Gain) vorgeben. Während der Kalibrierung wird für das Differenzsignal ein Korrekturfaktor ermittelt. Dieser ergibt sich aus dem Quotienten von Referenz- und Differenzsignal. Zur besseren Darstellung wird das Ergebnis auf 10000 normiert (URef / UDiff x 10000), d.h. 10000 entspricht dem Faktor 1. Liegt der Betrag der Differenz von 10000 und dem Korrekturfaktor (10000 - Korrekturfaktor) oberhalb dieses Grenzwertes, wird im Statuswort das Bit R0.15 gesetzt.
Anzahl der stabilen Messwerte (R47)
Hier können Sie für die Kalibrierungsstabilisierung die Anzahl der Messwerte (default: 50 Messwerte) vorgeben, die innerhalb der eingestellten Toleranz (R48) liegen müssen, damit.
Toleranz für Messwert-Stabilität (R48)
Hier können Sie für die Kalibrierungsstabilisierung die Toleranz (in Digit) vorgeben, die die Messwerte neben dem Referenzwert liegen dürfen (default: 5 Digit).
Manuelles Kalibriergewicht (R49)
Hier können Sie das Masse des Referenzgewichts für die manueller Kalibrierung vorgeben (default: 2000 Gramm).
Filterkonstante (R37.11-R37.4)
Die Filterkonstante SF legt die 3 dB Grenzfrequenz des sinc3 Filters fest (default: 860dez).
Fast-Step-Modus(TM) aktiv (R37.0)
Hier können Sie den Fast-Step-Modus aktivieren (default: deaktiviert). Im Fast-Step-Modus erfolgt trotz aktiver Filterstufe eine schnelle Reaktion auf Sprünge am Eingang. Das Filter wird in diesem Fall umgangen!
FIR-Filter aktiv (R37.1)
Hier können Sie das FIR-Filter deaktivieren (default: aktiviert).


Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314

Konfigurations-Software KS2000 [image] Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Anwenders zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Programmbeschreibung/ Funktion
Dieses Beispielprogramm (TwinCAT 3) erlaubt per AoE die Änderung einzelner Registerwerte der KL3314 wie die Auswahl des Element-Typs und charakteristische Einstellungen des Feature‑Registers R32 sowie die Anwenderskalierung Offset und Gain (R33/ R34) ähnlich wie per KS2000.
Einstellungen der KL3314 über die Visualisierung von TwinCAT 3
Es sollte mindestens die folgende Konfiguration vorhanden sein:
[Koppler (z.B. BK1120) oder embedded PC] + KL3314 + KL9010.
Download:
Vorbereitungen zum Starten des Beispielprogramms (tnzip - Datei/ TwinCAT 3)
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.tnzip -Archivdatei in einem temporären Ordner.
Öffnen des *. tnzip - Archives
▪
Wählen Sie die zuvor entpackte .tnzip Datei (Beispielprogramm) aus.
▪
Ein weiteres Auswahlfenster öffnet sich: wählen nun Sie das Zielverzeichnis, wo das Projekt gespeichert werden soll.
▪
Die generelle Vorgehensweise für die Inbetriebnahme der PLC bzw. dem Start des Programms kann u.a. den Klemmen‑Dokumentationen oder der EtherCAT‑Systemdokumentation entnommen werden.
▪
Das EtherCAT Gerät im Beispiel ist i.d.R. zuvor ihrem vorliegenden System bekannt zu machen. Verwenden Sie nach Auswahl des EtherCAT Gerätes im „Projektmappen-Explorer“ rechtsseitig den Karteireiter „Adapter“ und Klicken „Suchen...“:
Suche der bestehenden HW-Konfiguration zur bestehenden EtherCAT-Konfiguration
▪
Überprüfen der NetId: der Karteireiter „EtherCAT“ des EtherCAT Gerätes zeigt die konfigurierte NetId: .
Diese muss mit den ersten vier Zahlenwerten mit der Projekt‑NetId des Zielsystems übereinstimmen. Die NetId des Projektes kann oben in einem Textfeld der TwinCAT-Umgebung eingesehen werden. Ein pull-down Menü kann durch einen Klick rechts im Textfeld geöffnet werden; dort ist zu jeden Rechnernamen eines Zielsystems die NetId in Klammern angegeben.
▪
Ändern der NetId: mit einem Rechtsklick auf „Gerät EtherCAT“ im Projektmappen-Explorer öffnet sich das Kontextmenü, in dem „Ändern der NetId“ auszuwählen ist. Die ersten vier Zahlen der NetId des Projektes sind einzutragen. die beiden letzten Werte sind i.d.R. 4.1.
Beispiel:
–
NetId des Projektes: myComputer (123.45.67.89.1.1)
–
Eintrag per „Change NetId...“: 123.45.67.89.4.1


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Mapping
•
Control- und Status-Bytes
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Die KL3356 stellt sich im Prozessabbild immer mit 6 Byte Ein- und 6 Byte Ausgangsdaten dar.
Format | Eingangsdaten | Ausgangsdaten
Byte | Status-Byte (SB1) | Control-Byte (CB1)
Wort | DataIN1 | DataOUT1
Byte | Status-Byte (SB2) | Control-Byte (CB2)
Wort | DataIN2 | DataOUT2 (wird nicht genutzt und vom TwinCAT System Manager auch nicht angezeigt)
▪
Das Eingangsdatenwort DataIN1 und das Ausgangsdatenwort DataOUT1 werden nur zur Registerkommunikation genutzt.
▪
Im Prozessdatenbetrieb wird im Eingangsdatenwort DataIN2 das Gewicht übertragen und das Ausgangsdatenwort DataOUT2 nicht benutzt.
▪
Die Zuordnung der Bytes und Worte zu den Adressen der Steuerung entnehmen Sie bitte der Seite Mapping.
▪
Die Bedeutung der Control- und Status-Bytes entnehmen Sie bitte der Seite Control- und Status-Bytes.
Kompaktes Prozessabbild nicht möglich
Ein Betrieb der KL3356 mit kompaktem Prozessabbild (ohne Control- und Status-Bytes) ist nicht möglich, da Control- und Status-Bytes für einen sinnvollen Prozessdatenbetrieb der KL3356 erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen wird die KL3356 mit ihrem kompletten Prozessabbild dargestellt!


Mapping

Zugriff aus dem Anwenderprogramm [image] Mapping
Mapping
Die Busklemmen belegen Adressen im Prozessabbild der Steuerung. Die Zuordnung der Prozessdaten (Ein- und Ausgangsdaten) und Parametrierungsdaten (Control- und Status-Bytes) zu den Steuerungsadressen wird als Mapping bezeichnet. Die Art des Mappings ist abhängig von:
▪
dem verwendeten Feldbus-System
▪
dem Klemmentyp
▪
der Parametrierung des Buskopplers (Bedingungen) wie
–
Intel- oder Motorola-Format
–
Word-Alignment ein- oder ausgeschaltet
Die Buskoppler (BKxxxx, LCxxxx) und Busklemmen Controller (BCxxxx, BXxxxx) werden mit bestimmten Voreinstellungen (Default-Einstellungen) ausgeliefert. Mit der Konfigurationssoftware KS2000 oder mit einer Master-Konfigurationssoftware (z. B. TwinCAT System Manager oder ComProfibus) können Sie diese Default-Einstellungen verändern.
Die folgenden Tabellen zeigen das Mapping in Abhängigkeit der verschiedenen Bedingungen. Die Inhalte der einzelnen Bytes entnehmen Sie bitte den Seiten Prozessabbild sowie Control- und Status-Bytes.
Kompakte Auswertung
Kompaktes Prozessabbild nicht möglich
Ein Betrieb der KL3356 mit kompaktem Prozessabbild (ohne Control- und Status-Bytes) ist nicht möglich, da Control- und Status-Bytes für einen sinnvollen Prozessdatenbetrieb der KL3356 erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen wird die KL3356 mit ihrem kompletten Prozessabbild dargestellt!
Komplette Auswertung
Bei kompletter Auswertung belegen die analogen Eingangsklemmen Adressen im Ein- und im Ausgangsprozessabbild. Der Zugriff auf Control- und Status-Bytes ist möglich.
Komplette Auswertung im Intel-Format
Default-Mapping für CANopen-, CANCAL-, DeviceNet-, ControlNet-, Modbus-, RS232- und RS485-Koppler
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: nein | 0 | DataIN1 D0 | SB1 | DataOUT1 D0 | CB1
 | 1 | SB2 | DataIN1 D1 | CB2 | DataOUT1 D1
 | 2 | DataIN2 D1 | DataIN2 D0 | DataOUT2 D1 | DataOUT2 D0
Komplette Auswertung im Motorola-Format
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: nein | 0 | DataIN1 D1 | SB1 | DataOUT1 D1 | CB1
 | 1 | SB2 | DataIN1 D0 | CB2 | DataOUT1 D0
 | 2 | DataIN2 D0 | DataIN2 D1 | DataOUT2 D0 | DataOUT2 D1
Komplette Auswertung im Intel-Format bei Word-Alignment
Default-Mapping für Lightbus-, EtherCAT und Ethernet-Koppler sowie Busklemmen Controller (BCxxxx, BXxxxx)
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | DataIN1 D1 | DataIN1 D0 | DataOUT1 D1 | DataOUT1 D0
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | DataIN2 D1 | DataIN2 D0 | DataOUT2 D1 | DataOUT2 D0
Komplette Auswertung im Motorola-Format bei Word-Alignment
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | DataIN1 D0 | DataIN1 D1 | DataOUT1 D0 | DataOUT1 D1
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | DataIN2 D0 | DataIN2 D1 | DataOUT2 D0 | DataOUT2 D1
Legende
Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Worte immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.
SB n: Status-Byte n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte n (erscheint im Ausgangsprozessabbild)
DataIN n D0: Eingangswort n, niederwertiges Daten-Byte
DataIN n D1: Eingangswort n, höherwertiges Daten-Byte
DataOUT n D0: Ausgangswort n, niederwertiges Daten-Byte
DataOUT n D1: Ausgangswort n, höherwertiges Daten-Byte
reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
DataOUT2
Das Prozessdatenwort DataOUT2 wird nicht benutzt und vom TwinCAT System Manager auch nicht angezeigt.


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Bytes
Control- und Status-Bytes
Registerkommunikation
Control-Byte 1 (für Registerkommunikation)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIN1 lesen oder - mit dem Ausgangsdatenwort DataOUT1 beschreiben wollen.
Status-Byte 1 (für Registerkommunikation)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Verwendung der Control- und Status-Bytes
Im Gegensatz zu anderen Klemmentypen sind bei der KL3356 die angezeigten Prozessdaten auch während der Registerkommunikation gültig!
Die KL3356 verwendet
•
Control-Byte 0 und Status-Byte 0 ausschließlich für die Registerkommunikation
•
Control-Byte 1 und Status-Byte 1 ausschließlich für den Prozessdatenbetrieb
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Prozessdatenbetrieb
Control-Byte 2 (für Prozessdatenbetrieb)
Das Control-Byte 2 (CB2) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB2.7 | CB2.6 | CB2.5 | CB2.4 | CB2.3 | CB2.2 | CB2.1 | CB2.0
Name | - | Quit Error | - | MapCaliCounter | RegLockReq | MapCaliData/ DisableSymm | CaliDisReq/ Channel | StartManCheck/ StartManCali
Legende
Bit | Name | Beschreibung
CB2.7 | - | 0bin | reserviert
CB2.6 | QuitError | 1bin | alle Fehler werden gelöscht
CB2.5 | - | 0bin | reserviert
CB2.4 | MapCaliCounter | 0bin | In die Register R2, R3 und R5 werden die mit Bit CB2.2 ausgewählten Daten eingeblendet.
 |  | 1bin | In die Register R2, R3 und R5 werden die Kalibrierungszähler eingeblendet (hierzu muss außerdem das Bit CB2.3 auf 0bin gesetzt sein). (siehe folgenden Hinweis)
Auswertung der Kalibrierungszähler erfolgt durch die KL3356
Die Kalibrierungszähler sind ein Maß für die Qualität der Selbstkalibrierung. Ihre Auswertung durch den Anwender ist in Standardanwendungen nicht erforderlich, da die KL3356 diese Zähler selbst auswertet und eine Überschreitung der zulässigen Toleranzen mit Bit 0.8 oder Bit 0.15 des Statusworts (R0) meldet.
Bit
Name
Beschreibung
CB2.3
RegLockReq
0bin
Register-Lock nicht aktiv:
▪
Die KL3356 kann die Werte in Register R1, R2, R3 und R5 aktualisieren.
▪
Durch das Setzen von Bit CB2.4 auf 1bin, können Sie die Kalibrierungszähler in die Register R2, R3, und R5 einblenden.
1bin
Register-Lock aktiv:
▪
Die KL3356 aktualisiert die Register R1, R2, R3 und R5 nicht mehr.
▪
Bit CB2.4 wird nicht ausgewertet!
normaler Betrieb
manueller Betrieb*
CB2.2
MapCaliData/
DisableSymm
0bin
Die Messwert-Register enthalten die gemappten Rohdaten der Wandler:
▪
R1: das berechnete Gewicht
▪
R2: das DMS-Messsignal
▪
R3: das DMS-Referenzsignal
▪
R5: den letzten Prüf-Istwert
Die symmetrische Messung ist eingeschaltet, wenn sie durch das Bit R32.7 des Feature-Registers aktiviert wurde.
1bin
Die Messwert-Register enthalten die gemappten Kalibrierdaten:
▪
R1: reserviert (Register ist leer)
▪
R2: den Offset-Fehler des Mess-Signals
▪
R3: den Offset-Fehler des Referenzsignals
▪
R5: den Korrekturfaktor für das Differenzsignal
Die symmetrische Messung ist ausgeschaltet, auch wenn sie durch das Bit R32.7 des Feature-Registers aktiviert wurde.
CB2.1
CaliDisReq/
Channel
0bin
Status-Bit ForcedCali (SB2.4) wird gelöscht
Auswahl des Messkanals UDiff
1bin
Sperrung der automatischen Kalibrierung
Auswahl des Messkanals URef
CB2.0
StartManCheck/
StartManCali
1bin
Prüfung starten
Kalibrierung und Prüfung starten
*) Der manuelle Betrieb kann über das Kommando-Register (R7) aktiviert werden.
Status-Byte 2 (für Prozessdatenbetrieb)
Das Status-Byte 2 (SB2) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB2.7 | SB2.6 | SB2.5 | SB2.4 | SB2.3 | SB2.2 | SB2.1 | SB2.0
Name | - | Error | - | ForcedCali | RegLockAck | NoActualValue | CaliDisAck/Channel | NegWeight
Legende
Bit | Name | Beschreibung
SB2.7 | - | 0bin | reserviert
SB2.6 | Error | 1bin | interner Fehler
SB2.5 | - | 0bin | reserviert
SB2.4 | ForcedCali | 1bin | Es wurde eine Zwangskalibrierung durchgeführt.
SB2.3 | RegLockAck | 1bin | Quittung für Schreibschutz aller Register
SB2.2 | NoActualValue | 1bin | Die angezeigten Prozessdaten sind nicht gütig.
SB2.1 | CaliDisAck/ Channel |  | normaler Betrieb | manueller Betrieb*
 |  | 0bin | - | ausgewählter Messkanal: UDiff
 |  | 1bin | Quittung für Sperrung der Kalibrierung | ausgewählter Messkanal: URef
SB2.0 | NegWeight | 0bin | Prozessdaten sind positiv
 |  | 1bin | Prozessdaten sind negativ
*) Der manuelle Betrieb kann über das Kommando-Register (R7) aktiviert werden.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Alle Register können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register R0 bis R31 (direkter Zugriff)
Diese Register dienen zur Parametrierung der KL3356.
Register-Nr.
Kommentar
Default-Wert
R/W
Speicher
R0
Statuswort
0x0000
0dez
R
RAM
R1
Messwert-Register 1*:
▪
berechnetes Gewicht (Rohwert ohne Skalierungen)
▪
nichts
0x0000
0dez
R
RAM
R2
Messwert-Register 2*:
▪
DMS-Messsignal oder
▪
Offset-Fehler des Mess-Signals oder
▪
Kalibrierungszähler 0
0x0000
0dez
R
RAM
R3
Messwert-Register 3*:
▪
DMS-Referenzsignal oder
▪
Offset-Fehler des Referenzsignals oder
▪
Kalibrierungszähler 1
typisch 0xF618
typisch 63000dez
R
RAM
R4
Registerpage-Auswahlregister
0x0000
0dez
R/W
RAM
R5
Messwert-Register 4*:
▪
letzter Prüfistwert oder
▪
Korrekturfaktor für Differenzsignal oder (Faktor x 10000) oder
▪
Kalibrierungszähler 2
0x0000
0dez
R
RAM
R6
Diagnose-Register
0x0000
0dez
R
RAM
R7
Kommando-Register
0x0000
0dez
R/W
RAM
R8
Klemmentyp
0x0D1C
3356dez
R
ROM
R9
Firmware-Stand
z. B. 0x3141
z. B. 12609dez
R
ROM
R10
Multiplex-Schieberegister
0x0130
304dez
R
ROM
R11
Signalkanäle
0x0130
304dez
R
ROM
R12
minimale Datenlänge
0x3030
18dez
R
ROM
R13
Datenstruktur
0x0007
7dez
R
ROM
R14
reserviert
-
-
-
-
R15
Alignment-Register
typisch 0x7F80
typisch 32640dez
R/W
RAM
R16
Hardware-Versionsnummer
z. B. 0x0000
z. B. 0dez
R/W
SEEPROM
R17
reserviert
-
-
-
-
R18
reserviert
-
-
-
-
R19
Hersteller-Skalierung: Offset
typisch 0x0000
typisch 0dez
R/W
SEEPROM
R20
Hersteller-Skalierung: Gain
typisch 0x0100
typisch 256dez
R/W
SEEPROM
R21
reserviert
-
-
-
-
...
reserviert
-
-
-
-
R30
reserviert
-
-
-
-
R31
Kodewort-Register
0x0000
0dez
R/W
RAM
*) abhängig von Bit CB2.2 und Bit CB2.4 des Control-Bytes 2
Registerpage 0 (Zugriff auswählbar über Register R4)
Auch diese Register dienen zur Parametrierung der KL3356.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R32 | Feature-Register | 0x0380 | 896dez | R/W | SEEPROM
R33 | Anwender-Offset | 0x0000 | 0dez | R/W | SEEPROM
R34 | Anwender-Gain | 0x0800 | 2048dez | R/W | SEEPROM
R35 | Nennlast | 0x0005 | 5dez | R/W | SEEPROM
R36 | Nennkennwert | 0x0002 | 2dez | R/W | SEEPROM
R37 | Filterkonstante des A/D-Wandlers und Konfigurationsbits für die Filter | 0x35C0 | 13760dez | R/W | SEEPROM
R38 | Skalierfaktor | 0x03E8 | 1000dez | R/W | SEEPROM
R39 | Messintervall für Referenzsignal ****) | 0x0E10 | 3600dez | R/W | SEEPROM
R40 | Kalibrierintervall ****) | 0x0708 | 1800dez | R/W | SEEPROM
R41 | Prüfintervall *****) | 0x000A | 10dez | R/W | SEEPROM
R42 | Prüfsollwert | typisch 0x332C | typisch 13100dez | R/W | SEEPROM
R43 | Prüftoleranz | 0x0032 | 50dez | R/W | SEEPROM
R44 | Intervall für Zwangskalibrierung *****) | 0x0003 | 3dez | R/W | SEEPROM
R45 | Grenzwert für Referenzspannungsprüfung | 0x1388 | 5000dez | R/W | SEEPROM
R46 | Grenzwert für Korrekturfaktor | 0x0064 | 100dez | R/W | SEEPROM
R47 | Kalibrierungsstabilisierung: - Anzahl der stabilen Messwerte | 0x0032 | 50dez | R/W | SEEPROM
R48 | Kalibrierungsstabilisierung: - Toleranz für Messwert-Stabilität (in Digit) | 0x0005 | 5dez | R/W | SEEPROM
R49 | Gewicht für manuelles Kalibrieren | 0x7D0 | 2000dez | R/W | SEEPROM
R50 | reserviert | - | - | - | -
... | reserviert | - | - | - | -
R63 | reserviert | - | - | - | -
****) in Vielfachen von 100 ms
*****) in Vielfachen von Register R40
Registerpage 1 (Zugriff auswählbar über Register R4)
Frei verfügbarer SEEPROM-Speicher.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R32 | frei verfügbar | - | - | R/W | SEEPROM
... | frei verfügbar | - | - | R/W | SEEPROM
R63 | frei verfügbar | - | - | R/W | SEEPROM
Registerpage 2 (Zugriff auswählbar über Register R4)
Frei verfügbarer SEEPROM-Speicher.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R32 | frei verfügbar | - | - | R/W | SEEPROM
... | frei verfügbar | - | - | R/W | SEEPROM
R63 | frei verfügbar | - | - | R/W | SEEPROM


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Alle Register können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register R0 bis R31 (direkter Zugriff)
Diese Register dienen zur Parametrierung der KL3356.
R0: Statuswort
Das Statuswort beinhaltet Informationen über interne Signale und gibt Auskunft über aufgetretene Fehler.
Bit | Name | Beschreibung
R0.15 | GainError | 1bin | Die Abweichung des Gain-Korrekturfaktors ist größer als im Register R46 vorgegeben.
R0.14 | LowVoltageCh2 | 1bin | Das DMS-Referenzsignal ist kleiner als im Register R45 vorgegeben.
R0.13 | NoRefCh2 | 1bin | Die interne Referenzspannung von Kanal 2 (DMS-Referenzsignal) fehlt.
R0.12 | NoRefCh1 | 1bin | Die interne Referenzspannung von Kanal 1 (DMS-Differenzsignal) fehlt.
R0.11 | OverloadCh2 | 1bin | Das DMS-Referenzsignal ist oberhalb des gültigen Wertebereiches (max. 0xFFFF)
R0.10 | OverloadCh1 | 1bin | Das DMS-Differenzsignal ist oberhalb des gültigen Wertebereiches (max. 0xFFFF)
R0.9 | ADCError | 1bin | Keine Kommunikation mit dem A/D-Wandler.
R0.8 | TestError | 1bin | Der Istwert der Prüfung liegt außerhalb der vorgegebenen Toleranz.
R0.7 | - | reserviert
R0.6 | MapCaliCounter | 1bin | Quittung zu CB2.4. In die Register R2, R3 und R5 werden die Kalibrierungszähler eingeblendet.
R0.5 | CaliDataMapped | 1bin | Quittung zu CB2.2. In die Register R2, R3 und R5 werden die letzten Prüfergebnisse eingeblendet.
R0.4 | ManCheckDone | 1bin | Die manuelle Prüfung, die mit CB2.0 gestartet wurde, ist abgeschlossen.
R0.3 | TestActive | 1bin | Die manuelle Prüfung ist aktiv.
R0.2 | CaliActive | 1bin | Die Kalibrierung (manuell oder automatisch) ist aktiv.
R0.1 | NegSignalCh2 | 1bin | Das DMS-Referenzsignal ist negativ.
R0.0 | NegSignalCh1 | 1bin | Das DMS-Differenzsignal ist negativ.
R1: Messwert-Register 1
▪
Rohdaten der Wandler:
Wenn das Control-Bit CB2.2 nicht gesetzt ist, wird in Register R1 das nach den Formeln 1.0 und 1.1 berechnete Gewicht angezeigt.
▪
Wenn das Control-Bit CB2.2 gesetzt ist, wird in Register R1 nichts angezeigt.
▪
Wenn das Control-Bit CB2.4 gesetzt ist, wird in Register R1 nichts angezeigt.
R2: Messwert-Register 2
▪
Rohdaten der Wandler:
Wenn das Control-Bit CB2.2 nicht gesetzt ist, wird in Register R2 das DMS-Messsignal angezeigt.
▪
Kalibrierdaten:
Wenn das Control-Bit CB2.2 gesetzt ist, wird in Register R2 die Vorlast des Messsignal-Eingangs angezeigt.
▪
Kalibrierungszähler 0:
Wenn das Control-Bit CB2.4 gesetzt ist, wird in Register R2 die Anzahl der Messwerte angezeigt, die mit dem 1. Messwert identisch waren.
R3: Messwert-Register 3
▪
Rohdaten der Wandler:
Wenn das Control-Bit CB2.2 nicht gesetzt ist, wird in Register R3 das DMS-Referenzsignal angezeigt.
▪
Kalibrierdaten:
Wenn das Control-Bit CB2.2 gesetzt ist, wird in Register R3 die Vorlast des Referenzsignal-Eingangs angezeigt.
▪
Kalibrierungszähler 1:
Wenn das Control-Bit CB2.4 gesetzt ist, wird in Register R3 die Anzahl der Messwerte angezeigt, die kleiner waren als der 1. Messwert.
R4: Registerpage-Auswahlregister
Durch Schreiben in Register R4 kann auf weitere Registerpages zugegriffen werden. Der in Register R4 eingetragene Wert wird übernommen, wenn die gewünschte Registerpage vorhanden ist. Sollte das nicht der Fall sein, wird der letzte Wert beibehalten.
Registerinhalt R4 | Die Registernummern R32 bis R63 ermöglichen den Zugriff auf
0x0000 | Register-Page 0: Konfigurations-Register R32 bis R63
0x0001 | Register-Page 1: 32 Worte frei verfügbarer SEEPROM Speicher
0x0002 | Register-Page 2: 32 Worte frei verfügbarer SEEPROM Speicher
0x0003 bis 0xFFFF | reserviert
R5: Messwert-Register 4
▪
Rohdaten der Wandler:
Wenn das Control-Bit CB2.2 nicht gesetzt ist, wird in Register R5 der letzte Prüf-Istwert angezeigt.
▪
Kalibrierdaten:
Wenn das Control-Bit CB2.2 gesetzt ist, wird in Register R5 der Korrekturfaktor für das Differenzsignal (Faktor x 10000) angezeigt.
▪
Kalibrierungszähler 2:
Wenn das Control-Bit CB2.4 gesetzt ist, wird in Register R5 die Anzahl der Messwerte angezeigt, die größer waren als der 1. Messwert.
R6: Diagnose-Register
In Register R6 wird das Status-Byte SB2 eingeblendet.
R7: Kommando-Register
Anwender-Kodewort
Um ein Kommando auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein.
Kommando 0x0101: Anwender-Kalibrierung - Offset
Mit dem Eintrag 0x0101 in Register R7 gleicht die KL3356 den Anwender-Offset ab und trägt den Abgleichwert in Register R33 ein.
Der Abgleichwert geht in die Gewichtsmessung ein, wenn Bit R32.0 gesetzt ist.
Kommando 0x0102: Anwender-Kalibrierung - Gain
Mit dem Eintrag 0x0102 in Register R7 gleicht die KL3356 den Anwender-Gain ab und trägt denn Abgleichwert in Register R34 ein.
Der Abgleichwert geht in die Gewichtsmessung ein, wenn Bit R32.0 gesetzt ist.
Kommando 0x0401: manueller Kalibriermodus
Mit dem Eintrag 0x0401 in Register R7 wird der manuelle Kalibriermodus aktiviert. Hat die Klemme den Wert übernommen, kann durch
▪
CB2.1 = 0 auf den Analogwandler UDiff
▪
CB2.1 = 1 auf den Analogwandler URef
umgeschaltet werden. Mit dem Ausgangsdatenwort DataOUT1 können Sie die Betriebsart der KL3356 verändern.
Kommando 0x7000: Restore Factory Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register die Werte des Auslieferungszustands wiederhergestellt:
R19: 0
R20: 0x0100
R32: 0x0380
R33: 0
R34: 0x0800
R35: 5
R36: 2
R37: 0x35C0
R38: 1000dez
R39: 3600dez
R40: 1800dez
R41: 10dez
R43: 50dez
R44: 3
R45: 5000dez
R46: 100dez
R47: 50dez
R48: 5
R49: 2000dez
R8: Klemmenbezeichnung
Im Register R8 steht die Bezeichnung der Klemme. KL3356: 0x0D1C (3356dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme, dieser Wert kann nicht verändert werden.
R19: Hersteller-Skalierung - Offset
Dieses Register beinhaltet den Offset der Hersteller-Skalierung. Die Hersteller-Skalierung kann durch R32.1 im Feature-Register aktiviert werden.
R20: Hersteller-Skalierung - Gain
Dieses Register beinhaltet den Gain der Hersteller-Skalierung (16 Bit unsigned Integer x 2-8 + 1).
Beispiele:
0x0080 (128dez) bedeutet Faktor 0,5
0x0100 (256dez) bedeutet Faktor 1,0
Die Hersteller-Skalierung kann durch R32.1 im Feature-Register aktiviert werden.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
Register-Page 0 (Zugriff auswählbar über Register R4)
Auch diese Register dienen zur Parametrierung der KL3356.
R32: Feature-Register
Das Feature-Register legt die Konfiguration der Klemme fest.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | WaitForStableValue | ScalingUnit | enUsrCali | enStabCali | enScaling
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | enSymm | disRef | disTest | disCali | - | disWdTimer | enManScal | enUsrScal
Legende
Bit | Name | Beschreibung |  | Default
R32.15 | - | reserviert |  | 0bin
... | ... | ... |  | ...
R32.13 | - | reserviert |  | 0bin
R32.12 | WaitFor StableValue | 0bin | Nach einer Kalibrierung oder Messung der Referenzspannung gibt die KL3365 den Messwert sofort aus. Es können noch kleine Peaks angezeigt werden. | 0bin
 |  | 1bin | Nach einer Kalibrierung oder Messung der Referenzspannung wartet die KL3365 mit der Messwertausgabe, bis der ausgegebene Gewichtswert stabil ist.
R32.11 | ScalingUnit | 0bin | Einheit von R35 = 1 mV/V | 0bin
 |  | 1bin | Einheit von R35 = 0,01 mV/V
R32.10 | enUsrCali | 0bin | Anwender-Skalierung (siehe Formel 1.3.0) ist aktiv, wenn Bit 32.0 gesetzt ist. | 0bin
 |  | 1bin | Anwender-Kalibrierung (siehe Formel 1.3.1) ist aktiv, wenn Bit 32.0 gesetzt ist.
R32.9 | enStabCali | 0bin | Stabilisierung der Kalibrierung nicht aktiv | 1bin
 |  | 1bin | Stabilisierung der Kalibrierung aktiv
R32.8 | enScaling | 0bin | Skalierfaktor ist nicht aktiv | 1bin
 |  | 1bin | Skalierfaktor ist aktiv
R32.7 | enSymm | 0bin | symmetrische Messung nicht aktiv | 1bin
 |  | 1bin | symmetrische Messung aktiv
R32.6 | disRef | 0bin | zyklische Referenzmessung aktiv | 0bin
 |  | 1bin | zyklische Referenzmessung nicht aktiv
R32.5 | disTest | 0bin | zyklische Prüfung aktiv | 0bin
 |  | 1bin | zyklische Prüfung nicht aktiv
R32.4 | disCali | 0bin | zyklische Kalibrierung der A/D-Wandler aktiv | 0bin
 |  | 1bin | zyklische Kalibrierung der A/D-Wandler nicht aktiv
R32.3 | - | reserviert |  | 0bin
R32.2 | disWdTimer | 0bin | Watchdog-Timer aktiv (werden 100 ms keine Prozessdaten empfangen, löst der Watchdog aus) | 0bin
 |  | 1bin | Watchdog-Timer nicht aktiv
R32.1 | enManScal | 0bin | Hersteller-Skalierung nicht aktiv | 0bin
 |  | 1bin | Hersteller-Skalierung aktiv
R32.0 | enUsrScal | 0bin | Anwender-Skalierung und Anwender-Kalibrierung sind nicht aktiv | 0bin
 |  | 1bin | Anwender-Skalierung oder Anwender-Kalibrierung (abhängig von Bit 32.10) ist aktiv
R33: Anwender-Skalierung - Offset
Dieses Register beinhaltet den Offset der Anwender-Skalierung. Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden.
R34: Anwender-Skalierung - Gain
Dieses Register beinhaltet den Gain der Anwender-Skalierung (16 Bit unsigned Integer x 2-11 + 1).
Beispiele:
0x0400 (1024dez) bedeutet Faktor 0,5
0x0800 (2048dez) bedeutet Faktor 1,0
Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden.
R35: Nennlast der Wägezelle
In Register R35 wird die Nennlast der angeschlossenen Wägezelle eingetragen. Die Einheit ist 1 kg.
R36: Nennkennwert der Wägezelle
In Register R36 wird der Nennkennwert der angeschlossenen Wägezelle eingetragen. Die Einheit ist 1 mV / V.
R37: Filterkonstante des A/D-Wandlers und Konfigurationsbits für die Filter
Die KL3356 besitzt zwei Tiefpass-Filterstufen:
▪
Die erste Stufe besteht aus einem sinc3 Filter, welcher immer aktiv ist.
▪
Die zweite Stufe besteht aus einem FIR-Filter 22. Ordnung, welches deaktiviert werden kann
(FIR: Finite Impulse Response, also ein nicht rekursiver Filter).
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Filterkonstante SF (SF.11 bis SF.0) |  |  |  |  |  |  |  |  |  |  |  | Zero | Zero | SkipFIR | Fast
Legende
Bit | Name | Beschreibung | Default
R37.15 | Filterkonstante SF (SF.11 - SF.0) | Die Filterkonstante SF legt die 3dB Grenzfrequenz des sinc3 Filters fest. Der Wertebereich erstreckt sich von 150 bis 2047. Die 3 dB Grenzfrequenz FGrenz bzw. die 64,5 dB Stoppfrequenz FStop werden wie folgt berechnet: | 35Chex (860dez)
...
R37.4
SkipFIR = 0 | FGrenz = 11981 / SF
 | FStop = 43008 / SF
SkipFIR = 1 | FGrenz = 80486 / SF
Bit | Name | Beschreibung |  | Default
R37.3 | Zero | 0bin | (siehe folgenden Hinweis) | 0bin
R37.2 | Zero | 0bin |  | 0bin
Diese Bits nicht ändern
Die Bits R37.2 und R37.3 müssen immer 0bin sein, andernfalls treten Fehler im A/D-Wandler auf!
Bit | Name | Beschreibung |  | Default
R37.1 | SkipFIR | 0bin | FIR-Filter ist aktiviert. | 0bin
 |  | 1bin | FIR-Filter wird umgangen.
R37.0 | Fast | 0bin | Fast-Step-Modus ist deaktiviert. | 0bin
 |  | 1bin | Fast-Step-Modus ist aktiviert: trotz aktiver Filterstufe erfolgt eine schnelle Reaktion auf Sprünge am Eingang. Das Filter wird in diesem Fall umgangen!
Empfohlene Werte
Wert in R37 | FStop | Zykluszeit
0x35C0 | 50 Hz | 140 ms
0x2660 | 70 Hz | 100 ms
0x1330 | 140 Hz | 50 ms
0x7FF1 |  | 40 ms
0x3FF1 |  | 20 ms
0x1001 |  | <4 ms
Wert in R37 | FGrenz | Zykluszeit
0x7FF2 | 39,6 Hz | 40 ms
0x3FF2 | 77,36 Hz | 20 ms
0x1002 | 158 Hz | <4 ms
R38: Skalierfaktor
Dieses Register beinhaltet den Skalierfaktor.
Beispiele:
0x0001 (01dez) bedeutet Faktor 1
0x000A (10dez) bedeutet Faktor 10
Der Skalierfaktor kann im Feature-Register durch Bit R32.8 aktiviert werden.
R39: Messintervall für Referenzsignal
Dieses Register beinhaltet das Messintervall für die zyklische Referenzmessung. Die Einheit ist 100 ms. Die zyklische Referenzmessung kann im Feature-Register durch Bit R32.6 aktiviert werden.
R40: Kalibrierintervall
Dieses Register beinhaltet das Kalibrierintervall für die automatische Kalibrierung der Klemme. Die Einheit ist 100 ms. Die automatische Kalibrierung kann im Feature-Register durch Bit R32.4 aktiviert werden.
R41: Prüfintervall
Dieses Register beinhaltet das Prüfintervall für die zyklische Prüfung der Klemme. Dieses Intervall ist immer ein vielfaches (Default: 3dez) des Kalibrierintervalls (R40). Somit ergibt sich im Auslieferungszustand ein Prüfintervall von 10 x 180 s = 1800 s. Die zyklische Prüfung kann im Feature-Register durch Bit R32.5 aktiviert werden.
R42: Prüfsollwert
Dieses Register beinhaltet den Prüfsollwert der Klemme.
Bei der Produktion der Klemme wird der Prüfistwert von Register 5 ins das Prüfsollwert-Register R42 übertragen. Dieser Wert gibt Auskunft über eine Spannung, die sich durch eine interne Referenzspannungsquelle und einen Spannungsteiler ergibt.
Bei einer Kalibrierung wird überprüft, ob der Wert innerhalb der Toleranz gegeben durch Register R42 und Register R43 liegt. Damit kann eine Aussage gemacht werden, ob ein interner Defekt vorliegt (z. B. Analogschalter defekt).
Dieser Wert kann sich im Laufe der Zeit etwas verändern (durch Alterung der elektrischen Bauteile). Gegebenenfalls sollte deshalb von Zeit zu Zeit der Prüfistwert von Register R5 erneut in Register R42 übertragen werden. Dies kann bedenkenlos gemacht werden, da bei einem Fehler der Wert gegen 0 oder 65535 gehen wird.
R43: Prüftoleranz
Dieses Register beinhaltet die Prüftoleranz der Klemme (+/-).
R44: Intervall für Zwangskalibrierung
Dieses Register beinhaltet das Intervall für die Zwangskalibrierung der Klemme. Dieses Intervall ist immer ein vielfaches (Default: 3dez) des Kalibrierintervalls (R40). Somit ergibt sich im Auslieferungszustand ein Intervall für Zwangskalibrierung von 3 x 180 s = 540 s. Die Zwangskalibrierung kann im Feature-Register durch Bit R32.4 aktiviert werden.
Wenn Register R44 auf 0 gesetzt wird, wird die Zwangskalibrierung komplett ausgeschaltet.
R45: Grenzwert für Referenzspannungsprüfung
Dieses Register beinhaltet den Grenzwert für die Referenzspannungsprüfung. Die Einheit ist 1 mV. Liegt die Referenzspannung unterhalb dieses Grenzwertes, wird im Statuswort das Bit R0.14 gesetzt.
R46: Grenzwert für Korrekturfaktor
Dieses Register beinhaltet den Grenzwert für den Korrekturfaktor. Während der Kalibrierung wird für das Differenzsignal ein Korrekturfaktor ermittelt. Dieser ergibt sich, beim messen der internen Referenz, aus dem Quotienten von Referenz- und Differenzsignal. Zur besseren Darstellung wird das Ergebnis auf 10000 normiert (URef / UDiff x 10000), d.h. 10000 entspricht dem Faktor 1. Der Korrekturfaktor wird bei gemappten Kalibrierdaten in R5 ausgegeben. Liegt der Betrag der Differenz von 10000 und dem Korrekturfaktor (10000 - Korrekturfaktor) oberhalb dieses Grenzwertes, wird im Statuswort das Bit R0.15 gesetzt.
R47: Kalibrierungsstabilisierung - Anzahl der stabilen Messwerte
Default: 50
R48: Kalibrierungsstabilisierung - Toleranz für Messwert-Stabilität
Default: 5
R49: Gewicht für manuelles Kalibrieren
Default: 2000 Gramm
Register-Page 1 (Zugriff auswählbar über Register R4)
R32 bis R63: frei verfügbarer SEEPROM-Speicher
Die Register R32 bis R63 der Register-Page 1 sind frei verfügbare, nicht flüchtige Register, die zum Speichern von 2 x 32 Worten Anwenderdaten genutzt werden können. Da diese Werte im SEEPROM gespeichert werden, bleiben sie bei einem Neustart der Klemme erhalten.
Register-Page 2 (Zugriff auswählbar über Register R4)
R32 bis R63: frei verfügbarer SEEPROM-Speicher
Die Register R32 bis R63 der Register-Page 2 sind frei verfügbare, nicht flüchtige Register, die zum Speichern von 2 x 32 Worten Anwenderdaten genutzt werden können. Da diese Werte im SEEPROM gespeichert werden, bleiben sie bei einem Neustart der Klemme erhalten.


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.