KL320x - Analoge Eingangsklemmen für Pt100 (RTD) oder NTC10K
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
4.4
▪
Update Firm- und Hardware-Stände
▪
Update Kapitel „Grundlagen zur Funktion“
4.3
▪
Update Firm- und Hardware-Stände
▪
Update Technische Daten
▪
Kapitel "Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit" eingefügt
▪
Kapitel "TwinCAT" mit Link zu FB_KL320xConfig eingefügt
4.2
▪
KL3204-0030 hinzugefügt
4.1
▪
Anhang aktualisiert
4.0
▪
Migration in ST4
▪
Strukturupdate
Firm- und Hardware-Stände
Dokumentation Version | KL3201
 | Firmware | Hardware
4.4 | 3G | 09
4.3 | 3G | 09
4.0 | 3G | 08
Dokumentation Version | KL3202
 | Firmware | Hardware
4.4 | 3G | 09
4.3 | 3G | 09
4.0 | 3G | 08
Dokumentation Version | KL3204
 | Firmware | Hardware
4.4 | 3E | 05
4.3 | 3E | 05
4.0 | 3E | 05
Dokumentation Version | KL3204-0030
 | Firmware | Hardware
4.4 | 42 | 05
4.3 | 42 | 05
4.2 | 42 | 05
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 47 15 1A 00:
47 - Produktionswoche 47
15 - Produktionsjahr 2015
1A - Firmware-Stand 1A
00 - Hardware-Stand 00


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Grundlagen zur Funktion


Einführung

Produktübersicht [image] Einführung
Einführung
KL3201, KL3202
KL3201
KL3202
Die analogen Eingangsklemmen KL3201 und KL3202 erlauben den direkten Anschluss von Widerstandssensoren. Die Schaltung der Busklemmen kann Sensoren in 2- und 3-Leitertechnik betreiben.
Die Linearisierung über den gesamten Temperaturbereich wird durch einen Mikroprozessor realisiert. Der Temperaturbereich ist frei wählbar. Die Standardeinstellung der Busklemme ist: Auflösung 0,1°C im Temperaturbereich der PT100-Sensoren in 3-Leiteranschlusstechnik.
Die beiden Run-LEDs zeigen den Datenaustausch mit dem Buskoppler, die Error-LEDs zeigen Sensorstörungen (z. B. Drahtbruch) an.
KL3204-0000
KL3204-0000
Die analoge Eingangsklemme KL3204-0000 erlaubt den direkten Anschluss von vier Widerstandssensoren. Die Schaltung der Busklemme kann Sensoren in 2-Leitertechnik betreiben.
Die Linearisierung über den gesamten Temperaturbereich wird durch einen Mikroprozessor realisiert. Der Temperaturbereich ist frei wählbar. Die Standardeinstellung der Busklemme ist: Auflösung 0,1°C im Temperaturbereich der PT100-Sensoren.
Die Error-LEDs zeigen Sensorstörungen (z. B. Drahtbruch) an. Die KL3204 vereint vier Kanäle in einem Gehäuse.
KL3204-0030
KL3204-0030
Die analoge Eingangsklemme KL3204-0030 erlaubt den direkten Anschluss von vier NTC-Widerstandssensoren. Die Schaltung der Busklemme kann Sensoren in 2-Leitertechnik betreiben. Die Linearisierung über den gesamten Temperaturbereich wird durch einen Mikroprozessor realisiert. Die Standardeinstellung der Busklemme ist Auflösung 0,1°C im Temperaturbereich der NTC-10-kΩ-Sensoren. Die Error-LEDs zeigen Sensorstörungen (z. B. Drahtbruch) an. Die KL3204-0030 vereint vier Kanäle in einem Gehäuse.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten - KL3201, KL3202, KL3204, KL3204-0030
Technische Daten | KL3201 |  | KL3202 | KL3204-0000 | KL3204-0030
Anzahl der Eingänge | 1 |  | 2 | 4
Spannungsversorgung | über den K-Bus
Sensorarten | PT100, PT200, PT500, PT1000, Ni100, Ni120, Ni1000 Widerstandsmessung (z.B. Potentiometer-Anschluss) |  |  |  | NTC (10 kΩ)
Anschlusstechnik | 2 oder 3-Leiter (Voreinstellung: 3 Leiter) |  |  | 2-Leiter
Temperaturbereich | -200°C ... +850°C (PT-Sensoren), -60°C ... +250°C (Ni-Sensoren)
Auflösung | 0,1°C pro Digit (Messbereich 10 bis 5000 Ω: 0.5°C pro Digit)
Potentialtrennung | 500 V (K-Bus / Signalspannung)
Wandlungszeit | ~ 200 ms |  | ~ 250 ms
Messstrom | typisch 0,5 mA |  |  |  | typisch <0,5 mA
Messfehler (ges. Messbereich) | < ± 1°C |  | < ± 1 C (bei 0°C ... +55°C) < ± 1,5 C (bei Ausnutzung des erweiterten Temperaturbereichs)
Bitbreite im Prozessabbild | Input: 1 x 16 Bit Daten (1 x 8 Bit Control/ Status optional) |  | Input: 2 x 16 Bit Daten (2 x 8 Bit Control/ Status optional) | Input: 4 x 16 Bit Daten (4 x 8 Bit Control/ Status optional)
Stromaufnahme vom K-Bus | typisch 60 mA
Konfiguration | keine Adresseinstellung, Konfiguration über den Buskoppler oder die Steuerung
Besondere Eigenschaften | Drahtbrucherkennung
Gewicht | ca. 70 g
Zulässiger Umgebungstemperaturbereich (Betrieb) | 0°C ... +55°C |  | -25°C ... +60°C (erweiterter Temperaturbereich) |  | 0°C ... +55°C
Zulässiger Umgebungstemperaturbereich (Lagerung) | -25°C ... +85°C |  | -40°C ... +85°C |  | -25°C ... +85°C
relative Feuchte | 95% ohne Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27 siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit |  |  |  | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | beliebig
Schutzart | IP20
Zulassungen | CE, cULus, ATEX (Standardtemperaturbereich), GL | CE, cULus, ATEX (erweiterter Temperaturbereich), GL |  |  | CE


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Eigenschaften
Die analoge Eingangsklemmen KL320x erlauben den direkten Anschluss von Widerstandssensoren. Die Umrechnung und Linearisierung des Widerstandswertes in eine Temperatur erfolgt durch einen Micro-Controller in der Klemme. Die Temperaturen werden in folgender Skalierung ausgegeben:
▪
für KL3201, KL3202, KL3204, KL3204-0030:
–
Messbereich 10 bis 5000 Ω: 1/2 Ω (1 Digit = 0,5 Ω)
–
Messbereich 10 bis 1200 Ω: 1/10 Ω (1 Digit = 0,1 Ω)
–
alle anderen Messbereiche:1/10 °C (1 Digit = 0,1 °C)
▪
für KL3204-0030:
–
Messbereich -40°C bis 110°C: 1/10 °C (1 Digit = 0,1 °C)
–
Widerstand bei 0°C: 27 280 Ω
Hinweis: da es verschiedene NTC10K Typen gibt, charakterisiert dieser Wert die Kennlinie die in der KL3204-0030 hinterlegt ist
Darüber hinaus wird ein Drahtbruch bzw. Kurzschluss an den Buskoppler bzw. an die Steuerung gemeldet und durch die ERROR-LEDs angezeigt.
Als Widerstandssensoren sind die Elemente PT100, NI100, PT200, PT500, NI120, NI1000 und PT1000 sowie NTC10K bei der KL3204-0030 über ihren kompletten Messbereich implementiert. Die Klemme ist über einen Feldbus vollständig konfigurierbar, so kann z.B. eine selbstdefinierte Skalierung der Ausgabe erfolgen, oder es kann die Temperaturumrechnung abgeschaltet werden. In diesem Fall erfolgt die Ausgabe des Messwertes in einem Bereich von 10 Ω bis 1,2 kΩ mit einer Auflösung von 1/16 Ω (Die interne Auflösung des Widerstandswertes beträgt 1/255 Ω).
Ausgabeformat der Prozessdaten
Die Ausgabe des Messwertes erfolgt im Auslieferungszustand in 1/10° C Schritten in Zweierkomplement-Darstellung (integer). Es wird für jeden Widerstandssensor der komplette Messbereich ausgegeben. Über das Feature- Register sind andere Darstellungsarten anwählbar (z.B. Betrags-Vorzeichendarstellung, Siemens-Ausgabeformat).
Messwert | hexadezimale Ausgabe | Ausgabe in Signed-Integer
-250,0°C | 0xF63C | -2500
-200,0°C | 0xF830 | -2000
-100,0°C | 0xFC18 | -1000
-0,1°C | 0xFFFF | -1
0,0°C | 0x0000 | 0
0,1°C | 0x0001 | 1
100,0°C | 0x03E8 | 1000
200,0°C | 0x07D0 | 2000
500,0°C | 0x1388 | 5000
850,0°C | 0x2134 | 8500
Widerstandsgrenzen
▪
R > 400 Ω: Bit 1 und Bit 6 (Overrange- und Error-Bit) im Status-Byte werden gesetzt.
Die Linearisierung der Kennlinie wird mit den Koeffizienten der oberen Bereichsgrenze bis zum Endanschlag des A/D-Wandlers (ca. 500 Ω bei PT100) fortgesetzt.
▪
R<18 Ω: Bit 0 und Bit 6 (Underrange- und Error-Bit) im Status-Byte werden gesetzt.
Es wird die kleinste negativ Zahl ausgegeben (0x8001 entspricht -32767).
Bei Overrange bzw. Underrange wird die rote Error LED eingeschaltet.
Prozessdaten
Die Prozessdaten, die zum Klemmenbus übertragen werden, berechnen sich aus folgenden Gleichungen:
Variable | Bedeutung
X_RL | ADC-Wert der Zuleitung
X_RTD | ADC-Wert des Temperatursensors inklusive einer Zuleitung
X_R | ADC-Wert des Temperatursensors
A_a, B_a | Hersteller-Gain und Offsetabgleich (R17, R18)
A_h, B_h | Hersteller-Skalierung
A_w, B_w: | Anwender-Skalierung
Y_R | Widerstandswert des Temperatursensors
Y_T | gemessene Temperatur in 1/16 °C
Y_THS | Temperatur nach Herstellerskalierung (1/10 °C)
Y_TAS | Temperatur nach Anwenderskalierung
Y_AUS | Prozessdaten zur SPS
a) Berechnung des Widerstandswertes:
X_R = X_RTD-X_RL (1.0)
Y_R = A_a * (X_R - B_a) (1.1)
b) Linearisierung der Kennlinie:
Y_T = a1 * Y_R2 + b1* Y_R + c1 (1.2)
oder
Y_T = Y_R wenn Ausgabe in Ω (1.3)
c) weder Anwender noch Herstellerskalierung aktiv:
Y_AUS = Y_T (1.4)
d) Herstellerskalierung aktiv (Werkseinstellung):
Y_THS = A_h * Y_T + B_h (1.5)
Y_AUS = Y_THS
e) Anwenderskalierung aktiv:
Y_TAS = A_w * Y_T + B_w (1.6)
Y_AUS = Y_TAS
f) Hersteller- und Anwenderskalierung aktiv: (1.7)
Y_1 = A_h * Y_T + B_h
Y_2 = A_w * Y_1 + B_w
Y_AUS = Y_2
Datenfluss der KL320x


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschlusstechnik
•
Anschluss und LED-Beschreibung
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Anschluss und LED-Beschreibung

Montage und Verdrahtung [image] Anschluss und LED-Beschreibung
Anschluss und LED-Beschreibung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL3201
KL3201 – Anschluss und LEDs
Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
RL1 | 2 | Eingang RL
-R1 | 3 | Eingang -R1 (intern verbunden mit Klemmstelle 7)
Schirm | 4 | Schirm, FE (intern verbunden mit Klemmstelle 8)
n.c. | 5 | nicht belegt
n.c. | 6 | nicht belegt
-R1 | 7 | Eingang -R1 (intern verbunden mit Klemmstelle 3)
Schirm | 8 | Schirm, FE (intern verbunden mit Klemmstelle 4)
KL3202
KL3202 – Anschluss und LEDs
Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
RL1 | 2 | Eingang RL
-R1 | 3 | Eingang -R1 (intern verbunden mit Klemmstelle 7)
Schirm | 4 | Schirm, FE (intern verbunden mit Klemmstelle 8)
+R2 | 5 | Eingang +R2
RL2 | 6 | Eingang RL
-R2 | 7 | Eingang –R2 (intern verbunden mit Klemmstelle 3)
Schirm | 8 | Schirm, FE (intern verbunden mit Klemmstelle 4)
KL3204/ KL3204-0030
KL3204/ KL3204-0030 – Anschluss und LEDs
Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
- R1 | 2 | Eingang –R1
+R3 | 3 | Eingang +R3
-R3 | 4 | Eingang -R3
+R2 | 5 | Eingang +R2
-R2 | 6 | Eingang –R2
+R4 | 7 | Eingang +R4
-R4 | 8 | Eingang -R4
LED Beschreibung
LED | Farbe | Beschreibung
Run**) | grün | Ein: Normaler Betrieb Aus: Watchdog-Timer Overflow ist aufgetreten. Werden zum Buskoppler 100 ms keine Prozessdaten übertragen, so erlöschen die grünen LEDs
Error | rot | Ein: Es liegt ein Kurzschluss oder Drahtbruch am jeweiligen Kanal vor. Der Widerstandswert befindet sich im ungültigen Bereich der Kennlinie. Aus: Der Widerstandwert befindet sich im gültigen Bereich der Kennlinie.
**) nicht KL3204, KL3204-0030


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Bei den komplexen Klemmen können verschiedene Betriebsarten bzw. Funktionalitäten eingestellt werden. Das Kapitel Allgemeine Registerbeschreibung erläutert den Inhalt der Register, die bei allen komplexen Klemmen identisch sind.
Die klemmenspezifischen Register werden in dem darauf folgendem Kapitel erklärt.
Der Zugriff auf die internen Register der Klemme wird im Kapitel Registerkommunikation beschrieben.
Weiterführende Informationen
•
Mapping
•
Klemmenkonfiguration
•
Registerübersicht
•
Allgemeine Registerbeschreibung
•
Klemmenspezifische Registerbeschreibung
•
Control- und Status Byte
•
Registerkommunikation


Mapping

Zugriff aus dem Anwenderprogramm [image] Mapping
Mapping
Wie bereits im Kapitel Klemmenkonfiguration beschrieben wurde, wird jede Busklemme im Buskoppler gemappt. Dieses Mapping vollzieht sich im Auslieferungszustand mit den Voreinstellungen des Buskopplers für diese Klemme. Mit der Konfigurationssoftware KS2000 oder mit einer Master-Konfigurationssoftware (z.B. TwinCAT System Manager oder ComProfibus) können Sie diese Default-Einstellungen verändern.
Wenn die Klemmen komplett ausgewertet werden, belegen sie Speicherplatz im Eingangs- und Ausgangs-Prozessabbild.
Die folgenden Tabellen geben Auskunft darüber, wie sich die Klemmen, abhängig von den im Buskoppler eingestellten Bedingungen mappen.
Legende
▪
Komplette Auswertung:
Die Klemme wird mit Control- und Status-Byte gemappt.
▪
Motorola Format:
Einstellbar ist das Motorola oder Intel-Format
▪
Word-Alignment:
Die Klemme liegt auf einer Wortgrenze im Buskoppler.
▪
Ch n SB:
Status-Byte für Kanal n (erscheint im Eingangsprozessabbild).
▪
Ch n CB:
Control- Byte für Kanal n (erscheint im Ausgangsprozessabbild).
▪
Ch n D0:
Kanal n, Daten-Byte 0 (niederwertigste Byte)
▪
Ch n D1:
Kanal n, Daten-Byte 1 (höchstwertigste Byte)
▪
"-":
Dieses Byte wird von der Klemme nicht benutzt und belegt.
▪
res.: reserviert:
dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
Weiterführende Informationen
•
KL3201
•
KL3202
•
KL3204, KL3204-0030


KL3201

Zugriff aus dem Anwenderprogramm [image] Mapping [image] KL3201
KL3201
Default-Mapping für:
CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232, RS485
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | Ch0 D1 | Ch0 D0
 | 1 | - | -
 | 2 | - | -
 | 3 | - | -
Default-Mapping für:
PROFIBUS, Interbus
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | Ch0 D0 | Ch0 D1
 | 1 | - | -
 | 2 | - | -
 | 3 | - | -
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch0 D0 | Ch0 CB/SB
 | 1 | - | Ch0 D1
 | 2 | - | -
 | 3 | - | -
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch0 D1 | Ch0 CB/SB
 | 1 | - | Ch0 D0
 | 2 | - | -
 | 3 | - | -
Default-Mapping für:
Lightbus, EtherCAT, Ethernet und Busklemmen-Controller (BCxxxx, BXxxxx)
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D1 | Ch0 D0
 | 2 | - | -
 | 3 | - | -
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D0 | Ch0 D1
 | 2 | - | -
 | 3 | - | -


KL3202

Zugriff aus dem Anwenderprogramm [image] Mapping [image] KL3202
KL3202
Default-Mapping für:
CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232, RS485
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | Ch0 D1 | Ch0 D0
 | 1 | Ch1 D1 | Ch1 D0
 | 2 | - | -
 | 3 | - | -
Default-Mapping für:
PROFIBUS, Interbus
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | Ch0 D0 | Ch0 D1
 | 1 | Ch1 D0 | Ch1 D1
 | 2 | - | -
 | 3 | - | -
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch0 D0 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D1
 | 2 | Ch1 D1 | Ch1 D0
 | 3 | - | -
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch0 D1 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D0
 | 2 | Ch1 D0 | Ch1 D1
 | 3 | - | -
Default-Mapping für:
Lightbus, EtherCAT, Ethernet und Busklemmen-Controller (BCxxxx, BXxxxx)
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D1 | Ch0 D0
 | 2 | res. | Ch1 CB/SB
 | 3 | Ch1 D1 | Ch1 D0
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D0 | Ch0 D1
 | 2 | res. | Ch1 CB/SB
 | 3 | Ch1 D0 | Ch1 D1


KL3204, KL3204-0030

Zugriff aus dem Anwenderprogramm [image] Mapping [image] KL3204, KL3204-0030
KL3204, KL3204-0030
Default-Mapping für:
CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232, RS485
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | Ch0 D1 | Ch0 D0
 | 1 | Ch1 D1 | Ch1 D0
 | 2 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D1 | Ch3 D0
Default-Mapping für:
PROFIBUS, Interbus
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | Ch0 D0 | Ch0 D1
 | 1 | Ch1 D0 | Ch1 D1
 | 2 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D0 | Ch3 D1
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch0 D0 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D1
 | 2 | Ch1 D1 | Ch1 D0
 | 3 | Ch2 D0 | Ch2 CB/SB
 | 4 | Ch3 CB/SB | Ch2 D1
 | 5 | Ch3 D1 | Ch3 D0
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch0 D1 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D0
 | 2 | Ch1 D0 | Ch1 D1
 | 3 | Ch2 D1 | Ch2 CB/SB
 | 4 | Ch3 CB/SB | Ch2 D0
 | 5 | Ch3 D0 | Ch3 D1
Default-Mapping für:
Lightbus, EtherCAT, Ethernet und Busklemmen-Controller (BCxxxx, BXxxxx)
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D1 | Ch0 D0
 | 2 | res. | Ch1 CB/SB
 | 3 | Ch1 D1 | Ch1 D0
Bedingungen | Wort-Offset | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D0 | Ch0 D1
 | 2 | res. | Ch1 CB/SB
 | 3 | Ch1 D0 | Ch1 D1


Klemmenkonfiguration

Zugriff aus dem Anwenderprogramm [image] Klemmenkonfiguration
Klemmenkonfiguration
Die Klemme kann über die interne Registerstruktur konfiguriert und parametriert werden. Jeder Klemmenkanal wird im Buskoppler gemappt. In Abhängigkeit vom Typ des Buskopplers und von der eingestellten Mapping-Konfiguration (z.B. Motorola/Intel Format, Word-Alignment usw.) werden die Daten der Klemme unterschiedlich im Speicher des Buskopplers abgebildet. Zur Parametrierung einer Klemme ist es erforderlich, das Control- und Status-Byte mit abzubilden.
BK2000 - Lightbus-Koppler
Beim Lightbus-Koppler BK2000 wird neben den Datenbytes auch immer das Control- und Status-Byte gemappt. Dieses liegt stets im Low-Byte auf der Offsetadresse des Klemmenkanals.
Beispiel für die KL3202:
Mapping BK2000
BK3000 - PROFIBUS-Koppler
Beim PROFIBUS -Koppler BK3000 muss in der Masterkonfiguration festgelegt werden, für welche Klemmenkanäle das Control- und Status-Byte mit eingeblendet werden soll. Werden Control- und Status-Byte nicht ausgewertet, belegen die Klemmen 2 Byte pro Kanal:
▪
KL3201: 2 Byte Eingangsdaten
▪
KL3202: 4 Byte Eingangsdaten
▪
KL32x4: 8 Byte Eingangsdaten
Beispiel für die KL3202:
Mapping BK3000
BK4000 - Interbus-Koppler
Der Interbus-Koppler BK4000 mappt die Klemmen im Auslieferungszustand mit 2 Byte pro Kanal:
▪
KL3201: 2 Byte Eingangsdaten
▪
KL3202: 4 Byte Eingangsdaten
▪
KL3204: 8 Byte Eingangsdaten
Eine Parametrierung über den Feldbus ist nicht möglich. Soll das Control- und Status-Byte verwendet werden, wird die Konfigurations-Software KS2000 benötigt.
Beispiel für die KL3202:
Mapping BK4000
Überblick der Mapping-Konfigurationen
Im Anhang befindet sich eine Übersicht über die möglichen Mapping-Konfigurationen in Abhängigkeit der einstellbaren Parameter.
Parametrierung mit KS2000
Die Parametrierungen können unabhängig vom Feldbussystem mit der Konfigurationssoftware KS2000 über die serielle Konfigurationsschnittstelle im Buskoppler durchgeführt werden.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Diese Register sind für jeden Kanal einmal vorhanden.
Adresse | Bezeichnung | Defaultwert | R/W | Speichermedium
R0 | ADC-Rohwert | variabel | R | RAM
R1 | ADC-Rohwert der Leitung | variabel | R |
R2 | reserviert | 0x0000 | R |
R3 | ... | ... | ... | ...
R5 | reserviert | 0x0000 | R |
R6 | Diagnose-Register | variabel | R | RAM
R7 | Kommandoregister - nicht benutzt | 0x0000 | R |
R8 | Klemmentyp | z.B. 3202 | R | ROM
R9 | Software-Versionsnummer | 0x???? | R | ROM
R10 | Multiplex-Schieberegister | 0x0218/0130 | R | ROM
R11 | Signalkanäle | 0x0218 | R | ROM
R12 | minimale Datenlänge | 0x0098 | R | ROM
R13 | Datenstruktur | 0x0000 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Register | variabel | R/W | RAM
R16 | Hardware Versionsnummer | 0x???? | R/W | SEEROM
R17 | Hardware-Abgleich: Offset | spezifisch | R/W | SEEROM
R18 | Hardware-Abgleich: Gain | spezifisch | R/W | SEEROM
R19 | Hersteller Skalierung: Offset | 0x0000 | R/W | SEEROM
R20 | Hersteller Skalierung: Gain | 0x00A0 | R/W | SEEROM
R21 | Offset-Register 2-Draht Anschlusstechnik | spezifisch | R/W | SEEROM
R22 | reserviert | 0x0000 | R/W | SEEROM
R3 | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W | SEEROM
R31 | Codeword-Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0106 | R/W | SEEROM
R33 | Anwender-Skalierung: Offset | 0x0000 | R/W | SEEROM
R34 | Anwender-Skalierung: Gain | 0x0100 | R/W | SEEROM
R35 | reserviert | 0x0000 | R/W | SEEROM
R36 | reserviert | 0x0000 | R/W | SEEROM
R37 | Filterkonstante | 0x0138 | R/W | SEEROM
R38 | reserviert | 0x0000 | R/W | SEEROM
R3 | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R/W | SEEROM


Allgemeine Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Allgemeine Registerbeschreibung
Allgemeine Registerbeschreibung
Komplexe Klemmen die einen Prozessor besitzen, sind in der Lage mit der übergeordneten Steuerung bidirektional Daten auszutauschen. Diese Klemmen werden im Folgenden als intelligente Busklemmen bezeichnet. Zu ihnen zählen die analogen Eingänge, die analogen Ausgänge, serielle Schnittstellenklemmen (RS485, RS232, TTY usw.), Zähler-Klemmen, Encoder-Interface, SSI-Interface, PWM-Klemme und alle anderen parametrierbaren Klemmen.
Alle intelligenten Klemmen besitzen intern eine in ihren wesentlichen Eigenschaften identisch aufgebaute Datenstruktur. Dieser Datenbereich ist wortweise organisiert und umfasst 64 Register. Über diese Struktur sind die wesentlichen Daten und Parameter der Klemme les- und einstellbar. Zusätzlich sind Funktionsaufrufe mit entsprechenden Parametern möglich. Jeder logische Kanal einer intelligenten Klemme besitzt eine solche Struktur (Vierkanal-Analogklemmen besitzen also 4 Registersätze).
Diese Struktur gliedert sich in folgende Bereiche:
(Eine detaillierte Liste aller Register finden Sie im Anhang.)
Register | Verwendung
0 bis 7 | Prozessvariablen
8 bis 15 | Typ-Register
16 bis 30 | Hersteller-Parameter
31 bis 47 | Anwender-Parameter
48 bis 63 | Erweiterter Anwenderbereich
Weiterführende Informationen
•
Prozessvariablen
•
Typ-Register
•
Herstellerparameter
•
Anwenderparameter
•
Erweiteter Anwenderbereich


Prozessvariablen

Zugriff aus dem Anwenderprogramm [image] Allgemeine Registerbeschreibung [image] Prozessvariablen
Prozessvariablen
R0 bis R7: Register im internen RAM der Klemme
Die Prozessvariablen können ergänzend zum eigentlichen Prozessabbild genutzt werden und sind in ihrer Funktion klemmenspezifisch.
R0 bis R5: Klemmenspezifische Register
Die Funktion dieser Register ist abhängig vom jeweiligen Klemmentyp (siehe klemmenspezifische Registerbeschreibung).
▪
R6: Diagnoseregister
Das Diagnoseregister kann zusätzliche Diagnose-Information enthalten. So werden z. B. bei seriellen Schnittstellenklemmen Paritäts-Fehler, die während der Datenübertragung aufgetreten sind, angezeigt.
▪
R7: Kommandoregister
High-Byte_Write = Funktionsparameter
Low-Byte_Write = Funktionsnummer
High-Byte_Read = Funktionsergebnis
Low-Byte_Read = Funktionsnummer


Typ-Register

Zugriff aus dem Anwenderprogramm [image] Allgemeine Registerbeschreibung [image] Typ-Register
Typ-Register
R8 bis R15: Register im internen ROM der Klemme
Die Typ- und Systemparameter sind fest vom Hersteller programmiert und können vom Anwender nur ausgelesen und nicht verändert werden.
▪
R8: Klemmentyp
Der Klemmentyp in Register R8 wird zur Identifizierung der Klemme benötigt.
▪
R9: Softwareversion (X.y)
Die Software-Version kann als ASCII-Zeichenfolge gelesen werden.
▪
R10: Datenlänge
R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit.
Der Buskoppler sieht diese Struktur.
▪
R11: Signalkanäle
Im Vergleich zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z. B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.
▪
R12: Minimale Datenlänge
Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control- und Status-Byte nicht zwingend notwendig für die Funktion der Klemme und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen.
▪
R13: Datentypregister
Datentypregister | Bedeutung
0x00 | Klemme ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur 1Byte n Bytes
0x03 | Word-Array
0x04 | Struktur 1 Byte n Worte
0x05 | Doppelwort-Array
0x06 | Struktur 1 Byte n Doppelworte
0x07 | Struktur 1 Byte 1 Doppelwort
0x08 | Struktur 1 Byte 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur 1 Byte n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur 1 Byte n Worte mit variabler logischer Kanallänge
0x15 | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur 1 Byte n Doppelworte mit variabler logischer Kanallänge
▪
R14: reserviert
▪
R15: Alignment-Bits (RAM)
Mit den Alignment-Bits wird die Analogklemme im Buskoppler auf eine Bytegrenze gelegt.


Herstellerparameter

Zugriff aus dem Anwenderprogramm [image] Allgemeine Registerbeschreibung [image] Herstellerparameter
Herstellerparameter
R16 bis R30: Bereich der Herstellerparameter (SEEROM)
Die Herstellerparameter sind spezifisch für jeden Klemmentyp. Sie sind vom Hersteller programmiert, können jedoch auch von der Steuerung geändert werden. Die Herstellerparameter sind spannungsausfallsicher in einem seriellen EERPOM in der Klemme gespeichert.
Diese Register können nur nach dem Setzen eines Code-Worts in R31 geändert werden.


Anwenderparameter

Zugriff aus dem Anwenderprogramm [image] Allgemeine Registerbeschreibung [image] Anwenderparameter
Anwenderparameter
R31 bis R47: Bereich der Anwenderparameter (SEEROM)
Die Anwenderparameter sind spezifisch für jeden Klemmentyp. Sie können vom Programmierer geändert werden. Die Anwenderparameter sind spannungsausfallsicher in einem seriellen EEPROM in der Klemme gespeichert. Der Anwenderbereich ist über ein Code-Wort schreibgeschützt.
• R31: Code-Wort-Register im RAM
Damit Parameter im Anwender-Bereich geändert werden können muss hier das Code-Wort 0x1235 eingetragen werden. Wird ein abweichender Wert in dieses Register eingetragen, so wird der Schreibschutz gesetzt. Bei inaktivem Schreibschutz wird das Code-Wort beim Lesen des Registers zurückgegeben. Ist der Schreibschutz aktiv, enthält das Register den Wert Null.
▪
R32: Feature-Register
Dieses Register legt die Betriebsarten der Klemme fest. So kann z.B. eine anwenderspezifische Skalierung bei den analogen E/As aktiviert werden.
R33 bis R47: Klemmenspezifische Register
Die Funktion dieser Register ist abhängig vom jeweiligen Klemmentyp (siehe klemmenspezifische Registerbeschreibung).


Erweiteter Anwenderbereich

Zugriff aus dem Anwenderprogramm [image] Allgemeine Registerbeschreibung [image] Erweiteter Anwenderbereich
Erweiteter Anwenderbereich
R47 bis R63
Dieses Register legt die Betriebsarten der Klemme fest. So kann z.B. eine anwenderspezifische Skalierung bei den analogen E/As aktiviert werden.


Klemmenspezifische Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Klemmenspezifische Registerbeschreibung
Klemmenspezifische Registerbeschreibung
Weiterführende Informationen
•
Prozessvariablen
•
Herstellerparameter
•
Anwenderparameter
•
Ausgabeformat


Prozessvariablen

Zugriff aus dem Anwenderprogramm [image] Klemmenspezifische Registerbeschreibung [image] Prozessvariablen
Prozessvariablen
• R0: ADC-Rohwert X_R
Dieses Register beinhaltet den ADC-Rohwert.
• R1: ADC-Rohwert des Leitungswiderstandes zwischen +R1 – RL1 bzw. +R2 – RL2
• R2 bis R5: Reserviert
• R6: Diagnoseregister
▪
High-Byte: nicht benutzt
▪
Low-Byte: Status Byte


Herstellerparameter

Zugriff aus dem Anwenderprogramm [image] Klemmenspezifische Registerbeschreibung [image] Herstellerparameter
Herstellerparameter
• R17: Hardware-Abgleich - Offset (B_a)
16 Bit signed Integer
Über dieses Register erfolgt der Offset-Abgleich der Klemme (Gl. 1.1).
Registerwert ca. 0xEDXX
• R18: Hardware-Abgleich - Gain (A_a)
16 Bit * 16-5 (ca. 0,01907 Ω/Digit)
Über dieses Register erfolgt der Gain-Abgleich der Klemme (Gl. 1.1).
Registerwert ca. 0x27XX
• R19: Hersteller-Skalierung - Offset (B_h)
16 Bit signed Integer [0x0000]
Dieses Register beinhaltet den Offset der Hersteller-Geradengleichung (1.5). Die Geradengleichung wird über Register R32 aktiviert.
• R20: Hersteller-Skalierung - Gain (A_h)
16 Bit signed Integer *2-8 [0x00A0]
Dieses Register beinhaltet den Skalierungsfaktor der Hersteller-Geradengleichung (1.5). Die Geradengleichung wird über Register R32 aktiviert.
• R21: Zusätzliches Offsetregister für Zwei-Leiter-Anschluss
Der Wert von Register 1 bei Kurzschluss +R1-RL1 bzw. +R2-RL2
[ca. 0x01AX]


Anwenderparameter

Zugriff aus dem Anwenderprogramm [image] Klemmenspezifische Registerbeschreibung [image] Anwenderparameter
Anwenderparameter
• R32: Feature-Register
[0x0106]
Das Feature-Register legt die Betriebsart der Klemme fest.
Feature Bit Nr. |  | Beschreibung der Betriebsart
Bit 0 | 1 | Anwender-Skalierung (R33, R44) aktiv [0]
Bit 1 | 1 | Hersteller-Skalierung (R19, R20) aktiv [1]
Bit 2 | 1 | Watchdog-Timer aktiv [1] Der Watchdog-Timer ist im Auslieferungszustand eingeschaltet!
Bit 3 | 1 | Betrags- Vorzeichendarstellung [0] Anstelle der Zweierkomplement-Darstellung ist das Betrags-Vorzeichenformat aktiv (-1 = 0x8001).
Bit 4 | 1 | Siemens- Ausgabeformat [0] Mit diesem Bit werden auf den niedrigsten 3 Bits Statusanzeigen mit eingeblendet (siehe unten).
Bit 5,6 | - | reserviert, don't change
Bit 7 | 1 | aktiviert Filterkonstante in R37 [0]
Bit 8 | 1 | Overrange Protection [1] Wird eine Temperatur von 850°C überschritten, werden die Statusbits entsprechend gesetzt und der Ausgabewert auf 850°C beschränkt.
Bit 9 | - | reserviert, don't change
Bit 10 | 1 | Zwei-Leiter-Anschluss [0]
Bit 11 | - | reserviert, don't change
Bit 15,14,13,12 | Element | gültiger Messbereich
0 0 0 0 | PT100 | -200°C bis 850°C
0 0 0 1 | NI100 | -60°C bis 250°C
0 0 1 0 | PT1000 | -200°C bis 850°C
0 0 1 1 | PT500 | -200°C bis 850°C
0 1 0 0 | PT200 | -200° C bis 850°C
0 1 0 1 | NI1000 | -200°C bis 850°C
0 1 1 0 | NI120 | -80°C bis 320°C
1 1 1 0 | Ausgabe in Ω | 10,0 Ω bis 5000,0 Ω
1 1 1 1 | Ausgabe in Ω | 10,0 Ω bis 1200,0 Ω


Ausgabeformat

Zugriff aus dem Anwenderprogramm [image] Klemmenspezifische Registerbeschreibung [image] Ausgabeformat
Ausgabeformat
Ist nur die Herstellerskalierung über das Feature-Register aktiv, so ist das Ausgabeformat wie folgt:
▪
1 Digit entspricht 1/10 °C bzw.
▪
1 Digit entspricht 1/10 Ω
Ist keine Skalierung aktiv, so ist das Ausgabeformat wie folgt:
▪
1 Digit entspricht 1/16 °C bzw.
▪
1 Digit entspricht 1/16 Ω
Wird das Siemens-Ausgabeformat ausgewählt, werden die niedrigsten drei Bits zur Statusauswertung genutzt. Das Prozessdatum wird in den Bits 3 bis 15 abgebildet, wobei das Bit 15 das Vorzeichenbit ist. Die Skalierung des Messwertes entsprechend dem Siemensstandard muss über die Anwender-Skalierung erfolgen.
Bit Messwert | Bit 15-3 | Bit 2 X | Bit 1 Error | Bit 0 Überlauf
out of range |  | 0 | 0 | 1
in range | Prozessdatum | 0 | 0 | 0
• R33: Anwender Skalierung - Offset (B_w)
16 Bit signed Integer
Dieses Register beinhaltet den Offset der Anwender-Geradengleichung (1.6.). Die Geradengleichung wird über Register R32 aktiviert.
• R34: Anwender-Skalierung (A_w)
16 Bit signed Integer * 2-8.
Dieses Register beinhaltet den Skalierungsfaktor der Anwender-Geradengleichung (1.6). Die Geradengleichung wird über Register R32 aktiviert.
• R35 und R36: reserviert
• R37: Filterkonstante
[0x0000]
Filterkonstante: | First Notch [Hz] | Wandlungszeit [ms]
0x0000 | 25 | 250
0x50 | 100 | 65
0xA0 | 50 | 125
0x140 | 25 | 250
0x280 | 12.5 | 500
• Gültigkeit der Dokumentation
Diese Dokumentation ist gültig für alle Klemmen ab Firmware-Version 3x. Die Versionsangabe ist auf der rechten Seitenfläche der Klemme zu finden, in der Seriennummer: xxxx3xxx
Beispiel: 52983A2A  Die Firmware-Version ist 3A..


Control- und Status Byte

Zugriff aus dem Anwenderprogramm [image] Control- und Status Byte
Control- und Status Byte
Weiterführende Informationen
•
Control-Byte im Prozessdatenaustausch
•
Status-Byte im Prozessdatenaustausch
•
Abgleich
•
Voreinstellung der Register
•
KL3202 als Widerstandseingang 0 bis 1 kΩ


Control-Byte im Prozessdatenaustausch

Zugriff aus dem Anwenderprogramm [image] Control- und Status Byte [image] Control-Byte im Prozessdatenaustausch
Control-Byte im Prozessdatenaustausch
Das Control-Byte wird von der Steuerung zur Klemme übertragen. Es kann
▪
im Registermodus (REG = 1bin) oder
▪
im Prozessdatenaustausch (REG = 0bin)
genutzt werden.
Ein Gain- und Offsetabgleich der Klemme kann mit dem Control-Byte durchgeführt werden (Prozessdatenaustausch). Damit ein Abgleich der Klemme durchgeführt werden kann, muss das Code-Wort in R31 eingetragen werden. Daraufhin kann der Gain und Offset der Klemme abgeglichen werden.
Erst durch Zurücksetzen des Code-Worts werden die Parameter permanent gespeichert!
Control-Byte:
▪
Bit 7 = 0bin
▪
Bit 6 = 1bin: Abgleichfunktion der Klemme wird aktiviert
▪
Bit 4 = 1bin: Gain Abgleich
▪
Bit 3 = 1 Offset Abgleich
▪
Bit 2 = 0bin: langsamer Takt = 1000 ms
1bin: schneller Takt = 50 ms
▪
Bit 1 = 1bin: rauf
▪
Bit 0 = 1bin: runter


Status-Byte im Prozessdatenaustausch

Zugriff aus dem Anwenderprogramm [image] Control- und Status Byte [image] Status-Byte im Prozessdatenaustausch
Status-Byte im Prozessdatenaustausch
Das Status-Byte wird von der Klemme zur Steuerung übertragen. Das Status-Byte enthält verschiedene Statusbits des analogen Eingangskanals:
Status-Byte:
▪
Bit 7 = 0bin
▪
Bit 6 = 1bin: Error (allgemeines Fehlerbit)
▪
Bit 5 bis Bit 2: reserviert
▪
Bit 1 = 1bin: Overrange
▪
Bit 0 = 1bin: Underrange


Abgleich

Zugriff aus dem Anwenderprogramm [image] Control- und Status Byte [image] Abgleich
Abgleich
Implementierte Geradengleichung:
Y[Ω] = (X_Adc * G + B_h) * A_h + 100 Ω
Daraus folgt:
B_h besteht aus einem vom Gain des A/D-Wandlers abhängigen Anteil und einer Konstanten, um die Achsenverschiebung von 100 Ω herauszurechnen. Der gain-abhängige Anteil rechnet den Offset der externen Bauelemente heraus (Offset der Bauelemente ist über einstellbare Verstärkung veränderlich).
Diese Vorgehensweise ist notwendig, da ein Abgleich bei 0 Ω schaltungstechnisch nicht möglich ist. Die Gerade wird demzufolge um den Punkt 100 Ω abgeglichen (auf den Punkt verschoben und um diesen Punkt gedreht).
B_h: (B_off * G + B_100)
▪
Der Offsetabgleich ist demnach bei PT100 bei 100 Ω durchzuführen (bzw. PT1000 bei 1000 Ω).
▪
Der Gain-Abgleich wird dann unabhängig vom Offset bei z.B. 300 Ω durchgeführt. 300 Ω entsprechen 557,7°C = 0x15C9


Voreinstellung der Register

Zugriff aus dem Anwenderprogramm [image] Control- und Status Byte [image] Voreinstellung der Register
Voreinstellung der Register
▪
R17: 0xED68 entspricht -90,8 Ω
▪
R18: 0x4E20 entspricht 2000 * 16-5 = 0,01907 Ω/Digit
▪
R19: 0x0000
▪
R20: 0x00A0
▪
R32: 0x0106
▪
R33: 0x0000
▪
R34: 0x0100
Der einmalig durchzuführende Gain- und Offsetabgleich braucht bei allen anderen implementierten Elementen nicht wiederholt bzw. korrigiert werden.
Für den Zwei-Leiter-Anschluss muss bei kurzgeschlossenem Leitungswiderstand (+R1-Rl1) der ADC-Rohwert des Leitungswiderstandes (enthalten in R1) in Register R21 eingetragen werden.


KL3202 als Widerstandseingang 0 bis 1 kΩ

Zugriff aus dem Anwenderprogramm [image] Control- und Status Byte [image] KL3202 als Widerstandseingang 0 bis 1 kΩ
KL3202 als Widerstandseingang 0 bis 1 kΩ
Wird die KL3202 zur Widerstandsmessung genutzt müssen die folgenden Register mit den folgenden Werten beschrieben werden:
• R32: Feature Register: 0xF401
d.h. Anwenderskalierung aktiv mit der Ausgabe des Messwertes in Ohm und Zweileiteranschlusstechnik.
• R33: Anwender Skalierung - Offset (0x0000)
• R34: Anwender-Skalierung - Gain (0x0010)
daraus folgt die Ausgabe des Messwertes:
Widerstandswert in Ω | Ausgabewert
0 | 0
1000 | 1000


Registerkommunikation

Zugriff aus dem Anwenderprogramm [image] Registerkommunikation
Registerkommunikation
Weiterführende Informationen
•
Registerzugriff über den Prozessdatenaustausch
•
Beispiel 1
•
Beispiel 2


Registerzugriff über den Prozessdatenaustausch

Zugriff aus dem Anwenderprogramm [image] Registerkommunikation [image] Registerzugriff über den Prozessdatenaustausch
Registerzugriff über den Prozessdatenaustausch
Bit 7 = 1bin: Registermodus
Wenn Bit 7 des Control-Bytes gesetzt wird, werden die ersten zwei Byte der Nutzdaten nicht zum Prozessdatenaustausch verwendet, sondern in den Registersatz der Klemme geschrieben oder daraus ausgelesen.
Bit 6 = 0bin: lesen
Bit 6 = 1bin: schreiben
In Bit 6 des Control-Bytes legen Sie fest, ob ein Register ausgelesen oder beschrieben werden soll. Wenn das Bit 6 nicht gesetzt ist, wird ein Register ausgelesen, ohne es zu verändern. Der Wert kann dem Eingangs-Prozessabbild entnommen werden.
Wird das Bit 6 gesetzt, werden die Nutzdaten in ein Register geschrieben. Sobald das Status-Byte im Eingangs-Prozessabbild eine Quittung geliefert hat, ist der Vorgang abgeschlossen (siehe Beispiel).
Bit 0 bis 5: Adresse
In die Bits 0 bis 5 des Control-Bytes wird die Adresse des anzusprechenden Registers eingetragen.
Control-Byte im Register-Modus
MSB
REG=1
W/R
A5
A4
A3
A2
A1
A0
▪
REG = 0bin : Prozessdatenaustausch
▪
REG = 1bin: Zugriff auf Registerstruktur
▪
W/R = 0bin : Register lesen
▪
W/R = 1bin : Register schreiben
▪
A5...A0 = Registeradresse
Mit den Adress-Bits A5 bis A0 sind insgesamt 64 Register adressierbar.
Register-Modus Control Byte
Das Control- bzw. Status-Byte belegt die niedrigste Adresse eines logischen Kanals. Die entsprechenden Registerwerte befinden sich in den folgenden zwei Datenbytes. (Ausnahme ist der BK2000: hier wird nach dem Control- bzw. Status-Byte automatisch ein nicht genutztes (reserviertes) Daten-Byte eingeschoben, und somit der Registerwert auf eine Word-Grenze gelegt).


Beispiel 1

Zugriff aus dem Anwenderprogramm [image] Registerkommunikation [image] Beispiel 1
Beispiel 1
Lesen des Registers 8 im BK2000 mit einer KL3202 und der Endklemme:
Werden die folgenden Bytes von der Steuerung zur Klemme übertragen,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataOUT 1 | DataOUT 0 | Nicht benutzt | Control-Byte
Wert | 0xXX | 0xXX | 0xXX | 0x88
so liefert die Klemme die folgende Typ-Bezeichnung zurück (0x0C82 entspricht dem unsigned Integer 3202).
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataIN 1 | DataIN 0 | Nicht benutzt | Status-Byte
Wert | 0x0C | 0x82 | 0x00 | 0x88


Beispiel 2

Zugriff aus dem Anwenderprogramm [image] Registerkommunikation [image] Beispiel 2
Beispiel 2
Schreiben des Registers 31 im BK2000 mit einer intelligenten Klemme und der Endklemme:
Werden die folgenden Bytes (Code-Wort) von der Steuerung zur Klemme übertragen,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataOUT 1 | DataOUT 0 | Nicht benutzt | Control-Byte
Wert | 0x12 | 0x35 | 0xXX | 0xDF
so wird das Code-Wort gesetzt und die Klemme liefert als Quittung die Registeradresse mit dem Bit 7 für Registerzugriff zurück.
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataIN 1 | DataIN 0 | Nicht benutzt | Status-Byte
Wert | 0x00 | 0x00 | 0x00 | 0x9F


TwinCAT

TwinCAT
TwinCAT
SPS und Motion Control auf dem PC
TwinCAT - The Windows Control and Automation Technology
Die Automatisierungs-Software TwinCAT verwandelt jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS, NC-Achsregelung, Programmierumgebung und Bedienstation. TwinCAT substituiert herkömmliche SPS- und NC/CNC-Steuerungen sowie Bediengeräte:
▪
offene, kompatible PC-Hardware
▪
Einbettung von IEC 61131-3-Software-SPS, Software-NC und Software-CNC in Windows NT/2000/XP, NT/XP Embedded, CE
▪
Programmiersystem und Laufzeit wahlweise auf einem PC oder getrennt
▪
Anbindung an alle gängigen Feldbus-Systeme
▪
PC-Schnittstellen werden unterstützt
▪
Datenanbindung an Bedienoberflächen und andere Programme mittels offener Standards (OPC, OCX, DLL etc.)
TwinCAT-Architektur
TwinCAT besteht aus Laufzeitsystemen zur Echtzeitausführung von Steuerungsprogrammen und den Entwicklungsumgebungen zur Programmierung, Diagnose und Konfiguration. Alle Windows-Programme, beispielsweise Visualisierungen oder Office-Produkte, können über Microsoft-Schnittstellen auf TwinCAT-Daten zugreifen oder Kommandos ausführen.
Praxisorientierte Softwarelösung
TwinCAT bietet eine genaue Zeitbasis, die mit höchster Deterministik Programme unabhängig von anderen Prozessoraufgaben ausführt. Die Echtzeitlast auf einem PC wird mit TwinCAT eingestellt: Auf diese Weise wird ein definiertes Betriebsverhalten erreicht. TwinCAT zeigt die Systemlast für laufende Programme an. Eine Lastgrenze kann eingestellt werden, um für die Bedienprogramme und Windows NT/2000/XP eine definierte Rechenkapazität zur Verfügung zu stellen. Bei Überschreiten dieser Grenze wird eine Systemmeldung generiert.
TwinCAT unterstützt die Systemdiagnose
Die freie Verwendung von Hardware oder Software aus der offenen PC-Welt erfordert ihre Prüfung: Ungeeignete Komponenten können das PC-System außer Tritt bringen. Beckhoff integriert eine praktische Anzeige des Jitters der Echtzeit, um einem Administrator ein einfaches Mittel zur Evaluierung von Hardware und Software an die Hand zu geben. Im Betrieb kann eine Systemmeldung auf Fehlerzustände aufmerksam machen.
Start-/Stoppverhalten
TwinCAT startet und stoppt, je nach Einstellung, durch manuellen Eingriff oder automatisch. Da TwinCAT als Service in Windows NT/2000/XP integriert ist, wird zum Systemstart kein Bediener benötigt: Strom einschalten genügt.
Wiederanlauf und Datensicherung
TwinCAT lädt beim Start oder Wiederanlauf Programme und remanente Daten. Zur Datensicherung und zum korrekten Beenden von Windows NT/2000/XP empfiehlt sich eine USV (unterbrechungsfreie Stromversorgung).
TwinCAT und „Blue Screen“
Das TwinCAT-System kann so konfiguriert werden, dass die Echtzeit im Falle eines Betriebssystemabsturzes BSOD (Blue-Screen-of-Death) funktionell erhalten bleibt. Echtzeittasks, wie z. B. die SPS und NC, können somit weiterlaufen und den gesteuerten Prozess in einen sicheren Zustand bringen. Letztlich liegt es in der Entscheidung des Programmierers, diese Eigenschaft zu nutzen in Anbetracht dessen, dass Daten oder Programme durch den BSOD bereits zerstört sein können.
Weltweite Verbindung per Message-Routing – Remote-Verbindung ist systemimmanent
Die Softwaregeräte von TwinCAT können, je nach Anforderung, auf Betriebsmittel verteilt werden: TwinCAT-SPS-Programme können auf PCs und auf Beckhoff Busklemmen Controllern ablaufen. Ein „Message-Router“ verwaltet und verteilt alle Nachrichten im System und über TCP/IP-Verbindungen. PC-Systeme können per TCP/IP miteinander verbunden werden; Busklemmen Controller werden über serielle Schnittstellen und über Feldbus-Systeme (EtherCAT, Lightbus, PROFIBUS DP, PROFINET, Interbus, CANopen, DeviceNet, RS232, RS485, Ethernet TCP/IP, Ethernet/IP) angebunden.
Weltweiter Zugriff
Da Standard-TCP/IP-Dienste von Windows NT/2000/XP genutzt werden, kann dieser Datenaustausch weltweit erfolgen. Das System bietet skalierbare Kommunikationsleistung und Time-out-Zeiten zur Überwachung von Kommunikationen. Mittels OPC kann auf einem standardisierten Weg auf viele unterschiedliche SCADA-Pakete zugegriffen werden. Mit dem SOAP (Simple-Object-Access-Protocol) kann über eine Internetverbindung via Standard-HTTP eine Verbindung zwischen zwei Rechnern hergestellt werden. Auch hierzu bietet TwinCAT eine Komponente an.
Beckhoff-Information-System
Weitere Informationen über die Automatisierungs-Software TwinCAT finden Sie im Beckhoff-Information-System.
Das Setup zur Installation des Beckhoff-Information-Systems steht Ihnen auf der Beckhoff-DVD Products & Solutions und auf unseren Internetseiten zum Download zur Verfügung.
Außerdem finden Sie unter http://infosys.beckhoff.com die Online-Version des Beckhoff-Information-System.
Weiterführende Informationen
•
Programmierung
•
Funktionsbaustein FB_KL320xConfig


Programmierung

TwinCAT [image] Programmierung
Programmierung
TwinCAT-Bibliotheken
Siehe Software-Dokumentation im Beckhoff-Information-System.
TwinCAT 2: TwinCAT PLC Lib: IO Funktionen
TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_IoFunctions


Funktionsbaustein FB_KL320xConfig

TwinCAT [image] Funktionsbaustein FB_KL320xConfig
Funktionsbaustein FB_KL320xConfig
Mit dem Funktionsbaustein FB-KL320xConfig kann die Klemme KL320x konfiguriert werden. Eine ausführliche Beschreibung Sie im Beckhoff Information System:
TwinCAT2: TwinCAT PLC Lib: IO Funktionen/Busklemmen-Konfiguration
TwinCAT3: TwinCAT 3 PLC Lib:Tc2_IoFunctions/Funktionsbausteine/Busklemmen-Konfiguration


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Übersicht Analoge Eingangsklemmen

Übersicht Analoge Eingangsklemmen
Übersicht Analoge Eingangsklemmen
1-, 2- und 4-kanalige Eingangsklemmen für Pt100 (RTD)
▪
KL3201
▪
KL3202
▪
KL3204-0000
4-kanalige Eingangsklemme für NTC10K
▪
KL3204-0030