KL3208, KL3228 - Achtkanalige Eingangsklemmen für PT1000, NI1000, NTC
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Beckhoff Identification Code (BIC)


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.2.0
▪
Update Kapitel „Hinweise zum ESD-Schutz“
▪
Kapitel „Beckhoff Identification Code (BIC)“ eingefügt
3.1.0
▪
Sicherheitshinweise neues Layout
▪
Kapitel Hinweise zum ESD-Schutz eingefügt
▪
Update Kapitel Anschlusstechnik -> Anschluss
▪
Beispielprogramm zum Kapitel “Konfigurations-Software KS2000“ hinzugefügt
3.0.0
▪
Migration
▪
Technische Daten aktualisiert
▪
Kapitel "Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit" eingefügt"
▪
Kapitel "TwinCAT" mit Link zu FB_KL3208Config und FB_KL3228Config hinzugefügt
▪
Kapitel "ATEX - Besondere Bedingungen" ausgetauscht gegen Kapitel "ATEX - Besondere Bedingungen (Standardtemperaturbereich)" und "ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)"
2.2.0
▪
Prozessdaten korrigiert
2.1.0
▪
KS2000-Konfigurationsmaske für KL3208-0010 hinzugefügt
▪
Technische Daten aktualisiert
▪
Registerbeschreibung aktualisiert
▪
Grundlagen zur Funktion erweitert
▪
Zulassungen erweitert
▪
ATEX-Hinweise hinzugefügt
2.0.1
▪
KS3228-0000 hinzugefügt
2.0.0
▪
KL3208-0010 hinzugefügt
▪
KS2000-Konfigurationsmaske für KL3228-0000 korrigiert
1.1.0
▪
Hinweise zur Positionierung im Busklemmenblock erweitert
▪
Sensor-Typen korrigiert
1.0.0
▪
KS2000-Konfigurationsmaske für KL3228-0000 hinzugefügt
▪
erste Veröffentlichung
0.5
Vorabversion
Firm- und Hardware-Stände
Dokumentation Version | KL3208-0010 |  | KL3228-0000, KS3228-0000
 | Firmware | Hardware | Firmware | Hardware
3.1.0 | 1D | 02 | 3C | 01
3.0.0 | 1C | 02 | 3C | 01
2.2.0 | 1C | 02 | 3C | 01
2.1.0 | 1C | 02 | 3C | 01
2.0.1 | 1A | 00 | 3C | 00
2.0.0 | 1A | 00 | 3C | 00
1.1.0 | - | - | 3B | 00
1.0.0 | - | - | 3B | 00
0.5 | - | - | 3A | 00
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Jahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 20 09 3A 00:
20 - Produktionswoche 20
09 - Produktionsjahr 2009
3A - Firmware-Stand 3A
00 - Hardware-Stand 00


Beckhoff Identification Code (BIC)

Vorwort [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KL3208-0010 - Einführung
•
KL3228-0000 - Einführung
•
Technische Daten


KL3208-0010 - Einführung

Produktübersicht [image] KL3208-0010 - Einführung
KL3208-0010 - Einführung
KL3208-0010
Die analoge Eingangsklemme KL3208-0010 erlaubt den Anschluss von acht Widerstandssensoren. Die Schaltung der Busklemme kann Sensoren in 2-Leitertechnik betreiben.
Die Linearisierung über den gesamten, frei wählbaren, Temperaturbereich wird durch einen Mikroprozessor realisiert. Die Standardeinstellung der Busklemme ist: Auflösung 0,01 °C im Temperaturbereich der Ni1000-Sensoren.
Die Signal-LEDs zeigen an, dass der Kanal über den K-Bus kommuniziert.
Die Error-LEDs zeigen Sensorstörungen (z. B. Drahtbruch) des jeweiligen Kanals an.
Die HD-Busklemmen (High Density) mit erhöhter Packungsdichte enthalten 16 Anschlusspunkte im Gehäuse einer 12 mm Reihenklemme.


KL3228-0000 - Einführung

Produktübersicht [image] KL3228-0000 - Einführung
KL3228-0000 - Einführung
KL3228
Die analoge Eingangsklemme KL3228 erlaubt den Anschluss von acht Widerstandssensoren. Die Schaltung der Busklemme kann Sensoren in 1-Leitertechnik betreiben. Die Linearisierung über den gesamten, frei wählbaren Temperaturbereich wird durch einen Mikroprozessor realisiert. Die Auflösung der Klemme ist 0,1°C; die Standardeinstellung ist der Sensortyp PT1000. Die Error-LEDs zeigen Sensorstörungen (z. B. Drahtbruch) an.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten |  | KL3208-0010 | KL3228-0000, KS3228-0000
Eingänge |  | 8
Sensor-Typen |  | PT1000 (Auslieferungszustand), Ni1000, Poti: 1kΩ /5kΩ / 10kΩ, NTC: 1,8k / 2,2k / 3k / 5k / 10k / 20k / 100k | PT1000 (Auslieferungszustand), Ni1000
Leitungsführung |  | 2-Leiter | 1-Leiter
Klemmstellen |  | High-Density (HD) | Standard (KL) Steckbar (KS)
Temperaturbereich | PT-Sensoren | -50°C…+150°C
 | Ni-Sensoren | -50°C…+150°C
Wandlungszeit |  | ca. 1 s
Mess-Strom |  | typisch 0,5 mA
Auflösung |  | 0,01°C pro Digit | 0,1°C pro Digit
Messfehler (gesamter Messbereich) |  | -20°C…+60°C: ±0,25 °C (bei 25°C Umgebungstemperatur) -50°C…+150°C: ±1,5°C | ±1,0°C, abhängig von der Verdrahtung
Bitbreite im Eingangsprozessabbild |  | 8 Status-Bytes (optional), 8 Datenworte
Bitbreite im Ausgangsprozessabbild |  | 8 Control-Bytes (optional), 8 Datenworte (optional)
Spannungsversorgung für Elektronik |  | über den K-Bus
Stromaufnahme aus dem K-Bus |  | typisch 85 mA
Potenzialtrennung |  | 500 V (K-Bus / Signalspannung)
Gewicht |  | ca. 75 g | ca. 75 g
Abmessungen (B x H x T) |  | ca. 15 mm x 100 mm x 70 mm
Montage |  | auf 35 mm Tragschiene nach EN 60715
Steckbare Verdrahtung |  | - | bei allen Klemmen der Bauform KSxxxx
zulässiger Umgebungstemperaturbereich im Betrieb |  | -25°C ... + 60°C (erweiterter Temperaturbereich) | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung |  | -40°C ... + 85°C | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit |  | 95%, keine Betauung
Vibrations- / Schockfestigkeit |  | gemäß EN 60068-2-6 / EN 60068-2-27 siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung |  | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart |  | IP20
Einbaulage |  | beliebig
Zulassung |  | CE, ATEX (erweiterter Temperaturbereich), cULus |  | CE, ATEX (Standardtemperaturbereich), cULus


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss
•
KL3208-0010 - Anschluss
•
KL3228-0000 - Anschluss
•
KL3228 - Positionierung im Busklemmenblock
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endklemme KL9010 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


KL3208-0010 - Anschluss

Montage und Verdrahtung [image] KL3208-0010 - Anschluss
KL3208-0010 - Anschluss
KL3208-0010 - Anschluss
Klemmstelle | Nr. | Anschluss für
+R1 | 1 | PT-Sensor Kanal 1
+R2 | 2 | PT-Sensor Kanal 2
+R3 | 3 | PT-Sensor Kanal 3
+R4 | 4 | PT-Sensor Kanal 4
+R5 | 5 | PT-Sensor Kanal 5
+R6 | 6 | PT-Sensor Kanal 6
+R7 | 7 | PT-Sensor Kanal 7
+R8 | 8 | PT-Sensor Kanal 8
-R1 | 9 | PT-Sensor Kanal 1
-R2 | 10 | PT-Sensor Kanal 2
-R3 | 11 | PT-Sensor Kanal 3
-R4 | 12 | PT-Sensor Kanal 4
-R5 | 13 | PT-Sensor Kanal 5
-R6 | 14 | PT-Sensor Kanal 6
-R7 | 15 | PT-Sensor Kanal 7
-R8 | 16 | PT-Sensor Kanal 8


KL3228-0000 - Anschluss

Montage und Verdrahtung [image] KL3228-0000 - Anschluss
KL3228-0000 - Anschluss
KL3228-0000 - Anschluss
Klemmstelle | Nr. | Anschluss für
R1 | 1 | PT-Sensor Kanal 1
R2 | 2 | PT-Sensor Kanal 2
R3 | 3 | PT-Sensor Kanal 3
R4 | 4 | PT-Sensor Kanal 4
R5 | 5 | PT-Sensor Kanal 5
R6 | 6 | PT-Sensor Kanal 6
R7 | 7 | PT-Sensor Kanal 7
R8 | 8 | PT-Sensor Kanal 8
Schließen Sie die Rückleiter der acht PT-Sensoren über eine Potentialverteilungsklemme (KL9187) an. Die KL9187 führt die Rückleiter über den Power-Kontakt (0 V) zurück zur KL3228.
KL3228/KL9187 direkt vor der Busendklemme KL9010 montieren
Montieren Sie KL3228/KL9187 direkt nebeneinander und im Busklemmenblock so weit rechts wie möglich, am besten direkt vor der Busendklemme KL9010!
Wenn rechts von KL3228/KL9187 im Busklemmenblock weitere Busklemmen montiert sind, die Strom aus den Power-Kontakten beziehen, führt dieser Strom an den Powerkontakten zwischen KL3228/KL9187 zu einem Spannungsabfall. Dieser Spannungsabfall kann die Messwerte der KL3228 verfälschen, da auch die Rückleiter der PT-Sensoren über den Power-Kontakt (0 V) geführt werden.
Siehe Positionierung im Busklemmenblock


KL3228 - Positionierung im Busklemmenblock

Montage und Verdrahtung [image] KL3228 - Positionierung im Busklemmenblock
KL3228 - Positionierung im Busklemmenblock
Schließen Sie die Rückleiter der acht PT-Sensoren über eine Potentialverteilungsklemme (KL9187) an. Die KL9187 führt die Rückleiter über den Power-Kontakt (0 V) zurück zur KL3228.
KL3228/KL9187 direkt vor der Busendklemme KL9010 montieren
Montieren Sie KL3228/KL9187 direkt nebeneinander und im Busklemmenblock so weit rechts wie möglich, am besten direkt vor der Busendklemme KL9010!
Wenn rechts von KL3228/KL9187 im Busklemmenblock weitere Busklemmen montiert sind, die Strom aus den Power-Kontakten beziehen, führt dieser Strom an den Powerkontakten zwischen KL3228/KL9187 zu einem Spannungsabfall. Dieser Spannungsabfall kann die Messwerte der KL3228 verfälschen, da auch die Rückleiter der PT-Sensoren über den Power-Kontakt (0 V) geführt werden.
Beispiel für schlechte Positionierung
Dieses Beispiel zeigt KL3228/KL9187 links im Busklemmenblock montiert. Rechts von KL3228/KL9187 sind noch große Stromverbraucher montiert.
KL3228/KL9187 - Beispiel für schlechte Positionierung
Die KL2442 treibt einen Strom von je 4 A durch die beiden Lastwiderstände R1 und R2. Dieser Strom (in Summe 8 A) muss über die Powerkontakte zurück zum Netzteil fließen und verursacht am gelb gekennzeichneten Powerkontakt (zwischen KL3228 und KL9187) den Spannungsabfall UPC.
Die KL3228 treibt einen Strom durch den Sensor S1. Dieser Strom fließt ebenfalls über den gelb gekennzeichneten Powerkontakt zurück zur KL3228.
Der Spannungsabfall UPC verursacht so einen Messfehler bei der Widerstandsmessung durch die KL3228.
Beispiel für gute Positionierung
Dieses Beispiel zeigt KL3228/KL9187 rechts im Busklemmenblock montiert. Rechts von KL3228/KL9187 sind keine weiteren Stromverbraucher montiert.
KL3228/KL9187 - Beispiel für gute Positionierung
Der Strom aus den Lastwiderstände R1 und R2 fließt nicht über gelb gekennzeichneten Powerkontakt (zwischen KL3228 und KL9187).
Somit ist der Spannungsabfall UPC an diesem Powerkontakt zu vernachlässigen.
Es entsteht kein zusätzlicher Messfehler bei der Widerstandsmessung durch die KL3228.


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Einstellungen für KL3208-0010
•
Einstellungen für KL3228-0000
•
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies:
▪
ein Ethernet-Koppler BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine KL3228
▪
eine Bus-Endklemme KL9010
Anzeige der KL3228 in KS2000
Die achtkanalige Analogklemme KL3228 wird von der Konfigurations-Software KS2000 als zwei vierkanalige Analogklemmen angezeigt.
Sie können die 8 Kanäle jedoch wie gewohnt parametrieren.
Darstellung der Feldbusstation mit KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).
KS2000-Baumzweige für KL3228-0000
Für die KL3228 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL3228.
▪
Unter Einstellungen finden Sie Dialogmaske zur Parametrierung der KL3228.
▪
ProcData zeigt die Prozessdaten der KL3228.


Einstellungen für KL3208-0010

Konfigurations-Software KS2000 [image] Einstellungen für KL3208-0010
Einstellungen für KL3208-0010
Unter Einstellungen finden Sie die Dialogmaske zur Parametrierung der KL3208-0010.
KL3208-0010 - Dialog Einstellungen
Betriebsmodus
Hier können Sie
▪
die Anwender-Skalierung (enUsrScale, R32.0) und
▪
die Hersteller-Skalierung (enManScale, R32.1) aktivieren oder
▪
den Kanal komplett deaktivieren (disChannel, R32.11).
Widerstandsthermometer (Sensor-Typ)
Hier können Sie die KL3208-0010 auf den angeschlossenen Sensor-Type, (R32.15-R32.13) einstellen:
▪
PT1000
▪
NI1000 mit Standard-Kennlinie
▪
NI1000 mit Landis&Staefa-Kennlinie (1500 Ω entsprechen 100°C)
Auswahl der NTCs / Poti / b-Parameter
Hier können Sie die KL3208-0010 auf NTCs, Potentiometer usw. einstellen (R39).
Benutzerdefiniert
Wenn benutzerdefinierter NTC (255dez, siehe Register R39) gewählt wurde, können sie dessen Parameter hier eingeben.


Einstellungen für KL3228-0000

Konfigurations-Software KS2000 [image] Einstellungen für KL3228-0000
Einstellungen für KL3228-0000
Unter Einstellungen finden Sie die Dialogmaske zur Parametrierung der KL3228-0000.
KL3228 - Dialog Einstellungen
Betriebsmodus
Hier können Sie
▪
die Anwender-Skalierung (enUsrScale, R32.0) und
▪
die Hersteller-Skalierung (enManScale, R32.1) aktivieren oder
▪
den Kanal komplett deaktivieren (disChannel, R32.11).
Widerstandsthermometer (Sensor-Typ)
Hier können Sie die KL3228-0000 auf den angeschlossenen Sensor-Type, (R32.15-R32.13) einstellen:
▪
PT1000
▪
NI1000 mit Standard-Kennlinie
▪
NI1000 mit Landis&Staefa-Kennlinie (1500 Ω entsprechen 100°C)


Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314

Konfigurations-Software KS2000 [image] Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Anwenders zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Programmbeschreibung/ Funktion
Dieses Beispielprogramm (TwinCAT 3) erlaubt per AoE die Änderung einzelner Registerwerte der KL3314 wie die Auswahl des Element-Typs und charakteristische Einstellungen des Feature‑Registers R32 sowie die Anwenderskalierung Offset und Gain (R33/ R34) ähnlich wie per KS2000.
Einstellungen der KL3314 über die Visualisierung von TwinCAT 3
Es sollte mindestens die folgende Konfiguration vorhanden sein:
[Koppler (z.B. BK1120) oder embedded PC] + KL3314 + KL9010.
Download:
Vorbereitungen zum Starten des Beispielprogramms (tnzip - Datei/ TwinCAT 3)
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.tnzip -Archivdatei in einem temporären Ordner.
Öffnen des *. tnzip - Archives
▪
Wählen Sie die zuvor entpackte .tnzip Datei (Beispielprogramm) aus.
▪
Ein weiteres Auswahlfenster öffnet sich: wählen nun Sie das Zielverzeichnis, wo das Projekt gespeichert werden soll.
▪
Die generelle Vorgehensweise für die Inbetriebnahme der PLC bzw. dem Start des Programms kann u.a. den Klemmen‑Dokumentationen oder der EtherCAT‑Systemdokumentation entnommen werden.
▪
Das EtherCAT Gerät im Beispiel ist i.d.R. zuvor ihrem vorliegenden System bekannt zu machen. Verwenden Sie nach Auswahl des EtherCAT Gerätes im „Projektmappen-Explorer“ rechtsseitig den Karteireiter „Adapter“ und Klicken „Suchen...“:
Suche der bestehenden HW-Konfiguration zur bestehenden EtherCAT-Konfiguration
▪
Überprüfen der NetId: der Karteireiter „EtherCAT“ des EtherCAT Gerätes zeigt die konfigurierte NetId: .
Diese muss mit den ersten vier Zahlenwerten mit der Projekt‑NetId des Zielsystems übereinstimmen. Die NetId des Projektes kann oben in einem Textfeld der TwinCAT-Umgebung eingesehen werden. Ein pull-down Menü kann durch einen Klick rechts im Textfeld geöffnet werden; dort ist zu jeden Rechnernamen eines Zielsystems die NetId in Klammern angegeben.
▪
Ändern der NetId: mit einem Rechtsklick auf „Gerät EtherCAT“ im Projektmappen-Explorer öffnet sich das Kontextmenü, in dem „Ändern der NetId“ auszuwählen ist. Die ersten vier Zahlen der NetId des Projektes sind einzutragen. die beiden letzten Werte sind i.d.R. 4.1.
Beispiel:
–
NetId des Projektes: myComputer (123.45.67.89.1.1)
–
Eintrag per „Change NetId...“: 123.45.67.89.4.1


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Bytes
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Die Klemme stellt sich im komplexen Prozessabbild mit 24 Byte Ein- und 24 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | SB1 | CB1
1 | 2 | Wort | DataIN1 | DataOUT1
3 | 4 | Byte | SB2 | CB2
4 | 6 | Wort | DataIN2 | DataOUT2
6 | 8 | Byte | SB3 | CB3
7 | 10 | Wort | DataIN3 | DataOUT3
9 | 12 | Byte | SB4 | CB4
10 | 14 | Wort | DataIN4 | DataOUT4
12 | 16 | Byte | SB5 | CB5
13 | 18 | Wort | DataIN5 | DataOUT5
15 | 20 | Byte | SB6 | CB6
16 | 22 | Wort | DataIN6 | DataOUT6
18 | 24 | Byte | SB7 | CB7
19 | 26 | Wort | DataIN7 | DataOUT7
21 | 28 | Byte | SB8 | CB8
22 | 30 | Wort | DataIN8 | DataOUT8
Die Klemme stellt sich im kompakten Prozessabbild mit 16 Byte Eingangsdaten und ohne Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Wort | DataIN1 | -
1 | 1 | Wort | DataIN2 | -
2 | 2 | Wort | DataIN3 | -
3 | 3 | Wort | DataIN4 | -
4 | 4 | Wort | DataIN5 | -
5 | 5 | Wort | DataIN6 | -
6 | 6 | Wort | DataIN7 | -
6 | 6 | Wort | DataIN8 | -
*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen
Legende
SB1 ... SB8: | Status-Bytes der Kanäle 1 bis 8
CB1 ... CB8: | Control-Bytes der Kanäle 1 bis 8
DataIN1 ... DataIN8: | Eingangsworte der Kanäle 1 bis 8
DataOUT1 ... DataOUT8: | Ausgangsworte der Kanäle 1 bis 8 (werden für die Registerkommunikation benutzt)


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Bytes
Control- und Status-Bytes
Kanal1
Im Folgenden werden die Control- und Status-Bytes (CB1 und SB1) für Kanal 1 im Prozessdatenbetrieb und für die Registerkommunikation beschrieben.
Kanäle 2 bis 8
Die Control- und Status-Bytes der Kanäle 2 (CB2 und SB2) bis 8 (CB8 und SB8) sind wie das Control- und Status-Byte des Kanals 1 aufgebaut.
Weiterführende Informationen
•
Prozessdatenbetrieb
•
Registerkommunikation


Prozessdatenbetrieb

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Bytes [image] Prozessdatenbetrieb
Prozessdatenbetrieb
Control-Byte 1 (bei Prozessdatenbetrieb)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | Cali | Gain | Offset | Clock | up | down
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 | - | 0bin | reserviert
CB1.5 | Cali | 1bin | Abgleichfunktion der Klemme wird aktiviert | Mit dem Control-Byte kann im Prozessdatenbetrieb ein Gain- und Offsetabgleich der Klemme durchgeführt werden. Damit der Abgleich durchgeführt werden kann, muss zuvor das Code-Wort in Register R31 eingetragen werden. Erst durch Zurücksetzen des Code-Worts werden die Parameter permanent gespeichert!
CB1.4 | Gain | 1bin | Gain-Abgleich
CB1.3 | Offset | 1bin | Offset-Abgleich
CB1.2 | Clock | 0bin | langsamer Takt
 |  | 1bin | schneller Takt
CB1.1 | up | 1bin | rauf
CB1.0 | down | 1bin | runter
Status-Byte 1 (bei Prozessdatenbetrieb)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | - | - | - | - | Overrange | Underrange
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 | Error | 1bin | allgemeines Fehlerbit
SB1.5 ... SB1.2 | - | 0bin | reserviert
SB1.1 | Overrange | 1bin | Prozessdatum zu groß
SB1.0 | Underrange | 1bin | Prozessdatum zu klein


Registerkommunikation

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Bytes [image] Registerkommunikation
Registerkommunikation
Control-Byte 1 (bei Registerkommunikation)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit
Name
Beschreibung
CB1.7
RegAccess
1bin
Registerkommunikation eingeschaltet
CB1.6
R/W
0bin
Lesezugriff
1bin
Schreibzugriff
CB1.5 bis CB1.0
Reg-Nr.
Registernummer:
Tragen Sie hier die Nummer des Registers ein, das Sie
▪
mit dem Eingangsdatenwort DataIn lesen oder
▪
mit dem Ausgangsdatenwort DataOut beschreiben wollen
Status-Byte 1 (bei Registerkommunikation)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der Busklemme und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | A/D-Wandler, Rohwert |  | variabel | variabel | R | RAM
R1 | A/D-Wandler ,Rohwert der Leitung |  | variabel | variabel | R | RAM
R2 | reserviert |  | 0x0000 | 0dez | R | RAM
... | ... |  | ... | ... | ... | -
R5 | reserviert |  | 0x0000 | 0dez | R | RAM
R6 | Diagnose-Register |  | 0x0000 | 0dez | R | RAM
R7 | Kommando-Register (nicht benutzt) |  | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | KL3208-0010 | 0x0C88 | 3208dez | R | ROM
 |  | KL3228-0000 | 0x0C9C | 3228dez
R9 | Firmware-Stand |  | z. B. 0x3141 | z. B. 12609dez | R | ROM
R10 | Multiplex-Schieberegister |  | 0x0218 / 0x0130 | 536dez / 304dez | R | ROM
R11 | Signalkanäle |  | 0x0218 | 536dez | R | ROM
R12 | minimale Datenlänge eines Kanals |  | 0x0098 | 152dez | R | ROM
R13 | Datenstruktur |  | 0x0000 | 0dez | R | ROM
R14 | reserviert |  | - | - | - | -
R15 | Alignment-Register |  | variabel | variabel | R/W | RAM
R16 | Hardware-Versionsnummer |  | z. B. 0x0000 | z. B. 0dez | R/W | SEEPROM
R17 | Hersteller-Abgleich: Offset |  | spezifisch | spezifisch | R/W | SEEPROM
R18 | Hersteller-Abgleich: Gain |  | spezifisch | spezifisch | R/W | SEEPROM
R19 | Hersteller-Skalierung: Offset |  | 0x0000 | 0dez | R/W | SEEPROM
R20 | Hersteller-Skalierung: Gain |  | 0x0100 | 256dez | R/W | SEEPROM
R21 | Offset-Register 2-Draht Anschlusstechnik |  | spezifisch | spezifisch | R/W | SEEPROM
R22…R28 | reserviert |  | 0x0000 | 0dez | R/W | SEEPROM
R29 | Klemmentyp - Sonderkennung | KL3208-0010 | 0x000A | 0010dez | R | ROM
 |  | KL3228-0000 | 0x0000 | 0000dez
R30 | reserviert |  | 0x0000 | 0dez | R/W | SEEPROM
R31 | Codewort-Register |  | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register | KL3208-0010 | 0x0020 | 32dez | R/W | SEEPROM
 |  | KL3228-0000 | 0x0000 | 0dez
R33 | Anwender-Skalierung: Offset |  | 0x0000 | 0dez | R/W | SEEPROM
R34 | Anwender-Skalierung: Gain |  | 0x0100 | 256dez | R/W | SEEPROM
R35…R36 | ... |  | ... | ... | - | -
R37 | Filterkonstante des A/D-Wandlers | KL3208-0010 | 0x0000 | 0dez | R/W | SEEPROM
 |  | KL3228-0000 | 0x0138 | 312dez | R/W | SEEPROM
R38 | reserviert |  | 0x0000 | 0dez | R/W | SEEPROM
R39* | Weitere Elemente |  | 0x0000 | 0dez | R/W | SEEPROM
R40* | Wandlungszeit für alle Kanäle |  | 0x000A | 10dez | R/W | SEEPROM
R41* | B-Parameter für anwenderdefinierten NTC |  | 0x0F78 | 3960dez | R/W | SEEPROM
R42* | Widerstand bei 25°C für anwenderdefinierten NTC |  | 0x03E8 | 1000dez | R/W | SEEPROM
R43* | Referenztemperatur für anwenderdefinierten NTC |  | 0x0019 | 25dez | R/W | SEEPROM
R44* | Untere Bereichsgrenze für anwenderdefinierten NTC |  | 0xFFD8 | 65496dec | R/W | SEEPROM
R45* | Obere Bereichsgrenze für anwenderdefinierten NTC |  | 0x0082 | 130dez | R/W | SEEPROM
R46…R63 | reserviert |  | 0x0000 | 0dez | R/W | SEEPROM
*) Nur unterstützt von KL3208-0010, ab Firmware-Version 1C und ab Hardware-Version 01


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die Register dienen zur Parametrierung der Busklemme und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Eine Grundkonfiguration über die SPS ist mit den Funktionsbausteinen FB_KL3208Config (TwinCAT2, TwinCAT3) und FB_KL3228Config (TwinCAT2, TwinCAT3) ebenfalls möglich.
R0: A/D-Wandler, Rohwert
Im Register R0 steht der Rohwert des Analog/Digital-Wandlers. Dies ist der unveränderte Analogwert vor allen Skalierungen.
R1: A/D-Wandler, Rohwert der Leitung
Im Register R1 steht der Rohwert des Leitungswiderstandes zwischen +R1 – RL1 bzw. +R2 – RL2.
R6: Diagnose-Register
In das Low-Byte des Registers R6 wird das Status-Byte SBn des Kanals n eingeblendet.
R7: Kommando-Register
Das Kommandoregister der KL3228 wird nicht benutzt.
R8: Klemmenbezeichnung
Im Register R8 steht die Bezeichnung der Klemme:
▪
KL3208-0010: 0x0C88 (3208dez)
▪
KL3228-0000: 0x0C9C (3228dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R12: Minimale Datenlänge eines Kanals
Bit 0 bis 6 des höherwertigen Bytes geben die minimale Anzahl der Ausgangsdaten in Bit an: 000.0000bin = 0dez so 0 Byte.
Bit 0 bis 6 des niederwertigen Bytes geben die minimale Anzahl der Eingangsdaten in Bit an: 001.1000bin = 24dez so 3 Byte.
Das Bit 7 gesetzt ist zeigt, das Control- und Status-Byte für die Funktion der Klemme nicht zwingend erforderlich sind und im kompakten Modus nicht übertragen werden.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R17: Hersteller-Abgleich - Offset
Dieses Register beinhaltet den Offset des Hersteller-Abgleichs.
R18: Hersteller-Abgleich - Gain
Dieses Register beinhaltet den Gain des Hersteller-Abgleichs.
R19: Hersteller-Skalierung - Offset
Dieses Register beinhaltet den Offset der Hersteller-Skalierung. Kann durch R32.1 im Feature-Register aktiviert werden
R20: Hersteller-Skalierung - Gain
Dieses Register beinhaltet den Gain der Hersteller-Skalierung. Kann durch R32.1 im Feature-Register aktiviert werden
R21: Offsetregister für Zweileiter-Anschluss
Der Wert von Register 1 bei Kurzschluss +R1-RL1 bzw. +R2-RL2
R23: Referenz-Kalibrierwert: Offset
Dieses Register beinhaltet den Referenzwert der Kalibrierung, welcher beim Herstellerabgleich ermittelt wird.
R24: Referenz-Kalibrierwert: Gain
Dieses Register beinhaltet den Referenzwert der Kalibrierung, welcher beim Herstellerabgleich ermittelt wird.
R31: Codewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Codewort (0x1235) in das Codewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Codewort (0x1235) in das Codewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Codewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Betriebsart der Klemme fest.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | SensorType |  |  |  | disChannel | - | - | -
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | Resolution | - | - | disWdTimer | enManScal | enUsrScal
Legende
Bit | Name | Beschreibung |  | default
R32.15...R32.12 | SensorType | 0000bin | PT1000 | 0bin
 |  | 0001bin | NI1000
 |  | 0010bin | RSNI1000 (Hinweis: abweichende Kennlinie, ähnlich wie NI1000, aber mit 1000 Ω bei 0°C und 1500 Ω bei 100°C)
R32.11 | disChannel | 0bin | Kanal eingeschaltet | 0bin
 |  | 1bin | Kanal ausgeschaltet
R32.10… R32.2 | - | reserviert |  | 0bin
R32.1 | enManScal | 0bin | Hersteller-Skalierung nicht aktiv | 0bin
 |  | 1bin | Hersteller-Skalierung aktiv
R32.0 | enUsrScal | 0bin | Anwender-Skalierung nicht aktiv | 0bin
 |  | 1bin | Anwender-Skalierung aktiv
R33: Anwender-Skalierung - Offset
Dieses Register beinhaltet den Offset der Anwender-Skalierung. Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden
R34: Anwender-Skalierung - Gain
Dieses Register beinhaltet den Gain der Anwender-Skalierung. Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden
R37: Filterkonstante des A/D-Wandlers
Wert in R37 | First Notch | Wandlungszeit
0x0000 | 25 Hz | 250 ms
0x0050 | 100 Hz | 65 ms
0x00A0 | 50 Hz | 125 ms
0x0140 | 25 Hz | 250 ms
0x0280 | 12,5 Hz | 500 ms
R39: Weitere Elemente
Register R39 wird unterstützt von KL3208-0010, ab Firmware-Version 1C und Hardware-Version 01
(Default: 0dez)
Setzen von R39 erhöht die Wandlungszeit auf eine Sekunde pro Kanal
Sobald für einen Kanal der Klemme das Register R39 ungleich 0 ist, wird für alle Kanäle die Wandlungszeit automatisch und unabhängig vom Sensortyp auf ca. eine Sekunde pro Kanal erhöht, um die Messgenauigkeit zu optimieren. Die Wandlungszeit kann für alle Kanäle gemeinsam über Register R40 des Kanals 1 eingestellt werden. Eine Reduzierung wird wegen Genauigkeitsverlusten nicht empfohlen.
Wert in R39 |  | Element | Messbereich | R bei 25°C | R bei 0°C
0x0032 | 50dez | NCT1K8 | -40°C ... 130°C | 1,8 kΩ | 4940 Ω
0x0033 | 51dez | NCT1K8_TK | -30°C ... 150°C | 1,8 kΩ | 5200 Ω
0x0034 | 52dez | NCT2K2 | -50°C ... 130°C | 2,2 kΩ | 7373 Ω
0x0035 | 53dez | NCT3K | -50°C ... 80°C | 3,0 kΩ | 9822 Ω
0x0036 | 54dez | NCT5K | -40°C ... 100°C | 5,0 kΩ | 16325 Ω
0x0037 | 55dez | NTC10K | -30°C ... 150°C | 10 kΩ | 32650 Ω
0x0038 | 56dez | NTC10KPRE | -30°C ... 150°C | 10 kΩ | 29490 Ω
0x0039 | 57dez | NTC10K_3204 | -40°C ... 110°C | 10 kΩ | 27080 Ω
0x003A | 58dez | NTC10KTYP2 | -50°C ... 130°C | 10 kΩ | 32770 Ω
0x003B | 59dez | NTC10KTYP3 | -50°C ... 130°C | 10 kΩ | 29588 Ω
0x003C | 60dez | NTC10KDALE | -50°C ... 130°C | 10 kΩ | 32660 Ω
0x003D | 61dez | NTC10K3A221 | -40°C ... 130°C | 10 kΩ | 32639 Ω
0x003E | 62dez | NTC20K | -20°C ... 150°C | 20 kΩ | 70200 Ω
0x0064 | 100dez | Poti, Auflösung 0,1 Ω | 0 ... 5 kΩ | - | -
0x0065 | 101dez | Poti, Auflösung 1 Ω | 0 ... 10 kΩ | - | -
0x00C8 | 200dez | NTC100K | -40°C ... 130°C | 100 kΩ | 3266 kΩ
0x00FF | 255dez | anwenderdefinierter NTC |  |  |
Vermeiden Sie den Mischbetrieb von niederohmigen PT/NI-Sensoren und hochohmigen NTC-Sensoren an einer Klemme
Aufgrund großer Widerstandsunterschiede bei den Sensortypen sollte ein Mischbetrieb von niederohmigen PT/NI-Sensoren und hochohmigen NTC-Sensoren an einer Klemme vermieden werden, da dabei größere Messfehler für die PT/NI-Sensoren auftreten können.
R40: Wandlungszeit für alle Kanäle
Mit Register R40 des ersten Kanals können Sie für alle Kanäle der Klemme gemeinsam die Wandlungszeit vorgeben (Default: 10dez, entspricht ca. 120 ms pro Kanal).
R41: B-Parameter für anwenderdefinierten NTC
Dieses Register beinhaltet den B-Parameter eines anwenderdefinierten NTCs (Default: 3960dez = 0x0F78).
Der anwenderdefinierte NTC kann durch setzen des Registers R39 auf 255dez aktiviert werden.
R42: Widerstand bei 25°C für anwenderdefinierten NTC
Der Widerstand wird in 10 Ω / Digit vorgegeben. 1000dez entspricht also 10 kΩ
(Default: 1000dez = 0x03E8).
R43: Referenztemperatur für anwenderdefinierten NTC
(Default: 25°C = 0x0019)
R44: Untere Bereichsgrenze für anwenderdefinierten NTC
(Default: -40°C = 0xFFD8)
R45: Obere Bereichsgrenze für anwenderdefinierten NTC
(Default: 130°C = 0x0082)


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


TwinCAT

TwinCAT
TwinCAT
SPS und Motion Control auf dem PC
TwinCAT - The Windows Control and Automation Technology
Die Automatisierungs-Software TwinCAT verwandelt jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS, NC-Achsregelung, Programmierumgebung und Bedienstation. TwinCAT substituiert herkömmliche SPS- und NC/CNC-Steuerungen sowie Bediengeräte:
▪
offene, kompatible PC-Hardware
▪
Einbettung von IEC 61131-3-Software-SPS, Software-NC und Software-CNC in Windows NT/2000/XP, NT/XP Embedded, CE
▪
Programmiersystem und Laufzeit wahlweise auf einem PC oder getrennt
▪
Anbindung an alle gängigen Feldbus-Systeme
▪
PC-Schnittstellen werden unterstützt
▪
Datenanbindung an Bedienoberflächen und andere Programme mittels offener Standards (OPC, OCX, DLL etc.)
TwinCAT-Architektur
TwinCAT besteht aus Laufzeitsystemen zur Echtzeitausführung von Steuerungsprogrammen und den Entwicklungsumgebungen zur Programmierung, Diagnose und Konfiguration. Alle Windows-Programme, beispielsweise Visualisierungen oder Office-Produkte, können über Microsoft-Schnittstellen auf TwinCAT-Daten zugreifen oder Kommandos ausführen.
Praxisorientierte Softwarelösung
TwinCAT bietet eine genaue Zeitbasis, die mit höchster Deterministik Programme unabhängig von anderen Prozessoraufgaben ausführt. Die Echtzeitlast auf einem PC wird mit TwinCAT eingestellt: Auf diese Weise wird ein definiertes Betriebsverhalten erreicht. TwinCAT zeigt die Systemlast für laufende Programme an. Eine Lastgrenze kann eingestellt werden, um für die Bedienprogramme und Windows NT/2000/XP eine definierte Rechenkapazität zur Verfügung zu stellen. Bei Überschreiten dieser Grenze wird eine Systemmeldung generiert.
TwinCAT unterstützt die Systemdiagnose
Die freie Verwendung von Hardware oder Software aus der offenen PC-Welt erfordert ihre Prüfung: Ungeeignete Komponenten können das PC-System außer Tritt bringen. Beckhoff integriert eine praktische Anzeige des Jitters der Echtzeit, um einem Administrator ein einfaches Mittel zur Evaluierung von Hardware und Software an die Hand zu geben. Im Betrieb kann eine Systemmeldung auf Fehlerzustände aufmerksam machen.
Start-/Stoppverhalten
TwinCAT startet und stoppt, je nach Einstellung, durch manuellen Eingriff oder automatisch. Da TwinCAT als Service in Windows NT/2000/XP integriert ist, wird zum Systemstart kein Bediener benötigt: Strom einschalten genügt.
Wiederanlauf und Datensicherung
TwinCAT lädt beim Start oder Wiederanlauf Programme und remanente Daten. Zur Datensicherung und zum korrekten Beenden von Windows NT/2000/XP empfiehlt sich eine USV (unterbrechungsfreie Stromversorgung).
TwinCAT und „Blue Screen“
Das TwinCAT-System kann so konfiguriert werden, dass die Echtzeit im Falle eines Betriebssystemabsturzes BSOD (Blue-Screen-of-Death) funktionell erhalten bleibt. Echtzeittasks, wie z. B. die SPS und NC, können somit weiterlaufen und den gesteuerten Prozess in einen sicheren Zustand bringen. Letztlich liegt es in der Entscheidung des Programmierers, diese Eigenschaft zu nutzen in Anbetracht dessen, dass Daten oder Programme durch den BSOD bereits zerstört sein können.
Weltweite Verbindung per Message-Routing – Remote-Verbindung ist systemimmanent
Die Softwaregeräte von TwinCAT können, je nach Anforderung, auf Betriebsmittel verteilt werden: TwinCAT-SPS-Programme können auf PCs und auf Beckhoff Busklemmen Controllern ablaufen. Ein „Message-Router“ verwaltet und verteilt alle Nachrichten im System und über TCP/IP-Verbindungen. PC-Systeme können per TCP/IP miteinander verbunden werden; Busklemmen Controller werden über serielle Schnittstellen und über Feldbus-Systeme (EtherCAT, Lightbus, PROFIBUS DP, PROFINET, Interbus, CANopen, DeviceNet, RS232, RS485, Ethernet TCP/IP, Ethernet/IP) angebunden.
Weltweiter Zugriff
Da Standard-TCP/IP-Dienste von Windows NT/2000/XP genutzt werden, kann dieser Datenaustausch weltweit erfolgen. Das System bietet skalierbare Kommunikationsleistung und Time-out-Zeiten zur Überwachung von Kommunikationen. Mittels OPC kann auf einem standardisierten Weg auf viele unterschiedliche SCADA-Pakete zugegriffen werden. Mit dem SOAP (Simple-Object-Access-Protocol) kann über eine Internetverbindung via Standard-HTTP eine Verbindung zwischen zwei Rechnern hergestellt werden. Auch hierzu bietet TwinCAT eine Komponente an.
Beckhoff-Information-System
Weitere Informationen über die Automatisierungs-Software TwinCAT finden Sie im Beckhoff-Information-System.
Das Setup zur Installation des Beckhoff-Information-Systems steht Ihnen auf der Beckhoff-DVD Products & Solutions und auf unseren Internetseiten zum Download zur Verfügung.
Außerdem finden Sie unter http://infosys.beckhoff.com die Online-Version des Beckhoff-Information-System.
Weiterführende Informationen
•
Programmierung
•
KL3208, KL3228 - Funktionsbausteine zur Konfiguration


Programmierung

TwinCAT [image] Programmierung
Programmierung
TwinCAT-Bibliotheken
Siehe Software-Dokumentation im Beckhoff-Information-System.
TwinCAT 2: TwinCAT PLC Lib: IO Funktionen
TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_IoFunctions


KL3208, KL3228 - Funktionsbausteine zur Konfiguration

TwinCAT [image] KL3208, KL3228 - Funktionsbausteine zur Konfiguration
KL3208, KL3228 - Funktionsbausteine zur Konfiguration
FB_KL3208Config, FBKL3228Config
Mit dem Funktionsbausteinen FB_KL3208Config und FB_KL3228 können die Klemme KL3208 und KL3228 konfiguriert werden. Eine ausführliche Beschreibung Sie im Beckhoff Information System.
FB_KL3208Config:
TwinCAT2: TwinCAT PLC Lib: IO Funktionen/Busklemmen-Konfiguration
TwinCAT3: TwinCAT 3 PLC Lib:Tc2_IoFunctions/Funktionsbausteine/Busklemmen-Konfiguration
FB_KL3228Config:
TwinCAT2: TwinCAT PLC Lib: IO Funktionen/Busklemmen-Konfiguration
TwinCAT3: TwinCAT 3 PLC Lib:Tc2_IoFunctions/Funktionsbausteine/Busklemmen-Konfiguration


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.