KL31x2 - Präzise zweikanalige Analogeingangsklemmen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.4.0
▪
Hinweis zur Differentiellen Messung ergänzt
2.3.0
▪
Beispielprogramm zum Kapitel “Konfigurations-Software KS2000“ hinzugefügt
2.2.0
▪
Update Kapitel „Technische Daten“ (nur Spannungsmessklemmen)
2.1.0
▪
Update Kapitel „Grundlagen zur Funktion“
2.0.0
▪
Migration
1.6.0
▪
Titelseite und Einführung korrigiert
▪
Vorwort aktualisiert
▪
Technische Daten aktualisiert
1.5.0
▪
Registerbeschreibung aktualisiert (R32)
▪
Technische Daten aktualisiert
▪
KL3172-0500 und KL3172-1000 hinzugefügt
▪
ATEX-Hinweise hinzugefügt
1.4
▪
Control- und Status-Byte aktualisiert
▪
Montagebeschreibung erweitert
1.3
▪
LED-Beschreibungen aktualisiert (Prismen, neue RUN-LEDs)
▪
Anschlussbeschreibung aktualisiert (Powerkontakte, neue Anschlussbelegung für Klemmstellen)
▪
Kanalabschaltung hinzugefügt
▪
Technische Daten der KL3142 und KL3152 aktualisiert
1.2.1
▪
Anschlussbelegung korrigiert
1.2
▪
Registerbeschreibung erweitert (Kommando 7000)
1.1
▪
Technische Daten aktualisiert
▪
Beschreibung der Klemmstellen 3 und 7 an endgültige Anschlussbelegung angepasst
▪
KL3132, KL3142, KL3152, KL3162 und KL3182 hinzugefügt
1.0
erste Version (nur KL3172)
Firm- und Hardware-Stände
Dokumen- tation, Version | KL3132-0000 |  | KL3142-0000 |  | KL3152-0000 |  | KL3162-0000 |  | KL3172-0000 |  | KL3172-0500, KL3172-1000 |  | KL3182-0000
 | Firmw | Hardw | Firmw | Hardw | Firmw | Hardw | Firmw | Hardw | Firmw | Hardw | Firmw | Hardw | Firmw | Hardw
2.3.0 | 2D | 04 | 2E | 04 | 2D | 04 | 2D | 04 | 2D | 03 | 2D | 03 | 2D | 03
2.2.0 | 2D | 04 | 2E | 04 | 2D | 04 | 2D | 04 | 2D | 03 | 2D | 02 | 2D | 03
2.1.0 | 2D | 04 | 2E | 04 | 2D | 04 | 2D | 04 | 2D | 03 | 2D | 02 | 2D | 03
2.0.0 | 2D | 04 | 2E | 04 | 2D | 04 | 2D | 04 | 2D | 03 | 2D | 02 | 2D | 03
1.6.0 | 2D | 03 | 2E | 03 | 2D | 03 | 2D | 03 | 2D | 02 | 2D | 02 | 2D | 02
1.5.0 | 2D | 03 | 2E | 03 | 2D | 03 | 2D | 03 | 2D | 02 | 2D | 02 | 2D | 02
1.4 | 2A | 01 | 2B | 01 | 2A | 01 | 2A | 01 | 2A | 01 | - | - | 2A | 01
1.3 | 2A | 01 | 2A | 01 | 2A | 01 | 2A | 01 | 2A | 01 |  |  | 2A | 01
1.2.1 | 1A | 00 | 1A | 00 | 1A | 00 | 1A | 00 | 1B | 00 |  |  | 1A | 00
1.2 | 1A | 00 | 1A | 00 | 1A | 00 | 1A | 00 | 1B | 00 |  |  | 1A | 00
1.1 | 1A | 00 | 1A | 00 | 1A | 00 | 1A | 00 | 1B | 00 |  |  | 1A | 00
1.0 | - | - | - | - | - | - | - | - | B1 | 00 |  |  | - | -
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 35 04 1B 01:
35 - Produktionswoche 35
04 - Produktionsjahr 2004
1B - Firmware-Stand 1B
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KL3132, KL3162, KL3172, KL3182
•
KL3142, KL3152
•
Grundlagen zur Funktion
•
LEDs


KL3132, KL3162, KL3172, KL3182

Produktübersicht [image] KL3132, KL3162, KL3172, KL3182
KL3132, KL3162, KL3172, KL3182
Weiterführende Informationen
•
Einführung
•
Technische Daten


Einführung

Produktübersicht [image] KL3132, KL3162, KL3172, KL3182 [image] Einführung
Einführung
KL3132
Zweikanalige Analogklemmen mit Spannungseingängen (0,05% Genauigkeit)
Die analogen Eingangsklemmen KL3132, KL3162, KL3172 und KL3182 verarbeiten Signale im Bereich von -10 V bis +10 V. Die Spannung wird mit einer Auflösung von 16 Bit digitalisiert und galvanisch getrennt zum übergeordneten Automatisierungsgerät transportiert. Die Eingangskanäle einer Busklemme sind Differenzeingänge und besitzen ein gemeinsames, internes Massepotenzial. Aufgrund ihres geringen Messfehlers von ±0,05% vom Messbereichsendwert sind diese Klemmen optimiert für hochgenaue Regelprozesse, wie z. B. Dosieren, Füllen oder Qualitätssicherung. Die Busklemmen vereinen jeweils 2 Kanäle in einem Gehäuse. Status- und Error-LEDs zeigen den Zustand der Klemme an.
Übersicht
KL3132-0000: -10 ... +10 V
KL3162-0000: 0 ... +10 V
KL3172-0000: 0,0 ... +2,0 V
KL3172-0500: 0,0 ... +0,5 V
KL3172-1000: 0,0 ... +1,0 V
KL3182-0000: -2,0 ... +2,0 V


Technische Daten

Produktübersicht [image] KL3132, KL3162, KL3172, KL3182 [image] Technische Daten
Technische Daten
Technische Daten | KL3132-0000, KS3132-0000 | KL3162-0000, KS3162-0000 | KL3172-0000, KS3172-0000 | KL3172-0500, KS3172-0500 | KL3172-1000, KS3172-1000 | KL3182-0000, KS3182-0000
Anzahl der Eingänge | 2
Eingangssignal | -10 V ... +10 V | 0 ... 10 V | 0 ... 2 V | 0 ... 500 mV | 0 ... 1 V | -2 V ... +2 V
Eingangswiderstand | > 70 kΩ
Gleichtaktspannung UCM | ±10 V
Auflösung | 16 Bit
Wandlungszeit | 140 ms, konfigurierbar
Messfehler (gesamter Messbereich) | ±0,05% vom Messbereichsendwert, Selbstkalibrierung
Bitbreite im K-Bus E /A | 2 x 16 Bit Nutzdaten (optional 2 x 8 Bit Control/Status)
Bitbreite im Eingangsprozessabbild | 2 Datenworte, 2 Status-Bytes
Bitbreite im Ausgangsprozessabbild | 2 Datenworte, 2 Control-Bytes
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 85 mA
Potenzialtrennung | 500 V (Differenzeingang / K-Bus)
Anschluss | Federkrafttechnik
Steckbare Verdrahtung | bei allen KSxxxx-Klemmen
Gewicht | ca. 70 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus, ATEX


KL3142, KL3152

Produktübersicht [image] KL3142, KL3152
KL3142, KL3152
Weiterführende Informationen
•
Einführung
•
Technische Daten


Einführung

Produktübersicht [image] KL3142, KL3152 [image] Einführung
Einführung
KL3142
Zweikanalige Analogklemmen mit Stromeingängen (0,05% Genauigkeit)
Die analogen Eingangsklemmen KL3142 und KL3152 verarbeiten Signale im Bereich von 0 bis 20 mA bzw. 4 bis 20 mA. Der Strom wird mit einer Auflösung von 16 Bit (Default: 15 Bit) digitalisiert und galvanisch getrennt zum übergeordneten Automatisierungsgerät transportiert. Die Eingangskanäle der Busklemmen sind Differenzeingänge und besitzen ein gemeinsames, internes Massepotenzial. Aufgrund ihres geringen Messfehlers von ±0,05% vom Messbereichsendwert sind diese Klemmen optimiert für hochgenaue Regelprozesse, wie z. B. Dosieren, Füllen, oder Qualitätssicherung. Die Busklemmen vereinen 2 Kanäle in einem Gehäuse. Leitungsbruch und Überlastung werden erkannt und der Klemmenstatus über den K-Bus zur Steuerung weitergeleitet. Status- und Error-LEDs zeigen den Zustand der Klemme an.
Übersicht
KL3142-0000: 0 ... 20 mA
KL3152-0000: 4 ... 20 mA


Technische Daten

Produktübersicht [image] KL3142, KL3152 [image] Technische Daten
Technische Daten
Technische Daten | KL3142-0000, KS3142-0000 | KL3152-0000, KS3152-0000
Anzahl der Eingänge | 2
Signalstrom | 0 ... 20 mA | 4 ... 20 mA
Innenwiderstand | 100 Ω Messwiderstand
Gleichtaktspannung UCM | ±10 V
Auflösung | 16 Bit
Wandlungszeit | 140 ms, konfigurierbar
Messfehler (gesamter Messbereich) | ±0,05% vom Messbereichsendwert, Selbstkalibrierung
Bitbreite im K-Bus E /A | 2 x 16 Bit Nutzdaten (optional 2 x 8 Bit Control/Status)
Bitbreite im Eingangsprozessabbild | 2 Datenworte, 2 Status-Bytes
Bitbreite im Ausgangsprozessabbild | 2 Datenworte, 2 Control-Bytes
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 85 mA
Überspannungsfestigkeit | 35 VDC
Potenzialtrennung | 500 V (Differenzeingang / K-Bus)
Anschluss | Federkrafttechnik
Steckbare Verdrahtung | bei allen KSxxxx-Klemmen
Gewicht | ca. 70 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus, ATEX


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Mit den präzisen Analogeingangsklemmen KL3172 können zwei Spannungen (KL3132, KL3162, KL3172, KL3182) bzw. zwei Ströme (KL3142, KL3152) gemessen und mit einer Auflösung von 16 Bit (65535 Schritte) dargestellt werden. Die hochgenaue Messwertaufnahme wird durch zyklische Selbstkalibrierung gewährleistet.
Die Eingänge sind standardmäßig als Differentialeingänge geschaltet. Bei den Klemmen KL3132, KL3162, KL3172 und KL3182 kann die Klemmstelle -E1 des ersten Kanals mit Bit R32.6 des Featureregisters auf die interne Analogmasse geschaltet werden.
Prozessdaten
Analogwerte werden wie folgt dargestellt:
Eingangssignal |  |  |  |  |  | Wert
KL3142-0000 | KL3152-0000 | KL3162-0000 | KL3172-0000 | KL3172-0500 | KL3172-1000 | dez | hex
0 mA | 4 mA | 0 V | 0 V | 0 V | 0 V | 0 | 0x0000
20 mA | 20 mA | 10 V | 2 V | 500 mV | 1 V | 65535 | 0xFFFF
Eingangssignal |  | Wert
KL3132-0000 | KL3182-0000 | dez | hex
-10 V | -2 V | -32768 | 0x8000
+10 V | +2 V | +32767 | 0x7FFF
Berechnung
Die Klemme nimmt permanent Messwerte auf und legt die Rohwerte ihres A/D-Wandlers ins Register R0 (RAM ). Nach jeder Erfassung des Analogsignals erfolgt die Korrekturberechnung mit den Abgleich- und ggf. mit den Kalibrierwerten. Anschließend folgt noch die Hersteller- und die Anwenderskalierung:
YA = (XADC + BA) x AA | (1.0) | Hersteller-Abgleich (bei deaktivierter Kalibrierung)
YA = ((XADC + BK) x AA) x (AGK / AK) | (1.1) | Hersteller-Abgleich / Kalibrierung (bei aktivierter Kalibrierung)
YH = YA x AH + BH | (1.2) | Hersteller-Skalierung
Yaus = YH x AW + BW | (1.3) | Anwender-Skalierung
Legende
Name | Bezeichnung | Einheit | Register
XADC | Ausgabe Wert des A/D-Wandlers | [1] | -
Yaus | Prozessdaten zur Steuerung | [1] | -
BA | Hersteller-Abgleich: Offset (deaktivierbar über Bit R32.5 des Feature-Registers) | [1] | R17
AA | Hersteller-Abgleichs: Gain (immer aktiv) | [1 x 2-16 + 1] | R18
BK | Kalibrierung: Offset (aktivierbar über Bit R32.5 des Feature-Registers) | [1] | R1
AK | Kalibrierung: Gain (aktivierbar über Bit R32.5 des Feature-Registers) | [1] | R2
AGK | Grundkalibrierung: Gain (aktivierbar über Bit R32.5 des Feature-Registers) | [1] | R23
BH | Hersteller-Skalierung: Offset (aktivierbar über Bit R32.1 des Feature-Registers) | [1] | R19
AH | Hersteller-Skalierung: Gain (aktivierbar über Bit R32.1 des Feature-Registers) | [1 x 2-8 + 1] | R20
BW | Anwender-Skalierung: Offset (aktivierbar über Bit R32.0 des Feature-Registers) | [1] | R33
AW | Anwender-Skalierung: Gain (aktivierbar über Bit R32.0 des Feature-Registers) | [1 x 2-8 + 1] | R34
Kalibrierung
Die Analogkanäle werden periodisch einer Selbstkalibrierung unterzogen. Dafür sind interne Analogschalter vorgesehen, um die verschiedenen Kalibriersignale aufschalten zu können. Wichtig dabei ist, dass in jeder Phase der Kalibrierung immer der gesamte Signalpfad (inklusive aller passiven Bauteile) überprüft wird. Lediglich die Entstörglieder (L/C-Kombination) und die Analogschalter selber können nicht erfasst werden.
Das Kalibrierintervall wird in 100 ms Schritten mit Register R40 eingestellt. Während der Kalibrierung liegen keine aktuellen Prozessdaten an, sondern der Wert 0. Eine aktive Kalibrierung wird von der Klemme durch setzen des Bits SB1.6 im Status-Byte und durch Löschung der entsprechenden RUN-LED signalisiert. Die Kalibrierung kann von der Steuerung über das Control-Byte CB1.1 gesperrt werden falls dies erforderlich ist. Falls die Kalibrierung über einen längeren Zeitraum gesperrt wird, führt die Klemme eine Zwangskalibrierung durch, um durch Temperaturänderungen eventuell auftretende Spannungsdrifts auszugleichen. Das Intervall der Zwangskalibrierung wird mit Register R44 als Vielfaches vom Kalibrierintervall vorgegeben. Ist eine weitere Kalibrierung zwischen zwei Zyklen erforderlich, kann diese manuell durch Setzen des Bits CB1.0 gestartet werden. Die Klemme verhält sich dann genauso, als wenn sie selbst eine Kalibrierung ausgelöst hätte.
Schwankende Messsignale stören die Selbstkalibrierung
Die Klemme prüft in der Kalibrierungsphase per Stabilisierungsprüfung ob das Eingangssignal stabil ist. Stark schwankende Messsignale verhindern eine Beendigung der Selbstkalibrierung, sie bleibt mit Error=1 und Overload/Underload=1 stehen, vgl. Kapitel „Grundlagen zur Funktion/ Kalibrierung“ und „Zugriff aus dem Anwenderprogramm/ Status‑Byte 1 (bei Prozessdatenbetrieb)“.
Wird an der Anlage solcherart Signal erwartet kann wahlweise
- die Selbstkalibrierung per Control-Bit CB1.1 solange im Prozess gesperrt werden bis ein ruhiges Signal anliegt und die Selbstkalibrierung durchläuft.
- die Stabilisierungsprüfung mit Bit R32.7 abgeschaltet werden.
- die Anzeige des Stabilisierungsfehlers mit Bit R32.14 abgeschaltet werden.
- das Toleranzfenster R48 der Stabilisierungskontrolle vergrößert werden.
Die Funktionalität der Kalibrierung mit allen Eigenschaften bezieht sich immer auf beide Kanäle gleichzeitig! Die Kanäle können nicht einzeln Kalibriert werden. Aus diesem Grund sind die Register R40, R44, R47 und R48 für beide Kanäle nur einmal ausgeführt.
▪
In der ersten Kalibrierphase werden beide Analogeingänge mit einer Eingangsspannung von 0 V (Null-Kalibrierung) beaufschlagt. Somit können die Nullpunkte beider Analogeingangsstufen ermittelt werden. Bei dieser Messung ist der jeweilige Absolutwert, der Kanäle von Interesse. Der Wert wird anschließend im RAM (Register R1) abgelegt.
▪
In der zweiten Kalibrierphase werden beide Analogeingänge mit einer internen Referenzspannung von ca. 1,8 V (End-Kalibrierung) beaufschlagt. Hier interessiert nicht mehr der Absolutwert des Messergebnisses, sondern nur noch die eventuelle Abweichung des bei der Produktion ermittelten Grundkalibrierwertes (Register R23). Diese werden ins Verhältnis gesetzt und fließen in die nächste Korrekturrechnung ein. Der Wert wird anschließend im RAM (Register R2) abgelegt.
Stabilisierung der Kalibrierung
Während der Kalibrierung wird eine Stabilisierung der Offset- und Gain-Werte durchgeführt. Erst wenn eine gewisse Anzahl (durch Register R47 vorgegeben) an Messwerten innerhalb einer bestimmten Toleranz (durch Register R48 vorgegeben) liegt, werden die Kalibrierwerte übernommen. Dadurch wird eine weitere Steigerung der Genauigkeit erreicht. Diese Funktion kann durch das Bit R32.7 deaktiviert werden.
Grenzwerte
Die Klemme bietet die Möglichkeit der Überwachung von zwei Grenzwerten pro Kanal. Grenzwert 1 kann über Register R35 und Grenzwert 2 über Register R36 vorgegeben werden. Aktiviert werden sie durch Bits im Feature-Register R32.9 und R32.10. Der Status des aktuellen Prozessdatenwertes wird der Steuerung durch das Status-Byte SB1 signalisiert. Mögliche Zustände sind: Prozessdaten gleich Grenzwert (3), Prozessdaten kleiner Grenzwert (2) und Prozessdaten größer Grenzwert (1).
Begrenzung des Messbereichs
Die Klemme signalisiert der übergeordneten Steuerung eine Über- und Unterschreitung des Messbereichs im Status-Byte.
▪
Ist der aktuelle Messwert größer als 0xFFFF bzw. 0x7FFF wird das Bit SB1.1 gesetzt.
▪
Ist der aktuelle Messwert kleiner als 0 bzw. 0x8000 wird das Bit SB1.0 gesetzt.
In beiden Fällen leuchtet die ERROR-LED des jeweiligen Kanals. Diese Funktion kann durch das Bit R32.8 deaktiviert werden.
Differentielle Messung
Bei den KL3132, KL3162, KL3172, KL3182 kann in R32.6 die differentielle Messung deaktiviert werden. Dann wird bei Kanal 1 und 2 intern der Input- auf GND an Klemmpunkt 3/7 geschaltet, dieser ist dann entsprechend außen zu verdrahten.
Differentielle Messung


LEDs

Produktübersicht [image] LEDs
LEDs
LEDs
LED
Anzeige
K-Bus Power
(grün)
EIN
Spannungsversorgung (5 V) auf dem K-Bus vorhanden
AUS
keine Spannungsversorgung (5 V) auf dem K-Bus vorhanden
K-Bus Run
(grün)
EIN
Datenübertragung auf dem K-Bus aktiv
AUS
Datenübertragung auf dem K-Bus nicht aktiv
Run 1
(grün)
EIN
Kanal 1 aktiv:
▪
gültiger Analogwert in den Prozessdaten
AUS
Kanal 1 nicht aktiv:
▪
eine Kalibrierung wird durchgeführt, Analogwert in den Prozessdaten nicht aktuell (eingefroren oder Null)
▪
oder Kanal 1 ist abgeschaltet (wenn LED Error 1 nicht leuchtet)
Error 1
(rot)
EIN
▪
Analogwert von Kanal 1 ist oberhalb des gültigen Messbereichs, vorgegeben durch Register R21 des Kanals 1. Im Status-Byte des Kanals 1 wird das Bit SB1.1 gesetzt.
▪
Analogwert von Kanal 1 ist unterhalb des gültigen Messbereichs, vorgegeben durch Register R22 des Kanals 1. Im Status-Byte des Kanals 1 wird das Bit SB1.0 gesetzt.
▪
Es findet gerade eine Kalibrierung statt. Nach Beendigung der Kalibrierung erlischt die LED wieder.
AUS
▪
Analogwert von Kanal 1 ist innerhalb des gültigen Messbereichs (wenn LED Run 1 leuchtet)
▪
oder Kanal 1 ist abgeschaltet (wenn LED Run 1 nicht leuchtet)
Run 2
(grün)
EIN
Kanal 2 aktiv:
▪
gültiger Analogwert in den Prozessdaten
AUS
Kanal 2 nicht aktiv:
▪
eine Kalibrierung wird durchgeführt, Analogwert in den Prozessdaten nicht aktuell (eingefroren oder Null)
▪
oder Kanal 2 ist abgeschaltet (wenn LED Error 2 nicht leuchtet)
Error 2
(rot)
EIN
▪
Analogwert von Kanal 2 ist oberhalb des gültigen Messbereichs, vorgegeben durch Register R21 des Kanals 2. Im Status-Byte des Kanals 2 wird das Bit SB2.1 gesetzt.
▪
Analogwert von Kanal 2 ist unterhalb des gültigen Messbereichs, vorgegeben durch Register R22 Kanals 2. Im Status-Byte des Kanals 2 wird das Bit SB2.0 gesetzt.
▪
Es findet gerade eine Kalibrierung statt. Nach Beendigung der Kalibrierung erlischt die LED wieder.
AUS
▪
Analogwert von Kanal 2 ist innerhalb des gültigen Messbereichs (wenn LED Run 2 leuchtet)
▪
oder Kanal 2 ist abgeschaltet (wenn LED Run 2 nicht leuchtet)
Begrenzung des Messbereichs
Die Klemme signalisiert der übergeordneten Steuerung eine Über- und Unterschreitung des Messbereichs im Status-Byte. Ist der aktuelle Messwert
▪
größer als im Register R21 spezifiziert, wird im Status-Byte das Bit 1 gesetzt,
▪
kleiner als im Register R22 spezifiziert wird im Status-Byte das Bit 0 gesetzt.
In beiden Fällen leuchtet die ERROR-LED des jeweiligen Kanals. Diese Anzeige kann durch das Bit R32.8 deaktiviert werden.


Einbau und Verdrahtung

Einbau und Verdrahtung
Einbau und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Anschluss
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX-Dokumentation
•
Anwendungsbeispiel für KL3172-0000


Tragschienenmontage

Einbau und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschluss

Einbau und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung
•
Anschlussbelegung


Anschlusstechnik

Einbau und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Einbau und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Einbau und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Anschlussbelegung

Einbau und Verdrahtung [image] Anschluss [image] Anschlussbelegung
Anschlussbelegung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL3132 - Anschlussbelegung
KL3142 - Anschlussbelegung
Klemmstelle | Nr. | Anschluss für
Input 1+ | 1 | + Eingang Kanal 1
Input 1- | 2 | - Eingang Kanal 1
GND | 3 | interne Masse (intern verbunden mit Klemmstelle 7)
Schirm | 4 | PE-Kontakt (intern verbunden mit Klemmstelle 8)
Input 2+ | 5 | + Eingang Kanal 2
Input 2- | 6 | - Eingang Kanal 2
GND | 7 | interne Masse (intern verbunden mit Klemmstelle 3)
Schirm | 8 | PE-Kontakt (intern verbunden mit Klemmstelle 4)
Hinweis
Powerkontakte zur nächsten Klemme durchgeführt
Ab Hardware-Stand 01 werden zwei Power-Kontakte zur nächsten Klemme durchgeführt. Sie werden aber von der KL31x2 nicht benutzt.
Beachten Sie dies, wenn Sie Hardware-Stand 00 durch höhere Hardware-Stände ersetzen!
Den Hardware-Stand ihrer Klemme können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Einbau und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX-Dokumentation

Einbau und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Anwendungsbeispiel für KL3172-0000

Einbau und Verdrahtung [image] Anwendungsbeispiel für KL3172-0000
Anwendungsbeispiel für KL3172-0000
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Überwachung der Zellspannungen einer Batterie mit mehreren KL3172.
KL3172-0000 - Anwendungsbeispiel
Hinweis
Spannungsfestigkeit nicht überschreiten!
Beachten Sie, das die Summe der Zellspannungen (im Beispiel UB = n x 1,5 V) die Spannungsfestigkeit (Potentialtrennung 500 V) der KL3172 nicht überschreiten darf!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Register
•
Einstellungen
•
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Ethernet-Koppler BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine präzise zweikanalige Analogeingangsklemme für Signale von 0 bis 2 V, KL3172
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).
KS2000 Baumzweig für Kanal 1 der KL3172
Für die KL3172 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL3172.
▪
Unter Einstellungen finden Sie Dialogmaske zur Parametrierung der KL3172.
▪
ProcData zeigt die Prozessdaten der KL3172.


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register der KL3172 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Registeransicht in KS2000


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Unter Einstellungen finden Sie die Dialogmaske zur Parametrierung der KL3172.
Einstellungen über KS2000
Betriebsmodus
Kanal deaktiviert (R32.11)
Hier können Sie diesen Kanal deaktivieren um eine schnellere Zykluszeit für den anderen Kanal zu ermöglichen (Default: nicht deaktiviert).
Ein deaktivierter Kanal wird durch verlöschen seiner Run- und Error-LED angezeigt.
Anwender-Skalierung aktiv (R32.0)
Hier können Sie die Anwender Skalierung aktivieren (Default: deaktiviert).
Hersteller-Skalierung aktiv (R32.1)
Hier können Sie die Hersteller Skalierung aktivieren (Default: deaktiviert).
Watchdog Timer aktiv (R32.2)
Hier können Sie den Watchdog Timer deaktivieren (Default: aktiviert).
Betrags-Vorzeichen Darstellung (R32.3)
Hier können Sie die Betrags-Vorzeichen Darstellung aktivieren (Default: deaktiviert).
Siemens-Ausgabeformat (R32.4)
Hier können Sie das Siemens-Ausgabeformat aktivieren (Default: deaktiviert).
Kalibrierung aktiv (R32.5)
Hier können Sie die Kalibrierung deaktivieren (Default: aktiviert).
differentielle Messung (R32.6)
Hier können Sie die differentielle Messung deaktivieren (Default: aktiviert).
Stabilisierung der Kalibrierung aktiv (R32.7)
Hier können Sie die Stabilisierung der Kalibrierung deaktivieren (Default: aktiviert)..
Begrenzung des Messbereichs aktiv (R32.8)
Hier können Sie die Begrenzung des Messbereichs deaktivieren (Default: aktiviert)..
Grenzwert 1 aktiv (R32.9)
Hier können Sie den Grenzwert 1 aktivieren (Default: deaktiviert)..
Grenzwert 2 aktiv (R32.10)
Hier können Sie den Grenzwert 2 aktivieren (Default: deaktiviert)..
Registerwerte
Anwender Offset (R33)
Hier können Sie den Anwender Offset von -32768 bis 32767 vorgeben (Default: 0).
Anwender Gain (R34)
Hier können Sie den Anwender Gain von 0 bis 65535 vorgeben (Default: 256, entspricht einem Faktor von 1).
Kalibrierintervall (R40)
Hier können Sie in Stufen von 100 ms das Kalibrierintervall für das Referenzsignal vorgeben (Default: 300 s).
Intervall für Zwangskalibrierung (R44)
Hier können Sie das Intervall für Zwangskalibrierung vorgeben. Dieses Intervall ist immer ein vielfaches (Default: 3dez) des Kalibrierintervalls. Somit ergibt sich im Auslieferungszustand ein Intervall für Zwangskalibrierung von 3 x 180 s = 900 s.
Anzahl der stabilen Messwerte (R47)
Hier können Sie die Anzahl der bei der Kalibrierung gewerteten Messwerte vorgeben (Default: 50).
Toleranz für Messwert-Stabilität (R48)
Hier können Sie die Toleranz der stabilen Messwerte bei der Kalibrierung vorgeben (Default: 5).
Grenzwert 1 (R35)
Hier können Sie den Grenzwert 1 vorgeben (Default: 0).
Grenzwert 2 (R36)
Hier können Sie den Grenzwert 2 vorgeben (Default: 0).
Filterkonstante (R37.11-R37.4)
Die Filterkonstante SF legt die 3dB Grenzfrequenz des sinc3 Filters fest (Default: 860dez).
Fast-Step-Modus(TM) aktiv (R37.0)
Hier können Sie den Fast-Step-Modus aktivieren (Default: deaktiviert). Im Fast-Step-Modus erfolgt trotz aktiver Filterstufe eine schnelle Reaktion auf Sprünge am Eingang. Das Filter wird in diesem Fall umgangen!
FIR-Filter aktiv (R37.1)
Hier können Sie das FIR-Filter deaktivieren (Default: aktiviert).


Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314

Konfigurations-Software KS2000 [image] Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Anwenders zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Programmbeschreibung/ Funktion
Dieses Beispielprogramm (TwinCAT 3) erlaubt per AoE die Änderung einzelner Registerwerte der KL3314 wie die Auswahl des Element-Typs und charakteristische Einstellungen des Feature‑Registers R32 sowie die Anwenderskalierung Offset und Gain (R33/ R34) ähnlich wie per KS2000.
Einstellungen der KL3314 über die Visualisierung von TwinCAT 3
Es sollte mindestens die folgende Konfiguration vorhanden sein:
[Koppler (z.B. BK1120) oder embedded PC] + KL3314 + KL9010.
Download:
Vorbereitungen zum Starten des Beispielprogramms (tnzip - Datei/ TwinCAT 3)
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.tnzip -Archivdatei in einem temporären Ordner.
Öffnen des *. tnzip - Archives
▪
Wählen Sie die zuvor entpackte .tnzip Datei (Beispielprogramm) aus.
▪
Ein weiteres Auswahlfenster öffnet sich: wählen nun Sie das Zielverzeichnis, wo das Projekt gespeichert werden soll.
▪
Die generelle Vorgehensweise für die Inbetriebnahme der PLC bzw. dem Start des Programms kann u.a. den Klemmen‑Dokumentationen oder der EtherCAT‑Systemdokumentation entnommen werden.
▪
Das EtherCAT Gerät im Beispiel ist i.d.R. zuvor ihrem vorliegenden System bekannt zu machen. Verwenden Sie nach Auswahl des EtherCAT Gerätes im „Projektmappen-Explorer“ rechtsseitig den Karteireiter „Adapter“ und Klicken „Suchen...“:
Suche der bestehenden HW-Konfiguration zur bestehenden EtherCAT-Konfiguration
▪
Überprüfen der NetId: der Karteireiter „EtherCAT“ des EtherCAT Gerätes zeigt die konfigurierte NetId: .
Diese muss mit den ersten vier Zahlenwerten mit der Projekt‑NetId des Zielsystems übereinstimmen. Die NetId des Projektes kann oben in einem Textfeld der TwinCAT-Umgebung eingesehen werden. Ein pull-down Menü kann durch einen Klick rechts im Textfeld geöffnet werden; dort ist zu jeden Rechnernamen eines Zielsystems die NetId in Klammern angegeben.
▪
Ändern der NetId: mit einem Rechtsklick auf „Gerät EtherCAT“ im Projektmappen-Explorer öffnet sich das Kontextmenü, in dem „Ändern der NetId“ auszuwählen ist. Die ersten vier Zahlen der NetId des Projektes sind einzutragen. die beiden letzten Werte sind i.d.R. 4.1.
Beispiel:
–
NetId des Projektes: myComputer (123.45.67.89.1.1)
–
Eintrag per „Change NetId...“: 123.45.67.89.4.1


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Mapping
•
Control- und Status-Byte
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Die Klemmen KL3132, KL3162, KL3142, KL3152 KL3172 und KL3148 stellten sich im Prozessabbild mit maximal 6 Byte Ein- und 6 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Format | Eingangsdaten | Ausgangsdaten
Byte | SB1 | CB1
Wort | DataIN1 | DataOUT1
Byte | SB2 | CB2
Wort | DataIN2 | DataOUT2
Legende
SB n: Status-Byte für Kanal n
CB n: Control-Byte für Kanal n
DataIN n: Eingangsdatenwort Kanal n
DataOUT n: Ausgangsdatenwort Kanal n
▪
Die Zuordnung der Bytes und Worte zu den Adressen der Steuerung entnehmen Sie bitte der Seite Mapping.
▪
Die Bedeutung der Control- und Status-Bytes entnehmen Sie bitte der Seite Control- und Status-Bytes.
▪
Im Prozessdatenbetrieb werden in den Eingangsdatenworten DataIN1 und DataIN2 die Analogwerte übertragen und die Ausgangsdatenworte DataOUT1 und DataOUT2 nicht benutzt.
Darstellung der Analogwerte
Die analogen Eingangswerte werden von den Klemmen wie folgt dargestellt:
KL3132-0000
Spannung | Dezimal | Hexadezimal
-10 V | -32768 | 0x8000
+10 V | +32767 | 0x7FFF
KL3142-0000
Strom | Dezimal | Hexadezimal
0 mA | 0 | 0x0000
20 mA | 65535 | 0xFFFF
KL3152-0000
Strom | Dezimal | Hexadezimal
4 mA | 0 | 0x0000
20 mA | 65535 | 0xFFFF
KL3162-0000
Spannung | Dezimal | Hexadezimal
0 V | 0 | 0x0000
10 V | 65535 | 0xFFFF
KL3172-0000
Spannung | Dezimal | Hexadezimal
0 V | 0 | 0x0000
2 V | 65535 | 0xFFFF
KL3172-0500
Spannung | Dezimal | Hexadezimal
0 V | 0 | 0x0000
500 mV | 65535 | 0xFFFF
KL3172-1000
Spannung | Dezimal | Hexadezimal
0 V | 0 | 0x0000
1 V | 65535 | 0xFFFF
KL3182-0000
Spannung | Dezimal | Hexadezimal
-2 V | -32768 | 0x8000
+2 V | +32767 | 0x7FFF


Mapping

Zugriff aus dem Anwenderprogramm [image] Mapping
Mapping
Die Busklemmen belegen Adressen im Prozessabbild der Steuerung. Die Zuordnung der Prozessdaten (Ein- und Ausgangsdaten) und Parametrierungsdaten (Control- und Status-Bytes) zu den Steuerungsadressen wird als Mapping bezeichnet. Die Art des Mappings ist abhängig von:
▪
dem verwendeten Feldbus-System
▪
dem Klemmentyp
▪
der Parametrierung des Buskopplers (Bedingungen) wie
–
kompakte oder komplette Auswertung
–
Intel- oder Motorola-Format
–
Word-Alignment ein- oder ausgeschaltet
Die Buskoppler (BKxxxx, LCxxxx) und Busklemmen Controller (BCxxxx, BXxxxx) werden mit bestimmten Voreinstellungen (Default-Einstellungen) ausgeliefert. Mit der Konfigurationssoftware KS2000 oder mit einer Master-Konfigurationssoftware (z. B. TwinCAT System Manager oder ComProfibus) können Sie diese Default-Einstellungen verändern.
Die folgenden Tabellen zeigen das Mapping in Abhängigkeit der verschiedenen Bedingungen. Die Inhalte der einzelnen Bytes entnehmen Sie bitte den Seiten Prozessabbild sowie Control- und Status-Bytes.
Kompakte Auswertung
Bei kompakter Auswertung belegen die analogen Eingangsklemmen nur Adressen im Eingangsprozessabbild. Der Zugriff auf Control- und Status-Bytes ist nicht möglich.
Kompakte Auswertung im Intel-Format
Default-Mapping für CANopen-, CANCAL-, DeviceNet-, ControlNet-, Modbus-, RS232- und RS485-Koppler
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | Ch1 D1 | Ch1 D0 | - | -
 | 1 | Ch2 D1 | Ch2 D0 | - | -
Kompakte Auswertung im Motorola-Format
Default-Mapping für PROFIBUS- und Interbus-Koppler
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | Ch1 D0 | Ch1 D1 | - | -
 | 1 | Ch2 D0 | Ch2 D1 | - | -
Komplette Auswertung
Bei kompletter Auswertung belegen die analogen Eingangsklemmen Adressen im Ein- und im Ausgangsprozessabbild. Der Zugriff auf Control- und Status-Bytes ist möglich.
Komplette Auswertung im Intel-Format
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
Komplette Auswertung im Motorola-Format
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
Komplette Auswertung im Intel-Format bei Word-Alignment
Default-Mapping für Lightbus-, EtherCAT- und Ethernet-Koppler sowie Busklemmen Controller (BCxxxx, BXxxxx)
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
Komplette Auswertung im Motorola-Format bei Word-Alignment
 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
Legende
Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.
SB n: Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)
Ch n D0: Kanal n, niederwertiges Daten-Byte
Ch n D1: Kanal n, höherwertiges Daten-Byte
reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Klemme/Modul nicht belegt oder benutzt.


Control- und Status-Byte

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Byte
Control- und Status-Byte
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 (bei Prozessdatenbetrieb)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | CaliDisReq | StartManCali
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 bis CB1.2 | - | 0bin | reserviert
CB1.1 | CaliDisReq | 1bin | Sperrung der automatischen Kalibrierung
CB1.0 | StartManCali | 1bin | manuelle Kalibrierung starten
Status-Byte 1 (bei Prozessdatenbetrieb)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | StateThreshold2 |  | StateThreshold1 |  | Overload | Underload
Legende
Bit
Name
Beschreibung
SB1.7
RegAccess
0bin
Quittung für Prozessdatenbetrieb
SB1.6
Error
0bin
kein Fehler erkannt
1bin
KL3142 bis Firmware 2B
▪
Overload (Bit SB1.1 ist gesetzt) oder
▪
Underload (Bit SB1.0 ist gesetzt)
KL3142 ab Firmware 2C
und R32.14 = 1bin
KL3132, KL3152, KL3162, KL3172, KL3182 bis Firmware 2A
KL3132, KL3152, KL3162, KL3172, KL3182 ab Firmware 2B
und R32.14 = 1bin
KL3142 ab Firmware 2C
▪
Die letzte Kalibrierung ist mit einem Fehler beendet worden (kein Stabilität)
KL3132, KL3152, KL3162, KL3172, KL3182 ab Firmware 2B
SB1.5, SB1.4
StateThreshold2
00bin
Grenzwert 2 ist nicht über Bit R32.10 des Feature-Registers aktiviert
01bin
Prozessdatum ist kleiner als Grenzwert 2
10bin
Prozessdatum ist größer als Grenzwert 2
11bin
Prozessdatum ist gleich Grenzwert 2
SB1.3, SB1.2
StateThreshold1
00bin
Grenzwert 1 ist nicht über Bit R32.9 des Feature-Registers aktiviert
01bin
Prozessdatum ist kleiner als Grenzwert 1
10bin
Prozessdatum ist größer als Grenzwert 1
11bin
Prozessdatum ist gleich Grenzwert 1
SB1.1
Overload
1bin
Prozessdatum ist größer als in Register R21 vorgegeben. Die rote Error-LED dieses Kanals leuchtet.
Die Kalibrierung ist aktiv, wenn SB1.0 und SB1.1 gleichzeitig gesetzt sind.
SB1.0
Underload
1bin
Prozessdatum sind kleiner als in Register R22 vorgegeben. Die rote Error-LED dieses Kanals leuchtet
Registerkommunikation
Control-Byte 1 (bei Registerkommunikation)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIn lesen oder - mit dem Ausgangsdatenwort DataOut beschreiben wollen.
Status-Byte 1 (bei Registerkommunikation)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2
Control- und Status-Byte des Kanals 2 (CB2 und SB2) sind wie Control- und Status-Byte des Kanals 1 aufgebaut.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | ADC-Rohwert |  | 0x0000 | 0dez | R | RAM
R1 | Kalibrierwert: Offset |  | typisch 0x0046 | typisch 70dez | R | RAM
R2 | Kalibrierwert: Gain |  | typisch 0xF1CC | typisch 61900dez | R | RAM
R3 | reserviert |  | - | - | - | -
R4 | reserviert |  | - | - | - | -
R5 | reserviert |  | - | - | - | -
R6 | Diagnose-Register |  | 0x0000 | 0dez | R | RAM
R7 | Kommando-Register |  | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | KL3132: | 0xC3C | 3132dez | R | ROM
 |  | KL3142: | 0xC46 | 3142dez
 |  | KL3152: | 0xC50 | 3152dez
 |  | KL3162: | 0xC5A | 3162dez
 |  | KL3172: | 0x0C64 | 3172dez
 |  | KL3182: | 0x0C6E | 3182dez
R9 | Firmware-Stand |  | z. B. 0x3141 | z. B. 12609dez | R | ROM
R10 | Multiplex-Schieberegister |  | 0x0218 / 0x0130 | 536dez / 304dez | R | ROM
R11 | Signalkanäle |  | 0x0218 | 536dez | R | ROM
R12 | minimale Datenlänge eines Kanals |  | 0x0098 | 152dez | R | ROM
R13 | Datenstruktur |  | 0x0007 | 7dez | R | ROM
R14 | reserviert |  | - | - | - | -
R15 | Alignment-Register |  | typisch 0x7F80 | typisch 32640dez | R/W | RAM
R16 | Hardware-Versionsnummer |  | z. B. 0x0000 | z. B. 0dez | R/W | SEEPROM
R17 | Hersteller-Abgleich: Offset |  | typisch 0x0046 | 70dez | R/W | SEEPROM
R18 | Hersteller-Abgleich: Gain |  | typisch 0x5208 | typisch 21000dez | R/W | SEEPROM
R19 | Hersteller-Skalierung: Offset |  | 0x0000 | 0dez | R/W | SEEPROM
R20 | Hersteller-Skalierung: Gain | KL3162, KL3172, KL3142, KL3152: | 0x0100 | 256dez | R/W | SEEPROM
 |  | KL3132, KL3182: | 0x0080 | 128dez
R21 | Obere Begrenzung des Messbereichs | KL3162, KL3172, KL3142, KL3152: | 0xFFFF | 65535dez | R/W | SEEPROM
 |  | KL3132, KL3182: | 0x7FFF | +32767dez
R22 | Untere Begrenzung des Messbereichs | KL3162, KL3172, KL3142, KL3152: | 0x0000 | 0dez | R/W | SEEPROM
 |  | KL3132, KL3182: | 0x8000 | -32768dez
R23 | Referenz-Kalibrierwert: Offset |  | typisch 0x0046 | typisch 70dez | R/W | SEEPROM
R24 | Referenz-Kalibrierwert: Gain |  | typisch 0xF1CC | typisch 61900dez | R/W | SEEPROM
R25 | reserviert |  | - | - | - | -
... | reserviert |  | - | - | - | -
R28 | reserviert |  | - | - | - | -
R29 | Klemmentyp, Sonnderkennung | KL3132-0000 | 0x0000 | 0dez | R | ROM
 |  | KL3142-0000 | 0x0000 | 0dez
 |  | KL3152-0000 | 0x0000 | 0dez
 |  | KL3162-0000 | 0x0000 | 0dez
 |  | KL3172-0000 | 0x0000 | 0dez
 |  | KL3172-0500 | 0x01F4 | 500dez
 |  | KL3172-1000 | 0x03E8 | 1000dez
 |  | KL3182-0000 | 0x0000 | 0dez
R30 | reserviert |  | - | - | - | -
R31 | Kodewort-Register |  | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register | KL3162, KL3172, KL3142, KL3152: | 0x0180 | 384dez | R/W | SEEPROM
 |  | KL3132, KL3182: | 0x0182 | 386dez
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R33 | Anwender-Offset | 0x0000 | 0dez | R/W | SEEPROM
R34 | Anwender-Gain | 0x0100 | 256dez | R/W | SEEPROM
R35 | Grenzwert 1 | 0x0000 | 0dez | R/W | SEEPROM
R36 | Grenzwert 2 | 0x0000 | 0dez | R/W | SEEPROM
R37 | Filterkonstante des A/D-Wandlers und Konfigurationsbits für die Filter | 0x35C0 | 13760dez | R/W | SEEPROM
R38 | reserviert | - | - | - | -
R39 | reserviert | - | - | - | -
R40 | Kalibrierintervall *) | 0x0708 | 1800dez | R/W | SEEPROM
R41 | reserviert | - | - | - | -
... | reserviert | - | - | - | -
R43 | reserviert | - | - | - | -
R44 | Intervall für Zwangskalibrierung **) | 0x0003 | 3dez | R/W | SEEPROM
R45 | reserviert | - | - | - | -
R46 | reserviert | - | - | - | -
R47 | Anzahl stabiler Messwerte | 0x0032 | 50dez | R/W | SEEPROM
R48 | Toleranz für Messwertstabilität | 0x0005 | 5dez | R/W | SEEPROM
R49 | reserviert | - | - | - | -
... | reserviert | - | - | - | -
R63 | reserviert | - | - | - | -
*) in Vielfachen von 100 ms
**) in Vielfachen von Register R40


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die Register dienen zur Parametrierung der Busklemmen und sind für jeden Kanal einmal vorhanden. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
R0: ADC-Rohwert
Im Register R0 steht der Rohwert des Analog/Digital-Wandlers. Dies ist der unveränderte Analogwert vor allen Skalierungen.
R1: Kalibrierwert - Offset
In Register R1 wird nach einer Kalibrierung der ermittelte Offsetwert eingetragen, der bei der Korrekturrechnung verwendet wird.
R2: Kalibrierwert - Gain
In Register R2 wird nach einer Kalibrierung der ermittelte Gain-Wert eingetragen, der bei der Korrekturrechnung verwendet wird.
R6: Diagnose-Register
In Register R6 wird das Status-Byte SB eingeblendet.
R7: Kommando-Register
Anwender-Kodewort
Um die folgenden Kommandos auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein!
Kommando 0x7000: Restore Factory Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register beider Kanäle die Werte des Auslieferungszustands wiederhergestellt:
KL3162, KL3172, KL3142, KL3152:
R32: 0x0180 (384dez)
R33: 0x0000 (0dez)
R34: 0x0100 (256dez)
R35: 0x0000 (0dez)
R36: 0x0000 (0dez)
R37: 0x35C0 (13760dez)
R40: 0x0708 (1800dez)
R44: 0x0003 (3dez)
R47: 0x0032 (50dez)
R48: 0x0005 (5dez)
KL3132, KL3182:
R32: 0x0182 (386dez)
R33: 0x0000 (0dez)
R34: 0x0100 (256dez)
R35: 0x0000 (0dez)
R36: 0x0000 (0dez)
R37: 0x35C0 (13760dez)
R40: 0x0708 (1800dez)
R44: 0x0003 (3dez)
R47: 0x0032 (50dez)
R48: 0x0005 (5dez)
Restore Factory Settings
Das Kommando Restore Factory Settings setzt beide Kanäle der Klemme gleichzeitig zurück auf Auslieferungszustand, egal aus welchem Registersatz heraus es aufgerufen wird!
R8: Klemmenbezeichnung
Im Register R8 steht die Bezeichnung der Klemme.
KL3172: 0x0C64 (3172dez)
KL3182: 0x0C6E (3182dez)
KL3132: 0xC3C (3132dez)
KL3162: 0xC5A (3162dez)
KL3142: 0xC46 (3142dez)
KL3152: 0xC50 (3152dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R12: Minimale Datenlänge eines Kanals
Bit 0 bis 6 des höherwertigen Bytes geben die minimale Anzahl der Ausgangsdaten in Bit an: 000.0000bin = 0dez so 0 Byte.
Bit 0 bis 6 des niederwertigen Bytes geben die minimale Anzahl der Eingangsdaten in Bit an: 001.1000bin = 24dez so 3 Byte.
Das Bit 7 gesetzt ist zeigt, das Control- und Status-Byte für die Funktion der Klemme nicht zwingend erforderlich sind und im kompakten Modus nicht übertragen werden.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R17: Hersteller-Abgleich - Offset
Dieses Register beinhaltet den Offset des Hersteller-Abgleichs (16 Bit signed Integer).
R18: Hersteller-Abgleich - Gain
Dieses Register beinhaltet den Gain des Hersteller-Abgleichs (16 Bit unsigned Integer x 2-16 + 1). Beispiele:
0x0000 bedeutet Faktor 1
0xFFFF bedeutet Faktor 2
R19: Hersteller-Skalierung - Offset
Dieses Register beinhaltet den Offset der Hersteller-Skalierung. Kann durch R32.1 im Feature-Register aktiviert werden (16 Bit signed Integer).
R20: Hersteller-Skalierung - Gain
Dieses Register beinhaltet den Gain der Hersteller-Skalierung. Kann durch R32.1 im Feature-Register aktiviert werden (16 Bit unsigned Integer x 2-8 + 1). Beispiele:
0x0100 bedeutet Faktor 1.
0x0080 bedeutet Factor 0,5
R21: Obere Begrenzung Messbereich
Dieses Register beinhaltet die obere Begrenzung Messbereichs. Kann durch R32.8 im Feature-Register aktiviert werden.
R22: Untere Begrenzung Messbereich
Dieses Register beinhaltet die untere Begrenzung Messbereichs. Kann durch R32.8 im Feature-Register aktiviert werden.
R23: Referenz-Kalibrierwert: Offset
Dieses Register beinhaltet den Referenzwert der Kalibrierung, welcher beim Herstellerabgleich ermittelt wird.
R24: Referenz-Kalibrierwert: Gain
Dieses Register beinhaltet den Referenzwert der Kalibrierung, welcher beim Herstellerabgleich ermittelt wird.
R31: Kodewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die SEEPROM-Register gespeichert und bleiben somit bei einem Neustart der Klemme erhalten.
Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Konfiguration der Klemme fest.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | Callibration Display | Display StabilityError | - | - | disChannel | enTh2 | enTh1 | enOverProt
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | enStable | disDiff Measure | disCali | enSiemensFormat | enAverageFormat | disWd Timer | enManScal | enUsrScal
Legende
Bit | Name | Beschreibung |  | default
R32.15* | CallibrationDisplay | 0bin | Die Klemme setzt während der Kalibrierung das Overload-Bit SB1.1 und das Underload-Bit SB1.0. | 0bin
 |  | 1bin | Kompatibilitätsmodus: Die Klemme setzt während der Kalibrierung das Error-Bit SB1.6.
R32.14* | Display StabilityError | 0bin | Stability Error wird nicht angezeigt. | 0bin
 |  | 1bin | Falls keine Stabilisierung der Kalibrierungswerte eintritt, zeigt die Klemme dies durch setzen das Error-Bit SB1.6 an. (siehe folgenden Hinweis)
Schwankende Messsignale
Stark schwankende Messsignale können die Stabilisierung der Kalibrierungswerte unmöglich machen. Verzichten sie in diesem Fall auf die Stabilisierung und schalten Sie diese mit Bit R32.7 ab.
Bit | Name | Beschreibung |  |  | default
R32.13 | - | reserviert |  |  | 0bin
R32.12 | - | reserviert |  |  | 0bin
R32.11 | disChannel | 0bin | Kanal eingeschaltet |  | 0bin
 |  | 1bin | Kanal ausgeschaltet
R32.10 | enTh2 | 0bin | Grenzwert 2 nicht aktiv |  | 0bin
 |  | 1bin | Grenzwert 2 aktiv
R32.9 | enTh1 | 0bin | Grenzwert 1 nicht aktiv |  | 0bin
 |  | 1bin | Grenzwert 1 aktiv
R32.8 | enOverProt | 0bin | Begrenzung des Messbereichs nicht aktiv |  | 1bin
 |  | 1bin | Begrenzung des Messbereichs aktiv
R32.7 | enStable | 0bin | Stabilisierung der Kalibrierungswerte nicht aktiv |  | 1bin
 |  | 1bin | Stabilisierung der Kalibrierungswerte aktiv
R32.6 | disDiffMeasure | 0bin | Differentielle Messung aktiv |  | 0bin
 |  | 1bin | Differentielle Messung nicht aktiv (nur KL3132, KL3162, KL3172, KL3182)
R32.5 | disCali | 0bin | zyklische Kalibrierung der A/D-Wandler aktiv |  | 0bin
 |  | 1bin | zyklische Kalibrierung der A/D-Wandler nicht aktiv
R32.4 | enSiemensFormat | 0bin | Siemensausgabeformat nicht aktiv |  | 0bin
 |  | 1bin | Siemensausgabeformat aktiv
R32.3 | enAverageFormat | 0bin | Betragsvorzeichendarstellung nicht aktiv |  | 0bin
 |  | 1bin | Betragsvorzeichendarstellung aktiv
R32.2 | disWdTimer | 0bin | Watchdog-Timer aktiv (werden 100 ms keine Prozessdaten empfangen, löst der Watchdog aus) |  | 0bin
 |  | 1bin | Watchdog-Timer nicht aktiv
R32.1 | enManScal | 0bin | Hersteller-Skalierung nicht aktiv | KL3162, KL3172, KL3142, KL3152: | 0bin
 |  | 1bin | Hersteller-Skalierung aktiv | KL3132, KL3182: | 1bin
R32.0 | enUsrScal | 0bin | Anwender-Skalierung nicht aktiv |  | 0bin
 |  | 1bin | Anwender-Skalierung aktiv
*) Bit R32.14 und Bit R32.15 stehen erst ab den folgenden Firmware-Versionen zur Verfügung:
▪
KL3132, KL3152, KL3162, KL3172, KL3182: ab Firmware-Version 2B
▪
KL3142: ab Firmware-Version 2C
Bei kleineren Firmware-Versionen werden Bit R32.14 und Bit R32.15 nicht ausgewertet.
Diese Klemmen setzen während der Kalibrierung immer das Error-Bit SB1.6 und können den Stability Error nicht anzeigen!
R33: Anwender-Skalierung - Offset
Dieses Register beinhaltet den Offset der Anwender-Skalierung. Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden (16 Bit signed Integer).
R34: Anwender-Skalierung - Gain
Dieses Register beinhaltet den Gain der Anwender-Skalierung. Die Anwender-Skalierung kann im Feature-Register durch Bit R32.0 aktiviert werden (16 Bit unsigned Integer x 2-8 + 1, eine 1dez entspricht hierbei 0x0100).
R35: Grenzwert 1
In Register R35 wird der Grenzwert 1 eingetragen. Der Grenzwert kann im Feature-Register durch Bit R32.9 aktiviert werden.
R36: Grenzwert 2
In Register R36 wird der Grenzwert 2 eingetragen. Der Grenzwert kann im Feature-Register durch Bit R32.10 aktiviert werden.
R37: Filterkonstante des A/D-Wandlers und Konfigurationsbits für die Filter
(Default-Wert: 35C0hex)
Die Klemme besitzt zwei Tiefpass-Filterstufen:
▪
Die erste Stufe besteht aus einem sinc3 Filter, welcher immer aktiv ist.
▪
Die zweite Stufe besteht aus einem FIR-Filter 22. Ordnung, welches deaktiviert werden kann.
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Filterkonstante SF (SF.11 bis SF.0) |  |  |  |  |  |  |  |  |  |  |  | Null | Null | SkipFIR | Fast
Legende
Bit | Name | Beschreibung | Default
R37.15 | Filterkonstante SF (SF.11 - SF.0) | Die Filterkonstante SF legt die 3dB Grenzfrequenz des sinc3 Filters fest. Der Wertebereich erstreckt sich von 150 bis 2047. Die 3 dB Grenzfrequenz FGrenz bzw. die 64,5 dB Stopfrequenz FStop werden wie folgt berechnet: (Siehe folgende Tabelle) | 35Chex (860dez)
...
R37.4
Skip = 0 | FGrenz = 11981 / SF
 | FStop = 43008 / SF
Skip = 1 | FGrenz = 80486 / SF
Bit | Name | Beschreibung |  | Default
R37.3 | Null | 0bin | Siehe folgenden Hinweis | 0bin
R37.2 | Null | 0bin |  | 0bin
Nicht ändern
Die Bits R37.2 und R37.3 müssen immer Null sein, andernfalls treten im A/D-Wandler Fehler auf!
Bit | Name | Beschreibung |  | Default
R37.1 | SkipFIR | 0bin | FIR-Filter ist aktiviert. | 0bin
 |  | 1bin | FIR-Filter wird umgangen.
R37.0 | Fast | 0bin | Fast-Step-Modus ist deaktiviert. | 0bin
 |  | 1bin | Fast-Step-Modus ist aktiviert: trotz aktiver Filterstufe erfolgt eine schnelle Reaktion auf Sprünge am Eingang. Das Filter wird in diesem Fall umgangen!
Beispiele
Wert in R37 | FStop | Zykluszeit
0x35C0 | 50 Hz | 140 ms
0x2660 | 70 Hz | 100 ms
0x1330 | 140 Hz | 50 ms
0x7FF1 |  | 40 ms
0x3FF1 |  | 20 ms
0x1001 |  | <4 ms
Wert in R37 | FGrenz | Zykluszeit
0x7FF2 | 39,6 Hz | 40 ms
0x3FF2 | 77,36 Hz | 20 ms
0x1002 | 158 Hz | <4 ms
R40: Kalibrierintervall
Dieses Register beinhaltet das Kalibrierintervall für die automatische Kalibrierung der Klemme. Die Einheit ist 100 ms. Die automatische Kalibrierung kann im Feature-Register durch Bit R32.5 aktiviert werden.
R44: Intervall für Zwangskalibrierung
Dieses Register beinhaltet das Intervall für die Zwangskalibrierung der Klemme. Dieses Intervall ist immer ein Vielfaches (default: 3dez) des Kalibrierintervalls (R40). Somit ergibt sich im Auslieferungszustand ein Intervall für Zwangskalibrierung von 3 x 180 s = 540 s. Die Zwangskalibrierung kann im Feature-Register durch Bit R32.5 aktiviert werden.
R47: Anzahl stabiler Messwerte
Dieses Register beinhaltet die Anzahl der bei der Kalibrierung aufgenommenen stabilen Messwerte.
R48: Toleranz für Messwertstabilität
Dieses Register beinhaltet die vorgegebene Toleranz der stabilen Messwerte.


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.