KL2791 - Einkanalige Drehzahlstellerklemme
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0.0
▪
Migration
1.2.0
▪
Stell-Modus Phasenanschnitt hinzugefügt
▪
Montage und Verdrahtung aktualisiert
▪
Technische Daten aktualisiert
▪
Vorwort aktualisiert
1.1.0
Erhöhte Nennleistung von 200 VA für KL2791-0000 und KL2791-0011 freigegeben
1.0.0
erste Veröffentlichung
0.1
erste interne Vorabversion
Firm- und Hardware-Stände
Version der Dokumentation | KL2791-0000, KS2791-0000, KL2791-0011, KS2791-0011 |  | KL2791-1200
 | Firmware | Hardware | Firmware | Hardware
2.0.0 | 3A | 05 | 1B | 03
1.2.0 | 3A | 05 | 1B | 03
1.1.0 | 1B | 03 | 1B | 03
1.0.0 | 1A | 00 | 1A | 00
0.1 | 1A | 00 | - | -
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 24 08 1A 00:
24 - Produktionswoche 24
08 - Produktionsjahr 2008
1A - Firmware-Stand 1A
00 - Hardware-Stand 00


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Grundlagen zur Funktion
•
Technische Daten
•
LED-Anzeigen


Einführung

Produktübersicht [image] Einführung
Einführung
KL2791
In vielen Industrienationen machen Elektromotoren mehr als die Hälfte des Stromverbrauches aus, sodass hier ein enormes Energieeinsparpotenzial besteht.
Mithilfe einer Drehzahlregelung lässt sich der Energiebedarf leicht auf das notwendige Maß reduzieren und überflüssigen Energieverbrauch vermeiden.
Für diese Anwendung hat Beckhoff sein Busklemmen-System erweitert. Die Busklemme KL2791 ist als Drehzahlsteller für Einphasen-Wechselstrommotoren bis 100 VA geeignet.
Neben der Energieeinsparung bietet die Drehzahlreduzierung zudem eine Geräuschreduktion und erhöht die Lebensdauer des Motors.
Dieser Drehzahlsteller baut extrem kompakt und ist in einer Standard-Busklemme mit 12 mm Breite untergebracht.
Die Busklemme KL2791 ist in jedem, vom Beckhoff-Busklemmensystem unterstützten, Bussystem einsetzbar.
Sie ist für den direkten Anschluss von Einphasen-Wechselstrommotoren kleiner Leistung vorgesehen.
Typische Motoren, wie Kondensatormotor, Universalmotor und Spaltpolmotor, können durch die Ansteuerung mit der KL2791 in ihrer Drehzahl reduziert werden.
Mit der KL2791-0011 steht auch eine Variante ohne Power-Kontakte (siehe Kontaktplan rechts) zur Verfügung. Diese kann auch ohne spezielle Einspeiseklemme für 230 V verwendet werden.
Die KL2791-1200 ist speziell für 120 V Netzspannung ausgelegt.
Als KS2791 stehen auch Varianten mit steckbarer Verdrahtung zur Verfügung.


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Grundlagen zur Funktion KL2791
Der Motor wird nach einem praxisbewährten Muster netzsynchron ein- und ausgeschaltet, sodass er eine reduzierte Leistung aufnimmt und damit die Drehzahl deutlich absinkt.
Dieses Verfahren ist für Motoren mit fester Last, wie Pumpen und Lüfter, gut geeignet um einen Stellbereich für die Fördermenge von 10% bis 100% zu erreichen.
Die Busklemme KL2791 ermöglicht den direkten Anschluss von Einphasen-Wechselstrommotoren bis 100 VA.
Kondensator-, Universal- oder Spaltpolmotor können so einfach in ihrer Drehzahl reduziert werden.
Die Sollwertvorgabe erfolgt über die Prozessdaten. Mit einer 16 Bit-Darstellung wird die gewünschte Ausgangsleistung vorgegeben. Dazu stehen 3 verschiedene Stell-Modi zur Verfügung:
▪
Vollwellenansteuerung
▪
Phasenanschnitt erzeugt die beste Laufruhe
▪
Mischansteuerung
Bei der Vollwellensteuerung wird das gezielte Ein- und Ausschalten zu optimierten Zeitpunkten durchgeführt.
Dies schont den angeschlossenen Motor und ist besonders geeignet für Antriebe mit einer quadratischen Lastkennlinie, wie Lüfter und Pumpen.
Phasenanschnitt erzeugt die beste Laufruhe.
Mischansteuerung bietet einen Kompromiss aus Laufruhe und Motorschonung.
Achtung
Beachten Sie die Hinweise zum Betrieb
Lesen Sie auch die Hinweise zum Betrieb im Kapitel Montage und Verdrahtung.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | KL2791-0000, KS2791-0000, KL2791-0011, KS2791-0011 | KL2791-1200
Netzspannung | 230 VAC | 120 VAC
Nennleistung | 200 VA (W), max. 0,9 A | 100 VA (W), max. 0,85 A
Lastarten | Einphasen-Wechselstrommotoren
Ansteuerarten | Vollwellenansteuerung, Mischansteuerung
Auflösung | 1%
Leckstrom (OFF-Zustand) | < 1 mA
Potenzialtrennung | 500 V (K-Bus / Felsspannung), 3750 VAC (1 min.)
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 95 mA
Bitbreite im Eingangsprozessabbild | 1 x 16 Bit Daten, 1 x 8 Bit Status
Bitbreite im Ausgangsprozessabbild | 1 x 16 Bit Daten, 1 x 8 Bit Control
Konfiguration | über den Buskoppler oder die Steuerung
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Steckbare Verdrahtung | bei allen KSxxxx-Klemmen
Zulassung | CE


LED-Anzeigen

Produktübersicht [image] LED-Anzeigen
LED-Anzeigen
LEDs
LED
Anzeige
K-Bus Run (grün)
aus
keine Datenübertragung auf dem K-Bus
an
Datenübertragung auf dem K-Bus aktiv
Sync (grün)
aus
▪
Klemme ist nicht mit dem Netz synchronisiert*
an
▪
Klemme hat sich mit dem Netz synchronisiert*
ON (green)
aus
Prozessdaten sind Null
an
Prozessdaten sind ungleich Null
Error (rot)
an
ein lastseitiger Überstrom wurde erkannt
*) Die Synchronisierung auf das Netz kann nur bei angeschlossener Last erfolgen!
WARNUNG
Verletzungsgefahr durch Stromschlag!
Bei ausgeschalteter Sync-LED kann am Ausgang der KL2791 immer noch die Netzspannung anliegen!
Zu diesem Zeitpunkt wurde die die Synchronisierung noch nicht durchgeführt!


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Anschluss
•
Hinweise zum Betrieb


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Tragschienenverriegelungen ober- und unterhalb des Klemmenmoduls bis zu deren Einrastpunkt heraus. Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Anschlussbelegung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien bekannt ELxxxx und KLxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Hinweis
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Hinweis
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Anschlussbelegung

Montage und Verdrahtung [image] Anschluss [image] Anschlussbelegung
Anschlussbelegung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschlussbelegung
Klemmstelle | Nr. | KL2791-0000, KL2791-1200, Anschluss für | KL2791-0011, Anschluss für
Output | 1 | Last (intern verbunden mit Klemmstelle 5) | Last (intern verbunden mit Klemmstelle 5)
L1 | 2 | Phase (intern verbunden mit Klemmstelle 6 und Power-Kontakt für L1) | Phase (intern verbunden mit Klemmstelle 6)
N | 3 | Neutralleiter (intern verbunden mit Klemmstelle 7 und Power-Kontakt für N) | Neutralleiter (intern verbunden mit Klemmstelle 7)
PE | 4 | Schutzleiter (intern verbunden mit Klemmstelle 8 und Power-Kontakt für PE) | Schutzleiter (intern verbunden mit Klemmstelle 8)
Output | 5 | Last (intern verbunden mit Klemmstelle 1) | Last (intern verbunden mit Klemmstelle 1)
L1 | 6 | Phase (intern verbunden mit Klemmstelle 2 und Power-Kontakt für L1) | Phase (intern verbunden mit Klemmstelle 2)
N | 7 | Neutralleiter (intern verbunden mit Klemmstelle 3 und Power-Kontakt für N) | Neutralleiter (intern verbunden mit Klemmstelle 3)
PE | 8 | Schutzleiter (intern verbunden mit Klemmstelle 4 und Power-Kontakt für PE) | Schutzleiter (intern verbunden mit Klemmstelle 4)
Einspeiseklemme
Eine Einspeiseklemme kann mehrere Drehzahlstellerklemmen versorgen.
Achtung
Netzspannung nur über für 230 VAC / 120 VAC geeignete Einspeiseklemme einspeisen!
Verwenden Sie zum Einspeisen der Netzspannung (230 VAC / 120 VAC) in die Powerkontakte unbedingt eine für 230 VAC / 120 VAC ausgelegte Einspeiseklemme (z. B.: KL9150, KL9160, KL9250, KL9260)!
Buskoppler, Busklemmen-Controller und Einspeiseklemmen für 24 V sind nicht für die Einspeisung von Netzspannung in die Powerkontakte geeignet!
Sie sind nur für Spannungen bis 24 V ausgelegt und werden beim Anlegen von 230 VAC / 120 VAC an ihre Powerkontakte zerstört!
Hinweis
Trennklemme
Falls Sie in einem Busklemmenblock auf den Powerkontakten Spannungen von 24 V und 230 VAC / 120 VAC verwenden, können Sie die Trennklemme KL9080 verwenden um die Potentialblöcke auch optisch eindeutig voneinander zu trennen.
Kurzschlussstrombegrenzung
Die Drehzahlstellerklemmen sind mit einer Kurzschlussstrombegrenzung ausgestattet. Der Strom wird auf ca. 10 bis 15 A begrenzt. Ein auslösen der Sicherung wird damit typischerweise verhindert.
Der Kurzschlussstrom fließt für weniger als 0,5 ms und wird automatisch angeschaltet. Die KL2791 versucht nach einem erkannten Kurzschluss den Betrieb wieder aufzunehmen und testet die Leitung mit kleiner Spannung. Ist der Kurzschluss beseitigt, fährt die Drehzahlstellerklemme auf den vorherigen Stellwert zurück.
Ein Kurzschluss auf der Leitung sollte immer vermieden und keines falls willentlich herbeigeführt werden! Die Bauteile in der Drehzahlstellerklemme werden durch den Kurzschluss gestresst. Eine hohe Kurzschlussanzahl verringert die Lebensdauer der Drehzahlstellerklemme!
Sicherungen
Die Drehzahlstellerklemme darf mit Sicherungen bis 10 A abgesichert werden.
Die Drehzahlstellerklemme schützt sich selbst vor Zerstörungen durch Kurzschluss und Überlast. Dieser eingebaute Schutz greift beim Kurzschluss auf der Verbindungsleitung zwischen Drehzahlstellerklemme und Last.
Achtung
Überlastschutz verwenden!
Auf den Überlastschutz der Last darf trotzdem nicht verzichten werden. Die häufig in Geräten mit Transformator verwendete Feinsicherung darf nicht überbrückt oder in ihrem Wert verändert werden. Es droht sonst eine Überhitzung des Transformators.


Hinweise zum Betrieb

Montage und Verdrahtung [image] Hinweise zum Betrieb
Hinweise zum Betrieb
Bestimmungsgemäße Verwendung
Versorgungsnetz
Die Drehzahlstellerklemme KL2791 ist für den direkten Betrieb an Versorgungsnetzen (230 VAC/120 VAC) ohne vorgeschalteten Trafo vorgesehen.
Achtung
Keine vorgeschalteten Trafos!
Zu große Induktivitäten in der Zuleitung der Drehzahlstellerklemme führen im Kurzschlussfall zur Zerstörung der Drehzahlstellerklemme!
Auch die automatische Lasterkennung arbeitet bei vorgeschaltetem Trafo nicht zuverlässig.
Achtung
Kapazitive und induktive Lasten nicht mischen!
Kapazitive und induktive Lasten dürfen an einer Drehzahlstellerklemme nicht gemischt werden!
Stell-Modus
Achtung
Benutzen Sie den richtigen Stell-Modus!
Vollwellenansteuerung:
Die Vollwellenansteuerung ist grundsätzlich für einphasige rotatorische Wechselstrommotoren geeignet.
Phasenanschnitt:
Bei sehr dynamischem Motoren kann die Vollwellenansteuerung zu Laufunruhen führen. Für diese Motoren gibt es den Betriebmodus Phasenanschnitt. Dieser erzeugt die beste Laufruhe, kann aber unter Umständen die Lebensdauer des Motors negativ beeinflussen.
Mischansteuerung:
Die Mischansteuerung stellt einen Mittelweg zwischen Vollwellenansteuerung und Phasenanschnitt dar und bietet somit einen Kompromiss aus Laufruhe und Motorschonung.
Minimale Unterbrechung der Netzspannungszuführung
Achtung
Minimale Netzunterbrechung
Jede Unterbrechung der Netzspannungszuführung der Drehzahlstellerklemme darf nicht kürzer als 3 Sekunden sein (z. B. Aus- und Wiedereinschalten eines Sicherungsautomaten)!
Bei kürzeren Unterbrechungen verliert der Drehzahlsteller seine Netzsynchronisierung nicht und kann (bedingt durch die Einschaltflanke) für kurze Zeit die Last mit der falschen Ansteuer-Art betreiben.
Dieses kann bei Betrieb von gewickelten Trafos zu Zerstörung der Drehzahlstellerklemme führen!


Anwendungsbeispiele - Übersicht

Anwendungsbeispiele - Übersicht
Anwendungsbeispiele - Übersicht
▪
KL2791-0000: Drehzahlstellerklemme mit Power-Kontakten
▪
KL2791-0011: Drehzahlstellerklemme ohne Power-Kontakte
Weiterführende Informationen
•
KL2791-0000 - Anwendungsbeispiel
•
KL2791-0011 - Anwendungsbeispiel


KL2791-0000 - Anwendungsbeispiel

Anwendungsbeispiele - Übersicht [image] KL2791-0000 - Anwendungsbeispiel
KL2791-0000 - Anwendungsbeispiel
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Das Beispiel zeigt die Ansteuerung eines Wechselstrommotors durch eine KL2791-0000. Die Netzspannung (230 VAC) wird über die Einspeiseklemme KL9160 den Powerkontakten zugeführt.
KL2791-0000 - Anwendungsbeispiel
Einspeiseklemme
Eine Einspeiseklemme kann mehrere Drehzahlstellerklemmen versorgen.
Achtung
Netzspannung nur über für 230 VAC / 120 VAC geeignete Einspeiseklemme einspeisen!
Verwenden Sie zum Einspeisen der Netzspannung (230 VAC / 120 VAC) in die Powerkontakte unbedingt eine für 230 VAC / 120 VAC ausgelegte Einspeiseklemme (z.B.: KL9150, KL9160, KL9250, KL9260)!
Buskoppler, Busklemmen-Controller und Einspeiseklemmen für 24 V sind nicht für die Einspeisung von Netzspannung in die Powerkontakte geeignet!
Sie sind nur für Spannungen bis 24 V ausgelegt und werden beim Anlegen von 230 VAC / 120 VAC an ihre Powerkontakte zerstört!


KL2791-0011 - Anwendungsbeispiel

Anwendungsbeispiele - Übersicht [image] KL2791-0011 - Anwendungsbeispiel
KL2791-0011 - Anwendungsbeispiel
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Das Beispiel zeigt die Ansteuerung eines Motors durch eine KL2791-0011. Die Netzspannung (230 VAC) wird direkt auf die Drehzahlstellerklemme geführt.
KL2791-0011 - Anwendungsbeispiel
Achtung
Beschädigung des Gerätes möglich!
Die Einspeisung der Netzspannung ohne Einspeiseklemme ist nur für Drehzahlstellerklemmen ohne Power-Kontakte (KL2791-0011) zulässig!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Register
•
Einstellungen
•
Prozessdaten


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Buskoppler für Ethernet BK9000
▪
eine Einspeiseklemme für 230 V mit Diagnose KL9160
▪
eine Drehzahlstellerklemme KL2791
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (im Beispiel Position 2).
KS2000 Baumzweig für Kanal 1 der KL2791
Für die KL2791 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL2791.
▪
Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL2791.
▪
ProcData zeigt die Prozessdaten der KL2791.


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register der Drehzahlstellerklemme zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Das folgende Bild zeigt die Register der KL2791.
Registeransicht In KS2000


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Unter Einstellungen finden Sie die Dialogmaske zur Parametrierung der KL2791.
Einstellungen über KS2000
Betriebsmodus
Watchdog-Timer aktiv (R32.2)
Hier können Sie den Watchdog deaktivieren (Default: aktiv).
Anwenderskalierung aktiv (R32.0)
Hier können Sie die Anwenderskalierung aktivieren (Default: inaktiv).
Registerwerte
Anwender-Offset (R33)
Hier können Sie den Offset für die Anwender-Skalierung festlegen (Default: 0).
Anwender-Gain (R34)
Hier können Sie den Verstärkungsfaktor (Gain) für die Anwender-Skalierung festlegen (Default: 1).
Timeout (R36)
Hier können Sie die Timeout-Zeit für das Erkennen eines Feldbus-Fehlers festlegen (Default: 100 ms).
Stellwert bei Timeout (Ein) (R37)
Hier können Sie den Stellwert für einen Timeout festlegen, bei dessen Auftreten die Last eingeschaltet war (Default: 50%).
Stellwert bei Timeout (Aus) (R38)
Hier können Sie den Stellwert für einen Timeout festlegen, bei dessen Auftreten die Last ausgeschaltet war (Default: 0%).
Stell-Modus (R39)
Hier können Sie den Stell-Modus des Drehzahlstellers vorgeben:
▪
Vollwellenansteuerung (Default)
▪
Mischansteuerung (für sehr dynamische Motoren, bitte lesen Sie die Hinweise zum Betrieb!)
▪
Phasenanschnitt (ab Firmware-Version 2 A)
Verhalten nach Kurzschluss (R40)
Hier könne Sie das Verhalten der Drehzahlstellerklemme nach einem Kurzschluss am Lastausgang festlegen.
Die Drehzahlstellerklemme ist mit einer Kurzschlussstrombegrenzung ausgestattet. Der Strom wird auf ca. 10 bis 15 A begrenzt. Ein auslösen der Sicherung wird damit typischerweise verhindert. Der Kurzschlussstrom fließt für weniger als 0,5 ms und wird automatisch angeschaltet.
▪
Ausgeschaltet bleiben:
Das Wiedereinschalten nach einem Kurzschluss muss durch den Anwender erfolgen.
▪
Wieder Einschalten (Default):
Die Drehzahlstellerklemme versucht nach einem erkannten Kurzschluss den Betrieb wieder aufzunehmen und testet die Leitung mit kleiner Spannung. Ist der Kurzschluss beseitigt, fährt die Drehzahlstellerklemme auf den vorherigen Stellwert zurück.
Netzfrequenz (R41)
Hier könne Sie die Drehzahlstellerklemme auf Ihre Netzfrequenz einstellen, Default: 50 Hz


Prozessdaten

Konfigurations-Software KS2000 [image] Prozessdaten
Prozessdaten
Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.
ProcData
Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.
Feld Verlauf
Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.
Feld Wert
Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.
Feld Wert
VORSICHT
Gefahr für Personen, Umwelt oder Geräte!
Beachten Sie, das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann. Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, das Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.
Einstellungen


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Bytes
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Die KL2791 stellt sich im komplexen Prozessabbild mit 3 Byte Ein- und 3 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | SB | CB
1 | 2 | Wort | DataIN | DataOUT
Die KL2791 stellt sich im kompakten Prozessabbild ohne Eingangsdaten und mit 2 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Wort | - | DataOUT
*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen
Legende
SB: Status-Byte
CB: Control-Byte
DataIN: Eingangswort
DataOUT: Ausgangswort
Im Prozessdatenbetrieb steuert das Ausgangswort DataOUT die Ausgangsleistung der Drehzahlstellerklemme. Gültige Werte sind 0dez bis 32767dez.


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Bytes
Control- und Status-Bytes
Prozessdatenbetrieb
Control-Byte (bei Prozessdatenbetrieb)
Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB.6 bis CB.0 | - | 0bin | reserviert
Status-Byte (bei Prozessdatenbetrieb)
Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | Temperature warning | Overload | Operation mode |  |  | Synchron
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB.6 | Error | 1bin | Ein lastseitiger Kurzschluss wurde erkannt
SB.5 | Temperature warning | 1bin | Übertemperatur erkannt (> 80°C): die Prozessdaten werden auf 20% begrenzt (die Begrenzung wird automatisch zurückgesetzt, wenn die Temperatur unter 60°C fällt)
SB.4 | Overload | 1bin | Überlast erkannt (z. B. beim Einschalten hohen Lasten)
SB.3 bis SB.1 | Operation mode | 0dez | Vollwellenansteuerung
 |  | 1dez | Mischansteuerung
SB.0 | Synchron | 0bin | Klemme ist nicht mit dem Netz synchronisiert oder ein lastseitiger Kurzschluss wurde erkannt
 |  | 1bin | Klemme hat sich mit dem Netz synchronisiert
Registerkommunikation
Control-Byte (bei Registerkommunikation)
Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB.5 bis CB.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIN lesen oder - mit dem Ausgangsdatenwort DataOUT beschreiben wollen.
Status-Byte (bei Registerkommunikation)
Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB.6 | R | 0bin | Lesezugriff
SB.5 bis SB.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der Drehzahlstellerklemme. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | reserviert |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R6 | reserviert |  | - | - | - | -
R7 | Kommando-Register |  | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | KL2791-0000 | 0x0AE7 | 2791dez | R | ROM
 |  | KL2791-0011
 |  | KL2791-1200
R9 | Firmware-Stand |  | z. B. 0x3141 | z. B. 1AASCII | R | ROM
R10 | Multiplex-Schieberegister |  | 0x0118 | 280dez | R | ROM
R11 | Signalkanäle |  | 0x0118 | 280dez | R | ROM
R12 | minimale Datenlänge |  | 0x9800 | 38912dez | R | ROM
R13 | Datenstruktur |  | 0x0004 | 4dez | R | ROM
R14 | reserviert |  | - | - | - | -
R15 | Alignment-Register |  | 0x7F80 | 32640dez | R/W | RAM
R16 | Hardware-Versionsnummer |  | z. B. 0x0000 | z. B. 0dez | R/W | EEPROM
R17 | reserviert |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R28 | reserviert |  | - | - | - | -
R29 | Klemmentyp, Sondervariante | KL2791-0000 | 0x0000 | 0dez | R | ROM
 |  | KL2791-0011 | 0x000B | 11dez
 |  | KL2791-1200 | 0x04B0 | 1200dez
R30 | reserviert |  | - | - | - | -
R31 | Kodewort-Register |  | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register |  | 0x0000 | 0dez | R/W | EEPROM
R33 | Anwender-Skalierung - Offset |  | 0x0000 | 0dez | R/W | EEPROM
R34 | Anwender-Skalierung - Gain |  | 0x0100 | 256dez | R/W | EEPROM
R35 | reserviert |  | - | - | - | -
R36 | Watchdog-Timeout |  | 0x000A | 10dez | R/W | EEPROM
R37 | Stellwert bei Timeout (Ein) |  | 0x3FFF | 16383dez | R/W | EEPROM
R38 | Stellwert bei Timeout (Aus) |  | 0x0000 | 0dez | R/W | EEPROM
R39 | Stell-Modus |  | 0x0000 | 0dez | R/W | EEPROM
R40 | Verhalten nach Kurzschluss |  | 0x0001 | 1dez | R/W | EEPROM
R41 | Netzfrequenz | KL2791-0000 | 0x0000 | 0dez (50 Hz) | R/W | EEPROM
 |  | KL2791-0011
 |  | KL2791-1200 | 0x0001 | 1dez (60 Hz)
R42 | reserviert |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R63 | reserviert |  | - | - | - | -


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Alle Register können über die Registerkommunikation ausgelesen oder beschrieben werden. Sie dienen zur Parametrierung der Klemme.
R7: Kommando-Register
Hinweis
Anwender-Kodewort
Um die folgenden Kommandos auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein!
Kommando 0x7000: Restore Factory Default Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register die Werte des Auslieferungszustands wiederhergestellt:
R33: 0dez
R34: 256dez
R35: 3dez
R36: 10dez
R37: 16383dez
R38: 0dez
R39: 0dez
R40: 1dez
R41: 0dez
R8: Klemmentyp
Im Register R8 steht die Bezeichnung der Klemme: KL2791
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R29: Klemmentyp, Sondervariante
Im Register R29 steht die Sondervariante der Klemme.
R31: Kodewort-Register
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen. Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Konfiguration der Klemme fest.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | - | - | - | -
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | - | - | disWatchdog | - | enUserScale
Legende
Bit | Name | Beschreibung |  | Default
R32.15 - R32.3 | - | reserviert
R32.2 | disWatchdog | 1bin | interner Watchdog (Zeit einstellbar) deaktiviert | 0bin
R32.1 | - | reserviert
R32.0 | enUserScale | 1bin | Anwender-Skalierung aktiv (siehe R33 + R34) | 0bin
R33: Anwender-Skalierung - Offset
In diesem Register wird der Offset der Anwender-Skalierung eingetragen, wenn die Anwenderskalierung freigeschaltet (R32.0=1bin) ist (Default: 0).
R34: Anwender-Skalierung - Gain
In diesem Register wird der Verstärkungsfaktor (Gain) der Anwender-Skalierung eingetragen, wenn die Anwenderskalierung freigeschaltet (R32.0=1bin) ist.
Beispielwerte:
128dez = 0x80 = Faktor 0,5
256dez = 0x100 = Faktor 1,0 (Default)
512dez = 0x200 = Faktor 2,0
R36: Watchdog-Timeout
Dieses Register legt den Timeout, bei einem Feldbusfehler fest. Die Einheit ist 10 ms (Default: 10dez = 100 ms).
R37: Stellwert bei Timeout (Ein)
Dieses Register legt den Lichtwert fest, der bei einem Feldbusfehler und aktuellen Prozessdaten > 0 ausgegeben wird (Default: 16383dez).
Die Einheit ist 1. (R32.2=1bin).
R38: Stellwert bei Timeout (Aus)
Dieses Register legt den Lichtwert fest, der bei einem Feldbusfehler und aktuellen Prozessdaten = 0 ausgegeben wird (Default: 0dez).
Die Einheit ist 1. (R32.2=1bin).
R39: Stell-Modus
Dieses Register legt den Stell-Modus fest (siehe Hinweise zum Betrieb):
0dez: Vollwellenansteuerung (Default)
1dez: Mischansteuerung
2dez: Phasenanschnitt (ab Firmware-Version 2A)
R40: Verhalten nach Kurzschluss
Dieses Register legt das Verhalten nach Kurzschluss:
0dez: ausgeschaltet bleiben
1dez: wieder einschalten (Default)
R41: Netzfrequenz
Dieses Register legt die Netzfrequenz fest:
0dez: 50 Hz (Default)
1dez: 60 Hz


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Hinweis
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.