KL2542 - DC-Motorendstufen-Klemme
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0.0
▪
Migration
1.0.0
▪
Registerbeschreibung erweitert
0.5
▪
KL2532 ausgegliedert
0.4
▪
Beschreibung von Control- und Status-Byte aktualisiert
▪
Registerbeschreibung korrigiert
0.3
▪
Anschlussbeschreibung hinzugefügt
▪
Beschreibung der LEDs aktualisiert
▪
Technische Daten aktualisiert
0.2
▪
Informationen zur KL2532 hinzugefügt
▪
Beschreibung der Parametrierung mit der Konfigurationssoftware KS2000 hinzugefügt
0.1
erste vorläufige Vorab-Dokumentation für KL2542
Firm- und Hardware-Stände
Dokumentation Version | Firmware | Hardware
2.0.0 | 3A | 10
1.0.0 | 1C | 05
0.5 | 1C | 05
0.4 | 1B | 03
0.3 | 1B | 03
0.2 | 1A | 01
0.1 | 1A | 01
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 49 05 1B 03:
49 - Produktionswoche 49
05 - Produktionsjahr 2005
1B - Firmware-Stand 1B
03 - Hardware-Stand 03


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
LEDs


Einführung

Produktübersicht [image] Einführung
Einführung
KL2542
Die zweikanalige DC-Motor-Endstufe KL2542 ermöglicht den direkten Betrieb von zwei DC-Motoren. Die Solldrehzahl oder die Position wird durch einen 16-Bit-Wert vom Automatisierungsgerät vorgegeben. Die Ausgangsstufe ist überlast- und kurzschlusssicher und vom K-Bus galvanisch getrennt. Beide Kanäle zeigen ihren Signalzustand durch Leuchtdioden an, die eine schnelle Vor-Ort-Diagnose ermöglichen. Durch den Anschluss eines Inkremental-Encoders ist die einfache Realisierung einer Servo-Achse möglich.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten |  | KL2542
Anzahl der DC-Motor-Endstufen |  | 2
Lastart |  | Bürsten-DC-Motoren, induktiv
Versorgung der Ausgangsstufe |  | über Klemmstellen
Nennlastspannung |  | 8 VDC bis 50 VDC
Ausgangsstrom je Kanal |  | Nennstrom 3,5 A, Spitzenstrom 5 A (Kurzschlussfest, thermische Überlastwarnung für beide Ausgangsstufen gemeinsam)
PWM-Taktfrequenz |  | 36 kHz, Kanäle zueinander 180° phasenverschoben
Tastverhältnis |  | 0 ... 100% (spannungsgeregelt)
Auflösung | Strom | 12 Bit
 | Spannung (Geschwindigkeit) | 16 Bit
Anzahl digitale Eingänge |  | 2 (für Endlagen)
Nennspannung der Eingänge |  | 24 VDC (-15% / +20%)
Signalspannung digitaler Eingang "0" |  | -3 V ... 2 V
Signalspannung digitaler Eingang "1" |  | 15 V ... 30 V
Eingangsfilter |  | 0,2 ms
Eingangsstrom |  | typisch 5 mA
Anzahl Encoder-Eingänge |  | 4 (für ein Encoder-System)
Geberspannung "0" |  | -3 V ... 1,5 V
Geberspannung "1" |  | 2,5 V ... 24 V
Geberfrequenz |  | max. 250 kHz
Potenzialtrennung |  | 500 V (K-Bus/Netzspannung)
Spannungsversorgung für Elektronik |  | über den K-Bus
Stromaufnahme aus dem K-Bus |  | typisch: 100 mA
Stromaufnahme aus den Powerkontakten |  | typisch: 20 mA
Bitbreite im Eingangsprozessabbild |  | 2 x 16 Bit Daten, 2 x 8 Bit Status
Bitbreite im Ausgangsprozessabbild |  | 2 x 16 Bit Daten, 2 x 8 Bit Control
Konfiguration |  | über den Buskoppler oder die Steuerung
Gewicht |  | ca. 100 g
zulässiger Umgebungstemperaturbereich im Betrieb |  | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung |  | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit |  | 95%, keine Betauung
Abmessungen (B x H x T) |  | ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Montage |  | auf 35 mm Tragschiene nach EN
Vibrations- / Schockfestigkeit |  | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung |  | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart |  | IP 20
Einbaulage |  | beliebig
Zulassung |  | CE


LEDs

Produktübersicht [image] LEDs
LEDs
KL2542 - LEDs
Linkes LED-Prisma
LED | Anzeige
Run (grün) | an | Datenübertragung auf dem K-Bus aktiv
Enc. A: A (grün) | an | Am Eingang A für Encoder A liegt ein Signal an.
Enc. B: A (grün) | an | Am Eingang A für Encoder B liegt ein Signal an.
Input 1 (grün) | an | Am Eingang 1 liegt ein Signal an.
- | reserviert
Enc. A: B (grün) | an | Am Eingang B für Encoder A liegt ein Signal an.
Enc. B: B (grün) | an | Am Eingang B für Encoder B liegt ein Signal an.
Input 2 (grün) | an | Am Eingang 2 liegt ein Signal an.
Rechtes LED-Prisma
LED | Anzeige
- | reserviert
Enable A (grün) | aus | Kanal 1 ist nicht freigeschaltet oder nicht betriebsbereit.
 | an | Kanal 1 ist freigeschaltet und betriebsbereit.
- | reserviert
Error A (rot) | an | anstehender Fehler bei Kanal 1
Motor Power (grün) | aus | Die Versorgungsspannung für den Motor ist nicht vorhanden (kleiner als 7 V).
 | an | Die Versorgungsspannung für den Motor ist vorhanden (größer als 8 V).
Enable B (grün) | aus | Kanal 2 ist nicht freigeschaltet oder nicht betriebsbereit.
 | an | Kanal 2 ist freigeschaltet und betriebsbereit.
Warning (gelb) | an | Die interne Temperatur ist größer als 80 °C oder die Versorgungsspannung ist gesunken.
Error B (rot) | an | anstehender Fehler bei Kanal 2


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Anschluss


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Tragschienenverriegelungen ober- und unterhalb des Klemmenmoduls bis zu deren Einrastpunkt heraus. Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Anschlussbelegung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien bekannt ELxxxx und KLxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Hinweis
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Hinweis
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Anschlussbelegung

Montage und Verdrahtung [image] Anschluss [image] Anschlussbelegung
Anschlussbelegung
WARNUNG
Verletzung durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschluss KL2542
Klemmstellen
Linker Gehäuseteil
Klemmstelle | Nr. | Anschluss für
Encoder A, A | 1 | Encoder A, Anschluss A
Encoder B, A | 2 | Encoder B, Anschluss A
Encoder Power +24 V | 3 | Encoder-Versorgung (von positivem Powerkontakt)
Input 1 | 4 | Digitaler Eingang 1 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Byte das Bit CB.1 gesetzt ist und eine steigende Flanke am digitalen Eingang 1 auftritt.
Encoder A, B | 5 | Encoder A, Anschluss B
Encoder B, B | 6 | Encoder B, Anschluss B
Encoder Power 0 V | 7 | Encoder-Versorgung (von negativem Powerkontakt)
Input 2 | 8 | Digitaler Eingang 2 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Byte das Bit CB.2 gesetzt ist und eine steigende Flanke am digitalen Eingang 2 auftritt.
Rechter Gehäuseteil
Klemmstelle | Nr. | Anschluss für
Motor A, A1 | 1' | Motor A, Anschluss A1
Motor B, B1 | 2' | Motor B, Anschluss B1
n. c. | 3' | reserviert
Motor Power 50 V | 4' | Einspeisung für Motorversorgung (maximal +50 VDC)
Motor A, A2 | 5' | Motor A, Anschluss A2
Motor B, B2 | 6' | Motor B, Anschluss B2
n. c. | 7' | reserviert
Motor Power 0 V | 8' | Einspeisung für Motorversorgung (0 VDC)
VORSICHT
Gefahr für Personen, Umwelt oder Geräte!
Falls die K-Bus-Spannung (5 V, gespeist aus der Buskopplerversorgungsspannung Us) ausfällt, werden die Ausgangstreiber nicht zurückgesetzt! Dies bedeutet, dass die Motoren nicht gestoppt werden falls sie in Bewegung sind!
Power-Kontakte
Die Spannung Up der Powerkontakte (+24 VDC) versorgt folgende Verbraucher:
▪
Inkremental-Encoder (Klemmstelle 3 und 7)
▪
digitale Eingänge (Klemmstelle 4 und 8)
▪
Ausgangstreiber der DC-Motor-Endstufe
VORSICHT
Beachten Sie die Reihenfolge der Versorgungsspannungen!
Die Spannung Up muss an den Power-Kontakten schon anliegen wenn die K-Bus-Spannung eingeschaltet wird, damit interne Schaltkreise (Endstufentreiber) initialisiert werden können. Ist das applikationsbedingt nicht möglich (Versorgung wird z. B. über Not-Aus-Kreis geschaltet), führt die Klemme nach dem Hochfahren des Systems einen Software-Reset durch. Wenn die Spannung Up an den Powerkontakten ausfällt, wir dies im Register 0 durch Bit R0.14 angezeigt. Das Wiederkehren der Spannung wird automatisch erkannt und eine Initialisierung durchgeführt.


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Einstellungen
•
Register
•
Prozessdaten


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Buskoppler für Ethernet BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine zweikanalige DC-Motor-Endstufe KL2542
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (im Beispiel Position 2).
KS2000 Baumzweig für Kanal 1 der KL2542
Für die KL2542 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL2542.
▪
Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL2542.
▪
ProcData zeigt die Prozessdaten der KL2542.


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Einstellungen zur Parametrierung der KL2542.
Einstellungen über KS2000
Betriebsart
Watchdog Timer aktiv (R32.2)
Hier können Sie den Watchdog deaktivieren (Default: aktiv). Wenn die DC-Motor-Endstufe bei aktivem Watchdog für 100 ms keine Prozessdaten von der Steuerung empfängt, löst der Watchdog aus und der Motor wird gestoppt.
Betragsvorzeichendarstellung (R32.3)
Hier können Sie die Betragsvorzeichendarstellung aktivieren (Default: inaktiv).
Anwendereinschaltwert aktiv (R32.8)
Hier können Sie den Anwendereinschaltwert aktivieren (Default: inaktiv).
Geschwindigkeitsregelung aktiv (R32.15)
Hier können Sie die Geschwindigkeitsregelung deaktivieren (Default: aktiv).
I-Regler aktiv (R32.14)
Hier können Sie den I-Regler deaktivieren (Default: aktiv).
Inneres Fenster für I-Regler aktiv (R32.13)
Hier können Sie das innere Fenster des I-Reglers deaktivieren (Default: aktiv).
Drehmomentüberwachung aktiv (R32.9)
Hier können Sie die Drehmomentüberwachung aktivieren (Default: inaktiv).
Überspannungsschutz aktiv (R32.10)
Hier können Sie für Kanal 2 den Überspannungsschutz (Chopper-Widerstand) aktivieren (Default: inaktiv).
Anwenderskalierung aktiv (R32.0)
Hier können Sie die Anwenderskalierung aktivieren (Default: inaktiv).
Herstellerskalierung aktiv (R32.1)
Hier können Sie die Herstellerskalierung aktivieren (Default: inaktiv).
Registerwerte
Anwendereinschaltwert (R35)
Hier können Sie den Anwendereinschaltwert für die Geschwindigkeit festlegen (Default: 0).
Schaltschwelle für MixedDecay (R41)
Hier können Sie die automatische Ausschaltschwelle für MixedDecay festlegen (Default: 20%).
Nennstrom des Motors (R37)
Hier können Sie den Nennstrom des Motors angeben.
Default 3500 mA
Maximaler Motorstrom (R36)
Hier können Sie den maximalen Spulenstrom des Motors angeben.
Default 5000 mA
Innenwiderstand des Motors (R40)
Hier können Sie den Innenwiderstand des Motors angeben (Default: 1 Ohm).
Kp-Faktor (R42)
Hier können Sie den Kp-Faktor der internen Geschwindigkeitsregelung festlegen (Default: 1).
Inneres Fenster für I-Regler (R43)
Hier können Sie den Kp-Faktor der internen Geschwindigkeitsregelung festlegen (Default: 1%).
Der I-Anteil der Geschwindigkeitsregelung wird zum Nullpunkt hin abgeschwächt. Dieses Register gibt den Wert an, ab dem die Abschwächung aktiviert wird.
Maximaler Wert für I-Regler (R44)
Hier können Sie den größten Wert festlegen, den der I-Anteil annehmen kann (Default: 5%).
Zeitkonstante Tn für I-Regler (R45)
Hier können Sie die Zeitkonstante Tn festlegen (Default: 100).
Die Zeitkonstante steuert das Zeitverhalten des I-Reglers.
Maximales Drehmoment (R38)
Hier können Sie das maximales Drehmoment für die Applikation festlegen (Default: 10000), siehe Beschreibung von Register R2.
Steigt der aktuelle Wert (Register R2) über diese Schwelle, wird bei deaktivierter Drehmomentüberwachung nur eine Warnung ausgegeben (SB1.5=1 und R0.13=1). Ist die Drehmomentüberwachung aktiv (R32.9=1), wird der Motor stromlos geschaltet und ein Fehler ausgegeben (SB1.6=1 und R0.13=1).
Anwender-Offset (R33)
Hier können Sie den Offset für die Anwender-Skalierung festlegen (Default: 0).
Anwender-Gain (R34)
Hier können Sie den Verstärkungsfaktor (Gain) für die Anwender-Skalierung festlegen (Default: 1).


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register der KL2542 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Registeransicht in KS2000


Prozessdaten

Konfigurations-Software KS2000 [image] Prozessdaten
Prozessdaten
Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.
ProcData
Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.
Feld Verlauf
Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.
Feld Wert
Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.
Feld Wert
VORSICHT
Gefahr für Personen, Umwelt oder Geräte!
Beachten Sie, das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann. Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, das Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.
Einstellungen


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Byte
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Komplexes Mapping
Die KL2542 stellen sich im komplexen Prozessabbild mit mindestens 6 Byte Ein- und 6 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | SB1 | CB1
1 | 2 | Wort | DataIN1 | DataOUT1
3 | 4 | Byte | SB2 | CB2
4 | 6 | Wort | DataIN2 | DataOUT2
Kompaktes Mapping
Die KL2542 stellen sich im kompakten Prozessabbild mit mindestens 6 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | - | CB1
1 | 2 | Wort | - | DataOUT1
3 | 4 | Byte | - | CB2
4 | 6 | Wort | - | DataOUT2
*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen
Legende
SB n: Status-Byte des Kanals n
CB n: Control-Byte des Kanals n
DataIN n: Eingangswort des Kanals n
DataOUT n: Ausgangswort des Kanals n
Hinweis
Control-Bytes
Ein Betrieb der KL2542 ohne Control-Bytes ist nicht möglich, da die Control-Bytes für die Freigabe der Kanäle erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen, werden KL2542 mit ihrem Control-Bytes dargestellt!


Control- und Status-Byte

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Byte
Control- und Status-Byte
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 (bei Prozessdatenbetrieb)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reset | Enable | GetLatchData | enLatch FallEdge | enLatch RiseEdge | SetPos | disMixed DecayMan
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 | Reset | 1bin | alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke)
CB1.5 | Enable | 1bin | Schaltet den Kanal 1 frei
CB1.4 | GetLatchData | 0bin | die aktuelle Position in die Eingangsprozessdaten einblenden
 |  | 1bin | den aktuellen Latch-Wert in die Eingangsprozessdaten einblenden
CB1.3 | enLatch FallEdge | 1bin | externes Latch-Ereignis ist freigeschaltet (bei fallender Flanke des Latch-Eingangs speichert die Klemme die aktuelle Position)
CB1.2 | enLatch RiseEdge | 1bin | externes Latch-Ereignis ist freigeschaltet (bei steigender Flanke des Latch-Eingangs speichert die Klemme die aktuelle Position) ACHTUNG: höhere Priorität als CB1.3!
CB1.1 | SetPos | 1bin | Positionswert wird mit Register R1 gesetzt (steigende Flanke)
CB1.0 | disMixed DecayMan | 0bin | Motoransteuerung über 2 gepulste Transistoren pro Halbwelle
 |  | 1bin | Motoransteuerung über 1 gepulsten und einen durchgeschalteten Transistor pro Halbwelle (Manuelle Deaktivierung. Die automatische Deaktivierung erfolgt bei einer Schwelle, die mit RegisterR41 festgelegt wird).
Status-Byte 1 (bei Prozessdatenbetrieb)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Warning | Ready | LatchData | LatchValid | SetPos Ready | Input E1
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 | Error | 1bin | ein Fehler ist aufgetreten (wird im Statuswort in Register R0 angezeigt)
SB1.5 | Warning | 1bin | Die interne Temperatur ist größer als 80°C, die Versorgungsspannung ist gesunken oder das aktuelle Drehmoment ist (bei abgeschalteter Drehmomentüberwachung) größer als in Register R38 vorgegeben.
SB1.4 | Ready | 0bin | Motoransteuerung ist gesperrt oder es liegt ein Fehler vor (SB.6=1)
 |  | 1bin | Motoransteuerung ist frei geschaltet und es ist kein Fehler aufgetreten (Quittung für Enable, SB.6=0)
SB1.3 | LatchData | 0bin | die aktuelle Position ist in den Eingangsprozessdaten eingeblendet
 |  | 1bin | der letzte Latch-Wert ist in den Eingangsprozessdaten eingeblendet, wenn ein gültiger Latch-Wert vorhanden ist (Quittung für GetLatchData)
SB1.2 | LatchValid | 1bin | ein Latch-Ereignis ist eingetreten (bei CB1.2=1 oder CB1.3=1)
SB1.1 | SetPos Ready | 1bin | die aktuelle Position wurde gesetzt (Quittung für SetPos)
SB1.0 | Input E1 | Status des Eingangs E1
Registerkommunikation
Control-Byte 1 (bei Registerkommunikation)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIn lesen oder - mit dem Ausgangsdatenwort DataOut beschreiben wollen.
Status-Byte 1 (bei Registerkommunikation)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2
Control- und Status-Byte des Kanals 2 (CB2 und SB2) sind wie Control- und Status-Byte des Kanals 1 aufgebaut.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der DC-Motor-Endstufen. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R0 | Statuswort | 0x0000 | 0dez | R | RAM
R1 | Position setzen | 0x0000 | 0dez | R/W | RAM
R2 | Drehmoment | z. B. 0x015E | z. B. 350dez | R | RAM
R3 | Versorgungsspannung | z. B. 0x0030 | z. B. 48dez | R | RAM
R4 | reserviert | - | - | - | -
R5 | Temperatur | z. B. 0x0023 | z. B. 35dez | R | RAM
R6 | Status-Byte | z. B. 0x0010 | z. B. 16dez | R | RAM
R7 | Kommando-Register | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | 0x09EE | 2542dez | R | ROM
R9 | Firmware-Stand | z. B. 0x3141 | z. B. 1AASCII | R | ROM
R10 | Multiplex-Schieberegister | 0x0130 | 304dez | R | ROM
R11 | Signalkanäle | 0x0218 | 536dez | R | ROM
R12 | minimale Datenlänge | 0x1800 | 6144dez | R | ROM
R13 | Datenstruktur | 0x0004 | 4dez | R | ROM
R14 | reserviert | - | - | - | -
R15 | Alignment-Register | 0x7F80 | 32640dez | R/W | RAM
R16 | Hardware-Versionsnummer | z. B. 0x0000 | z. B. 0dez | R/W | EEPROM
R17 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R30 | reserviert | - | - | - | -
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R31 | Kodewort-Register | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register | 0x0000 | 0dez | R/W | EEPROM
R33 | Anwender-Skalierung - Offset | 0x0000 | 0dez | R/W | EEPROM
R34 | Anwender-Skalierung - Gain | 0x1000 | 4096dez | R/W | EEPROM
R35 | Anwender-Einschaltwert | 0x0000 | 0dez | R/W | EEPROM
R36 | maximaler Spulenstrom des Motors: | 0x1388 | 5000dez | R/W | EEPROM
R37 | Nennstrom des Motors | 0x0DAC | 3500dez | R/W | EEPROM
R38 | maximales Drehmoment | 0x2710 | 10000dez | R/W | EEPROM
R39 | Chopper-Spannung (nur Kanal 2) | 0x0000 | 0dez | R/W | EEPROM
R40 | Innenwiderstand des Motors | 0x0064 | 100dez | R/W | EEPROM
R41 | automatische Ausschaltschwelle für MixedDecay | 0x0014 | 20dez | R/W | EEPROM
R42 | Kp-Faktor | 0x1000 | 4096dez | R/W | EEPROM
R43 | inneres Fenster des I-Anteils | 0x0001 | 1dez | R/W | EEPROM
R44 | Maximalwert des I-Anteils | 0x0005 | 5dez | R/W | EEPROM
R45 | Zeitkonstante Tn des I-Anteils | 0x0064 | 100dez | R/W | EEPROM
R46 | Zeitkonstante zum Löschen bzw. begrenzen des maximalen Drehmoments | 0x01F4 | 500dez | R/W | EEPROM
R47 | Zeitkonstante zur Begrenzung des Motor Nennstroms | 0x2710 | 10000dez | R/W | EEPROM
R48 | reserviert |  |  |  |
... | ... | ... | ... | ... | ...
R61 | reserviert |  |  |  |
R62 | interner Parameter zur Stromregelung | 0x03E8 | 1000dez | R/W | EEPROM
R63 | interner Parameter zur Stromregelung | 0x0064 | 100dez | R/W | EEPROM


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Alle Register können über die Registerkommunikation ausgelesen oder beschrieben werden. Sie dienen zur Parametrierung der Klemme.
R0: Statuswort
Das Statuswort beinhaltet Informationen über interne Zustände und gibt Auskunft über aufgetretene Fehler
Bit | R0.15 | R0.14 | R0.13 | R0.12 | R0.11 | R0.10 | R0.9 | R0.8
Name | - | NoControl Power | Torque Overload | Over Current | Under Voltage | Over Voltage | Low Voltage | Over Temperature
Bit | R0.7 | R0.6 | R0.5 | R0.4 | R0.3 | R0.2 | R0.1 | R0.0
Name | - | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
R0.15 | - | reserviert
R0.14 | NoControl Power | 1bin | keine 24 V Steuerspannung an den Powerkontakten vorhanden
R0.13 | Torque Overload | 1bin | Drehmoment ist größer als in R38 vorgegeben
R0.12 | Over Current | 1bin | Überstrom der Treiberstufe
R0.11 | Under Voltage | 1bin | Versorgungsspannung kleiner als 7 V
R0.10 | Over Voltage | 1bin | Versorgungsspannung größer als 15% (bei R39=0) bzw. größer als in R39 vorgegeben (bei R39<>0) der Einschaltspannung
R0.9 | Low Voltage | 1bin | Versorgungsspannung ist um 10 V kleiner als die Einschaltspannung
R0.8 | Over Temperature | 1bin | Innentemperatur der Klemme ist größer als 80°C (siehe R5)
R0.0 - R0.7 | - | reserviert
R1: Position setzen
Hier können Sie die gewünschte Position vorgeben, mit der die Klemme geladen werden soll.
R2: Drehmoment
Dieses Register beinhaltet immer den letzten und größten Wert der vergangenen Millisekunden (Register R46) des aktuellen Drehmoments. Dieser Wert ist einheitenlos, auf 1000 normiert und immer positiv. Berechnet wird er folgendermaßen:
1.0 | M = | E x 1000 / VC |
wobei |
1.1 | E = VC - VG
1.2 | VC = VS x DataOUT / 32767
mit
M | Drehmoment (Betrag) | [M] = 1
E | Regelfehler | [E] = 1 V
VS | Versorgungsspannung | [VS] = 1 V
VG | Gegenspannung des Motors | [VG] = 1 V
VC | Sollgeschwindigkeit (Sollspannung, bezogen auf die Prozessdaten) | [VC] = 1 V
R3: Versorgungsspannung
Hier kann die Motor-Versorgungsspannung ausgelesen werden. Die Einheit ist 1 mV (Beispiel: 4800 = 48 V).
R5: Temperatur-Register
Aus Register R6 kann die Innentemperatur der Klemme in °C ausgelesen werden. Die Klemme setzt im Status-Byte das Bit SB.5 als Warnung, wenn die Temperatur die Schwelle von 80°C überschreitet. Sinkt die Temperatur unter 60°C wird das Bit SB.5 automatisch wieder zurückgesetzt.
R6: Status-Byte
Hier wird zusätzlich das Status-Byte des jeweiligen Kanals eingeblendet.
R7: Kommando-Register
Hinweis
Anwender-Kodewort
Um die folgenden Kommandos auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein!
Kommando 0x7000: Restore Factory Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register beider Kanäle die Werte des Auslieferungszustands wiederhergestellt:
R32: 0dez
R33: 0dez
R34: 4096dez
R35: 0dez
R36: 5000dez
R37: 3500dez
R38: 10000dez
R39: 0dez
R40: 100dez
R41: 20dez
R42: 4096dez
R43: 1dez
R44: 5dez
R45: 100dez
R46: 500dez
R47: 10000dez
Hinweis
Restore Factory Settings
Das Kommando Restore Factory Settings setzt beide Kanäle der DC-Motor-Endstufenklemme gleichzeitig zurück auf Auslieferungszustand, egal aus welchem Registersatz heraus es aufgerufen wird!
Kommando 0x8000: Software Reset
Mit dem Eintrag 0x8000 in Register R7 wird ein vollständiger Software-Reset der Klemme durchgeführt. Alle internen Variablen (Positionen, Latch-Werte, Fehler, usw.) werden gelöscht bzw. auf definierte Werte gesetzt, die aus dem EEPROM gelesen werden. Die internen Schaltkreise (D/A-C, Ausgangstreiber) werden bei einem Software-Reset neu initialisiert.
VORSICHT
Gefahr für Personen und Maschinen!
Während eines Software-Resets wird der Motor stromlos geschaltet. Stellen Sie sicher, dass ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
R8: Klemmentyp
Im Register R8 steht die Bezeichnung der Klemme:
0x09EE (2542dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z.B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R31: Kodewort-Register
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen. Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Konfiguration der Klemme fest.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | disVelocity Controller | disIPart | disIWindow | - | - | enChopper | enTorque Error | enUser StartValue
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | - | enAverage Notation | disWatchdog | enManu Scale | enUser Scale
Legende
Bit | Name | Beschreibung |  | default
R32.15 | disVelocity Controller | 1bin | Geschwindigkeitsregelung ist deaktiviert (proportionaler und integraler Anteil), siehe R42 | 0bin
R32.14 | disIPart | 1bin | I-Anteil der Geschwindigkeitsregelung ist deaktiviert (siehe R44 + R45) | 0bin
R32.13 | disIWindow | 1bin | inneres Fenster des I-Anteils ist deaktiviert (siehe R43) | 0bin
R32.11 - R32.12 | - | reserviert
R32.10 | enChopper | 1bin | Chopper-Widerstand aktiv (Überspannungsschutz, nur Kanal 2, siehe R39) | 0bin
R32.9 | enTorque Error | 1bin | Drehmomentabschaltung aktiv (siehe R38) | 0bin
R32.8 | enUser StartValue | 1bin | Anwendereinschaltwert aktiv (siehe R35) | 0bin
R32.4 - R32.7 | - | reserviert
R32.3 | enAverage Notation | 1bin | Betragsvorzeichendarstellung aktiv | 0bin
R32.2 | disWatchdog | 1bin | interner 100 ms Watchdog deaktiviert | 0bin
R32.1 | enManuScale | 1bin | Hersteller-Skalierung aktiv | 0bin
R32.0 | enUserScale | 1bin | Anwender-Skalierung aktiv (siehe R33 + R34) | 0bin
R33: Anwender-Skalierung - Offset
Hier können Sie den Offset für die Anwender-Skalierung eingetragen, wenn die Anwender-Skalierung aktiviert (R32.0=1) ist (Default: 0x0000). Beispiele:
hex | ... | 0xFFFD | 0xFFFE | 0xFFFF | 0x0000 | 0x0001 | 0x0002 | ...
Offset | ... | -3 | -2 | -1 | 0 | 1 | 2 | ...
R34: Anwender-Skalierung - Gain
Hier können Sie den Verstärkungsfaktor (Gain) für die Anwender-Skalierung eingetragen, wenn die Anwender-Skalierung aktiviert (R32.0=1) ist (Default 4096dez).
Beispiele:
hex | 0x0001 | 0x0800 | 0x0FFF | 0x1000 | 0x1001 | 0x1800 | 0x2000 | 0xFFFF
dez | 1dez | 2048dez | 4095dez | 4096 dez | 4097dez | 6144dez | 8192dez | 65535dez
Offset | 0,0002 | 0,5 | 0,0098 | 1 | 1,0002 | 1,5 | 2 | 15,9998
R35: Anwender-Einschaltwert
Schlägt der aktivierte Watchdog (R32.2 = 0bin) bei einem Feld- oder Klemmenbusfehler nach 100 ms zu, wird dieser Wert zum Ausgabewert.
R36: maximaler Spulenstrom des Motors
Dieses Register legt den maximalen Spulenstrom des Motors fest. Die Einheit ist 1 mA (Beispiel: 1500dez = 1,5 A).
maximal 5000 mA
R37: Nennstrom des Motors
Dieses Register legt den Nennstrom des Motors fest. Die Einheit ist 1 mA (Beispiel: 1000dez = 1,0 A).
maximal 3500 mA
R38: maximales Drehmoment
In diesem Register wird das für die Applikation maximal erlaubte Drehmoment konfiguriert (Default: 10000dez), siehe Beschreibung von Register R2
Steigt der aktuelle Wert (Register R2) über diese Schwelle, wird bei R32.9=0 nur eine Warnung ausgegeben (SB1.5=1 und R0.13=1). Ist die Drehmomentabschaltung aktiv (R32.9=1), wird der Motor stromlos geschaltet und ein Fehler ausgegeben (SB1.6=1 und R0.13=1).
R39: Chopper-Spannung (nur Kanal 2)
Steigt die Versorgungsspannung durch Rückspeisung über die eingestellte Chopper-Spannung, wird bei aktivierter Chopper-Funktion (R32.10=1) der zweite Kanal (Chopper-Widerstand muss angeschlossen sein) voll aufgesteuert und die Überspannung abgebaut.
R40: Innenwiderstand des Motors
Dieses Register beinhaltet den Innenwiderstandes des Motors (Default: 100dez).
Die Einheit ist 0,01 Ohm (Beispiel: 100dez = 1,00 Ohm).
R41: automatische Ausschaltschwelle für MixedDecay
MixedDecay: zur Vermeidung von Motor-Resonanzen bei niedriger Drehzahl erfolgt die ist die Motoransteuerung über 2 gepulste Transistoren pro Halbwelle.
Dieses Register beinhaltet die Schwelle, bei der die MixedDecay-Funktion des Motor-Controller-Chips automatisch deaktiviert wird (Default: 20dez).
Die Einheit ist 1% (Beispiel: 20 = 20%).
R42: Kp-Faktor
Dieses Register beinhaltet den Kp-Faktor der internen Geschwindigkeitsregelung (Default: 4096dez).
Die Einheit ist 1 / 4096 (Beispiel: 4096dez => Kp = 1,00).
R43: inneres Fenster des I-Anteils
Der I-Anteil der Geschwindigkeitsregelung wird zum Nullpunkt hin abgeschwächt (Default: 1dez). Dieses Register gibt den Wert an, ab der die Abschwächung aktiviert wird.
Die Einheit ist 1% (Beispiel: 1 = 1%).
R44: Maximalwert des I-Anteils
Dieses Register gibt den größten Wert an, den der I-Anteil annehmen kann (Default: 5dez).
Die Einheit ist 1% (Beispiel: 5dez = 5%).
R45: Zeitkonstante Tn des I-Anteils
Dieses Register steuert das Zeitverhalten des I-Reglers (Default: 100dez).
Die Einheit ist 1 (Beispiel: 100dez = 100).
R46: Zeitkonstante zum Löschen bzw. begrenzen des maximalen Drehmoments
Das maximale Drehmoment wird für die in diesem Register eingestellte Zeit in Register R2 gespeichert (Default: 500dez).
Die Einheit ist 1 ms (Beispiel: 500 = 0,5 s).
Danach wird das gespeicherte Drehmoment gelöscht und mit dem nächst größeren Wert beschrieben.
Ist die Drehmomentabschaltung aktiv, wird der Motor stromlos geschaltet, wenn das aktuelle Drehmoment für diese Zeit größer als der eingestellte Wert in Register R38 ist.
R47: Zeitkonstante zur Begrenzung des Motor-Nennstroms
Die Klemme bestromt einen angeschlossenen Motor bei steigender mechanischer Last maximal bis zu dem in Register R36 eingestellten Strom. Bleibt diese mechanische Last erhalten, wird der Motorstrom nach dieser eingestellten Zeit mit einer 1/T Funktion auf den Nennstrom reduziert (Default:10000dez).
Die Einheit ist 1 ms (Beispiel: 10000 = 10 s).
R62, R63: interne Parameter zur Stromregelung
Diese Register werden von der Klemme intern für die Stromregelung benutzt und dürfen nicht verändert werden!


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Hinweis
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.