KL2535_KL2545 - Pulsweitenstromklemmen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt. Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft. Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen. Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH & Co. KG.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0.0
▪
Migration
1.5.0
▪
Technische Daten aktualisiert
1.4.0
▪
Produkübersicht erweitert
1.3.0
▪
Montagehinweise aktualisiert
1.2.0
▪
Montagehinweise erweitert
▪
Technische Daten aktualisiert
▪
Registerübersicht aktualisiert
1.1.0
▪
Anschlussbeschreibung der KL2535 korrigiert
▪
Grundlagen zur Funktion korrigiert
▪
Hardware-Stand der KL2535 korrigiert
1.0
erste Veröffentlichung
0.1
internes Korrekturexemplar
Firm- und Hardware-Stände
Dokumentation Version | KL2535 |  | KL2545
 | Firmware | Hardware | Firmware | Hardware
1.5.0 | 1B | 04 | 2B | 08
1.4.0 | 1B | 01 | 1B | 05
1.3.0 | 1B | 01 | 1B | 05
1.2.0 | 1B | 01 | 1B | 05
1.1.0 | 1B | 00 | 1A | 02
1.0 | 1B | 00 | 1A | 02
0.1 | 1B | 00 | 1A | 02
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 06 1A 02:
12 - Produktionswoche 12
06 - Produktionsjahr 2006
1A - Firmware-Stand 1A
02 - Hardware-Stand 02


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KL2535 - Einführung
•
KL2535 - Technische Daten
•
KL2535 - LED-Anzeigen
•
KL2545 - Einführung
•
KL2545 - Technische Daten
•
KL2545 - LED-Anzeigen
•
Pulsweitenmodulation
•
Funktionen


KL2535 - Einführung

Produktübersicht [image] KL2535 - Einführung
KL2535 - Einführung
KL2535
Die zweikanalige Pulsweitenstromklemme KL2535 regelt einen Ausgangsstrom durch Pulsweitensteuerung der Versorgungsspannung. Der Stromwert (0 A bis 1 A) wird vom Automatisierungsgerät mit 16 Bit vorgegeben.
Die Ausgangsstufe ist überlast- und kurzschlusssicher und vom K-Bus galvanisch getrennt. Beide Kanäle zeigen ihren Signalzustand durch Leuchtdioden an, die eine schnelle Vor-Ort-Diagnose ermöglichen.
Die Busklemme ist als KL2535 für Standardverdrahtung und als KS2535 für stehende Verdrahtung lieferbar.


KL2535 - Technische Daten

Produktübersicht [image] KL2535 - Technische Daten
KL2535 - Technische Daten
Technische Daten | KL2535/KS2535
Anzahl der Endstufen | 2
Lastart | ohmsch-induktiv > 1 mH
Versorgung der Ausgangsstufe | 24 VDC, über Powerkontakte
Ausgangsstrom je Kanal | 1 A (kurzschlussfest, thermische Überlastwarnung für beide Ausgangsstufen gemeinsam)
PWM-Taktfrequenz | 36 kHz
Auflösung | maximal 12 Bit
Anzahl der digitalen Eingänge | 2 digitale Eingänge (24 V)
Nennspannung der Eingänge | 24 VDC (-15% / +20%)
Signalspannung "0" | -3 V ... 2 V
Signalspannung "1" | 15 V ... 30 V
Eingangsfilter | 0,2 ms
Eingangsstrom | typisch 5 mA
Potenzialtrennung | 500 V (K-Bus/Netzspannung)
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch: 60 mA
Stromaufnahme aus den Power-Kontakten | typisch: 10 mA
Bitbreite im Eingangsprozessabbild | 2 x 16 Bit Daten, 2 x 8 Bit Status
Bitbreite im Ausgangsprozessabbild | 2 x 16 Bit Daten, 2 x 8 Bit Control
Konfiguration | über den Buskoppler oder die Steuerung
Gewicht | ca. 55 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Zulässige Einbaulage | siehe Kapitel Einbaulage
Zulassung | CE


KL2535 - LED-Anzeigen

Produktübersicht [image] KL2535 - LED-Anzeigen
KL2535 - LED-Anzeigen
LED-Anzeigen
LEDs KL2535
LED | Anzeige
Run (grün) | reserviert | Datenübertragung auf dem K-Bus aktiv
Enable A (grün) | aus | Kanal 1 ist nicht freigeschaltet oder nicht betriebsbereit.
 | an | Kanal 1 ist freigeschaltet und betriebsbereit.
- | reserviert
Error A (rot) | an | anstehender Fehler bei Kanal 1
Power (grün) | aus | Die Versorgungsspannung ist nicht vorhanden (kleiner als 7 V).
 | an | Die Versorgungsspannung ist vorhanden (größer als 8 V).
Enable B (grün) | aus | Kanal 2 ist nicht freigeschaltet oder nicht betriebsbereit.
 | an | Kanal 2 ist freigeschaltet und betriebsbereit.
Warning (gelb) | an | Die interne Temperatur ist größer als 80°C oder die Versorgungsspannung ist gesunken.
Error B (rot) | an | anstehender Fehler bei Kanal 2


KL2545 - Einführung

Produktübersicht [image] KL2545 - Einführung
KL2545 - Einführung
KL2545
Die zweikanalige Pulsweitenstromklemme KL2545 regelt einen Ausgangsstrom durch Pulsweitensteuerung der Versorgungsspannung. Der Stromwert (0 A bis 3,5 A) wird vom Automatisierungsgerät mit 16 Bit vorgegeben.
Die Ausgangsstufe ist überlast- und kurzschlusssicher und vom K-Bus galvanisch getrennt. Beide Kanäle zeigen ihren Signalzustand durch Leuchtdioden an, die eine schnelle Vor-Ort-Diagnose ermöglichen. Pro Kanal kann ein Inkremental-Encoder angeschlossen werden, mit dem die Positionsrückführung direkt in der Klemme umgesetzt werden kann.
Die Busklemme ist als KL2545 für Standardverdrahtung und als KS2545 für stehende Verdrahtung lieferbar.


KL2545 - Technische Daten

Produktübersicht [image] KL2545 - Technische Daten
KL2545 - Technische Daten
Technische Daten | KL2545/KS2545
Anzahl der Endstufen | 2
Lastart | ohmsch-induktiv > 1 mH
Versorgung der Ausgangsstufe | 8 VDC bis 50 VDC, über Klemmstellen
Ausgangsstrom je Kanal | 3,5 A (kurzschlussfest, thermische Überlastwarnung für beide Ausgangsstufen gemeinsam)
PWM-Taktfrequenz | 36 kHz
Auflösung | maximal 12 Bit
Anzahl der digitalen Eingänge | 2 (für Endlagen)
Nennspannung der digitalen Eingänge | 24 VDC (-15% / +20%)
Signalspannung "0" an digitalen Eingängen | -3 V ... 2 V
Signalspannung "1" an digitalen Eingängen | 15 V ... 30 V
Eingangsfilter | 0,2 ms
Eingangsstrom | typisch 5 mA
Anzahl der Encoder-Eingänge | 4 (für ein Gebersystem)
Geberspannung "0" | -3 V ... 1,5 V
Geberspannung "1" | 2,5 V ... 24 V
Potenzialtrennung | 500 V (K-Bus/Netzspannung)
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch: 100 mA
Stromaufnahme aus den Power-Kontakten | typisch: 20 mA
Verlustleistung | typisch: 4 W
Bitbreite im Eingangsprozessabbild | 2 x 16 Bit Daten, 2 x 8 Bit Status
Bitbreite im Ausgangsprozessabbild | 2 x 16 Bit Daten, 2 x 8 Bit Control
Konfiguration | über den Buskoppler oder die Steuerung
Gewicht | ca. 100 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Zulässige Einbaulage | siehe Kapitel Einbaulage
Zulassung | CE


KL2545 - LED-Anzeigen

Produktübersicht [image] KL2545 - LED-Anzeigen
KL2545 - LED-Anzeigen
LEDs KL2545
Linkes LED-Prisma
LED | Anzeige
Run (grün) | an | Datenübertragung auf dem K-Bus aktiv
Enc. A: A (grün) | an | Am Eingang A für Encoder A liegt ein Signal an.
Enc. B: A (grün) | an | Am Eingang A für Encoder B liegt ein Signal an.
Input 1 (grün) | an | Am Eingang 1 liegt ein Signal an.
- | reserviert
Enc. A: B (grün) | an | Am Eingang B für Encoder A liegt ein Signal an.
Enc. B: B (grün) | an | Am Eingang B für Encoder B liegt ein Signal an.
Input 2 (grün) | an | Am Eingang 2 liegt ein Signal an.
Rechtes LED-Prisma
LED | Anzeige
- | reserviert
Enable A (grün) | aus | Kanal 1 ist nicht freigeschaltet oder nicht betriebsbereit.
 | an | Kanal 1 ist freigeschaltet und betriebsbereit.
- | reserviert
Error A (rot) | an | anstehender Fehler bei Kanal 1
Load Power (grün) | aus | Die Versorgungsspannung für die Last ist nicht vorhanden (kleiner als 7 V).
 | an | Die Versorgungsspannung für die Last ist vorhanden (größer als 8 V).
Enable B (grün) | aus | Kanal 2 ist nicht freigeschaltet oder nicht betriebsbereit.
 | an | Kanal 2 ist freigeschaltet und betriebsbereit.
Warning (gelb) | an | Die interne Temperatur ist größer als 80°C oder die Versorgungsspannung ist gesunken.
Error B (rot) | an | anstehender Fehler bei Kanal 2


Pulsweitenmodulation

Produktübersicht [image] Pulsweitenmodulation
Pulsweitenmodulation
Die Pulsweitenstromklemmen KL2535 und KL2545 integrieren eine kompakte PWM-Endstufe (bis 175 W) in kleinster Bauform.
Mittels PWM-Endstufe wird die Pulsweitenmodulation (PWM) der Versorgungsspannung zur Regelung des Ausgangsstroms einer angeschlossenen Ohmsch-Induktiven Last eingesetzt. Dem Ausgang wird dabei die Versorgungsspannung in voller Höhe mit einer bestimmten Frequenz pulsierend zugeführt. Nur mit dem High -Pegel baut sich an der Induktivität ein Laststrom auf. Eine Änderung des Laststroms erfolgt nun nicht durch Änderung der Spannungshöhe, sondern durch die Dauer des Ausschaltens (Pulsweite) im Verhältnis zur Periodendauer. Dies ergibt ein Tastverhältnis von Pulsweite dividiert durch Periodendauer entsprechend zwischen 0 bis 100 % und ist proportional zum Laststrom.
Betrieb an Last mit ausreichend großer Induktivität
Betrieb an Last mit zu kleiner Induktivität (nahezu ohmsch)
In der Abbildung „Betrieb an Last mit zu kleiner Induktivität“ ist zur Veranschaulichung der Betrieb mit einer nicht ausreichend großen Induktivität dargestellt. Ein kontinuierlicher Stromfluss kommt nicht zustande. Der Strom "lückt". Diese Betriebsart ist nicht zulässig.
Hinweis
Pulsweitenstromklemmen benötigen induktive Lasten
Die Induktivität der Last sollte mindestens 1 mH betragen! Ein Betrieb der Pulsweitenstromklemmen an Lasten mit einer Induktivität von weniger als 1 mH wird nicht empfohlen, weil auf Grund des unterbrochenen Stromflusses kein Bezug zwischen dem Sollwert und dem arithmetischen Mittelwert des Stroms gegeben ist!


Funktionen

Produktübersicht [image] Funktionen
Funktionen
Die Pulsweitenstromklemmen KL2535 und KL2545 integrieren eine kompakte PWM-Endstufe (bis 175 W) in kleinster Bauform.
Allgemeine Funktionen
Freigabe/Betriebsbereitschaft
Zur Aktivierung der Ausgangsstufe muss im Control-Byte das Enable-Bit CB1.5 gesetzt werden. Steht die Klemme zu dem Zeitpunkt in einem fehlerfreien Zustand, quittiert sie dies durch setzen des Ready-Bits SB1.4 im Status-Byte.
Position Setzen/Löschen (nur KL2545)
Der aktuelle Positionswert des Encoders kann vom Anwender gesetzt bzw. gelöscht werden. Das Register R1 dient hierbei als Bezug. Eine steigende Flanke von Bit CB1.1 setzt die aktuelle Position, die Quittierung erfolgt durch das Status-Bit SB1.1.
Latch-Funktionen
Der interne Encoder bietet die Möglichkeit der Erfassung eines Latch-Ereignisses. Ein Latch-Ereignis kann durch die digitalen Einganssignale erzeugt werden.
Die Reaktion der Klemme auf Latch-Ereignisse wird wie folgt aktiviert:
▪
Setzen des Control-Bits CB1.2 aktiviert die steigende Flanke am digitalen Eingang (höchste Priorität)
▪
Setzen des Control-Bits CB1.3 aktiviert die fallende Flanke am digitalen Eingang (zweithöchste Priorität)
Nachdem die Freigabe durch den Anwender erfolgt ist, speichert die Klemme beim nächsten Latch-Ereignis den aktuellen Positionswert und signalisiert dies durch Setzen des Status-Bits SB1.2. Das Auslesen der Latch-Werte muss durch Setzen von CB1.4 begonnen werden; hierdurch wird der Latch-Wert in den Prozessdaten DataIN eingeblendet (die Klemme signalisiert dies durch das Status-Bit SB1.3).
Hinweis
Freigabe für Latch-Werte
Beim Auslesen der Latch-Werte muss die zuvor gesetzte Freigabe erhalten bleiben. Die Latch-Werte gehen verloren, wenn die Freigabe weggenommen wird!
Digitale Eingänge
Die digitalen Eingänge werden im Status-Byte im Bit SB1.0 eingeblendet.
Fehleranzeige
Die Klemme bietet dem Anwender verschiedene Diagnosemöglichkeiten. Diese Meldungen sind in Hardware-Warnungen und Hardware-Fehler unterteilt.
Hardware-Warnungen
Bei Auftreten einer der folgenden Warnungen wird im Status-Byte das Bit SB1.5 (Warning) gesetzt.
▪
Übertemperatur (OverTemperature R0.8)
(Erreicht die Klemmeninnentemperatur 80°C, wird das SB1.5 (Warning) gesetzt. Sinkt die Temperatur unter 60°C, wird es automatisch zurückgesetzt.)
▪
Niedrigspannung (LowVoltage R0.9)
Hardware-Fehler
Bei Auftreten einer der folgenden Fehler wird die Last stromlos geschaltet und im Status-Byte das Bit SB1.6 (Error) gesetzt.
▪
Unterspannung (UnderVoltage R0.11)
▪
Überstrom (OverCurrent, R0.12)
▪
Offene Last / Drahtbruch (OpenLoad, R0.13)
▪
Ausfall der 24 V Steuerspannung (NoControlPower, R0.14)
(die Klemme wird bei wiederkehrender Steuerspannung automatisch reinitialisiert)
Bei Auftreten eines Fehlers muss dieser zunächst behoben und anschließend durch Setzen des Bits CB1.6 im Control-Byte quittiert und damit gelöscht werden.
Dithering
Zur Aktivierung des Dithers muss das Feature-Bit R32.5 und das Control-Bit CB1.0 gesetzt werden.
Diese Funktion dient dazu, Magnetisierungeffekte zu eliminieren. Beim Dithering wird dem eigentlichen Ausgabewert ein Rechtecksignal auf moduliert. Die dazu benötigte Konfiguration ist stark abhängig von der Applikation. Sie muss mit Hilfe der Kenndaten des angeschlossenen Aktors ermittelt werden.
Die folgenden Parameter sind einstellbar:
Name | Register | Wertebereich | Beschreibung
Frequenz - f | R37 | 10 Hz bis 500 Hz | Frequenz des Rechtecksignals, die Auflösung beträgt 1 Hz.
Amplitude - i | R38 | 0% bis 100% | Amplitude des Rechtecksignals, die Auflösung beträgt 1% (bezogen auf den eingestellten Ausgabestrom in Register R36)
Abschaltrampe - t | R39 | 0 ms bis 32767 ms | Das Dither-Signal springt beim Einschalten sofort auf die eingestellte Amplitude in R38. Beim Ausschalten nimmt das Signal mit der hier konfigurierten Zeit linear ab, die Auflösung beträgt 1 ms.
Frequenz - f / Amplitude - i
Abschaltrampe - t
Ventilkennlinie
Zur Aktivierung der Ventilkennlinie muss das Feature-Bit R32.4 gesetzt werden.
Die folgenden Parameter sind einstellbar:
Name | Register | Wertebereich | Beschreibung
Überlappung - Schwellwert - x1 | R40 | 0 bis 1000 | Bei diesem Prozessdatenwert endet der Überlappungsbereich, die Auflösung beträgt 0,1% (bezogen auf 32767)
Überlappung - Ausgabewert - y1 | R41 | 0 bis 1000 | Maximaler Ausgangsstrom im Überlappungsbereich, die Auflösung beträgt 0,1% (bezogen auf den eingestellten Ausgabestrom in Register R36)
Knickkompensation - Schwellwert - x2 | R42 | 0 bis 1000 | Bei diesem Prozessdatenwert endet der Knickkompensationsbereich, die Auflösung beträgt 0,1% (bezogen auf 32767)
Knickkompensation - Ausgabewert - y2 | R43 | 0 bis 1000 | Maximaler Ausgangsstrom im Knickkompensationsbereich, die Auflösung beträgt 0,1% (bezogen auf den eingestellten Ausgabestrom in Register R36)
Flächenkompensation - Schwellwert - x3 | R44 | 0 bis 1000 | Bei diesem Prozessdatenwert endet der Flächenkompensationsbereich, die Auflösung beträgt 0,1% (bezogen auf 32767)
Die Kennlinie teilt sich in vier Bereiche auf:
I | Überlappung
II | Knickkompensation
III, III' | Flächenkompensation
IV | Endbereich
Ventilkennlinie
Prozessdatenrampen
Zur Aktivierung der Prozessdatenrampen muss das Feature-Bit R32.6 gesetzt werden.
Diese Funktion bietet die Möglichkeit, den Ausgangsstrom automatisch mit einer linearen Rampe vom aktuellen auf den neuen Prozessdatenwert hoch- bzw. herunterzufahren. Die Registerwerte R45 und R46 beziehen sich dabei auf den gesamten Prozessdatenbereich, d.h. von 0 bis 32767.
Die folgenden Parameter sind einstellbar:
Name | Register | Wertebereich | Beschreibung
steigende Rampe - t1 | R45 | 0 bis 32767 ms | Die Zeit t1, die benötigt wird um den Prozessdatenwert von 0 auf 32767 zu fahren (Auflösung: 1 ms).
fallende Rampe - t2 | R46 | 0 bis 32767 ms | Die Zeit t2, die benötigt wird um den Prozessdatenwert von 32767 auf 0 zu fahren (Auflösung: 1 ms).
Prozessdatenrampen


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Vorgeschriebene Einbaulage
•
Anschlusstechnik
•
KL2535 - Anschluss
•
KL2545 - Anschluss


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Vorgeschriebene Einbaulage

Montage und Verdrahtung [image] Vorgeschriebene Einbaulage
Vorgeschriebene Einbaulage
Achtung
Einschränkung von Einbaulage und Betriebstemperaturbereich
Sorgen Sie bei der Montage der Klemmen dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Vorgeschriebene Einbaulage
Für die vorgeschriebene Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“).
Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach der obigen Abbildung wird dringend empfohlen!


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Hinweis
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Hinweis
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx / KLxxxx und Klemmen für stehende Verdrahtung ESxxxx / KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Hinweis
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


KL2535 - Anschluss

Montage und Verdrahtung [image] KL2535 - Anschluss
KL2535 - Anschluss
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL2535 Anschluss
Klemmstelle | Nr. | Anschluss
A1 | 1 | Last A, Anschluss A1
B1 | 2 | Last B, Anschluss B1
Sense A | 3 | Last A, Sense
Input 1 | 4 | Digitaler Eingang 1 (24 VDC).
A2 | 5 | Last A, Anschluss A2
B2 | 6 | Last B, Anschluss B2
Sense B | 7 | Last B, Sense
Input 2 | 8 | Digitaler Eingang 2 (24 VDC).


KL2545 - Anschluss

Montage und Verdrahtung [image] KL2545 - Anschluss
KL2545 - Anschluss
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL2545 Anschluss
Linker Gehäuseteil
Klemmstelle | Nr. | Anschluss für
Encoder A, A | 1 | Encoder A, Anschluss A
Encoder B, A | 2 | Encoder B, Anschluss A
Encoder Power +24 V | 3 | Encoder-Versorgung (von positivem Powerkontakt)
Input 1 | 4 | Digitaler Eingang 1 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Wort das Bit CW.1 gesetzt ist und eine steigende Flanke am digitalen Eingang 1 auftritt.
Encoder A, B | 5 | Encoder A, Anschluss B
Encoder B, B | 6 | Encoder B, Anschluss B
Encoder Power 0 V | 7 | Encoder-Versorgung (von negativem Powerkontakt)
Input 2 | 8 | Digitaler Eingang 2 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Wort das Bit CW.2 gesetzt ist und eine steigende Flanke am digitalen Eingang 2 auftritt.
Rechter Gehäuseteil
Klemmstelle (rechts) | Nr. | Anschluss für
Load A, A1 | 1' | Last A, Anschluss A1
Load B, B1 | 2' | Last B, Anschluss B1
Sense A | 3' | Last A, Sense
Load Power 50 V | 4' | Einspeisung für Lastversorgung (maximal +50 VDC)
Load A, A2 | 5' | Last A, Anschluss A2
Load B, B2 | 6' | Last B, Anschluss B2
Sense B | 7' | Last B, Sense
Load Power 0 V | 8' | Einspeisung für Lastversorgung (0 VDC)
Power Kontakte
Die Spannung Up der Powerkontakte (+24 VDC) versorgt folgende Verbraucher:
▪
Inkremental-Encoder (Klemmstelle 3 und 7)
▪
digitale Eingänge (Klemmstelle 4 und 8)
▪
Endstufentreiber der Pulsweitenstromklemme
Hinweis
Einschalt-Reihenfolge der Versorgungsspannungen
Die Spannung Up muss an den Power-Kontakten schon anliegen wenn die K-Bus-Spannung eingeschaltet wird, damit interne Schaltkreise (Endstufentreiber) initialisiert werden können.
Ist das applikationsbedingt nicht möglich (Versorgung wird z. B. über Not-Aus-Kreis geschaltet), führt die Klemme nach dem Hochfahren des Systems einen Software-Reset durch.
Wenn die Spannung Up an den Powerkontakten ausfällt, wir dies durch Bit SW.14 angezeigt. Das Wiederkehren der Spannung wird automatisch erkannt und eine Initialisierung durchgeführt.
WARNUNG
Ventile werden bei Ausfall der K-Bus-Spannung nicht zurückgesetzt!
Falls die K-Bus-Spannung (5 V, gespeist aus der Versorgungsspannung des Buskopplers Us) ausfällt, werden die Ausgangstreiber nicht zurückgesetzt! Dies bedeutet, dass die Ventile dann nicht in die Ausgangsstellung zurückgefahren werden!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Einstellungen
•
Register
•
Prozessdaten


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Buskoppler für Ethernet BK9000.
▪
eine digitale Eingangsklemme KL1xx2.
▪
eine zweikanalige Pulsweitenstromklemme KL2535 oder KL2545.
▪
eine Bus-Endklemme KL9010.
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (im Beispiel Position 2).
KS2000 Baumzweige für Kanal 1 der KL2535
Für die KL2535 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL2535.
▪
Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL2535.
▪
ProcData zeigt die Prozessdaten der KL2535.


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Einstellungen zur Parametrierung der KL2535 und KL2545.
Einstellungen über KS2000
Betriebsart
Watchdog Timer aktiv (R32.2)
Hier können Sie den Watchdog deaktivieren (Default: aktiv). Wenn die Pulsweitenstromklemme bei aktivem Watchdog für 100 ms keine Prozessdaten von der Steuerung empfängt, löst der Watchdog aus und das Ventil wird abgeschaltet.
Anwender-Skalierung (R32.0)
Hier können Sie die Anwender-Skalierung aktivieren (Default: inaktiv).
Anwendereinschaltwert aktiv (R32.8)
Hier können Sie den Anwendereinschaltwert aktivieren (Default: inaktiv).
Betrags-Vorzeichendarstellung (R32.3)
Hier können Sie die Betrags-Vorzeichendarstellung aktivieren (Default: inaktiv).
Dithering aktiv (R32.5)
Hier können Sie das Dithering aktivieren (Default: inaktiv).
Ventilkennlinie (R32.4)
Hier können Sie die Ventilkennlinie aktivieren (Default: inaktiv).
Prozessdatenrampen aktiv (R32.6)
Hier können Sie die Prozessdatenrampen aktivieren (Default: inaktiv).
Registerwerte
Anwender-Offset (R33)
Hier können Sie die den Offset für die Anwender-Skalierung festlegen (Default: 0).
Anwender-Gain (R34)
Hier können Sie die Vestärkung für die Anwender-Skalierung festlegen (Default: 4096dez).
Anwender-Einschaltwert (R35)
Hier können Sie die den Anwender-Einschaltwert für die Geschwindigkeit festlegen (Default: 0).
Max. Ausgangsstrom (R36)
Hier können Sie die den maximalen Ausgangsstrom angeben.
KL2535: Default 1000 mA
KL2545: Default 3500 mA
Dithering - Frequenz (R37)
Hier können Sie die Frequenz des Dithers angeben (Default: 0).
Dithering - Amplitude (R38)
Hier können Sie die Amplitude des Dithers angeben (Default: 0).
Dithering - Abschaltrampe (R39)
Hier können Sie die Abschaltrampe des Dithers angeben (Default: 0).
Überlappung - Schwellwert (R40)
Hier können Sie den Schwellwert des Überlappungsbereiches angeben (Default: 0).
Überlappung - Ausgabewert (R41)
Hier können Sie den Ausgabewert des Überlappungsbereiches angeben (Default: 0).
Knickbereich - Schwellwert (R42)
Hier können Sie den Schwellwert des Knickkompensationsbereiches festlegen (Default: 0).
Knickbereich - Ausgabewert (R43)
Hier können Sie die Ausgabewert des Knickkompensationsbereiches festlegen (Default: 0).
Der I-Anteil der Geschwindigkeitsregelung wird zum Nullpunkt hin abgeschwächt. Dieses Register gibt den Wert an, ab dem die Abschwächung aktiviert wird.
Flächenkompensation - Schwellwert (R44)
Hier können Sie den Schwellwert des Flächenkompensationsbereiches festlegen (Default: 1000dez).
Prozessdatenrampe (steigend) (R45)
Hier können Sie die steigende Prozessdatenrampe festlegen (Default: 0dez).
Prozessdatenrampe (fallend) (R38)
Hier können Sie die fallende Prozessdatenrampe festlegen (Default: 0dez).


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register der KL2535/KL2545 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Registeransicht in KS2000


Prozessdaten

Konfigurations-Software KS2000 [image] Prozessdaten
Prozessdaten
Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.
ProcData
Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.
Feld Verlauf
Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.
Feld Wert
Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.
Feld Wert
VORSICHT
Gefahr für Personen, Umwelt oder Geräte!
Beachten Sie, das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann.
Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, das Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.
Einstellungen


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Bytes
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Die KL2535 und KL2545 stellen sich im komplexen Prozessabbild mit mindestens 6 Byte Ein- und 6 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | SB1 | CB1
1 | 2 | Wort | DataIN1 | DataOUT1
3 | 4 | Byte | SB2 | CB2
4 | 6 | Wort | DataIN2 | DataOUT2
Die KL2535 und KL2545 stellen sich im kompakten Prozessabbild mit mindestens 6 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | - | CB1
1 | 2 | Wort | - | DataOUT1
3 | 4 | Byte | - | CB2
4 | 6 | Wort | - | DataOUT2
*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen
Legende
SB n: Status-Byte des Kanals n
CB n: Control-Byte des Kanals n
DataIN n: Eingangswort des Kanals n
DataOUT n: Ausgangswort des Kanals n
Hinweis
Prozessabbild
Ein Betrieb der KL2535 und KL2545 ohne Control-Bytes ist nicht möglich, da die Control-Bytes für die Freigabe der Kanäle erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen, werden KL2535 und KL2545 mit ihrem Control-Bytes dargestellt!
Prozessdaten
Ausgangswert | Ausgangsstrom
-32767dez | -100% vom maximalen Ausgangsstrom (siehe Register R36)
0dez | 0
+32767dez | +100% vom maximalen Ausgangsstrom (siehe Register R36)


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Bytes
Control- und Status-Bytes
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 (bei Prozessdatenbetrieb)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reset | Enable | GetLatchData | enLatch FallEdge | enLatch RiseEdge | SetPos | enDithering
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 | Reset | 1bin | alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke)
CB1.5 | Enable | 1bin | Schaltet den Kanal 1 frei
CB1.4 | GetLatchData | 0bin | die aktuelle Position in die Eingangsprozessdaten einblenden
 |  | 1bin | den aktuellen Latch-Wert in die Eingangsprozessdaten einblenden
CB1.3 | enLatch FallEdge | 1bin | externes Latch-Ereignis ist freigeschaltet (bei fallender Flanke des Latch-Eingangs speichert die Klemme die aktuelle Position)
CB1.2 | enLatch RiseEdge | 1bin | externes Latch-Ereignis ist freigeschaltet (bei steigender Flanke des Latch-Eingangs speichert die Klemme die aktuelle Position) ACHTUNG: höhere Priorität als CB1.3!
CB1.1 | SetPos | 1bin | Positionswert wird mit Register R1 gesetzt (steigende Flanke)
CB1.0 | enDithering | 1bin | Dithering ist aktiv (bei R32.5=1)
Status-Byte 1 (bei Prozessdatenbetrieb)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Warning | Ready | LatchData | LatchValid | SetPos Ready | Input E1
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 | Error | 1bin | ein Fehler ist aufgetreten (wird im Statuswort in Register R0 angezeigt)
SB1.5 | Warning | 1bin | Die interne Temperatur ist größer als 80 °C oder die Versorgungsspannung ist gesunken.
SB1.4 | Ready | 0bin | Motoransteuerung ist gesperrt oder es liegt ein Fehler vor (SB.6=1)
 |  | 1bin | Motoransteuerung ist frei geschaltet und es ist kein Fehler aufgetreten (Quittung für Enable, SB.6=0)
SB1.3 | LatchData | 0bin | die aktuelle Position ist in den Eingangsprozessdaten eingeblendet
 |  | 1bin | der letzte Latchwert ist in den Eingangsprozessdaten eingeblendet, wenn ein gültiger Latchwert vorhanden ist (Quittung für GetLatchData)
SB1.2 | LatchValid | 1bin | ein Latchereignis ist eingetreten (bei CB1.2=1 oder CB1.3=1)
SB1.1 | SetPos Ready | 1bin | die aktuelle Position wurde gesetzt (Quittung für SetPos)
SB1.0 | Input E1 | Status des Eingangs E1
Registerkommunikation
Control-Byte 1 (bei Registerkommunikation)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIn lesen oder - mit dem Ausgangsdatenwort DataOut beschreiben wollen.
Status-Byte 1 (bei Registerkommunikation)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2
Control- und Status-Byte des Kanals 2 (CB2 und SB2) sind wie Control- und Status-Byte des Kanals 1 aufgebaut.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der Pulsweitenstromklemme. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Register-Nr. | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | Statuswort |  | 0x0000 | 0dez | R | RAM
R1 | Position setzen (nur KL2545) |  | 0x0000 | 0dez | R/W | RAM
R2 | Spulenspannung (nur KL2545) |  | 0x0000 | 0dez | R | RAM
R3 | Versorgungsspannung (nur KL2545) |  | z. B. 0x0030 | z. B. 48dez | R | RAM
R4 | reserviert |  | - | - | - | -
R5 | Temperatur (nur KL2545) |  | z. B. 0x0023 | z. B. 35dez | R | RAM
R6 | Status-Byte |  | z. B. 0x0010 | z. B. 16dez | R | RAM
R7 | Kommando-Register |  | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | KL2535: | 0x09E7 | 2535dez | R | ROM
 |  | KL2545: | 0x09F1 | 2545dez
R9 | Firmware-Stand |  | z. B. 0x3141 | z. B. 1AASCII | R | ROM
R10 | Multiplex-Schieberegister |  | 0x0130 | 304dez | R | ROM
R11 | Signalkanäle |  | 0x0218 | 536dez | R | ROM
R12 | minimale Datenlänge |  | 0x1818 | 6168dez | R | ROM
R13 | Datenstruktur |  | 0x0004 | 4dez | R | ROM
R14 | reserviert |  | - | - | - | -
R15 | Alignment-Register |  | 0x7F80 | 32640dez | R/W | RAM
R16 | Hardware-Versionsnummer |  | z. B. 0x0000 | z. B. 0dez | R/W | EEPROM
R17 | reserviert |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R30 | reserviert |  | - | - | - | -
R31 | Kodewort-Register |  | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register |  | 0x0000 | 0dez | R/W | EEPROM
R33 | Anwender-Skalierung - Offset |  | 0x1000 | 4096dez | R/W | EEPROM
R34 | Anwender-Skalierung - Gain |  | 0x0000 | 0dez | R/W | EEPROM
R35 | Anwender-Einschaltwert |  | 0x0000 | 0dez | R/W | EEPROM
R36 | maximaler Ausgangsstrom | KL2535: | 0x03E8 | 1000dez | R/W | EEPROM
 |  | KL2545: | 0x0DAC | 3500dez
R37 | Dithering - Frequenz |  | 0x0000 | 0dez | R/W | EEPROM
R38 | Dithering - Amplitude |  | 0x0000 | 0dez | R/W | EEPROM
R39 | Dithering - Abschaltrampe |  | 0x0000 | 0dez | R/W | EEPROM
R40 | Überlappung - Schwellwert |  | 0x0000 | 0dez | R/W | EEPROM
R41 | Überlappung - Ausgabewert |  | 0x0000 | 0dez | R/W | EEPROM
R42 | Knickkompensation - Schwellwert |  | 0x0000 | 0dez | R/W | EEPROM
R43 | Knickkompensation - Ausgabewert |  | 0x0000 | 0dez | R/W | EEPROM
R44 | Flächenkompensation - Schwellwert |  | 0x03E8 | 1000dez | R/W | EEPROM
R45 | Prozessdatenrampe (steigend) |  | 0x0000 | 0dez | R/W | EEPROM
R46 | Prozessdatenrampe (fallend) |  | 0x0000 | 0dez | R/W | EEPROM
R47 | reserviert |  |  |  |  |
R63 | reserviert |  |  |  |  |


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Alle Register können über die Registerkommunikation ausgelesen oder beschrieben werden. Sie dienen zur Parametrierung der Klemme.
R0: Statuswort
Das Statuswort beinhaltet Informationen über interne Zustände und gibt Auskunft über aufgetretene Fehler
Bit | R0.15 | R0.14 | R0.13 | R0.12 | R0.11 | R0.10 | R0.9 | R0.8
Name | - | NoControlPower | OpenLoad | OverCurrent | UnderVoltage | - | LowVoltage | OverTemperature
Bit | R0.7 | R0.6 | R0.5 | R0.4 | R0.3 | R0.2 | R0.1 | R0.0
Name | - | - | - | - | - | - | - | -
Legende
Bit | Name | Beschreibung
R0.15 | - | reserviert
R0.14 | NoControlPower | 1bin | keine 24 V Steuerspannung an den Powerkontakten vorhanden
R0.13 | OpenLoad | 1bin | offene Last / Drahtbruch
R0.12 | OverCurrent | 1bin | Überstrom der Treiberstufe
R0.11 | UnderVoltage | 1bin | Versorgungsspannung kleiner als 7 V (nur KL2545)
R0.10 | - | reserviert
R0.9 | LowVoltage | 1bin | Versorgungsspannung ist um 10 V kleiner als die Einschaltspannung (nur KL2545)
R0.8 | OverTemperature | 1bin | Innentemperatur der Klemme ist größer als 80°C (siehe R5) (nur KL2545)
R0.0 - R0.7 | - | reserviert
R1: Position setzen
Hier können Sie die gewünschte Position vorgeben, mit der die Klemme geladen werden soll.
R2: Spulenspannung
Hier kann die Spulenspannung ausgelesen werden. Die Einheit ist 1 mV (Beispiel: 4800 = 48 V).
R3: Versorgungsspannung
Hier kann die Versorgungsspannung ausgelesen werden. Die Einheit ist 1 mV (Beispiel: 4800 = 48 V).
R5: Temperatur-Register
Aus Register R5 kann die Innentemperatur der Klemme in °C ausgelesen werden. Die Klemme setzt im Status-Byte das Bit SB.5 als Warnung, wenn die Temperatur die Schwelle von 80°C überschreitet. Sinkt die Temperatur unter 60°C wird das Bit SB.5 automatisch wieder zurückgesetzt.
R6: Status-Byte
Hier wird zusätzlich das Status-Byte des jeweiligen Kanals eingeblendet.
R7: Kommando-Register
Hinweis
Anwender-Kodewort
Um die folgenden Kommandos auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein!
Kommando 0x7000: Restore Factory Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register beider Kanäle die Werte des Auslieferungszustands wiederhergestellt:
R32: 0dez
R33: 0dez
R34: 4096dez
R35: 0dez
R36: KL2535: 1000dez, KL2545: 3500dez
R37: 0dez
R38: 0dez
R39: 0dez
R40: 0dez
R41: 0dez
R42: 0dez
R43: 0dez
R44: 1000dez
R45: 0dez
R46: 0dez
Hinweis
Kompletter Restore
Das Kommando Restore Factory Settings setzt beide Kanäle der Pulsweitenstromklemme gleichzeitig zurück auf Auslieferungszustand, egal aus welchem Registersatz heraus es aufgerufen wird!
Kommando 0x8000: Software Reset
Mit dem Eintrag 0x8000 in Register R7 wird ein vollständiger Software-Reset der Klemme durchgeführt. Alle internen Variablen (Positionen, Latch-Werte, Fehler, usw.) werden gelöscht bzw. auf definierte Werte gesetzt, die aus dem EEPROM gelesen werden. Die internen Schaltkreise (D/A-C, Ausgangstreiber) werden bei einem Software-Reset neu initialisiert.
VORSICHT
Software-Reset!
Während eines Software-Resets wird die Endstufe stromlos geschaltet. Stellen Sie sicher, dass ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
R8: Klemmentyp
Im Register R8 steht die Bezeichnung der Klemme:
KL2535: 0x09E7 (2535dez)
KL2545: 0x09F1 (2545dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R31: Kodewort-Register
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen. Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
R32: Feature-Register
Das Feature-Register legt die Konfiguration der Klemme fest.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | disMixedDecay | - | - | - | - | - | - | enUserStartValue
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | enRamps | enDithering | enValveCurve | enAverageNotation | disWatchdog | enManuScale | enUserScale
Legende
Bit | Name | Beschreibung |  | default
R32.15 | disMixedDecay | 1bin | Mixed Decay ist deaktiviert | 0bin
R32.14 - R32.9 | - | reserviert
R32.8 | enUserStartValue | 1bin | Anwendereinschaltwert aktiv (siehe R35) | 0bin
R32.7 | - | reserviert
R32.6 | enRamps | 1bin | Prozessdatenrampen aktiv (siehe R45 + R46) | 0bin
R32.5 | enDithering | 1bin | Dithering aktiv (siehe R37, R38 + R39), zusätzlich muss das Bit CB1.0 = 1 gesetzt werden | 0bin
R32.4 | enValveCurve | 1bin | Ventilkennlinie aktiv (siehe R40, R41, R42, R43 + R44) | 0bin
R32.3 | enAverageNotation | 0bin | Darstellung im Zweierkomplement aktiv | 0bin
 |  | 1bin | Betragsvorzeichendarstellung aktiv
R32.2 | disWatchdog | 1bin | interner 100 ms Watchdog deaktiviert | 0bin
R32.1 | enManuScale | 1bin | Hersteller-Skalierung aktiv | 0bin
R32.0 | enUserScale | 1bin | Anwender-Skalierung aktiv (siehe R33 + R34) | 0bin
R33: Anwender-Skalierung - Offset
Wenn die Anwender-Skalierung aktiviert (R32.0=1) ist, legt dieses Register den Offset der Anwender-Skalierung fest.
R34: Anwender-Skalierung - Gain
Wenn die Anwender-Skalierung aktiviert (R32.0=1) ist, legt dieses Register den Gain der Anwender-Skalierung fest.
R35: Anwender-Einschaltwert
Wenn der Anwendereinschaltwert aktiviert (R32.8=1) ist und der aktivierte (R32.2=0bin) Watchdog bei einem Feld- oder Klemmenbusfehler nach 100 ms anspricht, wird dieser Wert zum Ausgabewert.
R36: maximaler Ausgangsstrom
Dieses Register legt den maximalen Ausgangsstrom fest. Die Einheit ist 1 mA (Beispiel: 1000dez = 1 A).
KL2535: maximal 1000 mA (Default: 1000dez)
KL2545: maximal 3500 mA (Default: 3500dez)
R37: Dithering - Frequenz
Wenn das Dithering aktiviert ist (R32.5=1), legt dieses Register die Frequenz des Dither fest.
Zulässige Werte sind von 10 bis 500 Hz.
Die Einheit ist 1 Hz. (Beispiel: 100dez = 100 Hz).
R38: Dithering - Amplitude
Wenn das Dithering aktiviert ist (R32.5=1), legt dieses Register die Amplitude des Dither fest.
Der konfigurierte Wert bezieht sich auf den eingestellten Ausgangsstrom in Register R36.
Die Einheit ist 1% (Beispiel: 10dez = 10%).
R39: Dithering - Abschaltrampe
Wenn das Dithering aktiviert ist (R32.5=1), legt dieses Register die Abschaltrampe des Dither fest.
Die Einheit ist 1 ms (Beispiel: 100dez = 100 ms).
R40: Überlappung - Schwellwert (Ventilkennlinie)
Wenn die Ventilkennlinie aktiviert ist (R32.4=1), legt dieses Register den Schwellwert des Überlappungsbereiches fest.
Die Einheit ist 0,1% und bezieht sich auf den Prozessdatenendwert (Beispiel: 100dez = 10%).
R41: Überlappung - Ausgabewert (Ventilkennlinie)
Wenn die Ventilkennlinie aktiviert ist (R32.4=1), legt dieses Register den Ausgabewert des Überlappungsbereiches fest.
Der konfigurierte Wert bezieht sich auf den eingestellten Ausgangsstrom in Register R36.
Die Einheit ist 0,1% (Beispiel: 100dez = 10%) .
R42: Knickkompensation - Schwellwert (Ventilkennlinie)
Wenn die Ventilkennlinie aktiviert ist (R32.4=1), legt dieses Register den Schwellwert des Knickkompensationsbereiches fest.
Die Einheit ist 0,1% und bezieht sich auf den Prozessdatenendwert (Beispiel: 100dez = 10%).
R43: Knickkompensation - Ausgabewert (Ventilkennlinie)
Wenn die Ventilkennlinie aktiviert ist (R32.4=1), legt dieses Register den Ausgabewert des Knickkompensationsbereiches fest.
Der konfigurierte Wert bezieht sich auf den eingestellten Ausgangsstrom in Register R36.
Die Einheit ist 0,1% (Beispiel: 100dez = 10%) .
R44: Flächenkompensation - Schwellwert (Ventilkennlinie)
Wenn die Ventilkennlinie aktiviert ist (R32.4=1), legt dieses Register den Schwellwert des Flächenkompensationsbereiches fest.
Die Einheit ist 0,1% und bezieht sich auf den Prozessdatenendwert (Beispiel: 100dez = 10%).
R45: Prozessdatenrampe (steigend)
Wenn die Prozessdatenrampen aktiviert sind (R32.6=1), legt dieses Register die steigende Prozessdatenrampe fest.
Die Einheit ist 1 ms und bezieht sich auf den Prozessdatenendwert (Beispiel: 100dez = 100 ms).
R46: Prozessdatenrampe (fallend)
Wenn die Prozessdatenrampen aktiviert sind (R32.6=1), legt dieses Register die fallende Prozessdatenrampe fest.
Die Einheit ist 1 ms und bezieht sich auf den Prozessdatenendwert (Beispiel: 100dez = 100 ms).


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme
Beispiel 1: Lesen des Firmware-Stands aus Register 9 einer Klemme
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Hinweis
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel! Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.