KL2532, KL2552 - DC-Motor-Endstufen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Beckhoff Identification Code (BIC)


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.2.0
▪
Hinweise zum ESD-Schutz aktualisiert
▪
Kapitel „ Beckhoff Identification Code (BIC)“ eingefügt
3.1.0
▪
Update Hinweise zur Dokumentation
▪
Technische Daten aktualisiert
▪
Kapitel "Hinweise zum ESD Schutz" eingefügt
▪
Update Kapitel "Anschlusstechnik" -> "Anschluss"
▪
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit hinzugefügt
▪
Kapitel "Vorgeschriebene Einbaulage" ersetzt durch Kapitel "Einbaulagen bei Betrieb mit und ohne Lüfter"
▪
Revisionsstand aktualisiert
▪
Kapitel "UL Hinweis - Compact Motion" hinzugefügt
3.0.0
▪
Migration
▪
Revisionsstand aktualisiert
▪
Strukturupdate
2.6.0
▪
LED-Anzeigen der KL2532/KS2532 aktualisiert
▪
Technische Daten aktualisiert
2.5.0
▪
Technische Daten aktualisiert
▪
Registerübersicht korrigiert
▪
Registerbeschreibung erweitert
2.4.0
▪
Grundlagen zur Funktion aktualisiert
▪
Registerbeschreibung erweitert
▪
Technische Daten aktualisiert
▪
Montagehinweise aktualisiert
2.3.0
▪
Technische Daten aktualisiert
2.2.0
▪
Montagehinweise aktualisiert
2.1.0
▪
Einführung für KL2552 aktualisiert
▪
Registerbeschreibung aktualisiert
▪
Hinweise zur Anschlusstechnik erweitert
2.0.0
▪
KL2532 hinzugefügt
▪
Hinweise zur Anschlusstechnik hinzugefügt
1.1.0
▪
Registerbeschreibung erweitert
▪
Beschreibung der Konfigurations-Software KS2000 erweitert
▪
Beschreibung der KL2552-0005 hinzugefügt
▪
Technische Daten aktualisiert
▪
Beschreibung des Chopper-Betriebs hinzugefügt
▪
Anwendungsbeispiel hinzugefügt
1.0.0
▪
Englische Übersetzung veröffentlicht
▪
Kleinere Layout-Korrekturen
0.2
▪
Grundlagen zur Funktion hinzugefügt
▪
Beschreibung von Control- und Status-Byte erweitert
▪
Registerbeschreibung korrigiert
0.1
erste vorläufige Dokumentation für KL2552-0000
Firm- und Hardware-Stände
Dokumentation Version | KL2532/KS2532 |  |  | KL2552-0000/KS2552-0000 |  |  | KL2552-0005/KS2552-0005
 | Firmware |  | Hardware | Firmware |  | Hardware | Firmware |  | Hardware
 | K-Bus | Power Stage |  | K-Bus | Power Stage |  | K-Bus | Power Stage
3.1.0 | 3B | 3B | 07 | 2C | 2C | 09 | 2C | 2C | 09
3.0.0 | 3B | 3B | 07 | 1M | 1M | 07 | 1M | 1M | 07
2.6.0 |  |  |  |  |  |  |  |  |
2.5.0 | 3B | 3B | 05 | 1M | 1M | 03 | 1M | 1M | 04
2.4.0 | 3B | 3B | 05 | 1M | 1M | 03 | 1M | 1M | 04
2.3.0 | 3B |  | 05 | 1M |  | 03 | 1M |  | 04
2.2.0 | 1A | 1A | 02 | 1C | 1E | 00 | 1C | 1E | 00
2.1.0 | 1A | 1A | 02 | 1C | 1E | 00 | 1C | 1E | 00
2.0.0 | 1A | 1A | 00 | 1C | 1E | 00 | 1C | 1E | 00
1.1.0 | - | - | - | 1B | 1D | 00 | 1B | 1D | 00
1.0.0 |  |  |  | 1A | 1A | 00 | 1A | 1A | 00
0.2 |  |  |  | 1A | 1A | 00 | 1A | 1A | 00
0.1 |  |  |  | 1A | 1A | 00 | 1A | 1A | 00
Den K-Bus-Firmware und den Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - K-Bus-Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 49 05 1B 03:
49 - Produktionswoche 49
05 - Produktionsjahr 2005
1B - Firmware-Stand 1B
03 - Hardware-Stand 03


Beckhoff Identification Code (BIC)

Vorwort [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KL2532 - Einführung
•
KL2552 - Einführung
•
Technische Daten
•
KL2532 - LED-Anzeigen
•
KL2552 - LED-Anzeigen


KL2532 - Einführung

Produktübersicht [image] KL2532 - Einführung
KL2532 - Einführung
KL2532
Die zweikanalige Busklemme KL2532/KS2532 ermöglicht den direkten Betrieb von zwei DC-Motoren. Die Solldrehzahl wird vom Automatisierungsgerät mit einer Auflösung von 16 Bit vorgegeben.
Die Ausgangsstufe ist überlast- und kurzschlusssicher und vom K-Bus galvanisch getrennt. Beide Kanäle zeigen ihren Signalzustand durch Leuchtdioden an, die vor Ort eine schnelle Diagnose ermöglichen.
Die Busklemme ist als KL2532 für Standardverdrahtung und als KS2532 für stehende Verdrahtung lieferbar.


KL2552 - Einführung

Produktübersicht [image] KL2552 - Einführung
KL2552 - Einführung
KL2552
Die zweikanalige Busklemme KL2552/KS2552 ermöglicht den direkten Betrieb von zwei DC-Motoren. Die Solldrehzahl wird vom Automatisierungsgerät mit einer Auflösung von 16 Bit vorgegeben.
Die Ausgangsstufe ist überlast- und kurzschlusssicher und vom K-Bus galvanisch getrennt. Durch den Anschluss eines Inkremental-Encoders ist die einfache Realisierung einer Servo-Achse möglich.
Typische Motorparameter können eingestellt werden und vermeiden kritische Zustände für den DC-Motor. Die Last kann durch Maximalwertbegrenzung von Drehzahl und Drehmoment geschützt werden.
Beide Kanäle zeigen ihren Signalzustand durch Leuchtdioden an, die vor Ort eine schnelle Diagnose ermöglichen.
Die Busklemme ist als KL2552 für Standardverdrahtung und als KS2552 für stehende Verdrahtung lieferbar.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten |  | KL2532-0000 KS2532-0000 | KL2552-0000 KS2552-0000 | KL2552-0005 KS2552-0005
Anzahl der DC-Motor-Endstufen |  | 2
Lastart |  | Bürsten-DC-Motoren, induktiv
Versorgung der Ausgangsstufe |  | über Power-Kontakte | über Klemmstellen
Nennlastspannung (Motor Power) |  | 24 VDC | 8 VDC bis 50 VDC
Ausgangsstrom je Kanal |  | Nennstrom 1 A, Spitzenstrom 2,5 A | Nennstrom 5 A, Spitzenstrom 8 A (Kurzschlussfest, thermische Überlastwarnung für beide Ausgangsstufen gemeinsam)
PWM-Taktfrequenz |  | 30 kHz, Kanäle zueinander 180° phasenverschoben
Tastverhältnis |  | 0 ... 100% (spannungsgeregelt)
Auflösung | Strom | 10 Bit
 | Spannung (Geschwindigkeit) | 16 Bit
Anzahl digitale Eingänge |  | 2 (für Endlagen)
Input Filter |  | 0,2 ms
Signalspannung digitaler Eingang "0" |  | -3 V ... 1,5 V
Signalspannung digitaler Eingang "1" |  | 30 V
Eingangsstrom |  | typisch: 5,5 mA
Anzahl Encoder-Eingänge |  | - | 4 (für ein Encoder-System)
Encoder Signal |  | - | 5…24 V, 5 mA single-ended | 5 V, 5 mA single-ended
Encoder-Versorgung |  | - | 24 V, maximal 100 mA | 5 V, maximal 80 mA
Pulsfrequenz |  | - | max. 400000 Inkremente/s (bei Vierfachauswertung)
Geberspannung "0" |  | - | -3 V ... 1,5 V
Geberspannung "1" |  | - | 30 V
Potenzialtrennung |  | 500 V (K-Bus / Netzspannung)
Spannungsversorgung für Elektronik |  | über den K-Bus und über die Power-Kontakte
Stromaufnahme aus dem K-Bus (5 V) |  | typ. 50 mA | typ. 70 mA | typ. 120 mA
Stromaufnahme aus den Powerkontakten |  | typ. 30 mA + Motorstrom | typ. 40 mA + Sensorversorgung | typ. 120 mA
Bitbreite im Eingangsprozessabbild |  | 2 x 16 Bit Daten, 2 x 8 Bit Status
Bitbreite im Ausgangsprozessabbild |  | 2 x 16 Bit Daten, 2 x 8 Bit Control
Konfiguration |  | über den Buskoppler oder die Steuerung
Gewicht |  | ca. 55 g | ca. 100 g
zulässiger Umgebungstemperaturbereich im Betrieb |  | 0°C ... + 55°C | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung |  | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit |  | 95%, keine Betauung
Abmessungen (B x H x T) |  | ca. 14 mm x 100 mm x 70 mm (Breite angereiht: 12 mm) | ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Montage |  | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit |  | gemäß EN 60068-2-6 / EN 60068-2-27 siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung |  | gemäß EN 61000-6-2 / EN 61000-6-4 / EN 61800-6-3 * *) Standard: Kategorie C3. Für Kategorie C1 und C2 sind zusätzliche Filter erforderlich!
Schutzart |  | IP20
zulässige Einbaulage |  | ohne Lüftermodul ZB8610: Standard-Einbaulage mit Lüftermodul ZB8610: Standard-Einbaulage, weitere Einbaulagen (Beispiel 1 & 2) siehe Hinweis
Zulassung |  | CE, cULus


KL2532 - LED-Anzeigen

Produktübersicht [image] KL2532 - LED-Anzeigen
KL2532 - LED-Anzeigen
LEDs KL2532
LED | Anzeige
Run (grün) | reserviert | Datenübertragung auf dem K-Bus aktiv
Enable A (grün) | aus | Kanal 1 ist nicht frei geschaltet oder nicht betriebsbereit.
 | an | Kanal 1 ist frei geschaltet und betriebsbereit.
Warning A (gelb) | an | Die interne Temperatur ist größer als 80°C oder die Versorgungsspannung ist gesunken.
Error A (rot) | an | anstehender Fehler bei Kanal 1
Power (grün) | aus | Die Versorgungsspannung ist nicht vorhanden (kleiner als 7 V).
 | an | Die Versorgungsspannung ist vorhanden (größer als 8 V).
Enable B (grün) | aus | Kanal 2 ist nicht frei geschaltet oder nicht betriebsbereit.
 | an | Kanal 2 ist frei geschaltet und betriebsbereit.
Warning B (gelb) | an | Die interne Temperatur ist größer als 80°C oder die Versorgungsspannung ist gesunken.
Error B (rot) | an | anstehender Fehler bei Kanal 2


KL2552 - LED-Anzeigen

Produktübersicht [image] KL2552 - LED-Anzeigen
KL2552 - LED-Anzeigen
LEDs KL2552
Linkes LED-Prisma
LED | Anzeige
Run (grün) | an | Datenübertragung auf dem K-Bus aktiv
Enc. A: A (grün) | an | Am Eingang A für Encoder A liegt ein Signal an.
Enc. B: A (grün) | an | Am Eingang A für Encoder B liegt ein Signal an.
Input 1 (grün) | an | Am Eingang 1 liegt ein Signal an.
Enc. Rdy. (grün) | an | Encoderauswertung betriebsbereit.
Enc. A: B (grün) | an | Am Eingang B für Encoder A liegt ein Signal an.
Enc. B: B (grün) | an | Am Eingang B für Encoder B liegt ein Signal an.
Input 2 (grün) | an | Am Eingang 2 liegt ein Signal an.
Rechtes LED-Prisma
LED | Anzeige
Drv. Rdy. (grün) | an | Motortreiber betriebsbereit.
Enable A (grün) | aus | Kanal 1 ist nicht freigeschaltet oder nicht betriebsbereit.
 | an | Kanal 1 ist freigeschaltet und betriebsbereit.
Warning A (gelb) | an | Warnmeldung von Kanal 1
Error A (rot) | an | anstehender Fehler bei Kanal 1
Power (grün) | aus | Die Versorgungsspannung für den Motor ist nicht vorhanden.
 | an | Die Versorgungsspannung für den Motor ist vorhanden.
Enable B (grün) | aus | Kanal 2 ist nicht freigeschaltet oder nicht betriebsbereit.
 | an | Kanal 2 ist freigeschaltet und betriebsbereit.
Warning B (gelb) | an | Warnmeldung von Kanal 2
Error B (rot) | an | anstehender Fehler bei Kanal 2


Grundlagen zur Funktion

Grundlagen zur Funktion
Grundlagen zur Funktion
Weiterführende Informationen
•
Grundlagen
•
Chopper-Betrieb


Grundlagen

Grundlagen zur Funktion [image] Grundlagen
Grundlagen
Die DC-Motor-Klemme KL2532/KS2532 integriert zwei kompakte DC-Motor-Endstufen bis jeweils 24 W in kleinster Bauform.
Die DC-Motor-Klemme KL2552/KS2552 integriert zwei kompakte DC-Motor-Endstufen bis jeweils 250 W in kleinster Bauform.
Allgemeine Funktionen
Freigabe/Betriebsbereitschaft
Zur Aktivierung der Ausgangsstufe muss das Enable-Bit CB1.5 gesetzt werden. Steht die Klemme zu dem Zeitpunkt in einem fehlerfreien Zustand, quittiert sie dies durch setzen vom Ready-Bit SB1.4. Ist die Klemme betriebsbereit, signalisiert sie dies durch das Setzen von "Ready to Enable" (R0.2). Drehrichtungen werden durch Bit R0.4 (Moving Positive) und R0.5 (Moving Negative) angezeigt.
Position Setzen/Löschen
Der aktuelle Positionswert kann vom Anwender gesetzt bzw. gelöscht werden. Die Register R5 dient hierbei als Bezug. Eine steigende Flanke von Bit CB1.1 setzt die aktuelle Position, die Quittierung erfolgt durch das Status-Bit SB1.1.
Latch-Funktionen (nur KL2552/KS2552)
Der interne Encoder bietet die Möglichkeit der Erfassung eines Latch-Ereignisses. Ein Latch-Ereignis kann durch die digitalen Eingangssignale erzeugt werden.
Die Reaktion der Klemme auf Latcher-Ereignisse wird wie folgt aktiviert:
▪
Setzen des Control-Bits CB1.2 aktiviert die steigende Flanke am digitalen Eingang (höchste Priorität)
▪
Setzen des Control-Bits CB1.3 aktiviert die fallende Flanke am digitalen Eingang (zweithöchste Priorität)
Nachdem die Freigabe durch den Anwender erfolgt ist, speichert die Klemme beim nächsten Latch-Ereignis den aktuellen Positionswert und signalisiert dies durch Setzen des Status-Bits SB1.2. Das Auslesen der Latch-Werte muss durch Setzen von CB1.4 begonnen werden, hierdurch wird der Latch-Wert in den Prozessdaten DataIN eingeblendet (die Klemme signalisiert dies durch das Status-Bit SB1.3).
Auslesen des Latch-Wertes
Beim Auslesen des Latch-Wertes muss die vorher gesetzte Freigabe erhalten bleiben. Der Latch-Wert geht verloren, wenn die Freigabe weggenommen wird!
Manuelle und automatische Drehmomentreduzierung
Eine Drehmomentreduzierung kann auf zwei Arten erreicht werden:
▪
R32.10 = 0: Das Drehmoment wird reduziert (auf den Wert in R41 bzw. R49), wenn CB1.0 = 1 gesetzt wird. Die Klemme quittiert dies indem sie SB1.1 setzt
▪
R32.10 = 1: Das Drehmoment wird automatisch reduziert, wenn die Prozesseingangsdaten größer sind, als in R45 bzw. R48 konfiguriert. Deaktiviert wird die Reduzierung, wenn die Prozesseingangsdaten unter einen Wert von R45 bzw. R48 - 2% absinken.
Für die positive Drehrichtung werden R41 (reduziertes Drehmoment) und R45 (Drehmoment-Schwelle) verwendet.
Für die negative Drehrichtung werden R49 (reduziertes Drehmoment) und R48 (Drehmoment-Schwelle) verwendet.
Digitale Eingänge
Die digitalen Eingänge werden im Status-Byte im Bit SB1.0 eingeblendet.
Fehleranzeige
Die Klemme bietet dem Anwender verschiedene Diagnosemöglichkeiten. Unterteilt sind diese Meldungen Hardware-Warnungen und Hardware-Fehler.
Hardware-Warnungen
Bei Auftreten einer der folgenden Warnungen bleibt die Funktionalität der Klemme erhalten. Es wird im Status-Byte das Bit SB1.5 (Warning) gesetzt.
▪
Treiber in Sättigung (Saturated R0.6)
–
bei Ausgabe des größten Dutycycles wird dieses Bit gesetzt (wird automatisch gelöscht)
▪
Übertemperatur (Over Temperature R0.8)
–
liegt die Klemmeninnentemperatur über 80°C wird das Status-Bit gesetzt, sinkt die Temperatur unter 80°C wird es automatisch gelöscht
▪
Überlast (Over Current, R0.9) (R32.9 = 0)
–
steigt der Motorstrom über den in Register R35 konfigurierten Wert, wird das Bit gesetzt
–
steigt der Motorstrom bei aktiver Drehmomentbegrenzung (CB1.0 = 1) über den in Register R41 bzw. R49 konfigurierten Wert, wird das Bit gesetzt
▪
Unterspannung (Under Voltage R0.10)
–
sinkt die Motorspannung unter 8 V wird das Bit gesetzt
▪
Überspannung (Over Voltage R0.11)
–
steigt die Motorspannung über den Wert, der 10% größer, als in Register R36 konfigurierten, wird das Bit gesetzt
Bei Auftreten einer Warnung muss diese zunächst behoben und anschließend durch Setzen des Bits CB1.6 im Control-Byte quittiert und damit gelöscht werden (falls oben nicht anders angegeben).
Hardware-Fehler
Bei Auftreten einer der folgenden Fehler wird der Motor stromlos geschaltet und im Status-Byte das Bit SB1.6 gesetzt.
▪
Kurzschluss (Short Circuit R0.12)
▪
Ausfall der 24 V Steuerspannung (No Control Power, R0.14)
–
sinkt die Steuerspannung unter 12 V wird das Bit gesetzt (ein korrekte Funktion der Treiberstufen kann bei einer Steuerspannung kleiner 12 V nicht mehr garantiert werden)
–
die Klemme wird bei wiederkehrender Steuerspannung automatisch reinitialisiert
▪
weitere Fehler (Misc Error, R0.15), folgende Fehler sind durch dieses Bit zusammengefasst:
–
Übertemperatur (Klemmeninnentemperatur über 100°C, Bit "Over Temperature" ist ebenfalls gesetzt),
–
Initialisierungsfehler (unlogische Registerkonfiguration vorhanden)
–
Überlast (nur bei aktiviertem R32.9, wird gleichzeitig mit R0.9 gesetzt)
Bei Auftreten eines Fehlers muss diese zunächst behoben und anschließend durch Setzen des Bits CB1.6 im Control-Byte quittiert und damit gelöscht werden.


Chopper-Betrieb

Grundlagen zur Funktion [image] Chopper-Betrieb
Chopper-Betrieb
Sie können an einem Kanal der KL2532/KL2552 anstelle eines DC-Motors einen Bremswiderstand (Chopper) anschließen und für diesen Kanal die Betriebsart Bremswiderstand (siehe KS2000 oder Register R33.0 - R33.3) aktivieren.
Für Positionierungsaufgaben muss der Motor aktiv bremsen. Dabei wird die mechanische Energie in elektrische Energie zurückgewandelt. Geringe Energiemengen werden von einem Kondensator in der KL2532/KL2552 aufgenommen. Weitere Speicherkapazitäten zum Beispiel im Netzteil können auch Energie aufnehmen. In jedem Fall führt die Rückspeisung zu einer Spannungserhöhung.
Zur Vermeidung von Überspannungen kann an die KL2532/KL2552 ein Bremswiderstand geschaltet werden um die überschüssige Energie in Form von Wärme abgeben zu können. Sobald die Spannung 110% der Nennspannung (Register R36 , z. B. 55 V für KL2552) erreicht, treibt die richtig eingestellte Endstufe einen schnell getakteten Strom durch den Bremswiderstand (siehe Diagramm).
Strom durch den Bremswiderstand
UCH /UN | 20% | 40% | 60% | 80% | 100% | 110% | 130% | 160%
UCH bei UN = 50 V | 10 V | 20 V | 30 V | 40 V | 50 V | 55 V | 65 V | 80 V
UCH bei UN = 24 V | 4,8 V | 9,6 V | 14,4 V | 19,2 V | 24 V | 25,2 V | 31,2 V | 38,4 V
Hinweis
Auslegung des Bremswiderstands
Der Bremswiderstand sollte so dimensioniert werden dass er die zu erwartende Wärmeentwicklung schadlos übersteht!
Für die KL2552 wird ein Bremswiderstand von 10 Ω Empfohlen, wodurch sich ein Pulsstrom von ca. 5,5 A bis 6,5 A ergibt. Die maximal zu erwartende Dauerleistung ist 125 W. Typisch liegt der Wert jedoch deutlich darunter.
Leistungsabschätzung (für KL2552)
PN = IN² x R
PN = (5A)² x 10 Ω
PN = 250 W
Es ist eine Einschaltdauer von maximal 50% möglich. Somit ergibt sich eine maximale Dauerleistung von 125 W.
In der Praxis ist ein Motorwirkungsgrad von 80% üblich.
Der Motor setzt also beim Beschleunigen 80% der elektrischen Nennleistung in Bewegungsenergie um.
Beim Bremsen setzt der Motor (als Generator) wiederum 80% der Bewegungsenergie in elektrische Leistung um.
So ergibt sich eine praktische Bremsleistung von:
PCH = PN/2 x 80/100 x 80/100
PCH = 125W x 80/100 x 80/100
PCH = 80 W


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Einbaulagen bei Betrieb mit und ohne Lüfter
•
Anschluss
•
UL Hinweise - Compact Motion
•
KL2532/KS2532 - Anschluss
•
KL2552-0000/KS2552-0000 - Anschluss
•
KL2552-0005/KS2552-0005 - Anschluss
•
KL2552 - Anwendungsbeispiel


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endklemme KL9010 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Einbaulagen bei Betrieb mit und ohne Lüfter

Montage und Verdrahtung [image] Einbaulagen bei Betrieb mit und ohne Lüfter
Einbaulagen bei Betrieb mit und ohne Lüfter
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Sorgen Sie bei der Montage der Klemmen dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Vorgeschriebene Einbaulage bei Betrieb ohne Lüfter
Für die vorgeschriebene Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände Einbaulage bei Betrieb ohne Lüfter“).
Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht.
Empfohlene Abstände Einbaulage bei Betrieb ohne Lüfter
Die Einhaltung der Abstände nach der obigen Abbildung wird dringend empfohlen!
Weitere Hinweise zum Betrieb ohne Lüfter sind ggf. den Technischen Daten der Klemme zu entnehmen.
Standard-Einbaulage bei Betrieb mit Lüfter
Für die Standard-Einbaulage beim Betrieb mit Lüfter wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Betrieb mit Lüfter“). Die Klemmen werden dabei unterstützend vom z. B. ZB8610 Lüftermodul von unten nach oben durchlüftet.
Empfohlene Abstände bei Betrieb mit Lüfter
Weitere Einbaulagen
Durch die verstärkende Wirkung auf die Kühlung der Klemmen durch den Lüfter sind ggf. weitere Einbaulagen zulässig (siehe Abb. „Weitere Einbaulagen, Beispiel 1 und 2“); entnehmen Sie entsprechende Hinweise bitte den Technischen Daten der Klemme.

Weitere Einbaulagen, Beispiel 1
Weitere Einbaulagen, Beispiel 2


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


UL Hinweise - Compact Motion

Montage und Verdrahtung [image] UL Hinweise - Compact Motion
UL Hinweise - Compact Motion
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
culus-logo
Notes on motion devices
•
Motor overtemperature
Motor overtemperature sensing is not provided by the drive.
•
Application for compact motion devices
The modules are intended for use only within Beckhoff’s Programmable Controller system Listed in File E172151.
•
Galvanic isolation from the supply
The modules are intended for operation within circuits not connected directly to the supply mains (galvanically isolated from the supply, i.e. on transformer secondary).
•
Requirement for environmental conditions
For use in Pollution Degree 2 Environment only.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


KL2532/KS2532 - Anschluss

Montage und Verdrahtung [image] KL2532/KS2532 - Anschluss
KL2532/KS2532 - Anschluss
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL2532/KS2532 Anschlussbelegung
Klemmstelle | Nr. | Anschluss für
A1 | 1 | Motor A, Anschluss A1
B1 | 2 | Motor B, Anschluss B1
24 V | 3 | z. B. Encoder-Versorgung (von positivem Powerkontakt)
Input 1 | 4 | Digitaler Eingang 1 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Wort das Bit CB.1 gesetzt ist und eine steigende Flanke am digitalen Eingang 1 auftritt.
A2 | 5 | Motor A, Anschluss A2
B2 | 6 | Motor B, Anschluss B2
0 V | 7 | z. B. Encoder-Versorgung (von negativem Powerkontakt)
Input 2 | 8 | Digitaler Eingang 2 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Wort das Bit CB.2 gesetzt ist und eine steigende Flanke am digitalen Eingang 2 auftritt.


KL2552-0000/KS2552-0000 - Anschluss

Montage und Verdrahtung [image] KL2552-0000/KS2552-0000 - Anschluss
KL2552-0000/KS2552-0000 - Anschluss
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschlussbelegung der KL2552/KS2552
Klemmstellen
Linker Gehäuseteil
Klemmstelle | Nr. | Anschluss für
Encoder A, A | 1 | Encoder A, Anschluss A
Encoder B, A | 2 | Encoder B, Anschluss A
Encoder Power +24 V | 3 | Encoder-Versorgung (von positivem Powerkontakt)
Input 1 | 4 | Digitaler Eingang 1 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Byte 1das Bit CB1.1 gesetzt ist und eine steigende Flanke am digitalen Eingang 1 auftritt.
Encoder A, B | 5 | Encoder A, Anschluss B
Encoder B, B | 6 | Encoder B, Anschluss B
Encoder Power 0 V | 7 | Encoder-Versorgung (von negativem Powerkontakt)
Input 2 | 8 | Digitaler Eingang 2 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Byte 2 das Bit CB2.1 gesetzt ist und eine steigende Flanke am digitalen Eingang 2 auftritt.
Rechter Gehäuseteil
Klemmstelle | Nr. | Anschluss für
Motor A, A1 | 1' | Motor A, Anschluss A1
Motor B, B1 | 2' | Motor B, Anschluss B1
Motor Power 50 V | 3' | Einspeisung für Motorversorgung (maximal +50 VDC)
Motor Power 50 V | 4' | Einspeisung für Motorversorgung (maximal +50 VDC)
Motor A, A2 | 5' | Motor A, Anschluss A2
Motor B, B2 | 6' | Motor B, Anschluss B2
Motor Power 0 V | 7' | Einspeisung für Motorversorgung (0 VDC)
Motor Power 0 V | 8' | Einspeisung für Motorversorgung (0 VDC)
Power-Kontakte
Die Spannung Up der Powerkontakte (+24 VDC) versorgt folgende Verbraucher:
▪
Inkremental-Encoder (Klemmstelle 3 und 7)
▪
digitale Eingänge (Klemmstelle 4 und 8)
▪
Ausgangstreiber der DC-Motor-Endstufe


KL2552-0005/KS2552-0005 - Anschluss

Montage und Verdrahtung [image] KL2552-0005/KS2552-0005 - Anschluss
KL2552-0005/KS2552-0005 - Anschluss
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschlussbelegung der KL2552-0005/KS2552-0005
Klemmstellen
Linker Gehäuseteil
Klemmstelle | Nr. | Anschluss für
Encoder A, A | 1 | Encoder A, Anschluss A
Encoder B, A | 2 | Encoder B, Anschluss A
Encoder Power +5 V | 3 | Encoder-Versorgung (über Schaltregler von positivem Powerkontakt)
Input 1 | 4 | Digitaler Eingang 1 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Byte 1 das Bit CB1.1 gesetzt ist und eine steigende Flanke am digitalen Eingang 1 auftritt.
Encoder A, B | 5 | Encoder A, Anschluss B
Encoder B, B | 6 | Encoder B, Anschluss B
Encoder Power 0 V | 7 | Encoder-Versorgung (über Schaltregler von negativem Powerkontakt)
Input 2 | 8 | Digitaler Eingang 2 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Byte 2 das Bit CB2.1 gesetzt ist und eine steigende Flanke am digitalen Eingang 2 auftritt.
Rechter Gehäuseteil
Klemmstelle | Nr. | Anschluss für
Motor A, A1 | 1' | Motor A, Anschluss A1
Motor B, B1 | 2' | Motor B, Anschluss B1
Motor Power 50 V | 3' | Einspeisung für Motorversorgung (maximal +50 VDC)
Motor Power 50 V | 4' | Einspeisung für Motorversorgung (maximal +50 VDC)
Motor A, A2 | 5' | Motor A, Anschluss A2
Motor B, B2 | 6' | Motor B, Anschluss B2
Motor Power 0 V | 7' | Einspeisung für Motorversorgung (0 VDC)
Motor Power 0 V | 8' | Einspeisung für Motorversorgung (0 VDC)
Power-Kontakte
Die Spannung Up der Powerkontakte (+24 VDC) versorgt folgende Verbraucher:
▪
Inkremental-Encoder (Klemmstelle 3 und 7)
▪
digitale Eingänge (Klemmstelle 4 und 8)
▪
Ausgangstreiber der DC-Motor-Endstufe


KL2552 - Anwendungsbeispiel

Montage und Verdrahtung [image] KL2552 - Anwendungsbeispiel
KL2552 - Anwendungsbeispiel
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Bremswiderstand
Der am Kanal 2 der zweiten KL2552 angeschlossene Bremswiderstand verheizt die Bremsenergie der an den anderen drei Kanälen angeschlossenen Motoren.
KL2552 Anwendungsbeispiel
Hinweis
Auslegung des Bremswiderstands
Der Bremswiderstand sollte so dimensioniert werden dass er die zu erwartende Wärmeentwicklung schadlos übersteht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Register
•
Einstellungen
•
Prozessdaten


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies
▪
ein Buskoppler für Ethernet BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine zweikanalige DC-Motor-Endstufe KL2552
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (im Beispiel Position 2).
KS2000-Baumzweige für Kanal 1 der KL2552
Für die KL2532 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL2552.
▪
Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL2552.
▪
ProcData zeigt die Prozessdaten der KL2552.


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register der KL2552 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Registeransicht in KS2000


Einstellungen

Konfigurations-Software KS2000 [image] Einstellungen
Einstellungen
Einstellungen zur Parametrierung der KL2552.
Einstellungen über KS2000
Betriebsart (R33.0 - R33.3)
Hier können Sie die Grundbetriebsart der Kanäle auswählen (Default: "Geschwindigkeit, direkt").
Es werden folgende Betriebsarten von der Klemme unterstützt:
▪
Geschwindigkeit, direkt
▪
Geschwindigkeitsregelung
▪
Bremswiderstand (Chopper)
Allgemein
Watchdog Timer aktiv (R32.2)
Hier können Sie den Watchdog deaktivieren (Default: aktiv). Wenn die DC-Motor-Endstufe bei aktivem Watchdog für 100 ms keine Prozessdaten von der Steuerung empfängt, löst der Watchdog aus und der Motor wird gestoppt.
Automatische Stromreduzierung aktiv (R32.10)
Hier können Sie die automatische Stromreduzierung aktivieren (Default: inaktiv).
Automatische Überlastabschaltung aktiv (R32.9)
Hier können Sie die automatische Überlastabschaltung aktivieren (Default: inaktiv).
Geschwindigkeitsregler
Kp-Faktor (R37 nur KL2552)
Hier können Sie den Kp-Faktor (proportionalen Teil) der internen Geschwindigkeitsregelung festlegen (Default: 0,1).
Ki-Faktor (R38 nur KL2552)
Hier können Sie den Ki-Faktor (integralen Teil) der internen Geschwindigkeitsregelung festlegen (Default: 0).
Inneres Fenster für I-Regler aktiv (R33.4, R39 nur KL2552)
Hier können Sie das innere Fenster des I-Reglers aktivieren (Default: inaktiv) und die Schwelle ab der das innere Fenster aktiviert wird (Default: 0 %).
Äußeres Fenster für I-Regler aktiv (R33.5, R40 nur KL2552)
Hier können Sie das äußere Fenster des I-Reglers aktivieren (Default: inaktiv) und die Schwelle bis zu der das innere Fenster aktiv ist (Default: 0 %).
Ka-Faktor (R54 nur KL2552)
Hier können Sie den Ka-Faktor (a-Teil) der internen Geschwindigkeitsregelung festlegen (Default: 0).
Kd-Faktor (R55 nur KL2552)
Hier können Sie den Kd-Faktor (differentielle Teil) der internen Geschwindigkeitsregelung festlegen (Default: 0).
Enkoder
Eingangsfilter aktiv (R32.12)
Hier können Sie die Eingangsfilter der Enkodereingänge deaktivieren (Default: aktiv).
Inkremente pro Umdrehung (R42 nur KL2552)
Hier können Sie Anzahl der Inkremente pro Umdrehung des angeschlossenen Enkoders festlegen (Default: 0).
Motordaten
Maximaler Spulenstrom (R34)
Hier können Sie den maximalen Spulenstrom des Motors angeben (Default: 8000 mA).
Reduzierter Spulenstrom (positive Drehrichtung) (R41)
Hier können Sie den reduzierten Spulenstrom des Motors angeben (Default: 5000 mA), siehe Beschreibung von Register R32.10, R41 und R45.
Schwelle für Stromreduzierung (positive Drehrichtung) (R45)
Hier können Sie die Schwelle ab der die automatische Stromreduzierung aktiviert wird angeben (Default: 100 %).
Reduzierter Spulenstrom (negative Drehrichtung) (R49)
Hier können Sie den reduzierten Spulenstrom des Motors angeben (Default: 5000 mA), siehe Beschreibung von Register R32.10, R49 und R48.
Schwelle für Stromreduzierung (negative Drehrichtung) (R48)
Hier können Sie die Schwelle ab der die automatische Stromreduzierung aktiviert wird angeben (Default: 100 %).
Nennstrom (R35)
Hier können Sie den Nennstrom des Motors angeben (Default: 5000 mA).
Nennspannung (R36)
Hier können Sie die Nennspannung des Motors angeben (Default: 50 V).
Nenndrehzahl (R43 nur KL2552)
Hier können Sie die Nenndrehzahl des Motors angeben (Default: 0 RPM).
Innenwiderstand des Motors (R44)
Hier können Sie den Innenwiderstand des Motors angeben (Default: 0 Ohm).
Zeitkonstante für Stromreduzierung (R46)
Hier können Sie die Zeitdauer der Stromreduzierung angeben (Default: 2000 ms).
Zeit für Überlastabschaltung (R47)
Hier können Sie die Zeit angeben nach der die Endstufe abgeschaltet wird, wenn sie über den gesamten Zeitraum mit Überlast fährt (Default: 200 ms).


Prozessdaten

Konfigurations-Software KS2000 [image] Prozessdaten
Prozessdaten
Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.
Feld Prozessdaten
Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.
Feld Verlauf
Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.
Feld Wert für Eingangsdaten
Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.
Feld Wert für Ausgangsdaten
SmallWarningYellow VORSICHT
Gefahr für Personen, Umwelt oder Geräte!
Beachten Sie, das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann.
Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, das Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.
Einstellungen


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Bytes
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Komplexes Prozessabbild
Die KL2532/KL2552 stellt sich im komplexen Prozessabbild mit mindestens 6 Byte Ein- und 6 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | SB1 | CB1
1 | 2 | Wort | DataIN1 | DataOUT1
3 | 4 | Byte | SB2 | CB2
4 | 6 | Wort | DataIN2 | DataOUT2
*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen
Legende
SB n: Status-Byte des Kanals n
CB n: Control-Byte des Kanals n
DataIN n: Eingangswort des Kanals n
DataOUT n: Ausgangswort des Kanals n
Komplexes Prozessabbild
Ein Betrieb der KL2532/KL2552 ohne Control-Bytes ist nicht möglich, da die Control-Bytes für die Freigabe der Kanäle erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen, wird die KL2532/KL2552 mit ihrem Control-Bytes dargestellt!


Control- und Status-Bytes

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Bytes
Control- und Status-Bytes
Kanal 1
Prozessdatenbetrieb
Control-Byte 1 (bei Prozessdatenbetrieb)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reset | Enable | GetLatchData | enLatch FallEdge | enLatch RiseEdge | SetCounter | Reduced Torque
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB1.6 | Reset | 1bin | alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke)
CB1.5 | Enable | 1bin | Schaltet den Kanal 1 frei
CB1.4 | GetLatchData | 0bin | die aktuelle Position in die Eingangsprozessdaten einblenden
 |  | 1bin | den aktuellen Latch-Wert in die Eingangsprozessdaten einblenden
CB1.3 | enLatch FallEdge | 1bin | externes Latch-Ereignis ist freigeschaltet (bei fallender Flanke des Latch-Eingangs speichert die Klemme die aktuelle Position)
CB1.2 | enLatch RiseEdge | 1bin | externes Latch-Ereignis ist freigeschaltet (bei steigender Flanke des Latch-Eingangs speichert die Klemme die aktuelle Position) ACHTUNG: höhere Priorität als CB1.3!
CB1.1 | SetCounter | 1bin | Bei einer steigenden Flanke von CB1.1 wird der Zähler auf den durch Register R5 spezifizierten Wert gesetzt.
CB1.0 | Reduced Torque | 1bin | reduziertes Drehmoment (Spulenstrom) ist aktiv (vorgegeben durch R41)
Status-Byte 1 (bei Prozessdatenbetrieb)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Warning | Ready | LatchData | LatchValid | SetCounter Ready/ Reduced Torque Ready | Input E1
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB1.6 | Error | 1bin | ein Fehler ist aufgetreten (wird explizit im Statuswort in Register R0 angezeigt)
SB1.5 | Warning | 1bin | ein Warnung ist aufgetreten (wird explizit im Statuswort in Register R0 angezeigt)
SB1.4 | Ready | 0bin | Motoransteuerung ist gesperrt oder es liegt ein Fehler vor (SB.6=1)
 |  | 1bin | Motoransteuerung ist frei geschaltet und es ist kein Fehler aufgetreten (Quittung für Enable, SB.6=0)
SB1.3 | LatchData | 0bin | die aktuelle Position ist in den Eingangsprozessdaten eingeblendet
 |  | 1bin | der letzte Latch-Wert ist in den Eingangsprozessdaten eingeblendet, wenn ein gültiger Latch-Wert vorhanden ist (Quittung für GetLatchData)
SB1.2 | LatchValid | 1bin | ein Latchereignis ist eingetreten (bei CB1.2=1 oder CB1.3=1)
SB1.1 | SetCounter Ready/ Reduced Torque Ready | 1bin | - die Zähler wurde gesetzt (Quittung für SetCounter) oder - das reduzierte Drehmoment ist aktiv (Quittung für Reduced Torque)
SB1.0 | Input E1 | Status des Eingangs E1
Registerkommunikation
Control-Byte 1 (bei Registerkommunikation)
Das Control-Byte 1 (CB1) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
CB1.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB1.6 | R/W | 0bin | Lesezugriff
 |  | 1bin | Schreibzugriff
CB1.5 bis CB1.0 | Reg-Nr. | Registernummer: Tragen Sie hier die Nummer des Registers ein, das Sie - mit dem Eingangsdatenwort DataIn lesen oder - mit dem Ausgangsdatenwort DataOut beschreiben wollen.
Status-Byte 1 (bei Registerkommunikation)
Das Status-Byte 1 (SB1) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB1.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB1.6 | R | 0bin | Lesezugriff
SB1.5 bis SB1.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.
Kanal 2
Control- und Status-Byte des Kanals 2 (CB2 und SB2) sind wie Control- und Status-Byte des Kanals 1 aufgebaut.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der DC-Motor-Endstufen. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden und sind für jeden Kanal der Klemme einmal vorhanden.
Register-Nr. | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | Statuswort |  | 0x0000 | 0dez | R | RAM
R1 | Auswahl für Messwert 1 (Low-Byte) und Messwert 2 (High-Byte) | Kanal 1 | 0x0602 | 1538dez | R/W | RAM
 |  | Kanal 2 | 0x0703 | 1795dez | R/W | RAM
R2 | Messwert 1 |  | z. B. 0x0000 | z. B. 0dez | R | RAM
R3 | Messwert 2 |  | z. B. 0x0000 | z. B. 0dez | R | RAM
R4* | Auswahl der Registerpage |  | 0x0000 | 0dez | R/W | RAM
R5 | Zählervorgabe-Register |  | 0x0000 | 0dez | R/W | RAM
R6 | Status-Byte |  | z. B. 0x0010 | z. B. 16dez | R | RAM
R7 | Kommando-Register |  | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | KL2532/KS2532 | 0x09E4 | 2532dez | R | ROM
 |  | KL2552/KS2552 | 0x09F8 | 2552dez
R9 | Firmware-Stand |  | z. B. 0x3141 | z. B. 1AASCII | R | ROM
R10 | Multiplex-Schieberegister |  | 0x0130 | 304dez | R | ROM
R11 | Signalkanäle |  | 0x0218 | 536dez | R | ROM
R12 | minimale Datenlänge |  | 0x1818 | 6168dez | R | ROM
R13 | Datenstruktur |  | 0x0004 | 4dez | R | ROM
R14 | reserviert |  | - | - | - | -
R15 | Alignment-Register |  | z. B. 0x7F80 | z. B. 32640dez | R/W | RAM
R16 | Hardware-Versionsnummer |  | z. B. 0x0000 | z. B. 0dez | R/W | EEPROM
R17 | Zwischenkreisfrequenz |  | z. B. 0x7D00 | z. B. 32000dez | R | EEPROM
R18 | PWM-Totzeit | KL2532/KS2532 | z. B. 0x0102 | z. B. 258dez | R | EEPROM
 |  | KL2552/KS2552 | z. B. 0x0604 | z. B. 1540 | R | EEPROM
R19 | Dutycycle-Begrenzung |  | z. B. 0x0004 | z. B. 4dez | R | EEPROM
R20 | Temperaturschwellen |  | z. B. 0x5064 | z. B. 20580dez | R | EEPROM
R21 | Sample-Zeitpunkt des A/D-Converters |  | z. B. 0x000A | z. B. 10dez | R | EEPROM
R22 | reserviert |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R30 | reserviert |  | - | - | - | -
R31 | Kodewort-Register |  | 0x0000 | 0dez | R/W | RAM
*) Diese Register werden nur von der KL2552 unterstützt, nicht von von der KL2532
Registerpage 0
Register-Nr. |  | Kommentar |  | Default-Wert |  | R/W | Speicher
R32 |  | Feature-Register 1 |  | 0x0000 | 0dez | R/W | EEPROM
R33 |  | Feature-Register 2 |  | 0x0000 | 0dez | R/W | EEPROM
R34 |  | maximaler, dauerhafter Spulenstrom des Motors | KL2532/KS2532 | 0x09C4 | 2500dez | R/W | EEPROM
 |  |  | KL2552/KS2552 | 0x1F40 | 8000dez | R/W | EEPROM
R35 |  | Nennstrom des Motors | KL2532/KS2532 | 0x05DC | 1500dez | R/W | EEPROM
 |  |  | KL2552/KS2552 | 0x1388 | 5000dez | R/W | EEPROM
R36 |  | Nennspannung (Versorgungsspannung) des Motors | KL2532/KS2532 | 0x5DC0 | 24000dez | R/W | EEPROM
 |  |  | KL2552/KS2552 | 0xC350 | 50000dez | R/W | EEPROM
R37* |  | Kp-Faktor (Geschwindigkeitsregler) |  | 0x0064 | 100dez | R/W | EEPROM
R38* |  | Ki-Faktor (Geschwindigkeitsregler) |  | 0x0000 | 0dez | R/W | EEPROM
R39* |  | inneres Fenster des I-Anteils (Geschwindigkeitsregler) |  | 0x0000 | 0dez | R/W | EEPROM
R40* |  | äußeres Fenster des I-Anteils (Geschwindigkeitsregler) |  | 0x0000 | 0dez | R/W | EEPROM
R41 |  | reduziertes Drehmoment (Spulenstrom in positiver Drehrichtung) | KL2532/KS2532 | 0x05DC | 1500dez | R/W | EEPROM
 |  |  | KL2552/KS2552 | 0x09C4 | 2500dez | R/W | EEPROM
R42* |  | Encoder-Inkremente |  | 0x0000 | 0dez | R/W | EEPROM
R43* |  | Nenndrehzahl des Motors bei Nennspannung |  | 0x0000 | 0dez | R/W | EEPROM
R44 |  | Innenwiderstand des Motors |  | 0x0000 | 0dez | R/W | EEPROM
R45 |  | Schwelle für automatische Drehmomentreduzierung (in positiver Drehrichtung) |  | 0x0064 | 100dez | R/W | EEPROM
R46 | Zeit für Stromabsenkung bei Überlast |  |  | 0x07D0 | 2000dez | R/W | EEPROM
R47 | Zeit für Abschaltung bei Überlast |  |  | 0x00C8 | 200dez | R/W | EEPROM
R48 | Schwelle für automatische Drehmomentreduzierung (in negativer Drehrichtung) |  |  | 0x0064 | 100dez | R/W | EEPROM
R49 | reduziertes Drehmoment (Spulenstrom in negativer Drehrichtung) |  | KL2532/KS2532 | 0x05DC | 1500dez | R/W | EEPROM
 |  |  | KL2552/KS2552 | 0x09C4 | 2500dez | R/W | EEPROM
R50* | Kp-Faktor (Stromregler) |  |  | 0x0190 | 400dez | R/W | EEPROM
R51* | Ki-Faktor (Stromregler) |  |  | 0x0004 | 4dez | R/W | EEPROM
R52 | inneres Fenster des I-Anteils (Stromregler) |  |  | 0x0000 | 0dez | R/W | EEPROM
R53 | äußeres Fenster des I-Anteils (Stromregler) |  |  | 0x0000 | 0dez | R/W | EEPROM
R54* | Ka-Faktor (Geschwingikeitsregler) |  |  | 0x0000 | 0dez | R/W | EEPROM
R55* | Kd-Faktor (Geschwingikeitsregler) |  |  | 0x0000 | 0dez | R/W | EEPROM
R56 | reserviert |  |  | - | - | - | -
R63 | reserviert |  |  | - | - | - | -
*) Diese Register werden nur von der KL2552 unterstützt, nicht von von der KL2532
Registerpage 1 (nur KL2552, ab Firmware-Version 1M)
(siehe auch Auswahl für Messwert 1 und Messwert 2)
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R32 | internes Statuswort Kanal 1 | 0x0000 | 0dez | R | RAM
R33 | internes Statuswort Kanal 2 | 0x0000 | 0dez | R | RAM
R34 | Spannung der Motorspule Kanal 1 (Einheit: 1 mV) | 0x0000 | 0dez | R | RAM
R35 | Spannung der Motorspule Kanal 2 (Einheit: 1 mV) | 0x0000 | 0dez | R | RAM
R36 | Versorgungsspannung des Motors (Einheit: 1 mV) | 0x0000 | 0dez | R | RAM
R37 | Steuerspannung (Powerkontakte) (Einheit: 1 mV) | 0x0000 | 0dez | R | RAM
R38 | Strom der Motorspule Kanal 1 (Einheit: 1 mA) | 0x0000 | 0dez | R | RAM
R39 | Strom der Motorspule Kanal 2 (Einheit: 1 mA) | 0x0000 | 0dez | R | RAM
R40 | Innentemperatur der Treiberstufe (Einheit: 1°C) | 0x0000 | 0dez | R | RAM
R41 | Dutycycle Kanal 1 (Einheit: 1%) | 0x0000 | 0dez | R | RAM
R42 | Dutycycle Kanal 2 (Einheit: 1%) | 0x0000 | 0dez | R | RAM
R43 | Regelfehler Kanal 1 (Einheit: 1 Digit) | 0x0000 | 0dez | R | RAM
R44 | Regelfehler Kanal 2 (Einheit: 1 Digit) | 0x0000 | 0dez | R | RAM
R45 | Strombegrenzung Kanal 1 (Einheit: 1 mA) | 0x0000 | 0dez | R | RAM
R46 | Strombegrenzung Kanal 2 (Einheit: 1 mA) | 0x0000 | 0dez | R | RAM
R47 | Strom der Motorspule Kanal 1 (Betrag), (Einheit: 1 mA) | 0x0000 | 0dez | R | RAM
R48 | Strom der Motorspule Kanal 2 (Betrag), (Einheit: 1 mA) | 0x0000 | 0dez | R | RAM
R49 | Strom der Motorspule Kanal 1 (Mittelwert des Betrages), (Einheit: 1 mA) | 0x0000 | 0dez | R | RAM
R50 | Strom der Motorspule Kanal 2 (Mittelwert des Betrages), (Einheit: 1 mA) | 0x0000 | 0dez | R | RAM
R51 | Strom-Offset der Motorspule Kanal 1 (Abgleich), (Einheit: 1 Digit) | 0x0000 | 0dez | R | RAM
R52 | Strom-Offset der Motorspule Kanal 2 (Abgleich), (Einheit: 1 Digit) | 0x0000 | 0dez | R | RAM
R53 | Dauer der Überlast Kanal 1 (Einheit: 1 ms) | 0x0000 | 0dez | R | RAM
R54 | Dauer der Überlast Kanal 2 (Einheit: 1 ms) | 0x0000 | 0dez | R | RAM
R55 | Reserviert | - | - | - | -
R62 | reserviert | - | - | - | -
R63 | Firmware-Stand der Treiberkarte | - | - | - | ROM


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die Register dienen zur Parametrierung der DC-Motor-Endstufen. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden und sind für jeden Kanal der Klemme einmal vorhanden.
R0: Statuswort
Das Statuswort beinhaltet Informationen über interne Zustände und gibt Auskunft über aufgetretene Warnungen bzw. Fehler (siehe "Grundlagen zur Funktion" und "Status-Byte")
Bit | R0.15 | R0.14 | R0.13 | R0.12 | R0.11 | R0.10 | R0.9 | R0.8
Name | Misc Error | No Control Power | - | Short Circuit | Over Voltage | Under Voltage | Over Current | Over Temperature
Bit | R0.7 | R0.6 | R0.5 | R0.4 | R0.3 | R0.2 | R0.1 | R0.0
Name | - | Saturated | Moving Negative | Moving Positive | Ready | Ready to Enable | - | -
Legende
Bit
Name
Reaktion
Beschreibung
R0.15
Misc Error
Fehler
1bin
Fehler aufgetreten
R0.14
No Control Power
Fehler
1bin
Steuerspannung an den Powerkontakten kleiner als 12 V
R0.13
-
reserviert
R0.12
Short Circuit
Fehler
1bin
Kurzschluss der Treiberstufe
R0.11
Over Voltage
Warnung
1bin
Versorgungsspannung 10% größer als in R36 vorgegeben
R0.10
Under Voltage
Warnung
1bin
▪
Versorgungsspannung 80% kleiner als in Register R36 vorgegeben (Warnung)
▪
Versorgungsspannung kleiner als 8 V (Fehler, zusätzlich werden Register R0.15 und Bit SB1.6 des Status-Registers gesetzt sowie beide Kanäle deaktiviert)
R0.9
Over Current
Warnung
1bin
Seit der in Register R47 spezifizierten Zeit ist der aktuelle Strom größer als der Nennstrom.
R0.8
Over Temperature
Warnung
1bin
▪
Innentemperatur der Klemme ist größer als 80°C (Warnung)
▪
Innentemperatur der Klemme ist größer als 100°C (Fehler, zusätzlich werden Register R0.15 und Bit SB1.6 des Satus-Bytes gesetzt sowie beide Kanäle deaktiviert)
R0.7
-
reserviert
R0.6
Saturated
Warnung
1bin
Treiberstufe ist in der Sättigung (max. Ausgabewert erreicht)
R0.5
Moving Negative
1bin
Treiberstufe wird in negativer Richtung angesteuert
R0.4
Moving Positive
1bin
Treiberstufe wird in positiver Richtung angesteuert
R0.3
Ready
1bin
Treiberstufe ist aktiviert
R0.2
Ready to Enable
1bin
Treiberstufe bereit zum aktivieren
R0.0 - R0.1
-
reserviert
R1: Auswahl für Messwert 1 und Messwert 2
Hier wird die Vorauswahl der in R2 und R3 angezeigten Messwerte getroffen. Hierbei ist das untere Byte dem Register 2 und das obere Byte dem Register 3 zugeordnet.
Beispiel: R1 = 0x0602, unteres Byte = 2 (Spannung der Motorspule Kanal 1), oberes Byte = 6 (Strom der Motorspule Kanal 1).
Jeder einzelne Wert kann in Kanal 1 und Kanal 2 angezeigt werden.
Die angezeigten Werte ergeben sich nach dieser Tabelle:
Auswahl | Bezeichnung | Einheit
0 | internes Statuswort Kanal 1 | -
1 | internes Statuswort Kanal 2 | -
2 | Spannung der Motorspule Kanal 1 | 1 mV
3 | Spannung der Motorspule Kanal 2
4 | Versorgungsspannung des Motors
5 | Steuerspannung (Powerkontakte)
6 | Strom der Motorspule Kanal 1 | 1 mA
7 | Strom der Motorspule Kanal 2
8 | Innentemperatur der Treiberstufe | 1°C
9 | Dutycycle Kanal 1 | 1%
10 | Dutycycle Kanal 2
11 | Regelfehler Kanal 1 | 1 Digit
12 | Regelfehler Kanal 2
13 | Strombegrenzung Kanal 1 | 1 mA
14 | Strombegrenzung Kanal 2
15 | reserviert | -
... | reserviert | -
254 | reserviert | -
255 | Firmware-Stand der Treiberkarte | -
R2: Messwert 1
Hier wird der Messwert 1 ausgegeben (siehe R1).
R3: Messwert 2
Hier wird der Messwert 2 ausgegeben (siehe R1).
R4: Auswahl der Register-Page (nur KL2552, ab Firmware-Version 1M)
Dieses Register legt fest, welche Register-Page in den Registern R32 to R63 angezeigt wird (default: 0x0000).
Die Klemme unterstützt zwei Registerpages.
▪
Registerpage 0 wird genutzt, um die Konfigurationsdaten zu speichern (siehe ab Register R32)
▪
Registerpage 1 wird genutzt, um interne Messwerte auszulesen (zusätzlicher Mechanismus zum Auslesen der Messwerte über Register R2 und R3)
R5: Zählervorgabe-Register
Hier können Sie den Wert vorgeben, auf den der Zähler bei einer steigenden Flanke von CB1.1 (SetCounter) gesetzt wird.
R6: Status-Byte
Hier wird zusätzlich das Status-Byte des jeweiligen Kanals eingeblendet.
R7: Kommando-Register
Anwender-Kodewort
Um die folgenden Kommandos auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein!
Kommando 0x7000: Restore Factory Settings
KL2532
Mit dem Eintrag 0x7000 in Register R7 werden die folgenden Register beider Kanäle auf die nebenstehenden Standardwerte gesetzt:
R32: 0dez
R33: 0dez
R34: 2500dez
R35: 1500dez
R36: 24000dez
R41: 1500dez
R44: 0dez
R45: 100dez
R46: 2000dez
R47: 200dez
R48: 100dez
R49: 1500dez
R50: 400dez
R51: 4dez
R52: 0dez
R53: 0dez
KL2552
Mit dem Eintrag 0x7000 in Register R7 werden die folgenden Register beider Kanäle auf die nebenstehenden Standardwerte gesetzt:
R32: 0dez
R33: 0dez
R34: 5000dez
R35: 1000dez
R36: 50000dez
R37: 100dez
R38: 0dez
R39: 0dez
R40: 0dez
R41: 2500dez
R42: 0dez
R43: 0dez
R44: 0dez
R45: 100dez
R46: 2000dez
R47: 200dez
R48: 100dez
R49: 2500dez
R50: 400dez
R51: 4dez
R52: 0dez
R53: 0dez
R54: 0dez
R55: 0dez
Restore Factory Settings setzt beide Kanäle zurück
Das Kommando Restore Factory Settings setzt beide Kanäle der DC-Motor-Endstufenklemme gleichzeitig zurück auf ihre Standardwerte, egal aus welchem Registersatz heraus es aufgerufen wird!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Der Motor wird bei diesem Kommando stromlos geschaltet. Stellen Sie sicher, dass ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
Kommando 0x8000: Software Reset
Mit dem Eintrag 0x8000 in Register R7 wird ein vollständiger Software-Reset der Klemme durchgeführt. Alle internen Variablen (Positionen, Latch-Werte, Fehler, usw.) werden gelöscht bzw. auf definierte Werte gesetzt, die aus dem EEPROM gelesen werden. Die internen Schaltkreise (ADC, Ausgangstreiber) werden bei einem Software-Reset neu initialisiert.
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Während eines Software-Resets wird der Motor stromlos geschaltet. Stellen Sie sicher, dass ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
R8: Klemmentyp
Im Register R8 steht die Bezeichnung der Klemme: 0x09F8 (2552dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R17: Zwischenkreisfrequenz
Dies ist ein Hersteller-Register und kann vom Anwender nicht verändert werden.
Hier wird die Frequenz des Zwischenkreises konfiguriert.
R18: PWM-Totzeit
Dies ist ein Hersteller-Register und kann vom Anwender nicht verändert werden.
Hier wird die Totzeit der Highside- und Lowside-Transistoren konfiguriert.
R19: Dutycycle-Begrenzung
Dies ist ein Hersteller-Register und kann vom Anwender nicht verändert werden.
Hier wird der minimale und der maximale Dutycycle bezogen auf die Zwischenkreisfrequenz konfiguriert.
R20: Temperaturschwellen
Dies ist ein Hersteller-Register und kann vom Anwender nicht verändert werden.
Hier werden die Temperaturschwellen zur Bewertung der Innentemperatur der Treiberstufe konfiguriert (Warnungsausgabe/Abschalten der Treiberstufe).
R21: Sample-Zeitpunkt des A/D-Converters
Dies ist ein Hersteller-Register und kann vom Anwender nicht verändert werden.
Hier wird Sample-Zeitpunkt bezogen auf den Dutycycle konfiguriert.
R31: Kodewort-Register
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen. Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.
Registerpage 0
Registerpage 0 wird genutzt, um die Konfigurationsdaten zu speichern.
R32: Feature-Register 1
Das Feature-Register 1 legt die Konfiguration der Klemme fest.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | disEncoder Filter | - | enAutoReduce | enOverCurrentError | -
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | - | - | disWatchdog | - | -
Legende
Bit | Name | Beschreibung |  | default
R32.13 - R32.15 | - | reserviert
R32.12 | disEncoder Filter | 1bin | Eingangsfilter für Encoder-Signale deaktiviert | 0bin
R32.11 | - | reserviert
R32.10 | enAutoReduce | 0bin | Drehmoment kann manuell mit Bit CB1.0 abgesenkt werden (siehe auch R40, R49) | 0bin
 |  | 1bin | Drehmoment wird automatisch abgesenkt (siehe auch R41, R45 bzw. R49, R48)
R32.9 | enOverCurrentError | 0bin | Überlast (R0.9 = 1) erzeugt eine Warnung (SB1.5) | 0bin
 |  | 1bin | Überlast (R0.9 = 1) erzeugt einen Fehler (SB1.6) und der Kanal wird deaktiviert
R32.3 - R32.8 | - | reserviert
R32.2 | disWatchdog | 1bin | interner 100 ms Watchdog deaktiviert | 0bin
R32.0 - R32.1 | - | reserviert
R33: Feature-Register 2
Das Feature-Register 2 legt die Konfiguration der Klemme fest.
Bit | R33.15 | R33.14 | R33.13 | R33.12 | R33.11 | R33.10 | R33.9 | R33.8
Name | - | - | - | - | - | - | - | -
Bit | R33.7 | R33.6 | R33.5 | R33.4 | R33.3 | R33.2 | R33.1 | R33.0
Name | - | - | enOuter Window | enInner Window | Operation Mode
Legende
Bit | Name | Beschreibung |  |  | default
R33.6 - R33.15 | - | reserviert
R33.5* | enOuter Window | 1bin | äußeres Fenster des I-Anteils der internen Geschwindigkeitsregelung aktiv |  | 0bin
R33.4* | enInner Window | 1bin | inneres Fenster des I-Anteils der internen Geschwindigkeitsregelung aktiv |  | 0bin
R33.0 - R33.3 | Operation Mode | 0dez | DIRECT MODE | direkte Ansteuerung des Dutycycles proportional zu den Prozessdaten | 0dez
 |  | 1dez | VELOCITY MODE | Vorgabe der Sollgeschwindigkeit über die Prozessdaten proportional zur eingestellten Nenndrehzahl in R43
 |  | 3dez | reserviert
 |  | 14dez | reserviert
 |  | 15dez | CHOPPER MODE | vorhandene Überspannung (10 % > Nennspannung R36) wird über angeschlossenem Chopper-Widerstand abgebaut
*) Diese Einstellungen werden nur von der KL2552 unterstützt, nicht von der KL2532
R34: maximaler, dauerhafter Spulenstrom des Motors
Dieses Register legt den vom Motorhersteller angegebenen maximalen, dauerhaften Spulenstrom des Motors fest.
KL2532/KS2532: Default: 2500dez, Wertebereich: 0 - 2500 mA
KL2552/KS2552: Default: 8000dez, Wertebereich: 0 - 8000 mA
Die Einheit ist 0,001 A (Beispiel: 2500dez = 2,5 A).
R35: Nennstrom des Motors
Dieses Register legt den vom Motorhersteller angegebenen Nennstrom des Motors fest.
KL2532/KS2532: Default: 1500dez, Wertebereich: 0 - 1500 mA
KL2552/KS2552: Default: 5000dez, Wertebereich: 0 - 5000 mA
Die Einheit ist 0,001 A (Beispiel: 1500dez = 1,5 A).
R36: Nennspannung (Versorgungsspannung) des Motors
Steigt die Versorgungsspannung durch Rückspeisung über die eingestellte Spannung, wird bei aktivierter Chopper-Funktion (siehe R33) der jeweilige Kanal (Chopper-Widerstand muss angeschlossen sein) voll aufgesteuert und die Überspannung abgebaut.
KL2532/KS2532: Default: 24000dez, Wertebereich: 0 V - 24 V
KL2552/KS2552: Default: 50000dez, Wertebereich: 0 V - 50 V
Die Einheit ist 0,001 V (Beispiel: 24000dez => 24 V).
R37: Kp-Faktor (Geschwindigkeitsregler, nur KL2552)
Dieses Register beinhaltet den Kp-Faktor des proportionalen Anteils der internen Geschwindigkeitsregelung (Default: 100dez).
Die Einheit ist 0,001 (Beispiel: 1000dez => Kp = 1,00). Wertebereich: 0 - 65535
R38: Ki-Faktor (Geschwindigkeitsregler, nur KL2552)
Dieses Register beinhaltet den Ki-Faktor des integralen Anteils der internen Geschwindigkeitsregelung (Default: 0dez).
Die Einheit ist 0,001 (Beispiel: 1000dez => Ki = 1,00). Wertebereich: 0 - 65535
R39: inneres Fenster des I-Anteils (nur KL2552)
Der I-Anteil der Geschwindigkeitsregelung wird zum Nullpunkt hin linear abgeschwächt (Default: 0dez). Dieses Register gibt den Wert an, ab der die Abschwächung aktiviert wird (Default: 0dez).
Die Einheit ist 1% (Beispiel: 1 = 1%). Wertebereich: 0% - 100 %
R40: äußeres Fenster des I-Anteils (nur KL2552)
Dieses Register gibt den größten Wert an, den der I-Anteil annehmen kann (Default: 0dez).
Die Einheit ist 1% (Beispiel: 5dez = 5%). Wertebereich: 0% - 100 %
R41: reduziertes Drehmoment (Spulenstrom in positiver Drehrichtung)
Dieses Register beinhaltet das reduzierte Drehmoment (Spulenstrom) in positiver Drehrichtung. Es wird durch CB1.0 aktiviert.
KL2532/KS2532: Default: 1500dez, Wertebereich: 0 mA - 1500 mA
KL2552/KS2552: Default: 2500dez, Wertebereich: 0 mA - 5000 mA
Die Einheit ist 0,001 A (Beispiel: 500dez = 0,5 A).
R42: Encoder-Inkremente (nur KL2552)
Dieses Register beinhaltet die Anzahl der Inkremente des Encoders pro Motorumdrehung (Default: 0dez).
Wertebereich: 0 - 65535
R43: Nenndrehzahl des Motors bei Nennspannung (nur KL2552)
Dieses Register beinhaltet die Nenndrehzahl des Motors bei Nennspannung (Default: 0dez).
Die Einheit ist 1 RPM (Umdrehungen pro Minute). Wertebereich: 0 - 65535 RPM
R44: Innenwiderstand des Motors
Dieses Register beinhaltet den Innenwiderstandes des Motors (Default: 0dez).
Die Einheit ist 0,01 Ohm (Beispiel: 206dez = 2,06 Ohm). Wertebereich: 0 Ohm - 655,35 Ohm
R45: Schwelle für automatische Drehmomentreduzierung (in positiver Drehrichtung)
Dieses Register beinhaltet die Schwelle (positive Drehrichtung), ab der die automatische Drehmomentreduzierung aktiviert wird (R41) (Default: 100dez). Die Deaktivierung geschieht mit einer Hysterese von ca. 2% bezogen auf Vollansteuerung (65 Digit).
Die Einheit ist 1% (Beispiel: 5dez = 5%). Wertebereich: 0% - 100%
R46: Zeit zur Stromabsenkung bei Überlast
Dieses Register beinhaltet die Zeit, in der der Motorstrom vom Maximalstrom auf den Nennstrom abgesenkt wird. Dies geschieht nach einer I²t-Funktion, d.h. dass das Verhalten nicht linear ist. Je nach aktuellem Motorstrom dauert das Erreichen des Nennstromes länger als die eingestellte Zeit (Default: 2000dez).
Die Einheit ist 1 ms (Beispiel: 2000dez = 2000 ms). Wertebereich: 1 ms - 65535 ms (werden 0 ms konfiguriert, verwendet die Klemme den Defaultwert von 2000 ms)
R47: Zeit zur Abschaltung bei Überlast
Dieses Register beinhaltet die Zeit, nach der die Endstufe abgeschaltet wird, wenn sie über den gesamten Zeitraum mit Überlast fährt. (Default: 200dez).
Die Einheit ist 1 ms (Beispiel: 200dez = 200 ms). Wertebereich: 0 ms - 65535 ms
R48: Schwelle für automatische Drehmomentreduzierung (in negativer Drehrichtung)
Dieses Register beinhaltet die Schwelle (negative Drehrichtung), ab der die automatische Drehmomentreduzierung aktiviert wird (R49) (Default: 100dez). Die Deaktivierung geschieht mit einer Hysterese von ca. 2% bezogen auf Vollansteuerung (65 Digit).
Die Einheit ist 1% (Beispiel: 5dez = 5%). Wertebereich: 0% - 100%
R49: reduziertes Drehmoment (Spulenstrom in negativer Drehrichtung)
Dieses Register beinhaltet das reduzierte Drehmoment (Spulenstrom) in negativer Drehrichtung. Es wird durch CB1.0 aktiviert.
KL2532/KS2532: Default: 1500dez, Wertebereich: 0 mA - 1500 mA
KL2552/KS2552: Default: 2500dez, Wertebereich: 0 mA - 5000 mA
Die Einheit ist 0,001 A (Beispiel: 500dez = 0,5 A).
R50: Kp-Faktor (Stromregler, nur KL2552)
Dieses Register beinhaltet den Kp-Faktor des proportionalen Anteils der internen Stromregelung (Default: 400dez).
Die Einheit ist 0,001 (Beispiel: 1000dez => Kp = 1,00). Wertebereich: 0 - 65535
R51: Ki-Faktor (Stromregler, nur KL2552)
Dieses Register beinhaltet den Ki-Faktor des integralen Anteils der internen Stromregelung (Default: 4dez).
Die Einheit ist 0,001 (Beispiel: 1000dez => Ki = 1,00). Wertebereich: 0 - 65535
R52: inneres Fenster des I-Anteils (Stromregler)
Der I-Anteil der Geschwindigkeitsregelung wird zum Nullpunkt hin linear abgeschwächt (Default: 0dez). Dieses Register gibt den Wert an, ab der die Abschwächung aktiviert wird (Default: 0dez).
Die Einheit ist 1% (Beispiel: 1 = 1%). Wertebereich: 0% - 100%
R53: äußeres Fenster des I-Anteils (Stromregler)
Dieses Register gibt den größten Wert an, den der I-Anteil annehmen kann (Default: 0dez).
Die Einheit ist 1% (Beispiel: 5dez = 5%). Wertebereich: 0% - 100%
R54: Ka-Faktor (Geschwindigkeitsregler, nur KL2552)
Dieses Register beinhaltet den Ka-Faktor des dynamischen Anteils der internen Geschwindigkeitsregelung (Default: 0dez).
Die Einheit ist 0,001 (Beispiel: 1000dez => Ka = 1,00). Wertebereich: 0 - 65535
R55: Kd-Faktor (Geschwindigkeitsregler, nur KL2552)
Dieses Register beinhaltet den Kd-Faktor des differentiellen Anteils der internen Geschwindigkeitsregelung (Default: 0dez).
Die Einheit ist 0,1 (Beispiel: 10dez => Kd = 1,00). Wertebereich: 0 - 65535
Registerpage 1 (nur KL2552, ab Firmware-Version 1M)
Registerpage 1 wird genutzt, um interne Messwerte auszulesen.
Siehe Registerübersicht


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.