KL2531, KL2541 - Einkanalige Schrittmotorklemmen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.1.0
▪
Einführung für KL2541 aktualisiert
▪
Kapitel Schaltverhalten für KL2541 hinzugefügt
▪
Technische Daten aktualisiert
▪
KL2541-0006 hinzugefügt
2.0.0
▪
Migration
▪
Technische Daten aktualisiert
▪
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit hinzugefügt
▪
Kapitel Anschluss aktualisiert
▪
Kapitel Vorgeschriebene Einbaulage ersetzt durch Kapitel Einbaulagen bei Betrieb mit und ohne Lüfter
▪
Revisionsstand aktualisiert
▪
Kapitel UL Hinweis - Compact Motion hinzugefügt
▪
Strukturupdate
1.8.0
▪
Technische Daten aktualisiert
▪
Grundlagen zur Funktion erweitert
▪
Registerbeschreibung erweitert
1.7.0
▪
Montagehinweise erweitert
▪
Technische Daten aktualisiert
▪
Beschreibung der Temperaturüberwachung erweitert
▪
Aderfarben in den Anschlussbeispielen an die Farben der Motorleitung ZK4000-6200-2xxx für Beckhoff Schrittmotoren (AS10x0) angepasst
1.6.3
▪
Beschreibung der Betriebsarten erweitert
▪
Registerbeschreibung erweitert
▪
Beschreibung der Konfigurations-Software KS2000 erweitert
1.6.2
▪
Beschreibung des Prozessabbilds aktualisiert
1.6.1
▪
Beschreibung des Prozessabbilds erweitert
▪
Grundlagen zur Funktion aktualisiert
▪
Beschreibung der Betriebsarten erweitert
1.6.0
▪
Grundlagen zur Funktion erweitert
▪
Beschreibung der Betriebsarten erweitert
▪
Einführungen und Anschlusshinweise aktualisiert
▪
technische Daten aktualisiert
▪
Beschreibung von Control- und Status-Byte aktualisiert
▪
Registerbeschreibung erweitert
▪
Montagebeschreibung erweitert
1.5.0
▪
Beschreibung der Grundlagen zur Funktion erweitert
▪
Beschreibung der Betriebsarten erweitert
▪
Registerbeschreibung erweitert
▪
Beschreibung der Konfigurations-Software KS2000 erweitert
▪
technische Daten aktualisiert
1.4.1
kleinere Routinekorrekturen (Tippfehler, Rechtschreibung usw.)
1.4
(nur in deutscher Sprache veröffentlicht)
▪
Beschreibung der Grundlagen zur Funktion erweitert
▪
Beschreibung der Betriebsarten erweitert
▪
Anschlussbeispiele aktualisiert
▪
Registerbeschreibung erweitert
▪
Beschreibung von Control- und Status-Byte erweitert
▪
Beschreibung von Control- und Status-Wort erweitert
▪
Beschreibung der Konfigurations-Software KS2000 erweitert
▪
verschiedene Beispiele zum Klemmenhandling hinzugefügt
1.3
▪
Anschlussbeispiele zur KL2531 überarbeitet
▪
Anschlussbeispiele zur KL2541 hinzugefügt
Version
Kommentar
1.2
▪
Beschreibung der Power-Kontakte der KL2541 erweitert
▪
Beschreibung des Kommando-Registers erweitert
1.1
▪
Formel zur Berechnung der Registerwerte vereinfacht
1.0
▪
Beschreibung der Grundlagen zur Funktion erweitert
▪
Beschreibung der Betriebsarten erweitert
▪
Beispiel für die Betriebsart Fahrauftrag hinzugefügt
▪
Beschreibung der Konfigurations-Software KS2000 erweitert
0.2
▪
KL2541 hinzugefügt
▪
Registerbeschreibung aktualisiert und Register-Pages hinzugefügt
▪
weitere Betriebsarten hinzugefügt:
▪
Beschreibung der Konfigurations-Software KS2000 erweitert
0.1
▪
erste vorläufige Vorabdokumentation für KL2531
▪
beschreibt nur die Betriebsart Geschwindigkeit
Firm- und Hardware-Stände
Dokumentation Version | KL2531-0000, KS2531-0000 |  | KL2541-0000, KS2541-0000 |  | KL2541-0006
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
2.1.0 | 4A | 06 | 6B | 17 | 6B | 17
2.0.0 | 4A | 06 | 6B | 17 | - | -
1.8.0 | 4A | 04 | 4K | 13
1.7.0 | 3E | 02 | 4A | 10
1.6.3 | 3E | 02 | 3E | 08
1.6.2 | 3D | 02 | 3D | 07
1.6.1 | 3D | 02 | 3D | 07
1.6.0 | 3D | 02 | 3D | 07
1.5.0 | 3A | 02 | 3A | 06
1.4.1 | 2C | 01 | 2D | 02
1.4 | 2C | 01 | 2D | 02
1.3 | 2B | 01 | 2C | 02
1.2 | 2B | 01 | 2C | 02
1.1 | 2B | 01 | 2C | 02
1.0 | 2B | 01 | 2C | 02
0.2 | 2B | 01 | 2C | 01
0.1 | 1B | 01 | - | -
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 06 3A 02:
12 - Produktionswoche 12
06 - Produktionsjahr 2006
3A - Firmware-Stand 3A
02 - Hardware-Stand 02


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KL2531 - Einführung
•
KL2531 - Technische Daten
•
KL2531 - LED-Anzeigen
•
KL2541 - Einführung
•
KL2541 - Schaltverhalten
•
KL2541 - Technische Daten
•
KL2541 - LED-Anzeigen
•
Grundlagen zur Funktion
•
Temperaturüberwachung
•
Microstepping
•
Betriebsarten


KL2531 - Einführung

Produktübersicht [image] KL2531 - Einführung
KL2531 - Einführung
KL2531
Die Busklemme KL2531 ist für den direkten Anschluss unterschiedlicher kleiner Schrittmotoren vorgesehen.
Die PWM-Endstufen für zwei Motorspulen sind bei geringster Bauform zusammen mit zwei digitalen Eingängen (24 V) für Endlagenschalter in der Busklemme untergebracht. Mit einigen Parametern kann die KL2531 an den Motor und die Anwendung angepasst werden.
Ein besonders ruhiger und präziser Motorlauf ist durch ein 64-fach-Mircostepping sichergestellt. Die integrierte Überwachung der mechanischen Last spart in vielen Anwendungen das Gebersystem oder den Endlagenschalter ein.
Die Busklemme ist als KL2531 für Standardverdrahtung und als KS2531 für stehende Verdrahtung lieferbar.


KL2531 - Technische Daten

Produktübersicht [image] KL2531 - Technische Daten
KL2531 - Technische Daten
Technische Daten | KL2531-0000, KS2531-0000
Anzahl der digitale Ausgänge | 1, für einen Schrittmotor (2 Phasen)
Spannungsversorgung für Endstufe (über Powerkontakte) | 8 VDC bis 24 VDC
Ausgangsstrom | max. 1,5 A (überlast- und kurzschlussfest)
Stromreglerfrequenz | ca. 25 kHz
Maximale Schrittfrequenz | 125 kHz
Schrittmuster | Vollschritt, Halbschritt, 4 / 8 / 16 / 32 / 64-fach-Microstepping
Auflösung | maximal 64 Schritte Microstepping
Auflösung pro Umdrehung | ca. 5000 Positionen in typischen Anwendungen
Diagnose LED für | Fehler Strang A, Fehler Strang B, Schrittverlust/Stillstand, Power, Enable, Drehrichtung, digitale Eingänge
Anzahl digitale Eingänge | 2
Nennspannung | 24 VDC (-15%/+20%)
Signalspannung "0" | -3 V ... 5 V
Signalspannung "1" | 15 V ... 30 V
Eingangsfilter | 0,2 ms
Eingangsstrom | typisch 5 mA
Potenzialtrennung | 500 V (K-Bus / Signalspannung)
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 60 mA
Bitbreite im Eingangsprozessabbild | 1 x 8 Bit Status, 2 x 16 Bit Daten
Bitbreite im Ausgangsprozessabbild | 1 x 8 Bit Control, 2 x 16 Bit Daten
Steckbare Verdrahtung | bei allen KSxxxx-Klemmen
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Gewicht | ca. 55 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4 / EN 61800-6-3 * *) Standard: Kategorie C3. Für Kategorie C1 und C2 sind zusätzliche Filter erforderlich!
Schutzart | IP20
zulässige Einbaulage | ohne Lüftermodul ZB8610: Standard-Einbaulage mit Lüftermodul ZB8610: Standard-Einbaulage, weitere Einbaulagen (Beispiel 1 & 2), siehe Hinweis
Zulassung | CE, cULus


KL2531 - LED-Anzeigen

Produktübersicht [image] KL2531 - LED-Anzeigen
KL2531 - LED-Anzeigen
KL2531 - LEDs
LED
Anzeige
Run (grün)
an
Datenübertragung auf dem K-Bus aktiv
Turn CW (grün)
an
Motor wird im Uhrzeigersinn (clock wise) angesteuert
Enable (grün)
aus
Motoransteuerung ist gesperrt (Bit SB.0 im Status-Byte ist nicht gesetzt) oder KL2531 ist nicht Betriebsbereit
an
Motoransteuerung ist freigeschaltet (Bit SB.0 im Status-Byte ist gesetzt) und KL2531 ist Betriebsbereit
Error A (rot)
blinkt (1 Hz)
Konfigurationsfehler (Bit SW.15 im Status-Wort ist gesetzt):
▪
Wert für min. Geschwindigkeit vmin ist 0 (R38)
▪
Wert für max. Geschwindigkeit vmax ist 0 (R39)
▪
Wert für max. Beschleunigung amax ist 0 (R40)
▪
Wert für Spulenstrom IS bei a > ath ist 0 (R42)
▪
Wert für Spulenstrom IS bei a ≤ ath ist 0 (R43)
Power (grün)
aus
Versorgungsspannung (24VDC) nicht vorhanden oder
Motoransteuerung ist gesperrt (Bit SB.0 im Status-Byte ist nicht gesetzt)
an
Versorgungsspannung (24VDC) vorhanden
Turn CCW (grün)
an
Motor wird gegen den Uhrzeigersinn (counter clock wise) angesteuert
Stall detect (gelb)
an
Motoransteuerung ist gesperrt (Bit SB.0 im Status-Byte ist nicht gesetzt)
blinkt (1 Hz)
Der aktuelle Lastwinkel (SB.3 bis SB.1) ist größer als die konfigurierte Lastwinkelschwelle (R47).
Error B (rot)
blinkt (1 Hz)
Versorgungs- oder Last-Fehler
Versorgungsspannung (24 VDC) zu niedrig (Bit SW.9 im Status-Wort ist gesetzt)
▪
offene Last an Brücke A (Bit SW.11 im Status-Wort ist gesetzt)
▪
offene Last an Brücke B (Bit SW.12 im Status-Wort ist gesetzt)
▪
Überstrom an Brücke A (Bit SW.13 im Status-Wort ist gesetzt)
▪
Überstrom an Brücke B (Bit SW.11 im Status-Wort ist gesetzt)


KL2541 - Einführung

Produktübersicht [image] KL2541 - Einführung
KL2541 - Einführung
KL2541-0000
Die Busklemme KL2541 ist für den mittleren Leistungsbereich von Schrittmotoren vorgesehen.
Die PWM-Endstufen decken einen großen Spannungs- und Strombereich ab. Sie sind zusammen mit zwei digitalen Eingängen (5 V / 24 V) für Endlagenschalter und einem Inkremental-Encoder-Interface (5 V / 24 V) in der Busklemme untergebracht. Sowohl das Inkremental-Encoder-Interface als auch die beiden digitalen Eingänge sind auch für Signalpegel von 5 V nutzbar. Mit einigen Parametern kann die KL2541 an den Motor und die Anwendung angepasst werden.
Ein besonders ruhiger und präziser Motorlauf ist durch ein 64-fach-Mircostepping sichergestellt. Zusammen mit einem Schrittmotor stellt die KL2541 eine preiswerte Kleinservoachse dar.
Die Busklemme ist als KL2541-0000 für Standardverdrahtung und als KS2541-0000 für steckbare Verdrahtung lieferbar.
Außerdem steht mit der KL2541-0006 eine Variante mit 5 V Geberversorgung zur Verfügung.


KL2541 - Schaltverhalten

Produktübersicht [image] KL2541 - Schaltverhalten
KL2541 - Schaltverhalten
Die Schrittmotorklemme KL2541 ist auf schnellste Signalübertragung vom Eingang zur Auswerteeinheit optimiert.
Die Dauer, die eine Signaländerung als steigende oder fallende Flanke vom Klemmpunkt an der Klemmenvorderseite bis zur Logik der zentralen Auswerteinheit benötigt, liegt bei der KL2541 spezifiziert bei TON und TOFF < 10 µs, sowohl für steigende (TON) wie für fallende Flanke (TOFF). Durch diese geringe absolute Durchlaufzeit ist auch der Temperatur-Drift der Durchlaufzeit sehr gering.
Da zusätzliche Entstörfilter am Eingang die Signallaufzeit in der KL2541 deutlich verlängern würden, treffen schnelle Pegeländerungen oder Pulse im µs-Bereich ungefiltert und ungedämpft an der Auswerteeinheit ein.
Um externe Störeinflüsse weitgehend zu vermeiden, empfehlen wir unbedingt, die Signaleingänge der KL2541 über abgeschirmte Leitungen anzuschließen.
Der Sensor/Signalgeber muss eine ausreichend steile Signalflanke erzeugen können. Das verwendete Netzteil sollte über ausreichend Reserven/Puffer verfügen, damit trotz kapazitiven/induktiven Verlusten auf der Zuleitung das Signal die Klemme mit ausreichender Flankensteilheit erreicht.


KL2541 - Technische Daten

Produktübersicht [image] KL2541 - Technische Daten
KL2541 - Technische Daten
Technische Daten | KL2541-0000, KS2541-0000 | KL2541-0006
Anzahl der digitale Ausgänge | 1, für einen Schrittmotor (2 Phasen)
Spannungsversorgung für Endstufe (über Klemmstellen 4' und 8') | 8 VDC bis 50 VDC
Ausgangsstrom | max. 5 A (überlast- und kurzschlussfest)
Maximale Schrittfrequenz | 125 kHz
Schrittmuster | Vollschritt, Halbschritt, 4 / 8 / 16 / 32 / 64-fach-Microstepping
Auflösung | maximal 64 Schritte Microstepping
Auflösung pro Umdrehung | ca. 5000 Positionen in typischen Anwendungen
Stromreglerfrequenz | ca. 25 kHz
Anzahl Encoder-Eingänge | 4, für ein Gebersystem
Encoder-Spannung "0" | -3 V ... 2 V
Encoder-Spannung "1" | 2,5 V ... 30 V
Geberversorgung | 24 VDC | 5 VDC
Pulsfrequenz | maximal 400.000 Inkremente/s (4-fach Auswertung)
Anzahl digitale Eingänge | 2, für Endlage
Nennspannung | 24 VDC (-15%/+20%)
Signalspannung "0" | -3 V ... 2 V
Signalspannung "1" | 2,5 V ... 30 V
Eingangsfilter | 0,2 ms
Eingangsstrom | typisch 5 mA
Diagnose LED für | Fehler Strang A, Fehler Strang B, Schrittverlust/Stillstand, Power, Enable, Drehrichtung, Encoder-Signale, digitale Eingänge
Potenzialtrennung | 500 V (K-Bus / Signalspannung)
Spannungsversorgung für Elektronik | über den K-Bus und über die Power-Kontakte
Stromaufnahme aus dem K-Bus (5 V) | typisch 100 mA
Stromaufnahme aus den Powerkontakten | typisch 35 mA
Verlustleistung | typisch 4 W
Bitbreite im Eingangsprozessabbild | 1 x 8 Bit Status, 2 x 16 Bit Daten
Bitbreite im Ausgangsprozessabbild | 1 x 8 Bit Control, 2 x 16 Bit Daten
Steckbare Verdrahtung | bei allen KSxxxx-Klemmen
Abmessungen (B x H x T) | ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Gewicht | ca. 100 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4 / EN 61800-6-3 * *) Standard: Kategorie C3. Für Kategorie C1 und C2 sind zusätzliche Filter erforderlich!
Schutzart | IP20
zulässige Einbaulage | ohne Lüftermodul ZB8610: Standard-Einbaulage mit Lüftermodul ZB8610: Standard-Einbaulage, weitere Einbaulagen (Beispiel 1 & 2), siehe Hinweis
Zulassung | CE, cULus


KL2541 - LED-Anzeigen

Produktübersicht [image] KL2541 - LED-Anzeigen
KL2541 - LED-Anzeigen
KL2541 - LED
Linkes LED-Prisma
LED | Anzeige
Run (grün) | an | Datenübertragung auf dem K-Bus aktiv
A (grün) | an | Am Encoder-Eingang A liegt ein Signal an.
C (grün) | an | Am Encoder-Eingang C liegt ein Signal an.
Input 1 (grün) | an | Am digitalen Eingang E1 liegt ein Signal an.
- | reserviert
B (grün) | an | Am Encoder-Eingang B liegt ein Signal an.
Latch (grün) | an | Am Latch-Eingang des Encoders liegt ein Signal an.
Input 2 (grün) | an | Am digitalen Eingang E2 liegt ein Signal an.
Rechtes LED-Prisma
LED | Anzeige
- | reserviert
Turn CW (grün) | an | Motor wird im Uhrzeigersinn (clock wise) angesteuert
Enable (grün) | aus | Motoransteuerung ist gesperrt (Bit SB.0 im Status-Byte ist nicht gesetzt) oder KL2541 ist nicht Betriebsbereit
 | an | Motoransteuerung ist freigeschaltet (Bit SB.0 im Status-Byte ist gesetzt) und KL2541 ist Betriebsbereit
Error A (rot) | blinkt (1 Hz) | Konfigurationsfehler, z. B.: - Wert für Motor Vollschritte ist 0 (R33) - Wert für Encoder-Incremente ist 0 (R34) - Wert für min. Geschwindigkeit vmin ist 0 (R38) - Wert für max. Geschwindigkeit vmax ist 0 (R39) - Wert für max. Beschleunigung amax ist 0 (R40) - Wert für Spulenstrom IS bei a > ath ist 0 (R42) - Wert für Spulenstrom IS bei a ≤ ath ist 0 (R43)
Power (grün) | aus | Versorgungsspannung (50 VDC) nicht vorhanden oder Motoransteuerung ist gesperrt (Bit SB.0 im Status-Byte ist nicht gesetzt)
 | an | Versorgungsspannung (50 VDC) vorhanden
Turn CCW (grün) | an | Motor wird gegen den Uhrzeigersinn (counter clock wise) angesteuert
Stall detect (gelb) | an | Motoransteuerung ist gesperrt (Bit SB.0 im Status-Byte ist nicht gesetzt)
 | blinkt (1 Hz) | Der aktuelle Lastwinkel (SB.3 bis SB.1) ist größer als die konfigurierte Lastwinkelschwelle (R47).
Error B (rot) | blinkt (1 Hz) | Versorgungs- oder Last-Fehler - Versorgungsspannung (24 VDC) zu niedrig (Bit SW.9 im Status-Wort ist gesetzt) - offene Last an Brücke A (Bit SW.11 im Status-Wort ist gesetzt) - offene Last an Brücke B (Bit SW.12 im Status-Wort ist gesetzt) - Überstrom an Brücke A (Bit SW.13 im Status-Wort ist gesetzt) - Überstrom an Brücke B (Bit SW.11 im Status-Wort ist gesetzt)


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Die Schrittmotorklemmen KL2531 und KL2541 integrieren eine kompakte Motion-Control-Lösung für Schrittmotoren bis 200 W in kleinster Bauform.
Schrittmotor
Der Schrittmotor ist ein Elektromotor, vergleichbar dem Synchronmotor. Der Rotor ist als Permanentmagnet ausgeführt, während der Stator aus einem Spulenpaket besteht. Im Unterschied zum Synchronmotor verfügt der Schrittmotor über eine große Zahl von Polpaaren. Bei einfachster Ansteuerung schaltet man den Schrittmotor von Pol zu Pol, bzw. von Schritt zu Schritt.
Schrittmotoren sind schon seit vielen Jahren im Einsatz. Sie zeichnen sich durch Robustheit aus, lassen sich leicht ansteuern und liefern ein hohes Drehmoment. Die Möglichkeit, die Schritte mit zu zählen, erspart in vielen Anwendungsfällen ein kostenintensives Rückführungssystem. Auch nach der zunehmenden Verbreitung der Synchron-Servomotoren ist der Schrittmotor keineswegs „in die Jahre gekommen“, sondern gilt als ausgereift und wird nach wie vor weiter entwickelt, um Kosten und Baugröße zu reduzieren und um Drehmoment und Zuverlässigkeit zu steigern.
Mit der Entwicklung der Busklemmen KL2531 und KL2541 für das Beckhoff Busklemmen-System erschließen sich neue Anwendungsfelder. Der Einsatz von Microstepping und neuester Halbleitertechnologie bietet viele Vorteile:
▪
größere Laufruhe
▪
Vermeidung von Resonanzen
▪
sinkender Energieverbrauch
▪
geringere thermische Belastung des Motors
▪
kaum elektromagnetische Abstrahlung
▪
große Leitungslängen
▪
einfachere Handhabung
▪
reduzierte Bauform der Leistungselektronik
▪
einfache Integration in übergeordnete Systeme
▪
integriertes Rückführungssystem
Zwei Schrittmotorklemmen für optimalen Einsatz
Die Schrittmotorklemmen KL2531 und KL2541 unterscheiden sich durch ihre Leistungsklassen.
▪
Die KL2531 deckt mit ihrer geringen Bauform, von nur 12 mm, den unteren Leistungsbereich ab. Die Versorgungsspannung kann bis zu 24 VDC betragen und ist zur einfachen Integration in das 24 VDC Steuerspannungsnetz vorgesehen. Mit einem Spitzenstrom von 1,5 A pro Phase kann eine große Zahl von kleinen Antrieben und Verstellachsen versorgt werden.
▪
Mit der KL2541 erreicht der Anwender die nächste Leistungsklasse, die bereits unter den kleinsten Servoantrieben angesiedelt ist. Mit dem Spitzenstrom von 5 A kann die KL2541 ein beachtliches Drehmoment von z. B. 5 Nm an einem Standardschrittmotor erreichen. Die Versorgungsspannung von bis zu 50 VDC erlaubt hohe Drehzahlen mit gutem Drehmoment und damit eine hohe mechanische Leistung, bis in den Bereich von 200 W. Die KL2541 enthält zur Aufnahme aller Anschlussdrähte eines Antriebes eine integrierte Inkremental-Encoder-Schnittstelle und baut mit einer Breite von 24 mm immer noch sehr klein.
Beide Schrittmotorklemmen geben je zwei geregelte Ströme mit Sinus-/Cosinus-Verlauf aus. Die Stromregelung wird mit 25 kHz getaktet und ermöglicht einen glatten und resonanzfreien Stromverlauf. Hochdynamische, induktionsarme Motoren laufen dadurch genauso problemlos, wie Schrittmotoren mit einer kleinen Rotormasse. Die Auflösung des Stromes erfolgt in 64 Schritten pro Periode (64-faches Microstepping). Der Standardmotor mit einem 1,8° Schrittwinkel wird sehr laufruhig und kann auf bis zu elektronische 12800 Positionen pro Umdrehung gestellt werden. Erfahrungsgemäß können ca. 5000 Positionen mechanisch angefahren werden.
Typische Schrittmotorprobleme, wie eine ausgeprägte Resonanz, gehören damit der Vergangenheit an. Durch das Microstepping und entsprechende Sollwertverläufe ist der Rotor immer ruckfrei geführt und neigt nicht mehr zur Pendelbewegung um jede Rastposition. Mechanische Maßnahmen, wie Schwingungsdämpfer gegen die Resonanz oder Untersetzungen zur Genauigkeitserhöhung, können entfallen. Entsprechend reduzieren sich die Kosten und der Entwicklungsaufwand.
Mit den neuen Schrittmotorklemmen wird auch die Entwicklungszeit auf der Steuerungsseite reduziert. Beide Busklemmen sind in allen gängigen Feldbussen wie übliche Busklemmen zu benutzen. Die Programmierung von Schnittstellen kann somit entfallen. Das Beachten von Start- und Stoppfrequenzen, sowie das schnelle Durchschreiten der Resonanzfrequenz, sind nicht mehr notwendig. Für einfache Positionieraufgaben können beide Busklemmen den Antrieb selbstständig, unter Beachtung einer Beschleunigungsrampe und der maximalen Frequenz, an eine Position fahren.
Wenig verbreitet ist heute noch die Möglichkeit, über die vom Schrittmotor zurückgespeiste Spannung, eine Erkennung der Rotorlage durchzuführen. Die Busklemmen KL2531 und KL2541 enthalten eine Statusrückmeldung, die mit einer Auflösung von 3 Bit die Belastung des Motors wiedergibt. Eine „echte“ Lageregelung lässt sich mit dieser Art der Rückführung zwar nicht durchführen, da der Schrittmotor aber prinzipiell seiner Ansteuerung folgt und bei Überlast einfach stehen bleibt, ergibt sich ein praxistaugliches Verfahren: Solange der Motor nicht überlastet ist, erreicht er die vorgegebene Position. Der in der Busklemme mitgezählte Positionswert ist O.K.
Realisierung von anspruchsvolleren Positionieraufgaben
Anspruchsvollere Positionieraufgaben lassen sich mit Hilfe der Beckhoff-Automatisierungssoftware TwinCAT realisieren. Die beiden Schrittmotorklemmen werden, wie andere Achsen, via TwinCAT System Manager eingebunden und sind wie übliche Servoachsen zu nutzen. Besondere Eigenarten des Schrittmotors, wie Rücknahme der Drehzahlvorgabe bei zu großem Schleppfehler, werden automatisch durch die Option Schrittmotorachse berücksichtigt. Der Aufwand, von einem Servomotor auf einen Schrittmotor - und zurück - zu wechseln, ist nicht größer, als unter TwinCAT der Wechsel von einem Feldbus zum anderen.
Die Endstufen der Schrittmotorklemmen besitzen eine Überlastsicherung in Form einer Übertemperaturwarnung und -abschaltung. Zusammen mit der Kurzschlusserkennung werden die Diagnosedaten im Prozessabbild der Steuerung zugänglich gemacht. Zusätzlich wird dieser Status, neben weiteren Informationen durch die LEDs der Busklemme angezeigt. Mit einem Enable-Bit wird die Endstufe eingeschaltet. Über einen Parameterwert kann der Motorstrom eingestellt und abgesenkt werden.
Die optimale Anpassung an den Motor und der energiesparende Einsatz in der Anwendung erfordern keinen großen Programmieraufwand. In der Testphase erlaubt die Konfigurations-Software KS2000 eine schnelle und effiziente Optimierung. Da alle Daten in Form von Parametern durch die Software eingestellt werden, ist es leicht möglich, eine Busklemme auszutauschen oder einmal erarbeitete Parameter zu speichern und in ein nächstes Projekt zu übertragen. Das Übertragen bestimmter Potentiometer-Einstellungen und Dokumentieren von DIP-Schalter-Einstellungen ist somit nicht mehr erforderlich.
Weiterführende Informationen
•
Parameter eines Schrittmotors
•
Bestimmung des Schrittmotors
•
Nennleistung der Motorspannungsversorgung
•
Weitere Parameter
•
Fehleranzeige


Parameter eines Schrittmotors

Produktübersicht [image] Grundlagen zur Funktion [image] Parameter eines Schrittmotors
Parameter eines Schrittmotors
Drehmoment
Bezeichnet das maximale Drehmoment des Motors bei unterschiedlichen Drehzahlen. Meist wird eine Kennlinie zur Darstellung verwendet. Das Drehmoment eines Schrittmotors ist im unteren Drehzahlbereich vergleichsweise hoch und ermöglicht in vielen Anwendungsfällen einen direkten Einsatz ohne weiteres Getriebe. Ein Schrittmotor liefert, im Vergleich zu anderen Motoren, ohne großen Aufwand ein Haltemoment, das in der Größenordnung des Drehmoments liegt.
Drehzahl
Die maximale Drehzahl eines Schrittmotors ist gering und wird meist als maximale Schrittfrequenz angegeben.
Phasenzahl
Üblich sind 2- bis 5-Phasen-Motoren. Die Busklemmen KL2531 und KL2541 unterstützen 2-Phasen-Motoren. 4-Phasen-Motoren sind im Grunde 2-Phasen-Motoren mit getrennt herausgeführten Wicklungsenden und können direkt an die Busklemme angeschlossen werden.
Nennspannung, Versorgungsspannung und Wicklungswiderstand
Im stationären Zustand fließt der Nennstrom bei Nennspannung, in Abhängigkeit zum Wicklungswiderstand. Diese Spannung sollte nicht mit der Versorgungsspannung der Leistungsendstufe in der Busklemme verwechselt werden. Die KL2531 und KL2541 geben einen geregelten Strom auf die Motorwicklung. Unterschreitet die Versorgungsspannung die Nennspannung, kann die Leistungsendstufe den Strom nicht mehr in voller Höhe einprägen und ein Drehmomentverlust ist die Folge. Erstrebenswert sind ein kleiner Wicklungswiderstand und eine hohe Versorgungsspannung, um die Erwärmung gering zu halten und ein möglichst hohes Drehmoment bei hohen Drehzahlen zu erreichen.
Resonanzen
In bestimmten Drehzahlbereichen zeigen Schrittmotore einen mehr oder weniger rauen, unrunden Lauf. Dieses Phänomen ist besonders ausgeprägt, wenn der Motor ohne angekoppelte Last läuft; unter Umständen kann er dabei sogar stehen bleiben. Die Ursache ist in Resonanzen zu sehen. Grob kann man unterscheiden zwischen
▪
Resonanzen im unteren Frequenzbereich bis ca. 250 Hz und
▪
Resonanzen im mittleren bis oberen Frequenzbereich.
Die Resonanzen im mittleren bis oberen Frequenzbereich resultieren im Wesentlichen aus den elektrischen Kenngrößen wie Induktivität der Motorwicklung und Zuleitungskapazitäten. Sie sind über eine hohe Taktung der Regelung relativ einfach in den Griff zu bekommen.
Die Resonanzen im unteren Bereich resultieren im Wesentlichen aus den mechanischen Kenngrößen des Motors. Sie bewirken im Allgemeinen außer dem rauen Lauf, teilweise einen recht erheblichen Drehmomentverlust, bis hin zum Schrittverlust des Motors und sind also in der Anwendung besonders störend.
Der Schrittmotor stellt im Grunde ein schwingungsfähiges System dar, vergleichbar mit einem Masse-Federsystem, bestehend aus dem sich bewegenden Rotor mit Trägheitsmoment und einem magnetischen Feld, das eine Rückstellkraft auf den Rotor erzeugt. Beim Auslenken und Loslassen des Rotors wird eine gedämpfte Schwingung erzeugt. Entspricht die Ansteuerfrequenz der Resonanzfrequenz, wird die Schwingung verstärkt, so dass der Rotor im ungünstigsten Fall den Schritten nicht mehr folgt und zwischen zwei Rastungen hin und her schwingt.
Die Busklemmen KL2531 und KL2541 verhindern diesen Effekt durch ihr SinCos-förmiges Bestromungsprofil bei nahezu allen Standardmotoren. Der Rotor wird nicht von Schritt zu Schritt geschaltet, springt also nicht mehr in die nächste Rastung, sondern es werden 64 Zwischenschritte durchlaufen, d. h. der Rotor wird behutsam von einem Schritt zum nächsten geführt. Der sonst übliche Drehmomenteinbruch bei bestimmten Drehzahlen bleibt aus und es kann anwendungsoptimiert gefahren werden. Dadurch kann der Motor gerade im drehmomentstarken, unteren Drehzahlbereich voll genutzt werden.
Schrittwinkel
Der Schrittwinkel gibt den bei einem Schritt zurückgelegten Winkel an. Typische Werte sind 3,6°, 1,8° und 0,9°. Das entspricht 100, 200 und 400 Schritten pro Motorumdrehung. Dieser Wert ist, zusammen mit der nachgeschalteten Übersetzung, ein Maß für die Positioniergenauigkeit. Aus technischen Gründen lässt sich der Schrittwinkel nicht beliebig reduzieren. Die Positioniergenauigkeit kann nur mechanisch durch die Übersetzung gesteigert werden. Eine elegante Lösung zur Erhöhung der Positioniergenauigkeit ist das Microstepping der KL2531 und KL2541. Es erlaubt bis zu 64 Zwischenschritte. Der geringere, „künstliche“ Schrittwinkel hat einen weiteren positiven Effekt: Bei gleicher Genauigkeit kann der Antrieb mit einer höheren Geschwindigkeit gefahren werden. Die maximale Drehzahl bleibt erhalten, obwohl der Antrieb an der Grenze der mechanischen Auflösung positioniert.


Bestimmung des Schrittmotors

Produktübersicht [image] Grundlagen zur Funktion [image] Bestimmung des Schrittmotors
Bestimmung des Schrittmotors
1.
Bestimmung der erforderlichen Positioniergenauigkeit und - dadurch bedingt - der Schrittauflösung. Zunächst muss geklärt werden, wie die Auflösung erreicht werden kann. Mechanische Untersetzungen, wie Spindel, Getriebe oder Zahnstangen führen zu einer Erhöhung. Zu berücksichtigen ist auch das 64-fache Microstepping der Schrittmotorklemmen.
2.
Bestimmung der Massen (m) und der Trägheitsmomente (J) aller zu bewegenden Teile.
3.
Berechnung der Beschleunigung, die sich durch die zeitlichen Anforderungen der bewegten Massen ergibt.
4.
Berechnung der auftretenden Kräfte aus Massen, Trägheitsmomenten und den jeweiligen Beschleunigungen.
5.
Umrechnung der Kräfte und Geschwindigkeiten auf die Motorachse, unter besonderer Berücksichtigung der Wirkungsgrade, Reibungsmomente und der mechanischen Größen, wie der Übersetzung. Praktischerweise berechnet man den Antrieb vom letzten Glied (das ist in der Regel die Last) aus rückwärts. Jedes weitere Element überträgt Kraft und Geschwindigkeit und führt durch Reibung zu weiteren Kräften oder Drehmomenten. An der Motorwelle ergibt sich während der Positionierung die Summe aller Kräfte und Drehmomente. Das Ergebnis ist ein Geschwindigkeits-/Drehmomentverlauf, den der Motor zu erbringen hat.
6.
Aus der Drehmomentkennlinie ist der Motor zu ermitteln, der die Mindestanforderungen erfüllt. Das Trägheitsmoment des ermittelten Motors ist zum gesamten Antrieb zu addieren. Eine erneute Überprüfung wird notwendig. Das Drehmoment sollte, um eine ausreichende Praxissicherheit zu gewährleisten, 20% bis 30% überdimensioniert sein. Gegenteilig kann die Optimierung verlaufen, wenn der größte Teil der Beschleunigung für das Rotorträgheitsmoment aufgebracht werden muss. In diesem Fall sollte der Motor möglichst klein ausgelegt werden.
7.
Test des Motors unter realen Anwendungsbedingungen: Die Gehäusetemperaturen sind im Dauerbetrieb zu überwachen. Werden die Berechnungen nicht von den Testergebnissen bestätigt, müssen die angenommenen Ausgangsgrößen und die Randbedingungen auf ihre Richtigkeit überprüft werden. Wichtig ist auch die Überprüfung von Randeffekten, wie Resonanzerscheinungen, Spiel in der Mechanik, Einstellungen der maximalen Lauffrequenz und der Rampensteilheit.
8.
Der Antrieb kann zur Erhöhung der Leistung durch unterschiedliche Maßnahmen optimiert werden: Auswahl leichterer Materialien, Hohlkörper, statt volles Material, und Reduzierung der mechanischen Massen. Großen Einfluss auf das Verhalten des Antriebs übt auch die Ansteuerung aus. Die Busklemme ermöglicht den Betrieb mit unterschiedlichen Versorgungsspannungen. Die Drehmomentkennlinie kann durch höhere Spannung verlängert werden. Dabei liefert ein Stromanhebungsfaktor im entscheidenden Augenblick das erhöhte Drehmoment, während eine allgemeine Absenkung des Stroms die Temperatur des Motors deutlich reduziert. In Sonderfällen kann auch eine speziell angepasste Motorwicklung sinnvoll sein.


Nennleistung der Motorspannungsversorgung

Produktübersicht [image] Grundlagen zur Funktion [image] Nennleistung der Motorspannungsversorgung
Nennleistung der Motorspannungsversorgung
Für typische Anwendungen kann man die Nennleistung der Motorspannungsversorgung so dimensionieren, dass für die Stromaufnahme 50% des Stroms einer Schrittmotorphase angenommen wird.
VORSICHT
Für größere Lastmomente müssen Sie die tatsächliche maximal auftretende Stromaufnahme genau messen!
Dieses ist lediglich eine Abschätzung für typische Anwendungen. In Fällen, bei denen größere Lastmomente am Motor auftreten, ist diese Auslegung nicht ausreichend. Hier muss die tatsächliche maximal auftretende Stromaufnahme gemessen werden und die Motorspannungsversorgung entsprechend dimensioniert werden.
Beispiel für typische Anwendungen
Eine KL2541, die einen Schrittmotor mit max. 5 A Spulenstrom in einer typischen Anwendung betreibt, kann in der Regel mit einer Motorversorgung von 48 V / 2,5 A betrieben werden.


Weitere Parameter

Produktübersicht [image] Grundlagen zur Funktion [image] Weitere Parameter
Weitere Parameter
Lastwinkel
Der Lastwinkel gibt dem Anwender eine Aussage über die aktuelle mechanische Last, welche an der Achse des Motors herrscht. Er wird als 3-Bit Wert (SB.1-SB.3) dargestellt und nach jedem Vollschritt aktualisiert. Da der Lastwinkel mit Hilfe des Motorstroms ermittelt wird, ist er von den folgenden Faktoren direkt abhängig:
▪
Geschwindigkeit - Eine mittlere Geschwindigkeit ist für einen auswertbaren Lastwinkel von Vorteil, hohe und niedrige Geschwindigkeiten ergeben einen hohen Lastwinkel.
▪
Resonanzen - Motorresonanzen erzeugen eine hohe mechanische Last am Motor und verfälschen das Messergebnis.
▪
Beschleunigung - Beschleunigungsphasen erzeugen ebenfalls eine hohe Last am Motor.
▪
Mixed Decay - Da bei eingeschaltetem Mixed Decay der Motorstrom aktiv eingeprägt wird, wirkt sich eine Deaktivierung durch CW.9 positiv auf die Auflösung des Lastwinkels aus.
▪
Motorstrom - der eingestellte Spulenstrom hat direkten Einfluss auf die Auflösung des Lastwinkels, d. h. je kleiner der Strom, desto kleiner die Auflösung.
Für jede Applikation sollte der Anwender eine optimale Geschwindigkeit ermitteln, bei der der Lastwinkel eine befriedigende Auflösung erhält.
Stromtabelle
Es ist denkbar, dass es in einigen Anwendungen notwendig ist, den normalerweise sinusförmigen Stromverlauf an den Schrittmotor anzupassen. Dazu muss das Feature-Bit R32.7 aktiviert werden. Die angepasste Stromtabelle ist in der Registerpage 1 vom Anwender abzuspeichern.
Mixed Decay
Die Mixed Decay Eigenschaft dient dazu, den Spulenstrom zu präzisieren und zu reduzieren. Dies wird dadurch erreicht, dass der Komplementärtransistor einer Halbbrücke in der zweiten Hälfte der Microstep-Phase durch Pulsen, aktiv den Spulenstrom einprägt. Im Mikroschrittbetrieb hat dies positiven Einfluss auf die Motorbewegung. Der Motor dreht ruhiger und kann präziser positioniert werden. Bei niedrigen Geschwindigkeiten und im Stillstand sollte Mixed Decay ausgeschaltet werden.
Mixed Decay kann durch das Control-Bit CW.9 deaktiviert werden.
VORSICHT
Positionsverschiebung bei der Deaktivierung von Mixed Decay möglich
Die Position kann sich, bei der Deaktivierung von Mixed Decay, im ungünstigsten Fall um einige Mikrosteps verschieben, weil sich dadurch die Spulenströme verändern!
Automatische und manuelle Stromreduzierung
Die Schrittmotorklemme bietet dem Anwender die Möglichkeit der Stromreduzierung, um eine unnötige Erwärmung des Motors zu vermeiden:
▪
automatisch, Vorgabe durch Register R44
▪
manuell, Vorgabe durch Register R45
Ist der Motor im Stillstand (v=0), wird automatisch der Haltestrom aus R44 eingestellt. Dieser Wert bezieht sich auf den eingestellten Spulenstrom der Klemme, nicht auf den maximal möglichen Nennstrom der Klemme!
Um eine größtmögliche Kontrolle für den Anwender zu erreichen, kann dieser Wert auf 100% eingestellt werden und nur R45 auf z. B. 50% gesetzt werden. Durch Setzen der Control-Bits CB.3 oder CW.11 wird manuell ein Haltestrom in die Motorwicklungen eingeprägt. Dies kann im Stillstand und beim Fahren des Motors erfolgen.
Soll-Position vorgeben (über Register)
Der Anwender kann den Soll-Positionswert setzen oder löschen. Die Register R2 und R3 dienen hierbei als Bezug:
▪
eine steigende Flanke von CW.13 löscht die vorgegebene Soll-Position (höhere Priorität als CW.10 bei gleichzeitig gesetzten CW.10 und CW.13)
▪
eine steigende Flanke von CW.10 setzt die Soll-Position auf den Wert aus Register R2 und R3
Die Quittierung erfolgt durch das Status-Bit SW.2.
Fahrwegsteuerung
Für Positionierungen, die von einer SPS übernommen werden, ist die Fahrwegsteuerung die optimale Lösung. In dieser Betriebsart wird der Klemme ein 32 Bit Positionswert und verschiedene Parameter, solche wie Geschwindigkeit und Beschleunigung, vorgegeben. Die Klemme fährt nach der Freigabe selbsttätig auf die Zielposition.
Erkennung von Positionsfehlern
Über einen an den digitalen Eingang 2 angeschlossenen externen Sensor (z. B. induktiver Näherungsschalter) bestimmt die Klemme den relativen Positionsfehler des Motors (nur bei interner Positionierung). Durch Register RP0.R51 wird die Anzahl der Impulse pro Umdrehung vorgegeben (wenn z. B. ein Ritzel verwendet wird). Durch Setzen von Bit CW.7 des Control-Worts kann der Anwender den Fehler in die Prozessdaten einblenden und anschließend mit der SPS auswerten.
Die Klemme berechnet mit diesen Parametern ein Positionsdelta:
1.1 | IF = MS x Reg33 / Reg51 | Impulsfaktor
1.2 | ∆Pos = Pos - IC x IF | relativer Positionsfehler
Legende:
IF | Impulsfaktor | [IF] = Microsteps pro Impuls
IC | Impulszähler | gezählte Impulse am digitalen Eingang 2
MS | Microsteps pro Vollschritt | MS = 2R46
Reg33 | Motor Vollschritte |
Reg46 | Schrittweite pro Viertelperiode |
Reg51 | Anzahl Impulse pro Umdrehung |
Pos | aktuelle Position (Sollwert) | [Pos] = Microsteps
∆Pos | relativer Positionsfehler | [∆Pos] = Microsteps
Ritzel mit induktivem Näherungsschalter (Register R51 = 8)
Der relative Positionsfehler muss vom Anwender individuell ausgewertet werden. Er gibt keine direkten Rückschlüsse auf die reale Anzahl der verloren gegangenen Microsteps. Dies ist dadurch bedingt, dass die Klemme den Anfangsfehler (Anzahl Microsteps vom Start des Motors bis zum ersten Sensorimpuls) nicht einrechnet. Ebenfalls kann die Toleranz bzw. die Verzögerung nicht erfasst werden, mit der der Sensor die 24 V schaltet.
Aus diesen Vorüberlegungen ergibt sich eine Geschwindigkeitsabhängigkeit, die bei der Auswertung zu beachten ist. Bei einer konstanten Geschwindigkeit schwankt der Fehler um einige Microsteps, bleibt im Mittel aber gleich. In der Praxis ist die kleine Schwankung unerheblich sein, da der Motor im Fehlerfall
▪
entweder viele Schritte auf einmal verlieren wird (dies kann eindeutig durch einen sprunghaft steigenden Fehler nachgewiesen werden) oder
▪
ganz stehen bleibt, was dann durch einen stetig steigenden Positionsfehler erkennbar ist.
Enkoder-Interface
Der Enkoder arbeitet mit einer vierfachen Auswertung.
Latch-Funktionen
Der interne Enkoder bietet die Möglichkeit der Erfassung eines oder mehrerer Latch-Ereignisse. Ein Latch-Ereignis kann durch die Einganssignale C, Latch/Gate, Eingang 1 oder Eingang 2 erzeugt werden. Standardmäßig speichert die Klemme nur einen Latch-Wert. Durch Setzen des Feature-Bits R32.9 und parametrieren von Register R37 kann das Latch-Array aktiviert und die Anzahl der Latch-Werte erhöht werden, so das mehrere Latch-Werte gespeichert werden können.
Die Reaktion der Klemme auf Latch-Ereignisse wird wie folgt aktiviert:
▪
Setzen des Control-Bits CW.0 aktiviert die steigende Flanke am C-Eingang (höchste Priorität bei mehreren, gleichzeitig gesetzten Control-Bits)
▪
Setzen des Control-Bits CW.3 aktiviert die steigende Flanke am Latch/Gate-Eingang (zweithöchste Priorität)
▪
Setzen des Control-Bits CW.4 aktiviert die fallende Flanke am Latch/Gate-Eingang (dritthöchste Priorität)
▪
Setzen des Control-Bits CW.1 aktiviert die steigende Flanke am digitalen Eingang E1 (vierthöchste Priorität)
▪
Setzen des Control-Bits CW.2 aktiviert die steigende Flanke am digitalen Eingang E2 (niedrigste Priorität)
Durch Aktivierung von R32.8 kann ein Latch-Ereignis auch dazu genutzt werden, um die aktuelle Position zu löschen. Hierzu muss zuerst eines der oben genannten Ereignisse freigeschaltet werden und danach das Control-Bit CW.13 gesetzt werden. Beim nächsten Latch-Ereignis wird die aktuelle Position gelöscht.
Nachdem die Freigabe durch den Anwender erfolgt ist, speichert die Klemme beim nächsten Latch-Ereignis den aktuellen Positionswert und signalisiert dies durch Setzen des Status-Bits SW.4. Bei aktiviertem Latch-Array tut sie dies erst, nachdem die durch R37 gegebene Anzahl an Latch-Ereignissen aufgetreten ist. Das Auslesen der Latch-Werte muss durch Setzen von CW.5 begonnen werden, hierdurch wird das niederwertige Wort in den Prozessdaten DataIN eingeblendet (die Klemme signalisiert dies durch das Status-Bit SW.5). Das höherwertige Wort kann nur aus Register R5 per Registerkommunikation ausgelesen werden. Die folgenden Latch-Werte können durch Wechseln des Control-Bits CW.6 abgerufen werden. Die Klemme quittiert dies, indem sie das Status-Bit SW.6 ebenfalls wechselt. Der nächste Latch-Wert ist jetzt gültig und wird in DataIN angezeigt. Der letzte Latch-Wert ist erreicht, wenn die Klemme SW.6 nicht mehr analog zum CW.6 wechselt.
Hinweis
Freigabe muss erhalten bleiben!
Beim Auslesen der Latch-Werte muss die vorher gesetzte Freigabe erhalten bleiben. Die Latch-Werte gehen verloren, wenn die Freigabe weggenommen wird!
Digitale Eingänge
Die digitalen Eingänge können individuell für Öffner konfiguriert werden. Hierzu wird für Eingang 1 das Bit RP0.R52.14 und für Eingang 2 das Bit RP0.R52.15 des Feature-Registers 2 auf 1bin gesetzt. Im Auslieferungszustand sind beide Eingänge für Schließer konfiguriert.


Fehleranzeige

Produktübersicht [image] Grundlagen zur Funktion [image] Fehleranzeige
Fehleranzeige
Die Schrittmotorklemme bietet dem Anwender verschiedene Diagnosemöglichkeiten. Unterteilt sind diese Fehlermeldungen in Konfigurations-Fehler, Hardware-Warnungen und Hardware-Fehler.
Konfigurations-Fehler
Bei einer unlogischen Konfiguration d. h. falls eines der Register R33, R34 (nur KL2541), R38, R39, R40, R42, R43 oder R50 Null ist, wird im Status-Wort das Bit ConfigError (SW.15) gesetzt. Die Klemme berechnet aus diesen Registern weitere interne Parameter für die Fahrwegsteuerung. Ergeben diese Berechnungen Ergebnisse außerhalb des zulässigen Wertebereichs, d. h. kann eine Zielposition mit den gegebenen Geschwindigkeiten und Beschleunigungen nie erreicht werden, wird ebenfalls dieses Fehler-Bit gesetzt. Er wird automatisch zurückgesetzt, wenn durch eine Veränderung der Registerwerte die Berechnungen ein korrektes Ergebnis liefern. Durch diese Fehler wird das Status-Bit SB.6 nicht gesetzt!
Hardware-Warnungen
Bei einer Klemmeninnentemperatur von 80 °C wird im Status-Byte das Bit SB.5 (Warning) gesetzt. Sinkt die Temperatur unter 60 °C, wird SB.5 automatisch zurückgesetzt.
Hardware-Fehler
Bei Auftreten einer der folgenden Fehler wird der Motor stromlos geschaltet und im Status-Byte das Bit SB.6 gesetzt.
▪
Übertemperatur (OverTemperature SW.8)
▪
Unterspannung (UnderVoltage SW.9)
▪
offene Last, Brücke A (OpenLoad Br A, SW.10)
▪
offene Last, Brücke B (OpenLoad Br B, SW.11)
▪
Überstrom Brücke A (OverCurrent Br A, SW.12)
▪
Überstrom Brücke B (OverCurrent Br B, SW.13)
▪
Ausfall der 24 V Steuerspannung (NoControlPower, SW.14)
(die Klemme wird bei wiederkehrender Steuerspannung automatisch Reinitialisiert)
Bei Auftreten eines Fehlers muss dieser zunächst behoben und anschließend durch Setzen des Bits CB.6 im Control-Byte quittiert und damit gelöscht werden.


Temperaturüberwachung

Produktübersicht [image] Temperaturüberwachung
Temperaturüberwachung
Die Schrittmotorklemmen KL2531 und KL2541 haben eingebaute Temperaturüberwachung für die Gehäuseinnentemperatur und den Stepper-Controller-Chip.
Temperaturwarnung
Erreicht die Temperatur im Klemmengehäuse 80°C wird im Status-Byte das Bit SB.5 (Warning) gesetzt. Sinkt die Temperatur unter 60°C, wird SB.5 automatisch zurückgesetzt.
Aus dem Temperatur-Register R6 können Sie die aktuelle Gehäuseinnentemperatur auslesen.
Automatische Abschaltung
Überschreitet die Temperatur 125°C,
▪
schaltet der Stepper-Controller-Chip den Motor selbsttätig ab. Außerdem
▪
wird im Status-Wort, das Bit SW.8 (OverTemperature) gesetzt,
▪
blinkt die LED Error B,
▪
wird im Status-Byte das Bit SB.6 (Error) gesetzt
(Das Bit SB.6 des Status-Bytes kann durch setzen des Bits CB.6 im Control-Byte zurückgesetzt werden.)
Achtung
Temperaturüberwachung kontrollieren!
Kontrollieren Sie die Temperaturüberwachungen aus ihrem Anwenderprogramm heraus, wenn Sie die Schrittmotorklemmen KL2531 und KL2541 an deren Leistungsgrenzen betreiben!
Temperaturdiagramm der KL2541
Ab Hardware-Stand 10 der KL2541 ist das folgende Diagramm anwendbar.
KL2541 - Gehäuseinnentemperatur (worst case)
Dieses Diagramm stellt die Gehäuseinnentemperatur (worst case) der KL2541 bei 55°C Umgebungstemperatur und maximalem Motorstrom dar:
▪
Auf der X-Achse ist die Zeit in Sekunden angegeben.
▪
Auf der Y-Achse ist die Temperatur in Grad Celsius angegeben.
Bis zum Beginn der Temperatursteigerung (t = 0 s) ist die KL2541 disabled. Danach wird ein Schrittmotor mit 5 A betrieben.
Der Anwender kann anhand dieses Diagramms abschätzen, wie lange die KL2541 bei maximaler Umgebungstemperatur und maximalem Laststrom betrieben werden kann, bis die Abschaltautomatik des Stepper-Controller-Chips den Motor selbsttätig abschaltet (125°C).


Microstepping

Produktübersicht [image] Microstepping
Microstepping
Das Microstepping können Sie mit Register R46 und den Registern R48 bis R63 oder mit dem Dialog Stromtabelle der Konfigurationssoftware KS2000 vorgeben.
Microstepping | Schritte pro Viertelperiode
Vollschritt | 1
Halbschritt | 2
1/4-Schritt | 4
1/8-Schritt | 8
1/16-Schritt | 16
1/32-Schritt | 32
1/64-Schritt | 64
Stromverlauf Microstepping


Betriebsarten

Produktübersicht [image] Betriebsarten
Betriebsarten
Die Betriebsarten können Sie mit der Konfigurations-Software KS2000 oder per Register-Kommunikation über das Feature-Register RP0.R32 auswählen.
Die Schrittmotorklemmen KL2531 und KL2541 unterstützen folgende Betriebsarten:
▪
Geschwindigkeit, direkt
▪
Geschwindigkeit, mit Rampen
▪
Positionsnachführung
▪
Fahrwegsteuerung
–
Manuell (Geschwindigkeit, mit Rampen)
–
Fahrauftrag (einfach)
–
Fahrauftrag (mehrfach)
–
Auto-Start-Funktion
–
Auto-Stopp-Funktion
–
Schnell-Stopp-Funktion
–
Referenzierung (über die digitalen Eingänge)
–
Selbstjustierung
Betriebsart |  | zum Betrieb an | Wertebereich DataOUT
Geschwindigkeit, direkt |  | NC, zyklisches Geschwindigkeitsinterface | -7FFFhex bis +7FFFhex
Geschwindigkeit, mit Rampen |  | SPS | -7FFFhex bis -0010hex +0010hex bis +7FFFhex
Positionsnachführung (in Vorbereitung) |  | NC, zyklisches Positionsinterface | -7FFFhex bis +7FFFhex
Fahrwegsteuerung | Manuell | SPS | -7FFFhex bis -0010hex +0010hex bis +7FFFhex
 | Fahrauftrag |  | 0000hex
Weiterführende Informationen
•
Geschwindigkeit, direkt
•
Geschwindigkeit, mit Rampen
•
Positionsnachführung
•
Fahrwegsteuerung


Geschwindigkeit, direkt

Produktübersicht [image] Betriebsarten [image] Geschwindigkeit, direkt
Geschwindigkeit, direkt
Diese Betriebsart ist zur Verwendung am zyklischen Geschwindigkeitsinterface einer Numerischen Steuerung (NC) gedacht. Die NC gibt in dieser Betriebsart eine Sollgeschwindigkeit vor. Rampen für den Anlauf und das Abbremsen des Motors werden ebenfalls von der NC gesteuert.
DataOUT
Die Klemme wertet 15 Bit und Vorzeichen (VZ) aus:
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Inhalt | VZ | Geschwindigkeitswert
Wertebereich: -7FFFhex bis +7FFFhex (-32767dez bis +32767dez)


Geschwindigkeit, mit Rampen

Produktübersicht [image] Betriebsarten [image] Geschwindigkeit, mit Rampen
Geschwindigkeit, mit Rampen
Diese Betriebsart ist für die einfache Motorsteuerung aus einer herkömmlichen SPS (keine NC) heraus gedacht.
Die Schrittmotorklemme folgt den Geschwindigkeitsvorgaben der SPS unter Berücksichtigung von Rampen, die die Klemme aus den Parametern maximale Geschwindigkeit (RP0.R39), maximale Beschleunigung (RP0.R40) und minimale Geschwindigkeit (RP0.R38) bestimmt. Diese Parameter können Sie über die Registerkommunikation in den Registern der Klemme hinterlegen oder über die Konfigurations-Software KS2000 parametrieren.
DataOUT
Die Klemme wertet 11 Bit und Vorzeichen (VZ) aus, dadurch ist die Auflösung in dieser Betriebsart um den Faktor 16 schlechter, als in der Betriebsart Geschwindigkeit, direkt:
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Inhalt | VZ | Geschwindigkeitswert |  |  |  |  |  |  |  |  |  |  | 0 | 0 | 0 | 0
Wertebereich: -7FFFhex bis -10hex und +10hex bis +7FFFhex (-32767dez bis -16dez und +16dez bis +32767dez)
Berechnung der Geschwindigkeit (in Microsteps)
Der im Ausgangsdatenwort ausgegebene Wert wird von der Schrittmotorklemme nach folgender Formel in eine Geschwindigkeit umgesetzt.
Die durch Register RP0.R39 vorgegebene maximale Geschwindigkeit begrenzt in den Betriebsarten Geschwindigkeit, mit Rampen und Fahrwegsteuerung die Motorgeschwindigkeit nach oben.
1.1 | R = DataOUT / 32767 x f x 2047 / 262144 | DataOUT = R / f x 262144 x 32767 / 2047
vereinfachte Formeln:
1.2 | R = DataOUT x 3,812951 | DataOUT = R / 3,812951
1.3 | RFS = DataOUT x 3,812951 / MS | DataOUT = RFS x MS / 3,812951
1.4 | RPS = DataOUT x 3,812951 / (R33 x MS) | DataOUT = RPS x R33 x MS / 3,812951
Umrechnung in Fullsteps / Umdrehungen pro Sekunde
2.1 | RFS = R / MS; RFS = R / 2R46
2.2 | RPS = RFS / R33
mit
R | Geschwindigkeit in Microsteps | [R] = Microsteps / s
RFS | Geschwindigkeit in Fullsteps | [RFS] = Fullsteps / s
RPS | Umdrehungen pro Sekunde | [RPS] = N / s
MS | Microsteps | MS = 2R46
f | interne Taktfrequenz | f = 16 MHz
RP0.R33 | Wert in Register 33 | Anzahl der Vollschritte des Motors pro Umdrehung
RP0.R46 | Wert in Register 46 | Anzahl der Schritte/Viertelperiode
DataOUT | Wert im Ausgangsdatenwort |
Berechnung der Registerwerte (Reg) für R38, R39, R40, R41, R50, R58
minimale und maximale Geschwindigkeit
3.1 | Reg = R / f x 262144 | Geschwindigkeit gegeben in MS / s
3.2 | Reg = RFS x MS / f x 262144 | Geschwindigkeit gegeben in FS / s
vereinfachte Formeln:
3.3 | Reg = R x 0,016384 | Geschwindigkeit gegeben in MS / s
3.4 | Reg = RFS x MS x 0,016384 | Geschwindigkeit gegeben in FS / s
mit:
R | Geschwindigkeit in Microsteps | [R] = Microsteps / s
RFS | Geschwindigkeit in Fullsteps | [RFS] = Fullsteps / s
RPS | Umdrehungen pro Sekunde | [RPM] = N / s
MS | Microsteps | MS = 2R46
f | interne Taktfrequenz | f = 16 MHz
Reg | Registerwert R38 bzw. R39 |
maximale Beschleunigung und Beschleunigungsschwelle
4.1 | Reg = ∆R x 238 / f2 | Beschleunigung gegeben in MS / s2
4.2 | Reg = ∆RFS x MS x 238 / f2 | Beschleunigung gegeben in FS / s2
vereinfachte Formeln:
4.3 | Reg = ∆R x 1,073742 x 10-3 | Beschleunigung gegeben in MS / s2
4.4 | Reg = ∆RFS x MS x 1,073742 x 10-3 | Beschleunigung gegeben in FS / s2
Umrechnung in Fullsteps
5.1
∆RFS = ∆R / MS
∆RFS = R / 2R46
mit:
∆R | Beschleunigung | [∆R] = Microsteps / s2
∆RFS | Beschleunigung in Fullsteps | [∆RFS] = Fullsteps / s2
MS | Microsteps | MS = 2R46
f | interne Taktfrequenz | f = 16 MHz
Reg | Registerwert R40 bzw. R41 |
amax | maximale Beschleunigung (RP0.R40) | [amax] = 1


Positionsnachführung

Produktübersicht [image] Betriebsarten [image] Positionsnachführung
Positionsnachführung
(in Vorbereitung)
Diese Betriebsart ist zur Verwendung am zyklischen Positionsinterface einer Numerischen Steuerung (NC) gedacht. Hierbei wird von der NC eine 16 Bit Sollposition vorgegeben. Die Klemme versucht dieser Position zu folgen, indem der interne Lageregler eine Geschwindigkeit berechnet. Die zwei Parameter in Register RP0.R48 (Kp-Faktor) und RP0.R49 (Kv-Faktor) werden hierfür verwendet.


Fahrwegsteuerung

Produktübersicht [image] Betriebsarten [image] Fahrwegsteuerung
Fahrwegsteuerung
Diese Betriebsart ist für einfache Positionierungen aus einer herkömmlichen SPS (keine NC) heraus gedacht. In der Betriebsart Fahrwegsteuerung gibt es die Varianten:
▪
Manuell
▪
Fahrauftrag (einfach)
▪
Sollposition über Prozessdaten vorgeben (nur KL2531-1000 und KL2541-1000)
▪
Fahrauftrag (mehrfach)
▪
Auto-Start-Funktion
▪
Schnell-Start-Funktion
▪
Referenzierung
▪
Selbstjustierung
Weiterführende Informationen
•
Manuell
•
Fahrauftrag (einfach)
•
Sollpositipon über Prozessdaten vorgeben (nur KL2531-1000 und KL2541-1000)
•
Fahrauftrag (mehrfach)
•
Auto-Start-Funktion
•
Auto-Stopp-Funktion
•
Schnell-Stopp-Funktion
•
Referenzierung
•
Selbstjustierung


Manuell

Produktübersicht [image] Betriebsarten [image] Fahrwegsteuerung [image] Manuell
Manuell
Der manuelle Betriebsmodus ist identisch mit dem Geschwindigkeitsinterface mit Rampen. Dieser Modus wird von der Klemme automatisch ausgewählt, wenn kein Fahrauftrag aktiv ist (CB.2 = 0).


Fahrauftrag (einfach)

Produktübersicht [image] Betriebsarten [image] Fahrwegsteuerung [image] Fahrauftrag (einfach)
Fahrauftrag (einfach)
Bei der Fahrwegsteuerung (einfach) wird der Klemme ein Positionswert vorgegeben, der von der aktuellen Position maximal +/- 231 Positions-Inkremente entfernt sein darf. Die aktuelle Position kann von der Steuerung aus den Registern R0 und R1 gelesen werden. Während eines aktiven Fahrauftrags kann die Steuerung die Klemme schon für einen darauf folgenden Fahrauftrag parametrieren. Die neuen Parameter werden dabei in den RAM-Bereich der Register geschrieben (das Kodewort-Register muss hierzu gelöscht sein!). Die genaue Vorgehensweise ist weiter unten im Beispiel detailliert beschrieben.
Für einen sinnvollen und effektiven Fahrbetrieb können diese Register umparametriert werden:
▪
R2: Zielposition (niederwertiges Wort)
▪
R3: Zielposition (höherwertiges Wort)
▪
RP0.R38: minimale Geschwindigkeit
▪
RP0.R39: maximale Geschwindigkeit
▪
RP0.R40: maximale Beschleunigung
▪
RP0.R58: maximale Verzögerung (muss durch Bit RP0.R52.1 des Feature-Registers 2 aktiviert werden)
Beispiel
In dem folgenden Beispiel wird ein Fahrauftrag gestartet und während der Fahrt eine neue Position vorgeben. Anschließend wird ein zweiter Fahrauftrag gestartet. Der Motor wird danach manuell weitergefahren und wieder gestoppt.
1.
Setzen Sie im Control-Byte das Bit CB.0 auf 1, um die Motoransteuerung freizuschalten.
2.
Tragen Sie über Registerkommunikation die Zielposition (32 Bit) in die Register R2 und R3 ein.
3.
Tragen Sie über Registerkommunikation die restlichen Parameter in die Register R37, R38, R39, R40 und R58 (alle Register-Page 0) ein, falls diese geändert werden sollen.
4.
Die Prozessausgangsdaten DataOUT müssen jetzt Null sein, damit der Fahrauftrag gestartet werden kann.
5.
Setzen Sie im Control-Byte das Bit CB.2 auf 1 um den Fahrauftrag zu starten. Die Schrittmotorklemme fährt den Motor nun selbständig zur Zielposition. Halten Sie das Bit CB.2 auf 1 bis der Motor die gewünschte Position erreicht hat. Soll der Fahrauftrag zwischendurch abgebrochen werden, löschen Sie das Bit CB.2.
6.
Tragen Sie, während des aktiven Fahrauftrags, über Registerkommunikation die neuen Parameter in die Register R37, R38, R39, R40 und R58 ein, falls diese geändert werden sollen.
7.
Die Klemme meldet jetzt durch Setzen des Bits SW.3 im Status-Wort das Erreichen der Zielposition.
8.
Löschen Sie im Control-Byte das Bit CB.2 um den ersten Fahrauftrag abzuschließen.
9.
Die Klemme quittiert dies durch Löschen des Bits SW.3.
10.
Setzen Sie das Bit CB.2 auf 1 um den neuen Fahrauftrag zu starten.
11.
Die Klemme meldet erneut durch Setzen des Bits SW.3 das Erreichen der zweiten Zielposition.
12.
Löschen Sie im Control-Byte das Bit CB.2 um den zweiten Fahrauftrag abzuschließen.
13.
Die Klemme quittiert dies wieder durch Löschen des Bits SW.3.
14.
Tragen Sie jetzt über Prozessdatenkommunikation einen Geschwindigkeitswert in DataOUT ein, um den Motor manuell zu fahren.
15.
Löschen Sie jetzt den Geschwindigkeitswert in DataOUT ein, um den Motor wieder anzuhalten.


Sollpositipon über Prozessdaten vorgeben (nur KL2531-1000 und KL2541-1000)

Produktübersicht [image] Betriebsarten [image] Fahrwegsteuerung [image] Sollpositipon über Prozessdaten vorgeben (nur KL2531-1000 und KL2541-1000)
Sollpositipon über Prozessdaten vorgeben (nur KL2531-1000 und KL2541-1000)
Alternativ können Sie bei der Sondervariante KL2541-1000 die Zielposition auch über die Prozessdaten vorgeben. Die Vorgehensweise ist folgendermaßen:
1.
Speichern Sie den aktuellen Geschwindigkeitswert.
2.
Schalten Sie die Prozessausgangsdaten DataOUT durch setzen von Bit CW.14 um (Positions-Interface aktiv).
3.
Schreiben Sie die neue Soll-Position in die Prozessausgangsdaten DataOut.
4.
Übernehmen Sie die neue Soll-Position durch Setzen von Bit CW.10.
5.
Setzen Sie die Soll-Geschwindigkeit auf den gespeicherten Geschwindigkeitswert zurück.
6.
Schalten Sie die Prozessausgangsdaten DataOUT durch löschen von Bit CW.14 zurück (Geschwindigkeits-Interface aktiv).
7.
Starten Sie den neuen Fahrauftrag durch Setzen von Bit CB.2.


Fahrauftrag (mehrfach)

Produktübersicht [image] Betriebsarten [image] Fahrwegsteuerung [image] Fahrauftrag (mehrfach)
Fahrauftrag (mehrfach)
Bei der Fahrwegsteuerung (mehrfach) werden der Klemme bis zu 16 Positionswerte, 16 Geschwindigkeiten (ab Firmware 3E) und 16 Beschleunigungen (ab Firmware 3E) vorgegeben, die intern in verschiedenen Tabellen gespeichert werden. Eine Position setzt sich wiederum aus zwei Registern zusammen, die in den Registern R32 bis R63 der Register-Page 2 abgelegt sind. Jeder dieser Positionswerte darf von der aktuellen Position maximal +/- 231 Positions-Inkremente entfernt sein. Die aktuelle Position kann von der SPS aus den Registern R0 und R1 gelesen werden. Die Geschwindigkeiten werden in den Register R32 bis R47 und die Beschleunigungen in den Registern R48 bis R63 der Register-Page 3 abgelegt.
Während eines aktiven Fahrauftrags kann die Steuerung die Klemme schon für einen darauf folgenden Fahrauftrag parametrieren (ausgenommen R39 und R40, die beim Start des kommenden Fahrauftrages überschrieben werden). Die neuen Parameter werden dabei in den RAM-Bereich der Klemme geschrieben (das Kodewort-Register muss hierzu gelöscht sein!).
Ein mehrfacher Fahrauftrag wird gestartet, durch Beschreiben von Register R7
▪
mit Kommando 0x0500 (hierbei wird nach jedem Fahrauftrag der interne Positionsindex inkrementiert, bis Position 15 erreicht wird - d. h. die Tabelle wird vorwärts abgearbeitet) oder
▪
mit Kommando 0x0510 (hierbei wird nach jedem Fahrauftrag der interne Positionsindex dekrementiert, bis Position 0 erreicht wird - d. h. die Tabelle wird rückwärts abgearbeitet).
Die Startposition wird durch Hinzufügen eines Offsets zum Kommando-Code 0x0500 bzw. 0x0510 festgelegt (z. B. 0x0504 -> Startposition 4 vorwärts; 0x0518 -> Startposition 8 rückwärts). Ein mehrfacher Fahrauftrag kann durch das Kommando 0x0540 gestoppt werden. Die genaue Vorgehensweise ist weiter unten im Beispiel detailliert beschrieben.
Bis zu 16 mögliche Zielpositionen werden in den folgenden Registern festgelegt:
▪
RP2.R32: Zielposition 0 (niederwertiges Wort)
▪
RP2.R33: Zielposition 0 (höherwertiges Wort)
▪
RP2.R34: Zielposition 1 (niederwertiges Wort)
▪
RP2.R35: Zielposition 1 (höherwertiges Wort)
▪
usw.
Bis zu 16 mögliche Geschwindigkeiten werden in den folgenden Registern festgelegt:
▪
RP3.R32: Geschwindigkeit 0
▪
RP3.R33: Geschwindigkeit 1
▪
usw.
Bis zu 16 mögliche Beschleunigungen werden in den folgenden Registern festgelegt:
▪
RP3.R48: Beschleunigung 0
▪
RP3.R49: Beschleunigung 1
▪
usw.
Für sinnvollen und effektiven Fahrbetrieb mit mehrfacher Positionierung können die folgenden Register umparametriert werden:
▪
RP0.R38: minimale Geschwindigkeit
▪
RP0.R58: maximale Verzögerung (muss durch Bit RP0.R52.1 aktiviert werden)
Beispiel
In dem folgenden Beispiel wird ein mehrfacher Fahrauftrag bei Index 5 gestartet, danach werden drei Positionen (Position 5, 6 und 7) angefahren. Anschließend wird der interne Positionsindex auf 3 gesetzt und 2 Positionen (Position 3 und 2) angefahren. Danach wird der mehrfache Fahrauftrag gestoppt.
1.
Tragen Sie über Registerkommunikation die Zielpositionen (max. 16 Positionen je 32 Bit) in die Register RP2.R32 bis RP2.R63 ein.
2.
Setzen Sie das Bit CB.0 des Control-Bytes auf 1bin, um die Motoransteuerung freizuschalten.
3.
Tragen Sie über Registerkommunikation die weiteren Parameter in die Register RP0.R37, RP0.R38, RP0.R39, RP0.R40 und RP0.R58 (alle Register-Page 0) ein, falls diese neu parametriert werden sollen.
4.
Die Prozessausgangsdaten DataOUT müssen jetzt Null sein, damit der Fahrauftrag gestartet werden kann.
5.
Tragen Sie über Registerkommunikation das Start-Kommando 0x0505 (0x0500 + Offset 5) in Register R7 ein, um den internen Positionsindex auf Position 5 als erste Zielposition zu setzen.
6.
Setzen Sie im Control-Byte das Bit CB.2 auf 1bin um den ersten Fahrauftrag zu starten.
7.
Die Schrittmotorklemme fährt den Motor nun selbständig zur Zielposition. Halten Sie das Bit CB.2 auf 1bin bis der Motor die gewünschte Position erreicht hat. Soll der Fahrauftrag zwischendurch abgebrochen werden, setzen Sie das Bit CB.2 zurück auf 0bin.
8.
Tragen Sie, während des aktiven Fahrauftrags, über Registerkommunikation die neuen Parameter in die Register R37, R38, R39, R40 und R58 ein, falls diese geändert werden sollen.
9.
Die Klemme meldet jetzt durch Setzen des Bits SW.3 des Status-Wort auf 1bin das Erreichen der Zielposition.
10.
Löschen Sie im Control-Byte das Bit CB.2 um den ersten Fahrauftrag abzuschließen.
11.
Die Klemme quittiert dies durch zurücksetzen des Bits SW.3 auf 0bin. Der Positionsindex wird dabei automatisch um eine Position (auf Position 6) inkrementiert.
12.
Setzen Sie im Control-Byte das Bit CB.2 auf 1bin um den zweiten Fahrauftrag zu starten.
13.
Löschen Sie das Bit CB.2 um den zweiten Fahrauftrag abzuschließen, nachdem die Klemme durch zurücksetzen des Bits SW.3 auf 0bin das Erreichen der Position 6 signalisiert hat.
14.
Setzen Sie das Bit CB.2 auf 1bin um den dritten Fahrauftrag zu starten.
15.
Löschen Sie das Bit CB.2 um den dritten Fahrauftrag abzuschließen, nachdem die Klemme durch zurücksetzen des Bits SW.3 auf 0bindas Erreichen der Position 7 signalisiert hat.
16.
Tragen Sie über Registerkommunikation das Start-Kommando 0x0513 (0x5100 + Offset 3) in Register R7 ein, um den internen Positionsindex auf Position 3 als nächste Zielposition zu setzen.
17.
Setzen Sie das Bit CB.2 auf 1bin um den vierten Fahrauftrag zu starten.
18.
Löschen Sie das Bit CB.2 um den vierten Fahrauftrag abzuschließen, wenn die Klemme durch Setzen von Bit SW.3 das Erreichen der Position 3 signalisiert hat. Der Positionsindex wird dabei automatisch um eine Position (auf Position 2) dekrementiert.
19.
Setzen Sie das Bit CB.2 auf 1bin um den fünften Fahrauftrag zu starten.
20.
Löschen Sie das Bit CB.2 um den fünften Fahrauftrag abzuschließen, wenn die Klemme durch Setzen von Bit SW.3 das Erreichen der Position 2 signalisiert hat.
21.
Tragen Sie über Registerkommunikation das Stop-Kommando 0x0540 in Register R7 ein, um den 'mehrfachen' Fahrauftrag zu stoppen.


Auto-Start-Funktion

Produktübersicht [image] Betriebsarten [image] Fahrwegsteuerung [image] Auto-Start-Funktion
Auto-Start-Funktion
Die Auto-Start Funktion wird durch Setzen des Bits RP0.R32.0 im Feature-Register aktiviert.
Diese Funktion bietet dem Anwender die Möglichkeit, unabhängig von der SPS, eine schnelle und einfache Positionierung durchzuführen. Hierzu dient der digitale Eingang 1 als Vorwahl für den Positionssollwert. Der Anwender muss, wie bei einem normalen Fahrauftrag, die Sollposition in die Register R2 und R3 eintragen. Anschließend erfolgt die Freigabe durch Setzen von Bit CB.4 im Control-Byte. Abhängig vom Zustand des digitalen Eingangs 1 fährt der Schrittmotor auf die folgenden Positionen, wenn:
▪
der digitale Eingang 1 = High-Potential (24 V) hat, auf die in R2 und R3 vorgegebene Position
▪
der digitale Eingang 1 = Low-Potential (0 V) hat, zurück auf Position 0
Der digitale Eingang kann seinen Zustand während der Fahrt wechseln. Die Klemme erkennt diese Änderung sofort, stoppt den Motor und fährt in die andere Richtung. Die Klemme meldet durch Setzen des Bits SW.3 im Status-Wort das Erreichen der Zielposition.
WARNUNG
Motor startet sofort!
Der Schrittmotor wird, wenn er zwischen Position 0 und der oberen Zielposition (gegeben durch R2 und R3) steht, bei der Aktivierung von Bit CB.4 sofort gestartet!
Es wird empfohlen, vor der Aktivierung, die aktuelle Position zuerst zu löschen und den Eingang 1 auf Low-Potential zu legen.
Stellen Sie sicher dass ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!


Auto-Stopp-Funktion

Produktübersicht [image] Betriebsarten [image] Fahrwegsteuerung [image] Auto-Stopp-Funktion
Auto-Stopp-Funktion
Die Auto-Stopp-Funktion wird durch Setzen des Bits RP0.R32.1 im Feature-Register aktiviert und ist in allen Betriebsarten verfügbar.
Diese Funktion bietet dem Anwender die Möglichkeit, den Motor (z. B. durch zwei Endschalter) automatisch zu stoppen. Durch Setzen von Bit CB.5 im Control-Byte wird die Funktion freigeschaltet. Fährt der Motor gegen einen der Endschalter, welche an den digitalen Eingängen 1 oder 2 eine steigende Flanke erzeugen, wird er mit der Notfall-Beschleunigung (konfigurierbar durch Register RP0.R50) gestoppt. Die Eingänge 1 und 2 können durch die Bits R52.14 bzw. R52.15 für Öffner konfiguriert werden (d. h. der aktive Zustand ist LOW). So das der Motor auch bei Drahtbruch abgeschaltet wird.


Schnell-Stopp-Funktion

Produktübersicht [image] Betriebsarten [image] Fahrwegsteuerung [image] Schnell-Stopp-Funktion
Schnell-Stopp-Funktion
Die Schnell-Stopp-Funktion ist vergleichbar mit der Auto-Stopp-Funktion, nur das diese Funktion von der SPS genutzt werden kann. Sie muss nicht explizit im Feature-Register aktiviert werden. Durch Setzen von Bit CB.1 im Control-Byte wird die Funktion eingeschaltet und der Motor sofort mit der Notfall-Beschleunigung (Register R50) gestoppt. Dies kann z. B. bei einem aktiven Fahrauftrag nützlich sein, der mit einer kleinen Verzögerung konfiguriert ist.


Referenzierung

Produktübersicht [image] Betriebsarten [image] Fahrwegsteuerung [image] Referenzierung
Referenzierung
Die Schrittmotorklemme bietet die Möglichkeit einer einfachen Referenzierung (Homing). Hierzu werden die digitalen Eingänge als Nockenrückführung verwendet. Falls nur ein Referenzeingang genutzt werden soll, kann der zweite Eingang mit Bit RP0.52.4 oder RP0.52.5 deaktiviert werden. Die genaue Vorgehensweise ist weiter unten im Beispiel detailliert beschrieben.
Für eine sinnvolle Referenzierung können diese Register umparametriert werden:
▪
RP0.R40: maximale Beschleunigung
▪
RP0.R50: Notfall Beschleunigung
▪
RP0.R53: Referenziergeschwindigkeit rückwärts vref,b (rückwärts bedeutet abfallende Positionswerte)
▪
RP0.R54: Referenziergeschwindigkeit vorwärts vref,f (vorwärts bedeutet ansteigende Positionswerte)
▪
RP0.R55: Referenzierposition setzen (niederwertiges Wort)
▪
RP0.R56: Referenzierposition setzen (höherwertiges Wort)
Beispiel
In dem folgenden Beispiel wird eine Referenzierung durchgeführt.
1.
Tragen Sie über Registerkommunikation die Parameter in die Register RP0.R40, RP0.R50, RP0.R53, RP0.R54, RP0.R55 und RP0.R56.
2.
Setzen Sie im Control-Byte das Bit CB.0 auf 1bin, um die Motoransteuerung freizuschalten.
3.
Tragen Sie über Registerkommunikation das Kommando 0x0520 in Register R7 ein, um die Referenzierfahrt vorzubereiten.
4.
Die Prozessausgangsdaten DataOUT müssen jetzt Null sein, damit die Referenzierung gestartet werden kann.
5.
Die beiden digitalen Eingänge dürfen zu Beginn der Referenzfahrt nicht angesteuert sein, da sie miteinander oder-verknüpft sind!
6.
Setzen Sie im Control-Byte das Bit CB.2 auf 1 um die Referenzierung zu starten. Die Schrittmotorklemme fährt den Motor jetzt mit der Geschwindigkeit vref,b in negativer Richtung auf den Endschalter zu (falls das Bit RP0.R52.0 gesetzt ist mit der Geschwindigkeit vref,f in positiver Richtung).
7.
Erkennt die Klemme das Erreichen der Nocke durch eine steigende Flanke an einem der beiden Eingänge, stoppt sie den Motor mit der Notfall Beschleunigung.
8.
Anschließend fährt die Schrittmotorklemme den Motor mit der Geschwindigkeit vref,b in entgegengesetzter Richtung.
9.
Erscheint an dem angesteuerten digitalen Eingang jetzt eine fallende Flanke (Motor ist von der Nocke gefahren), stoppt die Klemme den Motor mit der Notfall Beschleunigung.
10.
Die Klemme meldet jetzt durch Setzen des Bits SW.3 im Status-Wort die erfolgreich abgeschlossene Referenzierung. Gleichzeitig wird die in RP0.R55 und RP0.R56 konfigurierte Referenzierposition als Ist-Position gesetzt.
11.
Löschen Sie im Control-Byte das Bit CB.2 um die Referenzierung abzuschließen.
12.
Die Klemme quittiert dies durch Löschen des Bits SW.3.


Selbstjustierung

Produktübersicht [image] Betriebsarten [image] Fahrwegsteuerung [image] Selbstjustierung
Selbstjustierung
Die Schrittmotorklemme bietet die Möglichkeit einer einfachen "on the fly" Selbstjustierung. Eine Linearachse bietet hierfür eine sinnvolle Plattform.
Ein auf der Wegstrecke positionierter Schalter dient als auslösender Sensor. Wird er überfahren, löst er in der Klemme ein Latch-Ereignis aus (es kann ein beliebiger Latch-Eingang verwendet werden).
Beim ersten Mal wird der Latch-Wert als Referenzposition genommen. Wird der Punkt erneut überfahren, und ein Latch-Wert gespeichert, korrigiert die Klemme beim nächsten Stillstand die Differenz zwischen der Referenzposition und dem im laufenden Betrieb gelatchten Wert. Die genaue Vorgehensweise ist weiter unten im Beispiel detailliert beschrieben.
Selbstjustierung
Beispiel
In dem folgenden Beispiel wird eine Selbstjustierung durchgeführt.
1.
Setzen Sie im Control-Byte das Bit CB.0 auf 1, um die Motoransteuerung freizuschalten.
2.
Tragen Sie über Registerkommunikation das Kommando 0x0530 in Register R7 ein, um die Selbstjustierung zu aktivieren.
3.
Aktivieren Sie unter Verwendung von Bit CW.0 bis CW.4 im Control-Wort ein Latchereignis, um die Referenz-Position zu latchen.
4.
Tragen Sie einen Geschwindigkeitswert in das Prozessdatenwort DataOUT ein, um den Motor zur Referenzposition zu fahren.
5.
Die Klemme setzt das Bit SW.4 nachdem die Referenzposition überfahren wurde.
6.
Setzen Sie die Geschwindigkeit im Prozessdatenwort DataOUT auf null und löschen Sie die Latchfreigabe (die Referenzposition wird jetzt erst gespeichert).
7.
Tragen Sie einen entgegengesetzten Geschwindigkeitswert in das Prozessdatenwort DataOUT ein, um den Motor wieder auf die Ausgangsposition zu fahren.
8.
An der Ausgangsposition angekommen, aktivieren Sie im Control-Wort wieder das Latchereignis, mit dem zuvor referenziert wurde.
9.
Tragen Sie jetzt über Prozessdatenkommunikation einen Geschwindigkeitswert in DataOUT ein, um den Motor wieder über den Latchpunkt zu fahren.
10.
Setzen Sie jetzt über Prozessdatenkommunikation die Geschwindigkeit auf null und löschen Sie die Latchfreigabe (die aktuelle Position wird jetzt korrigiert).
11.
Tragen Sie über Registerkommunikation das Stop-Kommando 0x0540 in Register R7 ein, um die Selbstjustierung zu deaktivieren.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Einbaulagen bei Betrieb mit und ohne Lüfter
•
Anschluss
•
UL Hinweise - Compact Motion
•
KL2531 - Anschluss
•
KL2531 - Allgemeine Anschlussbeispiele
•
KL2541 - Anschluss
•
KL2541 - Allgemeine Anschlussbeispiele


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Einbaulagen bei Betrieb mit und ohne Lüfter

Montage und Verdrahtung [image] Einbaulagen bei Betrieb mit und ohne Lüfter
Einbaulagen bei Betrieb mit und ohne Lüfter
Achtung
Einschränkung von Einbaulage und Betriebstemperaturbereich
Sorgen Sie bei der Montage der Klemmen dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Vorgeschriebene Einbaulage bei Betrieb ohne Lüfter
Für die vorgeschriebene Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände Einbaulage bei Betrieb ohne Lüfter“).
Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht.
Empfohlene Abstände Einbaulage bei Betrieb ohne Lüfter
Die Einhaltung der Abstände nach der obigen Abbildung wird dringend empfohlen!
Weitere Hinweise zum Betrieb ohne Lüfter sind ggf. den Technischen Daten der Klemme zu entnehmen.
Standard-Einbaulage bei Betrieb mit Lüfter
Für die Standard-Einbaulage beim Betrieb mit Lüfter wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Betrieb mit Lüfter“). Die Klemmen werden dabei unterstützend vom z. B. ZB8610 Lüftermodul von unten nach oben durchlüftet.
Empfohlene Abstände bei Betrieb mit Lüfter
Weitere Einbaulagen
Durch die verstärkende Wirkung auf die Kühlung der Klemmen durch den Lüfter sind ggf. weitere Einbaulagen zulässig (siehe Abb. „Weitere Einbaulagen, Beispiel 1 und 2“); entnehmen Sie entsprechende Hinweise bitte den Technischen Daten der Klemme.

Weitere Einbaulagen, Beispiel 1
Weitere Einbaulagen, Beispiel 2


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Hinweis
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Hinweis
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Hinweis
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


UL Hinweise - Compact Motion

Montage und Verdrahtung [image] UL Hinweise - Compact Motion
UL Hinweise - Compact Motion
Symbol cULus
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
Symbol cULus
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
Symbol cULus
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Symbol cULus
Notes on motion devices
•
Motor overtemperature
Motor overtemperature sensing is not provided by the drive.
•
Application for compact motion devices
The modules are intended for use only within Beckhoff’s Programmable Controller system Listed in File E172151.
•
Galvanic isolation from the supply
The modules are intended for operation within circuits not connected directly to the supply mains (galvanically isolated from the supply, i.e. on transformer secondary).
•
Requirement for environmental conditions
For use in Pollution Degree 2 Environment only.
Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:
1. UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
2. UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen
Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


KL2531 - Anschluss

Montage und Verdrahtung [image] KL2531 - Anschluss
KL2531 - Anschluss
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL2531-0000 - Anschluss
Klemmstelle | Nr. | Anschluss
A1 | 1 | Motorwicklung A
B1 | 2 | Motorwicklung B
Sense A | 3 | Motorwicklung A
Input 1 | 4 | Digitaler Eingang 1 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Wort das Bit CW.1 gesetzt ist und eine steigende Flanke am digitalen Eingang 1 auftritt.
A2 | 5 | Motorwicklung A
B2 | 6 | Motorwicklung B
Sense B | 7 | Motorwicklung B
Input 2 | 8 | Digitaler Eingang 2 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Wort das Bit CW.2 gesetzt ist und eine steigende Flanke am digitalen Eingang 2 auftritt.
Hinweis
Anschlussbeispiele
Beachten Sie die Anschlussbeispiele für die KL2531.


KL2531 - Allgemeine Anschlussbeispiele

Montage und Verdrahtung [image] KL2531 - Allgemeine Anschlussbeispiele
KL2531 - Allgemeine Anschlussbeispiele
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Achtung
Motorstränge korrekt anschließen!
•
den einen Motorstrang an die Klemmpunkte A1 und A2,
•
den anderen Motorstrang an die Klemmpunkte B1 und B2.
Anschlussarten
Die Schrittmotorklemme KL2531 hat bipolare Endstufen und kann damit bipolare und unipolare Motoren ansteuern.
Bipolaren Motoren
Bipolare Ansteuerung (seriell) eines bipolaren Motors
Bipolare Ansteuerung (parallel) eines bipolaren Motors
KL2531 - Bipolare Ansteuerung seriell (links) und parallel (rechts) eines bipolaren Motors
Hinweis
Dokumentation zu Schrittmotoren von Beckhoff
Diese beiden Beispiele zeigen den Anschluss der bipolaren Beckhoff-Motoren AS1010, AS1020 oder AS1030. Weitere Informationen zu Schrittmotoren von Beckhoff finden Sie in der zugehörigen Dokumentation, die auf unserer Internetseite http://www.beckhoff.de unter Download zur Verfügung steht.
Unipolare Motoren
Bipolare Ansteuerung eines unipolaren Motors
KL2531 - Bipolare Ansteuerung eines unipolaren Motors
Nur eine Hälfte jeder Wicklung wird angesteuert.


KL2541 - Anschluss

Montage und Verdrahtung [image] KL2541 - Anschluss
KL2541 - Anschluss
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL2541-0000 - Anschluss
Klemmstellen - Linker Gehäuseteil
Klemmstelle
Nr.
Anschluss
A
1
Encoder-Eingang A
C
2
Encoder-Eingang C (Nulleingang). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Wort das Bit CW.0 gesetzt ist und eine steigende Flanke am Encoder-Eingang C auftritt.
Encoder-Versorgung +
3
KL2541-0000: 24 V Encoder-Versorgung (von positivem Powerkontakt)
KL2541-0006: 5 V Encoder-Versorgung (wird aus positivem Powerkontakt erzeugt)
Input 1
4
Digitaler Eingang 1 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Wort das Bit CW.1 gesetzt ist und eine steigende Flanke am digitalen Eingang 1 auftritt.
B
5
Encoder-Eingang B
Latch/Gate
6
Latch-Eingang. Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Wort
▪
das Bit CW.3 gesetzt ist und eine steigende Flanke am Latch-Eingang auftritt oder
▪
das Bit CW.4 gesetzt ist und eine fallende Flanke am Latch-Eingang auftritt.
Der Counter kann durch diesen Eingang gesperrt werden, wenn
▪
das Feature-Bit RP0.R32.12 gesetzt ist und der Latch/Gate-Eingang auf Low-Potential ist, oder
▪
das Feature-Bit RP0.R32.13 gesetzt ist und der Latch/Gate-Eingang auf High-Potential ist
Ein gesperrter Zähler wird durch das Status-Bit SW.7 von der Klemme zur Steuerung gemeldet.
Encoder-Versorgung 0 V
7
Encoder-Versorgung (von negativem Powerkontakt)
Input 2
8
Digitaler Eingang 2 (24 VDC). Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn im Control-Wort das Bit CW.2 gesetzt ist und eine steigende Flanke am digitalen Eingang 2 auftritt.
Klemmstellen - Rechter Gehäuseteil
Klemmstelle | Nr. | Anschluss für
A1 | 1' | Motorwicklung A
B1 | 2' | Motorwicklung B
Sense A | 3' | Motorwicklung A
Motorversorgung | 4' | Einspeisung für Endstufen (maximal +50 VDC)
A2 | 5' | Motorwicklung A
B2 | 6' | Motorwicklung B
Sense B | 7' | Motorwicklung B
Motorversorgung | 8' | Einspeisung für Endstufen (0 VDC)
Hinweis
Anschlussbeispiele
Beachten Sie die Anschlussbeispiele für die KL2541.
Power-Kontakte
Die Powerkontakte (+24 VDC) versorgen folgende Verbraucher:
▪
Inkremental-Encoder (Klemmstelle 3 und 7)
▪
digitale Eingänge (Klemmstelle 4 und 8)
▪
Ausgangstreiber der Schrittmotorklemme
Hinweis
Einschalt-Reihenfolge der Versorgungsspannungen
Die Spannung an den Power-Kontakten muss beim Einschalten der K-Bus-Spannung schon anliegen, damit interne Schaltkreise (Ausgangstreiber) initialisiert werden können. Ist das applikationsbedingt nicht möglich (Versorgung wird z. B. über Not-Aus-Kreis geschaltet), müssen Sie nach dem Hochfahren des Systems einen Software-Reset der Klemme durchführen (siehe Kommando 0x8000).
Ab der Firmware-Version 2D wird ein Ausfall der Steuerspannung (24 V, aus den Power-Kontakten) erkannt und durch Bit SW.14 dargestellt. Das Wiederkehren der Steuerspannung wird automatisch erkannt und eine Initialisierung wird durchgeführt.
WARNUNG
Motor stoppt nicht bei Ausfall der K-Bus-Spannung!
Falls die K-Bus-Spannung (5 V) ausfällt, wird der Motor-Controller nicht zurückgesetzt! D. h. wenn der Motor in Bewegung ist, wird er nicht gestoppt!


KL2541 - Allgemeine Anschlussbeispiele

Montage und Verdrahtung [image] KL2541 - Allgemeine Anschlussbeispiele
KL2541 - Allgemeine Anschlussbeispiele
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Achtung
Motorstränge korrekt anschließen!
•
den einen Motorstrang an die Klemmpunkte A1 und A2,
•
den anderen Motorstrang an die Klemmpunkte B1 und B2.
⇨
Wenn Sie einen Motorstrang an die Klemmpunkte verschiedener Ausgangstreiber (z. B. an A1 und B1) anschließen, kann dies die Ausgangstreiber der Schrittmotorklemme zerstören!
Anschlussarten
Die Schrittmotorklemme KL2541 hat bipolare Endstufen und kann damit bipolare und unipolare Motoren ansteuern.
Bipolaren Motoren
Bipolare Ansteuerung (seriell) eines bipolaren Motors
Bipolare Ansteuerung (parallel) eines bipolaren Motors
KL2541 - Bipolare Ansteuerung seriell (links) und parallel (rechts) eines bipolaren Motors
Hinweis
Dokumentation zu Schrittmotoren von Beckhoff
Diese beiden Beispiele zeigen den Anschluss der bipolaren Beckhoff-Motoren AS1010, AS1020, AS1030, AS1050 oder AS1060.
Weitere Informationen zu Schrittmotoren von Beckhoff finden Sie in der zugehörigen Dokumentation, die auf unserer Internetseite http://www.beckhoff.de unter Download zur Verfügung steht.
Unipolare Motoren
Bipolare Ansteuerung eines unipolaren Motors
KL2541 - Bipolare Ansteuerung eines unipolaren Motors
Nur eine Hälfte jeder Wicklung wird angesteuert.
Encoder
Anschluss eines Encoders (24 V)
KL2541 - Anschluss eines Encoders
Der Encoder wird über die Klemmstellen 3 (+24 V) und 7 (0 V) aus den Powerkontakten versorgt.


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung
•
Parametrierung mit KS2000
•
Register
•
Einstellungen 1
•
Einstellungen 2
•
Einstellungen - Stromtabelle
•
Einstellungen - Berechnungen
•
Einstellungen - Inbetriebnahme
•
Prozessdaten


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Parametrierung mit KS2000

Konfigurations-Software KS2000 [image] Parametrierung mit KS2000
Parametrierung mit KS2000
Verbinden Sie Konfigurationsschnittstelle Ihres Feldbuskopplers über das Konfigurationskabel mit der seriellen Schnittstelle Ihres PCs und starten Sie die Konfigurations-Software KS2000.
Klicken Sie auf den Button Login. Die Konfigurations-Software lädt nun die Informationen der angeschlossenen Feldbusstation.
Im dargestellten Beispiel ist dies:
▪
ein Buskoppler für Ethernet BK9000
▪
eine digitale Eingangsklemme KL1xx2
▪
eine einkanalige Schrittmotorklemme KL2531
▪
eine Bus-Endklemme KL9010
Darstellung der Feldbusstation in KS2000
Das linke Fenster der KS2000 zeigt die Klemmen der Feldbusstation in einer Baumstruktur an.
Das rechte Fenster der KS2000 zeigt die Klemmen der Feldbusstation grafisch an.
Klicken Sie nun in der Baumstruktur des linken Fensters auf das Plus-Zeichen vor der Klemme, deren Parameter sie verändern möchten (Im Beispiel Position 2).
KS2000 Baumzweige für Kanal 1 der KL2531
Für die KL2531 oder KL2541 werden die Baumzweige Register, Einstellungen und ProcData angezeigt:
▪
Register erlaubt den direkten Zugriff auf die Register der KL2531/KL2541.
▪
Unter Einstellungen finden Sie Dialogmasken zur Parametrierung der KL2531/KL2541.
▪
ProcData zeigt die Prozessdaten der KL2531/KL2541.


Register

Konfigurations-Software KS2000 [image] Register
Register
Unter Register können Sie direkt auf die Register der KL2531/KL2541 zugreifen. Die Bedeutung der Register entnehmen Sie bitte der Registerübersicht.
Registeransicht in KS2000


Einstellungen 1

Konfigurations-Software KS2000 [image] Einstellungen 1
Einstellungen 1
Karteireiter Einstellungen 1 zur Parametrierung der KL2531 und KL2541
Einstellungen über KS2000
Betriebsart:
▪
Betriebsart (RP0.R32.4, RP0.R32.3)
Wählen Sie hier die Betriebsart der Schrittmotorklemme aus:
–
Geschwindigkeit, direkt
–
Geschwindigkeit, mit Rampen
–
Positionsnachführung
–
Fahrwegsteuerung: Manuell, Fahrauftrag
In Abhängigkeit der ausgewählten Betriebsart, stehen Ihnen unter Allgemein, Encoder (s. Einstellungen 2) und Registerwerte verschiedene Parameter zur Konfiguration der Schrittmotorklemmen zur Verfügung.
▪
Rampen
In der Betriebsart Fahrwegsteuerung können Sie zusätzlich die Rampenart (RP0.R32.5) festlegen:
–
Rampen linear
–
Rampen exponentiell (beim Verzögern)
Diese Einstellung ist nur während eines Fahrauftrags aktiv. In der Betriebsart Geschwindigkeit, mit Rampen und im manuellen Modus der Betriebsart Fahrwegsteuerung wird immer mit linearen Rampen beschleunigt.
Allgemein:
▪
Watchdog Timer aktiv (RP0.R32.2)
Hier können Sie den Watchdog deaktivieren (Default: aktiviert).
Wenn die Schrittmotorklemme bei aktivem Watchdog für 100 ms keine Prozessdaten von der Steuerung empfängt, löst der Watchdog aus und der Motor wird gestoppt.
▪
Auto-Start-Funktion aktiv (RP0.R32.0)
Hier können Sie die Auto-Start-Funktion aktivieren.
Dieses Feature ist nur in der Betriebsart Fahrwegsteuerung verfügbar (Default: deaktiviert).
▪
Auto-Stopp-Funktion aktiv (RP0.R32.1)
Hier können Sie die Auto-Stopp-Funktion aktivieren.
Dieses Feature ist nur in der Betriebsart Fahrwegsteuerung verfügbar (Default: deaktiviert).
▪
Verzögerung aktiv (RP0.R52.1)
Hier können Sie die Verzögerungsrampe aktivieren.
Dieses Feature ist nur in der Betriebsart Fahrwegsteuerung verfügbar (Default: deaktiviert).
▪
Latch-Ereignis löscht Zähler (RP0.R32.8)
Hier können Sie aktivieren, dass das Auftreten eines Latch-Ereignisses bei aktivem CW.13 den Zähler löscht (Default: deaktiviert).
▪
mehrfache Latch-Werte speichern (RP0.R32.9)
Hier können Sie die Speicherung mehrfacher Latch-Werte aktivieren (Default: deaktiviert).
Die Anzahl der Latch-Werte wird durch Register R37 vorgegeben.
▪
digitalen Eingang 1 für Öffner invertieren (RP0.R52.14)
Hier können Sie den digitalen Eingang 1 für Öffner invertieren (Default: deaktiviert, d. h. für Schließer konfiguriert).
▪
digitalen Eingang 2 für Öffner invertieren (RP0.R52.15)
Hier können Sie den digitalen Eingang 2 für Öffner invertieren (Default: deaktiviert, d. h. für Schließer konfiguriert).
▪
Positionsregister latchen (RP0.R52.2)
Hier können Sie die Latchfunktion der Positionsregister R0 und R1 aktivieren (Default: deaktiviert).
▪
Idle-Status einblenden (RP0.R52.3)
Hier können Sie die Anzeige des Idle-Bits im Status-Byte aktivieren (SB.4) (Default: deaktiviert).
▪
Positionsrückführung invertieren (RP0.R32.6)
Hier können Sie die Positionsrückführung invertieren, falls z. B. der Positionswert von einem Encoder stammt, der dem Schrittmotor auf einer Welle gegenüber montiert ist (Default: deaktiviert).
▪
Positionsrückführung mit Encoder (nur KL2541) (RP0.R32.11)
Hier können Sie den Encoder-Eingang der KL2541 deaktivieren (Default: aktiviert).
Gleichzeitig wird dadurch die interne Positionserfassung aktiviert.
Registerwerte:
▪
max. Spulenstrom A (RP0.R35)
Hier können Sie die Strombegrenzung für Wicklung A in 0 bis 100 % vom Nennstrom der Klemme festlegen (Default: 100%).
KL2531-0000: 100% = 1,5 A
KL2541-0000: 100% = 5,0 A
▪
max. Spulenstrom B (RP0.R36)
Hier können Sie die Strombegrenzung für Wicklung B in 0 bis 100 % vom Nennstrom der Klemme festlegen (Default: 100%).
KL2531-0000: 100% = 1,5 A
KL2541-0000: 100% = 5,0 A
▪
Anzahl Latch-Werte (RP0.R37)
Wenn Sie zuvor die Option mehrfache Latch-Werte speichern aktiviert haben, können Sie hier die Anzahl der gespeicherten Latch-Werte vorgeben (Default: 20, Maximum: 20).
▪
min. Geschwindigkeit vmax (RP0.R38)
Hier können Sie für die Betriebsart Fahrwegsteuerung die Auslaufgeschwindigkeit vorgeben (Default: 10dez).
Die Auslaufgeschwindigkeit ist die höchste Geschwindigkeit, aus der der Schrittmotor ohne Schrittfehler direkt anhalten kann. Sie ist abhängig vom Haltemoment des Motors und der mit dessen Welle rotierenden Masse.
▪
max. Geschwindigkeit vmin (RP0.R39)
Hier können Sie für die Betriebsarten Geschwindigkeit, mit Rampen und Fahrwegsteuerung die maximale Geschwindigkeit vorgeben (Default: 2047, Maximum: 2047).
▪
max. Beschleunigung aacc (RP0.R40)
Hier können Sie für die Betriebsarten Geschwindigkeit, mit Rampen und Fahrwegsteuerung die maximale Beschleunigung vorgeben (Default: 2047, Maximum: 2047).
▪
max. Verzögerung adec (RP0.R58)
Hier können Sie für die Betriebsarten Geschwindigkeit, mit Rampen und Fahrwegsteuerung die maximale Verzögerung vorgeben (Default: 2047, Maximum: 2047).
▪
max. Beschleunigung für Notfall ae (RP0.R50)
Hier können Sie für die Betriebsart Fahrwegsteuerung die maximale Notfallbeschleunigung vorgeben (Default: 2047, Maximum: 2047).
Bei steigender Flanke von Bit CB.1 wird der Motor mit der Notfallbeschleunigung zum Stehen gebracht. Dies geschieht ebenfalls bei steigender Flanke an den digitalen Eingängen 1 oder 2 wenn die Auto-Stopp-Funktion aktiviert ist (RP0.R32.1 = 1bin und CB.5 = 1bin).
▪
Beschleunigungs-Schwelle ath (RP0.R41)
Hier können Sie die Beschleunigungs-Schwelle festlegen (Default: 1023, Maximum: 2047).
▪
Lastwinkel-Schwelle (RP0.R47)
Hier können Sie die Lastwinkel-Schwelle festlegen, ab der die LED Stall Detect zu blinken beginnt. (Default: 7, Maximum: 7).
Der Lastwinkel ist ein Maß für die Belastung des Motors. Er wird mit Werten von 0 bis 7 angezeigt, wobei 7 die höchste Belastung darstellt.
▪
Spulenstrom für a > ath (RP0.R42)
Hier können Sie für den Fall, dass die momentane Beschleunigung größer als die Beschleunigungsschwelle ist, den Spulenstrom in 0 bis 100 % festlegen (Default: 100%). Dieser Wert bezieht sich auf den eingestellten Spulenstrom der Klemme.
a: aktuelle Beschleunigung
ath: Beschleunigungsschwelle
▪
Spulenstrom für a ≤ ath (RP0.R43)
Hier können Sie für den Fall, dass die momentane Beschleunigung kleiner oder gleich der Beschleunigungsschwelle ist, den Spulenstrom in 0 bis 100 % festlegen (Default: 100%). Dieser Wert bezieht sich auf den eingestellten Spulenstrom der Klemme.
▪
Spulenstrom für v = 0 (automatisch) (RP0.R44)
Hier können Sie den automatischen Haltestrom vorgeben (Default: 50%).
Bei Stillstand des Motors werden die Spulenströme automatisch auf diesen Wert reduziert, um eine unnötige Erwärmung des Motors zu vermeiden. Dieser Wert bezieht sich auf den eingestellten Spulenstrom der Klemme.
▪
Spulenstrom für v = 0 (manuell) (RP0.R45)
Hier können Sie den manuellen Haltestrom vorgeben (Default: 50%).
Bei gesetztem Control-Bit CB.3 oder CW.11 können die Spulenströme manuell auf diesen Wert reduziert werden, um eine unnötige Erwärmung des Motors zu vermeiden. Dieser Wert bezieht sich auf den eingestellten Spulenstrom der Klemme. Der automatisch und der manuell reduzierte Spulenstrom addieren sich nicht! Der manuelle Wert hat eine höhere Priorität als der automatische Wert!
▪
Anzahl Impulse pro Umdrehung (Motor) (RP0.R51)
Tragen Sie hier die Anzahl der Sensoren ein, mit der die Bewegung des Motors kontrolliert wird (Default: 1). Dieser Faktor geht mit in die Berechnung des Positionsfehlers ein.
▪
Vollschritte pro Umdrehung (Motor) (RP0.R33)
Tragen Sie hier die Anzahl der Vollschritte ein, die der angeschlossenen Schrittmotor für eine volle Umdrehung benötigt (Default: 200).
▪
Inkremente pro Umdrehung (Encoder), nur KL2541 (RP0.R34)
Tragen Sie hier die Anzahl der Inkremente ein, die der an die KL2541 angeschlossene Encoder bei einer vollen Umdrehung ausgibt (Default: 4000).


Einstellungen 2

Konfigurations-Software KS2000 [image] Einstellungen 2
Einstellungen 2
Karteireiter Einstellungen 2 zur Parametrierung der KL2531 und KL2541
Einstellungen 2 über KS2000
Referenzierung:
Diese Parameter sind nur in der Betriebsart Fahrwegsteuerung verfügbar.
▪
Richtung der Referenzfahrt umkehren (RP0.R52.0)
Hier können Sie die Richtung der Referenzfahrt umkehren (Default: deaktiviert).
▪
Referenzeingang 1 aktiv (RP0.R52.4)
Hier können Sie den Referenzeingang 1 deaktivieren (Default: aktiviert).
▪
Referenzeingang 2 aktiv (RP0.R52.5)
Hier können Sie den Referenzeingang 2 deaktivieren (Default: aktiviert).
▪
vref,b auf die Nocke, Referenziergeschwindigkeit rückwärts (RP0.R53)
Hier können Sie für die Referenzfahrt die Geschwindigkeit festlegen, mit der der Motor auf die Nocke zu fährt (Default: 500dez).
Rückwärts bedeutet hier, die Klemme steuert den Motor mit abfallenden Positionswerten.
▪
vref,f auf die Nocke, Referenziergeschwindigkeit vorwärts (RP0.R54)
Hier können Sie für die Referenzfahrt die Geschwindigkeit festlegen, mit der der Motor von der Nocke weg fährt (Default: 50dez).
Vorwärts bedeutet hier, die Klemme steuert den Motor mit ansteigenden Positionswerten.
▪
Referenzposition (RP0.R55 RP0.R56)
Hier können Sie für die Referenzfahrt die Referenzposition festlegen (Default: 0).
Encoder (nur KL2541):
▪
Counter-Modus aktiv (RP0.R32.15)
Hier können Sie den Counter-Modus aktivieren (Default: deaktiviert). Bei aktiviertem Counter-Modus arbeitet der Encoder-Eingang der KL2541 als 32 Bit Vorwärts/Rückwärts-Zähler (A-Signal=Takt, B-Signal=Richtung, C-Signal=Freigabe).
▪
Eingangsfilter aktiv (RP0.R32.14)
Hier können Sie den Eingangsfilter für die Encoder-Signale deaktivieren (Default: aktiv).
▪
Encoder-Signale einblenden (RP0.R32.10)
Für die KL2541 können Sie hier das Einblenden der Signale
–
des C-Eingangs in das Bit SW.6
–
des Gate-Eingangs in das Bit SW.7
des Statusworts aktivieren (default: deaktiviert). Das Acknowledge-Bit LatchDataToggled zu CW.6 und das Bit EncoderDisabled entfallen dann.
▪
positiver Pegel am Gate sperrt den Zähler (RP0.R32.13)
Hier können Sie das Sperren des Zählers durch einen positiven Pegel am Gate-Eingang der KL2541 aktivieren (Default: deaktiviert).
▪
negativer Pegel am Gate sperrt den Zähler (RP0.R32.12)
Hier können Sie das Sperren des Zählers durch einen negativen Pegel am Gate-Eingang der KL2541 aktivieren (Default: deaktiviert).
Zielpositionen:
Hier können Sie 16 Zielpositionen für die Betriebsart Fahrwegsteuerung vorgeben. Diese Parameter sind nur in der Betriebsart Fahrwegsteuerung verfügbar.
▪
Position 0 (RP2.R32 RP2.R33)
Hier können Sie die Zielposition 0 vorgeben (Default: 0).
▪
Position 1 (RP2.R34 RP2.R35)
Hier können Sie die Zielposition 1 vorgeben (Default: 0).
usw.
▪
Geschwindigkeit 0 (RP3.R32)
Hier können Sie die Geschwindigkeit vorgeben, mit der Zielposition 0 angefahren wird (Default: 2047).
▪
Geschwindigkeit 1 (RP3.R33)
Hier können Sie die Geschwindigkeit vorgeben, mit der Zielposition 0 angefahren wird (Default: 2047).
usw.
▪
Beschleunigung 0 (RP3.R48)
Hier können Sie die Beschleunigung vorgeben, die beim Anfahren auf Geschwindigkeit 0 benutzt wird (Default: 2047).
▪
Beschleunigung 1 (RP3.R49)
Hier können Sie die Beschleunigung vorgeben, die beim Anfahren auf Geschwindigkeit 1 benutzt wird (Default: 2047).
usw.


Einstellungen - Stromtabelle

Konfigurations-Software KS2000 [image] Einstellungen - Stromtabelle
Einstellungen - Stromtabelle
Karteireiter Stromtabelle zur Parametrierung der KL2531 und KL2541.
Karteireiter Stromtabelle in KS2000
Die erste Viertelperiode kann in bis zu 64 Schritten vorgegeben werden. Für jeden Schritt können Sie mit den untenstehenden Auswahlfeldern einen Stromwert zwischen 0 und 15 vorgeben.
Die für die erste Viertelperiode vorgegebenen Stromwerte werden (bei entsprechender Vorzeichenanpassung) automatisch für die restlichen 3 Viertelperioden übernommen.
▪
Schrittweite (RP0.R46)
Wählen Sie hier aus, in wie vielen Schritten Sie die Viertelperiode vorgeben möchten (s. Abb. Beispiele Schrittweite).
Schrittweite | 1/64 | 1/32 | 1/16 | 1/8 | 1/4 | 1/2 (Halbschritt) | 1/1 (Vollschritt)
Schritte/Viertelperiode | 64 | 32 | 16 | 8 | 4 | 2 | 1
▪
Stromwerte
Bei Auswahl der Schrittweite 1/64 können Sie die Stromwerte manuell vorgeben. Sie werden in der Anwender-Stromtabelle abgelegt.
Bei Auswahl aller anderen Schrittweiten ist nur der sinusförmige Kurvenverlauf vorgesehen.
▪
Manuelle Vorgabe der Stromwerte
Die Vorgabe der Stromwerte erfolgt in vier Gruppen zu je 16 Stromwerten. Wählen Sie hier aus, welche Gruppe Sie mit den 16 untenstehenden Auswahlfeldern parametrieren möchten:
1 - 16
17 - 32
33 - 48
49 - 64
Die eingetragenen Werte werden erst zur Klemme übertragen und in der Anwender-Stromtabelle hinterlegt, wenn Sie die Schaltfläche [image] drücken.
▪
Stromtabelle aktiv (RP0.R32.7)
Mit diesem Optionsfeld können Sie die Anwender-Stromtabelle anstelle der internen Stromtabelle aktivieren.
–
Die interne Stromtabelle gibt einen sinusförmigen Verlauf fest vor. Sie können nur die Schrittweite frei bestimmen.
–
Die Anwender-Stromtabelle können Sie (bei Auswahl der Schrittweite 1/64) mit den untenstehenden Auswahlfeldern frei editieren.
▪
neu Laden
Liest die in der Klemme abgespeicherten Werte (RP1.R32 bis RP1.R47) aus und zeigt sie an.
▪
Sinus
Gibt einen sinusförmigen Verlauf vor.
Beispiele
KL2541 - Beispiele für Einstellungen der Stromtabelle mit KS2000


Einstellungen - Berechnungen

Konfigurations-Software KS2000 [image] Einstellungen - Berechnungen
Einstellungen - Berechnungen
Die Registerkarte Berechnungen ist nur in den Betriebsarten Geschwindigkeit, mit Rampen und Fahrwegsteuerung verfügbar.
Dieser Dialog berechnet aus den Anwendungsparametern (u. A. Registerwerte der Schrittmotorklemme) die Motorparameter und stellt diese dann anschaulich dar. Diese Berechnungen stehen Ihnen auch als Excel Tabelle zur Verfügung. Zur Nutzung dieser Excel-Tabelle, muss in Excel die Ausführung von Makros erlaubt sein!
Excel Tabelle ( )
Registerkarte Berechnungen
Anwendungsparameter:
▪
maximaler Spulenstrom (RP0.R35)
Strombegrenzung für Wicklung A und B. Voreingetragen ist ein Wert, berechnet aus den im Dialog Einstellungen eingetragenen maximalen Spulenstrom A (in %) und dem maximalen Nennstrom der Schrittmotorklemme.
▪
Vorschub pro Umdrehung
Tragen Sie hier einen Wert ein (Parameter der angeschlossenen Mechanik), der dann zur Berechnung der Motorparameter benutzt wird. Dieser Wert wird nicht zur Schrittmotorklemme übertragen und nur zur Veranschaulichung der Motorparameter benutzt.
▪
Vollschritte pro Umdrehung (Motor) (RP0.R33)
Voreingetragen ist der Wert aus dem Dialog Einstellungen.
▪
Inkremente pro Umdrehung (Encoder), nur KL2541 (RP0.R34)
Voreingetragen ist der Wert aus dem Dialog Einstellungen.
▪
min. Geschwindigkeit (R38)
Voreingetragen ist der Wert aus dem Dialog Einstellungen. Dieser Wert wird für die Betriebsart Fahrwegsteuerung verwendet und in den Dialog Inbetriebnahme übernommen.
▪
max. Geschwindigkeit (R39)
Voreingetragen ist der Wert aus dem Dialog Einstellungen. Dieser Wert wird für die Betriebsart Fahrwegsteuerung verwendet und in den Dialog Inbetriebnahme übernommen.
▪
max. Beschleunigung (R40)
Voreingetragen ist der Wert aus dem Dialog Einstellungen. Dieser Wert wird für die Betriebsart Fahrwegsteuerung verwendet und in den Dialog Inbetriebnahme übernommen.
▪
max. Verzögerung (R58)
Voreingetragen ist der Wert aus dem Dialog Einstellungen. Dieser Wert wird für die Betriebsart Fahrwegsteuerung verwendet und in den Dialog Inbetriebnahme übernommen.
▪
Prozessdaten
In dieses Feld können Sie ein Prozessdatum (dezimal) eintragen, das dann zur Berechnung der resultierenden Geschwindigkeit, bei gegebenen Motorparametern, benutzt wird. Dieses Prozessdatum wird nicht zur Schrittmotorklemme übertragen und nur zur Veranschaulichung der Motorparameter benutzt.
Motorparameter:
▪
Spulenstrom
Gibt den maximalen Spulenstrom in Prozent (RP0.R35 und RP0.R36) vom maximalen Nennstrom der Schrittmotorklemme an.
▪
min. GeschwindigkeitDarstellung der Auslaufgeschwindigkeit (in der Betriebsart: Fahrwegsteuerung)
–
als Vorschubgeschwindigkeit
–
in Vollschritten pro Sekunde
–
als dezimaler Registerwert (R38)
▪
max. Geschwindigkeit
Darstellung der maximalen Geschwindigkeit
–
als Vorschubgeschwindigkeit
–
in Vollschritten pro Sekunde
–
als dezimaler Registerwert (R39)
▪
max. Beschleunigung
Darstellung der maximalen Beschleunigung
–
als Vorschubgeschwindigkeit
–
in Vollschritten pro Sekunde zum Quadrat
–
als dezimaler Registerwert (R40)
▪
max. Verzögerung
Darstellung der maximalen Beschleunigung
–
als Vorschubgeschwindigkeit
–
in Vollschritten pro Sekunde zum Quadrat
–
als dezimaler Registerwert (R58)
▪
empfohlene Schrittweite
Dieser Wert schlägt die kleinstmögliche Schrittweite, bei gegebenen Anwendungsparametern, vor. Die Schrittweite kann vom Anwender ggf. vergrößert werden. Dabei muss aber beachtet werden, dass die Geschwindigkeitsvorgabe durch die Prozessdaten eine neue Berechnung erfordert.
▪
Vollschrittwinkel
Gibt den resultierenden Winkel für einen Vollschritt an.
▪
Mikroschrittwinkel
Gibt den resultierenden Winkel für einen Mikroschritt an.
▪
Mikroschritte pro Umdrehung
Gibt die Anzahl der Mikroschritte an, die für eine volle Umdrehung der Motorwelle benötigten werden.
▪
aktuelle Geschwindigkeit
Gibt die, für den unter Prozessdaten eingetragenen Wert und den gegebenen Anwendungsparametern, resultierende Geschwindigkeit an.
▪
Skalierungsfaktor (SF)
Wird berechnet nach der Formel:
SF = Vorschub/Umdrehung / (Vollschritte/Umdrehung x Schrittweite)
▪
Bezugsgeschwindigkeit (vref)
Wird berechnet nach der Formel:
vref = SF x DataOUTmax x 3,812951 = SF x 32767 x 3,812951
(Siehe Kapitel Berechnung der Geschwindigkeit)


Einstellungen - Inbetriebnahme

Konfigurations-Software KS2000 [image] Einstellungen - Inbetriebnahme
Einstellungen - Inbetriebnahme
Karteireiter Inbetriebnahme zur Parametrierung der Schrittmotor-Ansteuerung durch die KL2531/2541.
WARNUNG
Manuelles Steuern des Schrittmotors
Mit dieser Dialogmaske können Sie den Schrittmotor manuell steuern.
Stellen Sie sicher dass ihr Anlagenzustand das manuelle Anfahren des Schrittmotors erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
Die Registerkarte Inbetriebnahme ist nur in der Betriebsart Fahrwegsteuerung verfügbar.
KL2541, KL2531 - Registerkarte Inbetriebnahme
Lastwinkel
Der Lastwinkel gibt dem Anwender eine Aussage über die aktuelle mechanische Last, welche an der Achse des Motors herrscht.
Motor aktivieren / Motor deaktivieren
Mit dieser Schaltfläche wird das Enable-Bit CB.0 gesetzt bzw. gelöscht und dadurch der Motor freigeschaltet bzw. gesperrt.
Schaltfläche Motor aktivieren und Motor deaktivieren im Registerreiter Inbetriebnahme
Fehler löschen
Ist ein Fehler aufgetreten verfärbt sich die Schaltfläche rot. Der Fehler kann durch Drücken dieser Schaltfläche gelöscht werden.
Schaltfläche Fehler löschen im Registerreiter Inbetriebnahme
Status / Position
Die Ist-Position ist direkt gekoppelt mit den Prozesseingangsdaten DataIN. Die Soll-Position zeigt die aktuelle bzw. letzte Zielposition der Fahrwegsteuerung. Die Geschwindigkeit ist direkt gekoppelt mit den Prozessausgangsdaten DataOUT. Die exakte Berechnung in mm bzw. in mm/s geschieht durch die Anwendungsparameter in der Registerkarte Berechnungen. Diese Angaben müssen sorgfältig gemacht werden, um einen sinnvollen Betrieb des Inbetriebnahme-Werkzeuges zu gewährleisten!
Status - und Positionsanzeige im Registerreiter Inbetriebnahme
▪
Fehler
Das Status-Bit SB.6 wird hier dargestellt. Im Fehlerfall erscheint nach klicken auf die Fehleranzeige ein Meldungsfenster, das die aufgetretenen Fehler im Klartext anzeigt.
Statusanzeige Fehler im Registerreiter Inbebriebnahme
▪
Warnung
Das Status-Bit SB.5 wird hier dargestellt.
▪
Bereit
Das Status-Bit SB.0 wird hier dargestellt.
▪
Eingang 1 / Eingang 2
Das Status-Bits SW.0 und SW.1 werden hier dargestellt.
Geschwindigkeit
Einstellung der Geschwindigkeit im Registerreiter Inbetriebnahme
Mit dem Schieber können Sie die den Motor links- oder rechtsherum laufen lassen. Dabei erhöht sich seine Drehzahl stufenlos, je weiter Sie den Schieber aus der Mittelposition stellen.
Mit der Schaltfläche STOP können Sie den Motor wieder anhalten. Der Schieber springt dann auf die Mittelposition zurück.
Mit den Schaltflächen --, -, + und ++ können Sie den Motor manuell steuern. Der Motor dreht sich, solange Sie die Schaltfläche gedrückt halten:
- - | langsamer Linkslauf (hält man den Button gedrückt, wird die Geschwindigkeit alle 3 Sekunden erhöht)
- | besonders langsamer Linkslauf
STOP | die Geschwindigkeit wird zu Null gesetzt bzw. ein aktiver Fahrauftrag wird gestoppt
+ | besonders langsamer Rechtslauf
++ | langsamer Rechtslauf (hält man den Button gedrückt, wird die Geschwindigkeit alle 3 Sekunden erhöht)
Fahrwegsteuerung
Die exakte Berechnung in mm, mm/s bzw. mm/s2 geschieht durch die Anwendungsparameter in der Registerkarte Berechnungen. Diese Angaben müssen sorgfältig gemacht werden, um einen sinnvollen Betrieb des Inbetriebnahme-Werkzeuges zu gewährleisten!
Einstellung der Fahrwegsteuerung im Registerreiter Inbetriebnahme
▪
Vmin - minimale Geschwindigkeit (R38)
Hier können Sie den Minimalwert für die Geschwindigkeit vorgeben.
Dieser Wert kann im Betrieb verändert werden und wird ins RAM der Klemme eingetragen.
▪
Vmax - maximale Geschwindigkeit (R39)
Hier können Sie den Maximalwert für die Geschwindigkeit vorgeben. Die Geschwindigkeit darf nicht größer als der vorgegebene Wert in der Registerkarte Berechnungen werden und wird deshalb automatisch begrenzt!
Dieser Wert kann im Betrieb verändert werden und wird ins RAM der Klemme eingetragen.
▪
Amax - maximale Beschleunigung (R40)
Hier können Sie den Maximalwert für die Beschleunigung vorgeben.
Dieser Wert kann im Betrieb verändert werden und wird ins RAM der Klemme eingetragen.
▪
Ziel-Position 1 / Ziel-Position 2
Hier können Sie die Werte für die Zielpositionen 1 und 2 vorgeben. Positive und negative Werte sind hier zulässig.
▪
Ist-Position
Hier können Sie den Wert für die Ist-Positionen vorgeben. Positive und negative Werte sind hier zulässig.
▪
Relative Positionierung
–
Wenn Sie das Kontrollkästchen relative Positionierung aktivieren, läuft der Motor bei jeder Betätigung einer Zielfahrt-Schaltfläche von der aktuellen Position aus um die in der zugehörigen Zielposition angegebene Strecke weiter.
–
Wenn das Kontrollkästchen relative Positionierung nicht aktiviert ist, läuft der Motor diese absoluten Ziel-Positionen direkt an, wenn Sie die Taste Zielfahrt 1 starten oder Zielfahrt 2 starten drücken.
WARNUNG
Schrittmotor läuft auf absolute Ziel-Position zurück!
Unter Verwendung der relativen Positionierung können Sie den Schrittmotor wiederholt um die Strecke weiterlaufen lassen, die unter Zielposition eingetragen ist.
Wenn Sie nun die relative Positionierung ausschalten und die Schaltfläche Zielfahrt starten erneut drücken, läuft der Schrittmotor auf seine absolute Ziel-Position zurück!
▪
Zielfahrt 1 starten / Zielfahrt 2 starten
Diese Schaltflächen starten die Zielfahrt 1, bzw. die Zielfahrt 2. Die Register R2 und R3 der Klemme werden mit der Zielposition 1 bzw. 2 beschrieben und der Fahrauftrag gestartet.
▪
Setzen
Diese Schaltfläche speichert den in Ist-Position eingetragenen Wert als neue Ist-Position der Klemme.
▪
Löschen
Diese Schaltfläche löscht die aktuelle Position und die aktuellen Latch-Werte.


Prozessdaten

Konfigurations-Software KS2000 [image] Prozessdaten
Prozessdaten
Unter ProcData werden das Status-Byte (Status), das Control-Byte (Ctrl) und die Prozessdaten (Data) in einer Baumstruktur dargestellt.
Prozessdaten - Darstellung der Prozessdaten in der Baumstruktur
Die Lesebrille markiert die Daten, die gerade im Feld Verlauf graphisch dargestellt werden.
Verlauf - graphischer Verlauf der in Prozessdaten mit der Lesebrille markierten Daten
Im Feld Wert wird der aktuelle Eingangswert numerisch dargestellt.
Wert - Anzeige der Eingangswerte
Ausgangswerte könne sie durch Eingabe oder über den Fader verändern.
Wert - Veränderung der Ausgangswerte
VORSICHT
Gefahr für Personen, Umwelt oder Geräte!
Beachten Sie, dass das Verändern von Ausgangswerten (Forcen) direkten Einfluss auf Ihre Automatisierungsanwendung haben kann.
Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, dass Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
Nach Drücken der Schaltfläche Einstellungen können Sie die numerische Darstellungsform auf hexadezimal, dezimal oder binär einstellen.
Einstellung der Darstellungsform


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessabbild
•
Control- und Status-Byte
•
Control- und Status-Wort
•
Registerübersicht
•
Registerbeschreibung
•
Beispiele für die Register-Kommunikation


Prozessabbild

Zugriff aus dem Anwenderprogramm [image] Prozessabbild
Prozessabbild
Hinweis
Kein kompaktes Prozessabbild
Ein Betrieb der KL2531 und KL2541 mit kompaktem Prozessabbild (ohne Control- und Status-Byte) ist nicht möglich, da Control- und Status-Byte für einen sinnvollen Prozessdatenbetrieb der Klemmen erforderlich sind. Auch wenn Sie Ihren Buskoppler auf kompaktes Prozessabbild einstellen, werden KL2531 und KL2541 mit ihrem kompletten Prozessabbild dargestellt!
Die KL2531-0000 und KL2541-0000 stellen sich im Prozessabbild mit mindestens 5 Byte Ein- und 5 Byte Ausgangsdaten dar. Diese sind wie folgt aufgeteilt:
Byte-0ffset (ohne Word-Alignment) | Byte-0ffset (mit Word-Alignment*) | Format | Eingangsdaten | Ausgangsdaten
0 | 0 | Byte | SB | CB
1 | 2 | Wort | DataIN | DataOUT
3 | 4 | Wort | SW | CW
*) Word-Alignment: Der Buskoppler legt Worte auf gerade Byte-Adressen
Legende
SB: Status-Byte
CB: Control-Byte
DataIN: Eingangsdatenwort (Ist-Position)
DataOUT: Ausgangsdatenwort (z. B. Soll-Geschwindigkeit, siehe Prozessdaten)
SW: zusätzliches Status-Wort
CW: zusätzliches Control-Wort
Prozessdaten
Die im Prozessdatenbetrieb in den Prozessdatenworten DataIN und DataOUT übertragenen Daten sind abhängig von der Betriebsart der Schrittmotorklemme.
Betriebsart | DataIN | DataOUT
Geschwindigkeit, direkt | Ist-Position (unteres Wort). Die komplette Ist-Position (32 Bit) kann über Registerkommunikation aus den Registern R0 und R1 ausgelesen werden. | Geschwindigkeitswert (15 Bit und Vorzeichen), siehe Formel
Geschwindigkeit, mit Rampen |  | Geschwindigkeitswert (11 Bit und Vorzeichen), siehe Formel. Die Klemme wertet nur Bit 4 bis 15 aus.
Positionsnachführung |  | Sollposition (15 Bit und Vorzeichen)
Fahrwegsteuerung |  | Manueller Betrieb: Geschwindigkeitswert (11 Bit und Vorzeichen) für den manuellen Betrieb, siehe Formel. Die Klemme wertet nur Bit 4 bis 15 aus. Um einen Geschwindigkeitswert manuell vorgeben zu können, darf kein Fahrauftrag aktiv sein (CB.2=0)! Fahrauftrag: Die Sollposition (32 Bit) für den Fahrauftrag wird über Registerkommunikation in die Register R2 und R3 eingetragen. Um den Fahrauftrag dann starten zu können, muss DataOUT 0 sein!
Hinweis
Sondertypen
Informationen über die Sondertypen KL2531-1000 und KL2541-1000 finden Sie in einer ergänzenden Dokumentation (KL2531-1000d.chm), die auf Anfrage erhältlich ist.


Control- und Status-Byte

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Byte
Control- und Status-Byte
Prozessdatenbetrieb
Control-Byte (bei Prozessdatenbetrieb)
Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | Reset | AutoStop | AutoStart | Reduced Current | Start | PLC-Stop | Enable
Legende
Bit | Name | Beschreibung
CB.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB.6 | Reset | 1bin | alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke)
CB.5 | AutoStop1 | 1bin | die automatische Stopp-Funktion ist aktiviert
CB.4 | AutoStart2 | 1bin | die automatische Start-Funktion ist aktiviert
CB.3 | Reduced Current (identisch mit Bit CW.11) | 1bin | reduzierter Spulenstrom, bei stehendem Motor, ist aktiv (vorgegeben durch R45)
CB.2 | Start2 | 0bin | Fahrauftrag ist gestoppt
 |  | 1bin | Fahrauftrag ist gestartet
CB.1 | PLC-Stop2 | 1bin | der Motor wird mit der Notfallbeschleunigung (R50) gestoppt (steigende Flanke)
CB.0 | Enable | 0bin | Motoransteuerung sperren
 |  | 1bin | Motoransteuerung freischalten
1) In allen Betriebsarten außer Positionsnachführung verfügbar.
2) Nur in der Betriebsart Fahrwegsteuerung verfügbar.
Status-Byte (bei Prozessdatenbetrieb)
Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | Warning | Idle | LoadAngle |  |  | Ready
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB.6 | Error | 0bin | kein Fehler
 |  | 1bin | ein Fehler ist aufgetreten (SW.13-SW.9)
SB.5 | Warning | 1bin | die Innentemperatur der Klemme liegt über 80 °C oder der LoadAngle ist größer als Register R47
SB.4 | Idle | 0bin | Klemme führt gerade einen Auftrag aus (der Motor dreht sich oder ein Fahrauftrag ist aktiv)
 |  | 1bin | Klemme ist ohne Auftrag (Idle)
SB.3 bis SB.1 | LoadAngle | Lastwinkel (aktuelle mechanische Last am Motor, ist abhängig vom maximalen Spulenstrom und der aktuellen Geschwindigkeit)
SB.0 | Ready | 0bin | Motoransteuerung ist gesperrt oder es liegt ein Fehler vor (SB.6=1)
 |  | 1bin | Motoransteuerung ist frei geschaltet und es ist kein Fehler aufgetreten (Quittung für Enable, SB.6=0)
Registerkommunikation
Control-Byte (bei Registerkommunikation)
Das Control-Byte (CB) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit
Name
Beschreibung
CB.7
RegAccess
1bin
Registerkommunikation eingeschaltet
CB.6
R/W
0bin
Lesezugriff
1bin
Schreibzugriff
CB.5 bis CB.0
Reg-Nr.
▪
Registernummer:
Tragen Sie hier die Nummer des Registers ein, das Sie
▪
mit dem Eingangsdatenwort DataIn
▪
mit dem Ausgangsdatenwort DataOut
Status-Byte (bei Registerkommunikation)
Das Status-Byte (SB) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg-Nr.
Legende
Bit | Name | Beschreibung
SB.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB.6 | R | 0bin | Lesezugriff
SB.5 bis SB.0 | Reg-Nr. | Nummer des Registers, das gelesen oder beschrieben wurde.


Control- und Status-Wort

Zugriff aus dem Anwenderprogramm [image] Control- und Status-Wort
Control- und Status-Wort
Control-Wort
Das Control-Wort (CW) befindet sich im Ausgangsabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CW.15 | CW.14 | CW.13 | CW.12 | CW.11 | CW.10 | CW.9 | CW.8
Name | - | Set Position in ProcData | Clear Position | Reduced Current (drive) | Reduced Current | SetPos | disMixed Decay | GetEncoder Position
Bit | CW.7 | CW.6 | CW.5 | CW.4 | CW.3 | CW.2 | CW.1 | CW.0
Name | GetPosition Error | ToggleLatch Data | GetLatch Data | enLatch FallEdge | enLatch RiseEdge | enLatch Input2 | enLatch Input1 | enLatchC
Legende
Bit | Name | Beschreibung
CW.15 | - | 0bin | reserviert
CW.14 | Set-Position in ProcData | 1bin | schaltet die Prozessdaten von Soll-Geschwindigkeit auf Soll-Position um (siehe Funktion Soll-Position vorgeben)
CW.13 | ClearPosition | 1bin | Positionswert wird gelöscht (steigende Flanke) ACHTUNG: höhere Priorität als CW.10
CW.12 | Reduced Current (drive) | 1bin | reduzierter Spulenstrom (vorgegeben durch R45) ist aktiv, bei drehendem Motor
CW.11 | Reduced Current (gleiche Funktion wie Bit CB.3) | 1bin | reduzierter Spulenstrom (vorgegeben durch R45) ist aktiv, bei stehendem Motor
CW.10 | SetPos | 1bin | Positionswert wird mit den Registern R2 und R3 gesetzt (steigende Flanke) NOTE: nur aktiv wenn CW.13=0
CW.9 | disMixedDecay | 0bin | Motoransteuerung über 2 gepulste Transistoren pro Halbwelle
 |  | 1bin | Motoransteuerung über 1 gepulsten und einen durchgeschalteten Transistor pro Halbwelle
CW.8 | GetEncoder Position1, 2) | 1bin | die aktuelle Encoder-Position in den Prozessdaten einblenden
CW.7 | GetPosition Error1 | 0bin | die aktuelle Position in Byte2,3 der Eingangsprozessdaten einblenden
 |  | 1bin | den relativen Positionsfehler in Byte2,3 der Eingangsprozessdaten einblenden
CW.6 | ToggleLatch Data | 0bin | wird dieses Bit gewechselt, können bei aktiviertem Latcharray (R32.9) und gesetztem CW.5 die bis zu 20 gespeicherten Latchwerte (R37) abgerufen werden
 |  | 1bin
CW.5 | GetLatchData | 0bin | die aktuelle Position in Byte2,3 der Eingangsprozessdaten einblenden
 |  | 1bin | den aktuellen Latchwert in Byte2,3 der Eingangsprozessdaten einblenden
CW.4 | enLatch FallEdge (extern) | 1bin | externes Latchereignis ist freigeschaltet (bei fallender Flanke des Latch-Eingangs speichert die Klemme die aktuelle Position) ACHTUNG: höhere Priorität als CW.1 und CW.2!
CW.3 | enLatch RiseEdge (extern) | 1bin | externes Latchereignis ist freigeschaltet (bei steigender Flanke des Latch-Eingangs speichert die Klemme die aktuelle Position) ACHTUNG: höhere Priorität als CW.1, CW.2 und CW.4!
CW.2 | enLatchInput2 | 1bin | externes Latchereignis ist freigeschaltet (bei steigender Flanke des digitalen Eingangs E2 speichert die Klemme die aktuelle Position)
CW.1 | enLatchInput1 | 1bin | externes Latchereignis ist freigeschaltet (bei steigender Flanke des digitalen Eingangs E1 speichert die Klemme die aktuelle Position) ACHTUNG: höhere Priorität als CW.2!
CW.0 | enLatchC (intern) | 1bin | internes Latchereignis ist freigeschaltet (bei steigender Flanke des C-Eingangs speichert die Klemme die aktuelle Position) ACHTUNG: höhere Priorität als CW.1, CW.2, CW.3 und CW.4!
1) Nur bei interner Positionierung
2) Nur für KL2541
Status-Wort
Das Status-Wort (SW) befindet sich im Eingangsabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8
Name | Config Error | NoControl Power | OverCurrent Br B | OverCurrent Br A | OpenLoad Br B | OpenLoad Br A | Under Voltage | Over Temperature
Bit | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | Encoder Disabled | LatchData Toggled | LatchData InByte2,3 | LatchValid | Target Reached | SetPos Ready | Input E2 | Input E1
Legende
Bit
Name
Beschreibung
SW.15
ConfigError
1bin
Konfigurationsfehler (die LED Error A blinkt). Ursache:
▪
Wert für Motor Vollschritte ist 0 (RP0.R33), nur KL2541
▪
Wert für Encoder-Inkremente ist 0 (RP0.R34), nur KL2541
▪
Wert für min. Geschwindigkeit vmin ist 0 (RP0.R38)
▪
Wert für max. Geschwindigkeit vmax ist 0 (RP0.R39)
▪
Wert für max. Beschleunigung amax ist zu klein (RP0.R40)
▪
Wert für Spulenstrom IS bei a > ath ist 0 (RP0.R42)
▪
Wert für Spulenstrom IS bei a ≤ ath ist 0 (RP0.R43)
▪
Wert für max. Notfall-Beschleunigung ae ist 0 (RP0.R50)
Der Fehleranzeige wird automatisch gelöscht, wenn die falsch konfigurierten Register mit korrekten Daten beschrieben wurden.
SW.14
NoControlPower
1bin
Ausfall der 24 V Steuerspannung (die LED Error B blinkt und die Klemme schaltet den Motor selbsttätig ab). Die Klemme wird automatisch Re-Initialisiert, wenn die Spannung wieder kommt!
ACHTUNG:
eine Quittierung dieser Fehlermeldungen muss vom Anwender durch setzen von Bit CB.6 des Control-Bytes erfolgen!
SW.13
OverCurrent Br B
1bin
Überstrom, Brücke B (die LED Error B blinkt und die Klemme schaltet den Motor selbsttätig ab).
SW.12
OverCurrent Br A
1bin
Überstrom, Brücke A (die LED Error B blinkt und die Klemme schaltet den Motor selbsttätig ab).
SW.11
OpenLoad Br B
1bin
offene Last, Brücke B (die LED Error B blinkt und die Klemme schaltet den Motor selbsttätig ab).
SW.10
OpenLoad Br A
1bin
offene Last, Brücke A (die LED Error B blinkt und die Klemme schaltet den Motor selbsttätig ab).
SW.9
UnderVoltage
1bin
Versorgungsspannung zu niedrig (die LED Error B blinkt und die Klemme schaltet den Motor selbsttätig ab).
SW.8
OverTemperature
1bin
Übertemperatur (siehe SB.5) - die Stepper-Controller-Chip Temperatur liegt über 125 °C (die LED Error B blinkt und die Klemme schaltet den Motor selbsttätig ab).
SW.7
EncoderDisabled
0bin
der Encoder ist freigegeben
1bin
der Encoder ist gesperrt (Feature-Bit R32.12=1 und Latch-Eingang=0 oder R32.13=1 und Latch-Eingang=1)
SW.6
LatchDataToggled
0bin
ein neuer Latchwert steht in Byte2,3 der Eingangsprozessdaten, wenn Bit CW.6 geändert wurde und SW.6 den neuen Zustand übernommen hat (Quittung für ToggleLatchData)
1bin
SW.5
LatchDataInByte2,3
0bin
die aktuelle Position ist in Byte2,3 der Eingangsprozessdaten eingeblendet
1bin
der letzte Latchwert ist in Byte2,3 der Eingangsprozessdaten eingeblendet (Quittung für GetLatchData)
SW.4
LatchValid
1bin
ein Latchereignis ist eingetreten (bei CW.0=1, CW.3=1 oder CW.4=1); ist das Latcharray aktiviert (R32.9) wird dieses Bit gesetzt, wenn die in R37 vorgegebene Anzahl an Latchwerten gespeichert wurde
SW.3
TargetReached3
1bin
Zielposition wurde erreicht
SW.2
SetPosReady
1bin
die aktuelle Position wurde gelöscht (bei CW.13=1) bzw. gesetzt (bei CW.10=1) (Quittung für ClearPos und SetPos)
SW.1
Input 2
Status des digitalen Eingangs 2. Die Auswertung des digitalen Eingangs 2 kann mit Bit RP0.R52.15 des Feature-Registers 2 invertiert werden.
SW.0
Input 1
Status des digitalen Eingangs 1. Die Auswertung des digitalen Eingangs 2 kann mit Bit RP0.R52.14 des Feature-Registers 2 invertiert werden.
3) Nur in der Betriebsart Fahrwegsteuerung


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Die Register dienen zur Parametrierung der Schrittmotorklemmen. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.
Die Register 0 bis 31 haben immer die gleiche Bedeutung. Der Inhalt der Register 32 bis 63 wird über das Registerpage-Auswahlregister (R4) festgelegt.
Register-Nr. | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | Ist-Position (niederwertiges Wort) |  | - | - | R | RAM
R1 | Ist-Position (höherwertiges Wort) |  | - | - | R | RAM
R2 | Setzen der Zielposition bzw. Position (niederwertiges Wort) |  | - | - | R/W | RAM
R3 | Setzen der Zielposition bzw. Position (höherwertiges Wort) |  | - | - | R/W | RAM
R4 | Register-Page-Auswahlregister (Wertebereich: 0 bis 2) |  | 0x0000 | 0dez | R/W | RAM
R5 | Latch-Wert (höherwertiges Wort) |  | - | - | R | RAM
R6 | Temperatur-Register |  | z. B. 0x003C | z. B. 60dez | R | RAM
R7 | Kommando-Register |  | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | KL2531: | 0x09E3 | 2531dez | R | ROM
 |  | KL2541: | 0x09ED | 2541dez
R9 | Firmware-Stand |  | z. B. 0x3141 | z. B. 1AASCII | R | ROM
R10 | Multiplex-Schieberegister |  | 0x0128 | 296dez | R | ROM
R11 | Signalkanäle |  | 0x0128 | 296dez | R | ROM
R12 | minimale Datenlänge |  | 0x2828 | 10260dez | R | ROM
R13 | Datenstruktur |  | 0x0004 | 4dez | R | ROM
R14 | reserviert |  | - | - | - | -
R15 | Alignment-Register |  | 0x7F80 | 32640 | R/W | RAM
R16 | Hardware-Versionsnummer |  | z. B. 0x0000 | z. B. 0dez | R/W | EEPROM
R17 | reserviert |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R30 | reserviert |  | - | - | - | -
R31 | Kodewort-Register |  | 0x0000 | 0dez | R/W | RAM
R32 bis R63 | Register zum Einblenden von Register-Page 0, Register-Page 1, Register-Page 2 oder Register-Page 3 |  |  |  |  |
Register-Page 0 (weitere Parameter)
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R32 | Feature-Register 1 | 0x0000 | 0dez | R/W | EEPROM
R33 | Motor Vollschritte | 0x00C8 | 200dez | R/W | EEPROM
R34 | Encoder-Inkremente (nur KL2541) | 0x0FA0 | 4000dez | R/W | EEPROM
R35 | maximaler Spulenstrom A | 0x0064 | 100dez | R/W | EEPROM
R36 | maximaler Spulenstrom B | 0x0064 | 100dez | R/W | EEPROM
R37 | Anzahl der Latch-Werte | 0x0014 | 20dez | R/W | RAM / EEPROM
R38 | min. Geschwindigkeit vmin | 0x000A | 10dez | R/W | RAM / EEPROM
R39 | max. Geschwindigkeit vmax | 0x07FF | 2047dez | R/W | RAM / EEPROM
R40 | max. Beschleunigung aacc | 0x07FF | 2047dez | R/W | RAM / EEPROM
R41 | Beschleunigungs-Schwelle ath | 0x03FF | 1023dez | R/W | EEPROM
R42 | Spulenstrom IS, a > ath | 0x0064 | 100dez | R/W | EEPROM
R43 | Spulenstrom IS, a ≤ ath | 0x0064 | 100dez | R/W | EEPROM
R44 | Spulenstrom IS, v = 0 (automatisch) | 0x0032 | 50dez | R/W | EEPROM
R45 | Spulenstrom IS (manuell) | 0x0032 | 50dez | R/W | EEPROM
R46 | Schrittweite pro Viertelperiode | 0x0006 | 6dez | R/W | EEPROM
R47 | Lastwinkelschwelle | 0x0007 | 7dez | R/W | RAM / EEPROM
R48 | Kp-Faktor | 0x0000 | 0dez | R/W | RAM / EEPROM
R49 | Kv-Faktor | 0x0000 | 0dez | R/W | RAM / EEPROM
R50 | Notfall-Beschleunigung ae | 0x07FF | 2047dez | R/W | RAM / EEPROM
R51 | Anzahl Impulse pro Umdrehung | 0x0001 | 1dez | R/W | EEPROM
R52 | Feature-Register 2 | 0x0000 | 0dez | R/W | EEPROM
R53 | Referenziergeschwindigkeit rückwärts vref,b | 0x01F4 | 500dez | R/W | EEPROM
R54 | Referenziergeschwindigkeit vorwärts vref,f | 0x0032 | 50dez | R/W | EEPROM
R55 | Referenzierposition (niederwertiges Wort) | 0x0000 | 0dez | R/W | EEPROM
R56 | Referenzierposition (höherwertiges Wort) | 0x0000 | 0dez | R/W | EEPROM
R57 | Encoder-Toleranz (nur KL2541) | 0x0000 | 0dez | R/W | EEPROM
R58 | max. Verzögerung adec | 0x07FF | 2047dez | R/W | RAM / EEPROM
R59 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R61 | reserviert | - | - | - | -
R62 | Setzen der Zielposition bzw. Position (niederwertiges Wort) für erweiteten Autostart | - | - | R/W | RAM / EEPROM
R63 | Setzen der Zielposition bzw. Position (höherwertiges Wort) für erweiteten Autostart | - | - | R/W | RAM / EEPROM
Register-Page 1 (Anwender-Stromtabelle)
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R32 | Stromwert 4 bis 1 | 0x1100 | 4352dez | R/W | EEPROM
R33 | Stromwert 8 bis 5 | 0x3221 | 12833dez | R/W | EEPROM
R34 | Stromwert 12 bis 9 | 0x4433 | 17459dez | R/W | EEPROM
R35 | Stromwert 16 bis 13 | 0x5554 | 21844dez | R/W | EEPROM
R36 | Stromwert 20 bis 17 | 0x7666 | 30310dez | R/W | EEPROM
R37 | Stromwert 24 bis 21 | 0x8877 | 34935dez | R/W | EEPROM
R38 | Stromwert 28 bis 25 | 0x9998 | 39320dez | R/W | EEPROM
R39 | Stromwert 32 bis 29 | 0xAAAA | 43690dez | R/W | EEPROM
R40 | Stromwert 36 bis 33 | 0xBBBB | 48059dez | R/W | EEPROM
R41 | Stromwert 40 bis 37 | 0xCCCC | 52428dez | R/W | EEPROM
R42 | Stromwert 44 bis 41 | 0xDDDC | 56796dez | R/W | EEPROM
R43 | Stromwert 48 bis 45 | 0xEEDD | 61149dez | R/W | EEPROM
R44 | Stromwert 52 bis 49 | 0xEEEE | 61166dez | R/W | EEPROM
R45 | Stromwert 56 bis 53 | 0xFFEE | 65518dez | R/W | EEPROM
R46 | Stromwert 60 bis 57 | 0xFFFF | 65535dez | R/W | EEPROM
R47 | Stromwert 64 bis 61 | 0xFFFF | 65535dez | R/W | EEPROM
R48 | reserviert | - | - | - | -
... | ... | ... | ... | ... | ...
R63 | reserviert | - | - | - | -
Register-Page 2 (Anwender-Positionstabelle)
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R32 | Zielposition 0 (niederwertiges Wort) (Startwert für Register 2) | 0x0000 | 0dez | R/W | EEPROM
R33 | Zielposition 0 (höherwertiges Wort) (Startwert für Register 3) | 0x0000 | 0dez | R/W | EEPROM
R34 | Zielposition 1 (niederwertiges Wort) | 0x0000 | 0dez | R/W | EEPROM
R35 | Zielposition 1 (höherwertiges Wort) | 0x0000 | 0dez | R/W | EEPROM
... | ... | ... | ... | ... | ...
... | ... | ... | ... | ... | ...
R62 | Zielposition 15 (niederwertiges Wort) | 0x0000 | 0dez | R/W | EEPROM
R63 | Zielposition 15 (höherwertiges Wort) | 0x0000 | 0dez | R/W | EEPROM
Register-Page 3 (Anwender-Geschwindigkeits- und Beschleunigungstabelle)
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R32 | Geschwindigkeit 0 (Startwert für Register 39) | 0x07FF | 2047dez | R/W | EEPROM
R33 | Geschwindigkeit 1 | 0x07FF | 2047dez | R/W | EEPROM
... | ... | ... | ... | ... | EEPROM
R47 | Geschwindigkeit 15 | 0x07FF | 2047dez | R/W | EEPROM
R48 | Beschleunigung 0 (Startwert für Register 40) | 0x07FF | 2047dez | R/W | EEPROM
R49 | Beschleunigung 1 | 0x07FF | 2047dez | R/W | EEPROM
... | ... | ... | ... | ... | EEPROM
R63 | Beschleunigung 15 | 0x07FF | 2047dez | R/W | EEPROM


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Alle Register können über die Registerkommunikation ausgelesen oder beschrieben werden. Sie dienen zur Parametrierung der Klemmen.
Die Register 0 bis 31 haben immer die gleiche Bedeutung.
Der Inhalt der Register 32 bis 63 wird über das Registerpage-Auswahlregister (R4) festgelegt.
▪
0x0000: Register-Page 0 - weitere Klemmenparameter (default)
▪
0x0001: Register-Page 1 - Stromwerte der Anwender-Stromtabelle
▪
0x0002: Register-Page 2 - Anwender-Positionstabelle
Hinweis
Schreiben Sie im laufenden Betrieb in den RAM-Bereich!
Die Register R37, R38, R39, R40, R47, R48, R49, R50 und R58 sollten im laufenden Betrieb nur über den RAM-Bereich beschrieben werden. Dazu darf in Register R31 das Codewort nicht gesetzt sein (wenn das Codewort gesetzt ist, wird in den EEPROM-Bereich der Klemme geschrieben)! Der EEPROM-Bereich soll nur zur Initialisierung nach einem Klemmen-Reset (verursacht durch Software oder Power-Off) dienen. Häufige Änderungen der EEPROM-Register können langfristig die Speicherzellen zerstören. Die heutigen EEPROM Bausteine sind für viele Schreibzyklen ausgelegt, bei mehrfachen Positionierungen mit unterschiedlichen Geschwindigkeiten und Beschleunigungen kann diese Anzahl aber dennoch erreicht werden.
Wird z. B. ein Fahrauftrag mit der max. Geschwindigkeit v1 gestartet, kann während der Zielfahrt schon eine neue max. Geschwindigkeit v2 in Register R39 und eine neue Zielposition in Register R2 und R3 eingetragen werden. Nachdem die Zielposition erreichet wurde, das Control-Bit CB.2 und die Prozessausgangsdaten beide null sind, berechnet die Klemme die neuen Parameter für den nächsten Fahrauftrag.
Weiterführende Informationen
•
Registerbeschreibung R0 - R31
•
Register-Page 0 (Anwender-Parameter)
•
Register-Page 1 (Anwender-Stromtabelle)
•
Register-Page 2 (Anwender-Positionstabelle)
•
Register-Page 3 (Anwender-Geschwindigkeits- und Beschleunigungstabelle)


Registerbeschreibung R0 - R31

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung [image] Registerbeschreibung R0 - R31
Registerbeschreibung R0 - R31
R0: Ist-Position (niederwertiges Wort)
Beinhaltet das niederwertige Wort der Ist-Position.
Bei aktivierter Latchfunktion (RP0.R52.2 = 1bin) muss dieses Register als erstes gelesen werden. Hierbei werden Register R0 und R1 zwischengespeichert. Beim anschließenden Lesen von Register R1 werden beide Register wieder freigegeben.
R1: Ist-Position (höherwertiges Wort)
Beinhaltet das höherwertige Wort der Ist-Position.
R2: Setzen der Zielposition bzw. Position (niederwertiges Wort)
Hier können Sie das niederwertige Wort der gewünschten Position vorgeben (Maximum: 65535).
R3: Setzen der Zielposition bzw. Position (höherwertiges Wort)
Hier können Sie das höherwertige Wort der gewünschten Position vorgeben (Maximum: 65535).
R4: Register-Page-Auswahlregister
Mit diesem Register legen Sie fest, welche Register-Page in die Register R32 bis R63 der KL2531/KL2541 eingeblendet wird:
▪
0x0000: Register-Page 0 - weitere Klemmenparameter (default)
▪
0x0001: Register-Page 1 - Stromwerte der Anwender-Stromtabelle
▪
0x0002: Register-Page 2 - Anwender-Positionstabelle
R5: Latch-Wert (höherwertiges Wort)
Beinhaltet das höherwertige Wort des Latch-Werts.
Das niederwertige Wort des Latch-Werts kann nur im Prozessdatenbetrieb, durch setzen von CW.5, auslesen werden.
R6: Temperatur-Register
Aus Register R6 kann die Innentemperatur der Klemme in °C ausgelesen werden. Die Klemme setzt das Bit SB.5 als Warnung, wenn die Temperatur die Schwelle von 80 °C überschreitet. Sinkt die Temperatur unter 60 °C wird SB5 automatisch wieder zurückgesetzt.
R7: Kommando-Register
▪
Standardkommandos
Um ein Standardkommando auszuführen muss zuvor in Register R31 das Anwender-Codewort 0x1235 eingetragen sein.
Kommando 0x7000: Restore Factory Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register die Werte des Auslieferungszustands wiederhergestellt:
Register-Page 0 (weitere Parameter):
R32: 0
R33: 200
R34: 4000
R35: 100
R36: 100
R37: 20
R38: 10
R39: 2047
R40: 2047
R41: 1023
R42: 100
R43: 100
R44: 50
R45: 50
R46: 6
R47: 7
R48: 8192
R49: 8192
R50: 2047
R51: 1
R52: 0
R53: 500
R54: 50
R55: 0
R56: 0
R57: 0
R58: 2047
Register-Page 1 (Stromtabelle):
R32: 0x1100
R33: 0x3221
R34: 0x4433
R35: 0x5554
R36: 0x7666
R37: 0x8877
R38: 0x9998
R39: 0xAAAA
R40: 0xBBBB
R41: 0xCCCC
R42: 0xDDDC
R43: 0xEEDD
R44: 0xEEEE
R45: 0xFFEE
R46: 0xFFFF
R47: 0xFFFF
Register-Page 2 (Positionstabelle):
R32-R63: 0
Register-Page 3 (Geschwindigkeits- und Beschleunigungstabelle):
R32-R63: 2047
Kommando 0x8000: Software Reset
Mit dem Eintrag 0x8000 in Register R7 wird ein vollständiger Software-Reset der Klemme durchgeführt. Alle internen Variablen (Position, Latch-Werte, Fehler, usw.) werden gelöscht bzw. auf einem neuen Wert gesetzt, der aus den gespeicherten EEPROM-Werten berechnet wird. Die internen Schaltkreise (DAC, Ausgangstreiber) werden bei einem Software-Reset neu initialisiert.
WARNUNG
Motor ist bei Software-Reset ungebremst!
Während eines Software-Resets wird der Motor stromlos geschaltet, d. h. die Motorachse kann sich frei drehen. Stellen Sie sicher dass ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
▪
Sonderkommandos
Um ein Sonderkommando auszuführen muss zuvor kein Codewort in Register R31 eingetragen sein.
Kommando 0x0500: mehrfacher Fahrauftrag 'vorwärts' starten
Mit dem Eintrag 0x0500 wird ein mehrfacher Fahrauftrag gestartet. Es können bis zu 16 Positionen angefahren werden, die durch eine Positionstabelle vorgegeben werden. Die Startposition wird durch einen, zum Kommando-Code addierten, Offset angegeben (z. B. für Startposition verwenden sie den Kommando-Code 0x0504). Die Positionstabelle wird vorwärts durchlaufen.
Kommando 0x0510: mehrfacher Fahrauftrag 'rückwärts' starten
Mit dem Eintrag 0x0510 wird ein mehrfacher Fahrauftrag gestartet. Es können bis zu 16 Positionen angefahren werden, die durch eine Positionstabelle vorgegeben werden. Die Startposition wird durch einen, zum Kommando-Code addierten, Offset angegeben (z. B. für Startposition verwenden sie den Kommando-Code 0x0518). Die Positionstabelle wird rückwärts durchlaufen.
Kommando 0x0520: Referenzierung starten
Mit dem Eintrag 0x0520 wird eine automatische Referenzierung (Homing) des Schrittmotors gestartet. Die digitalen Eingänge dienen hierbei als Endschalter.
Kommando 0x0530: Selbstjustierung starten
Mit dem Eintrag 0x0530 wird eine automatische Selbstjustierung der Position gestartet.
Kommando 0x0540: Sonderfunktionen stoppen bzw. zurücksetzen
Mit dem Eintrag 0x0540 wird das aktuell aktivierte Sonderkommando gestoppt.
R8: Klemmentyp
Im Register R8 steht die Bezeichnung der Klemme:
KL2531: 0x09E3 (2531dez)
KL2541: 0x09ED (2541dez)
R9: Firmware-Stand
Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z. B. 0x3141 = '1A'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x41' dem ASCII-Zeichen 'A'.
Dieser Wert kann nicht verändert werden.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R31: Codewort-Register
▪
Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Codewort (0x1235) in das Codewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
▪
Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Codewort (0x1235) in das Codewort-Register eingetragen, werden diese Werte in die RAM-Register und in die EEPROM-Register geschrieben und bleiben somit bei einem Neustart der Klemme erhalten.
▪
Die Register R37, R38, R39, R40, R47, R48, R49, R50 und R58 können auch ohne Anwender-Codewort beschrieben werden. Hierbei werden die neuen Werte nur im RAM gespeichert.
Das Codewort wird bei einem Neustart der Klemme zurückgesetzt.


Register-Page 0 (Anwender-Parameter)

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung [image] Register-Page 0 (Anwender-Parameter)
Register-Page 0 (Anwender-Parameter)
R32: Feature-Register 1
Das Feature-Register legt die Konfiguration der Klemme fest.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | enCounterMode | disEncFltr | enPosGateLock | enNegGateLock | FeedbackType | enSignalDisplay | enMultiLatchValues | enLatchEventClrPos
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | enUserCurTable | invPosFeedback | RampType | OperationMode |  | disWdTimer | enAutoStop | enAutoStart
Legende
Bit | Name | Beschreibung |  |  | default
R32.15 | enCounterMode | 0bin | Encoder-Modus aktiv | Nur KL2541 Die KL2531 wertet diese Bits nicht aus! | 0bin
 |  | 1bin | Zähler-Modus aktiv
R32.14 | disEncFltr | 1bin | Eingangsfilter für Encoder-Signale deaktiviert |  | 0bin
R32.13 | enPosGateLock | 1bin | Positiver Pegel am Latch/Gate-Eingang sperrt den Zähler |  | 0bin
R32.12 | enNegGateLock | 1bin | Negativer Pegel am Latch/Gate-Eingang sperrt den Zähler |  | 0bin
R32.11 | FeedbackType | 0bin | Encoder zur Positionsrückführung nutzen |  | 0bin
 |  | 1bin | internen Zähler zur Positionsrückführung nutzen
R32.10 | enSignalDisplay | 1bin | Die Signale C und Gate werden im Statuswort eingeblendet. |  | 0bin
R32.9 | enMultiLatchValues | 0bin | Es wird nur ein Latch-Wert gespeichert. |  | 0bin
 |  | 1bin | Es werden mehrere Latch-Werte gespeichert. Die Anzahl legt Register R37 fest.
R32.8 | enLatchEventClrPos | 1bin | Latch-Ereignis löscht die aktuelle Position (mit den entsprechenden Control-Bits) |  | 0bin
R32.7 | enUserCurTable | 0bin | interne Stromtabelle (Sinus) aktiv |  | 0bin
 |  | 1bin | Anwender-Stromtabelle aktiv
R32.6 | invPosFeedback | 1bin | Invertiert die Positionsrückführung. Diese Option ist nur für die Betriebsart Fahrwegsteuerung vorgesehen, wenn ein externer Encoder dem Schrittmotor gegenüberliegend montiert ist (der Encoder z. B. bei positiver Rotation des Motors eine negative Rotation anzeigt). Wird diese Funktion bei interner Positionsrückführung aktiviert oder ist die Positionserfassung des externen Encoders falsch, arbeitet die Fahrwegsteuerung fehlerhaft! |  | 0bin
R32.5 | RampType | 0bin | lineare Rampen |  | 0bin
 |  | 1bin | exponentielle Rampe beim Verzögern (nur bei der Fahrwegsteuerung)
R32.4 + R32.3 | OperationMode | 00bin | Geschwindigkeit, direkt |  | 00bin
 |  | 01bin | Geschwindigkeit, mit Rampen
 |  | 10bin | Positionsnachführung
 |  | 11bin | Fahrwegsteuerung
R32.2 | disWdTimer | 0bin | Watchdog-Timer aktiv (werden 100 ms keine Prozessdaten empfangen, löst der Watchdog aus) |  | 0bin
 |  | 1bin | Watchdog-Timer deaktiviert
R32.1 | enAutoStop | 1bin | die Auto-Stopp-Funktion ist freigeschaltet |  | 0bin
R32.0 | enAutoStart | 1bin | die Auto-Start-Funktion ist freigeschaltet |  | 0bin
R33: Motor Vollschritte
Tragen Sie hier die Anzahl der Vollschritte ein, die der angeschlossenen Schrittmotor für eine volle Umdrehung benötigt (Default: 200).
R34: Encoder-Incremente (nur KL2541)
Tragen Sie hier die Anzahl der Inkremente ein, die der an die KL2541 angeschlossene Encoder bei einer vollen Umdrehung ausgibt (Default: 4000).
R35: maximaler Spulenstrom A
Dieses Register legt die Strombegrenzung für Wicklung A fest (Angabe in 0 bis 100 % vom Nennstrom der Klemme):
KL2531-0000: 100% = 1,5 A
KL2541-0000: 100% = 5,0 A
R36: maximaler Spulenstrom B
Dieses Register legt die Strombegrenzung für Wicklung B fest (Angabe in 0 bis 100 % vom Nennstrom der Klemme):
KL2531-0000: 100% = 1,5 A
KL2541-0000: 100% = 5,0 A
R37: Anzahl Latch-Werte
Dieses Register legt die Anzahl der gespeicherten Latch-Werte fest (Default: 20, Maximum: 20).
R38: min. Geschwindigkeit vmin
Dieses Register legt für die Betriebsarten Geschwindigkeit, mit Rampen und Fahrwegsteuerung die maximale Abschaltgeschwindigkeit fest (Default: 10, Maximum: 2047).
Die maximale Abschaltgeschwindigkeit ist die höchste Geschwindigkeit, aus der der Schrittmotor ohne Schrittfehler direkt anhalten kann. Sie ist abhängig vom Haltemoment des Motors und der mit dessen Welle rotierenden Masse.
R39: max. Geschwindigkeit vmax
Dieses Register legt für die Betriebsarten Geschwindigkeit, mit Rampen und Fahrwegsteuerung die maximale Geschwindigkeit fest (Default: 2047, Maximum: 2047).
R40: max. Beschleunigung aacc
Dieses Register legt für die Betriebsarten Geschwindigkeit, mit Rampen und Fahrwegsteuerung die maximale Beschleunigung fest (Default: 2047, Maximum: 2047).
R41: Beschleunigungs-Schwelle ath
Dieses Register legt für die Betriebsarten Geschwindigkeit, mit Rampen und Fahrwegsteuerung die Beschleunigungs-Schwelle fest (Default: 2047, Maximum: 2047).
R42: Spulenstrom, a > ath (in %)
Dieses Register legt für den Fall, dass a > ath den Spulenstrom in 0 bis 100 % vom eingestellten Spulenstrom der Klemme fest (Default: 100%).
R43: Spulenstrom, a ≤ ath (in %)
Dieses Register legt für den Fall, dass a ≤ ath den Spulenstrom in 0 bis 100 % vom eingestellten Spulenstrom der Klemme fest (Default: 100%).
R44: Spulenstrom, v = 0 (automatisch) (in %)
Dieses Register legt den automatischen Haltestrom fest (default: 50%).
Bei Stillstand des Motors werden die Spulenströme automatisch auf diesen Wert reduziert, um eine unnötige Erwärmung des Motors zu vermeiden. Dieser Wert bezieht sich auf den eingestellten Spulenstrom der Klemme.
R45: Spulenstrom (manuell) (in %)
Dieses Register legt den manuellen Haltestrom fest (default: 50%).
Bei gesetztem Control-Bit CB.3 oder CW.11 können die Spulenströme, im Stillstand und beim Fahren des Motors, manuell auf diesen Wert reduziert werden, um eine unnötige Erwärmung des Motors zu vermeiden. Dieser Wert bezieht sich auf den eingestellten Spulenstrom der Klemme. Der automatisch und der manuell reduzierte Spulenstrom addieren sich nicht! Der manuelle Wert hat eine höhere Priorität als der automatische Wert!
R46: Schrittweite
Dieses Register legt fest, in wie vielen Schritten die Viertelperiode ausgegeben wird.
Registerwert | 0x0006 | 0x0005 | 0x0004 | 0x0003 | 0x0002 | 0x0001 | 0x0000
Schritte/Viertelperiode | 64 | 32 | 16 | 8 | 4 | 2 | 1
Schrittweite | 1/64 | 1/32 | 1/16 | 1/8 | 1/4 | 1/2 (Halbschritt) | 1/1 (Vollschritt)
R47: Lastwinkelschwelle
Dieses Register legt die Lastwinkel-Schwelle fest, ab der die LED Stall Detect zu blinken beginnt und das Status-Bit SB.5 gesetzt wird (Default: 7, Maximum: 7).
Der Lastwinkel ist ein Maß für die Belastung des Motors. Er wird mit Werten von 0 bis 7 angezeigt, wobei 7 die höchste Belastung darstellt. Dieser Wert ist stark abhängig von dem eingestellten Spulenstrom und der aktuellen Geschwindigkeit. Die beste Aussage über die Motorlast kann bei mittleren Geschwindigkeiten gemacht werden.
R48: Kp-Faktor
Dieses Register legt den Kp-Faktor für die Betriebsart Positionsnachführung (in Vorbereitung) des zyklischen Positionsinterfaces der TwinCAT NC fest (Default: 8192, Maximum: 65535).
R49: Kv-Faktor
Dieses Register legt den Kv-Faktor für die Betriebsart Positionsnachführung (in Vorbereitung) des zyklischen Positionsinterfaces der TwinCAT NC fest (Default: 8192, Maximum: 65535).
R50: Notfall-Beschleunigung ae
Dieses Register legt für die Betriebsart Fahrwegsteuerung die Notfall-Beschleunigung fest (Default: 2047, Maximum: 2047).
R51: Anzahl Impulse pro Umdrehung
Dieses Register legt die Anzahl der Impulse pro Umdrehung für die Positionsfehlererkennung fest (Default: 1).
R52: Feature-Register 2
Das Feature-Register 2 legt weitere Konfigurationen der Klemme fest.
Bit | R52.15 | R52.14 | R52.13 | R52.12 | R52.11 | R52.10 | R52.9 | R52.8
Name | revDigInput2 | revDigInput1 | enManEnc Tolerance | enClrProcess Data | - | - | - | -
Bit | R52.7 | R52.6 | R52.5 | R52.4 | R52.3 | R52.2 | R52.1 | R52.0
Name | - | - | disReferenceInput2 | disReference Input1 | ShowIdle | LatchRegister Position | enDecelaration Ramp | revHoming Direction
Legende
Bit | Name | Beschreibung |  |  | default
R52.15 | revDigInput2 | 0bin | digitalen Eingang 2 als Schließer auswerten: HIGH-Pegel = aktiver Zustand (SW.1=1bin) |  | 0bin
 |  | 1bin | digitalen Eingang 2 als Öffner auswerten: LOW-Pegel = aktiver Zustand (SW.1=1bin)
R52.14 | revDigInput1 | 0bin | digitalen Eingang 1 als Schließer auswerten: HIGH-Pegel = aktiver Zustand (SW.0=1bin) |  | 0bin
 |  | 1bin | digitalen Eingang 1 als Öffner auswerten: LOW-Pegel = aktiver Zustand(SW.0=1bin)
R52.13 | enManEnc Tolerance (nur KL2541) | 0bin | Die Toleranz der Zielposition bildet sich aus dem Quotienten der Register R34 / R33 (Positionsrückführung mit Encoder). | Die KL2531 wertet dieses Bit nicht aus! | 0bin
 |  | 1bin | Die Toleranz der Zielposition wird durch Register R57 vorgegeben
R52.12 | enClrProcess Data | 1bin | Die Eingangsprozessdaten werden im Watchdog-Fehlerfall auf null gesetzt. |  | 0bin
R52.7 - R52.11 | - | reserviert
R52.6 | enExtAutostart | 0bin | 1. Zielposition = 0 2. Zielposition = Register R2/R3 |  | 0bin
 |  | 1bin | 1. Zielposition = Register R62/R63 2. Zielposition = Register R2/R3
R52.5 | disReferenceInput2 | 1bin | digitalen Eingang 2 als Referenzeingang deaktiviert |  | 0bin
R52.4 | disReferenceInput1 | 1bin | digitalen Eingang 1 als Referenzeingang deaktiviert |  | 0bin
R52.3 | ShowIdle | 1bin | Idle-Bit des Status-Bytes SB.4 aktiviert |  | 0bin
R52.2 | LatchRegisterPosition | 1bin | Latchen der Positionsregister R0 und R1 aktiviert |  | 0bin
R52.1 | enDecelaration Ramp | 0bin | Die Beschleunigungs- und die Verzögerungsrampe werden durch Register R40 vorgegeben. |  | 0bin
 |  | 1bin | Die Beschleunigungsrampe wird durch Register R40 vorgegeben. Die Verzögerungsrampe wird durch Register R58 vorgegeben.
R52.0 | revHoming Direction | 0bin | fahre mit negativer Geschwindigkeit auf den Endschalter zu (Vref,f < 0), fahre mit positiver Geschwindigkeit vom Endschalter weg (Vref,b > 0) |  | 0bin
 |  | 1bin | fahre mit positiver Geschwindigkeit auf den Endschalter zu (Vref,f > 0), fahre mit negativer Geschwindigkeit vom Endschalter weg (Vref,b < 0)
R53: Referenziergeschwindigkeit rückwärts vref,b
Dieses Register legt für die Referenzierfunktion (Homing) die Geschwindigkeit fest, mit der die Klemme auf den Endschalter zu fährt (Default: 500, Maximum: 2047).
Rückwärts bedeutet hier, die Klemme steuert den Motor mit abfallenden Positionswerten.
R54: Referenziergeschwindigkeit vorwärts vref,f
Dieses Register legt für die Referenzierfunktion (Homing) die Geschwindigkeit fest, mit der die Klemme vom Endschalter weg fährt (Default: 50, Maximum: 2047).
Vorwärts bedeutet hier, die Klemme steuert den Motor mit ansteigenden Positionswerten.
R55: Referenzierposition (niederwertiges Wort)
Hier können Sie das niederwertige Wort der Referenzierposition vorgeben (Default: 0, Maximum: 65535).
R56: Referenzierposition (höherwertiges Wort)
Hier können Sie das höherwertige Wort der Referenzierposition vorgeben (Default: 0, Maximum: 65535).
R57: Encoder-Toleranz (nur KL2541)
Dieses Register legt, bei der Positionsrückführung per Encoder, die Toleranz der Zielfahrt fest in der Position liegen muss, bei der Bit SW.3 gesetzt wird (Default: 0, Maximum: 65535).
R58: max. Verzögerung adec
Dieses Register legt für die Betriebsarten Geschwindigkeit, mit Rampen und Fahrwegsteuerung die maximale Verzögerung fest (Default: 0, Maximum: 2047).
R62: Setzen der Zielposition bzw. Position (niederwertiges Wort) für erweiterten Autostart
Hier können Sie das niederwertige Wort der gewünschten Position vorgeben (Maximum: 65535).
Ohne Codewort wird dieser Wert in das RAM geschrieben, mit Codewort in das EEPROM.
R63: Setzen der Zielposition bzw. Position (höherwertiges Wort) für erweiterten Autostart
Hier können Sie das höherwertige Wort der gewünschten Position vorgeben (Maximum: 65535).
Ohne Codewort wird dieser Wert in das RAM geschrieben, mit Codewort in das EEPROM.


Register-Page 1 (Anwender-Stromtabelle)

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung [image] Register-Page 1 (Anwender-Stromtabelle)
Register-Page 1 (Anwender-Stromtabelle)
Die Register-Page 1 gibt die Stromwerte der Anwender-Stromtabelle vor.
R32: Stromwert 4 bis 1
Dieses Register gibt die Stromwerte 4, 3, 2 und 1 vor.
Aufbau
Bit | 15 bis 12 | 11 bis 8 | 7 bis 4 | 3 bis 0
Inhalt | Stromwert 4 | Stromwert 3 | Stromwert 2 | Stromwert 1
R33: Stromwerte 8 bis 5
Dieses Register gibt die Stromwerte 8, 7, 6 und 5 vor (Aufbau wie Stromwerte 4 bis 1).
R34: Stromwerte 12 bis 9
Dieses Register gibt die Stromwerte 12, 11, 10 und 9 vor (Aufbau wie Stromwerte 4 bis 1).
R35: Stromwerte 16 bis 13
Dieses Register gibt die Stromwerte 16, 15, 14 und 13 vor (Aufbau wie Stromwerte 4 bis 1).
R36: Stromwerte 20 bis 17
Dieses Register gibt die Stromwerte 20, 19, 18 und 17 vor (Aufbau wie Stromwerte 4 bis 1).
R37: Stromwerte 24 bis 21
Dieses Register gibt die Stromwerte 24, 23, 22 und 21 vor (Aufbau wie Stromwerte 4 bis 1).
R38: Stromwerte 28 bis 25
Dieses Register gibt die Stromwerte 28, 27, 26 und 25 vor (Aufbau wie Stromwerte 4 bis 1).
R39: Stromwerte 32 bis 29
Dieses Register gibt die Stromwerte 32, 31, 30 und 29 vor (Aufbau wie Stromwerte 4 bis 1).
R40: Stromwerte 36 bis 33
Dieses Register gibt die Stromwerte 36, 35, 34 und 33 vor (Aufbau wie Stromwerte 4 bis 1).
R41: Stromwerte 40 bis 37
Dieses Register gibt die Stromwerte 40, 39, 38 und 37 vor (Aufbau wie Stromwerte 4 bis 1).
R42: Stromwerte 44 bis 41
Dieses Register gibt die Stromwerte 44, 43, 42 und 41 vor (Aufbau wie Stromwerte 4 bis 1).
R43: Stromwerte 48 bis 45
Dieses Register gibt die Stromwerte 48, 47, 46 und 45 vor (Aufbau wie Stromwerte 4 bis 1).
R44: Stromwerte 52 bis 49
Dieses Register gibt die Stromwerte 52, 51, 50 und 49 vor (Aufbau wie Stromwerte 4 bis 1).
R45: Stromwerte 56 bis 53
Dieses Register gibt die Stromwerte 56, 55, 54 und 53 vor (Aufbau wie Stromwerte 4 bis 1).
R46: Stromwerte 60 bis 57
Dieses Register gibt die Stromwerte 60, 59, 58 und 57 vor (Aufbau wie Stromwerte 4 bis 1).
R47: Stromwerte 64 bis 61
Dieses Register gibt die Stromwerte 64, 63, 62 und 61 vor (Aufbau wie Stromwerte 4 bis 1).


Register-Page 2 (Anwender-Positionstabelle)

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung [image] Register-Page 2 (Anwender-Positionstabelle)
Register-Page 2 (Anwender-Positionstabelle)
Die Register-Page 2 gibt die Zielpositionen der Anwender-Positionstabelle vor.
R32: Zielposition 0 (niederwertiges Wort - Startwert für Register 2)
Dieses Register gibt das niederwertige Wort der Zielposition 0 vor.
R33: Zielposition 0 (höherwertiges Wort - Startwert für Register 3)
Dieses Register gibt das höherwertige Wort der Zielposition 0 vor.
R34: Zielposition 1 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 1 vor.
R35: Zielposition 1 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 1 vor.
R36: Zielposition 2 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 2 vor.
R37: Zielposition 2 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 2 vor.
R38: Zielposition 3 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 3 vor.
R39: Zielposition 3 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 3 vor.
R40: Zielposition 4 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 4 vor.
R41: Zielposition 4 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 4 vor.
R42: Zielposition 5 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 5 vor.
R43: Zielposition 5 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 5 vor.
R44: Zielposition 6 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 6 vor.
R45: Zielposition 6 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 6 vor.
R46: Zielposition 7 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 7 vor.
R47: Zielposition 7 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 7 vor.
R48: Zielposition 8 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 8 vor.
R49: Zielposition 8 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 8 vor.
R50: Zielposition 9 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 9 vor.
R51: Zielposition 9 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 9 vor.
R52: Zielposition 10 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 10 vor.
R53: Zielposition 10 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 10 vor.
R54: Zielposition 11 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 11 vor.
R55: Zielposition 11 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 11 vor.
R56: Zielposition 12 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 12 vor.
R57: Zielposition 12 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 12 vor.
R58: Zielposition 13 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 13 vor.
R59: Zielposition 13 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 13 vor.
R60: Zielposition 14 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 14 vor.
R61: Zielposition 14 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 14 vor.
R62: Zielposition 15 (niederwertiges Wort)
Dieses Register gibt das niederwertige Wort der Zielposition 15 vor.
R63: Zielposition 15 (höherwertiges Wort)
Dieses Register gibt das höherwertige Wort der Zielposition 15 vor.


Register-Page 3 (Anwender-Geschwindigkeits- und Beschleunigungstabelle)

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung [image] Register-Page 3 (Anwender-Geschwindigkeits- und Beschleunigungstabelle)
Register-Page 3 (Anwender-Geschwindigkeits- und Beschleunigungstabelle)
Die Register-Page 3 gibt die Geschwindigkeiten und Beschleunigungen für die zugehörigen Zielpositionen in der Anwender-Positionstabelle vor.
R32: Geschwindigkeit 0 (Startwert für Register 39)
Dieses Register gibt die Geschwindigkeit 0 vor.
R33: Geschwindigkeit 1
Dieses Register gibt die Geschwindigkeit 1 vor.
R34: Geschwindigkeit 2
Dieses Register gibt die Geschwindigkeit 2 vor.
R35: Geschwindigkeit 3
Dieses Register gibt die Geschwindigkeit 3 vor.
R36: Geschwindigkeit 4
Dieses Register gibt die Geschwindigkeit 4 vor.
R37: Geschwindigkeit 5
Dieses Register gibt die Geschwindigkeit 5 vor.
R38: Geschwindigkeit 6
Dieses Register gibt die Geschwindigkeit 6 vor.
R39: Geschwindigkeit 7
Dieses Register gibt die Geschwindigkeit 7 vor.
R40: Geschwindigkeit 8
Dieses Register gibt die Geschwindigkeit 8 vor.
R41: Geschwindigkeit 9
Dieses Register gibt die Geschwindigkeit 9 vor.
R42: Geschwindigkeit 10
Dieses Register gibt die Geschwindigkeit 10 vor.
R43: Geschwindigkeit 11
Dieses Register gibt die Geschwindigkeit 11 vor.
R44: Geschwindigkeit 12
Dieses Register gibt die Geschwindigkeit 12 vor.
R45: Geschwindigkeit 13
Dieses Register gibt die Geschwindigkeit 13 vor.
R46: Geschwindigkeit 14
Dieses Register gibt die Geschwindigkeit 14 vor.
R47: Geschwindigkeit 15
Dieses Register gibt die Geschwindigkeit 15 vor.
R48: Beschleunigung 0
Dieses Register gibt die Beschleunigung 0 vor.
R49: Beschleunigung 1
Dieses Register gibt die Beschleunigung 1 vor.
R50: Beschleunigung 2
Dieses Register gibt die Beschleunigung 2 vor.
R51: Beschleunigung 3
Dieses Register gibt die Beschleunigung 3 vor.
R52: Beschleunigung 4
Dieses Register gibt die Beschleunigung 4 vor.
R53: Beschleunigung 5
Dieses Register gibt die Beschleunigung 5 vor.
R54: Beschleunigung 6
Dieses Register gibt die Beschleunigung 6 vor.
R55: Beschleunigung 7
Dieses Register gibt die Beschleunigung 7 vor.
R56: Beschleunigung 8
Dieses Register gibt die Beschleunigung 8 vor.
R57: Beschleunigung 9
Dieses Register gibt die Beschleunigung 9 vor.
R58: Beschleunigung 10
Dieses Register gibt die Beschleunigung 10 vor.
R59: Beschleunigung 11
Dieses Register gibt die Beschleunigung 11 vor.
R60: Beschleunigung 12
Dieses Register gibt die Beschleunigung 12 vor.
R61: Beschleunigung 13
Dieses Register gibt die Beschleunigung 13 vor.
R62: Beschleunigung 14
Dieses Register gibt die Beschleunigung 14 vor.
R63: Beschleunigung 15
Dieses Register gibt die Beschleunigung 15 vor.


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Hinweis
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.