KL2521 - Einkanalige Pulse-Train-Ausgangsklemmen, RS422 / 24 V DC
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Beckhoff Identification Code (BIC)


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.2
▪
Update Kapitel „Hinweise zum ESD-Schutz“
▪
Kapitel „Beckhoff Identification Code (BIC)“ eingefügt
▪
Update Firm- und Hardware-Stände
2.1
▪
KL2521-0010 hinzugefügt
2.0
▪
Migration
▪
Strukturupdate
▪
Technische Daten aktualisiert
▪
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit hinzugefügt
▪
Revisionsstand aktualisiert
Firm- und Hardware-Stände
Dokumentation Version | KL2521-0000 |  | KL2521-0010 |  | KL2521-0024
 | Firmware | Firmware | Firmware | Hardware | Firmware | Hardware
2.2 | 4F | 09 | - | - | 4F | 08
2.1 | 4F | 08 | 4A | 08 | 4F | 07
2.0 | 4F | 08 |  |  | 4F | 07
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 06 3A 02:
12 - Produktionswoche 12
06 - Produktionsjahr 2006
3A - Firmware-Stand 3A
02 - Hardware-Stand 02


Beckhoff Identification Code (BIC)

Vorwort [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KL2521-xxxx - Einführung
•
KL2521-xxxx - Technische Daten
•
Grundlagen zur Funktion


KL2521-xxxx - Einführung

Produktübersicht [image] KL2521-xxxx - Einführung
KL2521-xxxx - Einführung
KL2521
Einkanalige Pulse-Train-Ausgangsklemme
Die Ausgangsklemmen KL2521-xxxx verändern ein binäres Signal in der Frequenz und geben es (galvanisch getrennt vom K-Bus) aus. Die Frequenz wird durch einen 16-Bit-Wert vom Automatisierungsgerät vorgegeben.
Die Ausgangsstufe der KL2521-0000 ist RS422-kompatibel. Die Ausgänge können sowohl für den Anschluss an RS422-Receiver, als auch für den direkten Anschluss eines Optokopplers (ohne externe Versorgungsspannung) eingesetzt werden (Default Mode).
Die Klemme KL2521-0010 enthält zusätzliche Ausgänge (230 VAC/DC, 100 mA) anstelle der zusätzlichen Eingänge (+T, +Z) der Standardvariante.
Die Version KL2521-0024 wurde für den Anschluss an Optokoppler (mit externer Versorgungsspannung) konzipiert. Zum Anschluss an Eingänge mit großen Eingangswiderständen kann eine externe Versorgungsspannung (bis zu 24 V) genutzt werden (Active Mode).
Die Busklemmen zeigen ihren Signalzustand durch Leuchtdioden an. Die LEDs sind mit den Ausgängen getaktet und zeigen jeweils einen aktiven Ausgang an.


KL2521-xxxx - Technische Daten

Produktübersicht [image] KL2521-xxxx - Technische Daten
KL2521-xxxx - Technische Daten
Technische Daten | KL2521-0000 | KL2521-0010 | KL2521-0024
Anzahl der Ausgänge | 1 Kanal (2 Differenzausgänge A, B) KL2521-0010: 2 zusätzliche Ausgänge 230 VAC/DC. 100 mA (+T, +Z)
Lastart* | Ohmsch, Optokoppler, Differenzeingänge
Nennlastspannung* | 5 VDC intern |  | 5 VDC..24 VDC, externe Speisung
Ausgangsstrom max. | 50 mA, RS485-Spezifikation |  | max. 0,5 A
Grundfrequenz | 100 Hz ... 500 kHz, Default: 50 kHz
Tastverhältnis | 50 %
Auflösung | 16 Bit über ein Wort im Feldbus, 24 Bit insgesamt nutzbar
Rampenberechnung | 2 ms / Step
Zykluszeit Ausgabe | 1 ms (K-Bus Synchron)
Totzeit | 0,6 ms nach K-Bus-Zyklus
Anzahl der Eingänge | 2 (+T, +Z) | - |  | 2 (+T, +Z)
Eingangsstrom | 2,3 mA bis 2,8 mA bei 5 V bis 30 V
Potenzialtrennung | 500 V (K-Bus/Feldspannung Output / Input)
Stromaufnahme aus dem K-Bus | typ. 50 mA, max. 120 mA (lastabhängig)
Eingangsprozessabbild | 24 Bit (16 Bit Eingangsdaten, 8 Bit Status)
Ausgangsprozessabbild | 24 Bit (16 Bit Ausgangsdaten, 8 Bit Control)
Gewicht | ca. 50 g
Zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
Zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
Zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus |  | CE cULus
*) abhängig von der Hardware-Version der Klemme, siehe Kapitel Anschluss


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Die Ausgangsklemme KL2521 erzeugt ein binäres Signal mit variabler Frequenz. Die Peripherieseite der Elektronik ist galvanisch getrennt vom internen K-Bus und damit auch vom Feldbus. Die Ausgabe-Frequenz ist einstellbar. Über das Prozessabbild der Steuerung können zur Einstellung 16-Bit Werte (signed integer) vorgegeben werden. Diese Werte verändern die Ausgabefrequenz von 0 bis zur vorgewählten Maximalfrequenz in gleichen Schritten -> je 32767 (15 Bit) Schritte Rechts-/Linkslauf.
Bei der KL2521–0010 sind im Unterschied zur KL2521 die beiden Eingänge +T und +Z nicht mehr vorhanden. Stattdessen ist die KL2521-0010 an den entsprechenden Kontakten mit zusätzlichen Ausgängen versehen.
Die Ausgangs-Signale T und Z können durch das Control.4 und Control.5 gesetzt werden.
Anschließend werden die Signale von der Klemme zurückgelesen, im Statusbyte angezeigt und direkt an die Steuerung übertragen (Status.4 / Status.5).
Der Ausgang ist durch einen MOSFET-Schalter realisiert und kann AC/DC-Spannungen bis 230 V schalten. Der maximale Strom ist 100 mA. DC-Spannungen können negativ und positiv geschaltet benutzt werden.
Prozessabbild
Die Klemme KL2521 belegt im Auslieferungszustand 3 Byte im Prozessabbild. Das Mapping der KL2521 ist über die Steuerung oder über die Konfigurationsschnittstelle des Buskopplers mit der Beckhoff Konfigurationssoftware KS2000 einstellbar.
Betriebsarten
Die KL2521 kann neben der Betriebsart FM (Frequenz-Modulation) auch zur Schrittmotoransteuerung mit Puls-Richtungsvorgabe (Frq-Cnt-Impuls-Modus) genutzt werden. Eine weitere Betriebsart ist die Inkrementalgeber Simulation. Der direkte Anschluss des Klemmen-Ausgangs an einen Inkremental-Encoder-Eingang ist möglich, wie er bei vielen Servoverstärkern und Frequenzumrichtern vorhanden ist.
Defaulteinstellung
Die Defaulteinstellung der KL2521 ist FM-Modus mit einer Grundfrequenz von 50 kHz und einer Auflösung von 15-Bit. Zurückgelesen wird die Anzahl der ausgegebenen Pulse in einem 16-Bit Register.
Der Zähler läuft mit Meldung an die Steuerung über. Dies wird durch Status.3 (Überlauf) bzw. Status.2 (Unterlauf) angezeigt. Parallel zu diesen beiden Bits wird Status.6 als allgemeines Fehlerbit gesetzt. Die Erweiterung auf mehr als 16-Bit in der Steuerungssoftware wird dadurch erleichtert. Der Überlauf kann des Weiteren aus dem Register 3 ausgelesen werden (interne 32-BitErweiterung).
Der Zähler kann durch Control.5 gelöscht werden. Das Löschen des Zählers erfolgt
▪
Bei Feature.4 = 1 bei steigender Flanke (default),
▪
bei Feature.4 = 0 ist diese Funktion pegelgesteuert.
Ist Bit Feature.10 = 1, wird durch Bit Control.5 der Zähler auf einen, durch Register R0 (unteres Wort) und Register R1 (oberes Wort) vorgegebenen Wert, gesetzt.
Auflösung
Die Grundfrequenzen werden mit einer Auflösung von 1 Hz pro Bit vorgegeben (GF1: Register 36, 37 bzw. GF2: Register 38, 39). Die Klemme arbeitet intern bei 16 MHz mit einer Auflösung von 32 Bit. Das entspricht einer theoretischen minimalen Schrittweite von 0,0037 Hz/Schritt über den gesamten Frequenzbereich. Über die Ausgangsstufe kann eine Frequenz von maximal 500 kHz ausgegeben werden
Weiterführende Informationen
•
Rampenfunktion
•
Fahrwegsteuerung
•
Ausgabemuster


Rampenfunktion

Produktübersicht [image] Grundlagen zur Funktion [image] Rampenfunktion
Rampenfunktion
Die Klemme bietet die Möglichkeit des sanften Hoch-/Herunterfahren. Durch Register 40 kann die Rampensteilheit für das Hochfahren mit einer Genauigkeit von 10 Hz / s bzw. 1000 Hz / s (Feature.6) eingestellt werden. Register 41 hat die gleiche Funktion für das Herunterfahren. Das Prozessdatum kann während einer Rampenfahrt (Status.2) geändert werden, die Klemme nimmt dann den neuen Wert als Zielfrequenz.
Die interne Rampenfunktion erhöht / erniedrigt die aktuelle Frequenz bis zur voreingestellten Maximalfrequenz (Register 2) mit den voreingestellten Parametern in Register 40 / 41.
▪
Mit FeatureBit.5 erfolgt die Aktivierung der Rampenfunktion.
▪
Mit FeatureBit.6 wird die Rampen-Basis-Frequenz vorgegeben.
▪
Status.1 ist gesetzt wenn eine Rampe durchfahren wird.
Die Deaktivierung dieser Funktion, welches im laufenden Betrieb auch über Control.1 geschehen kann, bewirkt die Freischaltung von Control.0. Hiermit kann der Anwender im Betrieb schnell die Grundfrequenz ändern.
▪
Bei Control.0 = 1 (Bestätigung durch Status.0) werden die Werte in den Registern 38/39 verwendet.
▪
Bei Control.0 = 0 werden die Werte in den Registern 36/37 verwendet.
Die Eingangs-Signale T und Z werden von der Klemme im Statusbyte direkt an die Steuerung übertragen (Status.4 / Status.5). Es findet keine interne Vorverarbeitung der Signale statt.


Fahrwegsteuerung

Produktübersicht [image] Grundlagen zur Funktion [image] Fahrwegsteuerung
Fahrwegsteuerung
Ist die Funktion Fahrwegsteuerung aktiviert (Feature.9), wird bei steigender Flanke an Control.2 ein fester Zählerwert angefahren, dieser muss zuvor in Register 0 (Low-Word) und Register 1 (High-Word) zur Laufzeit eingetragen werden.
Die Zeit t1 ist durch die Rampen-Zeitkonstante in Register 40 bestimmt.
Die Zeit t2 wird mit der maximalen Frequenz f1 (Register 2) durchfahren.
Die Zeit t3 ist durch die Rampen-Zeitkonstante in Register 41 bestimmt, mit der auf die Auslauf-Frequenz f2 (Register 43) gefahren wird.
Nach Ablauf von t5 ist der vorgegebene Zählerstand erreicht. Die Klemme schaltet die Frequenz auf null.
Voraussetzung für eine exakte Zielfahrt ist, dass die Zeitkonstante der fallenden Rampe um einen gewissen Faktor größer ist, als die der steigenden Rampe. Dies ist erforderlich, damit die Auslauf-Frequenz vor dem Endzählerstand erreicht wird und die Klemme nicht mit voller Geschwindigkeit auf den Endpunkt fährt.
Zu Erläuterung: Die KL2521 berechnet aus der Zeit t1 und der Anzahl der gefahrenen Schritte die noch zu fahrenden Schritte in der Zeit t2. Die Berechnung geht für das Herunterfahren von der gleichen Anzahl von Schritten aus wie für das ermittelte Herauffahren. Die Herunterfahrrampe muss etwas steiler sein, ca. 10%, damit es möglich ist in der verbleibenden Zeit t3 + t4 + t5 das Ziel exakt zu erreichen. Dieser Zusammenhang verändert sich mit der maximalen Frequenz.
Phasen der Fahrwegsteuerung


Ausgabemuster

Produktübersicht [image] Grundlagen zur Funktion [image] Ausgabemuster
Ausgabemuster
Das Pulsmuster wird über die Kanäle A und B ausgegeben. Die Konfiguration der Betriebsart erfolgt über das Feature-Register R32.
Die Betriebsarten unterscheiden sich grundsätzlich durch positive Logik (Mode 0, 1, 2) und negative Logik (Mode 4, 5, 6).
Die Betriebsarten 2 und 6 simulieren einen Inkremental-Encoder und ermöglichen den direkten Anschluss einer Auswerteeinheit. Dazu gehört auch ein Servoverstärker oder ein Frequenzumrichter mit Inkremental-Encoder-Eingang.
Betriebsmodus | Funktion
 | Rechtslauf Linkslauf
Frequenzmodulation positive Logik (BA0) |
Puls-Richtungsvorgabe positive Logik (BA1) |
Inkrementalenkoder positive Logik (BA2) |
Frequenzmodulation negative Logik (BA4) |
Puls-Richtungsvorgabe negative Logik (BA5) |
Inkrementalenkoder negative Logik (BA6) |


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss
•
KL2521-xxxx - Anschluss und LED-Beschreibung
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX-Dokumentation


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endklemme KL9010 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


KL2521-xxxx - Anschluss und LED-Beschreibung

Montage und Verdrahtung [image] KL2521-xxxx - Anschluss und LED-Beschreibung
KL2521-xxxx - Anschluss und LED-Beschreibung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL2521-xxxx - Anschluss und LEDs
Anschluss KL2521-xxxx
Klemmstelle | Nr. | Kommentar
+A | 1 | Ausgang +A
+B | 2 | Ausgang +B
+T | 3 | Eingang T (KL2521-0010: Ausgang T)
GND T, Z | 4 | Signalmasse für die Ausgänge
-A | 5 | Ausgang -A
-B | 6 | Ausgang -B
+Z | 7 | Eingang Z (KL2521-0010: Ausgang Z)
Schirm | 8 | Schirm
LED Beschreibung KL2521-xxxx
LED | Farbe | Beschreibung
Signal-LED A, B Input T, Z | grün | Die vier LEDs leuchten mit aktiven Signalpegeln der Ein- und Ausgänge. Die LED für den aktiven Frequenzausgang A oder B kann bei hohen Frequenzen nur noch als leuchten mit halber Helligkeit wahrgenommen werden. Bei aktiviertem Watchdog (Feature.2 = 0 !!!) schaltet die Klemme die Ausgänge ab bzw. gibt einen in Register 35 eingestellten Wert aus, falls innerhalb 100 ms keine neuen Prozessdaten zur Klemme übergeben werden.
Anschluss der Eingänge (KL2521-0000, KL2521-0024)
Die optisch isolierten Eingänge sind mit einer Strombegrenzung vor Überlastung geschützt. Die Betriebsspannung kann ohne weitere externe Beschaltung im Bereich zwischen 5 V ... 24 VDC liegen. Der Anschluss GND ist die gemeinsame Masse der beiden Eingänge T und Z. Das Schaltbild zeigt die interne Schaltung der beiden Eingänge:
Interne Schaltung der Eingänge T und Z
Anschluss der Ausgänge
Schaltungsbeispiele für den Ausgang A, sie gelten sinngemäß auch für Ausgang B.
KL2521-0000, KL2521-0010
Die Ausgänge A und B der KL2521 können in unterschiedlichen Anschlussarten benutzt werden. Ein integrierter DC/DC-Wandler versorgt die Ausgangsstufe beider Kanäle A und B mit einer galvanisch isolierten Spannung (5 V).
▪
Anschluss an RS485/RS232-Receiver
Der Ausgang kann als RS485 oder RS232-Ausgang betrieben werden. Die Schaltung erzeugt die nötigen Differenzsignale.
KL2521-0000 am RS485/RS232 Receiver
▪
Anschluss an Optokoppler (ohne externe Versorgungsspannung)
Die Ausgänge können für den direkten Anschluss eines Optokopplers eingesetzt werden. Die Ausgangsstufe liefert den nötigen Ausgangsstrom mit einer internen Versorgungsspannung von 5 V.
KL2521-0000 - direkter Anschluss an einem Optokoppler
Anschluss an Optokoppler (mit externer Versorgungsspannung)
Zum Anschluss an Eingänge mit großen Eingangswiderständen kann bei der KL2521-0024 eine externe Versorgungsspannung (bis zu 24 V) genutzt werden um den erforderlichen Strom zu treiben.
Betrieb mit externer Versorgungsspannung abhängig von der Hardware-Version
Der Betrieb mit externer Versorgungsspannung ist abhängig von der Hardware-Version der Klemme:
•
Bis Hardware-Version 03 können Sie hierzu die Standard-Variante KL2521-0000 verwenden.
•
Ab Hardware-Version 04 ist dies nur mit der Sondervariante KL2521-0024 möglich, die speziell für diesen Anwendungsfall optimiert wurde!
Da der KL2521-0024 die interne Versorgungsspannung (5 V) fehlt, ist sie jedoch nicht geeignet für den Anschluss an RS485/RS232-Receiver oder an Optokoppler ohne externe Versorgungsspannung.
▪
KL2521-0000 bis Hardware-Version 03
KL2521-0000 bis Hardware 03 - Beschaltung mit externer Stromquelle
▪
Anstelle der Hardware-Version 04 (oder höher) verwenden Sie die Sondervariante KL2521-0024
KL2521-0024 - Beschaltung mit externer Stromquelle
Zur Bestimmung der Hardware-Version s. Kapitel Ausgabestände der Dokumentation
KL2521-0024 - Anschluss an externe Elektronik
Beachten Sie, beim Anschluss an externe Elektronik, dass die Klemmstellen A- des ersten und B- des zweiten Kanals einer KL2521-0024 intern miteinander verbunden sind.
KL2521-0024 - Anschluss an externe Elektronik
Dies erlaubt den zweikanaligen Anschluss von externer Elektronik, wenn die KL2521-0024 wie in Beispiel 1 gezeigt die Masse des angeschlossenen Gerätes schaltet.
Hinweise zum Anschluss an externe Elektronik
•
Die Beckhoff Incremental-Encoder-Interface-Klemmen KL5111, KL5121, KL5151 und KL5152 erfordern das Schalten der positiven Spannung.
•
Weil die Klemmstellen A- und B- der KL2521-0024 intern gebrückt sind, kann die KL2521-0024 die beiden Eingänge der im Beispiel 2 gezeigten KL5151-0000 nicht unabhängig voneinander schalten. Diese rot durchgestrichene Schaltung ist also nicht sinnvoll!
•
Allerdings können Sie wie in Beispiel 3 gezeigt, einen Kanal der KL2521-0024 nutzen um einen Kanal der KL5151-0000 zu schalten.
KL2521-0010 - Anschluss der zusätzlichen Ausgänge T, Z
Der Ausgang ist durch einen MOSFET-Schalter realisiert und kann AC/DC-Spannungen bis 230 V schalten. Der maximale Strom ist 100 mA. DC-Spannungen können negativ und positiv geschaltet benutzt werden.
Ausgang T, Z
KL2521-0010 - Ausgang T, Z
Anschlusstechnik
KL2521-0010 - Anschlusstechnik


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
Prozessdaten
•
Registerübersicht
•
Registerbeschreibung
•
Control und Status Byte
•
Beispiele für die Register-Kommunikation


Prozessdaten

Zugriff aus dem Anwenderprogramm [image] Prozessdaten
Prozessdaten
Eingabeformat:
▪
2er Komplementdarstellung (integer -1 entspricht 0xFFFF) oder
▪
Betrags-Vorzeichendarstellung (Feature.3) (integer -1 entspricht 0x8001)
Die Ausgangsfrequenz wird mit einer maximalen Auflösung von 15 Bit vorgegeben (16. Bit für Richtungsvorgabe).
Negative Prozessdaten führen zur anderen Drehrichtung. Der interne Zähler zählt in diesem Fall zu kleineren Werten.
Relative Daten
Die Ausgabefrequenz richtet sich nach der eingestellten Grundfrequenz in den Registern 36 bis 39 und dem Prozessdatum (siehe Tabelle).
Ausgabefrequenz = Grundfrequenz x Prozessdaten / 32767
größte Auflösung = 125 mHz
Beispiel:
Grundfrequenz = 100.000 Hz (maximale gewählte Ausgabefrequenz)
Prozessdaten = 0x00FF (255dez)
Ausgabefrequenz = 778,22 Hz
Prozessdatum |  | Ausgabewert
 | 0x0000 (0dez) | 0% DC
 | 0x3FFF (16383dez) | 50% der Grundfrequenz, Rechtslauf
 | 0x7FFF (32767dez) | 100% der Grundfrequenz, Rechtslauf
2er Komplement | 0xC000 (-16384dez) | 50% der Grundfrequenz, Linkslauf
 | 0x8000 (-32768dez) | 100% der Grundfrequenz, Linkslauf
Betrag-Vorzeichendarstellung | 0xBFFF (-16383dez) | 50% der Grundfrequenz, Linkslauf
 | 0xFFFF (-32767dez) | 100% der Grundfrequenz, Linkslauf
Direkte Daten
Es besteht die Möglichkeit der direkten Eingabe der Frequenz (Reature.7). Hier werden die Prozessdaten mit dem Faktor aus Register 42 multipliziert und direkt in den Synthese-Chip geschrieben.
Ausgabefrequenz = Frequenz-Faktor x Prozessdaten x 10 mHz
größte Auflösung = 10 mHz
Beispiel:
Frequenz-Faktor = 100
Prozessdaten = 0x00FF (255dez)
Ausgabefrequenz = 255 Hz


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Diese Register sind für jeden Kanal einmal vorhanden
Adresse | Bezeichnung | Defaultwert | R/W | Speichermedium
R0 | Zielzählerstand (Low-Word) | 0x0000 (0dez) | R/W | RAM
R1 | Zielzählerstand (High-Word) | 0x0000 (0dez) | R/W | RAM
R2 | Maximale Frequenz | 0x0000 (0dez) | R/W | RAM
R3 | Zählererweiterung (High-Word) | 0x0000 (0dez) | R | RAM
R4…R6 | reserviert | 0x0000 (0dez) | R |
R7 | Kommando-Register - reserviert | 0x0000 (0dez) | R/W | RAM
R8 | Klemmentype | 0x09D9 (2521dez) | R | ROM
R9 | Software-Versionsnummer | 0x3446 (4FASCI) | R | ROM
R10 | Multiplex-Schieberegister | 0x0118 (280dez) | R | ROM
R11 | Signalkanäle | 0x0118 (280dez) | R | ROM
R12 | minimale Datenlänge | 0x1818 (6468dez) | R | ROM
R13 | Datenstruktur | 0x0004 (4dez) | R | ROM
R14 | reserviert | 0x0000 (0dez) | R |
R15 | Alignment-Register | variabel | R/W | RAM
R16 | Hardware Versionsnummer | 0x0003 (3dez) | R/W | EEPROM
R17…R30 | reserviert | 0x0000 (0dez) | R/W |
R31 | Code-Word-Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0030 (48dez) | R/W | EEPROM
R33… R34 | reserviert | 0x0000 (0dez) | R/W |
R35 | Anwender-Einschaltwert | 0x0000 (0dez) | R/W | EEPROM
R36* | Grund-Frequenz 1 (Low-Word) | 0xC350 (50000dez) | R/W | EEPROM
R37* | Grund-Frequenz 1 (High-Word) | 0x0000 (0dez) | R/W | EEPROM
R38* | Grund-Frequenz 2 (Low-Word) | 0x86A0 (34464dez) | R/W | EEPROM
R39* | Grund-Frequenz 2 (High-Word) | 0x0001 (1dez) | R/W | EEPROM
R40 | Rampen-Zeitkonstante (ansteigend, s. Feature-Register) | 0x03E8 (1000dez) | R/W | EEPROM
R41 | Rampen-Zeitkonstante (abfallend, s. Feature-Register) | 0x03E8 (1000dez) | R/W | EEPROM
R42 | Frequenz-Faktor (direkte Eingabe, Digit x 10 mHz) | 0x0064 (100dez) | R/W | SEEROM
R43 | Auslauffrequenz (Fahrwegsteuerung) | 0x0032 (50dez) | R/W | SEEROM
R44… R61 | reserviert | 0x0000 (0dez) | R/W |
*) Die Änderung der Grund-Frequenz erfordert zur Aktivierung einen Reset.


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die Register können über die Registerkommunikation ausgelesen oder beschrieben werden. Sie dienen zur Parametrierung der Klemme.
R0 bis R7: Register im internen RAM der Klemme
Die Prozessvariablen können ergänzend zum eigentlichen Prozessabbild genutzt werden und sind in ihrer Funktion klemmenspezifisch.
▪
R0 Zielzählerstand (Low-Word)
Dieses Register beinhaltet das untere Wort des Zielzählerstands.
▪
R1 Zielzählerstand (High-Word)
Dieses Register beinhaltet das obere Wort des Zielzählerstands.
▪
R2 maximale Frequenz
Dieses Register beinhaltet das obere Wort des Zielzählerstands.
▪
R3 Zählererweiterung High-Word
Dieses Register beinhaltet den Überlaufwert (interne 32-Bit Erweiterung).
▪
R4 bis R6: Reserviert
▪
R7: Kommandoregister [0x0000]
Um ein Kommando auszuführen muss zuvor in Register R31 das Anwender-Codewort 0x1235 eingetragen sein.
Kommando 0x7000: Restore Factory Settings
Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register die Werte des Auslieferungszustands wiederhergestellt.
R32: | 0x0030 | (48dez) | R38: | 0x86A0 | (34464dez)
R33: | 0x0000 | (0dez) | R39: | 0x0001 | (1dez)
R34: | 0x0000 | (0dez) | R40: | 0x03E8 | (1000dez)
R35: | 0x0000 | (0dez) | R41: | 0x03E8 | (1000dez)
R36: | 0xC350 | (50000dez) | R42: | 0x0064 | (100dez)
R37: | 0x0000 | (0dez) | R43: | 0x0032 | (50dez)
R8 bis R15: Register im internen ROM der Klemme
Die Typ- und Systemparameter sind fest vom Hersteller programmiert und können vom Anwender nur ausgelesen und nicht verändert werden.
▪
R8: Klemmentyp
Der Klemmentyp in Register R8 wird zur Identifizierung der Klemme benötigt.
▪
R9: Softwareversion (X.y)
Die Software-Version kann als ASCII-Zeichenfolge gelesen werden.
▪
R10: Datenlänge
R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit.
Der Buskoppler sieht diese Struktur.
▪
R11: Signalkanäle
Im Vergleich zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z. B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.
▪
R12: Minimale Datenlänge
Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control- und Status-Byte nicht zwingend notwendig für die Funktion der Klemme und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen.
▪
R13: Datentypregister
Datentypregister | Bedeutung
0x00 | Klemme ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur 1Byte n Bytes
0x03 | Word-Array
0x04 | Struktur 1 Byte n Worte
0x05 | Doppelwort-Array
0x06 | Struktur 1 Byte n Doppelworte
0x07 | Struktur 1 Byte 1 Doppelwort
0x08 | Struktur 1 Byte 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur 1 Byte n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur 1 Byte n Worte mit variabler logischer Kanallänge
0x15 | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur 1 Byte n Doppelworte mit variabler logischer Kanallänge
▪
R14: reserviert
▪
R15: Alignment-Bits (RAM)
Mit den Alignment-Bits wird die Analogklemme im Buskoppler auf eine Bytegrenze gelegt.
R16 bis R30: Bereich der Herstellerparameter (SEEROM)
Die Herstellerparameter sind spezifisch für jeden Klemmentyp. Sie sind vom Hersteller programmiert, können jedoch auch von der Steuerung geändert werden. Die Herstellerparameter sind spannungsausfallsicher in einem seriellen EERPOM in der Klemme gespeichert.
Diese Register können nur nach dem Setzen eines Code-Worts in R31 geändert werden.
R16: Hardware-Versionsnummer
Im Register R16 steht der Hardware-Stand der Klemme.
R31 bis R47: Bereich der Anwenderparameter (SEEROM)
Die Anwenderparameter sind spezifisch für jeden Klemmentyp. Sie können vom Programmierer geändert werden. Die Anwenderparameter sind spannungsausfallsicher in einem seriellen EEPROM in der Klemme gespeichert. Der Anwenderbereich ist über ein Code-Wort schreibgeschützt.
• R31: Code-Wort-Register im RAM
Damit Parameter im Anwender-Bereich geändert werden können muss hier das Code-Wort 0x1235 eingetragen werden. Wird ein abweichender Wert in dieses Register eingetragen, so wird der Schreibschutz gesetzt. Bei inaktivem Schreibschutz wird das Code-Wort beim Lesen des Registers zurückgegeben. Ist der Schreibschutz aktiv, enthält das Register den Wert Null.
▪
R32: Feature-Register
[0x0030]
Dieses Register legt die Betriebsarten der Klemme fest. So kann z. B. eine anwenderspezifische Skalierung bei den analogen E/As aktiviert werden.
Feature Bit Nr.
Beschreibung der Betriebsart
Bit 0…Bit1
-
Ohne Funktion
Bit 2
0
[0] Watchdog-Timer aktiv
Der Watchdog-Timer ist im Auslieferungszustand eingeschaltet. Bei einem Watchdog Overflow wird entweder der Hersteller- oder der Anwendereinschaltwert ausgegeben.
Bit 3
1
[0] Betrags- Vorzeichendarstellung
Anstelle der Zweierkomplement-Darstellung ist das Betrags-Vorzeichenformat aktiv. (-1 = 0x8001).
Bit 4
1
[1] Das Löschen des Zählers erfolgt bei einer positiven Flanke vom Conter_Clear-Bit im Control-Byte (Control.5)
Bit 5
1
[1] Rampenfunktion aktiv
Bit 6
0/1
[0] Rampen-Basis-Frequenz
▪
0:10 Hz / s
▪
1: 1000 Hz / s
Bit 7
0/1
[0] Eingabe-Modus
▪
0:relativ
▪
1: direkt
Bit 8
0/1
[0] Verhalten bei ausgelöstem Watchdog
▪
0:Hersteller Einschaltwert
▪
1: Anwender Einschaltwert
Bit 9
1
[0] Fahrwegsteuerung aktiv
Bit 10
0/1
[0] Zähler
▪
0: löschen
▪
1: setzen
Bit 11…12
-
Ohne Funktion
Bit 13…15
Pos. Logik
Neg. Logik
[000] Betriebsart
Wertebereich
000
100
Frequenz-Modulation
0 - 500 kHz
001
101
Puls Richtungsvorgabe
010
110
Inkrementalenkoder
▪
R35: Anwender-Einschaltwert
Wenn der Anwender-Einschaltwert mit Bit R32.8 des Feature-Registers aktiviert wurde, legt die Klemme anstelle des Hersteller-Einschaltwerts den Anwender-Einschaltwert an ihren Ausgang wenn ein System-Reset oder ein Watchdog-timer-Overflow (Klemme hat 100 ms lang keine Prozessdaten erhalten) auftritt.
▪
R36: Grund-Frequenz 1 (Low-Word)
Dieses Register beinhaltet das untere Wort der Grundfrequenz 1.
Die Grundfrequenz 1 wird verwendet, wenn
–
Die Rampenfunktion deaktiviert ist und
–
Das Frequency_Selection-Bit (Control.0) = 0 ist.
▪
R37: Grund-Frequenz 1 (High-Word)
Dieses Register beinhaltet das obere Wort der Grundfrequenz 1.
Die Grundfrequenz 1 wird verwendet, wenn:
–
Die Rampenfunktion deaktiviert ist und
–
das Frequency_Selection-Bit (Control.0) = 0 ist.
▪
R38: Grund-Frequenz 2 (Low-Word)
Dieses Register beinhaltet das untere Wort der Grundfrequenz 2.
Die Grundfrequenz 2 wird verwendet, wenn:
–
Die Rampenfunktion deaktiviert ist und
–
das Frequency_Selection-Bit (Control.0) = 1 ist.
▪
R39: Grund-Frequenz 2 (High-Word)
Dieses Register beinhaltet das obere Wort der Grundfrequenz 2.
Die Grundfrequenz 2 wird verwendet, wenn:
–
Die Rampenfunktion deaktiviert ist und
–
das Frequency_Selection-Bit (Control.0) = 1 ist.
▪
R40: Rampen-Zeitkonstante (ansteigend)
Durch Register 40 kann die Rampensteilheit für das Hochfahren mit einer Genauigkeit von 10 bzw. 1000 Hz / s (Feature.6) eingestellt werden.
▪
R41: Rampen-Zeitkonstante (abfallend)
Durch Register 41 kann die Rampensteilheit für das Herunterfahren mit einer Genauigkeit von 10 bzw. 1000 Hz / s (Feature.6) eingestellt werden.
▪
R42: Frequenz-Faktor (direkte Eingabe, Digit x 10 mHz)
Dieses Register beinhaltet den Frequenz-Faktor. Bei Direkter Eingabe der Frequenz (Feature.7 =1 ) werden die Prozessdaten mit dem Frequenz-Faktor multipliziert (s. Prozessdaten).
▪
R43: Auslauf-Frequenz (Fahrwegsteuerung)
Dieses Register beinhaltet die Auslauf-Frequenz (s. Fahrwegsteuerung).


Control und Status Byte

Zugriff aus dem Anwenderprogramm [image] Control und Status Byte
Control und Status Byte
Das Control-und Status-Byte wird von der Steuerung zur Klemme übertragen. Es kann
▪
im Registermodus (REG = 1bin) oder
▪
im Prozessdatenaustausch (REG = 0bin) genutzt werden.
Weiterführende Informationen
•
KL2521-0000, KL2521-0024 - Prozessdatenaustausch
•
KL2521-0010 - Prozessdatenaustausch
•
Registerkommunikation


KL2521-0000, KL2521-0024 - Prozessdatenaustausch

Zugriff aus dem Anwenderprogramm [image] Control und Status Byte [image] KL2521-0000, KL2521-0024 - Prozessdatenaustausch
KL2521-0000, KL2521-0024 - Prozessdatenaustausch
Control-Byte im Prozessdatenaustausch (REG=0)
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Reg_Access | 0 | Cnt_Clr | 0 | 0 | Go_Counter | Ramp_Dis | Freq_Sel
Bit | Name | Beschreibung
Bit 7 | Reg_Access | 0bin: Registerkommunikation inaktiv (Prozessdatenaustausch)
Bit 5 | Cnt_Clr | Der Zählerstand wird durch dieses Bit gelöscht oder gesetzt (Feature.10). Eventuell gesetzte Over-/Underflow-Bits werden ebenfalls durch dieses Bit gelöscht. Dies kann Flanken- oder Pegelgesteuert erfolgen (Feature.4).
Bit 2 | Go_Counter | Ist die Fahrwegsteuerung aktiviert (Feature.9), wird bei gesetztem Bit auf einem vorgegebenen Zählerwert gefahren.
Bit 1 | Ramp_Dis | Die Rampenfunktion wird aufgehoben, trotz aktivem Feature.5; ist die Fahrwegsteuerung aktiv, wird sie durch dieses Bit abgebrochen.
Bit 0 | Freq_Sel | Schnelle Umschaltung der Grund-Frequenz (nur bei deaktivierter Rampenfunktion) 0: Grund-Frequenz 1 (Reg 36/ 37) 1: Grund-Frequenz 2 (Reg 38 /39)
Status-Byte im Prozessdatenaustausch (REG=0)
Das Statusbyte wird von der Klemme zur Steuerung übertragen. Das Statusbyte enthält verschiedene Statusbits des analogen Eingangskanals:
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Reg_Access | Error | Input_Z | Input_T | Overflow | Underflow | Ramp_Active | Sel_Ack/ End_Counter
Bit | Name | Beschreibung
Bit 7 | Reg_Access | 0bin: Quittung für Prozessdatenaustausch
Bit 6 | Error | Allgemeines Fehlerbit, kommt mit Over-/Underflow
Bit 5 | Input_Z | Endposition erreicht
Bit 4 | Input_T | Der Istwert beim angeschlossenen Gerät stimmt nicht mit dem Sollwert des angeschlossenen Gerätes überein.
Bit 3 | Overflow | Tritt ein Überlauf (65535 -> 0) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt, wenn der Zähler ein Drittel des Messbereichs überschreitet (21845 -> 21846) oder sobald ein Unterlauf auftritt.
Bit 2 | Underflow | Tritt ein Unterlauf (0 -> 65535) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt, wenn der Zähler zwei Drittel des Messbereichs unterschreitet (43690 -> 43689) oder sobald ein Überlauf auftritt.
Bit 1 | Ramp_Active | Eine Rampe wird momentan durchfahren
Bit 0 | Sel_Ack/ End_Counter | Bestätigt den Wechsel der Grundfrequenz. Bei aktivierter Fahrwegsteuerung: Zielzählerstand erreicht
Die Änderung der Grund-Frequenz erfordert zur Aktivierung einen Reset.


KL2521-0010 - Prozessdatenaustausch

Zugriff aus dem Anwenderprogramm [image] Control und Status Byte [image] KL2521-0010 - Prozessdatenaustausch
KL2521-0010 - Prozessdatenaustausch
Control-Byte im Prozessdatenaustausch (REG=0)
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Reg_Access | 0 | SET_Z | SET_T | Cnt_Clr | Go_Counter | Ramp_Dis | Freq_Sel
Bit | Name | Beschreibung
Bit 7 | Reg_Access | 0bin: Registerkommunikation inaktiv (Prozessdatenaustausch)
Bit 5 | SET_Z | Setzen von Ausgang Z
Bit 4 | SET_T | Setzen von Ausgang T
Bit 3 | Cnt_Clr | Der Zählerstand und durch eventuell gesetzte Over-/Underflow-Bits werden durch dieses Bit gelöscht, dies kann Flanken- oder Pegelgesteuert erfolgen (Feature.4).
Bit 2 | Go_Counter | Ist die Fahrwegsteuerung aktiviert (Feature.9), wird bei gesetztem Bit auf einem vorgegebenen Zählerwert gefahren.
Bit 1 | Ramp_Dis | Die Rampenfunktion wird aufgehoben, trotz aktivem Feature.5; ist die Fahrwegsteuerung aktiv, wird sie durch dieses Bit abgebrochen.
Bit 0 | Freq_Sel | Schnelle Umschaltung der Grund-Frequenz (nur bei deaktivierter Rampenfunktion) 0: Grund-Frequenz 1 (Reg 36/ 37) 1: Grund-Frequenz 2 (Reg 38 /39)
Anmerkung: Die Änderung der Grundfrequenz wird erst nach einem Reset wirksam!
Status-Byte im Prozessdatenaustausch (REG=0)
Das Statusbyte wird von der Klemme zur Steuerung übertragen.
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Reg_Access | Error | Out_Z_ACK | Out_T_ACK | Overflow | Underflow | Ramp_Active | Sel_Ack
Bit | Name | Beschreibung
Bit 7 | Reg_Access | 0bin: Quittung für Prozessdatenaustausch
Bit 6 | Error | Allgemeines Fehlerbit, kommt mit Over-/Underflow
Bit 5 | Out_Z_ACK | Ausgang Z
Bit 4 | Out_T_ACK | Ausgang T
Bit 3 | Overflow | Tritt ein Überlauf (65535 -> 0) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt, wenn der Zähler ein Drittel des Messbereichs überschreitet (21845 -> 21846) oder sobald ein Unterlauf auftritt.
Bit 2 | Underflow | Tritt ein Unterlauf (0 -> 65535) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt, wenn der Zähler zwei Drittel des Messbereichs unterschreitet (43690 -> 43689) oder sobald ein Überlauf auftritt.
Bit 1 | Ramp_Active | Eine Rampe wird momentan durchfahren
Bit 0 | Sel_Ack | Bestätigt den Wechsel der Grundfrequenz.


Registerkommunikation

Zugriff aus dem Anwenderprogramm [image] Control und Status Byte [image] Registerkommunikation
Registerkommunikation
Registerzugriff über den Prozessdatenaustausch
▪
Bit 7=1: Registermodus
Wenn Bit 7 des Control-Bytes gesetzt wird, werden die ersten zwei Byte der Nutzdaten nicht zum Prozessdatenaustausch verwendet, sondern in den Registersatz der Klemme geschrieben oder daraus ausgelesen.
▪
Bit 6=0: lesen, Bit 6=1: schreiben
In Bit 6 des Control-Bytes legen Sie fest, ob ein Register ausgelesen oder beschrieben werden soll.
–
Bit 6=0: Ein Register wird ausgelesen, ohne es zu verändern. Der Wert kann dem Eingangs-Prozessabbild entnommen werden.
–
Bit 6=1: Die Nutzdaten werden in ein Register geschrieben. Sobald das Status-Byte im Eingangs-Prozessabbild eine Quittung geliefert hat, ist der Vorgang abgeschlossen (siehe Bsp.).
▪
Bit 0 bis 5: Adresse
In die Bits 0 bis 5 des Control-Bytes wird die Adresse des anzusprechenden Registers eingetragen
Control-Byte im Register-Modus (REG=1)
MSB
REG=1
W/R
A5
A4
A3
A2
A1
A0
REG = 0bin: Prozessdatenaustausch
REG = 1bin: Zugriff auf Registerstruktur
W/R = 0bin: Register lesen
W/R = 1bin: Register schreiben
A5..A0 = Registeradresse
Mit Adressen A5...A0 sind insgesamt 64 Register adressierbar.
Register-Modus Control Byte
Das Control- bzw. Status-Byte belegt die niedrigste Adresse eines logischen Kanals. Die entsprechenden Registerwerte befinden sich in den folgenden 2-Datenbytes. (Ausnahme ist der BK2000: hier wird nach dem Control- bzw. Status-Byte ein nicht genutztes Daten-Byte eingeschoben, und somit der Registerwert auf eine Word-Grenze gelegt).
Beispiel 1:
Lesen des Registers 8 im BK2000 mit einer KL3022 und der Endklemme:
Werden die folgenden Bytes von der Steuerung zur Klemme übertragen,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | Daten aus, low byte | Daten aus, high byte | Nicht benutzt | Control-Byte
Wert | 0xXX | 0xXX | 0xXX | 0x88
So liefert die Klemme die folgende Typ-Bezeichnung zurück (0x0BBA entspricht im unsigned Integer 3022)
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | Daten ein, low byte | Daten ein, high byte | Nicht benutzt | Status-Byte
Wert | 0xCE | 0x0B | 0x00 | 0x88
Beispiel 2:
Schreiben des Registers 31 im BK2000 mit einer intelligenten und der Endklemme:
Werden die folgenden Bytes (Code-Wort) von der Steuerung zur Klemme übertragen,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | Daten aus, low byte | Daten aus, high byte | Nicht benutzt | Control-Byte
Wert | 0x35 | 0x12 | 0xXX | 0xDF
So wird das Code-Wort gesetzt und die Klemme liefert als Quittung die Registeradresse mit dem Bit 7 für Registerzugriff zurück.
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | Daten ein, low byte | Daten ein, high byte | Nicht benutzt | Status-Byte
Wert | 0x00 | 0x00 | 0x00 | 0x9F


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.