KL1501, KL1512 - Vorwärts-/Rückwärts-Zählerklemme, 24 V DC
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.1.0
▪
KL1512 hinzugefügt
▪
Technische Daten aktualisiert
▪
Struktur-Update
3.0.0
▪
Migration
▪
Struktur-Update
▪
Technische Daten aktualisiert
▪
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit hinzugefügt
▪
Kapitel "TwinCAT" mit Link zu FB_KL1501Config eingefügt
▪
Revisionsstand aktualisiert
Firm- und Hardware-Stände
Dokumentation Version | KL1501 |  | KL1512
 | Firmware | Hardware | Firmware | Hardware
3.1.0 | 3B | 08 | 1A | 09
3.0.0 | 3B | 08 |  |
Den K-Bus-Firmware und den Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - K-Bus-Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 49 05 1B 03:
49 - Produktionswoche 49
05 - Produktionsjahr 2005
1B - Firmware-Stand 1B
03 - Hardware-Stand 03


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KL1501 - Einführung
•
KL1512 - Einführung
•
KL1501, KL1512 - Technische Daten
•
KL1501, KL1512 - LED-Anzeigen


KL1501 - Einführung

Produktübersicht [image] KL1501 - Einführung
KL1501 - Einführung
KL1501
Vor-/Rückwärtszähler 24 VDC, 100 kHz
Die Eingangsklemme KL1501 zählt binäre Impulse und überträgt den aktuellen Wert zur übergeordneten Steuerung. Neben dem 32 Bit Vorwärts- / Rückwärts-Zähler steht als weitere Betriebsart ein 32 Bit Gated-Zähler bzw. zwei 16 Bit-Zähler zur Verfügung. Im Gated-Zähler-Modus unterbindet ein Low-Pegel oder High-Pegel am Gate-Eingang die Zählfunktion der Klemme. Sind zwei 16 Bit-Zähler aktiv, so ist der V/R-Eingang der Clock-Eingang für den zweiten Zähler. Darüber hinaus können zwei digitale Ausgänge gesetzt werden.
Die maximale Eingangsfrequenz ist auf 100 kHz begrenzt, die minimale Impulsbreite des Eingangssignals beträgt ca. 1 Mikrosekunde. Die Zähler reagieren auf die steigende Flanke des Eingangssignals.
Von der Steuerung kann über das Control-Byte der Zählerstand gesetzt, die Zählfunktion der Klemme unterbunden und die Ausgänge aktiviert werden. Außerdem kann eine interne Funktion aktiviert werden, die das automatische Setzen der Ausgänge bei definierten Zählerständen ermöglicht.
Die LEDs geben den Zustand des V/R- und CLOCK Eingänge sowie von den Ausgänge 1 und 2 wieder.
Die Prozessdaten stellen sich abhängig von der eingestellten Funktion unterschiedlich dar.
Beim Standard Ausgabeformat werden 5 Byte (4 Byte Nutzdaten und 1 Byte Control/Status-Byte) gemappt. Die Prozessdaten stellen sich, abhängig von der eingestellten Funktion, unterschiedlich dar:
▪
Vor/Rückwärtszähler: 32 Bit signed Integer
▪
Gated Counter: 32 Bit unsigned Integer
▪
Zwei aktive Zähler: 2 x 16 Bit unsigned Integer
Wird das alternative Ausgabeformat ausgewählt, ist darauf zu achten, dass sich die Ausgabelänge (4 Byte oder 6 Byte statt 5 Byte) und das Mapping der Klemme verändern.
▪
Vor/Rückwärtszähler: 24 Bit signed Integer
▪
Gated Counter: 24 Bit signed Integer
▪
Zwei aktive Zähler: 1 x 8 Bit Zähler 0 und 1 x 16 Bit Zähler 1
Das Mapping der Klemme im Kapitel Mapping im Buskoppler näher beschrieben.


KL1512 - Einführung

Produktübersicht [image] KL1512 - Einführung
KL1512 - Einführung
KL1512
Vor-/Rückwärtszähler 24 VDC, 1 kHz, 16 Bit
Die Eingangsklemme KL15121 zählt binäre Impulse und überträgt den aktuellen Wert zur übergeordneten Steuerung.
Die maximale Eingangsfrequenz ist auf 1 kHz begrenzt, die minimale Impulsbreite des Eingangssignals beträgt ca. 500 Mikrosekunden. Das bedeutet, weder Puls noch Pause des Eingangssignals dürfen kürzer als 500 Mikrosekunden sein!
Die Zähler reagieren auf die Steigende Flanke des Eingangssignals.
Die Busklemme enthält zwei Eingänge, deren Signalzustand durch Leuchtdioden angezeigt wird.
Beim Standard Ausgabeformat werden 6 Byte (2 Byte Nutzdaten und 1 Byte Control/Status-Byte pro Kanal) gemappt. Die Prozessdaten stellen sich pro Kanal, wie folgt dar:
–
1 Byte Control/Status
–
16 Bit unsigned Integer
Das Mapping der Klemme im Kapitel Mapping im Buskoppler näher beschrieben.


KL1501, KL1512 - Technische Daten

Produktübersicht [image] KL1501, KL1512 - Technische Daten
KL1501, KL1512 - Technische Daten
Technische Daten | KL1501 | KL1512
Anschlusstechnik | 1 x Vor-/Rückwärtszähler, 2 x Vor- oder Rückwärtszähler
Spezifikation | EN 61131-2, Typ 1, „0“: < 5 VDC, „1“: > 15 VDC, 5 mA typ.
Anzahl der Zähler | 1 bzw. 2
Nennlastspannung | 24 VDC (-15 %/+20 %)
Signalspannung ‘0’ | -3 V ... 5 V (EN 61131-2, Typ1)
Signalspannung ‘1’ | 15 V ... 30 V (EN 61131-2, Typ1)
Eingangsstrom | typisch 5 mA (EN 61131-2, Typ1)
Schaltfrequenz | max. 100 kHz (2 kHz beim Umschalten V/R) | max. 1 kHz
Zählertiefe | 32 Bit oder 2 x 16 Bit | 16 Bit
Ausgangsstrom max. | 24 V / 0,5 A typ. (kurzschlussfest) je Kanal | -
Stromaufnahme vom K-Bus | typisch 50 mA
Stromaufnahme Powerkontakte | nur Last
Potentialtrennung | 500 V (K-Bus / Feldspannung)
Bitbreite im Prozessabbild | 40 E/A: 32 Bit Daten, 8 Bit Control-/Status | 2 x 16 Bit Daten 2 x 8 Bit Control-/Status
Konfiguration | keine Adresseinstellungen, Konfigurationen über den Buskoppler oder die Steuerung | keine Adresseinstellungen, Konfigurationen über Control- und Status-Byte
Besondere Eigenschaften | Zusätzlich 2 Ausgänge | Zähler setzen
Gewicht ca. | 50 g
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Zulässige relative Feuchte | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für erhöhte mechanische Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | beliebig
Schutzart | IP20
Zulassungen | CE, cULus, IECEx, ATEX | CE, cULus, ATEX


KL1501, KL1512 - LED-Anzeigen

Produktübersicht [image] KL1501, KL1512 - LED-Anzeigen
KL1501, KL1512 - LED-Anzeigen
KL1501, KL1512 - LEDs
KL1501
LED | Farbe | Bedeutung
Signal LED1 | grün | Signal am V/R-Eingang (Betriebsart: V/R-Zähler) Signal am Gate-Eingang (Betriebsart: Gated-Zähler) Signal am Clock1-Eingang (Betriebsart: 2 Zähler)
Signal LED2 | grün | Signal am Clock-Eingang
Signal LED3 | grün | Signal am Ausgang 1
Signal LED4 | grün | Signal am Ausgang 2
KL1512
LED | Farbe | Bedeutung
Signal LED1 | grün | Signal am Eingang 1
Signal LED2 | grün | Signal am Eingang 2
Run-LED | grün | Die RUN- LED zeigt zyklischen Datenaustausch mit der übergeordneten Steuerung an. Werden 100 ms lang keine Prozessdaten ausgetauscht, so erlischt die RUN-LED.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschlusstechnik
•
KL1501, KL1512 - Anschluss
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


KL1501, KL1512 - Anschluss

Montage und Verdrahtung [image] KL1501, KL1512 - Anschluss
KL1501, KL1512 - Anschluss
KL1501, KL1512 - Anschluss
KL1501
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
V/R CLOCK1 Gate | 1 | Eingang Vorwärts-/Rückwärtszähler (Betriebsart: V/R-Zähler) Eingang Gate (Betriebsart: Zähler mit Gate-Funktion) Eingang CLOCK1 (Betriebsart: 2 Zähler)
+24 V | 2 | +24 V (intern verbunden mit Klemmstelle 6 und positivem Powerkontakt)
0 V | 3 | 0 V (intern verbunden mit Klemmstelle 7 und negativem Powerkontakt)
Ausgang 1 | 4 | Ausgang 1
Clock | 5 | Eingang Clock
+24 V | 6 | +24 V (intern verbunden mit Klemmstelle 2 und positivem Powerkontakt)
0 V | 7 | 0 V (intern verbunden mit Klemmstelle 3 und negativem Powerkontakt)
Ausgang 2 | 8 | Ausgang 2
KL1512
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Eingang 1 | 1 | Eingang 1
+24 V | 2 | +24 V (intern verbunden mit Klemmstelle 6 und positivem Powerkontakt)
0 V | 3 | 0 V (intern verbunden mit Klemmstelle 7 und negativem Powerkontakt)
n.c. | 4 | Nicht belegt
Eingang 2 | 5 | Eingang 2
+24 V | 6 | +24 V (intern verbunden mit Klemmstelle 2 und positivem Powerkontakt)
0 V | 7 | 0 V (intern verbunden mit Klemmstelle 3 und negativem Powerkontakt)
n.c. | 8 | Nicht belegt


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
KL1501 - Klemmenkonfiguration
•
KL1512 - Klemmenkonfiguration
•
KL1501 - Mapping im Buskoppler
•
KL1512 - Mapping im Buskoppler
•
Registerübersicht
•
Registerbeschreibung
•
Control und Status Byte
•
Beispiele für die Register-Kommunikation
•
Datenaustausch, Funktion (nur KL1501)


KL1501 - Klemmenkonfiguration

Zugriff aus dem Anwenderprogramm [image] KL1501 - Klemmenkonfiguration
KL1501 - Klemmenkonfiguration
Die Klemme kann über die interne Registerstruktur konfiguriert und parametriert werden. Jeder Klemmenkanal wird im Buskoppler gemappt. In Abhängigkeit vom Typ des Buskopplers und von der eingestellten Mapping-Konfiguration (z. B. Motorola-/Intel-Format, Word-Alignment usw.), werden die Daten der Klemme unterschiedlich im Speicher des Buskopplers abgebildet.
Im Gegensatz zu den analogen Ein- und Ausgangsklemmen werden bei der KL1501, unabhängig vom eingesetzten Feldbussystem, immer das Control- und das Status-Byte abgebildet.
Lightbus-Koppler BK2000
Beim Lightbus-Koppler BK2000 wird neben den Datenbytes auch immer das Control-/Statusbyte gemappt. Dieses liegt stets im Low-Byte auf der Offsetadresse des Klemmenkanals.
KL1501 - Mapping im Lightbuskoppler
Profibus-Koppler BK3000
Beim Profibus-Koppler BK3000 wird die KL1501 automatisch mit jeweils 5 Byte Eingangs- und 5 Byte Ausgangsdaten gemappt.
KL1501 - Mapping im Profibus-Koppler
Interbus-Koppler BK4000
Der Interbus-Koppler BK4000 mappt die KL1501 standardmäßig mit 5 Byte Eingangs- und 5 Byte Ausgangsdaten.
KL1501 - Mapping im Interbus-Koppler
Andere Buskoppler und weitere Angaben
Nähere Angaben zur Mapping-Konfiguration von Buskopplern finden Sie im jeweiligen Buskoppler-Handbuch im Anhang unter Konfiguration der Master.
Im Kapitel Mapping im Buskoppler befindet sich eine Übersicht über die möglichen Mapping-Konfigurationen in Abhängigkeit der einstellbaren Parameter.
Parametrierung mit KS2000
Mit der Konfigurations-Software KS2000 können die Parametrierungen unabhängig vom Feldbussystem über die serielle Schnittstelle des Buskopplers durchgeführt werden.


KL1512 - Klemmenkonfiguration

Zugriff aus dem Anwenderprogramm [image] KL1512 - Klemmenkonfiguration
KL1512 - Klemmenkonfiguration
Die Klemme kann über die interne Registerstruktur konfiguriert und parametriert werden. Jeder Klemmenkanal wird im Buskoppler gemappt. In Abhängigkeit vom Typ des Buskopplers und von der eingestellten Mapping-Konfiguration (z. B. Motorola-/Intel-Format, Word-Alignment usw.), werden die Daten der Klemme unterschiedlich im Speicher des Buskopplers abgebildet.
Im Gegensatz zu den analogen Ein- und Ausgangsklemmen werden bei der KL1512, unabhängig vom eingesetzten Feldbussystem, immer das Control- und das Status-Byte abgebildet.
Lightbus-Koppler BK2000
Der Lightbus-Koppler BK2000 mappt die KL1512 automatisch mit 6 Byte Eingangs- und 6 Byte Ausgangsdaten.
KL1512 - Mapping im Lightbuskoppler
Profibus-Koppler BK3000
Der Profibus-Koppler BK3000 mappt die KL1512 automatisch mit 6 Byte Eingangs- und 6 Byte Ausgangsdaten.
KL1512 - Mapping im Profibus-Koppler
Interbus-Koppler BK4000
Der Interbus-Koppler BK4000 mappt die KL1512 automatisch mit 6 Byte Eingangs- und 6 Byte Ausgangsdaten.
KL1512 - Mapping im Interbus-Koppler
Andere Buskoppler und weitere Angaben
Nähere Angaben zur Mapping-Konfiguration von Buskopplern finden Sie im jeweiligen Buskoppler-Handbuch im Anhang unter Konfiguration der Master.
Im Kapitel Mapping im Buskoppler befindet sich eine Übersicht über die möglichen Mapping-Konfigurationen in Abhängigkeit der einstellbaren Parameter.
Parametrierung mit KS2000
Mit der Konfigurations-Software KS2000 können die Parametrierungen unabhängig vom Feldbussystem über die serielle Schnittstelle des Buskopplers durchgeführt werden.


KL1501 - Mapping im Buskoppler

Zugriff aus dem Anwenderprogramm [image] KL1501 - Mapping im Buskoppler
KL1501 - Mapping im Buskoppler
Wie bereits im Kapitel Klemmenkonfiguration beschrieben wurde, wird jede Busklemme im Buskoppler gemappt. Dieses Mapping vollzieht sich im Standardfall mit der Defaulteinstellung im Buskoppler / Busklemme. Mit der Konfigurations-Software KS2000 oder mit einer Master Konfigurationssoftware (z. B. ComProfibus oder TwinCAT System Manager) ist es möglich diese Defaulteinstellung zu verändern.
Die folgenden Tabellen geben darüber Auskunft wie sich die KL1501, abhängig von den eingestellten Parametern, im Buskoppler mappt.
Weiterführende Informationen
•
Standard Format
•
Alternatives Format


Standard Format

Zugriff aus dem Anwenderprogramm [image] KL1501 - Mapping im Buskoppler [image] Standard Format
Standard Format
Im Standard Format wird die KL1501 mit 5 Byte Eingangs- und 5 Byte Ausgangsdaten gemappt.
Default-Mapping für: CAN-, DeviceNet-, ControlNet-, Modbus-, RS232- und RS485-Koppler
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: nein | 0 | D0 | CB/SB
 | 1 | D2 | D1
 | 2 | Res. | D3
Default-Mapping für: Profibus- und Interbus-Koppler
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung:egal Motorola-Format: ja Word-Alignment: nein | 0 | D3 | CB/SB
 | 1 | D1 | D2
 | 2 | Res. | D0
Default-Mapping für: Lightbus- und Ethernet-Koppler sowie Busklemmen Controller (BCxxxx, BXxxxx)
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: ja | 0 | Res. | CB/SB
 | 1 | D1 | D0
 | 2 | D3 | D2
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: ja | 0 | Res | CB/SB
 | 1 | D2 | D3
 | 2 | D0 | D1
Legende
Komplette Auswertung | Die Klemme wird mit Control- und Status-Byte gemappt.
Motorola-Format | Es ist Motorola- oder Intel-Format einstellbar.
Word-Alignment | Die Klemme liegt auf einer Wortgrenze im Buskoppler.
CB | Control-Byte (erscheint im Prozessabbild der Ausgänge).
SB | Status-Byte (erscheint im Prozessabbild der Eingänge).
D0 | Datenbyte 0
D1 | Datenbyte 1
D2 | Datenbyte 2
D3 | Datenbyte 3
Res. | Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.


Alternatives Format

Zugriff aus dem Anwenderprogramm [image] KL1501 - Mapping im Buskoppler [image] Alternatives Format
Alternatives Format
Im alternativen Format wird die KL1501 mit 4/6 Byte Eingangs- und 4/6 Byte Ausgangsdaten gemappt.
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: nein | 0 | D0 | Cnt-CB/SB
 | 1 | D2 | D1
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: nein | 0 | Cnt-CB/SB | D0
 | 1 | D1 | D2
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Cnt-CB/SB | CB/SB
 | 1 | Res. | D0
 | 2 | D2 | D1
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | D0 | CB/SB
 | 1 | Res. | Cnt-CB/SB
 | 2 | D1 | D2
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | Res. | CB/SB
 | 1 | D0 | Cnt-CB/SB
 | 2 | Res. | Res.
 | 3 | D2 | D1
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | Res. | CB/SB
 | 1 | Cnt-CB/SB | D0
 | 2 | Res. | Res.
 | 3 | D1 | D2
Legende
Komplette Auswertung | Die Klemme wird mit Control- und Status-Byte gemappt.
Motorola-Format | Es ist Motorola- oder Intel-Format einstellbar.
Word-Alignment | Die Klemme liegt auf einer Wortgrenze im Buskoppler.
CB | Control-Byte (erscheint im Prozessabbild der Ausgänge).
SB | Status-Byte (erscheint im Prozessabbild der Eingänge).
Cnt-CB | Control-Byte im Prozessdatenaustausch.
Cnt-SB | Status-Byte im Prozessdatenaustausch.
D0 | Daten-Byte 0
D1 | Daten-Byte 1
D2 | Daten-Byte 2
Res. | Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.


KL1512 - Mapping im Buskoppler

Zugriff aus dem Anwenderprogramm [image] KL1512 - Mapping im Buskoppler
KL1512 - Mapping im Buskoppler
Wie bereits im Kapitel Klemmenkonfiguration beschrieben wurde, wird jede Busklemme im Buskoppler gemappt. Dieses Mapping vollzieht sich im Standardfall mit der Defaulteinstellung im Buskoppler / Busklemme. Mit der Konfigurations-Software KS2000 oder mit einer Master Konfigurationssoftware (z. B. ComProfibus oder TwinCAT System Manager) ist es möglich diese Defaulteinstellung zu verändern.
Die folgenden Tabellen geben darüber Auskunft wie sich die KL1512, abhängig von den eingestellten Parametern, im Buskoppler mappt.
Die KL1512 wird mit 6 Byte Eingangs- und 6 Byte Ausgangsdaten gemappt.
Default-Mapping für: CANopen-, CANCAL-,DeviceNet-, ControlNet-, Modbus-, RS232- und RS485-Koppler
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 D0 | Ch1 CB/SB
 | 1 | Ch2 CB/SB | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0
 | 3 | - | -
Default-Mapping für: Profibus- und Interbus-Koppler
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 D1 | Ch1 CB/SB
 | 1 | Ch2 CB/SB | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1
 | 3 | - | -
Default-Mapping für: Lightbus- und EtherCAT und Ethernet-Koppler sowie Busklemmen Controller (BCxxxx, BXxxxx)
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: ja | 0 | Res. | Ch1 CB/SB
 | 1 | Ch1 D1 | Ch1 D0
 | 2 | Res. | Ch2 CB/SB
 | 3 | Ch2 D1 | Ch2 D0
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: ja | 0 | Res. | Ch1 CB/SB
 | 1 | Ch1 D0 | Ch1 D1
 | 2 | Res. | Ch2 CB/SB
 | 3 | Ch2 D0 | Ch2 D1
Legende
Komplette Auswertung | Die Klemme wird mit Control- und Status-Byte gemappt.
Motorola-Format | Es ist Motorola- oder Intel-Format einstellbar.
Word-Alignment | Die Klemme liegt auf einer Wortgrenze im Buskoppler.
Ch n CB | Control-Byte für Kanal n (erscheint im Prozessabbild der Ausgänge).
Ch n SB | Status-Byte für Kanal n (erscheint im Prozessabbild der Eingänge).
Ch n D0 | Kanal n, Datenbyte 0 (niederwertigste Byte)
Ch n D1 | Kanal n, Datenbyte 1 (höchstwertigste Byte)
"-" | Dieses Byte wird von der Klemme nicht benutzt und belegt.
Res. | Reserviert: dieses Byte belegt den Prozessdatenspeicher, hat aber kein Funktion.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Adresse | Bezeichnung | Defaultwert | R/W | Speichermedium
R0 | reserviert | 0x0000 | R |
... | ... | ... | ... | ...
R5 | reserviert | 0x0000 | R |
R6 | Diagnose-Register - reserviert | 0x0000 | R |
R7 | Kommando-Register - reserviert | 0x0000 | R |
R8 | Klemmentype | 1501 / 1512 | R | ROM
R9 | Software-Versionsnummer | 0x???? | R | ROM
R10 | Multiplex-Schieberegister | 0x0130 | R | ROM
R11 | Signalkanäle | 0x0128 / 0x0218 | R | ROM
R12 | minimale Datenlänge | 0x2828 / 0x1818 | R | ROM
R13 | Datenstruktur | 0x0000 / 0x0004 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Register | variabel | R/W | RAM
R16 | Hardware Versionsnummer | 0x???? | R/W | SEEROM
R17 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W | SEEROM
R31 | Code-Word-Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0100 / 0x0000 | R/W | SEEROM
R33 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R/W | SEEROM


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die Register können über die Registerkommunikation ausgelesen oder beschrieben werden. Sie dienen zur Parametrierung der Klemme.
R0 bis R7: Register im internen RAM der Klemme
Die Prozessvariablen können ergänzend zum eigentlichen Prozessabbild genutzt werden und sind in ihrer Funktion klemmenspezifisch.
▪
R6: Diagnoseregister
Das Diagnoseregister kann zusätzliche Diagnose-Information enthalten. So werden z.B. bei seriellen Schnittstellenklemmen Paritäts-Fehler, die während der Datenübertragung aufgetreten sind, angezeigt.
▪
R7: Kommandoregister
High-Byte_Write = Funktionsparameter
Low-Byte_Write = Funktionsnummer
High-Byte_Read = Funktionsergebnis
Low-Byte_Read = Funktionsnummer
R8 bis R15: Register im internen ROM der Klemme
Die Typ- und Systemparameter sind fest vom Hersteller programmiert und können vom Anwender nur ausgelesen und nicht verändert werden.
▪
R8: Klemmentyp
Der Klemmentyp in Register R8 wird zur Identifizierung der Klemme benötigt.
▪
R9: Softwareversion (X.y)
Die Software-Version kann als ASCII-Zeichenfolge gelesen werden.
▪
R10: Datenlänge
R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit.
Der Buskoppler sieht diese Struktur.
▪
R11: Signalkanäle
Im Vergleich zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z. B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.
▪
R12: Minimale Datenlänge
Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control- und Status-Byte nicht zwingend notwendig für die Funktion der Klemme und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen.
▪
R13: Datentypregister
Datentypregister | Bedeutung
0x00 | Klemme ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur 1Byte n Bytes
0x03 | Word-Array
0x04 | Struktur 1 Byte n Worte
0x05 | Doppelwort-Array
0x06 | Struktur 1 Byte n Doppelworte
0x07 | Struktur 1 Byte 1 Doppelwort
0x08 | Struktur 1 Byte 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur 1 Byte n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur 1 Byte n Worte mit variabler logischer Kanallänge
0x15 | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur 1 Byte n Doppelworte mit variabler logischer Kanallänge
▪
R15: Alignment-Bits (RAM)
Mit den Alignment-Bits wird die Analogklemme im Buskoppler auf eine Bytegrenze gelegt.
R16 bis R30: Bereich der Herstellerparameter (SEEROM)
Die Herstellerparameter sind spezifisch für jeden Klemmentyp. Sie sind vom Hersteller programmiert, können jedoch auch von der Steuerung geändert werden. Die Herstellerparameter sind spannungsausfallsicher in einem seriellen EERPOM in der Klemme gespeichert.
Diese Register können nur nach dem Setzen eines Code-Worts in R31 geändert werden.
R31 bis R47: Bereich der Anwenderparameter (SEEROM)
Die Anwenderparameter sind spezifisch für jeden Klemmentyp. Sie können vom Programmierer geändert werden. Die Anwenderparameter sind spannungsausfallsicher in einem seriellen EEPROM in der Klemme gespeichert. Der Anwenderbereich ist über ein Code-Wort schreibgeschützt.
• R31: Code-Wort-Register im RAM
Damit Parameter im Anwender-Bereich geändert werden können muss hier das Code-Wort 0x1235 eingetragen werden. Wird ein abweichender Wert in dieses Register eingetragen, so wird der Schreibschutz gesetzt. Bei inaktivem Schreibschutz wird das Code-Wort beim Lesen des Registers zurückgegeben. Ist der Schreibschutz aktiv, enthält das Register den Wert Null.
▪
R32: Feature-Register (nur KL1501)
KL1501: [0x0100], KL1512: nicht benutzt
Dieses Register legt die Betriebsarten der Klemme fest.
Feature Bit Nr. |  | Beschreibung der Betriebsart
Bit 0 | - | ohne Funktion
Bit 1 | 0/1 | Ausgabeformat 0: Standard Ausgabe [0] 1: Alternative Ausgabe
Bit 2 | 1 | Sind zwei Zähler aktiv, so wird das CNT_INH-Bit zum CNT_SET für den zweiten Zähler [0].
Bit 3 | 1 | Das Setzen des/der Zähler erfolgt bei einer positiven Flanke vom CNT_SET-Bit im Control-Byte [0]
Bit 4 | 1 | Die interne Funktion zum Setzen von Ausgang A0 ist aktiv [0].
Bit 5 | 1 | Die interne Funktion zum Rücksetzen von Ausgang A0 ist aktiv [0].
Bit 6 | 1 | Die interne Funktion zum Setzen von Ausgang A1 ist aktiv [0].
Bit 7 | 1 | Die interne Funktion zum Rücksetzen von Ausgang A1 ist aktiv [0].
Bit 10, 9, 8 | 001 | 32-Bit-Vor/Rückwärts-Zähler [001]. 24-Bit wenn alternatives Ausgabeformat aktiv.
 | 010 | Standard Ausgabe: 2 *16-Bit Vorwärts- Zähler Alternative Ausgabe: Zähler0 ist 8-Bit und Zähler1 ist 16-Bit breit Die Zählfrequenz ist begrenzt auf ca. 5-KHz. [Impulsbreite > 100 Mikrosekunden]
 | 100 | 32-bit Gated-Counter 24-Bit, wenn alternatives Ausgabeformat aktiv Gate- Eingang low: Zähler ist gesperrt
 | 101 | 32-bit Gated-Counter 24-Bit wenn alternatives Ausgabeformat aktiv Gate- Eingang high: Zähler ist gesperrt
Bit 11 | 0/1 | Zählrichtung 0: Vorwärts [0] 1: Rückwärts
Bit 12 | 1 | Bei gesetztem Bit wird Klemmenbuszugriff gepollt [0]
Bit 15, 14, 13 | - | Ohne Funktion [0], nicht ändern!


Control und Status Byte

Zugriff aus dem Anwenderprogramm [image] Control und Status Byte
Control und Status Byte
Das Control-Byte wird von der Steuerung zur Klemme übertragen. Es kann
▪
im Registermodus (REG = 1bin) oder
▪
im Prozessdatenaustausch (REG = 0bin) genutzt werden.
Weiterführende Informationen
•
KL1501 - Prozessdatenaustausch
•
KL1512 - Prozessdatenaustausch
•
Registerkommunikation


KL1501 - Prozessdatenaustausch

Zugriff aus dem Anwenderprogramm [image] Control und Status Byte [image] KL1501 - Prozessdatenaustausch
KL1501 - Prozessdatenaustausch
Control-Byte im Prozessdatenaustausch (REG=0)
Mit dem Control-Byte werden in der Zählerklemme KL1501 im Prozessdatenaustausch verschiedene Aktionen ausgelöst:
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG=0 | 0 | CNT_SET | CNT_INH | SET_A1 | SET_A0 | EN_A1 | EN_A0
Bit | Funktion
CNT_SET | Der Zähler wird auf den Wert, der über die Prozessdaten vorgegeben wird, gesetzt. Das Setzen des Zählers kann Flanken- oder pegelgesteuert erfolgen (siehe R32.3).
CNT_INH | Der Zähler wird gestoppt, solange dieses Bit aktiv ist. Der alte Zählerstand bleibt dabei erhalten. Sind zwei Zähler aktiv, so kann der zweite Zähler mit diesem Bit gesetzt werden.
SET_A1 | Setzt den zweiten Ausgang
SET_A0 | Setzt den ersten Ausgang
EN_A1 | Dieses Bit enabled die über R32 aktivierte interne Funktion.
EN_A0 | Dieses Bit enabled die über R32 aktivierte interne Funktion.
▪
Setzen der Ausgänge A0, A1
Mit den Control- Bits EN_A0, EN_A1 können die Funktionen zum Setzen der Ausgänge scharf geschaltet werden. Die Control- Bits SET_A0 bzw. SET_A1 werden bei gesetzten EN_A0, EN_A1 ignoriert.
Status-Byte im Prozessdatenaustausch (REG=0)
Das Statusbyte wird von der Klemme zur Steuerung übertragen. Das Statusbyte enthält verschiedene Statusbits der Zählerklemme KL1501
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG=0 | 0 | SET_ACC | INH_ACC | ST_A1 | ST_A0 | ST_V/R | ST_CLK
Bit | Funktion
SET_ACC | Die Daten zum Setzen des Zählers wurden von der Klemme übernommen.
INH_ACC | Solange dieses Bit gesetzt ist, ist der Zähler gestoppt.
ST_A1 | Der Zustand von Ausgang A1 wird in diesem Bit wiedergegeben.
ST_A0 | Der Zustand von Ausgang A0 wird in diesem Bit wiedergegeben.
ST_V/R | Der Zustand vom V/R- Eingang wird in diesem Bit wiedergegeben.
ST_CLK | Der Zustand von CLOCK- Eingang wird in diesem Bit wiedergegeben.


KL1512 - Prozessdatenaustausch

Zugriff aus dem Anwenderprogramm [image] Control und Status Byte [image] KL1512 - Prozessdatenaustausch
KL1512 - Prozessdatenaustausch
Control-Byte im Prozessdatenaustausch (REG=0)
Mit dem Control-Byte werden in der Zählerklemme KL1512 im Prozessdatenaustausch verschiedene Aktionen ausgelöst:
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG=0 | 0 | CNT_SET | CNT_INH | 0 | CNT_OVL | CNT_CLR | CNT_DEC
Name
Funktion
REG=0
0 für Prozessdatenbetrieb
0
Nicht benutzt
CNT_SET
Der Zähler wird auf den Wert, der über die Prozessdaten vorgegeben wird, gesetzt.
Das Setzen des Zählers erfolgt Flankengesteuert.
CNT_INH
Der Zähler wird gestoppt, solange dieses Bit aktiv ist. Der aktuelle Zählerstand bleibt dabei erhalten.
0
Nicht benutzt
CNT_OVL
Wenn dieses Bit gesetzt ist, wird der Zähler gestoppt,
▪
wenn er beim Vorwärtszählen 0xFFFF erreicht.
▪
wenn er beim Rückwärtszählen 0x0000 erreicht.
CNT_CLR
Der Zähler wird auf den Wert 0x0000 gesetzt. Das setzen des Zählers erfolgt Flankengesteuert.
CNT_DEC
Wenn dieses Bit gesetzt ist, wird der Zähler mit jeder positiven Flanke dekrementiert.
Status-Byte im Prozessdatenaustausch (REG=0)
Das Statusbyte wird von der Klemme zur Steuerung übertragen. Es quittiert die Bits des Control-Bytes.
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG=0 | 0 | SET_ACK | INH_ACK | 0 | OVL_ACK | CLR_ACK | DEC_ACK
Name
Funktion
REG=0
0 für Prozessdatenbetrieb
0
Nicht benutzt
SET_ACK
Quittung (Acknowledgement) für CNT_SET: Die Daten zum Setzen des Zählers wurden von der Klemme übernommen.
INH_ACK
Quittung für CNT_INH: Der Zähler ist gestoppt.
0
Nicht benutzt
OVL_ACK
Quittung für CNT_OVL: Wenn dieses Bit gesetzt ist, wird der Zähler gestoppt,
▪
wenn er beim Vorwärtszählen 0xFFFF erreicht.
▪
wenn er beim Rückwärtszählen 0x0000 erreicht.
CLR_ACK
Quittung für CNT_CLR: Der Zähler wird auf den Wert 0x0000 gesetzt. Das setzen des Zählers erfolgt Flankengesteuert.
DEC_ACK
Quittung für CNT_DEC: Wenn dieses Bit gesetzt ist, wird der Zähler mit jeder positiven Flanke dekrementiert.


Registerkommunikation

Zugriff aus dem Anwenderprogramm [image] Control und Status Byte [image] Registerkommunikation
Registerkommunikation
Registerzugriff über den Prozessdatenaustausch
▪
Bit 7=1: Registermodus
Wenn Bit 7 des Control-Bytes gesetzt wird, werden die ersten zwei Byte der Nutzdaten nicht zum Prozessdatenaustausch verwendet, sondern in den Registersatz der Klemme geschrieben oder daraus ausgelesen.
▪
Bit 6=0: lesen, Bit 6=1: schreiben
In Bit 6 des Control-Bytes legen Sie fest, ob ein Register ausgelesen oder beschrieben werden soll.
–
Bit 6=0: Ein Register wird ausgelesen, ohne es zu verändern. Der Wert kann dem Eingangs-Prozessabbild entnommen werden.
–
Bit 6=1: Die Nutzdaten werden in ein Register geschrieben. Sobald das Status-Byte im Eingangs-Prozessabbild eine Quittung geliefert hat, ist der Vorgang abgeschlossen (siehe Bsp.).
▪
Bit 0 bis 5: Adresse
In die Bits 0 bis 5 des Control-Bytes wird die Adresse des anzusprechenden Registers eingetragen
Control-Byte im Register-Modus (REG=1)
MSB
REG=1
W/R
A5
A4
A3
A2
A1
A0
REG = 0: Prozessdatenaustausch
REG = 1: Zugriff auf Registerstruktur
W/R = 0: Register lesen
W/R = 1: Register schreiben
A5..A0 = Registeradresse
Mit Adressen A5...A0 sind insgesamt 64 Register adressierbar.
Register-Modus Control Byte
Das Control- bzw. Status-Byte belegt die niedrigste Adresse eines logischen Kanals. Die entsprechenden Registerwerte befinden sich in den folgenden 2-Datenbytes. (Ausnahme ist der BK2000: hier wird nach dem Control- bzw. Status-Byte ein nicht genutztes Daten-Byte eingeschoben, und somit der Registerwert auf eine Word-Grenze gelegt).


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Datenaustausch, Funktion (nur KL1501)

Zugriff aus dem Anwenderprogramm [image] Datenaustausch, Funktion (nur KL1501)
Datenaustausch, Funktion (nur KL1501)
Automatisches Setzen der Ausgänge bei definierten Zäherständen
Über das Feature-Register R32 kann eine interne Funktion zum Setzen der Ausgänge aktiviert werden.
▪
V/R-Zähler bzw. Gated-Zähler:
–
Erreicht der Zähler den Zählerstand 0x80000000, wird der Ausgang A0 gesetzt (Feature-Bit 5) bzw. zurückgesetzt (Feature-Bit 6).
–
Läuft der Zähler über, wird der Ausgang entsprechend zurückgenommen.
–
Ausgang A1 wird parallel mit Bit 15 gesetzt (0x8000).
▪
Zwei Zähler aktiv:
–
Erreicht der entsprechende Zähler den Zählerstand 0x8000, wird der Ausgang (A1, A0) gesetzt (Feature-Bit 4,6) bzw. zurückgesetzt (Feature-Bit 5,7).
–
Läuft der Zähler über, wird der Ausgang entsprechend zurückgenommen.
Beispiel:
Feature-Register = 0x02AC d. h.:
Zwei Zähler sind aktiv.
Das Setzen des Zählers erfolgt über die positive Flanke der CNT_SET Bits.
Das Control-Bit CNT_INH ist zuständig für das Setzen des zweiten Zählers.
Es soll ein Glas Bier mit 200 ml gefüllt werden.
Dabei entspricht ein Impuls 0.01 ml => 1 Glas entspricht 20000 Impulse (0x31E0 = 0x8000-20000).
Erster Zähler | Control-Byte | Status-Byte | Ausgangs-daten | Ausgang A0 | Funktion
0x0000 | 0x00 | 0x00 | 0x0000 | Low | Power-On-Reset
0x0000 | 0x22 | 0x00 | 0x31E0 | Low | Zähler wird gesetzt, interne Funktion aktiviert
0x31Ex | 0x02 | 0x28 | egal | High | Das Bier läuft.
… |  |  |  |  |
0x8000 | 0x02 | 0x00 | egal | Low | Das erste Glas ist voll.
… |  |  |  |  |
0x8000 | 0x22 | 0x00 | 0x31E0 | Low | Zähler wird gesetzt, interne Funktion aktiviert
0x31Ex | 0x02 | 0x28 | egal | High | Das Bier läuft.
… |  |  |  |  |
0x8000 | 0x02 | 0x00 | egal | Low | Das zweite Glas ist voll.
… |  |  |  |  |


TwinCAT

TwinCAT
TwinCAT
SPS und Motion Control auf dem PC
TwinCAT - The Windows Control and Automation Technology
Die Automatisierungs-Software TwinCAT verwandelt jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS, NC-Achsregelung, Programmierumgebung und Bedienstation. TwinCAT substituiert herkömmliche SPS- und NC/CNC-Steuerungen sowie Bediengeräte:
▪
offene, kompatible PC-Hardware
▪
Einbettung von IEC 61131-3-Software-SPS, Software-NC und Software-CNC in Windows NT/2000/XP, NT/XP Embedded, CE
▪
Programmiersystem und Laufzeit wahlweise auf einem PC oder getrennt
▪
Anbindung an alle gängigen Feldbus-Systeme
▪
PC-Schnittstellen werden unterstützt
▪
Datenanbindung an Bedienoberflächen und andere Programme mittels offener Standards (OPC, OCX, DLL etc.)
TwinCAT-Architektur
TwinCAT besteht aus Laufzeitsystemen zur Echtzeitausführung von Steuerungsprogrammen und den Entwicklungsumgebungen zur Programmierung, Diagnose und Konfiguration. Alle Windows-Programme, beispielsweise Visualisierungen oder Office-Produkte, können über Microsoft-Schnittstellen auf TwinCAT-Daten zugreifen oder Kommandos ausführen.
Praxisorientierte Softwarelösung
TwinCAT bietet eine genaue Zeitbasis, die mit höchster Deterministik Programme unabhängig von anderen Prozessoraufgaben ausführt. Die Echtzeitlast auf einem PC wird mit TwinCAT eingestellt: Auf diese Weise wird ein definiertes Betriebsverhalten erreicht. TwinCAT zeigt die Systemlast für laufende Programme an. Eine Lastgrenze kann eingestellt werden, um für die Bedienprogramme und Windows NT/2000/XP eine definierte Rechenkapazität zur Verfügung zu stellen. Bei Überschreiten dieser Grenze wird eine Systemmeldung generiert.
TwinCAT unterstützt die Systemdiagnose
Die freie Verwendung von Hardware oder Software aus der offenen PC-Welt erfordert ihre Prüfung: Ungeeignete Komponenten können das PC-System außer Tritt bringen. Beckhoff integriert eine praktische Anzeige des Jitters der Echtzeit, um einem Administrator ein einfaches Mittel zur Evaluierung von Hardware und Software an die Hand zu geben. Im Betrieb kann eine Systemmeldung auf Fehlerzustände aufmerksam machen.
Start-/Stoppverhalten
TwinCAT startet und stoppt, je nach Einstellung, durch manuellen Eingriff oder automatisch. Da TwinCAT als Service in Windows NT/2000/XP integriert ist, wird zum Systemstart kein Bediener benötigt: Strom einschalten genügt.
Wiederanlauf und Datensicherung
TwinCAT lädt beim Start oder Wiederanlauf Programme und remanente Daten. Zur Datensicherung und zum korrekten Beenden von Windows NT/2000/XP empfiehlt sich eine USV (unterbrechungsfreie Stromversorgung).
TwinCAT und „Blue Screen“
Das TwinCAT-System kann so konfiguriert werden, dass die Echtzeit im Falle eines Betriebssystemabsturzes BSOD (Blue-Screen-of-Death) funktionell erhalten bleibt. Echtzeittasks, wie z. B. die SPS und NC, können somit weiterlaufen und den gesteuerten Prozess in einen sicheren Zustand bringen. Letztlich liegt es in der Entscheidung des Programmierers, diese Eigenschaft zu nutzen in Anbetracht dessen, dass Daten oder Programme durch den BSOD bereits zerstört sein können.
Weltweite Verbindung per Message-Routing – Remote-Verbindung ist systemimmanent
Die Softwaregeräte von TwinCAT können, je nach Anforderung, auf Betriebsmittel verteilt werden: TwinCAT-SPS-Programme können auf PCs und auf Beckhoff Busklemmen Controllern ablaufen. Ein „Message-Router“ verwaltet und verteilt alle Nachrichten im System und über TCP/IP-Verbindungen. PC-Systeme können per TCP/IP miteinander verbunden werden; Busklemmen Controller werden über serielle Schnittstellen und über Feldbus-Systeme (EtherCAT, Lightbus, PROFIBUS DP, PROFINET, Interbus, CANopen, DeviceNet, RS232, RS485, Ethernet TCP/IP, Ethernet/IP) angebunden.
Weltweiter Zugriff
Da Standard-TCP/IP-Dienste von Windows NT/2000/XP genutzt werden, kann dieser Datenaustausch weltweit erfolgen. Das System bietet skalierbare Kommunikationsleistung und Time-out-Zeiten zur Überwachung von Kommunikationen. Mittels OPC kann auf einem standardisierten Weg auf viele unterschiedliche SCADA-Pakete zugegriffen werden. Mit dem SOAP (Simple-Object-Access-Protocol) kann über eine Internetverbindung via Standard-HTTP eine Verbindung zwischen zwei Rechnern hergestellt werden. Auch hierzu bietet TwinCAT eine Komponente an.
Beckhoff-Information-System
Weitere Informationen über die Automatisierungs-Software TwinCAT finden Sie im Beckhoff-Information-System.
Das Setup zur Installation des Beckhoff-Information-Systems steht Ihnen auf der Beckhoff-DVD Products & Solutions und auf unseren Internetseiten zum Download zur Verfügung.
Außerdem finden Sie unter http://infosys.beckhoff.com die Online-Version des Beckhoff-Information-System.
Weiterführende Informationen
•
Programmierung
•
Funktionsbaustein FB_KL1501Config


Programmierung

TwinCAT [image] Programmierung
Programmierung
TwinCAT-Bibliotheken
Siehe Software-Dokumentation im Beckhoff-Information-System.
TwinCAT 2: TwinCAT PLC Lib: IO Funktionen
TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_IoFunctions


Funktionsbaustein FB_KL1501Config

TwinCAT [image] Funktionsbaustein FB_KL1501Config
Funktionsbaustein FB_KL1501Config
Mit dem Funktionsbaustein FB-KL1501Config kann die Klemme KL1501 konfiguriert werden. Eine ausführliche Beschreibung Sie im Beckhoff Information System:
TwinCAT2: TwinCAT PLC Lib: IO Funktionen/Busklemmen-Konfiguration
TwinCAT3: TwinCAT 3 PLC Lib:Tc2_IoFunctions/Funktionsbausteine/Busklemmen-Konfiguration


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.