BECKHOFF Fieldbus Components

Documentation of

Fieldbus Box for Ethernet/IP

Version: 1.0.1
Date: 2009-10-30


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety Instructions

Safety Rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

State at Delivery

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.

Description of safety symbols

The following safety symbols are used in this operating manual. They are intended to alert the reader to the associated safety instructions.

Danger This symbol is intended to highlight risks for the life or health of personnel.

Warning This symbol is intended to highlight risks for equipment, materials or the environment.

Note This symbol indicates information that contributes to better understanding.


Fieldbus Box for Ethernet/IP - Document Issue Status

BECKHOFF Fieldbus Box: Foreword

Document Issue Status

Version | Comment
1.0.1 | System overview updated
1.0 | First version


Bus Coupler as a general term

Parts of this manual give general information about Ethernet implementation in Beckhoff products.
Thus in the following often the term Bus Coupler is used, that describes not only the IP20 products, but also means the IP67 modules.


The Fieldbus Box System

Fieldbus box modules are robust fieldbus stations for a large number of different fieldbus systems. They offer a wide range of I/O functionality. All relevant industrial signals are supported. As well as digital and analog inputs and outputs including thermocouple and RTD inputs, there are also incremental encoder interfaces available for displacement and angle measurement as well as serial interfaces to solve a large number of communications tasks.

Three varieties of signal connection

The digital inputs and outputs can be connected with snap-on 8 mm diameter plugs, screw-in M8 connectors, or with screw-in M12 pendants. The M12 version is provided for analog signals.

All important signal types

Special input and output channels on the combination I/O modules can be used for either input or output. It is not necessary to configure them, since the fieldbus interface is available for every combination channel as well as for input and output data. The combination modules give the user all of the advantages of fine signal granularity.

The processor logic, the input circuitry and the power supply for the sensor are all fed from the control voltage. The load voltage for the outputs can be supplied separately. In those Fieldbus Boxes in which only inputs are available, the load power supply, UP, can optionally be connected in order to pass it on downstream.

The states of the Fieldbus Box, the fieldbus connection, the power supplies and of the signals are indicated by LEDs.

The label strips can be machine printed elsewhere, and then inserted.

Fieldbus Boxes can be combined for greater flexibility

In addition to the Compact Box, the Fieldbus Box series also includes extendable devices, namely the Coupler Box and the Extension Box, as well as intelligent devices, the PLC Boxes.

Compact Box

The Compact Box makes the I/O data from the connected digital and analog sensors and actuators available to the fieldbus.

Coupler Box

The Coupler Box also collects I/O data from the Extension Boxes via an interference-proof optical fiber connection (IP-Link). Up to 120 Extension Boxes can be connected to a Coupler Box. In this way a distributed IP67 I/O network is formed with only one fieldbus interface.

The Coupler Box is capable of automatically recognizing the extension modules connected to it during start-up, and maps the I/O data automatically into the fieldbus process image – a configuration is not necessary. The Coupler Box appears, from the fieldbus point of view, along with all of the networked Extension Boxes, as a single participating bus device with a corresponding number of I/O signals.

The Coupler Box corresponds to the Bus Coupler in the BECKHOFF Bus Terminal system. BECKHOFF fieldbus devices made to protection class IP 20 (Bus Terminals) and IP 67 (Fieldbus Box) can be combined without difficulty – the data is handled in the same way in either case.

IP-Link

The IP-Link is an optical fiber connection with a transmission rate of 2 MBits/s which is capable of transmitting 1000 items of binary I/O data in approx. 1 ms, rapidly and securely. Smaller configurations are correspondingly faster. Because of the high usable data rate, the coupling via IP-Link does not reduce the performance of the fieldbus at all.

Low-priced plug connectors made according to Protection Class IP 67 can be used for the rapid and simple preparation of the IP-Link cable, in situ. The connection does not require special tools, and can be performed quickly and simply. The IP-Link cables can also be obtained with prepared plugs if required.

The separate supply of the output voltage allows output groups to be switched off individually. Differing potentials can also be created within an extension ring without difficulty, since the IP-Link naturally has optimum electrical isolation.

Extension box

Like the Compact Boxes, the Extension Boxes cover the full spectrum of I/O signals, and may be up to 15 m apart. They are remarkably small in size, and lead to particularly economical I/O solutions with high levels of protection. Here again, the digital inputs and outputs may optionally be connected via snap-on 8 mm connectors, or via screw-in connectors (M8 and M12). Analog signal types are provided with the M12 version. The snap-on connectors lock in place positively, forming a shake-proof connection, while the screw-in connectors offer the advantage of high resistance to being pulled out.

PLC Box

The PLC Box is an intelligent Fieldbus Box with PLC functionality for distributed pre-processing of the I/O signals. This allows parts of the application to be farmed out from the central controller. This reduces the load on the CPU and the fieldbus. Distributed counting, controlling and switching are typical applications for the PLC Box. The reaction times are independent of the bus communication and of the higher-level controller.

In the event of a bus or controller failure, maintenance of function (e.g. bringing the process to a safe state in an orderly manner) is possible.

Programming is carried out with TwinCAT in accordance with IEC 61131-3. Five different programming languages are available:

  • Instruction List (IL)

  • Function Block Diagram (FBD)

  • Ladder Diagram (LD)

  • Sequential Function Chart (SFC)

  • Structured Text (ST)

The program download occurs either via the fieldbus or via the programming interface.

Extensive debugging functions (breakpoint, single step, monitoring, etc) are also available. The PLC Box contains a powerful 16 bit controller, 32/96 kByte program memory and 32/64 kByte data memory. A further 512 bytes of non-volatile memory are available for remanent flags.

PLC Box with IP-Link

The programmable PLC Box with IP-Link provides almost unlimited I/O possibilities. Up to 120 extension modules, with more than 2000 I/Os, can be directly addressed from the PLC program. The PLC Box is thus also suitable for use as a small, autonomous controller for the operation of parts of equipment or small machines.


Fieldbus Box - Naming conventions

The identifications of the Fieldbus Box modules are to be understood as follows:
IXxxxy-zyyy

IX describes the design:

"IP" stands for the Compact Box design
"IL" stands for the Coupler Box design (with IP-Link)
"IE" stands for the Extension Box design

xxxy describes the I/O connection:

xxx describes the I/O property:
"10x" - 8 x digital inputs
"15x" - counter module
"20x" - 8 x digital outputs
"25x" - PWM module
"23x" - 4 x digital inputs and 4 x digital outputs
"24x" - 8 x digital inputs and 8 x digital outputs
"3xx" - 4 x analog inputs
"4xx" - 4 x analog outputs
"5xx" - incremental encoder or SSI transducer
"6xx" - Gateway module for RS232, RS422, RS485, TTY

y represents the mechanical connection:
"0" stands for 8mm snap-on connection,
"1" stands for M8 bolted connection
"2" stands for M12 bolted connection and
"9" stands for M23 bolted connection

zyyy describes the programmability and the fieldbus system

z distinguishes whether the device is a slave or is a programmable slave:

"B" - not programmable
"C" - programmable (PLC Box)

"yyy" stands for the fieldbus system and the bus connection:
"110" - EtherCAT
"200" - Lightbus
"310" - PROFIBUS
"318" - PROFIBUS with integrated tee-connector
"400" - Interbus
"510" - CANopen
"518" - CANopen with integrated tee-connector
"520" - DeviceNet
"528" - DeviceNet with integrated tee-connector
"730" - Modbus
"800" - RS485
"810" - RS232
"900" - Ethernet TCP/IP with RJ45 for the bus connection
"901" - Ethernet TCP/IP with M12 for the bus connection
"903" - PROFINET
"905" - EtherNet/IP

Compact Box

The Compact Box modules offer a wide range of I/O functionality. All relevant industrial signals are supported. The digital inputs and outputs can be connected either with snap-on 8 mm diameter plugs, screw-in M8 connectors, or screw-in M12 connectors. The M12 version is made available for analog signals.

Depending on the module, the I/O section and the power supply section can differ.

Coupler Box

There are three versions of the coupler box named IL230x-Bxxx. It differs from the compact box in that this module offers an interface to what are known as extension boxes. This interface is a subsidiary bus system based on the optical fiber what is known as IP Link. This powerful subsidiary bus system can handle up to 120 extension boxes at one coupler box.

Extension Box

Extension Modules, that are independent of the fieldbus and that can only be operated together with a coupler box via IP Link.

PLC Box

A PLC Box differ from the Coupler Box in that this module can be programmed in IEC 61131-3. This means that this slave is also capable of working autonomously, without a master, for instance for control or regulation tasks.


Firmware and hardware issue status

The documentation refers to the hardware and software status that was valid at the time it was prepared. The properties are subject to continuous development and improvement. Modules having earlier production statuses cannot have the same properties as modules with the latest status. Existing properties, however, are always retained and are not changed, so that these modules can always be replaced by new ones.
The number beginning with a D allows you to recognize the firmware and hardware status of a module.

Syntax:

D . ww yy x y z u

ww - calendar week
yy - year
x - bus board firmware status
y - bus board hardware status
z - I/O board firmware status
u - I/O board hardware status

Example:

D.22081501

- Calendar week 22
- in the year 2008
- bus board firmware status: 1
- bus board firmware hardware status: 5
- I/O board firmware status: 0 (no firmware is necessary for this board)
- I/O board hardware status: 1


Fieldbus Box for Ethernet/IP - Technical Data

BECKHOFF Fieldbus Box: Product Overview

Technical Data

Technical data | IL230x-B900
Extension modules (IL....) | max. 120
Maximum number of bytes (IL....) | 512Byte In- and 512 Byte Output
Transmission medium | 4 x 2 twisted pair copper cable; category 3 (10 MBaud), category 5 (100 MBaud)
Transfer rate | 10/100 MBaud
Topology | star shaped cabling
Distance between modules | 100 meters (Hub/Switch to Fieldbus Box)
Configuration | via KS2000 or via controller
Protocols | Ethernet/IP
Power supply | Control voltage: 24VDC (-15%/+20%); load voltage: according to I/O type
Control voltage current consumption | according to I/O type + current consumption of sensors, max. 0.5 A
Load voltage current consumption | according to I/O type
Power supply connection | Feed: 1 x M8 connector 4-pin downstream connection: 1 x M8 socket 4-polig
Connection Fieldbus | 1 x M12 d-coded socket (female)
Electrical isolation | Channels / control voltage: no between the channels: no control voltage / fieldbus: yes
Permissible ambient temperature range during operation | 0°C ... +55°C
Permissible ambient temperature range during storage | -25°C ... +85°C
Vibration / shock resistance | according to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance burst / ESD | according to EN 61000-6-2 (EN 50082) / EN 61000-6-4 (EN 50081)
Protection class | IP 65/66/67 (according to EN 60529)
Installation position | variable
Approvals | CE

Note Detailed technical data about all available I/O types can be found in the document Signal Types, Installation, Configuration of the I/O modules, that may be found on the Beckhoff CD Products & Solutions or in the internet (http://www.beckhoff.com) under Download/Fieldbus Box.


Fieldbus Box for Ethernet/IP - Ethernet

BECKHOFF Fieldbus Components: Ethernet

Ethernet

Ethernet was originally developed by DEC, Intel and XEROX (as the DIX standard) for passing data between office devices. The term nowadays generally refers to the IEEE 802.3 CSMA/CD specification, published in 1985. Because of the high acceptance around the world this technology is available everywhere and is very economical. This means that it is easy to make connections to existing networks.

There are now a number of quite different transmission media: coaxial cable (10Base5), optical fiber (10BaseF) or twisted pairs (10BaseT) with screen (STP) or without screen (UTP). A variety of topologies such as ring, line or star can be constructed with Ethernet.

Ethernet transmits Ethernet packets from a sender to one or more receivers. This transmission takes place without acknowledgement, and without the repetition of lost packets. To achieve reliable data communication, there are protocols, such as TCP/IP, that can run on top of Ethernet.

MAC-ID

The sender and receiver of Ethernet packets are addressed by means of the MAC-ID. The MAC-ID is a 6 byte identification code unique to every Ethernet device in the world. The MAC-ID consists of two parts. The first part (i.e. the first 3 bytes) is a manufacturer identifier. The identifier for Beckhoff is 00 01 05. The next 3 bytes are assigned by the manufacturer and implement a unique serial number. The MAC-ID can, for example, be used for the BootP protocol in order to set the TCP/IP number. This involves sending a telegram containing the information such as the name or the TCP/IP number to the corresponding node. You can read the MAC-ID with the KS2000 configuration software.

The Internet Protocol (IP)

The internet protocol (IP) forms the basis of this data communication. IP transports data packets from one device to another; the devices can be in the same network, or in different networks. IP here looks after the address management (finding and assigning MAC-IDs), segmentation and routing. Like the Ethernet protocol, IP does not guarantee that the data is transported - data packets can be lost, or their sequence can be changed.

TCP/IP was developed to provide standardized, reliable data exchange between any number of different networks. TCP/IP is thus substantially independent of the hardware or software being used. Although the term is often used as if it were a single concept, a number of protocols are layered together: e.g. IP, TCP, UDP, ARP and ICMP.

Transmission Control Protocol (TCP)

The Transmission Control Protocol (TCP) which runs on top of IP is a connection-oriented transport protocol. It includes error detection and error handling mechanisms. Lost telegrams are repeated.

User Datagram Protocol (UDP)

UDP is connectionless transport protocol. It provides no control mechanism when exchanging data between sender and receiver. This results in a higher processing speed than, for example, TCP. Checking whether or not the telegram has arrived must be carried out by the higher-level protocol.


Topology

In 10BaseT and 100BaseT a number of stations are star connected according to the Ethernet standard.

Star topology

The simplest form of a star LAN consists of a single point-to-point connection. All messages pass via a central node (the hub or switch), which then passes the information to the desired device according to the destination address.

Tree topology

A tree topology consists of a number of connected star networks. As soon as the network contains a number of hubs or switches, the topology is classified as a tree. Ideally the connections between the star couplers have a particularly wide bandwidth, since these transport the most traffic. When constructing tree topologies, the repeater rule must be observed. This is also known as the 5-4-3 repeater rule. There must be no more than two pairs of repeaters (or of hubs) in the transmission path between any two stations, unless they are separated by bridges, switches or routers. A transmission path may consist of at most five segments and four repeater sets (two repeater pairs). Up to three of these segments may be coaxial segments to which the stations are connected. The remaining segments must consist of point-to-point connections; these are also known as IRL (inter repeater link) connections.

Cabling guidelines

Structured cabling provides general guidelines for constructing the cabling for a LAN. It specifies maximum permitted cable lengths for the wiring within the grounds, building or floor. Standardized in EN 50173, ISO 11801 and TIA 568-A, structured cabling provides the basis for an advanced, application-independent and economical network infrastructure. The wiring standards are applicable to a range defined as having a geographical extent of up to 3 km and an office area of up to one million sq meters, with between 50 and 50,000 end devices. Recommendations for the structure of a cabling system are also given. The figures can vary, depending on the topology selected, the transmission media and coupling modules used under industrial conditions, and on the use of components from various manufacturers in one network. The given figures should therefore only be considered as recommendations.


Ethernet Cable

Transmission standards

10Base5

The transmission medium for 10Base5 consists of a thick coaxial cable ("yellow cable") with a max. transmission speed of 10 MBaud arranged in a line topology with branches (drops) each of which is connected to one network device. Because all the devices are in this case connected to a common transmission medium, it is inevitable that collisions occur often in 10Base5.

10Base2

10Base2 (Cheapernet) is a further development of 10Base5, and has the advantage that the coaxial cable is cheaper and, being more flexible, is easier to lay. It is possible for several devices to be connected to one 10Base2 cable. It is frequent for branches from a 10Base5 backbone to be implemented in 10Base2.

10BaseT

Describes a twisted pair cable for 10 MBaud. The network here is constructed as a star. It is no longer the case that every device is attached to the same medium. This means that a broken cable no longer results in failure of the entire network. The use of switches as star couplers enables collisions to be reduced. Using full-duplex connections they can even be entirely avoided.

100BaseT

Twisted pair cable for 100 MBaud. It is necessary to use a higher cable quality and to employ appropriate hubs or switches in order to achieve the higher data rate.

10BaseF

The 10BaseF standard describes several optical fiber versions.

Short description of the 10BaseT and 100BaseT cable types

Twisted pair copper cable for star topologies, where the distance between two devices may not exceed 100 meters.

UTP

Unshielded twisted pair
This type of cable belongs to category 3, and is not recommended for use in an industrial environment.

S/UTP

Screened/unshielded twisted pair (screened with copper braid)
Has a general screen of copper braid to reduce influence of external interference. This cable is recommended for use with Bus Couplers.

FTP

Foiled shielded twisted pair (screened with aluminum foil)
This cable has an outer screen of laminated aluminum and plastic foil.

S/FTP

Screened/foiled-shielded twisted pair (screened with copper braid and aluminum foil)
Has a laminated aluminum screen with a copper braid on top. Such cables can provide up to 70 dB reduction in interference power.

STP

Shielded twisted pair
Describes a cable with an outer screen, without defining the nature of the screen any more closely.

S/STP

Screened/shielded twisted pair (wires are individually screened)
This identification refers to a cable with a screen for each of the two wires as well as an outer shield.

ITP

Industrial Twisted-Pair
The structure is similar to that of S/STP, but, in contrast to S/STP, it has only one pair of conductors.


Fieldbusbox - Dimensions

BECKHOFF Fieldbus Box: Mounting and wiring

Dimensions

All dimensions are given in millimeters.

General

Technical data | Fieldbus Box
Material | PA6 (polyamide), casting compound: polyurethane
Assembly | 2 x fixing holes for M3
Metal parts | Brass, nickel-plated
Contacts | CuZn, gold-plated
Vibration / shock resistance | according to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance burst / ESD | according to EN 61000-6-2 (EN 50082) / EN 61000-6-4 (EN 50081)
Permissible ambient temperature during operation | 0 ... 55°C
Permissible ambient temperature during storage | -25 ... + 85°C
Installation position | any
Type of protection | IP65/66/67 when screwed together
Approvals | CE, UL E172151

IPxxxx-Bxx8, IL230x-Bxx8, IL230x-B110, IXxxxx-B400, IXxxxx-B90x, IXxxxx-C900

Technical data | Compact and Coupler Box with integrated tee connector
Dimensions (H x W x D) | ca. 210 x 30 x 26,5 mm (height to upper edge of fieldbus socket: 30 mm)
Weight | ca. 260 g - 290 g, depending on module type

IPxxxx-Bxx0, IL230x-Bxx0, IL230x-Cxx0

Technical data | Compact and Coupler Box
Dimensions (H x W x D) | Approx. 175 x 30 x 26.5 mm (height to upper edge of fieldbus socket: 30 mm, with T- connector ZS1031-2600 height approx. 65 mm)
Weight | Approx. 250 g - 280 g, depending on module type

IExxxx

Technical data | Extension box
Dimensions (H x W x D) | Approx. 126 x 30 x 26.5 mm
Weight | Approx. 120 g - 200 g, depending on module type


FBB-B901, FBB-B903, FBB-B905 - Ethernet Connection

BECKHOFF Fieldbus Box: Mounting and Wiring

Ethernet Connection

The connection to the Ethernet bus is made via an d-coded M12 female socket.

The cable should be CAT5 or CAT5e cable.

Cabling

Connection via hub or switch

Connect the PLC's network interface to the hub using a standard Ethernet cable, and connect the hub, again using a standard Ethernet cable, to the Fieldbus Box.

Connection via a switch is done in the same way.

Direct connection between PLC and IL230x-B90x

To connect the PLC directly to the Fieldbus Box, you must use an Ethernet cable in which the pairs of cores have been crossed (a crossover cable).

Pin assignment of the M12 connector

PIN | Signal | Description
1 | TD + | Transmit Data +
2 | RD + | Receive Data +
3 | TD - | Transmit Data -
4 | RD - | Receive Data -
housing | Shield | Shield

Note: There is no standardized color setting for the wires!


Fieldbus Box - Ethernet connector: M12

BECKHOFF Fieldbus Components: Mounting and Wiring

Ethernet connector: M12

The connection to the Ethernet is done with an d-coded M12 socket (IP67).


Note about parameterization

Note

Changes, e.g. the MAC-ID, that were done with the KS2000 configuration software are only stored in the volatile memory (RAM) of the Fieldbus Box.

After the changes a software reset is required. By this, the changes will be copied into the flash memory and are permanent.

A Cold-Start (Power-ON/OFF) is not enough. It has to be a software reset!


Start-up behavior of the Fieldbus Box

After power up, the Fieldbus Box checks its state, configures the IP-Link (if present) and refers to the extension modules to create a structure list. If the Fieldbus Box contains a decentralized controller (IL230x-C310) the local PLC is started once the structure list has successfully been created.
The I/O LEDs illuminate and flash as the module starts up. If there are no errors, the I/O LEDs should stop flashing within about 2-3 seconds. If there is an error, then the LED that flashes will depend on the type of that error (see Diagnostic LEDs).

Start_List.gif (8211 Byte)


Parameterizing via Rotary Switches

By using the rotary switches, the following parameterizations are possible without software changes.

Hex switch x10 | Hex switch x1 | Meaning
0x0 - D | 0x0 - F | IP address direct via switch
0xF | 0x0 | IP address via DHCP server
0xF | 0x1 | IP address via BootP server
0xF | 0x2 | BootP save address
Hex switch x10 | Hex switch x1 | Meaning (Power ON/OFF)
0xF | 0x3 | Fast ModbusTCP active (only B900, B901)
0xF | 0x4 | Fast ModbusTCP inactive (only B900, B901)
0xF | 0x5 | BOOTP / DHCP Server 2.3 (Rockwell) (only B905)
0xF | 0x6 | reserved
0xF | 0x7 | reserved
0xF | 0x8 | reserved
0xF | 0x9 | reserved
0xF | 0xA | reserved
0xF | 0xB | reserved
0xF | 0xC | deletes AMS NetID table
0xF | 0xD | sets fieldbus specific default values
0xF | 0xE | deletes boot project (only for Controller Box IL230x-C900)
0xF | 0xF | Sets module back to manufacturer settings
Restoring the manufacturer settings
  • Switch of the module.
  • Set the rotary switches to 0xFF and switch on the module.
  • After setting the default parameter successfully, the LEDs I/O RUN and I/O ERR are flashing simultaneously.
  • Now you can switch of the module again, to set the IP address.
Delete the boot project (only for Controller Box IL230x-C900)
  • Switch of the module.
  • Set the rotary switches to 0xFE and switch on the module.
  • After deleting the boot project successfully, the LEDs I/O RUN and I/O ERR are flashing simultanously.
  • Now you can switch of the module again, to set the IP address.
Setting the Ethernet parameters
  • Switch of the module.
  • Set the rotary switches to 0xFD and switch on the module.
  • The LEDs I/O RUN and I/O ERR are flashing.
  • The default values of table 100 are set.
  • Now you can switch of the module again, to set the IP address.


Fieldbus Box for Ethernet/IP - IP-address

BECKHOFF Fieldbus Box: Parameterization and Commissioning

IP-address

The IP address can be set using four different procedures, and these will be described in more detail below.

Procedure | Explanation | Necessary components
KS2000 | Addressing using the KS2000 configuration software and DIP switches | KS2000 configuration software and KS2000 cable
ARP | Addressing via the ARP table | PC with network
BootP | Addressing via BootP server | BootP-Server
DHCP | Addressing via DHCP server | DHCP-Server

Hex switch x10 | Hex switch x1 | Meaning
0x0 - D | 0x0 - F | IP address direct via switch
0xF | 0x0 | IP address via DHCP-Server
0xF | 0x1 | IP address via BootP-Server
0xF | 0x2 | BootP save Address
0xF | 0x3 | Fast ModbusTCP active (only IL230x-B900,- B901)
0xF | 0x4 | Fast ModbusTCP inactive (only IL230x-B900,- B901)
0xF | 0x5 | IP address via BootP-Server (Rockwell, only IL230x-B905)
0xF | 0x6 | reserved
0xF | 0x7 | reserved
0xF | 0x8 | reserved
0xF | 0x9 | reserved
0xF | 0xA | reserved
0xF | 0xB | reserved
0xF | 0xC | delete AMS NetID table
0xF | 0xD | set fieldbus specific default values
0xF | 0xE | delete Boot project (only for IL230x-C900)
0xF | 0xF | manufacturer setting


Ethernet - Network Classes

BECKHOFF Fieldbus Components: Ethernet

Network Classes

Three different network classes are distinguished. They specify how many address bits are reserved for the Network -ID and how many for the computer number (or node number). The difference is located in the first 3 bits of the IP address.

Network- class | Number of bits for the Network ID | Possible number of networks | Number of bits for the node address | Possible number of nodes per network
A | 7 | 126 | 24 | 16 777 214
B | 14 | 16 382 | 16 | 65 536
C | 21 | 2 097 150 | 8 | 254

Warning An IP address must be unique within the entire connected network!

Note In a communication with another Ethernet devices, the IP address set must have the same network class. Example: Your PC has address 172.16.17.55, which means that the Bus Coupler must have address 172.16.xxx.xxx (each xxx stands for a number between 0...255. The 0 is normally used for routers/switches, and should therefore be reserved).

In order to see the PC's own address, the command ipconfig can be entered into a DOS window under Windows NT/2000/XP.


Subnet mask

The subnet mask is subject to the control of the network administrator, and specifies the structure of the subnet.

Small networks without a router do not require a subnet mask. The same is true if you do not use registered IP numbers. A subnet mask can be used to subdivide the network with the aid of the mask instead of using a large number of network numbers.

The subnet mask is a 32-bit number.

  • Ones in the mask indicate the subnet part of an address region.
  • Zeros indicate that part of the address region which is available for the host IDs.
Description | Binary representation | Decimal representation
IP address | 10101100.00010000.00010001.11001000 | 172.16.17.200
Subnet mask | 11111111.11111111.00010100.00000000 | 255.255.20.0
Network ID | 10101100.00010000.00010000.00000000 | 172.16.16.0
Host ID | 00000000.00000000.00000001.11001000 | 0.0.1.200

Standard subnet mask

Address class | Standard subnet mask (decimal) | Standard subnet mask (hex)
A | 255.0.0.0 | FF.00.00.00
B | 255.255.0.0 | FF.FF.00.00
C | 255.255.255.0 | FF.FF.FF.00

Note Neither subnet 0 nor the subnet consisting only of ones may be used.
Neither host number 0 nor the host number consisting only of ones may be used!

If the IP address is set using the KS2000 configuration software, it is necessary for the subnet mask also to be changed with the KS2000 configuration software.
If ARP addressing is used, the associated standard subnet mask, based on the IP address, is entered.
Under BootP or DHCP the subnet mask is entered by the server.


Fieldbus Box for Ethernet/IP - Setting of the IP address via the ARP table

BECKHOFF Fieldbus Box: Parameterization and Commissioning

Setting of the IP address via the ARP table

An easy method to change the addressing is using the DOS window. Only addresses in the same network class can be changed though! The new address will be stored and kept even when the module is powered down.

Procedure:

  • switch to any IP address. DHCP or BootP shall not be activated.
  • open the DOS box on your PC
  • generate an entry in your ARP table using "ping >IP address<
  • read the ARP table with "ARP -a"
  • delete the module from the table with "ARP-d >IP-Address OLD<
  • carry out a manual entry in the table "ARS -s >IP Address NEW< >MAC-ID<"
  • check with "ping -l 123 >IP-Address NEW<" if the new IP-Address is valid

Temporary flashing of the ERROR LED during the initializing phase shows, that the module is addressed via ARP. The switches have no information about the actual module address!

Note When changing the IP address, all dynamic ARP entries should be deleted. Only a ping with a length of 123 Byte for changing the address is accepted (>ping -l "IP-Address<).
Example
  1. C:>ping 172.16.17.255
  2. C:>ARP -a
    172.16.17.255 00-01-05-00-11-22
  3. C:>arp -d 172.16.17.255
  4. C:>arp -s 172.16.44.44 00-01-05-00-11-22
  5. C:>ping -l 123 172.16.44.44


Fieldbus Box for Ethernet/IP - Adresseinstellung mit KS2000

BECKHOFF Fieldbus Box: Parameterization and Commissioning

Setting of the address using KS2000 and switch

The setting of the IP address can be done via the KS2000 and the 2 rotary switches.

Only the last Byte will be changed! All the other settings will be read directly from table 100. These values can only be changed with the KS2000 configuration software.

Before power on, the rotary switch x10 has to have a value <> 0xF.

To change the IP address it is necessary to reset the write protection in the KS2000. After the setting a Reset of the box is necessary.

Table 100

Register | High-Byte | Low-Byte
0 | IP-Byte 2 | IP-Byte 1
1 | not used | IP-Byte 3

Default

IP-Byte | Default value (hex) | Default value (dec)
1 | 0xAC | 172dec
2 | 0x10 | 16dec
3 | 0x11 | 17dec
4 | (rotary switches) | (0 to 239dec)
Example

Switch |  | x16 | x1
multiplicator |  | 16 | 1
this example | Switch position | Chex = 12dec | 4hex
 | value | 12dec x 16dec = 192dec | 4dec
 | IP address | 172.16.17.196


Fieldbus Box for Ethernet/IP - Adresseinstellung über DHCP-Server

BECKHOFF Fieldbus Components: Parameterization and Commissioning

Address Configuration via DHCP Server

To set the address by means of a DHCP server, set the rotary switches to 0xF0. In this state, the DHCP service is switched on, and the module is automatically assigned an IP number by the DHCP server. For this purpose the DHCP server must know the module's MAC-ID. The IP address should be set statically. The TCP/IP Error LED flashes while the address is being allocated.


Fieldbus Box for Ethernet/IP - Address Configuration via BootP Server

BECKHOFF Fieldbus Components: Parameterization and Commissioning

Addressing with the BOOTP/DHCP Server 2.3

IP address save modes

Rotary Switch = 0xF5

The IP address assigned by the BootP server is only valid until the Coupler Box is switched off. The BootP server must assign a new IP address to the Coupler Box at the next cold start.
The address is, however, retained through a software reset of the Coupler Box.

The MAC Address starts with 00-01-05-xx-xx-xx.

After a successful addressing you can disable the BOOTP addressing.


Testing the IP Address

Use the Ping command to test the IP address.


Reading the MAC-ID

Proceed as follows to read the MAC-ID:

  • Change the IP address of your PC to 172.16.x.x and the Subnet mask to 255.255.0.0
    The default IP address of the Ethernet Fieldbus Boxes is 172.16.18.1 (rotary switch setting: 0, 1).
  • Start the DOS Window
  • Send a Ping to IP address 172.16.17.1
  • Read the MAC-ID with arp -a.


Fieldbus Box for Ethernet/IP - Mapping

BECKHOFF Fieldbus Components: Mapping

Mapping

Type: ETHERNET-MODULE Generic Ethernet Module
Comm Format: SINT, INT or DINT
Assembly Instance:
- Input: 101 Size: 4 x SINT (BYTE) + terminals (2 x INT + terminals or 1 x DINT + terminals)
- Output: 102 Size: 4 x SINT (BYTE) + terminals (2 x INT + terminals or 1 x DINT + terminals)
- Configuration: 100 Size 0

Mapping rules

Complex terminals* (see documentation terminals)
- Word Alignment
- complex mapping

Comm Format: SINT
Offset | Inputs | Outputs
0 | Status Byte 0 | Control Byte 0
1 | Status Byte 1 | Control Byte 1
2 | Status Byte 2 | Control Byte 2
3 | Status Byte 3 | Control Byte 3
4...x | complex terminals* | complex terminals*
x...y | digital terminals** | digital terminals**

* complex terminals, example IE15xx, IE3xxx, IE4xxx, IE25xx, IE2808, IE5xxx, IE6xxx
** digital terminals, example IE1xxx, IE20xx, IE23xx, IE24xx

Comm Format: INT
Offset | Inputs | Outputs
0 | Status Word 0 | Control Word 0
1 | Status Word 1 | Control Word 1
2...x | complex terminals* | complex terminals*
x...y | digital terminals** | digital terminals**

* complex terminals, example IE15xx, IE3xxx, IE4xxx, IE25xx, IE2808, IE5xxx, IE6xxx
** digital terminals, example IE1xxx, IE20xx, IE23xx, IE24xx

Comm Format: DINT
Offset | Inputs | Outputs
0 | Status DWord 0 | Control DWord 0
1...x | complex terminals* | complex terminals*
x...y | digital terminals** | digital terminals**

* complex terminals, example IE15xx, IE3xxx, IE4xxx, IE25xx, IE2808, IE5xxx, IE6xxx
** digital terminals, example IE1xxx, IE20xx, IE23xx, IE24xx

Mapping terminals

Example:
Comm Format DINT
Size: 7 x Input, 7 x Output
1 x IL2301-B905
1 x IE3312
1 x IE1001
1 x IE2001

Offset | Name | Inputs | Outputs
0 | Control/Status Word 0 | DeviceName:I.data[0] | DeviceName:O.data[0]
1 | IE3312 Channel 0 Control/Status, Data | DeviceName:I.data[1] (Bit 0..7= Status, 8 ..15 unused,16 ..31 = Data) | DeviceName:O.data[1] (Bit 0..7 = Control, 8..15 unused)
2 | IE3312 Channel 0 Control/Status, Data | DeviceName:I.data[2] (Bit 0..7= Status, 8 ..15 unused,16 ..31 = Data) | DeviceName:O.data[2] (Bit 0..7 = Control, 8..15 unused)
3 | IE3312 Channel 0 Control/Status, Data | DeviceName:I.data[3] (Bit 0..7= Status, 8 ..15 unused,16 ..31 = Data) | DeviceName:O.data[3] (Bit 0..7 = Control, 8..15 unused)
4 | IE3312 Channel 0 Control/Status, Data | DeviceName:I.data[4] (Bit 0..7= Status, 8 ..15 unused,16 ..31 = Data) | DeviceName:O.data[4] (Bit 0..7 = Control, 8..15 unused)
5 | digital channels | DeviceName:I.data[5] (Bit 0..3 = IL2301, 4..11 = IE1001, 12..31 unused) | DeviceName:O.data[5] (Bit 0..3 = IL2301, 4..11 = IE2001, 12..31 unused)

B905 Control and Status

Status Bits 0..31

0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16-23 | 24-31
K1 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | IP-Link Error Code | IP-Link Error argument

K1 - if K1 = TRUE, IP-Link error, Error Code bit 16-31 (see IP-Link Error LED)

Control Bits 0..31

0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16-23 | 24-31
K1 | R1 | - | - | - | - | - | - | - | - | - | - | - | - | - | - | - | -

K1 - 0->1 rising Trig IP-Link Reset
R1 - 1->0 falling Trig Reboot IL230x-B905


Fieldbus Box for Ethernet/IP - First Steps

BECKHOFF Fieldbus Components: Product Overview

First Steps

Addressing with the BOOTP/DHCP Server 2.3

Switch the rotary switch to 0xF5.

The MAC Address begin with 00-01-05-xx-xx-xx ( the MAC address of each IL230x-B905 is printed on the right side of the box).

After a successful addressing you can disable the BOOTP addressing.

Open RSLogix 5000 and Create a new PLC project

When creating a new project make sure to select the correct controller type and controller settings. In this example we are using a SoftLogix Virtual Chassis, with the IL2301-B905 (Beckhoff Ethernet/IP Coupler Box)

Add Ethernet IP Module

Now you need to add your main communications module. Make sure you know the IP address of the card that is setup as the EtherNet IP card, that address will have to be set in the module settings along with the slot the card is in.

Add Ethernet IP Box

When adding the IL2301-B905 box you must select the "ETHERNET-MODULE" as it is a generic Ethernet/IP device and we will configure it to work with our Coupler Box.

Process Image

The figure below illustrates the hardware of the Beckhoff node in this example.

The process image table (I/O map) is displayed in double word format below the figure.

In order to properly configure the Ethernet Bridge, the process image of the Beckhoff IL2301-B905 node must be determined. When the Coupler Box is powered up, it automatically addresses the I/O modules of the node. The data for complex modules (modules using 2 or more bytes) are mapped first in the process image in the order of their physical position after the coupler. As such, they start at Double word 3. Following this, the digital modules are grouped into the next available Integer. The bits are arranged in the order of the modules location. When the number of digital points exceeds 32 (1-double integer), the coupler automatically starts the next Double Integer. THe Coupler Box itself has 4 digital input and 4 digital output bits. These shall not be forgotten, when looking for the signals in the data image!

Note: The modules can be mapped as Byte, Word, or Double Word. The example below maps them as Double Word, using 1 analog input module (IE3312), 1 digital input module (IE1001) and 1 digital output module (IE2001).

Input Process Image

• Double Word 0 - IL2301-B905 Status

• Double Word 1 – Channel 1 IE3312 (High Word) and Status (Low Word)

• Double Word 2 – Channel 2 IE3312 (High Word) and Status (Low Word)

• Double Word 3 – Channel 3 IE3312 (High Word) and Status (Low Word)

• Double Word 4 – Channel 4 IE3312 (High Word) and Status (Low Word)

• Double Word 5 – digital inputs IL2301-B905, IE1001

Output Process Image

• Double Word 0 - IL2301-B905 Status

• Double Word 1 – Channel 1 IE3312 (High Word) and Control (Low Word)

• Double Word 2 – Channel 2 IE3312 (High Word) and Control (Low Word)

• Double Word 3 – Channel 3 IE3312 (High Word) and Control (Low Word)

• Double Word 4 – Channel 4 IE3312 (High Word) and Control (Low Word)

• Double Word 5 – digital ouputs IL2301-B905, IE2001

Configuring the IL2301-B905 in RSLogix

For the example here we used one IE3312, one IE1001 and one IE2001 extension boxes. With these cards that gave us 2 words total of input and output data. On the properties dialog you will need to change some of the box settings, please read below for recommendations on settings.
  • IP Address (Refer to IP Address section of documentation)
  • The Assembly Instances will be as follows
    • Input: 101
    • Output: 102
    • Configuration: 100
  • Things to keep in mind when entering the data size for I/O
    • There will always be 4 bytes of input and 4 bytes of output data that is used for the Coupler itself
    • Digital IO: each channel will consume 1 bit of process data.
    • Complex IO: please refer to terminal documentation for consumed data size.

Working with IO data

Download the code to the controller unit, once you go online you will be able to toggle IO. Keep in mind that the first DINT is the Status for both the input and output data. At this point if you have the controller in RUN mode you will be able to toggle inputs and see the value in "IL2301B905_44:I.Data[5]" change and you should be able to update the values in "IL2301B905_44:O.Data[1]" and see the outputs change. Data[1] to [4] are the Status und Data form the 4 channel analog input module IE3312.

"IL2301B905_44:I.Data[5].5" is the second digital channel on the IE1001 (do not forget the 4 Bits for the IL2301-B905)


Fieldbus Box Diagnostic LEDs - Overview

BECKHOFF Fieldbus Box: Error handling and diagnosis

Diagnostic LEDs - Overview

Error diagnosis

There are 2 sorts of errors:

  • Fieldbus Errors
  • Local Errors on Compact Box or Coupler Box

Blink Codes

Blink sequence | Meaning
Fast flashing | Beginning of the Blink Code
first slow sequence | Error code
second slow sequence | Error argument
third slow sequence (optional) | Error argument

Flasching_codes.jpg (2840 Byte)

Beginning Error code Error argument


Fieldbus Box for Ethernet/IP - Diagnostic LEDs for Ethernet

BECKHOFF Fieldbus Box: Error Handling and Diagnosis

Diagnostic LEDs for Ethernet/IP

After switching on, the Fieldbus Box immediately checks the connected configuration. Error-free start-up is indicated when the red I/O ERR LED goes out. If the I/O ERR LED blinks, an error in the area of the Inputs/Outputs is indicated. The error code can be determined from the frequency and number of blinks. This permits rapid rectification of the error.

The module has two groups of LEDs for the display of status.
The upper group with four LEDs indicates the status of the respective fieldbus. The significance of the fieldbus status LEDs is explained in the appropriate sections of this manual. It corresponds to the usual fieldbus display.

At the lower end of the module are two more green LEDs that indicate the supply voltage. The left hand LED indicates the presence of the 24 VDC supply for the Fieldbus Box. The right hand LED indicates the presence of the supply to the power contacts.

LEDs for Ethernet diagnosis

LED | On | Out
LINK | Physical connection present | No physical connection present
ACT | Flashing: Bus traffic present | No bus traffic (bus idle)

LEDs for Ethernet/IP diagnosis

Ethernet/IP diagnostis | EIP R (green) | EIP E (red)
IP address OK | 0.5s | off
No IP Address (Switch 8,9 -> on) | off | off
Online | on | off
Offline PLC Stop | 0.1s | off
TimeOut | off | 0.5s
IP Address conflict | off | on

LEDs for power supply diagnosis

LED | Meaning
Left LED off | Module has no power
Left LED red | Short circuit detection for sensor supply (< 500mA) is active. Sensors/Inputs are not supplied anymore
Right LED off | No 24 VDC power for the outputs connected


Diagnostic LEDs for local errors

Local error in a Coupler Box (IL230x-Bxxx/Cxxx)

The term local error means that an error has occurred in the Fieldbus Box or the IP-Link. IP-Link errors most often turn out to be a result of inappropriate use of the optical fiber.

LED green | LED red |  |  | Description | Remedy
off | off |  |  | No data exchange | Module in synchronous mode or - activate PROFIBUS cyclic data
off | 1 | 0 |  | EEPROM checksum error | Set manufacturer’s setting with the KS2000 software
off | 2 |  |  | Reserved | -
off | 3 |  |  | Break location has been recognized | interruption before the master's receiver
 | 3 | n |  | Break location has been recognized | n-th module before the master's receiver
 | 3 | n | m | Break location has been recognized | (n*10)+m-th module before the master's receiver
off | 4 | n |  | Too many faulty telegrams have been detected (more than 25%) | The optical fiber wiring in front of the nth extension module should be checked
off | 5 | n |  | Register access to complex modules has failed | Check the nth module
off | 11 | n |  | Complex module working incorrectly | Exchange the nth module
off | 12 | n |  | More than 120 modules in the ring | Connect fewer modules
off | 13 | n |  | nth module unknown | Firmware update required
on | off |  |  | Module is exchanging data | no error

Local errors in an Extension Box

LED green | LED red | Description
off | on | No data is being received over the IP-Link
off | blinks, flickers | Faulty IP-Link protocols are being received (very poor data connection)
blinks, flickers | blinks, flickers | Faulty IP-Link protocols are being received (poor data connection), does not necessarily lead to an error
on | off | IP-Link protocols are being received, no error

Faulty protocols can occur, because of:

  • bad configured IP-Link connectors
  • IP-Link cable with higher dampening, e.g. because of a sharp curve
  • contaminated sender LED (module before the faulty one)
  • contaminated receiver

The internal IP-Link error counter of the Coupler Box can be read with the KS2000 software.


Fieldbus Box - Check of the IP-Link connection

BECKHOFF Fieldbus Box: Mounting and wring

Check of the IP-Link connection

A correct assembled IP-Link cable will assure an error free transmission.

An additional testing of the transmission quality and error diagnostics is possible with the KS2000 configuration software.

For this test, the fieldbus master (e.g. a PROFIBUS PC Card) should be on the bus and it should transmit data cyclical. Another way to generate cyclic data is, to switch the coupler to free running via the KS2000 software.

The result should be, that the I/O RUN LED flashes in a bright green. This shows, that a data exchange with the connected extension boxes takes place. A red blinking I/O ERR LED shows faulty IP-Link telegrams. These faulty telegrams will be repeated automatically like in any other fieldbus system. This way a transmission of the data is guaranteed.

Error counter

Table 90, offset 005 shows possible IP-Link errors. Sporadic appearing errors do not mean any problem for the communication, as long as they do not reach a critical limit.

This error counter is only reset by the Power ON/OFF.

If lots of errors occur in a very short time, this will be interpreted as a heavy disturbance of the communication and the coupler box will report this error. This can be seen at offset 006 and 007. Both values will show a value > 200 and the I/O ERR LEDs of the coupler box will blink the according error code.

Note The KS2000 Configuration Software communicates with the Coupler Box via the serial channel. The content of the registers will not be refreshed automatically.

Position of the error

In case of an IP-Link error, the Coupler Box tries to read the error location from the register of the Extension Box. If the fiber optic ring is interrupted or the communication is heavily disturbed, this is not possible. Only the position of the last functioning Extension Box before the receiver of the Coupler Box can be recognized. The box will then flash this error code via the I/O ERR LED.

If the communication via IP-Link is still running, table 87 shows the error counter of each Extension Box.

The offset register corresponds to the position of the Extension Box in the KS2000 tree (left side of graphic). This example shows errors at offset 004 and 006.

In the "real" world the faulty IP-Link telegram was reported from the IE20xx and the IE3112, that means the problem has to looked for before these modules.

The error can be up to:

  • the sending module
  • the receiving module
  • the IP-Link cable
  • the connectors

If there is an error in table 90 and none in table 87, the faulty transmission is between the last Extension Box and the Coupler Box.

In most cases the transmission errors can be traced back to bad configured IP-Link connectors or a too high attenuation of the cable due to sharp bending.

The values of table 87 directly come from the extension boxes. In case of an IP-Link interruption these values will be set to zero and only table 90 can be used.

Note If you want to operate a Coupler Box (e.g. IL2300-Bxxx, IL2301-Bxxx or IL2302-Bxxx ) totally without Extension Box Modules (IExxxx), you have to connect the send and receive socket of this Coupler Box directly by using an IP Link Cable! For this the IP Link Jumper ZK1020-0101-1000 fits perfect.


Fieldbus Box accessories

The necessary accessories for the Fieldbus Box Modules are also available from Beckhoff in protection class IP67. You may get an overview from the Beckhoff catalog or from our internet pages (http://www.beckhoff.com).

Fieldbus Accessories

  • Pre-assembled cable
  • Plug
  • Distributor

Power supply

  • Pre-assembled cable
  • Plug
  • Distributor

Sensor power supply

  • Pre-assembled cable
  • Plug
  • Distributor

IP-Link

  • Pre-assembled cable
  • Plug


General operating conditions

Protection degrees (IP-Code)

The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.

1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø12,5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø2,5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.

*) These protection classes define only protection against water!

Chemical Resistance

The Resistance relates to the Housing of the Fieldbus Box and the used metal parts.

Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key

resistant: Lifetime several months
non inherently resistant: Lifetime several weeks
not resistant: Lifetime several hours resp. early decomposition


Approvals

UL in preparation

Conformity mark

CE

Type of protection

IP65/66/67 in accordance with EN60529


Test standards for device testing

EMC

Resistance: EN 61000-6-2

Emission: EN 61000-6-4

Resistance to Vibration

EN 60068-2-2 Vibration test, Amplitude 2 g (Standard 1 g)

EN 60068-2-27 Shock Test, Shock count 1000 (Standard 2)


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


Fieldbus Box for Ethernet/IP - Adresseinstellung über BootP-Server

BECKHOFF Fieldbus Components: Addressing

Setting the IP-address via the BootP-server

Turn the rotary switch to 0xF1 resp. 0xF2 for using the Beckhoff BootP-server. The LED TCP/IP ERROR will flash during the address allocation.

Rotary switch in position 0xF2

The address assigned by the BootP server is stored, and the BootP service will not be restarted after the next cold start.

The address can be deleted by switching to manufacturer setting with the KS2000 or via the rotary switch (0xFF).

Rotary switch in position 0xF1

The IP address assigned by the BootP server is only valid until the module is switched off. At the next cold start, the BootP server must assign a new IP address to the module.
The address is, however, retained through a software reset of the module.

Beckhoff BootP server

Beckhoff supplies a BootP server for Windows 98, ME, NT4.0, NT2000 and XP. You find the installation version on the Beckhoff TwinCAT CD in folder Unsupported Utilities or from http://download.beckhoff.com/download/Software/TwinCAT/TwinCAT2/Unsupported Utilities/TcBootP Server.

BootP.jpg (39093 Byte)

As soon as the BootP server has started, the New MAC Address window shows all the Beckhoff nodes that are working in BootP mode and still have not received an IP address. The assignment of the MAC-ID to IP address is made with the "<<" button. Successful assignment is displayed in the log window.
To start the BootP server automatically when your PC boots, it is only necessary to provide a shortcut in the Windows autostart folder. Include the /Start parameter in the shortcut (.../TcBootPDlg.exe/start).