FBB-B903 - Feldbus Box für PROFINET

BECKHOFF Feldbuskomponenten

Dokumentation zur

FBB-B903

Feldbus Box für PROFINET

Version: 1.1.1
Datum: 30.10.2009


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


IL230x-B903 - Ausgabestände der Dokumentation

BECKHOFF IL230x-B903: Vorwort

Ausgabestände der Dokumentation

Version | Änderungen
1.1.1 | Systemübersicht aktualisiert
1.1 | Grafiken korrigiert
1.0 | Erste Version


Buskoppler als allgemeine Bezeichnung

Teile des vorliegenden Handbuches geben allgemeine Informationen über die Ethernet-Implementierung in Beckhoff Produkten.
Im folgenden wird daher oft der Begriff Buskoppler genutzt, der hier nicht nur die IP20-Produkte beschreibt, sondern auch die IP67-Module meint.


Das Feldbus Box System

Feldbus Box Module sind robuste Feldbusstationen für viele verschiedene Feldbus-Systeme. Sie verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Neben digitalen und analogen Ein- und Ausgängen samt Thermoelement- und RTD-Eingängen gibt es Inkrementalencoder-Interfaces für die Weg- und Winkelmessung sowie serielle Schnittstellen für die Lösung vielfältiger Kommunikationsaufgaben.

Signalanschluss in 3 Varianten

Die digitalen Ein-/Ausgänge können wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12-Variante vorgesehen.

Alle wichtigen Signalformen

Spezielle Ein-/Ausgangskanäle auf den Kombi-E/A-Module lassen sich wahlweise als Ein- oder Ausgang nutzen. Eine Konfiguration ist nicht erforderlich, da die Feldbusschnittstelle für jeden Kombikanal sowohl Eingangs- als auch Ausgangsdaten zur Verfügung stellt. Durch die Kombi-Module hat der Anwender alle Vorteile einer feinen Signal-Granularität.

Die Prozessor-Logik, die Eingangsbeschaltung sowie die Sensorversorgung werden aus der Steuerspannung gespeist. Die Lastspannung für die Ausgänge kann separat zugeführt werden. Bei Feldbus Boxen, in denen nur Eingänge zur Verfügung stehen, kann die Lastversorgung UP zur Weiterleitung optional angeschlossen werden.

Die Zustände der Feldbus Box, der Feldbusverbindung, der Spannungsversorgung sowie der Signale werden von LEDs angezeigt.

Die Beschriftungsstreifen lassen sich extern maschinell beschriften und können dann eingeschoben werden.

Kombinierbare Feldbus Boxen für mehr Flexibilität

Die Feldbus Box Serie umfasst neben der Kompakt Box auch erweiterbare Geräte, die Koppler Box und die Erweiterungsbox sowie intelligente Geräte, die SPS Boxen.

Kompakt Box

Die Kompakt Box stellt dem Feldbus die E/A-Daten der angeschlossenen digitalen und analogen Sensoren und Aktuatoren zur Verfügung.

Koppler Box

Die Koppler Box sammelt zusätzlich über eine störsichere LWL-Verbindung (IP-Link) E/A-Daten von den Erweiterungsboxen ein. Sie können bis zu 120 Erweiterungsboxen an eine Koppler Box anschließen. Es ergibt sich so ein verteiltes IP67 E/A-Netzwerk mit nur einer Feldbusschnittstelle.

Die Koppler Box erkennt die angeschlossenen Erweiterungsmodule selbsttätig in der Aufstart-Phase und mappt die E/A-Daten automatisch in das Feldbus-Prozessabbild – eine Konfiguration ist nicht erforderlich. Aus Sicht des Feldbusses stellt sich die Koppler Box samt allen vernetzten Erweiterungsboxen als ein einziger Busteilnehmer mit entsprechend vielen E/A-Signalen dar.

Die Koppler Box entspricht dem Buskoppler aus dem BECKHOFF Busklemmen-System. BECKHOFF Feldbus-Geräte der Schutzart IP 20 (Busklemmen) und IP 67 (Feldbus Box) können problemlos kombiniert werden - das Daten-Handling ist jeweils gleich.

IP-Link

IP-Link ist eine LWL-Verbindung mit 2 Megabit/s Übertragungsrate, die 1000 binäre E/A-Daten in ca. 1 ms schnell und sicher überträgt – kleinere Konfigurationen entsprechend schneller. Durch die hohe Nutzdatenrate ist gewährleistet, dass die Kopplung über IP-Link keine spürbare Einschränkung der Feldbus-Performance mit sich bringt.

Für die schnelle und einfache Konfektionierung der IP-Link-Kabel vor Ort wurden preisgünstige Steckverbinder in IP 67 Schutzart entwickelt. Der Anschluss erfordert kein Spezialwerkzeug und lässt sich schnell und einfach durchführen. Die IP-Link-Kabel sind alternativ auch mit vorkonfektionierten Steckern erhältlich.

Durch die getrennte Zuführung der Ausgangs-Spannungsversorgung lassen sich Ausgangsgruppen einzeln abschalten. Außerdem können problemlos unterschiedliche Potenziale innerhalb eines Erweiterungsringes aufgebaut werden, da IP-Link naturgemäß über eine optimale Potenzialtrennung verfügt.

Erweiterungsbox

Die Erweiterungsboxen decken wie die Kompakt Boxen das gesamte Spektrum der E/A-Signale ab und dürfen bis zu 15 m Abstand voneinander haben. Sie bauen hierbei besonders klein und führen zu besonders preiswerten E/A-Lösungen in hoher Schutzart. Auch hier sind die digitalen Ein-/Ausgänge wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder anschließbar. Analoge Signaltypen werden mit der M12-Variante ausgerüstet. Die Schnapp-Steckverbinder verriegeln formschlüssig und ergeben eine rüttelfeste Verbindung, während sich die Schraub-Steckverbinder durch eine hohe Zugfestigkeit auszeichnen.

SPS Box

Die SPS Box ist eine intelligentes Feldbus Box mit SPS-Funktionalität für dezentrale Vorverarbeitung der E/A-Signale. Hiermit lassen sich Applikationsteile aus der zentralen Steuerung auslagern. Deren CPU und der Feldbus werden entlastet. Dezentral Zählen, Regeln oder Schalten sind typische Anwendungen für die SPS-Box. Die Reaktionszeiten sind unabhängig von der Buskommunikation und der übergeordneten Steuerung.

Bei Bus- oder Steuerungsausfall ist ein Funktionserhalt (z.B. geordnete Überführung des Prozesses in einen sicheren Zustand) möglich.

Die Programmierung erfolgt mit TwinCAT nach IEC 61131-3. Fünf verschiedene Programmiersprachen stehen zur Verfügung:

  • Anweisungsliste (AWL)

  • Funktionsplan (FUP)

  • Kontaktplan (KOP)

  • Ablaufsprache (AS)

  • Strukturierter Text (ST).

Der Programm-Download erfolgt wahlweise über den Feldbus oder über die Programmierschnittstelle.

Es stehen umfangreiche Debug-Funktionalitäten (Breakpoint, Einzelschritt, Monitoring, etc.) zur Verfügung. SPS Box verfügt über einen leistungsfähigen 16 Bit Controller, 32/96 KByte Programmspeicher und 32/64 KByte Datenspeicher. Weiter stehen 512 Byte als nichtflüchtiger Speicher für remanente Merker zur Verfügung.

SPS Box mit IP-Link

Nahezu unbeschränkte E/A-Möglichkeiten ergeben sich durch die programmierbare SPS Box mit IP-Link. Aus dem SPS-Programm heraus lassen sich bis zu 120 Erweiterungsmodule mit über 2000 E/As direkt ansprechen. Die SPS Box eignet sich damit auch als autarke Kleinsteuerung zur Steuerung von Anlagenteilen oder kleiner Maschinen.


Feldbus Box - Bezeichnungsübersicht

Die Bezeichnung der Feldbus Box Module ist wie folgt zu verstehen:
IXxxxy-zyyy

IX beschreibt die Bauform:

"IP" steht für die Bauform Kompakt Box.
"IL" steht für die Bauform Koppler Box (mit IP-Link).
"IE" steht für die Bauform Erweiterungsbox.

xxxy beschreibt die E/A-Beschaltung:

xxx bezeichnet die E/A-Eigenschaft:
"10x" - 8 x digitale Eingänge
"15x" - Zählermodul
"20x" - 8 x digitale Ausgänge
"23x" - 4 x digitale Eingänge und 4 x digitale Ausgänge
"24x" - 8 x digitale Eingänge und 8 x digitale Ausgänge
"25x" - PWM-Modul
"3xx" - 4 x analoge Eingänge
"4xx" - 4 x analoge Ausgänge
"5xx" - Inkremental-Encoder oder SSI-Geber
"6xx" - Gateway-Module RS232, RS422, RS485, TTY

y beschreibt den mechanischer Anschluss:
"0" steht für 8mm Schnappanschluss
"1" steht für M 8 Schraubanschluss
"2" steht für M 12 Schraubanschluss und
"9" steht für M23 Schraubanschluss

zyyy bezeichnet die Programmierbarkeit und das Feldbus-System:

z unterscheidet ob es sich um einen Slave oder einen programmierbare Slave handelt:
"B" - nicht programmierbar
"C" - programmierbar (SPS Box)

yyy steht für das Feldbus-System und den Bus-Anschluss:
"110" - EtherCAT
"200" - Lightbus
"310" - PROFIBUS
"318" - PROFIBUS mit integriertem T-Stück
"400" - Interbus
"510" - CANopen
"518" - CANopen mit integriertem T-Stück
"520" - DeviceNet
"528" - DeviceNet mit integriertem T-Stück
"730" - Modbus
"800" - RS485
"810" - RS232
"900" - Ethernet TCP/IP mit RJ45 für den Bus-Anschluss
"901" - Ethernet TCP/IP mit M12 für den Bus-Anschluss
"903" - PROFINET
"905" - EtherNet/IP

Kompakt Box

Die Feldbus Boxe verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Die digitalen Ein-/Ausgänge können wahlweise über Ø 8 mm Schnapp-, M8 Schraub- oder über M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12 Variante verfügbar.

Je nach Modul kann der E/A-Teil und der Stromversorgungsteil unterschiedlich sein.

Koppler Box

Die Koppler Box gibt es in drei Varianten als IL230x-Bxxx. Diese unterscheidet sich von der Kompakt Box dadurch, dass diese Module eine Schnittstelle zu den sogenannten Erweiterungsboxen bietet. Diese Schnittstelle ist ein Sub-Bussystem auf LWL Basis den sogenannten IP-Link. Dieses leistungsfähige Sub-Bussytem kann bis zu 120 Erweiterungsboxen an einer Koppler Box verarbeiten.

Erweiterungsbox

Feldbusunabhängige Erweiterungsmodule, die nur an einer Koppler Box über IP-Link betrieben werden können.

SPS Box

Eine SPS Box unterscheidet sich von einer Koppler Box dadurch, dass sie in IEC 61131-3 programmierbar ist. Dadurch kann dieser Slave auch ohne Master autonom arbeiten, zum Beispiel für Steuerungs- oder Regelungsaufgaben.


Firm- und Hardware-Stand

Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Hard- und Firmware-Stand. Die Eigenschaften werden weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben wie Module neue Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das diese Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand der Module können Sie anhand der mit einem D beginnenden Nummer auf der Seite des Moduls erkennen.

Syntax:

D . ww yy x y z u

ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel:

D.22081501

- Kalenderwoche 22
- des Jahres 2008
- Firmware-Stand Busplatine: 1
- Hardware Stand Busplatine: 5
- Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig)
- Hardware-Stand E/A-Platine: 1


IL230x-B903 - Technische Daten

BECKHOFF IL230x-B903: Produktübersicht

Technische Daten

Technische Daten | IL230x-B903
Erweiterungsmodule | max. 120
Digitale Peripheriesignale | max. 960 Ein- und Ausgänge
Analoge Peripheriesignale | max. 480 Ein- und Ausgänge
Übertragungsmedium | 4 x 2 Twisted-Pair Kupferkabel; Kategorie 5 (100 MBaud)
Übertragungsrate | 100 MBaud
Topologie | sternförmige Verkabelung
Entfernung zwischen Modulen | 100 m (Hub/Switch bis Feldbus Box)
Konfiguration | über KS2000 oder über die Steuerung
Protokolle | Profinet RT (TCP-ADS für den Zugriff über Ethernet mit KS2000 Konfigurationssoftware)
Stromversorgung | Steuerspannung: 24VDC (-15%/+20%); Lastspannung: entsprechend E/A-Variante
Stromaufnahme Steuerspannung | entsprechend E/A-Variante + Stromaufnahme Sensorversorgung, max. 0,5A
Stromaufnahme Lastspannung | entsprechend E/A-Variante
Anschluss Stromversorgung | Einspeisung: 1 x M8 Stecker 4-polig Weiterleitung: 1 x M8 Buchse 4-polig
Anschluss Feldbus | 1 x M12, d-kodierte Buchse
Potentialtrennung | Kanäle / Steuerspannung: nein zwischen den Kanälen: nein Steuerspannung / Feldbus: ja
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... +55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 65/66/67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE, UL E172151
Hinweis Detaliierte technische Daten zu allen erhältlichen E/A-Varianten entnehmen Sie bitte der Dokumentation Signalvarianten, Installation, Konfiguration der E/A-Module, die Sie auf der Beckhoff CD Products & Solutions oder im Internet (http://www.beckhoff.de) unter Download/Feldbus Box finden.


Feldbusbox - Abmessungen

BECKHOFF Feldbus Box: Montage

Abmessungen

Alle Maßangaben sind in Millimeter angegeben.

Allgemein

Technische Daten | Feldbus Box
Gehäusematerial | PA6 (Polyamid), Vergussmasse: Polyuhrethan
Montage | 2 x Befestigungslöcher für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | IEC EN 50082-2 / EN 50081-2
Zulässige Umgebungstemperatur im Betrieb | 0 ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25 ... + 85°C
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65/66/67
Zulassungen | CE, UL E172151

IPxxxx-Bxx8, IL230x-Bxx8, IL230x-B110, IXxxxx-B400, IXxxxx-B90x, IXxxxx-C900

Technische Daten | Kompakt- und Kopplerbox mit integriertem T-Stück
Abmessungen (H x B x T) | ca. 210 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm)
Gewicht | ca. 260 g - 290 g, je nach Modultyp

IPxxxx-Bxx0, IL230x-Bxx0, IL230x-Cxx0

Technische Daten | Kompakt- und Kopplerbox
Abmessungen (H x B x T) | ca. 175 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm, mit T-Stück ZS1031-2600 Höhe ca. 65 mm)
Gewicht | ca. 250 g - 280 g, je nach Modultyp

IExxxx

Technische Daten | Erweiterungsbox
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Gewicht | ca. 120 g - 200 g, je nach Modultyp


FBB-B901, FBB-B903, FBB-B905 - Ethernet-Anschluss

BECKHOFF Feldbuskomponenten: Einbau und Verdrahtung

Ethernet-Anschluss

Der Anschluss an den Ethernet-Bus erfolgt über einen d-codierten M12 Steckverbinder. Das Modul besitzt eine Kupplung.

Als Leitung sollte ein CAT5 oder CAT5e Kabel eingesetzt werden.

Verkabelung

Verbindung über Hub oder Switch

VekabellungPC_HUB_B900.gif (16161 Byte)

Verbinden Sie die Netzwerkkarte des PCs über ein Ethernetkabel mit dem Hub, und den Hub ebenfalls über ein Ethernetkabel mit der Feldbus Box.

Die Verbindung über einen Switch erfolgt auf die gleiche Weise.

Direkte Verbindung zwischen PC mit Ethernet-Karte und B901/B903/905

VekabellungPC_B900.gif (15629 Byte)

Um den PC direkt mit Feldbus Box zu verbinden, muss ein Ethernetkabel mit gekreuzten Adernpaaren (Cross-Over-Kabel) verwendet werden.

Belegung des M12-Steckers

PIN | Signal | Beschreibung
1 | TD + | Transmit Data+
2 | RD+ | Receive Data-
3 | TD- | Transmit Data+
4 | RD- | Receive Data-
Gehäuse | Schirm | Schirmung der Leitung

Hinweis: Es gibt keine genormte Farbbelegung der Kabel!


Feldbus Box - Ethernet-Steckverbinder: M12

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Ethernet-Steckverbinder: M12

Der Ethernet-Anschluss erfolgt über eine d-codierte M12-Buchse (IP67).


Ethernet

Ethernet wurde ursprünglich von DEC, Intel und Xerox (als DIX-Standard) für die Datenübertragung zwischen Bürogeräten entwickelt. Heute versteht man darunter meist die Spezifikation IEEE 802.3 CSMA/CD, die 1985 veröffentlicht wurde. Diese Technologie ist durch ihren weltweiten Einsatz und die hohen Stückzahlen überall erhältlich und sehr preiswert.. Eine Anbindung an vorhandene Netze kann so problemlos realisiert werden.

Mittlerweile gibt es die verschiedensten Übertragungsmedien: Koaxialkabel (10Base5), Lichtwellenleiter (10BaseF) oder verdrillte Zweidrahtleitung (10BaseT) mit Schirmung (STP) oder ohne Schirmung (UTP). Mit Ethernet lassen sich verschieden Topologien aufbauen wie Ring, Linie oder Stern.

Ethernet transportiert Ethernet-Pakete von einem Sender zu einem oder mehreren Empfängern. Diese Übertragung verläuft ohne Quittung und ohne Wiederholung von verlorenen Paketen. Für die sichere Daten-Kommunikation stehen Protokolle wie TCP/IP zu Verfügung, die auf Ethernet aufsetzen.

MAC-ID

Sender und Empfänger von Ethernet-Paketen werden über die MAC-ID adressiert. Die MAC-ID ist ein 6 Byte großer Identifikations-Code, der eineindeutig, d.h. für jedes Ethernet-Gerät weltweit unterschiedlich ist. Die MAC-ID besteht aus zwei Teilen. Der erste Teil (d.h. die ersten 3 Byte) ist eine Herstellerkennung. Die Firma Beckhoff hat die Kennung 00 01 05. Die nächsten 3 Byte werden durch den Hersteller vergeben und entsprechen einer eindeutigen Seriennummer. Die MAC-ID kann zum Beispiel beim BootP-Protokoll zum Einstellen der TCP/IP-Nummer verwendet werden. Dafür wird ein Telegramm zum entsprechenden Knoten geschickt, das die Informationen wie Name oder TCP/IP-Nummer beinhaltet. Sie können die MAC-ID mit der Konfigurationssoftware KS2000 auslesen.

Internet-Protokoll (IP)

Die Grundlage der Datenkommunikation ist das Internet-Protokoll (IP). IP transportiert Datenpakete von einem Teilnehmer zu einem anderen, der sich im gleichen oder in einem anderen Netz befinden kann. IP kümmert sich dabei um das Adress-Management (Finden und Zuordnen der MAC-IDs), die Segmentierung und die Pfadsuche (Routing). Wie das Ethernet-Protokoll gewährleistet auch IP keinen gesicherten Transport der Daten; Datenpakete können verloren gehen oder in ihrer Reihenfolge vertauscht werden.

Für einen standardisierten, gesicherten Informationsaustausch zwischen beliebig vielen verschiedenen Netzwerken wurde TCP/IP entwickelt. Dabei ist TCP/IP weitgehend unabhängig von der verwendeten Hard- und Software. Oftmals als ein Begriff verwendet, handelt es sich hierbei um mehrere aufeinander aufgesetzte Protokolle: z.B. IP, TCP, UDP, ARP und ICMP.

Transmission Control Protocol (TCP)

Das auf IP aufsetzende Transmission Control Protocol (TCP) ist ein verbindungsorientiertes Transport-Protokoll. Es umfasst Fehlererkennungs- und Behandlungsmechanismen. Verlorengegangene Telegramme werden wiederholt.

User Datagram Protocol (UDP)

UDP ist ein verbindungsloses Transport-Protokoll. Es gibt keine Kontrollmechanismen beim Datenaustausch zwischen Sender und Empfänger. Dadurch resultiert eine schneller Verarbeitungsgeschwindigkeit als zum Beispiel bei TCP. Eine Prüfung ob das Telegramm angekommen ist muss vom übergeordneten Protokoll durchgeführt werden.

Auf TCP/IP und UDP/IP aufsetzende Protokolle

Auf TCP/IP bzw. UDP können folgende Protokolle aufsetzen:

  • ADS
  • ModbusTCP

Beide Protokolle sind parallel auf dem Buskoppler implementiert, so dass für die Aktivierung der Protokolle keine Konfiguration nötig ist.

ADS setzt wahlweise auf TCP oder UDP auf, während ModbusTCP stets auf TCP/IP basiert.


Topologie

Mit 10BaseT und 100BaseT werden mehrere Stationen im Ethernet-Standard sternförmig verbunden.

Stern-Topologie

Ein Stern-LAN besteht in der einfachsten Netzform aus einzelnen Punkt-zu-Punkt-Verbindungen. Alle Nachrichten laufen über einen zentralen Knoten (Hub oder Switch), der je nach Zieladresse die Informationen an den gewünschten Empfänger weitergibt.

Baum-Topologie

Eine Baum Topologie besteht aus mehreren verbundenen Stern-Topologien. Sobald mehrere Hubs oder Switches im Netz vorhanden sind, ist eine Baumtopologie vorhanden. Ideal ist es, die Verbindungen zwischen den Sternkopplern besonders breitbandig auszuführen, da diese den meisten Datenverkehr transportieren. Beim Aufbau von Baum-Topologien ist die Repeater-Regel zu beachten, die auch als 5-4-3-Repeater-Regel bezeichnet wird. Maximal zwei Repeater-Paare (bzw. Hub-Paare) dürfen im Übertragungsweg zwischen zwei beliebigen Stationen sein, sofern sie nicht durch Bridges, Switches oder Router getrennt sind. Ein Übertragungsweg kann aus maximal fünf Segmenten und vier Repeater-Sets (zwei Repeater-Paaren) bestehen. Dabei können bis zu drei Segmente Koax-Segmente sein, an denen die Stationen angeschlossen sind, die restlichen Segmente müssen Punkt-zu-Punkt-Verbindungen sein, die auch als IRL-Verbindung (Inter Repeater Link) bezeichnet werden.

Verkabelungsrichtlinien

Allgemeine Richtlinien für den Netzwerkaufbau eines LAN gibt die Strukturierte Verkabelung vor. Darin sind maximal zulässige Kabellängen für die Gelände-, Gebäude- und Etagenverkabelung festgelegt. In den Standards EN 50173, ISO 11801 und TIA 568-A normiert, bildet die Strukturierte Verkabelung die Grundlage für eine zukunftsweisende, anwendungsunabhängige und wirtschaftliche Netzwerk-Infrastruktur. Die Verkabelungsstandards definieren einen Geltungsbereich mit einer geographischen Ausdehnung von bis zu 3 km und für eine Bürofläche von bis zu 1 Mio. Quadratmeter mit 50 bis 50.000 Endgeräten. Darüber beschreiben sie Empfehlungen für den Aufbau eines Verkabelungssystems. Abhängig von der gewählten Topologie, den unter Industriebedingungen eingesetzten Übertragungsmedien und Koppelmodulen sowie von dem Einsatz von Komponenten verschiedener Hersteller in einem Netz können sich abweichende Angaben ergeben. Die Angaben verstehen sich hier deshalb lediglich als Empfehlungen.


Ethernet-Kabel

Übertragungsstandards

10Base5

Das Übertragungsmedium für 10Base5 ist ein dickes Koaxialkabel (Yellow Cable) mit einer max. Übertragungsgeschwindigkeit von 10 MBaud und einer Linien-Topologie mit Abzweigen (Drops), an die jeweils ein Teilnehmer angeschlossen wird. Da hier alle Teilnehmer an einem gemeinsamen Übertragungsmedium angeschlossen sind, kommt es bei 10Base5 zwangsläufig häufig zu Kollisionen.

10Base2

10Base2 (Cheaper net) ist eine Weiterentwicklung von 10Base5 und hat den Vorteil dass dieses Koaxialkabel billiger und durch eine höhere Flexibilität einfacher zu verlegen ist. Es können mehrere Geräte an eine 10Base2-Leitung angeschlossen werden. Häufig werden die Abzweige eines 10Base5-Backbones als 10Base2 ausgeführt.

10BaseT

Beschreibt ein Twisted-Pair-Kabel für 10 MBaud. Hierbei wird das Netz sternförmig aufgebaut, so dass nun nicht mehr jeder Teilnehmer am gleichem Medium hängt. Dadurch führt ein Kabelbruch nicht mehr zum Ausfall des gesamten Netzes. Durch den Einsatz von Switches als Sternkoppler können Kollisionen vermindert oder bei Voll-Duplex Verbindungen auch vollständig vermieden werden.

100BaseT

Twisted-Pair-Kabel für 100 MBaud. Für die höhere Datengeschwindigkeit ist eine bessere Kabelqualität und die Verwendung entsprechender Hubs oder Switches erforderlich.

10BaseF

Der Standard 10BaseF beschreibt mehrere Lichtwellenleiter-Varianten.

Kurzbezeichnung der Kabeltypen für 10BaseT und 100BaseT

Twisted-Pair Kupferkabel für sternförmige Topologie, wobei der Abstand zwischen zwei Geräten 100 Meter nicht überschreiten darf.

UTP

Unshielded Twisted-Pair (nicht abgeschirmte, verdrillte Leitung)
Dieser Kabeltyp gehört zur Kategorie 3 und sind für industrielle Umgebungen nicht empfehlenswert.

S/UTP

Screened/Unshielded Twisted-Pair (mit Kupfergeflecht abgeschirmte, verdrillte Leitung)
Besitzen einen Gesamtschirm aus einem Kupfergeflecht zur Reduktion der äußeren Störeinflüsse. Dieses Kabel wird zum Einsatz mit dem Buskopplern empfohlen.

FTP

Foilesshielded Twisted-Pair (mit Alufolie abgeschirmte, verdrillte Leitung)
Dieses Kabel hat eine alukaschierten Kunststoff-Folie-Gesamtschirm.

S/FTP

Screened/Foilesshielded Twisted-Pair (mit Kupfergeflecht und Alufolie abgeschirmte, verdrillte Leitung)
Besitzt einen alukaschierten Gesamtschirm mit einem darüber liegenden Kupfergeflecht. Solche Kabel können eine Störleistungsunterdrückung bis zu 70dB erreichen.

STP

Shielded Twisted-Pair (abgeschirmte, verdrillte Leitung)
Beschreibt ein Kabel mit Gesamtschirm ohne weitere Angabe der Art der Schirmung.

S/STP

Screened/Shielded Twisted-Pair (einzeln abgeschirmte, verdrillte Leitung)
Ein solche Bezeichnung kennzeichnet ein Kabel mit einer Abschirmung für jedes Leitungspaar sowie einen Gesamtschirm.

ITP

Industrial Twisted-Pair
Ist von Aufbau dem S/STP ähnlich, besitzt allerdings im Gegensatz zum S/STP nur 2 Leitungspaare.


Hinweis zur Parametrierung

Hinweis

Einstellungen und Parameteränderungen z.B. der MAC-ID, die mittels der Konfigurations-Software KS2000 gemacht werden, werden zunächst nur im flüchtigen Speicher der Feldbus Box (RAM) hinterlegt.

Dann muss ein Software-Reset durchgeführt werden, der die die Daten in den Flash-Speicher kopiert, und damit dauerhaft speichert.

Ein Kalt-Start (Power-ON/OFF) reicht nicht aus, es muss ein Software-Reset sein!


Anlaufverhalten der Feldbus Box

Nach dem Einschalten prüft die Feldbus Box ihren Zustand, konfiguriert (wenn vorhanden) den IP-Link ist und erstellt anhand der Erweiterungsmodule eine Aufbauliste. Wenn die Feldbus Box eine dezentrale Steuerung besitzt (IL230x-C310) wird nach einer erfolgreichen Aufbauliste die lokale SPS gestartet.
Beim Hochlauf des Moduls leuchten und blinken die E/A LEDs. Im fehlerfreien Zustand sollte nach ca. 2-3 sec keine E/A LED mehr Blinken. Sollte ein Fehler vorliegen, hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose LEDs).

Start_List.gif (8211 Byte)


Ethernet - Netzwerkklassen

BECKHOFF Feldbuskomponenten: Ethernet

Netzwerkklassen

Man unterscheidet drei verschiedene Netzwerkklassen. Diese legen fest, wie viele Adress-Bits für die Netzwerk-ID und wie viele für die Knotennummer (z.B. für PCs oder Buskoppler) reserviert werden. Die Unterscheidung findet in den ersten drei Bits der IP-Adresse statt.

Netzwerk- klasse | Anzahl Bits für die Netzwerk-ID | Ermöglicht Anzahl Netzwerke | Anzahl Bits für die Knotenadresse | Ermöglicht Anzahl Knoten pro Netzwerk
A | 7 | 126 | 24 | 16 777 214
B | 14 | 16 382 | 16 | 65 536
C | 21 | 2 097 150 | 8 | 254

Achtung Eine IP-Adresse muss im gesamten verbundenen Netzwerk einmalig sein!

Hinweis Die eingestellte IP-Adresse muss bei einer Kommunikation mit einem anderen Ethernet-Teilnehmer die gleiche Netzwerkklasse besitzen. Beispiel: Ihr PC hat die Adresse 172.16.17.55, damit muss der Koppler die Adresse 172.16.xxx.xxx haben (die xxx stehen für eine Zahl von 0...255. Die 0 wird üblicherweise vom Router/Switch benutzt sollte dafür reserviert bleiben).

Um sich die Adresse des eigenen PCs anzusehen, kann man bei Windows NT/2000/XP im DOS-Fenster den Befehl ipconfig eingeben.


IL230x-B903 - Einstellungen der Adress-Schalter

BECKHOFF IL230x-B903: Parametrierung und Inbetriebnahme

Einstellungen der Adress-Schalter

Über den Adress-Schalter können Sie zwischen verschiedenen Adressierungsmöglichkeiten wählen und die Auswahl des PROFINET-Namens vergeben.

Hinweis PROFINET-konform verhält sich das Gerät, wenn die Schalter x10 und x1 auf 0xEx oder > 0xF1 stehen.

Alle anderen Modi sind als Option möglich.

PROFINET-Name über Schalter

Hier wird der Name "il230x-b903-xx" gebildet gebildet. xx entspricht der Schalterstellung. "il" wird muss klein geschrieben werden!

Hex Switch x16 | Hex Switch x1 | Beschreibung | Verhalten bei Neustart | Verhalten bei Herstellereinstellung
0x0 - D | 0x0 - F | IP-Adresse über Schalter | - PN-Name aus dem Speicher - IP-Adresse über Schalter | - PN-Name wird Leerstring - IP-Adresse über Schalter 172.16.18.xxx (xxx Schalter) SNM 255.255.0.0
0xF | 0x0 | IP-Adresse über DHCP | - PN-Name aus dem Speicher - IP-Adresse und SNM über DHCP | - PN-Name wird Leerstring - IP-Adresse und SNM über DHCP
0xF | 0x1 | IP-Adresse über BootP | - PN-Name aus dem Speicher - IP-Adresse und SNM über BootP | - PN-Name wird Leerstring - IP-Adresse = 0.0.0.0, - SNM = 0.0.0.0
0xE | 0x0 - F | PN-Name über Schalter x1 | - PN-Name über Schalter* (il230x-b903-xx, mit xx = 0...15) - IP-Adresse aus dem Speicher | - PN-Name über Schalter - IP-Adresse = 0.0.0.0, - SNM = 0.0.0.0
0xF | 0x2 - F | PROFINET-konform | PN-Name aus dem Speicher - IP-Adresse aus dem Speicher | - PN-Name wird Leerstring - IP-Adresse = 0.0.0.0, - SNM = 0.0.0.0

*) Der PROFINET-Name kann nicht von der Steuerung überschrieben werden.

Legende

PN - PROFINET
SNM - SubNetMask
DHCP - Dynamic Host Configuration Protocol
DNS - Domain Name Server


IL230x-B903 - Adresseinstellung mit Kodierschalter und KS2000

BECKHOFF IL230x-B903: Adressierung

Adresseinstellung mit Kodierschalter und KS2000

Die TCP/IP-Adresse kann unter anderem auch über die beiden hexadezimalen Adress-Kodier-Schalter eingestellt werden.

Dabei wird nur das letzte Byte geändert. Die anderen Werte werden direkt aus Tabelle 100 der Box gelesen. Sie können nur mit der Konfigurationssoftware KS2000 angepasst werden. Die Dreh-Codier-Schalter x10 muss vor dem Einschalten einen Wert ungleich 0xF aufweisen.

Zum Ändern der IP-Adresse ist ein Aufheben ("Reset Schreibschutz") des Schreibschutzes in der KS2000 erforderlich. Nach dem Ändern der Adresse ist ein Reset des Kopplers erforderlich ("Reset").

Tabelle 100

Register | High-Byte | Low-Byte
0 | IP-Byte 2 | IP-Byte 1
1 | Nicht benutzt | IP-Byte 3

Default

IP-Byte | Default-Wert (hex) | Default-Wert (dez)
1 | 0xAC | 172dez
2 | 0x10 | 16dez
3 | 0x12 | 18dez
4 | (Dreh-Codier-Schalter) | (0 bis 223dez)
Beispiel

Schalter |  | x16 | x1
Wertigkeit |  | 16 | 1
Im Beispiel | Schalterstellung | 0 | 4
 | Wert | 0 | 4dez
 | IP-Adresse | 172.16.18.4


IL230x-B903 - Adresseinstellung über den Beckhoff BootP-Server

BECKHOFF IL230x-B903: Adressierung

Einstellung der IP-Adresse über den Beckhoff BootP-Server

Stellen Sie für die Adresseinstellung mit dem Beckhoff BootP-Server den Dreh-Kodier-Schalter auf 0xF1. Während der Adressvergabe blinkt die LED TCP/IP ERROR.

Speicherverhalten der IP-Adresse

Dreh-Kodier-Schalter in Stellung 0xF1

Die vom BootP-Server vergebene IP-Adresse ist nur bis zum Ausschalten des Moduls gültig. Beim nächsten Kaltstart muss der BootP-Server dem Modul eine neue IP-Adresse zuteilen.
Bei einem Software-Reset des Moduls bleibt die Adresse allerdings erhalten.

Beckhoff BootP-Server

Beckhoff bietet einen BootP-Server für Windows 98, ME, NT4.0, NT2000 und XP an. Sie finden die Installationsversion auf der Beckhoff TwinCAT CD im Ordner Unsupported Utilities oder unter http://download.beckhoff.com/download/Software/TwinCAT/TwinCAT2/Unsupported Utilities/TcBootP Server.

BootP.jpg (39093 Byte)

Sobald der BootP-Server gestartet wird zeigt das Fenster New MAC Address alle Beckhoff-Knoten an, die im BootP-Betrieb arbeiten und noch keine IP-Adresse bekommen haben. Die Zuweisung MAC-ID zu IP-Adresse erfolgt mit dem Button "<<". Eine erfolgreiche Zuweisung wird im Log-Fenster angezeigt.
Um den BootP-Server beim Booten Ihres PCs automatisch zu starten reicht eine Verknüpfung im Autostart von Windows. Fügen Sie hierzu im Verknüpfungspfad den Parameter /Start an (.../TcBootPDlg.exe/start).


Adresseinstellung über DHCP-Server

BECKHOFF Feldbuskomponenten: Adressierung

Adresseinstellung über einen DHCP-Server

Stellen Sie für die Adresseinstellung über einen DHCP-Server die Dreh-Kodier-Schalter auf 0xF0. In diesem Zustand ist der DHCP-Dienst eingeschaltet und das Modul bekommt automatisch eine IP-Nummer vom DHCP-Server zugewiesen. Der DHCP-Server muss hierfür die MAC-ID des Moduls kennen. Die IP-Adresse sollte statisch eingestellt werden. Während der Adressvergabe blinkt die LED TCP/IP Error.


Subnetz-Maske

Die Subnetz-Maske unterliegt der Kontrolle des Netzwerkverwalters und legt die Struktur der Subnetze fest.

Kleine Netze ohne Router benötigen keine Subnetz-Maske. Das gleiche gilt, wenn Sie keine registrierten IP-Nummern verwenden. Sie können die Subnetz-Maske dazu verwenden, anstelle des Gebrauchs vieler Netznummern das Netz mit dieser Maske zu unterteilen.

Die Subnetz-Maske ist eine 32-Bit Ziffer:

  • Einsen in der Maske kennzeichnen den Subnetz-Nummernteil eines Adressraums.
  • Nullen kennzeichnen den Teil des Adressraums, der für die Host-IDs zur Verfügung steht.
Beschreibung | Binäre Darstellung | Dezimale Darstellung
IP-Adresse | 10101100.00010000.00010001.11001000 | 172.16.17.200
Subnetz-Maske | 11111111.11111111.00010100.00000000 | 255.255.20.0
Netz-ID | 10101100.00010000.00010000.00000000 | 172.16.16.0
Host-ID | 00000000.00000000.00000001.11001000 | 0.0.1.200

Standard Subnetz-Maske

Adressklasse | Standard Subnetz-Maske (dezimal) | Standard Subnetz-Maske (hex)
A | 255.0.0.0 | FF.00.00.00
B | 255.255.0.0 | FF.FF.00.00
C | 255.255.255.0 | FF.FF.FF.00

Hinweis Die Subnetze 0 und das nur aus nur Einsen bestehende Subnetz dürfen nicht verwendet werden!
Die Host-Nummer 0 und die aus nur Einsen bestehende Host-Nummer dürfen nicht verwendet werden!

Wenn die IP-Adresse über die Konfigurationssoftware KS2000 eingestellt wurde, muss auch die Subnetz-Maske mit der Konfigurationssoftware KS2000 geändert werden.
Bei ARP-Adressierung wird anhand der IP-Adresse die dazugehörige Standard Subnetz-Maske eingetragen.
Bei BootP und DHCP wird die Subnetz-Maske mit vom Server übertragen.


Test der IP-Adresse

Zum Testen der IP-Adresse können Sie das Kommando Ping benutzen.


Auslesen der MAC-ID

Gehen Sie folgendermaßen vor, um die MAC-ID auszulesen:

  • Ändern Sie die IP-Adresse Ihres PCs auf 172.16.x.x. und SubNetMask auf 255.255.0.0
    Die IP-Adresse der Ethernet Feldbusboxen ist im Auslieferungszustand 172.16.18.1 (Dreh-Kodier-Schalter: 0, 1)
  • Starten Sie die Eingabeaufforderung (DOS-Fenster)
  • Schicken Sie ein Ping >ip-address< auf die IP-Adresse 172.16.18.1
  • Lesen Sie die MAC-ID mit arp -a aus.


BK9103 - GDSML-Konfigurationsdatei

BECKHOFF IL230x-B903: Parametrierung und Inbetriebnahme

GSDML-Konfigurationsdatei

Laden sie die Konfigurationsdatei für den PROFINET-Master von der Beckhoff Webseite www.beckhoff.de

Ein Update ihrer Firmware erhalten Sie gegebenenfalls unter support@beckhoff.com.

Bild zur Verwendung mit Siemens Step7

Das entsprechende Bild (*.bmp) finden sie ebenfalls auf der Beckhoff Webseite.

Kopieren Sie das Bild in folgendes Verzeichnis "\Siemens\Step7\S7DATA\NSBMP".


IL230x-B903 - Mapping der Busklemmen

BECKHOFF IL230x-B903: Parametrierung und Inbetriebnahme

Mapping der Koppler-Box

Die Signale der Koppler-Box, sowie der angeschlossenen Erweiterungsboxen mappen sich in der Reihenfolge , wie diese hardwaremäßig angeschlossen sind.

Für digitale Boxen wird immer mindestens ein Byte reserviert.
Haben die Boxen weniger als 8 Bits, so wird mit Nullen aufgefüllt.

Die Daten werden mit WORD Alignment dargestellt, d.h. bei analogen Modulen wird im ersten WORD das Status BYte und ein Leerbyte übertr.agen
Bespiel: IE2301 4 digitale Eingänge, 4 digitale Ausgänge, 8 Bit Eingang, 8 Bit Ausgang, wobei die ersten vier Bits 0-3 belegt sind. Bits 4-7 haben keine Bedeutung.

Komplexe Boxen werden mit Ein- und Ausgangsprozessabbild dargestellt.

Beispiel

IE3102, 4 Kanal analoger Eingang: je Kanal 1 Byte Control oder Status Informationen, ein Leerbyte, 2 Byte Daten.


IL230x-B903 - DAP

BECKHOFF IL230x-B903: DAP

DAP (Device Access Point) der Koppler-Box

Als Gerätemodell wurde für das PROFINET die aus dem PROFIBUS-DP bekannte Sichtweise der dezentralen Peripherie gewählt.

Die Steckplätze der modularen Geräte werden über Slots und Subslots repräsentiert.

Slot 0 ist als Device Access Point (DAP) ausgeprägt. Hier wird das Modul selber beschrieben.

In den Status-Bits wird der aktuelle Wert der Control-Bits zurückgemeldet. Außerdem wird in den Bits 8 -15 in Abhängigkeit von "S" im ControlBit 6 eine IP-Link-Counter oder die aktuelle IP-Link-Zykluszeit angezeigt.

Status-Bits

31 - 24 | 23 - 16 | 15 - 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
IP-Link Error Argument | IP-Link Error Code | IP-Link Counter oder IP-Link Cycle Timer | - | S | - | - | L2 | - | R1 | K1

K1: IP-Link Reset wurde getriggert

R1: Reboot des IL230x-B903 wurde ausgelöst

L2: IP-Link Stopp bei Profinet Fehler

Control-Bits

31 - 24 | 23 - 16 | 15 - 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
- | - | - | - | S | - | - | L2 | - | R1 | K1

K1: 0 -> 1 IP-Link Reset auslösen

R1: Reboot des IL230x-B903 wurde ausgelöst

L2: IP-Link Stopp bei Profinet Fehler

S: =1 IP-Link-Zykluszeit in ms


IL230x-B903 - Beispiel mit Step 7

BECKHOFF IL230x-B903: Parametrierung und Inbetriebnahme

Beispiel mit Step 7

Installieren Sie die GSDML-Datei (ab Step 7 ab Version 5.4 + SP1)

Öffnen Sie dazu den Hardware Manager. Installieren Sie die GSDML-Datei.

Fügen Sie einen IL230x-B903 Knoten in ihren Manager und fügen Sie die Erweiterungsmodule entsprechend Ihrer Konfiguration an.

Stellen Sie den Namen des PN-Gerätes ein, zum Beispiel "il230x-b903-10" ["il" muss Klein geschrieben sein] (Stellen Sie die Adress- Schalter der Box auf 0xFF und schalten dann den Koppler ein).

Die Konfiguration sieht zum Beispiel jetzt wie folgt aus. Laden Sie die Konfiguration in ihrer Steuerung.


Diagnose-LEDs

Fehlerdiagnose

Es gibt 2 Arten von Fehlern:

  • Feldbus Fehler
  • Lokaler Fehler auf Kompakt Box oder Koppler Box

Blink-Codes

Blinkfolge | Bedeutung
Schnelles Blinken | Anfang des Blink-Codes
erste langsame Sequenz | Fehler-Code
zweite langsame Sequenz | Fehlerargument
dritte langsame Sequenz (optional) | Fehlerargument

Flasching_codes.jpg (2840 Byte)

Anfang Fehler-Code Fehlerargument


IL230x-B903 - Diagnose-LEDs

BECKHOFF Feldbuskomponenten: Diagnose

Diagnose-LEDs

Nach dem Einschalten überprüft das Modul sofort die angeschlossene Konfiguration. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED I/O ERR signalisiert. Das Blinken der LED I/O ERR zeigt einen Fehler im Bereich der Ein/Ausgänge an. Durch Frequenz und Anzahl des Blinkens kann der Fehler-Code ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Zur Statusanzeige besitzt das Modul zwei Gruppen von LEDs. Die obere Gruppe mit vier LEDs zeigt den Zustand des jeweiligen Feldbusses an. Die Bedeutung der Feldbus-Status-LEDs wird in den entsprechenden Kapiteln dieses Handbuches erläutert. Sie entspricht den feldbusüblichen Anzeigen.

Am unteren Ende des Moduls befinden sich zwei weitere grüne LEDs zur Anzeige der Versorgungsspannung. Die linke LED zeigt die 24 VDC Logik-Versorgung des Moduls an. Die rechte LED signalisiert die Versorgung der Ausgänge.

LEDs zur Ethernet-Diagnose

LED | Ein | Aus
SPEED | Einstellung des Ports auf 100MBit/s | Einstellung des Ports 10MBit/s
ACT | Ein: Physikalische Verbindung vorhanden Blinkt: Busverkehr vorhanden | keine Verbindung

LEDs zur PROFINET-Diagnose

DIAG R (grün) | DIAG E (rot) | Konfiguration/Diagnose
an | aus | OK
0,5s | aus | Blinken (wird ausgelöst durch ein Profinet Tool)
0,1s | aus | Offline PLC Stop
aus | 0,5s | TimeOut
1 | Slot Nummer | Falsches Modul
2 | Slot Nummer | Fehlendes Modul (physikalisch)
3 | Slot Nummer | Fehlendes Modul (in der Konfiguration)
4 | aus | Kein Profinet Name vergeben
5 | Slot Nummer | Substitute

Anmerkung:

  • Treten mehrere Fehler auf, so wird immer das letzte fehlerhafte Modul angezeigt.
  • Substitute - wird bei falsch konfigurierten Modulen gesetzt, die aber trotzdem lauffähig sind (Beispiel IE3112 konfiguriert es steckt aber an dem Slot eine IE3102)
Beispiel

Sie haben eine IE3112 als fünftes Modul konfiguriert, tatsächlich sind aber nur vier Module verbunden.

  • Start Error Code: Rote DIAG E LED flackert schnell, grüne DIAG R LED ist aus
  • Rote DIAG E LED ist an, grüne LED zeigt den Error Code blickt 2 mal (0,5 Sec)
  • Rote und grüne LED aus
  • Rote DIAG E LED zeigt das Error Argument blickt 5 mal (0,5 Sec, hier die Slotnummer), grüne LED ist aus

LEDs zur Diagnose der Spannungsversorgung

LED | Bedeutung
Linke LED aus | Modul hat keine Spannung
Linke LED rot | Kurzschlussüberwachung der Sensorversorgung (< 500mA) ist akiviert. Sensoren/Eingänge werden nicht mehr versorgt.
Rechte LED aus | Keine Spannungsversorgung 24 VDC für Ausgänge angeschlossen


Diagnose-LEDs für lokale Fehler

Lokale Fehler in einer Koppler Box (IL230x-Bxxx/Cxxx)

Unter den lokalen Fehlern ist gemeint, das ein Fehler in der Feldbus Box oder dem IP-Link aufgetreten ist. IP-Link-Fehler sind meist durch unsachgemäßen Gebrauch der Lichtwellenleitung zurück zu führen.

LED grün | LED rot |  |  | Beschreibung | Abhilfe
aus | aus |  |  | kein Datenaustausch | Modul im synchron Mode - zyklische Daten aktivieren
aus | 1 | 0 |  | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
aus | 2 |  |  | reserviert | -
aus | 3 | n |  | Bruchstelle wurde erkannt | n-tes Modul vor dem Empfänger des Masters
 | 3 | n | m | Bruchstelle wurde erkannt | (n*10)+m-tes Modul vor dem Empfänger des Masters
aus | 4 | n |  | zu viele fehlerhafte Telegramme erkannt (mehr als 25%) | vor dem n-ten Erweiterungsmodul (vor dem Empfänger des Masters) ist die LWL-Verkabelung zu prüfen
aus | 5 | n |  | Registerzugriff auf komplexe Module gescheitert | n-tes Modul überprüfen
aus | 11 | n |  | Komplexes Modul arbeitet fehlerhaft | n-tes Modul tauschen
aus | 12 | n |  | mehr als 120 Module im Ring | weniger Module anschließen
aus | 13 | n |  | n-tes Modul unbekannt | Firmware Update erforderlich
an | aus |  |  | Modul ist im Datenaustausch (kein Fehler) | -

Lokale Fehler in einer Erweiterungsbox

LED grün | LED rot | Beschreibung
aus | an | es werden kein Daten über den IP-Link empfangen
aus | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (sehr schlechte Datenverbindung)
blinkt, flackert | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (schlechte Datenverbindung), muss noch nicht zum Fehler führen
an | aus | es werden IP-Link Protokolle empfangen, kein Fehler

Fehlerhafte IP-Link Protokolle können entstehen durch:

  • schlecht konfektionierte IP-Link Steckverbinder
  • IP-Link Leitung mit erhöhter Dämpfung durch z.B. Knick o.ä.
  • defekte oder verschmutzte Sende LED (Modul vor dem fehlerhaften Modul)
  • defekter oder verschmutzter Empfänger

Der interne IP-Link-Fehlerzähler der Koppler Box kann mit der KS2000 Software ausgelesen werden.


Feldbus Box - Überprüfung der IP-Link-Verbindung

BECKHOFF Feldbus Box: Montage und Verkabelung

Überprüfung der IP-Link-Verbindung

Ein IP-Link-Kabel mit auf beiden Seiten korrekt konfektionierten IP-Link-Steckern garantiert eine fehlerfrei Übertragung.

Eine nachträgliche Prüfung der Übertragungsqualität und eine Fehlersuche ist mit der Konfigurationssoftware KS2000 möglich.

Hierzu sollte die Steuerung (z.B. ein PC mit Profibus-Karte) am Feldbus des Koppler Box angeschlossen sein und diese zyklisch mit Daten versorgen, oder die Koppler Box sollte mit der KS2000 auf freilaufend geschaltet werden.

Als Ergebnis sollte die I/O RUN LED auf dem Kopplermodul hellgrün leuchten. Dies zeigt, dass ein Datenaustausch mit den angeschlossenen Erweiterungsbox Modulen stattfindet. Eine rot flackernde I/O ERR LED zeigt fehlerhafte IP-Link-Telegramme an! Telegramme werden wie bei auch jedem Feldbussystem im Fehlerfall wiederholt, so dass eine Übertragung der Daten gewährleistet ist.

Fehlerzähler

In Tabelle 90, Offset 005 werden aufgetretene IP-Link-Fehler gezählt. Sporadisch auftretende Fehler bedeuten noch keine Probleme für die Kommunikation. Dieser Fehlerzähler wird nur durch ein Power ON/OFF zurückgesetzt.

Sollten in kurzer Zeit viel Fehler auftreten, wird eine schwere Störung diagnostiziert und das Koppler-Modul meldet diesen Fehler. Dies ist am Offset 006 oder 007 zu erkennen. Die beiden Werte stehen dann auf einem Wert > 200 und die I/O ERR LEDs des Koppler-Moduls blinken mit dem entsprechenden Fehler-Code.

Hinweis Die Konfigurations-Software KS2000 kommuniziert über einen seriellen Kanal mit der Koppler Box. Der Registerinhalt wird nicht andauernd aktualisiert, muss also manuell refreshed werden.

Fehlerort

Stellt das Koppler Modul einen Fehler fest, versucht es den Fehlerort aus dem Register der Erweiterungs-Box herauszulesen. Ist der Ring tatsächlich unterbrochen bzw. die Kommunikation stark gestört, ist dies nicht möglich. Dann wird nur der Ort des Bruchs dargestellt und zwar rückwärts vom Koppler gezählt (siehe IP-Link Fehlersuche).

Läuft die Kommunikation noch, kann in Tabelle 87 der Fehlerzähler je Erweiterungsmodul ausgelesen werden.

Hier bezieht sich der Offset auf die Position links im KS2000 Baum (siehe Grafik). d.h. in diesem Beispiel werden Fehler beim Offset 004 und 006 angezeigt.

Im IP-Link Aufbau ist der Fehler also bei der Übertragung zu Modul IE20xx und bei der Übertragung zu IE3112 zu suchen.

Der Fehler kann also liegen, an:

  • dem Sender-Modul
  • dem Empfänger-Modul
  • dem Kabel oder
  • den Steckern

Wird in Tabelle 90 ein Fehler angezeigt, aber in Tabelle 87 nicht, so ist die Fehlerursache in der Übertragungsstrecke zwischen dem letzten Erweiterungsmodul und dem Koppler zu suchen.

In fast allen Fällen sind Übertragungsfehler auf schlecht konfektionierte IP-Link-Stecker oder zu hohe Dämpfung im LWL-Kabel (durch scharfe Knicke o.ä.) zurückzuführen.

Tabelle 87 wird bei einer IP-Link-Unterbrechung nicht aktualisiert, da diese Werte direkt aus den Erweiterungs-Modulen kommen. Diese können dann über den IP-Link natürlich nicht mehr ausgelesen werden.

Hinweis Falls Sie eine Koppler-Box (z.B. IL2300-Bxxx, IL2301-Bxxx oder IL2302-Bxxx ) ganz ohne Erweiterungs-Box-Module (IExxxx) betreiben möchten, müssen Sie Sende- und Empfangs-Anschluss diese Koppler-Box über ein IP-Link-Kabel direkt miteinander verbinden! Hierfür eignet sich besonders der IP-Link-Verbindungsstecker ZK1020-0101-1000.


Feldbus Box Zubehör

Das notwendige Zubehör für die Feldbus Box Module gibt es in Schutzklasse IP67 ebenfalls von Beckhoff. Eine Übersicht entnehmen Sie bitte aus dem Beckhoff Katalog oder unseren Internet-Seiten (http://www.beckhoff.de).

Feldbuszubehör

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Spannungsversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Sensorversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

IP-Link

  • Vorkonfektionierte Kabel
  • Stecker


Powerkabel

Bestelldaten

Bestellbezeichnung | Powerleitung | Schraub- Steckverbinder | Kontakte | Querschnitt | Länge
ZK2020-3200-0020 | Buchse gerade, offenes Ende | M8 | 4-polig | 0,34 mm2 | 2,00 m
ZK2020-3200-0050 |  |  |  |  | 5,00 m
ZK2020-3200-0100 |  |  |  |  | 10,00 m
ZK2020-3400-0020 | Buchse gewinkelt, offenes Ende |  |  |  | 2,00 m
ZK2020-3400-0050 |  |  |  |  | 5,00 m
ZK2020-3400-0100 |  |  |  |  | 10,00 m
ZK2020-3132-0001 | Buchse gerade, Stecker gerade |  |  |  | 0,15 m
ZK2020-3132-0005 |  |  |  |  | 0,50 m
ZK2020-3132-0010 |  |  |  |  | 1,00 m
ZK2020-3132-0020 |  |  |  |  | 2,00 m
ZK2020-3132-0050 |  |  |  |  | 5,00 m
ZK2020-3334-0001 | Buchse gewinkelt, Stecker gewinkelt |  |  |  | 0,15 m
ZK2020-3334-0005 |  |  |  |  | 0,50 m
ZK2020-3334-0010 |  |  |  |  | 1,00 m
ZK2020-3334-0020 |  |  |  |  | 2,00 m
ZK2020-3334-0050 |  |  |  |  | 5,00 m

Weitere verfügbare Powerkabel und die dazugehörigen Datenblätter finden Sie im Beckhoff Katalog oder auf unseren Internet-Seiten (http://www.beckhoff.de).

Technische Daten

Daten
Bemessungsspannung nach IEC61076-2-101 | 30 VDC
Verschmutzungsgrad nach IEC 60 664-1 | 3/2
Isolationswiderstand IEC 60 512-2 | >109 W
Strombelastbarkeit IEC 60512-3 | 4 A
Durchgangswiderstand IEC 60512-2 | < 5 mW
Schutzart nach IEC 60529 | IP65/66/67, im verschraubten Zustand
Umgebungstemperatur | -30°C bis +80°C


Allgemeine Betriebsbedingungen

Schutzarten nach IP-Code

In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.

1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub

2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist

*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.

Chemische Beständigkeit

Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus Box und den verwendeten Metallteilen.

Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende

beständig: Lebensdauer mehrere Monate
bedingt beständig: Lebensdauer mehrere Wochen
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zulassungen

UL E172151

Konformitätskennzeichnung

CE

Schutzart

IP65/66/67 gemäß EN60529


Prüfnormen für die Geräteprüfung

EMV

Festigkeit: EN 61000-6-2

Aussendung: EN 61000-6-4

Vibrationsfestigkeit

Schwingungsprüfung: EN 60068-2-2, Amplitude 2 g (Norm 1 g)

Schockprüfung: EN 60068-2-27, Schockanzahl 1000 (Norm 2)


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.