FBB-x900, FBB-x901 - Feldbus Box Module für Ethernet

BECKHOFF Feldbuskomponenten

Dokumentation

Feldbus Box Module für Ethernet

Version: 1.2.1
Datum: 29.10.2009


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


FBB-x900, FBB-x903 - Ausgabestände der Dokumentation

BECKHOFF Feldbus Box: Vorwort

Ausgabestände der Dokumentation

Version | Änderungen
1.2.1 | Systemübersicht aktualisiert
1.2 | Grafiken der Feldbus Box Module mit M12 Ethernet-Buchse (B901) aktualisiert
1.1 | Kapitel Überprüfung der IP-Link-Verbindung hinzugefügt
1.0 | Erste Version


Buskoppler als allgemeine Bezeichnung

Teile des vorliegenden Handbuches geben allgemeine Informationen über die Ethernet-Implementierung in Beckhoff Produkten.
Im folgenden wird daher oft der Begriff Buskoppler genutzt, der hier nicht nur die IP20-Produkte beschreibt, sondern auch die IP67-Module meint.


Das Feldbus Box System

Feldbus Box Module sind robuste Feldbusstationen für viele verschiedene Feldbus-Systeme. Sie verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Neben digitalen und analogen Ein- und Ausgängen samt Thermoelement- und RTD-Eingängen gibt es Inkrementalencoder-Interfaces für die Weg- und Winkelmessung sowie serielle Schnittstellen für die Lösung vielfältiger Kommunikationsaufgaben.

Signalanschluss in 3 Varianten

Die digitalen Ein-/Ausgänge können wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12-Variante vorgesehen.

Alle wichtigen Signalformen

Spezielle Ein-/Ausgangskanäle auf den Kombi-E/A-Module lassen sich wahlweise als Ein- oder Ausgang nutzen. Eine Konfiguration ist nicht erforderlich, da die Feldbusschnittstelle für jeden Kombikanal sowohl Eingangs- als auch Ausgangsdaten zur Verfügung stellt. Durch die Kombi-Module hat der Anwender alle Vorteile einer feinen Signal-Granularität.

Die Prozessor-Logik, die Eingangsbeschaltung sowie die Sensorversorgung werden aus der Steuerspannung gespeist. Die Lastspannung für die Ausgänge kann separat zugeführt werden. Bei Feldbus Boxen, in denen nur Eingänge zur Verfügung stehen, kann die Lastversorgung UP zur Weiterleitung optional angeschlossen werden.

Die Zustände der Feldbus Box, der Feldbusverbindung, der Spannungsversorgung sowie der Signale werden von LEDs angezeigt.

Die Beschriftungsstreifen lassen sich extern maschinell beschriften und können dann eingeschoben werden.

Kombinierbare Feldbus Boxen für mehr Flexibilität

Die Feldbus Box Serie umfasst neben der Kompakt Box auch erweiterbare Geräte, die Koppler Box und die Erweiterungsbox sowie intelligente Geräte, die SPS Boxen.

Kompakt Box

Die Kompakt Box stellt dem Feldbus die E/A-Daten der angeschlossenen digitalen und analogen Sensoren und Aktuatoren zur Verfügung.

Koppler Box

Die Koppler Box sammelt zusätzlich über eine störsichere LWL-Verbindung (IP-Link) E/A-Daten von den Erweiterungsboxen ein. Sie können bis zu 120 Erweiterungsboxen an eine Koppler Box anschließen. Es ergibt sich so ein verteiltes IP67 E/A-Netzwerk mit nur einer Feldbusschnittstelle.

Die Koppler Box erkennt die angeschlossenen Erweiterungsmodule selbsttätig in der Aufstart-Phase und mappt die E/A-Daten automatisch in das Feldbus-Prozessabbild – eine Konfiguration ist nicht erforderlich. Aus Sicht des Feldbusses stellt sich die Koppler Box samt allen vernetzten Erweiterungsboxen als ein einziger Busteilnehmer mit entsprechend vielen E/A-Signalen dar.

Die Koppler Box entspricht dem Buskoppler aus dem BECKHOFF Busklemmen-System. BECKHOFF Feldbus-Geräte der Schutzart IP 20 (Busklemmen) und IP 67 (Feldbus Box) können problemlos kombiniert werden - das Daten-Handling ist jeweils gleich.

IP-Link

IP-Link ist eine LWL-Verbindung mit 2 Megabit/s Übertragungsrate, die 1000 binäre E/A-Daten in ca. 1 ms schnell und sicher überträgt – kleinere Konfigurationen entsprechend schneller. Durch die hohe Nutzdatenrate ist gewährleistet, dass die Kopplung über IP-Link keine spürbare Einschränkung der Feldbus-Performance mit sich bringt.

Für die schnelle und einfache Konfektionierung der IP-Link-Kabel vor Ort wurden preisgünstige Steckverbinder in IP 67 Schutzart entwickelt. Der Anschluss erfordert kein Spezialwerkzeug und lässt sich schnell und einfach durchführen. Die IP-Link-Kabel sind alternativ auch mit vorkonfektionierten Steckern erhältlich.

Durch die getrennte Zuführung der Ausgangs-Spannungsversorgung lassen sich Ausgangsgruppen einzeln abschalten. Außerdem können problemlos unterschiedliche Potenziale innerhalb eines Erweiterungsringes aufgebaut werden, da IP-Link naturgemäß über eine optimale Potenzialtrennung verfügt.

Erweiterungsbox

Die Erweiterungsboxen decken wie die Kompakt Boxen das gesamte Spektrum der E/A-Signale ab und dürfen bis zu 15 m Abstand voneinander haben. Sie bauen hierbei besonders klein und führen zu besonders preiswerten E/A-Lösungen in hoher Schutzart. Auch hier sind die digitalen Ein-/Ausgänge wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder anschließbar. Analoge Signaltypen werden mit der M12-Variante ausgerüstet. Die Schnapp-Steckverbinder verriegeln formschlüssig und ergeben eine rüttelfeste Verbindung, während sich die Schraub-Steckverbinder durch eine hohe Zugfestigkeit auszeichnen.

SPS Box

Die SPS Box ist eine intelligentes Feldbus Box mit SPS-Funktionalität für dezentrale Vorverarbeitung der E/A-Signale. Hiermit lassen sich Applikationsteile aus der zentralen Steuerung auslagern. Deren CPU und der Feldbus werden entlastet. Dezentral Zählen, Regeln oder Schalten sind typische Anwendungen für die SPS-Box. Die Reaktionszeiten sind unabhängig von der Buskommunikation und der übergeordneten Steuerung.

Bei Bus- oder Steuerungsausfall ist ein Funktionserhalt (z.B. geordnete Überführung des Prozesses in einen sicheren Zustand) möglich.

Die Programmierung erfolgt mit TwinCAT nach IEC 61131-3. Fünf verschiedene Programmiersprachen stehen zur Verfügung:

  • Anweisungsliste (AWL)

  • Funktionsplan (FUP)

  • Kontaktplan (KOP)

  • Ablaufsprache (AS)

  • Strukturierter Text (ST).

Der Programm-Download erfolgt wahlweise über den Feldbus oder über die Programmierschnittstelle.

Es stehen umfangreiche Debug-Funktionalitäten (Breakpoint, Einzelschritt, Monitoring, etc.) zur Verfügung. SPS Box verfügt über einen leistungsfähigen 16 Bit Controller, 32/96 KByte Programmspeicher und 32/64 KByte Datenspeicher. Weiter stehen 512 Byte als nichtflüchtiger Speicher für remanente Merker zur Verfügung.

SPS Box mit IP-Link

Nahezu unbeschränkte E/A-Möglichkeiten ergeben sich durch die programmierbare SPS Box mit IP-Link. Aus dem SPS-Programm heraus lassen sich bis zu 120 Erweiterungsmodule mit über 2000 E/As direkt ansprechen. Die SPS Box eignet sich damit auch als autarke Kleinsteuerung zur Steuerung von Anlagenteilen oder kleiner Maschinen.


Feldbus Box - Bezeichnungsübersicht

Die Bezeichnung der Feldbus Box Module ist wie folgt zu verstehen:
IXxxxy-zyyy

IX beschreibt die Bauform:

"IP" steht für die Bauform Kompakt Box.
"IL" steht für die Bauform Koppler Box (mit IP-Link).
"IE" steht für die Bauform Erweiterungsbox.

xxxy beschreibt die E/A-Beschaltung:

xxx bezeichnet die E/A-Eigenschaft:
"10x" - 8 x digitale Eingänge
"15x" - Zählermodul
"20x" - 8 x digitale Ausgänge
"23x" - 4 x digitale Eingänge und 4 x digitale Ausgänge
"24x" - 8 x digitale Eingänge und 8 x digitale Ausgänge
"25x" - PWM-Modul
"3xx" - 4 x analoge Eingänge
"4xx" - 4 x analoge Ausgänge
"5xx" - Inkremental-Encoder oder SSI-Geber
"6xx" - Gateway-Module RS232, RS422, RS485, TTY

y beschreibt den mechanischer Anschluss:
"0" steht für 8mm Schnappanschluss
"1" steht für M 8 Schraubanschluss
"2" steht für M 12 Schraubanschluss und
"9" steht für M23 Schraubanschluss

zyyy bezeichnet die Programmierbarkeit und das Feldbus-System:

z unterscheidet ob es sich um einen Slave oder einen programmierbare Slave handelt:
"B" - nicht programmierbar
"C" - programmierbar (SPS Box)

yyy steht für das Feldbus-System und den Bus-Anschluss:
"110" - EtherCAT
"200" - Lightbus
"310" - PROFIBUS
"318" - PROFIBUS mit integriertem T-Stück
"400" - Interbus
"510" - CANopen
"518" - CANopen mit integriertem T-Stück
"520" - DeviceNet
"528" - DeviceNet mit integriertem T-Stück
"730" - Modbus
"800" - RS485
"810" - RS232
"900" - Ethernet TCP/IP mit RJ45 für den Bus-Anschluss
"901" - Ethernet TCP/IP mit M12 für den Bus-Anschluss
"903" - PROFINET
"905" - EtherNet/IP

Kompakt Box

Die Feldbus Boxe verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Die digitalen Ein-/Ausgänge können wahlweise über Ø 8 mm Schnapp-, M8 Schraub- oder über M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12 Variante verfügbar.

Je nach Modul kann der E/A-Teil und der Stromversorgungsteil unterschiedlich sein.

Koppler Box

Die Koppler Box gibt es in drei Varianten als IL230x-Bxxx. Diese unterscheidet sich von der Kompakt Box dadurch, dass diese Module eine Schnittstelle zu den sogenannten Erweiterungsboxen bietet. Diese Schnittstelle ist ein Sub-Bussystem auf LWL Basis den sogenannten IP-Link. Dieses leistungsfähige Sub-Bussytem kann bis zu 120 Erweiterungsboxen an einer Koppler Box verarbeiten.

Erweiterungsbox

Feldbusunabhängige Erweiterungsmodule, die nur an einer Koppler Box über IP-Link betrieben werden können.

SPS Box

Eine SPS Box unterscheidet sich von einer Koppler Box dadurch, dass sie in IEC 61131-3 programmierbar ist. Dadurch kann dieser Slave auch ohne Master autonom arbeiten, zum Beispiel für Steuerungs- oder Regelungsaufgaben.


Firm- und Hardware-Stand

Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Hard- und Firmware-Stand. Die Eigenschaften werden weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben wie Module neue Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das diese Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand der Module können Sie anhand der mit einem D beginnenden Nummer auf der Seite des Moduls erkennen.

Syntax:

D . ww yy x y z u

ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel:

D.22081501

- Kalenderwoche 22
- des Jahres 2008
- Firmware-Stand Busplatine: 1
- Hardware Stand Busplatine: 5
- Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig)
- Hardware-Stand E/A-Platine: 1


FBB-x900, FBB-x903 - Technische Daten

BECKHOFF Feldbus Box: Produktübersicht

Technische Daten

Technische Daten | IL230x-B900, IL230x-C900 | IL230x-B901
Erweiterungsmodule (IL....) | max. 120
Digitale Peripheriesignale (IL....) | max. 960 Ein- und Ausgänge
Analoge Peripheriesignale (IL....) | max. 480 Ein- und Ausgänge
Übertragungsmedium | 4 x 2 Twisted-Pair Kupferkabel; Kategorie 3 (10 MBaud), Kategorie 5 (100 MBaud)
Übertragungsrate | 10/100 MBaud
Topologie | sternförmige Verkabelung
Entfernung zwischen Modulen | 100 m (Hub/Switch bis Feldbus Box)
Konfiguration | über KS2000 oder über die Steuerung
Protokolle | UDP-ADS, TCP-ADS, Fast-ADS, ModbusTCP, Realtime-Ethernet
Stromversorgung | Steuerspannung: 24VDC (-15%/+20%); Lastspannung: entsprechend E/A-Variante
Stromaufnahme Steuerspannung | entsprechend E/A-Variante + Stromaufnahme Sensorversorgung, max. 0,5A
Stromaufnahme Lastspannung | entsprechend E/A-Variante
Anschluss Stromversorgung | Einspeisung: 1 x M8 Stecker 4-polig Weiterleitung: 1 x M8 Buchse 4-polig (außer IP/IE204x)
Anschluss Feldbus | 1 x RJ45 Buchse | 1 x M12 Buchse, d-codiert
Potentialtrennung | Kanäle / Steuerspannung: nein zwischen den Kanälen: nein Steuerspannung / Feldbus: ja
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... +55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 65/66/67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE, UL E172151
Hinweis Detaliierte technische Daten zu allen erhältlichen E/A-Varianten entnehmen Sie bitte der Dokumentation Signalvarianten, Installation, Konfiguration der E/A-Module, die Sie auf der Beckhoff CD Products & Solutions oder im Internet (http://www.beckhoff.de) unter Download/Feldbus Box finden.


Feldbusbox - Abmessungen

BECKHOFF Feldbus Box: Montage

Abmessungen

Alle Maßangaben sind in Millimeter angegeben.

Allgemein

Technische Daten | Feldbus Box
Gehäusematerial | PA6 (Polyamid), Vergussmasse: Polyuhrethan
Montage | 2 x Befestigungslöcher für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | IEC EN 50082-2 / EN 50081-2
Zulässige Umgebungstemperatur im Betrieb | 0 ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25 ... + 85°C
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65/66/67
Zulassungen | CE, UL E172151

IPxxxx-Bxx8, IL230x-Bxx8, IL230x-B110, IXxxxx-B400, IXxxxx-B90x, IXxxxx-C900

Technische Daten | Kompakt- und Kopplerbox mit integriertem T-Stück
Abmessungen (H x B x T) | ca. 210 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm)
Gewicht | ca. 260 g - 290 g, je nach Modultyp

IPxxxx-Bxx0, IL230x-Bxx0, IL230x-Cxx0

Technische Daten | Kompakt- und Kopplerbox
Abmessungen (H x B x T) | ca. 175 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm, mit T-Stück ZS1031-2600 Höhe ca. 65 mm)
Gewicht | ca. 250 g - 280 g, je nach Modultyp

IExxxx

Technische Daten | Erweiterungsbox
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Gewicht | ca. 120 g - 200 g, je nach Modultyp


Ethernet-Anschluss

Der Anschluss an den Ethernet-Bus erfolgt über einen gekapselten IP67 RJ45-Stecker (Westernstecker).

Als Leitung sollte ein CAT5 oder CAT5e Kabel eingesetzt werden.

Standard Patch-Kabel sind ebenfalls einsetzbar. Die Kombination erfüllt aber dann nicht die entsprechende Schutzklasse.

Verkabelung

Verbindung über Hub oder Switch

VekabellungPC_HUB_B900.gif (16161 Byte)

Verbinden Sie die Netzwerkkarte des PCs über ein Standard-Ethernetkabel mit dem Hub, und den Hub ebenfalls über ein Standard-Ethernetkabel mit der Feldbus Box.

Die Verbindung über einen Switch erfolgt auf die gleiche Weise.

Direkte Verbindung zwischen PC mit Ethernet-Karte und B900

VekabellungPC_B900.gif (15629 Byte)

Um den PC direkt mit Feldbus Box zu verbinden, muss ein Ethernetkabel mit gekreuzten Adernpaaren (Cross-Over-Kabel) verwendet werden.

Belegung des RJ45-Steckers

PIN | Signal | Beschreibung
1 | TD + | Transmit Data+
2 | TD - | Transmit Data-
3 | RD + | Receive Data+
4 | - | reserviert
5 | - | reserviert
6 | RD - | Receive Data-
7 | - | reserviert
8 | - | reserviert

Hinweis: Es gibt keine genormte Farbbelegung der Kabel!


Feldbus Box - Ethernet-Steckerverbinder: RJ45

BECKHOFF Feldbuskomponenten: Einbau und Verdrahtung

Ethernet-Steckerverbinder: RJ45

Der Anschluss an den Ethernet-Bus erfolgt über einen gekapselten IP67 RJ45-Stecker (Westernstecker).

B900_Connector.jpg (6645 Byte)

Konfektionierung

Vorbereitung des Kabels
  • Schieben Sie die Kabelverschraubung und das Steckergehäuse auf das Kabel.
  • Isolieren Sie den Kabelmantel auf 30 mm ab.
  • Längen Sie das Schirmgeflecht auf 8 mm ab und legen Sie es nach hinten über den Kabelmantel.
  • Entfernen Sie soweit vorhanden Kabelfüller, Kunststoffgeflecht, Beilauflitze und Schirmfolie.

  • Richten Sie die Einzeladern gemäß Kontaktbelegung nebeneinander aus.
  • Längen Sie die Einzeladern zum leichteren Einführen in die Kabeleinführhilfe schräg (ca.45°) ab.

Konfektionierung des Steckers
  • Fädeln Sie die Adern gemäß Kontaktbelegung in die Kabeleinführhilfe ein.
  • Ziehen Sie die Einführhilfe auf das Kabel auf bis die Aussparung an den Kabelmantel anschlägt.
  • Überprüfen Sie ob die Adern in der richtigen Position sitzen.
  • Längen Sie die Adern rechtwinklig auf 5 mm ab.

  • Ziehen Sie die Einführhilfe wieder in Richtung Kabelende zurück, bis die Adern nur noch 1 mm hervorstehen.

  • Schieben Sie das Kabel mit der Einführhilfe von hinten in den RJ45-Stecker (Bei dickeren, starren Kabeln können Sie den Kabelmantel mit einem stumpfen Hilfsmittel etwas flachdrücken um das Einführen des Kabels in den RJ45-Einsatz zu erleichtern).
  • Drücken Sie das Kabel fest an, wenn die Einführhilfe auf Anschlag sitzt.

Belegung des RJ45-Steckers

PIN | Signal | Beschreibung
1 | TD + | Transmit Data +
2 | TD - | Transmit Data -
3 | RD + | Receive Data +
4 | - | reserviert
5 | - | reserviert
6 | RD - | ReceiveData -
7 | - | reserviert
8 | - | reserviert

Hinweis: Es gibt keine genormte Farbbelegung der Kabel!


Feldbus Box - Ethernet-Steckverbinder: M12

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Ethernet-Steckverbinder: M12

Der Ethernet-Anschluss erfolgt über eine d-codierte M12-Buchse (IP67).


Ethernet

Ethernet wurde ursprünglich von DEC, Intel und Xerox (als DIX-Standard) für die Datenübertragung zwischen Bürogeräten entwickelt. Heute versteht man darunter meist die Spezifikation IEEE 802.3 CSMA/CD, die 1985 veröffentlicht wurde. Diese Technologie ist durch ihren weltweiten Einsatz und die hohen Stückzahlen überall erhältlich und sehr preiswert.. Eine Anbindung an vorhandene Netze kann so problemlos realisiert werden.

Mittlerweile gibt es die verschiedensten Übertragungsmedien: Koaxialkabel (10Base5), Lichtwellenleiter (10BaseF) oder verdrillte Zweidrahtleitung (10BaseT) mit Schirmung (STP) oder ohne Schirmung (UTP). Mit Ethernet lassen sich verschieden Topologien aufbauen wie Ring, Linie oder Stern.

Ethernet transportiert Ethernet-Pakete von einem Sender zu einem oder mehreren Empfängern. Diese Übertragung verläuft ohne Quittung und ohne Wiederholung von verlorenen Paketen. Für die sichere Daten-Kommunikation stehen Protokolle wie TCP/IP zu Verfügung, die auf Ethernet aufsetzen.

MAC-ID

Sender und Empfänger von Ethernet-Paketen werden über die MAC-ID adressiert. Die MAC-ID ist ein 6 Byte großer Identifikations-Code, der eineindeutig, d.h. für jedes Ethernet-Gerät weltweit unterschiedlich ist. Die MAC-ID besteht aus zwei Teilen. Der erste Teil (d.h. die ersten 3 Byte) ist eine Herstellerkennung. Die Firma Beckhoff hat die Kennung 00 01 05. Die nächsten 3 Byte werden durch den Hersteller vergeben und entsprechen einer eindeutigen Seriennummer. Die MAC-ID kann zum Beispiel beim BootP-Protokoll zum Einstellen der TCP/IP-Nummer verwendet werden. Dafür wird ein Telegramm zum entsprechenden Knoten geschickt, das die Informationen wie Name oder TCP/IP-Nummer beinhaltet. Sie können die MAC-ID mit der Konfigurationssoftware KS2000 auslesen.

Internet-Protokoll (IP)

Die Grundlage der Datenkommunikation ist das Internet-Protokoll (IP). IP transportiert Datenpakete von einem Teilnehmer zu einem anderen, der sich im gleichen oder in einem anderen Netz befinden kann. IP kümmert sich dabei um das Adress-Management (Finden und Zuordnen der MAC-IDs), die Segmentierung und die Pfadsuche (Routing). Wie das Ethernet-Protokoll gewährleistet auch IP keinen gesicherten Transport der Daten; Datenpakete können verloren gehen oder in ihrer Reihenfolge vertauscht werden.

Für einen standardisierten, gesicherten Informationsaustausch zwischen beliebig vielen verschiedenen Netzwerken wurde TCP/IP entwickelt. Dabei ist TCP/IP weitgehend unabhängig von der verwendeten Hard- und Software. Oftmals als ein Begriff verwendet, handelt es sich hierbei um mehrere aufeinander aufgesetzte Protokolle: z.B. IP, TCP, UDP, ARP und ICMP.

Transmission Control Protocol (TCP)

Das auf IP aufsetzende Transmission Control Protocol (TCP) ist ein verbindungsorientiertes Transport-Protokoll. Es umfasst Fehlererkennungs- und Behandlungsmechanismen. Verlorengegangene Telegramme werden wiederholt.

User Datagram Protocol (UDP)

UDP ist ein verbindungsloses Transport-Protokoll. Es gibt keine Kontrollmechanismen beim Datenaustausch zwischen Sender und Empfänger. Dadurch resultiert eine schneller Verarbeitungsgeschwindigkeit als zum Beispiel bei TCP. Eine Prüfung ob das Telegramm angekommen ist muss vom übergeordneten Protokoll durchgeführt werden.

Auf TCP/IP und UDP/IP aufsetzende Protokolle

Auf TCP/IP bzw. UDP können folgende Protokolle aufsetzen:

  • ADS
  • ModbusTCP

Beide Protokolle sind parallel auf dem Buskoppler implementiert, so dass für die Aktivierung der Protokolle keine Konfiguration nötig ist.

ADS setzt wahlweise auf TCP oder UDP auf, während ModbusTCP stets auf TCP/IP basiert.


Topologie

Mit 10BaseT und 100BaseT werden mehrere Stationen im Ethernet-Standard sternförmig verbunden.

Stern-Topologie

Ein Stern-LAN besteht in der einfachsten Netzform aus einzelnen Punkt-zu-Punkt-Verbindungen. Alle Nachrichten laufen über einen zentralen Knoten (Hub oder Switch), der je nach Zieladresse die Informationen an den gewünschten Empfänger weitergibt.

Baum-Topologie

Eine Baum Topologie besteht aus mehreren verbundenen Stern-Topologien. Sobald mehrere Hubs oder Switches im Netz vorhanden sind, ist eine Baumtopologie vorhanden. Ideal ist es, die Verbindungen zwischen den Sternkopplern besonders breitbandig auszuführen, da diese den meisten Datenverkehr transportieren. Beim Aufbau von Baum-Topologien ist die Repeater-Regel zu beachten, die auch als 5-4-3-Repeater-Regel bezeichnet wird. Maximal zwei Repeater-Paare (bzw. Hub-Paare) dürfen im Übertragungsweg zwischen zwei beliebigen Stationen sein, sofern sie nicht durch Bridges, Switches oder Router getrennt sind. Ein Übertragungsweg kann aus maximal fünf Segmenten und vier Repeater-Sets (zwei Repeater-Paaren) bestehen. Dabei können bis zu drei Segmente Koax-Segmente sein, an denen die Stationen angeschlossen sind, die restlichen Segmente müssen Punkt-zu-Punkt-Verbindungen sein, die auch als IRL-Verbindung (Inter Repeater Link) bezeichnet werden.

Verkabelungsrichtlinien

Allgemeine Richtlinien für den Netzwerkaufbau eines LAN gibt die Strukturierte Verkabelung vor. Darin sind maximal zulässige Kabellängen für die Gelände-, Gebäude- und Etagenverkabelung festgelegt. In den Standards EN 50173, ISO 11801 und TIA 568-A normiert, bildet die Strukturierte Verkabelung die Grundlage für eine zukunftsweisende, anwendungsunabhängige und wirtschaftliche Netzwerk-Infrastruktur. Die Verkabelungsstandards definieren einen Geltungsbereich mit einer geographischen Ausdehnung von bis zu 3 km und für eine Bürofläche von bis zu 1 Mio. Quadratmeter mit 50 bis 50.000 Endgeräten. Darüber beschreiben sie Empfehlungen für den Aufbau eines Verkabelungssystems. Abhängig von der gewählten Topologie, den unter Industriebedingungen eingesetzten Übertragungsmedien und Koppelmodulen sowie von dem Einsatz von Komponenten verschiedener Hersteller in einem Netz können sich abweichende Angaben ergeben. Die Angaben verstehen sich hier deshalb lediglich als Empfehlungen.


Ethernet-Kabel

Übertragungsstandards

10Base5

Das Übertragungsmedium für 10Base5 ist ein dickes Koaxialkabel (Yellow Cable) mit einer max. Übertragungsgeschwindigkeit von 10 MBaud und einer Linien-Topologie mit Abzweigen (Drops), an die jeweils ein Teilnehmer angeschlossen wird. Da hier alle Teilnehmer an einem gemeinsamen Übertragungsmedium angeschlossen sind, kommt es bei 10Base5 zwangsläufig häufig zu Kollisionen.

10Base2

10Base2 (Cheaper net) ist eine Weiterentwicklung von 10Base5 und hat den Vorteil dass dieses Koaxialkabel billiger und durch eine höhere Flexibilität einfacher zu verlegen ist. Es können mehrere Geräte an eine 10Base2-Leitung angeschlossen werden. Häufig werden die Abzweige eines 10Base5-Backbones als 10Base2 ausgeführt.

10BaseT

Beschreibt ein Twisted-Pair-Kabel für 10 MBaud. Hierbei wird das Netz sternförmig aufgebaut, so dass nun nicht mehr jeder Teilnehmer am gleichem Medium hängt. Dadurch führt ein Kabelbruch nicht mehr zum Ausfall des gesamten Netzes. Durch den Einsatz von Switches als Sternkoppler können Kollisionen vermindert oder bei Voll-Duplex Verbindungen auch vollständig vermieden werden.

100BaseT

Twisted-Pair-Kabel für 100 MBaud. Für die höhere Datengeschwindigkeit ist eine bessere Kabelqualität und die Verwendung entsprechender Hubs oder Switches erforderlich.

10BaseF

Der Standard 10BaseF beschreibt mehrere Lichtwellenleiter-Varianten.

Kurzbezeichnung der Kabeltypen für 10BaseT und 100BaseT

Twisted-Pair Kupferkabel für sternförmige Topologie, wobei der Abstand zwischen zwei Geräten 100 Meter nicht überschreiten darf.

UTP

Unshielded Twisted-Pair (nicht abgeschirmte, verdrillte Leitung)
Dieser Kabeltyp gehört zur Kategorie 3 und sind für industrielle Umgebungen nicht empfehlenswert.

S/UTP

Screened/Unshielded Twisted-Pair (mit Kupfergeflecht abgeschirmte, verdrillte Leitung)
Besitzen einen Gesamtschirm aus einem Kupfergeflecht zur Reduktion der äußeren Störeinflüsse. Dieses Kabel wird zum Einsatz mit dem Buskopplern empfohlen.

FTP

Foilesshielded Twisted-Pair (mit Alufolie abgeschirmte, verdrillte Leitung)
Dieses Kabel hat eine alukaschierten Kunststoff-Folie-Gesamtschirm.

S/FTP

Screened/Foilesshielded Twisted-Pair (mit Kupfergeflecht und Alufolie abgeschirmte, verdrillte Leitung)
Besitzt einen alukaschierten Gesamtschirm mit einem darüber liegenden Kupfergeflecht. Solche Kabel können eine Störleistungsunterdrückung bis zu 70dB erreichen.

STP

Shielded Twisted-Pair (abgeschirmte, verdrillte Leitung)
Beschreibt ein Kabel mit Gesamtschirm ohne weitere Angabe der Art der Schirmung.

S/STP

Screened/Shielded Twisted-Pair (einzeln abgeschirmte, verdrillte Leitung)
Ein solche Bezeichnung kennzeichnet ein Kabel mit einer Abschirmung für jedes Leitungspaar sowie einen Gesamtschirm.

ITP

Industrial Twisted-Pair
Ist von Aufbau dem S/STP ähnlich, besitzt allerdings im Gegensatz zum S/STP nur 2 Leitungspaare.


ADS-Kommunikation

Das ADS-Protokoll (ADS: Automation Device Specification) ist eine Transportschicht innerhalb des TwinCAT Systems. Es ist für den Datenaustausch der verschiedenen Software-Module entwickelt worden, zum Beispiel für die Kommunikation zwischen der NC und der PLC. Mit diesem Protokoll haben Sie die Freiheit von jedem Punkt im TwinCAT mit anderen Tools kommunizieren zu können. Wird die Kommunikation zu anderen PCs oder Geräten benötigt, setzt das ADS-Protokoll auf TCP/IP auf. Somit ist es in einem vernetzten System möglich, alle Daten von einem beliebigen Punkt aus zu erreichen.

Das ADS-Protokoll wird auf das TCP/IP- oder UDP/IP-Protokoll aufgesetzt. Es ermöglicht dem Benutzer innerhalb des Beckhoff-Systems über nahezu beliebige Verbindungswege mit allen angeschlossenen Geräten zu kommunizieren und diese zu parametrieren. Außerhalb des Beckhoff-Systems stehen verschiedene Wege offen, um mit anderen Software-Tools Daten auszutauschen.

Software-Schnittstellen

ADS-OCX

Das ADS-OCX ist eine Active-X-Komponente und bietet eine Standardschnittstelle zum Beispiel zu Visual Basic, Delphi, u.s.w.

ADS-DLL

Sie können die ADS-DLL (DLL: Dynamic Link Library) in Ihr C-Programm einbinden.

OPC

Die OPC-Schnittstelle ist eine genormte Standardschnittstelle für die Kommunikation in der Automatisierungstechnik. Beckhoff bietet hierfür einen OPC-Server an.


ADS-Protokoll

Die ADS-Funktionen bieten die Möglichkeit, direkt vom PC auf Informationen des Buskopplers zuzugreifen. Dafür können ADS-Funktionsbausteine im TwinCAT PLC Control verwendet werden. Die Funktionsbausteine sind in der Bibliothek TcSystem.lib enthalten. Genauso ist es möglich, die ADS-Funktionen von AdsOCX, ADSDLL oder OPC aufzurufen. Über die ADS-Portnummer 300 sind alle Daten und über die ADS-Portnummer 100 Zugriffe auf die Register des Buskopplers und der Klemmen möglich.

AMSNetID

Die AMSNetID beschreibt das anzusprechende Gerät. Diese wird aus der eingestellten TCP/IP-Adresse und zusätzlichen 2 Byte erstellt. Diese zusätzlichen 2 Byte bestehen aus "1.1" und sind nicht veränderbar.
Beispiel:
IP-Adresse 172.16.17.128
AMSNetID 172.16.17.128.1.1

Port-Nummer

Die Portnummer unterscheidet im angeschlossenen Gerät Unterelemente.
Port 100: Registerzugriff
Port 300: Prozessdaten Feldbus
Port 800: lokale Prozessdaten (nur BC90x0, C900)

Index Group

Die Index Group unterscheidet innerhalb eines Ports verschiedene Daten.

Index Offset

Gibt den Offset an, ab welchem Byte gelesen oder geschrieben werden soll.

Len

Gibt die Länge der Daten in Byte an, die gelesen bzw. geschrieben werden sollen.

TCP-Port-Nummer

Die TCP-Port-Nummer beträgt für das ADS-Protokoll 48898 oder 0xBF02.


ADS-Dienste

Hinweis Die Nutzdaten eines ADS-Telegramm betragen maximal 1900 Byte.

Prozessdaten-Port 300

Der Zugriff auf die Feldbusdaten erfolgt über die ADS-Portnummer 300. Diese Daten werden von einem Watchdog überwacht. Sollte innerhalb von 1000 ms kein weiteres Telegramm eintreffen, werden die Ausgänge in den sicheren Zustand geschaltet.

Index Group | Bedeutung | Index Offset (Wertebereich)
0xF020 | Input - Eingänge | 0...511
0xF030 | Output - Ausgänge | 0...511

Lokales Prozessabbild Port 800 (nur BC9000, C900)

Im lokalen Prozessabbild können Daten gelesen und geschrieben werden. Sollten Ausgänge geschrieben werden, muss darauf geachtet werden, dass diese von der lokalen SPS nicht verwendet werden, da die lokale Steuerung diese Werte überschreibt. Die Daten sind nicht an einen Watchdog gebunden und dürfen daher nicht für Ausgänge verwendet werden, die im Fehlerfall ausgeschaltet werden müssen.

Index Group | Bedeutung | Index Offset (Wertebereich)
0xF020 | Input - Eingänge | 0...511
0xF030 | Output - Ausgänge | 0...511
0x4020 | Merker (nur BC9000, C900) | 0...4096

Dienste des ADS

AdsServerAdsStateB7
Datentyp (read only) | Bedeutung
String | Start - die lokale PLC läuft Stop - die lokale PLC ist im Stop
AdsServerDeviceStateB7
Datentyp (read only) | Bedeutung
INT | 0 - Start - die lokale PLC läuft 1 - Stop - die lokale PLC ist im Stop
AdsServerTypeB7
Datentyp (read only) | Bedeutung
String | Coupler_PLC
ADSWriteControlBA
Datentyp (write only) | Bedeutung
NetID | Net ID des BC9000, C900
Port | 800
ADSSTATE | 5 - RUN / 6 - STOP
DEVSTATE | 0
LEN | 0
SRCADDR | 0
WRITE | positive Flanke startet den Baustein
TMOUT | zum Beispiel: t#1000ms
Hinweis Bei der azyklischen Datenkommunikation muss man beachten, dass ein TCP/IP-Verbindungsaufbau ca. 20 - 30 ms benötigt. Nach erfolgreichen Verbindungsaufbau werden die ADS Daten gesendet oder gelesen. Ein ADS Read von 1000 Byte dauert ca. 50 ms. Werden 10 sec lang keine Daten übertragen, wird die TCP/IP Verbindung vom BC/BK9000, B/C900 getrennt.

Register Port 100

Die ADS-Portnummer ist beim BK/BC9000, B/C900 für die Register-Kommunikation fest vorgegeben und beträgt 100.

Index Group | Index Offset (Wertebereich) |  | Bedeutung
 | Hi-Word | Lo-Word
0 | 0...127 | 0...255 | Register des Buskopplers Hi-Word Tabellennummer des Buskopplers Lo-Word Registernummer der Tabelle
1...64 | 0...3 | 1...64 | Register der Busklemmen Hi-Word Kanalnummer Lo-Word Registernummer der Busklemme
Hinweis Beachten Sie beim Lesen der Register, dass der Time-Out beim ADS-Baustein auf eine Zeit größer 1 sec eingestellt wird.
Hinweis Beachten Se beim Schreiben auf die Register, dass das Passwort gesetzt wird (siehe Dokumentation zur entsprechenden Busklemme).

Zugriffskontrolle und IP - AMS-Net-ID ZuordnungB6

Die Tabelle AMS Net-Id ermöglicht über AMS eine Zugriffskontrolle auf den BC9000, C900. Sobald Einträge in dieser Tabelle vorhanden sind, können nur noch die eingetragenen AMS-Teilnehmer auf den BC9000 zugreifen.
Des weiteren wird hier explizit eine Zuordnung der AMS Net ID zur IP-Adresse des Knotens gemacht.
Die Tabelle AMS Net-Id kann mit ADS Write Kommandos gefüllt werden:
Es sind maximal 10 Einträge möglich.

Aufbau der Struktur
AMS Net ID | Größe
AMS Net ID | 6 Byte
IP-Adresse | 4 Byte
Reserve | 2 Byte
Reserve | 4 Byte
Reserve | 4 Byte

Zugriff erfolgt überPortnummer: 10.000

Indexgroup: 700

Index Offset (Write) | Bemerkung | Daten
0 | Hinzufügen eines Eintrags | Datenstruktur 20 Byte
1 | Löschen eines Eintrags | -
2 | Löschen aller Einträge | -
10 | Speichern der Tabelle im Flash | -

Index Offset (Read) | Bemerkung | Daten
0 | Anzahl der Einträge | 2 Byte
1..10 | Eintrag n (1...10) | Datenstruktur 20 Byte
Hinweis Der erste Eintrag muss der Teilnehmer sein der in die Tabelle schreibt, da diese Einstellungen sofort gültig sind. Achten Sie darauf das die Einstellungen alle Richtig sind. Die Tabelle kann ebenfalls gelöscht werden wenn nur die Endklemme gesteckt ist und die DIP-Schalter 1 bis 7 auf ON gesetzt sind.

* ab Firmware B6
** ab Firmware B7
)² ab Firmware BA

Siehe Beispiel


AMS-Routing-Tabelle

Mit der AMS-Routing-Tabelle kann man zwei Funktionen nutzen:

  1. Sollte die AMS Net ID nicht der TCP/IP-Adresse entsprechen, kann man die Verknüpfung zwischen den beiden ungleichen Nummern hier eintragen.
    Die AMS Net ID ist gleich der TCP/IP Adresse wenn die ersten 4 Byte gleich sind und die AMS Net ID mit ".1.1" endet.
  2. Nur die AMS Net IDs, die in der Tabelle hinterlegt sind, können per ADS auf den BC9000 zugreifen.

Achten Sie darauf, dass alle ADS-Teilnehmer mit denen Sie kommunizieren wollen auch in der Tabelle eingetragen sind. Ist kein Eintrag in der Tabelle (Default) sind alle ADS Teilnehmer berechtigt auf den BC9000 zuzugreifen.

KS2000-Dialog

Ab KS2000-Version 4.3.0.39 kann der Eintrag in die AMS-Routing-Tabelle, per Dialog vorgenommen werden.

Per ADS die Routing-Tabelle füllen

Die AMS-Routing-Tabelle kann per ADS in den BC9000 geladen werden. Achten Sie hierbei darauf, dass der erste Eintrag der des Senders ist, da diese Einstellung sofort Gültigkeit hat und ein weiteres beschreiben der AMS-Routing-Tabelle sonst nicht mehr möglich wäre.

Beispielprogramm in ST:


ADS-Prozessabbild

Das Prozessabbild ist in Eingangs- und Ausgangsabbild unterteilt. Die Koppler Box mappt erst alle komplexen (byteorientierten) Erweiterungs-Boxen (IE3xxx, IE4xxx, IE5xxx, IE6xxx), in der Reihenfolge wie diese im IP-Link angeordnet sind, in das Prozessabbild. Anschließend werden alle digitalen Erweiterungs-Boxen (IE1xxx, IE2xxx) an das Prozessabbild angehängt.

Die komplexen (byteorientierten) Erweiterungen werden immer mit folgenden Einstellungen übernommen:

  • Komplette Auswertung
  • Wort-Alignment
  • Intel-Format
Beispiel 1:

IL2301-B900 (4DI, 4DO)
2 x IE1001 (8DI)
2 x IE2002 (8DO)
1 x IE3312 (4 AI)
1 x IE4132 (4AO)

Position | Modul | Input %I..Byte Offset | Output %Q..Byte Offset
1 | IE3312 | 0...7 | 0..7
2 | IE4132 | 8...15 | 8...15
3 | IL2301 | 16.0...16.3 | 16.0...16.3
5 | IE1001 | 16.4...17.3 | -
6 | IE2002 | - | 16.4...17.3

Hinweis Eine genaue Beschreibung des Mappings der einzelnen Feldbus Box Module entnehmen Sie bitte der Dokumentation Signalvarianten, Installation, Konfiguration der E/A-Module, die Sie auf der BECKHOFF CD Products & Solutions oder im Internet (http://www.beckhoff.de) unter Download/Feldbus Box finden.


Real-Time-Ethernet mit Fast-ADS

Das Fast-ADS Protokoll ist ein auf Ethernet basierendes Protokoll. In Verbindung mit TwinCAT ist dieses Bussystem Echtzeitfähig und erreicht Zykluszeiten < 1ms. Der Echtzeit-Ethernet-Treiber wurde für Windows 2000, Windows XP und Intel Ethernet-Chips entwickelt.

Weitere Infos finden Sie unter http://www.pc-control.net/pdf/022002/pcc_ethernet_d.pdf.

BK9000

Auf dem BK9000 ist ab der Firmware-Version B8 das Fast-ADS Protokoll zusätzlich zu den bereits bestehenden Protokollen implementiert. Eine gleichzeitige Nutzung ist nur dann möglich, wenn im System Manager die Funktion ADS angewählt wurde (Karteireiten IP Address). Falls die Funktion NoRealTimeFlag nicht angewählt ist, kann nur über Fast ADS kommuniziert werden.

Der Watchdog ist bei Fast-ADS auf 100 ms eingestellt. Falls er auslöst (z.B. wenn TwinCAT stoppt), sind auch alle anderen Ethernet Dienste wieder nutzbar. Der K-Bus arbeitet synchron zum Fast-ADS.

B900

RT-Ethernet bzw. Fast-ADS ist auf allen B900-Modulen implementiert. Die Zykluszeit der TwinCAT-Task muss kleiner als 10 ms sein. Nach 10 ms wird ansonsten das Prozessabbild und damit die Ausgänge des Moduls und der angeschlossenen Erweiterungen zurückgesetzt.

Einstellungen im System Manager

BK9000 tab

No Real Time Flag

Bei gesetztem Haken können auch TCP/IP oder UDP Telegramme empfangen werden. Der Jitter der Real-Time-Telegramme nimmt aber zu!

K-Bus Reset

Es wird auf dem K-Bus ein Reset ausgelöst.

Data Exchange

Hier bestimmt, nach wie vielen Task-Zyklen ein Telegramm zur Feldbus-Station (Bus Koppler / Feldbus Box) geschickt werden soll.
Modulo gibt an, in welcher Task das Telegramm abgeschickt werden soll. Dies ermöglich es, die Systemleistung zu optimieren.

Beispiel: Divider 5 und Modulo 3 - nach jeder 5ten Task (und zwar die Dritte) wird ein Telegramm verschickt.

VLAN
Switches die VLAN (virtuelle LANs) unterstützen, können hiermit die einkommenden Telegramme priorisieren.

Karteireiter IP-Adresse

Host Name

Hier kann der Name der Feldbus-Station (Bus Koppler / Feldbus Box) editiert werden.

IP Address

Hier muss die IP-Adresse des Feldbus-Station (Bus Koppler / Feldbus Box) eingetragen werden.

GetHostByName

Mit dieser Schaltfläche kann (BK9000: ab Firmware-Version B2), eine IP-Adresse von einem DHCP-Server (Dynamic Host Configuration Protocol Server), bezogen werden.

Set IP Address

Mit dieser Schaltfläche wird die IP-Adresse über ARP eingestellt.

AMS Address

Gibt die AMS-Net ID der Feldbus-Station (Bus Koppler / Feldbus Box) an. Sie wird automatisch generiert, indem zwei zusätzlichen Byte-Werte (".1.1") zur IP-Adresse hinzugefügt werden.

BootP

Diese Checkbox ist aktivierbar, falls der Beckhoff BootP-Server installiert und gestartet ist (ab TwinCAT Version 2.8).

New MAC Addresses

Bei gestartetem Beckhoff BootP-Server, können durch Betätigung dieser Schaltfläche die neuen MAC-Adressen (Media Access Controller Adressen) angezeigt werden.
Die neuen Adressen werden dem Feld unter der Schaltfläche angezeigt.

Falls nur eine neue Feldbus-Station angeschlossen wurde, wird dementsprechend auch nur eine neue MAC-Adresse angezeigt.
Dieser MAC-Adresse kann dann im oben beschriebenem Feld IP Address eine gewünschte IP-Adresse, zugewiesen werden.

Bei Anschluss weiterer Feldbus Stationen, können Sie diesen Vorgang auf den Karteireitern IP Address dieser Stationen wiederholen.

Communication Settings

Einstellungen zur Kommunikation über ADS oder RAW.


ModbusTCP-Protokoll

Das Ethernet-Protokoll wird über die MAC-ID adressiert. Der Anwender braucht sich meist um diese Adresse nicht zu kümmern. Die IP-Nummer ist 4 Byte groß und muss vom Anwender auf dem Buskoppler und in der Anwendung parametriert werden. Die TCP-Port ist bei ModbusTCP auf 502 festgelegt. Die UNIT ist bei ModbusTCP frei wählbar und braucht vom Anwender nicht konfiguriert werden.

TCP-Port-Nummer

Die TCP-Port-Nummer von ModbusTCP wurde auf den Wert 502 standardisiert.

Modbus-Unit

Die Unit wird vom Slave zurückgegeben.

ModbusTCP-Protokoll

Byte | Name | Beschreibung
0 | Transaction identifier | wird vom Slave zurückgesendet
1 | Transaction identifier | wird vom Slave zurückgesendet
2 | Protocol identifier | immer 0
3 | Protocol identifier | immer 0
4 | Length field | 0 (wenn die Nachricht kleiner 256 Byte ist)
5 | Length field | Anzahl der folgenden Bytes
6 | UNIT identtifier | wird vom Slave zurückgegeben
7 | Modbus | es folgt das Modbus-Protokoll beginnend mit der Funktion


ModbusTCP-Interface

BECKHOFF Feldbuskomponenten: ModbusTCP

Modbus TCP-Interface

Adresse |  | Beschreibung
0x0000 0x00FF |  | Prozessdaten-Inferface Eingänge
0x0800 0x08FF |  | Prozessdaten-Inferface Ausgänge
0x1000 0x1006 | Read only | Buskopplerkennung
0x100A |  | 2 Byte SPS-Interface
0x100B |  | Busklemmendiagnose
0x100C |  | Buskoppler Status
0x1010 |  | Prozessabbildlänge in Bit, analoge Ausgänge (ohne SPS Variablen)
0x1011 |  | Prozessabbildlänge in Bit, analoge Eingänge (ohne SPS Variablen)
0x1012 |  | Prozessabbildlänge in Bit, digitale Ausgänge
0x1013 |  | Prozessabbildlänge in Bit, digitale Eingänge
0x1020 |  | Watchdog, aktuelle Zeit in [ms]
0x110A | Read/Write | 2 Byte SPS Interface
0x110B |  | Busklemmendiagnose
0x1120 |  | Watchdog vordefinierte Zeit in [ms] (Default: 1000)
0x1121 |  | Watchdog Reset Register
0x1122 |  | Art des Watchdogs | 1 | Telegramm Watchdog (Default)
 |  |  | 0 | Schreibtelegramm Watchdog
0x1123** |  | ModbusTCP Mode** | 1 | Fast Modbus
 |  |  | 0 | Normal Modbus (Default)
0x4000* 0x47FF |  | Merkerbereich (%MB..)*

* alle Busklemmen Controller BC9xx0 und BX9000
** für BC9x00 ab Firmware B7 und BK9000 ab Firmware B5 und alle nicht aufgeführten BK9xxx und BC/BX9xxx

Watchdog

Der Watchdog ist im Auslieferungszustand aktiviert. Nach dem ersten Schreibtelegramm wird der Watchdog scharf geschaltet und bei jedem empfangenden Telegramm dieses Teilnehmers getriggert. Andere Teilnehmer haben auf den Watchdog keinen Einfluss. Eine zweite Möglichkeit, die eine schärfere Bedingung des Watchdogs darstellt, ist, dass der Watchdog nur nach jedem Schreibtelegramm getriggert wird. Dafür Schreiben Sie in das Register 0x1122 eine Null (Default "1").
Der Watchdog kann deaktiviert werden in dem im Offset 0x1120 eine Null geschrieben wird. Das Watchdog Register darf nur dann beschrieben werden, wenn der Watchdog noch nicht aktiv ist. Die Daten in diesem Register bleiben gespeichert.

Watchdog-Register

Sollte der Watchdog auf Ihren Slave abgelaufen sein können sie diesen durch ein zweimaliges beschreiben des Registers 0x1121 zurücksetzen. Dazu muss folgendes in das Register geschrieben werden: 0xBECF 0xAFFE. Dies kann mit der Funktion 6 oder der Funktion 16 geschehen.

Statusregister des Buskopplers

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | FB | - | - | - | - | - | - | - | - | - | - | - | - | - | CNF | KB
Legende
Bit | Name | Wert | Beschreibung
15 | FB | 1bin | Feldbusfehler, Watchdog abgelaufen
14...2 | - | - | reserviert
1 | CNF | 1bin | Buskoppler Konfigurationsfehler
0 | KB | 1bin | Busklemmenfehler

ModbusTCP Mode

Der Fast Modbus Mode sollte nur in kleinen lokalen Netzwerken eingesetzt werden. In der Default Einstellung ist der Fast ModbusTCP nicht aktiviert. Werden Probleme mit dieser Kommunikationsart festgestellt, ist der Buskoppler auf die "normale" ModbusTCP Kommunikation umzustellen. Per Modbus Interface Offset 0x1123 ist dieser Mode einzustellen. Nach der Änderung ist ein Reset (zum Beispiel mit der ModbusTCP Funktion 8) des Buskopplers notwendig. Im Fast Modbus Mode ist es nicht gestattet, mehr als ein Modbus Dienst in einem Ethernet Frame zu versenden.

2 Byte SPS-Interface

Mit dem 2 Byte SPS-Interface können Register der komplexen Klemmen sowie Register des Busklemmen-Controllers gelesen bzw. beschrieben werden. Die Register der komplexen Klemmen sind in der Dokumentation zur jeweiligen Klemme beschreiben.Über die Register des Buskopplers können z.B. K-Busdiagnosedaten, der Klemmenaufbau oder Zykluszeiten gelesen sowie die programmierte Konfiguration beschrieben werden. Weiterhin kann darüber auch ein manueller K-Bus-Reset durchgeführt werden. Das 2 Byte SPS-Interface benötigt je zwei Bytes in den Ein- und Ausgangsdaten, über die ein spezielles Protokoll abgewickelt wird. Eine Beschreibung des 2 Byte SPS-Interface, der verfügbaren Register im Buskopplers sowie Funktionsbausteine für verschiedene SPS-Systeme, die das 2 Byte SPS-Interface unterstützen, kann auf Anfrage geliefert werden.

2 Byte Diagnose-Interface

Die Fehlermeldungen der Klemmen können mit dem 2 Byte Diagnose-Interface gesendet werden. Dazu ist aber die K-Busdiagnose zu aktivieren. Das 2 Byte Diagnose-Interface belegt je zwei Bytes in den Ein- und Ausgangsdaten, über die ein spezielles Protokoll durchgeführt wird. Eine Beschreibung des 2 Byte Diagnose-Interfaces kann auf Anfrage geliefert werden.


ModbusTCP-Fehlerantwort

BECKHOFF Feldbuskomponenten: ModbusTCP

Fehlerantwort des ModbusTCP Slaves (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)

Wenn der Anwender dem Slave eine Anforderung oder Mitteilung sendet, die der Koppler nicht versteht, antwortet der Slave mit einer Fehlermitteilung. Diese Antwort enthält die Funktion und den Fehler-Code. Der Funktionsrückgabewert wird mit 0x80 addiert.

Code | Name | Bedeutung
1 | ILLEGAL FUNKTION | Nicht implementierte Modbus-Funktion
2 | ILLEGAL DATA ADDRESS | Ungültige Adresse oder Länge
3 | ILLEGAL DATA VALUE | Ungültige Parameter - Diagnose-Funktionen - falsches Register
4 | SLAVE DEVICE ERROR | Watchdog- oder K-Bus-Fehler EK9000: E-Bus Fehler
6 | SLAVE DEVICE BUSY | Es wird schon von einem anderen IP-Teilnehmer Ausgangs-Daten empfangen


ModbusTCP Prozessabbild

Das Prozessabbild des ModbusTCP unterscheidet grundsätzlich digitale (Bit) und byteorientierte (wortorientierte) Zugriff auf die Signale (Module). Zusätzlich wird nach Ein- und Ausgängen unterschieden. Welche Module zu welchem Mapping gehören kann anhand der Mapping Tabelle entnommen werden.

Bei einem Wort-orientiertem Zugriff werden zunächst die analogen Module und dann die digitalen Module im Adressbereich aufgelistet.

Bitweiser Zugriff
Digitale Eingänge | Digitale Ausgänge
Offset 0 ... 4095 Modbus Funktion Lesen 2 Schreiben: - | Offset 0 ... 4095 Modbus Funktion Lesen 1 Schreiben 5, 15
Wortweiser Zugriff
Analoge/digitale Eingänge | Analoge/digitale Ausgänge
Offset 0x000 ... 0x0FF Modbus Funktion Lesen 3, 4, 23 Schreiben: - | Offset 0x800 ... 0x8FF Modbus Funktion Lesen 3, 23 Schreiben 6, 16, 23

Anhand eines Beispielen soll dies verdeutlicht werden.

Beispiel

IL2301-B900 (Bemerkung: Die IL2301-B900 besitzt 4 Ein- und 4 Ausgänge auf dem Modul)
1 x IE1001
1 x IE2001

Eingänge |  |  | Ausgänge
Modbus-Funktion | Modbus Adresse/Offset | Feldbus Box Modul | Modbus-Funktion | Modbus Adresse/Offset | Feldbus Box Modul
3 lesen | 0x0000 | 4 Bit IL2301 8 Bit IE1001 | 3 lesen | 0x0800 | 4 Bit IL2301 8 Bit IE2001
4 lesen | 0x0000 |  | 1 lesen | 0x0000
2 lesen | 0x0000 - 0x0001 |  | 5 schreiben | 0x0000-0x000B
 |  |  | 15 schreiben | 0x0000-0x000B
 |  |  | 6 schreiben | 0x800
 |  |  | 16 schreiben | 0x800
 |  |  | 23 schreiben | 0x800


ModbusTCP-Funktionen

Die Funktionen entscheiden beim Modbus-Protokoll, ob Daten gelesen oder geschrieben werden und um welche Art von Daten es sich dabei handelt.

Funktion | Code | Beschreibung
Read coil status | 1 | Lesen digitaler Ausgänge
Read input status | 2 | Lesen digitaler Eingänge
Read holding register | 3 | Lesen analoger Aus- und Eingänge / GPR
Read input register | 4 | Lesen der Eingänge / GPR
Force single coil | 5 | Schreiben eines digitalen Ausgangs
Preset single register | 6 | Schreiben eines Ausgangs / GPR
Diagnose | 8 | Diagnose
Force multiple coils | 15 | Schreiben mehrere digitaler Ausgänge
Preset multiple register | 16 | Schreiben mehrerer Ausgänge / GPRs
Read / write registers | 23 | Schreiben und lesen mehrerer Prozessdaten Ausgänge / GPRs

GPR (General Preset Register) - Registerstruktur Modbus Interface (siehe Anhang)


Read coil status (Funktion 1)

Mit der Funktion Read coil status können die gesetzten, digitalen Ausgänge gelesen werden.

In diesem Beispiel werden die ersten 10 digitalen Ausgänge gelesen. Die Start-Adresse ist Null. Im Feld Start-Adresse können Sie einen Offset eintragen.

Anfrage (Query)

Byte Name | Beispiel
Funktions-Code | 1
Start-Adresse high | 0
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 10

Der Feldbus-Koppler antwortet mit dem Byte Count 2, d.h. 2 Byte Daten kommen zurück. Die Anfrage war 10 Bits, die jetzt auf 2 Byte aufgeteilt werden. Im Ausgangsprozessabbild ist das dritte Bit gesetzt und der Feldbus-Koppler gibt im ersten Datenbyte eine den Wert 4 wieder.

Antwort (Response)

Byte Name | Beispiel
Funktions-Code | 1
Byte Count | 2
Daten-Bit 0...7 | 4
Daten-Bit 8...18 | 0


Read input status (Funktion 2)

Mit der Funktion Read input status können die digitalen Eingangsdaten gelesen werden. In diesem Beispiel werden die ersten 10 digitale Eingänge gelesen. Die Start-Adresse ist Null. Im Feld Start-Adresse können Sie einen Offset eintragen.

Anfrage (Query)

Byte Name | Beispiel
Funktions-Code | 2
Start-Adresse high | 0
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 10

Der Feldbus-Koppler antwortet mit dem Byte Count 2, d.h. es kommen zwei Byte Daten zurück. Die Anfrage war 10 Bits, die jetzt auf zwei Byte aufgeteilt werden. Im Ausgangsprozessabbild ist das dritte Bit gesetzt und der Feldbus-Koppler gibt im ersten Datenbyte eine den Wert 4 wieder.

Antwort (Response)

Byte Name | Beispiel
Funktions-Code | 2
Byte Count | 2
Daten-Bits 0..7 | 1
Daten-Bits 8..18 | 0


Read holding register (Funktion 3)

Mit der Funktion Read holding register können die Ein- und Ausgangsworte und die Register gelesen werden. Eingänge ab dem Offset 0 - 0xFF und Ausgänge ab den Offset 0x800 - 0x8FF und bei den Steuerungen (BC, BX) der Merkerbereich ab den Offset 0x4000.

In diesem Beispiel werden die ersten zwei analogen Ausgänge (oder 2 Ausgangsworte) gelesen. Die analogen Ausgänge (oder Ausgangsworte) beginnen beim Offset 0x800. Die Länge bezeichnet die Anzahl, der zu lesenden Kanäle (oder der zu lesenden Worte).

Anfrage (Query)

Byte Name | Beispiel
Funktions-Code | 3
Start-Adresse high | 8
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 2

Der Feldbus-Koppler antwortet mit dem Byte Count 4, d.h. es kommen 4 Byte Daten zurück. Die Anfrage waren zwei Analogkanäle, die auf zwei Worte aufgeteilt sind. Im analogen Ausgangsprozessabbild hat der erste Kanal einen Wert von 0x3FFF und der zweite Kanal einen Wert von 0x0.

Antwort (Response)

Byte Name | Beispiel
Funktions-Code | 3
Byte Count | 4
Daten 1 High-Byte | 63
Daten 1 Low-Byte | 255
Daten 2 High-Byte | 0
Daten 2 Low-Byte | 0


Read input register (Funktion 4)

Die Funktion Read input register liest wort-orientiert die Eingänge aus.

In diesem Beispiel werden die ersten zwei analogen Eingänge (oder die erste 2 Eingangsworte) gelesen. Die analogen Eingänge (oder Eingangsworte) beginnen bei einem Offset von 0x0000. Die Länge bezeichnet die Anzahl der zu lesenden Worte. Eine KL3002 z.B. hat zwei Worte Eingangsdaten, daher ist die einzugebende Länge bei Anzahl low zwei.

Anfrage (Query)

Byte Name | Beispiel
Funktions-Code | 4
Start-Adresse high | 0
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 2

Der Feldbus-Koppler antwortet mit dem Byte Count 4, d.h. es kommen vier Byte Daten zurück. Die Anfrage waren zwei analog Kanäle, die jetzt auf zwei Worte aufgeteilt werden. Im analogen Eingangsprozessabbild hat der erste Kanal einen Wert von 0x0038 und der zweite Kanal einen Wert von 0x3F1B.

Antwort (Response)

Byte Name | Beispiel
Funktions-Code | 4
Byte Count | 4
Daten 1 High-Byte | 0
Daten 1 Low-Byte | 56
Daten 2 High-Byte | 63
Daten 2 Low-Byte | 11


Force single coil (Funktion 5)

Mir der Funktion Force single coil kann ein digitaler Ausgang beschrieben werden. In diesem Beispiel wird der dritte digitale Ausgang beschrieben. Die digitalen Ausgänge beginnen bei Adresse 0x0000. Im Daten high steht der digitale Wert. Um den Ausgang einzuschalten muss im Daten high der Wert 0xFF stehen und um den Ausgang wieder auszuschalten der Wert 0x00. Im Daten low muss der Wert 0x00 stehen.

Anfrage (Query)

Byte Name | Beispiel
Funktions-Code | 5
Start-Adresse high | 0
Start-Adresse low | 2
Daten high | 255
Daten low | 0

Der Koppler antwortet mit dem gleichen Telegramm.

Antwort (Response)

Byte Name | Beispiel
Funktions-Code | 5
Start-Adresse high | 0
Start-Adresse low | 2
Daten high | 255
Daten low | 0


Preset single register (Funktion 6)

Mit der Funktion Preset single register kann auf das Ausgangs- oder Merkerprozessabbild (nur bei den Steuerungen) und das Modbus-TCP-Interface zugegriffen werden.

Bei der Funktion 6 wird das erste Ausgangswort beschrieben. Die Ausgänge beginnen bei einem Offset von 0x0800. Auch hier beschreibt der Offset immer ein Wort. Das heißt, dass der Offset 0x0803, das 4. Wort auf dem Ausgangsprozessabbild ist.

Anfrage (Query)

Byte Name | Beispiel
Funktions-Code | 6
Start-Adresse high | 8
Start-Adresse low | 0
Daten high | 63
Daten low | 255

Der Feldbus-Koppler antwortet mit dem gleichen Telegramm und der Bestätigung der empfangenen Werte.

Antwort (Response)

Byte Name | Beispiel
Funktions-Code | 6
Start-Adresse high | 8
Start-Adresse low | 0
Daten high | 63
Daten low | 255


Diagnose (Funktion 8)

Die Funktion Diagnose stellt eine Reihe von Tests, für die Überprüfung des Übertragungssystems zwischen dem Master und dem Slave oder für die Überprüfung der verschiedenen internen Fehlerzustände innerhalb des Slaves zur Verfügung. Ein Broadcast-Telegramm wird nicht unterstützt.

Die Funktion benutzt in der Anfrage zwei Byte, um mit einem Unterfunktions-Code die Art des durchzuführenden Tests zu definieren. Der Slave gibt in der Antwort den Funktions-Code und den Unterfunktions-Code zurück.

Die Diagnose-Anfragen benutzen ein Datenfeld von zwei Byte, um Diagnosedaten oder Steuerinformationen zum Slave zu schicken.

Anfrage (Query)

Byte Name | Beispiel
Funktions-Code | 8
Unterfunktion high | 0
Unterfunktion low | 0
Data high | 2
Data low | 3

Antwort (Response)

Byte Name | Beispiel
Funktions-Code | 8
Unterfunktion high | 0
Unterfunktion low | 0
Data high | 2
Data low | 3

Spiegeln einer Anforderung (Unterfunktion 0)

Mit der Unterfunktion 0 werden die Daten, die der Master zum Slave schickt, wieder zurückgeschickt.

Koppler Reset (Unterfunktion 1)

Der Koppler wird mit der Unterfunktion 1 neu initialisiert, Fehlerzähler werden zurückgesetzt und der Controller führt einen Selbsttest durch. In der Zeit, in der der Controller zurückgesetzt wird, werden keine Telegramme empfangen oder gesendet. Der IP-Socket wird geschlossen.

Hinweis Bevor der Controller neu startet schickt er noch eine Antwort mit der Unterfunktion 1 dann wird der IP-Socket geschlossen.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0001 | 0x0000 | 0x0000

Löschen aller Zählerinhalte (Unterfunktion 10)

Beim Aufruf dieser Unterfunktion löscht der Controller alle Fehler Zähler.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x000A | 0x0000 | Echo Query Daten

Buskommunikation Antwort Zähler (Unterfunktion 11)

Gibt die Anzahl der Kommunikationsantworten an.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x000B | 0x0000 | Wert des Zählers

Fehlerantwort Zähler (Unterfunktion 13)

Dieser Zähler gibt die Anzahl der Fehlerantworttelegramme, die der Koppler gesendet hat, an.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x000D | 0x0000 | Wert des Zählers

Die folgenden Funktionen beinhalten die Zählerstände für verschiedene Units. D.h. die Modbus-Telegramme können mit Units unterschieden werden, wenn es sich zum Beispiel um einen Zugriff auf den Koppler von verschiedenen Mastern aus handelt.

Antworten des Slaves (Unterfunktion 14)

Gibt die Anzahl der gesendeten Antworten des Slaves an.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x000E | 0x0000 | Wert des Zählers

Anzahl der nicht geantworteten Telegramme (Unterfunktion 15)

Gibt die Anzahl der nicht gesendeten Antworten des Slaves an.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x000F | 0x0000 | Wert des Zählers

Anzahl der Fehlerantworten (Unterfunktion 16)

Gibt die Anzahl der gesendeten Fehlerantworten des Slaves an.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0010 | 0x0000 | Wert des Zählers


Force multiple coils (Funktion 15)

Bei der Funktion Force multiple coils können gleichzeitig mehrere digitale Ausgänge gesetzt oder zurückgesetzt werden.

In diesem Beispiel werden die ersten 20 digitalen Ausgänge beschrieben. Die digitalen Ausgänge beginnen bei einem Offset von 0x0000. Hier beschreibt der Offset immer ein Bit. Der Offset 0x0003 schreibt ab dem vierten Bit auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Bits an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.

Beispiel: 20 Bits belegen 3 Byte Count (auf Byte-Grenzen aufrunden).

Die Daten-Bytes enthalten die Werte für die einzelnen Bits. In diesem Beispiel werden die Bit 0 bis 15 auf TRUE gesetzt und Bit 16 bis 23 auf FALSE.

Anfrage (Query)

Byte Name | Beispiel
Funktions-Code | 15
Start-Adresse high | 0
Start-Adresse low | 0
Länge high | 0
Länge low | 20
Byte Count | 3
Daten 1 Bit 0..7 | 255
Daten 2 Bit 8..15 | 255
Daten 3 Bit 16..23 | 0

Antwort (Response)

Der Buskoppler antwortet mit dem gleichen Telegramm.

Byte Name | Beispiel
Funktions-Code | 15
Start-Adresse high | 0
Start-Adresse low | 0
Länge high | 0
Länge low | 20


Preset multiple register (Funktion 16)

Mit der Funktion Preset multiple register können mehrere Ausgänge beschrieben werden. In diesem Beispiel werden die ersten zwei analogen Ausgangsworte beschrieben. Die Ausgänge beginnen bei einem Offset von 0x0800. Hier beschreibt der Offset immer ein Wort. Der Offset 0x0003 schreibt ab dem vierten Wort auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Worte an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.

Beispiel: 4 Worte - entsprechen 8 Byte Count

Die Datenbytes enthalten die Werte für die analogen Ausgänge. In diesem Beispiel sind es zwei Worte, die zu beschreiben sind. Das erste Wort mit dem Wert 0x7FFF und das zweite Wort mit dem Wert 0x3FFF.

Anfrage (Query)

Byte Name | Beispiel
Funktions-Code | 16
Start-Adresse high | 8
Start-Adresse low | 0
Länge high | 0
Länge low | 2
Byte Count | 4
Daten 1 Byte 1 | 127
Daten 1 Byte 2 | 255
Daten 2 Byte 1 | 63
Daten 2 Byte 2 | 255

Antwort (Response)

Der Koppler antwortet mit der Start-Adresse und der Länge der gesendeten Worte.

Byte Name | Beispiel
Funktions-Code | 16
Start-Adresse high | 8
Start-Adresse low | 0
Länge high | 0
Länge low | 2


Read or write registers (Funktion 23)

BECKHOFF Feldbuskomponenten: ModbusTCP

Read / write registers (Funktion 23)

Mit der Funktion Read / write registers können mehrere analoge Ausgänge beschrieben und in einem Telegramm mehrere analoge Eingänge gelesen werden. In diesem Beispiel werden die ersten zwei analogen Ausgangsworte beschrieben und die ersten zwei analogen Eingänge gelesen. Die analogen Ausgänge beginnen beim Offset 0x0800 und die Eingänge ab dem Offset 0x0000. Hier beschreibt der Offset immer ein Wort. Der Offset 0x0003 schreibt ab dem 4. Wort auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Worte an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen. Beispiel: 4 Worte - entsprechen 8 Byte Count

Die Datenbytes enthalten die Werte für die analogen Ausgänge. In diesem Beispiel sind es zwei Worte, die zu beschreiben sind. Das erste Wort mit dem Wert 0x3FFF und das zweite Wort mit dem Wert 0x7FFF.

Anfrage (Query)

Byte Name | Beispiel
Funktions-Code | 23
Lesen Start-Adresse high | 0
Lesen Start-Adresse low | 0
Lesen Länge high | 0
Lesen Länge low | 2
Schreiben Start-Adresse high | 8
Schreiben Start-Adresse low | 0
Schreiben Länge high | 0
Schreiben Länge low | 2
Byte Count | 4
Daten 1 high | 63
Daten 1 low | 255
Daten 2 high | 127
Daten 2 low | 255

Antwort (Response)

Der Koppler antwortet mit der Start-Adresse und der Länge der übertragenen Bytes im Byte Count. Es folgen die Dateninformationen. In diesem Beispiel steht im ersten Wort eine 0x0038 und im zweiten Wort eine 0x3F0B.

Byte Name | Beispiel
Funktions-Code | 23
Byte Count | 4
Daten 1 high | 0
Daten 1 low | 56
Daten 2 high | 63
Daten 2 low | 11


Beispiele zu ModbusTCP

In dieser Hilfe sind Beispiele zu ModbusTCP enthalten.

Einfaches Beispiel: ModbusTCP über VB6.0
Extract ModbusTCP.zip

Beispiel: ModbusTCP über VB6.0, Set und Reset des Watchdogs:
Extract BK9000Modbus.zip


Hinweis zur Parametrierung

Hinweis

Einstellungen und Parameteränderungen z.B. der MAC-ID, die mittels der Konfigurations-Software KS2000 gemacht werden, werden zunächst nur im flüchtigen Speicher der Feldbus Box (RAM) hinterlegt.

Dann muss ein Software-Reset durchgeführt werden, der die die Daten in den Flash-Speicher kopiert, und damit dauerhaft speichert.

Ein Kalt-Start (Power-ON/OFF) reicht nicht aus, es muss ein Software-Reset sein!


Anlaufverhalten der Feldbus Box

Nach dem Einschalten prüft die Feldbus Box ihren Zustand, konfiguriert (wenn vorhanden) den IP-Link ist und erstellt anhand der Erweiterungsmodule eine Aufbauliste. Wenn die Feldbus Box eine dezentrale Steuerung besitzt (IL230x-C310) wird nach einer erfolgreichen Aufbauliste die lokale SPS gestartet.
Beim Hochlauf des Moduls leuchten und blinken die E/A LEDs. Im fehlerfreien Zustand sollte nach ca. 2-3 sec keine E/A LED mehr Blinken. Sollte ein Fehler vorliegen, hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose LEDs).

Start_List.gif (8211 Byte)


Parametrierung über Dreh-Kodier-Schalter

Die folgenden Parametrierungen können Sie ohne Konfigurationssoftware mit Hilfe der Dreh-Kodier-Schalter vornehmen.

Hex Schalter x10 | Hex Schalter x1 | Bedeutung
0x0 - D | 0x0 - F | IP Adresse direkt über Schalter
0xF | 0x0 | IP Adresse über DHCP-Server
0xF | 0x1 | IP Adresse über BootP-Server
0xF | 0x2 | BootP save Address
Hex Schalter x10 | Hex Schalter x1 | Bedeutung (Power ON/OFF)
0xF | 0x3 | Fast ModbusTCP aktiv
0xF | 0x4 | Fast ModbusTCP deaktiv
0xF | 0x5 | reserviert
0xF | 0x6 | reserviert
0xF | 0x7 | reserviert
0xF | 0x8 | reserviert
0xF | 0x9 | reserviert
0xF | 0xA | reserviert
0xF | 0xB | reserviert
0xF | 0xC | AMS NetID Tabelle löschen
0xF | 0xD | Feldbus-spezifische Default Werte setzen
0xF | 0xE | Bootprojekt löschen (nur bei IL230x-C900)
0xF | 0xF | Modul auf Hersteller-Einstellungen zurücksetzen
Wiederherstellen der Hersteller-Einstellungen
  • Schalten Sie das Modul aus.
  • Stellen Sie die Dreh-Kodier-Schalter auf 0xF und schalten Sie das Modul wieder ein.
  • Nach erfolgreichem Einstellen der Default-Parameter blinken die die LEDs I/O RUN und I/O ERR gleichzeitig.
  • Danach können Sie das Modul wieder ausschalten um die IP-Adresse einzustellen.
Löschen des Bootprojektes (nur bei Controller-Box)
  • Schalten Sie das Modul aus.
  • Stellen Sie die Dreh-Kodier-Schalter auf 0xFE und schalten Sie das Modul wieder ein.
  • Nach erfolgreichem Löschen des Bootprojektes blinken die LEDs I/O RUN und I/O ERR gleichförmig.
  • Danach können Sie das Modul wieder ausschalten um die IP-Adresse einzustellen.
Einstellung der Ethernet-Parameter
  • Schalten Sie das Modul aus .
  • Stellen Sie die Dreh-Kodier-Schalter auf 0xFD und schalten Sie das Modul wieder ein.
  • Die LEDs I/O RUN und I/O ERR blinken.
  • Es werden wieder die Default-Werte der Tabelle 100 eingestellt.
  • Danach können Sie das Modul wieder ausschalten um die IP-Adresse einzustellen.


Registereinstellungen Tabelle 100

Die Register können mit der Konfigurationssoftware KS2000 per Dialog eingestellt werden oder es ist auch möglich direkt in die Register zu schreiben.

Register | Beschreibung |  | Default
0-1 | IP-Adresse |  | 0xAC, 0x10, 0x12, 0x00
2-3 | IP-Maske |  | 0xFF, 0xFF, 0x00, 0x00
4-13 | Gerätemame |  | IL-B900 (ASCII codiert)
14 | Watchdog AMS/ADS |  | 1000 ms
15.0 | 0bin | enable ModbusTCP | 0bin
 | 1bin | disable ModbusTCP
15.1 | 0bin | enable AMS/ADS | 0bin
 | 1bin | disable AMS/ADS
16.8 | 0bin | Ethernet Modus halbduplex | 1bin
 | 1bin | Ethernet Modus vollduplex
16.12 | 0bin | Autobaud aus | 1bin
 | 1bin | Autobaud ein
16.13 | 0bin | 10 MBaud | 1bin
 | 1bin | 100 MBaud
17-18 | Default Gateway |  | 0x00, 0x00, 0x00, 0x00
24 | Watchdog ModbusTCP |  | 1000 ms
26 | ModbusTCP Port Nr |  | 502
27 | Lebensdauer ADS-Verbindung |  | 10 s
28 | Lebensdauer Modbus-Verbindung |  | 10 s
29.0 | ModbusTCP Mode |  | 0bin
 | 1bin | Fast ModbusTCP

Beispielansicht KS2000 für IP Adresse 172.16.200.xxx


FBB-B900 - IP-Adresse

BECKHOFF Feldbus Box: Adressieung

IP-Adresse

Die Einstellung der IP-Adresse kann mit vier unterschiedlichen Verfahren durchgeführt werden, die im Folgenden genauer beschrieben werden.

Verfahren | Erläuterung | Benötigte Komponenten
KS2000 | Adressierung über die Dreh-Codier-Schalter | Schraubendreher
ARP | Adressierung über die ARP-Tabelle | PC mit Netzwerk
BootP | Adressierung über BootP-Server | BootP-Server
DHCP | Adressierung über DHCP-Server | DHCP-Server

Hex Schalter x10 | Hex Schalter x1 | Bedeutung
0x0 - D | 0x0 - F | IP Adresse direkt über Schalter
0xF | 0x0 | IP Adresse über DHCP-Server
0xF | 0x1 | IP Adresse über BootP-Server
0xF | 0x2 | BootP speichere Adresse
0xF | 0x3 | Fast ModbusTCP aktiviert
0xF | 0x4 | Fast ModbusTCP deaktiviert
0xF | 0x5 | reserviert
0xF | 0x6 | reserviert
0xF | 0x7 | reserviert
0xF | 0x8 | reserviert
0xF | 0x9 | reserviert
0xF | 0xA | reserviert
0xF | 0xB | reserviert
0xF | 0xC | AMS NetID Tabelle löschen
0xF | 0xD | feldbus-spezifische Default Werte setzen
0xF | 0xE | Bootprojekt löschen (nur bei IL230x-C900)
0xF | 0xF | Hersteller Einstellung


Adresseinstellung mit KS2000

BECKHOFF Feldbuskomponenten: Adressierung

Adresseinstellung mit Kodierschalter und KS2000

Die TCP/IP-Adresse kann unter anderem auch über die beiden hexadezimalen Adress-Kodier-Schalter eingestellt werden.

Dabei wird nur das letzte Byte geändert. Die anderen Werte werden direkt aus Tabelle 100 der Box gelesen. Sie können nur mit der Konfigurationssoftware KS2000 angepasst werden. Die Dreh-Codier-Schalter x10 muss vor dem Einschalten einen Wert ungleich 0xF aufweisen.

Zum Ändern der IP-Adresse ist ein Aufheben ("Reset Schreibschutz") des Schreibschutzes in der KS2000 erforderlich. Nach dem Ändern der Adresse ist ein Reset des Kopplers erforderlich ("Reset").

Tabelle 100

Register | High-Byte | Low-Byte
0 | IP-Byte 2 | IP-Byte 1
1 | Nicht benutzt | IP-Byte 3

Default

IP-Byte | Default-Wert (hex) | Default-Wert (dez)
1 | 0xAC | 172dez
2 | 0x10 | 16dez
3 | 0x12 | 18dez
4 | (Dreh-Codier-Schalter) | (0 bis 239dez)
Beispiel:

Schalter |  | x16 | x1
Wertigkeit |  | 16 | 1
Im Beispiel | Schalterstellung | Chex = 12dez | 4
 | Wert | 12dez x 16dez = 192dez | 4dez
 | IP-Adresse | 172.16.18.196


Adresseinstellung über ARP

BECKHOFF Feldbus Box: Adressieung

Einstellung der IP-Adresse über die ARP-Tabelle

Eine einfache Methode die IP-Adresse zu ändern ist die Adresseinstellung über das DOS-Fenster. Sie können so allerdings nur Adressen innerhalb der selben Netzwerkklasse ändern. Die neu eingestellte IP-Adresse bleibt auch beim Ausschalten des Moduls gespeichert.

Vorgehensweise:

  • Stellen Sie eine beliebige IP-Adresse ein. DHCP bzw. BootP dürfen nicht aktiviert sein.
  • Öffnen Sie auf Ihrem PC eine DOS-Eingabeaufforderung (DOS-Box).
  • Erzeugen Sie mit "ping >IP-Adresse ALT<" einen Eintrag in die ARP-Tabelle.
  • Lesen Sie mit "ARP-a" die Tabelle aus.
  • Löschen Sie mit "ARP-d >IP-Adresse ALT< das Modul aus der Tabelle.
  • Nehmen Sie mit "ARP -s >IP Adresse NEU< >MAC-ID<" einen manuellen Eintrag vor.
  • Mit "ping -l 123 >IP-Adresse NEU<" ist die neue IP-Adesse gültig

Kurzzeitiges blinken der ERROR LED im Einschaltaugenblick signalisiert, dass das Modul über ARP adressiert wurde und die Dreh-Kodier-Schalter keine Aussage über die eingestellte Adresse geben.

Hinweis Bei Änderung der IP-Adresse müssen alle dynamischen ARP-Einträge gelöscht werden. Es wird nur ein ping mit der Länge 123 Byte zur Umkonfiguration der IP-Adresse zugelassen (>ping -l 123 >IP-Adresse<).
Während des Vorgangs darf kein anderer Netzwerkzugriff mit/zu dem Koppler laufen, da sonst erneut Einträge in der ARP Tabelle vorgenommen würden.
Beispiel
  1. C:>ping 172.16.17.255
  2. C:>ARP -a
    172.16.17.255 00-01-05-00-11-22
  3. C:>arp -d 172.16.17.255
  4. C:>arp -s 172.16.44.44 00-01-05-00-11-22
  5. C:>ping -l 123 172.16.44.44


Adresseinstellung über den Beckhoff BootP-Server

Stellen Sie für die Adresseinstellung mit dem Beckhoff BootP-Server den Dreh-Kodier-Schalter auf 0xF1. Während der Adressvergabe blinkt die LED TCP/IP ERROR.

Speicherverhalten der IP-Adresse

Dreh-Kodier-Schalter in Stellung 0xF2

Die vom BootP-Server vergebene IP-Adresse wird gespeichert und der BootP-Service wird beim nächsten Kaltstart nicht gestartet.
Die Adresse kann durch Reaktivierung der Herstellereinstellungen (mittels Konfigurationssoftware KS2000 oder Dreh-Kodier-Schalter) wieder gelöscht werden.

Dreh-Kodier-Schalter in Stellung 0xF1

Die vom BootP-Server vergebene IP-Adresse ist nur bis zum Ausschalten des Moduls gültig. Beim nächsten Kaltstart muss der BootP-Server dem Modul eine neue IP-Adresse zuteilen.
Bei einem Software-Reset des Moduls bleibt die Adresse allerdings erhalten.

Beckhoff BootP-Server

Beckhoff bietet einen BootP-Server für Windows 98, ME, NT4.0, NT2000 und XP an.
Sie finden die Installationsversion auf der Beckhoff TwinCAT CD im Ordner Unsupported Utilities oder unter http://download.beckhoff.com/download/Software/TwinCAT/TwinCAT2/Unsupported Utilities/TcBootP_Server

BootP.jpg (39093 Byte)

Sobald der BootP-Server gestartet wird zeigt das Fenster New MAC Address alle Beckhoff-Knoten an, die im BootP-Betrieb arbeiten und noch keine IP-Adresse bekommen haben. Die Zuweisung MAC-ID zu IP-Adresse erfolgt mit dem Button "<<". Eine erfolgreiche Zuweisung wird im Log-Fenster angezeigt.
Um den BootP-Server beim Booten Ihres PCs automatisch zu starten reicht eine Verknüpfung im Autostart von Windows. Fügen Sie hierzu im Verknüpfungspfad den Parameter /Start an (.../TcBootPDlg.exe/start).


Adresseinstellung über DHCP-Server

BECKHOFF Feldbuskomponenten: Adressierung

Adresseinstellung über einen DHCP-Server

Stellen Sie für die Adresseinstellung über einen DHCP-Server die Dreh-Kodier-Schalter auf 0xF0. In diesem Zustand ist der DHCP-Dienst eingeschaltet und das Modul bekommt automatisch eine IP-Nummer vom DHCP-Server zugewiesen. Der DHCP-Server muss hierfür die MAC-ID des Moduls kennen. Die IP-Adresse sollte statisch eingestellt werden. Während der Adressvergabe blinkt die LED TCP/IP Error.


Ethernet - Netzwerkklassen

BECKHOFF Feldbuskomponenten: Ethernet

Netzwerkklassen

Man unterscheidet drei verschiedene Netzwerkklassen. Diese legen fest, wie viele Adress-Bits für die Netzwerk-ID und wie viele für die Knotennummer (z.B. für PCs oder Buskoppler) reserviert werden. Die Unterscheidung findet in den ersten drei Bits der IP-Adresse statt.

Netzwerk- klasse | Anzahl Bits für die Netzwerk-ID | Ermöglicht Anzahl Netzwerke | Anzahl Bits für die Knotenadresse | Ermöglicht Anzahl Knoten pro Netzwerk
A | 7 | 126 | 24 | 16 777 214
B | 14 | 16 382 | 16 | 65 536
C | 21 | 2 097 150 | 8 | 254

Achtung Eine IP-Adresse muss im gesamten verbundenen Netzwerk einmalig sein!

Hinweis Die eingestellte IP-Adresse muss bei einer Kommunikation mit einem anderen Ethernet-Teilnehmer die gleiche Netzwerkklasse besitzen. Beispiel: Ihr PC hat die Adresse 172.16.17.55, damit muss der Koppler die Adresse 172.16.xxx.xxx haben (die xxx stehen für eine Zahl von 0...255. Die 0 wird üblicherweise vom Router/Switch benutzt sollte dafür reserviert bleiben).

Um sich die Adresse des eigenen PCs anzusehen, kann man bei Windows NT/2000/XP im DOS-Fenster den Befehl ipconfig eingeben.


Subnetz-Maske

Die Subnetz-Maske unterliegt der Kontrolle des Netzwerkverwalters und legt die Struktur der Subnetze fest.

Kleine Netze ohne Router benötigen keine Subnetz-Maske. Das gleiche gilt, wenn Sie keine registrierten IP-Nummern verwenden. Sie können die Subnetz-Maske dazu verwenden, anstelle des Gebrauchs vieler Netznummern das Netz mit dieser Maske zu unterteilen.

Die Subnetz-Maske ist eine 32-Bit Ziffer:

  • Einsen in der Maske kennzeichnen den Subnetz-Nummernteil eines Adressraums.
  • Nullen kennzeichnen den Teil des Adressraums, der für die Host-IDs zur Verfügung steht.
Beschreibung | Binäre Darstellung | Dezimale Darstellung
IP-Adresse | 10101100.00010000.00010001.11001000 | 172.16.17.200
Subnetz-Maske | 11111111.11111111.00010100.00000000 | 255.255.20.0
Netz-ID | 10101100.00010000.00010000.00000000 | 172.16.16.0
Host-ID | 00000000.00000000.00000001.11001000 | 0.0.1.200

Standard Subnetz-Maske

Adressklasse | Standard Subnetz-Maske (dezimal) | Standard Subnetz-Maske (hex)
A | 255.0.0.0 | FF.00.00.00
B | 255.255.0.0 | FF.FF.00.00
C | 255.255.255.0 | FF.FF.FF.00

Hinweis Die Subnetze 0 und das nur aus nur Einsen bestehende Subnetz dürfen nicht verwendet werden!
Die Host-Nummer 0 und die aus nur Einsen bestehende Host-Nummer dürfen nicht verwendet werden!

Wenn die IP-Adresse über die Konfigurationssoftware KS2000 eingestellt wurde, muss auch die Subnetz-Maske mit der Konfigurationssoftware KS2000 geändert werden.
Bei ARP-Adressierung wird anhand der IP-Adresse die dazugehörige Standard Subnetz-Maske eingetragen.
Bei BootP und DHCP wird die Subnetz-Maske mit vom Server übertragen.


Test der IP-Adresse

Zum Testen der IP-Adresse können Sie das Kommando Ping benutzen.


Auslesen der MAC-ID

Gehen Sie folgendermaßen vor, um die MAC-ID auszulesen:

  • Ändern Sie die IP-Adresse Ihres PCs auf 172.16.x.x. und SubNetMask auf 255.255.0.0
    Die IP-Adresse der Ethernet Feldbusboxen ist im Auslieferungszustand 172.16.18.1 (Dreh-Kodier-Schalter: 0, 1)
  • Starten Sie die Eingabeaufforderung (DOS-Fenster)
  • Schicken Sie ein Ping >ip-address< auf die IP-Adresse 172.16.18.1
  • Lesen Sie die MAC-ID mit arp -a aus.


Konfiguration mit dem System Manager

Tragen Sie im TwinCAT System Manager unter Geräte eine allgemeine Ethernet Karte ein. Sollten die Buskoppler schon am Netzwerk angeschlossen sein und eine IP-Adresse besitzen, können Sie diese auch einlesen. Dabei werden automatisch alle Buskoppler mit Busklemmen und Konfiguration hochgeladen. Diese können Sie dann nach Ihren Bedürfnissen anpassen.

TCSysMgr_Bx9Scan.gif (20904 Byte)

Inbetriebnahme bei 6 oder mehr Ethernet-Knoten

Wenn Sie im System-Manager mehr als 5 Knoten eintragen, müssen Sie den Router-Speicher erhöhen. Diese Einstellung finden Sie im System-Manager unter Real Time Settings. Tragen Sie dort für jeden Buskoppler 350 kByte ein. Dies ergibt z.B. für 10 Buskoppler 3,5 MB (10 x 350 kByte).

Hinweis: Der Router-Speicher ist vom Arbeitsspeicher ihres PCs abhängig und darf nicht beliebig hoch gesetzt werden.
Berechnung des maximal zulässigen Router-Speichers:
Max Routerspeicher [MB] = (1 MB +((Arbeitsspeicher [MB] - 4 MB ) x 0,4)

Beispiel:
Ihr PC hat 128 MB Arbeitsspeicher:
1MB +(128MB - 4MB) x 0,4 = 50,6 MB
Die maximale Größe des Router-Speichers darf bei 128 MB Arbeitsspeicher 50,6 MB nicht überschreiten.


Karteireiter IP Address

Ethernet-Komponenten benötigen im Netzwerk eine eindeutige IP-Adresse. Nachfolgend ist der, für die Konfiguration des Feldbusknoten im TwinCAT-System notwendige, Einstelldialog beschrieben. Der gezeigte Karteireiter erscheint nachdem Sie im System-Manager unter Ihrer Ethernetkarte mit der rechten Maustaste (Box Anfügen) einen BK9000, BC9000 oder eines anderen Ethernet-Feldbusgerätes ausgewählt haben.

Hostname

Hier kann der Name der Buskopplerstation editiert werden.

IP-Address

Tragen Sie hier die IP-Adresse des Buskopplers ein.

GetHostByName

Durch Betätigung dieser Schaltfläche kann (ab BK9000 Firmware-Version B2) eine IP-Adresse von einem Windows 2000 DHCP (Dynamic Host Configuration Protocol) Server bezogen werden.

AMS Address

Gibt die AMS-Net ID des Buskopplers an. Sie wird automatisch durch hinzufügen von zwei zusätzlichen Bytes (z.B.: ".1.1") aus der IP-Adresse generiert.

BootP

Diese Checkbox ist aktivierbar, falls der Beckhoff BootP-Server installiert und gestartet ist (ab TwinCAT Version 2.8

New MAC Addresses

Bei gestartetem Beckhoff BootP-Server können durch Betätigung dieser Schaltfläche die MAC-Adressen (Media Access Controller) neu angeschalteter Ethernet-Feldbusgerät angezeigt werden. Falls nur ein neues Ethernet-Feldbusgerät angeschlossen ist, wird dementsprechend auch nur eine neue MAC-Adresse angezeigt, der Sie dann im oben beschriebenem Feld IP Address die gewünschte IP-Adresse zuweisen können. Bei Anschluss jeder weiteren Ethernet-Feldbuskomponenten, können Sie diesen Vorgang auf dem hier beschriebenen Karteireiter des neuen Geräts wiederholen.

Communication Settings

Einstellungen zur Kommunikation über IP (Internet Protocol).

TCP

Wenn diese Option aktiv ist (default), wird die Kommunikation über TCP (Transmission Control Protocol ) abgewickelt. Dies bedeutet, das die Telegrammpakete vom und zum Buskoppler über einen gesicherten (bestätigten) Mechanismus ausgetauscht werden.

UDP

Wenn diese Option ausgewählt wurde, wird die Kommunikation über UDP (User Datagram Protocol ) abgewickelt. Im Gegensatz zum TCP sind hierbei die einzelnen Telegrammpakete nicht gesichert, d.h., sie werden nicht jeweils nach Erhalt vom Empfänger bestätigt. Zerstörte oder in der Reihenfolge vertauschte Telegrammpakete werden nicht erneut gesendet oder sortiert. Der Vorteil des UDP besteht aus kalkulierbaren Telegrammlaufzeiten, da nicht erst auf eine Antwort vom Empfänger gewartet werden muss. Man kann daher bei UDP von einer bedingten Echtzeitfähigkeit reden.

Max. Warning Level

Diese Einstelloption ist nur bei UDP aktiv. Hier kann der maximale Wert des Fehlerzählers eingetragen werden. Bei Erreichen des eingestellten Maximalwertes wird nicht mehr auf ein Antworttelegramm des Feldbusknotens gewartet. Stattdessen werden nur noch Lesetelegramme, basierend auf einer höheren Zykluszeit, zum Feldbusknoten geschickt.

No Auto Retries

Diese Checkbox ist auch nur bei aktivierter Option UDP anwählbar. Bei Erreichen des eingestellten Wertes unter Max. Warning Level, ist bei aktivierter Checkbox ein Ausführen der Funktion IO / Reset notwendig. Solange kein Reset ausgelöst wurde, werden keine Ausgänge ausgegeben.


Allgemeine Registerbeschreibung

Bei den komplexen Modulen können verschiedene Betriebsarten bzw. Funktionalitäten eingestellt werden. Die Allgemeine Registerbeschreibung erläutert den Inhalt der Register, die bei allen komplexen Modulen identisch sind. Die modulspezifischen Register werden in dem darauffolgendem Kapitel erklärt.
Der Zugriff auf die internen Register der Module wird im Kapitel Register-Kommunikation beschrieben.

Allgemeine Registerbeschreibung

Komplexe Module die einen Prozessor besitzen, sind in der Lage mit der übergeordneten Steuerung bidirektional Daten auszutauschen. Diese Module werden im folgenden als intelligente Module bezeichnet. Zu ihnen zählen die analogen Eingänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), die analogen Ausgänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), serielle Schnittstellenmodule (RS485, RS232, TTY, Datenaustausch-Module), Zähler-Module, Encoder-Interface, SSI-Interface, PWM-Module und alle anderen parametrierbare Module.

Alle intelligenten Modulen besitzen intern eine in ihren wesentlichen Eigenschaften identisch aufgebaute Datenstruktur. Dieser Datenbereich ist wortweise organisiert und umfasst 64 Speicherplätze. Über diese Struktur sind die wesentlichen Daten und Parameter der Module les- und einstellbar. Zusätzlich sind Funktionsaufrufe mit entsprechenden Parametern möglich. Jeder logische Kanal einer intelligenten Module besitzt eine solche Struktur (4-Kanal analoge Module besitzen also 4 Registersätze).

Diese Struktur gliedert sich in folgende Bereiche:

Bereich | Adresse
Prozessvariablen | 0-7
Typ-Register | 8-15
Hersteller- Parameter | 16-30
Anwender- Parameter | 31-47
Erweiterter Anwenderbereich | 48-63

Register R0-R7 (im internen RAM des Moduls)

Die Prozessvariablen können ergänzend zum eigentlichen Prozessabbild genutzt werden und sind in ihrer Funktion Modulspezifisch.

R0-R5

Diese Register besitzen eine vom Modul-Typ abhängige Funktion.

R6

Diagnose-Register: Das Diagnose-Register kann zusätzliche Diagnose-Information enthalten. So werden z.B. bei seriellen Schnittstellenmodulen Paritäts-Fehler, die während der Datenübertragung aufgetreten sind, angezeigt.

R7

Kommandoregister

  • High-Byte_Write = Funktionsparameter
  • Low-Byte_Write = Funktionsnummer
  • High-Byte_Read = Funktionsergebnis
  • Low-Byte_ Read = Funktionsnummer

Register R8-R15 (im internen ROM des Moduls)

Die Typ- und Systemparameter sind fest vom Hersteller programmiert und können vom Anwender nur gelesen und nicht verändert werden.

R8

Feldbus Box Typ: Der Feldbus Box Typ in Register R8 wird zur Identifizierung der Feldbus Box benötigt.

R9

Softwareversion x.y.: Die Software-Version kann als ASCII-Zeichenfolge gelesen werden.

R10

Datenlänge: R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit. Der Buskoppler sieht diese Struktur.

R11

Signalkanäle: Im Vergleich zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z.B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.

R12

Minimale Datenlänge: Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control/Status-Byte für die Funktion des Moduls nicht zwingend notwendig, und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen. Die Information steht

  • bei einem Ausgangsmodul im High-Byte
  • bei einem Eingangsmodul im Low-Byte.
R13

Datentypregister

Datentypregister | Beschreibung
0x00 | Modul ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur 1 Byte n Bytes
0x03 | Word-Array
0x04 | Struktur 1 Byte n Worte
0x05 | Doppelwort-Array
0x06 | Struktur 1 Byte n Doppelworte
0x07 | Struktur 1 Byte 1 Wort
0x08 | Struktur 1 Byte 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur 1 Byte n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur 1 Byte n Worte mit variabler logischer Kanallänge
0x15 | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur 1 Byte n Doppelworte mit variabler logischer Kanallänge
R14

reserviert

R15

Alignment-Bits (RAM): Mit den Alignment-Bits wird das Analogmodul im Prozessabbild auf eine Bytegrenze gelegt.

Register R16-R30 (Hersteller-Parameter, serielles EEPROM)

Die Hersteller-Parameter werden vom Hersteller für jeden Modultyp modulspezifisch festgelegt, können jedoch mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Hersteller-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Hersteller-Parameter müssen Sie zuvor in Register R31 ein Code-Wort setzen.

Register R31-R47 (Anwendungs-Parameter, serielles EEPROM)

Die Anwender-Parameter sind Modulspezifisch. Sie können mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Anwender-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Anwender-Parameter müssen Sie zuvor in Register R31 das Anwender-Code-Wort setzen.

R31

Code-Wort-Register im RAM: Damit Parameter im Anwender-Bereich geändert werden können muss hier das Code-Wort 0x1235 eingetragen werden. Wird ein abweichender Wert in dieses Register eingetragen, so wird der Schreibschutz gesetzt. Bei inaktivem Schreibschutz wird das Code-Wort beim Lesen des Register zurückgegeben, ist der Schreibschutz aktiv enthält das Register den Wert Null.

R32

Feature-Register: Dieses Register legt die Betriebsarten der Klemme fest. So kann z.B. bei den analogen E/A-Modulen eine anwenderspezifische Skalierung aktiviert werden.

R33 bis R63

Klemmenspezifische Register: Diese Register sind vom Klemmentyp abhängig.

Register R47 bis R63 (Registererweiterung für zusätzliche Funktionen)

Diese Register sind für zusätzliche Funktionen vorgesehen.


Beispiel für Register-Kommunikation

Control-Byte

Das Control-Byte befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R/W | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Registerkommunikation eingeschaltet: Die ersten zwei Byte der Nutzdaten werden nicht für den Prozessdatenaustausch verwendet, sondern in den Registersatz der Feldbus Box geschrieben oder daraus gelesen.
6 | R/W | 0bin | Read: Das Register soll gelesen werden ohne es zu verändern.
 |  | 1bin | Write: Das Register soll beschrieben werden.
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll. Es sind 64 Register adressierbar.
Status-Byte

Das Status-Byte befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Quittung Registerzugriff
6 | R | 0bin | Read
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.

Beispiel 1

Lesen des Registers 8 von KL3204 oder IP/IE3202
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x88 (1000 1000bin) | 0xXX | 0xXX

Bit 0.7 gesetzt bedeutet Register-Kommunikation aktiv
Bit 0.6 nicht gesetzt bedeutet lesen des Registers.
Bit 0.5 bis Bit 0.0 geben mit 001000bin die Registernummer 8 an.
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim lesenden Zugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x88 | 0x0C | 0x84

Die Klemme/Box liefert im Eingangsdatenwort (Byte 1 und Byte 2) die Typ-Bezeichnung 0x0C84 (entspricht unsigned Integer 3204) zurück .

Besonderheit bei der Bezeichnung von Feldbus Boxen:
Die letzte Ziffer des zurückgegebenen unsigned Integer (3204) entspricht nicht der letzten Ziffer der Feldbus Box-Bezeichnung (3202), die für die Anschlussvariante (0 für S8, 1 für M8 und 2 für M12) steht. Sie gibt stattdessen die Anzahl der Kanäle wieder (IE3204 besitzt 4 Kanäle).

Hinweis Damit Register beschreiben werden können, müssen Sie zuvor das Codewort 0x1235 in Register 31 schreiben, um den Schreibschutz zu deaktivieren. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder.
Beachten Sie das einige Einstellungen in den Registern erst nach einem Neustart (Power-Off/Power-ON) des Moduls übernommen werden.

Beispiel 2

Ablauf einer Register-Kommunikation zum ändern eines Register.

1. Schreiben des Register 31 (Codewort setzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x12 | 0x35

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX
2. Lesen des Register 31 (gesetztes Codewort überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x9F | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0x12 | 0x35
3. Schreiben des Register 32 (Register ändern)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)e
0xE0 | 0x00 | 0x02

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0xXX | 0xXX
4. Lesen des Register 32 (geändertes Register überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xA0 | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0x00 | 0x02
5. Schreiben des Register 31 (Codewort zurücksetzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x00 | 0x00

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX


Diagnose-LEDs

Fehlerdiagnose

Es gibt 2 Arten von Fehlern:

  • Feldbus Fehler
  • Lokaler Fehler auf Kompakt Box oder Koppler Box

Blink-Codes

Blinkfolge | Bedeutung
Schnelles Blinken | Anfang des Blink-Codes
erste langsame Sequenz | Fehler-Code
zweite langsame Sequenz | Fehlerargument
dritte langsame Sequenz (optional) | Fehlerargument

Flasching_codes.jpg (2840 Byte)

Anfang Fehler-Code Fehlerargument


Diagnose-LEDs

Nach dem Einschalten überprüft das Modul sofort die angeschlossene Konfiguration. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED I/O ERR signalisiert. Das Blinken der LED I/O ERR zeigt einen Fehler im Bereich der Ein/Ausgänge an. Durch Frequenz und Anzahl des Blinkens kann der Fehler-Code ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Zur Statusanzeige besitzt das Modul zwei Gruppen von LEDs. Die obere Gruppe mit vier LEDs zeigt den Zustand des jeweiligen Feldbusses an. Die Bedeutung der Feldbus-Status-LEDs wird in den entsprechenden Kapiteln dieses Handbuches erläutert. Sie entspricht den feldbusüblichen Anzeigen.

Am unteren Ende des Moduls befinden sich zwei weitere grüne LEDs zur Anzeige der Versorgungsspannung. Die linke LED zeigt die 24 VDC Logik-Versorgung des Moduls an. Die rechte LED signalisiert die Versorgung der Ausgänge.

LEDs zur Feldbus-Diagnose

LED | Ein | Aus
LINK | Physikalische Verbindung vorhanden | Keine physikalische Verbindung vorhanden
ACTIV | Blinkt: Busverkehr vorhanden | kein Busverkehr vorhanden (bus idle)
ERROR | LED blinkt langsam, wenn DHCP oder BootP aktiviert und das Modul noch keine IP-Adresse bekommen hat LED blink schnell (5 mal, nur beim Einschalten) Das Modul wurde mit ARP adressiert. Die Einstellungen auf dem Dreh-Codier-Schalter sind nicht gültig. | Kein Fehler
 | LED wird eingeschaltet, wenn mehr als ein Ethernet-Frame innerhalb eines Zyklus angekommen. Das ältere Telegramm wird verworfen. |
WD | Aus - Watchdog abgelaufen oder nicht getriggert | - Kommunikation starten - Watchdog Fehler zurücksetzen
 | Ein - Watchdog wird getriggert | Kein Fehler

LEDs zur Diagnose der Spannungsversorgung

LED | Bedeutung
Linke LED aus | Modul hat keine Spannung
Linke LED rot | Kurzschlussüberwachung der Sensorversorgung (< 500mA) ist akiviert. Sensoren/Eingänge werden nicht mehr versorgt.
Rechte LED aus | Keine Spannungsversorgung 24 VDC für Ausgänge angeschlossen


Diagnose-LEDs für lokale Fehler

Lokale Fehler in einer Koppler Box (IL230x-Bxxx/Cxxx)

Unter den lokalen Fehlern ist gemeint, das ein Fehler in der Feldbus Box oder dem IP-Link aufgetreten ist. IP-Link-Fehler sind meist durch unsachgemäßen Gebrauch der Lichtwellenleitung zurück zu führen.

LED grün | LED rot |  |  | Beschreibung | Abhilfe
aus | aus |  |  | kein Datenaustausch | Modul im synchron Mode - zyklische Daten aktivieren
aus | 1 | 0 |  | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
aus | 2 |  |  | reserviert | -
aus | 3 | n |  | Bruchstelle wurde erkannt | n-tes Modul vor dem Empfänger des Masters
 | 3 | n | m | Bruchstelle wurde erkannt | (n*10)+m-tes Modul vor dem Empfänger des Masters
aus | 4 | n |  | zu viele fehlerhafte Telegramme erkannt (mehr als 25%) | vor dem n-ten Erweiterungsmodul (vor dem Empfänger des Masters) ist die LWL-Verkabelung zu prüfen
aus | 5 | n |  | Registerzugriff auf komplexe Module gescheitert | n-tes Modul überprüfen
aus | 11 | n |  | Komplexes Modul arbeitet fehlerhaft | n-tes Modul tauschen
aus | 12 | n |  | mehr als 120 Module im Ring | weniger Module anschließen
aus | 13 | n |  | n-tes Modul unbekannt | Firmware Update erforderlich
an | aus |  |  | Modul ist im Datenaustausch (kein Fehler) | -

Lokale Fehler in einer Erweiterungsbox

LED grün | LED rot | Beschreibung
aus | an | es werden kein Daten über den IP-Link empfangen
aus | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (sehr schlechte Datenverbindung)
blinkt, flackert | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (schlechte Datenverbindung), muss noch nicht zum Fehler führen
an | aus | es werden IP-Link Protokolle empfangen, kein Fehler

Fehlerhafte IP-Link Protokolle können entstehen durch:

  • schlecht konfektionierte IP-Link Steckverbinder
  • IP-Link Leitung mit erhöhter Dämpfung durch z.B. Knick o.ä.
  • defekte oder verschmutzte Sende LED (Modul vor dem fehlerhaften Modul)
  • defekter oder verschmutzter Empfänger

Der interne IP-Link-Fehlerzähler der Koppler Box kann mit der KS2000 Software ausgelesen werden.


Feldbus Box - Überprüfung der IP-Link-Verbindung

BECKHOFF Feldbus Box: Montage und Verkabelung

Überprüfung der IP-Link-Verbindung

Ein IP-Link-Kabel mit auf beiden Seiten korrekt konfektionierten IP-Link-Steckern garantiert eine fehlerfrei Übertragung.

Eine nachträgliche Prüfung der Übertragungsqualität und eine Fehlersuche ist mit der Konfigurationssoftware KS2000 möglich.

Hierzu sollte die Steuerung (z.B. ein PC mit Profibus-Karte) am Feldbus des Koppler Box angeschlossen sein und diese zyklisch mit Daten versorgen, oder die Koppler Box sollte mit der KS2000 auf freilaufend geschaltet werden.

Als Ergebnis sollte die I/O RUN LED auf dem Kopplermodul hellgrün leuchten. Dies zeigt, dass ein Datenaustausch mit den angeschlossenen Erweiterungsbox Modulen stattfindet. Eine rot flackernde I/O ERR LED zeigt fehlerhafte IP-Link-Telegramme an! Telegramme werden wie bei auch jedem Feldbussystem im Fehlerfall wiederholt, so dass eine Übertragung der Daten gewährleistet ist.

Fehlerzähler

In Tabelle 90, Offset 005 werden aufgetretene IP-Link-Fehler gezählt. Sporadisch auftretende Fehler bedeuten noch keine Probleme für die Kommunikation. Dieser Fehlerzähler wird nur durch ein Power ON/OFF zurückgesetzt.

Sollten in kurzer Zeit viel Fehler auftreten, wird eine schwere Störung diagnostiziert und das Koppler-Modul meldet diesen Fehler. Dies ist am Offset 006 oder 007 zu erkennen. Die beiden Werte stehen dann auf einem Wert > 200 und die I/O ERR LEDs des Koppler-Moduls blinken mit dem entsprechenden Fehler-Code.

Hinweis Die Konfigurations-Software KS2000 kommuniziert über einen seriellen Kanal mit der Koppler Box. Der Registerinhalt wird nicht andauernd aktualisiert, muss also manuell refreshed werden.

Fehlerort

Stellt das Koppler Modul einen Fehler fest, versucht es den Fehlerort aus dem Register der Erweiterungs-Box herauszulesen. Ist der Ring tatsächlich unterbrochen bzw. die Kommunikation stark gestört, ist dies nicht möglich. Dann wird nur der Ort des Bruchs dargestellt und zwar rückwärts vom Koppler gezählt (siehe IP-Link Fehlersuche).

Läuft die Kommunikation noch, kann in Tabelle 87 der Fehlerzähler je Erweiterungsmodul ausgelesen werden.

Hier bezieht sich der Offset auf die Position links im KS2000 Baum (siehe Grafik). d.h. in diesem Beispiel werden Fehler beim Offset 004 und 006 angezeigt.

Im IP-Link Aufbau ist der Fehler also bei der Übertragung zu Modul IE20xx und bei der Übertragung zu IE3112 zu suchen.

Der Fehler kann also liegen, an:

  • dem Sender-Modul
  • dem Empfänger-Modul
  • dem Kabel oder
  • den Steckern

Wird in Tabelle 90 ein Fehler angezeigt, aber in Tabelle 87 nicht, so ist die Fehlerursache in der Übertragungsstrecke zwischen dem letzten Erweiterungsmodul und dem Koppler zu suchen.

In fast allen Fällen sind Übertragungsfehler auf schlecht konfektionierte IP-Link-Stecker oder zu hohe Dämpfung im LWL-Kabel (durch scharfe Knicke o.ä.) zurückzuführen.

Tabelle 87 wird bei einer IP-Link-Unterbrechung nicht aktualisiert, da diese Werte direkt aus den Erweiterungs-Modulen kommen. Diese können dann über den IP-Link natürlich nicht mehr ausgelesen werden.

Hinweis Falls Sie eine Koppler-Box (z.B. IL2300-Bxxx, IL2301-Bxxx oder IL2302-Bxxx ) ganz ohne Erweiterungs-Box-Module (IExxxx) betreiben möchten, müssen Sie Sende- und Empfangs-Anschluss diese Koppler-Box über ein IP-Link-Kabel direkt miteinander verbinden! Hierfür eignet sich besonders der IP-Link-Verbindungsstecker ZK1020-0101-1000.


Allgemeine Fehler

Kein Datenaustausch nach Tausch eines Buskopplers

Sie haben den Ethernet Buskoppler getauscht und die gleiche TCP/IP-Nummer eingestellt, erhalten danach aber keinen Datenaustausch mehr.

Jedes Ethernet-Gerät hat seine eigene und eindeutige MAC-ID. Diese Nummer wird bei der Verbindung zum Ethernet-Knoten gespeichert und in einer Tabelle hinterlegt. Die Tabelle enthält die Zuordnung zwischen der MAC-ID und der TCP/IP-Nummer. Sie müssen diesen Speicher löschen und das können Sie tun indem Sie im DOS-Fenster den Befehl >arp -d< und die TCP/IP-Nummer des Buskopplers eingeben.
Beispiel: >arp -d 172.16.17.203<
Bei aktiviertem DHCP- oder BootP-Protokoll muss auf dem DHCP- oder BootP-Server nach dem Kopplerwechsel die MAC-ID des neuen Buskopplers eingestellt werden.

Kommunikationsfehler im Online-Zustand *

Im Online-Zustand (eingeloggt über Ethernet/AMS) kommt es nach einiger Zeit immer zu der Meldung Kommunikationsfehler, es wird ausgeloggt.

Der Datenverkehr über die Ethernet Schnittstelle stockt.

Abhilfe:

  • Verringern Sie die Daten-Kommunikation.
  • Halten Sie den zyklischen Datenverkehr an, oder vergrößern Sie die Task-Zeit.
  • Verringern Sie die Anzahl der offenen Fenster in der Online-Darstellung.
  • Loggen Sie sich über die serielle Schnittstelle ein.

* nur BC9000, C900


ADS-Diagnose

Statuseingänge

Im System-Manager hat man die Möglichkeit die Kommunikation der Buskoppler BK/BC9000, B/C900 zu kontrollieren. Jeder Buskoppler verfügt über Status-Eingänge, die man im Hardwarebaum findet.

Coupler State
Wert | Bedeutung
0x0000 | kein Fehler
0x0001 | Busklemmen-Fehler, es liegt ein K-Bus-Fehler vor
0x0002 | Konfigurationsfehler, die parametrierte Konfiguration passt nicht mit der tatsächlichen Konfiguration überein
MissedCnt

Ideale Konfiguration:
Die Task-Zeit ist immer größer als die Ethernet-Laufzeit. Am Anfang der Task wird ein Ethernet Telegramm weggeschickt und kommt nach einer Zeit tEth wieder am PC an. Ist die Zeit tEth immer kleiner als die eingestellte Task-Zeit bleibt der Zähler MissedCnt konstant.

Sollte ein Ethernet-Telegramm nach Ablauf der Task-Zeit noch nicht wieder beim PC angekommen sein und erst nach dem Start der nächsten Task eintreffen, so arbeitet TwinCAT mit den alten Eingangsdaten weiter. Zusätzlich wird der Zähler MissedCnt um eins erhöht.

Dies kann folgende Ursache haben:

  • Task-Zeit zu klein gewählt. Stellen Sie
    - bei TCP 100 ms oder größer ein
    - bei UDP 20 ms oder größer ein
  • Zu viele Kollisionen im Netzwerk: setzen Sie Switches anstelle von Hubs ein!
  • Die Bus-Auslastung ist zu hoch: wechseln Sie auf 100 MBaud!
  • Sie Sind beim BC9000, C900 eingeloggt: dieses belegt zusätzliche Prozessorleistung des Controllers, was die eine Antwortzeit verlängert.

Die beiden folgende Diagnoseeingänge habe je nach Übertagungsart unterschiedliche Bedeutung.

Diagnose TCP/IP

BoxState
Wert | Bedeutung
0x0000 | kein Fehler
0x0001 | keine aktuellen Eingänge
MissedCnt
Wert | Bedeutung
0xyyyy | Anzahl der Telegramm, die nicht rechtzeitig zum Task-Anfang wieder angekommen sind. Dieser Wert sollte nahezu konstant sein. Sollte der Wert ständig hochzählen so ist die Task-Zeit zu erhöhen.

Diagnose UDP/IP

BoxState
Wert | Bedeutung
0x0000 | kein Fehler
0x0001 | keine aktuellen Eingänge
0x0002 | Ausgänge werden zu Null geschrieben
0xxxzz | xx - Warning Level. Hierbei wird bei jeden nicht rechtzeitigem Empfang der Daten der Wert um eins erhöht. Bei einem Fehlerfreien Datenaustausch wird dieser Wert wieder um eins herunter gezählt. Beim erreichen der max. Warning Level (Default 100) werden die Ausgangsdaten zu Null geschrieben und werden erst wieder für das normale Prozessabbild freigegeben wenn der Warning Level auf Null ist.
MissedCnt
Wert | Bedeutung
0xyyyy | Anzahl der Telegramm, die nicht rechtzeitig zum Task-Anfang wieder angekommen sind. Dieser Wert sollte nahezu konstant sein. Sollte der Wert ständig hochzählen so ist die Task-Zeit zu erhöhen.


ModbusTCP-Diagnose

siehe Modbus Diagnose-Funktion

siehe Fehlerantworten ModbusTCP


Feldbus Box Zubehör

Das notwendige Zubehör für die Feldbus Box Module gibt es in Schutzklasse IP67 ebenfalls von Beckhoff. Eine Übersicht entnehmen Sie bitte aus dem Beckhoff Katalog oder unseren Internet-Seiten (http://www.beckhoff.de).

Feldbuszubehör

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Spannungsversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Sensorversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

IP-Link

  • Vorkonfektionierte Kabel
  • Stecker


Allgemeine Betriebsbedingungen

Schutzarten nach IP-Code

In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.

1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub

2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist

*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.

Chemische Beständigkeit

Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus Box und den verwendeten Metallteilen.

Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende

beständig: Lebensdauer mehrere Monate
bedingt beständig: Lebensdauer mehrere Wochen
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zulassungen

UL E172151

Konformitätskennzeichnung

CE

Schutzart

IP65/66/67 gemäß EN60529


Prüfnormen für die Geräteprüfung

EMV

Festigkeit: EN 61000-6-2

Aussendung: EN 61000-6-4

Vibrationsfestigkeit

Schwingungsprüfung: EN 60068-2-2, Amplitude 2 g (Norm 1 g)

Schockprüfung: EN 60068-2-27, Schockanzahl 1000 (Norm 2)


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Abkürzungsverzeichnis

ADS

Automation Device Specification

IP (20)

Schutzart der Busklemmen

IPC

Industrie-PC

E/A

Ein- und Ausgänge

K-Bus

Klemmen-Bus

KS2000

Konfigurationssoftware für Busklemmen, Bus Koppler, Busklemmen Controller, Feldbus Box Module usw.

PE

Der PE-Powerkontakt kann als Schutzerde verwendet werden.

TwinCAT

The Windows Control and Automation Technology


Literaturverzeichnis

TCP/IP

TCP/IP (deutsch)
Aufbau und Betrieb eines TCP/IP Netzes
von Kevin Washburn, Jim Evans
Verlag: ADDISON-WESLEY Longmann Verlag

TCP/IP (englisch)
Illustrated, Volume1 The Protocols
von W. Richard Stevens
Verlag: ADDISON-WESLEY Longmann Verlag

Modbus/TCP

http://www.modicon.com/
http://www.modbus.org

TwinCAT

BECKHOFF Information System
http://infosys.beckhoff.com


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.