FBB-x730 - Feldbus Box für Modbus

BECKHOFF Feldbuskomponenten

Dokumentation zur

Feldbus Box für Modbus

Version: 1.0.2
Datum: 30.10.2009


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Version | Änderungen
1.0.2
  • Systemübersicht aktualisiert
1.0.1
  • Prüfnormen für die Geräteprüfung aktualisiert
  • kleinere Routinekorrekturen (Tippfehler, Rechtschreibung usw.)
1.0
  • Modbus-spezifische Inhalte aktualisiert
  • Signalvarianten und Anschlussbelegung der Signale in die Feldbus-neutrale Dokumentation Signalvarianten (Feldbus Box E/A-Module) ausgelagert, die Sie im Internet unter http://www.beckhoff.de im Bereich Download finden.
  • Dokumentation an die Erweiterung der Spezifikation des IP-Link auf 15 Meter angepasst
0.1 | Erste Vorabversion


Das Feldbus Box System

Feldbus Box Module sind robuste Feldbusstationen für viele verschiedene Feldbus-Systeme. Sie verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Neben digitalen und analogen Ein- und Ausgängen samt Thermoelement- und RTD-Eingängen gibt es Inkrementalencoder-Interfaces für die Weg- und Winkelmessung sowie serielle Schnittstellen für die Lösung vielfältiger Kommunikationsaufgaben.

Signalanschluss in 3 Varianten

Die digitalen Ein-/Ausgänge können wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12-Variante vorgesehen.

Alle wichtigen Signalformen

Spezielle Ein-/Ausgangskanäle auf den Kombi-E/A-Module lassen sich wahlweise als Ein- oder Ausgang nutzen. Eine Konfiguration ist nicht erforderlich, da die Feldbusschnittstelle für jeden Kombikanal sowohl Eingangs- als auch Ausgangsdaten zur Verfügung stellt. Durch die Kombi-Module hat der Anwender alle Vorteile einer feinen Signal-Granularität.

Die Prozessor-Logik, die Eingangsbeschaltung sowie die Sensorversorgung werden aus der Steuerspannung gespeist. Die Lastspannung für die Ausgänge kann separat zugeführt werden. Bei Feldbus Boxen, in denen nur Eingänge zur Verfügung stehen, kann die Lastversorgung UP zur Weiterleitung optional angeschlossen werden.

Die Zustände der Feldbus Box, der Feldbusverbindung, der Spannungsversorgung sowie der Signale werden von LEDs angezeigt.

Die Beschriftungsstreifen lassen sich extern maschinell beschriften und können dann eingeschoben werden.

Kombinierbare Feldbus Boxen für mehr Flexibilität

Die Feldbus Box Serie umfasst neben der Kompakt Box auch erweiterbare Geräte, die Koppler Box und die Erweiterungsbox sowie intelligente Geräte, die SPS Boxen.

Kompakt Box

Die Kompakt Box stellt dem Feldbus die E/A-Daten der angeschlossenen digitalen und analogen Sensoren und Aktuatoren zur Verfügung.

Koppler Box

Die Koppler Box sammelt zusätzlich über eine störsichere LWL-Verbindung (IP-Link) E/A-Daten von den Erweiterungsboxen ein. Sie können bis zu 120 Erweiterungsboxen an eine Koppler Box anschließen. Es ergibt sich so ein verteiltes IP67 E/A-Netzwerk mit nur einer Feldbusschnittstelle.

Die Koppler Box erkennt die angeschlossenen Erweiterungsmodule selbsttätig in der Aufstart-Phase und mappt die E/A-Daten automatisch in das Feldbus-Prozessabbild – eine Konfiguration ist nicht erforderlich. Aus Sicht des Feldbusses stellt sich die Koppler Box samt allen vernetzten Erweiterungsboxen als ein einziger Busteilnehmer mit entsprechend vielen E/A-Signalen dar.

Die Koppler Box entspricht dem Buskoppler aus dem BECKHOFF Busklemmen-System. BECKHOFF Feldbus-Geräte der Schutzart IP 20 (Busklemmen) und IP 67 (Feldbus Box) können problemlos kombiniert werden - das Daten-Handling ist jeweils gleich.

IP-Link

IP-Link ist eine LWL-Verbindung mit 2 Megabit/s Übertragungsrate, die 1000 binäre E/A-Daten in ca. 1 ms schnell und sicher überträgt – kleinere Konfigurationen entsprechend schneller. Durch die hohe Nutzdatenrate ist gewährleistet, dass die Kopplung über IP-Link keine spürbare Einschränkung der Feldbus-Performance mit sich bringt.

Für die schnelle und einfache Konfektionierung der IP-Link-Kabel vor Ort wurden preisgünstige Steckverbinder in IP 67 Schutzart entwickelt. Der Anschluss erfordert kein Spezialwerkzeug und lässt sich schnell und einfach durchführen. Die IP-Link-Kabel sind alternativ auch mit vorkonfektionierten Steckern erhältlich.

Durch die getrennte Zuführung der Ausgangs-Spannungsversorgung lassen sich Ausgangsgruppen einzeln abschalten. Außerdem können problemlos unterschiedliche Potenziale innerhalb eines Erweiterungsringes aufgebaut werden, da IP-Link naturgemäß über eine optimale Potenzialtrennung verfügt.

Erweiterungsbox

Die Erweiterungsboxen decken wie die Kompakt Boxen das gesamte Spektrum der E/A-Signale ab und dürfen bis zu 15 m Abstand voneinander haben. Sie bauen hierbei besonders klein und führen zu besonders preiswerten E/A-Lösungen in hoher Schutzart. Auch hier sind die digitalen Ein-/Ausgänge wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder anschließbar. Analoge Signaltypen werden mit der M12-Variante ausgerüstet. Die Schnapp-Steckverbinder verriegeln formschlüssig und ergeben eine rüttelfeste Verbindung, während sich die Schraub-Steckverbinder durch eine hohe Zugfestigkeit auszeichnen.

SPS Box

Die SPS Box ist eine intelligentes Feldbus Box mit SPS-Funktionalität für dezentrale Vorverarbeitung der E/A-Signale. Hiermit lassen sich Applikationsteile aus der zentralen Steuerung auslagern. Deren CPU und der Feldbus werden entlastet. Dezentral Zählen, Regeln oder Schalten sind typische Anwendungen für die SPS-Box. Die Reaktionszeiten sind unabhängig von der Buskommunikation und der übergeordneten Steuerung.

Bei Bus- oder Steuerungsausfall ist ein Funktionserhalt (z.B. geordnete Überführung des Prozesses in einen sicheren Zustand) möglich.

Die Programmierung erfolgt mit TwinCAT nach IEC 61131-3. Fünf verschiedene Programmiersprachen stehen zur Verfügung:

  • Anweisungsliste (AWL)

  • Funktionsplan (FUP)

  • Kontaktplan (KOP)

  • Ablaufsprache (AS)

  • Strukturierter Text (ST).

Der Programm-Download erfolgt wahlweise über den Feldbus oder über die Programmierschnittstelle.

Es stehen umfangreiche Debug-Funktionalitäten (Breakpoint, Einzelschritt, Monitoring, etc.) zur Verfügung. SPS Box verfügt über einen leistungsfähigen 16 Bit Controller, 32/96 KByte Programmspeicher und 32/64 KByte Datenspeicher. Weiter stehen 512 Byte als nichtflüchtiger Speicher für remanente Merker zur Verfügung.

SPS Box mit IP-Link

Nahezu unbeschränkte E/A-Möglichkeiten ergeben sich durch die programmierbare SPS Box mit IP-Link. Aus dem SPS-Programm heraus lassen sich bis zu 120 Erweiterungsmodule mit über 2000 E/As direkt ansprechen. Die SPS Box eignet sich damit auch als autarke Kleinsteuerung zur Steuerung von Anlagenteilen oder kleiner Maschinen.


Feldbus Box - Bezeichnungsübersicht

Die Bezeichnung der Feldbus Box Module ist wie folgt zu verstehen:
IXxxxy-zyyy

IX beschreibt die Bauform:

"IP" steht für die Bauform Kompakt Box.
"IL" steht für die Bauform Koppler Box (mit IP-Link).
"IE" steht für die Bauform Erweiterungsbox.

xxxy beschreibt die E/A-Beschaltung:

xxx bezeichnet die E/A-Eigenschaft:
"10x" - 8 x digitale Eingänge
"15x" - Zählermodul
"20x" - 8 x digitale Ausgänge
"23x" - 4 x digitale Eingänge und 4 x digitale Ausgänge
"24x" - 8 x digitale Eingänge und 8 x digitale Ausgänge
"25x" - PWM-Modul
"3xx" - 4 x analoge Eingänge
"4xx" - 4 x analoge Ausgänge
"5xx" - Inkremental-Encoder oder SSI-Geber
"6xx" - Gateway-Module RS232, RS422, RS485, TTY

y beschreibt den mechanischer Anschluss:
"0" steht für 8mm Schnappanschluss
"1" steht für M 8 Schraubanschluss
"2" steht für M 12 Schraubanschluss und
"9" steht für M23 Schraubanschluss

zyyy bezeichnet die Programmierbarkeit und das Feldbus-System:

z unterscheidet ob es sich um einen Slave oder einen programmierbare Slave handelt:
"B" - nicht programmierbar
"C" - programmierbar (SPS Box)

yyy steht für das Feldbus-System und den Bus-Anschluss:
"110" - EtherCAT
"200" - Lightbus
"310" - PROFIBUS
"318" - PROFIBUS mit integriertem T-Stück
"400" - Interbus
"510" - CANopen
"518" - CANopen mit integriertem T-Stück
"520" - DeviceNet
"528" - DeviceNet mit integriertem T-Stück
"730" - Modbus
"800" - RS485
"810" - RS232
"900" - Ethernet TCP/IP mit RJ45 für den Bus-Anschluss
"901" - Ethernet TCP/IP mit M12 für den Bus-Anschluss
"903" - PROFINET
"905" - EtherNet/IP

Kompakt Box

Die Feldbus Boxe verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Die digitalen Ein-/Ausgänge können wahlweise über Ø 8 mm Schnapp-, M8 Schraub- oder über M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12 Variante verfügbar.

Je nach Modul kann der E/A-Teil und der Stromversorgungsteil unterschiedlich sein.

Koppler Box

Die Koppler Box gibt es in drei Varianten als IL230x-Bxxx. Diese unterscheidet sich von der Kompakt Box dadurch, dass diese Module eine Schnittstelle zu den sogenannten Erweiterungsboxen bietet. Diese Schnittstelle ist ein Sub-Bussystem auf LWL Basis den sogenannten IP-Link. Dieses leistungsfähige Sub-Bussytem kann bis zu 120 Erweiterungsboxen an einer Koppler Box verarbeiten.

Erweiterungsbox

Feldbusunabhängige Erweiterungsmodule, die nur an einer Koppler Box über IP-Link betrieben werden können.

SPS Box

Eine SPS Box unterscheidet sich von einer Koppler Box dadurch, dass sie in IEC 61131-3 programmierbar ist. Dadurch kann dieser Slave auch ohne Master autonom arbeiten, zum Beispiel für Steuerungs- oder Regelungsaufgaben.


Firm- und Hardware-Stand

Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Hard- und Firmware-Stand. Die Eigenschaften werden weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben wie Module neue Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das diese Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand der Module können Sie anhand der mit einem D beginnenden Nummer auf der Seite des Moduls erkennen.

Syntax:

D . ww yy x y z u

ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel:

D.22081501

- Kalenderwoche 22
- des Jahres 2008
- Firmware-Stand Busplatine: 1
- Hardware Stand Busplatine: 5
- Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig)
- Hardware-Stand E/A-Platine: 1


Technische Daten

Technische Daten | IPxxxx-B730 | IL230x-B730
Erweiterungsmodule | - | max. 120 mit insgesamt 512 Bytes Ein- und 512 Byte Ausgänge
Digitale Peripheriesignale | entsprechend E/A-Variante | max. 960 Ein- und Ausgänge
Analoge Peripheriesignale | entsprechend E/A-Variante | max. 255 Ein- und Ausgänge
Konfigurationsmöglichkeiten | über KS2000 oder Adresswählschalter
Bus Teilnehmer | 69
Topologie | Linie
Übertragungsphysik | RS 485 (wie Profibus) abgeschirmtes, verdrilltes Kupferkabel
Max. Kabellänge | 1200 m
Protokoll | RTU (ASCII)
Baud-Rate | einstellbar: 150 bis 38400 Baud (default: 9,6 kBaud)
Stromversorgung | Steuerspannung: 24VDC (-15%/+20%); Lastspannung: entsprechend E/A-Variante
Stromaufnahme Steuerspannung | 30 mA + Stromaufnahme Sensorversorgung, max. 0,5A
Stromaufnahme Lastspannung | entsprechend E/A- Variante
Anschluss Stromversorgung | Einspeisung: 1 x M8 Stecker 4-polig Weiterleitung: 1 x M8 Buchse 4-polig (außer IP/IE204x)
Anschluss Feldbus | 1 x M12 5-polig Buchse (inverse Codierung)
Potentialtrennung | Kanäle / Steuerspannung: nein zwischen den Kanälen: nein Steuerspannung / Feldbus: ja
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... +55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 65/66/67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassung | CE, UL E172151


Beschreibung des Feldbussystems

Modbus ist ein offenes serielles Kommunikationsprotokoll, das auf der Master/Slave Architektur basiert. Da es recht einfach auf beliebigen seriellen Schnittstellen zu implementieren ist, hat es eine weite Verbreitung gefunden. Das Modbus Protokoll wurde ursprünglich für die Vernetzung von Steuerungen entwickelt, es wird jedoch auch häufig für die Anbindung von Ein-/Ausgangs-Baugruppen verwendet. Aufgrund der niedrigen Übertragungsrate von maximal 38,4 kBaud empfiehlt sich der Einsatz von Modbus vor allem für Applikationen mit wenigen Busteilnehmern oder geringen zeitlichen Anforderungen.

Der Bus besteht aus einer Master Station und mehreren Slave-Stationen, wobei die Kommunikation ausschließlich durch den Master gesteuert wird. Modbus verfügt über zwei grundlegende Kommunikationsmechanismen:

  • Frage/Antwort (Polling): Der Master sendet ein Anfragetelegramm an eine beliebige Station und erwartet deren Antworttelegramm.
  • Broadcast: Der Master sendet einen Befehl an alle Stationen im Netz, die diesen ohne Rückmeldung ausführen.

Die Telegramme erlauben das Schreiben und Lesen von Prozessdaten (Ein-/Ausgangsdaten) wahlweise einzeln oder gruppenweise. Die Daten können entweder ASCII codiert sein oder im RTU Format gepackt übertragen werden. Modbus wird auf unterschiedlichen Übertragungsmedien verwendet. Weit verbreitet ist die Implementierung auf der RS485-Busphysik, eine verdrillte geschirmte Zweidrahtleitung mit Abschlusswiderständen wie bei Profibus.

Konfiguration

Die Knotenadresse wird mit zwei dezimal kodierten Drehwahlschaltern im Bereich von 1 bis 69 eingestellt. Die Übertragungsrate und weitere Systemparameter werden mit dem KS2000 Softwaretool über die serielle Konfigurationsschnittstelle der Feldbus Box eingestellt oder über die Adresswählschalter 69-99.

Diagnose

Die BECKHOFF Modbus Knoten unterstützen die Diagnosefunktionen des Modbus Protokolls. Die Diagnosemeldungen werden über den Bus übertragen und im Master zusammengefasst. Der Status der Netzwerkverbindung, der Gerätestatus, der Status der Ein- und Ausgänge sowie der Spannungsversorgung wird mit LEDs dargestellt.

Kabel

Für Modbus kann die Auswahl an Profibus Kabeln verwendet werden. Mit dem BECKHOFF Programm an vorkonfektionierten Kabeln vereinfacht sich die Installation erheblich. Verdrahtungsfehler werden vermieden und die Inbetriebnahme führt schneller zum Erfolg. Das Programm umfasst Feldbuskabel, Stromversorgungskabel und Sensorkabel sowie Zubehör wie Abschlusswiderstände und T-Stücke. Feldkonfektionierbare Stecker und Kabel sind ebenfalls erhältlich.


Aufbau und Topologie RS485

RS 485 Modbus-Master mit mehren IP/ILxxxx-B730 Feldbus Boxen:

RS485_topologie1.jpg (11127 Byte)


Modbus RS485-Anschluss

Die M12-Buchse ist invers Codiert und besitzt 5 Pins. Pin 2 und Pin 3 sind die Signale der RS485-Physik. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist. Pin 5 ist (Abschirmung) Shield, die kapazitiv mit der Masse der Feldbus Box verbunden ist.

Kabel und Stecker können Sie aus aus dem BECKHOFF Programm für Profibus auswählten.

Pinbelegung der M12-Buchse (RS485)

Bedeutung | M12 | 9 poliger D-Sub
+5 V DC | Pin 1 | Pin 6
TxD/RxD | Pin 2 | Pin 3
GND | Pin 3 | Pin 5
RxD/TxD | Pin 4 | Pin 8
Shield | Pin 5 | D-Sub Buchse (Gehäuse)


Modbus-Verkabelung (RS485)

Für die RS485 Verkabelung können alle Profibus Kabel und Stecker eingesetzt werden.

Längenausdehnung

Die Busleitung ist in der EN 50170 spezifiziert. Daraus ergibt sich die nachfolgende Längenausdehnung eines Bussegment.

Baud-Rate in kBit/sec | 9,6 | 19,2 | 38,4
Leitungslänge in m | 1200 | 1200 | 1200

Bussegment

Ein Bussegment besteht aus maximal 32 Teilnehmern. An einem RS485-Netzwerk sind 69 Teilnehmer erlaubt. Um diese Anzahl zu erreichen sind Repeater erforderlich, die das Signal auffrischen (es können Profibus-Repeater verwendet werden). Jeder Repeater wird als Teilnehmer gezählt.

IP-Link

Der IP-Link ist das Sub-Bussystem der Feldbus Boxen. Die Topologie ist eine Ringstruktur. Es gibt einen IP-Link Master, der in einem IP230x-Bxxx oder IP230x-Cxxx sich befindet. Die IE Module sind Slaves. Es dürfen max. 120 Erweiterungsboxen angeschlossen werden. Der Abstand zwischen zwei Modulen darf 5 m nicht überschreiten. Beachten Sie bei der Planung und Installation der Module, dass am letzten Modul wieder der IP-Link Master angeschlossen werden muss.


Modbus-Protokoll

RTU

Im RTU-Modus startet das Protokoll mit einer Ruhezeit von 3,5 Zeichen und endet mit dieser auch (in der Abbildung mit T1-T2-T3-T4 gekennzeichnet).
Die zulässigen Zeichen, die für alle Felder übertragen werden, sind Hexadezimal 0... 9, A..., F.

Start | Slave Adresse | Funktion | Daten | CRC | END
t1-t2-t3-t4 | 1 Byte | 1 Byte | n Bytes | 2 Byte | t1-t2-t3-t4

ASCII

Im ASCII-Modus startet das Telegramm mit einem Doppelpunkt (":", Zeichen 0x3A) und endet mit einem carrige return line feed ("CRLF", Zeichen 0x0D und 0x0A).
Die übertragenen Zeichen setzen sich aus dem ASCII-Code zusammen.

Start | Slave Adresse | Funktion | Daten | LRC | END
1 Byte 0x3A | 2 Byte | 2 Byte | n Bytes | 2 Byte | 2 Byte 0x0D, 0x0A


Modbus-Interface

Adresse |  | Beschreibung
0x0000 0x00FF |  | Prozessdaten-Interface Eingänge
0x0800 0x08FF |  | Prozessdaten-Interface Ausgänge
0x1000 0x1006 | Read only | Buskoppler Feldbus Box Kennung
0x100A |  | 2 Byte SPS-Interface
0x100B |  | Busklemmendiagnose
0x100C |  | Buskoppler Status
0x1010 |  | Prozessabbildlänge in Bit, analoge Ausgänge (ohne SPS Variablen)
0x1011 |  | Prozessabbildlänge in Bit, analoge Eingänge (ohne SPS Variablen)
0x1012 |  | Prozessabbildlänge in Bit, digitale Ausgänge
0x1013 |  | Prozessabbildlänge in Bit, digitale Eingänge
0x1020 |  | Watchdog, aktuelle Zeit in [ms]
0x110A | Read/Write | 2 Byte SPS Interface
0x110B |  | Busklemmendiagnose
0x1120 |  | Watchdog vordefinierte Zeit in [ms] (Default: 1000)
0x1121 |  | Watchdog Reset Register
0x1122 |  | Art des Watchdogs | 1bin | Telegramm Watchdog (Default)
 |  |  | 0bin | Schreibtelegramm Watchdog
0x4000 0x40FF* |  | Merkerbereich (%MB..)*

* nur bei den Busklemmen Controller (BC7300, BC8x50, IL230x-C730)

Watchdog

Der Watchdog ist im Auslieferungszustand aktiviert. Nach dem ersten Schreibtelegramm wird der Watchdog scharf geschaltet und bei jedem empfangenden Telegramm dieses Teilnehmers getriggert. Eine zweite Möglichkeit, die eine schärfere Bedingung des Watchdogs darstellt, ist, dass der Watchdog nur nach jedem Schreibtelegramm getriggert wird. Dafür Schreiben Sie in das Register 0x1122 eine Null (Default "1").
Der Watchdog kann deaktiviert werden in dem im Offset 0x1120 eine Null geschrieben wird. Das Watchdog Register darf nur dann beschrieben werden, wenn der Watchdog noch nicht aktiv ist. Die Daten in diesem Register bleiben gespeichert.

Watchdog-Register

Sollte der Watchdog auf Ihren Slave abgelaufen sein können sie diesen durch ein zweimaliges beschreiben des Registers 0x1121 zurücksetzen. Dazu muss folgendes in das Register geschrieben werden: 0xBECF 0xAFFE. Dies kann mit der Funktion 6 oder der Funktion 16 geschehen.

Status des Buskopplers

15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
FB | - | - | - | - | - | - | - | - | - | - | - | - | - | CNF | KB

FB: Feldbusfehler, Watchdog abgelaufen
KB: Busklemmenfehler/IP-Link Fehler
CNF: Buskoppler Konfigurationsfehler

2 Byte SPS-Interface*

Mit dem 2 Byte SPS-Interface können Register der komplexen Klemmen sowie Register des Busklemmen-Controllers gelesen bzw. beschrieben werden. Die Register der komplexen Klemmen sind in der Dokumentation zur jeweiligen Klemme beschreiben. Über die Register des Buskopplers können z.B. K-Busdiagnosedaten, der Klemmenaufbau oder Zykluszeiten gelesen sowie die programmierte Konfiguration beschrieben werden. Weiterhin kann darüber auch ein manueller K-Bus-Reset durchgeführt werden. Das 2 Byte SPS-Interface benötigt je zwei Bytes in den Ein- und Ausgangsdaten, über die ein spezielles Protokoll abgewickelt wird. Eine Beschreibung des 2 Byte SPS-Interface, der verfügbaren Register im Buskopplers sowie Funktionsbausteine für verschiedene SPS-Systeme, die das 2 Byte SPS-Interface unterstützen, kann auf Anfrage geliefert werden.

* beim BC8150 nicht implementiert

2 Byte Diagnose-Interface

Die Fehlermeldungen der Klemmen können mit dem 2 Byte Diagnose-Interface gesendet werden. Dazu ist aber die K-Busdiagnose zu aktivieren. Das 2 Byte Diagnose-Interface belegt je zwei Bytes in den Ein- und Ausgangsdaten, über die ein spezielles Protokoll durchgeführt wird. Eine Beschreibung des 2 Byte Diagnose-Interfaces kann auf Anfrage geliefert werden.


Datenrahmen

Beschreibung | Wert
Datenbits | 8
Stopbits | 1
Baudrate | 9600 Baud
Parity | keine


Modbus Fehlerantwort

Wenn der Anwender den Slave eine Anforderung oder Mitteilung sendet, die der Koppler nicht versteht, antwortet der Slave mit einer Fehlermitteilung. Diese Antwort enthält die Funktion und den Fehler-Code. Der Funktionsrückgabewert wird mit 0x80 addiert.

Code | Name | Bedeutung
1 | ILLEGAL FUNKTION | Nicht implementierte Modbus-Funktion
2 | ILLEGAL DATA ADDRESS | Ungültige Adresse oder Länge
3 | ILLEGAL DATA VALUE | Ungültige Parameter - Diagnosefunktionen - Falsches Register
4 | SLAVE DEVICE ERROR | Watchdog- oder K-Bus-Fehler


Modbus-Funktionen

Die Funktionen entscheiden beim Modbus-Protokoll, ob Daten gelesen oder geschrieben werden und um welche Art von Daten es sich dabei handelt.

Funktion | Code | Beschreibung
Read coil status | 1 | Lesen digitaler Ausgänge
Read input status | 2 | Lesen digitaler Eingänge
Read holding register | 3 | Lesen analoger Aus- und Eingänge / GPR
Read input register | 4 | Lesen analoger Eingänge / GPR
Force single coil | 5 | Schreiben eines digitalen Ausgangs
Preset single register | 6 | Schreiben eines analogen Ausgangs / GPR
Diagnose | 8 | Diagnose
Force multiple coils | 15 | Schreiben mehrere digitaler Ausgänge
Preset multiple register | 16 | Schreiben mehrere analoger Ausgänge / GPRs
Read / write registers | 23 | Schreiben und lesen mehrere Prozessdaten Ausgänge / GPRs

GPR (General Preset Register) - Registerstruktur Modbus Interface (siehe Anhang)


Funktion 1: READ COIL STATUS

Mit der Funktion READ COIL STATUS können die gesetzten, digitalen Ausgänge gelesen werden.
In diesem Beispiel werden die ersten 10 digitalen Ausgänge gelesen. Die Start-Adresse ist Null. Im Feld Start-Adresse können Sie einen Offset eintragen.

Anfrage (Query)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 1 | 0x01 | "01" | 0x30, 0x31
Start-Adresse high | 0 | 0x00 | "00" | 0x30, 0x30
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Anzahl high | 0 | 0x00 | "00 | 0x30, 0x30
Anzahl low | 10 | 0x10 | "10" | 0x31, 0x30
Error Check, LRC/CRC |  | 0xBC, 0xA7 | "E4" | 0x45, 0x34
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A

Der Feldbus-Koppler-Box antwortet mit dem Byte Count 2, d.h. 2 Byte Daten kommen zurück. Die Anfrage war 10 Bits, die jetzt auf 2 Byte aufgeteilt werden. Im Ausgangsprozessabbild des Modbus-Slaves ist das 3.Bit gesetzt und der Feldbus-Koppler-Box gibt im ersten Datenbyte eine "4" wieder.

Antwort (Response)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 1 | 0x01 | "01" | 0x30, 0x31
Byte Count | 2 | 0x02 | "02" | 0x30, 0x32
Daten-Bit 0...7 | 4 | 0x04 | "04" | 0x30, 0x34
Daten-Bit 8...18 | 0 | 0x00 | "00" | 0x30, 0x30
Error Check, LRC/CRC |  | 0x23, 0x3D | "EE" | 0x45, 0x45
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 2: READ INPUT STATUS

Mit der Funktion READ INPUT STATUS können die digitalen Eingangsdaten gelesen werden. In diesem Beispiel werden die ersten 10 digitale Eingänge gelesen. Die Start-Adresse ist Null. Im Feld Start-Adresse können Sie einen Offset eintragen.

Anfrage (Query)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 2 | 0x02 | "02" | 0x30, 0x32
Start-Adresse high | 0 | 0x00 | "00" | 0x30, 0x30
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Anzahl high | 0 | 0x00 | "00" | 0x30, 0x30
Anzahl low | 10 | 0x0A | "10" | 0x31, 0x30
Error Check, LRC/CRC |  | 0xF8, 0xA7 | "E3" | 0x45, 0x33
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A

Der Feldbus-Koppler-Box antwortet mit dem Byte Count 2, d.h. 2 Byte Daten kommen zurück. Die Anfrage war 10 Bits, die jetzt auf 2 Byte aufgeteilt werden. Im Ausgangsprozessabbild des Modbus-Slaves ist das 3.Bit gesetzt und der Feldbus-Koppler-Box gibt im ersten Datenbyte eine "4" wieder.

Antwort (Response)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 2 | 0x02 | "02" | 0x32, 0x30
Byte Count | 2 | 0x02 | "02" | 0x32, 0x30
Daten-Bits 0..7 | 1 | 0x01 | "01" | 0x31, 0x30
Daten-Bits 8..18 | 0 | 0x00 | "00" | 0x30 , 0x30
Error Check, LRC/CRC |  | 0x20, 0x29 | "F0" | 0x46, 0x30
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 3: READ HOLDING REGISTERS

Mit der Funktion READ HOLDING REGISTERS können die Ein- und Ausgangsworte und die Register gelesen werden. Eingänge ab dem Offset 0 - 0xFF und Ausgänge ab den Offset 0x800 - 0x8FF.

In diesem Beispiel werden die ersten zwei analogen Ausgänge gelesen. Die analogen Ausgänge beginnen beim Offset 0x800 (hex). Die Länge bezeichnet die Anzahl, der zu lesenden Kanäle.

Anfrage (Query)

Byte Name | Beispiel |  |
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 3 | 0x03 | "03" | 0x30, 0x33
Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x38
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Anzahl high | 0 | 0x00 | "00" | 0x30, 0x30
Anzahl low | 2 | 0x02 | "02" | 0x30, 0x32
Error Check, LRC/CRC |  | 0xC6, 0xC1 | "E8" | 0x45, 0x38
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A

Der Feldbus-Koppler-Box antwortet mit dem Byte Count 4, d.h. 4 Byte Daten kommen zurück. Die Anfrage waren 2 Analogkanäle, die auf 2 Worte aufgeteilt sind. Im analogen Ausgangsprozessabbild hat der 1. Kanal einen Wert von 0x3FFF und der 2. Kanal 0x0.

Antwort (Response)

Byte Name | Beispiel |  |
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 3 | 0x03 | "03" | 0x30, 0x33
Byte Count | 4 | 0x04 | "04" | 0x30, 0x34
Daten 1 High-Byte | 63 | 0x3F | "3F" | 0x33, 0x46
Daten 1 Low-Byte | 255 | 0xFF | "FF" | 0x46, 0x46
Daten 2 High-Byte | 0 | 0x00 | "00" | 0x30, 0x30
Daten 2 Low-Byte | 0 | 0x00 | "00" | 0x30, 0x30
Error Check, LRC/CRC |  | 0xC6, 0xC1 | "B0" | 0x42, 0x30
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 4: READ INPUT REGISTERS

Die Funktion READ INPUT REGISTERS ließt die analogen Eingänge aus.

In diesem Beispiel werden die ersten zwei analogen Eingänge des Slaves mit der Nummer 11 gelesen. Die analogen Ausgänge beginnen bei einem Offset von 0x0000. Die Länge bezeichnet die Anzahl der zu lesenden Worte. Eine KL3002 hat 2 Worte Eingangsdaten, daher ist die einzugebende Länge bei "Anzahl low" zwei.

Anfrage (Query)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 4 | 0x04 | "04" | 0x30, 0x34
Start-Adresse high | 0 | 0x00 | "00" | 0x30, 0x30
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Anzahl high | 0 | 0x00 | "00" | 0x30, 0x30
Anzahl low | 2 | 0x02 | "02" | 0x30, 0x32
Error Check, LRC/CRC |  | 0x71, 0x61 | "EF" | 0x45, 0x46
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A

Der Feldbus-Koppler-Box antwortet mit dem Byte Count 4, d.h. 4 Byte Daten kommen zurück. Die Anfrage waren 2 analog Kanäle, die jetzt auf 2 Worte aufgeteilt werden. Im analogen Eingangsprozessabbild hat der 1. Kanal einen Wert von 0x0038 und der 2. Kanal 0x3F1B.

Antwort (Response)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 4 | 0x04 | "04" | 0x30, 0x34
Byte Count | 4 | 0x04 | "04" | 0x30, 0x34
Daten 1 High-Byte | 0 | 0x00 | "00" | 0x30, 0x30
Daten 1 Low-Byte | 56 | 0x38 | "38" | 0x33, 0x38
Daten 2 High-Byte | 63 | 0x3F | "3F" | 0x33, 0x46
Daten 2 Low-Byte | 11 | 0x0B | "0B" | 0x30, 0x42
Error Check, LRC/CRC |  | 0x80, 0x7E | "6A" | 0x36, 0x41
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 5: Schreiben eines digitalen Ausgangs

Mir der Funktion 5 kann ein digitaler Ausgang beschrieben werden. In diesem Beispiel wird der dritte digitale Ausgang beschrieben. Die digitalen Ausgänge beginnen bei einem Offset von 0x0000. Im High-Byte der Daten steht der digitale Wert. Um den Ausgang einzuschalten muss im "Daten High" 0xFF stehen und um den Ausgang wieder auszuschalten 0x00. Im "Daten low" muss 0x00 stehen.

Anfrage (Query)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 5 | 0x05 | "05" | 0x30, 0x35
Start-Adresse high | 0 | 0x00 | "00" | 0x30, 0x30
Start-Adresse low | 2 | 0x02 | "02" | 0x30, 0x32
Daten high | 255 | 0xFF | "FF" | 0x46, 0x46
Daten low | 0 | 0x00 | "00" | 0x30, 0x30
Error Check, LRC/CRC |  | 0x2D, 0x50 | "EF" | 0x45, 0x46
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A

Der Koppler/Box antwortet mit dem gleichen Telegramm.

Antwort (Response)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 5 | 0x05 | "05" | 0x30, 0x35
Start-Adresse high | 0 | 0x00 | "00" | 0x30, 0x30
Start-Adresse low | 2 | 0x02 | "02" | 0x30, 0x32
Daten high | 255 | 0xFF | "FF" | 0x46, 0x46
Daten low | 0 | 0x00 | "00" | 0x30, 0x30
Error Check, LRC/CRC |  | 0x2D, 0x50 | "EF" | 0x45, 0x46
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 6: Schreiben eines analogen Ausgangs

Mit der Funktion 6 kann auf das Ausgangsprozessabbild und dem Interface zugegriffen werden.
Bei der Funktion 6 wird der erste analoge Ausgang beschrieben. Die analogen Ausgänge beginnen bei einem Offset von 0x0800. Auch hier beschreibt der Offset immer ein Wort. Das heißt, dass der Offset 0x0803, das 4. Wort auf dem Ausgangsprozessabbild ist.

Anfrage (Query)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 6 | 0x06 | "06" | 0x30, 0x36
Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x36
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Daten high | 63 | 0x3F | "3F" | 0x33, 0x46
Daten low | 255 | 0xFF | "FF" | 0x46, 0x46
Error Check, LRC/CRC |  | 0xDA, 0xB0 | "A9" | 0x41, 0x39
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A

Der Feldbus-Koppler-Box antwortet mit dem gleichen Telegramm und der Bestätigung der empfangenen Daten.

Antwort (Response)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 6 | 0x06 | "06" | 0x30, 0x36
Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x36
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Daten high | 63 | 0x3F | "3F" | 0x33, 0x46
Daten low | 255 | 0xFF | "FF" | 0x46, 0x46
Error Check, LRC/CRC |  | 0xDA, 0xB0 | "A9" | 0x41, 0x39
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 8: Diagnose

Die Funktion 08 stellt eine Reihe von Tests, für die Überprüfung des Übertragungssystems zwischen dem Master und dem Slave oder für die Überprüfung der verschiedenen internen Fehlerzustände innerhalb des Slaves zur Verfügung. Ein Broadcast-Telegramm wird nicht unterstützt.
Die Funktion in der Abfrage benutzt ein Subfunktions-Code-Feld von zwei Byte, um die Art des durchzuführenden Tests zu definieren. Der Slave gibt den Funktions-Code und den Subfunktions-Code in einer Antwort aus.
Die Diagnose-Abfragen benutzen ein Datenfeld von zwei Byte, um Diagnosedaten oder Steuerinformationen zum Slave zu schicken.

Anfrage (Query)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 8 | 0x08 | "08" | 0x30, 0x38
Subfunction high | 0 | 0x00 | "00" | 0x30, 0x30
Subfunction low | 0 | 0x00 | "00" | 0x30, 0x30
Data high | 2 | 0x02 | "02" | 0x30, 0x32
Data low | 3 | 0x03 | "03" | 0x30, 0x33
Error Check, LRC/CRC |  | 0xA1, 0xC0 | "E8" | 0x45, 0x38
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A

Antwort (Response)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 8 | 0x08 | "08" | 0x30, 0x38
Subfunction high | 0 | 0x00 | "00" | 0x30, 0x30
Subfunction low | 0 | 0x00 | "00" | 0x30, 0x30
Data high | 2 | 0x02 | "02" | 0x30, 0x32
Data low | 3 | 0x03 | "03" | 0x30, 0x33
Error Check, LRC/CRC |  | 0xA1, 0xC0 | "E8" | 0x45, 0x38
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A

Spiegeln einer Anforderung (Subfunction 0)

Mit der Unterfunktion 0 werden die Daten, die der Master zum Slave schickt wieder zurückgeschickt.

Koppler Reset (Subfunction 1)

Der Buskoppler/Feldbus Box wird mit der Unterfunktion 1 neu initialisiert, Fehlerzähler werden zurückgesetzt und der Buskoppler/Feldbus Box führt einen Selbsttest durch. In der Zeit, in der der Buskoppler/Feldbus Box zurückgesetzt wird, werden keine Telegramme empfangen oder gesendet.

Hinweis Bevor der Busklemmen-Controller neu startet schickt er noch eine Antwort mit der Subfunction 1.
Hinweis Beim BC8150 ist die Unterfunktion 0 und 1 implementiert. Alle anderen Unterfunktionen liefern den Wert "0" zurück.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 01 | 00 00 | 00 00

Löschen aller Zählerinhalte (Subfunction 10)

Beim Aufruf dieser Unterfunktion löscht der Buskoppler/Feldbus Box alle Fehler Zähler.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0B | 00 00 | Echo Query Daten

Buskommunikation Antwort Zähler (Subfunction 11)

Gibt die Anzahl der Kommunikationsantworten an.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0C | 00 00 | Zähler Wert

CRC Fehler Zähler (Subfunction 11)

Gibt die Anzahl der festgestellten CRC Fehler an

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0D | 00 00 | Zähler Wert

Fehlerantwort Zähler (Subfunction 13)

Dieser Zähler gibt die Anzahl der Fehlerantworttelegramme, die der Buskoppler/Feldbus Box gesendet hat, an.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0D | 00 00 | Zähler Wert

Die folgenden Funktionen beinhalten die Zählerstände für verschiedene Units. D.h. die Modbus-Telegramme können mit Units unterschieden werden, wenn es sich zum Beispiel um einen Zugriff auf den Buskoppler/Feldbus Box von verschiedenen Mastern aus handelt.

Antworten des Slaves (Subfunction 14)

Gibt die Anzahl der gesendeten Antworten des Slaves an.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0E | 00 00 | Zähler Wert

Anzahl der nicht geantworteten Telegramme (Subfunction 15)

Gibt die Anzahl der nicht gesendeten Antworten des Slaves an.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0F | 00 00 | Zähler Wert

Anzahl der Fehlerantworten (Subfunction 16)

Gibt die Anzahl der gesendeten Fehlerantworten des Slaves an.

Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 10 | 00 00 | Zähler Wert


Funktion 15: Schreiben mehrerer digitaler Ausgänge

Bei der Funktion 15 können gleichzeitig mehrere digitale Ausgänge gesetzt oder zurückgesetzt werden.

In diesem Beispiel werden die ersten 20 digitalen Ausgänge beschrieben. Die digitalen Ausgänge beginnen bei einem Offset von 0x0000. Hier beschreibt der Offset immer ein Bit. Der Offset 0x0003 schreibt ab dem 4. Bit auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Bits an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.

Beispiel: 20 Bits belegen 3 Byte Count (auf Byte-Grenzen aufrunden).

Die Daten-Bytes enthalten die Werte für die einzelnen Bits. In diesem Beispiel werden die Bit 0 bis 15 auf TRUE gesetzt und Bit 16 bis 23 auf FALSE.

Anfrage (Query)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 15 | 0x0F | "0F" | 0x30, 0x46
Start-Adresse high | 0 | 0x00 | "00" | 0x30, 0x30
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Länge high | 0 | 0x00 | "00" | 0x30, 0x30
Länge low | 20 | 0x14 | "14" | 0x31, 0x34
Byte Count | 3 | 0x03 | "03" | 0x30, 0x33
Daten 1 Bit 0..7 | 255 | 0xFF | "FF" | 0x46, 0x46
Daten 2 Bit 8..15 | 255 | 0xFF | "FF" | 0x46, 0x46
Daten 3 Bit 16..23 | 0 | 0x00 | "00" | 0x30, 0x30
Error Check, LRC/CRC |  | 0x01, 0x95 | "D1" | 0x44, 0x31
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A

Antwort (Response)

Der Buskoppler/Feldbus Box antwortet mit dem gleichen Telegramm.

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 15 | 0x0F | "0F" | 0x30, 0x46
Start-Adresse high | 0 | 0x00 | "00" | 0x30, 0x30
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Länge high | 0 | 0x00 | "00" | 0x30, 0x30
Länge low | 20 | 0x14 | "14" | 0x31, 0x34
Error Check, LRC/CRC |  | 0xDA, 0xB0 | "D2" | 0x44, 0x32
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 16: Schreiben mehrerer analoger Ausgänge

Mit der Funktion 16 können mehrere analoge Ausgänge beschrieben werden. In diesem Beispiel werden die ersten 2 analogen Ausgangsworte beschrieben. Die analogen Ausgänge beginnen bei einem Offset von 0x0800. Hier beschreibt der Offset immer ein Wort. Der Offset 0x0003 schreibt ab dem 4. Wort auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Worte an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.
Beispiel: 4 Worte - entsprechen 8 Byte Count
Die Datenbytes enthalten die Werte für die analogen Ausgänge. In diesem Beispiel sind es zwei Worte, die zu beschreiben sind. Das erste Wort mit dem Wert 0x7FFF und das zweite Wort mit dem Wert 0x3FFF.

Anfrage (Query)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 16 | 0x10 | "10" | 0x31, 0x30
Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x38
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Länge high | 0 | 0x00 | "00" | 0x30, 0x30
Länge low | 2 | 0x02 | "02" | 0x30, 0x32
Byte Count | 4 | 0x04 | "04" | 0x30, 0x34
Daten 1 Byte 1 | 127 | 0x7F | "7F" | 0x37, 0x46
Daten 1 Byte 2 | 255 | 0xFF | "FF" | 0x46, 0x46
Daten 2 Byte 1 | 63 | 0x3F | "3F" | 0x33, 0x46
Daten 2 Byte 2 | 255 | 0xFF | "FF" | 0x46, 0x46
Error Check, LRC/CRC |  | 0xCD, 0xE3 | "1B" | 0x31, 0x42
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A

Antwort (Response)

Der Buskoppler/Feldbus Box antwortet mit der Start-Adresse und der Länge der gesendeten Worte.

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 16 | 0x10 | "10" | 0x31, 0x30
Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x38
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Länge high | 0 | 0x00 | "00" | 0x30, 0x30
Länge low | 2 | 0x02 | "02" | 0x30, 0x32
Error Check, LRC/CRC |  | 0x43, 0x02 | "DB" | 0x44, 0x42
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 23: Schreiben und Lesen mehrerer analoger Aus- oder Eingänge

Mit der Funktion 23 können mehrere analoge Ausgänge beschrieben und in einem Telegramm mehrere analoge Eingänge gelesen werden. In diesem Beispiel werden die ersten 2 analogen Ausgangsworte beschrieben und die ersten zwei analogen Eingänge gelesen. Die analogen Ausgänge beginnen beim Offset 0x0800 und die Eingänge ab dem Offset 0x0000. Hier beschreibt der Offset immer ein Wort. Der Offset 0x0003 schreibt ab dem 4. Wort auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Worte an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.
Beispiel: 4 Worte - entsprechen 8 Byte Count.
Die Datenbytes enthalten die Werte für die analogen Ausgänge. In diesem Beispiel sind es zwei Worte, die zu beschreiben sind. Das erste Wort mit dem Wert 0x3FFF und das zweite Wort mit dem Wert 0x7FFF.

Anfrage (Query)

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 23 | 0x17 | "17" | 0x31, 0x17
Lesen Start-Adresse high | 0 | 0x00 | "00" | 0x30, 0x30
Lesen Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Lesen Länge high | 0 | 0x00 | "00" | 0x30, 0x30
Lesen Länge low | 2 | 0x02 | "02" | 0x30, 0x32
Schreiben Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x38
Schreiben Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Schreiben Länge high | 0 | 0x00 | "00" | 0x30, 0x30
Schreiben Länge low | 2 | 0x02 | "02" | 0x30, 0x32
Byte Count | 4 | 0x04 | "04" | 0x30, 0x34
Daten 1 high | 63 | 0x3F | "3F" | 0x33, 0x46
Daten 1 low | 255 | 0xFF | "FF" | 0x46, 0x46
Daten 2 high | 127 | 0x7F | "7F" | 0x37, 0x46
Daten 2 low | 255 | 0xFF | "FF" | 0x46, 0x46
Error Check, LRC/CRC |  | 0x76, 0xD3 | "12" | 0x31, 0x32
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A

Antwort (Response)

Der Buskoppler/Feldbus Box antwortet mit der Start-Adresse und der Länge der übertragenen Bytes im "Byte Count". Es folgen die Dateninformationen. In diesem Beispiel steht im ersten Wort eine 0x0038 (hex) und im zweiten Wort eine 0x3F0B.

Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 23 | 0x17 | "17" | 0x31, 0x17
Byte Count | 4 | 0x04 | "04" | 0x30, 0x34
Daten 1 high | 0 | 0x00 | "00" | 0x30, 0x30
Daten 1 low | 56 | 0x38 | "38" | 0x33, 0x38
Daten 2 high | 63 | 0x3F | "3F" | 0x33, 0x46
Daten 2 low | 11 | 0x0B | "0B" | 0x30, 0x42
Error Check, LRC/CRC |  | 0xF8, 0xA7 | "E3" | 0x45, 0x33
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Parametrierung über den Adresswählschalter

Zur Einstellung wird der jeweilige Parameter, z.B. 4800 Baud, über die Schalter eingestellt. Dann muss die Spannung an- und wieder abgeschaltet werden.

Wiederholen Sie diese Prozedur für jeden einzelnen Parameter.

Adresse | Bedeutung | Einstellung
0 | Funktion | 0 | KS2000 Kommunikation (Parameter: 19200 Baud, 8 Daten, even Parity, 1 Stoppbit)
71-77 | Daten- rahmen | 71 | 8 Datenbits, no Parity
 |  | 72 | 8 Datenbits, even Parity
 |  | 73 | 8 Datenbits, odd Parity
 |  | 74 | 7 Datenbits, even Parity
 |  | 75 | 7 Datenbits, odd Parity
 |  | 76 | 1 Stoppbit
 |  | 77 | 2 Stoppbits
81-89 | Baudrate | 81 | 38400 Baud
 |  | 82 | 19200 Baud
 |  | 83 | 9600 Baud
 |  | 84 | 4800 Baud
 |  | 85 | 2400 Baud
 |  | 86 | 1200 Baud
 |  | 87 | 600 Baud
 |  | 88 | 300 Baud
 |  | 89 | 150 Baud
90-95 | Watchdog | 90 | Disable
 |  | 91 | 1000 ms
 |  | 92 | 2000 ms
 |  | 93 | 4000 ms
 |  | 94 | 8000 ms
 |  | 95 | max. ca. 65 sec
96-97 | Modbus Mode | 96 | RTU
 |  | 97 | ASCII
98 | Funktion | 98 | Herstellereinstellung
99 | Funktion | 99 | reserve


Tabellen- und Registerbeschreibung

Tabelle 100
Register | Beschreibung | Werte |  | Default
0 | Watchdog | 0...65767 | 0 ... Disable | 1000 [ms]
1 | Protokoll | 0 | RTU | 0
 |  | 1 | ASCII
2 | Datenbits Bit 0..3 | 1 | 8 Datenbytes | 1
 |  | 3 | 7 Datenbytes & Parity
 |  | 7 | 8 Datenbytes & Parity
 | Stopbits Bit 4 | 0 | ein Stopbit | 0
 |  | 1 | zwei Stopbits
 | Parity Bit 12 | 0 | Even | 0
 |  | 1 | Odd
3 | Baudrate | 0x8000 | 38400 Baud | 0x8002
 |  | 0x8001 | 19200 Baud
 |  | 0x8002 | 9600 Baud
 |  | 0x8003 | 4800 Baud
 |  | 0x8004 | 2400 Baud
 |  | 0x8005 | 1200 Baud
 |  | 0x8006 | 600 Baud
 |  | 0x8007 | 300 Baud
 |  | 0x8008 | 150 Baud


Anlaufverhalten der Feldbus Box

Nach dem Einschalten prüft die Feldbus Box ihren Zustand, konfiguriert (wenn vorhanden) den IP-Link ist und erstellt anhand der Erweiterungsmodule eine Aufbauliste. Wenn die Feldbus Box eine dezentrale Steuerung besitzt (IL230x-C310) wird nach einer erfolgreichen Aufbauliste die lokale SPS gestartet.
Beim Hochlauf des Moduls leuchten und blinken die E/A LEDs. Im fehlerfreien Zustand sollte nach ca. 2-3 sec keine E/A LED mehr Blinken. Sollte ein Fehler vorliegen, hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose LEDs).

Start_List.gif (8211 Byte)


Modbus-Adresse

Die Adresse bei der seriellen Feldbus Box ist über die zwei Drehwahlschalter hinter der Klarsichtabdeckung einzustellen. Die Default Einstellung beträgt 11. Die Adressen von 01 bis 69 zulässig. Dabei darf jede Adresse im Netzwerk nur einmal vorkommen. Die Adresse wird im ausgeschalteten Zustand der Feldbus Box geändert. Dafür lösen Sie die Abdeckung, und verändern Sie mit Hilfe eines Schraubendrehers die Schalter auf die gewünschte Position. Dabei ist zu beachten, dass die Schalter richtig einrasten. Der linke Schalter ist der Zehner Multiplikator und der rechte Schalter der Einer Multiplikator. Die Adressänderung wird aktiv, sobald das Gerät eingeschaltet wird.

Beispiel

Sie wollen Adresse 34 einstellen:
- Linker Drehwahlschalter: 3
- Rechter Drehwahlschalter: 4

AdressePB.jpg (19493 Byte)


Baud-Rate

Die Feldbus Box für Modbus ist auf 9600 Baud voreingestellt. Die Baud-Rate kann mit den Adresswählschalter oder mit der Konfigurations-Software KS2000 geändert werden.

Hinweis Die Adresse "0" ist reserviert für die KS2000- und TwinCAT-Kommunikation. Hier beträgt die Baud-Rate 19200 Baud. In der KS2000 muss die Multipoint-Adresse 0 eingetragen sein!

Die Defaulteinstellung der FeldbusBox für Modbus ist

Modbus | Frame | Watchdog | End of Frame
RTU | 8 Data, 1 Stop, 9600 baud, no parity | 1000 ms | 3 ms

Zulässige Leitungslängen RS485

Baud-Rate in kBits/sec | 9,6 | 19,2 | 38,4
Leitungslänge in m | 1200 | 1200 | 1200


Mapping der Feldbus Boxen

Die Feldbus Boxen besitzen einen Speicher, in dem die Prozessdaten gespeichert werden und die vom Feldbusmaster ausgelesen bzw. beschrieben werden. Die Anzahl der Daten und die Art der Daten hängen von der Art der eingesetzten Feldbus Box ab. Die Kompakte Feldbus Boxen besitzt immer die gleiche Anzahl an Daten. Die Koppler Box hat ein variables Mapping, das von Art und Anzahl der verbundenen Erweiterungs-Boxen abhängt.

Bitorientierte Feldbus Boxen

Die bitorientierten Feldbus Boxen besitzen immer die gleiche Anzahl von Ein oder/und Ausgängen. Diese können nicht verändert werden und sind fix.

Modul | Eingänge [Bit] | Modbus Funktion | Ausgänge [Bit] | Modbus Funktion
IP10xx-B8x0 IE10xx | 8 | read 2, 3, 4, 23 | - | -
IP20xx-B8x0 IE20xx | - | - | 8 | read 1, 3, 4, 23 write 5, 6, 15, 16, 23
IP23xx-B8x0 IE23xx | 8 (wobei das High-Nibbel nicht benutzt wird, letzen 4 Bit) | read 2, 3, 4, 23 | 8 (wobei das High-Nibbel nicht benutzt wird, letzten 4 Bit) | read 1, 3, 4, 23 write 5, 6, 15, 16, 23
IP240x-B8x0 IE240x | 8 | read 2, 3, 4, 23 | 8 | read 1, 3, 4, 23 write 5, 6, 15, 16, 23

Byteorientierte Feldbus Boxen

Die byteorientierten Feldbus Boxen können unterschiedlich parametriert werden. In der Tabelle ist der Default-Wert eingetragen.

Modul | Eingänge [Byte] | Modbus Funktion | Ausgänge [Byte] | Modbus Funktion
IP15xx-B730 IE15xx | 6 | read 3, 4, 23 | 6 | read 3, 4, 23 write 6, 16, 23
IP25xx-B730 IE25xx | 6 | read 3, 4, 23 | 6 | read 3, 4, 23 write 6, 16, 23
IP3xxx-B730 IE3xxx | 8 | read 3, 4, 23 | - | -
IP41xx-B730 IE41xx | - | - | 8 | read 3, 4, 23 write 6, 16, 23
IP5xxx-B730 IE5xxx | 6 | read 3, 4, 23 | 6 | read 3, 4, 23 write 6, 16, 23
IP6xxx-B730 IE6xxx | 4 | read 3, 4, 23 | 4 | read 3, 4, 23 write 6, 16, 23

Speicheraufteilung

Für die digitalen Funktionen steht ein Eingangs- und ein Ausgangsprozessabbild zur Verfügung. Für alle komplexen Signale (alle Busklemme oder Module die sich mit einem Byte oder mehr ins Prozessabbild eintagen) steht ein Prozessabbild zur Verfügung. Anhand der Offset Adresse wird unterschieden zwischen Eingang (Offset 0x0000) und Ausgang (0x0800) - siehe Modbus Interface.


Mapping einer IL230x-B730

Die IP-Link Module beginnen immer mit einem IL230x-Bxxx und einer Anzahl (max.120) Erweiterungsmodule. Das Mapping hängt von der Art und Anzahl der angeschlossenen Erweiterungsmodule ab.

Regel:
In des Prozessabbild werden erst alle byteorientierten Module eingetragen in der Reihenfolge, wie sie im IP-Link Ring eingetragen sind. Als nächstes folgen die digitalen Module in der Reihenfolge wie diese im Ring liegen, die am Ende auf 8 Bit aufgerundet werden.

Beispiel 1

Busaufbau:

  1. IL2301-B730
  2. IE1001
  3. IE1002
  4. IE2042
Modul | Position | Input |  |  | Output
 |  | Größe | Funktion | Offset | Größe | Funktion | Offset
IL2301-B730 | 1 | 4 Bit | 2 read | 0..3 | 4 Bit | 1 read | 0..3
 |  |  |  |  |  | 3 read | 0x0800 (Bit 0..3)
 |  |  |  |  |  | 5 write | 0..3
 |  |  | 3, 4 read | 0x0000 (Bit 0..3) |  | 6 write | 0x0800 (Bit 0..3)
 |  |  |  |  |  | 15 write | 0..3
 |  |  |  |  |  | 16 write | 0x0800 (Bit 0..3)
IE1001 | 2 | 8 Bit | 2 read | 4..11 | -
 |  |  | 3, 4 read | 0x0000 (Bit 4..11)
IE1002 | 3 | 8 Bit | 2 read | 12..19 | -
 |  |  | 3, 4 read | 0x0000 (Bit 12..15) 0x0001 (Bit 0..3)
IE2042 | 4 | - |  |  | 8 Bit | 1 read | 4..11
 |  |  |  |  |  | 3 read | 0x0800 (Bit 4..11)
 |  |  |  |  |  | 5 write | 4..11
 |  |  |  |  |  | 6 write | 0x0800 (Bit 4..11)
 |  |  |  |  |  | 15 write | 4..11
 |  |  |  |  |  | 16 write | 0x0800 (Bit 4..11)

Die Modbus Boxen arbeitet immer mit einer Größe von 16 Bit oder einem Wort. In diesem Beispiel wird ein Wort angefangen und wird leer aufgefüllt. Diese letzten Bits haben keine Funktion und sind immer "0", werden aber vom Protokoll übertragen.

Beispiel 2

Busaufbau:

  1. IL2301-B730
  2. IE1001
  3. IE3312
  4. IE3112
  5. IE4112
  6. IE2302
  7. IE2042
Modul | Position | Input |  |  | Output
 |  | Größe | Funktion | Offset | Größe | Funktion | Offset
IE3312 | 3 | 4 Worte | 3, 4 read | 0x0000..0x0003 | -
IE3112 | 4 | 4 Worte | 3, 4 read | 0x0004..0x0007 | -
IE4112 | 5 | - |  |  | 4 Worte | 3 read | 0x0800...0x0803
 |  |  |  |  |  | 6 write | 0x0800...0x0803
 |  |  |  |  |  | 16 write | 0x0800...0x0803
IL2301-B730 | 1 | 4 Bit | 2 read | 0..3 | -
 |  |  | 3, 4 read | 0x0008 (Bit 0..3)
IE1001 | 2 | 8 Bit | 2 read | 4..11 | -
 |  |  | 3, 4 read | 0x0008 (Bit 4..11)
IE2302 | 6 | 4 Bit | 2 read | 12..15 | 4 Bit | 1 read | 0..3
 |  |  |  |  |  | 3 read | 0x0804 (Bit 0..3)
 |  |  |  |  |  | 5 write | 0..3
 |  |  | 3, 4 read | 0x0008 (Bit 12..15) |  | 6 write | 0x0804 (Bit 0..3)
 |  |  |  |  |  | 15 write | 0..3
 |  |  |  |  |  | 16 write | 0x0804 (Bit 0..3)
IE2042 | 7 | - |  |  | 8 Bit | 1 read | 4..11
 |  |  |  |  |  | 3 read | 0x0804 (Bit 4..11)
 |  |  |  |  |  | 5 write | 4..11
 |  |  |  |  |  | 6 write | 0x0804 (Bit 4..11)
 |  |  |  |  |  | 15 write | 4..11
 |  |  |  |  |  | 16 write | 0x0804 (Bit 4..11)


Allgemeine Registerbeschreibung

Bei den komplexen Modulen können verschiedene Betriebsarten bzw. Funktionalitäten eingestellt werden. Die Allgemeine Registerbeschreibung erläutert den Inhalt der Register, die bei allen komplexen Modulen identisch sind. Die modulspezifischen Register werden in dem darauffolgendem Kapitel erklärt.
Der Zugriff auf die internen Register der Module wird im Kapitel Register-Kommunikation beschrieben.

Allgemeine Registerbeschreibung

Komplexe Module die einen Prozessor besitzen, sind in der Lage mit der übergeordneten Steuerung bidirektional Daten auszutauschen. Diese Module werden im folgenden als intelligente Module bezeichnet. Zu ihnen zählen die analogen Eingänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), die analogen Ausgänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), serielle Schnittstellenmodule (RS485, RS232, TTY, Datenaustausch-Module), Zähler-Module, Encoder-Interface, SSI-Interface, PWM-Module und alle anderen parametrierbare Module.

Alle intelligenten Modulen besitzen intern eine in ihren wesentlichen Eigenschaften identisch aufgebaute Datenstruktur. Dieser Datenbereich ist wortweise organisiert und umfasst 64 Speicherplätze. Über diese Struktur sind die wesentlichen Daten und Parameter der Module les- und einstellbar. Zusätzlich sind Funktionsaufrufe mit entsprechenden Parametern möglich. Jeder logische Kanal einer intelligenten Module besitzt eine solche Struktur (4-Kanal analoge Module besitzen also 4 Registersätze).

Diese Struktur gliedert sich in folgende Bereiche:

Bereich | Adresse
Prozessvariablen | 0-7
Typ-Register | 8-15
Hersteller- Parameter | 16-30
Anwender- Parameter | 31-47
Erweiterter Anwenderbereich | 48-63

Register R0-R7 (im internen RAM des Moduls)

Die Prozessvariablen können ergänzend zum eigentlichen Prozessabbild genutzt werden und sind in ihrer Funktion Modulspezifisch.

R0-R5

Diese Register besitzen eine vom Modul-Typ abhängige Funktion.

R6

Diagnose-Register: Das Diagnose-Register kann zusätzliche Diagnose-Information enthalten. So werden z.B. bei seriellen Schnittstellenmodulen Paritäts-Fehler, die während der Datenübertragung aufgetreten sind, angezeigt.

R7

Kommandoregister

  • High-Byte_Write = Funktionsparameter
  • Low-Byte_Write = Funktionsnummer
  • High-Byte_Read = Funktionsergebnis
  • Low-Byte_ Read = Funktionsnummer

Register R8-R15 (im internen ROM des Moduls)

Die Typ- und Systemparameter sind fest vom Hersteller programmiert und können vom Anwender nur gelesen und nicht verändert werden.

R8

Feldbus Box Typ: Der Feldbus Box Typ in Register R8 wird zur Identifizierung der Feldbus Box benötigt.

R9

Softwareversion x.y.: Die Software-Version kann als ASCII-Zeichenfolge gelesen werden.

R10

Datenlänge: R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit. Der Buskoppler sieht diese Struktur.

R11

Signalkanäle: Im Vergleich zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z.B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.

R12

Minimale Datenlänge: Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control/Status-Byte für die Funktion des Moduls nicht zwingend notwendig, und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen. Die Information steht

  • bei einem Ausgangsmodul im High-Byte
  • bei einem Eingangsmodul im Low-Byte.
R13

Datentypregister

Datentypregister | Beschreibung
0x00 | Modul ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur 1 Byte n Bytes
0x03 | Word-Array
0x04 | Struktur 1 Byte n Worte
0x05 | Doppelwort-Array
0x06 | Struktur 1 Byte n Doppelworte
0x07 | Struktur 1 Byte 1 Wort
0x08 | Struktur 1 Byte 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur 1 Byte n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur 1 Byte n Worte mit variabler logischer Kanallänge
0x15 | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur 1 Byte n Doppelworte mit variabler logischer Kanallänge
R14

reserviert

R15

Alignment-Bits (RAM): Mit den Alignment-Bits wird das Analogmodul im Prozessabbild auf eine Bytegrenze gelegt.

Register R16-R30 (Hersteller-Parameter, serielles EEPROM)

Die Hersteller-Parameter werden vom Hersteller für jeden Modultyp modulspezifisch festgelegt, können jedoch mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Hersteller-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Hersteller-Parameter müssen Sie zuvor in Register R31 ein Code-Wort setzen.

Register R31-R47 (Anwendungs-Parameter, serielles EEPROM)

Die Anwender-Parameter sind Modulspezifisch. Sie können mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Anwender-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Anwender-Parameter müssen Sie zuvor in Register R31 das Anwender-Code-Wort setzen.

R31

Code-Wort-Register im RAM: Damit Parameter im Anwender-Bereich geändert werden können muss hier das Code-Wort 0x1235 eingetragen werden. Wird ein abweichender Wert in dieses Register eingetragen, so wird der Schreibschutz gesetzt. Bei inaktivem Schreibschutz wird das Code-Wort beim Lesen des Register zurückgegeben, ist der Schreibschutz aktiv enthält das Register den Wert Null.

R32

Feature-Register: Dieses Register legt die Betriebsarten der Klemme fest. So kann z.B. bei den analogen E/A-Modulen eine anwenderspezifische Skalierung aktiviert werden.

R33 bis R63

Klemmenspezifische Register: Diese Register sind vom Klemmentyp abhängig.

Register R47 bis R63 (Registererweiterung für zusätzliche Funktionen)

Diese Register sind für zusätzliche Funktionen vorgesehen.


Aktivieren des kompletten Mappings

Um Registerkommunikation nutzen zu können, muss bei den Modulen IPxxxx-B730 / IL230x-B730 das komplette Mapping (mit Control- und Status-Byte) aktiviert werden.

Das komplette Mapping können Sie mit der Konfigurations-Software KS2000 (Menüpunkt: Settings/ProzessData1/Auswertung komplexer Klemmen) aktivieren.


Beispiel für Register-Kommunikation

Control-Byte

Das Control-Byte befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R/W | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Registerkommunikation eingeschaltet: Die ersten zwei Byte der Nutzdaten werden nicht für den Prozessdatenaustausch verwendet, sondern in den Registersatz der Feldbus Box geschrieben oder daraus gelesen.
6 | R/W | 0bin | Read: Das Register soll gelesen werden ohne es zu verändern.
 |  | 1bin | Write: Das Register soll beschrieben werden.
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll. Es sind 64 Register adressierbar.
Status-Byte

Das Status-Byte befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Quittung Registerzugriff
6 | R | 0bin | Read
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.

Beispiel 1

Lesen des Registers 8 von KL3204 oder IP/IE3202
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x88 (1000 1000bin) | 0xXX | 0xXX

Bit 0.7 gesetzt bedeutet Register-Kommunikation aktiv
Bit 0.6 nicht gesetzt bedeutet lesen des Registers.
Bit 0.5 bis Bit 0.0 geben mit 001000bin die Registernummer 8 an.
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim lesenden Zugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x88 | 0x0C | 0x84

Die Klemme/Box liefert im Eingangsdatenwort (Byte 1 und Byte 2) die Typ-Bezeichnung 0x0C84 (entspricht unsigned Integer 3204) zurück .

Besonderheit bei der Bezeichnung von Feldbus Boxen:
Die letzte Ziffer des zurückgegebenen unsigned Integer (3204) entspricht nicht der letzten Ziffer der Feldbus Box-Bezeichnung (3202), die für die Anschlussvariante (0 für S8, 1 für M8 und 2 für M12) steht. Sie gibt stattdessen die Anzahl der Kanäle wieder (IE3204 besitzt 4 Kanäle).

Hinweis Damit Register beschreiben werden können, müssen Sie zuvor das Codewort 0x1235 in Register 31 schreiben, um den Schreibschutz zu deaktivieren. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder.
Beachten Sie das einige Einstellungen in den Registern erst nach einem Neustart (Power-Off/Power-ON) des Moduls übernommen werden.

Beispiel 2

Ablauf einer Register-Kommunikation zum ändern eines Register.

1. Schreiben des Register 31 (Codewort setzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x12 | 0x35

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX
2. Lesen des Register 31 (gesetztes Codewort überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x9F | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0x12 | 0x35
3. Schreiben des Register 32 (Register ändern)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)e
0xE0 | 0x00 | 0x02

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0xXX | 0xXX
4. Lesen des Register 32 (geändertes Register überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xA0 | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0x00 | 0x02
5. Schreiben des Register 31 (Codewort zurücksetzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x00 | 0x00

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX


Diagnose-LEDs

Fehlerdiagnose

Es gibt 2 Arten von Fehlern:

  • Feldbus Fehler
  • Lokaler Fehler auf Kompakt Box oder Koppler Box

Blink-Codes

Blinkfolge | Bedeutung
Schnelles Blinken | Anfang
erste langsame Sequenz | Fehler-Code
zweite langsame Sequenz | Fehler-Argument
dritte langsame Sequenz (optional) | Fehler-Argument bei mehr als 20 Erweiterungen

Flasching_codes.jpg (2840 Byte)

Anfang Fehler-Code Fehler-Argument


Diagnose-LEDs für Modbus

Diese werden von den beiden oberen LEDs beschrieben.

LED grün | LED rot | E/A RUN | Beschreibung | Abhilfe
aus | aus | keine Bedeutung | - Kommunikation unterbrochen - Watchdog Zeit ist abgelaufen | - Kommunikation erneut starten - Watchdog zurücksetzen oder Modul neu starten
aus | an oder blink | keine Bedeutung | Fehler in der Datenübertragung | Folgende Fehler können dazu führen: - Parity Fehler - Checksummen Fehler - Zu viele Stopbits - Falsche Baudrate
an | aus | an | Modul im Datenaustausch | kein Fehler


Diagnose-LEDs für lokale Fehler

Lokale Fehler in einer Koppler Box (IL230x-Bxxx/Cxxx)

Unter den lokalen Fehlern ist gemeint, das ein Fehler in der Feldbus Box oder dem IP-Link aufgetreten ist. IP-Link-Fehler sind meist durch unsachgemäßen Gebrauch der Lichtwellenleitung zurück zu führen.

LED grün | LED rot |  |  | Beschreibung | Abhilfe
aus | aus |  |  | kein Datenaustausch | Modul im synchron Mode - zyklische Daten aktivieren
aus | 1 | 0 |  | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
aus | 2 |  |  | reserviert | -
aus | 3 | n |  | Bruchstelle wurde erkannt | n-tes Modul vor dem Empfänger des Masters
 | 3 | n | m | Bruchstelle wurde erkannt | (n*10)+m-tes Modul vor dem Empfänger des Masters
aus | 4 | n |  | zu viele fehlerhafte Telegramme erkannt (mehr als 25%) | vor dem n-ten Erweiterungsmodul (vor dem Empfänger des Masters) ist die LWL-Verkabelung zu prüfen
aus | 5 | n |  | Registerzugriff auf komplexe Module gescheitert | n-tes Modul überprüfen
aus | 11 | n |  | Komplexes Modul arbeitet fehlerhaft | n-tes Modul tauschen
aus | 12 | n |  | mehr als 120 Module im Ring | weniger Module anschließen
aus | 13 | n |  | n-tes Modul unbekannt | Firmware Update erforderlich
an | aus |  |  | Modul ist im Datenaustausch (kein Fehler) | -

Lokale Fehler in einer Erweiterungsbox

LED grün | LED rot | Beschreibung
aus | an | es werden kein Daten über den IP-Link empfangen
aus | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (sehr schlechte Datenverbindung)
blinkt, flackert | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (schlechte Datenverbindung), muss noch nicht zum Fehler führen
an | aus | es werden IP-Link Protokolle empfangen, kein Fehler

Fehlerhafte IP-Link Protokolle können entstehen durch:

  • schlecht konfektionierte IP-Link Steckverbinder
  • IP-Link Leitung mit erhöhter Dämpfung durch z.B. Knick o.ä.
  • defekte oder verschmutzte Sende LED (Modul vor dem fehlerhaften Modul)
  • defekter oder verschmutzter Empfänger

Der interne IP-Link-Fehlerzähler der Koppler Box kann mit der KS2000 Software ausgelesen werden.


Feldbus Box - Überprüfung der IP-Link-Verbindung

BECKHOFF Feldbus Box: Montage und Verkabelung

Überprüfung der IP-Link-Verbindung

Ein IP-Link-Kabel mit auf beiden Seiten korrekt konfektionierten IP-Link-Steckern garantiert eine fehlerfrei Übertragung.

Eine nachträgliche Prüfung der Übertragungsqualität und eine Fehlersuche ist mit der Konfigurationssoftware KS2000 möglich.

Hierzu sollte die Steuerung (z.B. ein PC mit Profibus-Karte) am Feldbus des Koppler Box angeschlossen sein und diese zyklisch mit Daten versorgen, oder die Koppler Box sollte mit der KS2000 auf freilaufend geschaltet werden.

Als Ergebnis sollte die I/O RUN LED auf dem Kopplermodul hellgrün leuchten. Dies zeigt, dass ein Datenaustausch mit den angeschlossenen Erweiterungsbox Modulen stattfindet. Eine rot flackernde I/O ERR LED zeigt fehlerhafte IP-Link-Telegramme an! Telegramme werden wie bei auch jedem Feldbussystem im Fehlerfall wiederholt, so dass eine Übertragung der Daten gewährleistet ist.

Fehlerzähler

In Tabelle 90, Offset 005 werden aufgetretene IP-Link-Fehler gezählt. Sporadisch auftretende Fehler bedeuten noch keine Probleme für die Kommunikation. Dieser Fehlerzähler wird nur durch ein Power ON/OFF zurückgesetzt.

Sollten in kurzer Zeit viel Fehler auftreten, wird eine schwere Störung diagnostiziert und das Koppler-Modul meldet diesen Fehler. Dies ist am Offset 006 oder 007 zu erkennen. Die beiden Werte stehen dann auf einem Wert > 200 und die I/O ERR LEDs des Koppler-Moduls blinken mit dem entsprechenden Fehler-Code.

Hinweis Die Konfigurations-Software KS2000 kommuniziert über einen seriellen Kanal mit der Koppler Box. Der Registerinhalt wird nicht andauernd aktualisiert, muss also manuell refreshed werden.

Fehlerort

Stellt das Koppler Modul einen Fehler fest, versucht es den Fehlerort aus dem Register der Erweiterungs-Box herauszulesen. Ist der Ring tatsächlich unterbrochen bzw. die Kommunikation stark gestört, ist dies nicht möglich. Dann wird nur der Ort des Bruchs dargestellt und zwar rückwärts vom Koppler gezählt (siehe IP-Link Fehlersuche).

Läuft die Kommunikation noch, kann in Tabelle 87 der Fehlerzähler je Erweiterungsmodul ausgelesen werden.

Hier bezieht sich der Offset auf die Position links im KS2000 Baum (siehe Grafik). d.h. in diesem Beispiel werden Fehler beim Offset 004 und 006 angezeigt.

Im IP-Link Aufbau ist der Fehler also bei der Übertragung zu Modul IE20xx und bei der Übertragung zu IE3112 zu suchen.

Der Fehler kann also liegen, an:

  • dem Sender-Modul
  • dem Empfänger-Modul
  • dem Kabel oder
  • den Steckern

Wird in Tabelle 90 ein Fehler angezeigt, aber in Tabelle 87 nicht, so ist die Fehlerursache in der Übertragungsstrecke zwischen dem letzten Erweiterungsmodul und dem Koppler zu suchen.

In fast allen Fällen sind Übertragungsfehler auf schlecht konfektionierte IP-Link-Stecker oder zu hohe Dämpfung im LWL-Kabel (durch scharfe Knicke o.ä.) zurückzuführen.

Tabelle 87 wird bei einer IP-Link-Unterbrechung nicht aktualisiert, da diese Werte direkt aus den Erweiterungs-Modulen kommen. Diese können dann über den IP-Link natürlich nicht mehr ausgelesen werden.

Hinweis Falls Sie eine Koppler-Box (z.B. IL2300-Bxxx, IL2301-Bxxx oder IL2302-Bxxx ) ganz ohne Erweiterungs-Box-Module (IExxxx) betreiben möchten, müssen Sie Sende- und Empfangs-Anschluss diese Koppler-Box über ein IP-Link-Kabel direkt miteinander verbinden! Hierfür eignet sich besonders der IP-Link-Verbindungsstecker ZK1020-0101-1000.


Feldbus Box Zubehör

Das notwendige Zubehör für die Feldbus Box Module gibt es in Schutzklasse IP67 ebenfalls von Beckhoff. Eine Übersicht entnehmen Sie bitte aus dem Beckhoff Katalog oder unseren Internet-Seiten (http://www.beckhoff.de).

Feldbuszubehör

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Spannungsversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Sensorversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

IP-Link

  • Vorkonfektionierte Kabel
  • Stecker


PROFIBUS-Zubehör

Dieses Zubehör können Sie auch für andere RS485-basierte Feldbussysteme (Modbus, RS485) verwenden.

PROFIBUS-Kabel

Bestelldaten

Bestellbezeichnung | Feldbuskabel | Verbinder | Kontakte | Querschnitt | Länge | Abb.
ZK1031-6200-1020 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 2,00 | A
ZK1031-6200-1050 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 5,00 | A
ZK1031-6200-1100 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 10,00 | A
ZK1031-6200-1150 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 15,00 | A
ZK1031-6100-1020 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 2,00 | B
ZK1031-6100-1050 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 5,00 | B
ZK1031-6100-1100 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 10,00 | B
ZK1031-6100-1150 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 15,00 | B
ZK1031-6251-1003 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 0,30 | A und B
ZK1031-6251-1005 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 0,50 | A und B
ZK1031-6251-1010 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 1,00 | A und B
ZK1031-6251-1020 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 2,00 | A und B
ZK1031-6251-1050 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 5,00 | A und B
ZK1031-6251-1100 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 10,00 | A und B
ZK1031-6251-1150 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 15,00 | A und B

Add PROFI cable.jpg (10647 Byte)

Stecker

PB_Buchse_klein.gif (11264 Byte) PB_Stecker_klein.gif (13122 Byte)

Pinbelegung

Profibus_IP_Pins_FeMale.gif (3009 Byte) Profibus_IP_Pins_Male.gif (3149 Byte) 1 nc.
2 grün
3 nc.
4 rot
5 Shield

Technische Daten

Elektrische Daten |
Bemessungsdaten | 300 V, 80°C
Material | Außenmantel PUR, Innere Isolierung Polyethylen
Querschnitt | 0,32 mm²
DC Widerstand | 54,12 Ohm/km
Leitungskapazität | 26,9 pF/m
Nominal-Impedanz | 150 Ohm bei 1 MHz
Zulassung | UL-Zulassung, AWM, Typ 20233, 80°C, 300V; CSA AWM, I/II A/B, 80°C, 300V FT1

Zubehör PROFIBUS

Bestelldaten

Bestellbezeichnung | Beschreibung
ZS1031-2600 | T-Stück, 12 MBaud
ZS1000-2600 | Y-Stück, 12 MBaud
ZS1000-1610 | Endwiderstand (Stecker)
ZS1000-0620 | Kupplung feldkonfektionierbar
ZS1000-0610 | Stecker feldkonfektionierbar
ZS1031-6610 | Schaltschrank Durchführung M12, Stecker-Kupplung

ZS1031-2600

PB T conector size.gif (37847 Byte) Add PROFI T-connector diag.gif (5258 Byte)

ZS1000-2600

Add PROFI Y-connector.gif (17718 Byte) Add PROFI Y-connector diag.gif (5090 Byte)

ZS1000-1610

Add Profibus End.gif (7936 Byte)

ZS1031-6610

Add Profibus ZS1031-6610.gif (6530 Byte)


Konfigurationssoftware KS2000

Die Konfigurationssoftware KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung der Buskoppler und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Buskoppler/Feldbus Box und PC wird über ein serielles Konfigurationskabel hergestellt.

Hinweis | Um mit der KS2000 Software eine Verbindung zu ermöglichen ist es wichtig, beim IP/ILxxxx-B730 die richtige Multipoint-Adresse (0) einzustellen. Bei der KS2000 Software können Sie diese unter Menupunkt Einstellung der COM-Schnittstelle parametrieren.
Hinweis | Bei allen seriellen Geräten ( IP/ILxxxx-B730) ist es nicht möglich gleichzeitig eine Verbindung zur KS2000 und einen zyklischen Datenaustausch zu betreiben.
Hinweis | Achten Sie darauf, dass die richtige Baudrate in der KS2000-Software eingestellt ist. Wenn Sie zuvor mit dem seriellen Modul einen zyklischen Datenaustausch bei 38,4 kBaud durchgeführt haben, müssen Sie in der KS2000 Software auch 38,4 kBaud einstellen (Default: 19,2 kBaud).


Allgemeine Betriebsbedingungen

Schutzarten nach IP-Code

In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.

1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub

2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist

*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.

Chemische Beständigkeit

Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus Box und den verwendeten Metallteilen.

Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende

beständig: Lebensdauer mehrere Monate
bedingt beständig: Lebensdauer mehrere Wochen
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zulassungen

UL E172151

Konformitätskennzeichnung

CE

Schutzart

IP65/66/67 gemäß EN60529


Prüfnormen für die Geräteprüfung

EMV

Festigkeit: EN 61000-6-2

Aussendung: EN 61000-6-4

Vibrationsfestigkeit

Schwingungsprüfung: EN 60068-2-2, Amplitude 2 g (Norm 1 g)

Schockprüfung: EN 60068-2-27, Schockanzahl 1000 (Norm 2)


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Verkabelung des IP-Link

IP-Link ist das Sub-Bussystem der Feldbus Boxen. Die Topologie ist eine Ringstruktur. In der Koppler Box (IL230x-Bxxx oder IL230x-Cxxx) befindet sich der IP-Link-Master. Die Erweiterungsboxen (IExxxx) sind Slaves. Es dürfen max. 120 Erweiterungsboxen angeschlossen werden. Berücksichtig werden muss aber auch der Adressraum, den der jeweilige Feldbus-Master zur Verfügung stellt. Der Abstand zwischen zwei Erweiterungsboxen darf 15 Meter nicht überschreiten. Beachten Sie bei Planung und Installation der Erweiterungsboxen, dass die letzte Erweiterungsbox des LWL-Rings wieder an der Koppler Box angeschlossen werden muss.

Aufbau/Topologie

Aufbau einer Linie

Hierbei wird nur jede zweite Erweiterungsboxen angeschlossen. Es ist hierbei zu beachten das sich die maximale Entfernung zwischen zwei Boxen halbiert.

Beispiel

Sie haben 4 Erweiterungsboxen (4 x 15 m = 60 m). Weil nur jede zweite Erweiterungsbox an der Hinleitung angeschlossen wird, ergibt sich für die letzte Erweiterungsbox eine maximale Entfernung von 30 Meter zum Koppler.

IL-Link Vekabelung Linie.jpg (13508 Byte)

Aufbau eines Rings

Hierbei dürfen die erste und die letzte Erweiterungsbox jeweils maximal 15 Meter von der Koppler Box entfernt sein.

IL-Link Vekabelung Ring.jpg (15983 Byte)

Technische Daten

IP-Link
 | IP-Link
Baud-Rate | 2 MBaud
Medium | Licht
Anzahl der Teilnehmer | max. 120
Länge zwischen zwei Stationen | 15 m
Kabel | Kunststoff-Lichtwellenleiter 1000 um - Kern 1-adrig, PU Schutzmantel mit Kevlarfaser Durchmesser 5,5 mm
IP-Link Stecker | zugelassen nur ZS1020-0010
Ausziehkräfte | 20 N - 30 N
IP-Link Kabel Z1101
 | Z1101
Außendurchmesser Nennwert | 5,5 mm
Mantelwanddicke | 1,4 mm
Faser | Kunststoff LWL 980/1000 µm aus PMMA
Ader | PE Aderhülle, Nenndurchmesser 2,2 mm
Temperatur | -20...+70°C
Außenmantelwerkstoff | PUR
Gewicht Nennwert kg/km | 25
Zugfestigkeit (DIN VDE 0888 Teil 100V erf.501) | dauernd 100 N kurzzeitig 400 N
Biegeradien | Radius minimal 50 mm
Wechselbiegefestigkeit (DIN VDE 0888 Teil100 Verf.509) | 30.000 Zyklen
Schleppkettenprüfung | Radius 10 X Dm., 2 Millionen Zyklen
Dämpfung bei 650 nm | < 200 dB/km