FBB-x310 - Feldbus-Box-Module für PROFIBUS

BECKHOFF Feldbuskomponenten

Dokumentation für

Feldbus-Box-Module für PROFIBUS

Version: 1.2.1
Datum: 29.10.2009


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Version | Änderungen
1.2.1
  • Systemübersicht aktualisiert
1.2
  • Überprüfung der IP-Link-Verbindung hinzugefügt
1.1
  • Erweiterung der Spezifikation des IP-Links auf 15 Meter
1.0
  • PROFIBUS-spezifische Inhalte vervollständigt
  • Signalvarianten und Anschlussbelegung der Signale in die Feldbus-neutrale Dokumentation Signalvarianten (Feldbus Box E/A-Module) ausgelagert, die Sie im Internet unter http://www.beckhoff.de im Bereich Download finden.
0.7 | Weitere Feldbus Box Module für Sonderfunktionen hinzugefügt.
0.6 | Feldbus Box Module für analoge Signale und Sonderfunktionen hinzugefügt.
0.4 | Feldbus Box Module hinzugefügt.
0.3 | Erste veröffentlichte Version.


Das Feldbus Box System

Feldbus Box Module sind robuste Feldbusstationen für viele verschiedene Feldbus-Systeme. Sie verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Neben digitalen und analogen Ein- und Ausgängen samt Thermoelement- und RTD-Eingängen gibt es Inkrementalencoder-Interfaces für die Weg- und Winkelmessung sowie serielle Schnittstellen für die Lösung vielfältiger Kommunikationsaufgaben.

Signalanschluss in 3 Varianten

Die digitalen Ein-/Ausgänge können wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12-Variante vorgesehen.

Alle wichtigen Signalformen

Spezielle Ein-/Ausgangskanäle auf den Kombi-E/A-Module lassen sich wahlweise als Ein- oder Ausgang nutzen. Eine Konfiguration ist nicht erforderlich, da die Feldbusschnittstelle für jeden Kombikanal sowohl Eingangs- als auch Ausgangsdaten zur Verfügung stellt. Durch die Kombi-Module hat der Anwender alle Vorteile einer feinen Signal-Granularität.

Die Prozessor-Logik, die Eingangsbeschaltung sowie die Sensorversorgung werden aus der Steuerspannung gespeist. Die Lastspannung für die Ausgänge kann separat zugeführt werden. Bei Feldbus Boxen, in denen nur Eingänge zur Verfügung stehen, kann die Lastversorgung UP zur Weiterleitung optional angeschlossen werden.

Die Zustände der Feldbus Box, der Feldbusverbindung, der Spannungsversorgung sowie der Signale werden von LEDs angezeigt.

Die Beschriftungsstreifen lassen sich extern maschinell beschriften und können dann eingeschoben werden.

Kombinierbare Feldbus Boxen für mehr Flexibilität

Die Feldbus Box Serie umfasst neben der Kompakt Box auch erweiterbare Geräte, die Koppler Box und die Erweiterungsbox sowie intelligente Geräte, die SPS Boxen.

Kompakt Box

Die Kompakt Box stellt dem Feldbus die E/A-Daten der angeschlossenen digitalen und analogen Sensoren und Aktuatoren zur Verfügung.

Koppler Box

Die Koppler Box sammelt zusätzlich über eine störsichere LWL-Verbindung (IP-Link) E/A-Daten von den Erweiterungsboxen ein. Sie können bis zu 120 Erweiterungsboxen an eine Koppler Box anschließen. Es ergibt sich so ein verteiltes IP67 E/A-Netzwerk mit nur einer Feldbusschnittstelle.

Die Koppler Box erkennt die angeschlossenen Erweiterungsmodule selbsttätig in der Aufstart-Phase und mappt die E/A-Daten automatisch in das Feldbus-Prozessabbild – eine Konfiguration ist nicht erforderlich. Aus Sicht des Feldbusses stellt sich die Koppler Box samt allen vernetzten Erweiterungsboxen als ein einziger Busteilnehmer mit entsprechend vielen E/A-Signalen dar.

Die Koppler Box entspricht dem Buskoppler aus dem BECKHOFF Busklemmen-System. BECKHOFF Feldbus-Geräte der Schutzart IP 20 (Busklemmen) und IP 67 (Feldbus Box) können problemlos kombiniert werden - das Daten-Handling ist jeweils gleich.

IP-Link

IP-Link ist eine LWL-Verbindung mit 2 Megabit/s Übertragungsrate, die 1000 binäre E/A-Daten in ca. 1 ms schnell und sicher überträgt – kleinere Konfigurationen entsprechend schneller. Durch die hohe Nutzdatenrate ist gewährleistet, dass die Kopplung über IP-Link keine spürbare Einschränkung der Feldbus-Performance mit sich bringt.

Für die schnelle und einfache Konfektionierung der IP-Link-Kabel vor Ort wurden preisgünstige Steckverbinder in IP 67 Schutzart entwickelt. Der Anschluss erfordert kein Spezialwerkzeug und lässt sich schnell und einfach durchführen. Die IP-Link-Kabel sind alternativ auch mit vorkonfektionierten Steckern erhältlich.

Durch die getrennte Zuführung der Ausgangs-Spannungsversorgung lassen sich Ausgangsgruppen einzeln abschalten. Außerdem können problemlos unterschiedliche Potenziale innerhalb eines Erweiterungsringes aufgebaut werden, da IP-Link naturgemäß über eine optimale Potenzialtrennung verfügt.

Erweiterungsbox

Die Erweiterungsboxen decken wie die Kompakt Boxen das gesamte Spektrum der E/A-Signale ab und dürfen bis zu 15 m Abstand voneinander haben. Sie bauen hierbei besonders klein und führen zu besonders preiswerten E/A-Lösungen in hoher Schutzart. Auch hier sind die digitalen Ein-/Ausgänge wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder anschließbar. Analoge Signaltypen werden mit der M12-Variante ausgerüstet. Die Schnapp-Steckverbinder verriegeln formschlüssig und ergeben eine rüttelfeste Verbindung, während sich die Schraub-Steckverbinder durch eine hohe Zugfestigkeit auszeichnen.

SPS Box

Die SPS Box ist eine intelligentes Feldbus Box mit SPS-Funktionalität für dezentrale Vorverarbeitung der E/A-Signale. Hiermit lassen sich Applikationsteile aus der zentralen Steuerung auslagern. Deren CPU und der Feldbus werden entlastet. Dezentral Zählen, Regeln oder Schalten sind typische Anwendungen für die SPS-Box. Die Reaktionszeiten sind unabhängig von der Buskommunikation und der übergeordneten Steuerung.

Bei Bus- oder Steuerungsausfall ist ein Funktionserhalt (z.B. geordnete Überführung des Prozesses in einen sicheren Zustand) möglich.

Die Programmierung erfolgt mit TwinCAT nach IEC 61131-3. Fünf verschiedene Programmiersprachen stehen zur Verfügung:

  • Anweisungsliste (AWL)

  • Funktionsplan (FUP)

  • Kontaktplan (KOP)

  • Ablaufsprache (AS)

  • Strukturierter Text (ST).

Der Programm-Download erfolgt wahlweise über den Feldbus oder über die Programmierschnittstelle.

Es stehen umfangreiche Debug-Funktionalitäten (Breakpoint, Einzelschritt, Monitoring, etc.) zur Verfügung. SPS Box verfügt über einen leistungsfähigen 16 Bit Controller, 32/96 KByte Programmspeicher und 32/64 KByte Datenspeicher. Weiter stehen 512 Byte als nichtflüchtiger Speicher für remanente Merker zur Verfügung.

SPS Box mit IP-Link

Nahezu unbeschränkte E/A-Möglichkeiten ergeben sich durch die programmierbare SPS Box mit IP-Link. Aus dem SPS-Programm heraus lassen sich bis zu 120 Erweiterungsmodule mit über 2000 E/As direkt ansprechen. Die SPS Box eignet sich damit auch als autarke Kleinsteuerung zur Steuerung von Anlagenteilen oder kleiner Maschinen.


Feldbus Box - Bezeichnungsübersicht

Die Bezeichnung der Feldbus Box Module ist wie folgt zu verstehen:
IXxxxy-zyyy

IX beschreibt die Bauform:

"IP" steht für die Bauform Kompakt Box.
"IL" steht für die Bauform Koppler Box (mit IP-Link).
"IE" steht für die Bauform Erweiterungsbox.

xxxy beschreibt die E/A-Beschaltung:

xxx bezeichnet die E/A-Eigenschaft:
"10x" - 8 x digitale Eingänge
"15x" - Zählermodul
"20x" - 8 x digitale Ausgänge
"23x" - 4 x digitale Eingänge und 4 x digitale Ausgänge
"24x" - 8 x digitale Eingänge und 8 x digitale Ausgänge
"25x" - PWM-Modul
"3xx" - 4 x analoge Eingänge
"4xx" - 4 x analoge Ausgänge
"5xx" - Inkremental-Encoder oder SSI-Geber
"6xx" - Gateway-Module RS232, RS422, RS485, TTY

y beschreibt den mechanischer Anschluss:
"0" steht für 8mm Schnappanschluss
"1" steht für M 8 Schraubanschluss
"2" steht für M 12 Schraubanschluss und
"9" steht für M23 Schraubanschluss

zyyy bezeichnet die Programmierbarkeit und das Feldbus-System:

z unterscheidet ob es sich um einen Slave oder einen programmierbare Slave handelt:
"B" - nicht programmierbar
"C" - programmierbar (SPS Box)

yyy steht für das Feldbus-System und den Bus-Anschluss:
"110" - EtherCAT
"200" - Lightbus
"310" - PROFIBUS
"318" - PROFIBUS mit integriertem T-Stück
"400" - Interbus
"510" - CANopen
"518" - CANopen mit integriertem T-Stück
"520" - DeviceNet
"528" - DeviceNet mit integriertem T-Stück
"730" - Modbus
"800" - RS485
"810" - RS232
"900" - Ethernet TCP/IP mit RJ45 für den Bus-Anschluss
"901" - Ethernet TCP/IP mit M12 für den Bus-Anschluss
"903" - PROFINET
"905" - EtherNet/IP

Kompakt Box

Die Feldbus Boxe verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Die digitalen Ein-/Ausgänge können wahlweise über Ø 8 mm Schnapp-, M8 Schraub- oder über M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12 Variante verfügbar.

Je nach Modul kann der E/A-Teil und der Stromversorgungsteil unterschiedlich sein.

Koppler Box

Die Koppler Box gibt es in drei Varianten als IL230x-Bxxx. Diese unterscheidet sich von der Kompakt Box dadurch, dass diese Module eine Schnittstelle zu den sogenannten Erweiterungsboxen bietet. Diese Schnittstelle ist ein Sub-Bussystem auf LWL Basis den sogenannten IP-Link. Dieses leistungsfähige Sub-Bussytem kann bis zu 120 Erweiterungsboxen an einer Koppler Box verarbeiten.

Erweiterungsbox

Feldbusunabhängige Erweiterungsmodule, die nur an einer Koppler Box über IP-Link betrieben werden können.

SPS Box

Eine SPS Box unterscheidet sich von einer Koppler Box dadurch, dass sie in IEC 61131-3 programmierbar ist. Dadurch kann dieser Slave auch ohne Master autonom arbeiten, zum Beispiel für Steuerungs- oder Regelungsaufgaben.


Firm- und Hardware-Stand

Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Hard- und Firmware-Stand. Die Eigenschaften werden weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben wie Module neue Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das diese Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand der Module können Sie anhand der mit einem D beginnenden Nummer auf der Seite des Moduls erkennen.

Syntax:

D . ww yy x y z u

ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel:

D.22081501

- Kalenderwoche 22
- des Jahres 2008
- Firmware-Stand Busplatine: 1
- Hardware Stand Busplatine: 5
- Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig)
- Hardware-Stand E/A-Platine: 1


Module - Technische Daten

Technische Daten | IPxxxx-B31x | IL230x-B310, IL230x-C310
Erweiterungsmodule | - | max. 120 mit insgesamt 128 Bytes Ein- und 128 Byte Ausgänge
Digitale Peripheriesignale | entsprechend E/A-Variante | max. 960 Ein- und Ausgänge
Analoge Peripheriesignale | entsprechend E/A-Variante | max. 60 Ein- und Ausgänge
Konfigurationsmöglichkeiten | über KS2000, über die Steuerung (Registerkommunikation, DPV1, oder Parameter Daten) | über KS2000, über die Steuerung (Registerkommunikation oder DPV1)
Baud-Rate | automatische Erkennung bis 12 MBaud
Stromversorgung | Steuerspannung: 24V DC (-15%/+20%); Lastspannung: entsprechend E/A Variante
Stromaufnahme Steuerspannung | entsprechend E/A- Variante + Stromaufnahme Sensorversorgung, max. 0,5A
Stromaufnahme Lastspannung | entsprechend E/A- Variante
Anschluss Stromversorgung | Einspeisung: 1 x M8 Stecker 4-polig Weiterleitung: 1 x M8 Buchse 4-polig (außer IP/IE204x)
Anschluss Feldbus | 1 x M12 5-polig Buchse (inverse Codierung)
Potentialtrennung | Kanäle / Steuerspannung: nein zwischen den Kanälen: nein Steuerspannung / Feldbus: ja
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... +55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 65/66/67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassung | CE, UL E172151


Controller Box - Technische Daten

BECKHOFF Feldbus Box: Produktübersicht

Controller - Technische Daten

PLC Daten | IL230x-C31x
Programmiermöglichkeit | über Programmierschnittstelle (TwinCAT) oder über PROFIBUS (TwinCAT mit FC310x)
Programmspeicher | 32/96 kByte
Datenspeicher | 32/64 kByte
Remanente Merker | 512 Byte
SPS-Zykluszeit | ca. 3 ms für 1000 AWL-Befehle (ohne E/A-Zyklus)
Programmiersprachen | IEC 6-1131-3 (AWL, KOP, FUP, ST, AS)


FBB E/A-Module - Stromverbrauch

BECKHOFF Feldbus Box: Verkabelung

Stromverbrauch

Für die Stromweiterleitung und der Absicherung der Module sowie bei der Betrachtung des Spannungsabfall auf der Powerleitungsversorgung ist es wichtig, den Stromverbrauch der einzelnen Module zu kennen. Die nachfolgende Tabelle enthält den Stromverbrauch bei 24 VDC.

Die Sensorversorgung bzw. der Strom für evtl. Ausgänge muss dazu addiert werden.

E/A-Type Kompakt-Box
Module | −B310 | −B510, −B520 | −B730, −B800, −B810
IP1000−Bxxx, IP1001−Bxxx, IP1002−Bxxx, IP1010−Bxxx, IP1011−Bxxx, IP1012−Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP1502-Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2000−Bxxx, IP2001−Bxxx, IP2002−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2020−Bxxx, IP2021−Bxxx, IP2022−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2040−Bxxx, IP2041−Bxxx, IP2042−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2300−Bxxx, IP2301−Bxxx, IP2302−Bxxx, IP2310−Bxxx, IP2311−Bxxx, IP2312−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2320−Bxxx, IP2321−Bxxx, IP2322−Bxxx, IP2330−Bxxx, IP2331−Bxxx, IP2332−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2400−Bxxx, IP2401−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2512−Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP3102−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP3112−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP3202−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP3312−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP4112−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP4132−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5009−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5109−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5209−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP6002−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP6012−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP6022−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
E/A−Type Koppler Box
Module | −B310 | −B510, −B520 | −B730, −B800, −B810
IL2300−Bxxx, IL2301−Bxxx, IL2302−Bxxx | Is = 100 mA Ip = 5 mA | Is = 60 mA Ip = 5 mA | Is = 60 mA Ip = 5 mA
IL2300−Cxxx, IL2301−Cxxx, IL2302−Cxxx | Is = 100 mA Ip = 5 mA | − | −
E/A−Type Erweiterungsbox
Module |
IE1000, IE1001, IE1002, IE1010, IE1011, IE1012 | Is = 25 mA Ip = 5 mA
IE1502 | Is = 25 mA Ip = 5 mA
IE2000, IE2001, IE2002 | Is = 25 mA Ip = 5 mA
IE2020, IE2021, IE2022 | Is = 25 mA Ip = 5 mA
IE23xx, IE240x | Is = 25 mA Ip = 5 mA
IE2512 | Is = 25 mA Ip = 5 mA
IE2808 | Is = 40 mA Ip = 5 mA
IE3102 | Is = 55 mA Ip = 5 mA
IE3112 | Is = 55 mA Ip = 5 mA
IE3202 | Is = 40 mA Ip = 5 mA
IE3312 | Is = 40 mA Ip = 5 mA
IE4112 | Is = 40 mA Ip = 5 mA
IE4132 | Is = 40 mA Ip = 5 mA
IE5009 | Is = 55 mA Ip = 5 mA
IE5109 | Is = 55 mA Ip = 5 mA
IE6002 | Is = 40 mA Ip = 5 mA
IE6012 | Is = 40 mA Ip = 5 mA
IE6022 | Is = 40 mA Ip = 5 mA


Feldbusübersicht

PROFIBUS ist ein herstellerunabhängiger, offener Feldbusstandard mit breitem Anwendungsbereich in der Fertigungs- und Prozessautomatisierung. Herstellerunabhängigkeit und Offenheit sind durch die internationalen Normen EN 50170 und EN 50254 garantiert. PROFIBUS ermöglicht die Kommunikation von Geräten verschiedener Hersteller ohne besondere Schnittstellenanpassungen. PROFIBUS ist sowohl für schnelle, zeitkritische Anwendungen , als auch für komplexe Kommunikationsaufgaben geeignet.

PROFIBUS bietet funktional abgestufte Kommunikationsprotokolle: DP und FMS. Als Übertragungstechniken stehen hierfür, je nach Anwendungsbereich, RS-485, IEC 1158-2 oder Lichtwellenleiter zur Verfügung.

PROFIBUS legt die technischen Merkmale eines seriellen Feldbussystems fest, mit dem verteilte digitale Automatisierungsgeräte von der Feldebene bis zur Zellenebene miteinander vernetzt werden können. PROFIBUS ist ein Multi-Master System und ermöglicht dadurch den gemeinsamen Betrieb von mehreren Automatisierungs-, Engineering- oder Visualisierungssystemen mit den dezentralen Peripheriegeräten an einem Bus.

PROFIBUS Gerätetypen

PROFIBUS unterscheidet folgende Gerätetypen:

Master-Geräte bestimmen den Datenverkehr auf dem Bus. Ein Master darf Nachrichten ohne externe Aufforderung aussenden, wenn er im Besitz der Buszugriffsberechtigung (Token) ist. Master werden auch als aktive Teilnehmer bezeichnet.

Slave-Geräte sind Peripheriegeräte wie beispielsweise Ein-/Ausgangsgeräte, Ventile, Antriebe, Messumformer und die Beckhoff PROFIBUS-Slaves der Reihe BK3xx0, BC3xx0, IPxxxx-B310, IL230x-B310 und IL230x-C310. Sie erhalten keine Buszugriffsberechtigung, d.h. sie dürfen nur empfangene Nachrichten quittieren oder auf Anfrage eines Masters Nachrichten an diesen übermitteln. Slaves werden als passive Teilnehmer bezeichnet. Sie benötigen nur einen geringen Anteil des Busprotokolls, dadurch wird eine aufwandsarme Implementierung ermöglicht.

PROFIBUS-DP

PROFIBUS-DP ist für den effizienten Datenaustausch in der Feldebene konzipiert. Hier kommunizieren die zentralen Automatisierungsgeräte, wie z.B. SPS/PC oder Prozessleitsysteme, über eine schnelle serielle Verbindung mit dezentralen Feldgeräten wie E/A, Antriebe, Ventile etc. Der Datenaustausch mit den dezentralen Geräten erfolgt vorwiegend zyklisch. Die dafür benötigten Kommunikationsfunktionen sind durch die DP-Grundfunktionen gemäß EN 50170 festgelegt.

Über diese Grundfunktionen hinaus bietet PROFIBUS-DP auch erweiterte azyklische Kommunikationsdienste für zum Beispiel Parametrierung und Bedienung welche auch durch die Beckhoff PROFIBUS-Slaves der Reihe IPxxxx-B310, IL230x-B310 und IL230x-C310 unterstützt werden. Eine zentrale Steuerung (Master) liest zyklisch die Eingangsinformationen von den Slaves und schreibt die Ausgangsinformationen zyklisch an die Slaves. Hierbei sollte die Buszykluszeit kürzer sein als die Programmzykluszeit des zentralen Automatisierungssystems, die in vielen Anwendungen etwa 10 ms beträgt.

Ein hoher Datendurchsatz alleine genügt nicht für den erfolgreichen Einsatz eines Bussystems. Vielmehr muss die einfache Handhabung, gute Diagnosemöglichkeiten und eine störsichere Übertragungstechnik gegeben sein, um die Anforderungen der Anwender zu erfüllen. Bei PROFIBUS-DP wurden diese Eigenschaften optimal kombiniert.

Systemkonfiguration und Gerätetypen

Mit PROFIBUS-DP können Mono- oder Multi-Master-Systeme realisiert werden. Dadurch wird ein hohes Maß ab Flexibilität bei der Systemkonfiguration ermöglicht. Es können maximal 126 Geräte (Master oder Slaves) an einem Bus angeschlossen werden. Mit den Beckhoff PROFIBUS-Slaves der Reihe IPxxxx-B310, IL230x- B310 und IL230x-C310 kann eine Stationsadresse zwischen 0 und 99 gewählt werden. Die Festlegungen zur Systemkonfiguration beinhalten die Anzahl der Stationen, die Zuordnung der Stationsadresse zu den E/A-Adressen, Datenkonsistenz der E/A-Daten, Format der Diagnosemeldungen und die verwendeten Busparameter. Jedes PROFIBUS-DP-System besteht aus unterschiedlichen Gerätetypen. Es werden drei Gerätetypen unterschieden:

Klasse | Beschreibung
DP-Master Klasse 1 (DPM1) z.B. Beckhoff FC310x: PROFIBUS-Masterkarte für PCs | Hierbei handelt es sich um eine zentrale Steuerung, die in einem festgelegten Nachrichtenzyklus zyklisch Informationen mit den dezentralen Stationen (Slaves) austauscht. Typische Geräte sind z.B. Speicherprogrammierbare Steuerungen (SPS) oder PC.
DP-Master Klasse 2 (DPM2) | Geräte dieses Typs sind Engineering-, Projektierungs- oder Bediengeräte. Sie werden bei der Inbetriebnahme und zur Wartung und Diagnose eingesetzt, um die angeschlossenen Geräte zu konfigurieren, Messwerte und Parameter auszuwerten sowie den Gerätezustand abzufragen.
DP-Slave z.B. Beckhoff IPxxxx-B310: Feldbus Box für PROFIBUS | Ein PROFIBUS-DP-Slave ist ein Peripheriegerät (E/A, Antriebe, Messumformer etc.), das Eingangsinformationen einliest und Ausgangsinformationen an die Peripherie abgibt. Es sind auch Geräte möglich, die nur Eingangs- oder nur Ausgangsinformationen bereitstellen. Die Menge der Eingangs- und Ausgangsinformationen ist geräteabhängig und darf max. 246 Byte Eingangs- und 246 Byte Ausgangsdaten betragen.
Mono-Master-Systeme

Bei Mono-Master-Systemen ist in der Betriebsphase des Bussystems nur ein Master am Bus aktiv. Die SPS-Steuerung ist die zentrale Steuerungskomponente. Die Slaves sind über das Übertragungsmedium dezentral an die SPS-Steuerung gekoppelt. Mit dieser Systemkonfiguration wird die kürzeste Buszykluszeit erreicht.

Multi-Master-Betrieb

Im Multi-Master-Betrieb befinden sich an einem Bus mehrere Master. Sie bilden entweder voneinander unabhängige Subsysteme, bestehend aus je einem DPM1 und den zugehörigen Slaves, oder zusätzliche Projektierungs- und Diagnosegeräte. Die Eingangs- und Ausgangsabbilder der Slaves können von allen DP-Mastern gelesen werden. Das Schreiben der Ausgänge ist nur für einen DP-Master (den bei der Projektierung zugeordneten DPM1) möglich. Multi-Master- Systeme erreichen eine mittlere Buszykluszeit. In zeitkritischen Anwendungen sollten Sie die Vergrößerung der Buszykluszeit durch Zuschalten eines Diagnosewerkzeugs beachten.

Gerätestammdatei (GSD)

Bei PROFIBUS-DP werden die Leistungsmerkmale der Geräte in Form eines Gerätedatenblattes und einer Gerätestammdatendatei von den Herstellern dokumentiert und den Anwendern zur Verfügung gestellt. Aufbau, Inhalt und Kodierung dieser Gerätestammdaten (GSD) sind standardisiert. Sie ermöglichen die komfortable Projektierung beliebiger PROFIBUS-DP-Slaves mit Projektierungsgeräten verschiedener Hersteller. Die PROFIBUS-Nutzer-Organisation (PNO) archiviert diese Informationen herstellerübergreifend und gibt auf Anfrage Auskünfte über die GSD aller Hersteller. Die GSD - Daten werden von einer PROFIBUS-Master - Konfigurationssoftware gelesen und entsprechende Einstellungen in den PROFIBUS-Master übertragen. Die Beschreibung entnehmen Sie bitte dem entsprechenden Softwarehandbuch des Masterherstellers.

Die Beckhoff GSD-Dateien sind über das Internet unter http://www.beckhoff.de erhältlich.

Diagnosefunktionen

Die umfangreichen Diagnosefunktionen von PROFIBUS-DP ermöglichen die schnelle Fehlerlokalisierung. Die Diagnose der Beckhoff Buskoppler ist in der Defaulteinstellung der Typdatei und der GSD-Datei nicht eingeschaltet. Die Diagnosemeldungen werden über den Bus übertragen und beim Master zusammengefasst.

Sie werden in drei Ebenen eingeteilt:

Diagnoseart | Beschreibung
Stationsbezogen | Meldungen zur allgemeinen Betriebsbereitschaft eines Teilnehmers wie z.B. Übertemperatur oder Unterspannung
Modulbezogen | Diese Meldungen zeigen an, dass innerhalb eines bestimmten E/A Teilbereichs (z.B. 8 Bit Ausgangs - Modul) eines Teilnehmers eine Diagnose ansteht
Kanalbezogen | Hier wird die Fehlerursache bezogen auf ein einzelnes Ein- / Ausgangs - Bit (Kanal) angegeben, wie z.B. Kurzschluss auf Ausgang 2

Die Beckhoff PROFIBUS-Slaves der Reihe IPxxxx-B310, IL230x-B310 und IL230x-C310 unterstützen die Diagnosefunktionen des PROFIBUS-DP. Die Auswertung der Diagnosedaten über die Steuerung hängt von der Unterstützung des PROFIBUS-Masters ab. Entnehmen Sie bitte den Gerätehandbüchern der Masteranschaltungen die Handhabung der Diagnose.

Sync- und Freeze-Mode

Zusätzlich zu dem Teilnehmer bezogenen Nutzdatenverkehr, der automatisch vom DPM1 abgewickelt wird, besteht für die DP-Master die Möglichkeit, Steuerkommandos an einen, eine Gruppe oder an alle DP-Slaves gleichzeitig zu senden. Diese Steuerkommandos werden als Multicast übertragen. Mit diesen Steuerkommandos können die Sync- und Freeze-Betriebsarten zur Synchronisation der DP-Slaves vorgegeben werden. Sie ermöglichen eine ereignisgesteuerte Synchronisation der DP-Slaves.

Die DP-Slaves beginnen den Sync-Mode, wenn sie vom zugeordneten DP-Master ein Sync-Steuerkommando empfangen. In diesem Betriebszustand werden bei allen adressierten DP-Slaves die Ausgänge auf den momentanen Zustand eingefroren. Bei den folgenden Nutzdatenübertragungen werden die Ausgangsdaten bei den DP-Slaves gespeichert, die Ausgangszustände bleiben jedoch unverändert. Erst beim Empfang des nächsten Sync-Steuerkommandos vom Master werden die gespeicherten Ausgangsdaten an die Ausgänge durchgeschaltet. Mit einem Unsync-Steuerkommando wird der Sync-Betrieb beendet.

Analog dazu bewirkt ein Freeze-Steuerkommando den Freeze-Mode der angesprochenen DP-Slaves. In dieser Betriebsart werden die Zustände der Eingänge auf den momentanen Wert eingefroren. Die Eingangsdaten werden erst dann wieder aktualisiert, wenn der DP-Master das nächste Freeze-Steuerkommando an die betroffenen Geräte gesendet hat. Mit Unfreeze wird der Freeze-Betrieb beendet.

Systemverhalten

Um eine weitgehende Geräteaustauschbarkeit zu erreichen, wurde bei PROFIBUS-DP auch das Systemverhalten standardisiert. Es wird im wesentlichen durch den Betriebszustand des DPM1 bestimmt. Dieser kann entweder lokal oder über den Bus vom Projektierungs-Gerät gesteuert werden.

Es werden folgende drei Hauptzustände unterschieden:

Betriebsart | Beschreibung
Stop | Es findet kein Datenverkehr zwischen dem DPM1 und den DP-Slaves statt. Der Buskoppler spricht die Busklemmen nur einmal nach dem Einschalten der Versorgungsspannung an (keine der E/A - LEDs leuchtet).
Clear | Der DPM1 liest die Eingangsinformationen der DP-Slaves, und hält die Ausgänge der DP-Slaves im sicheren Zustand (Abhängig von der Reaktion auf Feldbusfehler leuchtet die grüne E/A-LED und werden die Ausgänge gesetzt).
Operate | Der DPM1 befindet sich in der Datentransferphase. In einem zyklischen Datenverkehr werden die Eingänge von den DP - Slaves gelesen und die Ausgangsinformationen an die DP-Slaves übertragen (Die grüne E/A-LED leuchtet).

Der DPM1 sendet seinen lokalen Status in einem konfigurierbaren Zeitintervall mit einem Multicast-Kommando zyklisch an alle ihm zugeordneten DP-Slaves. Die Systemreaktion nach dem Auftreten eines Fehlers in der Datentransferphase des DPM1, wie z. B. Ausfall eines DP-Slaves, wird durch den Betriebsparameter Auto-Clear bestimmt. Wurde dieser Parameter auf True gesetzt, dann schaltet der DPM1die Ausgänge aller zugehörigen DP-Slaves in den sicheren Zustand, sobald ein DP-Slave nicht mehr bereit für die Nutzdatenübertragung ist. Danach wechselt der DPM1 in den Clear-Zustand. Ist dieser Parameter False, dann verbleibt der DPM1 auch im Fehlerfall im Operate-Zustand und der Anwender kann die Systemreaktion selbst bestimmen.

Datenverkehr zwischen DPM1 und den DP-Slaves

Der Datenverkehr zwischen dem DPM1 und den ihm zugeordneten DP-Slaves wird in einer festgelegten immer wiederkehrenden Reihenfolge automatisch durch den DPM1 abgewickelt. Bei der Projektierung des Bussystems legt der Anwender die Zugehörigkeit eines DP-Slaves zum DPM1 fest. Weiterhin wird definiert, welche DP-Slaves in den zyklischen Nutzdatenverkehr aufgenommen oder ausgenommen werden sollen.

Der Datenverkehr zwischen dem DPM1 und den DP-Slaves gliedert sich in die Phasen Parametrierung, Konfigurierung und Datentransfer.

Bevor ein DP-Slave in die Datentransferphase aufgenommen wird, prüft der DPM1 in der Parametrierungs- und Konfigurations-Phase, ob die projektierte Sollkonfiguration mit der tatsächlichen Gerätekonfiguration übereinstimmt. Bei dieser Überprüfung muss der Gerätetyp, die Format- und Längeninformationen sowie die Anzahl der Ein- und Ausgänge übereinstimmen. Der Benutzer erhält dadurch einen zuverlässigen Schutz gegen Parametrierungsfehler. Zusätzlich zum Nutzdatentransfer, der vom DPM1 automatisch durchgeführt wird, besteht die Möglichkeit neue Parametrierungsdaten auf Anforderung des Benutzers an die DP-Slaves zu senden.

Schutzmechanismen

Im Bereich der dezentralen Peripherie ist es aus Sicherheitsgründen erforderlich, die Systeme mit hochwirksamen Schutzfunktionen gegen Fehlparametrierung oder Ausfall der Übertragungseinrichtungen zu versehen. PROFIBUS-DP verwendet Überwachungsmechanismen beim DP-Master und bei den DP-Slaves. Sie werden als Zeitüberwachungen realisiert. Das Überwachungsintervall wird bei der Projektierung des DP-Systems festgelegt.

Schutzmechanismen | Beschreibung
Auf dem DP-Master | Der DPM1 überwacht den Nutzdatentransfer der Slaves mit dem Data_Control_Timer. Für jeden zugeordneten Slave wird ein eigener Überwachungszeitgeber benutzt. Die Zeitüberwachung spricht an, wenn innerhalb eines Überwachungsintervalls kein ordnungsgemäßer Nutzdatentransfer erfolgt. In diesem Fall wird der Benutzer informiert. Falls die automatische Fehlerreaktion (Auto_Clear =True) freigegeben wurde, verlässt der DPM1 den Zustand Operate, schaltet die Ausgänge der zugehörigen Slaves in den sicheren Zustand und geht in den Betriebszustand Clear über.
Auf dem DP-Slave | Der Slave führt zur Erkennung von Fehlern des Masters oder der Übertragungsstrecke die Ansprechüberwachung durch. Findet innerhalb des Ansprechüberwachungsintervalls kein Datenverkehr mit dem zugeordneten Master statt, dann schaltet der Slave die Ausgänge selbständig in den sicheren Zustand. Zusätzlich ist für die Ein- und Ausgänge der Slaves beim Betrieb in Multi - Master - Systemen ein Zugriffsschutz erforderlich damit sichergestellt ist, dass der direkte Zugriff nur vom berechtigten Master erfolgt. Für alle anderen Master stellen die Slaves ein Abbild der Eingänge und Ausgänge zur Verfügung, das von jedem beliebigen Master auch ohne Zugriffsberechtigung gelesen werden kann.

Ident-Nummer

Jeder DP-Slave und jeder DPM1 muss eine individuelle Ident-Nummer haben. Sie wird benötigt, damit ein DP-Master ohne signifikanten Protokoll-Overhead die Typen der angeschlossenen Geräte identifizieren kann. Der Master vergleicht die Ident-Nummer der angeschlossenen DP-Geräte mit den Ident-Nummern in den vom DPM2 vorgegebenen Projektierungsdaten. Der Nutzdatentransfer wird nur dann begonnen, wenn die richtigen Geräte-Typen mit den richtigen Stationsadressen am Bus angeschlossen wurden. Dadurch wird Sicherheit gegenüber Projektierungsfehlern garantiert. Die Vergabe der Herstellerspezifischen Ident-Nummern erfolgt durch die PROFIBUS Nutzerorganisation (PNO). Die PNO verwaltet die Ident-Nummern zusammen mit den Gerätestammdaten (GSD).


Topologie

  • Ein Bussegment darf aus maximal 32 Teilnehmern bestehen (einschließlich den Repeatern).
  • Die maximale Leitungslänge eines Segmentes ist abhängig von der verwendeten Übertragungsgeschwindigkeit und der Qualität der verwendeten Busleitung.
  • Zwischen zwei Teilnehmer dürfen maximal 9 Repeater installiert werden.
  • Stichleitungen sind zu vermeiden und ab 1,5 MBaud nicht zulässig.
  • Maximale Anzahl an Teilnehmern 127
  • Unterbrechung der Versorgungsspannung von Leitungsabschlüssen durch abschalten des Repeaters/Slave oder abziehen des Steckers ist nicht zulässig.

Abb. 1: RS485-Topologie mit 3 Segmenten und 2 Repeatern.


Busaufbau

Beispiel für einen Busaufbau mit Profibus

PB_Overview.jpg (123912 Byte)


PROFIBUS-Verkabelung

Die physikalische Datenübertragung ist in der PROFIBUS-Norm definiert (siehe PROFIBUS Schicht 1: Physical Layer).

Der Einsatzbereich eines Feldbus-Systems wird wesentlich durch die Wahl des Übertragungs-Mediums und der physikalischen Busschnittstelle bestimmt. Neben den Anforderungen an die Übertragungssicherheit sind die Aufwendungen für Beschaffung und Installation des Buskabels von entscheidender Bedeutung. Die PROFIBUS-Norm sieht daher verschiedene Ausprägungen der Übertragungstechnik unter Beibehaltung eines einheitlichen Busprotokolls vor.

Kabelgebundene Übertragung

Diese Version, gemäß dem US-Standard EIA RS-485, wurde als Grundversion für Anwendungen im Bereich der Fertigungstechnik, Gebäudeleittechnik und Antriebstechnik festgelegt. Es wird ein verdrilltes Kupferkabel mit einem Leiterpaar verwendet. Die Abschirmung kann in Abhängigkeit des beabsichtigten Einsatzgebietes (EMV-Gesichtspunkte beachten) entfallen.

Es stehen zwei Leitungstypen mit unterschiedlichen Höchstleitungslängen zur Verfügung (siehe Tabelle RS485).

RS485 - Grundlegende Eigenschaften
RS-485 Übertragungstechnik nach PROFIBUS-Norm
Netzwerk Topologie | Linearer Bus, aktiver Busabschluss an beiden Enden, Stichleitungen sind möglich
Medium | Abgeschirmtes verdrilltes Kabel, Schirmung darf abhängig von den Umgebungsbedingungen (EMV) entfallen
Anzahl der Stationen | 32 Stationen in jedem Segment ohne Repeater. Mit Repeater erweiterbar bis 127 Stationen
Max. Bus Länge ohne Repeater | 100 m bei 12 MBit/s 200 m bei 1500 KBit/s, bis zu 1,2 km bei 93,75 KBit/s
Max. Bus Länge mit Repeater | Durch Leitungsverstärker (Repeater) kann die max. Buslänge bis zu 10 km vergrößert werden. Die Anzahl der möglichen Repeater ist mindestens 3 und kann je nach Hersteller bis zu 10 betragen.
Übertragungsgeschwindigkeit (in Stufen einstellbar) | 9,6 kBit/s; 19,2 kBit/s; 93,75 kBit/s; 187,5 kBit/s; 500 kBit/s; 1500 kBit/s; 12 MBit/s
Steckverbinder | 9-Pin D-Sub-Steckverbinder für IP20 M12 Rundsteckverbinder für IP65/67

Verkabelung für PROFIBUS-DP und PROFIBUS-FMS

Beachten Sie die besonderen Anforderungen an das Datenkabel bei Baud-Raten von mehr als 1,5 MBaud. Das richtige Kabel ist Grundvoraussetzung für den störungsfreien Betrieb des Bussystems. Bei der Verwendung des normalen 1,5 MBaud-Kabels kann es durch Reflexionen und zu großer Dämpfung zu erstaunlichen Phänomenen kommen. Zum Beispiel bekommt eine eine angeschlossenen PROFIBUS-Station keine Verbindung, kann diese aber nach Abziehen der benachbarten Station wieder aufnehmen. Oder es kommt zu Übertragungsfehlern, wenn ein bestimmtes Bitmuster übertragen wird. Das kann bedeuten, das der PROFIBUS ohne Funktion der Anlage störungsfrei arbeitet und nach dem Hochlauf zufällig Busfehler meldet. Eine Reduzierung der Baud-Rate (< 93,75 kBaud) beseitigt das geschilderte Fehlerverhalten.

Führt die Verringerung der Baud-Rate nicht zur Beseitigung des Fehlers, liegt in häufig ein Verdrahtungsfehler vor. Die beiden Datenleitungen sind an einem oder mehreren Steckern gedreht oder Abschlusswiderstände sind nicht oder an falschen Stellen aktiviert.

Hinweis 		Vorkonfektionierte Kabel von BECKHOFF
Mit den vorkonfektionierten Kabeln von BECKHOFF vereinfacht sich die Installation erheblich! Verdrahtungsfehler werden vermieden und die Inbetriebnahme führt schneller zum Erfolg. Das BECKHOFF-Programm umfasst Feldbuskabel, Stromversorgungskabel und Sensorkabel sowie Zubehör wie Abschlusswiderstände und T-Stücke. Ebenso sind jedoch auch Feldkonfektionierbare Stecker und Kabel erhältlich.

Hinweis 		Abschlusswiderstände
In Systemen mit mehr als zwei Stationen werden alle Teilnehmer parallel verdrahtet. An den Leitungsenden muss das Buskabel in jedem Fall mit Widerständen abgeschlossen werden, um Reflexionen und damit Übertragungsprobleme zu vermeiden.

Längenausdehnung

Die Busleitung ist in der EN 50170 spezifiziert. Daraus ergibt sich die nachfolgende Längenausdehnung eines Bussegment.

Baud-Rate in kBits/sec | 9,6 | 19,2 | 93,75 | 187,5 | 500 | 1500 | 12000
Leitungslänge in m | 1200 | 1200 | 1200 | 1000 | 400 | 200 | 100

Stichleitungen bis 1500 kBaud <6,6 m, bei 12 MBaud sollten keine Stichleitungen verwendet werden.

Bussegment

Ein Bussegment besteht aus maximal 32 Teilnehmern. An einem PROFIBUS-Netzwerk sind 126 Teilnehmer erlaubt. Um diese Anzahl zu erreichen sind Repeater erforderlich, die das Signal auffrischen. Dabei wird jeder Repeater wie ein Teilnehmer angesehen.

IP-Link ist das Sub-Bussystem der Feldbus Boxen dessen Topologie eine Ringstruktur ist. In den Koppler Modulen (IP230x-Bxxx oder IP230x-Cxxx) befindet sich ein IP-Link Master, an den bis zu 120 Erweiterungsmodule (IExxxx) angeschlossen werden dürfen. Der Abstand zwischen zwei Modulen darf dabei 5 m nicht überschreiten. Achten Sie bei der Planung und Installation der Module, dass aufgrund der Ringsstruktur das letzte Modul wieder am IP-Link Master angeschlossen werden muss.

Einbaurichtlinie

Beachten Sie bei der Montage der Module und beim Verlegen der Leitung die technischen Richtlinien der PROFIBUS-Nutzerorganisation e.V. zu PROFIBUS-DP/FMS (siehe www.profibus.de).

Überprüfung der PROFIBUS-Verkabelung

Ein PROFIBUS-Kabel (bzw. ein Kabel-Segment bei Verwendung von Repeatern) kann mit ein paar einfachen Widerstandsmessungen überprüft werden. Dazu sollte das Kabel von allen Stationen abgezogen werden:

  1. Widerstand zwischen A und B am Anfang der Leitung: ca. 110 Ohm
  2. Widerstand zwischen A und B am Ende der Leitung: ca. 110 Ohm
  3. Widerstand zwischen A am Anfang und A am Ende der Leitung: ca. 0 Ohm
  4. Widerstand zwischen B am Anfang und B am Ende der Leitung: ca. 0 Ohm
  5. Widerstand zwischen Schirm am Anfang und Schirm am Ende der Leitung: ca. 0 Ohm

Falls diese Messungen erfolgreich sind, ist das Kabel in Ordnung. Wenn trotzdem noch Bus-Störungen auftreten, liegt es meistens an EMV-Störungen. Beachten Sie die Installationshinweise der PROFIBUS-Nutzer-Organisation (www.profibus.com).


PROFIBUS-Anschluss

M12-Rundsteckverbinder

Die M12-Buchse ist invers codiert und besitzt 5 Stifte. Stift 1 überträgt 5 VDC und Stift 3 überträgt GND für den aktiven Abschlusswiderstand. Diese dürfen auf keinen Fall für andere Funktionen missbraucht werden, da dies zu Zerstörung des Gerätes führen kann.

Stift 2 und Stift 4 übertragen die Signale des PROFIBUS. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist. Stift 5 ist überträgt den Schirm (Shield) der kapazitiv mit der Grundfläche der Feldbus Box verbunden ist.

Pinbelegung M12 Buchse (-B310)

Pinbelegung M12 Buchse/Stecker (-B318)

Neunpoliger D-Sub

Stift 6 überträgt 5 VDC und Stift 5 GND für den aktiven Abschlusswiderstand. Diese dürfen auf keinen Fall für andere Funktionen missbraucht werden, da dies zu Zerstörung des Gerätes führen kann.

Stift 3 und Stift 8 übertragen die Signale des PROFIBUS. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist.

Pinbelegung der PROFIBUS D-Sub Buchse

Leitungsfarben PROFIBUS

PROFIBUS Leitung | M12 | D-Sub
B rot | Stift 4 | Stift 3
A grün | Stift 2 | Stift 8

Anschluss der Feldbus Box Module

Der Anschluss der Feldbus Box Module erfolgt entweder direkt oder mittels T-Stück (oder Y-Stück).

Die B318 Serie verfügt über jeweils eine Buchse und einen Stecker, d.h. hier wird der PROFIBUS in dem Modul weitergeleitet. Die Versorgungsspannung (+5VDC) für den Abschluss-Widerstand liegt nur auf der Buchse an. Der Abschluss-Widerstand ZS1000-1610 steht nur als Stecker zur Verfügung!

Die ankommende PROFIBUS-Leitung sollte stets mit einer Buchse enden.

Es stehen zwei T-Stücke zur Verfügung:

  • ZS1031-2600 mit +5VDC Weiterleitung zur Versorgung des Abschluss-Widerstandes
  • ZS1031-2610 ohne +5VDC Weiterleitung


Prozessdaten

Nachdem die Parameterdaten und auch die Konfigurationsdaten fehlerfrei empfangen und bestätigt wurden , geht der Slave in den Zustand Data_Exch, d.h. er tauscht Daten mit dem Master aus. Der Master sendet die Ausgangsdaten und der Slave antwortet mit den Eingangsdaten.


Konfigurationsdateien

Feldbus Box: Profibus

Konfigurationsdaten (Cfg Data)

Nach dem Parametrieren sendet der Master ein Konfigurationstelegramm an den Slave. Das Konfigurationstelegramm veranlasst den Slave, die vom Master gesendeten Konfiguration zu prüfen.

Aufbau eines Konfigurationsbytes

Bit 0..3 Länge der Daten
00 = 1 Byte/Word
15 = 16 Byte/Word

Bit 4..5 Ein-/Ausgabe
00 = spezielles Kennungsformat
01 = Eingabe
10 = Ausgabe
11 = Ein/-Ausgabe

Bit 6 Byte/Word
0 = Byte
1 = Word

Bit 7 Konsistenz
0 = Konsistenz über Byte/Word
1 = Konsistenz gesamte Länge


Aktivieren der DPV1-Funktionen

In der Parameterdaten (GSD, GSE) können die DPV1 Funktionen aktiviert werden. in der Default Einstellung sind diese Funktionen deaktiviert. (Prm. Byte 0 Bit 15=1 aktiviert, Bit 15 =0 [Default] deaktiviert)

DPV1-Funktionen

Die IP/IL Module und die Economy Plus Buskoppler (BK3120) unterstützen die folgende Funktionen der DPV1 Dienste. Die maximale Länge der DP-V1 Dienste beträgt 48 Byte.

IP/IL-Konfiguration (nur IP-Link)

Die Konfiguration der Erweiterungsmodule kann aus dem IP-Link Koppler Modul ausgelesen werden. Für jedes angeschlossene Erweiterungsmodul (IExxxx) wir ein Wort (16 Bit) übertragen. Dies beinhaltet den Typ der Module bei den Analogen Modulen und die Größe und Typ von den digitalen Erweiterungsmodulen.

Bit | Wert: Beschreibung der digitalen Module
0-1 | wenn Bit 4 = 0: Anzahl der Ausgänge mal 2 Bit, wenn Bit 4 = 1: Anzahl der Ausgänge mal 8 Bit
2-3 | wenn Bit 4 = 0: Anzahl der Eingänge mal 2 Bit, wenn Bit 4 = 1: Anzahl der Eingänge mal 8 Bit
4 | 0: Bit Größe 2, 1: Bit Größe 8
5-6 | 0: Standard: Eingänge und Ausgänge haben nicht die gleiche Anfangsadresse 1: Kombi E/A: Eingänge und Ausgänge haben die gleiche Anfangsadresse 2: Reserviert 3: Ausgänge mit Diagnose
7-15 | immer 0

Die Modul-Konfiguration kann mit folgenden DPV1-Parametern ausgelesen werden: (KS2000 Tabelle 9) Eingetragen werden die Module in der Reihenfolge wie diese am IP-Link angeschlossen sind.

Slot-Nummer | Index | Byte | Beschreibung
0 | 9 | 0-1 | Buskoppler/Modul Bezeichnung
0 | 9 | 2-3 | Modul-1
0 | 9 | ... | ...
0 | 9 | 46-47 | Modul-23
0 | 10 | 0-1 | Modul 24
0 | 10 | ... | ...
0 | 10 | 46-47 | Modul 47
0 | 11 | 0-1 | Modul 48
0 | ... | ... | ...
0 | 13 | 46-47 | Modul 95
0 | 14 | 0-1 | Modul 96
0 | 14 | ... | ...
0 | 14 | 30-31 | Modul 119

Diese Informationen können auch per DVP1 geschrieben werden. Sollte die geschriebene Konfiguration nicht mit der in der Tabelle enthaltenen Konfiguration übereinstimmen bekommt man eine DPV1 Fehlermeldung.

Modul-Register

Die Register der Erweiterungsmodule könne gelesen oder geschrieben werden:

Slot-Nummer | Index | Beschreibung
1 | 0 | Register 0 von Modul 1, Kanal 1
1 | ... | ...
1 | 63 | Register 63 von Modul 1, Kanal 1
1 | 64 | Register 0 von Modul 1, Kanal 2
1 | ... | ...
1 | 255 | Register 63 von Modul 1, Kanal 4
2 | 0 | Register 0 von Modul 2, Kanal 1 (ab hier nur für IP-Link)
... | ... | ...
255 | 255 | Register 63 von Modul 255, Kanal 4

IP-Link-Reset

Der IP-Link-Reset kann mit den folgenden DPV1-Parameter aktiviert werden ( Nach einer IP-Link Unterbrechung und dessen Behebung kann der IP-Link wieder gestartet werden):

Slot-Number | Index | Byte | Wert
0 | 99 | 0 | 2
0 | 99 | 1 | 1
0 | 99 | 2 | 0
0 | 99 | 3 | 0

Messen der IP-Link-Zykluszeit

Das starten und stoppen der IP-Link-Zykluszeit wird über die folgenden DPV1-Parameter eingestellt:

Slot-Nummer | Index | Byte | Wert
0 | 99 | 0 | 4
0 | 99 | 1 | 1
0 | 99 | 2-3 | 0: Stop, >0: Start

Die Zyklus Zeit kann gelesen werden und für das Rücksetzen der Werte können diese auch geschrieben werden mit den folgenden DPV1-Parameter :

Slot-Number | Index | Byte | Beschreibung
0 | 98 | 0-1 | Minimale IP-Link-Zykluszeit (in µs)
0 | 98 | 2-3 | Maximale IP-Link-Zykluszeit (in µs)
0 | 98 | 4-5 | Aktuelle IP-Link-Zykluszeit (in µs)
0 | 98 | 6-7 | Mittlere IP-Link-Zykluszeit (in µs)

Hersteller-Einstellung

Für das Setzen der Hersteller-Einstellungen müssen folgende DPV1 Parameter geschrieben werden:

Slot-Nummer | Index | Byte | Wert
0 | 99 | 0 | 1
0 | 99 | 1 | 4
0 | 99 | 2 | 0
0 | 99 | 3 | 0


User Prm Data

BECKHOFF Feldbus Box: PROFIBUS

Parametriertelegramm

Mit dem Dienst Set_Prm können neben den in der PROFIBUS-DP-Norm beschriebenen Parametern auch herstellerspezifische Betriebsparameter (User_Prm_Data) übertragen werden. Diese werden beim Verbindungsaufbau einmal vom Master zum Slave übertragen. In der Regel kann das Konfigurationstool des DP-Masters die einstellbaren Betriebsparameter der Feldbus Box aus der GSD-Datei lesen und im Klartext darstellen. Folgende herstellerspezifische Betriebsparameter können Sie für die Feldbus Box einstellen:

Standard-Funktionalität | Module, die die Funktionen unterstützen
DPV1 - Dienste | IPxxxx-B310, IL230x-B310, IL230x-C310
Reset bei IP-Link-Fehler | IL230x-B310, IL230x-C310
Datenformat der Prozessdaten | IPxxxx-B310, IL230x-B310, IL230x-C310
Synchronisierung DP-/IP-Link-Zyklus | IL230x-B310, IL230x-C310
Reaktion auf Profibus-Fehler | IPxxxx-B310, IL230x-B310, IL230x-C310
Reaktion auf IP-Link-Fehler | IL230x-B310, IL230x-C310
Experten-Funktionalität
2-Byte-SPS-Interface


Aktualisierung des Prozessabbilds

Funktion

Der Start des K-Bus-Zyklusses (IP-Link) kann zyklisch (Prozessabbildaktualisierung: freilaufend) oder synchron zum Empfang des DP-Data_Exchange-Telegramms (Prozessabbildaktualisierung: zyklussynchron) erfolgen. Wenn die Prozessabbildaktualisierung auf zyklussynchron eingestellt ist, wird nach dem Empfang des Data_Exchange-Telegramms der K-Bus-Zyklus gestartet, anderenfalls wird der K-Bus-Zyklus (IP-Link) unabhängig von den Data_Exchange-Telegrammen gestartet. Nachfolgend ist schematisch die zyklussynchrone bzw. freilaufende Prozessabbildaktualisierung dargestellt.

Free Run

Bild: Free-Run-Mode

Synchron

Bild: Schema Prozessabbildaktualisierung

Byte | Bit | Beschreibung
9 | 6 | Prozessabbildaktualisierung
Hinweis Bei der Parametrierung der Funktion Prozessabbildaktualisierung sind insbesondere die Lauf- und Reaktionszeiten des Gesamtsystems zu beachten.

Fast- Free- Run

Im Fast- Free-Run Mode wird die Priorität des K-Busses / IP-Link höher gesetzt. Damit wird der interne Bus öfter angestoßen. Damit verbunden werden die Schnittstellen (wie KS2000 oder DPV-1) nicht mehr so schnell bearbeitet. Der Fast-Free-Run Mode ist nur im asynchronen Mode gestattet.

Bild: Fast-Free-Mode

Byte | Bit | Beschreibung
9 | 4 | Fast-Free-Run-Mode

Die Übertragung der Signale von den Eingängen in die Steuerung und von der Steuerung zu den Ausgängen benötigt eine Laufzeit. Sie setzt sich aus verschiedenen Teilen zusammen:

  • Übertragung von der Steuerung in den Profibus Master
  • Übertragung über den Profibus und (siehe Profibus-Reaktionszeit)
  • Übertragung von der Profibus-Box zu den Ausgängen (siehe K-Bus-Reaktionszeit) / (siehe IP-Link Zykluszeit)

Für den Rückweg gilt das in umgekehrter Weise.

Die Reaktionszeit von der Steuerung zum Profibus-Master entnehmen Sie bitte den Angaben des Profibus Masterherstellers. Die Zeiten sind vergleichsweise klein und müssen im Normalfall nicht berücksichtigt werden.

PROFIBUS-Reaktionszeit

Die Reaktionszeit tDP auf dem Profibus setzt sich wie folgt zusammen. Die Konstanten A, B und TBYTE sind von der Baud-Rate abhängig.

tDP = | Konstante A |
 | + (Konstante B + (Zahl der E/A-Byte x TBYTE)) | [Slave 1]
 | + (Konstante B + (Zahl der E/A-Byte x TBYTE)) | [Slave 2]
 | + (Konstante B + (Zahl der E/A-Byte x TBYTE)) | [Slave 3]
 | +(Konstante B + (Zahl der E/A-Byte x TBYTE)) | [Slave n]

Baud-Rate | Konstante A (in ms) | Konstante B (in ms) | TBYTE (in ms)
9,6 kBaud | 64,5 | 25,6 | 1,15
19,2 kBaud | 32,3 | 12,8 | 0,573
93,75 kBaud | 6,6 | 2,62 | 0,118
187,5 kBaud | 3,3 | 1,31 | 0,059
500 kBaud | 1,6 | 0,49 | 0,022
1,5 MBaud | 0,67 | 0,164 | 0,00733
3 MBaud | 0,436 | 0,085 | 0,00367
6 MBaud | 0,27 | 0,044 | 0,00183
12 MBaud | 0,191 | 0,024 | 0,00092

K-Bus-Reaktionszeit (K-Bus)

Die Reaktionszeit auf dem K-Bus (interner Bus der Kompakt Box) wird durch das Schieben und Sichern der Daten bestimmt. Die folgende Tabelle enthält Messwerte für typische Aufbauten. Die Hochrechnung auf größere Anzahlen ist möglich.

Kompaktbox (Zahlen sind Anzahl der Kanäle) |  |  | Laufzeit auf dem K-Bus
Digital OUT | Digital IN | Analog IN/OUT | T_Zyklus (µs)
4 | 0 | 0 | 150
8 | 0 | 0 | 170
12 | 0 | 0 | 170
16 | 0 | 0 | 200
20 | 0 | 0 | 200
24 | 0 | 0 | 220
28 | 0 | 0 | 220
32 | 0 | 0 | 245
0 | 4 | 0 | 150
0 | 8 | 0 | 180
0 | 12 | 0 | 180
0 | 16 | 0 | 200
0 | 20 | 0 | 200
0 | 24 | 0 | 230
0 | 28 | 0 | 230
0 | 32 | 0 | 250
4 | 4 | 0 | 170
8 | 8 | 0 | 195
12 | 12 | 0 | 220
16 | 16 | 0 | 250
20 | 20 | 0 | 275
24 | 24 | 0 | 300
28 | 28 | 0 | 325
32 | 32 | 0 | 350
4 | 4 | 1 | 630
4 | 4 | 2 | 700
Hinweis Der K-Bus-Zyklus beträgt physikalisch bedingt mindestens cirka 90 µs. Das bedeutet, dass die Lauf- bzw. Zykluszeit des Gesamtsystems, insbesondere jedoch die Zykluszeit der SPS-Task, größer als die Laufzeit des K-Bus-Zyklusses sein muss. Anderenfalls kann es zu instabilen Zuständen an den Ein- und Ausgangsklemmen der Profibus-Slaves kommen.

IP-Link-Reaktionszeit

Die Reaktionszeit auf dem IP-Link wird durch das Schieben und Sichern der Daten bestimmt. Die folgende Tabelle enthält Messwerte für typische Aufbauten. Die Hochrechnung auf größere Anzahlen ist möglich.

Erweiterungs-Box, mit Koppler Box verbunden |  |  | Laufzeit auf dem IP-Link
Digital OUT (Bit) | Digital IN (Bit) | Analog IN/OUT (Kanäle) | T_Zyklus (µs)
24 | 16 | 0 | 420
48 | 16 | 0 | 450
24 | 16 | 4 | 1500
48 | 16 | 16 | 2360
48 | 16 | 28 | 3500
48 | 16 | 40 | 4000

Die Einstellungen zur Funktion Prozessabbildaktualisierung befinden sich im Byte 9 der User_Prm_Data (Defaulteinstellungen sind fett gekennzeichnet):

Bit-Nr. | Beschreibung | Wird unterstützt von
Bit 6 | Prozessabbildaktualisierung 0: zyklussynchron 1: freilaufend | IP10xx, IP15xx; IP20xx, IP23xx, IP25xx, IP31xx, IP41xx, IP50xx, IP51xx, IP60xx

In TwinCAT können die Einstellungen Synchronisierung Profibus DP-/K-Bus-Zyklus mit ADSRead und ADSWrite (ADS: Automation Device Spezifikation) übertragen werden. Dazu sind diese in den User_Prm_Data zu aktivieren.

Die Einstellungen zur Funktion Prozessabbildaktualisierung befinden sich im TwinCAT System-Manager im Karteireiter PrmData der entsprechenden Busbox.


Datenformat Auto-Konfiguration

Mit diesem Parameter stellen Sie das Darstellungsformat der komplexen Klemmen ein. Sie können zwischen Intel- und Motorola-Format wählen:

  • Beim Intel-Format liegt das niederwertige Byte (Low-Byte) eines Daten-Wortes auf dem niedrigen Adress-Offset des Speicherplatzes.
  • Beim Motorola-Format liegt das höherwertige Byte (High-Byte) eines Daten-Wortes auf dem niedrigen Adress-Offset des Speicherplatzes.

Wenn Sie für digitale Klemmen das Motorola-Format wählen, so wird z.B. in den für 16 aufeinanderfolgende Digital-Kanäle übertragenen zwei Bytes, das High-Byte mit dem Low-Byte getauscht.

Darstellung im Intel-Format
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Wort 0 |  | Wort 2 |  | Wort 4
 | Wort 1 |  | Wort 3 |  |

Bezogen auf Bitadressen ergibt sich:
High Byte |  |  |  |  |  |  |  | Low Byte
1.7 | 1.6 | 1.5 | 1.4 | 1.3 | 1.2 | 1.1 | 1.0 | 0.7 | 0.6 | 0.5 | 0.4 | 0.3 | 0.2 | 0.1 | 0.0
Byte 1 |  |  |  |  |  |  |  | Byte 0

Darstellung im Motorola-Format
Byte 1 | Byte 0 | Byte 3 | Byte 2 | Byte 5 | Byte 4
Wort 0 |  | Wort 2 |  | Wort 4

Bezogen auf Bitadressen ergibt sich:
High Byte |  |  |  |  |  |  |  | Low Byte
0.7 | 0.6 | 0.5 | 0.4 | 0.3 | 0.2 | 0.1 | 0.0 | 1.7 | 1.6 | 1.5 | 1.4 | 1.3 | 1.2 | 1.1 | 1.0
Byte 0 |  |  |  |  |  |  |  | Byte 1

Einstellungen

Die Einstellungen zur Funktion Datenformat Auto-Konfiguration befinden sich im Byte 9 der User_Prm_Data (Defaulteinstellungen sind fett gekennzeichnet):

Bit-Nr. | Beschreibung | Wird unterstützt von
3 | Datenformat Auto-Konfiguration 0: Intel 1: Motorola | IP15xx, IP25xx, IP31xx, IP41xx, IP50xx, IP51xx, IP60xx

In TwinCAT können die Einstellungen zum Datenformat Auto-Konfiguration mit ADSRead und ADSWrite (ADS: Automation Device Spezifikation) übertragen werden. Dazu sind diese in den User_Prm_Data zu aktivieren.

Die Einstellungen zur Funktion Datenformat Auto-Konfiguration befinden sich im TwinCAT System-Manager im Karteireiter PrmData der entsprechenden Busbox.


Reaktion auf Profibus-Fehler

Bei einem Profibus-Fehler (z.B. abziehen des Steckers, STOP des DP-Masters, etc.) kann die Fehlerreaktion eingestellt werden. Die möglichen Reaktionen sind:

  • Stopp des K-Busses
  • Zurücksetzen der Ausgänge auf 0
  • beibehalten der aktuellen Ausgangszustände
Hinweis Die Signalzustände an den Ausgangsklemmen sind in der Einstellung Zyklus wird gestoppt identisch mit denen in der Einstellung Outputs werden 0.

Die Einstellungen zur Funktion Reaktion auf Profibus-Fehler befinden sich im Byte 10 der User_Prm_Data (Defaulteinstellungen sind fett gekennzeichnet):

Bit-Nr. | Beschreibung | Wird unterstützt von
Bit 0/1 | Reaktion auf Profibus-Fehler 0: Zyklus wird gestoppt 1: Outputs werden 0 2: Outputs bleiben gleich | IP10xx, IP15xx, IP20xx, IP23xx, IP25xx, IP31xx, IP41xx, IP50xx, IP51xx, IP60xx

In TwinCAT können die Einstellungen Reaktion auf Profibus-Fehler mit ADSRead und ADSWrite (ADS-Automation Device Spezifikation) übertragen werden. Dazu sind diese in den User_Prm_Data zu aktivieren.

Die Einstellungen zur Funktion Reaktion auf Profibus-Fehler befinden sich im TwinCAT System-Manager im Karteireiter "PrmData" des entsprechenden Buskopplers.


Reaktion auf Profibus-Fehler

BECKHOFF Feldbus Box: UserPrmData

Reaktion auf IP-Link Fehler

Bei einem IP-Link-Fehler (z.B. abziehen des Steckers) kann die Fehlerreaktion eingestellt werden. Die möglichen Reaktionen sind:

  • Datenaustausch wird gestoppt
  • Profibus Eingänge werden 0
  • Profibus Eingänge bleiben erhalten

Die Einstellungen zur Funktion Reaktion auf Profibus-Fehler befinden sich im Byte 10 der User_Prm_Data (Defaulteinstellungen sind fett gekennzeichnet):

Bit | Beschreibung | Wird unterstützt von
2, 3 | Reaktion auf Profibus-Fehler 0: Datenaustausch wird verlassen 1: Inputs werden 0 2: Inputs bleiben gleich | IL230x-B3xx

In TwinCAT können die Einstellungen Reaktion auf IP-Link-Fehler mit ADSRead und ADSWrite (ADS-Automation Device Spezifikation) übertragen werden. Dazu sind diese in den User_Prm_Data zu aktivieren.

Die Einstellungen zur Funktion Reaktion auf IP-Link-Fehler befinden sich im TwinCAT System-Manager im Karteireiter "PrmData" des entsprechenden Buskopplers.


Parameterdaten

Feldbus Box: Profibus UserPrmData

Anwender-Parameter für Kompakt Box Module (IPxxxx-B31x)

Datenformat

Auto-Konfiguration (nur bei allen komplexen Geräten, bei digitalen nicht benötigt)
Die Daten der komplexen Klemmen können im Intel- oder Motorola-Format dargestellt werden, wobei eine Steuerung die Daten in der Regel im Motorola-Format erwartet.

Beispiel:
Ein analog Wert eines IP3312-Bxxx zeigt im Motorola-Format 0x0016 an. Im Intel-Format wird dann das High- und Low-Byte getauscht 0x1600.

Prozessabbildaktualisierung

  • Zyklussynchron bedeutet das die Daten synchron zum Profibusabbild angetriggert werden. Wenn ein Profibustelegramm den Slave erreicht, kopiert der Slave die Daten nach verlassen des Antwort Telegramms in das ASIC. Die Ausgänge werden sofort geschrieben.
  • Freilaufend bedeutet, das die Daten geholt werden und in das ASIC kopiert werden und dies immer wider wiederholt wird.

Freilaufen kann benutzt werden, wenn die Eingangsdaten möglichst schnell in der Steuerung übertragen werden sollen. Dies hat aber den Nachteil, dass diese Daten nicht jitterfrei sind. Braucht man schnelle Ausgänge oder ist man auf jitterfreie Eingänge angewiesen (z.B. bei schnelle Reglern) dann sollte die zyklische Übertragung gewählt werden.

Reaktion auf Profibus-Fehler

  • Zyklus wird gestoppt. Der interne Datenprozess wird gestoppt und der Watchdog (WD) der Kanäle (in der Regel 100 ms) schlägt zu.
  • Outputs werden 0. Es werden definiert alle Ausgänge zu null geschrieben.
  • Outputs bleiben gleich. Das letzte empfangende Profibustelegramm und dessen Ausgangsdaten werden beibehalten. Ein geschalteter Ausgang, z.B. bei einem IP4112 mit 12 ms bleibt so lange erhalten bis der Profibuszyklus wieder aufgebaut ist und über die Prozessdaten ein neuer Wert übertragen wird.


IPxxxx-B31x - Anwender-Parameter

BECKHOFF Feldbus Box: PROFIBUS UserPrmData

Anwender-Parameter für Koppler Box Module (IL230x-B31x)

DPV1-Dienste

Hier können die DPV1 Dienste aktiviert bzw. deaktiviert werden. Default: nicht aktiv (siehe DPV1-Dienste).

Verhalten bei IP-Link-Fehler

Der IP-Link kann selbstständig nach Behebung eines IP-Link-Fehlers (z.B. Kabelbruch) selbstständig wieder anlaufen. Achtung: Die Profibus-Datenkommunikation wird wieder aufgenommen und Ausgänge werden wieder geschrieben. Der Anwender muss sicherstellen, das in diesem Fall nicht unabsichtlich Ausgänge geschrieben werden. Default: Manueller Reset.

Feldbus Box Diagnose

Hier können die Diagnose Daten aktiviert werden. Default: nicht aktiv (siehe Diagnose der Kompakt Box bzw. Diagnose der Koppler Box).
Byte 7, Bit 1:

  • True aktiviert
  • False deaktiviert

Datenformat

Daten die 2 Byte groß sind, können entweder im Intel oder im Motorola-Format übertragen werden. Das High-Byte wird mit dem Low-Byte getauscht. Default: Motorola.

Prozessdatenaktualisierung

Der IP-Link kann synchron zum Profibus angestoßen werden oder freilaufend arbeiten. Default: freilaufend (siehe Prozessdatenaktualisierung).

Reaktion auf Profibus-Fehler

Dies beschreibt das Verhalten des Slaves wenn ein Profibus-Fehler vorliegt (zum Beispiel Leitung defekt). Default: IP-Link Zyklus wird verlassen

  • Der IP-Link-Zyklus wird verlassen, das heißt der Watchdog der Erweiterungsmodule schlägt nach 100 ms zu und die Ausgänge werden in den Sichern Zustand geschaltet
  • Die Ausgänge werden vom IP-Link Master zu null geschrieben
  • Die Ausgänge bleiben im letzten Zustand eingefroren

Reaktion auf IP-Link-Fehler

Dies beschreibt das Verhalten des Slaves wenn ein IP-LInk Fehler vorliegt (zum Beispiel Leitung defekt). Default: DataExchange wird verlassen

  • DataExchange wird verlassen, bedeutet, das der Slave die Profibus Kommunikation unterbricht.
  • DP-Inputs werden 0 - Die Eingänge werden zu Null geschrieben
  • DP-Inputs bleiben erhalten - Die Eingänge bleiben im letzten gültigen Zustand erhalten

IL/IE Byte-Alignment )1

Damit können alle IL/IE23xx Module mit 4 Bit Ein-/Ausgänge auf ein Byte aufgerundet werden.

Byte 10 Bit 5 Default "0"
1 alle IE23xx Module werden mir 8 Bit gemappt, wobei die Eingänge von 0..3 reichen (4..7 werden nicht benutzt) und die Ausgänge von Bit 4..7 (0..3 werden nicht benutzt).
0 alle IE23xx Module mappen sich mit 4 Eingängen und 4 Ausgängen (Default)

)1Ab Software-Version 1 D:xxxx1xxx, Firmware Update bei den IL-Modulen ist möglich.


IL230x-C3xx - Anwender-Parameter

Feldbus Box: User Prm Data

Anwender-Parameter für Controller Box Module

Feldbus- und IP-Link-Status in den lokierten Merkerbereich kopieren

Byte 13, Bit 5
1 wird in den Bereich %MB408-411 kopiert (default)
0 wird nicht in den Bereich %MB408-411 kopiert

Abspeichern der Module beim erstellen des Bootprojektes

Byte 13, Bit 6
1 wird überprüft (default)
0 wird nicht überprüft

Zyklustick-Counter in den lokierten Merkerbereich kopieren

Byte 12, Bit 0
1 wird in den Bereich %MB404-407 kopiert (default)
0 wird nicht in den Bereich %MB404-407 kopiert

Reaktion auf Breakpoints

Byte 12, Bit 1
1 Ausgänge werde zu Null geschrieben
0 Ausgänge bleiben unverändert (default)


Modulspezifische Parameterdaten

Anwender-Parameter für Kompakt Box Module (IP3xxx-B310)

Die modulspezifischen Parameterdaten können ab der Version D.xxxx3xxx genutzt werden.
Ein Update Ihrer Software ist ab der Hardware D.xxxxx8xx möglich. Bitte wenden sie sich hierfür an den Support.

IP3102-B310

- Overflow Offset (für jeden Kanal individuell einstellbar)
- Grenzwerte einstellen und aktivieren ( für jeden Kanal individuell einstellbar)

IP3112-B310

- Overflow Offset (für jeden Kanal individuell einstellbar)
- Grenzwerte einstellen und aktivieren ( für jeden Kanal individuell einstellbar)
- Eingangsstrombereich ( für jeden Kanal individuell einstellbar): 0...20 mA oder 4...20 mA

IP3202-B310

- PT-Elemente einstellen ( für jeden Kanal individuell einstellbar)
- Zwei- / Drei- / Vierleiteranschluss ( für jeden Kanal individuell einstellbar)
- Overrange-Protektion ( für jeden Kanal individuell einstellbar)

IP3312-B310

- Thermo-Element einstellen ( für jeden Kanal individuell einstellbar)
- Kaltstellenkompensation ( für jeden Kanal individuell einstellbar)
- Overrange-Protektion (für jeden Kanal individuell einstellbar)

Anwender-Parameter für Kompakt Box Module IP4xxx-B310

Die modulspezifischen Parameterdaten können ab der Version D.xxxx3xxx genutzt werden.
Ein Update Ihrer Software ist ab der Hardware D.xxxxx8xx möglich. Bitte wenden sie sich hierfür an den Support.

IP4112-B310

- Ausgangsstrombereich (nur für alle Kanäle gemeinsam einstellbar): 0...20 mA oder 4...20 mA
- Watchdog ( für jeden Kanal individuell einstellbar)

IP4132-B310

- Watchdog ( für jeden Kanal individuell einstellbar)


Anlaufverhalten der Feldbus Box

Nach dem Einschalten prüft die Feldbus Box ihren Zustand, konfiguriert (wenn vorhanden) den IP-Link ist und erstellt anhand der Erweiterungsmodule eine Aufbauliste. Wenn die Feldbus Box eine dezentrale Steuerung besitzt (IL230x-C310) wird nach einer erfolgreichen Aufbauliste die lokale SPS gestartet.
Beim Hochlauf des Moduls leuchten und blinken die E/A LEDs. Im fehlerfreien Zustand sollte nach ca. 2-3 sec keine E/A LED mehr Blinken. Sollte ein Fehler vorliegen, hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose LEDs).

Start_List.gif (8211 Byte)


Adresse

Feldbus Box: Adresseinstellung

Adressierung

Die Adresse einer Profibusstation wird ist über zwei Drehwahlschalter eingestellt. Die Default-Einstellung beträgt 11. Es sind alle Adressen erlaubt, allerdings darf jede Adresse im Netzwerk nur einmal vorkommen. Die Adresse wird im ausgeschalteten Zustand von Feldbus Box (Buskoppler) geändert. Lösen Sie dazu bei der Feldbus Box die Abdeckung. Verändern Sie mit Hilfe eines Schraubendrehers die Schalter auf die gewünschte Position. Beachten Sie dabei, dass die Schalter richtig einrasten. Der linke Schalter ist der Zehner-Multiplikator und der rechte Schalter der Einer-Multiplikator. Die Adressänderung wird aktiv, sobald das Modul eingeschaltet wird.

Feldbus Box

AdressePB.jpg (19493 Byte)

Beispiel

Sie wollen Adresse 34 einstellen.
Linker Drehwahlschalter: 3
Rechter Drehwahlschalter: 4

Buskoppler

Der untere Schalter S311 ist der Zehner Multiplikator und der obere Schalter S310 der Einer Multiplikator.


Baud-Rate

Die Feldbus Box für Profibus besitzt eine automatische Baud-Raten-Erkennung. Nach Einschalten der Versorgungsspannung sucht die Feldbus Box die anliegende Baud-Rate und speichert sie, solange die Versorgungsspannung anliegt.

Hinweis Wenn Sie die Baud-Rate ihres Profibus-Masters ändern, müssen Sie die Feldbus Box einmal aus und wieder einschalten, damit die Änderung übernommen wird.

Längenausdehnung

Die Busleitung ist in der EN 50170 spezifiziert. Daraus ergibt sich die nachfolgende Längenausdehnung eines Bussegment.

Baud-Rate in kBit/sec | 9,6 | 19,2 | 93,75 | 187,5 | 500 | 1500 | 12000
Leitungslänge in m | 1200 | 1200 | 1200 | 1000 | 400 | 200 | 100

Bis 1500 kBaud können Stichleitungen von maximal 6,6 m Länge verwendet werden. Bei 12 MBaud sollten keine Stichleitungen verwendet werden.


Konfigurationsdateien

BECKHOFF Fieldbus Components: Konfiguration

Konfigurationsdaten (Cfg Data)

Der PROFIBUS-Koppler erstellt einen Datenbereich mit Ein- und Ausgangsbytes (Peripheriedaten im Prozessabbild). Die Zuordnung zwischen den Kanälen der Busklemmen/Modulen und des Prozessabbilds wird vom Buskoppler/Feldbus Box durchgeführt.

Der PROFIBUS-Master tauscht mit jedem Buskoppler/Feldbus Box einen zusammenhängenden Eingangs- und Ausgangsdatenblock aus. Die Zuordnung der Bytes aus diesem Datenblock zu den Adressen des Prozessabbilds wird vom Master durchgeführt. Bei dem SPS-Master der IM308-C unterstützt die Software COM PROFIBUS und bei der IM308-B die Software COMET200 die Konfigurierung. Für andere PROFIBUS-Master sind die entsprechenden Tools der Hersteller zu benutzen.

Hinweis Für die Konfiguration der PROFIBUS-Master wird eine Konfigurationssoftware eingesetzt. Herstellerabhängig werden unterschiedliche Programme eingesetzt. Diese Programme verwenden im allgemeinen die GSD-Datei um die Slave-Parameter optimal einstellen zu können. Für Siemens PROFIBUS-Master wird häufig die Typ-Datei verwendet, erst neuere Versionen der Siemenssoftware arbeiten auch mit der GSD-Datei. Kopieren Sie die erforderlichen Dateien in die entsprechenden Verzeichnisse bevor Sie die Master - Konfigurationssoftware starten. Die Beckhoff GSD- und Typ-Dateien stehen unter www.beckhoff.de zum Download zur Verfügung.

Buskoppler oder Feldbus Box ermitteln nach dem Einschalten die Konfiguration der angeschlossenen Ein-/Ausgangsklemmen. Die Zuordnung zwischen physikalischen Steckplätzen der Ein/Ausgangskanäle und den Adressen des Prozessabbilde wird vom Buskoppler automatisch durchgeführt. Unterschieden wird hier nach bitorientierter (digitale) und byteorientierter (analoge, bzw. komplexe) Signalverarbeitung. Der Buskoppler schreibt zuerst die byteorientierten und daran anschließend die bitorientierten Busklemmen in das Prozessabbild.

Busklemmen
byteorientierte Busklemmen | bitorientierte Busklemmen
KL1501, KL2502, KL3xxx, KL4xxx, KL5xxx, KL6xxx | KL10xx, KL11xx, KL12xx, KL17xx, KL20xx, KL21xx, KL22xx, KL26xx, KL9110, KL9160, KL9210, KL9260
Feldbus Boxen
byteorientierte Feldbus Boxen | bitorientierte Feldbus Boxen
IP/IE1501, IP/IE25x2, IE2808 IP/IE3xx2, IP/IE4xx2, IP/IE5xx2, IP/IE6xx2 | IP/IE1xxx, IPIE2xxx

Bei der Master-Konfiguration ist zu beachten, dass zuerst alle byteorientierte Busklemmen und Feldbus Boxen in der Reihenfolge wie sie physikalisch gesteckt sind einzutragen sind. Dabei wird nicht nach Eingangsklemmen und Ausgangsklemmen unterschieden. Als nächstes folgen dann die bitorientierten Busklemmen. Diese werden zu einem ganzen Byte aufgerundet, d.h. 12 digitale Signale entsprechend 12 Bit werden auf zwei Byte aufgerundet.. Die restlichen vier Bit werden automatisch mit Nullen aufgefüllt. In der GSD-Datei finden sie für die bitorientierten Busklemmen 8/16/32 bis 1Word digitale Eingänge bzw. Ausgänge.

Bei den byteorientierten Busklemmen/Modulen gibt es nicht die direkten Klemmen, sondern nur die Anfangskennzeichnung plus dem so genannten Platzhalter (z.B. KL3xxx oder IP3xxx-B310). Alle diese Klemmen sind von der Größe im Prozessabbild gleich. Danach kann die Anzahl der Kanäle festgelegt werden. Dieses ist sinnvoll wenn man die Kanäle der Klemme in der SPS unterschiedlichen Adressen vergeben möchte.

Anzahl Bits (In-, Output-Kanäle) | Bedeutung im Prozessabbild
16 In | nur Nutzdaten
24 In / 8 Out | Nutzdaten zzgl. Control und Status (nur bei KL3xxx)
8 In / 24 Out | Nutzdaten zzgl. Control und Status (nur bei KL4xxx)
24 In / 24 Out | vollständiges Prozessabbild


Konfiguration: Siemens S5 Steuerung mit COM-Profibus

BECKHOFF Feldbus Box: Konfiguration

Konfiguration: Siemens S5-Steuerung mit COM-Profibus

Kopieren Sie als erstes die *.gsg Dateien in das GSD-Verzeichnis Ihrer COM-PROFIBUS-Software. Die GSD finden Sie auf der Beckhoff-Homepage. Im nächsten Schritt lesen Sie die Dateien in die COM-PROFIBUS-Software ein.

S5_Step1.jpg (18223 Byte)

Sie finden die Dateien danach unter DP-Slave/E/A/...

S5_Step2.jpg (16120 Byte)

Wählen Sie nun den passenden Slave aus.


Konfiguration: IP41xx-B310

Sie haben bei der IP41xx-B310 die Möglichkeit zwischen zwei verschiedenen Mapping-Typen auszuwählen:

  • Das kompakte Mapping beschreibt rein die Ausgangsnutzdaten, d.h. 4 Ausgangsworte (für jeden Kanal 16 Bit).
  • Das komplexe Mapping hat zusätzlich ein Control- und ein Status-Byte, das bei den IP41xx.B310 nur für die Registerkommunikation genutzt werden kann. Mapping 4 x 3 Byte Input und Output.

Diese Einstellungen können nur für ein gesamtes Modul eingestellt werden (nicht kanalbezogen).

Beispiel für kompaktes Mapping:

Beispiel für komplexes Mapping:

Sie können auch die User-Parameter ändern (siehe Konfigurationsdateien).


Konfiguration: Siemens S5 Steuerung mit COM Profibus

Feldbus Box: Konfiguration

Konfiguration: Siemens S7-Steuerung

Einfügen der Bilder

Um in der Siemens Software den Geräten ein Bild zuzuweisen müssen diese in in das Verzeichnis Step7\S7Data\ncbmp kopiert werden.

IPxxxx-B310 IL230x-B310/C310

Einfügen der GSD Dateinen

  • Gehen sie in den Hardwarekatalog ihrer Step7 unter Extras\Neue GSD instalieren.
  • Wählen sie das Verzeichnis aus, in dem sich die Beckhoff GSD befinden und importieren Sie die Dateien.
  • Sie finden diese dann im Hardware Katalog unter Profibus-DP\Weiter Feldgeräte\I/O.


Konfiguration: Siemens S5 Steuerung mit COM Profibus

Feldbus Box: Konfiguration

Konfiguration: Siemens S7-Steuerung IL230x-B31x

Parameterdaten des IL230x-B31x

Einstellungen

Parameterdaten | Bezeichnung
DPV1-Services | DPV1-Dienste
IP-Link-Error | Reaktion bei IP-Link
IP-Modul diagnose | PROFIBUS Diagnose
Data-Format | Daten Format
Updating of process image | K-Bus Update
Reaction on DP-Error | Reaktion auf Feldbusfehler
IP-Link-Error-Reaction | IP-Link Fehler Reaktion
IL/IE23xx Byte-Align | Mapping der 4 DI / DO (IL/IE23xx) Module

Konfiguration IL230x-B31x Modul mit nur digitale Ein-/Ausgängen

Beispiel:
1 x IL2301-B310
4 x IE1001
5 x IE2001
Die Summe der digitalen Bytes müssen zusammenaddiert werden und eingetragen werden.

Beispiel:
1 x IL2301-B310
4 x IE1001
5 x IE2001

Die gleiche Konfiguration kann man auch wie folgt erstellen. Vorteil dieser Art ist es, dass jedes Byte eine unterschiedliche Adresse bekommt und wenn ein digitales Erweiterungsmodul eingeführt wird sich die Adressen der anderen Module nicht verschiebt. Maximal können 64 Module eingeführt werden (0-63 Slots).

Konfiguration IL230x-B31x Modul mit komplexen und digitale Ein-/Ausgängen

Komplexe Module mappen sich als erstes in das Prozessabbild, daher müssen erst alle komplexen Module in der Reihenfolge wie diese am IP-Link hängen eingetragen werden und anschließlicht die digitalen Signale auf ein Byte aufgerundet.

Beispiel:
1 x IL2301-B310
1 x IE3102 kompaktes Mapping

Beispiel:
1 x IL2301-B310
1 x IE3102 komplexes Mapping


Allgemeine Registerbeschreibung

Bei den komplexen Modulen können verschiedene Betriebsarten bzw. Funktionalitäten eingestellt werden. Die Allgemeine Registerbeschreibung erläutert den Inhalt der Register, die bei allen komplexen Modulen identisch sind. Die modulspezifischen Register werden in dem darauffolgendem Kapitel erklärt.
Der Zugriff auf die internen Register der Module wird im Kapitel Register-Kommunikation beschrieben.

Allgemeine Registerbeschreibung

Komplexe Module die einen Prozessor besitzen, sind in der Lage mit der übergeordneten Steuerung bidirektional Daten auszutauschen. Diese Module werden im folgenden als intelligente Module bezeichnet. Zu ihnen zählen die analogen Eingänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), die analogen Ausgänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), serielle Schnittstellenmodule (RS485, RS232, TTY, Datenaustausch-Module), Zähler-Module, Encoder-Interface, SSI-Interface, PWM-Module und alle anderen parametrierbare Module.

Alle intelligenten Modulen besitzen intern eine in ihren wesentlichen Eigenschaften identisch aufgebaute Datenstruktur. Dieser Datenbereich ist wortweise organisiert und umfasst 64 Speicherplätze. Über diese Struktur sind die wesentlichen Daten und Parameter der Module les- und einstellbar. Zusätzlich sind Funktionsaufrufe mit entsprechenden Parametern möglich. Jeder logische Kanal einer intelligenten Module besitzt eine solche Struktur (4-Kanal analoge Module besitzen also 4 Registersätze).

Diese Struktur gliedert sich in folgende Bereiche:

Bereich | Adresse
Prozessvariablen | 0-7
Typ-Register | 8-15
Hersteller- Parameter | 16-30
Anwender- Parameter | 31-47
Erweiterter Anwenderbereich | 48-63

Register R0-R7 (im internen RAM des Moduls)

Die Prozessvariablen können ergänzend zum eigentlichen Prozessabbild genutzt werden und sind in ihrer Funktion Modulspezifisch.

R0-R5

Diese Register besitzen eine vom Modul-Typ abhängige Funktion.

R6

Diagnose-Register: Das Diagnose-Register kann zusätzliche Diagnose-Information enthalten. So werden z.B. bei seriellen Schnittstellenmodulen Paritäts-Fehler, die während der Datenübertragung aufgetreten sind, angezeigt.

R7

Kommandoregister

  • High-Byte_Write = Funktionsparameter
  • Low-Byte_Write = Funktionsnummer
  • High-Byte_Read = Funktionsergebnis
  • Low-Byte_ Read = Funktionsnummer

Register R8-R15 (im internen ROM des Moduls)

Die Typ- und Systemparameter sind fest vom Hersteller programmiert und können vom Anwender nur gelesen und nicht verändert werden.

R8

Feldbus Box Typ: Der Feldbus Box Typ in Register R8 wird zur Identifizierung der Feldbus Box benötigt.

R9

Softwareversion x.y.: Die Software-Version kann als ASCII-Zeichenfolge gelesen werden.

R10

Datenlänge: R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit. Der Buskoppler sieht diese Struktur.

R11

Signalkanäle: Im Vergleich zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z.B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.

R12

Minimale Datenlänge: Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control/Status-Byte für die Funktion des Moduls nicht zwingend notwendig, und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen. Die Information steht

  • bei einem Ausgangsmodul im High-Byte
  • bei einem Eingangsmodul im Low-Byte.
R13

Datentypregister

Datentypregister | Beschreibung
0x00 | Modul ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur 1 Byte n Bytes
0x03 | Word-Array
0x04 | Struktur 1 Byte n Worte
0x05 | Doppelwort-Array
0x06 | Struktur 1 Byte n Doppelworte
0x07 | Struktur 1 Byte 1 Wort
0x08 | Struktur 1 Byte 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur 1 Byte n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur 1 Byte n Worte mit variabler logischer Kanallänge
0x15 | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur 1 Byte n Doppelworte mit variabler logischer Kanallänge
R14

reserviert

R15

Alignment-Bits (RAM): Mit den Alignment-Bits wird das Analogmodul im Prozessabbild auf eine Bytegrenze gelegt.

Register R16-R30 (Hersteller-Parameter, serielles EEPROM)

Die Hersteller-Parameter werden vom Hersteller für jeden Modultyp modulspezifisch festgelegt, können jedoch mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Hersteller-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Hersteller-Parameter müssen Sie zuvor in Register R31 ein Code-Wort setzen.

Register R31-R47 (Anwendungs-Parameter, serielles EEPROM)

Die Anwender-Parameter sind Modulspezifisch. Sie können mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Anwender-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Anwender-Parameter müssen Sie zuvor in Register R31 das Anwender-Code-Wort setzen.

R31

Code-Wort-Register im RAM: Damit Parameter im Anwender-Bereich geändert werden können muss hier das Code-Wort 0x1235 eingetragen werden. Wird ein abweichender Wert in dieses Register eingetragen, so wird der Schreibschutz gesetzt. Bei inaktivem Schreibschutz wird das Code-Wort beim Lesen des Register zurückgegeben, ist der Schreibschutz aktiv enthält das Register den Wert Null.

R32

Feature-Register: Dieses Register legt die Betriebsarten der Klemme fest. So kann z.B. bei den analogen E/A-Modulen eine anwenderspezifische Skalierung aktiviert werden.

R33 bis R63

Klemmenspezifische Register: Diese Register sind vom Klemmentyp abhängig.

Register R47 bis R63 (Registererweiterung für zusätzliche Funktionen)

Diese Register sind für zusätzliche Funktionen vorgesehen.


Beispiel für Register-Kommunikation

Control-Byte

Das Control-Byte befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R/W | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Registerkommunikation eingeschaltet: Die ersten zwei Byte der Nutzdaten werden nicht für den Prozessdatenaustausch verwendet, sondern in den Registersatz der Feldbus Box geschrieben oder daraus gelesen.
6 | R/W | 0bin | Read: Das Register soll gelesen werden ohne es zu verändern.
 |  | 1bin | Write: Das Register soll beschrieben werden.
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll. Es sind 64 Register adressierbar.
Status-Byte

Das Status-Byte befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Quittung Registerzugriff
6 | R | 0bin | Read
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.

Beispiel 1

Lesen des Registers 8 von KL3204 oder IP/IE3202
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x88 (1000 1000bin) | 0xXX | 0xXX

Bit 0.7 gesetzt bedeutet Register-Kommunikation aktiv
Bit 0.6 nicht gesetzt bedeutet lesen des Registers.
Bit 0.5 bis Bit 0.0 geben mit 001000bin die Registernummer 8 an.
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim lesenden Zugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x88 | 0x0C | 0x84

Die Klemme/Box liefert im Eingangsdatenwort (Byte 1 und Byte 2) die Typ-Bezeichnung 0x0C84 (entspricht unsigned Integer 3204) zurück .

Besonderheit bei der Bezeichnung von Feldbus Boxen:
Die letzte Ziffer des zurückgegebenen unsigned Integer (3204) entspricht nicht der letzten Ziffer der Feldbus Box-Bezeichnung (3202), die für die Anschlussvariante (0 für S8, 1 für M8 und 2 für M12) steht. Sie gibt stattdessen die Anzahl der Kanäle wieder (IE3204 besitzt 4 Kanäle).

Hinweis Damit Register beschreiben werden können, müssen Sie zuvor das Codewort 0x1235 in Register 31 schreiben, um den Schreibschutz zu deaktivieren. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder.
Beachten Sie das einige Einstellungen in den Registern erst nach einem Neustart (Power-Off/Power-ON) des Moduls übernommen werden.

Beispiel 2

Ablauf einer Register-Kommunikation zum ändern eines Register.

1. Schreiben des Register 31 (Codewort setzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x12 | 0x35

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX
2. Lesen des Register 31 (gesetztes Codewort überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x9F | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0x12 | 0x35
3. Schreiben des Register 32 (Register ändern)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)e
0xE0 | 0x00 | 0x02

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0xXX | 0xXX
4. Lesen des Register 32 (geändertes Register überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xA0 | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0x00 | 0x02
5. Schreiben des Register 31 (Codewort zurücksetzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x00 | 0x00

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX


Diagnose-LEDs

Fehlerdiagnose

Es gibt 2 Arten von Fehlern:

  • Feldbus Fehler
  • Lokaler Fehler auf Kompakt Box oder Koppler Box

Blink-Codes

Blinkfolge | Bedeutung
Schnelles Blinken | Anfang
erste langsame Sequenz | Fehler-Code
zweite langsame Sequenz | Fehler-Argument
dritte langsame Sequenz (optional) | Fehler-Argument bei mehr als 20 Erweiterungen

Flasching_codes.jpg (2840 Byte)

Anfang Fehler-Code Fehler-Argument


Diagnose-LEDs für Profibus

Diese werden von den beiden oberen LEDs beschrieben.

LED grün | LED rot | E/A RUN | Beschreibung | Abhilfe
an | an | keine Bedeutung | Modul wartet auf Kommunikation | Eine Baud-Rate wurde gefunden, Kommunikation Starten, falsche Ident-Nummer
aus | an | keine Bedeutung | Modul ist im Baud-Raten Such Modus | Profibus Starten, Busleitung anschließen/kontrollieren
aus | aus | keine Bedeutung | Modul wartet auf zyklische Kommunikation | Die zyklische Profibuskommunikation starten (Task starten)
an | blinkt | keine Bedeutung | Baud-Rate gefunden, Start-Up Fehler | Parameter- oder Konfigurationsfehler, siehe Blink-Code
an | aus | aus | DP-Hochlauf okay aber noch kein Data_Exchange-Telegramm erhalten | Die zyklische Profibuskommunikation starten (Task starten)
an | aus | an | Modul im Datenaustausch | kein Fehler

Parameterdaten Fehler

Fehler-Code 1

Die reservierten und festen UserPrm Data haben einen falschen Wert. Das Fehlerargument gibt das falsche Byte an (Byte 0 startet mit Fehlerargument 1).

Fehler-Code 3

Die Kombination einiger Funktionen, über die UserPrmData, ist nicht erlaubt. Das Fehlerargument gibt nähere Informationen

Fehlerargument | Beschreibung
1 | Im Synchronen-Mode ist es nicht erlaubt die Reaktion auf Profibus-Fehler "Ausgänge unverändert" einzustellen. Der Watchdog des Subbussystem schlägt schneller zu als der Watchdog des Profibus.
2-7 | reserve
8 | Synchron Made ist nicht gestattet wenn keine Ausgänge vorhanden sind.
9-11 | reserve
12 | Der Fast-FreeRun Mode ist nicht erlaubt wenn der Synchron Mode eingeschaltet ist
Fehler-Code 9

Fehler-Code 9 beschreibt Start-Up Fehler

Fehlerargument | Beschreibung
1 | Länge der DP Input Daten zu lang
2 | Länge der DP Output Daten zu lang
3 | Länge der DP CfgData zu lang
4 | IP-Box Typ nicht erkannt
5 | Konfigurationsdaten der DP-Schnittstelle sind nicht OK

Konfigurationsdaten (CfgData) Fehler

Fehler-Code 2

Fehler beim Vergleich der Konfigurationsdaten. Das Fehlerargument zeigt das erste fehlerhafte Byte an (beginnent mit "1")

Fehler-Code 5

Fehler bei der Länge der digitalen Output Daten. Das Fehlerargument zeigt die erwartete Byte Anzahl an.

Fehler-Code 6

Fehler bei der Länge der digitalen Input Daten. Das Fehlerargument zeigt die erwartete Byte Anzahl an.

Fehler-Code 7

Fehler-Code 7 beschreibt CfgData Fehler

Fehlerargument | Beschreibung
1 | Länge der CfgData stimmen nicht
2 | Syntax der CfgData stimmt nicht
3 | Länge der berechneten Input Daten der Konfigurationsdaten ist zu groß
4 | Länge der berechneten Output Daten der Konfigurationsdaten ist zu groß


Diagnose-LEDs für lokale Fehler

Lokale Fehler in einer Koppler Box (IL230x-Bxxx/Cxxx)

Unter den lokalen Fehlern ist gemeint, das ein Fehler in der Feldbus Box oder dem IP-Link aufgetreten ist. IP-Link-Fehler sind meist durch unsachgemäßen Gebrauch der Lichtwellenleitung zurück zu führen.

LED grün | LED rot |  |  | Beschreibung | Abhilfe
aus | aus |  |  | kein Datenaustausch | Modul im synchron Mode - zyklische Daten aktivieren
aus | 1 | 0 |  | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
aus | 2 |  |  | reserviert | -
aus | 3 | n |  | Bruchstelle wurde erkannt | n-tes Modul vor dem Empfänger des Masters
 | 3 | n | m | Bruchstelle wurde erkannt | (n*10)+m-tes Modul vor dem Empfänger des Masters
aus | 4 | n |  | zu viele fehlerhafte Telegramme erkannt (mehr als 25%) | vor dem n-ten Erweiterungsmodul (vor dem Empfänger des Masters) ist die LWL-Verkabelung zu prüfen
aus | 5 | n |  | Registerzugriff auf komplexe Module gescheitert | n-tes Modul überprüfen
aus | 11 | n |  | Komplexes Modul arbeitet fehlerhaft | n-tes Modul tauschen
aus | 12 | n |  | mehr als 120 Module im Ring | weniger Module anschließen
aus | 13 | n |  | n-tes Modul unbekannt | Firmware Update erforderlich
an | aus |  |  | Modul ist im Datenaustausch (kein Fehler) | -

Lokale Fehler in einer Erweiterungsbox

LED grün | LED rot | Beschreibung
aus | an | es werden kein Daten über den IP-Link empfangen
aus | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (sehr schlechte Datenverbindung)
blinkt, flackert | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (schlechte Datenverbindung), muss noch nicht zum Fehler führen
an | aus | es werden IP-Link Protokolle empfangen, kein Fehler

Fehlerhafte IP-Link Protokolle können entstehen durch:

  • schlecht konfektionierte IP-Link Steckverbinder
  • IP-Link Leitung mit erhöhter Dämpfung durch z.B. Knick o.ä.
  • defekte oder verschmutzte Sende LED (Modul vor dem fehlerhaften Modul)
  • defekter oder verschmutzter Empfänger

Der interne IP-Link-Fehlerzähler der Koppler Box kann mit der KS2000 Software ausgelesen werden.


Feldbus Box - Überprüfung der IP-Link-Verbindung

BECKHOFF Feldbus Box: Montage und Verkabelung

Überprüfung der IP-Link-Verbindung

Ein IP-Link-Kabel mit auf beiden Seiten korrekt konfektionierten IP-Link-Steckern garantiert eine fehlerfrei Übertragung.

Eine nachträgliche Prüfung der Übertragungsqualität und eine Fehlersuche ist mit der Konfigurationssoftware KS2000 möglich.

Hierzu sollte die Steuerung (z.B. ein PC mit Profibus-Karte) am Feldbus des Koppler Box angeschlossen sein und diese zyklisch mit Daten versorgen, oder die Koppler Box sollte mit der KS2000 auf freilaufend geschaltet werden.

Als Ergebnis sollte die I/O RUN LED auf dem Kopplermodul hellgrün leuchten. Dies zeigt, dass ein Datenaustausch mit den angeschlossenen Erweiterungsbox Modulen stattfindet. Eine rot flackernde I/O ERR LED zeigt fehlerhafte IP-Link-Telegramme an! Telegramme werden wie bei auch jedem Feldbussystem im Fehlerfall wiederholt, so dass eine Übertragung der Daten gewährleistet ist.

Fehlerzähler

In Tabelle 90, Offset 005 werden aufgetretene IP-Link-Fehler gezählt. Sporadisch auftretende Fehler bedeuten noch keine Probleme für die Kommunikation. Dieser Fehlerzähler wird nur durch ein Power ON/OFF zurückgesetzt.

Sollten in kurzer Zeit viel Fehler auftreten, wird eine schwere Störung diagnostiziert und das Koppler-Modul meldet diesen Fehler. Dies ist am Offset 006 oder 007 zu erkennen. Die beiden Werte stehen dann auf einem Wert > 200 und die I/O ERR LEDs des Koppler-Moduls blinken mit dem entsprechenden Fehler-Code.

Hinweis Die Konfigurations-Software KS2000 kommuniziert über einen seriellen Kanal mit der Koppler Box. Der Registerinhalt wird nicht andauernd aktualisiert, muss also manuell refreshed werden.

Fehlerort

Stellt das Koppler Modul einen Fehler fest, versucht es den Fehlerort aus dem Register der Erweiterungs-Box herauszulesen. Ist der Ring tatsächlich unterbrochen bzw. die Kommunikation stark gestört, ist dies nicht möglich. Dann wird nur der Ort des Bruchs dargestellt und zwar rückwärts vom Koppler gezählt (siehe IP-Link Fehlersuche).

Läuft die Kommunikation noch, kann in Tabelle 87 der Fehlerzähler je Erweiterungsmodul ausgelesen werden.

Hier bezieht sich der Offset auf die Position links im KS2000 Baum (siehe Grafik). d.h. in diesem Beispiel werden Fehler beim Offset 004 und 006 angezeigt.

Im IP-Link Aufbau ist der Fehler also bei der Übertragung zu Modul IE20xx und bei der Übertragung zu IE3112 zu suchen.

Der Fehler kann also liegen, an:

  • dem Sender-Modul
  • dem Empfänger-Modul
  • dem Kabel oder
  • den Steckern

Wird in Tabelle 90 ein Fehler angezeigt, aber in Tabelle 87 nicht, so ist die Fehlerursache in der Übertragungsstrecke zwischen dem letzten Erweiterungsmodul und dem Koppler zu suchen.

In fast allen Fällen sind Übertragungsfehler auf schlecht konfektionierte IP-Link-Stecker oder zu hohe Dämpfung im LWL-Kabel (durch scharfe Knicke o.ä.) zurückzuführen.

Tabelle 87 wird bei einer IP-Link-Unterbrechung nicht aktualisiert, da diese Werte direkt aus den Erweiterungs-Modulen kommen. Diese können dann über den IP-Link natürlich nicht mehr ausgelesen werden.

Hinweis Falls Sie eine Koppler-Box (z.B. IL2300-Bxxx, IL2301-Bxxx oder IL2302-Bxxx ) ganz ohne Erweiterungs-Box-Module (IExxxx) betreiben möchten, müssen Sie Sende- und Empfangs-Anschluss diese Koppler-Box über ein IP-Link-Kabel direkt miteinander verbinden! Hierfür eignet sich besonders der IP-Link-Verbindungsstecker ZK1020-0101-1000.


Trouble Shooting

Sollten Sie Probleme mit dem Modul haben, geben die Status LEDs Hinweise auf die mögliche Fehlerursache.

Vermeiden typischer Fehler

Überprüfung der Profibus-Verkabelung

Ein Profibus-Kabel (bzw. ein Kabel-Segment bei Verwendung von Repeatern) kann mit ein paar einfachen Widerstandsmessungen überprüft werden. Dazu sollte das Kabel von allen Stationen abgezogen werden:

Messpunkte | typischer Widerstand
Zwischen A und B am Anfang der Leitung | ca. 110 Ohm
Zwischen A und B am Ende der Leitung | ca. 110 Ohm
Zwischen A am Anfang und A am Ende der Leitung | ca. 0 Ohm
Zwischen B am Anfang und B am Ende der Leitung | ca. 0 Ohm
Zwischen Schirm am Anfang und Schirm am Ende der Leitung | ca. 0 Ohm

Falls diese Messungen erfolgreich sind, ist das Kabel in Ordnung. Wenn trotzdem noch Bus-Störungen auftreten, liegt es meistens an EMV-Störungen. Sie sollten dann die Installationshinweise der Profibus-Nutzer-Organisation (www.profibus.com) beachtet werden.

Reihenfolge bei der Konfiguration

Tragen Sie beim konfigurieren eines IP-Link mit analogen und digitalen Erweiterungsboxen immer zuerst alle analogen Boxen in der Reihenfolge wie diese am IP-Link angeschlossen sind ein. Tragen Sie danach die digitalen Boxen in der Reihenfolge wie diese am IP-Link angeschlossen sind ein. Dann werden die Ein- und Ausgänge gemappt.

Konfigurationsfehler bei IL230x-B3xx

Feldbus Boxen, die im Ein- oder Ausgangsbereich weniger als 8 Bit Prozessdaten besitzen, werden auf 8 Bit aufgerundet und belegen somit 8 Bit im jeweiligen Bereich. Beachten Sie, dies z.B. für die Box IL230x-B3xx, die vier Ein- und 4 Ausgänge besitzt.

IP-Link-Fehler

Falls die IP-Link-Error-LED leuchtet bzw. unregelmäßig blinkt, werden gar keine oder fehlerhafte Telegramme übertragen. Die Module verstärken zwar jedes Telegramm, können aber einen einmal aufgetretenen Fehler nicht wieder zurückkorrigieren. Der Fehler muss also vom letzten Modul rückwärts bis zum ersten fehlerfreien Modul zurückverfolgt werden. Die Verbindung von diesem Modul zum nächsten ist die Fehlerquelle.

Die Fehlerursache liegt fast immer in IP-Link-Leitungen mit zu hoher Dämpfung. Dies kann z.B. bei der Konfektionierung passieren. Der einfachste Test ist die Sichtprobe. Gegen eine nicht zu helle Lichtquelle gehalten, sollte die jeweilige Steckeroberfläche, hierbei beide Seiten prüfen, ein einheitlich leuchtendes Bild ergeben.

Im Zweifelsfall muss der Stecker neu konfektioniert werden. Dabei ist darauf zu achten, die optische Faser nicht zu weit zurückzuschleifen.

Beim Konfektionieren ist darauf zu achten, dass die Abisoliermaße eingehalten werden.

Das fertige Kabel kann am einfachsten geprüft werden, in dem es zwischen Koppler Box und Erweiterung gesteckt wird. Bei einem korrekt angeschlossenem Kabel gibt es keine fehlerhaften Telegramme.


Konfiguration: Siemens S5 Steuerung mit COM Profibus

BECKHOFF Feldbuskomponenten: Profibus-Slaves - DiagData

Diagnose-Telegramm Übersicht

Parameterdaten | Bezeichnung
Kompakt Boxen | IPxxxx-B3xx
Koppler Boxen | IL230x-B31x
Erweiterungs- Module | IExxxx


Diagnose-Telegramm der Kompakt Box

Feldbuskomponenten: Profibus-Slaves - DiagData

Diagnose-Telegramm der Kompakt Box (IPxxxx-B3xx)

DiagData im DPV1-Format

Die Diagnosedaten werden (wenn sie sich geändert haben) von den Feldbus Boxen automatisch an den DP-Master gemeldet. Die Bedeutung der ersten 6 Bytes ist für alle DP-Slaves gleich, danach folgende gerätespezifische Diagnosedaten. Bei der Kompakt Box ist deren Aufbau entsprechend der Einstellung "Altes Format / DPV1-Format" festgelegt.

In der Regel gibt es bei den DP-Mastern die Möglichkeit über ein Flag in der SPS abzufragen, ob sich die Diagnosedaten geändert haben. Die Diagnosedaten selbst können dann meistens über einen Funktionsbaustein gelesen werden. In der S5 werden die Diagnosedaten mit dem Funktionsbaustein FB IM308C, in der S7 mit den SFC13 und in TwinCAT mit dem Funktionsbaustein ADSREAD gelesen. Die maximale Länge der Diagnosedaten kann in den User_Prm_Data (Byte 11) verändert werden. Wenn mehr Diagnosedaten anstehen als gesendet werden können, wird das in den Diagnosedaten angezeigt.

Diagnose
Byte | Bit | Beschreibung
0 | 0 | Slave antwortet nicht (wird vom DP-Master intern gesetzt)
 | 1 | Slave ist im Hochlauf (Parametrierung und Konfiguration wird ausgewertet)
 | 2 | Konfigurationsfehler
 | 3 | Ext_Diag_Data liegen vor (ab Byte 6)
 | 4 | Funktion wird nicht unterstützt
 | 5 | Falsche Antwort des Slaves (wird vom DP-Master intern gesetzt)
 | 6 | Parametrierfehler
 | 7 | Slave ist mit anderem Master im Datenaustausch (wird vom DP-Master intern gesetzt)
1 | 0 | Slave muss neu parametriert werden
 | 1 | Slave hat statische Diagnose
 | 2 | 1
 | 3 | DP-Watchdog ist aktiv
 | 4 | Slave ist im Freeze-Mode
 | 5 | Slave ist im Sync-Mode
 | 6 | reserviert
 | 7 | Slave ist deaktiviert (wird vom DP-Master intern gesetzt)
2 | 0-6 | reserviert
 | 7 | Zu viele Ext_Diag_Data
3 |  | Stationsadresse des Masters, mit dem Datenaustausch durchgeführt wird
4, 5 |  | Ident-Nummer
Herstellerspezifische Diagnose für Kompakt Box
Byte | Bit | Beschreibung
6 |  | Länge der Ext_Diag_Data inklusive Längenbyte
7 |  | 0x81 (Kennung DPV1 Diagnoseformat)
8 |  | 0x00
9 |  | 0x00
10 |  | 0x00
11 |  | 0x00
12 |  | 0x00
13 |  | 0x00
14 |  | 0x00
15 |  | 0x00
Diagnose für Kompakt Box
Byte | Bit | Beschreibung
16 | 0-5 6-7 | bei Feldbus Boxen sind die Bits 0-5 immer null fehlerhafte Kanalnummer (0-3) 0x00 Kanal 0 0x40 Kanal 1 0x80 Kanal 2 0xC0 Kanal 3
17 | 0-5 6 | Status-Byte des Kanals (Bit 0-5) Allgemeines Fehlerbit
18 | 0-5 6-7 |
19 | 0-5 6 |
... |  |
60 | 0-5 6-7 |
61 | 0-5 6 |

Hinweis Das Status-Byte wird beim komplexen Mapping von der Klemme zur Steuerung übertragen. Es enthält verschiedene Statusbits in Abhängigkeit des entsprechenden Klemmentyps (wie z.B. Prozessdaten kleiner/größer Grenzwert x, Overrange, Underrange etc.)


Diagnose-Telegramm der Kopplerbox

Feldbuskomponenten: Profibus-Slaves - DiagData

Diagnose-Telegramm der Kopplerbox (IL230x-B3xx)

DiagData im DPV1-Format

Die Diagnosedaten werden von den Feldbus Boxen automatisch an den DP-Master gemeldet, wenn sie sich geändert haben. Die Bedeutung der ersten 6 Bytes ist für alle DP-Slaves gleich, danach folgende gerätespezifische Diagnosedaten. Beim der Koppler Box ist deren Aufbau entsprechend der Einstellung "Altes Format / DPV1-Format" festgelegt.

In der Regel gibt es bei den DP-Mastern die Möglichkeit über ein Flag in der SPS abzufragen, ob sich die Diagnosedaten geändert haben. Die Diagnosedaten selbst können dann meistens über einen Funktionsbaustein gelesen werden. In der S5 werden die Diagnosedaten mit dem Funktionsbaustein FB IM308C, in der S7 mit den SFC13 und in TwinCAT mit dem Funktionsbaustein ADSREAD gelesen. Die maximale Länge der Diagnosedaten kann in den User_Prm_Data (Byte 11) verändert werden. Wenn mehr Diagnosedaten anstehen als gesendet werden können, wird das in den Diagnosedaten angezeigt.

Diagnose
Byte | Bit | Beschreibung
0 | 0 | Slave antwortet nicht (wird vom DP-Master intern gesetzt)
 | 1 | Slave ist im Hochlauf (Parametrierung und Konfiguration wird ausgewertet)
 | 2 | Konfigurationsfehler
 | 3 | Ext_Diag_Data liegen vor (ab Byte 6)
 | 4 | Funktion wird nicht unterstützt
 | 5 | Falsche Antwort des Slaves (wird vom DP-Master intern gesetzt)
 | 6 | Parametrierfehler
 | 7 | Slave ist mit anderem Master im Datenaustausch (wird vom DP-Master intern gesetzt)
1 | 0 | Slave muss neu parametriert werden
 | 1 | Slave hat statische Diagnose
 | 2 | 1
 | 3 | DP-Watchdog ist aktiv
 | 4 | Slave ist im Freeze-Mode
 | 5 | Slave ist im Sync-Mode
 | 6 | reserviert
 | 7 | Slave ist deaktiviert (wird vom DP-Master intern gesetzt)
2 | 0-6 | reserviert
 | 7 | Zu viele Ext_Diag_Data
3 |  | Stationsadresse des Masters, mit dem Datenaustausch durchgeführt wird
4, 5 |  | Ident-Nummer
Herstellerspezifische Diagnose für Koppler Box
Byte | Bit | Beschreibung
6 |  | Länge der Ext_Diag_Data inklusive Längenbyte
7 |  | 0xA1 (Kennung DPV1 Diagnoseformat)
8 |  | 0x00
9 |  | 0x00
10 |  | 0x00
11 | 0 | kein Fehler
 | 1 | Start IP-Link-Fehlererkennungsdiagnose
 | 32 | Allgemeiner IP-Link-Fehler
12 | 0 | kein Fehler
 | 3 | IP-Link Unterbrechung Fehlerargument: Fehlerstelle (Achtung: Bei Kabelbruch ist die Zählrichtung entgegen der Lichtleiterverkabelung)
 | 4 | IP-Link Timeout-Fehler Fehlerargument: Fehlerstelle
 | 5 | Fehler beim Lesen der Register der komplexen Module Fehlerargument: Problematisches Modul
 | 11 | Erweiterungsmodul bearbeitet das Synchronisationstelegramm nicht Fehlerargument: Problematisches Modul
 | 12 | Mehr als 120 Module verkabelt Fehlerargument: Anzahl der zuviel gesteckten Module
 | 13 | Modultyp wird nicht unterstützt Fehlerargument: Problematisches Modul
13 | 0-120 | Fehlerargument: IP-Link-Fehler (z.B. Leitungsbruch) hinter der n .ten Erweiterungsbox. Zählung beginnend mit n = 1 von der letzten angeschlossenen Erweiterungsbox in Richtung Kopplerbox (siehe auch Beschreibung zum Fehlerargument Error LED). Fehlerargument n=0 entspricht IP-Link-Fehler zwischen der Kopplerbox und der letzten angeschlossenen Erweiterungsbox. Achtung: Bei Kabelbruch ist die Zählrichtung entgegen der Lichtleiterverkabelung
14 |  | 0x00
15 |  | 0x00
Diagnose für Koppler Box und SPS Box
Byte | Bit | Beschreibung
16 | 0-7 | fehlerhafte IE-Box-Nummer (1-120 nur komplexe Module werden in Zählrichtung "mit dem Licht" gezählt)
17 | 0-5 6-7 | Status-Byte des Kanals (Bit 0-5) fehlerhafte Kanalnummer (0-3)
18 | 0-7 |
19 | 0-5 6-7 |
... | ... |
60 | 0-7 |
61 | 0-5 6-7 |

Hinweis Das Status-Byte wird beim komplexen Mapping von der Klemme zur Steuerung übertragen. Es enthält verschiedene Statusbits in Abhängigkeit des entsprechenden Klemmentyps (wie z.B. Prozessdaten kleiner/größer Grenzwert x, Overrange, Underrange etc.)


TwinCAT-Beispiel für die Diagnose mit der Feldbuskarte FC310x

Über das Bit DiagnoseStation11 wird die Diagnose der Station 11 gemeldet. Die Diagnoseinformationen werden mit dem ADS-Baustein ausgelesen und in das Array strDiagnose kopiert. Dort kann die weitere Bearbeitung erfolgen.

NETID NetID der FC310x Karte
Port Diagnose Port Fest 200
IDXGRP Slave-Adresse im High-Wort und die Konstante 0xF181 im Low-Wort
IDXOFF immer "0", gesamte Diagnose auslesen
LEN 276 Byte

Aufbau der Diagnosedaten

Offset | Beschreibung
0 | Receive-Error-Counter (WORD): Anzahl der fehlerhaften Telegramme bei der Kommunikation mit diesem Slave
2 | ab FC310x, Version 1.11: Repeat-Counter[9] (WORD): Die Repeat-Counter zeigen an, wie oft wie viele Repeats (1..MaxRetryLimit, MaxRetryLimit ohne Antwort) gemacht werden mussten. Repeat-Counter[0] zeigt an, wie oft ein Telegramm zu diesem Slave einmal wiederholt werden musste, Repeat-Counter[1], wie oft ein Telegramm zu diesem Slave zweimal wiederholt werden musste, etc. Der Parameter MaxRetryLimit kann in den Profibus-Parametern eingestellt werden (Wertebereich 0..8)
20 | NoAnswer-Counter (DWORD): Anzahl der Telegramme bei der Kommunikation mit diesem Slave, auf die nicht geantwortet und bei denen kein Repeat durchgeführt wurde. Wenn ein Slave das erste Mal nicht antwortet, wird bis zu MaxRetryLimit mal das Telegramm wiederholt, wenn er auch dann nicht geantwortet hat, wird beim nächsten Mal keine Wiederholung mehr durchgeführt.
24-31 | reserviert
32-37 | Profibus-Norm-Diagnose
38-275 | Profibus-Norm-Extended-Diagnose (siehe Dokumentation des Herstellers)

Programmbeispiel

VAR
DiagnoseStation11 AT %IX100.0:BOOL;
strDiagnose : ARRAY[0..275] OF BYTE;
fbADSREAD : ADSREAD;
k: INT;
END_VAR

CASE k OF
 0: IF DiagnoseStation11 THEN fbADSREAD( NETID:= '172.16.3.106.2.1',
                        PORT:=200,
                        IDXGRP:=16#BF181,
                        IDXOFFS:=16#0,
            LEN:=276,
            DESTADDR:=ADR(strDiagnose),
            READ:= TRUE,
            TMOUT:= t#10s, );
        k:=k+1;
    END_IF
 1: 	fbADSREAD(READ:= FALSE);
    IF NOT fbADSREAD.busy THEN
        k:=0;
    END_IF
END_CASE


PROFIBUS-Zubehör

Dieses Zubehör können Sie auch für andere RS485-basierte Feldbussysteme (Modbus, RS485) verwenden.

PROFIBUS-Kabel

Bestelldaten

Bestellbezeichnung | Feldbuskabel | Verbinder | Kontakte | Querschnitt | Länge | Abb.
ZK1031-6200-1020 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 2,00 | A
ZK1031-6200-1050 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 5,00 | A
ZK1031-6200-1100 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 10,00 | A
ZK1031-6200-1150 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 15,00 | A
ZK1031-6100-1020 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 2,00 | B
ZK1031-6100-1050 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 5,00 | B
ZK1031-6100-1100 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 10,00 | B
ZK1031-6100-1150 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 15,00 | B
ZK1031-6251-1003 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 0,30 | A und B
ZK1031-6251-1005 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 0,50 | A und B
ZK1031-6251-1010 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 1,00 | A und B
ZK1031-6251-1020 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 2,00 | A und B
ZK1031-6251-1050 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 5,00 | A und B
ZK1031-6251-1100 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 10,00 | A und B
ZK1031-6251-1150 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 15,00 | A und B

Add PROFI cable.jpg (10647 Byte)

Stecker

PB_Buchse_klein.gif (11264 Byte) PB_Stecker_klein.gif (13122 Byte)

Pinbelegung

Profibus_IP_Pins_FeMale.gif (3009 Byte) Profibus_IP_Pins_Male.gif (3149 Byte) 1 nc.
2 grün
3 nc.
4 rot
5 Shield

Technische Daten

Elektrische Daten |
Bemessungsdaten | 300 V, 80°C
Material | Außenmantel PUR, Innere Isolierung Polyethylen
Querschnitt | 0,32 mm²
DC Widerstand | 54,12 Ohm/km
Leitungskapazität | 26,9 pF/m
Nominal-Impedanz | 150 Ohm bei 1 MHz
Zulassung | UL-Zulassung, AWM, Typ 20233, 80°C, 300V; CSA AWM, I/II A/B, 80°C, 300V FT1

Zubehör PROFIBUS

Bestelldaten

Bestellbezeichnung | Beschreibung
ZS1031-2600 | T-Stück, 12 MBaud
ZS1000-2600 | Y-Stück, 12 MBaud
ZS1000-1610 | Endwiderstand (Stecker)
ZS1000-0620 | Kupplung feldkonfektionierbar
ZS1000-0610 | Stecker feldkonfektionierbar
ZS1031-6610 | Schaltschrank Durchführung M12, Stecker-Kupplung

ZS1031-2600

PB T conector size.gif (37847 Byte) Add PROFI T-connector diag.gif (5258 Byte)

ZS1000-2600

Add PROFI Y-connector.gif (17718 Byte) Add PROFI Y-connector diag.gif (5090 Byte)

ZS1000-1610

Add Profibus End.gif (7936 Byte)

ZS1031-6610

Add Profibus ZS1031-6610.gif (6530 Byte)


Feldbus Box Zubehör

Das notwendige Zubehör für die Feldbus Box Module gibt es in Schutzklasse IP67 ebenfalls von Beckhoff. Eine Übersicht entnehmen Sie bitte aus dem Beckhoff Katalog oder unseren Internet-Seiten (http://www.beckhoff.de).

Feldbuszubehör

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Spannungsversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Sensorversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

IP-Link

  • Vorkonfektionierte Kabel
  • Stecker


Allgemeine Betriebsbedingungen

Schutzarten nach IP-Code

In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.

1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub

2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist

*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.

Chemische Beständigkeit

Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus Box und den verwendeten Metallteilen.

Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende

beständig: Lebensdauer mehrere Monate
bedingt beständig: Lebensdauer mehrere Wochen
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zulassungen

UL E172151

Konformitätskennzeichnung

CE

Schutzart

IP65/66/67 gemäß EN60529


Prüfnormen für die Geräteprüfung

EMV

Festigkeit: EN 61000-6-2

Aussendung: EN 61000-6-4

Vibrationsfestigkeit

Schwingungsprüfung: EN 60068-2-2, Amplitude 2 g (Norm 1 g)

Schockprüfung: EN 60068-2-27, Schockanzahl 1000 (Norm 2)


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Abkürzungsverzeichnis

In Vorbereitung


BECKHOFF Feldbus Box: Fehlerdiagnose

Error Codes

In Vorbereitung.


Feldbusbox - Abmessungen

BECKHOFF Feldbus Box: Montage

Abmessungen

Alle Maßangaben sind in Millimeter angegeben.

Allgemein

Technische Daten | Feldbus Box
Gehäusematerial | PA6 (Polyamid), Vergussmasse: Polyuhrethan
Montage | 2 x Befestigungslöcher für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | IEC EN 50082-2 / EN 50081-2
Zulässige Umgebungstemperatur im Betrieb | 0 ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25 ... + 85°C
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65/66/67
Zulassungen | CE, UL E172151

IPxxxx-Bxx8, IL230x-Bxx8, IL230x-B110, IXxxxx-B400, IXxxxx-B90x, IXxxxx-C900

Technische Daten | Kompakt- und Kopplerbox mit integriertem T-Stück
Abmessungen (H x B x T) | ca. 210 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm)
Gewicht | ca. 260 g - 290 g, je nach Modultyp

IPxxxx-Bxx0, IL230x-Bxx0, IL230x-Cxx0

Technische Daten | Kompakt- und Kopplerbox
Abmessungen (H x B x T) | ca. 175 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm, mit T-Stück ZS1031-2600 Höhe ca. 65 mm)
Gewicht | ca. 250 g - 280 g, je nach Modultyp

IExxxx

Technische Daten | Erweiterungsbox
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Gewicht | ca. 120 g - 200 g, je nach Modultyp


Feldbus Box: Fehlerdiagnose

Listen

In Vorbereitung.


BECKHOFF Feldbus Box: Fehlerdiagnose

Literaturverzeichnis

In Vorbereitung.


DPV1-Functionality Example TC ADS

BECKHOFF Feldbus Box: DPV1 ADS Beispiel

Beispiel für die DPV1 Kommunikation an einem IL2301-B310

Um die DV1-1 Dienste zu nutzen muss beim Buskoppler oder der Feldbus Box dieser Dienst aktiviert werden. Hierzu wird im System Manager an dieser Box der Karteireiter PrmData die DP-V1 Dienste auf "werden unterstützt" gestellt.

NETID
Port
IDXGRP
IDXOFFS
LEN
SRCADDR
WRITE

Example Tc_DPV1_1.gif (3323 Byte)

Example Tc_DPV1_2.gif (8084 Byte)


BECKHOFF Feldbus Box: PROFIBUS

Feldbuskarten

In Vorbereitung.


BECKHOFF Feldbus Box: PROFIBUS

Beispiel

In Vorbereitung.


Dienste

In Vorbereitung.


Servicedaten

In Vorbereitung.


Objekte und Daten

In Vorbereitung.


Registerbeschreibung

In Vorbereitung.


Schnelleinstieg für erfahrene Anwender

In Vorbereitung.


Temperature °F/°C

Feldbus Box: Analoge Eingänge Temperatur

Anwenderskalierung

Um das Modul auf Fahrenheit umzustellen müssen Sie die Formel umrechnen und die Anwender-Register beschreiben.

Formel:
°F = 9/5 x °C + 32

Zur Einstellung der Skalierung auf 1/10 °F wird der konstante Teil (Offset) mit 10 multipliziert.
Das bedeutet :

  • für den Offset 32 *10 =320
  • für den Gain (9/5 *10/16 *256) = 288

Nötige Registereinstellungen:

  • R31 Codewort setzen = 0x1235
  • R32 Herstellerskalierung deaktivieren
  • R32 Anwenderskalierung aktivieren
  • R33 Anwender Offset = 320dez
  • R34 Anwender Gain = 288dez

Die Änderungen der Skalierung sind sofort gültig und sind für jeden Kanal separat einstellbar.