IL230x-B110 - Feldbus Box für EtherCAT

BECKHOFF Feldbuskomponenten

Dokumentation zur

IL230x-B110

Feldbus Box für EtherCAT

Version: 1.0.2
Datum: 29.10.2009

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


IL230x-B110 - Ausgabestände der Dokumentation

BECKHOFF IL230x-B110: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
1.0.2
  • Systemübersicht aktualisiert
  • Beschreibung des CoE-Interfaces aktualisiert
1.0.1 | EtherCAT-Anschluss aktualisiert
1.0 | Erste Veröffentlichung


Buskoppler als allgemeine Bezeichnung

Teile des vorliegenden Handbuches geben allgemeine Informationen über die Ethernet-Implementierung in Beckhoff Produkten.
Im folgenden wird daher oft der Begriff Buskoppler genutzt, der hier nicht nur die IP20-Produkte beschreibt, sondern auch die IP67-Module meint.


Systemeihenschaften

BECKHOFF EtherCAT: Systemübersicht

Systemeigenschaften

Protokoll

Das für Prozessdaten optimierte EtherCAT-Protokoll wird dank eines speziellen Ether-Types direkt im Ethernet-Frame transportiert. Es kann aus mehreren Sub-Telegrammen bestehen, die jeweils einen Speicherbereich des bis zu 4 Gigabyte großen logischen Prozessabbildes bedienen. Die datentechnische Reihenfolge ist dabei unabhängig von der physikalischen Reihenfolge der Ethernet-Klemmen im Netz, es kann wahlfrei adressiert werden. Broadcast, Multicast und Querkommunikation zwischen Slaves sind möglich. Die Übertragung direkt im Ethernet-Frame wird stets dann eingesetzt, wenn EtherCAT-Komponenten im gleichen Subnetz wie der Steuerungsrechner betrieben werden.

Der Einsatzbereich von EtherCAT ist jedoch nicht auf ein Subnetz beschränkt: EtherCAT UDP verpackt das EtherCAT Protokoll in UDP/IP-Datagramme. Hiermit kann jede Steuerung mit Ethernet-Protokoll-Stack EtherCAT-Systeme ansprechen. Selbst die Kommunikation über Router hinweg in andere Subnetze ist möglich. Selbstverständlich hängt die Leistungsfähigkeit des Systems in dieser Variante von den Echtzeiteigenschaften der Steuerung und ihrer Ethernet-Protokollimplementierung ab. Die Antwortzeiten des EtherCAT-Netzwerks an sich werden jedoch nur minimal eingeschränkt: lediglich in der ersten Station muss das UDP-Datagramm entpackt werden.

Protokollstruktur: Die Prozessabbild-Zuordnung ist frei konfigurierbar. Daten werden direkt in der E/A-Klemme an die gewünschte Stelle des Prozessabbilds kopiert: zusätzliches Mapping ist überflüssig. Der zur Verfügung stehende logische Adressraum ist mit 4 Gigabyte sehr groß.

Topologie

Linie, Baum oder Stern: EtherCAT unterstützt nahezu beliebige Topologien. Die von den Feldbussen her bekannte Bus- oder Linienstruktur wird damit auch für Ethernet verfügbar. Besonders praktisch für die Anlagenverdrahtung ist die Kombination aus Linie und Abzweigen bzw. Stichleitungen. Die hierzu benötigten Schnittstellen sind auf den Kopplern vorhanden; zusätzliche Switches werden nicht benötigt. Natürlich kann aber auch die klassische Switch-basierte Ethernet-Sterntopologie eingesetzt werden.

Maximale Flexibilität bei der Verdrahtung:
mit und ohne Switch, Linien- und Baumtopologien frei wähl- und kombinierbar.

Die maximale Flexibilität bei der Verdrahtung wird durch die Auswahl verschiedener Leitungen vervollständigt. Flexible und sehr preiswerte Standard Ethernet-Patch-Kabel übertragen die Signale auf Ethernet-Art (100Base-TX). Die gesamte Bandbreite der Ethernet-Vernetzung – wie verschiedenste Lichtleiter und Kupferkabel – kann in der Kombination mit Switches oder Medienumsetzern zum Einsatz kommen.

Distributed Clocks

Der exakten Synchronisierung kommt immer dann eine besondere Bedeutung zu, wenn räumlich verteilte Prozesse gleichzeitige Aktionen erfordern. Das kann z. B. in Applikationen der Fall sein, wo mehrere Servo-Achsen gleichzeitig koordinierte Bewegungen ausführen.

Der leistungsfähigste Ansatz zur Synchronisierung ist der exakte Abgleich verteilter Uhren – wie im neuen Standard IEEE 1588 beschrieben. Im Gegensatz zur vollsynchronen Kommunikation, deren Synchronisationsqualität bei Kommunikationsstörungen sofort leidet, verfügen verteilte abgeglichene Uhren über ein hohes Maß an Toleranz gegenüber möglichen störungsbedingten Verzögerungen im Kommunikationssystem.

Beim EtherCAT basiert der Datenaustausch vollständig auf einer reinen Hardware-Maschine. Da die Kommunikation eine logische (und dank Vollduplex-Fast-Ethernet auch physikalische) Ringstruktur nutzt, kann die Mutter-Uhr den Laufzeitversatz zu den einzelnen Tochter-Uhren einfach und exakt ermitteln – und umgekehrt. Auf Basis dieses Wertes werden die verteilten Uhren nachgeführt und es steht eine hochgenaue netzwerkweite Zeitbasis zur Verfügung, deren Jitter deutlich unter einer Mikrosekunde beträgt.

Hochauflösende verteilte Uhren dienen aber nicht nur der Synchronisierung, sondern können auch exakte Informationen zum lokalen Zeitpunkt der Datenerfassung liefern. Steuerungen berechnen beispielsweise häufig Geschwindigkeiten aus nacheinander gemessenen Positionen. Speziell bei sehr kurzen Abtastzeiten führt schon ein kleiner zeitlicher Jitter in der Wegerfassung zu großen Geschwindigkeitssprüngen. Konsequenterweise werden mit EtherCAT auch neue, erweiterte Datentypen eingeführt (Timestamp und Oversampling Data Type). Mit dem Messwert wird die lokale Zeit mit einer Auflösung von bis zu 10 ns verknüpft - die große Bandbreite von Ethernet macht das möglich. Damit hängt dann die Genauigkeit einer Geschwindigkeitsberechnung nicht mehr vom Jitter des Kommunikationssystems ab. Sie wird um Größenordnungen besser als diejenige von Messverfahren, die auf jitterfreier Kommunikation basieren.

Performance

Mit EtherCAT werden neue Dimensionen in der Netzwerk-Performance erreicht. Dank FMMU-Chip in der Klemme und DMA-Zugriff auf die Netzwerkkarte des Masters erfolgt die gesamte Protokollbearbeitung in Hardware. Sie ist damit unabhängig von der Laufzeit von Protokoll-Stacks, von CPU-Performance oder Software-Implementierung. Die Update-Zeit für 1000 E/As beträgt nur 30 µs – einschließlich Klemmen-Durchlaufzeit. Mit einem einzigen Ethernet-Frame können bis zu 1486 Bytes Prozessdaten ausgetauscht werden – das entspricht fast 12000 digitalen Ein- und Ausgängen. Für die Übertragung dieser Datenmenge werden dabei nur 300 µs benötigt.

Für die Kommunikation mit 100 Servoachsen werden nur 100 µs benötigt. In dieser Zeit werden alle Achsen mit Sollwerten und Steuerdaten versehen und melden ihre Ist-Position und Status. Mit den Distributed-Clocks können die Achsen dabei mit einer Abweichung von deutlich weniger als einer Mikrosekunde synchronisiert werden.

Die extrem hohe Performance der EtherCAT-Technologie ermöglicht Steuerungs- und Regelungskonzepte, die mit klassischen Feldbussystemen nicht realisierbar waren. So kann beispielsweise nicht nur die Geschwindigkeitsregelung, sondern neu auch die Stromregelung verteilter Antriebe über das Ethernet-System erfolgen. Die enorme Bandbreite erlaubt es, zu jedem Datum z. B. auch Status-Informationen zu übertragen. Mit EtherCAT steht eine Kommunikationstechnologie zur Verfügung, die der überlegenen Rechenleistung moderner Industrie-PCs entspricht. Das Bussystem ist nicht mehr der Flaschenhals im Steuerungskonzept. Verteilte E/As werden schneller erfasst, als dies mit den meisten lokalen E/A-Schnittstellen möglich ist. Das EtherCAT Technologieprinzip ist skalierbar und nicht an die Baudrate von 100 MBaud gebunden – eine Erweiterung auf GBit Ethernet ist möglich.

Diagnose

Die Erfahrungen mit Feldbussystemen zeigen, dass die Verfügbarkeit und Inbetriebnahmezeiten entscheidend von der Diagnosefähigkeit abhängen. Nur eine schnell und präzise erkannte und eindeutig lokalisierbare Störung kann kurzfristig behoben werden. Deshalb wurde bei der Entwicklung des EtherCAT-Systems besonderer Wert auf vorbildliche Diagnoseeigenschaften gelegt.

Bei der Inbetriebnahme gilt es zu prüfen, ob die Ist-Konfiguration der E/A-Klemmen mit der Soll-Konfiguration übereinstimmt. Auch die Topologie sollte der gespeicherten Konfiguration entsprechen. Durch die eingebaute Topologie-Erkennung bis hinunter zu den einzelnen Klemmen kann nicht nur diese Überprüfung beim Systemstart stattfinden – auch ein automatisches Einlesen des Netzwerkes ist möglich (Konfigurations-Upload).

Bitfehler in der Übertragung werden durch die Auswertung der CRC-Prüfsumme zuverlässig erkannt: das 32 Bit CRC-Polynom weist eine minimale Hamming-Distanz von 4 auf. Neben der Bruchstellenerkennung und -lokalisierung erlauben Protokoll, Übertragungsphysik und Topologie des EtherCAT-Systems eine individuelle Qualitätsüberwachung jeder einzelnen Übertragungsstrecke. Die automatische Auswertung der entsprechenden Fehlerzähler ermöglicht die exakte Lokalisierung kritischer Netzwerkabschnitte. Schleichende oder wechselnde Fehlerquellen wie EMV-Einflüsse, fehlerhafte Steckverbindungen oder Kabelschäden werden erkannt und lokalisiert, auch wenn sie die Selbstheilungsfähigkeit des Netzwerkes noch nicht überfordern.

Integration von Beckhoff Standard-Busklemmen

Neben den neuen Busklemmen mit E-Bus-Anschluss (ELxxxx) lassen sich auch sämtliche Busklemmen aus dem bewährten Standardprogramm mit K-Bus-Anschluss (KLxxxx) über den Buskoppler BK1120 oder BK1250 anschließen. Damit sind Kompatibilität und Durchgängigkeit zum bestehenden Beckhoff Busklemmensystemen gewährleistet. Bestehende Investitionen werden geschützt.


CoE-Interface

Objektverzeichnis

Jeder EtherCAT-Slave der das CoE-Interface unterstützt, besitzt ein Objektverzeichnis in dem alle Parameter-, Diagnose-, Prozess- oder sonstige Daten aufgeführt sind, die über EtherCAT gelesen oder beschrieben werden können.

Das Objektverzeichnis ist per SDO-Information-Dienst auslesbar und in der Gerätebeschreibungsdatei enthalten. Jeder EtherCAT-Slave sollte den SDO-Information-Dienst zumindest soweit unterstützen, das die kompakte Objektbeschreibung eines jeden Objekts (ab Index 0x1000) auslesbar ist. Diese Objektbeschreibung enthält den Datentyp, die Länge, die Zugriffsrechte und die Information, ob das Objekt in ein PDO abzubilden (also als Prozessdatum verwendbar) ist.

Start-Up Liste

Der Start-Up Liste beschreibt den Zusammenhang zwischen EtherCAT State-Machine, dem Prozessdaten-Mapping und dem Einstellen von Geräteparametern im Hochlauf des EtherCAT-Netzwerks.

Wiederherstellen des Auslieferungszustandes

Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt "Restore default parameters", Subindex 001angewählt werden (s. Abb. 1)

Abb.1 Auswahl des PDO "Restore default parameters"

Durch Doppelklick auf "SubIndex 001"gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld "Dec" den Wert "1684107116" oder alternativ im Feld "Hex" den Wert "0x64616F6C" ein und bestätigen Sie mit "OK" (Abb. 2).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.

Abb.2 Eingabe des Restore-Wertes im Set Value Dialog

Hinweis 		Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:

Dezimalwert: "1819238756"
Hexadezimalwert: "0x6C6F6164"

Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


EtherCAT State Machine

Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.

Es werden folgende Zustände unterschieden:

  • Init
  • Pre-Operational
  • Safe-Operational und
  • Operational
  • Boot

Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.

Init

Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init . Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.

Pre-Operational (Pre-Op)

Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.

Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.

Safe-Operational (Safe-Op)

Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).

Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.

Hinweis 		Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS.

Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.

Operational (Op)

Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet muss er bereits gültige Outputdaten übertragen.

Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.

Boot

Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.

Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


Das Feldbus Box System

Feldbus Box Module sind robuste Feldbusstationen für viele verschiedene Feldbus-Systeme. Sie verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Neben digitalen und analogen Ein- und Ausgängen samt Thermoelement- und RTD-Eingängen gibt es Inkrementalencoder-Interfaces für die Weg- und Winkelmessung sowie serielle Schnittstellen für die Lösung vielfältiger Kommunikationsaufgaben.

Signalanschluss in 3 Varianten

Die digitalen Ein-/Ausgänge können wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12-Variante vorgesehen.

Alle wichtigen Signalformen

Spezielle Ein-/Ausgangskanäle auf den Kombi-E/A-Module lassen sich wahlweise als Ein- oder Ausgang nutzen. Eine Konfiguration ist nicht erforderlich, da die Feldbusschnittstelle für jeden Kombikanal sowohl Eingangs- als auch Ausgangsdaten zur Verfügung stellt. Durch die Kombi-Module hat der Anwender alle Vorteile einer feinen Signal-Granularität.

Die Prozessor-Logik, die Eingangsbeschaltung sowie die Sensorversorgung werden aus der Steuerspannung gespeist. Die Lastspannung für die Ausgänge kann separat zugeführt werden. Bei Feldbus Boxen, in denen nur Eingänge zur Verfügung stehen, kann die Lastversorgung UP zur Weiterleitung optional angeschlossen werden.

Die Zustände der Feldbus Box, der Feldbusverbindung, der Spannungsversorgung sowie der Signale werden von LEDs angezeigt.

Die Beschriftungsstreifen lassen sich extern maschinell beschriften und können dann eingeschoben werden.

Kombinierbare Feldbus Boxen für mehr Flexibilität

Die Feldbus Box Serie umfasst neben der Kompakt Box auch erweiterbare Geräte, die Koppler Box und die Erweiterungsbox sowie intelligente Geräte, die SPS Boxen.

Kompakt Box

Die Kompakt Box stellt dem Feldbus die E/A-Daten der angeschlossenen digitalen und analogen Sensoren und Aktuatoren zur Verfügung.

Koppler Box

Die Koppler Box sammelt zusätzlich über eine störsichere LWL-Verbindung (IP-Link) E/A-Daten von den Erweiterungsboxen ein. Sie können bis zu 120 Erweiterungsboxen an eine Koppler Box anschließen. Es ergibt sich so ein verteiltes IP67 E/A-Netzwerk mit nur einer Feldbusschnittstelle.

Die Koppler Box erkennt die angeschlossenen Erweiterungsmodule selbsttätig in der Aufstart-Phase und mappt die E/A-Daten automatisch in das Feldbus-Prozessabbild – eine Konfiguration ist nicht erforderlich. Aus Sicht des Feldbusses stellt sich die Koppler Box samt allen vernetzten Erweiterungsboxen als ein einziger Busteilnehmer mit entsprechend vielen E/A-Signalen dar.

Die Koppler Box entspricht dem Buskoppler aus dem BECKHOFF Busklemmen-System. BECKHOFF Feldbus-Geräte der Schutzart IP 20 (Busklemmen) und IP 67 (Feldbus Box) können problemlos kombiniert werden - das Daten-Handling ist jeweils gleich.

IP-Link

IP-Link ist eine LWL-Verbindung mit 2 Megabit/s Übertragungsrate, die 1000 binäre E/A-Daten in ca. 1 ms schnell und sicher überträgt – kleinere Konfigurationen entsprechend schneller. Durch die hohe Nutzdatenrate ist gewährleistet, dass die Kopplung über IP-Link keine spürbare Einschränkung der Feldbus-Performance mit sich bringt.

Für die schnelle und einfache Konfektionierung der IP-Link-Kabel vor Ort wurden preisgünstige Steckverbinder in IP 67 Schutzart entwickelt. Der Anschluss erfordert kein Spezialwerkzeug und lässt sich schnell und einfach durchführen. Die IP-Link-Kabel sind alternativ auch mit vorkonfektionierten Steckern erhältlich.

Durch die getrennte Zuführung der Ausgangs-Spannungsversorgung lassen sich Ausgangsgruppen einzeln abschalten. Außerdem können problemlos unterschiedliche Potenziale innerhalb eines Erweiterungsringes aufgebaut werden, da IP-Link naturgemäß über eine optimale Potenzialtrennung verfügt.

Erweiterungsbox

Die Erweiterungsboxen decken wie die Kompakt Boxen das gesamte Spektrum der E/A-Signale ab und dürfen bis zu 15 m Abstand voneinander haben. Sie bauen hierbei besonders klein und führen zu besonders preiswerten E/A-Lösungen in hoher Schutzart. Auch hier sind die digitalen Ein-/Ausgänge wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder anschließbar. Analoge Signaltypen werden mit der M12-Variante ausgerüstet. Die Schnapp-Steckverbinder verriegeln formschlüssig und ergeben eine rüttelfeste Verbindung, während sich die Schraub-Steckverbinder durch eine hohe Zugfestigkeit auszeichnen.

SPS Box

Die SPS Box ist eine intelligentes Feldbus Box mit SPS-Funktionalität für dezentrale Vorverarbeitung der E/A-Signale. Hiermit lassen sich Applikationsteile aus der zentralen Steuerung auslagern. Deren CPU und der Feldbus werden entlastet. Dezentral Zählen, Regeln oder Schalten sind typische Anwendungen für die SPS-Box. Die Reaktionszeiten sind unabhängig von der Buskommunikation und der übergeordneten Steuerung.

Bei Bus- oder Steuerungsausfall ist ein Funktionserhalt (z.B. geordnete Überführung des Prozesses in einen sicheren Zustand) möglich.

Die Programmierung erfolgt mit TwinCAT nach IEC 61131-3. Fünf verschiedene Programmiersprachen stehen zur Verfügung:

  • Anweisungsliste (AWL)

  • Funktionsplan (FUP)

  • Kontaktplan (KOP)

  • Ablaufsprache (AS)

  • Strukturierter Text (ST).

Der Programm-Download erfolgt wahlweise über den Feldbus oder über die Programmierschnittstelle.

Es stehen umfangreiche Debug-Funktionalitäten (Breakpoint, Einzelschritt, Monitoring, etc.) zur Verfügung. SPS Box verfügt über einen leistungsfähigen 16 Bit Controller, 32/96 KByte Programmspeicher und 32/64 KByte Datenspeicher. Weiter stehen 512 Byte als nichtflüchtiger Speicher für remanente Merker zur Verfügung.

SPS Box mit IP-Link

Nahezu unbeschränkte E/A-Möglichkeiten ergeben sich durch die programmierbare SPS Box mit IP-Link. Aus dem SPS-Programm heraus lassen sich bis zu 120 Erweiterungsmodule mit über 2000 E/As direkt ansprechen. Die SPS Box eignet sich damit auch als autarke Kleinsteuerung zur Steuerung von Anlagenteilen oder kleiner Maschinen.


Feldbus Box - Bezeichnungsübersicht

Die Bezeichnung der Feldbus Box Module ist wie folgt zu verstehen:
IXxxxy-zyyy

IX beschreibt die Bauform:

"IP" steht für die Bauform Kompakt Box.
"IL" steht für die Bauform Koppler Box (mit IP-Link).
"IE" steht für die Bauform Erweiterungsbox.

xxxy beschreibt die E/A-Beschaltung:

xxx bezeichnet die E/A-Eigenschaft:
"10x" - 8 x digitale Eingänge
"15x" - Zählermodul
"20x" - 8 x digitale Ausgänge
"23x" - 4 x digitale Eingänge und 4 x digitale Ausgänge
"24x" - 8 x digitale Eingänge und 8 x digitale Ausgänge
"25x" - PWM-Modul
"3xx" - 4 x analoge Eingänge
"4xx" - 4 x analoge Ausgänge
"5xx" - Inkremental-Encoder oder SSI-Geber
"6xx" - Gateway-Module RS232, RS422, RS485, TTY

y beschreibt den mechanischer Anschluss:
"0" steht für 8mm Schnappanschluss
"1" steht für M 8 Schraubanschluss
"2" steht für M 12 Schraubanschluss und
"9" steht für M23 Schraubanschluss

zyyy bezeichnet die Programmierbarkeit und das Feldbus-System:

z unterscheidet ob es sich um einen Slave oder einen programmierbare Slave handelt:
"B" - nicht programmierbar
"C" - programmierbar (SPS Box)

yyy steht für das Feldbus-System und den Bus-Anschluss:
"110" - EtherCAT
"200" - Lightbus
"310" - PROFIBUS
"318" - PROFIBUS mit integriertem T-Stück
"400" - Interbus
"510" - CANopen
"518" - CANopen mit integriertem T-Stück
"520" - DeviceNet
"528" - DeviceNet mit integriertem T-Stück
"730" - Modbus
"800" - RS485
"810" - RS232
"900" - Ethernet TCP/IP mit RJ45 für den Bus-Anschluss
"901" - Ethernet TCP/IP mit M12 für den Bus-Anschluss
"903" - PROFINET
"905" - EtherNet/IP

Kompakt Box

Die Feldbus Boxe verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Die digitalen Ein-/Ausgänge können wahlweise über Ø 8 mm Schnapp-, M8 Schraub- oder über M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12 Variante verfügbar.

Je nach Modul kann der E/A-Teil und der Stromversorgungsteil unterschiedlich sein.

Koppler Box

Die Koppler Box gibt es in drei Varianten als IL230x-Bxxx. Diese unterscheidet sich von der Kompakt Box dadurch, dass diese Module eine Schnittstelle zu den sogenannten Erweiterungsboxen bietet. Diese Schnittstelle ist ein Sub-Bussystem auf LWL Basis den sogenannten IP-Link. Dieses leistungsfähige Sub-Bussytem kann bis zu 120 Erweiterungsboxen an einer Koppler Box verarbeiten.

Erweiterungsbox

Feldbusunabhängige Erweiterungsmodule, die nur an einer Koppler Box über IP-Link betrieben werden können.

SPS Box

Eine SPS Box unterscheidet sich von einer Koppler Box dadurch, dass sie in IEC 61131-3 programmierbar ist. Dadurch kann dieser Slave auch ohne Master autonom arbeiten, zum Beispiel für Steuerungs- oder Regelungsaufgaben.


Firm- und Hardware-Stand

Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Hard- und Firmware-Stand. Die Eigenschaften werden weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben wie Module neue Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das diese Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand der Module können Sie anhand der mit einem D beginnenden Nummer auf der Seite des Moduls erkennen.

Syntax:

D . ww yy x y z u

ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel:

D.22081501

- Kalenderwoche 22
- des Jahres 2008
- Firmware-Stand Busplatine: 1
- Hardware Stand Busplatine: 5
- Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig)
- Hardware-Stand E/A-Platine: 1


IL230x-B110 - Technische Daten

BECKHOFF IL230x-B110: Produktübersicht

Technische Daten

Technische Daten | IL230x-B110
Erweiterungsmodule (IL....) | max. 32 (bis Firmware-Version B0) max. 78 (ab Firmware-Version B1)
Byte-Anzahl Feldbus | max. 512 Byte Input und max. 512 Byte Output
Digitale Peripheriesignale (IL....) | max. 624 Eingänge und max. 624 Ausgänge
Analoge Peripheriesignale (IL....) | max. 128 Eingänge und max. 128 Ausgänge
Übertragungsmedium | 4 x 2 Twisted-Pair Kupferkabel; Kategorie 5 (100 MBaud)
Baudrate | 100 MBaud
Entfernung zwischen Modulen | 100 m
Konfiguration | Konfigurations-Software KS2000, TwinCAT System Manager oder via EtherCAT (ADS)
Protokolle | EtherCAT (Direct Mode)
Stromversorgung | Steuerspannung: 24VDC (-15%/+20%); Lastspannung: entsprechend E/A-Variante
Stromaufnahme Steuerspannung | entsprechend E/A-Variante + Stromaufnahme Sensorversorgung, max. 0,5A
Stromaufnahme Lastspannung | entsprechend E/A-Variante
Anschluss Stromversorgung | Einspeisung: 1 x M8 Stecker 4-polig Weiterleitung: 1 x M8 Buchse 4-polig (außer IP/IE204x)
Anschluss Feldbus | 2 x M12 d-codiert, Buchse
Potentialtrennung | Kanäle / Steuerspannung: nein zwischen den Kanälen: nein Steuerspannung / Feldbus: ja
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... +55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 (EN 50082) / EN 61000-6-4 (EN 50081)
Schutzart | IP 65/66/67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE, UL E172151

Hinweis 		Weitere Dokumentation
Detaliierte technische Daten zu allen erhältlichen E/A-Varianten entnehmen Sie bitte der Dokumentation Signalvarianten, Installation, Konfiguration der E/A-Module, die Sie auf der BECKHOFF CD Products & Solutions oder im Internet (http://www.beckhoff.de) unter Download/Feldbus Box finden.


Feldbusbox - Abmessungen

BECKHOFF Feldbus Box: Montage

Abmessungen

Alle Maßangaben sind in Millimeter angegeben.

Allgemein

Technische Daten | Feldbus Box
Gehäusematerial | PA6 (Polyamid), Vergussmasse: Polyuhrethan
Montage | 2 x Befestigungslöcher für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | IEC EN 50082-2 / EN 50081-2
Zulässige Umgebungstemperatur im Betrieb | 0 ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25 ... + 85°C
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65/66/67
Zulassungen | CE, UL E172151

IPxxxx-Bxx8, IL230x-Bxx8, IL230x-B110, IXxxxx-B400, IXxxxx-B90x, IXxxxx-C900

Technische Daten | Kompakt- und Kopplerbox mit integriertem T-Stück
Abmessungen (H x B x T) | ca. 210 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm)
Gewicht | ca. 260 g - 290 g, je nach Modultyp

IPxxxx-Bxx0, IL230x-Bxx0, IL230x-Cxx0

Technische Daten | Kompakt- und Kopplerbox
Abmessungen (H x B x T) | ca. 175 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm, mit T-Stück ZS1031-2600 Höhe ca. 65 mm)
Gewicht | ca. 250 g - 280 g, je nach Modultyp

IExxxx

Technische Daten | Erweiterungsbox
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Gewicht | ca. 120 g - 200 g, je nach Modultyp


EtherCAT-Anschluss

Der Anschluss an das EtherCAT erfolgt über zwei d-kodierte M12 Buchsen, jeweils für den EtherCAT ein- und Ausgang.

Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen.

Kabel und Steckverbinder

Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Kabel, die mindestens der Kategorie 5 (CAt5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.

Die folgenden Kabel und Steckverbinder sind für den Einsatz an EtherCAT-Systemen geeignet:

Bezeichnung | Kommentar
ZB9010 | EtherCAT-Kabel, feste Verlegung CAT 5e, 4-adrig
ZB9020 | EtherCAT-Kabel schleppkettentauglich CAT 5e, 4-adrig
ZS1090-0004 | M12-Stecker, 4-polig, IP67, feldkonfektionierbar
ZK1090-6161-0005 | EtherCAT-Kabel, fertig konfektioniert, M12 Stecker - M12 Stecker, 0,5 m Länge
ZK1090-6161-0010 | EtherCAT-Kabel, fertig konfektioniert, M12 Stecker - M12 Stecker, 1,0 m Länge
ZK1090-6161-0020 | EtherCAT-Kabel, fertig konfektioniert, M12 Stecker - M12 Stecker, 2,0 m Länge
ZK1090-6161-0025 | EtherCAT-Kabel, fertig konfektioniert, M12 Stecker - M12 Stecker, 2,5 m Länge
ZK1090-6161-0050 | EtherCAT-Kabel, fertig konfektioniert, M12 Stecker - M12 Stecker, 5,0 m Länge
ZK1090-6161-0100 | EtherCAT-Kabel, fertig konfektioniert, M12 Stecker - M12 Stecker, 10 m Länge
ZK1090-6292-0005 | EtherCAT-Kabel, M12-Buchse - RJ45, 0,5 m Länge
ZK1090-6292-0020 | EtherCAT-Kabel, M12-Buchse - RJ45, 2,0 m Länge

Hinweis 		Datenblätter
Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.
Die Farbebelegung der Kabel von Beckhoff entnehmen Sie bitte den zugehörigen Datenblättern.

Belegung des M12-Steckers (d-kodiert)

PIN | Signal | Beschreibung
1 | Tx + | Transmit Data+
2 | Rx + | Receive Data+
3 | Tx - | Transmit Data-
4 | Rx - | Receive Data-

Belegung des RJ45-Steckers

PIN | Signal | Beschreibung
1 | TD + | Transmit Data+
2 | TD - | Transmit Data-
3 | RD + | Receive Data+
4 | - | reserviert
5 | - | reserviert
6 | RD - | Receive Data-
7 | - | reserviert
8 | - | reserviert


Anlaufverhalten der Feldbus Box

Nach dem Einschalten prüft die Feldbus Box ihren Zustand, konfiguriert (wenn vorhanden) den IP-Link ist und erstellt anhand der Erweiterungsmodule eine Aufbauliste. Wenn die Feldbus Box eine dezentrale Steuerung besitzt (IL230x-C310) wird nach einer erfolgreichen Aufbauliste die lokale SPS gestartet.
Beim Hochlauf des Moduls leuchten und blinken die E/A LEDs. Im fehlerfreien Zustand sollte nach ca. 2-3 sec keine E/A LED mehr Blinken. Sollte ein Fehler vorliegen, hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose LEDs).

Start_List.gif (8211 Byte)


IL230x-B110 - Übersicht Konfiguration

BECKHOFF IL230x-B110: Konfiguration

Übersicht Konfiguration

IL230x-B110
Eingänge
Ausgänge
Status des Working Counters (WcState)
Online Status (Info Data)
ADS Adresse (ADSAddr)
EtherCAT-Zykluszeit

IL230x-B110 (IL2300-B110, IL2301-B110, IL2302-B110)

Tragen Sie im TwinCAT System Manager im Config-Mode unter Geräte den IL230x-B110 als EtherCAT (Direct Mode) Gerät ein (Abb. 1). Sollten die FeldbusBox Module schon am Netzwerk angeschlossen sein, können Sie diese auch einlesen. Dabei werden automatisch alle Boxen mit Erweiterungen und Konfiguration hochgeladen. Diese können Sie dann nach Ihren Bedürfnissen anpassen. Im TwinCAT muss dann der Status FreeRun gesetzt werden.

Anmerkung zu den Screenshots: im TwinCAT werden IP-Link Werte als K-Bus Werte angezeigt.

Abb. 1 TwinCAT Baum IL2302-B110

Eingänge

CouplerState, Karteireiter "Online"

Anzeige von allgemeinen Fehlern der FeldbusBox.

Abb. 3 CouplerState, Karteireiter "Online"

Ausgänge

CouplerCtrl, Karteireiter "Online"

Anzeige von IP-Link/K-Bus Fehlern bzw. Deaktivierung der Ausgänge.

Abb. 4 CouplerCrtl, Karteireiter "Online"

Status des Working Counters (WcState)

WCstate, Karteireiter "Online"

Boolesche Variable, die den Working Counter Status der FeldbusBox anzeigt. Ein ungültiger Working Counter (Wert: 1) wird angezeigt, wenn ungültige Daten vom EtherCAT Slave Controller übertragen wurden.

Abb. 5 WCstate, Karteireiter "Online"

Online Status (Info Data)

State, Karteireiter "Online"

Zeigt den Online-Status der FeldbusBox an.

Abb. 6 State, Karteireiter "Online"

Wert | Beschreibung
0x___1 | Slave in 'INIT' state
0x___2 | Slave in 'PREOP' state
0x___3 | Slave in 'BOOT' state
0x___4 | Slave in 'SAFEOP' state
0x___8 | Slave in 'OP' state
0x001_ | Slave signals error
0x002_ | Invalid vendorId, productCode... read
0x004_ | Initialization error occurred
0x010_ | Slave not present
0x020_ | Slave signals link error
0x040_ | Slave signals missing link
0x080_ | Slave signals unexpected link
0x100_ | Communication port A
0x200_ | Communication port B
0x400_ | Communication port C
0x800_ | Communication port D

ADS Adresse (ADSAddr)

ADSAddr, Karteireiter Online

Gibt einzeilig die AMS netID und den AMS Port der FeldbusBox im hexadezimalen System an. Diese Angaben werden für die Mailbox-Kommunikation über ADS benötigt.

Beispiel

AC 10 07 3F 02 01 (AMS netID) = 172.16.7.63.2.1
03 E9 (port) = 1001dez

Abb. 7 ADSAddr, Karteireiter "Online"

EtherCAT / IP-Link Zykluszeit

Die IP-Link-Zykluszeit die sich aus dem Ausbau der Station mit ErweiterungsBox Modulen ergibt, wird im ConfigMode direkt angezeigt.

Abb. 8 CycleTime

Ist die EtherCAT Zykluszeit größer als der IP-Link Zyklus arbeiten beide Systeme synchron. Der IP-Link wird nach einem EtherCAT-Telegramm gestartet und kopiert dann seine Eingänge in den Speicher. Mit dem nächsten EtherCAT Telegramm werden diese dann abgeholt, d. h. die Eingänge sind immer genau einen Zyklus alt.

Ist der EtherCAT Zyklus kleiner als der IP-Link Zyklus, läuft der K-Bus asynchron zum EtherCAT. Eine schnellere Abfrage als "Estimated Cycle (offline)" ist somit möglich, führt aber dann ggf. zu veralteten Eingangsdaten bzw. Ausgänge werden über den IP-Link nicht rechtzeitig gesetzt.

Die auf die IL230x-B110 FeldbusBox Module angewendete EtherCAT-Zykluszeit sollte daher deutlich größer sein als der "Estimated Cycle(offline)" (min. 250 µs, abhängig von der Konfiguration). Eine Online-Kontrolle im System durch "Max. Cycle (online)" oder "CouplerState" wird empfohlen.

Die Zykluszeit kann auch über CoE-Online aus Tabelle 98 [LO] ausgelesen werden.

Abb. 9 CycleTime via Table98[LO]

Überprüfung der der angeschlossenen Boxen

Wenn Sie "Check Terminals at Startup" aktivieren, wird beim Start überprüft, of die angeschlossene Boxen mit den konfigurierten Boxen übereinstimmen.


IL230x-B110 - Objektbeschreibung

BECKHOFF IL230x-B110: Konfiguration

Objektbeschreibung

Standardobjekte

Index 1000 Device type

Geräte-Typ (read only) des EtherCAT-Slaves.
Index | Name | Bedeutung | Flags | Default
1000 | DeviceType | Geräte-Typ | RO | 0x00001389 (5001dez)

Index 1008 Device name

Gerätename (read only, Value: z. B. IL2302-B110-0000-0000) des EtherCAT-Slaves.
Index | Name | Bedeutung | Flags | Default
1008 | DeviceName | Gerätename | RO | z.B. IL2302-B110-0000-0000

Index 1009 Hardware version

Hardware-Version (read only) des EtherCAT-Slaves.

Index | Name | Bedeutung | Flags | Default
1009 | Hardware-Version | Hardware-Version | RO | z.B. 01
Index 100A Software version

Version (read only, Value: z. B. 01) der Firmware (Chip zur Aufbereitung der E/A-Signale) des EtherCAT-Slaves.

Index | Name | Bedeutung | Flags | Default
100A | Software-Version | Software-Version | RO | z.B. 01
Index 1018 Identity object
Index | Name | Bedeutung | Flags | Default
1018:0 | Identity object | Länge dieses Objekts | RO | -
1018:01 | Vendor id | Hersteller-ID des EtherCAT-Slaves | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | RO | 0x04602C22 (73411618dez)
1018:03 | Revision number | Revisionsnummer des EtherCAT-Slaves | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves | RO | 0x00000000 (0dez)
Index 16kk RxPDO Mapping Terminal

Wertebereiche: (kk = 00...FE)hex , [(hh = 01...FF)hex , (ddd = 001...255)]dez

Index | Name | Bedeutung | Flags | Default
16kk:0 | RxPDO Mapping Terminal | Länge dieses Objekts | RW | -
16kk:01 | Output Mapping Area 001 | 1. Ausgangsvariable dieser Box (Subindex 001) | RW | z. B. 0x7kk0:01, 1
... | ... | ... | ... | ...
16kk:hh | Output Mapping Area ddd | Letzte Ausgangsvariable (Subindex ddd) | RW | z.B. 0x7kk0:hh, 1
Index 16FF Control PDO
Index | Name | Bedeutung | Flags | Default
16FF:0 | Control PDO | Länge dieses Objekts | RW | -
16FF:01 | Output Mapping Area | Control-Wort | RW | 0xF200:01, 16
Index 1701 RxPDO Digital Align
Index | Name | Bedeutung | Flags | Default
1701:0 | RxPDO Digital Align | Länge dieses Objekts | RW | -
1701:01 | PDO Align | Word Alignment Dummy für Digital RxPDOs | RW | 0x0000:00, 12
Index 1Akk TxPDO Mapping Terminal

Wertebereiche: (kk = 00...FE)hex , [(hh = 01...FF)hex ,(ddd = 001...255)dez]

Index | Name | Bedeutung | Flags | Default
1Akk:0 | TxPDO Mapping Terminal | Länge dieses Objekts | RW | -
1Akk:01 | Input Mapping Area 001 | 1. Eingangsvariable dieser Box (Subindex 001) | RW | z. B. 0x6kk0:01, 1
... | ... | ... | ... | ...
1Akk:hh | Input Mapping Area ddd | Letzte Eingangsvariable dieser Box (Subindex ddd) | RW | z. B. 0x6kk0:hh, 1
Index 1AFF Status PDO
Index | Name | Bedeutung | Flags | Default
16FF:0 | Status PDO | Länge dieses Objekts | RW | -
16FF:01 | Input Mapping Area | Status-Wort | RW | 0xF100:01, 16
Index 1B01 TxPDO Digital Align
Index | Name | Bedeutung | Flags | Default
1B01:0 | TxPDO Digital Align | Länge dieses Objekts | RW | -
1B01:01 | PDO Align | Word Alignment Dummy für Digital TxPDOs | RW | 0x0000:00, 12
Index 1C00 SM type
Index | Name | Bedeutung | Flags | Default
1C00:0 | Sync Manager Type | Länge dieses Objekts | RO | 4
1C00:01 | Subindex 001 | Sync-Manager, Parameter 1 | RO | 0x01 (1dez)
1C00:02 | Subindex 002 | Sync-Manager, Parameter 2 | RO | 0x02 (2dez)
1C00:03 | Subindex 003 | Sync-Manager, Parameter 3 | RO | 0x03 (3dez)
1C00:04 | Subindex 004 | Sync-Manager, Parameter 4 | RO | 0x04 (4dez)
Index 1C12 RxPDO Assign
Wertebereiche: [(hh = 01...FF)hex ,(ddd = 001...255)dez]
Index | Name | Bedeutung | Flags | Default
1C12:0 | RxPDO Assign | Länge dieses Objekts | RW | -
1C12:01 | Subindex 001 | Zuordnung des Control PDO | RW | 0x16FF(5887dez)
1C12:02 | Subindex 002 | Zuordnung 1. RxPDO analoge Boxen | RW | z. B. 0x1603 (5635dez)
... | ... | ... | ... | ...
1C12:nn | Subindex nnn | Zuordnung n. RxPDO analoge Boxen | RW | z. B. 0x1605 (5637dez)
1C12:(nn+1) | Subindex (nnn+1) | Zuordnung (n+1). RxPDO digitale Boxen | RW | z. B. 0x1600 (5632dez)
... | ... | ... | ... | .....
1C12:hh | Subindex ddd | Zuordnung Word Alignment Dummy für Digital RxPDOs | RW | 0x1701(5889dez)
Index 1C13 TxPDO Assign

Wertebereiche: [(hh = 01...FF)hex ,(ddd = 001...255)dez]

Index | Name | Bedeutung | Flags | Default
1C13:0 | TxPDO Assign | Länge dieses Objekts | RW | -
1C13:01 | Subindex 001 | Zuordnung des Control PDO | RW | 0x1AFF(6911dez)
1C13:02 | Subindex 002 | Zuordnung 1. TxPDO analoge Boxen | RW | z. B. 0x1A03 (6659dez)
... | ... | ... | ... | ...
1C13:nn | Subindex nnn | Zuordnung n. TxPDO analoge Boxen | RW | z. B. 0x1A05 (6661dez)
1C13:(nn+1) | Subindex (nnn+1) | Zuordnung (n+1). TxPDO digitale Boxen | RW | z. B. 0x1A01 (6657dez)
... | ... | ... | ... | .....
1C13:hh | Subindex ddd | Zuordnung Word Alignment Dummy für Digital TxPDOs | RW | 0x1B01(6913dez)

Gerätespezifische Objekte

Index 4000 Koppler Box Table 0 [LO]: allgemeinen Konfiguration der Feldbus Box
Index | Name | Bedeutung | Flags | Default
4000:0 | Coupler Box Table 0 [LO] | Länge dieses Objekts | RW | 128
4000:01 | Subindex 001 | Register 0 | RW |
4000:02 | Subindex 002 | Register 1 | RW |
... |  | ... | ... | ...
4000:80 | Subindex 128 | Register 127 | RW |
Index 4001 Koppler Box Table 0 [HI]: allgemeinen Konfiguration der Feldbus Box (Fortsetzung)
Index | Name | Bedeutung | Flags | Default
4001:0 | Coupler Box Table 0 [HI] | Länge dieses Objekts | RW | 128
4001:01 | Subindex 001 | Register 128 | RW |
4001:02 | Subindex 002 | Register 129 | RW |
... | ... | ... | ... | ...
4001:80 | Subindex 128 | Register 255 | RW |
Index 4012 Koppler Box Table 9 [LO]: Unterlagerte Erweiterungs Box Module
Index | Name | Bedeutung | Flags | Default
4012:0 | Coupler Box Table 9 [LO] | Länge dieses Objekts | RO | max. 128
4012:01 | Subindex 001 | Register 0: Bezeichnung der Feldbus Box | RO | 0x006E (110dez1)
4012:02 | Subindex 002 | Register 1: Bezeichnung der 1. Erweiterung | RO | z.B.: 0x000A (10dez2)
4012:03 | Subindex 003 | Register 2: Bezeichnung der 2. Erweiterung | RO | z.B.: 0x000A (10dez2)
4012:04 | Subindex 004 | Register 3: Bezeichnung der 3. Erweiterung | RO | z.B. 0x0C82 (3202dez)
... | ... | ... | ... | ...
4012:80 | Subindex 121 | Register 120: Bezeichnung der 120. Erweiterung | RO |

1) Für Feldbus Box und intelligente (z.B. analoge) Erweiterungen wird die Boxenbezeichnung
dezimal im Klartext angegeben; z.B. 0x0C82 (3202dez) bedeutet IE3202.

2) Für einfache (digitale) Erweiterungs Box Module gilt folgende Kodierung:

Wert | Bedeutung
0x000A (10) | 4 digitale Eingänge und 4 digitale Ausgänge
0x0015 (21) | 8 digitale Eingänge und 8 digitale Ausgänge
0x0035 (53) | 8 digitale Eingänge und 8 digitale Ausgänge (physikalisch auf der gleichen Adresse)
0x0011 (17) | 8 digitale Ausgänge
0x0014 (20) | 8 digitale Eingänge
Index 40AE Koppler Box Table 87 [LO]: IP-Link Fehlerstellen
Index | Name | Bedeutung | Flags | Default
40AE:0 | Coupler Box Table 87 [LO] | Länge dieses Objekts | RO | 128dez
40AE:01 | Subindex 001 |  | RO |
40AE:02 | Subindex 002 |  | RO |
40AE:03 | Subindex 003 | Anzahl fehlerhafter Telegramme an der 1. Erweiterungs Box | RO |
40AE:04 | Subindex 004 | Anzahl fehlerhafter Telegramme an der 2. Erweiterungs Box | RO |
... | ... |  | ... | ...
40AE:0127 | Subindex 127 | Register 127: reserviert | RO |
Index 40B4 Koppler Box Table 90 [LO]: interne Diagnoseinformationen der Feldbus Box
Index | Name | Bedeutung | Flags | Default
40B4:0 | Coupler Box Table 90 [LO] | Länge dieses Objekts | RO | 128dez
40B4:01 | Subindex 001 | reserviert | RO |
40B4:02 | Subindex 002 | reserviert | RO |
40B4:03 | Subindex 003 | Fehler Code | RO |
40B4:04 | Subindex 004 | Fehler Argument | RO |
... | ... | ... | ... | ...
40B4:04 | Subindex 128 | reserviert | RO |

Der Fehlercode und das Argument entsprechen der Bedeutung der Blink-Codes der Feldbus LEDs.

Index 40C4 Coupler Table 98 [LO]: IP-Link Zykluszeit (µs)
Index | Name | Bedeutung | Flags | Default
40C4:0 | Coupler Table 98 IP-Link Cycle Time (µs) | Länge dieses Objekts | RW | 3
40C4:01 | Min IPL time | minimale Update-Zeit auf dem K-Bus | RW | -
40C4:02 | Max IPL time | maximale Update-Zeit auf dem K-Bus | RW | -
40C4:03 | Curr IPL time | aktuelle Update-Zeit des auf dem K-Bus | RW | -
Index 427F ExtensionBox No
Index | Name | Bedeutung | Flags | Default
427F:0 | ExtensionBoxeno | Zur Kommunikation mit intelligenten ErweiterungsBox Modulen muss in diesem Objekt die Nummer der Box eingetragen werden. Mit den vier folgenden Tabellen (Objekt 4280 - 4287) kann die Box dann parametriert werden. Zählweise: die Koppler Box hat die Nr.0. Die erste Erweiterungs Box die Nr. 1 usw. Es können nur intelligente Boxen (mit Registersatz) parametriert werden! | RW | 0
Index 4280 - 4287Terminal Table 0 [LO]: zur Parametrierung der mit Objekt 427F spezifizierten Box
Index | Name | Bedeutung | Flags | Default
428x:0 | ExtensionBox Channel 0 ... 3 | Länge dieses Objekts | RW | 64
428x:01 | Subindex 001 | Register 0 | RW | 0x0000 (0dez)
428x:02 | Subindex 002 | Register 1 | RW | 0x0000 (0dez)
... | ... | ... | ... | ...
428x:40 | Subindex 064 | Register 63 | RW | 0x0000 (0dez)
Index 6xxx und 7xxx Process Data

Im Index 6xxx und 7xxx werden die Prozessdaten der ErweiterungsBoxen abgebildet. Die Reihenfolge entspricht der physikalischen Reihenfolge im IP-Link Ring. Dabei wird jeweils in den Indizes in 10er Schritten hochgezählt, also z.B. 6000, 6010, 7020, 7030, 6040... sofern das entsprechende Modul nur Ein- oder nur Ausgänge hat. Besitzt es Ein-und Ausgänge wie z.B. ein IE2301 (auf der Koppler Box) gibt es sowohl den Index 6000 als auch 7000.

Hinweis 		Erzeugung der Ein- und Ausgangsobjekte
Die Wertebereiche der "kk", "hh", und "ddd" Variablen der Eingangs- und Ausgangsindizes sind unten dargestellt.
Die dynamische Erzeugung der Ein- und Ausgangsobjekte ist abhängig von der Reihenfolge der Erweiterungs Box Module in der gesamten Feldbus Box-Station.

Beispiel Aufbau einer Feldbus Box Station

IL2301-B110 - IE1001- IE2001- IE3102; EtherCAT bzw. die Koppler Box unterscheidet bei den digitalen Boxen nicht nach unterschiedlichen Anschlussarten, daher wird z.B. ein IE2301 als IE23xx angezeigt.

Mapping der zugeordneten PDOs (ab Index 6000):

Index | Name | Bedeutung
6000:0 | IE23xx | IE2301, max . Subindex (4) | Signale in Koppler Box: IE2301 | Eingangsdaten
6000:01 | Channel 1 | 1. Kanal, IE2301
6000:02 | Channel 2 | 2. Kanal, IE2301
6000:03 | Channel 3 | 3. Kanal, IE2301
6000:04 | Channel 4 | 4. Kanal, IE2301
6010:0 | IE10xx | IE1001, max. Subindex (8) | Position 1 nach Koppler Box: IE1001
6010:01 | Channel 1 | 1. Kanal, IE1001
6010:02 | Channel 2 | 2. Kanal, IE1001
6010:03 | Channel 3 | 3. Kanal, IE1001
6010:04 | Channel 4 | 4. Kanal, IE1001
6010:05 | Channel 5 | 5. Kanal, IE1001
6010:06 | Channel 6 | 6. Kanal, IE1001
6010:07 | Channel 7 | 7. Kanal, IE1001
6010:08 | Channel 8 | 8. Kanal, IE1001
6030:0 | IE3102 | IE3102, max. Subindex (12) | Position 3 nach Koppler Box: IE3102
6030:01 | Channel 1 Status | 1. Kanal, Status, IE3102
6030:03 | Channel 1 Data | 1. Kanal, Data IE3102
6030:04 | Channel 2 Status | 2. Kanal, Status, IE3102
6030:06 | Channel 2 Data | 2. Kanal, Data, IE3102
6030:07 | Channel 3 Status | 3. Kanal, Status, IE3102
6030:09 | Channel 3 Data | 3. Kanal, Data, IE3102
6030:0A | Channel 4 Status | 4. Kanal, Status, IE3102
6030:0C | Channel 4 Data | 4. Kanal, Status, IE3102
7000:0 | IE23xx | IE2301, max. Subindex (4) | Signale in Koppler Box: IE2301 | Ausgangsdaten
7000:01 | Channel 1 | 1. Kanal, IE2301
7000:02 | Channel 2 | 2. Kanal, IE2301
7000:03 | Channel 3 | 3. Kanal, IE2301
7000:04 | Channel 4 | 4. Kanal, IE2301
7020:0 | IE20xx | IE2001, max. Subindex (8) | Position 2 nach Koppler Box: IE3102
7020:01 | Channel 1 | 1. Kanal, IE2001
7020:02 | Channel 2 | 2. Kanal, IE2001
7020:03 | Channel 3 | 3. Kanal, IE2001
7020:04 | Channel 4 | 4. Kanal, IE2001
7020:05 | Channel 5 | 5. Kanal, IE2001
7020:06 | Channel 6 | 6. Kanal, IE2001
7020:07 | Channel 7 | 7. Kanal, IE2001
7020:08 | Channel 8 | 8. Kanal, IE2001
7030:0 | IE3102 | IE3102, max. Subindex (12) | Position 3 nach Koppler Box: IE3102
7030:01 | Channel 1 Control | 1. Kanal, Control, IE3102
7030:03 | Channel 1 Data | 1. Kanal, Data IE3102
7030:04 | Channel 2 Control | 2. Kanal, Control, IE3102
7030:06 | Channel 2 Data | 2. Kanal, Data IE3102
7030:07 | Channel 3 Control | 3. Kanal, Control, IE3102
7030:09 | Channel 3 Data | 3. Kanal, Data IE3102
7030:0A | Channel 4 Control | 4. Kanal, Control, IE3102
7030:0C | Channel 4 Data | 4. Kanal, Data IE3102

Index 6kk0 Process Input Data
Digitale Erweiterungs Boxen:

Wertebereiche:
(kk = 00hex...FFhex),
[(hh = 01hex...FFhex), (ddd = 001dez...255dez)]

Index | Name | Bedeutung | Flags | Default
6kk0:0 | Process Input Data | [Modulbezeichnung] | RO P | -
6kk0:01 | Channel 001 | Kanal 001 | RO P | -
... | ... | ... | ... | ...
6kk0:hh | Channel ddd | Kanal ddd | RO P | -
Nicht-Digitale Erweiterungs Boxen (für hh ≥ 03; ddd ≥ 003):

Wertebereiche:
(kk = 00hex...FFhex),
[(hh = 01hex...FFhex), (ddd = 001dez...255dez)] für ganzzahlig durch 3 teilbare Werte hh bzw. ddd

Index | Name | Bedeutung | Flags | Default
6kk0:0 | Process Input Data | [Modulbezeichnung] | RO P | -
6kk0:01 | Channel 001 Status | Kanal 001: Status | RO P | -
6kk0:02 | Channel 001 Word-Alignment | Kanal 001: Word-Alignment | RO P | -
6kk0:03 | Channel 001 Data | Kanal 001: Data | RO P | -
... | ... | ... | ... | ...
6kk0:hh-2 | Channel ddd/3 | Kanal ddd/3: Status | RO P | -
6kk0:hh-1 | Channel ddd/3 | Kanal ddd/3: Word-Alignment | RO P | -
6kk0:hh | Channel ddd/3 | Kanal ddd/3: Data | RO P | -
Index 7kk0 Process Output Data
Digitale ErweiterungsBoxen:

Wertebereiche:
(kk = 00hex...FFhex),
[(hh = 01hex...FFhex), (ddd = 001dez...255dez)]

Index | Name | Bedeutung | Flags | Default
7kk0:0 | Process Output Data | [Modulbezeichnung] | RO P | -
7kk0:01 | Channel 001 | Kanal 001 | RO P | -
... | ... | ... | ... | ...
7kk0:hh | Channel ddd | Kanal ddd | RO P | -
Nicht-Digitale Erweiterungs Boxen (für hh ≥ 03; ddd ≥ 003):

Wertebereiche:
(kk = 00hex...FFhex),
[(hh = 01hex...FFhex), (ddd = 001dez...255dez)] für ganzzahlig durch 3 teilbare Werte hh bzw. ddd

Index | Name | Bedeutung | Flags | Default
7kk0:0 | Process Input Data | [Modulbezeichnung] | RO P | -
7kk0:01 | Channel 001 Ctrl | Kanal 001: Control | RO P | -
7kk0:02 | Channel 001 Word-Alignment | Kanal 001: Word-Alignment | RO P | -
7kk0:03 | Channel 001 Data | Kanal 001: Data | RO P | -
... | ... | ... | ... | ...
7kk0:hh-2 | Channel ddd/3 Ctrl | Kanal ddd/3: Control | RO P | -
7kk0:hh-1 | Channel ddd/3 Word-Alignment | Kanal ddd/3: Word-Alignment | RO P | -
7kk0:hh | Channel ddd/3 Data | Kanal ddd/3: Data | RO P | -
Index 9kk0 Slave Info Data

Wertebereiche: (kk = 00hex...FFhex)

Index | Name | Bedeutung | Flags | Default
9kk0:0 | Slave Info Data | [Modulbezeichnung] | RO | -
9kk0:01 | Position | Modul Position im Verbund | RO | -
9kk0:09 | Module PDO Group | Modul PDO Gruppe • Nicht-Digitale ErweiterungsBoxen: Gruppe 1 • Digitale ErweiterungsBoxen: Gruppe 2 | RO | -
9kk0:0A | Module Ident | Modul Bezeichnung | RO | -
Index F000 Modular Device Profile
Index | Name | Bedeutung | Flags | Default
F000:0 | Modular Device Profile | Länge dieses Objekts | RO | 5
F000:01 | Module Index Distance | Abstand Modul Index | RO | 0x0010 (16dez)
F000:02 | Maximum Number of Modules | Max. Anzahl der IP-Link Module | RO | 0x0079 (121dez)
F000:03 | Standard Entries in Object 0x8yy0 | Mögliche Einträge in Objekt 0x8kk0 | RO | 0x0000000 (0dez)
F000:04 | Standard Entries in Object 0x9yy0 | Mögliche Einträge in Objekt 0x9kk0 | RO | 0x0000000 (0dez)
F000:04 | Module PDO Group | Modul PDO Gruppe des Gerätes = 0, (Control- und Status-Daten werden vor allen Boxen in den Prozessdaten zugeordnet | RO | 0x00 (0dez)
Index F00E Group Alignment PDO
Index | Name | Bedeutung | Flags | Default
F00E:0 | Group Alignment PDO | Länge dieses Objekts (3 PDO Boxen Gruppen) | RO | 3
F00E:01 | Subindex 001 | Gruppe 0: Keine Alignment notwendig | RO | 0x0000 (0dez)
F00E:02 | Subindex 002 | Gruppe 1: Alignment PDO (PDO 257) für PDO Gruppe 1 (Nicht-Digitale ErweiterungsBoxen) | RO | 0x0100 (256dez)
F00E:03 | Subindex 003 | Gruppe 2: Alignment PDO (PDO 258) für PDO Gruppe 2 (Digitale ErweiterungsBoxen) | RO | 0x0101 (257dez)
Index F00F Module Group Mapping Alignment
Index | Name | Bedeutung | Flags | Default
F00F:0 | Module Group Mapping Alignment | Länge dieses Objekts (3 PDO Modul Gruppen) | RO | 3
F00F:01 | Subindex 001 | Gruppe 0: Keine Alignment für PDO Gruppe 0 notwendig, Control- und Status Daten sind fix | RO | 0x0000 (0dez)
F00F:02 | Subindex 002 | Gruppe 1: Wort-Alignment für PDO Gruppe 1 (Nicht-Digitale Boxen). Die folgenden Prozessdaten der Digitalen ErweiterungsBoxen werden so immer auf eine gerade Byte-Adresse gelegt | RO | 0x0002 (2dez)
F00F:03 | Subindex 003 | Gruppe 2: Wort-Alignment für PDO Gruppe 2 (Digitale ErweiterungsBoxen ). Die Prozessdatengröße der Digitalen ErweiterungsBoxen ist immer geradzahlig. | RO | 0x0002 (2dez)
Index F010 Module List

Wertebereiche: (hh = 01hex...FFhex), (ddd = 001dez...255)dez

Index | Name | Bedeutung | Flags | Default
F010:0 | Module List | Länge dieses Objekts | RO | -
F010:01 | Subindex 001 | Bezeichnung Modul 001 | RO | -
... | ... | ... | ... | ...
F010:hh | Subindex ddd | Bezeichnung Modul ddd | RO | -
Index F030 Configured Module List

Wertebereiche: (hh = 01hex...FFhex), (ddd = 001dez...255dez)

Index | Name | Bedeutung | Flags | Default
F030:0 | Module List | Länge dieses Objekts | RW | -
F030:01 | Subindex 001 | Boxenbezeichnung der konfigurierten ErweiterungsBoxen an Position 1 (Wert wie 0x8kk0:0A) | RW | -
... | ... | ... | ... | ...
F030:hh | Subindex ddd | Boxenbezeichnung der konfigurierten ErweiterungsBoxen an letzter Position (Wert wie 0x8kk0:0A) | RW | -
Index F040 Detected Address List

Wertebereiche: (hh = 01hex...FFhex), (ddd = 001dez...255dez)

Index | Name | Bedeutung | Flags | Default
F040:0 | Module List | Länge dieses Objekts | RO | -
F040:01 | Subindex 001 | Position der ersten ErweiterungsBoxen (Wert wie 0x9kk0:01) | RO | 0x0001 (1dez)
... | ... | ... | ... | ...
F040:hh | Subindex ddd | Position der letzten ErweiterungsBoxen (Wert wie 0x9kk0:01) | RO | 0x00hh (ddddez)
Index F050 Detected Module List

Wertebereiche: (hh = 01hex...FFhex), (ddd = 001dez...255dez)

Index | Name | Bedeutung | Flags | Default
F050:0 | Module List | Länge dieses Objekts | RO | -
F050:01 | Subindex 001 | Bezeichnung der ErweiterungsBoxen an Position 1 (Wert wie 9kk0:0A) | RO | -
... | ... | ... | ... | ...
F050:hh | Subindex ddd | Bezeichnung der ErweiterungsBoxen an letzter Position (Wert wie 9kk0:0A) | RO | -
Index F100 Status PDO
Index | Name | Bedeutung | Flags | Default
F100:0 | Status PDO | Länge dieses Objekts | RO | 1
F100:01 | CouplerState | Koppler Status-Word | RO P | 0x0000 (0dez)
Index F200 Control PDO
Index | Name | Bedeutung | Flags | Default
F100:0 | ControlPDO | Länge dieses Objekts | RO | 1
F100:01 | CouplerCtrl | Koppler Control-Word | RO P | 0x0000 (0dez)


Allgemeine Registerbeschreibung

Bei den komplexen Modulen können verschiedene Betriebsarten bzw. Funktionalitäten eingestellt werden. Die Allgemeine Registerbeschreibung erläutert den Inhalt der Register, die bei allen komplexen Modulen identisch sind. Die modulspezifischen Register werden in dem darauffolgendem Kapitel erklärt.
Der Zugriff auf die internen Register der Module wird im Kapitel Register-Kommunikation beschrieben.

Allgemeine Registerbeschreibung

Komplexe Module die einen Prozessor besitzen, sind in der Lage mit der übergeordneten Steuerung bidirektional Daten auszutauschen. Diese Module werden im folgenden als intelligente Module bezeichnet. Zu ihnen zählen die analogen Eingänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), die analogen Ausgänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), serielle Schnittstellenmodule (RS485, RS232, TTY, Datenaustausch-Module), Zähler-Module, Encoder-Interface, SSI-Interface, PWM-Module und alle anderen parametrierbare Module.

Alle intelligenten Modulen besitzen intern eine in ihren wesentlichen Eigenschaften identisch aufgebaute Datenstruktur. Dieser Datenbereich ist wortweise organisiert und umfasst 64 Speicherplätze. Über diese Struktur sind die wesentlichen Daten und Parameter der Module les- und einstellbar. Zusätzlich sind Funktionsaufrufe mit entsprechenden Parametern möglich. Jeder logische Kanal einer intelligenten Module besitzt eine solche Struktur (4-Kanal analoge Module besitzen also 4 Registersätze).

Diese Struktur gliedert sich in folgende Bereiche:

Bereich | Adresse
Prozessvariablen | 0-7
Typ-Register | 8-15
Hersteller- Parameter | 16-30
Anwender- Parameter | 31-47
Erweiterter Anwenderbereich | 48-63

Register R0-R7 (im internen RAM des Moduls)

Die Prozessvariablen können ergänzend zum eigentlichen Prozessabbild genutzt werden und sind in ihrer Funktion Modulspezifisch.

R0-R5

Diese Register besitzen eine vom Modul-Typ abhängige Funktion.

R6

Diagnose-Register: Das Diagnose-Register kann zusätzliche Diagnose-Information enthalten. So werden z.B. bei seriellen Schnittstellenmodulen Paritäts-Fehler, die während der Datenübertragung aufgetreten sind, angezeigt.

R7

Kommandoregister

  • High-Byte_Write = Funktionsparameter
  • Low-Byte_Write = Funktionsnummer
  • High-Byte_Read = Funktionsergebnis
  • Low-Byte_ Read = Funktionsnummer

Register R8-R15 (im internen ROM des Moduls)

Die Typ- und Systemparameter sind fest vom Hersteller programmiert und können vom Anwender nur gelesen und nicht verändert werden.

R8

Feldbus Box Typ: Der Feldbus Box Typ in Register R8 wird zur Identifizierung der Feldbus Box benötigt.

R9

Softwareversion x.y.: Die Software-Version kann als ASCII-Zeichenfolge gelesen werden.

R10

Datenlänge: R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit. Der Buskoppler sieht diese Struktur.

R11

Signalkanäle: Im Vergleich zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z.B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.

R12

Minimale Datenlänge: Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control/Status-Byte für die Funktion des Moduls nicht zwingend notwendig, und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen. Die Information steht

  • bei einem Ausgangsmodul im High-Byte
  • bei einem Eingangsmodul im Low-Byte.
R13

Datentypregister

Datentypregister | Beschreibung
0x00 | Modul ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur 1 Byte n Bytes
0x03 | Word-Array
0x04 | Struktur 1 Byte n Worte
0x05 | Doppelwort-Array
0x06 | Struktur 1 Byte n Doppelworte
0x07 | Struktur 1 Byte 1 Wort
0x08 | Struktur 1 Byte 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur 1 Byte n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur 1 Byte n Worte mit variabler logischer Kanallänge
0x15 | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur 1 Byte n Doppelworte mit variabler logischer Kanallänge
R14

reserviert

R15

Alignment-Bits (RAM): Mit den Alignment-Bits wird das Analogmodul im Prozessabbild auf eine Bytegrenze gelegt.

Register R16-R30 (Hersteller-Parameter, serielles EEPROM)

Die Hersteller-Parameter werden vom Hersteller für jeden Modultyp modulspezifisch festgelegt, können jedoch mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Hersteller-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Hersteller-Parameter müssen Sie zuvor in Register R31 ein Code-Wort setzen.

Register R31-R47 (Anwendungs-Parameter, serielles EEPROM)

Die Anwender-Parameter sind Modulspezifisch. Sie können mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Anwender-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Anwender-Parameter müssen Sie zuvor in Register R31 das Anwender-Code-Wort setzen.

R31

Code-Wort-Register im RAM: Damit Parameter im Anwender-Bereich geändert werden können muss hier das Code-Wort 0x1235 eingetragen werden. Wird ein abweichender Wert in dieses Register eingetragen, so wird der Schreibschutz gesetzt. Bei inaktivem Schreibschutz wird das Code-Wort beim Lesen des Register zurückgegeben, ist der Schreibschutz aktiv enthält das Register den Wert Null.

R32

Feature-Register: Dieses Register legt die Betriebsarten der Klemme fest. So kann z.B. bei den analogen E/A-Modulen eine anwenderspezifische Skalierung aktiviert werden.

R33 bis R63

Klemmenspezifische Register: Diese Register sind vom Klemmentyp abhängig.

Register R47 bis R63 (Registererweiterung für zusätzliche Funktionen)

Diese Register sind für zusätzliche Funktionen vorgesehen.


Beispiel für Register-Kommunikation

Control-Byte

Das Control-Byte befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R/W | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Registerkommunikation eingeschaltet: Die ersten zwei Byte der Nutzdaten werden nicht für den Prozessdatenaustausch verwendet, sondern in den Registersatz der Feldbus Box geschrieben oder daraus gelesen.
6 | R/W | 0bin | Read: Das Register soll gelesen werden ohne es zu verändern.
 |  | 1bin | Write: Das Register soll beschrieben werden.
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll. Es sind 64 Register adressierbar.
Status-Byte

Das Status-Byte befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Quittung Registerzugriff
6 | R | 0bin | Read
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.

Beispiel 1

Lesen des Registers 8 von KL3204 oder IP/IE3202
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x88 (1000 1000bin) | 0xXX | 0xXX

Bit 0.7 gesetzt bedeutet Register-Kommunikation aktiv
Bit 0.6 nicht gesetzt bedeutet lesen des Registers.
Bit 0.5 bis Bit 0.0 geben mit 001000bin die Registernummer 8 an.
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim lesenden Zugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x88 | 0x0C | 0x84

Die Klemme/Box liefert im Eingangsdatenwort (Byte 1 und Byte 2) die Typ-Bezeichnung 0x0C84 (entspricht unsigned Integer 3204) zurück .

Besonderheit bei der Bezeichnung von Feldbus Boxen:
Die letzte Ziffer des zurückgegebenen unsigned Integer (3204) entspricht nicht der letzten Ziffer der Feldbus Box-Bezeichnung (3202), die für die Anschlussvariante (0 für S8, 1 für M8 und 2 für M12) steht. Sie gibt stattdessen die Anzahl der Kanäle wieder (IE3204 besitzt 4 Kanäle).

Hinweis 		Anwender-Codewort
Damit Register beschreiben werden können, müssen Sie zuvor das Anwender-Codewort 0x1235 in Register 31 schreiben, um den Schreibschutz zu deaktivieren. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder.
Beachten Sie das einige Einstellungen in den Registern erst nach einem Neustart (Power-Off/Power-ON) des Moduls übernommen werden.

Beispiel 2

Ablauf einer Register-Kommunikation zum ändern eines Register.

1. Schreiben des Register 31 (Codewort setzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x12 | 0x35

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX
2. Lesen des Register 31 (gesetztes Codewort überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x9F | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0x12 | 0x35
3. Schreiben des Register 32 (Register ändern)

VORSICHT 		Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften des Moduls und haben je nach Modul-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihres Moduls (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)e
0xE0 | 0x00 | 0x02

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0xXX | 0xXX
4. Lesen des Register 32 (geändertes Register überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xA0 | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0x00 | 0x02
5. Schreiben des Register 31 (Codewort zurücksetzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x00 | 0x00

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX


IL230x-B110 - Beispielparametrierung mit KS2000

BECKHOFF Feldbuskomponenten: Beispiel ADS-Kommunikation mit KS2000

Beispielparametrierung mit KS2000

Die Konfigurations-Software KS2000 dient zur Projektierung, Parametrierung und Inbetriebnahme von Buskopplern und Busklemmen und kann von der Beckhoff Website unter KS2000 Update heruntergeladen werden.

Hilfe zur Installation und Bedienung finden Sie unter Dokumentation KS2000 im Downloadbereich.

Das folgende Beispiel beschreibt, wie eine Kommunikation via ADS mit einem IL2302-B110 hergestellt wird. Dazu wird die AmsServerNetId des Zielsystems benötigt.

Schritt 1

Markieren Sie im TwinCAT System Manager den entsprechenden Koppler IL2302-B110 gehen Sie auf den Karteireiter "EtherCAT" und klicken Sie "Erweiterte Einstellungen" (Abb. 1).

Abb. 1: TwinCAT System Manager: EtherCAT-Reiter für Box IL2302-B110

Schritt 2

Unter "Mailbox", "AoE" (ADS over EtherCAT) sind "Erzeuge NetID" und "Initialize NetId" zu markieren. Bestätigen Sie mit OK.

Abb. 2: Dialog "EtherCAT" , "Erweiterte Einstellungen", "AoE"

Schritt 3

Die im TwinCAT System Manager unter "Mailbox", "ADS-Info" angegebene AmsServerNetId (Abb. 3) ist nach dem Start der KS2000-Software und Aktivierung des ADS-Kommunikationskanals ("Optionen", "Kommunikationskanal", "ADS") im Pulldown-Menü des Karteireiters "ADS" einzutragen (Abb.4):

  • Eingetragenes Gerät: Wenn Sie bei Name (1) ein eingetragenes Gerät wählen, dann wir die AmsServerNetId (2) automatisch übernommen. Die Einstellungen für den AdsPort (3) "100" sollten Sie nicht verändern. Klicken Sie auf Test (4) um die Verbindungseinstellungen zu überprüfen.
  • User Defined: Wenn Sie User Defined wählen, dann müssen Sie die AmsServerNetId manuell eintragen (2). Klicken Sie auch hier auf Test (4) um die Verbindungseinstellungen zu überprüfen.

Abb. 3: TwinCAT System Manager: Dialog "Mailbox", Übertragen der AmsServerNetID

Abb. 4: KS2000: Karteireiter "ADS", Eintragen der AmsServerNetID

Schritt 4

Der Test war erfolgreich, wenn das folgende Dialogfenster erscheint (Abb. 5). Klicken Sie auf OK um das Dialogfenster zu schließen.

Abb 5: KS2000: Bestätigung erfolgreicher Kommunikationstest

Schritt 5

Klicken Sie auf OK um die eingestellten Werte zu übernehmen (Abb.4).

Schritt 6

Loggen Sie sich in das KS2000 System ein (siehe auch Dokumentation KS2000). Die Parametrierung kann nun gemäß der Klemmenkonfiguration vorgenommen werden. Hinweise hierzu erhalten Sie in den entsprechenden Klemmendokumentationen.


Diagnose-LEDs

Fehlerdiagnose

Es gibt 2 Arten von Fehlern:

  • Feldbus Fehler
  • Lokaler Fehler auf Kompakt Box oder Koppler Box

Blink-Codes

Blinkfolge | Bedeutung
Schnelles Blinken | Anfang des Blink-Codes
erste langsame Sequenz | Fehler-Code
zweite langsame Sequenz | Fehlerargument
dritte langsame Sequenz (optional) | Fehlerargument

Flasching_codes.jpg (2840 Byte)

Anfang Fehler-Code Fehlerargument


Diagnose-LEDs

Nach dem Einschalten überprüft das Modul sofort die angeschlossene Konfiguration. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED I/O ERR signalisiert. Das Blinken der LED I/O ERR zeigt einen Fehler im Bereich der Ein/Ausgänge an. Durch Frequenz und Anzahl des Blinkens kann der Fehler-Code ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Zur Statusanzeige besitzt das Modul zwei Gruppen von LEDs. Die obere Gruppe mit vier LEDs zeigt den Zustand des jeweiligen Feldbusses an. Die Bedeutung der Feldbus-Status-LEDs unten erläutert. Sie entspricht den feldbusüblichen Anzeigen.

Am unteren Ende des Moduls befinden sich zwei weitere grüne LEDs zur Anzeige der Versorgungsspannung. Die linke LED zeigt die 24 VDC Logik-Versorgung des Moduls an. Die rechte LED signalisiert die Versorgungspannung der Ausgänge.

Die LEDs ACT und ERR sind reserviert und haben zur Zeit keine Bedeutung.

LEDs zur Feldbus-Diagnose

LED | Anzeige | Zustand | Beschreibung
LINK IN | Aus | - | keine Verbindung auf dem ankommenden EtherCAT-Strang
 | An | linked | Physikalische Verbindung zum vorhergehenden EtherCAT Slave vorhanden
 | Blinkt | active | Kommunikation mit vorhergehendem EtherCAT-Teilnehmer
LINK OUT | Aus | - | keine Verbindung auf dem weiterführenden EtherCAT-Strang
 | An | linked | Physikalische Verbindung zum weiterführenden EtherCAT Slave vorhanden
 | Blinkt | active | Kommunikation mit weiterführenden EtherCAT-Teilnehmer
ACT | - | - | reserviert
ERR | - | - | reserviert

LEDs zur Diagnose der EtherCAT State Machine / PLC

LED |  | Anzeige | Zustand | Beschreibung
RUN | grün | aus | Init | Die FeldbusBox ist im Initialisierungs-Zustand
 |  | blinkt | Pre-Operational | Die FeldbusBox ist im Zustand Pre-Operational
 |  | Einzelblitz | Safe-Operational | Die FeldbusBox ist im Zustand Safe-Operational
 |  | an | Operational | Die FeldbusBox ist im Zustand Operational
 |  | flackert | Bootstrap | Er wird eine Firmware geladen.
ERROR | rot | aus | - | Kein Fehler
 |  | blinkt | Err-Operational No Communication | PLC-Fehler / Lost Frames

LEDs zur Diagnose der Spannungsversorgung

LED | Bedeutung
Linke LED aus | Modul hat keine Spannung
Linke LED rot | Kurzschlussüberwachung der Sensorversorgung hat ausgelöst (> 500mA). Sensoren/Eingänge werden nicht mehr versorgt.
Rechte LED aus | Keine Spannungsversorgung 24 VDC für Ausgänge angeschlossen


Diagnose-LEDs für lokale Fehler

Lokale Fehler in einer Koppler Box (IL230x-Bxxx/Cxxx)

Unter den lokalen Fehlern ist gemeint, das ein Fehler in der Feldbus Box oder dem IP-Link aufgetreten ist. IP-Link-Fehler sind meist durch unsachgemäßen Gebrauch der Lichtwellenleitung zurück zu führen.

LED grün | LED rot |  |  | Beschreibung | Abhilfe
aus | aus |  |  | kein Datenaustausch | Modul im synchron Mode - zyklische Daten aktivieren
aus | 1 | 0 |  | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
aus | 2 |  |  | reserviert | -
aus | 3 | n |  | Bruchstelle wurde erkannt | n-tes Modul vor dem Empfänger des Masters
 | 3 | n | m | Bruchstelle wurde erkannt | (n*10)+m-tes Modul vor dem Empfänger des Masters
aus | 4 | n |  | zu viele fehlerhafte Telegramme erkannt (mehr als 25%) | vor dem n-ten Erweiterungsmodul (vor dem Empfänger des Masters) ist die LWL-Verkabelung zu prüfen
aus | 5 | n |  | Registerzugriff auf komplexe Module gescheitert | n-tes Modul überprüfen
aus | 11 | n |  | Komplexes Modul arbeitet fehlerhaft | n-tes Modul tauschen
aus | 12 | n |  | mehr als 120 Module im Ring | weniger Module anschließen
aus | 13 | n |  | n-tes Modul unbekannt | Firmware Update erforderlich
an | aus |  |  | Modul ist im Datenaustausch (kein Fehler) | -

Lokale Fehler in einer Erweiterungsbox

LED grün | LED rot | Beschreibung
aus | an | es werden kein Daten über den IP-Link empfangen
aus | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (sehr schlechte Datenverbindung)
blinkt, flackert | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (schlechte Datenverbindung), muss noch nicht zum Fehler führen
an | aus | es werden IP-Link Protokolle empfangen, kein Fehler

Fehlerhafte IP-Link Protokolle können entstehen durch:

  • schlecht konfektionierte IP-Link Steckverbinder
  • IP-Link Leitung mit erhöhter Dämpfung durch z.B. Knick o.ä.
  • defekte oder verschmutzte Sende LED (Modul vor dem fehlerhaften Modul)
  • defekter oder verschmutzter Empfänger

Der interne IP-Link-Fehlerzähler der Koppler Box kann mit der KS2000 Software ausgelesen werden.


Feldbus Box - Überprüfung der IP-Link-Verbindung

BECKHOFF Feldbus Box: Montage und Verkabelung

Überprüfung der IP-Link-Verbindung

Ein IP-Link-Kabel mit auf beiden Seiten korrekt konfektionierten IP-Link-Steckern garantiert eine fehlerfrei Übertragung.

Eine nachträgliche Prüfung der Übertragungsqualität und eine Fehlersuche ist mit der Konfigurationssoftware KS2000 möglich.

Hierzu sollte die Steuerung (z.B. ein PC mit Profibus-Karte) am Feldbus des Koppler Box angeschlossen sein und diese zyklisch mit Daten versorgen, oder die Koppler Box sollte mit der KS2000 auf freilaufend geschaltet werden.

Als Ergebnis sollte die I/O RUN LED auf dem Kopplermodul hellgrün leuchten. Dies zeigt, dass ein Datenaustausch mit den angeschlossenen Erweiterungsbox Modulen stattfindet. Eine rot flackernde I/O ERR LED zeigt fehlerhafte IP-Link-Telegramme an! Telegramme werden wie bei auch jedem Feldbussystem im Fehlerfall wiederholt, so dass eine Übertragung der Daten gewährleistet ist.

Fehlerzähler

In Tabelle 90, Offset 005 werden aufgetretene IP-Link-Fehler gezählt. Sporadisch auftretende Fehler bedeuten noch keine Probleme für die Kommunikation. Dieser Fehlerzähler wird nur durch ein Power ON/OFF zurückgesetzt.

Sollten in kurzer Zeit viel Fehler auftreten, wird eine schwere Störung diagnostiziert und das Koppler-Modul meldet diesen Fehler. Dies ist am Offset 006 oder 007 zu erkennen. Die beiden Werte stehen dann auf einem Wert > 200 und die I/O ERR LEDs des Koppler-Moduls blinken mit dem entsprechenden Fehler-Code.

Hinweis 		Manueller Refresh erforderlich
Die Konfigurations-Software KS2000 kommuniziert über einen seriellen Kanal mit der Koppler Box.
Der Registerinhalt wird nicht andauernd aktualisiert, muss also manuell refreshed werden.

Fehlerort

Stellt das Koppler Modul einen Fehler fest, versucht es den Fehlerort aus dem Register der Erweiterungs-Box herauszulesen. Ist der Ring tatsächlich unterbrochen bzw. die Kommunikation stark gestört, ist dies nicht möglich. Dann wird nur der Ort des Bruchs dargestellt und zwar rückwärts vom Koppler gezählt (siehe IP-Link Fehlersuche).

Läuft die Kommunikation noch, kann in Tabelle 87 der Fehlerzähler je Erweiterungsmodul ausgelesen werden.

Hier bezieht sich der Offset auf die Position links im KS2000 Baum (siehe Grafik). d.h. in diesem Beispiel werden Fehler beim Offset 004 und 006 angezeigt.

Im IP-Link Aufbau ist der Fehler also bei der Übertragung zu Modul IE20xx und bei der Übertragung zu IE3112 zu suchen.

Der Fehler kann also liegen, an:

  • dem Sender-Modul
  • dem Empfänger-Modul
  • dem Kabel oder
  • den Steckern

Wird in Tabelle 90 ein Fehler angezeigt, aber in Tabelle 87 nicht, so ist die Fehlerursache in der Übertragungsstrecke zwischen dem letzten Erweiterungsmodul und dem Koppler zu suchen.

In fast allen Fällen sind Übertragungsfehler auf schlecht konfektionierte IP-Link-Stecker oder zu hohe Dämpfung im LWL-Kabel (durch scharfe Knicke o.ä.) zurückzuführen.

Tabelle 87 wird bei einer IP-Link-Unterbrechung nicht aktualisiert, da diese Werte direkt aus den Erweiterungs-Modulen kommen. Diese können dann über den IP-Link natürlich nicht mehr ausgelesen werden.

Hinweis 		Betrieb einer Koppler-Box ohne Erweiterungs-Module
Falls Sie eine Koppler-Box (z.B. IL2300-Bxxx, IL2301-Bxxx oder IL2302-Bxxx ) ganz ohne Erweiterungs-Module (IExxxx) betreiben möchten, müssen Sie Sende- und Empfangs-Anschluss diese Koppler-Box über ein IP-Link-Kabel direkt miteinander verbinden! Hierfür eignet sich besonders der IP-Link-Verbindungsstecker ZK1020-0101-1000.


Feldbus Box Zubehör

Das notwendige Zubehör für die Feldbus Box Module gibt es in Schutzklasse IP67 ebenfalls von Beckhoff. Eine Übersicht entnehmen Sie bitte aus dem Beckhoff Katalog oder unseren Internet-Seiten (http://www.beckhoff.de).

Feldbuszubehör

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Spannungsversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Sensorversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

IP-Link

  • Vorkonfektionierte Kabel
  • Stecker


Allgemeine Betriebsbedingungen

Schutzarten nach IP-Code

In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.

1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub

2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist

*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.

Chemische Beständigkeit

Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus Box und den verwendeten Metallteilen.

Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende

beständig: Lebensdauer mehrere Monate
bedingt beständig: Lebensdauer mehrere Wochen
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zulassungen

UL E172151

Konformitätskennzeichnung

CE

Schutzart

IP65/66/67 gemäß EN60529


Prüfnormen für die Geräteprüfung

EMV

Festigkeit: EN 61000-6-2

Aussendung: EN 61000-6-4

Vibrationsfestigkeit

Schwingungsprüfung: EN 60068-2-2, Amplitude 2 g (Norm 1 g)

Schockprüfung: EN 60068-2-27, Schockanzahl 1000 (Norm 2)


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Ethernet

Ethernet wurde ursprünglich von DEC, Intel und Xerox (als DIX-Standard) für die Datenübertragung zwischen Bürogeräten entwickelt. Heute versteht man darunter meist die Spezifikation IEEE 802.3 CSMA/CD, die 1985 veröffentlicht wurde. Diese Technologie ist durch ihren weltweiten Einsatz und die hohen Stückzahlen überall erhältlich und sehr preiswert.. Eine Anbindung an vorhandene Netze kann so problemlos realisiert werden.

Mittlerweile gibt es die verschiedensten Übertragungsmedien: Koaxialkabel (10Base5), Lichtwellenleiter (10BaseF) oder verdrillte Zweidrahtleitung (10BaseT) mit Schirmung (STP) oder ohne Schirmung (UTP). Mit Ethernet lassen sich verschieden Topologien aufbauen wie Ring, Linie oder Stern.

Ethernet transportiert Ethernet-Pakete von einem Sender zu einem oder mehreren Empfängern. Diese Übertragung verläuft ohne Quittung und ohne Wiederholung von verlorenen Paketen. Für die sichere Daten-Kommunikation stehen Protokolle wie TCP/IP zu Verfügung, die auf Ethernet aufsetzen.

MAC-ID

Sender und Empfänger von Ethernet-Paketen werden über die MAC-ID adressiert. Die MAC-ID ist ein 6 Byte großer Identifikations-Code, der eineindeutig, d.h. für jedes Ethernet-Gerät weltweit unterschiedlich ist. Die MAC-ID besteht aus zwei Teilen. Der erste Teil (d.h. die ersten 3 Byte) ist eine Herstellerkennung. Die Firma Beckhoff hat die Kennung 00 01 05. Die nächsten 3 Byte werden durch den Hersteller vergeben und entsprechen einer eindeutigen Seriennummer. Die MAC-ID kann zum Beispiel beim BootP-Protokoll zum Einstellen der TCP/IP-Nummer verwendet werden. Dafür wird ein Telegramm zum entsprechenden Knoten geschickt, das die Informationen wie Name oder TCP/IP-Nummer beinhaltet. Sie können die MAC-ID mit der Konfigurationssoftware KS2000 auslesen.

Internet-Protokoll (IP)

Die Grundlage der Datenkommunikation ist das Internet-Protokoll (IP). IP transportiert Datenpakete von einem Teilnehmer zu einem anderen, der sich im gleichen oder in einem anderen Netz befinden kann. IP kümmert sich dabei um das Adress-Management (Finden und Zuordnen der MAC-IDs), die Segmentierung und die Pfadsuche (Routing). Wie das Ethernet-Protokoll gewährleistet auch IP keinen gesicherten Transport der Daten; Datenpakete können verloren gehen oder in ihrer Reihenfolge vertauscht werden.

Für einen standardisierten, gesicherten Informationsaustausch zwischen beliebig vielen verschiedenen Netzwerken wurde TCP/IP entwickelt. Dabei ist TCP/IP weitgehend unabhängig von der verwendeten Hard- und Software. Oftmals als ein Begriff verwendet, handelt es sich hierbei um mehrere aufeinander aufgesetzte Protokolle: z.B. IP, TCP, UDP, ARP und ICMP.

Transmission Control Protocol (TCP)

Das auf IP aufsetzende Transmission Control Protocol (TCP) ist ein verbindungsorientiertes Transport-Protokoll. Es umfasst Fehlererkennungs- und Behandlungsmechanismen. Verlorengegangene Telegramme werden wiederholt.

User Datagram Protocol (UDP)

UDP ist ein verbindungsloses Transport-Protokoll. Es gibt keine Kontrollmechanismen beim Datenaustausch zwischen Sender und Empfänger. Dadurch resultiert eine schneller Verarbeitungsgeschwindigkeit als zum Beispiel bei TCP. Eine Prüfung ob das Telegramm angekommen ist muss vom übergeordneten Protokoll durchgeführt werden.

Auf TCP/IP und UDP/IP aufsetzende Protokolle

Auf TCP/IP bzw. UDP können folgende Protokolle aufsetzen:

  • ADS
  • ModbusTCP

Beide Protokolle sind parallel auf dem Buskoppler implementiert, so dass für die Aktivierung der Protokolle keine Konfiguration nötig ist.

ADS setzt wahlweise auf TCP oder UDP auf, während ModbusTCP stets auf TCP/IP basiert.


Das Beckhoff Busklemmensystem

Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform

Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.

Dezentrale Verdrahtung der E/A-Ebene

Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.

Industrie-PCs als Steuerung

Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.

Buskoppler für alle gängigen Bussysteme

Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.

Montage auf genormten Tragschienen

Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 50022, 35 mm) und die direkte Verdrahtung von Akttoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.

Die geringe Baugröße und die große Flexibilität des Busklemme-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.

Modularität

Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.

Anzeige des Kanalzustands

Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.

K-Bus

Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.

Potential-Einspeiseklemmen für potentialgetrennte Gruppen

Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.

In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.

Buskoppler für verschiedene Feldbus-Systeme

Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.

Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.

Die Schnittstellen

Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


IL230x-B110 - Mapping der FeldbusBox

BECKHOFF Feldbuskomponenten: Konfiguration

Mapping der Feldbus Box

Die genaue Belegung der byteorientierten Erweiterungs Box Module entnehmen Sie bitte der Konfigurations-Anleitung zu den jeweiligen Signalbeschreibungen.


IL230x-B110 - Objektübersicht

BECKHOFF IL230x-B110: Konfiguration

Objektübersicht

Index |  | Name | Flags | Default oder Beispielwert
1000 |  | Device type | RO | 0x0000138A (5002dez)
1008 |  | Device name | RO | z. B. BK1120-0000-0000
1009 |  | Hardware version | RO | 01
100A |  | Software version | RO | z.B. 07 (B7)
1018:0 | Subindex | Identity | RO | >4<
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x04602C22 (73411618dez)
 | 1018:03 | Revision number | RO | 0x00000000 (0dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
1600 - 16FE |  | RxPDO Mapping Area | RW | -
16FF:0 | Subindex | Control PDO | RW | >1<
 | 16FF:01 | Output Mapping Area | RW | 0xF200:01, 16
1701:0 | Subindex | RxPDO Digital Align | RW | >1<
 | 1701:01 | PDO Align | RW | z.B. 0x0000:00, 14
1A00 - 1AFE |  | TxPDO Mapping Area | RW | -
1AFF:0 | Subindex | Status PDO | RW | >1<
 | 1AFF:01 | Input Mapping Area | RW | 0xF100:01, 16
1B01:0 | Subindex | TxPDO Digital Align | RW | >1<
 | 1B01:01 | PDO Align | RW | z. B. 0x0000:00, 6
1C00:0 | Subindex | Sync Manager Type | RO | >4<
 | 1C00:01 | Subindex 001 | RO | 0x01 (1dez)
 | 1C00:02 | Subindex 002 | RO | 0x02 (2dez)
 | 1C00:03 | Subindex 003 | RO | 0x03 (3dez)
 | 1C00:04 | Subindex 004 | RO | 0x04 (4dez)
1C12:0 ** | Subindex | RxPDO Assign | RO | ><
 | 1C12:01 | Subindex 001 | RW | 0x16FF (5887dez)
 | 1C12:02 | Subindex 002 | RW | z. B. 0x1603 (5635dez)
 | 1C12:03 | Subindex 003 | RW | z. B. 0x1600 (5632dez)
 | ... | ... | ... | ...
 | 1C12:hh | Subindex ddd | RW | 0x1701(5889dez)
1C13:0 ** | Subindex | TxPDO Assign | RW | ><
 | 1C13:01 | Subindex 001 | RW | 0x1AFF (6911dez)
 | 1C13:02 | Subindex 002 | RW | z. B. 0x1A03 (6659dez)
 | 1C13:03 | Subindex 003 | RW | z. B. 0x1A01 (6657dez)
 | ... | ... | ... | ...
 | 1C13:hh | Subindex ddd | RW | 0x1701(5889dez)
4000:0 | Subindex | Coupler Table 0 [LO] | RW | >128<
 | 4000:01 | Register 0 | RW | 0x0000 (0dez)
 | 4000:02 | Register 1 | RW | 0x0000 (0dez)
 | ... | ... | ... | ...
 | 4000:80 | Register 127 | RW | 0x0000 (0dez)
4001:0 | Subindex | Coupler Table 0 [HI] | RW | >128<
 | 4001:01 | Register 128 | RW | 0xFFFF (65535dez)
 | 4001:02 | Register 129 | RW | 0xFFFF (65535dez)
 | ... | ... | ... | ...
 | 4001:80 | Register 255 | RW | 0xB700 (46848dez)
4012:0 | Subindex | Coupler Table 9 [LO] | RO | >4<
 | 4002:01 | Register 000 | RO | 0x0460 (1120dez)
 | 4002:02 | Register 001 | RO | z.B.: 0x8201 (33281dez)
 | 4002:03 | Register 003 | RO | z.B.: 0x0BBA (3002dez)
 | 4002:04 | Register 004 | RO | z.B.: 0x0C84 (3204dez)
4013:0 | Subindex | Coupler Table 9 [HI] | RO | >0<
40B4:0 | Subindex | Coupler Table 90 [LO] | RO | >128<
 | 40B4:01 | Register 0 | RO | 0x0000 (0dez)
 | 40B4:02 | Register 1 | RO | 0x0000 (0dez)
 | ... | ... | ... | ...
 | 40B4:80 | Register 127 | RO | 0x0000 (0dez)
40B5:0 | Subindex | Coupler Table 90 [HI] | RO | >128<
 | 40B5:01 | Register 128 | RO | 0x0000 (0dez)
 | 40B5:02 | Register 129 | RO | 0x0000 (0dez)
 | ... | ... | ... | ...
 | 40B5:80 | Register 255 | RO | 0x0000 (0dez)
40C4:0 | Subindex | Coupler Table 98 [LO] | RW | >5<
 | 40C4:01 | Min. K-Bus time | RW | z.B. 0x0355 (853dez)
 | 40C4:02 | Max. K-Bus time | RW | z.B. 0x059A (1434dez)
 | 40C4:03 | Curr. K-Bus time | RW | z.B. 0x036A (874dez)
 | 40C4:04 | reserviert | RW | 0x0000 (0dez)
 | 40C4:05 | reserviert | RW | 0x09F8 (2552dez)
40C5:0 | Subindex | Coupler Table 98 [HI] | RW | >0<
40C8:0 | Subindex | Coupler Table 100 [LO] | RW | >128<
 | 40C8:01 | Register 0 | RW | 0x0000 (0dez)
 | 40C8:02 | Register 1 | RW | 0x0000 (0dez)
 | ... | ... | ... | ...
 | 40C8:80 | Register 127 | RW | 0x0000 (0dez)
40C9:0 | Subindex | Coupler Table 100 [HI] | RW | >128<
 | 40C9:01 | Register 128 | RW | 0x0000 (0dez)
 | 40C9:02 | Register 129 | RW | 0x0000 (0dez)
 | ... | ... | ... | ...
 | 40C9:80 | Register 255 | RW | 0x0000 (0dez)
40FE:0 | Subindex | Coupler Table 127 [LO] | RO | >128<
 | 40FE:01 | Register 0 | RO | 0x0100 (256dez)
 | 40FE:02 | Register 1 | RO | 0x0000 (0dez)
 | ... | ... | ... | ...
 | 40FE:80 | Register 127 | RO | 0x0000 (0dez)
40FF:0 | Subindex | Coupler Table 127 [HI] | RO | >128<
 | 40FF:01 | Register 128 | RO | 0x0000 (0dez)
 | 40FF:02 | Register 129 | RO | 0x0000 (0dez)
 | ... | ... | ... | ...
 | 40FF:80 | Register 255 | RO | 0x0000 (0dez)
427F |  | Terminal No | RW | 0x0003 (3dez)
4280:0 | Subindex | Terminal Channel 0 [LO] | RW | >64<
 | 4280:01 | Register 0 | RW | 0x0000 (0dez)
 | 4280:02 | Register 1 | RW | 0x0000 (0dez)
 | ... | ... | ... | ...
 | 4280:40 | Register 63 | RW | 0x0000 (0dez)
4281:0 | Subindex | Terminal Channel 0 [HI] | RW | >0<
4282:0 | Subindex | Terminal Channel 1 [LO] | RW | >64<
 | 4280:01 | Register 0 | RW | 0x0000 (0dez)
 | 4280:02 | Register 1 | RW | 0x0000 (0dez)
 | ... | ... | ... | ...
 | 4280:40 | Register 63 | RW | 0x0000 (0dez)
4283:0 | Subindex | Terminal Channel 1 [HI] | RW | >0<
4284:0 | Subindex | Terminal Channel 2 [LO] | RW | >64<
 | 4280:01 | Register 0 | RW | 0x0000 (0dez)
 | 4280:02 | Register 1 | RW | 0x0000 (0dez)
 | ... | ... | ... |
 | 4280:40 | Register 63 | RW | 0x0000 (0dez)
4285:0 | Subindex | Terminal Channel 2 [HI] | RW | >0<
4286:0 | Subindex | Terminal Channel 3 [LO] | RW | >64<
 | 4280:01 | Register 0 | RW | 0x0000 (0dez)
 | 4280:02 | Register 1 | RW | 0x0000 (0dez)
 | ... | ... | ... |
 | 4280:40 | Register 63 | RW | 0x0000 (0dez)
4287:0 | Subindex | Terminal Channel 3 [HI] | RW | >0<
6000 - 6FF0 |  | Terminal Input data | RO P | -
7000 - 7FF0 |  | Terminal Output data | RO P | -
9kk0:0 *** | Subindex | Slave kk Info data | RO | >10<
 | 9hh0:01 | Position | RO | z. B. 0x0001 (1dez)
 | 9hh0:09 | Module PDO Group | RO | z. B. 0x0002 (2dez)
 | 9hh0:0A | Module Ident | RO | z. B. 0x00008201 (33282dez)
F000:0 | Subindex | Modular Device Profile | RO | >5<
 | F000:01 | Module Index Distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum Number of Modules | RO | 0x00FF (255dez)
 | F000:03 | Standard Entries in Object 0x8yy0 | RO | 0x00000000 (0dez)
 | F000:04 | Standard Entries in Object 0x9yy0 | RO | 0x00000000 (0dez)
 | F000:05 | Module PDO Group | RO | 0x00 (0dez)
F00E:0 | Subindex | Group alignment PDO | RO | >3<
 | F00E:01 | Subindex 001 | RO | 0x0000 (0dez)
 | F00E:02 | Subindex 002 | RO | 0x0100 (256dez)
 | F00E:03 | Subindex 003 | RO | 0x0101 (257dez)
F00F:0 | Subindex | Module Group Mapping Alignment | RO | >3<
 | F00F:01 | Subindex 001 | RO | 0x0000 (0dez)
 | F00F:02 | Subindex 002 | RO | 0x0002 (2dez)
 | F00F:03 | Subindex 003 | RO | 0x0002 (2dez)
F010:0 ** | Subindex | Module List | RO | ><
 | F010:01 | Subindex 001 | RO | z. B. 0x8202 (33282dez)
 | ... | ... | ... | ...
 | F010:hh | Subindex ddd | RO | z. B. 0x09D9 (2521dez)
F030:0 ** | Subindex | Configured Module List | RW | ><
 | F030:01 | Subindex 001 | RW | z. B. 0x00000000 (0dez)
 | ... | ... | ... | ...
 | F030:hh | Subindex ddd | RW | z. B. 0x00000000 (0dez)
F040:0 ** | Subindex | Detected Address List | RO | ><
 | F040:01 | Subindex 001 | RO | 0x0001 (1dez)
 | ... | ... | ... | ...
 | F040:hh | Subindex ddd | RO | 0x00FF (0dez)
F050:0 ** | Subindex | Detected Module List | RO | ><
 | F050:01 | Subindex 001 | RO | z. B. 0x00008202 (33282dez)
 | ... | ... | ... | ...
 | F050:hh | Subindex ddd | RO | z. B. 0x000009D9 (2521dez)
F100:0 | Subindex | Status PDO | RO P | >1<
 | F0100:01 | CouplerState | RO P | 0x0000 (0dez)
F200:0 | Subindex | Status PDO | RW P | >1<
 | F200:01 | CouplerCtrl | RW P | 0x0000 (0dez)
Legende

**Dynamisch erzeugte Objekte:
Wertebereich: (hh= 01..FF)hex , (ddd= 001..255)dez

***Dynamisch erzeugtes Objekt
Wertebereich: (hh= 00..FF)hex

Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RO P (Read Only Process Data): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden
RW P (Read/Write Process Data): dieses Objekt kann gelesen und beschrieben werden