FeldbusBox E/A-Module - Signalvarianten, Installation und Konfiguration

BECKHOFF Feldbuskomponenten

Dokumentation für

Feldbus Box E/A-Module

Signalvarianten, Installation und Konfiguration

Version: 2.0.0
Datum: 28.11.2013


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Feldbus Box E/A-Module - Ausgabestände der Dokumentation

BECKHOFF Feldbus Box E/A-Module: Vorwort

Ausgabestände der Dokumentation

Version Kommentar
2.0.0
  • Anzugsmomente für Steckverbinder hinzugefügt
  • UL-Hinweise ergänzt
  • Zubehör erweitert
  • Technische Daten aktualisiert
  • IP-Link LED-Diagnoseanzeigen aktualisiert
1.9.1
  • Systemübersicht aktualisiert
1.9.0
  • Einführung und Signalanschluss des IE2808 aktualisiert
  • Sondervariante IE2808-0001 hinzugefügt
  • Blockschaltbild des IP/IE5109 aktualisiert
  • Montageanleitung für ZS1022 hinzugefügt
1.8.1
  • Mapping des IP5209 korrigiert
  • Beschreibung des Feature-Registers für IP/IE3312 aktualisiert
1.8.0
  • Erweiterungsmodul IE2403 hinzugefügt
1.7.4
  • IL230x-B110 im Kapitel Abmessungen hinzugefügt
  • Kapitel Third Party Produkte aktualisiert
1.7.3
  • Mapping des IE2808 korrigiert
1.7.2
  • Technische Daten des IE2808 aktualisiert
  • Blockschaltbild des IE2808 korrigiert
1.7.1
  • IP/IE1502, Gate-Eingang wird im Status-Byte abgebildet
1.7.0
  • Erweiterungsmodul IE2808 hinzugefügt
  • Montageschiene ZS5300-0001 hinzugefügt
  • IP-Link Direktsteckverbinder ZK1020-0101-1000 hinzugefügt
1.6.2
  • Diagnose-Kapitel erweitert
1.6.1
  • Technische Daten der Feldbus Box Module aktualisiert
  • kleinere Routinekorrekturen (Tippfehler, Rechtschreibung usw.)
1.6.0
  • Registereinstellungen IP/IE5009 korrigiert
  • kleinere Routinekorrekturen (Tippfehler, Rechtschreibung usw.)
1.5
  • Nummerierung der Kanäle in den Beschreibungen der Mappings an Darstellung in TwinCAT und KS2000 angepasst
  • kleinere Routinekorrekturen (Tippfehler, Rechtschreibung usw.)
1.4
  • Beschreibung der Mappings um Ethernet erweitert
1.3
  • Erweiterung der Spezifikation des IP-Link auf 15 Meter
  • Kapitel zu IP-Link überarbeitet und ergänzt
  • Registerbeschreibung für die Module IP/IE3202 korrigiert
1.2
  • Beschreibung von Control- und Status-Bytes aller Module überarbeitet
  • Beschreibung von Mapping und Konfiguration der Module IP/IE2512 und IP/IE5009 aktualisiert
1.1
  • Beschreibung der Mappings an die Registerdarstellung in der Konfigurations-Software KS2000 angepasst
1.0
  • weitere Feldbus Box Module ergänzt
0.8
  • erste Vorabversion


Das Feldbus Box System

Feldbus Box Module sind robuste Feldbusstationen für viele verschiedene Feldbus-Systeme. Sie verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Neben digitalen und analogen Ein- und Ausgängen samt Thermoelement- und RTD-Eingängen gibt es Inkrementalencoder-Interfaces für die Weg- und Winkelmessung sowie serielle Schnittstellen für die Lösung vielfältiger Kommunikationsaufgaben.

Signalanschluss in 3 Varianten

Die digitalen Ein-/Ausgänge können wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12-Variante vorgesehen.

Alle wichtigen Signalformen

Spezielle Ein-/Ausgangskanäle auf den Kombi-E/A-Module lassen sich wahlweise als Ein- oder Ausgang nutzen. Eine Konfiguration ist nicht erforderlich, da die Feldbusschnittstelle für jeden Kombikanal sowohl Eingangs- als auch Ausgangsdaten zur Verfügung stellt. Durch die Kombi-Module hat der Anwender alle Vorteile einer feinen Signal-Granularität.

Die Prozessor-Logik, die Eingangsbeschaltung sowie die Sensorversorgung werden aus der Steuerspannung gespeist. Die Lastspannung für die Ausgänge kann separat zugeführt werden. Bei Feldbus Boxen, in denen nur Eingänge zur Verfügung stehen, kann die Lastversorgung UP zur Weiterleitung optional angeschlossen werden.

Die Zustände der Feldbus Box, der Feldbusverbindung, der Spannungsversorgung sowie der Signale werden von LEDs angezeigt.

Die Beschriftungsstreifen lassen sich extern maschinell beschriften und können dann eingeschoben werden.

Kombinierbare Feldbus Boxen für mehr Flexibilität

Die Feldbus Box Serie umfasst neben der Kompakt Box auch erweiterbare Geräte, die Koppler Box und die Erweiterungsbox sowie intelligente Geräte, die SPS Boxen.

Kompakt Box

Die Kompakt Box stellt dem Feldbus die E/A-Daten der angeschlossenen digitalen und analogen Sensoren und Aktuatoren zur Verfügung.

Koppler Box

Die Koppler Box sammelt zusätzlich über eine störsichere LWL-Verbindung (IP-Link) E/A-Daten von den Erweiterungsboxen ein. Sie können bis zu 120 Erweiterungsboxen an eine Koppler Box anschließen. Es ergibt sich so ein verteiltes IP67 E/A-Netzwerk mit nur einer Feldbusschnittstelle.

Die Koppler Box erkennt die angeschlossenen Erweiterungsmodule selbsttätig in der Aufstart-Phase und mappt die E/A-Daten automatisch in das Feldbus-Prozessabbild – eine Konfiguration ist nicht erforderlich. Aus Sicht des Feldbusses stellt sich die Koppler Box samt allen vernetzten Erweiterungsboxen als ein einziger Busteilnehmer mit entsprechend vielen E/A-Signalen dar.

Die Koppler Box entspricht dem Buskoppler aus dem BECKHOFF Busklemmen-System. BECKHOFF Feldbus-Geräte der Schutzart IP 20 (Busklemmen) und IP 67 (Feldbus Box) können problemlos kombiniert werden - das Daten-Handling ist jeweils gleich.

IP-Link

IP-Link ist eine LWL-Verbindung mit 2 Megabit/s Übertragungsrate, die 1000 binäre E/A-Daten in ca. 1 ms schnell und sicher überträgt – kleinere Konfigurationen entsprechend schneller. Durch die hohe Nutzdatenrate ist gewährleistet, dass die Kopplung über IP-Link keine spürbare Einschränkung der Feldbus-Performance mit sich bringt.

Für die schnelle und einfache Konfektionierung der IP-Link-Kabel vor Ort wurden preisgünstige Steckverbinder in IP 67 Schutzart entwickelt. Der Anschluss erfordert kein Spezialwerkzeug und lässt sich schnell und einfach durchführen. Die IP-Link-Kabel sind alternativ auch mit vorkonfektionierten Steckern erhältlich.

Durch die getrennte Zuführung der Ausgangs-Spannungsversorgung lassen sich Ausgangsgruppen einzeln abschalten. Außerdem können problemlos unterschiedliche Potenziale innerhalb eines Erweiterungsringes aufgebaut werden, da IP-Link naturgemäß über eine optimale Potenzialtrennung verfügt.

Erweiterungsbox

Die Erweiterungsboxen decken wie die Kompakt Boxen das gesamte Spektrum der E/A-Signale ab und dürfen bis zu 15 m Abstand voneinander haben. Sie bauen hierbei besonders klein und führen zu besonders preiswerten E/A-Lösungen in hoher Schutzart. Auch hier sind die digitalen Ein-/Ausgänge wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder anschließbar. Analoge Signaltypen werden mit der M12-Variante ausgerüstet. Die Schnapp-Steckverbinder verriegeln formschlüssig und ergeben eine rüttelfeste Verbindung, während sich die Schraub-Steckverbinder durch eine hohe Zugfestigkeit auszeichnen.

SPS Box

Die SPS Box ist eine intelligentes Feldbus Box mit SPS-Funktionalität für dezentrale Vorverarbeitung der E/A-Signale. Hiermit lassen sich Applikationsteile aus der zentralen Steuerung auslagern. Deren CPU und der Feldbus werden entlastet. Dezentral Zählen, Regeln oder Schalten sind typische Anwendungen für die SPS-Box. Die Reaktionszeiten sind unabhängig von der Buskommunikation und der übergeordneten Steuerung.

Bei Bus- oder Steuerungsausfall ist ein Funktionserhalt (z.B. geordnete Überführung des Prozesses in einen sicheren Zustand) möglich.

Die Programmierung erfolgt mit TwinCAT nach IEC 61131-3. Fünf verschiedene Programmiersprachen stehen zur Verfügung:

  • Anweisungsliste (AWL)

  • Funktionsplan (FUP)

  • Kontaktplan (KOP)

  • Ablaufsprache (AS)

  • Strukturierter Text (ST).

Der Programm-Download erfolgt wahlweise über den Feldbus oder über die Programmierschnittstelle.

Es stehen umfangreiche Debug-Funktionalitäten (Breakpoint, Einzelschritt, Monitoring, etc.) zur Verfügung. SPS Box verfügt über einen leistungsfähigen 16 Bit Controller, 32/96 KByte Programmspeicher und 32/64 KByte Datenspeicher. Weiter stehen 512 Byte als nichtflüchtiger Speicher für remanente Merker zur Verfügung.

SPS Box mit IP-Link

Nahezu unbeschränkte E/A-Möglichkeiten ergeben sich durch die programmierbare SPS Box mit IP-Link. Aus dem SPS-Programm heraus lassen sich bis zu 120 Erweiterungsmodule mit über 2000 E/As direkt ansprechen. Die SPS Box eignet sich damit auch als autarke Kleinsteuerung zur Steuerung von Anlagenteilen oder kleiner Maschinen.


Feldbus Box - Bezeichnungsübersicht

Die Bezeichnung der Feldbus Box Module ist wie folgt zu verstehen:
IXxxxy-zyyy

IX beschreibt die Bauform:

"IP" steht für die Bauform Kompakt Box.
"IL" steht für die Bauform Koppler Box (mit IP-Link).
"IE" steht für die Bauform Erweiterungsbox.

xxxy beschreibt die E/A-Beschaltung:

xxx bezeichnet die E/A-Eigenschaft:
"10x" - 8 x digitale Eingänge
"15x" - Zählermodul
"20x" - 8 x digitale Ausgänge
"23x" - 4 x digitale Eingänge und 4 x digitale Ausgänge
"24x" - 8 x digitale Eingänge und 8 x digitale Ausgänge
"25x" - PWM-Modul
"3xx" - 4 x analoge Eingänge
"4xx" - 4 x analoge Ausgänge
"5xx" - Inkremental-Encoder oder SSI-Geber
"6xx" - Gateway-Module RS232, RS422, RS485, TTY

y beschreibt den mechanischer Anschluss:
"0" steht für 8mm Schnappanschluss
"1" steht für M 8 Schraubanschluss
"2" steht für M 12 Schraubanschluss und
"9" steht für M23 Schraubanschluss

zyyy bezeichnet die Programmierbarkeit und das Feldbus-System:

z unterscheidet ob es sich um einen Slave oder einen programmierbare Slave handelt:
"B" - nicht programmierbar
"C" - programmierbar (SPS Box)

yyy steht für das Feldbus-System und den Bus-Anschluss:
"110" - EtherCAT
"200" - Lightbus
"310" - PROFIBUS
"318" - PROFIBUS mit integriertem T-Stück
"400" - Interbus
"510" - CANopen
"518" - CANopen mit integriertem T-Stück
"520" - DeviceNet
"528" - DeviceNet mit integriertem T-Stück
"730" - Modbus
"800" - RS485
"810" - RS232
"900" - Ethernet TCP/IP mit RJ45 für den Bus-Anschluss
"901" - Ethernet TCP/IP mit M12 für den Bus-Anschluss
"903" - PROFINET
"905" - EtherNet/IP

Kompakt Box

Die Feldbus Boxe verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Die digitalen Ein-/Ausgänge können wahlweise über Ø 8 mm Schnapp-, M8 Schraub- oder über M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12 Variante verfügbar.

Je nach Modul kann der E/A-Teil und der Stromversorgungsteil unterschiedlich sein.

Koppler Box

Die Koppler Box gibt es in drei Varianten als IL230x-Bxxx. Diese unterscheidet sich von der Kompakt Box dadurch, dass diese Module eine Schnittstelle zu den sogenannten Erweiterungsboxen bietet. Diese Schnittstelle ist ein Sub-Bussystem auf LWL Basis den sogenannten IP-Link. Dieses leistungsfähige Sub-Bussytem kann bis zu 120 Erweiterungsboxen an einer Koppler Box verarbeiten.

Erweiterungsbox

Feldbusunabhängige Erweiterungsmodule, die nur an einer Koppler Box über IP-Link betrieben werden können.

SPS Box

Eine SPS Box unterscheidet sich von einer Koppler Box dadurch, dass sie in IEC 61131-3 programmierbar ist. Dadurch kann dieser Slave auch ohne Master autonom arbeiten, zum Beispiel für Steuerungs- oder Regelungsaufgaben.


Firm- und Hardware-Stand

Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Hard- und Firmware-Stand. Die Eigenschaften werden weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben wie Module neue Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das diese Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand der Module können Sie anhand der mit einem D beginnenden Nummer auf der Seite des Moduls erkennen.

Syntax:

D . ww yy x y z u

ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel:

D.22081501

- Kalenderwoche 22
- des Jahres 2008
- Firmware-Stand Busplatine: 1
- Hardware Stand Busplatine: 5
- Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig)
- Hardware-Stand E/A-Platine: 1


IP100x-Bxxx, IE100x

8 digitale Eingänge (Filter 3,0 ms) 24 VDC

Die digitalen Eingangsmodule IP100x erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Der Signalzustand wird über Leuchtdioden angezeigt. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP1000), M8 Steckverbinder (IP1001) oder M12 Steckverbinder (IP1002). Die Sensoren werden aus der Steuerspannung US versorgt. Die Lastspannung UP wird im Eingangsmodul nicht verwendet, sie kann jedoch zur Weiterleitung optional angeschlossen werden.

Technische Daten | IP1000-Bxxx, IE1000 | IP1001-Bxxx, IE1001 | IP1002-Bxxx, IE1002
Anzahl Eingänge | 8
Anschluss Eingänge | Ø 8 Schnapp-Steckverbinder | M8 Steckverbinder | M12 Steckverbinder
Eingangsfilter | 3,0 ms
Nennspannung Eingänge | 24 VDC (20 V ... 29 V)
Signalspannung '0' | -3 V ... 5 V (EN61131-2, Typ 2)
Signalspannung '1' | 11 V ... 30 V (EN61131-2, Typ 2)
Eingangsstrom, Typ. | 6 mA (EN61131-2, Typ 2)
Sensorversorgung | aus Steuerspannung, max. 0,5 A je Kanal, gesamt kurzschlussfest
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 8 Eingangsbits
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Steckerbelegung siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP101x-Bxxx, IE101x

8 digital Eingänge 24 VDC, Filter 0,2 ms

Die digitalen Eingangsmodule IP101x erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Der Signalzustand über Leuchtdioden angezeigt, der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP1010), M8 Steckverbinder (IP1011) oder M12 Steckverbinder (IP1012). Die Sensoren werden aus der Steuerspannung US versorgt. Die Lastspannung UP wird im Eingangsmodul nicht verwendet, sie kann jedoch zur Weiterleitung optional angeschlossen werden.

Technische Daten | IP1010-Bxxx / IE1010 | IP1011-Bxxx / IE1011 | IP1012-Bxxx / IE1012
Anzahl Eingänge | 8
Anschluss Eingänge | Ø 8 Schnapp-Steckverbinder | M8 Steckverbinder | M12 Steckverbinder
Eingangsfilter | 0,2 ms
Nennspannung Eingänge | 24 VDC (20 V ... 29 V)
Signalspannung '0' | -3 V ... 5 V (EN61131-2, Typ 2)
Signalspannung '1' | 11 V ... 30 V (EN61131-2, Typ 2)
Eingangsstrom | typisch 6 mA (EN61131-2, Typ 2)
Sensorversorgung | aus Steuerspannung, maximal 0,5 A je Kanal, gesamt kurzschlussfest
Stromversorgung | Einspeisung: 1 x M 8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 8 Eingangsbits
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Steckerbelegung siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP200x-Bxxx, IE200x

8 digitale Ausgänge 24 VDC, Imax = 0,5 A

Die digitalen Ausgangsmodule IP200x schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 8 Ausgänge verarbeiten Lastströme bis 0,5 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2000), M8 Steckverbinder (IP2001) oder M12 Steckverbinder (IP2002). Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.

ip200x.jpg (29519 Byte)

Technische Daten | IP2000-Bxxx / IE2000 | IP2001-Bxxx / IE2001 | IP2002-Bxxx / IE2002
Anzahl Ausgänge | 8
Anschluss Ausgänge | Ø 8 Schnapp-Steckverbinder | M8 Steckverbinder | M12 Steckverbinder
Lastart | ohmsch, induktiv, Lampenlast
Nennspannung | 24 VDC (20 V ... 29 V)
Ausgangsstrom | maximal 0,5 A je Kanal, einzeln kurzschlussfest
Kurzschlussstrom | typisch 1,5 A
Stromaufnahme Lastspannung | typisch 20 mA pro Kanal
Sensorversorgung | aus Steuerspannung, maximal 0,5 A je Kanal, gesamt kurzschlussfest
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 8 Ausgangsbits
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP202x-Bxxx, IE202x

8 digitale Ausgänge 24 VDC, Imax = 2,0 A (Summenstrom max. 4 A)

Die digitalen Ausgangsmodule IP202x schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 8 Ausgänge verarbeiten Lastströme bis jeweils 2 A , wobei der Gesamtstrom auf 4 A begrenzt ist. Damit eignen sich diese Module besonders für Anwendungen, bei denen nicht alle Ausgänge gleichzeitig aktiv sind oder bei denen nicht alle Aktuatoren Signalströme von 2 A benötigen. Der Signalzustand wird über Leuchtdioden angezeigt.
Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2020), M8 Steckverbinder (IP2021) oder M12 Steckverbinder (IP2022). Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.

ip200x.jpg (29519 Byte)

Technische Daten | IP2020-Bxxx / IE2020 | IP2021-Bxxx / IE2021 | IP2022-Bxxx / IE2022
Anzahl Ausgänge | 8
Anschluss Ausgänge | Ø 8 Schnapp-Steckverbinder | M8 Steckverbinder | M12 Steckverbinder
Lastart | ohmsch, induktiv, Lampenlast
Nennspannung | 24 VDC (20 V ... 29 V)
Ausgangsstrom | maximal 2,0 A je Kanal, einzeln kurzschlussfest, Summenstrom maximal 4 A
Kurzschlussstrom | typisch 4,0 A
Stromaufnahme Lastspannung | typisch 30 mA pro Kanal
Sensorversorgung | aus Steuerspannung, maximal 0,5 A je Kanal, gesamt kurzschlussfest
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 8 Ausgangsbits
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP204x-Bxxx, IE204x

8 digitale Ausgänge 24 VDC, Imax = 2,0 A (Summenstrom max. 12A)

Die digitalen Ausgangsmodule IP204x schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 8 Ausgänge verarbeiten Lastströme bis jeweils 2 A, wobei der Gesamtstrom auf 12 A begrenzt ist. Die Ausgänge werden über drei Lastspannungskreise versorgt; damit entfällt bei diesen Modulen die Weiterleitung der Versorgungsspannung. Der Signalzustand wird über Leuchtdioden angezeigt. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2040), M8 Steckverbinder (IP2041) oder M12 Steckverbinder (IP2042). Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.

ip200x.jpg (29519 Byte)

Technische Daten | IP2040-Bxxx / IE2040 | IP2041-Bxxx / IE2041 | IP2042-Bxxx / IE2042
Anzahl Ausgänge | 8
Anschluss Ausgänge | Ø 8 Schnapp-Steckverbinder | M8 Steckverbinder | M12 Steckverbinder
Lastart | ohmsch, induktiv, Lampenlast
Nennspannung | 24 VDC (20 V ... 29 V)
Ausgangsstrom | maximal 2,0 A je Kanal, einzeln kurzschlussfest, Summenstrom 12 A - Kanäle 0...3: S 4 A - Kanäle 4...5: S 4 A - Kanäle 6...7: S 4 A
Kurzschlussstrom | typisch 4,0 A
Stromaufnahme Lastspannung | typisch 50 mA pro Kanal
Sensorversorgung | aus Steuerspannung, maximal 0,5 A je Kanal, gesamt kurzschlussfest
Stromversorgung | Einspeisung: 2 x M8 Stecker, 4-polig Weiterleitung: keine
Bits im Prozessabbild | 8 Ausgangsbits
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IE2808

16 digitale Ausgänge 24 VDC, Imax = 2,0 A (Summenstrom max. 4A)

Das digitale Ausgangsmodul IE2808 schaltet die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 16 Ausgänge verarbeiten Lastströme bis jeweils 0,5 A, wobei der Gesamtstrom auf 4 A begrenzt ist. Damit eignen sich diese Baugruppen besonders für Anwendungen, bei denen nicht alle Ausgänge gleichzeitig aktiv sind oder bei denen nicht alle Aktuatoren Signalströme von 0,5 A benötigen. Ein Ausgangskurzschluss wird erkannt und an die Steuerungsebene weitergeleitet.

Der Signalzustand wird über Leuchtdioden angezeigt. Der Signalanschluss erfolgt über eine 25-polige D-Sub-Buchse. Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.

Über die Register R32 und R33 können Default-Werte aktiviert werden, d.h. diese Werte werden im Falle eines Kommunikationsverlustes angenommen.

Mit R32 wird diese Fehlerbehandlung aktiviert. In R33 wird der Wert (ONn oder OFF) für jeden Ausgang vorgegegben.

Technische Daten | IE2808-0000 | IE2808-0001
Anzahl Ausgänge | 8
Anschluss Ausgänge | D-Sub-Buchse, 25-polig, UNC-Gewinde
Lastart | ohmsch, induktiv, Lampenlast
Nennlastspannung | 24 VDC (20 V ... 29 V)
Ausgangsstrom | max. 0,5 A je Kanal, einzeln kurzschlussfest, Summenstrom max. 4 A
Kurzschlussstrom | maximal 1,5 A
Stromaufnahme Lastspannung | typisch 5 mA pro Kanal
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 16 Ausgangsbits, optional: 16 Eingangsbits (Diagnose), Control-/Status-Byte
Rücksetzen der Fehleranzeige | manuell | automatisch
Potenzialtrennung | Steuerspannung / Feldbus: ja, durch IP-Link Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP230x-Bxxx, IE230x

4 digitale Eingänge (Eingangsfilter 3,0 ms) und 4 digitale Ausgänge, 24 VDC, Imax = 0,5 A

Die digitalen E/A-Module IP230x kombinieren 4 digitale Eingänge mit einem Eingangsfilter von 3 ms und 4 digitale Ausgänge auf einem Gerät. Die Ausgänge verarbeiten Lastströme bis 0,5 A , sie sind kurzschlussfest und verpolungsgeschützt. Der Signalzustand wird jeweils über Leuchtdioden angezeigt. Der Anschluss der Signale erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2300), M8 Schraub-Steckverbinder (IP2301) oder M12 Steckverbinder (IP2302).

Technische Daten | IP2300-Bxxx / IE2300 | IP2301-Bxxx / IE2301 | IP2302-Bxxx / IE2302
Anzahl Ausgänge | 4 Eingänge und 4 Ausgänge
Anschluss Ausgänge | Ø 8 Schnapp-Steckverbinder | M8 Steckverbinder | M12 Steckverbinder
Eingangsfilter | 3,0 ms
Signale „0“ / „1“ | -3 ... 5 V / 11 ... 30 V, 6 mA Eingangsstrom (EN61131-2, Typ 2)
Lastart | ohmsch, induktiv, Lampenlast
Nennlastspannung | 24 VDC (20 V ... 29 V)
Ausgangsstrom | maximal 0,5 A je Kanal, einzeln kurzschlussfest
Kurzschlussstrom | typisch 1,5 A
Stromaufnahme Lastspannung | typisch 20 mA pro Kanal
Sensorversorgung | aus Steuerspannung, maximal 0,5 A je Kanal, gesamt kurzschlussfest
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 4 Eingangsbits und 4 Ausgangsbits
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP231x-Bxxx, IE231x

4 digitale Eingänge (Eingangsfilter 0,2 ms) und 4 digitale Ausgänge 24 VDC, Imax = 0,5 A

Die digitalen E/A-Module IP231x kombinieren 4 digitale Eingänge mit einem Eingangsfilter von 0,2 ms und 4 digitale Ausgänge auf einem Gerät. Die Ausgänge verarbeiten Lastströme bis 0,5 A, sie sind kurzschlussfest und verpolungsgeschützt. Der Signalzustand wird jeweils über Leuchtdioden angezeigt. Der Anschluss der Signale erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2310), M8 Steckverbinder (IP2311) oder M12 Steckverbinder (IP2312).

Technische Daten | IP2310-Bxxx / IE2310 | IP2311-Bxxx / IE2311 | IP2312-Bxxx / IE2312
Anzahl Ausgänge | 4 Eingänge und 4 Ausgänge
Anschluss Ausgänge | Ø 8 Schnapp-Steckverbinder | M8 Steckverbinder | M12 Steckverbinder
Eingangsfilter | 0,2 ms
Signale „0“ / „1“ | -3 ... 5 V / 11 ... 30 V, 6 mA Eingangsstrom (EN61131-2, Typ 2)
Lastart | ohmsch, induktiv, Lampenlast
Nennlastspannung | 24 VDC (20 V ... 29 V)
Ausgangsstrom | maximal 0,5 A je Kanal, einzeln kurzschlussfest
Kurzschlussstrom | typisch 1,5 A
Stromaufnahme Lastspannung | typisch 20 mA pro Kanal
Sensorversorgung | aus Steuerspannung, maximal 0,5 A je Kanal, gesamt kurzschlussfest
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 4 Eingangsbits und 4 Ausgangsbits
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP232x-Bxxx, IE232x

4 digitale Eingänge (Eingangsfilter 3,0 ms) und 4 digitale Ausgänge 24 VDC, Imax = 2,0 A, Summenstrom 4 A

Die digitalen E/A-Module IP232x kombinieren 4 digitale Eingänge mit einem Eingangsfilter von 3 ms und 4 digitale Ausgänge auf einem Gerät. Die Ausgänge verarbeiten Lastströme bis 2,0 A, sie sind kurzschlussfest und verpolungsgeschützt. Der Signalzustand wird jeweils über Leuchtdioden angezeigt. Der Anschluss der Signale erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2320), M8 Steckverbinder (IP2321) oder M12 Steckverbinder (IP2322).

ip200x.jpg (29519 Byte)

Technische Daten | IP2320-Bxxx / IE2320 | IP2321-Bxxx / IE2321 | IP2322-Bxxx / IE2322
Anzahl Ausgänge | 4 Eingänge und 4 Ausgänge
Anschluss Ausgänge | Ø 8 Schnapp-Steckverbinder | M8 Steckverbinder | M12 Steckverbinder
Eingangsfilter | 3,0 ms
Signale „0“ / „1“ | -3 ... 5 V / 11 ... 30 V, 6 mA Eingangsstrom (EN61131-2, Typ 2)
Lastart | ohmsch, induktiv, Lampenlast
Nennlastspannung | 24 VDC (20 V ... 29 V)
Ausgangsstrom | max. 2,0 A je Kanal, einzeln kurzschlussfest, Summenstrom 4 A
Kurzschlussstrom | typisch 4,0 A
Stromaufnahme Lastspannung | typisch 30 mA pro Kanal
Sensorversorgung | aus Steuerspannung, max. 0,5 A je Kanal, gesamt kurzschlussfest
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 4 Eingangsbits und 4 Ausgangsbits
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP233x-Bxxx, IE233x

4 digitale Eingänge (Eingangsfilter 0,2 ms) und 4 digitale Ausgänge 24 VDC, Imax = 2,0 A, Summenstrom 4 A

Die digitalen E/A-Module IP233x kombinieren 4 digitale Eingänge mit einem Eingangsfilter von 0,2 ms und 4 digitale Ausgänge auf einem Gerät. Die Ausgänge verarbeiten Lastströme bis 2,0 A, sie sind kurzschlussfest und verpolungsgeschützt. Der Signalzustand wird jeweils über Leuchtdioden angezeigt. Der Anschluss der Signale erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2330), M8 Schraub-Steckverbinder (IP2331) oder M12 Schraub-Steckverbinder (IP2332).

ip200x.jpg (29519 Byte)

Technische Daten | IP2330-Bxxx / IE2330 | IP2331-Bxxx / IE2331 | IP2332-Bxxx / IE2332
Anzahl Ausgänge | 4 Eingänge und 4 Ausgänge
Anschluss Ausgänge | Ø 8 Schnapp-Steckverbinder | M8 Steckverbinder | M12 Steckverbinder
Eingangsfilter | 0,2 ms
Signale „0“ / „1“ | -3 ... 5 V / 11 ... 30 V, 6 mA Eingangsstrom (EN61131-2, Typ 2)
Lastart | ohmsch, induktiv, Lampenlast
Nennlastspannung | 24 VDC (20 V ... 29 V)
Ausgangsstrom | maximal 2,0 A je Kanal, einzeln kurzschlussfest, Summenstrom 4 A
Kurzschlussstrom | typisch 4,0 A
Stromaufnahme Lastspannung | typisch 30 mA pro Kanal
Sensorversorgung | aus Steuerspannung, max. 2,0 A je Kanal, gesamt kurzschlussfest
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 4 Eingangsbits und 4 Ausgangsbits
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP2400-Bxxx, IE2400, IP2401-Bxxx, IE2401

8 digitale Eingänge (Eingangsfilter 3,0 ms) und 8 digitale Ausgänge, 24 VDC, Imax = 0,5 A

Die digitalen E/A-Module IP240x verfügen über 8 Kanäle, die wahlweise als Ein- oder Ausgang nutzbar sind. Damit passt sich das Gerät flexibel an die Applikationsanforderungen an. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2400) oder M8 Schraub-Steckverbinder (IP2401), die jeweils vierpolig ausgeführt sind (getrennte Ein- und Ausgangspins). Damit lässt sich antivalente Sensorik direkt anschließen, für reine Ein- und Ausgänge stehen sowohl Adapterkabel als auch feldkonfektonierbare Steckverbinder zur Verfügung. Zudem können die Stromversorgungskabel direkt als Sensorkabel eingesetzt werden. Die Ausgänge verarbeiten Lastströme bis 0,5 A, sie sind kurzschlussfest und verpolungsgeschützt. Der Signalzustand wird jeweils über Leuchtdioden angezeigt.

Technische Daten | IP2400-Bxxx / IE2400 | IP2401-Bxxx / IE2401
Anzahl Ausgänge | 8 Eingänge und 8 Ausgänge
Anschluss Ausgänge | Ø 8 Schnapp-Steckverbinder | M8 Steckverbinder
Eingangsfilter | 3,0 ms
Signale „0“ / „1“ | -3 ... 5 V / 11 ... 30 V, 6 mA Eingangsstrom (EN61131-2, Typ 2)
Lastart | ohmsch, induktiv, Lampenlast
Nennlastspannung | 24 VDC (20 V ... 29 V)
Ausgangsstrom | maximal 0,5 A je Kanal, einzeln kurzschlussfest
Kurzschlussstrom | typisch 1,5 A
Stromaufnahme Lastspannung | typisch 20 mA pro Kanal
Sensorversorgung | aus Steuerspannung, maximal 0,5 A je Kanal, gesamt kurzschlussfest
Stromversorgung | Einspeisung: 1 x M 8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 8 Eingangsbits und 8 Ausgangsbits
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IE2403

8 digitale Eingänge (Eingangsfilter 3,0 ms) und 8 digitale Ausgänge, 24 VDC, Imax = 0,5 A

Das digitale Kombimodul IE2403 verfügt über 16 Kanäle mit 8 Ein- und 8 Ausgängen. Das Gerät passt sich flexibel an die Applikationsanforderungen an. Die Ausgänge stellen Lastströme bis 0,5 A zur Verfügung, Sie sind kurzschlussfest und verpolungsgeschützt. Der Signalanschluss erfolgt über KM-Steckverbinder mit Federkrafttechnik. Die KM-Steckverbinder stehen optional in 1- und 3-poliger Ausführung zur Verfügung. Die Baugruppe wird ohne KM-Steckverbinder ausgeliefert.

Achtung

Das Kombimodul IE2403 entspricht der Schutzart IP20. Es ist dazu gedacht innerhalb von Schalttafeln, Bedientableaus oder Schaltkästen eingesetzt zu werden um deren Signale in den IP-Link zu integrieren.

Das Kombimodul IE2403 entspricht nicht den Schutzarten IP65/IP67!

Technische Daten | IE2403
Anzahl Kanäle | 16 (8 Eingänge und 8 Ausgänge)
Anschluss Eingänge | Über KM-Steckverbinder ZS2001 (nicht im Lieferumfang des IE2403 enthalten). Bestellen Sie die gewünschte Variante für Ein- oder Dreileiteranschlusstechnik (siehe Bestellangaben und technische Daten).
Eingangsfilter | 3,0 ms
Signale „0“ / „1“ | -3 ... 5 V / 11 ... 30 V, 6 mA Eingangsstrom (EN61131-2, Typ 2)
Sensorversorgung | aus Steuerspannung, maximal 0,5 A je Kanal, gesamt kurzschlussfest
Anschluss Ausgänge | Über KM-Steckverbinder ZS2001 (nicht im Lieferumfang des IE2403 enthalten). Bitte bestellen Sie die gewünschte Variante für Ein- oder Dreileiteranschlusstechnik (siehe Bestellangaben und technische Daten).
Nennlastspannung | 24 VDC (20 V ... 29 V)
Lastart | ohmsch, induktiv, Lampenlast
Ausgangsstrom | maximal 0,5 A je Kanal, einzeln kurzschlussfest
Kurzschlussstrom | typisch 1,5 A
Stromaufnahme Lastspannung | typisch 20 mA pro Kanal
Stromversorgung | Einspeisung: 1 x M 8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 8 Eingangsbits und 8 Ausgangsbits
Potenzialtrennung | Steuerspannung / Feldbus: ja, durch IP-Link Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP3102-Bxxx, IE3102

4 analoge Eingänge, ±10 V

Die analoge Eingangsmodule IP3102 verarbeitet Signale im Bereich von -10 V bis +10 V. Die Spannung wird mit einer Auflösung von 16 Bit digitalisiert und galvanisch getrennt zum übergeordneten Automatisierungsgerät transportiert. Die 4 Eingangskanäle sind Differenzeingänge und besitzen ein gemeinsames, internes Massepotenzial. Die eingespeiste Lastspannung (frei wählbar bis 30 VDC) wird für die Sensorversorgung durchgeleitet. Somit können z. B. Mess-Potentiometer mit 10 VDC von einer externen Spannungsquelle versorgt werden. Das Modul verfügt über vielfältige Leistungsmerkmale, wobei die Default-Werte so gewählt wurden, dass eine Konfiguration in der Regel nicht erforderlich ist. Die Eingangsfilter und damit verbunden die Wandlungszeiten sind in weiten Bereichen einstellbar, mehrere Datenausgabeformate stehen zur Wahl. Die Skalierung der Eingänge kann bei Bedarf verändert werden, eine automatische Grenzwertüberwachung steht ebenfalls zur Verfügung. Parametriert wird wahlweise über den Feldbus oder mit der Konfigurations-Software KS2000.

ip200x.jpg (29519 Byte)

Technische Daten | IP3102-Bxxx / IE3102
Anzahl Kanäle | 4 analoge Eingänge
Anschluss Ausgänge | M12 Steckverbinder
Eingangsbereich Nennwert | -10 V ... +10 V
Eingangswiderstand | > 100 kΩ
Gleichtaktspannung | maximal 35 V
Wandlungszeit | 250 ms (default), konfigurierbar bis 5 ms
Auflösung | 15 Bit + Vorzeichen
Relativer Messfehler | < ± 0,3% vom Messbereichsendwert
Eingangsfilter | konfigurierbar
Sensorversorgung | aus der Lastspannung UP, DC, frei wählbar bis 30 V
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | E: 4 x 16 Bit, optional E/A: 4 x 8 Bit Control/Status + 4 x 16 Bit
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: 500 V zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP3112-Bxxx, IE3112

4 analog Eingänge, 0 bis 20 mA

Das analoge Eingangsmodul IP3112 verarbeitet Signale im Bereich von 0 bis 20 mA. Der Eingangsstrom wird mit einer Auflösung von 16 Bit (Default: 15 Bit) digitalisiert und galvanisch getrennt zum übergeordneten Automatisierungsgerät transportiert. Die 4 Eingangskanäle sind Differenzeingänge und besitzen ein gemeinsames, internes Massepotential. Die eingespeiste Lastspannung (frei wählbar bis 30 VDC) wird für die Sensorversorgung durchgeleitet. Das Modul verfügt über vielfältige Leistungsmerkmale, wobei die Default-Werte so gewählt wurden, dass eine Konfiguration in der Regel nicht erforderlich ist. Die Eingangsfilter und damit verbunden die Wandlungszeiten sind in weiten Bereichen einstellbar, mehrere Datenausgabeformate stehen zur Wahl. Die Skalierung der Eingänge kann bei Bedarf verändert werden, eine automatische Grenzwertüberwachung steht ebenfalls zur Verfügung. Parametriert wird wahlweise über den Feldbus oder mit dem Konfigurations-Software KS2000tool über die Konfigurationsschnittstelle. Die Parameter werden auf dem Modul gespeichert.

ip200x.jpg (29519 Byte)

Technische Daten | IP3112-Bxxx / IE3112
Anzahl Kanäle | 4 analoge Eingänge
Anschluss Ausgänge | M12 Steckverbinder
Eingangsbereich Nennwert | 0 ... 20 mA
Eingangswiderstand | 80 Ω Messwiderstand
Gleichtaktspannung | maximal 35 V
Wandlungszeit | 140 ms
Auflösung | 15 Bit + Vorzeichen
Relativer Messfehler | < ± 0,3% vom Messbereichsendwert
Eingangsfilter | konfigurierbar
Sensorversorgung | aus der Lastspannung UP, DC, frei wählbar bis 30 V
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | E: 4 x 16 Bit, optional E/A: 4 x 8 Bit Control/Status + 4 x 16 Bit
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: 500 V zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP3202-Bxxx, IE3202

4 Analoge Eingänge für PT100 (RTD)

Das analoge Eingangsmodul IP3202 erlaubt den direkten Anschluss von Widerstandssensoren. Die Schaltung des Moduls kann Sensoren in 2-, 3- und 4-Leiter-Anschlusstechnik betreiben. Die Linearisierung über den gesamten Temperaturbereich wird durch einen Mikroprozessor realisiert. Der Temperaturbereich ist frei wählbar. Das Modul kann auch zur Widerstandsmessung eingesetzt werden, die Ausgabe erfolgt dann direkt in Ohm. Die Standardeinstellung des Moduls ist: Auflösung 0,1°C im Temperaturbereich der PT100-Sensoren in 4-Leiteranschlusstechnnik. Sensorstörungen, wie z. B. Drahtbruch werden über Error-LEDs angezeigt. Das Modul verfügt über vielfältige Features, wobei die Default-Werte so gewählt wurden, dass ein Konfiguration in der Regel nicht erforderlich ist. Die Eingangsfilter und damit verbunden die Wandlungszeiten sind in weiten Bereichen einstellbar, mehrere Datenausgabeformate stehen zur Wahl. Die Skalierung der Eingänge kann bei Bedarf verändert werden, eine automatische Grenzwertüberwachung steht ebenfalls zur Verfügung. Parametriert wird wahlweise über den Feldbus oder mit dem Softwaretool KS2000.

ip200x.jpg (29519 Byte)

Technische Daten | IP3202-Bxxx / IE3202
Anzahl Kanäle | 4 analoge Eingänge
Anschluss Eingänge | M12 Steckverbinder
PT100-Anschlussart | 2-, 3- und 4-Leiter (4-Leiter default)
Eingangsbereich Nennwert | PT100, PT200, PT500, PT1000, Ni100, Ni120, Ni1000, Widerstandsmessung (z.B. Potentiometer)
Auflösung | 0,1°C pro Digit
Mess-Strom | typisch 0,5 A
Wandlungszeit | 260 ms
Messfehler | < +/-1°C
Eingangsfilter | 4 Varianten
Sensorversorgung | aus der Lastspannung US
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | E: 4 x 16 Bit, optional E/A: 4 x 8 Bit Control/Status + 4 x 16 Bit
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: 500 V zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP3312-Bxxx, IE3312

4 analoge Eingänge für Thermoelemente

Das analoge Eingangsmodul IP3312 erlaubt den direkten Anschluss von vier Thermoelementen. Die Schaltung des Moduls kann Thermoelement-Sensoren in 2-Leitertechnik betreiben. Die Linearisierung über den gesamten Temperaturbereich wird durch einen Mikroprozessor realisiert. Der Temperaturbereich ist frei wählbar. Das Modul kann auch zur Spannungsmessung (mV) eingesetzt werden. Die Standardeinstellung des Moduls ist: Auflösung 0,1°C im Temperaturbereich der Typ K-Sensoren. Sensorstörungen, wie z. B. Drahtbruch werden über Error-LEDs angezeigt. Die Kaltstellenkompensation erfolgt durch Temperaturmessung im Anschluss-Stecker. Somit können Standard Verlängerungsleitungen angeschlossen werden.

Das Modul verfügt über vielfältige Features, wobei die Default-Werte so gewählt wurden, dass ein Konfiguration in der Regel nicht erforderlich ist. Die Eingangsfilter und damit verbunden die Wandlungszeiten sind in weiten Bereichen einstellbar, mehrere Datenausgabeformate stehen zur Wahl. Die Skalierung der Eingänge kann bei Bedarf verändert werden, eine automatische Grenzwertüberwachung steht ebenfalls zur Verfügung. Parametriert wird wahlweise über den Feldbus oder mit der Parametrierungs-Software KS2000.

ip200x.jpg (29519 Byte)

Technische Daten | IP3312-Bxxx / IE3312
Anzahl Kanäle | 4 analoge Eingänge
Anschluss Eingänge | M12 Steckverbinder
Eingangsbereich Nennwert | Typ J, K, L, B, E, N, R, S, T, U (Voreingestellt Typ K), mV Messung
Auflösung | 0,1°C pro Digit
Wandlungszeit | 260 ms
Messfehler | < +/- 0,5% (vom Messbereichsendwert)
Eingangsfilter | 4 Varianten
Kaltstellenkompensation | über ZS2000-3712
Sensorversorgung | aus der Lastspannung US
Stromversorgung | Einspeisung: 1 x M 8 Stecker, 4-polig Weiterleitung: 1 x M 8 Buchse, 4-polig
Bits im Prozessabbild | E: 4 x 16 Bit, optional E/A: 4 x 8 Bit Control/Status + 4 x 16 Bit
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: 500 V zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP4112-Bxxx, IE4112

4 analoge Ausgänge, 0 bis 20 mA

Das analoge Ausgangsmodul IP/IE4112 erzeugt analoge Ausgangssignale im Bereich von 0 bis 20 mA. Der Strom wird mit einer Auflösung von 15 Bit (Default) galvanisch getrennt in die Prozessebene gespeist. Unter Verzicht auf die Übertragung des Vorzeichens kann auch eine Auflösung von 16 Bit gewählt werden. Die Skalierung der Ausgänge kann bei Bedarf verändert werden.
Die 4 Ausgangskanäle besitzen ein gemeinsames Massepotential mit der Versorgung 24 VDC. Die Ausgangstreiber werden aus der Steuerspannung gespeist. Die eingespeiste Lastspannung (frei wählbar bis 30 VDC) wird für die Aktuatorversorgung durchgeleitet.

ip200x.jpg (29519 Byte)

Technische Daten | IP4112-Bxxx, IE4112
Anzahl Kanäle | 4
Anschluss Ausgänge | M12 Steckverbinder
Ausgangsbereich | 0 ... 20 mA
Bürdenwiderstand | < 500 Ω
Auflösung | 15 Bit, konfigurierbar 16 Bit
Wandlungszeit | < 4 ms
Genauigkeit | < ± 0,1% vom Messbereichsendwert
Aktuatorversorgung | aus Lastspannung UP
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | A: 4 x 16 Bit Daten, optional: 4 x 8 Bit Control/Status
Potenzialtrennung | Steuerspannung / Feldbus: abhängig vom Bussystem Kanäle / Steuerspannung: 500 V zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... + 85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschluss.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP4132-Bxxx, IE4132

4 analoge Ausgänge, -10 V bis +10 V

Das analoge Ausgangsmodul IP/IE4132 erzeugt analoge Ausgangssignale im Bereich von -10 V bis +10 V. Die Spannung wird mit einer Auflösung von 16 Bit galvanisch getrennt zur Prozessebene gespeist. Die Skalierung der Ausgänge kann bei Bedarf verändert werden.
Die 4 Ausgangskanäle besitzen ein gemeinsames Massepotential mit der Versorgung 24 VDC. Die Ausgangstreiber werden aus der Steuerspannung gespeist. Die eingespeiste Lastspannung (frei wählbar bis 30 VDC) steht zur Aktuatorversorgung zur Verfügung.

ip200x.jpg (29519 Byte)

Technische Daten | IP4132-Bxxx
Anzahl Kanäle | 4
Anschluss Ausgänge | M12 Steckverbinder
Ausgangsbereich | - 10 V / 0 V ... 10 V
Bürdenwiderstand | > 5 kΩ
Auflösung | 16 Bit
Wandlungszeit | < 4 ms
Genauigkeit | < ± 0,1% vom Messbereichsendwert
Aktuatorversorgung | aus Lastspannung UP
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | A: 4 x 16 Bit Daten, optional: 4 x 8 Bit Control/Status
Potenzialtrennung | Steuerspannung / Feldbus: abhängig vom Bussystem Kanäle / Steuerspannung: ja zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... + 85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP1502-Bxxx, IE1502

Zähler Modul

Das Zählermodul verfügt über zwei schnelle Zähler bis 100 kHz. Es zählt binäre Impulse und transportiert den Zählerstand zum übergeordneten Automatisierungsgerät. Über den Eingang V/R sind die Zähler zwischen Vorwärts- und Rückwärtszählen (32 Bit) umschaltbar. Über die Torsignale (Gate-Eingänge) lassen sich die Zähler triggern: abhängig vom Gate-Eingangspegel wird die Zählfunktion unterbunden bzw. aktiviert. Die Ausgänge können abhängig vom Zählerstand schalten oder pulsen und lassen sich somit als schnelle Steuersignale für Feldgeräte nutzen. Von der Steuerung aus können der Zählerstand gesetzt, die Zählfunktionen gestartet und unterbunden sowie die Ausgänge gesetzt werden. Das Modul zeigt den Signalzustand der Ein- und Ausgänge durch Leuchtdioden an.

ip1502.jpg (29519 Byte)

Technische Daten | IP1502-Bxxx / IE1502
Anzahl der Zähler | 2 mit je 32 Bit Zählertiefe
Schaltfrequenz | 100 kHz (2 kHz bei der Umschaltung von Vorwärts/Rückwärts)
Anschluss Signale | M12 Steckverbinder
Anzahl Eingänge | 2 Zählereingänge, 2 Gate-Eingänge, 2 Vorwärts-/Rückwärtsumschalter
Nennspannung Eingänge | 24 VDC (20 V ... 29 V)
Signalspannung "0" | -3 V ... 5 V (EN61131-2, Typ 2)
Signalspannung "1" | 11 V ... 30 V (EN61131-2, Typ 2)
Anzahl der Ausgänge | pro Zähler ein Ausgang, maximal 0,5 A, kurzschlussfest
Sensorversorgung | aus der Steuerspannung, maximal 0,5 A gesamt, kurzschlussfest
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 64 Ausgangsbits (2 x 32) und 64 Eingangsbits (2 x 32) für Prozessdaten, 8 Ausgangsbits für Control-Byte und 8 Eingangsbits für Status-Byte
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Steckerbelegung siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP2512-Bxxx, IE2512

2-Kanal Pulsweiten Ausgang 24 VDC

Die Ausgänge der Module IP25x2 modulieren ein binäres Signal in der Pulsweite. Das Takt- und Pausenverhältnis wird durch einen 16-Bit-Wert vom Automatisierungsgerät vorgegeben. Die Ausgangsstufe ist überlast- und kurzschlusssicher, der maximalen Ausgangsstrom beträgt 2,5 A je Kanal. Neben der Betriebsart Pulsweitenmodulation können die Ausgänge auch frequenzmoduliert oder zur Schrittmotoransteuerung mit Puls-Richtungsvorgabe betrieben werden. Die Module enthalten zwei Kanäle, die ihren Signalzustand durch Leuchtdioden anzeigen. Die LEDs sind mit den Ausgängen getaktet und zeigen durch ihre Helligkeit das Taktverhältnis an.

Technische Daten | IP2512-Bxxx / IE2512
Anzahl der Ausgänge | 2
Anschluss Signale | M12 Steckverbinder
Lastart | ohmsch, induktiv
Nennlastspannung | 24 VDC (-15%/+20%)
Ausgangsstrom | maximal 2,5 A je Kanal, einzeln kurzschlussfest
Grundfrequenz | 2 Hz ... 80 kHz, Default: 250 Hz
Tastverhältnis | 0 % ... 100 % (Ton > 750 ns, Toff > 500 ns)
Auflösung | maximal 10 Bit
Freilaufdiode (Ausgang) | ja
Stromversorgung | Einspeisung: 1 x M 8 Stecker, 4-polig Weiterleitung: 1 x M 8 Buchse, 4-polig
Bits im Prozessabbild | 2 x 16 Ausgangsbits für Prozessdaten, 2 x 8 Ausgangsbits für Control-Bytes und 2 x 8 Eingangsbits für Status-Bytes
Potenzialtrennung | Steuerspannung / Feldbus: ja Kanäle / Steuerspannung: nein zwischen den Kanälen: nein
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Steckerbelegung siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP5009-Bxxx, IE5009

1-Kanal SSI-Geber Interface

Das SSI-Interface Modul IP5009 dient zum direkten Anschluss eines SSI-Gebers. Die Versorgung des Gebers erfolgt über das SSI-Interface. Die Schnittstellenschaltung gibt zum Auslesen des Gebers ein Taktsignal aus und stellt der Steuerung den einlaufenden Datenstrom als Datenwort im Prozessabbild zur Verfügung. Das Modul gibt die Daten wahlweise in Dual-Zahlen (binär) umgewandelt oder Graycode aus. Die Drehrichtungsanpassung ist konfigurierbar. Unterschiedliche Betriebsarten, Übertragungsfrequenzen und Bitbreiten können über Kontrollregister dauerhaft eingestellt werden.

Technische Daten | IP5009-Bxxx / IE5009
Anzahl der Kanäle | 1
Anschluss Encoder | M23 Steckverbinder, 12-polig
Signalart | Differenzsignal (RS485)
Geberversorgung | 24 VDC, aus Lastspannung
Übertragungsrate | einstellbar bis 1 MHz, 250 kHz voreingestellt
serieller Eingang | 24 Bit (einstellbar)
Datenrichtung | lesen
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | 32 Eingangsbits für Prozessdaten, optional: 8 Ausgangsbits für Control-Byte und 8 Eingangsbits für Status-Byte
Potenzialtrennung | abhängig vom Bussystem
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Steckerbelegung siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Maximale Ausgangsleistung siehe Derating.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP5109-Bxxx, IE5109

1-Kanal Inkremental Encoder-Interface 1 MHz

Das Modul IP5109 ist ein Interface zum direkten Anschluss von Inkremental-Encodern mit Differenzeingängen (RS485/5V) oder Einfacheingängen. Ein 16 Bit Zähler mit Quadraturdecoder sowie ein 16 Bit Latch für den Nullimpuls können gelesen, gesetzt oder aktiviert werden. Die Eingänge können wahlweise als Komplementär- oder Einfacheingänge genutzt werden.

Am Status Eingang des Interfaces kann, falls vorhanden, der Störmelde-Ausgang des Encoders angeschlossen werden. Eine Periodendauermessung mit einer Auflösung von 200 ns ist möglich. Der Tor-Eingang (Gate) erlaubt das Sperren des Zählers (High = Stop).

Über den Latch-Eingang wird mit einer steigenden Flanke vom Encoder oder über einen externen Sensor der aktuelle Zählerwert gespeichert.

Technische Daten | IP5109-Bxxx / IE5109
Anzahl der Kanäle | 1
Anschluss Encoder | M23 Steckverbinder, 12-polig
Anschluss Gate/Latch | M12 Steckverbinder
Sensorversorgung | aus Steuerspannung, maximal 0,5 A, gesamt kurzschlussfest
Zähler | 16 Bit binär
Geberversorgung | 5 VDC
Grenzfrequenz | 1 MHz (bei 4-fach Auswertung)
Quadraturdecoder | 1-, 2-, 4-fach Auswertung
Nullimpuls-Latch | 16 Bit
Befehle | Lesen, Setzen, Aktivieren
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | E/A: 2 x 16 Bit Daten, 1 x 8 Bit Control/Status
Potenzialtrennung | abhängig vom Bussystem
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Steckerbelegung siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP5209-Bxxx

BECKHOFF Feldbus Box: Sonderfunktionsmodule

IP5209-Bxxx (1Vss), IP5209-Bxxx-1000 (11µAss)

1-Kanal SinCos Encoder-Interface

Das Sinus-Cosinus Modul IP5209 dient als Interface zum direkten Anschluss eines Mess-Sensors z.B. eines Messtasters oder Encoders mit sinusförmigem Spannungsausgang 1Vss bzw. 11µAss an den übergeordneten Feldbus. Das Mess-Signal wird aufbereitet, interpoliert und als 32 Bit Wert zur Verfügung gestellt. Eine Signalperiode wird mit 10 Bit, d.h. 1024 Schritten aufgelöst. Die Interpolationsrate kann über das Register R35 geändert werden. Eine Zählrichtungsänderung kann über Register R32 durchgeführt werden. Die Referenzmarke wird ebenfalls in einem 32 Bit Wert gespeichert. Der aktuelle Zählwert und der Wert der Referenzmarke können gelesen und auf Null gesetzt werden. Ebenso ist ein Setzen des Zählwertes möglich. Die Grenzfrequenz für die Messsignaleingänge beträgt 100 kHz.

Die Verfahr- bzw. Drehgeschwindigkeit kann durch Vorgabe eines Grenzwertes überwacht werden. Wird dieser Grenzwert überschritten, wird ein Fehlerbit gesetzt.

Technische Daten | IP5209-Bxxx (1Vss), IP5209-Bxxx-1000 (11µAss)
Anzahl der Zähler | 1
Anschluss Encoder | M23 Steckverbinder, 12-polig
Sensorversorgung | 5 VDC aus Steuerspannung, maximal 0,5 A
Grenzfrequenz | 100 kHz (Abtastung der Eingangssignale mit 500 kHz)
Auflösung | 10 Bit, 1024 Schritte je Periode
Befehle | Zählwert löschen, Zählwert setzen, Zählrichtung ändern, Referenzmarken-Latch, Skalierung des Messwertes
Stromversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Bits im Prozessabbild | E/A: 2 x 32 Bit Daten (alternativ 1 x 32 Bit), 1 x 8 Bit Control/Status
Potenzialtrennung | abhängig vom Bussystem
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Steckerbelegung siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP6002-Bxxx, IE6002

1-Kanal RS232-Gateway

Das Schnittstellen-Modul IP/IE6002 ermöglicht den Anschluss von Geräten mit einer RS232-Schnittstelle. Die Schnittstelle arbeitet normkonform nach CCITT V.28/DIN 66 259-1. Das Modul überträgt die Daten volltransparent zum überlagerten Automatisierungsgerät, wobei der Datentransfer über den Feldbus mit einem einfachen Handshake-Protokoll abgewickelt wird. Dieses hat keinen Einfluss auf das Protokoll der seriellen Schnittstelle. Der aktive serielle Kommunikationskanal arbeitet unabhängig vom überlagerten Bussystem im Vollduplex-Betrieb mit bis zu 19200 Baud, wobei 128 Byte Empfangs- und 16 Byte Sendepuffer zur Verfügung stehen. Die RS323-Schnittstelle garantiert hohe Störsicherheit durch galvanisch getrennte Signale.

ip200x.jpg (29519 Byte)

Technische Daten | IP6002-Bxxx, IE6002
Anzahl Kanäle | 1 TxD und RxD, vollduplex
Übertragungsrate | 1200 ... 19200 Baud, 9600 Baud (8 Daten-Bits, no parity, ein Stop Bit)
Anschluss RS 232 | 5 Pin M12 Buchse
Bitverzerrung | < 3 %
RS 232 Leitungslänge | maximal 15 m
Signalspannung LOW | 3 V ... 18 V
Signalspannung HIGH | -18 V ... -3 V
Datenpuffer | 128 Byte Empfangs und 16 Byte Sendepuffer
Bytes im Prozessabbild | E/A: 5 Byte Nutzdaten,1 Byte Control/Status
Potenzialtrennung | Steuerspannung / Feldbus: abhängig vom Bus-System RS232 / Steuerspannung: 500 V
Zulässige Umgebungstemperatur im Betrieb | 0°C ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... + 85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP6012-Bxxx, IE6012

1-Kanal TTY-Gateway

Das Modul IP/IE6012 ermöglicht den Anschluss von Geräten mit einer 20 mA Strom-Schnittstelle. Die Schnittstelle arbeitet im passiven Betrieb. Das Modul überträgt die Daten volltransparent zum überlagerten Automatisierungsgerät, wobei der Datentransfer über den Feldbus mit einem einfachen Handshake-Protokoll abgewickelt wird. Dieses hat keinen Einfluss auf das Protokoll der seriellen Schnittstelle. Der aktive serielle Kommunikationskanal arbeitet unabhängig vom überlagerten Bussystem im Vollduplex-Betrieb mit bis zu 19200 Baud, wobei 128 Byte Empfangs- und 16 Byte Sendepuffer zur Verfügung stehen.
Die Strom-Schnittstelle garantiert hohe Störsicherheit durch galvanisch getrennte Signale mit eingeprägtem Strom.

ip200x.jpg (29519 Byte)

Technische Daten | IP6012-Bxxx, IE6012
Anzahl Kanäle | 1
Übertragungsrate | 1200 ... 19200 Baud, 9600 Baud (8 Daten-Bits, no parity, ein Stop Bit)
Anschluss TTY | 5 Pin M12 Buchse, Steckverbinder
Bitverzerrung | < 3 %
TTY Leitungslänge | maximal 1000 m twisted pair
Signalspannung LOW | 0 ... 3 mA
Signalspannung HIGH | 14 ... 20 mA
Datenpuffer | 128 Byte Empfangs und 16 Byte Sendepuffer
Bytes im Prozessabbild | E/A: 5 Byte Nutzdaten,1 Byte Control/Status
Potenzialtrennung | Steuerspannung / Feldbus: abhängig vom Bus-System TTY-Schnittstelle / Steuerspannung: 500 V
Zulässige Umgebungstemperatur im Betrieb | 0°C ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... + 85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


IP6022-Bxxx, IE6022

1-Kanal RS422/RS485-Gateway

Das Schnittstellen-Modul IP/IE6022 ermöglicht den Anschluss von Geräten mit einer RS422- oder RS485-Schnittstelle. Das Modul überträgt die Daten volltransparent zum überlagerten Automatisierungsgerät, wobei der Datentransfer über den Feldbus mit einem einfachen Handshake-Protokoll abgewickelt wird. Dieses hat keinen Einfluss auf das Protokoll der seriellen Schnittstelle. Der aktive serielle Kommunikationskanal arbeitet unabhängig vom überlagerten Bussystem im Vollduplex-Betrieb mit bis zu 19200 Baud, wobei 128 Byte Empfangs- und 16 Byte Sendepuffer zur Verfügung stehen. Die Differenzsignal-Übertragung nach RS422 garantiert hohe Störsicherheit durch galvanisch getrennte Signale.

ip200x.jpg (29519 Byte)

Technische Daten | IP6022-Bxxx, IE6022
Anzahl Kanäle | 1 RS 422 vollduplex, RS 485 halbduplex
Übertragungsrate | 1200 ... 19200 Baud, 9600 Baud (8 Daten-Bits, no parity, ein Stop Bit)
Anschluss RS 422/485 | 5 Pin M12 Buchse, Steckverbinder
Bitübertragung | mit Differenzsignal
Leitungsimpendanz | 120 Ω
RS 422/485 Leitungslänge | maximal 500 m twisted pair
Datenpuffer | 128 Byte Empfangs und 16 Byte Sendepuffer
Gleichtaktspannung | -7 V ... 12 V gegen Masse
Bytes im Prozessabbild | E/A: 5 Byte Nutzdaten,1 Byte Control/Status
Potenzialtrennung | Steuerspannung / Feldbus: abhängig vom Bus-System RS422/485 / Steuerspannung: 500 V
Zulässige Umgebungstemperatur im Betrieb | 0°C ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... + 85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig

Anschluss siehe Anschlussplan.

Parametrierung siehe Parametrierungsbeschreibung.

Mapping siehe Mapping-Beschreibung.

Gewicht und Abmessungen siehe Seite Abmessungen.


Feldbusbox - Abmessungen

BECKHOFF Feldbus Box: Montage

Abmessungen

Alle Maßangaben sind in Millimeter angegeben.

Allgemein

Technische Daten | Feldbus Box
Gehäusematerial | PA6 (Polyamid), Vergussmasse: Polyuhrethan
Montage | 2 x Befestigungslöcher für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | IEC EN 50082-2 / EN 50081-2
Zulässige Umgebungstemperatur im Betrieb | 0 ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25 ... + 85°C
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65/66/67
Zulassungen | CE, UL E172151

IPxxxx-Bxx8, IL230x-Bxx8, IL230x-B110, IXxxxx-B400, IXxxxx-B90x, IXxxxx-C900

Technische Daten | Kompakt- und Kopplerbox mit integriertem T-Stück
Abmessungen (H x B x T) | ca. 210 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm)
Gewicht | ca. 260 g - 290 g, je nach Modultyp

IPxxxx-Bxx0, IL230x-Bxx0, IL230x-Cxx0

Technische Daten | Kompakt- und Kopplerbox
Abmessungen (H x B x T) | ca. 175 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm, mit T-Stück ZS1031-2600 Höhe ca. 65 mm)
Gewicht | ca. 250 g - 280 g, je nach Modultyp

IExxxx

Technische Daten | Erweiterungsbox
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Gewicht | ca. 120 g - 200 g, je nach Modultyp


Befestigung

Achtung

Schützen Sie während der Montage der Module alle Anschlüsse, insbesondere die IP-Link-Anschlüsse vor Verschmutzung!

Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind!
Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden (Steckersets siehe Katalog)!

Die Feldbus Boxen werden mit zwei M3-Schrauben befestigt. Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher besitzen kein Gewinde. Beachten Sie bei der Montage, dass ein Y oder T-Stück für den Feldbusanschluss die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.

Der Abstand zwischen den Modulen sollte mindestens 4 cm betragen, damit der für das IP-Link-Kabel minimal zulässige Biegeradius von 50 mm nicht unterschritten wird. Die Erweiterungsmodule dürfen auch dicht aneinander gebaut werden, wenn Sie dabei folgendes beachten:

  • Der für das IP-Link-Kabel minimal zulässige Biegeradius darf nicht unterschritten werden.
  • Die Umgebungstemperatur darf 55°C nicht überschreiten.

Einbauvorschrift_IL_IE_Module.jpg (17147 Byte)

Montageschiene ZS5300-0001

Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Erweiterungs-Box-Module. Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3 Gewinden. Mittels M5 Schrauben (5,3 mm Langlöcher) kann die Schiene an der Maschine befestigt werden.

Die Schiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 Modulen. Sie kann applikationsspezifisch gekürzt werden.
Achtung Verwenden Sie zusammen mit Montageschiene ZS5300-0001 den IP-Link Direktsteckverbinder ZK1020-0101-1000 um den minimal zulässige Biegeradius (50 mm) des Standard-IP-Link-Kabels nicht zu unterscheiten.

IP-Link Direktsteckverbinder ZK1020-0101-1000

Der IP-Link Direktsteckverbinder ZK1020-0101-1000 ermöglicht die direkte Verbindung zweier Erweiterungs-Box-Module, zur einfachen Montage direkt nebeneinander.

Mit dem IP-Link Direktsteckverbinder kann der Montageabstand der Module zwischen 0 und 5 mm betragen.


Fieldbus Box - Anzugsmomente für Steckverbinder

BECKHOFF Feldbus Box: Montage und Verkabelung

Anzugsmomente für Steckverbinder

M8-Steckverbinder

Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen.

M12-Steckverbinder

Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.

Drehmomentschlüssel

Hinweis
Korrektes Drehmoment sicherstellen

Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (siehe Zubehör)!


Power Anschluss

Steuerspannung Us: 24V

Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.

Lastspannung UP: 24V

Die Lastspannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet (z.B. in Not-Aus-Fall), so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.

Weiterleitung der Versorgungsspannungen

Die Power-Anschlüsse IN und OUT sind im Modul gebrückt (nicht IP204x-Bxxx und IE204x). Somit können auf einfache Weise die Versorgungsspannungen Us und Up von Feldbus Box zu Feldbus Box weitergereicht werden.

Achtung Beachten Sie bei der Weiterleitung der Versorgungsspannung Us und Up jeweils, dass der maximal zulässige Strom von 4 A nicht überschritten wird!

Galvanische Trennung

Digitale Module

Bei den digitalen Ein-/Ausgabemodulen sind die Massen (GND) von Steuerspannung und Lastspannung verbunden!

Analoge Module

Bei den analogen Ein-/Ausgabemodulen sind diese Massen getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten. Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z.B. bei 0...10V Eingängen eine beliebige Referenzspannung (0...30 V) an Up angeschlossen werden, diese steht dann den Sensoren zur Verfügung (z.B. geglättete 10 V für Messpotentiometer). Details der Spannungsversorgung bei Analogmodulen sind daher dem Kapitel Signalvarianten zu entnehmen.

Achtung Wenn Sie digitale und analoge Feldbus Boxen direkt über vierpolige Powerleitungen verbinden, so ist für die analogen Feldbus Boxen die galvanische Trennung der Analogsignale von der Steuerspannung nicht mehr gegeben!

Pinbelegung (nicht IP204x-Bxxx und IE204x)

Pinbelegung (IP204x-Bxxx und IE204x)

sbsupply2.gif (7053 Byte)

Siehe auch im Kapitel IP204x-Bxxx / IE204x Signalanschluss unter Potentialgruppen.


Zuleitung und Stromversorgung

Allgemein

Bei den Feldbus Boxen gilt für jedes Modul, das pro Pin nur maximal 4 A fließen dürfen. Dies gilt für sämtliche Anschlussvarianten S8, M 8 und M12.

Worauf müssen Sie achten

  • Stromverbrauch der Feldbus Boxen (siehe Kapitel Stromverbrauch)
  • Stromverbrauch der Sensoren
  • Stromverbrauch der Aktuatoren
  • Kabel Länge und Verluste auf den Leitungen (siehe Kapitel Leitungsverluste)
  • Wird die Powerleitung weitergeführt, ist darauf zu achten das der Strom nicht überschritten wird (siehe Punkte davor).

Hinweis:

Beispiel 1:

Werden zum Beispiel an einem IP2001-Bxxx alle 8 Ausgänge mit 0,5 A gleichzeitig belastet, darf in diesem Fall die Power-Weiterleitung nicht genutzt werden, da dies sonst zur Zerstörung des Anschlusses bzw. des Gerätes führen kann.

Beispiel 2:

An einem IP/IE204x die Kanäle 0...3 angeschlossen, so dürfen hier nur 2 der 4 Kanäle mit 2 A belastet werden.


Leitungsverluste

Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkablung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.

Beispiel:
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.


FBB E/A-Module - Stromverbrauch

BECKHOFF Feldbus Box: Verkabelung

Stromverbrauch

Für die Stromweiterleitung und der Absicherung der Module sowie bei der Betrachtung des Spannungsabfall auf der Powerleitungsversorgung ist es wichtig, den Stromverbrauch der einzelnen Module zu kennen. Die nachfolgende Tabelle enthält den Stromverbrauch bei 24 VDC.

Die Sensorversorgung bzw. der Strom für evtl. Ausgänge muss dazu addiert werden.

E/A-Type Kompakt-Box
Module | −B310 | −B510, −B520 | −B730, −B800, −B810
IP1000−Bxxx, IP1001−Bxxx, IP1002−Bxxx, IP1010−Bxxx, IP1011−Bxxx, IP1012−Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP1502-Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2000−Bxxx, IP2001−Bxxx, IP2002−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2020−Bxxx, IP2021−Bxxx, IP2022−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2040−Bxxx, IP2041−Bxxx, IP2042−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2300−Bxxx, IP2301−Bxxx, IP2302−Bxxx, IP2310−Bxxx, IP2311−Bxxx, IP2312−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2320−Bxxx, IP2321−Bxxx, IP2322−Bxxx, IP2330−Bxxx, IP2331−Bxxx, IP2332−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2400−Bxxx, IP2401−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2512−Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP3102−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP3112−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP3202−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP3312−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP4112−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP4132−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5009−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5109−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5209−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP6002−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP6012−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP6022−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
E/A−Type Koppler Box
Module | −B310 | −B510, −B520 | −B730, −B800, −B810
IL2300−Bxxx, IL2301−Bxxx, IL2302−Bxxx | Is = 100 mA Ip = 5 mA | Is = 60 mA Ip = 5 mA | Is = 60 mA Ip = 5 mA
IL2300−Cxxx, IL2301−Cxxx, IL2302−Cxxx | Is = 100 mA Ip = 5 mA | − | −
E/A−Type Erweiterungsbox
Module |
IE1000, IE1001, IE1002, IE1010, IE1011, IE1012 | Is = 25 mA Ip = 5 mA
IE1502 | Is = 25 mA Ip = 5 mA
IE2000, IE2001, IE2002 | Is = 25 mA Ip = 5 mA
IE2020, IE2021, IE2022 | Is = 25 mA Ip = 5 mA
IE23xx, IE240x | Is = 25 mA Ip = 5 mA
IE2512 | Is = 25 mA Ip = 5 mA
IE2808 | Is = 40 mA Ip = 5 mA
IE3102 | Is = 55 mA Ip = 5 mA
IE3112 | Is = 55 mA Ip = 5 mA
IE3202 | Is = 40 mA Ip = 5 mA
IE3312 | Is = 40 mA Ip = 5 mA
IE4112 | Is = 40 mA Ip = 5 mA
IE4132 | Is = 40 mA Ip = 5 mA
IE5009 | Is = 55 mA Ip = 5 mA
IE5109 | Is = 55 mA Ip = 5 mA
IE6002 | Is = 40 mA Ip = 5 mA
IE6012 | Is = 40 mA Ip = 5 mA
IE6022 | Is = 40 mA Ip = 5 mA


Verkabelung des IP-Link

IP-Link ist das Sub-Bussystem der Feldbus Boxen. Die Topologie ist eine Ringstruktur. In der Koppler Box (IL230x-Bxxx oder IL230x-Cxxx) befindet sich der IP-Link-Master. Die Erweiterungsboxen (IExxxx) sind Slaves. Es dürfen max. 120 Erweiterungsboxen angeschlossen werden. Berücksichtig werden muss aber auch der Adressraum, den der jeweilige Feldbus-Master zur Verfügung stellt. Der Abstand zwischen zwei Erweiterungsboxen darf 15 Meter nicht überschreiten. Beachten Sie bei Planung und Installation der Erweiterungsboxen, dass die letzte Erweiterungsbox des LWL-Rings wieder an der Koppler Box angeschlossen werden muss.

Aufbau/Topologie

Aufbau einer Linie

Hierbei wird nur jede zweite Erweiterungsboxen angeschlossen. Es ist hierbei zu beachten das sich die maximale Entfernung zwischen zwei Boxen halbiert.

Beispiel

Sie haben 4 Erweiterungsboxen (4 x 15 m = 60 m). Weil nur jede zweite Erweiterungsbox an der Hinleitung angeschlossen wird, ergibt sich für die letzte Erweiterungsbox eine maximale Entfernung von 30 Meter zum Koppler.

IL-Link Vekabelung Linie.jpg (13508 Byte)

Aufbau eines Rings

Hierbei dürfen die erste und die letzte Erweiterungsbox jeweils maximal 15 Meter von der Koppler Box entfernt sein.

IL-Link Vekabelung Ring.jpg (15983 Byte)

Technische Daten

IP-Link
 | IP-Link
Baud-Rate | 2 MBaud
Medium | Licht
Anzahl der Teilnehmer | max. 120
Länge zwischen zwei Stationen | 15 m
Kabel | Kunststoff-Lichtwellenleiter 1000 um - Kern 1-adrig, PU Schutzmantel mit Kevlarfaser Durchmesser 5,5 mm
IP-Link Stecker | zugelassen nur ZS1020-0010
Ausziehkräfte | 20 N - 30 N
IP-Link Kabel Z1101
 | Z1101
Außendurchmesser Nennwert | 5,5 mm
Mantelwanddicke | 1,4 mm
Faser | Kunststoff LWL 980/1000 µm aus PMMA
Ader | PE Aderhülle, Nenndurchmesser 2,2 mm
Temperatur | -20...+70°C
Außenmantelwerkstoff | PUR
Gewicht Nennwert kg/km | 25
Zugfestigkeit (DIN VDE 0888 Teil 100V erf.501) | dauernd 100 N kurzzeitig 400 N
Biegeradien | Radius minimal 50 mm
Wechselbiegefestigkeit (DIN VDE 0888 Teil100 Verf.509) | 30.000 Zyklen
Schleppkettenprüfung | Radius 10 X Dm., 2 Millionen Zyklen
Dämpfung bei 650 nm | < 200 dB/km


Konfektionierung des IP-Link-Kabels

Benötigtes Werkzeug:
  • Seitenschneider
  • Abiosolierwerkzeug
  • Schleifpapier (Körnung 600)
Hinweis Beachten Sie beim Abisolieren und bei der Montage,
  • das der Lichtwellenleiter nicht geknickt und
  • der minimale Biegeradius von 50 mm nicht unterschritten wird! Engere Biegeradien können den Lichtwellenleiter beschädigen.
  • während der Montage ist es hilfreich, die Ader gegen Verschieben zu fixieren. Dies geht am einfachsten, indem Sie die LWL-Leitung mittels einer Schlaufe in der Hand halten (siehe Bild). Die kurzzeitige Unterschreitung des Biegeradius führt zu keiner bleibenden Dämpfung der Leitung.

Verwenden Sie zusammen mit Montageschiene ZS5300-0001 den IP-Link Direktsteckverbinder ZK1020-0101-1000 um den minimal zulässige Biegeradius (50 mm) des Standard-IP-Link-Kabels nicht zu unterscheiten.

Fixierung der IP-Link-Leitung zur Abisolierung

IP-Link-Stecker

IP-Link-Stecker (1) mit Kappe (2)

Kabelende vorbereiten

IP-Link Stecker Kabel.jpg (36044 Byte)

  • Schieben Sie zuerst die Kappe des IP-Link-Steckers (2) auf das Lichtwellenleiterkabel.
  • Kürzen Sie den orange-farbenen Außenmantel (A) um ca. 23 mm, ohne dabei die darunter liegenden Kevlar-Fasern (K) zu beschädigen.
  • Kürzen Sie die Kevlar-Fasern (K) auf ca. 19 mm.
  • Legen Sie die gelbe Kevlar-Fasern (K) nach hinten über den Außenmantel (A) zurück.
  • Kürzen Sie den schwarzen Adernmantel (U) um ca. 17 mm, ohne dabei den darunter liegenden Lichtwellenleiter (L) zu beschädigen.

Montage des IP-Link-Steckers

  • Schieben Sie den IP-Link-Stecker (1) vorsichtig auf das Lichtwellenleiterkabel, bis er gegen die über den Außenmantel geschlagenen Kevlar-Fasern stößt.
  • Schrauben Sie den Stecker im Uhrzeigersinn so weit auf den Außenmantel, bis er sich von Hand nicht weiter weiter drehen lässt (handfest). Verwenden Sie dazu kein Werkzeug! Der Stecker ist so konzipiert, dass er dabei in den schwarzen Adernmantel (U) ein Gewinde schneidet.
    Bei exakter Abisolierung steht der Lichtwellenleiter jetzt ca. 8 mm vorne aus dem IP-Link-Stecker (1) heraus.
  • Schneiden Sie die evtl. hinten aus dem IP-Link-Stecker herausstehenden Kevlar-Fasern ab, ohne den Außenmantel zu beschädigen.
  • Schieben sie die Kappe (2) auf dem Lichtwellenleiterkabel von hinten gegen den IP-Link-Stecker (1), bis sie darauf einrastet.
  • Schneiden Sie den vorne aus dem IP-Link-Stecker herausstehenden Lichtwellenleiter ca. 2 mm vor der Steckerspitze ab. Achtung, nicht kürzer schneiden, da die Faser sehr spröde ist und bis in den Stecker hinein absplittern könnte!
  • Schleifen Sie den Lichtwellenleiter mit Schleifpapier von 600er-Körnung, bis er nur noch ca. 0,4 mm aus der Steckerspitze heraussteht. Schleifen dabei den Stecker nicht an!
  • Entfernen Sie vorhandenen Schleifstaub und evtl. den entstandenen Grat.

Faserenden prüfen (Sichtkontrolle)

Überprüfen Sie die geschliffenen Faserenden:

  • Das Ende des Lichtwellenleiters muss rechtwinkelig zur Steckerführung eine saubere, plane Fläche aufweisen, die ca. 0,4 mm aus der Steckerspitze heraussteht.

  • Richten Sie ein Kabelende auf eine Lichtquelle. Am anderen Kabelende dürfen in der leuchtenden Faser keine Kratze, Risse oder Absplitterungen zu sehen sein.

Bestellhinweis

ZS1020-0010: IP-Link-Stecker, Verpackungseinheit 1 Stück
ZS1021-0010: IP-Link-Stecker, Verpackungseinheit 10 Stück


Montage des IP-Link-Steckers ZS1022-0010 (Clip-Variante)

Vorbereitung (Explosionszeichnung)

A: Lichtwellenleiter
B: Außenmantel
C: Kevlarfaser
D: Fasermantel
E: Faserkern
F: Klemmverschluss
G: O-Ring
H: Tülle
I: Steckergehäuse
  1. Manteln Sie Außen- und Fasermantel gemäß den vordefinierten Längenangaben ab.
    ACHTUNG:
    Achten Sie darauf achten, dass der Faserkern nicht beschädigt wird!
  2. Kürzen Sie die Kevlarfaser bündig zum Außenmantel.
    ACHTUNG:
    Um maximale Klemmkräfte zu erreichen, müssen Außen- und Fasermantel frei von plastischer Verformung (Kerben, etc.) sowie fett-, öl- und schmiermittelfrei sein.

Montage

  1. Ziehen Sie die Tülle auf den Außenmantel und den O-Ring auf den Klemmverschluss.
  2. Führen Sie den vorbereiteten Lichtwellenleiter soweit in das Steckergehäuse ein, bis Außenmantel an L und Fasermantel an K gleichzeitig anschlagen.
  3. Richten Sie das Steckergehäuse wie gewünscht aus um eine evtl. Torsion der Leitung beim Einbau zu verhindern.
  4. Schieben Sie die Tülle soweit auf das Steckergehäuse, bis sie radial einrastet.
  5. Drücken Sie den Klemmverschluss soweit in das Steckergehäuse, bis alle 4 Rastnasen einrasten. Dies kann werkzeugfrei oder unterstützend mit einer entsprechenden Zange erfolgen. Achten Sie dabei ist auf die richtige Einbaulage des Klemmverschlusses (siehe Kennzeichnung M). Die Rastlöcher N dienen zusätzlich zur Montagekontrolle des O-Rings.

Oberflächenbehandlung

  1. Bearbeiten Sie den Faserkern mittels Schleiflehre O auf das Endmaß und die Endgüte.
    Verwenden Sie dazu Schleifpapier mit 600er Körnung und einen festen, glatten Untergrund.
  2. Stecken Sie den montierten Stecker in die Schleiflehre und bewegen Sie die Schleiflehre mit leichtem Druck in Form einer Acht über das Schleifpapier.
  3. Entfernen Sie den angefallenen Schleifstaub mit einem sauberen, fusselfreien Tuch.
  4. Prüfen Sie die Qualität der geschliffenen Stirnfläche.
    Die Oberfläche muss eben und frei von Kratzern, Rillen und Absplitterungen sein!

Demontage

  1. Setzen Sie mit einem geeigneten Werkzeug an den Aussparungen P oder Q an.
  2. Hebeln Sie den Klemmverschluss einseitig aus dem geschlossenen Steckergehäuse heraus.
    ACHTUNG:
    Beschädigte bzw. verformte Bauteile nach erfolgter Demontage nicht wiederverwenden!
  3. Bereiten Sie den LWL nach erfolgter Demontage erneut gemäß Punkt 1 vor.

Bestellhinweis

ZS1022-0010: IP-Link-Stecker (Clip-Variante), Verpackungseinheit 10 Stück


Beispiele konfektionierter Stecker

Die Fotos wurden bei Verwendung einer Taschenlampe mit weißem Licht aufgenommen, die in das gegenüberliegende Ende der Leitung scheint.

Richtig:

Ein korrekt konfektionierter IP-Link Stecker sollte so aussehen:

Die Faser steht leicht über und ist rechtwinklig abgeschliffen. Keine Splitter oder ähnliches sind erkennbar.

Falsch:

Die Faser wurde zu kurz vor dem Stecker abgeschnitten, dabei splitterte sie bis in den Stecker zurück (der dunkle Teil im Faserzentrum).
Hier muss neu abgesetzt werden!

Falsch:

Hier wurde von vornherein zu kurz abgeschnitten. Die Faser erreicht nicht mal das Stecker-Ende.
Hier muss neu abgesetzt werden!

Falsch:

Faser wurde korrekt geschliffen. Sie zeigt einen sauberen, gleichmäßigen Lichtaustritt.

Die Faser ist aber zu lang und könnte so beim Stecken die optischen Elemente der Module beschädigen.
Hier kann einfach etwas weiter abgeschliffen werden.


Feldbus Box - Überprüfung der IP-Link-Verbindung

BECKHOFF Feldbus Box: Montage und Verkabelung

Überprüfung der IP-Link-Verbindung

Ein IP-Link-Kabel mit auf beiden Seiten korrekt konfektionierten IP-Link-Steckern garantiert eine fehlerfrei Übertragung.

Eine nachträgliche Prüfung der Übertragungsqualität und eine Fehlersuche ist mit der Konfigurationssoftware KS2000 möglich.

Hierzu sollte die Steuerung (z.B. ein PC mit Profibus-Karte) am Feldbus des Koppler Box angeschlossen sein und diese zyklisch mit Daten versorgen, oder die Koppler Box sollte mit der KS2000 auf freilaufend geschaltet werden.

Als Ergebnis sollte die I/O RUN LED auf dem Kopplermodul hellgrün leuchten. Dies zeigt, dass ein Datenaustausch mit den angeschlossenen Erweiterungsbox Modulen stattfindet. Eine rot flackernde I/O ERR LED zeigt fehlerhafte IP-Link-Telegramme an! Telegramme werden wie bei auch jedem Feldbussystem im Fehlerfall wiederholt, so dass eine Übertragung der Daten gewährleistet ist.

Fehlerzähler

In Tabelle 90, Offset 005 werden aufgetretene IP-Link-Fehler gezählt. Sporadisch auftretende Fehler bedeuten noch keine Probleme für die Kommunikation. Dieser Fehlerzähler wird nur durch ein Power ON/OFF zurückgesetzt.

Sollten in kurzer Zeit viel Fehler auftreten, wird eine schwere Störung diagnostiziert und das Koppler-Modul meldet diesen Fehler. Dies ist am Offset 006 oder 007 zu erkennen. Die beiden Werte stehen dann auf einem Wert > 200 und die I/O ERR LEDs des Koppler-Moduls blinken mit dem entsprechenden Fehler-Code.

Hinweis Die Konfigurations-Software KS2000 kommuniziert über einen seriellen Kanal mit der Koppler Box. Der Registerinhalt wird nicht andauernd aktualisiert, muss also manuell refreshed werden.

Fehlerort

Stellt das Koppler Modul einen Fehler fest, versucht es den Fehlerort aus dem Register der Erweiterungs-Box herauszulesen. Ist der Ring tatsächlich unterbrochen bzw. die Kommunikation stark gestört, ist dies nicht möglich. Dann wird nur der Ort des Bruchs dargestellt und zwar rückwärts vom Koppler gezählt (siehe IP-Link Fehlersuche).

Läuft die Kommunikation noch, kann in Tabelle 87 der Fehlerzähler je Erweiterungsmodul ausgelesen werden.

Hier bezieht sich der Offset auf die Position links im KS2000 Baum (siehe Grafik). d.h. in diesem Beispiel werden Fehler beim Offset 004 und 006 angezeigt.

Im IP-Link Aufbau ist der Fehler also bei der Übertragung zu Modul IE20xx und bei der Übertragung zu IE3112 zu suchen.

Der Fehler kann also liegen, an:

  • dem Sender-Modul
  • dem Empfänger-Modul
  • dem Kabel oder
  • den Steckern

Wird in Tabelle 90 ein Fehler angezeigt, aber in Tabelle 87 nicht, so ist die Fehlerursache in der Übertragungsstrecke zwischen dem letzten Erweiterungsmodul und dem Koppler zu suchen.

In fast allen Fällen sind Übertragungsfehler auf schlecht konfektionierte IP-Link-Stecker oder zu hohe Dämpfung im LWL-Kabel (durch scharfe Knicke o.ä.) zurückzuführen.

Tabelle 87 wird bei einer IP-Link-Unterbrechung nicht aktualisiert, da diese Werte direkt aus den Erweiterungs-Modulen kommen. Diese können dann über den IP-Link natürlich nicht mehr ausgelesen werden.

Hinweis Falls Sie eine Koppler-Box (z.B. IL2300-Bxxx, IL2301-Bxxx oder IL2302-Bxxx ) ganz ohne Erweiterungs-Box-Module (IExxxx) betreiben möchten, müssen Sie Sende- und Empfangs-Anschluss diese Koppler-Box über ein IP-Link-Kabel direkt miteinander verbinden! Hierfür eignet sich besonders der IP-Link-Verbindungsstecker ZK1020-0101-1000.


IP100x-Bxxx, IE100x Signalanschluss

8 digitale Eingänge 24 VDC, Filter 3,0 ms

Die digitalen Eingangsmodule IP100x erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Der Signalzustand wird über Leuchtdioden angezeigt, der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP1000), M8 Schraub-Steckverbinder (IP1001) oder M12 Schraub-Steckverbinder (IP1002). Die Sensoren werden aus der Steuerspannung Us versorgt. Die Lastspannung Up wird im Eingangsmodul nicht verwendet, sie kann jedoch zur Weiterleitung optional angeschlossen werden.


IP101x-Bxxx, IE101x Signalanschluss

8 digitale Eingänge 24 VDC, Filter 0,2 ms

Die digitalen Eingangsmodule IP101x erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Der Signalzustand wird über Leuchtdioden angezeigt Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP1010), M8 Schraub-Steckverbinder (IP1011) oder M12 Schraub-Steckverbinder (IP1012). Die Sensoren werden aus der Steuerspannung US versorgt. Die Lastspannung UP wird im Eingangsmodul nicht verwendet, sie kann jedoch zur Weiterleitung optional angeschlossen werden.


IP1502-Bxxx, IE1502 Signalanschluss

2-Kanal Vor-/Rückwärts-Zähler 24 VDC, 100 kHz

Das Zählermodul wird wie folgt angeschlossen:
Die Zählimpulse der Zähler 1 und 2 werden über Buchse A (Zähleranschluss) angeschlossen. Die Zählrichtung kann über Buchse B (Vor-/Rückwärts) vorgegeben werden. An Buchse C kann das Torsignal (Gate) kann den Zählerstand einfrieren, d.h. die Clock-Signale werden ignoriert. Die Ausgänge werden über Buchse D ausgegeben. Die Ausgänge werden über UP gespeist. Die Feldbus Box und die Signale für den Sensor werden über US gesteuert.


IP200x-Bxxx, IE200x Signalanschluss

8 digitale Ausgänge 24 VDC, Imax = 0,5 A

Die digitalen Ausgangsmodule IP200x schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 8 Ausgänge verarbeiten Lastströme bis 0,5 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2000), M8 Schraub-Steckverbinder (IP2001) oder M12 Schraub-Steckverbinder (IP2002). Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.


IP202x-Bxxx, IE202x Signalanschluss

8 digitale Ausgänge 24 VDC, Imax = 2,0 A, Summenstrom 4 A

Die digitalen Ausgangsmodule IP202x schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 8 Ausgänge verarbeiten Lastströme bis 2,0 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2020), M8 Schraub-Steckverbinder (IP2021) oder M12 Schraub-Steckverbinder (IP2022). Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.

Achtung Der Summenstrom darf nicht überschritten werden. Das heißt, es dürfen nur maximal 2 Ausgänge mit jeweils 2 A Last gleichzeitig eingeschaltet sein.


IP204x-Bxxx, IE204x Signalanschluss

8 digitale Ausgänge 24 VDC, Imax = 2,0 A, Summenstrom 12 A

Die digitalen Ausgangsmodule IP204x schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 8 Ausgänge verarbeiten Lastströme bis 2,0 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2040), M8 Schraub-Steckverbinder (IP2041) oder M12 Schraub-Steckverbinder (IP2042). Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.

Potentialgruppen

Bei diesem Modul wird die Lastspannung drei mal eingespeist. UP1 für Kanal 0-3 (Summenstrom 4 A), UP2 für Kanal 4-5 (Summenstrom 4 A) und UP3 für Kanal 6-7 (Summenstrom 4 A).

Der Summenstrom darf nicht überschritten werden. Das heißt, es dürfen nur maximal 2 Ausgänge mit jeweils 2 A Last gleichzeitig von Kanal 0-3 eingeschaltet sein.

Siehe auch Kapitel Technische Daten.


IP230x-Bxxx, IL230x-Bxxx, IL230x-Cxxx, IE230x Signalanschluss

BECKHOFF Feldbus Box: Verkabelung

IP230x-Bxxx, IL230x-Bxxx / IL230x-Cxxx / IE230x Signalanschluss

4 digitale Eingänge (Filter 3,0 ms) und 4 digitale Ausgänge 24 VDC, Imax = 0,5 A

Die digitalen Ausgangsmodule IP230x schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 4 Ausgänge verarbeiten Lastströme bis 0,5 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2300), M8 Schraub-Steckverbinder (IP2301) oder M12 Schraub-Steckverbinder (IP2302). Die kurzschlussfesten und verpolungsgeschützten Ausgänge befinden sich auf der unteren Hälfte der Feldbus Box. Bei den S8 und M8 sind dies die 4 untersten Buchsen und bei der M12 Anschlusstechnik die beiden untersten, wobei sich bei der M12 Variante 2 Ausgänge auf einer Buchse befinden.

Die digitalen Eingänge erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Der Signalzustand wird über Leuchtdioden angezeigt. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder. Die Eingänge befinden sich auf der oberen Hälfte der Feldbus Box. Bei den S8 und M8 sind dies die 4 obersten Buchsen und beim M12 die beiden oberen, wobei sich bei der M12 Variante 2 Eingänge auf einer Buchse befinden.
Die Sensoren werden aus der Steuerspannung US versorgt. Die Lastspannung UP wird für die Ausgangstreiber benötigt. Wenn Up und Us für die Weiterleitung genutzt wird, darf der maximale Strom 4 A nicht überschreiten.


IP231x-Bxxx, IE231x Signalanschluss

4 digitale Eingänge (Filter 0,2 ms) und 4 digitale Ausgänge 24 VDC, Imax = 0,5 A

Die digitalen Ausgangsmodule IP231x schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 4 Ausgänge verarbeiten Lastströme bis 0,5 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2300), M8 Schraub-Steckverbinder (IP2301) oder M12 Schraub-Steckverbinder (IP2302). Die Ausgänge sind kurzschlussfest und verpolungsgeschützt. Die Ausgänge befinden sich auf der unteren Hälfte der Feldbus Box. Bei den S8 und M8 sind dies die 4 untersten Buchsen und bei der M12 Anschlusstechnik die beiden untersten, wobei sich bei der M12 Variante 2 Ausgänge auf einer Buchse befinden.

Die digitalen Eingänge erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Der Signalzustand wird über Leuchtdioden angezeigt, der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder. Die Eingänge befinden sich auf der oberen Hälfte der Feldbus Box. Bei den S8 und M8 sind dies die 4 obersten Buchsen und beim M12 die beiden oberen, wobei sich bei der M12 Variante 2 Eingänge auf einer Buchse befinden.
Die Sensoren werden aus der Steuerspannung US versorgt. Die Lastspannung UP wird für die Ausgangstreiber benötigt. Wenn UP und US für die Weiterleitung genutzt wird, darf der maximale Strom 4 A nicht überschreiten.


IP232x-Bxxx, IE232x Signalanschluss

4 digitale Eingänge (Filter 3,0 ms) und 4 digitale Ausgänge 24 VDC, Imax = 2,0 A

Die digitalen Ausgangsmodule IP232x schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 4 Ausgänge verarbeiten Lastströme bis 2,0 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2320), M8 Schraub-Steckverbinder (IP2321) oder M12 Schraub-Steckverbinder (IP2322). Die kurzschlussfesten und verpolungsgeschützten Ausgänge befinden sich auf der unteren Hälfte der Feldbus Box. Bei den S8 und M8 sind dies die 4 untersten Buchsen und bei der M12 Anschlusstechnik die beiden untersten, wobei sich bei der M12 Variante 2 Ausgänge auf einer Buchse befinden.

Die digitalen Eingänge erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Der Signalzustand wird über Leuchtdioden angezeigt. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder. Die Eingänge befinden sich auf der oberen Hälfte der Feldbus Box. Bei den S8 und M8 sind dies die 4 obersten Buchsen und beim M12 die beiden oberen, wobei sich bei der M12 Variante 2 Eingänge auf einer Buchse befinden.
Die Sensoren werden aus der Steuerspannung US versorgt. Die Lastspannung UP wird für die Ausgangstreiber benötigt. Wenn UP und US für die Weiterleitung genutzt wird darf der maximale Strom die 4 A nicht überschreiten.


IP233x-Bxxx, IE233x Signalanschluss

4 digitale Eingänge (Filter 0,2 ms) und 4 digitale Ausgänge 24 VDC, Imax = 2,0 A

Die digitalen Ausgangsmodule IP233x schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 4 Ausgänge verarbeiten Lastströme bis 2,0 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2330), M8 Schraub-Steckverbinder (IP2331) oder M12 Schraub-Steckverbinder (IP2332). Die Ausgänge sind kurzschlussfest und verpolungsgeschützt. Die Ausgänge befinden sich auf der unteren Hälfte der Feldbus Box. Bei den S8 und M8 sind dies die 4 untersten Buchsen und bei der M12 Anschlusstechnik die beiden untersten, wobei sich bei der M12 Variante 2 Ausgänge auf einer Buchse befinden.

Die digitalen Eingänge erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Der Signalzustand wird über Leuchtdioden angezeigt. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder. Die Eingänge befinden sich auf der oberen Hälfte der Feldbus Box. Bei den S8 und M8 sind dies die 4 obersten Buchsen und beim M12 die beiden oberen, wobei sich bei der M12 Variante 2 Eingänge auf einer Buchse befinden.
Die Sensoren werden aus der Steuerspannung US versorgt. Die Lastspannung UP wird für die Ausgangstreiber benötigt. Wenn UP und US für die Weiterleitung genutzt wird darf der maximale Strom 4 A nicht überschreiten.


IP2400-Bxxx, IE2400, IP2401-Bxxx, IE2401 Signalanschluss

8 digitale Eingänge (Filter 3,0 ms) und 8 digitale Ausgänge 24 VDC, Imax = 0,5 A

Die digitalen Ausgangsmodule IP240x schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter. Die 8 Ausgänge verarbeiten Lastströme bis 0,5 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder (IP2400) oder M8 Schraub-Steckverbinder (IP2400). Die Ausgänge sind kurzschlussfest und verpolungsgeschützt. Ein Ausgang befinden sich zusammen mit einem Eingang auf einem S8 bzw. M8 Buchse.

Die digitalen Eingänge erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Der Signalzustand wird über Leuchtdioden angezeigt. Der Signalanschluss erfolgt wahlweise über 8 mm Schnapp-Steckverbinder oder M8 Schraub-Steckverbinder.
Die Sensoren werden aus der Steuerspannung US versorgt. Die Lastspannung UP wird für die Ausgangstreiber benötigt. Wenn UP und US für die Weiterleitung genutzt, wird darf der maximale Strom 4 A nicht überschreiten.


IE2403 Signalanschluss

8 digitale Eingänge (Filter 3,0 ms) und 8 digitale Ausgänge 24 VDC, Imax = 0,5 A

Das digitale Ausgangsmodul IE2403 schaltet die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Akttoren weiter. Die 8 Ausgänge verarbeiten Lastströme bis 0,5 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über verschiedene KM-Steckverbinder. Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.

Die digitalen Eingänge erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Der Signalzustand wird über Leuchtdioden angezeigt. Der Signalanschluss erfolgt wahlweise über verschiedene KM-Steckverbinder.

Die Sensoren werden aus der Steuerspannung US versorgt. Die Lastspannung UP, wird für die Ausgangstreiber benötigt. Falls UP und US weitergeführt werden, darf der maximale Strom 4 A nicht überschreiten.

Eingänge

Die Grafik zeigt den Anschluss von 8 Sensoren in Einleitertechnik sowie von jeweils einem Sensor in Zwei- und Dreileitertechnik.
Bitte beachten Sie für KM-Steckverbinder ZS2001-0004: zwei Brücken (24 V und 0 V) sind erforderlich um die Klemmstellen für Zwei- und Dreileiteranschlusstechnik zu versorgen.

Ausgänge

Die Grafik zeigt den Anschluss von 8 Aktoren in Einleitertechnik sowie von jeweils einem Aktor in Zwei- und Dreileitertechnik.
Bitte beachten Sie für KM-Steckverbinder ZS2001-0004: zwei Brücken (24 V und 0 V) sind erforderlich um die Klemmstellen für Zwei- und Dreileiteranschlusstechnik zu versorgen.

Spannungsversorgung

(Siehe auch Kapitel Power-Anschluss)

Das Kombimodul IE2403 wird über den linken M8-Schraubsteckverbinder (IN) Versorgt.
Die Sensoren werden aus der Steuerspannung US versorgt. Die Lastspannung UP wird für die Ausgangstreiber benötigt.

Der rechte M8-Schraubsteckverbinder (OUT) steht zur Weiterleitung der Versorgungsspannungen zum nächstem IP-Modul zur Verfügung.
Wenn UP und US für die Weiterleitung genutzt werden, wird darf der maximale Strom 4 A nicht überschreiten.


IP2512-Bxxx, IE2512 Signalanschluss

2 Pulsweitenausgänge, 24 VDC

Das Pulsweitenmodul wird wie folgt angeschlossen:


IE2808 Signalanschluss

8 digitale Ausgänge 24 VDC, Imax = 0,5 A

Das digitale Ausgangsmodul IE2808 schaltet die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktoren weiter.

Die 16 Ausgänge liefern Lastströme bis 0,5 A, wobei der Gesamtstrom aller Ausgänge 4 A nicht überschreiten darf.

Der Signalanschluss erfolgt über eine 25-polige D-Sub-Buchse. Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.


IP3102-Bxxx, IE3102 Signalanschluss

4 analoge Eingänge; -10 bis +10 V

Das Signal wird über ein Differenzsignal gemessen. Stehen an ihrem Sensor keine zwei Leitungen für die Differenzmessung zur Verfügung (z.B. 24 V, GND und Signal), muss GND mit Input gebrückt werden.

Pin 5 (Shield) ist kapazitiv mit dem Untergrund Ihrer Feldbus Box verbunden.

Versorgungsspannung

US - Es versorgt die Feldbus Elektronik und die Sensorelektronik. Sie ist galvanisch getrennt von UP.

UP - Wird für die Funktion des Moduls nicht benötigt und braucht nicht eingespeist werden.

Achtung

Sollten Sie UP für eine Weiterleitung nutzen und sie schließen ein Modul an in der US und UP nicht galvanisch getrennt sind (z.B. alle digitalen Module), wird durch die Weiterleitung die galvanische Trennung aufgehoben.

Bedeutung der LEDs

Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error. Die grüne LED Run leuchtet wenn Daten zum D/A-Wandler übertragen werden. Die rote LED Error zeigt einen Fehler an (Drahtbruch, Messwert außerhalb des Messbereichs).
Eine einwandfreie Funktion besteht wenn die grüne LED Run leuchtet und die rote LED Error aus ist.


IP3112-Bxxx, IE3112 Signalanschluss

4 analoge Eingänge, 0 bis 20 mA

Das Signal wird über ein Differenzsignal gemessen. Stehen an ihrem Sensor nur zwei Leitungen für die Differenzmessung zur Verfügung, d.h. der Sensor wird aus dem Modul gespeist , muss GND mit Input- gebrückt werden.

Pin 5 (Shield) ist kapazitiv mit dem Untergrund Ihrer Feldbus Box verbunden.

Versorgungsspannung

US - Es versorgt die Feldbus Elektronik und die Sensorelektronik. Sie ist galvanisch getrennt von UP.

UP - Wird für die Funktion des Moduls nicht benötigt und braucht nicht eingespeist werden.

Achtung

Sollten Sie UP für eine Weiterleitung nutzen und sie schließen ein Modul an in der US und UP nicht galvanisch getrennt sind (z.B. alle digitalen Module), wird durch die Weiterleitung die galvanische Trennung aufgehoben.

Bedeutung der LEDs

Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error . Die grüne LED Run leuchtet wenn Daten zum D/A Wandler übertragen werden. Die rote LED Error zeigt einen Fehler an (Drahtbruch, Messwert außerhalb des Messbereichs).
Eine einwandfreie Funktion besteht wenn die grüne LED Run leuchtet und die rote LED Error aus ist.


IP3202-Bxxx, IE3202 Signalanschluss

4 analoge Eingänge PT100 (RTD)

Die Vierleitertechnik hat den Vorteil, dass der Fehler durch das Kabel und Kontakte mit gemessen und herausgerechnet wird. Die Dreileitertechnik misst nur in eine Richtung zum Widerstandssensor den Leitungswiderstand und multipliziert diesen mal zwei. Dafür müssen Hin- und Rückleitung annähernd den gleichen ohmschen Widerstand besitzen. Bei der Zweileitertechnik gibt es einen Fehler, der durch Temperaturdeltas und Kabelquerschnitt sehr unterschiedlich sein kann.

Achtung

Die Einstellung der Anschlusstechnik muss für alle vier Kanäle gleich sein!

Pin 5 (Shield) ist kapazitiv mit dem Untergrund Ihrer Feldbus Box verbunden.

Versorgungsspannung

US - Versorgt die Feldbus Elektronik und die Sensorelektronik. Sie ist galvanisch getrennt von UP.

UP - Wird für die Funktion des Moduls nicht benötigt und braucht nicht eingespeist werden.

Achtung

Sollten Sie UP für eine Weiterleitung nutzen und sie schließen ein Modul an in der US und UP nicht galvanisch getrennt sind (z.B. alle digitalen Module), wird durch die Weiterleitung die galvanische Trennung aufgehoben.

Bedeutung der LEDs

Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error. Die grüne LED Run leuchtet wenn Daten zum D/A Wandler übertragen werden. Die rote LED Error zeigt einen Fehler an (Drahtbruch, Messwert außerhalb des Messbereichs, Temperaturkompensation außerhalb des Gültigkeitsbereich).
Eine einwandfreie Funktion besteht wenn die grüne LED Run leuchtet und die rote LED Error aus ist.


IP3312-Bxxx, IE3312 Signalanschluss

4 analoge Eingänge Thermoelement

Die Temperaturkompensation ist bei den IP/IE3312 Modulen nach außen geführt. Das heißt im Stecker wird die Temperaturkompensation direkt an der Anschlussstelle gemessen. Dies erlaubt ein wesentlich besseres Messergebnis der Temperatur. Beckhoff bietet hierfür ein Stecker (ZS2000-3712) an. Die Temperaturkompensation kann auch entfernt von der Feldbus Box durchgeführt werden. Sie müssen dann ein PT1000 zwischen Pin 1 und Pin 3 schalten. Je länger Sie die Leitung wählen, desto größer wird der gemessene Fehler durch Leitungslänge, Leitungsverluste und Störungen.

Pin 5 (Shield) ist kapazitiv mit dem Untergrund Ihrer Feldbus Box verbunden.

Versorgungsspannung

US - Es versorgt die Feldbus Elektronik und die Sensorelektronik. Sie ist galvanisch getrennt von UP.

UP - Wird für die Funktion des Moduls nicht benötigt und braucht nicht eingespeist werden.

Achtung

Sollten Sie UP für eine Weiterleitung nutzen und sie schließen ein Modul an in der US und UP nicht galvanisch getrennt sind (z.B. alle digitalen Module), wird durch die Weiterleitung die galvanische Trennung aufgehoben.

Bedeutung der LEDs

Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error. Die grüne LED Run leuchtet wenn Daten zum D/A Wandler übertragen werden. Die rote LED Error zeigt einen Fehler an (Drahtbruch, Messwert außerhalb des Messbereichs, Temperaturkompensation außerhalb des Gültigkeitsbereich).
Eine einwandfreie Funktion besteht wenn die grüne LED Run leuchtet und die rote LED Error aus ist.


IP4112-Bxxx, IE4112 Signalanschluss

4 analoge Ausgänge, 0 bis 20 mA

Der angeschlossene Aktuator wird über Output +/- angeschlossen. Optional kann der Aktuator noch mit 24 VDC betrieben/versorgt werden. Der Shield ist kapazitiv mit dem Untergrund verbunden. Um eine wirkungsvolle Ableitung der Störungen zu gewährleisten, muss der Untergrund leitend sein und niederohmig geerdet sein.

Bedeutung der LEDs

Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error. Die grüne LED Run leuchtet wenn Daten zum D/A Wandler übertragen werden. Die rote LED Error hat keine Funktion und leuchtet nur in der Hochlaufphase kurz auf.
Eine einwandfreie Funktion besteht, wenn die grüne LED Run leuchtet und die rote LED Error aus ist.


IP4132-Bxxx, IE4132 Signalanschluss

4 analoge Ausgänge, -10 bis +10 V

Der angeschlossene Aktuator wird über Output +/- angeschlossen. Optional kann der Aktuator noch mit 24 VDC betrieben/versorgt werden. Shield ist kapazitiv mit dem Untergrund verbunden. Um eine wirkungsvolle Ableitung der Störungen zu gewährleisten, muss der Untergrund leitend sein und niederohmig geerdet sein.

Bedeutung der LEDs

Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error. Die grüne LED Run leuchtet wenn Daten zum D/A Wandler übertragen werden. Die rote LED Error hat keine Funktion und leuchtet nur in der Hochlaufphase kurz auf.
Eine einwandfreie Funktion besteht, wenn die grüne LED Run leuchtet und die rote LED Error aus ist.


IP5009-Bxxx, IE5009 Signalanschluss

1-Kanal SSI-Geber-Interface

Das Modul besitzt eine M23-Buchse mit Außengewinde.

Pinbelegung:

Bedeutung der LEDs

Die grünen LEDs zeigen den Betrieb des Moduls an.


IP5109-Bxxx, IE5109 Signalanschluss

1-Kanal Inkremental Encoder-Interface, 1 MHz

Das Modul besitzt eine M23-Buchse mit Außengewinde für den Encoder-Anschluss und eine M12-Buchse mit Innengewinde.
Der Encoder wird über A, B und Null am M23 angeschlossen werden. Falls ein Fehlermeldeausgang am Encoder vorhanden ist, kann dieser über den Status-Eingang angeschlossen werden.

Über Gate auf dem M12-Steckverbinder kann der Encoder freigegeben werden. Über Latch wird z.B. ein externer Sensor angeschlossen, über den die Freigabe für die Erfassung des Latch-Werts erfolgen kann.

Bedeutung der LEDs

Die grünen LEDs zeigen die Pegel der Kanäle A, B und C an.


IP5209-Bxxx, Signalanschluss

BECKHOFF Feldbus Box: Verkabelung

IP5209-Bxxx Signalanschluss

1-Kanal SinCos-Encoder-Interface

Das Modul besitzt eine M23-Buchse mit Außengewinde.

  • die Variante IP5209-Bxxx-0000 (Version für 1 VSS) hat einen 12-poligen Stecker.
  • die Variante IP5209-Bxxx-1000 (Version für 11 µASS) hat einen 9-poligen Stecker.

Der Messtaster wird über einen M23-Steckverbinder (male) angeschlossen. Dieser ist typischerweise per Kabel direkt am Messtaster fest angeschlossen und enthält eine Anpassungs-Elektronik. Über den Stecker wird der Messtaster/Encoder/Sensor vom Modul aus mit der notwendigen Spannung versorgt!

Übertragen werden das Sinus-, das Cosinus-Signal und die Referenzmarke (Nullpunkt).


IP6002-Bxxx, IE6002 Signalanschluss

1 Kanal RS 232 Gateway

Die RS 232 Schnittstelle ist ein vollduplex Datenübertragung.

Bedeutung der LEDs

Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error. Die grüne LED Run leuchtet, wenn Daten übertragen werden. Die rote LED Error leuchtet, wenn Fehler in der Datenübertragung festgestellt werden.


IP6012-Bxxx, IE6012 Signalanschluss

1 Kanal TTY Gateway

Mit der TTY-Schnittstelle ist eine vollduplex Übertagung möglich. Das Modul ist rein passiv, d.h. der Strom für die Datenübertragung muss vom angeschlossenen Gerät geliefert werden. Sollte es sich bei dem angeschossenen Gerät ebenfalls um eine passive Strom Schnittstelle handeln muss der Strom eingespeist werden (siehe Bild 2).

Abb.1: Anschlussbelegung TTY-Schnittstelle

Abb.2: Anschluss an ein passives TTY-Geräte

Bedeutung der LEDs

Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error. Die grüne LED Run leuchtet, wenn Daten übertragen werden. Die rote LED Error leuchtet wenn Fehler in der Datenübertragung festgestellt werden.


IP6022-Bxxx, IE6022 Signalanschluss

1 Kanal RS 422 / RS 485 Gateway

Das Modul kann als RS 422 vollduplex oder als RS 485 halbduplex Gerät betrieben werden. Für den Betrieb an einem RS485 Gerät achten Sie darauf die PIN 1 und 3 und die PIN 2 und 4 zu brücken. Die Abschirmung (Shield) ist kapazitiv mit dem Untergrund verbunden. Um Störungen über die Abschirmung wirkungsvoll abzuleiten, muss der Untergrund, auf den das Modul befestig ist, niederohmig mit der Erde verbunden sein).

Anschluss Beispiel für RS 485 Übertragung

Bedeutung der LEDs

Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error. Die grüne LED Run leuchtet, wenn Daten übertragen werden. Die rote LED Error leuchtet, wenn Fehler in der Datenübertragung festgestellt werden.


ZS2001 - Bestellangaben

BECKHOFF ZS2001: Produktübersicht

Bestellangaben für KM-Steckverbinder

KM-Steckverbinder für Einleiteranschlusstechnik (ZS2001-0001, ZS2001-0002) | KM-Steckverbinder für Dreileiteranschlusstechnik (ZS2001-0004)
Bestellbezeichnung | Signal LEDs | Anschlusstechnik
 |  | Einleiter | Zweileiter | Dreileiter
ZS2001-0001 | nein | ja | nein | nein
ZS2001-0002 | ja | ja | nein | nein
ZS2001-0004 | ja | ja | ja | ja


ZS2001 - Technische Daten

BECKHOFF ZS2001: Produktübersicht

Technische Daten

Technische Daten | ZS2001-0001 | ZS2001-0002 | ZS2001-0004
Anzahl der Klemmstellen | 10 | 10 | 30
Signal-LEDs | nein | ja | ja
Nennspannung | 50 VDC | 24 VDC | 24 VDC
Nennstrom | 2 A
Leitungsquerschnitt | 0,5 mm2 ... 1,5 mm2
Abisolierlänge | 8 mm
Abmessungen (B x H x T) | ca. 42mm x 10,3mm x 26,9mm | ca. 42mm x 12,7mm x 26,9mm | ca. 42mm x 20,8mm x 26,9mm
Gewicht | ca. 10 g | ca. 10 g | ca. 20 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE


FBB E/A Module - Übersicht der Blockschaltbilder

BECKHOFF Feldbus Box: Blockschaltbilder

Übersicht der Blockschaltbilder

Typ | Beschreibung | Zeichnung
IP/IE1xxx | 8 digitale Eingänge 24 VDC | Blockschaltbild
IP/IE1502 | Vor-/Rückwärts-Zähler 24 VDC, 100 kHz | Blockschaltbild
IP/IE200x | 8 digitale Ausgänge 24 VDC, 0,5 A | Blockschaltbild
IP/IE202x | 8 digitale Ausgänge 24 VDC, 2.0 A, Summe = 4 A | Blockschaltbild
IP/IE204x | 8 digitale Ausgänge 24 VDC, 2.0 A, Summe = 12 A | Blockschaltbild
IP/IE23xx | 4 digitale Eingänge 24 VDC, 4 digitale Ausgänge 24 VDC | Blockschaltbild
IP/IE2400, IP/IE2401 | 8 digitale Eingänge 24 VDC, 8 digitale Ausgänge 24 VDC | Blockschaltbild
IE2403 (IP20) | 8 digitale Eingänge 24 VDC, 8 digitale Ausgänge 24 VDC | Blockschaltbild
IP/IE2512 | 2 Kanal Pulsweiten-Ausgang | Blockschaltbild
IE2808 | 16 digitale Ausgänge 24 VDC, 2,0 A, Summe = 4A | Blockschaltbild
IP/IE3102 | 4 analoge Differenzeingänge +-10V, 16 Bit | Blockschaltbild
IP/IE3112 | 4 analoge Differenzeingänge 0...20 mA, 16 Bit | Blockschaltbild
IP/IE3202 | 4 analoge Differenzeingänge RTD, 16 Bit | Blockschaltbild
IP/IE3312 | 4 analoge Differenzeingänge Thermoelemente, 16 Bit | Blockschaltbild
IP/IE4112 | 4 analoge Differenzausgänge 0...20 mA, 16 Bit | Blockschaltbild
IP/IE4132 | 4 analoge Differenzausgänge +- 10 V, 16 Bit | Blockschaltbild
IP/IE5009 | SSI Geber Interface | Blockschaltbild
IP/IE5109 | Inkremental Encoder Eingang | Blockschaltbild
IP5209 | Sin/Cos Encoder Eingang | Blockschaltbild
IP/IE6002 | serielle Schnittstelle RS232 | Blockschaltbild
IP/IE6012 | serielle Schnittstelle 0...20 mA (TTY) | Blockschaltbild
IP/IE6022 | serielle Schnittstelle RS485 | Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE1xxx Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE1502 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE20xx Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE23xx Blockschaltbild


IP2400-Bxxx, IE2400, IP2401-Bxxx, IE2401 Blockschaltbild

BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE2400, IP/IE2401 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IE2403 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE2512 Blockschaltbild


IE2808 Blockschaltbild

Ab Hardware-Version 0012:

Bis Hardware-Version 0011:


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE3102 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE3112 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE3202 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE3312 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE4112 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE4132 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE5009 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE5109 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP5209 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE6002 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE6012 Blockschaltbild


BECKHOFF Feldbus Box: Blockschaltbilder

IP/IE6022 Blockschaltbild


Mapping der Feldbus Box Module

Die Feldbus Box Module besitzen einen Speicher für das Abbild der Prozessdaten. Dieser Speicher wird vom Feldbus-Master ausgelesen bzw. beschrieben. Die Größe und die die Art des Prozessabbilds hängt vom Feldbus Box Typ, der Konfiguration, vom Feldbus-System und vom Feldbus-Master ab.

  • Bit-orientierte Feldbus Box Module (hauptsächlich digitale Module) haben eine feste Anzahl an Daten.
  • Nur bei den Byte-orientierten Feldbus Box Modulen (z.B. analoge Module und Module für Sonderfunktionen) können einige Änderungen vorgenommen werden:
    - kompaktes oder komplettes Mapping
    - tauschen von High- und Low-Byte (Intel-/Motorola-Format)
    - Word-Alignment (nur bei LightBus und Ethernet)
  • Eine Koppler Box hat ein variables Mapping, das von Art und Anzahl der angeschlossenen Erweiterungsboxen abhängt.

Bit-orientierte Feldbus Box Module

Bit-orientierte Feldbus Box Module besitzen eine bestimmte Anzahl von Ein oder/und Ausgängen, die nicht verändert werden kann.

 | Eingangsdaten | Ausgangsdaten
Modul | Anzahl der benutzten Bits | Anzahl der benutzten Bits
IP10xx-Byyy IE10xx | 8 | 0
IP20xx-Byyy IE20xx | 0 | 8
IP23xx-Byyy IE23xx | 4 (die 4 höherwertigen Bits werden nicht benutzt, belegen aber Prozessdatenspeicher) | 4 (die 4 höherwertigen Bits werden nicht benutzt, belegen aber Prozessdatenspeicher)
IP2400-Byyy, IP2401-Byyy IE2400, IE2401, IE2403 | 8 | 8

yyy steht für das Feldbus-System und den Bus-Anschluss (siehe Kapitel Bezeichnungsübersicht).

Byte-orientierte Feldbus Box Module

Byte-orientierten Feldbus Box Module können mit kompakten oder kompletten Prozessabbild betrieben werden. Die Anzahl der Bytes für das komplette Mapping ist in Klammern angegeben.

 | Eingangsdaten | Ausgangsdaten
Modul | Anzahl der benutzten Bytes | Anzahl der benutzten Bytes
IP15xx-Byyy IE15xx | 6 (6) | 6 (6)
IP25xx-Byyy IE25xx | 6 (6) | 6 (6)
IE2808 | 2 (3) | 2 (3)
IP3xxx-Byyy IE3xxx | 8 (12) | 0 (12)
IP41xx-Byyy IE41xx | 0 (12) | 8 (12)
IP5009-Byyy IE5009 | 4 (6) | 4 (6)
IP5109-Byyy IE5109 | 6 (8) | 6 (8)
IE5209 | 10 (10) | 10 (10)
IP6xxx-Byyy IE6xxx | 6 (6) | 6 (6)

Bei eingeschaltetem Word-Alignment kann sich die Anzahl der belegten Bytes noch erhöhen da nicht benutzte Bytes eingefügt werden können. Details entnehmen Sie bitte den modulspezifischen Mapping-Beschreibungen.


IP/IE10xx Mapping

Alle IP/IE10xx mappen sich mit 8 Bit Eingänge im Prozessabbild und sind für alle Bussysteme gleich.


IP/IE1502 Mapping

Auswertung im Intel-Format

Default-Mapping für CANopen, DeviceNet, Modbus, RS232 und RS485

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | Ch1 D2 | Ch1 D1 | Ch1 D2 | Ch1 D1
 | 2 | SB2 | Ch1 D3 | CB2 | Ch1 D3
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | Ch2 D3 | Ch2 D2 | Ch2 D3 | Ch2 D2

Auswertung im Motorola-Format

Default-Mapping für Profibus und Interbus

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 D3 | SB1 | Ch1 D3 | CB1
 | 1 | Ch1 D1 | Ch1 D2 | Ch1 D1 | Ch1 D2
 | 2 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 3 | Ch2 D2 | Ch2 D3 | Ch2 D2 | Ch2 D3
 | 4 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1

Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus und Ethernet sowie Controller Box (IL230x-Cxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | Ch1 D3 | Ch1 D2 | Ch1 D3 | Ch1 D2
 | 3 | reserviert | SB2 | reserviert | CB2
 | 4 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 5 | Ch2 D3 | Ch2 D2 | Ch2 D3 | Ch2 D2

Auswertung im Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D2 | Ch1 D3 | Ch1 D2 | Ch1 D3
 | 2 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 3 | reserviert | SB2 | reserviert | CB2
 | 4 | Ch2 D2 | Ch2 D3 | Ch2 D2 | Ch2 D3
 | 5 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
Legende

Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB n: Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)

Ch n D0: Kanal n, Daten-Byte 0 (niederwertigste Byte)
Ch n D1: Kanal n, Daten-Byte 1
Ch n D2: Kanal n, Daten-Byte 2
Ch n D3: Kanal n, Daten-Byte 3 (höchstwertigste Byte)

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IP/IE20xx Mapping

Alle IP/IE20xx mappen sich mit 8 Bit Ausgänge im Prozessabbild und sind für alle Bussysteme gleich.


IP/IE23xx Mapping

Alle IP/IE23xx mappen sich mit 4 Bit Ein- und 4 Bit Ausgänge im Prozessabbild und sind für alle Bussysteme gleich.

Bei Profibus kann das Mapping auf ein Byte aufgerundet werden (siehe Byte-Alignment).


IP/IE240x Mapping

Alle IP/IE240x mappen sich mit 8 Bit Ein- und 8 Bit Ausgänge im Prozessabbild und sind für alle Bussysteme gleich.


IP/IE2512 Mapping

Auswertung im Intel-Format

Default-Mapping für CANopen, DeviceNet, Modbus, RS232 und RS485

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 Reg0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 Reg1 | CB2 | Ch1 D1
 | 2 | Ch2 Reg1 | Ch2 Reg0 | Ch2 D1 | Ch2 D0

Auswertung im Motorola-Format

Default-Mapping für Profibus und Interbus

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 Reg1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 Reg0 | CB2 | Ch1 D0
 | 2 | Ch2 Reg0 | Ch2 Reg1 | Ch2 D0 | Ch2 D1

Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus und Ethernet sowie Controller Box (IL230x-Cxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 Reg1 | Ch1 Reg0 | Ch1 D1 | Ch1 D0
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 Reg1 | Ch2 Reg0 | Ch2 D1 | Ch2 D0

Auswertung im Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 Reg0 | Ch1 Reg1 | Ch1 D0 | Ch1 D1
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 Reg0 | Ch2 Reg1 | Ch2 D0 | Ch2 D1
Legende

Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB n: Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)

Ch n D0: Kanal n, niederwertiges Daten-Byte
Ch n D1: Kanal n, höherwertiges Daten-Byte

Ch n Reg0: Kanal n, niederwertiges Byte für Register Kommunikation
Ch n Reg1: Kanal n, höherwertiges Byte für Register Kommunikation

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IE2808 Mapping

Kompakte Auswertung

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: egal Word-Alignment: egal | 0 | - | - | Out2 | Out1

Komplette Auswertung ohne Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: egal Word-Alignment: nein | 0 | Diag1 | SB | Out1 | CB
 | 1 | - | Diag2 | - | Out2

Komplette Auswertung mit Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: egal Word-Alignment: ja | 0 | Diag1 | SB | Out1 | CB
 | 1 | res. | Diag2 | res. | Out2
Legende

Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB: Status-Byte (erscheint im Eingangsprozessabbild)
CB: Control-Byte (erscheint im Ausgangsprozessabbild)

Out1: Eingangsbits der Kanäle 8 bis 1
Out2: Eingangsbits der Kanäle 16 bis 9

Diag1: Diagnosebits der Kanäle 8 bis 1
Diag2: Diagnosebits der Kanäle 16 bis 9

res.: reserviert; dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IP/IE3102 Mapping

Kompakte Auswertung im Intel-Format

Default-Mapping für CANopen, DeviceNet, Modbus, RS232 und RS485

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | Ch1 D1 | Ch1 D0 | - | -
 | 1 | Ch2 D1 | Ch2 D0 | - | -
 | 2 | Ch3 D1 | Ch3 D0 | - | -
 | 3 | Ch4 D1 | Ch4 D0 | - | -

Kompakte Auswertung im Motorola-Format

Default-Mapping für Profibus und Interbus

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | Ch1 D0 | Ch1 D1 | - | -
 | 1 | Ch2 D0 | Ch2 D1 | - | -
 | 2 | Ch3 D0 | Ch3 D1 | - | -
 | 3 | Ch4 D0 | Ch4 D1 | - | -

Komplette Auswertung im Intel-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Komplette Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus und Ethernet sowie Controller Box (IL230x-Cxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Legende

Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB n: Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)

Ch n D0: Kanal n, niederwertiges Daten-Byte
Ch n D1: Kanal n, höherwertiges Daten-Byte

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IP/IE3112 Mapping

Kompakte Auswertung im Intel-Format

Default-Mapping für CANopen, DeviceNet, Modbus, RS232 und RS485

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | Ch1 D1 | Ch1 D0 | - | -
 | 1 | Ch2 D1 | Ch2 D0 | - | -
 | 2 | Ch3 D1 | Ch3 D0 | - | -
 | 3 | Ch4 D1 | Ch4 D0 | - | -

Kompakte Auswertung im Motorola-Format

Default-Mapping für Profibus und Interbus

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | Ch1 D0 | Ch1 D1 | - | -
 | 1 | Ch2 D0 | Ch2 D1 | - | -
 | 2 | Ch3 D0 | Ch3 D1 | - | -
 | 3 | Ch4 D0 | Ch4 D1 | - | -

Komplette Auswertung im Intel-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Komplette Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus und Ethernet sowie Controller Box (IL230x-Cxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Legende

Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB n: Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)

Ch n D0: Kanal n, niederwertiges Daten-Byte
Ch n D1: Kanal n, höherwertiges Daten-Byte

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IP/IE3202, KL3204 Mapping

Kompakte Auswertung im Intel-Format

Default-Mapping für CANopen, DeviceNet, Modbus, RS232 und RS485

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | Ch1 D1 | Ch1 D0 | - | -
 | 1 | Ch2 D1 | Ch2 D0 | - | -
 | 2 | Ch3 D1 | Ch3 D0 | - | -
 | 3 | Ch4 D1 | Ch4 D0 | - | -

Kompakte Auswertung im Motorola-Format

Default-Mapping für Profibus und Interbus

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | Ch1 D0 | Ch1 D1 | - | -
 | 1 | Ch2 D0 | Ch2 D1 | - | -
 | 2 | Ch3 D0 | Ch3 D1 | - | -
 | 3 | Ch4 D0 | Ch4 D1 | - | -

Komplette Auswertung im Intel-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Komplette Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus und Ethernet sowie Controller Box (IL230x-Cxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Legende

Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB n: Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)

Ch n D0: Kanal n, niederwertiges Daten-Byte
Ch n D1: Kanal n, höherwertiges Daten-Byte

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IP/IE3312, KL3314 Mapping

Kompakte Auswertung im Intel-Format

Default-Mapping für CANopen, DeviceNet, Modbus, RS232 und RS485

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | Ch1 D1 | Ch1 D0 | - | -
 | 1 | Ch2 D1 | Ch2 D0 | - | -
 | 2 | Ch3 D1 | Ch3 D0 | - | -
 | 3 | Ch4 D1 | Ch4 D0 | - | -

Kompakte Auswertung im Motorola-Format

Default-Mapping für Profibus und Interbus

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | Ch1 D0 | Ch1 D1 | - | -
 | 1 | Ch2 D0 | Ch2 D1 | - | -
 | 2 | Ch3 D0 | Ch3 D1 | - | -
 | 3 | Ch4 D0 | Ch4 D1 | - | -

Komplette Auswertung im Intel-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Komplette Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus und Ethernet sowie Controller Box (IL230x-Cxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Legende

Komplette Auswertung: Die Klemme/das Modul wird mit Control- und Status-Byte gemappt.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Die Klemme/das Modul liegt auf einer Wordgrenze im Buskoppler.

SB n: Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)

Ch n D0: Kanal n, niederwertiges Daten-Byte
Ch n D1: Kanal n, höherwertiges Daten-Byte

reserviert: Dieses Byte belegt Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IP/IE4112 Mapping

Kompakte Auswertung im Intel-Format

Default-Mapping für CANopen, DeviceNet, Modbus, RS232 und RS485

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | - | - | Ch1 D1 | Ch1 D0
 | 1 | - | - | Ch2 D1 | Ch2 D0
 | 2 | - | - | Ch3 D1 | Ch3 D0
 | 3 | - | - | Ch4 D1 | Ch4 D0

Kompakte Auswertung im Motorola-Format

Default-Mapping für Profibus und Interbus

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | - | - | Ch1 D0 | Ch1 D1
 | 1 | - | - | Ch2 D0 | Ch2 D1
 | 2 | - | - | Ch3 D0 | Ch3 D1
 | 3 | - | - | Ch4 D0 | Ch4 D1

Komplette Auswertung im Intel-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Komplette Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus und Ethernet sowie Controller Box (IL230x-Cxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Legende

Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB n: Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)

Ch n D0: Kanal n, niederwertiges Daten-Byte
Ch n D1: Kanal n, höherwertiges Daten-Byte

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IP/IE4132, KL4132 Mapping

Kompakte Auswertung im Intel-Format

Default-Mapping für CANopen, DeviceNet, Modbus, RS232 und RS485

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | - | - | Ch1 D1 | Ch1 D0
 | 1 | - | - | Ch2 D1 | Ch2 D0
 | 2 | - | - | Ch3 D1 | Ch3 D0
 | 3 | - | - | Ch4 D1 | Ch4 D0

Kompakte Auswertung im Motorola-Format

Default-Mapping für Profibus und Interbus

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | - | - | Ch1 D0 | Ch1 D1
 | 1 | - | - | Ch2 D0 | Ch2 D1
 | 2 | - | - | Ch3 D0 | Ch3 D1
 | 3 | - | - | Ch4 D0 | Ch4 D1

Komplette Auswertung im Intel-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Komplette Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus und Ethernet sowie Controller Box (IL230x-Cxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Komplette Auswertung im Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB1 | reserviert | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserviert | SB2 | reserviert | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserviert | SB3 | reserviert | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserviert | SB4 | reserviert | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Legende

Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB n: Status-Byte für Kanal n (erscheint im Eingangsprozessabbild)
CB n: Control-Byte für Kanal n (erscheint im Ausgangsprozessabbild)

Ch n D0: Kanal n, niederwertiges Daten-Byte
Ch n D1: Kanal n, höherwertiges Daten-Byte

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IP/IE5009 Mapping

Kompakte Auswertung im Intel-Format

Default-Mapping für CANopen, DeviceNet, Modbus, RS232 und RS485

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | D1 | D0 | - | -
 | 1 | D3 | D2 | - | -

Kompakte Auswertung im Motorola-Format

Default-Mapping für Profibus und Interbus

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | D2 | D3 | - | -
 | 1 | D0 | D1 | - | -

Komplette Auswertung im Intel-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | D0 | SB | Reg0 | Control
 | 1 | D2 | D1 | reserviert | Reg1
 | 2 | - | D3 | - | reserviert

Komplette Auswertung im Motorola-Format

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | D3 | SB | Reg1 | CB
 | 1 | D1 | D2 | reserviert | Reg0
 | 2 | - | D0 | - | reserviert

Komplette Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus und Ethernet sowie Controller Box (IL230x-Cxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB | reserviert | CB
 | 1 | D1 | D0 | Reg1 | Reg0
 | 2 | D3 | D2 | reserviert | reserviert

Komplette Auswertung im Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB | reserviert | CB
 | 1 | D2 | D3 | Reg0 | Reg1
 | 2 | D0 | D1 | reserviert | reserviert
Legende

Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB: Status-Byte (erscheint im Eingangsprozessabbild)
CB: Control-Byte (erscheint im Ausgangsprozessabbild)

D0 - D3 : Daten Bytes 0 bis 3

Reg0: niederwertiges Byte für Register Kommunikation
Reg1: höherwertiges Byte für Register Kommunikation

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IP/IE5109 Mapping

Auswertung im Intel-Format

Default-Mapping für CANopen, DeviceNet, Modbus, RS232 und RS485

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: nein | 0 | D0 | SB | Reg0 | CB
 | 1 | D2 | D1 | reserviert | Reg1
 | 2 | D4 | D3 | reserviert | reserviert

Auswertung im Motorola-Format

Default-Mapping für Profibus und Interbus

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: nein | 0 | D1 | SB | Reg1 | CB
 | 1 | D2 | D0 | reserviert | Reg0
 | 2 | D3 | D4 | reserviert | reserviert

Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus und Ethernet sowie Controller Box (IL230x-Cxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: ja | 0 | reserviert | SB | reserviert | CB
 | 1 | D1 | D0 | Reg1 | Reg0
 | 2 | reserviert | D2 | reserviert | reserviert
 | 3 | D4 | D3 | reserviert | reserviert

Auswertung Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: ja | 0 | reserviert | SB | reserviert | CB
 | 1 | D0 | D1 | Reg0 | Reg1
 | 2 | reserviert | D2 | reserviert | reserviert
 | 3 | D3 | D4 | reserviert | reserviert
Legende

Komplette Auswertung: Das Modul wird mit Control- und Status-Byte gemappt.
Motorola-Format: Einstellbar ist das Motorola oder Intel-Format .
Word-Alignment: Das Modul liegt auf einer Wordgrenze in der Koppler Box.

SB: Status-Byte (erscheint im Eingangsprozessabbild)
CB: Control-byte (erscheint im Ausgangsprozessabbild)

D0: niederwertiges Byte des Counter Word (lesen/setzen)
D1: höherwertiges Byte des Counter Word (lesen/setzen)
D2: Status von A,B, C (Latch), Gate und Latch Eingang
D3: niederwertiges Byte des Latch Word (lesen) / niederwertiges Byte der Periodendauer
D4: höherwertiges Byte des Latch Word (lesen) / höherwertiges Byte der Periodendauer

Reg0: niederwertiges Byte für Register Kommunikation
Reg1: höherwertiges Byte für Register Kommunikation

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IP5209 Mapping

Im Auslieferungszustand werden diese Module im Standard Format mit 8 Byte Nutzdaten ausgeliefert (Default: 8 Byte Nutzdaten, 9 Byte gesamt). Durch Umschalten des Feature Registers R32 kann auch ein 5-Byte Prozessinterface gewählt werden. Die Datenbytes des Latch-Wertes D4-D7 entfallen dann!

Auswertung im Intel-Format

Default-Mapping für CANopen, DeviceNet, Modbus, RS232 und RS485

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: nein | 0 | D0 | SB | D0 | CB
 | 1 | D2 | D1 | D2 | D1
 | 2 | D4 | D3 | reserviert | D3
 | 3 | D6 | D5 | reserviert | reserviert
 | 4 | - | D7 | - | reserviert

Auswertung im Motorola-Format

Default-Mapping für Profibus und Interbus

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: nein | 0 | D3 | SB | D3 | CB
 | 1 | D1 | D2 | D1 | D2
 | 2 | D7 | D0 | reserviert | D0
 | 3 | D5 | D6 | reserviert | reserviert
 | 4 | - | D4 | reserviert | -

Auswertung im Intel-Format bei Word-Alignment

Default-Mapping für Lightbus und Ethernet

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: nein Word-Alignment: ja | 0 | - | SB | - | CB
 | 1 | D1 | D0 | D1 | D0
 | 2 | D3 | D2 | D3 | D2
 | 3 | D5 | D4 | reserviert | reserviert
 | 4 | D7 | D6 | reserviert | reserviert

Auswertung im Motorola-Format bei Word-Alignment

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: ja Word-Alignment: ja | 0 | - | SB | - | CB
 | 1 | D2 | D3 | D2 | D3
 | 2 | D0 | D1 | D0 | D1
 | 3 | D6 | D7 | reserviert | reserviert
 | 4 | D4 | D5 | reserviert | reserviert
Legende

Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB: Status-Byte (erscheint im Eingangsprozessabbild)
CB: Control-Byte (erscheint im Ausgangsprozessabbild)

D0, D1, D2, D3: Bytes für den Counter-Wert (lesen), Zählwert
D4, D5, D6, D7: Bytes für den Latch-Wert (lesen)

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


IP/IE60x2 Mapping

Standardformat

(Default: 5 Byte Nutzdaten, 6 Byte gesamt)
Im Auslieferungszustand werden diese Module im Standard Format mit 5 Byte Nutzdaten ausgeliefert.

Default-Mapping für Lightbus, Profibus, Interbus, CANopen, DeviceNet, Modbus, RS232, RS485 und Ethernet sowie Controller Box (IL230x-Cxxx)

 | Adresse | Eingangsdaten |  | Ausgangsdaten
Bedingungen | Wort-Offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Komplette Auswertung: egal Motorola-Format: egal Word-Alignment: egal | 0 | D0 | SB | D0 | CB
 | 1 | D2 | D1 | D2 | D1
 | 2 | D4 | D3 | D4 | D3
Legende

Komplette Auswertung: Zusätzlich zu den Prozessdaten werden auch die Control- und Status-Bytes in den Adressraum eingeblendet.
Motorola-Format: Einstellbar ist Motorola- oder Intel-Format.
Word-Alignment: Damit der Adressbereich der Kanäle immer auf einer Wortgrenze beginnt, werden Leer-Bytes in das Prozessabbild eingefügt.

SB: Status-Byte (erscheint im Eingangsprozessabbild)
CB: Control-Byte (erscheint im Ausgangsprozessabbild)

D0, D1, D2, D3, D4: Daten-Bytes

reserviert: Dieses Byte belegt den Prozessdatenspeicher, hat aber keine Funktion.
"-": Diese Byte wird von der Feldbus Box nicht belegt oder benutzt.


Allgemeine Registerbeschreibung

Bei den komplexen Modulen können verschiedene Betriebsarten bzw. Funktionalitäten eingestellt werden. Die Allgemeine Registerbeschreibung erläutert den Inhalt der Register, die bei allen komplexen Modulen identisch sind. Die modulspezifischen Register werden in dem darauffolgendem Kapitel erklärt.
Der Zugriff auf die internen Register der Module wird im Kapitel Register-Kommunikation beschrieben.

Allgemeine Registerbeschreibung

Komplexe Module die einen Prozessor besitzen, sind in der Lage mit der übergeordneten Steuerung bidirektional Daten auszutauschen. Diese Module werden im folgenden als intelligente Module bezeichnet. Zu ihnen zählen die analogen Eingänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), die analogen Ausgänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), serielle Schnittstellenmodule (RS485, RS232, TTY, Datenaustausch-Module), Zähler-Module, Encoder-Interface, SSI-Interface, PWM-Module und alle anderen parametrierbare Module.

Alle intelligenten Modulen besitzen intern eine in ihren wesentlichen Eigenschaften identisch aufgebaute Datenstruktur. Dieser Datenbereich ist wortweise organisiert und umfasst 64 Speicherplätze. Über diese Struktur sind die wesentlichen Daten und Parameter der Module les- und einstellbar. Zusätzlich sind Funktionsaufrufe mit entsprechenden Parametern möglich. Jeder logische Kanal einer intelligenten Module besitzt eine solche Struktur (4-Kanal analoge Module besitzen also 4 Registersätze).

Diese Struktur gliedert sich in folgende Bereiche:

Bereich | Adresse
Prozessvariablen | 0-7
Typ-Register | 8-15
Hersteller- Parameter | 16-30
Anwender- Parameter | 31-47
Erweiterter Anwenderbereich | 48-63

Register R0-R7 (im internen RAM des Moduls)

Die Prozessvariablen können ergänzend zum eigentlichen Prozessabbild genutzt werden und sind in ihrer Funktion Modulspezifisch.

R0-R5

Diese Register besitzen eine vom Modul-Typ abhängige Funktion.

R6

Diagnose-Register: Das Diagnose-Register kann zusätzliche Diagnose-Information enthalten. So werden z.B. bei seriellen Schnittstellenmodulen Paritäts-Fehler, die während der Datenübertragung aufgetreten sind, angezeigt.

R7

Kommandoregister

  • High-Byte_Write = Funktionsparameter
  • Low-Byte_Write = Funktionsnummer
  • High-Byte_Read = Funktionsergebnis
  • Low-Byte_ Read = Funktionsnummer

Register R8-R15 (im internen ROM des Moduls)

Die Typ- und Systemparameter sind fest vom Hersteller programmiert und können vom Anwender nur gelesen und nicht verändert werden.

R8

Feldbus Box Typ: Der Feldbus Box Typ in Register R8 wird zur Identifizierung der Feldbus Box benötigt.

R9

Softwareversion x.y.: Die Software-Version kann als ASCII-Zeichenfolge gelesen werden.

R10

Datenlänge: R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit. Der Buskoppler sieht diese Struktur.

R11

Signalkanäle: Im Vergleich zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z.B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.

R12

Minimale Datenlänge: Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control/Status-Byte für die Funktion des Moduls nicht zwingend notwendig, und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen. Die Information steht

  • bei einem Ausgangsmodul im High-Byte
  • bei einem Eingangsmodul im Low-Byte.
R13

Datentypregister

Datentypregister | Beschreibung
0x00 | Modul ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur 1 Byte n Bytes
0x03 | Word-Array
0x04 | Struktur 1 Byte n Worte
0x05 | Doppelwort-Array
0x06 | Struktur 1 Byte n Doppelworte
0x07 | Struktur 1 Byte 1 Wort
0x08 | Struktur 1 Byte 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur 1 Byte n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur 1 Byte n Worte mit variabler logischer Kanallänge
0x15 | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur 1 Byte n Doppelworte mit variabler logischer Kanallänge
R14

reserviert

R15

Alignment-Bits (RAM): Mit den Alignment-Bits wird das Analogmodul im Prozessabbild auf eine Bytegrenze gelegt.

Register R16-R30 (Hersteller-Parameter, serielles EEPROM)

Die Hersteller-Parameter werden vom Hersteller für jeden Modultyp modulspezifisch festgelegt, können jedoch mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Hersteller-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Hersteller-Parameter müssen Sie zuvor in Register R31 ein Code-Wort setzen.

Register R31-R47 (Anwendungs-Parameter, serielles EEPROM)

Die Anwender-Parameter sind Modulspezifisch. Sie können mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Anwender-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Anwender-Parameter müssen Sie zuvor in Register R31 das Anwender-Code-Wort setzen.

R31

Code-Wort-Register im RAM: Damit Parameter im Anwender-Bereich geändert werden können muss hier das Code-Wort 0x1235 eingetragen werden. Wird ein abweichender Wert in dieses Register eingetragen, so wird der Schreibschutz gesetzt. Bei inaktivem Schreibschutz wird das Code-Wort beim Lesen des Register zurückgegeben, ist der Schreibschutz aktiv enthält das Register den Wert Null.

R32

Feature-Register: Dieses Register legt die Betriebsarten der Klemme fest. So kann z.B. bei den analogen E/A-Modulen eine anwenderspezifische Skalierung aktiviert werden.

R33 bis R63

Klemmenspezifische Register: Diese Register sind vom Klemmentyp abhängig.

Register R47 bis R63 (Registererweiterung für zusätzliche Funktionen)

Diese Register sind für zusätzliche Funktionen vorgesehen.


Beispiel für Register-Kommunikation

Control-Byte

Das Control-Byte befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R/W | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Registerkommunikation eingeschaltet: Die ersten zwei Byte der Nutzdaten werden nicht für den Prozessdatenaustausch verwendet, sondern in den Registersatz der Feldbus Box geschrieben oder daraus gelesen.
6 | R/W | 0bin | Read: Das Register soll gelesen werden ohne es zu verändern.
 |  | 1bin | Write: Das Register soll beschrieben werden.
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll. Es sind 64 Register adressierbar.
Status-Byte

Das Status-Byte befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Quittung Registerzugriff
6 | R | 0bin | Read
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.

Beispiel 1

Lesen des Registers 8 von KL3204 oder IP/IE3202
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x88 (1000 1000bin) | 0xXX | 0xXX

Bit 0.7 gesetzt bedeutet Register-Kommunikation aktiv
Bit 0.6 nicht gesetzt bedeutet lesen des Registers.
Bit 0.5 bis Bit 0.0 geben mit 001000bin die Registernummer 8 an.
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim lesenden Zugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x88 | 0x0C | 0x84

Die Klemme/Box liefert im Eingangsdatenwort (Byte 1 und Byte 2) die Typ-Bezeichnung 0x0C84 (entspricht unsigned Integer 3204) zurück .

Besonderheit bei der Bezeichnung von Feldbus Boxen:
Die letzte Ziffer des zurückgegebenen unsigned Integer (3204) entspricht nicht der letzten Ziffer der Feldbus Box-Bezeichnung (3202), die für die Anschlussvariante (0 für S8, 1 für M8 und 2 für M12) steht. Sie gibt stattdessen die Anzahl der Kanäle wieder (IE3204 besitzt 4 Kanäle).

Hinweis Damit Register beschreiben werden können, müssen Sie zuvor das Codewort 0x1235 in Register 31 schreiben, um den Schreibschutz zu deaktivieren. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder.
Beachten Sie das einige Einstellungen in den Registern erst nach einem Neustart (Power-Off/Power-ON) des Moduls übernommen werden.

Beispiel 2

Ablauf einer Register-Kommunikation zum ändern eines Register.

1. Schreiben des Register 31 (Codewort setzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x12 | 0x35

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX
2. Lesen des Register 31 (gesetztes Codewort überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x9F | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0x12 | 0x35
3. Schreiben des Register 32 (Register ändern)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)e
0xE0 | 0x00 | 0x02

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0xXX | 0xXX
4. Lesen des Register 32 (geändertes Register überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xA0 | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0x00 | 0x02
5. Schreiben des Register 31 (Codewort zurücksetzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x00 | 0x00

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX


Funktionsweise IP/IE1502

Das Eingangsmodul Ix1502 zählt binäre Impulse und überträgt den aktuellen Wert zur übergeordneten Steuerung. Es stehen zwei vollkommen eigenständige 32-Bit-Vor/Rückwärts-Gated-Counter zur Verfügung. Ein Low-Pegel bzw. High-Pegel am Eingang GATE stoppt den jeweiligen Zähler abhängig der Einstellung im Feature-Register ( Feature.8 ) des Kanals. Die Zählrichtungen können durch separate Eingänge gesteuert werden (Low-Pegel=vorwärts, High-Pegel=rückwärts). Darüber hinaus können 2 digitale Ausgänge gesetzt werden.
Die maximale Eingangsfrequenz ist auf 100 kHz begrenzt, die minimale Impulsbreite des Eingangssignals beträgt ca. 1 Mikrosekunde. Die Zähler reagieren auf eine steigende Flanke des Eingangssignals.
Von der Steuerung kann über das Control-Byte (CB) der Zählerstand gesetzt (CB.5), die Zählfunktion des Moduls unterbunden (CB.4) und die Ausgänge aktiviert werden (CB.2 ). Außerdem kann eine interne Funktion aktiviert werden (CB.0), die das automatische Setzen der Ausgänge bei definierten Zählerständen ermöglicht. Durch das Bit R32.2 im Feature-Register kann noch unterschieden werden, ob die Zähler Flanken- oder Zustandsgesteuert gesetzt werden.

Interne Funktionen

Setzen/Zurücksetzen des Ausgangs und Reset des Zählers

Bei aktivierter interner Funktion (CB.0) werden die Ausgänge abhängig der Einstellungen im Feature-Register (R32.4 - R32.6) und der voreingestellten Werte in den Registern 35 - 38 gesetzt bzw. zurückgesetzt. Das Bit (Control Byte, Bit 2) zum Setzen des Ausgangs ist hierbei außer Funktion. Register 39 und 40 geben die Werte vor, bei denen die Zähler auf Null gesetzt werden, diese Funktion wird nur durch das Bit R32.6 im Feature-Register aktiviert und ist unabhängig vom Control-Byte.

Hinweis Das Setzen/Zurücksetzen/Reset der Zähler ist nur beim Vorwärtszählen implementiert!

Beim Starten des Moduls werden die Registerdaten aus dem EEPROM Bereich in den RAM Bereich übertragen.

Sollen die Werte während der Laufzeit geändert werden, so müssen sie von der Steuerung im RAM Bereich R0 - R5 eingetragen werden.

Impulsbetrieb

Bei aktivierter Impulsbetriebsart (R32.7 und CB.0) wird abhängig der voreingestellten Werte in den Registern 35 und 36 der jeweilige Ausgang für eine vorgegebene Impulslänge ( Einstellung im Register 41, Einheit: 1 µs/Digit oder 64 µs/Digit (Timer Faktor, Bit R32.9), kleinster Impuls: 250 µs, maximaler Impuls 4 s) gesetzt. Hierbei haben die Bits R32.4 und R32.5 des Feature-Registers keine Funktion. Der Reset der Zählerstände erfolgt identisch. Durch Bit R32.10 des Feature-Registers kann die Abschaltung des Ausgangs beeinflusst werden, und zwar ob der Ausgang mit einem Reset des Zählers oder nach Ablauf der Impulszeit zurückgenommen werden soll. Die voreingestellten Werte der Register 35 bis 41 werden nach einem Power-On-Reset in die Register 0 bis 5 kopiert (siehe Registertabelle), diese können während des Betriebes verändert werden. Nachdem das Feature-Register oder andere Register-Werte die im EEPROM stehen verändert wurden, muss ein Power-On-Reset erfolgen, damit diese Werte übernommen werden.

Prozessdaten

Beim Ix1502 Modul werden 5 Byte (4 Byte Nutzdaten und 1 Byte Control/Status) gemappt. Werden 100ms keine Prozessdaten ausgetauscht (Aktivierung über Bit R32.3 des Feature-Register), schaltet ein Watchdog die Ausgänge ab.

Ersatzschaltbild


Control- und Status-Byte IP/IE1502

Prozessdatenbetrieb

Control-Byte

Das Control-Byte ist immer sichtbar. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | 0 | CNT_SET | CNT_INH | GATE_A | SET_A | 0 | EN_A

Name | Beschreibung
RegAccess | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CNT_SET | Das Modul wird auf den Wert, der über die Prozessdaten vorgegeben wird, gesetzt. Das Setzen des Zählers kann Flanken- oder Pegelgesteuert erfolgen (Bit 2 des Feature-Registers). Pegelgesteuert: Das Zählermodul übernimmt die vorgegebenen Daten, der Zähler ist gesperrt bis zum zurücksetzen des CNT_SET Bit gesperrt. Flankengesteuert: Das Zählermodul übernimmt die vorgegebenen Daten bei einer positiven Flanke des CNT_SET Bit. Der Zähler kann danach sofort weiter zählen.
CNT_INH | Der Zähler wird gestoppt, solange dieses Bit aktiv ist. Der alte Zählerstand bleibt erhalten.
GATE_A | Der Zustand des GATE EIngangs wird im Status-Byte angezeigt. (IE1502 ab Version D.xxxxxx11, IP1502-Bxxx ab Version D.xxxxxx23)
SET_A | Setzen des Ausgangs
EN_A | Über dieses Bit werden die internen Funktionen im Register 32 freigegeben.

Status-Byte

Das Control-Byte ist immer sichtbar. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | 0 | SET_ACC | INH_ACC | ST_GATE | ST_A | ST_V/R | 0

Name | Beschreibung
RegAccess | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
SET_ACC | Die Daten zum Setzen des Zählers wurden vom Modul übernommen.
INH_ACC | Solange dieses Bit gesetzt ist, ist der Zähler gestoppt.
ST_GATE | Der Zustand des GATE Eingangs wird in diesem Bit wiedergegeben, wenn GATE_A im Control-Byte aktiviert ist.(ab Version D.xxxxxx11)
ST_A | Der Zustand vom Ausgang wird in diesem Bit wiedergegeben.
ST_V/R | Der Zustand vom V/R-Eingang wird im diesem Bit wiedergegeben.

Register-Kommunikation

Während der Register-Kommunikation sind keine Zählerwerte übertragbar.

Control-Byte

Das Control-Byte ist immer sichtbar. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Registerkommunikation eingeschaltet
R/W | 0bin: Read 1bin: Write
Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Control-Byte ist immer sichtbar. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Quittung für Registerzugriff
R/W | 0bin: Read
Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht IP/IE1502

Die Änderungen der Register R35 bis R40 werden erst nach einem Power On in die Register R0 bis R5 übernommen. R0 bis R5 können aber auch direkt beschrieben werden, dann werden die Schwellwerte, je nach Einstellung von R32, sofort gültig.

Achtung: Einschalt-Schwellwert < Ausschaltschwellwert < Reset-Schwellwert!

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | Einschalt-Schwellwert, niederwertiges Wort | variabel | R/W | RAM
R1 | Einschalt-Schwellwert, High-Wort | variabel | R/W | RAM
R2 | Ausschalt-Schwellwert, niederwertiges Wort Impulslänge (1µs/Digit) | variabel | R/W | RAM
R3 | Ausschalt-Schwellwert, höherwertiges Wort | variabel | R/W | RAM
R4 | Reset-Schwellwert, niederwertiges Wort | variabel | R/W | RAM
R5 | Reset-Schwellwert, höherwertiges Wort | variabel | R/W | RAM
R6 | reserviert | 0x0000 | R | RAM
R7 | reserviert | 0x0000 | R | RAM
R8 | Modul Typ | 1502dec | R | ROM
R9 | Software-Version | 0xXXXX | R | ROM
R10 | Multiplex-Schieberegister | 0x0228 | R | ROM
R11 | Signalkanäle | 0x0228 | R | ROM
R12 | minimale Datenlänge | 0x2828 | R | ROM
R13 | Datenstruktur | 0x0006 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Register | variable | R/W | RAM
R16 | Hardware-Versionsnummer | 0xXXXX | R/W | EEPROM
R17 | reserviert | 0x0000 | R/W |
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W |
R31 | Codeword-Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0104 | R/W | EEPROM
R33 | reserviert | 0x0000 | R/W |
R34 | reserviert | 0x0000 | R/W |
R35 | Einschalt-Schwellwert, niederwertiges Wort | 0x0000 | R/W | EEPROM
R36 | Einschalt-Schwellwert, höherwertiges Wort | 0x0000 | R/W | EEPROM
R37 | Ausschalt-Schwellwert, niederwertiges Wort | 0x0000 | R/W | EEPROM
R38 | Ausschalt-Schwellwert, höherwertiges Wort | 0x0000 | R/W | EEPROM
R39 | Reset-Schwellwert, niederwertiges Wort | 0xFFFF | R/W | EEPROM
R40 | Reset-Schwellwert, höherwertiges Wort | 0xFFFF | R/W | EEPROM
R41 | Impulslänge (1µs bzw. 64µs/Digit) | 0x00FA | R/W | EEPROM
R42 | reserviert | 0x0000 | R/W |
... | ... | ... | ... | ...
63 | reserviert | 0x0000 | R/W |


Feature-Register (R32) IP/IE1502

Im Feature-Register können die grundlegenden Einstellungen des Moduls verändert werden. Um das Register zu beschreiben muss im Codewort-Register erst der Schreibschutz aufgehoben werden. Die Einstellungen in Register 32 wenden erst nach einem Power-On-Reset (Modul aus- und einschalten) gültig.
Default 0x0104

Bit | Wert | Beschreibung | default
0 | 0bin | reserviert | 0bin
1 | 0bin | reserviert | 0bin
2 | 0bin | Watchdog ist aktiv | 0bin
 | 1bin | Watchdog ist inaktiv
3 | 0bin | Das Setzen des Zählers erfolgt bei einen positiven Signal von CNT_SET Bit im Control-Byte | 1bin
 | 1bin | Das Setzen des Zählers erfolgt bei positiver Flanke von CNT_SET Bit im Control-Byte
4 | 0bin | Die Funktion zum Setzen des Ausgangs ist inaktiv | 0bin
 | 1bin | Die Funktion zum Setzen des Ausgangs ist aktiv
5 | 0bin | Die Funktion zum Rücksetzen des Ausgangs ist inaktiv | 0bin
 | 1bin | Die Funktion zum Rücksetzen des Ausgangs ist aktiv
6 | 0bin | Die Funktion zum Reset des Zählers ist inaktiv | 0bin
 | 1bin | Die Funktion zum Reset des Zählers ist aktiv
7 | 0bin | Die Impuls-Betriebsart ist inaktiv | 0bin
 | 1bin | Die Impuls-Betriebsart ist aktiv
8 | 0bin | Zähler ist gesperrt wenn der Eingang Gate low (0) ist. | 1bin
 | 1bin | Zähler ist gesperrt wenn der Eingang Gate high (1) ist.
9 | 0bin | Timer-Basis (Impulslänge Register 41): 1 µs/Digi (250 µs - 65 ms) | 0bin
 | 1bin | Timer-Basis (Impulslänge Register 41): 64 µs/Digi (10 ms - 4 s)
10 | 0bin | Zurücksetzen des Ausgangs erfolgt mit einem Reset des Zählers | 0bin
 | 1bin | Zurücksetzen des Ausgangs erfolgt nach Ablauf der Impulszeit
11 | 0bin | reserviert | 0bin
... | ... | ... | ...
15 | 0bin | reserviert | 0bin

Erläuterung zum Watchdog
Der Watchdog-Timer ist im Auslieferungszustand eingeschaltet. Bei einem Watchdog-Overflow (>100 ms) wird der Ausgang zurückgesetzt.


Funktions-Register IP/IE1502

On/Off/Reset-Betrieb (RAM)

Register | Bedeutung | Ort | Speicher
0 | Einschalt-Schwellwert | Low-Wort | RAM
1 | Einschalt-Schwellwert | High-Wort | RAM
2 | Ausschalt-Schwellwert | Low-Wort | RAM
3 | Ausschalt-Schwellwert | High-Wort | RAM
4 | Reset-Schwellwert | Low-Wort | RAM
5 | Reset-Schwellwert | High-Wort | RAM

On/Off/Reset-Betrieb (EEPROM)

Register | Bedeutung | Ort | Speicher
35 | Einschalt-Schwellwert | Low-Wort | EEPROM
36 | Einschalt-Schwellwert | High-Wort | EEPROM
37 | Ausschalt-Schwellwert | Low-Wort | EEPROM
38 | Ausschalt-Schwellwert | High-Wort | EEPROM
39 | Reset-Schwellwert | Low-Wort | EEPROM
40 | Reset-Schwellwert | High-Wort | EEPROM

Impuls/Reset-Betrieb (RAM)

Register | Bedeutung | Ort | Speicher
0 | Einschalt-Schwellwert | Low-Wort | RAM
1 | Einschalt-Schwellwert | High-Wort | RAM
2 | Impulslänge | 1/64 µs/Digit | RAM
3 | - | - | -
4 | Reset-Schwellwert | Low-Wort | RAM
5 | Reset-Schwellwert | High-Wort | RAM

Impuls/Reset-Betrieb (EEPROM)

Register | Bedeutung | Ort | Speicher
35 | Einschalt-Schwellwert | Low-Wort | EEPROM
36 | Einschalt-Schwellwert | High-Wort | EEPROM
37 | - | - | -
38 | - | - | -
39 | Reset-Schwellwert | Low-Wort | EEPROM
40 | Reset-Schwellwert | High-Wort | EEPROM
41 | Impulslänge | 1/64 µs/Digit | EEPROM

Hinweise:

  • Beim Unterlauf der Zähler werden die Zählerstände nicht zurückgesetzt, d.h. das automatische Setzen der Zähler auf Null erfolgt nur, wenn der Reset-Wert von unten angelaufen wird.
  • Die folgenden Bereiche der Schwellwerte sind einzuhalten:
    Einschaltschwellwert < Ausschaltschwellwert < Reset-Schwelle
  • mögliche Impulslänge von 0,25 ms - 4000 ms
  • Beim Impulsbetrieb darf die Zählerbreite die Zählerlaufzeit nicht überschreiten:
    max. Impulslänge < Reset Schwelle/Zählerfrequenz


Funktionsweise IP/IE2512

Das Sonderfunktions-Modul IP/IE2512 moduliert ein binäres Signal. Dabei wird entweder die Frequenz oder Pulsweite/Impulslänge beeinflusst und kontinuierlich ausgegeben. es kann auch gezielt eine bestimmte Anzahl von Impulsen ausgegeben werden (Cnt_Cnt_PWM Modus).

Die Peripherieseite der Modulelektronik ist vom Feldbus, bzw. IP-Link galvanisch getrennt. Den Takt (Grundfrequenz) und das Puls-Pausenverhältnis können Sie über 16-Bit Werte im Prozessabbild der Steuerung vorgeben.
Das Modul IP/IE2512 belegt im Auslieferungszustand 6 Byte im Prozessabbild. Das Mapping der IP/IE2512 ist über die Steuerung oder mit der Konfigurationssoftware KS2000 einstellbar. Das IP/IE2512 kann neben der Betriebsart PWM (Pulsweitenmodulation), auch in der Betriebsart FM (Frequenz-Modulation) oder zur Schrittmotoransteuerung mit Puls- Richtungsvorgabe (Frq-Cnt-Impuls-Modus) betrieben werden. Die Defaulteinstellung des Moduls ist der PWM-Modus mit einer Grundfrequenz von 250 Hz und einer Auflösung von 10 Bit.

Das Modul wird temperaturüberwacht. Bei einer Übertemperatur werden die Ausgänge abgeschaltet, die rote Error LED am Ausgang wird gesetzt und ein Fehler-Bit im Status-Byte gesetzt!

Betriebsarten

Die verschiedenen Betriebsarten des Moduls werden über das Feature Register (R32) eingestellt. Drei Parameter sind beeinflussbar:

  • Pulsweiten-Verhältnis
  • Impulslänge
  • Frequenz (Periodendauer)

Je nach Betriebsart hängen diese Parameter voneinander ab!

Achtung | Es erfolgt keine Überwachung der jeweiligen Frequenzgrenzdaten! Werden in den Betriebsarten abweichende Frequenzen eingestellt, kann es u.U. zu Fehlfunktionen kommen!
Achtung | Bei Auswahl der Schrittmotorfunktion (Frq_Cnt_PWM, Frq_Cnt_Impuls, Cnt_Cnt_PWM) ist nur Kanal 1 nutzbar!

PWM-Modus (Frequenz im Register, Pulsweite über die Prozessdaten)

Im PWMH- und im PWML-Modus können zwei Kanäle betrieben werden. Dabei ist die Betriebsart und die Periodendauer für beide Kanäle identisch.

Das Verhältnis von Duty-Cycle zur Periodendauer wird über die Prozessdaten vorgegeben (100 % Einschaltdauer dem Prozessdatum 0x7FFF). Der Duty-Cycle ist das Verhältnis von eingeschaltetem Zustand zu ausgeschaltetem Zustand.

Über das Register R2 können Sie im laufenden Betrieb die Periodendauer also die Frequenz vorgeben. Dieses Register wird nach einem Systemstart automatisch aus dem Register R35 (SEEROM) geladen. Im R35 sollte also die Applikations-Default-Einstellung abgelegt werden.

oder

Es gibt zwei unterschiedliche PWM-Frequenzbereiche, die Sie über das Feature Register (R32) vorwählen können.

PWMH-Modus
Parameter | Speicherort
Periodendauer | R2 (R35)
DutyCycle | Prozessdaten

Der Frequenzbereich erstreckt sich von 1 kHz bis 80 KHz.

Die Periodendauer wird in R2 (R35) vorgegeben. 1 Digit = 0,25 µs. Achtung: dieser Wert weicht von der Einstellung der IP20 Klemme KL2502 ab!

Der Duty-Cycle wird über die Prozessdaten gewählt, 0x7FFF hex entspricht 100 % Duty-Cycle. 25 % sind demzufolge 0x1FFF hex.

PWML-Modus
Parameter | Speicherort
Periodendauer | R2 (R35)
DutyCycle | Prozessdaten

Der Frequenzbereich erstreckt sich von 8Hz bis 1 kHz .

Die Periodendauer wird in R2 (R35) vorgegeben. 1 Digit = 2µsec. Achtung: dieser Wert weicht von der Einstellung der IP20 Klemme KL2502 ab!

Der Duty-Cycle wird über die Prozessdaten gewählt, 0x7FFF hex entspricht 100 % Duty-Cycle. 25 % sind demzufolge 0x1FFF hex.

Frq-Cnt-PWM-Modus (Pulsweitenverhältnis im Register, Frequenz über die Prozessdaten)

Parameter | Speicherort
Puls-Weitenverhältnis | R36
Frequenz | Prozessdaten

Über die Prozessausgangsdaten der Steuerung wird die Frequenz in 8 Hz pro Digit vorgegeben. Die Steuerung erhält die Anzahl der von dem Modul ausgegebenen Perioden als Prozesseingangsdaten zurück. Die Zählrichtung wird in dieser Betriebsart über das Vorzeichen der Ausgangsdaten bestimmt:

  • 8 Hz entspricht hier dem Wert 0x0001
  • -8 Hz dem Wert 0xFFFF (signed Integer)

Der Frequenzbereich erstreckt sich von 8 Hz bis 8 kHz.

Die Impulse werden auf Ausgang OUTPUT, die Zählrichtung wird auf Ausgang UP/DOWN ausgegeben. Dabei entspricht:

  • aufsteigende Zählrichtung dem Pegel VCC
  • absteigende Zählrichtung dem Pegel GND

Mit steigender Flanke des Bit 0 im Control-Byte werden die Prozesseingangsdaten auf den Wert der Prozessausgangsdaten gesetzt (Prozessdatenbetrieb, d.h. Bit 7 des Control-Bytes ist 0).

Das Pulsweiten-Verhältnis wird über Register R36 festgelegt und bleibt konstant!

Änderungen werden erst nach dem Neustart des Moduls übernommen.

Frq-Cnt-Impuls-Modus (Pulslänge im Register, Frequenz über die Prozessdaten)

Parameter | Speicherort
Impulsbreite | R37
Frequenz | Prozessdaten

Über die Prozessausgangsdaten der Steuerung wird die Frequenz mit 8 Hz pro Digit vorgegeben. Die Steuerung erhält die Anzahl der von dem Modul ausgegebenen Impulse als Prozesseingangdaten zurück. Die Zählrichtung wird in dieser Betriebsart über das Vorzeichen der Ausgangsdaten bestimmt:

  • 8 Hz entspricht dem Wert 0x0001
  • -8 Hz entspricht dem Wert 0xFFFF (Signed Integer)

Der Frequenzbereich erstreckt sich von 8 Hz bis 8 kHz.

Die Impulse werden auf Ausgang OUTPUT, die Zählrichtung wird auf Ausgang UP/DOWN ausgegeben. Dabei entspricht:

  • aufsteigende Zählrichtung dem Pegel VCC
  • absteigende Zählrichtung dem Pegel GND

Mit steigender Flanke des Bit 0 im Control-Byte, werden die Prozesseingangsdaten auf den Wert der Prozessausgangsdaten gesetzt (Control-Byte im Prozessdatenbetrieb, d.h. Bit7=0). Die für alle Frequenzen feste Impulsbreite wird über R37 in 2 µs Schritten pro Digit festgelegt.

Änderungen werden erst nach dem Neustart des Moduls übernommen.

Cnt-Cnt-PWM-Modus (Pulsweitenverhältnis und Frequenz im Register, Impuls-Anzahl über die Prozessdaten)

Parameter | Speicherort
Puls-Weitenverhältnis | R36
Periodendauer | R35
Anzahl Impulse | Prozessdaten

Über die Prozessausgangsdaten wird die Anzahl der Impulse vorgegeben. Die Steuerung erhält die Anzahl der ausgegebenen Perioden als Prozesseingangsdaten zurück. Dabei wird das

  • Pulsweitenverhältnis über Register R36 und die
  • Periodendauer über Register R35 festgelegt (1 Digit = 0,25 µs).

Der Frequenzbereich erstreckt sich von 1 kHz bis 32 kHz.

Eine positiven Flanke des Bit 0 im Control-Byte startet die Pulsausgabe. Mit jeder weiteren Flanke kann diese nachgetriggert werden. Die Impulse werden auf Ausgang OUTPUT ausgegeben. Ausgang UP/DOWN kann über Bit 2 des Control-Bytes gesetzt werden.

Als Status-Information erhält die Steuerung in Bit 0 des Status-Bytes die Übernahme und den gleichzeitigen Start der Impulsausgabe zurück. Bit 1 des Status-Bytes bleibt solange gesetzt, wie die Ausgabe aktiv ist. Bit 2 des Status-Bytes meldet den Zustand von Kanal 1 zurück.

Pulsweiten-Verhältnis in den Prozessdaten

Eingabeformat: Darstellung im Zweier-Komplement (der Integer-Wert "-1" wird als 0xFFFF dargestellt).
Das Verhältnis von Duty-Cycle/Periodendauer wird mit einer maximalen Auflösung von 10 Bit vorgegeben.

Prozessdatum | Ausgabewert
0x0000 | 0 % Duty-Cycle
0x3FFF | 50 % Duty-Cycle
0x7FFF | 100 % Duty-Cycle


Ausgangsleistung (Derating), IP/IE2512

Beim Einsatz der PWM-Module ist die Verlustleistung innerhalb des Moduls zu berücksichtigen.

Die maximale Stromstärke für den stark induktiven Grenzfall, z.B. beim Einsatz von Proportional-Ventilen wird in der folgenden Grafik angegeben.

Im stark ohmschen Grenzfall verläuft die Linie horizontal bei 2,5 A, unabhängig von der Frequenz.

Stromstärke in Abhängigkeit vom Duty Cycle (Tastverhältnis)

Achtung Bei Modulen mit Hardwarestand D.xxxxxx00 (siehe Hard-Softwarestände) ist ein anderes Derating zu berücksichtigen.


Control- und Status-Byte IP/IE2512

Prozessdatenbetrieb

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | 0 | 0 | 0 | 0 | 0 | 0 | StartPulses

Name | Beschreibung
RegAccess | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
StartPulses | Im Cnt_Cnt_PWM Modus startet eine positiven Flanke dieses Bits die Pulsausgabe. Mit jeder weiteren positiven Flanke kann diese nachgetriggert werden.

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | ERROR | OVR_TEMP_ERR | - | 0 | StateCh1 | OUT | StartPulses

Name | Beschreibung
RegAccess | 0bin: Quittung für Prozessdatenbetrieb
ERROR | 0bin: allgemeines Fehlerbit, Fehler liegt vor
OVR_TEMP_ERR | 0bin: kein Fehler
 | 1bin: Übertemperatur im Modul, die Ausgänge werden ausgeschaltet.
StateCh1 | Im Cnt_Cnt_PWM Modus wird der Zustand den von Kanal 1 zurückgemeldet.
OUT | Im Cnt_Cnt_PWM Modus wird der Status des Ausgangs eingeblendet (1bin: Write).
StartPulses | Im Cnt_Cnt_PWM Modus wird der Status von Bit 0 des des Control-Bytes eingeblendet.

Register-Kommunikation

Während der Register-Kommunikation können keine Zählerwerte übertragen werden.

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Registerkommunikation eingeschaltet
R/W | 0bin: Read 1bin: Write
Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Quittung für Registerzugriff
R/W | 0bin: Read
Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht IP/IE2512

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | reserviert | 0x0000 | R | RAM
R1 | reserviert | 0x0000 | R | RAM
R2 | Periodendauer | variabel | R/W | RAM
R3 | Grundfrequenz | variabel | R/W | RAM
R4 | reserviert | variabel | R/W | RAM
R5 | PWM-Rohwert | variabel | R/W | RAM
R6 | Diagnose-Register - nicht benutzt | 0x0000 | R | RAM
R7 | Kommandoregister - nicht benutzt | 0x0000 | R | RAM
R8 | Modultyp | 2512dec | R | ROM
R9 | Software Versionsnummer | 0xXXXX | R | ROM
R10 | Multiplex-Schieberegister | 0x0218 | R | ROM
R11 | Signalkanäle | 0x0218 | R | ROM
R12 | minimale Datenlänge | 0x1818 | R | ROM
R13 | Datenstruktur | 0x0000 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Register | variable | R/W | RAM
R16 | Hardware Versionsnummer | 0xXXXX | R/W | SEEROM
R17 | reserviert | 0x0000 | R/W |
R18 | reserviert | 0x0000 | R/W |
R19 | Hersteller Skalierung: Offset | 0x0000 | R/W |
R20 | Hersteller Skalierung: Gain | 0x0000 | R/W |
R21 | reserviert | 0x0000 | R/W |
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W |
R31 | Codeword-Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0004 | R/W | SEEROM
R33 | Anwender-Offset | 0x0000 | R/W | SEEROM
R34 | Anwender-Gain | 0x0100 | R/W | SEEROM
R35 | Periodendauer PWM | 0x0FA0 | R/W | SEEROM
R36 | Duty-Cycle | 0x0000 | R/W | SEEROM
R37 | Impulsdauer | 0x0000 | R/W | SEEROM
R38 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R/W | SEEROM


Feature-Register (R32) IP/IE2512

Mit dem Feature-Register können Sie die grundlegenden Einstellungen des Moduls vorgeben. Um das Register zu beschreiben zu können, müssen Sie zuvor mit dem Codewort-Register den Schreibschutz aufheben.

Default 0x0004

Bit | Wert | Beschreibung |  | default
0 | 0bin | Anwender-Skalierung nicht aktiv |  | 0bin
 | 1bin | Anwender-Skalierung aktiv
1 | 0bin | Hersteller-Skalierung nicht aktiv |  | 0bin
 | 1bin | Hersteller-Skalierung aktiv
2 | 0bin | Watchdog nicht aktiv |  | 1bin
 | 1bin | Watchdog aktiv Empfängt die Klemme 100 ms keine Daten, so wird das PWM-Signal auf 0% Einschaltdauer gesetzt.
12 - 3 | reserviert |  |  | 0
15 - 13 |  | Betriebsart | Frequenzbereich | 000bin
 | 000bin | PWMH-Modus | 1 kHz bis 80 kHz
 | 001bin | PWML-Modus | 8 Hz bis 1 kHz
 | 011bin | Frq-Cnt-PWM-Modus | 8 Hz bis 8 kHz
 | 101bin | Frq-Cnt-Impuls-Modus | 8Hz bis 8 kHz
 | 111bin | Cnt-Cnt-PWM-Modus | 1 kHz bis 32 kHz


Funktionsweise IE2808

Das Ausgangsmodul IE2808 besitzt 16 Ausgänge mit einer Strombelastbarkeit von je 0,5 A. Der Gesamtstrom des Moduls darf maximal 4,0 A betragen.

Fehleranzeige

Jeder Kanal ist individuell diagnostizierbar, d.h. im Fehlerfall wird für diesen Kanal ein Fehlerbit im Prozessdaten-Eingangsbereich gesetzt.

Für das IE2808-0000 muss dieses Fehlerbit durch Setzen eines Bits im Control-Byte manuell zurückgesetzt werden.
Für das IE2808-0001 wird dieses Fehlerbit nach Beseitigung des Fehlers automatisch zurück gesetzt.

LEDs

Das Modul verfügt über 4 LEDs. Us und Up zeigen das Vorhandensein der Spannungsversorgung für Logik bzw. die Ausgänge an.

ERR 1-8 und ERR 9-16 zeigen gruppenweise den Zustand der Ausgänge an.

LED | Grün | Rot
ERR 1-8 | mindestens ein Ausgang der Gruppe 1-8 ist geschaltet | mindestens ein Ausgang der Gruppe 1-8 hat einen Kurzschluss
ERR 9-16 | mindestens ein Ausgang der Gruppe 9-16 ist geschaltet | mindestens ein Ausgang der Gruppe 9-16 hat einen Kurzschluss


Control- und Status-Byte IE2808

Prozessdatenbetrieb

Control-Byte

Das Control-Byte (CB) ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | ResetErr | SetDefaultStatus | - | - | - | - | -

Bit | Name | Beschreibung
CB.7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CB.6 | ResetErr | 1bin | Setzt im Status-Byte angezeigte Fehler zurück.
CB.5 | SetDefaultStatus | 1bin | Setzt Ausgänge auf den mit Register R33 vorgegebenen Default-Status
CB.4 | - | 0bin | reserviert
... | ... | ... | ...
CB.0 | - | 0bin | reserviert

Status-Byte

Das Status-Byte (SB) ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | UnderVoltage | OvrCurrentGrp2 | OvrCurrentGrp1 | - | DefaultStatus | -

Bit | Name | Beschreibung
SB.7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
SB.6 | Error | 0bin | allgemeines Fehlerbit: kein Fehler aufgetreten
 |  | 1bin | allgemeines Fehlerbit: Fehler aufgetreten
SB.5 | UnderVoltage | 0bin | Lastspannung UL ≥ 18 V
 |  | 1bin | Lastspannung UL < 18 V, UL-LED leuchtet rot, die Ausgänge bleiben aber geschaltet
SB.4 | OvrCurrentGrp2 | 0bin | kein Fehler
 |  | 1bin | Kurzschluss an einem Ausgang der Gruppe 2. Der betroffene Ausgang wird im Eingangs-Byte Diag2 angezeigt. Diese Fehleranzeige muss nach Behebung durch Bit CB.6 des Control-Bytes zurückgesetzt werden!
SB.3 | OvrCurrentGrp1 | 0bin | kein Fehler
 |  | 1bin | Kurzschluss an einem Ausgang der Gruppe 1. Der betroffene Ausgang wird im Eingangs-Byte Diag1 angezeigt. Diese Fehleranzeige muss nach Behebung durch Bit CB.6 des Control-Bytes zurückgesetzt werden!
SB.2 | - | 0bin | reserviert
SB.1 | DefaultStatus | 0bin | Ausgänge in Betrieb
 |  | 1bin | Ausgänge haben den in Register R33 definierten Default-Status angenommen
SB.0 | - | 0bin | reserviert

Register-Kommunikation

Control-Byte

Das Control-Byte (CB) ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Registernummer

Bit | Name | Beschreibung
CB.7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
CB.6 | R/W | 0bin | Read
 |  | 1bin | Write
CB.5 - CB.0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte (SB) ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Registernummer

Bit | Name | Beschreibung
SB.7 | RegAccess | 1bin | Quittung für Registerzugriff
SB.6 | R/W | 0bin | Read
SB.5 - SB.0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht IE2808

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | reserviert | 0x0000 | R/W | RAM
... | ... | ... | ... | ...
R5 | reserviert | 0x0000 | R/W | RAM
R6 | Diagnose-Register - nicht benutzt | 0x0000 | R | RAM
R7 | Kommandoregister - nicht benutzt | 0x0000 | R | RAM
R8 | Modultyp | 2808dez | R | ROM
R9 | Firmware Versionsnummer | z.B. 0x3142 | R | ROM
R10 | Multiplex-Schieberegister | 0x0118 | R | ROM
R11 | Signalkanäle | 0x0118 | R | ROM
R12 | minimale Datenlänge | 0x9898 | R | ROM
R13 | Datenstruktur | 0x0001 | R | ROM
R14 | reserviert | 0x0000 | R/W | RAM
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W | RAM
R31 | Code-Wort-Register | variabel | R/W | RAM
R32 | Enable-Defaultstatus-Register | 0xFFFF | R/W | SEEROM
R33 | Defaultstatus-Register | 0x0000 | R/W | SEEROM
R34 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R/W | SEEROM


IE2808 Watchdog-Feature (R32-R33)

BECKHOFF Feldbus Box: Konfiguration

Watchdog-Feature (R32-R33) IE2808

Über das Enable-Defaultstatus-Register R32 und das Defaultstatus-Register R33 kann das Verhalten der Ausgänge im Fall eines Kommunikationsausfalls festgelegt werden.

  • Register R32 aktiviert oder deaktiviert das Watchdog-Feature.
  • Register R33 definiert für jeden einzelnen Kanal den Schaltzustand seines Ausgangs im Fehlerfall (wenn Watchdog aktiviert wurde).

Zum Ändern der Register muss zunächst der Schreibschutz aufgehoben werden. Dies geschieht durch Schreiben des Anwender-Code-Worts (0x1235) in das Register R31.

Achtung Beachten Sie bei Nutzung des Watchdog-Features, dass beim Einschalten des Systems keine Kommunikationsverbindung besteht, d.h. die Ausgänge werden auf die vordefinierten Wert egesetzt.
Register | Beschreibung | Ausgang | Beschreibung | Default
32 | Watchdog aktiv | 00 - 15 | 1 = aktiviert; 0 = deaktiviert | 0xFFFF
Register | Beschreibung | Ausgang | Beschreibung | Default
33 | Output State | 00 - 15 | 1 = ON; 0 = OFF | 0x0000

In Auslieferungszustand ist der Watchdog aktiviert und die vordefinierten Ausgangs-Stati sind auf 0 gesetzt. Alle Ausgänge werden also im Fehlerfall ausgeschaltet!

Beispiel

Register 32 = 1111 1111 1111 1111
Register 33 = 1000 0000 0000 0000
Prozessdaten von der übergeordneten Steuerung = ON für alle Ausgänge

Bei einer Kommunikationsunterbrechung werden nun alle Ausgänge, außer Ausgang 16, auf OFF gesetzt. Ausgang 16 wird auf ON gesetzt.


Defaultstatus-Register (R33) IE2808

Das Defaultstatus-Register legt legt für jeden einzelnen Ausgang den Defaultstatus für den Kommunikationsfehlerfall fest.

Bit | Wert | Beschreibung | Hersteller- einstellung
0 | 0bin | Defaultstatus für Ausgang 1 ist AUS | 0bin
 | 1bin | Defaultstatus für Ausgang 1 ist EIN
1 | 0bin | Defaultstatus für Ausgang 2 ist AUS | 0bin
 | 1bin | Defaultstatus für Ausgang 2 ist EIN
... | 0bin | ... | 0bin
 | 1bin | ...
15 | 0bin | Defaultstatus für Ausgang 16 ist AUS | 0bin
 | 1bin | Defaultstatus für Ausgang 16 ist EIN


Enable-Defaultstatus-Register (R32) IE2808

Das Enable-Defaultstatus-Register legt legt für jeden einzelnen Ausgang fest, ob dieser im Kommunikationsfehlerfall auf den für Ihn im Register R33 festgelegten Default-Wert gesetzt wird.

Bit | Wert | Beschreibung | Hersteller- einstellung
0 | 0bin | Defaultstatus für Ausgang 1 gesperrt | 0bin
 | 1bin | Defaultstatus für Ausgang 1 freigegeben
1 | 0bin | Defaultstatus für Ausgang 2 gesperrt | 0bin
 | 1bin | Defaultstatus für Ausgang 3 freigegeben
... | 0bin | ... | 0bin
 | 1bin | ...
15 | 0bin | Defaultstatus für Ausgang 16 gesperrt | 0bin
 | 1bin | Defaultstatus für Ausgang 16 freigegeben


Funktionsweise IP/IE3102

Das analoge Eingangsmodul verarbeitet Signale von -10 V bis 10 V mit einer Auflösung von 16 Bit. Die Filterkonstanten und die damit verbundenen Wandlungszeiten sind in weiten Bereichen einstellbar.

Prozessdaten (hex) | Prozessdaten (dezimal) | Messwert
0x8000 | -32768 | -10 V
0xC001 | -16383 | - 5 V
0x0000 | 0 | 0 V
0x3FFF | 16383 | 5 V
0x7FFF | 32767 | 10 V

Die Darstellung entspricht dem Zahlenformat Integer (INT) . Die Prozessdaten werden in der Default-Einstellung im Zweierkomplement eingegeben (-1 entspricht 0xFFFF).

Prozessdaten

Die Prozessdaten, die die Steuerung schreibt, werden wie folgt ausgegeben:
x_adc = Ausgabe Wert des A/D Wandlers
y_aus = Prozessdaten zur PLC Steuerung
B_a, A_a = Hersteller Skalierung (Register 17, 18)
B_h, A_h = Hersteller Skalierung (Register 19, 20)
B_w, A_w = Anwender Skalierung (Register 33, 34)
Y_dac = Ausgabewert zum D/A Wandler

weder Anwender noch Herstellerskalierung aktiv

Y_a = (B_a + x_adc)*A_a
Y_aus = Y_a

Herstellerskalierung aktiv (Default)

Y_1 = B_h + A_h * Y_a
Y_aus = Y_1

Anwenderskalierung aktiv

Y_2 = B_w + A_w * Y_a
Y_aus = Y_2

Hersteller- und Anwenderskalierung aktiv

Y_1 = B_h + A_h *Y_a
Y_2 = B_w + A_w * Y_1
Y-aus = Y_2

Die Gradengleichungen werden über Register 32 aktiviert.

Ersatzschaltbild


Control- und Status-Byte IP/IE3102

Prozessdatenbetrieb

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | -

Legende:

Bit | Name | Beschreibung
7 | RegAccess | 0bin | Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
6...0 | - | reserviert

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | Error | Grenzwert 2 |  | Grenzwert 1 |  | Over-Range | Under-Range

Legende:

Bit | Name | Beschreibung
7 | RegAccess | 0bin | Quittung für Prozessdatenbetrieb
6 | Error | allgemeines Fehlerbit
5,4 | Grenzwert 2 | 00bin: | Grenzwert 2 nicht aktiv
 |  | 01bin | Prozessdaten > Grenzwert 2
 |  | 10bin | Prozessdaten < Grenzwert 2
 |  | 11bin | Prozessdaten = Grenzwert 2
3,2 | Grenzwert 1 | 00bin: | Grenzwert 1 nicht aktiv
 |  | 01bin | Prozessdaten > Grenzwert 1
 |  | 10bin | Prozessdaten < Grenzwert 1
 |  | 11bin | Prozessdaten = Grenzwert 1
1 | Over-Range | 1bin | wenn R32.4 = 0: Messbereich überschritten (>0x7FFF)
 |  |  | wenn R32.4 = 1: Messwert ≥ 10,5 V
0 | Under-Range | 1bin | wenn R32.4 = 0: Messbereich unterschritten (>0x8000)
 |  |  | wenn R32.4 = 1: Messwert ≤ -10,5 V
Hinweis

Um den Over/Under-Range Bereich zu ändern muss die Anwenderskalierung geändert werden. Beispiel:
Sie wollen einen Overrange von 10,6 V einstellen. Dazu müssen Sie die Anwenderskalierung aktivieren und den Gain in Register 34 auf 0x00F0 ändern. Der Messbereich geht nun bis 10,6 V (maximal bis 11,8 V möglich).

Register-Kommunikation

Während der Register-Kommunikation sind keine Messwerte übertragbar.

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Legende:

Bit | Name | Beschreibung
7 | RegAccess | 1bin | Registerkommunikation eingeschaltet
6 | R/W | 0bin | Read
 |  | 1bin | Write
5...0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Legende:

Bit | Name | Beschreibung
7 | RegAccess | 1bin | Quittung für Registerzugriff
6 | R/W | 0bin | Read
5...0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht IP/IE3102

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | ADC-Rohwert | variabel | R | RAM
R1 | reserviert | 0x0000 | R |
... | ... | ... | ... | ...
R7 | reserviert | 0x0000 | R |
R8 | Modul Typ | 3102dec | R | ROM
R9 | Software-Version | 0xXXXX | R | ROM
R10 | Multiplex-Schieberegister | 0x0418 | R | ROM
R11 | Signalkanäle | 0x0418 | R | ROM
R12 | minimale Datenlänge | 0x0098 | R | ROM
R13 | Datenstruktur | 0x0004 | R | ROM
R14 | nicht benutzt | 0x0000 | R |
R15 | Alignment-Regiser | variable | R/W | RAM
R16 | Hardware-Versionsnummer | 0xXXXX | R/W | SEEROM
R17 | Hardware-Abgleich: Offset | spezifisch | R/W | SEEROM
R18 | Hardware-Abgleich: Gain | spezifisch | R/W | SEEROM
R19 | Hersteller Skalierung: Offset | 0x0000 | R/W | SEEROM
R20 | Hersteller Skalierung: Gain | 0x0100 | R/W | SEEROM
R21 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W | SEEROM
R31 | Codeword-Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0010 | R/W | SEEROM
R33 | Anwender-Offset | 0x0000 | R/W | SEEROM
R34 | Anwender-Gain | 0x0100 | R/W | SEEROM
R35 | Grenzwert 1 | 0x0000 | R/W | SEEROM
R36 | Grenzwert 2 | 0x0000 | R/W | SEEROM
R37 | Filter-Register | 0x3200 | R/W | SEEROM
R38 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R/W | SEEROM


Feature-Register (R32) IP/IE3102

Im Feature-Register können die grundlegenden Einstellungen des Moduls verändert werden. Um das Register zu beschreiben muss im Codewort-Register erst der Schreibschutz aufgehoben werden.
Default [0x0010]

Bit | Wert | Beschreibung | Hersteller- einstellung
0 | 0bin | Anwender-Skalierung inaktiv | 0bin
 | 1bin | Anwender-Skalierung aktiv
1 | 0bin | Hersteller-Skalierung inaktiv | 0bin
 | 1bin | Hersteller-Skalierung aktiv
2 | 0bin | reserviert | 0bin
3 | 0bin | Betragsvorzeichendarstellung inaktiv | 0bin
 | 1bin | Betragsvorzeichendarstellung aktiv (-1 = 0x8001)
4 | 0bin | Overflow-Offset inaktiv: Die Prozessdaten werden auf größer 0x7FFF (oder 0xFFFF je nach Hersteller-Skalierung) überwacht und das Ergebnis wird im Status-Byte angezeigt. | 1bin
 | 1bin | Overflow-Offset aktiv Der Messwert (die tatsächliche Spannung) wird überwacht und das Ergebnis wird im Status-Byte angezeigt.
5 | 0bin | reserviert | 0bin
... | ... | ... | ...
8 | 0bin | reserviert | 0bin
9 | 0bin | Grenzwert 1 inaktiv | 0bin
 | 1bin | Grenzwert 1 aktiv (der Grenzwert 1 wird in Register R35 festgelegt)
10 | 0bin | Grenzwert 2 inaktiv | 0bin
 | 1bin | Grenzwert 2 aktiv (der Grenzwert 2 wird in Register R36 festgelegt)
11 | 0bin | reserviert | 0bin
... | ... | ... | ...
15 | 0bin | reserviert | 0bin


Filter-Register (R37) IP/IE3102

Die IP/IE3102 besitzen zwei Tiefpass Filterstufen. Die erste Stufe besteht aus einem sinc³ Filter. Diese ist immer aktiv. Die zweite besteht aus einem FIR-Filter 22. Ordnung, welches deaktiviert werden kann. Die Filtereinstellungen gelten immer für alle Kanäle und werden im ersten Register des Kanal 1 eingestellt. Die Einstellungen sind erst nach einem Power-On Reset (Feldbus Box aus und wieder einschalten) wirksam.

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | SF11 | SF10 | SF9 | SF8 | SF7 | SF6 | SF5 | SF4 | SF3 | SF2 | SF1 | SF0 | 0 | 0 | SKIP | Fast
FAST

0 - Inaktiv
1 - Aktiv
Bei Aktivierung folgt eine schnelle Reaktion auf Sprünge am Eingang (trotz aktivierter 2. Filterstufe), der Filter wird für die nächsten & A/D Wandlungen umgangen und der Wert gemittelt.

SKIP

0 - FIR Filter aktiv
1 - FIR Filter wird umgangen. Bei aktiviertem SKIP Modus ist der FAST Modus irrelevant.

Bit 2, 3

müssen Null sein.

SF0-11

Dies ist die eigentliche Filterkonstante. Diese legt die 3dB Grenzfrequenz des sinc³ Filter fest. Der Wertebereich erstreckt sich von 150 - 2047. Die 3 dB Grenzfrequenz bzw. die 64,5 dB Stopfrequenz Fstop sind in der folgenden Tabelle aufgelistet und werden wie folgt berechnet:

SKIP = 0
SF = 11981/ FGrenz
SF = 43008/ Fstop

SKIP = 1
SF = 80486/ FGrenz

Beispiel: Sie wollen eine Grenzfrequenz von 75 Hz einstellen
SF = 11981/ FGrenz = 11981/75 = 160dez » 0000_1010_0000 bin + Low-Byte = 0000_1010_0000_0000bin = 0x0A00

Default-Registereinstellung ist 0x35C0.

 | Register 37 | Fstop [Hz] | FGrenz [Hz] | Zykluszeit [ms]
SKIP =0 Fast = 0 | 0x0A00 | 270 | 75 | 50
 | 0x1400 | 135 | 38 | 100
 | 0x1E00 | 90 | 25 | 150
 | 0x2800 | 68 | 19 | 200
 | 0x3200 | 54 | 15 | 250
SKIP = 0 Fast =1 | 0x0781 |  |  | 5
 | 0x0F01 |  |  | 10
 | 0x1681 |  |  | 15
 | 0x1E01 |  |  | 20
 | 0x2581 |  |  | 25
SKIP = 1 Fast = x | 0x0782 |  | 671 | 5
 | 0x0F02 |  | 335 | 10
 | 0x1682 |  | 224 | 15
 | 0x1E02 |  | 168 | 20
 | 0x2582 |  | 134 | 15


Funktionsweise IP/IE3112

Das analoge Eingangsmodul verarbeitet Signale von 0 bis 20 mA mit einer Auflösung von 16 Bit. Die Filterkonstanten und die damit verbundenen Wandlungszeiten sind in weiten Bereichen einstellbar.

Prozessdaten (hex) | Prozessdaten (dezimal) | Messwert
0x0000 | 0 | 0 mA
0x3FFF | 16383 | 10 mA
0x7FFF | 32767 | 20 mA

Ab der Softwareversion [IP3112-Bxxx "3"; IE3112 "0"] (siehe Anhang) kann im Register 32 (Bit 5= 1) auch der Bereich von 4..20 mA eingestellt werden. Diese Einstellung im Feature-Register (R32) können für jeden Kanal separat angewählt werden.

Prozessdaten (hex) | Prozessdaten (dezimal) | Messwert
0x0000 | 0 | 4 mA
0x3FFF | 16383 | 12 mA
0x7FFF | 32767 | 20 mA

Die Darstellung entspricht dem INT (Integer) Zahlenformat. Die Prozessdaten werden in der Default-Einstellung im 2er Complement eingegeben (-1 entspricht 0xFFFF).

Prozessdaten

Die Prozessdaten, die die Steuerung schreibt, werden wie folgt ausgegeben:
x_adc = Ausgabe Wert des A/D Wandlers
y_aus = Prozessdaten zur PLC Steuerung
B_a, A_a = Hersteller Skalierung (Register 17, 18)
B_h, A_h = Hersteller Skalierung (Register 19, 20)
B_w, A_w = Anwender Skalierung (Register 33, 34)
Y_dac = Ausgabewert zum D/A Wandler

weder Anwender noch Herstellerskalierung aktiv

Y_a = (B_a + x_adc)*A_a
Y_aus = Y_a

Herstellerskalierung aktiv (Default)

Y_1 = B_h + A_h * Y_a
Y_aus = Y_1

Anwenderskalierung aktiv

Y_2 = B_w + A_w * Y_a
Y_aus = Y_2

Hersteller- und Anwenderskalierung aktiv

Y_1 = B_h + A_h *Y_a
Y_2 = B_w + A_w * Y_1
Y-aus = Y_2

Die Gradengleichungen werden über Register 32 aktiviert.

Ersatzschaltplan


Control- und Status-Byte IP/IE3112

Prozessdatenbetrieb

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserviert

Name | Beschreibung
RegAccess | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | Error | Grenzwert 2 |  | Grenzwert 1 |  | Over-Range | Under-Range

Name | Beschreibung
RegAccess | 0bin: Quittung für Prozessdatenbetrieb
Error | allgemeines Fehlerbit (Messwert >21 mA, bzw. <3mA (4...20mA Modus)
Grenzwert 2 Grenzwert 1 | 00bin: Grenzwert nicht aktiv 10bin: Prozessdaten < Grenzwert 01bin: Prozessdaten > Grenzwert 11bin: Prozessdaten = Grenzwert
Over-Range | R32 Bit 4 = 0 Messbereich überschritten >0x7FFF bzw. 0xFFFF | R32 Bit 4 = 1 Messwert > 20 mA
Under-Range | R32 Bit 4 = 0 und R32 Bit 5 = 0 keine Funktion | R32 Bit 4 = 1 und R32 Bit 5 = 1 Messwert < 4 mA

Register-Kommunikation

Während der Register-Kommunikation sind keine Messwerte übertragbar.

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Registerkommunikation eingeschaltet
R/W | 0bin: Read 1bin: Write
Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild der Feldbus Box und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Quittung für Registerzugriff
R/W | 0bin: Read
Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht IP/IE3112

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | ADC-Rohwert | variabel | R | RAM
R1 | reserviert | 0x0000 | R |
... | ... | ... | ... | ...
R7 | reserviert | 0x0000 | R |
R8 | Modul Typ | 0x0C28 (3112dec) | R | ROM
R9 | Software-Version | 0xXXXX | R | ROM
R10 | Multiplex-Schieberegister | 0x0418 | R | ROM
R11 | Signalkanäle | 0x0418 | R | ROM
R12 | minimale Datenlänge | 0x0098 | R | ROM
R13 | Datenstruktur | 0x0004 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Register | variable | R/W | RAM
R16 | Hardware-Versionsnummer | 0xXXXX | R/W | EEPROM
R17 | Hardware-Abgleich: Offset | spezifisch | R/W | EEPROM
R18 | Hardware-Abgleich: Gain | spezifisch | R/W | EEPROM
R19 | Hersteller-Skalierung: Offset | 0x0000 | R/W | EEPROM
R20 | Hersteller-Skalierung: Gain | 0x0080 | R/W | EEPROM
R21 | reserviert | 0x0000 | R/W |
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W |
R31 | Codeword Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0012 | R/W | EEPROM
R33 | Anwender-Offset | 0x0000 | R/W | EEPROM
R34 | Anwender-Gain | 0x0100 | R/W | EEPROM
R35 | Grenzwert 1 | 0x0000 | R/W | EEPROM
R36 | Grenzwert 2 | 0x0000 | R/W | EEPROM
R37 | Filter-Register | 0x3200 | R/W | EEPROM
R38 | reserviert | 0x0000 | R/W |
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R/W |


Feature-Register (R32) IP/IE3112

Im Feature-Register können die grundlegenden Einstellungen des Moduls verändert werden. Um das Register zu beschreiben muss im Codewort-Register erst der Schreibschutz aufgehoben werden.
Default [0x0012]

Bit | Wert | Beschreibung | Hersteller- einstellung
0 | 0bin | Anwender-Skalierung inaktiv | 0bin
 | 1bin | Anwender-Skalierung aktiv
1 | 0bin | Hersteller-Skalierung inaktiv | 1bin
 | 1bin | Hersteller-Skalierung aktiv
2 | 0bin | reserviert | 0bin
3 | 0bin | Betragsvorzeichendarstellung inaktiv | 0bin
 | 1bin | Betragsvorzeichendarstellung aktiv (-1 = 0x8001)
4 | 0bin | Overflow-Offset inaktiv | 1bin
 | 1bin | Overflow-Offset aktiv
5 )1 | 0bin | 0..20 mA Modus | 0bin
 | 1bin | 4..20 mA Modus
6 | 0bin | reserviert | 0bin
... | ... | ... | ...
8 | 0bin | reserviert | 0bin
9 | 0bin | Grenzwert 1 inaktiv | 0bin
 | 1bin | Grenzwert 1 aktiv (R35)
10 | 0bin | Grenzwert 2 inaktiv | 0bin
 | 1bin | Grenzwert 2 aktiv (R36)
11 | 0bin | reserviert | 0bin
... | ... | ... | ...
15 | 0bin | reserviert | 0bin

Overflow-Offset

Ist dieses Bit gesetzt, wird der Messwert (der tatsächliche Strom) überwacht und im Status-Byte angezeigt.
Ist dieses Bit nicht gesetzt, so werden die Prozessdaten auf größer 0x7FFF (oder 0xFFFF je nach Hersteller Skalierung) im Status-Byte angezeigt.

)1 ab Software-Version der E/A Platine IP3112-Bxxx "3" IE3112 "0"


Filter-Register (R37) IP/IE3112

Die IP/IE3112 besitzen zwei Tiefpass-Filterstufen. Die erste Stufe besteht aus einem sinc³ Filter. Diese ist immer aktiv. Die zweite besteht aus einem FIR-Filter 22. Ordnung, welches deaktiviert werden kann. Die Filtereinstellungen gelten immer für alle Kanäle und werden im ersten Register des Kanal 1 eingestellt. Die Einstellungen sind erst nach einem Power-On-Reset (Feldbus Box aus und wieder einschalten) wirksam.

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | SF11 | SF10 | SF9 | SF8 | SF7 | SF6 | SF5 | SF4 | SF3 | SF2 | SF1 | SF0 | 0 | 0 | SKIP | Fast
FAST

0 - Inaktiv
1 - Aktiv
Bei Aktivierung folgt eine schnelle Reaktion auf Sprünge am Eingang (trotz aktivierter 2. Filterstufe), der Filter wird für die nächsten & A/D Wandlungen umgangen und der Wert gemittelt.

SKIP

0 - FIR Filter aktiv
1 - FIR Filter wird umgangen. Bei aktiviertem SKIP Modus ist der FAST Modus irrelevant.

Bit 2, 3

müssen Null sein.

SF0-11

Dies ist die eigentliche Filterkonstante. Diese legt die 3dB Grenzfrequenz des sinc³ Filter fest. Der Wertebereich erstreckt sich von 150 - 2047.
Die 3 dB Grenzfrequenz bzw. die 64,5 dB Stopfrequenz Fstop sind in der folgenden Tabelle aufgelistet und werden wie folgt berechnet:

SKIP = 0
SF = 11981/ FGrenz
SF = 43008/ Fstop

SKIP = 1
SF = 80486/ FGrenz

Beispiel
Sie wollen eine Grenzfrequenz von 75 Hz einstellen:
SF=11981/ FGrenz = 11981/75 = 160dez » 0000_1010_0000bin + LowByte = 0000_1010_0000_0000 = 0x0A00

Defaultregistereinstellung ist 0x3200.

 | Register 37 | Fstop [Hz] | FGrenz [Hz] | Zykluszeit [ms]
SKIP =0 Fast = 0 | 0x0A00 | 270 | 75 | 50
 | 0x1400 | 135 | 38 | 100
 | 0x1E00 | 90 | 25 | 150
 | 0x2800 | 68 | 19 | 200
 | 0x3200 | 54 | 15 | 250
SKIP = 0 Fast =1 | 0x0781 |  |  | 5
 | 0x0F01 |  |  | 10
 | 0x1681 |  |  | 15
 | 0x1E01 |  |  | 20
 | 0x2581 |  |  | 25
SKIP = 1 Fast = x | 0x0782 |  | 671 | 5
 | 0x0F02 |  | 335 | 10
 | 0x1682 |  | 224 | 15
 | 0x1E02 |  | 168 | 20
 | 0x2582 |  | 134 | 15


Funktionsweise IP/IE3202

Das analoge Eingangsmodul IP3202-Bxxx bzw. IE3202 erlaubt den direkten Anschluss von vier Widerstandssensoren. Die Widerstandssensoren können in 2, 3 oder 4 Leiteranschlusstechnik betrieben werden. Die Umrechnung und Linearisierung des Widerstandswertes in eine Temperatur erfolgt durch einen Mikro-Controller in dem Modul.

Temperaturen werden in 1/10°C (1 Digit = 0,1°C) ausgegeben. Darüber hinaus wird ein Drahtbruch bzw. Kurzschluss an den Slave bzw. an die Steuerung gemeldet und durch die Error-LED angezeigt.

Als Widerstandssensoren sind die Elemente PT100, NI100, PT200, PT500, NI120, NI1000 und PT1000 über ihren kompletten Messbereich implementiert. Das Modul ist über einen Feldbus vollständig konfigurierbar, so kann z.B. eine selbstdefinierte Skalierung der Ausgabe erfolgen, oder es kann die Temperaturumrechnung abgeschaltet werden. In diesem Fall erfolgt die Ausgabe des Messwerts in einem Bereich von 10 Ohm bis 1,2/5,0 kOhm mit einer Auflösung von 1/10 bzw. 1/2 Ohm (Die interne Auflösung des Widerstandswertes beträgt 1/255 Ohm).

Ausgabeformat der Prozessdaten

Prozessdaten (hex) | Prozessdaten Dezimal (integer) | Messwert
0xF63C | -2500 | -250°C
0xF830 | -2000 | -200°C
0xFC18 | -1000 | -100°C
0xFFFF | -1 | -0,1°C
0x0000 | 0 | 0,0°C
0x0001 | 1 | 0,1°C
0x02E8 | 1000 | 100°C
0x07D0 | 2000 | 200°C
0x1388 | 5000 | 500°C
0x2134 | 8500 | 850°C

Prozessdaten

Die Prozessdaten, die zum K-Bus übertragen werden, berechnen sich aus folgenden Gleichungen:

X_RL: ADC-Wert der Zuleitung
X_RTD: ADC-Wert des Temperatursensors inklusive einer Zuleitung
X_R: ADC-Wert des Temperatursensors
A_a, B_a: Hersteller, Gain und Offsetabgleich (R17,R18)
A_h, B_h: Hersteller-Skalierung
A_w, B_w: Anwender-Skalierung
Y_R: Widerstandswert des Temperatursensors
Y_T: gemessene Temperatur in 1/16°C
Y_THS: Temperatur nach Herstellerskalierung (1/10°C )
Y_TAS: Temperatur nach Anwenderskalierung
Y_AUS: Prozessdaten zur SPS- Steuerung

a) Berechnung des Widerstandswertes:
X_R = X_RTD-X_RL (1.0) Y_R = A_a * (X_R -B_a) (1.1)

b) Linearisierung der Kennlinie:
Y_T = a1 * Y_R^2 + b1* Y_R + c1 (1.2) oder Y_T = Y_R wenn Ausgabe in Ohm (1.3)

c) weder Anwender noch Herstellerskalierung aktiv:
Y_AUS = Y_T (1.4)

d) Herstellerskalierung aktiv (Werkseinstellung):
Y_THS = A_h * Y_T + B_h (1.5) Y_AUS = Y_THS

e) Anwenderskalierung aktiv:
Y_TAS = A_w * Y_T + B_w (1.6) Y_AUS = Y_TAS

f) Hersteller- und Anwenderskalierung aktiv: (1.7)
Y_1 = A_h * Y_T + B_h Y_2 = A_w * Y_1 + B_w Y_AUS = Y_2

Ersatzschaltbild


Control- und Status-Byte IP/IE3202

BECKHOFF Feldbus Box: Konfiguration

Control und Status-Byte IP/IE3202

Prozessdatenbetrieb

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserviert

Name | Beschreibung
RegAccess | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | Error | reserviert |  | reserviert |  | Over-Range | Under-Range

Name | Beschreibung
RegAccess | 0bin: Quittung für Prozessdatenbetrieb
Error | allgemeines Fehlerbit
Over-Range | R > 400 Ohm
Under-Range | R < 18 Ohm

Register-Kommunikation

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Registerkommunikation eingeschaltet
R/W | 0bin: Read 1bin: Write
Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Quittung für Registerzugriff
R/W | 0bin: Read
Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht IP/IE3202

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | ADC-Rohwert | variabel | R | RAM
R1 | ADC-Rohwert der Leitung | variabel | R | RAM
R2 | reserviert | 0x0000 | R |
... | ... | ... | ... | ...
R5 | reserviert | 0x0000 | R |
R6 | Diagnose-Register | variabel | R | RAM
R7 | reserviert | 0x0000 | R |
R8 | Modul Typ | 3202dec | R | ROM
R9 | Software-Version | 0xXXXX | R | ROM
R10 | Multiplex-Schieberegister | 0x0418 | R | ROM
R11 | Signalkanäle | 0x0418 | R | ROM
R12 | minimale Datenlänge | 0x0098 | R | ROM
R13 | Datenstruktur | 0x0000 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Regiser | variable | R/W | RAM
R16 | Hardware-Versionsnummer | 0xXXXX | R/W | SEEROM
R17 | Hardware-Abgleich: Offset | spezifisch | R/W | SEEROM
R18 | Hardware-Abgleich: Gain | spezifisch | R/W | SEEROM
R19 | Hersteller-Skalierung: Offset | 0x0000 | R/W | SEEROM
R20 | Hersteller Skalierung: Gain | 0x00A0 | R/W | SEEROM
R21 | Offset-Register Zweidraht- Anschlusstechnik | spezifisch | R/W | SEEROM
R22 | Offset-Register Dreidraht-Anschlusstechnik | spezifisch | R/W | SEEROM
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W | SEEROM
R31 | Codeword Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0102 | R/W | SEEROM
R33 | Anwender-Offset | 0x0000 | R/W | SEEROM
R34 | Anwender-Gain | 0x0100 | R/W | SEEROM
R35 | reserviert | 0x0000 | R/W | SEEROM
R36 | reserviert | 0x0000 | R/W | SEEROM
R37 | Filter-Register | 0x0000 | R/W | SEEROM
R38 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R/W | SEEROM


Feature-Register (R32) IP/IE3202

Im Feature-Register können die grundlegenden Einstellungen des Moduls verändert werden.

Um das Register zu beschreiben muss im Codewort- Register erst der Schreibschutz aufgehoben werden (default: 0x0106).

Achtung

Die Auswahl der Messmethode (2-, 3- oder 4-Leiteranschluss) muss für alle Kanälen gleich sein.

Bit | Wert | Beschreibung |  | default
0 | 0bin | Anwender-Skalierung inaktiv |  | 0bin
 | 1bin | Anwender- Skalierung aktiv (Register 33, 34)
1 | 0bin | Hersteller- Skalierung inaktiv |  | 1bin
 | 1bin | Hersteller- Skalierung aktiv (Register 19, 20)
2 | 0bin | reserviert |  | 0bin
3 | 0bin | Betrags-Vorzeichendarstellung inaktiv |  | 0bin
 | 1bin | Betrags-Vorzeichendarstellung aktiv
4 | 0bin | Siemens-Ergänzungsbits ausblenden |  | 0bin
 | 1bin | Siemens-Ergänzungsbits einblenden
5 | 0bin | reserviert |  | 0bin
6 | 0bin | reserviert |  | 0bin
7 | 0bin | manuelle Filtereinstellung in Register 37 deaktivieren |  | 0bin
 | 1bin | manuelle Filtereinstellung in Register 37 aktivieren
8 | 0bin | Overrange-Protection deaktivieren |  | 1bin
 | 1bin | Overrange-Protection aktivieren: Wird eine Temperatur von 850°C überschritten, werden die Statusbits entsprechend gesetzt und der Ausgabewert auf 850°C beschränkt.
10...9 | 00bin | 4-Leiteranschluss aktviert (Achtung: alle Kanäle müssen gleich konfiguriert werden!) |  | 00bin
 | 01bin | 3-Leiteranschluss aktviert *(Achtung: alle Kanäle müssen gleich konfiguriert werden!)
 | 10bin | 2-Leiteranschluss aktviert (Achtung: alle Kanäle müssen gleich konfiguriert werden!)
11 | 0bin | reserviert |  | 0bin
15...12 | 0hex | PT100 | -200°C - 850°C ± 0,3°C | 0hex
 | 1hex | NI100 | -60°C - 250°C ± 0,3°C
 | 2hex | PT1000 | -200°C - 850°C ± 0,3°C
 | 3hex | PT500 | -200°C - 850°C ± 0,5°C
 | 4hex | PT200 | -200°C - 850°C ± 0,3°C
 | 5hex | NI1000 | -200°C - 850°C ± 0,3°C
 | 6hex | NI120 | -80°C - 320°C ± 0,3°C
 | 7hex | RSNE1000 | Nickel 1000 spezielle Temperaturkurve der Fa. Siemens
 | Ehex | Ohm | 10 - 5000 Ohm (Darstellung in 1/2 Ohm)
 | Fhex | Ohm | 10 - 1200 Ohm (Darstellung in 1/10 Ohm)

*) ab Firmware-Version 2 der E/A-Platine des IP3202 bzw. ab Firmware-Version 0 der E/A-Platine des IE3202

Erläuterung zum Vorzeichenbit

Default zweierkomplementäre Darstellung, d.h. bei -1 Darstellung 0xFFFF

Betrags Vorzeichendarstellung aktiv, d.h. bei -1 Darstellung 0x8001

Skalierungsbeispiel

Hersteller-Sklalierung aktiv, Anwender-Skalierung aktiv, Ausgabe in Ohm 10 - 5000 Ohm
Register 34 0x0500 0,100 Ohm / Digit
Register 34 0x0400 0,125 Ohm / Digit
Register 34 0x0200 0,250 Ohm / Digit
Register 34 0x0100 0,500 Ohm / Digit
Register 34 0x0080 1,000 Ohm / Digit

Siemens-Ausgabeformat (S5)

Wird das Siemens-Ausgabeformat ausgewählt werden die niedrigsten drei Bits zur Statusauswertung genutzt. Das Prozessdatum wird in den Bits 15-3 abgebildet, wobei das Bit 15 das Vorzeichenbit ist.

Bit | Name | Beschreibung
0 | Überlauf | 0bin | Messwert im gültigen Bereichgültig Value in Range
 |  | 1bin | Messwertüberlauf Value out of range
1 | Error | 0bin | kein Fehler
 |  | 1bin | Fehler
2 | - | 0bin | reserviert
14...3 | Messwert Value | 0bin | Prozessdatum
15 | Vorzeichen Sign | 0bin | plus
 |  | 1bin | minus

Zweileiteranschluss

Über den Zweileiteranschluss kann direkt ein Widerstand gemessen werden. Den ohmschen Anteil des Leitungswiderstand kann man messen und in das Register 21 eintragen. Für den Zweileiter-Anschluss muss man bei kurzgeschlossenem Leitungswiderstand (+RL -RL) den ADC-Rohwert aus Register 1 in das Register 21 eintragen.

Anwender-Skalierung

Beispiel für die Skalierung auf Fahrenheit


Filter-Register (R37) IP/IE3202

Im Filter-Register kann die Filterzeit des A/D Wandlers geändert werden. Um das Register zu beschreiben muss im Codewort Register erst der Schreibschutz aufgehoben werden. Mit der Filterzeit verändert sich auch die Wandlungszeit des A/D Wandlers. Beide Werte sind direkt von einander Abhängig. Die Filtereinstellungen gelten immer für alle Kanäle und werden im ersten Register des Kanal 1 eingestellt. Die Einstellungen sind erst nach einem Power-On-Reset wirksam (Feldbus Box aus und wieder einschalten).

Default 0x0000

Wert | Filter First Notch [Hz] | Wandlungszeit
0x0000 | 25 | 250 ms
0x0050 | 100 | 65 ms
0x00A0 | 50 | 125 ms
0x0140 | 25 | 250 ms
0x0280 | 12.5 | 500 ms


Funktionsweise IP/IE3312

Thermoelemente gehören zu der Kategorie der aktiven Messwertaufnehmer, ausgenutzt wird hier der thermoelektrische Effekt (Seebeck, Peltier, Thomson). An den Berührungsstellen zweier elektrischer Leiter aus unterschiedlichen Materialien (z.B. Eisen-Konstantan) tritt eine Ladungsverschiebung an den Berührungspunkten auf. Es entsteht eine Kontaktspannung, die eine eindeutige Funktion der Temperatur ist. Diese Thermospannung ist sowohl eine Funktion der Messtemperatur T als auch der Vergleichstemperatur Tv an den Anschlusskontakten des Thermoelementes. Da die Ermittlung der Koeffizienten bei einer Vergleichstemperatur von 0°C erfolgt, muss der Einfluss der Vergleichstemperatur kompensiert werden. Dazu wird die Vergleichstemperatur in eine vom Thermoelement-Typ abhängigen Vergleichsspannung umgerechnet und diese zur gemessenen Thermospannung addiert. Aus der resultierenden Spannung und der entsprechenden Kennlinie wird die Temperatur ermittelt.

Temperaturen werden in 1/10°C (1 Digit = 0,1°C) ausgegeben. Darüber hinaus wird ein Drahtbruch bzw. der fehlende Kaltstellenkompensations-Sensor (PT1000) gemeldet und durch die Error-LED angezeigt.

Ausgabeformat der Prozessdaten

Prozessdaten (hex) | Prozessdaten Dezimal (integer) | Messwert
0xF63C | -2500 | -250°C
0xF830 | -2000 | -200°C
0xFC18 | -1000 | -100°C
0xFFFF | -1 | -0,1°C
0x0000 | 0 | 0,0°C
0x0001 | 1 | 0,1°C
0x02E8 | 1000 | 100°C
0x07D0 | 2000 | 200°C
0x1388 | 5000 | 500°C
0x2134 | 8500 | 850°C

Prinzipschaltbild

Ersatzschaltbild


Control- und Status-Byte IP/IE3312

Prozessdatenbetrieb

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserviert

Name | Beschreibung
RegAccess | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | Error | - | - | NoColdJunction | internal Error | Over-Range | Under-Range

Name | Beschreibung
RegAccess | 0bin: Quittung für Prozessdatenbetrieb
Error | allgemeines Fehlerbit
NoColdJunction | Verlust der Kaltstelle im Stecker: Wenn die Kaltstelle nicht im Bereich von -50 bis 100°C liegt so wird ein Fehler gemeldet.
internal Error | Analogteil der Feldbus Box ist defekt
Over-Range | Drahtbruch
Under-Range | Minimalwert des ausgewählten Thermoelements (Bit R32.12 bis Bit R32.12 des Feature-Registers) unterschritten

Register-Kommunikation

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Registerkommunikation eingeschaltet
R/W | 0bin: Read 1bin: Write
Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Quittung für Registerzugriff
R/W | 0bin: Read
Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht IP/IE3312

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | ADC-Rohwert | variabel | R | RAM
R1 | VGL-Rohwert | variabel | R | RAM
R2 | TVGL in 1/16°C | variabel | R | RAM
R3 | reserviert | 0x0000 | R |
R4 | reserviert | 0x0000 | R |
R5 | reserviert | 0x0000 | R |
R6 | Diagnose-Register | variabel | R | RAM
R7 | reserviert | 0x0000 | R |
R8 | Modul-Typ | 3314dec | R | ROM
R9 | Software-Version | 0xXXXX | R | ROM
R10 | Multiplex-Schieberegister | 0x0418 | R | ROM
R11 | Signalkanäle | 0x0418 | R | ROM
R12 | minimale Datenlänge | 0x0098 | R | ROM
R13 | Datenstruktur | 0x0000 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Regiser | variable | R/W | RAM
R16 | Hardware-Versionsnummer | 0xXXXX | R/W | SEEROM
R17 | Hardware-Abgleich: Offset | spezifisch | R/W | SEEROM
R18 | Hardware-Abgleich: Gain | spezifisch | R/W | SEEROM
R19 | Hersteller-Skalierung: Offset | 0x0000 | R/W | SEEROM
R20 | Hersteller Skalierung: Gain | 0x00A0 | R/W | SEEROM
R21 | Hardware-Abgleich: Vergleichstemperatur | spezifisch | R/W | SEEROM
R22 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W | SEEROM
R31 | Codeword-Register | variabel | R/W | RAM
R32 | Feature-Register | 0x1002 | R/W | SEEROM
R33 | Anwender-Offset | 0x0000 | R/W | SEEROM
R34 | Anwender-Gain | 0x0100 | R/W | SEEROM
R35 | reserviert | 0x0000 | R/W | SEEROM
R36 | reserviert | 0x0000 | R/W | SEEROM
R37 | Filter-Register | 0x0000 | R/W | SEEROM
R38 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R/W | SEEROM


Feature-Register (R32) IP/IE3312

Im Feature-Register können die grundlegenden Einstellungen des Moduls verändert werden. Um das Register zu beschreiben muss im Codewort-Register erst der Schreibschutz aufgehoben werden.
Default: 0x1002

Bit | Wert | Beschreibung |  |  |  | Hersteller- einstellung
0 | 0bin | Anwender-Skalierung inaktiv |  |  |  | 0bin
 | 1bin | Anwender- Skalierung aktiv
1 | 0bin | Hersteller- Skalierung inaktiv |  |  |  | 1bin
 | 1bin | Hersteller- Skalierung aktiv
2 | 0bin | reserviert |  |  |  | 0bin
3 | 0bin | Betrags-Vorzeichendarstellung inaktiv |  |  |  | 0bin
 | 1bin | Betrags-Vorzeichendarstellung aktiv
4 | 0bin | Siemens- Ergänzungsbits ausblenden |  |  |  | 0bin
 | 1bin | Siemens- Ergänzungsbits einblenden
5 | 0bin | manueller Filtereinstellung in Register 37 deaktivieren |  |  |  | 0bin
 | 1bin | manueller Filtereinstellung in Register 37 aktivieren
6 | 0bin | reserviert |  |  |  | 0bin
7 | 0bin | reserviert |  |  |  | 0bin
8 | 0bin | Vergleichstemperatur eingeschaltet |  |  |  | 0bin
 | 1bin | Vergleichstemperatur ausgeschaltet
9 | 0bin | reserviert |  |  |  | 0bin
10 | 0bin | reserviert |  |  |  | 0bin
11 | 0bin | Vergleichsstelle des ersten Kanals für alle anderen Kanäle nicht übernehmen |  |  |  | 0bin
 | 1bin | Vergleichsstelle des ersten Kanals für alle anderen Kanäle übernehmen
15-12 |  | Thermoelement-Typ |  | Minimalwert | Maximalwert | 1hex
 | 0hex | Typ L |  | -100 °C | 900 °C
 | 1hex | Typ K |  | -100 °C | 1370 °C
 | 2hex | Typ J |  | -100 °C | 1000 °C
 | 3hex | Typ E |  | -100 °C | 800 °C
 | 4hex | Typ T |  | -100 °C | 400 °C
 | 5hex | Typ N |  | -100 °C | 1300 °C
 | 6hex | Typ U |  | -100 °C | 600 °C
 | 7hex | Typ B |  | 600 °C | 1800 °C
 | 8hex | Typ R |  | 0 °C | 1700 °C
 | 9hex | Typ S |  | 0 °C | 1700 °C
 |  | Millivoltmessung, Auflösung: |  | Minimalwert | Maximalwert
 | Dhex | 1 µV* | 1,6 µV** | -30 mV | +30 mV
 | Ehex | 2 µV* | 3,2 µV** | -60 mV | +60 mV
 | Fhex | 4 µV* | 6,4 µV** | -80 mV | +80 mV
Hinweis Beachten Sie bei der Millivoltmessung, welche Skalierung aktiviert ist:
*) keine Skalierung aktiv
**) nur Herstellerskalierung aktiv

Erläuterung zum Vorzeichenbit

Default zweierkomplementäre Darstellung, d.h. bei -1 Darstellung 0xFFFF

Betrags Vorzeichendarstellung aktiv, d.h. bei -1 Darstellung 0x8001

Anwender Skalierung

Siehe Beispiel für die Skalierung auf Fahrenheit.


Filter-Register (R37) IP/IE3312

Im Filter-Register kann die Filterzeit des A/D-Wandlers geändert werden. Um das Register zu beschreiben muss im Codewort-Register erst der Schreibschutz aufgehoben werden. Mit der Filterzeit verändert sich auch die Wandlungszeit des A/D-Wandlers. Beide Werte sind direkt von einander Abhängig. Die Filtereinstellungen gelten immer für alle Kanäle und werden im ersten Register des Kanal 1 eingestellt. Die Einstellungen sind erst nach einem Power-Restart wirksam (Feldbus Box aus und wieder einschalten).

Default 0x0000

Wert | Filter First Notch [Hz] | Wandlungszeit
0x0000 | 25 | 200 ms
0x0050 | 100 | 70 ms
0x00A0 | 50 | 120 ms
0x0140 | 25 | 200 ms
0x0280 | 12.5 | 400 ms


Funktionsweise IP/IE4112

Das analoge Ausgangsmodul erzeugt Ausgangssignale im Bereich von 0...20 mA. Der Ausgangsstrom wird mit bis zu 16 Bit Auflösung von dem Modul ausgegeben.

Prozessdaten (hex) | Prozessdaten (dezimal) | Ausgabewert
0x0000 | 0 | 0 mA
0x3FFF | 16383 | 10 mA
0x7FFF | 32767 | 20 mA

Ab der Softwareversion 2 (siehe Anhang) kann im Register 32 (Bit 5= 1) auch der Bereich von 4...20mA eingestellt werden. Diese Einstellung im Feature-Register des ersten Kanals ist dann für alle Kanäle gültig und kann nicht für jeden Kanal separat angewählt werden.

Prozessdaten (hex) | Prozessdaten (dezimal) | Ausgabewert
0x0000 | 0 | 4 mA
0x3FFF | 16383 | 12 mA
0x7FFF | 32767 | 20 mA

Die Darstellung entspricht dem Zahlenformat Integer (INT) . Die Prozessdaten werden in der Default-Einstellung im Zweierkomplement eingegeben (-1 entspricht 0xFFFF).

Prozessdaten

Die Prozessdaten, die die Steuerung schreibt, werden wie folgt ausgegeben:
x = Prozessdaten der PLC (D0, D1)
B_a, A_a = Hersteller Skalierung (Register 17, 18)
B_h, A_h = Hersteller Skalierung (Register 19, 20)
B_w, A_w = Anwender Skalierung (Register 33, 34)
Y_dac = Ausgabewert zum D/A Wandler

weder Anwender noch Herstellerskalierung aktiv
Y_0 = B_a + A_a * x
Y_dac = Y_0

Herstellerskalierung aktiv (Default)
Y_1 = B_h + A_h * Y_0
Y_dac = Y_1

Anwenderskalierung aktiv
Y_2 = B_w + A_w * Y_0
Y_dac = Y_2

Hersteller- und Anwenderskalierung aktiv
Y_1 = B_h + A_h *Y_0
Y_dac = B_w + A_w * Y_1

Die Gradengleichungen werden über Register 32 aktiviert.

Ersatzschaltbild

IPIE4112.jpg (51976 Byte)


Control- und Status-Byte IP/IE4112

Prozessdatenbetrieb

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserviert

Name | Beschreibung
RegAccess | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserviert

Name | Beschreibung
RegAccess | 0bin: Quittung für Prozessdatenbetrieb

Register-Kommunikation

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Registerkommunikation eingeschaltet
R/W | 0bin: Read 1bin: Write
Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Quittung für Registerzugriff
R/W | 0bin: Read
Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht IP/IE4112

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | Hersteller Einschaltwert | 0x0000 | R/W |
... | ... | ... | ... | ...
R4 | reserviert | 0x0000 | R |
R5 | DAC-Rohwert | variabel | R | RAM
R6 | reserviert | 0x0000 | R |
R7 | reserviert | 0x0000 | R |
R8 | Modul Typ | 4112dec | R | ROM
R9 | Software-Version | 0xXXXX | R | ROM
R10 | Multiplex-Schieberegister | 0x0418 | R | ROM
R11 | Signalkanäle | 0x0418 | R | ROM
R12 | minimale Datenlänge | 0x9800 | R | ROM
R13 | Datenstruktur | 0x0004 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Register | variable | R/W | RAM
R16 | Hardware-Versionsnummer | 0xXXXX | R/W | EEPROM
R17 | Hardware-Abgleich Offset | spezifisch | R/W | EEPROM
R18 | Hardware-Abgleich Gain | spezifisch | R/W | EEPROM
R19 | Hersteller Skalierung: Offset | 0x0000 | R/W | EEPROM
R20 | Hersteller Skalierung: Gain | 0x0200 | R/W | EEPROM
R21 | reserviert | 0x0000 | R/W |
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W |
R31 | Codeword-Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0002 | R/W | EEPROM
R33 | Anwender-Offset | 0x0000 | R/W | EEPROM
R34 | Anwender-Gain | 0x0100 | R/W | EEPROM
R35 | Anwender Einschaltwert | 0x0000 | R/W |
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R/W |


Feature-Register (R32) IP/IE4112

Im Feature-Register können die grundlegenden Einstellungen des Moduls verändert werden. Um das Register zu beschreiben muss im Codewort-Register erst der Schreibschutz aufgehoben werden.

Bit | Wert | Beschreibung | Hersteller Einstellung
0 | 0bin | Anwender-Skalierung inaktiv | 0bin
 | 1bin | Anwender- Skalierung aktiv
1 | 0bin | Hersteller- Skalierung inaktiv | 1bin
 | 1bin | Hersteller Skalierung aktiv
2 | 0bin | Watchdog-Timer aktiv | 0bin
 | 1bin | Watchdog-Timer inaktiv
3 | 0bin | reserviert | 0bin
4 | 0bin | reserviert | 0bin
5)1 | 0bin | Modus 0..20 mA | 0bin
 | 1bin | Modus 4..20 mA
6 | 0bin | reserviert | 0bin
7 | 0bin | reserviert | 0bin
8 | 0bin | Hersteller-Einschaltwert [0] | 0bin
 | 1bin | Anwender-Einschaltwert R35
9 | 0bin | reserviert | 0bin
... | ... | ... | ...
15 | 0bin | reserviert | 0bin

Erläuterung zum Watchdog-Timer

Der Watchdog-Timer ist im Auslieferungszustand eingeschaltet. Bei einem Watchdog Overflow wird entweder der Hersteller- oder der Anwender-Einschaltwert am Ausgang des Moduls ausgegeben.

Achtung | Die Einstellung des Modus 0..20mA / 4..20mA können nur im Register des ersten Kanals gemacht werden und gelten für alle vier Kanäle! Die Einstellung werden erst nach einem POWER OFF/ON gültig!
Hinweis | Aus Kompatibilitätsgründen ist das Standard-Ausgabeformat 16 Bit signed Integer eingeschaltet. Der positive Wertebereich für 0..20 mA erstreckt sich von 0x0000..0x7FFF. Dies entspricht 15 Bit. Um alle 16 Bit zu nutzen, muss die Hersteller-Skalierung deaktiviert werden. )1 Ab Software-Version der E/A Platine IP4112-Bxxx "2" IE4112 "0"


Funktionsweise IP/IE4132

Das analoge Ausgangsmodul erzeugt Ausgangssignale im Bereich von -10...10 V. Die Ausgangsspannung wird mit bis zu 16 Bit Auflösung von dem Modul ausgegeben.

Prozessdaten (hex) | Prozessdaten (dezimal) | Ausgabewert
0x8001 | -32767 | -10 V
0xC001 | -16383 | - 5 V
0x0000 | 0 | 0 V
0x3FFF | 16383 | 5 V
0x7FFF | 32767 | 10 V

Die Darstellung entspricht dem Zahlenformat Integer (INT). Die Prozessdaten werden in der Default-Einstellung im Zweierkomplement eingegeben (-1 entspricht 0xFFFF).

Prozessdaten

Die Prozessdaten, die die Steuerung schrieb, werden wie folgt ausgegeben:
x = Prozessdaten der PLC (D0, D1)
B_a, A_a = Hersteller Skalierung (Register 17, 18)
B_h, A_h = Hersteller Skalierung (Register 19, 20)
B_w, A_w = Anwender Skalierung (Register 33, 24)
Y_dac = Ausgabewert zum D/A Wandler

weder Anwender noch Herstellerskalierung aktiv
Y_0 = B_a + A_a * x
Y_dac = Y_0

Herstellerskalierung aktiv (Default)
Y_1 = B_h + A_h * Y_0
Y_dac = Y_1

Anwenderskalierung aktiv
Y_2 = B_w + A_w * Y_0
Y_dac = Y_2

Hersteller- und Anwenderskalierung aktiv
Y_1 = B_h + A_h *Y_0
Y_dac = B_w + A_w * Y_1

Die Gradengleichungen werden über Register 32 aktiviert.

Ersatzschaltbild

IPIE4132.jpg (48260 Byte)


Control- und Status-Byte IP/IE4132

Prozessdatenbetrieb

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserviert

Name | Beschreibung
RegAccess | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserviert

Name | Beschreibung
RegAccess | 0bin: Quittung für Prozessdatenbetrieb

Register-Kommunikation

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Registerkommunikation eingeschaltet
R/W | 0bin: Read 1bin: Write
Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Quittung für Registerzugriff
R/W | 0bin: Read
Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht IP/IE4132

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | Herstelller Einschaltwert | 0x0000 | R/W |
... | ... | ... | ... | ...
R4 | reserviert | 0x0000 | R |
R5 | DAC-Rohwert | variabel | R | RAM
R6 | reserviert | 0x0000 | R |
R7 | reserviert | 0x0000 | R |
R8 | Modul Typ | 4132dec | R | ROM
R9 | Software-Version | 0xXXXX | R | ROM
R10 | Multiplex-Schieberegister | 0x0418 | R | ROM
R11 | Signalkanäle | 0x0418 | R | ROM
R12 | minimale Datenlänge | 0x9800 | R | ROM
R13 | Datenstruktur | 0x0004 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Register | variable | R/W | RAM
R16 | Hardware-Versionsnummer | 0xXXXX | R/W | SEEROM
R17 | Hardware-Abgleich: Offset | spezifisch | R/W | SEEROM
R18 | Hardware-Abgleich: Gain | spezifisch | R/W | SEEROM
R19 | Hersteller-Skalierung: Offset | 0x0000 | R/W | SEEROM
R20 | Hersteller Skalierung: Gain | 0x0100 | R/W | SEEROM
R21 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W | SEEROM
R31 | Codeword-Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0000 | R/W | SEEROM
R33 | Anwender-Offset | 0x0000 | R/W | SEEROM
R34 | Anwender-Gain | 0x0100 | R/W | SEEROM
R35 | Anwender Einschaltwert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R/W | SEEROM


Feature-Register (R32) IP/IE4132

Im Feature-Register können die grundlegenden Einstellungen des Moduls verändert werden. Um das Register zu beschreiben muss im Codewort-Register erst der Schreibschutz aufgehoben werden.

Bit | Wert | Beschreibung | default
0 | 0bin | Anwender-Skalierung inaktiv | 0bin
 | 1bin | Anwender-Skalierung aktiv
1 | 0bin | Hersteller-Skalierung inaktiv | 0bin
 | 1bin | Hersteller-Skalierung aktiv
2 | 0bin | Watchdog-Timer aktiv | 0bin
 | 1bin | Watchdog-Timer inaktiv
3 | 0bin | reserviert | 0bin
... | ... | ... | ...
7 | 0bin | reserviert | 0bin
8 | 0bin | Hersteller-Einschaltwert [0] | 0bin
 | 1bin | Anwender-Einschaltwert R35
9 | 0bin | reserviert | 0bin
... | ... | ... | ...
15 | 0bin | reserviert | 0bin

Erläuterung zum Watchdog-Timer

Der Watchdog-Timer ist im Auslieferungszustand eingeschaltet. Bei einem Watchdog-Overflow wird entweder der Hersteller- oder der Anwender-Einschaltwert am Ausgang des Moduls ausgegeben.


Funktionsweise IP/IE5009

Das SSI-Geber Interface Modul IP/IE5009 ermöglicht den direkten Anschluss eines SSI-Gebers an den Feldbus bzw. die Koppler Box. Die Versorgung des Gebers erfolgt über das SSI-Interface. Das Modul gibt zum Auslesen des Gebers einen Takt aus und stellt der Steuerung den einlaufenden darauf abgestimmten Datenstrom im Prozessabbild zur Verfügung. Unterschiedliche Betriebsarten, Übertragungsfrequenzen, Bitbreiten und Codeumsetzungen sind einstellbar. Die individuelle Konfiguration wird permanent in einem Registersatz gespeichert.

Das SSI-Interface wird mit einer Datenbreite von 24-Bit und aktivierter Gray-code-Wandlung geliefert. Die Baudrate zum SSI-Geber ist auf 250 kHz eingestellt. Die Prozessdaten werden in den Eingangs-Daten-Bytes D0 - D3 ausgegeben. Das Mapping Moduls wird im Kapitel Mapping näher beschrieben.

Prozessdaten

Signale | Beschreibung
Ausgänge Clock+ / Clock- | Taktausgang für den SSI-Geber
Eingänge Data+ / Data- | Differenzsignaleingänge (RS485)
+24 VDC US | Spannungsausgang zur Versorgung des Gebers
US | Spannungsversorgung für Elektronik und Encoder
UP, GND | Eine Spannungsversorgung von 0 V und 24 V muß für den Betrieb des Moduls auf diese Kontakte gelegt werden.


Control- und Status-Byte IP/IE5009

Prozessdatenbetrieb

Control-Byte

Das Control-Byte nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserviert

Name | Beschreibung
RegAccess | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild der Feldbus Box und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | Error | 0 | 0 | 0 | 0 | FRAME_E | SSI_IN_E

Name | Beschreibung
RegAccess | 0bin: Quittung für Prozessdatenbetrieb
Error | Ein allgemeiner Fehler ist aufgetreten. Dieses Bit wird gesetzt wenn FRAME-E oder SSI_IN-E Fehler aufgetreten ist
FRAME_E | Es liegt ein falscher Datenrahmen vor, d.h. der Datenrahmen wird nicht mit Null abgeschlossen (evtl. Drahtbruch auf Clock-Leitungen).
SSI_IN_E | Der SSI-Eingang der Klemme liegt auf Low-Pegel, wenn keine Datenübertragung stattfindet. (SSI hat keine Spannungsversorgung bzw. Drahtbruch auf SSI-Dateneingänge D+ bzw. D-oder Datenleitungen vertauscht.)

Register-Kommunikation

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Registerkommunikation eingeschaltet
R/W | 0bin: Read 1bin: Write
Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Quittung für Registerzugriff
R/W | 0bin: Read
Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht IP/IE5009

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | reserviert | 0000hex | R |
... | ... | ... | ... | ...
R7 | reserviert | 0000hex | R |
R8 | Modul Typ | 5009dec | R | ROM
R9 | Software-Version | XXXXhex | R | ROM
R10 | Multiplex-Schieberegister | 0218hex/0130hex | R | ROM
R11 | Signalkanäle | 0128hex | R | ROM
R12 | minimale Datenlänge | 00A8hex | R | ROM
R13 | Datenstruktur | 0000hex | R | ROM
R14 | reserviert | 0000hex | R |
R15 | Alignment-Regiser | variabel | R/W | RAM
R16 | Hardware-Versionsnummer | XXXXhex | R/W | SEEROM
R17 | reserviert | 0000hex | R |
... | ... | ... | ... | ...
R30 | reserviert | 0000hex | R |
R31 | Codewort-Register | variabel | R/W | RAM
R32 | Feature-Register | 0007hex | R/W | SEEROM
R33 | Baudrate | 0002hex | R |
R34 | Datenlänge | 0018hex | R |
R35 | reserviert | 0000hex | R |
... | ... | ... | ... | ...
R63 | reserviert | 0000hex | R |
Hinweis Änderungen der Regsitereinstellungen werden erst nach einem Neustart der Feldbus Box wirksam.


Feature-Register (R32) IP/IE5009

Im Feature-Register können die grundlegenden Einstellungen des Moduls verändert werden. Um das Register zu beschreiben muss im Codewort-Register erst der Schreibschutz aufgehoben werden.
Default: 0x0001

Bit | Wert | Beschreibung | default
0 | 0bin | Binärausgabe | 1bin
 | 1bin | GrayCode Die Zahlen werden als Graycode ausgegeben
1 | 0bin | reserviert | 0bin
2 | 0bin | Freilaufend | 0bin
 | 1bin | Synchrone Betriebsart Die Daten werden synchron zum Lesezyklus des Klemmenbus geladen.
3 | 0bin | Multi- Turn Auswertung des Gebers | 0bin
 | 1bin | Single- Turn Auswertung des Gebers
4 | 0bin | Enable Frame Error | 0bin
 | 1bin | Disable Frame Error Nach dem letzten gültigen Bit wird nicht überprüft ob die Datenleitung ein Null Signal liefert.


Baudraten-Register (R33) IP/IE5009

Im Baudraten-Register wird die Baudrate für dasLesen der SSI-Daten eingestellt. Damit das Register beschreiben werden kann, müssen Sie zuvor mit dem Codewort-Register den Schreibschutz für die Register aufheben.
(Default: 0x0002)

Bit | Beschreibumg
0x0000 | reserviert
0x0001 | 1 MHz
0x0002 | 250 kHz (Default)
0x0003 | 125 kHz
0x0004 | 100 kHz
0x0005 | 83 kHz
0x0006 | 71 kHz
0x0007 | 62,5 kHz
0x0008 | reserviert
... | ...
0xFFFF | reserviert


Datenlängen-Register (R34) IP/IE5009

Im Datenlängen-Register wird die wir die Datenlänge, die im Prozessabbild erscheint eingestellt. Damit das Register beschreiben werden kann, müssen Sie zuvor mit dem Codewort-Register den Schreibschutz für die Register aufheben.

Default: 0x0018 (24 Bit Datenlänge)

Bit | Wert | Beschreibung
0 bis 7 | 0hex | 0 Bit Datenlänge
 | 1hex | 1 Bit Datenlänge
 | ... | ...
 | 20hex | 32 Bit Datenlänge
 | 21hex | reserviert
 | ... | ...
 | FFhex | reserviert
8 bis 15 | reserviert


Funktionsweise IP/IE5109

Die Inkremental Encoder Interface Modul IP/IE5109 ermöglicht den Anschluss beliebiger 5 V Inkremental Encoder an den Feldbus bzw. die Koppler Box. Ein 16-Bit Zähler mit Quadraturdecoder sowie ein 16-Bit Latch können gelesen, gesetzt oder aktiviert werden. Neben den Gebereingängen A, B, C steht ein zusätzlicher Latch-Eingang (24 V) sowie ein Gate-Eingang (24 V) zum Sperren des Zählers zur Verfügung.

Darüber hinaus ist die Betriebsart 16-Bit Vor- Rückwärts-Zähler anwählbar. In dieser Betriebsart ist Eingang A der Zähleingang, über Eingang B wird die Zählrichtung vorgegeben.

Über das Feature Register ist auch eine Periodendauermessung möglich. Dabei wird die Periodendauer zwischen zwei positiven Flanken des Eingangssignals A mit einer Auflösung von 250 ns ermittelt.

Eine 1-fach, 2-fach bzw. 4-fach Auswertung der Encoder-Signale A, B, C in einfacher oder komplementärer Form kann über den Feldbus parametriert werden. Geliefert wir das Modul in der Grundeinstellung als 4-fach Quadraturdecoder mit komplementärer Auswertung der Gebersignale A, B, C.

Besitzt der Encoder einen Störmeldeausgang, so kann dieser an dem STATUS Eingang des Moduls angeschlossen werden.

Der Encoder wird vom Modul mit der erforderlichen Spannung von 5 VDC versorgt.

Prozessdaten

Signale | Beschreibung
Eingänge A,/A | Impulseingang in der Encoder- und Zähler-Betriebsart des Moduls
Eingänge B,/B | Phasenverschobener Impulseingang in der Encoder-Betriebsart des Moduls
Eingänge C,/C | Nullpunktimpuls-Eingang für das Latch-Register des Moduls Dieser Eingang wird über das EN_LATC Bit im Control-Byte des Moduls aktiviert
Externes Latch 24V | Zusätzlicher Latch-Eingang des Moduls Dieser Eingang wird über das EN_LAT_EXT-Bit im Control-Byte des Moduls aktiviert. Ist dieser Eingang scharf geschaltet und erfolgt ein Flankenwechsel von 0 V auf 24 V, so wird der Zählerwert gelatcht.
Externes Gate 24 V | Ein High-Pegel an diesem Kontakt unterbindet das Zählen der Klemme.
Status Eingang | Besitzt der Inkremental Encoder ein Störmelde Ausgang, kann dieser an den Status Eingang angeschlossen werden (aktiv low Eingang mit interner pull-up Beschaltung).
US | Spannungsversorgung für Elektronik und Encoder
UP, GND | Eine Spannungsversorgung von 0 V und 24 V muss für den Betrieb des Moduls auf diese Kontakte gelegt werden.


Control- und Status-Byte IP/IE5109

Prozessdatenbetrieb

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | - | - | - | - | CNT_SET | EN_LAT_EXT / RD_PERIOD | EN_LATC

Name | Beschreibung
RegAccess | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
CNT_SET | Der Zähler wird mit steigender Flanke von CNT_SET auf den Wert , der über die Prozessdaten vorgegeben wird, gesetzt.
EN_LAT_EXT | Der externe Latch-Eingang wird aktiviert. Beim ersten externen Latch-Impuls nach Gültigkeit des EN_LAT_EXT Bits wird der Zählerwert im Latch-Register gespeichert. Die folgenden Impulse haben bei gesetztem Bit keinen Einfluß auf das Latch-Register. Es ist darauf zu achten, dass das entsprechende Latch-Valid-Bit (LAT_EXT_VAL) vor einem Scharfschalten des Nullimpulses vom Modul zurückgenommen wurde. Diese Funktionalität ist im Feature Register einstellbar (Defaulteinstellung).
RD_PERIOD | Es wird die Periodendauer zwischen zwei postiven Flanken vom Eingang A mit einer Auflösung von 200 ns gemessen. Diese Periodendauer wird bei gesetztem Bit in den Datenbytes D3, D4 ausgegeben. Diese Funktionalität ist im Feature Register einstellbar.
EN_LATC | Der Nullpunkt-Latch (C-Eingang) wird aktiviert. Beim ersten externen Latch-Impuls nach Gültigkeit des EN_LATC Bits wird der Zählerwert im Latch-Register gespeichert (hat Vorrang vor EN_LAT_EXT). Die folgenden Impulse haben bei gesetztem Bit keinen Einfluss auf das Latch-Register. Es ist darauf zu achten, dass das entsprechende Latch-Valid-Bit (LATC_VAL) vor einem Scharfschalten des Nullimpulses vom Modul zurückgenommen wurde. (das Latch-Valid-Bit kann von dem Modul erst zurückgenommen werden, wenn der C-Impuls einen Low Pegel besitzt).

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | - | STATUS_EINGANG | OVERFLOW | UNDERFLOW | CNTSET-ACC | LAT_EXT_VAL/ RD_PERIOD_Q | LATC_VAL

Name | Beschreibung
RegAccess | 0bin: Quittung für Prozessdatenbetrieb
STATUS_EINGANG | Es wird der Zustand des Status-Einganges in diesem Bit eingeblendet (Einstellmöglichkeit über Feature-Register)
OVERFLOW | Tritt ein Überlauf (65535 auf 0) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt wenn der Zähler ein Drittel des Messbereichs überschreitet (21845 auf 21846) oder sobald ein Unterlauf auftritt.
UNDERFLOW | Tritt ein Unterlauf (0 auf 65535) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt wenn der Zähler zwei Drittel des Messbereichs unterschreitet (43690 auf 43689) oder sobald ein Überlauf auftritt.
CNTSET_ACC | Die Daten zum Setzen des Zählers wurden vom Modul übernommen.
LAT_EXT_VAL | Ein externer Latch-Impuls ist aufgetreten. Die Daten D3,D4 im Prozessabbild entsprechen dem aktuellen Zählerwert bei gesetztem Bit. Um den Latch-Eingang erneut zu aktivieren, muss EN_LAT_EXT erst zurückgenommen und dann neu gesetzt werden.
RD_PERIOD_Q | Die Datenbytes 3, 4 beinhalten die Periodendauer
LATC_VAL | Ein Nullpunkt-Latch ist aufgetreten. Die Daten D3,D4 im Prozessabbild entsprechen dem aktuellen Zählerwert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren muss EN_LATC erst zurückgenommen und dann neu gesetzt werden.

Register-Kommunikation

Während der Register-Kommunikation sind keine Messwerte übertragbar.

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Registerkommunikation eingeschaltet
R/W | 0bin: Read 1bin: Write
Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Quittung für Registerzugriff
R/W | 0bin: Read
Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Datenbyte D2, IP/IE5109

D2-Byte

In der Betriebsart Vor-/Rückwärtszähler wird im Byte D2 der Status der Encoder- und Gate/Latch Eingänge angezeigt.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name |  |  | INPUT_A | INPUT_B | INPUT_C | INPUT_ERR | LATCH | GATE

Name | Beschreibung
INPUT_A | Status des Eingangskanal A
INPUT_B | Status des Eingangskanal B
INPUT_C | Status des Eingangskanal C
INPUT_ERR | Status des Störmeldekanals
LATCH | Status des LATCH Eingangs der M12 Buchse
GATE | Status des GATE Eingangs der M12 Buchse


Registerübersicht IP/IE5109

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | reserviert | 0x0000 | R |
... | ... | ... | ... | ...
R7 | reserviert | 0x0000 | R |
R8 | Modul Typ | 5109dec | R | ROM
R9 | Software-Version | 0xXXXX | R | ROM
R10 | Multiplex-Schieberegister | 0x0218/0130 | R | ROM
R11 | Signalkanäle | 0x0130 | R | ROM
R12 | minimale Datenlänge | 0x3030 | R | ROM
R13 | Datenstruktur | 0x0000 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Regiser | variabel | R/W | RAM
R16 | Hardware-Versionsnummer | 0xXXXX | R/W | SEEROM
R17 | reserviert | 0x0000 | R |
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R |
R31 | Codewort Register | variabel | R/W | RAM
R32 | Feature Register | 0x0000 | R/W | SEEROM
R33 | reserviert | 0x0000 | R |
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R |


Feature-Register (R 32) IP/IE5109

BECKHOFF Feldbus Box: Konfiguration

Feature-Register (R32) IP/IE5109

Im Feature-Register können die grundlegenden Einstellungen des Moduls verändert werden. Um das Register zu beschreiben muss im Codewort-Register erst der Schreibschutz aufgehoben werden.
Default: 0x0000

Bit | Wert | Beschreibung | default
0 | 0bin | nicht benutzt | 0bin
1 | 0bin | Zähler sperrt mit High-Pegel am Gate-Eingang | 0
 | 1bin | Zähler sperrt mit Low-Pegel am Gate-Eingang
3, 2 | 00bin | Status-Eingang (aktiv-low) wird ins Status-Byte.5 (ST.5) eingeblendet | 00
 | 10bin | ST.5 = Status-Eingang, ST.6 = StatusEingang
 | 11bin | ST.5 = Status-Eingang, ST.6 = !StatusEingang
 | 01bin | reserviert
6, 5, 4 | 000bin | Externe Latchfunktion aktiv | 000
 | 001bin | Periodendauer-Messung aktiv
 | alle anderen Kombinationen | reserviert, nicht benutzen
7 - 9 |  | reserviert, nicht benutzen |
11, 10 | 00bin | 4-fach Auswertung der Encodersignale A,B,C d.h. sowohl steigende als auch fallende Flanken der Gebersignale A, B werden gezählt | 00
 | 01bin | 1-fach Auswertung der Encodersignale A, B, C d.h. jede Periode des Gebersignals A wird gezählt.
 | 10bin | 2-fach Auswertung der Encodersignale A, B, C d.h. jede Flanke des Gebersignals A wird gezählt.
 | 11bin | 4-fach Auswertung der Encodersignale A, B, C
14 - 12 |  | reserviert, nicht benutzen |
15 | 0bin | Encoder Interface | 0
 | 1bin | Counter Modus ist aktiviert. 16 Bit Vorwärts/Rückwärts Zähler Eingang A: Counter Eingang B: Zählrichtung (5 V oder offen = vorwärts, 0 V = rückwärts Eingang C: Latch


Funktionsweise IP5209

Das Eingangsmodul IP5209-Bxxx-0000 wertet die 1 VSS Sinus-Cosinus Signale und
das Eingangsmodul IP5209-Bxxx-1000 wertet die 11 µASS Sinus-Cosinus Signale
eines entsprechenden Messtasters oder Encoders aus. Eine Signalperiode wird mit 10 Bit, entsprechend 1024 Schritten aufgelöst. So ergibt z.B. ein Drehgeber mit 1024 Signalperioden ca. 2 Millionen Messschritte pro Umdrehung. Das entspricht einer Auflösung von 21-Bit.

Verglichen mit einem herkömmlichen Drehgeber mit digitalen Rechtecksignalen reduziert sich so die Übertragungsfrequenz bei gleicher Auflösung erheblich. Anstelle von Übertragungsraten im MHz Bereich erreicht der Drehgeber so bei 6000 U/min lediglich 100 kHz.

Die IP5209-Bxxx FeldbusBox erlaubt durch die interne Zählfrequenz von 400 kHz eine maximale Eingangs-Grenzfrequenz von 100 kHz.

Das Modul belegt 9 Byte Eingangs- und 9 Byte Ausgangsdaten im Prozessabbild. Alternativ kann das Prozessabbild auf 5-Byte begrenzt werden. Der Latch-Wert wird dann nicht übertragen.

Prozessdaten

Eine Signalperiode wird mit 10 Bit, d.h. in 1048 Schritte aufgelöst. Die Gesamt-Zählwertdarstellung erfolgt als 32 Bit-Wert. Dabei erfolgt von Bit 31 ... 10 die Zählung der Perioden, in Bit 9 und Bit 8 die der Viertelperioden bzw. Nulldurchgänge und die Interpolation innerhalb der Viertelperiode von Bit 7 bis Bit 0.

Die Darstellung wird durch das Skalierungsregister R35 beeinflusst. In der Default-Einstellung 0x0008 wird der Messwert folgendermaßen dargestellt:

Bit | 31 ... 10 | 9 | 8 | 7 | 6 | 6 | 4 | 3 | 2 | 1 | 0
Name | Periodenzähler | Nulldurchgänge |  | Auflösung innerhalb der Viertelperiode
Kommentar | 4.194.304 Perioden | 1024 Schritte innerhalb einer Periode

Die Referenzmarke, wird in den Latch-Worten auf die gleiche Weise abgebildet (siehe IP5209 Mapping).

Interne Funktionen

Rücksetzen/Setzen des Zählers

Durch Setzen des CNT_SET Bit im Control-Byte wird der Zählwert auf den Wert D1-D3 im Ausgangs-Prozessbereich gesetzt.

Referenzmarke (Null Latch) Wert speichern

Die Referenzmarken-Erfassung wird aktiviert und der bei Erreichen der Referenzmarke gültige Zählerwert wird in das Latch geschrieben.

Statusanzeigen

Im Status-Byte des Zählers wird ein Überschreiten der max. Zählfrequenz (einstellbar über R36, R37) angezeigt.


Control- und Status-Byte IP5209

Prozessdatenbetrieb

Control-Byte

Das Control-Byte wird von der Steuerung zur FeldbusBox übertragen. Es befindet sich im Ausgangsabbild der Feldbus Box und kann gelesen und beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | RS_FRQ_ERR | RS_CNT_LAT | - | - | CNT_SET | - | EN_LATC

Name | Beschreibung
REG | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
RS_FRQ_ERR | Setzt FRQ_ERR im Status-Byte zurück (solange das Bit gesetzt bleibt, wird die Frequenz nicht überwacht!)
RS_CNT_LAT | Bei Setzen von RS_CNT_LAT und EN_LATC, wird der Zähler mit steigender Flanke des Nullpunktlatch zurückgesetzt (C-Eingang)
CNT_SET | Der Zähler wird mit steigender Flanke von CNT_SET mit den Werten aus D0-D3 (siehe Mapping) gesetzt.
EN_LATC | Das Referenzmarken-Signal (Nullpunkt-Latch) wird aktiviert. Beim ersten Auftreten des Signals nach Gültigkeit des EN_LATC wird der aktuelle Zählerwert in das Latch-Register gespeichert.´ Die folgenden Impulse haben keinen Einfluss auf das Latch-Register bei gesetztem Bit. Im Prozessabbild D4 - D7 stehen die Daten zur Verfügung.

Status-Byte

Das Status-Byte wird von der Feldbus Box zur Steuerung übertragen. Es befindet sich im Eingangsabbild der Feldbus Box und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | ERROR | NO_SIGNAL | - | FRQ_ERR | CNTSET_ACC | - | LATC_VAL

Name | Beschreibung
REG | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb)
ERROR | allgemeines Fehlerbit, wird gesetzt wenn NO_SIGNAL gesetzt ist
NO_SIGNAL | Das Bit wird gesetzt, wenn kein Sinus-Cosinus Signal an den Eingängen anliegt (Betrag des Sinus-Cosinus-Signals < 0,3V)
FRQ_ERR | Bei Überschreitung der in R37 angegebenen Viertelperiode pro Fenster (R36), wird das FRQ_ERR-Bit im Status-Byte gesetzt. Ein Rücksetzen ist nur über RS_FRQ_ERR im Control-Byte möglich. Die Zählfrequenz beträgt dabei maximal 400 KHz, das entspricht einer Eingangsfrequenz von 100 KHz.
CNTSET_ACC | Die Daten zum Setzen des Zählers wurden von der FeldbusBox übernommen.
LATC_VAL | Ein Referenzmarken-Signal (Nullpunkt Latch) ist aufgetreten. Die Daten D4 - D7 im Prozessabbild entsprechen dem gespeicherten Wert, falls die Funktion aktiviert ist (EN_LATC im CONTROL Byte). Um den Wert erneut zu latchen, muss EN_LATC erst zurückgenommen werden, auf die Quittung der Rücknahme gewartet und dann das Bit neu gesetzt werden.

Register-Kommunikation

Während der Register-Kommunikation sind keine Messwerte übertragbar.

Control-Byte

Das Control-Byte befindet sich im Ausgangsabbild der Feldbus Box und kann gelesen und beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R/W | Registernummer

Name | Beschreibung
REG | 1bin: Registerkommunikation eingeschaltet
R/W | 0bin: Read 1bin: Write
Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R/W | Registernummer

Name | Beschreibung
REG | 1bin: Quittung für Registerkommunikation
R/W | 0bin: Read
Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Feature-Register (R32) IP5209

Im Feature-Register wird die Betriebsart des Moduls festgelegt.
Default: 0x0000

Bit | Wert | Beschreibung | default
0 | 0bin | Normale Zählrichtung | 0bin
 | 1bin | Umgekehrte Zählrichtung
1 | 0bin | 9-Byte Prozessdaten-Interface | 0bin
 | 1bin | 5-Byte Prozessdaten-Interface (ohne Latch-Wert)
2 | 0bin | IP5209-Bxxx-0000 (Version für 1 VSS) | ja nach Modultyp*
 | 1bin | IP5209-Bxxx-1000 (Version für 11 µASS)

Achtung *) Bit 2 ist für den jeweiligen Modultyp (IP5209-Bxxx-0000 oder IP5209-Bxxx-1000) voreingestellt und darf nicht geändert werden!


Skalierungsfaktor-Register (R35) IP5209

Im Skalierungsfaktor-Register wird die Skalierung bzw. Interpolation des Moduls festgelegt. Diese sollte auf die eingesetzte Mess-Hardware abgestimmt sein.

Durch die Skalierung kann der Messwert auf die Applikation abgeglichen werden, so dass ein Umrechnen im Anwendungsprogramm oft entfallen kann!

Der Wert in R35 gibt die Anzahl von Binärstellen (Bits) an, die innerhalb der Viertelperiode eingeblendet werden (Default: 0x0008).

Die folgende Grafik zeigt den Signalverlauf des Sinus-Signals.

Mit der Defaulteinstellung R35 = 0x0008 wird der Messwert D3/D2/D1/D0 des Sinus/Cosinus-Encoders folgendermaßen dargestellt:

Bit | 31 ... 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Anzahl Signalperioden | Nulldurchgänge |  | Auflösung innerhalb der Viertelperiode
Kommentar | 4.194.304 Perioden | 1024 Schritte innerhalb einer Periode

z.B. R35 = 0004

Bit | 31 ... 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Anzahl Signalperioden | Nulldurchgänge |  | Auflösung innerhalb der Viertelperiode
Kommentar | 67.108.864 Perioden | 64 Schritte innerhalb einer Periode
Berechnungs-Beispiel

Sinus/Cosinus-Messtaster 2 µm Signalperiode

Default Einstellung R35: 0x0008,

Taster im ausgefahrenen Zustand auf Null gesetzt (Control-Byte =0x0004),

Messtaster über den vollen Messweg einschieben.

Ergebnis:

Byte | D3 | D2 | D1 | D0
Wert | 0x00 | 0x63 | 0x34 | 0x00

Umrechnung in reellen Messwert:

Wert = Modulwert x Gebersignalperiode / (4 x 2R35)

Wert = 0x633400 x 2 µm / (4 x 28)

Wert = 6.501.376 * 2 µm / (4 x 256) = 0,012698 m = 12,698 mm

Der gemessene Wert entspricht der Datenblatt Angabe eines Gesamthubes von 12 mm für diesen Messtaster.


Frequenzüberwachungs-Register (R36, R37) IP5209

Um die Verfahr- bzw. Drehgeschwindigkeit des Sinus/Cosinus-Sensors zu überwachen, kann eine Frequenzüberwachung eingestellt werden.

Diese besteht aus einem Zeitfenster, dargestellt über Register R36, und einem Grenzwert R37. Innerhalb des Zeitfensters werden die Viertelperioden des Signals gezählt. Überschreiten sie den in R37 parametrierten Wert, so wird ein Fehlerbit im Status-Byte gesetzt.

R36: Frequenzüberschreitungsfenster

Default: [1600]

Diese Überwachungsfenster hat eine Auflösung von 0,0625 µs/Digit. Die Defaulteinstellung ist 1600dez, also 1600 x 0,0625 µs = 100 µs = 0,1 ms.

R37: Maximaler Zähler für die Zeitüberwachung

Default: [41]

Der Zähler gibt die maximale Anzahl der Viertelperioden pro Zeitfenster an. Wird diese Anzahl erreicht, so wird das FRQ_ERR-Bit im Status-Byte des Moduls gesetzt. Das Rückstellen kann nur über das Bit RS_FRQ_ERR im Control-Byte erfolgen. Die Zählfrequenz beträgt maximal 400 KHz, aufgrund der Quadratur-Auswertung ergibt dies eine maximale Eingangs- und damit Geberfrequenz von 100 kHz.

f = R37 / ( R36 x 0,0625µs x 4 )

Defaulteinstellung

f = 41 / ( 1.600 x 0,0625µs x 4 ) = 102.500 Hz , d.h. 40 Viertelperioden sind noch in Ordnung, 40 / ( 1600 x 0,0625µs x 4) = 100 KHz. Werden 41 Viertelperioden gezählt entspricht dies einer Frequenz von 102,5 KHz und ist damit eine Frequenzüberschreitung.

Beispiel 1

Messtaster mit einer Signalperiode von 2 µm.

max. Verfahrgeschwindigkeit = Modul-Eingangsfrequenz x Signalperiode des Tasters

max. V = 100 kHz x 2 µm = 0,2 m/s = 200 mm/s

Bei der obigen Default-Einstellung würde also bei einer Verfahrgeschwindigkeit oberhalb von 200mm/sec ein Fehlerbit gesetzt werden.

Beispiel 2

Messtaster mit einer Signalperiode von 10µm. Maximale Verfahrgeschwindigkeit 50mm/sec.

Modul-Eingangsfrequenz = max. V / Signalperiode

f = 50mm/s / 10µm = 5000 Hz = 5 kHz

z.B. R36 = 25600

R37 = f x R36 x 0,0625µs x 4
R37 = 5000 Hz x 25600 x 0,0625µs x 4 = 32

R37 muss auf den nächst höheren Wert also 33, R36 auf den Wert 25600 eingestellt werden. Dann wird bei einer Überschreitung von 50 mm/s ein Fehlerbit gesetzt!


Registerübersicht IP5209

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | reserviert | 0x0000 | R |
... | ... | ... | ... | ...
R7 | reserviert | 0x0000 | R |
R8 | Modul Typ | 5209dec | R | ROM
R9 | Software-Version | 0xXXXX | R | ROM
R10 | Multiplex-Schieberegister | 0x0228 | R | ROM
R11 | Signalkanäle | 0x0148 | R | ROM
R12 | minimale Datenlänge | 0x4848 | R | ROM
R13 | Datenstruktur | 0x0006 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Regiser | variabel | R/W | RAM
R16 | Hardware-Versionsnummer | 0xXXXX | R/W | SEEROM
R17 | reserviert | 0x0000 | R |
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R |
R31 | Codeword-Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0000 | R/W | SEEROM
R33 | reserviert | 0x0000 | R |
R34 | reserviert | 0x0000 | R |
R35 | Skalierungsfaktor | 0x0008 | R/W | SEEROM
R36 | Frequenzüberwachungsfenster | 0x0640 | R/W | SEEROM
R37 | Viertelperioden-Grenzzähler | 0x0028 | R/W | SEEROM
R38 | reserviert | 0x0000 | R |
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R |


Funktionsweise IP/IE60x2

Die serielle Schnittstellenklemmen KL60x1 Modul IP/IE60x2 ermöglicht den Anschluss von Geräten mit eine serielle Schnittstelle (z.B. bei Bar Code Scannern). Unabhängig vom überlagerten Bussystem können Daten im Halb-/Vollduplex-Betrieb mit der Steuerung ausgetauscht werden. Der Empfangsbuffer ist 128 Byte, der Sendebuffer 16 Byte groß. Der Datentransfer zwischen Klemme/Modul und Steuerung wird über einen Handshake im Status und Control-Byte abgewickelt. Die Werkseinstellung der Klemme/Modul ist 9600 Baud, 8 Daten-Bits, 1Stopbit, no Parity.

Beschreibung | Input %IB... | Output %QB...
Handshake-Byte | Status | Control
Datenbyte 0 | D0 | D0
Datenbyte 1 | D1 | D1
Datenbyte 2 | D2 | D2
Datenbyte 3 | D3 | D3
Datenbyte 4 | D4 | D4

Ersatzschaltbild IP/IE6002

IPIE6002.gif (9164 Byte)

Ersatzschaltbild IP/IE6012, IP/IE6022


Control- und Status-Byte IP/IE60x2

Prozessdatenbetrieb

Zur Abwicklung der Datenübertragung (Handshake) wird das Control- und Status-Byte im Prozessdatenaustausch benutzt.

Control-Byte

Das Control-Byte wird von der Steuerung zum Modul übertragen. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | OL2 | OL1 | OL0 | - | IR | RA | TR

Name | Beschreibung
RegAccess | 0bin: Registerkommunikation ausgeschaltet (Prozessdatenbetrieb: Control- und Statusbyte im Handshake)
OL2-OL0 | Anzahl der gesendeten Daten
IR | Handshake Bit für die Initialisierung der Busklemme/Modul Ist IR high, so führt die Busklemme/Module eine Initialisierung durch. Die Sende und Empfangsfunktionen werden gesperrt, die FIFO-Zeiger werden zurückgesetzt und die Schnittstelle wird mit den Werten der zuständigen Register (R32-R35,R18) initialisiert. Die Ausführung der Initialisierung wird von der Busklemme/Modul mit IA quittiert.
RA | Handshake Bit für das Empfangen von Daten Über eine Zustandsänderung von RR teilt die Busklemme/Modul der Steuerung mit, daß sich die in IL0-IL1 angezeigte Anzahl von Daten in D0-D4 befinden. Die Übernahme der Daten wird im Control-Byte mit RA quittiert, erst daraufhin werden neue Daten von der Busklemme/Modul zur Steuerung übertragen.
TR | Handshake Bit für das Senden von Daten Der Handshake für das Senden der Daten wird über dieses Bit durchgeführt. Eine Zustandsänderung von TR bewirkt, daß die über OL0-OL2 festgesetzte Anzahl von Daten (maximal 5 Bytes) in das Sende-FIFO geladen werden. Die Busklemme/Modul signalisiert über TA die Ausführung dieses Befehls.

Status-Byte

Das Status-Byte wird von der Busklemme/Modul zur Steuerung übertragen. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | IL2 | IL1 | IL0 | BUF_F | IA | RR | TA

Name | Beschreibung
RegAccess | 0bin: Quittung für Prozessdatenbetrieb (Control- und Statusbyte im Handshake)
IL2-IL0 | Anzahl der empfangenen Daten
BUF_F | Empfangspuffer voll, Daten die jetzt noch empfangen werden gehen verloren
IA | Handshake Bit für die Initialisierung der Busklemme/Modul Ist IR high, so führt die Busklemme/Module eine Initialisierung durch. Die Sende und Empfangsfunktionen werden gesperrt, die FIFO-Zeiger werden zurückgesetzt und die Schnittstelle wird mit den Werten der zuständigen Register (R32-R35,R18) initialisiert. Die Ausführung der Initialisierung wird von der Busklemme/Modul mit IA quittiert.
RR | Handshake Bit für das Empfangen von Daten Über eine Zustandsänderung von RR teilt die Busklemme/Modul der Steuerung mit, daß sich die in IL0-IL1 angezeigte Anzahl von Daten in D0-D4 befinden. Die Übernahme der Daten wird im Control-Byte mit RA quittiert, erst daraufhin werden neue Daten von der Busklemme/Modul zur Steuerung übertragen.
TA | Handshake Bit für das Senden von Daten Der Handshake für das Senden der Daten wird über dieses Bit durchgeführt. Eine Zustandsänderung von TR bewirkt, daß die über OL0-OL2 festgesetzte Anzahl von Daten (maximal 5 Bytes) in das Sende-FIFO geladen werden. Die Busklemme/Modul signalisiert über TA die Ausführung dieses Befehls.

Hinweis: Beim ersten empfangen der Daten, steht nur ein Byte im Puffer, da die Busklemme/Modul noch nicht weiß ob weitere Daten folgen.

Beispiele

Beispiel für das Empfangen von Daten

Hinweis: beim Empfang von Daten wird, auch bei mehreren Bytes zunächst nur ein Byte angezeigt.!

Output Control-Byte | Input Status-Byte | Beschreibung
0000_0000 | 0xxx_x00x | Start der Datenübertragung
0xxx_000x | 0011_x01x | 3 Bytes in den Datenbytes und sind bereit zur Abholung
0xxx_001x | 0011_x01x | Quittierung, das die Datenbytes abgeholt worden sind
0xxx_001x | 0101_x00x | 5 Bytes in den Datenbytes und sind bereit zur Abholung
0xxx_000x | 0101_x00x | Quittierung, das die Datenbytes abgeholt worden sind

Beispiel für das Senden von Daten

Output Control-Byte | Input Status-Byte | Beschreibung
0000_0000 | 0xxx_x0x0 | Start der Datenübertragung
0010_00x1 | 0xxx_x0x0 | 2 Bytes in den Datenbytes sollen gesendet werden
0010_00x1 | 0xxx_x0x1 | 2 Byte Daten in den Sende FIFO geladen, Daten werden gesendet
0101_00x0 | 0xxx_x0x1 | 5 Bytes in den Datenbytes sollen gesendet werden
0101_00x0 | 0xxx_x0x0 | 5 Byte Daten in den Sende FIFO geladen, Daten werden gesendet

Beispiel für das Initialisierung

Output Control-Byte | Input Status-Byte | Beschreibung
0xxx_xxxx | 0xxx_xxxx | Start der Datenübertragung
0000_0100 | 0xxx_xxxx | Busklemme/Modul soll initialisiert werden
0000_0100 | 0000_0100 | Busklemme/Modul hat Initialisierung vollzogen
0000_0000 | 0000_0100 | Busklemme/Modul wieder in den Datenaustausch versetzen
0000_0000 | 0000_0000 | Busklemme/Modul ist beriebsbereit

Fehlerbehandlung

Tritt ein Parity-, Framing- oder Overun-Error auf, so geht das betreffende Datum für die Übertragung verloren, es wird nicht in das Empfangs-FIFO der Busklemme/Modul geladen.
Ist der Buffer voll, so werden die ankommenden Daten ignoriert.
Im Fehlerfall werden die entsprechenden Diagnosebits in Register 6 gesetzt.

Register-Kommunikation

Während der Register-Kommunikation sind keine seriellen Daten übertragbar.

Control-Byte

Das Control-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Registerkommunikation eingeschaltet
R/W | 0bin: Read 1bin: Write
Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll.

Status-Byte

Das Status-Byte ist nur sichtbar, wenn die Feldbus Box im kompletten Modus betrieben wird. Es befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Registernummer

Name | Beschreibung
RegAccess | 1bin: Quittung für Registerzugriff
R/W | 0bin: Read
Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.


Registerübersicht IP/IE60x2

Register | Bezeichnung | Default-Wert | Read/Write | Speichermedium
R0 | Anzahl der Datenbytes im Sende-Buffer | variabel | R | RAM
R1 | Anzahl der Datenbytes im Empfangs-Buffer | variabel | R | RAM
R2 | reserviert | 0x0000 | R | RAM
... | ... | ... | ... | ...
R5 | reserviert | 0x0000 | R | RAM
R6 | Diagnose-Register | variabel | R | RAM
R7 | reserviert | 0x0000 | R |
R8 | Modul Typ | 6002dec | R | ROM
R9 | Software-Version | 0xXXXX | R | ROM
R10 | Multiplex-Schieberegister | 0x0218 | R | ROM
R11 | Signalkanäle | 0x0230 | R | ROM
R12 | minimale Datenlänge | 0x5050 | R | ROM
R13 | Datenstruktur | 0x0000 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Register | variable | R/W | RAM
R16 | Hardware-Versionsnummer | 0xXXXX | R/W | SEEROM
R17 | reserviert | 0x0000 | R/W | SEEROM
R18 | Buffer -Größe | 0x0080 | R/W | SEEROM
R19 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R30 | reserviert | 0x0000 | R/W | SEEROM
R31 | Codeword-Register | variabel | R/W | RAM
R32 | Baud-Raten-Register | 0x0006 | R/W | SEEROM
R33 | Datenrahmen-Register | 0x0003 | R/W | SEEROM
R34 | Feature-Register | 0x0000 | R/W | SEEROM
R35 | Datenbyte-Register | 0x0005 | R/W | SEEROM
R36 | reserviert | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserviert | 0x0000 | R/W | SEEROM

R6: Diagnose-Register

Bit Nr. | Wert | Bedeutung
Bit 0 | 1 | Der Empfangsbuffer ist übergelaufen, ankommende Daten gehen verloren.
Bit 1 | 1 | Parity Error ist aufgetreten
Bit 2 | 1 | Framing Error ist aufgetreten
Bit 3 | 1 | Overrun ist aufgetreten
Bit 4 | 1 | Buffer ist voll
Bit 5-16 | - | reserviert

R18: Buffer-Größe

Buffer-Größe [0x0080]
Das Register R18 legt die Anzahl der Daten im Empfangs-FIFO fest, ab der das BUF_F-Bit im Status-Byte gesetzt wird.
Low-Byte: wird dieser Wert erreicht, so wird BUF_F im Status gesetzt
High-Byte: reserviert


Baudraten-Register (R32) IP/IE60x2

Im Baud-Raten-Register kann die gewünschte Übertragungsrate eingestellt werden (Default 9600 Baud).

Bit | Wert | Baud-Rate | Default
0-3 | 0011bin | 1200 Baud | 0110bin
 | 0100bin | 2400 Baud
 | 0101bin | 4800 Baud
 | 0110bin | 9600 Baud
 | 0111bin | 19200 Baud
 | 1000bin | 38400 Baud (ab Hardware Stand D.XX XX XX X1)
 | 1001bin | 56600 Baud (ab Hardware Stand D.XX XX XX X1)
 | 1010bin | 115000 Baud (ab Hardware Stand D.XX XX XX X1)
4 | - | reserviert | 0bin
... | ... | ... | ...
15 | - | reserviert | 0bin

Die Baud-Rate wird nach folgender Gleichung eingestellt:
Baud-Rate = 4 MHz/(16*(HB+1))
Dabei muss das Low-Byte mit 0xFF beschrieben werden, und das High-Byte (HB) gibt den Operator an.


Datenrahmen-Register (R33) IP/IE60x2

Im Datenrahmen-Register kann der gewünschte Übertragungsrahmen eingestellt werden
Default: 0x0003.

Bit | Wert | Datenrahmen | default
0-2 | 001bin | 7 Daten-Bits, even Parity | 011bin
 | 010bin | 7 Daten-Bits, odd Parity
 | 011bin | 8 Daten-Bits, no Parity
 | 100bin | 8 Daten-Bits, even Parity
 | 101bin | 8 Daten-Bits, odd Parity
3 | 0bin | 1 Stopbit | 0bin
 | 1bin | 2 Stopbits
4 | - | reserviert | 0bin
... | ... | ... | 0bin
15 | - | reserviert | 0bin


Feature-Register (R34) IP/IE60x2

Das Feature-Register der IP/IE6002 und IP/IE6012 legt die Betriebsart des Moduls fest.
Default: 0x0000

Bit | Wert | Beschreibung | Default
0 | - | reserviert | 0bin
1 | - | reserviert | 0bin
2 | 0bin | nicht aktiv | 0bin
 | 1bin | aktiv: Das Status-Byte wird von dem Modul einen Zyklus später als die höherwertigen Datenbytes in die Schieberegister des IP-Link kopiert. Dadurch verringert sich die Datenübertragungsrate zur Steuerung.
3 | 0bin | nicht aktiv | 0bin
 | 1bin | aktiv: Das XON/XOFF-Protokoll wird von dem Modul beim Senden von Daten unterstützt, d.h. das Modul sendet die von der Steuerung übergebenen Daten, bis es das Zeichen XOFF (DC3==0x13) vom Partner empfängt. Das Senden wird daraufhin solange unterbunden bis das Zeichen XON (DC1==0x11) empfangen wird.
4 | 0bin | nicht aktiv | 0bin
 | 1bin | aktiv: Das XON/XOFF-Protokoll wird von dem Modul beim Daten-Empfang unterstützt. Das Modul sendet das Steuerzeichen XOFF, wenn 118 Zeichen im Buffer der Busklemme/Modul stehen, XON wird gesendet, wenn vorher XOFF gesendet wurde und die Buffer-Grenze von 18-Byte unterschritten wurde.
5 | - | reserviert | 0bin
6 | 0bin | nicht aktiv | 0bin
 | 1bin | aktiv: Kontinuierliches Senden der Daten aus dem Fifo. Über die Steuerung wird der Sendebuffer gefüllt (bis zu 16 Byte). Mit steigender Flanke im Control-Byte.3 wird der gefüllte Buffer-Inhalt gesendet. Sind die Daten übertragen, so wird dies durch das Setzen des Bits Status-Byte.2 von dem Modul an die Steuerung quittiert. Status-Byte.2 wird mit Control-Byte.3 zurückgenommen.
7 | - | reserviert | 0bin
... | ... | ... | ...
15 | - | reserviert | 0bin

Das Feature-Register des IP/IE6022 legt die Betriebsart des Moduls fest.

Bit | Wert | Beschreibung | Default
0 | 0bin | Halbduplex: Der Empfang der gesendeten Daten wird unterdrückt | 0bin
 | 1bin | Vollduplex Gesendete Daten im RS485 Mode werden mitgehört
1 | - | reserviert | 0bin
2 | 0bin | nicht aktiv | 0bin
 | 1bin | aktiv: Das Status-Byte wird von dem Modul einen Zyklus später als die höherwertigen Datenbytes in die Schieberegister des IP-Link kopiert. Dadurch verringert sich die Datenübertragungsrate zur Steuerung.
3 | 0bin | nicht aktiv | 0bin
 | 1bin | aktiv: Das XON/XOFF-Protokoll wird von dem Modul beim Senden von Daten unterstützt, d.h. das Modul sendet die von der Steuerung übergebenen Daten, es sie das Zeichen XOFF (DC3==0x13) vom Partner empfängt. Das Senden wird daraufhin solange unterbunden bis das Zeichen XON (DC1==0x11) empfangen wird.
4 | 0bin | nicht aktiv | 0bin
 | 1bin | aktiv: Das XON/XOFF-Protokoll wird von dem Modul beim Daten-Empfang unterstützt. Das Modul sendet das Steuerzeichen XOFF, wenn 118 Zeichen im Buffer dem Modul stehen, XON wird gesendet, wenn vorher XOFF gesendet wurde und die Buffer-Grenze von 18-Byte unterschritten wurde.
5 | 0bin | Das Modul wird nach RS485 Norm in einer Busstruktur genutzt | 0bin
 | 1bin | Das Modul wird als Punkt zu Punkt Verbindung genutzt (RS 422). Das Modul schaltet die Datenleitung nicht hochohmig
6 | 0bin | nicht aktiv | 0bin
 | 1bin | aktiv: Kontinuierliches Senden der Daten aus dem Fifo. Über die Steuerung wird der Sendebuffer gefüllt (bis zu 16 Byte). Mit steigender Flanke im Control-Byte.3 wird der gefüllte Buffer-Inhalt gesendet. Sind die Daten übertragen, so wird dies durch das Setzen des Bits Status-Byte.2 von dem Modul an die Steuerung quittiert. Status-Byte.2 wird mit Control-Byte.3 zurückgenommen.
7-15 | - | reserviert | 0bin


Datenbyte-Register (R35) IP/IE60x2

Bestimmt die Anzahl der Daten-Bytes die zwischen Steuerung und Buskoppler/Feldbus Box übertragen werden.

Bit | Wert | Beschreibung | Default
0-7 | 1hex | 1 Byte | 5hex
 | 2hex | 2 Byte
 | 3hex | 3 Byte
 | 4hex | 4 Byte
 | 5hex | 5 Byte
8 | - | reserviert | 0bin
... | ... | ... | ...
15 | - | reserviert | 0bin


Signalverhalten bei Busfehlern

BECKHOFF Feldbus Box: Diagnose

Signalverhalten bei Busfehler

IP-Link-Fehler

Bei IP-Link-Fehler setzen

  • die digitalen Erweiterungsbox-Module ihre Ausgänge auf Null.
  • die analogen Erweiterungsbox-Module ihre Ausgänge auf Null oder den Anwender-Einschaltwert, falls dieser parametriert ist.

Feldbus-Fehler

Bei Ausfall des übergeordneten Feldbusses verhalten sich die Ausgänge der Erweiterungsbox-Module wie die Kopplerbox, an die sie angeschlossen sind.
Das Verhalten von Kopplerbox und Kompaktbox Modulen ist feldbusspezifisch (siehe Feldbus Box Dokumentation zum übergeordneten Feldbus) und abhängig von der Parametrierung.


Diagnose-LEDs

Fehlerdiagnose

Es gibt 2 Arten von Fehlern:

  • Feldbus Fehler
  • Lokaler Fehler auf Kompakt Box oder Koppler Box

Blink-Codes

Blinkfolge | Bedeutung
Schnelles Blinken | Anfang
erste langsame Sequenz | Fehler-Code
zweite langsame Sequenz | Fehler-Argument
dritte langsame Sequenz (optional) | Fehler-Argument bei mehr als 20 Erweiterungen

Flasching_codes.jpg (2840 Byte)

Anfang Fehler-Code Fehler-Argument


Diagnose-LEDs für lokale Fehler

Lokale Fehler in einer Koppler Box (IL230x-Bxxx/Cxxx)

Unter den lokalen Fehlern ist gemeint, das ein Fehler in der Feldbus Box oder dem IP-Link aufgetreten ist. IP-Link-Fehler sind meist durch unsachgemäßen Gebrauch der Lichtwellenleitung zurück zu führen.

LED grün | LED rot |  |  | Beschreibung | Abhilfe
aus | aus |  |  | kein Datenaustausch | Modul im synchron Mode - zyklische Daten aktivieren
aus | 1 | 0 |  | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
aus | 2 |  |  | reserviert | -
aus | 3 | n |  | Bruchstelle wurde erkannt | n-tes Modul vor dem Empfänger des Masters
 | 3 | n | m | Bruchstelle wurde erkannt | (n*10)+m-tes Modul vor dem Empfänger des Masters
aus | 4 | n |  | zu viele fehlerhafte Telegramme erkannt (mehr als 25%) | vor dem n-ten Erweiterungsmodul (vor dem Empfänger des Masters) ist die LWL-Verkabelung zu prüfen
aus | 5 | n |  | Registerzugriff auf komplexe Module gescheitert | n-tes Modul überprüfen
aus | 11 | n |  | Komplexes Modul arbeitet fehlerhaft | n-tes Modul tauschen
aus | 12 | n |  | mehr als 120 Module im Ring | weniger Module anschließen
aus | 13 | n |  | n-tes Modul unbekannt | Firmware Update erforderlich
an | aus |  |  | Modul ist im Datenaustausch (kein Fehler) | -
Hinweis Bei einer Unterbrechung der letzten IP-Link Verbindung vor der Koppler-Box kann statt des tatsächlichen Fehlerarguments 0 auch eine 1 zurückgemeldet werden, da durch die Empfängerschaltung eine eindeutige Identifikation nicht möglich ist. Ist mindestens ein Teilnehmer davor noch in Ordnung wird mindestens ein lesbares Telegramm empfangen.

Lokale Fehler in einer Erweiterungsbox

LED grün | LED rot | Beschreibung
aus | an | es werden kein Daten über den IP-Link empfangen
aus | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (sehr schlechte Datenverbindung)
blinkt, flackert | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (schlechte Datenverbindung), muss noch nicht zum Fehler führen
an | aus | es werden IP-Link Protokolle empfangen, kein Fehler

Fehlerhafte IP-Link Protokolle können entstehen durch:

  • schlecht konfektionierte IP-Link Steckverbinder
  • IP-Link Leitung mit erhöhter Dämpfung durch z.B. Knick o.ä.
  • defekte oder verschmutzte Sende LED (Modul vor dem fehlerhaften Modul)
  • defekter oder verschmutzter Empfänger

Der interne IP-Link-Fehlerzähler der Koppler Box kann mit der KS2000 Software ausgelesen werden.


Feldbus Box Zubehör

Das notwendige Zubehör für die Feldbus Box Module gibt es in Schutzklasse IP67 ebenfalls von Beckhoff. Eine Übersicht entnehmen Sie bitte aus dem Beckhoff Katalog oder unseren Internet-Seiten (http://www.beckhoff.de).

Feldbuszubehör

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Spannungsversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

Sensorversorgung

  • Vorkonfektionierte Kabel
  • Stecker
  • Verteiler

IP-Link

  • Vorkonfektionierte Kabel
  • Stecker


Feldbus Box - Zubehör

BECKHOFF Feldbus Box: Produktübersicht

Zubehör

Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder unbedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmomentsteckschlüssel mit Ratsche für angespritzte M8-Steckverbinder
ZB8800-0001 | Ratsche für feldkonfektionierbare M8-Steckverbinder
ZB8800-0002 | Ratsche für angespritzte M12-Steckverbinder
Hinweis
Weiteres Zubehör

Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter www.beckhoff.de.


Powerkabel

Bestelldaten

Bestellbezeichnung | Powerleitung | Schraub- Steckverbinder | Kontakte | Querschnitt | Länge
ZK2020-3200-0020 | Buchse gerade, offenes Ende | M8 | 4-polig | 0,34 mm2 | 2,00 m
ZK2020-3200-0050 |  |  |  |  | 5,00 m
ZK2020-3200-0100 |  |  |  |  | 10,00 m
ZK2020-3400-0020 | Buchse gewinkelt, offenes Ende |  |  |  | 2,00 m
ZK2020-3400-0050 |  |  |  |  | 5,00 m
ZK2020-3400-0100 |  |  |  |  | 10,00 m
ZK2020-3132-0001 | Buchse gerade, Stecker gerade |  |  |  | 0,15 m
ZK2020-3132-0005 |  |  |  |  | 0,50 m
ZK2020-3132-0010 |  |  |  |  | 1,00 m
ZK2020-3132-0020 |  |  |  |  | 2,00 m
ZK2020-3132-0050 |  |  |  |  | 5,00 m
ZK2020-3334-0001 | Buchse gewinkelt, Stecker gewinkelt |  |  |  | 0,15 m
ZK2020-3334-0005 |  |  |  |  | 0,50 m
ZK2020-3334-0010 |  |  |  |  | 1,00 m
ZK2020-3334-0020 |  |  |  |  | 2,00 m
ZK2020-3334-0050 |  |  |  |  | 5,00 m

Weitere verfügbare Powerkabel und die dazugehörigen Datenblätter finden Sie im Beckhoff Katalog oder auf unseren Internet-Seiten (http://www.beckhoff.de).

Technische Daten

Daten
Bemessungsspannung nach IEC61076-2-101 | 30 VDC
Verschmutzungsgrad nach IEC 60 664-1 | 3/2
Isolationswiderstand IEC 60 512-2 | >109 W
Strombelastbarkeit IEC 60512-3 | 4 A
Durchgangswiderstand IEC 60512-2 | < 5 mW
Schutzart nach IEC 60529 | IP65/66/67, im verschraubten Zustand
Umgebungstemperatur | -30°C bis +80°C


Third Party Produkte

Zum IP-Link des Feldbus Box Systems kompatible Produkte gibt es außer von Beckhoff auch von anderen Herstellern (Third Party).

Diese Produkte werden von Beckhoff nicht vertrieben. Bitte wenden Sie sich an den entsprechenden Hersteller.

Ventilinseln

FESTO

CPV10-IL-IP8 und CPV14-IL-IP8 von FESTO sind kompakte Ventilinseln mit direktem Interface an den IP-Link.

Im TwinCAT werden diese Module als IE4404-0010 bzw. IE4404-0014 abgebildet.

Weitere Informationen erhalten Sie im Internet unter http://www.festo.com.

SMC

Das EX250 von SMC ist eine modulare Ventilinsel mit direktem Interface an den IP-Link.

Im TwinCAT wird dieses Modul als IE4414 abgebildet.

Weitere Informationen erhalten Sie im Internet unter http://www.smceu.com.


Allgemeine Betriebsbedingungen

Schutzarten nach IP-Code

In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.

1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub

2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist

*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.

Chemische Beständigkeit

Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus Box und den verwendeten Metallteilen.

Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende

beständig: Lebensdauer mehrere Monate
bedingt beständig: Lebensdauer mehrere Wochen
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zulassungen

UL E172151

Konformitätskennzeichnung

CE

Schutzart

IP65/66/67 gemäß EN60529


Feldbus Box - UL-Anforderungen

BECKHOFF Feldbus Box: Montage und Verkabelung

UL-Anforderungen

Die Installation der nach UL zertifizierten Feldbus Box Module muss den folgenden Anforderungen entsprechen.

Versorgungsspannung

Achtung Zur Einhaltung der UL-Anforderungen dürfen die Feldbus Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
  • von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
  • von einer Spannungsquelle die NEC class 2 entspricht stammt.
    Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller so gekennzeichneten Feldbus Box Module.
Achtung Zur Einhaltung der UL-Anforderungen dürfen die Feldbus Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!

Netzwerke

Achtung Zur Einhaltung der UL-Anforderungen dürfen die Feldbus Box Module nicht mit Telekommunikations-Netzen verbunden werden!

Umgebungstemperatur

Achtung Zur Einhaltung der UL-Anforderungen dürfen die Feldbus Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!

Kennzeichnung für UL

Alle nach UL (Underwriters Laboratories) zertifizierten Feldbus Box Module sind mit der folgenden Markierung gekennzeichnet:


Prüfnormen für die Geräteprüfung

EMV

Festigkeit: EN 61000-6-2

Aussendung: EN 61000-6-4

Vibrationsfestigkeit

Schwingungsprüfung: EN 60068-2-2, Amplitude 2 g (Norm 1 g)

Schockprüfung: EN 60068-2-27, Schockanzahl 1000 (Norm 2)


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Ausgangsleistung (Derating), IP/IE2512

Beim Einsatz der PWM-Module Hardwarestand D.xxxxxx00 ist die Verlustleistung innerhalb des Moduls zu berücksichtigen.

Sie setzt sich aus drei Komponenten zusammen und darf insgesamt max. 1W betragen (P = PI + Pf + PL):

  1. stromabhängige Verluste
    PI = Imax2 x 0,15 Ohm
  2. frequenzabhängige Verluste
    Pf = U x Imax x 10-6sec x f
  3. induktive Rückspeisung
    PL = Imax2 x L / (2 x f)

Legende
Imax: maximaler Ausgangsstrom (Duty-Cycle berücksichtigen)
U: Ausgangs-Spannung
f : Frequenz
L: Induktivität

Die induktive Komponente wird über eine interne Diode mit 39 V abgebaut. Durch eine externe Schottky-Diode mit entsprechender Verlustleistung und Spannung (min. 45 V), kann die Energie außerhalb des Moduls umgesetzt werden. Der Anschluss erfolgt mit Kathode an Pin 4, Anode an Pin 3.

Zur Veranschaulichung die möglichen Frequenzen in Abhängigkeit des Ausgangsstroms (für verschiedene Duty-Cycle).

Derating ohne induktive Komponente

Derating bei 1 mH induktiver Belastung


Temperature °F/°C

Feldbus Box: Analoge Eingänge Temperatur

Anwenderskalierung

Um das Modul auf Fahrenheit umzustellen müssen Sie die Formel umrechnen und die Anwender-Register beschreiben.

Formel:
°F = 9/5 x °C + 32

Zur Einstellung der Skalierung auf 1/10 °F wird der konstante Teil (Offset) mit 10 multipliziert.
Das bedeutet :

  • für den Offset 32 *10 =320
  • für den Gain (9/5 *10/16 *256) = 288

Nötige Registereinstellungen:

  • R31 Codewort setzen = 0x1235
  • R32 Herstellerskalierung deaktivieren
  • R32 Anwenderskalierung aktivieren
  • R33 Anwender Offset = 320dez
  • R34 Anwender Gain = 288dez

Die Änderungen der Skalierung sind sofort gültig und sind für jeden Kanal separat einstellbar.