FC90xx - PCI-Karten für Ethernet

BECKHOFF Feldbuskomponenten

Dokumentation zu

FC9001, FC9001-0010, FC9011, FC9002 and FC9004

PCI-Karten für Ethernet

Version: 1.2
Datum: 19.01.2009


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist. Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Haftungsbedingungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Die Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiterentwickelt. Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft. Keine der in diesem Handbuch enthaltenen Erklärungen stellt eine Garantie im Sinne von § 443 BGB oder eine Angabe über die nach dem Vertrag vorausgesetzte Verwendung im Sinne von § 434 Abs. 1 Satz 1 Nr. 1 BGB dar. Falls sie technische Fehler oder Schreibfehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung durchzuführen. Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte gemacht werden.

Copyright

© Diese Dokumentation ist urheberrechtlich geschützt. Jede Wiedergabe oder Drittverwendung dieser Publikation, ganz oder auszugsweise, ist ohne schriftliche Erlaubnis der Beckhoff Automation GmbH verboten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


FC90xx - Ausgabestände der Dokumentation

BECKHOFF FC90xx: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
1.2
  • FC9001-0010, FC9011 hinzugefügt
1.1
  • Treiberaustausch mit Hilfe des TwinCAT System-Managers hinzugefügt
  • Beschreibung der Aktivierung des TwinCAT Ethernet Protokolls aktualisiert
1.0 | erste Veröffentlichung


FC90xx - Einführung

PCI-Karten für Ethernet

Bis zu vier Ethernet-Kanäle auf einem Steckplatz: die Ethernet-PCI-Netzwerkkarten von Beckhoff sparen Platz und Kosten. Sie sind in Büro- und Automatisierungsnetzwerken einsetzbar und bieten folgende Vorteile:

  • Kompatibel zu EtherCAT und Beckhoff RealTime-Ethernet
  • Plug-and-Play-Interface
  • 10/100 MBaud bzw. 10/100/1000 MBaud (FC9011)
  • kanalweise automatische Baudrateneinstellung nach IEEE 802.3u bzw. IEEE 802.3ab (FC9011)
  • Vollduplex-Betrieb
  • maximale Performance durch hardwareintegrierte Checksummenbildung und -überprüfung
  • Quality-of-Service (QoS) Dienste durch priorisierte Mehrfach-Queues werden hardwareseitig unterstützt


FC90xx - Technische Daten

Technische Daten | FC9001 | FC9001-0010 | FC9011 | FC9002 | FC9004
Bussystem | Ethernet (sämtliche auf IEEE 802.3 basierende Protokolle)
Anzahl der Ethernet-Kanäle | 1 | 1 | 1 | 2 | 4
Ethernet-Interface | 10BASE-T / 100BASE-TX Ethernet |  | 10BASE-T / 100BASE-TX/ 1000BASE-TX Ethernet | 10BASE-T / 100BASE-TX Ethernet
Ethernet-Stecker | 1 x RJ45 |  |  | 2 x RJ45 | 4 x RJ45
Leitungslänge | maximal 100 m bis zum Hub, Switch oder Endgerät
Baudrate | 10/100 MBit/s, IEEE 802.3u Auto-Negotiation, Vollduplex bei 10 oder 100 MBit/s |  | 10/100/1000 MBit/s, IEEE 802.3ab Auto-Negotiation, Vollduplex bei 10, 100 oder 1000 MBit/s | 10/100 MBit/s, IEEE 802.3u Auto-Negotiation, Vollduplex bei 10 oder 100 MBit/s, Einstellungen kanalweise
Diagnose | 2 LEDs je Kanal: - Link - Activity
Interface zum PC | 32 Bit Plug-and-Play PCI-Interface
Standard-Treiber | Standard Betriebssystem-Treiber für Intel-kompatible NIC |  |  | Standard-Treiber für Intel 8255xER Serie oder BECKHOFF Treiber für Windows 2000/XP (Treiberauswahl kanalweise möglich)
Echtzeit-Treiber | TwinCAT-Treiber für Echtzeit Ethernet
Versorgungsspannung (PCI-Bus) | 5 V
Stromaufnahme (PCI-Bus, 5 V) | typisch 250 mA | typisch 200 mA | typisch 300 mA | typisch 800 mA | typisch 1200 mA
Gewicht | ca. 45 g | ca. 45 g | ca. 45 g | ca. 75 g | ca. 95 g
Abmessungen (B x H x T, ohne Slot-Blende)) | ca. 14 mm x 51 mm x 120 mm | ca. 18 mm x 45 mm x 120 mm |  | ca. 18 mm x 95 mm x 125 mm
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | beliebig
Zulassung | CE


Ethernet

Ethernet wurde ursprünglich von DEC, Intel und Xerox (als DIX-Standard) für die Datenübertragung zwischen Bürogeräten entwickelt. Heute versteht man darunter meist die Spezifikation IEEE 802.3 CSMA/CD, die 1985 veröffentlicht wurde. Diese Technologie ist durch ihren weltweiten Einsatz und die hohen Stückzahlen überall erhältlich und sehr preiswert.. Eine Anbindung an vorhandene Netze kann so problemlos realisiert werden.

Mittlerweile gibt es die verschiedensten Übertragungsmedien: Koaxialkabel (10Base5), Lichtwellenleiter (10BaseF) oder verdrillte Zweidrahtleitung (10BaseT) mit Schirmung (STP) oder ohne Schirmung (UTP). Mit Ethernet lassen sich verschieden Topologien aufbauen wie Ring, Linie oder Stern.

Ethernet transportiert Ethernet-Pakete von einem Sender zu einem oder mehreren Empfängern. Diese Übertragung verläuft ohne Quittung und ohne Wiederholung von verlorenen Paketen. Für die sichere Daten-Kommunikation stehen Protokolle wie TCP/IP zu Verfügung, die auf Ethernet aufsetzen.

Grundlagen

Internet-Protokoll (IP)

Die Grundlage der Datenkommunikation ist das Internet-Protokoll (IP). IP transportiert Datenpakete von einem Teilnehmer zu einem anderen, der sich im gleichen oder in einem anderen Netz befinden kann. IP kümmert sich dabei um das Adress-Management (Finden und Zuordnen der MAC-IDs), die Segmentierung und die Pfadsuche (Routing). Wie das Ethernet-Protokoll gewährleistet auch IP keinen gesicherten Transport der Daten; Datenpakete können verloren gehen oder in ihrer Reihenfolge vertauscht werden.

Für einen standardisierten, gesicherten Informationsaustausch zwischen beliebig vielen verschiedenen Netzwerken wurde TCP/IP entwickelt. Dabei ist TCP/IP weitgehend unabhängig von der verwendeten Hard- und Software. Oftmals als ein Begriff verwendet, handelt es sich hierbei um mehrere aufeinander aufgesetzte Protokolle: z.B. IP, TCP, UDP, ARP und ICMP.

Transmission Control Protocol (TCP)

Das auf IP aufsetzende Transmission Control Protocol (TCP) ist ein verbindungsorientiertes Transport-Protokoll. Es umfasst Fehlererkennungs- und Behandlungsmechanismen. Verlorengegangene Telegramme werden wiederholt.

User Datagram Protocol (UDP)

UDP ist ein verbindungsloses Transport-Protokoll. Es gibt keine Kontrollmechanismen beim Datenaustausch zwischen Sender und Empfänger. Dadurch resultiert eine schneller Verarbeitungsgeschwindigkeit als zum Beispiel bei TCP. Eine Prüfung ob das Telegramm angekommen ist muss vom übergeordneten Protokoll durchgeführt werden.

Internet Control Message Protocol (ICMP)

Dient dem Informationsaustausch der Endgeräte über den aktuellen Status des Internet-Protokolls.

Address Resolution Protocol (ARP)

Dient der Umwandlung zwischen IP-Adressen und MAC-Adressen.

BootP

Das BootP-Protokoll ermöglicht das Einstellen und Ändern der TCP/IP-Adresse indem der Netzwerk-Teilnehmer mit der MAC-ID angesprochen wird.


FC90xx - Einbau in den PC

BECKHOFF FC90xx: Installation

Einbau in den PC

Achtung Die Ethernet-Karten werden in einer ESD-Verpackung ausgeliefert. Beachten Sie beim Einbau die für den Umgang mit PC-Karten üblichen ESD-Vorschriften!
  1. Schalten Sie vor dem Einbau der Ethernet-Karte den PC und eventuelle externe Spannungsversorgungen aus und trennen Sie den PC vom Stromnetz.
  2. Öffnen Sie das Gehäuse des PCs.
  3. Entfernen Sie an einem freien PCI-Steckplatz des Motherboards das Verschlussblech in der Gehäusewand Ihres PCs.
  4. Stecken Sie die Ethernet-Karte in den freien PCI-Steckplatz und fixieren Sie sie mit der dafür vorgesehenen Schraube oder Vorrichtung.
    Achten Sie darauf, das zwischen der Ethernet-Karte und anderen PC-Komponenten genügend Abstand vorhanden ist, so dass die Ethernet-Karte keine anderen Steckkarten, Speicherbausteine usw. berühren kann.
  5. Schließen Sie das Gehäuse des PCs.
  6. Schließen Sie die Ethernet-Leitung an eine RJ45-Buchse der Ethernet-Karte an:
  7. Verbinden Sie den PC mit dem Stromnetz und schalten Sie den PC ein.
  8. Nach Hochlauf des Betriebssystems wird die Ethernet-Karte als neue Hardware erkannt. Folgen Sie den Anweisungen des Assistenten Treiber für die Ethernet-Karte zu installieren.
  9. Falls Sie den TwinCAT-Treiber für Echtzeit-Ethernet und EtherCAT verwenden möchten, müssen Sie nun
    - TwinCAT installieren
    - den Treiber installieren bzw. ändern

Die Ethernet-Karte benötigt keine externe Spannungsversorgung. Sie wird direkt vom PC über den PCI-Bus gespeist. Die Stromversorgung des PCs muss insbesondere beim Betrieb mehrerer Ethernet-Karten ausreichend bemessen sein, um den Strombedarf der Ethernet-Karten zu decken.


FC90xx - TwinCAT-Treiber für Ethernet-Karten

BECKHOFF FC90xx: Installation

TwinCAT-Treiber für Ethernet-Karten

Hinweis Installieren Sie vor dem Einbau der Beckhoff Ethernet-Karte die Beckhoff Automatisierungs-Software TwinCAT.

Treiberübersicht

TwinCAT stellt zwei verschiedene Treiber für Ethernet-Karten zur Verfügung:

  • TwinCAT-Treiber für Echtzeit-Ethernet
  • TwinCAT RT-Ethernet Intermediate Driver
TwinCAT-Treiber für Echtzeit-Ethernet

Der TwinCAT-Treiber für Echtzeit-Ethernet funktioniert nur mit Ethernet-Karten mit Intel-Chipsatz!

Er unterstützt harte Echtzeit für Beckhoff Realtime-Ethernet- und EtherCAT-Anwendungen.

TwinCAT RT-Ethernet Intermediate Driver

Der TwinCAT RT-Ethernet Intermediate Driver funktioniert auch mit Ethernet-Karten ohne Intel-Chipsatz.

Er ist ein Evaluierungs-Treiber für den Labor- und Testbetrieb, um TwinCAT auch mit anderen Netzwerkadaptern ohne Intel-Chipsatz testen zu können.
Er stellt keine harte Echtzeit zur Verfügung und kann Jitter verursachen!

Weitere Informationen zum TwinCAT RT-Ethernet Intermediate Driver finden Sie im TwinCAT Information System.

Installation des TwinCAT-Treiber für Echtzeit-Ethernet

Es gibt drei Wege den TwinCAT-Treiber für Echtzeit-Ethernet auf Ihrem PC zu installieren:

  • Treiberinstallation mit Hilfe des Windows Hardware-Assistenten:
    Das ist der übliche weg um Treiber zu installieren.
  • Treiberaustausch über den TwinCAT-System Manager:
    Falls Ihr Betriebssystem einen eigenen Treiber für die Beckhoff Intel PCI-Ethernet Adapter installiert hat, können Sie mit Hilfe des TwinCAT-System-Managers diesen Treiber durch den TwinCAT-Treiber für Echtzeit-Ethernet ersetzen ,um die Echtzeitfähigkeit nutzen zu können.
  • Manuelle Treiberinstallation:
    Falls Ihr Betriebssystem einen eigenen Treiber für die Beckhoff Intel PCI-Ethernet Adapter installiert hat, können Sie den TwinCAT-Treiber für Echtzeit-Ethernet manuell installieren, um die Echtzeitfähigkeit nutzen zu können.


FC90xx - Treiberinstallation mit Hilfe des Hardwareassistenten

BECKHOFF FC90xx: Installation

Treiberinstallation mit Hilfe des Hardwareassistenten

Hinweis Installieren Sie vor dem Einbau der Beckhoff Ethernet-Karte die Beckhoff Automatisierungs-Software TwinCAT.
Hinweis Alle Screen-Shots dieser Beschreibung wurden unter Windows 2000 erstellt.
Unter Windows XP wird der TwinCAT-Treiber für Echtzeit-Ethernet auf die gleiche Weise installiert.

Nach Einbau der Beckhoff Ethernet-Karte meldet sich z.B. Windows 2000 beim Hochlauf mit folgenden Meldungen:

Folgen Sie den Anweisungen des Hardwareassistenten.

Lassen Sie den Assistenten nach einem passenden Treiber suchen.

Der TwinCAT-Treiber für Echtzeit-Ethernet ist im Lieferumfang der Beckhoff Automatisierungs-Software TwinCAT enthalten.

Wenn Sie die Beckhoff Automatisierungs-Software TwinCAT vor dem Einbau der Beckhoff Ethernet-Karte installiert haben, wird der Hardware-Assistent den TwinCAT-Treiber für Echtzeit-Ethernet auf der Festplatte ihres PCs (in der Treiberdatenbank) finden!

Für den einwandfreien Betrieb des TwinCAT-Treibers für Echtzeit-Ethernet ist keine digitale Signatur von Microsoft erforderlich.
Beckhoff hat diesen Treiber in Verbindung mit der unterstützten Hardware gründlich getestet und die Kompatibilität mit Windows 2000 und XP überprüft.
Klicken Sie auf Ja um die Installation fortzuführen.

Der TwinCAT-Treiber für Echtzeit-Ethernet wurde für einen Ethernet-Port erfolgreich installiert. Beenden Sie die Installation mit Fertig stellen!

Falls sie eine mehrkanalige Beckhoff Ethernet-Karte verwenden, wiederholt sich die Installation des Treibers für jeden weiteren Kanal:

Aktivieren Sie nun das TwinCAT-Ethernet-Protokoll.

Ressourcen

Beispiel für die Ressourcen einer FC900x unter Windows 2000.
(Systemsteuerung/System/Hardware/Gerätemanager/Netzwerkadapter/TwinCAT Intel PCI-Ethernet Adapter/Resourcen):


FC90xx - Treiberaustausch mit Hilfe des TwinCAT System-Managers

BECKHOFF FC90xx: Installation

Treiberaustausch mit Hilfe des TwinCAT System-Managers

Hinweis Installieren Sie vor dem Einbau der Beckhoff Ethernet-Karte die Beckhoff Automatisierungs-Software TwinCAT.
Hinweis Alle Screen-Shots dieser Beschreibung wurden unter Windows 2000 erstellt.
Unter Windows XP wird der TwinCAT-Treiber für Echtzeit-Ethernet auf die gleiche Weise installiert.

Klicken Sie in der Windows-Task-Leiste rechts unten auf das TwinCAT-Symbol und starten Sie den TwinCAT System-Manger.

Klicken Sie im Menü Optionen auf Liste Echtzeit Ethernet kompatibler Geräte.

Der TwinCAT System-Manager zeigt nun die echtzeitfähigen (Compatible devices) und nicht echtzeitfähigen (Incompatible devices) Netzwerkadapter an.

Wählen Sie einen echtzeitfähigen Netzwerkadapter aus und klicken Sie auf die Schaltfläche Install.

Der TwinCAT System-Manager installiert nun für das Ausgewählte Gerät den TwinCAT-Treiber für Echtzeit-Ethernet und das TwinCAT-Ethernet-Protokoll.

Für den einwandfreien Betrieb des TwinCAT-Treibers für Echtzeit-Ethernet ist keine digitale Signatur von Microsoft erforderlich.
Beckhoff hat diesen Treiber in Verbindung mit der unterstützten Hardware gründlich getestet und die Kompatibilität mit Windows 2000 und XP überprüft.
Klicken Sie auf Ja um die Installation fortzuführen.

Der TwinCAT-Treibers für Echtzeit-Ethernet und das zugehörige TwinCAT-Ethernet-Protokoll wurden installiert.

Aktivieren Sie die Check-Box Show Bindings um das verbundene Protokoll anzuzeigen.


FC90xx - Manuelle Treiberinstallation

BECKHOFF FC90xx: Installation

Manuelle Treiberinstallation

Falls Ihr Betriebssystem einen eigenen Treiber für die Beckhoff Intel PCI-Ethernet Adapter installiert hat, müssen Sie den TwinCAT-Treiber für Echtzeit-Ethernet manuell installieren um die Echtzeitfähigkeit nutzen zu können.

Hinweis Installieren Sie vor der manuellen Installation TwinCAT-Treiber für Echtzeit-Ethernet die Beckhoff Automatisierungs-Software TwinCAT!

Nach Installation der Beckhoff Automatisierungs-Software TwinCAT können sie den TwinCAT-Treiber für Echtzeit-Ethernet manuell installieren.

Hinweis Alle Screen-Shots dieser Beschreibung wurden unter Windows 2000 erstellt.
Unter Windows XP wird der TwinCAT-Treiber für Echtzeit-Ethernet auf die gleiche Weise installiert.

Klicken Sie sie unter Start/Einstellungen/Systemsteuerung/System auf Netzwerk- und DFÜ-Verbindungen.

Klicken Sie auf eine noch nicht benutzte LAN-Verbindung (im Beispiel LAN-Verbindung 2).

Die Eigenschaften der LAN-Verbindung 2 werden angezeigt.

Klicken Sie auf die Schaltfläche Konfigurieren.

Wechseln Sie auf den Karteireiter Treiber, klicken Sie auf die Schaltfläche Treiber aktualisieren und folgen Sie den Anweisungen des Hardwareassistenten!

Lassen Sie Alle für das Gerät bekannten Treiber in einer Liste anzeigen um den entsprechenden Treiber selbst auszuwählen!

Wenn Sie zuvor die Beckhoff Automatisierungs-Software TwinCAT installiert haben, wird ihnen der Hardware-Assistent auch den TwinCAT-Treiber für Echtzeit-Ethernet anbieten.

Wählen Sie den TwinCAT-Treiber für Echtzeit-Ethernet!

Starten Sie die Installation des ausgewählten Treibers.

Für den einwandfreien Betrieb des TwinCAT-Treibers für Echtzeit-Ethernet ist keine digitale Signatur von Microsoft erforderlich.
Beckhoff hat diesen Treiber in Verbindung mit der unterstützten Hardware gründlich getestet und die Kompatibilität mit Windows 2000 und XP überprüft.
Klicken Sie auf Ja um die Installation fortzuführen.

Der TwinCAT-Treiber für Echtzeit-Ethernet wurde erfolgreich installiert. Beenden Sie die Installation mit Fertig stellen!

Aktivieren Sie nun das TwinCAT-Ethernet-Protokoll.

Ressourcen

Beispiel für die Ressourcen einer FC900x unter Windows 2000.
(Systemsteuerung/System/Hardware/Gerätemanager/Netzwerkadapter/TwinCAT Intel PCI-Ethernet Adapter/Resourcen):


FC90xx - Aktivierung des TwinCAT-Ethernet-Protokolls

BECKHOFF FC90xx: Installation

Aktivierung des TwinCAT-Ethernet-Protokolls

Um Echtzeit verwenden zu können muss für den Beckhoff Intel PCI-Ethernet Adapter das TwinCAT-Ethernet-Protokolls aktiviert werden!

Klicken Sie sie unter Start/Einstellungen/Netzwerk und DFÜ-Verbindungen die LAN-Verbindung an, für die Sie TwinCAT-Ethernet-Protokolls aktivieren möchten (im Beispiel LAN-Verbindung 2).

Klicken Sie auf die Schaltfläche Installieren!

Wählen Sie die Protokoll (nicht Service!) und klicken Sie auf die Schaltfläche Hinzufügen!

Wählen Sie unter Beckhoff die Option TwinCAT Ethernet Protocol aus und klicken Sie auf OK!

Hinweis Falls das Beckhoff TwinCAT-Ethernet-Protokoll nicht zur Auswahl steht, obwohl sie TwinCAT und den TwinCAT-Treiber für Echtzeit-Ethernet installiert haben, klicken Sie auf Datenträger, dann auf Durchsuchen und wählen Sie im Ordner C:\Windows\inf die Datei TcEther.inf aus.
Falls der Ordner C:\Windows\inf nicht angezeigt wird müssen Sie im Windows-Explorer unter Extras/Ordneroptionen/Ansicht folgende Optionen aktivieren:
- Inhalte von Systemordnern anzeigen
- Versteckte Dateien und Ordner - Alle Dateien und Ordner anzeigen
Achtung

Zur Steuerung realer Anlagen wählen Sie unbedingt das TwinCAT Ethernet Protocol und nicht das TwinCAT Ethernet Protocol for all Network Adaptors!

Das TwinCAT Ethernet Protocol for all Network Adaptors ist nur ein Evaluierungs-Protokoll um TwinCAT auch auch mit anderen Netzwerkadaptern ohne Intel-Chipsatz testen zu können. Es stellt keine harte Echtzeit zur Verfügung und kann Jitter verursachen!

Nun sollte das TwinCAT-Ethernet-Protokoll in der Liste der Komponenten angezeigt werden.

Um das TwinCAT Ethernet Protocol zu Starten können sie in einer DOS-Eingabeauffprderung den Befehl net start TcEther absetzen oder nun den PC neu starten. Das TwinCAT Ethernet Protocol wird von nun an bei jedem Neustart des PCs gestartet!


FC90xx - Geräte suchen

BECKHOFF FC90xx: Anfügen von Komponenten

Geräte suchen

  1. Schalten Sie TwinCAT in den Konfigurations-Modus.
  2. Starten Sie den TwinCAT System-Manager.
  3. Starten Sie mit der rechten Maustaste unter dem Baumzweig E/A-Konfiguration \ E/A-Geräte oder mit der Zauberstab-Schaltfläche in der Button-Leiste die Suche nach neuen Geräten.

Der System-Manager sucht nun nach im PC eingebauten E/A-Geräten (z.B. Feldbuskarten).

Im dargestellten Beispiel werden die Kanäle der FC9004, für die
- der TwinCAT-Treiber für Echtzeit-Ethernet installiert und
- das TwinCAT Ethernet Protokoll aktiviert ist
als Gerät 1 und Gerät 2 angezeigt.

Der System-Manager will nun an den Kanälen der FC9004 nach Boxen (Buskopplern, Busklemmen Controllern oder Feldbus Box Modulen) suchen.

Der System Manager möchte nun den Free Run Modus aktivieren. Klicken Sie auf Ja.

Der System Manager zeigt nun die gefundene Konfiguration an:


FC90xx - Konfiguration mit TwinCAT System Manager

BECKHOFF FC90xx: Konfiguration

Konfiguration mit TwinCAT System Manager

Klicken Sie im linken Fenster des TwinCAT System Managers auf den Ethernet-Kanal den Sie konfigurieren möchten (im Beispiel: Gerät 2 (RT-Ethernet)).

Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter
- Allgemein
- Adapter
- EtherCAT
- Statistik
- Diagnose
zur Konfiguration dieses Ethernet-Kanals zur Verfügung.

Hinweis Der System-Manager nummeriert die Ethernet-Kanäle (Gerät 1, Gerät 2 ...) in der Reihenfolge, in der er sie als betriebsbereit für Echtzeit-Ethernet erkennt. Diese Nummerierung muss nicht zur Nummerierung der LAN-Verbindungen in den Netzwerkverbindungen der Windows-Systemsteuerung oder zur Nummerierung der RJ45-Buchsen auf der FC900x (X1, X2 ...) korrespondieren.

Sie können die Kanäle einer FC9002/FC9004 aber anhand ihrer eindeutigen MAC-Adressen identifizieren.


FC90xx - Karteireiter Allgemein

BECKHOFF FC90xx: Konfiguration

Karteireiter Allgemein

Name

Der Name Gerät 2 (RT-Ethernet) wurde vom System-Manager vergeben. Sie können ihn ändern.

Typ

Gerätetyp

Kommentar

Hier können Sie einen freien Kommentartext hinterlegen.

Disabled

Mit diesem Kontrollkästchen können Sie den Ethernet-Kanal abschalten.

Symbole erzeugen

Wenn dieses Kontrollkästchen aktiviert ist, können Sie auch über Namen auf die Variablen zugreifen, was aber mehr Speicher belegt.


FC90xx - Karteireiter Adapter

BECKHOFF FC90xx: Konfiguration

Karteireiter Adapter

Beschreibung

Zeigt die Nummer der LAN-Verbindung und des Desktop Adapters des benutzten Ethernet-Kanals an.

Gerätename

Zeigt den Windows-Gerätenamen des benutzten Ethernet-Kanals an.

MAC-Adresse

Zeigt die eindeutige MAC-Adresse des benutzten Ethernet-Kanals.

IP-Adresse

Zeigt die IP-Adresse des benutzten Ethernet-Kanals.

Free Run Zyklus

Hier können Sie die Zykluszeit für den Free Run Modus vorgeben.

E/A sperren nach Link-Fehler (Verbindungsfehler)

Bei aktiviertem Kontrollkästchen wird nach einem behobenem Link-Fehler (z.B. nach Abziehen und Wiederaufstecken des Netzwerkkabels) der Prozessdatenaustausch nicht automatisch wieder gestartet, sondern es ist zuvor ein E/A-Reset notwendig.

Promiscuous Mode (use with Netmon only)

Bei aktiviertem Kontrollkästchen werden die Ethernet-Telegramme des TwinCATs auch zum Windows übertragen und können so mit einem Netzwerkmonitor (z.B. Etherreal oder MS Netzwerkmonitor) ausgewertet werden.

Verbose Mode (for testing only)

In Vorbereitung

No Jitter Mode (for testing only)

In Vorbereitung

Compatible Devices

Klicken Sie auf Compatible Devices um die in Ihrem PC gefundenen TwinCAT-kompatiblen Ethernet-Geräte anzuzeigen.

TwinCAT Ethernet Protokoll installiert

Dieses Kontrollkästchen zeigt an, ob der TwinCAT Protokoll Treiber bereits installiert ist.

Installierte benutzbare Geräte

Für die hier angezeigten Feldbuskarten/Feldbuskartenkanäle ist
- der TwinCAT-Treiber für Echtzeit-Ethernet installiert und
- das TwinCAT Ethernet-Protokoll aktiviert

Diese Geräte sind für Echtzeit-Ethernet betriebsbereit.

Installierte Geräte ohne notwendiges Binding zu TwinCAT Ethernet

Für die hier angezeigten Feldbuskarten/Feldbuskartenkanäle ist
- zwar der TwinCAT-Treiber für Echtzeit-Ethernet installiert
- aber das TwinCAT Ethernet-Protokoll noch nicht aktiviert

Aktivieren Sie das TwinCAT Ethernet Protokoll um diese Geräte für Echtzeit-Ethernet betriebsbereit zu machen.

Kompatible Geräte mit inkompatiblem Treiber

Für die hier angezeigten Feldbuskarten/Feldbuskartenkanäle ist
- weder der TwinCAT-Treiber für Echtzeit-Ethernet installiert
- noch das TwinCAT Ethernet-Protokoll noch nicht aktiviert

Installieren Sie den TwinCAT-Treiber für Echtzeit-Ethernet und aktivieren Sie das TwinCAT Ethernet-Protokoll um diese Geräte für Echtzeit-Ethernet betriebsbereit zu machen.

Achtung Der Vorteil, dass TwinCAT Echtzeit-Ethernet auf Standard-Hardware zurückgreift, hat auch einen kleinen Nachteil: Windows kennt diese Standard-Hardware, versucht beim Windows Update oder beim Installieren eines Service Packs die neuesten, seiner Meinung nach "besten" Treiber für diese Hardware zu installieren und kann so den TwinCAT Treiber für Echtzeit-Ethernet überschreiben.

Abhilfe:
Das automatische Windows Update lässt sich abschalten und bei manuellen Updates sollten Sie dem Vorschlag, den Intel Networking Driver auszutauschen nicht folgen.
Nach der Installation eines Service Packs müssen Sie den TwinCAT-Treiber für Echtzeit-Ethernet erneut installieren und das TwinCAT Ethernet-Protokoll wieder aktivieren.

Mit der Maske TwinCAT Ethernet kompatible Geräte können Sie jederzeit die Betriebsbereitschaft von TwinCAT Echtzeit-Ethernet überprüfen.


FC90xx - Karteireiter EtherCAT

BECKHOFF FC90xx: Konfiguration

Karteireiter EtherCAT

Net ID

Zeigt die AMS Net-ID.

Start up to

Mit diesem Optionsfeld können Sie festlegen, welcher EtherCAT-Systemzustand nach dem Einschalten aktiviert werden soll:
INIT: Initiate
PRE-OP: Pre Operation
SAFE-OP: Safe Operation
OP: Operation

Export Configuration File

Mit dieser Schaltfläche können Sie die Konfigurations-Informationen in einer XML-Datei abspeichern um sie z.B. mit einem anderen Master-System einzulesen.

Virtual Ethernet Switch

In Vorbereitung

Anzeigefenster

Zeigt den Aufbau der EterCAT-Frames mit den aufgerufenen Kommandos.


FC90xx - Karteireiter Statistik

BECKHOFF FC90xx: Konfiguration

Karteireiter Statistik

Sent Frames

Zeigt die Anzahl der gesendeten EtherCAT-Frames und die Anzahl der gesendeten Frames pro Sekunde.

Recv Frames

Zeigt die Anzahl der empfangenen EtherCAT-Frames und die Anzahl der empfangenen Frames pro Sekunde.

Missed Frames

Schleppzeiger, der die Anzahl der verlorenen EtherCAT-Frames anzeigt.

Tc Mode

Zeigt den TwinCAT-Mode.


FC90xx - Karteireiter Diagnose

BECKHOFF FC90xx: Konfiguration

Karteireiter Diagnose

State

INIT: Initiate
PRE-OP: Pre Operation
SAFE-OP: Safe Operation
OP: Operation

CRC A

Cyclic Redundancy Check am ankommenden EtherCAT-Anschluss.

CRC B

Cyclic Redundancy Check am weiterführenden EtherCAT-Anschluss.

CRC C

Cyclic Redundancy Check am abzweigenden EtherCAT-Anschluss (falls vorhanden).


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.