FC750x - PCI-Karten für SERCOS
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Systembeschreibung
•
Hardware
•
Technische Daten


Systembeschreibung

Produktübersicht [image] Systembeschreibung
Systembeschreibung
SERCOS ist ein offenes, schnelles Bussystem, das seit 1995 internationale Norm (IEC 61491) für numerisch gesteuerte Maschinen ist. Die Erfüllung hoher Echtzeitanforderungen und die störsichere Übertragung in Lichtwellenleitertechnologie (LWL) sind wesentliche Merkmale dieses Bussystems, dessen Einsatz ist in der Antriebstechnik weit verbreitet ist. Der Bus besteht aus einem Master und mehreren Slaves. Die Slaves stellen bei SERCOS die Servoverstärker oder der SERCOS-Buskoppler BK7500 dar.
SERCOS interface LWL-Ring
Die Bustopologie ist ein Ring-System, an dem bis zu 254 Stationen betrieben werden. Die Übertragungsgeschwindigkeit beträgt 2, 4, 8 oder 16 MBit/s. Grundsätzlich gibt es drei Telegrammarten:
1.
Das Master-Sync-Telegramm wird von allen Slaves empfangen und dient der Synchronisation.
2.
Das Master-Datentelegramm wird ebenfalls von allen Slaves empfangen und enthält die zyklischen Daten und die Servicedaten.
3.
Die Slaves senden ihre Daten als Antriebstelegramm.
PC-Feldbuskarten für SERCOS interface
Speziell für SERCOS interface entwickelte Beckhoff die Feldbuskarten FC7501 (1-Kanal) und FC7502 (2-Kanal) mit PCI-Interface. Der in der Automatisierungssoftware TwinCAT integrierte Treiber sorgt für eine optimale Performance dieser passiven Masterkarten, so dass dem Anwender im Vergleich zu einer aktiven Lösung keinerlei unnötige Beschränkungen bezüglich Teilnehmerzahl oder Datenlänge entstehen. Es lassen sich auch größere SERCOS-Projekte von mehr als 50 Achsen realisieren. Dazu werden mehrere PCs über SERCOS präzise synchronisiert, wobei ein PC zum Master und alle anderen zu Slaves definiert werden. Für diese Anwendungen ist interessant, dass die zweikanalige Karte FC7502 einen Slave und einen Master-Ring betreiben kann. Die Parametrierung des Master/Slave-Modus erfolgt einfach per Software.
Buskoppler für SERCOS interface
Ein weiterer Vorteil ergibt sich durch den Einsatz von Beckhoff Busklemmen am SERCOS-Buskoppler BK7500, der die hohe Datenrate, die kurze Zykluszeit und die hohe Deterministik von SERCOS auch für die klassische E/A-Technik nutzbar macht. An einen Buskoppler lassen sich bis zu 64 der Busklemmen für die unterschiedlichen analogen oder digitalen Signale ankoppeln. Maschinenbauer mit einem hohen Antriebs- und geringen E/A-Aufwand können so auf die Installation eines zusätzlichen E/A-Busses verzichten.
SERCOS-Steuerungssystem
Mit TwinCAT als Software-SPS/NC, den SERCOS-Karten, den digitalen Servoverstärkern und den Busklemmen als E/A-System stellt Beckhoff so ein komplettes PC-basiertes Steuerungssystem für SERCOS Interface zur Verfügung.


Hardware

Produktübersicht [image] Hardware
Hardware
Die PCI-Karten für SERCOS Interface FC7501 (einkanalig) und FC7502 (zweikanalig) erlauben den direkten Zugriff auf das Asic SERCON816. Der in der Softwarelösung TwinCAT integrierte Treiber ermöglicht für diese passiven Karten den optimalen Zugriff auf das SERCOS Interface. Es bestehen keine unnötigen Einschränkungen bezüglich Busteilnehmeranzahl und E/A-Daten pro Teilnehmer.
Mit dieser neuen Interface-Generation kommt die Leistungsfähigkeit von TwinCAT voll zur Geltung:
▪
Bis zu 254 Teilnehmer (Servoverstärker oder E/A-Module, wie z. B. Busklemmen mit Buskoppler BK7500)
▪
Beliebige Zuordnung und Länge der E/A-Daten
▪
Exakte Synchronisierung zwischen TwinCAT und SERCOS
▪
Zykluszeiten bis 62,5 µs möglich
▪
Prozessdatenkommunikation erfolgt synchron
▪
Master- und Slave-Modus per Software parametrierbar
▪
Wahlweise zwei Feldbus-Kanäle parallel auf einer Karte (2x SERCON816)
▪
Synchronisierung der beiden Kanäle und weitere Karten sowie des PCs möglich
▪
Einlesen der Buskonfiguration möglich
FC7501 und FC7502 in Revision B
FC7501 und FC502 in Revision C
1. PCI-Bus-Interface
2. Buchse zum Anschluss des Sync-Kabels
11. SERCOS-Ausgang zum Anschluss des abgehenden Lichtwellenleiters für LWL-Ring A
12. SERCOS-Eingang zum Anschluss des zurückkommenden Lichtwellenleiters für LWL-Ring A
13. Diagnose LED für LWL-Ring A
21. SERCOS-Ausgang zum Anschluss des abgehenden Lichtwellenleiters für LWL-Ring B
22. SERCOS-Eingang zum Anschluss des zurückkommenden Lichtwellenleiters für LWL-Ring B
23. Diagnose LED für LWL-Ring B
Die schraffiert dargestellten Komponenten für den SERCOS-Kanal B sind auf der einkanaligen FC7501 nicht bestückt.
Revision C hat gegenüber Revision B eine vergrößerte Platine, die der für PCI-Karten üblichen Standardhöhe entspricht.
Mit TwinCAT I/O stehen Konfigurations-Tools sowie Windows NT/2000-Treiber für Hochsprachen-Programme (DLL) und Visual Basic Applikationen (ActiveX) zur Verfügung. Anwendungen mit OPC-Schnittstellen können über einen OPC-Server auf die Karten zugreifen.
Diagnose LED
Die Diagnose LED eines Feldbuskanals leuchtet, wenn die Datenübertragung auf dem Lichtleiter gestört ist.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
 | FC7501 | FC7502
Feldbus | SERCOS interface
Anzahl Feldbuskanäle | 1 | 2
Übertragungsrate | 2, 4, 8 oder 16 Mbit/s
Synchronisierung | Synchronisierung mehrerer Karten über Flachbandkabel
Busteilnehmer | maximal 254 je Kanal
Zykluszeit | alle von SERCOS interface unterstützten (ab 62,5 µs)
Hardware Diagnose | 1 LED je Kanal
Interface zum PC | Plug and Play PCI-Interface 32 Bit, direkter Zugriff auf DPRAM und Register des SERCON816
Stromaufnahme aus dem PCI-Bus | typisch 180 mA | typisch 285 mA
Maße | ca. 95 mm x 120 mm
zulässige Umgebungstemperatur im Betrieb | 0° bis 55° C
Bestellangaben
Bestellbezeichnung | Produkt
FC7501 | SERCOS Interface PCI-Karte, einkanalig
FC7502 | SERCOS Interface PCI-Karte, zweikanalig
Z1003 | FSMA-Stecker mit Rändelmutter für 1000 µm Kunststoff-Faser
Z1100 | Kunststoff-Lichtleiter, 1-adrig, 1000 µm
Z1101 | Kunststoff-Lichtleiter, 1-adrig, 1000 µm mit PU-Schutzmantel und Kevlar-Zugentlastung
ZB7501 | SERCOS Master Sync-Kabel, zur Verbindung von SERCOS Interface PCI-Karten eines PCs


Installation

Installation
Installation
Weiterführende Informationen
•
Montage der SERCOS-Karte im PC
•
Installation des PCI-Treibers


Montage der SERCOS-Karte im PC

Installation [image] Montage der SERCOS-Karte im PC
Montage der SERCOS-Karte im PC
Achtung
ESD-Vorschriften beachten
Die SERCOS-Karten werden in einer ESD-Verpackung ausgeliefert. Beachten Sie beim Einbau die für den Umgang mit PC-Karten üblichen ESD-Vorschriften!
1.
Schalten Sie vor dem Einbau der SERCOS-Karte den PC und eventuelle externe Spannungsversorgungen aus und trennen Sie den PC vom Stromnetz.
2.
Öffnen Sie das Gehäuse des PCs.
3.
Entfernen Sie die Schutzkappen von den LWL-Anschlüssen der SERCOS-Karte.
4.
Entfernen Sie an einem freien PCI-Steckplatz des Motherboards das Verschlussblech in der Gehäusewand Ihres PCs.
5.
Stecken Sie die SERCOS-Karte in den freien PCI-Steckplatz und fixieren Sie sie mit der dafür vorgesehenen Schraube oder Vorrichtung.
Achten Sie darauf, dass zwischen der SERCOS-Karte und anderen PC-Komponenten genügend Abstand vorhanden ist, so dass die Lightbus-Karte keine anderen Steckkarten, Speicherbausteine usw. berühren kann.
6.
Schließen Sie das Gehäuse des PCs.
7.
Schließen Sie die SERCOS-Leitungen an die LWL-Anschlüsse der SERCOS-Karte an:
–
Hellgrau: abgehende SERCOS-Leitung
–
Dunkelgrau: zurückkommende SERCOS-Leitung
8.
Verbinden Sie den PC mit dem Stromnetz und schalten Sie den PC ein.
9.
Unter Windows 2000 und Windows XP installiert der Hardware-Assistent nach Hochlauf des Betriebssystems einen PCI-Treiber, um die SERCOS-Karte in das Plug and Play Interface des Betriebssystems einzubinden. Unter Windows NT 4.0 ist dieser Treiber nicht erforderlich.
Die SERCOS-Karte benötigt keine externe Spannungsversorgung. Sie wird direkt vom PC über den PCI-Bus gespeist. Die Stromversorgung des PCs muss insbesondere beim Betrieb mehrerer SERCOS-Karten ausreichend bemessen sein, um den Strombedarf der SERCOS-Karten zu decken.
SERCOS-Master Sync-Kabel
Wenn sie in einem PC mehr als eine SERCOS-Karte verwenden, müssen Sie diese Karten über das SERCOS-Master Sync-Kabel zur Synchronisation miteinander verbinden:
▪
Stecken Sie dazu das Sync-Kabel ZB7501 in die dafür vorgesehenen Buchsen an der Oberkante der SERCOS-Karten.
▪
Legen Sie mit dem TwinCAT System Manager für alle Kanäle der SERCOS-Karten die Betriebsart zur Synchronisation fest.


Installation des PCI-Treibers

Installation [image] Installation des PCI-Treibers
Installation des PCI-Treibers
Nach Einbau der SERCOS-Karte meldet sich z. B. Windows 2000 beim Hochlauf mit folgender Meldung:
Installation des PCI-Treibers
Der PCI-Treiber für die SERCOS-Karten ist im Lieferumfang der Beckhoff Automatisierungs-Software TwinCAT enthalten.
Folgen Sie den Anweisungen des Hardwareassistenten.
Unter Windows XP wird der PCI-Treiber auf die gleiche Weise installiert.
Unter Windows NT 4.0 ist der PCI-Treiber nicht erforderlich.
Beispiel für die Ressourcen einer FC750x unter Windows2000
(Systemsteuerung / System / Hardware / Gerätemanager / TwinCAT PNP Drivers / TwinCAT FC750x PCI Driver / Ressourcen):
Ressourcen des PCI-Treibers
Hinweis
IRQ wird nicht benutzt
Die SERCOS-Karte bekommt vom PCI-Bus einen IRQ zugewiesen (im Beispiel IRQ9). Der IRQ wird aber von der SERCOS-Karte nicht benutzt!


Konfiguration

Konfiguration
Konfiguration
Weiterführende Informationen
•
Konfiguration
•
Karteireiter FC750x
•
Karteireiter Timing (Online/Offline)
•
Karteireiter Online
•
Karteireiter DPRAM (Online)


Konfiguration

Konfiguration [image] Konfiguration
Konfiguration
Die FC7501 ist eine einkanalige und die FC7502 eine zweikanalige passive SERCOS Karte (SErial Realtime COmmunication System) mit PCI Interface. Sie kann sowohl als Sercos Master und-/oder als Sercos Slave betrieben werden. Es wird das Sercos Asic SERCON816 verwendet, das neben 2 und 4 Mbit/s auch 8 und 16 Mbit/s unterstützt.
Kontextmenü
Kontextmenü
Box Anfügen... <Einfg>
Fügt Sercos Slaves (Boxen) an:
Unterstützte Boxen | Beschreibung
BK7500 | Buskoppler
Sercos Achse | Sercos Achse
Gerät Löschen... <Entf>
Entfernt die FC750x Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.
Online Reset
Initiiert einen Online Reset auf den Sercos Master, d.h. ein Phasenumschalten auf Phase 0 und dann wieder auf die davor aktuelle Phase.


Karteireiter FC750x

Konfiguration [image] Karteireiter FC750x
Karteireiter FC750x
Karteireiter FC750x
PCI-Slot / IRQ
Zeigt an in welchem logischen PCI-Slot die Karte gefunden wurde und welcher IRQ ihr zugewiesen wurde. Der IRQ wird nicht benutzt.
Suchen...
Hierüber werden alle gesteckten FC750x-Kanäle gesucht, und es kann der gewünschte ausgewählt werden. Bei einer FC7502 erscheinen beide Kanäle A und B, die sich logisch wie zwei FC7501-Karten verhalten.
PCI-Cfg...
Hiermit kann die Adresse der FC750x in den unteren Memory-Bereich (unterhalb von 1 MB) des PCs eingestellt werden.
Bus absuchen...
Hiermit wird Sercos Ring gescannt und alle gefunden Geräte werden dem Device hinzugefügt. Bei Beckhoff-Boxen wird die Konfiguration genau ausgelesen.
Datenrate
Hier wird die Sercos Baudrate eingestellt. Auswählbar sind 2 Mbit/s, 4 Mbit/s, 8 Mbit/s und 16 Mbit/s.
Sendeleistung
Hier wird die Sendeleistung des Transmitters in Abhängigkeit der dort verwendeten Lichtwellenleiterlänge eingestellt.
Betriebsart
Die FC750x kann sowohl als Sercos Master als auch als Sercos Slave verwendet werden. In beiden Betriebsarten kann die Karte als Synchron-Master (der PC und andere synchrone Geräte werden erhalten vom Sync-Master ihren Takt) oder als Synchron Slave (die Karte, bzw. der Kartenkanal, erhält das Sync-Signal vom anderen Kanal oder über das Sync-Kabel von einer anderen Karte) verwendet werden. Innerhalb eines PCs ist nur ein Synchron Master möglich. Werden bei einer FC7502 beide Kanäle verwendet, dann kann nur der A-Kanal (der Kanal, der näher am Motherboard ist) als Sync-Master verwendet werden.
Startup auf Phase 4
Wenn angewählt wird bei jedem TwinCAT Start versucht den Sercos-Bus in Phase 4 und damit in den zyklischen Datenaustausch zu versetzen. Ist diese Option nicht angewählt verbleibt die Karte in Phase 2 und muss später per ADS z. B. von der SPS in Phase 4 versetzt werden.
Überprüfe Timing
Wenn angewählt wird in jedem Zyklus das exakte Echtzeitverhalten beim Zugriff auf die Karte überwacht und bei Verletzungen (Istwerte werden zu früh gelesen oder Sollwerte werden zu spät geschrieben) wird ein entsprechender Zähler, der in den Prozessdaten zu finden ist, inkrementiert. Die Überwachung benötigt nur sehr wenig Performance, so dass sie in normalen Anwendungen ohne Nachteile mitlaufen kann. In Anwendungen mit sehr kurzer Zykluszeit und Performance Engpässen kann sie dagegen abgeschaltet werden.
Watchdog
Das verwendete Sercos-Asic SERCON816 besitzt einen Hardware Watchdog, der den regelmäßigen Zugriff des PCs überwacht und bei ausbleibenden Zugriffen die Phase 0 aktiviert. Hier kann angegeben werden wie viele Zyklen Toleranz der Watchdog erlaubt. Mit einer Toleranz von 0 wird der Watchdog deaktiviert.
NC Zugriffszeit
Hier wird angegeben wie lange die NC benötigt um pro Zyklus die Istwerte zu lesen und die Sollwerte zu schreiben. Dieser Wert wird nur für die interne Zeitschlitzberechnung verwendet um bereits im Vorfeld mögliche Zeitschlitzprobleme (vergl. Check Timing Errors) zu erkennen.
NC Shift Zeit
Mit Hilfe der NC Shift Zeit kann der Zeitpunkt an dem die NC anfängt die Istwerte zu lesen verschoben werden. Dieser Wert gibt die Anzahl der µs nach dem letzten AT an. Der Default-Wert von 50 µs stellt im Normalfall sicher, dass auch bei geringem Jitter des Echtzeitsystems die ATs und damit die Istwerte sicher beim Master angekommen sind bevor die NC zugreift. Wenn mehr als ein Sercos-Ring verwendet wird, muss dieser Wert eventuell angepasst werden da der NC Zugriff für alle Ringe quasi gleichzeitig erfolgt, das letzte AT des jeweiligen Ringes auf Grund der angeschlossenen Teilnehmer aber zu unterschiedlichen Zeiten eintreffen. Da die Sercos-Ringe auf dem Bus hardwaremäßig synchronisiert sind gilt folgende Regel: Die NC Shift Zeit sollte bei allen Ringen so eingestellt werden, das die resultierende Zeit tNcAccess (siehe Timing) bei allen Ringen etwa gleich ist. Außerdem sollte die NC Shift Zeit bei keinem Ring wesentlich kleiner als etwa 20 µs betragen.
Cycle-Time(3-4)
Hier wird die Zykluszeit der zugehörigen höchstprioren Task angezeigt, diese wird in den Phasen 3 und 4 verwendet.
Cycle-Time(0-2)
Hier wird die Zykluszeit in den Phasen 0 bis 2 angegeben, die für den Hochlauf des Busses verwendet werden.
Die nachfolgenden Werte ermöglichen die interne Zeitschlitzberechnung zu beeinflussen um bei Kommunikationsproblemen oder Auslastungsproblemen noch einige µs zu verändern. Dieses sollte aber nur durchgeführt werden, wenn entsprechendes Sercos-Know-how vorliegt und die Einflüsse abgeschätzt werden können.
JT1 User
Der eingestellte Wert verändert den intern bei der Zeitschlitzberechnung errechneten Jitter JT1.
JT2 User
Der eingestellte Wert verändert den intern bei der Zeitschlitzberechnung errechneten Jitter JT2.
JTSCyc User
Der eingestellte Wert verändert den intern bei der Zeitschlitzberechnung errechneten Jitter JTSCyc.
T3 User
Der eingestellte Wert verändert die intern bei der Zeitschlitzberechnung errechnete Zeit T3.
T4 User
Der eingestellte Wert verändert die intern bei der Zeitschlitzberechnung errechnete Zeit T4.


Karteireiter Timing (Online/Offline)

Konfiguration [image] Karteireiter Timing (Online/Offline)
Karteireiter Timing (Online/Offline)
Karteireiter Timing (Offline)
Der Timing-Karteireiter informiert über interne Details der Zeitschlitzberechnung. Da für die Zeitschlitzberechnung auch Parameter aus den Teilnehmern ausgelesen werden und in Berechnung mit eingehen, wird zwischen einem Online und Offline Modus unterschieden. Im Offline Modus (TwinCAT ist gestoppt) werden Default-Werte für die normalerweise aus den Teilnehmern ausgelesenen Timing-Werte verwand, so dass diese Berechnung geringfügig von den tatsächlich verwendeten Werten abweichen kann. Für eine recht gute Abschätzung des Bustimings reicht die Offline Berechnung in der Regel jedoch aus. Im Online Modus (TwinCAT ist gestartet und der Sercos-Bus muss in Phase 3 oder 4 sein) werden die exakten Werte angezeigt und geben dem fachkundigen Anwender genaueste Informationen über das Timing auf dem Bus.
Die Grafik im unteren Teil gibt einen guten Überblick über die erzeugt Buslast bzw. über die noch vorhandenen Kapazitäten. Zwischen den beiden roten Master Steuer Telegramme (MST) wird ein Sercos-Zyklus dargestellt. Nachdem MST senden die Teilnehmer als erstes ihre Antriebstelegramme (grün) und nach der NC Shift Zeit beginnt die NC Zugriffszeit (gestrichelter Bereich), in der die NC die Istwerte übernimmt und neue Sollwerte übergibt. Der nachfolgende freie Bereich bis zum Master Daten Telegramm (MDT, blau) kennzeichnet "noch freie Buslast" und könnte für weitere Teilnehmer bzw. zusätzliche Daten der vorhandenen Teilnehmer genutzt werden.
Kurz hinter dem MDT wird vom Master bereits ein weiteres MST gesendet und damit der nächste Zyklus gestartet. Die Zeiten T3 und T4 geben an, wann die Teilnehmer alle gleichzeitig die Sollwerte übernehmen bzw. die Istwerte erfassen sollen.


Karteireiter Online

Konfiguration [image] Karteireiter Online
Karteireiter Online
Karteireiter Online
Über den Online-Reiter kann die aktuelle Phase des Sercos-Ringes ermittelt und verändert werden. Drei rote Striche "---" als Phasenangabe deuten auf einen nicht geschlossenen Ring hin. Eine Phasenangabe der Art "2->3" zeigt an, das gerade eine Phasenumschaltung aktiv ist, die unter Umständen länger dauern kann.


Karteireiter DPRAM (Online)

Konfiguration [image] Karteireiter DPRAM (Online)
Karteireiter DPRAM (Online)
Bei aktivem TwinCAT kann zu Diagnosezwecken direkt auf das DPRAM der Feldbuskarten lesend zugegriffen werden.
Karteireiter DPRAM (Online)?
Im Anschluss an das DPRAM des SERCON816 sind ab Adresse 0x1000 die Register des ASIC zu sehen.


Diagnoseeingänge

Diagnoseeingänge
Diagnoseeingänge
Die FC750x verfügt automatisch über verschiedene Diagnosevariablen, die den Zustand der Karte und des Sercos-Ringes beschreiben:
Diagnoseeingänge
ActualPhase
Es wird die aktuelle Phase des Sercos-Ringes angezeigt.
RequestedPhase
Es wird die aktuell angeforderte Phase (z. B. von der SPS) angezeigt. Die Karte bzw. der Treiber versucht gerade diese Phase zu aktivieren.
SystemState
Gibt genaueren Aufschluss über die momentane Phase:
0xE001 = Phase 0
0xE002 = Phase 1
0xE003 = Phase 2
0xE004 = Phase 3
0xE005 = Phase 4
0xE008 = Break
0xE011 = Phase switch 0 -> 1
0xE012 = Phase switch 1 -> 2
0xE013 = Phase switch 2 -> 3
0xE014 = Phase switch 3 -> 4
SystemError
Zeigt den aktuellen Fehler an:
0x0000 = No error
0x8005 = Drive addresses are incorrect
0x8006 = HS-timeout (service channel)
0x8007 = Double AT-failure
0x8009 = LWL-bus is interrupted
0xD002 = Break
0xD003 = Switch from 2->3 failure (S-0-0127)
0xD004 = Switch from 3->4 failure (S-0-0128)
0xF001 = Configuration error (actual/nominal channel)
0xF002 = Error in the time slot calculation
0xF003 = Incorrect phase setting by the NC
0xF004 = Internal error
0xF005 = Error lifecounter
0xF008 = Double MDT-failure
0xF009 = Double MST-failure
0xF00A = Sync-In signal failure
TimingError1
Ein Zähler, der inkrementiert wird, wenn die NC zu früh auf die Istwerte zugreift ('Überprüfe Timing" muss angewählt sein).
TimingError2
Ein Zähler, der inkrementiert wird, wenn die NC zu spät neue Sollwerte liefert ('Überprüfe Timing" muss angewählt sein).
RDistErrorCnt
Ein Fehlerzähler, der zerstört empfangene Telegramme zählt (vergl. RDIST im Reference Manual des SERCON816). Ursache könnte eine falsche Baudrate sein.
FibBrErrorCnt
Ein Fehlerzähler, der zerstört empfangene Telegramme zählt (vergl. FIBBR im Reference Manual des SERCON816). Ursache könnte eine falsche Baudrate sein.
RRerrErrorCnt
Ein Fehlerzähler, der verlorene oder zum falschen Zeitpunkt empfangene Telegramme zählt (vergl. RERR im Reference Manual des SERCON816).
MstLateErrorCnt
Ein Fehlerzähler, der zu spät empfangene MSTs zählt (vergl. MSTLATE im Reference Manual des SERCON816).
MstEarlyErrorCnt
Ein Fehlerzähler, der zu früh empfangene MSTs zählt (vergl. MSTEARLY im Reference Manual des SERCON816).


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.