FC200x - PCI-Karten für Lightbus
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Lightbus Systembeschreibung
•
Hardware
•
Technische Daten


Lightbus Systembeschreibung

Produktübersicht [image] Lightbus Systembeschreibung
Lightbus Systembeschreibung
Hinweis
Systembeschreibung für FC200x / EL6720
Die folgende Systembeschreibung ist sowohl auf die Beckhoff Lightbus-PCI-Interfacekarte FC200x als auch auf die Lightbus-Masterklemme EL6720 anwendbar.
Der Lightbus besteht aus der Lightbus-PCI-Interfacekarte (kurz Lightbus-Karte) und einem Feldbus auf Lichtwellenleiterbasis.
Lightbus LWL-Ring
Die Kopplung des Lightbus mit dem PC ist auf der Lightbus-Karte über ein Dual Ported RAM (DPRAM) realisiert.
Zur Ein- und Ausgabe des Prozessabbildes stehen diverse E/A-Module (Buskoppler, Busklemmen, Feldbus Box usw.) zur Verfügung, die der Lightbus in einer Ringstruktur miteinander verbindet. Durch den Einsatz des Lichtwellenleiters (LWL) ergibt sich eine geringe Störempfindlichkeit und eine hohe Übertragungsrate von 2,5 MBaud. Im LWL-Ring auftretende Fehler werden von der der Lightbus-Karte erkannt und dem PC gemeldet. TwinCAT stellt umfangreiche Funktionen für die Diagnose zur Verfügung, die eine schnelle Erkennung und Behebung auftretender Fehler unterstützen.
Für die Datenübertragung zwischen Lightbus-Karte und E/A-Modulen ist ein auf Geschwindigkeit und Einfachheit optimiertes Kommunikationsprotokoll festgelegt. Die Lightbus-Karte steuert die Kommunikation auf dem LWL-Ring. Sie sendet Telegramme, die nachdem diese die E/A-Module im LWL-Ring durchlaufen haben wieder von der Lightbus-Karte empfangen und geprüft werden.
Ein Telegramm besteht aus Telegrammrahmen und Telegramminhalt.
Aufbau eines Lightbus Telegramms
Der Telegrammrahmen ist für die serielle Datenkommunikation erforderlich und besteht aus 1 Startbit, 6 CRC-Prüfbits und 2 Stoppbits. Er wird von der Hardware der Lightbus-Karte selbständig erzeugt und überprüft. Eine Software-Unterstützung ist nicht notwendig.
Der Telegramminhalt ist im Wesentlichen byteweise organisiert. AD0 bis AD7 bilden das Adressfeld, über das bis zu 254 E/A-Module angesprochen werden (die Adressen 0x00und 0x0FF sind reserviert). Die Bits CR0 bis CR3 legt den Telegrammtyp fest. Folgende Funktionen können im Telegramm festgelegt werden:
Funktionen
CR3 | CR2 | CR1 | CR0 | Funktion | Beschreibung
0 | 0 | 0 | 0 | Read | Das adressierte Modul blendet die Eingangsinformation in die Datenfelder D0 bis D3 ein.
0 | 0 | 0 | 1 | Read und Write | Das adressierte Modul blendet die Eingangsinformation in die Datenfelder D0 bis D3 ein und übernimmt die Ausgangsinformation.
0 | 0 | 1 | 0 | Adressinitialisierung | Das adressierte Modul übernimmt den Inhalt von D0 als Moduladresse und setzt D0 auf den Wert 0.
0 | 0 | 1 | 1 | RAM | Ein spezieller Telegrammtyp für Buskoppler BK2000.
0 | 1 | 0 | 0 | Adress-Check- und Count | Jedes durchlaufene Modul erhöht den Inhalt von D0 um 1. Das adressierte Modul übernimmt den Inhalt von D0 nach D3.
1 | 0 | 0 | 1 | Low Intensity | Das adressierte Modul reduziert die Sendeintensität um 20%.
1 | 0 | 1 | 1 | Broadcast | Ein spezieller Telegrammtyp für Buskoppler BK2000.
Die Bytes D0 bis D3 enthalten die eigentlichen Nutzdaten. Das Control-Feld legt die Verarbeitung dieser Nutzdaten fest. Das letzte Byte im Telegramm enthält 6 Bits zur Bildung einer CRC-Prüfsumme sowie 2 reservierte Bits. Bei einer Nutzdatenlänge von 50 Bit wird so eine Hamming-Distanz von d=3 erreicht.
Der Lightbus besteht aus einem physikalischen Ring, der zur Verarbeitung des Prozessabbilds in bis zu 8 logische Ringe aufgeteilt werden kann. Ein logischer Ring arbeitet nur auf ausgewählte E/A-Module, die durch Communication Description Lists (CDLs) festgelegt werden.
Im DPRAM stellt die Lightbus-Karte dem PC das Prozessabbild zur Verfügung. Das DPRAM ist in drei Bereiche eingeteilt:
▪
Daten:
Input, Output und Merker
▪
Kommunikation:
Initialisierung, Test, Analyse und Konfiguration des Beckhoff Lightbus
▪
Prozesskontrolle:
Aktualisierung des Prozessabbilds
Das DPRAM der Lightbus-Karten benötig pro Kanal 4 kByte im Adressraum des PCs.


Hardware

Produktübersicht [image] Hardware
Hardware
Als Lightbus-PCI-Interfacekarte (kurz Lightbus-Karte) realisiert die FC200x die Anbindung des Lightbus an den PC und somit für TwinCAT den Zugriff auf die Sensoren und Aktuatoren im Automatisierungsprozess. Die Lightbus-Karte FC2002 kann zwei LWL-Ringe betreiben. Sie verhält sich logisch wie zwei FC2001-Karten, d.h. die Komponenten für den LWL-Ring sind auf der FC2002 doppelt vorhanden.
Komponenten der Lightbus-Karte
Komponenten der Lightbus-Karte
1. PCI-Bus-Interface
11. Lightbus-Ausgang zum Anschluss des abgehenden Lichtwellenleiters für LWL-Ring A
12. Lightbus-Eingang zum Anschluss des zurückkommenden Lichtwellenleiters für LWL-Ring A
13. drei LEDs zur Statusanzeige für LWL-Ring A
14. Lightbus-LCA für LWL-Ring A
15. 4 kByte DP-RAM für LWL-Ring A
16. 512 kByte RAM (4 x 128 kByte) für LWL-Ring A
17. 256 kByte Flash für LWL-Ring A
21. Lightbus-Ausgang zum Anschluss des abgehenden Lichtwellenleiters für LWL-Ring B
22. Lightbus-Eingang zum Anschluss des zurückkommenden Lichtwellenleiters für LWL-Ring B
23. drei LEDs zur Statusanzeige für LWL-Ring B
24. Lightbus-LCA für LWL-Ring B
25. 4 kByte DP-RAM für LWL-Ring B
26. 512 kByte RAM (4 x 128 kByte) für LWL-Ring B
27. 256 kByte Flash für LWL-Ring B
Die schraffiert dargestellten Komponenten für LWL-Ring B sind auf der FC2001 nicht bestückt.
Statusanzeige
Jeder Lightbus-Kanal besitzt 3 LEDs zur Statusanzeige.
Statusanzeigen
1.
LWL-Err (Lightbus-Error):
–
Tritt während des Betriebs ein Defekt im LWL-Ring auf, so wird die rote LED LWL-Err aktiviert.
–
Liegt ein allgemeiner LWL-Fehler vor, blinkt die LED LWL-Err.
–
Falls der Fehler beim residenten Adresstest aufgetreten ist die LED LWL-Err statisch eingeschaltet.
Die Aktualisierung des Prozessabbilds ist unterbrochen.
Mit den Diagnosefunktionen kann die Fehlerursache ermittelt werden.
2.
CPU-Err (CPU-Error):
–
Leuchtet nur die rote LED CPU-Err, so liegt ein nicht behebbarer Hardwarefehler vor.
–
Leuchtet die LED Run ebenfalls, so liegt ein Programmfehler vor, der eventuell durch einen Hardware-Reset behoben werden kann.
3.
Run:
–
Wenn nur die grüne LED Run leuchtet, ist die FC200x fehlerfrei initialisiert und betriebsbereit.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | FC2001 | FC2002
Feldbus | Lightbus (LWL)
Übertragungsrate | 2,5 Mbit/s (32 Bit Nutzinformation in 25 µs)
Anzahl Lightbus-Kanäle | 1 | 2
Kommunikation | 8 prioritätsgesteuerte logische Kommunikationskanäle je Lightbus-Kanal
Busteilnehmer | maximal 255 Busteilnehmer mit maximal 65280 E/A-Punkten je Lightbus-Kanal
Hardware-Diagnose | 1 Status- und 2 Diagnose-LEDs (Run, CPU-Err, LWL-Err) je Lightbus-Kanal
Interface zum PC | 32 Bit Plug and Play PCI-Interface
Adressraum | Pro Lightbus-Kanal 4 kByte DP-RAM für 8 Kommunikationskanäle, Daten-, Control- und Statusregister
Interrupts | Auslösen von 2 IRQ möglich
Versorgungsspannung (PCI-BUS) | 5 V
Stromaufnahme (PCI-BUS) | typisch 385 mA | typisch 700 mA
zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Abmessungen | ca. 106 mm x 187 mm


Installation

Installation
Installation
Weiterführende Informationen
•
Einbau in den im PC
•
Installation des PCI-Treibers


Einbau in den im PC

Installation [image] Einbau in den im PC
Einbau in den im PC
Achtung
Beschädigung des Gerätes möglich!
Die Lightbus-Karten werden in einer ESD-Verpackung ausgeliefert. Beachten Sie beim Einbau die für den Umgang mit PC-Karten üblichen ESD-Vorschriften!
1.
Schalten Sie vor dem Einbau der Lightbus-Karte den PC und eventuelle externe Spannungsversorgungen aus und trennen Sie den PC vom Stromnetz.
2.
Öffnen Sie das Gehäuse des PCs.
3.
Entfernen Sie die Schutzkappen von den LWL-Anschlüssen der Lightbus-Karte.
4.
Entfernen Sie an einem freien PCI-Steckplatz des Motherboards das Verschlussblech in der Gehäusewand Ihres PCs.
5.
Stecken Sie die Lightbus-Karte in den freien PCI-Steckplatz und fixieren Sie sie mit der dafür vorgesehenen Schraube oder Vorrichtung.
Achten Sie darauf, dass zwischen der Lightbus-Karte und anderen PC-Komponenten genügend Abstand vorhanden ist, so dass die Lightbus-Karte keine anderen Steckkarten, Speicherbausteine usw. berühren kann.
6.
Schließen Sie das Gehäuse des PCs.
7.
Schließen Sie die Leitungen des LWL-Rings an die LWL-Anschlüsse der Lightbus-Karte an:
–
OUT: abgehender Lightbus
–
IN: zurückkommender Lightbus
8.
Verbinden Sie den PC mit dem Stromnetz und schalten Sie den PC ein.
9.
Unter Windows 2000 und Windows XP installiert der Hardware-Assistent nach Hochlauf des Betriebssystems einen PCI-Treiber, um die Lightbus-Karte in das Plug and Play Interface des Betriebssystems einzubinden. Unter Windows NT 4.0 ist dieser Treiber nicht erforderlich.
Die Lightbus-Karte benötigt keine externe Spannungsversorgung. Sie wird direkt vom PC über den PCI-Bus gespeist. Die Stromversorgung des PCs muss insbesondere beim Betrieb mehrerer Lightbus-Karten ausreichend bemessen sein, um den Strombedarf der Lightbus-Karten zu decken.


Installation des PCI-Treibers

Installation [image] Installation des PCI-Treibers
Installation des PCI-Treibers
Nach Einbau der Beckhoff Lightbus Karte meldet sich z. B. Windows 2000 beim Hochlaufen mit folgender Meldung:
Installation des PCI-Treibers - Neue Hardware gefunden
Der PCI-Treiber für die Lightbus-Karten ist im Lieferumfang der Beckhoff Automatisierungs-Software TwinCAT enthalten.
Folgen Sie den Anweisungen des Hardwareassistenten.
Unter Windows XP wird der PCI-Treiber auf die gleiche Weise installiert.
Unter Windows NT 4.0 ist der PCI-Treiber nicht erforderlich.
Beispiel für die Ressourcen einer FC200x unter Windows2000.
(Systemsteuerung / System / Hardware / Gerätemanager / TwinCAT PNP Drivers / TwinCAT FC2002x PCI Driver / Ressourcen):
Installation des PCI-Treibers - Ressourceneinstellungen


Konfiguration mit dem TwinCAT System Manager

Konfiguration mit dem TwinCAT System Manager
Konfiguration mit dem TwinCAT System Manager
Weiterführende Informationen
•
Suchen der E/A-Geräte
•
Karteireiter FC200x
•
Karteireiter DPRAM (Online)
•
Anfügen weiterer Komponenten


Suchen der E/A-Geräte

Konfiguration mit dem TwinCAT System Manager [image] Suchen der E/A-Geräte
Suchen der E/A-Geräte
1.
Starten Sie den TwinCAT System Manager.
2.
Starten Sie mit der rechten Maustaste unter dem Baumzweig E/A-Konfiguration \ E/A-Geräte die Suche nach neuen Geräten.
Konfiguration mit dem System Manager - Geräte suchen
Beispiel: Die beiden Lightbus-Kanäle einer FC2002 werden als Gerät 1 und Gerät 2 angezeigt.
Konfiguration mit dem System Manager - neue E/A-Geräte gefunden
Sie können die Namen der E/A-Geräte durch langsamen Doppelklick umbenennen (z. B. auf FC2002 Lightbus A).
Konfiguration mit dem System Manager - Umbenennen der E/A-Geräte


Karteireiter FC200x

Konfiguration mit dem TwinCAT System Manager [image] Karteireiter FC200x
Karteireiter FC200x
Unter den Einträgen für die E/A-Geräte finden Sie deren weitere Eigenschaften. Wählen Sie mit der Maus einen Lightbus-Kanal (im Beispiel FC 2002 Lightbus A) an und klicken Sie auf den Kartenreiter FC200x.
TwinCAT Sytem Manager - Karteireiter FC200x
PCI-Bus-Slot (Basisadresse) und LWL-Ring
Logische Nummer des PCI-Bus-Slots (bzw. Basisadresse im Speicherbereich), welche die Lightbus-Karte im PC belegt.
Für die Lightbus-Karte FC2002 wird an die Nummer des PCI-Bus-Slots der von diesem Geräteeintrag genutzte LWL-Ring (-A oder -B) angehängt.
Suchen
Sucht im Rechner nach vorhandenen Lightbus-Karten und stellt die logische Nummer des PCI-Bus-Slots bzw. die Adresse entsprechend ein.
PCI Cfg
Im Auslieferungszustand liegt die Basisadresse der Lightbus-Karte im Bereich oberhalb von 1 MB (32-Bit Adresse). Mit dem PCI-Confiuration-Dialog können Sie die Basisadresse der Lightbus-Karte in den Bereich unterhalb von 1 MB (DOS-Adresse) legen. Nutzen Sie diese Option nur, wenn Ihr PC dies unbedingt erfordert.
Überprüfe Anzahl der Boxen
Wenn diese Option gewählt ist, wird beim Initialisieren der Karte die physikalisch vorhandene Anzahl von Boxen (Buskoppler, Module) mit der Anzahl verglichen, die unterhalb dieser Karte im System Manager eingetragen ist. Falls die Anzahl nicht übereinstimmt, wird eine Fehlermeldung generiert.
Systemstart auch bei LWL-Fehler
Wenn diese Option gewählt ist, wird bei während des TwinCAT-Starts auftretendem Lightbus-Fehler der Systemstart nicht abgebrochen, sondern nur eine Warnung ausgegeben.
K-Bus-Update mit Broadcast-Telegramm (0xB0)
Wenn diese Option gewählt ist, erfolgt der K-Bus Update per Broadcast-Telegramm gleichzeitig für alle Buskoppler, anstelle für jeden Buskoppler einzeln.
Reservierte CDLs
Jeder Feldbuskanal besitzt acht Prioritätskanäle (CDLs), die auch vom TwinCAT System Manager frei benutzt werden können. Wenn einzelne CDLs für Sollen Spezialanwendungen reserviert werde, müssen Sie diese hier markieren. Sie stehen dann dem TwinCAT System Manager nicht mehr zur Verfügung.
Firmware
Gibt die Firmware-Version der Lightbus-Karte an. Bei älteren Lightbus-Karten (z. B. C1220) wird nur Found angezeigt.


Karteireiter DPRAM (Online)

Konfiguration mit dem TwinCAT System Manager [image] Karteireiter DPRAM (Online)
Karteireiter DPRAM (Online)
Bei aktivem TwinCAT kann zu Diagnosezwecken direkt auf das DPRAM der Feldbuskarten lesend zugegriffen werden.
TwinCAT System Manager - Karteireiter DPRAM (Online)


Anfügen weiterer Komponenten

Konfiguration mit dem TwinCAT System Manager [image] Anfügen weiterer Komponenten
Anfügen weiterer Komponenten
Mit der rechten Maustaste können Sie weitere Komponenten hinzufügen.
E/A-Module anfügen
Klicken Sie mit der rechten Maustaste auf das E/A-Gerät (im Beispiel FC2002 Lightbus A) dem Sie E/A-Module hinzufügen möchten und wählen Sie den Menüpunkt Box Anfügen.
TwinCAT System Manager - Anfügen weiterer Komponenten
Der TwinCAT System Manager bietet Ihnen nun verschiedene E/A-Module zur Auswahl an.
TwinCAT System Manager - Buskoppler anfügen
Im Beispiel wird der Buskoppler BK2000 ausgewählt und als Box 1 eingefügt.
TwinCAT System Manager - BK2000 angefügt
Im Konfigurationsbaum des Beispiels erscheint der Buskoppler BK2000 mit seinen Ein- und Ausgängen und einer Endklemme KL9110 als Box 1. Sie können nun, nach Klicken mit der rechten Maustaste auf Box 1 mit dem Menüpunkt Klemme Anfügen die gewünschten Busklemmen hinzufügen.
Fügen Sie so nacheinander alle E/A-Module Ihres Lightbus-Aufbaus in den Konfigurationsbaum ein. Die sich ergebende Reihenfolge muss der physikalischen Reihenfolge der E/A-Module in Ihrem LWL-Ring entsprechen!
Wie Sie die eingefügten E/A-Module mit dem Prozessabbild der Lightbus-Karte verknüpfen, entnehmen sie bitte dem Beckhoff Information System.


Diagnose

Diagnose
Diagnose
Weiterführende Informationen
•
Diagnose mit dem System Manager
•
Status- und Diagnose-Eingänge
•
Diagnose mit Funktionsbausteinen


Diagnose mit dem System Manager

Diagnose [image] Diagnose mit dem System Manager
Diagnose mit dem System Manager
Der TwinCAT System Manager stellt verschiedene Test- und Analysefunktionen zur Verfügung.
Online-Reset
Initiiert einen Reset der Lightbus-Karte.
Der Controller, das DPRAM und der LWL-Ring werden neu initialisiert. Die Lightbus-Karte bestimmt die Anzahl der Module im Ring, verteilt die Moduladressen, testet sie und überprüft den LWL-Ring auf seine Dämpfungsreserve. Eine eventuell vorhandene Bruchstelle wird ebenfalls erkannt und lokalisiert.
TwinCAT System Manager - Online-Reset
LWL-Bruchstellentest
Initiiert einen Bruchstellentest auf dem LWL-Ring.
Bruchstellentest
Der Test gibt die Anzahl der im Ring gefundenen E/A-Module (Boxen) an
Oder im Fehlerfall den Ort der Bruchstelle an


Status- und Diagnose-Eingänge

Diagnose [image] Status- und Diagnose-Eingänge
Status- und Diagnose-Eingänge
Im Prozessabbild der FC200x liegen Statusregister und Fehlerzähler, die im TwinCAT System Manager angezeigt werden.
TwinCAT System Manager - Status- und Diagnose-Eingänge
Statusregister
Die FC200x verfügt für jeden LWL-Ring über Eingangsworte, die den Zustand der Lightbus-Karte und des LWL-Rings beschreiben:
DeviceState
Allgemeiner Status: beinhaltet nur im Fehlerfall den Wert 1, sonst den Wert 0 (Device O.K.).
DeviceIioFunc
Beinhaltet im Fehlerfall den Code der Funktion, die den Fehler ausgelöst hat, z. B.:
0x01 LWL-Reset
0x02 Codewort-Anforderung (Code Word Request)
0x05 LWL-Dämpfungstest (Intensity Check)
0x06 E/A-Module zählen (Counting Boxes)
0x07 E/A-Moduladressen testen (Address Check)
0x09 Software-Reset
0x0A LWL-Bruchstellentest
0x0C Reinitialisierung der CDL (CDL Reinit)
0x10 Konfiguration der CDL (CDL Config)
DeviceIioFuncArg
Beinhaltet im Fehlerfall den Code des Arguments, das der fehlerauslösenden Funktion angefügt war.
BoxWithError
Beinhaltet die Nummer des E/A-Moduls (Box) im LWL-Ring, bei welchem der Fehler aufgetreten ist.
Fehlerzähler
Die FC200x verfügt zu jeden LWL-Ring über Eingangsworte für Fehlerzähler. Es erfolgt keine Überlaufverarbeitung bzw. kein Löschen der Zähler durch die Lightbus-Karte!
CdlErrorCount
Fehler in der CDL (DPRAM-Offset: 0xE30):
CdlErrorCount [0] .. [7] zählt Fehler in jedem einzelnen logischen Ring (CDL).
CdlErrorBit
Bit wird gesetzt wenn CDL einen Fehler hat (DPRAM-Offset: 0xE40):
Wird die CDL erfolgreich übertragen, wird dieses Bit wieder gelöscht.
ErrorCounter
Summenfehler (DPRAM-Offset: 0xEE0):
Register für die Summe aller Fehlerzähler mit Ausnahme des AddressCheckErrCnt
ErrCntRec1
Zähler für Fehler im Receiver 1 (DPRAM-Offset: 0xEE2):
Empfangenes Adress- bzw. Control-Byte ungleich des gesendeten Bytes.
ErrCntRec2
Zähler für Fehler im Receiver 2 (DPRAM-Offset: 0xEE4):
Empfangenes Adress- bzw. Control-Byte ungleich des gesendeten Bytes.
ErrCntTimeout
Zähler für Timeout-Fehler (DPRAM-Offset: 0xEE6):
Zeitüberlauf bei Telegrammempfang
ErrCntParity
Zähler für Parity-Fehler (DPRAM-Offset: 0xEE8):
Telegramm mit CRC-Fehler empfangen
AddressCheckErrCnt
Zähler für Fehler bei internem Adress-Check (DPRAM-Offset: 0xEEA):
Telegramm mit logisch falschem Inhalt (AD ungleich D3) empfangen. Dieser Zähler inkrementiert nicht den Summenfehler!
AddressCheckModule
Moduladresse zu Fehler bei internem Adress-Check (DPRAM-Offset: 0xEEC):
Enthält die Adresse des E/A-Moduls (Box), das den Fehler verursacht hat.


Diagnose mit Funktionsbausteinen

Diagnose [image] Diagnose mit Funktionsbausteinen
Diagnose mit Funktionsbausteinen
Die Beckhoff Automatisierungs-Software TwinCAT stellt verschiedene Funktionsbausteine (kurz FBs) für die Diagnose zur Verfügung.
Lightbus-spezifische Funktionsbausteine
Funktionsbaustein | Beschreibung
IOF_LB_BreakLocationTest | Führt im Lightbus LWL-Ring ein Bruchstellentest durch, um eventuelle Bruchstellen zu lokalisieren.
IOF_LB_ParityCheck | Liest die Parity-Fehlerzähler der Lightbus-Module (z. B. BK2000).
IOF_LB_ParityCheckWithReset | Liest die Parity-Fehlerzähler der Lightbus-Module (z. B. BK2000) und setzt die Fehlerzähler zurück.
Allgemeine Funktionsbausteine
Funktionsbaustein | Beschreibung
IOF_GetBoxCount | Zählt die Anzahl der E/A-Boxen (Box = Slave, Modul, Station) eines E/A-Gerätes (z. B. einer Feldbuskarte).
IOF_GetBoxAddrByName | Ermittelt die physikalische Box-Nummer im LWL-Ring anhand der Box-Bezeichnung und der Geräte-ID (Nr. der Feldbuskarte).
IOF_GetBoxNameByAddr | Ermittelt die Box-Bezeichnung anhand der physikalischen Box-Nummer im LWL-Ring und der Geräte-ID (Nr. der Feldbuskarte).
Als Beispiele werden im Folgenden nur die Funktionsbausteine IOF_LB_BreakLocationTest und IOF_GetBoxCount beschrieben. Die ausführliche Dokumentation dieser und weiterer Funktionsbausteine finden Sie im Beckhoff Information System, das zum Lieferumfang der Automatisierungs-Software TwinCAT gehört und auch auf der Beckhoff-CD Products & Solutions enthalten ist.
IOF_LB_BreakLocationTest
Funktionsbaustein IOF_LB_BreakLocationTest
Mit dem Funktionsbaustein IOF_LB_BreakLocationTest wird ein Bruchstellentest im Lightbus-Lichtwellenleiterring durchgeführt um eventuelle Bruchstellen zu lokalisieren. Wurde während des Tests keine Bruchstelle im Ring erkannt, dann liefert die Ausgangsvariable BOXNO die aktuelle Anzahl der Lightbus-Module im Ring. Bei einer erkannten Bruchstelle vor dem n-ten Modul vor dem Empfängereingang wird das Flag BREAK gesetzt und die Modulnummer über die Ausgangsvariable BOXNO ausgegeben. Liefert die Variable BOXNO den Wert 0xFF, dann liegt die Bruchstelle direkt vor dem Empfängereingang und kann nicht lokalisiert werden.
Eingangsvariablen
NETID | Hier können Sie die AmsNetId des Rechners übergeben, auf dem der FB ausgeführt werden soll. Falls Sie einen Leerstring übergeben, wird der FB auf dem lokalen Rechner ausgeführt.
DEVICEID | Über die Device-ID (Geräte-ID) wird das Gerät (z. B. die Feldbuskarte) spezifiziert, auf dem die Funktion ausgeführt werden soll. Die Geräte-IDs werden während der Hardware-Konfiguration vom TwinCAT System Manager festgelegt.
START | Eine positive Flanke am Eingang START aktiviert den FB.
TMOUT | Übergeben Sie hier die Zeit, die bei der Ausführung des ADS-Kommandos nicht überschritten werden darf.
Ausgangsvariablen
BUSY | Der FB setzt bei seiner Aktivierung den Ausgang BUSY. Der Ausgang bleibt so lange gesetzt, wie der FB aktiv ist.
ERR | Falls bei der Übertragung des Kommandos ein ADS-Fehler auftritt, setzt der Funktionsbaustein den Ausgang ERR nachdem er den Ausgang BUSY zurückgesetzt hat.
ERRID | Der Ausgang ERRID liefert im Fehlerfall die ADS-Fehlernummer.
BREAK | Dieses Flag wird gesetzt, wenn in dem Lichwellenleiter-Ring eine Bruchstelle erkannt wurde.
BOXNO | Die Modulnummer vor dem Empfängereingang, vor dem die Bruchstelle erkannt wurde.
Weitere Informationen zur Anwendung dieses Funktionsbausteins finden Sie im Beckhoff Information System.
IOF_GetBoxCount
Mit dem Funktionsbaustein IOF_GetBoxCount kann die Anzahl der konfigurierten und aktiven E/A-Boxen (Module) eines E/A-Gerätes (Feldbuskarte) bestimmt werden.
Funktionsbaustein IOF_GetBox_Count
Eingangsvariablen
NETID | Hier können Sie die AmsNetId des Rechners übergeben, auf dem der FB ausgeführt werden soll. Falls Sie einen Leerstring übergeben, wird der FB auf dem lokalen Rechner ausgeführt.
DEVICEID | Über die Device-ID (Geräte-ID) wird das Gerät (z. B. die Feldbuskarte) spezifiziert, auf dem die Funktion ausgeführt werden soll. Die Geräte-IDs werden während der Hardware-Konfiguration vom TwinCAT-Systemmanager festgelegt.
START | Eine positive Flanke am Eingang START aktiviert den FB.
TMOUT | Übergeben Sie hier die Zeit, die bei der Ausführung des ADS-Kommandos nicht überschritten werden darf.
Ausgangsvariablen
BUSY | Der FB setzt bei seiner Aktivierung den Ausgang BUSY. Der Ausgang bleibt so lange gesetzt, wie der FB aktiv ist.
ERR | Falls bei der Übertragung des Kommandos ein ADS-Fehler auftritt, setzt der Funktionsbaustein den Ausgang ERR nachdem er den Ausgang BUSY zurückgesetzt hat.
ERRID | Der Ausgang ERRID liefert im Fehlerfall die ADS-Fehlernummer.
BOXCOUNT | Der Ausgang BOXCOUNT gibt nach erfolgreicher Ausführung des Funktionsbausteins die Anzahl der gefundenen E/A-Module (Boxen) zurück.
Weitere Informationen zur Anwendung dieses Funktionsbausteins finden Sie im Beckhoff Information System.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.