ET2000 - Industrial-Ethernet-Multichannel-Probe
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt. Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft. Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen. Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH & Co. KG.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version | Kommentar
2.2 | - Update Kapitel „Grundlagen der Funktion“ - Strukturupdate
2.1 | - Update Kapitel „Grundlagen der Funktion“ - Strukturupdate
2.0 | - 1.Veröffentlichung in PDF
1.8 | - Technische Daten aktualisiert
1.7 | - Technische Hinweise geändert
1.6 | - Technische Hinweise ergänzt
1.5 | - Technische Beschreibung und neue Sicherheitshinweise ergänzt
1.4 | - Technische Beschreibung ergänzt
1.3 | - Umstellung Wiresharkunterstützung
1.2 | - Technische Beschreibung ergänzt
1.1 | - Technische Daten ergänzt (SoF)
1.0 | - Technische Daten ergänzt
0.1 | - Vorläufige Dokumentation für ET2000


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
ET2000 - Einführung
•
Technische Daten
•
Grundlagen zur Funktion
•
Analyse von EtherCAT Telegrammen
•
LED-Anzeigen


ET2000 - Einführung

Produktübersicht [image] ET2000 - Einführung
ET2000 - Einführung
ET2000
Industrial-Ethernet-Multichannel-Probe
Mit der Multichannel-Probe ET2000 stellt Beckhoff eine vielseitige Hardware für die Analyse aller Industrial-Ethernet-Lösungen vor. Mit acht Ports ermöglicht dieses Gerät das unbegrenzte, zeitlich korrelierte Mitschneiden von bis zu vier unabhängigen Kanälen bei einer Geschwindigkeit von 100 MBit/s halb/vollduplex. Hierbei werden alle Echtzeit-Ethernet-Standards, wie z. B. EtherCAT, PROFINET etc., sowie herkömmliche Office-Ethernet-Netzwerke unterstützt.
Durch ihre kompakte und robuste Bauform ist die ET2000 nicht nur für den Vor-Ort-Einsatz an Maschinen sondern auch für den Einsatz im Labor bestens geeignet. Mit den vier Kanälen können sowohl getrennte Netzwerke als auch verschiedene Stellen im gleichen Netzwerk mitgeschnitten und analysiert werden. Alle durchlaufenden Frames – in Hin- und Rückrichtung – werden in der Probe-Hardware mit einem hochgenauen Zeitstempel versehen und an den GBit-Uplink-Port kopiert.
Durch die hohe Auflösung des Zeitstempels von 1 ns kann eine sehr genaue Timing- Analyse der angeschlossenen Netzwerksegmente erfolgen. Die ET2000-Probe ist für die angeschlossenen Busse transparent. Dank der sehr geringen Durchlaufverzögerung von < 1 μs wird das System so gut wie nicht beeinflusst. Das Gerät kann PC-seitig an beliebige GBit-Ethernet-Schnittstellen angeschlossen werden. Die ET2000-Probe kann mit frei verfügbaren Netzwerkmonitoren, wie z. B. Wireshark (Ethereal), universell eingesetzt werden.
Für die Auswertung des ET2000-Zeitstempels ist für Wireshark unter EtherCAT-Entwicklungsprodukte Software eine Erweiterung verfügbar.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | ET2000
Bussystem | Ethernet (sämtliche auf IEEE 802.3 basierende Protokolle)
Anzahl Ethernet-Ports | 8/4
Ethernet-Interface | 100BASE-TX Ethernet mit RJ45
Uplink-Port | 1 GBit/s
Baudrate | Probe-Ports: 100 MBit/s, Uplink-Port: 1 GBit/s
Durchlaufverzögerung | < 1 µs
Auflösung Zeitstempel | 1 ns
Genauigkeit Zeitstempel | 40 ns
Erfassungszeitpunkt Ethernet Frame | Start of Frame (SoF)
Diagnose | 2 LEDs je Kanal: - Link/Activity 8 Status LED, noch ohne Funktion
Versorgung | über dreipolige Federzugklemme (+, -, PE)
Versorgungsspannung | 24 VDC (18 VDC bis 30 VDC)
Software Interface | Wireshark Erweiterung aktuell erforderliche Wireshark-Version: siehe Kapitel Grundlagen zur Funktion
Stromaufnahme | typisch 250 mA
Gewicht | ca. 300 g
Abmessungen ohne Stecker (B x H x T) | ca. 100 mm x 150 mm x 40 mm
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Die ET2000 wird betriebsbereit ausgeliefert. Es sind keinerlei Einstellungen an der Hardware vorzunehmen. Die ET2000 wird in eine Ethernet-Leitung eingeschleust und spiegelt dann alle Ethernet-Frames über einen 1 GBit-Port zu einem datenaufzeichnenden PC. Die ET2000 verfügt über keinen eigenen Speicher, dadurch ist die Verwendung einer 1 GBit-Uplink-Verbindung zwingend vorgeschrieben.
Die ET2000 versieht jeden aufgezeichneten Frame mit einem Zeitstempel. Dieser Zeitstempel kann zur genaueren Netzwerkverkehrsanalyse verwendet werden. Der Erfassungszeitpunkt ist der StartOfFrame (SoF).

Inbetriebnahme - Hardware
▪
Schließen Sie die ET2000 entsprechend der Bezeichnung an eine 24V DC Versorgungsspannung an.
▪
LED 3 und 4 leuchten (siehe LED Status).
Spannungsversorgung der ET2000
▪
Schließen Sie den 1 GBit/s-Uplink an einen ebenfalls 1 GBit-fähigen Netzwerkport Ihres PCs an. Der Betrieb an einem 100MBit-Port ist nicht möglich.
▪
Leiten Sie nun den zu analysierenden Netzwerkverkehr über eine der 4 Lines (Kanäle) der ET2000. Alle 4 Kanäle können gleichzeitig benutzt werden. Die Activity-LED zeigen jeweils Datenverkehr an. Der jeweils linke Port (IN) ist als Eingang in Vorwärtsrichtung zu sehen, der rechte Port (OUT) als Ausgang, s. Abb. "Draufsicht auf die ET2000".
Draufsicht auf die ET2000
Hinweis
Gespiegelte Frames (ab Firmware 02)
Für eine optimale Anwendung der ET2000 in einem EtherCAT-Netzwerk arbeitet die ET2000 in folgender Weise: wenn auf einem Kanal nur ein Port beschaltet ist, spiegelt die ET2000 alle ankommenden Frames wieder auf diesen Port zurück. Durch diese Funktion wird sichergestellt, dass ein EtherCAT-Zweig auch während des Anschlussvorgangs ohne Frame-Verlust weiterlaufen kann. In Netzwerken, die nicht auf zurückgespiegelte Frames ausgelegt sind, kann diese Funktion zu Konflikten führen! Dies kann z.B. bei managebaren Switchen mit LoopBack-Überwachung auftreten. Soll dieser Effekt vermieden werden, muss an der ET2000 zuerst der Netzwerkteilnehmer angeschlossen werden, der reflektierte Frames verarbeiten kann.
Hinweis
Einsatz in Profinet IRT-Systemen
Ein Frame wird beim einfachen Durchlauf durch eine Line der ET2000 um typ. 540 +/- 40 ns verzögert. Beim Einsatz in Profinet IRT-Systemen ist dies zu berücksichtigen.
Anwendungsbeispiel im EtherCAT System
In Abb. "Beispielanschluss der ET2000" wird beispielhaft die Verwendung in einem EtherCAT System zum Mitschnitt der Protokolldaten gezeigt.
Beispielanschluss der ET2000
Inbetriebnahme - Software
Jeder aufgezeichnete Ethernet-Frame wird von der ET2000 um 16 Byte Daten ergänzt, die Informationen über den verwendeten Port, die Datenintegrität und den Zeitstempel enthalten. Diese Ergänzung wird hinten an die Nutzdaten als Postfix angefügt, das Datenformat wird als ESL (EtherCAT Switch Link) bezeichnet. Der Empfangszeitpunkt des Ethernet-Frames an der ET2000 (Start of Frame, SoF) wird als 64-bit-Timestamp-Wert erfasst und ist in den Nutzdaten enthalten.
Dieser erweiterte Frame wird nun über die 1 GBit-Uplink-Verbindung zum PC gesendet. Dort können die fortlaufend eintreffenden Ethernet-Frames mit entsprechender Software aufgezeichnet werden. Diese Software ist nicht im Lieferumfang enthalten und kann z.B. aus dem Internet frei bezogen werden. Die aktuell beste Unterstützung ist für Wireshark ab Version 1.0.2 gegeben.
Beim Versenden werden von der ET2000 eine neue Checksumme/CRC und ein neuer Header erstellt.
▪
Betrieb ohne ESL-Auswertung
Mit dem standardmäßig in Wireshark > 1.0.2 integrierten Parser ..\Wireshark\Plugins\ethercat.dll werden nur EtherCAT-Frames entschlüsselt und lesbar gemacht. Die 16 Byte Zusatzdaten (ESL) werden als "Padding Byte" bezeichnet. Eine Filterung auf die darin enthaltenen Informationen ist nicht möglich.
▪
Betrieb mit ESL-Auswertung
Nach Austausch der ethercat.dll gegen eine spezielle Version von Beckhoff ist zusätzlich die ESL-Information entschlüsselt:
- CRC Error im ursprünglichen Frame
- Alignment Error
- Zeitstempel der ET2000
Hinweis
Anzeige EtherCAT-Frames mit ESL Information
Im oben genannten Fall kann Wireshark nur noch von der ET2000-gesendete, also eine ESL-Information enthaltende Ethernet-Frames anzeigen! Um wieder Ethernet-Frames ohne ESL-Information lesen zu können, muss die ethercat.dll gelöscht/umbenannt und Wireshark neu gestartet werden.
In dieser Anleitung wird nur Software für Windows-Betriebssysteme berücksichtigt.
Betrieb ohne ESL/Zeitstempelauswertung
Zum Aufzeichnen der Ethernet-Frames ist prinzipiell jede entsprechende Software geeignet, z.B. Microsoft Network Monitor (NetMon) oder Wireshark/Etherreal Network Analyser. Zur Analyse der in den Frames enthaltenen Informationen sind u. U. Zusatzwerkzeuge nötig, die nicht für jede beliebige Software verfügbar sind. Die weiteren Vorgänge werden deshalb am Beispiel der Netzwerkanalysesoftware Wireshark beschrieben.
Hinweis
Etherreal vs. Wireshark
Etherreal wird z. Z. im Gegensatz zu Wireshark nicht mehr weiterentwickelt. Wireshark ist die Fortführung und Weiterentwicklung des bekannten Netzwerkanalyseprogramms Etherreal unter neuem Namen. Beide sind frei verfügbar und können (wie auch NetMon) mit Skripten automatisiert werden.
▪
Installieren Sie eine aktuelle Version von Wireshark (www.wireshark.org) auf Ihrem PC. Wireshark stellt dabei die Bedienungsoberfläche und das Datenverwaltungsmanagement für die aufgezeichneten Frames bereit. Falls noch nicht vorhanden, wird bei der Installation der aktuelle WinPcap-Treiber mitinstalliert. Dieser übernimmt die Ethernet-Frames vom Netzwerkport am PC und leitet sie an Wireshark weiter.
▪
Starten Sie nach der Installation Wireshark, wählen Sie über Capture --> Interfaces den 1 GBit-Netzwerport aus an den die ET2000 sendet und starten sie die Aufzeichnung.
Hinweis
Datenmengen
Je nach EtherCAT-Zykluszeit und Prozessdatenumfang können u. U. in kürzester Zeit erhebliche Datenmengen anfallen!
Screenshot einer Wireshark-Aufzeichnung
Abb. "Screenshot einer Wireshark-Aufzeichnung" zeigt den Mitschnitt von EtherCAT-Frames des TwinCAT EtherCAT Masters, in den Fenstern darunter wird der Inhalt eines Frames (wenn möglich) aufgeschlüsselt. In der Spalte "Time" wird der Zeitpunkt des Eintreffens von dem ET2000 gesendeten Frame am GBit-Port des PCs angezeigt. Da hierbei einige Windows-Protokoll-Schichten durchlaufen werden, ist die Genauigkeit dieser Werte kritisch zu hinterfragen.
Betrieb mit ESL/Zeitstempelauswertung
Falls keine weiteren Maßnahmen getroffen werden, geben die Angaben in der Spalte "Time" den ungefähren Ankunftszeitpunkt des von der ET2000 gesendeten Ethernet-Frames am GBit-Port des PC an. Dieser Wert kann u .U. erheblich von dem Durchlaufzeitpunkt des originalen Frames durch die ET2000 abweichen. Zur Auswertung des von der ET2000 angefügten Zeitstempels ist eine von Beckhoff bereitgestellte Erweiterung für Wireshark notwendig, die für Wireshark ab Version 1.0.2 erstellt wurde. Es handelt sich dabei um einen modifizierten EtherCAT-Parser "EtherCAT.dll", der dafür sorgt, dass Wireshark einen Ethernet-Frame mit EtherCAT-Datagrammen in seine Bestandteile aufschlüsseln kann, s. Abb. "Screenshot einer Wireshark-Aufzeichnung".
Durch den Austausch gegen die standardmäßige EtherCAT.dll kann Wireshark auch die ESL-Information lesen - andere als ESL-beinhaltende Ethernet-Frames werden dann allerdings nicht mehr aufgezeichnet.
Diese dll-Datei kann von http://www.beckhoff.de unter Download --> Software --> Entwicklungsprodukte heruntergeladen werden. Die Wireshark-Installation enthält bereits eine EtherCAT.dll, die jedoch ggf. noch nicht das ESL-Protokoll unterstützt. Nach Ersetzen der vorhandenen EtherCAT.dll im Ordner Wireshark/Plugins/<build>/ kann dieser Dissector (i.e. Aufschlüsselung) unter Edit/Preferences angeschaltet werden, s. Abb. "Anschalten des ESL Dissectors in Wireshark". Dann wird in der Spalte "Time" der Wireshark-Oberfläche der Zeitstempel der ET2000 angezeigt, ansonsten der Zeitpunkt, an dem der Frame am GBit-Port des PC eintraf.
Hinweis
Dateiversionen EtherCAT.dll
• vor Version 1.0.2: Modifikation des WinPcap-Treibers nötig, kein Support
• ab Version 1.0.2: zum Download unter http://www.beckhoff.de
• ab Version 1.2.0: zum Download unter http://www.beckhoff.de
• ab Version 1.6: bereits in Wireshark integriert, keine separate Nachinstallation erforderlich
Unter View/TimeDisplayFormat/ kann die Auflösung der Anzeige bis auf 1 ns erhöht werden.
Anschalten des ESL Dissectors in Wireshark
Hinweis
Zusätzliche Daten (16 Byte)
Die ET2000 fügt an den gespiegelten Frame zum Aufzeichnungs-PC 16 Byte weitere Daten als Postfix an. Hat der originale Frame bereits die nach Ethernet-Standard maximal erlaubte Länge von 1500 Byte, kann der GBit-Port des PC den nun 1516 Byte langen Frame evtl. verwerfen. Ggf. sind in den Treibereigenschaften des Netzwerkport Einstellungen zu JumboPackets zu ändern.
Von der ET2000 angefügte Zusatzdaten im ESL (EtherCAT Switch Link) Protokoll
Aufbau der 16 Byte Zusatzdaten
Die 16 Byte Zusatzdaten der ET2000 haben der Reihenfolge nach folgende Bedeutung, s. Abb. "Von der ET2000 angefügte Zusatzdaten im ESL (EtherCAT Switch Link) Protokoll":
6 Byte | Identifier 01 01 05 10 00 00 (symbolische MAC-Adresse)
1 Byte | Portangabe 0..7 auf dem der Frame ankam
1 Byte | bit 0..2 reserved, bit 3: alignment error, bit 4: CRC Error im aufgezeichneten Frame
8 Byte | Timestamp in ns (Genauigkeit: 10 ns) - x00 00 00 5D 34 81 99 08 (Leserichtung rückwärts)
Hinweis
ET2000 Erweiterungen
Diese Beschreibung ist nicht endgültig. Zukünftige Funktionalitätserweiterungen können einen veränderten Aufbau der Zusatzdaten nötig machen. Eine entsprechende Version der EtherCAT.dll wird dann zum Download bereitgestellt.
Hinweis
Ausgleich der minimalen Ethernet-Framelänge
Wenn nur wenig Prozessdaten im EtherCAT Protokoll vorliegen, weil z.B. nur ein kleiner Aufbau mit wenig Teilnehmern verwendet wird, liegen so wenig Nutzdaten vor, daß der Ethernet-Frame zwischen dem regulären Frameende und der ET2000-Erweiterung (16 Byte) mit Füllbytes (Padding bytes, x00) aufgefüllt wird um die minimale Ethernet-Framelänge zu erreichen.
Hinweis
Alignment Fehler
Das Alignment-Fehlerbit in den ESL-Informationen zeigt an, dass der aufgezeichnete Frame nicht an einer Bytegrenze endete. In diesem Fall muss das letzte Byte der Daten vor den ESL-Informationen ignoriert werden.
Analyse von EtherCAT-Datagrammen
Abb. "Screenshot einer Wireshark-Aufzeichnung" zeigt den Mitschnitt von EtherCAT-Frames des TwinCAT EtherCAT Masters. Frame 348 ist markiert, sein Inhalt wird in den Feldern darunter aufgeschlüsselt dargstellt. Im mittleren Fenster werden im unteren Abschnitt die im Frame 348 enthaltenen EtherCAT-Datagramme mit Erläuterungen aufgeschlüsselt.
Hinweis
Parser
Für jedes zu analysierende Netzwerkprotokoll ist ein eigener Parser im Verzeichnis <Wireshark Installationsverzeichnis>\plugins\<Version> erforderlich. Diese Parser können meist von der jeweiligen Nutzerorganisation bezogen werden.
Der Parser ist z. Z. in Versionen für Microsoft NetMon, Wireshark und Etherreal erhältlich. Legen Sie ihn am o. a. Ort ab und starten Sie Wireshark neu. Nun kann Wireshark die EtherCAT-Datagramme wie in Abb. "Screenshot einer Wireshark-Aufzeichnung" darstellen.
Beispiele für Filtereinstellungen und ihr Nutzen
▪
"(esl.crcerror == 1) or malformed": von der ET2000 als defekt markierte Ethernet Frames werden angezeigt
▪
"ecat.adp==0x03ed and (ecat.ado==0x120 or ecat.ado==0x130)": Kontrolle der Statusübergänge des EtherCAT-Slave 0x03EDhex/1005d.
▪
"ecat_mailbox": nur Mailboxkommandos werden angezeigt
▪
"((ecat.cmd==4)&&(frame.number>110)): alle FPRD-Datagramme ab dem 110.Ethernet-Frame werden angezeigt.
Siehe dazu auch das gesonderte Beispiel.


Analyse von EtherCAT Telegrammen

Produktübersicht [image] Analyse von EtherCAT Telegrammen
Analyse von EtherCAT Telegrammen
Im Folgenden werden beispielhaft aufgezeichnete Telegramme mit der verwendeten Konfiguration analysiert und gegenübergestellt.
Aufzeichnung
Die Line 1 der verwendeten ET2000 wird zwischen IPC und dem Koppler EK1100 eingesetzt. Denn das Ziel dieser Untersuchung ist festzustellen, inwiefern alle Slaves die versendeten Frames verändern. Dies kann am besten direkt am EtherCAT Master geloggt werden.
Der ET2000-Uplink wird mit der GBit-Schnittstelle eines CP6920 verbunden.
Hinweis
Hinweise zur Datenaufzeichnung
Aufzeichnungen >>100.000 Frames können unter Umständen den Arbeitsspeicher des verwendeten PC überfordern. Ggf. sind Filter zu setzen um das Datenaufkommen zu reduzieren. Zur Aufzeichnung sollte ein PC mit herkömmlicher Festplatte, nicht mit CF-Card verwendet werden.
Hinweis
Position der Datenaufzeichnung
Eine sinnvolle Interpretation der geloggten Daten ist meist nur bei bekanntem Anschlussort sinnvoll bzw. möglich. So kann ein Anschluss zwischen Master und dem ersten Slave, zwischen Ethernet-Teilnehmern oder auch am Ende einer Topologie sinnvoll sein, je nach Ziel der Untersuchung. Da in der ET2000 4 Lines zur Verfügung stehen, können Ethernet-Telegramme an bis zu 4 unterschiedlichen Orten gleichzeitig aufgenommen werden.
Interpretation
Konfiguration
Die TwinCAT-Konfiguration nach Abb. "Konfiguration und versendete EtherCAT-Datagramme" wird hier verwendet.
Konfiguration und versendete EtherCAT-Datagramme
Der EtherCAT-Master (A) versendet zyklisch alle 1 ms einen Ethernet-Frame mit den Prozessdaten (B). Dieser Frame beinhaltet 5 EtherCAT-Datagramme (C). Im TwinCAT-EtherCAT-Master werden diese Datagramme automatisch berechnet. Die Berechnung kann in den "Advanced Settings" oder durch SyncUnits beeinflusst werden.
Exemplarisch sei hier das 2. Datagramm "LWR" betrachtet. Diese "Logical Write" ist 1 Byte lang (Len = 1) und liegt im 4,2-GByte EtherCAT-Addressraum an der logischen Addresse 0x10800 (D). Ein oder mehrere EtherCAT-Slaves müssen dieses Datagramm im Durchlauf bearbeiten. Nachdem alle Slaves dies erfolgreich getan haben, muss das Datagramm mit einem WorkingCounter = 1 zurückkommen (E).
Der gesamte Ethernet-Frame umfasst 94 Bytes (F) und lässt im verwendeten 1 ms-Zyklus mit einer Länge/Duration = 9.44 µs noch viel Raum für weitere Prozessdaten bzw. azyklische/queued Telegramme.
Während sich die azyklischen Telegramme während der Applikationslaufzeit verändern können, sind im TwinCAT-EtherCAT-Master die zyklischen Telegramme in der Regel unveränderlich. Dies vereinfacht die Interpretation der Aufzeichnungen.
Informationen zum Slave
Nun soll der Slave EL2008 betrachtet werden. Aus seinen "Advanced Settings"-->FMMU/SM, Abb. "Mapping-Einstellungen der EL2008" kann entnommen werden:
▪
dass er nur 1 FMMU (Fieldbus Memory Management Unit) verwendet (B),
▪
die 1 Byte (Length = 1)
▪
aus dem logischen Addressraum bei Byte 0x10800 (C)
▪
ab Bit 0 (L Start: ".0")
▪
bis Bit 7 (L EndBit = 7)
▪
in den physikalischen RAM-Speicher des Slaves nach Addresse 0x0F00 überträgt (D).
Diese Einstellungen werden vom TwinCAT-EtherCAT-Master automatisch gesetzt.
In den Telegrammaufzeichnungen muss nun nach den LWR auf log. 0x10800 gesucht werden.
Mapping-Einstellungen der EL2008
Logs
Im Wireshark-Log lassen sich die EtherCAT-Datagramme sofort wiederfinden, Abb. "Wireshark Log". Mehrere tausend Frames wurden hier geloggt, exemplarisch wird hier Frame No. 4855 (abgehend vom Master, ca. im 1 ms Takt) und 4856 (aus dem Feld zurückkommend, abhängig vom Konfigurationsumfang einige µs später) betrachtet.
Hinweis
Anzeige der Zeit-Spalte
Oft ist es hilfreich, in der Zeitspalte den Abstand zwischen 2 aufeinanderfolgenden Paketen angezeigt zu bekommen, s. Abb. "Wireshark Log". Unter View --> TimeDisplayFormat kann dies eingestellt werden.
Hinweis
Verwertbarkeit der Zeit-Spalte
Die Informationen in der Zeitspalte "Time" können nur sinnvoll bewertet werden, wenn die Frames mit der ET2000 geloggt wurden, da sie jeden Frame mit einem HW-Zeitstempel versieht - wenn die Wireshark-dll wie beschrieben installiert ist, wird dieser Zeitstempel in der Time-Spalte auch angezeigt.. Andernfalls wird auf Software-Ebene der Ankunftszeitpunkt des Frames im Ethernet-Treiber des loggenden PC auf Basis der Betriebssystem-Zeit im ms-Raster verwendet. Außerdem wird dann üblicherweise die Reihenfolge im Log massiv verändert - dann muss vom Anwender z.B. durch Verwendung des Index-Feldes in den EtherCAT-Datagrammen erst die richtige Reihenfolge ermittelt werden.Die Verwendung der ET2000 vereinfacht/beschleunigt also die Dateninterpretation deutlich.
Wireshark Log
Der abgehende Frame No. 4855 trägt 5 Commands/Datagramme (C). Angehängt wird von der ET2000 die ESL/EtherCATSwitchLink-Information (16 Byte) mit dem Zeitstempel (D). Dadurch wächst der Frame auf eine Länge von 110 Byte (B).
Von Interesse ist nun das LWR auf 0x10800, das nach Abb. "Konfiguration und versendete EtherCAT-Datagramme" das zweite Datagramm ist (B). Der in Wireshark integrierte EtherCAT-Parser erlaubt die Darstellung der Informationen nach Abb. "Datagramm Interpretation" - das 2.Datagramm ist markiert, dadurch werden auch die zugehörigen Bytes im 100-Byte-Rohdatenfeld hervorgehoben. Das Datagramm beginnt mit dem Datagrammtyp (LWR = x0B), es folgt der fortlaufende Index, hier x02. Weitere Information zum EtherCAT-Protokoll können der Dokumentation auf www.ethercat.org entnommen werden.
Von besonderem Interesse ist hier noch der WorkingCounter = 0 - alle vom Master abgehenden Datagramme tragen Wc=0.
Datagramm Interpretation
Das Prozessdatum der EL2008, 1 Byte, findet sich auch im Datagramm wieder, s. Abb. "Prozessdatum der EL2008".
Prozessdatum der EL2008
Im nach 2 µs aus dem Feld zurückkommenden Frame No. 4856 (A) haben sich alle WorkingCounter verändert, diese müssen nun den Erwartungswerten aus Abb. "Konfiguration und versendete EtherCAT-Datagramme" entsprechen.
WorkingCounter im zurückkommenden Frame


LED-Anzeigen

Produktübersicht [image] LED-Anzeigen
LED-Anzeigen
Ethernet
RJ45-Buchse
Für jeden Kanal zeigt eine LED den aktuellen Status an.
LED-Anzeigen pro Kanal
LED | Anzeige
Link Act | off | Keine Verbindung
 | on | Verbindung vorhanden (Link)
 | blinkt | Datenübertragung (Act)
Status
Die 8 Status LED 1 - 8 sind für zukünftige Diagnose vorgesehen.
Im normalen Betrieb leuchten LED 3 und 4 dauerhaft.
Status LEDs


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.