EPP4374 - EtherCAT Box mit analogen Eingängen und Ausgängen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Sicherheitshinweise
•
Hinweise zur Dokumentation
•
Ausgabestände der Dokumentation


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
1.0
▪
Erste Veröffentlichung
0.1
▪
Erste vorläufige Version
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Dokumentation Version | Firmware | Hardware
1.0 | 04 | 03
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer)
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code enthält zusätzliche Informationen über den Auslieferungszustand des Moduls: Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC).


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT-P-Box-Module
•
Einführung
•
Technische Daten
•
Lieferumfang
•
Prozessabbild


EtherCAT-P-Box-Module

Produktübersicht [image] EtherCAT-P-Box-Module
EtherCAT-P-Box-Module
EtherCAT P
EtherCAT P ergänzt die EtherCAT-Technologie um ein Verfahren, bei dem Kommunikation und Versorgungsspannungen auf einer gemeinsamen Leitung übertragen werden. Alle Eigenschaften von EtherCAT bleiben bei diesem Verfahren erhalten.
Es werden zwei Versorgungsspannungen pro EtherCAT-P-Leitung übertragen. Die Versorgungsspannungen sind galvanisch voneinander getrennt und sind somit einzeln schaltbar. Die Nennspannung der Versorgungsspannungen ist 24 VDC.
EtherCAT P verwendet den gleichen Leitungs-Aufbau wie EtherCAT: eine 4-adrige Ethernet-Leitung mit M8-Steckverbindern. Die Steckverbinder sind mechanisch codiert, so dass ein Vertauschen von EtherCAT-Steckverbindern und EtherCAT-P-Steckverbindern nicht möglich ist.
EtherCAT-P-Box-Module
EtherCAT-P-Box-Module sind EtherCAT-P-Slaves in Schutzart IP67. Sie sind vorgesehen für den Betrieb in nassen, schmutzigen oder staubigen Industrie-Umgebungen.
EtherCAT P Einführung
EtherCAT P
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.


Einführung

Produktübersicht [image] Einführung
Einführung
EPP4374 Inventarbild Website de
EPP4374-0002
EtherCAT-P-Box mit analogen Eingängen und Ausgängen
EPP4374-0002 hat zwei analoge Eingänge und zwei analoge Ausgänge. Für jeden analogen Eingang und Ausgang kann der Signalbereich individuell parametriert werden:
▪
-10 .. +10 V
▪
0 .. 10 V
▪
0 .. 20 mA
▪
4 .. 20 mA
Quick links
▪
Installation
▪
Konfiguration
▪
UL-Anforderungen


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Alle Werte sind typische Werte bei 25 °C, wenn nicht anders angegeben.
Technische Daten
EPP4374-0002
Feldbus
Feldbus
EtherCAT
Anschluss
EtherCAT P: Kombinierter Anschluss für EtherCAT und Versorgungsspannungen
Einspeisung: 1 x M8-Buchse, P-kodiert, rot
Weiterleitung: 1 x M8-Buchse, P-kodiert, rot
Versorgungsspannungen
Anschluss
Siehe Feldbus-Anschluss
Steuerspannung US
Nennspannung
24 VDC (-15 % / +20 %)
Summenstrom
max. 3 A 1)
Verbraucher
Modulelektronik: 120 mA bei 24 VDC
Peripheriespannung UP
Nennspannung
24 VDC (-15 % / +20 %)
Summenstrom
max. 3 A 1)
Verbraucher
• Sensoren 2)
• Aktoren 2)
Analoge Eingänge
Anzahl
2
Anschluss
M12-Buchsen, 5-polig. Kontakt-Belegung
Signalbereich
Parametrierbar:
▪
-10 .. +10 V (default)
▪
0 .. 10 V
▪
0 .. 20 mA
▪
4 .. 20 mA
Elektrische Spezifikationen
Sensor/Aktor-
Versorgungsspannung 3)
aus der Peripheriespannung UP
max. 3 A in Summe, nicht kurzschlussfest
Analoge Ausgänge
Anzahl
2
Anschluss
M12-Buchsen, 5-polig. Kontakt-Belegung
Ausgangssignalbereich
Parametrierbar:
▪
-10 .. +10 V (default)
▪
0 .. 10 V
▪
0 .. 20 mA
▪
4 .. 20 mA
Elektrische Spezifikationen
Sensor/Aktor-
Versorgungsspannung 3)
aus der Peripheriespannung UP
max. 3 A in Summe, nicht kurzschlussfest
1) Summenstrom von Verbrauchern und Spannungs-Weiterleitung.
2) „Aktoren“: Feldgeräte, die für den Anschluss an Ausgängen vorgesehen sind.
„Sensoren“: Feldgeräte, die für den Anschluss an Eingängen vorgesehen sind.
3) Versorgungsspannung, die an den Steckverbindern der analogen Schnittstellen zur Verfügung steht.
Technische Daten | EPP4374-0002
Umgebungsbedingungen
Umgebungstemperatur im Betrieb | -25 .. +60 °C 0 .. +55 °C gemäß cURus 0 .. +55 °C gemäß ATEX
Umgebungstemperatur bei Lagerung | -40 .. +85 °C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27; siehe auch Zusätzliche Prüfungen.
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 gemäß EN 60529
Mechanik
Gewicht | ca. 165 g
Einbaulage | beliebig
Zulassungen und Konformität
Zulassungen | CE, cURus
Analoge Eingänge
Der Signalbereich kann im Betrieb umgeschaltet werden. Die folgende Tabelle zeigt die elektrischen Spezifikationen in Abhängigkeit vom gewählten Signalbereich.
Technische Daten | Signalbereich
 | -10 .. 10 V | 0 .. 10 V | 0 .. 20 mA | 4 .. 20 mA
Eingangsart | Differentiell
Eingangswiderstand | > 200 kΩ | > 200 kΩ | 85 Ω typ.+ Diodenspannung | 85 Ω typ. + Diodenspannung
Digitale Auflösung | 16 Bit | 15 Bit | 15 Bit | 15 Bit
Messfehler | < 0,3 %, bezogen auf den Messbereichsendwert
Wandlungszeit | ca. 100 µs
Eingangsfilter Grenzfrequenz | 5 kHz
Wert des niederwertigsten Bits | ca. 305 µV | ca. 305 µV | ca. 610 µA | ca. 488 µA
Die analogen Eingänge und Ausgänge haben ein gemeinsames analoges Massepotential. Das analoge Massepotential ist galvanisch getrennt von allen anderen Massepotentialen in der Box.
Analoge Ausgänge
Der Ausgangssignalbereich kann im Betrieb umgeschaltet werden. Die folgende Tabelle zeigt die elektrischen Spezifikationen in Abhängigkeit vom gewählten Ausgangssignalbereich.
Technische Daten | Ausgangssignalbereich
 | -10 .. 10 V | 0 .. 10 V | 0 .. 20 mA | 4 .. 20 mA
Lastwiderstand / Bürde | > 5 kΩ | > 5 kΩ | < 500 Ω | < 500 Ω
Digitale Auflösung | 16 Bit | 15 Bit | 15 Bit | 15 Bit
Ausgabefehler | < 0,1 % (Umgebungstemperatur 0 °C ... +55 °C) < 0,2 % (Umgebungstemperatur < 0 °C oder > 55 °C) bezogen auf den Endwert.
Wandlungszeit | ca. 40 µs
Wert des niederwertigsten Bits | ca. 305 µV | ca. 305 µV | ca. 610 µA | ca. 488 µA
Die analogen Eingänge und Ausgänge haben ein gemeinsames analoges Massepotential. Das analoge Massepotential ist galvanisch getrennt von allen anderen Massepotentialen in der Box.
Zusätzliche Prüfungen
Die Boxen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3 Achsen
 | 5 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3 Achsen
 | 35 g, 11 ms


Lieferumfang

Produktübersicht [image] Lieferumfang
Lieferumfang
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EtherCAT-P-Box EPP4374-0002
▪
2x Schutzkappe für EtherCAT-P-Buchse, M8, rot (vormontiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
Vormontierte Schutzkappen gewährleisten keinen IP67-Schutz
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Stellen Sie den korrekten Sitz der Schutzkappen sicher, um die Schutzart IP67 zu gewährleisten.


Prozessabbild

Produktübersicht [image] Prozessabbild
Prozessabbild
Weiterführende Informationen
•
Zuordnung von Steckverbindern zu Prozessdatenobjekten
•
Inhalte von Prozessdatenobjekten


Montage und Verkabelung

Montage und Verkabelung
Montage und Verkabelung
Weiterführende Informationen
•
Montage
•
Verkabelung
•
UL-Anforderungen


Montage

Montage und Verkabelung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung


Abmessungen

Montage und Verkabelung [image] Montage [image] Abmessungen
Abmessungen
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 3,5 mm für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Gewicht | ca. 165 g


Befestigung

Montage und Verkabelung [image] Montage [image] Befestigung
Befestigung
Hinweis
Verschmutzung bei der Montage
Verschmutzte Steckverbinder können zu Fehlfunktion führen. Die Schutzart IP67 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind.
•
Schützen Sie die Steckverbinder bei der Montage vor Verschmutzung.
Montieren Sie das Modul mit zwei M3-Schrauben an den Befestigungslöchern in den Ecken des Moduls. Die Befestigungslöcher haben kein Gewinde.


Verkabelung

Montage und Verkabelung [image] Verkabelung
Verkabelung
Richtlinien
Befolgen Sie diese Richtlinien, um die Schutzart IP67 zu gewährleisten:
▪
Montieren Sie Stecker mit den unten angegebenen Drehmomenten. Verwenden Sie einen Drehmomentschlüssel, z.B. Beckhoff ZB8801.
▪
Verschließen Sie nicht benutzte Steckverbinder mit Schutzkappen.
▪
Stellen Sie den korrekten Sitz von vormontierten Schutzkappen sicher.
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Steckverbinder-Übersicht
Hinweis
Verwechselungsgefahr: Eingänge und Ausgänge
Defekt durch Verwechselung von Eingängen und Ausgängen möglich. Die Steckverbinder von Eingängen und Ausgängen sind vom gleichen Typ.
•
Beachten Sie die Namen der Steckverbinder, um eine Verwechselung zu vermeiden.
Steckverbinder-Übersicht
Name | Steckverbinder- Typ | Anzugs- Drehmoment | Funktion
X01 | M12 | 0,6 Nm | Analoge Eingänge
X02
X03 | M12 | 0,6 Nm | Analoge Ausgänge
X04
X50 | M8, P-kodiert | 0,4 Nm | EtherCAT P
X51
Weiterführende Informationen
•
EtherCAT P
•
Analoge Schnittstellen


EtherCAT P

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P
EtherCAT P
Hinweis
Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT/EtherCAT-P-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung von EtherCAT P, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 3 A nicht überschritten wird!
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungsverluste


Steckverbinder

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P [image] Steckverbinder
Steckverbinder
Steckverbinder für EtherCAT P
1 - Eingang
2 - Weiterleitung
Kontaktbelegung
M8-Buchse, P-kodiert
Kontakt | Signal | Spannung | Aderfarben1)
1 | Tx + | GNDS | gelb
2 | Rx + | GNDP | weiß
3 | Rx - | UP: Peripheriespannung, +24 VDC | blau
4 | Tx - | US: Steuerspannung, +24 VDC | orange
Gehäuse | Schirm | Schirm | Schirm
1) Die Aderfarben gelten für EtherCAT-P-Leitungen und ECP-Leitungen von Beckhoff.


Status-LEDs

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P [image] Status-LEDs
Status-LEDs
Weiterführende Informationen
•
Versorgungsspannungen
•
EtherCAT


Versorgungsspannungen

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P [image] Status-LEDs [image] Versorgungsspannungen
Versorgungsspannungen
Status-LEDs für die Spannungsversorgung
EtherCAT-P-Box-Module haben zwei LEDs, die den Status der Versorgungsspannungen anzeigen. Die Status-LEDs sind mit den Bezeichnungen der Versorgungsspannungen beschriftet: Us und Up.
Eine Status-LED leuchtet grün, wenn die jeweilige Versorgungsspannung vorhanden ist.


EtherCAT

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P [image] Status-LEDs [image] EtherCAT
EtherCAT
Status-LEDs für EtherCAT
L/A (Link/Act)
Neben jeder EtherCAT-/EtherCAT-P-Buchse befindet sich eine grüne LED, die mit „L/A“ oder „Link/Act“ beschriftet ist. Die LED signalisiert den Kommunikationsstatus der jeweiligen Buchse:
LED | Bedeutung
aus | keine Verbindung zum angeschlossenen EtherCAT-Gerät
leuchtet | LINK: Verbindung zum angeschlossenen EtherCAT-Gerät
blinkt | ACT: Kommunikation mit dem angeschlossenen EtherCAT-Gerät
Run
Jeder EtherCAT-Slave hat eine grüne LED, die mit „Run“ beschriftet ist. Die LED signalisiert den Status des Slaves im EtherCAT-Netzwerk:
LED | Bedeutung
aus | Slave ist im Status „Init“
blinkt gleichmäßig | Slave ist im Status „Pre-Operational“
blinkt vereinzelt | Slave ist im Status „Safe-Operational“
leuchtet | Slave ist im Status „Operational“
Beschreibung der Stati von EtherCAT-Slaves


Leitungsverluste

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P [image] Leitungsverluste
Leitungsverluste
Beachten Sie bei der Planung einer Anlage den Spannungsabfall an der Versorgungs-Zuleitung. Vermeiden Sie, dass der Spannungsabfall so hoch wird, dass die Versorgungsspannungen an der Box die minimale Nennspannung unterschreiten.
Berücksichtigen Sie auch Spannungsschwankungen des Netzteils.
Spannungsabfall an der Versorgungs-Zuleitung
Leitungsverluste M8-EPP 3A
Spannungsabfall an der Versorgungs-Zuleitung


Analoge Schnittstellen

Montage und Verkabelung [image] Verkabelung [image] Analoge Schnittstellen
Analoge Schnittstellen
Hinweis
Signalbereiche müssen vor der Verkabelung parametriert werden
Defekt durch falsch parametrierte Signalbereiche möglich.
•
Parametrieren Sie die Signalbereiche, bevor Sie Sensoren und Aktoren anschließen.
•
Parametrieren Sie die Signalbereiche entsprechend der Spezifikation der vorgesehenen Sensoren und Aktoren.
Hinweis
Verwechselungsgefahr: Eingänge und Ausgänge
Defekt durch Verwechselung von Eingängen und Ausgängen möglich. Die Steckverbinder von Eingängen und Ausgängen sind vom gleichen Typ.
•
Beachten Sie die Namen der Steckverbinder, um eine Verwechselung zu vermeiden.
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Beispiele


Steckverbinder

Montage und Verkabelung [image] Verkabelung [image] Analoge Schnittstellen [image] Steckverbinder
Steckverbinder
M12-Buchsen
M12-Buchse
Pin | Eingänge X01 und X02 |  | Ausgänge X03 und X04
 | Symbol | Beschreibung | Symbol | Beschreibung
1 | UP | Sensorversorgung + | Out | Analoger Ausgang
2 | In + | Analoger Eingang + | UP | Aktorversorgung +
3 | GNDP | Sensorversorgung Masse | Out GND | Analoge Masse
4 | In - | Analoger Eingang - | GNDP | Aktorversorgung Masse
5 | Schirm |  | Schirm


Status-LEDs

Montage und Verkabelung [image] Verkabelung [image] Analoge Schnittstellen [image] Status-LEDs
Status-LEDs
Status-LEDs an den M12-Anschlüssen
Status-LEDs an den M12-Anschlüssen 1 und 2 (Eingänge)
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse Nr. 1 und 2 | R links | aus | keine Datenübertragung zum D/A-Wandler
 |  | grün | Datenübertragung zum D/A-Wandler
 | E rechts | aus | einwandfreie Funktion
 |  | rot | Fehler: Drahtbruch oder Messwert außerhalb des Messbereichs (kleiner als 3,5 mA / -11 V oder größer als 21 mA /11 V)
Eine einwandfreie Funktion besteht wenn die grüne LED Run leuchtet und die rote LED Error aus ist.
Status-LEDs an den M12-Anschlüssen 3 und 4 (Ausgänge)
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse Nr. 3 und 4 | R links | aus | keine Datenübertragung zum D/A-Wandler
 |  | grün | Datenübertragung zum D/A-Wandler


Beispiele

Montage und Verkabelung [image] Verkabelung [image] Analoge Schnittstellen [image] Beispiele
Beispiele
Analoge Eingänge
Signalanschluss - Analoge Eingänge
Der Sensor wird über In+ und In- angeschlossen. Optional kann der Sensor noch mit 24 VDC betrieben/versorgt werden.
Analoge Ausgänge
Signalanschluss - Analoge Ausgänge
Der Aktor wird über Output +/- und Output GND angeschlossen. Optional kann der Aktor noch mit 24 VDC betrieben/versorgt werden.


UL-Anforderungen

Montage und Verkabelung [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


Inbetriebnahme und Konfiguration

Inbetriebnahme und Konfiguration
Inbetriebnahme und Konfiguration
Weiterführende Informationen
•
Konfiguration in TwinCAT
•
Signalbereiche parametrieren
•
Objektübersicht
•
Objektbeschreibung und Parametrierung
•
Wiederherstellen des Auslieferungszustandes


Konfiguration in TwinCAT

Inbetriebnahme und Konfiguration [image] Konfiguration in TwinCAT
Konfiguration in TwinCAT
Eine EtherCAT Box muss in TwinCAT konfiguriert werden, damit ihre Funktionen in einem SPS-Programm genutzt werden können.
Unter dem folgenden Link finden Sie eine Schnellstartanleitung, die die Konfiguration einer EtherCAT Box in TwinCAT beschreibt:
https://infosys.beckhoff.com/content/1031/epioconfiguration/index.html?id=5323978252154950216


Signalbereiche parametrieren

Inbetriebnahme und Konfiguration [image] Signalbereiche parametrieren
Signalbereiche parametrieren
Hinweis
Signalbereiche müssen vor der Verkabelung parametriert werden
Defekt durch falsch parametrierte Signalbereiche möglich.
•
Parametrieren Sie die Signalbereiche, bevor Sie Sensoren und Aktoren anschließen.
•
Parametrieren Sie die Signalbereiche entsprechend der Spezifikation der vorgesehenen Sensoren und Aktoren.
Der Signalbereich jedes analogen Eingangs und Ausgangs kann individuell parametriert werden. Die Parameter, die den Signalbereich definieren, befinden sich im CoE-Verzeichnis:
Schnittstelle | CoE-Index
Analoger Eingang X01 | F800:01
Analoger Eingang X02 | F800:02
Analoger Ausgang X03 | F800:03
Analoger Ausgang X04 | F800:04
TwinCAT
Gehen Sie wie folgt vor, um den Signalbereich eines analogen Kanals in TwinCAT zu ändern:
1.
Doppelklicken Sie im IO-Baum auf das IO-Modul EPP4374-0002.
2.
Klicken Sie auf den Karteireiter „CoE – Online“.
⇨
Das CoE-Verzeichnis wird angezeigt.
3.
Doppelklicken Sie auf den CoE-Index der Schnittstelle, die Sie parametrieren wollen (s. Tabelle oben).
4.
Wählen Sie im erscheinenden Dialogfenster den Signalbereich.


Objektübersicht

Inbetriebnahme und Konfiguration [image] Objektübersicht
Objektübersicht
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Index (hex) |  | Name | Flags | Default Wert
1000 |  | Device type | RO | 0x00001389 (5001dez)
1008 |  | Device name | RO | EP4374-0002
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 02
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x11164052 (286670930dez)
 | 1018:03 | Revision | RO | 0x00110002 (1114114dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1600:0 | Subindex | AO Outputs Ch.3 | RO | 0x01 (1dez)
 | 1600:01 | SubIndex 001 | RO | 0x7020:11, 16
1601:0 | Subindex | AO Outputs Ch.4 | RO | 0x01 (1dez)
 | 1601:01 | SubIndex 001 | RO | 0x7030:11, 16
1800:0 | Subindex | AI Inputs Ch.1 | RO | 0x06 (6dez)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
1801:0 | Subindex | AI Inputs Compact Ch.1 | RO | 0x06 (6dez)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
1802:0 | Subindex | AI Inputs Ch.2 | RO | 0x06 (6dez)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
1803:0 | Subindex | AI Inputs Compact Ch.2 | RO | 0x06 (6dez)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A
1A00:0 | Subindex | AI Inputs Ch.1 | RO | 0x0B (11dez)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 2
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 2
 | 1A00:05 | SubIndex 005 | RO | 0x6000:07, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A00:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A00:08 | SubIndex 008 | RO | 0x6000:0E, 1
 | 1A00:09 | SubIndex 009 | RO | 0x6000:0F, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:10, 1
 | 1A00:0B | SubIndex 011 | RO | 0x6000:11, 16
Index (hex) |  | Name | Flags | Default Wert
1A01:0 | Subindex | AI Inputs Compact Ch.1 | RO | 0x01 (1dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:11, 16
1A02:0 | Subindex | AI Inputs Ch.2 | RO | 0x0B (11dez)
 | 1A02:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A02:08 | SubIndex 008 | RO | 0x6010:0E, 1
 | 1A02:09 | SubIndex 009 | RO | 0x6010:0F, 1
 | 1A02:0A | SubIndex 010 | RO | 0x6010:10, 1
 | 1A02:0B | SubIndex 011 | RO | 0x6010:11, 16
1A03:0 | Subindex | AI Inputs Compact Ch.2 | RO | 0x01 (1dez)
 | 1A03:01 | SubIndex 001 | RO | 0x6010:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x02 (2dez)
 | 1C12:01 | SubIndex 001 | RW | 0x1600 (5632dez)
 | 1C12:02 | SubIndex 002 | RW | 0x1601 (5633dez)
1C13:0 | Subindex | TxPDO assign | RW | 0x02 (2dez)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 | 1C13:02 | SubIndex 002 | RW | 0x1A02 (6658dez)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dez)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C32:03 | Shift time | RO | 0x00002710 (10000dez)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C32:05 | Minimum cycle time | RO | 0x0007A120 (500000dez)
 | 1C32:06 | Calc and copy time | RO | 0x00001388 (5000dez)
 | 1C32:07 | Minimum delay time | RO | 0x00001388 (5000dez)
 | 1C32:08 | Command | RW | 0x0000 (0dez)
 | 1C32:09 | Maximum delay time | RO | 0x00001388 (5000dez)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C32:20 | Sync error | RO | 0x00 (0dez)
Index (hex) |  | Name | Flags | Default Wert
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dez)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dez)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C33:03 | Shift time | RO | 0x00001388 (5000dez)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C33:05 | Minimum cycle time | RO | 0x0007A120 (500000dez)
 | 1C33:06 | Calc and copy time | RO | 0x00002710 (10000dez)
 | 1C33:07 | Minimum delay time | RO | 0x00001388 (5000dez)
 | 1C33:08 | Command | RW | 0x0000 (0dez)
 | 1C33:09 | Maximum delay time | RO | 0x00001388 (5000dez)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 | Subindex | AI Inputs Ch.1 | RO | 0x11 (17dez)
 | 6000:01 | Underrange | RO | 0x00 (0dez)
 | 6000:02 | Overrange | RO | 0x00 (0dez)
 | 6000:03 | Limit 1 | RO | 0x00 (0dez)
 | 6000:05 | Limit 2 | RO | 0x00 (0dez)
 | 6000:07 | Error | RO | 0x00 (0dez)
 | 6000:0E | Sync error | RO | 0x00 (0dez)
 | 6000:0F | TxPDO State | RO | 0x00 (0dez)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6000:11 | Value | RO | 0x0000 (0dez)
6010:0 | Subindex | AI Inputs Ch.2 | RO | 0x11 (17dez)
 | 6010:01 | Underrange | RO | 0x00 (0dez)
 | 6010:02 | Overrange | RO | 0x00 (0dez)
 | 6010:03 | Limit 1 | RO | 0x00 (0dez)
 | 6010:05 | Limit 2 | RO | 0x00 (0dez)
 | 6010:07 | Error | RO | 0x00 (0dez)
 | 6010:0E | Sync error | RO | 0x00 (0dez)
 | 6010:0F | TxPDO State | RO | 0x00 (0dez)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6010:11 | Value | RO | 0x0000 (0dez)
Index (hex) |  | Name | Flags | Default Wert
7020:0 | Subindex | AO Outputs Ch.3 | RO | 0x11 (17dez)
 | 7020:11 | Analog output | RO | 0x0000 (0dez)
7030:0 | Subindex | AO Outputs Ch.4 | RO | 0x11 (17dez)
 | 7030:11 | Analog output | RO | 0x0000 (0dez)
8000:0 | Subindex | AI Settings Ch.1 | RW | 0x18 (24dez)
 | 8000:01 | Enable user scale | RW | 0x00 (0dez)
 | 8000:02 | Presentation | RW | 0x00 (0dez)
 | 8000:05 | Siemens bits | RW | 0x00 (0dez)
 | 8000:06 | Enable filter | RW | 0x00 (0dez)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8000:11 | User scale offset | RW | 0x0000 (0dez)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8000:15 | Filter settings | RW | 0x0000 (0dez)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dez)
800E:0 | Subindex | AI Internal data Ch.1 | RO | 0x01 (1dez)
 | 800E:01 | ADC raw value | RO | 0x0000 (0dez)
800F:0 | Subindex | AI Vendor data Ch.1 | RW | 0x06 (6dez)
 | 800F:01 | R0 offset | RW | 0x0000 (0dez)
 | 800F:02 | R0 gain | RW | 0x4000 (16384dez)
 | 800F:03 | R1 offset | RW | 0x0000 (0dez)
 | 800F:04 | R1 gain | RW | 0x4000 (16384dez)
 | 800F:05 | R2 offset | RW | 0x0000 (0dez)
 | 800F:06 | R2 gain | RW | 0x4000 (16384dez)
8010:0 | Subindex | AI Settings Ch.2 | RW | 0x18 (24dez)
 | 8010:01 | Enable user scale | RW | 0x00 (0dez)
 | 8010:02 | Presentation | RW | 0x00 (0dez)
 | 8010:05 | Siemens bits | RW | 0x00 (0dez)
 | 8010:06 | Enable filter | RW | 0x00 (0dez)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8010:11 | User scale offset | RW | 0x0000 (0dez)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8010:15 | Filter settings | RW | 0x0000 (0dez)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dez)
Index (hex) |  | Name | Flags | Default Wert
801E:0 | Subindex | AI Internal data Ch.2 | RO | 0x01 (1dez)
 | 801E:01 | ADC raw value | RO | 0x0000 (0dez)
801F:0 | Subindex | AI Vendor data Ch.2 | RW | 0x06 (6dez)
 | 801F:01 | R0 offset | RW | 0x0000 (0dez)
 | 801F:02 | R0 gain | RW | 0x4000 (16384dez)
 | 801F:03 | R1 offset | RW | 0x0000 (0dez)
 | 801F:04 | R1 gain | RW | 0x4000 (16384dez)
 | 801F:05 | R2 offset | RW | 0x0000 (0dez)
 | 801F:06 | R2 gain | RW | 0x4000 (16384dez)
8020:0 | Subindex | AO Settings Ch.3 | RW | 0x16 (22dez)
 | 8020:01 | Enable user scale | RW | 0x00 (0dez)
 | 8020:02 | Presentation | RW | 0x00 (0dez)
 | 8020:05 | Watchdog | RW | 0x00 (0dez)
 | 8020:07 | Enable user calibration | RW | 0x00 (0dez)
 | 8020:08 | Enable vendor calibration | RW | 0x01 (1dez)
 | 8020:11 | User scale offset | RW | 0x0000 (0dez)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8020:13 | Default output | RW | 0x0000 (0dez)
 | 8020:14 | Default output ramp | RW | 0xFFFF (65535dez)
 | 8020:15 | User calibration offset | RW | 0x0000 (0dez)
 | 8020:16 | User calibration gain | RW | 0x4000 (16384dez)
802E:0 | Subindex | AO Internal data Ch.3 | RO | 0x01 (1dez)
 | 802E:01 | DAC raw value | RO | 0x0000 (0dez)
802F:0 | Subindex | AO Vendor data Ch.3 | RW | 0x06 (6dez)
 | 802F:01 | R0 Calibration Offset | RW | 0x0000 (0dez)
 | 802F:02 | R0 Calibration Gain | RW | 0x4000 (16384dez)
 | 802F:03 | R1 Calibration Offset | RW | 0x0000 (0dez)
 | 802F:04 | R1 Calibration Gain | RW | 0x4000 (16384dez)
 | 802F:05 | R2 Calibration Offset | RW | 0x0000 (0dez)
 | 802F:06 | R2 Calibration Gain | RW | 0x4000 (16384dez)
Index (hex) |  | Name | Flags | Default Wert
8030:0 | Subindex | AO Settings Ch.4 | RW | 0x16 (22dez)
 | 8030:01 | Enable user scale | RW | 0x00 (0dez)
 | 8030:02 | Presentation | RW | 0x00 (0dez)
 | 8030:05 | Watchdog | RW | 0x00 (0dez)
 | 8030:07 | Enable user calibration | RW | 0x00 (0dez)
 | 8030:08 | Enable vendor calibration | RW | 0x01 (1dez)
 | 8030:11 | User scale offset | RW | 0x0000 (0dez)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8030:13 | Default output | RW | 0x0000 (0dez)
 | 8030:14 | Default output ramp | RW | 0xFFFF (65535dez)
 | 8030:15 | User calibration offset | RW | 0x0000 (0dez)
 | 8030:16 | User calibration gain | RW | 0x4000 (16384dez)
803E:0 | Subindex | AO Internal data Ch.4 | RO | 0x01 (1dez)
 | 803E:01 | DAC raw value | RO | 0x0000 (0dez)
803F:0 | Subindex | AO Vendor data Ch.4 | RW | 0x06 (6dez)
 | 803F:01 | R0 Calibration Offset | RW | 0x0000 (0dez)
 | 803F:02 | R0 Calibration Gain | RW | 0x4000 (16384dez)
 | 803F:03 | R1 Calibration Offset | RW | 0x0000 (0dez)
 | 803F:04 | R1 Calibration Gain | RW | 0x4000 (16384dez)
 | 803F:05 | R2 Calibration Offset | RW | 0x0000 (0dez)
 | 803F:06 | R2 Calibration Gain | RW | 0x4000 (16384dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x04 (4dez)
 | F010:01 | SubIndex 001 | RW | 0x0000012C (300dez)
 | F010:02 | SubIndex 002 | RW | 0x0000012C (300dez)
 | F010:03 | SubIndex 003 | RW | 0x00000190 (400dez)
 | F010:04 | SubIndex 004 | RW | 0x00000190 (400dez)
F800:0 | Subindex | AIAO Range settings | RW | 0x04 (4dez)
 | F800:01 | Input type Ch1 | RW | 0x0000 (0dez)
 | F800:02 | Input type Ch2 | RW | 0x0000 (0dez)
 | F800:03 | Output type Ch3 | RW | 0x0000 (0dez)
 | F800:04 | Output type Ch4 | RW | 0x0000 (0dez)
Legende
Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden


Objektbeschreibung und Parametrierung

Inbetriebnahme und Konfiguration [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die zum regulären Betrieb z. B. durch ADS-Zugriff bestimmt sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
▪
Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Objekte zur Parametrierung bei der Inbetriebnahme
•
Standardobjekte (0x1000-0x1FFF)
•
Profilspezifische Objekte (0x6000-0xFFFF)


Objekte zur Parametrierung bei der Inbetriebnahme

Inbetriebnahme und Konfiguration [image] Objektbeschreibung und Parametrierung [image] Objekte zur Parametrierung bei der Inbetriebnahme
Objekte zur Parametrierung bei der Inbetriebnahme
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 AI Settings Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8000:0 | AI Settings Ch.1 | Maximaler Subindex |  | UINT8 | RO | 0x18 (24dez)
8000:01 | Enable user scale | 0bin | Die Anwender-Skalierung ist nicht aktiv. | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Die Anwender-Skalierung ist aktiv.
8000:02 | Presentation | 0dez | Signed presentation | BIT3 | RW | 0x00 (0dez)
 |  | 1dez | Unsigned presentation
 |  | 2dez | Absolute value with MSB as sign (Betragsvorzeichendarstellung)
8000:05 | Siemens bits |  |  | BOOLEAN | RW | 0x00 (0dez)
8000:06 | Enable filter | 0bin | Filter nicht aktiviert | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Filter aktiviert, dadurch entfällt der SPS-zyklussynchrone Datenaustausch
8000:07 | Enable limit 1 | 0bin | Limit 1 nicht aktiviert | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Limit 1 aktiviert
8000:08 | Enable limit 2 | 0bin | Limit 2 nicht aktiviert | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Limit 2 aktiviert
8000:0A | Enable user calibration | 0bin | Anwender-Abgleich nicht aktiviert | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Anwender-Abgleich aktiviert
8000:0B | Enable vendor calibration | 0bin | Hersteller-Abgleich nicht aktiviert | BOOLEAN | RW | 0x01 (1dez)
 |  | 1bin | Hersteller-Abgleich aktiviert
8000:0E | Swap limit bits | 1bin | Limit-Bits getauscht | BOOLEAN | RW | 0x00 (0dez)
8000:11 | User scale offset | Anwender-Skalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8000:12 | User scale gain | Anwender-Skalierung: Gain Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8000:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8000:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8000:15 | Filter settings | Dieses Objekt bestimmt die digitalen Filtereinstellungen, wenn es über Enable filter (Index 0x80n0:06) aktiv ist. Die möglichen Einstellungen sind fortlaufend nummeriert. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0dez | 50 Hz FIR
 |  | 1dez | 60 Hz FIR
 |  | 2dez | IIR 1
 |  | 3dez | IIR 2
 |  | 4dez | IIR 3
 |  | 5dez | IIR 4
 |  | 6dez | IIR 5
 |  | 7dez | IIR 6
 |  | 8dez | IIR 71
 |  | 9dez | IIR 8
8000:17 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8000:18 | User calibration gain | Anwenderabgleich: Gain |  | INT16 | RW | 0x4000 (16384dez)
Index 8010 AI Settings Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8010:0 | AI Settings Ch.2 | Maximaler Subindex |  | UINT8 | RO | 0x18 (24dez)
8010:01 | Enable user scale | 0bin | Die Anwender-Skalierung ist nicht aktiv. | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Die Anwender-Skalierung ist aktiv.
8010:02 | Presentation | 0dez | Signed presentation | BIT3 | RW | 0x00 (0dez)
 |  | 1dez | Unsigned presentation
 |  | 2dez | Absolute value with MSB as sign (Betragsvorzeichendarstellung)
8010:05 | Siemens bits |  |  | BOOLEAN | RW | 0x00 (0dez)
8010:06 | Enable filter | 0bin | Filter nicht aktiviert | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Filter aktiviert, dadurch entfällt der SPS-zyklussynchrone Datenaustausch
8010:07 | Enable limit 1 | 0bin | Limit 1 nicht aktiviert | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Limit 1 aktiviert
8010:08 | Enable limit 2 | 0bin | Limit 2 nicht aktiviert | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Limit 2 aktiviert
8010:0A | Enable user calibration | 0bin | Anwender-Abgleich nicht aktiviert | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Anwender-Abgleich aktiviert
8010:0B | Enable vendor calibration | 0bin | Hersteller-Abgleich nicht aktiviert | BOOLEAN | RW | 0x01 (1dez)
 |  | 1bin | Hersteller-Abgleich aktiviert
8010:0E | Swap limit bits | 1bin | Limit-Bits getauscht | BOOLEAN | RW | 0x00 (0dez)
8010:11 | User scale offset | Anwender-Skalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8010:12 | User scale gain | Anwender-Skalierung: Gain Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8010:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8010:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8010:15 | Filter settings | Dieses Objekt bestimmt die digitalen Filtereinstellungen, wenn es über Enable filter (Index 0x80n0:06) aktiv ist. Die möglichen Einstellungen sind fortlaufend nummeriert. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0dez | 50 Hz FIR
 |  | 1dez | 60 Hz FIR
 |  | 2dez | IIR 1
 |  | 3dez | IIR 2
 |  | 4dez | IIR 3
 |  | 5dez | IIR 4
 |  | 6dez | IIR 5
 |  | 7dez | IIR 6
 |  | 8dez | IIR 71
 |  | 9dez | IIR 8
8010:17 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8010:18 | User calibration gain | Anwenderabgleich: Gain |  | INT16 | RW | 0x4000 (16384dez)
Index 8020 AO Settings Ch.3
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8020:0 | AO Settings Ch.3 | Maximaler Subindex |  | UINT8 | RO | 0x16 (22dez)
8020:01 | Enable user scale | 0bin | Anwenderskalierung nicht aktiv | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Anwenderskalierung aktiv
8020:02 | Presentation | 0dez | Signed presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit signed Integer dargestellt. Bei unipolaren Klemmen (0-10 V oder 0-20 mA) wird der negative Bereich auf Null gesetzt. | BIT3 | RW | 0x00 (0dez)
 |  | 1dez | Unsigned presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit unsigned Integer dargestellt. Negative Werte sind nicht möglich.
 |  | 2dez | Absolute value with MSB as sign Betragsvorzeichendarstellung ist aktiv.
 |  | 3dez | Absolute value Es wird der Absolutwert der signed Darstellung gebildet.
8020:05 | Watchdog | 0dez | Default watchdog value Der Defaultwert (0x8pp0:13) ist aktiv. | BIT2 | RW | 0x00 (0dez)
 |  | 1dez | Watchdog ramp Die Rampe (0x8pp0:14) zum Fahren auf den Defaultwert ((0x8pp0:13)) ist aktiv.
 |  | 2dez | Last output value Das letzte Prozessdatum wird im Fehlerfall (Ansprechen des Watchdogs) ausgegeben.
8020:07 | Enable user calibration | 0bin | Anwender-Abgleich nicht aktiv | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Anwender-Abgleich aktiv
8020:08 | Enable vendor calibration | 0bin | Hersteller-Abgleich nicht aktiv | BOOLEAN | RW | 0x01 (1dez)
 |  | 1bin | Hersteller-Abgleich aktiv
8020:11 | User scale offset | Anwenderskalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8020:12 | User scale gain | Anwenderskalierung: Gain Dies ist der Gain der Anwenderskalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert eins entspricht 65535 (0x00010000). |  | INT32 | RW | 0x00010000 (65536dez)
8020:13 | Default output | Default-Ausgabewert |  | INT16 | RW | 0x0000 (0dez)
8020:14 | Default output ramp | Dieser Wert legt die Rampen zum Herunterfahren auf den Defaultwert fest. Der Wert wird in Digits/ms vorgegeben. Ist der Eintrag z.B. 100 und der Defaultwert 0, so dauert es 327ms (32767/100) bis der Ausgangswert im Fehlerfall vom Maximalwert (32767) auf den Defaultwert geht. |  | UINT16 | RW | 0xFFFF (65535dez)
8020:15 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8020:16 | User calibration gain | Anwenderabgleich: Gain |  | UINT16 | RW | 0x4000 (16384dez)
Index 8030 AO Settings Ch.4
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8030:0 | AO Settings Ch.4 | Maximaler Subindex |  | UINT8 | RO | 0x16 (22dez)
8030:01 | Enable user scale | 0bin | Anwenderskalierung nicht aktiv | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Anwenderskalierung aktiv
8030:02 | Presentation | 0dez | Signed presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit signed Integer dargestellt. Bei unipolaren Klemmen (0-10 V oder 0-20 mA) wird der negative Bereich auf Null gesetzt. | BIT3 | RW | 0x00 (0dez)
 |  | 1dez | Unsigned presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit unsigned Integer dargestellt. Negative Werte sind nicht möglich.
 |  | 2dez | Absolute value with MSB as sign Betragsvorzeichendarstellung ist aktiv.
 |  | 3dez | Absolute value Es wird der Absolutwert der signed Darstellung gebildet.
8030:05 | Watchdog | 0dez | Default watchdog value Der Defaultwert (0x8pp0:13) ist aktiv. | BIT2 | RW | 0x00 (0dez)
 |  | 1dez | Watchdog ramp Die Rampe (0x8pp0:14) zum Fahren auf den Defaultwert ((0x8pp0:13)) ist aktiv.
 |  | 2dez | Last output value Das letzte Prozessdatum wird im Fehlerfall (Ansprechen des Watchdogs) ausgegeben.
8030:07 | Enable user calibration | 0bin | Anwender-Abgleich nicht aktiv | BOOLEAN | RW | 0x00 (0dez)
 |  | 1bin | Anwender-Abgleich aktiv
8030:08 | Enable vendor calibration | 0bin | Hersteller-Abgleich nicht aktiv | BOOLEAN | RW | 0x01 (1dez)
 |  | 1bin | Hersteller-Abgleich aktiv
8030:11 | User scale offset | Anwenderskalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8030:12 | User scale gain | Anwenderskalierung: Gain Dies ist der Gain der Anwenderskalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert eins entspricht 65535 (0x00010000). |  | INT32 | RW | 0x00010000 (65536dez)
8030:13 | Default output | Default-Ausgabewert |  | INT16 | RW | 0x0000 (0dez)
8030:14 | Default output ramp | Dieser Wert legt die Rampen zum Herunterfahren auf den Defaultwert fest. Der Wert wird in Digits/ms vorgegeben. Ist der Eintrag z. B. 100 und der Defaultwert 0, so dauert es 327 ms (32767/100) bis der Ausgangswert im Fehlerfall vom Maximalwert (32767) auf den Defaultwert geht. |  | UINT16 | RW | 0xFFFF (65535dez)
8030:15 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8030:16 | User calibration gain | Anwenderabgleich: Gain |  | UINT16 | RW | 0x4000 (16384dez)
Index F800 AIAO Range settings
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
F800:0 | AIAO Range settings | Maximaler Subindex |  | UINT8 | RO | 0x04 (4dez)
F800:01 | Input type Ch1 | Eingangssignalbereich für Kanal 1 |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0dez | -10...+10 V
 |  | 1dez | 0...20 mA
 |  | 2dez | 4...20 mA
 |  | 3dez | 0...10 V
F800:02 | Input type Ch2 | Eingangssignalbereich für Kanal 2 (Werte siehe Kanal 1 |  | UINT16 | RW | 0x0000 (0dez)
F800:03 | Output type Ch3 | Ausgangssignalbereich für Kanal 3 |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0dez | -10...+10 V
 |  | 1dez | 0...20 mA
 |  | 2dez | 4...20 mA
 |  | 3dez | 0...10 V
F800:04 | Output type Ch4 | Ausgangssignalbereich für Kanal 4 (Werte siehe Kanal 3) |  | UINT16 | RW | 0x0000 (0dez)


Standardobjekte (0x1000-0x1FFF)

Inbetriebnahme und Konfiguration [image] Objektbeschreibung und Parametrierung [image] Standardobjekte (0x1000-0x1FFF)
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EPP4374-0002
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 02
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x6476D769 (1685509993dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00110002 (1114114dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 AO Outputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | AO Outputs Ch.3 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (AO outputs Ch.3), entry 0x11 (Analog output)) | UINT32 | RO | 0x7020:11, 16
Index 1601 AO Outputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | AO Outputs Ch.4 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (AO outputs Ch.4), entry 0x11 (Analog output)) | UINT32 | RO | 0x7030:11, 16
Index 1800 AI Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | AI Inputs Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 1801 AI Inputs Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | AI Inputs Compact Ch.1 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 1802 AI Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | AI Inputs Ch.2 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[2] | RO | 03 1A
Index 1803 AI Inputs Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | AI Inputs Compact Ch.2 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 02 1A
Index 1A00 AI Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | AI Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 AI Inputs Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | AI Inputs Compact Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A02 AI Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | AI Inputs Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A03 AI Inputs Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | AI Inputs Compact Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
Index 1C32 SM output parameter
Index (hex) | Name | Bedeutung |  |  | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs |  |  | UINT8 | RO | 0x20 (32dez)
1C32:01 | Sync mode | Wert | Aktuelle Synchronisierungsbetriebsart |  | UINT16 | RW | 0x0001 (1dez)
 |  | 0 | Free Run
 |  | 1 | Synchron with SM 2 Event
 |  | 2 | DC-Mode - Synchron with SYNC0 Event
 |  | 3 | DC-Mode - Synchron with SYNC1 Event
1C32:02 | Cycle time | Zykluszeit (in ns) |  |  | UINT32 | RW | 0x000F4240 (1000000dez)
 |  | Free Run |  | Zykluszeit des lokalen Timers
 |  | Synchron with SM 2 Event |  | Zykluszeit des Masters
 |  | DC-Mode |  | SYNC0/SYNC1 Cycle Time
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) |  |  | UINT32 | RO | 0x00002710 (10000dez)
1C32:04 | Sync modes supported | Bit | Wert | Unterstützte Synchronisierungsbetriebsarten: | UINT16 | RO | 0xC007 (49159dez)
 |  | 0 | 1 | Free Run wird unterstützt
 |  | 1 | 1 | Synchron mit SM 2 Event wird unterstützt
 |  | 3,2 | 01 | DC-Mode wird unterstützt
 |  | 5,4 | 10 | Output Shift mit SYNC1 Event (nur DC-Mode)
 |  | 14 | 1 | dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) |  |  | UINT32 | RO | 0x0007A120 (500000dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) |  |  | UINT32 | RO | 0x00001388 (5000dez)
1C32:07 | Minimum delay time |  |  |  | UINT32 | RO | 0x00001388 (5000dez)
1C32:08 | Command | 0 | Messung der lokalen Zykluszeit wird gestoppt |  | UINT16 | RW | 0x0000 (0dez)
 |  | 1 | Messung der lokalen Zykluszeit wird gestartet
 |  | Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09
1C32:09 | Maximum Delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) |  |  | UINT32 | RO | 0x00001388 (5000dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) |  |  | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) |  |  | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) |  |  | UINT16 | RO | 0x0000 (0dez)
1C32:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) |  |  | BOOLEAN | RO | 0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00001388 (5000dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x0007A120 (500000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00002710 (10000dez)
1C33:07
Minimum delay time
UINT32
RO
0x00001388 (5000dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00001388 (5000dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)


Profilspezifische Objekte (0x6000-0xFFFF)

Inbetriebnahme und Konfiguration [image] Objektbeschreibung und Parametrierung [image] Profilspezifische Objekte (0x6000-0xFFFF)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000 AI Inputs Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6000:0 | AI Inputs Ch.1 |  |  | UINT8 | RO | 0x11 (17dez)
6000:01 | Underrange | Underrange event active |  | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Overrange | Overrange event active |  | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Limit 1 | Bit 0 = 1bin | Wert größer als Limit1 | BIT2 | RO | 0x00 (0dez)
 |  | Bit 1 = 1bin | Wert kleiner als Limit1
6000:05 | Limit 2 | Bit 0 = 1bin | Wert größer als Limit2 | BIT2 | RO | 0x00 (0dez)
 |  | Bit 1 = 1bin | Wert kleiner als Limit2
6000:07 | Error | Bit set when Over- or Underrange |  | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State |  |  | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle |  |  | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Value |  |  | INT16 | RO | 0x0000 (0dez)
Index 6010 AI Inputs Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6010:0 | AI Inputs Ch.2 |  |  | UINT8 | RO | 0x11 (17dez)
6010:01 | Underrange | Underrange event active |  | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Overrange | Overrange event active |  | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Limit 1 | Bit 0 = 1bin | Wert größer als Limit1 | BIT2 | RO | 0x00 (0dez)
 |  | Bit 1 = 1bin | Wert kleiner als Limit1
6010:05 | Limit 2 | Bit 0 = 1bin | Wert größer als Limit2 | BIT2 | RO | 0x00 (0dez)
 |  | Bit 1 = 1bin | Wert kleiner als Limit2
6010:07 | Error | Bit set when Over- or Underrange |  | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO State |  |  | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle |  |  | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Value |  |  | INT16 | RO | 0x0000 (0dez)
Index 7020 AO Outputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | AO Outputs Ch.3 |  | UINT8 | RO | 0x11 (17dez)
7020:11 | Analog output | Das analoge Ausgangsdatum | INT16 | RO | 0x0000 (0dez)
Index 7030 AO Outputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7030:0 | AO Outputs Ch.4 |  | UINT8 | RO | 0x11 (17dez)
7030:11 | Analog output | Das analoge Ausgangsdatum | INT16 | RO | 0x0000 (0dez)
Index 800E AI Internal data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800E:0 | AI Internal data Ch.1 |  | UINT8 | RO | 0x01 (1dez)
800E:01 | ADC raw value |  | INT16 | RO | 0x0000 (0dez)
Index 800F AI Vendor data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800F:0 | AI Vendor data Ch.1 |  | UINT8 | RO | 0x06 (6dez)
800F:01 | R0 offset |  | INT16 | RW | 0x0000 (0dez)
800F:02 | R0 gain |  | INT16 | RW | 0x4000 (16384dez)
800F:03 | R1 offset |  | INT16 | RW | 0x0000 (0dez)
800F:04 | R1 gain |  | INT16 | RW | 0x4000 (16384dez)
800F:05 | R2 offset |  | INT16 | RW | 0x0000 (0dez)
800F:06 | R2 gain |  | INT16 | RW | 0x4000 (16384dez)
Index 801E AI Internal data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801E:0 | AI Internal data Ch.2 |  | UINT8 | RO | 0x01 (1dez)
801E:01 | ADC raw value |  | INT16 | RO | 0x0000 (0dez)
Index 801F AI Vendor data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801F:0 | AI Vendor data Ch.2 |  | UINT8 | RO | 0x06 (6dez)
801F:01 | R0 offset |  | INT16 | RW | 0x0000 (0dez)
801F:02 | R0 gain |  | INT16 | RW | 0x4000 (16384dez)
801F:03 | R1 offset |  | INT16 | RW | 0x0000 (0dez)
801F:04 | R1 gain |  | INT16 | RW | 0x4000 (16384dez)
801F:05 | R2 offset |  | INT16 | RW | 0x0000 (0dez)
801F:06 | R2 gain |  | INT16 | RW | 0x4000 (16384dez)
Index 802E AO Internal data Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802E:0 | AO Internal data Ch.3 |  | UINT8 | RO | 0x01 (1dez)
802E:01 | DAC raw value | Dies ist der DAC Rohwert. | UINT16 | RO | 0x0000 (0dez)
Index 802F AO Vendor data Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802F:0 | AO Vendor data Ch.3 |  | UINT8 | RO | 0x06 (6dez)
802F:01 | R0 Calibration Offset | Herstellerabgleich: Offset für +/-10 V | INT16 | RW | 0x0000 (0dez)
802F:02 | R0 Calibration Gain | Herstellerabgleich: Gain für für +/-10 V | UINT16 | RW | 0x4000 (16384dez)
802F:03 | R1 Calibration Offset | Herstellerabgleich: Offset für 0-20 mA | INT16 | RW | 0x0000 (0dez)
802F:04 | R1 Calibration Gain | Herstellerabgleich: Gain für für 0-20 mA | UINT16 | RW | 0x4000 (16384dez)
802F:05 | R2 Calibration Offset | Herstellerabgleich: Offset für 4-20 mA | INT16 | RW | 0x0000 (0dez)
802F:06 | R2 Calibration Gain | Herstellerabgleich: Gain für 4-20 mA | UINT16 | RW | 0x4000 (16384dez)
Index 803E AO Internal data Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803E:0 | AO Internal data Ch.4 |  | UINT8 | RO | 0x01 (1dez)
803E:01 | DAC raw value | Dies ist der DAC Rohwert. | UINT16 | RO | 0x0000 (0dez)
Index 803F AO Vendor data Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803F:0 | AO Vendor data Ch.4 |  | UINT8 | RO | 0x06 (6dez)
803F:01 | R0 Calibration Offset | Herstellerabgleich: Offset für +/-10 V | INT16 | RW | 0x0000 (0dez)
803F:02 | R0 Calibration Gain | Herstellerabgleich: Gain für für +/-10 V | UINT16 | RW | 0x4000 (16384dez)
803F:03 | R1 Calibration Offset | Herstellerabgleich: Offset für 0-20 mA | INT16 | RW | 0x0000 (0dez)
803F:04 | R1 Calibration Gain | Herstellerabgleich: Gain für für 0-20 mA | UINT16 | RW | 0x4000 (16384dez)
803F:05 | R2 Calibration Offset | Herstellerabgleich: Offset für 4-20 mA | INT16 | RW | 0x0000 (0dez)
803F:06 | R2 Calibration Gain | Herstellerabgleich: Gain für 4-20 mA | UINT16 | RW | 0x4000 (16384dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0004 (4dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x04 (4dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000190 (400dez)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x00000190 (400dez)


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme und Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx- und EPPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der IP-67-Module und die verwendeten Metallteile. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)

Anhang [image] Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
Allgemeines
Zukünftig werden Sie vermehrt auf Beckhoff Produkten maschinenlesbare Informationen in Form eines Data Matrix Codes (DMC, Code-Schema ECC200) finden. Dieser hilft uns bei der Verbesserung des Qualitätssicherungsprozesses und kann darüber hinaus von Ihnen zur besseren Identifikation unserer Produkte genutzt werden.
Die Einführung des Data Matrix Codes (bei Beckhoff BIC = Beckhoff Identification Code genannt) erfolgt schrittweise über alle Produktgruppen hinweg.
Die Informationen des BICs orientieren sich an dem ANSI-Standard MH10.8.2-2016
Darstellung und Inhalte des BICs
Der BIC ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist lesbar und enthält Informationen, die Sie für Ihr internes Handling und Verwaltung der Produkte nutzen können. Beim Scannen des BICs finden Sie folgende Informationen:
Codierte Informationen auf dem BIC
Pos.-Nr. | Art der Information | Erklärung
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u.
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10…
5 | Chargennummer | Optional: Produktionsjahr und -woche
6 | ID-/Seriennummer | Optional: Heutiges Seriennummer-System, z. B. bei Safety-Produkten
7 | Variantennummer | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten
8 | Date Code | Intern
9 | Auftrags-/Chargennummer | Intern
10 | Seriennummer | Intern
... |  |
Jede Information ist anhand des sog. Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gem. nachstehender Tabelle. Sind die Informationen kürzer werden sie durch Leerzeichen ersetzt. Die Daten unter den Positionen 1-4 sind immer vorhanden (temporäre Einschränkung, s. u., BTN).
Übersicht der festgelegten Datenidentifikatoren mit Beispielen
Pos-Nr. | Art der Information | Datenidentifikator | Anzahl Stellen | Beispiel
1 | Beckhoff-Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | 1K | 32 | 1KEL1809
4 | Menge | Q | 6 | Q1
5 | Chargennummer | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | 51S | 12 | 51S678294104
7 | Variante | 30P | 32 | 30PF971 , 2*K183
8 | Date Code | 9D | 8 | 9DG0118
9 | Auftrags-/Chargennummer | 1T | 14 | 1TFA12345678
10 | Seriennummer | 52S | 23 | 52S2304853-1-004
... |  |  |  |
Aufbau des BICs
Beispiel einer zusammengesetzten Information aus den Positionen 1 - 4 und 6. Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die in Zukunft alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Zuordnung von Steckverbindern zu Prozessdatenobjekten

Produktübersicht [image] Prozessabbild [image] Zuordnung von Steckverbindern zu Prozessdatenobjekten
Zuordnung von Steckverbindern zu Prozessdatenobjekten
Prozessabbild in TwinCAT | Steckverbinder | Prozessdatenobjekt
EPP4374 Prozessabbild zugeklappt | X01 | TC3 InputVariableContainer Symbol AI Inputs Channel 1
 | X02 | TC3 InputVariableContainer Symbol AI Inputs Channel 2
 | X03 | TC3 OutputVariableContainer Symbol AO Outputs Channel 3
 | X04 | TC3 OutputVariableContainer Symbol AO Outputs Channel 4


Inhalte von Prozessdatenobjekten

Produktübersicht [image] Prozessabbild [image] Inhalte von Prozessdatenobjekten
Inhalte von Prozessdatenobjekten
AI Inputs Channel 1
EPP4374 Prozessabbild - AI Inputs Channel 1
Unter AI Inputs Channel 1 finden Sie die Daten des 1. analogen Kanals.
▪
Underrange: Wert des analogen Eingangs ist kleiner als 0/4 mA bzw. -10/0 V
▪
Overrange: Wert des analogen Eingangs ist größer als 20 mA bzw. +10 V
▪
Limit 1: bei aktiviertem Limit 1 (Objekt 0x80x0:07 = 1) bedeutet
1: Wert kleiner als Limit 1 (eingestellt in Objekt 0x80x0:13)
2: Wert größer als Limit 1 (eingestellt in Objekt 0x80x0:13)
3: Wert gleich Limit 1 (eingestellt in Objekt 0x80x0:13)
▪
Limit 2: bei aktiviertem Limit 2 (Objekt 0x80x0:08 = 1) bedeutet
1: Wert kleiner als Limit 2 (eingestellt in Objekt 0x80x0:14)
2: Wert größer als Limit 2 (eingestellt in Objekt 0x80x0:14)
3: Wert gleich Limit 2 (eingestellt in Objekt 0x80x0:14)
▪
Error: Dieses Bit wird gesetzt wenn Over- oder Underrange erkannt wurde.
AI Inputs Channel 2
Die Daten des 2. analogen Kanals sind genauso aufgebaut wie die des 1. Kanals.
AO Outputs Channel 3
EPP4374 Prozessabbild - AO Outputs Channel 3
Unter AO Outputs Channel 3 finden Sie die Daten des 3. analogen Kanals.
AO Outputs Channel 4
Die Daten des 4. analogen Kanals sind genauso aufgebaut, wie die des 3. Kanals.