EPP3204 - 4x Widerstandsthermometer
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
1.0
▪
Erste Veröffentlichung
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer)
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code enthält zusätzliche Informationen über den Auslieferungszustand des Moduls: Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC).


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT-P-Box-Module
•
Einführung
•
Technische Daten
•
Lieferumfang
•
Prozessabbild


EtherCAT-P-Box-Module

Produktübersicht [image] EtherCAT-P-Box-Module
EtherCAT-P-Box-Module
EtherCAT P
EtherCAT P ergänzt die EtherCAT-Technologie um ein Verfahren, bei dem Kommunikation und Versorgungsspannungen auf einer gemeinsamen Leitung übertragen werden. Alle Eigenschaften von EtherCAT bleiben bei diesem Verfahren erhalten.
Es werden zwei Versorgungsspannungen pro EtherCAT-P-Leitung übertragen. Die Versorgungsspannungen sind galvanisch voneinander getrennt und sind somit einzeln schaltbar. Die Nennspannung der Versorgungsspannungen ist 24 VDC.
EtherCAT P verwendet den gleichen Leitungs-Aufbau wie EtherCAT: eine 4-adrige Ethernet-Leitung mit M8-Steckverbindern. Die Steckverbinder sind mechanisch codiert, so dass ein Vertauschen von EtherCAT-Steckverbindern und EtherCAT-P-Steckverbindern nicht möglich ist.
EtherCAT-P-Box-Module
EtherCAT-P-Box-Module sind EtherCAT-P-Slaves in Schutzart IP67. Sie sind vorgesehen für den Betrieb in nassen, schmutzigen oder staubigen Industrie-Umgebungen.
EtherCAT P Einführung
EtherCAT P
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.


Einführung

Produktübersicht [image] Einführung
Einführung
EPP3204 Inventarbild Website DE
EPP3204-0002
EPP3204-0002 | 4-Kanal-Analog-Eingang Pt100 (RTD)
Die EtherCAT-P-Box EPP3204 mit analogen Eingängen erlaubt den direkten Anschluss von Widerstandssensoren. Die Schaltung der Baugruppe kann Sensoren in 2-, 3- und 4-Leiteranschlusstechnik betreiben. Die Linearisierung über den gesamten Temperaturbereich wird durch einen Mikroprozessor realisiert. Der Temperaturbereich ist frei wählbar. Die Baugruppe kann auch zur reinen Widerstandsmessung eingesetzt werden; die Ausgabe erfolgt dann direkt in Ohm. Die Standardeinstellung der Baugruppe ist: Auflösung 0,1 °C im Temperaturbereich der PT100-Sensoren in 2-Leiteranschlusstechnik. Sensorstörungen, wie z. B. Drahtbruch, werden über Error-LEDs angezeigt. Die Baugruppe verfügt über vielfältige Features, wobei die Defaultwerte so gewählt wurden, dass eine Konfiguration meist nicht erforderlich ist. Die Eingangsfilter und damit verbunden die Wandlungszeiten sind in weiten Bereichen einstellbar, mehrere Datenausgabeformate stehen zur Wahl. Die Skalierung der Eingänge kann bei Bedarf verändert werden, eine automatische Grenzwertüberwachung steht ebenfalls zur Verfügung. Parametriert wird über EtherCAT.
Quick Links
Installation
Konfiguration


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Alle Werte sind typische Werte bei 25 °C, wenn nicht anders angegeben.
Technische Daten
EPP3204-0002
Feldbus
Feldbus
EtherCAT
Anschluss
EtherCAT P: Kombinierter Anschluss für EtherCAT und Versorgungsspannungen
Einspeisung: 1 x M8-Buchse, P-kodiert, rot
Weiterleitung: 1 x M8-Buchse, P-kodiert, rot
Versorgungsspannungen
Anschluss
Siehe Feldbus-Anschluss
Steuerspannung US
Nennspannung
24 VDC (-15 % / +20 %)
Summenstrom
max. 3 A 1)
Verbraucher
Modulelektronik: 100 mA
Peripheriespannung UP
Nennspannung
24 VDC (-15 % / +20 %)
Summenstrom
max. 3 A 1)
Verbraucher
-
RTD-Eingänge
Anzahl
4
Steckverbinder
4 x M12-Buchse
Sensor-Typen
▪
Platin-RTD: Pt100, Pt200, Pt500, Pt1000
▪
Nickel-RTD: Ni100, Ni120, Ni1000
▪
Widerstand/Potentiometer bis 4095 Ω
Anschlusstechnik
▪
Zweileiter-Technik
▪
Dreileiter-Technik
▪
Vierleiter-Technik
Potentialtrennung
Die Messkanäle haben ein gemeinsames, isoliertes Massepotential.
Messstrom RL+, RL-
max. 0,5 mA, lastabhängig
Messbereich
Platin-RTD: -200 .. +850 °C
Nickel-RTD: -60 .. +250 °C (Ni120: -60 .. +320 °C)
Widerstand: 0 .. 4095 Ω
Messfehler
max. ±0,5 K (Pt-Sensoren in Vierleitertechnik)
Digitale Auflösung
16 Bit
Wert eines LSB
Temperatur-Messung:
Standard: 0,1 °C
Hochgenau: 0,01 °C
Widerstands-Messung:
Messbereich 1023 Ω: 1/64 Ω
Messbereich 4095 Ω: 1/16 Ω
Filter
Digitaler Filter. Grenzfrequenz parametrierbar: 5 Hz .. 30 kHz.
Wandlungszeit
2 .. 800 ms, abhängig von der Parametrierung.
Default: ca. 85 ms
Diagnose
▪
Drahtbruch-Erkennung
▪
Grenzwert-Überwachung
1) Summenstrom von Verbrauchern und Spannungs-Weiterleitung.
Technische Daten | EPP3204-0002
Umgebungsbedingungen
Umgebungstemperatur im Betrieb | -25 .. +60 °C 0 .. +55 °C gemäß cURus
Umgebungstemperatur bei Lagerung | -40 .. +85 °C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Mechanik
Gewicht | ca. 165 g
Einbaulage | beliebig
Zulassungen und Konformität
Zulassungen | CE, cURus
Zusätzliche Prüfungen
Die Boxen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3 Achsen
 | 5 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3 Achsen
 | 35 g, 11 ms


Lieferumfang

Produktübersicht [image] Lieferumfang
Lieferumfang
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EPP3204-0002
▪
2x Schutzkappe für EtherCAT-P-Buchse, M8, rot (vormontiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
Vormontierte Schutzkappen gewährleisten keinen IP67-Schutz
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Stellen Sie den korrekten Sitz der Schutzkappen sicher, um die Schutzart IP67 zu gewährleisten.


Prozessabbild

Produktübersicht [image] Prozessabbild
Prozessabbild
Weiterführende Informationen
•
Zuordnung von Steckverbindern zu Prozessdatenobjekten
•
Inhalt von Prozessdatenobjekten


Montage und Anschluss

Montage und Anschluss
Montage und Anschluss
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Funktionserdung (FE)
•
EtherCAT P
•
RTD-Eingänge
•
UL-Anforderungen


Abmessungen

Montage und Anschluss [image] Abmessungen
Abmessungen
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 3,5 mm für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Gewicht | ca. 165 g


Befestigung

Montage und Anschluss [image] Befestigung
Befestigung
Hinweis
Verschmutzung bei der Montage
Verschmutzte Steckverbinder können zu Fehlfunktion führen. Die Schutzart IP67 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind.
•
Schützen Sie die Steckverbinder bei der Montage vor Verschmutzung.
Montieren Sie das Modul mit zwei M3-Schrauben an den Befestigungslöchern in den Ecken des Moduls. Die Befestigungslöcher haben kein Gewinde.


Funktionserdung (FE)

Montage und Anschluss [image] Funktionserdung (FE)
Funktionserdung (FE)
Das obere Befestigungsloch dient gleichzeitig als Anschluss für die Funktionserdung (FE).
Stellen Sie sicher, dass die Box über die Anschlüsse für die Funktionserdung (FE) niederimpedant geerdet ist. Das erreichen Sie z.B., indem Sie die Box an einem geerdeten Maschinenbett montieren.
Anschluss für die Funktionserdung (FE)


EtherCAT P

Montage und Anschluss [image] EtherCAT P
EtherCAT P
Hinweis
Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT/EtherCAT-P-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung von EtherCAT P, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 3 A nicht überschritten wird!
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungsverluste


Steckverbinder

Montage und Anschluss [image] EtherCAT P [image] Steckverbinder
Steckverbinder
Steckverbinder für EtherCAT P
1 - Eingang
2 - Weiterleitung
Kontaktbelegung
M8-Buchse, P-kodiert
Kontakt | Signal | Spannung | Aderfarben1)
1 | Tx + | GNDS | gelb
2 | Rx + | GNDP | weiß
3 | Rx - | UP: Peripheriespannung, +24 VDC | blau
4 | Tx - | US: Steuerspannung, +24 VDC | orange
Gehäuse | Schirm | Schirm | Schirm
1) Die Aderfarben gelten für EtherCAT-P-Leitungen und ECP-Leitungen von Beckhoff.


Status-LEDs

Montage und Anschluss [image] EtherCAT P [image] Status-LEDs
Status-LEDs
Weiterführende Informationen
•
Versorgungsspannungen
•
EtherCAT


Versorgungsspannungen

Montage und Anschluss [image] EtherCAT P [image] Status-LEDs [image] Versorgungsspannungen
Versorgungsspannungen
Status-LEDs für die Spannungsversorgung
EtherCAT-P-Box-Module haben zwei LEDs, die den Status der Versorgungsspannungen anzeigen. Die Status-LEDs sind mit den Bezeichnungen der Versorgungsspannungen beschriftet: Us und Up.
Eine Status-LED leuchtet grün, wenn die jeweilige Versorgungsspannung vorhanden ist.


EtherCAT

Montage und Anschluss [image] EtherCAT P [image] Status-LEDs [image] EtherCAT
EtherCAT
Status-LEDs für EtherCAT
L/A (Link/Act)
Neben jeder EtherCAT-/EtherCAT-P-Buchse befindet sich eine grüne LED, die mit „L/A“ oder „Link/Act“ beschriftet ist. Die LED signalisiert den Kommunikationsstatus der jeweiligen Buchse:
LED | Bedeutung
aus | keine Verbindung zum angeschlossenen EtherCAT-Gerät
leuchtet | LINK: Verbindung zum angeschlossenen EtherCAT-Gerät
blinkt | ACT: Kommunikation mit dem angeschlossenen EtherCAT-Gerät
Run
Jeder EtherCAT-Slave hat eine grüne LED, die mit „Run“ beschriftet ist. Die LED signalisiert den Status des Slaves im EtherCAT-Netzwerk:
LED | Bedeutung
aus | Slave ist im Status „Init“
blinkt gleichmäßig | Slave ist im Status „Pre-Operational“
blinkt vereinzelt | Slave ist im Status „Safe-Operational“
leuchtet | Slave ist im Status „Operational“
Beschreibung der Stati von EtherCAT-Slaves


Leitungsverluste

Montage und Anschluss [image] EtherCAT P [image] Leitungsverluste
Leitungsverluste
Beachten Sie bei der Planung einer Anlage den Spannungsabfall an der Versorgungs-Zuleitung. Vermeiden Sie, dass der Spannungsabfall so hoch wird, dass die Versorgungsspannungen an der Box die minimale Nennspannung unterschreiten.
Berücksichtigen Sie auch Spannungsschwankungen des Netzteils.
Spannungsabfall an der Versorgungs-Zuleitung
Leitungsverluste M8-EPP 3A
Spannungsabfall an der Versorgungs-Zuleitung


RTD-Eingänge

Montage und Anschluss [image] RTD-Eingänge
RTD-Eingänge
Weiterführende Informationen
•
Steckverbinder
•
Verkabelung
•
Status-LEDs


Steckverbinder

Montage und Anschluss [image] RTD-Eingänge [image] Steckverbinder
Steckverbinder
M12-Buchsen
M12-Buchse
Kontakt | Aderfarbe 1) | 4-Leiter |  | 3-Leiter |  | 2-Leiter
1 | braun | RL+ | Messstrom + | RL+ | Messstrom + | RL+ R+ | Messstrom + Messeingang +
2 | weiß | R+ | Messeingang + | R+ | Messeingang + | - | -
3 | blau | RL- | Messstrom - | RL- R- | Messstrom - Messeingang - | RL- R- | Messstrom - Messeingang -
4 | schwarz | R- | Messeingang - | - | - | - | -
5 | - | Schirm |  | Schirm |  | Schirm
1) Die Aderfarben gelten für geschirmte M12-Sensorleitungen von Beckhoff: ZK2000-7xxx
Anschlusstechnik


Verkabelung

Montage und Anschluss [image] RTD-Eingänge [image] Verkabelung
Verkabelung
▪
Schließen jeden Sensor mit einer geschirmten Mantelleitung an, bei der der Kabelschirm mit Kontakt 5 des M12-Steckers verbunden ist. Z.B. Beckhoff ZK2000-7xxx.
▪
Zweileitermessung: verwenden Sie möglichst niederohmige Leitungen.
▪
Dreileitermessung: Stellen Sie sicher, dass der Leitungswiderstand der Leiter für RL+ und RL- möglichst gleich groß ist.


Status-LEDs

Montage und Anschluss [image] RTD-Eingänge [image] Status-LEDs
Status-LEDs
Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error.
Eine einwandfreie Funktion besteht wenn die grüne LED Run leuchtet und die rote LED Error aus ist.
Status-LEDs an den Signalanschlüssen
Anschluss
LED
Anzeige
Bedeutung
M12-Buchse Nr. 1-4
R
links
aus
keine Datenübertragung zum A/D-Wandler
grün
Datenübertragung zum A/D-Wandler
E
rechts
aus
einwandfreie Funktion
rot
Fehler:
▪
Drahtbruch oder
▪
Messwert außerhalb des Messbereichs oder
▪
Temperaturkompensation außerhalb des Gültigkeitsbereich


UL-Anforderungen

Montage und Anschluss [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


Inbetriebnahme/Konfiguration

Inbetriebnahme/Konfiguration
Inbetriebnahme/Konfiguration
Weiterführende Informationen
•
Konfiguration in TwinCAT
•
Messwertverarbeitung
•
Zweipunkt Benutzerabgleich
•
Grenzwert-Überwachung
•
CoE-Objekte
•
Wiederherstellen des Auslieferungszustandes
•
Außerbetriebnahme


Konfiguration in TwinCAT

Inbetriebnahme/Konfiguration [image] Konfiguration in TwinCAT
Konfiguration in TwinCAT
Eine EtherCAT Box muss in TwinCAT konfiguriert werden, damit ihre Funktionen in einem SPS-Programm genutzt werden können.
Unter dem folgenden Link finden Sie eine Schnellstartanleitung, die die Konfiguration einer EtherCAT Box in TwinCAT beschreibt:
https://infosys.beckhoff.com/content/1031/epioconfiguration/index.html?id=5323978252154950216


Messwertverarbeitung

Inbetriebnahme/Konfiguration [image] Messwertverarbeitung
Messwertverarbeitung
Messwertverarbeitung
Weiterführende Informationen
•
Herstellerabgleich
•
Benutzerabgleich und Linearisierung
•
Skalierung, Limits und Formatierung
•
Zusammenfassung


Herstellerabgleich

Inbetriebnahme/Konfiguration [image] Messwertverarbeitung [image] Herstellerabgleich
Herstellerabgleich
Weiterführende Informationen
•
2- und 4-Leiter Widerstandsmessung
•
3-Leiter Widerstandsmessung


2- und 4-Leiter Widerstandsmessung

Inbetriebnahme/Konfiguration [image] Messwertverarbeitung [image] Herstellerabgleich [image] 2- und 4-Leiter Widerstandsmessung
2- und 4-Leiter Widerstandsmessung
Ob eine Messung als 2- oder als 4-Leiter Messung ausgeführt wird, wird über die Anschlusspunkte bestimmt, an denen gemessen wird. Für beide Messmethoden ist ein Abgleichwert in der Firmware hinterlegt.
▪
Bei der 2-Leiter Messung
–
wird ein Strom zwischen den Kontaktstellen RL+ und RL- eingeprägt und der Spannungsabfall zur Ermittlung des Widerstandes gemessen.
–
Der parasitäre Leitungswiderstand kann dabei nicht durch die Box selbst ermittelt werden, sondern muss als Korrekturwert in das CoE-Register 0x80n0:1B eingetragen werden.
▪
Bei der 4-Leiter Messung
–
wird der Sensorstrom zwischen den Kontaktstellen RL+ und RL- der M12 Buchse eingeprägt und dabei der Spannungsabfall an den Kontaktstellen R+ und R- zur Widerstandsmessung verwendet.
–
Dadurch ist die Stromführende Leitung nicht Teil des Messkreises und fließt nicht als Fehlerquelle in die Messung ein.
Widerstandsmessung in 4-Leiter, 3-Leiter und 2-Leiter Anschlusstechnik
Die Box verwendet die folgende Berechnungsvorschrift:
Datenfluss Widerstandsmessung in 2- und 4-Leiter Anschlusstechnik
Mit den Werten:
 | Index im CoE-Verzeichnis mit n: Kanalnummer mit 0 ≤ n ≤ 3 (Kanal 1 - 4)
X: Rohwert | 0x80nE:01
 | PT100 |  | PT1000
 | 2-Leiter | 4-Leiter | 2-Leiter | 4-Leiter
Gv: Vendor Gain | 0x80nF:04 | 0x80nF:06 | 0x80nF:0A | 0x80nF:0C
Ov: Vendor Offset | 0x80nF:03 | 0x80nF:05 | 0x80nF:09 | 0x80nF:0B
YR: Ausgangswert in 1/256 Ω | 0x80nE:02
Überlauf YR nach 16 Bit
Dieser Wert dient nur der Fehlersuche. Das Register läuft nach 16 Bit, also bei 65536 über.


3-Leiter Widerstandsmessung

Inbetriebnahme/Konfiguration [image] Messwertverarbeitung [image] Herstellerabgleich [image] 3-Leiter Widerstandsmessung
3-Leiter Widerstandsmessung
▪
Bei der 3-Leiter Messung
–
wird zunächst zwischen den Kontaktstellen RL+ und RL- ein definierter Strom eingeprägt und anhand des Spannungsabfalls der Widerstand dazwischen bestimmt.
–
Anschließend wird das gleiche Verfahren an den Kontaktstellen RL+ und R- durchgeführt.
–
Die Differenz der beiden Messungen ist der Leitungswiderstand einer der Adern der Sensorleitung. Durch die Kenntnis des Leitungswiderstandes lässt sich der daraus resultierende Messfehler kompensieren.
–
Damit das Verfahren funktioniert, müssen die Adern der Sensorleitung den gleichen Widerstand aufweisen.
Widerstandsmessung in 4-Leiter, 3-Leiter und 2-Leiter Anschlusstechnik
Die Box verwendet die folgende Berechnungsvorschrift
Datenfluss Widerstandsmessung in 3-Leiter Anschlusstechnik
Mit den Werten:
 | Index im CoE-Verzeichnis mit n: Kanalnummer mit 0 ≤ n ≤ 3 (Kanal 1 - 4)
X1: Rohwert der 1. Messung | 0x80nE:01
X2: Rohwert der 2. Messung | 0x80nE:03
 | PT100 | PT1000
Gv1: Vendor Gain 1. Messung | 0x80nF:04 | 0x80nF:0A
Ov1: Vendor Offset 1. Messung | 0x80nF:03 | 0x80nF:09
Gv2: Vendor Gain 2. Messung | 0x80nF:02 | 0x80nF:08
Ov2: Vendor Offset 2. Messung | 0x80nF:01 | 0x80nF:07
YR1: Ausgangswert in 1/256 Ω | 0x80nE:02
YR2: Ausgangswert in 1/256 Ω | 0x80nE:04
YR: Ausgangswert in 1/256 Ω
Überlauf YR1 und YR2 nach 16 Bit
Diese Werte dienen nur der Fehlersuche. Die Register laufen nach 16 Bit, also bei 65536 über.


Benutzerabgleich und Linearisierung

Inbetriebnahme/Konfiguration [image] Messwertverarbeitung [image] Benutzerabgleich und Linearisierung
Benutzerabgleich und Linearisierung
▪
Der abgeglichene Messwert wird gegebenenfalls durch die Anwenderabgleichwerte modifiziert.
▪
Das Ergebnis der Widerstandsmessung wird auf einen Temperaturwert abgebildet. Die zugrunde liegende Linearisierungsfunktion ist durch den Anwender nicht modifizierbar.
▪
Erst nach der Linearisierung wird die Benutzerskalierung eingerechnet.
Folgende Berechnungsvorschrift verwendet die Box
Datenfluss Benutzerabgleich und Linearisierung
Mit den Werten:
 | Index im CoE-Verzeichnis mit n: Kanalnummer mit 0 ≤ n ≤ 3 (Kanal 1 - 4)
XV: Ausgangswert des Herstellerabgleichs
GU: User Gain | 0x80n0:18
OU: User Offset | 0x80n0:17
Yint: Ausgangswert in 1/256 Ω vor der Linearisierung


Skalierung, Limits und Formatierung

Inbetriebnahme/Konfiguration [image] Messwertverarbeitung [image] Skalierung, Limits und Formatierung
Skalierung, Limits und Formatierung
▪
Im Anschluss an die Berechnung des Widerstandswertes werden die Skalierung und die Limit Bits ausgewertet.
▪
Das Ergebnis wird entsprechend der eingestellten Präsentation formatiert und in das Prozessabbild kopiert.
Folgende Berechnungsvorschrift verwendet die Box
Datenfluss Anwenderskalierung, Limitauswertung, Error-Bits und Formatierung
Mit den Werten:
 | Index im CoE-Verzeichnis mit n: Kanalnummer mit 0 ≤ n ≤ 3 (Kanal 1 - 4)
Ylin: Ausgangswert in 1/100 °C
GS: User Scale Gain | 0x80n0:12
OS: User Scale Offset | 0x80n0:11
Y: Ausgangswert PDO


Zusammenfassung

Inbetriebnahme/Konfiguration [image] Messwertverarbeitung [image] Zusammenfassung
Zusammenfassung
Zusammenfassung der Berechnungsvorschriften:
Mit den Werten:
 | Index im CoE-Verzeichnis mit n: Kanalnummer mit 0 ≤ n ≤ 3 (Kanal 1 - 4)
X1: Rohwert Rohwert der 1. Messung | 0x80nE:01
X2: Rohwert Rohwert der 2. Messung | 0x80nE:03
 | PT100 |  | PT1000
 | 2-Leiter | 4-Leiter | 2-Leiter | 4-Leiter
Gv: Vendor Gain | 0x80nF:04 | 0x80nF:06 | 0x80nF:0A | 0x80nF:0C
Ov: Vendor Offset | 0x80nF:03 | 0x80nF:05 | 0x80nF:09 | 0x80nF:0B
 | 3-Leiter
Gv1: Vendor Gain 1. Messung | 0x80nF:04 |  | 0x80nF:0A
Ov1: Vendor Offset 1. Messung | 0x80nF:03 |  | 0x80nF:09
Gv2: Vendor Gain 2. Messung | 0x80nF:02 |  | 0x80nF:08
Ov2: Vendor Offset 2. Messung | 0x80nF:01 |  | 0x80nF:07
GU: User Gain | 0x80n0:18
OU: User Scale Offset | 0x80n0:17
GS: User Scale Gain | 0x80n0:12
OS: User Scale Offset | 0x80n0:11
ƒlin: Funktion zur Abbildung auf die gewählte Darstellungsweise |
ƒpres: Linearisierungsfunktion |
YR1:Ausgangswert in 1/256 Ω | 0x80nE:02
YR2: Ausgangswert in 1/256 Ω | 0x80nE:04
Y: Ausgangswert PDO |
Überlauf YR1 und YR2 nach 16 Bit
Diese Werte dienen nur der Fehlersuche. Die Register laufen nach 16 Bit, also bei 65536 über.


Zweipunkt Benutzerabgleich

Inbetriebnahme/Konfiguration [image] Zweipunkt Benutzerabgleich
Zweipunkt Benutzerabgleich
Der Herstellerabgleich ist durch Index (0x80n0:0B) zu deaktivieren.
Bis FW-Version 07 wird durch das Abschalten des Herstellerabgleichs nur der Vendor-Gain auf 214 (Festkommadarstellung für 1.0) gesetzt. Der Hersteller-Offset bleibt unverändert und wird weiterhin eingerechnet. Damit ergibt sich bei abgeschaltetem Herstellerabgleich:
Da der letzte Teil des Terms konstant ist, kann trotz des unvermeidbaren Einflusses des Hersteller-Offsets ein Benutzerabgleich durchgeführt werden. Der Einfluss des Herstelleroffsets kann dabei vollständig kompensiert werden.
Es ist folgendes Verfahren anzuwenden:
Zwei Referenzmessungen durchführen mit Y1(X1) und Y2(X2). Dann gilt:
GU und OU sind ganzzahlig zu runden und in Index 0x80n0:18 und Index 0x80n0:17 einzutragen.
X | Rohwert (0x80nE:01)
OV: | Vendor Offset (Index abhängig vom modus s. Kapitel Herstellerabgleich)
GU: | User Gain (0x80n0:18)
OU: | User Offset (0x80n0:17)
gf: | Gain als Floatwert
OR: | Offset als Rohwert
Xn: | Gemessener Rohwert bei Referenzmessung n
Yn: | Referenzwert in 1/256 Ω
Yint: | Ausgangswert in 1/256 Ω vor der Linearisierung
Hinweis
Yn: Verwendung des Rohwerts
Da der Widerstandwert in Index 0x8xxE:02 überläuft wird für Yn der Rohwert in Index 0x8xxE:01 verwendet.
Weiterführende Informationen
•
Beispiel


Beispiel

Inbetriebnahme/Konfiguration [image] Zweipunkt Benutzerabgleich [image] Beispiel
Beispiel
Kanal 1 soll bei Zweidrahtmessung an zwei Punkten bei 100 Ω und 350 Ω abgeglichen werden. Das Vendor-Offset für den 2-Draht- Abgleich beträgt -2607 (entnommen aus Index 0x800F:03).
Folgende Messwerte werden aufgenommen:
100 Ω durch Präzisionswiderstand | X1 = 25600 (1/256 Ω)
171125, abgelesen in Index 0x800E:01 | Y1 = 171125
350 Ω durch Präzisionswiderstand | X2 = 89600 (1/256 Ω)
592224, abgelesen in Index 0x800E:01 | Y2 = 592224
Mit den Gleichungen (1) - (3):
ergeben sich die Werte für gf, GU und OU zu:
Die Indizes akzeptieren nur ganzzahlige Werte. Es sind also folgende Einträge im CoE vorzunehmen:
Index 0x8000:17 = -12
Index 0x8000:18 = 9960
Anschließend ist der Herstellerabgleich zu deaktivieren (0x8000:0B) und der Anwenderabgleich zu aktivieren (0x8000:0A).


Grenzwert-Überwachung

Inbetriebnahme/Konfiguration [image] Grenzwert-Überwachung
Grenzwert-Überwachung
Sie können für jeden Messwert zwei Grenzwerte definieren. Eine Variable zeigt an, ob der Messwert oberhalb oder unterhalb des Grenzwertes liegt.
Einen Grenzwert definieren
Tragen Sie den Grenzwert in das entsprechende CoE-Objekt ein.
Datenformat: das gleiche Datenformat wie das Datenformat des zu überwachenden Messwerts.
CoE-Index | Name
80n0:13 | Limit 1
80n0:14 | Limit 2
(n = 0 .. 3 für die RTD-Eingänge X01 .. X04)
Überwachung aktivieren
Setzen Sie das CoE-Objekt für den jeweiligen Grenzwert auf TRUE:
CoE-Index | Name
80n0:07 | Enable limit 1
80n0:08 | Enable limit 2
Auswerten
Werten Sie die Eingangsvariablen „Limit 1“ und „Limit 2“ in den Prozessdaten aus:
Wert | Bedeutung
0 | Die Überwachung ist für diesen Grenzwert nicht aktiviert.
1 | Der Messwert ist kleiner als der Grenzwert.
2 | Der Messwert ist größer als der Grenzwert.


CoE-Objekte

Inbetriebnahme/Konfiguration [image] CoE-Objekte
CoE-Objekte
Weiterführende Informationen
•
Objektübersicht
•
Objektbeschreibung und Parametrierung


Objektübersicht

Inbetriebnahme/Konfiguration [image] CoE-Objekte [image] Objektübersicht
Objektübersicht
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Index (hex) |  | Name | Flags | Default-Wert
1000 |  | Device type | RO | 0x01401389 (20976521dez)
1008 |  | Device name | RO | EPP3204-0002
1009 |  | Hardware version | RO | 01
100A |  | Software version | RO | 03
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x0C844052 (209993810dez)
 | 1018:03 | Revision | RO | 0x00120002 (1179650dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1A00:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.1 | RO | 0x0A (10dez)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 2
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 2
 | 1A00:05 | SubIndex 005 | RO | 0x6000:07, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A00:07 | SubIndex 007 | RO | 0x6000:0F, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:10, 1
 | 1A00:09 | SubIndex 009 | RO | 0x1800:11, 16
1A01:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.2 | RO | 0x0A (10dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A01:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A01:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A01:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A01:07 | SubIndex 007 | RO | 0x6010:0F, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6010:10, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6010:11, 16
1A02:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.3 | RO | 0x0A (10dez)
 | 1A02:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A02:07 | SubIndex 007 | RO | 0x6020:0F, 1
 | 1A02:08 | SubIndex 008 | RO | 0x6020:10, 1
 | 1A02:09 | SubIndex 009 | RO | 0x6020:11, 16
Index (hex) |  | Name | Flags | Default-Wert
1A03:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.4 | RO | 0x0A (10dez)
 | 1A03:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A03:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 1A03:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 1A03:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 1A03:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 1A03:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A03:07 | SubIndex 007 | RO | 0x6030:0F, 1
 | 1A03:08 | SubIndex 008 | RO | 0x6030:10, 1
 | 1A03:09 | SubIndex 009 | RO | 0x6030:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dez)
1C13:0 | Subindex | TxPDO assign | RW | 0x04 (4dez)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 | 1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dez)
 | 1C13:03 | SubIndex 003 | RW | 0x1A02 (6658dez)
 | 1C13:04 | SubIndex 004 | RW | 0x1A03 (6659dez)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dez)
 | 1C33:01 | Sync mode | RW | 0x0000 (0dez)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C33:05 | Minimum cycle time | RO | 0x00002710 (10000dez)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C33:08 | Command | RW | 0x0000 (0dez)
 | 1C33:09 | Maximum Delay time | RO | 0x00000000 (0dez)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 | Subindex | RTD Inputs Ch.1 | RO | 0x11 (17dez)
 | 6000:01 | Underrange | RO | 0x00 (0dez)
 | 6000:02 | Overrange | RO | 0x00 (0dez)
 | 6000:03 | Limit 1 | RO | 0x00 (0dez)
 | 6000:05 | Limit 2 | RO | 0x00 (0dez)
 | 6000:07 | Error | RO | 0x00 (0dez)
 | 6000:0E | Sync error | RO | 0x00 (0dez)
 | 6000:0F | TxPDO State | RO | 0x00 (0dez)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6000:11 | Value | RO | 0x0000 (0dez)
6010:0 | Subindex | RTD Inputs Ch.2 | RO | 0x11 (17dez)
 | 6010:01 | Underrange | RO | 0x00 (0dez)
 | 6010:02 | Overrange | RO | 0x00 (0dez)
 | 6010:03 | Limit 1 | RO | 0x00 (0dez)
 | 6010:05 | Limit 2 | RO | 0x00 (0dez)
 | 6010:07 | Error | RO | 0x00 (0dez)
 | 6010:0E | Sync error | RO | 0x00 (0dez)
 | 6010:0F | TxPDO State | RO | 0x00 (0dez)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6010:11 | Value | RO | 0x0000 (0dez)
Index (hex) |  | Name | Flags | Default-Wert
6020:0 | Subindex | RTD Inputs Ch.3 | RO | 0x11 (17dez)
 | 6020:01 | Underrange | RO | 0x00 (0dez)
 | 6020:02 | Overrange | RO | 0x00 (0dez)
 | 6020:03 | Limit 1 | RO | 0x00 (0dez)
 | 6020:05 | Limit 2 | RO | 0x00 (0dez)
 | 6020:07 | Error | RO | 0x00 (0dez)
 | 6020:0E | Sync error | RO | 0x00 (0dez)
 | 6020:0F | TxPDO State | RO | 0x00 (0dez)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6020:11 | Value | RO | 0x0000 (0dez)
6030:0 | Subindex | RTD Inputs Ch.4 | RO | 0x11 (17dez)
 | 6030:01 | Underrange | RO | 0x00 (0dez)
 | 6030:02 | Overrange | RO | 0x00 (0dez)
 | 6030:03 | Limit 1 | RO | 0x00 (0dez)
 | 6030:05 | Limit 2 | RO | 0x00 (0dez)
 | 6030:07 | Error | RO | 0x00 (0dez)
 | 6030:0E | Sync error | RO | 0x00 (0dez)
 | 6030:0F | TxPDO State | RO | 0x00 (0dez)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6030:11 | Value | RO | 0x0000 (0dez)
8000:0 | Subindex | RTD Settings Ch.1 | RW | 0x1B (27dez)
 | 8000:01 | Enable user scale | RW | 0x00 (0dez)
 | 8000:02 | Presentation | RW | 0x00 (0dez)
 | 8000:05 | Siemens bits | RW | 0x00 (0dez)
 | 8000:06 | Enable filter | RW | 0x00 (0dez)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8000:11 | User scale offset | RW | 0x0000 (0dez)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8000:15 | Filter settings | RW | 0x0000 (0dez)
 | 8000:16 | Calibration intervall | RW | 0x0000 (0dez)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 8000:19 | RTD Element | RW | 0x0000 (0dez)
 | 8000:1A | Connection technology | RW | 0x0000 (0dez)
 | 8000:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dez)
800E:0 | Subindex | RTD Internal data Ch.1 | RO | 0x04 (4dez)
 | 800E:01 | ADC raw value 1 | RO | 0x00000000 (0dez)
 | 800E:02 | Resistor 1 | RO | 0x0000 (0dez)
 | 800E:03 | ADC raw value 2 | RO | 0x00000000 (0dez)
 | 800E:04 | Resistor 2 | RO | 0x0000 (0dez)
800F:0 | Subindex | RTD Vendor data Ch.1 | RW | 0x07 (7dez)
 | 800F:01 | Calibration offset 3-wire | RW | 0x0000 (0dez)
 | 800F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dez)
 | 800F:03 | Calibration offset 2-wire | RW | 0x0000 (0dez)
 | 800F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dez)
 | 800F:05 | Calibration offset 4-wire | RW | 0x0000 (0dez)
 | 800F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dez)
 | 800F:07 | PGA Gain Correction | RW | 0x0000 (0dez)
Index (hex) |  | Name | Flags | Default-Wert
8010:0 | Subindex | RTD Settings Ch.2 | RW | 0x1B (27dez)
 | 8010:01 | Enable user scale | RW | 0x00 (0dez)
 | 8010:02 | Presentation | RW | 0x00 (0dez)
 | 8010:05 | Siemens bits | RW | 0x00 (0dez)
 | 8010:06 | Enable filter | RW | 0x00 (0dez)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8010:11 | User scale offset | RW | 0x0000 (0dez)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8010:15 | Filter settings | RW | 0x0000 (0dez)
 | 8010:16 | Calibration intervall | RW | 0x0000 (0dez)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 8010:19 | RTD Element | RW | 0x0000 (0dez)
 | 8010:1A | Connection technology | RW | 0x0000 (0dez)
 | 8010:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dez)
801E:0 | Subindex | RTD Internal data Ch.2 | RO | 0x04 (4dez)
 | 801E:01 | ADC raw value 1 | RO | 0x00000000 (0dez)
 | 801E:02 | Resistor 1 | RO | 0x0000 (0dez)
 | 801E:03 | ADC raw value 2 | RO | 0x00000000 (0dez)
 | 801E:04 | Resistor 2 | RO | 0x0000 (0dez)
801F | Subindex | RTD Vendor data Ch.2 | RW | 0x07 (7dez)
 | 801F:01 | Calibration offset 3-wire | RW | 0x0000 (0dez)
 | 801F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dez)
 | 801F:03 | Calibration offset 2-wire | RW | 0x0000 (0dez)
 | 801F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dez)
 | 801F:05 | Calibration offset 4-wire | RW | 0x0000 (0dez)
 | 801F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dez)
 | 801F:07 | PGA Gain Correction | RW | 0x0000 (0dez)
8020:0 | Subindex | RTD Settings Ch.3 | RW | 0x1B (27dez)
 | 8020:01 | Enable user scale | RW | 0x00 (0dez)
 | 8020:02 | Presentation | RW | 0x00 (0dez)
 | 8020:05 | Siemens bits | RW | 0x00 (0dez)
 | 8020:06 | Enable filter | RW | 0x00 (0dez)
 | 8020:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8020:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8020:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8020:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8020:11 | User scale offset | RW | 0x0000 (0dez)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8020:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8020:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8020:15 | Filter settings | RW | 0x0000 (0dez)
 | 8020:16 | Calibration intervall | RW | 0x0000 (0dez)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8020:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 8020:19 | RTD Element | RW | 0x0000 (0dez)
 | 8020:1A | Connection technology | RW | 0x0000 (0dez)
 | 8020:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dez)
Index (hex) |  | Name | Flags | Default-Wert
802E:0 | Subindex | RTD Internal data Ch.3 | RO | 0x04 (4dez)
 | 802E:01 | ADC raw value 1 | RO | 0x00000000 (0dez)
 | 802E:02 | Resistor 1 | RO | 0x0000 (0dez)
 | 802E:03 | ADC raw value 2 | RO | 0x00000000 (0dez)
 | 802E:04 | Resistor 2 | RO | 0x0000 (0dez)
802F:0 | Subindex | RTD Vendor data Ch.3 | RW | 0x07 (7dez)
 | 802F:01 | Calibration offset 3-wire | RW | 0x0000 (0dez)
 | 802F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dez)
 | 802F:03 | Calibration offset 2-wire | RW | 0x0000 (0dez)
 | 802F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dez)
 | 802F:05 | Calibration offset 4-wire | RW | 0x0000 (0dez)
 | 802F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dez)
 | 802F:07 | PGA Gain Correction | RW | 0x0000 (0dez)
8030:0 | Subindex | RTD Settings Ch.4 | RW | 0x1B (27dez)
 | 8030:01 | Enable user scale | RW | 0x00 (0dez)
 | 8030:02 | Presentation | RW | 0x00 (0dez)
 | 8030:05 | Siemens bits | RW | 0x00 (0dez)
 | 8030:06 | Enable filter | RW | 0x00 (0dez)
 | 8030:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8030:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8030:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8030:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8030:11 | User scale offset | RW | 0x0000 (0dez)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8030:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8030:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8030:15 | Filter settings | RW | 0x0000 (0dez)
 | 8030:16 | Calibration intervall | RW | 0x0000 (0dez)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8030:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 8030:19 | RTD Element | RW | 0x0000 (0dez)
 | 8030:1A | Connection technology | RW | 0x0000 (0dez)
 | 8030:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dez)
803E:0 | Subindex | RTD Internal data Ch.4 | RO | 0x04 (4dez)
 | 803E:01 | ADC raw value 1 | RO | 0x00000000 (0dez)
 | 803E:02 | Resistor 1 | RO | 0x0000 (0dez)
 | 803E:03 | ADC raw value 2 | RO | 0x00000000 (0dez)
 | 803E:04 | Resistor 2 | RO | 0x0000 (0dez)
803F:0 | Subindex | RTD Vendor data Ch.4 | RW | 0x07 (7dez)
 | 803F:01 | Calibration offset 3-wire | RW | 0x0000 (0dez)
 | 803F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dez)
 | 803F:03 | Calibration offset 2-wire | RW | 0x0000 (0dez)
 | 803F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dez)
 | 803F:05 | Calibration offset 4-wire | RW | 0x0000 (0dez)
 | 803F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dez)
 | 803F:07 | PGA Gain Correction | RW | 0x0000 (0dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x04 (4dez)
 | F010:01 | SubIndex 001 | RW | 0x00000140 (320dez)
 | F010:02 | SubIndex 002 | RW | 0x00000140 (320dez)
 | F010:03 | SubIndex 003 | RW | 0x00000140 (320dez)
 | F010:04 | SubIndex 004 | RW | 0x00000140 (320dez)
Index (hex) |  | Name | Flags | Default-Wert
F080:0 | Subindex | Channel Enable | RO | 0x04 (4dez)
 | F080:01 | SubIndex 001 | RW | 0xFF (255dez)
 | F080:02 | SubIndex 002 | RW | 0xFF (255dez)
 | F080:03 | SubIndex 003 | RW | 0xFF (255dez)
 | F080:04 | SubIndex 004 | RW | 0xFF (255dez)
Legende
Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden


Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration [image] CoE-Objekte [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die zum regulären Betrieb z. B. durch ADS-Zugriff bestimmt sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
▪
Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Objekte zur Parametrierung bei der Inbetriebnahme
•
Objekte für den regulären Betrieb
•
Standardobjekte (0x1000-0x1FFF)
•
Profilspezifische Objekte (0x6000-0xFFFF)


Objekte zur Parametrierung bei der Inbetriebnahme

Inbetriebnahme/Konfiguration [image] CoE-Objekte [image] Objektbeschreibung und Parametrierung [image] Objekte zur Parametrierung bei der Inbetriebnahme
Objekte zur Parametrierung bei der Inbetriebnahme
Index 1011: Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000: RTD Settings Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8000:0 | RTD Settings Ch.1 | Maximaler Subindex |  | UINT8 | RO | 0x1B (27dez)
8000:01 | Enable user scale | Aktiviert die Anwenderskalierung |  | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Presentation | Darstellung des Messwertes |  | BIT3 | RW | 0x00 (0dez)
 |  | 0 | mit Vorzeichen im Zweierkomplement
 |  | 1 | Höchstwertiges Bit als Vorzeichen
 |  | 2 | Hochauflösend (1/100°C Schritte)
8000:05 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits eingeblendet |  | BOOLEAN | RW | 0x00 (0dez)
8000:06 | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch |  | BOOLEAN | RW | 0x00 (0dez)
8000:07 | Enable limit 1 | Aktiviert die Limitprüfung für Limit 1 |  | BOOLEAN | RW | 0x00 (0dez)
8000:08 | Enable limit 2 | Aktiviert die Limitprüfung für Limit 2 |  | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable user calibration | Aktiviert die Anwenderkalibrierung |  | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Enable vendor calibration | Aktiviert die Herstellerkalibrierung |  | BOOLEAN | RW | 0x01 (1dez)
8000:0E | Swap limit bits | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. |  | BOOLEAN | RW | 0x00 (0dez)
8000:11 | User scale offset | Offset der Anwenderskalierung |  | INT16 | RW | 0x0000 (0dez)
8000:12 | User scale gain | Verstärkung der Anwenderskalierung |  | INT32 | RW | 0x00010000 (65536dez)
8000:13 | Limit 1 | Wert für das Limit 1 |  | INT16 | RW | 0x0000 (0dez)
8000:14 | Limit 2 | Wert für das Limit 2 |  | INT16 | RW | 0x0000 (0dez)
8000:15 | Filter settings | Filtereinstellungen |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3,75 kHz
 |  | 7 | 7,5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8000:16 | Calibration intervall | reserviert |  | UINT16 | RW | 0x0000 (0dez)
8000:17 | User calibration offset | Offset der Benutzerkalibrierung |  | INT16 | RW | 0x0000 (0dez)
8000:18 | User calibration gain | Verstärkung der Benutzerkalibrierung |  | UINT16 | RW | 0x4000 (16384dez)
8000:19 | RTD Element | Sensortyp |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Widerstandsmessung mit 1/16 Ohm Auflösung
 |  | 9 | Widerstandsmessung mit 1/64 Ohm Auflösung
Index 8000: RTD Settings Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8000:1A | Connection technology | Verbindungstechnik: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 2-Draht
 |  | 1 | 3-Draht
 |  | 2 | 4-Draht
 |  | 3 | kein Sensor angeschlossen (wird nur von Hardware-Version 00 unterstützt): Diese Einstellung überspringt die gesamte Messung und beschleunigt so die Messwerterfassung der anderen Kanäle. Die grüne Status-LED des jeweiligen Kanals erlischt nicht. Das Error-Bit eines deaktivierten Kanals wird zurückgenommen und nicht mehr gesetzt.
8000:1B | Wire calibration 1/32 Ohm | Nur für 2-Draht-Messungen: Enthält den Widerstandswert der Zuleitung des Temperatursensors (in 1/32 Ohm). |  | INT16 | RW | 0x0000 (0dez)
Index 8010: RTD Settings Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8010:0 | RTD Settings Ch.2 | Maximaler Subindex |  | UINT8 | RO | 0x1B (27dez)
8010:01 | Enable user scale | Aktiviert die Anwenderskalierung |  | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Presentation | Darstellung des Messwertes |  | BIT3 | RW | 0x00 (0dez)
 |  | 0 | mit Vorzeichen im Zweierkomplement
 |  | 1 | Höchstwertiges Bit als Vorzeichen
 |  | 2 | Hochauflösend (1/100°C Schritte)
8010:05 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits eingeblendet |  | BOOLEAN | RW | 0x00 (0dez)
8010:06 | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch |  | BOOLEAN | RW | 0x00 (0dez)
8010:07 | Enable limit 1 | Aktiviert die Limitprüfung für Limit 1 |  | BOOLEAN | RW | 0x00 (0dez)
8010:08 | Enable limit 2 | Aktiviert die Limitprüfung für Limit 2 |  | BOOLEAN | RW | 0x00 (0dez)
8010:0A | Enable user calibration | Aktiviert die Anwenderkalibrierung |  | BOOLEAN | RW | 0x00 (0dez)
8010:0B | Enable vendor calibration | Aktiviert die Herstellerkalibrierung |  | BOOLEAN | RW | 0x01 (1dez)
8010:0E | Swap limit bits | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. |  | BOOLEAN | RW | 0x00 (0dez)
8010:11 | User scale offset | Offset der Anwenderskalierung |  | INT16 | RW | 0x0000 (0dez)
8010:12 | User scale gain | Verstärkung der Anwenderskalierung |  | INT32 | RW | 0x00010000 (65536dez)
8010:13 | Limit 1 | Wert für das Limit 1 |  | INT16 | RW | 0x0000 (0dez)
8010:14 | Limit 2 | Wert für das Limit 2 |  | INT16 | RW | 0x0000 (0dez)
8010:15 | Filter settings | Filtereinstellungen |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3,75 kHz
 |  | 7 | 7,5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8010:16 | Calibration intervall | reserviert |  | UINT16 | RW | 0x0000 (0dez)
8010:17 | User calibration offset | Offset der Benutzerkalibrierung |  | INT16 | RW | 0x0000 (0dez)
8010:18 | User calibration gain | Verstärkung der Benutzerkalibrierung |  | UINT16 | RW | 0x4000 (16384dez)
Index 8010: RTD Settings Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8010:19 | RTD Element | Sensortyp |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Widerstandsmessung mit 1/16 Ohm Auflösung
 |  | 9 | Widerstandsmessung mit 1/64 Ohm Auflösung
8010:1A | Connection technology | Verbindungstechnik: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 2-Draht
 |  | 1 | 3-Draht
 |  | 2 | 4-Draht
 |  | 3 | kein Sensor angeschlossen (wird nur von Hardware-Version 00 unterstützt): Diese Einstellung überspringt die gesamte Messung und beschleunigt so die Messwerterfassung der anderen Kanäle. Die grüne Status-LED des jeweiligen Kanals erlischt nicht. Das Error-Bit eines deaktivierten Kanals wird zurückgenommen und nicht mehr gesetzt.
8010:1B | Wire calibration 1/32 Ohm | Nur für 2-Draht-Messungen: Enthält den Widerstandswert der Zuleitung des Temperatursensors (in 1/32 Ohm). |  | INT16 | RW | 0x0000 (0dez)
Index 8020: RTD Settings Ch.3
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8020:0 | RTD Settings Ch.3 | Maximaler Subindex |  | UINT8 | RO | 0x1B (27dez)
8020:01 | Enable user scale | Aktiviert die Anwenderskalierung |  | BOOLEAN | RW | 0x00 (0dez)
8020:02 | Presentation | Darstellung des Messwertes |  | BIT3 | RW | 0x00 (0dez)
 |  | 0 | mit Vorzeichen im Zweierkomplement
 |  | 1 | Höchstwertiges Bit als Vorzeichen
 |  | 2 | Hochauflösend (1/100°C Schritte)
8020:05 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits eingeblendet |  | BOOLEAN | RW | 0x00 (0dez)
8020:06 | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch |  | BOOLEAN | RW | 0x00 (0dez)
8020:07 | Enable limit 1 | Aktiviert die Limitprüfung für Limit 1 |  | BOOLEAN | RW | 0x00 (0dez)
8020:08 | Enable limit 2 | Aktiviert die Limitprüfung für Limit 2 |  | BOOLEAN | RW | 0x00 (0dez)
8020:0A | Enable user calibration | Aktiviert die Anwenderkalibrierung |  | BOOLEAN | RW | 0x00 (0dez)
8020:0B | Enable vendor calibration | Aktiviert die Herstellerkalibrierung |  | BOOLEAN | RW | 0x01 (1dez)
8020:0E | Swap limit bits | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. |  | BOOLEAN | RW | 0x00 (0dez)
8020:11 | User scale offset | Offset der Anwenderskalierung |  | INT16 | RW | 0x0000 (0dez)
8020:12 | User scale gain | Verstärkung der Anwenderskalierung |  | INT32 | RW | 0x00010000 (65536dez)
8020:13 | Limit 1 | Wert für das Limit 1 |  | INT16 | RW | 0x0000 (0dez)
8020:14 | Limit 2 | Wert für das Limit 2 |  | INT16 | RW | 0x0000 (0dez)
Index 8020: RTD Settings Ch.3
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8020:15 | Filter settings | Filtereinstellungen |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3,75 kHz
 |  | 7 | 7,5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8020:16 | Calibration intervall | reserviert |  | UINT16 | RW | 0x0000 (0dez)
8020:17 | User calibration offset | Offset der Benutzerkalibrierung |  | INT16 | RW | 0x0000 (0dez)
8020:18 | User calibration gain | Verstärkung der Benutzerkalibrierung |  | UINT16 | RW | 0x4000 (16384dez)
8020:19 | RTD Element | Sensortyp |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Widerstandsmessung mit 1/16 Ohm Auflösung
 |  | 9 | Widerstandsmessung mit 1/64 Ohm Auflösung
8020:1A | Connection technology | Verbindungstechnik: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 2-Draht
 |  | 1 | 3-Draht
 |  | 2 | 4-Draht
 |  | 3 | kein Sensor angeschlossen (wird nur von Hardware-Version 00 unterstützt): Diese Einstellung überspringt die gesamte Messung und beschleunigt so die Messwerterfassung der anderen Kanäle. Die grüne Status-LED des jeweiligen Kanals erlischt nicht. Das Error-Bit eines deaktivierten Kanals wird zurückgenommen und nicht mehr gesetzt.
8020:1B | Wire calibration 1/32 Ohm | Nur für 2-Draht-Messungen: Enthält den Widerstandswert der Zuleitung des Temperatursensors (in 1/32 Ohm). |  | INT16 | RW | 0x0000 (0dez)
Index 8030: RTD Settings Ch.4
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8030:0 | RTD Settings Ch.4 | Maximaler Subindex |  | UINT8 | RO | 0x1B (27dez)
8030:01 | Enable user scale | Aktiviert die Anwenderskalierung |  | BOOLEAN | RW | 0x00 (0dez)
8030:02 | Presentation | Darstellung des Messwertes |  | BIT3 | RW | 0x00 (0dez)
 |  | 0 | mit Vorzeichen im Zweierkomplement
 |  | 1 | Höchstwertiges Bit als Vorzeichen
 |  | 2 | Hochauflösend (1/100°C Schritte)
8030:05 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits eingeblendet |  | BOOLEAN | RW | 0x00 (0dez)
8030:06 | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch |  | BOOLEAN | RW | 0x00 (0dez)
8030:07 | Enable limit 1 | Aktiviert die Limitprüfung für Limit 1 |  | BOOLEAN | RW | 0x00 (0dez)
8030:08 | Enable limit 2 | Aktiviert die Limitprüfung für Limit 2 |  | BOOLEAN | RW | 0x00 (0dez)
Index 8030: RTD Settings Ch.4
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8030:0A | Enable user calibration | Aktiviert die Anwenderkalibrierung |  | BOOLEAN | RW | 0x00 (0dez)
8030:0B | Enable vendor calibration | Aktiviert die Herstellerkalibrierung |  | BOOLEAN | RW | 0x01 (1dez)
8030:0E | Swap limit bits | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. |  | BOOLEAN | RW | 0x00 (0dez)
8030:11 | User scale offset | Offset der Anwenderskalierung |  | INT16 | RW | 0x0000 (0dez)
8030:12 | User scale gain | Verstärkung der Anwenderskalierung |  | INT32 | RW | 0x00010000 (65536dez)
8030:13 | Limit 1 | Wert für das Limit 1 |  | INT16 | RW | 0x0000 (0dez)
8030:14 | Limit 2 | Wert für das Limit 2 |  | INT16 | RW | 0x0000 (0dez)
8030:15 | Filter settings | Filtereinstellungen |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3,75 kHz
 |  | 7 | 7,5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8030:16 | Calibration intervall | reserviert |  | UINT16 | RW | 0x0000 (0dez)
8030:17 | User calibration offset | Offset der Benutzerkalibrierung |  | INT16 | RW | 0x0000 (0dez)
8030:18 | User calibration gain | Verstärkung der Benutzerkalibrierung |  | UINT16 | RW | 0x4000 (16384dez)
8030:19 | RTD Element | Sensortyp |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Widerstandsmessung mit 1/16 Ohm Auflösung
 |  | 9 | Widerstandsmessung mit 1/64 Ohm Auflösung
8030:1A | Connection technology | Verbindungstechnik: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 2-Draht
 |  | 1 | 3-Draht
 |  | 2 | 4-Draht
 |  | 3 | kein Sensor angeschlossen (wird nur von Hardware-Version 00 unterstützt): Diese Einstellung überspringt die gesamte Messung und beschleunigt so die Messwerterfassung der anderen Kanäle. Die grüne Status-LED des jeweiligen Kanals erlischt nicht. Das Error-Bit eines deaktivierten Kanals wird zurückgenommen und nicht mehr gesetzt.
8030:1B | Wire calibration 1/32 Ohm | Nur für 2-Draht-Messungen: Enthält den Widerstandswert der Zuleitung des Temperatursensors (in 1/32 Ohm). |  | INT16 | RW | 0x0000 (0dez)


Objekte für den regulären Betrieb

Inbetriebnahme/Konfiguration [image] CoE-Objekte [image] Objektbeschreibung und Parametrierung [image] Objekte für den regulären Betrieb
Objekte für den regulären Betrieb
EPP3204 verfügt über keine solchen Objekte.


Standardobjekte (0x1000-0x1FFF)

Inbetriebnahme/Konfiguration [image] CoE-Objekte [image] Objektbeschreibung und Parametrierung [image] Standardobjekte (0x1000-0x1FFF)
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000: Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Low-Word enthält das verwendete CoE Profil (5001). Das High-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01401389 (20976521dez)
Index 1008: Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EPP3204-0002
Index 1009: Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 05
Index 100A: Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 07
Index 1018: Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0C844052 (209993810dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00120002 (1179650dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0: Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1A00: RTD TxPDO-Map RTDInputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | RTD TxPDO-Map RTDInputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A00:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6000:0, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6000:10, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6000:11, 16
Index 1A01: RTD TxPDO-Map RTDInputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | RTD TxPDO-Map RTDInputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6010:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6010:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6010:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A01:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6010:0F, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6010:10, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6010:11, 16
Index 1A02: RTD TxPDO-Map RTDInputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | RTD TxPDO-Map RTDInputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x09 (9dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6020:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6020:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6020:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A02:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6020:0F, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6020:10, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6020:11, 16
Index 1A03: RTD TxPDO-Map RTDInputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | RTD TxPDO-Map RTDInputs Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x09 (9dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6030:03, 2
1A03:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6030:05, 2
1A03:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6030:07, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A03:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6030:0F, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6030:10, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6030:11, 16
Index 1C00: Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12: RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
Index 1C13: TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
Index 1C33: SM input parameter
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Maximaler Subindex | UINT8 | RO | 0x20 (32dez)
1C33:01 | Sync mode |  | UINT16 | RW | 0x0000 (0dez)
1C33:02 | Cycle time |  | UINT32 | RW | 0x000F4240 (1000000dez)
1C33:03 | Shift time |  | UINT32 | RO | 0x00000000 (0dez)
1C33:04 | Sync modes supported |  | UINT16 | RO | 0xC007 (49159dez)
1C33:05 | Minimum cycle time |  | UINT32 | RO | 0x00002710 (10000dez)
1C33:06 | Calc and copy time |  | UINT32 | RO | 0x00000000 (0dez)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000000 (0dez)
1C33:08 | Command |  | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Maximum Delay time |  | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter |  | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter |  | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter |  | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error |  | BOOLEAN | RO | 0x00 (0dez)


Profilspezifische Objekte (0x6000-0xFFFF)

Inbetriebnahme/Konfiguration [image] CoE-Objekte [image] Objektbeschreibung und Parametrierung [image] Profilspezifische Objekte (0x6000-0xFFFF)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000: RTD Inputs Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6000:0 | RTD Inputs Ch.1 | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6000:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6000:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6000:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Nur in DC: Bit wird gesetzt, wenn der Slave nicht im Stande ist, Synchron zum Master zu arbeiten da er die Zykluszeit nicht einhalten kann. |  | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6000:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Value | Analoges Eingangsdatum |  | INT16 | RO | 0x0000 (0dez)
Index 6010: RTD Inputs Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6010:0 | RTD Inputs Ch.2 | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6010:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6010:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6010:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error | Nur in DC: Bit wird gesetzt, wenn der Slave nicht im Stande ist, Synchron zum Master zu arbeiten da er die Zykluszeit nicht einhalten kann. |  | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6010:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Value | Analoges Eingangsdatum |  | INT16 | RO | 0x0000 (0dez)
Index 6020: RTD Inputs Ch.3
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6020:0 | RTD Inputs Ch.3 | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6020:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6020:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6020:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6020:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6020:0E | Sync error | Nur in DC: Bit wird gesetzt, wenn der Slave nicht im Stande ist, Synchron zum Master zu arbeiten da er die Zykluszeit nicht einhalten kann. |  | BOOLEAN | RO | 0x00 (0dez)
6020:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6020:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Value | Analoges Eingangsdatum |  | INT16 | RO | 0x0000 (0dez)
Index 6030: RTD Inputs Ch.4
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6030:0 | RTD Inputs Ch.4 | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6030:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6030:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6030:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6030:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6030:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6030:0E | Sync error | Nur in DC: Bit wird gesetzt, wenn der Slave nicht im Stande ist, Synchron zum Master zu arbeiten da er die Zykluszeit nicht einhalten kann. |  | BOOLEAN | RO | 0x00 (0dez)
6030:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6030:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6030:11 | Value | Analoges Eingangsdatum |  | INT16 | RO | 0x0000 (0dez)
Index 800E: RTD Internal data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800E:0 | RTD Internal data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
800E:01 | ADC raw value 1 | Rohwert des Analog-Digital-Wandlers | INT32 | RO | 0x00000000 (0dez)
800E:02 | Resistor 1 | Widerstandswert der ersten Messung | UINT16 | RO | 0x0000 (0dez)
800E:03 | ADC raw value 2 | Rohwert des Analog-Digital-Wandlers | INT32 | RO | 0x00000000 (0dez)
800E:04 | Resistor 2 | Widerstandswert der zweiten Messung | UINT16 | RO | 0x0000 (0dez)
Index 800F: RTD Vendor data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800F:0 | RTD Vendor data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x07 (7dez)
800F:01 | Calibration offset 3-wire | Kalibrierung für die 3-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
800F:02 | Calibration gain 3-wire | Kalibrierung für die 3-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
800F:03 | Calibration offset 2-wire | Kalibrierung für die 2-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
800F:04 | Calibration gain 2-wire | Kalibrierung für die 2-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
800F:05 | Calibration offset 4-wire | Kalibrierung für die 4-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
800F:06 | Calibration gain 4-wire | Kalibrierung für die 4-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
800F:07 | PGA Gain Correction | Gain-Korrektur für die PT1000-Messung | INT16 | RW | 0x0000 (0dez)
Index 801E: RTD Internal data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801E:0 | RTD Internal data Ch.2 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
801E:01 | ADC raw value 1 | Rohwert des Analog-Digital-Wandlers | INT32 | RO | 0x00000000 (0dez)
801E:02 | Resistor 1 | Widerstandswert der ersten Messung | UINT16 | RO | 0x0000 (0dez)
801E:03 | ADC raw value 2 | Rohwert des Analog-Digital-Wandlers | INT32 | RO | 0x00000000 (0dez)
801E:04 | Resistor 2 | Widerstandswert der zweiten Messung | UINT16 | RO | 0x0000 (0dez)
Index 801F: RTD Vendor data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801F:0 | RTD Vendor data Ch.2 | Maximaler Subindex | UINT8 | RO | 0x07 (7dez)
801F:01 | Calibration offset 3-wire | Kalibrierung für die 3-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
801F:02 | Calibration gain 3-wire | Kalibrierung für die 3-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
801F:03 | Calibration offset 2-wire | Kalibrierung für die 2-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
801F:04 | Calibration gain 2-wire | Kalibrierung für die 2-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
801F:05 | Calibration offset 4-wire | Kalibrierung für die 4-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
801F:06 | Calibration gain 4-wire | Kalibrierung für die 4-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
801F:07 | PGA Gain Correction | Gain-Korrektur für die PT1000-Messung | INT16 | RW | 0x0000 (0dez)
Index 802E: RTD Internal data Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802E:0 | RTD Internal data Ch.3 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
802E:01 | ADC raw value 1 | Rohwert des Analog-Digital-Wandlers | INT32 | RO | 0x00000000 (0dez)
802E:02 | Resistor 1 | Widerstandswert der ersten Messung | UINT16 | RO | 0x0000 (0dez)
802E:03 | ADC raw value 2 | Rohwert des Analog-Digital-Wandlers | INT32 | RO | 0x00000000 (0dez)
802E:04 | Resistor 2 | Widerstandswert der zweiten Messung | UINT16 | RO | 0x0000 (0dez)
Index 802F: RTD Vendor data Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802F:0 | RTD Vendor data Ch.3 | Maximaler Subindex | UINT8 | RO | 0x07 (7dez)
802F:01 | Calibration offset 3-wire | Kalibrierung für die 3-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
802F:02 | Calibration gain 3-wire | Kalibrierung für die 3-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
802F:03 | Calibration offset 2-wire | Kalibrierung für die 2-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
802F:04 | Calibration gain 2-wire | Kalibrierung für die 2-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
802F:05 | Calibration offset 4-wire | Kalibrierung für die 4-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
802F:06 | Calibration gain 4-wire | Kalibrierung für die 4-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
802F:07 | PGA Gain Correction | Gain-Korrektur für die PT1000-Messung | INT16 | RW | 0x0000 (0dez)
Index 803E: RTD Internal data Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803E:0 | RTD Internal data Ch.4 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
803E:01 | ADC raw value 1 | Rohwert des Analog-Digital-Wandlers | INT32 | RO | 0x00000000 (0dez)
803E:02 | Resistor 1 | Widerstandswert der ersten Messung | UINT16 | RO | 0x0000 (0dez)
803E:03 | ADC raw value 2 | Rohwert des Analog-Digital-Wandlers | INT32 | RO | 0x00000000 (0dez)
803E:04 | Resistor 2 | Widerstandswert der zweiten Messung | UINT16 | RO | 0x0000 (0dez)
Index 803F: RTD Vendor data Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803F:0 | RTD Vendor data Ch.4 |  | UINT8 | RO | 0x07 (7dez)
803F:01 | Calibration offset 3-wire | Kalibrierung für die 3-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
803F:02 | Calibration gain 3-wire | Kalibrierung für die 3-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
803F:03 | Calibration offset 2-wire | Kalibrierung für die 2-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
803F:04 | Calibration gain 2-wire | Kalibrierung für die 2-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
803F:05 | Calibration offset 4-wire | Kalibrierung für die 4-Leiter-Messung: Offset | INT16 | RW | 0x0000 (0dez)
803F:06 | Calibration gain 4-wire | Kalibrierung für die 4-Leiter-Messung: Gain | UINT16 | RW | 0x4000 (16384dez)
803F:07 | PGA Gain Correction | Gain-Korrektur für die PT1000-Messung | INT16 | RW | 0x0000 (0dez)
Index F000: Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand für die Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0004 (4dez)
Index F008: Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010: Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x04 (4dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000140 (320dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000140 (320dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000140 (320dez)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x00000140 (320dez)
Index F080: Channel Enable
Index (hex) | Name | Bedeutung |  |  | Datentyp | Flags | Default
F080:0 | Channel Enable | Maximaler Subindex |  |  | UINT8 | RO | 0x04 (4dez)
F080:01 | SubIndex 001 | 0 | Kanal 1 deaktiviert | (ab Hardware-Version 01 werden deaktivierte Kanäle nicht gemessen und die grüne LED R dieser Kanäle erlischt) | BOOLEAN | RW | 0x01 (1dez)
 |  | 1 | Kanal 1 aktiviert
F080:02 | SubIndex 002 | 0 | Kanal 2 deaktiviert |  | BOOLEAN | RW | 0x01 (1dez)
 |  | 1 | Kanal 2 aktiviert
F080:03 | SubIndex 003 | 0 | Kanal 3 deaktiviert |  | BOOLEAN | RW | 0x01 (1dez)
 |  | 1 | Kanal 3 aktiviert
F080:04 | SubIndex 004 | 0 | Kanal 4 deaktiviert |  | BOOLEAN | RW | 0x01 (1dez)
 |  | 1 | Kanal 5 aktiviert


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme/Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx- und EPPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Außerbetriebnahme

Inbetriebnahme/Konfiguration [image] Außerbetriebnahme
Außerbetriebnahme
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Setzen Sie das Bus-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Demontage der Geräte beginnen!
Entsorgung
Zur Entsorgung muss das Gerät ausgebaut werden.
Gemäß der WEEE-Richtlinie 2012/19/EU nimmt Beckhoff Altgeräte und Zubehör in Deutschland zur fachgerechten Entsorgung zurück. Die Transportkosten werden vom Absender übernommen.
Senden Sie die Altgeräte mit dem Vermerk „zur Entsorgung“ an:
Beckhoff Automation GmbH & Co. KG
Abteilung Service
Stahlstraße 31
D-33415 Verl


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der IP-67-Module und die verwendeten Metallteile. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)

Anhang [image] Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
Allgemeines
Zukünftig werden Sie vermehrt auf Beckhoff Produkten maschinenlesbare Informationen in Form eines Data Matrix Codes (DMC, Code-Schema ECC200) finden. Dieser hilft uns bei der Verbesserung des Qualitätssicherungsprozesses und kann darüber hinaus von Ihnen zur besseren Identifikation unserer Produkte genutzt werden.
Die Einführung des Data Matrix Codes (bei Beckhoff BIC = Beckhoff Identification Code genannt) erfolgt schrittweise über alle Produktgruppen hinweg.
Die Informationen des BICs orientieren sich an dem ANSI-Standard MH10.8.2-2016
Darstellung und Inhalte des BICs
Der BIC ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist lesbar und enthält Informationen, die Sie für Ihr internes Handling und Verwaltung der Produkte nutzen können. Beim Scannen des BICs finden Sie folgende Informationen:
Codierte Informationen auf dem BIC
Pos.-Nr. | Art der Information | Erklärung
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u.
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10…
5 | Chargennummer | Optional: Produktionsjahr und -woche
6 | ID-/Seriennummer | Optional: Heutiges Seriennummer-System, z. B. bei Safety-Produkten
7 | Variantennummer | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten
8 | Date Code | Intern
9 | Auftrags-/Chargennummer | Intern
10 | Seriennummer | Intern
... |  |
Jede Information ist anhand des sog. Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gem. nachstehender Tabelle. Sind die Informationen kürzer werden sie durch Leerzeichen ersetzt. Die Daten unter den Positionen 1-4 sind immer vorhanden (temporäre Einschränkung, s. u., BTN).
Übersicht der festgelegten Datenidentifikatoren mit Beispielen
Pos-Nr. | Art der Information | Datenidentifikator | Anzahl Stellen | Beispiel
1 | Beckhoff-Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | 1K | 32 | 1KEL1809
4 | Menge | Q | 6 | Q1
5 | Chargennummer | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | 51S | 12 | 51S678294104
7 | Variante | 30P | 32 | 30PF971 , 2*K183
8 | Date Code | 9D | 8 | 9DG0118
9 | Auftrags-/Chargennummer | 1T | 14 | 1TFA12345678
10 | Seriennummer | 52S | 23 | 52S2304853-1-004
... |  |  |  |
Aufbau des BICs
Beispiel einer zusammengesetzten Information aus den Positionen 1 - 4 und 6. Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die in Zukunft alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Zuordnung von Steckverbindern zu Prozessdatenobjekten

Produktübersicht [image] Prozessabbild [image] Zuordnung von Steckverbindern zu Prozessdatenobjekten
Zuordnung von Steckverbindern zu Prozessdatenobjekten
Prozessabbild in TwinCAT | Steckverbinder | Prozessdatenobjekt
EPP3204-0002 Prozessabbild zugeklappt | X01 | TC3 InputVariableContainer Symbol RTD RTDInputs Channel 1
 | X02 | TC3 InputVariableContainer Symbol RTD RTDInputs Channel 2
 | X03 | TC3 InputVariableContainer Symbol RTD RTDInputs Channel 3
 | X04 | TC3 InputVariableContainer Symbol RTD RTDInputs Channel 4


Inhalt von Prozessdatenobjekten

Produktübersicht [image] Prozessabbild [image] Inhalt von Prozessdatenobjekten
Inhalt von Prozessdatenobjekten
Die Struktur des Inhalts aller Prozessdatenobjekte ist gleich. Hier wird beispielhaft der Inhalt des Prozessdatenobjekts von Kanal 1 beschrieben.
EPP3204 Prozessabbild 1 Kanal ausgeklappt
Prozessdatenobjekt "RTD RTDInputs Channel 1"
Status
Variable
Beschreibung
TC3 InputVariable Symbol Underrange
TRUE, wenn der Messwert den Messbereich unterschreitet.
TC3 InputVariable Symbol Overrange
TRUE, wenn der Messwert den Messbereich überschreitet.
TC3 InputVariable Symbol Limit 1
Grenzwert-Überwachung
TC3 InputVariable Symbol Limit 2
Grenzwert-Überwachung
TC3 InputVariable Symbol Error
TRUE, wenn der Messwert ungültig ist. Mögliche Gründe:
▪
Drahtbruch
▪
Messwert außerhalb des Messbereichs
TC3 InputVariable Symbol TxPDO State
TRUE, wenn ein interner Fehler auftritt.
TC3 InputVariable Symbol TxPDO Toggle
Dieses Bit wird bei jeder Aktualisierung des Messwerts invertiert.
Aus der Zeit zwischen zwei Flanken dieses Bits können Sie auf die aktuelle Wandlungszeit rückschließen.
Value
Der Messwert.