EP8309-1022 - Multifunktionale EtherCAT Box
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0.0
▪
Migration
▪
Technische Daten aktualisiert
1.1.0
▪
Power-Anschluss aktualisiert
1.0.0
▪
Erste Veröffentlichung
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das ältere Module immer durch neue ersetzt werden können.
Dokumentation Version | EP8309-0002
 | Firmware | Hardware
2.0.0 | 06 | 06
1.0.0 | 06 | 03
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer)
WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr.: 25 13 06 03:
25 - Produktionswoche 25
13 - Produktionsjahr 2013
06 - Firmware-Stand 06
03 - Hardware-Stand 03


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT Box - Einführung
•
EP8309 - Einführung
•
EP8309 - Technische Daten
•
EP8309 - Prozessabbild
•
Pulsweitenmodulation (PWM)
•
Beeinflussung des PWMi-Ausgabewertes durch die Parameter


EtherCAT Box - Einführung

Produktübersicht [image] EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Hinweis
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
Hinweis
XML-Dateien
XML-Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


EP8309 - Einführung

Produktübersicht [image] EP8309 - Einführung
EP8309 - Einführung
EP8309
EtherCAT Box mit verschiedenen digitalen und analogen Ein- und Ausgängen
Die EtherCAT Box EP8309-x022 verfügt über verschiedene digitale und analoge Ein- und Ausgänge.
Die analogen Signale können im Bereich von 0/4…20 mA verarbeitet bzw. ausgegeben werden, die digitalen Signale im Bereich von 24 VDC.
Die möglichen Ausgangsströme sind unterschiedlich und den technischen Daten zu entnehmen.
Die Auflösung der Stromsignale erfolgt mit 12 Bit, vorzeichenbehaftet. Dies gilt für Ein- und Ausgangssignale.
Die Signalkanäle besitzen ein gemeinsames Massepotenzial mit der Versorgung 24 VDC.
Für den Anschluss von einem Proportionalventil ist ein PWMi Ausgang integriert. Für Ventile mit integrierter Elektronik kann dieser Ausgang alternativ auch als analoger Strom-Ausgang mit kontinuierlicher 24 V Versorgung des Ventils betrieben werden.
Quick links
▪
Installation
▪
Konfiguration
▪
UL-Anforderungen


EP8309 - Technische Daten

Produktübersicht [image] EP8309 - Technische Daten
EP8309 - Technische Daten
Feldbus
Technische Daten | EP8309-x022
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Tacho-Eingänge
Technische Daten | EP8309-x022
Anzahl der Tacho-Eingänge | 1 oder 2 (Dual Shaft oder Single Shaft Modus)
Eingangsart | Single-Shaft-Modus: zwei digitale Sensoren auf einer gemeinsamen Achse Dual-Shaft-Modus: zwei digitale Sensoren auf zwei unterschiedlichen Achsen, keine Richtungserkennung, keine Fehlererkennung)
Anschluss Tacho-Eingänge | M12
Nennspannung Eingänge | 24 VDC (-15%/+20%)
Eingangsfilter | 2,5 kHz
Signalspannung "0" | -3...+5 V (EN 61131-2, Typ 3)
Signalspannung "1" | +11...+30 V (EN 61131-2, Typ 3)
Eingangsstrom | typisch 3 mA (EN 61131-2, Typ 3)
Versorgung der Sensoren | aus der Steuerspannung Us
Stromaufnahme der Sensoren | max. 0,5 A, gesamt kurzschlussfest
Digitale Ein-/Ausgänge (DIO)
Technische Daten | EP8309-x022
Anzahl der digitalen Ein-Ausgänge (DIO) | 8
Eingänge |
Anschluss Eingänge | M12
Nennspannung Eingänge | 24 VDC (-15%/+20%)
Eingangsfilter | 3,0 ms
Signalspannung "0" | -3...+5 V (EN 61131-2, Typ 3)
Signalspannung "1" | +11...+30 V (EN 61131-2, Typ 3)
Eingangsstrom | typisch 3 mA (EN 61131-2, Typ 3)
Versorgung der Sensoren | aus der Steuerspannung Us
Stromaufnahme der Sensoren | max. 0,5 A, gesamt kurzschlussfest
Ausgänge |
Anschluss Ausgänge | M12
Lastart | ohmsch, induktiv, Lampenlast
Nennspannung Ausgänge | 24 VDC (-15%/+20%)
Ausgangsstrom | max. 0,5 A je Kanal für die Buchsen 4 und 5 max. 1,0 A je Kanal für die Buchsen 6 und 7
Kurzschlussstrom | typisch 1,5 A
Versorgung der Ausgangstreiber | aus der Lastspannung Up
Stromaufnahme der Ausgangstreiber | typisch 8 mA je Kanal
PWM-Ausgänge
Technische Daten | EP8309-x022
Anzahl der PWM-Ausgänge (alternativ analog Ausgang) | 1
Anschluss Ausgänge | M12
Lastart | ohmsch-induktiv > 1 mH
Versorgung der Ausgangsstufe | 24 VDC, über Powerkontakte
Ausgangsstrom je Kanal | 1,2 A (kurzschlussfest, thermische Überlastwarnung für beide Ausgangsstufen gemeinsam)
PWM-Taktfrequenz | ca. 30 kHz
Nennlastspannung | 24 VDC (-15 %/+20 %)
Auflösung | 10 Bit
Distributed Clocks | ja
Analoge Eingänge (AI)
Technische Daten | EP8309-x022
Anzahl analoge Eingänge | 2
Anschluss Eingänge | M12-Buchsen
Signaltyp | 0…20 mA bzw. 4…20 mA (einstellbar per CoE)
Eingangswiderstand | 85 Ω typ. + Diodenspannung
Auflösung | 12 Bit (inkl. Vorzeichen)
Grenzfrequenz Eingangsfilter | 5 kHz
Wandlungszeit | ca. 100 µs
Messfehler | < 0,3 % (bezogen auf den Messbereichsendwert)
Analoge Ausgänge (AO)
Technische Daten | EP8309-x022
Anzahl analoge Ausgänge (alternativ PWMi Ausgang) | 1
Anschluss Ausgänge | M12-Buchsen
Signaltyp | 0…20 mA bzw. 4…20 mA (einstellbar per CoE)
Bürde | < 500 Ω
Auflösung | 12 Bit
Wandlungszeit | ca. 40 µs
Messfehler | < 0,3 % (bezogen auf den Messbereichsendwert)
Allgemeine technische Daten
Technische Daten | EP8309-x022
Besondere Eigenschaften | Multifunktions-Modul
Versorgung der Modulelektronik | aus der Steuerspannung Us
Stromaufnahme der Modulelektronik | typisch 120 mA
Sensorversorgung | aus Lastspannung Up, DC, frei wählbar bis 30 V
Aktorversorgung | aus Lastspannung Up, DC, frei wählbar bis 30 V
Anschluss Spannungsversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Prozessabbild | Eingänge: 2 x 16 Bit Ausgänge: 2 x 16 Bit
Potenzialtrennung | Steuerspannung / Feldbus: 500 V
Gewicht | ca. 165 g
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE, cULus


EP8309 - Prozessabbild

Produktübersicht [image] EP8309 - Prozessabbild
EP8309 - Prozessabbild
In der Default Einstellung ist die EP8309 konfiguriert auf:
▪
analoger Eingang Kanal 1
▪
analoger Eingang Kanal 2
▪
Tacho Signal von zwei Sensoren auf einer Achse (Single-Shaft-Mode)
▪
6 digitale Eingänge
▪
Status des PWM Ausgangs
▪
Acknowledge / Reset im PWM Fehlerfall.
▪
6 digitale Ausgänge
▪
allgemeine EtherCAT Prozessdaten
AI Inputs Channel 1 und 2
Unter AI Inputs Channel 1 finden Sie die Daten des 1. analogen Kanals.
Underrange: Wert des analogen Eingangs ist kleiner als 0/4 mA bzw. -10/0 V
Overrange: Wert des analogen Eingangs ist größer als 20 mA bzw. +10 V
Limit 1: bei aktiviertem Limit 1 (Object 0x8000:07 = 1) bedeutet
1: Wert kleiner als Limit 1 (eingestellt in Object 0x8000:13)
2: Wert größer als Limit 1 (eingestellt in Object 0x8000:13)
3: Wert gleich Limit 1 (eingestellt in Object 0x8000:13)
Limit 2: bei aktiviertem Limit 2 (Object 0x8000:08= 1) bedeutet
1: Wert kleiner als Limit 2 (eingestellt in Object 0x8000:14)
2: Wert größer als Limit 2 (eingestellt in Object 0x8000:14)
3: Wert gleich Limit 2 (eingestellt in Object 0x8000:14)
Error: Dieses Bit wird gesetzt wenn Over- oder Underrange erkannt wurde.
Tacho Single-Shaft-Mode (abhängig von der Einstellung im PDO-Assignment)
Unter TACHO Single Saift Mode Input Channel 1 finden Sie die Daten des Tacho-Eingangs.
siehe Daten unter Inbetriebnahme
Tacho Dual-Shaft-Mode (abhängig von der Einstellung im PDO-Assignment)
Unter TACHO Dual Shaft Mode Input Channel 1 resp. 2 finden Sie die Daten des Tacho-Eingangs.
siehe Daten unter Inbetriebnahme
DIG Inputs
Unter DIG Inputs finden Sie die Daten der digitalen Eingänge.
X4 Pin4 -> Buchse 4, Pin 4
....
PWM Status
Unter PWM Status finden Sie die Daten desPWM Ausgangs
DEV Inputs
Unter DEV Inputs finden Sie die Diagnose Daten der beiden Spannungen Us und Up.
TRUE = Spannung <= ca. 18 VDC
....
TACHO Output Channel 1
Unter TACHO Output Channel 1 finden Sie die Control-Daten des Tacho-Eingangs.
Reset Error - Rücksetzen eines Fehlers
DO Outputs
Unter DO Inputs finden Sie die Daten der digitalen Ausgänge.
X5 Pin4 -> Buchse 5, Pin 4
....
PWM Control (aktiviert durch PDO Assignment 0x1602, Default PWM, alternativ AO)
Unter PWM Control finden Sie die Control Daten des PWM Ausgangs.
Enable Dithereing -> Aktivierung des Dithering
Enable -> Aktivierung des PWM Ausgangs
Reset -> Rücksetzen im Fehlerfall
PWM Output -> eingeprägter Strom, abhängig von Modul-Nennwert (z. B. 1,2 A und Einstellung in Object 0x8060:10)
AO Outputs (aktiviert durch PDO Assignment 0x1603), im Defaultsetting nicht aktiviert
Unter AO Outputs finden Sie die Werte des analogen Ausgangs.
Analog Output - Ausgabewert


Pulsweitenmodulation (PWM)

Produktübersicht [image] Pulsweitenmodulation (PWM)
Pulsweitenmodulation (PWM)
Die Beckhoff Klemmen und Box Module integrieren kompakte PWM-Endstufen in kleinster Bauform.
PWM-Endstufen regeln den Ausgangsstrom durch Pulsweitenmodulation (PWM) der Versorgungsspannung. Dies bedeutet, dass die Versorgungsspannung in voller Höhe dem Ausgang auf- oder abgeschaltet wird. Verändert wir dabei nicht die Spannungshöhe, sondern die Einschaltdauer (Pulsweite). Erst an der Induktivität der angeschlossenen Last baut sich daraus der Strom auf.
Betrieb an Last mit ausreichend großer Induktivität
Betrieb an Last mit zu kleiner Induktivität (nahezu ohmsch)
In Abb. Betrieb an Last mit zu kleiner Induktivität (nahezu ohmsch) ist zur Veranschaulichung der Betrieb mit einer nicht ausreichend großen Induktivität dargestellt. Ein kontinuierlicher Stromfluss kommt nicht zustande. Der Strom "lückt". Diese Betriebsart ist nicht zulässig.
Hinweis
Pulsweitenstromklemmen benötigen induktive Lasten
Die Induktivität der Last sollte mindestens 1 mH betragen! Ein Betrieb der Pulsweitenstromklemmen an Lasten mit einer Induktivität von weniger als 1 mH wird nicht empfohlen, weil auf Grund des unterbrochenen Stromflusses kein Bezug zwischen dem Sollwert und dem arithmetischen Mittelwert des Stroms gegeben ist!


Beeinflussung des PWMi-Ausgabewertes durch die Parameter

Produktübersicht [image] Beeinflussung des PWMi-Ausgabewertes durch die Parameter
Beeinflussung des PWMi-Ausgabewertes durch die Parameter
Beeinflussung des PWMi Ausgabewertes


Grundlagen EtherCAT

Grundlagen EtherCAT
Grundlagen EtherCAT
Weiterführende Informationen
•
EtherCAT Grundlagen
•
Watchdogeinstellung
•
EtherCAT State Machine
•
CoE-Interface


EtherCAT Grundlagen

Grundlagen EtherCAT [image] EtherCAT Grundlagen
EtherCAT Grundlagen
Grundlagen zum EtherCAT Feldbus entnehmen Sie bitte der Dokumentation EtherCAT System Dokumentation.


Watchdogeinstellung

Grundlagen EtherCAT [image] Watchdogeinstellung
Watchdogeinstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen und die EPxxxx Box-Module sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme/Box zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme/Box statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme/Box bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT--> Erweiterte Einstellungen-->Verhalten--> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist. Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmen-/Boxentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40 ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0...~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
VORSICHT
Vorsicht! Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
VORSICHT
Vorsicht! Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!
Hinweis
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand – je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.


EtherCAT State Machine

Grundlagen EtherCAT [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand. Die Inputdaten werden aber zyklisch aktualisiert.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen EtherCAT [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind:
▪
Index 0…65535
▪
Subindex: 0…255
Üblicherweise wird ein so lokalisierter Parameter geschrieben als x8010:07 mit voranstehendem "x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind:
▪
x1000: hier sind feste Identitäts-Information zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
x4000: hier liegen in manchen EtherCAT-Geräte alternativ zum x8000-Bereich die Kanalparameter.
▪
x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Hinweis
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis.
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter CoE-Online
In der vorherigen Abbildung sind die im Beispiel-gerät „EL2502“ verfügbaren CoE-Objekte von x1000 bis x1600 zu sehen, die Subindizes von x1018 sind aufgeklappt.
Datenerhaltung
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den Systemmanager (vorherige Abbildung) durch Anklicken. Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im Dialog SetValue ein.
▪
aus der Steuerung/PLC über ADS z.B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek. Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein Systemmanager bzw. Bedienpersonal zur Verfügung steht.
Hinweis
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten ausfallsicher im Gerät (EEPROM) gespeichert. D.h. nach einem Neustart sind die veränderten CoE-Parameter immer noch erhalten. Andere Hersteller können dies anders handhaben.
StartUP-Liste
Hinweis
StartUP-Liste
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Werte nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen. Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen. Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abbildung „Karteireiter CoE-Online“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
Wenn der Slave offline ist
▪
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
▪
wird in der Identität der konfigurierte Stand angezeigt
▪
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
▪
ist ein rotes Offline zu sehen
Offline-Verzeichnis
Wenn der Slave online ist
▪
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
▪
wird die tatsächliche Identität angezeigt
▪
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt.
▪
Ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0 ... 10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich x8000:00 ... x800F:255
▪
Kanal 1: Parameterbereich x8010:00 ... x801F:255
▪
Kanal 2: Parameterbereich x8020:00 ... x802F:255
▪
…
Allgemein wird dies geschrieben als x80n0. Ausführliche Hinweise zum Coe-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Montage und Verkabelung

Montage und Verkabelung
Montage und Verkabelung
Weiterführende Informationen
•
Montage
•
Verkabelung


Montage

Montage und Verkabelung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung


Abmessungen

Montage und Verkabelung [image] Montage [image] Abmessungen
Abmessungen
Abmessungen der EtherCAT-Box-Module
Alle Maßangaben sind in Millimeter angegeben.
Gehäuseeigenschaften
EtherCAT Box | Schmales Gehäuse | Breites Gehäuse
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyuhrethan
Montage | zwei Befestigungslöcher Ø 3 mm für M3 | zwei Befestigungslöcher Ø 3 mm für M3 zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm
Gewicht | ca. 125 g, je nach Modultyp | ca. 250 g, je nach Modultyp


Befestigung

Montage und Verkabelung [image] Montage [image] Befestigung
Befestigung
Hinweis
Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung! Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind! Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.
Module mit schmalem Gehäuse werden mit zwei M3-Schrauben montiert.
Module mit breitem Gehäuse werden mit zwei M3-Schrauben an den in den Ecken angeordneten oder mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern montiert.
Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher der Module besitzen kein Gewinde.
Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.
Montageschiene ZS5300-0001
Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module.
Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3-Gewinden. Die Schiene hat 5,3 mm Langlöcher um sie mit M5-Schrauben an der Maschine zu befestigen.
Montageschiene ZS5300-0001
Die Montageschiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 schmalen Modulen. Sie kann applikationsspezifisch gekürzt werden.
Montageschiene ZS5300-0011
Die Montageschiene ZS5300-0011 (500 mm x 129 mm) bietet neben den M3- auch vorgefertigte M4-Gewinde zur Befestigung der 60 mm breiten Module über deren mittlere Bohrungen.
Bis zu 14 schmale oder 7 breite Module können gemischt montiert werden.


Verkabelung

Montage und Verkabelung [image] Verkabelung
Verkabelung
Weiterführende Informationen
•
Anschlüsse
•
Anzugsmomente für Steckverbinder
•
EtherCAT
•
Power-Anschluss
•
Signalanschluss
•
UL-Anforderungen


Anschlüsse

Montage und Verkabelung [image] Verkabelung [image] Anschlüsse
Anschlüsse
Die EP8309 verfügt über verschiedene Signale, die über die acht M12 Buchsen angeschlossen werden können.
Kommentar
Steckverbinder
Kommentar
EtherCAT IN
EtherCAT OUT
Buchse 1:
▪
analog In
Buchse 5:
▪
digital In/Out Kanal 1
▪
digital In/Out Kanal 2
Buchse 2:
▪
analog In
Buchse 6:
▪
digital In/Out Kanal 1
▪
digital In/Out Kanal 2
Buchse 3:
▪
digital In Kanal 1 / Tachoinput 1
▪
digital In Kanal 2 / Tachoinput 2
Buchse 7:
▪
digital In/Out Kanal 3
▪
digital In/Out Kanal 4
Buchse 4:
▪
digital In/Out Kanal 3
▪
digital In/Out Kanal 4
Buchse 8:
▪
Pulsweitenstromausgang oder
▪
analoger Ausgang
Power In
Power Out


Anzugsmomente für Steckverbinder

Montage und Verkabelung [image] Verkabelung [image] Anzugsmomente für Steckverbinder
Anzugsmomente für Steckverbinder
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen. Bei Verwendung des Drehmoment-Schraubendrehers ZB8800 ist auch ein max. Drehmoment von 0,5 Nm zulässig.
EtherCAT Box mit M8-Steckverbindern
M12-Steckverbinder
Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.
EtherCAT Box mit M8- und M12-Steckverbindern
7/8"-Steckverbinder
Es wird empfohlen die 7/8"-Steckverbinder mit einem Drehmoment von 1,5 Nm festzuziehen.
7/8"-Steckverbinder
Drehmomentschlüssel
Drehmomentschlüssel ZB8801
Hinweis
Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (ZB8800, ZB8801-0000)!


EtherCAT

Montage und Verkabelung [image] Verkabelung [image] EtherCAT
EtherCAT
Weiterführende Informationen
•
EtherCAT-Anschluss
•
EtherCAT-LEDs


EtherCAT-Anschluss

Montage und Verkabelung [image] Verkabelung [image] EtherCAT [image] EtherCAT-Anschluss
EtherCAT-Anschluss
Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt
▪
die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
▪
die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8, 30 mm Gehäuse
EtherCAT Box: M860 mm Gehäuse (am Beispiel EP9214)
Koppler Box: M12
Belegung
Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.
Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm
1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003
2) Aderfarben nach EN 61918
3) Aderfarben
Hinweis
Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)
Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx, also die mit M8-Steckverbindern vorkonfektionierten Leitungen auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau). Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!
EtherCAT-Steckverbinder
Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.
Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12-Stecker | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, geeignet GigaBit-Ethernet
ZS1090-0006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-0007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-1006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm
ZS1090-1007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm


EtherCAT-LEDs

Montage und Verkabelung [image] Verkabelung [image] EtherCAT [image] EtherCAT-LEDs
EtherCAT-LEDs
EtherCAT-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational
Hinweis
EtherCAT-Stati
Die verschiedenen Stati, eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (http://www.beckhoff.de/) unter Downloads zur Verfügung steht.


Power-Anschluss

Montage und Verkabelung [image] Verkabelung [image] Power-Anschluss
Power-Anschluss
Weiterführende Informationen
•
Power-Anschluss
•
Status-LEDs für die Spannungsversorgung
•
Powerkabel
•
Leitungsverluste M8


Power-Anschluss

Montage und Verkabelung [image] Verkabelung [image] Power-Anschluss [image] Power-Anschluss
Power-Anschluss
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:
▪
IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
▪
OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen
EtherCAT Box, Anschlüsse für die Versorgungsspannungen
Pinbelegung M8, Power In und Power Out
Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*
Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.
Zwei LEDs zeigen den Status der Versorgungsspannungen an.
Achtung
Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!
Steuerspannung Us: 24 VDC
Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.
Peripheriespannung Up: 24 VDC
Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Achtung
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Versorgung über PowerBox Module EP92x4-0023
Benötigt die Maschine größere Ströme oder sind die EtherCAT Box Module weit vom Schaltschrank und der darin befindlichen Spannungsversorgung entfernt installiert, so empfiehlt sich der Einsatz der vierkanaligen Powerverteilungsmodule EP9214 oder EP9224 (mit integriertem Data Logging, siehe www.beckhoff.de/EP9224).
Mit diesen Modulen lassen sich intelligente Powerverteilungskonzepte mit bis zu 2 x 16 A und maximal 2,5 mm² Leitungsquerschnitt im Feld realisieren.
EP92x4-0023, Anschlüsse Power In und Power Out
Pinbelegung 7/8“, Power IN und Power Out
Galvanische Trennung
Digitale Module
Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) ggfs. miteinander verbunden!
Überprüfen Sie dies in der Dokumentation jeder verwendeten EtherCAT Box.
Analoge Module
Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.
Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z.B. bei 0 bis 10 V Eingängen eine beliebige Referenzspannung (0 bis 30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z.B. geglättete 10 V für Messpotentiometer).
Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.
Achtung
Galvanische Trennung kann aufgehoben werden!
Wenn Sie unterschiedliche EtherCAT Boxen direkt über vierpolige Powerleitungen verbinden, so kann die galvanische Trennung der Analogsignale u.U. nicht mehr gegeben sein!


Status-LEDs für die Spannungsversorgung

Montage und Verkabelung [image] Verkabelung [image] Power-Anschluss [image] Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
LED-Anzeigen
LED | Anzeige | Bedeutung
Us (Steuerspannung) | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung Us erzeugte Sensorversorgung für alle daraus gespeisten Sensoren abgeschaltet.
Up (Peripheriespannung) | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


Powerkabel

Montage und Verkabelung [image] Verkabelung [image] Power-Anschluss [image] Powerkabel
Powerkabel
Bestelldaten
Bestellbezeichnung | Powerleitung | Schraub- Steckverbinder | Kontakte | Querschnitt | Länge
ZK2020-3200-0020 | Buchse gerade, offenes Ende | M8 | 4-polig | 0,34 mm2 | 2,00 m
ZK2020-3200-0050 |  |  |  |  | 5,00 m
ZK2020-3200-0100 |  |  |  |  | 10,00 m
ZK2020-3400-0020 | Buchse gewinkelt, offenes Ende |  |  |  | 2,00 m
ZK2020-3400-0050 |  |  |  |  | 5,00 m
ZK2020-3400-0100 |  |  |  |  | 10,00 m
ZK2020-3132-0001 | Buchse gerade, Stecker gerade |  |  |  | 0,15 m
ZK2020-3132-0005 |  |  |  |  | 0,50 m
ZK2020-3132-0010 |  |  |  |  | 1,00 m
ZK2020-3132-0020 |  |  |  |  | 2,00 m
ZK2020-3132-0050 |  |  |  |  | 5,00 m
ZK2020-3334-0001 | Buchse gewinkelt, Stecker gewinkelt |  |  |  | 0,15 m
ZK2020-3334-0005 |  |  |  |  | 0,50 m
ZK2020-3334-0010 |  |  |  |  | 1,00 m
ZK2020-3334-0020 |  |  |  |  | 2,00 m
ZK2020-3334-0050 |  |  |  |  | 5,00 m
Weitere verfügbare Powerkabel und die dazugehörigen Datenblätter finden Sie im Beckhoff Katalog oder auf unseren Internet-Seiten (http://www.beckhoff.de).
Technische Daten
Daten
Bemessungsspannung nach IEC61076-2-101 | 30 VDC
Verschmutzungsgrad nach IEC 60 664-1 | 3/2
Isolationswiderstand IEC 60 512-2 | >109Ω
Strombelastbarkeit IEC 60512-3 | 4 A
Durchgangswiderstand IEC 60512-2 | < 5 mΩ
Schutzart nach IEC 60529 | IP65/66/67, im verschraubten Zustand
Umgebungstemperatur | -30°C bis +80°C


Leitungsverluste M8

Montage und Verkabelung [image] Verkabelung [image] Power-Anschluss [image] Leitungsverluste M8
Leitungsverluste M8
Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
Leitungsverluste auf den Powerkabeln
Beispiel
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.
Hinweis
Powerverteilungs-Module EP92x4-0023
Mit den Powerverteilungs-Modulen EP9214 und EP9224 sind intelligente Spannungsverteilungskonzepte verfügbar. Weitere Information finden sie unter www.beckhoff.de/EP9224


Signalanschluss

Montage und Verkabelung [image] Verkabelung [image] Signalanschluss
Signalanschluss
Weiterführende Informationen
•
Digitale Eingänge M12
•
Digitale Ein-/ Ausgänge M12
•
Analoge Eingänge M12
•
Analoger Ausgang und PWMi-Ausgang M12
•
Status-LEDs


Digitale Eingänge M12

Montage und Verkabelung [image] Verkabelung [image] Signalanschluss [image] Digitale Eingänge M12
Digitale Eingänge M12
Die digitalen Eingangsmodule erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät.
Der Signalanschluss erfolgt über M12-Steckverbinder.
Digitale Eingänge M12
Die Sensoren werden aus der Steuerspannung Us mit einem gemeinsamen, maximalen Strom von 0,5 A versorgt.
Leuchtdioden zeigen den Signalzustand der Eingänge an.


Digitale Ein-/ Ausgänge M12

Montage und Verkabelung [image] Verkabelung [image] Signalanschluss [image] Digitale Ein-/ Ausgänge M12
Digitale Ein-/ Ausgänge M12
Die digitalen Ein-Ausgangskanäle schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktuatoren weiter oder lesen digitale Eingangssignale ein.
Es ist keine Konfiguration notwendig. Je Kanal kann entweder ein Ein- oder ein Ausgang angeschlossen werden.
Wir ein Ausgang verwendet, kann beim Einschalten des Ausgangs die Statusänderung über das entsprechende Signal im Eingangs-Prozessabbild überprüft werden.
Der Signalanschluss erfolgt über M12-Steckverbinder.
Digitale Ein-/ Ausgänge M12
Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.
Leuchtdioden zeigen den Signalzustand der Ausgänge an.


Analoge Eingänge M12

Montage und Verkabelung [image] Verkabelung [image] Signalanschluss [image] Analoge Eingänge M12
Analoge Eingänge M12
Die analogen Signaleingänge erfassen analoge Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät.
Der Signalanschluss erfolgt über M12-Steckverbinder.
Analoge Eingänge M12
Die Sensoren werden aus der Steuerspannung Us mit einem gemeinsamen, maximalen Strom von 0,5 A versorgt.
Leuchtdioden zeigen den Status der Eingänge an.


Analoger Ausgang und PWMi-Ausgang M12

Montage und Verkabelung [image] Verkabelung [image] Signalanschluss [image] Analoger Ausgang und PWMi-Ausgang M12
Analoger Ausgang und PWMi-Ausgang M12
Über den Multifunktionsausgang kann entweder ein analoger Ausgang oder ein PWMi-Ausgang an z. B. ein Proportionalventil ausgegeben werden.
Der Signalanschluss erfolgt über M12-Steckverbinder.
Analoger Ausgang und PWMi-Ausgang M12
Die Ausgänge sind kurzschlussfest.
Leuchtdioden zeigen den Signalzustand des Ausgangs an.


Status-LEDs

Montage und Verkabelung [image] Verkabelung [image] Signalanschluss [image] Status-LEDs
Status-LEDs
Status LEDs
Status-LEDs an den M12-Anschlüssen
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse analoge Eingänge, PWMi | links | aus | keine Datenübertragung zum D/A-Wandler
 |  | grün | Datenübertragung zum D/A-Wandler
 | rechts | aus | einwandfreie Funktion
 |  | rot | analog Fehler: Drahtbruch oder Messwert außerhalb des Messbereichs PWMi: allgemeiner Fehler, siehe Status-Wort
Eine einwandfreie Funktion besteht wenn die grüne LED Run leuchtet und die rote LED Error aus ist.
Status-LEDs an den M12-Anschlüssen
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse digitale Ein- / Ausgänge | links / rechts | aus | Eingang / Ausgang aus bzw. Low
 |  | grün | Eingang / Ausgang an bzw. High


UL-Anforderungen

Montage und Verkabelung [image] Verkabelung [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


Inbetriebnahme und Konfiguration

Inbetriebnahme und Konfiguration
Inbetriebnahme und Konfiguration
Weiterführende Informationen
•
Einfügen in das EtherCAT-Netzwerk
•
Konfiguration mit TwinCAT
•
Tachoauswertung
•
Umstellung des PWMi-/Analog-Ausgangs
•
Schnellstart
•
Bereichseinstellungen für Ein- und Ausgänge
•
CoE Objekte
•
Wiederherstellen des Auslieferungszustandes


Einfügen in das EtherCAT-Netzwerk

Inbetriebnahme und Konfiguration [image] Einfügen in das EtherCAT-Netzwerk
Einfügen in das EtherCAT-Netzwerk
Hinweis
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140) und entsprechend der Installationsanweisungen installiert werden.
Der Konfigurationsbaum im Beckhoff TwinCAT SystemManager kann auf 2 Wegen erstellt werden:
▪
durch Einscannen vorhandener Hardware (genannt "online") und
▪
durch manuelles Einfügen/Anhängen von Feldbus-Geräten, Kopplern und Slaves.
Automatisches Einscannen der Box
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode) und scannen Sie die Geräte ein. Bestätigen Sie alle folgenden Dialoge mit OK, so dass sich die Konfiguration im Modus FreeRun befindet.
Einscannen der Konfiguration (E/A-Geräte -> Rechte Maustaste -> Geräte suchen...)
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z.B.: EP2816-0008), bestätigen Sie mit OK.
Auswahl einer Box (z.B.: EP2816-0008)
Angefügte Box im TwinCAT-Baum


Konfiguration mit TwinCAT

Inbetriebnahme und Konfiguration [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten (in diesem Beispiel EP2816-0008).
Baumzweig der zu konfigurierende EtherCAT Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Hinweis
Aktivierung der PDO-Zuordnung
•
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
•
der System Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


Tachoauswertung

Inbetriebnahme und Konfiguration [image] Tachoauswertung
Tachoauswertung
Unter Tachoauswertung wird die Geschwindigkeits- bzw. Frequenzerfassung von zwei digitalen Sensoren, die auf einer Welle (Single Shaft Mode) oder auf zwei Wellen (Dual Shaft Mode) angebracht sind, verstanden.
Beim Single Shaft Mode kann auf Plausibilität der beiden Sensor geprüft werden (z. B. Abweichung der Geschwindigkeit beider Sensoren).
Die Targets (Markierungen für die Sensoren) müssen beim Auslösen ein 90° überlappendes Signal ergeben. Die minimale ON bzw. OFF Time darf 0,2 ms nicht unterschreiten, sonst ist eine Detektierung auf Grund der Abtastfrequenz nicht möglich.
Die Anzahl der Targets auf der Achse kann im CoE Object 0x80x0:11 eingestellt werden, so kann eine langsamere Geschwindigkeit/Drehzahlerkennung mit vielen Targets oder eine hohe Geschwindigkeit mit wenigen Targets erreicht werden.
Auswahl der Modi über die PDOs
Die Aktivierung der verschiedenen Modi geschieht über das PDO Assignment.
Single Shaft Mode
Das Eingangs PDO 0x1A02 aktiviert das entsprechende Setting. Die Ausgangsdaten sind immer gesetzt.
Tachoauswertung - Single Shaft Mode
Prozessdaten
Wert | Beschreibung
Error Input A | die gemessene Geschwindigkeit/Frequenz ist langsamer als die der Spur B, oder sie ist 0 (Sensordefekt)
Input Status A | Status des Eingangs A
Error Input B | die gemessene Geschwindigkeit/Frequenz ist langsamer als die der Spur A, oder sie ist 0 (Sensordefekt)
Input Status B | Status des Eingangs B
Speed below threshold | die Geschwindigkeit ist unterhalb des Grenzwertes in CoE 0x8020:12 Rotational Speed Threshold oder = 0
Rotational Speed | die Umdrehungsgeschwindigkeit bzw. Frequenz, dargestellt in Abhängigkeit von CoE Object 0x80x0:15
Rotation Direction | 0: steigende Flanke Input A kommt zeitlich vor der steigenden Flanke Input B
Darstellung der Rotational Speed
Tachoauswertung - Darstellung der Rotational Speed
Dual Shaft Mode
Die Eingangs PDOs 0x1A03 und 0x1A04 aktivieren die beiden Dual Shaft Prozessdaten. Die Ausgangsdaten sind immer gesetzt.
Tachoauswertung - Dual Shaft Mode
Prozessdaten (Einstellungen für den zweiten Kanal ebenso)
Wert | Beschreibung
Digital Input | Status des Eingangs
Speed below threshold | die Geschwindigkeit ist unterhalb des Grenzwertes in CoE 0x8020:12 oder = 0
Rotational Speed | die Umdrehungsgeschwindigkeit bzw. Frequenz, dargestellt in Abhängigkeit von CoE Object 0x80x0:15
Darstellung der Rotational Speed
siehe Single Shaft Mode
CoE Einstellungen
Über die CoE Objecte wird das Verhalten der Tachoeingänge eingestellt.
Tachoauswertung -
Folgende Einstellungen gelten bei allen Kanälen:
CoE | Wert | Beschreibung
80xx:12 | Input Signal Timeout | nach x msec ohne Signalwechsel am Eingang wird das Prozessdatum <Speed Below Threshold> gesetzt.
Folgende Einstellungen stehen nur im Single-Shaft-Mode zur Verfügung
CoE Objecte für Tacho Settings (0x8020 und 0x8030)
CoE | Wert | Beschreibung
80x0:0B | Enable Error Detection | Fehleranzeige aktivieren/deaktivieren
80x0:0C | Reversion of rotation | Umkehr der Drehrichtungsdarstellung in Rotation direction
80x0:11 | No. of Targets | Anzahl der "Nocken" auf der Welle/Achse
80x0:12 | Rotational Speed Threshold | Grenzwert unterhalb das entsprechende StatusBit gesetzt wird
80x0:15 | Presentation | Darstellung des Messwertes in RPM, Hz, ...


Umstellung des PWMi-/Analog-Ausgangs

Inbetriebnahme und Konfiguration [image] Umstellung des PWMi-/Analog-Ausgangs
Umstellung des PWMi-/Analog-Ausgangs
Auswahl der Modi über die PDOs
Zum Betrieb eines z. B. Proportionalventils an der Buchse 7 kann entweder der PWMi-Modus oder der analoge Modus gewählt werden.
▪
Im PWMi-Modus (Default) wird die Spule direkt über ein PWM Signal angesteuert. Das Ventil benötigt keine Steuerelektronik.
▪
Im analogen Modus wird ein Stromwert von 0...20 mA bzw. 4...20 mA ausgegeben, über den die im Ventil integrierte Steuerelektronik den Ventilhub ansteuert.
Die 24 VDC-Versorgung wird dabei dauerhaft eingeschaltet.
Die Aktivierung der verschiedenen Modi geschieht über das PDO-Assignment.
PWMi-Modus
Das Ausgangs-PDO 0x1602 aktiviert den PWMi-Modus.
Umstellung des PWMi-/Analog-Ausgangs - PWMi-Modus
Analog-Modus
Das Ausgangs PDO 0x1603 aktiviert den analogen Modus.
Umstellung des PWMi-/Analog-Ausgangs - Analog-Modus


Schnellstart

Inbetriebnahme und Konfiguration [image] Schnellstart
Schnellstart
Parametrierung der wichtigsten Einstellungen
Das Modul ist ab Werk so eingestellt, dass sie in den meisten Anwendungen ohne weitere Parametrierung funktionstüchtig ist.
Stellen Sie den Parameter Max Current [%] (0x8pp0:10) so ein, dass der Maximalstrom der Induktivität nicht überschritten wird. Beim Einsatz einer EP8309 mit 1,2 A Nennstrom und einer Induktivität mit einem maximalen Strom von 600 mA kann dieser Parameter auf 50 (50%) gesetzt werden. Somit wird bei einem maximalen Prozessdatenwert von 32767dez ein Spulenstrom von +600 mA und nicht von +1 A erreicht.
Info Data Objekte
Über die Info Daten Objekte lassen sich Zusatzinformationen synchron übertragen. Für jeden Kanal stehen zwei dieser Objekte zur Verfügung.
Die Synchronen Info Daten lassen sich im TwinCAT System Manager, auf dem Karteireiter "Prozessdaten" (0x1A07) aktivieren.
Info Data Objekte - Aktivierung der Synchronen Info Daten
Über die Objekte 0x8060:21 und 0x8060:22 lässt sich einstellen, welcher Wert synchron übertragen werden soll.
Info Data Objekte - Auswahl des zu übertragenden Wertes
Zur Verfügung stehen folgende Einträge:
Wert | Text | Beschreibung
0 | Actual current | Ist-Strom in mA
1 | Set current | Soll-Strom in mA
2 | Duty Cycle | Der PWM Duty cycle der Endstufe. Ein Wert von 1000 entspricht 100% Duty cycle
Watchdog
Der analoge Ausgabewert kann - z. B. im Falle einer Kommunikationsstörung mit der Steuerung - auf einen anwenderspezifischen Wert gesetzt werden.
Watchdog
Zu diesem Zweck gibt es drei Parametrierungsmöglichkeiten:
Watchdog Objekt (0x8060:05) | Verhalten
0: Default watchdog value | Der Ersatzschaltwert (0x8060:0D) wird im Fehlerfall ausgegeben.
1: Watchdog ramp active | Das Ausgabewert wird im Fehlerfall mit der unter 0x8060:0E eingestellten Rampenzeit auf den Defaultwert (0x8060:0D) gefahren Dabei wird die Rampenzeit in Digits / ms vorgegeben. Ist der Eintrag z. B. 100 und der Defaultwert 0, so dauert es 327 ms (32767/100) bis der Ausgangswert im Fehlerfall vom Maximalwert (32767) auf den Defaultwert geht.
2: Last output value active | Das letzte Prozessdatum wird im Fehlerfall (Abfall des Watchdogs) ausgegeben.
Optimierung der Stromreglerparameter
Um möglicht alle Lasten ab Werk zu unterstützen, wurde die Klemme mit einem moderaten Reglerverhalten parametriert. Die Ausregelung des Stromes kann durch Anpassung der Reglerparameter an die verwendete Last erheblich verbessert werden.
Zur Ermittlung der Einstellungen wird ein Stromsprung auf die Last gegeben. Dieser Sprung kann mit einem Oszilloskop oder mit dem TwinCAT ScopeView aufgenommen werden.
Um eine Auswertung mit dem TwinCat ScopeView durchzuführen werden in die synchronen Info Daten der Soll- und Ist-Strom eingeblendet.
Auswahl der synchronen Info Daten
EP8309 Standard Parameter (20 ms/Div)
Grün: Soll-Strom
Rot: Ist-Strom
Optimierte Parameter (20 ms/Div)
Grün: Soll-Strom
Rot: Ist-Strom
Unter Zuhilfenahme der Kp,Ki, und Kd (0x8060:12 bis 0x8060:14) Parameter kann die gewünschte Sprungantwort eingestellt werden.
Dithering
Beim Dithering wird dem eigentlichen Ausgabewert ein Rechtecksignal aufmoduliert. Durch das aufmodulierte Signal wird z. B. der Kolben eines Ventils ständig in Bewegung gehalten.
Dadurch reduziert sich der Einfluss der Haftreibung und ein plötzliches "Losbrechen" des Kolbens wird verhindert.
Die dazu benötigte Konfiguration ist stark von der Applikation abhängig.
Zur Aktivierung des Dithers muss das Objekt 0x8060:03 ("Enable dithering") und das entsprechende Control-Bit gesetzt werden.
Enable Dithering
Die folgenden Parameter sind einstellbar:
Wert | Text | Beschreibung
0x8060:1E | Dithering frequency [Hz] | Frequenz des aufmodulierten Dithers in Hz
0x8060:1F | Dithering amplitude [%] | Amplitude des Aufmodulierten Dithers (in % des Nennstoms der Klemme)
Weiterhin spielen die Reglerparameter selber eine Rolle Kp, Ki, und Kd). In den Graphen wird ein Dither von 10 % des Nennstromes mit 100 Hz dargestellt. Dem Regler steht damit eine Zeit von 5 ms zur Verfügung, um einen Stromsprung von 10 % auszuregeln. Die Steilheit des Stromanstieges ist jedoch durch die Reglerparameter und die Induktivität selber begrenzt. Der Ist-Strom sollte dem Soll-Strom möglichst folgen. Dies wird durch geeignete Einstellung der Regler- und Dither-Parameter (Frequenz und Amplitude) ermöglicht.
EP8309 100 z Dither mit 10 % Amplitude,
schlechte Parametrierung (5 ms/Div)
Grün: Soll-Strom
Rot: Ist-Strom
EP8309 100 Hz Dither mit 10 % Amplitude,
bessere Parametrierung (5 ms/Div)
Grün: Soll-Strom
Rot: Ist-Strom


Bereichseinstellungen für Ein- und Ausgänge

Inbetriebnahme und Konfiguration [image] Bereichseinstellungen für Ein- und Ausgänge
Bereichseinstellungen für Ein- und Ausgänge
Karteireiter CoE-Online
Der Karteireiter CoE-Online listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern.
Objekt 0xF800:0 enthält die Bereichseinstellungen für die Ein- und Ausgänge von Kanal 1 bis 4.
Karteireiter CoE-Online
Klicken Sie auf die Objekte 0xF800:01 bis 0xF800:04 um die Einstellungen zu ändern.
Ändern der Einstellungen


CoE Objekte

Inbetriebnahme und Konfiguration [image] CoE Objekte
CoE Objekte
Weiterführende Informationen
•
CoE-Interface
•
Objektübersicht
•
Objektbeschreibung und Parametrierung


CoE-Interface

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind:
▪
Index 0…65535
▪
Subindex: 0…255
Üblicherweise wird ein so lokalisierter Parameter geschrieben als x8010:07 mit voranstehendem "x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind:
▪
x1000: hier sind feste Identitäts-Information zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
x4000: hier liegen in manchen EtherCAT-Geräte alternativ zum x8000-Bereich die Kanalparameter.
▪
x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Hinweis
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis.
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter CoE-Online
In der vorherigen Abbildung sind die im Beispiel-gerät „EL2502“ verfügbaren CoE-Objekte von x1000 bis x1600 zu sehen, die Subindizes von x1018 sind aufgeklappt.
Datenerhaltung
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den Systemmanager (vorherige Abbildung) durch Anklicken. Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im Dialog SetValue ein.
▪
aus der Steuerung/PLC über ADS z.B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek. Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein Systemmanager bzw. Bedienpersonal zur Verfügung steht.
Hinweis
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten ausfallsicher im Gerät (EEPROM) gespeichert. D.h. nach einem Neustart sind die veränderten CoE-Parameter immer noch erhalten. Andere Hersteller können dies anders handhaben.
StartUP-Liste
Hinweis
StartUP-Liste
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Werte nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen. Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen. Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abbildung „Karteireiter CoE-Online“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
Wenn der Slave offline ist
▪
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
▪
wird in der Identität der konfigurierte Stand angezeigt
▪
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
▪
ist ein rotes Offline zu sehen
Offline-Verzeichnis
Wenn der Slave online ist
▪
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
▪
wird die tatsächliche Identität angezeigt
▪
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt.
▪
Ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich x8000:00 ... x800F:255
▪
Kanal 1: Parameterbereich x8010:00 ... x801F:255
▪
Kanal 2: Parameterbereich x8020:00 ... x802F:255
▪
…
Allgemein wird dies geschrieben als x80n0. Ausführliche Hinweise zum Coe-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Objektübersicht

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] Objektübersicht
Objektübersicht
Hinweis
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Index (hex) |  | Name | Flags | Default-Wert
1000 |  | Device type | RO | 0x00001389 (5001dez)
1008 |  | Device name | RO | EP8309-1022
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 02
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x20754052 (544555090dez)
 | 1018:03 | Revision | RO | 0x00110016 (1114134dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1402:0 | Subindex | PWM RxPDO-Par Control | RO | 0x06 (6dez)
 | 1402:06 | Exclude RxPDOs | RO | 03 16
1403:0 | Subindex | AO RxPDO-Par Outputs | RO | 0x06 (6dez)
 | 1403:06 | Exclude RxPDOs | RO | 02 16
1600:0 | Subindex | TACHO RxPDO-Map OutputsCh.1 | RO | 0x03 (3dez)
 | 1600:01 | SubIndex 001 | RO | 0x0000:00, 8
 | 1600:02 | SubIndex 002 | RO | 0x7020:09, 1
 | 1600:03 | SubIndex 003 | RO | 0x0000:00, 7
1601:0 | Subindex | DO RxPDO-Map Outputs | RO | 0x07 (7dez)
 | 1601:01 | SubIndex 001 | RO | 0x7050:01, 1
 | 1601:02 | SubIndex 002 | RO | 0x7050:02, 1
 | 1601:03 | SubIndex 003 | RO | 0x7050:03, 1
 | 1601:04 | SubIndex 004 | RO | 0x7050:04, 1
 | 1601:05 | SubIndex 005 | RO | 0x7050:05, 1
 | 1601:06 | SubIndex 006 | RO | 0x7050:06, 1
 | 1601:07 | SubIndex 007 | RO | 0x0000:00, 10
1602:0 | Subindex | PWM RxPDO-Map Control | RO | 0x06 (6dez)
 | 1602:01 | SubIndex 001 | RO | 0x7060:01, 1
 | 1602:02 | SubIndex 002 | RO | 0x0000:00, 4
 | 1602:03 | SubIndex 003 | RO | 0x7060:06, 1
 | 1602:04 | SubIndex 004 | RO | 0x7060:07, 1
 | 1602:05 | SubIndex 005 | RO | 0x0000:00, 9
 | 1602:06 | SubIndex 006 | RO | 0x7060:11, 16
Index (hex) |  | Name | Flags | Default-Wert
1603:0 | Subindex | AO RxPDO-Map Outputs | RO | 0x01 (1dez)
 | 1603:01 | SubIndex 001 | RO | 0x7070:11, 16
1802:0 | Subindex | TACHO TxPDO-Par Single Shaft Mode Input Ch.1 | RO | 0x06 (6dez)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A 04 1A
1803:0 | Subindex | TACHO TxPDO-Par Dual Shaft Mode Input Ch.1 | RO | 0x06 (6dez)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A 00 00
1804:0 | Subindex | TACHO TxPDO-Par Dual Shaft Mode Input Ch.2 | RO | 0x06 (6dez)
 | 1804:06 | Exclude TxPDOs | RO | 02 1A 00 00
1A00:0 | Subindex | AI TxPDO-Map Inputs Ch.1 | RO | 0x0A (10dez)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 2
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 2
 | 1A00:05 | SubIndex 005 | RO | 0x6000:07, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A00:07 | SubIndex 007 | RO | 0x6000:0E, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:0F, 1
 | 1A00:09 | SubIndex 009 | RO | 0x6000:10, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Inputs Ch.2 | RO | 0x0A (10dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A01:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A01:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A01:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A01:07 | SubIndex 007 | RO | 0x6010:0E, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6010:0F, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6010:10, 1
 | 1A01:0A | SubIndex 010 | RO | 0x6010:11, 16
1A02:0 | Subindex | TACHO TxPDO-Map Single Shaft Mode Input Ch.1 | RO | 0x0C (12dez)
 | 1A02:01 | SubIndex 001 | RO | 0x0000:00, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6037:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6037:03, 1
 | 1A02:04 | SubIndex 004 | RO | 0x6037:04, 1
 | 1A02:05 | SubIndex 005 | RO | 0x6037:05, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 3
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 3
 | 1A02:08 | SubIndex 008 | RO | 0x6037:0C, 1
 | 1A02:09 | SubIndex 009 | RO | 0x0000:00, 3
 | 1A02:0A | SubIndex 010 | RO | 0x6037:10, 1
 | 1A02:0B | SubIndex 011 | RO | 0x6037:11, 16
 | 1A02:0C | SubIndex 012 | RO | 0x6037:12, 16
Index (hex) |  | Name | Flags | Default-Wert
1A03:0 | Subindex | TACHO TxPDO-Map Dual Shaft Mode Input Ch.1 | RO | 0x09 (9dez)
 | 1A03:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A03:02 | SubIndex 002 | RO | 0x0000:00, 2
 | 1A03:03 | SubIndex 003 | RO | 0x0000:00, 1
 | 1A03:04 | SubIndex 004 | RO | 0x0000:00, 4
 | 1A03:05 | SubIndex 005 | RO | 0x0000:00, 3
 | 1A03:06 | SubIndex 006 | RO | 0x6020:0C, 1
 | 1A03:07 | SubIndex 007 | RO | 0x0000:00, 3
 | 1A03:08 | SubIndex 008 | RO | 0x6020:10, 1
 | 1A03:09 | SubIndex 009 | RO | 0x6020:11, 16
1A04:0 | Subindex | TACHO TxPDO-Map Dual Shaft Mode Input Ch.2 | RO | 0x09 (9dez)
 | 1A04:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A04:02 | SubIndex 002 | RO | 0x0000:00, 2
 | 1A04:03 | SubIndex 003 | RO | 0x0000:00, 1
 | 1A04:04 | SubIndex 004 | RO | 0x0000:00, 4
 | 1A04:05 | SubIndex 005 | RO | 0x0000:00, 3
 | 1A04:06 | SubIndex 006 | RO | 0x6030:0C, 1
 | 1A04:07 | SubIndex 007 | RO | 0x0000:00, 3
 | 1A04:08 | SubIndex 008 | RO | 0x6030:10, 1
 | 1A04:09 | SubIndex 009 | RO | 0x6030:11, 16
1A05:0 | Subindex | DI TxPDO-Map Inputs | RO | 0x07 (7dez)
 | 1A05:01 | SubIndex 001 | RO | 0x6040:01, 1
 | 1A05:02 | SubIndex 002 | RO | 0x6040:02, 1
 | 1A05:03 | SubIndex 003 | RO | 0x6040:03, 1
 | 1A05:04 | SubIndex 004 | RO | 0x6040:04, 1
 | 1A05:05 | SubIndex 005 | RO | 0x6040:05, 1
 | 1A05:06 | SubIndex 006 | RO | 0x6040:06, 1
 | 1A05:07 | SubIndex 007 | RO | 0x0000:00, 10
1A06:0 | Subindex | PWM TxPDO-Map Status | RO | 0x08 (8dez)
 | 1A06:01 | SubIndex 001 | RO | 0x0000:00, 1
 | 1A06:02 | SubIndex 002 | RO | 0x0000:00, 3
 | 1A06:03 | SubIndex 003 | RO | 0x6060:05, 1
 | 1A06:04 | SubIndex 004 | RO | 0x6060:06, 1
 | 1A06:05 | SubIndex 005 | RO | 0x6060:07, 1
 | 1A06:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A06:07 | SubIndex 007 | RO | 0x0000:00, 7
 | 1A06:08 | SubIndex 008 | RO | 0x6060:10, 1
1A07:0 | Subindex | PWM TxPDO-Map Synchron info data | RO | 0x02 (2dez)
 | 1A07:01 | SubIndex 001 | RO | 0x6060:11, 16
 | 1A07:02 | SubIndex 002 | RO | 0x6060:12, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
Index (hex) |  | Name | Flags | Default-Wert
1C12:0 | Subindex | RxPDO assign | RW | 0x03 (3dez)
 | 1C12:01 | SubIndex 001 | RW | 0x1600 (5632dez)
 | 1C12:02 | SubIndex 002 | RW | 0x1601 (5633dez)
 | 1C12:03 | SubIndex 003 | RW | 0x1602 (5634dez)
 | 1C12:04 | SubIndex 004 | RW | 0x0000 (0dez)
1C13:0 | Subindex | TxPDO assign | RW | 0x05 (5dez)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 | 1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dez)
 | 1C13:03 | SubIndex 003 | RW | 0x1A02 (6658dez)
 | 1C13:04 | SubIndex 004 | RW | 0x1A05 (6661dez)
 | 1C13:05 | SubIndex 005 | RW | 0x1A06 (6662dez)
 | 1C13:06 | SubIndex 006 | RW | 0x0000 (0dez)
 | 1C13:07 | SubIndex 007 | RW | 0x0000 (0dez)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dez)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C32:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C32:05 | Minimum cycle time | RO | 0x0007A120 (500000dez)
 | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C32:08 | Command | RW | 0x0000 (0dez)
 | 1C32:09 | Maximum delay time | RO | 0x00000000 (0dez)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C32:20 | Sync error | RO | 0x00 (0dez)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dez)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dez)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C33:05 | Minimum cycle time | RO | 0x0007A120 (500000dez)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C33:08 | Command | RW | 0x0000 (0dez)
 | 1C33:09 | Maximum delay time | RO | 0x00000000 (0dez)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C33:20 | Sync error | RO | 0x00 (0dez)
Index (hex) |  | Name | Flags | Default-Wert
6000:0 | Subindex | AI Inputs Ch.1 | RO | 0x11 (17dez)
 | 6000:01 | Underrange | RO | 0x00 (0dez)
 | 6000:02 | Overrange | RO | 0x00 (0dez)
 | 6000:03 | Limit 1 | RO | 0x00 (0dez)
 | 6000:05 | Limit 2 | RO | 0x00 (0dez)
 | 6000:07 | Error | RO | 0x00 (0dez)
 | 6000:0E | Sync error | RO | 0x00 (0dez)
 | 6000:0F | TxPDO State | RO | 0x00 (0dez)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6000:11 | Value | RO | 0x0000 (0dez)
6010:0 | Subindex | AI Inputs Ch.2 | RO | 0x11 (17dez)
 | 6010:01 | Underrange | RO | 0x00 (0dez)
 | 6010:02 | Overrange | RO | 0x00 (0dez)
 | 6010:03 | Limit 1 | RO | 0x00 (0dez)
 | 6010:05 | Limit 2 | RO | 0x00 (0dez)
 | 6010:07 | Error | RO | 0x00 (0dez)
 | 6010:0E | Sync error | RO | 0x00 (0dez)
 | 6010:0F | TxPDO State | RO | 0x00 (0dez)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6010:11 | Value | RO | 0x0000 (0dez)
6020:0 | Subindex | TACHO Dual Shaft Mode Input Ch.1 | RO | 0x11 (17dez)
 | 6020:01 | Digital Input | RO | 0x00 (0dez)
 | 6020:0C | Speed Below Threshold | RO | 0x00 (0dez)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6020:11 | Rotational Speed | RO | 0x0000 (0dez)
6030:0 | Subindex | TACHO Dual Shaft Mode Input Ch.2 | RO | 0x11 (17dez)
 | 6030:01 | Digital Input | RO | 0x00 (0dez)
 | 6030:0C | Speed Below Threshold | RO | 0x00 (0dez)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6030:11 | Rotational Speed | RO | 0x0000 (0dez)
6037:0 | Subindex | TACHO Single Shaft Mode Input | RO | 0x12 (18dez)
 | 6037:02 | Error Input A | RO | 0x00 (0dez)
 | 6037:03 | Input Status A | RO | 0x00 (0dez)
 | 6037:04 | Error Input B | RO | 0x00 (0dez)
 | 6037:05 | Input Status B | RO | 0x00 (0dez)
 | 6037:0C | Speed Below Threshold | RO | 0x00 (0dez)
 | 6037:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6037:11 | Rotational Speed | RO | 0x0000 (0dez)
 | 6037:12 | Rotation Direction | RO | 0x0000 (0dez)
6040:0 | Subindex | DI Inputs | RO | 0x06 (6dez)
 | 6040:01 | Digital Input X4 Pin4 | RO | 0x00 (0dez)
 | 6040:02 | Digital Input X4 Pin2 | RO | 0x00 (0dez)
 | 6040:03 | Digital Input X6 Pin4 | RO | 0x00 (0dez)
 | 6040:04 | Digital Input X6 Pin2 | RO | 0x00 (0dez)
 | 6040:05 | Digital Input X7 Pin4 | RO | 0x00 (0dez)
 | 6040:06 | Digital Input X7 Pin2 | RO | 0x00 (0dez)
Index (hex) |  | Name | Flags | Default-Wert
6060:0 | Subindex | PWM Inputs | RO | 0x12 (18dez)
 | 6060:05 | Ready to enable | RO | 0x00 (0dez)
 | 6060:06 | Warning | RO | 0x00 (0dez)
 | 6060:07 | Error | RO | 0x00 (0dez)
 | 6060:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6060:11 | Info data 1 | RO | 0x0000 (0dez)
 | 6060:12 | Info data 2 | RO | 0x0000 (0dez)
7020:0 | Subindex | TACHO Outputs | RO | 0x09 (9dez)
 | 7020:09 | Reset Error | RO | 0x00 (0dez)
7030:0 | Subindex | TACHO Outputs | RO | 0x09 (9dez)
 | 7030:09 | Reset Error | RO | 0x00 (0dez)
7050:0 | Subindex | DO Outputs | RO | 0x06 (6dez)
 | 7050:01 | Digital Output X5 Pin4 | RO | 0x00 (0dez)
 | 7050:02 | Digital Output X5 Pin2 | RO | 0x00 (0dez)
 | 7050:03 | Digital Output X6 Pin4 | RO | 0x00 (0dez)
 | 7050:04 | Digital Output X6 Pin2 | RO | 0x00 (0dez)
 | 7050:05 | Digital Output X7 Pin4 | RO | 0x00 (0dez)
 | 7050:06 | Digital Output X7 Pin2 | RO | 0x00 (0dez)
7060:0 | Subindex | PWM Outputs | RO | 0x11 (17dez)
 | 7060:01 | Enable dithering | RO | 0x00 (0dez)
 | 7060:06 | Enable | RO | 0x00 (0dez)
 | 7060:07 | Reset | RO | 0x00 (0dez)
 | 7060:11 | PWM output | RO | 0x0000 (0dez)
7070:0 | Subindex | AO Outputs | RO | 0x11 (17dez)
 | 7070:11 | Analog output | RO | 0x0000 (0dez)
8000:0 | Subindex | AI Settings Ch.1 | RW | 0x18 (24dez)
 | 8000:01 | Enable user scale | RW | 0x00 (0dez)
 | 8000:02 | Presentation | RW | 0x00 (0dez)
 | 8000:05 | Siemens bits | RW | 0x00 (0dez)
 | 8000:06 | Enable filter | RW | 0x00 (0dez)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8000:11 | User scale offset | RW | 0x0000 (0dez)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8000:15 | Filter settings | RW | 0x0000 (0dez)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dez)
800E:0 | Subindex | AI Internal data Ch.1 | RO | 0x01 (1dez)
 | 800E:01 | ADC raw value | RO | 0x0000 (0dez)
Index (hex) |  | Name | Flags | Default-Wert
800F:0 | Subindex | AI Vendor data Ch.1 | RW | 0x06 (6dez)
 | 800F:01 | R0 offset | RW | 0x0000 (0dez)
 | 800F:02 | R0 gain | RW | 0x4000 (16384dez)
 | 800F:03 | R1 offset | RW | 0x0000 (0dez)
 | 800F:04 | R1 gain | RW | 0x4000 (16384dez)
 | 800F:05 | R2 offset | RW | 0x0000 (0dez)
 | 800F:06 | R2 gain | RW | 0x4000 (16384dez)
8010:0 | Subindex | AI Settings Ch.2 | RW | 0x18 (24dez)
 | 8010:01 | Enable user scale | RW | 0x00 (0dez)
 | 8010:02 | Presentation | RW | 0x00 (0dez)
 | 8010:05 | Siemens bits | RW | 0x00 (0dez)
 | 8010:06 | Enable filter | RW | 0x00 (0dez)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8010:11 | User scale offset | RW | 0x0000 (0dez)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8010:15 | Filter settings | RW | 0x0000 (0dez)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dez)
801E:0 | Subindex | AI Internal data Ch.2 | RO | 0x01 (1dez)
 | 801E:01 | ADC raw value | RO | 0x0000 (0dez)
801F:0 | Subindex | AI Vendor data Ch.2 | RW | 0x06 (6dez)
 | 801F:01 | R0 offset | RW | 0x0000 (0dez)
 | 801F:02 | R0 gain | RW | 0x4000 (16384dez)
 | 801F:03 | R1 offset | RW | 0x0000 (0dez)
 | 801F:04 | R1 gain | RW | 0x4000 (16384dez)
 | 801F:05 | R2 offset | RW | 0x0000 (0dez)
 | 801F:06 | R2 gain | RW | 0x4000 (16384dez)
8020:0 | Subindex | TACHO Settings Dual Shaft Mode Ch.1 | RW | 0x15 (21dez)
 | 8020:11 | No. of Targets | RW | 0x0001 (1dez)
 | 8020:12 | Input Signal Timeout | RW | 0x0064 (100dez)
 | 8020:15 | Presentation | RW | 0x0001 (1dez)
8030:0 | Subindex | TACHO Settings Dual Shaft Mode Ch.2 | RW | 0x15 (21dez)
 | 8030:11 | No. of Targets | RW | 0x0001 (1dez)
 | 8030:12 | Input Signal Timeout | RW | 0x0064 (100dez)
 | 8030:15 | Presentation | RW | 0x0001 (1dez)
8031:0 | Subindex | TACHO Settings Single Shaft Mode | RW | 0x15 (21dez)
 | 8031:0B | Enable Error Detection | RW | 0x01 (1dez)
 | 8031:0C | Reversion of Rotation | RW | 0x00 (0dez)
 | 8031:11 | No. of Targets | RW | 0x0001 (1dez)
 | 8031:12 | Input Signal Timeout | RW | 0x0064 (100dez)
 | 8031:15 | Presentation | RW | 0x0000 (0dez)
Index (hex) |  | Name | Flags | Default-Wert
8060:0 | Subindex | PWM Settings | RW | 0x22 (34dez)
 | 8060:03 | Enable dithering | RW | 0x00 (0dez)
 | 8060:04 | Invert polarity | RW | 0x00 (0dez)
 | 8060:05 | Watchdog | RW | 0x00 (0dez)
 | 8060:0B | Offset | RW | 0x0000 (0dez)
 | 8060:0C | Gain | RW | 0x00010000 (65536dez)
 | 8060:0D | Default output | RW | 0x0000 (0dez)
 | 8060:0E | Default output ramp | RW | 0xFFFF (65535dez)
 | 8060:10 | Max current [%] | RW | 0x64 (100dez)
 | 8060:12 | Kp factor | RW | 0x00FA (250dez)
 | 8060:13 | Ki factor | RW | 0x0004 (4dez)
 | 8060:14 | Kd factor | RW | 0x0032 (50dez)
 | 8060:1E | Dithering frequency [Hz] | RW | 0x0064 (100dez)
 | 8060:1F | Dithering amplitude [%] | RW | 0x0A (10dez)
 | 8060:21 | Select info data 1 | RW | 0x00 (0dez)
 | 8060:22 | Select info data 2 | RW | 0x00 (0dez)
806F:0 | Subindex | PWM Vendor data | RW | 0x02 (2dez)
 | 806F:01 | Offset | RW | 0x0000 (0dez)
 | 806F:02 | Gain | RW | 0x4000 (16384dez)
8070:0 | Subindex | AO Settings | RW | 0x16 (22dez)
 | 8070:01 | Enable user scale | RW | 0x00 (0dez)
 | 8070:02 | Presentation | RW | 0x00 (0dez)
 | 8070:05 | Watchdog | RW | 0x00 (0dez)
 | 8070:07 | Enable user calibration | RW | 0x00 (0dez)
 | 8070:08 | Enable vendor calibration | RW | 0x01 (1dez)
 | 8070:11 | User scale offset | RW | 0x0000 (0dez)
 | 8070:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8070:13 | Default output | RW | 0x0000 (0dez)
 | 8070:14 | Default output ramp | RW | 0xFFFF (65535dez)
 | 8070:15 | User calibration offset | RW | 0x0000 (0dez)
 | 8070:16 | User calibration gain | RW | 0x4000 (16384dez)
807E:0 | Subindex | AO Internal data | RO | 0x01 (1dez)
 | 807E:01 | DAC raw value | RO | 0x0000 (0dez)
807F:0 | Subindex | AO Vendor data | RW | 0x06 (6dez)
 | 807F:01 | R0 Calibration Offset | RW | 0x0000 (0dez)
 | 807F:02 | R0 Calibration Gain | RW | 0x4000 (16384dez)
 | 807F:03 | R1 Calibration Offset | RW | 0x0000 (0dez)
 | 807F:04 | R1 Calibration Gain | RW | 0x4000 (16384dez)
 | 807F:05 | R2 Calibration Offset | RW | 0x0000 (0dez)
 | 807F:06 | R2 Calibration Gain | RW | 0x4000 (16384dez)
A060:0 | Subindex | PWM Diag data | RO | 0x06 (6dez)
 | A060:02 | Overtemperature | RO | 0x00 (0dez)
 | A060:06 | Short circuit | RO | 0x00 (0dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0008 (8dez)
Index (hex) |  | Name | Flags | Default-Wert
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x08 (8dez)
 | F010:01 | SubIndex 001 | RW | 0x0000012C (300dez)
 | F010:02 | SubIndex 002 | RW | 0x0000012C (300dez)
 | F010:03 | SubIndex 003 | RW | 0x00000208 (520dez)
 | F010:04 | SubIndex 004 | RW | 0x00000208 (520dez)
 | F010:05 | SubIndex 005 | RW | 0x00000064 (100dez)
 | F010:06 | SubIndex 006 | RW | 0x000000C8 (200dez)
 | F010:07 | SubIndex 007 | RW | 0x000000FA (250dez)
 | F010:08 | SubIndex 008 | RW | 0x00000190 (400dez)
F800:0 | Subindex | AIAO Range settings | RW | 0x08 (8dez)
 | F800:01 | Input type Ch1 | RW | 0x0001 (1dez)
 | F800:02 | Input type Ch2 | RW | 0x0001 (1dez)
 | F800:08 | Output type | RW | 0x0001 (1dez)
F900:0 | Subindex | PWM Info data | RO | 0x02 (2dez)
 | F900:02 | Temperature [°C] | RO | 0x00 (0dez)
FB00:0 | Subindex | PWM Command | RO | 0x03 (3dez)
 | FB00:01 | Request | RW | {0}
 | FB00:02 | Status | RO | 0x00 (0dez)
 | FB00:03 | Response | RO | {0}
Legende
Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden


Objektbeschreibung und Parametrierung

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
Hinweis
Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Hinweis
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die zum regulären Betrieb z. B. durch ADS-Zugriff bestimmt sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
▪
Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Objekte zur Parametrierung bei der Inbetriebnahme
•
Objekte für den regulären Betrieb
•
Standardobjekte (0x1000-0x1FFF)
•
Profilspezifische Objekte (0x6000-0xFFFF)


Objekte zur Parametrierung bei der Inbetriebnahme

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] Objektbeschreibung und Parametrierung [image] Objekte zur Parametrierung bei der Inbetriebnahme
Objekte zur Parametrierung bei der Inbetriebnahme
Index 8000 AI Settings Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8000:0 | AI Settings | Maximaler Subindex |  | UINT8 | RO | 0x18 (24dez)
8000:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (Betragsvorzeichendarstellung)
8000:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x00 (0dez)
8000:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8000:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable user calibration | 1 | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Enable vendor calibration | 1 | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8000:11 | User scale offset | Offset der Anwender-Skalierung |  | INT16 | RW | 0x0000 (0dez)
8000:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8000:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8000:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8000:15 | Filter settings | Dieses Objekt bestimmt die digitalen Filtereinstellungen aller Kanäle des Moduls, wenn es über Enable filter (Index 0x80n0:06) aktiv ist. Die möglichen Einstellungen sind fortlaufend nummeriert. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8000:17 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8000:18 | User calibration gain | Anwenderabgleich: Gain |  | INT16 | RW | 0x4000 (16384dez)
Index 8000 AI Settings Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8010:0 | AI Settings | Maximaler Subindex |  | UINT8 | RO | 0x18 (24dez)
8010:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (Betragsvorzeichendarstellung)
8010:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x00 (0dez)
8010:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8010:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8010:0A | Enable user calibration | 1 | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8010:0B | Enable vendor calibration | 1 | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8010:11 | User scale offset | Offset der Anwender-Skalierung |  | INT16 | RW | 0x0000 (0dez)
8010:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8010:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8010:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8010:15 | Filter settings | Dieses Objekt bestimmt die digitalen Filtereinstellungen aller Kanäle des Moduls, wenn es über Enable filter (Index 0x80n0:06) aktiv ist. Die möglichen Einstellungen sind fortlaufend nummeriert. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8010:17 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8010:18 | User calibration gain | Anwenderabgleich: Gain |  | INT16 | RW | 0x4000 (16384dez)
Index 8020 TACHO Settings Dual Shaft Mode Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8020:0 | TACHO Settings Dual Shaft Mode Ch.1 |  | UINT8 | RO | 0x15 (21dez)
8020:11 | No. of Targets | Anzahl der "Nocken" auf der Welle/Achse | UINT16 | RW | 0x0001 (1dez)
8020:12 | Input Signal Timeout | nach x msec ohne Signalwechsel am Eingang wird das Prozessdatum <Speed Below Threshold> gesetzt. | UINT16 | RW | 0x0064 (100dez)
8020:15 | Presentation | Darstellung des Messwertes in RPM, Hz, ... | UINT16 | RW | 0x0001 (1dez)
Index 8030 TACHO Settings Dual Shaft Mode Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8030:0 | TACHO Settings Dual Shaft Mode Ch.2 |  | UINT8 | RO | 0x15 (21dez)
8030:11 | No. of Targets | Anzahl der "Nocken" auf der Welle/Achse | UINT16 | RW | 0x0001 (1dez)
8030:12 | Input Signal Timeout | nach x msec ohne Signalwechsel am Eingang wird das Prozessdatum <Speed Below Threshold> gesetzt. | UINT16 | RW | 0x0064 (100dez)
8030:15 | Presentation | Darstellung des Messwertes in RPM, Hz, ... | UINT16 | RW | 0x0001 (1dez)
Index 8031 TACHO Settings Single Shaft Mode
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8031:0 | TACHO Settings Single Shaft Mode |  | UINT8 | RO | 0x15 (21dez)
8031:0B | Enable Error Detection | Fehleranzeige aktivieren/deaktivieren | BOOLEAN | RW | 0x01 (1dez)
8031:0C | Reversion of Rotation | Umkehr der Drehrichtungsdarstellung in Rotation direction | BOOLEAN | RW | 0x00 (0dez)
8031:11 | No. of Targets | Anzahl der "Nocken" auf der Welle/Achse | UINT16 | RW | 0x0001 (1dez)
8031:12 | Input Signal Timeout | nach x msec ohne Signalwechsel am Eingang wird das Prozessdatum <Speed Below Threshold> gesetzt. | UINT16 | RW | 0x0064 (100dez)
8031:15 | Presentation | Darstellung des Messwertes in RPM, Hz, ... | UINT16 | RW | 0x0000 (0dez)
Index 8040 DIG Safe State Active
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8040:0 | DIG Safe State Active |  | UINT8 | RO | 0x08 (8dez)
8040:01 | X4 Pin4 | Aktivierung des Safe State Value bei Kommunikationsabbruch | BOOLEAN | RW | TRUE
8040:02 | X4 Pin2 | Aktivierung des Safe State Value bei Kommunikationsabbruch | BOOLEAN | RW | TRUE
8040:03 | X5 Pin4 | Aktivierung des Safe State Value bei Kommunikationsabbruch | BOOLEAN | RW | TRUE
8040:04 | X5 Pin2 | Aktivierung des Safe State Value bei Kommunikationsabbruch | BOOLEAN | RW | TRUE
8040:05 | X6 Pin4 | Aktivierung des Safe State Value bei Kommunikationsabbruch | BOOLEAN | RW | TRUE
8040:05 | X6 Pin2 | Aktivierung des Safe State Value bei Kommunikationsabbruch | BOOLEAN | RW | TRUE
8040:07 | X7 Pin4 | Aktivierung des Safe State Value bei Kommunikationsabbruch | BOOLEAN | RW | TRUE
8040:08 | X7 Pin2 | Aktivierung des Safe State Value bei Kommunikationsabbruch | BOOLEAN | RW | TRUE
Index 8041 DIG Safe State Value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8040:0 | DIG Safe State Value |  | UINT8 | RO | 0x00 (0dez)
8040:01 | X4 Pin4 | Wert des Ausgangs bei Kommunikationsabbruch | BOOLEAN | RW | False
8040:02 | X4 Pin2 | Wert des Ausgangs bei Kommunikationsabbruch | BOOLEAN | RW | False
8040:03 | X5 Pin4 | Wert des Ausgangs bei Kommunikationsabbruch | BOOLEAN | RW | False
8040:04 | X5 Pin2 | Wert des Ausgangs bei Kommunikationsabbruch | BOOLEAN | RW | False
8040:05 | X6 Pin4 | Wert des Ausgangs bei Kommunikationsabbruch | BOOLEAN | RW | False
8040:05 | X6 Pin2 | Wert des Ausgangs bei Kommunikationsabbruch | BOOLEAN | RW | False
8040:07 | X7 Pin4 | Wert des Ausgangs bei Kommunikationsabbruch | BOOLEAN | RW | False
8040:08 | X7 Pin2 | Wert des Ausgangs bei Kommunikationsabbruch | BOOLEAN | RW | False
Index 8043 DIG Safe State Delay
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8040:0 | DIG Safe State Delay |  | UINT8 | RO | 0x00 (0dez)
8040:01 | X4 Pin4 | Wartezeit nach Kommunikationsabbruch in msec | UINT16 | RW | False
8040:02 | X4 Pin2 | Wartezeit nach Kommunikationsabbruch in msec | UINT16 | RW | False
8040:03 | X5 Pin4 | Wartezeit nach Kommunikationsabbruch in msec | UINT16 | RW | False
8040:04 | X5 Pin2 | Wartezeit nach Kommunikationsabbruch in msec | UINT16 | RW | False
8040:05 | X6 Pin4 | Wartezeit nach Kommunikationsabbruch in msec | UINT16 | RW | False
8040:05 | X6 Pin2 | Wartezeit nach Kommunikationsabbruch in msec | UINT16 | RW | False
8040:07 | X7 Pin4 | Wartezeit nach Kommunikationsabbruch in msec | UINT16 | RW | False
8040:08 | X7 Pin2 | Wartezeit nach Kommunikationsabbruch in msec | UINT16 | RW | False
Index 8060 PWM Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8060:0 | PWM Settings | Maximaler Subindex | UINT8 | RO | 0x22 (34dez)
8060:03 | Enable dithering | Dithering wird "freigeschaltet", die Aktivierung erfolgt durch das Prozessdatum | BOOLEAN | RW | 0x00 (0dez)
8060:04 | Invert polarity | Stromrichtung umkehren | BOOLEAN | RW | 0x00 (0dez)
8060:05 | Watchdog | 0: Default watchdog value Der Defaultwert (0x8pp0:0D) ist aktiv. 1: Watchdog ramp aktiv Die Rampe (0x8pp0:0E) zum Fahren auf den Defaultwert (0x8pp0:0D) ist aktiv. 2: Last output value aktiv Das letzte Prozessdatum wird im Fehlerfall (Abfall des Watchdogs) ausgegeben. | BIT2 | RW | 0x00 (0dez)
8060:0B | Offset | Dies ist der Offset der Anwenderskalierung Skalierung: 1 = Nennstrom der Klemme / 1024 | INT16 | RW | 0x0000 (0dez)
8060:0C | Gain | Dies ist der Gain der Anwenderskalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2^-16. Der Wert eins entspricht 65536 (0x00010000). | INT32 | RW | 0x00010000 (65536dez)
8060:0D | Default output | Dies ist der Default Ausgabewert. Der Wert wird ausgegeben, wenn er über 0x8pp0:05 aktiviert ist. | INT16 | RW | 0x0000 (0dez)
8060:0E | Default output ramp | Dieser Wert legt die Rampen zum Herunterfahren auf den Defaultwert fest. Der Wert wird in Digits / ms vorgegeben. Ist der Eintrag z. B. 100 und der Defaultwert 0, so dauert es 327 ms (32767/100) bis der Ausgangswert im Fehlerfall vom Maximalwert (32767) auf den Defaultwert geht. | UINT16 | RW | 0xFFFF (65535dez)
8060:10 | Max current [%] | Maximaler Ausgangsstrom mA | UINT8 | RW | 0x64 (100dez)
8060:12 | Kp factor | Dies ist der Gain der Anwenderskalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2^-16. Der Wert eins entspricht 65535 (0x00010000). | UINT16 | RW | 0x00FA (250dez)
8060:13 | Ki factor | Dies ist der Default Ausgabewert | UINT16 | RW | 0x0004 (4dez)
8060:14 | Kd factor | Dieser Wert legt die Rampen zum Herunterfahren auf den Defaultwert fest. Der Wert wird in Digits / ms vorgegeben. Ist der Eintrag z .B. 100 und der Defaultwert 0, so dauert es 327 ms (32767/100) bis der Ausgangswert im Fehlerfall vom Maximalwert (32767) auf den Defaultwert geht. | UINT16 | RW | 0x0032 (50dez)
8060:1E | Dithering frequency [Hz] | Dither-Frequenz in Herz | UINT16 | RW | 0x0064 (100dez)
8060:1F | Dithering amplitude [%] | Dither-Amplitude in Prozent vom maximal zulässigen Strom (Nennstrom der Box * 0x8pp0:10) | UINT8 | RW | 0x0A (10dez)
8060:21 | Select info data 1 | Auswahl der synchronen Info Daten (s. 0x6pp0:11) | UINT8 | RW | 0x00 (0dez)
8060:22 | Select info data 2 | Auswahl der synchronen Info Daten (s. 0x6pp0:12) | UINT8 | RW | 0x00 (0dez)
Index 8070 AO Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8070:0 | AO Settings |  | UINT8 | RO | 0x16 (22dez)
8070:01 | Enable user scale | Mit diesem Eintrag wird die Skalierung wird 0x8pp0:11 und 0x8pp0:12 aktiviert. | BOOLEAN | RW | 0x00 (0dez)
8070:02 | Presentation | 0: Signed presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit signed Integer dargestellt. Bei unipolaren Klemmen (0-10 V oder 0-20 mA) wird der negative Bereich auf Null gesetzt. 1: Unsigned presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit unsigned Integer dargestellt. Negative Werte sind nicht möglich. 2: Absolute value with MSB as sign Betragsvorzeichendarstellung ist aktiv. 3: Absolute value Es wird der Absolutwert der signed Darstellung gebildet. | BIT3 | RW | 0x00 (0dez)
8070:05 | Watchdog | 0: Default watchdog value Der Defaultwert (0x8pp0:13) ist aktiv. 1: Watchdog ramp Die Rampe (0x8pp0:14) zum Fahren auf den Defaultwert ((0x8pp0:13)) ist aktiv. 2: Last output value Das letzte Prozessdatum wird im Fehlerfall (Abfall des Watchdogs) ausgegeben. | BIT2 | RW | 0x00 (0dez)
8070:07 | Enable user calibration | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8070:08 | Enable vendor calibration | Freigabe des Herstellerabgleichs | BOOLEAN | RW | 0x01 (1dez)
8070:11 | User scale offset | Dies ist der Offset der Anwenderskalierung | INT16 | RW | 0x0000 (0dez)
8070:12 | User scale gain | Dies ist der Gain der Anwenderskalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2^-16. Der Wert eins entspricht 65535 (0x00010000). | INT32 | RW | 0x00010000 (65536dez)
8070:13 | Default output | Dies ist der Default Ausgabewert | INT16 | RW | 0x0000 (0dez)
8070:14 | Default output ramp | Dieser Wert legt die Rampen zum Herunterfahren auf den Defaultwert fest. Der Wert wird in Digits / ms vorgegeben. Ist der Eintrag z. B. 100 und der Defaultwert 0, so dauert es 327 ms (32767/100) bis der Ausgangswert im Fehlerfall vom Maximalwert (32767) auf den Defaultwert geht. | UINT16 | RW | 0xFFFF (65535dez)
8070:15 | User calibration offset | Anwender Offset Abgleich | INT16 | RW | 0x0000 (0dez)
8070:16 | User calibration gain | Anwender Gain Abgleich | UINT16 | RW | 0x4000 (16384dez)
Index F800 AIAO Range settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F800:0 | AIAO Range settings |  | UINT8 | RO | 0x08 (8dez)
F800:01 | Input type Ch1 | Select input type for Ch1 | UINT16 | RW | 0x0001 (1dez)
F800:02 | Input type Ch2 | Select input type for Ch2 | UINT16 | RW | 0x0001 (1dez)
F800:08 | Output type | Select input type for Ch1 | UINT16 | RW | 0x0001 (1dez)


Objekte für den regulären Betrieb

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] Objektbeschreibung und Parametrierung [image] Objekte für den regulären Betrieb
Objekte für den regulären Betrieb
Die EP8309 verfügt über keine solchen Objekte.


Standardobjekte (0x1000-0x1FFF)

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] Objektbeschreibung und Parametrierung [image] Standardobjekte (0x1000-0x1FFF)
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Low-Word enthält das verwendete CoE Profil (5001). Das High-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP8309-1022
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 02
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x20754052 (544555090dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00110016 (1114134dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1402 PWM RxPDO-Par Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1402:0 | PWM RxPDO-Par Control | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1402:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 3 übertragen werden dürfen | OCTET-STRING[2] | RO | 03 16
Index 1403 AO RxPDO-Par Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | AO RxPDO-Par Outputs | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 02 16
Index 1600 TACHO RxPDO-Map OutputsCh.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | TACHO RxPDO-Map OutputsCh.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x03 (3dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (PWM Outputs Ch.1), entry 0x01 (Enable dithering)) | UINT32 | RO | 0x0000:00, 8
1600:02 | SubIndex 002 | 2. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x7020:09, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (PWM Outputs Ch.1), entry 0x06 (Enable)) | UINT32 | RO | 0x0000:00, 7
Index 1601 DO RxPDO-Map Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | DO RxPDO-Map Outputs | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (PWM Outputs Ch.2), entry 0x01 (Enable dithering)) | UINT32 | RO | 0x7050:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x7050:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (PWM Outputs Ch.2), entry 0x06 (Enable)) | UINT32 | RO | 0x7050:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7050 (DO Outputs), entry 0x04 (Digital Output X6 Pin2)) | UINT32 | RO | 0x7050:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7050 (DO Outputs), entry 0x05 (Digital Output X7 Pin4)) | UINT32 | RO | 0x7050:05, 1
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7050 (DO Outputs), entry 0x06 (Digital Output X7 Pin2)) | UINT32 | RO | 0x7050:06, 1
1601:07 | SubIndex 007 | 7. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
Index 1602 PWM RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | PWM RxPDO-Map Control | PDO Mapping RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (DO Outputs), entry 0x01 (Output 10)) | UINT32 | RO | 0x7060:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7040 (DO Outputs), entry 0x02 (Output 11)) | UINT32 | RO | 0x0000:00, 4
1602:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x7060:06, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x7060:07, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7050 (DO Outputs), entry 0x0E (Output 14)) | UINT32 | RO | 0x0000:00, 9
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7050 (DO Outputs), entry 0x0F (Output 15)) | UINT32 | RO | 0x7060:11, 16
Index 1603 AO RxPDO-Map Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | AO RxPDO-Map Outputs | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7060 (AO Outputs Ch.3), entry 0x11 (Analog output)) | UINT32 | RO | 0x7070:11, 16
Index 1802 TACHO TxPDO-Par Single Shaft Mode Input Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | TACHO TxPDO-Par Single Shaft Mode Input Ch.1 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[4] | RO | 03 1A 04 1A
Index 1803 TACHO TxPDO-Par Dual Shaft Mode Input Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | TACHO TxPDO-Par Dual Shaft Mode Input Ch.1 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[4] | RO | 02 1A 00 00
Index 1804 TACHO TxPDO-Par Dual Shaft Mode Input Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | TACHO TxPDO-Par Dual Shaft Mode Input Ch.2 | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[4] | RO | 02 1A 00 00
Index 1A00 AI TxPDO-Map Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | AI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0A (10dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 AI TxPDO-Map Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | AI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0A (10dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A02 TACHO TxPDO-Map Single Shaft Mode Input Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | TACHO TxPDO-Map Single Shaft Mode Input Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0C (12dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RO | 0x0000:00, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x02 (Track Error A)) | UINT32 | RO | 0x6037:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x03 (Input Status Track A)) | UINT32 | RO | 0x6037:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x04 (Track Error B)) | UINT32 | RO | 0x6037:04, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x05 (Input Status Track B)) | UINT32 | RO | 0x6037:05, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 3
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x0C (Speed Below Threshold)) | UINT32 | RO | 0x0000:00, 3
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x6037:0C, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x0000:00, 3
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x6037:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6027 (TACHO Single Shaft Mode Input), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x6037:11, 16
1A02:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6027 (TACHO Single Shaft Mode Input), entry 0x12 (Rotation Direction)) | UINT32 | RO | 0x6037:12, 16
Index 1A03 TACHO TxPDO-Map Dual Shaft Mode Input Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | TACHO TxPDO-Map Dual Shaft Mode Input Ch.1 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x09 (9dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x02 (Overrange)) | UINT32 | RO | 0x0000:00, 2
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x03 (Limit 1)) | UINT32 | RO | 0x0000:00, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x05 (Limit 2)) | UINT32 | RO | 0x0000:00, 4
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RO | 0x0000:00, 3
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x6020:0C, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (TACHO Dual Shaft Mode Input Ch.1), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x0000:00, 3
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (TACHO Dual Shaft Mode Input Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (TACHO Dual Shaft Mode Input Ch.1), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x6020:11, 16
Index 1A04 TACHO TxPDO-Map Dual Shaft Mode Input Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | TACHO TxPDO-Map Dual Shaft Mode Input Ch.2 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x09 (9dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x01 (Digital input 1)) | UINT32 | RO | 0x6030:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 2
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x05 (Ready to enable)) | UINT32 | RO | 0x0000:00, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x06 (Warning)) | UINT32 | RO | 0x0000:00, 4
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x0000:00, 3
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x6030:0C, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (TACHO Dual Shaft Mode Input Ch.2), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x0000:00, 3
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (TACHO Dual Shaft Mode Input Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6030 (TACHO Dual Shaft Mode Input Ch.2), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x6030:11, 16
Index 1A05 DI TxPDO-Map Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | DI TxPDO-Map Inputs | PDO Mapping TxPDO 6 | UINT8 | RO | 0x07 (7dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x01 (Digital input 1)) | UINT32 | RO | 0x6040:01, 1
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x6040:02, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x05 (Ready to enable)) | UINT32 | RO | 0x6040:03, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x06 (Warning)) | UINT32 | RO | 0x6040:04, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6040:05, 1
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x6040:06, 1
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x0000:00, 10
Index 1A06 PWM TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | PWM TxPDO-Map Status | PDO Mapping TxPDO 7 | UINT8 | RO | 0x08 (8dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x01 (Digital Input X4 Pin4)) | UINT32 | RO | 0x0000:00, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x02 (Digital Input X4 Pin2)) | UINT32 | RO | 0x0000:00, 3
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x03 (Digital Input X6 Pin4)) | UINT32 | RO | 0x6060:05, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x04 (Digital Input X6 Pin2)) | UINT32 | RO | 0x6060:06, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x05 (Digital Input X7 Pin4)) | UINT32 | RO | 0x6060:07, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x06 (Digital Input X7 Pin2)) | UINT32 | RO | 0x0000:00, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 7
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6060 (PWM Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6060:10, 1
Index 1A07 PWM TxPDO-Map Synchron info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | PWM TxPDO-Map Synchron info data | PDO Mapping TxPDO 8 | UINT8 | RO | 0x02 (2dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6060 (PWM Inputs), entry 0x01 (Digital input 1)) | UINT32 | RO | 0x6060:11, 16
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x6060:12, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:04 | Subindex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A05 (6661dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A06 (6662dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0007A120 (500000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x0007A120 (500000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)


Profilspezifische Objekte (0x6000-0xFFFF)

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] Objektbeschreibung und Parametrierung [image] Profilspezifische Objekte (0x6000-0xFFFF)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000 AI Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | AI Inputs Ch.1 |  | UINT8 | RO | 0x11 (17dez)
6000:01 | Underrange | Underrange event active | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Overrange | Overrange event active | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Limit 1 | Bit0: Value greater than Limit1 Bit1: Value smaller than Limit1 | BIT2 | RO | 0x00 (0dez)
6000:05 | Limit 2 | Bit0: Value greater than Limit2 Bit1: Value smaller than Limit2 | BIT2 | RO | 0x00 (0dez)
6000:07 | Error | Bit set when Over- or Underrange | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error |  | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Value |  | INT16 | RO | 0x0000 (0dez)
Index 6010 AI Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | AI Inputs Ch.2 |  | UINT8 | RO | 0x11 (17dez)
6010:01 | Underrange | Underrange event active | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Overrange | Overrange event active | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Limit 1 | Bit0: Value greater than Limit1 Bit1: Value smaller than Limit1 | BIT2 | RO | 0x00 (0dez)
6010:05 | Limit 2 | Bit0: Value greater than Limit2 Bit1: Value smaller than Limit2 | BIT2 | RO | 0x00 (0dez)
6010:07 | Error | Bit set when Over- or Underrange | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error |  | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Value |  | INT16 | RO | 0x0000 (0dez)
Index 6020 TACHO Dual Shaft Mode Input Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | TACHO Dual Shaft Mode Input Ch.1 |  | UINT8 | RO | 0x11 (17dez)
6020:01 | Digital Input |  | BOOLEAN | RO | 0x00 (0dez)
6020:0C | Speed Below Threshold |  | BOOLEAN | RO | 0x00 (0dez)
6020:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Rotational Speed |  | INT16 | RO | 0x0000 (0dez)
Index 6030 TACHO Dual Shaft Mode Input Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6030:0 | TACHO Dual Shaft Mode Input Ch.2 |  | UINT8 | RO | 0x11 (17dez)
6030:01 | Digital Input |  | BOOLEAN | RO | 0x00 (0dez)
6030:0C | Speed Below Threshold |  | BOOLEAN | RO | 0x00 (0dez)
6030:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6030:11 | Rotational Speed |  | INT16 | RO | 0x0000 (0dez)
Index 6037 TACHO Single Shaft Mode Input
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6037:0 | TACHO Single Shaft Mode Input |  | UINT8 | RO | 0x12 (18dez)
6037:02 | Error Input A |  | BOOLEAN | RO | 0x00 (0dez)
6037:03 | Input Status A |  | BOOLEAN | RO | 0x00 (0dez)
6037:04 | Error Input B |  | BOOLEAN | RO | 0x00 (0dez)
6037:05 | Input Status B |  | BOOLEAN | RO | 0x00 (0dez)
6037:0C | Speed Below Threshold |  | BOOLEAN | RO | 0x00 (0dez)
6037:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6037:11 | Rotational Speed |  | INT16 | RO | 0x0000 (0dez)
6037:12 | Rotation Direction |  | UINT16 | RO | 0x0000 (0dez)
Index 6040 DI Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6040:0 | DI Inputs |  | UINT8 | RO | 0x06 (6dez)
6040:01 | Digital Input X4 Pin4 |  | BOOLEAN | RO | 0x00 (0dez)
6040:02 | Digital Input X4 Pin2 |  | BOOLEAN | RO | 0x00 (0dez)
6040:03 | Digital Input X6 Pin4 |  | BOOLEAN | RO | 0x00 (0dez)
6040:04 | Digital Input X6 Pin2 |  | BOOLEAN | RO | 0x00 (0dez)
6040:05 | Digital Input X7 Pin4 |  | BOOLEAN | RO | 0x00 (0dez)
6040:06 | Digital Input X7 Pin2 |  | BOOLEAN | RO | 0x00 (0dez)
Index 6060 PWM Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6060:0 | PWM Inputs |  | UINT8 | RO | 0x12 (18dez)
6060:05 | Ready to enable |  | BOOLEAN | RO | 0x00 (0dez)
6060:06 | Warning |  | BOOLEAN | RO | 0x00 (0dez)
6060:07 | Error |  | BOOLEAN | RO | 0x00 (0dez)
6060:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6060:11 | Info data 1 |  | INT16 | RO | 0x0000 (0dez)
6060:12 | Info data 2 |  | INT16 | RO | 0x0000 (0dez)
Index 7020 TACHO Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | TACHO Outputs |  | UINT8 | RO | 0x09 (9dez)
7020:09 | Reset Error |  | BOOLEAN | RO | 0x00 (0dez)
Index 7030 TACHO Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7030:0 | TACHO Outputs |  | UINT8 | RO | 0x09 (9dez)
7030:09 | Reset Error |  | BOOLEAN | RO | 0x00 (0dez)
Index 7040 DIG Output
Index (hex) | Output 11>Name | Bedeutung | Datentyp | Flags | Default
7050:0 | DIG Outputs |  | UINT8 | RO | 0x06 (6dez)
7050:01 | Digital Output X4 Pin4 |  | BOOLEAN | RO | 0x00 (0dez)
7050:02 | Digital Output X4 Pin2 |  | BOOLEAN | RO | 0x00 (0dez)
7050:03 | Digital Output X5 Pin4 |  | BOOLEAN | RO | 0x00 (0dez)
7050:04 | Digital Output X5 Pin2 |  | BOOLEAN | RO | 0x00 (0dez)
7050:05 | Digital Output X6 Pin4 |  | BOOLEAN | RO | 0x00 (0dez)
7050:06 | Digital Output X6 Pin2 |  | BOOLEAN | RO | 0x00 (0dez)
7050:07 | Digital Output X7 Pin4 |  | BOOLEAN | RO | 0x00 (0dez)
7050:08 | Digital Output X7 Pin2 |  | BOOLEAN | RO | 0x00 (0dez)
Index 7060 PWM Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7060:0 | PWM Outputs |  | UINT8 | RO | 0x11 (17dez)
7060:01 | Enable dithering |  | BOOLEAN | RO | 0x00 (0dez)
7060:06 | Enable |  | BOOLEAN | RO | 0x00 (0dez)
7060:07 | Reset |  | BOOLEAN | RO | 0x00 (0dez)
7060:11 | PWM output | Das analoge Ausgangsdatum | INT16 | RO | 0x0000 (0dez)
Index 7070 AO Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7070:0 | AO Outputs |  | UINT8 | RO | 0x11 (17dez)
7070:11 | Analog output | Das analoge Ausgangsdatum | INT16 | RO | 0x0000 (0dez)
Index 800E AI Internal data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800E:0 | AI Internal data Ch.1 |  | UINT8 | RO | 0x01 (1dez)
800E:01 | ADC raw value |  | INT16 | RO | 0x0000 (0dez)
Index 800F AI Vendor data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800F:0 | AI Vendor data Ch.1 |  | UINT8 | RO | 0x06 (6dez)
800F:01 | R0 offset |  | INT16 | RW | 0x0000 (0dez)
800F:02 | R0 gain |  | INT16 | RW | 0x4000 (16384dez)
800F:03 | R1 offset |  | INT16 | RW | 0x0000 (0dez)
800F:04 | R1 gain |  | INT16 | RW | 0x4000 (16384dez)
800F:05 | R2 offset |  | INT16 | RW | 0x0000 (0dez)
800F:06 | R2 gain |  | INT16 | RW | 0x4000 (16384dez)
Index 801E AI Internal data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801E:0 | AI Internal data Ch.2 |  | UINT8 | RO | 0x01 (1dez)
801E:01 | ADC raw value |  | INT16 | RO | 0x0000 (0dez)
Index 801F AI Vendor data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801F:0 | AI Vendor data Ch.2 |  | UINT8 | RO | 0x06 (6dez)
801F:01 | R0 offset |  | INT16 | RW | 0x0000 (0dez)
801F:02 | R0 gain |  | INT16 | RW | 0x4000 (16384dez)
801F:03 | R1 offset |  | INT16 | RW | 0x0000 (0dez)
801F:04 | R1 gain |  | INT16 | RW | 0x4000 (16384dez)
801F:05 | R2 offset |  | INT16 | RW | 0x0000 (0dez)
801F:06 | R2 gain |  | INT16 | RW | 0x4000 (16384dez)
Index 806F PWM Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
806F:0 | PWM Vendor data |  | UINT8 | RO | 0x02 (2dez)
806F:01 | Offset | Herstellerabgleich für +/-10V | INT16 | RW | 0x0000 (0dez)
806F:02 | Gain | Herstellerabgleich für +/-10V | INT16 | RW | 0x4000 (16384dez)
Index 807E AO Internal data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
807E:0 | AO Internal data |  | UINT8 | RO | 0x01 (1dez)
807E:01 | DAC raw value | Dies ist der DAC Rohwert. | UINT16 | RO | 0x0000 (0dez)
Index 807F AO Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
807F:0 | AO Vendor data |  | UINT8 | RO | 0x06 (6dez)
807F:01 | R0 Calibration Offset | Herstellerabgleich für +/-10 V | INT16 | RW | 0x0000 (0dez)
807F:02 | R0 Calibration Gain | Herstellerabgleich für +/-10 V | UINT16 | RW | 0x4000 (16384dez)
807F:03 | R1 Calibration Offset | Herstellerabgleich für 0-20 mA | INT16 | RW | 0x0000 (0dez)
807F:04 | R1 Calibration Gain | Herstellerabgleich für 0-20 mA | UINT16 | RW | 0x4000 (16384dez)
807F:05 | R2 Calibration Offset | Herstellerabgleich für 4-20 mA | INT16 | RW | 0x0000 (0dez)
807F:06 | R2 Calibration Gain | Herstellerabgleich für 4-20 mA | UINT16 | RW | 0x4000 (16384dez)
Index A060 PWM Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A060:0 | PWM Diag data |  | UINT8 | RO | 0x06 (6dez)
A060:02 | Overtemperature |  | BOOLEAN | RO | 0x00 (0dez)
A060:06 | Short circuit |  | BOOLEAN | RO | 0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0008 (8dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x08 (8dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000208 (520dez)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x00000208 (520dez)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x00000064 (100dez)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x000000C8 (200dez)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x000000FA (250dez)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x00000190 (400dez)
Index F900 PWM Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | PWM Info data |  | UINT8 | RO | 0x02 (2dez)
F900:02 | Temperature [°C] |  | UINT8 | RO | 0x00 (0dez)
Index FB00 PWM Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | PWM Command |  | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request |  | OCTET-STRING[2] | RW | {0}
FB00:02 | Status |  | UINT8 | RO | 0x00 (0dez)
FB00:03 | Response |  | OCTET-STRING[4] | RO | {0}


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme und Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den EPPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Hinweis
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Diagnose

Diagnose
Diagnose
Das Modul bietet dem Anwender verschiedene Diagnosemöglichkeiten. Diese Meldungen sind in Hardware-Warnungen und Hardware-Fehler unterteilt. In den jeweiligen Status-Wörtern der Kanäle (außer digitale Ein-/Ausgänge) existiert je ein Bit für Warnungen und Fehler. Die genaue Ursache wird über die Diagnostikdaten (0xA050) ausgewertet. Warnungen werden selbsttätig zurückgenommen. Fehler können zum Abschalten der Ausgangsendstufe führen (PWMi) und müssen anschließend im Control-Word (0x7050:07 Reset) quittiert werden
Fehler/Warnung der PWM-Stufe
Index (hex) | Warnung | Bedeutung
A050:02 | Overtemperature | ab 100°C
A050:06 | Short circuit | Es ist ein Überstrom/Kurzschluss von mehr als 105% des Nennstromes für mehr als 200 ms aufgetreten
Steuer- (Us) und Peripheriespannung (Up) der EP8309
Diagnose - Steuer- (Us) und Peripheriespannung (Up) der EP8309
Prozessdatum DEV Input | Bedeutung
Undervoltage Us | Warnung unterhalb 18 VDC
Undervoltage Up | Warnung unterhalb 18 VDC


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Firmware Update EL/ES/EM/EPxxxx
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus/EtherCAT Box und den verwendeten Metallteilen. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Firmware Update EL/ES/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Achtung
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Achtung
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Hinweis
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt im Config/FreeRun-Mode das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Hinweis
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
Hinweis
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
Hinweis
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Achtung
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Hinweis
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter www.beckhoff.de.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.