EP7211 - Servomotormodul mit OCT
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
1.1
▪
Variante -9034 entfernt
1.0
▪
Erste Veröffentlichung
0.4
▪
Vorläufige Version
0.3
▪
Aktualisierungen
0.2
▪
Technische Daten aktualisiert
0.1
▪
Erster Entwurf
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer)
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code enthält zusätzliche Informationen über den Auslieferungszustand des Moduls: Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC).


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT Box - Einführung
•
EP7211-0034 - Einführung
•
Technische Daten
•
Lieferumfang
•
Technologie


EtherCAT Box - Einführung

Produktübersicht [image] EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
XML-Dateien
XML -Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


EP7211-0034 - Einführung

Produktübersicht [image] EP7211-0034 - Einführung
EP7211-0034 - Einführung
EP7211-0034
Die EtherCAT Box EP7211-0034 ist ein einkanaliger Servoverstärker für Synchron-Servomotoren mit OCT-Feedbacksystem.
Sie ist vorgesehen für den Betrieb mit Motoren der Baureihe AM81xx. Diese Motoren haben ein elektronisches Typenschild. EP7211-0034 kann das elektronische Typenschild auslesen, um die Motor-Parameter in TwinCAT automatisch einzustellen.
Prozess-seitige Schnittstellen von EP7211-0034:
▪
Motor
▪
Motorbremse
▪
OCT-Kommunikation:
–
Feedback
–
Auslesen des elektronischen Typenschilds
▪
2 x Touch Probe
▪
Hardware-Enable: digitaler Eingang zum Aktivieren der Endstufe
Der Motor wird über ein Hybrid-Kabel angeschlossen. Das Hybrid-Kabel beinhaltet die Leitungen für die Motorphasen, für die Bremse und für die OCT-Kommunikation.
EP7211-0034 kann wahlweise über die Antriebsprofile MDP742 oder DS402 gesteuert werden.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten
EP7211-0034
Feldbus
Feldbus
EtherCAT
Anschluss
2 x M8 Buchse (grün)
Potenzialtrennung
500 V (Feldbus / IO)
Distributed clocks
Ja
Prozessabbild
Abhängig von der Betriebsart
Versorgung
Anschluss
Einspeisung: 1 x 7/8" Stecker, 5-polig
Weiterleitung: 1 x 7/8" Buchse, 5-polig
Steuerspannung US
24 VDC (-15 % / +20 %)
Zwischenkreis-Versorgungsspannung UP
48 VDC (8 .. 50 VDC), nicht verpolungssicher
Versorgung der Modulelektronik
aus der Steuerspannung US
Stromaufnahme der Modulelektronik
typ. 120 mA
Stromaufnahme aus der
Zwischenkreis-Versorgungsspannung
typ. 50 mA
Motor
Motor-Art
Synchron-Servomotor
Anschluss
1 x iTec-Buchse, 9-polig, M23
Hybrid-Steckverbinder für:
▪
1 x Motor
▪
1 x Feedback (OCT-Geber)
▪
1 x Bremse
Nennleistung Pn
max. 276 W
Ausgangs-Nennstrom In
4,5 Aeff
Ausgangs-Spitzenstrom Ipeak
9,0 Aeff für 1 s
Ausgangs-Frequenzbereich
0 .. 599 Hz
PWM-Taktfrequenz
16 kHz
Stromreglerfrequenz
32 kHz
Drehzahlreglerfrequenz
16 kHz
Antriebsprofil
Wahlweise:
▪
MDP 742 (default)
▪
CiA DS402
Motorbremse
Ausgangsspannung
24 VDC aus der Steuerspannung US
Ausgangsstrom
max. 0,5 A, kurzschlussgeschützt
Digitale Eingänge
Schnittstellen
2 x Touch Probe
1 x Hardware-Enable
Technische Daten | EP7211-0034
Umgebungsbedingungen
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
EMV-Kategorie | Kategorie C3 (Zusatzfilter erforderlich) Kategorie C2, C1 in Vorbereitung (Zusatzfilter erforderlich)
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Mechanik
Abmessungen | 150 mm x 60 mm x 26,5 mm (ohne Steckverbinder)
Gewicht | ca. 500 g
Einbaulage | beliebig
Zulassungen und Konformität
Zulassungen | CE, UL in Vorbereitung


Lieferumfang

Produktübersicht [image] Lieferumfang
Lieferumfang
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EtherCAT Box EP7211-0034
▪
2x Schutzkappe für EtherCAT- Buchse (montiert)
▪
1x Schutzkappe für 7/8"- Buchse (montiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
Vormontierte Schutzkappen gewährleisten keinen IP67-Schutz
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Stellen Sie den korrekten Sitz der Schutzkappen sicher, um die Schutzart IP67 zu gewährleisten.


Technologie

Produktübersicht [image] Technologie
Technologie
Servomotor
Der Servomotor ist ein elektrischer Motor. Zusammen mit einem Servoverstärker bildet der Servomotor einen Servoantrieb. Der Servomotor wird in einem geschlossenen Regelkreis positions-, moment- oder geschwindigkeitsgeregelt betrieben.
EP7211-0034 unterstützt die Ansteuerung von permanenterregten Synchronmotoren. Diese bestehen aus drei um 120° verschobenen Spulen und einen permanenterregten Rotor.
Drei um 120° verschobenen Spulen eines Synchronmotors
Die One Cable Technology (OCT)
Bei den Servomotoren der Serie AM8100-xF2 x erfolgt die Übertragung der Feedback-Signale direkt über die Leitung zur Spannungsversorgung, sodass Power und Feedbacksystem in einem Motoranschlusskabel zusammengefasst sind. Durch die One Cable Technology werden die Informationen störsicher und zuverlässig über eine digitale Schnittstelle übertragen. Da sowohl motor- als auch reglerseitig Kabel und Steckverbinder entfallen, werden die Komponenten- und Inbetriebnahmekosten reduziert.
Thermisches Motormodell I²T
Das thermische I²T Motormodell bildet das thermische Verhalten der Motorwicklung unter Berücksichtigung des absoluten Wärmewiderstands Rth und der Wärmekapazität Cth des Motors und der Statorwicklung ab.
Im Modell wird angenommen, dass der Motor bei Dauerbetrieb mit Nennstrom Inenn seine maximale Dauerbetriebstemperatur Tnenn erreicht. Diese Temperatur entspricht einer Auslastung des Motors von 100%. Bei Betrieb mit Nennstrom erreicht das Motormodell nach einer Zeit von τth=Rth∙Cth eine Auslastung von 63% und erreicht langsam seine Dauerbetriebstemperatur.
Wird der Motor mit einem Strom größer dem Nennstrom betrieben, erreicht das Modell eine Auslastung von 100% schneller.
Überschreitet die Auslastung des I²T Modells den Wert von 100%, wird der angeforderte Sollstrom auf den Nennstrom limitiert, um die Motorwicklung thermisch zu schützen. Die Auslastung fällt auf maximal 100% zurück. Bei Unterschreiten des Nennstroms fällt die Auslastung auf unter 100% und die Limitierung des Sollstroms wird aufgehoben.
Bei einem vorher auf Umgebungstemperatur abgekühlten Motor kann die Zeit zum Erreichen von 100% Auslastung bei Bestromung mit einem Sollstrom größer als Nennstrom grob mit τth∙Inenn²/Iist² abgeschätzt werden.
Die exakte Berechnung des Durchtritts von 100% Auslastung erfordert die Kenntnis der aktuellen Auslastung.
Limitierung auf den Nennstroms des Motors


Montage und Verkabelung

Montage und Verkabelung
Montage und Verkabelung
Weiterführende Informationen
•
Montage
•
Verkabelung


Montage

Montage und Verkabelung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Funktionserdung (FE)


Abmessungen

Montage und Verkabelung [image] Montage [image] Abmessungen
Abmessungen
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 16 A bei 40°C (gemäß IEC 60512-3)
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 150 x 60 x 26,5 mm (ohne Steckverbinder)


Befestigung

Montage und Verkabelung [image] Montage [image] Befestigung
Befestigung
Hinweis
Anschlüsse vor Verschmutzung schützen!
Die Schutzart IP67 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind.
Schützen Sie die Anschlüsse bei der Montage vor Verschmutzung.
Montieren Sie das Modul mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern.


Funktionserdung (FE)

Montage und Verkabelung [image] Montage [image] Funktionserdung (FE)
Funktionserdung (FE)
Alle vorhandenen Anschlüsse für die Funktionserdung müssen mit Erde verbunden werden:
▪
Befestigungslöcher
▪
„FE“-Adern in den Zuleitungen
Funktionserdung über die Befestigungslöcher
Die Befestigungslöcher dienen gleichzeitig als Anschlüsse für die Funktionserdung (FE).
Stellen Sie sicher, dass die Box über beide Befestigungsschrauben niederimpedant geerdet ist.
FE-Anschluss über Befestigungslöcher
Funktionserdung über die Befestigungslöcher
Funktionserdung über die Zuleitungen
Die mit „FE“ bezeichneten Pins der Versorgungs-Steckverbinder sind direkt mit dem Funktionserde-Potential der Befestigungslöcher verbunden.
Führen Sie die Funktionserdung der Adern „FE“ gemäß den folgenden Hinweisen aus:
▪
Wenn die Gegenstelle ein Gerät mit 7/8 "-Steckverbinder ist: verbinden Sie die Geräte mit einer konfektionierten Leitung. Mögliche Typen von konfektionierten Leitungen:
–
Beckhoff ZK2030-1112-0xxx
–
Beckhoff ZK2030-1114-0xxx
–
Beckhoff ZK2030-1314-0xxx
▪
Ansonsten: Erden Sie die Ader „FE“ niederimpedant möglichst nahe an der Gegenstelle.


Verkabelung

Montage und Verkabelung [image] Verkabelung
Verkabelung
Steckverbinder-Übersicht
Name | Steckverbinder- Typ | Anzugs- Drehmoment | Funktion
X01 | M12 | 0,6 Nm 1) | Hardware Enable HWE
X02
X03 | M12 | 0,6 Nm 1) | Touch Probe
X04
X20 | iTec M23 | - | Motor, Bremse und Feedbacksystem
X40 | M8 | 0,4 Nm 1) | EtherCAT
X41
X60 | 7/8 " | 1,5 Nm | Spannungsversorgung
X61
1) Montieren Sie Stecker an diesen Steckverbindern mit einem Drehmomentschlüssel; z.B. ZB8801 von Beckhoff.
Schutzkappen
▪
Verschließen Sie nicht benutzte Steckverbinder mit Schutzkappen.
▪
Stellen Sie den korrekten Sitz von vormontierten Schutzkappen sicher.
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u. U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Weiterführende Informationen
•
Spannungsversorgung
•
EtherCAT
•
Motor, Bremse und Feedbacksystem
•
Hardware Enable HWE
•
Touch Probe


Spannungsversorgung

Montage und Verkabelung [image] Verkabelung [image] Spannungsversorgung
Spannungsversorgung
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungsverluste


Steckverbinder

Montage und Verkabelung [image] Verkabelung [image] Spannungsversorgung [image] Steckverbinder
Steckverbinder
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei 7/8 " - Steckverbinder am unteren Ende der Module:
▪
„IN“ (male): linker Steckverbinder zur Einspeisung der Versorgungsspannungen
▪
„OUT“ (female): rechter Steckverbinder zur Weiterleitung der Versorgungsspannungen
7/8 Zoll In+Out Kontaktbelegung
7/8 " - Steckverbinder Pinbelegung
Hinweis Defekt durch Verpolung möglich. Der Eingang für die Zwischenkreisspannung Up ist nicht verpolungssicher. Achten Sie auf korrekte Polung.
Pin | Name | Kommentar | Aderfarben 1)
1 | GNDP | GND zu UP | Schwarz
2 | GNDS | GND zu US | Blau
3 | FE | Funktionserde | Grau
4 | +24 VDC US | Steuerspannung US | Braun
5 | +48 VDC UP | Zwischenkreisspannung UP | Weiß
1) Die Aderfarben gelten für Leitungen vom Typ: Beckhoff ZK203x-xxxx.


Status-LEDs

Montage und Verkabelung [image] Verkabelung [image] Spannungsversorgung [image] Status-LEDs
Status-LEDs
Der Status der Versorgungsspannungen wird durch zwei LEDs signalisiert. Eine Status-LED leuchtet grün, wenn die jeweilige Versorgungsspannung am Steckverbinder für die Einspeisung anliegt.
Spannungsversorgung Status-LEDs


Leitungsverluste

Montage und Verkabelung [image] Verkabelung [image] Spannungsversorgung [image] Leitungsverluste
Leitungsverluste
Beachten Sie bei der Planung einer Anlage den Spannungsabfall an der Versorgungs-Zuleitung. Vermeiden Sie, dass der Spannungsabfall so hoch wird, dass die Versorgungsspannungen an der Box die minimale Nennspannung unterschreiten.
Berücksichtigen Sie auch Spannungsschwankungen des Netzteils.
Spannungsabfall an der Versorgungs-Zuleitung
Leitungsverluste 7/8" 2A
Leitungsverluste 7/8" 4A


EtherCAT

Montage und Verkabelung [image] Verkabelung [image] EtherCAT
EtherCAT
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs


Steckverbinder

Montage und Verkabelung [image] Verkabelung [image] EtherCAT [image] Steckverbinder
Steckverbinder
Für den ankommenden und weiterführenden EtherCAT-Anschluss haben EtherCAT-Box-Module zwei grüne M8-Buchsen.
EtherCAT Steckverbinder
Kontaktbelegung
M8-Buchse 4polig Kontaktbelegung
M8-Buchse
EtherCAT | M8- Steckverbinder | Aderfarben
Signal | Kontakt | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | gelb1) | orange/weiß | weiß/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | weiß1) | blau/weiß | weiß/grün
Rx - | 3 | blau1) | blau | grün
Shield | Gehäuse | Schirm | Schirm | Schirm
1) Aderfarben nach EN 61918
Anpassung der Aderfarben für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx
Zur Vereinheitlichung wurden die Aderfarben der Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx auf die Aderfarben der EN61918 umgestellt: gelb, orange, weiß, blau. Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften der Leitungen sind bei der Umstellung der Aderfarben erhalten geblieben.


Status-LEDs

Montage und Verkabelung [image] Verkabelung [image] EtherCAT [image] Status-LEDs
Status-LEDs
EtherCAT Status-LEDs
L/A (Link/Act)
Neben jeder EtherCAT-Buchse befindet sich eine grüne LED, die mit „L/A“ beschriftet ist. Die LED signalisiert den Kommunikationsstatus der jeweiligen Buchse:
LED | Bedeutung
aus | keine Verbindung zum angeschlossenen EtherCAT-Gerät
leuchtet | LINK: Verbindung zum angeschlossenen EtherCAT-Gerät
blinkt | ACT: Kommunikation mit dem angeschlossenen EtherCAT-Gerät
Run
Jeder EtherCAT-Slave hat eine grüne LED, die mit „Run“ beschriftet ist. Die LED signalisiert den Status des Slaves im EtherCAT-Netzwerk:
LED | Bedeutung
aus | Slave ist im Status „Init“
blinkt gleichmäßig | Slave ist im Status „Pre-Operational“
blinkt vereinzelt | Slave ist im Status „Safe-Operational“
leuchtet | Slave ist im Status „Operational“
Beschreibung der Stati von EtherCAT-Slaves


Motor, Bremse und Feedbacksystem

Montage und Verkabelung [image] Verkabelung [image] Motor, Bremse und Feedbacksystem
Motor, Bremse und Feedbacksystem
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs


Steckverbinder

Montage und Verkabelung [image] Verkabelung [image] Motor, Bremse und Feedbacksystem [image] Steckverbinder
Steckverbinder
iTec-Buchse 9pol M23 Polbild 150%
iTec-Buchse Pinbelegung
Pin | Name | Kommentar | Aderfarben1)
1 | Bremse + | Motorbremse + | Rot
2 | Bremse - | Motorbremse - | Schwarz
3 | OCT + | Daten und Versorgung für das OCT-Feedbacksystem | Weiß
4 | OCT - | Daten und Versorgung für das OCT-Feedbacksystem | Blau
5 | - | - |
A | U | Motorphase U | Schwarz
B | W | Motorphase W | Grau
C | V | Motorphase V | Braun
 | FE, Schirm | Funktionserde, Kabelschim | Grün-gelb
1) Die Aderfarben gelten für Motorleitungen ZK470x-xxxx von Beckhoff.


Status-LEDs

Montage und Verkabelung [image] Verkabelung [image] Motor, Bremse und Feedbacksystem [image] Status-LEDs
Status-LEDs
Status-LEDs der EP7211-9034 (EP7211-9034_LED.PNG)
Status-LEDs des Motor-Anschlusses
LED-Anzeigen
LED
Anzeige
Bedeutung
Drv OK
leuchtet grün
Die Treiberstufe ist betriebsbereit.
Rd OCT
blinkt grün
Das elektronische Typenschild wird gelesen.
Enable
grün
Die Treiberstufe ist freigegeben.
Die LED ist mit Bit 1 und 2 des Statuswortes1) verknüpft.
Limit
orange
Limit erreicht (z. B. Torque- oder Drehzahllimit).
Die LED ist mit Bit 11 des Statuswortes1) verknüpft.
Warning
blinkt
Fehler beim Lesen des elektronischen Typenschilds.
orange
Warnung. Der Schwellwert für "Warning" ist überschritten.
Mögliche Gründe:
▪
Motor-Auslastung (I²T) ist höher als 100%
▪
Die Motor-Endstufe ist nicht aktiviert
▪
Maximale Betriebstemperatur überschritten
Die LED ist mit Bit 7 des Statuswortes1) verknüpft.
Error
rot
Fehler. Der Schwellwert für "Error" ist überschritten.
Mögliche Gründe:
▪
Überstrom
▪
Spannung nicht vorhanden
▪
Feedback nicht angeschlossen
▪
max. Temperatur (100°C) überschritten
Die LED ist mit Bit 3 des Statuswortes1) verknüpft.
1) Statuswort im CoE-Verzeichnis:
▪
Geräteprofil MDP742 (default)
▪
Geräteprofil DS402


Hardware Enable HWE

Montage und Verkabelung [image] Verkabelung [image] Hardware Enable HWE
Hardware Enable HWE
Weiterführende Informationen
•
Steckverbinder
•
Status-LED
•
Verkabelung


Steckverbinder

Montage und Verkabelung [image] Verkabelung [image] Hardware Enable HWE [image] Steckverbinder
Steckverbinder
Schließen Sie das Signal „Hardware Enable“ wahlweise an Buchse X01 oder X02 an. Die Buchsen X01 und X02 sind gleich belegt und 1:1 in der Box gebrückt.
M12-Buchse Pinbelegung
Pin | Signal | Aderfarben1)
1 | n.c. | Braun
2 | n.c. | Weiß
3 | n.c. | Blau
4 | Hardware Enable HWE | Schwarz
5 | FE (Funktionserde) | Grau
1) Die Aderfarben gelten für Kabel der Typen ZK2000-5xxx, ZK2000-6xxx und ZK2000-7xxx von Beckhoff.


Status-LED

Montage und Verkabelung [image] Verkabelung [image] Hardware Enable HWE [image] Status-LED
Status-LED
Status-LED für HWE
Die grüne LED mit der Bezeichung „HWE“ (Hardware Enable) leuchtet, wenn ein High-Pegel am entsprechenden Pin von X01 oder X02 anliegt.
→ Die Motor-Endstufe ist aktiviert.


Verkabelung

Montage und Verkabelung [image] Verkabelung [image] Hardware Enable HWE [image] Verkabelung
Verkabelung
Die Buchsen X01 und X02 sind gleich belegt und 1:1 in der Box gebrückt. Dadurch ist es möglich, das Signal für „Hardware Enable“ von einer Box auf die nächste weiterzuleiten.
Beispiel:
Beispiel: weitergeleitetes HWE -Signal


Touch Probe

Montage und Verkabelung [image] Verkabelung [image] Touch Probe
Touch Probe
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Verkabelung


Steckverbinder

Montage und Verkabelung [image] Verkabelung [image] Touch Probe [image] Steckverbinder
Steckverbinder
Schließen Sie Touch Probes an den Buchsen X03 und X04 an. Die Buchsen X03 und X04 sind gleich belegt und 1:1 in der Box gebrückt.
M12-Buchse Pinbelegung
Pin | Signal | Aderfarben1)
1 | US: +24 VDC | Braun
2 | IN B = TP2 | Weiß
3 | GNDS | Blau
4 | IN A = TP1 | Schwarz
5 | n.c. | Grau
1) Die Aderfarben gelten für Kabel der Typen ZK2000-5xxx, ZK2000-6xxx, ZK2000-7xxx, von Beckhoff.


Status-LEDs

Montage und Verkabelung [image] Verkabelung [image] Touch Probe [image] Status-LEDs
Status-LEDs
Touch Probe Status-LEDs
Die grünen LEDs mit den Bezeichnungen „IN A“ und „IN B“ leuchten, wenn ein High-Pegel an den entsprechenden Pins von X03 oder X04 anliegt:
▪
IN A = TP1
▪
IN B = TP2


Verkabelung

Montage und Verkabelung [image] Verkabelung [image] Touch Probe [image] Verkabelung
Verkabelung
Die Buchsen X03 und X04 sind gleich belegt und 1:1 in der Box gebrückt. Das ermöglicht die Verkabelung der Touch Probes auf zwei Arten:
▪
Ein gemeinsames Kabel (Anschluss an X03 oder X04)
Endlagenschalter Verkabelung V1
▪
Ein Kabel pro Touch Probe (Anschluss an X03 und X04)
Endlagenschalter Verkabelung V2


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
Motor-Endstufe aktivieren
•
Konfiguration in TwinCAT
•
Start up und Parameter-Konfiguration
•
Antriebsprofile
•
Betriebsarten
•
Prozessdaten MDP 742
•
Prozessdaten DS402
•
Objektbeschreibung (MDP 742)
•
Objektbeschreibung (DS402)


Motor-Endstufe aktivieren

Inbetriebnahme [image] Motor-Endstufe aktivieren
Motor-Endstufe aktivieren
Aktivieren Sie die Motor-Endstufe durch einen High-Pegel am digitalen Eingang Hardware Enable HWE.


Konfiguration in TwinCAT

Inbetriebnahme [image] Konfiguration in TwinCAT
Konfiguration in TwinCAT
Eine EtherCAT Box muss in TwinCAT konfiguriert werden, damit ihre Funktionen in einem SPS-Programm genutzt werden können.
Unter dem folgenden Link finden Sie eine Schnellstartanleitung, die die Konfiguration einer EtherCAT Box in TwinCAT beschreibt:
https://infosys.beckhoff.com/content/1031/epioconfiguration/index.html?id=5323978252154950216


Start up und Parameter-Konfiguration

Inbetriebnahme [image] Start up und Parameter-Konfiguration
Start up und Parameter-Konfiguration
Weiterführende Informationen
•
Einbindung in die NC-Konfiguration
•
Einstellungen mit dem Drive Manager
•
Einstellungen im CoE-Register
•
Einstellungen in der NC
•
Inbetriebnahme ohne die NC, Status-Wort/Control-Wort
•
Einstellungen der automatischen Konfiguration
•
Endlagenüberwachung konfigurieren
•
Homing
•
Touch Probe


Einbindung in die NC-Konfiguration

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Einbindung in die NC-Konfiguration
Einbindung in die NC-Konfiguration
(Master: TwinCAT 2.11 R3)
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen und entsprechend der Installationsanweisungen installiert werden.
Die Einbindung an die NC kann wie folgt durchgeführt werden:
▪
Die Box muss bereits unter E/A-Geräte manuell eingefügt oder vom System eingescannt worden sein (siehe Kapitel Konfiguration in TwinCAT).
Achse automatisch hinzufügen
▪
Nach dem erfolgreichen Einscannen der IO-Module erkennt TwinCAT automatisch die neuen Achsen. Es wird die Frage gestellt, ob die erkannten Achsen automatisch
hinzugefügt werden sollen (siehe Abb. Achse erkannt). Wenn dieses bestätigt wird, werden alle Achsen automatisch mit der NC verknüpft.
Achse erkannt
▪
Damit der Motor in Betrieb genommen werden kann, müssen noch einige Parameter eingestellt werden. Die Werte entnehmen Sie dem Kapitel Einstellungen im CoE-Register.
Stellen Sie diese Parameter ein, bevor Sie mit der Inbetriebnahme des Motors fortfahren.
Achse manuell hinzufügen
▪
Fügen Sie zuerst einen neuen Task an. Dazu klicken Sie mit der rechten Maustaste auf NC-Konfiguration und wählen Sie "Task Anfügen..." aus (siehe Abb. Neuen Task einfügen).
▪
Benennen Sie gegebenenfalls den Task um und bestätigen Sie mit OK.
Neuen Task einfügen
▪
Wählen Sie mit der rechten Maustaste Achsen aus und fügen anschließend eine neue Achse an (siehe Abb. Auswahl einer neuen Achse).
Auswahl einer neuen Achse
▪
Wählen Sie unter Typ eine Kontinuierliche Achse aus und bestätigen Sie mit OK (siehe Abb. Achsentyp auswählen und bestätigen).
Achsentyp auswählen und bestätigen
▪
Markieren Sie Ihre Achse mit der linken Maustaste. Unter der Registerkarte Einstellungen wählen Sie "Verknüpft mit..." aus (siehe Abb. Verknüpfung der Achse mit der Box).
Verknüpfung der Achse mit der Box
▪
Wählen Sie die passende Box aus (CANopen DS402, EtherCAT CoE) und bestätigen Sie mit "OK ".
Auswahl der richtigen Box
▪
Alle wichtigen Verknüpfungen zwischen der NC-Konfiguration und der Box werden dadurch automatisch durchgeführt (siehe Abb. Automatische Verknüpfung aller wichtiger Variablen)
Automatische Verknüpfung aller wichtigen Variablen
▪
Damit der Motor in Betrieb genommen werden kann, müssen noch einige Parameter eingestellt werden. Die Werte entnehmen Sie dem Kapiteln Einstellungen im CoE-Register und Einstellungen in der NC.
Stellen Sie diese Parameter ein, bevor Sie mit der Inbetriebnahme des Motors fortfahren.


Einstellungen mit dem Drive Manager

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Einstellungen mit dem Drive Manager
Einstellungen mit dem Drive Manager
(Master TwinCAT 2.11 R3)
Die hier angegebenen Daten sind beispielhaft für einen Servomotor AM8131-0F20-0000 der Firma Beckhoff Automation aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Inhaltsverzeichnis
Start-up mit dem Drive Manager
Anpassung weiterer Parameter mit dem Drive Manager
Integralanteil Geschwindigkeitsregler Tn
Proportionalanteil Geschwindigkeitsregler Kp
Sie finden den TwinCAT Drive Manager zum Download im AX5000-Download-Package.
Der TwinCAT Drive Manager für die Parametrierung von EP7211 ist in den System Manager integriert, so dass kein separates Konfigurationstool erforderlich ist. Nachdem EP7211 erkannt oder eingetragen wurde, steht der TwinCAT Drive Manager im Karteireiter „Configuration“ zur Verfügung.
Die nachfolgenden Punkte sollen als Start-up dienen, um EP7211 in kurzer Zeit in Betrieb nehmen zu können. Detaillierte Informationen zum Drive Manager entnehmen Sie bitte der zugehörigen Dokumentation "AX5000 Einführung in den TCDrivemanager"
Start-up mit dem Drive Manager
▪
Die Box muss bereits unter E/A-Geräte manuell eingefügt oder vom System eingescannt worden sein (siehe Kapitel Konfiguration in TwinCAT)
▪
Die Box muss bereits in der NC eingebunden sein (siehe Kapitel Einbindung in die NC-Konfiguration)
▪
Wählen Sie den Karteireiter Drive Manager der EP7211.
▪
Unter Power Management können Sie die angeschlossene Spannung auswählen.
Auswahl der angeschlossenen Spannung
▪
Sie können anschließend unter Channel A > Configuration > Motor and Feedback den angeschlossenen Motor scannen oder auswählen. Sollten Sie sich für das automatische Scannen entscheiden, klicken Sie auf Scan motor and feedback. Anschließend wird automatisch das elektronische Typenschild der AM81xx-x2xx Motoren ausgelesen. Dazu ist es erforderlich, dass das automatische Scannen des Motors in der Box aktiviert ist (Index 0x8008, MDP oder Index 0x2018, DS402)
Automatisch Scannen des angeschlossenen Motors
▪
Sollten Sie sich für die manuelle Eingabe des angeschlossenen Motors entscheiden, klicken Sie bitte auf Select Motor.
Auswahl des angeschlossenen Motors
▪
Im Auswahlfenster können Sie den passenden Motor auswählen und mit Ok bestätigen.
Liste der verfügbaren Motoren
▪
Das nächste Dialogfenster sollte mit Ok bestätigt werden. Damit werden automatisch nötige Parameter in der NC eingetragen und der Skalierungsfaktor berechnet. Wird dies nicht bestätigt, müssen Sie diese Einstellungen manuell eintragen. Sehen Sie dazu Kapitel Einstellungen in der NC.
Bestätigung der automatischen Einstellung der NC-Parameter
▪
Unter Scalings and NC Parameters können Sie die Skalierung bestimmen. Hier ist beispielhaft definiert, dass eine Motorumdrehung 360° entspricht. Alle nötigen Parameter werden automatisch angepasst. Die Einstellung wird erst übernommen, wenn Sie die Konfiguration aktivieren.
Anpassung der Skalierung
Damit sind alle wichtigen Parameter für die Inbetriebnahme des Motors eingestellt. Sie können den Motor nun beispielsweise mit der NC in Betrieb nehmen. Eine kurze Beschreibung hierzu finden Sie im Kapitel "Inbetriebnahme des Motors mit der NC". Oder Sie sprechen die NC aus der PLC heraus an. Auch dazu ist in der Dokumentation ein Beispielprogramm hinzugefügt worden.
Sie haben weiterhin die Möglichkeit einige Parameter manuell in Ihrer Applikation anzupassen.
Anpassung weiterer Parameter mit dem Drive Manager
Die hier angegebenen Werte sind beispielhaft und haben in den meisten Fällen zu sehr guten Ergebnissen geführt. Je nach Applikation können andere Werte zu besseren Ergebnissen führen.
Sie können diese Werte im laufenden Betrieb ändern. Sobald Sie auf Download klicken, werden die Werte übernommen.
Integralanteil Geschwindigkeitsregler Tn
▪
Verringern Sie den Wert, bis der Motor anfängt leicht zu schwingen. Erhöhen Sie diesen Wert anschließend um 10%.
Anpassung Tn
Proportionalanteil Geschwindigkeitsregler Kp
▪
Erhöhen Sie den Wert, bis der Motor anfängt leicht zu schwingen. Verringern Sie diesen Wert anschließend auf 80%.
Anpassung Kp


Einstellungen im CoE-Register

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Einstellungen im CoE-Register
Einstellungen im CoE-Register
(Master TwinCAT 2.11 R3)
Die hier angegebenen Daten sind beispielhaft für einen Servomotor AM8131-0F20-0001 der Firma Beckhoff Automation aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Inhaltsverzeichnis
Einstellungen im CoE-Register
Einstellungen im CoE-Register
Einstellung weiterer Parameter
Einstellungen im CoE-Register
Torque limitation
Einstellungen im CoE-Register
Einstellungen im CoE-Register
Einfügen der Motor XML-Datei
Download der Motor XML-Dateien
Die Motor XML-Dateien können im Download-Bereich auf der Beckhoff Website herunter geladen werden.
Zur Erleichterung der Inbetriebnahme von EP7211 wurden für die Servomotoren, die von EP7211 unterstützt werden, Motor XML-Dateien erstellt. Diese XML-Dateien können im System Manager eingelesen werden.
Anschließend sind alle nötigen CoE-Parameter bzw. DS402-Parameter passend eingestellt.
▪
Zum Einlesen der Motor XML-Datei wählen Sie EP7211 aus und betätigen die Registerkarte Startup. Klicken Sie mit der rechten Maustaste in das leere Feld und wählen Sie Import from XML...(siehe Abb. Importieren der Motor XML-Datei).
Importieren der Motor XML-Datei
▪
Wählen Sie die passende Motor XML-Datei zum angeschlossenen Motor (siehe Abb. Auswahl der richtigen Motor XML-Datei)
Auswahl der richtigen Motor XML-Datei
▪
Anschließend sind alle nötigen Parameter eingestellt, um den Motor in Betrieb zu nehmen (siehe Abb. CoE Parameter der Motor XML-Datei).
CoE Parameter der Motor XML-Datei
Startup-Liste
Sollten applikationsabhängige Feineinstellungen nötig sein, sollten diese ebenfalls im Startup geändert werden. Andernfalls werden die geänderten Einstellungen beim nächsten Hochlauf der Box überschrieben.
Anpassung von Strom und Spannung
Hinweis
Überhitzung des Motors möglich!
Um den angeschlossenen Motor nicht zu überhitzen ist es wichtig, die Spannung, die von der Box ausgegeben wird, der tatsächlich angeschlossenen Spannung anzupassen.
Dazu muss der Index 0x8010:19 (0x2002:19, DS402-Profil) "Nominal DC Link Voltage" der angeschlossenen Spannung passend eingestellt werden
Einstellung weiterer Parameter
Singleturn Bits (MDP742: Index 0x8000:12 / DS402: Index 0x2010:12) /
Multiturn Bits (MDP742: Index 0x8000:13 / DS402: Index 0x2010:13)
Hier kann der Anwender selber festlegen, wie viele Singleturn Bits und Multiturn Bits von der Box angezeigt werden sollen. Insgesamt stehen 32 Bits zur Verfügung. Diese 32 Bits können beliebig aufgeteilt werden.
Standardmäßig sind 20 Singleturn Bits und 12 Multiturn Bits eingestellt.
Singleturn Bits: Anzahl der Bits, mit denen eine Rotordrehung aufgelöst wird.
Multiturn Bits: Nach einer Rotordrehung werden die Multiturn Bits um eins hochgezählt.
Überhitzung des Motors möglich!
Wird die Anzahl der Singleturn Bits geändert, muss der Skalierungsfaktor in der NC angepasst werden!
Multiturn / Singleturn bits
Torque limitation (MDP742: Index 0x7010:0B / DS402: Index 0x6072:0)
Limitiert den Strom / das Drehmoment auf diesen Wert. Der Wert wird in 1000stel vom "rated current" angegeben.
Integralanteil Geschwindigkeitsregler Tn (MDP742: Index 0x8010:14 / DS402: Index 0x2002:14)
Die hier angegebenen Werte sind beispielhaft und haben in den meisten Fällen zu sehr guten Ergebnissen geführt. Es kann aber je nach Applikation vorkommen, dass andere Werte zu besseren Ergebnissen führen.
▪
Verringern Sie den Wert, bis der Motor anfängt leicht zu schwingen. Erhöhen Sie diesen Wert anschließend um 10%.
Proportionalanteil Geschwindigkeitsregler Kp (MDP742: Index 0x8010:15 / DS402: Index 0x2002:15)
Die hier angegebenen Werte sind beispielhaft und haben in den meisten Fällen zu sehr guten Ergebnissen geführt. Es kann aber je nach Applikation vorkommen, dass andere Werte zu besseren Ergebnissen führen.
▪
Erhöhen Sie den Wert, bis der Motor anfängt leicht zu schwingen. Verringern Sie diesen Wert anschließend auf 80%.


Einstellungen in der NC

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Einstellungen in der NC
Einstellungen in der NC
(Master TwinCAT 2.11 R3)
Die hier angegebenen Daten sind beispielhaft für einen Servomotor AM8122-0F20-0000, der Firma Beckhoff Automation aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Inhaltsverzeichnis
Definition der Einheit
Auswahl der max. Geschwindigkeit
Totzeitkompensation
Einstellungen in der NC
Einstellungen in der NC
Berechnung des Skalierungsfaktors
Ausgabe Skalierung
Einstellungen in der NC
Inbetriebnahme des Motors mit der NC
Für die Inbetriebnahme mit der NC sind einige wichtige Parameter notwendig. Diese sollten vor der Inbetriebnahme wie folgt eingestellt werden. Grundlegend für die Einstellung der folgenden Parameter ist die eingestellte Einheit, in der die NC arbeiten soll. Bei den folgenden Parametern wurde zu Grunde gelegt, dass eine Umdrehung 360° entspricht.
Definition der Einheit
Die Einheit kann in der Registerkarte Einstellungen der Achse definiert werden.
Definition der Einheit
Auswahl der max. Geschwindigkeit
Die maximale erlaubte Geschwindigkeit errechnet sich anhand der maximalen Motorgeschwindigkeit (Typenschild) und der zu verfahrenden Distanz. Hier bezogen auf 360° pro Sekunde.
Anpassung der Bezugsgeschwindigkeit
Die Bezugsgeschwindigkeit ist der maximalen erlaubten Geschwindigkeit gleichgestellt.
Darunter können bei Belieben noch die max. und min. Geschwindigkeit für den Handbetrieb der NC eingestellt werden.
Totzeitkompensation
Die Totzeitkompensation der Achse kann in der Registerkarte Time Compensation der Encodereinstellungen Achse1_ENC eingestellt werden. Sie sollte theoretisch 3 Zyklen der NC-Zykluszeit betragen, besser haben sich jedoch 4 Zyklen der NC-Zykluszeit erwiesen. Dazu sollten die Parameter Time Compensation Mode Encoder auf ‚ON (with velocity)‘ und Encoder Delay in Cycles auf 4 eingestellt sein.
Parameter Totzeitkompensation
Einstellung der Geber-Maske
In der Registerkarte Parameter der Encodereinstellungen Achse1_ENC können die maximalen Werte für die Geber-Maske eingestellt werden. EP7211 stellt für den Geber maximal 32 Bit zur Verfügung.
Mit dem Parameter Geber-Maske (Maximalwert des Gebers) kann die Anzahl der Bits eingestellt werden, die maximal zur Verfügung stehen sollen. Im Default steht hier 0xFFFF FFFF, das entspricht 32 Bit (20 Singleturn Bits und 12 Multiturn Bits). Berechnen lässt sich das mit der folgenden Formel.
Der Parameter Geber-Sub-Maske (Maximalwert des Absolutbereichs) gibt an, wie viele Bits vom Maximalwert des Gebers Singleturn Bits sein sollen. Im Default sind es 20 (und damit 12 Multiturn Bits). Das kann mit folgender Formel berechnet werden.
Ein weiteres Rechenbeispiel mit 13 Singleturn Bits und 8 Multiturn Bits.
Einstellung der Geber-Maske
Skalierungsfaktor
Den Skalierungsfaktor können Sie ändern, wenn Sie in der NC Achse 1_Enc und die Registerkarte Parameter auswählen (siehe Abb. Skalierungsfaktor einstellen). Der Wert lässt sich mit den unten angegebenen Formeln berechnen. Bei der Berechnung wird zur Grunde gelegt, dass eine Umdrehung 360° entspricht.
In die Berechnung des Skalierungsfaktors fließt die Anzahl der Singleturn Bits mit ein. Wie bereits beschrieben, rechnet EP7211 im Default mit 20 Singleturn Bits. Mit diesem Wert wird im Folgenden auch der Skalierungsfaktor berechnet. Sollte sich der Wert der Singleturn Bits ändern, muss der Skalierungsfaktor angepasst werden.
Berechnung des Skalierungsfaktors
Skalierungsfaktor einstellen
Ausgabe Skalierung
Bitte tragen Sie in der Registerkarte Parameter der Drive-Einstellungen, beim Parameter Ausgabeskalierung (Geschw.) den Wert 32 ein.
Ausgabeskalierung
Schleppüberwachung Position
Die Schleppabstandsüberwachung kontrolliert, ob der aktuelle Schleppabstand einer Achse einen Grenzwert überschreitet. Als Schleppabstand wird die Differenz zwischen ausgegebenem Sollwert (Stellgröße) und dem rückgemeldeten Istwert bezeichnet. Sind die Parameter der Box noch unzureichend eingestellt, kann es dazu führen, dass beim Verfahren der Achse die Schleppabstandsüberwachung einen Fehler ausgibt. Bei der Inbetriebnahme kann es deswegen eventuell von Vorteil sein, wenn man die Grenzen der Schleppüberwachung Position etwas erhöht.
Hinweis
Beschädigung von Geräten, Maschinen und Peripherieteilen möglich!
Bei der Parametrierung der Schleppüberwachung können durch Einstellen zu hoher Grenzwerte Geräte, Maschinen und Peripherieteile beschädigt werden!
Schleppüberwachung
Inbetriebnahme des Motors mit der NC
▪
Sind die Parameter eingestellt, dann ist der Motor prinzipiell betriebsbereit. Einzelne weitere Parameter müssen der jeweiligen Applikation angepasst werden.
▪
Um die Achse in Betrieb zu nehmen, aktivieren Sie die Konfiguration (Ctrl+Shift+F4), markieren die Achse, wählen die Registerkarte Online aus und geben unter Set die Achse frei.
▪
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. Achse freigeben). Anschließend kann die Achse bewegt werden.
Achse freigeben
Sie können nun die Achse mit Hilfe der Funktionstasten F1, F2 (Rückwärts) und F3, F4 (Vorwärts) bewegen.
Sie können hier den Kv Faktor verstellen und sich somit an einen passenden Faktor herantasten. Stellen Sie zunächst 0 ein, um die richtige Bezugsgeschwindigkeit einzustellen. Wie die Bezugsgeschwindigkeit berechnet wird, entnehmen Sie bitte dem Kapitel "Auswahl der max. Geschwindigkeit". Die Berechnung gibt einen relativ genauen Wert an, Sie müssen diesen Wert gegebenenfalls noch etwas korrigieren. Verfahren Sie dazu den Motor mit einem Kv Faktor von 0 und achten Sie darauf, dass die Ist-Geschwindigkeit mit der Soll-Geschwindigkeit übereinstimmt.
Eine andere Möglichkeit besteht darin, unter der Registerkarte Funktionen, die Achse anzusteuern. Nachfolgend ein Beispiel dazu.
▪
Wählen Sie als Starttyp Reversing Sequence.
▪
Geben Sie eine gewünschte Zielposition2 an, z. B. 12000°.
▪
Geben Sie eine gewünschte Zielgeschwindigkeit an, z. B. 12000°/s.
▪
Geben Sie eine gewünschte Zielposition1 an, z. B. 0°.
▪
Geben Sie den gewünschte Idle Time an, z.B. 2 s.
▪
Wählen Sie Start.
Reversing Sequence
Nun dreht sich Ihr Motor auf die Position 2, verbleibt dort 2 s und fährt wieder auf die Position 1. Das wird wiederholt, bis Sie das mit "Stop" beenden.


Inbetriebnahme ohne die NC, Status-Wort/Control-Wort

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Inbetriebnahme ohne die NC, Status-Wort/Control-Wort
Inbetriebnahme ohne die NC, Status-Wort/Control-Wort
(Master: TwinCAT 2.11 R3)
Die Betriebsarten CST, CSTCA, CSV und CSP lassen sich grundsätzlich auch ohne die TwinCAT NC betreiben.
Endstufe freigeben über Control-Wort
Für jede Betriebsart ist es notwendig, die Endstufe freizugeben. Dazu müssen über die PLC im Control-Wort (MDP742 / DS402) die folgenden Werte in der angegeben Reihenfolge eingeben werden (siehe Abb. DS402 State Machine ).
Im Status-Wort (MDP742 / DS402) werden die entsprechenden Statusmeldungen ausgegeben.
0hex
80hex (Fault reset)
6hex (Shutdown)
7hex (Switch on)
Fhex (Enable operation)
DS402 State Machine
CST - cyclic synchronous torque
Im Index 0x7010:03 Modes of operation (MDP) oder Index 0x6060:0 Modes of operation (DS402) muss Cyclic synchronous torque mode gewählt werden. In den jeweiligen Prozessdaten sollte ebenfalls das Predefined PDO Assignment: 'Cyclic synchronous torque mode (CST)' gewählt werden (siehe Prozessdaten MDP 742 oder Prozessdaten DS402). Anschließend muss die Konfiguration neu geladen werden, um die Auswahl zu übernehmen.
Unter dem Index 0x6010:03 Modes of operation display (MDP) oder dem Index 0x6061:0 Modes of operation display (DS402) kann überprüft werden, in welchem Modus sich die Box tatsächlich befindet.
Über die PLC kann in der Variable Target torque ein definiertes Moment eingestellt werden, auf das die Box regeln soll. Das Moment wird in 1000stel des Nennstroms angegeben. Sollte dort beispielsweise 1000dec angegeben werden, entspricht das dem eingestellten Index 0x8011:12 Rated current (MDP) bzw. Index 0x6075:0 Motor rated current (DS402). Der Wert 1dec entspricht einem 1000stel des Nennstroms.
CSTCA - cyclic synchronous torque with commutation angle
Im Index 0x7010:03 Modes of operation (MDP) oder Index 0x6060:0Modes of operation (DS402) muss Cyclic synchronous torque mode with commutation angle gewählt werden. In den jeweiligen Prozessdaten sollte ebenfalls das Predefined PDO Assignment: 'Cyclic synchronous torque mode with commutation angle mode (CSTCA)' gewählt werden (siehe Prozessdaten MDP 742 oder Prozessdaten DS402). Anschließend muss die Konfiguration neu geladen werden, um die Auswahl zu übernehmen.
Unter dem Index 0x6010:03 Modes of operation display (MDP) oder dem Index 0x6061:0 Modes of operation display (DS402) kann überprüft werden, in welchem Modus sich die Box tatsächlich befindet.
Über die PLC kann in der Variable Target torque ein definiertes Moment eingestellt werden, auf das die Box regelt und in der Variable Commutation angle kann der Winkel angegeben werden, der mit dem eingestellten Moment gehalten werden soll. Das Moment wird in 1000stel des Nennstroms angegeben. Sollte dort beispielsweise 1000dec angegeben werden, entspricht das dem eingestellten Index 0x8011:12 Rated current (MDP) bzw. Index 0x6075:0 Motor rated current (DS402). Der Wert 1dec entspricht einem 1000stel des Nennstroms.
Der Wert für den Winkel muss umgerechnet werden, 65536dec entsprechen 360°.
CSV - cyclic synchronous velocity
Im Index 0x7010:03 Modes of operation (MDP) oder Index 0x6060:0 Modes of operation (DS402) muss Cyclic synchronous velocity gewählt werden. In den jeweiligen Prozessdaten sollte ebenfalls das Predefined PDO Assignment: 'Cyclic synchronous velocity mode (CSV)' gewählt werden (siehe Prozessdaten MDP 742 oder Prozessdaten DS402). Anschließend muss die Konfiguration neu geladen werden, um die Auswahl zu übernehmen.
Unter dem Index 0x6010:03 Modes of operation display (MDP) oder dem Index 0x6061:0 Modes of operation display (DS402) kann überprüft werden, in welchem Modus sich die Box tatsächlich befindet.
Über die PLC kann in der Variable Target velocity 0x7010:06 (MDP) oder 0x60FF:0 (DS402) eine definierte Drehzahl eingestellt werden, auf die die Box regeln soll. Der konstante Wert Velocity encoder resolution im CoE Objekt 0x9010:14 (MDP) oder 0x6090:0 (DS402) entspricht 1 Umdrehung pro Sekunde. Wird dieser Wert in Target velocity eingetragen, dreht der Motor 1 Umdrehung / s, ein entsprechendes Vielfaches vom Wert Velocity encoder resolution bei Target velocity eingtragen, erhöht die Geschwindigkeit.
CSP - cyclic synchronous position
Im Index 0x7010:03 Modes of operation (MDP) oder Index 0x6060:0 Modes of operation (DS402) muss Cyclic synchronous position gewählt werden.
In den jeweiligen Prozessdaten sollte ebenfalls das Predefined PDO Assignment: 'Cyclic synchronous position mode (CSP)' gewählt werden (siehe Prozessdaten MDP 742 oder Prozessdaten DS402). Anschließend muss die Konfiguration neu geladen werden, um die Auswahl zu übernehemen.
Unter dem Index 0x6010:03 Modes of operation display (MDP) oder dem Index 0x6061:0 Modes of operation display (DS402) kann überprüft werden, in welchem Modus sich die Box tatsächlich befindet.
Über die PLC kann in der Variable Target position 0x7010:05 (MDP) oder 0x607A:0 (DS402) eine definierte Position eingestellt werden, auf die der Motor fahren soll. Bei der Berechnung der Position wird der berechnete Skalierungsfaktor zugrunde gelegt. Der in der Variable Target position eingetragene Wert muss mit dem berechneten Skalierungsfaktor multipliziert werden.


Einstellungen der automatischen Konfiguration

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Einstellungen der automatischen Konfiguration
Einstellungen der automatischen Konfiguration
(Master TwinCAT 2.11 R3)
EP7211 bietet die Möglichkeit, einen angeschlossenen Motor der Baureihe AM81xx automatisch zu konfigurieren. Dabei wird das im Motor integrierte elektronische Typenschild ausgelesen und die notwendigen Parameter der Box entsprechend angepasst.
Die automatische Konfiguration ist im Auslieferungszustand ausgeschaltet. Der Anwender hat die Möglichkeit, die automatische Konfiguration entsprechend des unten ersichtlichen Flussdiagramms (siehe Abb. Flussdiagramm der automatischen Konfiguration) anzupassen.
Überschreibung der Parameter bei Automatischer Konfiguration
Die vom Anwender manuell geänderten Parameter der Parameterliste der automatischen Konfiguration werden beim nächsten Starten automatisch überschrieben, wenn die automatische Konfiguration eingeschaltet ist.
▪
Die automatische Konfiguration kann im Index 0x8008:01 (0x2018:01, DS402 Profil) Enable autoconfig eingeschaltet werden.
▪
Im Index 0x8008:02 (0x2018:02, DS402 Profil) Reconfig identical motor kann der Anwender entscheiden, ob im Austauschfall eines identischen Motors, die Box den Motor automatisch neu konfigurieren soll (Einstellung = true) oder der Motor mit den gespeicherten Einstellungen betrieben werden soll (Einstellung = false). Die Deaktivierung dieser Funktion kann beispielsweise von Vorteil sein, wenn der Anwender den Motor speziell auf seine Anwendung eingestellt hat und diese Einstellungen nach einem Austausch des Motors nicht verlieren möchte.
▪
Im Index 0x8008:03 (0x2018:03, DS402 Profil) Reconfig non-identical motor kann der Anwender entscheiden, ob im Austauschfall eines nicht-identischen Motors, die Box den Motor automatisch neu konfigurieren soll (Einstellung = true) oder der Motor mit den gespeicherten Einstellungen betrieben werden soll (Einstellung = false).
Flussdiagramm der automatischen Konfiguration
Parameterliste der automatischen Konfiguration
Folgende Parameter sind von der automatischen Konfiguration betroffen.
Index (hex) |  | Bezeichnung | Bedeutung
MDP 407 Profil | DS402 Profil
8010:12 | 2002:12 | Current loop integral time | wird nach dem symmetrischen Optimum berechnet
8010:13 | 2002:13 | Current loop proportional gain | wird nach dem symmetrischen Optimum berechnet
8011:11 | 2003:11 | Max. current | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:12 | 2003:12 | Rated current | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:13 | 2003:13 | Motor pole pairs | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:15 | 2003:15 | Commutation offset | wird immer auf -90° gesetzt
8011:16 | 2003:16 | Torque constant | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:18 | 2003:18 | Rotor moment of inertia | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:19 | 2003:19 | Winding inductance | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:1B | 2003:1B | Motor speed limitation | Berechnung der max. Geschwindigkeit des angeschlossenen Motors
8011:2B | 2003:2B | Motor temperature warn level | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:2C | 2003:2C | Motor temperature error level | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:2D | 2003:2D | Motor thermal time constant | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8012:11 | 2004:11 | Release delay | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8012:12 | 2004:12 | Application delay | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8012:14 | 2004:14 | Brake moment of inertia | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen


Endlagenüberwachung konfigurieren

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Endlagenüberwachung konfigurieren
Endlagenüberwachung konfigurieren
Software-Endlagenüberwachung
Mittels der TwinCAT NC kann für EP7211 eine Software-Endlagenüberwachung eingestellt werden. Diese Überwachung dient der Sicherheit der Anlage. Die eingestellte Position wird von der Achse nicht überschritten (max. Endlage) bzw. unterschritten (min. Endlage). In der Registerkarte Parameter der entsprechenden Achse kann die jeweilige Endlagenüberwachung eingeschaltet werden.
Pulldown-Menü zum Einschalten der Endlagenüberwachung


Homing

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Homing
Homing
(Master TwinCAT 2.11 R3)
Die hier angegebenen Daten sind beispielhaft für einen Servomotor AM8131-0F20-0000 der Firma Beckhoff Automation aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Inhaltsverzeichnis
Referenzierung
Funktionsbaustein "MC_Home"
Homing
Referenzierung
Die Referenzierung funktioniert nicht über den Online-Inbetriebnahme-Reiter der Achse (siehe Abb. Online-Homing in der NC).
Online-Homing in der NC
Funktionsbaustein "MC_Home"
▪
Die Referenzierung muss aus der SPS heraus durchgeführt werden. Dazu wird hier der Funktionsbaustein MC_Home aus der TC MC2 Lib genutzt.
▪
Folgende minimale Beschaltung ist in dem MC_Home notwendig.
–
der HomingMode, mit dem Sie auswählen können, welchen Modus Sie für die Referenzierung nutzen möchten.
–
der Execute, mit dem Sie die Referenzfahrt starten können.
–
der bCalibrationCam, der mit Ihrer Referenznocke verknüpft werden muss, um die Referenzfahrt zu stoppen.
Beschaltung des MC_Home Bausteins
▪
In der folgenden Abb. Auszug der Funktionsbeschreibung des MC_Home sehen Sie einen Auszug aus der Funktionsbeschreibung des MC_Home. Die gesamten Informationen entnehmen Sie bitte direkt aus der zugehörigen Funktionsbeschreibung.
Auszug der Funktionsbeschreibung des MC_Home
Referenz Modi
▪
EP7211 kann mit den folgenden Referenz Modi der NC betrieben werden (siehe Abb. Auswahl der Referenz Modi in der NC).
▪
Default: Ist eine allgemeine Einstellung und für die meisten Anwendungen geeignet.
Fährt der Motor an den Referenznocken, wird eine Richtungsumkehr ausgelöst. Mit dem abfallenden Signal des Nocken bleibt der Motor stehen und die Referenzposition ist gesetzt.
▪
Software Sync: Die C-Spur wird virtuell nachgebildet.
Auswahl der Referenz Modi in der NC
Weiterhin lässt sich in der NC die Geschwindigkeit einstellen die bei der Referenzfahrt genutzt werden soll (Abb. Einstellung der Referenzgeschwindigkeit).
Einstellung der Referenzgeschwindigkeit


Touch Probe

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Touch Probe
Touch Probe
(Master TwinCAT 2.11 R3)
Funktionsbeschreibung
Die Funktion Touch Probe speichert die aktuelle Position des Motors, wenn eine Signalflanke an einem digitalen Eingang erkannt wird.
Im Reiter Prozessdaten können die dazu nötigen Prozessdatenobjekte aktiviert werden (siehe Abb. Touch Probe inputs und Abb. Touch Probe outputs).
Touch Probe inputs
Touch Probe outputs
Step-by-step
Zur Funktionsbeschreibung wird hier beispielhaft TP1 verwendet.
▪
Um die Touch Probe Funktion generell zu aktivieren, muss TP1 Enable auf true gesetzt werden.
▪
Anschließend muss entschieden werden, ob bei einer positiven Flanke auf dem Eingang 1 die Position gespeichert werden soll (TP1 Enable pos edge = true), bei einer negativen Flanke (TP1 Enable neg edge = true) oder in beiden Fällen (beide auf "true" setzen).
▪
Mit TP1 Continous wird entschieden, ob nur beim ersten Event die Position gespeichert werden soll (TP1 Continous = false) oder ob das bei jedem Event geschehen soll (TP1 Continous = true).
Sind beispielsweise TP1 Continous und TP1 Enablepos edge gesetzt, wird bei jeder steigenden Flanke am Eingang 1 der Box die Position gespeichert.
Ist TP1 Enable neg edge gesetzt und TP1 Continous nicht, wird nur bei der ersten negativen Flanke am Eingang 1 der Box die Position gespeichert. Möchte man diesen Vorgang wiederholen, muss zunächst der TP1 Enable wieder deaktiviert und anschließend wieder aktiviert werden. Dann wird erneut bei der ersten negativen Flanke die Position gespeichert.
▪
Der TP1 Trigger mode hat bei EP7211 keine Funktion.
▪
Die gespeicherte Position der positiven Flanke kann in den Inputs der Prozessdaten unter TP1 Pos position, die der negativen Flanke kann unter TP1 Neg position ausgelesen werden.
▪
Die Variablen unter Touch probe status dienen der Diagnose.
▪
Die Touch Probe Eingänge müssen mit einem 1-Leiter +24 V Signal angesprochen werden.


Antriebsprofile

Inbetriebnahme [image] Antriebsprofile
Antriebsprofile
EP7211 unterstützt die Antriebsprofile MDP 742 und DS402. Beide Antriebsprofile beinhalten die gleichen Parameter. Die Antriebsprofile definieren die Darstellung der Parameter in TwinCAT und den Index, unter dem die jeweiligen Parameter im Objektverzeichnis angeordnet sind:
▪
MDP 742 (Modular Device Profile) hat die für Beckhoff IO-Module übliche Aufteilung der CoE-Objekte.
▪
DS402 ist in IEC61800-7-200 spezifiziert (CiA402) und nutzt eine andere Aufteilung der Objektverzeichnisstruktur.
Die Drive State Machine basiert in beiden Antriebsprofilen auf der CiA402 State Machine, somit ist das funktionale Verhalten identisch.
Ab Werk wird die Box mit dem Antriebsprofil MDP 742 ausgeliefert.
Antriebsprofil wechseln
Sie können das Antriebsprofil wechseln, indem Sie ein EEPROM Update durchführen. Wählen Sie die EEPROM-Beschreibung anhand der folgenden Tabelle aus.
Antriebsprofil | EEPROM-Beschreibung
MDP 742 | EP7211-0034
DS402 | EP7211-0035
Die EEPROM-Beschreibung ist gleichzeitig der Name des IO-Moduls im Solution Explorer von TwinCAT.
Die CoE-Objektbeschreibung und die Prozessdaten der Antriebsprofile sind unterschiedlich. Es müssen jeweils die zu dem eingestellten Profil passenden Motor XML Files hinzugezogen werden.


Betriebsarten

Inbetriebnahme [image] Betriebsarten
Betriebsarten
Weiterführende Informationen
•
Übersicht
•
CSV
•
CST
•
CSTCA
•
CSP


Übersicht

Inbetriebnahme [image] Betriebsarten [image] Übersicht
Übersicht
Es werden die Betriebsarten CST, CSTCA, CSV und CSP unterstützt. Die Betriebsart wird im CoE-Verzeichnis im Index 0x7010:03 Modes of operation (MDP) oder Index 0x6060:0 Modes of opreration (DS402) eingestellt. In den jeweiligen Prozessdaten hat der Anwender zusätzlich die Möglichkeit das passende Predefined PDO Assigment auszuwählen. Damit sind alle nötigen Variablen in den Prozessdaten.
CSV - cyclic synchronous velocity (Geschwindigkeitsregelung)
In der Betriebsart CSV arbeitet EP7211 im zyklischen Geschwindigkeitsinterface. Über die Variable Target velocity kann eine definierte Geschwindigkeit eingestellt werden.
CST - cyclic synchronous torque (Drehmomentregelung)
In der Betriebsart CST arbeitet EP7211 im zyklischen Drehmomentsinterface. Über die Variable Target torque kann ein definiertes Drehmoment eingestellt werden.
CSTCA - cyclic synchronous torque with commutation angle (Drehmomentregelung mit Kommutierungswinkel)
Diese Betriebsart ist ebenfalls zur Verwendung am zyklischen Drehmomentsinterface. Zusätzlich hat der Anwender die Möglichkeit den Kommutierungswinkel anzugeben. Über die Variable Commutation angle kann ein Winkel eingestellt werden, der mit einem definierten Drehmoment der Variablen Target torque gehalten werden soll.
CSP - cyclic synchronous position (Positionsregelung)
In der Betriebsart CSP arbeitet EP7211 im zyklischen Positionsinterface. Über die Variable Target position kann eine definierte Position eingestellt werden.
Mehr Informationen zu den drei oben angegebenen Betriebsarten finden Sie im Kapitel Inbetriebnahme ohne die NC.


CSV

Inbetriebnahme [image] Betriebsarten [image] CSV
CSV
In der Betriebsart CSV arbeitet EP7211 im zyklischen Geschwindigkeitsinterface. Über die Variable Target velocity kann eine definierte Geschwindigkeit eingestellt werden.
Step-by-Step
▪
Fügen Sie die Box, wie im Kapitel Konfiguration in TwinCAT beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Box, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC.
▪
Importieren Sie die Motor XML Datei, wie im Kapitel Einstellungen im CoE beschrieben, in das Start-up Verzeichnis.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Cyclic synchronous velocity mode (CSV), Abb. Auswahl Betriebsart.
Auswahl Betriebsart
▪
Wählen Sie bei den Predefined PDO Assignments ebenfalls Cyclic synchronous velocity mode (CSV), Abb. Predefined PDO Assignment wählen.
Predefined PDO Assignment wählen
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Box. Dazu gibt es zwei Möglichkeiten:
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können in der Registerkarte Online der Achse die Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. Freigaben setzen). Anschließend kann die Achse bewegt werden.
Freigaben setzen
–
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Befolgen Sie dazu die Anweisungen im Kapitel Inbetriebnahme ohne die NC.
▪
Über die zyklische Variable Target velocity (Abb. Vorgabe Drehmoment) können Sie eine definierte Geschwindigkeit vorgeben. Der Wert im Index 0x9010:14 (0x6090, DS402) Velocity encoder resolution entspricht 1 U/s.
Vorgabe Drehmoment


CST

Inbetriebnahme [image] Betriebsarten [image] CST
CST
In der Betriebsart CST arbeitet EP7211 im zyklischen Drehmomentsinterface. Über die Variable Target torque kann ein definiertes Drehmoment eingestellt werden.
Step-by-Step
▪
Fügen Sie die Box, wie im Kapitel Konfiguration in TwinCAT beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Box, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC.
▪
Importieren Sie die Motor XML Datei, wie im Kapitel Einstellungen im CoE beschrieben, in das Start-up Verzeichnis.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Cyclic synchronous torque mode (CST), Abb. Auswahl Betriebsart
Auswahl Betriebsart
▪
Wählen Sie bei den Predefined PDO Assignments ebenfalls Cyclic synchronous torque mode (CST), Abb. Predefined PDO Assignment wählen
Predefined PDO Assignment wählen
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Box. Dazu gibt es zwei Möglichkeiten:
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können in der Registerkarte Online der Achse die Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. Freigaben setzen). Anschließend kann die Achse bewegt werden.
–
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Befolgen Sie dazu die Anweisungen im Kapitel Inbetriebnahme ohne die NC.
Freigaben setzen
▪
Über die zyklische Variable Target torque (Abb. Vorgabe Drehmoment) können Sie ein definiertes Moment vorgeben.
Vorgabe Drehmoment


CSTCA

Inbetriebnahme [image] Betriebsarten [image] CSTCA
CSTCA
Diese Betriebsart ist ebenfalls zur Verwendung am zyklischen Drehmomentsinterface. Zusätzlich hat der Anwender die Möglichkeit den Kommutierungswinkel anzugeben. Über die Variable Commutation angle kann ein Winkel eingestellt werden, der mit einem definierten Drehmoment der Variablen Target torque gehalten werden soll.
Step-by-Step
▪
Fügen Sie die Box, wie im Kapitel Konfiguration in TwinCAT beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Box, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC.
▪
Importieren Sie die Motor XML Datei, wie im Kapitel Einstellungen im CoE beschrieben, in das Start-up Verzeichnis.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Cyclic synchronous torque mode with commutation angle (CSTCA), Abb. Auswahl Betriebsart
Auswahl Betriebsart
▪
Wählen Sie bei den Predefined PDO Assignments ebenfalls Cyclic synchronous torque mode with commutation angle (CSTCA), Abb. Predefined PDO Assignment wählen.
Predefined PDO Assignment wählen
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Box. Dazu gibt es zwei Möglichkeiten:
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können in der Registerkarte Online der Achse die Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. Freigaben setzen). Anschließend kann die Achse bewegt werden.
Freigaben setzen
–
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Befolgen Sie dazu die Anweisungen im Kapitel Inbetriebnahme ohne die NC.
▪
Über die zyklische Variable Target torque können Sie ein definiertes Moment vorgeben. Der Wert wird in 1000stel vom rated current angegeben und das Moment wird nach folgeneder Formel berechnet, wobei der rated current sich auf den Wert im Index 0x8011:12 rated current bezieht.
Über die zyklische Variable Commutation angle können Sie einen definierten Winkel vorgeben. Der Wert wird in 360°/216 angegeben.
Vorgabe Drehmoment und Kommutierungswinkel


CSP

Inbetriebnahme [image] Betriebsarten [image] CSP
CSP
In der Betriebsart CSP arbeitet EP7211 im zyklischen Positionsinterface. Über die Variable Target position kann eine definierte Position eingestellt werden.
Minimale Zykluszeit
Die Zykluszeit im CSP Modus muss 2^n * 125 µs betragen (mit n = 1 bis 8), also 250 µs, 500 µs, 1 ms, 2 ms, 4 ms, 8 ms, 16 ms oder 32 ms.
Step-by-Step
▪
Fügen Sie die Box, wie im Kapitel Konfiguration in TwinCAT beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Box, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC.
▪
Konfigurieren Sie den Motor mit Hilfe der Automatischen Konfiguration (nur OCT-Typen), anhand des Drive Managers oder importieren Sie die Motor XML-Datei, wie im Kapitel Einstellungen im CoE beschrieben, in das Start-up Verzeichnis.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Cyclic synchronous position mode (CSP), Abb. Auswahl Betriebsart.
Auswahl Betriebsart
▪
Wählen Sie bei den Predefined PDO Assignments ebenfalls Cyclic synchronous position mode (CSP), Abb. Predefined PDO Assignment wählen.
Predefined PDO Assignment wählen
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Box. Dazu gibt es zwei Möglichkeiten:
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können in der Registerkarte "Online" der Achse die Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. Freigaben setzen). Anschließend kann die Achse bewegt werden.
Freigaben setzen
–
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Befolgen Sie dazu die Anweisungen im Kapitel Inbetriebnahme ohne die NC.
▪
Über die zyklische Variable Target position (Abb. Vorgabe Position) können Sie eine Position vorgeben. Der Wert muss mit dem berechneten Skalierungsfaktor multipliziert werden, um die korrekte Position zu erhalten.
Vorgabe Position
Schleppfehlerüberwachung
Weiterhin besteht im CSP Mode die Möglichkeit, eine Schleppfehlerüberwachung einzuschalten. Im Auslieferungszustand ist die Schleppfehlerüberwachung ausgeschaltet. Bei allen anderen Modes kommt dies nicht zum Einsatz und wird ignoriert.
▪
Mit dem Following error window (Index 0x8010:50 MDP742 / Index 0x6065 DS402) lässt sich das Fenster der Schleppfehlerüberwachung einstellen. Der hier eingestellte Wert - mit dem Skalierungsfaktor multipliziert - gibt an, um welche Position die Ist-Position von der Sollposition, positiv und negativ, abweichen darf. Die gesamte akzeptierte Toleranz ist somit doppelt so groß, wie die im Following error window eingetragene Position (siehe Abb. Schleppfehlerfenster).
Schleppfehlerfenster
▪
Mit dem Following error time out (Index 0x8010:51 MDP742 / Index 0x6066 DS402) lässt sich die Zeit (in ms) einstellen, die für eine Schleppfehlerüberschreitung erlaubt ist. Sobald die Sollposition für die im Following error time out eingetragene Zeit um mehr als die im Following error window eingetragene Position überschritten wird, gibt die Box einen Fehler aus und bleibt unverzüglich stehen.
▪
Der aktuelle Schleppfehler kann im Following error actual value (Index 0x6010:09 MDP742 / Index 0x60F4 DS402) ausgelesen werden.
Schleppfehler über die Zeit
Der Wert 0xFFFFFF (-1) im Following error window bedeutet, dass die Schleppfehlerüberwachung ausgeschaltet ist und entspricht dem Auslieferungszustand.
Der Following error time out ist im Auslieferungszustand 0x0000 (0).


Prozessdaten MDP 742

Inbetriebnahme [image] Prozessdaten MDP 742
Prozessdaten MDP 742
Inhaltsverzeichnis
• Sync Manger
• PDO-Zuordnung
• Predefined PDO Assignment
Sync Manager (SM)
Sync Manager (SM) Der Umfang der angebotenen Prozessdaten kann über den Reiter „Prozessdaten“ verändert werden (siehe folgende Abb.).
Karteireiter Prozessdaten SM2, EP7211 (default)
Karteireiter Prozessdaten SM3, EP7211 (default)
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld „Sync Manager“ (siehe Abb. Karteireiter Prozessdaten SM3) den gewünschten Sync Manager (editierbar sind hier SM 2 + 3). Im Feld darunter „PDO Zuordnung“ können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Box übertragen.
SM2, PDO-Zuordnung 0x1C12
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 (default) | 2.0 | DRV Controlword | Index 0x7010:01
0x1601 (default) | 4.0 | DRV Target velocity | Index 0x7010:06
0x1602 | 2.0 | DRV Target torque | Index 0x7010:09
0x1603 | 2.0 | DRV Commutation angle | Index 0x7010:0E
0x1604 | 2.0 | DRV Torque limitation | Index 0x7010:0B
0x1605 | 2.0 | DRV Torque offset | Index 0x7010:0A
0x1606 | 4.0 | DRV Target position | Index 0x7010:05
0x1607 | 2.0 | FB Touch probe control | Index 0x7001:0
 |  |  | Index 0x7001:01 Index 0x7001:02 Index 0x7001:03 Index 0x7001:05 Index 0x7001:06 Index 0x7001:09 Index 0x7001:0A Index 0x7001:0B Index 0x7001:0D Index 0x7001:0E | TP1 Enable TP1 Continous TP1 Trigger mode TP1 Enable pos. edge TP1 Enable neg. edge TP2 Enable TP2 Continous TP2 Trigger mode TP2 Enable pos. edge TP2 Enable neg. edge
SM3, PDO-Zuordnung 0x1C13
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 (default) | 4.0 | FB Position | Index 0x6000:11
0x1A01 (default) | 2.0 | DRV Statusword | Index 0x6010:01
0x1A02 | 4.0 | DRV Velocity actual value | Index 0x6010:07
0x1A03 | 2.0 | DRV Torque actual value | Index 0x6010:08
0x1A04 | 2.0 | DRV Info data 1 | Index 0x6010:12
0x1A05 | 2.0 | DRV Info data 2 | Index 0x6010:13
0x1A06 | 4.0 | DRV Following error actual value | Index 0x6010:09
0x1A07 | 2.0 | FB Touch probe status | Index 0x6001:0
 |  |  | Index 0x6001:01 Index 0x6001:02 Index 0x6001:03 Index 0x6001:08 Index 0x6001:09 Index 0x6001:0A Index 0x6001:0B Index 0x6001:10 | TP1 Enable TP1 Pos. value stored TP1 Neg. value stored TP1 Input TP2 Enable TP2 Pos. value stored TP2 Neg. value stored TP2 Input
0x1A08 | 4.0 | FB Touch probe 1 pos. position | Index 0x6001:11
0x1A09 | 4.0 | FB Touch probe 1 neg. position | Index 0x6001:12
0x1A0A | 4.0 | FB Touch probe 2 pos. position | Index 0x6001:13
0x1A0B | 4.0 | FB Touch probe 2 neg. position | Index 0x6001:14
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Folgende PDO-Zuordnungen stehen zur Auswahl:
Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
Cyclic synchronous velocity mode (CSV) | 0x1600 (DRV Controlword) 0x1601 (DRV Target velocity) | 0x1A00 (FB Position) 0x1A01 (DRV Statusword)
Cyclic synchronous torque mode (CST) | 0x1600 (DRV Controlword) 0x1602 (DRV Target torque) | 0x1A00 (FB Position) 0x1A01 (DRV Statusword) 0x1A03 (DRV Torque actual value)
Cyclic synchronous torque mode with commutation angle (CSTCA) | 0x1600 (DRV Controlword) 0x1602 (DRV Target torque) 0x1603 (DRV Commutation angle) | 0x1A01 (DRV Statusword)
Cyclic synchronous position mode (CSP) | 0x1600 (DRV Controlword) 0x1606 (DRV Target position) | 0x1A00(FB Position) 0x1A01(DRV Statusword)
Karteireiter Prozessdaten Predefined PDO Assignment


Prozessdaten DS402

Inbetriebnahme [image] Prozessdaten DS402
Prozessdaten DS402
Inhaltsverzeichnis
Sync Manger
PDO-Zuordnung
Predefined PDO Assignment
Sync Manager (SM)
Sync Manager (SM) Der Umfang der angebotenen Prozessdaten kann über den Reiter „Prozessdaten“ verändert werden (siehe Abb. Karteireiter Prozessdaten SM2 (default)).
Karteireiter Prozessdaten SM2 (default)
Karteireiter Prozessdaten SM3 (default)
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld „Sync Manager“ (siehe Abb.) den gewünschten Sync Manager (editierbar sind hier SM 2 + 3). Im Feld darunter „PDO Zuordnung“ können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Box übertragen.
SM2, PDO-Zuordnung 0x1C12
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 (default) | 2.0 | DS402 Controlword | Index 0x6040
0x1601 (default) | 4.0 | DS402 Target velocity | Index 0x60FF
0x1602 | 2.0 | DS402 Target torque | Index 0x6071
0x1603 | 2.0 | DS402 Commutation angle | Index 0x60EA
0x1604 | 2.0 | DS402 Torque limitation | Index 0x6072
0x1605 | 2.0 | DS402 Torque offset | Index 0x2001:11
0x1606 | 4.0 | DS402 Target position | Index 0x607A
0x1607 | 2.0 | DS402 FB Touch probe cfunction | Index 0x60B8
 |  |  | Bit 0 Bit 1 Bit 2 Bit 4 Bit 5 Bit 8 Bit 9 Bit 10 Bit 12 Bit 13 | TP1 Enable TP1 Continous TP1 Trigger mode TP1 Enable pos. edge TP1 Enable neg. edge TP2 Enable TP2 Continous TP2 Trigger mode TP2 Enable pos. edge TP2 Enable neg. edge
SM3, PDO-Zuordnung 0x1C13
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 (default) | 2.0 | DS402 Statusword | Index 0x6041
0x1A01 (default) | 4.0 | DS402 Position actual value | Index 0x6064
0x1A02 | 4.0 | DS402 Velocity actual value | Index 0x606C
0x1A03 | 2.0 | DS402 Torque actual value | Index 0x6077
0x1A04 | 4.0 | DS402 Following error actual value | Index 0x60F4
0x1A05 | 2.0 | DS402 Touch probe status | Index 0x60B9
 |  |  | Bit 0 Bit 1 Bit 2 Bit 7 Bit 8 Bit 9 Bit 10 Index 6001:10 | TP1 Enable TP1 Pos. value stored TP1 Neg. value stored TP1 Input TP2 Enable TP2 Pos. value stored TP2 Neg. value stored TP2 Input
0x1A06 | 4.0 | DS402 Touch probe 1 pos. position | Index 0x60BA
0x1A07 | 4.0 | DS402 Touch probe 1 neg. position | Index 0x60BB
0x1A08 | 4.0 | DS402 Touch probe 2 pos. position | Index 0x60BC
0x1A09 | 4.0 | DS402 Touch probe 2 neg. position | Index 0x60BD
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Folgende PDO-Zuordnungen stehen zur Auswahl:
Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
Cyclic synchronous velocity mode (CSV) | 0x1600 (DS402 Controlword) 0x1601 (DS402 Target velocity) | 0x1A00 (DS402 Statusword) 0x1A01 (DS402 Position actual value)
Cyclic synchronous torque mode (CST) | 0x1600 (DS402 Controlword) 0x1602 (DS402 Target torque) | 0x1A00 (DS402 Statusword) 0x1A01 (DS402 Position actual value) 0x1A03 (DS402 Torque actual value)
Cyclic synchronous torque mode with commutation angle (CSTCA) | 0x1600 (DS402 Controlword) 0x1602 (DS402 Target torque) 0x1603 (DS402 Commutation angle) | 0x1A00 (DS402 Statusword)
Cyclic synchronous position mode (CSP) | 0x1600 (DS402 Controlword) 0x1606 (DS402 Target position) | 0x1A00 (DS402 Statusword) 0x1A01 (DS402 Position actual value)
Karteireiter Prozessdaten Predefined PDO Assignment


Objektbeschreibung (MDP 742)

Inbetriebnahme [image] Objektbeschreibung (MDP 742)
Objektbeschreibung (MDP 742)
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Box wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Hinweis
Beschädigung des Gerätes möglich!
Es wird dringend davon abgeraten, die Einstellungen in den CoE-Objekten zu ändern während die Achse aktiv ist, da die Reglung beeinträchtigt werden könnte.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Konfigurationsdaten (herstellerspezifisch)
•
Kommando-Objekt
•
Eingangsdaten
•
Ausgangsdaten
•
Informations-/Diagnostikdaten
•
Standardobjekte


Restore-Objekt

Inbetriebnahme [image] Objektbeschreibung (MDP 742) [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung (MDP 742) [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 FB Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | FB Settings | Maximaler Subindex | UINT8 | RO | 0x13 (19dez)
8000:01 | Invert feedback direction | Zählrichtung invertieren | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Referenced |  | BOOLEAN | RW | 0x00 (0dez)
8000:11 | Device type | 3: OCT (nicht änderbar) | UINT32 | RW | 0x00000003 (3dez)
8000:12 | Singleturn bits | Anzahl der Singleturn-Bits | UINT8 | RW | 0x14 (20dez)
8000:13 | Multiturn bits | Anzahl der Multiturn-Bits | UINT8 | RW | 0x0C (12dez)
8000:14 | Observer bandwidth | Bandbreite des Drehzahlbeobachters [Hz] | UINT16 | RW | 0x01F4 (500dez)
8000:15 | Observer feed-forward | Lastverhältnis [%] 100 % = Lastfrei 50 % = Massenträgheitsmomente von An- und Abtrieb sind gleich | UINT8 | RW | 0x01 (0dez)
8000:17 | Position Offset |  | UINT32 | RW | 0x00000000 (0dez)
Index 8008 FB OCT Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8008:0 | FB OCT Settings | Maximaler Subindex | UINT8 | RO | 0x00 (0dez)
8008:01 | Enable autoconfig | Nach dem Einslesen des elektronischen Typenschilds wird automatisch konfiguriert (siehe Automatisches Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)
8008:02 | Reconfig identical motor | Bei Austausch identischer Motoren wird nach dem Einlesen des elekronischen Typenschilds automatisch neu konfiguriert. Enable autoconfig muss eingeschaltet sein. (siehe Automatisches Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)
8008:03 | Reconfig non-identical motor | Bei Austausch nicht-identischer Motoren wird nach dem Einlesen des elekronischen Typenschilds automatisch neu konfiguriert. Enable autoconfig muss eingeschaltet sein. (siehe Automatisches Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)
Index 8010 DRV Amplifier Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:0 | DRV Amplifier Settings | Maximaler Subindex | UINT8 | RO | 0x42 (66dez)
8010:01 | Enable TxPDOToggle | TxPDO Toggle im Statuswort (Bit 10) einblenden | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Enable input cyle counter | 1: aktiviert Zwei-Bit-Zähler, der mit jedem Prozessdatenzyklus bis zum Maximalwert von 3 inkrementiert wird und danach wieder bei 0 beginnt Das Low-Bit wird in Bit 10 und das Hi-Bit in Bit 14 vom Status-Wort dargestellt. | BOOLEAN | RW | 0x00 (0dez)
8010:11 | Device type | 1: Servo drive (nicht änderbar) | UINT32 | RW | 0x00000001 (1dez)
8010:12* | Current loop integral time | Integralanteil Stromregler Einheit: 0,1 ms Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x000A (10dez)
8010:13* | Current loop proportional gain | Proportionalanteil Stromregler Einheit: 0,1 V/A Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0064 (100dez)
8010:14 | Velocity loop integral time | Integralanteil Geschwindigkeitsregler Einheit: 0,1 ms | UINT32 | RW | 0x00000032 (50dez)
8010:15 | Velocity loop proportional gain | Proportionalanteil Geschwindigkeitsregler Einheit: mA / (rad/s) | UINT32 | RW | 0x00000096 (150dez)
8010:17 | Position loop proportional gain | Proportionalanteil Positionsregler Einheit: (rad/s) / rad | UINT32 | RW | 0x0000000A (10dez)
8010:19 | Nominal DC link voltage | Nenn-Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x0000BB80 (48000dez)
8010:1A | Min DC link voltage | Minimale Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x00001A90 (6800dez)
8010:1B | Max DC link voltage | Maximale Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x0000EA60 (60000dez)
8010:29 | Amplifier I2T warn level | I²T-Modell Warnschwelle Einheit: % | UINT8 | RW | 0x50 (80dez)
8010:2A | Amplifier I2T error level | I²T-Modell Fehlerschwelle Einheit: % | UINT8 | RW | 0x69 (105dez)
8010:2B | Amplifier Temperature warn level | Übertemperatur Warnschwelle Einheit: 0,1 °C | UINT16 | RW | 0x0320 (800dez)
8010:2C | Amplifier Temperature error level | Übertemperatur Fehlerschwelle Einheit: 0,1 °C | UINT16 | RW | 0x03E8 (1000dez)
8010:31 | Velocity limitation | Drehzahlbegrenzung Einheit: 1/min | UINT32 | RW | 0x00040000 (262144dez)
8010:32 | Short-Circuit Brake duration max | Max. Dauer der Anker-Kurzschluss-Bremse Einheit: ms | UINT16 | RW | 0x03E8 (1000dez)
8010:33 | Stand still window | Stillstandsfenster Einheit: 1/min | UINT16 | RW | 0x0000 (0dez)
*) siehe Index 9009 FB OCT Nameplate
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:39 | Select info data 1 | Auswahl "Info data 1" Hier kann eine zusätzliche Information in den zyklischen Prozessdaten angezeigt werden. Folgende Informationen stehen zur Auswahl. | UINT8 | RW | 0x01 (1dez)
 |  | Torque current (filtered 1ms) [1000stel vom rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0,1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder Bit8: Watchdog
 |  | Warnings: Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level
8010:3A | Select info data 2 | Auswahl "Info data 2" Hier kann eine zusätzliche Information in den zyklischen Prozessdaten angezeigt werden. Folgende Informationen stehen zur Auswahl. | UINT8 | RW | 0x01 (1dez)
 |  | Torque current (filtered 1ms) [1000stel vom rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0,1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder Bit8: Watchdog
 |  | Warnings: Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level
8010:41 | Low-pass filter frequency | Lastfilterfrequenz Einheit: Hz Es können folgende Werte eingestellt werden: 0 Hz = Aus 160 Hz 320 Hz | UINT16 | RW | 0x0140 (320dez)
8010:49 | Halt ramp deceleration | Verzögerung der Drehzahl-Halterampe Einheit: 0,1 rad / s² | UINT32 | RW | 0x0000F570 (62832dez)
8010:50 | Following error window | Schleppabstandsüberwachung: Schleppfehlerfenster Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden 0xFFFFFFFF (-1dez) = Schleppabstandsüberwachung aus Jeder andere Wert = Schleppabstandsüberwachung ein | UINT32 | RW | 0xFFFFFFFF (-1 dez)
8010:51 | Following error time out | Schleppabstandsüberwachung: Timeout Einheit: ms Ist der Schleppfehler größer als das Schleppfehlerfenster, für eine Zeit, die größer ist als der Timeout, führt das zu einer Fehlerreaktion | UINT16 | RW | 0x0000 (0 dez)
8010:52 | Fault reaction option code | Erlaubte Werte 0: Disable drive function, motor is free to rotate 1: Slow down on slow down ramp | UINT16 | RW | 0x0000 (0 dez)
8010:53 | Position loop proportional gain | Proportionalanteil Positionssregler Einheit: mA / (rad/s) | UINT32 | RW | 0x00000000 (0 dez)
8010:54 | Feature bits | Die einstellbaren Motorstromwerte können als Scheitelwert oder Effektivwert interpretiert werden. Das Feature Bit ermöglicht die Umstellung. Scheitelwert → Bit 0 = 0 (default) Effektivwert → Bit 0 = 1 normaler Ausgangsstrom → Bit 1 = 0 (default) erhöhter Ausgangsstrom → Bit 1 = 1 Daraus lassen sich folgende Kombinationen in einstellen: 0dez → normaler Ausgangsstrom in Scheitelwert interpretiert 1dez → normaler Ausgangsstrom in Effektivwert interpretiert 2dez → erhöhter Ausgangsstrom in Scheitelwert interpretiert 3 dez → erhöhter Ausgangsstrom in Effektivwert interpretiert | UINT32 | RW | 0x00000000 (0 dez)
*) siehe Index 9009 FB OCT Nameplate
Index 8011 DRV Motor Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8011:0 | DRV Motor Settings | Maximaler Subindex | UINT8 | RO | 0x2D (45dez)
8011:11* | Max current | Spitzenstrom Einheit: mA Die einstellbaren Motorstromwerte können als Scheitelwert oder Effektivwert interpretiert werden. Das Feature Bit (8010:54) ermöglicht die Umstellung. Scheitelwert → Bit 0 = 0 (default) Effektivwert → Bit 0 = 1 Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00001770 (6000dez)
8011:12* | Rated current | Nennstrom Einheit: mA Die einstellbaren Motorstromwerte können als Scheitelwert oder Effektivwert interpretiert werden. Das Feature Bit (8010:54) ermöglicht die Umstellung. Scheitelwert → Bit 0 = 0 (default) Effektivwert → Bit 0 = 1 Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT32 | RW | 0x000003E8 (1000dez)
8011:13* | Motor pole pairs | Anzahl der Polpaare Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT8 | RW | 0x03 (3dez)
8011:15* | Commutation offset | Kommutierungs-Offset (zwischen elektrischer Nullposition und mechanischer Single-Turn Nullposition) Einheit: Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | INT16 | RW | 0x0000 (0dez)
8011:16* | Torque constant | Drehmoment-Konstante Einheit: mNm / A Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00000000 (0dez)
8011:18* | Rotor moment of inertia | Massenträgheitsmoment des Motors Einheit: g cm^2 Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00000000 (0dez)
8011:19* | Winding inductance | Induktivität Einheit: 0,1 mH Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x000E (14dez)
8011:1B* | Motor speed limitation | Drehzahlbegrenzung Einheit: 1/min Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00040000 (262144dez)
*) siehe Index 9009 FB OCT Nameplate
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8011:29 | I2T warn level | I2T-Modell Warnschwelle Einheit: % | UINT8 | RW | 0x50 (80dez)
8011:2A | I2T error level | I2T-Modell Fehlerschwelle Einheit: % | UINT8 | RW | 0x69 (105dez)
8011:2B* | Motor Temperature warn level | Übertemperatur Warnschwelle Einheit: 0,1 °C Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x03E8 (1000dez)
8011:2C* | Motor Temperature error level | Übertemperatur Fehlerschwelle Einheit: 0,1 °C Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x05DC (1500dez)
8011:2D* | Motor thermal time constant | Thermische Zeitkonstante Einheit: 0,1 s Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0028 (40dez)
*) siehe Index 9009 FB OCT Nameplate
Index 8012 DRV Brake Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8012:0 | DRV Brake Settings | Maximaler Subindex | UINT8 | RO | 0x14 (20dez)
8012:01 | Manual override (release) | Manuelles Lösen der Motorhaltebremse | BOOLEAN | RW | 0x00 (0dez)
8012:11* | Release delay | Zeit, die die Haltebremse zum Öffnen (Lösen) benötigt, nachdem der Strom angelegt wurde Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
8012:12* | Application delay | Zeit, die die Haltebremse zum Schließen (Halten) benötigt, nachdem der Strom abgeschaltet wurde Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
8012:13 | Emergency application timeout | Zeit, die der Verstärker abwartet, bis die Drehzahl nach Halt-Anforderung (Solldrehzahl 0 nach Halterampe oder Torque off) das Stillstandfenster erreicht. Bei Überschreiten der eingestellten Wartezeit wird die Haltebremse unabhängig von der Drehzahl ausgelöst. Hinweis: Bei rotatorischen Achsen und der Einstellung Torque off für den Fehlerfall muss dieser Parameter mindestens auf die längste Zeit des „Austrudelns“ der Achse angepasst werden. Bei hängenden Achsen und der Einstellung Torque off für den Fehlerfall sollte dieser Parameter auf eine sehr kurze Zeit eingestellt werden, um ein weites Absacken der Achse/Last zu verhindern. | UINT16 | RW | 0x0000 (0dez)
8012:14* | Brake moment of inertia | Massenträgheitsmoment der Bremse Einheit: g cm^2 Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
*) siehe Index 9009 FB OCT Nameplate


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] Objektbeschreibung (MDP 742) [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index 801F DRV Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801F:0 | DRV Vendor data | Maximaler Subindex | UINT8 | RO | 0x14 (20dez)
801F:11 | Amplifier peak current | Spitzenstrom des Verstärkers (Scheitelwert) Einheit: mA | UINT32 | RW | 0x00001F40 (8000dez)
801F:12 | Amplifier rated current | Nennstrom des Verstärkers (Scheitelwert) Einheit: mA | UINT32 | RW | 0x00000FA0 (4000dez)
801F:13 | Amplifier thermal time constant | Thermische Zeitkonstante des Verstärkers Einheit: 0,1 ms | UINT16 | RW | 0x0023 (35dez)
801F:14 | Amplifier overcurrent threshold | Schwellwert für Kurzschlusserkennung Einheit: mA | UINT32 | RW | 0x00002EE0 (12000dez)


Kommando-Objekt

Inbetriebnahme [image] Objektbeschreibung (MDP 742) [image] Kommando-Objekt
Kommando-Objekt
Index FB00 Command
Index (hex) | Name | Bedeutung |  |  | Datentyp | Flags | Default
FB00:0 | DCM Command | Max. Subindex |  |  | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | 0x1100 | Get build number | Auslesen der Build-Nummer | OCTET-STRING[2] | RW | {0}
 |  | 0x1101 | Get build date | Auslesen des Build-Datums
 |  | 0x1102 | Get build time | Auslesen der Build-Zeit
FB00:02 | Status | 0 | Finished, no error, no response | Kommando ohne Fehler und ohne Antwort (Response ) beendet | UINT8 | RO | 0x00 (0dez)
 |  | 1 | Finished, no error, response | Kommando ohne Fehler und mit Antwort beendet
 |  | 2 | Finished, error, no response | Kommando mit Fehler und ohne Antwort beendet
 |  | 3 | Finished, error, response | Kommando mit Fehler und mit Antwort beendet
 |  | 255 | Executing | Kommando wird ausgeführt
FB00:03 | Response | abhängig vom Request |  |  | OCTET-STRING[4] | RO | {0}


Eingangsdaten

Inbetriebnahme [image] Objektbeschreibung (MDP 742) [image] Eingangsdaten
Eingangsdaten
Index 6000 FB Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | FB Inputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
6000:11 | Position | Position | UINT32 | RO | 0x00000000 (0dez)
Index 6001 FB Touch probe inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6001:0 | FB Touch probe inputs | Maximaler Subindex | UINT8 | RO | 0x14 (20dez)
6001:01 | TP1 Enable | Touchprobe 1 eingeschaltet | BOOLEAN | RO | 0x00 (0dez)
6001:02 | TP1 pos value stored | Positiver Wert von Touchprobe 1 gespeichert | BOOLEAN | RO | 0x00 (0dez)
6001:03 | TP1 Neg value stored | Negativer Wert von Touchprobe 1 gespeichert | BOOLEAN | RO | 0x00 (0dez)
6001:09 | TP2 Enable | Touchprobe 2 eingeschaltet | BOOLEAN | RO | 0x00 (0dez)
6001:0A | TP2 pos value stored | Positiver Wert von Touchprobe 2 gespeichert | BOOLEAN | RO | 0x00 (0dez)
6001:0B | TP2 neg value stored | Negativer Wert von Touchprobe 2 gespeichert | BOOLEAN | RO | 0x00 (0dez)
6001:11 | TP1 pos position | Positiver Wert von Touchprobe 1 Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | UINT32 | RO | 0x00000000 (0dez)
6001:12 | TP1 neg position | Negativer Wert von Touchprobe 1 Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | UINT32 | RO | 0x00000000 (0dez)
6001:13 | TP2 pos position | Positiver Wert von Touchprobe 2 Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | UINT32 | RO | 0x00000000 (0dez)
6001:14 | TP2 neg position | Negativer Wert von Touchprobe 2 Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | UINT32 | RO | 0x00000000 (0dez)
Index 6010 DRV Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | DRV Inputs | Maximaler Subindex | UINT8 | RO | 0x13 (19dez)
6010:01 | Statusword | Statusword Bit 0: Ready to switch on Bit 1: Switched on Bit 2: Operation enabled Bit 3: Fault Bit 4: reserved Bit 5: Quick stop (inverse) Bit 6: Switch on disabled Bit 7: Warning Bit 8 + 9: reserved Bit 10: TxPDOToggle (An-/Abwahl über 0x8010:01) Bit 11: Internal limit active Bit 12: (Target value ignored) Bit 13 - 15: reserved | UINT16 | RO | 0x0000 (0dez)
6010:03 | Modes of operation display | Anzeige des Betriebsmodus. Erlaubte Werte: 9: Cyclic synchronous velocity mode (CSV) 10: Cyclic synchronous torque mode (CST) 11: Cyclic synchronous torque mode with commutation angle (CSTCA) | UINT8 | RO | 0x00 (0dez)
6010:06 | Following error actual value | Schleppfehler Einheit : der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
6010:07 | Velocity actual value | Anzeige des aktuellen Geschwindigkeitswertes Einheit: siehe Index 0x9010:14 | INT32 | RO | 0x00000000 (0dez)
6010:08 | Torque actual value | Anzeige des aktuellen Drehmomentwertes Der Wert wird in 1000stel vom rated current (0x8011:12) angegeben Formel für Index 8010:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16) Formel für Index 8010:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16) | INT16 | RO | 0x0000 (0dez)
6010:12 | Info data 1 | Synchrone Informationen (Auswahl über Subindex 0x8010:39) | UINT16 | RO | 0x0000 (0dez)
6010:13 | Info data 2 | Synchrone Informationen (Auswahl über Subindex 0x8010:3A) | UINT16 | RO | 0x0000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] Objektbeschreibung (MDP 742) [image] Ausgangsdaten
Ausgangsdaten
Index 7001 FB Touch probe outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7001:0 | FB Touch probe outputs | Maximaler Subindex | UINT8 | RO | 0x0E (14dez)
7001:01 | TP1 Enable | Touchprobe 1 einschalten | BOOLEAN | RO | 0x00 (0dez)
7001:02 | TP1 Continous | 0: Es wird nur beim ersten Event getriggert 1. Es wird bei jedem Event getriggert | BOOLEAN | RO | 0x00 (0dez)
7001:03 | TP1 Trigger mode | Es wird Input 1 getriggert (nicht änderbar) | BIT2 | RO | 0x00 (0dez)
7001:05 | TP1 Enable pos edge | Bei positiver Flanke triggern | BOOLEAN | RO | 0x00 (0dez)
7001:06 | TP1 Enable neg edge | Bei negativer Flanke triggern | BOOLEAN | RO | 0x00 (0dez)
7001:09 | TP2 Enable | Touchprobe 2 einschalten | BOOLEAN | RO | 0x00 (0dez)
7001:0A | TP2 Continous | 0: Es wird nur beim ersten Event getriggert 1. Es wird bei jedem Event getriggert | BOOLEAN | RO | 0x00 (0dez)
7001:0B | TP2 Trigger mode | Es wird Input 2 getriggert (nicht änderbar) | BIT2 | RO | 0x00 (0dez)
7001:0D | TP2 Enable pos edge | Bei positiver Flanke triggern | BOOLEAN | RO | 0x00 (0dez)
7001:0E | TP2 Enable neg edge | Bei negativer Flanke triggern | BOOLEAN | RO | 0x00 (0dez)
Index 7010 DRV Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | DRV Outputs | Maximaler Subindex | UINT8 | RO | 0x0E (14dez)
7010:01 | Controlword | Controlword Bit 0: Switch on Bit 1: Enable voltage Bit 2: Quick stop (inverse) Bit 3: Enable operation Bit 4 - 6: reserved Bit 7: Fault reset Bit 8 - 15: reserved | UINT16 | RO | 0x0000 (0dez)
7010:03 | Modes of operation | Erlaubte Werte: 0x08: Cyclic synchronous position mode (CSP) 0x09: Cyclic synchronous velocity mode (CSV) 0x0A: Cyclic synchronous torque mode (CST) 0x0B: Cyclic synchronous torque mode with commutation angle (CSTCA) | UINT8 | RW | 0x00 (0dez)
7010:05 | Target position | Konfigurierte Ziel-Position Einheit: der Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RW | 0x00000000 (0dez)
7010:06 | Target velocity | Konfigurierte Ziel-Geschwindigkeit Die Geschwindigkeitsskalierung kann dem Objekt 0x9010:14 ("Velocity encoder resolution") entnommen werden | INT32 | RO | 0x00000000 (0dez)
7010:09 | Target torque | Konfigurierter Eingangswert der Drehmoment-Überwachung Der Wert wird in 1000stel vom rated current (0x8011:12) angegeben Formel für Index 8010:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16) Formel für Index 8010:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16) | INT16 | RO | 0x0000 (0dez)
7010:0A | Torque offset | Offset des Drehmoment-Wertes Der Wert wird in 1000stel vom rated current (0x8011:12) angegeben Formel für Index 8010:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16) Formel für Index 8010:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16) | INT16 | RO | 0x0000 (0dez)
7010:0B | Torque limitation | Grenzwert des Drehmomentes für die Drehmoment-Überwachung (Bipolar Limit) Der Wert wird in 1000stel vom rated current (0x8011:12) angegeben Formel für Index 8010:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16) Formel für Index 8010:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16) | UINT16 | RW | 0x7FFF (32767dez)
7010:0E | Commutation angle | Kommutierungs-Winkel (für CSTCA Modus) Einheit: 360° / 216 | UINT16 | RO | 0x0000 (0dez)


Informations-/Diagnostikdaten

Inbetriebnahme [image] Objektbeschreibung (MDP 742) [image] Informations-/Diagnostikdaten
Informations-/Diagnostikdaten
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x37 (55dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Nachricht 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |
Index 9008 FB OCT Info data
(diese Daten werden immer automatisch aus dem elektronischen Typenschild des Motors eingelesen und dienen rein informativen Zwecken)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9008:0 | FB OCT Info data | Maximaler Subindex | UINT8 | RO | 0x1F (31dez)
9008:11 | Encoder Type | Feedbacktyp 2: Dreh-Encoder, unipolare Zählung | UINT16 | RO | 0x0000 (0dez)
9008:12 | Resolution | Auflösung des Feedbacks Einheit: Schritte pro Umdrehung | UINT32 | RO | 0x00000000 (0dez)
9008:13 | Range | Arbeitsbereich des Feedbacks. Beim Verlassen dieses Bereichs gibt es einen Überlauf der Position. Einheit: Umdrehungen | UINT32 | RO | 0x00000000 (0dez)
9008:14 | Type Code Name | Name des Feedbacks | STRING | RO |
9008:15 | Serial No | Seriennummer des Feedbacks | STRING | RO |
9008:16 | Firmware Revision No | Revision der Firmware | STRING | RO |
9008:17 | Firmware Date | Datum der Firmware | STRING | RO |
9008:18 | EEPROM Size | EEPROM Größe | UINT16 | RO | 0x0000 (0dez)
9008:19 | Temperature | Temperatur Einheit: 0,1° | INT16 | RO | 0x0000 (0dez)
9008:1A | LED Current | Strom der Feedback-LED Einheit: 0,1 mA | UINT16 | RO | 0x0000 (0dez)
9008:1B | Supply voltage | Versorgungsspannung des Feedbacks Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
9008:1C | Life- time | Betriebsstundenzähler Einheit: Minuten | UINT32 | RO | 0x00000000 (0dez)
9008:1D | Received Signal Strength Indicator | Empfangssignalstärke an der Box Einheit: % | UINT16 | RO | 0x0000 (0dez)
9008:1E | Slave Received Signal Strength Indicator | Empfangssignalstärke am Geber Einheit: % | UINT16 | RO | 0x0000 (0dez)
9008:1F | Line delay | Laufzeit des Signals im Kabel Einheit: ns | UINT16 | RO | 0x0000 (0dez)
Index 9009 FB OCT Nameplate
Die in diesem Index beschriebenen Parameter werden immer aus dem elektronischen Typenschild des angeschlossenen Motors gelesen. Aus diesen Parametern ergeben sich die in diesem Kapitel mit Sternchen (*) markierten Parameter automatisch, wenn das Automatische Scannen des elektronischen Typenschild eingeschaltet ist (Index 8008).
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9009:0 | FB OCT Nameplate | Maximaler Subindex | UINT8 | RO | 0x24 (36dez)
9009:01 | Motor vendor | Motorhersteller | STRING | RO |
9009:02 | Electric motor type | Motortyp | STRING | RO |
9009:03 | Serial No | Seriennummer | STRING | RO |
9009:04 | Order code | Bestellnummer (Auf diesen Index wird beim Autoconfig geprüft, ob der Motor identisch zum Vorgänger ist) | STRING | RO |
9009:05 | Motor construction | Art des Motors | STRING | RO |
9009:06 | Pole pairs | Polpaarzahl | UINT32 | RO | 0x00000000 (0dez)
9009:07 | Standstill current (rms) | Effektiver Haltestrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
9009:08 | Rated current (rms) | Effektiver Nennstrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
9009:09 | Peak current (rms) | Effektiver Spitzenstrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
9009:0A | Nominal voltage (rms) | Effektive Nennspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
9009:0B | Max voltage (rms) | Maximale Spannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
9009:0C | Max winding du/dt | Maximal zulässige Spannungsanstieg an der Spule Einheit: kV/s | UINT32 | RO | 0x00000000 (0dez)
9009:0D | Max torque | Maximales Drehmoment Einheit: mNm | UINT16 | RO | 0x0000 (0dez)
9009:0E | Torque constant | Drehmoment-Konstante Einheit: mNm / A | UINT16 | RO | 0x0000 (0dez)
9009:0F | EMK (rms) | Gegenspannung Einheit: mV / (1/min) | UINT32 | RO | 0x00000000 (0dez)
9009:10 | Winding resistance Ph-Ph 20°C | Spulenwiderstand Einheit: mOhm | UINT16 | RO | 0x0000 (0dez)
9009:11 | Ld Ph-Ph | Induktivität in Flussrichtung Einheit: 0,1 mH | UINT16 | RO | 0x0000 (0dez)
9009:12 | Lq Ph-Ph | Induktivität in momentbildene Richtung Einheit: 0,1 mH | UINT16 | RO | 0x0000 (0dez)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
9009:13
Max speed
Maximale Geschwindigkeit
Einheit: 1/min
UINT32
RO
0x00000000 (0dez)
9009:14
Moment of inertia
Massenträgheitsmoment
Einheit: g cm^2
UINT16
RO
0x0000 (0dez)
9009:15
T motor warn limit
Warnungsschwelle Motortemperatur
Einheit: 0,1°C
UINT16
RO
0x0000 (0dez)
9009:16
T motor shut down
Fehlerschwelle Motortemperatur
Einheit: 0,1°C
UINT16
RO
0x0000 (0dez)
9009:17
Time constant i2t
Zeitkonstante I2T-Modell
Einheit: s
UINT16
RO
0x0000 (0dez)
9009:18
Motor thermal constant
Thermische Zeitkonstante des Motors
Einheit: s
UINT16
RO
0x0000 (0dez)
9009:1B
Brake type
Typ der Bremse
▪
no Brake
▪
holding Brake
STRING
RO
9009:1C
Min brake voltage
Minimale Bremsspannung
Einheit: mV
UINT32
RO
0x00000000 (0dez)
9009:1D
Max brake voltage
Maximale Bremsspannung
Einheit: mV
UINT32
RO
0x00000000 (0dez)
9009:1E
Min brake monitor current
Minimaler Strom für die Überwachung der Bremse
Einheit: mA
UINT32
RO
0x00000000 (0dez)
9009:1F
Brake holding torque
Haltemoment der Bremse
Einheit: mNm
UINT32
RO
0x00000000 (0dez)
9009:20
Brake T on
Zeit bis die Bremse anzieht
Einheit: ms
UINT16
RO
0x0000 (0dez)
9009:21
Brake T off
Zeit bis die Bremse löst
Einheit: ms
UINT16
RO
0x0000 (0dez)
9009:22
Brake reduced holding voltage
Reduzierte Spannung der Bremse
Einheit: mV
UINT32
RO
0x00000000 (0dez)
9009:23
Brake time to red. holding volt.
Zeit ab der die Bremse mit reduzierter Spannung hält
Einheit: ms
UINT16
RO
0x0000 (0dez)
9009:24
Motor temp sensor connection
Anschluss des Temperatursensors
Feedback port (nicht änderbar)
STRING
RO
Index 9010 DRV Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9010:0 | DRV Info data | Maximaler Subindex | UINT8 | RO | 0x14 (20dez)
9010:11 | Amplifier temperature | Interne Temperatur der Box Einheit: 0,1 °C | UINT16 | RO | 0x0000 (0dez)
9010:12 | DC link voltage | Zwischenkreisspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
9010:13 | Supported drive modes | Informationen der unterstützten Drive Modi. (DS402: Object 0x6502) Es werden nur die Modi CSV, CST, CSTCA und CSP unterstützt Bit 0: PP Bit 1: VL Bit 2: PV Bit 3: TQ Bit 4: R Bit 5: HM Bit 6: IP Bit 7: CSP Bit 8: CSV Bit 9: CST Bit 10: CSTCA Bit 11 - 15: reserved Bit 16-31: Manufacturer-specific | UINT32 | RO | 0x00000000 (0dez)
9010:14 | Velocity encoder resolution | Anzeige der konfigurierten Encoder-Inkremente/s und Motorumdrehungen/s. Die "Velocity Encoder Resolution" wird nach folgender Formel berechnet: Velocity Encoder Resolution = (encoder_increments / s ) / (motor_revolutions / s) | UINT32 | RO | 0x00041893 (268435dez)
Index 9018 DRV Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9018:0 | DRV Info data | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
9018:11 | Auxiliary voltage (10 V) | Hilfsspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
Index A010 DRV Amplifier Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A010:0 | DRV Amplifier Diag data | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
A010:11 | Amplifier I2T temperature | I2T-Modell-Auslastung Einheit: % | UINT8 | RO | 0x00 (0dez)
Index A011 DRV Motor Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A011:0 | DRV Motor Diag data | Maximaler Subindex | UINT8 | RO | 0x13 (19dez)
A011:11 | Motor I2T temperature | I2T-Modell-Auslastung Einheit: % | UINT8 | RO | 0x00 (0dez)
A011:13 | Motor temperature | Temperatur-Auslastung Einheit: ° | INT16 | RO | 0x0000 (0dez)


Standardobjekte

Inbetriebnahme [image] Objektbeschreibung (MDP 742) [image] Standardobjekte
Standardobjekte
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP7211-0034
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1C2B4052 (472596562dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 DRV RxPDO-Map Controlword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | DRV RxPDO-Map Controlword | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x01 (Controlword)) | UINT32 | RO | 0x7010:01, 16
Index 1601 DRV RxPDO-Map Target velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | DRV RxPDO-Map Target velocity | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x06 (Target velocity)) | UINT32 | RO | 0x7010:06, 32
Index 1602 DRV RxPDO-Map Target torque
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | DRV RxPDO-Map Target torque | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x09 (Target torque)) | UINT32 | RO | 0x7010:09, 16
Index 1603 DRV RxPDO-Map Commutation angle
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | DRV RxPDO-Map Commutation angle | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x0E (Commutation angle)) | UINT32 | RO | 0x7010:0E, 16
Index 1604 DRV RxPDO-Map Torque limitation
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | DRV RxPDO-Map Torque limitation | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x0B (Torque limitation)) | UINT32 | RO | 0x7010:0B, 16
Index 1605 DRV RxPDO-Map Torque offset
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | DRV RxPDO-Map Torque offset | PDO Mapping RxPDO 6 | UINT8 | RO | 0x01 (1dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x0A (Torque offset)) | UINT32 | RO | 0x7010:0A, 16
Index 1606 DRV RxPDO-Map Target position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | DRV RxPDO-Map Target position | PDO Mapping RxPDO 7 | UINT8 | RO | 0x01 (1dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x05 (Target position)) | UINT32 | RO | 0x7010:05, 32
Index 1607 FB RxPDO-Map Touch probe control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | FB RxPDO-Map Touch probe control | PDO Mapping RxPDO 8 | UINT8 | RO | 0x0C (12dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x01 (TP1 Enable)) | UINT32 | RO | 0x7001:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x02 (TP1 Continous)) | UINT32 | RO | 0x7001:02, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x03 (TP1 Trigger mode)) | UINT32 | RO | 0x7001:03, 2
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x05 (TP1 Enable pos edge)) | UINT32 | RO | 0x7001:05, 1
1607:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x06 (TP1 Enable neg edge)) | UINT32 | RO | 0x7001:06, 1
1607:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x09 (TP2 Enable)) | UINT32 | RO | 0x7001:09, 1
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0A (TP2 Continous)) | UINT32 | RO | 0x7001:0A, 1
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0B (TP2 Trigger mode)) | UINT32 | RO | 0x7001:0B, 2
1607:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0D (TP2 Enable pos edge)) | UINT32 | RO | 0x7001:0D, 1
1607:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0E (TP2 Enable neg edge)) | UINT32 | RO | 0x7001:0E, 1
1607:0C | SubIndex 012 | 12. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
Index 1A00 FB TxPDO-Map Position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | FB TxPDO-Map Position | PDO Mapping TxPDO 1 | UINT8 | RO | 0x01 (1dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (FB Inputs), entry 0x11 (Position)) | UINT32 | RO | 0x6000:11, 32
Index 1A01 DRV TxPDO-Map Statusword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | DRV TxPDO-Map Statusword | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x01 (Statusword)) | UINT32 | RO | 0x6010:01, 16
Index 1A02 DRV TxPDO-Map Velocity actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | DRV TxPDO-Map Velocity actual value | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x07 (Velocity actual value)) | UINT32 | RO | 0x6010:07, 32
Index 1A03 DRV TxPDO-Map Torque actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | DRV TxPDO-Map Torque actual value | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x08 (Torque actual value)) | UINT32 | RO | 0x6010:08, 16
Index 1A04 DRV TxPDO-Map Info data 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | DRV TxPDO-Map Info data 1 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x01 (1dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x12 (Info data 1)) | UINT32 | RO | 0x6010:12, 16
Index 1A05 DRV TxPDO-Map Info data 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | DRV TxPDO-Map Info data 2 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x13 (Info data 2)) | UINT32 | RO | 0x6010:13, 16
Index 1A06 DRV TxPDO-Map Following error actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | DRV TxPDO-Map Following error actual value | PDO Mapping TxPDO 7 | UINT8 | RO | 0x01 (1dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x01 (Statusword)) | UINT32 | RO | 0x6010:09, 32
Index 1A07 FB TxPDO-Map Touch probe status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | FB TxPDO-Map Touch probe status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x08 (8dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x07 (Velocity actual value)) | UINT32 | RO | 0x6001:01, 1
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x02 (TP1 pos value stored)) | UINT32 | RO | 0x6001:02, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x03 (TP1 Neg value stored)) | UINT32 | RO | 0x6001:03, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x09 (TP2 Enable)) | UINT32 | RO | 0x6001:09, 1
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x0A (TP2 pos value stored)) | UINT32 | RO | 0x6001:0A, 1
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x0B (TP2 neg value stored)) | UINT32 | RO | 0x6001:0B, 1
1A07:08 | SubIndex 008 | 8. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
Index 1A08 FB TxPDO-Map Touch probe 1 pos position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | FB TxPDO-Map Touch probe 1 pos position | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (FP Touch probe inputs), entry 0x11 (TP1 Pos position)) | UINT32 | RO | 0x6001:11, 32
Index 1A09 FB TxPDO-Map Touch probe 1 neg position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | FB TxPDO-Map Touch probe 1 neg position | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x12 (TP1 Neg position)) | UINT32 | RO | 0x6001:12, 32
Index 1A0A FB TxPDO-Map Touch probe 2 pos position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | FB TxPDO-Map Touch probe 2 pos position | PDO Mapping TxPDO 11 | UINT8 | RO | 0x01 (1dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x13 (TP2 Pos position)) | UINT32 | RO | 0x6001:13, 32
Index 1A0B FB TxPDO-Map Touch probe 2 neg position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0B:0 | FB TxPDO-Map Touch probe 2 neg position | PDO Mapping TxPDO 12 | UINT8 | RO | 0x01 (1dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x14 (TP2 neg position)) | UINT32 | RO | 0x6001:14, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:04 | Subindex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:05 | Subindex 005 | 5. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:06 | Subindex 006 | 6. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:07 | Subindex 007 | 7. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:08 | Subindex 008 | 8. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x03 (3dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:08 | Subindex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:09 | Subindex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0A | Subindex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0B | Subindex 011 | 11. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0C | Subindex 012 | 12. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x0003D090 (250000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0x4808 (18440dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0001E848 (125000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
3: DC - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x0003D090 (250000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00001C52 (7250dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x4808 (18440dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x0001E848 (125000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00001C52 (7250dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00001C52 (7250dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0002 (2dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | Profilnummer Encoder Profile | UINT32 | RW | 0x00000201 (513dez)
F010:02 | SubIndex 002 | Profilnummer Servo Drive | UINT32 | RW | 0x000002E6 (742dez)
Index FB40 Memory interface
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB40:0 | Memory interface | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
FB40:01 | Address | reserviert | UINT32 | RW | 0x00000000 (0dez)
FB40:02 | Length | reserviert | UINT16 | RW | 0x0000 (0dez)
FB40:03 | Data | reserviert | OCTET-STRING[8] | RW | {0}


Objektbeschreibung (DS402)

Inbetriebnahme [image] Objektbeschreibung (DS402)
Objektbeschreibung (DS402)
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Box wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Hinweis
Beschädigung des Gerätes möglich!
Es wird dringend davon abgeraten, die Einstellungen in den CoE-Objekten zu ändern während die Achse aktiv ist, da die Reglung beeinträchtigt werden könnte.
Weiterführende Informationen
•
Konfigurationsdaten
•
Konfigurationsdaten (herstellerspezifisch)
•
Kommando-Objekt
•
Eingangsdaten/Ausgangsdaten
•
Informations-/Diagnostikdaten
•
Standardobjekte


Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung (DS402) [image] Konfigurationsdaten
Konfigurationsdaten
Index 2002 Amplifier Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2002:0 | Amplifier Settings | Maximaler Subindex | UINT8 | RO | 0x49 (73dez)
2002:11 | Device type | 1: Servo drive (nicht änderbar) | UINT32 | RW | 0x00000001 (1dez)
2002:12* | Current loop integral time | Integralanteil Stromregler Einheit: 0,1 ms Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x000A (10dez)
2002:13* | Current loop proportional gain | Proportionalanteil Stromregler Einheit: 0,1 V/A Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0064 (100dez)
2002:14 | Velocity loop integral time | Integralanteil Geschwindigkeitsregler Einheit: 0,1 ms | UINT32 | RW | 0x00000032 (50dez)
2002:15 | Velocity loop proportional gain | Proportionalanteil Geschwindigkeitsregler Einheit: mA / (rad/s) | UINT32 | RW | 0x00000096 (150dez)
2002:17 | Position loop proportional gain | Proportionalanteil Positionsregler Einheit: (rad/s) / rad | UINT32 | RW | 0x0000000A (10dez)
2002:19 | Nominal DC link voltage | Nenn-Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x0000BB80 (48000dez)
2002:1A | Min DC link voltage | Minimale Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x00001A90 (6800dez)
2002:1B | Max DC link voltage | Maximale Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x0000EA60 (60000dez)
2002:29 | Amplifier I2T warn level | I²T-Modell Warnschwelle Einheit: % | UINT8 | RW | 0x50 (80dez)
2002:2A | Amplifier I2T error level | I²T-Modell Fehlerschwelle Einheit: % | UINT8 | RW | 0x69 (105dez)
2002:2B | Amplifier temperature warn level | Übertemperatur Warnschwelle Einheit : 0,1 °C | UINT16 | RW | 0x0320 (800dez)
2002:2C | Amplifier temperature error level | Übertemperatur Fehlerschwelle Einheit: 0,1 °C | UINT16 | RW | 0x03E8 (1000dez)
2002:31 | Velocity limitation | Drehzahlbegrenzung Einheit: 1/min | UINT32 | RW | 0x00040000 (262144dez)
2002:32 | Short circuit brake duration max | Max. Dauer der Anker-Kurzschluss-Bremse Einheit: ms | UINT16 | RW | 0x03E8 (1000dez)
2002:33 | Stand still window | Stillstandsfenster Einheit: 1/min | UINT16 | RW | 0x0000 (0dez)
2002:41 | Low-pass filter frequency | Lastfilterfrequenz Einheit: Hz Es können folgende Werte eingestellt werden: 0 Hz = Aus 160 Hz 320 Hz | UINT16 | RW | 0x0140 (320dez)
2002:49 | Halt ramp deceleration | Verzögerung der Drehzahl-Halterampe Einheit: 0,1 rad / s² | UINT32 | RW | 0x0000F570 (62832dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2002:53 | Position loop proportional gain | Proportionalanteil Positionssregler Einheit: mA / (rad/s) | UINT32 | RW | 0x00000000 (0 dez)
2002:54 | Feature bits | Die einstellbaren Motorstromwerte können als Scheitelwert oder Effektivwert interpretiert werden. Das Feature Bit (2002:54) ermöglicht die Umstellung. Scheitelwert → Bit 0 = 0 (default) Effektivwert → Bit 0 = 1 normaler Ausgangsstrom → Bit 1 = 0 (default) erhöhter Ausgangsstrom → Bit 1 = 1 Daraus lassen sich folgende Kombinationen in einstellen: 0dez → normaler Ausgangsstrom in Scheitelwert interpretiert 1dez → normaler Ausgangsstrom in Effektivwert interpretiert 2dez → erhöhter Ausgangsstrom in Scheitelwert interpretiert 3 dez → erhöhter Ausgangsstrom in Effektivwert interpretiert | UINT32 | RW | 0x00000000 (0 dez)
2002:55 | Select info data 1 | Auswahl "Info data 1" Hier kann eine zusätzliche Information in die zyklischen Prozessdaten angezeigt werden. Folgende Informationen stehen zur Auswahl. | UINT8 | RW | 0x00 (0 dez)
 |  | Torque current (filtered 1ms) [1000stel vom rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0,1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder Bit8: Watchdog
 |  | Warnings: Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level
2002:56 | Select info data 2 | Auswahl "Info data 2" Hier kann eine zusätzliche Information in die zyklischen Prozessdaten angezeigt werden. Folgende Informationen stehen zur Auswahl. | UINT8 | RW | 0x00 (0 dez)
 |  | Torque current (filtered 1ms) [1000stel vom rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0,1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder Bit8: Watchdog
 |  | Warnings: Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level
*) siehe Index 2059 OCT Nameplate
Index 2003 Motor Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2003:0 | Motor Settings | Maximaler Subindex | UINT8 | RO | 0x2D (45dez)
2003:11* | Max current | Spitzenstrom Einheit: mA Die einstellbaren Motorstromwerte können als Scheitelwert oder Effektivwert interpretiert werden. Das Feature Bit (2002:54) ermöglicht die Umstellung. Scheitelwert → Bit 0 = 0 (default) Effektivwert → Bit 0 = 1 Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00001770 (6000dez)
2003:13* | Motor pole pairs | Anzahl der Polpaare Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT8 | RW | 0x03 (3dez)
2003:15* | Commutation offset | Kommutierungs-Offset (zwischen elektrischer Nullposition und mechanischer Single-Turn Nullposition) Einheit: ° Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | INT16 | RW | 0x0000 (0dez)
2003:16* | Torque constant | Drehmoment-Konstante Einheit: mNm / A Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00000000 (0dez)
2003:18* | Rotor moment of inertia | Massenträgheitsmoment des Motors Einheit: g cm^2 Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00000000 (0dez)
2003:19* | Winding inductance | Induktivität Einheit: 0,1 mH Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x000E (14dez)
2003:29 | Motor I2T warn level | I2T-Modell Warnschwelle Einheit: % | UINT8 | RW | 0x50 (80dez)
2003:2A | Motor I2T error level | I2T-Modell Fehlerschwelle Einheit: % | UINT8 | RW | 0x69 (105dez)
2003:2B* | Motor Temperature warn level | Übertemperatur Warnschwelle Einheit: 0,1 °C Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
2003:2C* | Motor Temperature error level | Übertemperatur Fehlerschwelle Einheit: 0,1 °C Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
2003:2D* | Motor thermal time constant | Thermische Zeitkonstante Einheit: 0,1 s Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0028 (40dez)
*) siehe Index 2059 OCT Nameplate
Index 2004 Brake Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2004:0 | Brake Settings | Maximaler Subindex | UINT8 | RO | 0x14 (20dez)
2004:01 | Manual override (release) | Manuelles Lösen der Motorhaltebremse | BOOLEAN | RW | 0x00 (0dez)
2004:11* | Release delay | Zeit, die die Haltebremse zum Öffnen (Lösen) benötigt, nachdem die Spannung angelegt wurde Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
2004:12* | Application delay | Zeit, die die Haltebremse zum Schließen (Halten) benötigt, nachdem die Spannung abgeschaltet wurde Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
2004:13 | Emergency application timeout | Zeit, die der Verstärker abwartet, bis die Drehzahl nach Halt-Anforderung (Solldrehzahl 0 nach Halterampe oder Torque off) das Stillstandfenster erreicht. Bei Überschreiten der eingestellten Wartezeit wird die Haltebremse unabhängig von der Drehzahl ausgelöst. Hinweis: Bei rotatorischen Achsen und der Einstellung Torque off für den Fehlerfall muss dieser Parameter mindestens auf die längste Zeit des „Austrudelns“ der Achse angepasst werden. Bei hängenden Achsen und der Einstellung Torque off für den Fehlerfall sollte dieser Parameter auf eine sehr kurze Zeit eingestellt werden, um ein weites Absacken der Achse/Last zu verhindern. | UINT16 | RW | 0x0000 (0dez)
2004:14* | Brake moment of inertia | Massenträgheitsmoment der Bremse Einheit: g cm^2 Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatisches Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
*) siehe Index 2059 OCT Nameplate
Index 2010 Feedback Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2010:0 | Feedback Settings | Maximaler Subindex | UINT8 | RO | 0x13 (19dez)
2010:01 | Invert feedback direction | Zählrichtung invertieren | BOOLEAN | RW | 0x00 (0dez)
2010:11 | Device type | 3: OCT (nicht änderbar) | UINT32 | RW | 0x00000003 (3dez)
2010:12 | Singleturn bits | Anzahl der Singleturn-Bits | UINT8 | RW | 0x14 (20dez)
2010:13 | Multiturn bits | Anzahl der Multiturn-Bits | UINT8 | RW | 0x0C (12dez)
2010:14 | Observer bandwidth | Bandbreite des Drehzahlbeobachters [Hz] | UINT16 | RW | 0x01F4 (500dez)
2010:15 | Observer feed-forward | Lastverhältnis [%] 100 % = Lastfrei 50 % = Massenträgheitsmomente von An- und Abtrieb sind gleich | UINT8 | RW | 0x01 (0dez)
Index 2018 OCT Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2018:0 | OCT Settings | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
2018:01 | Enable auto config | Nach dem Einlesen des elektronischen Typenschilds wird automatisch konfiguriert (siehe Automatisches Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)
2018:02 | Reconfig identical motor | Bei Austausch identischer Motoren wird nach dem Einlesen des elekronischen Typenschilds automatisch neu konfiguriert. Enable autoconfig muss eingeschaltet sein. (siehe Automatisches Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)
2018:03 | Reconfig non-identical motor | Bei Austausch nicht-identischer Motoren wird nach dem Einlesen des elekronischen Typenschilds automatisch neu konfiguriert. Enable autoconfig muss eingeschaltet sein. (siehe Automatisches Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] Objektbeschreibung (DS402) [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index 2020 Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2020:0 | Vendor data | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
2020:11 | Amplifier peak current | Spitzenstrom des Verstärkers (Scheitelwert) Einheit: mA | UINT32 | RW | 0x00001F40 (8000dez)
2020:12 | Amplifier rated current | Nennstrom des Verstärkers (Scheitelwert) Einheit: mA | UINT32 | RW | 0x00000FA0 (4000dez)
2020:13 | Amplifier thermal time constant | Thermische Zeitkonstante des Verstärkers Einheit: 0,1 ms | UINT16 | RW | 0x0023 (35dez)
2020:14 | Amplifier overcurrent threshold | Schwellwert für Kurzschlusserkennung Einheit: mA | UINT32 | RW | 0x00002EE0 (12000dez)
2020:15 | Max rotary field frequency | Max. Drehfeldfrequenz Einheit: Hz | UINT16 | RW | 0x0257 (599dez)


Kommando-Objekt

Inbetriebnahme [image] Objektbeschreibung (DS402) [image] Kommando-Objekt
Kommando-Objekt
Index FB00 Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | Command | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | reserviert | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | reserviert | UINT8 | RO | 0x00 (0dez)
FB00:03 | Response | reserviert | OCTET-STRING[4] | RO | {0}


Eingangsdaten/Ausgangsdaten

Inbetriebnahme [image] Objektbeschreibung (DS402) [image] Eingangsdaten/Ausgangsdaten
Eingangsdaten/Ausgangsdaten
Index 2001 Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2001:0 | Outputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
2001:11 | Torque offset | Offset des Drehmoment-Wertes Der Wert wird in 1000stel vom rated current angegeben Formel für Index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Formel für Index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | INT16 | RO | 0x0000 (0dez)
Index 2008 Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2008:0 | Inputs | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
2008:01 | Info data1 | Synchrone Informationen (Auswahl über Subindex 2002:55) | UINT16 | RO | 0x0000 (0dez)
2008:01 | Info data2 | Synchrone Informationen (Auswahl über Subindex 2002:56) | UINT16 | RO | 0x0000 (0dez)
Index 603E TxPDO Data invalid
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
603E:0 | TxPDO Data invalid | Max. Subindex | UINT8 | RO | 0x02 (2dez)
603E:02 | Position actual value | 0: Die aktuelle Position ist gültig 1: Die aktuelle Position ist ungültig | BOOLEAN | RO P | 0
Index 6040 Controlword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6040:0 | Controlword | DS402 Controlword Bit 0: Switch on Bit 1: Enable voltage Bit 2: reserved Bit 3: Enable operation Bit 4 - 6: reserved Bit 7: Fault reset Bit 8 - 15: reserved | UINT16 | RO | 0x0000 (0dez)
Index 6041 Statusword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6041:0 | Statusword | DS402 Statusword Bit 0: Ready to switch on Bit 1: Switched on Bit 2: Operation enabled Bit 3: Fault Bit 4: reserved Bit 5: reserved Bit 6: Switch on disabled Bit 7: Warning Bit 8 + 9: reserved Bit 10: TxPDOToggle (An-/Abwahl über 0x60DA) Bit 11: Internal limit active Bit 12: (Target value ignored) Bit 13 - 15: reserved | UINT16 | RO | 0x0000 (0dez)
Index 605E Fault reaction option code
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
605E:0 | Fault reaction option code | 0: Disable drive function, motor is free to rotate 1: Slow down by slow down ramp | ENUM16BIT | RW | 0
Index 6060 Modes of operation
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6060:0 | Modes of operation | erlaubte Werte: 0x08: Cyclic synchronous position mode (CSP) 0x09: Cyclic synchronous velocity mode (CSV) 0x0A: Cyclic synchronous torque mode (CST) 0x0B: Cyclic synchronous torque mode with commutation angle (CSTCA) | UINT8 | RW | 0x00 (0dez)
Index 6061 Modes of operation display
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6061:0 | Modes of operation display | erlaubte Werte: 8: Cyclic synchronous position mode (CSP) 9: Cyclic synchronous velocity mode (CSV) 10: Cyclic synchronous torque mode (CST) 11: Cyclic synchronous torque mode with commutation angle (CSTCA) | UINT8 | RO | 0x00 (0dez)
Index 6064 Position actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6064:0 | Position actual value | Position Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | UINT32 | RO | 0x00000000 (0dez)
Index 6065 Following error window
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6065:0 | Following error window | Schleppabstandsüberwachung: Schleppfehlerfenster Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden 0xFFFFFFFF (-1dez) = Schleppabstandsüberwachung aus Jeder andere Wert = Schleppabstandsüberwachung ein | UINT32 | RO | 0xFFFFFFFF (-1dez)
Index 6066 Following error time out
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6066:0 | Following error time out | Schleppabstandsüberwachung: Timeout Einheit: ms Ist der Schleppfehler größer als das Schleppfehlerfenster, für eine Zeit, die größer ist als der Timeout, führt das zu einer Fehlerreaktion | UINT1616 | RO | 0x0000 (0dez)
Index 606C Velocity actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
606C:0 | Velocity actual value | Anzeige des aktuellen Geschwindigkeitswerts | INT3232 | RO | 0x00000000 (0dez)
Index 6071 Target torque
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6071:0 | Target torque | This object shall indicate the configured input value for the torque controller. Der Wert wird in 1000stel vom rated current angegeben. Formel für Index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Formel für Index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | INT16 | RO | 0x0000 (0dez)
Index 6072 Max torque
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6072:0 | Max torque | This object limits the target torque for the torque controller (bipolar limit). Der Wert wird in 1000stel vom rated current angegeben. Formel für Index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Formel für Index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | UINT16 | RW | 0x7FFF (32767dez)
Index 6075 Motor rated current
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6075:0 | Motor rated current | Motor-Nennstrom Einheit : mA | UINT32 | RW | 0x000003E8 (1000dez)
Index 6077 Torque actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6077:0 | Torque actual value | This object shall provide the actual value of the torque. Der Wert wird in 1000stel vom rated current angegeben. Formel für Index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Formel für Index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | INT16 | RO | 0x0000 (0dez)
Index 6079 DC link circuit voltage
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6079:0 | DC link circuit voltage | Zwischenkreisspannung g Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
Index 607A Target position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
607A:0 | Target position | This object shall provide the actual position. Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 6080 Max motor speed
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6080:0 | Max motor speed | Drehzahlbegrenzung Einheit: 1 / min | UINT32 | RW | 0x00040000 (262144dez)
Index 608F Position encoder resolution
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
608F:0 | Position encoder resolution | Dieses Objekt stellt die konfigurierten Encoderinkremente und Anzahl der Motorumdrehungen dar. Die “Position encoder resolution” wird mit folgender Formel berechnet: Position encoder resolution = (Encoderinkremente / Motorumdrehungen) | UINT8 | RO | 0x02 (2dez)
608F:01 | SubIndex 001 | Encoderinkremente | UINT32 | RO | 0x00000000 (0dez)
608F:02 | SubIndex 002 | Motorumdrehungen | UINT32 | RO | 0x00000000 (0dez)
Index 6090 Velocity Encoder Resolution
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6090:0 | Velocity Encoder Resolution | Anzeige der konfigurierten Encoder-Inkremente/s und Motorumdrehungen/s. Die "Velocity Encoder Resolution" wird nach folgender Formel berechnet: Velocity Encoder Resolution = (encoder_increments / s ) / (motor_revolutions / s) | UINT32 | RO | 0x00000000 (0dez)
Index 60B8 Touch probe function
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60B8:0 | Touch probe function | Touch probe function byte | UINT16 | RO | 0x0000 (0dez)
Index 60B9 Touch probe status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60B9:0 | Touch probe status | Touch probe status byte | UINT1616 | RO | 0x0000 (0dez)
Index 60BA Touch probe 1 positive edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60BA:0 | Touch probe 1 positive edge | Positiver Positionswert von TP 1 Einheit :der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 60BB Touch probe 1 negative edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60BB:0 | Touch probe 1 negative edge | Negativer Positionswert von TP 1 Einheit :der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 60BC Touch probe 2 positive edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60BC:0 | Touch probe 2 positive edge | Positiver Positionswert von TP 2 Einheit :der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 60BD Touch probe 2 negative edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60BD:0 | Touch probe 2 negative edge | Negativer Positionswert von TP 2 Einheit :der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 60C2 Interpolation time period
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60C2:0 | Interpolation time period | Maximaler Subindex x | UINT8 | RO | 0x02 (2dez)
60C2:01 | Interpolation time period value | Anzeige des Interpolations Zeitraums (sub-index 0x01) der Wert wird in 10(interpolation time index) (Sekunden) angegeben. Der Interpolation time index (sub-index 0x02) ist dimesionslos | UINT8T8 | RO | 0x00 (0dez)
60C2:02 | Interpolation time index |  | INT8 | RO | 0x00 (0dez)
Index 60D9 Supported functions
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60D9:0 | Supported functions | Angabe der vom Gerät unterstützten Funktionen | UINT3232 | RO | 0x00000000 (0dez)
Index 60DA Function settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60DA:0 | Function settings | Aktiviert / Deaktiviert unterstützte Funktionen. Bit 0: Enable TxPDOToggle-Bit in Statusword: Bit 10 Bit 1: Enable input cycle counter in Statusword: Bit 13 Bit 2-31: reserved | UINT32 | RW | 0x00000000 (0dez)
Index 60EA Commutation angle
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60EA:0 | Commutation angle | Kommutierungs-Winkel (für CSTCA Modus) Einheit: 5,49 * 10-3 ° | UINT16 | RO | 0x0000 (0dez)
Index 60F4 Following error actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60F4:0 | Following error actual value | Schleppfehler Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 60FF Target velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60FF:0 | Target velocity | Konfigurierte Ziel-Geschwindigkeit Die Geschwindigkeitsskalierung kann dem Objekt 0x6090 ("Velocity encoder resolution") entnommen werden | INT32 | RO | 0x00000000 (0dez)
Index 6403 Motor catalogue number
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6403:0 | Motor catalogue number | Ist der Order Code aus dem elektronischen Typenschild des Motors, z. B. AM8121-0F20-0000 | STRING | RO |
Index 6502 Supported drive modes
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6502:0 | Supported drive modes | Angabe der unterstützten Betriebsmodi. (DS402 Object 0x6502) Es werden nur die Modi CSV, CST, CSTCA und CSP unterstützt Bit 0: PP Bit 1: VL Bit 2: PV Bit 3: TQ Bit 4: R Bit 5: HM Bit 6: IP Bit 7: CSP Bit 8: CSV Bit 9: CST Bit 10: CSTCA Bit 11-15: reserved Bit 16-31: Manufacturer-specific | UINT32 | RO | 0x00000000 (0dez)


Informations-/Diagnostikdaten

Inbetriebnahme [image] Objektbeschreibung (DS402) [image] Informations-/Diagnostikdaten
Informations-/Diagnostikdaten
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x37 (55dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Nachricht 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |
Index 2030 Amplifier Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2030:0 | Amplifier Diag data | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
2030:11 | Amplifier I2T temperature | I2T-Modell-Auslastung Einheit: % | UINT8 | RO | 0x00 (0dez)
Index 2031 Motor Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2031:0 | Motor Diag data | Maximaler Subindex | UINT8 | RO | 0x13 (19dez)
2031:11 | Motor I2T temperature | I2T-Modell-Auslastung Einheit: % | UINT8 | RO | 0x00 (0dez)
2031:13 | Motor temperature | Temperatur-Auslastung Einheit: ° | UINT16 | RO | 0x0000 (0dez)
Index 2040 Amplifier Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2040:0 | Amplifier Info data | Maximaler Subindex | UINT8 | RO | 0x12 (18dez)
2040:11 | Amplifier temperature | Interne Temperatur der Box Einheit: 0,1 °C | UINT16 | RO | 0x0000 (0dez)
2040:12 | DC link voltage | Zwischenkreisspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
Index 2041 Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2041:0 | Info data | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
2041:11 | Auxiliary voltage (10 V) | Hilfsspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
Index 2058 OCT Info data
(diese Daten werden immer automatisch aus dem elektronischen Typenschild des Motors eingelesen und dienen rein informativen Zwecken)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2058:0 | OCT Info data | Maximaler Subindex | UINT8 | RO | 0x1F (31dez)
2058:11 | Encoder Type | Feedbacktyp 2: Dreh-Encoder, unipolare Zählung | UINT16 | RO | 0x0000 (0dez)
2058:12 | Resolution | Auflösung des Feedbacks Einheit: Schritte pro Umdrehung | UINT32 | RO | 0x00000000 (0dez)
2058:13 | Range | Arbeitsbereich des Feedbacks. Beim Verlassen dieses Bereichs gibt es einen Überlauf der Position. Einheit: Umdrehungen | UINT32 | RO | 0x00000000 (0dez)
2058:14 | Type Code Name | Name des Feedbacks | STRING | RO |
2058:15 | Serial No | Seriennummer des Feedbacks | STRING | RO |
2058:16 | Firmware Revision No | Revision der Firmware | STRING | RO |
2058:17 | Firmware Date | Datum der Firmware | STRING | RO |
2058:18 | EEPROM Size | EEPROM Größe | UINT16 | RO | 0x0000 (0dez)
2058:19 | Temperature | Temperatur Einheit: 0,1° | INT16 | RO | 0x0000 (0dez)
2058:1A | LED Current | Strom der Feedback-LED Einheit: 0,1 mA | UINT16 | RO | 0x0000 (0dez)
2058:1B | Supply voltage | Versorgungsspannung des Feedbacks Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
2058:1C | Life- time | Betriebsstundenzähler Einheit: Minuten | UINT32 | RO | 0x00000000 (0dez)
2058:1D | Received Signal Strength Indicator | Empfangssignalstärke an der Klemme Einheit: % | UINT16 | RO | 0x0000 (0dez)
2058:1E | Slave Received Signal Strength Indicator | Empfangssignalstärke am Geber Einheit: % | UINT16 | RO | 0x0000 (0dez)
2058:1F | Line delay | Laufzeit des Signals im Kabel Einheit: ns | UINT16 | RO | 0x0000 (0dez)
Index 2059 OCT Nameplate
Die in diesem Index beschriebenen Parameter werden immer aus dem elektronischen Typenschild des angeschlossenen Motors gelesen. Aus diesen Parametern ergeben sich die in diesem Kapitel mit Sternchen (*) markierten Parameter automatisch, wenn das Automatische Scannen des elektronischen Typenschild eingeschaltet ist (Index 2018).
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2059:0 | OCT Nameplate | Maximaler Subindex | UINT8 | RO | 0x24 (36dez)
2059:01 | Motor vendor | Motorhersteller | STRING | RO |
2059:02 | Electric motor type | Motortyp | STRING | RO |
2059:03 | Serial No | Seriennummer | STRING | RO |
2059:04 | Order code | Bestellnummer (Auf diesen Index wird beim Autoconfig geprüft, ob der Motor identisch zum Vorgänger ist) | STRING | RO |
2059:05 | Motor construction | Art des Motors | STRING | RO |
2059:06 | Pole pairs | Polpaarzahl | UINT32 | RO | 0x00000000 (0dez)
2059:07 | Standstill current (rms) | Effektiver Haltestrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
2059:08 | Rated current (rms) | Effektiver Nennstrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
2059:09 | Peak current (rms) | Effektiver Spitzenstrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
2059:0A | Nominal voltage (rms) | Effektive Nennspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
2059:0B | Max voltage (rms) | Maximale Spannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
2059:0C | Max winding du/dt | Maximal zulässige Spannungsanstieg an der Spule Einheit: kV/s | UINT32 | RO | 0x00000000 (0dez)
2059:0D | Max torque | Maximales Drehmoment Einheit: mNm | UINT16 | RO | 0x0000 (0dez)
2059:0E | Torque constant | Drehmoment-Konstante Einheit: mNm / A | UINT16 | RO | 0x0000 (0dez)
2059:0F | EMK (rms) | Gegenspannung Einheit: mV / (1/min) | UINT32 | RO | 0x00000000 (0dez)
2059:10 | Winding resistance Ph-Ph 20°C | Spulenwiderstand Einheit: mOhm | UINT16 | RO | 0x0000 (0dez)
2059:11 | Ld Ph-Ph | Induktivität in Flussrichtung Einheit: 0,1 mH | UINT16 | RO | 0x0000 (0dez)
2059:12 | Lq Ph-Ph | Induktivität in momentbildene Richtung Einheit: 0,1 mH | UINT16 | RO | 0x0000 (0dez)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
2059:13
Max speed
Maximale Geschwindigkeit
Einheit: 1/min
UINT32
RO
0x00000000 (0dez)
2059:14
Moment of inertia
Massenträgheitsmoment
Einheit: g cm^2
UINT16
RO
0x0000 (0dez)
2059:15
T motor warn limit
Warnungsschwelle Motortemperatur
Einheit: 0,1 °C
UINT16
RO
0x0000 (0dez)
2059:16
T motor shut down
Fehlerschwelle Motortemperatur
Einheit: 0,1°C
UINT16
RO
0x0000 (0dez)
2059:17
Time constant i2t
Zeitkonstante I2T-Modell
Einheit: s
UINT16
RO
0x0000 (0dez)
2059:18
Motor thermal constant
Thermische Zeitkonstante des Motors
Einheit: s
UINT16
RO
0x0000 (0dez)
2059:1B
Brake type
Typ der Bremse
▪
no Brake
▪
holding Brake
STRING
RO
2059:1C
Min brake voltage
Minimale Bremsspannung
Einheit: mV
UINT32
RO
0x00000000 (0dez)
2059:1D
Max brake voltage
Maximale Bremsspannung
Einheit: mV
UINT32
RO
0x00000000 (0dez)
2059:1E
Min brake monitor current
Minimaler Strom für die Überwachung der Bremse
Einheit: mA
UINT32
RO
0x00000000 (0dez)
2059:1F
Brake holding torque
Haltemoment der Bremse
Einheit: mNm
UINT32
RO
0x00000000 (0dez)
2059:20
Brake T on
Zeit bis die Bremse anzieht
Einheit: ms
UINT16
RO
0x0000 (0dez)
2059:21
Brake T off
Zeit bis die Bremse löst
Einheit: ms
UINT16
RO
0x0000 (0dez)
2059:22
Brake reduced holding voltage
Reduzierte Spannung der Bremse
Einheit: mV
UINT32
RO
0x00000000 (0dez)
2059:23
Brake time to red. holding volt.
Zeit ab der die Bremse mit reduzierter Spannung hält
Einheit: ms
UINT16
RO
0x0000 (0dez)
2059:24
Motor temp sensor connection
Anschluss des Temperatursensors Feedback port
(nicht änderbar)
STRING
RO


Standardobjekte

Inbetriebnahme [image] Objektbeschreibung (DS402) [image] Standardobjekte
Standardobjekte
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00000192 (402dez)
Index 1001 Error register
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1001:0 | Error register |  | UINT8 | RO | 0x00 (0dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP7211-0034
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1C2B4052 (472596562dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 1600 DS402 RxPDO-Map Controlword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | DS402 RxPDO-Map Controlword | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6040:00, 16
Index 1601 DS402 RxPDO-Map Target velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | DS402 RxPDO-Map Target velocity | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60FF:00, 32
Index 1602 DS402 RxPDO-Map Target torque
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | DS402 RxPDO-Map Target torque | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6071:00, 16
Index 1603 DS402 RxPDO-Map Commutation angle
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | DS402 RxPDO-Map Commutation angle | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60EA:00, 16
Index 1604 DS402 RxPDO-Map Torque limitation
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | DS402 RxPDO-Map Torque limitation | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6072:00, 16
Index 1605 DS402 RxPDO-Map Torque offset
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | DS402 RxPDO-Map Torque offset | PDO Mapping RxPDO 6 | UINT8 | RO | 0x01 (1dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x2001:11, 16
Index 1606 DS402 RxPDO-Map Target position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | DS402 RxPDO-Map Target position | PDO Mapping RxPDO 7 | UINT8 | RO | 0x01 (1dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x607A:00, 32
Index 1607 DS402 RxPDO-Map Touch probe function
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | DS402 RxPDO-Map Touch probe function | PDO Mapping RxPDO 8 | UINT8 | RO | 0x01 (1dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60B8:00, 16
Index 1A00 DS402 TxPDO-Map Statusword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | DS402 TxPDO-Map Statusword | PDO Mapping TxPDO 1 | UINT8 | RO | 0x01 (1dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6041:00, 16
Index 1A01 DS402 TxPDO-Map Position actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | DS402 TxPDO-Map Position actual value | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6064:00, 32
Index 1A02 DS402 TxPDO-Map Velocity actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | DS402 TxPDO-Map Velocity actual value | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x606C:00, 32
Index 1A03 DS402 TxPDO-Map Torque actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | DS402 TxPDO-Map Torque actual value | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6077:00, 16
Index 1A04 DS402 TxPDO-Map Following error actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | DS402 TxPDO-Map Following error actual value | PDO Mapping TxPDO 5 | UINT8 | RO | 0x01 (1dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60F4:00, 32
Index 1A05 DS402 TxPDO-Map Touch probe status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | DS402 TxPDO-Map Touch probe status | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60B9:00, 16
Index 1A06 DS402 TxPDO-Map Touch probe 1 positive edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | DS402 TxPDO-Map Touch probe 1 positive edge | PDO Mapping TxPDO 7 | UINT8 | RO | 0x01 (1dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BA:00, 32
Index 1A07 DS402 TxPDO-Map Touch probe 1 negative edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | DS402 TxPDO-Map Touch probe 1 negative edge | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BB:00, 32
Index 1A08 DS402 TxPDO-Map Touch probe 2 positive edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | DS402 TxPDO-Map Touch probe 2 positive edge | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BC:00, 32
Index 1A09 DS402 TxPDO-Map Touch probe 2 negative edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | DS402 TxPDO-Map Touch probe 2 negative edge | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BD:00, 32
Index 1A0B DS402 TxPDO-Map Info data 1
Index | Name | Bedeutung | Data type | Flags | Default
1A0B:0 | DS402 TxPDO-Map Info data 1 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x01 (1dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x2008 (Inputs), entry 0x01 (Info data 1)) | UINT32 | RO | 0x2008:01, 16
Index 1A0C DS402 TxPDO-Map Info data 2
Index | Name | Bedeutung | Data type | Flags | Default
1A0C:0 | DS402 TxPDO-Map Info data 2 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x01 (1dez)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x2008 (Inputs), entry 0x02 (Info data 2)) | UINT32 | RO | 0x2008:02, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:04 | Subindex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:05 | Subindex 005 | 5. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:06 | Subindex 006 | 6. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:07 | Subindex 007 | 7. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:08 | Subindex 008 | 8. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:08 | Subindex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:09 | Subindex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0A | Subindex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (Hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x0003D090 (250000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0x4808 (18440dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0001E848 (125000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
3: DC - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x0003D090 (250000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00001C52 (7250dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x4808 (18440dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x0001E848 (125000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00001C52 (7250dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00001C52 (7250dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | siehe Hinweis! | UINT32 | RW | 0x00000000 (0dez)


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Servotechnik - Zubehör
•
Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der IP-67-Module und die verwendeten Metallteile. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Servotechnik - Zubehör

Anhang [image] Servotechnik - Zubehör
Servotechnik - Zubehör
Artikel | Kommentar
ZK1090-3xxx-xxxx | Leitung für EtherCAT-Signalein- und -ausgang
ZK2030-xxxx-xxxx, ZK2031-xxxx-xxxx | Leitung für 7/8"-Stromversorgung
AM811x | Servomotor 0,20…0,52 Nm für Servo-I/Os (EL72xx, EP72xx)
AM812x | Servomotor 0,50…0,80 Nm für Servo-I/Os (EL72xx, EP72xx)
AM813x | Servomotor 1,35…2,37 Nm für Servo-I/Os (EL72xx, EP72xx)
AM814x | Servomotor 2,40 Nm für Servo-I/Os (EL72xx, EP72xx)
ZK47x4-04xx, ZK4000-xxxx | Anschlussleitungen für kompakte Antriebstechnik
EL6910 | TwinSAFE-Logic-Klemme
EP1908 | EtherCAT Box, Industriegehäuse, 8 digitale Eingänge, TwinSAFE, 24 VDC
EL2904 | vierkanalige, digitale-Ausgangsklemme, TwinSAFE, 24 VDC, 0,5 A


Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)

Anhang [image] Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
Allgemeines
Zukünftig werden Sie vermehrt auf Beckhoff Produkten maschinenlesbare Informationen in Form eines Data Matrix Codes (DMC, Code-Schema ECC200) finden. Dieser hilft uns bei der Verbesserung des Qualitätssicherungsprozesses und kann darüber hinaus von Ihnen zur besseren Identifikation unserer Produkte genutzt werden.
Die Einführung des Data Matrix Codes (bei Beckhoff BIC = Beckhoff Identification Code genannt) erfolgt schrittweise über alle Produktgruppen hinweg.
Die Informationen des BICs orientieren sich an dem ANSI-Standard MH10.8.2-2016
Darstellung und Inhalte des BICs
Der BIC ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist lesbar und enthält Informationen, die Sie für Ihr internes Handling und Verwaltung der Produkte nutzen können. Beim Scannen des BICs finden Sie folgende Informationen:
Codierte Informationen auf dem BIC
Pos.-Nr. | Art der Information | Erklärung
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u.
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10…
5 | Chargennummer | Optional: Produktionsjahr und -woche
6 | ID-/Seriennummer | Optional: Heutiges Seriennummer-System, z. B. bei Safety-Produkten
7 | Variantennummer | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten
8 | Date Code | Intern
9 | Auftrags-/Chargennummer | Intern
10 | Seriennummer | Intern
... |  |
Jede Information ist anhand des sog. Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gem. nachstehender Tabelle. Sind die Informationen kürzer werden sie durch Leerzeichen ersetzt. Die Daten unter den Positionen 1-4 sind immer vorhanden (temporäre Einschränkung, s. u., BTN).
Übersicht der festgelegten Datenidentifikatoren mit Beispielen
Pos-Nr. | Art der Information | Datenidentifikator | Anzahl Stellen | Beispiel
1 | Beckhoff-Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | 1K | 32 | 1KEL1809
4 | Menge | Q | 6 | Q1
5 | Chargennummer | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | 51S | 12 | 51S678294104
7 | Variante | 30P | 32 | 30PF971 , 2*K183
8 | Date Code | 9D | 8 | 9DG0118
9 | Auftrags-/Chargennummer | 1T | 14 | 1TFA12345678
10 | Seriennummer | 52S | 23 | 52S2304853-1-004
... |  |  |  |
Aufbau des BICs
Beispiel einer zusammengesetzten Information aus den Positionen 1 - 4 und 6. Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die in Zukunft alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.