EP7041 - Schrittmotormodule
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
2.3
▪
Technische Daten aktualisiert
2.2.0
▪
Sicherheitshinweise neues Layout
▪
Kapitel Montage aktualisiert
2.1.0
▪
EP7041-3102 hinzugefügt
2.0.0
▪
Migration
1.7.0
▪
Vorwort aktualisiert
▪
Kapitel Anzugsmomente für Steckverbinder aktualisiert
▪
Kapitel EtherCAT-Anschluss aktualisiert
▪
Kapitel Signalleitungen aktualisiert
▪
Kapitel Zubehör aktualisiert
▪
Kapitel Leitungsverluste aktualisiert
1.6.0
▪
Power-Anschluss aktualisiert
1.5.0
▪
Technische Daten aktualisiert
1.4.0
▪
Technische Daten aktualisiert
1.3.0
▪
Technische Daten aktualisiert
▪
Objektbeschreibungen aktualisiert
▪
Grundlagen zum Positions-Interface hinzugefügt
▪
Kapitel Zubehör aktualisiert
▪
Kapitel Anzugsmomente für Steckverbinder aktualisiert
▪
Kapitel Power-Anschluss aktualisiert
1.2.0
▪
Kapitel Konfiguration der wichtigsten Parameter aktualisiert
▪
Kapitel Zubehör hinzugefügt
1.1.0
▪
Technische Daten aktualisiert
▪
EP7041-2002 und EP7041-3002 hinzugefügt
▪
Übersicht der EtherCAT-Kabel erweitert
▪
Übersicht der Signalleitungen aktualisiert
▪
Beschreibung des Power-Anschlusses aktualisiert
▪
ATEX-Hinweise hinzugefügt
▪
Erweiterter Temperaturbereich für freigegebene Module dokumentiert
1.0.0
▪
Kapitel zu Inbetriebnahme und Konfiguration überarbeitet
0.6
▪
EP7041-1002 hinzugefügt
▪
Objektbeschreibung aktualisiert
▪
Anzugsmomente für Steckverbinder hinzugefügt
▪
Übersicht der Signalleitungen hinzugefügt
0.5
▪
Erste vorläufige Version für EP7041-0002
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Dokumentation Version | EP7041-0002 |  | EP7041-1002 |  | EP7041-2002 |  | EP7041-3002 |  | EP7041-3102
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
2.3 | 11 | 14 | 10 | 12 | 11 | 13 | 07 | 10 | 07 | 07
2.2.0 | 11 | 14 | 10 | 12 | 11 | 13 | 07 | 10 | 07 | 06
2.1.0 | 11 | 12 | 10 | 10 | 11 | 11 | 06 | 08 | 06 | 04
2.0.0 | 11 | 11 | 10 | 09 | 11 | 10 | 06 | 08 | - | -
1.7.0 | 11 | 11 | 10 | 09 | 11 | 10 | 06 | 07
1.6.0 | 09 | 10 | 09 | 08 | 10 | 10 | 06 | 07
1.4.0 | 08 | 06 | 08 | 04 | 08 | 06 | 04 | 02
1.3.0 | 08 | 06 | 08 | 04 | 08 | 06 | 04 | 02
1.2.0 | 08 | 03 | 08 | 01 | 08 | 03 | 04 | 02
1.1.0 | 07 | 03 | 07 | 01 | 07 | 03 | 02 | 01
1.0.0 | 04 | 01 | 04 | 00 | - | - | - | -
0.6 | 04 | 01 | 04 | 00
0.5 | 03 | 01 | - | -
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code enthält zusätzliche Informationen über den Auslieferungszustand des Moduls: Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC).
Syntax der Batch-Nummer (D-Nummer):
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT Box - Einführung
•
Modulübersicht
•
Einführung
•
Technische Daten
•
Lieferumfang
•
EP7041 - Prozessabbild


EtherCAT Box - Einführung

Produktübersicht [image] EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
XML-Dateien
XML -Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


Modulübersicht

Produktübersicht [image] Modulübersicht
Modulübersicht
EP7041 mit Schrittmotor
Modul
Ausgangsstrom für Schrittmotor
Integrierter
Anschluss für
Motorversorgung
Kommentar
EP7041-0002
2 x 3,5 A Nennstrom,
2 x 5,0 A Spitzenstrom
M12-Buchse
▪
Für besonders ruhigen und präzisen Motorlauf ausgelegt.
EP7041-1002
2 x 1,0 A Nennstrom,
2 x 1,5 A Spitzenstrom
M12-Buchse
▪
Für besonders ruhigen und präzisen Motorlauf ausgelegt.
▪
Kleinerer Ausgangsstrom für Schrittmotoren mit geringerer Leistungsaufnahme.
EP7041-2002
2 x 3,5 A Nennstrom,
2 x 5,0 A Spitzenstrom
M12-Stecker
▪
Für besonders ruhigen und präzisen Motorlauf ausgelegt.
▪
Eingebauter Anschluss für die Einspeisung der Motorversorgungsspannung mit Stiften (male) ausgeführt.
EP7041-3002
2 x 3,5 A Nennstrom,
2 x 5,0 A Spitzenstrom
M12-Stecker
▪
Für höhere Geschwindigkeiten ausgelegt.
▪
Eingebauter Anschluss für die Einspeisung der Motorversorgungsspannung mit Stiften (male) ausgeführt.
EP7041-3102
2 x 3,5 A Nennstrom,
2 x 5,0 A Spitzenstrom
M12-Stecker
▪
Für höhere Geschwindigkeiten ausgelegt.
▪
Eingebauter Anschluss für die Einspeisung der Motorversorgungsspannung mit Stiften (male) ausgeführt.
▪
Encoder-Versorgung: 5 VDC


Einführung

Produktübersicht [image] Einführung
Einführung
Weiterführende Informationen
•
EP7041-0002, EP7041-1002
•
EP7041-2002
•
EP7041-3002, EP7041-3102


EP7041-0002, EP7041-1002

Produktübersicht [image] Einführung [image] EP7041-0002, EP7041-1002
EP7041-0002, EP7041-1002
EP7041-0002
Schrittmotormodule mit Interface für Inkremental-Encoder
Die EtherCAT Box Module EP7041-0002 und EP7041-1002 sind für den direkten Anschluss unterschiedlicher Schrittmotoren vorgesehen.
Es sind zwei Versionen Verfügbar:
▪
EP7041-0002: 2 x 3,5 A Nennstrom, (2 x 5,0 A Spitzenstrom)
▪
EP7041-1002: 2 x 1,0 A Nennstrom, (2 x 1,5 A Spitzenstrom)
Die PWM-Endstufen für zwei Motorspulen sind bei geringster Bauform, zusammen mit zwei Eingängen für Endlagenschalter, in der Baugruppe untergebracht und decken einen großen Spannungs- und Strombereich ab.
Durch den Anschluss eines Inkremental-Encoders ist die Realisierung einer einfachen Servo-Achse möglich.
Zwei digitale Eingänge und ein digitaler Ausgang (0,5 A) erlauben die Verbindung von Endschaltern und Motorbremse.
Mit verschiedenen Parametern können die Module an den Motor und die Anwendung angepasst werden.
Ein besonders ruhiger und präziser Motorlauf ist durch ein 64-faches Microstepping sichergestellt.
Quick-Links
▪
Installation
▪
Konfiguration


EP7041-2002

Produktübersicht [image] Einführung [image] EP7041-2002
EP7041-2002
EP7041-2002
Schrittmotormodul mit Interface für Inkremental-Encoder
Die EtherCAT Box EP7041-2002 ist für den direkten Anschluss unterschiedlicher Schrittmotoren vorgesehen.
Die PWM-Endstufen für zwei Motorspulen sind bei geringster Bauform, zusammen mit zwei Eingängen für Endlagenschalter, in der Baugruppe untergebracht und decken einen großen Spannungs- und Strombereich ab.
Durch den Anschluss eines Inkremental-Encoders ist die Realisierung einer einfachen Servo-Achse möglich.
Zwei digitale Eingänge und ein digitaler Ausgang (0,5 A) erlauben die Verbindung von Endschaltern und Motorbremse.
Die externe Motoreinspeisung erfolgt über einen integrierten Stecker.
Mit verschiedenen Parametern kann die EP7041-2002 an den Motor und die Anwendung angepasst werden.
Ein besonders ruhiger und präziser Motorlauf ist durch ein 64-faches Microstepping sichergestellt.
Quick-Links
▪
Installation
▪
Konfiguration


EP7041-3002, EP7041-3102

Produktübersicht [image] Einführung [image] EP7041-3002, EP7041-3102
EP7041-3002, EP7041-3102
EP7041-3002 und EP7041-3102
Schrittmotormodule mit Interface für Inkremental-Encoder
Die EtherCAT-Box-Module EP7041-3002 und EP7041-3102 sind für den direkten Anschluss unterschiedlicher Schrittmotoren vorgesehen. Die PWM-Endstufen für zwei Motorspulen sind bei geringster Bauform, zusammen mit zwei Eingängen für Endlagenschalter, in der Baugruppe untergebracht und decken einen großen Spannungs- und Strombereich ab.
Durch den Anschluss eines Inkremental-Encoders ist die Realisierung einer einfachen Servo-Achse möglich. Die Module versorgen den Inkremental-Encoder mit:
EP7041-3002: 24 VDC
EP7041-3102: 5 VDC
Zwei digitale Eingänge und ein digitaler Ausgang (0,5 A) erlauben die Verbindung von Endschaltern und Motorbremse.
Die externe Motoreinspeisung erfolgt über einen integrierten Stecker.
EP7041-3002 und EP7041-3102 sind für höhere Geschwindigkeiten ausgelegt und können mit verschiedenen Parametern an den Motor und die Anwendung angepasst werden.
Quick-Links
▪
Installation
▪
Konfiguration


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Alle Werte sind typische Werte bei 25 °C, wenn nicht anders angegeben.
Technische Daten
EP7041-0002
EP7041-1002
EP7041-2002
EP7041-3002
EP7041-3102
Feldbus
Feldbus
EtherCAT
Anschluss
2 x M8-Buchse, grün
Potenzialtrennung
500 V (Feldbus / IO)
Prozessabbild
Input: 2 x 16 Bit Daten, 1 x 16 Bit Status
Output: 2 x 16 Bit Daten, 1 x 16 Bit Control
Versorgungsspannungen
Anschluss
Einspeisung: 1 x M8-Stecker, 4-polig
Weiterleitung: 1 x M8-Buchse, 4-polig
Steuerspannung US
Nennspannung
24 VDC (-15 % / +20 %)
Summenstrom
max. 4 A 1)
Verbraucher
Modulelektronik: 120 mA
Peripheriespannung UP
Nennspannung
24 VDC (-15 % / +20 %)
Summenstrom
max. 4 A 1)
Verbraucher
• Encoder
• Digitaler Ausgang: Bremse
Motor
Motor-Art
2-Phasen-Schrittmotor, unipolar oder bipolar
Anschluss
M12-Buchse
Zwischenkreisspannung
max. 50 VDC, nicht verpolungssicher
Anschluss
M12-Buchse „2“
M12-Stecker „2“
Nennstrom pro Phase
3,5 A
1,0 A
3,5 A
Spitzenstrom pro Phase
5,0 A bei 50 °C
1,5 A
5,0 A bei 50 °C
Microstepping
max. 64 Microsteps 2)
max. 256 Microsteps 2)
Schrittfrequenz
max. 32.000 Vollschritte/s (konfigurierbar)
Stromreglerfrequenz
ca. 30 kHz
Treiberschaltung
2 x H-Brücke
Schutzfunktionen
Überlast-Schutz, Kurzschluss-Schutz
Encoder-Eingang
Encoder-Typ
Inkrementalgeber mit single-ended Ausgangstreibern:
▪
Push-pull
▪
Open collector 3)
Anschluss
M12-Buchse
Signale
A, B, C (Referenzimpuls/Nullimpuls)
Low-Pegel
-3 .. 2 VDC
max. 1 VDC 4)
High-Pegel
3,5 .. 28 VDC
2,5 .. 28 VDC 4)
Versorgungsspannung
24 VDC aus der Peripheriespannung UP
5 VDC
Versorgungs-Strom
0,5 A, nicht kurzschlussfest
0,3 A
Pulsfrequenz
max. 400.000 Inkremente/s (Vierfachauswertung)
1) Summenstrom von Verbrauchern und Spannungs-Weiterleitung. Dieser Wert entspricht der
Stromtragfähigkeit der Anschlüsse für die Versorgungsspannungen.
2) EP7041 wählt die Anzahl der Microsteps automatisch entsprechend der Drehzahl
3) Pullup-Widerstand erforderlich
4) Diese Pegel gelten ab Hardware Stand 09. Bis einschließlich Hardware Stand 08 gelten die Pegel:
▪
Low-Pegel: -3 .. 2 VDC
▪
High-Pegel: 3,5 .. 28 VDC
Technische Daten | EP7041-0002 | EP7041-1002 | EP7041-2002 | EP7041-3002 | EP7041-3102
Digitale Eingänge: Endlagenschalter
Anzahl | 2
Anschluss | M12-Buchse
Signalspannung "0" | -3 V ... 2 V
Signalspannung "1" | 3,5 V ... 28 V
Eingangsstrom | 5 mA
Digitaler Ausgang: Bremse
Anzahl | 1
Anschluss | M12-Buchse
Ausgangsspannung | 24 VDC aus der Peripheriespannung UP
Ausgangsstrom | 0,5 A, kurzschlussfest
Umgebungsbedingungen
Umgebungstemperatur im Betrieb | -25 .. +60 °C 0 .. +55 °C gemäß ATEX, siehe besondere Bedingungen
Umgebungstemperatur bei Lagerung | -40 .. +85 °C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Mechanik
Abmessungen | ca. 126 x 30 x 26,5 mm (ohne Steckverbinder)
Gewicht | ca. 165 g
Einbaulage | bis 40 °C Umgebungstemperatur: beliebig über 40 °C Umgebungstemperatur: mindestens 20 mm Abstand zwischen 2 Schrittmotormodulen
Zulassungen und Konformität
Zulassungen | CE, ATEX


Lieferumfang

Produktübersicht [image] Lieferumfang
Lieferumfang
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EtherCAT Box EP7041
▪
1x Schutzkappe für Versorgungsspannungs-Eingang, M8, transparent (vormontiert)
▪
1x Schutzkappe für Versorgungsspannungs-Ausgang, M8, schwarz (vormontiert)
▪
2x Schutzkappe für EtherCAT-Buchse, M8, grün (vormontiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
Vormontierte Schutzkappen gewährleisten keinen IP67-Schutz
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Stellen Sie den korrekten Sitz der Schutzkappen sicher, um die Schutzart IP67 zu gewährleisten.


EP7041 - Prozessabbild

Produktübersicht [image] EP7041 - Prozessabbild
EP7041 - Prozessabbild
Der TwinCAT System Manager zeigt die Daten der EP7041 in einer Baumstruktur an.
Der Baum zeigt
▪
ENC Status compact: Encoder Status
▪
STM Status: Stepper Motor Status
▪
ENC Control compact: Encoder Control
▪
STM Control: Stepper Motor Control
▪
STM Velocity: Stepper Motor Velocity
ENC Status compact
Unter ENC Status compact finden Sie die Statusinformationen des Encoders.
STM Status
Unter STM Status finden Sie die Statusinformationen des Schrittmotors (Stepper Motors).
ENC Control compact
Unter ENC Control compact finden Sie Control-Parameter für den Encoder.
STM Control
Unter STM Control finden Sie Control-Parameter für den Schrittmotors (Stepper Motor).
STM Velocity
Unter STM Velocity finden Sie die Geschwindigkeitsvorgaben für den Schrittmotor (Stepper Motor).


Installation

Installation
Installation
Weiterführende Informationen
•
Montage
•
Anschluss
•
ATEX-Hinweise


Montage

Installation [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anzugsdrehmomente für Steckverbinder


Abmessungen

Installation [image] Montage [image] Abmessungen
Abmessungen
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 3,5 mm für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm (ohne Steckverbinder)


Befestigung

Installation [image] Montage [image] Befestigung
Befestigung
Hinweis
Verschmutzung bei der Montage
Verschmutzte Steckverbinder können zu Fehlfunktion führen. Die Schutzart IP67 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind.
•
Schützen Sie die Steckverbinder bei der Montage vor Verschmutzung.
Montieren Sie das Modul mit zwei M3-Schrauben an den Befestigungslöchern in den Ecken des Moduls. Die Befestigungslöcher haben kein Gewinde.


Anzugsdrehmomente für Steckverbinder

Installation [image] Montage [image] Anzugsdrehmomente für Steckverbinder
Anzugsdrehmomente für Steckverbinder
Schrauben Sie Steckverbinder mit einem Drehmomentschlüssel fest. (z.B. ZB8801 von Beckhoff)
Steckverbinder-Durchmesser | Anzugsdrehmoment
M8 | 0,4 Nm
M12 | 0,6 Nm


Anschluss

Installation [image] Anschluss
Anschluss
Weiterführende Informationen
•
Versorgungsspannungen
•
EtherCAT
•
Schrittmotor, Bremse, Encoder


Versorgungsspannungen

Installation [image] Anschluss [image] Versorgungsspannungen
Versorgungsspannungen
Die EtherCAT Box wird mit zwei Versorgungsspannungen versorgt. Die Massepotentiale der Versorgungsspannungen sind galvanisch miteinander verbunden.
▪
Steuerspannung US
▪
Peripheriespannung UP
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen US und UP von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen US und UP, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungsverluste


Steckverbinder

Installation [image] Anschluss [image] Versorgungsspannungen [image] Steckverbinder
Steckverbinder
Hinweis
Verwechselungs-Gefahr: Versorgungsspannungen und EtherCAT
Defekt durch Fehlstecken möglich.
•
Beachten Sie die farbliche Codierung der Steckverbinder:
schwarz: Versorgungsspannungen
grün: EtherCAT
Steckverbinder für Versorgungsspannungen
M8 4polig In+Out Kontaktbelegung
M8-Steckverbinder
Kontakt | Funktion | Beschreibung | Aderfarbe 1)
1 | US | Steuerspannung | Braun
2 | UP | Peripheriespannung | Weiß
3 | GNDS | GND zu US | Blau
4 | GNDP | GND zu UP | Schwarz
1) Die Aderfarben gelten für Leitungen vom Typ: Beckhoff ZK2020-xxxx-xxxx


Status-LEDs

Installation [image] Anschluss [image] Versorgungsspannungen [image] Status-LEDs
Status-LEDs
Steckverbinder + LEDs
Status-LEDs für die Spannungsversorgung
LED | Anzeige | Bedeutung
US (Steuerspannung) | aus | Versorgungsspannung US nicht vorhanden
 | leuchtet grün | Versorgungsspannung US vorhanden
UP (Peripheriespannung) | aus | Versorgungsspannung UP nicht vorhanden
 | leuchtet grün | Versorgungsspannung UP vorhanden


Leitungsverluste

Installation [image] Anschluss [image] Versorgungsspannungen [image] Leitungsverluste
Leitungsverluste
Beachten Sie bei der Planung einer Anlage den Spannungsabfall an der Versorgungs-Zuleitung. Vermeiden Sie, dass der Spannungsabfall so hoch wird, dass die Versorgungsspannungen an der Box die minimale Nennspannung unterschreiten.
Berücksichtigen Sie auch Spannungsschwankungen des Netzteils.
Spannungsabfall an der Versorgungs-Zuleitung
Leitungsverluste M8 2A
Leitungsverluste M8 4A


EtherCAT

Installation [image] Anschluss [image] EtherCAT
EtherCAT
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungen


Steckverbinder

Installation [image] Anschluss [image] EtherCAT [image] Steckverbinder
Steckverbinder
Für den ankommenden und weiterführenden EtherCAT-Anschluss haben EtherCAT-Box-Module zwei grüne M8-Buchsen.
EtherCAT Steckverbinder
Kontaktbelegung
M8-Buchse 4polig Kontaktbelegung
M8-Buchse
EtherCAT | M8- Steckverbinder | Aderfarben
Signal | Kontakt | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | gelb1) | orange/weiß | weiß/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | weiß1) | blau/weiß | weiß/grün
Rx - | 3 | blau1) | blau | grün
Shield | Gehäuse | Schirm | Schirm | Schirm
1) Aderfarben nach EN 61918
Anpassung der Aderfarben für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx
Zur Vereinheitlichung wurden die Aderfarben der Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx auf die Aderfarben der EN61918 umgestellt: gelb, orange, weiß, blau. Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften der Leitungen sind bei der Umstellung der Aderfarben erhalten geblieben.


Status-LEDs

Installation [image] Anschluss [image] EtherCAT [image] Status-LEDs
Status-LEDs
EtherCAT Status-LEDs
L/A (Link/Act)
Neben jeder EtherCAT-Buchse befindet sich eine grüne LED, die mit „L/A“ beschriftet ist. Die LED signalisiert den Kommunikationsstatus der jeweiligen Buchse:
LED | Bedeutung
aus | keine Verbindung zum angeschlossenen EtherCAT-Gerät
leuchtet | LINK: Verbindung zum angeschlossenen EtherCAT-Gerät
blinkt | ACT: Kommunikation mit dem angeschlossenen EtherCAT-Gerät
Run
Jeder EtherCAT-Slave hat eine grüne LED, die mit „Run“ beschriftet ist. Die LED signalisiert den Status des Slaves im EtherCAT-Netzwerk:
LED | Bedeutung
aus | Slave ist im Status „Init“
blinkt gleichmäßig | Slave ist im Status „Pre-Operational“
blinkt vereinzelt | Slave ist im Status „Safe-Operational“
leuchtet | Slave ist im Status „Operational“
Beschreibung der Stati von EtherCAT-Slaves


Leitungen

Installation [image] Anschluss [image] EtherCAT [image] Leitungen
Leitungen
Verwenden Sie zur Verbindung von EtherCAT-Geräten geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
EtherCAT nutzt vier Adern für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung „Auto MDI-X“ können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, als auch gekreuzte Kabel (Cross-Over) verwenden.
Detaillierte Empfehlungen zur Verkabelung von EtherCAT-Geräten


Schrittmotor, Bremse, Encoder

Installation [image] Anschluss [image] Schrittmotor, Bremse, Encoder
Schrittmotor, Bremse, Encoder
Weiterführende Informationen
•
Signalanschluss
•
Status-LEDs


Signalanschluss

Installation [image] Anschluss [image] Schrittmotor, Bremse, Encoder [image] Signalanschluss
Signalanschluss
Signalanschluss EP7041-3002
Hinweis
Beachten Sie die Nummerierung der M12-Buchsen
Das Verwechseln der M12-Steckverbinder kann das Modul beschädigen.
M12-Buchse Nr. 1: Schrittmotoranschluss
Schrittmotoranschluss
M12-Buchse Nr. 2: Anschluss für Motorversorgung
Hinweis
Anschluss für Motorversorgung ist nicht verpolungssicher
Defekt durch Verpolung möglich.
•
Achten Sie auf korrekte Polung.
Anschluss für Motorversorgung bei EP7041-0002 und EP7041-1002
Anschluss für Motorversorgung bei EP7041-2002 und EP7041-3002
M12-Buchse Nr. 3: Anschluss für digitale Ein- und Ausgänge
Der Signalanschluss der digitale Ein- und Ausgänge erfolgt über M12-Steckverbinder.
Anschluss für digitale Ein- und Ausgänge
Die Sensoren werden aus der Steuerspannung Us mit einem gemeinsamen, maximalen Strom von 0,5 A versorgt.
Der Ausgang ist kurzschlussfest und verpolungsgeschützt.
Leuchtdioden zeigen den Signalzustand der Ein- und Ausgänge an.
M12-Buchse Nr. 4: Encoder-Anschluss
Hinweis
Die Encoder-Versorgungsspannung ist nicht kurzschlussfest.
Defekt durch Kurzschluss möglich.
•
Vermeiden Sie einen Kurzschluss der Encoder-Versorgungsspannung „V Enc“.
Encoder
Encoder-Anschluss


Status-LEDs

Installation [image] Anschluss [image] Schrittmotor, Bremse, Encoder [image] Status-LEDs
Status-LEDs
LEDs EP7041-3002
Status-LEDs an den M12-Anschlüssen
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse Nr. 1: Schrittmotor | S links | grün | Motoransteuerung ist frei geschaltet (Index 0x6010:02 ist gesetzt) und EP7041 ist betriebsbereit
 |  | gelb | Wenn Motor disabled: Motoransteuerung im Stand By
 |  |  | Wenn Motor enabled: Warning, Konfigurationsfehler. Überprüfen Sie den Motor-Status.
 |  | rot | Error: Überprüfen Sie DiagData (Index 0xA010)
 | R rechts | grün | Motor dreht
 |  | rot | interner Fehler
M12-Buchse Nr. 2: Motorversorgung | V links | aus | Motorversorgungsspannung nicht vorhanden
 |  | grün | Motorversorgungsspannung vorhanden
 | O rechts | aus | Binärer Ausgang (M12-Buchse Nr. 3, Pin 5) ausgeschaltet (0 V)
 |  | grün | Binärer Ausgang (M12-Buchse Nr. 3, Pin 5) eingeschaltet (24 V)
M12-Buchse Nr. 3: binäre Eingänge binärer Ausgang | DI 1 links | aus | Low-Pegel am digitalen Eingang 1 (M12-Buchse Nr. 3, Pin 4)
 |  | grün | High-Pegel am digitalen Eingang 1 (M12-Buchse Nr. 3, Pin 4)
 | DI 2 rechts | aus | Low-Pegel am digitalen Eingang 2 (M12-Buchse Nr. 3, Pin 2)
 |  | grün | High-Pegel am digitalen Eingang 2 (M12-Buchse Nr. 3, Pin 2)
M12-Buchse Nr. 4: Encoder | C links | blinkt | Encoder-Spur C
 | A rechts | blinkt | Encoder-Spur A


ATEX-Hinweise

Installation [image] ATEX-Hinweise
ATEX-Hinweise
Weiterführende Informationen
•
ATEX - Besondere Bedingungen
•
BG2000 - Schutzgehäuse für EtherCAT Box
•
ATEX-Dokumentation


ATEX - Besondere Bedingungen

Installation [image] ATEX-Hinweise [image] ATEX - Besondere Bedingungen
ATEX - Besondere Bedingungen
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen – Richtlinie 94/9/EG!
•
Die zertifizierten Komponenten sind mit einem Schutzgehäuse BG2000-0000 oder BG2000-0010 zu errichten, das einen Schutz gegen mechanische Gefahr gewährleistet!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie beim Einsatz von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten EtherCAT-Box-Module tragen folgende Kennzeichnung:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
oder
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch-Nummer (D-Nummer)
Die EtherCAT-Box-Module tragen eine Batch-Nummer (D-Nummer), die wie folgt aufgebaut ist:
D: KW JJ FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Batch-Nummer 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


BG2000 - Schutzgehäuse für EtherCAT Box

Installation [image] ATEX-Hinweise [image] BG2000 - Schutzgehäuse für EtherCAT Box
BG2000 - Schutzgehäuse für EtherCAT Box
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
ATEX
SmallWarningYellow WARNUNG
Schutzgehäuse montieren!
Um die Einhaltung der besonderen Bedingungen gemäß ATEX zu erfüllen, muss ein Schutzgehäuse BG2000-0000 oder BG2000-0010 über der EtherCAT Box montiert werden!
Installation
Schieben Sie die Anschlussleitungen für EtherCAT, Spannungsversorgung und die Sensoren/Aktoren durch die Öffnung des Schutzgehäuses.
BG2000 - Anschlussleitungen durchschieben
Schrauben Sie die Anschlussleitungen für die EtherCAT, Spannungsversorgung und die Sensoren/Aktoren an der EtherCAT Box fest.
BG2000 - Anschlussleitungen festschrauben
Montieren Sie das Schutzgehäuse über der EtherCAT Box.
BG2000 - Schutzgehäuse montieren


ATEX-Dokumentation

Installation [image] ATEX-Hinweise [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX) die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Inbetriebnahme/Konfiguration

Inbetriebnahme/Konfiguration
Inbetriebnahme/Konfiguration
Weiterführende Informationen
•
Einbinden in TwinCAT
•
CoE-Objekte EP7041-0002, EP7041-1002, EP7041-2002
•
CoE-Objekte EP7041-3002, EP7041-3102


Einbinden in TwinCAT

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT
Einbinden in TwinCAT
Weiterführende Informationen
•
Einfügen in das EtherCAT-Netzwerk
•
Konfiguration mit TwinCAT
•
Einbindung in die NC-Konfiguration
•
Konfiguration der wichtigsten Parameter
•
Grundlagen zum Positioning Interface
•
Anwendungsbeispiel
•
Wiederherstellen des Auslieferungszustandes


Einfügen in das EtherCAT-Netzwerk

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Einfügen in das EtherCAT-Netzwerk
Einfügen in das EtherCAT-Netzwerk
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140) und entsprechend der Installationsanweisungen installiert werden.
Der Konfigurationsbaum im Beckhoff TwinCAT SystemManager kann auf 2 Wegen erstellt werden:
▪
durch Einscannen vorhandener Hardware (genannt "online") und
▪
durch manuelles Einfügen/Anhängen von Feldbus-Geräten, Kopplern und Slaves.
Automatisches Einscannen der Box
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode) und scannen Sie die Geräte ein. Bestätigen Sie alle folgenden Dialoge mit OK, so dass sich die Konfiguration im Modus FreeRun befindet.
Einscannen der Konfiguration (E/A-Geräte -> Rechte Maustaste -> Geräte suchen...)
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z.B.: EP2816-0008), bestätigen Sie mit OK.
Auswahl einer Box (z.B.: EP2816-0008)
Angefügte Box im TwinCAT-Baum


Konfiguration mit TwinCAT

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten (in diesem Beispiel EP2816-0008).
Baumzweig der zu konfigurierende EtherCAT Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
•
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
•
der System Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


Einbindung in die NC-Konfiguration

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Einbindung in die NC-Konfiguration
Einbindung in die NC-Konfiguration
(Master: TwinCAT 2.11)
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen installiert werden.
Die Einbindung an die NC kann wie folgt durchgeführt werden:
▪
Die Klemme muss bereits unter E/A-Geräte manuell eingefügt oder vom System eingescannt worden sein (siehe Kapitel "Einsetzen der Klemme in den EtherCAT-Klemmenverbund").
▪
Fügen Sie zuerst einen neuen Task an. Dazu klicken Sie mit der rechten Maustaste auf NC-Konfiguration und wählen Sie "Task Anfügen..." aus (siehe Abb. Neuen Task einfügen).
▪
Benennen Sie gegebenenfalls den Task um und bestätigen Sie mit OK.
Neuen Task einfügen
▪
Wählen Sie mit der rechten Maustaste Achsen aus und fügen anschließend eine neue Achse an (siehe Abb. Verknüpfung der Achse mit der Klemme).
Auswahl einer neuen Achse
▪
Wählen Sie unter Typ eine Kontinuierliche Achse aus und bestätigen Sie mit OK (siehe Abb. 3).
Achsentyp auswählen und bestätigen
▪
Markieren Sie Ihre Achse mit der linken Maustaste. Unter der Registerkarte Einstellungen wählen Sie "Verknüpft mit..." aus (siehe Abb. Verknüpfung der Achse mit der Klemme).
Verknüpfung der Achse mit der Klemme
▪
Wählen Sie die passende Klemme aus (Stepper Drive (MDP 703)) und bestätigen Sie mit "OK ".
Auswahl der richtigen Klemme
▪
Alle wichtigen Verknüpfungen zwischen der NC-Konfiguration und der Klemme werden dadurch automatisch durchgeführt (siehe Abb. Automatische Verknüpfung aller wichtigen Variablen)
Automatische Verknüpfung aller wichtigen Variablen
▪
Damit der Motor in Betrieb genommen werden kann, müssen noch einige Parameter eingestellt werden. Die Werte entnehmen Sie dem Kapitel "Konfiguration der wichtigsten Parameter". Stellen Sie bitte diese Parameter ein, bevor Sie mit der Inbetriebnahme des Motors fortführen.
Inbetriebnahme des Motors mit der NC
▪
Sind die Parameter eingestellt, dann ist der Motor prinzipiell betriebsbereit. Einzelne weitere Parameter müssen der jeweiligen Applikation angepasst werden.
▪
Um die Achse in Betrieb zu nehmen, aktivieren Sie die Konfiguration (Ctrl+Shift+F4), markieren die Achse, wählen die Registerkarte Online aus und geben unter Set die Achse frei.
▪
Setzen Sie alle Häkchen und stellen Sie Override auf 100 (siehe Abb. 7). Anschließend kann die Achse bewegt werden.
Achse freigeben
Sie können nun die Achse mit Hilfe der Funktionstasten F1, F2 (Rückwärts) und F3, F4 (Vorwärts) bewegen.
Eine andere Möglichkeit besteht darin, unter der Registerkarte Funktionen die Achse anzusteuern.
Beispiel
▪
Wählen Sie als Starttyp Reversing Sequence.
▪
Geben Sie eine gewünschte Zielposition1 an, z. B. 5000°.
▪
Geben Sie eine gewünschte Zielgeschwindigkeit an, z. B. 1200°/s.
▪
Geben Sie eine gewünschte Zielposition2 an, z. B. 0°.
▪
Geben Sie den gewünschte Idle Time an, z. B. 1 s.
▪
Wählen Sie Start.
Achse ansteuern, Reiter „Funktionen“
Der Motor fährt nun auf die Position 1, verbleibt dort 1 s und fährt wieder auf die Position 2. Das wird wiederholt, bis Sie mit Klick auf "Stop" beenden.


Konfiguration der wichtigsten Parameter

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Konfiguration der wichtigsten Parameter
Konfiguration der wichtigsten Parameter
Die hier angegebenen Daten sind beispielhaft für einen Schrittmotor AS 1050-0120 aufgeführt. Bei anderen Motoren können die Werte je nach Applikation variieren.
Einstellen der CoE-Objekte
Ausführung von Änderungen
Änderungen der CoE-Objekte werden erst ausgeführt, nachdem das Modul in den Status Init gebracht wurde. Erst danach sind die Änderungen aktiv.
Anpassung von Strom und Spannung
Hinweis
Überhitzung des Motors möglich!
Um den angeschlossenen Motor nicht zu überhitzen, ist es wichtig Strom und Spannung, die vom Stepper-Interface ausgegeben werden, an den Motor anzupassen.
Dazu müssen im CoE-Register der Index 0x8010:01Maximal current und der Index 0x8010:03Nominal voltage passend eingestellt werden (siehe Abb. Anpassung von Strom und Spannung).
Im Index 0x8010:02 kann der Reduced current eingestellt werden. Dadurch wird der Spulenstrom im Stillstand (und damit auch die Verlustleistung) reduziert. Es ist zu beachten, dass sich damit auch das Drehmoment reduziert.
Anpassung von Strom und Spannung
Auswahl der Grundfrequenz
Das Microstepping ist fest auf 1/64 eingestellt und kann nicht verändert werden. Es kann jedoch die Grundfrequenz verändert werden (default: 2000). Dazu markieren Sie das Modul und wählen die Registerkarte CoE-Online aus. Mit einem Doppelklick auf den Index 0x8012:05Speed range können Sie die Grundfrequenz verändern (Abb. Grundfrequenz einstellen).
Grundfrequenz einstellen
Auswahl des Feedbacksystems
Das Modul mit Encoder-Anschlüssen stellt 2 Möglichkeiten für das Feedback-System zur Auswahl:
▪
Internal Counter (default): Internen Zähler zur Positionsrückführung nutzen
▪
Encoder: Externen Encoder zur Positionsrückführung nutzen
Einstellen des Feedback-Typs
In der Grundeinstellung ist das Steppermodul auf den internen Zähler gesetzt. Wenn ein externer Encoder eingesetzt wird, muss die Einstellung mit einem Doppelklick auf den Index 0x8012:08 Feedback type im Enum-Menü geändert werden (Abb. Feedbacksystem auswählen).
Feedbacksystem auswählen
KA-Faktor (nur EP7041-0002 und EP7041-1002)
Mit dem KA-Faktor kann der Strom in den Beschleunigungsphasen angepasst werden. Die Stromerhöhung wird wie folgt berechnet.
Stromerhöhung in mA = Geschwindigkeitsdifferenz x KA / 1000
Je steiler also die Geschwindigkeitsrampen sind, desto höher ist die Erhöhung des Stroms.
Geschwindigkeitsrampen
Dieser Wert lässt sich im Index 0x8011:07Ka factor (curr.) einstellen (siehe Abb. KA-Faktor einstellen).
KA-Faktor einstellen
Einstellungen in der NC
Auswahl der Bezugsgeschwindigkeit
Die Maximalgeschwindigkeit errechnet sich anhand der Grundfrequenz und der Motorfrequenz.
vmax = Grundfrequenz / Motorfrequenz = (2000 Fullsteps / s) / (200 Fullsteps / Umdrehung) = 10 Umdrehungen / s
Multipliziert man die Maximalgeschwindigkeit mit dem Weg pro Umdrehung, erhält man die Bezugsgeschwindigkeit.
vref = 10 Umdrehungen / s x 360° = 3600 °/ s
Parameter Bezugsgeschwindigkeit
Totzeitkompensation
Die Totzeitkompensation sollte theoretisch 3 Zyklen der NC-Zykluszeit betragen, besser haben sich jedoch 4 Zyklen der NC-Zykluszeit erwiesen. Bei einer Zykluszeit von 2 ms sollte diese somit 0,008 s betragen. Sie finden die Totzeitkompensation unter Weitere Einstellungen der Encoder-Parameter.
Parameter Totzeitkompensation
Skalierungsfaktor
Den Skalierungsfaktor können Sie ändern, wenn Sie in der NC Achse 1_Enc und die Registerkarte Parameter auswählen (siehe Abb. Skalierungsfaktor einstellen (Beispiel mit Encoder)). Der Wert lässt sich mit den unten angegebenen Formeln berechnen.
Skalierungsfaktor einstellen (Beispiel mit Encoder)
Berechnung des Skalierungsfaktors
mit Encoder:
SF = Weg pro Umdrehung / Inkremente x 4 = 360° / 1024 x 4 = 0,087890625 mm / INC
ohne Encoder:
SF = Weg pro Umdrehung / Fullsteps x Microsteps = 360° / 200 x 64 = 0,028125 mm / INC
Schleppüberwachung Position
Die Schleppabstandsüberwachung überwacht, ob der aktuelle Schleppabstand einer Achse einen Grenzwert überschreitet. Als Schleppabstand wird die Differenz zwischen ausgegebenem Sollwert (Stellgröße) und zurückgemeldetem Istwert bezeichnet. Sind die Parameter der Klemme noch unzureichend eingestellt, kann es dazu führen, dass beim Verfahren der Achse die Schleppabstandsüberwachung einen Fehler ausgibt. Bei der Inbetriebnahme kann es deswegen eventuell von Vorteil sein, wenn man die Grenzen der Schleppüberwachung Position etwas erhöht.
Hinweis
ACHTUNG: Beschädigung von Geräten, Maschinen und Peripherieteilen möglich!
Bei der Parametrierung der Schleppüberwachung können durch Einstellen zu hoher Grenzwerte Geräte, Maschinen und Peripherieteile beschädigt werden!
Schleppüberwachung einstellen
Kv-Faktoren (nur mit externem Encoder)
In der NC lassen sich unter Achse 1_Ctrl in der Registerkarte Parameter zwei Proportionalfaktoren Kv einstellen. Wählen Sie jedoch vorher unter der Registerkarte NC-Controller den Typ Positionsregler mit zwei P-Konstanten (mit Ka) aus. Die beiden P-Konstanten sind einmal für den Bereich Stillstand und ein weiteres Mal für den Bereich Fahren (siehe Abb. Proportionalfaktor KV einstellen). Damit hat man die Möglichkeit, im Anfahrmoment und im Bremsmoment ein anderes Drehmoment einzustellen als beim Fahren. Der Schwellwert lässt sich direkt darunter (Pos-Regelung: Geschw.schwelle V dyn) zwischen 0.0 (0%) und 1.0 (100%) einstellen. In der (Abb. Geschwindigkeitsrampe mit Grenzwerten des KV-Faktors) ist eine Geschwindigkeitsrampe mit Schwellwerten von 30% dargestellt. Im Bereich Stillstand (t1 und t3) kann dann ein unterschiedlicher Kv-Faktor eingestellt werden als im Bereich Fahren (t2). In diesem Fall ist jeweils der gleiche Faktor verwendet worden, da bei Steppermotoren diese Funktion nicht so ausschlaggebend ist, wie bei DC-Motoren.
Geschwindigkeitsrampe mit Grenzwerten des KV-Faktors
Proportionalfaktor KV einstellen
Totzone für Positionsfehler
Mit Hilfe des Microstepping können 200 x 64 = 12800 Positionen angefahren werden. Da der Encoder nur 1024 x 4 = 4096 Positionen abfragen kann, wird unter Umständen eine Position, die sich zwischen zwei Abtastpunkten des Encoders befindet, nicht richtig erfasst und die Klemme regelt um diese Position herum. Mit Hilfe der Totzone für Positionsfehler kann eine Toleranz angegeben werden, innerhalb der die Position als "erreicht" gesehen wird (Abb. Totzone für Positionsfehler).
Totzone für Positionsfehler
Einstellung der Hochlaufzeit
Um eventuell auftretende Resonanzen schnell zu durchfahren, sollten Hochlaufzeit und Bremszeit möglichst mit steilen Rampen gefahren werden.
Einstellung der Hochlaufzeit


Grundlagen zum Positioning Interface

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Grundlagen zum Positioning Interface
Grundlagen zum Positioning Interface
Das Positioning interface bietet dem Anwender eine Möglichkeit direkt auf der Klemme Fahraufträge auszuführen.
Weiterführende Informationen
•
Predefined PDO Assignment
•
Parametersatz
•
Informations- und Diagnosedaten
•
Zustände der internen Statemachine
•
Standard Ablauf eines Fahrauftrags
•
Starttypen
•
Modulo - allgemeine Beschreibung
•
Beispiele von zwei Fahraufträgen mit dynamischer Änderung der Zielposition


Predefined PDO Assignment

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Grundlagen zum Positioning Interface [image] Predefined PDO Assignment
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die Funktion "Positioning interface" oder "Positioning interface compact“ aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Predefined PDO Assignment


Parametersatz

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Grundlagen zum Positioning Interface [image] Parametersatz
Parametersatz
Für die Konfiguration stehen dem Anwender im CoE zwei Objekte zur Verfügung, die "POS Settings" (Index 0x8020) und die "POS Features" (Index 0x8021).
Settings-Objekte im CoE
POS Settings: Velocity min.:
Die Klemme benötigt aus Gründen der Performance beim Herunterrampen auf die Zielposition einen Sicherheitsbereich von 0,5 %. Das bedeutet, dass abhängig von der erreichten Maximalgeschwindigkeit und der konfigurierten Verzögerung der Zeitpunkt errechnet wird, an dem die Bremsrampe beginnt. Um immer sicher ins Ziel zu gelangen, werden von der ermittelten Position 0,5% abgezogen. Ist die Bremsrampe beendet und das Ziel noch nicht erreicht, fährt die Klemme mit der Geschwindigkeit "Velocity min." bis ins Ziel hinein. Sie muss so konfiguriert werden, dass der Motor in der Lage ist abrupt und ohne einen Schrittverlust mit dieser Geschwindigkeit abzustoppen.
Velocity max.:
Die maximale Geschwindigkeit, mit der der Motor während eines Fahrauftrages fährt
„Speed range" (Index 0x8012:05) [gilt für EL70x1]
Velocity min./max. sind auf die konfigurierte "Speed range" (Index 0x8012:05) normiert. Das bedeutet, dass bei einer „Speed range“ von beispielsweise 4000 Vollschritten/Sekunde für eine Geschwindigkeitsausgabe von 100% (d.h. 4000 Vollschritte/Sekunde) in „Velocity max.“ eine 10000 und bei 50% (d.h. 2000 Vollschritte/Sekunde) eine 5000 eingetragen werden muss
Acceleration pos.:
Beschleunigungszeit in positiver Drehrichtung.
Die 5 Parameter der Beschleunigung beziehen sich ebenfalls auf die eingestellte "Speed range" und werden in ms angegeben. Mit der Einstellung von 1000 beschleunigt die Klemme den Motor in 1000 ms von 0 auf 100%. Bei einer Geschwindigkeit von 50% verringert sich die Beschleunigungszeit dementsprechend linear auf die Hälfte.
Acceleration neg.:
Beschleunigungszeit in negativer Drehrichtung.
Deceleration pos.:
Verzögerungszeit in positiver Drehrichtung.
Deceleration neg.:
Verzögerungszeit in negativer Drehrichtung.
Emergency deceleration:
Notfall-Verzögerungszeit (beide Drehrichtungen). Ist im entsprechenden PDO "Emergency stop" gesetzt, wird der Motor innerhalb dieser Zeit gestoppt.
Calibration position:
Der aktuelle Zählerstand wird nach erfolgter Kalibrierung mit diesem Wert geladen.
Calibration velocity (towards plc cam):
Geschwindigkeit, mit der der Motor, während der Kalibrierung auf die Nocke fährt.
Calibration velocity (off plc cam):
Geschwindigkeit, mit der der Motor, während der Kalibrierung von der Nocke herunter fährt.
Target window:
Zielfenster der Fahrwegsteuerung. Kommt der Motor innerhalb dieses Zielfensters zum Stillstand, wird "In-Target" gesetzt
In-Target timeout:
Steht der Motor nach Ablauf der Fahrwegsteuerung nach dieser eingestellten Zeit nicht im Zielfenster, wird "In-Target" nicht gesetzt. Dieser Zustand kann nur durch Kontrolle der negativen Flanke von "Busy" erkannt werden.
Dead time compensation:
Kompensation der internen Laufzeiten. Dieser Parameter muss bei Standardanwendungen nicht geändert werden.
Modulo factor:
Der "Modulo factor" wird zur Berechnung der Zielposition und der Drehrichtung in den Modulo-Betriebsarten herangezogen. Er bezieht sich auf das angesteuerte System.
Modulo tolerance window:
Toleranzfenster zur Ermittlung der Startbedingung der Modulo-Betriebsarten.
POS Features:
Start type:
Der "Start type" bestimmt die Art der Berechnung für die Ermittlung der Zielposition (siehe unten).
Time information:
Durch diesen Parameter wird die Bedeutung der angezeigten "Actual drive time" konfiguriert. Zurzeit kann dieser Wert nicht verändert werden, da es keine weitere Auswahlmöglichkeit gibt. Es wird die abgelaufene Zeit des Fahrauftrages angezeigt.
Invert calibration cam search direction:
Bezogen auf eine positive Drehrichtung wird hier die Richtung der Suche nach der Kalibrier-Nocke konfiguriert (auf die Nocke fahren).
Invert sync impulse search direction:
Bezogen auf eine positive Drehrichtung wird hier die Richtung der Suche nach dem HW-Sync-Impuls konfiguriert (von der Nocke herunter fahren).


Informations- und Diagnosedaten

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Grundlagen zum Positioning Interface [image] Informations- und Diagnosedaten
Informations- und Diagnosedaten
Über die Informations- und Diagnosedaten kann der Anwender eine genauere Aussage darüber erhalten, welcher Fehler während eines Fahrauftrages aufgetreten ist.
Diagnose-Objekte im CoE
POS Info data:
Status word:
Das "Status word" spiegelt die im Index 0xA020 verwendeten Status-Bits in einem Datenwort, um diese in der PLC einfacher verarbeiten zu können. Die Positionen der Bits entsprechen der Nummer des Subindizes-1.
Bit 0: Command rejected
Bit 1: Command aborded
Bit 2: Target overrun
State (drive controller):
Hier wird der aktuelle Status der internen Statemachine eingeblendet (siehe unten).
POS Diag data:
Command rejected:
Eine dynamische Änderung der Zielposition wird nicht zu jedem Zeitpunkt von der Klemme übernommen, da dies dann nicht möglich ist. Der neue Auftrag wird in diesem Fall abgewiesen und durch setzen dieses Bits signalisiert.
Diese 3 Diagnose-Bits werden durch Setzten von "Warning" im PDO zur Steuerung synchron übertragen.
Command aborted:
Der aktuelle Fahrauftrag wurde durch einen internen Fehler oder durch ein "Emergency stop" vorzeitig abgebrochen.
Target overrun:
Bei einer dynamischen Änderung der Zielposition kann es vorkommen, dass die Änderung zu einem relativ späten Zeitpunkt erfolgt. Dies kann zur Folge haben, dass ein Drehrichtungswechsel erforderlich ist und ggf. die neue Zielposition überfahren wird. Tritt dies ein, so wird "Target overrun" gesetzt.


Zustände der internen Statemachine

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Grundlagen zum Positioning Interface [image] Zustände der internen Statemachine
Zustände der internen Statemachine
Der State (drive controller) (Index 0x9020:03) gibt Auskunft über den aktuellen Zustand der internen Statemachine. Zu Diagnosezwecken kann dieser zur Laufzeit von der PLC ausgelesen werden. Der interne Zyklus arbeitet konstant mit 250 µs. Ein angeschlossener PLC-Zyklus ist großer Wahrscheinlichkeit nach langsamer (z. B. 1 ms). Daher kann es vorkommen, dass manche Zustände in der PLC überhaupt nicht sichtbar sind, da diese teilweise nur einen internen Zyklus durchlaufen werden.
Name | ID | Beschreibung
INIT | 0x0000 | Initialisierung/Vorbereitung für den nächsten Fahrauftrag.
IDLE | 0x0001 | Warten auf den nächsten Fahrauftrag.
START | 0x0010 | Das neue Kommando wird ausgewertet und die entsprechenden Berechnungen durchgeführt.
ACCEL | 0x0011 | Beschleunigungs-Phase.
CONST | 0x0012 | Konstant-Phase
DECEL | 0x0013 | Verzögerungs-Phase
EMCY | 0x0020 | Es wurde ein Emergency stop ausgelöst.
STOP | 0x0021 | Der Motor ist gestoppt.
CALI_START | 0x0100 | Start eines Kalibrierkommandos.
CALI_GO_CAM | 0x0110 | Der Motor wird auf die Nocke gefahren.
CALI_ON_CAM | 0x0111 | Die Nocke wurde erreicht.
CALI_GO_SYNC | 0x0120 | Der Motor wird in Richtung des HW-Sync-Impulses gefahren.
CALI_LEAVE_CAM | 0x0121 | Der Motor wird von der Nocke herunter gefahren.
CALI_STOP | 0x0130 | Ende der Kalibrier-Phase.
CALIBRATED | 0x0140 | Der Motor ist kalibriert.
NOT_CALIBRATED | 0x0141 | Der Motor ist nicht kalibriert.
PRE_TARGET | 0x1000 | Sollposition ist erreicht, der Positionsregler "zieht" den Motor weiter ins Ziel, In-Target timeout wird hier gestartet.
TARGET | 0x1001 | Der Motor hat das Zielfenster innerhalb des Timeouts erreicht.
TARGET_RESTART | 0x1002 | Eine dynamische Änderung der Zielposition wird hier verarbeitet.
END | 0x2000 | Ende der Positionier-Phase.
WARNING | 0x4000 | Während des Fahrauftrages ist ein Warn-Zustand aufgetreten, dieser wird hier verarbeitet.
ERROR | 0x8000 | Während des Fahrauftrages ist ein Fehler-Zustand aufgetreten, dieser wird hier verarbeitet.
UNDEFINED | 0xFFFF | Undefinierter Zustand (kann z.B. auftreten, wenn die Treiberstufe keine Steuerspannung hat).


Standard Ablauf eines Fahrauftrags

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Grundlagen zum Positioning Interface [image] Standard Ablauf eines Fahrauftrags
Standard Ablauf eines Fahrauftrags
Im folgenden Ablaufdiagramm ist ein "normaler" Ablauf eines Fahrauftrags dargestellt.
Es wird grob zwischen diesen vier Stufen unterschieden:
Startup
Überprüfung des Systems und der Betriebsbereitschaft des Motors.
Start positioning
Schreiben aller Variablen und Berechnung der gewünschten Zielposition mit dem entsprechenden "Start type". Anschließend den Fahrauftrag starten.
Evaluate status
Überwachung des Klemmen-Status und ggf. dynamische Änderung der Zielposition.
Error handling
Im Falle eines Fehlers die nötigen Informationen aus dem CoE beziehen und auswerten.
Ablauf-Diagramm eines Fahrauftrages


Starttypen

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Grundlagen zum Positioning Interface [image] Starttypen
Starttypen
Das Positioning Interface bietet verschiedene Arten der Positionierung. Die folgende Tabelle enthält alle unterstützten Kommandos, diese sind in vier Gruppen aufgeteilt.
Unterstützte Start Types des Positioning Interfaces
Name | Kommando | Gruppe | Beschreibung
ABSOLUTE | 0x0001 | Standard | Absolute Positionierung auf eine vorgegebene Zielposition
RELATIVE | 0x0002 |  | Relative Positionierung auf eine berechnete Zielposition, ein vorgegebener Positionsunterschied wird zur aktuelle Position addiert
ENDLESS_PLUS | 0x0003 |  | Endlos fahren in positiver Drehrichtung (direkte Vorgabe einer Geschwindigkeit)
ENDLESS_MINUS | 0x0004 |  | Endlos fahren in negativer Drehrichtung (direkte Vorgabe einer Geschwindigkeit)
ADDITIVE | 0x0006 |  | Additive Positionierung auf eine berechnete Zielposition, ein vorgegebener Positionsunterschied wird zur letzten Zielposition addiert
ABSOLUTE_CHANGE | 0x1001 | Standard Ext. | Dynamische Änderung der Zielposition währen eines Fahrauftrages auf eine neue, absolute Position
RELATIVE_CHANGE | 0x1002 |  | Dynamische Änderung der Zielposition währen eines Fahrauftrages auf eine neue, relative Position (es wird hier ebenfalls der aktuelle, sich verändernde Positionswert verwendet)
ADDITIVE_CHANGE | 0x1006 |  | Dynamische Änderung der Zielposition währen eines Fahrauftrages auf eine neue, additive Position (es wird hier die letzte Zielposition verwendet)
MODULO_SHORT | 0x0105 | Modulo | Modulo Positionierung auf kürzestem Weg zur Moduloposition (positiv oder negativ), berechnet durch den konfigurierten "Modulo factor" (Index 0x8020:0E)
MODULO_SHORT_EXT | 0x0115 |  | Modulo Positionierung auf kürzestem Weg zur Moduloposition, das "Modulo tolerance window" (Index 0x8020:0F) wird ignoriert
MODULO_PLUS | 0x0205 |  | Modulo Positionierung in positiver Drehrichtung auf die berechnete Moduloposition
MODULO_PLUS_EXT | 0x0215 |  | Modulo Positionierung in positiver Drehrichtung auf die berechnete Moduloposition, das "Modulo tolerance window" wird ignoriert
MODULO_MINUS | 0x0305 |  | Modulo Positionierung in negativer Drehrichtung auf die berechnete Moduloposition
MODULO_MINUS_EXT | 0x0315 |  | Modulo Positionierung in negativer Drehrichtung auf die berechnete Moduloposition, das "Modulo tolerance window" wird ignoriert
MODULO_CURRENT | 0x0405 |  | Modulo Positionierung mit der letzten Drehrichtung auf die berechnete Moduloposition
MODULO_CURRENT_EXT | 0x0415 |  | Modulo Positionierung mit der letzten Drehrichtung auf die berechnete Moduloposition, das "Modulo tolerance window" wird ignoriert
CALI_PLC_CAM | 0x6000 | Calibration | Starten einer Kalibrierung mit Nocke (digitale Eingänge)
CALI_HW_SYNC | 0x6100 |  | Starten einer Kalibrierung mit Nocke und HW-Sync-Impuls (C-Spur)
SET_CALIBRATION | 0x6E00 |  | Manuelles Setzen der Klemme auf "Kalibriert"
SET_CALIBRATION_AUTO | 0x6E01 |  | Automatisches Setzen der Klemme auf "Kalibriert" bei der ersten steigenden Flanke von "Enable"
CLEAR_CALIBRATION | 0x6F00 |  | Manuelles Löschen der Kalibrierung
ABSOLUTE
Die absolute Positionierung stellt den einfachsten Fall einer Positionierung dar. Es wird eine Position B vorgegeben, welche vom Startpunkt A aus angefahren wird.
Absolute Positionierung
RELATIVE
Bei der relativen Positionierung gibt der Anwender ein Positionsdelta S vor, welches zur aktuellen Position A addiert wird und die Zielposition B ergibt.
Relative Positionierung
ENDLESS_PLUS / ENDLESS_MINUS
Die beiden Starttypen ENDLESS_PLUS und ENDLESS_MINUS bieten im Positioning Interface die Möglichkeit dem Motor eine direkte Geschwindigkeit vorzugeben, um endlos in positiver oder negativer Richtung, mit den vorgegebenen Beschleunigungen, zu fahren.
Endlos fahren
ADDITIVE
Für die additive Positionierung wird, zur Berechnung der Zielposition B, das vom Anwender vorgegebene Positionsdelta S mit der beim letzten Fahrauftrag verwendeten Zielposition E addiert.
Diese Art der Positionierung ähnelt der relativen Positionierung, hat aber doch einen Unterschied. Wurde der letzte Fahrauftrag mit Erfolg abgeschlossen, ist die neue Zielposition gleich. Gab es aber einen Fehler, sei es dass der Motor in eine Stallsituation geraten ist oder ein Emergency stop ausgelöst wurde, ist die aktuelle Position beliebig und nicht vorausschaubar. Der Anwender hat jetzt den Vorteil, dass er die letzte Zielposition für die Berechnung der folgenden Zielposition nutzen kann.
Additive Positionierung
ABSOLUTE_CHANGE / RELATIVE_CHANGE / ADDITIVE_CHANGE
Diese drei Positionierarten sind komplett identisch zu den oben beschrieben. Der wichtige Unterschied dabei ist, dass der Anwender während eines aktiven Fahrauftrags diese Kommandos nutzt, um dynamisch eine neue Zielposition vorzugeben.
Es gelten dabei die gleichen Regeln und Voraussetzungen, wie bei den "normalen" Starttypen. ABSOLUTE_CHANGE und ADDITIVE_CHANGE sind in der Berechnung der Zielposition eindeutig d.h. bei der absoluten Positionierung wird eine absolute Position vorgegeben und bei der additiven Positionierung wird ein Positionsdelta zu der gerade aktiven Zielposition addiert.
Hinweis
Vorsicht bei der Verwendung der Positionierung RELATIVE_CHANGE
Die Änderung per RELATIVE_CHANGE muss mit Vorsicht angewendet werden, da auch hier die aktuelle Position des Motors als Startposition verwendet wird. Durch Laufzeiten des Systems stimmt die im PDO angezeigte Position nie mit der realen Position des Motors überein! Daher wird sich bei der Berechnung des übergebenen Positionsdeltas immer eine Differenz zur gewünschten Zielposition einstellen.
Zeitpunkt der Änderung der Zielposition
Eine Änderung der Zielposition kann nicht zu jedem beliebigen Zeitpunkt erfolgen. Falls die Berechnung der Ausgabeparameter ergibt, dass die neue Zielposition nicht ohne weiteres erreicht werden kann, wird das Kommando von der Klemme abgewiesen und das Bit Command rejected gesetzt. Dies ist z. B. im Stillstand (da die Klemme hier eine Standard Positionierung erwartet) und in der Beschleunigungsphase (da zu diesem Zeitpunkt der Bremszeitpunkt noch nicht berechnet werden kann) der Fall.
CALI_PLC_CAM / CALI_HW_SYNC / SET_CALIBRATION / SET_CALIBRATION_AUTO / CLEAR_CALIBRATION
Der einfachste Fall einer Kalibrierung ist der, nur per Nocke (an einem dig. Eingang angeschlossen) zu kalibrieren.
Hier bei fährt der Motor im 1. Schritt mit der Geschwindigkeit 1 (Index 0x8020:09) in Richtung 1 (Index 0x8021:13) auf die Nocke. Anschließend im 2. Schritt mit der Geschwindigkeit 2 (Index 0x8020:0A) in Richtung 2 (Index 0x8021:14) von der Nocke herunter. Nachdem das In-Target timeout (Index 0x8020:0C) abgelaufen ist wird die Kalibrierposition (Index 0x8020:08) als aktuelle Position von der Klemme übernommen.
Hinweis
Schalthysterese des Nockenschalters beachten
Bei dieser einfachen Kalibrierung muss beachtet werden, dass die Positionserfassung der Nocke nur bedingt genau ist. Die digitalen Eingänge sind nicht Interrupt gesteuert und werden "nur" gepollt. Durch die internen Laufzeiten kann sich deshalb eine systembedingte Positionsdifferenz ergeben.
Kalibrierung mit Nocke
Für eine genauere Kalibrierung wird zusätzlich zu der Nocke ein HW-Sync-Impuls (C-Spur) verwendet. Der Ablauf dieser Kalibrierung erfolgt genau wie oben beschrieben, bis zu dem Zeitpunkt, an dem der Motor von der Nocke herunterfährt. Jetzt wird nicht sofort gestoppt, sondern erst auf den Sync-Impuls gewartet. Anschließend läuft wieder das In-Target timeout ab und die Kalibrierposition wird als aktuelle Position von der Klemme übernommen.
Kalibrierung mit Nocke und C-Spur
Falls eine Kalibrierung per Hardware, aufgrund der applikatorischen Umstände, nicht möglich ist, kann der Anwender das Bit Calibrated auch manuell bzw automatisch setzen. Das manuelle Setzen bzw. Löschen erfolgt mit den Kommandos SET_CALIBRATION und CLEAR_CALIBRATION.
Einfacher ist es aber, wenn man den Standard-Starttypen (Index 0x8021:01) auf SET_CALIBRATION_AUTO konfiguriert. Jetzt wird bei der ersten steigenden Flanke von Enable das Bit Calibrated automatisch gesetzt. Das Kommando ist nur für diesen Zweck konzipiert, daher ist es nicht sinnvoll es über den synchronen Datenaustausch zu benutzen.


Modulo - allgemeine Beschreibung

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Grundlagen zum Positioning Interface [image] Modulo - allgemeine Beschreibung
Modulo - allgemeine Beschreibung
MODULO
Die Modulo-Position der Achse ist eine zusätzliche Information zur absoluten Achsposition und die Modulo-Positionierung stellt die gewünschte Zielposition auf eine andere Art dar. Im Gegensatz zu den Standard-Positionierarten, birgt die Modulo-Positionierung einige Tücken, da die gewünschte Zielposition unterschiedlich interpretiert werden kann.
Die Modulo-Positionierung bezieht sich grundsätzlich auf den im CoE einstellbaren Modulo factor (Index 0x8020:0E). In den folgenden Beispielen wird von einer rotatorischen Achse mit einem Modulo factor von umgerechnet 360 Grad ausgegangen.
Das Modulo tolerance window (Index 0x8020:0F) definiert ein Positionsfenster um die aktuelle Modulo-Sollposition der Achse herum. Die Fensterbreite entspricht dem doppelten angegebenen Wert (Sollposition ± Toleranzwert). Auf das Toleranzfenster wird im Folgenden näher eingegangen.
Die Positionierung einer Achse bezieht sich immer auf deren aktuellen Ist-Position. Die Ist-Position der Achse ist im Normalfall die Position, die mit dem letzten Fahrauftrag angefahren wurde. Unter Umständen (fehlerhafte Positionierung durch einen Stall der Achse, oder eine sehr grobe Auflösung des angeschlossenen Encoders) kann sich aber eine vom Anwender nicht erwartete Position einstellen. Wenn dieser Umstand nicht berücksichtigt wird, kann sich eine nachfolgende Positionierung unerwartet verhalten.
Wirkung des Modulo-Toleranzfensters - Modulo-Zielposition 0° in positiver Richtung
Beispiel
Eine Achse wird auf 0° positioniert, wodurch die Ist-Position der Achse anschließend exakt 0° beträgt. Ein weiterer Modulo-Fahrauftrag auf 360° in positiver Richtung führt zu einer vollen Umdrehung und die Modulo-Position der Achse ist anschließend wieder exakt 0°. Kommt die Achse bedingt durch die Mechanik etwas vor oder hinter der Zielposition zum Stehen, so verhält sich das nächste Fahrkommando ggf. nicht so, wie man es erwartet. Liegt die Ist-Position leicht unter 0° (siehe Abb. Kalibrierung mit Nocke, links unten), so führt ein neues Fahrkommando auf 0° in positiver Richtung nur zu einer minimalen Bewegung. Die vorher entstandene Abweichung wird ausgeglichen und die Position ist anschließend wieder exakt 0°. Liegt aber die Position leicht über 0°, so führt dasselbe Fahrkommando zu einer vollen Umdrehung um wieder die exakte Position von 0° zu erreichen. Diese Problematik tritt auf, wenn volle Umdrehungen um 360° oder ein Vielfaches von 360° beauftragt werden. Bei Positionierungen auf einen von der aktuellen Modulo-Position entfernten Winkel ist der Fahrauftrag eindeutig.
Um das Problem zu lösen, kann ein Modulo tolerance window (Index 0x8020:0F) parametriert werden. Kleine Abweichungen der Position, die innerhalb des Fensters liegen, führen damit nicht mehr zu einem unterschiedlichen Verhalten der Achse. Wird beispielsweise ein Fenster von 1° parametriert, so verhält sich die Achse im oben beschriebenen Fall gleich, solange die Ist-Position zwischen 359° und 1° liegt. Wenn jetzt die Position weniger als 1° über 0° liegt, wird die Achse bei einem Modulo-Start in positiver Richtung zurückpositioniert. Bei einer Zielposition von 0° wird also in beiden Fällen eine Minimalbewegung auf exakt 0° ausgeführt und bei einer Zielposition von 360° wird in beiden Fällen eine ganze Umdrehung gefahren.
Das Modulo-Toleranzfenster kann also innerhalb des Fensters zu Bewegungen gegen die beauftragte Richtung führen. Bei einem kleinen Fenster ist das normalerweise unproblematisch, weil auch Regelabweichungen zwischen Soll- und Ist-Position in beide Richtungen ausgeglichen werden. Das Toleranzfenster lässt sich also auch bei Achsen verwenden, die konstruktionsbedingt nur in einer Richtung verfahren werden dürfen.
Modulo-Positionierung um weniger als eine Umdrehung
Die Modulo-Positionierung von einer Ausgangsposition auf eine nicht identische Zielposition ist eindeutig und birgt keine Besonderheiten. Eine Modulo-Zielposition im Bereich [0 ≤ Position < 360] führt in weniger als einer ganzen Umdrehung zum gewünschten Ziel. Ist die Zielposition mit der Ausgangsposition identisch, so wird keine Bewegung ausgeführt. Bei Zielpositionen ab 360° aufwärts werden ein oder mehr vollständige Umdrehungen ausgeführt, bevor die Achse auf die gewünschte Zielposition fährt.
Für eine Bewegung von 270° auf 0° darf demnach nicht 360°, sondern es muss 0° als Modulo-Zielposition beauftragt werden, da 360° außerhalb des Grundbereiches liegt und zu einer zusätzlichen Umdrehung führen würde.
Die Modulo-Positionierung unterscheidet drei Richtungsvorgaben, positive Richtung, negative Richtung und auf kürzestem Weg (MODULO_PLUS, MODULO_MINUS, MODULO_SHORT). Bei der Positionierung auf kürzestem Weg sind Zielpositionen ab 360° nicht sinnvoll, da das Ziel immer direkt angefahren wird. Im Gegensatz zur positiven oder negativen Richtung können also nicht mehrere Umdrehungen ausgeführt werden, bevor das Ziel angefahren wird.
Hinweis
Nur Grundperioden kleiner 360° sind erlaubt
Bei Modulo-Positionierungen mit dem Start-Typ MODULO_SHORT sind nur Modulo-Zielpositionen in der Grundperiode (z. B. kleiner als 360°) erlaubt, anderenfalls wird ein Fehler zurückgegeben.
Positionierung ohne Modulo-Toleranzfenster
Bei den "normalen" Modulo-Positionierarten wird immer das "Modulo tolerance window" (Index 0x8020:0F) berücksichtigt. In manchen Situationen ist dies aber eher unerwünscht. Um diesen "Nachteil" zu eliminieren, können die vergleichbaren Starttypen "MODULO_SHORT_EXT", "MODULO_PLUS_EXT", "MODULO_MINUS_EXT" und "MODULO_CURRENT_EXT" verwendet werden, welche das Modulo-Toleranzfenster ignorieren.
Die folgende Tabelle zeigt Beispiele zur Modulo-Positionierung bei weniger als einer Umdrehung.
Modulo-Starttyp | Absolute Anfangsposition | Modulo- Zielposition | Relativer Verfahrweg | Absolute Endposition | Modulo Endposition
MODULO_PLUS | 90° | 0° | 270° | 360° | 0°
MODULO_PLUS | 90° | 360° | 630° | 720° | 0°
MODULO_PLUS | 90° | 720° | 990° | 1080° | 0°
MODULO_MINUS | 90° | 0° | -90° | 0° | 0°
MODULO_MINUS | 90° | 360° | -450° | -360° | 0°
MODULO_MINUS | 90° | 720° | -810° | -720° | 0°
MODULO_SHORT | 90° | 0° | -90° | 0° | 0°
Modulo-Positionierung um ganze Umdrehungen
Modulo-Positionierungen um ein oder mehrere ganze Umdrehungen verhalten sich grundsätzlich nicht anders als Positionierungen auf von der Ausgangsposition entfernt liegende Winkel. Wenn die beauftragte Zielposition gleich der Ausgangsposition ist, so wird keine Bewegung ausgeführt. Für eine ganze Umdrehung muss zur Ausgangsposition 360° addiert werden. Das beschriebene Verhalten im Beispiel zeigt, dass Positionierungen mit ganzzahligen Umdrehungen besonders beachtet werden müssen. Die nachfolgende Tabelle zeigt Positionierbeispiele für eine Ausgangsposition von ungefähr 90°. Das Modulo-Toleranzfenster ist hier auf 1° eingestellt. Besondere Fälle, in denen die Ausgangsposition außerhalb dieses Fensters liegt, sind gekennzeichnet.
Die folgende Tabelle zeigt Beispiele zur Modulo-Positionierung bei ganzen Umdrehungen.
Modulo-Starttyp | Absolute Anfangs- position | Modulo- Ziel- position | Relativer Verfahrweg | Absolute Endposition | Modulo Endposition | Anmerkung
MODULO_PLUS | 90,00° | 90,00° | 0,00° | 90,00° | 90,00° |
MODULO_PLUS | 90,90° | 90,00° | -0,90° | 90,00° | 90,00° |
MODULO_PLUS | 91,10° | 90,00° | 358,90° | 450,00° | 90,00° | außerhalb TF
MODULO_PLUS | 89,10° | 90,00° | 0,90° | 90,00° | 90,00° |
MODULO_PLUS | 88,90° | 90,00° | 1,10° | 90,00° | 90,00° | außerhalb TF
MODULO_PLUS | 90,00° | 450,00 | 360,00° | 450,00° | 90,00° |
MODULO_PLUS | 90,90° | 450,00° | 359,10° | 450,00° | 90,00° |
MODULO_PLUS | 91,10° | 450,00° | 718,90° | 810,00° | 90,00° | außerhalb TF
MODULO_PLUS | 89,10° | 450,00° | 360,90° | 450,00° | 90,00° |
MODULO_PLUS | 88,90° | 450,00° | 361,10° | 450,00° | 90,00° | außerhalb TF
MODULO_PLUS | 90,00° | 810,00 | 720,00° | 810,00° | 90,00° |
MODULO_PLUS | 90,90° | 810,00 | 719,10° | 810,00° | 90,00° |
MODULO_PLUS | 91,10° | 810,00 | 1078,90° | 1170,00° | 90,00° | außerhalb TF
MODULO_PLUS | 89,10° | 810,00 | 720,90° | 810,00° | 90,00° |
MODULO_PLUS | 88,90° | 810,00 | 721,10° | 810,00° | 90,00° | außerhalb TF
MODULO_MINUS | 90,00° | 90,00° | 0,00° | 90,00° | 90,00° |
MODULO_MINUS | 90,90° | 90,00° | -0,90° | 90,00° | 90,00° |
MODULO_MINUS | 91,10° | 90,00° | -1,10° | 90,00° | 90,00° | außerhalb TF
MODULO_MINUS | 89,10° | 90,00° | 0,90° | 90,00° | 90,00° |
MODULO_MINUS | 88,90° | 90,00° | -358,90° | -270,00° | 90,00° | außerhalb TF
MODULO_MINUS | 90,00° | 450,00° | -360,00° | -270,00° | 90,00° |
MODULO_MINUS | 90,90° | 450,00° | -360,90° | -270,00° | 90,00° |
MODULO_MINUS | 91,10° | 450,00° | -361,10° | -270,00° | 90,00° | außerhalb TF
MODULO_MINUS | 89,10° | 450,00° | -359,10° | -270,00° | 90,00° |
MODULO_MINUS | 88,90° | 450,00° | -718,90° | -630,00° | 90,00° | außerhalb TF
MODULO_MINUS | 90,00° | 810,00° | -720,00° | -630,00° | 90,00° |
MODULO_MINUS | 90,90° | 810,00° | -720,90° | -630,00° | 90,00° |
MODULO_MINUS | 91,10° | 810,00° | -721,10° | -630,00° | 90,00° | außerhalb TF
MODULO_MINUS | 89,10° | 810,00° | -719,10° | -630,00° | 90,00° |
MODULO_MINUS | 88,90° | 810,00° | -1078,90° | -990,00° | 90,00° | außerhalb TF


Beispiele von zwei Fahraufträgen mit dynamischer Änderung der Zielposition

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Grundlagen zum Positioning Interface [image] Beispiele von zwei Fahraufträgen mit dynamischer Änderung der Zielposition
Beispiele von zwei Fahraufträgen mit dynamischer Änderung der Zielposition
Ohne Überfahren der Zielposition
Zeitpunkt
POS Outputs
POS Inputs
Beschreibung
t1:
Execute = 1
Target position = 200000
Velocity = 2000
Start type = 0x0001
Acceleration = 1000
Deceleration = 1000
Busy = 1
Accelerate = 1
▪
Vorgabe der ersten Parameter
▪
Beginn der Beschleunigungsphase
t2:
Accelerate = 0
▪
Ende der Beschleunigungsphase
t3:
Target position = 100000
Velocity = 1500
Start type = 0x1001
Acceleration = 2000
Deceleration = 2000
▪
Änderung der Parameter
▪
Aktivierung durch neuen Starttypen
t4:
Decelerate = 1
▪
Beginn der Verzögerungsphase
t5:
Execute = 0
Busy = 0
In-Target = 1
Decelerate = 0
▪
Ende der Verzögerungsphase
▪
Motor ist auf neuer Zielposition
t6 - t9:
▪
Absolute Fahrt zurück auf die Startposition 0
Scope-Aufnahme ohne Überfahren der Zielposition
Die Achsen-Skalierung bezieht sich nur auf die Positionen, nicht auf die Geschwindigkeit und die Status-Bits.
Mit Überfahren der Zielposition
Zeitpunkt
POS Outputs
POS Inputs
Beschreibung
t1
Execute = 1
Target position = 200000
Velocity = 5000
Start type = 0x0001
Acceleration = 3000
Deceleration = 5000
Busy = 1
Accelerate = 1
▪
Vorgabe der 1. Parameter
▪
Beginn der 1. Beschleunigungsphase
t2:
Accelerate = 0
▪
Ende der 1. Beschleunigungsphase
t3
Target position = 100000
Velocity = 1500
Start type = 0x1001
Acceleration = 1000
Deceleration = 2000
Warning = 1
Decelerate = 1
▪
Änderung der Parameter
▪
Aktivierung durch neuen Starttypen
▪
Warnung vor dem Überfahren der Zielposition
▪
Beginn der 1. Verzögerungsphase
t4
Accelerate = 1
Decelerate = 0
▪
Ende der 1. Verzögerungsphase
▪
Beginn der 2. Beschleunigungsphase in Gegenrichtung
t5
Accelerate = 0
Decelerate = 1
▪
Ende der 2. Beschleunigungsphase
▪
Beginn der 2. Verzögerungsphase
t6
Execute = 0
Busy = 0
In-Target = 1
Decelerate = 0
▪
Ende der 2.Verzögerungsphase
▪
Motor ist auf neuer Zielposition
t7 - t10
▪
Absolute Fahrt zurück auf die Startposition 0
Scope-Aufnahme mit Überfahren der endgültigen Zielposition
Die Achsen-Skalierung bezieht sich nur auf die Positionen, nicht auf die Geschwindigkeit und die Status-Bits.


Anwendungsbeispiel

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Anwendungsbeispiel
Anwendungsbeispiel
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Motoransteuerung mit Visualisierung
Beispielprogramm ( )
Verwendeter Master: TwinCAT 2.11 (bei älteren Versionen muss der Regelkreis manuell programmiert werden, der in diesem Fall bereits in der NC implementiert ist).
Mit diesem Anwendungsbeispiel lässt sich ein Motor mit Hilfe der Visualisierung in eine beliebige Position fahren oder im Endlosmodus betreiben. Dabei kann die Geschwindigkeit, die Anfahrbeschleunigung und die Bremsbeschleunigung festgelegt werden.
Das Beispielprogramm besteht aus 2 Dateien (PLC-Datei und System Manager Datei).
Öffnen Sie zunächst die PLC-Datei und kompilieren Sie die Datei, damit Sie für den System Manager die *.tpy Datei zur Verfügung haben.
Beachten Sie, dass Sie im PLC-Programm gegebenenfalls die Zielplattform anpassen müssen (default: PC oder CX 8x86). Sollten Sie das ändern müssen, können Sie unter der Registerkarte Ressourcen -> Steuerungskonfiguration die richtige Zielplattform auswählen.
Auswahl der Zielplattform
Bei der System Manager Datei muss folgendes beachtet werden:
▪
Starten Sie den System Manager im Konfig-Modus.
▪
Stellen Sie sicher, dass die E/A-Konfiguration mit Ihrer tatsächlichen Konfiguration übereinstimmt. Im Beispielprogramm ist nur eine EL7041 integriert. Wenn Sie weitere Klemmen angeschlossen haben, müssen Sie diese zusätzlich einfügen oder Ihre Konfiguration neu einscannen.
▪
Sie müssen die MAC-Adresse anpassen. Klicken Sie dazu auf Ihr EtherCAT-Gerät, anschließend wählen Sie die Registerkarte Adapter und klicken hinter der MAC-Adresse auf Suchen (siehe Abb. Auswahl der MAC-Adresse). Dort wählen Sie den richtigen Adapter aus.
Auswahl der MAC-Adresse
▪
Bei der SPS-Konfiguration muss der Pfad des SPS-Programms angepasst werden. Klicken Sie dazu auf das angefügte SPS-Programm und wählen Sie die Registerkarte IEC1131 aus (siehe Abb. Ändern des SPS-Pfades). Dort müssen Sie Ändern anwählen und den richtigen Pfad bestimmen.
Ändern des SPS-Pfades
▪
Unter NC-Konfiguration ist bereits eine EL7041 mit der NC verknüpft. Sollten Sie diese neu verknüpfen müssen oder zusätzliche hinzufügen wollen, dann gehen Sie bitte wie im Kapitel "Einbindung in die NC-Konfiguration" vor.
Das PLC-Programm setzt sich wie folgt zusammen. Die Bibliotheken TcMC.lib und TcNC.lib müssen eingebunden werden (siehe Abb. Erforderliche Bibliotheken).
Erforderliche Bibliotheken
Anschließend werden einige globale Variablen deklariert (siehe Abb. Globale Variablen). Die Datentypen PLCTONC_AXLESTRUCT und NCTOPLC_AXLESTRUCT sorgen für die Kommunikation zwischen der PLC und der NC.
Globale Variablen
Nachdem die globalen Variablen deklariert worden sind, können Sie mit der Programmierung starten. Dazu deklarieren Sie vorerst die lokalen Variablen (siehe Abb. Lokale Variablen).
MC_Direction ist ein Aufzählungstyp, der dem Baustein MC_MoveVelocity die Bewegungsrichtung vorgibt, der wiederum eine Endlosfahrt des Motors durchführt.
Mit dem Funktionsbaustein MC_Reset wird ein Reset der Achse durchgeführt. MC_MoveAbsolute ist ein Funktionsbaustein mit dem eine absolute Positionierung durchgeführt wird. Mit dem Funktionsbaustein MC_ReadActualPosition kann die aktuelle Position der Achse gelesen werden.
MC_Power gibt die Achse frei und MC_Stop wird für das Stoppen der Achse benötigt.
Lokale Variablen
Der Programmcode lautet wie folgt (siehe Abb. Programmcode):
Programmcode
Mit Hilfe der folgenden Visualisierung (siehe Abb. Visualisierung) kann der Motor anschließend betrieben werden.
Bitte betätigen Sie den Taster Enable, um die Freigaben für die Achse zu setzen. Sie können jetzt im "Free run mode" den Taster Left oder Right betätigen und der Motor dreht sich mit einer im fbMoveVelocity_Axis_1 definierten Geschwindigkeit, in die ausgewählte Richtung, oder Sie können im "Absolute mode" Geschwindigkeit, Beschleunigung, Bremsbeschleunigung und die anzufahrende Position angeben und mit Start Job die Fahrt starten. Wenn Sie bei der Beschleunigung und der Bremsbeschleunigung nichts angeben, wird der Default-Wert der NC benutzt.
Visualisierung
Informationen zu Funktionsbausteinen und Datentypen
Weitere Informationen zu den verwendeten Funktionsbausteinen und Datentypen erhalten Sie im aktuellen Beckhoff Information System.


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme/Konfiguration [image] Einbinden in TwinCAT [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx- und EPPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


CoE-Objekte EP7041-0002, EP7041-1002, EP7041-2002

Inbetriebnahme/Konfiguration [image] CoE-Objekte EP7041-0002, EP7041-1002, EP7041-2002
CoE-Objekte EP7041-0002, EP7041-1002, EP7041-2002
Weiterführende Informationen
•
Objektbeschreibung und Parametrierung


Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration [image] CoE-Objekte EP7041-0002, EP7041-1002, EP7041-2002 [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
Gültig für EP7041-0002, EP7041-1002 und EP7041-2002.
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zu Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
▪
Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Objekte für die Inbetriebnahme
•
Standardobjekte (0x1000 .. 0x1FFF)
•
Profilspezifische Objekte (0x6000 .. 0xFFFF)


Objekte für die Inbetriebnahme

Inbetriebnahme/Konfiguration [image] CoE-Objekte EP7041-0002, EP7041-1002, EP7041-2002 [image] Objektbeschreibung und Parametrierung [image] Objekte für die Inbetriebnahme
Objekte für die Inbetriebnahme
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 ENC Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | ENC Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x0F (15dez)
8000:08 | Disable filter | Deaktiviert die Eingangsfilter. | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable micro increments | Die unteren 8 Bit des Zählerstandes werden extrapoliert. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr des Enkoders. | BOOLEAN | RW | 0x00 (0dez)
Index 8010 STM Motor Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:0 | STM Motor Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
8010:01 | Maximal current | maximaler, dauerhafter Spulenstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x1388 (5000dez)
8010:02 | Reduced current | reduzierter Spulenstrom (reduziertes Drehmoment, Einheit: 1 mA) | UINT16 | RW | 0x09C4 (2500dez)
8010:03 | Nominal voltage | Nennspannung (Versorgungsspannung) des Motors (Einheit: 1 mV) | UINT16 | RW | 0xC350 (50000dez)
8010:04 | Motor coil resistance | Innenwiderstand einer Spule (Einheit: 0,01 Ohm) | UINT16 | RW | 0x0064 (100dez)
8010:05 | Motor EMF | Motor-Gegenspannung (Einheit: 1 mV / 1000 Digit) | UINT16 | RW | 0x0000 (0dez)
8010:06 | Motor fullsteps | Motor-Vollschritte pro Umdrehung | UINT16 | RW | 0x00C8 (200dez)
8010:07 | Encoder increments (4-fold) | Enkoder Inkremente pro Umdrehung (Vierfachauswertung) | UINT16 | RW | 0x0000 (0dez)
8010:09 | Start velocity | maximal mögliche Startgeschwindigkeit des Motors | UINT16 | RW | 0x0064 (100dez)
8010:10 | Drive on delay time | Einschaltverzögerung der Treiberstufe (Einheit: ms) | UINT16 | RW | 0x0064 (100dez)
8010:11 | Drive off delay time | Ausschaltverzögerung der Treiberstufe (Einheit: ms) | UINT16 | RW | 0x0096 (150dez)
Index 8011 STM Controller Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8011:0 | STM Controller Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
8011:01 | Kp factor (curr.) | Kp-Regelfaktor (Proportional-Anteil) für den Stromregler (Einheit: 0,001) | UINT16 | RW | 0x00C8 (200dez)
8011:02 | Ki factor (curr.) | Ki-Regelfaktor (Integral-Anteil) für den Stromregler (Einheit: 0,001) | UINT16 | RW | 0x0002 (2dez)
8011:03 | Inner window (curr.) | inneres Fenster des I-Anteils des Stromreglers (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8011:05 | Outer window (curr.) | äußeres Fenster des I-Anteils des Stromreglers (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8011:06 | Filter cut off frequency (curr.) | Filter-Grenzfrequenz des Stromreglers (Tiefpass, Einheit: 1 Hz) | UINT16 | RW | 0x0000 (0dez)
8011:07 | Ka factor (curr.) | Ka-Regelfaktor (Beschleunigungs-Anteil) für den Stromregler (Einheit: 0,001) | UINT16 | RW | 0x0000 (0dez)
8011:08 | Kd factor (curr.) | Kd-Regelfaktor (Brems-Anteil) für den Stromregler (Ein-heit: 0,001) | UINT16 | RW | 0x0064 (100dec)
Index 8012 STM Features Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8012:0 | STM Features Ch.1 | Maximaler Subindex |  | UINT8 | RO | 0x36 (54dez)
8012:01 | Operation mode | Betriebsart (zur Zeit wird nur direkte Geschwindigkeit unterstützt) |  | BIT4 | RW | 0x01 (1dez)
 |  | 0 | Automatik
 |  | 1 | direkte Geschwindigkeit
 |  | 2 | Geschwindigkeitsregler
 |  | 3 | Positionsregler
8012:05 | Speed range | Vorwahl des Geschwindigkeitsbereichs |  | BIT3 | RW | 0x01 (1dez)
 |  | 0 | 1000 Vollschritte/Sekunde
 |  | 1 | 2000 Vollschritte/Sekunde
 |  | 2 | 4000 Vollschritte/Sekunde
 |  | 3 | 8000 Vollschritte/Sekunde
 |  | 4 | 16000 Vollschritte/Sekunde
 |  | 5 | 32000 Vollschritte/Sekunde
8012:08 | Feedback type | Auswahl des Feedback-Systems |  | BIT1 | RW | 0x01 (1dez)
 |  | 0 | externer Enkoder
 |  | 1 | interner Zähler
8012:09 | Invert motor polarity | Aktiviert die Drehrichtungsumkehr des Motors. |  | BOOLEAN | RW | 0x00 (0dez)
8012:11 | Select info data 1 | Auswahl "Info data 1" (siehe 0x6010:11) |  | UINT8 | RW | 0x03 (3dez)
 |  | 0 | Statuswort
 |  | 1 | Motorspannung Spule A (Einheit 1 mV)
 |  | 2 | Motorspannung Spule B (Einheit 1 mV)
 |  | 3 | Motorstrom Spule A (Einheit 1 mA)
 |  | 4 | Motorstrom Spule B (Einheit 1 mA)
 |  | 5 | Duty-Cycle Spule A (Einheit 1 %)
 |  | 6 | Duty-Cycle Spule B (Einheit 1 %)
 |  | 7 | aktuelle Geschwindigkeit (Wertebereich +/- 10000)
 |  | ... | reserviert
 |  | 101 | Innentemperatur der Treiberkarte
 |  | ... | reserviert
 |  | 103 | Steuerspannung
 |  | 104 | Versorgungsspannung des Motors
 |  | ... | reserviert
 |  | 150 | Drive - Status Wort
 |  | 151 | Drive - State
 |  | 152 | Drive - Position lag (low word)
 |  | 153 | Drive - Position lag (highword)
 |  | ... | reserviert
 |  | 255 | reserviert
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8012:19 | Select info data 2 | Auswahl "Info data 2" |  | UINT8 | RW | 0x04 (4dez)
 |  | 0 | Statuswort
 |  | 1 | Motorspannung Spule A (Einheit 1 mV)
 |  | 2 | Motorspannung Spule B (Einheit 1 mV)
 |  | 3 | Motorstrom Spule A (Einheit 1 mA)
 |  | 4 | Motorstrom Spule B (Einheit 1 mA)
 |  | 5 | Duty-Cycle Spule A (Einheit 1 %)
 |  | 6 | Duty-Cycle Spule B (Einheit 1 %)
 |  | 7 | aktuelle Geschwindigkeit (Wertebereich +/- 10000)
 |  | ... | reserviert
 |  | 101 | Innentemperatur der Treiberkarte
 |  | ... | reserviert
 |  | 103 | Steuerspannung
 |  | 104 | Versorgungsspannung des Motors
 |  | ... | reserviert
 |  | 150 | Drive - Status Wort
 |  | 151 | Drive - State
 |  | 152 | Drive - Position lag (low word)
 |  | 153 | Drive - Position lag (highword)
 |  | ... | reserviert
 |  | 255 | reserviert
8012:30 | Invert digital input 1 | Invertierung des digitalen Eingangs 1 |  | BOOLEAN | RW | 0x00 (0dez)
8012:31 | Invert digital input 2 | Invertierung des digitalen Eingangs 2 |  | BOOLEAN | RW | 0x00 (0dez)
8012:32 | Function for input 1 | Auswahl der Funktion von Eingang 1 |  | BIT4 | RW | 0x00 (0dez)
 |  | 0 | Normaler Eingang
 |  | 1 | Hardware Enable
 |  | 2 | Plc cam
 |  | 3 | Auto start
8012:36 | Function for input 2 | Auswahl der Funktion von Eingang 2 |  | BIT4 | RW | 0x00 (0dez)
 |  | 0 | Normaler Eingang
 |  | 1 | Hardware Enable
 |  | 2 | Plc cam
 |  | 3 | Auto start
8012:3A | Function for output 1 | Auswahl der Funktion von Ausgang 1 |  | BIT4 | RW | 0x00 (0dez)
 |  | 0 | Normaler Ausgang
 |  | 1 | Bremse bei gesetztem Bit in 0x7010:01 wird mit der in 0x8010:10 und 0x8010:11 eingestellter Verzögerungszeit der Treiberstufe der Ausgang geschaltet
Index 8013 STM Controller Settings 2 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8013:0 | STM Controller Settings 2 Ch.1 | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
8013:01 | Kp factor (velo.) | Kp-Regelfaktor (Proportional-Anteil) für den Geschwindigkeitsregler (Einheit: 0,001) | UINT16 | RW | 0x03E8 (1000dez)
8013:02 | Ki factor (velo.) | Ki-Regelfaktor (Integral-Anteil) für den Geschwindigkeitsregler (Einheit: 0,001) | UINT16 | RW | 0x0000 (0dez)
8013:03 | Inner window (velo.) | inneres Fenster des I-Anteils des Geschwindigkeitsregler (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8013:05 | Outer window (velo.) | äußeres Fenster des I-Anteils des Geschwindigkeitsregler (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8013:06 | Filter cut off frequency (velo.) | Filter-Grenzfrequenz des Geschwindigkeitsregler (Tiefpass, Einheit: 1 Hz) | UINT16 | RW | 0x0000 (0dez)
Index 8020 POS Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8020:0 | POS Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x10 (16dez)
8020:01 | Velocity min. | minimale Sollgeschwindigkeit (Bereich: 0-10000) | INT16 | RW | 0x0064 (100dez)
8020:02 | Velocity max. | maximale Sollgeschwindigkeit (Bereich: 0-10000) | INT16 | RW | 0x2710 (10000dez)
8020:03 | Acceleration pos. | Beschleunigung in positiver Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8020:04 | Acceleration neg. | Beschleunigung in negativer Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8020:05 | Dezeleration pos. | Verzögerung in positiver Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8020:06 | Dezeleration neg. | Verzögerung in negativer Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8020:07 | Emergency dezeleration | Notfallverzögerung (beide Drehrichtungen, Einheit: 1 ms) | UINT16 | RW | 0x0064 (100dez)
8020:08 | Calibration position | Kalibrierposition | UINT32 | RW | 0x00000000 (0dez)
8020:09 | Calibration velocity (towards plc cam) | Kalibriergeschwindigkeit auf die Nocke (Bereich: 0-10000) | INT16 | RW | 0x0064 (100dez)
8020:0A | Calibration Velocity (off plc cam) | Kalibriergeschwindigkeit von der Nocke herunter (Bereich: 0-10000) | INT16 | RW | 0x000A (10dez)
8020:0B | Target window | Zielfenster | UINT16 | RW | 0x000A (10dez)
8020:0C | In-Target timeout | Zielpositions-Timeout (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8020:0D | Dead time compensation | Totzeitkompensation (Einheit: 1 us) | INT16 | RW | 0x0032 (50dez)
8020:0E | Modulo factor | Modulofaktor/-position | UINT32 | RW | 0x00000000 (0dez)
8020:0F | Modulo tolerance window | Toleranzfenster für Modulopositionierung | UINT32 | RW | 0x00000000 (0dez)
8020:10 | Position lag max. | max. erlaubter Schrittfehler | UINT16 | RW | 0x0000 (0dez)
Index 8021 POS Features Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
8021:0 | POS Features Ch.1 | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
8021:01 | Start type | erlaubte Werte: | UINT16 | RW | 0x0001 (1dez)
 |  | 0: Idle
 |  | 1: Absolute
 |  | 2: Relative
 |  | 3: Endless plus
 |  | 4: Endless minus
 |  | 6: Additive
 |  | 24832: Calibration (Hardware sync)
 |  | 24576: Calibration (Plc cam)
 |  | 28416: Calibration (Clear manual)
 |  | 28160: Calibration (Set manual)
 |  | 28161: Calibration (Set manual auto)
 |  | 1029: Modulo current
 |  | 773: Modulo minus
 |  | 517: Modulo plus
 |  | 261: Modulo short
8021:11 | Time information | erlaubte Werte: 0: Elapsed time aktuell gefahrene Zeit seit Beginn des Fahrauftrages | BIT2 | RW | 0x00 (0dez)
8021:13 | Invert calibration cam search direction | Invertierung der Drehrichtung auf die Nocke | BOOLEAN | RW | 0x01 (1dez)
8021:14 | Invert sync impulse search direction | Invertierung der Drehrichtung von der Nocke herunter | BOOLEAN | RW | 0x00 (0dez)
8021:15 | Emergency stop on position lag error | löst einen Nothalt bei Überschreitung des max. Schleppfehlers aus | BOOLEAN | RW | 0x00 (0dez)
8021:16 | Enhanced diag history | gibt detailliertere Meldungen zum Status des Positioning Interface in der Diag history aus | BOOLEAN | RW | 0x00 (0dez)
Index FB00 STM Command
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
FB00:0 | STM Command | Maximaler Subindex |  | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | Anforderung eines Kommando |  | OCTET-STRING[2] | RW | {0}
 |  | 0x8000 | Software-Reset
FB00:02 | Status | Status des Kommandos |  | UINT8 | RO | 0x00 (0dez)
 |  | 0 | kein Fehler, ohne Rückgebewert
 |  | 1 | kein Fehler, mit Rückgebewert
 |  | 2 | mit Fehler, ohne Rückgebewert
 |  | 3 | mit Fehler, mit Rückgebewert
 |  | ... | reserviert
 |  | 255 | Kommandoausführung aktiv
FB00:03 | Response | Rückgabewert des ausgeführten Kommandos |  | OCTET-STRING[4] | RO | {0}


Standardobjekte (0x1000 .. 0x1FFF)

Inbetriebnahme/Konfiguration [image] CoE-Objekte EP7041-0002, EP7041-1002, EP7041-2002 [image] Objektbeschreibung und Parametrierung [image] Standardobjekte (0x1000 .. 0x1FFF)
Standardobjekte (0x1000 .. 0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP7041-0002
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1B813052 (461451346dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x37 (55dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Nachricht 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |
Index 1400 ENC RxPDO-Par Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[6] | RO | 01 16 00 00 00 00
Index 1401 ENC RxPDO-Par Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[6] | RO | 00 16 00 00 00 00
Index 1403 STM RxPDO-Par Position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | STM RxPDO-Par Position | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1404 STM RxPDO-Par Velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1404:0 | STM RxPDO-Par Velocity | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dez)
1404:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 5 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 05 16 06 16
Index 1405 POS RxPDO-Par Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1405:0 | POS RxPDO-Par Control compact | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dez)
1405:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 6 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 04 16 06 16
Index 1406 POS RxPDO-Par Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1406:0 | POS RxPDO-Par Control | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dez)
1406:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 7 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1407 POS RxPDO-Par Control 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1407:0 | POS RxPDO-Par Control | PDO Parameter RxPDO 8 | UINT8 | RO | 0x06 (6dez)
1407:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 7 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1600 ENC RxPDO-Map Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 1 | UINT8 | RO | 0x07 (7dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1602 STM RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | STM RxPDO-Map Control | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x01 (Enable)) | UINT32 | RO | 0x7010:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x02 (Reset)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7010:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1602:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x0C (Digital output 1)) | UINT32 | RO | 0x7010:0C, 1
1602:07 | SubIndex 007 | 7. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
Index 1603 STM RxPDO-Map Position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | STM RxPDO-Map Position | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x11 (Position)) | UINT32 | RO | 0x7010:11, 32
Index 1604 STM RxPDO-Map Velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | STM RxPDO-Map Velocity | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7010:21, 16
Index 1605 POS RxPDO-Map Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | POS RxPDO-Map Control compact | PDO Mapping RxPDO 6 | UINT8 | RO | 0x05 (5dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1605:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
Index 1606 POS RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | POS RxPDO-Map Control | PDO Mapping RxPDO 7 | UINT8 | RO | 0x09 (9dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1606:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1606:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7020:21, 16
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7020:22, 16
1606:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7020:23, 16
1606:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7020:24, 16
Index 1607 POS RxPDO-Map Control 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | POS RxPDO-Map Control 2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x09 (9dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x0000:00,2
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x03 (Enable auto start)) | UINT32 | RO | 0x7020:03, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00,5
1607:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1607:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7021:11, 32
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7021:21, 16
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7021:22, 16
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7021:23, 16
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7021:24, 16
Index 1800 ENC TxPDO-Par Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 1801 ENC TxPDO-Par Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 1805 POS TxPDO-Par Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | POS TxPDO-Par Status compact | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 7 übertragen werden dürfen | OCTET-STRING[2] | RO | 06 1A
Index 1806 POS TxPDO-Par Status
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1806:0 | POS TxPDO-Par Status | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dez)
1806:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 8 übertragen werden dürfen | OCTET-STRING[2] | RO | 05 1A
Index 1A00 ENC TxPDO-Map Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 1 | UINT8 | RO | 0x11 (17dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09) | UINT32 | RO | 0x1800:09, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 2 | UINT8 | RO | 0x11 (17dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09) | UINT32 | RO | 0x1801:09, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1A03 STM TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | STM TxPDO-Map Status | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0E (14dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6010:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6010:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6010:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6010:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6010:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6010:06, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6010:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x6010:08, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6010:0C, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6010:0D, 1
1A03:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A03:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1803, entry 0x09) | UINT32 | RO | 0x6010:10, 1
Index 1A04 STM TxPDO-Map Synchron info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | STM TxPDO-Map Synchron info data | PDO Mapping TxPDO 5 | UINT8 | RO | 0x02 (2dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6010:11, 16
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6010:12, 16
Index 1A05 POS TxPDO-Map Status compact
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1A05:0 | POS TxPDO-Map Status compact | PDO Mapping TxPDO 7 | UINT8 | RO | 0x09 (9dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A05:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A05:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A06 POS TxPDO-Map Status
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1A06:0 | POS TxPDO-Map Status compact | PDO Mapping TxPDO 7 | UINT8 | RO | 0x09 (9dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x08 (Ready to execute)) | UINT32 | RO | 0x6020:08, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x11 (Actual position)) | UINT32 | RO | 0x6020:11, 32
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x21 (Actual velocity)) | UINT32 | RO | 0x6020:21, 16
1A06:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x22 (Actual drive time)) | UINT32 | RO | 0x6020:22, 32
Index 1A07 STM TxPDO-Map Internal position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | POS TxPDO-Map Status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x14 (Internal position)) | UINT32 | RO | 0x6010:14, 32
Index 1A08 STM TxPDO-Map External position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | POS TxPDO-Map Status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x115 (External position)) | UINT32 | RO | 0x6010:15, 32
Index 1A09 POS TxPDO-Map Actual position lag
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | POS TxPDO-Map Status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (STM Inputs Ch.1), entry 0x23 (Actual position lag)) | UINT32 | RO | 0x6020:23, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1604 (5636dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:08 | Subindex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x000249F0 (150000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x000249F0 (150000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)


Profilspezifische Objekte (0x6000 .. 0xFFFF)

Inbetriebnahme/Konfiguration [image] CoE-Objekte EP7041-0002, EP7041-1002, EP7041-2002 [image] Objektbeschreibung und Parametrierung [image] Profilspezifische Objekte (0x6000 .. 0xFFFF)
Profilspezifische Objekte (0x6000 .. 0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000 ENC Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | ENC Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
6000:01 | Latch C valid | Der Zählerstand wurde mit der C-Spur gelatched. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch gespeichert. | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Counter overflow | Der Zähler ist übergelaufen. | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Extrapolation stall | Die Extrapolierte Teil des Zähler ist ungültig | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Der Zustand des A-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Der Zustand des B-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Status of input C | Der Zustand des C-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Status of extern latch | Der Zustand des Ext. Latch-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO upgedatet wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Der Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Latch value | Der Latchwert. | UINT32 | RO | 0x00000000 (0dez)
6000:16 | Timestamp | Zeitstempel der letzten Zähleränderung. | UINT32 | RO | 0x00000000 (0dez)
Index 6010 STM Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | STM Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x12 (18dez)
6010:01 | Ready to enable | Treiberstufe ist bereit zum Freischalten | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Ready | Treiberstufe ist betriebsbereit | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Warning | eine Warnung ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Error | ein Fehler ist aufgetreten (siehe Index 0xA010) | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Moving positive | Motor dreht in positiver Richtung | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Moving negative | Motor dreht in negativer Richtung | BOOLEAN | RO | 0x00 (0dez)
6010:07 | Torque reduced | reduziertes Drehmoment ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6010:0C | Digital input 1 | digitaler Eingang 1 | BOOLEAN | RO | 0x00 (0dez)
6010:0D | Digital input 2 | digitaler Eingang 2 | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO upgedatet wurden. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Info data 1 | synchrone Informationen (Auswahl über Subindex 0x8012:11) | UINT16 | RO | 0x0000 (0dez)
6010:12 | Info data 2 | synchrone Informationen (Auswahl über Subindex 0x8012:19) | UINT16 | RO | 0x0000 (0dez)
6010:14 | Internal position | Interne Microstep Position | UINT32 | RO | 0x00000000 (0dez)
1010:15 | External position | Encoder Position | UINT32 | RO | 0x00000000 (0dez)
Index 6020 POS Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | POS Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x22 (34dez)
6020:01 | Busy | ein aktueller Fahrauftrag ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6020:02 | In-Target | Motor ist im Ziel angekommen | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Warning | eine Warnung ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6020:04 | Error | eine Fehler ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6020:05 | Calibrated | Motor ist kalibriert | BOOLEAN | RO | 0x00 (0dez)
6020:06 | Accelerate | Motor ist in der Beschleunigungsphase | BOOLEAN | RO | 0x00 (0dez)
6020:07 | Decelerate | Motor ist in der Verzögerungsphase | BOOLEAN | RO | 0x00 (0dez)
6020:08 | Ready to execute |  | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Actual position | aktuelle Sollposition des Fahrauftraggenerators | UINT32 | RO | 0x00007FFF (32767dez)
6020:21 | Actual velocity | aktuelle Sollgeschwindigkeit des Fahrauftraggenerators | INT16 | RO | 0x0000 (0dez)
6020:22 | Actual drive time | Zeitinformation des Fahrauftrages (siehe Subindex 0x8021:11) | UINT32 | RO | 0x00000000 (0dez)
6020:23 | Actual position lag |  | UINT32 | RO | 0x00000000 (0dez)
Index 7000 ENC Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7000:01 | Enable latch C | Das Latchen über die C-Spur aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Den Zählerstand setzen. | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Dies ist der über "Set counter" zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
Index 7010 STM Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | STM Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x21 (33dez)
7010:01 | Enable | aktiviert die Ausgangsstufe (siehe Subindex 0x8012:3A) | BOOLEAN | RO | 0x00 (0dez)
7010:02 | Reset | alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7010:03 | Reduce torque | Aktivierung des reduzierten Drehmoments (Spulenstrom) (siehe Subindex 0x8010:02) | BOOLEAN | RO | 0x00 (0dez)
7010:0C | Digital output 1 | Signal am Digitalen Ausgang 1 | BOOLEAN | RO | 0x00 (0dez)
7010:11 | Position | Soll-Position | UINT32 | RO | 0x00000000 (0dez)
7010:21 | Velocity | Soll-Geschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7020 POS Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | POS Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x24 (36dez)
7020:01 | Execute | Fahrauftrag starten (steigende Flanke), bzw. Fahrauftrag vorzeitig abbrechen (fallende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7020:02 | Emergency stop | Fahrauftrag vorzeitig mit einer Notfallrampe abbrechen (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7020:11 | Target position | Vorgabe der Zielposition | UINT32 | RO | 0x00007FFF (32767dez)
7020:21 | Velocity | Vorgabe der maximalen Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index (hex) | Name | Bedeutung |  |  |  | Datentyp | Flags | Default
7020:22 | Start type | Vorgabe des Starttypen | 0x0000 | Idle | es wird kein Fahrauftrag ausgeführt | UINT16 | RO | 0x0000 (0dez)
 |  |  | 0x0001 | Absolute | Zielposition absolut
 |  |  | 0x0002 | Relative | Zielposition relativ von Startposition aus
 |  |  | 0x0003 | Endless plus | Endlosfahrt in positiver Drehrichtung
 |  |  | 0x0004 | Endless minus | Endlosfahrt in negativer Drehrichtung
 |  |  | 0x0105 | Modulo short | kürzeste Entfernung zur nächsten Moduloposition
 |  |  | 0x0115 | Modulo short extended | kürzeste Entfernung zur nächsten Moduloposition (ohne Modulofenster)
 |  |  | 0x0205 | Modulo plus | Fahrt in positiver Drehrichtung zur nächsten Moduloposition
 |  |  | 0x0215 | Modulo plus extended | Fahrt in positiver Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
 |  |  | 0x0305 | Modulo minus | Fahrt in negativer Drehrichtung zur nächsten Moduloposition
 |  |  | 0x0315 | Modulo minus extended | Fahrt in negativer Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
 |  |  | 0x0405 | Modulo current | Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition
 |  |  | 0x0415 | Modulo current extended | Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
 |  |  | 0x0006 | Additive | neue Zielposition relativ / additiv zur letzten Zielposition
 |  |  | 0x6000 | Calibration, Plc cam | Kalibrierung mit Nocke
 |  |  | 0x6100 | Calibration, Hw sync | Kalibrierung mit Nocke und C-Spur
 |  |  | 0x6E00 | Calibration, set manual | Kalibrierung manuell setzen
 |  |  | 0x6E01 | Calibration, set manual auto | Kalibrierung automatisch setzen
 |  |  | 0x6F00 | Calibration, clear manual | Kalibrierung manuell löschen
7020:23 | Acceleration | Vorgabe der Beschleunigung |  |  |  | UINT16 | RO | 0x0000 (0dez)
7020:24 | Deceleration | Vorgabe der Verzögerung |  |  |  | UINT16 | RO | 0x0000 (0dez)
Index 7021 POS Outputs 2 Ch.1 (Teil 1)
Index | Name | Bedeutung | Datentyp | Flags | Default
7021:0 | POS Outputs 2 Ch.1 | Maximaler Subindex | UINT8 | RO | 0x24 (36dec)
7021:03 | Enable auto start | Auto-Start Funktion aktivieren | BOOL | RO | 0x00000000 (0dez)
7021:11 | Target position | Vorgabe der Zielposition | UINT32 | RO | 0x00000000 (0dez)
7021:21 | Velocity | Vorgabe der maximalen Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7021 POS Outputs 2 Ch.1 (Teil 2)
Index | Name | Bedeutung | Datentyp | Flags | Default
7021:22 | Start type
 | 0x0000 Idle: es wird kein Fahrauftrag ausgeführt |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0001 Absolute: Zielposition absolut |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1001 Absolute (Change): Änderung während eines aktiven Fahrauftrages |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0002 Relative: Zielposition relativ von der aktuellen Position aus |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1002 Relative (Change): Änderung während eines aktiven Fahrauftrages |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0003 Endless plus: Endlosfahrt in positiver Drehrichtung |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0004 Endless minus: Endlosfahrt in negativer Drehrichtung |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0105 Modulo short: kürzeste Entfernung zur nächsten Moduloposition |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0115 Modulo short extended: kürzeste Entfernung zur nächsten Moduloposition (ohne Modulofenster) |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0205 Modulo plus: Fahrt in positiver Drehrichtung zur nächsten Moduloposition |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0215 Modulo plus extended: Fahrt in positiver Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0305 Modulo minus: Fahrt in negativer Drehrichtung zur nächsten Moduloposition |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0315 Modulo minus extended: Fahrt in negativer Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0405 Modulo current: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0415 Modulo current extended: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0006 Additive: neue Zielposition relativ / additiv zur letzten Zielposition |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1006 Additive (Change): Änderung während eines aktiven Fahrauftrages |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6000 Calibration, PLC cam: Kalibrierung mit Nocke |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6100 Calibration, HW sync: Kalibrierung mit Nocke und C-Spur |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E00 Calibration, set manual: Kalibrierung manuell setzen |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E01 Calibration, set manual auto: Kalibrierung autom. setzen, bei "Enable = 1" |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6F00 Calibration, clear manual: Kalibrierung manuell löschen |  | UINT16 | RO | 0x0000 (0dez)
7021:23 | Acceleration | Vorgabe der Beschleunigung | UINT16 | RO | 0x0000 (0dez)
7021:24 | Deceleration | Vorgabe der Verzögerung | UINT16 | RO | 0x0000 (0dez)
Index F081 Download revision
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F081:0 | Download revision | Reserviert | UINT8 | RO | 0x01 (1dez)
F081:01 | Revision number | Reserviert | UINT32 | RW | 0x00000000 (0dez)
Index 9010 STM Info data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9010:0 | STM Info data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x08 (8dez)
9010:01 | Status word | Staturwort (siehe Index 0xA010) | UINT16 | RO | 0x0000 (0dez)
9010:02 | Motor coil voltage A | Motorspannung Spule A (Einheit 1 mV) | UINT16 | RO | 0x0000 (0dez)
9010:03 | Motor coil voltage B | Motorspannung Spule B (Einheit 1 mV) | UINT16 | RO | 0x0000 (0dez)
9010:04 | Motor coil current A | Motorstrom Spule A (Einheit 1 mA) | INT16 | RO | 0x0000 (0dez)
9010:05 | Motor coil current B | Motorstrom Spule B (Einheit 1 mA) | INT16 | RO | 0x0000 (0dez)
9010:06 | Duty cycle A | Duty-Cycle Spule A (Einheit 1 %) | INT8 | RO | 0x00 (0dez)
9010:07 | Duty cycle B | Duty-Cycle Spule B (Einheit 1 %) | INT8 | RO | 0x00 (0dez)
9010:08 | Motor velocity | aktuelle Geschwindigkeit (Wertebereich +/- 10000) | INT16 | RO | 0x0000 (0dez)
Index 9020 POS Info data Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
9020:0 | POS Info data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
9020:01 | Status word | Statuswort | UINT16 | RO | 0x0000 (0dez)
9020:03 | State (drive controller) | erlaubte Werte: | UINT16 | RO | 0x0000 (0dez)
 |  | 0: Init
 |  | 1: Idle
 |  | 272: Go cam
 |  | 273: On cam
 |  | 16: Start
 |  | 17: Acceleration
 |  | 18: Constant
 |  | 19: Decelleration
 |  | 288: Go sync impulse
 |  | 289: Leave cam
 |  | 4096: Pre target
 |  | 4097: In target
 |  | 32: Emergency stop
 |  | 33: Normal stop
 |  | 304: Calibration stop
 |  | 8192: Drive end
 |  | 8193: Wait for init
 |  | 320: Is calibrated
 |  | 321: Not calibrated
 |  | 16384: Drive warning
 |  | 32768: Error
 |  | 65535: Undefined
 |  | 256: Calibration start
9020:04 | Actual position lag | aktueller Schrittfehler | INT32 | RO | 0x00000000 (0dez)
Index A010 STM Diag data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A010:0 | STM Diag data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
A010:01 | Saturated | Treiberstufe arbeitet mit maximalem Duty-Cycle | BOOLEAN | RO | 0x00 (0dez)
A010:02 | Over temperature | Innentemperatur der Klemme ist größer als 80 °C (siehe Subindex 0xF80F:04) | BOOLEAN | RO | 0x00 (0dez)
A010:03 | Torque overload | aktueller Motorstrom ist größer als der Nennstrom | BOOLEAN | RO | 0x00 (0dez)
A010:04 | Under voltage | Versorgungsspannung des Motors ist 20% kleiner, als die konfigurierte Nennspannung (Warning) oder Versorgungsspannung des Motors ist kleiner 8 V (Fehler, siehe 0xA010:09) | BOOLEAN | RO | 0x00 (0dez)
A010:05 | Over voltage | Versorgungsspannung des Motors ist 10% größer, als die konfigurierte Nennspannung | BOOLEAN | RO | 0x00 (0dez)
A010:06 | Short circuit A | Kurzschluss der Motorspule A | BOOLEAN | RO | 0x00 (0dez)
A010:07 | Short circuit B | Kurzschluss der Motorspule B | BOOLEAN | RO | 0x00 (0dez)
A010:08 | No control power | Steuerspannung an den Powerkontakten kleiner als 12 V | BOOLEAN | RO | 0x00 (0dez)
A010:09 | Misc error | Initialisierung der Klemme fehlgeschlagen oder Versorgungsspannung ist kleiner 8 V oder Innentemperatur der Klemme ist größer als 100 °C (siehe Subindex 0xF80F:05) | BOOLEAN | RO | 0x00 (0dez)
A010:11 | Actual operation mode | aktuelle Betriebsart (relevant bei aktivierter Automatik, siehe 0x8012:01) | BIT4 | RO | 0x00 (0dez)
Index A020 POS Diag data Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
A020:0 | POS Diag data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
A020:01 | Command rejected | Fahrauftrag wurde abgewiesen | BOOLEAN | RO | 0x00 (0dez)
A020:02 | Command aborted | Fahrauftrag wurde abgebrochen | BOOLEAN | RO | 0x00 (0dez)
A020:03 | Target overrun | Zielposition wurde in entgegengesetzter Richtung überfahren | BOOLEAN | RO | 0x00 (0dez)
A020:04 | Target timeout | das Zielfenster wurde innerhalb des In-Target timeouts nicht erreicht | BOOLEAN | RO | 0x00 (0dez)
A020:05 | Position lag | der max. Schleppfehler wurde überschritten | BOOLEAN | RO | 0x00 (0dez)
A020:06 | Emergency stop | ein Nothalt wurde ausgelöst (automatisch oder manuell) | BOOLEAN | RO | 0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0002 (2dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | Profilnummer der Enkoder-Schnittstelle | UINT32 | RW | 0x000001FF (511dez)
F010:02 | SubIndex 002 | Profilnummer der Schrittmotor-Schnittstelle | UINT32 | RW | 0x000002BF (703dez)
Index F80F STM Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | STM Vendor data | Maximaler Subindex | UINT8 | RO | 0x08 (8dez)
F80F:01 | PWM Frequency | Zwischenkreisfrequenz (Einheit: 1 Hz) | UINT16 | RW | 0x7530 (30000dez)
F80F:02 | Deadtime | Totzeit der Pulsweitenmodulation | UINT16 | RW | 0x0102 (258dez)
F80F:03 | Deadtime space | Duty Cycle Begrenzung | UINT16 | RW | 0x0009 (9dez)
F80F:04 | Warning temperature | Schwelle der Temperaturwarnung (Einheit: 1 °C, siehe Subindex 0xA010:02) | INT8 | RW | 0x50 (80dez)
F80F:05 | Switch off temperature | Abschalttemperatur (Einheit: 1 °C) | INT8 | RW | 0x64 (100dez)
F80F:06 | Analog trigger point | Triggerpunkt der AD-Wandlung | UINT16 | RW | 0x000A (10dez)
F80F:07 | Calibration offset A | Offsetabgleich der Strommessung für Spule A (wird vom Hersteller gesetzt) | INT16 | RW | 0x0000 (0dez)
F80F:08 | Calibration offset B | Offsetabgleich der Strommessung für Spule B (wird vom Hersteller gesetzt) | INT16 | RW | 0x0000 (0dez)
Index F900 STM Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | STM Info data | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
F900:01 | Software version (driver) | Softwareversion der Treiberkarte | STRING | RO | {0}
F900:02 | Internal temperature | interne Klemmentemperatur (Einheit: 1 °C) | INT8 | RO | 0x00 (0dez)
F900:04 | Control voltage | Steuerspannung (Einheit: 1 mV) | UINT16 | RO | 0x0000 (0dez)
F900:05 | Motor supply voltage | Versorgungsspannung des Motors (Einheit: 1 mV) | UINT16 | RO | 0x0000 (0dez)
F900:06 | Cycle time | gemessene Zykluszeit (Einheit: 1 µs) | UINT16 | RO | 0x0000 (0dez)


CoE-Objekte EP7041-3002, EP7041-3102

Inbetriebnahme/Konfiguration [image] CoE-Objekte EP7041-3002, EP7041-3102
CoE-Objekte EP7041-3002, EP7041-3102
Weiterführende Informationen
•
Objektbeschreibung und Parametrierung


Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration [image] CoE-Objekte EP7041-3002, EP7041-3102 [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
Gültig für EP7041-3002 und EP7041-3102
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zu Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
▪
Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Objekte für die Inbetriebnahme
•
Standardobjekte (0x1000 .. 0x1FFF)
•
Profilspezifische Objekte (0x6000 .. 0xFFFF)


Objekte für die Inbetriebnahme

Inbetriebnahme/Konfiguration [image] CoE-Objekte EP7041-3002, EP7041-3102 [image] Objektbeschreibung und Parametrierung [image] Objekte für die Inbetriebnahme
Objekte für die Inbetriebnahme
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 ENC Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | ENC Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x0F (15dez)
8000:08 | Disable filter | Deaktiviert die Eingangsfilter. | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable micro increments | Die unteren 8 Bit des Zählerstandes werden extrapoliert. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr des Enkoders. | BOOLEAN | RW | 0x00 (0dez)
Index 8010 STM Motor Settings Ch.1
Index (hex) | Name | Bedeutung | Data type | Flags | Default
8010:0 | STM Motor Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
8010:01 | Maximal current | maximaler, dauerhafter Spulenstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x1388 (5000dez)
8010:02 | Reduced current | reduzierter Spulenstrom (reduziertes Drehmoment, Einheit: 1 mA) | UINT16 | RW | 0x09C4 (2500dez)
8010:03 | Nominal voltage | Nennspannung (Versorgungsspannung) des Motors (Einheit: 1 mV) | UINT16 | RW | 0xC350 (50000dez)
8010:06 | Motor fullsteps | Motor-Vollschritte pro Umdrehung | UINT16 | RW | 0x00C8 (200dez)
8010:07 | Encoder increments (4-fold) | Enkoder Inkremente pro Umdrehung (Vierfachauswertung) | UINT16 | RW | 0x0000 (0dez)
8010:09 | Start velocity | maximal mögliche Startgeschwindigkeit des Motors | UINT16 | RW | 0x0000 (0dez)
8010:10 | Drive on delay time | Einschaltverzögerung der Treiberstufe (Einheit: ms) | UINT16 | RW | 0x0064 (100dez)
8010:11 | Drive off delay time | Ausschaltverzögerung der Treiberstufe (Einheit: ms) | UINT16 | RW | 0x0096 (150dez)
Index 8012 STM Features Ch.1
Index (hex) | Name | Bedeutung |  | Data type | Flags | Default
8012:0 | STM Features Ch.1 | Maximaler Subindex |  | UINT8 | RO | 0x45 (69dez)
8012:01 | Operation mode | Betriebsart (zur Zeit wird nur direkte Geschwindigkeit unterstützt) |  | BIT4 | RW | 0x00 (0dez)
 |  | 0 | Automatik
 |  | 1 | direkte Geschwindigkeit
 |  | 2 | Geschwindigkeitsregler
 |  | 3 | Positionsregler
8012:05 | Speed range | Vorwahl des Geschwindigkeitsbereichs |  | BIT3 | RW | 0x01 (1dez)
 |  | 0 | 1000 Vollschritte/Sekunde
 |  | 1 | 2000 Vollschritte/Sekunde
 |  | 2 | 4000 Vollschritte/Sekunde
 |  | 3 | 8000 Vollschritte/Sekunde
 |  | 4 | 16000 Vollschritte/Sekunde
 |  | 5 | 32000 Vollschritte/Sekunde
8012:08 | Feedback type | Auswahl des Feedback-Systems |  | BIT1 | RW | 0x01 (1dez)
 |  | 0 | externer Enkoder
 |  | 1 | interner Zähler
8012:09 | Invert motor polarity | Aktiviert die Drehrichtungsumkehr des Motors. |  | BOOLEAN | RW | 0x00 (0dez)
8012:11 | Select info data 1 | Auswahl "Info data 1" (siehe 0x6010:11) |  | UINT8 | RW | 0x00 (0dez)
 |  | 0 | Statuswort
 |  | 1 | reserviert
 |  | ... | ...
 |  | 6 | reserviert
 |  | 7 | aktuelle Geschwindigkeit (Wertebereich +/- 10000)
 |  | 8 | reserviert
 |  | 9 | Statuswort 2
 |  | 10 | Motor: Belastung
 |  | 11 | Motor: "Smart Current"
 |  | 12 | reserviert
 |  | ... | ...
 |  | 100 | reserviert
 |  | 101 | Innentemperatur der Treiberkarte
 |  | ... | reserviert
 |  | 103 | Steuerspannung
 |  | 104 | Motorversorgung: Spannung
 |  | ... | reserviert
 |  | 106 | Motorversorgung: Strom
 |  | 107 | reserviert
 |  | ... | ...
 |  | 149 | reserviert
 |  | 150 | Positions-Interface - Statuswort
 |  | 151 | Positions-Interface - Status der internen State Maschine
 |  | 152 | Positions-Interface - Schleppfehler (Low-Word)
 |  | 153 | Positions-Interface - Schleppfehler (High-Word)
 |  | 154 | reserviert
 |  | ... | ...
 |  | 255 | reserviert
Index 8012 STM Features Ch.1
Index (hex) | Name | Bedeutung |  | Data type | Flags | Default
8012:19 | Select info data 2 | Auswahl "Info data 2" (siehe 0x8012:11) |  | UINT8 | RW | 0x09 (9dez)
8012:30 | Invert digital input 1 | Invertierung des digitalen Eingangs 1 |  | BOOLEAN | RW | 0x00 (0dez)
8012:31 | Invert digital input 2 | Invertierung des digitalen Eingangs 2 |  | BOOLEAN | RW | 0x00 (0dez)
8012:32 | Function for input 1 | Auswahl der Funktion von Eingang 1 |  | BIT4 | RW | 0x00 (0dez)
 |  | 0 | Normaler Eingang
 |  | 1 | Hardware Enable
8012:36 | Function for input 2 | Auswahl der Funktion von Eingang 2 |  | BIT4 | RW | 0x00 (0dez)
 |  | 0 | Normaler Eingang
 |  | 1 | Hardware Enable
8012:3A | Function for output 1 | Auswahl der Funktion von Ausgang 1 |  | BIT4 | RW | 0x00 (0dez)
 |  | 0 | Normaler Ausgang
 |  | 1 | Bremse bei gesetztem Bit in 0x7010:01 wird mit der in 0x8010:10 und 0x8010:11 eingestellter Verzögerungszeit der Treiberstufe der Ausgang geschaltet
8012:45 | Microstepping | 0 | Vollschritt | BIT4 | RW | 0x08 (8dez)
 |  | 1 | Halbschritt
 |  | 2 | 1/4 Mikroschritt
 |  | 3 | 1/8 Mikroschritt
 |  | 4 | 1/16 Mikroschritt
 |  | 5 | 1/32 Mikroschritt
 |  | 6 | 1/64 Mikroschritt
 |  | 7 | 1/128 Mikroschritt
 |  | 8 | 1/256 Mikroschritt
Index 8013 STM Controller Settings 2 Ch.1
Index (hex) | Name | Bedeutung | Data type | Flags | Default
8013:0 | STM Controller Settings 2 Ch.1 | Maximaler Subindex | UINT8 | RO | 0x07 (7dez)
8013:01 | Kp factor (velo./pos.) | Kp-Regelfaktor (Proportional-Anteil) für den Geschwindigkeitsregler (Einheit: 0,001) | UINT16 | RW | 0x03E8 (1000dez)
8013:02 | Ki factor (velo./pos.) | Ki-Regelfaktor (Integral-Anteil) für den Geschwindigkeitsregler (Einheit: 0,001) | UINT16 | RW | 0x0000 (0dez)
8013:03 | Inner window (velo./pos.) | inneres Fenster des I-Anteils des Geschwindigkeitsregler (Einheit: 1%) | UINT8 | RW | 0x00 (0dez)
8013:05 | Outer window (velo./pos.) | äußeres Fenster des I-Anteils des Geschwindigkeitsregler (Einheit: 1%) | UINT8 | RW | 0x00 (0dez)
8013:06 | Filter cut off frequency (velo./pos.) | Filter-Grenzfrequenz des Geschwindigkeitsregler (Tiefpass, Einheit: 1 Hz) | UINT16 | RW | 0x0000 (0dez)
8013:07 | Ka factor (velo./pos.) | Ka-Regelfaktor des Geschwindigkeits-/Positionsreglers | UINT16 | RW | 0x0000 (0dez)
Index 8014 STM Motor Features Ch.1
Index (hex) | Name | Bedeutung | Data type | Flags | Default
8014:0 | STM Motor Features Ch.1 | Maximaler Subindex | UINT8 | RO | 0x31 (49dez)
8014:01 | Chopper: Mode |  | BIT2 | RW | 0x00 (0dez)
8014:03 | Chopper: Off time |  | BIT4 | RW | 0x05 (5dez)
8014:07 | Chopper: Comparator disabled |  | BOOLEAN | RW | 0x00 (0dez)
8014:08 | Chopper: Fast decay time |  | BIT4 | RW | 0x03 (3dez)
8014:0C | Chopper: Sine wave offset |  | BIT4 | RW | 0x03 (3dez)
8014:11 | Chopper: Hysteresis start value |  | BIT3 | RW | 0x02 (2dez)
8014:14 | Chopper: Hysteresis end value |  | BIT4 | RW | 0x06 (6dez)
8014:18 | Chopper: Hysteresis decrement time |  | BIT2 | RW | 0x00 (0dez)
8014:1A | Stall guard: Filter enable |  | BOOLEAN | RW | 0x01 (1dez)
8014:1B | Stall guard: Current up step width |  | BIT2 | RW | 0x00 (0dez)
8014:1D | Stall guard: Current down step speed |  | BIT2 | RW | 0x00 (0dez)
8014:1F | Stall guard: Minimum current |  | BIT1 | RW | 0x00 (0dez)
8014:21 | Stall guard: Minimum value |  | BIT4 | RW | 0x00 (0dez)
8014:25 | Stall guard: Hysteresis value |  | BIT4 | RW | 0x00 (0dez)
8014:31 | Stall guard: Threshold value |  | INT8 | RW | 0x01 (1dez)
Index 8020 POS Settings Ch.1
Index (hex) | Name | Bedeutung | Data type | Flags | Default
8020:0 | POS Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x0F (15dez)
8020:01 | Velocity min. | minimale Sollgeschwindigkeit (Bereich: 0 ... 10000) | INT16 | RW | 0x0064 (100dez)
8020:02 | Velocity max. | maximale Sollgeschwindigkeit (Bereich: 0 ... 10000) | INT16 | RW | 0x2710 (10000dez)
8020:03 | Acceleration pos. | Beschleunigung in positiver Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8020:04 | Acceleration neg. | Beschleunigung in negativer Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8020:05 | Deceleration pos. | Verzögerung in positiver Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8020:06 | Deceleration neg. | Verzögerung in negativer Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8020:07 | Emergency deceleration | Notfallverzögerung (beide Drehrichtungen, Einheit: 1 ms) | UINT16 | RW | 0x0064 (100dez)
8020:08 | Calibration position | Kalibrierposition | UINT32 | RW | 0x00000000 (0dez)
8020:09 | Calibration velocity (towards plc cam) | Kalibriergeschwindigkeit auf die Nocke (Bereich: 0 ... 10000) | INT16 | RW | 0x0064 (100dez)
8020:0A | Calibration Velocity (off plc cam) | Kalibriergeschwindigkeit von der Nocke herunter (Bereich: 0 ... 10000) | INT16 | RW | 0x000A (10dez)
8020:0B | Target window | Zielfenster | UINT16 | RW | 0x000A (10dez)
8020:0C | In-Target timeout | Zielpositions-Timeout (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8020:0D | Dead time compensation | Totzeitkompensation (Einheit: 1 µs) | INT16 | RW | 0x0032 (50dez)
8020:0E | Modulo factor | Modulofaktor / -position | UINT32 | RW | 0x00000000 (0dez)
8020:0F | Modulo tolerance window | Toleranzfenster für Modulo-Positionierung | UINT32 | RW | 0x00000000 (0dez)
Index 8021 POS Features Ch.1
Index (hex) | Name | Bedeutung |  | Data type | Flags | Default
8021:0 | POS Features Ch.1 | Maximaler Subindex |  | UINT8 | RO | 0x14 (20dez)
8021:01 | Start type | Standard-Starttyp |  | UINT16 | RW | 0x0001 (1dez)
8021:11 | Time information | Zeitinformation in Subindex 0x6pp0:22 ("Actual drive time") |  | BIT2 | RW | 0x00 (0dez)
 |  | 0 | Elapsed time: aktuell gefahrene Zeit seit Beginn des Fahrauftrages
 |  | ... | reserviert
8021:13 | Invert calibration cam search direction | Invertierung der Drehrichtung auf die Nocke |  | BOOLEAN | RW | 0x01 (1dez)
8021:14 | Invert sync impulse search direction | Invertierung der Drehrichtung von der Nocke herunter |  | BOOLEAN | RW | 0x00 (0dez)
Index FB00 STM Command
Index (hex) | Name | Bedeutung |  | Data type | Flags | Default
FB00:0 | STM Command | Maximaler Subindex |  | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | Anforderung eines Kommando |  | OCTET-STRING[2] | RW | {0}
 |  | 0x8000 | Software-Reset
FB00:02 | Status | Status des Kommandos |  | UINT8 | RO | 0x00 (0dez)
 |  | 0 | kein Fehler, ohne Rückgebewert
 |  | 1 | kein Fehler, mit Rückgebewert
 |  | 2 | mit Fehler, ohne Rückgebewert
 |  | 3 | mit Fehler, mit Rückgebewert
 |  | ... | reserviert
 |  | 255 | Kommandoausführung aktiv
FB00:03 | Response | Rückgabewert des ausgeführten Kommandos (abhängig vom Kommando) |  | OCTET-STRING[4] | RO | {0}


Standardobjekte (0x1000 .. 0x1FFF)

Inbetriebnahme/Konfiguration [image] CoE-Objekte EP7041-3002, EP7041-3102 [image] Objektbeschreibung und Parametrierung [image] Standardobjekte (0x1000 .. 0x1FFF)
Standardobjekte (0x1000 .. 0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP7041-3002
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 02
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1B814052 (461455442dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100BBA (1051578dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x37 (55dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Nachricht 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |
Index 1400 ENC RxPDO-Par Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[6] | RO | 01 16 00 00 00 00
Index 1401 ENC RxPDO-Par Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[6] | RO | 00 16 00 00 00 00
Index 1403 STM RxPDO-Par Position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | STM RxPDO-Par Position | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1404 STM RxPDO-Par Velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1404:0 | STM RxPDO-Par Velocity | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dez)
1404:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 5 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 05 16 06 16
Index 1405 POS RxPDO-Par Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1405:0 | POS RxPDO-Par Control compact | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dez)
1405:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 6 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 04 16 06 16
Index 1406 POS RxPDO-Par Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1406:0 | POS RxPDO-Par Control | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dez)
1406:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 7 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1407 POS RxPDO-Par Control 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1407:0 | POS RxPDO-Par Control | PDO Parameter RxPDO 8 | UINT8 | RO | 0x06 (6dez)
1407:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 7 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1600 ENC RxPDO-Map Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 1 | UINT8 | RO | 0x07 (7dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1602 STM RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | STM RxPDO-Map Control | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x01 (Enable)) | UINT32 | RO | 0x7010:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x02 (Reset)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7010:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1602:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x0C (Digital output 1)) | UINT32 | RO | 0x7010:0C, 1
1602:07 | SubIndex 007 | 7. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
Index 1603 STM RxPDO-Map Position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | STM RxPDO-Map Position | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x11 (Position)) | UINT32 | RO | 0x7010:11, 32
Index 1604 STM RxPDO-Map Velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | STM RxPDO-Map Velocity | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7010:21, 16
Index 1605 POS RxPDO-Map Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | POS RxPDO-Map Control compact | PDO Mapping RxPDO 6 | UINT8 | RO | 0x05 (5dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1605:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
Index 1606 POS RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | POS RxPDO-Map Control | PDO Mapping RxPDO 7 | UINT8 | RO | 0x09 (9dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1606:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1606:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7020:21, 16
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7020:22, 16
1606:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7020:23, 16
1606:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7020:24, 16
Index 1607 POS RxPDO-Map Control 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | POS RxPDO-Map Control 2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x09 (9dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x0000:00,2
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x03 (Enable auto start)) | UINT32 | RO | 0x7020:03, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00,5
1607:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1607:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7021:11, 32
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7021:21, 16
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7021:22, 16
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7021:23, 16
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7021:24, 16
Index 1800 ENC TxPDO-Par Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 1801 ENC TxPDO-Par Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 1806 POS TxPDO-Par Status compact
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1806:0 | POS TxPDO-Par Status compact | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dez)
1806:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 7 übertragen werden dürfen | OCTET-STRING[2] | RO | 07 1A
Index 1807 POS TxPDO-Par Status
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1807:0 | POS TxPDO-Par Status | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dez)
1807:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 8 übertragen werden dürfen | OCTET-STRING[2] | RO | 06 1A
Index 1A00 ENC TxPDO-Map Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 1 | UINT8 | RO | 0x11 (17dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09) | UINT32 | RO | 0x1800:09, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 2 | UINT8 | RO | 0x11 (17dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09) | UINT32 | RO | 0x1801:09, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1A03 STM TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | STM TxPDO-Map Status | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0E (14dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6010:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6010:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6010:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6010:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6010:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6010:06, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6010:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x6010:08, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6010:0C, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6010:0D, 1
1A03:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A03:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1803, entry 0x09) | UINT32 | RO | 0x6010:10, 1
Index 1A04 STM TxPDO-Map Synchron info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | STM TxPDO-Map Synchron info data | PDO Mapping TxPDO 5 | UINT8 | RO | 0x02 (2dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6010:11, 16
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6010:12, 16
Index 1A05 STM TxPDO-Map Motor load
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1A05:0 | STM TxPDO-Map Motor load | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6010:13, 16
Index 1A06 POS TxPDO-Map Status compact
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1A06:0 | POS TxPDO-Map Status compact | PDO Mapping TxPDO 7 | UINT8 | RO | 0x09 (9dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x08 (Ready to execute)) | UINT32 | RO | 0x6020:08, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A07 POS TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | POS TxPDO-Map Status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x0C (12dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A07:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A07:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A07:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x11 (Actual position)) | UINT32 | RO | 0x6020:11, 32
1A07:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x21 (Actual velocity)) | UINT32 | RO | 0x6020:21, 16
1A07:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x22 (Actual drive time)) | UINT32 | RO | 0x6020:22, 32
Index 1A08 STM TxPDO-Map Internal Position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | STM TxPDO-Map Internal Position | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch. 1), entry 0x14 (Internal Position)) | UINT32 | RO | 0x6010:14, 32
Index 1A09 STM TxPDO-Map External Position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | STM TxPDO-Map External Position | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch. 1), entry 0x15 (External Position)) | UINT32 | RO | 0x6010:15, 32
Index 1A0A POS TxPDO-Map Actual Position lag
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | POS TxPDO-Map Actual Position lag | PDO Mapping TxPDO 11 | UINT8 | RO | 0x01 (1dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (POS Inputs Ch. 1), entry 0x23 (Actual position lag)) | UINT32 | RO | 0x6020:23, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1604 (5636dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:08 | Subindex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:09 | Subindex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0003D090 (250000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x0003D090 (250000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)


Profilspezifische Objekte (0x6000 .. 0xFFFF)

Inbetriebnahme/Konfiguration [image] CoE-Objekte EP7041-3002, EP7041-3102 [image] Objektbeschreibung und Parametrierung [image] Profilspezifische Objekte (0x6000 .. 0xFFFF)
Profilspezifische Objekte (0x6000 .. 0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000 ENC Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | ENC Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
6000:01 | Latch C valid | Der Zählerstand wurde mit der C-Spur gelatched. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch gespeichert. | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Counter overflow | Der Zähler ist übergelaufen. | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Extrapolation stall | Die Extrapolierte Teil des Zähler ist ungültig | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Der Zustand des A-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Der Zustand des B-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Status of input C | Der Zustand des C-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Status of extern latch | Der Zustand des Ext. Latch-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO upgedatet wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Der Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Latch value | Der Latchwert. | UINT32 | RO | 0x00000000 (0dez)
6000:16 | Timestamp | Zeitstempel der letzten Zähleränderung. | UINT32 | RO | 0x00000000 (0dez)
Index 6010 STM Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | STM Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x12 (18dez)
6010:01 | Ready to enable | Treiberstufe ist bereit zum Freischalten | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Ready | Treiberstufe ist betriebsbereit | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Warning | eine Warnung ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Error | ein Fehler ist aufgetreten (siehe Index 0xA010) | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Moving positive | Motor dreht in positiver Richtung | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Moving negative | Motor dreht in negativer Richtung | BOOLEAN | RO | 0x00 (0dez)
6010:07 | Torque reduced | reduziertes Drehmoment ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6010:0C | Digital input 1 | digitaler Eingang 1 | BOOLEAN | RO | 0x00 (0dez)
6010:0D | Digital input 2 | digitaler Eingang 2 | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO upgedatet wurden. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Info data 1 | synchrone Informationen (Auswahl über Subindex 0x8012:11) | UINT16 | RO | 0x0000 (0dez)
6010:12 | Info data 2 | synchrone Informationen (Auswahl über Subindex 0x8012:19) | UINT16 | RO | 0x0000 (0dez)
6010:14 | Internal position | Interne Microstep Position | UINT32 | RO | 0x00000000 (0dez)
1010:15 | External position | Encoder Position | UINT32 | RO | 0x00000000 (0dez)
Index 6020 POS Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | POS Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x22 (34dez)
6020:01 | Busy | ein aktueller Fahrauftrag ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6020:02 | In-Target | Motor ist im Ziel angekommen | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Warning | eine Warnung ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6020:04 | Error | eine Fehler ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6020:05 | Calibrated | Motor ist kalibriert | BOOLEAN | RO | 0x00 (0dez)
6020:06 | Accelerate | Motor ist in der Beschleunigungsphase | BOOLEAN | RO | 0x00 (0dez)
6020:07 | Decelerate | Motor ist in der Verzögerungsphase | BOOLEAN | RO | 0x00 (0dez)
6020:08 | Ready to execute |  | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Actual position | aktuelle Sollposition des Fahrauftraggenerators | UINT32 | RO | 0x00007FFF (32767dez)
6020:21 | Actual velocity | aktuelle Sollgeschwindigkeit des Fahrauftraggenerators | INT16 | RO | 0x0000 (0dez)
6020:22 | Actual drive time | Zeitinformation des Fahrauftrages (siehe Subindex 0x8021:11) | UINT32 | RO | 0x00000000 (0dez)
6020:23 | Actual position lag |  | UINT32 | RO | 0x00000000 (0dez)
Index 7000 ENC Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7000:01 | Enable latch C | Das Latchen über die C-Spur aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Den Zählerstand setzen. | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Dies ist der über "Set counter" zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
Index 7010 STM Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | STM Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x21 (33dez)
7010:01 | Enable | aktiviert die Ausgangsstufe (siehe Subindex 0x8012:3A) | BOOLEAN | RO | 0x00 (0dez)
7010:02 | Reset | alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7010:03 | Reduce torque | Aktivierung des reduzierten Drehmoments (Spulenstrom) (siehe Subindex 0x8010:02) | BOOLEAN | RO | 0x00 (0dez)
7010:0C | Digital output 1 | Signal am Digitalen Ausgang 1 | BOOLEAN | RO | 0x00 (0dez)
7010:11 | Position | Soll-Position | UINT32 | RO | 0x00000000 (0dez)
7010:21 | Velocity | Soll-Geschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7020 POS Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | POS Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x24 (36dez)
7020:01 | Execute | Fahrauftrag starten (steigende Flanke), bzw. Fahrauftrag vorzeitig abbrechen (fallende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7020:02 | Emergency stop | Fahrauftrag vorzeitig mit einer Notfallrampe abbrechen (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7020:11 | Target position | Vorgabe der Zielposition | UINT32 | RO | 0x00007FFF (32767dez)
7020:21 | Velocity | Vorgabe der maximalen Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index (hex) | Name | Bedeutung |  |  |  | Datentyp | Flags | Default
7020:22 | Start type | Vorgabe des Starttypen | 0x0000 | Idle | es wird kein Fahrauftrag ausgeführt | UINT16 | RO | 0x0000 (0dez)
 |  |  | 0x0001 | Absolute | Zielposition absolut
 |  |  | 0x0002 | Relative | Zielposition relativ von Startposition aus
 |  |  | 0x0003 | Endless plus | Endlosfahrt in positiver Drehrichtung
 |  |  | 0x0004 | Endless minus | Endlosfahrt in negativer Drehrichtung
 |  |  | 0x0105 | Modulo short | kürzeste Entfernung zur nächsten Moduloposition
 |  |  | 0x0115 | Modulo short extended | kürzeste Entfernung zur nächsten Moduloposition (ohne Modulofenster)
 |  |  | 0x0205 | Modulo plus | Fahrt in positiver Drehrichtung zur nächsten Moduloposition
 |  |  | 0x0215 | Modulo plus extended | Fahrt in positiver Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
 |  |  | 0x0305 | Modulo minus | Fahrt in negativer Drehrichtung zur nächsten Moduloposition
 |  |  | 0x0315 | Modulo minus extended | Fahrt in negativer Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
 |  |  | 0x0405 | Modulo current | Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition
 |  |  | 0x0415 | Modulo current extended | Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
 |  |  | 0x0006 | Additive | neue Zielposition relativ / additiv zur letzten Zielposition
 |  |  | 0x6000 | Calibration, Plc cam | Kalibrierung mit Nocke
 |  |  | 0x6100 | Calibration, Hw sync | Kalibrierung mit Nocke und C-Spur
 |  |  | 0x6E00 | Calibration, set manual | Kalibrierung manuell setzen
 |  |  | 0x6E01 | Calibration, set manual auto | Kalibrierung automatisch setzen
 |  |  | 0x6F00 | Calibration, clear manual | Kalibrierung manuell löschen
7020:23 | Acceleration | Vorgabe der Beschleunigung |  |  |  | UINT16 | RO | 0x0000 (0dez)
7020:24 | Deceleration | Vorgabe der Verzögerung |  |  |  | UINT16 | RO | 0x0000 (0dez)
Index 7021 POS Outputs 2 Ch.1 (Teil 1)
Index | Name | Bedeutung | Datentyp | Flags | Default
7021:0 | POS Outputs 2 Ch.1 | Maximaler Subindex | UINT8 | RO | 0x24 (36dec)
7021:03 | Enable auto start | Auto-Start Funktion aktivieren | BOOL | RO | 0x00000000 (0dez)
7021:11 | Target position | Vorgabe der Zielposition | UINT32 | RO | 0x00000000 (0dez)
7021:21 | Velocity | Vorgabe der maximalen Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7021 POS Outputs 2 Ch.1 (Teil 2)
Index | Name | Bedeutung | Datentyp | Flags | Default
7021:22 | Start type
 | 0x0000 Idle: es wird kein Fahrauftrag ausgeführt |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0001 Absolute: Zielposition absolut |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1001 Absolute (Change): Änderung während eines aktiven Fahrauftrages |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0002 Relative: Zielposition relativ von der aktuellen Position aus |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1002 Relative (Change): Änderung während eines aktiven Fahrauftrages |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0003 Endless plus: Endlosfahrt in positiver Drehrichtung |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0004 Endless minus: Endlosfahrt in negativer Drehrichtung |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0105 Modulo short: kürzeste Entfernung zur nächsten Moduloposition |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0115 Modulo short extended: kürzeste Entfernung zur nächsten Moduloposition (ohne Modulofenster) |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0205 Modulo plus: Fahrt in positiver Drehrichtung zur nächsten Moduloposition |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0215 Modulo plus extended: Fahrt in positiver Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0305 Modulo minus: Fahrt in negativer Drehrichtung zur nächsten Moduloposition |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0315 Modulo minus extended: Fahrt in negativer Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0405 Modulo current: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0415 Modulo current extended: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0006 Additive: neue Zielposition relativ / additiv zur letzten Zielposition |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1006 Additive (Change): Änderung während eines aktiven Fahrauftrages |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6000 Calibration, PLC cam: Kalibrierung mit Nocke |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6100 Calibration, HW sync: Kalibrierung mit Nocke und C-Spur |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E00 Calibration, set manual: Kalibrierung manuell setzen |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E01 Calibration, set manual auto: Kalibrierung autom. setzen, bei "Enable = 1" |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6F00 Calibration, clear manual: Kalibrierung manuell löschen |  | UINT16 | RO | 0x0000 (0dez)
7021:23 | Acceleration | Vorgabe der Beschleunigung | UINT16 | RO | 0x0000 (0dez)
7021:24 | Deceleration | Vorgabe der Verzögerung | UINT16 | RO | 0x0000 (0dez)
Index 9010 STM Info data Ch.1
Index (hex) | Name | Bedeutung | Data type | Flags | Default
9010:0 | STM Info data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x0C (12dez)
9010:01 | Status word |  | UINT16 | RO | 0x0000 (0dez)
9010:08 | Motor velocity |  | INT16 | RO | 0x0000 (0dez)
9010:09 | Internal position |  | UINT32 | RO | 0x00000000 (0dez)
9010:0A | Status word 2 |  | UINT16 | RO | 0x0000 (0dez)
9010:0B | Motor load |  | UINT16 | RO | 0x0000 (0dez)
9010:0C | Motor smart current |  | UINT8 | RO | 0x00 (0dez)
Index 9020 POS Info data Ch.1
Index (hex) | Motor smart current>Name | Bedeutung | UINT8>Data type | RO>Flags | 0x00 (0dez)>Default
9020:0 | POS Info data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
9020:01 | Status word |  | UINT16 | RO | 0x0000 (0dez)
9020:03 | State (drive controller) |  | UINT16 | RO | 0xFFFF (65535dez)
Index 9020 POS Info data Ch.1
Index (hex) | State (drive controller)>Name | Bedeutung | UINT16>Data type | RO>Flags | 0xFFFF (65535dez)>Default
9020:0 | POS Info data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
9020:01 | Status word |  | UINT16 | RO | 0x0000 (0dez)
9020:03 | State (drive controller) |  | UINT16 | RO | 0xFFFF (65535dez)
Index A010 STM Diag data Ch.1
Index (hex) | Name | Bedeutung | Data type | Flags | Default
A010:0 | STM Diag data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
A010:01 | Saturated |  | BOOLEAN | RO | 0x00 (0dez)
A010:02 | Over temperature |  | BOOLEAN | RO | 0x00 (0dez)
A010:03 | Torque overload |  | BOOLEAN | RO | 0x00 (0dez)
A010:04 | Under voltage |  | BOOLEAN | RO | 0x00 (0dez)
A010:05 | Over voltage |  | BOOLEAN | RO | 0x00 (0dez)
A010:06 | Short circuit |  | BOOLEAN | RO | 0x00 (0dez)
A010:08 | No control power |  | BOOLEAN | RO | 0x00 (0dez)
A010:09 | Misc error |  | BOOLEAN | RO | 0x00 (0dez)
A010:0A | Configuration |  | BOOLEAN | RO | 0x00 (0dez)
A010:0B | Motor stall |  | BOOLEAN | RO | 0x00 (0dez)
A010:11 | Actual operation mode |  | BIT4 | RO | 0x00 (0dez)
Index A020 POS Diag data Ch.1
Index (hex) | Name | Bedeutung | Data type | Flags | Default
A020:0 | POS Diag data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
A020:01 | Command rejected |  | BOOLEAN | RO | 0x00 (0dez)
A020:02 | Command aborted |  | BOOLEAN | RO | 0x00 (0dez)
A020:03 | Target overrun |  | BOOLEAN | RO | 0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Maximum sub-index | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0003 (3dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x000001FF (511dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x000002BF (703dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x000002C0 (704dez)
Index F081 Download revision
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F081:0 | Download revision | Reserviert | UINT8 | RO | 0x01 (1dez)
F081:01 | Revision number | Reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F80F STM Vendor data
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F80F:0 | STM Vendor data | Maximaler Subindex | UINT8 | RO | 0x09 (9dez)
F80F:04 | Warning temperature |  | INT8 | RW | 0x50 (80dez)
F80F:05 | Switch off temperature |  | INT8 | RW | 0x64 (100dez)
F80F:09 | Maximum current |  | UINT16 | RW | 0x1DC9 (7625dez)
Index F81F STM Vendor data 2
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F81F:0 | STM Vendor data 2 | Maximaler Subindex | UINT8 | RO | 0x0A (10dez)
F81F:01 | Slope control low side |  | BIT2 | RW | 0x00 (0dez)
F81F:03 | Slope control high side |  | BIT2 | RW | 0x00 (0dez)
F81F:05 | Sense voltage |  | BIT1 | RW | 0x00 (0dez)
F81F:08 | Blank time |  | BIT2 | RW | 0x03 (3dez)
Index F900 STM Info data
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F900:0 | STM Info data | Maximaler Subindex | UINT8 | RO | 0x07 (7dez)
F900:01 | Software version (driver) |  | STRING | RO |
F900:02 | Internal temperature |  | INT8 | RO | 0x00 (0dez)
F900:04 | Control voltage |  | UINT16 | RO | 0x0000 (0dez)
F900:05 | Motor supply voltage |  | UINT16 | RO | 0x0000 (0dez)
F900:06 | Cycle time |  | UINT16 | RO | 0x0000 (0dez)
F900:07 | Motor supply current |  | UINT16 | RO | 0x0000 (0dez)


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der IP-67-Module und die verwendeten Metallteile. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)

Anhang [image] Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
Allgemeines
Zukünftig werden Sie vermehrt auf Beckhoff Produkten maschinenlesbare Informationen in Form eines Data Matrix Codes (DMC, Code-Schema ECC200) finden. Dieser hilft uns bei der Verbesserung des Qualitätssicherungsprozesses und kann darüber hinaus von Ihnen zur besseren Identifikation unserer Produkte genutzt werden.
Die Einführung des Data Matrix Codes (bei Beckhoff BIC = Beckhoff Identification Code genannt) erfolgt schrittweise über alle Produktgruppen hinweg.
Die Informationen des BICs orientieren sich an dem ANSI-Standard MH10.8.2-2016
Darstellung und Inhalte des BICs
Der BIC ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist lesbar und enthält Informationen, die Sie für Ihr internes Handling und Verwaltung der Produkte nutzen können. Beim Scannen des BICs finden Sie folgende Informationen:
Codierte Informationen auf dem BIC
Pos.-Nr. | Art der Information | Erklärung
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u.
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10…
5 | Chargennummer | Optional: Produktionsjahr und -woche
6 | ID-/Seriennummer | Optional: Heutiges Seriennummer-System, z. B. bei Safety-Produkten
7 | Variantennummer | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten
8 | Date Code | Intern
9 | Auftrags-/Chargennummer | Intern
10 | Seriennummer | Intern
... |  |
Jede Information ist anhand des sog. Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gem. nachstehender Tabelle. Sind die Informationen kürzer werden sie durch Leerzeichen ersetzt. Die Daten unter den Positionen 1-4 sind immer vorhanden (temporäre Einschränkung, s. u., BTN).
Übersicht der festgelegten Datenidentifikatoren mit Beispielen
Pos-Nr. | Art der Information | Datenidentifikator | Anzahl Stellen | Beispiel
1 | Beckhoff-Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | 1K | 32 | 1KEL1809
4 | Menge | Q | 6 | Q1
5 | Chargennummer | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | 51S | 12 | 51S678294104
7 | Variante | 30P | 32 | 30PF971 , 2*K183
8 | Date Code | 9D | 8 | 9DG0118
9 | Auftrags-/Chargennummer | 1T | 14 | 1TFA12345678
10 | Seriennummer | 52S | 23 | 52S2304853-1-004
... |  |  |  |
Aufbau des BICs
Beispiel einer zusammengesetzten Information aus den Positionen 1 - 4 und 6. Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die in Zukunft alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.