EP6224, EP6228 - IO-Link-Master in Schutzart IP67
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
1.5
▪
IO-Link Master Grundlagen aktualisiert
▪
IO-Link Konfiguration aktualisiert
1.4
▪
Update Technische Daten
▪
EP6228-3132 eingefügt
1.3.0
▪
Update Technische Daten
▪
Sicherheitshinweise neues Layout
1.2.5
▪
EP6228-x0x2 – Technische Daten aktualisiert
▪
Gestaltung der Sicherheitshinweise an IEC 82079-1 angepasst.
1.2.4
▪
EP6228-3032 hinzugefügt
▪
EP6224-x022 – Technische Daten aktualisiert
▪
EP6228-x0x2 – Technische Daten aktualisiert
▪
EP6228-x0x2 – Einführung aktualisiert
▪
EP622x Modulübersicht aktualisiert
▪
Leitungsverluste 7/8“ hinzugefügt
▪
Konfiguration mit TwinCAT - Erläuterung Karteireiter und IO-Link Master aktualisiert
1.2.3
▪
Objektbeschreibung und Parametrierung aktualisiert
▪
Grundlagen IO-Link aktualisiert
1.2.2
▪
Objektbeschreibung und Parametrierung aktualisiert
1.2.1
▪
Anzugsmomente für Steckverbinder aktualisiert
1.2.0
▪
EP6228-0022 hinzugefügt
▪
Objektbeschreibung und Parametrierung aktualisiert
▪
EP6224-x022 Prozessabbild aktualisiert
▪
Bilder für IO-Link und Sensorkabel aktualisiert
1.1.0
▪
Power-Anschluss aktualisiert
1.0.0
▪
Erste Veröffentlichung
0.6
▪
Korrekturen
0.5
▪
Erste vorläufige Version
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer):
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code enthält zusätzliche Informationen über den Auslieferungszustand des Moduls: Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC).


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Produktgruppe: EtherCAT-Box-Module
•
Modulübersicht
•
EP6224
•
EP6228


Produktgruppe: EtherCAT-Box-Module

Produktübersicht [image] Produktgruppe: EtherCAT-Box-Module
Produktgruppe: EtherCAT-Box-Module
EtherCAT-Box-Module sind I/O-Module für industrielle Steuerungen.
Sie erfüllen die Schutzart IP67 und sind vorgesehen für den Einsatz außerhalb des Schaltschranks in nassen, schmutzigen oder staubigen Industrie-Umgebungen.
EtherCAT-Box-Module kommunizieren mit der Steuerung über den Feldbus EtherCAT. Sie haben jeweils zwei Anschlüsse für die EtherCAT-Kommunikation und für die Spannungsversorgung:
▪
Einspeisung
▪
Weiterleitung
Das ermöglicht die Verkabelung von EtherCAT-Box-Modulen in einer Linienstruktur:
EtherCAT Box Weiterleitung Beispiel
EtherCAT-Box-Module: Beispiel für die Verkabelung in einer Linienstruktur


Modulübersicht

Produktübersicht [image] Modulübersicht
Modulübersicht
Modul | IO-Link Ports | Ausgangsstrom
 |  | Sensor/Logik-Versorgung L+ |  | Aktor-Versorgung (Ports Class B) P24
 |  | Pro Port | Summe | Pro Port | Summe
EP6224-2022 | 4 x Class A | 1,4 A | 4,0 A | - | -
EP6224-3022 | 4 x Class B | 1,4 A | 4,0 A | 2,0 A | 2,0 A
EP6228-0022 | 8 x Class A | 1,4 A | 4,0 A | - | -
EP6228-3032 | 8 x Class B | 1,4 A | 16,0 A | 4,0 A 1) | 16,0 A
EP6228-3132 | 4 x Class A 4 x Class B | 1,4 A | 16,0 A | 4,0 A 1) | 16,0 A
1) Dieser Ausgangsstrom ist außerdem der maximale Summenstrom für ein Port-Paar.
Die Port-Paare sind in den Technischen Daten spezifiziert.


EP6224

Produktübersicht [image] EP6224
EP6224
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Lieferumfang
•
Prozessabbild


Einführung

Produktübersicht [image] EP6224 [image] Einführung
Einführung
EP6224-2022
EP6224-3022
IO-Link Master
Das IO-Link-Modul EP6224 ermöglicht den Anschluss von bis zu vier IO-Link-Teilnehmern, den sogenannten IO-Link-Devices. Dies können Aktoren, Sensoren, Kombinationen aus beiden oder die Beckhoff EPIxxxx-Module sein. Die Verbindung zwischen dem Modul und dem Teilnehmer erfolgt als Punkt-zu-Punkt-Verbindung. IO-Link ist als intelligentes Bindeglied zwischen der Feldbusebene und dem Sensor angelegt, wobei Parametrierungsinformationen über die IO-Link-Verbindung bidirektional ausgetauscht werden können. Die Parametrierung der IO-Link-Devices mit Servicedaten kann aus TwinCAT heraus über ADS oder im System Manager erfolgen.
In der Standardeinstellung arbeitet die EP6224 als 4-Kanal-Eingangsmodul, 24 VDC, das bei Bedarf mit angeschlossenen IO-Link-Devices kommuniziert, sie parametriert und ggf. in der Betriebsart umstellt.
Quick Links
Installation
Inbetriebnahme


Technische Daten

Produktübersicht [image] EP6224 [image] Technische Daten
Technische Daten
Alle Werte sind typische Werte bei 25 °C, wenn nicht anders angegeben.
Technische Daten | EP6224-2022 | EP6224-3022
Feldbus
Feldbus | EtherCAT
Anschluss | 2 x M8-Buchse, grün
Potenzialtrennung | 500 V (Feldbus / IO)
Versorgungsspannungen
Anschluss | Einspeisung: 1 x M8-Stecker, 4-polig Weiterleitung: 1 x M8-Buchse, 4-polig
Steuerspannung US
Nennspannung | 24 VDC (-15 % / +20 %)
Summenstrom | max. 4 A 1)
Verbraucher | • Modulelektronik: 130 mA • IO-Link Devices: Sensor/Logik-Versorgung L+
Peripheriespannung UP
Nennspannung | 24 VDC (-15 % / +20 %)
Summenstrom | max. 4 A 1)
Verbraucher | - | IO-Link Devices Class B: Aktor-Versorgung P24
IO-Link
Anzahl Ports | 4 x Class A | 4 x Class B
Anschluss | 4 x M12-Buchse
Kabellänge | max. 20 m
Spezifikation | IO-Link V1.1
Datenrate | COM1: 4,8 kbit/s COM2: 38,4 kbit/s COM3: 230,4 kbit/s
Sensor/Logik-Versorgung L+ | 24VDC aus der Steuerspannung US max. 1,4 A pro Port max. 4,0 A in Summe
Aktor-Versorgung P24 (Ports Class B) | - | 24VDC aus der Peripheriespannung UP max. 2,0 A pro Port max. 4,0 A in Summe
Umgebungsbedingungen
Umgebungstemperatur im Betrieb | -25 .. +60 °C 0 .. +55 °C gemäß cURus
Umgebungstemperatur bei Lagerung | -40 .. +85 °C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Mechanik
Gewicht | ca. 250 g
Einbaulage | beliebig
Zulassungen und Konformität
Zulassungen | CE, cURus
1) Summenstrom von Verbrauchern und Spannungs-Weiterleitung. Dieser Wert entspricht der
Stromtragfähigkeit der Anschlüsse für die Versorgungsspannungen.
Zusätzliche Prüfungen
Die Boxen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3 Achsen
 | 5 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3 Achsen
 | 35 g, 11 ms


Lieferumfang

Produktübersicht [image] EP6224 [image] Lieferumfang
Lieferumfang
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EtherCAT Box EP6224
▪
1x Schutzkappe für Versorgungsspannungs-Eingang, M8, transparent (vormontiert)
▪
1x Schutzkappe für Versorgungsspannungs-Ausgang, M8, schwarz (vormontiert)
▪
2x Schutzkappe für EtherCAT-Buchse, M8, grün (vormontiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
Vormontierte Schutzkappen gewährleisten keinen IP67-Schutz
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Stellen Sie den korrekten Sitz der Schutzkappen sicher, um die Schutzart IP67 zu gewährleisten.


Prozessabbild

Produktübersicht [image] EP6224 [image] Prozessabbild
Prozessabbild
Weiterführende Informationen
•
Zuordnung von IO-Link Ports zu Prozessdaten


Zuordnung von IO-Link Ports zu Prozessdaten

Produktübersicht [image] EP6224 [image] Prozessabbild [image] Zuordnung von IO-Link Ports zu Prozessdaten
Zuordnung von IO-Link Ports zu Prozessdaten
Prozessabbild in TwinCAT | IO-Link Port | Status-Variable | Prozessdaten des IO-Link Device
EP6224-2022 Prozessabbild, 4 Devices | 1 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch1 | TC3 IO-Link-Modul Symbol Module 3 1)
 | 2 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch2 | TC3 IO-Link-Modul Symbol Module 4 1)
 | 3 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch3 | TC3 IO-Link-Modul Symbol Module 5 1)
 | 4 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch4 | TC3 IO-Link-Modul Symbol Module 6 1)
1) Die Module „Module 3“ bis „Module 6“ sind nur in den Prozessdaten vorhanden, wenn die entsprechenden IO-Link Ports konfiguriert wurden.


EP6228

Produktübersicht [image] EP6228
EP6228
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Lieferumfang
•
Prozessabbild


Einführung

Produktübersicht [image] EP6228 [image] Einführung
Einführung
EP6228-0022
EP6228-3032
EP6228-3132
IO-Link-Master
Das IO-Link-Modul EP6228 ermöglicht den Anschluss von bis zu acht IO-Link-Teilnehmern, den sogenannten IO-Link-Devices. Dies können IO-Link-Box-Module, Aktoren, Sensoren oder Kombinationen aus beiden sein. Die Verbindung zwischen dem Modul und dem Teilnehmer erfolgt als Punkt-zu-Punkt-Verbindung. Die EtherCAT Box wird über den EtherCAT-Master parametriert. IO-Link ist als intelligentes Bindeglied zwischen der Feldbusebene und dem Sensor angelegt, wobei Parametrierungsinformationen über die IO-Link-Verbindung bidirektional ausgetauscht werden können. Die Parametrierung der IO-Link-Devices mit Servicedaten kann aus TwinCAT heraus über ADS erfolgen oder sehr komfortabel über das integrierte IO-Link-Konfigurationstool.
In der Standardeinstellung arbeitet die EP6228 als 8-Kanal-Eingangsmodul, 24 VDC, das bei Bedarf mit angeschlossenen IO-Link-Devices kommuniziert, sie parametriert und ggf. in der Betriebsart umstellt.
Quick Links
Installation
Inbetriebnahme


Technische Daten

Produktübersicht [image] EP6228 [image] Technische Daten
Technische Daten
Alle Werte sind typische Werte bei 25 °C, wenn nicht anders angegeben.
Technische Daten | EP6228-0022 | EP6228-3032 | EP6228-3132
Feldbus
Feldbus | EtherCAT
Anschluss | 2 x M8-Buchse, grün
Potenzialtrennung | 500 V (Feldbus / IO)
Versorgungsspannungen
Anschluss | Einspeisung: 1 x M8-Stecker, 4-polig Weiterleitung: 1 x M8-Buchse, 4-polig | Einspeisung: 1 x 7/8"-Stecker, 5-polig Weiterleitung: 1 x 7/8"-Buchse, 5-polig
Steuerspannung US
Nennspannung | 24 VDC (-15 % / +20 %)
Verbraucher | • Modulelektronik: 130 mA • IO-Link Devices: Sensor/Logik-Versorgung L+
Summenstrom | max. 4 A 1) | max. 16 A 1)
Peripheriespannung UP
Nennspannung | 24 VDC (-15 % / +20 %)
Verbraucher | - | IO-Link Devices Class B: Aktor-Versorgung P24
Summenstrom | max. 4 A 1) | max. 16 A 1)
IO-Link
Anzahl Ports | 8 x Class A | 8 x Class B | 4 x Class A (Ports 1, 2, 5, 6) 4 x Class B (Ports 3, 4, 7, 8)
Anschluss | 8 x M12-Buchse
Kabellänge | max. 20 m
Spezifikation | IO-Link V1.1
Datenrate | COM1: 4,8 kbit/s COM2: 38,4 kbit/s COM3: 230,4 kbit/s
Sensor/Logik-Versorgung L+ | 24 VDC aus der Steuerspannung US max. 1,4 A pro Port max. 4,0 A in Summe | 24 VDC aus der Steuerspannung US max. 4,0 A pro Port max. 16,0 A in Summe
Aktor-Versorgung P24 (Ports Class B) | - | 24VDC aus der Peripheriespannung UP max. 4,0 A pro Port-Paar 2) max. 16,0 A in Summe
Umgebungsbedingungen
Umgebungstemperatur im Betrieb | -25 .. +60 °C 0 .. +55 °C gemäß cURus
Umgebungstemperatur bei Lagerung | -40 .. +85 °C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Mechanik
Gewicht | ca. 250 g | ca. 450 g
Einbaulage | beliebig
Zulassungen und Konformität
Zulassungen | CE, cURus | CE, cURus in Vorbereitung
1) Summenstrom von Verbrauchern und Spannungs-Weiterleitung. Dieser Wert entspricht der
Stromtragfähigkeit der Anschlüsse für die Versorgungsspannungen.
2) Port-Paare mit gemeinsamer Begrenzung der Aktor-Versorgung:
▪
EP6228-3032: Port-Paare 1+5, 2+6, 3+7, 4+8
▪
EP6228-3132: Port-Paare 3+7, 4+8
Zusätzliche Prüfungen
Die Boxen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3 Achsen
 | 5 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3 Achsen
 | 35 g, 11 ms


Lieferumfang

Produktübersicht [image] EP6228 [image] Lieferumfang
Lieferumfang
EP6228-0022
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EtherCAT Box EP6228-0022
▪
1x Schutzkappe für Versorgungsspannungs-Eingang, M8, transparent (vormontiert)
▪
1x Schutzkappe für Versorgungsspannungs-Ausgang, M8, schwarz (vormontiert)
▪
2x Schutzkappe für EtherCAT-Buchse, M8, grün (vormontiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
EP6228-3x32
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EtherCAT Box EP6228-3x32
▪
1x Schutzkappe für Versorgungsspannungs-Ausgang, 7/8", schwarz (vormontiert)
▪
2x Schutzkappe für EtherCAT-Buchse, M8, grün (vormontiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
Vormontierte Schutzkappen gewährleisten keinen IP67-Schutz
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Stellen Sie den korrekten Sitz der Schutzkappen sicher, um die Schutzart IP67 zu gewährleisten.


Prozessabbild

Produktübersicht [image] EP6228 [image] Prozessabbild
Prozessabbild
Weiterführende Informationen
•
Zuordnung von IO-Link Ports zu Prozessdaten


Zuordnung von IO-Link Ports zu Prozessdaten

Produktübersicht [image] EP6228 [image] Prozessabbild [image] Zuordnung von IO-Link Ports zu Prozessdaten
Zuordnung von IO-Link Ports zu Prozessdaten
Prozessabbild in TwinCAT | IO-Link Port | Status-Variable | Prozessdaten des IO-Link Device
EP6228-2022 Prozessabbild, 8 Devices | 1 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch1 | TC3 IO-Link-Modul Symbol Module 3 1)
 | 2 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch2 | TC3 IO-Link-Modul Symbol Module 4 1)
 | 3 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch3 | TC3 IO-Link-Modul Symbol Module 5 1)
 | 4 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch4 | TC3 IO-Link-Modul Symbol Module 6 1)
 | 5 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch5 | TC3 IO-Link-Modul Symbol Module 7 1)
 | 6 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch6 | TC3 IO-Link-Modul Symbol Module 8 1)
 | 7 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch7 | TC3 IO-Link-Modul Symbol Module 9 1)
 | 8 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputVariableContainer Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch8 | TC3 IO-Link-Modul Symbol Module 10 1)
1) Die Module „Module 3“ bis „Module 10“ sind nur in den Prozessdaten vorhanden, wenn die entsprechenden IO-Link Ports konfiguriert wurden.


IO-Link Master Grundlagen

IO-Link Master Grundlagen
IO-Link Master Grundlagen
Weiterführende Informationen
•
Topologie
•
Ports
•
Funktion „Data storage“


Montage und Anschluss

Montage und Anschluss
Montage und Anschluss
Weiterführende Informationen
•
Montage
•
Anschluss
•
UL-Anforderungen


Montage

Montage und Anschluss [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anzugsdrehmomente für Steckverbinder


Abmessungen

Montage und Anschluss [image] Montage [image] Abmessungen
Abmessungen
EP6224-xxxx
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 60 x 26,5 mm (ohne Steckverbinder)
EP6228-0022
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 60 x 26,5 mm (ohne Steckverbinder)
EP6228-xx32
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 16 A bei 40°C (gemäß IEC 60512-3)
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 150 x 60 x 26,5 mm (ohne Steckverbinder)


Befestigung

Montage und Anschluss [image] Montage [image] Befestigung
Befestigung
Hinweis
Verschmutzung bei der Montage
Verschmutzte Steckverbinder können zu Fehlfunktion führen. Die Schutzart IP67 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind.
•
Schützen Sie die Steckverbinder bei der Montage vor Verschmutzung.
Montieren Sie das Modul mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern.


Anzugsdrehmomente für Steckverbinder

Montage und Anschluss [image] Montage [image] Anzugsdrehmomente für Steckverbinder
Anzugsdrehmomente für Steckverbinder
Schrauben Sie Steckverbinder mit einem Drehmomentschlüssel fest. (z.B. ZB8801 von Beckhoff)
Steckverbinder-Durchmesser | Anzugsdrehmoment
M8 | 0,4 Nm
M12 | 0,6 Nm
7/8“ | 1,5 Nm


Anschluss

Montage und Anschluss [image] Anschluss
Anschluss
Richtlinien
Befolgen Sie diese Richtlinien, um die Schutzart IP67 zu gewährleisten:
▪
Montieren Sie Steckverbinder mit dem angegebenen Drehmoment. Verwenden Sie einen Drehmomentschlüssel, z.B. Beckhoff ZB8801.
▪
Verschließen Sie nicht benutzte Steckverbinder mit Schutzkappen.
▪
Stellen Sie den korrekten Sitz von vormontierten Schutzkappen sicher.
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u. U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Weiterführende Informationen
•
Versorgungsspannungen
•
EtherCAT
•
IO-Link


Versorgungsspannungen

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen
Versorgungsspannungen
Die EtherCAT Box wird mit zwei Versorgungsspannungen versorgt. Die Versorgungsspannungen sind in der EtherCAT Box galvanisch getrennt.
▪
Steuerspannung US
▪
Peripheriespannung UP
Weiterführende Informationen
•
EP6224-2022, EP6224-3022, EP6228-0022
•
EP6228-3032, EP6228-3132


EP6224-2022, EP6224-3022, EP6228-0022

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen [image] EP6224-2022, EP6224-3022, EP6228-0022
EP6224-2022, EP6224-3022, EP6228-0022
Weiterführende Informationen
•
M8-Steckverbinder
•
Status-LEDs
•
Leitungsverluste


M8-Steckverbinder

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen [image] EP6224-2022, EP6224-3022, EP6228-0022 [image] M8-Steckverbinder
M8-Steckverbinder
Hinweis
Defekt durch Fehlstecken möglich
M8-Steckverbinder für Versorgungsspannungen haben die gleiche Bauform wie M8-Steckverbinder für EtherCAT. Beachten Sie die farbliche Codierung der Steckverbinder, um Fehlstecken zu vermeiden:
schwarz: Versorgungsspannungen
grün: EtherCAT
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei Steckverbinder am unteren Ende der Module:
▪
Einspeisung: Stecker IN, links
▪
Weiterleitung: Buchse OUT, rechts
Steckverbinder + LEDs
Steckverbinder für die Versorgungsspannungen
Kontaktbelegung
M8 4polig In+Out Kontaktbelegung
M8-Steckverbinder
Kontakt | Funktion | Beschreibung | Aderfarbe 1)
1 | US | Steuerspannung | Braun
2 | UP | Peripheriespannung | Weiß
3 | GNDS | GND zu US | Blau
4 | GNDP | GND zu UP | Schwarz
1) Die Aderfarben gelten für Leitungen vom Typ: Beckhoff ZK2020-xxxx-xxxx


Status-LEDs

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen [image] EP6224-2022, EP6224-3022, EP6228-0022 [image] Status-LEDs
Status-LEDs
Steckverbinder + LEDs
Status-LEDs für die Versorgungsspannungen
LED | Anzeige | Bedeutung
US (Steuerspannung) | aus | Versorgungsspannung US nicht vorhanden
 | leuchtet grün | Versorgungsspannung US vorhanden
UP (Peripheriespannung) | aus | Versorgungsspannung UP nicht vorhanden
 | leuchtet grün | Versorgungsspannung UP vorhanden


Leitungsverluste

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen [image] EP6224-2022, EP6224-3022, EP6228-0022 [image] Leitungsverluste
Leitungsverluste
Beachten Sie bei der Planung einer Anlage den Spannungsabfall an der Versorgungs-Zuleitung. Vermeiden Sie, dass der Spannungsabfall so hoch wird, dass die Versorgungsspannungen an der Box die minimale Nennspannung unterschreiten.
Berücksichtigen Sie auch Spannungsschwankungen des Netzteils.
Spannungsabfall an der Versorgungs-Zuleitung
Leitungsverluste M8 2A
Leitungsverluste M8 4A


EP6228-3032, EP6228-3132

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen [image] EP6228-3032, EP6228-3132
EP6228-3032, EP6228-3132
Weiterführende Informationen
•
7/8"-Steckverbinder
•
Status-LEDs
•
Leitungsverluste


7/8"-Steckverbinder

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen [image] EP6228-3032, EP6228-3132 [image] 7/8"-Steckverbinder
7/8"-Steckverbinder
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei Steckverbinder am unteren Ende der Module:
▪
Einspeisung: Stecker IN, links
▪
Weiterleitung: Buchse OUT, rechts
Steckverbinder + LEDs
Steckverbinder für die Versorgungsspannungen
Kontaktbelegung
7/8 Zoll In+Out Kontaktbelegung
7/8"-Steckverbinder
Kontakt | Funktion | Beschreibung | Aderfarbe 1)
1 | GNDP | GND zu UP | Schwarz
2 | GNDS | GND zu US | Blau
3 | FE | Funktionserde | Grau
4 | US | Steuerspannung | Braun
5 | UP | Peripheriespannung | Weiß
1) Die Aderfarben gelten für Leitungen vom Typ: Beckhoff ZK203x-xxxx.


Status-LEDs

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen [image] EP6228-3032, EP6228-3132 [image] Status-LEDs
Status-LEDs
Steckverbinder + LEDs
Status-LEDs für die Versorgungsspannungen
LED | Anzeige | Bedeutung
US (Steuerspannung) | aus | Versorgungsspannung US nicht vorhanden
 | leuchtet grün | Versorgungsspannung US vorhanden
UP (Peripheriespannung) | aus | Versorgungsspannung UP nicht vorhanden
 | leuchtet grün | Versorgungsspannung UP vorhanden


Leitungsverluste

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen [image] EP6228-3032, EP6228-3132 [image] Leitungsverluste
Leitungsverluste
Beachten Sie bei der Planung einer Anlage den Spannungsabfall an der Versorgungs-Zuleitung. Vermeiden Sie, dass der Spannungsabfall so hoch wird, dass die Versorgungsspannungen an der Box die minimale Nennspannung unterschreiten.
Berücksichtigen Sie auch Spannungsschwankungen des Netzteils.
Spannungsabfall an der Versorgungs-Zuleitung
Leitungsverluste 7/8" 2A
Leitungsverluste 7/8" 4A


EtherCAT

Montage und Anschluss [image] Anschluss [image] EtherCAT
EtherCAT
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungen


Steckverbinder

Montage und Anschluss [image] Anschluss [image] EtherCAT [image] Steckverbinder
Steckverbinder
Für den ankommenden und weiterführenden EtherCAT-Anschluss haben EtherCAT-Box-Module zwei grüne M8-Buchsen.
EtherCAT Steckverbinder
Kontaktbelegung
M8-Buchse 4polig Kontaktbelegung
M8-Buchse
EtherCAT | M8- Steckverbinder | Aderfarben
Signal | Kontakt | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | gelb1) | orange/weiß | weiß/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | weiß1) | blau/weiß | weiß/grün
Rx - | 3 | blau1) | blau | grün
Shield | Gehäuse | Schirm | Schirm | Schirm
1) Aderfarben nach EN 61918
Anpassung der Aderfarben für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx
Zur Vereinheitlichung wurden die Aderfarben der Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx auf die Aderfarben der EN61918 umgestellt: gelb, orange, weiß, blau. Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften der Leitungen sind bei der Umstellung der Aderfarben erhalten geblieben.


Status-LEDs

Montage und Anschluss [image] Anschluss [image] EtherCAT [image] Status-LEDs
Status-LEDs
EtherCAT Status-LEDs
L/A (Link/Act)
Neben jeder EtherCAT-Buchse befindet sich eine grüne LED, die mit „L/A“ beschriftet ist. Die LED signalisiert den Kommunikationsstatus der jeweiligen Buchse:
LED | Bedeutung
aus | keine Verbindung zum angeschlossenen EtherCAT-Gerät
leuchtet | LINK: Verbindung zum angeschlossenen EtherCAT-Gerät
blinkt | ACT: Kommunikation mit dem angeschlossenen EtherCAT-Gerät
Run
Jeder EtherCAT-Slave hat eine grüne LED, die mit „Run“ beschriftet ist. Die LED signalisiert den Status des Slaves im EtherCAT-Netzwerk:
LED | Bedeutung
aus | Slave ist im Status „Init“
blinkt gleichmäßig | Slave ist im Status „Pre-Operational“
blinkt vereinzelt | Slave ist im Status „Safe-Operational“
leuchtet | Slave ist im Status „Operational“
Beschreibung der Stati von EtherCAT-Slaves


Leitungen

Montage und Anschluss [image] Anschluss [image] EtherCAT [image] Leitungen
Leitungen
Verwenden Sie zur Verbindung von EtherCAT-Geräten geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
EtherCAT nutzt vier Adern für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung „Auto MDI-X“ können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, als auch gekreuzte Kabel (Cross-Over) verwenden.
Detaillierte Empfehlungen zur Verkabelung von EtherCAT-Geräten


IO-Link

Montage und Anschluss [image] Anschluss [image] IO-Link
IO-Link
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs


Steckverbinder

Montage und Anschluss [image] Anschluss [image] IO-Link [image] Steckverbinder
Steckverbinder
Die IO-Link Ports sind als M12-Buchsen ausgeführt.
M12-Buchse
EP6224-2022
EP6228-0022
Kontakt | Funktion | Beschreibung | Aderfarbe 1)
1 | L+ | Versorgungsspannung (US1) | braun
2 | - | - | weiß
3 | L- | GND | blau
4 | C/Q | IO-Link Datenleitung | schwarz
5 | - | - | grau
EP6224-3022
EP6228-3032
Kontakt | Funktion | Beschreibung | Aderfarbe 1)
1 | L+ | Sensor/Logik-Versorgung (US1) | braun
2 | P24 | Aktor-Versorgung (UP1) | weiß
3 | L- | GND zu L+ | blau
4 | C/Q | IO-Link Datenleitung | schwarz
5 | N24 | GND zu P24 | grau
EP6228-3132
Kontakt | X01, X02, X05, X06: Ports Class A |  | X03, X04, X07, X08: Ports Class B |  | Aderfarbe 1)
 | Funktion | Beschreibung | Funktion | Beschreibung
1 | L+ | Versorgungsspannung (US1) | L+ | Sensor/Logik-Versorgung (US1) | braun
2 | DI | Digitaler Eingang | P24 | Aktor-Versorgung (UP1) | weiß
3 | L- | GND | L- | GND zu L+ | blau
4 | C/Q | IO-Link Datenleitung | C/Q | IO-Link Datenleitung | schwarz
5 | - | - | N24 | GND zu P24 | grau
1) Die Aderfarben gelten für M12-Sensorleitungen von Beckhoff:
▪
ZK2000-5xxx
▪
ZK2000-6xxx
▪
ZK2000-7xxx.


Status-LEDs

Montage und Anschluss [image] Anschluss [image] IO-Link [image] Status-LEDs
Status-LEDs
IO-Link Port LEDs
Status-LEDs eines IO-Link Ports
1 - IO-Link
LED-Signal
Bedeutung
aus
Möglichkeiten:
▪
Port nicht konfiguriert
▪
Logikpegel Low 1)
leuchtet rot
blinkt vereinzelt grün
Möglichkeiten:
▪
IO-Link Verbindungsversuch
▪
Kein IO-Link Device angeschlossen
▪
Falsches IO-Link Device angeschlossen
▪
IO-Link Device defekt
blinkt grün
IO-Link Kommunikation aktiv
leuchtet grün
Logikpegel High 1)
1) Port konfiguriert als digitaler Eingang oder Ausgang
2 - Digitaler Eingang DI (nur EP6228-3132)
Die LED leuchtet, wenn ein High-Pegel am digitalen Eingang DI anliegt.


UL-Anforderungen

Montage und Anschluss [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


Inbetriebnahme und Konfiguration

Inbetriebnahme und Konfiguration
Inbetriebnahme und Konfiguration
Weiterführende Informationen
•
Konfiguration in TwinCAT
•
IO-Link Konfiguration
•
Objektbeschreibung und Parametrierung


Konfiguration in TwinCAT

Inbetriebnahme und Konfiguration [image] Konfiguration in TwinCAT
Konfiguration in TwinCAT
Eine EtherCAT Box muss in TwinCAT konfiguriert werden, damit ihre Funktionen in einem SPS-Programm genutzt werden können.
Unter dem folgenden Link finden Sie eine Schnellstartanleitung, die die Konfiguration einer EtherCAT Box in TwinCAT beschreibt:
https://infosys.beckhoff.com/content/1031/epioconfiguration/index.html?id=5323978252154950216


IO-Link Konfiguration

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration
IO-Link Konfiguration
Weiterführende Informationen
•
Konfigurationstool öffnen
•
Devices zu Ports zuweisen
•
Device-Katalog ergänzen
•
Einen Port parametrieren
•
Ein Device parametrieren
•
Einen Port als digitalen Eingang/Ausgang konfigurieren
•
Konfiguration aktivieren


Konfigurationstool öffnen

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Konfigurationstool öffnen
Konfigurationstool öffnen
➢
Voraussetzung: ein IO-Link Master ist im Solution Explorer unter dem Eintrag „I/O“ angefügt.
1.
Doppelklicken Sie auf den IO-Link Master.
⇨
Der Geräte-Editor für den IO-Link Master öffnet sich.
2.
Klicken Sie auf den Karteireiter „IO-Link“.
⇨
Das IO-Link Konfigurationstool öffnet sich.
IO-Link Konfigurationstool mit Markierung
Übersicht
Das Konfigurationstool enthält zwei Felder:
▪
„Ports“
Das linke Feld „Ports“ zeigt eine Liste der Ports des IO-Link Masters. Wenn einem Port ein Device zugewiesen ist, steht neben dem Port die Bezeichnung des Device.
▪
„Catalog“
Das rechte Feld „Catalog“ zeigt den Device-Katalog. Der Device-Katalog enthält eine Liste der IO-Link Devices, für die in der lokalen TwinCAT-Installation eine Gerätebeschreibung vorhanden ist.
Änderungen im IO-Link Konfigurationstool werden erst wirksam, wenn Sie die IO-Link Konfiguration aktivieren.


Devices zu Ports zuweisen

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Devices zu Ports zuweisen
Devices zu Ports zuweisen
Es gibt vier Möglichkeiten, Devices zu Ports zuzuweisen:
Ein Device aus dem Device-Katalog auswählen
1.
Suchen Sie das gewünschte Device im Feld „Catalog“.
Nicht vorhanden? Device-Katalog ergänzen.
2.
Weisen Sie das Device einem Port zu. Dazu gibt es zwei Möglichkeiten:
- Ziehen Sie das Device per Drag-and-drop auf den gewünschten Port.
- Klicken Sie mit der rechten Maustaste auf das Device
Klicken Sie im Kontextmenü auf „Add to Port n“.
⇨
Das Device wird dem Port zugewiesen
Eine Gerätebeschreibungs-Datei IODD importieren
1.
Device-Katalog ergänzen > „Import aus dem Dateisystem“
2.
Ein Device aus dem Device-Katalog auswählen
⇨
Das Device wird dem Port zugewiesen
Devices scannen
➢
Voraussetzung: der Master und die Devices sind verkabelt und mit Spannung versorgt.
1.
Klicken Sie auf die Schaltfläche „Scan Devices“.
⇨
Der IO-Link Master fordert alle angeschlossenen Devices auf, sich zu identifizieren. Jedes erkannte Device wird automatisch dem Port zugewiesen, an dem es angeschlossen ist.
Eine Gerätebeschreibung manuell eintragen
1.
Klicken Sie mit der rechten Maustaste auf einen Port.
2.
Klicken Sie im Kontextmenü auf „Create Device“.
⇨
Ein Dialogfenster öffnet sich.
3.
Tragen Sie die Informationen ein, die das IO-Link Device beschreiben.


Device-Katalog ergänzen

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Device-Katalog ergänzen
Device-Katalog ergänzen
Der Device-Katalog enthält nach der Installation von TwinCAT nur die Gerätebeschreibungen von IO-Link Devices von Beckhoff. Es gibt zwei Möglichkeiten, den Katalog zu ergänzen:
Import aus der Online-Datenbank „IODDfinder“
➢
Voraussetzung: der PC kann auf das Internet zugreifen
1.
Klicken Sie auf die Schaltfläche „IODD Finder“.
2.
Suchen Sie das gewünschte Device.
3.
Klicken Sie auf das Bild in der Spalte „Picture“.
⇨
Die Gerätebeschreibung wird heruntergeladen und in den Device-Katalog eingefügt.
Import aus dem Dateisystem
1.
Klicken Sie auf die Schaltfläche „Import Devicedescription“
2.
Öffnen Sie in dem erscheinenden Dialogfenster eine Gerätebeschreibungs-Datei (IODD)
⇨
Die Gerätebeschreibung wird in den Device-Katalog eingefügt.


Einen Port parametrieren

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Einen Port parametrieren
Einen Port parametrieren
➢
Voraussetzung: Dem Port ist ein Device zugewiesen. Devices zu Ports zuweisen.
1.
Klicken Sie im Feld „Ports“ mit der rechten Maustaste auf den Port
2.
Klicken Sie im Kontextmenü auf „Settings“
⇨
Die Registerkarte „Settings“ öffnet sich


Ein Device parametrieren

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Ein Device parametrieren
Ein Device parametrieren
➢
Voraussetzung: Das Device ist einem Port zugewiesen. Devices zu Ports zuweisen.
1.
Klicken Sie im Feld „Ports“ mit der rechten Maustaste auf das Device
2.
Klicken Sie auf „Parameter“
⇨
Die Registerkarte „Parameter“ öffnet sich
Schaltflächen
▪
„Read“
Werte der Parameter aus dem Device auslesen.
▪
„Write“
Werte der Parameter in das Device schreiben.
▪
„Set default“
Die Werte der Device-Parameter auf die Standardwerte zurücksetzen. Die Standardwerte werden aus der Gerätebeschreibung im Device-Katalog übernommen.
▪
„Store“
Die aktuellen Werte der Device-Parameter im Master speichern. Funktion „Data Storage“.


Einen Port als digitalen Eingang/Ausgang konfigurieren

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Einen Port als digitalen Eingang/Ausgang konfigurieren
Einen Port als digitalen Eingang/Ausgang konfigurieren
IO-Link Ports können auch als digitaler Eingang oder digitaler Ausgang konfiguriert werden. So können digitale Sensoren und Aktoren ohne IO-Link-Funktionalität an IO-Link Ports angeschlossen werden.
1.
Klappen Sie im Feld „Catalog“ den Baumknoten „Std-I/O“ auf
⇨
Die Betriebs-Modi „dig in“ und „dig out“ werden sichtbar
2.
Konfigurieren Sie den gewünschten Port. Dazu gibt es zwei Möglichkeiten:
1. Drag-and-drop: ziehen Sie „dig in“ oder „dig out“ auf den Port im Feld „Ports“
2. Rechtsklick auf „dig in“ oder „dig out“ und Klick auf „Add to Port n“


Konfiguration aktivieren

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Konfiguration aktivieren
Konfiguration aktivieren
Änderungen im IO-Link Konfigurationstool werden erst wirksam, wenn Sie die IO-Link Konfiguration aktivieren.
Es gibt zwei Möglichkeiten, die IO-Link Konfiguration zu aktivieren:
▪
Klicken Sie auf die Schaltfläche „Reload Devices“
TC3 Button Reload Devices
▪
Aktivieren Sie die TwinCAT-Konfiguration:
Klicken Sie auf die Schaltfläche „Activate Configuration“
TC3 Button Activate Configuration


Objektbeschreibung und Parametrierung

Inbetriebnahme und Konfiguration [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind.
▪
Objekte die zum regulären Betrieb z.B. durch ADS-Zugriff bestimmt sind.
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind.
▪
Profilspezifische Objekte, die allgemeine Statusanzeigen und Stati der Ein- und Ausgänge darstellen.
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Objekte für die Inbetriebnahme
•
Objekte für den regulären Betrieb
•
Standardobjekte (0x1000-0x1FFF)
•
Profilspezifische Objekte (0x6000-0xFFFF)


Objekte für die Inbetriebnahme

Inbetriebnahme und Konfiguration [image] Objektbeschreibung und Parametrierung [image] Objekte für die Inbetriebnahme
Objekte für die Inbetriebnahme
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 80n0 IO Settings Ch. 1 - 4 (für 0 ≤ n ≤ 3)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | IO Settings | IO Settings Channel x | UINT8 | RW | 0x28 (40dez)
80n0:04 | Device ID | Die Device ID dient zur Validierung eines IO-Link Gerätes. | UINT32 | RW | 0x00000000 (0dez)
80n0:05 | VendorID | Die Vendor ID dient zur Validierung des Herstellers vom IO-Link Gerät. | UINT32 | RW | 0x00000000 (0dez)
80n0:20 | IO-Link Revision | Kennzeichnung der Version der Spezifikation, nach der das IO-Link Gerät kommuniziert. Bit 0-3: MinorRev Bit 4-7: MajorRev | UNIT8 | RW | 0x00 (0dez)
80n0:21 | Frame capability | Der Frame capability kennzeichnet bestimmte Funktionalitäten des IO-Link Gerätes (wie z. B.: SPDU supported). Bit 0: SPDU Bit 1: Type1 Bit 7: PHY1 | UINT8 | RW | 0x00 (0dez)
80n0:22 | Min cycle time | Die Cycle Time entspricht der Zykluszeit, mit der der IO-Link Master das IO-Link Gerät ansprechen soll. Dieser Wert wird in das IO-Link Format für Min Cycle Time übertragen. Bit 6 und 7: Time Base Bit 0 bis 5: Multiplier 0x00: Der IO-Link-Master verwendet automatisch die kleinstmögliche Updatezeit des IO-Link-Devices. | UINT8 | RW | 0x00 (0dez)
80n0:23 | Offset time | reserviert | UINT8 | RW | 0x00 (0dez)
80n0:24 | Process data in length | Diese Parameter werden im IO-Link Format für "Process data in length" übertragen. Bit 7: BYTE (zeigt an, ob der Wert in LENGTH als Bitlänge [Bit nicht gesetzt] oder als Bytelänge + 1 [Bit gesetzt] interpretiert wird Bit 6: SIO (zeigt an, ob das Gerät den Standard IO-Modus unterstützt [Bit gesetzt]) Bit 0 bis 4: LENGTH (Länge der Prozessdaten) | UINT8 | RW | 0x00 (0dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:25 | Process data out length | Diese Parameter werden im IO-Link Format für "Process data out length" übertragen. Bit 7: BYTE (zeigt an, ob der Wert in LENGTH als Bitlänge [Bit nicht gesetzt] oder als Bytelänge + 1 [Bit gesetzt] interpretiert wird Bit 6: SIO (zeigt an, ob das Gerät den Standard IO-Modus unterstützt [Bit gesetzt]) Bit 0 bis 4: LENGTH (Länge der Prozessdaten) | UINT8 | RW | 0x00 (0dez)
80n0:26 | Compatible ID | reserviert | UINT16 | RW | 0x0000 (0dez)
80n0:27 | Reserved | reserviert | UINT16 | RW | 0x0000 (0dez)
80n0:28 | Master Control | 0: IO-Link Port inaktiv 1: IO-Link Port als Digital Input Port 2: IO-Link Port als Digital Output Port 3: IO-Link Port in Kommunikation über das IO-Link Protokoll 4: IO-Link Port in Kommunikation über das IO-Link Protokoll. IO-Link State ist ComStop (keine zyklische Kommunikation, nur auf Bedarf werden Daten ausgetauscht). | UINT16 | RW | 0x0000 (0dez)


Objekte für den regulären Betrieb

Inbetriebnahme und Konfiguration [image] Objektbeschreibung und Parametrierung [image] Objekte für den regulären Betrieb
Objekte für den regulären Betrieb
Die EP6224 verfügt über keine solchen Objekte.
Vollständige Übersicht


Standardobjekte (0x1000-0x1FFF)

Inbetriebnahme und Konfiguration [image] Objektbeschreibung und Parametrierung [image] Standardobjekte (0x1000-0x1FFF)
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x184C1389 (407638921dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP6224-xxxx
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x18503052 (407908434dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 IO RxPDOPDO-Map Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | IO RxPDOPDO-Map Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RW | 0x01 (1dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1601 IO RxPDOPDO-Map Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | IO RxPDOPDO-Map Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RW | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1602 IO RxPDOPDO-Map Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | IO RxPDOPDO-Map Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RW | 0x01 (1dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1603 IO RxPDOPDO-Map Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | IO RxPDOPDO-Map Ch.4 | PDO Mapping RxPDO 4 | UINT8 | RW | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A00 IO TxPDOPDO-Map Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | IO TxPDOPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RW | 0x01 (1dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A01 IO TxPDOPDO-Map Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | IO TxPDOPDO-Map Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RW | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A02 IO TxPDOPDO-Map Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | IO TxPDOPDO-Map Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RW | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A03 IO TxPDOPDO-Map Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | IO TxPDOPDO-Map Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RW | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A04 TxPDOeState TxPDO-Map Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | TxPDOeState TxPDO-Map Device | PDO Mapping TxPDO 5 | UINT8 | RW | 0x04 (4dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x01 (State Ch1)) | UINT32 | RW | 0xF100:01, 8
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x02 (State Ch2)) | UINT32 | RW | 0xF100:02, 8
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x03 (State Ch3)) | UINT32 | RW | 0xF100:03, 8
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x04 (State Ch4)) | UINT32 | RW | 0xF100:04, 8
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x04 (4dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | SubIndex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:04 | SubIndex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1603 (5635dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
1C13:05 | SubIndex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A04 (6660dez)
Index 1C32 SM output parameter
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 | Sync mode | Aktuelle Synchronisierungsbetriebsart: 0: Free Run 1: Synchron with SM 2 Event 2: DC-Mode - Synchron with SYNC0 Event 3: DC-Mode - Synchron with SYNC1 Event | UINT16 | RW | 0x0000 (0dez)
1C32:02 | Cycle time | Zykluszeit (in ns): Free Run: Zykluszeit des lokalen Timers Synchron with SM 2 Event: Zykluszeit des Masters DC-Mode: SYNC0/SYNC1 Cycle Time | UINT32 | RW | 0x000186A0 (100000dez)
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:04 | Sync modes supported | Unterstützte Synchronisierungsbetriebsarten: Bit 0 = 1: Free Run wird unterstützt Bit 1 = 1: Synchron with SM 2 Event wird unterstützt Bit 2-3 = 01: DC-Mode wird unterstützt Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode) Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08) | UINT16 | RO | 0xC007 (49159dez)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RO | 0x000186A0 (100000dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:08 | Command | 0: Messung der lokalen Zykluszeit wird gestoppt 1: Messung der lokalen Zykluszeit wird gestartet Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert. Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt | UINT16 | RW | 0x0000 (0dez)
1C32:09 | Delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) | BOOLEAN | RO | 0x00 (0dez)
Index 1C33 SM input parameter
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 | Sync mode | Aktuelle Synchronisierungsbetriebsart: 0: Free Run 1: Synchron with SM 3 Event (keine Outputs vorhanden) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 Event (Outputs vorhanden) | UINT16 | RW | 0x0000 (0dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x000186A0 (100000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:04 | Sync modes supported | Unterstützte Synchronisierungsbetriebsarten: Bit 0: Free Run wird unterstützt Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden) Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden) Bit 2-3 = 01: DC-Mode wird unterstützt Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden) Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden) Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08) | UINT16 | RO | 0xC007 (49159dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RO | 0x000186A0 (100000dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | wie 1C32:32 | BOOLEAN | RO | 0x00 (0dez)


Profilspezifische Objekte (0x6000-0xFFFF)

Inbetriebnahme und Konfiguration [image] Objektbeschreibung und Parametrierung [image] Profilspezifische Objekte (0x6000-0xFFFF)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 60n0 IO Inputs Ch. 1 - 4 (für 0 ≤ n ≤ 3)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | IO Inputs Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x00 (0dez)
60n0:01 | Subindex 001 | IO-Link Eingangs-Prozessdaten | - | RO | -
... | ... | ... | ... | ... | ...
60n0:10 | Subindex 016 | IO-Link Eingangs-Prozessdaten | - | RO | -
Index 70n0 IO Outputs Ch. 1 - 4 (für 0 ≤ n ≤ 3)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
70n0:0 | IO Outputs Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x00 (0dez)
70n0:01 | Subindex 001 | IO-Link Ausgangs-Prozessdaten | - | RO | -
... | ... | ... | ... | ... | ...
70n0:10 | Subindex 016 | IO-Link Ausgangs-Prozessdaten | - | RO | -
Index 90n0 IO Info data Ch. 1 - 4 (für 0 ≤ n ≤ 3)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n0:0 | IO Info data | Max. Subindex | UINT8 | RO | 0x27 (39dez)
90n0:04 | Device ID | Die Device ID dient zur Validierung eines IO-Link Gerätes. | UINT32 | RO | 0x00000000 (0dez)
90n0:05 | VendorID | Die Vendor ID dient zur Validierung des Herstellers vom IO-Link Gerät. | UINT32 | RO | 0x00000000 (0dez)
90n0:07 | IO-Link revision | Kennzeichnung der Version der Spezifikation, nach der das IO-Link Gerät kommuniziert. Bit 0-3: MinorRev Bit 4-7: MajorRev | UINT8 | RO | 0x00 (0dez)
90n0:20 | FrameCapability | Der Frame Capability kennzeichnet bestimmte Funktionalitäten des IO-Link Gerätes (wie z. B.: SPDU supported). Bit 0: SPDU Bit 1: Type1 Bit 7: PHY1 | UINT8 | RO | 0x00 (0dez)
90n0:21 | Min cycle time | Die Cycle Time entspricht der Zykluszeit, mit der der IO-Link Master das IO-Link Gerät ansprechen soll. Dieser Wert wird in der IO-Link Format für Min Cycle Time übertragen. Bit 6 und 7: Time Base Bit 0 bis 5: Multiplier | UINT8 | RO | 0x00 (0dez)
90n0:22 | Offset time | reserviert | UINT8 | RO | 0x00 (0dez)
90n0:23 | Process data in length | Diese Parameter werden im IO-Link Format für "Process data in length" übertragen. Bit 7: BYTE (zeigt an, ob der Wert in LENGTH als Bitlänge [Bit nicht gesetzt] oder als Bytelänge + 1 [Bit gesetzt] interpretiert wird Bit 6: SIO (zeigt an, ob das Gerät den Standard IO-Modus unterstützt [Bit gesetzt]) Bit 0 bis 4: LENGTH (Länge der Prozessdaten) | UINT8 | RO | 0x00 (0dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n0:24 | Process data out length | Diese Parameter werden im IO-Link Format für "Process data out length" übertragen. Bit 7: BYTE (zeigt an, ob der Wert in LENGTH als Bitlänge [Bit nicht gesetzt] oder als Bytelänge + 1 [Bit gesetzt] interpretiert wird Bit 6: SIO (zeigt an, ob das Gerät den Standard IO-Modus unterstützt [Bit gesetzt]) Bit 0 bis 4: LENGTH (Länge der Prozessdaten) | UINT8 | RO | 0x00 (0dez)
90n0:26 | Reserved | reserviert | UINT16 | RO | 0x0000 (0dez)
90n0:27 | Reserved2 | reserviert | UINT16 | RO | 0x0000 (0dez)
Index A0n0 IO Diag data Ch. 1 - 4 (für 0 ≤ n ≤ 3)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A0n0:0 | IO Diag data Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x02 (2dez)
A0n0:01 | IO-Link State | Der Wert des IO-Link State entspricht einem State aus der IO-Link Master Statemachine 0: INACTIVE 1: DIGINPUT 2: DIGOUTPUT 3: ESTABLISHCOMM 4: INITMASTER 5: INITDEVICE 7: PREOPERATE 8: OPERATE 9: STOP | UINT8 | RO | 0x00 (0dez)
A0n0:02 | Lost Frames | Hier werden die Anzahl der verloren gegangenen IO-Link Telegramme mitgezählt. Dieser Wert wird bei jedem Hochlauf von IO-Link gelöscht, ansonsten immer weiter gezählt. | UINT8 | RO | 0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0004 (4dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x04 (4dez)
F010:01 | SubIndex 001 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:02 | SubIndex 002 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:03 | SubIndex 003 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:04 | SubIndex 004 | - | UINT32 | RW | 0x0000184C (6220dez)
Index F100 Diagnosis Status data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F100:0 | Diagnosis Status data | Max. Subindex | UINT8 | RO | 0x04 (4dez)
F100:01 | State Ch1 | Statusbyte Ch. 1 | UINT8 | RO | 0x00 (0dez)
F100:02 | State Ch2 | Statusbyte Ch. 2 | UINT8 | RO | 0x00 (0dez)
F100:03 | State Ch3 | Statusbyte Ch. 3 | UINT8 | RO | 0x00 (0dez)
F100:04 | State Ch4 | Statusbyte Ch. 4 | UINT8 | RO | 0x00 (0dez)
Index F900 Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | Info data | Max. Subindex | UINT8 | RO | 0x09 (9dez)
F900:01 | IO-Link Version | - | UINT8 | RO | 0x10 (16dez)


Diagnose

Diagnose
Diagnose
Weiterführende Informationen
•
IO-Link Events
•
ADS Error Codes


IO-Link Events

Diagnose [image] IO-Link Events
IO-Link Events
Einige der IO-Link Sensoren leiten auftretende Ereignisse an der Master weiter. Diese Events können Informationen, Warnungen oder auch Fehlermeldungen sein, z. B. Kurzschluss oder Überhitzung.
Der IO-Link Master meldet diese Events durch Setzen des Device Diag Bits. Weiterführende Informationen zu den Events können über das CoE Verzeichnis oder auch über den Karteireiter DiagHistory ausgelesen werden.
Karteireiter DiagHistory
Die auftretenden Ereignisse werden nach Typ (Information, Warnung, Fehler), Flag, Auftreten des Ereignisses (Zeitstempel) und Nachricht (Port-Nummer & Eventcode) aufgegliedert.
Die Bedeutung der einzelnen Meldungen ist der Herstellerdokumentation zu entnehmen. Anhand der Portnummer kann das IO-Link Device direkt zugeordnet werden. Eine Verwaltung der eintreffenden Ereignisse kann über die verschiedenen Buttons erfolgen.
▪
Update History: ist das Feld "Auto Update" nicht ausgewählt, so können über den Button "Update History" die aktuellen Ereignisse angezeigt werden
▪
Auto Update: ist das Feld ausgewählt, so wird die Liste der auftretenden Ereignisse automatisch aktualisiert
▪
Only new Messages: ist das Feld ausgewählt, so werden nur die Meldungen angezeigt, die noch nicht bestätigt wurden
▪
Ack. Messages: ein auftretendes Ereignis wird über das Bit Device Diag gemeldet. Eine Bestätigung der Meldung setzt das Bit wider auf 0.
▪
Export Diag History: die aufgetretenen Ereignisse können als "txt"- Datei exportiert und somit archiviert werden.
▪
Advanced: dieses Feld hat zurzeit (3 Qu./2015) noch keine Funktion.


ADS Error Codes

Diagnose [image] ADS Error Codes
ADS Error Codes
Beim Auftreten eines Fehlers über ADS-Zugriff auf einen IO-Link Teilnehmer werden Fehlercodes generiert.
Der Fehlercode enthält Informationen über die Fehlerkategorie, Herkunft und Instanz. Die möglichen Fehlercodes sind in der nachfolgenden Tabelle aufgeführt.
In der darauffolgenden Tabelle sind zusätzliche Informationen zu einem bestimmten Fehler aufgelistet (S_APP_DEV):
Beispiel eines AdsReturnCode
AdsReturnCode 0x80110700
80: Device Application Error (IO-Link Spec),
11: Index not Available (IO-Link Spec),
0700: General ADS Error
Error Codes (IO-Link Spec)
Type | Herkunft | Name | Kategorie | Mode | Instanz | Wert (Hi Byte, hex) | Bemerkung
PDU buffer overflow | remote | S_PDU_BUFFER | ERROR | SiNGLE SHOT | DL | 52 | Device buffer is too small for storing the complete PDU
PDU checksum error (master) | local | M_PDU_CHECK | ERROR | SiNGLE SHOT | DL | 56 | Calculated PDU checksum in master does not match actual received SPDU
PDU checksum error (device) | remote | S_PDU_CHECK | ERROR | SiNGLE SHOT | DL | 56 | Calculated PDU checksum in device does not match actual received SPDU
PDU flow control error | remote | S_PDU_FLOW | ERROR | SiNGLE SHOT | DL | 56 | Violation of flow control rule during transfer of SPDU between master and device
Illegal PDU service primitive (master) | local | M_PDU_ILLEGAL | ERROR | SiNGLE SHOT | AL | 57 | Unknown service primitive or wrong response e.g. Read Response on Write Request
Illegal PDU service primitive (device) | local / remote | S_PDU_ILLEGAL | ERROR | SiNGLE SHOT | AL | 58 | Unknown service primitive e.g. different protocol revision
Communication error | remote | COM_ERR |  | SiNGLE SHOT | unknown | 10 | Negative service response initiated by a communication error, eg. IO-Link connection interrupted
Device application error | remote | S_APP_DEV** | ERROR | SiNGLE SHOT | APP | 80 | Service PDU transferred, but not processed due to device error. See error details in Additional Code**
Additional Code (IO-Link Spec)
Type | Wert (Lo Byte, hex) | Beschreibung
No details | 00 | Device buffer is too small for storing the complete PDU
Index not available | 11 | Calculated PDU checksum in master does not match actual received SPDU
Subindex not available | 12 | Calculated PDU checksum in device does not match actual received SPDU
Service temporarily not available | 20 | Violation of flow control rule during transfer of SPDU between master and device
Service temporarily not available, local control | 21 | Unknown service primitive or wrong response e.g. Read Response on Write Request
Service temporarily not available, device control | 22 | Unknown service primitive e.g. different protocol revision
Access denied | 23 | Negative service response initiated by a communication error, eg. IO-Link connection interrupted
Parameter value out of range | 30 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Parameter value above limit | 31 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Parameter value below limit | 32 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Interfering parameter | 40 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Application failure | 81 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Application not ready | 82 | Service PDU transferred, but not processed due to device error. See error details in Additional Code


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der IP-67-Module und die verwendeten Metallteile. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)

Anhang [image] Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
Allgemeiner Hinweis zur Einführung des Beckhoff Identification Code (BIC)
Allgemeines
Zukünftig werden Sie vermehrt auf Beckhoff Produkten maschinenlesbare Informationen in Form eines Data Matrix Codes (DMC, Code-Schema ECC200) finden. Dieser hilft uns bei der Verbesserung des Qualitätssicherungsprozesses und kann darüber hinaus von Ihnen zur besseren Identifikation unserer Produkte genutzt werden.
Die Einführung des Data Matrix Codes (bei Beckhoff BIC = Beckhoff Identification Code genannt) erfolgt schrittweise über alle Produktgruppen hinweg.
Die Informationen des BICs orientieren sich an dem ANSI-Standard MH10.8.2-2016
Darstellung und Inhalte des BICs
Der BIC ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist lesbar und enthält Informationen, die Sie für Ihr internes Handling und Verwaltung der Produkte nutzen können. Beim Scannen des BICs finden Sie folgende Informationen:
Codierte Informationen auf dem BIC
Pos.-Nr. | Art der Information | Erklärung
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u.
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10…
5 | Chargennummer | Optional: Produktionsjahr und -woche
6 | ID-/Seriennummer | Optional: Heutiges Seriennummer-System, z. B. bei Safety-Produkten
7 | Variantennummer | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten
8 | Date Code | Intern
9 | Auftrags-/Chargennummer | Intern
10 | Seriennummer | Intern
... |  |
Jede Information ist anhand des sog. Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gem. nachstehender Tabelle. Sind die Informationen kürzer werden sie durch Leerzeichen ersetzt. Die Daten unter den Positionen 1-4 sind immer vorhanden (temporäre Einschränkung, s. u., BTN).
Übersicht der festgelegten Datenidentifikatoren mit Beispielen
Pos-Nr. | Art der Information | Datenidentifikator | Anzahl Stellen | Beispiel
1 | Beckhoff-Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | 1K | 32 | 1KEL1809
4 | Menge | Q | 6 | Q1
5 | Chargennummer | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | 51S | 12 | 51S678294104
7 | Variante | 30P | 32 | 30PF971 , 2*K183
8 | Date Code | 9D | 8 | 9DG0118
9 | Auftrags-/Chargennummer | 1T | 14 | 1TFA12345678
10 | Seriennummer | 52S | 23 | 52S2304853-1-004
... |  |  |  |
Aufbau des BICs
Beispiel einer zusammengesetzten Information aus den Positionen 1 - 4 und 6. Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die in Zukunft alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Ports

IO-Link Master Grundlagen [image] Ports
Ports
In der IO-Link Spezifikation sind zwei Klassen von IO-Link Ports definiert:
Ports Class A
Ports Class A sind vorgesehen für den Anschluss von IO-Link Devices vom Typ: Sensor.
Kontakte eines Ports Class A:
▪
Versorgungsspannung für das IO-Link Device: L+, L-
▪
Datenleitung für serielle Kommunikation oder Schaltsignale: C/Q
▪
Datenleitung für Schaltsignale (optional): DI/DQ
Ports Class B
Ports Class B sind vorgesehen für den Anschluss von IO-Link Devices vom Typ: Aktor.
Kontakte eines Ports Class B:
▪
Zwei galvanisch getrennte Versorgungsspannungen das für IO-Link Device:
–
Sensor/Logik-Versorgung: L+, L-
–
Aktor-Versorgung: P24, N24
▪
Datenleitung für serielle Kommunikation oder Schaltsignale: C/Q


Topologie

IO-Link Master Grundlagen [image] Topologie
Topologie
Der IO-Link Master dient als Gateway zwischen einem Automatisierungssystem (EtherCAT) und den IO-Link Devices. Er hat mehrere IO-Link Ports, an die jeweils ein IO-Link Device angeschlossen werden kann.
IO-Link Grundlagen Beispiel
IO-Link Topologie


Funktion „Data storage“

IO-Link Master Grundlagen [image] Funktion „Data storage“
Funktion „Data storage“
Der IO-Link Master unterstützt die Funktion „Data storage“. Er kann eine Kopie der Parameter von angeschlossenen Devices nichtflüchtig speichern.
Wenn ein Device ausfällt, bleiben seine Parameter im Speicher des IO-Link Masters erhalten.
Wenn ein defektes Device durch ein neues, baugleiches Device ersetzt wird, kann der Master das neue Device automatisch mit den gespeicherten Parametern parametrieren.