EP6224 - IO-Link-Master in Schutzart IP67
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
1.1.0
▪
Power-Anschluss aktualisiert
1.0.0
▪
Erste Veröffentlichung
0.6
▪
Korrekturen
0.5
▪
Erste vorläufige Version
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der IO-Link-Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer):
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


EtherCAT Box - Einführung

EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Hinweis
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
Hinweis
XML-Dateien
XML-Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Modulübersicht EP6224
•
EP6224


Modulübersicht EP6224

Produktübersicht [image] Modulübersicht EP6224
Modulübersicht EP6224
IO-Link Master
Modul | Signalanschluss | IO-Link Schnittstellen | Spezifikationsversion | Kommentar
EP6224-2022 | 4 x M12 | 4 | IO-Link V1.1, Class A | breites Gehäuse
EP6224-3022 | 4 x M12 | 4 | IO-Link V1.1, Class B | breites Gehäuse


EP6224

Produktübersicht [image] EP6224
EP6224
Weiterführende Informationen
•
EP6224-x022- Einführung
•
EP6224-x022- Technische Daten
•
EP6224-x022- Prozessabbild


EP6224-x022- Einführung

Produktübersicht [image] EP6224 [image] EP6224-x022- Einführung
EP6224-x022- Einführung
EP6224-2022
EP6224-3022
IO-Link Master
Das IO-Link-Modul EP6224 ermöglicht den Anschluss von bis zu vier IO-Link-Teilnehmern, den sogenannten IO-Link-Devices. Dies können Aktoren, Sensoren, Kombinationen aus beiden oder die Beckhoff EPIxxxx-Module sein. Die Verbindung zwischen dem Modul und dem Teilnehmer erfolgt als Punkt-zu-Punkt-Verbindung. IO-Link ist als intelligentes Bindeglied zwischen der Feldbusebene und dem Sensor angelegt, wobei Parametrierungsinformationen über die IO-Link-Verbindung bidirektional ausgetauscht werden können. Die Parametrierung der IO-Link-Devices mit Servicedaten kann aus TwinCAT heraus über ADS oder im System Manager erfolgen.
In der Standardeinstellung arbeitet die EP6224 als 4-Kanal-Eingangsmodul, 24 V DC, das bei Bedarf mit angeschlossenen IO-Link-Devices kommuniziert, sie parametriert und ggf. in der Betriebsart umstellt. Beckhoff bietet mit der EP6224-2022 einen Class A Master und mit der EP6224-3022 einen Class B Master an.
Quick Links
Abmessungen
Inbetriebnahme/Konfiguration IO-Link Master


EP6224-x022- Technische Daten

Produktübersicht [image] EP6224 [image] EP6224-x022- Technische Daten
EP6224-x022- Technische Daten
Technische Daten | EP6224-2022 | EP6224-3022
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Datenübertragungsrate | 4,8 kBaud (COM 1), 38,4 kBaud (COM 2), 230,4 kBaud (COM 3)
IO-Link-Anschluss | 1 x M12 Buchse, a-kodiert
IO-Link Schnittstellen | 4
Spezifikationsversion | IO-Link V1.1, Class A | IO-Link V1.1, Class B
Nennspannung Eingänge | 24 VDC (-15%/+20%)
Kabellänge (IO-Link) | max. 20 m
Sensorversorgung | 24 V DC, 1,4 A, für alle 4 Ports, Port Class A | 24 V DC, 1,4 A, für alle 4 Ports, Port Class B
Stromaufnahme der Modulelektronik aus US (ohne Sensorstrom) | Typ. 130 mA + Last
Anschluss Spannungsversorgung | Einspeisung: 1 x M8-Stecker, 4-polig; Weiterleitung: 1 x M8-Buchse, 4-polig
Potenzialtrennung | 500 V
Gewicht | ca. 250 g
Zulässige Umgebungstemperatur im Betrieb | 0°C … +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C … +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE


EP6224-x022- Prozessabbild

Produktübersicht [image] EP6224 [image] EP6224-x022- Prozessabbild
EP6224-x022- Prozessabbild
Kanal 1 bis 4
Die EtherCAT-Box EP6224-x022 enthält 4 IO-Link Schnittstellen an denen jeweils ein IO-Link Device angeschlossen werden kann. In der nachfolgenden Abbildung finden Sie als Beispiel das Prozessabbild der EP6224-2022. Wird beispielweise ein digitales Eingangsmodul an den Kanal 1 angeschlossen, werden die Eingänge dieses IO-Link Devices in dem Prozessabbild unter IO Inputs Channel 1 aufgelistet.
EP6224-x022, Prozessabbild


Grundlagen der Kommunikation - EtherCAT

Grundlagen der Kommunikation - EtherCAT
Grundlagen der Kommunikation - EtherCAT
Weiterführende Informationen
•
Konfiguration mit TwinCAT – Erläuterung Karteireiter
•
Wiederherstellen des Auslieferungszustandes von einem EtherCAT-Gerät
•
EtherCAT State Machine


Konfiguration mit TwinCAT – Erläuterung Karteireiter

Grundlagen der Kommunikation - EtherCAT [image] Konfiguration mit TwinCAT – Erläuterung Karteireiter
Konfiguration mit TwinCAT – Erläuterung Karteireiter
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der IO-Link Box die Sie konfigurieren möchten.
Baumzweig der zu konfigurierende IO-Link-Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der IO-Link Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des IO-Link-Masters
Id | Laufende Nr. des IO-Link-Masters
Typ | Typ des IO-Link-Masters
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie den IO-Link-Master deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf den IO-Link-Master zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des IO-Link Masters
Product/Revision | Produkt- und Revisions-Nummer des IO-Link Masters
Auto Inc Adr. | Auto-Inkrement-Adresse des IO-Link Masters. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät oder jeden IO-Link Master anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der IO-Link Master die Adressen an die EtherCAT-Geräte oder weitere IO-Link Master vergibt. Bei der Auto-Inkrement-Adressierung hat das erste EtherCAT-Gerät im Ring die Adresse 0000hex und für jedes weitere wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Gerätes/IO-Link-Masters. Diese Adresse wird vom EtherCAT-Gerät/IO-Link Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts/IO-Link-Masters, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte/IO-Link-Master im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät oder den IO-Link Master auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses IO-Link Masters.
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des IO-Link Masters werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der IO-Link Master es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn der IO-Link Master eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung des System-Managers als Variablen des IO-Link-Masters angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Hinweis
Aktivierung der PDO-Zuordnung
•
Den IO-Link Master einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen lassen (siehe Karteireiter Online)
•
den System-Manager des IO-Link-Masters neu laden (Schaltfläche [image])
PDO-Liste
Liste aller von diesem IO-Link Master unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen IO-Link-Mastern unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in dem Karteireiter Startup betrachtet werden.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der IO-Link-Master eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Master gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der während des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der IO-Link-Master das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Masters auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen IO-Link-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Gerätes enthaltenen Objekte über SDO-Information aus dem Master hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Diag History
Über den Karteireiter "Diag History" können geloggte Diagnose-Meldungen vom Controller Protokoll ausgelesen werden. Der Diagnosepuffer arbeitet als Ringpuffer mit einer derzeitigen Größe von max. 1000 Einträgen.
Karteireiter Diag History
Karteireiter Diag History
Die möglichen Fehler sind in drei Arten gruppiert:
▪
Info: z.B. Informationen zum Verbindungsaufbau
▪
Warning: z.B. PROFINET Diagnose Alarme
▪
Error: z.B. Verbindungsabbruch
Über "AddInfo" wird angezeigt, ob zusätzliche Informationen zu dem Ereignis vorliegen. Ist dieses mit "Yes" gekennzeichnet, wird durch ein Klicken auf die entsprechende Meldung die Zusatzinformation abgeholt und angezeigt. Handelt es sich um einen Diagnosealarm ("Diagnosis appears") so können auf den entsprechenden Ebenen (Gerät, API oder Modul) die genauen Diagnoseinformationen abgeholt werden.
Über den Button "Clear Diag History" wird der komplette Diagnosepuffer geleert.
Über den Button "Export Diag History" besteht die Möglichkeit, die angezeigten Meldungen in einem .TXT-File abzuspeichern
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht den IO-Link-Master auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht den IO-Link-Master auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht den IO-Link-Master auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht den IO-Link-Master auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht den IO-Link-Master auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein IO-Link-Master beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein IO-Link-Master ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Master nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des IO-Link-Masters an.
Angeforderter Status | Zeigt den für den IO-Link-Master angeforderten Status an.


Wiederherstellen des Auslieferungszustandes von einem EtherCAT-Gerät

Grundlagen der Kommunikation - EtherCAT [image] Wiederherstellen des Auslieferungszustandes von einem EtherCAT-Gerät
Wiederherstellen des Auslieferungszustandes von einem EtherCAT-Gerät
Um den Auslieferungszustand der Backup-Objekte von der EP6224-xxxx (IO-Link Master) wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoEObjekt „Restore default parameters“, „Subindex 001“ angewählt werden (siehe nachfolgende Abbildung).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf „SubIndex 001“ gelangen Sie in den „Set Value Dialog“ (siehe nachfolgende Abbildung). Tragen Sie im Feld „Dec“ den Wert 1684107116 oder alternativ im Feld „Hex“ den Wert 0x64616F6C ein und bestätigen Sie mit OK. Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog


EtherCAT State Machine

Grundlagen der Kommunikation - EtherCAT [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand. Die Inputdaten werden aber zyklisch aktualisiert.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


Grundlagen IO-Link

Grundlagen IO-Link
Grundlagen IO-Link
IO-Link stellt ein Kommunikationssystem zur Anbindung intelligenter Sensoren und Aktoren an ein Automatisierungssystem in der Norm IEC 61131-9 unter der Bezeichnung "Single-drop digital communication interface for small sensors and actuators" (SDCI) dar.
Sowohl die elektrischen Anschlussdaten als auch das Kommunikationsprotokoll sind standardisiert und in der IO-Link Spezifikation zusammengefasst.
Hinweis
Spezifikation IO-Link
Die Entwicklung der EP6224-xxxx unterlag der IO-Link Spezifikation 1.1. Zum Zeitpunkt der Erstellung dieser Dokumentation geht die IO-Link Spezifikation in die IEC-Normung ein und wird als IEC 61131-9 in erweiterter Form übernommen. Dabei wird auch die neue Bezeichnung SDCI eingeführt. Beckhoff unterstützt als Teilnehmer in den entsprechenden Gremien die Entwicklung von IO-Link und bildet Spezifikationsänderungen in seinen Produkten ab.
Ein IO-Link System besteht aus einem IO-Link Master, einem oder mehreren IO-Link Devices und Sensoren oder Aktoren. Der IO-Link Master stellt die Schnittstelle zur überlagerten Steuerung zur Verfügung und steuert die Kommunikation mit den angeschlossenen IO-Link Devices. Das Beckhoff IO-Link Mastermodul EP6224-xxxx besitzt vier IO-Link-Ports, an dem je ein IO-Link-Device angeschlossen werden kann. IO-Link stellt daher keinen Feldbus dar, sondern ist eine Peer-to-Peer Verbindung (siehe nachfolgende Abbildung).
IO-Link Übersicht: Peer-to-Peer Kommunikation
Die angeschlossenen IO-Link Devices besitzen individuelle Parameterinformationen, die während des automatischen Scannens mit TwinCAT erkannt und im System Manager übernommen werden. Offline können modulspezifische Informationen in Form einer IO-Link Device Description (IODD) eingelesen und in TwinCAT übernommen werden.
Parameter Datenaustausch
Ein intelligenter IO-Link Sensor/Aktuator (in der vorherigen Abbildung mit „Sensor (IO-Link Device)“ gekennzeichnet) kann eine Parametrierung durch SPDU (Service Protocol Data Units) unterstützen. Diese azyklischen Servicedaten müssen von der SPS explizit angefragt oder, als solche gekennzeichnet, gesendet werden.
Hinweis
Zugang SPDU
TwinCAT unterstützt den Zugriff über ADS und über das EP6224-xxxx CoE-Verzeichnis.
Über den sogenannten SPDU Index wird der entsprechende Parameter adressiert, verfügbar sind die Bereiche:
Bezeichnung | Bereich Index
System | 0x00..0x0F
Identification | 0x10..0x1F
Diagnostic | 0x20..0x2F
Communication | 0x30..0x3F
Prefered Idnex | 0x40..0xFE
Extended Index | 0x0100..0x3FFF
 | der Bereich 0x4000..0xFFFF ist reserviert
Die Nutzung der Implementierung dieser Bereiche obliegt dem Sensor/Aktor-Hersteller. Zur Verdeutlichung sehen Sie hier nur einige mögliche Indexe mit Bezeichnung aufgeführt, sehen Sie sich dazu das entsprechende Kapitel „Objektbeschreibung und Parametrierung“ an.
Index | Name
0010 | Vendor Name
0011 | Vendor Text
0012 | Product Name
0013 | Product ID
0015 | Serial Number
0016 | Hardware Revision
0017 | Firmware Revision
... | ...


Montage und Anschluss

Montage und Anschluss
Montage und Anschluss
Weiterführende Informationen
•
Montage
•
EtherCAT
•
IO-Link
•
Spannungsversorgung


Montage

Montage und Anschluss [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anzugsmomente für Steckverbinder


Abmessungen

Montage und Anschluss [image] Montage [image] Abmessungen
Abmessungen
Abmessungen der EtherCAT-Box-Module
Alle Maßangaben sind in Millimeter angegeben.
Gehäuseeigenschaften
EtherCAT Box | Schmales Gehäuse | Breites Gehäuse
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyuhrethan
Montage | zwei Befestigungslöcher Ø 3 mm für M3 | zwei Befestigungslöcher Ø 3 mm für M3 zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm
Gewicht | ca. 125 g, je nach Modultyp | ca. 250 g, je nach Modultyp


Befestigung

Montage und Anschluss [image] Montage [image] Befestigung
Befestigung
Hinweis
Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung! Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind! Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.
Module mit schmalem Gehäuse werden mit zwei M3-Schrauben montiert.
Module mit breitem Gehäuse werden mit zwei M3-Schrauben an den in den Ecken angeordneten oder mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern montiert.
Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher der Module besitzen kein Gewinde.
Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.
Montageschiene ZS5300-0001
Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module.
Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3-Gewinden. Die Schiene hat 5,3 mm Langlöcher um sie mit M5-Schrauben an der Maschine zu befestigen.
Montageschiene ZS5300-0001
Die Montageschiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 schmalen Modulen. Sie kann applikationsspezifisch gekürzt werden.
Montageschiene ZS5300-0011
Die Montageschiene ZS5300-0011 (500 mm x 129 mm) bietet neben den M3- auch vorgefertigte M4-Gewinde zur Befestigung der 60 mm breiten Module über deren mittlere Bohrungen.
Bis zu 14 schmale oder 7 breite Module können gemischt montiert werden.


Anzugsmomente für Steckverbinder

Montage und Anschluss [image] Montage [image] Anzugsmomente für Steckverbinder
Anzugsmomente für Steckverbinder
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen.
EtherCAT Box mit M8-Steckverbindern
M12-Steckverbinder
Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.
EtherCAT Box mit M8- und M12-Steckverbindern
7/8"-Steckverbinder
Es wird empfohlen die 7/8"-Steckverbinder mit einem Drehmoment von 1,5 Nm festzuziehen.
7/8"-Steckverbinder
Drehmomentschlüssel
Drehmomentschlüssel ZB8801
Hinweis
Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (siehe Zubehör)!


EtherCAT

Montage und Anschluss [image] EtherCAT
EtherCAT
Weiterführende Informationen
•
EtherCAT-Anschluss
•
EtherCAT-LEDs


EtherCAT-Anschluss

Montage und Anschluss [image] EtherCAT [image] EtherCAT-Anschluss
EtherCAT-Anschluss
Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt
▪
die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
▪
die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8, 30 mm Gehäuse
EtherCAT Box: M860 mm Gehäuse (am Beispiel EP9214)
Koppler Box: M12
Belegung
Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.
Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm
1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003
2) Aderfarben nach EN 61918
3) Aderfarben
Hinweis
Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)
Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx, also die mit M8-Steckverbindern vorkonfektionierten Leitungen auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau). Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!
EtherCAT-Steckverbinder
Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.
Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12-Stecker | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, für Gigabit-Ethernet geeignet
ZS1090-0006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar, für ZB903x Kabel
ZS1090-0007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar, für ZB903x Kabel
ZS1090-1006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar bis OD = 6.5 mm
ZS1090-1007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar bis OD = 6.5 mm


EtherCAT-LEDs

Montage und Anschluss [image] EtherCAT [image] EtherCAT-LEDs
EtherCAT-LEDs
EtherCAT-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational
Hinweis
EtherCAT-Stati
Die verschiedenen Stati, die eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.


IO-Link

Montage und Anschluss [image] IO-Link
IO-Link
Weiterführende Informationen
•
Anschluss IO-Link Master


Anschluss IO-Link Master

Montage und Anschluss [image] IO-Link [image] Anschluss IO-Link Master
Anschluss IO-Link Master
IO-Link Schnittstelle
In der IO-Link-Spezifikation sind verschiedene IO-Link-Anschlussbelegungen festgelegt, auf die im nachfolgenden Teil eingegangen wird.
Port Class A (Typ A): Die Funktion von Pin 2 und Pin 5 ist nicht vorgegeben. Der Hersteller kann Pin 2 mit einem zusätzlichen Digitalkanal belegen. Bei dem Class A Master/Device von Beckhoff ist der Pin 2 nicht belegt.
Anschlussbelegung IO-Link Device_Beckhoff
Anschlussbelegung Port Class A
Port Class B (Typ B): Für Devices mit erhöhtem Strombedarf wird über Pin 2 und Pin 5 eine zusätzliche Spannungsversorgung zur Verfügung gestellt.
Anschlussbelegung Port Class B IO-Link
Anschlussbelegung Port Class B
Die Schalt- und Kommunikationsleitung ist mit (C/Q) gekennzeichnet.
Beckhoff bietet einen Master in Class A- Ausführung (EP6224-2022) und einen Master in Class B- Ausführung (EP6224-3022) an.
Für den abgehenden IO-Link-Anschluss verfügt der IO-Link Master (EP6224-xxxx) über eine a-kodierte M12-Buchse.
IO-Link-Anschluss, Master
Aderfarben
Die Aderfarben des IO-Link Kabels mit der dazugehörigen Pinbelegung des IO-Link Steckverbinders:
Pin | Aderfarbe
1 | braun
2 | weiß
3 | blau
4 | schwarz
5 | grau
IO-Link-Kabel
Beispiel IO-Link Kabel: Stecker auf Buchse
Die von Beckhoff lieferbaren Kabel für das IO-Link-System finden Sie unter dem folgenden Link unter dem Punkt „Zubehör“: http://beckhoff.de/default.asp?fieldbus_box/data_sheets.htm?id=69033899254355
Hinweis
IO-Link Kabel
Für Class A Master/Devices von Beckhoff ist ein 3-adriges IO-Link Kabel ausreichend. Ein Class B Master/Device benötigt ein 5-adriges IO-Link Kabel.


Spannungsversorgung

Montage und Anschluss [image] Spannungsversorgung
Spannungsversorgung
Weiterführende Informationen
•
Power-Anschluss
•
Status-LEDs für die Spannungsversorgung
•
Leitungsverluste M8


Power-Anschluss

Montage und Anschluss [image] Spannungsversorgung [image] Power-Anschluss
Power-Anschluss
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:
▪
IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
▪
OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen
EtherCAT Box, Anschlüsse für die Versorgungsspannungen
Pinbelegung M8, Power In und Power Out
Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*
Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.
Zwei LEDs zeigen den Status der Versorgungsspannungen an.
Achtung
Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!
Steuerspannung Us: 24 VDC
Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.
Peripheriespannung Up: 24 VDC
Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Achtung
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Versorgung über PowerBox Module EP92x4-0023
Benötigt die Maschine größere Ströme oder sind die EtherCAT Box Module weit vom Schaltschrank und der darin befindlichen Spannungsversorgung entfernt installiert, so empfiehlt sich der Einsatz der vierkanaligen Powerverteilungsmodule EP9214 oder EP9224 (mit integriertem Data Logging, siehe www.beckhoff.de/EP9224).
Mit diesen Modulen lassen sich intelligente Powerverteilungskonzepte mit bis zu 2 x 16 A und maximal 2,5 mm² Leitungsquerschnitt im Feld realisieren.
EP92x4-0023, Anschlüsse Power In und Power Out
Pinbelegung 7/8“, Power IN und Power Out
Galvanische Trennung
Digitale Module
Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) ggfs. miteinander verbunden!
Überprüfen Sie dies in der Dokumentation jeder verwendeten EtherCAT Box.
Analoge Module
Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.
Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z.B. bei 0 bis 10 V Eingängen eine beliebige Referenzspannung (0 bis 30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z.B. geglättete 10 V für Messpotentiometer).
Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.
Achtung
Galvanische Trennung kann aufgehoben werden!
Wenn Sie unterschiedliche EtherCAT Boxen direkt über vierpolige Powerleitungen verbinden, so kann die galvanische Trennung der Analogsignale u.U. nicht mehr gegeben sein!


Status-LEDs für die Spannungsversorgung

Montage und Anschluss [image] Spannungsversorgung [image] Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
LED-Anzeigen
LED | Anzeige | Bedeutung
Us (Steuerspannung) | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung Us erzeugte Sensorversorgung für alle daraus gespeisten Sensoren abgeschaltet.
Up (Peripheriespannung) | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


Leitungsverluste M8

Montage und Anschluss [image] Spannungsversorgung [image] Leitungsverluste M8
Leitungsverluste M8
Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
Leitungsverluste auf den Powerkabeln
Beispiel
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.
Hinweis
Powerverteilungs-Module EP92x4-0023
Mit den Powerverteilungs-Modulen EP9214 und EP9224 sind intelligente Spannungsverteilungskonzepte verfügbar. Weitere Information finden sie unter www.beckhoff.de/EP9224


Verkabelung

Verkabelung
Verkabelung
Weiterführende Informationen
•
Verkabelung EtherCAT
•
Verkabelung IO-Link


Verkabelung EtherCAT

Verkabelung [image] Verkabelung EtherCAT
Verkabelung EtherCAT
Eine Auflistung der EtherCAT-Kabel, Powerkabel, Sensorkabel, Ethernet-/EtherCAT-Steckverbinder sowie feldkonfektionierbare Steckverbinder finden Sie unter dem folgenden Link: http://download.beckhoff.com/download/document/catalog/main_catalog/german/Beckhoff_EtherCAT-Box-Zubehoer.pdf
Die dazugehörigen Datenblätter finden Sie unter dem folgenden Link: http://beckhoff.de/german/fieldbus_box/data_sheets.htm?id=69033899254355
EtherCAT-Kabel
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
Hinweis
Empfehlungen zur Verkabelung
Detailliert Empfehlungen zur Verkabelung von EtherCAT können Sie der Dokumentation "Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet" entnehmen, die auf www.beckhoff.de zum Download zur Verfügung steht.
EtherCAT nutzt vier Adern der Kabel für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie gekreuzte Kabel (Cross-Over) verwenden.
Powerkabel


Verkabelung IO-Link

Verkabelung [image] Verkabelung IO-Link
Verkabelung IO-Link
Eine Auflistung der EtherCAT-Kabel, Powerkabel, Sensorkabel, IO-Link-Kabel, Ethernet-/EtherCAT-Steckverbinder sowie feldkonfektionierbare Steckverbinder finden Sie unter dem folgenden Link: http://download.beckhoff.com/download/document/catalog/main_catalog/german/Beckhoff_EtherCAT-Box-Zubehoer.pdf
Die dazugehörigen Datenblätter finden Sie unter dem folgenden Link: http://beckhoff.de/german/fieldbus_box/data_sheets.htm?id=69033899254355
IO-Link-Kabel
Der IO-Link Master wird über ein ungeschirmtes, maximal 20 m langes, 3-adriges (Typ A) oder 5-adriges (Typ B) Kabel mit dem IO-Link Device verbunden. Die IO-Link Kabel sind als gerade und abgewinkelte Variante verfügbar. Weitere Informationen zu dem IO-Link Anschluss finden Sie unter: Anschluss IO-Link Master
Beispiel IO-Link-Kabel: Stecker auf Buchse
Sensorkabel
Auswahl der von Beckhoff lieferbaren Sensorkabel


UL-Anforderungen

UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
VORSICHT
VORSICHT!
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


ATEX-Hinweise

ATEX-Hinweise
ATEX-Hinweise
Weiterführende Informationen
•
ATEX - Besondere Bedingungen
•
BG2000-0000 - Schutzgehäuse für EtherCAT Box
•
ATEX-Dokumentation


ATEX - Besondere Bedingungen

ATEX-Hinweise [image] ATEX - Besondere Bedingungen
ATEX - Besondere Bedingungen
WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen – Richtlinie 94/9/EG!
•
Die zertifizierten Komponenten sind mit dem Schutzgehäuse BG2000-0000 zu errichten, das einen Schutz gegen mechanische Gefahr gewährleistet!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie beim Einsatz von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten EtherCAT-Box-Module tragen folgende Kennzeichnung:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
oder
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch-Nummer (D-Nummer)
Die EtherCAT-Box-Module tragen eine Batch-Nummer (D-Nummer), die wie folgt aufgebaut ist:
D: KW JJ FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


BG2000-0000 - Schutzgehäuse für EtherCAT Box

ATEX-Hinweise [image] BG2000-0000 - Schutzgehäuse für EtherCAT Box
BG2000-0000 - Schutzgehäuse für EtherCAT Box
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
ATEX
Das Schutzgehäuse BG2000-0000 wird über eine einzelne EtherCAT Box montiert, um die Einhaltung der besonderen Bedingungen gemäß ATEX zu erfüllen.
Installation
Schieben Sie die Anschlussleitungen für EtherCAT, Spannungsversorgung und die Sensoren/Aktoren durch die Öffnung des Schutzgehäuses BG2000-0000.
BG2000-0000, Anschlussleitungen durchschieben
Schrauben Sie die Anschlussleitungen für die EtherCAT, Spannungsversorgung und die Sensoren/Aktoren an der EtherCAT Box fest.
BG2000-0000, Anschlussleitungen festschrauben
Montieren Sie das Schutzgehäuses BG2000-0000 über der EtherCAT Box.
BG2000-0000, Schutzgehäuse montieren


ATEX-Dokumentation

ATEX-Hinweise [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweis
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX) die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Inbetriebnahme/Konfiguration

Inbetriebnahme/Konfiguration
Inbetriebnahme/Konfiguration
Weiterführende Informationen
•
IO-Link Master
•
Objektbeschreibung und Parametrierung


IO-Link Master

Inbetriebnahme/Konfiguration [image] IO-Link Master
IO-Link Master
Weiterführende Informationen
•
Konfigurationserstellung TwinCAT - Manuell (Master)
•
Konfigurationserstellung TwinCAT - Online scan (Master)


Konfigurationserstellung TwinCAT - Manuell (Master)

Inbetriebnahme/Konfiguration [image] IO-Link Master [image] Konfigurationserstellung TwinCAT - Manuell (Master)
Konfigurationserstellung TwinCAT - Manuell (Master)
In diesem Teil der Dokumentation wird die manuelle Konfiguration des IO-Link Masters in TwinCAT beschrieben.
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, Box-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden (wie nachfolgend unter Konfigurationserstellung TwinCAT - Manuell (Device) beschrieben ist). Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang. In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Geräte der Konfiguration entsprechen. Dieser Test kann in den erweiterten Device-Einstellungen parametriert werden.
Damit die aktuellsten Features/Einstellungen des Masters genutzt werden können, sollte immer die aktuellste ESI-Datei heruntergeladen werden. Beachten Sie bitte deshalb den nachfolgenden Hinweis.
Hinweis
Installation der neusten ESI-XML-Device-Description
Der TwinCAT Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Die Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten (http://www.beckhoff.de/german/default.htm?download/elconfg.htm). Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen. TwinCAT bringt bei der Installation die Beckhoff-ESI-Dateien mit, die zum Erstellungszeitpunkt des TwinCAT builds aktuell waren. Ab TwinCAT 2.11 und in TwinCAT 3 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (TwinCAT → EtherCAT-Devices → Update Device Description…) Update EtherCAT Device Description
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Anfügen eines neuen E_A Gerätes
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Auswahl eines Gerätes (EtherCAT)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Anfügen einer neuen Box
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z.B.: EP6224-2022), bestätigen Sie mit OK.
Auswahl einer Box
Auswahl einer Box (z.B.: EP6224-2022)
Angefügte Box im TwinCAT Baum
Angefügte Box im TwinCAT-Baum
Konfiguration des IO-Link Masters
Zur Konfiguration des IO-Link Masters wird ein PlugIn benötigt, das im Regelfall mit der TwinCAT Installation geliefert wird. Beim Anfügen des IO-Link Masters (siehe Kapitel Inbetriebnahme/Konfiguration) im TwinCAT System Manager wird ein zusätzlicher Karteireiter namens IO-Link angelegt (siehe nachfolgende Abbildung). Sollte der Karteireiter nicht angezeigt werden, fehlt die entsprechende System Manager Extension. Diese kann von der Beckhoff Downloadseite heruntergeladen und nachinstalliert werden http://beckhoff.de/default.asp?download/elconfg.htm?id=71003277100532.
Karteireiter "IO-Link"


Konfigurationserstellung TwinCAT - Online scan (Master)

Inbetriebnahme/Konfiguration [image] IO-Link Master [image] Konfigurationserstellung TwinCAT - Online scan (Master)
Konfigurationserstellung TwinCAT - Online scan (Master)
In diesem Teil der Dokumentation wird die Konfiguration eines physisch vorhandenen IO-Link Masters in TwinCAT beschrieben.
Online Konfigurationserstellung „Scannen“ (TwinCAT 3.x)
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, Box-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden (wie nachfolgend unter Konfigurationserstellung TwinCAT - Manuell (Device) beschrieben ist). Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang. In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Geräte der Konfiguration entsprechen. Dieser Test kann in den erweiterten Device-Einstellungen parametriert werden.
Damit die aktuellsten Features/Einstellungen des Masters genutzt werden können, sollte immer die aktuellste ESI-Datei heruntergeladen werden. Beachten Sie bitte deshalb den nachfolgenden Hinweis.
Hinweis
Installation der neusten ESI-XML-Device-Description
Der TwinCAT Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Die Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten (http://www.beckhoff.de/german/default.htm?download/elconfg.htm). Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen. TwinCAT bringt bei der Installation die Beckhoff-ESI-Dateien mit, die zum Erstellungszeitpunkt des TwinCAT builds aktuell waren. Ab TwinCAT 2.11 und in TwinCAT 3 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (TwinCAT → EtherCAT-Devices → Update Device Description…) Update EtherCAT Device Description
Zur Konfigurationserstellung
▪
muss die reale EtherCAT- und IO-Link-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
die Geräte/Module müssen über EtherCAT-Kabel und IO-Link-Kabel so verbunden sein wie sie später eingesetzt werden sollen.
▪
die Geräte/Module müssen mit Energie versorgt werden und kommunikationsbereit sein.
▪
TwinCAT muss auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer- Dieser Schritt kann auch unabhängig vom vorherigen Schritt durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.
Erkennen/Scan des EtherCAT Geräts
Befindet sich das TwinCAT-System im Config-Modus (TwinCAT Icon blau bzw. blaue Anzeige im Systemmanager) kann online nach Geräten gesucht werden.
TwinCAT Anzeige Config-Modus
Hinweis
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich.
Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten. Das TwinCAT-Icon neben der Windows-Uhr stellt immer den TwinCAT-Modus des lokalen IPC dar. Im Systemmanager-Fenster wird dagegen der TwinCAT-Zustand des Zielsystems gezeigt.
TwinCAT target und local System
Im Konfigurationsbaum bringt Sie ein Rechtsklick auf den Punkt „I/O Devices“ zum Such-Dialog.
Scan Devices
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer Gerätescan
Hinweis automatischer Gerätescan
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Gerät angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
erkannte Ethernet-Geräte
Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen (siehe nachfolgende Abbildung).
Erkennen/Scan der EtherCAT Teilnehmer
Hinweis
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Information des EtherCAT Devices aus dem Device-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan for Boxes
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes
Die Konfiguration wurde aufgebaut und direkt in den Online-Zustand (OPERATIONAL) versetzt. Das EtherCAT System sollte sich in einem funktionsfähigen zyklischen Betrieb, wie in der nachfolgenden Abbildung dargestellt, befinden.
beispielhafte Online-Anzeige
Zu beachten sind:
▪
Alle Boxen sollten im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Wie in der nachfolgenden Abbildung sichtbar, wird der angeschlossene IO-Link Master (EP6224-3022) im TwinCAT Baum angezeigt.
Master-Anzeige_Nach Scan for Boxes
Master-Anzeige nach „Scan for boxes“
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Device für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der Systemmanager an, die im Gerät eventuell vorliegende ESI auszulesen.
▪
Teilnehmer werden nicht richtig erkannt
Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Device hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z.B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Scan über bestehender Konfiguration
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Configuration is identical
Identische Konfiguration
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Beispiel-Korrekturdialog
Es wird empfohlen das Häkchen „Extended Information“ zu setzen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe | Erläuterung
grün | dieses EtherCAT Device findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau | dieses EtherCAT Device ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich. Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau | dieses EtherCAT Device wird ignoriert (Button "Ignore")
rot | dieses EtherCAT Device ist auf der Gegenseite nicht vorhanden.
Hinweis
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Device/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/Boxen ist anzunehmen:
Geräte-Revision in der Anlage >= Geräte Revision in der Konfiguration
Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich). Beispiel: In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1019 oder höher (-1020, -1021) eingesetzt werden.
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Beispiel-Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch „OK“ in die reale *.tsm-Konfiguration übernommen werden.


Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
Hinweis
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen zu installieren.
Hinweis
Parametrierung
Die Parametrierung der Klemme/Box wird über den CoE – Online Reiter (mit Doppelklick auf das entsprechende Objekt, s.u.) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind.
▪
Objekte die zum regulären Betrieb z.B. durch ADS-Zugriff bestimmt sind.
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind.
▪
Profilspezifische Objekte, die allgemeine Statusanzeigen und Stati der Ein- und Ausgänge darstellen.
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Objekte für die Inbetriebnahme
Index 1011 Restore default parameters
Index | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 80n0 IO Settings Ch. 1 – 4 (für 0 ≤ n ≤ 3)
Index | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | IO Settings | Max. Subindex | UINT8 | RO | 0x28 (40dez)
80n0:04 | Device ID | Die Device ID dient zur Validierung eines IO-Link Gerätes. | UINT32 | RW | 0x00000000 (0dez)
80n0:05 | VendorID | Die Vendor ID dient zur Validierung des Herstellers vom IO-Link Gerät. | UINT32 | RW | 0x00000000 (0dez)
80n0:07 | IO-Link Revision | Kennzeichnung der Version der Spezifikation, nach der das IO-Link Gerät kommuniziert. Bit 0-3: MinorRev Bit 4-7: MajorRev | UNIT8 | RW | 0x00 (0dez)
80n0:20 | FrameCapability | Der Frame Capability kennzeichnet bestimmte Funktionalitäten des IO-Link Gerätes (wie z.B.: SPDU supported). Bit 0: SPDU Bit 1: Type1 Bit 7: PHY1 | UINT8 | RW | 0x00 (0dez)
80n0:21 | Min cycle time | Die Cycle Time entspricht der Zykluszeit, mit der der IO-Link Master das IO-Link Gerät ansprechen soll. Dieser Wert wird in der IO-Link Format für Min Cycle Time übertragen. Bit 6 und 7: Time Base Bit 0 bis 5: Multiplier | UINT8 | RW | 0x00 (0dez)
80n0:22 | Offset time | reserviert | UINT8 | RW | 0x00 (0dez)
80n0:23 | Process data in length | Diese Parameter werden im IO-Link Format für "Process data in length" übertragen. Bit 7: BYTE (zeigt an, ob der Wert in LENGTH als Bitlänge [Bit nicht gesetzt] oder als Bytelänge + 1 [Bit gesetzt] interpretiert wird Bit 6: SIO (zeigt an, ob das Gerät den Standard IO-Modus unterstützt [Bit gesetzt]) Bit 0 bis 4: LENGTH (Länge der Prozessdaten) | UINT8 | RW | 0x00 (0dez)
80n0:24 | Process data out length | Diese Parameter werden im IO-Link Format für "Process data out length" übertragen. Bit 7: BYTE (zeigt an, ob der Wert in LENGTH als Bitlänge [Bit nicht gesetzt] oder als Bytelänge + 1 [Bit gesetzt] interpretiert wird Bit 6: SIO (zeigt an, ob das Gerät den Standard IO-Modus unterstützt [Bit gesetzt]) Bit 0 bis 4: LENGTH (Länge der Prozessdaten) | UINT8 | RW | 0x00 (0dez)
80n0:26 | Compatible ID | reserviert | UINT16 | RW | 0x0000 (0dez)
80n0:27 | Reserved | reserviert | UINT16 | RW | 0x0000 (0dez)
80n0:28 | Master Control | 0: IO-Link Port inaktiv 1: IO-Link Port als Digital Input Port 2: IO-Link Port als Digital Output Port 3: IO-Link Port in Kommunikation über das IO-Link Protokoll 4: IO-Link Port in Kommunikation über das IO-Link Protokoll. IO-Link State ist ComStop (keine zyklische Kommunikation, nur auf Bedarf werden Daten ausgetauscht). | UINT16 | RW | 0x0000 (0dez)
Objekte für den regulären Betrieb
Die EP6224 verfügt über keine solchen Objekte.
Vollständige Übersicht
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x184C1389 (407638921dez)
Index 1008 Device name
Index | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP6224-xxxx
Index 1009 Hardware version
Index | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 100A Software version
Index | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x18503052 (407908434dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 IO RxPDOPDO-Map Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | IO RxPDOPDO-Map Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RW | 0x01 (1dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1601 IO RxPDOPDO-Map Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | IO RxPDOPDO-Map Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RW | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1602 IO RxPDOPDO-Map Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | IO RxPDOPDO-Map Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RW | 0x01 (1dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1603 IO RxPDOPDO-Map Ch.4
Index | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | IO RxPDOPDO-Map Ch.4 | PDO Mapping RxPDO 4 | UINT8 | RW | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A00 IO TxPDOPDO-Map Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | IO TxPDOPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RW | 0x01 (1dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A01 IO TxPDOPDO-Map Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | IO TxPDOPDO-Map Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RW | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A02 IO TxPDOPDO-Map Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | IO TxPDOPDO-Map Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RW | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A03 IO TxPDOPDO-Map Ch.4
Index | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | IO TxPDOPDO-Map Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RW | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A04 TxPDOeState TxPDO-Map Device
Index | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | TxPDOeState TxPDO-Map Device | PDO Mapping TxPDO 5 | UINT8 | RW | 0x04 (4dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x01 (State Ch1)) | UINT32 | RW | 0xF100:01, 8
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x02 (State Ch2)) | UINT32 | RW | 0xF100:02, 8
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x03 (State Ch3)) | UINT32 | RW | 0xF100:03, 8
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x04 (State Ch4)) | UINT32 | RW | 0xF100:04, 8
Index 1C00 Sync manager type
Index | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x04 (4dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | SubIndex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:04 | SubIndex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1603 (5635dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
1C13:05 | SubIndex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A04 (6660dez)
Index 1C32 SM output parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 | Sync mode | Aktuelle Synchronisierungsbetriebsart: 0: Free Run 1: Synchron with SM 2 Event 2: DC-Mode - Synchron with SYNC0 Event 3: DC-Mode - Synchron with SYNC1 Event | UINT16 | RW | 0x0000 (0dez)
1C32:02 | Cycle time | Zykluszeit (in ns): Free Run: Zykluszeit des lokalen Timers Synchron with SM 2 Event: Zykluszeit des Masters DC-Mode: SYNC0/SYNC1 Cycle Time | UINT32 | RW | 0x000186A0 (100000dez)
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:04 | Sync modes supported | Unterstützte Synchronisierungsbetriebsarten: Bit 0 = 1: Free Run wird unterstützt Bit 1 = 1: Synchron with SM 2 Event wird unterstützt Bit 2-3 = 01: DC-Mode wird unterstützt Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode) Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08) | UINT16 | RO | 0xC007 (49159dez)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RO | 0x000186A0 (100000dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:08 | Command | 0: Messung der lokalen Zykluszeit wird gestoppt 1: Messung der lokalen Zykluszeit wird gestartet Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert. Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt | UINT16 | RW | 0x0000 (0dez)
1C32:09 | Delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) | BOOLEAN | RO | 0x00 (0dez)
Index 1C33 SM input parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 | Sync mode | Aktuelle Synchronisierungsbetriebsart: 0: Free Run 1: Synchron with SM 3 Event (keine Outputs vorhanden) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 Event (Outputs vorhanden) | UINT16 | RW | 0x0000 (0dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x000186A0 (100000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:04 | Sync modes supported | Unterstützte Synchronisierungsbetriebsarten: Bit 0: Free Run wird unterstützt Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden) Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden) Bit 2-3 = 01: DC-Mode wird unterstützt Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden) Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden) Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08) | UINT16 | RO | 0xC007 (49159dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RO | 0x000186A0 (100000dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | wie 1C32:32 | BOOLEAN | RO | 0x00 (0dez)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 60n0 IO Inputs Ch. 1 - 4 (für 0 ≤ n ≤ 3)
Index | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | IO Inputs Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x00 (0dez)
60n0:01 | Subindex 001 | IO-Link Eingangs-Prozessdaten | - | RO | -
... | ... | ... | ... | ... | ...
60n0:10 | Subindex 016 | IO-Link Eingangs-Prozessdaten | - | RO | -
Index 70n0 IO Outputs Ch. 1 - 4 (für 0 ≤ n ≤ 3)
Index | Name | Bedeutung | Datentyp | Flags | Default
70n0:0 | IO Outputs Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x00 (0dez)
70n0:01 | Subindex 001 | IO-Link Ausgangs-Prozessdaten | - | RO | -
... | ... | ... | ... | ... | ...
70n0:10 | Subindex 016 | IO-Link Ausgangs-Prozessdaten | - | RO | -
Index 90n0 IO Info data Ch. 1 - 4 (für 0 ≤ n ≤ 3)
Index | Name | Bedeutung | Datentyp | Flags | Default
90n0:0 | IO Info data | Max. Subindex | UINT8 | RO | 0x27 (39dez)
90n0:04 | Device ID | Die Device ID dient zur Validierung eines IO-Link Gerätes. | UINT32 | RO | 0x00000000 (0dez)
90n0:05 | VendorID | Die Vendor ID dient zur Validierung des Herstellers vom IO-Link Gerät. | UINT32 | RO | 0x00000000 (0dez)
90n0:07 | IO-Link revision | Kennzeichnung der Version der Spezifikation, nach der das IO-Link Gerät kommuniziert. Bit 0-3: MinorRev Bit 4-7: MajorRev | UINT8 | RO | 0x00 (0dez)
90n0:20 | FrameCapability | Der Frame Capability kennzeichnet bestimmte Funktionalitäten des IO-Link Gerätes (wie z.B.: SPDU supported). Bit 0: SPDU Bit 1: Type1 Bit 7: PHY1 | UINT8 | RO | 0x00 (0dez)
90n0:21 | Min cycle time | Die Cycle Time entspricht der Zykluszeit, mit der der IO-Link Master das IO-Link Gerät ansprechen soll. Dieser Wert wird in der IO-Link Format für Min Cycle Time übertragen. Bit 6 und 7: Time Base Bit 0 bis 5: Multiplier | UINT8 | RO | 0x00 (0dez)
90n0:22 | Offset time | reserviert | UINT8 | RO | 0x00 (0dez)
90n0:23 | Process data in length | Diese Parameter werden im IO-Link Format für "Process data in length" übertragen. Bit 7: BYTE (zeigt an, ob der Wert in LENGTH als Bitlänge [Bit nicht gesetzt] oder als Bytelänge + 1 [Bit gesetzt] interpretiert wird Bit 6: SIO (zeigt an, ob das Gerät den Standard IO-Modus unterstützt [Bit gesetzt]) Bit 0 bis 4: LENGTH (Länge der Prozessdaten) | UINT8 | RO | 0x00 (0dez)
90n0:24 | Process data out length | Diese Parameter werden im IO-Link Format für "Process data out length" übertragen. Bit 7: BYTE (zeigt an, ob der Wert in LENGTH als Bitlänge [Bit nicht gesetzt] oder als Bytelänge + 1 [Bit gesetzt] interpretiert wird Bit 6: SIO (zeigt an, ob das Gerät den Standard IO-Modus unterstützt [Bit gesetzt]) Bit 0 bis 4: LENGTH (Länge der Prozessdaten) | UINT8 | RO | 0x00 (0dez)
90n0:26 | Reserved | reserviert | UINT16 | RO | 0x0000 (0dez)
90n0:27 | Reserved2 | reserviert | UINT16 | RO | 0x0000 (0dez)
Index A0n0 IO Diag data Ch. 1 - 4 (für 0 ≤ n ≤ 3)
Index | Name | Bedeutung | Datentyp | Flags | Default
A0n0:0 | IO Diag data Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x02 (2dez)
A0n0:01 | IO-Link State | Der Wert des IO-Link State entspricht einem State aus der IO-Link Master Statemachine 0: INACTIVE 1: DIGINPUT 2: DIGOUTPUT 3: ESTABLISHCOMM 4: INITMASTER 5: INITDEVICE 8: OPERATE 9: STOP | UINT8 | RO | 0x00 (0dez)
A0n0:02 | Lost Frames | Hier werden die Anzahl der verloren gegangenen IO-Link Telegramme mitgezählt. Dieser Wert wird bei jedem Hochlauf von IO-Link gelöscht, ansonsten immer weiter gezählt. | UINT8 | RO | 0x00 (0dez)
Index F000 Modular device profile
Index | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0004 (4dez)
Index F008 Code word
Index | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x04 (4dez)
F010:01 | SubIndex 001 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:02 | SubIndex 002 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:03 | SubIndex 003 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:04 | SubIndex 004 | - | UINT32 | RW | 0x0000184C (6220dez)
Index F100 Diagnosis Status data
Index | Name | Bedeutung | Datentyp | Flags | Default
F100:0 | Diagnosis Status data | Max. Subindex | UINT8 | RO | 0x04 (4dez)
F100:01 | State Ch1 | Statusbyte Ch. 1 | UINT8 | RO | 0x00 (0dez)
F100:02 | State Ch2 | Statusbyte Ch. 2 | UINT8 | RO | 0x00 (0dez)
F100:03 | State Ch3 | Statusbyte Ch. 3 | UINT8 | RO | 0x00 (0dez)
F100:04 | State Ch4 | Statusbyte Ch. 4 | UINT8 | RO | 0x00 (0dez)
Index F900 Info data
Index | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | Info data | Max. Subindex | UINT8 | RO | 0x09 (9dez)
F900:01 | IO-Link Version | - | UINT8 | RO | 0x10 (16dez)


Fehlerbehandlung und Diagnose

Fehlerbehandlung und Diagnose
Fehlerbehandlung und Diagnose
Weiterführende Informationen
•
Ex6224 - ADS Error Codes


Ex6224 - ADS Error Codes

Fehlerbehandlung und Diagnose [image] Ex6224 - ADS Error Codes
Ex6224 - ADS Error Codes
Beim Auftreten eines Fehlers über ADS-Zugriff auf einen IO-Link Teilnehmer werden Fehlercodes generiert.
Der Fehlercode enthält Informationen über die Fehlerkategorie, Herkunft und Instanz. Die möglichen Fehlercodes sind in der nachfolgenden Tabelle aufgeführt.
In der darauffolgenden Tabelle sind zusätzliche Informationen zu einem bestimmten Fehler aufgelistet (S_APP_DEV):
Beispiel eines AdsReturnCode
AdsReturnCode 0x80110700
80: Device Application Error (IO-Link Spec),
11: Index not Available (IO-Link Spec),
0700: General ADS Error
Error Codes (IO-Link Spec)
Type | Herkunft | Name | Kategorie | Mode | Instanz | Wert (Hi Byte, hex) | Bemerkung
PDU buffer overflow | remote | S_PDU_BUFFER | ERROR | SiNGLE SHOT | DL | 52 | Device buffer is too small for storing the complete PDU
PDU checksum error (master) | local | M_PDU_CHECK | ERROR | SiNGLE SHOT | DL | 56 | Calculated PDU checksum in master does not match actual received SPDU
PDU checksum error (device) | remote | S_PDU_CHECK | ERROR | SiNGLE SHOT | DL | 56 | Calculated PDU checksum in device does not match actual received SPDU
PDU flow control error | remote | S_PDU_FLOW | ERROR | SiNGLE SHOT | DL | 56 | Violation of flow control rule during transfer of SPDU between master and device
Illegal PDU service primitive (master) | local | M_PDU_ILLEGAL | ERROR | SiNGLE SHOT | AL | 57 | Unknown service primitive or wrong response e.g. Read Response on Write Request
Illegal PDU service primitive (device) | local / remote | S_PDU_ILLEGAL | ERROR | SiNGLE SHOT | AL | 58 | Unknown service primitive e.g. different protocol revision
Communication error | remote | COM_ERR |  | SiNGLE SHOT | unknown | 10 | Negative service response initiated by a communication error, eg. IO-Link connection interrupted
Device application error | remote | S_APP_DEV** | ERROR | SiNGLE SHOT | APP | 80 | Service PDU transferred, but not processed due to device error. See error details in Additional Code**
Additional Code** (IO-Link Spec)
Type | Wert (Lo Byte, hex) | Beschreibung
No details | 00 | Device buffer is too small for storing the complete PDU
Index not available | 11 | Calculated PDU checksum in master does not match actual received SPDU
Subindex not available | 12 | Calculated PDU checksum in device does not match actual received SPDU
Service temporarily not available | 20 | Violation of flow control rule during transfer of SPDU between master and device
Service temporarily not available, local control | 21 | Unknown service primitive or wrong response e.g. Read Response on Write Request
Service temporarily not available, device control | 22 | Unknown service primitive e.g. different protocol revision
Access denied | 23 | Negative service response initiated by a communication error, eg. IO-Link connection interrupted
Parameter value out of range | 30 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Parameter value above limit | 31 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Parameter value below limit | 32 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Interfering parameter | 40 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Application failure | 81 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Application not ready | 82 | Service PDU transferred, but not processed due to device error. See error details in Additional Code


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
IP67 Box – Zubehör


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus/EtherCAT Box und den verwendeten Metallteilen. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


IP67 Box – Zubehör

Anhang [image] IP67 Box – Zubehör
IP67 Box – Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmomentsteckschlüssel mit Ratsche für angespritzte M8-Steckverbinder
ZB8800-0001 | Ratsche für feldkonfektionierbare M8-Steckverbinder
ZB8800-0002 | Ratsche für angespritzte M12-Steckverbinder
ZB8801 | Drehmomentschlüssel einstellbar für M8 und M12 Steckverbinder
ZB8801-0001 | Wechselklinge für konfektionierte M8 Steckverbinder
ZB8801-0002 | Wechselklinge für feldkonfektionierbare M8 und konfektionierte M12 Steckverbinder
ZB8801-0003 | Wechselklinge für feldkonfektionierbare M12 Steckverbinder
Hinweis
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter http://www.beckhoff.de/german/fieldbus_box/data_sheets.htm?id=69033899254355.